Provision Orglnfo.json and AnyConnect via | SE
for Umbrella
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This document describes how to provision the Orglnfo.json profile and AnyConnect client using Identity
Services Engine (ISE) for Umbrellaintegration.

Prerequisites

Access to the Umbrella dashboard

Access to the | SE dashboard

Umbrella Module Profile (Orginfo.json)

AnyConnect Headend Deployment Package (Windows or macOS)
| SE Posture Compliance Library (Windows or macOS)

Latest I SE patch installed (to avoid Cisco bug ID CSCvz01485 )

Not Covered:

 |ISE Authentication and Authorization policies
» |ISE Client Provisioning Portal and client redirection

Preparation Steps

1. Access the Umbrella dashboard and download the Umbrella Module Profile (Orglnfo.json)
fromDeployments > Roaming Computer s > Download > Download M odule Profile.


https://tools.cisco.com/bugsearch/bug/CSCvz01485

Download Roaming Client

13294624684052

2. Download the AnyConnect Headend Deployment Package from the Cisco Software Download page,
selecting the version appropriate for your deployment.

AnyConnect Headend Deployment Package (Windows) 26-Jan-2023
anyconnect-win-4.10.06090-webdeploy-k9.pkg
Advisories [

13295068420244

AnyConnect Headend Deployment Package (Mac OS) 26-Jan-2023
anyconnect-macos-4.10.06090-webdeploy-k9.pkg
Advisories [

13295069069716

3. Download the I SE Posture Compliance Library from the Cisco Software Download page, selecting
the version appropriate for your deployment.

ISE Posture Compliance Library - Windows [/ Head-end 30-Jan-2023
deployment (PKG). This image can be used with AnyConnect
version 4.3 and later along with ISE 2.1 and later. Cisco Secure

Client 5.x along with ISE 2.7 and later.
cisco-secure-client-win-4.3.3335.6146-isecompliance-webdeploy-k9_pkg
Advisories []

13295164717716

ISE Posture Compliance Library - Mac OS X [/ Head-end 30-Jan-2023
deployment (PKG). This image can be used with AnyConnect
version 4.3 and later along with ISE 2.1 and later.Cisco Secure

Client 5.x along with ISE 2.7 and later.
cisco-secure-client-macos-4.3.2868.4 354 -isecompliance-webdeploy-
k9 pkg

Advisories [



13295155874580

| SE Configuration

1. Access the | SE dashboard and navigate towWork Centers> Posture > Client Provisioning >
Resources > Add > Agent resour ces from local disk.

= Cisco ISE Work Centers - Posture

Overview Metwork Devices Client Provisioning Policy Elements Posture Policy Policy Sets Troubleshoot Reports Settings
Client Provisioning Policy
| Resources

Client Provisioning Portal
0O AGERT resourees from Ci Version Last Update Description
a | Agent resources from local disk I oTemporalAgent... 4.10.2051.0 2021/08/09 13:12:31 With CM: 4.3.1858.4353
O Mative Supplicant Profile se Supplicant Pro... Mot Applic... 2016/10/06 14:01:12 Pre-configured Native S...
G ol oAgentlessOSX 4.10.2051.0 2021/08/09 13:12:36 With CM: 4.3.1858.4353
O Ar DsXSPWizard 2.7.01 2021/08/09 13:12:27 Supplicant Provisioning ...
O oAgentiessWind 4.10.2051.0 2021/08/09 13:12:33  With CM: 4.3.2227.6145
|:| Cisco-ISE-NSP Native Supplicant Pro... Mot Applic... 2016/10/06 14:01:12 Pre-configured Mative S...
(] WinSPWizard 3.0.0.3 WinSPWizard 3.0.0.3 2021/08/09 13:12:27 Supplicant Provisioning ...
G CiscoTemporalAgentWindo... CiscoTemporalAgent... 4.10.2051.0 2021/08/09 13:12:28 With CM: 4.3.2227.6145

13296001416212

2. SelectCisco Provided Package > Choose File, upload the AnyConnect Headend Deployment
Package, and clickSubmitandConfirm.



= Cisco ISE Work Centers - Posture
Overview Network Devices Client Provisioning Policy Elements Posture Policy Policy Sets Troubleshoot Reports Settings

Client Provisioning Palicy Agent Resources From Local Disk Agent Resources From Local Disk

Resources Agent Resources From Local Disk

Client Provisioning Portal

Category Cisco Provided Package hd

[ Choose File :anywlrnoct-v-' ~eploy-k9.pkg

~ AnyConnect Uploaded Resources

Name Type Version Description

AnyConnectDesktopWindow... AnyConnectDesktop... 4.10.6090.0 AnyConnect Secure Mob...

m cancel

13296134663316

3. Repeat the process to upload the | SE Posture Compliance Library:
» SelectCisco Provided Package > Choose File, upload the | SE Posture Compliance Library,

= CiscoISE Work Centers - Posture
Overview Network Devices  Client Provisioning Policy Elements Posture Policy Policy Sets Troublesheot Reports Settings
Client Provisioning Palicy Agent Resources From Local Disk » Agent Resources From Local Disk

Agent Resources From Local Disk

Category Cisco Provided Package M (e

Choose File | cisco-secure-.eploy. mml

~ AnyConnect Uploaded Resources

Name Type Version Description

Anyl nyCH 1C: 4.3.3335. Cisco Secure Client Win,

o

and clickSubmitandConfirm.

13296424126484

4. Upload the OrgInfo.json profile:
» SelectCustomer Created Package > Select AnyConnect Profile > Add Name > Choose File
> Orglnfo.json > Submit.



= Cisco ISE Work Centers - Posture

Overview MNetwork Devices Client Provisioning Policy Elements Posture Policy Policy Sets Troubleshoot Reports Settings
Client Provisioning Policy Agent Resources From Local Disk > Agent Resources From Local Disk
Resources

Agent Resources From Local Disk

Client Provisioning Portal

Category Customer Created Pack: v ©
Type AnyConnect Profile v
* Name

Umbrella Profile I

Description

13296644513172

5. Add the AnyConnect Posture Profile:
* GotoWork Centers> Posture > Client Provisioning > Resour ces > Add > AnyConnect

= Cisco ISE Work Centers - Posture
Overview Network Devices Policy Elements Posture Policy Policy Sets Troubleshoot Reports Settings
Client Provisioning Policy
Resources
Client Provisioning Portal
O Ag ources from Version Last Update Description
C] Agent resources from local disk SonnectDesktop... 4.10.6090.0 2023/02/17 15:00:34 AnyConnect Secure Mob...
[:] Native Supplicant Profile oTemporalAgent... 4.10.2051.0 2021/08/09 13:12:31 With CM: 4.3.1858.4353
O AnyConnect Configuration ZonnectProfile Mot Applic... 2023/02/17 15:00:16
0O BRI e e se Supplicant Pro... Not Applic... 2016/10/06 14:01:12  Pre-configured Native S...
AMP Enabler Profile
O oAgentlessOSX 4.10.2051.0 2021/08/09 13:12:36  With CM: 4.3.1858.4353
O MacOsXSPWizard 2.7.0.1 MacOsXSPWizard 2.7.041 2021/08/09 13:12:27 Supplicant Provisioning ...
C] CiscoAg indows 4.1... Ci Wind... 4.10.2051.0 2021/08/09 13:12:33 With CM: 4.3.2227.6145
O AnyConnectComplianceMod... AnyConnectComplian... 4.3.3335.... 2023/02/17 15:00:57 Cisco Secure Client Win...
D Cisco-ISE-NSP Mative Supplicant Pro... Not Applic... 2016/10/06 14:01:12 Pre-configured Native S...
C] WinSPWizard 3.0.0.3 WinSPWizard 3.0.0.3 2021/08/09 13:12:27 Supplicant Provisioning ...
0 CiscoTemporalAg Windo.. CiscoTemporalAgent. 4.10.2051.0 2021/08/09 13:12:28 With CM: 4.3.2227.6145

13296771328020

» Add aprofile name and server name rules (wildcarded, comma-separated names that define the



servers that the agent can connect to for example,* .cisco.com), then clickSubmit.

= Cisco ISE Work Centers - Posture
Overview MNetwork Devices Client Provisioning Policy Elements Posture Policy Policy Sets Troubleshoot Reports Settings
Client Provisioning Policy SE F ture Agent Profile Settings New Profile
Resources

AnyConnect Posture Profile

ioning Portal

Name *

Posture Profile

Description:

Agent Behavior

Parameter Value

13296832646420
= Cisco ISE Work Centers - Posture
Overview Network Devices Client Provisioning Policy Elements Posture Policy Policy Sets Troubleshoot Reports Settings

Client Provisioning Policy

Resources

Client Provisioning Partal Posture Protocol
Paramuter Value
PRA retransmission time 120 5655
Retransmission Delay &0 Frry
Retransmission Limit 4

Discovery host

Discovery Backup Server List Choose

*.dacabrer.lab

Call Home List

Back-off Timer a0 secs

13298487677972

6. Add AnyConnect Configuration:
* Navigate towork Centers> Posture > Client Provisioning > Resources > Add >
AnyConnect Configuration.



= Cisco ISE Work Centers - Posture

Overview Metwork Devices Client Provisioning Policy Elements Posture Policy Policy Sets Troubleshoot Reports Settings
Client Provisioning Policy
== Resources
Resources
Client Provisioning Portal
Agent rasources from Cisco sit Version Last Update Description
AQENT 1esoure ycal disk ZonnectComplian... 4.3.3335.... 2023/02/17 15:00:57 Cisco Secure Client Win...

ZonnectDesktop...  4.10.6090.0 2023/02/17 15:00:34 AnyConnect Secure Mob...

~onnectProfile Not Applic... 2023/02/17 15:00:16

AnyConnect Configurathon
2 2

ConnectProfile Not Applic 2023/02/17 15:03:12

Cisco-ISE-NSP

GiscoTemporalAgentWindo...
CiscoAgentless0OSX 4,10.02...
CiscofgentlessWindows 4.1...
MacOsXSPWizard 2.7.0.1

Cisco-1SE-Chrome-NSP

OO0OO0OO0OO0OO0ooooooo b

WinSPWizard 3.0.0.3

oTemporalAgent...
CiscoTemporalAgent...
CiscoAgentlessOSX
CiscoAgentlessWind...
MacOsXSPWizard
Native Supplicant Pro...

MNative Supplicant Pro.

WinSPWizard

4.10.2051.0 2021/08/09 13:12:31

4.10.2051.0 2021/08/09 13:12:28

4.10.2051.0 2021/08/09 13:12:36

4.10.2051.0 2021/08/09 13:12:33

2.7.01

2021/08/09 13:12:27

Not Applic... 2016/10/06 14:01:12

Not Applic... 2016/10/06 14:01:12

3.0.0.3

2021/08/09 13:12:27

With CM: 4.3.1858.4353

With CM: 4.3.2227.6145

With CM: 4.3.1858.4353

With CM: 4.3.2227.6145

Supplicant Provisioning ...

Pre-configured Native S...

Pre-configured Native S

Supplicant Provisioning ...

13297194126612

» Select the AnyConnect Package, add a configuration name, select the Compliance Package,
choose the AnyConnect Modules (Umbrella and Diagnostic), select the ISE Profile, select the

= CiscoISE Work Centers » Posture
Overview  Network Devices  Client Provisioning  Policy Elements  Posture Policy  Policy Sets  Troubleshoot  Roports  Setlings
Gilent Provisioning Policy an i New AnyConnect Confguration

Client Provisioning Portal

* Select AnyConnect Package: AnyConnectDesktopWindows 4.10.609(~

* Configuration Name: AnyConnect Configuration

Description

Description Value Notes

* Compliance Module

CiscoSecureClientComplianceModuleW ~

AnyConnect Module Selection
1SE Posture

VPN

Network Access Manager

AMP Enabler

ASA Posture

Network Visibility

[Sreorers rowming Sevury

Start Before Logon

[esrosie 2ne Reporing Toor

Profile Selection

e

VPN ~

Umbrella Profile, and clickSubmit.

13297382333588

7. Assign the AnyConnect Configuration to the Client Provisioning Policy:
* GotoWork Centers> Posture > Client Provisioning > Client Provisioning Policy.



= Cisco ISE Work Centers - Posture

Overview  Network Devices | Client Provisioning | Policy Elements  Posture Policy Policy Sets  Troubleshoot  Repons  Settings
R

Client Provisioning Policy

Rulé Name Identity Groups Operating Systems Other Conditions Rusults

<]

[ |

a
H
H
o
H
H
£
g
g

= [-Aa— g .05 & ai Hative Suppiicant Configuration

13297993535508

 Edit the policy and underResults, add the AnyConnect Configuration, then clickSave.
8. Create an Authorization Policy to redirect clients to the Client Provisioning Portal. (Thisstep is
outside the scope of thisguide.)

Saatus  Fule Hame

13380169470868

Client side Configuration

1. Oncethe client is able to get the redirection from the Client Provisioning Portal click Start:
13380233607956

2. Select Thisismy first time here and it begins downloading AnyConnect: =

13380334336020

3. Open/run the downloaded file and it starts the process:



Metwork Setup Assistant

Network Setup Assistant

Downloading Cisco AnyConnect Secure
Mobility Client...

Cancel

{c) 2014-2022 Cisco Systems, Inc, Csco, Cioo Systems and Cisco Systems
logo are registered trademarks of Cisco Systams, Inc and/or its affilistes in the
.S, and certzin other countries,

13380212207508

4. When "Trusted and Secure Connection” message appears click Connect if the ISE information is

Metwork Setup Assistant

Trusted and Secure Connection

ﬁ You are connected to

ise3d-1.dacabrer.lab
whose identity has been certified. Your
connection to this website is encrypted.

Connect Canhcel

{c) 2014-2022 Cisco Systems, Inc, Cisco, Cisco Systems and Cisco Systems
logo are registered trademarks of Cisco Systems, Inc and/or its affilistes in the
U.S. and certzin other countries.

correct:




13380233399956

5. Once the "Installation is completed” message appears click Quit:

Metwork Setup Assistant

Network Setup Assistant

?} Installation is completed.

Cluit

{c) 2014-2022 Cisco Systems, Inc, Cisco, Cioo Systems and Cisco Systems
logo are registered trademarks of Cisco Systems, Inc andfor its affiliates in the
U.5. and certain other countries.

13380233308820

6. You can close all other windows. Umbrella has been installed, plus the |SE Posture module:



'{ﬁ:‘ Cisco AnyConnect Secure Mobility Client

a &

Mo policy server detected.

Default network access is in effect.

Roaming Security:
Umbrella is active.

-||.l|l'||-
CISCO

13380212092308



