Configure and Troubleshoot WCCP on FTD Using
Predefined Template
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This document describes the configuration and troubleshooting steps for WCCP on FTD.
Prerequisites

Requirements

Cisco recommends that you have knowledge of these topics:

» Web Cache Communications Protocol (WCCP) version 2 (v2)
* Firepower Management Center (FMC)
» Firepower Threat Defense (FTD)

Components Used

The information in this document is based on these software and hardware versions:

e Secure Firewall Management Center (FMCv) v7.4.2
» Secure Firewall Threat DefenseVirtual (FTDv) v7.4.2

The information in this document was created from the devices in a specific lab environment. All of the
devices used in this document started with a cleared (default) configuration. If your network islive, ensure
that you understand the potential impact of any command.

Configure

Web Cache Communication Protocol (WCCP) is used to redirect web traffic to a cache server. It is
commonly implemented in network devices such as Cisco routers and firewallsto redirect HTTP, HTTS and
FTD over HTTP requeststo a proxy server.



WCCP isavailable in different versions, including WCCP v1, v2, and v3, with each version offering
enhanced features and scalability.

How it works

User machine Win10-0 makes aHTTPS request.

Here, the FTD Firewall isthe gateway for the user PC. It receivesthe HTTP/HTTPS request.
FTD understands the destination port is 443 and redirects the traffic to DMZ

DMZ encapsulates the packet with GRE and forwards the request to Proxy server.

Proxy server looks into its cache or initiates a new connection to the original server and directly
responds to the user machine.

Network Diagram
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Configurations

These steps demonstrate the configuration for WCCP on FMC. The traffic with port 80 and 443 must be
redirected from the Inside zone to the DM Z zone.



Note: The document describes the steps for dynamic service-id. The port information has been
learned from WCCP client.

Step 1: Loginto FM C GUI and navigate to Object > Object Management > Access List > Extended
>Add Extended AccessList.

Create two Extended Access Lists.

1) Create Access List to redirect user traffic and click Save.



Edit Extended Access List Object

Name

I Redirect_traffic

Entries (3)

@ Block  WSA_serer

2 © Block

user_LanN

3 Allow

Allow Overrides

Note: This access-list ensures that you have Action Block for traffic coming from WCCP client
towards FTD to avoid loop in the network.



Additionally, you can create another statement with Action Block to ensure the communication
between internal hosts are not sent to proxy server.

Thefinal statement must allow all other traffic that are eligible for redirection to the proxy.

2) Create Access List to identify the WCCP client and click Save.

Name
[ wece-cuent

Entries (1)

1 S Allow WSA_server

Allow Overrides

Access List to identify the WCCP client



Note: Configuring an extended access list to include the I P addresses of WCCP server.

Step 2: Navigate to Object > Object Management > FlexConfig > Text Object > Add Text Object to
add WCCP service and Save.



Edit Text Object T

Mame:

Description:
Variable Type Count
Single v 1
1 a7
|| Allow Overrides

| Cancel | Save

Creating wccp service object



Note: In this example, the service id is 97. It is advisable to select a Service ID between 90 and 97,
asthese are custom service IDs that typically do not conflict with other service IDs assigned to
specific protocols.

For more details, refer to WCCP on ASA: Concepts, Limitations, and Configuration

Step 3:

* Navigate to Object > Object Management > FlexConfig > Text Object and
Sear ch for isServicel dentifer.

Text Object ['5'« isServiceldentifieq %

Text objects define free-form text strings that you use as variables in a FlexConfig object. These objects can have single values or be a list of multiple values

* Modify the isServicel dentifer from falseto true.
* isServiceldentifer - When false, uses the standardweb-cacheservice identifier. Refer the


https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html

document Firepower Management Center Configuration Guide

Edit Text Object @

Name:

isServiceldentifier

Description:

A flag to identity whether to use
service in wccep.

Variable Type Count
Single v 1 §
1 true

Allow Overrides

» Override (0)

Modify the value fromfalse to true



https://www.cisco.com/c/en/us/td/docs/security/firepower/70/configuration/guide/fpmc-config-guide-v70/flexconfig_policies.html

Note: Additionally, you can create a user defined Text Object shown in Step 2.

Step 4:

» Navigate to Object > Object Management > Flex Config > FlexConfig Object.
* Search for keyword wccp.
 Click the Clone option for Wcep_Configur e template.
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* Access List

g Object include device configuration commands, variables, and scripting language instructions. It is used in FlexConfig polices.

Address Pools FlexConf

Application Filters
AS Path Hamy & i
EFD Template
W > ure The template is a mple of weep configur. . B
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"~ FlenConfig
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Note: FlexConfig object has a predefined template: Wccp_Configur e. The template cannot be
attached to the device. Y ou must cloneit.



Step 5:

* Remove the $servicel dentifier variables from the third line and provide your own variable.

Add FlexConfig Object (7]

MName:

Weep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.
Insert = B2 Deployment: Once v Type: | Append A

#set( $service = "web-cache")

#if( $isServiceldentifier == "true")
#set( Sservice = “Ssepviceldentifier”
#end -'""'L

#set ( SweepCli =
#end
####wecepRedirectList is place-holder for extended ACL.

f####Replace wecpRedirectList with extended ACL defined in FMC by inserting policy-object of type extended ACL.
#1if( SwccpRedirectList )

fset( SweepCli = "$weopCli redirect-list SwegpRedirectList"™)

fend
¥ Variables
Name Dimension Default Value Pra-pelrly Override Description
(Type:Name)
isServiceldentifier SINGLE true FREEFORM:I... false A flag to determine if service ...
serviceldentifier SINGLE 1 FREEFORM:... false service identifier number is to...

Remove the service identifier

* Insert the Text Objectwccp-service as the variable created in step 2.
» From the drop-down menu, select Insert > Insert Policy Object > Text Object



Add FlexConfig Object

Name:

! Weep_Configure_clone

Description:

. The template is an example of
| wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v . E3 Deployment: ' Once v Type: ' Append

| Insert Policy Object Text Object

Insert System Variable » Network

§

Insert Secret Key Security Zones
#set ( SwecepGli = "Sweg .
####wccpGroupList is pl Standard ACL Object 3 acr.
f###Replace wecepGroupLi afined in FMC by inserting policy-object of type extended ACL.

§if ( $wecpGroupl Extended ACL Object

#set( SwccpCli =

#end Route Map

fend

Inser the weep-service object as variable

» Provide aVariable Namewccp-service.
» Search for wecep-service-object in Available Object.
» Add the object and Saveit.



Insert Text Object Variable (7]

Variable Name:

| wecep-service ‘

Description:
Available Objects Selected Object
| 2, weep b4 ‘ weep-service-object .

wecepPassword

Cancel Save

Add wccp-service object
Step 6:

» Copy the weepGroupList variable name and provide your own variable.



Add FlexConfig Object

Name:

: | Wecep_Configure_clone l

Description

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

llnsertv s Deployment: Once v Type: Append v

#set( $service = "web-cache")

#if( $isServiceldentifier == "true")
#set( $service = "$wecp-service")
fend

###fwocepGroup. t is place-holder for extended ACL.
] ####Replace weoopGr List with extended ACL defined in FMC by inserting policy-cbject of type extended ACL.
S if ( $WcCPGrouplLis

#end

- A

5!
Remove pre-defined weepGrouplist variable

* From drop-down menu Insert > Insert Policy Object > Extended ACL Object.

Name:

| Weep_Configure_clone

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

!

Insert v Deployment: Once v Type: Append

| Insert Policy Object Text Object

Insert System Variable »  Network

Insert Secret Key Security Zones

Standard ACL Object i ACL.

rfined in FMC by inserting policy-object of type extended ACL.
Extended ACL Object

#end

¥ Variables

Adding wccpGrouplist Extended ACL

* Paste the name wcepGroupList you have copied in previous step in Variable Name section.
» Search for WCCP-CLIENT in Available Objects created in step 1.



* Add and Saveit.

o

Insert Extended Access List Object Variable (7]

Variable Name:

‘ wccpGrouplList |

Description:

Available Objects C Selected Object
| | a search X | BVCCP-CLIENT ]
U L’?edirect_trafﬁc

**NCCP-CLIENT

Add WCCP-CLIENT extended list

Step 7:

» Select weepRedirectList to copy and and provide your own variable.



Add FlexConfig Object

Name:

( Weep_Configure_clone ]

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v Deployment: | Once v ‘ Type: | Append
f#set ( $service = "web-cache")
#if( $isServiceldentifier == "true")

####Replace wecpRedirectList with extended ACL defined in FMC by inserting policy-object of type extended ACL.
mp-§1f ( $wccpRedirectList )

#end

Remove wccpRedirectlList

» From the drop-down menu, select Insert > Insert Policy Object > Extended ACL Object .

Add FlexConfig Object

Name:

l Wecep_Configure_clone j

Description:

The template is an example of
wccp conﬁguration, It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v | Deployment: . Once v Type: | Append
Fl Insert Policy Object Text Object

Insert System Variable »  Network

Insert Secret Key Security Zones

####wccpGroupList is pl Standard ACL Object  j acr.
$444Replace w i X

#if( ) Extended ACL Object
#set ( $weepCli = “"$weck JupList™)
#end Route Map
##f#wcepRedirectlist is plrace-nolaer ror extended ACL.

fined in FMC by inserting policy-object of type extended ACL.

#end

¥ Variables

Select extedned ACL object for wecpRedirectList

» Paste wccpRedirectList in Variable Name.
» Search for Redirect_trafficin Available Object.



* Select Add and Saveit.

et e = e e o AR 4 SN EASEAEESASEETEma Lo

Insert Extended Access List Object Variable (7]

Variable Name:

[ wccpRedirectList ‘

Description:

Available Objects C Selected Object
‘ Q_ Search b 4 | Lﬁib:edirect_traﬁ“lc

:' *Redirect_traffic

BVCCP-CLIENT

)

Add Redirect_traffic ACL

Step 8:

¢ Remove @wccpPassword



Add FlexConfig Object

Name:

[ Wecep_Configure_clone ‘

Description:
The template is an example of
wccep configuration. It can not be
A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

|- Insert v - [ Deployment: [ Once v | Type: [ Append

$#44wcepGrouplist is place-holder for extended ACL.
st with extended ACL defined in FMC by inserting policy-object of type extended ACL.

t is place-holder for extended ACL.
irectList with extended ACL defined

in FMC by inserting policy-object of type extended ACL.

#foreach( $interfaceName in $security-zone)

Removed the pre-defined wccppassword

» Select the Key from the drop down menu Insert > Insert Secret Key.

Add FlexConfig Object

Name:

' Weep_Configure_clone ‘

Description:

The template is an example of
wecep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

‘. Insert v . k2 Deployment: l Once - l Type: l Append

: f -holder for extended ACL.
Insert Policy Object  » 3°©
Y d st with extended ACL defined in FMC by inserting policy-object of type extended ACL.

Insert System Variable »
Y Cli group-list $wccpGroupList")

Insert Secret Ke

####Replace wecpRedirectList with extended ACL defined in FMC by inserting policy-object of type extended ACL.

#set( $wccpCli = "$wccpCli redirect-list $wccpRedirectList™)
#end

#set( SwecepCli = "SweepCli password ")

$weepCli

###4 Assiging woep onto interface
#foreach( $interfaceName in $security-zone)

¥ Variables
Select secret key

* Click Add Secret Key.




Insert Secret Key @

Add Secret Key

Name

o)

[ ] wccpPassword 4

Cancel Save

Add secret key

* Enter anamein Secret Key name.
» Enter the password.
 Enter the same password in Confirm Password and click Add.



Add Secret Key

Secret Key name:*

‘ wccpPassword

Password:*

Add user defined secret key

[ Cancel ] Add




Note: In this example, the inside interface belongs to Security Zonein.

Step 9:

» Copy the predefined security-zone and replace $ security-zone with your own variable.



Edit FlexConfig Object

Name:

| Weep_Configure_clone |

Description:

The template is an example of
weep configuration. It can not

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Deployment: | Once

fforeach( $interfaceName in $SECUrity-ZONe |
weep interface $interfaceName §service redireet in

fend

v Variables
Name Dimension
wcepGrouplist SINGLE
wcecp-service SINGLE
interfaceName SINGLE
security-zone SINGLE

Copy the name security-zone

Default Value

WCCP-CLIENT

97

in

in

Property
(Type:Name)

EXD_ACL:W...
FREEFORM:...
SECURITYZ...

SECURITYZ...

v | Type: | Append

Override

false

false

false

false

Description

» Select Security Zones from the drop-down menu and Insert > Insert Policy Object.



Add FlexConfig Object

Name:

Wecep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert B2 Deployment: I Once v ‘ Type: I Append

Insert Policy Object Text Object supList™)

Insert System Variable »  Network wded ACL.
. defined in FMC by inserting peolicy-object of type extended ACL.
Insert Secret Key Security Zones
¥5eT| PWCCPULL = “3»WCCE JRedirectList")
$end Standard ACL Object

#set ( SwcepCli = "Swecp Extended ACL Object vord ")
$WecpCli Route Map

#### Assiging wccp onto interface
#foreach( in $security-zone)

#end

¥ Variables

Select the security zone

» Pastethe Variable Name as security-zone

* From Available Objects, select the interface to Add.
» Click Save.



Insert Security Zone Variable (7]

Variable Name:

| security-zone |

Description:

Available Objects Selected Object
| C, Search ‘ in

o/

dmz

out

Cancel Save

Adding security-zone

Step 10:

» Navigateto Devices> FlexConfig, Click New Policy or Edit an existing policy.
» Select the configured Wcep_configure_clone object and click > to assignit.
* Click Save.



Note: For aNew Policy, ensure that you assign the Policy to FTD device. For an existing policy,
the policy must have been already assigned.

WCCP_config E=3

Weep_ConSgure_tions

Step 11: Navigate to Deploy > Select the FTD Device > click Deploy.



Verify
Step 1: Verify the running configuration.

Loginto FTD CLI and run the command show running-config wcep.

Configuration example:

o

wcecp 97 redirect-Tist Redirect_traffic group-Tist WCCP-CLIENT password #¥¥*%*
wccp interface inside 97 redirect 1in

To ensure the configuration has the correct password, run the commands.
1) system support diagnostic-cli

2) enable

3) Press Enter without password

4) more system:running-config | include wccp

Step 2: Verify the WCCP status

Run the command show weep

Global WCCP information:
Router information:
Router Identifier: -not yet determined-
Protocol Version: 2.0

Service Identifier: 97

Number of Cache Engines: 1

Number of routers: 2

Total Packets Redirected: 0

Redirect access-1ist: Redirect_traffic
Total Connections Denied Redirect: 0

Total Packets Unassigned: 0

Group access-Tist: WCCP-CLIENT
Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

Run the command show wcep 97 service

WCCP service information definition:

Type: Dynamic
Id: 97
Priority: 240

Protocol: 6



Options: 0x00000012

Hash: DstIP
Alt Hash: -none-
Ports: Destination:: 80 443 000000

Note: Here 97 isthe service-id. Ensure you can see the port number learned from WCCP client in
Ports: section.

3) Run the command show wecp 97 view

Troubleshoot

Step 1: Verify FTD has the route from the same interface that received the WCCP request from Proxy
server.

In this example, traffic is redirected to thedmz interface.



>show route
S 10.xx.xx.xx 255.yyy.yyy.yyy [1/0] via 10.zz.zz.z, dmz

Note: Here 10.xx.Xx.xX is proxy server IP, 255.yyy.yyy.yyy is Netmask, 10.zz.zz.z is the next hop
gateway.

Step 2: Take the captures on inside and dmz interface to ensure the traffic is redirected.

Capture on Inside interface for port 443

capture capinside interface inside trace detail match tcp any any eq 443

Capture on dmz interface:



capture capdmz interface dmz trace detail match gre any any

Note: On dmz interface, you must filter with GRE protocol. The redirect packet is encapsulated in
GRE packet to wecep client.

Step 3: Debug for weep
Run the commands:

debug weep event debu weep packet

Cisco bug IDCSCvn90518 has been raised for enhancement to have the FDM and FMC native mode support
for WCCP configuration.


https://tools.cisco.com/bugsearch/bug/CSCvn90518

