
Fehlerbehebung bei COS-AP-Startproblemen 
und Herunterladen von AP-Images

Inhalt
Einleitung

Voraussetzungen

Anforderungen

Verwendete Komponenten

AP-Startvorgang

U-Boot

U-Boot-Startsequenz

U-Boot-Bootpartition ändern

COS-Shell

AP-Dateisystemüberprüfung

show image integrität Befehl

show filesystems-Befehl

AP-Upgrade-Pfad

Methoden zum Herunterladen von AP-Bildern

AP-Image-Vordownload

AP-Image-Vordownload über GUI

AP-Image-Vordownload über CLI

Standard-WLC- und AP-Upgrade

Standard-WLC- und AP-Upgrade über GUI

Standard-WLC- und AP-Upgrade über CLI

Manueller AP-Image-Download

Überprüfung

Zugehörige Informationen

Einleitung

In diesem Dokument werden der AP-Startvorgang, der AP-Upgrade-Pfad und die Methoden zum 
Herunterladen von AP-Images im Detail beschrieben.

Voraussetzungen

Anforderungen

Cisco empfiehlt, dass Sie über Kenntnisse in folgenden Bereichen verfügen:

Grundkenntnisse der Catalyst Wireless LAN Controller•

Verwendete Komponenten



Catalyst 9800-CL, Cisco IOS® XE 17.15.3•
Access Point Catalyst 9162•
Cisco Aironet Access Point der Serie 3802•

Die Informationen in diesem Dokument beziehen sich auf Geräte in einer speziell eingerichteten 
Testumgebung. Alle Geräte, die in diesem Dokument benutzt wurden, begannen mit einer 
gelöschten (Nichterfüllungs) Konfiguration. Wenn Ihr Netzwerk in Betrieb ist, stellen Sie sicher, 
dass Sie die möglichen Auswirkungen aller Befehle kennen.

AP-Startvorgang

U-Boot

U-Boot-Startsequenz

Die Cisco APs beginnen den Bootvorgang im U-BOOT-Modus, der vor der COS-Shell stattfindet. 
Gehen Sie diese Schritte durch, um den U-BOOT-Modus zu aktivieren.

Schließen Sie ein Konsolenkabel an den AP-Konsolenport an.1. 
Öffnen Sie ein Terminalemulationsprogramm auf Ihrem PC, und stellen Sie die Sitzung auf 
den richtigen seriellen COM-Anschluss ein. Überprüfen Sie den COM-Port, der auf Ihrem 
Gerät verwendet werden soll.

2. 

Stellen Sie die Terminal-Emulatorsoftware auf eine Baudrate von 115200 bit/s ein.3. 



Anmerkung: Wenn keine Ausgabe vom Access Point erfolgt, stellen Sie die Baudrate auf 
9600 ein.

4. Schließen Sie den Access Point an die Stromversorgung an.

5. Geben Sie U-Boot-Modus durch über die Escape (esc) Taste auf Ihrer Tastatur, sehen Sie die 
Option Hit ESC to stop autoboot wie im Screenshot zu sehen. Diese Meldung wird angezeigt, 
wenn der Access Point neu gestartet wird, während er mit dem Konsolenport verbunden ist. 



Bildschirm "U-Boot Startup"

Verwenden Sie den Befehl printenv aus dem U-Boot-Modus, um die verschiedenen U-Boot-
Umgebungsdetails für den Access Point aufzulisten.



U-Boot printenv

Diese Ausgabe zeigt an, dass die Boot-Partition part1 ist. Diese Boot-Partition kann im U-Boot-
Modus geändert werden.

U-Boot-Bootpartition ändern

Passen Sie die aktuelle Boot-Partition mit dem Befehl setenve BOOT part <1-2> an.1. 
Speichern Sie die Partitionsanpassung mit dem Befehl saveenv.2. 
Überprüfen Sie die aktuelle Bootpartition mit dem Befehl printenv.3. 

 

u-boot>> setenv BOOT part 2 



u-boot>> saveenv 
Saving Environment to SPI Flash... 
SF: Detected N25Q32A with page size 64 KiB, total 4 MiB 
Erasing SPI flash....Writing to SPI flash.....done 
u-boot>> printenv 
BOOT=part 2 

 

4. Starten Sie den AP mit der neu konfigurierten Boot-Partition mit dem Befehl boot.

 

u-boot>> boot 
Creating 1 MTD partitions on "nand0": 
0x000000200000-0x000010000000 : "mtd=2" 
UBI: attaching mtd1 to ubi0 
ubifsmount - mount UBIFS volume 
 
Usage: 
ubifsmount 
 
        
 
 
    - mount 'volume-name' volume 
Unable to ubi mount UBIFS partition part 2 
Trying alternate partition part2 
UBIFS: mounted UBI device 0, volume 0, name "part2" 
 
 
 

 

5. Der Access Point startet von der ausgewählten Bootpartition.

COS-Shell

AP-Dateisystemüberprüfung



Anmerkung: Es wird empfohlen, die Access Points vor dem Upgrade neu zu laden. 
Dadurch können alle zwischengespeicherten Dateisysteme aktualisiert und temporäre 
Dateien vor dem Upgrade geleert werden.

Geben Sie über die CLI des Access Points den privilegierten Modus ein, und führen Sie diese 
Befehle aus, um die aktuellen AP-Images und die Größe des TMP-Verzeichnisses zu überprüfen.

show image integrität Befehl

Diese Ausgabe zeigt die aktuellen Versionen auf dem Access Point an.

Die primäre Partitionsversion gibt die aktuelle AP-Bootversion an.

Die Backup-Partitionsversion gibt die AP-Backup-Version an.

 

AP-CW9162#show image integrity 
/part1(primary) 17.15.3.28 



    part.bin : Good 
    ramfs_data_cisco.squashfs : Good 
    iox.tar.gz : Good 
/part2(Backup) 17.9.6.40 
    part.bin : Good 
    ramfs_data_cisco.squashfs : Good 
    iox.tar.gz : Good 

 

Sie können mit den fett markierten Befehlen zwischen der aktuellen AP-Bootversion wechseln. 
Nach dem nächsten AP-Neuladen wird der Access Point mit der ausgewählten Partition gestartet:

Konfigurieren von Startpfad 1 (bootet AP mit Teil1-Version)

Oder

Konfigurieren von Startpfad 2 (bootet AP mit Teil2-Version)

show filesystems-Befehl

Die Ausgabe zeigt die Dateisystemstruktur des Access Points an.



Anmerkung: Die Zeile /tmp in der Spalte Mounted on zeigt den Dateisystemeintrag an, der 
für den AP-Image-Speicher für ein AP-Upgrade verwendet wird.

 
<#root>

AP-CW9162#show filesystems 
Filesystem                Size      Used Available Use% Mounted on 
..... 

none                    114.4M      4.7M    109.7M   4% /tmp 

.....

 

Es ist wichtig, dass das AP /tmp-Dateisystem eine Größe von 100M oder höher hat. Das /tmp-
Dateisystem wird zum Speichern des AP-Image-Upgrades verwendet. 



Anmerkung: Wenn der /tmp-Dateisystemeintrag nicht 100M oder größer ist, können 
Probleme mit AP-Images auftreten, die für die Partition zu groß sind. Sie müssen den AP 
über eine der Methoden zum Herunterladen von AP-Images auf Version 17.6.6 
aktualisieren, wodurch die Partition erweitert wird.

AP-Upgrade-Pfad

Cisco APs erfordern einen bestimmten Upgrade-Pfad mit Verweis auf die aktuelle und die 
Zielversion. In diesem Leitfaden wird Cisco IOS XE Version 17.15.3 verwendet. 

Suchen Sie nach dem Dokument mit den Versionshinweisen und dem Upgrade-Pfad auf 
Cisco IOS XE für die ausgewählte Upgrade-Version.

1. 

https://www.cisco.com/c/de_de/support/wireless/catalyst-9800-series-wireless-controllers/products-release-notes-list.html


Versionshinweise 17.15.X

2. Der Abschnitt Vor dem Upgrade enthält wichtige Details zur Upgrade-Version. Es wird 
empfohlen, diese Informationen zu überprüfen.

3. Die Tabelle Upgrade Path to Cisco IOS XE Cupertino 17.15.X enthält Details zu den Versionen, 
von denen Sie direkt aktualisieren können.



Upgrade-Pfad auf 17.15.X

3. Die Cisco Wireless Solutions Software-Kompatibilitätsmatrix zeigt an, welche AP-Modelle mit 
der von Ihnen gewählten Version kompatibel sind.

https://www.cisco.com/c/en/us/td/docs/wireless/compatibility/matrix/compatibility-matrix.html


Anmerkung: Die Spalte "Access Point Release" entspricht dem Codenamen der AP-
Version. Diese Access Point-Version wird über die manuelle AP-Image-Download-
Methode verwendet und muss mit Anmerkungen versehen werden.

Wireless-Kompatibilitätsmatrix 17.9.6 - Tabelle Überschrift.png



Wireless-Kompatibilitätsmatrix 17.15.3

4. Verwenden Sie die Software Download-Webseite, um das Upgrade-Paket zu erhalten, und 
fahren Sie dann mit einer AP Image Download-Methode fort.

Methoden zum Herunterladen von AP-Bildern

Verwenden Sie den 9800 WLC, um den AP zu aktualisieren. Dieser Prozess umfasst das 
Herunterladen des Cisco IOS XE-Upgrades auf das 9800-Chassis und die Initiierung des Image-
Downloads auf verknüpfte Access Points.

Es gibt zwei Methoden zum Aktualisieren von AP-Images: AP Image-Vorabdownload und 
Standard-WLC-Upgrade.

AP-Image-Predownload ermöglicht das Vorladen der AP-Image-Software vor dem erneuten 
Laden des AP.

•

Das Standard-WLC-Upgrade schließt das Upgrade auf dem WLC ab, lädt den WLC neu und 
lädt die neue Version anschließend von den APs beim Beitritt zum Access Point herunter. 

•

AP-Image-Vordownload

AP-Image-Vordownload über GUI

Laden Sie die bevorzugte Cisco IOS XE-Image-Version von der Cisco Software-Download-
Site herunter.

1. 

https://software.cisco.com/download/home
https://software.cisco.com/download/home
https://software.cisco.com/download/home


Laden Sie das Cisco IOS XE-Image über die Web-Benutzeroberfläche Administration > 
Software Management > Software Upgrade > Source File Path > Select File > Select the 
9800 Upgrade File, um es auf den Controller hochzuladen.

2. 

Benutzeroberfläche für die Softwareverwaltung

3. Überprüfen Sie AP Image Predownload.

4. Klicken Sie auf Herunterladen und installieren.



WLC-Upgrade-Vorabdownload - Image installieren

5. APs werden mithilfe der AP-Image-Predownload-Methode aktualisiert.

AP-Image-Vordownload über CLI

Fügen Sie dem WLC das Controller-Image hinzu, und erweitern Sie es.1. 

 

install add file bootflash:image.bin 

 

2. Laden Sie das Image auf alle Access Points oder einen bestimmten Access Point herunter, der 
mit dem Controller verbunden ist.

 

ap image predownload 

 

Oder

 

ap name 
 
        
 
         image predownload 
 
 
 

 

3. Überprüfen Sie den Status des AP-Vorabdownloads für alle Access Points oder einen 
bestimmten Access Point.

 

show ap image 

 

Oder

 

show ap name 
 
        
 
         image 
 



 
 

 

4. Tauschen Sie Images aller APs, bestimmter APs oder APs aus, die das Vorabdownload 
abgeschlossen haben. 
 

 

ap image swap 

 

Oder

 

ap name 
 
        
 
         image swap 
 
 
 

 

Oder

 

ap image swap completed 

 

5. Aktivieren Sie das neu installierte Abbild. Dadurch wird der WLC neu geladen und mit der 
neuen Version gestartet.

 

install activate 

 

6. Sobald der WLC online und erreichbar ist, übertragen Sie das Bild.

 

install commit

 

Standard-WLC- und AP-Upgrade



Standard-WLC- und AP-Upgrade über GUI

Laden Sie die bevorzugte Cisco IOS XE-Image-Version von der Cisco Software-Download-
Site herunter.

1. 

Laden Sie das Cisco IOS XE-Image über die Web-Benutzeroberfläche Administration > 
Software Management > Software Upgrade > Source File Path > Select File > Select the 
9800 Upgrade File, um es auf den Controller hochzuladen.

2. 

Benutzeroberfläche für die Softwareverwaltung

3. Nachdem Sie die Quelldatei für den Upload ausgewählt haben, wählen Sie die Option aus, die 
Ihren Anforderungen am besten entspricht: Standard WLC Upgrade oder AP Image Predownload .

4. Klicken Sie auf Herunterladen und installieren.

5. Der Fortschrittsbalken erreicht 100 % und der Status "Image installieren/Paket" ist erreicht.

https://software.cisco.com/download/home
https://software.cisco.com/download/home


Standard-WLC-Upgrade - Image installieren

6. Nachdem der WLC die letzten Prüfungen durchgeführt hat, klicken Sie auf Save Configuration 
& Activate (Konfiguration speichern und aktivieren). Dadurch wird der WLC neu geladen und mit 
der neuen Version gestartet.

7. Nachdem der WLC über die GUI erreichbar ist, bestätigen Sie die aktualisierte Version.



Upgrade bestätigen

Standard-WLC- und AP-Upgrade über CLI

1. Laden Sie das Image auf den Controller.

 

copy tftp|ftp|sftp:// 
 
        
 
        / 
 
         
 
          bootflash: 
 
 
         
 
 

 

2. Installieren Sie das Image auf dem Controller.

 

install add file bootflash: 
 
 

 

3. Aktivieren Sie das neue Bild. Dadurch wird der WLC neu geladen und mit der neuen Version 
gestartet.



 

install activate 

 

4. Sobald der WLC online und erreichbar ist, übertragen Sie das Bild.

 

install commit

 

Manueller AP-Image-Download

Verwenden Sie eine Dateiserver-Anwendung Ihrer Wahl auf Ihrem Computer oder Server. Dieser 
Dateiserver ist der Server, der den Access Point mit den bevorzugten Upgrade-Dateien versorgt.

Laden Sie die gewünschte Version des AP-Images von der Cisco Software-Download-Site 
herunter.

1. 

Speichern Sie die AP-Softwaredatei in Ihrem Dateiserververzeichnis.2. 
Verwenden Sie den Befehl archive download-sw, um das Datei-Upgrade von der CLI Ihres 
AP aus zu starten.

3. 

https://software.cisco.com/download/home
https://software.cisco.com/download/home


Anmerkung: Die für den Befehl archive download-sw verfügbaren Transportmethoden 
sind auf TFTP und SFTP beschränkt.

 

#archive download-sw /reload 
 
        
 
        ://[your TFTP server's IP address]/[image filename.tar] 
 
 

 

4. AP lädt die TAR-Upgrade-Datei wie angewiesen vom Dateiserver herunter. Dies dauert in 
Abhängigkeit von der Übertragungsrate zwischen dem WAP und dem Dateiserver eine gewisse 
Zeit.

5. Nach Abschluss der Dateiübertragung lädt der WAP das neu heruntergeladene WAP-Image 
automatisch neu und startet es.



Anmerkung: Wenn der Befehl archive download-sw vom Access Point nicht akzeptiert 
wird, geben Sie den Befehl debug capwap console cli ein, um den Befehl archive 
download-sw zu aktivieren

Überprüfung

Nachdem das AP-Upgrade abgeschlossen ist, überprüfen Sie mit den Befehlen die AP-Version, 
die Image-Integrität und die Bootpartition.

1. Überprüfen der AP-Version

 

show version 

 

2. Überprüfen der Bildintegrität



 

show image integrity

 

3. Überprüfen der Bootpartition

 

show boot 

 

Zugehörige Informationen

Reparieren von C9120/C9115 Access Points über U-Boot•
Herunterladen eines Images auf einen Access Point•
Aktualisieren der Cisco Catalyst Wireless Controller-Software der Serie 9800•

https://www.cisco.com/c/de_de/support/docs/wireless/catalyst-9120axi-access-point/217537-repairing-c9120-c9115-access-points-from.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_predwnld_image_ap_ewlc.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_upgrade_9800cl.html


Informationen zu dieser Übersetzung
Cisco hat dieses Dokument maschinell übersetzen und von einem menschlichen Übersetzer
editieren und korrigieren lassen, um unseren Benutzern auf der ganzen Welt Support-Inhalte
in ihrer eigenen Sprache zu bieten. Bitte beachten Sie, dass selbst die beste maschinelle
Übersetzung nicht so genau ist wie eine von einem professionellen Übersetzer angefertigte.
Cisco Systems, Inc. übernimmt keine Haftung für die Richtigkeit dieser Übersetzungen und
empfiehlt, immer das englische Originaldokument (siehe bereitgestellter Link) heranzuziehen.


