Setup and Configuration Guide
for Cisco Unified Contact Center Hosted
Release 9.0(1)

June 2012
Table of Contents

Preface .............................................................................................................................................. 1
Purpose ........................................................................................................................................ 1
Audience ..................................................................................................................................... 1
Organization ............................................................................................................................. 2
Related Documentation ............................................................................................................ 3
Product Naming Conventions ................................................................................................. 4
Conventions ............................................................................................................................... 4
Obtaining Documentation and Submitting a Service Request .................................................. 5
Documentation Feedback ......................................................................................................... 5

1. Introduction to Cisco Unified Contact Center Hosted .......................................................... 7
   About Cisco Unified Contact Center Hosted ........................................................................... 7
      Multi-tenant PG for Cisco Unified Contact Center Hosted .................................................. 8
      Multi-Tenant Outbound Option for Cisco Unified Contact Center Hosted ....................... 8
   About Cisco Unified Contact Center Hosted Hardware Components .................................. 8
   About Cisco Unified Contact Center Hosted Software Components .................................. 8
   Cisco Unified Contact Center Hosted Core Components ..................................................... 8
   Cisco Unified Contact Center Hosted Installation and Configuration Tasks ......................... 9
      Hardware Installation Checklist ....................................................................................... 9
      Cisco Unified Contact Center Hosted Component Software Installation Checklist ............. 10
      Cisco Unified Contact Center Hosted Component Software Configuration Tasks ............. 12
      Cisco Unified Contact Center Hosted Production Environment Worksheet ...................... 13

2. CICM Installation and Configuration ..................................................................................... 15
   Introduction to Instances ........................................................................................................ 15
   Naming Conventions for Instances ....................................................................................... 16
   Selecting the CICM Complex ............................................................................................... 16
   Assigning an Instance Number to a CICM .......................................................................... 17
      How to See Instance Numbers Currently in Use ................................................................ 17
      How to Add an Instance to a CICM ................................................................................. 18
   Installing and Configuring CICM Loggers ......................................................................... 19
      How to Install and Configure a CICM Logger (Side A or Side B) ...................................... 19
   Installing and Configuring CICM CallRouters ................................................................... 20
      How to Install and Configure CICM CallRouter Software ................................................. 20
   Installing a CICM Network Administration & Data Server ................................................. 20
      How to Install a CICM Network Administration & Data Server ....................................... 21
   Configuring the CICM's INCRP NIC ................................................................................. 21
      How to Define the INCRP NIC ......................................................................................... 21
      How to Complete the INCRP NIC Setup .......................................................................... 23
      Consideration for Multiple NAM/CICM Routing Clients ................................................ 24
   Quality of Service (QoS) ........................................................................................................ 25
   Adding and Upgrading Components for Instances .............................................................. 25
      Removing an Instance ....................................................................................................... 25

3. Cisco Unified Communications Manager Configuration .................................................. 27
   Cisco Unified Communications Manager Configuration ..................................................... 27
      Installing Cisco Unified Communications Manager ......................................................... 27
      Stopping Cisco Unified Communications Manager Associated PG Services .................. 28
      Configuring Agent Phones in Cisco Unified Communications Manager ......................... 28
      Configure CTI Route Points ............................................................................................ 29
Create CICM Cisco Unified Communications Manager PG User (Cisco Unified Communications Manager JTAPI User).......................................................... 29
Cisco Unified Communications Manager Multi-tenancy Configuration......................................................... 30
Setting Up Duplicate Extensions in Different Customer Instances................................................................. 33

4. Installing and Configuring Cisco Unified Customer Voice Portal for Cisco Unified Contact Center Hosted. 35
Related Documentation................................................................................................................................................. 35
About Cisco Unified Customer Voice Portal........................................................................................................ 36
About Installing Unified CVP for Cisco Unified Contact Center Hosted......................................................... 36
About Configuring Unified CVP for Cisco Unified Contact Center Hosted...................................................... 37
About Setting Up Cisco Gateways/Gatekeepers to Interact with Unified CVP................................................. 37
How to Set Up Cisco NAM Software to Interact with Unified CVP................................................................. 37
How to Set Up Cisco CICM Software to Interact with Unified CVP................................................................. 37
How to Configure the Dynamic Routing Client................................................................................................. 38

5. NAM Installation and Configuration for Cisco Unified Contact Center Hosted.............................................. 41
Installing NAM Logger Software............................................................................................................................... 41
Post-Installation Setup and Installing Multiple Components............................................................................... 43
Installing NAM CallRouter Software..................................................................................................................... 43
Installing a Network Administration & Data Server.......................................................................................... 44
About Administration & Data Server Types.......................................................................................................... 44
NAM Configuration Data......................................................................................................................................... 45
Defining CICM Instances and Customers on the NAM....................................................................................... 46
Configuring CICM Instances on the NAM............................................................................................................ 46
Configuring CICM Associated Administration & Data Servers on the NAM............................................... 48
Defining CICM Customers...................................................................................................................................... 48
Installing NAM Cisco Unified Customer Voice Portal PG.................................................................................. 49
Configuring the NAM for a Unified CVP PG......................................................................................................... 50
How to Install a NAM Unified CVP PG.................................................................................................................. 51
Installing and Configuring NAM NICs and PGs................................................................................................. 55
Network Interface Controllers............................................................................................................................... 55
Peripheral Gateways.............................................................................................................................................. 55
How to Configure Device Management Protocols for NAM PGs................................................................. 55
Creating a Cisco Unified Intelligent Contact Management Application Gateway to Access CICM Instances................................................................................................................................. 55
Upgrading the NAM................................................................................................................................................. 58

6. Installing and Configuring CTI OS Server for Cisco Unified Contact Center Hosted...................................... 59
CTI OS Server Installation Guidelines.................................................................................................................... 59
How to Install the CTI OS Server.............................................................................................................................. 60
How to Start CTI OS Service After Installation.................................................................................................. 63
CTI OS Failover....................................................................................................................................................... 63

7. Installing and Configuring Outbound Option for Cisco Unified Contact Center Hosted.............................. 65
Configuring Outbound Option Multi-Tenant Customer Instances.................................................................. 65
Using the ConfigLimit Tool to Change Multi-Tenant Parameter Limits............................................................. 66

8. Reporting Installation and Configuration for Cisco Unified Contact Center Hosted..................................... 69

9. Installing and Configuring Cisco Multichannel Components for Cisco Unified Contact Center Hosted... 71

10. Advanced Services and Feature Control...................................................................................................... 73
Introduction.............................................................................................................................................................. 73
Setup and Configuration of an Advanced Services ICM Instance..................................................................... 74
Configuration of New Advanced Services Customer.......................................................................................... 76
# List of Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Figure 1: Name Fragment Dialog</td>
<td></td>
<td>17</td>
</tr>
<tr>
<td>Figure 2: Instance Number Values Dialog</td>
<td></td>
<td>18</td>
</tr>
<tr>
<td>Figure 3: Logical Interface Controller Tab</td>
<td></td>
<td>22</td>
</tr>
<tr>
<td>Figure 4: Physical Interface Controller Dialog</td>
<td></td>
<td>22</td>
</tr>
<tr>
<td>Figure 5: ICM Instance Dialog</td>
<td></td>
<td>47</td>
</tr>
<tr>
<td>Figure 6: Application Gateway List Window</td>
<td></td>
<td>56</td>
</tr>
<tr>
<td>Figure 7: Enter NAM Addresses Dialog</td>
<td></td>
<td>57</td>
</tr>
<tr>
<td>Figure 8: System Information Dialog</td>
<td></td>
<td>58</td>
</tr>
<tr>
<td>Figure 9: Call Type List Dialog</td>
<td></td>
<td>78</td>
</tr>
<tr>
<td>Figure 10: Dialed Number List Tool</td>
<td></td>
<td>79</td>
</tr>
<tr>
<td>Figure 11: Scheduled Target Explorer Tool</td>
<td></td>
<td>79</td>
</tr>
<tr>
<td>Figure 12: Label List Dialog</td>
<td></td>
<td>80</td>
</tr>
<tr>
<td>Figure 13: Network VRU Script List Tool</td>
<td></td>
<td>80</td>
</tr>
<tr>
<td>Figure 14: Example NAM Routing Script</td>
<td></td>
<td>84</td>
</tr>
<tr>
<td>Figure 15: NetworkTransferEnabled Set Variable Node</td>
<td></td>
<td>85</td>
</tr>
<tr>
<td>Figure 16: ECC Variable user.microapp.media_server Set Variable Node</td>
<td></td>
<td>86</td>
</tr>
<tr>
<td>Figure 17: ICM Gateway Properties - Send Tab</td>
<td></td>
<td>86</td>
</tr>
<tr>
<td>Figure 18: Changing the Queue Type to Enable Requery</td>
<td></td>
<td>89</td>
</tr>
<tr>
<td>Figure 19: RONA Scripting in IP Contact Center Hosted-Edition</td>
<td></td>
<td>89</td>
</tr>
<tr>
<td>Figure 20: Registry Editor on CallRouter</td>
<td></td>
<td>92</td>
</tr>
<tr>
<td>Figure 21: Historical Data Server Architecture</td>
<td></td>
<td>93</td>
</tr>
</tbody>
</table>
Preface

Purpose

This manual describes how to set up, run, and administer the Cisco Unified Contact Center Hosted (Unified CCH) product. It supplements the installation and configuration instructions in the general Cisco Unified Intelligent Contact Management (Unified ICM) software documentation set with specific instructions for installing, configuring, and upgrading software components.

Warning: You must have a copy of the Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted available in addition to this manual in order to successfully complete Unified CCH installation and configuration. Many of the details for installation are found only in the Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.

This guide also provides configuration settings to be used with the Cisco Unified Customer Voice Portal (Unified CVP) and Cisco Unified Communications Manager (Unified CM) applications.

Note: You must use the documentation provided with those systems to install the Unified CVP and Unified CM software.

Audience

This document is intended for managers and administrators working in a network service provider environment. Readers of this manual should already have a general understanding of the Unified CCH product. Readers must be familiar with general Unified ICM installation and setup procedures.
Organization

The manual is divided into the following chapters.

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1, Introduction to Cisco Unified Contact Center Hosted (page 7)</td>
<td>This chapter provides a brief description of the Unified CCH system and an explanation of its components.</td>
</tr>
<tr>
<td>Chapter 2, CICM Installation and Configuration (page 15)</td>
<td>This chapter discusses the procedures you need to perform to install and configure CICM.</td>
</tr>
<tr>
<td>Chapter 3, Cisco Unified Communications Manager Configuration (page 27)</td>
<td>The <a href="http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_maintenance_guides_list.html">Cisco Unified Communications Manager Administration Guide</a> provides detailed information for all of the topics in tasks explained in this section.</td>
</tr>
<tr>
<td>Chapter 4, Installing and Configuring Cisco Unified Customer Voice Portal for Cisco Unified Contact Center Hosted (page 35)</td>
<td>This chapter describes how to install and configure Unified CVP for queuing in your Unified CCH system.</td>
</tr>
<tr>
<td>Chapter 5, NAM Installation and Configuration for Cisco Unified Contact Center Hosted (page 41)</td>
<td>This chapter discusses the procedures you need to perform to install and configure a NAM system. These instructions assume that Windows—including SNMP and SQL Server are already installed, and that Windows Active Directory services for the system software, including at least one ICM instance, have been set up.</td>
</tr>
<tr>
<td>Chapter 6, Installing and Configuring CTI OS Server for Cisco Unified Contact Center Hosted (page 59)</td>
<td>This chapter provides CTI OS Server installation guidelines for Unified CCE.</td>
</tr>
<tr>
<td>Chapter 7, Installing and Configuring Outbound Option for Cisco Unified Contact Center Enterprise (page 65)</td>
<td>Outbound Option is a feature of Unified ICM that provides outbound dialing functionality along with the existing inbound the existing inbound capabilities of Unified ICM. With Outbound Option, contact centers can be configured for automated outbound activities. Agents who are not busy handling inbound requests can perform outbound calls, thereby maintaining a high level of agent productivity.</td>
</tr>
<tr>
<td>Chapter 8, Reporting Installation and Configuration for Cisco Unified Contact Center Hosted (page 69)</td>
<td>Unified IC is the reporting application for the Unified CCH environment.</td>
</tr>
<tr>
<td>Chapter 9, Installing and Configuring Cisco Multichannel Components for Cisco Unified Contact Center Hosted (page 71)</td>
<td>For information about installing and configuring Cisco multichannel components, refer to the Installation and Configuration Guide for Cisco Unified Contact Center Enterprise &amp; Hosted.</td>
</tr>
<tr>
<td>Chapter 10, Advanced Services and Feature Control (page 73)</td>
<td>Advanced Services allows service providers to offer call center routing services to end-customers independent of any end-customer equipment, such as ACDs, PBXs, key systems or even simple analogue phone lines. This section describes how to setup and administer an Advanced Services instance.</td>
</tr>
</tbody>
</table>
Chapter 11, Scripting Considerations (page 83) | This chapter covers scripting considerations to use in a Unified CCH system. For more details on scripting in a Cisco Unified Intelligent Contact Management Hosted (Unified ICMH) environment, refer to the Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted, as well as the Setup and Configuration Guide for Cisco Unified ICM Hosted.

Chapter 12, Security Considerations (page 91) | Unified CCH allows several customers to share the same Central Controller complex.

Related Documentation

Documentation for Cisco Unified ICM/Contact Center Enterprise & Hosted, as well as related documentation, is accessible from Cisco.com at: http://www.cisco.com/cisco/web/psa/default.html.

Related documentation includes the documentation sets for Cisco CTI Object Server (CTI OS), Cisco Agent Desktop (CAD), Cisco Agent Desktop Browser Edition (CAD-BE), Cisco Unified Contact Center Management Portal, Cisco Unified Customer Voice Portal (CVP), Cisco Unified IP IVR, Cisco Unified Intelligence Center. The following list provides more information.

- For documentation for the Cisco Unified Contact Center products mentioned above, go to http://www.cisco.com/cisco/web/psa/default.html, click Voice and Unified Communications, then click Customer Collaboration, and then click Cisco Unified Contact Center Products or Cisco Unified Voice Self-Service Products, then click the product or option you are interested in.

- For troubleshooting tips for the Cisco Unified Contact Center Products mentioned above, go to http://docwiki.cisco.com/wiki/Category:Troubleshooting, and then click the product or option you are interested in.

- Documentation for Cisco Unified Communications Manager is accessible from: http://www.cisco.com/cisco/web/psa/default.html.


- The Product Alert tool is accessible from (login required): http://www.cisco.com/cgi-bin/Support/FieldNoticeTool/field-notice.


Product Naming Conventions

In this release, the product names listed in the table below have changed. The New Name (long version) is reserved for the first instance of that product name and in all headings. The New Name (short version) is used for subsequent instances of the product name.

*Note:* This document uses the naming conventions provided in each GUI, which means that in some cases the old product name is in use.

<table>
<thead>
<tr>
<th>Old Product Name</th>
<th>New Name (long version)</th>
<th>New Name (short version)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco IPCC Enterprise Edition</td>
<td>Cisco Unified Contact Center Enterprise</td>
<td>Unified CCE</td>
</tr>
<tr>
<td>Cisco IPCC Hosted Edition</td>
<td>Cisco Unified Contact Center Hosted</td>
<td>Unified CCH</td>
</tr>
<tr>
<td>Cisco Intelligent Contact Management (ICM) Enterprise Edition</td>
<td>Cisco Unified Intelligent Contact Management Enterprise</td>
<td>Unified ICME</td>
</tr>
<tr>
<td>Cisco Intelligent Contact Management (ICM) Hosted Edition</td>
<td>Cisco Unified Intelligent Contact Management Hosted</td>
<td>Unified ICMH</td>
</tr>
<tr>
<td>Cisco Call Manager/Cisco Unified Call Manager</td>
<td>Cisco Unified Communications Manager</td>
<td>Unified CM</td>
</tr>
</tbody>
</table>

Conventions

This manual uses the following conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
</table>
| **boldface**   |Boldface font is used to indicate commands, such as user entries, keys, buttons, and folder and submenu names. For example:  
  - Choose **Edit > Find**.  
  - Click **Finish**.|
| **italic**     |Italic font is used to indicate the following:  
  - To introduce a new term; for example: A *skill group* is a collection of agents who share similar skills  
  - For emphasis; for example: *Do not* use the numerical naming convention  
  - A syntax value that the user must replace; for example: IF (*condition, true-value, false-value*)|
<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>• A book title; for example: Refer to the <em>Cisco CRS Installation Guide</em></td>
<td></td>
</tr>
<tr>
<td><strong>window font</strong></td>
<td>Window font, such as Courier, is used for the following:</td>
</tr>
<tr>
<td>• Text as it appears in code or that the window displays; for example: <code>&lt;html&gt;&lt;title&gt;Cisco Systems, Inc. &lt;/title&gt;&lt;/html&gt;</code></td>
<td></td>
</tr>
<tr>
<td>• Navigational text when selecting menu options; for example: ICM Configuration Manager &gt; Tools&gt; Explorer Tools &gt; Agent Explorer</td>
<td></td>
</tr>
<tr>
<td><code>&lt; &gt;</code></td>
<td>Angle brackets are used to indicate the following:</td>
</tr>
<tr>
<td>• For arguments where the context does not allow italic, such as ASCII output</td>
<td></td>
</tr>
<tr>
<td>• A character string that the user enters but that does not appear on the window such as a password</td>
<td></td>
</tr>
</tbody>
</table>

**Obtaining Documentation and Submitting a Service Request**

For information about obtaining documentation, submitting a service request, and gathering additional information, see the monthly *What's New in Cisco Product Documentation*, which also lists all new and revised Cisco technical documentation, at:


Subscribe to *What's New in Cisco Product Documentation* as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0.

**Documentation Feedback**

You can provide comments about this document by sending an email message to the following address:

ccbu_docfeedback@cisco.com (mailto:ccbu_docfeedback@cisco.com)

We appreciate your comments.
Introduction to Cisco Unified Contact Center Hosted

This chapter provides a brief description of the Unified CCH system and an explanation of its components.

This chapter contains the following topics:

- About Cisco Unified Contact Center Hosted, page 7
- About Cisco Unified Contact Center Hosted Hardware Components, page 8
- About Cisco Unified Contact Center Hosted Software Components, page 8
- Cisco Unified Contact Center Hosted Installation and Configuration Tasks, page 9

About Cisco Unified Contact Center Hosted

Unified CCH allows a network service provider to offer virtual call center services to its customers. Using Cisco Network Applications Manager (NAM), the carrier-class version of the Cisco Unified Intelligent Contact Management (Unified ICM) software, it distributes incoming calls to individual network service customers based on the number dialed, the call’s point of origin, and caller-entered digits.

The Unified ICM systems that are connected to the NAM are known as Customer ICMs, or CICMs. Often the phrase CICM is used to refer to a deployment where a single computer can host Unified ICM Central Controllers for multiple customers (up to 25, depending on the side of the Unified ICM system).

A single Unified CCH NAM can pass route requests to any of several CICMs. Based on the information it has for the call (dialed number, caller-entered digits, and calling line ID), Unified CCH can run a routing script that selects the appropriate CICM and sends it a route request.

A Unified CCH deployment usually involves refers to a specific deployment, where a multi-tenant CICM talks to a set of Unified CCH PGs and these PGs all talk to the same Unified CM. (The Unified CM is partitioned so that certain ranges of extensions belong to each customer.)
Multi-tenancy PG for Cisco Unified Contact Center Hosted

The generic PG allows multiple instances of the PG to be installed on the same physical server, each of which is connected to a single instance of Unified CM via JTAPI. Combined with multi-tenancy CTI OS, this feature allows service providers to deploy Unified CCH without the need for dedicated servers for each PG. For example, a service provider desiring to host 10 customers could install 10 instances of the Unified CCH PG and 10 instances of CTIOS all on a single box, and then perform comparable installation on a second box for the purpose of redundancy. (Total of 2 boxes for 10 customers.)

Multi-Tenant Outbound Option for Cisco Unified Contact Center Hosted

Release 8.0(1) of Outbound Option allows multiple customer instances to run Outbound Option in a Hosted environment. This new feature, known as Outbound Option Multi-Tenant, is available in Outbound Option deployments that use the SIP Dialer.

See Also

See the "Configuring Outbound Option Multi-Tenant Customer Instances (page 65)" section for more details.

About Cisco Unified Contact Center Hosted Hardware Components


About Cisco Unified Contact Center Hosted Software Components

This section briefly describes the software components of the Unified CCH system. For more detailed information regarding software components and Unified CCH architecture, refer to the Cisco Unified Contact Center Enterprise 8.0(x) Solution Reference Network Design (SRND) (http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_implementation_design_guides_list.html).

Cisco Unified Contact Center Hosted Core Components

The following core software components are required in all Unified CCH systems.

Table 1: Unified CCH Core Components

<table>
<thead>
<tr>
<th>Unified CCH Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unified CM</td>
<td>Unified CM provides features comparable with those of a traditional PBX system and handles the switching requirements of the Unified CCH system.</td>
</tr>
</tbody>
</table>
### Unified CCH Component Table

<table>
<thead>
<tr>
<th>Unified CCH Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>It allows deployment of voice applications and the integration of telephony</td>
</tr>
<tr>
<td></td>
<td>systems with Intranet applications.</td>
</tr>
<tr>
<td>Cisco Unified Customer Voice Portal (Unified CVP)</td>
<td>Unified CVP both provides Interactive Voice Response (IVR) and queuing capability in the Unified CCH system.</td>
</tr>
<tr>
<td>Cisco NAM software</td>
<td>Cisco NAM software provides intelligent multichannel contact routing and</td>
</tr>
<tr>
<td></td>
<td>ACD functionality, including monitoring and controlling agent state, CTI</td>
</tr>
<tr>
<td></td>
<td>capabilities, and gathering real-time and historical data for reporting in</td>
</tr>
<tr>
<td></td>
<td>the Unified CCH system.</td>
</tr>
<tr>
<td></td>
<td>The NAM software includes the CallRouter, Logger, Peripheral Gateway(s) for</td>
</tr>
<tr>
<td></td>
<td>Unified CM and VRU PIMs, CTI Server, and Administration &amp; Data Server.</td>
</tr>
<tr>
<td>Cisco CTI Object Server</td>
<td>Cisco CTI Object Server (CTI OS) is a server-based CTI solution that provides</td>
</tr>
<tr>
<td></td>
<td>desktops used by contact center agents and supervisors.</td>
</tr>
<tr>
<td></td>
<td>CTI OS includes the CTI OS Server, CTI OS Agent Desktop, Unified CCH</td>
</tr>
<tr>
<td></td>
<td>Supervisor Desktop, CTI OS Toolkit, and Client Interface Library (CIL).</td>
</tr>
<tr>
<td>Customer ICM (CICM)</td>
<td>The Customer ICM (CICM) duplicates the functionality of the Cisco NAM</td>
</tr>
<tr>
<td></td>
<td>software.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> See Chapter 2, &quot;CICM Installation and Configuration (page 15),&quot; for</td>
</tr>
<tr>
<td></td>
<td>CICM configuration instructions.</td>
</tr>
</tbody>
</table>

### Cisco Unified Contact Center Hosted Installation and Configuration Tasks

Setting up an Unified CCH system involves a significant number of installation and configuration tasks. This section includes task checklists designed to help you track your progress as you install and configure Unified CCH. These checklists apply to both production and laboratory deployments.

This chapter contains these sections:

- **Hardware Installation Checklist (page 9)**
- **Unified CCH Component Software Installation Checklist (page 10)**
- **Unified CCH Component Software Configuration Tasks (page 12)**
- **Unified CCH Production Environment Worksheet (page 13)**

### Hardware Installation Checklist

This section lists the basic order or Unified CCH component hardware installation. For hardware installation instructions, see the documentation packaged with each component.
Table 2: Hardware Installation Checklist

<table>
<thead>
<tr>
<th>Task</th>
<th>Notes</th>
<th>Done?</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Install the Media Convergence Server(s) for Unified CM</td>
<td>Hardware and OS requirements for these servers are available from their respective Hardware Bills of Materials (see link below table). Network architecture requirements are described in the <em>Cisco Unified Contact Center Enterprise 8.0(x) Solution Reference Network Design (SRND)</em> at <a href="http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_implementation_design_guides_list.html">http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_implementation_design_guides_list.html</a>.</td>
<td></td>
</tr>
<tr>
<td>2. Install Unified ICM, the PG, Unified CVP, and CTI OS</td>
<td>Hardware and OS requirements for these servers are available from their respective Hardware Bills of Materials (see link below table). Network architecture requirements are described in the <em>Cisco Unified Contact Center Enterprise 8.0(x) Solution Reference Network Design (SRND)</em> at <a href="http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_implementation_design_guides_list.html">http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_implementation_design_guides_list.html</a>.</td>
<td></td>
</tr>
<tr>
<td>3. Install IP phones. Configure each IP phone with an IP address.</td>
<td>Install the IP phones after installing Unified CM. If you are configuring the phones through auto-registration, also enable auto-registration on Unified CM before installing the phones. Refer to the user documentation for your phone for information on IP address configuration requirements. Refer to the <a href="http://tools.cisco.com/ITDIT/vtgsca/VTGServlet">Cisco Unified Communications Compatibility Tool</a> for a list of supported IP Phones.</td>
<td></td>
</tr>
</tbody>
</table>


Cisco Unified Contact Center Hosted Component Software Installation Checklist

This section lists the installation tasks for the Unified CCH software components.

**Note:** For the list of Cisco IP Phone and Unified CCH component (for example, Unified ICM, Unified CM) versions supported by Unified CCH 8.0(1), refer to the [Cisco Unified Communications Compatibility Tool](http://tools.cisco.com/ITDIT/vtgsca/VTGServlet). The Cisco Unified Communications Compatibility Tool is updated regularly to reflect subsequent component releases and services releases.

Table 3: Unified CCH Software Installation Checklist

<table>
<thead>
<tr>
<th>Unified CCH Installation Task</th>
<th>Unified CCH Installation Notes</th>
<th>Done?</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Install Unified CM.</td>
<td>See Chapter 3, Cisco Unified Communications Manager Configuration (page 27) for details.</td>
<td></td>
</tr>
<tr>
<td>On the Unified CM, you must:</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

4) [http://tools.cisco.com/ITDIT/vtgsca/VTGServlet](http://tools.cisco.com/ITDIT/vtgsca/VTGServlet)
<table>
<thead>
<tr>
<th>Unified CCH Installation Task</th>
<th>Unified CCH Installation Notes</th>
<th>Done?</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Configure one CTI Route Point for each post route number and/or one for each translation route DNIS.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2. Create a Unified CM PG user and associate the user with CTI Route Point(s) and CTI Port(s).</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3. Enable CTI OS for the Unified CM PG user.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4. Configure the Unified CVP Voice Browser as a Gateway on Unified CM.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2. Install NAM software, including the CallRouter, Logger, Administration &amp; Data Server, and Historical Data Server (HDS) database, and the PG containing the VRU PIM(s).</td>
<td>See Chapter 5, NAM Installation and Configuration for Cisco Unified Contact Center Hosted (page 41) for details.</td>
<td></td>
</tr>
<tr>
<td>3. Configure a Generic Unified CCH PG in Unified ICM.</td>
<td>This guide provides instructions for installing both the Unified CM and VRU PIMs on a single PG known as the Generic Unified CCH PG. While not described, you can also install the CallManager and VRU PIMs on separate PGs.</td>
<td></td>
</tr>
<tr>
<td>4. Install the Generic Unified CCH PG.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5. Install JTAPI Client on the Generic Unified CCH PG.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6. Install the Unified CVP software.</td>
<td>See Chapter 4, Installing and Configuring Cisco Unified Customer Voice Portal for Cisco Unified Contact Center Hosted (page 35) for details.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you are deploying a Unified CCH laboratory system, you can install all Unified CVP components on a single machine and must install all components at the same time.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you are deploying a Unified CCH production system, you can install individual components on different machines. To maximize performance, refer to the Unified Customer Voice Portal (CVP) Solution Reference Network Design (SRND) for details.</td>
<td></td>
</tr>
<tr>
<td>7. Install CTI Server.</td>
<td>See Chapter 6, Installing and Configuring CTI OS Server for Cisco Unified Contact Center Hosted (page 59) for details.</td>
<td></td>
</tr>
</tbody>
</table>

---

Unified CCH Installation Task | Unified CCH Installation Notes | Done?
--- | --- | ---
The CTI Server is a Unified ICM component that allows an external CTI application to communicate with a PG. The CTI Server is part of the Cisco Enterprise CTI product. You can install the CTI Server on the same machine as the Peripheral Gateway software or on a separate machine.
8. Install CTI OS or Cisco Agent Desktop software. | There are no Unified CCH-specific installation instructions for CTI OS. |
9. Install one or more customers on the shared CICM. | See Chapter 2, "CICM Installation and Configuration (page 15)," for CICM configuration instructions. |

For additional information, refer to the following documents:


Cisco Unified Contact Center Hosted Component Software Configuration Tasks

Subsequent chapters in this book guide you through configuring each Unified CCH component/functionality area. Each chapter contains a list of the configuration tasks for that component, as well as a list of prerequisites that must be met before that component can be configured.
Table 4: Software Configuration Tasks

<table>
<thead>
<tr>
<th>Unified CCH Configuration Task</th>
<th>Described In</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Configure the CICM customer instance.</td>
<td>Chapter 2, CICM Installation and Configuration (page 15)</td>
</tr>
<tr>
<td>2. Configure Unified CM.</td>
<td>Chapter 3, Cisco Unified Communications Manager Configuration (page 27)</td>
</tr>
<tr>
<td>3. Configure NAM.</td>
<td>Chapter 5, NAM Installation and Configuration for Cisco Unified Contact Center Hosted (page 41)</td>
</tr>
<tr>
<td>4. Configure Unified CVP.</td>
<td>Chapter 4, Installing and Configuring Cisco Unified Customer Voice Portal for Cisco Unified Contact Center Hosted (page 35)</td>
</tr>
<tr>
<td>6. Configure WebView.</td>
<td>Chapter 8, WebView Installation and Configuration for Cisco Unified Contact Center Hosted (page 69)</td>
</tr>
</tbody>
</table>

Cisco Unified Contact Center Hosted Production Environment Worksheet

You can use the table below as a worksheet to record the values you enter on each Unified CCH component during installation and configuration. In the table, cells containing an "X" indicate configuration items that do not pertain to a specific component.

If the worksheet does not contain enough rows for you to enter all of your configuration values (for example, you configure 30 agents and the worksheet contains only two rows for agents), you can use the worksheet to indicate a file containing all of the values for that item.

Table 5: Unified CCH Production Environment Worksheet

<table>
<thead>
<tr>
<th>Item</th>
<th>Unified CM</th>
<th>Unified CVP</th>
<th>NAM</th>
<th>CICM</th>
<th>CTI OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Telephone</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Telephone</td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTI Route Point</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>CTI Route Point</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>CTI Route Point</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTI Port</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTI Port</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTI Port</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTI Port</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTI Port</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Item</th>
<th>Unified CM</th>
<th>Unified CVP</th>
<th>NAM</th>
<th>CICM</th>
<th>CTI OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unified CM JTAPI User</td>
<td>X</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco Unified IP-IVR JTAPI User</td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTI Port Group number</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IVR Flow</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IVR Flow</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>VRU Connection Port</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unified CM PG Name</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unified CM PIM Name</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Logical Controller ID#</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peripheral ID#</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTI Server Connection Port</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Network VRU Name</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unified CM PG Peripheral Name</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unified CM PG Network Trunk</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unified CM PG Trunk Group</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ConAPI Connections (registry port)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Service Name</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Service Number</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SVC Virtual Ext.#</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skill Group #1 Name</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skill Group Number</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SG Virtual Ext.#</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skill Group #2 Name</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skill Group Number</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SG Virtual Ext.#</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Agent Name</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Agent Number</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Agent Name</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Agent Number</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
CICM Installation and Configuration

This chapter discusses the procedures you need to perform to install and configure CICM.

Note:

• You must have a copy of the *Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted* available in addition to this manual in order to successfully complete CICM configuration.

• If you are installing and configuring CICM systems that will be part of a Multiple-NAM configuration, also refer to the installation and configuration instructions in the *Multiple-NAM Setup and Configuration Guide for Cisco Unified ICM Hosted*.

This chapter contains the following topics:

- Introduction to Instances, page 15
- Naming Conventions for Instances, page 16
- Selecting the CICM Complex, page 16
- Assigning an Instance Number to a CICM, page 17
- Installing and Configuring CICM Loggers, page 19
- Installing and Configuring CICM CallRouters, page 20
- Installing a CICM Network Administration & Data Server, page 20
- Configuring the CICM's INCRP NIC, page 21
- Quality of Service (QoS), page 25
- Adding and Upgrading Components for Instances, page 25

Introduction to Instances

In a NAM environment, each duplexed CICM system serves up to 25 instances. Each instance is associated with one duplexed CICM system.

As mentioned earlier, a CICM complex is a single hardware platform on which multiple CICM instances may reside. Each instance, in turn, can be shared by several customers with limited
functionality. As new instances are added to the system, you must install additional Unified ICM components (Loggers, CallRouters, and Administration & Data Servers) on the CICM machines.

Adding a new instance to a CICM complex consists of several tasks.

- Deciding on the instance name
- Selecting the CICM complex to service the instance
- Assigning an instance number
- Setting up the CICM Loggers
- Setting up the CICM CallRouters
- Setting up the CICM instance Administration & Data Server on the NAM
- Configuring the INCRP NIC

The following subsections explain these steps. After completing these steps you can proceed to set up Peripheral Gateways and Administration & Data Servers at the customer premises.

Naming Conventions for Instances

Select a unique instance name of up to five characters. The first character of the name must be a letter (a–z or A–Z). Subsequent characters can be letters, digits, or the symbols # or $. The name must not contain spaces.

You cannot use case to differentiate instances. For example, you cannot name two instances cus01 and Cus01. When forming database names, the system software converts the instance name to all lowercase.

The instance name is used in naming a registry subtree, a subdirectory of the \icm directory, and as a prefix on database names. For an instance named cust1, the CICM databases are named cust1_sideA and cust1_sideB. The local database on an Administration & Data Server is named cust1_awdb.

Selecting the CICM Complex

Select which CICM complex will service this instance. Consider the current load on each CICM complex and the expected load for the new instance. Usually it is best to roughly balance the overall load among available CICM complexes. If all CICM complexes are nearing capacity, consider adding a new CICM complex.
Assigning an Instance Number to a CICM

Each instance within a CICM complex must have a unique instance number. The same number must be used to identify the instance on each machine in the CICM complex.

How to See Instance Numbers Currently in Use

Step 1
On any Administration & Data Server in the CICM complex, select Start > Run. The Run dialog box appears.

Step 2
Type `instanceno.exe` in the Open field and click OK. (This executable is installed in the `\icm\bin` directory on every Administration & Data Server.) The Name Fragment dialog box appears.

![Figure 1: Name Fragment Dialog](image)

Step 3
Specify the machine name fragment that is used in all machines on your site. (For example, if Logger A is named CSOXYZLGRA, enter XYZ.)

Step 4
If the system is simplex, check the Simplex option and choose side A or B.

Step 5
Click OK. The system checks each CallRouter and Logger to find which instance numbers are in use. It then displays a screen similar to the following:
Figure 2: Instance Number Values Dialog

<table>
<thead>
<tr>
<th>Instance Name</th>
<th>Router A</th>
<th>Router B</th>
<th>Logger A</th>
<th>Logger B</th>
</tr>
</thead>
<tbody>
<tr>
<td>mid1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>mid2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>mid3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>mid4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>mid5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>mid6</td>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
</tr>
<tr>
<td>mid7</td>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
</tr>
<tr>
<td>mid8</td>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
</tr>
<tr>
<td>mid9</td>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
</tr>
<tr>
<td>mid10</td>
<td>10</td>
<td>10</td>
<td>10</td>
<td>10</td>
</tr>
<tr>
<td>mid11</td>
<td>11</td>
<td>11</td>
<td>11</td>
<td>11</td>
</tr>
<tr>
<td>mid12</td>
<td>12</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>mid13</td>
<td>13</td>
<td>13</td>
<td>13</td>
<td>13</td>
</tr>
<tr>
<td>mid14</td>
<td>14</td>
<td>14</td>
<td>14</td>
<td>14</td>
</tr>
<tr>
<td>mid15</td>
<td>15</td>
<td>15</td>
<td>15</td>
<td>15</td>
</tr>
<tr>
<td>mid16</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
</tr>
<tr>
<td>mid17</td>
<td>17</td>
<td>17</td>
<td>17</td>
<td>17</td>
</tr>
<tr>
<td>mid18</td>
<td>18</td>
<td>18</td>
<td>18</td>
<td>18</td>
</tr>
<tr>
<td>mid19</td>
<td>19</td>
<td>19</td>
<td>19</td>
<td>19</td>
</tr>
<tr>
<td>mid20</td>
<td>20</td>
<td>20</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>mid21</td>
<td>21</td>
<td>21</td>
<td>21</td>
<td>21</td>
</tr>
<tr>
<td>mid22</td>
<td>22</td>
<td>22</td>
<td>22</td>
<td>22</td>
</tr>
<tr>
<td>mid23</td>
<td>23</td>
<td>23</td>
<td>23</td>
<td>23</td>
</tr>
<tr>
<td>mid24</td>
<td>24</td>
<td>24</td>
<td>24</td>
<td>24</td>
</tr>
<tr>
<td>ser0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

A value of –1 indicates that the instance is not defined on that machine. The field at the bottom of the window specifies which instance numbers are available for use.

**Step 6** Take note of the available numbers so you can use one of them for the new instance. You must use this same number when adding the instance to each machine.

**Step 7** Click Close.

---

**How to Add an Instance to a CICM**

**Step 1** On a CICM, open the Web Setup tool.

**Step 2** Click **Instance Management** in the left frame, then click **Add** in the right frame. An Add Instance page appears.

**Step 3** From the drop-down lists, select a facility and an instance.

**Step 4** Enter the instance number you chose previously.

**Step 5** Click **Save** to add the instance.
Installing and Configuring CICM Loggers

You must perform the following steps to install and configure a Logger in a CICM domain.

**Note:** If a Logger is duplexed, perform these steps on each side. Be careful to use the same instance name and instance number on both sides.

How to Install and Configure a CICM Logger (Side A or Side B)

**Step 1** Create the central database on the Logger machine using the ICMDBA utility.

**Step 2** Open the Web Setup tool.

**Step 3** Select Component Management > Loggers in the left frame, then click Add in the right frame. The Add Logger Deployments page appears.

**Step 4** On this page, be sure to select Hosted > Customer ICM (CICM) for Logger Type.

**Step 5** Provide values for the other fields on this page. Click Next.

**Step 6** Provide values for the applicable fields on the Central Controller Connectivity and Additional Options page. Clicking Next from the Additional Options page takes you to a NAM page.

**Step 7** On the NAM page, select one of the following values for NAM Type:

a. Provisioning/Standalone NAM: NAM Logger is either a Standalone NAM or a NAM that provides Slave NAMs with configuration information

b. Slave NAM: NAM Logger that obtains configuration information from a Provisioning NAM

**Step 8** Provide the following values in the NAM Configuration section:

a. Provisioning/Standalone Router Side A: Enter the Side A machine name or IP address of the provisioning Router

b. Provisioning/Standalone Router Side B: If a Side B machine exists, enter the Side B machine name or IP address of the provisioning Router

**Step 9** If you specified a NAM Type of Provisioning/Standalone NAM, skip the Slave NAM Configuration section. If you specified a NAM Type of Slave NAM, specify the following information:

a. Provisioning NAM Instance Name: The instance name of the Provisioning NAM

b. Provisioning NAM Instance Number: The instance number of the Provisioning NAM
Installing and Configuring CICM CallRouters

You must perform the following steps to install and configure a CallRouter in a CICM domain.

Note:

• You must set up the instance on the Logger machines before the CallRouter machines.

• If a CallRouter is duplexed, perform these steps on each side. Be careful to use the same instance name and instance number on both sides.

How to Install and Configure CICM CallRouter Software

Step 1 Open the Web Setup tool.

Step 2 Select Component Management > Routers in the left frame, then click Add in the right frame.

Step 3 Click Next.

Step 4 Complete the CallRouter setup.

Note: If a CallRouter is duplexed, perform these steps on each side. Be careful to use the same instance name and instance number on both sides.

Installing a CICM Network Administration & Data Server

To create configuration data for an instance, you must add the instance to a CICM Network Administration & Data Server.
How to Install a CICM Network Administration & Data Server

**Step 1**  
Open the Web Setup tool.

**Step 2**  
Select **Component Management > Administration & Data Servers** in the left frame, then click **Add** in the right frame.

**Step 3**  
In the first Add Administration & Data Server page, select **Hosted** for the Deployment Type, and also select **Network Administration & Data Server for Customer ICM (CICM)**.

**Step 4**  
Supply values for the other fields in this window, then click **Next**.

**Step 5**  
Complete the rest of the Administration & Data Server setup.

### Configuring the CICM’s INCRP NIC

The NAM communicates with the CICM by means of an INCRP NIC. To set up the INCRP NIC for each instance on the CICM, you must perform the following tasks:

- Define the INCRP NIC using the NIC Explorer tool (page 21)
- Add CallRouter configuration information using the Web Setup tool (page 23)

### How to Define the INCRP NIC

**Note:** The preferred network for this connection is the Public/Visible or SAN network. When using the SAN network, it must have a WAN link between Side A and B (SAN was originally intended for the CallRouter to Network Gateway connection, which does not cross the A/B boundary).

**Step 1**  
Access the Select Administration Instance tool by selecting **Start > All Programs > Cisco Unified CCE Tools > Administration Tools > Select Administration Instance**. The Select Administration Instance window displays.

**Step 2**  
Select the instance you will be configuring.

**Step 3**  
From the Configuration Manager, open the NIC Explorer tool by selecting **Tools > Explorer Tools > NIC Explorer**. The NIC Explorer window displays.

**Step 4**  
In the Select filter data box, click **Retrieve**. This enables the **Add NIC** button.

**Step 5**  
Click **Add NIC**. A new NIC and its routing client display in the tree window. Next to each is a **To Be Inserted** icon.
On the right of the tree window, tabbed fields also display for the new NIC's and routing client's configuration information.

**Step 6** Enter the following in the Logical Interface Controller tab fields:

- **Name.** An enterprise name that will serve as the NIC name. The name can be up to 32 characters. The valid characters are upper-case and lower-case letters, digits, periods (.) and underlines (_). The first character of the name must be a letter or digit.

- **Client Type (drop-down list).** The type of routing client serviced by the NIC. Select **INCRP**.

  **Note:** Selecting a type of routing client automatically places that type's default values in the Routing Client's Timeout Threshold, Late Threshold, Timeout Limit, Use DN/Label Map, and Client Type fields.

**Figure 3: Logical Interface Controller Tab**

![Logical Interface Controller Tab](image)

**Step 7** Click the **Add Physical Interface Controller** button. The Physical Interface Controller dialog displays.

**Figure 4: Physical Interface Controller Dialog**

![Physical Interface Controller Dialog](image)

**Step 8** In the Create Single Physical Interface Controller section, specify an **Enterprise Name** and, optionally, a **Description**.

**Step 9** Click **OK**. The Physical Interface Controller tab displays, displaying the information you specified, and an ID value of UNASSIGNED.
Step 10 Click the Add Routing Client button, and enter the following on the Routing Client tab fields:

• **Name**. An enterprise name that will serve as the NIC Routing Client name. The name can be up to 32 characters. The valid characters are upper-case and lower-case letters, digits, periods (.) and underlines (_). The first character of the name must be a letter or digit.

• **Client Type** (drop-down list). The type of routing client that ultimately routes the call on the requesting NAM.

  **Note**: This field is enabled only for the routing client associated with an INCRP NIC.

If your NAM has multiple routing clients, ensure that each client is defined and that the ClientType field in the Routing Client record matches the client type of the NAM's NIC. In addition, the Configuration Parameter field for each record must contain the parameter:

```
/CustomerID <RCID>
```

where `<RCID>` is the Routing Client ID of the matching routing client on the NAM, as defined in the SQL table.

**Note**: For instructions on how to update a record in the Configuration Manager, refer to the Configuration Guide for Cisco Unified ICM/Contact Center Enterprise and Hosted.

Step 11 If desired, define security settings on the records.

Step 12 Click **Save**. The newly defined NIC is saved in the database, a Physical Controller ID is assigned, and the To Be Inserted icon is removed from the tree window.

  **Note**: Make a note of the Physical Controller ID value. You need this value to set up the INCRP NIC on the CallRouter. If the NIC is duplexed, you need both Physical Controller ID values.

Step 13 Click **Close** to exit the NIC Explorer tool.

---

**How to Complete the INCRP NIC Setup**

To provide detailed set-up information for the NIC, do the following:

Step 1 Open the Web Setup tool.

Step 2 Select Component Management > Routers > Network Interface Controllers in the left frame, then click Add in the right frame. The Add Network Interface Controllers Deployments page displays.

Step 3 Select a value for the Instance.

Step 4 On the Network Interface Controller pull-down menu, select **INCRP**.

Step 5 Click Next. The Properties page displays.
Step 6 Specify the following values:

a. **Physical Interface Controller ID**: Enter one of the physical controller IDs (from the Configuration Manager) for the INCRP NIC on the CICM. If the NIC is duplexed, be sure to enter a different physical controller ID on each side.

b. **Local Hostname or IP Address**: Enter the IP Name (IP Address or hostname) of the local address for incoming NAM connections. (Note that this address/host must be on the same network as the NAM Addresses.)

c. **Handshake Timeout (ms)**: Enter the milliseconds to wait for a handshake response from the routing client (the supplied default of 5000 milliseconds is usually appropriate).

Step 7 Click **Next**. The Client ICM/CCE/CCH page displays.

Step 8 Enter the following information:

a. **Enabled**: Check the box to enable the Client ICM.

b. **Description**: Enter a description of the Client ICM.

c. **Client ID**: Enter the ID of the Client ICM machine. In this case, that is the same as the NAM ID.

d. **AppGateway ID**: Specify the ApplicationGatewayID for the INCRP NIC as configured in the Client ICM database.

e. **SCP Side A IP Address/Hostname**: Enter the Public Network (or SAN) addresses/hostnames of the NAM on Side A.

f. **SCP Side B IP Address/Hostname**: Enter the Public Network (or SAN) addresses/hostnames of the NAM on Side B.

Step 9 Click **Next**, then click **Finish** to complete INCRP NIC installation.

**Note**: You need not set up DMP devices for the INCRP NIC, because it is a process on the CallRouter rather than a separate device.

**Consideration for Multiple NAM/CICM Routing Clients**

For multiple NAM/CICM routing client configurations that will use CICM Replication, you must associate a routing client on the CICM for each routing client on the NAM for that customer. You cannot use the same name for two different routing clients on the CICM or NAM.

For example:

- A NAM system has two routing clients with enterprise names XYZ_NIC_1 and INAP_NIC_1. The XYZ_NIC_1 routing client has a network routing client of XYZ_NIC, and the INAP_NIC_1 routing client has a network routing client of INAP_NIC.
• The associated CICM system has two routing clients with enterprise names INCRP_NIC_1 and INCRP_NIC_2.

• For these routing clients on the CICM, you must define network routing clients of XYZ_NIC and INAP_NIC, respectively.

**Note:** Because routes are not normally defined on the NAM, a default route for a dialed number cannot be set on the NAM. However, labels are defined on both the NAM and the CICM. Therefore, dialed numbers have default labels rather than default routes.

### Quality of Service (QoS)

If you wish to use the optional Unified ICM Quality of Service feature, the appropriate steps are provided in the *Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted*, with discussion of QoS to be found in the *Pre-installation Planning Guide for Cisco Unified ICM Enterprise and Hosted*. However, note the following if you are using the Microsoft Packet Scheduler.

As all ICM instances of a CICM share, by design, public and private network interfaces, and the Microsoft Packet Scheduler is mapped to an address / interface, it follows that ICM instances hosted in a common physical CICM complex must be uniformly configured when deploying QoS.

**Note:** The configuration settings of the last customer configured via the Web Setup tool will be those in effect.

### Adding and Upgrading Components for Instances

To add or upgrade components for instances, do one of the following:

• To add a new component for an instance, run the Web Setup tool. From the initial Web Setup page, click **Component Management** in the left column. Under Component Management, click the type of component you want to add; a List page for the component appears. Click **Add** on this List page to start the Add wizard for the component.

• To upgrade all installed components for all instances, rerun the main installation program (setup.exe) from the Release 8.0(1) ICM/CCE/CCH DVD. Refer to the *Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted* for instructions.

### Removing an Instance

The following steps describe the process for removing an instance.

**Step 1** Use the Service Control utility to stop the services for that instance on all CICM machines and Administration & Data Servers.
### Adding and Upgrading Components for Instances

<table>
<thead>
<tr>
<th>Step 2</th>
<th>Run the Web Setup tool.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 3</td>
<td>Click <strong>Instance Management</strong> in the left column. An Instance List page appears.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Check the check box to the left of the instance(s) you want to remove.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Click <strong>Remove</strong> to remove the instance(s).</td>
</tr>
</tbody>
</table>
Chapter 3

Cisco Unified Communications Manager Configuration

The [Cisco Unified Communications Manager Administration Guide](http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_maintenance_guides_list.html) provides detailed information for all of the topics in tasks explained in this section.

This chapter contains the following topics:

- Cisco Unified Communications Manager Configuration, page 27
- Setting Up Duplicate Extensions in Different Customer Instances, page 33

Cisco Unified Communications Manager Configuration

**Note:** The following tasks assume that the initial installation of the Unified CM has been completed.

Follow the installation instructions in the [Installing Cisco Unified Communications Manager](http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_installation_guides_list.html) guide to install your Unified CM.

Follow the upgrade instructions in the [Cisco Unified Communications Operating System Administration Guide](http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_maintenance_guides_list.html) to upgrade your Unified CM.

**Installing Cisco Unified Communications Manager**

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Stop the PG Services associated with the Unified CM.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Install the JTAPI Plugin on the PG.</td>
</tr>
</tbody>
</table>
**Step 3**
Enable Unified CM PIMs.

**Step 4**
Verify Unified CM PG PIM services are active.

---

**Stopping Cisco Unified Communications Manager Associated PG Services**

**Step 1**
On the PG associated with the Unified CM:

a. Open Unified CCE Service Control for the CICM.

b. Select the PG service associated with the Unified CM.

c. Click **Stop** to stop the service.

**Step 2**
On the CTI Server associated with the Unified CM:

a. Open Unified CCE Service Control.

b. Select the PG service associated with the Unified CM.

c. Click **Stop** to stop the service.

---

**Configuring Agent Phones in Cisco Unified Communications Manager**

Before you can configure phones in Unified CM, each IP phone that you use with Unified CCH requires an IP address. IP addresses can be assigned either dynamically or manually (statically). Configuring an IP address may also be involved assigning a default gateway, assigning a subnet mask, and assigning a Domain Name. Refer to the user documentation for your phone for information on IP address configuration requirements.

In Unified CM, you must configure one directory number (extension) for each agent. Multiple extensions for an agent are not currently supported. You must configure an agent phone and then associate the phone with the Unified CM PG user.

**Step 1**
From the Unified CM Administration window, select **Device > Phone**.

**Step 2**
On the Find and List Phone page, enter the search criteria to list the registered phones. When the list displays, double-click the phone icon in the Device Name column to display the Phone Configuration window. Check that the Device Information is correct.

**Step 3**
Click on the Line 1 to configure the Directory Number for the device.

**Step 4**
You must disable call waiting on all agent phones. This is done to ensure that forward on busy option is available. You can do this most easily by setting the Unified CM system default for Call Waiting Enable to **off**. If this is not practical due to, for example, other agents that are configured on the Unified CM that require call waiting, then you can set individual agent phones to disable call waiting by selecting the line from the phone configuration page for each phone.
Configure CTI Route Points

Step 1  From the Unified CM Administration window, select Device > CTI Route Point.

The Find and List CTI Route Point window displays.

Step 2  Select Add New.

The CTI Route Point Configuration page displays.

Step 3  Enter the Route Point in the Device Name field.

Step 4  Enter a brief description in the Description field.

Step 5  Select Default from the Device Pool drop-down list.

Step 6  Click Save.

A message displays.

Step 7  Click Save.

A link displays where you can add a line.

Step 8  Click Save.

Step 9  Verify the CTI Route Point when finished by viewing the CTI Route Point Configuration fields.

Create CICM Cisco Unified Communications Manager PG User (Cisco Unified Communications Manager JTAPI User)

You must create a User on the Unified CM for each CICM Unified CM PG.

Step 1  From the Unified CM Administration window, select User > End User.

The Find and List End User window displays.

Step 2  Click Add New.

Step 3  In the UserID field, enter the User ID, and in the User Password field, enter the password. For the Unified CM peripheral gateway (PG) user, these must be the same as the JTAPI user in defined during the setup process. For the Cisco Unified IP-IVR (Unified IP IVR) User, the information must match Unified IP IVR configuration.

Step 4  In the PIN field, enter an IP phone password (at least five characters) and then enter it again in the Confirm PIN field.
Step 5  Select the **Enable CTI Application Use** checkbox.

Step 6  Click **Insert**.

The window changes.

Step 7  To put the user and the route point together you must associate the devices. Click **Device Association** and then click **Select Devices**.

All the Device names and extensions appear.

Step 8  Select all of the devices that you want this user to control. The Unified CM PG User controls the IP phones; the Unified IP IVR User controls the Route Points for Unified IP IVR DNs and the Ports.

Step 9  Select the **No Primary Extension** radio button.

Step 10  Click **Save**.

---

**Cisco Unified Communications Manager Multi-tenancy Configuration**

Unified CM clusters in Unified CCH can be shared across multiple servers. However, special configuration must take place to ensure that calls can not be inadvertently transferred between server instances. Single multiple customer instances can exist on a single Unified CM cluster, so you need to configure Unified CM for multi-tenancy.

Multi-tenancy in Unified CM is achieved by using Route Plan Partitions and Calling Search Spaces to restrict direct calls between customer instances.

The following sections describe Partitions and Calling Search Spaces, and how they can be used in multi-tenant situations.

**Partitions and Calling Search Spaces**

A partition comprises a logical grouping of directory numbers (DNs) and route patterns with similar reachability characteristics. Devices that are typically placed in partitions include DNs and route patterns. These entities associate with DNs that users dial. For simplicity, partition names usually reflect their characteristics, such as “NYLongDistancePT,” “NY911PT,” and so on.

A calling search space comprises an ordered list of partitions that users can look at before users are allowed to place a call. Calling search spaces determine the partitions that calling devices, including IP phones, soft phones, and gateways can search when attempting to complete a call.

When a calling search space is assigned to a device, the list of partitions in the calling search space comprises only the partitions that the device is allowed to reach. All other DNs that are in partitions not in the device calling search space receive a busy signal.

Partitions and calling search spaces address three specific problems:
Routing by geographical location
Routing by tenant
Routing by class of user

Partitions and calling search spaces provide a way to segregate the global dialable address space. The global dialable address space comprises the complete set of dialing patterns to which the Unified CM can respond.

Partitions do not significantly impact the performance of digit analysis, but every partition that is specified in a calling device search space does require that an additional analysis pass through the analysis data structures. The digit analysis process looks through every partition in a calling search space for the best match. The order of the partitions that are listed in the calling search space serves only to break ties when equally good matches occur in two different partitions. If no partition is specified for a pattern, the pattern goes in the null partition to resolve dialed digits. Digit analysis always looks through the null partition last.

In a typical Unified CCH system you will create partitions for your different dialing options, for example: US_National, US_International, and US_Emergency, as well as creating a partition for each customer instance, for example: Customer_1, Customer_2, and Customer_3. Once you have created the partitions, you can then create Calling Search Spaces to limit the dialability for each customer. The following table represents a basic Calling Search Space configuration in Unified CCH:

<table>
<thead>
<tr>
<th>CallingSearch Space</th>
<th>Dialable Partitions (highest priority first)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gateway_CSS</td>
<td>customer2_partition, customer2_partition</td>
</tr>
</tbody>
</table>

Individual phones are associated with a calling search space. A Manager’s phone might be connected to the Customer1_Manager_CSS Calling search space. This allows the user of that phone to make national, international, emergency, and calls to other phones in the search space, but it does not allow for calls to be places directly to phones in the Customer2_Partition Route Plan Partition.

When setting up your Unified CM keep in mind the need to create customer-instance specific partitions and Calling Search Spaces that limit interaction between customer instances.

Multi-tenancy Configuration

To enable multi-tenancy you must create separate partitions for each customer instance in addition to the normal partitions required for a Unified CM system.

Adding a Partition


**Step 1**
In the Unified CM Administration window, select Call Routing > Class of Control > Partition.

**Step 2**
Click Add New.

The Add Partition window displays.

**Step 3**
Enter a name in the partition name and description box.

Ensure each partition name is unique to the route plan. Partition names can contain alphanumeric characters, as well as spaces, hyphens (-), and underscore characters (_).

**Note:** The length of the partition names limits the maximum number of partitions that can be added to a calling search space. Follow the partition name by a comma (,); then, enter a description on the same line as the Partition Name. If you do not enter a description, Unified CM automatically enters the partition name in this field. Use a new line for each partition and description.

**Step 4**
Click Save to add the new partition(s).

**Note:** You can configure multiple partitions. To enter multiple partitions, use one line for each partition entry. You can enter up to 75 partitions; the names and descriptions can have a total of up to 1475 characters. Use a comma (,) to separate the partition name and description on each line. If you do not enter a description, Unified CM uses the name as the description.

Adding a Calling Search Space


**Step 1**
In the Unified CM Administration window, select Call Routing > Class of Control > Calling Search Space.

**Step 2**
Click Add New.
The Add Calling Search Space window displays.

a. **Calling Search Space Name** — Enter a name in the Calling Search Space Name field. The name can comprise up to 50 alphanumeric characters and can contain any combination of spaces, periods (.), hyphens (-), and underscore characters (_). Ensure each calling search space name is unique to the plan.

The name can comprise up to 50 alphanumeric characters and can contain any combination of spaces, periods (.), hyphens (-), and underscore characters (_). Ensure each calling search space name is unique to the plan.

**Note:** Use concise and descriptive names for your calling search spaces. The CompanynameLocationCalltype format usually provides a sufficient level of detail and is short enough to enable you to quickly and easily identify a calling search space. For example, CiscoDallasMetroCS identifies a calling search space for toll-free, inter-local access and transport area (LATA) calls from the Cisco office in Dallas.

b. **Description** — Enter a description in the Description field.

The description can comprise up to 50 alphanumeric characters and can contain any combination of spaces, periods (.), hyphens (-), and underscore characters (_).

c. **Selected Partitions** — Select the partitions to add to this calling search space from the list of available partitions. You can limit the list of partitions by using the following field.

d. **Available Partitions** — Enter the character(s) that are found in the partition name that you are seeking and click **Find**.

Partition names that match the character(s) that you entered display in the Available Partitions box.

To add multiple partitions that are not contiguous, hold down the Control (Ctrl) key while clicking on multiple partitions. Click the arrow button between the two list boxes to add the chosen partitions.

**Step 3** To add the new calling search space, click **Save**.

The message “Status: Insert completed” displays.

**Step 4** To add more calling search spaces, click **Add New** and repeat this procedure.

**Setting Up Duplicate Extensions in Different Customer Instances**

You can use duplicate extensions in different instances in a Unified CCH environment. To accomplish this, you must associate the device targets with the appropriate peripheral using the /PID configuration parameter. This ensures that the device target is tied to the peripheral; other peripherals will not recognize it. To associate a device target with a peripheral:
Step 1 Using the Device Target Explorer on a CICM Administration & Data Server, add or modify single device target entries.

Step 2 Set the Configuration Parameter field to /PID <xxxx>, where <xxxx> is the four-digit Peripheral ID (for example: /PID 5000).

Step 3 Click Save to save the device.

Note: When you save this change, it takes effect immediately. You do not need to cycle the Unified CM PG Node services for this to take effect.
Chapter 4

Installing and Configuring Cisco Unified Customer Voice Portal for Cisco Unified Contact Center Hosted

This chapter provides information about installing and configuring Unified CVP for queuing in your Unified CCH system.

Note: For information about installing the Unified CVP Peripheral Gateway on the NAM, see Chapter 5, NAM Installation and Configuration for Cisco Unified Contact Center Hosted (page 41).

This chapter contains the following topics:

- Related Documentation, page 35
- About Cisco Unified Customer Voice Portal, page 36
- About Configuring Unified CVP for Cisco Unified Contact Center Hosted, page 37

Related Documentation

The following Cisco documents provide additional information on the installation/configuration tasks described in this chapter:


About Cisco Unified Customer Voice Portal

Cisco Unified Customer Voice Portal (Unified CVP) can be deployed in the Unified CCH system to provide IVR queuing and call treatment.


About Installing Unified CVP for Cisco Unified Contact Center Hosted


If you are deploying a Unified CCH laboratory system, you can install all of these components on a single machine and must install all components at the same time. If you do not install all components and later decide to add a component, you must uninstall the existing Unified CVP software and perform a complete re-install.

If you are deploying a Unified CCH production system, you can install individual components on different machines.

See Also

About Configuring Unified CVP for Cisco Unified Contact Center Hosted


About Setting Up Cisco Gateways/Gatekeepers to Interact with Unified CVP

You must configure Gateway(s) and Gatekeeper(s) in order to properly route inbound calls (calls originating from the caller into Unified CVP) and outbound calls (calls being transferred to an agent through Unified CVP).


How to Set Up Cisco NAM Software to Interact with Unified CVP

There are several "one time only" steps you need to take to enable interaction between NAM/Unified ICM and Unified CVP software:

Step 1 Determine what Unified CVP Network VRU types you need to define.
Step 2 Define an Unified CVP Network VRU.
Step 3 Set the Enable Expanded Call Context option.
Step 4 Define expanded call context (ECC) variables for Unified CVP.
Step 5 Define the default Network VRU.
Step 6 Configure the Peripheral Gateway (PG) for the Unified CVP.


How to Set Up Cisco CICM Software to Interact with Unified CVP

Do the following to enable interaction between CICM and Unified CVP software:
Chapter 4: Installing and Configuring Cisco Unified Customer Voice Portal for Cisco Unified Contact Center Hosted

About Configuring Unified CVP for Cisco Unified Contact Center Hosted

**How to Configure the Dynamic Routing Client**

When Unified ICM uses the Translation Route to VRU method to route a call to a type 2 SCI VRU, the VRU becomes the new routing client for the call. This means that the next Connect message is sent to the VRU to connect the call (to an agent, for example). The dynamic routing client feature is required to allow Unified ICM to make a subsequent network transfer using the new VRU routing client.

Dynamic routing client capability is required for the following call scenarios:

- Receiving a call on a converged enterprise network after a carrier pre-route using Unified CVP (release 2.1 and later) to control the call.

- Using pre-routing for load balancing purposes before the call is sent to an Unified CVP-controlled network with call context and cradle to grave reporting capabilities.

- Supporting Outbound Option for Unified CCH where a shared Network VRU is used for providing announcements to targeted phones/answer machines.

In an environment where the routing client is not capable of Network Transfer, all the pre-route calls must be transferred to Unified CVP via Translation Route To VRU to take advantage of the network transfer feature.

To configure Unified CVP as a dynamic routing client:

**Step 1** Configure the Unified CVP machine used for Dynamic Routing Client like any other, with the following exceptions:

- In **Configuration Manager > Network VRU Explorer**, define the machine as a **Type 2 VRU**.

- In **Configuration Manager > PG Explorer**, on the Routing Client tab, de-select **Network Transfer Preferred** for this peripheral.
• In Unified CVP AppAdmin > Call Definitions > Select Group 200 > Add New DNIS, add each Translation Route DNIS.

Step 2 Size and configure the network appropriately.

If the Unified CVP machine resides in a different location than the Unified CM cluster initiating the calls, WAN bandwidth is a consideration because the prompts are played G.711 from the Unified CVP machine. Where possible, the Unified CVP should be co-located with the Unified CM to eliminate these bandwidth requirements.

Step 3 Define a gateway device in Unified CM for the Unified CVP machine.

a. In the Unified CM Administration window, select Device > Gateway.

b. Define an H.323 gateway using the Unified CVP IP address.

Step 4 Configure labels for the dynamic routing client.

In Configuration Manager, the routing target (the network VRU, device targets, services, etc.) must have labels configured for the type2 VRU as routing client.

Note: For information on scripting for Translation Route to VRU, refer to the Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted. For information on deploying a dynamic routing client with Outbound Option, refer to the Outbound Option Guide for Cisco Unified Contact Center Enterprise & Hosted.
Chapter 4: Installing and Configuring Cisco Unified Customer Voice Portal for Cisco Unified Contact Center Hosted

About Configuring Unified CVP for Cisco Unified Contact Center Hosted
This chapter discusses the procedures you need to perform to install and configure a NAM system. These instructions assume that Windows—including SNMP and SQL Server are already installed, and that Windows Active Directory services for the system software, including at least one ICM instance, have been set up.

Note:

• You must have a copy of the Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted available in addition to this manual in order to successfully complete NAM installation and configuration.

• If you are installing and configuring NAM systems that are part of a Multiple-NAM configuration, refer to the installation and configuration instructions in the Multiple-NAM Setup and Configuration Guide for Cisco Unified ICM Hosted.

This chapter contains the following topics:

• Installing NAM Logger Software, page 41
• Post-Installation Setup and Installing Multiple Components, page 43
• About Administration & Data Server Types, page 44
• NAM Configuration Data, page 45
• Defining CICM Instances and Customers on the NAM, page 46
• Installing NAM Cisco Unified Customer Voice Portal PG, page 49
• Installing and Configuring NAM NICs and PGs, page 55
• Upgrading the NAM, page 58

Installing NAM Logger Software

The Logger is the process that manages the central database. A Logger process runs on each NAM and CICM in the Unified ICMH system.
Step 1 Create the central database on the Logger machine using the ICMDBA utility.

Step 2 Open the Web Setup tool.

Step 3 Select Component Management > Loggers in the left frame, then click Add in the right frame. The Add Logger Deployments page appears.

Step 4 On this page, be sure to select Hosted > Network Application Manager (NAM) for Logger Type.

Step 5 Provide values for the other fields on this page, then click Next.

Step 6 Provide values for the applicable fields on the Central Controller Connectivity and Additional Options page. Clicking Next from the Additional Options page takes you to a NAM page.

Step 7 On the NAM page, select one of the following values for NAM Type:

   a. Provisioning/Standalone NAM: NAM Logger is either a Standalone NAM or a NAM that provides Slave NAMs with configuration information

   b. Slave NAM: NAM Logger that obtains configuration information from a Provisioning NAM

   Note: This option is only used in a Multiple-NAM setup.

Step 8 Provide the following values in the NAM Configuration section:

   a. Provisioning/Standalone Router Side A: Enter the Side A machine name or IP address of the provisioning Router

   b. Provisioning/Standalone Router Side B: If a Side B machine exists, enter the Side B machine name or IP address of the provisioning Router

Step 9 If you specified a NAM Type of Provisioning/Standalone NAM, skip the Slave NAM Configuration section. If you specified a NAM Type of Slave NAM, specify the following information:

   a. Provisioning NAM Instance Name: The instance name of the Provisioning NAM

   b. Provisioning NAM Instance Number: The instance number of the Provisioning NAM

   c. Provisioning Logger Side A: The Side A machine name or IP address of the Provisioning Logger

   d. Provisioning Logger Side B: If present, the Side B machine name or IP address of the Provisioning Logger

   e. Slave Router Side A: The Side A machine name or IP address of the Slave Router

   f. Slave Router Side B: If present, the Side B machine name or IP address of the Slave Router
Step 10  Click Next.

Step 11  Complete the rest of the Logger setup.

---

Post-Installation Setup and Installing Multiple Components

In cases where you want to install more than one Unified ICM component on a single computer—for example, to install the CallRouter and Logger software on a single node—you must run the Web Setup tool for each component. Similarly, to install a specific component for more than one customer, you must run the Web Setup tool for each instance.

Installing NAM CallRouter Software

The CallRouter process contains the call routing logic of the system. The CallRouter runs on each NAM and CICM in the Unified ICMH system.

During NAM CallRouter installation you set up the following:

- **Enable Remote Network Routing.** This option sets up the NAM to send routing requests to the CICM systems.

- **NAM ID.** This value is passed with messages sent to a CICM so that the CICM can identify which NAM in the configuration sent the message.

How to Install CallRouter Software on the NAM

Step 1  Open the Web Setup tool.

Step 2  Select Component Management > Routers in the left frame, then click Add in the right frame.

Step 3  In the first Add Router window, be sure to check the Enable Remote Network Routing box.

Step 4  In the NAM ID field, do the following:

a. If your NAM configuration contains only a single NAM, accept the default value of 0.

b. If your NAM configuration contains multiple NAMs that might communicate with a single CICM, specify a unique nonzero value. (The same NAM ID is used for Side A and Side B of a given NAM. However, the NAM ID must be different for different instances in a multiple NAM environment.)

Step 5  Click Next.

Step 6  Complete the rest of the CallRouter setup.
Installing a Network Administration & Data Server

The Administration & Data Server provides the user interface to the NAM and Unified ICM software.

How to Install Network Administration & Data Server Software for the NAM

---

**Step 1** Open the Web Setup tool.

**Step 2** Select Component Management > Administration & Data Servers in the left frame, then click Add in the right frame.

**Step 3** In the first Add Administration & Data Server page, select Hosted for the Deployment Type, and also select Network Administration & Data Server for Customer ICM (CICM).

**Step 4** Supply values for the other fields in this window, then click Next.

**Step 5** Complete the rest of the Administration & Data Server setup.

---

About Administration & Data Server Types

There are four possible types of Administration & Data Servers in the Unified CCH environment:

- **Limited (Single Instance) Administration & Data Server**: Used by network service provider customers. This type can access data only for its associated instance; it cannot access data from other instances in the same CICM complex or other CICM complexes.

- **Network Administration & Data Server for Customer ICM (CICM)**: A network Administration & Data Server associated with the CICM systems.

- **Network Administration & Data Server for Network Application Manager (NAM)**: Used by network service provider personnel. This type has multiple Administration & Data Servers: one for the NAM instance, and one for each associated CICM instance.

- **Configuration-Only Administration Server**: HDS is not enabled and real-time reporting is turned off. This deployment only allows configuration changes with no real-time and historical reporting.

  **Note**: A separate Configuration-Only Administration Server is required for each CICM instance being provisioned by Cisco Unified Contact Center Management Portal (Unified CCMP).

  **Note**: Refer to the *Hardware & System Software Specification (Bill of Materials) for Cisco Unified ICM/Contact Center Enterprise & Hosted* for hardware requirements and sizing guidelines.
You have the option of installing the Administration & Data Server as an Administration Server and Real-time Data Server (AW), Administration Server, Real-time and Historical Data Server and Detail Data Server (AW-HDS-DDS), or Administration Server and Real-time and Historical Data Server (AW-HDS). Each of these Administration & Data Server roles run as a Windows service and manage several Unified ICM processes. (Refer to the Administration Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted for more details about these roles.)

**Note:** You can either access the shared Administration & Data Server or your own dedicated Administration & Data Server, but not both. The reporting application, Unified IC, is used to report on the stored data.

## NAM Configuration Data

At this point, you can start the NAM Logger, CallRouter, and Administration & Data Server, and set up the NAM configuration data.

In a two-tier architecture, the NAM system requires only a subset of the normal Unified ICM configuration data. The following table summarizes the configuration data for a NAM.

<table>
<thead>
<tr>
<th>Table</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Announcement</td>
<td>Any announcements used in NAM scripts.</td>
</tr>
<tr>
<td>Application Gateway</td>
<td>A remote ICM gateway for each instance on each associated CICM.</td>
</tr>
<tr>
<td>Business Entity</td>
<td>The default business entity only.</td>
</tr>
<tr>
<td>Call Type</td>
<td>Typically, one for each instance.</td>
</tr>
<tr>
<td>Call Type Map</td>
<td>Associate each NAM call type with a NAM script.</td>
</tr>
<tr>
<td>Dialed Number</td>
<td>All dialed numbers used on associated CICMs, plus those used for direct translation. (No default routes are defined for NAM dialed numbers.)</td>
</tr>
<tr>
<td>Dialed Number Map</td>
<td>Associates dialed numbers and calling line IDs with NAM call types.</td>
</tr>
<tr>
<td>Label</td>
<td>All labels that can be returned by associated CICMs, plus those used for direct translation.</td>
</tr>
<tr>
<td>Network Interface Controller</td>
<td>One required for the Network Interface Controller to the carrier network.</td>
</tr>
<tr>
<td>Peripheral Gateway (PG)</td>
<td>One or more for the Peripheral Gateway to the carrier network.</td>
</tr>
<tr>
<td>Prefix</td>
<td>Any prefixes used in NAM regions.</td>
</tr>
<tr>
<td>Region</td>
<td>Any regions used in NAM dialed number map.</td>
</tr>
<tr>
<td>Routing Client</td>
<td>One or more for the carrier network.</td>
</tr>
<tr>
<td>Script</td>
<td>One or more for each call type.</td>
</tr>
</tbody>
</table>
Defining CICM Instances and Customers on the NAM

A process called the NAM Replication Process (NRP) runs on the NAM Logger system. The NRP monitors configuration changes made on the NAM for items such as the dialed number and label for a customer. Whenever you add a dialed number or label on the NAM, the NRP determines which CICM is affected. The NRP then forwards and automatically applies the change to the appropriate CICM.

**Note:** Because the NRP cannot apply updates to records, modifications to dialed number and label strings are disallowed.

Database records do not necessarily share the same ID values between NAM and CICM. For example, when you add a dialed number for a customer into the NAM, the record created in the CICM has the same values for DialedNumberString and EnterpriseName, but not necessarily the same value for DialedNumberID. The Dialed_Number.LabelID on the CICM is set to point to a label that is equivalent to the label on the NAM, although the ID values might not be the same.

In order for the NRP to function properly, you must do the following:

- Configure all associated CICMs as ICM instances and customers on the NAM, so that the NRP can forward changes to the appropriate CICM databases. (For instructions, see the "Configuring CICM Instances on the NAM (page 46)" section.)

- Configure the Administration & Data Servers for each CICM and the customers to allow the NRP to locate the CICM databases to be updated. (For instructions, see the "Configuring CICM Associated Administration & Data Servers on the NAM (page 48)" section.)

- Define each customer associated with each CICM instance.

- Associate the routing client on a CICM with a routing client on the NAM, so that customer data on the NAM and CICM can match up. (For instructions, see the "How to Associate a CICM Routing Client with a NAM Routing Client (page 49)" section.)

Configuring CICM Instances on the NAM

You must perform the following steps to configure an instance for each associated CICM.

**Note:** CICM instance names and numbers are defined on the CICMs. For information, see the CICM Installation and Configuration chapter.

**Step 1**
On the NAM, start the **Configuration Manager** from the Administration Tools folder. The Configuration Manager window opens.

**Step 2**
Open the Instance Explorer tool by selecting **Configure ICM > Enterprise > ICM Instance > ICM Instance Explorer**. The ICM Instance Explorer window appears.
Step 3  Click Retrieve.

Step 4  Click Add ICM Instance.

Figure 5: ICM Instance Dialog

Step 5  Specify the following on the ICM Instance tab:

- **Name.** The enterprise name for the CICM instance, as used in the Web Setup tool.
- **Type** (drop-down list). Select **Customer ICM**.
- **Instance Number.** The instance number as defined in the Web Setup tool.

**Note:** For information about defining a name and number for a CICM instance, see the CICM Installation and Configuration chapter.

- **Network ICM Instance** (drop-down list). The associated NAM instance.
- **Description** (optional). Additional information about the ICM Instance.

Step 6  Click Save.
Configuring CICM Associated Administration & Data Servers on the NAM

You must perform the following steps to configure the primary and secondary Administration & Data Servers associated with the CICM instances you just defined.

How to Configure the Administration & Data Servers Associated with the Instance

<table>
<thead>
<tr>
<th>Step 1</th>
<th>On the NAM, start Configuration Manager from the Administration Tools folder. The Configuration Manager window opens.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Open the Instance Explorer tool by selecting Configure ICM &gt; Enterprise &gt; ICM Instance &gt; ICM Instance Explorer. The ICM Instance Explorer window appears.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click Retrieve.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click Add ICM Instance. (this button does not display)</td>
</tr>
<tr>
<td>Step 5</td>
<td>Specify the following on the ICM Node tab:</td>
</tr>
<tr>
<td></td>
<td>a. ICM Instance (drop-down list). The name for the instance that contains the node.</td>
</tr>
<tr>
<td></td>
<td>b. System Domain. The name of the Windows security domain that contains the NAM machine.</td>
</tr>
<tr>
<td></td>
<td>c. System Name. The name of the computer that runs both instances.</td>
</tr>
<tr>
<td></td>
<td>d. Node Type (drop-down list). The node type: Primary Administration &amp; Data Server or Backup Administration &amp; Data Server.</td>
</tr>
<tr>
<td></td>
<td>e. Name. The enterprise name for the node. (The default enterprise name is formed by combining the ICM instance, system name, and node type.)</td>
</tr>
<tr>
<td></td>
<td>f. Configuration Parameter (optional). A string of configuration parameters to be passed to the node at initialization.</td>
</tr>
<tr>
<td></td>
<td>g. Description (optional). Additional information about the node.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click Apply and Done.</td>
</tr>
</tbody>
</table>

Defining CICM Customers

You must perform the following steps to define each customer associated with each CICM instance.
How to Define a Customer

You must perform the following steps to define a customer:

**Step 1** On the NAM, in **Configuration Manager**, choose **Enterprise > Customer > Customer List**. The Customer Definition List window appears.

**Step 2** Click the **Add** button.

**Step 3** Specify the following in the Attributes tab:

- **Name**. The enterprise name for the customer.
- **ICM Instance** (drop-down list). The name of the instance associated with the customer.
- **Network VRU** (drop-down list). The name of the network VRU (if any) associated with the customer.
- **Description** (optional). Additional information about the customer.

**Step 4** Click **Save**.

How to Associate a CICM Routing Client with a NAM Routing Client

**Step 1** *On the NAM*, double-click the **NIC Explorer** tool. The NIC Explorer window appears.

**Step 2** In the Select filter data box, click **Retrieve**. The NIC tree window appears.

**Step 3** Select a NIC. The Explorer tab fields appear.

**Step 4** Click the **Routing client** tab.

**Step 5** Set the **Network routing client** field on the NAM to the same value to appear on the CICM. (For example, you can set it to the enterprise name of the NAM routing client.)

**Step 6** Click **Done** to apply the changes and close the dialog box.

Installing NAM Cisco Unified Customer Voice Portal PG

The “**Configuring the NAM for a Unified CVP PG (page 50)**” section describes the procedures to perform to complete NAM Unified CVP configuration and installation.
## Configuring the NAM for a Unified CVP PG

### Step 1
From the NAM Administration & Data Server Configuration Manager, select **Explorer Tools > PG Explorer**.

The PG Explorer window displays.

### Step 2
Click **Retrieve**, then click **Add** (bottom left).

The Logical Controller tab displays in the left-hand pane.

### Step 3
Enter a Name for the PG in the Name field.

### Step 4
Select **VRU** as the client type from the Client type drop-down menu.

### Step 5
Highlight the Peripheral under the PG that you just created (left-hand pane).

The Peripheral and associated tabs appear below the logical controller tab.

### Step 6
In the Peripheral tab, complete the following:

- Provide a name for the peripheral in the Name field.
- Verify the Client Type is VRU.
- If a Unified CVP Application Server is the routing client, then check **Enable Post Routing**. Otherwise, verify that it is unchecked.
- If you checked Enable Post Routing in the previous step, then select the Routing Client tab.

The Routing Client tab displays.

### Step 7
In the Routing Client tab, complete the following:

- Enter a name for the Routing Client in the Name field. The convention is to use the same name as the peripheral with _rc appended to the end of the name; for example, `NAM_PG1_rc`.
- Enter the same name as above in the Network Routing Client field.
- Verify that the Network Transfer Preferred checkbox is **NOT** checked.

### Step 8
Click **Save**.

**Note:** After you click **Save**, a Logical Controller ID and Peripheral ID are assigned to the PG and its associated peripheral(s). Note these numbers for the next task.
How to Install a NAM Unified CVP PG

You must install and configure at least one Unified CVP PG for your hosted system.

You need the following information:

- Peripheral Gateway DMP Configuration ID, which you specify during Router setup
- Peripheral Gateway Logical Controller ID, which you specify during Peripheral Gateway configuration

**Step 1**
On the machine to be used as the NAM PG, run Peripheral Gateway Setup.

**Step 2**
Click Add in the Instance Components section and select Peripheral Gateway from the ICM/CCE/CCH Component Selection window.

The Peripheral Gateway Properties window displays.

**Step 3**
Leave Auto Start at System Startup unchecked. The server might need to be rebooted a number of times during installation, and problems could occur if the node starts before Service Releases and/or databases are applied.

**Step 4**
Specify whether the PG is part of a duplexed pair.

**Step 5**
In the ID field, select the PG device identifier (as enabled in the CallRouter’s DMP Configuration dialog) from the pull-down menu.

*Note:* Each logical PG must have a unique device assignment at the CallRouter. (If a PG is duplexed, both physical machines use the same device assignment.) To add another logical PG, you must enable another PG device for the CallRouter. For example, if you checked only box number 1 during the CallRouter setup, then you must select the ID PG1 from the drop-down list.

**Step 6**
If the PG is duplexed, specify whether you are installing Side A or Side B. If the PG is simplex, select Side A.

**Step 7**
In the Client Type Selection area, select the type of Peripheral Gateway you want to add. Use the Add and Remove buttons to select or de-select PG types. You can install one PG type and one VRU PG at the same time.

*Note:* For an Unified CVP PG you must select VRU as one of the client types.

**Step 8**
Click Next.

The Peripheral Gateway Component Properties window displays.

**Step 9**
In the Peripheral Gateway Configuration section of the window, enter the Logical Controller ID from the Logical_Interface_Controller record for the PG.
Note: You can view the Logical_Interface_Controller record for the PG using the PG Explorer tool from the Configuration Manager on the NAM AW.

Step 10  The VRU Reporting options are available only if the PG supports VRUs. Select the option that you want to use for VRU reporting.

Note: For a typical application you should select Service Control and check Queue Reporting.

Step 11  In the Peripheral Interface Managers section, click Add.

The Add PIM dialog displays.

Step 12  Select VRU for the Client type.

Step 13  Select an available PIM from the Available PIMs list.

The list contains only PIM numbers that are not already defined for this PG.

Step 14  Click OK.

The VRU configuration dialog displays in which you can enter the properties of the peripheral.

Step 15  To put the PIM into service, check the Enabled option. This allows the PIM to communicate with the peripheral when the Peripheral Gateway is running.

Step 16  Enter the peripheral name in the Peripheral name field. In most cases, you will want to use the enterprise name from the associated Peripheral record.

Step 17  Enter the Peripheral ID from the Peripheral record.

Note: You can view the Peripheral ID of the PG using the PG Explorer tool in the Configuration Manager on the NAM AW.

Step 18  In the VRU Host Name field, enter the name or IP Address by which the VRU is known to the network.

Step 19  Enter the number of the VRU port that the PG connects to.

Typically, port 5000 is the default for a Unified CVP Application server.

Step 20  In the Reconnect Interval field, specify how often the PG should try to re-establish a lost connection to the VRU.

Step 21  In the Heartbeat Interval field, specify how often the PG should check its connection to the VRU.

Note: The defaults for the Reconnect Interval and Heartbeat Interval are usually appropriate.

Step 22  Click OK to set the values and close the VRU dialog.

Step 23  Click Advanced.
The MDS and DMP Properties dialog displays.

**Note:** Your network design might dictate different settings than the defaults; change as appropriate. (Click **Help** for more information on this window.)

Click **OK**.

**Step 24**  
Click **Next**.

The Device Management Protocol Properties window displays.

**Step 25**  
If you prefer that the PG communicate with one side or the other of the Central Controller (for example, if the PG is collocated with one side), indicate the preferred side.

Whether you specify a preferred side or not, if the PG cannot communicate with one side, it will automatically switch to the other.

**Step 26**  
For the Side A properties, and if applicable the Side B properties, define the following:

- Indicate whether the PG is local to or remote from each side of the Central Controller. If the PG is remote from either side, specify the maximum amount of bandwidth (in bits per second) the PG can use for communication with the CallRouter. Use this option to prevent the PG from overloading the wide-area network.

- If the CallRouter is not local, in the Bandwidth fields, input the bandwidth for the WAN link to the CallRouter side A and side B. In the case that QoS is not an intended feature, you do not need to worry about how to divide the link bandwidth into each priority. The sum for the three priorities, however, must be the physical bandwidth you actually have, and the input for each priority must be at least 1K (1024) bps.

- For QoS connections, you need to enter the appropriate bandwidth value for the High, Medium and Low priority individually. Consult with your network administrator or Cisco representative to determine the bandwidth requirements for your network.

**Step 27**  
Click **Next**. The Peripheral Gateway Network Interfaces dialog displays.

**Step 28**  
In the Private Interfaces section, enter the TCP/IP addresses (or host names) of the private network for the PG machines (PG private A, PG private A high) and, if it is duplexed, its pair (PG private B, PG private B high). If the PG is simplex, enter localhost for the B side addresses.

In the Visible Interfaces section, enter the visible network addresses (or host names) for the PG (PG visible A, PG visible B) and CallRouter (Router visible A, Router visible A high, Router visible B, Router visible B high) machines. (Refer to the *Pre-installation Planning Guide for Cisco Unified ICM Enterprise and Hosted* for detailed information about setting the Central Controller network interfaces.) If simplex, enter localhost for the B side addresses.

**Step 29**  
If you want to use the QoS feature for your private interfaces and/or your visible interfaces, click the appropriate **QoS** button. A QoS Settings dialog displays.

**Step 30**  
Verify that **Use Packet Scheduler** is checked.
Step 31 Set the DSCP (DiffServ Codepoint) marking for each priority of the ICM traffic going to the CallRouter. The defaults are acceptable if your network is Cisco AVVID compliant (Architecture for Voice, Video and Integrated Data). Otherwise, you need to consult your network administrator or Cisco representative for the proper values for these fields.

Step 32 Uncheck the Use Packet Scheduler box, if you plan to use the Microsoft Packet Scheduler utility. This changes the appearance of the PG QoS DMP Properties Advanced Options window. The edit boxes for Medium Priority are grayed out and the Medium Priority always has the same settings as the High Priority. This is because Microsoft Packet Scheduler supports at most two classification levels (except best effort).

In addition to DSCP marking, the Class-of-Service (802.1p) marking is supported. The default values are set in compliance with Cisco AVVID recommendations. Consult your network administrator or Cisco representative for changes.

Note: Microsoft Packet Scheduler must be installed separately from the setup process, if you uncheck the Bypass Packet Scheduler box. For more information about QoS for the system software, refer to the Pre-installation Planning Guide for Cisco Unified ICM Enterprise and Hosted.

Step 33 Click OK.

You are returned to the Peripheral Gateway Network Interfaces window.

Step 34 Click Next.

The Check Setup Information window displays.

Step 35 Ensure that the settings displayed are as you intended. If you want to modify any settings before proceeding, click Back. When the settings are correct, click Next to begin copying files.

The copying process may take several minutes to complete. You can continue with other work while the setup process operates in the background.

Note: For specific information about what the Peripheral Gateway Setup utility installs, refer to the Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted and the Peripheral Gateway Setup online help.

Step 36 When the setup process successfully copies all the files, it displays the final window and asks whether you want to start the ICM Node Manager now. Do not start the Node Manager until you have completed the entire Unified ICM installation.

Step 37 Click Finish to exit Peripheral Gateway Setup and optionally start the Node Manager.

If you choose to start the Node Manager, it automatically starts the other Unified ICM processes on the PG.
Installing and Configuring NAM NICs and PGs

This section provides guidelines for configuring network interface controllers (NICs) and peripheral gateways (PGs) for the NAM.

Network Interface Controllers

Refer to the *Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted*, and the System Manager Guide Supplement for your particular NICs for guidelines and procedures.

Peripheral Gateways

To support duplexed operation, the NAM must also communicate with at least one Peripheral Gateway device. (In a duplexed environment, a CallRouter does not route calls when the duplexed partner has nodal or network failure unless it has active connections to a majority of the PGs and it cannot see the other CallRouter. This prevents both CallRouters from trying to route simultaneously.) Therefore, you must define at least one Peripheral Gateway for the NAM. You can run the Peripheral Gateway on one of the Administration & Data Server machines associated with the NAM. The Peripheral Interface Manager (PIM) on the PG need not be enabled.

How to Configure Device Management Protocols for NAM PGs

Follow the steps described in the Peripheral Gateway Setup online help to set up a Peripheral Gateway. This includes instructions for the Device Management Protocol Properties dialog.

Creating a Cisco Unified Intelligent Contact Management Application Gateway to Access CICM Instances

After adding the instance components to the CICM, you must configure a Unified ICM Application Gateway in Configuration Manager on an Administration & Data Server associated with the NAM. (The Unified ICM Application Gateway is the path a NAM takes to access a CICM.)

After the Unified ICM Application Gateway is configured, you can reference it using a Unified ICM Application Gateway node within a routing script on the NAM.

How to Create a Cisco Unified Intelligent Contact Management Application Gateway

**Step 1** Within Configuration Manager on an Administration & Data Server associated with the NAM, select Calls > Application Gateway > Application Gateway List. The Application Gateway List window appears.

**Step 2** Click Retrieve.
Step 3  Click **Add**. The Attributes tab appears.

*Figure 6: Application Gateway List Window*

Step 4  Specify the following values on the Attributes tab:

- **Name**. Enter a name for the Unified ICM Application Gateway.
- **Type**. Select **Remote ICM**.
- **Preferred Side**. Indicates the preferred side of the Unified ICM Application Gateway to use when both are available. If only one side is available, the system software uses that side regardless of preference. This option applies only for Custom Gateways. For Remote ICM systems, the preference is indicated by a suffix on the connection address.
- **Encryption**. Indicates whether requests to the Unified ICM Application Gateway are encrypted. Select **None**.
- **Fault Tolerance**. If the Unified ICM Application Gateway is duplexed, specifies the fault-tolerance strategy it uses.
- **Connection**. Select whether the Unified ICM Application Gateway is Duplex (has both a Side A and Side B connection), Simplex A (only has a Side A), or Simplex B (only has a Side B).
- **Description** (optional). Additional information about the Unified ICM Application Gateway.

Step 5  Click **Save** to create the Unified ICM Application Gateway.
Note: Make a note of the Unified ICM Application Gateway ID value, as you will need it when you run the Web Setup tool to configure the INCRP NIC on the CICM.

Step 6 To set the connection information, click the Connection Side A tab or the Connection Side B tab.

Step 7 To specify an address, click the Enter Address button. The Enter NAM Addresses dialog box appears.

Step 8 Specify the following information:

- **NAM Mode.** Select Single NAM or Multiple NAMs, depending on the number of NAMs connected to the selected Unified ICM Application Gateway.

- **IP Address/Name.** Enter the Public (high priority) IP address of the CICM. Alternatively, the SAN can be used (consult your Cisco certified partner or TAC for assistance). This address must be the same address specified for the INCRP NIC on the CICM. (You can use the hostname in place of the address.)

- **Instance Number.** Enter the number of the customer ICM on the CICM (0 through 24).

- **Side.** Indicate which side of the NAM prefers this connection:
  - **Side A.** NAM Side A prefers to use this connection.
  - **Side B.** NAM Side B prefers to use this connection.
  - **None.** Neither side of the NAM prefers to use this connection.
  - **Both Side A and B.** Both sides of the NAM prefer to use this connection.
Note: Consider network traffic in choosing this value. For example, if one side of the NAM is collocated with only one side of the CICM, you can make that the preferred connection in order to avoid unnecessary WAN traffic to the other side.

• NAM ID. This field appears only if you select a NAM Mode of Multiple NAM. Enter the NAM ID.

Step 9  Set the In Service field to indicate whether this connection is currently available for use by the system software.

Step 10 When finished, click Save.

The bottom half of the connection tab displays a number of timeout and limit values. The defaults for these values as shipped may not be appropriate for a NAM system; these values are highly configuration-dependent. A rough guideline is that the CICMs’ timeout value be less than the timeout value for the NAM’s NIC.

How to Set Default Values for the Cisco Unified Intelligent Contact Management Application Gateway

Step 1 Within Configuration Manager, select Enterprise > System Information > System Information. The System Information dialog box appears.

Step 2 In the Application Gateway section, select the Remote ICM radio button.

Figure 8: System Information Dialog

Step 3 Use the Timeouts, Sessions, Heartbeats, and Error tabs to set the default values for the Unified ICM Application Gateway connections. (The Unified ICM Application Gateway timeout settings for a CICM must be set keeping in mind the NAM NIC settings for timeout, late, and so on.)

Step 4 When finished, click OK to make the changes and close the dialog box.

Upgrading the NAM

For instructions on how to upgrade a NAM system, refer to the Upgrade Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.
Chapter 6

Installing and Configuring CTI OS Server for Cisco Unified Contact Center Hosted

This chapter provides CTI OS Server installation guidelines for Unified CCH.

The following Cisco documents provide additional information on the installation/configuration tasks described in this chapter.

- **CTI OS Developer's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted**

- **CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted**

- **CTI Product Description Guide for Cisco ICM/IPCC Enterprise & Hosted Editions**

This chapter contains the following topics:

- CTI OS Server Installation Guidelines, page 59
- CTI OS Failover, page 63

**CTI OS Server Installation Guidelines**

Following are some guidelines to consider when you install CTI OS Server.

CTI OS is typically installed in a duplex configuration. Two CTI OS servers installed on separate systems work in parallel to provide redundancy. Installing only one CTI OS server would prevent failover recovery by client systems. Refer to the *Startup, Shutdown, and Failover* discussions in the [CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted](http://www.cisco.com/en/US/products/sw/custcosw/ps14/tsd_products_support_series_home.html) for more information on CTI OS failover.

CTI OS must be installed on the same server on which the PG/CG is installed, then you can start the CTI OS Service.

Ensure that your CTI OS system meets the minimum hardware and software requirements, as listed in the [Hardware & System Software Specification (Bill of Materials) for Cisco Unified ICM/Contact Center Enterprise & Hosted](http://www.cisco.com/en/US/products/sw/custcosw/ps5053/tsd_products_support_series_home.html).

### How to Install the CTI OS Server

The CTI OS Server must be installed on the same system where the PG and CG are installed.

If you are performing a new install of the CTI OS Server altogether, perform the following steps.

**Note:** For instructions on upgrading the CTI OS Server from a previous version, refer to the [CTI OS System Manager’s Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted](http://www.cisco.com/en/US/products/sw/custcosw/ps14/tsd_products_support_series_home.html).

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Run the PG Setup tool (accessed from the Unified CCE Tools folder) to install the CTI OS Server.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Click <em>Yes</em> on the Software License Agreement window. The CTI OS Instance list dialog displays.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>In the CTI OS Instance List section, click <em>Add</em>. The Add CTI OS Instance dialog displays.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>Specify an Instance Name value by selecting the correct ICM instance name that has already been configured for this instance of CTI OS, and click <em>OK</em>. The CTI OS Instance list dialog redispays, displaying the new Instance Name.</td>
</tr>
<tr>
<td><strong>Step 5</strong></td>
<td>In the CTI OS Server List section, click <em>Add</em>. The Add CTI OS Server Instance dialog displays.</td>
</tr>
<tr>
<td><strong>Step 6</strong></td>
<td>If you are installing CTI OS Server for the first time, a dialog displays. Accept the default installation drive or select another drive from the pulldown list and click <em>OK</em>.</td>
</tr>
</tbody>
</table>
The CTI Server Information window displays.

**Step 7** Enter the Name or IP Address and the Port Number for your CTI systems and click **Next**.

The Peripheral Identifier window displays.

**Step 8** Specify the following information:

- A Logical Name for your peripheral. This can be any valid logical name that uniquely identifies your peripheral.

**Note:** Only Peripheral Types of Unified CCE, Unified SCCE, and Unified CCH have the Login By group box enabled where you can choose between logging in by Agent ID or by Login Name. The Login By setting determines how CTI Toolkit Agent and Supervisor desktops allow Login and Chat request (either AgentID OR LoginName). This setting does not affect other CTI applications. CTI OS Server itself can service Login requests both ways (by AgentID and by LoginName) for Unified CCH. All other peripheral types will login by Agent ID only, and the choice is disabled. If this is to be a multi-instance environment, select **Unified CCH**.

- The Peripheral ID associated with the switch connection.

- The Peripheral Type of the switch connection.

**Note:** You can specify information for only one peripheral during CTI OS Server setup. To configure additional peripherals, follow the procedure in the section describing Automatic Agent Statistics Grid Configuration in **CTI OS Configuration** in the **CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted** (http://www.cisco.com/en/US/products/sw/custcosw/ps14/tsd_products_support_series_home.html).

**Step 9** Click **Next**.

The Connection Information dialog displays.

**Step 10** Enter the port number and heartbeat information for your CTI OS server instance.

**Note:** For an Unified CCH peripheral type, only the first instance can have this port. Subsequent ones must have the port number incremented by 1 (i.e. 42029, 42030, etc.), taking care to configure the clients that connect to them with the same port in their installs. (For all non-Unified CCH peripheral types, the Listen Port must be left at the default value of 42028.)

**Step 11** Click **Next**.

The Statistics Information dialog displays.

**Step 12** Accept the default polling value or enter the polling interval for Skillgroup statistics (in seconds).

**Note:** Since QoS enablement and statistics enablement are mutually exclusive, enabling QoS zeros and disables all of the information relating to statistics.

**Step 13** Click **Next**.
The Peer CTI OS Server window displays.

**Step 14** Optionally, configure a Peer Server for Chat, Silent Monitoring, and to support fault tolerance and the failover mechanism built into the product:

- Enable the Duplex CTI OS Install checkbox.
- Specify a Peer CTI OS Server value.
- Specify a Port value.

**Step 15** Click **Add Server**.

The CTI OS Server information is added to the system and the CTI OS Server Security dialog displays.

**Step 16** Do one of the following:

- To enable security, select the **Enable Security** checkbox and click **OK**.
- To disable security, click **OK**.

CTI OS Server Security Install Schield Wizard dialog displays.

**Note:** Refer to the [CTI OS System Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted](http://www.cisco.com/en/US/products/sw/custcosw/ps14/prod_installation_guides_list.html) for detailed security setup information.

**Step 17** Click **Next**; when CTI OS Server Security Setup is complete, click **Finish**.

The system asks whether to restart your computer now or later.

**Step 18** Do one of the following:

- Select **Yes**; your machine reboots, then restarts the PG Setup tool.
- Select **No**; the CTI OS Instances dialog appears.

**Step 19** For the Unified CCH peripheral type, click **Add** and follow the procedure described upon to create additional instances.

**Note:**

- For any other peripheral type, the **Add** button under the Instance List is disabled after one instance is created.
- CTI OS Multi Instance setup does not allow two or more CTI OS Servers to connect to the same CTI Server. Also, it does not allow two or more CTI OS Servers to use the same listen port.

**Step 20** When finished creating instances, click **Exit Setup**.
How to Start CTI OS Service After Installation

The CTI OS Server runs as a service on the host Windows Server 2008 R2 (SP1) computer. The Unified CCE Service Control application is an interface into the Windows platform’s service control manager, which start and stops services.

To start, stop, or cycle the processes in the CTI OS Server, use the appropriate tabs from the Unified CCE Service Control window.

Use the following procedure to start the CTI OS Service:

**Step 1**
On the CTI OS Server machine, open **Unified CCE Service Control**.

**Step 2**
Select **CTI OS Service**.

**Step 3**
Click **Start**.

When the CTI OS service starts, it launches processes listed in the following table. Some of these processes open and run in console windows. These windows can be minimized, but cannot be closed. Closing the console window in which a process is running forces a restart of that process.

### Table 6: CTI OS System Processes

<table>
<thead>
<tr>
<th>Process Name</th>
<th>Process Description</th>
<th>Runs In Console Window</th>
</tr>
</thead>
<tbody>
<tr>
<td>CtiosServerNode</td>
<td>The main CTI OS Server process. This process manages all CTI OS objects and listens for and manages client connections</td>
<td>Yes</td>
</tr>
<tr>
<td>NM</td>
<td>The ICM NodeManager (fault tolerance manager). Each ICM service is started by NodeManager, and NodeManager restarts any abnormally terminated processes.</td>
<td>No</td>
</tr>
<tr>
<td>NMM</td>
<td>The ICM NodeManagerManager (system fault tolerance). Each ICM Node (that is, CTI OS) starts up a NMM process to handle system-level faults. In the event of a unrecoverable system fault, NMM will restart the host computer.</td>
<td>No</td>
</tr>
</tbody>
</table>

CTI OS Failover

The CTI OS Server is a fault-tolerant server. The server processes are managed by a fault tolerance/recovery platform called NodeManager. NodeManager creates and monitors each process running as part of the CTI OS service, and automatically restarts abnormally terminated processes.

Installing and Configuring Outbound Option for Cisco Unified Contact Center Hosted

Outbound Option is a feature of Unified CCH that provides outbound dialing functionality along with the existing inbound capabilities of Unified CCH. With Outbound Option, contact centers can be configured for automated outbound activities. Agents who are not busy handling inbound requests can perform outbound calls, thereby maintaining a high level of agent productivity.

For Unified CCH, a Cisco voice gateway is required to place customer calls.

Configuring Outbound Option Multi-Tenant Customer Instances

Release 8.0(1) of Outbound Option allows multiple customer instances to run Outbound Option in a Hosted environment. This new feature, known as Outbound Option Multi-Tenant, is available in Outbound Option deployments that use the SIP Dialer.

In a Multi-Tenant environment, there are certain configuration values that you must set for each customer instance:

- You must set the number of agents when configuring each customer instance.

  **Note:** For instructions on how to set and configure the number of agents for a customer instance, refer to the *Setup and Configuration Guide for Cisco Unified Contact Center Hosted.*

- You must set Port Throttling for each customer instance in the Dialer General tab of the Outbound Option Configuration tool.

  **Note:** See the “Configuring the Dialer Component (page ?)” section for more details.

- For the SCCP Dialer, you can optionally enable recording of sessions by turning on the CPARecordWaveFile registry value. For the SIP Dialer, you can enable recording of sessions...
in ICM Configuration Manager. On the Outbound Option Campaign Purpose tab, check Call Progress Analysis (CPA), and also check Record CPA.

Note: See Appendix A for more details.

- You must set the Do Not Call List size and the number of Dialer ports for each customer instance using the configlimits tool (see the next section for details).

Using the ConfigLimit Tool to Change Multi-Tenant Parameter Limits

Each customer instance database contains Configuration Limit scalability records. The two records kept concerning Outbound Option are the size (in Records) of the Do-Not-Call List to be imported, and the maximum number of Dialer Ports available for a specific customer instance of outbound Option.

You can change these values with the Configuration Limits (configlimit) tool. Perform the following steps:

**Step 1** Run the configlimit tool by selecting Start > Run from the Windows menu, then entering configlimit.

Note: Run configlimit on the same machine as the Distributor for the instance you want to configure. If more than one instance of the Administration & Data Server is installed on the Distributor machine, use the Select Administration Server tool to select the instance you want to configure.

**Step 2** If you want to obtain the currently configured multi-tenant parameter limits, run the following command:

```
cl /show
```

**Step 3** To change a multi-tenant parameter limit, enter a command in the following format:

```
cl /id [ConfigLimitID] /value [ConfigLimitCurrentValue] [/update]
```

where:

ConfigLimitID = the ID for the multitenant parameter that you want to change. Possible values are:

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Skill_Groups_Per_Agent</td>
</tr>
<tr>
<td>2</td>
<td>MAX_DNC_LIST_SIZE</td>
</tr>
<tr>
<td>3</td>
<td>MAX_SIP_PORTS</td>
</tr>
</tbody>
</table>

ConfigLimitCurrentValue = the new limit for the parameter.

Note: The configlimit tool only allows the changing of the ConfigLimitCurrentValue. You cannot change the ConfigLimitDefaultValue.
For example, the following command line changes the ConfigLimitCurrentValue value of MAX_SIP_PORTS to 250:

```
cl /id 3 /value 250 /update
```

**Note:** In Contact Center Hosted (CCH) deployments, configure customers with Configuration-only Administration and Data Servers so they do not have access to modify the DNC or SIP Dialer.

---

**See Also**

Chapter 8

Reporting Installation and Configuration for Cisco Unified Contact Center Hosted

Unified IC is the reporting application for the Unified CCH environment.

Refer to the Cisco Unified Intelligence Center 8.0 Solution Reference Network Design (SRND) (http://www.cisco.com/en/US/products/ps9755/tsd_products_support_series_home.html) guide for detailed information about configuring Unified IC for Unified CCH.

For complete instructions on installation and configuration of these reporting applications, see the Unified IC documentation (http://www.cisco.com/en/US/products/ps9755/tsd_products_support_series_home.html).

Note: Beginning with Release 8.5(1), WebView is no longer supported.
Chapter 9

Installing and Configuring Cisco Multichannel Components for Cisco Unified Contact Center Hosted


There is one caveat specific to Unified CCH: you must deploy multichannel components dedicated to each particular customer instance. That is, there is no multi-tenant multichannel capability.
Advanced Services and Feature Control

Advanced Services allows service providers to offer call center routing services to end-customers independent of any end-customer equipment, such as ACDs, PBXs, key systems or even simple analogue phone lines. This section describes how to set up and administer an Advanced Services instance.

Note: For information about the relationship between Advanced Services and Customer Concept, refer to the Setup and Configuration Guide for Cisco Unified ICM Hosted.

This chapter contains the following topics:

- Introduction, page 73
- Setup and Configuration of an Advanced Services ICM Instance, page 74
- Configuration of New Advanced Services Customer, page 76

Introduction

There is a special ICM instance that is used for Advanced Services. The Advanced Services ICM is a multi-customer instance. A single Advanced Services ICM can support large numbers of customers. Advanced Services customers have web-based tools to control and manage their call routing, specifically WebView and Unified IC for reporting and Internet Script Editor for call routing.

An Advanced Services ICM is an ICM instance just like any other, but it is configured differently. This means that a CICM complex can run a single Advanced Services ICM and a maximum of 24 CICMs. However, for performance reasons it is desirable to run an Advanced Services ICM on its own dedicated hardware.

To support multiple subscribers on the same Advanced Services ICM, Advanced Services has a particular concept of a customer. A customer is an organization that uses Unified ICM to manage its call center. Each customer has its own configuration elements, such as dialed numbers, labels, call types, scripts, VRU scripts and scheduled targets. All these configuration elements
are stored in the same Advanced Services ICM database, but the reporting and scripting tools will make sure that a specific customer only has access to his own data. Since Advanced Services customers do not have ACD and Peripheral Gateways there are no configuration elements like peripherals, services, skill groups, and so forth.

No special security is applied at the customer level. Any Administration & Data Server user with access to the Advanced Services ICM instance can choose to view data for any or all customers in that instance. So the Service Provider can use the Administration & Data Server to administer the Advanced Services ICM as any other ICM instance. Advanced Services customers must only have access to their data using WebView, Unified IC, and Internet Script Editor. These tools will prevent a customer from accessing other customer data. This is achieved by having a user login with a personal userid and password. The user ID is tied to a specific customer and WebView, Unified IC, and Internet Script Editor will only expose this customer's data. Each individual user also has a profile, called a Feature Set, that determines his or her access rights in detail.

The following table provides an overview of the tools used by the Service Provider and the end-customer for day-to-day management tasks.

<table>
<thead>
<tr>
<th>Task</th>
<th>Service Provider (Tool)</th>
<th>End-user (Tool)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration</td>
<td>Configuration Manager</td>
<td>N/A</td>
</tr>
<tr>
<td>Scripting</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New scripts</td>
<td>Administration &amp; Data Server Script Editor</td>
<td>Internet Script Editor in full edit mode</td>
</tr>
<tr>
<td>Structural script changes</td>
<td>Administration &amp; Data Server Script Editor</td>
<td>Internet Script Editor in full edit mode</td>
</tr>
<tr>
<td>Changing script parameters</td>
<td>Administration &amp; Data Server Script Editor</td>
<td>Internet Script Editor in quick edit mode</td>
</tr>
<tr>
<td>Reporting</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Defining and running report based on existing template</td>
<td>WebView and Unified IC, using Call Type reporting and scheduling, exporting and e-mail options</td>
<td>WebView and Unified IC, using Call Type reporting</td>
</tr>
<tr>
<td>Defining custom reporting template</td>
<td>Using Sybase InfoMaker to define new Call Type templates</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Setup and Configuration of an Advanced Services ICM Instance

The following steps are required to setup and configure an Advance Services ICM instance. These steps assume that a NAM has been setup with at least one Network VRU connected to it.

- Install a new ICM instance.

This includes installing a Logger, Router with INCRP NIC and one or more Administration & Data Servers (Administration & Data Server instances) for the Service Provider to manage the service. Do not configure or install any Peripheral Gateways (PGs), since they are not used by Advanced Services.
• Install one or more WebView, Unified IC, and Internet Script Editor Servers that will act as web servers for end-customer use.

A WebView or Unified IC server will fetch real-time data for reporting purposes from its local Administration & Data Server (if installed on an Administration & Data Server) or from another Administration & Data Server's real-time Administration & Data Server. Historical data will be fetched from an Administration & Data Server with the Historical Data Server (HDS) option installed. This could be the same or a different Administration & Data Server as the WebView or Unified IC server.

The remainder of the setup is identical to setting up a regular Administration & Data Server.

• Configure the Network VRU. Only Network VRUs of Type 3, 5, 6 or 7 are supported with Advanced Services.

• Enter customer specific configuration data using Configuration Manager. For each customer this consists of the elements listed in the following table.

<table>
<thead>
<tr>
<th>Data elements</th>
<th>Required/optional</th>
<th>Tool used to configure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer</td>
<td>Required</td>
<td>ICM Instance Explorer</td>
</tr>
<tr>
<td>Feature Control Set</td>
<td>Required (although generic, non-customer specific feature control sets can be used)</td>
<td>Feature Control Set List</td>
</tr>
<tr>
<td>User</td>
<td>Required (but see the &quot;User (page 77)&quot; section)</td>
<td>User List</td>
</tr>
<tr>
<td>Call Type</td>
<td>Required</td>
<td>Call Type List</td>
</tr>
<tr>
<td>Dialed Number</td>
<td>Required(^1)</td>
<td>Dialed Number List</td>
</tr>
<tr>
<td>Label</td>
<td>Required unless dynamic labels are usedâ€”which they must not be because of security reasons</td>
<td>Label List</td>
</tr>
<tr>
<td>Label List</td>
<td>Optional</td>
<td>Network VRU Script List</td>
</tr>
<tr>
<td>Scheduled Target</td>
<td>Optional</td>
<td>Scheduled Target Explorer</td>
</tr>
<tr>
<td>Routing Script</td>
<td>Required unless performed by the customer using Internet Script Editor</td>
<td>Script Editor</td>
</tr>
</tbody>
</table>

The next section describes these steps in detail.

Enter customer specific configuration data in the NAM. This is identical to normal ICM instances and is only summarized here. The main customer specific configuration elements in the NAM are:

• Labels

• Dialed Numbers

\(^1\) Population of Dialed Numbers and Labels in the Advanced Services ICM can be automated when CICM replication is used. See Chapter 4, â€œCustomer Concept.â€‌
Configuration of New Advanced Services Customer

For each new Advanced Services customer, the following configuration elements need to be defined by the Service Provider.

For more information, refer to the *Configuration Guide for Cisco Unified ICM/Contact Center Enterprise and Hosted*, the Configuration Manager online help, and the *Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted*.

Feature Control Set

Perform the following steps to configure Feature Control Set.

**Step 1**
Access the Select Administration Instance tool by selecting **Start > All Programs > Cisco Unified CCE Tools > Administration Tools > Select Administration Instance**. The Select Administration Instance window appears.

**Step 2**
Select the instance you will be configuring.

**Step 3**
From within the Administration Tools folder, double-click the **Configuration Manager**.

**Step 4**
Open the Feature Control Set List tool (**Tools > List Tools > Feature Control Set List**). The Feature Control Set List window appears.

Configure a Feature Control Set that contains the maximum number of elements that this customer can get access to. Since an Advanced Services customer will never use the Configuration Manager, uncheck all check boxes.

Under the Script Editor application, click **Advanced**. Under Edit Options, select either **Full Editor**, or **Quick Edit**. This determines what edit mode this user is allowed to use.

Under Node Control uncheck each Script Node that this profile must not provide access to. For Advanced Services, the following nodes must always be unchecked, since they are not permissible with Advanced Services:

- Agent
- Agent to Agent
- DB Lookup
- Enterprise Service
- Enterprise Skill Group
• Gateway
• ICM Gateway
• Queue to Agent
• Route Select
• Select
• Service
• Skill Group
• Translation Route to VRU

In particular, the DB Lookup and Gateway nodes must not be allowed end-customer access since they might expose other customer data. It is possible for Advance Services Scripts to use these nodes for database lookups. The DB Lookup and Application Gateway configuration must be controlled entirely by the Service Provider and not by the end-customer. An end-customer must not get access to these nodes since it will expose other customers' databases and external applications. This implies that end-customers do not have full edit access to routing scripts containing these nodes, since they will not be able to full edit scripts that include these nodes.

Note: Creating a custom DB on the Logger or HDS is not supported.

Multiple Feature Control Sets can be defined for a single customer. Feature Control Sets are assigned to a user (not a customer), so that different users can have different levels of access.

Customer

Using ICM Instance Explorer, configure a new Customer under the Advanced Services ICM Instance. Select a Network VRU to be used by this customer and the customer level Feature Set. This Feature Set is used for users associated with this Customer, unless the user is associated with a different Feature Set in the User List tool.

User

Note: You only need to use the User List tool if the user will have restrictions (such as Feature Control or Read-only); otherwise, the user can be given access using Domain Manager.

Using the User List tool, configure one or more users for this customer.

• In the Domain name field, select the Active Directory (AD) Domain that this user's AD domain account is going to be created in. This would typically not be the CICM domain, but a separate domain specific to the WebView, Unified IC, and Internet Script Editor servers.
• The User name for this user. This becomes the AD domain username as well.
• The user’s **Password**. This becomes the AD domain user's password as well.

• The **Customer** created using the ICM Instance Explorer, or All Customers.

• Select the **Feature Control Set** that is to be associated with this user. If the setting chosen is `<None>`, the Customer level feature control set will be used.

• Checking **Configuration** gives the user access to Configuration Manager and Script Editor. If you also check **Read only**, the user cannot make any changes using Configuration Manager or Script Editor. In any case, the user's feature control set determines which routing scripts the user can access.

• Checking **Setup** gives the user access to Setup, Configuration Manager, Script Editor, and WebView.

• Checking **WebView** gives the user access to WebView.

  **Note:** This checkbox is not applicable when deploying Unified IC.

**Call Type**

Configure one or more call types for this customer using the Call Type List tool. Select the associated customer from the Customer drop-down menu.

*Figure 9: Call Type List Dialog*

**Dialed Number**

Configure one or more Dialed Numbers for this customer using the Dialed Number List tool. On the attributes tab, select the associated customer from the Customer drop-down menu.
On the Dialed Number Mapping tab, select a Call Type mapping for this Dialed Number. The tool will only show Call Types defined for the customer selected on the attributes tab.

Scheduled Target

Configure one or more Scheduled Targets for this customer using Scheduled Target Explorer. Select the associated customer from the Customer drop-down menu.

Label

You can add one or more Labels for each Scheduled Target using this tool or using the Label List tool. In either case, select the same customer for the Label as selected for the Scheduled Target. Select the associated customer from the Customer drop-down menu.
Observe the following guidelines for labels:

- If this is a standard Label to be used in a Label or Divert Label node, leave the Target Type and Network Target set to None.

- If this is a Label for a Scheduled Target Type, select the Scheduled Target from the Network Target drop-down menu.

- You can configure multiple labels for Scheduled Targets, but for a specific Routing Client only the first label will be used; therefore, when you configure multiple labels, configure each for a different Routing Client. Configuring more than one label for the same Routing Client will have no effect.

Network VRU Script

Configure one or more Network VRU Scripts for this customer using the Network VRU Script List tool. Select the associated customer from the Customer drop-down menu.

Routing Script

The Service Provider can either create routing scripts for the customer or the customer can use Internet Script Editor to create routing scripts himself.
When the Service Provider is creating routing scripts for an end-customer, the scripts are not automatically associated with any specific customer. Use the following action to associate a script with a specific customer, so that the customer can get access to it:

- Make sure the script is saved.
- Using Script Editor, select Script Explorer from the File menu.
- Under All Customers, Default business unit, locate the script(s) to associate with a specific customer and drag them over to the customer's Default business unit. Dragging the mouse pointer to the customer and holding it there briefly will show the default business unit.
Chapter 11

Scripting Considerations


This chapter contains the following topics:

- NAM Script Configuration, page 83
- CICM Scripting Considerations, page 87

NAM Script Configuration

Scripting on the NAM only requires one Dialed Number script per Customer Instance; however, your design might include more.

The NAM routing script sends the dialed number to the correct Unified CVP Media Server for treatment, then ultimately to the ICM Gateway of the CICM instance for the particular Dialed Number.
Figure 14: Example NAM Routing Script

The first script node after the Start should be a "set variable" node that contains the following:

- Object Type — Call
- Object — (no selection)
- Variable — NetworkTransferEnabled
- Value — 1
After you have set the variable for NetworkTransferEnabled you can create a Dialed Number (DN) Node to route to a particular CICM Instance Routing Client.

If the Dialed Number node is true, then you typically send the call to the Unified CVP Media Server using another Set Variable node as described below.

The first script node after the star should be a “set variable” node that contains the following:

- **Object Type** — Call
- **Object** — (no selection)
- **Variable** — user.microapp.media_server
- **Value** — the IP address of the Unified CVP Media Server, enclosed in quotes, for example "192.168.10.11"
At this point, scripting is conducted on the Unified CVP. (Refer to the Configuration and Administration Guide for Cisco Unified Customer Voice Portal (http://www.cisco.com/en/US/products/sw/custcosw/ps1006/products_installation_and_configuration_guides_list.html) for details on scripting in Unified CVP.)

Finally, the call is sent to the Unified ICM gateway of a particular customer instance. If multiple DNs are used, then you can send the call to a different Unified CVP Media Server based on the different DN, as in the Example NAM Routing Script (page 84) figure preceding.

Finally, the call is sent to the Unified ICM gateway of a particular customer instance. Add an ICM Gateway Node and select the customer to which to route the call.
Note: Do NOT select the Validate returned labels checkbox. If you do so, you will have to provision the NAM with all of the labels that exist on every customer instance.

CICM Scripting Considerations


Create CICM VRU Scripts

VRU Scripts differ from Unified ICM routing scripts. A configured VRU Script runs only when the system software instructs it to do so from a Unified ICM routing script. A VRU Script on Unified ICM is the configured record for the VRU script that resides on the Unified CVP. A VRU Script executes to collect digits, play hold music, or perform many other common IVR functions.

Step 1

From the Configuration Manager, select Targets > Network VRU Script > Network VRU Script List.

The Network VRU Script List dialog displays.

Step 2

On the Attributes tab, enter the configuration information for the BasicQ script as follows:

a. Network VRU — Enter isnvru.

b. VRU Script Name — Enter script name (for example, BasicQ).

c. Name — Enter the script file name (for example, BasicQ.aef).

d. Timeout [seconds] — Enter 180.

e. Configuration param — Leave blank.

f. Customer — Select the same Unified ICM customer you selected for Call Type from the drop-down list.

Step 3

Select Interruptible (checkbox).

Step 4

Click Save, then click Close.
CICM VRU Script Considerations

Use the CICM Script Editor’s SendToVRU node to connect the call to the Network VRU.


Note: A RunVRU Script or Queue node is an "implicit" SendToVRU node, although error handling is easier if the explicit SendToVRU node is used.

RONA and Unified CVP

When using Unified CCH with Unified CVP, the ICM Router Requery function is used to take the call away from the non-answering agent and requeue it for service.

There are two places in which configuration must occur:

• in the Agent Desk Settings - the Ring no answer dialed number field must be blank, and a ring no answer time must be set.

• in the Script (see below):

  – The Queue node for the skill group that selects the first agent must have Target Requery enabled.

  – The priority of the call should be raised so that it goes to the front of the queue.

Scripting for RONA

When scripting for RONA, you should Enable Requery on the node in the script that selects the first agent. Depending on the type of node used, the Requery mechanism selects a new target from the available agents or requires additional scripting. The Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted (http://www.cisco.com/en/US/products/sw/custcosw/ps1001/tsd_products_support_series_home.html) describes how Requery works for the different nodes.
The Queue node selects the longest available agent from the skill groups configured, if there is an available agent. If there is no available agent, the script then queues the call with a priority set in the node and continues down the success exit of the node.

When an agent becomes available, Unified ICM will always select the longest queued call from the ones with the highest priority.

The RONA mechanism works as follows:
1. The Queue node selects an agent.

2. If the agent does not answer the call, the script exits through the failure exit of the Queue node.

3. The If node tests the RequeryStatus variable. If it has value of greater than zero, this is a requery call, and the script re-queues the call.

4. In the example above it also sets a flag using a call variable for reporting purposes.

5. Assuming that there are no agents available, the Queue node immediately exits through the success exit.

6. The If node checks if this is a required call.

7. If so, it increases the Queue Priority of the call so that it gets handled before any other calls in queue.

8. It then enters the normal wait loop with RunScripts.
Chapter 12

Security Considerations

The Unified CCH product allows several customers to share the same Central Controller complex. This presents some possible security concerns in the following areas:

• Relationships between Windows domains
• Preventing unauthorized access to real-time data
• Access to historical data

This chapter discusses these concerns and the means by which the Unified CCH product addresses them.


This chapter contains the following topics:

• Windows Domains, page 91
• Validating Real-Time Clients, page 92
• Historical Data Server, page 93

Windows Domains

Components in this architecture are divided among several Windows domains. All NAMs and their associated Administration & Data Servers are in a single domain. Each CICM complex and its associated Administration & Data Servers is in a separate domain.

Each instance’s Administration & Data Servers can be in two different domains:
Validating Real-Time Clients

To prevent unauthorized access to real-time data, you can configure Unified ICM’s Real-Time Server process to validate each connection. This ensures that only expected clients receive the real-time data.

To set up this validation, you must edit the Windows Registry on the CallRouter machine. Locate the customer’s subtree under the registry tree `HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM`. The customer’s subtree contains either a RouterA or RouterB tree. Under that tree locate RealTimeServer\CurrentVersion\Clients.

![Registry Editor on CallRouter](image)

To allow access for a specific machine or subnet, you must specify an IP address (IP00, IP01, IP02, etc.) and a corresponding mask (IP00Mask, IP01Mask, IP02Mask, etc.). The IP address
can be a complete or partial address. The mask indicates which part of the address must match. You can specify up to 30 addresses and associated masks.

For example, to allow access only to a machine with an address of 199.99.123.45, specify that value as IP00 and set IP00Mask to 255.255.255.255 (meaning to match all four octets of the address). To then allow access to any member of the 199.99.125 subnet, set IP01 to 199.99.125.0 and set IP01Mask to 255.255.255.0 (meaning to match only the first three octets of the address).

The IP mask 0.0.0.0 is a special value indicating that the associated IP address is to be ignored. By default, all the masks are set to this value. If Unified ICM does not find any valid values, it allows any machine to connect.

**Historical Data Server**

Administration & Data Servers need to access historical data (15-minute and half hour data, call detail, and so forth). The system software normally stores historical data in the central database on the Logger, as well as on the Administration & Data Server that acts as the Historical Data Server (HDS).

One Administration & Data Server at each admin site is an HDS machine. The Central Controller forwards historical records to the HDS machine for storage in a special local database (awdb). Other Administration & Data Servers at the local site can retrieve historical data from the HDS machine without having to access the central site (see the following figure).

*Figure 21: Historical Data Server Architecture*

To set up an Historical Data Server, you must configure the Logger to perform historical data replication. You must also configure an Administration & Data Server to be an Historical Data Server. You can use the ICMDBA tool to create an HDS database, then use the Web Setup tool to add an Administration & Data Server with an HDS role.
Small to Medium Historical Data Server Deployments

**Note:** Before reviewing this section, review the *Cisco Unified Contact Center Enterprise 8.x Solution Reference Network Design (SRND)* at [http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_implementation_design_guides_list.html](http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_implementation_design_guides_list.html) for scalability details about small to medium deployments.

In this deployment, all agent-related historical data is replicated to an HDS.

This deployment type supports the following Logger setup:

- Maximum of 2 Loggers
- Maximum of 2 Historical Data Servers allowed per Logger side

There are three options available for an Administration & Data Server role in a small to medium deployment:

- **Administration Server, Real-time and Historical Data Server and Detail Data Server (AW-HDS-DDS):** Stores real-time, historical, call detail, and call variable data, including agent historical data filtered by peripheral

  This role is similar to the "Distributor AW with HDS" role in previous ICM releases. It provides ability for configuration changes as well as both real-time and historical reporting. The real-time and historical reporting is supported using one of two reporting clients: WebView server or Cisco Unified Intelligence Center (CUIC). The call detail and call variable data are supported for custom reporting data extraction to meet the requirements for System Call Trace tool and feed historical data to the CUIS (Archiver).

- **Administration Server and Real-time Data Server (AW):** Stores real-time data, including agent historical data filtered by peripheral, but no historical data

  This role is similar to the "Distributor AW" role in previous ICM releases. This role provides the ability for configuration changes as well as for real-time reporting. The real-time reporting is supported using either WebView server or Cisco Unified Intelligent Center (Reporting client). This role does not support historical reporting.

- **Configuration-Only Administration Server:** HDS is not enabled and real-time reporting is turned off. This deployment only allows configuration changes with no real-time and historical reporting.

**See Also**

Refer to the *Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted* for details about how to use the Web Setup tool to add Administration & Data Servers.
Large Historical Data Server Deployments

**Note:**


- This deployment is *not* supported in Unified SCCE; however, Unified SCCE Release 7.5 is supported in the 8.0(1) solution.

In this deployment, historical data can be distributed for scalability purposes.

This deployment type supports a maximum of 4 Historical Data Servers per Logger side, which can be configured as 3 AW-HDS and 1 HDS-DDS deployments (see descriptions below).

There are four options available for an Administration & Data Server role in a large deployment:

- **Administration Server and Real-time and Historical Data Server (AW-HDS):** Stores real-time and historical data, including agent historical data filtered by peripheral, but no call detail and call variable data

  This role provides ability for configuration changes as well as for both real-time and historical reporting. The real-time and historical reporting is supported using either WebView server or Cisco Unified Intelligent Center (Reporting client).

- **Historical Data Server and Detail Data Server (HDS-DDS):** Stores only historical data, including all agents and detail data (TCD, and so on) with additional indices (this option is limited to one per Logger side)

  This role provides support for historical reporting. Call Detail data extraction for System Call Trace tool and feed to CUIS Archiver. This deployment also includes configuration data available for historical reporting. Real-time data reporting and the ability to make configuration changes are not supported.

- **Administration Server and Real-time Data Server (AW):** Stores real-time data, including agent historical data filtered by peripheral, but no historical data

  This role is similar to the "Distributor AW" role in previous ICM releases. This role provides the ability for configuration changes as well as for real-time reporting. The real-time reporting is supported using either WebView server or Cisco Unified Intelligent Center (Reporting client). This role does not support historical reporting.

- **Configuration-Only Administration Server:** HDS is not enabled and real-time reporting is turned off. This deployment only allows configuration changes with no real-time and historical reporting.
See Also

Refer to the *Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted* for details about how to use the Web Setup tool to add Administration & Data Servers.

For specific information about setting up an HDS database, see Chapter 4, "[Database Administration](#)."
Chapter 13

Example Deployment

This section contains an example deployment for configuring for IP Contact Center - Hosted Edition with Unified CVP Comprehensive.

Cisco Unified Contact Center Hosted with Cisco Unified Customer Voice Portal Comprehensive Deployment

The following tasks outline an example deployment of IP Contact Center Hosted-Edition with Comprehensive Unified CVP. These tasks detail configuration after the installations of the NAM and CICM Loggers, Call Routers, Administration & Data Servers, and PGs.

Table 7: Unified CVP Comprehensive

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAM</td>
<td>Configure Network VRU for Switch Leg</td>
<td>Configuring the NAM Network VRU for the Unified CVP Switch Leg (Type 5) (page 98)</td>
</tr>
<tr>
<td></td>
<td>Define Network VRU for the VRU Leg</td>
<td>Configuring the NAM for the Unified CVP VRU Leg (Type 7) (page 99)</td>
</tr>
<tr>
<td></td>
<td>Define System Information and Default Network VRU</td>
<td>Define System Information and Default Network VRU on the NAM (page 99)</td>
</tr>
<tr>
<td>NAM Unified CVP PG</td>
<td>Configure PG for Switch Leg</td>
<td>Configuring the NAM for a Unified CVP PG (page 50)</td>
</tr>
<tr>
<td></td>
<td>Configure Unified CVP PG for the Client Leg</td>
<td></td>
</tr>
<tr>
<td>NAM and each CICM Instance</td>
<td>Define ECC Variables</td>
<td>Configure ECC Variables (page 100)</td>
</tr>
<tr>
<td>Each CICM Instance</td>
<td>Configure Network VRU for Switch Leg</td>
<td>Configuring the CICM for the Unified CVP Switch Leg (Type 5) (page 102)</td>
</tr>
</tbody>
</table>
Warning: Labels assigned to device targets for an Unified CVP routing client within a particular partition should be checked to ensure that the labels are ONLY defined on that customer's partition. Transfers between customer instances are possible if the same labels are assigned on multiple customer partitions.

Configuring the NAM Network VRU for the Unified CVP Switch Leg (Type 5)

**Step 1**  
On the NAM Administration & Data Server, open Configuration Manager > Tools > Explorer Tools > Network VRU Explorer tool.

**Step 2**  
Click Retrieve.

**Step 3**  
Click Add Network VRU.  
The Network VRU Tab displays.

**Step 4**  
Provide a name, for example Unified CVPSwitch.

**Step 5**  
Select Type 5.

**Step 6**  
Highlight the Network VRU that you just created.

**Step 7**  
You must create a label for each Unified CVP Application Server that is handling the switch leg:

a. Click Add Label.  
The Label tab displays.

b. Select the Routing Client.  
The Routing Client was created during the PG configuration. See Installing NAM Unified CVP PG (page 49) for more information on the routing client.

c. Provide a number for the label. For example, 8888.

d. Select Normal for the Label Type.

**Step 8**  
Click Save.
Configuring the NAM for the Unified CVP VRU Leg (Type 7)

**Step 1**
On the NAM AW, open Configuration Manager > Tools > Explorer Tools > Network VRU Explorer tool.

**Step 2**
Click Retrieve.

**Step 3**
Click Add.

The Network VRU Tab displays.

**Step 4**
Specify a Client type of Type 7.

**Step 5**
Provide a Name.

**Step 6**
Highlight the Network VRU that you just created.

**Step 7**
Click Add Label.

The Label Tab displays.

**Step 8**
In the label field, enter the network routing number.

*Note:* Make sure the Network VRU label is identical in both the NAM and CICM. It is recommended that the Network VRU name be identical as well to avoid confusion.

**Step 9**
Select Normal for the type.

**Step 10**
Select the Routing Client.

The Routing Client was created during the PG configuration. See Installing NAM Unified CVP PG (page 49) for more information on the routing client.

**Step 11**
Click Save.

Define System Information and Default Network VRU on the NAM

**Step 1**
On the NAM AW, open Configuration Manager > Tools > Miscellaneous Tools > System Information.

The System Information window displays.

**Step 2**
Define the Minimum Correlation Number by setting it to the starting number for the Correlation ID, for example 10000.

**Step 3**
Define the Maximum Correlation Number by setting it to the ending number for the Correlation ID, for example 99999.
Step 4 Define a default VRU by selecting one from the Default Network VRU drop-down menu. This should be the Type 5 VRU.

Step 5 Check Enable expanded call content (checkbox).

Step 6 Click Save.

Configure ECC Variables

You need to set up ECC variables that the Unified CVP uses to exchange information with Unified ICM/NAM.

Step 1 Within Configuration Manager on a NAM or CICM Administration & Data Server, select Tools > Miscellaneous Tools > System Information.

Step 2 Select Enable expanded call context (checkbox).

Step 3 Within Configuration Manager, select Tools > List Tools > Expanded Call Variable List.

Step 4 In the Expanded Call Variable List window, enable the Add button by clicking Retrieve.

Step 5 Click Add.

The Attributes property tab is enabled.

Step 6 Create each of the variables in the table below (Unified CVP ECC Variables), clicking Save after defining each variable.

Note: It is important that you enter the ECCs Name values listed in Table C-17 exactly as specified. If you do not, NAM/Unified ICM is not able to successfully communicate with the micro-applications on the Application Server. Length values are a bit more flexible. Unless the values listed in the table below are specifically noted as "required", the value in the Length column is the maximum the NAM/Unified ICM can handle for that ECC; you can specify a value between 1 and the maximum length.

Unified CVP ECC Variables

Note: ECC Variables must exactly match on both the NAM and the CICMs.

Table 8: ECC Variables

<table>
<thead>
<tr>
<th>Name</th>
<th>Length</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>user.media.id</td>
<td>Required value: 36</td>
<td>A number identifying a call to the Application Server and, optionally, the Voice Browser:</td>
</tr>
<tr>
<td>Name</td>
<td>Length</td>
<td>Definition</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>user.microapp.currency</td>
<td>Required value: 6</td>
<td>Currency Type</td>
</tr>
<tr>
<td>user.microapp.error_code</td>
<td>Required value: 2</td>
<td>Return status error code to be returned from the Unified CVP to the NAM/CICM upon a false return code in the Run Script Result.</td>
</tr>
<tr>
<td>user.microapp.locale</td>
<td>Required value: 5</td>
<td>Locale, a combination of language and country which define the grammar and prompt set to use.</td>
</tr>
<tr>
<td>user.microapp.media_server</td>
<td>40</td>
<td>Root of the URL for all media files and external grammar files used in the script.</td>
</tr>
<tr>
<td>user.microapp.sys_media_lib</td>
<td>10</td>
<td>Directory for all system media files, such as individual digits, months, default error messages, etc.</td>
</tr>
<tr>
<td>user.microapp.app_media_lib</td>
<td>10</td>
<td>Directory for all application-specific media files and grammar files.</td>
</tr>
</tbody>
</table>

The system and application media libraries need message and prompt files created/recorded for each locale that will be referenced. For more information, turn to [Configuration and Administration Guide for Cisco Unified Customer Voice Portal](http://www.cisco.com/en/US/products/sw/custcosw/ps1006/products_installation_and_configuration_guides_list.html), Chapter 3, Prompt Recording and Distribution.

<table>
<thead>
<tr>
<th>Name</th>
<th>Length</th>
<th>Definition</th>
</tr>
</thead>
</table>
| user.microapp.grammar_choices | Configured on Unified ICM. Maximum length: 210 characters. | Specifies the ASR choices that a caller can input for the Get Speech micro-application. Each option in the list of choices is delimited by a forward slash (/).  
If text is placed in this variable that is longer than the variable is configured to handle, only the first 210 characters are sent. |
| user.microapp.inline_tts  | Configured on Unified ICM. Maximum length: 210 characters. | Specifies the text for inline Text To Speech (TTS).  
If text is placed in this variable that is longer than the variable is configured to handle, only the first 210 characters are sent. |
| user.microapp.input_type  | Required value: 1 | Specifies the type of input that is allowed.  
Valid contents are:  
• D - DTMF |

<table>
<thead>
<tr>
<th>Name</th>
<th>Length</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>user.microapp.caller_input</td>
<td>Configured on Unified ICM. Maximum length: 210 characters.</td>
<td>Storage area for any ASR input that is collected from Get Speech. Get Speech text results will be written to this ECC variable. Results from Get Digits or Menu micro-applications will be written to the CED.</td>
</tr>
<tr>
<td>user.microapp.pd_tts</td>
<td>Required value: 1</td>
<td>Specifies the text for inline Text To Speech (TTS). Valid contents are: • Y - Yes, use TTS capabilities • N - No, do not use TTS capabilities; play media files instead. Used only with Play Data micro-application.</td>
</tr>
<tr>
<td>user.num.steps.executed</td>
<td>Required value: 10</td>
<td>Used by system to track script progress.</td>
</tr>
<tr>
<td>user.session.handled</td>
<td>Required value: 5</td>
<td>Used by system to pass information.</td>
</tr>
<tr>
<td>user.task.id</td>
<td>Required value: 19</td>
<td>Used by system to pass information. Used only with Play Data micro-application.</td>
</tr>
<tr>
<td>user.connect.script.config</td>
<td>Required value: 40</td>
<td>Used by system to pass information.</td>
</tr>
<tr>
<td>user.connect.script.name</td>
<td>Required value: 39</td>
<td>Used by system to pass information.</td>
</tr>
<tr>
<td>user.connection.type</td>
<td>Required value: 17</td>
<td>Used by system to pass information.</td>
</tr>
<tr>
<td>user.last.redirected.address</td>
<td>Required value: 40</td>
<td>Used by system to pass information.</td>
</tr>
</tbody>
</table>

* These ECC variables are required for Application Server internal processing. Set them and forget them.

Configuring the CICM for the Unified CVP Switch Leg (Type 5)

**Step 1**
On the CICM Administration & Data Server, double-click **AW Select**.

The Select ICM AW Service window displays.

**Step 2**
Select the instance you will be configuring.

**Step 3**
From the ICM Configuration Manager, open **Tools > Explorer Tools > NIC Explorer tool**.

The NIC Explorer window displays.

**Step 4**
Select the INCRP NIC.
The Routing Client displays under the INCRP NIC.

**Step 5** Select the Routing Client.

The Routing Client Tab displays.

**Step 6** Click **Save**.

---

**Configuring the CICM for the Unified CVP VRU Leg (Type 7)**

**Step 1** On the CICM Administration & Data Server, open **Configuration Manager > Tools > Explorer Tools > Network VRU Explorer tool**.

**Step 2** Click **Retrieve**.

**Step 3** Click **Add**.

**Step 4** Specify a Client type of Type 7.

**Step 5** Provide a Name.

**Step 6** Highlight the Network VRU that you just created.

**Step 7** Click **Add Label**.

**Step 8** In the Label tab:

  a. In the label field, enter the network routing number.

  **Note:** Make sure the Network VRU label is identical in both the NAM and CICM. The Network VRU name must be identical as well to avoid confusion.

  b. Select **Normal** for the type.

  c. In the Routing-client field, select the INCRP routing client from the drop-down list.

**Step 9** Click **Save**.

---

**Define Default Network VRU on the CICM**

If all dialed numbers will use the same VRUs, it is easiest to use a default Network VRU, rather than to configure multiple Network VRUs.

**Step 1** On the CICM Administration & Data Server, open **Configuration Manager > Tools > Miscellaneous Tools > System Information**.

**Step 2** Define a default VRU by selecting one from the Default Network VRU drop-down menu.
Step 3

Click Save.
Additional Resources

Cisco provides Leading-Practice Deployment Templates for qualified partners. These documents provide the following templates and examples for an Unified CCH System.

They include:

- Unified CCH Low Level Design Template
- Unified CCH Network Implementation Plan Template
- Unified CCH Network Staging Plan Template
- Unified CCH Application Implementation Plan Template
- Unified CCH Network Ready for Use Test Plan Template

The templates include checklists and ordered steps for turning up your Unified CCH system. Contact your account representative to gain access to these guides.

The table below lists the Cisco documentation resources that contain detailed instructions for installing and configuring the NAM, CICM, and ICM portions of the Unified CM.

<table>
<thead>
<tr>
<th>Component</th>
<th>Guide(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component</td>
<td>Guide(s)</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Component</td>
<td>Guide(s)</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
## Index

Adding

- components for instances....25
- instance to a CICM....18
- new instance to a CICM....15

Administration & Data Servers

- configuring CICM associated....48
- definition....44
- installing a CICM Network....20
- installing on NAM....44
- types....44

Advanced Services, about....73

Application Gateways, creating....55

Assigning instance number to a CICM....17

CallRouters

- installing....43
- installing on the CICM....20

Changing multi-tenant parameter limits....66

Checklists

- hardware installation....9
- software installation....10

Components

- core, about....8
- hardware, about....8
- software, about....8

Configuring

- agent phones in Unified CM....28
- CallRouter on CICM....20
- CICM, about....15
- CICM's INCRP NIC....21
- CICM associated Administration & Data Servers....48
- CICM Loggers....19
- CICM scripts....87

CTI route points in Unified CM....29

Device Management Protocols for NAM PGs....55

gateways to interact with Unified CVP....37

NAM for a Unified CVP PG....50

NAM scripts....83

Outbound Option....65

Outbound Option Multi-Tenant customer instances.65

software components....12

Unified CM, about....27

Unified CM multi-tenancy....30

Unified CVP for Unified CCH....37

Core components, about....8

Creating

- CICM Unified CM PG user....29
- CICM VRU scripts....87

CTI OS

- failover....63
- installing the Server....60
- processes....63
- Server installation guidelines....59
- starting the service after installation....63

CTI OS server instance, in IPCC Hosted deployments...61

CTI Server, CTI OS Multi-Instance....62

Customers for CICM instances, configuring on NAM....48

database names....16

defining NICs....21

deployments

- Large HDS....95
- Small to Medium HDS....94

deployments, about Unified CCH....7

documentation resources....105

domains, Windows....91

duplicate extensions, setting up in different customer instances....33

dynamic routing client....38

Feature control, about....73
gateways, setting up to interact with Unified CVP...37
hardware components, about....8
Historical Data Server
  architecture....93
  Large deployments....95
  Small to Medium deployments....94
installing
  CallRouter on CICM...20
  CallRouter on NAM...43
  CICM, about....15
  CICM Network Administration & Data Server...20
  CTI OS Server....59
  hardware checklist....9
  Logger on CICM....19
  Logger on NAM....41
  multiple instances of the PG...8
  NAM Unified CVP PG....49, 51
  Network Administration & Data Servers....44
  Outbound Option....65
  post-installation setup and installing multiple components....43
  software checklist....10
  Unified CM....27
  Unified CVP for Unified CCH....36
instanceno.exe....17
instances
  adding and upgrading components....25
  configuring multiple customer....8
  naming conventions....16
  procedure for adding to CICM....18
  removing....25
  selecting a CICM....16
instances for CICMs, configuring on NAM....46
Loggers
  installing on CICM....19
  installing on NAM....41
masking....92
multichannel components, installing and configuring....71
multi-customer systems....43
multiple components, installing....43
NAM configuration data....45
naming conventions
databases....16
instances....16
NAM Logger, installing....41
NAM Replication Process (NRP)....46
Network Interface Controller, INCRP....21
Network Voice Response Units (VRUs)....80
NICS, defining....21
Peripheral Gateway, configuring on NAM....55
peripherals, multi-tenancy....8
PG services, stopping associated....28
Physical controller ID, INCRP NIC....21
production environment worksheet....13
Quality of Service (QoS)....25
real-time clients, validating....92
removing an instance....25
reporting applications, installing and configuring....69
scripting
  about....83
  CICM....87
  CICM VRU....88
security concerns....91
setting up
  CICM software to interact with Unified CVP....37
  NAM software to interact with Unified CVP....37
software components, about....8
translation route to VRU....39
upgrading components for instances....25
VRU....80