Configuration Guide
for Cisco Unified ICM/Contact Center Enterprise and Hosted
Release 8.0(2)

April 2012
# Table of Contents

Preface ........................................................................................................................................................... 1  
Purpose .......................................................................................................................................................... 1  
Audience ...................................................................................................................................................... 1  
Organization ............................................................................................................................................... 1  
Related Documentation ............................................................................................................................. 3  
Product Naming Conventions ................................................................................................................... 3  
Conventions .................................................................................................................................................. 4  
Obtaining Documentation and Submitting a Service Request ................................................................. 5  
Documentation Feedback ......................................................................................................................... 5  

1. Configuration Overview ............................................................................................................................... 7  
   Software Overview ........................................................................................................................................ 7  
      Cisco Unified Intelligent Contact Management Overview ..................................................................... 7  
      Cisco Unified Contact Center Enterprise Overview ............................................................................... 8  
   Configuration Management ....................................................................................................................... 9  
   Script Management .................................................................................................................................... 9  

2. How Routing Works ................................................................................................................................... 11  
   The Routing Process .................................................................................................................................. 11  
   Steps in the Routing Process .................................................................................................................... 12  
   Routing Requests ...................................................................................................................................... 13  
   Targets ...................................................................................................................................................... 13  
      Cisco Unified Intelligent Contact Management Enterprise System Processing .................................. 15  
      Routing Client's Processing ................................................................................................................... 18  
      The Peripheral's Processing .................................................................................................................. 19  
   Translation Routes .................................................................................................................................... 19  
   Timeouts and Thresholds ........................................................................................................................... 20  
      Routing Clients ...................................................................................................................................... 20  
      Abandoned Call Wait Time .................................................................................................................... 21  
      Service Level ......................................................................................................................................... 22  
   Configuring Service Levels ....................................................................................................................... 23  
      Configuring the System Information Service Level for Call Types ....................................................... 24  
      Configuring the Service Levels for Specific Call Types ...................................................................... 24  
      Service Level Relationships: Media Routing Domain, Peripheral, and Skill Groups ......................... 25  
      Configuring the Service Level for the Media Routing Domain ............................................................ 27  
      Configuring the Service Level for a Peripheral ................................................................................... 27  
      Configuring the Service Level for Skill Groups .................................................................................. 28  
      Configuring the Service Level for an Aspect VRU ............................................................................ 29  

3. The Configuration Manager ....................................................................................................................... 31  
   Accessing the Configuration Manager ..................................................................................................... 32  
   Using the Configuration Manager .......................................................................................................... 32  
   Online Help .............................................................................................................................................. 33  
   Configuration Manager Tools ................................................................................................................. 34  
      Bulk Configuration Tools .................................................................................................................... 35  
      Explorer and List Tools ....................................................................................................................... 36  
      Miscellaneous Tools ............................................................................................................................ 38  
      Wizards ................................................................................................................................................ 38  
      Common Bulk, List, and Explorer Tool Features ................................................................................. 39  
      Common List and Explorer Tool Features .......................................................................................... 40
| 4. Configuring Multiple Records at a Time .................................................. 53 |
| How to Access the Bulk Configuration Tools .................................................. 53 |
| Data You Can Bulk Configure ...................................................................... 54 |
| Insert and Edit Windows .............................................................................. 54 |
| Bulk Configuration Features ........................................................................ 55 |
| Retrieving and Editing Records .................................................................. 56 |
| Sorting Records ............................................................................................ 57 |
| Finding Data in a List of Records ................................................................ 58 |
| Selecting Data .............................................................................................. 58 |
| Editing a Range of Data .............................................................................. 59 |
| Inserting New Records ............................................................................... 61 |
| Importing Data ............................................................................................. 62 |
| Import/Export Data File Format ................................................................... 63 |
| Exporting Data .............................................................................................. 64 |
| How to Export Data ...................................................................................... 64 |
| Applying Security Settings to Multiple Records .......................................... 65 |
| Deleting and Undeleting Records ................................................................. 66 |

| 5. Configuring Routing Clients .................................................................... 69 |
| The Routing Client Subsystem .................................................................... 69 |
| Interface Controllers .................................................................................. 70 |
| Examples of Routing Client Subsystems ...................................................... 70 |
| Configuring a Network Interface Controller (NIC) ....................................... 72 |
| How to View a NIC and Its Routing Client(s) .............................................. 72 |
| NIC Explorer Tab Descriptions ................................................................... 72 |
| Configuring Dialed Number/Script Selectors .............................................. 78 |
| Dialed Number/Script Selector List Tab Descriptions .................................. 78 |
| Configuring Dialed Numbers on the Child Central Controller ...................... 79 |
| Dialed Number/Script Selector List Tab Descriptions .................................. 80 |

<p>| 6. Configuring Peripherals and Trunk Groups .............................................. 85 |
| The Peripheral Subsystem ........................................................................... 86 |
| Peripheral Gateways (PGs) .......................................................................... 86 |
| Configuring a PG ........................................................................................ 87 |
| How to View PG Records ........................................................................... 87 |
| PG Explorer Tab Descriptions .................................................................... 88 |
| Defining PGs and peripherals ...................................................................... 99 |
| Configuring the System Peripheral Gateways ............................................ 100 |
| Modifying a PG or Peripheral ................................................................. 102 |
| Deleting a PG or a Peripheral ..................................................................... 103 |
| Configuring Agent Targeting Rules ............................................................ 104 |
| Configuring Trunk Groups and Trunks ....................................................... 106 |
| Network Trunk Groups, Trunk Groups, and Trunks ....................................... 106 |
| Trunk Tab Descriptions ............................................................................. 109 |</p>
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mapping Labels</td>
<td>160</td>
</tr>
<tr>
<td>How to Map Specific Labels to a Dialed Number/Script Selector</td>
<td>160</td>
</tr>
<tr>
<td>How to Set a Default Label for a Dialed Number/Script Selector</td>
<td>161</td>
</tr>
<tr>
<td>Service Arrays</td>
<td>161</td>
</tr>
<tr>
<td>How to Configure Service Arrays</td>
<td>162</td>
</tr>
<tr>
<td>Application Wizard</td>
<td>163</td>
</tr>
<tr>
<td>How to Use the Application Wizard</td>
<td>163</td>
</tr>
<tr>
<td>Scheduled Targets</td>
<td>167</td>
</tr>
<tr>
<td>How to Create a New Scheduled Target</td>
<td>168</td>
</tr>
<tr>
<td>How to Create a New Schedule Period for a Target</td>
<td>168</td>
</tr>
<tr>
<td>How to Associate Labels with a Scheduled Target</td>
<td>170</td>
</tr>
<tr>
<td>Translation Routes</td>
<td>170</td>
</tr>
<tr>
<td>Translation Route Wizard</td>
<td>171</td>
</tr>
<tr>
<td>How to Create a Translation Route</td>
<td>171</td>
</tr>
<tr>
<td>Introducing Network IVRs/VRUs</td>
<td>209</td>
</tr>
<tr>
<td>Configuring Network VRUs and VRU Scripts</td>
<td>217</td>
</tr>
<tr>
<td>Configuring Expanded Call Context Variables</td>
<td>205</td>
</tr>
<tr>
<td>How to Set the Expanded Call Context Enabled Option</td>
<td>205</td>
</tr>
<tr>
<td>How to Define an Expanded Call Context (ECC) Variable</td>
<td>205</td>
</tr>
<tr>
<td>Configuring ECC Variables for Use by CTI Server</td>
<td>207</td>
</tr>
<tr>
<td>User Variables</td>
<td>207</td>
</tr>
<tr>
<td>How to Define a User Variable</td>
<td>208</td>
</tr>
<tr>
<td>Introducing Network IVRs/VRUs</td>
<td>209</td>
</tr>
<tr>
<td>VRU Configuration Tools</td>
<td>210</td>
</tr>
<tr>
<td>Network VRU Explorer Tool</td>
<td>210</td>
</tr>
<tr>
<td>Network VRU Script List Tool</td>
<td>213</td>
</tr>
<tr>
<td>VRU Currency List Tool</td>
<td>214</td>
</tr>
<tr>
<td>VRU Defaults List Tool</td>
<td>215</td>
</tr>
<tr>
<td>VRU Locale List Tool</td>
<td>217</td>
</tr>
<tr>
<td>Configuring Network VRUs and VRU Scripts</td>
<td>217</td>
</tr>
<tr>
<td>VRU Port Map Data Descriptions</td>
<td>219</td>
</tr>
</tbody>
</table>
Network VRU Script Data Descriptions
Configuring Network VRUs
Network VRU Script Configuration
Accessing VRUs in Cisco Unified Intelligent Contact Management Scripts
Queuing Calls at VRUs
Appendix A. Peripheral Terminology
Mapping Cisco Unified Intelligent Contact Management Terminology to ACD-specific Terminology
Index
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sample Routing Script</td>
</tr>
<tr>
<td>2</td>
<td>Targets, routes and labels</td>
</tr>
<tr>
<td>3</td>
<td>Unified ICME Route Request Processing</td>
</tr>
<tr>
<td>4</td>
<td>MRD Hierarchy Example 1: Service level threshold at the MRD</td>
</tr>
<tr>
<td>5</td>
<td>MRD Hierarchy Example 2: Changing the Peripheral</td>
</tr>
<tr>
<td>6</td>
<td>MRD Hierarchy Example 3: Changing the Skill Group</td>
</tr>
<tr>
<td>7</td>
<td>Configuration Manager</td>
</tr>
<tr>
<td>8</td>
<td>Explorer Tools Help</td>
</tr>
<tr>
<td>9</td>
<td>Green check</td>
</tr>
<tr>
<td>10</td>
<td>Red X</td>
</tr>
<tr>
<td>11</td>
<td>Yellow arrow</td>
</tr>
<tr>
<td>12</td>
<td>Yellow addition</td>
</tr>
<tr>
<td>13</td>
<td>Red Circle</td>
</tr>
<tr>
<td>14</td>
<td>Select Filter Data Box</td>
</tr>
<tr>
<td>15</td>
<td>Not changed icon</td>
</tr>
<tr>
<td>16</td>
<td>Changed icon</td>
</tr>
<tr>
<td>17</td>
<td>Changed Icon</td>
</tr>
<tr>
<td>18</td>
<td>To be deleted icon</td>
</tr>
<tr>
<td>19</td>
<td>Example Bulk Configuration Edit Window</td>
</tr>
<tr>
<td>20</td>
<td>Edit Range dialog box</td>
</tr>
<tr>
<td>21</td>
<td>Routing Client Subsystem</td>
</tr>
<tr>
<td>22</td>
<td>Two Clients / One Logical Interface Controller</td>
</tr>
<tr>
<td>23</td>
<td>Two Clients / Two Logical Interface Controllers</td>
</tr>
<tr>
<td>24</td>
<td>Changed icon</td>
</tr>
<tr>
<td>25</td>
<td>To be inserted Icon</td>
</tr>
<tr>
<td>26</td>
<td>Marked for deletion icon</td>
</tr>
<tr>
<td>27</td>
<td>Peripheral Subsystem</td>
</tr>
<tr>
<td>28</td>
<td>Records generated by PG Explorer</td>
</tr>
<tr>
<td>29</td>
<td>PG to be inserted icon</td>
</tr>
<tr>
<td>30</td>
<td>Changed Icon</td>
</tr>
<tr>
<td>31</td>
<td>Marked for deletion Icon</td>
</tr>
<tr>
<td>32</td>
<td>Example Network Trunk Group Explorer Window</td>
</tr>
<tr>
<td>33</td>
<td>Marked for deletion icon</td>
</tr>
</tbody>
</table>
Preface

Purpose


Audience

This document is intended for Unified ICM system administrators. A system administrator must have a general understanding of call center operations and management and specific information about the call centers and carrier networks connected to Unified ICM/CCE/CCH software.

Organization

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1, &quot;Overview&quot; (page 7)</td>
<td>Describes the system software and introduces the Administration Data Server Group and the Administration Client Group set of tools.</td>
</tr>
<tr>
<td>Chapter 2, &quot;How Routing Works&quot; (page 11)</td>
<td>Describes how the system software interacts with the interexchange carrier (IXC) signaling network and your call centers.</td>
</tr>
<tr>
<td>Chapter</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Chapter 3, &quot;The Configuration Manager&quot; (page 31)</td>
<td>Describes the Configuration Manager tool and how to use it to define and maintain information about your enterprise in the Unified ICM database. This chapter also contains a call type configuration example based on the child deployment documented in the <em>Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX</em> located at <a href="http://www.cisco.com/en/US/products/sw/custcosw/ps1844/prod_installation_guides_list.html">http://www.cisco.com/en/US/products/sw/custcosw/ps1844/prod_installation_guides_list.html</a>.</td>
</tr>
<tr>
<td>Chapter 4, &quot;Configuring Multiple Records at a Time&quot; (page 53)</td>
<td>Explains how to configure multiple records at a time.</td>
</tr>
<tr>
<td>Chapter 5, &quot;Configuring Routing Clients&quot; (page 69)</td>
<td>Explains how to define your routing clients. This chapter also contains a dialed number configuration example based on the child deployment documented in the <em>Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX</em>.</td>
</tr>
<tr>
<td>Chapter 6, &quot;Configuring Peripherals and Trunk Groups&quot; (page 85)</td>
<td>Explains how to define your peripherals, trunk groups, and dialed numbers. This chapter also contains a PG configuration example based on the child deployment documented in the <em>Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX</em>.</td>
</tr>
<tr>
<td>Chapter 7, &quot;Configuring Skill Targets&quot; (page 113)</td>
<td>Explains how to define the services, skill groups, and agents associated with each peripheral. This chapter also contains an agent and a skill group configuration example based on the child deployment documented in the <em>Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX</em>.</td>
</tr>
<tr>
<td>Chapter 8, &quot;Configuring Routes and Routing Targets&quot; (page 149)</td>
<td>Explains how to define the routes and targets within your system.</td>
</tr>
<tr>
<td>Chapter 9, &quot;Configuring Cisco Unified Intelligent Contact Management Software for Integrated Applications&quot; (page 179)</td>
<td>Describes how to configure multimedia applications in the system software.</td>
</tr>
<tr>
<td>Chapter 10, &quot;Configuring Cisco Unified Intelligent Contact Management Variables&quot; (page 203)</td>
<td>Describes the ECC and user variables and how to define and use them.</td>
</tr>
<tr>
<td>Chapter 11, &quot;Network IVRs/VRUs&quot; (page 209)</td>
<td>Discusses the Network IVR/VRU feature that lets you divert a call to an interactive voice response unit for additional processing.</td>
</tr>
<tr>
<td>Appendix A, &quot;Peripheral Terminology&quot; (page 225)</td>
<td>Discusses the different terminology peripheral manufacturers use for agents, skill groups, and services.</td>
</tr>
</tbody>
</table>
Related Documentation

Documentation for Cisco Unified ICM/Contact Center Enterprise & Hosted, as well as related documentation, is accessible from Cisco.com at: http://www.cisco.com/cisco/web/psa/default.html.

Related documentation includes the documentation sets for Cisco CTI Object Server (CTI OS), Cisco Agent Desktop (CAD), Cisco Agent Desktop Browser Edition (CAD-BE), Cisco Unified Contact Center Management Portal, Cisco Unified Customer Voice Portal (CVP), Cisco Unified IP IVR, Cisco Unified Intelligence Center, and Cisco Support Tools. The following list provides more information.

- For documentation for the Cisco Unified Contact Center products mentioned above, go to http://www.cisco.com/cisco/web/psa/default.html, click Voice and Unified Communications, then click Customer Collaboration, and then click Cisco Unified Contact Center Products or Cisco Unified Voice Self-Service Products, then click the product or option you are interested in.

- For troubleshooting tips for the Cisco Unified Contact Center Products mentioned above, go to http://docwiki.cisco.com/wiki/Category:Troubleshooting, and then click the product or option you are interested in.

- Documentation for Cisco Unified Communications Manager is accessible from: http://www.cisco.com/cisco/web/psa/default.html.


- The Product Alert tool is accessible from (login required): http://www.cisco.com/cgi-bin/Support/FieldNoticeTool/field-notice.


Product Naming Conventions

In this release, the product names listed in the table below have changed. The New Name (long version) is reserved for the first instance of that product name and in all headings. The New Name (short version) is used for subsequent instances of the product name.

Note: This document uses the naming conventions provided in each GUI, which means that in some cases the old product name is in use.
## Conventions

This manual uses the following conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Boldface font</strong></td>
<td>Boldface font is used to indicate commands, such as user entries, keys, buttons, and folder and submenu names. For example:</td>
</tr>
<tr>
<td></td>
<td>• Choose <strong>Edit &gt; Find.</strong></td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Finish.</strong></td>
</tr>
<tr>
<td><strong>Italic font</strong></td>
<td>Italic font is used to indicate the following:</td>
</tr>
<tr>
<td></td>
<td>• To introduce a new term; for example: A <em>skill group</em> is a collection of agents who share similar skills</td>
</tr>
<tr>
<td></td>
<td>• For emphasis; for example: <em>Do not</em> use the numerical naming convention</td>
</tr>
<tr>
<td></td>
<td>• A syntax value that the user must replace; for example: <strong>IF (condition, true-value, false-value)</strong></td>
</tr>
<tr>
<td></td>
<td>• A book title; for example: Refer to the <em>Cisco CRS Installation Guide</em></td>
</tr>
<tr>
<td><strong>Window font</strong></td>
<td>Window font, such as Courier, is used for the following:</td>
</tr>
<tr>
<td></td>
<td>• Text as it appears in code or that the window displays; for example: <strong>&lt;html&gt;&lt;title&gt;Cisco Systems,Inc.&lt;/title&gt;&lt;/html&gt;</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Old Product Name</th>
<th>New Name (long version)</th>
<th>New Name (short version)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco IPCC Enterprise Edition</td>
<td>Cisco Unified Contact Center Enterprise</td>
<td>Unified CCE</td>
</tr>
<tr>
<td>Cisco System IPCC Enterprise Edition</td>
<td>Cisco Unified System Contact Center Enterprise</td>
<td>Unified SCCE</td>
</tr>
<tr>
<td>Cisco IPCC Hosted Edition</td>
<td>Cisco Unified Contact Center Hosted</td>
<td>Unified CCH</td>
</tr>
<tr>
<td>Cisco Intelligent Contact Management (ICM) Enterprise Edition</td>
<td>Cisco Unified Intelligent Contact Management Enterprise</td>
<td>Unified ICME</td>
</tr>
<tr>
<td>Cisco Intelligent Contact Management (ICM) Hosted Edition</td>
<td>Cisco Unified Intelligent Contact Management Hosted</td>
<td>Unified ICMH</td>
</tr>
<tr>
<td>Cisco CallManager/Cisco Unified CallManager</td>
<td>Cisco Unified Communications Manager</td>
<td>Unified CM</td>
</tr>
</tbody>
</table>
## Obtaining Documentation and Submitting a Service Request

For information about obtaining documentation, submitting a service request, and gathering additional information, see the monthly *What's New in Cisco Product Documentation*, which also lists all new and revised Cisco technical documentation, at:


Subscribe to *What's New in Cisco Product Documentation* as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0.

## Documentation Feedback

You can provide comments about this document by sending an email message to the following address:

ccbu_docfeedback@cisco.com (mailto:ccbu_docfeedback@cisco.com)

We appreciate your comments.
Chapter 1

Configuration Overview

This chapter provides the following information:

• An introduction to the system software and its components

• An introduction to the Administration Data Server Group and Administration Client Group tools

• A summary of system management tasks

This chapter contains the following topics:

• Software Overview, page 7
• Configuration Management, page 9
• Script Management, page 9

Software Overview

This section provides an overview of the following:

• Cisco Unified Intelligent Contact Management (Unified ICM) software (page 7)
• Cisco Unified Contact Center Enterprise (Unified CCE) solution (page 8)

Cisco Unified Intelligent Contact Management Overview

Unified ICM provides enterprise-wide distribution of multi-channel contacts (inbound/outbound telephone calls, Web collaboration requests, email messages, chat requests) across geographically separated contact centers. Unified ICM is an open standards-based solution whose capabilities
include routing, queuing, monitoring, and fault tolerance. Unified ICM forms the basis for the Cisco Customer Contact Suite.

The system software functions across environments as well as across channels.

The system software functions in the older environment of telephone calls delivered over TDM line, of hardware ACDs and IVRs, and of call centers centralized around the hardware. The system software can route calls for a single 800 number or for several different numbers. The system software reads information about each incoming call from the public network, determines the best destination for that call, and returns information to the public network instructing it where to route the call. This is known as call-by-call routing.

The system software makes routing decisions by executing scripts that can easily be modified. These scripts can use real-time information about activity at the contact centers to find the destination best able to handle the call. You can monitor how the system is handling calls and can make changes to the scripts when needed.

The system software functions in the newer environment of multi-channel contacts delivered through IP connections, of software ACDs and IVRs, and of contact centers that can be as decentralized as the Internet or as centralized as business practices — not hardware necessities — require them to be.

The system software functions in the mixed transition environment that involves all of the above.

**See Also**

For detailed information about Unified ICM, refer to the *Pre-installation Planning Guide for Cisco Unified ICM Enterprise and Hosted* and the *Administration Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted*.

**Cisco Unified Contact Center Enterprise Overview**

Cisco Unified Contact Center Enterprise (Unified CCE) delivers intelligent contact routing, call treatment, network-to-desktop computer telephony integration (CTI), and multichannel contact management over an IP infrastructure. It combines multichannel automatic call distributor (ACD) functionality with IP telephony in a unified solution, enabling your company to rapidly deploy a distributed contact center infrastructure.

Unified CCE provides:

- Segmentation of customers, and monitoring of resource availability
- Delivery of each contact to the most appropriate resource anywhere in the enterprise
- Comprehensive customer profiles using contact-related data, such as dialed number, and calling line ID
- Routing to the most appropriate resource to meet customer needs based on real-time conditions (such as agent skills, availability, and queue lengths)
• Presence integration to increase caller satisfaction through improved agent performance, and knowledge-worker expertise

Unified CCE allows you to smoothly integrate inbound and outbound voice applications with Internet applications such as real-time chat, web collaboration, and email. This integration enables a single agent to support multiple interactions simultaneously regardless of which communications channel the customer has chosen. Since each interaction is unique and may require individualized service, Cisco provides contact center solutions to manage customer interactions based on almost any contact attribute.

See Also

For detailed information about Unified CCE, refer to the Installation and Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted and the Administration Guide for Cisco Unified Contact Center Enterprise & Hosted.

Configuration Management

Unified ICM configuration information is permanently stored in the Central Controller database. The system software configuration consists of hardware entities, call targets, announcements, routes, dialed numbers, and regions. Use the Unified ICM/CCE/CCH Configuration Manager (referred to as the "Configuration Manager" in this guide) tools to create and modify configuration data. When you apply a change in the Configuration Manager, it is immediately applied to the central database.

To get started setting up and maintaining your configuration, see Chapter 3, "The Configuration Manager (page 31)."

Script Management

After you have set up your configuration, you can write routing scripts and administrative scripts:

• A routing script processes a call routing request from a routing client and determines the best destination for that call. The system software then passes a label associated with the destination back to the routing client.

• An administrative script runs periodically to perform a task, such as setting variables.

Use the Script Editor to create, maintain, and monitor scripts.

You can set up different routing scripts to execute for different types of tasks. You can define call types in terms of the telephone number the caller dialed, the number the caller is calling from, and additional digits entered by the caller. For each call type, you can schedule different routing scripts to execute on different days or at different times of the day. The Figure "Sample Routing Script" shows a sample routing script.
A routing script typically examines several targets and applies selection rules to find an available qualified agent or a target with the shortest expected delay. You can use any of several predefined selection rules or you can set up your own selection criteria.

Within the Script Editor, you can open a script for browsing, monitoring, or editing. When you open a script for editing, the Script Editor automatically obtains the lock for that script.

To get started using the Script Editor to create or maintain scripts, refer to the Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.
How Routing Works

This chapter describes in detail the process of routing a call.

It includes:

• An overview of the routing process
• A description of routing requests and routing clients
• Information about how calls arrive at targets
• An overview of translation routes
• The importance of timeouts and thresholds

Understanding this process will help you set up the configuration of your system software and create effective scripts.

This chapter contains the following topics:

• The Routing Process, page 11
• Steps in the Routing Process, page 12
• Routing Requests, page 13
• Targets, page 13
• Translation Routes, page 19
• Timeouts and Thresholds, page 20
• Configuring Service Levels, page 23

The Routing Process

To properly route calls, three independent systems must work together:
• The routing client
• The system software
• The peripheral that ultimately receives the call

The routing client requests a route from the system software, receives a response, and delivers the call to the specified destination.

The system software receives routing requests and determines the appropriate destination for the call. The destination is an announcement (which is played by the routing client), a scheduled target, or a specific target at a peripheral (represented by a trunk group and DNIS).

A peripheral is a switch at a call center, such as an ACD, a PBX, or Unified CM. The peripheral completes the routing by dispatching the call to the specific target determined by the system software.

Steps in the Routing Process

The process of routing a call consists of the following steps:

**Step 1**
A routing client requests a route from the system software.

**Step 2**
The system software, using information supplied by the routing client, categorizes the request as a specific call type.

**Step 3**
The system software executes a routing script scheduled for the call type to find a destination for the call. The destination can be a routing label, an announcement, or a skill target: a service, skill group, or agent. (If the script fails to find a destination, the system software uses a default destination based on the dialed number.)

**Step 4**
If: the destination is an announcement, scheduled target, or skill target
Then: the system software maps that destination to a routing label.

A routing label is a character string value that the routing client maps to a destination trunk group and, optionally, a Dialed Number Identification Service (DNIS) value for the call.

**Step 5**
The system software passes the routing label back to the routing client.

**Step 6**
The routing client interprets the label to find the destination.

**Step 7**
The routing client dispatches the call to the destination (with the appropriate DNIS value, if any).

**Step 8**
If: the call is sent to a peripheral
Then: the peripheral must determine the specific target for which the call is intended.
The peripheral typically makes this determination based on the trunk group on which the call arrived and, optionally, the DNIS value sent with the call. The peripheral then completes the routing by dispatching the call appropriately.

The following sections describe the process in detail.

Routing Requests

The system software receives routing requests from routing clients, where the type is either the specific IXC (for example, AT&T, MCI, or Sprint) or the specific type of the peripheral (for example, VRU or a specific type of ACD).

Routing clients send messages to the system software. One type of message is a route request. In this case, given a call, the routing client asks the system software for a destination, or route, for that call. If the routing client is an IXC, this is the only type of message that it sends.

Routing requests are of two types: Pre-Routing and Post-Routing. A Pre-Routing request is sent by an IXC to determine the initial destination for a call. A Post-Routing request is sent by the peripheral that receives the call to either refine the original route or to redirect the call.

A routing request includes the following information about the call to be routed:

- **Dialed Number (DN)**. The number the caller dialed.

- **Calling Line ID (CLID)**. The caller’s billing telephone number. This value is also referred to as Automatic Number Identification or ANI.

- **Caller-Entered Digits (CED)**. Digits the caller entered on a touch-tone phone in response to prompts.

Post-Routing messages vary depending on the type of the peripheral.

Targets

A target is the destination for a call. The target can be either a label, an announcement defined by the routing client, or a target at a peripheral.

On a high level, a target at the peripheral is a service, skill group, or individual agent that the system software selects to handle the call. This is called the *skill target*. Regardless of the specific skill target, every call routed by the system software must also be associated with a service. The combination of a skill target and a service is a *route*.

On a lower level, a target represents a network trunk group at the peripheral and, optionally, a Dialed Number Identification Service (DNIS) value. The routing client uses this type of target, called a *peripheral target*, to route the call.
On a still lower level, each peripheral target or announcement maps to a routing label. A *label* is a character string that the routing client associates with a specific peripheral target or announcement.

The following figure shows the relationships among skill targets, routes, peripheral targets, announcements, and labels.

*Figure 2: Targets, routes and labels*

The system software works from the top to the bottom of the Figure Targets, routes and labels:

1. A routing script determines a destination for the call.

   **If:** the destination is a routing label

   **Then:** the system software can return that value directly to the routing client.

   Otherwise, the destination is one of the following:

   — A *skill target* to receive the call

   — An *announcement* to be played

   — A *scheduled target* to receive the call

2. If the destination is a skill target, that skill target has an associated *route*.

3. The system software uses the route to find an associated *peripheral target* supported by the routing client.
4. The peripheral target is associated with a label. The system software returns that label to the routing client. If the destination is an announcement, the system software only needs to find the label associated with that announcement and return the label to the routing client.

The routing client's processing depends on the type of the label. Some labels instruct the routing client to take a special action: playing a busy signal for the caller, playing an unanswered ring for the caller, or making a special query.

For normal labels, the routing client converts the label to an announcement, scheduled target, or peripheral target by working up from the bottom of the "Targets, Routes and Labels (page 14)" figure.

1. The routing client receives a label from the system software in response to its route request.

   It translates that label into one of the following:
   
   – A peripheral target
   – An announcement
   – A scheduled target
   – An unrouted task that gets routed to a local agent

   **If:** the result is an announcement
   **Then:** it plays the announcement for the caller.

   **If:** the result is a scheduled target
   **Then:** it delivers the call to that target.

2. **If:** the result is a *peripheral target*

   **Then:** the routing client delivers the call to the specified network trunk group at the peripheral and sends the specified DNIS value, if any, with it.

3. The peripheral itself must then recognize the network trunk group and DNIS for the call as it arrives and determine the associated service and skill target. The peripheral then completes the process by locating the appropriate agent to handle the call.

Cisco Unified Intelligent Contact Management Enterprise System Processing

The "Unified ICME Route Request Processing (page 16)" figure summarizes how the system software processes a route request.
The following subsections describe this processing.

Determine Call Type

When the system software receives a route request for a call, it first determines the call type of the call. A call type is a category of incoming Unified ICME routable tasks. Each call type has a schedule that determines which routing script or scripts are active for that call type at any time.

There are two classes of call types:

- Voice (phone calls)
- Non-voice (for example, email and text chat)

Voice call types are categorized by the dialed number (DN), the caller-entered digits (CED), and the calling line ID (CLID).

Non-voice call types are categorized by the Script Type Selector, Application String 1, and Application String 2.

In either case, the last two categories of the call type are optional. For voice call types, the caller-entered digits and the calling line ID are optional, depending on the call. For non-voice call types, Application String 1 and Application String 2 are optional, depending on the application.
While chat sessions and blended collaboration are different from email and also require call variables, the call variables are not part of the call type definition.

For example, you might define three call types to correspond to three sales regions within the country. You might have a network prompt that lets the caller enter 1 for sales, 2 for support, and 3 for information. If a call arrives for the dialed number 800.486.0029, with a CLID from the 403 (San Jose region) area code, and the caller enters 1 (sales) in response to the prompt, that call is classified as Western Sales.

If another call arrives with the same dialed number, but with a CLID from the 212 (New York City) area code, and the caller-entered digit 1, that call is classified as Eastern Sales.

You can define a general default call type and a specific default call type for each routing client. If the call qualifiers do not map to a specific call type, the system software uses a default call type defined for the routing client. If no default call type is defined for the routing client, the system software uses the general default call type.

### Execute Script

Each call type has specific routing scripts scheduled for different times of day and different days of the year. The system software finds the script currently scheduled for the call type and executes it. If that script fails to find a suitable destination (that is, a label, announcement, or skill target) for the call, then the system software uses a default target associated with the Dialed Number value.

If the system software finds an announcement or scheduled target for the call, then it can immediately resolve that to a label to return to the routing client. If the system software finds a skill target for the call, it must perform a few extra steps before it finds a label.

### Determine Route

If the system software finds a skill target for the call, that target has an associated route. You specify the route when you set up the target within the routing script. A route represents the combination of a skill target and a service. That is, a route represents the destination for a call and the type of service to be provided to the caller. Every call routed to a peripheral must have an associated service.

For example, the skill target for a call might be the skill group Denver.PostSales and the associated service might be Denver.TechSupport. Another call might also be routed to the Denver.PostSales group with the associated service Denver.Upgrades.

**Note:** If the destination is itself a service, for example Chicago.Sales, then the associated service must also be Chicago.Sales. To associate a service skill target with a route for a different service would skew the statistics for those services.

### Determine Trunk Group and DNIS

Once it has determined a route for a call, the system software finds an associated peripheral target (trunk group and DNIS). It is possible to have several peripheral targets associated with the same route, but typically only one of those targets is valid for the routing client. For example,
if you have switched access lines, two IXCs could direct calls to the same trunk group and DNIS, but each requires a different label value for that target. Therefore, you need to define two separate peripheral targets for the route. If more than one peripheral target is associated with the route, the system software chooses the first peripheral target that maps to a valid label for the routing client.

Determine Label

Each peripheral target, scheduled target, or announcement maps to one or more labels. The system software finds the first label that is valid for the routing client and dialed number and returns that label to the routing client. It is then up to the routing client to interpret the label.

Default Label

It is possible that the system software might fail to find a call type for a route request. Also, the system software may execute the script currently scheduled for a call type and fail to find a destination for the call. In these cases, it uses a default label that is defined for the dialed number. If no default label is defined for the dialed number, the system software returns an error to the routing client.

The routing client itself also has some default action defined. When you set up each routing client you can specify the maximum time that client can wait for a response to a routing request. If the system software has not returned a destination for the call before the time limit is reached, or if the system software returns an error, the routing client performs its own default action.

For more information on timeout limits, see the "Timeouts and Thresholds (page 11)" section.

Routing Client's Processing

The routing client begins by requesting a route for a call from the system software. The system software processes the request as described in the preceding section and returns a label to the routing client.

The routing client has its own internal mappings for labels to announcements, scheduled targets, and peripheral targets.

It uses these mappings to interpret the label from the system software:

- **Busy.** Routing client plays a busy signal for the caller.
- **Ring.** Routing client plays an unanswered ring for the caller.
- **Normal** and the label maps to an announcement. Routing client plays the announcement for the caller.
- **Normal** and the label maps to a scheduled target. Routing client delivers the call to that target.
• **Normal** or **DNIS Override** and the label maps to a **peripheral target** (that is, a trunk group and a DNIS). Routing client delivers the call and the specified DNIS value to that trunk group. The peripheral then has responsibility for dispatching the call to the appropriate skill target.

**The Peripheral’s Processing**

When a peripheral receives a call, it determines the trunk group on which the call arrived and the DNIS value, if any, associated with it. The peripheral must be programmed to map these values to the same service and skill target determined by the system software.

The peripheral, acting as a routing client, can also send a routing request to the system software.

**Translation Routes**

Sometimes you want to send additional information along with the call to a skill target. Translation routes allow you to do that.

A translation route is a temporary destination for a call. When the system software returns a translation route label to the routing client, it also sends a message directly to the Peripheral Gateway (PG) at the targeted peripheral. This message alerts the PG that a call will be arriving that requires route translation.

The message contains the following information:

• The trunk group on which the call will arrive and the DNIS value associated with it.

• A label to be used by the PG to determine the ultimate skill target of the call. This is a label that the PG can interpret to find the correct destination.

• Instructions for further processing to be performed by the PG. This further processing might include, for example, looking up an account number in a database.

When the peripheral sees the call arrive on the specified trunk group and with the specified DNIS value, it passes this information to the PG. The PG then combines it with the information it has received from the system software. It then sends the call along with this information to the skill target specified by the label it received. At the same time, the peripheral might, for example, send a message to a host computer that controls the display on the agent's workstation. This allows data, such as the caller's account information, to be displayed on the screen when the call arrives. The PG coordinates communication among the network, the peripheral, and the computer application that controls the display.

To set up a translation route, you must do the following:

• Set up a translation route associated with the peripheral. You do not need a separate translation route for each possible skill target at the site, but you need at least one for each peripheral that performs translation routing.
• Set up one or more routes and associated peripheral targets for the translation route. Typically, all peripheral targets for a translation route refer to the same trunk group, but with different DNIS values.

• Set up a label for the original routing client for the call to access each of the peripheral targets associated with the translation route. For example, if the routing client is an interexchange carrier (IXC), you must set up a label to the targets with the IXC. This allows the call to be initially sent to the translation route at the peripheral.

• For each peripheral target that you want to be able to ultimately access via a translation route, set a label with the peripheral as the routing client. For example, you might want to be able to send calls to the Atlanta.Support skill group through a translation route. To do this, you must configure a label for that skill group with the Atlanta peripheral as the routing client. This allows the peripheral to determine the ultimate destination for the call.

• To display data on the agent’s workstation when the call arrives, you must configure the peripheral to inform the PG which agent is receiving the call.

Timeouts and Thresholds

In setting up your configuration, you need to specify several timeout and timing threshold values.

For routing clients, you must specify the maximum time the system software can spend before responding to each routing request. You must also specify the maximum time for the routing client to wait for a response before it stops sending new requests to the system software.

For each service at a peripheral, you must specify your goal for the maximum time a caller must wait before the call is answered. The system software uses this value in calculating the service level.

You can specify how to count abandoned calls in the service level calculation. You can also specify the minimum time a call must be in the queue before it can be considered abandoned.

For specific information about configuring routing clients, peripherals, and services, see Chapters 4 through 7.

Routing Clients

In some cases, a routing client might be unable to receive routing responses from the system software. Sometimes this affects only a single request, but other times the routing client loses contact with the system software for longer periods. You can specify the amount of time for the routing client to wait before giving up on a single request and the amount of time to wait before it stops sending any requests to the system software.

Timeout Threshold

The maximum time (in milliseconds) the routing client can wait for a response to a routing request. The NIC sends a default response before this threshold.
Late Threshold

A threshold value (in milliseconds) for classifying responses as late. Any response that exceeds this threshold is considered late even if it does not exceed the Timeout Threshold.

Timeout Limit

The system software is designed to be a highly reliable system. Distributed duplicated hardware and software fault-tolerance ensure very high availability. However, the NIC uses a timeout limit to provide a safety net to ensure that your calls continue to be routed even if the system software were to become completely unavailable. If the routing client receives no responses from the system software within the timeout limit (and a minimum number of requests have been made), it stops sending requests to the system software. You can set the minimum number of requests that must be made (the consecutive timeout limit) when you set up the NIC software. The default is 10.

When a routing request first exceeds the timeout threshold, the NIC for the routing client starts a timer. If the timer reaches the timeout limit before the routing client receives any on-time routing responses from the system software, then the NIC tells the routing client to stop sending routing requests to the system software. An on-time response is a response within the timeout threshold. You can specify the timeout limit in seconds. For example, for AT&T ICP connections, set the timeout limit to 10 seconds.

Abandoned Call Wait Time

When a call is delivered to a peripheral, the caller might be placed in a queue waiting for an agent to become available. Normally, if the caller hangs up before being connected with an agent, the call is considered abandoned. A high number of abandoned calls might mean that you are losing business because callers are being made to wait too long.

However, if a caller hangs up almost immediately after being placed in a queue, you might not want to count that as an abandoned call. In these cases, caller impatience or excessive queue times are not the problem; the caller probably hung up for another reason. Tracking these as abandoned calls can be misleading.

Therefore, you can specify a minimum amount of time that a caller must wait before the call can be considered abandoned. This value is called the abandoned call wait time. You can set this value for each peripheral. A typical value might be 10 seconds. This would mean that if the caller hangs up in the first 10 seconds, the call is not considered abandoned, nor is it counted as a call offered. If the caller waits at least 10 seconds and then hangs up, the call is counted as both offered and abandoned. (In the real-time data, a call is counted as offered as soon as it arrives at the peripheral. Therefore, a short call might appear as a call offered in the real-time data, but is not counted as offered in the historical data.)
Service Level

Service level is a measure of how well you are meeting your goals for answering calls. For each service, you can set a goal for the maximum time a caller spends in a queue before being connected to an agent. This value is the service level threshold. The service level is usually expressed as the percentage of calls that are answered within the threshold.

To calculate the service level for a period of time, the system software determines the number of calls that have had a service level event within that period.

A service level event occurs when one of three things happens to a call:

- It is answered within the service level threshold.
- It is abandoned within the service level threshold.
- It reaches the service level threshold without being answered or abandoned.

All calls that have a service level event within a specified period are considered as service level calls offered for that period. This differs from a simple call's offered value, which counts each call at the time it is first offered to the service.

Service Level Threshold

The service level threshold is the number of seconds you set as a goal for connecting a call with an agent. When you set up a peripheral, you can specify a default service level threshold for all services associated with that peripheral. When you set up each service, you can choose to either use the default threshold set for the peripheral or specify a threshold for the service itself in the Service Level Threshold field. If you do not specify a service level threshold for an individual service, the default threshold you specified for the peripheral is used. Typically, you must set these values to match the service level thresholds being used by the peripheral itself.

Service Level Types

Different peripheral types use slightly different formulas to calculate service level. The system software provides a uniform calculation across all peripherals. This allows you to apply uniform metrics and performance goals across all peripherals. However, the system software also tracks the service level as calculated by the peripheral itself. This is called the peripheral service level. You can use this value, for example, to continue to compare performance to historical norms.

Some peripherals let you select one of several types of service level calculation. You can specify which of these types of service level you want the system software to track.

The uniform service level calculation performed by the system software can be done in any of three ways:

- Abandoned calls ignored. The number of calls answered within the threshold divided by the number of calls that had a service level event minus the number of calls that were
abandoned before exceeding the service level threshold. Calls abandoned before the service level threshold expired are removed from this calculation.

- **Abandoned calls negatively impact service level.** The number of calls answered within the threshold divided by the number of calls that had a service level event. This treats these abandoned calls as though they had exceeded the threshold.

- **Abandoned calls positively impact service level.** The number of calls answered within the threshold plus the number of calls abandoned within the threshold, all divided by the number of calls that had a service level event. This treats these abandoned calls as though they were answered within the threshold.

The following example illustrates these different ways of calculating service level.

**Example Service Level Calculations**

**Call Counts**

- **Answered within service level threshold:** 70
- **Abandoned within service level threshold:** 10
- **Exceeded service level threshold:** 20
- **Total service level events:** 100

**Service Level Calculations**

- **Abandoned calls ignored:** $\frac{70}{100 - 10} = 77.7\%$
- **Abandoned calls negatively impact:** $\frac{70}{100} = 70.0\%$
- **Abandoned calls positively impact:** $\frac{70 + 10}{100} = 80.0\%$

The value of the Service Level Type field for the service determines how the system software treats abandoned calls. You set this value when you configure the service.

**Configuring Service Levels**

Service Level is set in six configurable windows in Configuration Manager, which you can define in different ways depending on the kind of information you want it to provide.

- **System Level (page 24)**
- **Call Types (page 24)**
- **Media Routing Domain (page 27)**
- **Peripheral (page 27)**
Configuring Service Levels

- Skill Group (page 28)
- VRU (page 29)

See also:

Reporting on Service Level (page ?)

Configuring the System Information Service Level for Call Types

Service Levels are set at the System Information level for all call types. To view or change the default system-level settings for all Call Types:

**Step 1** In the Configuration Manager, select **Tools > Miscellaneous Tools > System Information**.

**Step 2** Specify a value for Service level threshold in seconds.

The default is 20 seconds.

**Step 3** Select the Service level type.

The options are: Abandoned Calls have Negative Impact, Abandoned Calls have Positive Impact, and Ignore Abandoned Calls.

The default is Ignore Abandoned Calls.

**Step 4** Click **Save**.

Configuring the Service Levels for Specific Call Types

To configure Service Levels for specific Call Types, which override the System Information settings:

**Step 1** In the Configuration Manager, select **Tools > List Tools > Call Type Lists**.

**Step 2** Click **Retrieve**.

**Step 3** Select the Call Type whose service level you want to set.

**Step 4** For Service level threshold, check the box to the right of the field to override the default from the System Information (20 seconds).

Specify a Service level threshold value in seconds for this Call Type.

**Step 5** For Service level type, check the box to the right of the field to override the default.

Select from Ignore Abandoned Calls, Abandoned Calls have Negative Impact, and Abandoned Calls have Positive Impact.
Step 6  Click Save.

See also Service Level at the Call Type (page ?).

Service Level Relationships: Media Routing Domain, Peripheral, and Skill Groups

Service Level setting for MRDs, Peripherals, and Skill Groups are hierarchical and are interpreted as follows:

- MRD - is the highest level. It is set in Configuration Manager > Tools > List Tools > Media Routing Domain.

  The default settings for the MRD are Service level threshold = 30 seconds and Service level type = Ignore Abandoned Calls. Ignore Abandoned Calls is the only value, and it is protected.

- Peripheral - is set in Configuration Manager > Tools > List Tools > Service Level Threshold List.

  The default settings for a Peripheral are taken from its MRD. You can override them.

- Skill Group - is set in Configuration Manager > Explorer Tools > Skill Group Explorer > Advanced tab.

  The default settings for Skill Group are taken from its peripheral. You can override them.

This example explains the configuration.

1. The MRD has two Peripherals. Each Peripheral has two Skill Groups. The Service level threshold for the MRD is set to the default of 30 seconds. By default, the Service level thresholds for both Peripherals is 30 seconds, and the Service level thresholds for all four Skill Groups is 30 seconds.
2. If you change the Service level threshold of Peripheral 1 to 20 seconds, the Service level thresholds of Skill Groups 1 and 2 become 20 seconds.

The Service level thresholds of Skill Groups 3 and 4 remain at 30 seconds.

3. If you want the Service level threshold of Skill Group 1 to be 45 seconds, you can independently configure Skill Group 1 to have a Service level threshold of 45 seconds.
Configuring the Service Level for the Media Routing Domain

To configure the Service Level settings for the Media Routing Domain:

Step 1 In the Configuration Manager, select **Tools > List Tools > Media Routing Domain List**.
Step 2 Select the Routing Domain with the service level you want to modify.
Step 3 Click **Retrieve**.
Step 4 Select the MRD that has the Service level you want to set.
Step 5 Specify a value in seconds for Service level threshold. *The default is 30 seconds.*
Step 6 Service level type is protected and always shows *Ignore Abandoned Calls.*
Step 7 Click **Save**.

Configuring the Service Level for a Peripheral

To configure Service Level settings for a Peripheral:

Step 1 In the Configuration Manager, select **Tools > List Tools > Service Level Threshold List**.
Step 2 Click **Retrieve** to populate the list with the Peripherals.
Step 3 Select the Peripheral that has the Service Level you want to modify.
Step 4 Specify a value for Service level threshold. The default is inherited from the MRD.
Configuring Service Levels

Your options are to:

• Retain the default from the MRD.

• Check the Override MRD default box to unprotect the value and enter a new value in seconds for the Peripheral Service level threshold.

**Step 5** For Service level type, check the box to override the default. Select from *Abandoned Calls have Negative Impact*, *Abandoned Calls have Positive Impact*, and *Ignore Abandoned Calls*.

For a non-Unified CCE/CCH peripheral and a voice media routing domain, select from *Abandoned Calls have Negative Impact*, *Abandoned Calls have Positive Impact*, and *Ignore Abandoned Calls*. For other media routing domains, only *Ignore Abandoned Calls*, and it is protected.

**Step 6** Click **Save**.

---

Configuring the Service Level for Skill Groups

To configure Service Level settings for a Skill Group:

**Step 1** In the Configuration Manager, select **Explorer Tools > Skill Group Explorer**.

**Step 2** Click **Retrieve**.

**Step 3** Select the Skill Group and click the Advanced tab.

**Step 4** The service level threshold defaults to that of the Peripheral.

Your options are to:

• Keep the Service level threshold setting of the Peripheral.

• Check the Override Peripheral default box to unprotect the value and enter a new value in seconds for the Skill Group Service level threshold.

**Step 5** The service level type defaults to that of the Peripheral.

Your options are to:

• Keep the setting of the Peripheral.

• From the dropdown, change to: *Abandoned Calls have Negative Impact*, *Abandoned Calls have Positive Impact*, or *Ignore Abandoned Calls*.

**Step 6** Click **Save**.
Configuring the Service Level for an Aspect VRU

To configure Service Level settings for an Aspect VRU:

**Step 1**  
In the Configuration Manager, select **Explorer Tools > PG Explorer**.

**Step 2**  
Click **Retrieve**.

**Step 3**  
Select and expand the PG.

**Step 4**  
Select the peripheral and click the Peripheral tab.

For all peripherals except Aspect, the Peripheral Service Level Type field is protected and shows *Calculated by Call Center*.

For Aspect, choose the type of calculation to be performed by default. You can override the default for each individual service.
Chapter 3

The Configuration Manager

After you have installed Unified ICM and have it running, use the Configuration Manager to view and update the configuration information in the Unified ICM database. The configuration information describes the people, groups, and devices that are part of your enterprise.

For example, use the Configuration Manager to specify:

• The devices in your system and the clients they serve
  Which includes
  – The peripherals at your contact centers
  – The routing clients served by your system

• Targets at the peripherals to which the system software can direct calls
  Which includes
  – Trunks and trunk groups connected to peripherals
  – Skill targets associated with each peripheral: agents, skill groups, services, and translation routes
  – Information used by scripts to organize call requests and direct calls to targets, including call types, regions, prefixes, and dialed numbers
  – Targets understood by the routing client, including announcements, peripheral targets, and routing labels
  – The associations among routing labels, routes, peripheral targets, and skill targets

• Enterprise services and enterprise skill groups as a combination of individual services and groups from different contact centers
Chapter 3: The Configuration Manager

This chapter contains the following topics:

- Accessing the Configuration Manager, page 32
- Using the Configuration Manager, page 32
- Online Help, page 33
- Configuration Manager Tools, page 34

Accessing the Configuration Manager

To access the Configuration Manager:

- Double-click the Unified CCE Administration Tools folder icon, then double-click the Configuration Manager icon.

-or-

- From the Start menu, select All Programs > Cisco Unified CCE Tools > Administration Tools > Configuration Manager.

Using the Configuration Manager

When you start the Configuration Manager, the Configuration Manager window appears. The "Configuration Manager (page 33)" figure shows the window with the top-level directories displayed for all its menus.

The Configuration Manager lets you view and update the configuration information in the Unified ICM database. The configuration information describes the people, groups, and devices that are part of your enterprise.

To set up the configuration of a new system when you are a new user, follow the steps in the menu bar’s Step by Step Configuration selection list.

Use the tools in the Telephony Contact Center Configuration menu in the order given to configure, first Network Interface Controllers (NICs), then peripherals, and so on. After you configure the system software for your telephony contact center, then you can configure the software for multi-media applications.

The tools in the MultiMedia Contact Center Configuration menu are also in the order in which you might use them. For example: you must have a media class before you can create a media routing domain for that class. And you must have an application instance before you can specify the path to that application.

To ...

- Access the configuration tools according to the menu selections of the former Configure ICM tool, in the menu, select Configure ICM.

- Access all the tools you can use in the Configuration Manager, in the menu bar, select Tools.
Online Help

For information about any Configuration Manager tools, menu options, or other interface features, refer to the online help.

You can activate help from within the system software in any of three ways:

- Click **Help** in the tool bar or in the dialog.
- Select **Help > Help Contents** from the menu bar.
- Press the **F1** key.
Configuration Manager Tools

Use the menu bar in the Configuration Manager window to select the task or tool you want.

Table 1: Tools Summary

<table>
<thead>
<tr>
<th>Tools</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bulk Configuration Tools (page 35)</td>
<td>Enable you to configure multiple records at a time.</td>
</tr>
<tr>
<td>Explorer and List Tools (page 36)</td>
<td>Enable you to both view records and their related records and to define, edit, and delete them and their relationships. The difference between the Explorer tools and the List tools is that the Explorer tools manage records that have more than one relationship while the List tools manage records that have no or only one relationship to other records.</td>
</tr>
<tr>
<td>Miscellaneous Tools (page 38)</td>
<td>Help you perform configuration tasks for which the previous tools are not appropriate.</td>
</tr>
<tr>
<td>Wizards (page 38)</td>
<td>Guide you through configuration tasks.</td>
</tr>
<tr>
<td>Outbound Option</td>
<td>Adds outbound dialing functionality to the existing inbound capabilities of the system software. <strong>Note:</strong> Refer to the Outbound Option Guide for Cisco Unified Contact Center Enterprise &amp; Hosted and the online help for detailed information about Outbound Option.</td>
</tr>
</tbody>
</table>

**Note:** Refer to each tool's online help for detailed information.
Bulk Configuration Tools

Use the Configuration Manager's Bulk Configuration tools to configure multiple records at a time. For information on how to use these tools, see Chapter 4, "Configuring Multiple Records at a Time (page 53)."

The Bulk Configuration tools enable you to bulk configure the following individual database table records.

The tools are named for the records they manage:

- Agents
- Call types
- Dialed number plans
- Dialed numbers
- Device targets
- Labels
- Network trunk groups
- Network VRU scripts
- Peripheral targets
- Person bulk tool
- Regions
- Region prefixes
- Routes
- Trunks
- Trunk groups
- Scheduled targets
- Services
- Skill groups
- VRU port maps

Note: Refer to each tool's online help for detailed information.
Explorer and List Tools

Use the Configuration Manager’s Explorer and List tools to configure and manage individual database records.

Explorer Tools

Use the Explorer tools to configure and manage database records that have hierarchical relationships to other records. In this way, at one time, you can see and update both the individual records and their relationships. You can configure and manage the following records with the Explorer tools.

The tools are named for the type of records they manage:

- Agent Explorer
- Announcement Explorer
- Database Lookup Explorer
- Device Target Explorer
- ICM Instance Explorer
- Network VRU Explorer
- Network Trunk Group Explorer
- NIC Explorer
- PG Explorer
- Region Explorer
- Scheduled Target Explorer
- Service Explorer
- Service Array Explorer
- Skill Group Explorer
- Translation Route Explorer

See Also

Refer to each tool's online help for detailed information.
List Tools

Use the List tools to configure and manage database records that have limited or no hierarchical relationship to other records. You can configure and manage the following individual records with the List tools.

The tools are named for the type of records they manage:

- Agent Desk Settings List
- Agent Targeting Rule List
- Agent Team List
- Application Gateway List
- Application Instance List
- Bucket Intervals List
- Business Entity List
- Call Type List
- Class Security List (On partitioned systems only)
- Dialed Number/Script Selector List
- Enterprise Route List
- Enterprise Service List
- Enterprise Skill Group List
- Expanded Call Variable List
- Feature Control Set List
- Label List
- Media Class List
- Media Routing Domain List
- Network VRU Script List
- Person List
- Reason Code List
- Service Level Threshold List
• Supervisor List
• User List
• User Group List
• User Variable List
• VRU Currency List
• VRU Defaults List
• VRU Locale List

See Also

Refer to each tool's online help for detailed information.

Miscellaneous Tools

The following Configuration Manager tools enable you to do miscellaneous functions not available with the other tools:

• **Deleted Objects**: Enables you to view all records deleted from the database and to permanently delete them if you no longer want them available for your records.

• **Integrity Check**: Allows you to perform specific integrity checks on the configuration data in the Unified ICM database.

• **Region Editor**: Allows you to:
  
  — View, create, update (cut, copy, paste, move, or edit), and delete custom regions.
  
  — View, copy, move or delete predefined regions, but not edit them.

• **Script Reference**: Allows you to generate a report that shows which routing scripts reference a specific configuration record.

• **System Information**: Allows you to view and set general and application gateway information about your enterprise.

• **Unreferenced Objects**: Lists the database tables that have unreferenced records. Use this tool to find specific integrity problems within the database.

Wizards

Two wizards guide you through the configuration of:

• Translation routes (Translation Route Wizard)
• Call center applications (Application Wizard)

Use these wizards for step-by-step guidance in configuring the above.

Common Bulk, List, and Explorer Tool Features

The Bulk, List, and Explorer tools have the following common features:

• Common Filter Access

To access data from the database, in the Select filter data box of the Explorer, List, or Bulk Insert tool window, select the type of data you want and click the Retrieve button.

• Record Status Symbols

When you make an edit, the record's status symbol updates accordingly. This appears to the left of the record name in the list box of the Explorer or List tool and in the State column of the bulk tool.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Figure 9: Green check</td>
<td>A green check mark means the object has not changed since you retrieved it from the database or made a save.</td>
</tr>
<tr>
<td><img src="image" alt="Green Check" /></td>
<td>Note: This feature not common to the Explorer tools.</td>
</tr>
<tr>
<td>Figure 10: Red X</td>
<td>A red X means the object is marked for deletion and will be deleted when you click the Save button.</td>
</tr>
<tr>
<td><img src="image" alt="Red X" /></td>
<td></td>
</tr>
<tr>
<td>Figure 11: Yellow arrow</td>
<td>A yellow arrow means that the object's data has been changed and the changes have not yet been saved in the database.</td>
</tr>
<tr>
<td><img src="image" alt="Yellow Arrow" /></td>
<td></td>
</tr>
<tr>
<td>Figure 12: Yellow addition</td>
<td>A yellow addition sign means the object is to be inserted into the database when you click the Save button.</td>
</tr>
<tr>
<td><img src="image" alt="Yellow Addition" /></td>
<td></td>
</tr>
<tr>
<td>Figure 13: Red Circle</td>
<td>A red circle with a red slash through it indicates the object was created using an application and is controlled by the Application Object Filter (AOF) or by Peripheral Auto Configuration.</td>
</tr>
<tr>
<td><img src="image" alt="Red Circle" /></td>
<td></td>
</tr>
</tbody>
</table>

Other common features:

• ID status box

The label in the ID box at the bottom of the screen identifies the Unified ICME system (instance) on which you are working.

• Delete/Undelete button
When a record is selected and you click the **Delete** button, that button toggles to **Undelete** and a red x marks the record for deletion. As soon as you save your database changes the marked record(s) is deleted from the database.

- **Save button**

  No changes are made to the database until you click the **Save** button.

**Common List and Explorer Tool Features**

The List and Explorer tools share the following features.

- **List Box of Retrieved Records**

  Both the Explorer and List tools have a list box that displays retrieved records. Selecting a record in this list displays that record's properties in the right side of the tool window. Once displayed, you can edit a record if you have maintenance access to it.

  **Retrieved records**

  - **Tree** (only in Explorer tools)

    In an Explorer window, the retrieved list is called a directory *tree*, which can be expanded or contracted to show a hierarchy of records. A *legend* above the tree identifies the types of records that can be displayed in the tree.

    With the mouse, you can select a record in a tree and then move it to another part of the tree, as long as its object type belongs in that tree location.

  - **UNASSIGNED** (only in Explorer tools)

    The Explorer tree can also contain UNASSIGNED records. These are stored in an UNASSIGNED directory for the selected directory tree object.

    A record is named UNASSIGNED if it was not assigned (mapped) to a parent object. For example, a label, created in the Bulk Configuration tool, might not have been assigned to a peripheral target, or a route might not have been assigned to a service.

    You can also use the Label Bulk Configuration tool to take the output of a switch and create 20 or 30 labels. Then, using an Explorer tool, you can attach the labels to an appropriate location.

  - **List** (only in List tools)

    In a list window, the retrieved list is called a *list* and has no legend above it since its records have no or only one relationship to another record.

- **Adding New Records**

  The **Add** button is enabled only after you use the Select filter data section of the window.
In the Explorer tools, when a record in the tree is selected, you can add another record of the same kind or a record immediately below it in the tree hierarchy. In the List tools, the Add button is enabled only for the single type of records listed.

**Deleting Records**

Selecting a record and clicking Delete marks the record (with a red x) for deletion. However, the record is not deleted until you click Save.

Delete toggles to Undelete when you select an object marked for deletion. To undelete an object marked for deletion, select it and click Undelete.

**Options Menu**

In the Explorer and List tool windows, right clicking on a retrieved record displays an options menu containing all the editing options for that record.

Note: This menu is not available in the List tools if you have read-only access.

**Accessing Database Records**

The Bulk Configuration, Explorer, and List tools enable you to access records from the database in the same way. In these tools, use the Select filter data box to select and retrieve data from the database. Until you retrieve database data, no data is displayed.

In the top left of the Bulk Configuration Insert, the Explorer, and the List tool windows is a Select filter data box similar to the following.

*Figure 14: Select Filter Data Box*

In this example, all records belonging to the Boston_PG_1 peripheral and having JO in their names are selected for retrieval from the database.

The filters used to select data vary according to the type of data. In the preceding example, data is first selected by peripheral and then by name. Some filter selection boxes have only optional filters.

To achieve maximum response time when retrieving records
Always select a specific member from the Primary Filter, even if only one exists. For example, for the Dialed Number/Script Selector List tool, always select a specific Routing client and Customer. In addition to reducing the number of records loaded and listed, this also improves response time when navigating through the list of records and when adding new ones.

Specify an Optional Filter whenever possible to further reduce the number of records retrieved. For example, when using the Dialed Number/Script Selector List tool, this could be a Name, Dialed number string, or Description.

Separate the operation of adding records from editing existing records. In addition to selecting the targeted Primary Filter, specify a unique Optional Filter for the new record that will result in no existing records being loaded. For example, when using the Dialed Number/Script Selector List tool, specify the exact Dialed Number string to be added. The retrieval response time will be almost instantaneous and the list of records being added will be easier to manage.

If any editable field is changed, an additional dialog appears (below the Select filter data dialog) displaying the original filter settings. In addition, the tree list box and all buttons except Retrieve, Close, and Help are disabled.

Clicking Close cancels the filter changes and returns the fields to their original settings. Clicking Retrieve closes the Select filter data dialog and enables the display (in the tree list box) of the record retrieved based on the selected filter criteria.

The following table describes how the optional filters, the check box, and the filter buttons work for all the Bulk Insert, Explorer, and List tools.

### Table 3: Common Filter Functions

<table>
<thead>
<tr>
<th>Filter Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Filter</td>
<td>None in the optional filter box means no optional filtering. All data is displayed for the selected records. The optional fields to filter on differ by record type according to both the fields in a record and the fields considered useful as filters.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Condition</th>
<th>If the selected Optional Filter is</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>None</td>
<td>The Condition filter is ignored.</td>
</tr>
<tr>
<td></td>
<td>A text filter (for example, Description)</td>
<td>Select one of the text conditions (Contains, Ends With, Starts With, Is Blank) and enter an appropriate entry in the Value field.</td>
</tr>
<tr>
<td></td>
<td>A numeric filter (for example, Trunk Number)</td>
<td>Select one of the numeric conditions (Equal, Greater Than, Less Than, Not Equal) and enter an appropriate entry in the Value field. The available numeric conditions can change depending on the record data. For example Equal or Not Equal might be the only choices.</td>
</tr>
<tr>
<td>Filter Item</td>
<td>Function</td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td>The entry in this field is based on the selections made in the Optional Filter and Condition fields. If None is selected in the Optional Filter field, this field is ignored.</td>
<td></td>
</tr>
<tr>
<td>Save check box</td>
<td>Checked, indicates the current settings are saved so that when you next open the List tool for this type of record, the current settings will be selected. However, no data is displayed until you click the Retrieve button.</td>
<td></td>
</tr>
<tr>
<td>Retrieve button</td>
<td>This button displays the data selected in the Select filter data box.</td>
<td></td>
</tr>
<tr>
<td>Cancel filter changes button</td>
<td>If you change the Optional Filter settings after a Retrieve, clicking this button resets the filter settings back to the preceding ones.</td>
<td></td>
</tr>
</tbody>
</table>

**Saving Configuration Data to the Database**

When you have completed adding information in an open configuration window, click Save.

The system software saves the configuration data and immediately applies your changes to both the local and central Unified ICM database.

**Note:**

- Whenever any data is retrieved by a configuration tool, it notes the last change mark on that data at this point in time. If you then attempt to change that item, it first checks the current copy in the database for its change mark. If the change marks do not agree, it indicates another user has changed this item since you last retrieved it, and an error is returned. You must then discard any changes, using Retrieve to obtain the latest information for editing.

- This approach is called *optimistic* locking, and assumes that it is rare to have two people needing to change the same item at the same time. This prevents the performance and maintenance issues involved with hard locking items, while still preventing one person from accidentally overwriting another user's changes.

**Feature Control**

In general, feature control addresses the need of restricting users, or classes of users, from all functionality of the system software.

Observe the following distinctions between object level control and feature control:

- Object control, part of the system software partitioning feature, is a method of security for prohibiting access to configuration data in the Unified ICM database.

- Feature control, like the Limited (single Instance) Administration & Data Server, is a method of security for prohibiting access to the system software features.

Script Editor feature control addresses the need of restricting users, or classes of users, from some or all of the functionality of the Script Editor software. In a possible deployment scenario, a system software administrator can restrict certain people from doing specific types of script
editing. Similar functionality was previously available in the system software in both the “Limited (single Instance) Administration & Data Servers” and the WebView “Quick Edit” feature control.

An administrator has two means to restrict access to the editing features of Script Editor and Internet Script Editor:

- Edit options
- Script node control

It is also possible for an administrator to use a combination of both feature control options.

**Note:**

- In previous Unified ICM Software versions (including, and prior to Unified ICM 4.x), any change made to the read-only status of a user was not dynamically updated in the Script Editor. Script Editor had to be closed, then reopened before the change took effect.

- In Unified ICM Release 7.0(0) and higher, any change made to a user’s read-only status (using the User List tool) is automatically updated in Script Editor.

Refer to the *Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted* for additional feature control information.

**Script Node Control**

Script node control allows an administrator to create feature sets that can be assigned to users. The feature set controls which script nodes are accessible to the user.

**Node Control Table**

The node control table (on the *Configuration Manager Script Editor Feature Control* dialog) has two columns, the *Node* column and the *Available* column. This table allows an administrator to create feature control sets that can be assigned to users. The feature control set controls which script nodes are accessible to the user.

If a script is opened that contains a disabled node, you can browse or monitor the script but you cannot put the script into edit mode. If you attempt to put this script into edit mode a message indicating you are not authorized to enter edit mode is displayed. However, you can still Quick Edit the script, just not the node.

**Node column**

A node is an executable element within a script. A script consists of nodes, connections, routing targets, and comments. Every script begins with a Start node. This column lists all the nodes that can be used in a script.
Available column

Each checked node in this column appears on editing pallet of the feature-control-set user, regardless of the edit mode (Full Edit or Quick Edit Only).

There are two possible presentation effects:

- Enabled nodes are displayed on the object palette
- Disabled nodes are removed from the object palette

Configuring a Feature Control Set

Configuring a feature control set consists of:

- Creating a feature controls set (see the "How to Create a Feature Control Set (page 45)" section)
- Assigning users to a feature controls set (see the "How to Assign Users to a Feature Control Set (page 46)" section)
- Selecting the script nodes available in a feature controls set (see the "How to Select Script Nodes for a Feature Control Set (page 46)" section)

How to Create a Feature Control Set

The system administrator can create a feature control set using the Configuration Manager on the Unified ICM Administration & Data Server.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Ensure the user(s) the feature set is to be assigned to are configured.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Start the Configuration Manager by selecting Start &gt; All Programs &gt; Cisco Unified CCE Tools &gt; Administration Tools &gt; Configuration Manager. The Configuration Manager dialog opens.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Select Tools &gt; List Tools &gt; Feature Control Set List.</td>
</tr>
<tr>
<td>Step 4</td>
<td>In the Feature Control Set section (on the left), click Add.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Select the Attributes tab.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Enter the name of the feature control set. The name appears in the left section when Enter or Tab is pressed.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Enter a description (optional).</td>
</tr>
</tbody>
</table>
How to Assign Users to a Feature Control Set

The system administrator can assign users to a feature control set:

**Step 1** Start the Configuration Manager by selecting Start > All Programs > Cisco Unified CCE Tools > Administration Tools > Configuration Manager. The Configuration Manager dialog opens.

**Step 2** Select Tools > List Tools > User List.

**Step 3** Select the user to whom feature control set is to be assigned.

*Note:* If no users appear, add the user(s) using the User List tool.

**Step 4** On the Attribute tab, select the feature set for the selected user.

**Step 5** Click Save when you are finished assigning feature sets.

How to Select Script Nodes for a Feature Control Set

To select script nodes:

**Step 1** Select the name of the feature control set to be assigned.

**Step 2** Select the Attributes tab.

**Step 3** Select Advanced (under Script Editor).

**Step 4** In the Script Editor Feature Control dialog, select the nodes for this feature control set and an edit option (Full Edit or Quick Edit).

**Step 5** Click OK.

**Step 6** Click Save.

Validating Configuration Data

After making changes or additions to your configuration, you must always check that it is internally consistent and complete.

*Note:* It is especially important to perform integrity checks if you have imported data from another source.
How to Check the Integrity of Your Configuration Data

To check the integrity of your configuration data, perform the following:

**Step 1** In the Configuration Manager menu, select **Miscellaneous Tools > Integrity Check**. The Integrity Check dialog appears.

**Step 2** Choose the type of check option that you want to perform or click **Select All** to choose all the check options. (For specific information about each of these options and the tables and fields they check, refer to the Configuration Manager online help.)

**Step 3** Click **Perform Check**. The Configuration Manager performs the check and one of the following happens:

a. If the check discovers a problem, the Configuration Manager displays messages in the Integrity Problems text box. Double-click on a message to receive specific information about the records in the data table at the bottom of the window.

b. If the check completes without finding any invalid data, the Configuration Manager displays a message saying the integrity check completed successfully.

**Step 4** When all checks are complete, click **Close**. The Integrity Check dialog closes.

Many database records need references to related records. For example, each peripheral target ought to reference a route and each trunk group ought to reference a network trunk group.

How to Check Record References

To check record references, perform the following:

**Step 1** In the Configuration Manager menu, select **Miscellaneous Tools > Unreferenced Objects**. The Unreferenced Object dialog appears listing the database tables containing objects that are missing references.

**Step 2** To see the specific rows that are missing references in a table, double-click on the table name. Double-clicking on a table name entry displays that table showing the records that are missing references.

Deleting Configuration Records

At some point, you might want to remove configuration records from your database; for example, if data has been entered in error or changes occur in your business.
How to Delete a Record

To delete a record:

Step 1 Within Configuration Manager, open any one of the tools in which you can configure that type of record and retrieve the record.

Step 2 Select the retrieved record.

Step 3 Click **Delete**. A red X (marked for deletion) appears in the window next to the name of the record. The **Delete** button toggles to **Undelete**. To undelete the record, select it and click **Undelete**.

Step 4 Click **Save** to save the deletion to the database. The record is deleted from the database and is removed from the window.

**Note:** Some deleted records can still be viewed, as described in the “Administering Deleted Records (page 47)” section. The following section, Types of Deletion (page 47), describes why.

Step 5 Click **Save**. The deletion is saved to the database and the record disappears from the window.

Types of Deletion

Depending on the record involved, the Configuration Manager performs one of two types of deletion:

- **Immediate deletion.** The system software immediately removes the record from the database. (Also known as “physical deletion.”)

- **Logical deletion.** The system software sets the record's Deleted field to **Y** (yes), but the record remains in the database. The Configuration Manager and the CallRouter treat the record as though it were deleted. The record remains in the database, however, for historical reporting purposes.

**Immediate Deletion**

Some tables — for example, the Skill Group Member table, which maps agents to skill groups — do not have a Deleted field. When you delete a record from such a table, the system software immediately removes the record from the central and local database.

**Logical Deletion**

Other tables, for example, the Skill Group table, which describes a skill group associated with a peripheral — do have a Deleted field. When you delete a record from such a table, the system
software does not remove the record from the central and local database. Instead, the system software sets the record's Deleted field to Y to indicate that it is logically deleted.

Logical deletion ensures that any references to the record — for example, references to a skill group in call detail records — remain valid. However, the Configuration Manager and the Script Editor treat the record as though it were deleted.

**Caution:** Never attempt to set a configuration record's Deleted field directly. Changing a Deleted field directly can compromise the integrity of your Unified ICM database. Use the Configuration Manager Tools > Miscellaneous Tools > Deleted Objects option to permanently remove logically deleted records.

**Deletion Dependencies**

How a configuration tool processes a record deletion request depends on whether, and how, the record is referenced by other configuration records:

- If no other records reference the current record, the configuration tool deletes the record.
- If other records reference the current record — and the configuration tool can neither modify the references nor delete the other records — the configuration tool does not delete the record.

**Administering Deleted Records**

The Configuration Manager lets you view logically deleted records. It also allows you to permanently delete these records.

**How to View Deleted Records**

To view deleted records, perform the following:

**Step 1**

In Configuration Manager menu, select **Tools > Miscellaneous Tools > Deleted Objects**. The Deleted Objects dialog appears, indicating the tables in which records are marked for deletion and the number of records so marked.

**Step 2**

To see the specific records marked for deletion within a table, double-click on a table name. If you double-click on a table name entry, a list window appears showing records from that table that are marked for logical deletion.

**Step 3**

To remove a record(s) from the database entirely, select it in the list (or use the Select All button to select all) and click **Delete Permanently**. The Configuration Manager displays a message indicating the operation completed.

You must have access rights to a record to be able to delete it permanently.

**Step 4**

Click **Close** to close the dialog.
Configuring Bucket Intervals

You can configure call type intervals in relation to your service levels. For example, if your service level threshold is 15 seconds and you want to see when callers are abandoning within that service level, you can set intervals of 5 seconds, 10 seconds, and 15 seconds.

How to Configure Bucket Intervals

**Note:** The "Configuring Call Types on the Child Central Controller (page 50)" section contains an example of how to configure call types on a child deployment, which is documented in the Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX.

Reports can display information from up to ten intervals. You can configure up to nine intervals, and the tenth interval shows all the remaining data. To configure bucket intervals, perform the following:

**Step 1** Open the Configuration Manager tool and expand the Tools menu.

**Step 2** Expand the List Tools menu and double-click **Bucket Intervals List**.

**Step 3** Click **Retrieve** to display the default values.

**Step 4** Click **Add** to add a new list of interval values.

**Step 5** In the Name field of the Attributes tab, assign the list a name.

**Step 6** Assign your new values to the **Upper bound 1 - 9** fields.

**Step 7** Click **Close** to close the Bucket Interval List tool.

**Step 8** Double-click the **Call Type List** tool.

**Step 9** Click **Add**.

**Step 10** In the Name field of the Attributes tab, assign the new list a name.

**Step 11** Select the **Customer** from the pull-down menu.

**Step 12** Check the **Override System Information Default** box for the Bucket intervals section.

**Step 13** Using the pull-down menu, select the Bucket intervals list you previously created.

Configuring Call Types on the Child Central Controller

Access the Configuration Manager on the Child Administration & Data Server to configure call types.
How to Configure Call Types on the Child Central Controller

Use the Configuration Manager Call Type List tool to configure call types on the Child Central Controller.

**Step 1**
Start the Call Type List tool.

**Step 2**
In the Main window of the Call Type List tool, click **Retrieve**.

**Step 3**
Click **Add**.

The Call Type Attributes tab appears.

**Step 4**
Set **internal_2500CT** as the Name, then select **bh03** as the Customer setting.

**Step 5**
Click **Save**.

The call type appears in the tree list.

**Step 6**
Repeat this process to add two more call types (**internal_2501CT** and **internal_2502CT**).

When finished, you have the following call types:

- internal_2500CT
- internal_2501CT
- internal_2502CT

**Step 7**
Click **Save** next to the green checkmark, and then **Close** to exit the Call Type List tool.
Configuring Multiple Records at a Time

This chapter shows you how to use the Configuration Manager Bulk Configuration tool to insert and update multiple configuration records in a single transaction from a single screen.

In some cases, you might need to work with multiple records of configuration data simultaneously.

For example, you might want to:

- Import records from a text file
- Modify a specific field in multiple records
- Insert a set of records

The Bulk Configuration tool lets you perform these operations on several Unified ICM data tables simultaneously. This tool supplements the Configuration Manager Explorer and List tools, which allow you to insert and update single records.

**Note:** Refer to the Bulk Configuration tool’s online help for detailed information.

This chapter contains the following topics:

- How to Access the Bulk Configuration Tools, page 53
- Data You Can Bulk Configure, page 54
- Insert and Edit Windows, page 54
- Bulk Configuration Features, page 55

How to Access the Bulk Configuration Tools

To access the Bulk Configuration tools, follow these steps:
Step 1  Double-click Configuration Manager in the Administration Data Server group or the Administration Client group.

Step 2  In the Menu selection box, select Tools > Bulk Configuration.

Step 3  Then from the submenu selection list, select Insert if you need to insert data or Edit if you need to edit.

Step 4  Finally, in the next menu selection list, select the type of table with which you need to work.

Data You Can Bulk Configure

From the Bulk Configuration menu, you can choose to create or update records in the database tables.

Start by selecting the Bulk Configuration Insert or Edit menu. Then select the database table you want to modify.

If you have any questions, refer to the online help. The help contains table record and field definitions and procedures for all that you can do with the Bulk Configuration tool. The following sections briefly describe the tool and how to use it.

Insert and Edit Windows

Depending on whether you select Bulk Configuration Insert or Edit, the Bulk Configuration Insert or Edit window for the selected database table opens.

These two windows have the following features:

• Same Options

Both windows have the same options except for Insert (Insert window) and Retrieve (Edit window).

Reason for Two Windows

The reason for having both an insert and an edit window is to prevent confusion when editing records since some configuration objects can only be edited when inserted into the database, the database being a relational one. For example, when you insert the record of a label, you can edit all its fields. However, once you define (and save it in the database) its routing client, the only way you can redefine the routing client is by deleting the label and creating a new one.

• Saving Changes
The changes you make in the Insert or Edit window are not applied to the database until you click **Save** or **Close.** The **Close** button closes the window and gives you the option of saving or cancelling any database changes.

- **Initial Display**

  Initially, both windows open without data and wait for your retrieval command (in the Edit window) or insert/import command (in the Insert window).

- **Editable Data Table Fields**

  Columns with an asterisk (*) next to the title indicate required fields. Fields shaded in **blue** cannot be modified directly. However, in some cases setting or changing one field will make another field updateable.

- **Record State**

  The first data column contains a symbol indicating the condition of a row's record.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Indicates the record is</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Not changed icon" /></td>
<td>Not changed since you retrieved the record or saved it.</td>
</tr>
<tr>
<td><img src="image2" alt="Changed icon" /></td>
<td>Changed in the current editing session but not yet saved.</td>
</tr>
<tr>
<td><img src="image3" alt="Changed icon" /></td>
<td>To be inserted into the database when you save your edits.</td>
</tr>
<tr>
<td><img src="image4" alt="Deleted icon" /></td>
<td>To be deleted from the database when you save your edits.</td>
</tr>
</tbody>
</table>

**Bulk Configuration Features**

You can do the following with the Bulk Configuration tool:

- Retrieve records from the database (Edit Window only).
- Sort records by a single column or by multiple columns.
- Use the search tool to find data in a list of records.
- Apply a single value to a range of fields or apply a range of values to a range of fields.
- Insert additional new rows (records) into the database table (Insert Window only).
• Import multiple record data (either whole records or record fields).

• Export multiple record data (either whole records or record fields).

• Set or change security settings to multiple records at a time.

• Delete records. After deletions are saved to the database (or after you close your editing session), you can no longer undelete deleted records.

• Undelete records that are marked for deletion in the current editing session.

The following sections describe how to use the Bulk Configuration tool.

Retrieving and Editing Records

Use the *Select filter data* box in the *Edit* window to retrieve records from the database.

How to Retrieve and Edit Existing Records

To retrieve and edit existing records, follow these steps:

**Step 1**  
Within the **Bulk Configuration > Edit** menu, select the name of the database table you want to modify. The appropriate Edit window appears. (Initially, no records are shown.)

**Step 2**  
Do one of the following:

a. To retrieve a range of records, specify values in the *Select filter data* fields. For example, you could enter values that would retrieve only dialed numbers associated with a specific customer, with a specific routing client, or both.

b. To retrieve all records, leave the Customer and Routing Client fields set to **All**.

**Step 3**  
Click **Retrieve**. The appropriate rows are displayed in the Edit window as in the following example.
Step 4 Once you have retrieved the records you want to edit, you can edit individual records or a range of records. In a range of records, you can enter a range of values or the same value. You can also delete, import, export, and sort records.

Sorting Records

You can sort records (rows) in two ways: by one column or by multiple columns.

You might want to sort by multiple columns if the first column(s) to sort by has the same value in more than one field, for example, the same routing client, label, or customer name.

- To sort records by one column: double-click on that column's header. To reverse the sort, double-click a second time. When you double-click, an A (Ascending) or D (Descending) appears after the header to indicate the sort order.
- To sort records by multiple columns, see the following procedure.

How to Sort Records by Multiple Columns

Step 1 In the Insert or Edit window, click Sort. The Sort dialog displays.

Step 2 In the Columns available for sort list, select each column by which you want to sort and click Add.
The primary sorting column will be the first column listed in the Columns selected for sort list. To change the column sort order, select a column and click the up or down arrow.

The data within each column is sorted in Ascending order unless you deselect the check box beside the column.

**Step 3** Click OK.

---

**Finding Data in a List of Records**

After you have retrieved a set of records, you can use the Find area of the Edit window (Column Name and Expression fields) to search for specific records within the set.

**How to Find Data**

To find data in a list of records follow these steps:

**Step 1** In Find box of the *Edit or Insert* window, select the database column in which you want to search for data.

**Note:** You can also select a column by clicking in that column.

**Step 2** In the *Find box Expression* field, enter the value for which you want to search. You can enter a full value or a sub-string.

**Step 3** Click *Find Next* to locate the first record that matches the search criteria. The first row that contains the specified expression in the selected column is highlighted.

---

**Selecting Data**

You can select whole records for importing, exporting, setting security, deleting, or undeleting. Or, you can select the same field in multiple records for simultaneous editing.

**How to Select Records**

Clicking in the left-most numbered field in a row both selects that row and highlights it. Clicking in any field in a row also selects the row but does not highlight it.

**How to Select One Field in Multiple Records**

You can select one edit-control field (when there is no section box in the field) in multiple records in any one of the following three ways:

- Click the field where you want to start and, keeping the left mouse button held down, move the cursor to the last field.
• Click the field where you want to start. While holding down the Shift key, click the last field.

• Click the field where you want to start. While holding down the Shift key, make your selection by clicking the down arrow.

• Press Ctrl, then left-click on each field you wish to select. This allows you to select a random group of fields.

For selecting one value in multiple selection box fields, see the following section, "Editing a Range of Data (page 59)."

Editing a Range of Data

You can edit a range of data in a table column in several ways:

• Apply a single value to a range of (edit-control) fields

• Apply a single value to a range of selection-box fields

• Apply a range of values to a range of fields

How to Apply a Single Value to a Range of Edit-Control Fields

An edit-control field is one you can edit that does not contain a selection box.

**Step 1** Make your selection: click the field where you want the range to start and, keeping the left mouse button held down, move the cursor to the last field in the range.

**Step 2** Type the new entry that you want to appear in all the fields.

**Step 3** Click Enter or Tab. This applies the change to all the records in the range and moves the focus to the next data field.

How to Apply a Single Value to a Range of Selection-Box Fields

**Step 1** Select the first field where you want the range to start.

**Step 2** Hold down the Shift key and keep it down for steps 3, 4, and 5.

**Step 3** Click the selection-box down arrow but keep the left mouse button held down and select the fields you want in the range.

**Step 4** Click the last field in the selection to display the selection list. You can also open the selection box by pressing Alt + an arrow key.

**Step 5** Click your selection.
Step 6  Click **Enter** or **Tab** (or in any other field). This applies the change to all the records and moves the focus to the next data field.

How to Apply a Range of Values to a Range of Fields in a Column

To apply a range of values to a range of fields in a column

Step 1  Select the range of fields in a database column. This enables the **Edit Range** button.

**Note:** The **Edit Range** button does not work for selection-box fields.

Step 2  Click **Edit Range**. The Edit Range dialog displays.

*Figure 20: Edit Range dialog box*

Step 3  In the Edit Range From field, enter the first number of the range.

Step 4  In the Prefix and Suffix fields, you can optionally enter substrings to appear at the start and/or end of each value. The Edit Range dialog lists the generated values.

**Note:** When entering a numeric range, you may also enter leading zeros to ensure proper alignment (that is, 001 to 999).

Step 5  Click **OK**. This applies the changes to the fields you selected in the Insert or Edit window.
Inserting New Records

You can insert new records by inserting multiple blank rows (records) and filling in the data (see the "How to Insert New Records (page 61)" section, or by importing the data (see the "How to Import Data (page 62)" section).

You can also edit the data you insert when you insert it.

How to Insert New Records

**Step 1**  
In the **Bulk Configuration > Insert** menu, select the name of the data table to which you want to add records. The appropriate Insert window opens, automatically displaying one new row.

**Step 2**  
To create additional rows, enter the number of additional rows in the Quantity field and click **Insert**. The additional rows are added in the Insert window.

**Step 3**  
Enter the data in the rows:
   a. If you want to edit individual fields in the new rows, type the information you want in each of the fields and go to Step 8.
   b. If you want to edit a column in multiple rows so that a range of values is entered, go to Step 4.
   c. For other ways of entering data into multiple rows, see the "Editing a Range of Data (page 59)" section.

**Step 4**  
Select the rows in the column you want to modify.

**Step 5**  
Click **Edit Range**. The Edit Range dialog appears.

**Step 6**  
Enter a prefix (optional), the start value for the range, and a suffix (optional). The generated values are listed in the dialog.

**Step 7**  
Click **OK** to close the Edit Range dialog and apply the values to the column you selected.

**Step 8**  
When you have finished setting fields in the new rows, press **Enter** to apply your changes to the Unified ICM database.

You can leave empty rows, the system ignores them.

**Note:** No changes are made to the database until you press **Enter**.
Importing Data

You can import data from a specified text file into the opened database table. Whole records or only columns of data can be imported, if the data matches (see Step 3 of the following procedure). If any error occurs during the import process, the process is cancelled.

How to Import Data

**Step 1**
In the Insert or Edit window, click **Import**.

**Step 2**
In the Import dialog, click **File**.

**Step 3**
In the File Open dialog, select the file containing the data you want to import and click **Open**. For a description of the required import-file format, see the "Import/Export Data File Format (page 63)" section following this procedure.

The Import File Data area displays the first few lines of the opened file.

- When importing data in the Edit mode, the following rules apply:
  - The Bulk Configuration tool reads only those records whose primary key values match those of records in the Edit window.
    
    If there is a record that does not match the primary key value, the record is considered to be an error and a message box with the primary key value pops up to ask you to correct the problem.
    
    - If any field in the import record is null, the corresponding field value in the grid window become blank for an edit cell or uses the default value for a drop-down list cell.
    
    - If any field is missing in the import file, the corresponding field in the Edit window remain unchanged.
    
    - If there is a larger number of records in the file to be imported than the number of rows in the grid, it is considered as an error and a message box pops up asking you to correct it.
    
    - If there is a duplicated primary key in the file to be imported, it is considered as an error. A message box with the duplicated primary key value pops up asking you to correct it.
    
    - After importing, all records imported (including records marked for deletion in the grid) are marked as “Changed” regardless whether the value is changed or not.
    
    - After a importing, the records are displayed in index order (ordered by logical keys). If you did not sort before importing, the order appears the same after the import.
  
- When importing data in the Insert mode, the following rules apply:
– Only a single import is supported and any existing rows are removed from the grid. When you click Import, a message box pops up if there is any record in the grid. You will see the following message:

“All the existing data will be replaced by the data to be imported. If you want to retain the current data on the grid please click the Cancel button then save or export the existing data. Click the OK button to proceed with the importing.”

– After importing, all rows are marked as “New” and the ordering is the same as that in the file imported from.

– In the Import Insert mode, the tool reads only those records whose primary key values are not presented. If the primary key field is selected for file to be imported, it is considered an error and a message box with the primary key field name pops up asking you to correct the problem.

– If any field in the import record is null, the corresponding field value in the grid window becomes blank for an edit cell or uses the default value for a drop-down list cell.

**Note:** If headers are included in the imported file, the Add and Remove buttons are not enabled and you can only import the record(s) as a whole. In that case, go to Step 6.

**Step 4** If the imported data does not contain headers, in the Available Fields list box, select the names of the fields to import that match the data and click Add.

**Step 5** To change the order of the columns, select a column and move it within the list by clicking Up or Down.

**Step 6** Click OK. The data is imported into the data table.

---

**Import/Export Data File Format**

The import and export files used by the Bulk Configuration tool can optionally include a header that identifies the table and columns in the file. The header is followed by one line for each row of data.

The following rules apply to the file headers:

- A line beginning with a number sign (#) is a comment and is ignored.
- Blank lines are also ignored.
- The header content is indicated by a line beginning with two underline characters and the word TABLE or COLUMNS. The following line contains the name of the table or the name of the columns. For example:__TABLE

  Call_Type __

  COLUMNS
<table>
<thead>
<tr>
<th>CallTypeID</th>
<th>EnterpriseName</th>
<th>Description</th>
<th>Deleted</th>
<th>CustomerDefinitionID</th>
</tr>
</thead>
</table>

- All column names must be on a single line and are separated by Tab characters.

The following rules apply to the data in the files:

- One row of table data per line.

- Column values must be in the same order in all rows. If columns are specified in the header, the columns in the data rows must be in the same order.

- Column values are separated by a single Tab character.

- Fields intentionally left blank must be represented by two adjacent Tab characters or a Tab character at the end of a line. On import, the default value is used for such a value.

- String values may include spaces.

- An error occurs on import if a line contains too few or too many values.

**Note:** A simple way to create the import file with a valid format is to use Excel and save it as Text (Tab delimited) (*.TXT).

### Exporting Data

The export function saves the selected records or field(s) to a tab-delimited text file that you can import into the Unified ICM database or into a database tool such as Microsoft Excel. If any error occurs during the export process, the process is cancelled.

### How to Export Data

To export data, follow these steps:

1. **Step 1** Select the rows with fields you want to export.

   **Note:**

   - If you intend to import this data into the Edit window, you must export a primary key field along with any other fields. The primary key field has the same column name as the database table name.

   - All rows selected (including records marked for deletion) are exported.

2. **Step 2** Click **Export**.

3. **Step 3** Select the Header option if you want to include a header containing the table name and column names in the output file. Including the header clarifies the content of the file.

4. **Step 4** In the Export dialog, select the column(s) you want to export and click **Add** or **AddAll**.
Step 5  To change the order of the columns to export, select one of them and move it within the list by clicking **Up** or **Down**.

Step 6  Click **File** and specify the file name and directory to which to save the data.

Step 7  Click **OK**.

---

**Applying Security Settings to Multiple Records**

For the **Security** button (in the Explorer and Bulk tools) or tab (in the List tools) to be visible and enabled:

- The Unified ICM Partition installation **setup** option must be installed on your Unified ICME system.

  **Note:** As of Unified ICME Release 8.0(1), Partitioning is no longer supported except on systems that already have Partitioning installed.

- You must have maintenance access to the selected database record(s) and to the system class.

**How to View or Apply Security Settings**

To view or apply security settings:

**Step 1**  Follow the steps for viewing the item whose security setting you want to see or apply. (See the online help if you have questions.)

The selected item's configuration information displays.

**Step 2**  Select the item(s) whose security settings you want to view or edit.

**Note:** You can apply security setting to more than one record at a time only in the Bulk Configuration tool. In this tool's window, if there are security settings on the selected records and they are mixed (different records having different settings), no security data is displayed. If you want to apply one setting to records with mixed settings, select **Override existing settings**.

**Step 3**  Click **Security**. The Security dialog displays.

**Step 4**  View and/or make the security settings.

To view or make the security settings:

- To remove access to the records: In the User Access display area of the Security dialog, select the user or group to remove and click **Remove**.
To edit access to the records: In the User Access display area, select the user or group to edit and click Edit or double-click on the item you want to edit. Then in the Edit Permissions dialog, select the access type and click OK.

To add access to the selected records:
- Click Add. The Add Users and Groups dialog displays.
- Select User or Group
- Select the user or group name(s) for which you want access rights.
- Select the Access type from the selection list and click OK:

  **Access Type**
  - **Read** access means a specific user or group can view or reference the object, but cannot modify it.
  - **Reference** access means a specific user or group can reference the object in a script. This includes read access, but not write access.
  - **Maintenance** access means a specific user or group can update or delete the object as well as view and use it.

**Step 5** When done, in the Security dialog, click OK.

Deleting and Undeleting Records

You can delete one or more records at a time and you can undelete records marked for deletion.

How to Delete Records

To delete records, follow these steps:

**Step 1** Select the row(s) to be deleted.

**Note:** Selecting any field in a row (or any range of fields in a column) selects the rows of which they are a part.

**Step 2** Click Delete. The selected rows are marked for deletion.

**Step 3** Click Save. The rows marked for deletion are deleted from the database.

**Note:** You can no longer undelete records marked for deletion once you have saved your changes to the database.
How to Undelete Records

**Step 1**  Select the rows marked for deletion.

**Step 2**  Click **Undelete**. The deletion mark is removed from the records.

**Step 3**  Click **Save**. The change is saved to the database.
Bulk Configuration Features
Chapter 5

Configuring Routing Clients

This chapter describes how to set up routing clients and their directly related elements.

It includes:

• An introduction to the Routing Client subsystem

• Instructions on how to view, delete, modify, and define:
  – Network Interface Controllers (NICs)
  – Routing clients
  – Dialed numbers

This chapter contains the following topics:

• The Routing Client Subsystem, page 69
• Configuring a Network Interface Controller (NIC), page 72
• Configuring Dialed Number/Script Selectors, page 78

The Routing Client Subsystem

A routing client is an entity that sends route requests to the system software.

A routing client can be:

• A public network interexchange carrier (IXC), such as AT&T, BT, MCI, Nortel, or Sprint

• A private network peripheral, such as an Aspect or Lucent ACD
The "Routing Client Subsystem (page 70)" figure shows the elements of the Routing Client subsystem.

### Interface Controllers

Each routing client must be associated with an interface controller. An interface controller operates on two levels: physical and logical. A physical device is a single instance of a device. A logical device is either a single physical device or more than one physical device running duplexed.

A Physical Interface Controller can be a:

- **Network Interface Controller (NIC).** A NIC communicates directly with the IXC's signaling network, reading call routing requests from the network and transferring them to the Central Controller. This chapter describes how to set up a NIC.

- **Peripheral Gateway (PG).** A PG communicates with the ACD, PBX, or VRU at a contact center, monitoring status information from the peripheral and sending it to the Central Controller. The PG can also act as a routing client, sending routing requests to Unified ICM software. For information on setting up Peripheral Gateways, see Chapter 6, "Configuring Peripherals and Trunk Groups (page 85)."

### Examples of Routing Client Subsystems

You can associate more than one routing client with a single logical interface controller. For example, if a Unified ICM Network Interface Controller (NIC) is serving two AT&T Intelligent
Call Processing (ICP) subsystems, as shown in the figure "Two Clients / One Logical Interface Controller (page 71)," you can define each as a separate routing client through the single logical interface controller.

Figure 22: Two Clients / One Logical Interface Controller

On the other hand, if you have two ACDs performing private network routing through two different Peripheral Gateways, as shown in the figure "Two Clients / Two Logical Interface Controllers (page 71)," you must define each as a routing client because each Peripheral Gateway is a separate logical interface controller.

Figure 23: Two Clients / Two Logical Interface Controllers
Configuring a Network Interface Controller (NIC)

Use the NIC Explorer to view, define, modify, or delete Network Interface Controller information and its associated routing client information.

The NIC Explorer generates records that set up a logical interface controller, one or more physical interface controllers, and one or more routing clients.

How to View a NIC and Its Routing Client(s)

To view a NIC and its routing client(s), follow these steps:

Step 1 From the Configuration Manager menu, select Tools > Explorer Tools > NIC Explorer. The NIC Explorer window appears.

Step 2 In the Select filter data box, select the filters you want.

Step 3 Click Retrieve. The name(s) of the retrieved NIC(s) are listed in the tree list box.

Step 4 In the tree list box, select the NIC whose records you want to view. The selected NIC's configuration information displays in the fields on the right. For field descriptions, see the "NIC Explorer Tab Descriptions (page 72)" section.

Step 5 To view a routing client record, in the tree list box, expand the tree branch for the selected NIC and select the NIC's routing client icon.

The routing client configuration information displays in the window on the right. For field descriptions, see the "Routing Client Tab Descriptions (page 74)" table.

NIC Explorer Tab Descriptions

The following tables describe the tabbed property fields and buttons that configure a NIC and its routing client(s).

Logical Interface Controller Tab

The Logical Interface Controller tab allows you to view (and define or edit, if you have maintenance access) the properties of the selected logical interface controller.

The NIC (Network Interface Controller) is the computer and process within Unified ICM software that reads call routing requests from the network and transfers them to the Central Controller. It consists of a logical interface controller and one or two physical interface controllers. The number of physical interface controllers permitted depends on the client type.
Table 4: Logical Interface Controller Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field/Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller ID (required)</td>
<td>A unique identifier for the NIC's logical controller. This is a read-only field. When you create a new NIC, the system places UNASSIGNED in this field and automatically creates an ID when you save your edits.</td>
</tr>
<tr>
<td>Name (required)</td>
<td>The enterprise name for the NIC's logical controller. This name also identifies the NIC and must be unique for all logical controllers in the enterprise.</td>
</tr>
<tr>
<td>Client Type (required)</td>
<td>The type of routing client serviced by the NIC. For example, Lucent, MCI, Sprint, and so on. When defining a new NIC, select one from the pop-up selection box.</td>
</tr>
<tr>
<td>Configuration Parameter</td>
<td>A string containing information such as logon information, specific to the interface controller device. For example: -rtuser UserName -rtpswd Password</td>
</tr>
<tr>
<td>Add Physical Interface Controller</td>
<td>Click this button to add one or more Physical Interface Controllers. This button is disabled when there is no client type, as in a new NIC record, or when the NIC node reaches its upper limit of Physical Interface Controllers.</td>
</tr>
</tbody>
</table>

Physical Interface Controller Tab

The Physical Interface Controller tab allows you to view (and define or edit, if you have maintenance access) the properties of the selected NIC's physical interface controller(s).

Table 5: Physical Interface Controller Tab Descriptions

<table>
<thead>
<tr>
<th>Field/Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Associated Physical Interface Controllers</td>
<td>A duplexed NIC has two entries in the Physical Interface Controller table and a single entry in the Logical Interface Controller table.</td>
</tr>
<tr>
<td>ID</td>
<td>A unique identifier for the NIC's associated physical interface controller. This is a read-only field. When you create a new NIC, the system places UNASSIGNED in this field and automatically creates an ID when you save your edits.</td>
</tr>
<tr>
<td>Name</td>
<td>The enterprise name of the routing client associated with the NIC. This name must be unique for all physical controllers in the enterprise.</td>
</tr>
<tr>
<td>Description</td>
<td>Any other information about the physical interface controller.</td>
</tr>
<tr>
<td>Modify</td>
<td>To edit the name or description of the physical interface controller, click this button and in the Physical Interface Controller dialog enter your edits and click OK.</td>
</tr>
<tr>
<td>New</td>
<td>To enter a record for a new associated physical interface controller, click this button and in the Physical Interface Controller dialog, enter its enterprise name and click OK.</td>
</tr>
</tbody>
</table>
The system assigns an ID to the controller when you save it to the database. The NIC can represent multiple physical devices. The limit is different for different client types. Refer to the Pre-installation Planning Guide for Cisco Unified ICM Enterprise and Hosted for more information.

<table>
<thead>
<tr>
<th>Field/Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td>Deletes the selected physical interface controller.</td>
</tr>
</tbody>
</table>

Routing Client Tab

The Routing Client tab allows you to view (and define or edit, if you have maintenance access) the properties of the selected routing client. The Routing client is the entity that sends routing requests to the system software.

Table 6: Routing Client Tab Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (required)</td>
<td>The enterprise name of the routing client associated with the NIC. You can have more than one routing client associated with a NIC. Typically, each routing client maps to a subsystem within the interexchange carrier network.</td>
</tr>
<tr>
<td>Timeout threshold (required)</td>
<td>The maximum time, in milliseconds, that the routing client can wait for a response to a routing request. The NIC sends a default response slightly before this threshold.</td>
</tr>
<tr>
<td>Late threshold (required)</td>
<td>A threshold value, in milliseconds, for classifying responses as late. Any response that exceeds this threshold is considered late even if it does not exceed the Timeout Threshold.</td>
</tr>
<tr>
<td>Timeout limit (required)</td>
<td>The maximum time, in seconds, for which the routing client waits for a response. This is the maximum time the routing client will tolerate consecutive response timeouts before it stops sending requests to the system software. For more information, see Chapter 2, &quot;How Routing Works (page 11).&quot;</td>
</tr>
<tr>
<td>Default call type</td>
<td>An enterprise name for the call type. Initially, you can leave this field blank. For information on this field, refer to the Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise &amp; Hosted.</td>
</tr>
<tr>
<td>Configuration parameters</td>
<td>A string containing any initialization parameters that must be passed to the routing client. For a public network, this might include the subsystem number. A null value indicates no configuration parameters are provided.</td>
</tr>
<tr>
<td>Use DN/Label map</td>
<td>Indicates whether the Dialed Number (DN) Label table is used to determine which labels are valid for each dialed number. If not, all labels for the routing client are valid for all dialed number.</td>
</tr>
<tr>
<td>Client type (required)</td>
<td>The type of routing client that ultimately routes the call on the requesting Unified ICM system. This field is enabled only for the routing client associated with an INCRP NIC. In all other cases, it is the same as the logical interface controller's client type. See also &quot;Sprint Routing Clients (page 72)&quot; and &quot;CRSP Routing Clients (page 72).&quot;</td>
</tr>
</tbody>
</table>
# Chapter 5: Configuring Routing Clients

## Configuring a Network Interface Controller (NIC)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Description</strong></td>
<td>Additional information about the routing client.</td>
</tr>
<tr>
<td><strong>Network routing client</strong></td>
<td>A name used to associate routing clients across instances.</td>
</tr>
<tr>
<td></td>
<td>The same string value for the routing client on the NAM and the corresponding routing client on the CICM (applies only for a network ICM). For information on the Network routing client field, refer to the <em>Multiple-NAM Setup and Configuration Guide for Cisco Unified ICM Hosted</em>.</td>
</tr>
<tr>
<td><strong>Default Media Routing Domain</strong></td>
<td>(selection list) The media routing domain associated with the routing client.</td>
</tr>
</tbody>
</table>

### How to Modify a NIC and or Its Routing Client(s)

To modify a NIC and or its routing client(s), follow these steps:

**Step 1**
Follow the preceding steps for viewing a NIC (See the "How to View a NIC and Its Routing Client(s) (page 72)" section.

The selected NIC's configuration information displays in the fields on the right.

**Step 2**
Edit the configuration information. (For field descriptions, see the "NIC Explorer Tab Descriptions (page 72)" section.)

You can modify all fields in the logical controller, physical controller, and router client tabs that are not greyed out.

When you make a modification, the **Changed** icon appears next to the edited item (NIC or routing client) in the tree list box.

**Step 3**
Click **Save**.

The modified data in the Unified ICM database is saved and the **Changed** icon is removed from the display in the tree list box.

### How to Define a NIC

To define a NIC, follow these steps:

**Step 1**
From the **Configuration Manager** menu, select **Tools > Explorer Tools > NIC Explorer**. The NIC Explorer window appears.

**Step 2**
In the **Select filter** data box, click **Retrieve**. This enables the **Add NIC** button.
Step 3
Click Add NIC. A new NIC and its routing client display in the tree list box. Next to each is a To Be Inserted icon.

Figure 25: To be inserted Icon

On the right of the tree list box, tabbed fields also display for the new NIC's and routing client's configuration information.

Step 4
Fill in the tabbed fields. (For field descriptions, see the "NIC Explorer Tab Descriptions (page 72)" section.)

Step 5
If desired, set security settings on the records. (See the "How to View or Apply Security Settings (page 31)" section.)

Step 6
Click Save. The newly defined NIC is saved in the database and the To Be Inserted icon is removed from the tree list box.

How to Define a Routing Client

To define a routing client, follow these steps:

Step 1
Follow the steps for viewing a NIC. (See the "How to View a NIC and Its Routing Client(s) (page 72)" section). The selected NIC's configuration information displays in the fields on the right.

Step 2
In the tree list box, select the NIC to which you want to add a routing client. This enables the Add Routing Client button.

Step 3
Click Add Routing Client. A new routing client icon appears under the selected NIC in the tree list box and a new routing client tab appears in the window on the right.

Step 4
Enter the needed routing client configuration information in the fields on the right. (For field descriptions, see the "Routing Client Tab Descriptions (page 74)" table.)

Step 5
If desired, set security settings on the records. (See the "How to View or Apply Security Settings (page 65)" section.)

Step 6
Click Save.

Sprint Routing Clients

If you specify Sprint as the type of routing client, the NIC Explorer automatically generates some additional records:

• An announcement named NPA_Blocked_Recording (if it does not already exist).
CRSP Routing Clients

CRSP. If you specify CRSP as the type of routing client, two labels are automatically created by the NIC Explorer and are associated with the new routing client:

- “ringForever” with a label type of 3 (ring)
- “busyForever” with a label type of 2 (busy)

When a CRSP routing client record is deleted, the preceding labels associated with the routing client are also deleted.

How to Delete a NIC

Follow these steps to delete a NIC:

**Step 1**
Follow the steps for viewing a NIC. (See the "How to View a NIC and Its Routing Client(s) (page 72)" section.)

The selected NIC’s configuration information displays in the fields on the right.

**Step 2**
In the tree list box, select the NIC whose records you want to delete.

**Step 3**
Click **Delete**. This places a **Marked for Deletion** icon next to the NIC in the tree list box. This also toggles the **Delete** button to **Undelete**.

To undelete a NIC marked for deletion, select it in the tree list box and click **Undelete**.

**Step 4**
Click **Save**.

This deletes from the database the NIC marked for deletion and removes it from the tree list box. Once you do this, you cannot undelete the NIC.
Configuring Dialed Number/Script Selectors

After you have set up a routing client, you need to define the dialed number/script selectors serviced by it. A dialed number/script selector can represent an actual number dialed by a caller or any string passed by a routing client to indicate the number dialed.

The Configuration Manager's Dialed Number/Script Selector List tool allows you to list the dialed number/script selectors currently defined in the Unified ICM database, to define new ones, and to view, edit, or delete the records of existing ones. The following instructions show you how to configure individual dialed number/script selectors. For configuring multiple dialed number/script selectors at a time, see Chapter 4, "Configuring Multiple Records at a Time (page 85)."

Dialed Number/Script Selector List Tab Descriptions

How to View, Define, Delete, or Modify Dialed Number/Script Selectors

**Note:** The "Configuring Dialed Numbers on the Child Central Controller (page 79)" section contains an example of how to configure dialed numbers on a child deployment, which is documented in the *Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX*.

Follow the steps below, to view, define, delete, or modify dialed number/script selectors:

**Step 1**
From within the Configuration Manager menu, select Tools > List Tools > Dialed Number/Script Selector List. The Dialed Number/Script Selector List window appears.

**Step 2**
In the Select filter data area, select the Routing client and Customer associated with the dialed number/script selector.

**Note:** Once you have saved a Dialed Number record to the Unified ICM database, you cannot update the Routing Client field.

If you are viewing or modifying a previously created record and you want to limit the number of records retrieved from the database, also select one of the optional filters.

**Step 3**
Click Retrieve. This enables the Add button and displays a list of the retrieved dialed number/script selectors.

The properties of the dialed number/script selector selected in the Dialed Number/Script Selector list box on the left side of the window are displayed in the property tabs on the right side of the window:

The following properties are displayed:

- The Attributes tab allows you to view and (if you have maintenance access) to define, edit, or delete the attributes of the selected dialed number/script selector. Attributes with an asterisk
are required. Table "Dialed Number/Script Selector Attributes Tab Descriptions" (page 80) describes these attributes.

- The Dialed Number Label tab allows you to map labels (in addition to a default label) to the selected dialed number/script selector. The "Dialed Number Label Tab Descriptions (page 80)" table describes the fields and buttons on this tab.

**Step 4** This step depends on what you want to do:

- To add a new dialed number/script selector, click **Add** and enter the appropriate values in the tabbed property fields on the right side of the window.

- To delete a dialed number/script selector, select that number in the **Dialed Number/Script Selector** list box and click **Delete**.

- To edit a dialed number/script selector, select that number in the **Dialed Number/Script Selector** list box and edit the appropriate values in the tabbed property fields on the right side of the window.

**Step 5** Click **Save** to enter any edits into the database.

The dialog closes, and for a new dialed number/script selector, the Unified ICM database manager automatically generates a unique Dialed Number ID for the routing client.

---

**Configuring Dialed Numbers on the Child Central Controller**

Access the Configuration Manager on the Child Administration & Data Server to configure dialed numbers.

**How to Configure Dialed Numbers on the Child Central Controller**

Use the Configuration Manager Dialed Number/Script Selector List Tool to configure dialed numbers on the Child Central Controller.

**Step 1** Start the **Dialed Number/Script Selector List Tool**.

**Step 2** On the Main window of the Dialed Number/Script Selector List Tool, click **Retrieve**.

**Step 3** Click **Add**.

The Dialed Number Attributes tab appears.

**Step 4** Select **IPCC_RC** as the Routing Client.

**Step 5** Select **Cisco_Voice** for the Media Routing Domain.

**Step 6** Set the Dialed Number String/Script Selector to **2500** (the route point set up on the Unified CM).
**Step 7** Set IPCC_RC_2500 as the Name, then select bh03 as the Customer setting.

**Step 8** Check **Permit Application Routing** on the route points controlled by the Parent (the Post route points and the Translation route points).

This provides the link between the Parent and the Child. It gives the Parent visibility to the Dialed Number so it is able to handle it.

**Step 9** Click **Save**.

The dialed number appears in the tree list.

**Step 10** Repeat this to add two more dialed numbers (one for each skill group).

When complete, you have the following DNs:

- 2500
  - Connects to all of the skill groups.
  - Named IPCC_RC_2500.
- 2501
  - Connects to SG01.
  - Named IPCC_RC_2501.
- 2502
  - Connects to SG02.
  - Named IPCC_RC_2502.

**Step 11** Click **Save**, then **Close** to exit the Skill Group Explorer Tool.

---

**Dialed Number/Script Selector List Tab Descriptions**

The following tables describe the tabbed property fields and buttons that configure a dialed number record.

**Attributes Tab**

Allows you to view and (if you have maintenance access) to define, edit, or delete the attributes of the dialed number/script selector.

Attributes with an asterisk are required.
### Table 7: Dialed Number/Script Selector Attributes Tab Descriptions

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Routing Client (required)</td>
<td>(selection list) The enterprise name of the routing client associated with this dialed number/script selector. Once you select a routing client and save to the database, this field becomes read only.</td>
</tr>
<tr>
<td>Dialed number/script selector string (required)</td>
<td>The string value by which the routing client identifies this dialed number/script selector. This must be the value the routing client passes to the system software for calls to this number. For example: 8005551212.</td>
</tr>
<tr>
<td>Name (required)</td>
<td>The enterprise name for the dialed number/script selector. This name must be unique among all dialed number/script selectors in the system.</td>
</tr>
<tr>
<td>Media routing domain (required)</td>
<td>(selection list) The media routing domain associated with the selected dialed number/script selector.</td>
</tr>
<tr>
<td>Customer</td>
<td>(optional) (selection list) The customer associated with the dialed number/script selector.</td>
</tr>
<tr>
<td>Default label</td>
<td>(optional) (selection list) The name of the default label for this dialed number/script selector. The label must have been previously defined for it to be in the selection list. Use the Configuration Manager's Label List tool to define labels. If the system software fails to determine a target for the call within the routing client’s time-out threshold, then the default label for the dialed number/script selector is used.</td>
</tr>
<tr>
<td>Description</td>
<td>(optional) Additional description for the dialed number/script selector.</td>
</tr>
<tr>
<td>Permit Application Routing</td>
<td>Check this to allow Application Routing. Indicates if remote routing is permitted on this dialed number's script selector.</td>
</tr>
<tr>
<td>Reserved by IVR</td>
<td>Enabled when a Type 9 is selected in the Network VRU tab</td>
</tr>
</tbody>
</table>

### Dialed Number Mapping Tab

Allows you to view the call types that are mapped to the selected dialed number/script selector and to add, edit, or remove call-type mappings.

A call type is a classification for incoming calls. The call type determines which routing script is executed to find a destination for the call. A call type maps to specific combinations of dialed number (DN), calling line ID (CLID), and caller-entered digits (CED).

You can create as many different mappings for each call type as you want.

### Table 8: Dialed Number Mapping Tab Descriptions

<table>
<thead>
<tr>
<th>Column/ button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLID/App String 1</td>
<td>The string value by which the routing client identifies the Calling Line ID.</td>
</tr>
<tr>
<td>CED/AppString 2</td>
<td>The string value by which the routing client identifies the Caller Entered Digits.</td>
</tr>
<tr>
<td>Call Type</td>
<td>Name of the call type to map to the selected dialed number/script selector.</td>
</tr>
</tbody>
</table>
Table 9: Dialed Number Label Tab Descriptions

<table>
<thead>
<tr>
<th>Column/ Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This list contains all the Labels currently assigned to the selected dialed number/script selector.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the label.</td>
</tr>
<tr>
<td>Add</td>
<td>To assign a label to the dialed number/script selector selected in the Dialed Number/Script Selector list box, click <strong>Add</strong>. Then in the Add Label dialog, select a label name and click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Column/Button</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Note:</td>
<td>For labels to appear in this dialog, they must have been previously defined for the selected dialed number/script selector routing client. Use the Label List tool to define labels.</td>
</tr>
<tr>
<td>Remove</td>
<td>To remove a label from the dialed number/list selector selected in the Dialed Number/Script Selector list box, select the label name and click Remove.</td>
</tr>
</tbody>
</table>
Chapter 5: Configuring Routing Clients

Configuring Dialed Number/Script Selectors
Chapter 6

Configuring Peripherals and Trunk Groups

This chapter describes how to configure peripherals and the trunk groups associated with them.

It includes:

• An introduction to the Peripheral Subsystem

• Instructions on how to view, define, delete, or modify:
  – Peripheral Gateways
  – Peripherals
  – Network Trunk Groups
  – Trunk Groups
  – Trunks

Note: See Appendix A, "Peripheral Terminology (page 225)," for more details.

This chapter contains the following topics:

• The Peripheral Subsystem, page 86
• Peripheral Gateways (PGs), page 86
• Configuring a PG, page 87
• Configuring Trunk Groups and Trunks, page 106
The Peripheral Subsystem

A peripheral is a switch, such as an ACD, PBX, VRU, or Unified CM. Calls arrive at the peripheral through trunks that are organized into trunk groups. The system software monitors activity at each peripheral and can route calls to targets at each peripheral.

The logical interface controller and physical interface controller represent the Peripheral Gateway (PG) through which the peripheral communicates with the system.

To view the elements in a peripheral subsystem, see the following figure.

*Figure 27: Peripheral Subsystem*

The routing client figures into this subsystem only if the peripheral acts as a routing client (that is, it sends routing requests to the system software). For information on defining Routing Clients, see the "Configuring Routing Clients (page 69)" section.

Peripheral Gateways (PGs)

Each peripheral communicates with the system software through a Peripheral Gateway, called a PG. The PG is a computer that communicates directly with the ACD, PBX, VRU, or Unified CM at a contact center, monitoring status information from the peripheral and sending it to the Central Controller. If the peripheral acts as a routing client, the PG sends routing requests to the system software.

The PG can be a single simplex computer or a pair of duplexed computers. A single PG can service more than one peripheral; however, each peripheral uses one, and only one, PG.

*Note:* Although a PG can consist of a pair of duplexed computers, only one of them is active at a time, so that the system software sees it as a single, logical and physical, PG.
Configuring a PG

Use the PG Explorer to view, define, modify, or delete peripheral gateway records.

The PG Explorer generates and maintains PG records for a logical interface controller, a physical interface controller, associated peripherals, and, if appropriate, an associated routing client.

**Note:** If you are configuring a PG for a duplexed pair, you only need to define the information once.

The following figure shows the records generated by the PG Explorer.

*Figure 28: Records generated by PG Explorer*

![Diagram showing records generated by PG Explorer]

How to View PG Records

To view PG records, follow these steps:

**Step 1** From the Configuration Manager menu, select **Tools > Explorer Tools > PG Explorer**. The PG Explorer window appears.

**Step 2** In the **Select filter data** box, select the filters you want.

**Step 3** Click **Retrieve**. The name(s) of the retrieved PG(s) appear in the tree list box.

**Step 4** In the tree list box, select the PG whose records you want to view. The selected PG's configuration information displays in the tabbed fields on the right.

**Step 5** To view a peripheral's record: in the tree list box, expand the tree branch for the selected PG, and select the PG's peripheral icon.
Configuring a PG

See Also

The peripheral configuration information displays in the window on the right. For field descriptions, see the “PG Explorer Tab Descriptions (page 87)” section.

PG Explorer Tab Descriptions

The following tables describe the tabbed property fields and buttons that configure a PG. Use these fields to define and update PGs and their associated peripherals.

Logical Controller Tab

Use the Logical Controller tab to view, define, and update PG definitions. In the Unified ICM database, a PG is identified by its logical controller.

Table 10: Logical Controller Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Logical Controller ID (required) | A unique identifier used to reference the PG's Logical Interface Controller table.  
This is a read-only field. When you create a new PG, the system places UNASSIGNED in this field and automatically creates an ID when you save your edits. |
| Physical Controller ID (required) | A unique identifier for the PG's physical controller.  
This is a read-only field. When you create a new PG, the system places UNASSIGNED in this field and automatically creates an ID when you save your edits. |
| Name (required)              | An enterprise name for the PG. This name must be unique for all PGs in the enterprise.  
An enterprise name:  
• Is a character-string name commonly used to identify an object in the Unified ICM database.  
• Must be unique among all objects of a specific type. For example, each service must have an enterprise name that is unique among all services.  
• Can be up to 32 characters. The valid characters are upper-case and lower-case letters, digits, periods (.) and underlines (_). The first character of the name must be a letter or digit.  

Note: This name is used in composite names which are limited to a 32 character length, i.e., an agent enterprise name. Therefore, keep the name short. |
| Client type (required)       | (selection list) The type of client that the PG services. |
When defining a new PG, select one from the pop-up selection box.

Selecting a type of peripheral automatically places that type's default values in the associated peripheral's Client type, Peripheral service level type, Service level type, and Service level threshold fields.

**Note:**

- Once a client type is selected and saved in the database, the selection box options change and you are limited on how you can change that type. If the client type is PG Generic, then you may be able to change that type from the Peripheral tab. However, if the peripheral is online and agents are logged onto it, then the agents will be automatically logged off when the peripheral’s client type is changed.

- Previously configured PG types used in earlier releases that are no longer supported, such as ACP1000, will display the following error message when the PG is selected: "Client Type 'ACP1000' is no longer supported. This PG should be deleted."

### Configuration parameters

A string containing information, such as logon information, specific to the PG.

For example: `-rtuser UserName -rtpswd Password`

### Description

Additional information about the PG.

### Physical controller description

Information about the physical controller.

### Primary CTI address

Address for CTI server as `<IP>:<port>` in either dotted numeric or name format. If a CTI server is installed at the PG, then enter its address. This address is needed if an agent is connected through a CTI server rather than through a peripheral.

### Secondary CTI address

Address for CTI server as `<IP>:<port>` in either dotted numeric or name format. The secondary CTI address is needed if a CTI server is installed at the PG and the Unified ICM system is duplexed.

**Note:** If you use a simplex system, fill in both the addresses. Otherwise the CeM arm connection will not be established.

### Reporting interval

The system software stores historical information in either fifteen-minute or half-hour summaries (but not both), based on the reporting interval option set. The CallRouter sends these records to the Logger, which in turn writes them to the Central Database.

Select the **15 Minute** or **30 Minute** reporting interval option (default is 30 Minute).

**Note:** Be aware that the 15 Minute interval requires a larger amount of space than the 30 Minute interval.

Interval data is populated in these tables:
### Field

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Agent_Interval</td>
<td></td>
</tr>
<tr>
<td>• Agent_Skill_Group_Interval</td>
<td></td>
</tr>
<tr>
<td>• Peripheral_Interval</td>
<td></td>
</tr>
<tr>
<td>• Service_Interval</td>
<td></td>
</tr>
<tr>
<td>• Skill_Group_Interval</td>
<td></td>
</tr>
<tr>
<td>• Call_Type_Interval</td>
<td></td>
</tr>
<tr>
<td>• Call_Type_SG_Interval</td>
<td></td>
</tr>
<tr>
<td>• Campaign_Query_Rule_Interval</td>
<td></td>
</tr>
</tbody>
</table>

### Time Source

The time source that the PG uses to copy the historical interval data (15 or 30 minute) and send to the CallRouter. Any change made to the time source requires simultaneous shutdown (PG services to be stopped and restarted simultaneously) of both PG sides.

Two time source options are available:

- **Use Central Controller Time.** The PG uses the Central Controller CallRouter time source to obtain the historical interval (15 or 30 Minute) data and send to the CallRouter (default time source when adding or upgrading a PG).

- **Use ACD Time.** The PG uses the corresponding ACD time source to obtain only the 30 minute historical interval data and send to the CallRouter. (15 minute historical data is not supported for PG’s that use the ACD time source.)

**Note:** If the Use ACD Time option is enabled, the CallRouter-generated Call Type and Call Type Skill Group data will not align with the Peripheral-generated Skill Group data.

This option is only available for the following client types for the defined PG:

- Definity G3
- Aspect
- Rockwell
- Rockwell Spectrum
- IPCC Enterprise Gateway
- ACMI
### Peripheral Tab

A peripheral is a switch, such as an ACD, PBX, or IVR, that receives calls that have been routed by the system software. Use the Peripheral tab and its associated tabs to view, define, and update the peripherals associated with a PG.

#### Table 11: Peripheral Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peripheral ID (required)</td>
<td>A unique identifier for the peripheral. This is a read-only field. When you create a new PG, the system places UNASSIGNED in this field and automatically creates an ID when you save your edits.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> If you change the Agent ID (Peripheral ID), you must cycle the PG in order to populate the new agent ID and information in the CTI OS Supervisor Desktop.</td>
</tr>
<tr>
<td>Name (required)</td>
<td>An enterprise name for this peripheral. The name must be unique among all peripherals in the enterprise.</td>
</tr>
<tr>
<td>Peripheral name (required)</td>
<td>The name of the peripheral as it is known at the local site. Unlike the Enterprise Name field, the value of this field does not have to be unique. For example, at each site you might label the peripherals Switch1, Switch2, and so forth.</td>
</tr>
<tr>
<td>Client type (required)</td>
<td>The type of peripheral. The value for this field comes from the Logical Controller Client Type field.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Once a client type is selected and saved in the database, the selection box options change and you are limited on how you can change that type. If the client type is PG Generic, then you may be able to change that type from the Peripheral tab. However, if the peripheral is online and agents are logged onto it, then the agents will be automatically logged off when the peripheral's client type is changed.</td>
</tr>
<tr>
<td>Location</td>
<td>The peripheral's location; for example: the name of a city, building, or department.</td>
</tr>
<tr>
<td>Abandoned call wait time (required)</td>
<td>Minimum time in seconds an incoming call must be queued before being considered an abandoned call if the caller hangs up.</td>
</tr>
<tr>
<td>Configuration parameters</td>
<td>A string containing any parameters that must be sent to the device to initialize it. In most cases, leave this string blank.</td>
</tr>
<tr>
<td>Call control variable map</td>
<td>A string that describes the mappings of the peripheral's call control variables to the system software's call control variables.</td>
</tr>
<tr>
<td>Default desk settings</td>
<td>(selection list) Default desk settings for agents associated with the peripheral. If NONE is the only option in the selection list, you need to create desk settings. To create desk settings, use the Configuration Manager's Agent Desk Settings List tool.</td>
</tr>
</tbody>
</table>
### Peripheral service level type (required)

The default type of service level calculation to be performed by the peripheral for its associated services.

Specify one of the following:

- If the peripheral type is Aspect, choose the type of calculation to be performed by default. You can override the default for each individual service.
- If the peripheral type is not Aspect, choose **Calculated by Call Center**.

### Agent Phone Line Control (required)

Indicates whether this agent peripheral supports multi-line control for all agents with more than one line configured on the phone.

Specify one of the following agent phone line control options:

- **Single Line**: Enables single line monitoring and reporting (default).
- **All Lines**: Enables multi-line monitoring and reporting.

### Non ACD Line Impact (required)

Indicates how many non-ACD calls the agent initiated on one of the non-ACD lines. (This field is only populated when the **All Lines** option is enabled.)

Specify one of the following non ACD line impact options:

- **Available Agent Goes Not Ready**: Agent state is set to NOT READY with a system reason code when agent answers or places a call on a secondary line while in the AVAILABLE or NOT READY state.
- **Available Agent Stays Available**: Agent state is unchanged when agent is on a call on a secondary line.

### Description

Additional information about the peripheral.

### Enable post routing

Checked, indicates post routing is enabled. When this is enabled, the Routing Client tab is also enabled.

If you check **Enable post routing** in the Peripheral tab, also enter the properties in the Routing Client tab.

**Note**: If an existing PG does not have post-routing enabled and its type supports it, you can enable it. However, if an existing PG has post-routing enabled, you cannot disable it.

### Peripheral auto configured

Checked, indicates peripheral is auto configured.

---

**Advanced Tab**

The Advanced tab allows you to view (and define or edit, if you have maintenance access) the advanced properties of the selected peripheral.
### Table 12: Advanced Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Available holdoff delay (required)** | The number of seconds to wait after the end of a call before recording the agent as available. The value you enter here is the default for all skill groups associated with the peripheral. You can change the value for individual skill groups. Specify one of the following:  
  - For a DMS-100, this is the default Variable WrapUp time for ACD DN.  
  - For all other peripheral types, set this field to 0. |
| **Default route**              | The default route associated with this peripheral.                                                                                                                                                            |
| **Answered short calls threshold** | The maximum length, in seconds, for a short call to the peripheral. Any calls with a duration below the threshold are considered short. You might then choose to factor out short calls from handle times you calculate. |
| **Network VRU**                | The type of network VRU. If the peripheral is a VRU, that is, used as a network VRU, select the name of the network VRU from the drop-down list.                                                                    |
|                               | **Agent auto-configuration**                                                                                                                                                                                 |
|                               | Specifies whether agent auto-configuration is enabled for the peripheral.                                                                                                                                    |
|                               | **Note:** Agent Reporting implies Auto Configuration. Agent Reporting without auto-configuration is NOT supported. Unified ICM does not support Agent Reporting on manually configured agents with auto-configuration off. |
|                               | **Internal IPTA only**                                                                                                                                                                                      |
|                               | Specifies whether the peripheral belongs to internal IPTA.                                                                                                                                                  |

### Skill Group Mask Tab

This tab allows you to view (and define or edit, if you have maintenance access) the default number of sub-skill groups associated with the selected peripheral.

**Note:**

- **Important!** Sub-skill groups were supported in earlier releases, but are currently only supported for Avaya PG, Symposium PG, IPCC PG, Spectrum PG, and NEC PG TDM peripherals. Sub-skill groups are also not supported for non-voice skill groups. That is, you cannot create sub-skill groups for these media classes: single-session chat, multi-session chat, blended collaboration, and email.

- For some peripherals (Definity ECS EAS, and Rockwell Spectrum), the Configuration Manager can automatically create subgroups (primary, secondary, and so on) for each skill group.
Subskill Group Check Boxes

Note: These check boxes are only enabled for Avaya PG, Symposium PG, IPCC PG, Spectrum PG, and NEC PG TDM peripherals.

The maximum number of subgroups that may be created depends on the Peripheral's client type, and may be none. Where subgroups are available, a default selection has been made. You may change this default, either to none or any number up to the maximum number allowed for this client type.

If you later edit the subgroup selection, removing any previously used subgroups may cause loss of reporting information and must be done carefully. Changes done here will be reflected in all Skill Group entries that currently exist for this Peripheral, which do not explicitly override the settings in the Peripheral.

Check a box for each sub-skill group for each non-enterprise skill group you want to be associated by default with the peripheral. For each box you check, a skill group record is created in the database if the primary skill group uses the peripheral's default.

The number of sub-skill groups used by a primary skill group is specified in the Subgroup Mask tab of the Skill Group Explorer. There, you can add more sub-skill groups than are defined for the peripheral if the selected skill group requires additional ones.

Note: The Subskill Group check boxes are dimmed for enterprise skill groups.

Routing Client Tab

A routing client represents an entity that sends routing requests to the system software through a logical interface controller. Use the Routing Client tab to view, define, or update a PG's routing clients.

Table 13: Routing Client Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (required)</td>
<td>An enterprise name for this routing client. The name must be unique among all routing clients in the enterprise.</td>
</tr>
<tr>
<td>Timeout threshold (required)</td>
<td>The maximum time, in milliseconds, the routing client can wait for a response to a routing request. The NIC sends a default response slightly before this threshold.</td>
</tr>
<tr>
<td>Late threshold (required)</td>
<td>The threshold value, in milliseconds, for classifying responses as late. Any response that exceeds this threshold is considered late even if it does not exceed the TimeoutThreshold.</td>
</tr>
<tr>
<td>Timeout limit (required)</td>
<td>The number of seconds to wait for routing responses before the routing client terminates communication with the system software. When a response from the CallRouter exceeds the time-out threshold, then the routing client starts a timer. If the timer reaches the specified time-out limit before the routing client receives any responses from the CallRouter, then the routing client...</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Default MR domain ID (required)</td>
<td>(selection list) The media routing domain associated with the routing client.</td>
</tr>
<tr>
<td>Default call type</td>
<td>The call type to be used for any route request that does not match a defined call type mapping. The drop-down list contains all configured call types. The system software uses the default call type for any routing request from the routing client that does not otherwise map to a call type. If you do not define a default call type for the routing client, the system software uses a general default call type.</td>
</tr>
<tr>
<td>Configuration parameters</td>
<td>An optional string containing the configuration parameters to be used by the controller to initialize the routing client. For a public network client, this field normally specifies the subsystem for the NIC to use.</td>
</tr>
<tr>
<td>Use DN/Label map</td>
<td>Indicates that the Dialed Number (DN) Label table is used to determine which labels are valid for each dialed number (if checked), or that all labels for the routing client are valid for all dialed numbers (if not checked). Normally, leave this field unchecked.</td>
</tr>
<tr>
<td>Client type</td>
<td>Indicates the type of client. For an ICRP NIC, this is the type of the ultimate client on the Network Unified ICM. In all other cases, it is the same as the PG's Client Type.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the routing client.</td>
</tr>
<tr>
<td>Network routing client</td>
<td>A name used to associate routing clients across instances.</td>
</tr>
<tr>
<td>Network transfer preferred</td>
<td>Checked, indicates network transfer is preferred. When the target of a call transfer is reachable by both a label defined for the requesting routing client and by another label defined for the network routing client that pre-routed the call, this option indicates which choice is preferred.</td>
</tr>
</tbody>
</table>

Peripheral Monitor Tab

A peripheral monitor is an entity that you want to monitor at the peripheral. Not all peripherals require peripheral monitor records.

You must configure Peripheral Monitor records for:

- Extension numbers on a Definity switch
- Pilots and agents on an Alcatel 4400
- Monitored entities on a Siemens ACD
- Primary ACD DNs and Secondary DNs on a DMS-100
Table 14: Peripheral Monitor Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current peripheral monitor entries</td>
<td>Lists the current peripheral monitor data (Type, Extension, and Configuration Parameter) entered for the selected PG.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> The Peripheral monitor records are initially sorted by PeripheralMonitorID (the default sort order). Click any column header to reverse the sort order (ascending-to-descending or descending-to-ascending). The indicator to the right always points to the lowest item in the current list order.</td>
</tr>
<tr>
<td>Type (required)</td>
<td>The type of entity to be monitored: ACD Directory Number (ACD DN), Meridian Position, Queue, Route Control Group (RCG), Routing Device, Station, Symposium CDN, Trunk, Vector Directory Number (VDN), or Virtual Routing Device.</td>
</tr>
<tr>
<td></td>
<td><strong>Type of entity</strong></td>
</tr>
<tr>
<td></td>
<td>• For a DMS-100, choose ACD DN for each entry.</td>
</tr>
<tr>
<td></td>
<td>• For an Alcatel 4400, choose:</td>
</tr>
<tr>
<td></td>
<td>– ACD DN for Non CSTA Routing Pilots or an agent</td>
</tr>
<tr>
<td></td>
<td>– Routing Device for CSTA Routing Pilots</td>
</tr>
<tr>
<td></td>
<td>– Virtual Routing Device for all virtual devices to be used for translation or post routing</td>
</tr>
<tr>
<td>Extension</td>
<td>Extensions are</td>
</tr>
<tr>
<td></td>
<td>• For an Alcatel 4400, the DN for a pilot or the agent number for an agent.</td>
</tr>
<tr>
<td></td>
<td>• For an Avaya DEFINITY, if there is a single extension number, enter the number here (for example, 6002) and do not enter it in the parameter string. If there is more than one number, leave this field blank and enter the numbers as a range in the parameter string.</td>
</tr>
<tr>
<td></td>
<td>• For a DMS-100, the Primary ACD DN, Secondary DN, or a non-digit character.</td>
</tr>
<tr>
<td></td>
<td>• For a Siemens ACD, the extension number to be monitored.</td>
</tr>
<tr>
<td>Configuration Parameters</td>
<td>A parameter string to be passed to the peripheral along with the extension string to start monitoring on the specified extension:</td>
</tr>
<tr>
<td></td>
<td>• For a Definity, if there is more than one extension number, enter them here as a range, for example, 6001-6020. If there is only one extension number, leave the parameter string blank.</td>
</tr>
<tr>
<td></td>
<td>• For a DMS-100, the string can contain the following items:</td>
</tr>
</tbody>
</table>
Field | Description
---|---
|  – <SN n> where n is the CompuCALL session associated with the Primary ACD DN or Secondary DN in the Extension field.
|  – <CDN> indicates that the Primary ACD DN in the Extension field is a CDN.
|  – <DN dn> <ID posID> where dn is an Agent DN and posID is the associated agent position ID.
|  • For Siemens ACDs, this string is optional.

**New**
Click this button to enter new monitor data. Then, select a type from the Type selection list, fill in any other appropriate field information, and press the **Enter** key.

**Delete**
Click this button to delete the selected row item from the list of Current peripheral monitor entries.

**Extension**
Displays the Extension of the selected Current peripheral monitor entries for editing purposes. Click **Save** when you are done editing to save your changes.

**Configuration Parameter**
Displays the Configuration Parameter of the selected Current peripheral monitor entries for editing purposes. Click **Save** when you are done editing to save your changes.

**Type**
Displays the Type of the selected Current peripheral monitor entries for editing purposes. Click **Save** when you are done editing to save your changes.

---

**Default Route Tab**

Use this tab to create a default route for each Media Routing Domain that is associated with a peripheral.

**Table 15: Default Route Tab Descriptions**

<table>
<thead>
<tr>
<th>Field/Button</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Current default route entries** | **Media routing domain**
The media routing domain configured for the selected default route entry. |
| **Route** | The default route configured for the media routing domain of the selected default route entry. |
| **Note:** The default route configured for the media routing domain of the selected default route entry. Click any column header to reverse the sort order (ascending-to-descending or descending-to-ascending). The indicator to the right always points to the lowest item in the current list order. |
| **New** | Click to enter new default route data. Then, enter a media routing domain and a route. |
Configuring a PG

<table>
<thead>
<tr>
<th>Field/Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td>Click to delete the selected row item from the list of current default route entries.</td>
</tr>
<tr>
<td>Media routing domain (required)</td>
<td>Enter the media routing domain when creating a new default route entry.</td>
</tr>
<tr>
<td>Route</td>
<td>Enter the route when creating a new default route entry.</td>
</tr>
</tbody>
</table>

Agent Distribution Tab

Use the Agent Distribution tab to list and view the agent distributions currently defined in the Unified ICM database and (if you have maintenance access) to define new agent distributions, and to edit, or delete existing ones. This data is stored in the database Agent Distribution table.

**Note:** The PG Explorer (and the assigning of agent distribution) is not available on a limited Administration and Data Server.

**Table 16: Agent Distribution Tab Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable agent reporting</td>
<td>Specifies whether agent reporting is enabled for the peripheral. Select this option if you want the peripheral to report agent-level statistics to the system software.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong></td>
</tr>
<tr>
<td></td>
<td>• Agent Reporting implies Auto Configuration. Agent Reporting without auto-configuration is NOT supported. Unified ICM does not support Agent Reporting on manually configured agents with auto-configuration off.</td>
</tr>
<tr>
<td></td>
<td>• If the peripheral's client type is CallManager/SoftACD, then you must select an agent desk setting in the PG Explorer's Peripheral tab before you can enable agent reporting. The peripheral's client type is indicated in the PG Explorer's Peripheral tab.</td>
</tr>
<tr>
<td>Agent event detail</td>
<td>Specifies whether agent event detail reporting is enabled for the peripheral. This checkbox is enabled only if the Enable agent reporting checkbox is selected. Making this selection result in agent reason codes being added to agent reporting.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This checkbox is enabled by default if you are adding a Unified CM PG.</td>
</tr>
<tr>
<td>Agent distribution entries</td>
<td>Lists the agent distributors (Administration Clients or Administration &amp; Data Servers) available for distributing agent report data for the selected peripheral.</td>
</tr>
<tr>
<td>Site name</td>
<td>One or more names of agent distribution sites associated with the selected peripheral.</td>
</tr>
<tr>
<td>Agent real time data</td>
<td>N indicates the agent real time data is not enabled. Y indicates the agent real time data is enabled.</td>
</tr>
<tr>
<td>Agent historical data</td>
<td></td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>N</td>
<td>Indicates the agent historical data is not enabled. Y indicates the agent historical data is enabled.</td>
</tr>
<tr>
<td>Currently selected site</td>
<td>Administration &amp; Data Server site name</td>
</tr>
<tr>
<td></td>
<td>The name of the currently selected site in the agent distribution entries list.</td>
</tr>
<tr>
<td>Agent real time data</td>
<td>If checked, enables the flow of agent real time data from the peripheral to the Administration &amp; Data Server. Unchecked, disables the flow of agent real time data.</td>
</tr>
<tr>
<td>Agent historical data</td>
<td>If checked, enables the flow of agent historical data from the peripheral to the Administration &amp; Data Server. Unchecked, disables the flow of agent historical data.</td>
</tr>
<tr>
<td>New</td>
<td>Click to add a new Administration &amp; Data Server site. This places <em>NEW</em> in the Administration &amp; Data Server site name input box and in the Agent Distribution Entries list. Replace <em>NEW</em> in the Administration &amp; Data Server site name input box with the name you want. Then click the check box if you want to enable it, and click Save.</td>
</tr>
<tr>
<td>Delete</td>
<td>To delete an Administration &amp; Data Server site, select that site's name in the Agent Distribution Entries list and click this button. Then click Save.</td>
</tr>
</tbody>
</table>

**Note:** For information on how to use the AgentCfg command line utility to import agent data, see "Importing Agent Configuration Data from the Peripheral (page 135)" in the "Configuring Skill Targets" section.

Defining PGs and Peripherals

Use the PG Explorer to define a PG and its associated peripherals.

**How to Define a PG**

**Note:** The "Configuring the System Peripheral Gateways (page 100)" section contains an example of how to define a PG on a child deployment, which is documented in the Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX.

To define a PG, perform the following:

**Step 1**
From the Configuration Manager menu, select **Tools > Explorer Tools > PG Explorer.** The PG Explorer window appears.

**Step 2**
In the Select filter data box, click **Retrieve.** This enables the **Add PG** button.

**Step 3**
Click **Add PG.** A new PG appears in the tree list box with a **To Be Inserted** icon.
Configuring a PG

Figure 29: PG to be inserted icon

next to it. Tabbed fields also appear on the right for the new PG's configuration information.

Step 4 Fill in the tabbed fields. (For field descriptions, see the "PG Explorer Tab Descriptions (page 87)" section.

Step 5 If desired, set security settings on the records. (See the "How to View or Apply Security Settings (page 31)" section.)

Step 6 Click Save to save the newly defined PG in the database.

How to Define a Peripheral

Follow the steps for defining a peripheral:

Step 1 Follow the steps for viewing a PG. (See the "How to View PG Records (page 85)" section.)

The selected PG's configuration information appears in the fields on the right. For field descriptions, see the "PG Explorer Tab Descriptions (page 87)" section.

Step 2 In the tree list box, select the PG to which you want to add a peripheral. This enables the Add Peripheral button.

Step 3 Click Add Peripheral. A peripheral is added to the selected PG in the tree list box. Also a new set of tabbed fields appear on the right for the new PG's configuration information.

Step 4 Enter the needed peripheral configuration information in the fields on the right. (For field descriptions, see "Table Peripheral Tab Descriptions (page 91)."

Step 5 If desired, set security settings on the records. (See the "How to View or Apply Security Settings (page 65)" section.)

Step 6 Click Save.

After you have defined a peripheral, you can define the trunks, agents, groups, and services associated with that peripheral.

Configuring the System Peripheral Gateways

On the Administration & Data Server, run the Configuration Manager to add the System Peripheral Gateways.

How to Configure the System PGs

Use the Configuration Manager tools to add and configure the System PGs.
**Step 1**  
Select Start > All Programs > Cisco Unified CCE Tools > Administration Tools > Configuration Manager.

**Step 2**  
Start the PG Explorer Tool, then in the Main window click **Retrieve**.

**Step 3**  
Click **Add PG**.  
This creates both the Peripheral Gateway and the Peripheral.  
a. Enter **IPCC** for the Name.  
b. Select **IPCC System** for the Client Type.  
c. If no desk settings are set, set them now. Click **OK**.  
The Agent Desk Settings List Tool appears.  
d. Click **Add**.  
The Attribute tab appears.  
e. Enter the Name **default**.  
f. Leave all other settings at their defaults and click **Save**.  
g. Close the Desk Settings List Tool.

**Step 4**  
Go back to the PG Explorer Tool.  
a. Select **IPCC-1** as the Peripheral.  
b. On the Peripheral tab, set the Default Desk Settings to **default**.  
c. On the Agent Distribution tab, click **New**.  
d. Set the Administration & Data Server site name to **BELO-5C-Site 1** and leave all other settings at their defaults.  
e. On the Routing Client tab, enter the Name **IPCC_RC** and leave all other settings at their defaults.  
f. Click **Save**.  
The Logical Controller ID (5000) and the Physical Controller ID (5000) are now indicated on the Logical Controller tab.  
g. Reboot the System Peripheral Gateway computers (BELO-5A and BELO-5B).

The Central Controller setup and configuration is now complete. The Peripheral Gateways can now be installed and configured to communicate with the Central Controller.
How to Add the Instance

This task is performed on the Child System Peripheral Gateway computers BELO-5A (PG1A) and BELO-5B (PG1B).

After the reboot, use the Web Setup Tool to add the Instance.

**Step 1** Enter `http://BELO-5B/setup` (or BELO-5A, as applicable) and log in to the Web Setup Tool to add the Instance. The main Web Setup Tool window appears.

**Step 2** Click **Instance Management**, then click **Add**.

The Add Instance dialog appears.

**Step 3** Select **BELO** (the Facility), then **bh03** (the Instance to add).

**Step 4** Click **Save**.

**Step 5** Click **Log Out**.

Modifying a PG or Peripheral

Use the PG Explorer to modify a PG or a peripheral.

How to Modify a PG and Peripheral Records

Follow the steps to modify a PG and peripheral records:

**Step 1** Follow the steps for viewing a PG. (See the "How to View PG Records (page 85)" section.)

The selected PG’s configuration information displays in the fields on the right.

**Step 2** Edit the configuration information. (For field descriptions, see the “PG Explorer Tab Descriptions (page 87)” section.)

**Note:** You cannot modify fields that are greyed out.

**Table 17: Rules for Changing a PG’s Client Type**

<table>
<thead>
<tr>
<th>If the PG Client Type is</th>
<th>Then it can be</th>
</tr>
</thead>
<tbody>
<tr>
<td>Non PG_Generic (ACD or VRU)</td>
<td>Changed to PG_Generic.</td>
</tr>
<tr>
<td>PG_Generic</td>
<td>Changed to VRU or a specific ACD type if and only if all peripherals configured for that PG are of the same type.</td>
</tr>
<tr>
<td>Rockwell r1.3 ACD</td>
<td>Changed to Rockwell Spectrum.</td>
</tr>
</tbody>
</table>
Then it can be switched between EAS and non-EAS mode.

Table 18: Rules for Changing a PG's Peripheral

<table>
<thead>
<tr>
<th>If the PG Client Type is...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>PG_Generic</td>
<td>A VRU peripheral can always be added.</td>
</tr>
<tr>
<td>PG_Generic with only VRU peripherals</td>
<td>Any type of ACD peripheral can be added.</td>
</tr>
<tr>
<td>PG_Generic with at least one ACD peripheral</td>
<td>Any additional ACDs must be of the same type.</td>
</tr>
</tbody>
</table>

When you make a modification, the Changed icon appears next to the selected item (PG or Peripheral) in the tree list box.

**Step 3** Click Save.

The modified data is saved in the Unified ICM database and the Changed icon is removed from the PG or peripheral in the tree list box.

Deleting a PG or a Peripheral

Use the PG Explorer to delete a PG or a peripheral.

How to Delete a PG or a Peripheral

Follow the steps to delete a PG or a peripheral:

**Step 1** Follow the steps for viewing a PG. (See the "How to View PG Records (page 85)" section.)

The selected PG's configuration information displays in the fields on the right.

**Step 2** In the tree list box, select the PG or peripheral whose records you want to delete.

**Note:** If you select a PG, the records for all peripherals associated with it will also be deleted. If you select a peripheral, only its records will be deleted.

**Step 3** Click Delete. This places a Marked for Deletion icon
next to the selected item in the tree list box. This also toggles the Delete button to Undelete.

To undelete an item marked for deletion, select it in the tree list box and click Undelete.

**Step 4**  Click Save.

This deletes from the database the PG or peripheral marked for deletion and removes it from the tree list box. Once you do this, you cannot undelete the deleted item.

### Configuring Agent Targeting Rules

Use the Agent Targeting Rule List tool to configure Agent Targeting Rules.

An Agent Targeting Rule allows you to configure call routing by specifying the agent extension range, instead of configuring device targets and labels for every phone and for every routing client. This simplifies the call routing configuration for the Unified CCE/CCH agent PGs.

Agent Targeting Rules are supported for System PGs, CallManager PGs, and Generic PGs in Unified CCE/CCH deployments (standalone Unified CCE/CCH, Unified CCE/CCH child of a Unified ICM parent, or a CICM Unified CCE/CCH Enterprise in a NAM deployment).

**Note:**

- Agent Targeting Rules are not supported in Unified SCCE deployments.

- In a NAM environment, Agent Targeting Rules can be used on the CICM side in a Cisco Unified Contact Center Hosted (Unified CCH) deployment to target agents. However, if label validation is required on the NAM side, you must either define all the labels that can be generated by the Agent Targeting Rules at the CICM on the NAM side, or you must turn label validation off. The **Validate Returned Labels** checkbox in the ICM Gateway node must be unchecked for calls routed using Agent Targeting Rules to work. Not defining the labels, and turning label validation on, results in calls failing at the NAM even though a response with a valid label was sent from the CICM.

### How to Configure Agent Targeting Rules

You can define one or more rules for a peripheral. However, each rule must cover a different agent extension range for the same routing client. In other words, if there are multiple rules that a routing client can use to target a peripheral, there must be no overlapping extension ranges in those rules.

**Note:** To use Agent Targeting Rules, you must have both the Central Controller and the PGs upgraded to the same version of Unified ICM that supports the Agent Targeting Rules feature.
Step 1
Using the PG Explorer tool, define a PG (page 99) that directly targets an agent. On the Advanced tab, select the Rules Preferred option, which indicates the CallRouter will use the Agent Targeting Rule (if one exists). Save the PG.

Step 2
Using the Agent Targeting Rule List tool, create the rule:

a. Add a name for the rule in the Name field.

b. Select the PG you just defined in the Peripheral field.

c. Select the Rule type:

   • **Agent Extension**: Enter the agent extension prefix. This option directly targets the agent. The agent is identified by an ID, which will display in the PreCall and Connect messages. (The agent's extension is included as the label.)

   • **Substitute Agent Extension**: Enter the agent extension length. When using this type, the label returned will be the combined Agent Extension prefix and the actual agent extension. For example, if the call from Unified CVP goes through the target agent on a CallManager PG, then use this option.

   • **Translation Route**: A translation route is used to move the call. This option allows pre-routing of calls directly to an agent without requiring DID to all agents. Translation routes require the generation of a second label, used to target the agent from the peripheral's local routing client. For example, select a translation route associated with the peripheral and define the extension range.

d. Select the routing client in the Routing client group box by clicking Add (defines where the call comes from).

e. Add the phone extension range in the Extension Ranges group box by clicking Add.

f. Click Save.

When the CallRouter routes a call, it will check if there is a rule for that routing client. The CallRouter decides which rule to use based on routing client, PG, and extension range. When the CallRouter finds a rule, it uses the rule type to decide how to construct a label to send to the routing client.

**Note:** When configuring an Agent Targeting Rule for a Translation Route, if you are using Agent Targeting Rule Type 3 (Translation Route), you must also configure the Translation Route DNIS as dialed numbers associated with the target agent's peripheral routing client in Unified ICM. The dialed numbers must be mapped to the route points that are configured in Unified CM and associated with the JTAPI user. This is necessary to complete the Translation Route Rule.
Configuring Trunk Groups and Trunks

Every peripheral has one or more associated trunk groups, with each trunk group containing one or more physical trunks. Trunk groups map to trunk sets defined by the peripheral.

A peripheral dispatches a call to the appropriate skill target based on the trunk group on which the call arrives and the DNIS value that accompanies it. The peripheral treats all trunks with a particular trunk group the same, but it might treat trunks within another trunk group differently.

Note: The DMS-100 does not have trunk groups, but within the system software you must define one network trunk group and one trunk group for each DMS-100.

When setting up trunk groups and trunks, you must specify:

- Each trunk group that can receive calls
- How many trunks are in each trunk group, or configuration information for each trunk in the group

This section describes how to configure the trunk groups and trunks that will be used by routing clients and peripherals.

Network Trunk Groups, Trunk Groups, and Trunks

Routing clients deliver calls to trunk groups at the peripheral. However, a routing client might group the trunks differently from the way the peripheral groups them. The groups as seen by the routing client are called network trunk groups.

A network trunk group:

- Is a collection of peripheral trunk groups.
- Can map directly to a single trunk group at the peripheral or to multiple trunk groups.
- Can also map to trunk groups at different peripherals, provided that all the peripherals are associated with the same Peripheral Gateway. (Only valid for VRU peripherals.)

How to View a Network Trunk Group, Its Trunk Groups, and Its Trunks

Follow the steps to view a network trunk group, its trunk groups, and its trunks:

**Step 1**

From the Configuration Manager menu, select **Tools Explorer Tools Network Trunk Group Explorer**. The Network Trunk Group Explorer window appears.
Step 2  In the Select filter data box, select the filters you want.

Step 3  Click Retrieve. This enables the Add button and displays a list of the retrieved network trunk group(s) in a tree list box on the left side of the Explorer window.

Step 4  In the tree list box, select the network trunk group whose records you want to view or modify. The selected network trunk group's configuration information displays in the tabbed fields on the right.

Step 5  To view trunk group or trunk data, expand the tree and then select the tree item whose properties you want to view or edit. In the "Example Network Trunk Group Explorer Window (page 107)" figure, Trunk 99 is selected. This trunk belongs to the Boston_PG_1 trunk group, which belongs to the Boston network trunk group.

The property tabs on the right side of the Explorer window display the properties of the item selected in the tree list box. Properties with an asterisk are required. If you have maintenance access, you can define or edit these properties.

Network Trunk Group Tab Descriptions

Allows you to view (and define or edit, if you have maintenance access) the properties of the selected network trunk group.
Table 19: Network Trunk Group Tab Descriptions

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (required)</td>
<td>An enterprise name for the network trunk group. This name must be unique for all network trunk groups in the system.</td>
</tr>
<tr>
<td>Description</td>
<td>(optional) Any other information about the network trunk group.</td>
</tr>
</tbody>
</table>

Trunk Group Tab Descriptions

Allows you to view (and define or edit, if you have maintenance access) the properties of the selected trunk group.

Table 20: Trunk Group Tab Descriptions

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peripheral (required)</td>
<td>(selection list) The enterprise name of the peripheral with which the trunk group is associated.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Once you have saved a trunk group record to the Unified ICM database, you cannot update this field.</td>
</tr>
<tr>
<td>Peripheral number (required)</td>
<td>The number of this trunk group as understood by the peripheral. This value must be unique among all trunk groups connected to the same peripheral, but not throughout the entire system. Once you install the data to the central database, you cannot change this field.</td>
</tr>
<tr>
<td>Peripheral name (required)</td>
<td>The name of this trunk group as understood by the peripheral. This value must be unique among all trunk groups connected to the same peripheral, but not throughout the entire system.</td>
</tr>
<tr>
<td>Name (required)</td>
<td>The enterprise name for the trunk group. This name must be unique among all trunk groups in the entire system. If you click in this field when entering a new trunk group, the system by default creates a name from the peripheral and the peripheral name. For example: Boston_PG.TrunkGroup2 where Boston_PG is the peripheral and TrunkGroup2 is the peripheral name.</td>
</tr>
<tr>
<td>Extension</td>
<td>The description is:</td>
</tr>
<tr>
<td></td>
<td>• If the peripheral is an Avaya DEFINITY ECS, the extension number that the peripheral associates with this trunk group.</td>
</tr>
<tr>
<td></td>
<td>• For all other peripheral types, leave this field blank.</td>
</tr>
<tr>
<td>Trunk count</td>
<td>(selection list) The number of trunks in this trunk group or <strong>Use Trunk Data.</strong></td>
</tr>
<tr>
<td></td>
<td>If <strong>Use Trunk Data</strong> is selected, the system software determines the trunk count dynamically by counting the associated records in the Trunk table.</td>
</tr>
<tr>
<td>Config. Param.</td>
<td>A parameter string that the system software must send to the ACD to configure the trunk group.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Description</td>
<td>A description for the trunk group.</td>
</tr>
</tbody>
</table>

**Trunk Tab Descriptions**

Allows you to view (and define or edit, if you have maintenance access) the properties of the selected trunk.

**Table 21: Trunk Tab Descriptions**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trunk number (required)</td>
<td>The number of this trunk within the trunk group.</td>
</tr>
<tr>
<td>Trunk type (required)</td>
<td>(selection list) The trunk's trunk type: DID/DNIS, Foreign Exchange, Interflow, Local Central Office, PRI, Tie Line, or WATS. The &quot;Trunk Types (page 109)&quot; table lists the types of trunks that the system software supports.</td>
</tr>
<tr>
<td>Circuit provider</td>
<td>The name of the carrier that provides the circuit for this trunk. The provider is either a local phone company or an interexchange carrier.</td>
</tr>
</tbody>
</table>

**Table 22: Trunk Types**

<table>
<thead>
<tr>
<th>Trunk Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local CO</td>
<td>Connects the peripheral directly to the local telephone company's central office (CO).</td>
</tr>
<tr>
<td>Foreign exchange</td>
<td>Connects the peripheral directly to the central office of a non-local central office.</td>
</tr>
<tr>
<td>WATS</td>
<td>Dedicated to Wide Area Telecommunication Service (WATS). This is a special service that allows a peripheral to place or receive calls from specific regions at a discounted price.</td>
</tr>
<tr>
<td>DID/DNIS</td>
<td>Supports Direct Inside Dial (DID) or Dialed Number Identification Service (DNIS). A code to identify the number dialed by the caller accompanies each call. The peripheral can then dispatch the call to a specific target.</td>
</tr>
<tr>
<td>PRI</td>
<td>Supports ISDN Primary Rate Interface (PRI). This mode typically provides 23 channels for voice or data and one channel for signaling information (23B + 1D).</td>
</tr>
<tr>
<td>Tie-line</td>
<td>Connects one peripheral directly with another across a wide area.</td>
</tr>
<tr>
<td>Interflow</td>
<td>Dedicated line that allows one peripheral to off-load calls to another peripheral.</td>
</tr>
</tbody>
</table>

**How to Edit a Network Trunk Group, Its Trunk Groups, and Its Trunks**

Follow the steps to edit a network trunk group, its trunk groups, and its trunks:

**Step 1** From the Configuration Manager menu, select **Tools Explorer Tools Network Trunk Group Explorer**. The Network Trunk Group Explorer window appears.
Step 2  In the **Select filter data** box, select the filters you want.

Step 3  Click **Retrieve**. This displays a list of the retrieved network trunk group(s) in a tree list box on the left side of the Explorer window.

Step 4  In the tree list box, select the item you want to edit. Expand the tree if necessary. This displays the selected item's property tab on the right side of the window.

Step 5  Edit the appropriate properties. For property descriptions, see the "Network Trunk Group Tab Descriptions (page 106)" section.

Step 6  Click **Save**.

---

**How to Define a Network Trunk Group, Its Trunk Groups, and Its Trunks**

Follow the steps to define a network trunk group, its trunk groups, and its trunks:

Step 1  From the Configuration Manager menu, select **Tools Explorer Tools Network Trunk Group**. The Network Trunk Group Explorer window appears.

Step 2  In the **Select filter data** box, select the filters you want.

Step 3  Click **Retrieve**. This displays a list of the retrieved trunk groups and enables the add functionality.

Step 4  This step depends on what you want to do:

a. To add a new network trunk group, click **Add Network Trunk Group**.

b. To add a new trunk group, select the network trunk group to which you want to add a group, and click **Add Network Trunk Group**.

c. To add a new trunk, select the trunk group to which you want to add a trunk, and click **Add Trunk**.

Step 5  Enter the appropriate values in the tabbed property fields on the right side of the window. For property descriptions, see the "Network Trunk Group Tab Descriptions (page 106)" section.

Step 6  Click **Save**.

---

**How to Delete a Network Trunk Group, Its Trunk Groups, and Its Trunks**

Follow the steps to delete a network trunk group, its trunk groups, and its trunks:

Step 1  From the Configuration Manager menu, select **Tools Explorer Tools Network Trunk Group Explorer**. The Network Trunk Group Explorer window appears.

Step 2  In the **Select filter data** box, select the filters you want.
Step 3  Click Retrieve. This displays a list of the retrieved network trunk groups.

Step 4  In the tree list box, select the network trunk group, trunk group, or trunk whose records you want to delete.

Note: If you select a network trunk group, the records for all trunk groups and trunks associated with it will also be deleted. If you select a trunk, only its records will be deleted.

Step 5  Click Delete.

Step 6  This places a Marked for Deletion icon

Figure 33: Marked for deletion icon

next to the selected item in the tree list box. This also toggles the Delete button to Undelete.

To undelete an item marked for deletion, select it in the tree list box and click Undelete.

Step 7  Click Save.

This deletes from the database the item marked for deletion and removes it from the tree list box. Once you do this, you cannot undelete the deleted item.

---

How to Define Multiple Trunks

You can quickly define multiple trunks of the same type for a specific trunk group by using the Multiple button in the Network Trunk Group Explorer window.

Step 1  From within the Network Trunk Group Explorer, select the trunk group to which you want to add trunks. This enables the Multiple button.

Note: You must have an existing trunk from the peripheral defined before you click Multiple.

Step 2  Click Multiple. The Multiple Trunk Creation dialog appears.

Figure 34: Multiple Trunk Creation Dialog
Step 3  Set the First trunk number and the Last trunk number fields so that you define the range of trunks you want.

Step 4  In the Trunk type field, select the trunk type. For a description of trunk types, see the "Trunk Types (page 109)" table.

Step 5  (optional) In the Circuit provider field, enter the name of the carrier that provides the circuit for this trunk.

Step 6  Click Create records. The tree list box will display a list of the numbered trunks beneath the selected trunk group and the Trunk tab on the right side of the window will display the properties of the trunk at the end of the series of numbers.

Step 7  In the Network Trunk Group Explorer window, click Save.

Note: If a trunk number in the range you specified has already been used, that trunk number is selected in the tree list box and a message displays. Before you can save the data, you must edit the trunk number.
Chapter 7

Configuring Skill Targets

This chapter describes how to set up the entities that the system software selects to handle calls at a peripheral.

It includes:

• An introduction to the skill targets subsystem
• Instructions on how to view, define, delete, or modify:
  – Services
  – Skill Groups
  – Agents
  – Persons
  – Agent reporting
  – Enterprise services
  – Enterprise skill groups

This chapter also includes instructions for using the agentcfg.exe utility that allows you to update your Unified ICM database with agent information from a Unified ICM peripheral.

This chapter contains the following topics:

• The Skill Targets Subsystem, page 114
• Services, page 114
• Skill Groups, page 120
• Modifying the Skill Groups Per Agent Limit, page 130
• Persons, page 132
The Skill Targets Subsystem

After you define a peripheral, you must define the skill targets associated with the peripheral. The Figure “Skill Targets” shows the elements in a skill target subsystem.

Figure 35: The Skill Targets Subsystem

Skill targets are the entities that the system software chooses to handle calls at a peripheral: services, skill groups, and agents.

The other members in the skill target subsystem define relationships among skill targets:

- Agents are members of skill groups.
- Skill groups are members of services.
- An enterprise skill group is a collection of skill groups, usually from different peripherals.
- An enterprise service is a collection of services, usually from different peripherals.

The rest of this chapter describes how to define these skill targets and establish the relationships among them.

Services

You must provide information about each service associated with a peripheral. A service is a type of caller need that the peripheral handles; for example, Sales, Support, and Information might all be services.

Use the Service Explorer to configure services and their associated records.
Service Explorer

The following sections show you how to use the Service Explorer to view and configure a service and its associated routes, peripheral targets, and labels.

How to View a Service

To view a service, follow these steps:

**Step 1** In the Configuration Manager menu, select Tools > Explorer Tools > Service Explorer. The Service Explorer window appears.

**Step 2** In the Select filter data box, select the peripheral associated with the service you want to view. You can choose the name from the drop-down list.

*Note:* Once you have saved a service record to the Unified ICM database, you cannot change the peripheral to which it is associated.

**Step 3** Select any other filters you want. **None** in the Optional filter box means all services associated with the selected peripheral will be displayed.

**Step 4** Click Retrieve. This lists in the tree list box the name(s) of the retrieved service(s).

*Note:* A tree object is unassigned if it was made by another configuration tool and was not assigned (mapped) to a parent object; for example, a label might not have been assigned to a peripheral target or a route might not have been assigned to a service, and so on.

**Step 5** In the tree list box, select a service to display its configuration information on the right side of the window.

**Step 6** If the service has a route associated with it, click its icon in the tree list box to display its configuration information. Do the same for a peripheral target associated with the route and a label associated with the peripheral target.

Service Explorer Tab Descriptions

The tables in the following sections describe the fields in the Service Explorer records.

Service Tab

This tab allows you to view (and define or edit, if you have maintenance access) the properties of the selected service.

A service is the type of caller need that a peripheral handles; for example, Sales, Support, and Information.
### Table 23: Service Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media routing domain (required)</td>
<td>(selection list) The media routing domain associated with the service.</td>
</tr>
<tr>
<td>Peripheral number (required)</td>
<td>The number of this service as understood by the selected peripheral. Use the application number, gate number, split number, or skill number. This value must be unique among all services for a peripheral, but need not be unique across peripherals.</td>
</tr>
<tr>
<td>Peripheral name (required)</td>
<td>The local name for the peripheral's service. This value must be unique among all services associated with the peripheral, but need not be unique across peripherals. For example, each peripheral can have a service named Sales.</td>
</tr>
<tr>
<td>Name (required)</td>
<td>The enterprise name of the service. This name must be unique among all the services in the enterprise. If you click in this box after entering the peripheral name, the software automatically creates this name by appending the peripheral name to the selected peripheral. For example: Boston_PG_1.Sales.</td>
</tr>
<tr>
<td>Config param</td>
<td>(optional) A string of parameters the Unified ICM system sends to the peripheral to initialize the service.</td>
</tr>
<tr>
<td>Service level type (required)</td>
<td>For Unified CCE peripherals and for non-voice MRDs, the value of this field is always one (“ignore abandoned calls”) since you cannot track abandoned calls in these cases. The Configuration Manager tools do not allow this field to be changed for Unified CCE peripherals and non-voice MRDs. The allowed values here are constrained by the formula:</td>
</tr>
<tr>
<td></td>
<td>[ \text{If} \ (\text{MRD} == \text{CISCO_VOICE}) \ &amp; \ (\text{Peripheral} \ != \text{IPCC}) \ \text{then} \ \langle \text{any}_\text{valid}_\text{value} \rangle \ \text{Else} \ 0/1 \ \text{allowed}. ]</td>
</tr>
<tr>
<td>Service level threshold (required)</td>
<td>Default value at runtime. This can be overridden for individual services (Service table). If not, then this value is used if valid. If this entry is negative, the default is obtained from the ServiceLevelThreshold table, then the MRDomain table. Default entry is -1, which must be displayed in text, and not as a number.</td>
</tr>
<tr>
<td>Peripheral service level type</td>
<td>Ignored for non-voice services.</td>
</tr>
<tr>
<td>No longer used by peripheral</td>
<td>Indicates that this was originally configured by Peripheral Auto Config and this service is no longer used by the peripheral.</td>
</tr>
</tbody>
</table>

### Advanced Tab

This tab allows you to view (and define or edit, if you have maintenance access) advanced properties of the selected service.

### Table 24: Advanced Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peripheral service level type (required)</td>
<td>Type of service level calculation to be used in the Peripheral Service Level fields of the Service Real Time and Service Half Hour tables.</td>
</tr>
<tr>
<td>Schedule name</td>
<td>Identifies an imported schedule associated with the service.</td>
</tr>
</tbody>
</table>
Extension

The extension number for the skill group used by AT&T Definity G3. For all other peripheral types, leave this field blank.

Service Members Tab

This tab allows you to view service member information for the service that is currently selected. If you have maintenance access, this tab also lets you add or remove service members.

Table 25: Service Members Tab Field/Button Descriptions

<table>
<thead>
<tr>
<th>Field/Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>This window lists the names of all the skill groups that are members of the selected service.</td>
</tr>
<tr>
<td>Current Service Members</td>
<td>Use the Primary checkbox to indicate whether a skill is a primary group (the default) for the service or a backup group. You can have more than one primary skill group.</td>
</tr>
<tr>
<td>Primary</td>
<td>To add a service member, click this button. Then in the Add Service Member window, select the name of a skill group from the list of available records and click OK.</td>
</tr>
<tr>
<td>Buttons</td>
<td>An enterprise name for the skill group. This name must be unique among all skill groups in the enterprise.</td>
</tr>
<tr>
<td>Add</td>
<td>To remove a service member, select a skill group in the Current service members window and click this button.</td>
</tr>
</tbody>
</table>

Route Tab

A route is a value returned by a routing script that maps to a target at a peripheral; that is, a service, skill group, agent, or translation route. In this case, the route maps to the selected service. For more information on routes, see Chapter 8, "Configuring Routes and Routing Targets (page 149)."

Table 26: Route Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (required)</td>
<td>The enterprise name of the route.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the route.</td>
</tr>
</tbody>
</table>

Peripheral Target Tab

The DNIS tab allows you to view (and define, delete, or edit, if you have maintenance access) the DNIS properties of the selected peripheral target. A peripheral target is a combination of a
network trunk group and a DNIS (Dialed Number Identification Service) value, which the system software uses to indicate the destination for a call.

A DNIS is a string of digits indicating the number dialed by a caller and how the call will be handled by the ACD, PBX, or VRU.

**Table 27: DNIS Tab Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DNIS</td>
<td>Dialed Number Identification Service (DNIS). Usually a string of digits indicating the number dialed by a caller and how the call will be handled by the ACD, PBX, or IVR. Sometimes the string may include letters. The exact content of this field is dependant on the external hardware the system software interfaces with. Unified ICM system itself has no dependency on the contents of this field being in any particular format. The system software uses the DNIS and trunk group to indicate the destination for a call. The logger enforces the following rule: If a peripheral target (DNIS) is attached to a route, the route must have its Service field populated.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the peripheral target.</td>
</tr>
<tr>
<td>Network trunk group</td>
<td>(drop-down list) The enterprise name of the network trunk group associated with the peripheral target.</td>
</tr>
</tbody>
</table>

**Label Tab**

The Label tab allows you to view (and create, delete, or edit, if you have maintenance access) the properties of the selected label. A label (or routing label) is a value that the Unified ICM system returns to a routing client to map to a target, which, in this case, is the selected service on the selected peripheral. For a full description of labels, see the "Labels (page 157)" section.

**Table 28: Label Tab Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Routing Client (required)</td>
<td>The label value.</td>
</tr>
<tr>
<td>Label (required)</td>
<td>Additional information about the peripheral target.</td>
</tr>
<tr>
<td>Label type</td>
<td>(Drop-down list) The valid types depend on the type of routing client. Select one valid type for your routing client. Check with your carrier for the latest information about supported label types. Typical types are Normal, DNIS Override, Busy, Ring, and Post-Query.</td>
</tr>
<tr>
<td>Customer</td>
<td>The customer associated with the label.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the label.</td>
</tr>
</tbody>
</table>

**Modifying, Defining, and Deleting Services**

The following sections show you how to modify, define, and delete services.
How to Modify a Service

To modify a service, do the following:

**Step 1**
Follow the steps for viewing a service. (See the "How to View a Service (page 115)" section.)

**Step 2**
Edit the configuration information. (For field descriptions, see the "Service Explorer Tab Descriptions (page 115)" section.)

**Note:** You cannot modify fields that are greyed out.

With the mouse, you can select an object and then move it to another part of the tree, as long as its object type belongs in that tree location. For example, to move a route to another service, select it and then move the mouse to that service. When that service becomes highlighted, lift your finger off the mouse. You can also use the Bulk Configuration tool to take the output of a switch and create 20 or 30 labels. Then, using the Service Explorer, you can attach the labels to an appropriate location.

When you make a modification, the **Changed** icon

![Figure 36: Changed icon](image)

appears next to the selected item in the tree list box.

**Step 3**
Click **Save**.

The modified data is saved in the Unified ICM database and the **Changed** icon is removed from the edited object in the tree list box.

How to Define a Service and/or Its Associated Records

To define a service and/or its associated records follow these steps:

**Step 1**
In the Configuration Manager menu, select **Tools > Explorer Tools > Service Explorer**. The Service Explorer window appears.

**Step 2**
In the **Select filter data** box of the Explorer window, click **Retrieve**. This enables the **Add Service** button.

**Step 3**
Click **Add Service**. A new service appears in the tree list box with a **To Be Inserted** icon

![Figure 37: To be inserted icon](image)

next to it. Tabbed fields also appear on the right for the new service's configuration information.
Step 4 Fill in the tabbed fields. (For field descriptions, see the "Service Explorer Tab Descriptions (page 115)" section.)

Step 5 Click Add Route and fill in its configuration records.

Step 6 Click Add Peripheral Target and also Add Label and fill in those records.

Selecting an item in the tree list box enables the Add button for more items of that type and for the associated item immediately beneath it in the tree, if it can have one.

Step 7 If desired, set security settings on the records. (See the "How to View or Apply Security Settings (page 65)" section.)

Step 8 Click Save.

How to Delete a Record

To delete a record:

Step 1 In the Explorer tree list box, select the item or associated items whose records you want to delete.

Note: Deleting any item in the tree list box with branches beneath it also deletes those branches. For example, if you delete a service, you also delete its associated route, peripheral target, and label, if it has such. But, deleting a label deletes only that label.

Step 2 Click Delete. This places a Marked for Deletion icon

Figure 38: Marked for deletion icon

next to the selected item in the tree list box. This also toggles the Delete button to Undelete.

To undelete an item marked for deletion, select it in the tree list box and click Undelete.

Step 3 Click Save.

This deletes from the database the item(s) marked for deletion and removes it from the tree list box. Once you do this, you cannot undelete the deleted item.

Skill Groups

Enter information about each skill group associated with each peripheral. A skill group is a collection of agents that share a common set of skills and is associated with a service. Each skill group can be a member of more than one service.

Use the Configuration Manager's Skill Group Explorer to view, modify, or define a skill group.
Skill Group Explorer

The following sections show you how to use the Skill Group Explorer to view and configure a skill group and its associated routes, peripheral targets, and labels.

How to View a Skill Group

To view a skill group, follow these steps:

Step 1
In the Configuration Manager’s menu, select **Tools > Explorer Tools > Skill Group Explorer**. The Skill Group Explorer window appears.

Step 2
In the **Select filter data** box, select the peripheral associated with the skill group you want to view. You can choose the name from the drop-down list of peripheral enterprise names.

Step 3
Select any other filters you want. None in the Optional filter box means all skill groups associated with the selected peripheral will be displayed.

Step 4
Click **Retrieve**. This lists in the tree list box the name(s) of the retrieved service(s).

Step 5
In the tree list box, select a service to display its configuration information on the right side of the window.

Step 6
If the skill group has a route associated with it, click its icon in the tree list box to display its configuration information. Do the same for a peripheral target associated with the route and a label associated with the peripheral target.

**Note:** A tree object is unassigned if it was made by another configuration tool and was not assigned (mapped) to a parent object; for example, a label might not have been assigned to a peripheral target or a route might not have been assigned to a service, and so on.

Skill Group Explorer Tab Descriptions

The tables in the following sections describe the tabbed fields in the Skill Group Explorer records.

### Skill Group Tab

The Skill Group tab allows you to view (and edit, if you have maintenance access) the properties of the currently selected skill group. A skill group is a collection of agents that share a common set of skills.

**Table 29: Skill Group Tab Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media routing domain (required)</td>
<td>(selection list) The media routing domain associated with the skill group.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Peripheral Number (required)</strong></td>
<td>The skill group number as known by the peripheral. This value must be unique among all skill groups for a peripheral, but need not be unique across peripherals.</td>
</tr>
<tr>
<td><strong>Peripheral Name (required)</strong></td>
<td>The local name for this skill group. This value must be unique among all skill groups associated with the peripheral, but need not be unique across peripherals. For example, each peripheral can have a skill group named International_Orders. For skill groups that support sub-skill groups, the sub-skill groups' name are made out of the base skill group's name plus a suffix. A suffix can have max 4 characters. Therefore, the maximum length for base skill group name is 28 characters when you plan to have sub-skill groups. Note: The peripheral name in the filter box is its enterprise name, not this name.</td>
</tr>
<tr>
<td><strong>Name (required)</strong></td>
<td>An enterprise name for the skill group. This name must be unique among all skill groups in the enterprise. If you click in this box after entering the peripheral name, the software automatically creates this name by appending the peripheral name to the selected peripheral. For example: Boston_PG1.International_Orders.</td>
</tr>
<tr>
<td><strong>Available Holdoff Delay</strong></td>
<td>The number of seconds to wait after a call ends before recording the agent as Available. You can enter a value or choose the default. • For a DMS-100, enter the Variable WrapUp time for the ACD DN. • For all other peripheral types, set this field to zero.</td>
</tr>
<tr>
<td><strong>Priority</strong></td>
<td>(read-only) Indicates the routing priority of this base group for the skill. The value 0 indicates a base skill group. This is the default when there is only one skill group and there are no priorities. For sub skill group priorities please refer to the Sub Skill Group tab as well as the Subgroup Mask tab.</td>
</tr>
<tr>
<td><strong>Extension</strong></td>
<td>If the peripheral is an Avaya DEFINITY ECS or Rockwell Spectrum, enter the extension number associated with the skill group. For all other peripheral types, leave this field blank.</td>
</tr>
<tr>
<td><strong>ICM picks the agent</strong></td>
<td>Checked, indicates that the system software selects the agent. This option is used for IPCC-like routing where the system software picks the agent to handle a request. Unchecked, indicates another entity, typically an ACD, does the agent selection (after the system software has sent a call to an ACD skill group). This option applies to pre-routed requests.</td>
</tr>
</tbody>
</table>
### Skill Group Members Tab

The Skill Group Members tab allows you to view skill group member information for the currently selected skill group. If you have maintenance access, this tab also lets you add or remove skill group members. It also lets you assign this skill group as the default skill group for one or more agents.

**Note:** This tab is only enabled if there are no sub-skill groups configured for this base skill group.

#### Table 30: Skill Group Members Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field/Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current skill group members</td>
<td>This window lists the names of all the agents that are members of the selected skill group.</td>
</tr>
<tr>
<td>Agent name</td>
<td>The name of an agent in the skill group.</td>
</tr>
<tr>
<td>Current default skill group name</td>
<td>The name of each agent's default skill group. &lt;System-defined&gt; indicates that the agent's default skill group is the peripheral default skill group.</td>
</tr>
<tr>
<td>Add</td>
<td>To add a skill group member, click this button. Then in the Add Skill Group Member window, select the name of an agent from the list of available records and click OK.</td>
</tr>
<tr>
<td>Remove</td>
<td>To remove an agent, select an agent name in the Current skill group members window and click this button.</td>
</tr>
<tr>
<td>Set Default Skill Group</td>
<td>To set an agent's default skill group to the current skill group, select one or more agent names in the Current skill group members window and click this button. This button is disabled if the peripheral is not a CallManager/SoftACD or IPCC System peripheral, or the Media routing domain is not configured as Cisco_Voice.</td>
</tr>
</tbody>
</table>

### Assigning Agents to a Default Skill Group

Observe the following guidelines when assigning an agent to a default skill group:

- An agent can be a member of multiple skill groups, but can only belong to one *default* skill group. Clicking the Set Default Skill Group button sets the default skill group for all selected agents to this skill group.

- Removing one or more agents with this skill group set as its default causes the agent's default skill group to be set to the *peripheral* default skill group.
• Changing the Media routing domain from Cisco_Voice to non Cisco_Voice sets the default skill group for all member agents having this skill group as their default to the peripheral default skill group, and the Set Default Skill Group button is disabled.

Subgroup Mask Tab

The Subgroup Mask tab allows you to view (and edit, if you have maintenance access) the number of sub-skill groups on the currently selected peripheral. This tab is enabled only if the selected peripheral can have sub-skill groups. A subgroup mask defines sub-skill groups.

Note:

• **Important!** Sub-skill groups were supported in earlier releases, but are currently only supported for Avaya PG, Symposium PG, IPCC PG, Spectrum PG, and NEC PG TDM peripherals. Sub-skill groups are also not supported for non-voice skill groups. That is, you cannot create sub-skill groups for these media classes: single-session chat, multi-session chat, blended collaboration, and email.

• For all peripherals that support sub-skills (Definity ECS EAS, and Rockwell Spectrum), the Skill Group Explorer automatically creates the sub-skills (primary, secondary, and so on) as defined by the peripheral subgroup mask. This tab gives you the option of changing the sub-skill mask on a skill-group-by-skill-group basis.

**Table 31: Subgroup Mask Tab Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Override Peripheral Default Mask</td>
<td>If this check box is not checked, the default sub-skill groups for the selected peripheral are created. Selecting this check box enables the Subskill group check boxes.</td>
</tr>
<tr>
<td>Subskill group check boxes</td>
<td>Check the box for each sub-skill group you want to generate.</td>
</tr>
<tr>
<td></td>
<td>Uncheck the box for each sub-skill group that you want to delete.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> These check boxes are only enabled for Avaya PG, Symposium PG, IPCC PG, Spectrum PG, and NEC PG TDM peripherals.</td>
</tr>
<tr>
<td></td>
<td>Upon saving, the unchecked sub-skill groups are only marked deleted in the database for reporting purposes. To permanently delete these sub-skill groups once they are on longer needed, use the Deleted Object tool.</td>
</tr>
<tr>
<td></td>
<td>If these sub-skill groups are not permanently deleted, configuring a sub-skill group with the same priority by checking off the corresponding checkbox in the Subgroup mask tab causes the error message “Failed to update the database. The enterprise name that was entered is already in use”.</td>
</tr>
</tbody>
</table>
Sub Skill Groups Tab

The Sub Skill Groups tab allows you to view (and edit, if you have maintenance access) the sub-skill group properties of the currently selected peripheral. This tab is enabled only if the selected peripheral has sub-skill groups.

Table 32: Sub Skill Groups Tab Descriptions

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Associated sub skill groups</td>
<td>The list of sub-skill groups associated with the peripheral.</td>
</tr>
<tr>
<td>Priority</td>
<td>The names of the sub-skill groups associated with the peripheral.</td>
</tr>
<tr>
<td>Agents in the selected sub-group</td>
<td>The priority level of the sub-skill groups: 1=primary; 2=secondary; 3=tertiary; and so on. The value 0 indicates a base skill group. This is the default when there is only one skill group and there are no priorities.</td>
</tr>
<tr>
<td>Agents in the selected sub-group</td>
<td>The list of agents in the selected sub-skill group.</td>
</tr>
<tr>
<td>Agent name</td>
<td>The names of the agents in the selected sub-skill groups.</td>
</tr>
<tr>
<td>Add</td>
<td>To add an agent to the selected sub-skill group, click this button, and in the Add Skill Group Member dialog, select a name and click OK.</td>
</tr>
<tr>
<td>Remove</td>
<td>To remove an agent from the selected sub-skill group, select that agent's name and click Remove.</td>
</tr>
</tbody>
</table>

Route Tab

The Route tab allows you to view (and define, delete, or edit, if you have maintenance access) the properties of the selected route.

A route is a value returned by a routing script that maps to a target at a peripheral; that is, a service, skill group, agent, or translation route. In this case, the route maps to a skill group. For more information on routes, see the "Configuring Routes and Routing Targets (page 149)" section.

Table 33: Route Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Skill group priority</td>
<td>Set to 0 if the route is assigned to the base skill group. If the route is assigned to a sub skill group (as listed on the Sub skill groups tab), select the setting (1, 2, 3, etc.) that matches the desired sub skill group from the sub skill groups list. The number of priority levels available depends upon the subgroup mask setting (1-64) on the Subgroup Mask tab which in turn depends upon the peripheral chosen.</td>
</tr>
<tr>
<td>Name (required)</td>
<td>The enterprise name of the route.</td>
</tr>
</tbody>
</table>

You might derive the enterprise name for the route from the skill group and service associated with it. For example, you might have a route associated with the *Dallas.TeleSales* service and the *Dallas.Sales* skill group. You might name the route *Dallas.TS_Sales*. |
Every route must be associated with a service for it to be functional. By choosing a service, you are implicitly associating the route with the peripheral for that service. For a new route, the drop-down list contains all the services defined for the selected peripheral (or PG, in the case of a service array).

If you select None as the service name, then the route cannot be associated with a peripheral and you can move the route to the UNASSIGNED list.

Once a route has a service selected, it can no longer be moved to the UNASSIGNED list. However, it can be moved within the appropriate tool to another skill target. For example, in the Skill Group Explorer, you can move a route to another skill group, in the Service Explorer, you can move a route to another service, and in the Agent Explorer, you can move a route to another agent.

Peripheral Target Tab

The Peripheral Target tab allows you to view (and define, delete, or edit, if you have maintenance access) the DNIS properties of the selected peripheral target. A peripheral target is a combination of a trunk group and a DNIS value.

A peripheral target is associated with a service, skill group, agent, or translation route at a peripheral. Each peripheral target is also associated with a route that can be returned by a routing script.

A DNIS is a string of digits indicating the number dialed by a caller and how the call will be handled by the ACD, PBX, or VRU.

Note that peripheral target refers to a trunk group and DNIS value. Skill target refers to the entity at the peripheral to which the call is dispatched.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DNIS (required)</td>
<td>Dialed Number Identification Service (DNIS). Usually a string of digits indicating the number dialed by a caller and how the call will be handled by the ACD, PBX, or IVR. Sometimes the string may include letters. The exact content of this field is dependant on the external hardware the system software interfaces with. The Unified ICM system itself has no dependency on the contents of this field being in any particular format. The system software uses the DNIS and trunk group to indicate the destination for a call. The logger enforces the following rule: If a peripheral target (DNIS) is attached to a route, the route must have its Service field populated.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the peripheral target.</td>
</tr>
</tbody>
</table>
Table 35: Label Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Routing client (required)</td>
<td>The enterprise name of the routing client associated with the label.</td>
</tr>
<tr>
<td></td>
<td>The logger enforces the following rule: If a peripheral target (DNIS) is attached to a route, the route must have its Service field populated.</td>
</tr>
<tr>
<td>Label (required)</td>
<td>The label value.</td>
</tr>
<tr>
<td>Label type (required)</td>
<td>(drop-down list) The valid types depend on the type of routing client. Select one valid type for your routing client. Check with your carrier for the latest information about supported label types. Typical types are Normal, DNIS Override, Busy, Ring, and Post-Query.</td>
</tr>
<tr>
<td>Customer</td>
<td>(optional) The customer associated with the label.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the label.</td>
</tr>
</tbody>
</table>

Modifying, Defining, and Deleting Skill Groups

The following sections show you how to modify, define skill groups. For information on how to delete a skill group or any of its records, see the "How to Delete a Record (page 120)" section.

How to Modify a Skill Group

To modify a skill group follow these steps:

**Step 1**  
Follow the steps for viewing a skill group. (See the "How to View a Skill Group (page 121)" section.)

**Note:** Once you have saved a skill group record to the Unified ICM database, you cannot update the Peripheral field.

**Step 2**  
Edit the configuration information. (For field descriptions, see the "Skill Group Explorer Tab Descriptions (page 121)" section.)
**Note:** You cannot modify fields that are greyed out.

With the mouse, you can select an object and then move it to another part of the tree, as long as its object type belongs in that tree location. For example, to move a route to another skill group, select it and then move the mouse to that skill group. When that skill group becomes highlighted, lift your finger off the mouse. You can also use the Bulk Configuration tool to take the output of a switch and create 20 or 30 labels. Then, using the Explorer, you can attach the labels to an appropriate location.

When you make a modification, the **Changed** icon

![Changed icon](image)

appears next to the selected item in the tree list box.

**Step 3** Click **Save**.

The modified data is saved in the Unified ICM database and the **Changed** icon is removed from the edited object in the tree list box.

---

**How to Define a Skill Group and/or Its Associated Records**

**Note:** The "Configuring Skill Groups on the Child Central Controller (page 129)" section contains an example of how to configure skill groups for a child deployment, which is documented in the *Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX*.

To define a skill group and/or its associated records follow these steps:

**Step 1** In the Configuration Manager's menu, select **Tools > Explorer Tools > Skill Group Explorer**. The Skill Group Explorer window appears.

**Step 2** In the **Select filter data** area of the Explorer window, click **Retrieve**. This enables the **Add Skill Group** button.

**Step 3** Click **Add Skill Group**. A new skill group appears in the tree list box with a **To Be Inserted** icon next to it. Tabbed fields also appear on the right for the new skill group's configuration information.

**Step 4** Fill in the tabbed fields. (For field descriptions, see the "Skill Group Explorer Tab Descriptions (page 121)" section.)

**Step 5** Click **Add Route** and fill in its configuration records.

**Step 6** Click **Add Peripheral Target** and also **Add Label** and fill in those records.

Selecting an item in the tree list box enables the **Add** button for more items of that type and for the associated item immediately beneath it in the tree, if it can have one.
If desired, set security settings on the records. (See the "How to View or Apply Security Settings (page 65)" section).

Click *Save*.

### Configuring Skill Groups on the Child Central Controller

Access the Configuration Manager on the Child Administration & Data Server to configure skill groups.

### How to Configure Skill Groups on the Child Central Controller

Use the Configuration Manager Skill Group Explorer Tool to configure skill groups SG01 and SG02 on the Child Central Controller.

1. Start the **Skill Group Explorer Tool**.
2. On the Main window of the Agent Explorer Tool, click **Retrieve**.
3. Click **Add Skill Group**.
   
   The Skill Group tab appears.
4. Complete all the fields and click **OK**.
   
   The skill group name appears in the list, as with all Explorer tools.
5. Select the **Skill Group Member** tab and click **Add**.
   
   The Add Skill Group Member dialog appears.
6. Select the agents to add to the skill group, then click **OK**.
   
   The agents become members of the skill group.
7. Select the skill group in the tree list, then click **Add Route**.
   
   The Route tab appears.
8. Provide the Route Name and click **Save**.
   
   The route name appears in the tree list and the skill group is added to the peripheral.
9. Repeat this to add one more skill group.
10. Click **Save**, then **Close** to exit the Skill Group Explorer Tool.
Mapping Skill Groups to Services

When you define services and skill groups, you can establish the mappings of skill groups to services. Each skill group can be mapped to zero, one, or more services; each service can be mapped to zero, one, or more skill groups.

You can define some service member skill groups as being primary for the service. The system software uses the primary attribute in determining the destination for a call to the service. For example, the Longest Available Agent (LAA) for a service is really the LAA for the primary group(s) configured for that service.

How to Map Skill Groups to Services

To map skill groups to services, follow these steps:

1. Within the Configuration Manager menu, select Tools > Explorer Tools > Service Explorer. The Service Explorer window appears.
2. Select the filters you want and click Retrieve. The retrieved services appear in the list box.
3. Select the service you want and click the Service Members tab.
4. This step depends on whether you want to add or to remove skill group(s):
   a. To remove a skill group(s), select the skill group’s name(s) and click Remove.
   b. To add a skill group(s), click Add, and in the Add Service Member dialog, select the skill group(s) and click OK.

   The available skill groups are all those defined for the selected peripheral.
5. In the Service Members tab, select the Primary check box for any skill groups that you want to be primary.
6. When finished, in the Skill Group Explorer window, click Save.

Modifying the Skill Groups Per Agent Limit

Unified ICM and Unified CCE impose a default limit on the number of skill groups that you can assign to a single agent. Once this limit is reached, additional skill groups cannot be assigned. The default limit is specified in the Cisco Unified Contact Center Enterprise 8.x Solution Reference Network Design (SRND). The limit considers the total of both skill groups and sub-skill groups.

If desired, you can use the ConfigLimit Tool to specify your own limit on the number of skill groups that can be assigned to an agent. For optimum performance, you can specify a limit far
lower than the system default (refer to the *Cisco Unified Contact Center Enterprise 8.x Solution Reference Network Design (SRND)* for performance considerations in choosing a skill groups per agent limit).

**Warning:** Setting a default value for skill groups per agent that is higher than the system default can adversely affect system performance. Cisco will not support configurations that exceed the default value.

**Caution:** The ConfigLimit tool is a command-line tool utility from the bin directory of all Unified ICM/CCE Administration & Data Servers. Access is limited to users with privileges for the Setup or Config Groups in Active Directory for the chosen customer instance. *(Refer to the Outbound Option Guide for Cisco Unified Contact Center Enterprise & Hosted for detailed information about the ConfigLimit tool.)*

### Using the ConfigLimit Tool

To change the skill groups per agent limit in configlimit.exe:

**Step 1** Launch a command line window on any Administration Client or Administration & Data Server.

**Step 2** Enter `configlimit`.

**Step 3** Optionally, enter `cl /show` to view the existing limit.

**Step 4** To change the limit, enter `cl /id 1 value/<new_value> /update`

For example, to change the skill groups per agent limit to 5, enter the following text: `cl /id 1 value/5 /update`

**Step 5** Press Enter.

### Additional Requirements

#### Lowering the Limit

If you have modified the skill groups per agent limit to be lower than the system default, no additional changes are necessary. The new, lower limit will be enforced immediately. Note that the new limit will **not** impact agents whose existing skill group membership exceeds the new limit until the next attempt to add a new skill group for those agents. At that time the new limit will be enforced, preventing you from adding additional skill groups.

#### Exceeding the Default Limit

If you have modified the skill groups per agent limit to be higher than the system default (in spite of the Warning given above), certain deployments will require additional changes (listed in the following sections) to your system to use the new limit and will allow you to add additional skill groups.
Note: If you exceed the default limit and are using CTI OS, do not exceed a maximum of 99 skill groups.

IPCC Gateway PG

For IPCC Gateway deployments, modify the following registry keys on your IPCC Gateway PGs to include the new value. A change to the registry will require that the PG service be restarted.

IPCC Enterprise Gateway PIM (Cisco Unified Contact Center Enterprise parent)

```
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\< customer_instance >\PG[n]\[A|B]\PG\CurrentVersion\PIMS\pim\ACMIData\Config\MaxSkills
```

IPCC Express Gateway PIM (Cisco Unified Contact Center Express parent)

```
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\< customer_instance >\PG[n]\[A|B]\PG\CurrentVersion\PIMS\pim\ACMIData\Config\MaxSkills
```

ERI PG

For ERI deployments, modify the following registry key on your ERI PGs to include the new value. A change to the registry will require that the PG service be restarted.

ER Service PIM

```
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\< customer_instance >\PG[n]\[A|B]\PG\CurrentVersion\PIMS\pim\ERSData\Config\MaxSkills
```

Persons

You must associate every agent with a person record. The person stores the login name, first name, last name, and password. On Unified ICM you can have multiple agents per person. An agent is an "extension" of a person on a given peripheral.

The Person List tool allows you to list the persons currently defined in the Unified ICM database, to define new ones, and to view, edit, or delete the records of existing ones.

Note: You can create Persons and/or Agents in the system software and the Cisco Unified Interaction Manager application. Creating them in one of the preceding makes them available to all. However, if agents exist in your enterprise in the system software and you want them to be able to work on an Unified ICM application, you must also enable those existing agents in that application.

Available person records are records that have not been mapped to any agent records (including logically deleted ones) at the peripheral selected in the Agent Explorer. To free a person associated with a logically deleted agent, use the Configuration Manager's Deleted Objects tool to permanently delete the logically deleted agent.
Select Filter Data

Use the Select filter data box to select and retrieve data from the database. Until you retrieve database data, no data is displayed.

Optional filter

None means no optional filtering. All data is displayed for the selected records.

The optional fields to filter on differ by record type according to both the fields in a record and the fields considered useful as filters.

Condition filter

**Table 36: Option Filters**

<table>
<thead>
<tr>
<th>If the selected Optional Filter is</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>The Condition filter is ignored.</td>
</tr>
<tr>
<td>A text filter (for example, Description)</td>
<td>Select one of the text conditions (Contains, Ends With, Starts With, Is Blank) and enter an appropriate entry in the Value field.</td>
</tr>
<tr>
<td>A numeric filter (for example, Trunk Number)</td>
<td>Select one of the numeric conditions (Equal, Greater Than, Less Than, Not Equal) and enter an appropriate entry in the Value field. The available numeric conditions can change depending on the record data. For example Equal or Not Equal might be the only choices.</td>
</tr>
</tbody>
</table>

Value

The entry in this field is based on the selections made in the Optional Filter and Condition fields. If None is selected in the Optional Filter field, this field is ignored.

Save

Checked, indicates the current settings are saved so that when you next open the List tool for this type of record, the current settings will be selected. However, no data is displayed until you click the Retrieve button.

Retrieve

This button displays the data selected in the Select filter data box.

Cancel filter changes

If you change the Optional Filter settings after a Retrieve, clicking this button resets the filter settings back to the preceding ones.
Person List Tool Tab Descriptions

Following are the Person List tool tab descriptions:

Attributes tab

Allows you to view (and define, delete, or edit, if you have maintenance access) the properties of the selected person.

Table 37: Person List Tool Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First name (required)</td>
<td>The selected agent's first name; for example: John. The system automatically fills in the name fields after you select a person.</td>
</tr>
<tr>
<td>Last name (required)</td>
<td>The selected agent's last name; for example: Smith.</td>
</tr>
<tr>
<td>Login name (required)</td>
<td>The selected agent's login name; for example: jsmith.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> In the System Information tool, the administrator can set whether or not person login names are case sensitive.</td>
</tr>
<tr>
<td>Password</td>
<td>(optional) An MD5 encrypted password, used for authentication by Unified ICM and by applications integrated with Unified ICM. The password is</td>
</tr>
<tr>
<td></td>
<td>restricted to the 7-bit printable ASCII characters (any of the 94 characters with the numeric values from 32 to 126). Control characters (for</td>
</tr>
<tr>
<td></td>
<td>example, 'tab') and international characters are not allowed. This means passwords cannot be entered in a non-Western alphabet, such as Kanji.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> In the System Information tool, the administrator can set the number of required characters for person passwords. A person password is case sensitive.</td>
</tr>
<tr>
<td>Change Password</td>
<td>Click to change your password.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Enables the Password and Confirm Password fields.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Used when changing your password.</td>
</tr>
<tr>
<td>Description</td>
<td>(optional) Additional information about the person.</td>
</tr>
<tr>
<td>Enable logins (optional)</td>
<td>(optional) Checked, indicates that this person is currently allowed to access the system. Unchecked, indicates the person is not allowed to access</td>
</tr>
<tr>
<td></td>
<td>the system. A typical use of this is to temporarily suspend a person's access to the system during vacation or certain hours, and to do so without disturbing any of the entered information for this person.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This option is not and will not be supported by ACDs or soft ACDs. This option is also currently not supported by Unified CCE voice phones.</td>
</tr>
</tbody>
</table>
How to Change Your Password

Follow these steps to change your password:

**Step 1**  Click Change Password.

**Step 2**  Enter your new password in the enabled Password field.

**Step 3**  Re-enter your new password in the enabled Confirm password field to ensure you have typed it correctly.

**Step 4**  Click Save to set your new password.

Agents

An agent is a person who handles calls from a peripheral or supervises those who do. You need to set up each agent associated with each peripheral.

Use the Configuration Manager's Agent Explorer to configure agents.

**Note:** If partitioning is enabled, you need supervisor privileges to add or remove an agent from a skill group and you need administrator privileges to define an agent record and to edit it in other ways.

The system software also provides a utility that allows you to insert and update agent records based on data in a text file. For more information, see the "Importing Agent Configuration Data from the Peripheral (page 141)" section.

How to View or Modify an Agent(s) Record

To view or modify an agent(s) record, follow these steps:

**Step 1**  In the Configuration Manager menu, select Tools > Explorer Tools > Agent Explorer. The Agent Explorer window appears.

**Step 2**  In the Select filter data box, select the peripheral with which the agent is associated. Enter any other filters you want and click Retrieve.

The retrieved enterprise names for the agents are displayed in the list box.

**Step 3**  Select the agent name whose properties you want to view and use the tabs on the right side of the window to view the properties.

**Step 4**  Edit the properties appropriate. See the online help if you have questions.

**Step 5**  When finished, in the Agent Explorer window, click Save.
How to Create an Agent

Note: The "Configuring Agents on the Child Central Controller (page 136)" section contains an example of how to configure agents for a child deployment, which is documented in the Cisco Contact Center Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX.

Follow these steps to create an agent:

**Step 1**  
In the Configuration Manager menu, select **Tools > Explorer Tools > Agent Explorer**. The Agent Explorer window appears.

**Step 2**  
In the **Select filter data** box, select the peripheral with which the agent is to associated and click **Retrieve**. This enables the **Add Agent** button.

**Step 3**  
Click **Add Agent**.

**Step 4**  
In the property tabs on the right side of the window, enter the appropriate property values. (See the online help for field definitions.) Use the **Agent tab** (page 137) to define the agent, the **Skill group membership tab** (page 138) to map the agent to any skill groups, and the **Supervisor tab** (page 139) to assign the agent as a supervisor.

Note: An agent team can have only one primary supervisor. There is no upper limit to the number of secondary supervisors for a team. Refer to the online help for instructions on how to assign a primary supervisor.

**Step 5**  
When finished, click **Save**.

Configuring Agents on the Child Central Controller

Access the Configuration Manager on the Child Administration & Data Server to configure agents.

How to Configure Agents on the Child Central Controller

Use the Configuration Manager Agent Explorer tool to configure agents on the Child Central Controller.

**Step 1**  
Start the **Agent Explorer tool**.

**Step 2**  
On the Main window of the Agent Explorer tool, click **Retrieve**.

**Step 3**  
Click **Add Agent**.

The Agent tab appears.

**Step 4**  
Complete all the fields except the Password and the Peripheral Name fields.
The agent name information appears in the list, as with all Explorer tools.

**Step 5**  
Repeat this process to add at least three agents.

**Step 6**  
Click **Save**, and then **Close** to exit the Agent Explorer tool.

---

Agent Explorer Tab Descriptions

The tables in the following sections describe the tabbed fields in the Agent Explorer.

### Agent Tab

The Agent tab allows you to view (and define, delete, or edit, if you have maintenance access) the properties of the selected agent's account.

#### Table 38: Agent Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| **First name (required)** | The selected agent's first name; for example: John.  
                            The system automatically fills in the name fields after you select a person.                                                                |
| **Temporary**          | (appears only if agent is a temporary one) This label and checkbox appear next to the first name field only if the selected agent is a temporary agent created by the CallRouter. In this case the name related fields are unavailable. To change this agent to a permanent agent, uncheck this checkbox, fill in the required fields, and click **Save**. This checkbox then becomes hidden. |
| **Last name (required)** | The selected agent's last name; for example: Smith  
                            **Note:** When you add new agents, ensure that the agent names are unique. If the first name and the last name of two agents are same, the reporting data for both agents will be grouped under one single name and thus cause confusion. |
| **Login name (required)** | The selected agent's login name; for example: jsmith. The login name must be unique within the enterprise. Use the System Info tool to determine if the login name is to be case-sensitive or not. |
| **Select Person**      | (optional) Click this button to select a person to associate with the agent record. You can select a person for a new agent, an existing agent, or a temporary agent.  
                            To create an agent record, you must associate a person with the agent. For an existing agent record, you can select a different person (from the current one selected) to be associated with that agent record. |
If you select a person for a temporary agent, you make that agent a permanent one. You cannot demote an agent to be a temporary one.

A Unified ICM agent's personal information is stored in the database's Person table.

**Enterprise Name (required)**

An enterprise name for the agent that is unique within the enterprise.

When defining a new agent, if you click this field after entering the agent's first and last name, the system by default enters as the enterprise name the peripheral with the agent's last and first name appended to it. For example: Boston_PG_1.Smith_John where Boston_PG_1 is the peripheral and Smith_John is the agent's last and first name.

**Peripheral number (required)**

The agent login ID assigned at the peripheral. The peripheral number is equivalent to the agent ID. You must enter the Peripheral number for a voice agent or agent enabled for voice. If you create an agent on Unified ICM without assigning the agent to a skill group and leave the Peripheral number blank, it is auto-generated.

**Note:** If you change the Agent ID (Peripheral ID), you must cycle the PG in order to populate the new agent ID and information in the CTI OS Supervisor Desktop.

**Peripheral name**

(optional) The name of the agent as known to the peripheral; for example: service_expert1. The peripheral name is equivalent to the agent name.

**Note:** If you change the Agent ID (Peripheral ID), you must cycle the PG in order to populate the new agent ID and information in the CTI OS Supervisor Desktop.

**No longer used by peripheral**

Indicates that this was originally configured by Peripheral Auto Config and is no longer used by the peripheral.

### Skill Group Membership Tab

The Skill Group Membership tab lists the skill groups in which the selected agent is a member and enables a supervisor to add (or remove) the selected agent to (or from) a skill group. You can also assign a default skill group for an agent on this tab.

<table>
<thead>
<tr>
<th>Field/Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Skill Group Name</strong></td>
<td>The skill groups in which the selected agent is a member.</td>
</tr>
<tr>
<td><strong>Add</strong></td>
<td>Click this button to add the selected agent to a skill group. In the Add Skill Group Member dialog, select the skill group you want and click <strong>OK</strong>.</td>
</tr>
<tr>
<td><strong>Remove</strong></td>
<td>Click this button to remove the selected agent from the selected skill group.</td>
</tr>
<tr>
<td><strong>Default Skill Group</strong></td>
<td>Select the agent's default skill group from the drop-down list box.</td>
</tr>
</tbody>
</table>
Assigning an Agent to a Default Skill Group

Observe the following guidelines when assigning an agent to a default skill group:

- **<System-defined>** indicates that the peripheral default skill group is selected as the agent's default skill group.

- For CallManager/ACD and IPCC System peripherals, the Default Skill Group drop-down list box is populated with <System-defined> and all the skill group members that are configured with the Cisco_Voice Media routing domain. This list automatically updates when skill group members are added or removed.

- For peripherals other than CallManager/ACD and IPCC System peripherals, the Default Skill Group drop-down list box is only populated with <System-defined> and is disabled.

- An agent can be a member of multiple skill groups, but can only belong to one default skill group. The Default Skill Group drop-down list box displays the agent's default skill group.

- When the agent's default skill group is removed as a skill group member, it is also removed from the Default Skill Group drop-down list box and <System-defined> is selected, effectively selecting the peripheral default skill group as the agent's default skill group.

Supervisor Tab

The Supervisor tab allows an administrator to assign (or unassign) the selected agent to be a supervisor.

**Note:** Agents are not Unified ICM users; therefore, they cannot run any reports. Supervisors are special agents who are Unified ICM users with limited privileges. Supervisors can only see their agent team reports, and no agent in their team or other teams can see any data as they are not Unified ICM users. Supervisors can also add and remove members of their teams.

**Table 40: Supervisor Tab Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Supervisor Agent</td>
<td>Checked, indicates the selected agent is a supervisor.</td>
</tr>
<tr>
<td>Domain name (required)</td>
<td>Select the Active Directory Domain Name.</td>
</tr>
<tr>
<td>Location</td>
<td>Select the Location.</td>
</tr>
<tr>
<td>Supervisor login as user (required)</td>
<td>Window domain account login name for the selected agent.</td>
</tr>
<tr>
<td>Supervisor login password</td>
<td>The Window domain account password for the account of the selected supervisor agent. Only asterisks appear in the field as you type.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional supervisor information about the selected agent.</td>
</tr>
</tbody>
</table>
Mapping Agents to Skill Groups

After you have set up skill groups and agents, enter the assignments of agents to skill groups as configured for the peripheral. Each agent can belong to zero, one, or more skill groups.

You can use the Configuration Manager's Skill Group Explorer to map agents to skill groups.

How to Assign Agents to a Skill Group

Follow these steps to assign agents to a skill group:

**Step 1** Within the Configuration Manager menu, select Tools > Explorer Tools > Agent Explorer. The Agent Explorer window appears.

**Step 2** Select the filters you want and click Retrieve. The retrieved agents appear in the list box.

**Step 3** Select the agent you want assign to a skill group and click the Skill Group Membership tab.

**Step 4** This step depends on whether you want to add or to remove agent. On the Skill group membership tab:

a. To remove the selected agent from a skill group, select the appropriate skill group(s) and click Remove.

b. To add the selected agent to a skill group, click Add, and in the Add Skill Group Member dialog, select the appropriate skill group(s) and click OK.

**Step 5** When finished, in the Agent Explorer window, click Save.

How to Enable/Disable Agent Data at a Peripheral and Define an Agent Distribution

Follow these steps to enable/disable agent data at a peripheral and define an agent distribution:

**Step 1** In the Configuration Manager menu, select Tools > Explorer Tools > PG Explorer. The PG Explorer window appears.

**Step 2** Click Retrieve.

**Step 3** In the tree list box, expand the appropriate logical controller and select the peripheral.

**Step 4** In the Agent Distribution tab, select or deselect the Enable agent reporting check box.

**Step 5** In the Agent Distribution Entries list box, select an existing distribution site or create a new one by clicking New and entering values for the following fields:

a. Administration & Data Server site name. The Admin site name for the Primary/Secondary Pair (Site) name, as specified in the Web Setup tool.
b. **Agent real time data.** If checked, enables the flow of agent real time data from the peripheral to the Administration & Data Server. Unchecked, disables the flow of agent real time data.

c. **Agent historical data.** If checked, enables the flow of agent historical data from the peripheral to the Administration & Data Server. Unchecked, disables the flow of agent historical data.

**Step 6**  
Click **Save** to apply your changes.

---

**Agent State Trace**

 Optionally, the system software can track every state (Available, Talking, and so on) an agent passes through. You can turn on this feature in the Configuration Manager's Agent Explorer. The Agent tab includes the Agent State Trace check box, which you select if you want to track this agent's states.

**Note:** Tracking every state of an agent puts an added load on the system software. Activating this feature for all agents at all times may require additional network bandwidth, additional database space, and so on. Typically, you must use this feature only for short-term tracking of specific agents.

---

**Temporary Agents**

The system software might receive agent-level reporting data for an agent that has not been configured. The system software automatically configures a temporary agent to associate with this data.

The Agent Explorer Agent tab includes a **Temporary Agent** check box. This check box is disabled and unchecked for standard agents. For temporary agents created by the CallRouter software, this checkbox is enabled and checked.

The system software derives the last name, first name, and enterprise name from the peripheral number and skill target ID.

You can subsequently modify the agent configuration to assign the correct names to the agent. To convert a temporary agent to a standard agent, uncheck the Temporary Agent check box. When you apply these modifications, the Temporary Agent field is automatically deselected and disabled.

---

**Importing Agent Configuration Data from the Peripheral**

An ACD requires all the available agents to be configured to allow the agents to login to the call handling devices with their peripheral number (Agent ID) or peripheral name, password, etc. Also, these agents are configured to handle specific category of calls based on Skill Group. There are some other data elements configured on the ACD such as last name, first name and other class of services.
The Unified ICM Agent Level Reporting requires these agents to be configured in Unified ICM in order to identify them with either full name, peripheral name or enterprise name on both the real-time and historical reports.

The agentcfg.exe command line tool provides a process of configuring the agent configuration data elements available on an ACD into the Agent table in the Unified ICM database. This can also be automated by scheduling the process to run as an AT job at a specific time during a day. The frequency of scheduling the agent configuration process depends on your requirements.

The Agent configuration process is required to run for each peripheral.

How to Import Agent Data

Follow these steps to import agent data:

**Step 1** Retrieve the agent configuration data from the peripheral.

**Step 2** Form all the information in a tab-delimited text file with one row per agent. Each row of the file must contain the following fields, in order:

- PeripheralNumber
- FirstName
- LastName
- Description
- PeripheralName

**Step 3** To import data from the file into the system software, enter one of the following commands at the command prompt:

```
AgentCfg <Peripheral ID or Peripheral Name> <Input file name> [<Second input file>] [<Option>]
```

These variables are defined as:

a. **<Peripheral ID or Peripheral Name>:**
   Peripheral ID or Peripheral Name of the peripheral that you want to configure.

b. **<Input file name>:**
   The name of the input file contains the agent OR skill group member configuration data on the ACD in the appropriate format (described in the next section). The file must contain header information, otherwise the tool assumes the data is for the Agent table.

   Full or relative path is allowed.

c. **<Second input file>:**
   If the first file contained Agent data, the second file must contain Skill Group Member data. If the first file contained Skill Group Member data, the second file must contain Agent data.

   If no files contain headers, it is assumed that Agent data is in the first file and Skill Group Member data is in the second file. If headers are provided, the files may be specified in either order.

   Full or relative path is allowed.
d. <Option>:

/show Only - show configuration changes without committing to the database.
/nodelete - the tool will not perform any delete operations. All inserts and updates will be saved.

Example:

1. AgentCfg.exe peripheral1 c:\temp\agentData.txt c:\temp\skillGrpMemData.txt
   This example will configure both agent and skill group member data for peripheral1.

2. AgentCfg.exe peripheral1 c:\temp\skillGrpMemData.txt
   This example will configure skill group member data for peripheral. The file must contain header information.

Step 4

When the system software invokes the AgentCfg command, it performs the following steps for each line in the input file:

The following steps are performed for each line in the input file:

1. The system software attempts to match the PeripheralNumber value to a configured agent for the peripheral.

   If it finds a match, it proceeds directly to step 2.

   If it cannot find a match, it creates a new agent row in the database using the data from the input file, and proceeds to step 2.

2. The system software checks to see if the "temporary" flag is set. If it is, it then updates the existing record.

3. The system software checks whether the peripheral name values also match.

   If the FirstName and LastName values match, then the system software updates the existing record with the given Description and PeripheralName values. (If the existing record was for a temporary agent, the agent is no longer temporary after the update.)

   If the values do not match, then the system software marks the existing record as deleted and inserts a new row with the data from the input file. If an agent is configured for the peripheral in the database, but is not listed in the input file, then the system software marks the agent as deleted in the database.

4. The system software does a loop through the Skill Group Member input file container and compares the records in file and those in database:

   - If the record is found in file but does not exist in the database, the record is inserted.
   - If the record is found in the database but does not exist in the file, the record is deleted.
Input File Formats

When using the AgentCfg.exe tool to import data, the input files must be formatted as described below. Note that the `_TABLE` and `_COLUMNS` and the line below each is considered the header. The header is not always required. The beginning of this section indicates when the headers are needed.

**Agent Configuration Data File**

The input file must contain the list of all the agents configured on the ACD for that peripheral in the following format:

```plaintext
_TABLE
Agent
Indicates the name of the table to which the data will be configured. The table name is always *Agent* (do not change this line).

_COLUMNS
Indicates the tab delimited column names corresponds to the data values (do not change this line). The columns need to be in the order as shown below:

<table>
<thead>
<tr>
<th>PeripheralNumber</th>
<th>FirstName</th>
<th>LastName</th>
<th>Description</th>
<th>PeripheralName</th>
</tr>
</thead>
<tbody>
<tr>
<td>1045</td>
<td>F1045</td>
<td>L1045</td>
<td>Auto Configured by Router</td>
<td>F1045.L1045</td>
</tr>
<tr>
<td>1046</td>
<td>F1046</td>
<td>L1046</td>
<td>Auto Configured by Router</td>
<td>F1046.L1046</td>
</tr>
<tr>
<td>1047</td>
<td>F1047</td>
<td>L1047</td>
<td>Auto Configured by Router</td>
<td>F1047.L1047</td>
</tr>
</tbody>
</table>
```

The following indicates the tab delimited data values correspond to the column names:

```
1045<F1045<L1045<Auto Configured by Router>F1045.L1045
1046<F1046<L1046<Auto Configured by Router>F1046.L1046
1047<F1047<L1047<Auto Configured by Router>F1047.L1047
```

**Skill Group Member Configuration Data File**

Note that the `_TABLE` and `_COLUMNS` and the line below each is considered the header. The header is not always required.

The input file contains the list of all the skill group member data as a relation between skill group and agents, which configured on the ACD for that peripheral in the following format:

```plaintext
_TABLE
Skill_Group_Member
```
Indicates the name of the table to which the data will be configured. The table name is always `Skill_Group_Member` (do not change this line).

**_COLUMNS**

Indicates the tab delimited column names corresponds to the data values (do not change this line). The columns need to be in the order that has been shown below.

```
SkillGroupEnterpriseName <tab> AgentPeripheralNumber
SkillGroupEnterprise1<tab>1045  SkillGroupEnterprise2<tab>1046
SkillGroupEnterprise1<tab>1046
```

SkillGroupEnterpriseName is the EnterpriseName of the skill group, which the agent belongs to.

AgentPeripheralNumber is the agent's login ID assigned at the switch, which is the same as the above Agent Peripheral Number.

The following indicates the tab delimited data values correspond to the column names:

```
SkillGroupEnterprise1<tab>1045
```

**Enterprise Data**

Within a script, you often want to examine a set of possible targets on different peripherals before deciding where to send the call. For example, if you are routing a sales call, you might want to check the Sales skill groups at each call center to find which has the longest available agent or shortest expected delay.

An enterprise service is a set of services that can be referenced in a script. The individual services can be associated with different peripherals. Similarly, an enterprise skill group is a set of skill groups that can be referenced in a script. The individual skill groups can be associated with different peripherals.

In addition to using them within a script, you can track enterprise services and enterprise skill groups through monitoring screens and reports. This allows you to easily follow the performance, for example, of all Support services within the system.

For information on monitoring screens and reports, refer to the *CTI OS Supervisor Desktop User Guide for Cisco Unified Contact Center Enterprise & Hosted*.

If your system has partitioning enabled, each enterprise service and enterprise skill group is associated with a specific business entity. If partitioning is not enabled, you can ignore the Business Entity field.

**Enterprise Services**

Within a routing script, you can use an enterprise service as a shorthand for a set of services. You might want to scan several services to find, for example, the service with the shortest
expected delay. Within the script, you can specify individual services to scan or, if you have an enterprise service defined, you can simply specify the enterprise service.

How to Create an Enterprise Service and Assign Specific Services

Follow these steps to create an enterprise service and assign specific services:

**Step 1** In the Configuration Manager menu, select **Tools > List Tools > Enterprise Service List**. The Enterprise Service List window appears.

**Step 2** In the Select filter data box, select the filters you want and click the Members tab. This enables the Add button and lists the currently defined enterprise services for the selected business entity(s).

**Step 3** Click Add.

**Step 4** In the Attributes tab, enter values for the following fields:

   a. **Name.** A name for the enterprise service. This name must be unique among all enterprise services in the system

   b. **Business Entity.** If partitioning is enabled, the business entity to which the enterprise service belongs.

   c. **Description.** Any other information you want about the enterprise service. Any other information you want about the enterprise service.

**Step 5** Click Save to save the changes.

**Step 6** Click the Members tab.

**Step 7** In the Members tab, click Add.

**Step 8** In the Add Enterprise Service Member dialog, select the services you want to add and click OK. The dialog closes and the selected services are listed as members in the Members tab.

**Step 9** When done, click Save to save the changes.

Enterprise Skill Groups

Just as you can use an enterprise service as a shorthand for a collection of services, so you can use an enterprise skill group as a shorthand for a collection of skill groups. The skill groups can be defined on different peripherals.

How to Create an Enterprise Skill Group

Follow these steps to create an enterprise skill group:
Step 1
In the Configuration Manager menu, select **Tools > List Tools > Enterprise Skill Groups List**. The Enterprise Skill Group List window appears.

Step 2
In the Select filter data box, select the filters you want and click **Retrieve**. This enables the **Add** button and lists the currently defined skill groups for the selected business entity(s).

Step 3
Click **Add**, and in the **Attributes** tab, enter values for the following fields:

   a. **Name**. A name for the enterprise skill group. This name must be unique among all enterprise skill groups in the system.

   b. **Business Entity**. If partitioning is enabled, the business entity to which the enterprise skill belongs.

   c. **Description**. Any other information about the enterprise skill group.

Step 4
Click **Save** to save the changes.

Step 5
Click the **Members** tab.

Step 6
In the Members tab, click **Add**.

Step 7
In the Add Enterprise Skill Group Member dialog, select the skill groups you want to add and click **OK**. The dialog closes and the selected skill groups are listed as members in the Members tab.

**Note:** The Skill Group list includes base skill groups as well as primary and secondary groups for those switches that support them. Typically, add either the base group or the associated primary and secondary groups, but not all three, to the enterprise skill group.

Step 8
Click **Save** to save the changes to the database.
Chapter 8

Configuring Routes and Routing Targets

This chapter describes how to configure the information that routing clients use to interpret the response from the system software and route the call to its destination.

It includes:

• An overview of the routes and targets subsystem
• Information on how to configure routes, network targets, and labels
• A discussion of mapping labels to dialed numbers
• Information about service arrays
• Instructions for using the Application Wizard
• A discussion of default route and default label
• Information about scheduled targets and translation routes

This chapter contains the following topics:

• The Routes and Target Subsystem, page 150
• Route Configuration, page 152
• Network Targets, page 154
• Announcement Configuration Information, page 156
• Labels, page 157
• Service Arrays, page 161
• Application Wizard, page 163
• How to Use the Application Wizard, page 163
• Scheduled Targets, page 167
• Translation Routes, page 170
• Translation Route Wizard, page 171
The Routes and Target Subsystem

For every routing request it processes, the system software determines an announcement to be played to the caller, a route for the call, or a special action such as ring-no-answer or signal busy.

To see the elements of the routes and targets subsystem and the order in which you must define them, see the following figure (page 150). Note that elements in this subsystem depend on elements defined in the routing client and peripheral subsystems. For example, you must define a network trunk group and trunk group, which are part of the peripheral subsystem, before you can define a peripheral target.

*Figure 40: Routes and Target subsystem*

For information on defining routing clients and dialed numbers, see the "Configuring Routing Clients (page 69)" section. For information on defining trunk groups, see the "Configuring Peripherals and Trunk Groups (page 85)" section. For information on defining services and skill targets, see the "Configuring Skill Targets (page 113)" section. This section describes the relationship between the elements in the Routes and Targets subsystem and how to configure them.
Cisco Unified Intelligent Contact Management Routing Targets

The system software can route a call to a carrier resource such as an announcement or to a target at a peripheral. A peripheral, such as an ACD, PBX, or Unified CM dispatches calls within a contact center.

Peripheral Targets

Depending on the capabilities of the peripheral and the type of routing instructions you use, the system software might choose a specific agent at the peripheral to handle the call. In that case, the peripheral merely dispatches the call to the chosen agent. In other cases, the system software might specify only a group of agents or a type of service to be provided to the caller.

The system software can route to three types of peripheral targets:

- **Agent.** A specific individual who receives calls through the peripheral. (The system software, however, cannot guarantee that the specific agent will be available when the call arrives.) The Queue to Agent node allows the targeting of a task (the work performed by an agent) to a script-specified agent. This node enables an agent to receive and operate on more than one task at a time.

- **Skill group.** A group of agents who share a common set of skills and who can, therefore, all handle specific types of calls. Each skill group contains one or more agents. If supported by the peripheral, each agent can be a member of more than one skill group.

- **Service.** A type of processing the caller requires. For example, a peripheral might have services defined for sales, technical support, or opening new accounts. Each service has one or more skill groups whose members can provide the service. Each skill group can be associated with more than one service.

In the last two cases, the peripheral must choose a specific agent within the group who can provide the service. In each case, the peripheral plays a key role in completing the routing that the system software has determined. Therefore, the system software and the peripheral must be set up to complement each other. They must have the same understanding of the agents, skill groups, and services available at each site.

For specific information about how the system software routes a call and its coordination with peripherals, see the "How Routing Works (page 11)" section.

Scheduled Targets

Some routing clients also support *scheduled targets.* A scheduled target is a group of agents not associated with a Peripheral Gateway. The system software cannot monitor the group directly. Instead it relies on a periodic schedule to determine the number of agents logged on to the group. The routing client informs the system software when a call to the group ends. Since the system software knows how many calls it has routed to the group, it can determine the number of calls in progress. Based on this and the schedule, the system software can determine whether the target can handle an additional call.
Route Configuration

A route consists of two components:

- The skill target (agent, skill group, service, translation route, or service array) at a peripheral which can handle a call.
- The service by which the peripheral classifies the call.

**Note:** You must have defined the skill target and service before you can configure a route. Follow the steps in the Configuration Manager's Step by Step Configuration menu when configuring your Unified ICM system.

How to Define and Update a Route

In the Configuration Manager, you can define and update many routes at a time using the Route Bulk tool. Or you can create and update a route using one of the following Explorer tools:

- Agent Explorer
- Skill Group Explorer
- Service Explorer
- Service Array Explorer
- Translation Route Explorer

With the Explorer tools, you can define and update a route at the same time you define and update its target. You can access all the tools for creating routes from the Configuration Manager's ICM Configure > Targets > Route menu. (See the following figure (page 153).)
How to Define or Modify a Route

Use the Configuration Manager's Route Bulk tool to create multiple routes. To create individual routes, use the Configuration Manager's Explorer tool appropriate for the route target. Follow the instructions in the online help.

The following instructions apply in general to all the Explorer tools dealing with routes.

**Step 1**  
In the appropriate Explorer window:

- To define a new route, select the target for which you are creating the route and click Add Route.

- To modify a route, select the route.

**Step 2**  
In the Route tab, enter values for the following fields:

- **Name.** A unique name for the route. You might derive the name for the route from the skill target and service associated with it. For example, you might have a route associated with the Dallas.TeleSales service and the Dallas.Sales skill group. You might name the route Dallas.TS_Sales.
• **Description.** Text identifying the route.

• **Service name.** (selection list) Every route must be associated with a service. By choosing a service, you are implicitly associating the route with the peripheral for that service. For a new route, the drop-down list contains all the services defined for the selected peripheral (or PG, in the case of a service array).

To assign the route to another service, in the tree list, drag it to the desired peripheral. You can also move the route to the UNASSIGNED list.

**Warning:** When you break the association between a route and a peripheral, the system software removes the Route ID value from all peripheral targets that reference that route.

**Step 3** Click **Save.** The system software saves your changes in the database.

---

**How to Set a Default Route for a Peripheral**

After you have defined routes, you can set a default route for each peripheral. The system software uses the default route to classify calls for statistical purposes.

For each call that arrives at a peripheral, the system software records monitoring information in the real-time and historical tables for the route associated with that call. If the system software cannot determine a route for the call, it uses the default route defined for the peripheral.

By defining a default route for each peripheral, you ensure that the system software captures route information for every call. You might want to create a special route for this purpose. You can then determine which calls are not being accounted for properly.

**Step 1** In the Configuration Manager menu, select **Tools > Explorer Tools > PG Explorer.** The PG Explorer window appears.

**Step 2** In the tree list window, select the peripheral you want to modify and click the **Advanced** tab.

**Step 3** In the Default route field, select the enterprise name of a route from the selection list. The list includes all routes associated with skill targets at the chosen peripheral.

**Step 4** After choosing the route, click **Save** to enter your edits into the database.

---

**Network Targets**

Routing clients do not send calls directly to services, skill groups, or agents. They send each call to an announcement or to a specific trunk group at a peripheral. If the call is sent to a trunk group, the routing client can also send a DNIS value for the call. The combination of trunk group and DNIS value is a **peripheral target.**
You must define the announcements and peripheral targets that the routing clients use. These are called network targets. Later, you can associate a routing label with each network target.

How to Define Peripheral Targets

A peripheral target is a combination of a network trunk group and a DNIS value. You must work with your interexchange carrier or other routing client to set up the trunk groups on which you expect to receive calls and the DNIS values that are sent with them.

**Step 1** In the Configuration Manager menu, select Configure ICM > Targets > Target from the menu bar.

The resulting menu (see the following figure (page 155)) gives you the option of creating multiple peripheral targets, using the Peripheral Target Bulk configuration tool or creating a peripheral target for a service, a service array, a skill group, a translation route, or an agent. Select the appropriate tool for your needs.

**Step 2** Use the online help if you have questions.

**Step 3** When finished, click Save.

---

Figure 42: Configuration Manager's Target Submenu

Configuration Guide for Cisco Unified ICM/Contact Center Enterprise and Hosted Release 8.0(2)
Announcement Configuration Information

You must provide information about any announcements to which you want to route calls. You must work with the interexchange carrier or other routing client to set up announcements within the network and assign labels to them. You can then enter information about the labels into the Unified ICM system.

**Note:** If you have a Sprint routing client, the system software automatically configures an announcement named NPA Blocked Recording.

How to Add Announcement Configuration Information

To add announcement configuration information, proceed along the following steps:

**Step 1**  
In the Configuration Manager menu, select **Tools > Explorer Tools > Announcement Explorer.** The Announcement Explorer window appears.

**Step 2**  
Click **Retrieve.** This enables the **Add Announcement** button.

**Step 3**  
Click **Add Announcement.**

**Step 4**  
In the Announcement tab, enter values for the following fields:

- **Name.** A unique name for the announcement.

- **Description.** Text identifying the announcement.

**Note:** You have the option of saving at this point and then adding the label information in the following step.

**Step 5**  
To associate a label with the announcement:

- In the tree list window select one from the UNASSIGNED group and drag it to the announcement.

**Note:** A description of the Label tab fields and buttons can be found in the online help.

**Step 6**  
Click **Save** to save the announcement configuration settings. The system software automatically generates a unique Network Target ID value.
Labels

After defining announcements and peripheral targets, you must define the labels that your routing clients use to reference network targets. The label is the value that the system software returns to the routing client. The routing client then translates the label to an announcement or peripheral target (trunk group and DNIS) that the peripheral will convert to the skill target and service you specify.

Note: For an AT&T ICP connection, the system software treats a CRP code as a label.

Label Types

In defining a label, you must specify a label type by selecting an option from the Type drop-down list in the Label Configuration selection box.

Note: Each label you define is valid only for a specific routing client; not all label types are valid for all types of routing clients. Check with your carrier for the latest information about supported label types.

The "Supported Label Types (page 157)" table lists the configured label types the system software supports. In addition to these labels, a script can create a dynamic label, which is defined in realtime through a script expression and then passed to a routing client.

Table 41: Supported Label Types

<table>
<thead>
<tr>
<th>Label Type</th>
<th>Description</th>
<th>Routing Clients</th>
<th>How to Send Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Maps to a trunk group and DNIS or announcement defined by the routing client.</td>
<td>All</td>
<td>Specify an associated route in a routing script target.</td>
</tr>
<tr>
<td>DNIS Override</td>
<td>Sends a value along with the label that overrides the DNIS value of the routing client.</td>
<td>MCI</td>
<td>Specify an associated route in a routing script target.</td>
</tr>
<tr>
<td>Busy</td>
<td>Plays a busy signal for the caller.</td>
<td>All</td>
<td>Use a Busy or Termination script node.</td>
</tr>
<tr>
<td>Ring</td>
<td>Plays an unanswered ring for the caller.</td>
<td>AT&amp;T GTN</td>
<td>Use a Ring or Termination script node.</td>
</tr>
<tr>
<td>Post-Query</td>
<td>Specifies a re-entry point in the network routing plan. The routing client begins processing the routing plan from that point.</td>
<td>All</td>
<td>Use a Return Label script node.</td>
</tr>
</tbody>
</table>

The Normal and DNIS Override types are used for peripheral targets (and hence, for routes) or for announcements. Busy, Ring, and Post-Query labels are not associated with any target in the Unified ICM configuration. The routing client uses its own special targets for labels of these types.
For more information on targets within scripts, refer to the Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.

Special Sprint Labels

Sprint routing clients require two special labels to support the Busy feature and the NPA Blocked Recording feature:

- A Busy label named @Slow Busy.
- A Normal label named @NPA Blocked Recording. The target for this label must be the NPA_Blocked_Recording announcement.

When you use the NIC Explorer to set up a Sprint routing client, the system software creates these labels automatically. (It also automatically creates the NPA_Blocked_Recording announcement, if necessary.)

The label names @Slow Busy and @NPA Blocked Recording are reserved for this specific use. You must not create any other labels with these names.

Creating Labels

To set up a label, you create configuration information and associate the label with a network target.

How to Create a Label

To create a label, follow these steps:

1. In the Configuration Manager menu, select Configure ICM > Targets > Label.
2. This displays the following menu options for configuring a label:
   - Label Bulk
   - Label List
   - Service Explorer
   - Service Array Explorer
   - Skill Group Explorer
   - Translation Route Explorer
   - Agent Explorer
   - Announcement Explorer
• Network VRU Explorer

**Step 3** Select the tool you need:

• Use the Label Bulk tool to configure many labels at a time.

• Use the Label List tool to configure individual labels for any network targets.

• Use the preceding Explorer tools to configure labels for a specific network target (services, service arrays, skill groups, translation routes, agents, announcements, network VRUs).

**Step 4** Enter values for the following fields. Use the online help if you have questions:

• **Routing Client.** (required) The enterprise name of the routing client that can receive this label.

• **Label.** (required)

  The literal string of characters to be returned to the routing client.

• **Label Type.** (required)

  The type of label. The valid types depend on the type of the routing client. For more information, see the descriptions of label types in the "Supported Label Types (page 157)” table.

• **Target type**

  (selection list) Indicates the type of the network target associated with the label: Network Announcement, PBX/ACD Peripheral (that is, a peripheral target), a device target, a scheduled target, or a network VRU.

  **Note:** The Target type is a filter for the Network target field. The Target type selected is not retained unless a Network target is selected.

• **Network target.** (list and bulk tools only)

  (selection list) Indicates the announcement, peripheral target, or scheduled target associated with the label.

• **Customer.** (list and bulk tools only)

  The customer associated with the label.

• **Description.** Any other information you want about the label.

  The Valid Label Targets (page 159) table lists which targets are valid for each label type.
### Table 42: Valid Label Targets

<table>
<thead>
<tr>
<th>Label</th>
<th>ACD/PBX</th>
<th>Network Announcement</th>
<th>Scheduled Target</th>
<th>Network Device</th>
<th>Network VRU</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Valid</td>
<td>Valid</td>
<td>Valid</td>
<td>Valid</td>
<td>Valid</td>
</tr>
<tr>
<td>DNIS Override</td>
<td>Valid</td>
<td>Valid</td>
<td>Valid</td>
<td>Valid</td>
<td>Valid</td>
</tr>
<tr>
<td>Busy</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>Valid</td>
</tr>
<tr>
<td>Ring</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>Valid</td>
</tr>
<tr>
<td>Post-Query</td>
<td>Valid</td>
<td>—</td>
<td>Valid</td>
<td>Valid</td>
<td>Valid</td>
</tr>
</tbody>
</table>

Step 5 Click Save.

### Mapping Labels

For some routing clients, all labels are valid for all dialed number/script selectors. For other routing clients, you must specify which labels are valid for each dialed number/script selector. You specify whether the mapping of labels to dialed number/script selectors is necessary when you configure the routing client. For more information on this, see the "Configuring Routing Clients (page 69)" section.

### How to Map Specific Labels to a Dialed Number/Script Selector

To map specific labels to a dialed number/script selector, follow these steps:

**Step 1** In the Configuration Manager menu, select Tools > List Tools > Dialed Number/Script Selector List. The Dialed Number/Script Selector List window appears.

**Step 2** Select the filters you want and click Retrieve. The enterprise names for the retrieved dialed number/script selectors are listed in the list box.

**Step 3** Select the enterprise name for the dialed number/script selector you want.

**Step 4** Click the Dialed Number Label tab.

The Name column displays a list of all labels currently associated with that dialed number/script selector.

**Note:** For a call associated with this dialed number/script selector, the system software can return only labels assigned to the dialed number/script selector.

**Step 5** Click Add.

**Step 6** In the Add Label dialog, select a label name and click OK.

**Note:** For labels to appear in this dialog selection box, they must have been previously defined for the selected dialed number/script selector’s routing client. Use the Label List tool to define labels.
Step 7  Click Save.

How to Set a Default Label for a Dialed Number/Script Selector

After you have defined labels, you can set a default label for each dialed number/script selector. If the system software fails to find a label by running the routing scripts for the call type, it uses the default label for the dialed number/script selector.

You can use the Configuration Manager’s Dialed Number Bulk tool to configure many dialed number/script selectors at a time or the Dialed Number/Script Selector List tool to configure one at a time. The following instructions show how to use the Dialed Number/Script Selector List tool.

Step 1  In the Configuration Manager’s menu, select Tools > List Tools > Dialed Number/Script Selector List. The Dialed Number/Script Selector List window appears.

Step 2  Select the filters you want click Retrieve. The enterprise names for the dialed number/script selector(s) retrieved are listed in the list box.

Step 3  Select the dialed number/script selector you want and click the Attributes tab.

Step 4  In the Default label field, select the enterprise name of a label from the selection list. This list includes all labels associated with the same routing client as the dialed number/script selector.

Step 5  After choosing the label, click Save.

Note: Within a routing script, you can explicitly invoke the default label for the current dialed number/script selector by using a Termination node.

Service Arrays

Service arrays are closely tied to network trunk groups. Typically, you use service arrays in cases where:

- You have similar peripheral services defined on multiple VRUs.

- VRUs all share the same network group.

By grouping the services of multiple VRUs into a service array, you can send calls to a single target (a service array) and let the network deliver the call to any one of the peripheral services that make up the service array. For example, if several VRUs each support a Quotes service, you can define a Quotes service array for those services.
How to Configure Service Arrays

To configure service arrays, proceed along the following steps:

**Step 1**
In the Configuration Manager menu, select **Configure ICM > Targets > VRU Service Arrays > Service Array Explorer**. The Service Array Explorer window appears.

**Step 2**
In the Select filter data box, select the appropriate filters and click **Retrieve**. This enables the **Add Service array** button and displays a list of all currently defined service arrays associated with the selected PG.

**Step 3**
You can define a new service array or modify an existing one:

- To set up a new service array, click **Add Service array**.

  **Note:** To create subsequent service arrays for the same PG, select the PG in the tree list window and then click **Add Service array**.

- To modify an existing service array, select it in the tree list window.

**Step 4**
In the **Service Array** tab for the selected service array, enter values for the following fields:

- **Name.** A unique name for the service array.

- **Description.** Additional information about the service array.

**Step 5**
Click the **Members** tab.

This tab lists the services that are current service array members of the selected PG.

- To add service members, click **Add**. Then in the Add Service Member window, select the name of a service from the list of available records and click **OK**. The Available records list contains all the services connected to the peripherals associated with the selected PG.

- To remove a service member, select it in the list and click **Remove**.

**Step 6**
Add or modify a route associated with the service array:

- To add a route, select the service array in the tree list box, and click **Add Route**. Or in the tree list box, select a route from the UNASSIGNED group and drag it to the service array. Then in the **Route** tab, enter or modify the Name and Description.

- To modify the route, select it in the tree list box, and modify the Name and Description in the **Route** tab.

**Step 7**
Add or modify one or more peripheral targets for the route:

- To add a peripheral target, select the route and click **Add Peripheral target**. Or in the tree list box, select a peripheral target from the UNASSIGNED group and drag it to the route. Then in the Peripheral target tab, enter the following:
– **DNIS**. The DNIS value for the peripheral target. The routing client delivers this value to the trunk group along with the call.

– **Description**. Any additional information about the DNIS value.

– **Network trunk group**. The group on which to deliver calls for the service array.

**Step 8**

To add or modify a label for the peripheral target:

- To add a label, select the peripheral target in the tree list box, and click **Add Label**. Or in the tree list box, select a label from the UNASSIGNED group and drag it to the peripheral target. Then in the Label tab, enter or modify the following:

  – **Routing client**. The enterprise name of the routing client that can receive this label.

  – **Label**. The literal string of characters to be returned to the routing client.

  – **Label type**. The type of label. The valid types depend on the type of the routing client. For more information, see the descriptions of label types in the "Supported Label Types (page 157)" table.

  – **Description**. Any additional information about the label.

- To modify the label, select it in the tree list box, and modify the preceding fields in the **Route** tab.

**Step 9**

Click **Save** to save the changes to the database.

**Step 10**

Click **Close** to close the Service Array Explorer.

---

**Application Wizard**

The Application Wizard provides an alternate method for defining labels, peripheral targets, and routes and associating them with services at a peripheral.

Before starting the Application Wizard, you must have defined the routing client, peripheral, network trunk groups (and associated trunk groups), and services to be used. Within the Application Wizard you can create dialed numbers, labels, peripheral targets, and routes.

**Note:** The Application Wizard does not allow you to associate routes and targets with skill groups or agents. It allows you to target only services.

**How to Use the Application Wizard**

To use the Application Wizard, follow these steps:
**Step 1**  
In the Configuration Manager menu, select **Tools > Wizards > Application Wizard**. The Routing window appears.

**Step 2**  
Choose the type of application you want to set up (Pre-Routing or Post-Routing) and click **Next** to continue. The Routing Client and Dialed Number window appears, displaying information about all the configured routing clients of the type you selected.

*Figure 43: Application Wizard - Routing Client and Dialed Number*

**Step 3**  
Specify the following:

- **Routing Client.** Click to select one or more routing clients for the application. (A check mark to the left of the routing client indicates it is selected.)

- **Dialed Number.** Click the row and select a number from the drop-down list or enter a new dialed number value.

*Note:* You must specify a dialed number for each routing client selected.

**Step 4**  
Click **Next**. The Peripheral window appears.
Step 5 Specify the following:

- **Peripheral.** Click to select one or more peripherals to which you want the application to deliver calls.

- **Number of Network Trunks.** The number of network trunk groups to be targeted at each peripheral.

Step 6 Click **Next.** The Network Trunk Group window appears, displaying the peripherals and routing clients you have previously selected.

Step 7 For each row, specify the following:

- **Network Trunk Group.** Click the row and select from the drop-down list.
• **# DNIS**. The number of peripheral targets (DNIS values) to define for each network trunk group.

**Step 8**
Click *Next*. The Route DNIS and Label window appears.

*Figure 46: Application Wizard—Service, Route, DNIS and Label*

For each network trunk group, specify the following:

• **Label**. (This value does not have to be defined in the Unified ICM database.) The value the system software returns to the routing client to indicate the destination of the call.

• **DNIS**. (This value does not have to be defined in the Unified ICM database.) The value the routing client sends to the network trunk group to indicate the destination of the call.

• **Service Peripheral Name**. Click the row and select a predefined service at the peripheral from the drop-down list.

• **Route**. Name of the route to be associated with the service. Select from the drop-down list or enter a new route name.

**Step 10**
Click *Next*. The Application Wizard displays a dialog listing the changes that will be made to the Unified ICM database.

**Step 11**
Click *Finish* to save the changes and exit the Application Wizard.
Scheduled Targets

A scheduled target is a special type of destination for a call. The system software has only limited information about a scheduled target: the number of calls that the target can handle simultaneously and the number of calls currently in progress at the target.

**Note:** Scheduled targets are only available for NICs that use intelligent network support. These include CRSP, INAP (CS-1 and CS-2), Carrier AIN, and CWC routing targets.

The system software determines the number of calls the target can handle by referring to a periodic schedule associated with the target, as shown in the following figure (page 167).

*Figure 47: A Scheduled Target with Multiple Periods*

The system software determines the number of calls in progress based on the number of calls it has sent and the number of calls that have ended. (The routing client must inform the system software each time a call at the target ends.)

The system software evaluates the periods in the order listed in the Schedule Periods dialog. (You can use the up and down arrow buttons to change a period's position within the list.)

You can also associate the scheduled target with previously defined routing labels.

For information on defining routing labels, see the "Labels (page 157)" section. For information about referencing scheduled targets in a routing script, refer to the *Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted*.

Use the Scheduled Target Manager to configure a scheduled target and associated schedule.
How to Create a New Scheduled Target

To create a new scheduled target, follow these steps:

**Step 1**  
In the Administration Data Server group or the Administration Client group, click the **Scheduled Target Manager**. The Scheduled Target Manager dialog appears, listing any scheduled targets that have been previously defined.

**Step 2**  
Click **New**. The New Scheduled Target dialog appears.

*Figure 48: New Scheduled Target*

![New Scheduled Target](image)

**Step 3**  
Enter a name for the target and, optionally, a description. If you are using partitioning, choose the business entity for the target.

**Step 4**  
Click **Finish** to create the scheduled target and return to the main window.

**Step 5**  
Click **Exit** to close the Scheduled Target Manager.

How to Create a New Schedule Period for a Target

To create a new schedule period for a target, proceed along the following steps:

**Step 1**  
Within the Scheduled Target Manager main window, click **View**. The Scheduled Targets dialog appears.
**Step 2**  Click **Add Period**. The Periodic Schedule Information dialog appears.

**Step 3**  Specify the following:
• **Date Range.** A starting date for the period and, optionally, an end date.

• **Recurrence Pattern.** Which days the schedule applies to.

  **Note:** For details about the choices for the Recurrence Pattern fields, refer to the discussion of script scheduling in the *Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted*. The options for periodic schedules are the same as for script schedules.

• **Duration.** The time range for the schedule period.

• **Data.** The maximum number of calls in progress the target that can handle during the specified period.

**Step 4** Click **OK** to save the period information and return to the Scheduled Target dialog.

**Note:** None of the periods you have added or changed are saved until you click the Scheduled Target’s **OK** button.

**Step 5** Click **Exit** to close the Scheduled Target Manager.

---

### How to Associate Labels with a Scheduled Target

To associate labels with a scheduled target, follow these steps:

**Step 1** Within the Scheduled Target Manager main window, click **Associate Label.** The Associate Label dialog appears, displaying a list of labels not currently associated with a target.

**Step 2** Choose a label from the list and click **OK** to save the label and return to the Scheduled Target Manager dialog.

**Step 3** Repeat Steps 1 and 2 to associate additional labels with the scheduled target.

**Step 4** Click **OK** in the Scheduled Target dialog to save the changes you have made and return to the Scheduled Target Manager main window.

**Step 5** Click **Exit** to close the Scheduled Target Manager.

---

### Translation Routes

A translation route is a special destination for a call that allows you to deliver other information along with the call. You do this by delivering the call first to the translation route. While the routing client is processing the call, the system software delivers the final destination for the call to the Peripheral Gateway along with any other necessary information. The peripheral then works with the PG to reroute the call to the ultimate target and ensure that the appropriate information is also delivered.
A single translation route can be used to send information to any number of different targets. However, because the PG must uniquely identify the call, you cannot perform translation routing on two calls to the same peripheral target simultaneously. To avoid this, you typically define a set of peripheral targets, and routes, for each translation route.

Translation Route Wizard

You can define translation routes within the Configuration Manager. However, defining the correct associations with peripheral targets, labels, and routes is complicated. To automate much of the process, use the Translation Route Wizard.

**Note:** You can also use the Translation Route Wizard to view configuration or integrity reports on translation routes, update existing translation routes, or to delete translation routes and their associated entities.

How to Create a Translation Route

To create a translation route, follow these steps:

**Step 1**  In the Configuration Manager, select **Tools > Wizards > Translation Route Wizard**. The Translation Route Wizard introductory dialog opens.

**Step 2**  Click **Next**. The **Select Configuration Task** dialog appears.

**Step 3**  To create a translation route, choose **Create New** and click **Next**. The Define Translation Route dialog appears.

![Figure 51: Define Translation Route](image)
Note: The graphic on the left of the dialog shows the entities you will be defining while using the Translation Route Wizard.

**Step 4**

Enter a long and short name for the translation route and, optionally, a description — the short name is used in forming target names — and click **Next**. The Select Configuration dialog appears.

*Figure 52: Select Configuration*

**Step 5**

Use the drop-down list to choose the configuration. The graphic changes to show the configuration you select.

Note: A translation route can be associated with a single peripheral or with multiple VRUs associated with a single PG. It can handle calls originating from a single routing client or from multiple routing clients. (The Multiple ACD type is not currently supported.)

**Step 6**

Click **Next**. The Select Peripheral Gateway, Peripherals, and Services dialog appears.
Step 7 Specify the following:

- **Peripheral Gateway.** (scrolling list) The gateway target for the translation route.
- **Peripheral.** (scrolling list) The single peripheral or the peripheral to route calls to.
- **Service/Service Array.** (scrolling list) If the translation route is associated with a single peripheral, then select the service associated with the translation route. If the translation route is associated with multiple VRUs, then select a service array.

Step 8 Click Next. The Select Routing Clients and Dialed Numbers appears.
Use this dialog to specify the routing client or routing clients from which translation routed calls originate. For each routing client, you can also specify which specific dialed numbers are used for translation routed calls.

**Step 9**  
Select a routing client from the Pre-Routing Client list or the Post-Routing Client list. The Dialed Number lists updates to show the dialed numbers associated with the selected routing client.

**Step 10**  
Select a dialed number you want to use with the translation route and click the **Add** button. The number appears in the list at the bottom of the dialog. The Translation Route Wizard will map the translation route’s labels to each of these dialed numbers.

**Note:** Some routing clients do not require mappings of labels to specific dialed numbers. The Dialed Number list is automatically disabled for such routing clients. You need only select the routing client and click the **Add** button to add it to the list. You can also use the Disable Dialed Number Selection option to manually disable the Dialed Number list. The Translation Route Wizard will then not create mappings of dialed numbers to labels for the routing client.

**Step 11**  
Click **Next**. The Select Network Trunk Groups for Routing Clients dialog appears.
For each routing client you have selected, you must select at least one network trunk group to be used in peripheral targets associated with the translation route.

**Step 12**  Select a routing client, select a network trunk group value for it, and click **Add**. The Network Trunk Group appears in the list at the bottom of the dialog.

**Step 13**  Click **Next**. The Configure DNIS dialog appears.
Use this dialog to specify the DNIS values to be used in peripheral targets associated with the translation route.

**Step 14**

Do one of the following:

- To enter a specific DNIS value, click **Add DNIS** and enter the value.
- To add a range of DNIS values, typically required by a translation route, click **Add DNIS Range**. A dialog prompts you to enter a starting and ending DNIS value. The Translation Route Wizard automatically generates the DNIS values in the range.

**Note:** DNIS values with leading zeroes, while valid, are different from DNIS values without leading zeroes. For example, 400, 0400, and 00400 are three different and unique DNIS values.

**Step 15**

Click **Next**. The **Configure Label** dialog appears.

**Step 16**

Do one of the following:

- Enter prefixes and suffixes individually.
- Use the buttons in this dialog to set a range of values or to base the prefix or suffix values on the DNIS values.

**Step 17**

Click **Next**. The **Wizard Complete** dialog appears.
Step 18  Click **Create Translation Route** to create the translation route and its associated entities. First, the Translation Route Wizard displays a success message and then the dialog appears as follows.

Step 19  Do one of the following:

- To see details about the translation route you just created, click **Run Report**.
• To return to the beginning of the Translation Route Wizard and perform a new task, select Start New Task and click Finish.

• To exit the Translation Route Wizard, click Finish.
Chapter 9

Configuring Cisco Unified Intelligent Contact Management Software for Integrated Applications

These instructions provide information for installing and configuring Unified ICM Release 8.0 software as part of a system integrated with the integrated applications.


For additional information about the system software, refer to the Cisco web site (http://www.cisco.com) listing Unified ICM documentation: http://www.cisco.com/web/psa/products/index.html

For a high-level overview of integrating the applications with the system software, refer to the Cisco Customer Contact Suite Implementation Map that is delivered with the system software.

Note: Important! While performing the tasks outlined in this chapter, be sure to note the system software configuration information, as you will need to enter this information when configuring the integrated applications.

This chapter contains the following topics:

- Cisco Unified Intelligent Contact Management 8.0 Software Requirements, page 179
- Configuring Cisco Unified Intelligent Contact Management Software for Integration, page 181
- Application Object Filter, page 200

Cisco Unified Intelligent Contact Management 8.0 Software Requirements

Note: Important! Do not install the system software and the integrated applications on the same machine.
Before you begin configuring the system software for the integrated applications, you must upgrade the system software.

For complete and current information on Software Requirements, refer to the Hardware & System Software Specification (Bill of Materials) for Cisco Unified ICM/Contact Center Enterprise & Hosted. The Unified ICM BOM is available at: http://www.cisco.com/univercd/cc/td/doc/product/icm/index.htm.

Refer to the Upgrade Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted for specific upgrade and installation requirements.

How to Install the Application Interface

**Note:** Important! You must install the application interface before beginning the Unified ICM configuration.

If you want your Administration & Data Server to be the point of contact for the integrated applications configuration (to host the CMS Server), you need to perform this installation.

Refer to the Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted for detailed information about the Administration & Data Server setup.

| Step 1 | Run the Web Setup tool (accessed from the Unified CCE Tools folder). |
| Step 2 | Select Component Management > Administration & Data Servers. |
| Step 3 | Edit the Administration & Data Server on which the Distributor Service is running. |
| Step 4 | On the Database and Options page, be sure to check Configuration Management Service (CMS) Node. |
| Step 5 | Finish the installation process by completing the rest of the pages, then click Finish to save your edits. |

After installing the application interface, you need to run the CMS Control tool on the installed Administration & Data Server to set up, from the Unified ICM side, the connections that allow the integrated applications to talk to that Administration & Data Server. You must also configure each application's end of the connection.

To improve performance, if no debugging is being performed using that console, keep the CMS node console minimized. If the console is not minimized, considerable CPU resources are tied up displaying numerous messages from the system I/O.

See the "Application Connections (page 193)" section for more information about using the CMS Control tool to set up the connections between the system software and the integrated applications.
Verify Pre-Integration Configuration

Verify the configuration by doing the following:

- Verify that all processes, including all PIMs and CTI servers, are active (that is, all processes start, duplexed routers load the configuration and synchronize, and all PIMs and CTI servers are active).

- Verify that the MSSQL server has started. Submit sample calls through all routing clients and all call types. Use the Call Tracer tool in the Script Editor to test router call handling functionality.

**Note:** This test must be done prior to the Unified ICM upgrade and after the Unified ICM upgrade. Address failures prior to integration.

Configuring Cisco Unified Intelligent Contact Management Software for Integration

To configure the system software for the applications, you need to configure/install the following:

- Media routing domains for appropriate media classes within the system software
- Media routing peripheral gateways (PGs) and peripherals
- ECC (Expanded Call Context) variables
- Application instance(s) and define them in the system software
- Agents (you can create agents either in the system software or in the applications)
- Connections to the CMS server using the Application tab of the CMS Control tool in the Administration Tools folder
- Configuration work on the integrated applications
- Skill group configuration using Script Editor
- Information to push to waiting Cisco Unified Interaction Manager callers

The following sections describe each of the preceding, their configuration and installation instructions, and indicate the configuration tool you need for each configuration. Refer to a configuration tool’s online help if you have any questions.

**Note:** Before using the configuration tools to perform each configuration process, if you have more than one Unified ICM instance you want to configure, open the Select Administration Instance tool in the Administration & Data Server or Administration Client and select the Unified ICM instance with which you want to work.
Media Routing Domains

To create and then assign a media routing domain to a media class (physical media that the system software treats as a single concept), use the Configuration Manager's Media Routing Domain List tool.

The system software uses Media Routing Domains (MRDs) to organize how requests from different media are routed. An MRD is a collection of skill groups and services that are associated with a common communication medium. The system software uses an MRD to route a task to an agent who is associated with a skill group and a particular medium.

Before you can configure your application (for example, the Cisco Unified Interaction Manager) to use the system software as a routing engine, MRDs must be established in the system software. These MRDs have unique IDs across the enterprise. Then, on the application, you must enable those Unified ICM Media Routing Domains that you need to use.

**Note:** Important! The MRD IDs *must* be created in the system software first, and then passed on to the person configuring the application, in order to perform a successful configuration. In Cisco Unified Interaction Manager you only need the MRD name, you do not need the MRD ID.

A media class describes the type of requests you want to set up for routing on the system software.

**Note:** Create the following media classes for Cisco Unified Interaction Manager:

- CIM_EIM
- CIM_WIM
- CIM_BC

The media class for voice already exists (Cisco_Voice).

How to Configure the Media Routing Domain

**Step 1**
Start the Configuration Manager and select **Tools > List Tools > Media Routing Domain List.**
The Media Routing Domain List window displays. Click the **Retrieve** button and then the **Add** button to display the Attributes tab.

**Step 2**
Enter the following information:

- **Name.** Enter the enterprise name of the MRD.
- **Media Class.** Use the drop-down list to select the media class for the integrated application.
- **The MRDomainID is a required read-only field.** (An ID number will be automatically created when you save your entry.)

**Step 3**
After entering the required fields, save the configuration and close the window.
Note: Refer to the Configuration Manager's online help for detailed information about the Media Routing Domain List tool.

Media Routing Peripheral Gateway (MR-PG)

To create a media routing peripheral gateway, use the Configuration Manager’s Network VRU Explorer and the PG Explorer tools.

A media routing peripheral gateway is capable of routing media requests of different kinds (for example, email, Web callback, and so on). MR-PGs support multiple media routing applications by placing multiple, independent Peripheral Interface Managers (PIMs) on a PG platform. (Set up no more than 10 PIMs per MR-PG.) A single MR-PIM is required for each application server to be connected to the Unified ICM system. In addition to an MR-PG, you also need at least one Agent PG, such as an IPCC PG, a legacy ACD PG, or a NonVoiceAgent PG. For this example, we will use an IPCC PG.

For example, the diagram below provides an overview of the interfaces that need to be configured for Unified ICM integration with Cisco Unified Interaction Manager.

![Diagram showing interfacing with Cisco Unified Interaction Manager](image_url)

Figure 60: Interfacing with Cisco Unified Interaction Manager

Configuring the MR-PG

The MR-PG interface provides routing instructions to the integrated applications, while the Agent PG configuration is used to report agent state and status to the system software.

Note: No agents are configured on MR-PGs. Agents are configured on NonVoice Agent PGs or other agent PGs.

The system software media routing mechanism leverages and takes advantage of the existing Unified ICM Network VRU operational infrastructures. In order to set up for media routing, you must configure a Network VRU in the Unified ICM configuration. This Network VRU configuration has no relationship with any actual Network VRU in your environment.
How to Configure the MR-PG

Step 1  Start the Configuration Manager. From the Configuration Manager menu, select Configure ICM > Targets > Network VRU > Network VRU Explorer. The Network VRU Explorer window displays.

Step 2  Click the Retrieve button and then click the Add Network VRU button. The Network VRU dialog displays.

Step 3  Do the following:

• Enter a name for the Network VRU (for example, Cust_MR_VRU).

• Select Type 2 from Type drop-down list.

• Optionally, enter a description (that is, Media Routing).

• Save and close the window.

Step 4  From the Configuration Manager menu, select Configure ICM > Peripherals > Peripheral > PG Explorer. The PG Explorer window displays.

Step 5  Click the Retrieve and then click the Add PG button. The Logical controller dialog displays.

Step 6  Do the following:

• Enter a name for the PG (for example, Cust_MR_PG1).

• Select MR PG as the Client Type.

Step 7  In the tree section of the window, expand the tree and click the Add Peripheral button. The Peripheral configuration dialog displays.

Step 8  Do the following:

• Select the Peripheral tab and check the Enable Post Routing box.

• Select the Advanced tab and select the previously created Network VRU from the drop-down list.

• On the Routing Client tab, enter a routing client name (for example, Cust_MR_PG1_1.RC) and set the default timeouts to 2000, 1000, and 10, respectively.

• Save the configuration. After you save the configuration, the system assigns a Logical Controller ID and a Physical Controller ID.

Note: Make a note of these values because you will need to provide them when you install the MR-PG.

Step 9  Close the window.
Setting Up the MR-PG

Customer contact applications use the MediaRouting interface to request instructions from the system software when they receive a contact request from a customer using one of the mediums, such as email, web collaboration, or voice. When the system software receives a new task request from the application, Unified ICM runs a pre-defined Unified ICM script to determine how to handle the task.

As a result of the execution of the Unified ICM script, Unified ICM sends an instruction to the application to do one of the following:

- While the application is executing an application script that is stored on the application server, Unified ICM is looking for a best available agent that has the matching skill within the enterprise, and assigns this agent to this task.

- Handle the new task with a Unified ICM determined best available agent that has the matching skill within the enterprise or a label the application utilizes to determine the best available agent for the task.

**Note:** When choosing where to set up the MR-PG, be aware you can only set up two PG's per server.

How to Set Up the MR-PG

To set up the MR-PG, follow these steps:

**Step 1**
Access the Peripheral Gateway Setup tool on the machine that you want to make an MR-PG. Add the customer if you have not already done so.

**Step 2**
Click **Add** in the Instance Components section and choose **Peripheral Gateway** from the Unified ICM Component Selection window. The Peripheral Gateway Properties window displays.

**Step 3**
Do the following:

- Choose Production Mode.

  **Note:** The Auto Start at System Startup option ensures that the Peripheral Gateway can restart itself automatically if necessary. Set the Auto Start feature after installation is complete. The server may need to be rebooted a number of times during installation, and problems could occur if the node starts before hotfixes and/or databases are applied.

- Specify whether the PG is part of a duplexed pair.

- In the ID field, choose the PG's device identifier as enabled in the CallRouter's Device Management Protocol (DMP) configuration dialog (part of setting up the CallRouter portion; enables the connection between the Router and the PG). Each logical PG must have a unique device assignment at the CallRouter. (If a PG is duplexed, both physical machines use the
same device assignment.) To add another logical PG, you must enable another PG device for the CallRouter.

- If the PG is duplexed, specify whether you are installing Side A or Side B. If the PG is simplexed, select **Side A**.

- Use the Client Type Selection section of the window to select **MediaRouting** and click the **Add** button.

- Select the drive and language as appropriate and click the **Next** button.

**Step 4** The Peripheral Gateway Component Properties window displays.

Enter the Logical Controller ID generated when you configured the PG with the PG Explorer in Step 8 of the "How to Configure the MR-PG (page 184)" section. Click the **Add** button and select **PIM 1** from the list.

**Step 5** The MediaRouting Configuration box displays.

**Step 6** Do the following:

- To put the PIM into service, check the **Enabled** option. This allows the PIM to communicate with the peripheral when the Peripheral Gateway is running.

- Enter the peripheral name in the Peripheral name field. In most cases, you must use the enterprise name from the associated Peripheral record.

  **Note:** When creating peripheral names, use short descriptive names and keep the length to a minimum.

- Enter the Peripheral ID from the Peripheral record.

- For Application Hostname (1), enter the host name or the IP address of the application server machine (Cisco Unified Web Interaction Manager). If using the host name, the name must be in the host's file.

- For Application Connection Port (1), enter the port number on the application server machine that the PIM will use to communicate with the application.

- Leave Application Hostname (2) blank.

- Leave Application Connection Port (2) blank.

- For Heartbeat Interval (seconds), specify how often the PG will check its connection to the application server. (Use the default value.)

- For Reconnect Interval (seconds), specify how often the PG will try to re-establish a lost connection to the application server. Use the default value

- Click **OK**.
**Step 7**  From the Peripheral Gateway Component Properties window, click the **Next** button. The Device Management Protocol Properties window displays. Enter the appropriate settings and click the **Next** button.

**Step 8**  The Peripheral Gateway Network Interfaces window displays. Enter the appropriate settings and click the **Next** button.

**Step 9**  The Check Setup Information window displays. Verify the setup information and click the **Next** button. The system software sets up the PG.

**Step 10**  When the Setup Complete window displays, click the **Finish** button to exit from the setup program.

---

**Configuring and Installing the IPCC PG**

When agents and skill groups are created in the system software, they reside on a peripheral. A peripheral can be associated with an IPCC, SoftACD, or Legacy ACD for agents doing any work on the phone. If the agents on the peripheral will never be doing phone work, one or more NonVoice peripherals can be used.

**How to Configure the IPCC PG**

To configure the IPCC PG, follow these steps:

**Step 1**  Start the Configuration Manager. From the Configuration Manager menu, select **Configure ICM > Peripherals > Peripheral > PG Explorer**. The PG Explorer window displays.

**Step 2**  Click the **Retrieve** and then click the **Add PG** button. The Logical controller dialog displays.

**Step 3**  Do the following:

- Enter a name for the PG (for example, Cust_NV A_PG1).
- Select **IPCC/SoftACD/EA** as the Client Type.
- Enter the address for the Primary CTI server and the Secondary CTI server in the following form:

  ```
  <IP address of the CTI server>:<Client Connection Port Number>
  ```

  that is, **192.168.1.101:42027**

  This entry is necessary for Cisco Unified E-Mail Interaction Manager to gather CTI connection data.

**Step 4**  In the tree section of the window, expand the tree and click on the peripheral. The Peripheral configuration dialog displays.

**Step 5**  Do the following:
• Use the default name or change the name.

    **Note:** This name is used in composite names which are limited to a 32 character length, i.e., an agent enterprise name. Therefore, keep the name short.

• Unified CCE uses post routing, do not un-select the **Enable Post Routing** checkbox.

**Step 6** Select the Advanced tab and click the **Agent Reporting** checkbox.

**Step 7** Select the Routing Client tab and specify the routing client for post routing.

    **Note:** This tab appears only if the **Enable Post Routing** checkbox is selected.

**Step 8** Save the configuration. After you save the configuration, the system assigns a Logical Controller ID and a Physical Controller ID. Make a note of these values because you will need to provide them when you install the IPCC PG.

**Step 9** Close the window.

---

**How to Install the IPCC PG**

To install the IPCC PG, follow these steps:

**Step 1** Run the PG Setup tool (accessed from the Unified CCE Tools folder) on the machine that will be the Agent PG. Add the customer if you have not already done so.

**Step 2** Click **Add** in the Instance Components section and select **Peripheral Gateway** from the ICM Component Selection window. The Peripheral Gateway Properties window displays.

**Step 3** Do the following:

    • Choose **Production Mode**.

    **Note:** The **Auto Start at System Startup** option ensures that the Peripheral Gateway can restart itself automatically if necessary. Set the Auto Start feature after installation is complete. The server may need to be rebooted a number of times during installation, and problems could occur if the node starts before hotfixes and/or databases are applied.

    • Specify whether the PG is part of a duplexed pair.

    • In the ID field, choose the PG's device identifier as enabled in the CallRouter's DMP configuration dialog. Each logical PG must have a unique device assignment at the CallRouter. (If a PG is duplexed, both physical machines use the same device assignment.) To add another logical PG, you must enable another PG device for the CallRouter.

    • If the PG is duplexed, specify whether you are installing Side A or Side B. If the PG is simplexed, select **Side A**.
• Use the Client Type Selection section of the window to select the IPCC/SoftACD/EA PG and click the **Add** button.

• Select the drive and language as appropriate and click the **Next** button.

**Step 4**
The Peripheral Gateway Component Properties window displays.

Enter the Logical Controller ID generated when you configured the Agent PG with the PG Explorer. Click the **Add** button.

**Step 5**
The IPCC/SoftACD/EA Configuration box displays.

**Step 6**
Do the following:

• To put the PIM into service, check the **Enabled** option. This allows the PIM to communicate with the peripheral when the Peripheral Gateway is running.

• Enter the peripheral name in the Peripheral Name field. In most cases, you must use the enterprise name from the associated Peripheral record.

  **Note:** When creating peripheral names, use short descriptive names and keep the length to a minimum.

• Enter the Peripheral ID from the Peripheral record.

• Specify the maximum length for an agent extension in the Agent Extension Length field.

• Click the **IPCC** button in the Telephony Server Protocol section.

• Enter the Unified CM host/IP that this peripheral will connect to in the Service field in the IPCC Parameters section.

• Specify a the User ID and User password created on the Unified CM you are connecting to.

**Step 7**
Click **OK**.

---

**Installing CTI Server**

You need to install a CTI Server for each Agent PG (the steps are basically the same as those for a Media Routing PG). Each PG uses CTI Server to provide the interface between the integrated application and the system software.

**Note:**

• It is important that when you install a CTI Server, you pick the Custom Gateway (CG) that corresponds to the Agent PG that you just installed. For example, if you just installed a MR-PG as PG1 and an IPCC Agent PG as PG2; you must install the CTI Server for PG2 as CG2, not CG1.

• You do not need to install a CTI server on the Agent PG if one is already installed.
How to Install CTI Server

To install CTI Server, follow these steps:

**Step 1** Run the PG Setup tool (accessed from the Unified CCE Tools folder) on the same machine as the Agent PG. Add the customer if you have not already done so.

**Step 2** Click **Add** in the Instance Components section and select **CTI Server** from the ICM Component Selection window. The CTI Server Properties window displays.

![Figure 61: cti_server_prop_dialogbox](image)

**Step 3** Do the following:

- Choose **Production Mode**.

  **Note:** The **Auto Start at System Startup** option ensures that the Peripheral Gateway can restart itself automatically if necessary. Set the Auto Start feature *after* installation is complete. The server may need to be rebooted a number of times during installation, and problems could occur if the node starts before hotfixes and/or databases are applied.

- Specify whether the CTI Server is part of a duplexed pair.

- In the ID field, specify the number of the CTI Server node (CG1 through CG80).

- In the ICM System ID field, enter the DMP device number of the Agent PG that you want associated with the CTI Server.

  **Note:** The DMP device number is the checkbox you checked for the PG (that is, if you checked box 1, the device number is 1, box 2, the device number is 2, etc.).

- If the CTI Server is duplexed, specify whether you are installing Side A or Side B. If the CTI Server is simplexed, select Side A.

- Select the drive and language as appropriate and click the **Next** button.

**Step 4** The CTI Server Component Properties window displays.
Enter the Client Connection Port Number.

**Step 5**
Click the **Next** button. The CTI Server Network Interface Properties window displays. Enter the appropriate interface information.

**Step 6**
Click the **Next** button to view the setup information window. If the information is correct, click the **Next** button and finish the installation.

---

**Agents**

You can create *persons* (records that contain personal information about an agent) and *agents* (person who handles customer contact) in the system software. Creating them in Unified ICM does not make them immediately available to Unified ICM, the application must enable the agent.

**Note:** When you create an Agent record, you have the option of associating it with an existing Person record (clicking the **Select Person** button). If you do not associate the Agent record with an existing Person record, a new Person record is automatically created when you create the agent.

Configuring an agent for multi-media means assigning that agent to at least two skill groups (one for each media). For example, the agent might handle both email and phones, chat and phones, or blended collaboration and email.

**Note:** Use the integrated applications to assign an agent an application-specific skill group. Application-specific skill groups must be created and maintained in the application, not in the system software.

If you want to configure phone agents in the system software, you must first create person records for them in the Configuration Manager's Person List tool.

Every agent is associated with a person record. This is primarily a person's first and last name and login password. This record must exist before you can create an agent in the system software (see the "How to Create an Agent (page 136)" section).
The purpose of the person record is so that, in a multi-channel contact center, one person can be assigned as an agent on different peripherals since the system software defines an agent as belonging to only one peripheral.

**Note:** The preceding is also true for non-integrated Unified ICM systems.

The second step in creating an agent in the system software is to use the Configuration Manager's Agent Explorer tool to create the agent. When you do so, the agent is associated with a person.

**Non Voice Agents**

A NonVoiceAgent PG/PIM is only intended for use at a site that does not have voice, but that does want to use Unified ICM to do its multi-channel (Non Voice) contact routing. For such a site a Non Voice Agent PG is necessary, since every agent must be associated with a peripheral, and the site has no Agent peripheral other than the NonVoiceAgent PG. (A Media Routing PG is also needed, but an MR-PG is not an Agent PG.)

At a site with voice, some agents may be NonVoice agents, that is, these agents will not make/take telephone calls. Such agents are created on the IPCC or ACD PG for that site and indicated by a Peripheral Number beginning with the letters NV. You do not require a separate NonVoiceAgent PG for these agents.

**Note:** In this discussion "voice" means the making/taking of telephone calls, while NonVoice implies the inability to make/take any such calls. This is to be distinguished from the meaning of Voice with regard to Media Classes. The Media Classes called Voice and Blended Collaboration both involve "voice" in the current sense.

- If a NonVoice agent is created through the application, a peripheral-unique Peripheral Number beginning with the letters NV is automatically generated. If later you wish to change a NonVoice agent to a voice enabled agent, go to the Agent Explorer in Configuration Manager and change the agent's Peripheral Number to the agent's peripheral-unique voice Peripheral Number (often the agent's telephone number). Do not simply remove the letters NV from the beginning of the previously generated Peripheral Number. If the agent was created as a voice agent, a peripheral-unique peripheral number is assigned at creation.

- If a NonVoice agent is being created through Configuration Manager, leave the Peripheral Number field blank when creating the agent. The system will then generate a peripheral-unique Peripheral Number beginning with NV.

If it is later decided that an existing NonVoice agent will be allowed to receive telephone calls, change the agent's Peripheral Number to a voice Peripheral Number, using Agent Explorer, as indicated above in the first bulleted item.

If it is decided that an existing voice-enabled agent will become a NonVoice agent, delete the Peripheral Number as it appears in the Agent Explorer—thus blanking the field—and then continue as indicated above in the second bulleted item.
Application Instance

Important! Application instances must be configured before you configure the multi-media application.

Use the Configuration Manager's Application Instance List tool to configure application instances, external to Unified ICM, to allow identification and access to the Configuration Management System (CMS). This enters an application ID and application key (password) that identifies the application. You need to enter the same information in the application.

Note: Important! Share the system software configuration information you noted during the previous procedures with the person performing the integrated applications configuration.

How to Configure the Application Instance

To configure the application instance, follow these steps:

Step 1
Start the Configuration Manager and select Tools > List Tools > Application Instance List. The Application Instance List window displays. Click the Retrieve button and then the Add button to display the Attributes tab.

Step 2
Enter the following information:

• Name. The enterprise name for the application instance.

• Application key. This is the password that the integrated application will use to be identified by the system software. The password is restricted to the 7-bit printable ASCII characters (any of the 94 characters with the numeric values from 32 to 126). Control characters (for example, 'tab') and international characters are not allowed. This means passwords cannot be entered in a non-Western alphabet, such as Kanji.

• Application type. Available option is <Other>.

  Note: Select <Other> when using Unified EIM and Unified WIM.

• Permission Level. Select the permission level from the drop-down list.

Step 3
After entering the required fields, save the configuration and close the window.

Note: Refer to the Configuration Manager's online help for detailed information about the Application Instance List tool.

Application Connections

In order for the application to communicate with the Unified ICM system for configuration purposes, a communications path between the system software and the application must be established.
You can define the communications path from the system software (CMS Server) to the application using the Application tab in the CMS Control tool (resides on the Administration & Data Server in icm\bin directory). A similar user interface on the application side is used to define the communications path from the application to the CMS Server.

Within the Application tab, the Application Connections table lists the current application connections, where you can add, edit, and delete application connections.

**Note:** The Application link and Unified ICM Administration & Data Server link must match on the application side.

### How to Configure CMS Server Connections

To configure CMS Server connections, follow these steps:

**Step 1**
From the **Start** menu, select **Run** and enter `C:\icm\bin\cmscontrol.exe` to access CMS Control.

**Step 2**
Select the Application tab.

**Step 3**
Click **Add**. The Application Connection Details dialog displays.

**Step 4**
Enter the application connection properties:

- **Administration & Data Server link.** The Unified ICM RMI Driver connection end point identity.
- **Administration & Data Server RMI Registry Port.** The port number for the Unified ICM Administration & Data Server RMI registry.
- **Application link.** The application RMI Driver connection end point identity.
- **Application RMI registry port.** The port number for the Application RMI registry.
- **Application host name.** The computer address where the application interface client resides. This name can be either an IP address or a name resolved by DNS or WINS.

**Step 5**
Click **OK** twice. This restarts the Cms_Jserver on the Administration & Data Server or Administration Client.

**Note:** When you click **OK** the second time to save your changes and close the CMS Control window, a message box may appear that states:

“The CmsJServer process is about to be cycled. Click **OK** to proceed or **Cancel** to quit.”

Click **OK** to proceed.

**Note:** Refer to the application-specific instructions for specific field information. Refer to the CMS Control tool's online help for specific information about the field descriptions.
Additional Configuration Setups

After configuring the system software, you need to perform the following configurations in the Cisco Unified Interaction Manager application:

- Once you have configured the system software and Cisco Unified Interaction Manager, more configuration must occur on the Cisco Media Blender server.

  **Note:** Refer to the *Cisco Media Blender Administration Guide, Release 7.1*, for details.

- Unified ICM and ACD queues:

  If the Cisco Unified Interaction Manager will be used to send requests submitted to it to the system software, you must create one Unified ICM queue. When a request is submitted to a Unified ICM queue, the system software will route the request to the Cisco Unified Interaction Manager and agent most appropriate to handle the request.

  If you are using legacy ACDs for blended collaboration you must create ACD queues on the Cisco Unified Interaction Manager. ACD queues are used to communicate with Cisco Media Blender.

  Refer to the Cisco Unified Interaction Manager installation CD for documentation on performing these configurations.

Using Application Gateways

An application gateway is an optional Unified ICM feature that allows you to invoke an external application from within a script (using a Gateway node). You can pass data to the application and receive data in return, which you can then examine and use for routing decisions.

Before you can use these nodes in a script, you must first configure the gateways.

The application gateway requires connection information to communicate with the external application. You perform this task using the Configuration Manager.

Configuring Application Gateways

You must configure an application gateway for each application you want to access from within scripts.

Configuration information includes data such as:

- The type of application the gateway will interact with: a non-Unified ICM application or an application on another Unified ICM system

- The form of connection the gateway will use: duplex or simplex
A fault tolerance strategy for the gateway, described below in the "Application Gateway Fault Tolerance Strategies (page 196)" table

Table 43: Application Gateway Fault Tolerance Strategies

<table>
<thead>
<tr>
<th>Fault Tolerance Strategy</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate Request</td>
<td>Each request is sent to both sides of the gateway.</td>
</tr>
<tr>
<td>Alternate Request</td>
<td>All requests are sent to only the A side of the gateway unless it fails. Side B is used only if side A is not available.</td>
</tr>
<tr>
<td>None</td>
<td>The application gateway is not duplexed.</td>
</tr>
</tbody>
</table>

Once you specify the configuration information, you can define the connection information for the gateway, such as the network address of the port through which the system software communicates with the application.

If your Central Controller is duplexed, you can define separate connection information for each side of the Central Controller. This allows each side to communicate with a local copy of the external application.

**Note:** For a remote Unified ICM, the address must be the same address specified for the ICRP NIC on the targeted system. (You may use the hostname in place of the address.) This address value must be followed by a colon, an instance or customer number (denoting which Unified ICM to access on the remote system), another colon, and a letter indicating which side of the NAM system prefers to use this connection. The preference letters are A (side A of the NAM prefers this connection), B (side B of the NAM prefers this connection), N (neither side of the NAM prefers this connection), or R (both sides of the NAM prefer this connection). For example, the address might be 199.97.123.45:1:A.

How to Configure an Application Gateway

To configure an application gateway, follow these steps:

**Step 1** Within the Configuration Manager, select Tools > List Tools > Application Gateway List. The Application Gateway List window appears.

**Step 2** To enable Add, click Retrieve.

**Step 3** Click Add. The Attributes property tab appears.

**Step 4** Complete the Attributes property tab.

**Note:** For additional information refer to the online Help.

**Step 5** Click Save to create the application gateway.

Next, configure the connection information for the application gateway.
How to Configure an Application Gateway Connection and Set the Default Connection Parameters

To configure an application gateway connection and set the default connection parameters, follow these steps:

**Step 1** Within the Application Gateway List window, click **Retrieve** and select the desired Application Gateway.

**Step 2** Complete the Connection property tab(s).

*Note:* For additional information refer to the online Help.

**Step 3** Click **Save** to apply your changes.

Skill Group Configuration with Script Editor

Universal Queue is the ability of the system software to route requests from voice, web, chat, and email channels from a single queue point directly to appropriately skilled agents. With Universal Queue, the system software treats requests from different media channels as a part of a single queue. Routing scripts send queued requests to agents based on business rules regardless of the media channel. For example, the routing of asynchronous channels such as email, and synchronous channels such as voice and chat, allows the system software to deliver the right contact to the right resource the first time, regardless of the channel it came through. The Queue to Agent node allows the targeting of a task (the work performed by an agent) to a script-specified agent.

The Queue to Agent node enables an agent to receive and operate on more than one task at a time. As a result, Universal Queue coordinates an agent's ability to work on multiple tasks of various media. It supports a simple control model where an agent's ability to handle an additional task depends on what task that agent is currently handling. For this level of control, the system software must have exclusive access to task assignment.

*Note:* For Universal Queue to work, the agent must be assigned to skill groups that "ICM picks the agent," for which the system software does the routing.

The CallRouter has the ability to move tasks out of the present script execution and resubmit them into the system as a new invocation.

Routing Script Configuration

Due to the introduction of a Media Routing Domain relationship, skill groups are medium specific. When an agent logs into the system software via a phone, or via Cisco Unified Interaction Manager, the agent actually logs into an MRD. This automatically logs the agent into skill groups associated with that agent within that MRD. Then, as a task request for a specific MRD begins script execution, the CallRouter considers only the skill groups associated with that specific MRD. This allows one script to be written to handle many MRDs.
When upgrading from an earlier version of the system software, setup upgrades all existing skill group definitions to the Voice Media Routing Domain. (MRDs for chat, email, or blended collaboration media classes must be added using the Configuration Manager's Media Routing Domain List tool.)

The associated MRD applies to most related objects. Service member objects only map skill groups to services of the same media routing domain.

Skill groups are created as follows:

- Skill groups for integrated email, chat, and blended collaboration are created, modified and deleted using the system software.
- Skill groups for standalone email and chat are created, modified, and deleted using the application.
- Legacy ACD skill groups are configured on the ACD and on the system software.

Queue to Specific Agent

To assign a task to a specific agent, the CallRouter needs to do four things:

1. Pick an agent to receive the task.
2. Pick the MRD.
3. Pick a skill group from the list provided by the MRD selection.
4. Pick a route from the list provided by the skill group selection.

Using this style of Queue to Agent node, you select a specific agent at script design time.

In this case, where it is obvious who the agent is, the node property sheet displays a choice of routes for the peripheral that the agent is assigned to.

Note: Routes, agents, skill groups, and services are all associated with a peripheral.

How to Select Multiple Skill Groups and Routes for Different Media by Agent

To select multiple skill groups and routes for different media by agent, follow these steps:

Step 1
In Script Editor, open the appropriate script in Edit mode.

Step 2
Select the Queue to Agent node.

Step 3
Right-click and select Properties to open the Queue to Agent Properties dialog.

Step 4
Ensure the Queue to Agent type is set to Select using direct references. If not:
1. Select Change to open the Queue Agent Type dialog.

2. Select Explicit agent references.

3. Click OK to return to the Queue to Agent Properties dialog.

**Step 5**
Select an agent from the drop-down list in the Agent column. This enables the rest of the columns.

**Step 6**
In the Domain column, select the appropriate MRD.

**Step 7**
In the appropriate column, select a skill group and a Route valid for the selected agent and MRD.

You can specify the agent multiple times, each with a different MRD selection.

Queue to Agent Expression

In this mode of the Queue to Agent node, the agent identity is determined by the queue to agent expression at runtime.

Since the agent and MRD are not known until script execution time, you need some way of selecting an appropriate skill group and route. To accomplish this, pick an enterprise skill group. Ensure the enterprise skill group includes appropriate skill groups to cover all MRD cases for that agent. To select the route, use an enterprise route. Again, ensure that the enterprise route includes an appropriate collection of routes.

How to Select Multiple Skill Groups and Routes for Different Media by Agent Expression

To select multiple skill groups and routes for different media by agent expression, follow these steps:

**Step 1**
In Script Editor, open the appropriate script in Edit mode.

**Step 2**
Select the Queue to Agent node.

**Step 3**
Right-click and select Properties to open the Queue to Agent Properties dialog.

**Step 4**
Ensure the Queue to Agent type is set to Select using indirect references. If not:

1. Select Change to open the Queue Agent Type dialog.

2. Select Lookup agent references by expression.

3. Click OK to return to the Queue to Agent Properties dialog.

**Step 5**
Enter an agent expression (normally task.PreferredAgentID) into the Agent Expression column. Formula Editor is enabled when the Agent Expression column is selected.
**Application Object Filter**

**Step 6**  
In the appropriate column, select an appropriate Enterprise Skill Group and an Enterprise Route valid for the entered agent expression.

You can specify the agent expression multiple times, each with a different enterprise skill group and enterprise route selection.

Refer to the *Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted* for more information about using Script Editor.

**Pushing Information to Waiting Web Collaboration/Chat Users**

On the Central Controller, you can create a Network VRU script list, which lists scripts set up to play to callers waiting for an agent.

With Unified ICM routing, you have the option of displaying information, such as advertisements or informational URLs to a caller who is waiting to join a session with an agent. You can also populate these ads or URLs so that they display caller information originating in the callform. This way, you can personalize ads or messages seen by the waiting caller.

You can set up a VRU script list to point to URLs or text messages to display on the browsers of callers waiting for a Collaboration agent. Refer to the *Cisco Unified Web and E-Mail Interaction Manager System Administration Guide* for detailed instructions on setting up this information.

**Application Object Filter**

The application object filter restricts access to application specific data that is not owned by the running application. Application owned data includes skill groups, services, application paths, and routes. The application object filter is not applicable if there are no multimedia applications.

Access to the application object filter is restricted. You must use a super user password (case sensitive) to enable or disable the application object filter. This password is set as "password" during installation.

Normally enabled, the application object filter prevents administrators from creating or editing application specific skill groups, services, application paths, or routes in the Configuration Manager. You would want this enabled since creating or editing the preceding application specific data using Unified ICM could cause the application to become out of sync with Unified ICM. These items must be created and updated in the application requiring them, and not in the system software.

Disabling the application object filter allows administrators to create, delete, or edit application specific skill groups, services, application paths, and routes from the Configuration Manager tools. You might want to do this if, for example, an application is dead (you cannot access the application) and application specific data needs to be removed from the Unified ICM database. Another example of when you would want to disable the application object filter would be you need clean up after removing an application.
How to Disable an Application Object Filter

To disable an application object filter, follow these steps:

**Step 1** Select **Options > Application Object Filter**.

**Step 2** Enter the Password when prompted.

**Step 3** Select Disable.

**Step 4** The tool opens and the status line indicates the application object filter is disabled.

**Note:**

- Open tools are not affected by the change in the application object filter status. The status change only effects tools opened after the application object filter status has been changed.

- Each time the Configuration Manager opens, the application object filter reverts to its default status – enabled.
Chapter 10

Configuring Cisco Unified Intelligent Contact Management Variables

There are two types of Unified ICM variables you can configure:

- Expanded Call Context variables
- User variables

This chapter contains the following topics:

- ECC (Expanded Call Context) Variables, page 203
- Configuring Expanded Call Context Variables, page 205
- User Variables, page 207
- How to Define a User Variable, page 208

ECC (Expanded Call Context) Variables

Expanded Call Context (ECC) variables are variables that you define and enable in the Configuration Manager to store values associated with the call. You can specify the variable name and data type. The name must begin with the string `user`. These are in addition to the variables the system software defines for each call (PeripheralVariable1 through PeripheralVariable10, CallerEnteredDigits, CallingLineID, etc.).

An ECC variable name can be up to 33 bytes long (1-32 usable characters). Use the following naming convention when creating an ECC variable:

```
user.<CompanyName>.<VariableDescription>
```

In this syntax:

- `<CompanyName>` is the name of your company
<VariableDescription> is a descriptive tag for the variable.

For example, you could use the following name for an ECC variable created for Cisco account numbers:

user.Cisco.AcctNum

Using this naming convention will prevent naming conflicts with any third-party applications that interface with the system software.

Note: If your corporation is large, you may even want to break <VariableDescription> down to include the Business Unit, Division, or other organizational entity that exists in your company.

In addition:

- An ECC variable can be either a scalar variable or an array element, each with a maximum length of 210 bytes.
- The maximum number of elements in an array can be 255.
- The maximum buffer size for each scalar variable = 5 + the maximum length of the variable where the 5 bytes includes 4 bytes to tag the variable and 1 byte for the null terminator.
- The maximum buffer size for each array = 5 + (1 + the maximum length of array element) * (the maximum number of elements in the array).
- There is a null terminator for each element, as well as a null terminator for the array as a whole.
- Since the total size of the buffer used to store the variables internally is 2000 bytes, the total sum of all the maximum buffer sizes for each variable and each array must be no greater than 2000.

For example, if you intended to use one scalar ECC variable with a maximum length of 100 bytes, one scalar ECC variable with a maximum length of 80 bytes, and an ECC array with a maximum of 9 elements with each element having a maximum length of 200 bytes, the buffer size would be: (5+100) + (5+80) + (5 + (1+200)*9) = 2004. As this buffer size is too large, the length of one of the scalar ECC variables or the length of the array ECC variable would need to be adjusted.

ECC Variables for Cisco Blended Collaboration or Voice MRDs with Collaboration

ECC variables must be configured in the Configuration Manager’s Expanded Call Variable List tool (for each integrated application) in order to route requests using the voice Media Routing Domain.

For Cisco Blended Collaboration or Voice MRDs with Collaboration, the ECC variables are:

- user.cisco.cmb
• user.cisco.cmb.callclass
• user.cim.activity.id
• user.wim.customer.name

Note:
• Important! While their default size is 40 characters, use the Expanded Call Variable List tool in the Configuration Manager to limit the user.cisco.cmb variable to 8 bytes and the user.cisco.cmb.callclass variable to 10 bytes to prevent ECC space limitation issues.
• Refer to the Configuration Manager's online help for detailed information about the Expanded Call Variable List tool.

Configuring Expanded Call Context Variables

Expanded call context variable configuration consists of two steps:

• Setting the **Expanded call context enabled** option in the System Information dialog
• Defining the variable through the Expanded Call Variable List in the Configuration Manager

For Web Callback and Delayed Callback to work properly, an ECC variable (also known as a named variable) must be defined. The Cisco CTI driver supports the use of ECC variables in addition to the standard call variables associated with a call. Before an ECC variable can be used, it must be defined in the Unified ICM ECC variable database table.

**Note:** For more information, refer to the *Database Schema Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted*.

How to Set the Expanded Call Context Enabled Option

**Step 1** Within the Configuration Manager, select **Tools > Miscellaneous Tools > System Information**. The System Information window appears.

**Step 2** Select **Expanded call context enabled**.

**Note:** For additional information refer to the online Help.

**Step 3** Click **Save** to apply your changes.

How to Define an Expanded Call Context (ECC) Variable

**Step 1** Within the Configuration Manager, select **Tools > List Tools > Expanded Call Variable List**.
The Expanded Call Variable List window appears.

**Step 2**  
In the Expanded Call Variable List window, enable Add by clicking **Retrieve**.

**Step 3**  
Click **Add**.

The Attributes property tab appears.

**Step 4**  
Complete the Attributes property tab:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Name (required)         | The enterprise name of the expanded call variable. This name must start with the string user and must be unique among all expanded call variables in the system (an enterprise name).  
  **Note:** Use the following syntax to prevent naming conflicts: `user.company.name` where company is your company name and name describes the expanded call variable. |
| Maximum length (required) | Specifies the maximum number of characters (1-210) allowed in the extended call variable value (the size of the variable string). For a numeric value, the number of digits is specified.  
  **Important notes:**  
  • The maximum amount of space that all the ECC variables together can take up in the Unified ICM system is no more than 2000 bytes (not 2K or 2048 bytes) and sometimes less, depending on your combination of scalar and array variables and their sizes. Each ECC variable takes up space based on the following formula: For scalar: \(5 + \text{Maximum\_Length}\)  
  For array: \(5 + (1 + \text{Maximum\_Length}) \times \text{Maximum\_Array\_Size}\)  
  • The number of characters or digits does not indicate the number of bytes. For example, a scalar ECC variable of 10 characters could take up 15 bytes of space. |
| Array (checkbox)        | When selected, indicates the expanded call variable is an array, not a scalar. Maximum array size If the expanded call variable is an array, this indicates the maximum number of elements (1-255) in that array. See also the note under the Maximum length description. |
| Enabled (checkbox)      | When selected, indicates the generation of the expanded call variable for each call is enabled. |
When selected, ECC variables will be written to the Logger database.

**Note:** Non-persistent variables can be used in routing scripts, but will not be written to the database.

<table>
<thead>
<tr>
<th><strong>Persistent</strong> (checkbox)</th>
<th>When selected, indicates that the system software predefines the selected expanded call variable.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cisco provided</strong> (checkbox)</td>
<td>Provides additional information about the ECC variable.</td>
</tr>
</tbody>
</table>

**Step 5**  
Click **Save** to apply your changes.

---

### Configuring ECC Variables for Use by CTI Server

Before entering ECC variables using the configuration tool, the total size of the ECC variables must be validated against the following rules and limits.

**Step 1**  
Since the total size of the buffer used to store the variables in CTI Server internally is 2500 bytes, the total sum of all the maximum buffer sizes for each scalar variable and arrays must be no greater than 2500.

**Step 2**  
The maximum buffer size for each scalar variable = 4 + length of the ECC name + the maximum length of the variable where the 4 bytes includes a 1 byte tag, 1 byte to define the length, and 2 terminating NULL characters.

**Step 3**  
The maximum buffer size for each array = (5 + length of the ECC name + the maximum length of array element) * (the maximum number of elements in the array) where the 5 bytes includes a 1 byte tag, 1 byte to define the length, 1 byte for the array index, and 2 terminating NULL characters.

For example, if you intended to use one scalar ECC variable with a maximum length of 100 bytes named `user.var`, one scalar ECC variable with a maximum length of 80 bytes named `user.vartwo`, and an ECC array named `user.varthree` with a maximum of 9 elements with each element having a maximum length of 200 bytes, the buffer size would be:

\[(4+8+100) + (4+11+80) + ((5 + 13 + 200)*9)) = 2169\]

where 8 is the length of `user.var`, 11 is the length of `user.vartwo` and 13 is the length of `user.varthree`.

### User Variables

You can also create global user variables; for example, you could create a user variable called `usertemp` to serve as a temporary storage area for a string value used by an If node.
Each user variable must:

- Have a name that begins with user.

  **Note:** This name cannot contain the dot/period (.) character.

- Be associated with an object type, for example, Service. (This enables the system software to maintain an instance of that variable for each object of that type in the system.)

- Be identified as a persistent (retains value across CallRouter restarts) or non-persistent (does not retain value across CallRouter restarts) variable.

  **Note:** A user variable can store a value up to 254 characters long.

After you have defined a variable, you can then use the Script Editor Formula Editor to access the variable and reference it in expressions, just as you would with a “built-in” variable

**How to Define a User Variable**

**Step 1**
Within the Configuration Manager, select **Tools > List Tools > User Variable List**.

The User Variable List window appears.

**Step 2**
In the User Variable List window, enable Add by clicking **Retrieve**.

**Step 3**
Click **Add**.

The Attributes property tab appears.

**Step 4**
Complete the Attributes property tab.

  **Note:** The **Variable name**, **Object type**, and **Data type** fields are required. All other fields are optional. For additional information refer to the online Help.

**Step 5**
Click **Save** to apply your changes.
Network IVRs/VRUs

This chapter discusses the Network IVR/VRU feature that lets you divert a call to an interactive voice response unit for additional processing.

It includes:

- An introduction to IVR/VRUs
- Information on how to configure IVR/VRUs
- A discussion on how to access IVR/VRUs in scripts
- Instructions on how to queue calls at IVR/VRUs

This chapter contains the following topics:

- Introducing Network IVRs/VRUs, page 209
- VRU Configuration Tools, page 210
- Configuring Network VRUs and VRU Scripts, page 217
- Accessing VRUs in Cisco Unified Intelligent Contact Management Scripts, page 222
- Queuing Calls at VRUs, page 222

Introducing Network IVRs/VRUs

Each routing client can have one or more associated Network Voice Response Units (VRUs). A VRU is a telecommunications computer, also called an Interactive Voice Response (IVR) unit, that responds to caller-entered touch-tone digits.

The routing client can be a public network interexchange carrier (IXC) intelligent network, or a private network peripheral, such as an Aspect or Avaya ACD.
Note: Network VRUs are only available for intelligent public network IXCs, not all public network IXCs.

A Network VRU supports the system software's service control interface. A routing script can divert a call to a Network VRU and instruct the VRU to perform specific processing before the system software determines the final destination for the call.

Preparation for using the VRU feature includes:

- Setting up Network VRU targets with the Configuration Manager
- Inserting VRU nodes in the routing script

This chapter describes how to perform these tasks.

Note: For the remainder of this chapter, the term VRU will be used exclusively to be consistent with the on-screen prompts.

VRU Configuration Tools

Network VRU Explorer Tool

This tool allows a Network Applications Manager (NAM) to view, edit, or define network VRUs, labels, and their associations. The system software can send a customer call to a network VRU.

Note: The Network VRU Explorer is not available on a Limited (single Instance) Administration & Data Server.

To begin, select the filters you want and click Retrieve.

The changes you make in the Network VRU Explorer window are not applied to the database until you click Save.

Select Filter Data Box

Use the Select filter data box (see the "Accessing Database Records (page 34)" section in Chapter 3 for additional information) to select and retrieve data from the database. Until you retrieve database data, no data is displayed.

Network VRU Label Tree

Hide/Show legend

This button toggles between Hide and Show. Click it to hide or show a diagram identifying all the objects that can be displayed in the tree list box and showing their hierarchy.
Tree list box

The tree list box displays the names of the retrieved Network VRUs and, when expanded, the labels associated with them.

When you select an item within the tree, details about that item appear in the tabbed property fields to the right of the tree list box.

Tree list box Properties

- Expanding (+)/contracting (-) the tree (+ and – buttons)
- Displaying option menu (right mouse button clicking)
- Making tree connections (drag and drop)

With the mouse, you can select an object and then move it to another part of the tree, as long as its object type belongs in that tree location.

For example, to move a route to another service, select it by clicking the left mouse button, and then move the mouse to that service. When that service becomes highlighted, lift your finger off the mouse. You could also use the Bulk Configuration tool to take the output of a switch and create 20 or 30 labels. Then, using one of the Explorer tools, you could attach these UNASSIGNED labels to an appropriate location.

- Symbols indicating object state (see the "Record Status Symbol Descriptions (page 39)" table in the "Common Bulk, List, and Explorer Tool Features" section.

- UNASSIGNED tree objects

A tree object is marked UNASSIGNED if it was made by another configuration tool and was not assigned (mapped) to a parent object.

For example, a label might not have been assigned to a peripheral target or a route might not have been assigned to a service.

With the mouse, you can select an UNASSIGNED object and move it to a tree branch, as long as it's an object that belongs in that tree location. Use the window legend to see what objects belong where.

When you move an UNASSIGNED object to an appropriate tree-branch location, you assign that object to the object above it in the tree. Then the object is no longer unassigned. For example, in this way you might assign an unassigned label to a peripheral target.

Add

When an object in the tree is selected, you can add another object of the same kind or an object immediately below it in the tree hierarchy. The Add buttons are enabled accordingly.

Add Network VRU

Click to add a network VRU to the database.
Add Label
Click to add a label to the selected network VRU.

Delete
Click to delete the selected object in the tree. This marks the selected object for deletion. When you click Save, the object is deleted from the database.

If a network VRU is selected, it and the labels associated with it are marked for deletion. If a label is selected, only that label's record is marked for deletion.

Undelete
The Delete button toggles to Undelete when you select an object marked for deletion. To undelete an object marked for deletion, select it and click Undelete.

Security
Visible only if you have partitioning. Enabled only if you have maintenance access to the database record.

Click to apply security options to the selected tree object. For a description of the security options, click.

ID status box
The label in the ID box at the bottom of the screen identifies the Unified ICM system on which you are working.

Network VRU Tab
Allows you to view (and define or edit, if you have maintenance access) the properties of the selected network VRU.

Table 44: Network VRU Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (required)</td>
<td>An enterprise name for the network VRU. This name must be unique for all network VRUs in the enterprise</td>
</tr>
<tr>
<td>Type (required)</td>
<td>(selection list) The type of network VRU. For additional information, see the &quot;Voice Response Unit (VRU) Types (page 217)&quot; table.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the network VRU.</td>
</tr>
</tbody>
</table>

Network VRU Banks Tab
This is enabled when a Type 9 is selected in the Network VRU tab.
Table 45: Network VRU Banks Tab Button Descriptions

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Displays a list of Trunk Groups that are on an IPCC System Peripheral.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the added items from the list of Trunk Groups.</td>
</tr>
</tbody>
</table>

Label tab

Allows you to view (and create, delete, or edit, if you have maintenance access) the properties of the selected label.

Table 46: Label Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network VRU Bank</td>
<td>Specify the Network Target for the Label to be associated with.</td>
</tr>
<tr>
<td>Routing client (required)</td>
<td>The enterprise name of the routing client associated with the label.</td>
</tr>
<tr>
<td>Label (required)</td>
<td>The label value.</td>
</tr>
<tr>
<td>Label type (required)</td>
<td>(Drop-down list) The valid types depend on the type of routing client. Select one valid type for your routing client. Check with your carrier for the latest information about supported label types. Typical types are Normal, DNIS Override, Busy, Ring, and Post-Query.</td>
</tr>
<tr>
<td>Customer (optional)</td>
<td>The customer associated with the label.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the label.</td>
</tr>
</tbody>
</table>

Network VRU Script List Tool

This tool allows you to list the network VRU scripts currently defined in the Unified ICM database, to define new ones, and to view, edit, or delete the records of existing ones.

Network VRU scripts are created by VRU engineers for VRUs. This List tool defines these previously created scripts for the system software so it can interact with the scripts.

**Note:** The Network VRU Script List tool is not available on a Limited (single Instance) Administration & Data Server.

Select Filter Data Box

Use the Select filter data box (see the "Accessing Database Records (page 34)" section in Chapter 3 for additional information) to select and retrieve data from the database. Until you retrieve database data, no data is displayed.

Network VRU Script List Box

Lists the network VRU scripts retrieved or created in the current editing session. The tabbed fields on the right side of the window display the properties of the selected network VRU script.
Attributes Tab

Allows you to view and (if you have maintenance access) to define, edit, or delete the attributes of the selected network VRU script.

### Table 47: Attributes Tab Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (required)</td>
<td>An enterprise name for the VRU script. This name must be unique for all VRU scripts in the system.</td>
</tr>
<tr>
<td>Network VRU (required)</td>
<td>(selection list) The network VRU associated with the VRU script.</td>
</tr>
<tr>
<td>VRU script name (required)</td>
<td>The number by which the script is known to the VRU.</td>
</tr>
<tr>
<td>Timeout (seconds) (required)</td>
<td>The number of seconds Unified ICM will wait for a response after directing the routing client to run this script. If Unified ICM does not receive a response from the routing client within this time, it assumes the VRU script has failed.</td>
</tr>
<tr>
<td>Configuration param</td>
<td>A string to be passed to the VRU when the script is invoked.</td>
</tr>
<tr>
<td>Customer</td>
<td>(selection list) The customer associated with the VRU script, if any.</td>
</tr>
<tr>
<td>Interruptible</td>
<td>Checked, indicates the script can be interrupted (for example, if an agent becomes available to handle the call).</td>
</tr>
<tr>
<td>Overridable</td>
<td>Checked, indicates the script can make itself interruptible or non-interruptible.</td>
</tr>
<tr>
<td>Description</td>
<td>Any additional information about the VRU script.</td>
</tr>
</tbody>
</table>

Security Tab

Visible only on partitioned systems and enabled only on records for which you have maintenance access.

VRU Currency List Tool

This tool allows you to list the VRU currencies currently defined in the Unified ICM database, to define new ones, and to view, edit, or delete the records of existing ones.

Select Filter Data Box

Use the Select filter data box (see the "Accessing Database Records (page 34)" section for additional information) to select and retrieve data from the database. Until you retrieve database data, no data is displayed.

VRU Currency List Box

Lists the VRU currencies retrieved and or created in the current editing session. The tabbed field on the right side of the window displays the name of the selected VRU currency.
Currency (required)

The type of currency (pounds, dollars, yens, and so on) that the VRU uses when playing prompts. For example, the type of currency is needed if a caller requests information regarding a bank statement. The currency type cannot be longer than 10 characters.

Attributes Tab

Allows you to view and (if you have maintenance access) to define, modify, and delete currencies.

VRU Defaults List Tool

This tool allows you to list VRU defaults currently defined in the Unified ICM database, to define new ones, and to view, edit, or delete the records of existing ones.

Select filter data box

Use the Select filter data box (see the "Accessing Database Records (page 34)" section in Chapter 3 for additional information) to select and retrieve data from the database. Until you retrieve database data, no data is displayed.

VRU Defaults List Box

Lists the VRU defaults retrieved and or created in the current editing session. The tabbed fields on the right side of the window display the properties of the selected VRU defaults.

Attributes tab

Allows you to view and (if you have maintenance access) to update the defaults used by ISN (Internet Service Node).

Table 48: Attributes Tab Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name (required)</td>
<td>A unique name for the VRU defaults list.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the VRU defaults list.</td>
</tr>
<tr>
<td>Media server set (required)</td>
<td>The base URL (Uniform Resource Locator) for all media files used in the VRU script. For example: <a href="http://www.machine1/dir1/dirs">www.machine1/dir1/dirs</a>. Part of the base URL is the application server IP address or DNS name. The maximum string size is 30 characters. The default value localhost. When the Media Server URL is DNS name and if the DNS Server is configured to return multiple IP addresses for a host name, then ISN will attempt to get the</td>
</tr>
</tbody>
</table>
### VRU Configuration Tools

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em><strong>media</strong></em></td>
<td>media files from each Media Server IP address in sequence with the priority to the closest IP address (as determined by the subnet mask).</td>
</tr>
<tr>
<td>Note:</td>
<td>For multi-tenant systems, you can include the customer name at the end of the string.</td>
</tr>
<tr>
<td><strong>Locale (required)</strong></td>
<td>(selection list) A combination of language and country which define the grammar and prompt set to use. The default is en_US.</td>
</tr>
<tr>
<td>System media library</td>
<td>The name of the system library of media files and prompts for individual digits, months, default error messages, and so on. The maximum string size is 10 characters. The default is sys.</td>
</tr>
<tr>
<td>Note:</td>
<td>Each locale has a specific system media library.</td>
</tr>
<tr>
<td>Application media library</td>
<td>The name of the application library of media files and prompts for individual digits, months, default error messages, and so on. Indicates the application media library that contains the application media file to be played to the caller. The maximum string size is 10 characters. The default is app.</td>
</tr>
<tr>
<td>Note:</td>
<td>Each locale has a specific application media library.</td>
</tr>
<tr>
<td>Currency (required)</td>
<td>(selection list) The currency type used in the IVR prompts to the caller. The default is dollar.</td>
</tr>
<tr>
<td>DTMF termination key (required)</td>
<td>(selection list) The key the caller presses to signify the end of digit entry. The default value is #. The choices are 0 through 9, #, or *.</td>
</tr>
<tr>
<td></td>
<td>DTMF (Dual Tone Multi Frequency) is the “touch-tone” method used by the telephone system to communicate the keys pressed when dialing.</td>
</tr>
<tr>
<td>InterDigit Timeout (required)</td>
<td>The timeout in seconds allowed between entering digits before the system assumes the caller is finished. The range is from 1 to 99 seconds. The default value is 3 seconds.</td>
</tr>
<tr>
<td><strong>No Entry</strong></td>
<td>Defaults for when the caller does not enter data.</td>
</tr>
<tr>
<td>Number of tries (required)</td>
<td>The number of times the VRU queries the caller when the caller does not enter any data. The range of value is from 1 to 9. The default value is 3.</td>
</tr>
<tr>
<td>Timeout (required)</td>
<td>The number of seconds allowed before the caller starts entering data. After this time, the call is ended. The timeout range is from 0 to 99 seconds. The default value is 5 seconds.</td>
</tr>
<tr>
<td><strong>Invalid Entry</strong></td>
<td>Defaults for when the caller enters incorrect data.</td>
</tr>
<tr>
<td>Number of tries (required)</td>
<td></td>
</tr>
</tbody>
</table>
The number of times the VRU queries the caller when the caller enters incorrect data. The range is from 1 to 9. The default value is 3.

### VRU Locale List Tool

This tool allows you to list the VRU locales currently defined in the Unified ICM database, to define new ones, and to view, edit, or delete the records of existing ones.

### Select Filter Data Box

Use the Select filter data box (see the "Accessing Database Records (page 34)" section for additional information) to select and retrieve data from the database. Until you retrieve database data, no data is displayed.

### VRU Locales List Box

Lists the VRU locales retrieved and or created in the current editing session. The tabbed fields on the right side of the window display the properties of the selected VRU locales.

### VRU Locale

A combination of language and country which define the grammar and prompt set to use when the VRU plays prompts.

### Attributes Tab

 Allows you to view and (if you have maintenance access) to define, modify, and delete VRU locales.

#### Locale (required)

A combination of language and country which define the grammar and prompt set to use when the VRU plays prompts. The default is en_US. This cannot be longer than 10 characters.

### Configuring Network VRUs and VRU Scripts

Before you start configuring a Network VRU, you must know its type. The VRU type determines what routing script nodes the system software needs to use to communicate with the VRU. For example, when interacting with a Type 3 VRU, the system software executes a routing script containing a Send to VRU node in order to successfully process a call.

The following table lists the VRU types that are currently available.
## Table 49: Voice Response Unit (VRU) Types

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Nodes to Use with This Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Normal label type and a correlation ID.</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Normal label type and a DNIS.</td>
<td>Required: Translation Route to VRU. Optional: Queue and Run VRU Script.</td>
</tr>
<tr>
<td>3</td>
<td>Resource label type and a correlation ID. The routing client can automatically take back the call from the VRU when the system software returns a destination label.</td>
<td>Optional: Send to VRU, Queue, and Run VRU Script.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Use this type (rather than Type 7) when the routing client can automatically take back the call from the VRU when the system software returns a destination.</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Resource label type and a DNIS.</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Resource label type and either a correlation ID or a DNIS.</td>
<td>Required: Send to VRU. Optional: Queue and Run VRU Script.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Use this type (rather than a Type 3 or Type 7) when the routing client itself takes care of mapping the call to requests from the system software.</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>No label, no correlation ID, and no DNIS (call is already at the VRU).</td>
<td>The VRU for this type is programmed so that it can recognize such a request based on the call qualifiers, so you can then assume the call is already at the VRU. Optional: Queue and Run VRU Script.</td>
</tr>
<tr>
<td>7</td>
<td>Similar to Type 3, but the system software automatically instructs the VRU to release the call when it sends a destination label to the routing client.</td>
<td>Optional: Send to VRU1, Queue, and Run VRU Script.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Use this type (instead of Type 3) when the routing client cannot take back the call from the VRU. That is, the system software automatically instructs the VRU to release when it sends a route response to the routing client; for example, CWC Network VRUs.</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Similar to Type 2, but a Type 8 VRU is used when the NAM has a routing client that controls the call to the VRU.</td>
<td>Required: Translation Route to VRU. Optional: Queue and Run VRU Script.</td>
</tr>
<tr>
<td>9</td>
<td>Queuing for Unified SCCE.</td>
<td>Required</td>
</tr>
<tr>
<td>Type</td>
<td>Description</td>
<td>Nodes to Use with This Type</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>10</td>
<td>Simplifies configuration requirements in Unified CVP Comprehensive Model deployments. Use this type for calls that originate from a TDM VRU or ACD and need to be transferred to Cisco Unified Customer Voice Portal (Unified CVP) for self service or queuing, and for calls that originate from an Unified CCE Unified CM and need to be transferred to Unified CVP for self service or queuing.</td>
<td>Required: All Unified CVP micro-application scripts</td>
</tr>
</tbody>
</table>

It is not really necessary to include a Send to VRU node in a script referring to a Type 3 or Type 7 VRU, as the Queue and Run VRU Script nodes automatically send the call to the VRU if it is not already there when they execute. However, make a practice of including it in such scripts, as it can act as a visual aid if you ever need to troubleshoot the script.

For Types 3 and 7 you must use the System Information dialog to configure a range of correlation IDs. These IDs allow the system software to match calls arriving at the VRU with calls sent there by the system software. (For Types 2 and 8, the system software uses the DNIS values associated with the translation route to match up the calls. For Type 6, no matching is required since the call is already at the VRU.)

**VRU Port Map Data Descriptions**

A VRU Port Map associates a VRU trunk with an ACD trunk or an ADC port. In cases where ACD and VRU PIMs are controlled by the same PG, each row in the VRU_Port_Map table specifies how a VRU port maps to an ACD trunk or port.

**Table 50: VRU Port Map Data Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>(display only) A symbol indicating whether a row’s record is changed, not changed, to be deleted, or to be inserted. (See the &quot;Insert and Edit Windows (page 53)&quot; section for additional information.)</td>
</tr>
<tr>
<td>VRU Trunk Group</td>
<td>Indicates the VRU Trunk Group associated with this port map.</td>
</tr>
<tr>
<td>VRU Trunk Number</td>
<td>Indicates the VRU Trunk associated with this port map.</td>
</tr>
<tr>
<td>Mapping Type</td>
<td>Type of mapping associated with this port map. There are two mapping types:</td>
</tr>
<tr>
<td></td>
<td>• VRU Trunk, which maps to ACD Trunk</td>
</tr>
<tr>
<td></td>
<td>• VRU Port, which maps to ACD Port</td>
</tr>
<tr>
<td></td>
<td>This selection determines which two of the next four fields are editable.</td>
</tr>
<tr>
<td>ACD Trunk Group</td>
<td>(optional) Indicates the ACD Trunk Group associated with this port map.</td>
</tr>
<tr>
<td>ACD Trunk Number</td>
<td>(optional) Indicates the ACD Trunk associated with this port map.</td>
</tr>
<tr>
<td>ACD Peripheral</td>
<td>(optional) Indicates the ACD Peripheral associated with this port map.</td>
</tr>
<tr>
<td>ACD Port</td>
<td>(optional) Indicates the ACD Port associated with this port map.</td>
</tr>
</tbody>
</table>
Network VRU Script Data Descriptions

Each row identifies a script used by a network VRU to handle a call. A VRU script is managed by the VRU itself. It is not stored in the Unified ICM database or directly managed by the system software. The system software can only direct the VRU to run the script.

**Note:** The Network VRU Script Bulk tool is not available on a Limited (single Instance) Administration & Data Server.

Table 51: Network VRU Script Data Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>State</strong></td>
<td>(display only) A symbol indicating whether a row's record is changed, not changed, to be deleted, or to be inserted.</td>
</tr>
<tr>
<td><strong>Network Target</strong> (required)</td>
<td>Identifies the network VRU associated with the script.</td>
</tr>
<tr>
<td><strong>VRU Script Name</strong> (required)</td>
<td>The name of the script as known at the VRU.</td>
</tr>
<tr>
<td><strong>Network VRU Script</strong> (required)</td>
<td>The enterprise name of the script.</td>
</tr>
<tr>
<td><strong>Customer</strong></td>
<td>(optional) The name of the customer associated with the script.</td>
</tr>
<tr>
<td><strong>Interruptible</strong> (required)</td>
<td>Indicates whether the system software can interrupt the script (for example, if a routing target becomes available): Yes or No.</td>
</tr>
<tr>
<td><strong>Overridable</strong> (required)</td>
<td>Indicates whether the script can override its own Interruptible attribute: Yes or No.</td>
</tr>
<tr>
<td><strong>Configuration Parameter</strong></td>
<td>(optional) A parameter string that is sent to the VRU to initialize the script.</td>
</tr>
<tr>
<td><strong>Timeout</strong></td>
<td>(optional) The number of seconds the system software will wait for a response after invoking the script.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>(optional) Additional information about the script.</td>
</tr>
</tbody>
</table>

Configuring Network VRUs

First, you need to define each logical VRU in the database.

How to Configure a Network VRU

Perform the following steps to configure a Network VRU:

**Step 1** Within the Configuration Manager, select **Tools Explorer Tools Network VRU Explorer**. The Network VRU Explorer window appears.

**Step 2** In the Network VRU Explorer window, enable **Add Network VRU** by clicking **Retrieve**.

**Step 3** Click **Add Network VRU**. The Network VRU property tab appears.
Step 4 Complete the Network VRU property tab.

**Note:** The Name and Type fields are required. For a description of the available types, see "Table VRU Types (page 217)." All other fields are optional. For additional information refer to the online Help.

Step 5 Click **Save** to apply your changes.

---

**Network VRU Labels**

You must associate all VRU Types (except Type 6) with a Network VRU Label.

**How to Define a Network VRU label**

Perform the following steps to define a Network VRU label:

**Step 1** In the Network VRU Explorer window, click **Retrieve** and select the Network VRU you want to add the label to. The Label property tab appears.

**Note:** For information on defining labels, see the "Labels (page 157)" section.

**Step 2** Complete the Label property tab.

**Note:** The Routing client, Label, and Label type fields are required. All other fields are optional. For additional information refer to the online Help.

**Step 3** Click **Save** to apply your changes.

---

**Network VRU System Information**

For Network VRUs, you must use the System Information dialog to define a range of correlation IDs so the system software can communicate with the VRU about the call.

**How to Set the Default Network VRU and Range of Correlation Numbers**

Perform the following steps to set the default Network VRU and range of correlation numbers:

**Step 1** Within the Configuration Manager, select **Tools > Miscellaneous Tools > System Information.** The System Information window appears.

**Step 2** In the System Information window, select the Default Network VRU.

**Step 3** Enter the Minimum Correlation Number.

**Step 4** Enter the Maximum Correlation Number.
**Note:** For additional information refer to the online Help.

**Step 5**
Click **Save** to apply your changes.

---

### Network VRU Script Configuration

To allow a routing script to control the processing on the VRU, you must configure VRU-based scripts within the system software. A routing script can then direct the VRU to run a specific script.

**Note:** VRU scripts are defined and maintained on the VRU. The system software only maintains a name for each VRU script. It does not maintain the scripts themselves.

### How to Configure VRU Scripts

Perform the following steps to configure VRU scripts:

**Step 1**
Within the Configuration Manager, select **Tools > Network VRU Script List**. The Network VRU Script List window appears.

**Step 2**
In the Network VRU Script List window, enable **Add** by clicking **Retrieve**.

**Step 3**
Click **Add**. The Attributes property tab appears.

**Step 4**
Complete the Attributes property tab.

**Note:** The **Name**, **Network VRU**, **VRU script name**, and **Timeout** fields are required. All other fields are optional. For additional information refer to the online Help.

**Step 5**
Click **Save** to apply your changes. The system software database manager automatically generates a unique Network VRU Script ID.

---

### Accessing VRUs in Cisco Unified Intelligent Contact Management Scripts

After you have configured a Network VRU and VRU scripts, you can use the Script Editor (refer to the *Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted* for additional information) to write a routing script to send a call to the VRU and invoke a specific VRU script.

### Queuing Calls at VRUs

You can queue a call at a Network VRU until a specific resource becomes available. A call can be queued for one or more skill groups, an enterprise skill group, or one or more scheduled
targets. As soon as an agent becomes available at one of the specified targets, the call is removed from queue and sent to the target.
Peripheral Terminology

Overview

Different peripheral manufacturers use different terminology for agents, skill groups, and services. For example, a service might be called an application, split, or gate. A skill group might be called an agent group or hunt group.

For example, note the following about using peripherals with Unified ICM:

1. The Aspect contact center maps a trunk group and DNIS to a Call Control Table (CCT). The DEFINITY ECS uses the trunk group and DNIS for incoming calls.

2. Without Customer Controlled Routing (CCR), one or more services map to an ACD DN. With CCR, one or more services map to an ACD CDN.

3. If an ECS is running in Expert Agent Selection (EAS) mode, a skill group maps to an ECS skill group; otherwise, it maps to a hunt group.

4. A contact center instrument can be a trunk, a teleset, or a workstation.

5. Define one network trunk group and one associated trunk group for each DMS-100, DMS-500, and SL-100.

Mapping Cisco Unified Intelligent Contact Management Terminology to ACD-specific Terminology

The following table summarizes the mapping of Unified ICM terminology to ACD-specific terminology.
<table>
<thead>
<tr>
<th>Unified ICME Term</th>
<th>Peripheral-Specific Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent</td>
<td>Agent</td>
</tr>
<tr>
<td>Peripheral target</td>
<td>Alcatel 400: DNIS</td>
</tr>
<tr>
<td></td>
<td>NEC NEAX 2400, NEAX 7400, APEX 7600: Pilot number</td>
</tr>
<tr>
<td></td>
<td>Nortel DMS-100, DMS-500, and SL-100: Primary or Supplementary ACD DN</td>
</tr>
<tr>
<td></td>
<td>Others: Trunk group and DNIS¹</td>
</tr>
<tr>
<td>Service</td>
<td>Alcatel 400: Pilot</td>
</tr>
<tr>
<td></td>
<td>Aspect Contact Center: Application</td>
</tr>
<tr>
<td></td>
<td>Avaya DEFINITY ECS: Vector Directory Number (VDN)</td>
</tr>
<tr>
<td></td>
<td>NEC NEAX 2400, NEAX 7400, APEX 7600: CCV number</td>
</tr>
<tr>
<td></td>
<td>Nortel DMS-100, DMS-500, and SL-100: Primary or Supplementary ACD DN</td>
</tr>
<tr>
<td></td>
<td>Rockwell Spectrum: Application</td>
</tr>
<tr>
<td></td>
<td>Siemens Hicom 300/E: ACD Routing Table (ART)</td>
</tr>
<tr>
<td>Skill group</td>
<td>Alcatel 400: Agent PG</td>
</tr>
<tr>
<td></td>
<td>Aspect Contact Center: Agent group</td>
</tr>
<tr>
<td></td>
<td>Avaya DEFINITY ECS: Skill group or hunt group³</td>
</tr>
<tr>
<td></td>
<td>NEC NEAX 2400, NEAX 7400, APEX 7600: Split number</td>
</tr>
<tr>
<td></td>
<td>Nortel DMS-100, DMS-500, and SL-100: ACD Group</td>
</tr>
<tr>
<td></td>
<td>Others: Trunk group and DNIS</td>
</tr>
<tr>
<td>Trunk</td>
<td>Alcatel 400: None</td>
</tr>
<tr>
<td></td>
<td>Aspect Contact Center: Instrument⁴</td>
</tr>
<tr>
<td></td>
<td>Nortel DMS-100, DMS-500, and SL-100: None</td>
</tr>
<tr>
<td></td>
<td>Others: Trunk</td>
</tr>
<tr>
<td>Trunk group</td>
<td>Alcatel 400: None</td>
</tr>
<tr>
<td></td>
<td>Nortel DMS-100, DMS-500, and SL-100: None⁵</td>
</tr>
<tr>
<td></td>
<td>Others: Trunk group</td>
</tr>
</tbody>
</table>
Note: Multi-channel applications function as application instances. See Chapter 9, "Configuring Cisco Unified Intelligent Contact Management Software for Integrated Applications (page 179)," for more information about these applications.

In some cases the Unified ICM concept is very close to the corresponding ACD feature. For example, the Unified ICM concept of a service is very similar to the Aspect concept of an application. In other cases, the ACD does not have a feature that maps exactly to the Unified ICM feature. In these cases, you might choose a different mapping than shown in the "Cisco Unified Intelligent Contact Management Software and Peripheral-Specific Terminology (page 225)" table. For example, although it might make sense to associate each VDN on a DEFINITY ECS with a Unified ICM service, you could also map each hunt group to a service.

On an Avaya DEFINITY ECS running in EAS mode, each skill group has primary and secondary subgroups. The system software emulates this by automatically creating additional skill groups for these peripheral types. For example, when you configure the Sales skill group for an Avaya DEFINITY ECS ACD, the system software automatically creates the Sales.pri and Sales.sec skill groups in addition to the base Sales group. In monitoring and scripts, you can reference the .pri and .sec skill groups directly or you can refer to the base skill group.

Some ACDs have limitations that prevent them from making full use of specific features of the system software.

See Also

Refer to the Pre-installation Planning Guide for Cisco Unified ICM Enterprise and Hosted for the current list of supported peripherals with any peripheral-specific limitations.
Index

abandoned calls
  high number....21
  wait time....21
accessing
  Bulk Configuration tools....53
  Configuring Manager....32
database records....41
  VRUs in ICM scripts....222
adding
  announcement configuration information....156
  service member....117
Advanced tab
  field descriptions....116
  for selected peripheral, field descriptions....92
agent data
  enabling/disabling agent data at a peripheral and define
  an agent distribution....140
  importing....142
agent distributions, listing and viewing....98
Agent Explorer tab, field descriptions....137
agents
  about....151
  assigning to default skill group....123, 138
  assigning to skill group....140
  configuring....135
  creating....136
  temporary....141
announcements
  adding configuration information....156
  configuration information....156
application gateways
  configuring connection and setting the default
  connection parameters for integrated applications.197
  configuring for integrated applications....196
  application instances
    about....193
    configuring, how to....193
  installing for integrated applications....180
application object filters, disabling for integrated applications....201
Application Wizard
  about....163
  using....163
applying
  range of values to a range of fields in a column....60
  security settings....65
  security settings to multiple records....65
  single value to a range of edit-control fields....59
  single value to a range of selection-box fields....59
assigning
  agent as supervisor....139
  agents to a skill group....140
  users to a feature control set....46
associating labels with a scheduled target....170
bucket intervals
  configuring....50
  configuring call type intervals....50
Bulk Configuration tools
  accessing....53
  creating or updating records in the database tables....54
  using....35
calls, routing process....11
call types
  about....16
  default labels....18
  determining....16
  determining labels....18
  determining routes....17
  determining trunk groups and DNIS....17
executing routing scripts....17
non-voice....16
voice....16
call wait time, abandoned....21
changed symbol....55
changing passwords....135
checking
  integrity of your configuration data....47
  record references....47
CMS Server
  application connections....193
  how to configure connections for integrated applications....194
ConfigLimit tool, using....131
configuration data
  checking integrity....47
  file, agent....144
  file, Skill Group Member....144
  importing from the peripheral....141
  saving to the database....43
  validating....46
configuration information, storing....9
Configuration Manager
  about....31
  accessing....32
  Bulk Configuration tools, about....35
  Explorer tools, about....36
  List tools, about....37
  miscellaneous tools, about....38
  tools summary....34
  using Explorer tools to add records....41
  using the tools....32
  wizards, about....38
configuration records, deleting....47
configuring
  agent targeting rules....104
application gateway connection and set the default connection parameters for integrated applications.197
application gateway for integrated applications....196
application instance for integrated applications....193
bucket intervals....50
bulk data....54
CMS Server connections for integrated applications....194
Expanded Call Context (ECC) variables....205
Expanded Call Context (ECC) variables for CTI Server....207
feature control set....45
IPCC PG for integrated applications....187
media routing domain for integrated applications..182
MR-PGs for integrated applications....184
multiple records at a time....53
Network Interface Controller (NIC)....72
Network VRU....220
network VRUs and VRU scripts....217
peripheral gateway....87
peripherals....85
routes....152
routes and routing targets....149
service arrays....162
Service Level for a Peripheral....27
Service Level for Aspect VRU....29
Service Level for Media Routing Domain....27
Service Level for Skill Group ...28
Service Levels for specific call types....24
services using the Service Explorer....115
skill targets....113
System Information Service Level for call types....24
System Peripheral Gateways....100
timeouts and thresholds....20
trunk groups....85
VRU scripts....222
<table>
<thead>
<tr>
<th>Index</th>
<th>231</th>
</tr>
</thead>
<tbody>
<tr>
<td>creating</td>
<td>skill group and/or its associated records....128</td>
</tr>
<tr>
<td>agent....136</td>
<td>user variable....208</td>
</tr>
<tr>
<td>enterprise service and assign specific services....146</td>
<td>deleting</td>
</tr>
<tr>
<td>enterprise skill group....146</td>
<td>dialed number/script selectors....78</td>
</tr>
<tr>
<td>feature control set....45</td>
<td>network trunk group....110</td>
</tr>
<tr>
<td>label....158</td>
<td>NIC....77</td>
</tr>
<tr>
<td>new scheduled target....168</td>
<td>PG or a peripheral....103</td>
</tr>
<tr>
<td>new schedule period for a target....168</td>
<td>records....48, 66, 120</td>
</tr>
<tr>
<td>records in the database tables....54</td>
<td>deletion</td>
</tr>
<tr>
<td>translation route....171</td>
<td>dependencies....49</td>
</tr>
<tr>
<td>CTI Servers, installing, how to....190</td>
<td>immediate....48</td>
</tr>
<tr>
<td>data</td>
<td>logical....48</td>
</tr>
<tr>
<td>editing range....59</td>
<td>types....48</td>
</tr>
<tr>
<td>enterprise....145</td>
<td>determining</td>
</tr>
<tr>
<td>exporting....64</td>
<td>call types....16</td>
</tr>
<tr>
<td>file format, importing/exporting....63</td>
<td>labels....18</td>
</tr>
<tr>
<td>finding....58</td>
<td>routes....17</td>
</tr>
<tr>
<td>importing....62</td>
<td>trunk groups and DNIS....17</td>
</tr>
<tr>
<td>selecting....58</td>
<td>Dialed Number/Script Selector List tab</td>
</tr>
<tr>
<td>database records, accessing....41</td>
<td>descriptions....80</td>
</tr>
<tr>
<td>default skill groups, assigning agent....123, 138</td>
<td>viewing dialed number/script selectors....78</td>
</tr>
<tr>
<td>defining</td>
<td>dialed number/script selectors</td>
</tr>
<tr>
<td>communications path from CMS Server to application....193</td>
<td>configuring....78</td>
</tr>
<tr>
<td>dialed number/script selectors....78</td>
<td>viewing, defining, deleting, modifying....78</td>
</tr>
<tr>
<td>Expanded Call Context (ECC) variables....203</td>
<td>Dialed Number Label tab, viewing mapping of labels to selected dialed number/script selectors....82</td>
</tr>
<tr>
<td>multiple trunks....111</td>
<td>Dialed Number Mapping tab, viewing call types mapped to selected dialed number/script selectors....81</td>
</tr>
<tr>
<td>network trunk group....110</td>
<td>disabling</td>
</tr>
<tr>
<td>Network VRU label....221</td>
<td>agent data at a peripheral and define an agent distribution....140</td>
</tr>
<tr>
<td>NIC....75</td>
<td>application object filter for integrated applications....201</td>
</tr>
<tr>
<td>peripherals....100</td>
<td>DMS-100, defining trunk groups....106</td>
</tr>
<tr>
<td>peripheral targets....155</td>
<td>editing</td>
</tr>
<tr>
<td>PG....99</td>
<td>existing records....56</td>
</tr>
<tr>
<td>route....152, 153, 154</td>
<td>network trunk group....109</td>
</tr>
<tr>
<td>routing client....76</td>
<td>service and/or its associated records....119</td>
</tr>
</tbody>
</table>
Index

records...56
enabling agent data at a peripheral and defining an agent distribution...140
enterprise services, creating and assigning specific services...146
enterprise skill groups, creating...146
executing scripts...17
expanded call context
defining variable...205
setting Enabled option...205
Expanded Call Context (ECC) variables
configuring...205
configuring for CTI Server...207
with Collaboration...204
Explorer tools, using...36
exporting data...64
feature control
node control table...44
restricting users or classes of users...43
script node control...44
feature control set
assigning users...46
configuring...45
creating...45
selecting script nodes...46
features
bulk configuration...55
common bulk, list, and explorer tool...39
network IVRs/VRUs...209
finding data...58
importing
agent data...142
data...62
inserting new records...61
installing
application instances for integrated applications...180
CTI Server for integrated applications...190
IPCC PGs for integrated applications...188
Intelligent Call Processing subsystems...71
IPCC PGs
configuring for integrated applications...187
installing for integrated applications...188
labels
associating with a scheduled target...170
creating...158
default...18
defining...157
internal mappings...18
mapping...160
mapping specific labels to a dialed number/script selector...160
setting default label for a dialed number/script selector...161
special Sprint...158
types...157
Label tab
field descriptions...118, 127
late thresholds...21
limit, skill groups...130
List tools, using...36
Logical Controller tab field descriptions...88
logical interface controller...71
Logical Interface Controller tab, configuring NIC and routing client(s), field descriptions...72
mapping
skill groups to services...130
specific labels to a dialed number/script selector...160
media routing domains
configuring for integrated applications...182
creating a default route...97
miscellaneous tools, using...38
modifying
agent record...135
dialed number/script selectors....78
NIC or its routing client(s)....75
PG or peripheral....102
route....153, 154
service....119
skill group....127
MR-PGs
  configuring for integrated applications....184
  setting up for integrated applications....185
network interface controllers, about....70
network trunk groups
  defining....110
  deleting....110
  editing....109
  viewing....106
Network Trunk Group tab descriptions....107
Network VRU Banks tab....212
Network VRU Explorer
  Network Applications Manager....210
  Network VRU Label Tree....210
Network VRU Explorer tool....210
Network VRU Label Tree
  Add....211
  Add Label....212
  Add Network VRU ....211
Delete....212
  Hide/Show legend....210
ID status box....212
  Security....212
  Tree list box....211
  Undelete....212
Network VRUs
  configuring....220
  defining a label....221
labels....221
script configuration....222
script data descriptions....220
setting default Network VRU and range of correlation numbers....221
Network VRU Script List tool
  about....213
  Attributes tab....214
  Network VRU Script List box....213
  Security tab....214
Network VRU tab....212
NICs
  defining....75
  deleting....77
  modifying....75
  viewing....72
not changed symbol....55
object control, prohibiting access to configuration data.43
online help, Configuration Manager....33
passwords, changing....135
peripheral gateways
  about....70
  configuring....87
  configuring agent targeting rules....104
  deleting a PG....103
  viewing records....87
peripherals
  Advanced tab field descriptions....92
  calls to skill targets....106
  configuring agent targeting rules....104
  Default Route tab field descriptions....97
  defining....100
  defining PGs....99
  deleting....103
  gateways, about....86
  modifying records....102
overview...86
Peripheral Monitor tab field descriptions...95
Peripheral tab field descriptions...91
processing...19
subsystem...86
Peripheral tab, field descriptions...91
peripheral targets, defining...155
Peripheral Target tab, field descriptions...117, 126
peripheral terminology
  ACD routing table...226
  agent...226
  application...226
  peripheral targets...226
  service...226
  skill group...226
terminology overview...225
  trunk...226
  trunk group...226
  vector directory number...226
Person List tool, storing person records...132
Person List tool tab, field descriptions...134
PG Explorer tool, tab descriptions...88
PGs
  configuring agent targeting rules...104
  defining...99
deleting...103
Physical Interface Controller tab, viewing selected NIC's physical interface controller properties, field
descriptions...73
private network peripherals, routing clients...69
public network interexchange carriers, routing clients...69
queuing calls at VRUs...222
receiving routing responses...20
record references, checking...47
records
  administering deleted...49
applying security settings to multiple...65
configuring multiple...53
deleting...48, 120
deleting and undeleting...66
finding data...58
inserting new...61
modifying a PG and peripheral...102
Peripheral Monitor...95
retrieving and editing existing...56
selecting...58
selecting one field in multiple...58
sorting...57
sorting by multiple columns...57
viewing deleted...49
viewing or modifying agent...135
viewing PG...87
Record State...55
removing service member...117
reporting
call type configuration...24
retrieving
data from the database...133
existing records...56
records...56
route requests, how system software processes...15
routes
configuration overview...152
defining and updating...152
defining or modifying...153, 154
determining...17
how to select multiple skill groups and routes for different media by agent expression for integrated
applications...199
how to select multiple skill groups and routes for different media by agent for integrated
applications...198
translation...170
Route tab
  field descriptions....117, 125
routing
creating a default route for each Media Routing Domain....97
how it works....11
process....11
process steps....12
requests, about....13
targets, Unified ICM....151
routing clients
  CRSP....77
defining....76
examples....70
processing....18
receiving routing responses....20
Routing Client tab field descriptions....94
Sprint....76
subsystem....69
  viewing a NIC....72
  working with trunk groups....106
Routing Client tab, viewing selected routing client properties....74
routing requests
  about....13
  Caller-Entered Digits (CED)....13
  Calling Line ID (CLID)....13
  Dialed Number (DN)....13
  Post-Routing....13
  Pre-Routing....13
  route and target subsystem....150
saving configuration data to the database....43
scheduled targets
  about....167
  associating labels....170
  creating a new....168
creating a new schedule period....168
scripts
  administrative....9
  executing....17
  managing....9
  routing....9
security settings, applying to multiple records....65
selecting
data from the database....133
  multiple skill groups and routes for different media by agent expression for integrated applications....199
  multiple skill groups and routes for different media by agent for integrated applications....198
  one field in multiple records....58
  records....58
  script nodes for a feature control set....46
service arrays
  about....161
  configuring....162
Service Explorer tool, viewing and configuring a service....115
service levels
  about....22
  configuring....23
  threshold....22
  types....22
Service Members tab, field descriptions....117
services
  about....114, 151
  defining....119
  enterprise....145
  modifying....119
  viewing....115
Service tab, field descriptions....115
setting
default label for a dialed number/script selector....161
default Network VRU and range of correlation numbers....221
expanded call context Enabled option....205
expanded call context variable....205
setting up MR-PGs for integrated applications....185
Skill Group Explorer tool, viewing and configuring skill groups....121
Skill Group Mask tab
field descriptions....124
viewing default number of subskill groups....93
Skill Group Membership tab
assigning agent to default skill group....138
field descriptions....138
Skill Group Members tab
assigning agent to default skill group....123
field descriptions....123
Skill Group tab
field descriptions....121
Sub Skill Groups tab, field descriptions....125
Supervisor tab, field descriptions....139
symbols
cr changed....55
cr not changed....55
cr record status....39
to be deleted....55
to be inserted....55
System Peripheral Gateways, configuring....100
system software overview....7
tabs
Advanced tab field descriptions....92
Agent Distribution tab field descriptions....98
Default Route tab field descriptions....97
Label tab field descriptions....213
Logical Controller tab field descriptions....88
Logical Interface Controller field descriptions....72
Network Trunk Group tab descriptions....107
Network VRU Banks tab field descriptions....212
Network VRU Script List tool Attributes tab field descriptions....214
Network VRU Script List tool Security tab....214
Network VRU tab field descriptions....212
Peripheral Monitor tab field descriptions....95
Peripheral tab field descriptions....91
Physical Interface Controller field descriptions....73
Routing Client field descriptions....74
Routing Client tab field descriptions....94
Service Explorer tab field descriptions....115
Skill Group Explorer tab field descriptions....121
Skill Group Mask....93
Trunk Group tab descriptions....108
Trunk tab descriptions....109
targets
about....13
network....154
Peripheral target....14
Skill target....13

Tasks

How to access the Bulk Configuration tools....53
How to add announcement configuration information....156
How to apply a range of values to a range of fields in a column....60
How to apply a single value to a range of edit-control fields....59
How to apply a single value to a range of selection-box fields....59
How to assign agents to a skill group....140
How to assign users to a feature control set....46
How to associate labels with a scheduled target....170
How to change your password....135
How to check record references....47
How to check the integrity of your configuration data....47
How to configure agent targeting rules....104
How to configure an application gateway....196
How to configure an application gateway connection and set the default connection parameters....197
How to configure a Network VRU....220
How to configure bucket intervals....50
How to configure CMS Server connections....194
How to configure service arrays....162
How to configure the application instance for integrated applications....193
How to configure the IPCC PG....187
How to configure the media routing domain....182
How to configure the MR-PG....184
How to configure VRU scripts....222
How to create a feature control set....45
How to create a label....158
How to create an agent....136
How to create a new scheduled target....168
How to create a new schedule period for a target....168
How to create a translation route....171
How to create enterprise service and assign specific services....146
How to create enterprise skill group....146
How to define and update a route....152
How to define a network trunk group....110
How to define a Network VRU label....221
How to define a NIC....75
How to define a peripheral....100
How to define a PG....99
How to define a routing client....76
How to define a service and/or its associated records....119
How to define a skill group and/or its associated records....128
How to define a user variable....208
How to define multiple trunks....111
How to define or modify a route....153, 154
How to define peripheral targets....155
How to define the expanded call context variable....205
How to delete a network trunk group....110
How to delete a NIC....77
How to delete a PG or a peripheral....103
How to delete a record....48, 120
How to delete records....66
How to disable an application object filter....201
How to enable/disable agent data at a peripheral and define an agent distribution....140
How to export data....64
How to find data....58
How to import agent data....142
How to import data....62
How to insert new records....61
How to install CTI Server for integrated applications....190
how to install the application instance...180
how to install the IPCC PG...188
how to map skill groups to services...130
how to map specific labels to a dialed number/script selector...160
how to modify a NIC or its routing client(s)...75
how to modify a PG and peripheral records...102
how to modify a service...119
how to modify a skill group...127
how to retrieve and edit existing records...56
how to select multiple skill groups and routes for different media by agent...198
how to select multiple skill groups and routes for different media by agent expression...199
how to select one field in multiple records...58
how to select records...58
how to select script nodes for a feature control set...46
how to set a default label for a dialed number/script selector...161
how to set the default Network VRU and range of correlation numbers...221
how to set the expanded call context Enabled option...205
how to set up the MR-PG...185
how to sort records by multiple columns...57
how to undelete records...67
how to use the Application Wizard...163
how to view, define, delete, or modify dialed number/script selectors...78
how to view a network trunk group...106
how to view a NIC and its routing client(s)...72
how to view a service...115
how to view a skill group...121
how to view deleted records...49
how to view or apply security settings...65
how to view or modify agent record...135

about...20
late...21
timeout...20

Timeout limit...74

timeouts
about...20
limit...21
threshold...20

Timeout threshold...74
to be deleted symbol...55
to be inserted symbol...55
tools

Bulk Configuration...35
ConfigLimit...131
Explorer...36
List...36
miscellaneous...38
wizards...38

tracking agent states...141
translation routes
about...19
creating...171
Translation Route Wizard, about...171
Trunk Group tab, descriptions...108
trunks, defining multiple...111
Trunk tab
descriptions...109
trunk types...109
types of deletions
immediate deletion...48
logical deletion...48
undeleting records...67
Unified CCE, overview...8
Unified ICM
overview...7
Index

routing targets....151

updating

  records in the database tables....54
  route....152

user variables

  about....207
  defining....208

using

  Application Wizard....163
  Bulk Configuration tools....35
  Configuration Manager....31, 32
  Explorer tools....36
  List tools....36
  miscellaneous tools....38
  wizards....38

variables

  Expanded Call Context (ECC)....203
  user....207

viewing

  agent distributions....98
  agent record....135
  deleted records....49
  dialed number/script selectors....78
  network trunk group....106
  NIC and its routing client(s)....72
  PG records....87
  security settings....65
  selected NIC's physical interface controller properties....73
  selected routing client properties....74
  service....115
  skill group....121

VRU configuration tools, about....210
VRU Currency List tool....214

  Attributes tab....215
  VRU Currency List box....214

VRU Defaults List tool

  about....215
  Attributes tab....215
  VRU Currency List box....215

VRU Locale....217
VRU Locale List tool

  about....217
  Attributes tab....217
  VRU Locales List box....217

VRU port maps, data description....219
VRU scripts, configuring....222
windows, Insert and Edit....54

VRU scripts, configuring....222
wizards, using....38