Template Design Guide Using InfoMaker for Cisco Unified ICM/Contact Center Enterprise and Hosted

Release 8.0(1)
February 2010

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
http://www.cisco.com
Tel: 408 526-4000
800 553-NETS (6387)
Fax: 408 527-0883
CONTENTS

Preface i
   About This Guide i
   Objective i
   Audience i
   Conventions ii
Obtaining Documentation and Submitting a Service Request 2-ii
Documentation Feedback 2-ii

CHAPTER 1
Getting Started with InfoMaker 1-1
   About WebView and InfoMaker 1-1
   Upgrading from InfoMaker 8 1-2
   Where to Install InfoMaker 1-3
   How to Install InfoMaker 1-3
   How to Allow Access to the Template Library 1-4
   How to Create an ODBC Connection to the Reporting Database 1-5
      Setting Up the ODBC Driver in Windows Control Panel 1-5
      Creating the Database Profile in InfoMaker 1-8
   The InfoMaker Interface 1-9
      The InfoMaker Toolbar 1-10
   How to access WebView Templates from InfoMaker 1-11
   InfoMaker Windows Used for WebView Templates 1-12

CHAPTER 2
Introduction to Report Templates 2-1
   About Templates 2-2
   Cisco Templates and Custom Templates 2-2
   Where Templates are Located and How They are Organized 2-2
      Sharing Template Library Files 2-3
   About Complex Report Templates 2-4
   Planning a Custom Report Template 2-5

CHAPTER 3
Creating New Custom Templates 3-1
   Check the Database Connection 3-1
   Select the Report Category Library 3-3
Select the Presentation Style and Data Source 3-4
Create the SQL Statement 3-4
  Select Tables for the SQL Statement 3-7
  Select Columns for the SQL Statement 3-7
  Create the Retrieval Argument(s) for the SQL Statement 3-8
  Construct the Where Clause for the SQL Statement 3-9
  Create a Computed Column for the SQL Statement 3-10
  View and Save a Completed SQL Statement 3-12
Open the Report Painter to Design, Preview, and Test the Template Layout 3-13
Save the Template 3-13

Creating Custom Templates Based on Existing Templates 4-1
Overview of Creating a Custom Template Based on an Existing Template 4-2
Check the Database Connection 4-2
Select the Report Category 4-3
Open a Standard Template to Use as a Model 4-3
Save the Standard Template with a New Name 4-3
Make SQL Modifications 4-5
Make Design Modifications 4-5
Save the Template 4-6

Template Layout Guidelines 5-1
Template Guidelines 5-2
Template Layout Tips 5-3
How to Design the Layout for a Graphic Template 5-5
  Additional Design Options for Graphs 5-6
How to Design the Layout for a Tabular Template 5-6
  About Panes, Bands, and Properties 5-8
  About HTML Preview 5-10
  How to Modify Column Headings 5-11
  How to Add a Title to the Template 5-13
  How to Make the Template “Web-Ready” 5-15
  How to Modify Column Data Properties 5-16
  How to Align Columns and Headings 5-17
  How to Add a Data Summary Row 5-19
  How to Enable a Tabular Template for Drill-Down 5-20
  How to Add a Column 5-21
  How to Delete a Column 5-21
CHAPTER 6

Maintaining Templates  6-1
   How to Edit a Template  6-2
   How to Preview and Test a Template  6-4
   How to Delete a Template  6-5
   How to Name and Save a Template  6-6
   How to Access New Templates in WebView  6-7
      How to Start WebView  6-7
      How to Locate the Report Category in WebView  6-7
      How to Refresh the Cache  6-7
      How to Run a Report from the New Template in WebView  6-8
   How to Prevent a Template from Displaying in WebView  6-8
   How to Distribute Templates to Other Template Libraries  6-9

APPENDIX A

Creating Sample Report Templates  A-1
   Sample Real-Time Template  A-2
      Specifications for the Sample Real-Time Template  A-2
      How to Create a Sample Real-Time Template  A-4
   Sample Historical Template  A-8
      Specifications for the Sample Historical Template  A-8
      How to Create a Sample Historical Template  A-11

APPENDIX B

Template Libraries and Report Categories  B-1
   About Template Libraries  B-2
   About WebView Report Categories  B-3

APPENDIX C

Considerations and Tips for Working with Custom Reports  C-1
   Custom Template Name Changes  C-2
   Database Error  C-2
   Database Schema Changes that Affect Custom Reporting  C-3
      Reporting Data Differences With and Without IPCC System PG  C-3
      DBDateTime Field Improves Extracts  C-3
      Differences in Half Hour Counts and TCD/RCD Counts per Interval  C-4
      Network Queue and Local Queue Time in TCDs  C-4
      RONA TCD and the Counting of Redirected Calls  C-4
   Divide by Zero Errors  C-5
   Errors Opening and Saving Templates  C-6
      <Template_name> is not in your current library list.  C-6
Select Data Source dialog box appears  C-6
Saved Custom Templates Do Not Appear in WebView  C-6
  Have you Refreshed the List of Templates in WebView?  C-6
  Does the Template Name have Multiple Underscores?  C-7
Templates That are Moved or Deleted  C-7
The PATCHPBL Utility  C-8
Preface

This preface describes the scope and intended audience for this guide. It also provides general information on accessing Cisco product documentation and getting assistance with Cisco products. It contains these sections:

- About This Guide, page i
- Obtaining Documentation and Submitting a Service Request, page ii
- Documentation Feedback, page ii

About This Guide

This section is an overview of the purpose of this guide.

Objective

This guide provides instructions for using InfoMaker™ from Sybase® to create and modify custom templates used with WebView reporting. WebView is the browser-based reporting tool of Cisco Unified ICM/Contact Center Enterprise (Unified ICM/CCE&H).

Note

WebView to also used to generate reports on Cisco e-Mail Manager activity. CEM customers who employ InfoMaker to create custom templates for CEM reports might find the information in this guide helpful.

WebView supports a subset of InfoMaker features. The instructions in this guide explain which InfoMaker features WebView supports, but this guide does not in all cases include a full description of those features. Refer to your Sybase product guides for details on InfoMaker functionality.

Audience

This guide is intended for individuals who create and maintain custom templates used to render WebView reports for Unified ICM/CCE&H. This guide assumes that you have knowledge of:

- Unified ICM/CCE WebView and WebView reports
- Unified ICM/CCE database table structures
- Relational databases and Structured Query Language (SQL).
Familiarity with Sybase InfoMaker is also useful.

Conventions

This document uses the following conventions:

<table>
<thead>
<tr>
<th>Format</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boldface type</td>
<td>Click Next.</td>
</tr>
<tr>
<td>Courier type</td>
<td>Peripheral services templates are stored in the persvc subdirectory.</td>
</tr>
<tr>
<td>Italic type</td>
<td>A newly introduced term</td>
</tr>
<tr>
<td></td>
<td>An emphasized word or phrase</td>
</tr>
<tr>
<td></td>
<td>A generic syntax item that you must replace with a specific value</td>
</tr>
<tr>
<td></td>
<td>The title of a publication</td>
</tr>
<tr>
<td></td>
<td>• A skill group is a collection of agents who share similar skills.</td>
</tr>
<tr>
<td></td>
<td>• Do not use the numerical naming convention.</td>
</tr>
<tr>
<td></td>
<td>• IF (condition, true-value, false-value)</td>
</tr>
<tr>
<td></td>
<td>• For more information, see the Database Schema Guide for Cisco Unified ICM/Contact Center Enterprise &amp; Hosted.</td>
</tr>
<tr>
<td>A right-angle bracket</td>
<td>Select File &gt; Save.</td>
</tr>
<tr>
<td>An entry enclosed within</td>
<td>Save the file to the icm&lt;icm_instance_name&gt; directory.</td>
</tr>
</tbody>
</table>

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:


Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 2.0.

Documentation Feedback

You can provide comments about this document by sending email to the following address:

mailto:ccbu_docfeedback@cisco.com

We appreciate your comments.
This chapter describes InfoMaker, gives instructions for installing it, and provides a brief description of its interface. It contains these sections:

- About WebView and InfoMaker, page 1-1
- Upgrading from InfoMaker 8, page 1-2
- Where to Install InfoMaker, page 1-3
- How to Install InfoMaker, page 1-3
- How to Allow Access to the Template Library, page 1-4
- How to Create an ODBC Connection to the Reporting Database, page 1-5
  - Setting Up the ODBC Driver in Windows Control Panel, page 1-5
  - Creating the Database Profile in InfoMaker, page 1-8
- The InfoMaker Interface, page 1-9
  - The InfoMaker Toolbar, page 1-10
  - How to access WebView Templates from InfoMaker, page 1-11
  - InfoMaker Windows Used for WebView Templates, page 1-12

### About WebView and InfoMaker

WebView is the Unified ICM/CCE browser-based reporting tool that presents call center data in real-time and historical reports. WebView is installed with more than 225 templates.

The templates that Cisco provides might be sufficient for your needs. If you prefer to create additional templates or to modify the templates that come with WebView, InfoMaker is the desktop reporting and data-maintenance tool from Sybase that you use to do so.

InfoMaker is an optional application and is not supplied by Cisco. If you choose to create custom templates, you must purchase InfoMaker separately from Sybase. At the time this guide was prepared, the release of InfoMaker that you need to use with WebView 7.0(0) was InfoMaker 10.x.

---

**Note**

For complete and updated information on current third-party software versions, refer to the Cisco Intelligent Contact Management Software Release 7.0(0) Bill of Materials (BOM). The Unified ICM BOM is available at [http://www.cisco.com/univercd/cc/td/doc/product/icm/ccbubom/index.htm](http://www.cisco.com/univercd/cc/td/doc/product/icm/ccbubom/index.htm).
Upgrading from InfoMaker 8

Release 8.0(1) of WebView for Unified ICM/CCE&H requires InfoMaker 10.x and also requires that InfoMaker 10.x NOT be installed on the WebView server machine or on the distributor Admin Workstation.

Templates created with InfoMaker 8 will continue to work with InfoMaker 10.x and WebView 8.0(1). However, if you need to change existing custom templates created with InfoMaker 8, you must open them and modify them using InfoMaker 10.x.

Note

Customers who upgrade can test their InfoMaker 8 templates to verify that they behave as expected before deploying them.

For information on upgrade considerations, refer to the *WebView Installation and Administration Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted Editions*. 
Where to Install InfoMaker

InfoMaker must be located on a separate machine that has network connections to the WebView server and the distributor Admin Workstation.

Effective with WebView 7.0(0), you must not install InfoMaker on the WebView server or on a distributor Admin Workstation where WebView is installed. InfoMaker installs certain DLL (dynamic link library) files that must be in a separate space from the DLL files called by the software installed with WebView. If you have upgraded from a prior release, the administrator who performed the upgrade was instructed to remove InfoMaker software from the WebView server.

For WebView to work correctly, the machine where you install InfoMaker:

- Must have an ODBC connection to the reporting databases on the distributor Admin Workstation. See How to Create an ODBC Connection to the Reporting Database, page 1-5.
- Must have a network connection to the shared folder on the WebView server where templates are stored. See How to Allow Access to the Template Library, page 1-4.

How to Install InfoMaker

Step 1  Close any open applications.
Step 2  Suspend the Cisco Security Agent, if it is running on the machine.
Step 3  Insert the CD for Sybase InfoMaker, ver. 10.x, into the CD-ROM drive and wait for AutoRun to launch the Welcome screen for the installation. If Autorun does not begin, navigate to the setup.exe file for the CD and double-click it.
How to Allow Access to the Template Library

Because InfoMaker is installed on a separate machine and InfoMaker users work remotely, the system administrator must create a temporary network share to the templates folder on the WebView server machine.

This allows those who create and maintain custom templates to read, write, and copy from the template PPB050.PBL files.

The system administrator accomplishes this by using the standard Windows procedure:

- **Step 1** Use Windows Explorer to navigate to the icm\<icm_instance_name>\aw\custom folder on the WebView server.
- **Step 2** Right-click the custom folder and select Sharing...
- **Step 3** Click the button for Share this folder.

When users have completed their custom template work, the administrator can remove the Share property from the custom folder.

For more on this folder and PPB050.PBL files in contains, see Where Templates are Located and How They are Organized, page 2-2

---

**How to Allow Access to the Template Library**

Because InfoMaker is installed on a separate machine and InfoMaker users work remotely, the system administrator must create a temporary network share to the templates folder on the WebView server machine.

This allows those who create and maintain custom templates to read, write, and copy from the template PPB050.PBL files.

The system administrator accomplishes this by using the standard Windows procedure:

- **Step 1** Use Windows Explorer to navigate to the icm\<icm_instance_name>\aw\custom folder on the WebView server.
- **Step 2** Right-click the custom folder and select Sharing...
- **Step 3** Click the button for Share this folder.

When users have completed their custom template work, the administrator can remove the Share property from the custom folder.

For more on this folder and PPB050.PBL files in contains, see Where Templates are Located and How They are Organized, page 2-2
How to Create an ODBC Connection to the Reporting Database

After you install InfoMaker, you need to establish an ODBC connection to the distributor Admin Workstation where the reporting database resides.

**Note**
Create an ODBC connection to the AW database only. Both real-time and historical reports are run against the distributor AW database, which has views into the Historical Data Server (HDS).

Creating the ODBC connection is a two-part procedure. First, you set up the ODBC driver in Windows Control Panel. Then you create a database profile in the InfoMaker application. This section explains both procedures.

Setting Up the ODBC Driver in Windows Control Panel

Follow these steps to set up the ODBC Driver in Windows Control Panel:

**Step 1** Select **Start > Settings > Control Panel**.

**Step 2** From the Control Panel menu, select **Administrative Tools > Data Sources (ODBC)** to launch the ODBC Data Source Administrator.

**Step 3** Click the System DSN tab. Then click **Add** to open the Create New Data Source dialog box.

**Step 4** Scroll down to locate and select the driver named **SQL Server**.

**Step 5** Click **Finish** to display the Create a New Data Source to SQL Server dialog box.
Step 6  In the Create a New Data Source to SQL Server dialog box:

a. Enter a Name of your choice. Remember this name, You will select it when you create a database profile in InfoMaker.

b. Enter a Description of your choice.

c. For Server, select or enter the name of the distributor Admin Workstation where the reporting databases for WebView server are located.

d. Click **Next** to confirm and proceed to the second Create a New Data Source to SQL Server dialog box.

Step 7  At the second Create a New Data Source to SQL Server dialog box:

a. If you have a login account on SQL Server, select the button for **With SQL Server authentication using a login ID and password entered by the user.**

   If not, select **With Windows NT authentication...**

b. Click the button for **Client Configuration** to open a secondary dialog box (Edit Network Library Configuration).

   At this dialog box, select **TCP/IP** for Network Libraries. Then click **OK** to return to the Create a New Data Source... dialog box.

c. Check **Connect to SQL Server to obtain default settings...**

d. Enter your Login ID and password.
e. Click **Next** to proceed to the third Create a New Data Source to SQL Server dialog box.

**Step 8**  
At the third Create a New Data Source to SQL Server dialog box:

a. Check **Change the default database** and enter the database name: `<icm_instance_name_awdb>`.

b. Make no other changes, and click **Next** to proceed to the fourth Create a New Data Source to SQL Server dialog box.

**Step 9**  
At the fourth Create a New Data Source to SQL Server dialog box, make no changes and click **Finish**.

**Step 10**  
At the ODBC Microsoft SQL Server Setup dialog box, click **Test Data Source**.

If you do not see a message that the connection was successful, troubleshoot the connection issue before proceeding to create the database profile in InfoMaker.

**Step 11**  
Continue to click **OK** to exit the ODBC Data Source Administrator utility.

Once you have a successful connection, you are ready to create the database profile in InfoMaker.
Creating the Database Profile in InfoMaker

Follow these steps to create a Database Profile in InfoMaker:

**Step 1**  Select **Programs > Sybase > InfoMaker 10.0 > InfoMaker** to launch InfoMaker.

**Step 2**  Select **Tools > Database Profile...**, or click **DB Prof** on the toolbar.

**Step 3**  From the Database Profile dialog box, highlight **ODBC ODBC** and click **New...**

**Step 4**  At the Database Profile Setup - ODBC screen, on the Connection tab:
   a. Enter a Profile Name of your choice.
   b. At the Data Source drop-down list, select the data source name that you defined in the ODBC Data Source Administrator.

**Step 5**  Click the Options tab.
   • If your login account on the machine where InfoMaker is installed has permission on the database, check Integrated Security. Then click **Apply**.
   • If you are given a username and password for SQL and use SQL authentication, do not check Integrated Security.

**Step 6**  Click **OK** and then **Close** to exit the InfoMaker Database Profile screen.

A green checkmark next to the Database Name indicates a successful connection.
The InfoMaker Interface

To review the InfoMaker Interface, select **Start > Programs > Sybase > InfoMaker 10.0 > InfoMaker**. This opens the main InfoMaker window.

Initially, this is a blank screen with a menu (File, Tools, Window, and Help) and the InfoMaker toolbar. Sybase documentation refers to the InfoMaker toolbar as the ‘Powerbar’.

Select **Tools > Toolbars** from the menu to change the appearance of the toolbar. For example, you can display text under the buttons, and you can change the font of that text.

**Figure 1-2** on the next page shows the toolbar buttons with text and explains each.

---

For details on using InfoMaker features, refer to your Sybase InfoMaker documentation.
The InfoMaker Toolbar

Use This Button  To
---  -----------------------------------
New  Create a new object (such as a report template).
Open  Open an existing object (such as a report template or query) from the current library.
Preview  Preview a report template from the current library.
Sel Lib  Select the current library file.
Lib List  Add additional libraries to your search list (for example, to locate library files that have been transferred from another WebView server).
To-Do List  Open the To-Do List, to enter and maintain a list of outstanding tasks for the current library.
Library  Open the Library Painter, which allows you to browse and view libraries and their contents.
DB Prof  Set the current database connection and create or modify database profiles (connection information).
Database  Open the Database Painter, which allows you to maintain databases and database tables, control user access to databases, and manipulate data in databases.
Exit  Exit InfoMaker.
How to access WebView Templates from InfoMaker

Once you have established an ODBC connection to the AW database and have ensured network access to the shared custom subdirectory where the templates are stored, you can open the standard (Cisco-provided) templates from the InfoMaker Library interface.

To open WebView templates from InfoMaker

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Map a network drive to the shared icm&lt;icm_instance_name&gt;\aw\custom directory on the WebView server where templates are stored.</td>
</tr>
<tr>
<td>Step 2</td>
<td>From the InfoMaker toolbar, select File &gt; Select Library. This opens an Explorer-type interface.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Browse to the mapped drive where the PPB050.PBL files are stored and click OK.</td>
</tr>
<tr>
<td>Step 4</td>
<td>From the InfoMaker toolbar, click Library.</td>
</tr>
</tbody>
</table>
InfoMaker Windows Used for WebView Templates

Most of the tasks related to working with custom WebView report templates in InfoMaker take place in the following three InfoMaker Painter windows:

**Library Painter**

The *Library Painter* allows you to browse and view libraries and their contents. To open the Library Painter, click *Library* from the InfoMaker toolbar. This is the screen from which you set the working library for a new template. See Select the Report Category Library, page 3-3.
Select Painter

The Select Painter allows you to define a template’s SQL select statement. This is the first window you see when you create a new template. It is the graphical interface where you create the SQL statement.

See Create the SQL Statement, page 3-4.
Report Painter

The Report Painter allows you to design the layout for a template.

This is the first screen you see when you open an existing template. When you work in a new template, click the Return button at the Select Painter to open the Report Painter.

See Chapter 5 for more on the Report Painter.
CHAPTER 2

Introduction to Report Templates

This chapter explains Unified ICM/CCE WebView report templates—what they are, where they are located, and how they are organized. It also describes considerations for planning a report template. It contains these sections:

• About Templates, page 2-2
• Where Templates are Located and How They are Organized, page 2-2
• Cisco Templates and Custom Templates, page 2-2
• About Complex Report Templates, page 2-4
• Planning a Custom Report Template, page 2-5
About Templates

Templates contain configuration instructions for a specific presentation of data.
A template provides the SQL queries, as well as the format, columns, headers, sorts, summaries, and groupings of data that can appear in a report.
When WebView reporting users create a report, they first select a reporting category, then select a template from that category, and finally specify the items (such as agents, skill groups, or peripherals) that are to populate that report. For historical reports, the user also selects a date range.
When the report is generated from the template, its content reflects these item and date-range selections.

Cisco Templates and Custom Templates

Cisco templates are installed when you run WebView Reporting from Web Setup tool. More than 225 Cisco-provided templates are available with WebView.
Custom templates are templates created using Sybase InfoMaker. They are often created as ‘Save As’ (that is modified and renamed) versions of Cisco templates.

Note Cisco supports your ability to create custom templates as described in this guide. However, Cisco cannot troubleshoot SQL query errors or performance problems due to custom templates that were created incorrectly.

Note also that if you change and rename a Cisco-provided template, it becomes an unsupported custom template.

Once a custom template is created and deployed, any changes that you make to it do not change the original Cisco template on which it was based.
Similarly, any changes to a Cisco template (for example, a change to columns and groupings due to a new release of WebView) do not change custom templates based on that original Cisco template.

Where Templates are Located and How They are Organized

Templates are organized by reporting category. This organizing methodology affects how templates display in the WebView user interface and also how they are stored on the WebView server machine.

Note See Appendix B, “Template Libraries and Report Categories” for a table that shows the relationship between each category, template library, and WebView menu option.

WebView templates are installed and stored to the WebView server at this location:

\icm\<icm_instance_name>\aw\custom

The custom folder contains a ‘child’ subdirectory for each reporting category. For example, there is an AgTeam subdirectory custom folder for all templates that generate reports on Agents by Team. There is an AgtSkg subdirectory for all templates that generate reports on Agents by Skill Group. And so forth. Figure 2-1 shows the directory structure.
Chapter 2      Introduction to Report Templates

Figure 2-1       Directory structure for templates

All subdirectories have the same structure. They each contain:

- A file named PPB050.PBL. This is the PowerBuilder Library file that contains all templates for that report category. Each report-category folder has its own PPB050.PBL file.

- One or more files with the extension of .SRD. These are the individual Cisco template files. Each Cisco-provided template has an .SRD file. Custom templates do not have .SRD files.

Note The .SRD files and the srldlist.txt file are used by the installation program and are not used by WebView. Do not move or modify these files, and do not create and add .SRD files to these directories.

- A file named srldlist.txt. This is the list of all template files in the report-category library (in the PPB050.PBL).

Before you create and save a template, you must specify its report category. This ensures that your saved custom template appears in the right WebView menu and that it can access the correct retrieval values.

You specify a report category by setting the PPB050.PBL file for that category as your ‘working library’ in InfoMaker. For example, to create a template for the category ‘Agent by Team’, you would set the PPB050.PBL in the AgTeam subdirectory as your ‘working library’.

See Select the Report Category Library, page 3-3 for the procedure to do this.

Sharing Template Library Files

The system administrator must create a temporary network share so that reporting users can read, write, and copy from the PPB050.PBL files.

For security reasons, be sure to unshare the folders in icm\icm_instance_name>\aw\custom when the custom templates are published.

About Complex Report Templates

This guide provides information for creating basic report templates. It does not explain the use of complex SQL statements and advanced InfoMaker features. For example, many enterprise templates use:

- Long lists of computed fields defined within the SQL syntax
- Rows joined across three or more database tables
- Group By clauses, which must be defined within the SQL syntax, and cannot be viewed through the InfoMaker graphical interface

If you need assistance to create complex report templates, ask your Cisco representative about consulting services.
Planning a Custom Report Template

Whether you create a new custom template “from scratch” (as explained in Chapter 3) or you create a custom template by modifying an existing template (as explained in Chapter 4), first consider the following:

<table>
<thead>
<tr>
<th>What is the reporting category for the template?</th>
</tr>
</thead>
<tbody>
<tr>
<td>What entity do you want to target (for example: Agent by Agent, Call Types, Peripheral services)?</td>
</tr>
<tr>
<td>The reporting category determines the template’s Webview report type, and consequently the menu where it appears in the WebView interface, the report parameters passed to it, and the template library in which it will be stored.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>What presentation style do you want for the template: graph or table?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unified ICM/CCE templates can use either a tabular (text) or graph (graphical) presentation format.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>What data is to appear in the template?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Which database tables and columns do you want to include in the template?</td>
</tr>
<tr>
<td>For information on Unified ICM databases, refer to the Database Schema Handbook for Cisco ICM/IPCC Enterprise &amp; Hosted Editions, Release 7.0(0) and the Schema Help available from the Cisco Admin Workstation program group.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>What arguments does the template require to retrieve data?</th>
</tr>
</thead>
<tbody>
<tr>
<td>WebView users are prompted to specify certain data retrieval parameters when launching a report template:</td>
</tr>
<tr>
<td>• Real-time reports always provide one argument—a list of IDs that represent the entities listed in your report. These are the items the user selects in WebView.</td>
</tr>
<tr>
<td>• Historical reports always provide three arguments—a list of IDs and also the start date and the end date for the period of time represented in your report.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>What computed fields, if any, does the template include?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your template can include computed columns that reflect calculations based on the values of two more database columns.</td>
</tr>
<tr>
<td>Computed columns can be created at two points in the template creation process: when you create the template SQL statement (in the Select Painter), or when you design the template layout (in the Report Painter).</td>
</tr>
<tr>
<td>However, templates containing computed columns created in the Report Painter will not support WebView’s threshold capabilities. You can, however, use the compute columns feature in Report Painter for formatting purposes; for example, to change the time format to \texttt{hh:mm:ss}.</td>
</tr>
</tbody>
</table>
Are you familiar with the WebView?
Before creating your first report template, become familiar with the content and structure of the standard templates that ship with WebView.
To do this, open a Cisco template from InfoMaker to review the report layout and the SQL. Be sure to make no changes.

Are you familiar with the WebView template guidelines?
Follow these to ensure that your custom template has a format that displays well in WebView. See Template Guidelines, page 5-2.
Creating New Custom Templates

This chapter explains the steps to create a new custom template “from scratch.”
For information on how to create a custom template by modifying a Cisco template, refer to Chapter 4, “Creating Custom Templates Based on Existing Templates.”
For information on modifying the layout of a template after you have created and saved it, refer to Chapter 5, “Template Layout Guidelines.”
This chapter contains these sections:
• Check the Database Connection, page 3-1
• Select the Report Category Library, page 3-3
• Select the Presentation Style and Data Source, page 3-4
• Create the SQL Statement, page 3-4
• Open the Report Painter to Design, Preview, and Test the Template Layout, page 3-13
• Save the Template, page 3-13

Note: If this is your first new template, be sure to first review the information in Chapter 2, “Introduction to Report Templates.”
You might find it helpful to work on the practice templates presented in Appendix A, “Creating Sample Report Templates.”

Check the Database Connection

Before you create a new template, be sure you have an ODBC connection to the distributor AW database.
Both real-time and historical reports are run against the AW database.

To check the database connection

From the InfoMaker toolbar, click DB Prof (Database Profiles).
Check the Database Connection

When there is a connection, the Profile Name for the database on the Cisco distributor Admin Workstation appears with a checkmark superimposed on it.

If you do not see the database, see the procedure on How to Create an ODBC Connection to the Reporting Database, page 1-5.

If you see the database, but it has no green checkmark, right-click the database profile name and select Connect.

Supply your login name and password, if prompted to do so.
Select the Report Category Library

WebView report templates are stored in, and accessed from, PowerBuilder library files (PBLs) on the WebView server. There is a separate folder and a separate library file (named PPB050.PBL) for each report category.

Figure 2-1 on page 2-3 illustrates the organization of report categories.

After you confirm the database connection, the next step in creating a template is to select the appropriate report category and to set the library (PPB050.PBL) file for that report category as your ‘working library’.

When you save the finished template, it will be associated with the report category for the library you select.

Follow these steps to set the working library:

---

Step 1   From the InfoMaker toolbar, click Library.

Step 2   Locate the folder for the report category with which you want to associate the template.

Step 3   Right-click the ppb050.pbl file in that folder and select Set as working library.

---

You can also select File > Select Working Library from the InfoMaker menu.

For more information on WebView report categories and library files, see Appendix B, “Template Libraries and Report Categories.”
Select the Presentation Style and Data Source

After selecting the report category library, the next step is to specify the presentation style and data source.

**Presentation style** determines the format in which reports based on a template are displayed in WebView. WebView supports two InfoMaker presentation styles:

- Tabular (text-based table format, with columns going across the page and headers above each column)
- Graph (including pie charts, bar charts, line charts, and so on)

You might want to browse through the report descriptions in WebView to locate and open examples of the various graph presentations.

Other presentation styles available in the InfoMaker new-template wizard are not supported.

**Data source** determines how data are extracted from the database. WebView supports SQL Select only. Other data source options offered in the InfoMaker new-template wizard (such as Quick Select and Query) are not supported.

Follow these steps to launch the New Template wizard and to select a Presentation Style and Data Source:

---

**Step 1**  On the InfoMaker toolbar, click **New**. The New dialog box opens.

**Step 2**  On the Object tab, select either **Graph** or **Tabular** as your presentation style. These are the only presentation styles supported by WebView.

If you select Graph, you will have the opportunity to specify the type of graph (pie chart, bar graph, and so forth) after you create the SQL statement.

**Step 3**  Click **OK**. The Tabular (or Graph) Report Generator screen opens.

**Step 4**  Select **SQL Select** as your data source. SQL Select is the only data source supported by WebView.

**Step 5**  Click **Next**. This opens the Select Painter, shown in Figure 3-1 on page 3-5.

---

Create the SQL Statement

The fourth step in creating a template is to create the SQL statement. You do this in the Select Painter, which opens immediately after you select SQL Select as your data source.
Chapter 3      Creating New Custom Templates

Create the SQL Statement

Figure 3-1     The Select Painter

The Select Painter is the graphical object you use to build a basic SQL statement. By default, it appears with the Select Tables dialog box open for your table selection.

To define the SQL statement, you perform four required procedures and one optional procedure. These procedures are:

- **Select Tables for the SQL Statement** from the database that will be used for the report. (See page 7.)
- **Select Columns for the SQL Statement** from which the data will be retrieved. (See page 7.)
- **Create the Retrieval Argument(s) for the SQL Statement** — a total of one argument for a real-time template and three for an historical one. (See page 8.)
- **Construct the Where Clause for the SQL Statement** to limit the retrieval argument(s). (See page 9.)
- Optionally, **Create a Computed Column for the SQL Statement**. (See page 10.)

The next few pages present all of these procedures.

---

**Note**

InfoMaker allows you to incorporate elements in SQL statements that are not covered in this guide (for example, Group By). For information on these additional elements, consult your InfoMaker documentation.

---

**Graphical or Syntax Environment?**

This section describes how to create the SQL statement in the graphical Select Painter environment. You can also write the SQL statement in a text window.

---

1. Tables are described in-depth in the *Database Schema Handbook for Cisco ICM/IPCC Enterprise & Hosted Editions*. 

---

Template Design Guide Using InfoMaker for Cisco Unified ICM/Contact Center Enterprise & Hosted Editions, Release 8.0(1)
If you intend to write a complex SQL query, or if you are more comfortable in a text window, select Design > Convert to Syntax. To return to the Select Painter from the SQL text window, select Design > Convert to Graphics.
Select Tables for the SQL Statement

Follow these steps to select Tables:

**Step 1** Scroll through the Select Tables dialog box to locate and click each table you want for the report.

![Select Tables dialog box](image)

**Step 2** Click Open.

The Table Select window now contains the tables you selected. InfoMaker automatically joins tables by their key relationships.

![Table Select window](image)

**Step 3** To add additional tables, right-click anywhere on the Table Select window and click Select Tables. Then repeat Steps 1 and 2.

**Step 4** To remove a table, right-click its title and choose Close.

Select Columns for the SQL Statement

Follow these steps to select columns:

**Step 1** From each table you add to the Table Layout view, locate and click the column(s) from which you want data to be retrieved.

To remove a column, simply deselect it in the table.
Create the SQL Statement

The columns appear as text boxes across the top of the tables.

Note Although you can drag the column text boxes in the Select Painter to reposition them, doing so does not change their order in the tabular report layout. To rearrange (and rename) columns, you must use the Report Painter.

The default sort order for data is Ascending (A to Z; 1 to 10). If this order is appropriate, then you have completed this procedure and can create retrieval arguments. To sort any columns in descending order, follow Step 2.

Step 2 To change the default sort order for the data that appears in the column:

a. Click in the left pane of the Sort Window.
b. Locate the columns you want sorted in Descending order.
c. Clear the checkbox next to Ascending.

Create the Retrieval Argument(s) for the SQL Statement

When WebView users generate a report, they are prompted to select retrieval arguments. For real-time reports, they need to select the Item(s) they want included in the report. For historical reports, they need to select Items and also a Date Range of start_ and end_dates.

When you create a template, you need to define the following retrieval arguments in your SQL select statement:

- **For all templates**, you define an ID argument for the Items, with the data type NumberArray.
- **In addition, for historical templates only**, you define start_date and end_date arguments, with the data type DateTime.

These are the only arguments supported for WebView reports. Templates that do not include the correct arguments will not appear in the template list in WebView.

Follow these steps to create the retrieval argument:

Step 1 From the Select Painter menu, click Design > Retrieval Arguments to open the Specify Retrieval Arguments dialog box.
Step 2  In the Name field, enter a name for the ID argument. The name cannot include spaces. Example: `skill_set_id`.

Step 3  From the Type drop-down list, select NumberArray. If you are creating a real-time template, go to Step 5. If you are creating an historical report, click Add and create arguments for the start_date and the end_date, using DateTime as the data type for both. The order of the retrieval arguments is important. If you do not enter them in the correct order, you will not be able to see the template in WebView.

![Specify Retrieval Arguments](image)

**Construct the Where Clause for the SQL Statement**

The Where clause limits data retrieval and acts as a placeholder for a value that the user will supply. For example, if the retrieval argument specifies that the report is to return all rows from the Skill Group table that match a user-supplied value, the Where clause looks similar like this: `WHERE: SkillTargetID IN (agtskg_list)`.

**Follow these steps to specify the Where clause:**

Step 1  Click the Where tab at the bottom of the Select Painter. This tab displays initially as a table with four columns: Column, Operator, Value, and Logical.

<table>
<thead>
<tr>
<th>Column</th>
<th>Operator</th>
<th>Value</th>
<th>Logical</th>
</tr>
</thead>
<tbody>
<tr>
<td>dbo.Service.SkillTargetID</td>
<td>=</td>
<td>list_of_service</td>
<td></td>
</tr>
</tbody>
</table>

Step 2  Click the Column field to open Column drop-down list. Then select the table column whose data will be matched against your first retrieval argument.

<table>
<thead>
<tr>
<th>Column</th>
<th>Operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>dbo.Service.SkillTargetID</td>
<td>=</td>
</tr>
<tr>
<td>dbo.Service.ScheduledID</td>
<td></td>
</tr>
<tr>
<td>dbo.Service.PreferredID</td>
<td></td>
</tr>
<tr>
<td>dbo.Service.EnterpriseName</td>
<td></td>
</tr>
<tr>
<td>dbo.Service.PhoneNumber</td>
<td></td>
</tr>
<tr>
<td>dbo.Service.RedirectName</td>
<td></td>
</tr>
<tr>
<td>dbo.Service.RedirectNumber</td>
<td></td>
</tr>
<tr>
<td>dbo.Service.RedirectServiceLevelType</td>
<td></td>
</tr>
</tbody>
</table>

**Note** An ID argument must reference a specific database column based on report category. Appendix B, “Template Libraries and Report Categories” lists the database columns to use with each report category.

Step 3  Click the Operator field and select the operator you want from the drop-down.
Create the SQL Statement

Step 4  Right-click the **Value** field.
    a. Select **Argument** from the popup menu. This opens a dialog box displaying the list of defined arguments.
    b. Select the argument appropriate for your column. Then click **Paste**.

Step 5  As necessary, to add additional Where criteria for the start and end dates, click the **Logical** drop-down list and select **AND**.

See How to Create a Sample Historical Template, page A-11, for an example of a Where clause with start_date and end_date arguments.

**Note**  You can further narrow the scope of the report by adding additional Where criteria that do not use arguments.

Create a Computed Column for the SQL Statement

You can create computed columns in both real-time and historical templates to reflect calculations based on the values of two or more database columns.

**Note**  You can also insert computed fields when you design the layout in the Report Painter. However, computed fields created in the Report Painter do not support WebView’s threshold capabilities or dynamic sorting. Computed columns created in the SQL Select Painter do.

It is best to create computed columns in the SQL Select Painter and to use the Report Painter to modify their formatting, if necessary—for example, by changing the format of the query result from seconds to minutes.

Step 1  Locate the **Compute** tab at the bottom of the Select Painter. This tab initially displays as a blank field.

Step 2  In the **Computed Columns** field, enter a name for the column followed by an equal (=) sign. The computed column name cannot contain spaces.

Step 3  Right-click to the right of the equal sign. Select **Columns** from the popup menu.

Step 4  Select the column you want to use and click **Paste**. This adds the column to the **Computed Columns** field.

Step 5  Enter the symbol for the mathematical operation you want to perform (for example: +, -, /, *).

Step 6  To add the next column for the mathematical expression, right-click again in **Computed Columns**.
Step 7  Select a second column to act upon the first and click **Paste**.

Creating the computed column using the SQL Select Painter results in a basic statement, such as:

```
AvgHandleTime = dbo.t_Service_Half_Hour.HandleTimeToHalf / dbo.t_Service_Half_Hour.CallsHandledToHalf.
```

You might need to edit the query.
Create the SQL Statement

Chapter 3      Creating New Custom Templates

View and Save a Completed SQL Statement

After completing your template’s SQL statement, you can review the entire statement by clicking the Syntax tab in the Select Painter.

This is a read-only view of the SQL. To edit the SQL, click Design > Convert to Syntax.

An example of a completed SQL statement that includes a computed field (AvgHandleTime) and ID, start_date, and end_date arguments:

```
SELECT Service.EnterpriseName, 
    Service_Half_Hour.DateTime, 
    Service_Half_Hour.CallsOfferedToHalf, 
    Service_Half_Hour.CallsHandledToHalf, 
    Service_Half_Hour.AvgDelayQToHalf, 
    Service_Half_Hour.HandleTimeToHalf, 
    Service_Half_Hour.ServiceLevelToHalf, 
    Service_Half_Hour.CallsAbandQToHalf, 
    AvgHandleTime=Service_Half_Hour.HandleTimeToHalf/Service_Half_Hour.CallsHandledToHalf, 
FROM Service, Service_Half_Hour 
WHERE ( Service.SkillTargetID = 
    Service_Half_Hour.SkillTargetID ) and 
    ( ( Service.SkillTargetID = :servicesList ) 
    AND 
    ( Service_Half_Hour.DateTime >= :start_date ) 
    AND 
    ( Service_Half_Hour.DateTime <= :end_date ) ) 
ORDER BY Service.EnterpriseName ASC, 
    Service_Half_Hour.DateTime DESC, 
    Service_Half_Hour.CallsOfferedToHalf ASC
```
Open the Report Painter to Design, Preview, and Test the Template Layout

Once you have completed the SQL Select statement, you are ready to move from the Select Painter to the Report Painter. To do this, click the **Return** button.

---

**Note**

If, when you click **Return**, you see a message asking if you want to correct SQL errors, click **Yes**. It is important to correct SQL errors before you move to the Report Painter.

For a new template, the initial transition from Select Painter to Report Painter moves you through a series of either two or three screens, based on whether you are using a Tabular or a Graphical presentation format.

**If you are using a Tabular presentation**, clicking **Return** opens the Tabular Report Generator. This is a two-screen wizard, where you select color and border settings and review characteristics of the report.

Clicking **Finish** at the second screen (Ready to Create Tabular Report) opens the Report Painter where you can refine the layout and design.

**If you are using a Graph presentation**, clicking **Return** opens the Graph Report Generator. This is a three-screen wizard, where you:

- Select the Category and Values for the graph.
  
  The **Category** axis represents the column whose values will serve as the grouping criteria for the report.

  The **Values** axis represents the column whose values will be measured for each category.

- Enter a Title for the graph and select its style (for example, bar graph or pie chart).

- Review characteristics of the report.

  Click **Finish** at the third screen (Ready to Create Graph Report) to open the Report Painter.

See Chapter 5 of this guide for some basic guidelines on template design.

See Chapter 6, “Maintaining Templates,” for instructions on previewing and testing your new custom template.

---

Save the Template

You must be in the Report Painter to save the report template.

Even if you have not completed the design layout, it is a good idea to save the template as soon as you reach the Report Painter and to continue to save it regularly during the design process.

**To Save the Template**

**Step 1**

With the template displayed in the Report Painter, select **File > Save As**. The Save Report dialog box opens.

**Step 2**

Enter a name for the new template. See **How to Name and Save a Template, page 6-6** for naming guidelines.
Step 3  In the **Comments** field, enter a brief description of the template. This description will display below the template name in WebView.

Step 4  Click **OK**.
Save the Template
Creating Custom Templates Based on Existing Templates

This chapter explains how to create a custom template by opening, modifying, and renaming one of the standard Cisco templates that are installed with WebView.

It includes these sections:

- Overview of Creating a Custom Template Based on an Existing Template, page 4-2
- Check the Database Connection, page 4-2
- Select the Report Category, page 4-3
- Open a Standard Template to Use as a Model, page 4-3
- Save the Standard Template with a New Name, page 4-3
- Make SQL Modifications., page 4-5
- Save the Template, page 4-6

For information on modifying the layout of a template after you have created and saved it, refer to Chapter 5, “Template Layout Guidelines.”
Overview of Creating a Custom Template Based on an Existing Template

It is easier to create a custom template that is based on an existing Cisco template than to create a new template “from scratch”.

If a modified version of an existing template can meet your needs, then creating a custom template by ‘cloning’ an existing template offers these benefits:

• The formatting and alignment are already in place.
• The grouping and retrieval are done.
• Some or most of the columns you need are present.
• Other features, such as sorting, summaries, and computed columns, might already be there.

Check the Database Connection

Before you begin, make sure you are connected to the distributor Admin Workstation database. To do this, from the InfoMaker toolbar, click DB Prof (Database Profiles).

The Profile Name for the database on the Cisco distributor Admin Workstation appears with a checkmark superimposed on it. See Check the Database Connection, page 3-1 for details.
Select the Report Category

When you find a template that approximates the information and the design you want to appear in your custom template, select the report category library for that ‘model’ template as your working library in InfoMaker.

*Table 0-1 on page B-3* that shows the correspondence between the WebView menu and the template library. It is important to work in the correct library. When you save the finished template, it is saved to that library and appears under the report category for that library in the WebView interface.

To select the working library

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the InfoMaker toolbar, click <strong>Library</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Locate the folder for the appropriate report category.</td>
</tr>
<tr>
<td>3</td>
<td>Right-click the <code>ppb050.pbl</code> file in that folder and select <strong>Set as working library</strong>.</td>
</tr>
</tbody>
</table>

Open a Standard Template to Use as a Model

With the database connect established and the appropriate report category set as your working library, the next step is to open the standard template you intend to use as the model for your custom template.

To Open a Template

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Select <strong>File &gt; Open</strong> from the InfoMaker menu.</td>
</tr>
<tr>
<td>2</td>
<td>From the <strong>Open</strong> dialog box, highlight the template that you intend to model and click <strong>OK</strong>.</td>
</tr>
<tr>
<td>3</td>
<td>Enter retrieval values if you want to see data on the Report Painter, or click Cancel to open the template with no data retrieved.</td>
</tr>
</tbody>
</table>

The template opens in the Report Painter.

Save the Standard Template with a New Name

Before you make any changes, save the template with a new name. This keeps the original Cisco template intact.

To Save the Standard Template as a Custom Template

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Select <strong>File &gt; Save As</strong> from the InfoMaker menu.</td>
</tr>
<tr>
<td>2</td>
<td>In the Save Report dialog box:</td>
</tr>
<tr>
<td></td>
<td>a. Change the name of the standard template. See <a href="#">How to Name and Save a Template, page 6-6</a> for naming guidelines.</td>
</tr>
<tr>
<td></td>
<td>b. Change the comment to indicate the nature of the customizations.</td>
</tr>
</tbody>
</table>
Save the Standard Template with a New Name

This comment appears in WebView and helps the reporting user select the correct template.

c. Click **OK** to save the template to the library and return to the Report Painter.

---

**Note**  
If you prefer to ‘hide’ the template while you are working on it, see How to Prevent a Template from Displaying in WebView, page 6-8.
Make SQL Modifications.

One of your goals might be to customize a standard report by changing its SQL statement.

To do this, you can work directly in InfoMaker, or you can copy the SQL statement from InfoMaker and work in another tool, such as SQL Query Analyzer.

This guide assumes that you have a working knowledge of SQL and the Unified ICM database.

Unified ICM tables are described in-depth in the *Database Schema Handbook for Cisco ICM/IPCC Enterprise & Hosted Editions*.

See Create the SQL Statement, page 3-4 for details on what must be included in SQL statements for WebView reports.

To Modify the SQL

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Select <strong>Design &gt; Data Source</strong> from the Report Painter menu to open the SQL Select statement. (To return to the Report Painter from the SQL Select statement, click <strong>Return</strong>.)</th>
</tr>
</thead>
</table>

**Note** The Select Painter allows you to create basic queries, but it does not support sophisticated queries. For this reason, the graphical Select Painter is not available for most of the standard WebView templates.

When you attempt to view the SQL Select Painter (by clicking **Design > Convert to Graphics**), you are likely to see a message asking if you want to continue to Graphics mode. Click **No** to open the SQL in text format.

<table>
<thead>
<tr>
<th>Step 2</th>
<th>From the SQL Select text screen, make any modifications. For example, comment out parameters and add or remove columns.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Step 3</th>
<th>Review the SQL and correct errors before you return to the Report Painter.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 4</strong></td>
<td>When the SQL is complete, click <strong>Return</strong> to review the changes in Report Painter.</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>• Computed fields that are no longer valid are commented out.</td>
<td></td>
</tr>
<tr>
<td>• Fields that are no longer in your result set are deleted.</td>
<td></td>
</tr>
<tr>
<td>• New fields appear to the far right of the detail band.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 5</th>
<th>Select <strong>File &gt; Save</strong> from the InfoMaker menu to save your work.</th>
</tr>
</thead>
</table>

Make Design Modifications

After you modify the SQL statement, review the template in the Report Painter and make any design modifications.

For example, you might need to change headers, to delete or add columns, or to complete summaries.

Refer to the InfoMaker documentation for complete details on report layout.

See Chapter 5 of this guide for basic guidelines on template design.
See Chapter 6, “Maintaining Templates,” for instructions on previewing and testing your new custom template.

**Save the Template**

To save your changes, select **File > Save** from the InfoMaker menu. You can also click **Save** on the toolbar.
Template Layout Guidelines

This chapter has basic guidelines for working in the Report Painter to design or modify template layout. It includes the following sections:

- Template Guidelines, page 5-2
- Template Layout Tips, page 5-3
- How to Design the Layout for a Graphic Template, page 5-5
- How to Design the Layout for a Tabular Template, page 5-6
  - About Panes, Bands, and Properties, page 5-8
  - About HTML Preview, page 5-10
  - How to Modify Column Headings, page 5-11
  - How to Add a Title to the Template, page 5-13
  - How to Make the Template “Web-Ready”, page 5-15
  - How to Modify Column Data Properties, page 5-16
  - How to Align Columns and Headings, page 5-17
  - How to Add a Data Summary Row, page 5-19
  - How to Enable a Tabular Template for Drill-Down, page 5-20
  - How to Add a Column, page 5-21
  - How to Delete a Column, page 5-21

Refer to the Sybase InfoMaker documentation as your complete resource for information on how to enhance the appearance of a report template.
## Template Guidelines

If you follow these guidelines when designing the template layout, your custom template will conform in appearance to the standard Cisco templates.

If you do not follow these guidelines, the displayed format of reports can be unpredictable.

<table>
<thead>
<tr>
<th>Table 5-1 Template Layout Guidelines</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Column type</strong></td>
</tr>
<tr>
<td>-----------------</td>
</tr>
<tr>
<td>Datawindow</td>
</tr>
<tr>
<td>Title</td>
</tr>
<tr>
<td>FROM-TO Dates</td>
</tr>
<tr>
<td>Header Columns</td>
</tr>
<tr>
<td>Header Band</td>
</tr>
<tr>
<td>Detail data (string)</td>
</tr>
<tr>
<td>Detail data (number)</td>
</tr>
<tr>
<td>Detail data (percent)</td>
</tr>
<tr>
<td>Detail data (average)</td>
</tr>
<tr>
<td>Detail data (time)</td>
</tr>
<tr>
<td>Detail data for Half Hour Reports (datetime)</td>
</tr>
<tr>
<td>Detail data for Daily Reports (datetime)</td>
</tr>
</tbody>
</table>
Table 5-1  Template Layout Guidelines  (continued)

<table>
<thead>
<tr>
<th>Column type</th>
<th>Align</th>
<th>Units/Border</th>
<th>Font</th>
<th>Size</th>
<th>Style</th>
<th>BG Color</th>
<th>Text Color</th>
<th>General/Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Summary column</td>
<td>right</td>
<td>no</td>
<td>Arial</td>
<td>8</td>
<td>bold</td>
<td>transparent</td>
<td>window text</td>
<td></td>
</tr>
<tr>
<td>Summary data (number)</td>
<td>right</td>
<td>no</td>
<td>Arial</td>
<td>8</td>
<td>bold</td>
<td>transparent</td>
<td>window text</td>
<td></td>
</tr>
<tr>
<td>Summary data (percent)</td>
<td>right</td>
<td>no</td>
<td>Arial</td>
<td>8</td>
<td>bold</td>
<td>transparent</td>
<td>window text</td>
<td>0.00%</td>
</tr>
<tr>
<td>Summary data (average)</td>
<td>right</td>
<td>no</td>
<td>Arial</td>
<td>8</td>
<td>bold</td>
<td>transparent</td>
<td>window text</td>
<td>0.00</td>
</tr>
<tr>
<td>Summary data (time)</td>
<td>right</td>
<td>no</td>
<td>Arial</td>
<td>8</td>
<td>bold</td>
<td>transparent</td>
<td>window text</td>
<td>00:00:00</td>
</tr>
<tr>
<td>Group summary Band</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>button face</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Summary Band</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>button face</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Template Layout Tips

Borders  Select No Border (0) for all data columns.

Columns  All columns fields (headers, invisible fields, detail, and summary fields) must be aligned and have the same width. A column belonging to each member of a group must have its right edge aligned with the right edge of any adjoining header or detail column.

Computed fields  Any computed fields from header groups 1, 2, 3 used in summary row calculations, or any detail computed fields must have the Visible property unchecked.

Daily reports  Daily reports must have the Date column showing only the date and not the time. Also Daily report titles must say ‘Daily’ and not ‘Half Hour’ report.

Headers  Headers can have no more then three lines. This means that subheaders can consist of no more then two lines. Align headers vertically aligned to the top and center them horizontally. For all templates (except the ‘all fields’ templates) the header name must be the database column name + "_t" for the sorting feature.
### Template Layout Tips

<table>
<thead>
<tr>
<th><strong>HTML</strong></th>
<th>When you create a new template, be sure to check the HTML Datawindow check box.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rows</strong></td>
<td>All rows (invisible fields, detail, and summary fields) must have the same height.</td>
</tr>
<tr>
<td><strong>Toolbars</strong></td>
<td>The Report Painter offers several toolbars. To open a toolbar, select <strong>Tools &gt; Toolbars</strong> from the Report Painter menu. Highlight a toolbar and click <strong>Show</strong>.</td>
</tr>
<tr>
<td><strong>Undo</strong></td>
<td>To undo changes, use Ctrl+Z or select <strong>Edit &gt; Undo</strong> from the menu bar.</td>
</tr>
<tr>
<td><strong>Visible property</strong></td>
<td>Any space and text fields used for alignment must have the ‘Visible’ property unchecked.</td>
</tr>
<tr>
<td><strong>Web-ready</strong></td>
<td>On the General tab for the data window, check Web DataWindow.</td>
</tr>
</tbody>
</table>
How to Design the Layout for a Graphic Template

To specify the layout for a graph template

**Step 1** After completing the template’s SQL statement, click the **Return** button. The Graph Report Generator dialog box opens.

**Step 2** From the **Category** drop-down list, select the template column you want to assign to the **Category** axis. The Category axis represents the column whose values serve as the grouping criteria for the report.

**Step 3** From the **Values** drop-down list, select the template column that you want to assign to the **Values** axis. This axis represents the column whose values are measured for each category.

**Step 4** Optionally, if you want to graph more than one series, select the **Series** check box and specify the column that will provide the series values.

**Step 5** Click **Next**. The Define Graph Style dialog box appears.

**Step 6** In the **Title** field, enter a title for the report. This is the text that will appear at the top of the report when it is viewed online or printed. It also appears alongside the template file name when the template is listed in WebView.

**Step 7** In **Graph Type**, select the graph’s graph type (for example: pie chart or bar chart).

**Step 8** Click **Next**. The attributes of the graph of the graph are displayed.

**Step 9** Click **Finish**. The Specify Retrieval Arguments dialog box opens. Enter valid arguments for the template and click **OK**. The report displays in the Report Painter window.

*Figure 5-1 on page 5-6* shows a sample graphical report as it appears in the Report Painter.

---

**Note** For Graphical Reports, selecting **Design > HTML Preview** from the InfoMaker menu does not display the report as a graphic.
How to Design the Layout for a Tabular Template

Additional Design Options for Graphs

Once your graphical template launches in the Report Painter, it is functionally complete and ready to save and use.

The Report Painter gives you additional options for customizing the design of report templates.

It also allows you to change the selections you made earlier in the Graph Report Generator and Define Graph Style dialog boxes.

These and other features of the Report Painter window lie outside the scope of this document. For more information on using the Report Painter, consult your InfoMaker documentation.

How to Design the Layout for a Tabular Template

To specify the layout for a tabular template

Step 1  After completing the template’s SQL statement, click the Return button. The Tabular Report Generator dialog box opens.

Note  If, when you click Return, the following message displays: “Data conversion resulted in overflow. Do you want to correct errors?” select Yes and then click Return again.

Step 2  Specify the template’s background, text, and column colors. See Template Guidelines, page 5-2.

Step 3  Click Next to see a dialog box listing the attributes of the tabular template.
**Step 4**  
Click **Finish**. The Specify Retrieval Arguments dialog box opens. Enter valid arguments for the template and click **OK**. The report displays in the Report Painter window.

InfoMaker transfers the table and column data you selected in the SQL statement into a basic, ‘no frills’ layout.

Column names appear exactly as they are stored in the database.

The template title does not appear in the header, and the template has no groupings or subheadings which might make it more intuitive to a reporting user.

**Figure 5-2 on page 5-8** shows how a tabular report initially appears in the Report Painter.

The pages that follow contain basic procedures for refining the default InfoMaker layout for tabular reports.
About Panes, Bands, and Properties

Panes

The Report Painter interface has multiple panes of information. This figure shows the Default layout of panes (View > Layouts > Defaults).

Figure 5-2 The Report Painter - Panes

To open a pane, select it from the View menu.

To close a pane, place your cursor near the top right corner of the pane and click the close icon [X] when it becomes visible.

Properties

Each part of the report layout (for example, bands, columns, and computed fields) has a tabbed set of Properties appropriate to that part.

Many Properties have more tabs that can display at one time. Use the arrows at the top left of the Properties to move among the tabs.
Bands

The Design pane is divided into four bands.

<table>
<thead>
<tr>
<th>bands</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Header</strong></td>
<td>Displays information at the top of every screen and page, such as the title</td>
</tr>
<tr>
<td><strong>Detail</strong></td>
<td>Displays data from the database as well as computed values based on data</td>
</tr>
<tr>
<td><strong>Summary</strong></td>
<td>Displays information that appears beneath the data, such as totals and counts,</td>
</tr>
<tr>
<td><strong>Footer</strong></td>
<td>Displays information that appears at the bottom of the page.</td>
</tr>
</tbody>
</table>

- The **Header** band displays information at the top of every screen and page, such as the title of the report and the column names. It also prints on every page.

  **Note**  The Header band is locked in WebView. It does not scroll with the page. Because it does not scroll, make sure that the background of the Header band is Button Face, as indicated in the Template Guidelines on page 5-2, and not transparent so that people do not see overlapping text when they scroll.

  See To Change the Header Band, page 5-13 for more on this.

- The **Detail** band displays data from the database as well as computed values based on data from the database.
- The **Summary** band displays information that appears beneath the data, such as totals and counts, averages, and maximums.
- The **Footer** band displays information that appears at the bottom of the page.
About HTML Preview

Select Design > HTML Preview to review your tabular template as an HTML file in a new window. You cannot use this functionality for graphical templates, but it is a convenient way to see your progress as you work on the layout of a tabular template.

Your first view of a report, when it initially opens in Report Painter, will show a layout that you most likely will want to refine. Figure 5-3 is an example.

Figure 5-3 Initial HTML Preview for a Template

<table>
<thead>
<tr>
<th>Service Entitlement</th>
<th>Service Half Hour Datetime</th>
<th>Service Half Hour Callsreferred</th>
<th>Service Half Hour Callsabandoned</th>
<th>Service Half Hour Servicelevel</th>
<th>Service Half Hour Avgdelay</th>
</tr>
</thead>
<tbody>
<tr>
<td>CVG.44975 OCAT_CiscoLineTest</td>
<td>12/8/2004 20:30:00</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>CVG.44975 OCAT_CiscoLineTest</td>
<td>12/8/2004 20:00:00</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Click the close box to close the HTML Preview and return to the Report Painter.

**Note** Not all design selections appear in the HTML Preview. One example is setting the background color for the Header Band to ‘button face’, as indicated in the Template Guidelines. This color selection does not appear until you generate a report from the template in WebView.
How to Modify Column Headings

This section explains how to modify the attributes of a column header in a tabular report template. Do this, for example, to replace the database names with ‘user-friendly’ names and to make other modifications as indicated in the Template Guidelines.

To Change the Column Heading Name

**Step 1** In the Design window, in the Header Row box, click the column header you want to modify. The header’s attributes display in the Properties Window.

**Step 2** In the Text field on the General Properties tab, type the name you want to appear in the column heading.
To Change the Format of the Column Headings

Note that the Template Guidelines, page 5-2, indicate that the header columns are to be centered, and to use Arial 8 Bold for text, with Window text color, on a transparent background.

Follow these instructions to make your headings comply with the guidelines:

Step 1  Click the first heading (at the far left).
Step 2  Click Edit > Select > Select Right.
Step 3  In the General Properties tab, make sure the Alignment is Center.
Step 4  In the Font Properties tab, set the values to Arial, 8, Bold, Windows Text, and Transparent.
To Change the Header Band

Note that the Template Guidelines, page 5-2, indicate that the header band use the background color ‘Button Face’.

Follow these instructions to make all your headings comply with this guideline:

**Step 1** Click in the header band.

**Step 2** In the General Properties tab, change the background color selection to **Button Face**.

How to Add a Title to the Template

This section explains how to add a title to the template header by moving the column names down and adding title text above them.

**Step 1** Place your cursor on the header band until it changes to an up/down arrow.

**Step 2** Drag the band down to increase the size of the header area.

**Step 3** Use **Ctrl-Click** or **Edit > Select All** to select all column headers. Then drag them down.

Refer to the InfoMaker documentation for various methods of selecting multiple controls.

**Step 4** Select **Insert > Control > Text** or click the Text box tool from the Stylebar.

**Step 5** Click in the header band where you want the title to appear.

**Step 6** Add text for the title in the Text box or in the General Properties tab.
Step 7  Format and position the title.
How to Make the Template “Web-Ready”

To enhance your template’s appearance in a browser window, in the General Properties tab, check **Web DataWindow**.

The illustration below shows a template before and after this property is checked.

**Figure 5-4** Template Without the Web DataWindow Property

<table>
<thead>
<tr>
<th>Peripheral Service Name</th>
<th>Date and Time</th>
<th>Calls Offered</th>
</tr>
</thead>
<tbody>
<tr>
<td>CVG.44975,CCAT_CiscoLiveTest</td>
<td>12/8/2004 20:30:00</td>
<td>0</td>
</tr>
<tr>
<td>CVG.44975,CCAT_CiscoLiveTest</td>
<td>12/8/2004 20:00:00</td>
<td>0</td>
</tr>
</tbody>
</table>

**Figure 5-5** Template With the Web DataWindow Property

<table>
<thead>
<tr>
<th>Peripheral Service Name</th>
<th>Date and Time</th>
<th>Calls Offered</th>
</tr>
</thead>
<tbody>
<tr>
<td>CVG.44975,CCAT_CiscoLiveTest</td>
<td>12/8/2004 20:30:00</td>
<td>0</td>
</tr>
<tr>
<td>CVG.44975,CCAT_CiscoLiveTest</td>
<td>12/8/2004 20:00:00</td>
<td>0</td>
</tr>
</tbody>
</table>
How to Modify Column Data Properties

To modify the attributes of a data column in a tabular report template

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the <strong>Design</strong> window, in the <strong>Detail Row</strong> box, click the column you want to modify. To select multiple columns, hold down the <strong>Ctrl</strong> key as you select them. The column’s attributes display in the Properties Window.</td>
</tr>
<tr>
<td>2</td>
<td>In the <strong>Properties</strong> window, modify the data column’s font, border, alignment, format, and other attributes as desired.</td>
</tr>
</tbody>
</table>

To Change a Column’s Display Format

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the <strong>Header</strong> row, click the column’s header to select it.</td>
</tr>
<tr>
<td>2</td>
<td>From the <strong>Edit</strong> menu, choose <strong>Select &gt; Select Below</strong> to select all rows in the column.</td>
</tr>
<tr>
<td>3</td>
<td>From the <strong>Format</strong> menu, select a format for the column (for example: Percent).</td>
</tr>
</tbody>
</table>
How to Align Columns and Headings

InfoMaker offers considerable functionality for controlling the size, space, and alignment of controls, such as report headings and the columns that display beneath them.

This section introduces you to these features. Refer to the Sybase documentation for details.

To Select all Headings or all Columns:

Step 1  Click on the first heading or column (the one to the far left).
Step 2  From the InfoMaker menu, select Edit > Select > Select Right.

To Align Controls

Step 1  Select the control whose position you want to align with respect to the others.
Step 2  Click (select) the control(s) you want to align with the first one.
Step 3  Select Format > Align from the menu, or click the Format button.
Step 4  Select the dimension you want to align.

Examples:

To align a Heading with the Column beneath it:

- Select the Heading.
- Select the Column.
- Click Align, then select Align L.

To align the bottom edges of all headings:

- Click the first heading at the far left.
- Select Edit > Select > Select Right.
- Click Align, then select Align B.

To Display Boundaries for Controls

Step 1  Select Design > Options from the InfoMaker menu.
Step 2  Check Show Edges.

The boundaries display in Design view but do not display when you run the report.

To Work with a Grid and Ruler in the Report Painter

Step 1  Select Design > Options from the InfoMaker menu.
Step 2  Check Show Grid and Show Ruler.
To Resize a Control

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Select it.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Resize with the mouse by grabbing the edge and dragging.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Resize with the keyboard by pressing the Shift key and then the Right, Left, Down, or Up arrow key.</td>
</tr>
</tbody>
</table>
How to Design the Layout for a Tabular Template

How to Add a Data Summary Row

You might want to add a row that will summarize; for example, give a total or average of the values in some of the template’s data columns.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>In the Design window, click and drag the Summary bar to create room for a new blank row.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>In the Header Box, click the header of the first column for which you want to create a summary.</td>
</tr>
<tr>
<td>Step 3</td>
<td>From the Edit menu, choose Select &gt; Select Below to highlight all column cells.</td>
</tr>
<tr>
<td>Step 4</td>
<td>From the Insert menu, choose Control &gt; followed by the desired summary type (that is, Average, Count, or Sum). A summary field for the column is added to the new row displaying the field’s syntax.</td>
</tr>
</tbody>
</table>

**Note** Simple calculations (such as summary row data) can be done in the Report Painter design mode. More complex computed columns (such as the Average Handle Time column) must be created in the SQL data source mode in order for the template to have threshold capabilities when launched in WebView.

| Step 5 | Repeat steps 1-4 to add additional summary fields, as desired. |

**Note** Some summary fields might require more complex calculations than can be described in this guide. Examples of more complex calculations can be found in some of the WebView standard templates.

<table>
<thead>
<tr>
<th>Step 6</th>
<th>To add a row label for the summary row:</th>
</tr>
</thead>
<tbody>
<tr>
<td>a.</td>
<td>On the InfoMaker toolbar, click Text.</td>
</tr>
<tr>
<td>b.</td>
<td>In the Detail window, click in an open area in the summary row. A selected Text field appears.</td>
</tr>
<tr>
<td>c.</td>
<td>On the General tab in the Properties window, navigate to the Text field and enter a label.</td>
</tr>
</tbody>
</table>
How to Enable a Tabular Template for Drill-Down

WebView’s drill-down feature allows users to launch a detailed sub-report from within the current report window. The sub-report uses the same retrieval argument values as the report from which it was launched.

Drill-down is supported for tabular templates only, and only for templates created for these report categories:

- Enterprise Service
- Enterprise Skill Group
- Peripheral
- Peripheral service
- Peripheral skill group

To Enable Drill-down

**Step 1** Click the column name.

**Step 2** In the General tab in the Properties window, modify the column name to remove the table, but do not change the column name.

For example, change the column specification `service_enterprisename` to `enterprisename`. It must be `enterprisename`. Do not change it.
How to Add a Column

To Add a Column

Step 1 Position the cursor where you want to add a column. If the column location will be the last column in the table, go to Step 3. Otherwise go to Step 2.

Step 2 If you need to make space for the column between other columns, select the columns that will be to the right of the new column and move them to the right, while keeping their alignment.

You can do this by holding down the Ctrl key while clicking on each of the fields in each column that you want to move and then moving the cursor.

Step 3 Enter the new header and field information for the new column, align the new fields, and then align the column with the other columns.

To align fields, select the fields while holding down the Ctrl key and then select Format > Align.

If you have any questions, see the InfoMaker online help.

How to Delete a Column

To Delete a Column

Step 1 While holding down the Ctrl key, select each field in the column.

Step 2 Right click the mouse, and from the pop-up menu, click Delete.

Step 3 Select any columns to the right of the missing column and move them to the left to fill the empty column space, making sure the alignment remains between all columns.
Maintaining Templates

This chapter explains procedures you might need to perform with custom templates. It contains these sections:

- How to Edit a Template, page 6-2
- How to Preview and Test a Template, page 6-4
- How to Delete a Template, page 6-5
- How to Name and Save a Template, page 6-6
- How to Access New Templates in WebView, page 6-7
- How to Prevent a Template from Displaying in WebView, page 6-8
- How to Distribute Templates to Other Template Libraries, page 6-9
How to Edit a Template

You can edit any template to change its layout or SQL statement.

As noted in Chapter 4, do not modify a Cisco-provided template unless you save it as a new (custom) template. If you modify a Cisco template and save it with the same name, that template is no longer supported.

If you change a Cisco template and forget to rename it before you save it, you can revert to the original Cisco template by running the PATCHPBL utility. See The PATCHPBL Utility, page C-8 for the procedure to do this.

If you intend to keep the modification as a custom template, be sure to rename it before you run PATCHPBL.

To edit a template

Step 1 Set the current library file:

a. From the InfoMaker main window, on the toolbar, click Sel Lib. The Select Library dialog box opens.

b. Browse to and double-click the library you want to set as the current library. The Select Library dialog box closes.

Step 2 From the InfoMaker main window, on the toolbar, click Open. The Open dialog box opens, displaying the list of templates in the current library.

Step 3 Select the template you want to modify and click OK. The template opens in the Report Painter.

When prompted, enter retrieval arguments to display data, or click Cancel to open the template with no data.

Step 4 Make desired SQL Statement modifications.

There are two ways to open the SQL from the Report Painter:

• From the Report Painter, click the SQL Data button.

• From the Report Painter menu, select Design > Data Source.
The graphical Select Painter is not available for most of the standard WebView templates. The Select Painter allows you to create basic queries, but it does not support sophisticated queries.

If you attempt to view the SQL in the Select Painter (by clicking Design > Convert to Graphics), you are likely to see a message asking if you want to continue to Graphics mode. Click No to open the SQL in text format.

**Step 5**  
From the SQL Select text screen, make any modifications. For example, comment out parameters and add or remove columns.

**Step 6**  
Review the SQL and correct errors before you click Return to return to the Report Painter.

**Step 7**  
Make desired layout changes in the Report Painter.


**Step 8**  
Save your edits.

- To save the existing template with your modifications, click File > Save.
- To save the modified file as a new (custom) template, click File > Save As.
How to Preview and Test a Template

You can preview report templates directly from InfoMaker to check layout and to test data retrieval.

How to Preview and Test an Open Template in Report Painter

You can preview open templates in the Preview window in the Report Painter. The Preview window is a child window which, by default, is tiled within the Report Painter. For best viewing, maximize it.

To maximize the Preview window:

Step 1  In the Report Painter, position your mouse point near the top of the Preview window, until a window bar with a Maximize button appears.
Step 2  Click the Maximize box. The Preview window expands to full-screen mode.
Step 3  To test that data is retrieved successfully from the template, click Retrieve.
Step 4  When prompted, provide values for the required arguments.

How to Preview an Open Template in the Browser

Step 1  From the Report Painter menu, select Design > HTML Preview.
The template opens in a browser window,
Step 2  Close the browser (by selecting File > Close or by clicking x) to return to the Report Painter.

How to Preview a Closed Template

At any time, from any place in InfoMaker, you can preview any template in the current library, even if the template is not currently open.

To preview a closed template:

Step 1  From the File menu, select Run/Preview. The Run/Preview dialog box opens, displaying all of the templates in the current library.
(To preview a template from a different library, close the dialog box and set the current Library as described in Select the Report Category Library, page 3-3.)
Step 2  Select the template you want to preview and click OK. The template displays in preview mode.
Step 3  Optionally, to retrieve data into the displayed template, from the Rows menu, select Retrieve. If prompted, provide values for required arguments.
How to Delete a Template

As necessary, you can delete custom template files. Once a template is deleted, it is no longer available for use in WebView.

Note: Do not delete a Cisco-provided standard template.

To delete a template:

Step 1: From the toolbar on the InfoMaker main window, click Library to open the Library Painter.
Step 2: Browse to the directory containing the template’s library file.
Step 3: Double-click the library file to display its contents.
Step 4: Right click on the template you want to delete.
Step 5: From the popup menu, select Delete.
Step 6: Refresh the report cache to make certain the template’s menu item is removed from WebView (for instructions on refreshing the cache, see WebView online help).

Note: If WebView users have created and saved reports based on a subsequently deleted custom template, these reports will continue to exist in WebView and will throw errors when run. Therefore, after deleting a custom template, be certain to delete any associated reports in WebView.
How to Name and Save a Template

When you save a template, it saves within the current library file. This is the category in which it will be displayed from WebView.

To save a report template:

**Step 1** With the template displayed in the Report Painter, select **File > Save As**. The Save Report dialog box opens.

**Step 2** Enter a name for the new template. When naming a template:

- You cannot use spaces.
- Choose an intuitive name that describes the template’s basic attributes (for example: `AgentSkillGroup_Logout`). This will be helpful to the reporting users who select the template in WebView.
- Avoid choosing a name that could be overwritten by subsequent installations of WebView that might include new Cisco templates. A simple workaround to this is to append the word “custom” to the name.
- If you want the template to display in the appropriate environment list in WebView (Unified ICM/CCE Templates), use the following prefixes:

| For templates that can be used to report only on Unified ICM with CCE configurations: | ipcc_template-name_custom |
| For templates that can be used to report only on Unified ICM legacy ACD configurations: | olds_template-name_custom |
| For templates that can be used to report on Unified ICM with CCE and Unified ICM with legacy ACD configurations: | both_template-name_custom or use no prefix template-name_custom |

**Note** Custom template names are truncated to the second underscore when they appear in the WebView interface. For this reason, use the `ipcc`, `olds`, or `both` prefix as indicated above, then enter the template names without underscores (you can use hyphens), and then append `_custom` at the end.

For example: `ipcc_cc-agent-realtime_custom`.

**Step 3** In the **Comments** field, enter a brief description of the template. This description will display below the template name in WebView.

**Step 4** Click **OK**.

**Note** Saving a template deploys it (makes it visible from) WebView.

See How to Prevent a Template from Displaying in WebView, page 6-8 for methods for “hiding” incomplete or untested templates from WebView.
How to Access New Templates in WebView

The custom templates you create and save in InfoMaker are immediately available to WebView and, following a refresh of the report cache, appear alongside the standard report templates in the WebView interface.

To access a new template
- Start WebView
- Locate the report category and click Create a Report.
- Scroll to the bottom of the Create a Report page and click Refresh the list of templates.
- Run the report.

How to Start WebView

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Open a browser window. In the Address bar, enter a URL comprised of the server name and the Unified ICM instance on that server whose templates you want to view. For example: http://my_aw_server/instance1.</td>
</tr>
<tr>
<td>2</td>
<td>Enter your WebView username and password.</td>
</tr>
<tr>
<td>3</td>
<td>Click OK. The WebView main page opens.</td>
</tr>
<tr>
<td>4</td>
<td>Click WebView Reporting. The Welcome to WebView Reporting page opens.</td>
</tr>
</tbody>
</table>

How to Locate the Report Category in WebView

The left panel of the WebView screen lists all the report categories. Some categories have nested subcategories. For example, the Agent category has four subcategories: Agent by Agent, Agent by Peripheral, Agent by Skill Group, and Agent by Team.

Locate the category in the WebView interface that corresponds to the report category library to which you saved the template.

See Table 0-1 on page B-3 for a list of WebView categories and their associated report libraries.

How to Refresh the Cache

Template file names are stored in a cache on the WebView server. At startup, WebView reads this cache to determine what templates are available for use.

When you create a new template, it might be necessary to refresh the cache before your new template becomes visible in WebView.

To Refresh the Cache Immediately, Without Restarting IIS

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Open the report category for the new template.</td>
</tr>
<tr>
<td>2</td>
<td>Scroll to the bottom of the page.</td>
</tr>
</tbody>
</table>
How to Prevent a Template from Displaying in WebView

In some cases, you might prefer that a template not be available in WebView. This might be the case, for example, if it is only partially complete or if it requires a period of internal testing.

There are several strategies you can use to ‘hide’ a template from WebView until such time as you are ready to make it visible.

- WebView only displays templates that contain valid SQL arguments. Therefore, you can hide a template by omitting its arguments until you are ready to use it.
- WebView only displays templates stored in the standard libraries that ship with the Cisco Unified ICM/CCE Setup CD. Therefore, you can hide a template by creating and storing it in your own library file. Once you are ready to use it, you can move it to one of the standard template libraries.

How to Run a Report from the New Template in WebView

Once you have refreshed the cache, you can run a report based on the new template.

To Run a Report

Step 1  From the report menus on the left side of the WebView screen, expand the menu that corresponds to the template’s report type.

Step 2  Select Create a Report.

Step 3  Select the template and Click Next.

Step 4  As prompted, select whatever items you want to include in the report. If you are creating an historical report, you will also be prompted to specify a date/time range.

Step 5  Click Finish.

Once you generate a report from a template, you can save it to a report definition file. The custom report templates remain listed in the template launcher until you delete them.

For more information on accessing and using WebView, see the WebView Installation and Administration Guide for Cisco ICM/IPCC Enterprise & Hosted Editions and WebView’s online Help.

Note  As with the standard templates, when you open a new custom template in WebView you can make further changes and additions such as adding thresholds and drill-downs (for those templates that support WebView’s drill-down and threshold features).
How to Distribute Templates to Other Template Libraries

To make a custom report template available from a different WebView server, or from a different library on the current WebView server, you must copy its file and move the copy to the desired target library.

To move as template file using InfoMaker:

1. Launch InfoMaker.
2. On the InfoMaker toolbar, click Library.
3. Browse to the Library containing the template you want to copy. Expand the Library to display its templates.
4. Right-click on the desired template and select Copy from the popup menu. The Select Library dialog box opens.
5. Browse to the target template library.
6. Click Open. If that library already contains an identically-named template, InfoMaker will prompt you for confirmation before it overwrites the file.

Note: Overwriting an entire template library file with one from a different WebView server will cause the loss of customized templates currently stored in the overwritten library.
Creating Sample Report Templates

This appendix has instructions for creating two sample templates. Practicing with these samples can be helpful before you begin to create templates that you will make available for actual use in the WebView application.

These instructions assume that you have installed InfoMaker, have created an ODBC connection to the reporting database, and are familiar with the basics of InfoMaker described in the previous chapters.

This appendix contains these sections:

• Sample Real-Time Template, page A-2
• Sample Historical Template, page A-8
Sample Real-Time Template

This section provides instructions for creating a template that retrieves real-time data from the Admin Workstation database for several selected peripheral services. It employs a SQL statement with a single retrieval argument and presents the results as a 3D Pie Chart.

The completed template produces a report that looks similar to the following example.

For each service, this template shows two pieces of information from the tables in the Distributor Admin Workstation database:

- The box on the left shows the *category*, or subject of the report template. The category identifies the entities for which the template will retrieve data. In this example, the category is Enterprise Name (from the *Service* table).
- Calls Offered (from the *Service_Real_Time* table) is the *value* displayed for each entity.

Specifications for the Sample Real-Time Template

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set as Working Library</td>
<td>icm&lt;icm_instance_name&gt;\aw\custom\persvc\ppb050.pbl</td>
</tr>
<tr>
<td>Presentation Style</td>
<td>Graph</td>
</tr>
<tr>
<td>Tables</td>
<td>• Service</td>
</tr>
<tr>
<td></td>
<td>• Service_Real_Time</td>
</tr>
<tr>
<td>Table Columns</td>
<td>• Service.EnterpriseName</td>
</tr>
<tr>
<td></td>
<td>• Service_Real_Time.CallsOfferedHalf</td>
</tr>
</tbody>
</table>
### Table 0-1  Sample Real-time Template Specifications (continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
</table>
| Retrieval Argument      | • **Name:** list_of_persvc  
                           | • **Type:** Number array                          |
| Where Clause            | • **Column:** Service.SkillTargetID  
                           | • **Operator:** in  
                           | • **Value:** (argument) : list_of_persvc         |
| Layout                  | • **Category:** Service_EnterpriseName  
                           | • **Values:** Service_Real_Time_CallsOfferedHalf  
                           | • **Title:** Calls Offered                      
                           | • **Graph Type:** 3D Pie Chart                   |
| Template File Name      | custom_real-time-callsoffered                    |
Appendix A      Creating Sample Report Templates

How to Create a Sample Real-Time Template

Step 1  Select the Library and Presentation Style as follows:
   a.  Launch InfoMaker. From the InfoMaker toolbar, select Library.
   b.  Locate the persvc folder. Right-click the ppb050.pbl file, and select Set as working library.
   c.  From the InfoMaker toolbar, select File > New.
   d.  From the New dialog box, click the Object tab. Then select Graph, and click OK. This launches the Graph Report Generator screen.

Step 2  Select the Data Source, Tables, and Columns as follows:
   a.  At the Graph Report Generator screen, select SQL Select and click Next.  
       This opens the Select Tables dialog box on the Select Painter screen.
   b.  Scroll down to locate and click the Service table. Continue to scroll down and click the Service_Real_Time table. Click Open.

   The Select Painter now contains two tables.
   c.  Add columns from these two tables follows:
      – From the Service Table, locate and click EnterpriseName.
      – From the Service_Real_Time table, locate and click CallsOfferedHalf.
Step 3 Specify the Retrieval Argument and Where clause as follows:

a. From the InfoMaker toolbar, select Design > Retrieval Arguments.

b. At the Specify Retrieval Arguments dialog box, type list_of_persvc in the Name field and select Number array in the Type field. Click OK.

c. Click the Where tab at the bottom of the Table Layout screen.

d. To create the Where clause, click in the fields as follows:
   • for Column, select Service.SkillTargetID from the drop-down list
   • for Operator, select in from the drop-down list
   • for Value, right click, select Arguments. Then select and paste: list_of_persvc

Step 4 From the InfoMaker toolbar, click Return. This opens the Graph Report Generator wizard.

Step 5 Select Layout as follows:

a. At the first Graph Report Generator dialog box:
   – Click the drop-down arrow for Category and select service_enterprisename.
   – Click the drop-down arrow for Value and select service_real_time_callsofferedhalf.
   – Click Next.

b. At the Define Graph Style dialog box:
   – Enter Calls Offered in the Title field.
   – Select 3D Pie for the graph style.
c. At the Ready to Create Graph Report screen, review your selections and click **Finish**.

This opens the graph in the Report Painter window, with the Specify Retrieval Arguments dialog box superimposed.

**Step 6** At the Specify Retrieval Arguments dialog box, enter IDs that corresponds to your database and click **OK**.

See *Additional Design Options for Graphs, page 5-6* for information on working with a graphical report in the Report Painter.

**Step 7** From the toolbar, select **File > Save**.
Step 8  At the Save Report dialog box:

- Save the file with the name `custom_real-time-callsoffered`.
- Make sure the appropriate Library is selected.
- Click OK.
Sample Historical Template

This section provides instructions for creating a sample historical report template that displays data for selected peripheral services.

The completed template will produce a report that looks similar to the following example:

<table>
<thead>
<tr>
<th>Peripheral Service Name</th>
<th>Date and Time</th>
<th>Calls Offered</th>
<th>Calls Handled</th>
<th>Service Level %</th>
<th>Avg. Delay in Queue</th>
</tr>
</thead>
<tbody>
<tr>
<td>CVG44713_CSH_East</td>
<td>12/8/2004 20:30:00</td>
<td>0</td>
<td>0</td>
<td>0.00%</td>
<td>0</td>
</tr>
<tr>
<td>CVG44713_CSH_East</td>
<td>12/8/2004 20:00:00</td>
<td>0</td>
<td>0</td>
<td>0.00%</td>
<td>0</td>
</tr>
<tr>
<td>CVG44713_CSH_East</td>
<td>12/8/2004 19:30:00</td>
<td>0</td>
<td>0</td>
<td>0.00%</td>
<td>0</td>
</tr>
<tr>
<td>CVG44713_CSH_East</td>
<td>12/8/2004 19:00:00</td>
<td>0</td>
<td>0</td>
<td>0.00%</td>
<td>0</td>
</tr>
<tr>
<td>CVG44713_CSH_East</td>
<td>12/8/2004 18:30:00</td>
<td>0</td>
<td>0</td>
<td>0.00%</td>
<td>0</td>
</tr>
</tbody>
</table>

For each service, this template shows the following pieces of information from tables in the reporting database:

- Enterprise Name (from the Service table) is the category, or subject of the report template. The category identifies the entities for which the template will retrieve data.
- From the Service_Half.Hour table, the following values are displayed for each entity in the report template:
  - DateTime
  - CallsOfferedToHalf
  - CallsAbandQToHalf
  - ServiceLevelToHalf
  - AvgDelayQToHalf
  - CallsHandledToHalf
  - HandleTimeToHalf

Specifications for the Sample Historical Template

Table A-2 Sample Historical Template Specifications

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reporting Element / Template Library</td>
<td>icm\icm_instance_name\aw\custom\persvc\ppb050.pbl</td>
</tr>
<tr>
<td>Presentation Style</td>
<td>Tabular</td>
</tr>
</tbody>
</table>
### Table A-2 Sample Historical Template Specifications (continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>• Service</td>
</tr>
<tr>
<td></td>
<td>• Service_Half_Hour</td>
</tr>
<tr>
<td>Table Columns</td>
<td>• Service.EnterpriseName</td>
</tr>
<tr>
<td></td>
<td>• Service_Half_Hour.DateTime</td>
</tr>
<tr>
<td></td>
<td>• Service_Half_Hour.CallsOfferedToHalf</td>
</tr>
<tr>
<td></td>
<td>• Service_Half_Hour.CallsAbandQToHalf</td>
</tr>
<tr>
<td></td>
<td>• Service_Half_Hour.ServiceLevelToHalf</td>
</tr>
<tr>
<td></td>
<td>• Service_Half_Hour.AvgDelayQToHalf</td>
</tr>
<tr>
<td></td>
<td>• Service_Half_Hour.CallsHandledToHalf</td>
</tr>
<tr>
<td></td>
<td>• Service_Half_Hour.HandleTimeToHalf</td>
</tr>
<tr>
<td>Retrieval Argument</td>
<td>Name: services_list</td>
</tr>
<tr>
<td></td>
<td>Type: Number array</td>
</tr>
<tr>
<td></td>
<td>Name: start_date</td>
</tr>
<tr>
<td></td>
<td>Type: DateTime</td>
</tr>
<tr>
<td></td>
<td>Name: end_date</td>
</tr>
<tr>
<td></td>
<td>Type: DateTime</td>
</tr>
<tr>
<td>Where Clause</td>
<td>Create a three part Where clause with these attributes:</td>
</tr>
<tr>
<td></td>
<td>Column: Service.SkillTargetID</td>
</tr>
<tr>
<td></td>
<td>Operator: IN</td>
</tr>
<tr>
<td></td>
<td>Value: (argument) :services list</td>
</tr>
<tr>
<td></td>
<td>AND</td>
</tr>
<tr>
<td></td>
<td>Column: Service_Half_Hour.DateTime</td>
</tr>
<tr>
<td></td>
<td>Operator: &gt;=</td>
</tr>
<tr>
<td></td>
<td>Value: (argument) :start_date</td>
</tr>
<tr>
<td></td>
<td>AND</td>
</tr>
<tr>
<td></td>
<td>Column: Service_Half_Hour.DateTime</td>
</tr>
<tr>
<td></td>
<td>Operator: &lt;=</td>
</tr>
<tr>
<td></td>
<td>Value: (argument) :end_date</td>
</tr>
<tr>
<td>Sort Order</td>
<td>Set the sort order so that records display first by</td>
</tr>
<tr>
<td></td>
<td>Service.EnterpriseName in ascending order, and then by</td>
</tr>
<tr>
<td></td>
<td>Service_Half_Hour.DateTime in descending order.</td>
</tr>
</tbody>
</table>
### Appendix A  Creating Sample Report Templates

#### Sample Historical Template Specifications (continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Layout:** | In the Report Painter, set these attributes for the template:  
**Title:** Tasks Offered  
**Column Names:**  
Modify the default Column Header names to the following:  
- `Service.EnterpriseName` to Peripheral Service Name  
- `Service_Half_Hour.DateTime` to Date and Time  
- `Service_Half_Hour.CallsOfferedToHalf` to Calls Offered  
- `Service_Half_Hour.CallsAbandQToHalf` to Calls Aband. in Queue  
- `Service_Half_Hour.ServiceLevelToHalf` to Service Level%  
- `Service_Half_Hour.AvgDelayQToHalf` to Avg. Delay in Queue  
- `Service_Half_Hour.CallsHandledToHalf` to Calls Handled  
- `Service_Half_Hour.HandleTimeToHalf` to Handle Time |
| **Row and Column Formatting:** | Adjust row heights and column widths to appropriate viewing sizes.  
Center all Column header labels. Set all numeric column data to align right.  
Set the display format of data in the `Service_Half_Hour.ServiceLevelToHalf` column to percent (%).  
Summary row: Create a summary row that includes data totals for the following:  
Average of `Service_Half_Hour.ServiceLevelToHalf`  
Sum of `Service_Half_Hour.CallsOfferedToHalf`  
Sum of `Service_Half_Hour.CallsAbandQToHalf`  
Sum of `Service_Half_Hour.CallsHandledToHalf`  
Sum of `Service_Half_Hour.HandleTimeToHalf` |
| **Template File Name** | Save the template as:  
custom_taskanalysis_halfhour |
How to Create a Sample Historical Template

Step 1  Select the Library and Presentation Style as follows:

a. Launch InfoMaker. From the InfoMaker toolbar, select Library.

b. Locate the persvc folder. Right-click the ppb050.pbl file, and select Set as working library.

c. From the InfoMaker toolbar, select File > New.

d. From the New dialog box, click the Object tab. Then select Tabular, and click OK. This launches the Tabular Report Generator screen.

Step 2  Select the Data Source, Tables, and Columns as follows:

a. At the Tabular Report Generator screen, select SQL Select and click Next.

This opens the Select Tables dialog box on the Select Painter screen.

b. Scroll down to locate and click the Service table. Continue to scroll down and click the Service_Half_Hour table. Click Open.

The Table Layout screen now contains two tables.

c. Add columns from these two tables follows:

- From the Service Table, locate and select EnterpriseName.
- From the Service_Half_Hour table, locate and select these seven columns:
  DateTime
  CallsOfferedToHalf
  CallsHandledToHalf
  CallsAbandQToHalf
  ServiceLevelToHalf
  AvgDelayQToHalf
Step 3  Specify the Retrieval Argument and Where clause as follows:

a. From the InfoMaker toolbar, select Design > Retrieval Arguments.
b. At the Specify Retrieval Arguments dialog box, enter these three retrieval arguments:
   - list_of_persvc with Type Number array. Click Add.
   - start_date with Type DateTime. Click Add.
   - end_date with Type DateTime
   - Click OK.

Step 4  Create the Where clause as follows:

a. Click the Where tab at the bottom of the Table Layout screen.
b. Create this three-part Where clause:
   • for Column, select Service.SkillTargetID from the drop-down list.
   • for Operator, select in from the drop-down list.
   • for Value, right click, select Arguments, and paste :list_of_persvc.
c. for Logical select and to add a second row.
d. for Column, select Service_Half_Hour,DateTime.
e. for Operator, select >.
f. for Value, right click, select Arguments, and paste :start_date.
g. for Logical, select and to add a third row.
h. for Column, select Service_Half_Hour,DateTime.
i. for Operator, select <=.
j. for Value, right click, select Arguments, and paste :end_date.

<table>
<thead>
<tr>
<th>Column</th>
<th>Operator</th>
<th>Value</th>
<th>Logical</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc_service_startTime</td>
<td>=</td>
<td>ticket_service</td>
<td>End</td>
</tr>
<tr>
<td>doc_service_startTime</td>
<td>&gt;</td>
<td>start_date</td>
<td>End</td>
</tr>
<tr>
<td>doc_service_startTime</td>
<td>&lt;</td>
<td>end_date</td>
<td>End</td>
</tr>
</tbody>
</table>

Step 5 From the InfoMaker toolbar, click Return. This opens the Tabular Report Generator wizard.

Step 6 Click Next and then Finish to accept the defaults.

Step 7 At the Specify Retrieval Arguments dialog box, enter values that pertain to your database, or click Cancel to display the template with no data.

Step 8 From the InfoMaker toolbar, select File > Save.

Step 9 At the Save Report dialog box:
   • Save the file with the name custom_taskanalyshalfhour.
   • Make sure the appropriate Library is selected.
   • Click OK.

Step 10 Work in the Report Painter to modify the layout according to the Layout guidelines in Table A-2. Refer to the InfoMaker documentation for complete details on report layout.

Refer to Chapter 5 of this guide for some basic guidelines on template design.
Sample Historical Template
Template Libraries and Report Categories

This appendix describes how WebView stores report templates and provides a listing of WebView report categories. It contains these sections:

- About Template Libraries, page B-2
- About WebView Report Categories, page B-3
About Template Libraries

WebView report templates are stored in, and accessed from, PowerBuilder library files (PBLs) on your WebView server.

The path to the location where all templates are stored is:
```
icm\<icm_instance_name>\aw\custom.
```

The `custom` folder contains a subdirectory for each reporting category. For example, there is a subdirectory for the Agent by Agent, a subdirectory for Agent by Team, and so forth. Figure 2-1 on page 2-3 illustrates the directory structure.

Within each subdirectory folder, there is a library file named `PPB050.PBL`.

Working Library

It’s important that you select the appropriate working library in InfoMaker when you create a new template.

Working within the environment of the appropriate library ensures that the template:

- is associated with the correct report category
- displays under the correct menu in WebView
- has access to the correct retrieval values

See Select the Report Category Library, page 3-3 for the procedure to set the working library.

Both real-time and historical templates are stored in the same library file for a specific report category. For example, the templates for `call type` real-time and historical reports are all stored in the library file located in the `caltyp` subdirectory.

WebView only recognizes and displays templates from the standard libraries that ship with Unified ICM/CCE. In other words, you cannot create your own library files and display their templates in WebView.

However, you can create your own libraries to store templates under development, or templates that you want to remove from WebView but retain for possible future use. See the InfoMaker documentation for instructions on creating new libraries.
About WebView Report Categories

The following table lists all WebView report categories, and their associations:

- Column 1, **WebView Report Category**, lists the name of the report category.
- Column 2, **Library Subdirectory**, lists the subdirectory on the Admin Workstation server where the report category’s library file is stored.
- Column 3, **ID Argument**, lists the database column used with the ID argument (in a template’s SQL statement) for templates of this report category.
- Column 4, **WebView Menu**, lists the menu from which templates that use this report category are available in Webview.

**Table 0-1**  
**WebView Report Categories and Library Subdirectories**

<table>
<thead>
<tr>
<th>WebView Report Category</th>
<th>Library Subdirectory</th>
<th>ID Argument</th>
<th>WebView Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent by agent</td>
<td>peragt</td>
<td>Agent.SkillTargetID</td>
<td>Agent &gt; By Agent</td>
</tr>
<tr>
<td>All agents by team</td>
<td>agteam</td>
<td>Agent_Team.AgentTeamID</td>
<td>Agent &gt; By Team</td>
</tr>
<tr>
<td>All agents by peripheral</td>
<td>agtper</td>
<td>Peripheral.PeripheralID</td>
<td>Agent &gt; By Peripheral</td>
</tr>
<tr>
<td>All agents by skill group</td>
<td>agtskg</td>
<td>Skill_Group.SkillTargetID</td>
<td>Agent &gt; By Skill Group</td>
</tr>
<tr>
<td>Application gateways</td>
<td>apgate</td>
<td>Application_Gateway.</td>
<td>Application Gateway</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ApplicationGatewayID</td>
<td></td>
</tr>
<tr>
<td>Application path</td>
<td>appath</td>
<td>Application_Path.</td>
<td>Application Path</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ApplicationPathID</td>
<td></td>
</tr>
<tr>
<td>Outbound Option agent campaign</td>
<td>bacamp</td>
<td>Campaign.CampaignID</td>
<td>Outbound Option &gt; Campaign</td>
</tr>
<tr>
<td>Outbound Option agent dialer</td>
<td>badial</td>
<td>Dialer.DialerID</td>
<td>Outbound Option &gt; Dialer</td>
</tr>
<tr>
<td>Outbound Option agent dialer port</td>
<td>badprt</td>
<td>Dialer.DialerID</td>
<td>Outbound Option &gt; Dialer Port</td>
</tr>
<tr>
<td>Outbound Option agent import rule</td>
<td>baimp</td>
<td>Import_Rule.ImportRuleID</td>
<td>Outbound Option &gt; Import Rule</td>
</tr>
<tr>
<td>Call types</td>
<td>caltyp</td>
<td>Call_Type.CallTypeID</td>
<td>Call Type</td>
</tr>
<tr>
<td>Enterprise skill groups</td>
<td>entskg</td>
<td>Enterprise_Skill_Group.</td>
<td>Skill Group &gt; Enterprise</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EnterpriseSkillGroupID</td>
<td></td>
</tr>
<tr>
<td>Enterprise services</td>
<td>entsvc</td>
<td>Enterprise_Service.</td>
<td>Service &gt; Array</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EnterpriseServiceID</td>
<td></td>
</tr>
<tr>
<td>Network trunk groups</td>
<td>nettrk</td>
<td>Network_Trunk_Group.</td>
<td>Trunk Group &gt; Network</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NetworkTrunkGroupID</td>
<td></td>
</tr>
<tr>
<td>Peripherals</td>
<td>periph</td>
<td>Peripheral.PeripheralID</td>
<td>Peripheral</td>
</tr>
<tr>
<td>Peripheral skill groups</td>
<td>perskg</td>
<td>Skill_Group.SkillTargetID</td>
<td>Skill Group &gt; Base Only</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>AND Skill Group &gt; Peripheral</td>
</tr>
<tr>
<td>Peripheral services</td>
<td>persvc</td>
<td>Service.SkillTargetID</td>
<td>Service &gt; Peripheral</td>
</tr>
</tbody>
</table>
### About WebView Report Categories

<table>
<thead>
<tr>
<th>WebView Report Category</th>
<th>Library Subdirectory:</th>
<th>ID Argument</th>
<th>WebView Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Routes</td>
<td>routes</td>
<td>Route.RouteID</td>
<td>Route</td>
</tr>
<tr>
<td>Routing clients</td>
<td>rtecli</td>
<td>Routing_Client. RoutingClientID</td>
<td>Routing Client</td>
</tr>
<tr>
<td>Script queue</td>
<td>scriptq</td>
<td>Script.ScriptID</td>
<td>Script Queue</td>
</tr>
<tr>
<td>Trunk groups</td>
<td>trkgrp</td>
<td>Trunk_Group. TrunkGroupID</td>
<td>Trunk Group &gt; Peripheral</td>
</tr>
</tbody>
</table>

**Note**

Note that the Service Array category shows all of the templates from the enterprise service category, but the prompts for that category come from Service_Array.SkillTargetID.
Considerations and Tips for Working with Custom Reports

This appendix explains some issues you need to be aware of when working with custom reports. It includes these sections:

- Custom Template Name Changes, page C-2
- Database Error, page C-2
- Database Schema Changes that Affect Custom Reporting, page C-3
  - Reporting Data Differences With and Without IPCC System PG, page C-3
  - DBDateTime Field Improves Extracts, page C-3
  - Differences in Half Hour Counts and TCD/RCD Counts per Interval, page C-4
  - Network Queue and Local Queue Time in TCD, page C-4
  - RONA TCD and the Counting of Redirected Calls, page C-4
- Divide by Zero Errors, page C-5
- Errors Opening and Saving Templates, page C-6
  - <Template_name> is not in your current library list., page C-6
  - Select Data Source dialog box appears, page C-6
  - Saved Custom Templates Do Not Appear in WebView, page C-6
- The PATCHPBL Utility, page C-8
Custom Template Name Changes

If the name of a custom template changes, saved reports using that template are no longer accessible. The name of the template is one of the parameters saved in the report-definition record stored for a saved report.

The saved report record is NOT automatically updated to reflect a name change for a custom template. Changing the custom template name therefore invalidates the saved report definition, and WebView cannot create the report.

You need to create a new saved report that uses the new (changed) template name.

Database Error

You will see a Database Error message if you import SQL code into InfoMaker and that SQL code references a database that InfoMaker is not connected to.

For example if the SQL calls a table in a custom database, the SQL might run with no errors in SQL Query Analyzer. However, the same SQL would generate an error from InfoMaker.

If you need to access delivered Unified ICM/CCE database tables, you must add views of those tables to your custom database. For example, to view Agent information with your custom table(s), you would create a view of the Agent table as follows:

```
CREATE VIEW AgentCust AS
SELECT t.*
FROM devry_awdb.dbo.t_Agent t
```

Doing this allows you to access data in other tables, provided you add a view for each table in your custom database.
Database Schema Changes that Affect Custom Reporting

Each new release brings new Database Schema fields and changes to existing fields that affect reporting.

In Release 7.0(0), for example, there are new Abandon and Error fields, as well as new SkillGroup and Agent fields that might have an impact on custom reports.

Refer to the Release Notes for Cisco ICM/IPCC Enterprise & Hosted Editions Release 7.0(0) for a list of the Database Schema changes in Release 7.0(0).

Reporting Data Differences With and Without IPCC System PG

In Release 7.0(0), reporting data is identical for the following database tables for IPCC Enterprise with and without the IPCC System PG:

- Agent RT & HH
- Call Type RT & HH
- Route Call Detail
- Agent Logout
- Agent Skill Group Logout

However, reporting data can differ in the following database tables:

- Skill Group RT & HH
- Agent Skill Group RT & HH
- Peripheral RT & HH
- Termination Call Detail

These changes can impact custom reports as follows:

When calls are queued to a skill group, IPCC System PG updates the CallsQueued fields in the Skill_Group_Real_Time and Skill_Group_Half_Hour tables, whereas IPCC without System PG does not. Use the RouterCallsQueued field for IPCC templates, as it is updated consistently regardless of PG.

Non-IPCC System PG creates more TCDs than IPCC System PG (by a ration of 3 to 1) for call flows that involve IVR and agent.

For some call scenarios, IPCC System PG will increment the CallsOffered fields in the Skill_Group RT & HH tables whereas IPCC will not. CallsOffered is not in any standard reports.

For some RONA call scenarios, IPCCE will increment the CallsOffered fields in the Peripheral RT & HH tables whereas IPCC System PG will not.

DBDateTime Field Improves Extracts

Customers who have upgraded to ICM 7.0(0) from releases prior to 6.0 please note that ICM 6.0(0) added a new database field to many tables: DBDateTime.

This field is a Date/Time indicator that tells what time a record was written to the HDS.

It is included in all of the Half_Hour tables, as well as in many other tables.

This field enables you to determine whether or not you have already extracted a particular record.
For new records in the HDS, the DBDateTime field will be populated with the date and time that the record was written to the HDS. For migrated records, the DBDateTime field will be null.

**Tip**
Selecting the MAX(DBDateTime) is a useful way to monitor the last time a table was updated with records.

### Differences in Half Hour Counts and TCD/RCD Counts per Interval

If you develop custom reports based on the timestamp of completed calls from the TDC/RCD tables, which are grouped in half-hour intervals, you might notice discrepancies when you compare the results of these custom reports with the values in the standard Half_Hour tables.

The totals for the day match up exactly for the count of handled calls, but the half-hour intervals do not match up.

The reason is as follows:

The TCD datetime is written by the PG, which can delay sending the TCDs by a second or so. Also, any network issues can contribute to a time difference.

Handled Calls are determined by the Router when it receives a TCD.

Therefore, if the TCD from the PG states the time is 14:29:59, but the Router does not receive the TCD until 15:00:01, then the TCD would reflect one half hour interval, and the Router would reflect another.

### Network Queue and Local Queue Time in TCDs

Customer who have upgraded to ICM 7.0(0) from 5.0, please note that ICM 6.0(0) added a new database field: NetQTime.

In ICM 5.0, the time spent in the Router queue and the time spent in the local queue was stored in the same database field, LocalQTime.

ICM 6.0 added a new field called NetQTime to the Termination Call Detail Records. This field records the Time spent in the Network Queue (Router queue). This is different from the LocalQTime field that records the time spent in the local queue (at the ACD).

### RONA TCD and the Counting of Redirected Calls

Customer who have upgraded to ICM 7.0(0) from releases prior to 6.0, please note that the call disposition record for incrementing RONA data, the number of calls that Redirect On No answer from the agent's phone was changed in ICM 6.0:

- In ICM 5.0, a call disposition of 15 increments the RONA data. A call disposition of 19 is unused and increments errors.
- In ICM 6.0, a call disposition of 19 increments the RONA data. A call disposition of 15 is the call disposition of redirected calls (as opposed to “abandon ring no answer” calls and is used when an agent or device (voice mail) does not take the call.

This change allows for the counting of redirected calls in customized reports.
Divide by Zero Errors

Note

This procedure is helpful when running and debugging in InfoMaker.

WebResponse automatically executes this statement when a template is run.

If you see a Divide by Zero warning in InfoMaker when you run a report, follow this procedure to temporarily disable the warning:

• Open the SQL statement (click the SQL button or select Design > Data Source).
• At the top of the code, type this line: SET ANSI_WARNINGS OFF.
• Close the SQL window.
• Re-run the report.
Errors Opening and Saving Templates

This section documents some errors you might see opening and saving templates.

<Template_name> is not in your current library list.

If you see this message, the template you are trying to open is not in your current working library.

**Step 1** Click OK to close the message.

**Step 2** Select File > Select Library to open the Select Library dialog box.

**Step 3** Navigate to the folder for the template library you want to use.

**Step 4** Highlight the ppb050.pbl file in that folder, and click OK.

Select Data Source dialog box appears

If the Data Source dialog box opens when you select a template, you do not have an active connection to the Admin Workstation database.

**Step 1** Click the Machine Data Source tab.

**Step 2** Locate and highlight the Data Source Name for your AW connection.

**Step 3** Click OK.

**Step 4** Supply your Login ID and Password if prompted to do so.

Saved Custom Templates Do Not Appear in WebView

There are several reasons this may occur.

Have you Refreshed the List of Templates in WebView?

You may have added and saved the template correctly, but the WebView cache may not have been refreshed to display it.

**Step 1** Open the report category for the new template.

**Step 2** Scroll to the bottom of the page.

**Step 3** Click Refresh the list of templates.

This ability to refresh the cache without restarting IIS is new functionality in WebView 7.0(0).
Appendix C Considerations and Tips for Working with Custom Reports

Errors Opening and Saving Templates

Does the Template Name have Multiple Underscores?

When a custom template name has more than two underscores, the name that displays on the WebView report page is truncated to the second underscore.

That is, if you save three templates as:

olds_custom_templatename1
olds_custom_templatename2
olds_custom_templatename3

Then all three appear in WebView as:

olds_custom
olds_custom
olds_custom

To avoid this, append the prefix (ipcc_, olds_, or both_) and type the template name without using underscores. (You can use hyphens.) Then add _custom at the end. For example,

olds-templatename1_custom
olds-templatename2_custom
olds-templatename3_custom

Note Use this naming convention when creating new templates.

Do not change the names of existing templates, as doing so would affect Job Scheduler, Favorites, and Saved Reports.

Templates That are Moved or Deleted

No templates were deleted, replaced, or moved in Release 7.0(0).

However, in WebView 5.0, new templates were added and several existing templates were deleted. The deleted templates were either replaced by templates in the same reporting category, replaced by templates in different reporting categories, or not replaced at all.

• If a deleted template was replaced by a new template in the same reporting category, saved reports use the replacement template and work correctly. This is the case, for example, with agteam01, which was replaced by agteam20 in Release 5.0.

• If a deleted template was replaced by a new template in a different reporting category, saved reports using the deleted template are not migrated and will not open. You need to create a new report using the replacement template.

• If a deleted template was not replaced, saved reports using that template are not moved to the WebView database and cannot be accessed through WebView.
The PATCHPBL Utility

The PATCHPBL utility regenerates the PPB050.PBL files. If a PPB050.PBL file does not exist, the utility creates that file.

The PATCHPBL utility goes through each report-category directory, reads each category’s srldist.txt file, and copies all the listed SRD files into the PPB050.PBL file.

The utility does NOT delete any template in the PPB050.PBL file that is not in the srldist.txt file. Therefore, custom templates remain unaltered in the regenerated PPB050.PBL file.

If you mistakenly open a Cisco template, modify it, and do not save it with a new (custom) name, running PATCHPBL restores the original Cisco template.

How to Run PATCHPBL

The PATCHPBL utility is located in the ICM\bin directory and is put there when WebView is installed.

To run the PATCHPBL utility, from the command-prompt window, use the following command format:

PATCHPBL -root <drive>:\ICM\<instance_name>\aw

For example: PATCHPBL -root C:\ICM\Cisco\aw
INDEX

A

adding
  columns 3-7, A-11
  Retrieval Arguments 3-8, A-5, A-12
  summary rows 5-19
  tables 3-7, A-4, A-11
  templates 2-4
  titles A-5
  Where clause 3-9, A-5
aligning columns 5-2, 5-16, 5-17

copying templates 6-9
creating templates A-4
  based on Cisco templates 4-1
  from scratch 3-1
  samples A-1
custom folder 1-4, 1-11, 2-2
custom templates 2-2
  changing names C-2
  creating 3-4
  launching 6-7, 6-8
  See also templates

B

background colors 5-2
Bill of Materials (BOM) 1-1

columns
  adding 3-7, 5-21, A-11
  aligning 5-2, 5-16, 5-17
  computed 2-5, 3-10
  deleting 5-21
  modifying 5-16
  resizing 5-18
  complex templates 2-4
  computed columns 2-5, 3-10, 5-3
data source 3-4, A-4, A-11
data summaries 5-19
DBDataTime field C-3
DB Prof 1-10, 3-1, 4-2
deleting

C

CEM 2-i
check Web DataWindow 5-2
Cisco templates 1-1, 2-2
  and custom templates C-2
  changing 2-2
  See also templates
columns
  adding 3-7, 5-21, A-11
  aligning 5-2, 5-16, 5-17
  computed 2-5, 3-10
  deleting 5-21
  modifying 5-16
  resizing 5-18
custom folder 1-4, 1-11, 2-2
custom templates 2-2
database
  connection error C-6
  connection from InfoMaker 1-8, 4-2
  ODBC connection 1-5
  See also reporting database, DAW
Database button 1-10
database error C-2
Database Painter 1-10
Database Profile 1-8
database schema
  changes in this Release C-3
  DBDataTime field C-3
  LocalQTime field C-4
  NetQTime field C-4

database error C-2
Database Painter 1-10
database schema
  changes in this Release C-3
  DBDataTime field C-3
  LocalQTime field C-4
  NetQTime field C-4

data source 3-4, A-4, A-11
data summaries 5-19
DBDataTime field C-3
DB Prof 1-10, 3-1, 4-2
deleting
columns 5-21
templates 6-5
Design Convert to Graphics 6-3
Design HTML Preview 6-4
Design pane 5-9
distributing templates 6-9
divide by zero error C-4, C-5
drilldown 5-20

E
editing
   SQL 4-5, 6-2
templates 6-2
end_date argument 3-8
errors
database C-2
database connection C-6
divide by zero C-4
saving and opening templates C-6

F
fonts 5-2
formats 5-3

G
graphical templates
   adding titles A-5
designing 5-5, A-2
   Report Painter 5-6
   selecting graph type 5-5, A-5
graph type 3-4

H
HDS 1-5
headers 5-2, 5-3
formats 5-12

I
InfoMaker
   acquiring 1-1
   and WebView templates 1-11
   Database Profile 1-8
   earlier versions 1-2
   installation 1-3
   interface 2-i, 1-9, 5-8
   Painter windows 1-12
   purpose 1-1
   supported version 1-1
   Sybase documentation 2-i
toolbars and menus 1-9, 1-10
   upgrading 1-2
   IPCC System PG C-3

J
joins 2-4

L
Lib List button 1-10
Library 3-3
   button 1-10
   opening templates from 1-11
   set working 4-3, A-11
   template error C-6
Library Painter 1-10, 1-12
LocalQTime C-4
LocalQTime field C-4
location of templates 6-8, B-3

N
naming templates 4-3, 6-6, C-2, C-7
NetQTime  C-4
NetQTime field  C-4

O
ODBC database connection 1-5
opening templates 4-3

P
PATCHPBL 6-2, C-8
percentages 5-3, 5-16
PPB050.PBL files 1-4, 1-11, 3-3
presentation style 2-5, 3-4
previewing templates 1-10, 5-10, 6-4
properties tabs 5-8, 5-16

Q
queue time  C-4

R
real-time templates 2-5, A-4
refreshing template cache 6-7, C-6
report categories 3-3, 4-3, B-3
reporting database 1-5
Report Painter 1-14, 3-13, 5-8
graphical templates 5-6
Preview window 6-4
tabular templates 5-9
resizing columns 5-18
Retrieval Arguments 2-5, A-5, A-12
adding 3-8
historical and real-time templates 3-8
Retrieve for preview 6-4
RONA TCD  C-4

S
saved reports  C-2
saving
errors  C-6
templates 3-13, 4-3, 6-6, A-7, A-13
Select Painter 1-13, 3-13, 4-5, 6-3, A-11
Sel Lib button 1-10
Sequel Painter 3-5
set as working library 2-2, 3-3, 4-3, A-11
sharing template library files 1-4, 2-3
sort order 3-7
SQL
complex queries 6-3
creating statement 3-5
divide by zero errors  C-5
editing 4-5, 6-2
graphic and text formats 3-5, 6-3
SQL Data 4-5
SQL Select 3-4, A-4, A-11
start_date argument 3-8

tables
adding 3-7, A-4, A-11
removing 3-7
tabular templates
designing 5-6
Report Painter 5-9
TCD and RCD counts  C-4
template design
adding columns 5-21
adding summary row 5-19
data summary 5-19
deleting columns 5-21
Index

detail band 5-9
drilldown 5-20
editing 6-3
footers 5-9
graphical templates 5-5
header band 5-9
modifying columns 5-16
presentation style 2-5
summary band 5-9, 5-19
tabular templates 5-6
titles 5-5, 5-13
template errors C-6
template guidelines 5-2
template libraries 2-2
template library 1-11
shared access to 1-4, 2-3
templates 2-2
changing names C-2
complex 2-4
copying 6-9
creating 2-4, A-4
deleting 6-5
directory organization B-3
distributing 6-9
editing 6-2
from and to dates 5-2
hiding from WebView 6-8
launching 6-7
layout tips 5-2
location 1-3, 2-2, 6-8, B-3
naming 4-3, 6-6, C-2
opening 4-3
organization 2-2
presentation style 3-4
previewing 5-8, 6-4
saving 3-13, 4-3, 6-6, A-7, A-13
shared folders 1-3
sharing 1-4
testing 6-4, 6-8
titles A-5
web-ready 5-2, 5-4
WebView menu organization B-3
testing templates 6-4, 6-8
Text button, InfoMaker 5-19
titles 5-13

U

upgrading 1-2
InfoMaker 1-2
templates 1-2, C-7

V

Visible property 5-4

W

Web DataWindow 5-4
WebView 1-1
for CEM 2-1
hiding templates 6-8
launching templates 6-8
opening templates 1-11
refreshing template cache 6-7, C-6
report menus B-3
WebView server 6-9
Where clause 3-9, A-5, A-12
working library 2-2