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Purpose
This guide describes how to administer components of the Cisco Unified Contact Center Enterprise/Cisco
Unified Contact Center Hosted (Unified CCE/Unified CCH) solution. It includes information about
administering Unified CCE for voice and multichannel contact centers.

Audience
This document is intended for contact center supervisors and administrators.

Organization
The following table describes the information contained in each section of this guide:
Section

Description

Part I: Agent management and call
routing

Provides conceptual information about Unified CCE agents, agent
features, and call routing.
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Related documentation

Section

Description

Part II: Overview

Describes how to perform administrative tasks using Unified CCE
with Cisco Unified Intelligent Contact Management (Unified
ICM) software (documented as “system software” in this guide).

Related documentation
Documentation for Unified ICM/Unified CCE/Unified CCH, as well as related documentation, is accessible
from Cisco.com at: http://www.cisco.com/cisco/web/psa/default.html.
• Related documentation includes the documentation sets for Cisco CTI Object Server (CTI OS), Cisco
Agent Desktop, Cisco Agent Desktop—Browser Edition, Cisco Unified Contact Center Management
Portal, Cisco Unified Customer Voice Portal (Unified CVP), Cisco Unified IP IVR, Cisco Unified
Intelligence Center, and Cisco Support Tools.
• For documentation for these Cisco Unified Contact Center products, go to http://www.cisco.com/cisco/
web/psa/default.html, click Voice and Unified Communications, then click Customer Collaboration,
then click Cisco Unified Contact Center Products or Cisco Unified Voice Self-Service Products,
then click the product/option you are interested in.
• For troubleshooting tips for these Cisco Unified Contact Center products, go to http://docwiki.cisco.com/
wiki/Category:Troubleshooting, then click the product/option you are interested in.
• You can access documentation for Cisco Unified Communications Manager from: http://www.cisco.com/
cisco/web/psa/default.html.
• You can access technical support documentation and tools from: http://www.cisco.com/en/US/support/
index.html.
• You can access the Product Alert tool from (login required): http://www.cisco.com/cgi-bin/Support/
FieldNoticeTool/field-notice.
• For more information about the Cisco software support methodology, see Software Release and Support
Methodology: ICM/IPCC available at (login required): http://www.cisco.com/en/US/partner/products/
sw/custcosw/ps1844/prod_bulletins_list.html.
• For more information about language localizations, see the Cisco Unified ICM/Contact Center Product
and System Localization Matrix available at the bottom of the following page: http://www.cisco.com/
en/US/products/sw/custcosw/ps1001/prod_technical_reference_list.html.

Product naming conventions
In this release, the product names defined in the following table have changed. The New Name (long version)
is reserved for the first instance of that product name and in all headings. The New Name (short version) is
used for subsequent instances of the product name.
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Note

This document uses the naming conventions provided in each GUI, which means that in some cases the
old product name is in use.
Old Product Name

New Name (long version)

New Name (short version)

Cisco IPCC Enterprise
Edition

Cisco Unified Contact
Center Enterprise

Unified CCE

Cisco IPCC Hosted Edition Cisco Unified Contact
Center Hosted

Unified CCH

Cisco Intelligent Contact
Management (ICM)
Enterprise Edition

Unified ICME

Cisco Unified Intelligent
Contact Management
Enterprise

Cisco Intelligent Contact
Cisco Unified Intelligent
Unified ICMH
Management (ICM) Hosted Contact Management Hosted
Edition
Cisco CallManager/Cisco
Unified CallManager

Cisco Unified
Communications Manager

Unified CM

Conventions
This manual uses the following conventions:
Convention

Description

boldface font

Boldface font is used to indicate commands, such as user entries, keys,
buttons, and folder and submenu names. For example:
• Choose Edit > Find.
• Click Finish.

italic font

Italic font is used to indicate the following:
• To introduce a new term; for example: A skill group is a collection
of agents who share similar skills.
• For emphasis; for example: Do not use the numerical naming
convention.
• A syntax value that the user must replace; for example: IF
(condition, true-value, false-value)
• A book title; for example: Refer to the Cisco CRS Installation
Guide.
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Documentation and service requests

Convention

Description

window font

Window font, such as Courier, is used for the following:
• Text as it appears in code or that the window displays; for example:
<html><title>Cisco Systems, Inc.</title></html>

• Navigational text when selecting menu options; for example: ICM
Configuration Manager > Tools > Explorer Tools > Agent
Explorer

< >

Angle brackets are used to indicate the following:
• For arguments where the context does not allow italic, such as
ASCII output.
• A character string that the user enters but that does not appear on
the window such as a password.

Documentation and service requests
For more information about obtaining documentation, submitting a service request, and gathering additional
information, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised
Cisco technical documentation, at:
http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html
Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free
service and Cisco currently supports RSS Version 2.0.

Documentation feedback
You can provide comments about this document by sending email to the following address:
mailto:ccbu_docfeedback@cisco.com
We appreciate your comments.
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PART

I

Agent management and call routing
• Cisco Unified Contact Center Enterprise agents, page 3
• CTI OS and Cisco Agent Desktop Feature Configuration, page 9
• Routing tasks for multichannel options, page 23

CHAPTER

1

Cisco Unified Contact Center Enterprise agents
This chapter explains the concepts you must be familiar with when setting up agents for your Unified CCE
contact center.
• Agent administration, page 3
• Single-line versus multi-line behavior, page 6

Agent administration
This section provides information about the Unified CCE agent, including associating the agent with database
records and agent desk settings.

Agents
An agent is an individual who handles customer contact within your contact center. In a Unified CCE
configuration, you can create two types of agents:
Agent type

Description

Voice-only agents

Agents can receive telephone calls. You can also configure voice-only
agents to receive non-voice requests such as chat, blended
collaboration, and email.

Multichannel agents

Agents can receive voice calls and requests from other media. You
can also configure multichannel agents to only receive non-voice
requests such as chat, blended collaboration, and email.
Note

You must have Cisco multichannel software installed as part
of your Unified CCE configuration to create multichannel
agents.
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Note

In most cases, the Cisco Unified Communications Manager (Unified CM) peripheral on the Generic IPCC
peripheral gateway (PG), which is set up with your initial Unified CCE installation, tracks and records
the state and activity of all voice and non-voice agents. You can configure a non-voice PG rather than a
Unified CM PG to monitor state and activity of agents configured as non-voice agents. However, this is
optional, and is not necessary if you have a Unified CM peripheral on the Generic IPCC PG.

Database records for voice-only agents
In the Unified ICM database, you must associate each agent with two database records.
Unified ICM database record

Description

Person record

Identifies the individual. Person records must exist for all Unified CCE
agents. Every agent in your configuration must have a single Person
record. You can then associate this record with one or multiple Agent
records, as described below.

Agent record

Identifies the agent working on a particular peripheral. There must be
a one-to-one correspondence between each Agent record and its
associated peripheral. However, in Unified CCE, if an agent is going
to be working on several peripherals, you can create several Agent
records and associate these with the same Person record. In this way,
a single agent can work on several different peripherals.

When you create an Agent record, you have the option of associating it with an existing Person record (select
Select Person). If you do not associate the Agent record with an existing Person record, a new Person record
is automatically created when you create the agent.

Database records for multichannel agents
Unified CCE agents who use multichannel software are associated with three different database records:
• The Person record in the ICM Unified CCE database
• The Agent record in the ICM Unified CCE database
• The Agent record in the database for the multichannel application

Agent desk settings configuration
You must associate each Agent record with an agent desk setting. You use the agent desk settings configuration
to associate a set of permissions or characteristics with specific agents. These settings are comparable to Class
of Service settings on a PBX or ACD. Desk settings are associated with an agent when the agent is configured
in the Unified ICM database. The desk settings are global in scope and you can apply them to any configured
agent on any peripheral within a ICM Unified CCE configuration.
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Agent administration

If desktop settings are not associated with a configured agent, the agent is assigned the peripheral default
settings. The peripheral default settings depend on the default setting for the Generic IPCC PG the agent is
logged in to.
Agent feature configuration with agent desk settings list tool, on page 9

Agent teams and supervisors
You can organize Unified CCE voice agents into teams. A team is a collection of agents grouped for reporting
purposes.

Note

A single agent can belong to only one team.
Unified ICM/CCE software allows you to group individual agents into agent teams that supervisors can
manage. Agent teams are assigned to a specific peripheral, so you must assign all agents of a given team to
the same Unified CM peripheral.
Unified ICM/CCE software lets you assign both Primary and Secondary supervisors to an individual team.
Cisco recommends that you set up your teams with both a Primary and a Secondary supervisor. This setup
helps to accommodate Supervisor and Emergency assist scenarios.
Supervisors listed on the agents team list are able to view real-time statistics (using your reporting application).
Supervisors can, for example, barge-in, intercept, silently monitor, and log out agents in the associated team
using the CTI Toolkit IPCC Supervisor Desktop application.

Note

If you use Cisco Agent Desktop, you must configure the supervisor in Unified ICM/Unified CCE software
first, then configure the supervisory features within Cisco Agent Desktop.
For reporting purposes, you can report on agent teams and agents grouped into teams. Also, supervisors can
run reports on their teams. (For more information about reposting, see Reporting Guide for Cisco Unified
ICM/Contact Center Enterprise & Hosted.)
Each team you set up must have an agent supervisor associated with it. You can then configure supervisory
agent features, to allow the supervisor to better monitor agent activity and assist agents on their team. When
you create an agent supervisor, you must enter the following information for the supervisor:
• Windows Domain name to which the agent team belongs
• Windows User ID for the supervisor
• Windows password for the supervisor
When configuring agent teams, be aware of the following rules:
• An agent can be a member of only one agent team.
• An agent team can have only one Primary Supervisor.
• A supervisor can be a supervisor of any number of agent teams.
• A supervisor for an agent team can also be a member of that agent team.
• All agents belonging to an agent team and all supervisors for that agent team must be on the same
peripheral.
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• A supervisor cannot be using the Windows administrator account when logging in as supervisor.

Agent teams and multichannel applications
You can group voice agents into teams using the Unified ICM/Unified CCE/Unified CCH Administration
User Interface. However, that there is no team feature in Cisco Unified E-Mail Interaction Manager (Unified
EIM) and Cisco Unified Web Interaction Manager (Unified WIM); therefore, you cannot group Unified
EIM-only agents and Unified WIM-only agents into teams.
For more information about supervisory features, see CTI OS System Manager's Guide for Cisco Unified
ICM/Contact Center Enterprise & Hosted and CTI OS Supervisor Desktop User Guide for Cisco Unified
Contact Center Enterprise & Hosted.
CTI OS and Cisco Agent Desktop Feature Configuration, on page 9
Supervisor feature configuration, on page 14

Single-line versus multi-line behavior
The following table details single-line behavior versus multi-line behavior.
Action

Single-line behavior

Multi-line behavior

Accept a routed call while call is
on second line?

Yes

Yes, when Non ACD Line Impact
is set no impact for the deployment.

Supervisor monitor second line
Yes, but supervisor cannot know
using Supervisor Desktop Monitor agent had calls by looking at
(CTI OS or Cisco Agent Desktop)? desktop

Yes, and supervisor can see second
line calls on desktop by default.

Supervisor Monitor using Unified No
CM-based silent monitor

Yes, depending on the CTI OS
Server privacy configuration.

Call park

Supported on unmonitored second Not supported because all lines are
line
monitored.

Join Across Lines (JAL)/Direct
Transfer across Lines (DTAL)

Not supported

Shared line

Supported on unmonitored line; no Not supported when Agent Phone
configuration limitations
Line Control is enabled for the
deployment.

Call Waiting / Busy trigger > 1

No longer supported
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Yes, depending on the CTI OS
Server privacy configuration.

Supported

No longer supported. Hard-coded
to 1 on 69xx series phones (must
be configured before enabling
multi-line).

Single-line versus multi-line behavior

Action

Single-line behavior

Multi-line behavior

Reporting on second line calls

Use CDRs in Unified CM

Termination Call Detail Records
for call to or from an agent's Non
ACD line with an unmonitored
device or another agent's Non ACD
line is reported with a Non ACD
Peripheral Call Type. Reporting for
all calls on the Non ACD line is
captured in the Agent Interval table
for that agent.

Number of configured lines on
phone

No limit described (only
monitoring one line)

Maximum of four lines. Agent
login will be rejected. Config Alert
generated.

For more information about enabling the Cisco Round Table phones, see Installation and Configuration Guide
for Cisco Unified Contact Center Enterprise & Hosted. For more information about configuring the Cisco
Round Table phones, see Installation Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted and
the Cisco Unified Communications Manager documentation.
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CHAPTER

2

CTI OS and Cisco Agent Desktop Feature
Configuration
• Agent feature configuration with agent desk settings list tool, page 9
• Supervisor feature configuration, page 14
• Agent Re-skilling Tool, page 15
• Skill groups per agent limit modification, page 16
• Network transfer for IVRs, page 18
• Unified CCE routing, page 18

Agent feature configuration with agent desk settings list tool
You must associate each voice Agent record with an agent desk setting (not necessary for non-voice agents).
You can use the agent desk settings list tool configuration to associate a set of permissions or characteristics
with specific agents. You can use the agent desk settings list tool to configure the following agent features:
• Agent Wrap-up
• Reason Codes
• Redirection on No Answer
• Emergency and Supervisor Assist Calls

Agent Wrap-up
Agents can enter Wrap-up mode after completing a call. Wrap-up mode enables the agent to finish with any
tasks that require after-call work before entering a Ready state. When in Wrap-up mode, the agent is not routed
any additional tasks.
Agents can manually enter Wrap-up state by activating the wrap-up button on their soft phone. You can also
configure agent desk settings so that agents automatically enter Wrap-up mode after finishing each call.
When you create agent desk settings using the Unified ICM/Unified CCE/Unified CCH Administration User
Interface, you can specify whether agents enter Wrap-up mode automatically after finishing incoming calls.
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The Work Mode Settings allow you to specify whether the agent must enter Wrap-up mode after incoming
calls. You can also use these settings to require agents to enter reason codes while in Wrap-up mode (incoming
calls only).

Reason Codes
Agents select Reason Codes when they:
• Log out of the agent desktop system
• Enter Wrap-up mode after a call
• Change to a Not Ready state
Reason Codes allow you to track the agent's state and logout status as it changes. You configure Reason Codes
using the agent desktop application (CTI OS and/or the Cisco Agent Ddesktop administrator's desktop). If
you use the CTI OS desktop, you can also configure Unified ICM/Unified CCE software to control when
Reason Codes are required.

Agent desk settings that affect Reason Codes
Agent desk setting option

Affects this type of reason code

Work mode on Incoming

Wrap-up

Idle reason required

Not Ready

Logout reason required

Logout

Wrap-Up Reason Codes and Work Mode
If you use the CTI Toolkit Agent Desktop, you can use the Work Mode on Incoming option on the agent desk
settings list window to specify when and if agents are required to enter Reason Codes when entering Wrap-up
for incoming calls. The following table describes Work Mode on Incoming options and explains how Reason
Codes are related to each.
Work Mode

Description

Required

Ensures that the agent
The agent can choose to enter a
automatically enters Wrap-up state Reason Code.
after completing the call.

Optional

Allows agents to choose whether
to activate the wrap-up button or
the Not Ready button to end the
call.

If the agent uses the wrap-up
button, the agent can choose to
enter a Reason Code.

Not Allowed

Restricts the agent from entering
Wrap-up mode. The agent can go
into Not Ready mode.

The agent can decide whether to
enter a Not Ready Reason Code.
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Reason Code

Agent feature configuration with agent desk settings list tool

Work Mode

Description

Required with wrap-up data

Ensures that the agent
The agent must enter a Reason
automatically enters Wrap-up state Code.
after completing the call.
Note

Reason Code

This mode is not
supported for outgoing
calls.

The following table describes the Cisco Agent Desktop configuration for Work Mode on Incoming options.
Work Mode

Description

Required

Not used with Cisco Agent Desktop.

Optional

Recommended setting when using Cisco Agent Desktop.

Not Allowed

Configure Wrap-up options in Cisco Desktop
Administrator.
Not used with Cisco Agent Desktop.

Required with Wrap-up data

Not used with Cisco Agent Desktop.

Note

The following table describes the Cisco Agent Desktop configuration for Work Mode on Outgoing options.
Work Mode

Description

Required

When the agent drops an outbound call, the agent goes into a Work
Not Ready state for the time specified in the Wrap-up time in the agent
desk settings and pops the Wrap-up options, if they are enabled in the
Cisco Agent Desktop Administrator application.

Optional

Recommended setting if not using Wrap-up options for outbound calls.

Not Allowed

Not used with Cisco Agent Desktop.

Required with wrap-up data

Not used with Cisco Agent Desktop.

Predefined Reason Codes
Unified CCE uses several predefined reason codes to indicate certain system events, described in the following
table.
Reason Code

Description

32767

Agent state changed because the agent did not answer the call.
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Reason Code

Description

50001

The CTI OS client disconnected, logging the agent out.

50002

This reason code is converted to a 50002, so 50001 does not display in
the agent log out records.
A CTI OS component disconnected, causing the agent to be logged out or set to
the Not Ready state. This could be due to closing the agent desktop application,
heart beat time out, or a CTI OS Server failure.

50003

Agent was logged out because the Unified CM reported the device out of service.

50004

Agent was logged out due to agent inactivity as configured in agent desk settings.

50005

For a Unified CCE agent deployment, where the Agent Phone Line Control is
enabled in the peripheral and the Non ACD Line Impact is configured to impact
agent state, the agent is set to Not Ready while talking on a call on the Non ACD
line with this reason code.

50010

Agent was set to Not Ready state because the agent was routed two consecutive
calls that did not arrive.

50020

Agent was logged out when the agent's skill group dynamically changed on the
Administration & Data Server.

50030

If an agent is logged in to a dynamic device target that is using the same dialed
number (DN) as the PG static device target, the agent is logged out.

50040

Mobile agent was logged out because the call failed.

50041

Mobile agent state changed to Not Ready because the call fails when the mobile
agent's phone line rings busy.

50042

Mobile agent was logged out because the phone line disconnected while using
nailed connection mode.

-1

Agent reinitialized (used if peripheral restarts).

-2

PG reset the agent, normally due to a PG failure.

-3

An administrator modified the agent's extension while the agent was logged in.

Note

These reason codes appear in these reports:
• Agent log out reports if the event caused the agent to log out.
• Agent real time reports if the agent was set to a Not Ready state.
• Agent Not Ready reports.
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Important

For reporting on all PGs other than VRU PGS, be sure to select the Agent event detail check box on the
Agent Distribution tab in the Unified ICM/Unified CCE/Unified CCH Administration User Interface's
PG Explorer tool. You must select this check box to report on Not Ready Reason Codes.

If you are using Cisco Agent Desktop, the Desktop Administrator uses the following predefined reason codes.
Reason Code

Description

20001

Places the agent in the Not Ready state first before forcefully logging
them off.

20002

Forces the logout request; for example, when Agent A attempts to log
in to Cisco Agent Desktop and Agent B is already logged in under that
agent ID, Agent A is asked whether or not to force the login. If Agent
A answers yes, Agent B is logged out and Agent A is logged in. Reports
then show that Agent B logged out at a certain time with a reason code
of 20002 (Agent B was forcibly logged out).
Cisco Unified Mobile Agent is the only exception, where CAD
will not allow you to log out a login name/ID that is already
in use.
If not already in the Logout state, request is made to place agent in the
Not Ready state. Then logout request is made to log agent out.
Note

20003

Supervisor Not Ready

This code is reserved.

Supervisor Logout

This code is reserved.

Redirection on No Answer
You can configure your Unified CCE system to handle and accurately report on situations when the agent
does not answer their phone. These situations are referred to as Redirection on No Answer.
Although you can specify some values that control Redirection on No Answer situations, configuring
Redirection on No Answer involves additional steps:
• Unified ICM/Unified CCE configuration
• Unified ICM/Unified CCE scripting
• Unified CM configuration
Redirection on No Answer conditions are handled by two routing scripts: the initial routing script and a script
specifically set up for these conditions. The initial routing script handles the incoming call; when the call is
redirected on no answer from the agent's IP phone, the script branches to another script set up specifically for
Ring No Answer conditions.
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Note

The Target Requery script feature, implemented using the Label, Queue, Route Select, and Select nodes,
is not supported for Unified CCE systems; however, it is supported for Cisco Unified Customer Voice
Portal (Unified CVP).
Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted

Emergency and supervisor assist calls
Agents can activate Supervisor Assist or Emergency Assist buttons on their desktop when they need special
assistance from the primary or secondary supervisor assigned to their team.
Agents can use the Supervisor and Emergency assist features, regardless of whether or not they are on a call.
There are two types of Supervisor and Emergency Assist calls:
• Existing call—Consultative Conference
• No call

Note

Blind Conference is not supported for Emergency and Supervisor Assist.

Supervisor feature configuration
Note

If you use Cisco Agent Desktop, you must configure the supervisor in Unified ICM/Unified CCE software
first, then configure the supervisory features using Cisco Desktop Administrator.
The CTI Toolkit IPCC Supervisor Desktop includes functions that allow supervisors to monitor and manage
their agent team members. A supervisor desktop application has all of the capabilities of an agent desktop
application plus supervisor services to monitor and manage agent team members. The desktop application
supports the Barge-In and Intercept call monitoring features.

Note

For more information on setting up Unified CCE supervisory features, see Reporting Guide for Cisco
Unified ICM/Contact Center Enterprise & Hosted. These instructions help ensure successful use of these
features and accurate reporting.
Administering agents, on page 27

Barge-In
When using the CTI OS Desktop to barge in on an agent's call, a supervisor needs to select an agent from the
Team State Information grid and select a call from the Monitored Calls section. The supervisor can select a
call in this window and then select the Barge-In button. The supervisor then becomes party to the call. The
supervisor must be in the Not Ready state to use the barge-in function.
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When using Cisco Supervisor Desktop, an agent supervisor can use the barge-in function while in the Ready
or Not Ready state.
Cisco Supervisor Desktop does not allow barge-in when the agent is:
• On hold
• On two calls
• On a conference call
• Already on another call
• Running Cisco Agent Desktop—Browser Edition

Intercept
When using the CTI OS Desktop, you can only use the Intercept button after Barge-in. The supervisor can
use the Intercept button to remove the agent from the call, leaving only the supervisor and the customer on
the call.

Note

The Intercept button mentioned above refers to the button located on the CTI OS Desktop (soft phone),
not the button on the hard phone.
When using Cisco Supervisor Desktop, an agent supervisor can intercept an agent's call without using Barge-In.
Cisco Supervisor Desktop does not allow intercept when the agent is:
• On hold
• On two calls
• The Cisco Supervisor Desktop self is on another call
• An IP Phone agent

Agent Re-skilling Tool
The Unified CCE Agent Re-skilling Tool is an optional, browser-based application designed for use by Unified
CCE call center supervisors. It lets you change the skill group designations of agents on your team, and quickly
view skill group members and details on individual agents. Changes made to an agent's skill group membership
take place immediately without the need for the agent to exit and re-enter the system.

Note

• If an agent is currently in a call, a change to the agent's skill group membership takes place after the
call has terminated.
• The Agent Re-skilling Tool is an optional tool that you must install to take advantage of these features.
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Skill groups per agent limit modification
Unified ICM and Unified CCE impose a default limit on the number of skill groups that you can assign to a
single agent (sub-skill groups are included in this total for those Unified ICME/H peripherals that continue
to support sub-skills in the current release). After this limit is reached, you cannot reassign additional skill
groups. The default limit is specified in Cisco Unified Contact Center Enterprise Solution Reference Network
Design (SRND).
You can also use the Configuration Limit tool to specify your own limit on the number of skill groups that
you can assign to an agent. For optimum performance, you can specify a limit far lower than the system
default. For more information about performance considerations in choosing a skill groups per agent limit,
see Cisco Unified Contact Center Enterprise Solution Reference Network Design (SRND).

Warning

Setting a default value for skill groups per agent that is higher than the system default can adversely affect
system performance. Cisco does not support configurations that exceed the default value.

Caution

The Configuration Limit tool is a command-line tool utility from the bin directory of all Unified ICM and
Unified CCE Administration & Data Servers. Access is limited to users with privileges for the Setup or
Config Groups in Active Directory for the chosen customer instance. For more information about the
Configuration Limit tool, see Outbound Option Guide for Cisco Unified Contact Center Enterprise &
Hosted.

Change skill groups per agent limit
To change the skill groups per agent limit using the Configuration Limit tool, complete the following steps:

Procedure
Step 1

Step 2

From the Windows menu, select Start > Run, type configlimit , and then click Enter.
Note
Run the Configuration Limit tool on the same machine as the Distributor for the instance you want
to configure. If more than one instance of the Administration & Data Server is installed on the
Distributor machine, use the Select Administration Server tool to select the instance you want to
configure.
To view currently configured parameter limits, run the following command:
cl /show

Step 3

To change the skill groups per agent limit, enter a command in the following format:
cl /id 1 /value [ConfigLimitCurrentValue] [/update]

Where:
• id 1 = the ID of the skill groups per agent limit.
• ConfigLimitCurrentValue = the parameter limit. In this case, the parameter limit is the skill groups per
agent limit.
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For example, to change the skill groups per agent limit to 5, enter the following:
cl /id 1 value/5 /update

Note

Using the Configuration Limit tool, you can change the ConfigLimitCurrentValue only. You cannot
change the ConfigLimitDefaultValue.

Additional requirements
Lowering the limit
If you have modified the skill groups per agent limit to be lower than the system default, no additional changes
are necessary. The new, lower limit is enforced immediately. Note that the new limit does not impact agents
whose existing skill group membership exceeds the new limit until the next attempt to add a new skill group
for those agents. At that time the new limit is enforced, preventing you from adding additional skill groups.

Exceeding the default limit
If you have modified the skill groups per agent limit to be higher than the system default (in spite of the
Warning given above), certain deployments require additional changes (listed in the following sections) to
your system to use the new limit and allow you to add additional skill groups.

Note

If you exceed the default limit and are using CTI OS, do not exceed a maximum of 99 skill groups.

IPCC Gateway PG
For IPCC Gateway deployments, modify the following registry keys on your IPCC Gateway PGs to include
the new value. A change to the registry requires that you restart the PG service.
IPCC Enterprise Gateway PIM (Cisco Unified Contact Center Enterprise parent):
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\< customer_instance
>\PG{n}[A|B]\PG\CurrentVersion\PIMS\pim{m}\ACMIData\Config\MaxSkills
IPCC Express Gateway PIM (Cisco Unified Contact Center Express parent):
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\< customer_instance
>\PG{n}[A|B]\PG\CurrentVersion\PIMS\pim{n}\ACMIData\Config\MaxSkills

ERI PG
For ERI deployments, modify the following registry key on your ERI PGs to include the new value. A change
to the registry requires that you restart the PG service.
ER Service PIM:
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\< customer_instance
>\PG{n}[A|B]\PG\CurrentVersion\PIMS\pim{n}\ERSData\Config\MaxSkills
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Network transfer for IVRs
When a call is transferred from an IVR (for example, IP IVR) to an agent and that agent wants to transfer the
call to another agent, the transfer can be made either from the agent's IP phone or the agent desktop.
Transfers made from the:
• IP phone are made using CTI route points that point to a Unified ICM/Unified CCE script.
• Agent desktop are made using the Dialed Number Plan.

Note

If the route point is configured using Unified CM, there is no difference between using the hard phone or
the desktop phone.
For network transfer from either the IP phone or the CTI Toolkit Agent Desktop, you must queue the call to
the skill group in the first Unified ICM/Unified CCE script; for example, “NetXfer1,” to create the call context.
In this script you must set the “networkTransferEnabled” flag to “1”.

Note

IP IVR does not support network transfer. Unified CVP supports only network “blind” transfer.

Unified CCE routing
To understand how Unified CCE routes voice calls, you must understand the concepts of routing operation
and routing configuration.

Routing operations
To understand how Unified CCE routing occurs, you must understand these concepts:
• The Routing Client: The Unified CCE component that submits a route request to the Central Controller.
In Unified CCE configurations, the routing client can be:
◦ The Unified CM PG
◦ An interexchange carrier (IXC)
◦ A VRU PG
◦ A Media Routing Peripheral Gateway
When a routing client makes a request for a route from the Unified ICM/Unified CCE platform, it receives
the response and delivers the call to the specified destination. If an Unified CCE agent is available,
Unified ICM/Unified CCE software routes the call to the device target (phone) on the Unified CM
(device targets are dynamically associated with the agent when the agent logs in to the system). If an
agent is not available, you can configure Unified ICM/Unified CCE software to queue the call to IP IVR
or Unified CVP.
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• Route and Queuing Requests: Messages sent from the routing client to the Central Controller. Route
requests typically pass along call detail information about the incoming call. Unified ICM/Unified CCE
software uses information in the route request to determine which routing script is run for the call.
Call detail information sent with the route request can include:
◦ Dialed Number (DN)
◦ Calling line ID (CLID)
◦ Caller Entered Digits (CED)
Queueing requests are messages sent from the VRU using the Cisco Service Control Interface. The VRU
makes a queue request to provide announcements or music when no Unified CCE agents are available
to take the call.
• About Routing to the VRU with Unified CCE: With Unified CCE you can ensure that voice calls are
routed to the VRU when an agent is not immediately available. The call is queued to the VRU and sent
to the next available agent via the routing script.
The configurations for routing to a VRU in a Unified CCE environment include:
◦ Translation Route to the VRU via a route on the PG. The Unified CM uses the DNIS in the
translation route to direct the call to the VRU.
◦ A network route request is issued by the carrier via the NIC. The DNIS and/or Correlation ID is
retrieved from the carrier.
◦ The call is sent directly to the VRU, so that caller entered digits (CED) can be collected.
You do not need a translation route to a Unified CM PG because it is targeting agents and implicitly
matches call data.
• Routing a Call to the VRU: Translation routing is the preferred method of routing a call to the VRU.
The DNIS used in the translation route is not the original number dialed by the customer, but rather, the
Dialed Number used to route the call to the VRU.
The scenario is as follows:
◦ Call comes in to the Unified CM.
◦ Unified CM identifies the number as a route point for the Unified CM PG.
◦ The Unified C PG receives a route request from the Unified CM and forwards it to the CallRouter.
◦ The CallRouter runs the script for the translation route to the VRU.
◦ A Label is returned to the Unified CM via the Unified CM PG.
◦ The Unified CM routes the call to the VRU, based on the CTI route point for the translation route.
◦ VRU sends up a request instruction with the DN as the DNIS.
◦ VRU PG matches up the call and the Correlation ID, then informs the CallRouter of the call arrival
with a “request instruction.”
◦ The CallRouter matches the correlation ID and finds the pending script/call.
◦ The CallRouter continues with script (for example, run script).
For translation routing, the VRU Type to configure in the Network VRU in the Unified
ICM/CCE/CCH Administration User Interface is type 2.
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Be sure the Unified CM PG routing client and the VRU PG routing client both have the labels
mapped for the peripheral targets in the translation route.

Routing configuration
To set up routing in your Unified CCE system, you must set up the following entities:
• Dialed Numbers: The dialed number is the number that the caller dials to contact an agent. It is sent as
part of the call detail information in the route request message sent from the routing client.
In the system software, you set up a Dialed Number List. It identifies all of the phone numbers in your
contact center that customers can dial to initiate contact.
The Dialed Number plays an integral role in routing calls. Dialed Numbers are required pieces of Unified
ICM call types that are used to identify the appropriate routing script for each call.
• Call Types: A call type is a category of incoming Unified ICM routable tasks. Each call type has a
schedule that determines which routing script or scripts are active for that call type at any time. There
are two classes of call types: voice (phone calls) and non-voice (for example, email and text chat). Voice
call types are categorized by the dialed number (DN), the caller-entered digits (CED) and the calling
line ID (CLID). Non voice call types are categorized by the Script Type Selector, Application String 1,
and Application String 2. In either case, the last two categories of the call type can be optional. For voice
call types, the caller-entered digits and the calling line ID can be optional, depending on the call. For
non voice call types, Application String 1 and Application String 2 can be optional, depending on the
application.
Because the call type determines which routing script is run for a call, the call type defines call treatment
in a Unified CCE system. Therefore, the call type is the highest level reporting entity. Reporting on call
type activity provides insight into end-to-end customer interactions with the system and with agents by
providing data such as service level adherence, transfers, average speed of answer, calls handled, and
calls abandoned.
In routing scripts, such as scripts for Self-Service VRU applications, you may change the call type at
specific points in the script to indicate that a transaction has been completed. For example, if the customer
is calling a bank and successfully checks their account balance using a Self-Service script, you may
want to change the call type to indicate that the account balance transaction has completed and a new
transaction has begun.
You can also change the call type in a script to invoke a new routing script associated with that call type.
For example, if a call is not answered at an agent's desktop, you can change the call type in the script to
redirect the call to a different script designed for Redirection on No Answer. The Redirection on No
Answer script assigns a different agent to handle the call.
• Routes:Unified ICM/Unified CCE software uses routes to define the mapping of a target to a specific
label for a routing script. Targets include services (service targets), skill groups (skill targets), agents
(device targets), and translation routes.
Routes must be defined for VRU Translation Routing and to route calls to agents.
• Device Targets: A device target is a telephony device that can be uniquely addressed (or identified) by
a telephone number. A device target is not associated with any one peripheral. Each device target must
have one or more labels associated with it, although only one label may exist per routing client. Unified
CCE V9.0(1) introduces Agent Targeting Rules, which greatly simplifies call routing configuration.
Cisco recommends you move from Device Targets to Agent Targeting Rules.
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Note

Device targets and agents are separate entities. A device target is a separately addressable
device and is not exclusively owned by any particular agent. Device targets are
dynamically associated with Unified CM PG agents for the duration of a log in session.

You must configure each Unified CM PG telephony device that is used by an agent in the Unified ICM
database as a device target.
• Labels: A label is the value that Unified ICM/Unified CCE software returns to a routing client instructing
it where to send the call. The routing client can map the label to an announcement, a trunk group and
DNIS, or a device target. Special labels might instruct the routing client to take another action, such as
playing a busy signal or an unanswered ring to the caller.
If the label is for a device target, the routing client is responsible for delivering the call to the device
target on the Unified CM through the voice gateway.
If the label is for a VRU queue point, the routing client delivers the call to the Route Point on the VRU.
The VRU must recognize that the call has arrived and then request queue instructions from Unified
ICM/Unified CCE software. Unified ICM/Unified CCE software returns either a destination for the call
or instructions on what script the VRU will run, based on a particular Call Type.
• Services: You set up Services in Unified ICM/Unified CCE software to represent the type of processing
that a caller requires, and to configure VRU Services to route calls to the VRU. For example, you might
define separate services for Sales, Support, or Accounts Payable. A Service is often associated with a
peripheral and can be referred to as a Peripheral Service.
For Services that are used to route a call to an agent, you must associate them with skill groups. You
associate different Skill Groups with Services by making them members of the Service. Using Services
allows you to group agents working in like skill groups.
• Skill Groups: Agents must be associated with skill groups to receive Unified ICM-routed calls. You
create skill groups using the Unified ICM/Unified CCE/Unified CCH Administration User Interface.
A base skill group is the main skill group created using the Unified ICM/Unified CCE/Unified CCH
Administration User Interface. Using base skill groups ensures accurate agent reporting and simplifies
configuration and scripting for your contact center.
Agents must be associated with skill groups or precision queues. You can create precision queues using
the Unified CCE Web Administration.
A sub-skill group is a subdivision of a base skill group.

Note

Sub-skill groups are not supported in Unified CCE 9.0(1); the only instance where they
are still supported is for Avaya PG, Symposium PG, and Spectrum PG peripherals in
Unified ICM deployments.

You cannot create a sub-skill group for the System PG, CallManager, and ARS PG peripheral types.
The only operation allowed on these sub-skill groups on these peripheral types is their removal. After
you remove the sub-skill groups, you cannot add them back into the configuration.

Note

Sub-skill groups are also not supported for non-voice skill groups. That is, you cannot
create sub-skill groups for these media classes: chat, blended collaboration, and email.
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• Migrating from Sub-skill Groups to Base or Enterprise Skill Groups
Follow these steps to migrate from sub-skill groups to base and enterprise skill groups:
◦ Disable the sub-skill group mask for the peripheral using the PG Explorer tool. All skill groups
created after you complete this are base skill groups.
◦ Define a new base skill group to correspond with each sub-skill group being removed.
◦ Assign agents to the new base skill groups and remove them from your sub-skill groups.
◦ Optionally, create enterprise skill groups to group the base skill groups.
◦ Update all of your routing scripts and routing templates so that they refer to the newly created base
or enterprise skill groups.

Routing scripts
A routing script, created using the Script Editor, identifies the desired agent based upon skills and customer
database profile, determines the call target, and returns a route response to the routing client.
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Routing tasks for multichannel options
If you install multichannel features with Unified CCE, it is important that you understand how Unified
ICM/Unified CCE software routes contacts and requests made from the Unified EIM Server and the Unified
WIM Server.
• Software configuration for multichannel routing, page 23
• Multichannel software configuration, page 23

Software configuration for multichannel routing
To route contact requests submitted from the World Wide Web or email, you must configure:
• Media Routing Peripheral Gateway
• Media Routing Domains and Media Classes
• Multichannel agents
• Application instances
• Administration connections
• Multichannel skill groups
• Multichannel routing scripts
For more information about configuring Unified CCE for multichannel routing, see Installation and
Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted.

Multichannel software configuration
After you complete your Unified ICM/Unified CCE configuration, you must configure your Unified ICM
multichannel software and Cisco Media Blender.
The multichannel software you must configure includes:
• Cisco Unified Interaction Manager, which includes Unified EIM and Unified WIM
• Cisco Media Blender
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For more information about how to administer these components, see Unified EIM and Unified WIM Installation
Guides and Administration Guides at http://www.cisco.com/en/US/products/ps7236/tsd_products_support_
series_home.html and http://www.cisco.com/en/US/products/ps7233/tsd_products_support_series_home.html.
For more information about configuring the Cisco Media Blender component of the Web Collaboration Option,
see Cisco Media Blender Installation Guide for Cisco ICM/IPCC Enterprise & Hosted Editions and the Cisco
Media Blender Administration Guide for Cisco ICM/IPCC Enterprise & Hosted Editions.
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PART

II

Administrative tasks with Cisco Unified Contact
Center Enterprise
• Overview, page 25
• Agent administration, page 27
• Voice Call Routing with Cisco Unified Contact Center Enterprise, page 39
• Dialed Number Plan, page 43

Overview
The following sections describe the configuration required for setting up Unified CCE agents and agent
features. These sections also provide information on setting up voice and multichannel routing with Unified
CCE.

Note

If you choose to upgrade Unified CM, you need to update the Java Telephony API (JTAPI) client on the
Unified CM PG and then restart the PG. If you perform Unified CM maintenance that involves configuration
changes only, the Unified CM PG does not require restart. For more information about updating the JTAPI
Client, see Cisco Unified Contact Center Express Administration Guide.

CHAPTER

4

Agent administration
This chapter explains the tasks you must be familiar with when setting up agents for your Unified CCE
contact center.
• Administering agents, page 27
• Configure Not Ready Reason Codes, page 30
• Agent feature configuration, page 30
• Supervisor feature configuration, page 35
• Agent Re-skilling Tool, page 35
• Network transfer for IVR configuration, page 36

Administering agents
Create voice-only agent
Before You Begin
You must ensure that you have already set up agent desk settings before configuring agents.

Procedure
Step 1

Create an Agent record by selecting ICM Configuration Manager > Tools > Explorer Tools > Agent
Explorer.
If you want to associate this agent with an existing Person record, select the Select Person button.
Important

Do not change an agent's ID while the agent is logged in to the CTI Toolkit Agent Desktop.
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Note

This step creates an Agent record associated with the Person record.
• Agent IDs can be up to nine digits long. The first digit in the ID must be 1 through 9. It cannot
be 0. Also, this number cannot be the same as the extensions on the CCM cluster for this agent.
• If you change the Agent ID (Peripheral ID), you must cycle the PG to populate the new agent
ID and information in the CTI Toolkit IPCC Supervisor Desktop.

Step 2

Enter the agent information and click Save.
This step creates the Agent record.
If you did not use the Select Person button to associate the agent with an existing Person record, a new Person
record is automatically created for the agent.

Note

You can also add many agents at one time using the Bulk Configuration tool.

Delete voice-only agent
You logically delete agents using the Agent Explorer tool. You cannot delete agents from the Agent Explorer
until you remove them from any teams using the Agent Team List tool. If agents exist in script references,
use the Script Reference tool to find any existing references, then use the Script Editor application to delete
that script. Agents still exist in the deleted objects databases until permanently deleted.

Note

For scripting and reporting purposes, if you configure the script to send a call directly to an agent and that
agent is permanently deleted, the call/script fails. Also, you can run historical reports for permanently
deleted agents.

Procedure
Step 1
Step 2
Step 3
Step 4

Select ICM Configuration Manager > Tools > Explorer Tools > Agent Explorer.
Note
If this was the last or only Agent record associated with the Person record for this agent, then the
associated Person record is also deleted.
Highlight the agent and select Delete.
Deletes the agent as well as the associated person.
Select ICM Configuration Manager > Tools > Miscellaneous Tools > Deleted Objects.
Highlight the Agent table name in the Tables with Deleted Records window, then highlight the agent in the
Deleted Records of the “Agent” Table window and select Delete.
The agent is permanently deleted from the database.

Create agent supervisor
You create an agent supervisor by simply modifying the Agent record in the Configuration Manager.
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Important

You must perform the configuration procedure below so the supervisor can use the Barge-In and Intercept
features.

Procedure
Step 1

Select the Supervisor tab in the Agent Explorer tool application when you create or modify an Agent record.
Accesses an Agent record.

Step 2

Select the Supervisor Agent check box. Enter the Windows Domain name.
Complete the remaining fields on this tab as described in the Configuration Manager online help.
Designates the agent as a supervisor.

Delete agent supervisor
You delete an agent supervisor by simply modifying the Agent record in the Configuration Manager.

Procedure
Step 1
Step 2

Select the Supervisor tab in the Agent Explorer tool application when you delete an Agent record.
This step accesses an Agent record.
Clear the Supervisor Agent check box.
The agent is no longer designated as a supervisor.

Delete voice-only agent, on page 28

Create agent team
After adding agents with the Agent Explorer tool, you can create agent teams with the Agent Team List tool.

Procedure
Step 1
Step 2

Access the Agent Team List tool by selecting ICM Configuration Manager > Tools > List Tools > Agent
Team List.
Select Retrieve, and then select Add to add a new agent team.
Allows you to begin defining a new agent team. Complete the window, adding desired agents to the team.

Step 3

Select the Members tab.
Allows you to select agents to add to the team.

Step 4

Select the Supervisor tab.
Allows you to designate a supervisor for the team.
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With Unified CCE, assign both a primary and a secondary supervisor to each agent team.

Delete agent team
You delete agent teams with the Agent Teams List tool. You cannot delete a team until you remove the agent
and supervisor from that team.

Procedure
Step 1
Step 2
Step 3
Step 4

Access the Agent Team List tool in the Configuration Manager by selecting ICM Configuration Manager
> Tools > List Tools > Agent Team List.
Select Retrieve to obtain the current list of teams.
Highlight the team you want to delete and select Delete.
Select Save to save your changes.

Configure Not Ready Reason Codes
Procedure
Step 1

Select ICM Configuration Manager > Tools > List Tools > Reason Code List.
Example:

If you are using the CTI Toolkit Agent Desktop, make sure the Reason Codes match the codes on
the desktop. Unified ICM Reason Codes appear in the Agent Not Ready reports, but the agent actually
selects the desktop code, so these codes must match to avoid confusion. Configure predefined Not
Ready Reason Codes so their text appears in the reports.
Enable the Agent event detail option by selecting ICM Configuration Manager > Tools > Explorer Tools
> PG Explorer, and then selecting the Unified CM peripheral.
Select the Agent event detail check box on the Agent Distribution tab to enable reporting on Not Ready
Reason Codes.
Configure the Not Ready Reason Codes on the desktop.
Note

Step 2
Step 3
Step 4

For more information about configuring CTI OS Logout and Not Ready Reason Codes, see CTI OS System
Manager's Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.

Agent feature configuration
This section describes how to perform the following tasks:
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• Configure Unified CCE for Redirection on No Answer situations on IP IVR and Unified CVP
• Configure automatic wrap-up
• Configure supervisor assist and emergency alert situations

Configure Unified CCE for Redirection on No Answer on IP IVR
Unified CM is the Unified ICM Routing Client that ensures the call arrives at the right destination.

Important

The recommended Redirection on No Answer situation configuration is detailed in the procedure below.

Procedure
Step 1

Configure agent desk settings by selecting ICM Configuration Manager > Tools > List Tools > Agent
Desk Settings List.
Allows you to define the following:
• A Redirection on No Answer time
• Redirection on No Answer dialed number (to access the Redirection on No Answer script defined in
Step 3, below)
The Redirection on No Answer timer is not applicable if the Auto answer option is enabled because
the Redirection on No Answer feature and Force Answer are mutually exclusive. If both are defined,
Auto answer takes precedence over Redirection on No Answer.
Set up the call type by selecting ICM Configuration Manager > Tools > List Tools > Call Type List.
This step sets up the call type and associates it with the dialed number and the routing script.
Note

Step 2
Step 3

Using the Script Editor, create a routing script to handle Redirection on No Answer situations.
This step allows you to define routing logic used for situations when an assigned agent does not answer.
Important

This script queues the call at the highest priority in the skill group(s) defined within the call
variables; otherwise, the call is no longer the first call to be routed off of the queue, as it was
when it was first assigned to the (unavailable) agent. Also, call variables that were set in the
original routing script are still present in the ring-no-answer script. Consequently, you might
want to set variable values in one script that can be checked and acted upon in the other script.
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• If you configure the Redirection on No Answer timer in the Unified ICM agent desk settings, it is
not necessary to configure the Unified CM Call Forward No Answer fields for the agent extensions
in the Unified CM configuration. If you want to configure them for cases when an agent is not logged
in, set the Unified CM system service parameter for the Unified CM Call Forward No Answer timer
at least 3 seconds higher than the Unified ICM Redirection on No Answer timer on each of the
Unified CM nodes.

Note

• If you want to ensure that Redirection on No Answer calls adversely affect the service level, define
the service level threshold to be less than the Redirection on No Answer timer at the call type and
service.

Configure Unified CCE for Redirection on No Answer on Cisco Unified CVP
For Unified CCE systems in which Unified CVP is deployed, the Unified CM does not control Unified CVP
and cannot send an unanswered call back to Unified CVP for re-queuing. You configure the Re-route on
Redirection on No Answer feature to only make the agent state “Not Ready” when the agent does not answer
a call; you can use the Unified CVP Target Requery feature to re-queue the call. For more information, see
Installation and Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted.

Unified CM does not control the queuing platform (Unified CVP); therefore, Unified CM cannot send the
call back to Unified CVP for re-queuing.

Important

Recommended configuration for Redirection on No Answer situations is detailed in the procedure below.

Procedure
Step 1

Configure agent desk setting by selecting ICM Configuration Manager > Tools > List Tools > Agent Desk
Settings List.
Allows you to define the following:
• A Redirection on No Answer time: Set this number less than the number set for the No Answer Timeout
for the Target Requery that you set in Unified CVP (causes agent to be made unavailable after the
Redirection on No Answer timer expires, but cannot invoke the Redirection on No Answer mechanism
to re-route the call—see Step 3, below)
• Redirection on No Answer dialed number (to access the Redirection on No Answer script): Leave this
field blank
The Redirection on No Answer timer is not applicable if Auto-answer is enabled because the
Redirection on No Answer feature and Force Answer are mutually exclusive. If both are defined,
Auto-answer takes precedence over Redirection on No Answer.
Using the Unified CVP VBAdmin tool, configure the Unified CVP ring-no-answer timeout value.
This step causes Unified CVP to issue a requery to the system software, if the assigned agent does not answer.
In the VBAdmin tool, use the SetRNATimeout command to set the ring-no-answer timeout to a duration that
is two seconds longer than the Redirection on No Answer time set in Step 1.
Note

Step 2
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Set this timeout to under 30 seconds because the system software waits 30 seconds for Unified CVP
to return a routing label and then fails, so Unified CVP needs to requery before this happens.
Using the Script Editor, account for requeries in the routing script to handle Redirection on No Answer
situations.
Use the Target Requery script feature.
Note

Step 3

Do not create and schedule a new Routing script for Redirection on No Answer purposes in Unified
CVP deployments.
Allows you to report on Redirection on No Answer information. This script enables Requery (selects the
Requery check box) on the node in the script that selects and delivers the call to the first agent. Depending
on the type of node used, the Requery mechanism selects a new target from the available agents or requires
additional scripting.
Note

For information about how Requery works for the different nodes, see Scripting and Media Routing Guide
for Cisco Unified ICM/Contact Center Enterprise & Hosted.
Important

Note

This script queues the call at the highest priority in the skill group(s) defined within the call
variables. Otherwise, the call is no longer the first in queue, as it was when it was first assigned
to the (unavailable) agent.

• If you configure the Redirection on No Answer timer in the Unified ICM agent desk settings, it is
not necessary to configure the Unified CM Call Forward No Answer fields for the agent extensions
in the Unified CM configuration. To configure them for cases when an agent is not logged in, set
the Unified CM system service parameter for the Unified CM Call Forward No Answer timer at
least 3 seconds higher than the Unified ICM Redirection on No Answer timer on each of the Unified
CM nodes.
• To ensure that Redirection on No Answer calls adversely affect the service level, define the service
level threshold to be less than the Redirection on No Answer timer at the call type and service.

Configure automatic wrap-up
Automatic wrap-up allows you to force agents into Wrap-up mode when they are finished with inbound or
outbound calls.

Procedure
Step 1

Select ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List.
Use these two fields to enable automatic wrap-up:
• Work mode on Incoming
• Work mode on outgoing
Choose either Required or Required with wrap-up data to indicate automatic wrap-up.
Also, enter the time, in seconds, allocated to an agent to wrap-up a call.

Step 2

Configure agent desk settings to require appropriate Reason Codes.
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This configuration allows you to determine if and when agents are required to enter a Reason Code when they
log out or enter a Not Ready state.

Configure supervisor assist and emergency alert
The recommended supervisor assist and emergency alert situation configuration is detailed in the procedure
below.

Procedure
Step 1

Configure agent desk settings by selecting ICM Configuration Manager > Tools > List Tools > Agent
Desk Settings List.
This step allows you to define the following:
• Assist call method
• Emergency alert method

Step 2

Set up the call type by selecting ICM Configuration Manager > Tools > List Tools > Call Type List
This step allows you to set up the call type and associate it with the dialed number and the routing script.

Step 3

Configure Dialed Number for supervisor by selecting ICM Configuration Manager > Tools > List Tools
> Dialed Number/Script Selector List.
This step allows you to define the following:
• Dialed number string
• Call type

Step 4

Configure Agent Team by selecting ICM Configuration Manager > Tools > List Tools > Agent Team
List.
Allows you to define the Supervisor script dialed number option.

Step 5

Using the Script Editor, create a routing script to associate the dialed number.
Use the Agent to Agent node to route the call to the primary supervisor by editing the formula with the call
preferredagentid. In addition, in case this routing fails, set up a route to the skill group where the secondary
supervisors are located.
This step allows you to report on blind conference and consultative call information. This script associates
the supervisor's dialed number with the script using the Script Editor's Call Type Manager window.

For more information about agent desk settings, agent teams, and dialed numbers, see Installation and
Configuration Guide for Cisco Unified Contact Center Enterprise & Hosted and the Configuration Manager
online help.
For more information about Reason Codes, see CTI OS System Manager's Guide for Cisco Unified ICM/Contact
Center Enterprise & Hosted.
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Supervisor feature configuration
This section explains how to configure the supervisor logged-in state for CAD.

Configure supervisor logged-in state for CAD
Procedure
Step 1

Configure agent desk settings for the CAD supervisor by selecting ICM Configuration Manager > Tools
> List Tools > Agent Desk Settings List.
Example:

This step creates separate desk settings for the CAD supervisor.
Step 2

Leave the Logout non-activity time option blank.
Leaving this option blank keeps a supervisor logged in to Cisco Agent Desktop.
A CAD supervisor uses Cisco Supervisor Desktop to view agent activity, silently monitor, record agent calls,
send Team Performance Messages, and chat with agents and other supervisors. A supervisor can only barge
in, intercept, or view skill statistics if Cisco Agent Desktop is running on the supervisor's computer.

For more information about agent desk settings, see Installation and Configuration Guide for Cisco Unified
Contact Center Enterprise & Hosted and the Configuration Manager online help.
For more information about barge-in and intercept, see CTI OS System Manager's Guide for Cisco Unified
ICM/Contact Center Enterprise & Hosted.

Agent Re-skilling Tool
Access Agent Re-skilling Tool
Access to the Agent Re-skilling Tool is limited to individuals with supervisor privileges.

Procedure
Step 1

To access the Agent Re-skilling Tool using your agent name:
a) In your browser's address bar, enter:
https://<agent_reskilling_server_ip_or_dns>/reskill
Your administrator must provide you with this address.
b) Press Enter.
The Login page appears.
c) Enter your supervisor username and password.
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In a Unified CCE system, the login name to the Agent Re-skilling Tool may or may not be case
sensitive. This is determined by the “Login case sensitive” value in the System Information screen
under Miscellaneous Tools in the Configuration Manager.
d) Select Login.
Note

Step 2

In certain deployments, you have the option of logging in to the Agent Re-skilling Tool using your numeric
agent ID. To log in using your agent ID:
a) In your browser's address bar, enter:
https://<agent_reskilling_server_ip_or_dns>/reskill.
Your administrator must provide you with this address.
b) Press Enter. The Login page appears.
c) Select the Login By Agent ID link.
Note
If this link does not appear on the Login Page you can only log in using your login
name.
d) Enter your numeric agent ID and password.
e) Select the correct peripheral for your agent ID. Consult your administrator if you are not sure of your
correct peripheral.
f) Select Login.

What to Do Next
For security purposes, log out when you are finished using the Agent Re-skilling Tool. Select the Log Out
link at the top-right of the page. This action returns you to the Login page. Sessions also time-out automatically
after 30 minutes of inactivity. If your session ended due to inactivity, you are prompted to login again to
resume using the tool.
For more information about using the Unified CCE Agent Re-skilling tool, see the online help.

Network transfer for IVR configuration
Configure network transfer from IP phone
To configure network transfer from an IP Phone, complete the following steps.

Procedure
Step 1
Step 2

Define a CTI Route Point, for example “9999”, in the Unified CM. Associate it with the JTAPI User that is
connected to IPCC PIM in the system software.
In the Administration Client or Administration & Data Server, define a Dialed Number for IPCC PIM and a
call type for that dialed number. You can then associate this call type with a Unified ICM script; for example,
“NetXfer2.”
Note
Do not define the labels of agents for the Unified CM PG. Instead, define the labels for the VRU
PIM so that the route result is returned to VRU instead of a Unified CM PG. If you do define the
agent labels for the Unified CM PG, the Router returns the route result to the VRU PIM, if “Network
Transfer Preferred” is enabled on the Unified CM PG and VRU PIM and returns the route result to
the Unified CM PG if “Network Transfer Preferred”" is disabled on the Unified CM PG and VRU
PIM.
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Step 3

When the call is delivered to Agent 1 using the Unified ICM Script “NetXfer1,” the agent can dial the number
9999 to send the call to another script, “NetXfer2.”

Configure network transfer from CTI OS Desktop
To configure network transfer from a CTI OS Desktop, complete the following steps.

Procedure
Step 1
Step 2
Step 3

Define a “Dialed Number Plan” in the system software. The routing client is the IPCC PIM and the dialed
number is the one defined before for the IPCC PIM (that is, IPCC_PIM.9999).
Set the Post Route to Yes and the Plan to International.
In the agent desk settings, select all the Outbound access check boxes.
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Voice Call Routing with Cisco Unified Contact
Center Enterprise
• Unified CCE voice routing setup, page 39
• Routing a target device in Unified CCE, page 40

Unified CCE voice routing setup
Configure a device target
Procedure
Step 1
Step 2

Add/configure an IP Phone on Unified CM.
Create/configure a Device Target on the system software by selecting ICM Configuration Manager >
Targets > Device Target > Device Target Explorer.
Be sure to enter the Dialed Number associated with the IP Phone. Use this string when you enter the dialed
number: /devtype ciscophone/dn 9510.
This step ensures that Unified ICM can send this string to the Unified CM to initialize the device.

Step 3

Associate the device in Unified CM with the selected Global User.
Maps the user and CTI Route Point.

Duplicate extensions in multi-site installations
You can use duplicate extensions in different sites in a multi-site Unified CCE configuration. To accomplish
this, you must associate the device targets with the appropriate peripheral using the /PID configuration
parameter. This ensures that the device target is tied to the peripheral and is not recognized by other peripherals.
To associate a device target with a peripheral:
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• Add or modify single device target entries using the Device Target Explorer. (Use the Device Target
Bulk (Insert) tool when adding a new device.)
• Set the Configuration Parameter field to /PID <xxxx>, where <xxxx> is the four-digit Peripheral ID
(that is, /PID 5000). When you save this change, it takes effect immediately. You do not need to cycle
the Unified CM PG Node services for this to take effect.

Routing a target device in Unified CCE
The following procedures outline the steps to follow each time you want to route to a new device target in
Unified CCE.

Target device routing on Unifed CM
Procedure
Step 1

Create a CTI Route Point on the Unified CM.
This step configures the Unified CM to make a route request to the system software when the Route Point is
dialed.

Step 2

Associate the CTI Route Point with the PG User.
This step makes the Route Point visible to the system software.

Route target device using Configuration Manager
Procedure
Step 1

Create a new Dialed Number using the Configuration Manager.
Defines a new entry point for call routing.

Step 2

Add a new Call Type using the Configuration Manager.
Allows you to categorize calls and route them appropriately.

Step 3

Associate the Dialed Number with the Unified ICM Call Type.
Allows you to map the Dialed Number to a routing script.

Step 4

Create a new routing script using the Script Editor.
Routes the call to the entry point.

Step 5

Associate the Call Type with the routing script.
Associates the Call Type with the routing script.
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Note

• In a Unified CM cluster, be aware that two routing clients must not share the same CTI Route Point.
Each routing client must use distinct CTI Route Points in a Unified CM cluster.
• When you configure a calling party transformation mask for the translation pattern in Unified CM,
the application will have additional connections and disconnections. Therefore, for the components
to function properly, Cisco recommends you not have a translation pattern mask for the calling party.

Peripherals and skill groups
Only base skill groups are supported for Unified CCE configurations. A default is set at the peripheral level,
ensuring that any new skill group created is base-only.
Agents must be associated with skill groups or precision queues. You can create precision queues using the
Unified CCE Web Administration.
For more information about creating routing scripts, see Scripting and Media Routing Guide for Cisco Unified
ICM/Contact Center Enterprise & Hosted and the Script Editor online help.
For more information about configuring Unified CCE, see Installation and Configuration Guide for Cisco
Unified Contact Center Enterprise & Hosted.

Administration Guide for Cisco Unified Contact Center Enterprise & Hosted Release 9.0(1)
41

Routing a target device in Unified CCE

Administration Guide for Cisco Unified Contact Center Enterprise & Hosted Release 9.0(1)
42

CHAPTER

6

Dialed Number Plan
Note

The Dialed Number Plan is applicable only to the Voice media.
• About Dialed Number Plan, page 43
• Dialed Number Plan values, page 44
• Dialed Number Plan configuration, page 48

About Dialed Number Plan
The Dialed Number Plan allows you to manage and track agent-initiated calls.
The Dialed Number Plan applies only to calls initiated by the agent on their soft phone and not on their hard
phone. Calls made on the hard phone are not subject to the permission, interpretation, translation, posting
routing, and so on, specified in the Dialed Number Plan.

Dialed Number Plan explained
The Dialed Number Plan consists of a number of entries intended to accommodate the different types of calls
agents might make. Each entry contains a wildcard string that is used to match a number that an agent might
dial. Each digit of the string is processed until a matching dial plan entry is found. When found, the selected
trunk group or resource is used to complete the call.
Each entry contains additional information indicating how to handle the calls matching that wildcard string.
For example, dialing a 9 to receive an outside line on a PBX or ACD is specified in the dial plan. All patterns
that reference network trunks might begin with a “9” digit. Subsequent digits might be “1” for long distance
patterns, “0” for operator assisted or international calls, “2” through “9” to specify an area code. The dial plan
allows a customer to have multiple phone carrier trunks terminated at the PBX or ACD for different outbound
call types. A customer might choose MCI as the long distance carrier while AT&T is the international carrier,
and Bell Atlantic is the local carrier. The dial plan configuration is used to determine which carrier to use
based on the patterns defined within the dial plan.
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Note

Do not confuse the Dialed Number Plan Bulk Insert tool with the Dialed Number Bulk Insert tool.
You use the Dialed Number Plan to:
• Ensure agent-initiated calls are routed by a Unified ICM routing script
• Set up basic dialing substitutions

Dialed Number Plan and routing of agent calls
The most common and powerful use of the Dialed Number Plan is to ensure that agent-initiated calls are
routed through the system software. In this case, you must specify that you want to request a PostRoute for
the call and specify a dialed number associated with a routing script designed to handle the type of agent call.
Use this method of configuring the Dialed Number Plan for:
• Agent-to-agent transfers
• Agent-to-agent calling
• Agent-initiated outbound calls

Dialed Number Plan and basic dialing substitutions
You can also use the Dialed Number Plan to specify basic dialing substitutions. In this scenario, you identify
a wildcard pattern to match the number dialed by an agent. However, you do not request a Post Route and the
call is not matched to a Dialed Number, and thus not routed by the system software. Instead, you enter the
string you want to be dialed in the Dial String field. That string is used to place the agent's call.
Using the Dialed Number Plan in this way is most useful for setting up such things as:
• Speed dial
• Using alphanumeric characters to dial from a soft phone

Dialed Number Plan values
Each field on the Dialed Number Plan dialog box is defined in the Configuration Manager online help. This
section provides additional information about these fields and how you can use them to set up agent dialing
for your contact center.
The window below illustrates a Dialed Number Plan entry that specifies Unified ICM routing for the agent
call.
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Wildcard pattern
The wildcard pattern you enter can contain letters, digits, and number signs (#). It can also include the following
wildcard characters.
Character

Description

?

Represents any single alphanumeric character.

!

Represents any string of character and can appear only at the end of a
pattern.

Routing Client
The Routing Client field lets you specify the routing client for the agent call. In Unified CCE configurations,
set this field to identify the Unified CM PG.

Post Route
Use the Post Route field to specify whether this type of agent call will be sent to a routing script. If you set
Post Route to Yes, you must also enter a Dialed Number that is associated with a routing script designed to
handle the type of agent call.

Dialed Number
Use the Dialed Number field if you have set the Post Route field to Yes, indicating that you want a Unified
ICM routing script to handle this agent call.
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Dial String
Use the Dial String field only when you set the Post Route field to No, indicating that you want to use this
entry for dialing substitutions. This field cannot be used when PostRoute is selected to send the call to a
Unified ICM routing script.
The Dial String field can contain wildcard characters used to translate the dialed number string provided by
the agent to the dial string that will be delivered to the switching platform. The following table describes the
wildcard characters that might appear in the DialString field.
Wildcard Character

Description

!

Matches any group of characters

?

Matches any single character

X or x

Excludes the character in the agent supplied dialed number string at the
position identified from the offset as defined from the beginning of the
DialedNumberPlan DialString field

The following table provides examples of the translation of a DialedNumber string specified by an agent to
a resultant DialString as defined by the DialString entry of the matching DialedNumberPlan entry.
Agent Dialed Number

DialedNumber Plan Dial Dial string result
String

Description

5133

6100

6100

Direct substitution.

5133

6X???

6133

Partial replacement.

5133

!

5133

Complete Copy.

5133

9275!

92755133

Prefix Addition.

5133

62XX??

6233

First 2 char substitution.

5133

????

5133

Complete Copy.

5133

?XXX000

5000

Retain first character;
substitute the remaining
characters.

2755100

????200

2755200

Replace last three
characters.

2755100

!220

2755100220

Suffix addition.
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Dial String configuration for speed dialing
You can configure Static Dial String translations to provide speed dial capabilities. Here, you enter the
abbreviated string an agent dials in the wildcard pattern. You enter the actual target number in the Dial String
of the entry.
When a dialed number (provided by an agent) matches the wildcard pattern of the Dialed Number Plan entry,
the Dial String configured entry is sent in place of the agent supplied Dialed Number string.
The following table provides an example of a speed dial configuration.
Agent Dialed Number

Wildcard Pattern

Dial String

Result

133

1??

919782755!

919782755133

Dial String configuration for alphanumeric substitutions
You can use the Dialed Number Plan to allow agents to specify an alphanumeric string when dialing. For
instance, an agent might dial SALES when calling the sales department rather than a numeric value that might
be harder to remember.
To configure an alphanumeric substitution, configure the alphanumeric dial string as the wildcard pattern and
the target number as the Dial String of the DialedNumberPlan entry. When a dialed number provided by an
agent matches the wildcard pattern of the Dialed Number Plan entry, the configured Dial String is sent in
place of the agent supplied string.
You can combine wildcard characters with this feature to allow Alpha prefixes to be added to numbers to
identify the location of the number. Examples are shown the following table.
Agent Dialed Number

DialedNumberPlan Dial String

Resultant Dial String

SALES

919782755100

919782755100

BOS5133

9782755133

9782755133

FL14Office1433

5133

5133

Dial Number Type Plan
The Dial Number Type Plan lets you specify the type of call that will be placed.
Dialed Number Plan

Description

International

Allows agents to place calls classified as international calls.

National

Allows agents to place calls classified as national long distance
calls.

Local

Allows agents to place calls classified as national local calls.
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Dialed Number Plan

Description

Operator Assisted

Allows agents to place calls classified as operator assisted calls.

PBX

Allows agents to place calls to agents on the same peripheral.

The options for this field map exactly with the options on the agent desk settings list window. The system
software checks the agent desk settings for the agent placing the outbound call. agent desk settings define
which types of calls agents are permitted to make. If the agent desk settings for an agent prevent them from
placing a particular type of call (for instance, international), the call is not placed.

Dialed Number Plan configuration
Use Dialed Number Plan to ensure routing of agent calls
Follow these steps to configure a Dialed Number Plan entry to route an agent call through the system software.

Procedure
Step 1

Create a routing script to handle each type of agent-initiated call using the Script Editor.
This step ensures agent-initiated calls are routed appropriately by the system software.
The script can target agent, services, or skill groups using Unified ICM script nodes. When a target is chosen,
the associated label is sent back to the requesting peripheral. The label value is substituted for the dial string
specified by the agent and sent to the switching platform to place the outbound call.

Step 2

Select ICM Configuration Manager > Tools > List Tools > Call Type List.
Allows you to set up the call type and associate it with the dialed number to target to routing scripts.
You can also use a pre-existing call type and
script.
Select ICM Configuration Manager > Tools > Bulk Configuration > Insert > Dialed Number Plan Bulk
Insert and insert an entry in the Dialed Number Plan dialog.
Using the fields in this window, make sure to:
Note

Step 3

• Indicate the appropriate wildcard character.
• Set the Post Route text box to Yes.
• Select a valid Dialed Number associated with the routing script used to route the agent call.
• Set the Dial Number Type Plan to indicate the type of call.
This step matches the agent's dialed string to a Dialed Number. This ensures the agent's call will be routed by
a Unified ICM routing script.
Step 4

Select ICM Configuration Manager > Tools > List Tools > Agent Desk Settings List and ensure that Agent
Desk Settings are set to identify the types of calls agents can place.
Ensures that agents are allowed to or restricted from placing different types of outbound calls.
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Use Dialed Number Plan to set up basic dialing substitutions
Follow these steps to configure a Dialed Number Plan entry to route an agent call through the system software.

Procedure
Step 1

Insert an entry in the Dialed Number Plan dialog box by selecting ICM Configuration Manager > Tools >
Bulk Configuration > Insert > Dialed Number Plan Bulk Insert.
Using the fields in this window, make sure to:
• Indicate the appropriate wildcard character.
• Set the PostRoute field to No.
• Identify a valid Dial String used to place the call.
• Set the Dial Number Type Plan to indicate the type of call.
Matches the agent's dialed string to the Dial String indicated in the entry. This Dial String is used to place the
call (the call will not be routed by the system software).

Step 2

Ensure agent desk settings are set to identify the types of calls agents can place by selecting ICM Configuration
Manager > Tools > List Tools > Agent Desk Settings List.
Ensures that agents make only the types of outbound calls they are permitted to make.

For more information about Unified ICM Routing Scripts, see Scripting and Media Routing Guide for Cisco
Unified ICM/Contact Center Enterprise & Hosted.
Agent desk settings configuration, on page 4
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