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Introduction
Cisco Supervisor Desktop is a robust computer telephony integration solution for IPbased contact centers that is easy to deploy, configure, and manage. It provides
supervisors with powerful tools to increase productivity and improve customer
satisfaction.
Supervisor Desktop’s features allow you to view real time statistics, monitor and coach
agents, barge-in, intercept, and record active agent calls when necessary, enabling
effective management of agent resources.

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering
additional information, see the monthly What’s New in Cisco Product Documentation,
which also lists all new and revised Cisco technical documentation, at:
http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html
Subscribe to the What’s New in Cisco Product Documentation as a Really Simple
Syndication (RSS) feed and set content to be delivered directly to your desktop using a
reader application. The RSS feeds are a free service and Cisco currently supports RSS
version 2.0.

Documentation Feedback
You can provide comments about this document by sending e-mail to the following
address:
ccbu_docfeedback@cisco.com
We appreciate your comments.

Supervisor Desktop Feature Levels
There are three feature levels in Supervisor Desktop: Standard, Enhanced, and Premium.
The following table outlines the features available at each feature level. All features not
listed here are present in both versions.
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Feature

Standard

Enhanced

Premium

Silent monitoring

x

x

Barge-in

x

x

Intercept

x

x

Recording

x

x

Chat with team members (CAD agents only)

x

x

Team messages

x

x
x

E-mail contact service queues (CSQs)
Supervisor work flows—threshold alerts for tree control
actions

x

Supervisor work flows—all actions except threshold
alerts for tree control actions
Real time displays (text)

x
x

x

x

Real time displays (charts)

x

Web page push to agents

x

Contact service queue statistics

x

x

x

Cisco Unified Personal Communicator

x

x

x

Cisco Unified CCX Web Chat
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x

x

Logging In
Note: If you want to use all of the functionality of Supervisor Desktop, you must
first log into Agent Desktop. For more information, see the Cisco Agent Desktop
User Guide.
To log in to Supervisor Desktop:
1. Start Supervisor Desktop. The Supervisor Login dialog box appears.
2. Enter your Supervisor Desktop login name or ID and password in the appropriate
fields, and then click OK or press Enter. Supervisor Desktop starts, but does not show
any data, and the status bar displays “No Service”.
3. From the Team drop-down list, select a team. Supervisor Desktop displays the data
for the selected team.
4. If your configuration includes Cisco Unified Presence, you have chosen to log into
Unified Presence through Supervisor Desktop (see Logging into Cisco Unified
Presence), and your Unified Presence login is different from your Supervisor Desktop
login, the Cisco Unified Presence Server Login dialog box appears. Type your Unified
Presence username and password and click Login.
Note: In a high availability over WAN triangle configuration (both servers and
the CAD client applications communicate over a WAN) when the WAN link
between the two servers is down, Supervisor Desktop might not function
properly and you might not be able to see all active agents.

Login Notes
The first time you log into Supervisor Desktop:
n

Your user ID and password are the same as your Agent Desktop user ID and password.

n

The User ID field is empty. The next time you log in, the User ID field is automatically
filled with the information you entered before. If you share a computer with another
supervisor, verify that this field has your information and not the other supervisor’s
information.
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n

It might take some time for Supervisor Desktop to start because default report
data must be generated.

Logging in to Cisco Unified Presence
You can log into Cisco Unified Presence through any one of the following applications:
n

Agent Desktop

n

Supervisor Desktop

n

Cisco Unified Personal Communicator

Important: Do not log in to Unified Presence through more than one application,
even using different user IDs. Unified Presence cannot communicate with more
than one client application on any one computer.
By default, Supervisor Desktop assumes that you log into Unified Presence through Agent
Desktop. If you choose to log in through Supervisor Desktop, you must configure this
option (Enable Cisco Unified Presence) through the Preferences window. See Preferences
for more information.
Information from Unified Presence (for example, non-agent subject matter experts and
personal contacts) appears only in the Contact Selection window accessed from the
application through which you logged into Unified Presence.
For example, if you log into Unified Presence through Supervisor Desktop, the Supervisor
Desktop Contact Selection window will display Unified Presence information, agents, and
supervisors, and the Agent Desktop Contact Selection window will display only agents
and supervisors.
If you log in to Unified Presence through Unified Personal Communicator, neither
Supervisor Desktop nor Agent Desktop will display Unified Presence information, and
Unified Personal Communicator will not display agent and supervisor information.

Access Through a VPN
Supervisor Desktop is able to connect to the CAD servers through a virtual private
network (VPN). This allows a supervisor to work remotely and still have the benefits of the
full functionality of Supervisor Desktop.
Using a VPN is recommended in order to provide a more secure connection.
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When a desktop is using network address translation (NAT) due to a firewall or router, then
VPN software must be used on the desktop to ensure full bi-directional network
connectivity between the contact center servers and the desktop. Failure to use VPN
software will result in connectivity issues and a loss in functionality such as silent
monitoring, recording, and incoming chat message and team message failures.
Cisco AnyConnect Secure Mobility Client is verified to work correctly with Supervisor
Desktop.
VPN solutions from other vendors might result in feature loss. Because they have not been
formally verified, they are not supported.
Note: After installing Cisco AnyConnect Secure Mobility Client, you must restart
your computer. If you do not restart, monitoring and recording will not work
properly.

VPN Tunneling
There are two types of VPN tunneling mechanism, full tunneling and split tunneling, both of
which are supported for connection between Supervisor Desktop and the CAD services.

VPN Full Tunneling
VPN full tunneling virtually replaces the network connection with the local area network
defined by the VPN. If VPN full tunneling is used to connect to CAD servers, the VPN
connection must be established before starting Supervisor Desktop. If the VPN
connection is lost during a session, you must close Supervisor Desktop, reestablish the
VPN connection, and then restart Supervisor Desktop.

VPN Split Tunneling
VPN split tunneling allows you to access a public network and a local area network
simultaneously, using the same physical network connection.
There are two types of VPN split tunneling scenarios.
n

Scenario 1: The CAD servers are on the public network and a third-party application is used through the VPN. In this scenario, you must launch and log into
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Supervisor Desktop before establishing the VPN connection. If the VPN connection
is lost during a session, you must restart Supervisor Desktop and then reestablish
the VPN connection.
n

Scenario 2: The CAD servers are on the VPN and a third-party application is used
through the public network. In this scenario, you must establish the VPN connection before launching Supervisor Desktop. If the VPN Connection is lost during
a session, you must close Supervisor Desktop, reestablish the VPN connection,
and then restart Supervisor Desktop.

If Supervisor Desktop can log into all services except the Chat service, it must be restarted
after the Chat service comes back online.
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Automated Updates
CAD enables your administrator to update all instances of the CAD desktop applications
automatically to a newer version. It also ensures that the correct version of Java Runtime
Environment (JRE) is installed on your computer.

CAD Desktop Applications
Every time you launch Supervisor Desktop, the software checks to see if there is an
updated version available, or if there was a system configuration change that requires a
Windows registry change. If either of these conditions exists, the software automatically
runs the update process.
When an update is available, you will see a dialog box notifying you that your copy of
Supervisor Desktop will be updated. Click OK to proceed with the update.
A progress bar is displayed to show you the status of the update process.
When the update is finished, you will see a final dialog box that tells you that the update is
complete, and which applications were updated. If you have Cisco Agent Desktop and
Cisco Desktop Administrator on your PC, they will also have been updated.
Note: Because Agent Desktop is automatically installed when Supervisor
Desktop is installed, only Supervisor Desktop will be listed as having been
updated in the final dialog box. Agent Desktop will be listed only if Supervisor
Desktop is not present on your PC.
When you click OK to close the dialog box, any CAD desktop application running on your
desktop restarts automatically.
Note: To ensure that automated updates function correctly, you must configure
Internet Explorer so that it checks for newer versions of stored pages. To
configure this setting, launch Internet Explorer and choose Tools > Internet
Options. In the Browsing history section on the General tab, click Settings. Select
the option labeled Every time I visit the web page.

Note: If your system is configured with two Unified CCX servers, and one server is
upgraded while your instance of Supervisor Desktop is connected to the older
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Unified CCX server, and your administrator performs a failover to switch all
agents to the upgraded server, your instance of Supervisor Desktop will not
automatically upgrade when you log into the new server. You must shut down
Supervisor Desktop and start it again for the automatic upgrade to take place.

Java Runtime Environment
Every time Supervisor Desktop is launched, it checks to see if the correct version of Java
Runtime Environment (JRE) is installed. If the correct version is not detected, you will be
notified, and Supervisor Desktop will download and install the correct JRE.
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The Supervisor Desktop window is divided into five areas:
n

The Skill Groups tree, which lists all of the CSQs associated with the team you
choose from the team selection list

n

The agents tree, which lists all of the agents and supervisors on the team

n

Tabular/graphical real time displays of CSQ information

n

Tabular/graphical real time displays of agent and team information

n

Integrated browser (if enabled)

The Supervisor Desktop interface is highly configurable. By default, the browser is not
enabled and the panes are not dockable. However, you can add or remove real time
displays, enable the integrated browser, and enable all panes to act as dockable windows
(so you can move them and resize them independently). You can also change the size of
the toolbar icons from the default 16 × 16 pixels to 32 × 32 pixels.
The specific panes that are displayed depends on the nodes that you select in the Skill
Groups and Agents tree. If you choose to enable the integrated browser, the real time
displays and the browser appear on tabs in the right pane.
The figure below shows the Supervisor Desktop window in its default configuration.
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Real time display panes are identified as containing information related to voice CSQs, email CSQs, or agents by the text in their title bars, as shown in the following figure.

When Supervisor Desktop is in default layout (movable windows are disabled), CSQ real
time displays occupy approximately the top half of the right pane, and the Agents real time
displays occupy approximately the lower half of the right pane. The tree panes and real
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time display panes can all be resized by dragging the horizontal splitters up and down and
the vertical splitters left and right.
If you choose to enable movable windows (see Preferences), all of the real time display
panes can be resized and moved anywhere on your desktop. However, each type of
display can only dock to another display of its own type. In other words, CSQ displays
dock to other CSQ displays and Agent displays dock to other Agent displays. For
example, you cannot separate one Agent display from another Agent display, although
they can be resized in relationship to each other, as shown in the following figure.

You can also drag the vertical splitter between the trees panes and the display panes left or
right, and the horizontal splitter between the two trees panes up and down.
If you choose to enable the integrated browser, the real time displays and the browser
appear on tabs in the area to the right of the Skill Groups and Agents navigation trees.
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Preferences
The Preferences dialog box controls what information is displayed in the display panes
and how those panes behave. The following table summarizes what you can configure
using Preferences.
Tree Control Node

Available Displays

Configure
Graphs?

Configure
Refresh?

CSQs

Team Summary

Yes

Yes

Yes

Voice > CSQ

Summary

Yes

No

Yes

Detail

Yes

Yes

No

Summary

Yes

No

Yes

Detail

Yes

No

Yes

Assigned

Yes

No

Yes

Queued

Yes

No

Yes

Resolved

Yes

No

Yes

Team Summary

Yes

Yes

Yes

Team State

Yes

Yes

No

Agent

Agent vs. Team Summary

Yes

Yes

Yes

Logs

State

Yes

No

No

Call

Yes

No

No

Active Call

Yes

No

No

Enterprise Data

Yes

No

No

Enterprise Call History

Yes

No

No

E-Mail

Active E-Mail

Yes

No

No

Browser

Supervisor browser tabs

—

—

—

E-Mail > CSQ
(Premium package only)

Team

Calls

To set your preferences:
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The Supervisor Desktop Window
1. Choose View > Preferences. The Preferences window appears.

2. In the left pane, select a node. The right pane displays that node’s settings for each
available real time display.
n

Click Configure… next to Columns and select the columns to appear in the real
time display. Use the up and down arrows to set the order in which they should
appear.

n

Click Configure … next to Graphical Displays and select the type of chart you
want to display. You can select only one type of chart for each real time display.

n

Click Refresh rate in seconds and adjust the real time display’s refresh rate. The
refresh rate ranges from every 5 to 60 seconds, with the default set to 15
seconds. For CSQs, you can configure the data refresh to be done manually by
setting the refresh rate to zero (0).

3. In the left pane, select the Browser node. The right pane displays browser settings.
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n

In the Browser Home Page field, enter the URL for your home page. The default
is www.cisco.com.

n

In the Number of Browser Tabs field, select the number of browser tabs you
want, from 1 to 10. You can specify what web page appears in the tab by
selecting the tab from the Browser Tab field and entering the URL of the
desired web page. If you do not set a URL the tab will display the default, www.cisco.com.

4. At the bottom of the Preferences window are options that allow you to customize
Supervisor Desktop. Select or clear the check box for each option to turn it on or off.
The options are:
n

Enable movable windows—lets you rearrange the real time display panes.

n

Enable Integrated Browser—gives you access to the integrated browser.

n

Change Report Font Size to <size>—sets the font size in real time displays from
15 to 72 points.

n

Enable Large Toolbar Icons—changes the size of toolbar icons from 16 × 16
pixels to 32 × 32 pixels.

n

Enable Cisco Unified Presence—gives you access to Unified Presence users in
the Chat window. You must restart Supervisor Desktop (and Agent Desktop, if
running) for this option to take effect.

n

Enable Cisco Web Chat—gives you access to Cisco Unified Contact Center
Express Web Chat through the integrated browser. Unified CCX Web Chat will
appear in the first tab after the real time displays.

5. When you are finished configuring Supervisor Desktop, click OK.

Restoring the Interface Default Layout
To restore Supervisor Desktop to its default layout, open the Preferences window (choose
View > Preferences) and click Restore Default Layout.
Clicking this button makes the following changes:
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n

In the Real Time Displays pane, moves displays to their default positions

n

Disables the integrated browser

n

Disables movable windows

n

Disables any graphical real time displays you selected previously

The Supervisor Desktop Window
n

Resets the toolbar buttons to the default size

n

Disables Cisco Unified Presence

n

Disables Cisco Web Chat

Clicking this button does not make any of the following changes:
n

Columns are not resized to the default widths

n

Real time display columns that you delected previously are not restored

n

Report font size is not changed back to the default (15 points)

You must manually resize the columns yourself and reset the other two elements to their
default settings in the Preferences window.

Agents Tree
The Agents tree displays all agents and supervisors on the selected team who are currently
logged in, and any calls (ACD and non-ACD) they are on.
n

The icon next to the agent’s name indicates the agent’s current agent state.

n

This icon

n

If an agent device is multi-line–enabled, an asterisk next to an inbound or outbound
call indicates that the call is on an ACD line.

indicates that an agent is in the Not Ready state and is on a call.

Note: If you have the Standard feature level, only IP Phone agents appear in the
Agents tree.

Note: If an agent’s team assignment is changed, the change does not go into
effect until the CAD desktop applications are restarted.

Formatting Agent Names in the Agents Tree
The Preferences dialog box enables you to control how agent names are displayed in the
Agents tree.
An agent can be identified by any or all of the following:
n

Name

n

Extension
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n

Application used by the agent (CAD or Cisco IP Phone Agent [IPPA])

At least one of these must be selected to identify an agent in the Agents tree. If all options
are selected, the information in the agents tree appears as follows:
Jane Smith x1500 CAD
In this example, Jane Smith is a CAD agent on extension 1500.
To format agent names in the Agents tree:
1. Choose View > Preferences and then select the Agents node.
2. In the Format node text grid, check the elements you want to use to identify an agent.
You must select at least one element. A sample of what the name will look like appears
on the Sample line.
3. Click OK.

Accessibility
Supervisor Desktop has a number of features that improve accessibility for visionimpaired users.
n

Uses Windows settings for screen resolution, color/contrast, and font settings
Note: Enable high contrast before launching Supervisor Desktop to ensure
that all tables match the high contrast settings.

n

Scrolling or non-scrolling team messages

n

Shortcut keys and tool tips that are compatible with screen readers

n

Toolbar buttons available in small (16 × 16) and large (32 × 32) sizes

n

Navigation through each pane, browser, and all the elements of the main window
using the Tab key

n

Support for Job Access With Speech (JAWS) 11 screen reader software

Toolbar and Shortcut Keys
The following tables list the toolbar buttons and shortcut keys that you can use in
Supervisor Desktop.
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Agent State Buttons
Button

Name

Shortcut

Description

Logout

Ctrl+L

Logs the selected agent out of the
ACD.

Ready

Ctrl+E

Changes the seected agent’s state to
Ready.

Not Ready

Ctrl+N

Changes the selected agent’s state to
Not Ready.

Work

Ctrl+D

Changes the selected agent’s state to
Work.

Call Handling Buttons
Button

Name

Shortcut

Description

Barge In

Ctrl+B

Enables you to join an agent’s phone
conversation.

Intercept

Ctrl+I

Enables you to intercept a call while
disconnecting the agent from the call.

Team Communication Buttons
Button

—

Name

Shortcut

Description

Chat

Ctrl+J

Opens the Chat Selection window.

Team Message

Ctrl+X

Opens the Team Message window.

Refresh

Ctrl+F

Refreshes the information in the Skill
Groups tree and the Team Agent State
Display data view pane that has
changed since the last sync.

Coach by Pushing a Page

Ctrl+U

Opens the Push URL to Agent window.
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Recording Buttons
Button

Name

Shortcut

Description

Start Record

Ctrl+R

(Enhanced/Premium only) Starts
recording the selected call.

Stop Record

Ctrl+S

(Enhanced/Premium only) Stops
recording the selected call.

Voice Monitoring Buttons
Button

Name

Shortcut

Description

Start Voice Monitor

Ctrl+A

Starts monitoring the selected agent.

Stop Voice Monitor

Ctrl+P

Stops monitoring the selected agent.

Voice Monitor
Volume

Ctrl+V

Opens a volume slider control.

Accessibility Shortcut Keys
Shortcut Keys

Description

Ctrl+Shift+S

Selects the Skill Groups node in the Skill Groups tree.

Ctrl+Shift+A

Selects the Agents node in the Agents tree.

Ctrl+Shift+B

Shifts focus to the browser pane.

Ctrl+Shift+R

Shifts focus to the real time displays.

Ctrl+Shift+T

Selects the Team node in the Agents tree.

Ctrl+H

Selects the Team Selection drop-down list.

Ctrl+T

Shifts focus to what was previously selected in the Agents tree.

Ctrl+Shift+H

Opens the Service Status window.

Once you have set focus to the Skill Groups tree, the Agents tree, or the team node in the
agents tree, you can use the tab key to navigate to the real time display panes. Once your
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focus is in a real time display pane, you can use the arrow keys to navigate around the
display grid.
Note: The tab key will move you among the real time display panes, but the order
in which you access them will not necessarily be in sync with the physical
arrangement of the display panes on your desktop.

Integrated Browser Pane
The integrated browser pane allows you to view internet and intranet web pages to help
you assist agents and customers. The integrated browser has from 1 to 10 tabs, each of
which can display a different web page. You can configure each tab to display a specific
website.
For more information about this pane, see Integrated Browser.

Status Bar
The status bar displays current information about Supervisor Desktop.

From left to right, the status bar displays the following information:
n

User name

n

User ID or name

n

Current status of Supervisor Desktop features

n

Current system time in 24-hour format

In the event of a service failure, the Current Status section changes from “In Service” to
“Partial Service” or “No Service.” To learn which features are affected by the service
outage, double-click the Current Status section of the status bar to view a popup window
that displays active or inactive features.
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Integrated Browser
The integrated browser enables you to view intranet and internet web pages from within
Supervisor Desktop. When enabled, the browser appears as one or more tabs in the real
time display pane, with up to 20 characters of the name of the current web page displayed
on the tab. The real time displays appear on another tab in that pane (the default position is
in the first tab). The integrated browser can display up to 10 tabs, each containing a
different web page. The Address drop-down list contains the URLs of the last 25 websites
visited for quick access to frequently visited websites.
Note: You must have Internet Explorer installed on your PC for the integrated
browser to function.

Note: The integrated browser supports only one web session at a time for web
applications that use cookies for session management. For example, you cannot
log into a web application that uses cookies in one tab as User A and then log into
the same web application in another tab as User B. However, multiple web
sessions are supported for web applications that use URL-based session
management.

Note: Reordering of integrated browser tabs by dragging is not supported.
By default, the browser is not enabled. See Preferences for instructions on enabling the
browser and configuring a home page.

Toolbar Buttons and Shortcut Keys
The integrated browser toolbar contains basic browser buttons that allow you to navigate
among the web pages you view, refresh a current page, and return to your home page.
The integrated browser toolbar buttons and shortcut keys are listed in the following table.
Button

Name
Back
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Shortcut
Alt+left arrow

Description
Returns you to the last page you
viewed.

Integrated Browser
Button

—

Name

Shortcut

Description

Forward

Alt+right arrow

Takes you to the page you viewed
before clicking the Back button.

Stop

Esc

Stops the browser from loading a web
page.

Refresh

F5

Refreshes the current web page.

Home

Alt+Home

Returns you to your predefined home
page.

Address

Alt+D

Selects the Address field
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Real Time Displays
The real time displays contain the information you need to manage your teams and
agents. Real time displays include the following:
n

Agent – Agent vs. Team Summary

n

Agent Contact – Active Call

n

Agent Contact – Active E-Mail

n

Agent Contact – Enterprise Call History

n

Agent Contact – Enterprise Data

n

Agent Logs – Call

n

Agent Logs – State

n

Agents – Team State

n

Agents – Team Summary

n

E-Mail CSQ – Assigned

n

E-Mail CSQ – Detail

n

E-Mail CSQ – Queued

n

E-Mail CSQ – Resolved

n

E-Mail CSQ – Summary

n

E-Mail CSQ – Team Summary

n

Voice CSQ – Detail

n

Voice CSQ – Summary

n

Voice CSQs – Team Summary

There are two types of displays: tabular and graphical.
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n

Tabular displays present skill group, team, and agent information in a grid. Tabular
information can be sorted in scending/descending order by clicking any column
header in the grid. You can sort by one column only.

n

Graphical displays present the same information as bar charts, except for the
Agent vs. Team Statistics, which is presented as two pie charts.

Real Time Displays

Note: Graphical displays are available at the Premium feature level only.

Agent - Agent vs. Team Summary
The Agent vs. Team Summary display is available when you select a specific agent in the
Agents tree. This display presents the performance details for the agent and compares
them to the performance details of the team.
The data is obtained from the CAD Recording & Statistics service, and is for the current
day starting at midnight. The data refresh rate is configurable and ranges from every 5 to
630 seconds. By default it is every 15 seconds.
The graphical display is presented as two pie charts. These pie charts show the
percentage of time a specific agent spends in various ACD states in comparison to the
percentages spent by the team as a whole.

.
Note: Percentages in the pie chart are rounded to two decimal places. As a result,
the total of all percentages might not equal 100%.

Note: If Other Time is a small value, it might not show up as a slice in the graphical
display pie chart.
The display fields are described in the following table.
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Field
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Description

ID

Identifies the statistics as for the selected agent or the team.

Logon Time

The amount of time (in seconds) since midnight the agent and team
havebeen logged into Agent Desktop.

Calls Presented

The number of inbound calls (ACD and non-ACD) presented to the
agent since midnight.

Calls Handled

The number of inbound calls (ACD and non-ACD) presented to and
handled by the agent since midnight.

Max Talking

The longest talk time (in seconds) of all calls handled since midnight.

Avg Talking

The average talk time and hold time (in seconds) of all calls handled
since midnight.

Total Talking

The total Reserved time, talk time, and hold time (in seconds) of all
calls handled since midnight.

Max Ready

The longest time (in seconds) spent in the Ready state since midnight.

Avg Ready

The average time (in secondsd) spent in the Ready state since midnight.

Total Ready

The total time (in secondsd) spent in the Ready state since midnight.

Max Not Ready

The longest time (in seconds) spent in the Not Ready state since midnight.

Avg Not Ready

The average time (in seconds) spent in the Not Ready state since midnight.

Total Not Ready

The total time (in seconds) spent in the Not Ready state since midnight.

Max After Call Work

The longest time (in seconds) spent in the Work state since midnight.

Avg After Call Work

The average time (in seconds) spent in the Work state since midnight.

Total After Call Work

The total time (in seconds) spent in the Work state since midnight.

Other Time

The total time (in seconds) spent in states other than Talking, Ready,
Not Ready, Reserved, and Work since midnight.

E-Mails Retrieved

The number of e-mails received since midnight.

E-Mails Sent

The number of e-mails sent since midnight.

Real Time Displays
Field

Description

Max Processing

For all sent e-mail, the longest time (in seconds) spent in the E-Mail
Processing state with the e-mail in focus since midnight. All processing time is included, whether it occurred before or after midnight.

Avg Processing

For all sent e-mail, the average time (in seconds) spent in the E-Mail
processing state with the e-mail in focus since midnight. All processing time is included.

Total Processing

For all sent e-mail, the total time (in seconds) spent in the E-Mail Processing state with the e-mail in focus since midnight. All processing
time is included, whether it occurred before or after midnight.

Max On Desk

For all sent e-mail, the maximum time (in seconds) an e-mail spent on
desk since midnight. On-desk time begins when an agent receives an
e-mail and ends when the agent sends a reply to that e-mail. All ondesk time is included, whether it occurred before or after midnight.

Avg On Desk

For all sent e-mail, the average time (in seconds) an e-mail spent on
desk since midnight. On-desk time begins when an agent receives an
e-mail and ends when the agent sends a reply to that e-mail. All ondesk time is included, whether it occurred before or after midnight.

Max E-Mail Ready

The longest time (in seconds) spent in the E-Mail Ready state since
midnight.

Avg E-Mail Ready

The average time (in seconds) spent in the E-Mail Ready state since
midnight.

Total E-Mail Ready

The total time (in seconds) spent in the E-Mail Ready state since midnight.

Max E-Mail Not Ready

The longest time (in seconds) spent in the E-Mail Not Ready state
since midnight.

Avg E-Mail Not Ready

The average time (in seconds) spent in the E-Mail Not Ready state
since midnight.

Total E-Mail Not Ready

The total time (in seconds) spent in the E-Mail Not Ready state since
midnight.

Agent Contact - Active Call
The Active Call display is available when you select an active call under a specific agent’s
name in the Agents tree. This display presents information about each party in the current
active call. The data refresh rate is 1 second, and is not configurable.
The display fields are described in the following table.
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Field

Description

Name

Name of the parties in the call, if known. If this data is not known,
<unavailable> is displayed.

Number

The party’s phone number.

Call Status

The party’s hook state (Active or Held).

Duration

The length of time the party has been on the call.

Contact Service Queue

The ID of the CSQ that the call was queued to, if applicable.

Agent Contact - Active E-Mail
The Active E-Mail display is available when you select the E-Mail node underneath a
specific agent’s name in the Agents tree.
You can view an e-mail along with any inbound and outbound attachments in Agent EMail Viewer by double clicking the email from any of the Real Time Displays.
This display presents a summary of the e-mails the agent is working on. The data is for the
current day starting at midnight. The data refresh rate is 1 second, and is not configurable.
The display fields are described in the following table.
Field
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Description

From

The sender of the e-mail.

To

The recipient of the e-mail.

Subject

The subject of the e-mail.

Date Received

The date the e-mail was received.

Date Retrieved

The date the e-mail was retrieved from the queue by the agent.

In Process Duration

The length of time the agent spent processing the e-mail. Processing
time includes all time that the agent was in E-Mail Processing state
with the e-mail in focus.

On Desk Duration

The length of time the e-mail was on the agent’s desk. On-desk time
begins when an agent receives an e-mail and ends when the agent
sends a reply to that e-mail.

Contact Service Queues

The name of the CSQ to which the e=mail was routed.

Real Time Displays

Agent Contact - Enterprise Call History
The Enterprise Call History display is available when you select an active call under a
specific agent’s name in the Agents tree. This display presents a history of the call’s
presence in the contact center. The data refresh rate is 1 second, and is not configurable.
The display fields are described in the following table.
Field

Description

Threshold

The acceptable amount of time a call can remain at a particular device
or contact center. The administrator might assign caution and warning
threshold values to each device type, as well as a total threshold value
for a call. If a call remains at a device longer than the defined caution
and warning thresholds, a caution or warning icon is displayed in this
field.

Device

A device that the call has passed through.

type

The type of device that the call has passed through.

Description

Description of the device.

Duration

The amount of time that the call spent at the device.

Agent Contact - Enterprise Data
The Enterprise Data display is available when you select an active call under a specific
agent’s name in the Agents tree. The data displayed is configured by your administrator.
The data in the report can be refreshed manually by clicking the Refresh button on the
toolbar.

Agent Logs - Call
The Agent Call Log display is available when you select the Logs node underneath a
specific agent’s name in the Agents tree.
This display presents a history of the calls made and received by the agent during the
current session. By default, the data displayed is sorted in ascending order by time of day.
The data in the report can be refreshed manually by clicking the Refresh button on the
toolbar.
The display fields are described in the following table.
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Field

Description

Start Time

The time the call was answered.

Direction

Indicates if this is an inbound or outbound call.

Answered

(Yes/No) Indicates if this is an answered or unanswered call.

Calling Party

The originating phone number.

Called Party

The recipient phone number.

Call Duration

The length of the call.

Agent Logs - State
The Agent State Log display is available when you select the Logs node underneath a
specific agent’s name in the Agents tree.
This display presents a history of the ACD states the agent transitioned through during the
current session. By default, the data displayed is sorted in ascending order by time of day.
The data in the report can be refreshed manually by clicking the Refresh button on the
toolbar.
The display fields are described in the following table.
Field

Description

Start Time

The time the agent state was initiated.

Agent State

The ACD agent state.

Wrap-up Data

Any wrap-up data the agent entered, if the agent state transitioned to
after ending a call or sending an e-mail is Work (after-call work).

Reason Code

Any reason code the agent entered, if the agent state transitioned to is
Not Ready or Logout (if required).

State Duration

The length of time the agent was in the agent state.

Agents - Team State
The Team State display is available when you select the Team node or Agents node in the
Agents tree. This display presents the current agent state status for each agent on the
team. By default, the data displayed is sorted in ascending order by agent name.
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Note: If the agent is assigned to a new team while logged in, that agent will still
show up as a member of the old team in the Team State display until the agent
logs out and logs in again. After logging in, the agent will show up as a member of
the new team in the Team State display.
The data is obtained from the Chat service. The data refresh rate is 1 second, and is not
configurable.
The graphical display of the information consists of a bar chart with ACD states on the Y
axis and the number of agents currently in each ACD state.
The display fields are described in the following table.
Field

Description

Agent Name

The agent’s name.

Agent ID

The agent’s ID.

Current State

The agent’s current ACD state.

Skill Group

The skill group ID of the call the agent is currently servicing (in Talking
state). If there is no call, or if the call is a non-ACD call, this field is
blank.

Contact Service Queue

The name of the CSQ.

State Duration

The amount of time (in seconds) that the agent has been in the current
agent state.

Reason Code

The reason why the agent is in the current ACD state. Reason codes
are available for the Not Ready and Logout states only.

Agents - Team Summary
The Team Summary display is available when you select the Team node or Agents node in
the Agents tree.
This display presents the real time state of the agents on the selected team who are
currently logged into the ACD. By default, the data displayed is sorted in ascending order
by agent name.
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Note: If the agent is assigned to a new team while logged in, that agent will still
show up as a member of the old team in the Team Summary display until the
agent logs out and logs in again. After logging in, the agent will show up as a
member of the new team in the Team Summary display.
The data is obtained from the CAD Recording & Statistics service, and is for the current
day starting at midnight. The data refresh rate is configurable and ranges from every 5 to
60 seconds. By default it is every 15 seconds.
Graphical displays of the information consist of bar charts with agent names on the Y axis
and the average amount of time (hh:mm:ss) the agent spent in a selected ACD state.
The display fields are described in the following table.
Field
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Description

Agent Name

The agent’s name.

Agent ID

The agent’s ID.

Logon Time

The total amount of time the agent has been logged in to the
ACD today.

Calls Presented

The number of inbound calls (ACD and non-ACD) presented to the
agent today.

CAlls Handled

The number of inbound calls (ACD and non-ACD) presented to and
answered by the agent today.

Max Talking

The longest talk time of all calls handled today.

Avg Talking

The average talk time and hold time of all calls handled today.

Total Talking

The total resrved time, talk time, and hold time of all calls handled
today.

Max Ready

The longest time the agent spent in the Ready state today.

Avg Ready

The average time the agent spent in the Ready state today.

Total Ready

The total time the agent spent in the Ready state today.

Max Not Ready

The longest time the agent spent in the Not Ready state today.

Avg Not Ready

The average time the agent spent in the Not Ready state today.

Real Time Displays
Field

Description

Total Not Ready

The total time the agent spent in the Not Ready state today.

Max After Call Work

The longest time spent in the Work state today.

Avg After Call Work

The average time the agent spent in the Work state today.

Total After Call Work

The total time the agent spent in the Work state today.

Other Time

The total time (in seconds) the agent spent in states other than Talking,
Ready, Not Ready, Reserved, and Work since midnight.

E-Mail CSQ - Assigned
The Assigned display is available when you select a specific CSQ from the Contact
Service Queues > E-Mail tree.
Double-click any e-mail listed in the display to view the e-mail in the Agent E-Mail Viewer.
The data is for the last seven days. The data refresh rate is configurable and ranges from
every 5 to 60 seconds. By default it is every 15 seconds.
There is no graphical display available for these statistics.
The display fields are described in the following table.
Field

Description

Agent Name

The agent’s name.

From

The sender of the e-mail.

To

The recipient of the e-mail.

Subject

The subject of the e-mail.

Date Received

The date the e-mail was received.

Date Queued

The date the e-mail was moved to the CSQ.

Date Retrieved

The date the e-mail was retrieved from the queue by the agent.

E-Mail State

The agent’s current e-mail state.

Process Duration

The length of time the agent spent processing the e-mail. Processing
time includes all time that the agent was in E-Mail Processing state
with the e-mail in focus.

Draft Duration

The length of time the e-mail is in Draft state since the agent retrieved
it from the CSQ.
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E-Mail CSQ - Detail
The Detail display is available when you select a specific CSQ from the Contact Service
Queues > E-Mail tree.
Double-click any e-mail listed in the display to view the e-mail in the Agent E-Mail Viewer.
The data is for the current day starting at midnight. The data refresh rate is configurable
and ranges from every 5 to 60 seconds. By default it is every 15 seconds.
There is no graphical display available for these statistics.
The display fields are described in the following table.
Field

Description

Agent Name

The agent’s name.

Current Voice State

The agent’s current call ACD agent state.

Voice State Duration

The length of time the agent has been in the current call ACD agent
state.

Voice Reason Code

The reason code the agent selected when transitioning to the current
call ACD agent state.

Current E-Mail State

The agent’s current e-mail state.

E-Mail State Duration

The length of time the agent has been in the current e-mail state.

E-Mail Reason Code

The reason code the agent selected when transitioning to the current
e-mail state.

Contact Service Queue

The name of the CSQ for which the agent is currently handling a contact, if any.

Contact Service Queue ID

The ID of the CSQ for which the agent is handling a contact, if any.

Media

The media type of the CSQ, Voice or E-Mail.

E-Mail CSQ - Queued
The Queued display is available when you select a specific CSQ from the Contact Service
Queues > E-Mail tree.
Double-click any e-mail listed in the display to view the e-mail in the Agent E-Mail Viewer.
The data is for the last seven days. The data refresh rate is configurable and ranges from
every 5 to 60 seconds. By default it is every 15 seconds.
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There is no graphical display available for these statistics.
The display fields are described in the following table.
Field

Description

From

The sender of the e-mail.

To

The recipient of the e-mail.

Subject

The subject of the e-mail.

Date Received

The date the e-mail was received.

Date Queued

The date the e-mail was moved to the CSQ.

E-Mail CSQ - Resolved
The Resolved display is available when you select a specific CSQ from the Contact
Service Queues > E-Mail tree.
Double-click any e-mail listed in the display to view the e-mail in the Agent E-Mail Viewer.
The data is for the last seven days. The data refresh rate is configurable and ranges from
every 5 to 60 seconds. By default it is every 15 seconds.
There is no graphical display available for these statistics.
The display fields are described in the following table.
Field

Description

Agent Name

The agent’s name.

From

The sender of the e-mail.

To

The recipient of the e-mail.

Subject

The subject of the e-mail.

Date Received

The date the e-mail was received.

Date Completed

The date the e-mail was sent to the customer or to the Peer Review
Queue.

E-Mail State

The agent’s current e-mail state.

Wrap-up Data

Any wrap-up data the agent entered, if the agent state transitioned to
after ending a call or sending an e-mail is Work (after-call work).

38

Real Time Displays
Field

Description

Process Duration

The length of time the agent spent processing the e-mail. Processing
time includes all time that the agent was in E-Mail Processing state
with the e-mail in focus.

Draft Duration

The length of time the e-mail is in Draft state since the agent retrieved
it from the CSQ.

Date Reviewed

The date the e-mail is sent to the peer review agent.

Review Process Duration

The time the peer review agent spent on the e-mail after retrieving it
from the queue.

Review Draft Duration

The time the e-mail was in Draft state since it was retrieved from the
CSQ by the peer review agent.

E-Mail CSQ - Summary
The Summary display is available when you select a specific CSQ from the Contact
Service Queues > E-Mail tree.
You can view an e-mail along with any inbound and outbound attachments in Agent EMail Viewer by double clicking the email from any of the Real Time Displays.
The data is for the current day starting at midnight. The data refresh rate is configurable
and ranges from every 5 to 60 seconds. By default it is every 15 seconds.
There is no graphical display available for these statistics.
The display fields are described in the following table.
Field
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Description

Contact Service Queue

Name of the CSQ.

Agents Logged In

The number of agents in this CSQ who are currently logged in.

Agents Processing

The number of agents in this CSQ who are currently in the Processing
E-Mail state.

Agents Ready

The number of agents in this CSQ who are currently in the Ready state.

Agents Not Ready

The number of agents in this CSQ who are currently in the Not Ready
state.

Real Time Displays
Field

Description

Oldest E-Mail in Queue

Of the e-mails currently in queue for this CSQ, the length of time in
queue (in seconds) of the e-mail that has been in the queue the
longest.

Total E-Mail in Queue

The current number of e-mails in queue that have not been routed to
an agent.

Total E-Mails Received

The number of e-mails routed to this CSQ since the Start Time.

Handled Today

The number of e-mails routed through this CSQ that agent have sent
since midnight. The time of the sent event determines whether the email is included in the count.

Average Handle

The average processing time for e-mails sent since midnight. All the
processing time is included for the e-mail, including any time before or
after midnight.

Average Response

The average response time for e-mails sent since midnight. Response
time is the difference between the times the e-mail was received and
sent. All the response time is included for the e-mail, including any
time before or after midnight.

Longest Handle

Of the e-mails routed through the CSQ and sent since midnight, the
handle time (in seconds) for the e-mail with the longest handle time.
All the processing time is included for the e-mail, including any time
before or after midnight.

Longest Response

Of the e-mails routed through the CSQ and sent since midnight, the
response time for the e-mail with the longest response time (in
seconds). All the response time is included for the e-mail, including
any time before or after midnight.

E-Mail CSQ - Team Summary
The Team Summary display is available when you select the Contact Service Queues > EMail node.
Note: If the agent is assigned to a new team while logged in, that agent will still
show up as a member of the old team in the E-mail CSQs – Team Summary
display until the agent logs out and logs in again. After logging in, the agent will
show up as a member of the new team in the E-mail CSQs – Team Summary
display.
You can view an e-mail along with any inbound and outbound attachments in Agent EMail Viewer by double clicking the email from any of the Real Time Displays.

40

Real Time Displays
The data is for the current day starting at midnight. The data refresh rate is configurable
and ranges from every 5 to 60 seconds. By default it is every 15 seconds.
There is no graphical display available for these statistics.
The display fields are described in the following table.
Field
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Description

Contact Service Queue

The name of the CSQ.

Agents Logged In

The number of agents currently logged in who support the CSQ.

Agents Processing

The number of agents currently in the Processing E-Mail state who support the CSQ.

Agents Ready

The number of agents currently in the E-Mail Ready state who support
the CSQ.

Agents Not Ready

The number of agents currently in the E-Mail Not Ready state who support the CSQ.

Oldest E-Mail in Queue

Of the e-mails currently in queue for this CSQ, the length of time in
queue (in seconds) of the e-mail that has been in the queue the
longest.

Total E-Mail in Queue

The current number of e-mails in queue that have not been routed to
an agent.

Total E-Mails Received

The number of e-mails routed to the CSQ since midnight.

Handled Today

The number of e-mails routed through the CSQ that agents sent since
midnight. The time the e-mail was sent determines whether the e-mail
is included in this count.

Average Handle

The average e-mail processing time for e-mails sent since midnight. All
the processing time is included for the e-mail, including any time
before or after midnight

Average Response

The average response time for e-mails sent since midnight. Response
time is the difference between the times the e-mail was received and
sent. All the response time is included for the e-mail, including any
time before or after midnight.

Longest Handle

Of the e-mails routed through the CSQ and sent since midnight, the
handle time (in seconds) for the e-mail with the longest handle time.
All the processing time is included for the e-mail, including any time
before or after midnight.

Real Time Displays
Field
Longest Response

Description
Of the e-mails routed through the CSQ and sent since midnight, the
response time for the e-mail with the longest response time (in
seconds). All the response time is included for the e-mail, including
any time before or after midnight.

Voice CSQ - Detail
The Voice CSQ—Detail display is available when you select a specific CSQ from the Skill
Groups tree.
This display presents information about each agent logged into the ACD and assigned to
the selected CSQ. By default, the data displayed is sorted in ascending order by agent
name.
The data is obtained from the CAD Chat service, and are for the current day starting at
midnight. The data refresh rate is 1 second, and is not configurable.
The graphical display of this information consists of a bar chart with the ACD states on the
Y axis and the number of agents on the X axis.
The display fields are described in the following table.
Field

Description

Agent Name

The agent’s name.

Agent ID

The agent’s ID.

Current State

The agent’s current ACD state.

Skill Group

The skill group ID of the ACD call the agent is currently servicing (in
Talking state). If there is no call, or if the call is a non-ACD call, this
field is blank.

Contact Service Queue

The name of the CSQ.

State Duration

The amount of time (in seconds) that the agent has been in the current
ACD state.

Reason Code

The reason why the agent is in the current ACD state. Reason codes
are available for the Not Ready and Logout states only.

Voice CSQ - Summary
The CSQ — Summary display is available when you select a specific CSQ from the Skill
Groups tree.

42

Real Time Displays
This display presents a summary of a specific CSQ’s statistics. These statistics are from
the entire contact center, not just from members of the selected team.
The data is obtained from the CTI server unless otherwise noted, and are for the current
day starting at midnight. The data refresh rate is configurable and ranges from every 5 to
60 seconds. By default it is every 15 seconds.
Note: Even though you can configure the refresh rate, it is still dependent on how
often the Enterprise service queries the CTI service (every 10 seconds). If the
refresh rate is changed to a shorter time interval, the display will be refreshed at
that interval, but the statistics might not change until the Enterprise service
receives the updated information from the CTI service.
There is no graphical display available for these statistics.
The display fields are described in the following table.
Field
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Description

Contact Service Queue

The name of the CSQ.

Agents Logged In

The number of agents currently logged into the system.

Agents in Talking

The number of agents currently in the Talking state.

Agents Ready

The number of agents currently in the Ready state.

Agents Not Ready

The number of agents currently in the Not Ready state.

Agents in Work

The number of agents currently in the Work state.

Agents Reserved

The number of agents currently in the Reserved state.

Current Oldest

The number of calls in queue and the elapsed wait time of the oldest
call in the queue, displayed in the format “x [hh:mm:ss]”, where X is
the number of calls and hh:mm:ss is the elapsed wait time.

Total Calls

Total number of calls that have arrived, including calls waiting, calls
connected to agents, and calls that have disconnected.

Handled Calls Today

Number of calls handled by the CSQ for the current reporting period. A
handled call is defined as an inbound call (ACD and non-ACD) presented to and answered by the agent.

Calls Abandoned

Number of calls that were routed to the CSQ but were not answered by
an agent because the caller hung up or was disconnected.

Real Time Displays
Field

Description

Calls De-queued

Number of calls that were dequeued. A call is considered to be
dequeued from a particular CSQ if the call is handled by an agent in
another CSQ. This situation can occur when a call is queued for more
than one CSQ.

Start Time

The starting date and time of the current reporting period.

End Time

The ending date and time of the current reporting period.

Talk Average

Average talk time for all calls handled by agents. Talk time is the
elapsed time between the time that an agent connects to a call and
when the call is disconnected or transferred, not including hold time.

Average Wait Duration

Average wait time for calls routed to the CSQ. Wait time is the elapsed
time between the time a call entered the queue and the time the call
was answered by an agent or was disconnected.

Longest Talking

Longest talk time of any one call that agents have handled. Talk time is
the elapsed time between the time that an agent connects to a call
and when the call is disconnected or transferred, not including hold
time.

Longest Waiting

Longest wait time for any one call routed to the CSQ. Wait time is the
time that elapsed between the time a call entered the queue and the
time the call was answered by an agent or was disconnected.

Calls Priority 1 … Calls Priority 10

Total number of Priority N calls that were routed to each CSQ.

Voice CSQs - Team Summary
The Team Summary display is available when you select the Skill Groups node in the Skill
Groups tree.
This display presents the details of each individual skill group, regardless of whether or not
an agent with that skill is logged in. By default, the data displayed is sorted in ascending
order by skill name.
The data is obtained from the CTI server unless otherwise noted, and are for the current
day starting at midnight. The data refresh rate is configurable and ranges from every 5 to
60 seconds. By default it is every 15 seconds.
Note: Even though you can configure the refresh rate, it is still dependent on how
often the Enterprise service queries the CTI service (every 10 seconds). If the
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refresh rate is changed to a shorter time interval, the display will be refreshed at
that interval, but the statistics might not change until the Enterprise service
receives the updated information from the CTI service.
Graphical displays of this information consist of bar charts with the skill name on the Y axis
and any of the available statistics listed in the table below on the X axis, expressed in either
an integer (0, 1, 2…) or time duration (hh:mm:ss).
The display fields are described in the following table.
Field
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Description

Contact Service Queue

The name of the CSQ.

Agents Logged In

The number of agents currently logged into the system.

Agents in Talking

The number of agents currently in the Talking state.

Agents Ready

The number of agents currently in the Ready state.

Agents Not Ready

The number of agents currently in the Not Ready state.

Agents in Work

The number of agents currently in the Work state.

Agents Reserved

The number of agents currently in the Reserved state.

Current Oldest

The number of calls in queue and the elapsed wait time of the oldest
call in the queue, displayed in the format “x [hh:mm:ss]”, where X is
the number of calls and hh:mm:ss is the elapsed wait time.

Total Calls

Total number of calls that have arrived, including calls waiting, calls
connected to agents, and calls that have disconnected.

Handled Calls Today

Number of calls handled by the CSQ for the current reporting period. A
handled call is defined as an inbound call (ACD and non-ACD) presented to and answered by the agent.

Calls Abandoned

Number of calls that were routed to the CSQ but were not answered by
an agent because the caller hung up or was disconnected.

Calls De-queued

Number of calls that were dequeued. A call is considered to be
dequeued from a particular CSQ if the call is handled by an agent in
another CSQ. This situation can occur when a call is queued for more
than one CSQ.

Start Time

Starting date and time of the current reporting period. If there is a failover, the start time reflects the time when the failover occurred.

Real Time Displays
Field

Description

End Time

The ending date and time of the current reporting period.

Talk Average

Average talk time for all calls handled by agents. Talk time is the
elapsed time between the time that an agent connects to a call and
when the call is disconnected or transferred, not including hold time.

Average Wait Duration

Average wait time for calls routed to the CSQ. Wait time is the elapsed
time between the time a call entered the queue and the time the call
was answered by an agent or was disconnected.

Longest Talking

Longest talk time of any one call that agents have handled. Talk time is
the elapsed time between the time that an agent connects to a call
and when the call is disconnected or transferred, not including hold
time.

Longest Waiting

Longest wait time for any one call routed to the CSQ. Wait time is the
time that elapsed between the time a call entered the queue and the
time the call was answered by an agent or was disconnected.

Calls Priority 1 … Calls Priority 10

Total number of Priority N calls that were routed to each CSQ.
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Agent E-Mail Viewer
You can view customer e-mail messages, along with agent responses and attachments, in
the Agent E-Mail Viewer.
You can view any e-mail listed in the Assigned, Queued, or Resolved real time displays or
under the E-Mail node in the Agents tree. For more details on E-Mail CSQ real time
displays, see Real Time Displays.
The fields displayed in the Agent E-Mail Viewer are listed in the following table.
Field

Description

From

The sender of the e-mail.

To

The recipient of the e-mail.

Cc

The external e-mail addresses of the recipients copied in on the email, if any.

Subject

The subject of the e-mail.

Sent

The date and time when the customer sent the e-mail.

Received

The date and time when the e-mail was received.

Handled By

The name of the agent who handled the e-mail.

Handled Date

The date and time when the agent replied to the customer.

To vew an e-mail using the Agent E-Mail Viewer:
1. Double-click an e-mail from the Assigned, Queued, or Resolved real time display or
under the E-Mail node in the Agents tree. The e-mail opens in the Agent E-Mail Viewer.
2. Double-click any inbound or outbound attachment. The attachment opens in an
application based on the attachment’s format.
Note: Although you can edit opened attachments, those changes are not
saved and will not appear in the e-mail attachment when reopened.
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Supervisor Record Viewer
The Supervisor Record Viewer displays all recordings made by your team over the last
seven days as well as those you tag for a 30-day extended lifetime.
Note: Supervisor Record Viewer is a separate program from Supervisor Desktop.
Closing Supervisor Desktop will not close Supervisor Record Viewer.

The Supervisor Record Viewer displays the information listed in the following table.
Field

Description

Agent

The name of the agent whose call is recorded.

Team

The team to which the agent belongs.

Time

The time the recording was made.

Duration

The length of the recording in hh:mm:ss format.
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Field

Description

Lifetime

The length of time the recording is archived. Normal is 7 days, Extended is 30 days.

Date Recorded

Appears only when “Extended Lifetime” is selected in Day Select. The
date the recording was made.

Note: A license is used whenever a playback is in progress and released when the
playback ends. If no licenses are available when you attempt to play back a
recording, this error message is displayed: “A licensing error has occurred. Please
try again in five minutes. If the problem persists, please see your log file or System
Administrator for details.” You must wait until a license is released and available in
order to review any recordings.

Note: In a High Availability system, recordings can be stored on either of the two
recording servers, and all are displayed in Supervisor Record Viewer. If one of the
servers becomes inactive and cannot be accessed, the recordings stored on that
server cannot be played, even though they continue to be displayed in Supervisor
Record Viewer. If you attempt to play a recording stored on an inactive server,
you will see the error message, “The recording server is inactive.” You will be able
to play the recording when the server becomes active again.
The recordings are archived as raw voice data packets; they can only be played back
using the Supervisor Record Viewer. However, if you want to save selected recordings as
WAV files, you can use the “Play and Save” button and save the recording to a folder in
WAV format.
Unless recordings are tagged for an extended lifetime, they are automatically deleted after
seven days.
If a recording is tagged for the 30-day extended lifetime, it will not be deleted until that
30-day period expires. If you delete it manually before the 30-day period expires, it is
deleted in the next folder cleanup. Cleanups run daily at midnight.
To start Supervisor Record Viewer:
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1. From the Supervisor Desktop menu bar, choose Tools > Recorded Files. Supervisor
Record Viewer starts with the current day selected.
2. From the Day Select section, click one of the date options to view the recordings made
by your team on that date.
To listen to a recording:
1. From the Day Select section, click the option for the date of the recording you want to
review.
You can also click the Extended Lifetime option to view a list of all recordings that have
been tagged for extended 30-day archiving.
2. Select the recording you want to review.
3. Click the play button, or choose Recording > Play from the menu bar.
Use the Pause or Stop buttons to control the recording playback, and the volume
slider to control the playback volume.
There is a progress bar at the bottom of the window that shows where you are within
the recording. You can click the progress bar and drag it to the left or right to rewind or
fast forward the recording. To restart the playback, click Play.
Note: You cannot play back a recording while you are monitoring a call.
To save a recording:
1. Select the recording you want to save.
2. Click the Play and Save button, or choose Recording > Play and Save from the menu
bar. The Save As dialog box appears.
3. Select the folder where the recording is to be saved, enter a file name for the recording, and then click Save. The recording plays and simultaneously is saved as a WAV file
to the location you selected.
To tag a recording for extended archiving:
1. Select the recording you want to archive for 30 days.
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2. Click the Set Extended Lifetime button, or choose File > Set Extended Lifetime from
the menu bar. The recording is tagged to be archived for 30 days from the date of
recording.

Toolbar and Shortcut Keys

From left to right, the toolbar buttons are:
n

Play

n

Play & Save

n

Pause

n

Stop

n

Set Extended Lifetime

n

Set Normal Lifetime

n

Delete

n

Volume Control

The shortcut keys for Supervisor Record Viewer are listed in the following table.
Shortcut Key
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Description

Ctrl+D

Selects the first option in the Day Select section. Use the left and right
arrows to navigate within the section.

Ctrl+F

Selects the first recording in the list if no other recordings are selected.

Ctrl+S

Plays the selected recording and simultaneously saves it as a WAV file
to the selected location.
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Supervisor Work Flow Administrator
Supervisor Work Flow Administrator enables you to configure your desktop to perform
certain actions based on queue statistics for calls waiting and calls in queue for specified
skill groups.
These work flows apply only to you, not to any other supervisors, and are available to you
no matter where you log into Supervisor Desktop. They are tied to your login information.
In general, work flows consist of events, thresholds, and actions.
n

The event that triggers an action is a queue statistics update. Queue statistics are
updated once every 5 seconds.

n

The thresholds the event must meet is one or both of the following:

n

n

The number of calls waiting is below, within, or above specified limits

n

The oldest call in queue is below, within, or above specified limits

The actions triggered by meeting the thresholds can be:
n

Change the color of the skill group name in the tree control and/or add a
message next to it

n

Highlight data in the tabular real time display

n

Display a popup message on your desktop

n

Play a WAV file on your desktop

n

Send an e-mail to selected recipients

For example, you can set up a work flow so that when there are more than 10 calls waiting
in the queue for Skill Group 6500, the skill group name in the Skill Groups tree turns red
and an audible warning sounds every 15 seconds.
Note: Supervisor work flow actions are available at the Premium level, except for
the Tree Control action, which is also available at the Enhanced level.

Setting Up a Work Flow
Follow these steps to set up a supervisor work flow.
To set up a supervisor work flow:
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1. Choose Tools > Supervisor Work Flow Administrator.
2. In the Supervisor Work Flow List dialog box, click Add.
3. In the Add New Work Flow dialog box, enter a name for your new work flow and click
OK.
4. In the Skill Group Selection dialog box, select the skill groups you want your work flow
to apply to from the Available Skill Groups pane and use the arrows to move them to
the Selected Skill Groups pane, and click OK.
Note: A skill group can be part of only one work flow per supervisor.
5. In the Supervisor Work Flow Setup dialog box, set up the parameters for the work
flow.
a. Specify the upper and lower limits for the Call Waiting and/or Current Oldest
threshold. Note that when you select both Calls Waiting and Current Oldest, the
highest threshold crossed takes precedence.
b. Select Above from the Thresholds pane.
c. Click Add. In the resulting Action Type Selection dialog box, select the action you
want to be triggered when the Calls Waiting and/or Current Oldest statistic is
above the upper limit you set, and then click OK. See Work Flow Actions for information on the types of actions available.
d. Repeat steps b–c for the Within and Below thresholds.
6. When you have finished completing the Supervisor Work Flow Setup dialog box, click
OK to enable the work flow.
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Example of Setting Up a Supervisor Work Flow
The following is a step-by-step example of setting up a supervisor work flow. This work
flow:
n

Changes the skill group name color to green and displays “Below” next to it in the
Skill Groups tree control when there are fewer than two calls waiting, or if the current oldest call is less than 1 minute old.

n

Changes the skill group name color to blue and displays “Caution” when there are
2 to 5 calls waiting, or if the current oldest call is between 1 and 5 minutes old.

n

Changes the skill group name color to red and displays “Warning” when there are
more than five calls waiting, or if the current oldest call is more than 5 minutes old.
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To set up the example supervisor work flow:
1. Choose Tools > Supervisor Work Flow Administrator.
2. In the Supervisor Work Flow List dialog box, click Add.
3. In the Add New Work Flow dialog box, enter the name “Customer Management” and
then click OK.
4. In the Skill Group Selection dialog box, select the skill groups you want your work flow
to apply to from the Available Skill Groups pane and use the arrows to move them to
the Selected Skill Gropus pane. Click OK when finished.
5. In the Supervisor Work Flow Setup dialog box, select the Calls Waiting check box and
set the lower limit to 2 and the upper limit to 5.
Select the Current Oldest check box and set the lower limit to 1 minute and the upper
limit to 5 minutes.
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6. Select Below in the Thresholds pane and then click Add under the Actions pane.
7. In the Action Type Selection dialog box, select Tree Control Action and click OK.

8. In the Tree Control Action dialog box, select the Display Text check box and Below
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from the drop-down list.

9. Select the Change Text Color check box, click Set Color, choose green from the color
palette displayed, and then click OK.
10. Repeat steps 6–9 for the Above and Within thresholds. For Above, select “Warning” as
the display text and set the color to red. For Within, select “Caution” as the display text
and set the color to blue. When you are finished, click OK to enable the work flow.
The skill group names will now be color-coded with text displayed.
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Work Flow Actions
There are five work flow actions that can be triggered by threshold rules. These actions
are:
n

Audible Alert Action

n

E-Mail Alert Action

n

Message Box Action

n

Report Action

n

Tree Control Action

Audible Alert Action
The Audible Alert action plays a WAV file on your desktop whenever the threshold rules are
met. By default, the file plays once, but you can also configure it so that it plays repeatedly
at specified intervals.
This action is available at the Premium level.
Note: You can turn off audible alerts that are configured to repeat at intervals by
choosing Actions > Supervisor Work Flow — Audio Off from the menu.
Your computer most likely has system WAV files available that are used to signal standard
Windows events. These files are a good source of sounds.
Note: The WAV file you select must be 50 KB or smaller.
To set up an audible alert action:
1. Click Add New and browse to the location of your selected WAV file.
2. If desired, set up a repeat interval.
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3. Click OK.

E-Mail Alert Action
The E-mail Alert action enables you to send an e-mail to specified people whenever the
threshold rules are not met.
The e-mail messages have predefined subject lines, depending on what threshold rule is
met. They are:

59

n

Skill: <CSQ name>, Number of Calls Waiting is above upper limit

n

Skill: <CSQ name>, Number of Calls Waiting is below lower limit

n

Skill: <CSQ name>, Number of Calls Waiting is within upper and lower limits

n

Skill: <CSQ name>, Oldest Call in Queue is above upper limit

Supervisor Work Flow Administrator
n

Skill: <CSQ name>, Oldest Call in Queue is below lower limit

n

Skill: <CSQ name>, Oldest Call in Queue is within upper and lower limits

The e-mail messages sent can consist of just the Subject line. A message in the body of
the e-mail is optional.
To set up an e-mail alert action:
1. Complete the fields in the E-Mail Alert Action Setup dialog box as follows.
Field

Description

From

Required. Enter your e-mail address.

To

Required. Enter the e-mail addresses of the recipients,
separated by a semicolon.

Mail Server

Required. The SMTP IP address or host name of the email server used to send the e-mail.

BCC

Optional. Enter the e-mail addresses of the recipients you
want copied in on the e-mail message.

2. Click Send to verify that the e-mail alert action is configured correctly. If the test email is successfully sent, “Mail Sent Successfully” appears in the field next to the Send
button. “Error sending mail” appears if there is a problem. If this occurs, check your
entries in the To, BCC, and Mail Server fields for accuracy and test the action again
until it is successful.
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3. Click OK.

Message Box Action
The Message Box action pop ups a message box containing a customized message on
your desktop whenever the threshold rules are met. The message box is closed by clicking
OK.
This action is available at the Premium level.
To set up a message box action:
1. Type your message in the Message Text field.
2. Select the appropriate message icon from the drop-down list.
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3. Click OK.

Report Action
The Report action highlights cells in the Team Skill Statistics real time display when the
data in the cells exceeds the threshold rules. The cells appear in the CSQ and Oldest in
Queue columns.
This action is available at the Premium level.
To set up a report action:
1. Click Set Color and select the color to use for highlighting the cells.
2. Select the Show Team Skill Statistics Report check box if you want Supervisor
Desktop to automatically change its focus to display the Team Skill Statistics real time
display whenever a statistic changes and triggers the Report action.
3. Click OK.
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Tree Control Action
The Tree Control action enables you to select a color to apply to a skill group name and/or
a message to display beside the name in the Skill Groups tree control whenever the
threshold rules are met.
This action is available at the Enhanced and Premium levels.
To set up a tree control action:
1. Select the Display Text check box and text from the drop-down list if you want the
text to be displayed next to the skill group name.
2. Select the Change Text Color check box and click Set Color if you want to choose the
color for the text and the skill group name.
3. Click OK.
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Supervising Agents
Monitoring an Agent
The voice monitor button enables you to silently listen in on an agent’s phone
conversations.
Voice monitoring is available whenever an agent is logged in to Agent Desktop (uses either
desktop monitoring or server monitoring) or IP Phone Agent (uses server monitoring only).
It is not available when:
n

You are a participant in a phone call (you cannot monitor yourself)

n

You use the Barge-In or Intercept function

n

In a multi-line situation, the agent is talking on the non-ACD second line

Note: The administrator can restrict you from monitoring an agent’s non-ACD
phone conversations.
The Voice Monitor Volume button allows you to control the volume when monitoring an
agent’s phone conversation. The system remembers your last volume setting and uses it
the next time you log in.
When monitoring a call, keep in mind the following considerations:
n

When you select a specific call from the Team View pane to monitor, all voice activity to and from that particular agent is monitored. The monitoring is not limited to
the call you selected. For instance, if the agent puts the selected call on hold and
switches to another call, both calls will be monitored.

n

If notification is off, agents have no way of knowing if you are monitoring their calls.

Monitoring sessions are on a per agent basis, and only one monitoring session can be in
progress at one time. When you select an agent from the Team View pane to monitor, you
can hear all voice activity to and from that agent. If configured by your administrator, the
monitoring session is not limited to one call. For instance, if the agent puts an active call on
hold and switches to another call, you will monitor both calls.
You can record while monitoring an agent.
To start monitoring an agent:
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1. Choose an agent in the Agents tree.
2. Click the Start Voice Monitor button, or choose Intervention > Start Voice Monitor.
To stop monitoring an agent:
n

Click the Stop Voice Monitor button, or choose Intervention > Stop Voice Monitor.

Pushing a Web Page to an Agent
You can coach an agent by pushing a web page to that agent’s Agent Desktop integrated
browser.
To push a web page to an agent:
1. From the Agents tree, select an agent.
2. Choose Intervention > Coach by Pushing a Page. The Push URL to Agents dialog box
appears.

3. Enter the URL of the web page you want the agent to see, and then click Push to send
the web page to the agent. The web page you pushed to the agent is displayed in the
first tab of the agent’s integrated browser. This tab is reserved for pushed web pages.
Note: There are no restrictions on what you can enter as a URL (for example,
you are not required to prefix the URL with “http://”) as long as the URL can
be resolved by a browser. Some sites require that “http” or “https” be part of
the URL.

Note: If the integrated browser is not enabled for the selected agent, this
operation will fail and no error message will appear.
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Barging in on a Call
The Barge-In feature enables you to join an agent’s ACD (and if enabled by the
administrator, non-ACD) phone conversation. When you click the Barge-In button, you
are automatically added to the phone call. It is a forced conference.
Note: To barge in on a call, you must first be logged into Agent Desktop.
If notification is enabled, the agent sees a message that you are attempting to join the call,
then sees a message that you have successfully joined it.
When you use the Barge-In feature, voice monitoring is disabled. You can, however,
record calls.
You cannot barge in if any of the following conditions are true:
n

The agent is on hold

n

The agent is on two calls

n

The agent is in a conference call

n

You are already on another call

To barge in on a call:
1. Select an agent call in the team view pane.
2. Click Barge-In or choose Intervention > Barge-In. You are added to the call.
At any time during the conference call, you can click Intercept to disconnect the agent
whose call is selected from the conference call and continue talking with the remaining
parties yourself.
To drop the barged-in call:
n

In Agent Desktop, select the conference call in the contact appearance pane and
then click Drop.

Intercepting a Call
The Intercept feature enables you to intercept an agent’s ACD (and if enabled by the
administrator, non-ACD) phone conversation while disconnecting the agent from that
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phone call. It is a forced transfer.
Note: To intercept a call, you must first be logged into Agent Desktop.

Note: You can intercept a call only once. For example, if you intercept a call, drop
out of the conversation, and then attempt to intercept the same call again, you will
not be able to do so.
If notification is enabled, the agent sees a message that you are attempting to intercept
the phone call, then sees a further message when the interception is successful.
When you use the Intercept feature, voice monitoring is disabled. You can, however,
record calls.
You cannot intercept if any of the following conditions are true:
n

The agent is on hold

n

The agent is on two calls

n

You are already on another call

To intercept a phone call:
1. Select an agent call in the team view pane.
2. Click Intercept or choose Intervention > Intercept. The call is transferred to you.
If you are intercepting a conference call you are on, the agent call you selected in the
team view pane is dropped from the conference call, and all other participants in the
conference call remain connected.
To drop the intercepted call:
n

In Agent Desktop, select the intercepted call in the contact appearance pane and
then click Drop.

Recording a Call
You can use Supervisor Desktop to record, save, and play back ACD calls handled by
agents on your team. If enabled by the administrator, you can also record an agent’s nonACD phone call.
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Recordings are made on a per call basis, and multiple recordings can be in progress at the
same time. Recordings can be made on all lines for an agent, including non-ACD lines (if
enabled by your administrator). For instance, if an agent puts an active call on hold and
starts another call, you can record both calls, if the administrator configuration allows it.
You use the Supervisor Record Viewer to review recorded calls.
You can use the Barge-in, Intercept, and Voice Monitor features while recording.
When recording a call, keep in mind the following considerations:
n

The recording feature is not intended to record every call. It is an on-demand solution only.

n

When you select a call from the Team View pane to record, only the voice activity
for that particular call is recorded. The recording is limited to the call you selected.
In order to record all voice activity from an agent across all lines, each call must be
individually selected for recording. For instance, if the agent puts the selected call
on hold and switches to another call, you must select the other call and press
Record in order to record both calls.

n

Your administrator must enable recording of non-ACD calls.

n

The recording will end when the selected call terminates, or when you manually
stop recording, whichever comes first.

n

Agents can be configured so that they can start and stop recording calls. However,
an agent cannot stop a recording started by a supervisor. If an agent attempts to
do so, their Agent Desktop or IP Phone Agent interface indicates the recording is
stopped. However, the recording is not stopped, and Supervisor Desktop displays
an icon indicating that recording is proceeding.

n

You can stop a recording initiated by an agent.

n

If notification is off, agents have no way of knowing if you are recording their calls.
If an agent attempts to start recording a call that you are already recording, the
agent will see a recording icon on the call, although the agent is not in control of the
recording.

n

When you or an agent record a call, a recording license is used. The license is
released when the recording stops. If all recording licenses are in use when you
attempt to start a recording, the recording will not start.
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Note: When you receive a message saying the recording has failed due to the
server running out of disk space, you free the space for new recordings by
deleting the existing recordings in the Supervisor Record Viewer.
To record a call:
1. Choose the call you want to record from the Agents tree.
2. Click the Start Record button, or choose Intervention > Call/Agent Start Recording.
3. When you are finished, click the Stop Record button, or choose Intervention >
Call/Agent Stop Recording. The call is archived to the Recording service database,
where it is automatically saved for seven days.
Note: If you want to save the recording for a longer period, you can do so for
up to 30 days, after which it is deleted. For more information on playing and
saving recordings, see Supervisor Record Viewer.

Changing an Agent’s ACD State
You can use Supervisor Desktop to change the ACD state of an agent on your team,
including logging an agent out.
Note: If you log a CAD agent out, that agent will continue to appear in the agents
tree and will be able to chat and receive team messages. If you log out an IPPA
agent, that agent disappears from the agents tree.
To change an agent’s agent state:
1. From the Agents tree, select the agent whose state you want to change.
2. On the toolbar, click the appropriate agent state button.
Note: There is a delay of about 2 to 3 seconds before the command to change agent
state takes effect. To ensure you set the desired agent state, allow enough time
between clicking Agent State buttons for the command to take effect.
Note: If an agent state change fails, you will not see any failure message. You will know
that an agent state change succeeds if the icon next to the agent’s name in the team
view pane changes to the current agent state icon.
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Monitoring Agent-Deleted E-Mail
Agents are able to delete e-mail that is delivered to their inbox. Some reasons for deleting
an e-mail are:
n

The e-mail is spam

n

The e-mail is abusive

The deleted e-mail is not actually deleted. It is transferred to an e-mail address set up by
the administrator in Cisco Desktop Administrator.
You can view a deleted e-mail either of two ways:
n

In the Agent E-Mail Viewer from its listing in the E-Mail CSQ - Resolved real time
display

n

Using a third party e-mail client (for example, Microsoft Outlook)

The Agent E-Mail Viewer only allows you to view the agent-deleted e-mail. If you want to
permanently delete the e-mail, or re-queue it to be handled by another agent, you must
use a third party e-mail client.
Consult with your administrator for the procedure for accessing agent-deleted e-mail.

Reviewing Agent E-Mail
The E-Mail Review CSQ is used to review agents’ responses to customer e-mail. By
incorporating a Review CSQ into the e-mail handling process, a contact center can ensure
that any response undergoes a review before delivering it to the customer. If an agent’s
work flow group and e-mail CSQ are configured for review, then all of the agent’s
responses are transferred to the E-Mail Review CSQ.
You must use Agent Desktop to participate in the review process. See the Cisco Agent
Desktop User Guide for more information about reviewing e-mails.

Sending a Team Message
You can send a team message to all agents on a team, whether or not the agent is logged
into the ACD. As long as Agent Desktop is open, an agent can view a team message.
Note: You cannot send team messages to IP Phone agents.
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The Team Messages dialog box stores the last 10 team messages you broadcast. You can
select any one of these messages to broadcast again. If you send more than 10 team
messages, the oldest one drops off the stored list. You cannot designate any particular
team message for permanent storage.

Note: By default, the team message scrolls across Agent Desktop’s team
message pane. Individual agents can set their preference in Agent Desktop to
view team messages as stationary. A stationary team message is more
compatible with screen readers, which are often used by vision-impaired agents.
The Current Message pane displays the message that is currently being sent to your team.
To send a team message to all agents on a team:
1. From the team selection list, choose the team to which you want to send the message,
and then click View > Team Messages or click the Team Messages button.
2. Type your message in the text box. The team message can be up to 255 characters
long. You must type a message before choosing an expiration time.
3. In the Expires at field, choose a specific time for the message to expire. By default, the
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message runs for 30 minutes.
If you set a time earlier than the current time, the message will run until that time the
next day. For example, if it is 10:15 AM and you set the expiration time to be 10:00
AM, the message will run until 10:00 AM tomorrow.
4. Click Start or press Enter.
The team message is sent to the team for the length of time you chose. The text of the
message you sent is logged in the current team performance message field.
To cancel a team message:
n

In the Team Message dialog box, click Stop.
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Chat
Chat enables you to send instant messages to agents and supervisors on your teams. In
addition, if your configuration includes Cisco Unified Presence, you can send instant
messages to non-agents (called subject matter experts, or SMEs) who are using Cisco
Unified Personal Communicator.
Some Chat features include:
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n

You can send the same chat message to multiple recipients. The sending chat window closes after the message is sent, and recipient’s replies, if any, appear in separate chat windows, one for each person.

n

You can participate in multiple concurrent chat sessions.

n

The title bar of the Chat window displays the name of the person with whom you
are chatting.

n

If you flag a chat message as high priority, the Chat window will pop up on the
other person’s screen so that the message is noticed immediately.

n

If the priority of a chat message is normal (the default), the Chat window will remain
in its current state (open or minimized) and the corresponding icon will flash on
your Windows task bar.

n

A log of the chat messages sent between you and your chat partner (chat history)
is available as long as the Chat window is open. After you close the Chat window,
the log is lost.

n

Chat history is in chronological order, with the oldest messages at the top of the
log pane.

n

You can chat with agents who are logged out of the ACD as long as they still have
Agent Desktop open.

n

You can chat with subject matter experts (SMEs) (non-agents).

n

An agent’s ACD state is indicated by both an icon to the left of the agent name and
by text to the right of the agent name.

n

If you are logged into Unified Presence, an SME’s Unified Presence status is
indicated both by an icon to the left of the SME name and by text to the right of the
SME name.

Chat

Chat Contacts
Your contacts are organized in groupings called drawers in the Chat Selection window.
Some drawers, such as the Teammates, Supervisors, and Conference drawers, are
default drawers. Any other drawers that appear are customized by your administrator and
appear only if you are logged into Unified Presence.
The example of a Contact Selection window below shows the default Teammates and
Supervisors drawers, as well as two customizable drawers, TAC and Engineering.

n

The Agents drawer lists all the agents on the team selected in Supervisor Desktop.
The agents’ agent state is indicated both by an icon to the left of the agent name
and by text to the right of the agent name. The agent state is updated whenever it
changes. Agents do not have to be currently logged into Agent Desktop to be
listed here, but they must have Agent Desktop open and they must have logged in
at least once.
Note: You cannot chat with IP Phone agents.

n

The Supervisors drawer lists all supervisors on your team. Their status is always
listed as Available. Supervisors must be logged in to be listed here.

n

The Conference drawer appears when you are on a conference call with other
agents. SMEs, if they are on the conference call, are not listed here.
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n

The Personal Contacts drawer appears if you have this drawer set up in Unified Personal Communicator. The contacts in this drawer are administered in Unified Personal Communicator.

n

Other drawers list the SMEs associated with the work flow groups to which your
agents belong. The SMEs’ Unified Presence status is indicated both by an icon to
the left of the SME name and by text to the right of the SME name. The Unified
Presence status is updated whenever an SME status changes.

The Chat Selection window also provides menu access to the following call handling
functions:
n

Making a call

n

Transferring a call

n

Initiating a conference call

Chat Shortcut Keys
The following table lists the shortcut keys in the Chat window.
Shortcut Key

Description

Alt+L

Starts a chat session with the person highlighted in the Chat Selection
window. If you are already chatting with the highlighted person, Alt+L
will bring that chat window to the foreground.

Alt+C

Opens the dial pad so you can call the person highlighted in the Chat
Selection window. The Name: Number field is auto-populated with the
selected person's extension.

Ctrl+Shift+H

Selects the chat log pane.

Sending a Chat Message
To send a chat message:
1. Click Chat on the toolbar to open the Chat Selection window.
2. To chat with one person, double-click that person’s name. To chat with several
people, Ctrl+click to select their names and press Enter or choose Actions > Chat. A
Chat window opens and a session begins with the people you selected.
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3. Type your message in the text entry pane and click Send or press Enter. Your message
is sent to your chat partner and logged in the chat history pane.
Replies from recipients of a group message appear in individual chat session windows.
They cannot reply to the group, they can reply only to you.
Note: If you want your message to be noticed immediately by popping on
your chat partner’s desktop, select the High priority check box.

Note: If you log out during a chat, your copy of the chat log is lost, the current
Chat window closes, and a new Chat window opens so you can continue
communicating. The entire chat log is still present in the other party’s Chat
window.
To end a chat session:
n

Choose File > Close or click Close in the upper right corner of the Chat window.

Predefined High Priority Chat Messages
Agents can have a task button in Agent Desktop configured to send a predefined highpriority chat message to their supervisors. This predefined message (for example, “Please
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barge in on my call”) is set up by the administrator. It behaves just like a regular chat
message that is flagged as high priority—it pops up on your screen on top of all other
windows for your immediate attention.
You can reply to a predefined high-priority chat message from a CAD agent.

Calling Someone in the Chat List
You can make a call, transfer a call, or conference a call to anyone listed in your Chat
Selection window using the call control actions.
n

To call someone, you must be logged into Agent Desktop and be in an agent state
that allows you to make a call.

n

You cannot call someone listed in your Personal Contacts drawer.

n

You do not have to be chatting with an agent or SME in order to call them.

The call control menu items are typically disabled for SMEs. In order to make a call,
transfer a call, or conference a call to an SME in your chat list, the SME must be configured
as an External Contact by your administrator. If an SME name does not have a phone
number associated with it, the call control menu items are disabled.
To call someone in your chat list:
1. In the Chat Selection window, do one of the following:
n

If you are chatting with the person you want to call, choose Actions > Call,
Transfer, or Conference.

n

If you are not chatting with the person you want to call, select the person’s
name and choose Actions > Call, Transfer, or Conference. You can also rightclick the person’s name and choose the desired call action from the resulting
popup menu.

The dial pad appears with the person’s phone number autofilled in the Name: Number
field.
2. Click Dial.
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Cisco Unified CCX Web Chat
Unified CCX Web Chat is a web-based application that allows agents to chat with
customers, and supervisors to view agent and team chat reports. It is configured for use
with CAD in the Cisco Unified CCX Administration application by the administrator, and is
available only at the Premium feature level.
If configured for use with CAD, Unified CCX Web Chat appears in the first tab of the Agent
Desktop integrated browser, and in the first tab after the real time displays in the
Supervisor Desktop integrated browser.
Supervisors have the option of enabling or disabling Unified CCX Web Chat’s appearance
in the Supervisor Desktop integrated browser. See Preferences for more information.
For information on how to use Unified CCX Web Chat, see the Cisco Unified CCX Web
Chat Agent and Supervisor Desktop User Guide, available at:
http://www.cisco.com/en/us/support/customer-collaboration/unified-contact-centerexpress/products-user-guide-list.html

Unified CCX Web Chat Reports
Once you log into Unified CCX Web Chat, you have access to reports on the chat activity
of your agents and teams. These reports are:
n

Agent Summary Report

n

CSQ Detail Report

n

CSQ Summary Report
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Service Autorecovery
The service autorecovery feature allows Supervisor Desktop to automatically recover its
connection to the Cisco services in the event of a service restart or a network outage.
When Supervisor Desktop detects that it is unable to communicate with a service
(generally within three minutes of the service failure), the status bar displays “Partial
Service” or “No Service” to indicate some or all of the services have failed.
When Supervisor Desktop detects that the service is again available (usually within one
minute of service recovery), the status bar displays “In Service” to indicate that the
services have recovered.
Note: In some situations, you will not recover your connection to Cisco Unified
Presence and you must log back into Unified Presence manually.
To learn more about what is affected by the service failure, double-click the status
message on the status bar. Supervisor Desktop displays a popup window that lists
features and indicates if that feature is available or not due to the service outage.

Phone Network Failure
In the event that an agent’s phone loses its connection to the network, the agent is
automatically moved to the Not Ready agent state, and will see a popup window
displaying a message that the phone is out of service.
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The supervisor will see the change of agent state in the Agent ACD State Log report, along
with the “Device out of service” reason code (code 32759).
The agent must drop any call he or she is on in order for the phone to reconnect to the
network. If the agent continues on a call, CAD will not be able to show the call’s actual
length because it shows as “terminated” in the system.
When the phone comes back into service, the agent will see the popup window display a
message that the phone is in service. The agent can then change the agent state back to
Ready and resume taking calls.
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