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Introduction
Cisco Supervisor Desktop is a robust computer telephony integration solution for single-site and multi-site
IP-based contact centers that is easy to deploy, configure, and manage. It provides supervisors with
powerful tools to increase productivity and improve customer satisfaction.

Supervisor Desktop’s features allow you to view real time statistics, monitor and coach agents, barge-in,
intercept, and record active agent calls when necessary, enabling effective management of agent
resources.

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional
information, see the monthlyWhat’s New in Cisco Product Documentation, which also lists all new and
revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to theWhat’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a
free service and Cisco currently supports RSS version 2.0.

Documentation Feedback

You can provide comments about this document by sending e-mail to the following address:

ccbu_docfeedback@cisco.com

We appreciate your comments.

Supervisor Desktop Feature Levels

There are three feature levels in Supervisor Desktop: Standard, Enhanced, and Premium.

The following table outlines the features available at each feature level. All features not listed here are
present in both versions.

Feature Standard Enhanced Premium

Barge-in x x x

Cisco Mobile Agent support x x x
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Feature Standard Enhanced Premium

Cisco Unified Presence Server integration x x x

Integrated browser x x x

Intercept x x x

Real time display (charts) x

Real time displays (text) x x x

Recording x x

Silent monitoring x x x

Skill statistics x x x

Supervisor work flows—all actions except threshold
alerts for tree control actions

x

Supervisor work flows—threshold alerts for tree control
actions

x x

Teammessages x x x

Web page push to agents x
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Logging In

Note: If you want to use all of the functionality of Supervisor Desktop, you must first log into Agent
Desktop. For more information, see the Cisco Agent Desktop User Guide.

To log in to Supervisor Desktop:
1. Start Supervisor Desktop. The Supervisor Login dialog box appears.

2. Enter your Supervisor Desktop login name or ID and password in the appropriate fields, and then click
OK or press Enter. Supervisor Desktop starts, but does not show any data, and the status bar displays
“No Service”.

3. From the Team drop-down list, select a team. Supervisor Desktop displays the data for the selected
team.

Login Notes
n The Supervisor login window prompts for either your name or your ID, depending on the method that

your administrator configured.

n The first time you log in to Supervisor Desktop, consider the following:

n The password is empty by default — all you need to enter is your Login Name/ID. After you have
logged in, create a password using the Change Password function.

n The Login Name/ID field is empty. The next time you log in, the Login Name/ID field is
automatically filled with the information you entered before. If you share a computer with another
supervisor, verify that this field has your information and not the other supervisor’s information.

n It might take some time for Supervisor Desktop to start because default report data must be
generated.

n The administrator can configure Supervisor Desktop to use your Agent Desktop password. In that
case, you cannot change your password in Supervisor Desktop. Your password is administered in
Unified ICM and can only be changed by your administrator.

Changing Your Password

Do not share your password with others. If someone else learns your password, change the password
using the Change Password option.

Note: The Change Password option is not enabled if your administrator has configured Supervisor
Desktop to use your Agent Desktop password. The Agent Desktop password can only be changed
in Unified ICM.

To change your password:
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1. From the menu bar, choose Tools > Change Password. The Change Password dialog box appears.

2. Type your old password, your new password, and your new password again. If your old password was
empty (blank), leave the Old pssword field empty.

Note: Passwords are a maximum of 32 alphanumeric characters.

3. Click OK. Your password is changed.

Access Through a VPN

Supervisor Desktop is able to connect to the CAD servers through a virtual private network (VPN). This
allows a supervisor to work remotely and still have the benefits of the full functionality of Supervisor
Desktop.

Using a VPN is recommended in order to provide a more secure connection.

When a desktop is using network address translation (NAT) due to a firewall or router, then VPN software
must be used on the desktop to ensure full bi-directional network connectivity between the contact center
servers and the desktop. Failure to use VPN software will result in connectivity issues and a loss in
functionality such as silent monitoring, recording, and incoming chat message and teammessage failures.

Cisco AnyConnect Secure Mobility Client is verified to work correctly with Supervisor Desktop.

VPN solutions from other vendors might result in feature loss. Because they have not been formally
verified, they are not supported.

Note: After installing Cisco AnyConnect Secure Mobility Client, you must restart your computer. If
you do not restart, monitoring and recording will not work properly.

VPNTunneling

There are two types of VPN tunneling mechanism, full tunneling and split tunneling, both of which are
supported for connection between Supervisor Desktop and the CAD services.

VPN Full Tunneling
VPN full tunneling virtually replaces the network connection with the local area network defined by the
VPN. If VPN full tunneling is used to connect to CAD servers, the VPN connection must be established
before starting Supervisor Desktop. If the VPN connection is lost during a session, you must close
Supervisor Desktop, reestablish the VPN connection, and then restart Supervisor Desktop.
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VPN Split Tunneling
VPN split tunneling allows you to access a public network and a local area network simultaneously, using
the same physical network connection.

There are two types of VPN split tunneling scenarios.

n Scenario 1: The CAD servers are on the public network and a third-party application is used through
the VPN. In this scenario, you must launch and log into Supervisor Desktop before establishing the
VPN connection. If the VPN connection is lost during a session, you must restart Supervisor Desktop
and then reestablish the VPN connection.

n Scenario 2: The CAD servers are on the VPN and a third-party application is used through the public
network. In this scenario, you must establish the VPN connection before launching Supervisor
Desktop. If the VPN Connection is lost during a session, you must close Supervisor Desktop, rees-
tablish the VPN connection, and then restart Supervisor Desktop.

If Supervisor Desktop can log into all services except the Chat service, it must be restarted after the Chat
service comes back online.
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Automated Updates
CAD enables your administrator to update all instances of the CAD desktop applications automatically to a
newer version. It also ensures that the correct version of Java Runtime Environment (JRE) is installed on
your computer.

CAD Desktop Applications

Every time you launch Supervisor Desktop, the software checks to see if there is an updated version
available, or if there was a system configuration change that requires a Windows registry change. If either
of these conditions exists, the software automatically runs the update process.

When an update is available, you will see a dialog box notifying you that your copy of Supervisor Desktop
will be updated. Click OK to proceed with the update.

A progress bar is displayed to show you the status of the update process.

When the update is finished, you will see a final dialog box that tells you that the update is complete, and
which applications were updated. If you have Cisco Agent Desktop and Cisco Desktop Administrator on
your PC, they will also have been updated.

Note: Because Agent Desktop is automatically installed when Supervisor Desktop is installed,
only Supervisor Desktop will be listed as having been updated in the final dialog box. Agent
Desktop will be listed only if Supervisor Desktop is not present on your PC.

When you click OK to close the dialog box, any CAD desktop application running on your desktop restarts
automatically.

Note: To ensure that automated updates function correctly, you must configure Internet Explorer
so that it checks for newer versions of stored pages. To configure this setting, launch Internet
Explorer and choose Tools > Internet Options. In the Browsing history section on the General tab,
click Settings. Select the option labeled Every time I visit the web page.

Java Runtime Environment

Every time Supervisor Desktop is launched, it checks to see if the correct version of Java Runtime
Environment (JRE) is installed. If the correct version is not detected, you will be notified, and Supervisor
Desktop will download and install the correct JRE.
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The Supervisor Desktop Window
The Supervisor Desktop window is divided into five areas:

n The Skill Groups tree, which lists all of the CSQs associated with the team you choose from the team
selection list

n The agents tree, which lists all of the agents and supervisors on the team

n Tabular/graphical real time displays of CSQ information

n Tabular/graphical real time displays of agent and team information

n Integrated browser (if enabled)

The Supervisor Desktop interface is highly configurable. By default, the browser is not enabled and the
panes are not dockable. However, you can add or remove real time displays, enable the integrated
browser, and enable all panes to act as dockable windows (so you can move them and resize them
independently). You can also change the size of the toolbar icons from the default 16 × 16 pixels to 32 × 32
pixels.

The specific panes that are displayed depends on the nodes that you select in the Skill Groups and Agents
tree. If you choose to enable the integrated browser, the real time displays and the browser appear on tabs
in the right pane.

The figure below shows Supervisor Desktop with the integrated browser enabled and the default real time
displays (Team Skill Statistics, TeamAgent Statistics, and TeamAgent State).
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Real time display panes are identified as containing information related to skill groups/precision queues or
agents by the text in their title bars, as shown in the following figure.

When Supervisor Desktop is in default layout (movable windows are disabled), Skill Groups real time
displays occupy approximately the top half of the right pane, and the Agents real time displays occupy
approximately the lower half of the right pane. The tree panes and real time display panes can all be
resized by dragging the horizontal splitters up and down and the vertical splitters left and right.

If you choose to enable movable windows (see Preferences), all of the real time display panes can be
resized and moved anywhere on your desktop. However, each type of display can only dock to another
display of its own type. In other words, Skill Group displays dock to other Skill Group displays and Agent
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displays dock to other Agent displays. For example, you cannot separate one Agent display from another
Agent display, although they can be resized in relationship to each other, as shown in the following figure.

You can also drag the vertical splitter between the trees panes and the display panes left or right, and the
horizontal splitter between the two trees panes up and down.

If you choose to enable the integrated browser, the real time displays and the browser appear on tabs in
the area to the right of the Skill Groups and Agents navigation trees.

Preferences

The Preferences dialog box controls what information is displayed in the display panes and how those
panes behave. The following table summarizes what you can configure using Preferences.

Tree Control Node Available Displays Configure
Columns?

Configure
Graphs?

Configure
Refresh?

Skill Groups Team Skill Statistics Yes Yes Yes

Skill Skill Summary Statistics Yes No Yes

Skill Agent State Yes Yes No

Team TeamAgent Statistics Yes Yes Yes

TeamAgent State Yes Yes Yes

Agent Agent vs. Team Statistics Yes Yes Yes
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Tree Control Node Available Displays Configure
Columns?

Configure
Graphs?

Configure
Refresh?

Logs Agent Call Log Yes No No

Agent ACD State Log Yes No No

Calls Agent Active Call Yes No No

Enterprise Data Yes No No

Call History Yes No No

Browser Supervisor browser tabs — — —

To set your preferences:

1. Choose View > Preferences. The Preferences window appears.

2. In the left pane, select a node. The right pane displays that node’s settings for each available real time
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display.

n Click Configure… next to Columns and select the columns to appear in the real time display. Use
the up and down arrows to set the order in which they should appear.

n Click Configure … next to Graphical Displays and select the type of chart you want to display. You
can select only one type of chart for each real time display.

n Click Refresh rate in seconds and adjust the real time display’s refresh rate. The refresh rate
ranges from every 5 to 60 seconds, with the default set to 15 seconds. For Skill Groups, you can
configure the data refresh to be done manually by setting the refresh rate to zero (0).

3. In the left pane, select the Browser node. The right pane displays browser settings.

n In the Browser Home Page field, enter the URL for your home page. The default is www.-
cisco.com.

n In the Number of Browser Tabs field, select the number of browser tabs you want, from 1 to 10.
You can specify what web page appears in the tab by selecting the tab from the Browser Tab field
and entering the URL of the desired web page. If you do not set a URL the tab will display the
default, www.cisco.com.

4. At the bottom of the Preferences window are options that allow you to customize Supervisor Desktop.
Select or clear the check box for each option to turn it on or off. The options are:

n Enable movable windows—lets you rearrange the real time display panes.

n Enable Integrated Browser—gives you access to the integrated browser.

n Change Report Font Size to <size>—sets the font size in real time displays from 15 to 72 points.

n Enable Large Toolbar Icons—changes the size of toolbar icons from 16 × 16 pixels to 32 × 32
pixels.

n Enable Cisco Unified Presence—gives you access to Unified Presence users in the Chat window.
You must restart Supervisor Desktop (and Agent Desktop, if running) for this option to take effect.

n Enable Third-Party Recording of CAD Agents—enables recording to be done through CTI OS.
Selecting this check box disables the Start Recording and Stop Recording buttons on the toolbar.

5. When you are finished configuring Supervisor Desktop, click OK.

Restoring the InterfaceDefault Layout

To restore Supervisor Desktop to its default layout, open the Preferences window (choose View >
Preferences) and click Restore Default Layout.

Clicking this button makes the following changes:

n In the Real Time Displays pane, moves displays to their default positions

n Disables the integrated browser

n Disables movable windows

n Disables any graphical real time displays you selected previously
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n Resets the toolbar buttons to the default size

n Disables Cisco Unified Presence

n Disables third-party recording of CAD agents

Clicking this button does not make any of the following changes:

n Columns are not resized to the default widths

n Real time display columns that you delected previously are not restored

n Report font size is not changed back to the default (15 points)

You must manually resize the columns yourself and reset the other two elements to their default settings in
the Preferences window.

Agents Tree

The Agents tree displays all agents and supervisors on the selected teamwho are currently logged in, and
any calls (ACD and non-ACD) they are on.

n The icon next to the agent’s name indicates the agent’s current agent state.

n If an agent device is multi-line–enabled, an asterisk next to an inbound or outbound call indicates that
the call is on an ACD line.

Formatting Agent Names in theAgents Tree

The Preferences dialog box enables you to control how agent names are displayed in the Agents tree.

An agent can be identified by any or all of the following:

n Name

n Extension

n Application used by the agent (CAD or Cisco IP Phone Agent [IPPA])

n Type of agent (mobile)

At least one of these must be selected to identify an agent in the Agents tree. If all options are selected,
the information in the agents tree appears as follows:

Jane Smith x1500 CAD

John Doe x1000 CAD 6125551234 (Mobile)

In this example:

n Jane Smith is a CAD agent on extension 1500.
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n John Doe is a mobile agent. The number displayed as the extension is the CTI port that John connects
to when logging in. The 10-digit phone number is the number of the phone that the agent is using to
handle calls.

To format agent names in the Agents tree:
1. Choose View > Preferences and then select the Agents node.

2. In the Format node text grid, check the elements you want to use to identify an agent. You must select
at least one element. A sample of what the name will look like appears on the Sample line.

3. Click OK.

Accessibility

Supervisor Desktop has a number of features that improve accessibility for vision-impaired users.

n Uses Windows settings for screen resolution, color/contrast, and font settings

Note: Enable high contrast before launching Supervisor Desktop to ensure that all tables
match the high contrast settings.

n Scrolling or non-scrolling teammessages

n Shortcut keys and tool tips that are compatible with screen readers

n Toolbar buttons available in small (16 × 16) and large (32 × 32) sizes

n Navigation through each pane, browser, and all the elements of the main window using the Tab key

n Support for Job Access With Speech (JAWS) 11 screen reader software

Toolbar and Shortcut Keys

The following tables list the toolbar buttons and shortcut keys that you can use in Supervisor Desktop.

Button Name Shortcut Description

Logout Ctrl+L Logs the selected agent out of the
ACD.

Ready Ctrl+E Changes the seected agent’s state to
Ready.

Not Ready Ctrl+N Changes the selected agent’s state to
Not Ready.

Agent State Buttons
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Button Name Shortcut Description

Work Ready Ctrl+D Changes the selected agent’s state to
Work Ready.

Work Not Ready Ctrl+Y Changes the selected agent’s state to
Work Not Ready.

Agent State Buttons (cont'd)

Button Name Shortcut Description

Barge In Ctrl+B Enables you to join an agent’s phone
conversation.

Intercept Ctrl+I Enables you to intercept a call while
disconnecting the agent from the call.

Call Handling Buttons

Button Name Shortcut Description

Chat Ctrl+J Opens the Chat Selection window.

TeamMessage Ctrl+X Opens the TeamMessage window.

Refresh Ctrl+F Refreshes the information in the Skill
Groups tree and the TeamAgent State
Display data view pane that has
changed since the last sync.

— Coach by Push-
ing a Page

Ctrl+U Opens the Push URL to Agent window.

Team Communication Buttons

Button Name Shortcut Description

Start Record Ctrl+R (Enhanced/Premium only) Starts
recording the selected call.

Stop Record Ctrl+S (Enhanced/Premium only) Stops
recording the selected call.

Recording Buttons
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Button Name Shortcut Description

Start Voice Mon-
itor

Ctrl+A Starts monitoring the selected agent.

Stop Voice Mon-
itor

Ctrl+P Stops monitoring the selected agent.

Voice Monitor
Volume

Ctrl+V Opens a volume slider control.

Voice Monitoring Buttons

Shortcut Keys Description

Ctrl+Shift+S Selects the Skill Groups node in the Skill Groups tree.

Ctrl+Shift+A Selects the Agents node in the Agents tree.

Ctrl+Shift+B Shifts focus to the browser pane.

Ctrl+Shift+R Shifts focus to the real time displays.

Ctrl+Shift+T Selects the Team node in the Agents tree.

Ctrl+H Selects the Team Selection drop-down list.

Ctrl+T Shifts focus to what was previously selected in the Agents tree.

Ctrl+Shift+H Opens the Service Status window.

Accessibility Shortcut Keys

Once you have set focus to the Skill Groups tree, the Agents tree, or the team node in the agents tree, you
can use the tab key to navigate to the real time display panes. Once your focus is in a real time display
pane, you can use the arrow keys to navigate around the display grid.

Note: The tab key will move you among the real time display panes, but the order in which you
access themwill not necessarily be in sync with the physical arrangement of the display panes
on your desktop.

Integrated Browser Pane

The integrated browser pane allows you to view internet and intranet web pages to help you assist agents
and customers. The integrated browser has from 1 to 10 tabs, each of which can display a different web
page. You can configure each tab to display a specific website.

For more information about this pane, see Integrated Browser.
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Status Bar

The status bar displays current information about Supervisor Desktop.

From left to right, the status bar displays the following information:

n User name

n User ID or name

n Current status of Supervisor Desktop features

n Current system time in 24-hour format

In the event of a service failure, the Current Status section changes from “In Service” to “Partial Service”
or “No Service.” To learn which features are affected by the service outage, double-click the Current
Status section of the status bar to view a popup window that displays active or inactive features.
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Integrated Browser
The integrated browser enables you to view intranet and internet web pages fromwithin Supervisor
Desktop. When enabled, the browser appears as one or more tabs in the real time display pane, with up to
20 characters of the name of the current web page displayed on the tab. The real time displays appear on
another tab in that pane (the default position is in the first tab). The integrated browser can display up to
10 tabs, each containing a different web page. The Address drop-down list contains the URLs of the last
25 websites visited for quick access to frequently visited websites.

Note: You must have Internet Explorer installed on your PC for the integrated browser to function.

Note: The integrated browser supports only one web session at a time for web applications that
use cookies for session management. For example, you cannot log into a web application that
uses cookies in one tab as User A and then log into the same web application in another tab as
User B. However, multiple web sessions are supported for web applications that use URL-based
session management.

Note: Reordering of integrated browser tabs by dragging is not supported.

By default, the browser is not enabled. See Preferences for instructions on enabling the browser and
configuring a home page.

Toolbar Buttons and Shortcut Keys

The integrated browser toolbar contains basic browser buttons that allow you to navigate among the web
pages you view, refresh a current page, and return to your home page.

The integrated browser toolbar buttons and shortcut keys are listed in the following table.

Button Name Shortcut Description

Back Alt+left arrow Returns you to the last page you
viewed.

Forward Alt+right arrow Takes you to the page you viewed
before clicking the Back button.

Stop Esc Stops the browser from loading a web
page.

Refresh F5 Refreshes the current web page.

Home Alt+Home Returns you to your predefined home
page.
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Button Name Shortcut Description

— Address Alt+D Selects the Address field
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Real Time Displays
The real time displays contain the information you need to manage your teams and agents. Real time
displays include the following:

n Team Skill Statistics

n Skill Summary Statistics

n Skill Agent State

n TeamAgent Statistics

n TeamAgent State

n Agent vs. Team Statistics

n Agent Call Log

n Agent ACD State Log

n Enterprise Data

n Call History

There are two types of displays: tabular and graphical.

n Tabular displays present skill group/precision queue, team, and agent information in a grid. Tabular
information can be sorted in scending/descending order by clicking any column header in the grid.
You can sort by one column only.

n Graphical displays present the same information as bar charts, except for the Agent vs. Team Stat-
istics, which is presented as two pie charts.

Note: Graphical displays are available at the Premium feature level only.

Data Updates

There are two ways that data is updated in Supervisor Desktop: syncing and refreshing.

n Syncing. Precision queue data is updated by an automatic sync that occurs every 10 minutes. Click
the Refresh button in the Supervisor Desktop toolbar to display the most recent data. If you want to
display updated data immediately following a change to precision queues, ask the administrator to
perform a manual sync in Desktop Administrator and then click the Refresh button.
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Note: A full sync is performed at startup and failover to update all precision queue data. This
sync can take up to 25 minutes or more. Changes are not visible in Supervisor Desktop until
this sync process is complete.

n Refreshing. The Refresh button in the Supervisor Desktop toolbar updates information in the Skill
Group tree and the TeamAgent State Display pane that has changed since the last sync. When you
click the Refresh button, the team information is reloaded and the display is updated with the latest
information fromDirectory Services.

Team Skill Statistics

The Team Skill Statistics display is available when you select the Skill Groups node in the Skill Groups tree.

This display presents the details of each individual skill group or precision queue, regardless of whether or
not an agent with that skill is logged in. By default, the data displayed is sorted in ascending order by skill
or precision queue name. The data is obtained from the CTI server unless otherwise noted, and is for the
current day starting at midnight. The data refresh rate for skills is configurable and ranges from every 5 to
60 seconds. By default it is every 15 seconds.

Graphical displays of this information consist of bar charts with the skill or precision queue name on the Y
axis and any of the available statistics listed in the table below on the X axis, expressed in either an integer
(0, 1, 2…) or time duration (hh:mm:ss).

Field Description

Skill Name The skill group or precision queue identifier, as set up in Cisco Unified
CCE. This column is required and cannot be disabled.

Agents Logged In The number of agents logged in.

Calls Waiting The number of calls currently in queue waiting for an agent.

Current Oldest The time of the oldest call in queue.
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Field Description

ASA Average speed of answer. The average time a caller waits in queue for
an agent, calculated by dividing the skill group or precision queue wait
time by the number of calls answered by the skill group or precision
queue.

Note: This statistic is calculated from the columns
PeripheralNumber, AnswerWaitTimeTo5, and
CallsAnsweredTo5 in the tables t_skill_group and t_skill_
group_real_time in the Cisco Unified CCE Admin Workstation
(AW) HDS database, not from the CTI server.

Calls Handled The number of inbound calls (ACD and non-ACD) presented to and
answered by the agent today.

Talk Average The average amount of time agents in the skill group or precision
queue spend in the Talking state.

Skill Summary Statistics

The Skill Summary Statistics display is available when you select a specific skill or precision queue from
the Skill Groups tree.

This display presents a summary of a specific skill group or precision queue’s statistics. These statistics
are from the entire contact center regardless of agent team assignments or the CAD-based client
applications the agents might be using. If agents are logged into the ACD and they are skilled to handle
contacts from this skill group or precision queue, then they are counted in this report.

For example, the number of agents logged in could include agents logged into the ACD through Agent
Desktop, IP Phone Agent, CTI OS, or any other ACD client that handles voice contacts. Similarly, if the skill
group or precision queue selected is a multimedia skill group or precision queue, the report will reflect
agents who could be logged in through Cisco Unified E-Mail andWeb Interaction Manager (Unified EIM
WIM) to handle e-mail contacts.

The data is obtained from the CTI server unless otherwise noted, and are for the current day starting at
midnight. The data refresh rate is configurable and ranges from every 5 to 60 seconds. By default it is
every 15 seconds.

There is no graphical display available for these statistics.
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Field Description

Skill Name The skill group or precision queue identifier, as set up in Cisco Unified
CCE. This column is required and cannot be disabled.

Agents Logged In The number of agents in the contact center who are assigned to the
skill group or precision queue and who are logged in to the ACD
through any client application.

Calls Waiting The number of calls currently in queue waiting for an agent.

Current Oldest The time of the oldest call in queue.

ASA Average speed of answer. The average amount of time a caller waits in
queue for an agent, calculated by dividing the skill group or precision
queue wait time by the number of calls answered by the skill group or
precision queue. The data for this statistic comes from the AW HDS
database, not from the CTI server.

Calls Handled The number of inbound calls (ACD and non-ACD) presented to and
answered by the agent today.

Talk Average The average amount of time agents in the skill group or precision
queue spend in the Talking state.

Skill Agent State

The Skill Agent State Display is available when you select a specific skill or precision queue from the Skill
Groups tree.

This display presents information about the voice state of each agent on your teamwho is logged into the
ACD through Agent Desktop or IP Phone Agent and who is assigned to the selected skill group or precision
queue. Users of any other desktop client, such as the CTI OS desktop, will not appear in this report.

This is true even if a multimedia skill group or precision queue is selected. That is, all agents on your team
who are logged into the ACD through Agent Desktop or IP Phone Agent and who are assigned the selected
multimedia skill group or precision queue, whether or not they are currently operating Cisco Unified E-Mail
andWeb Interaction Manager (Unified EIMWIM), will be listed in this display. In this way, you are made
aware that there are members of your teamwho have a CAD client open and who therefore could
potentially help with the multimedia skill group or precision queue.

By default, the data displayed is sorted in ascending order by agent name.
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The data is obtained from the Cisco Chat Service, and is for the current day starting at midnight. The data
refresh rate is 1 second, and is not configurable.

The graphical display of this information consists of a bar chart with the ACD states on the Y axis and the
number of agents on the X axis.

Field Description

Agent Name The agent’s name. Only agents logged in through Agent Desktop and IP
Phone Agent are displayed.

Agent ID The agent’s ID.

Current State The agent’s current ACD state for voice contacts.

Skill Group The skill group or precision queue ID of the ACD call the agent is cur-
rently servicing (in Talking state). If there is no call, or if the call is a
non-ACD call, this field is blank.

Skill Name The skill group or precision queue identifier, as set up in Cisco Unified
CCE.

State Duration The amount of time, in seconds, that the agent has been in the current
ACD state.

Reason Code The reason why the agent is in the current ACD state. Reason codes
are available for the Not Ready and Logout states only.

TeamAgent Statistics

The TeamAgent Statistics Display is available when you select the Team node or Agents node in the
Agents tree.

This display presents the real time state of the agents on the selected teamwho are currently logged into
the ACD. By default, the data displayed is sorted in ascending order by agent name.

Note: If the agent is assigned to a new teamwhile logged in, that agent will still show up as a
member of the old team in the TeamAgent Statistics display until the agent logs out and logs in
again. After logging in, the agent will show up as a member of the new team in the TeamAgent
Statistics display.
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The data is obtained from the CAD Recording & Statistics service, and is for the current day starting at
midnight. The data refresh rate is configurable and ranges from every 5 to 60 seconds. By default it is
every 15 seconds.

Graphical displays of the information consist of bar charts with agent names on the Y axis and the average
amount of time (hh:mm:ss) the agent spent in a selected ACD state.

Field Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Logon Time The total time the agent has been logged into the ACD today.

Calls Presented The number of inbound calls (ACD and non-ACD) presented to the
agent today.

Calls Handled The number of inbound calls (ACD and non-ACD) presented to and
answered by the agent today.

Max Talking The longest talk time of all calls handled today.

Avg Talking The average talk time and hold time of all calls handled today.

Total Talking The total talk time and hold time of all calls handled today.

Max Ready The longest time the agent spent in the Ready state today.

Avg Ready The average time the agent spent in the Ready state today.

Total Ready The total time the agent spent in the Ready state today.

Max Not Ready The longest time the agent spent in the Not Ready state today.

Avg Not Ready The average time the agent spent in the Not Ready state today.

Total Not Ready The total time the agent spent in the Not Ready state today.

Max After Call Work The longest time the agent spent in the Work Ready or Work Not Ready
states today.

Avg After Call Work The average time the agent spent in the Work Ready andWork Not
Ready states today.

Total After Call Work The total time the agent spent in the Work Ready andWork Not Ready
states today.

Other Time The total time the agent spent in states other than Talking, Ready, Not
Ready, Work Ready, or Work Not Ready today.
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TeamAgent State

The TeamAgent State Display is available when you select the Team node or Agents node in the Agents
tree.

This display presents the performance details for each agent on the team. By default, the data displayed is
sorted in ascending order by agent name.

Note: If the agent is assigned to a new teamwhile logged in, that agent will still show up as a
member of the old team in the TeamAgent State display until the agent logs out and logs in
again. After logging in, the agent will show up as a member of the new team in the TeamAgent
State display.

The data is obtained from the Cisco Chat Service, and is for the current day starting at midnight. The data
refresh rate is 1 second, and is not configurable.

The graphical display of the information consists of a bar chart with ACD states on the Y axis and the
number of agents currently in each ACD state.

Field Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Current State The agent’s current ACD state.

Skill Group The skill group or precision queue ID of the call the agent is currently
servicing (in Talking state). If there is no call, or if the call is a non-ACD
call, this field is blank.

Skill Name The skill group or precision queue identifier, as set up in Cisco Unified
CCE.

State Duration The amount of time, in seconds, that the agent has been in the current
ACD state.

Reason Code The reason why the agent is in the current ACD state. Reason codes
are available for the Not Ready and Logout states only.
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Agent vs. Team Statistics

The Agent vs. Team Statistics display is available when you select a specific agent in the Agents tree.

This display presents the performance details for the agent and compares them to the performance details
of the team. The data is obtained from the Cisco Recording & Statistics service, and is for the current day
starting at midnight. The data refresh rate is configurable and ranges from every 5 to 60 seconds. By
default it is every 15 seconds.

The graphical display consists of two pie charts, which show the percentage of time a specific agent
spends in various ACD states compared to the percentages spent by the team as a whole.

The ACD states compared are:

n Ready

n Not Ready

n Talking

n After Call Work (Work Ready andWork Not Ready)

n Other (all other ACD states not listed here)
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Field Description

ID Identifies the statistics as for the selected agent or the team.

Logon Time The amount of time the agent and team have been logged into Agent
Desktop.

Calls Presented Agent: The number of inbound calls (ACD and non-ACD) presented to
the agent today.

Team: The total number of inbound calls (ACD and non-ACD)
presented to all members of the team today.

Calls Handled Agent: The number of inbound calls (ACD and non-ACD) presented to
and answered by the agent today.

Team: The number of inbound calls (ACD and non-ACD) presented to
and answered by all members of the team today.

Max Talking Agent: The longest talk time of all calls handled today.

Team: The longest talk time of all calls handled by any member of the
team today.

Avg Talking Agent: The average talk and hold time of all calls handled today.

Team: The average talk and hold time of all calls handled by all
members of the team today.

Total Talking Agent: The total talk and hold time of all calls handled today.

Team: The total talk and hold time of all calls handled by all members
of the team today.

Max Ready Agent: The longest time the agent spent in the Ready state today.

Team: The longest time any member of the team spent in the Ready
state today.

Avg Ready Agent: The average time the agent spent in the Ready state today.

Team: The average time all members of the team spent in the Ready
state today.

Total Ready Agent: The total time the agent spent in the Ready state today.

Team: The total time all members of the team spent in the Ready state
today.

Max Not Ready Agent: The longest time the agent spent in the Not Ready state today.

Team: The longest time any member of the team spent in the Not
Ready state today.
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Field Description

Avg Not Ready Agent: The average time the agent spent in the Not Ready state today.

Team: The average time all members of the team spent in the Not
Ready state today.

Total Not Ready Agent: The total time the agent spent in the Not Ready state today.

Team: The total time all members of the team spent in the Not Ready
state today.

Max After Call Work Agent: The longest time the agent spent in the Work Ready or Work
Not Ready state today.

Team: The longest time any member of the team spent in the Work
Ready or Work Not Ready state today.

Avg After Call Work Agent: The average time the agent spent in the Work Ready andWork
Not Ready states today.

Team: The average time all members of the team spent in the Work
Ready andWork Not Ready states today.

Total After Call Work Agent: The total time the agent spent in the Work Ready andWork Not
Ready states today.

Team: The total time all members of the team spent in the Work Ready
andWork Not Ready states today.

Other Time Agent: The total time the agent spent in states other than Talking,
Ready, Not Ready, Work Ready, andWork Not Ready today.

Team: The total time all members of the team spent in states other than
Talking, Ready, Not Ready, Work Ready, andWork Not Ready today.

Agent Call Log

The Agent Call Log Display is available when you select the Logs node under a specific agent’s name in
the Agents tree.
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This display presents a history of the calls made and received by the agent during the current session. By
default, the data displayed is sorted in ascending order by time of day. The data in the report must be
refreshed manually by clicking the Refresh button on the toolbar.

Field Description

Start Time The time the call was answered.

Direction Inbound or outbound call.

Answered Indicates if the call was answered (Yes) or unanswered (No).

Calling Party The originating phone number.

Called Party The recipient phone number.

Call Duration The length of the call.

ACD Line Indicates if the line used by the call was ACD (Yes) or non-ACD (No).

Agent ACD State Log

The Agent ACD State Log Display is available when you select the Logs node under a specific agent’s
name in the Agents tree.

This display presents a history of the ACD states the agent transitioned through during the current session.
By default, the data displayed is sorted in ascending order by time of day.
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Note: Agent events that occur within the same second might be displayed out of order. For
example, when an agent logs in, that agent’s states might display the Not Ready state before the
Login state.

The data in the report must be refreshed manually by clicking the Refresh button on the toolbar.

Field Description

State Start Time The time the agent state was initiated.

Agent State The last agent state written to the log is actually the previous agent
state that the agent was in. In order to calculate State Duration, the
agent’s current state cannot be written to the log until the agent trans-
itions to the next agent state.

Wrap-up Data Any wrap-up data the agent entered, if the agent state transitioned to
is After Call Work (Work Ready or Work Not Ready).

Reason Code Any reason code the agent entered, if the agent state transitioned to is
Not Ready or Logout (if required).

State Duration The length of time the agent was in the agent state.

Agent Active Call

The Agent Active Call Display is available when you select an active call under a specific agent’s name in
the Agents tree.

This display presents information about each party in the current active call.

Field Description

Name Name of the parties in the call, if known. If this data is not known,
<Unavailable> is displayed.

Number The party’s phone number.

Call Status Hook state of the party (Active or Held).

Duration The length of time the party has been in the call.
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Field Description

Skill Group The skill group or precision queue ID the call was queued to, if applic-
able.

ACD Line Indicates if the call came in on an ACD (Yes) or non-ACD (No) line.

Enterprise Data

The Enterprise Data Display is available when you select an active call under a specific agent’s name in
the Agents tree. The specific data that is displayed is configured by your administrator.

Call History

The Call History real time display is available when you select an active call under a specific agent’s name
in the Agent’s tree.

This display presents a history of the call’s presence in the contact center.
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Field Description

Threshold The acceptable length of time that a call can stay at a specific device
or contact center. The administrator can assign caution and warning
thresholds to each device type, as well as a total threshold for a call.

If a call remains at a device longer than the defined caution and
warning thresholds, a caution or warning icon appears in this field.

Device A device that the call has passed through.

Type The type of device the call has passed through.

Description Description of the device.

Duration The amount of time the call spends at a device.
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Supervisor Record Viewer
The Supervisor Record Viewer displays all recordings made by your team over the last seven days as well
as those you tag for a 30-day extended lifetime.

Note: Supervisor Record Viewer is a separate program from Supervisor Desktop. Closing
Supervisor Desktop will not close Supervisor Record Viewer.

The Supervisor Record Viewer displays the information listed in the following table.

Field Description

Agent The name of the agent whose call is recorded.

Team The team to which the agent belongs.

Time The time the recording was made.

Duration The length of the recording in hh:mm:ss format.
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Field Description

Lifetime The length of time the recording is archived. Normal is 7 days, Exten-
ded is 30 days.

Date Recorded Appears only when “Extended Lifetime” is selected in Day Select. The
date the recording was made.

Note: A license is used whenever a playback is in progress and released when the playback
ends. If no licenses are available when you attempt to play back a recording, this error message
is displayed: “A licensing error has occurred. Please try again in five minutes. If the problem
persists, please see your log file or SystemAdministrator for details.” You must wait until a
license is released and available in order to review any recordings.

Note: In a High Availability system, recordings can be stored on either of the two recording
servers, and all are displayed in Supervisor Record Viewer. If one of the servers becomes inactive
and cannot be accessed, the recordings stored on that server cannot be played, even though
they continue to be displayed in Supervisor Record Viewer. If you attempt to play a recording
stored on an inactive server, you will see the error message, “The recording server is inactive.”
You will be able to play the recording when the server becomes active again.

The recordings are archived as raw voice data packets; they can only be played back using the Supervisor
Record Viewer. However, if you want to save selected recordings as WAV files, you can use the “Play and
Save” button and save the recording to a folder in WAV format.

Unless recordings are tagged for an extended lifetime, they are automatically deleted after seven days.

If a recording is tagged for the 30-day extended lifetime, it will not be deleted until that 30-day period
expires. If you delete it manually before the 30-day period expires, it is deleted in the next folder cleanup.
Cleanups run daily at midnight.

To start Supervisor Record Viewer:

1. From the Supervisor Desktop menu bar, choose Tools > Recorded Files. Supervisor Record Viewer
starts with the current day selected.

2. From the Day Select section, click one of the date options to view the recordings made by your team
on that date.

To listen to a recording:

1. From the Day Select section, click the option for the date of the recording you want to review.

You can also click the Extended Lifetime option to view a list of all recordings that have been tagged
for extended 30-day archiving.

2. Select the recording you want to review.

3. Click the play button, or choose Recording > Play from the menu bar.
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Use the Pause or Stop buttons to control the recording playback, and the volume slider to control the
playback volume.

There is a progress bar at the bottom of the window that shows where you are within the recording.
You can click the progress bar and drag it to the left or right to rewind or fast forward the recording. To
restart the playback, click Play.

Note: You cannot play back a recording while you are monitoring a call.

To save a recording:

1. Select the recording you want to save.

2. Click the Play and Save button, or choose Recording > Play and Save from the menu bar. The Save As
dialog box appears.

3. Select the folder where the recording is to be saved, enter a file name for the recording, and then click
Save. The recording plays and simultaneously is saved as a WAV file to the location you selected.

To tag a recording for extended archiving:

1. Select the recording you want to archive for 30 days.

2. Click the Set Extended Lifetime button, or choose File > Set Extended Lifetime from the menu bar. The
recording is tagged to be archived for 30 days from the date of recording.

Toolbar and Shortcut Keys

From left to right, the toolbar buttons are:

n Play

n Play & Save

n Pause

n Stop

n Set Extended Lifetime

n Set Normal Lifetime

n Delete

n Volume Control

The shortcut keys for Supervisor Record Viewer are listed in the following table.
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Shortcut Key Description

Ctrl+D Selects the first option in the Day Select section. Use the left and right
arrows to navigate within the section.

Ctrl+F Selects the first recording in the list if no other recordings are selected.

Ctrl+S Plays the selected recording and simultaneously saves it as a WAV file
to the selected location.
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Supervisor Work Flow Administrator
Supervisor Work Flow Administrator enables you to configure your desktop to perform certain actions
based on queue statistics for calls waiting and calls in queue for specified skill groups.

These work flows apply only to you, not to any other supervisors, and are available to you no matter where
you log into Supervisor Desktop. They are tied to your login information.

In general, work flows consist of events, thresholds, and actions.

n The event that triggers an action is a queue statistics update. Queue statistics are updated once every
5 seconds.

n The thresholds the event must meet is one or both of the following:
n The number of calls waiting is below, within, or above specified limits

n The oldest call in queue is below, within, or above specified limits

n The actions triggered by meeting the thresholds can be:
n Change the color of the skill group or precision queue name in the tree control and/or add a mes-

sage next to it

n Highlight data in the tabular real time display

n Display a popup message on your desktop

n Play a WAV file on your desktop

n Send an e-mail to selected recipients

For example, you can set up a work flow so that when there are more than 10 calls waiting in the queue for
Skill Group 6500, the skill group or precision queue name in the Skill Groups tree turns red and an audible
warning sounds every 15 seconds.

Note: Supervisor work flow actions are available at the Premium level, except for the Tree Control
action, which is also available at the Enhanced level.

Setting Up aWork Flow

Follow these steps to set up a supervisor work flow.

To set up a supervisor work flow:
1. Choose Tools > Supervisor Work Flow Administrator.

2. In the Supervisor Work Flow List dialog box, click Add.

3. In the Add New Work Flow dialog box, enter a name for your new work flow and click OK.

4. In the Skill Group Selection dialog box, select the skill groups or precision queues you want your work
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flow to apply to from the Available Skill Groups pane and use the arrows to move them to the Selected
Skill Groups pane, and click OK.

Note: A skill group or precision queue can be part of only one work flow per supervisor.

5. In the Supervisor Work Flow Setup dialog box, set up the parameters for the work flow.
a. Specify the upper and lower limits for the Call Waiting and/or Current Oldest threshold. Note that

when you select both Calls Waiting and Current Oldest, the highest threshold crossed takes pre-
cedence.

b. Select Above from the Thresholds pane.

c. Click Add. In the resulting Action Type Selection dialog box, select the action you want to be
triggered when the Calls Waiting and/or Current Oldest statistic is above the upper limit you set,
and then click OK. See Work Flow Actions for information on the types of actions available.

d. Repeat steps b–c for the Within and Below thresholds.

6. When you have finished completing the Supervisor Work Flow Setup dialog box, click OK to enable
the work flow.
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Example of Setting Up a SupervisorWork Flow

The following is a step-by-step example of setting up a supervisor work flow. This work flow:

n Changes the skill group name color to green and displays “Below” next to it in the Skill Groups tree
control when there are fewer than two calls waiting, or if the current oldest call is less than 1 minute
old.

n Changes the skill group name color to blue and displays “Caution” when there are 2 to 5 calls waiting,
or if the current oldest call is between 1 and 5 minutes old.

n Changes the skill group name color to red and displays “Warning” when there are more than five calls
waiting, or if the current oldest call is more than 5 minutes old.

46



Supervisor Work Flow Administrator

To set up the example supervisor work flow:
1. Choose Tools > Supervisor Work Flow Administrator.

2. In the Supervisor Work Flow List dialog box, click Add.

3. In the Add New Work Flow dialog box, enter the name “Customer Management” and then click OK.

4. In the Skill Group Selection dialog box, select the skill groups you want your work flow to apply to from
the Available Skill Groups pane and use the arrows to move them to the Selected Skill Gropus pane.
Click OK when finished.

5. In the Supervisor Work Flow Setup dialog box, select the Calls Waiting check box and set the lower
limit to 2 and the upper limit to 5.

Select the Current Oldest check box and set the lower limit to 1 minute and the upper limit to 5
minutes.
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6. Select Below in the Thresholds pane and then click Add under the Actions pane.

7. In the Action Type Selection dialog box, select Tree Control Action and click OK.
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8. In the Tree Control Action dialog box, select the Display Text check box and Below from the drop-
down list.

9. Select the Change Text Color check box, click Set Color, choose green from the color palette dis-
played, and then click OK.

10. Repeat steps 6–9 for the Above andWithin thresholds. For Above, select “Warning” as the display text
and set the color to red. For Within, select “Caution” as the display text and set the color to blue.
When you are finished, click OK to enable the work flow.

The skill group names will now be color-coded with text displayed.
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Work Flow Actions

There are five work flow actions that can be triggered by threshold rules. These actions are:

n Audible Alert Action

n E-Mail Alert Action

n Message Box Action

n Report Action

n Tree Control Action

Audible Alert Action

The Audible Alert action plays a WAV file on your desktop whenever the threshold rules are met. By
default, the file plays once, but you can also configure it so that it plays repeatedly at specified intervals.

This action is available at the Premium level.

Note: You can turn off audible alerts that are configured to repeat at intervals by choosing
Actions > Supervisor Work Flow — Audio Off from the menu.

Your computer most likely has systemWAV files available that are used to signal standard Windows
events. These files are a good source of sounds.

Note: The WAV file you select must be 50 KB or smaller.

To set up an audible alert action:
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1. Click Add New and browse to the location of your selectedWAV file.

2. If desired, set up a repeat interval.

3. Click OK.

E-Mail Alert Action

The E-mail Alert action enables you to send an e-mail to specified people whenever the threshold rules
are not met.

The e-mail messages have predefined subject lines, depending on what threshold rule is met. They are:

n Skill: <skill group or precision queue name>, Number of Calls Waiting is above upper limit

n Skill: <skill group or precision queue name>, Number of Calls Waiting is below lower limit

n Skill: <skill group or precision queue name>, Number of Calls Waiting is within upper and lower limits
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n Skill: <skill group or precision queue name>, Oldest Call in Queue is above upper limit

n Skill: <skill group or precision queue name>, Oldest Call in Queue is below lower limit

n Skill: <skill group or precision queue name>, Oldest Call in Queue is within upper and lower limits

The e-mail messages sent can consist of just the Subject line. Amessage in the body of the e-mail is
optional.

To set up an e-mail alert action:

1. Complete the fields in the E-Mail Alert Action Setup dialog box as follows.

Field Description

From Required. Enter your e-mail address.

To Required. Enter the e-mail addresses of the recipients, separated
by a semicolon.

Mail Server Required. The SMTP IP address or host name of the e-mail server
used to send the e-mail.

BCC Optional. Enter the e-mail addresses of the recipients you want
copied in on the e-mail message.

2. Click Send to verify that the e-mail alert action is configured correctly. If the test e-mail is suc-
cessfully sent, “Mail Sent Successfully” appears in the field next to the Send button. “Error sending
mail” appears if there is a problem. If this occurs, check your entries in the To, BCC, and Mail Server
fields for accuracy and test the action again until it is successful.
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3. Click OK.

MessageBoxAction

The Message Box action pop ups a message box containing a customized message on your desktop
whenever the threshold rules are met. The message box is closed by clicking OK.

This action is available at the Premium level.

To set up a message box action:
1. Type your message in the Message Text field.

2. Select the appropriate message icon from the drop-down list.
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3. Click OK.

Report Action

The Report action highlights cells in the Team Skill Statistics real time display when the data in the cells
exceeds the threshold rules. The cells appear in the Calls Waiting and Current Oldest columns.

This action is available at the Premium level.

To set up a report action:
1. Click Set Color and select the color to use for highlighting the cells.

2. Select the Show Team Skill Statistics Report check box if you want Supervisor Desktop to auto-
matically change its focus to display the Team Skill Statistics real time display whenever a statistic
changes and triggers the Report action.

3. Click OK.
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TreeControl Action

The Tree Control action enables you to select a color to apply to a skill group or precision queue name
and/or a message to display beside the name in the Skill Groups tree control whenever the threshold rules
are met.

This action is available at the Enhanced and Premium levels.

To set up a tree control action:
1. Select the Display Text check box and text from the drop-down list if you want the text to be displayed

next to the skill group or precision queue name.

2. Select the Change Text Color check box and click Set Color if you want to choose the color for the
text and the skill group or precision queue name.

3. Click OK.
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Supervising Agents

Monitoring an Agent

The voice monitor button enables you to silently listen in on an agent’s ACD phone conversations. If
enabled by the administrator, you can also monitor an agent’s non-ACD phone conversations.

Voice monitoring is available whenever an agent is logged in, whether or not the agent is on the phone. It
is not available when:

n You are a participant in a phone call (you cannot monitor yourself).

n You use the Barge-In or Intercept function.

When monitoring a call, keep in mind the following considerations:

n When you select a specific call from the Team View pane to monitor, all voice activity to and from that
particular agent is monitored. The monitoring is not limited to the call you selected. For instance, if the
agent puts the selected call on hold and switches to another call, both calls will be monitored.

n If notification is off, agents have no way of knowing if you are monitoring their calls.

CAD supports two kinds of monitoring:

n Unified CM-based (call-based) monitoring

n CAD-based monitoring, which can be either desktop monitoring or server (SPAN) monitoring

The type of monitoring that is used is determined when the Cisco components of your system are installed.
CAD uses either Unified CM-based or CAD-based monitoring, not both. Supervisor Desktop automatically
determines which kind of monitoring is used when it is launched.

CAD-based Monitoring

CAD-based monitoring is available whenever an agent is logged in to Agent Desktop (uses either desktop
monitoring or server monitoring) or IP Phone Agent (uses server monitoring only). It is not available when:

n You are a participant in a phone call (you cannot monitor yourself)

n You use the Barge-In or Intercept function

Note: Agents logged in to IP Phone Agent can only be monitored by one supervisor at a time.

When you use CAD-based monitoring, the monitored call is audible through your PC speakers. The volume
slide on the Supervisor Desktop toolbar enables you to control the volume when monitoring an agent’s
phone conversation. The system remembers your last volume setting and uses it the next time you log in.

Monitoring sessions are on a per-agent basis, and only one monitoring session can be in progress at one
time. When you select an agent from the Team View pane to monitor, you can hear all voice activity to and
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from that agent. If configured by your administrator, the monitoring session is not limited to one call. For
instance, if the agent puts an active call on hold and switches to another call, you will monitor both calls.

In CAD-based monitoring, you can record while monitoring an agent.

To start monitoring an agent using CAD-based monitoring:
1. Choose an agent in the Agents tree.

2. Click the Start Voice Monitor button, or choose Intervention > Start Voice Monitor.

To stop monitoring an agent using CAD-based monitoring:
n Click the Stop Voice Monitor button, or choose Intervention > Stop Voice Monitor.

Unified CM-based Monitoring

Unified CM-based monitoring is available when an agent is logged into Agent Desktop and is on an active
call. You must also be logged into Agent Desktop, and in the Not Ready agent state. It is not available
when any of the following conditions are true:

n You are a participant in a phone call.

n The agent you want to monitor is not on a call or has a call on hold.

n The agent being monitored is logged in as a mobile agent.

n The agent is using the Cisco IP Communicator soft phone.

Note: Recording is not supported with Unified CM-based monitoring.

In Unified CM-based monitoring, when you start monitoring an agent’s call, a new call is directed to your
IP phone and answered automatically. The phone does not ring. You can listen to the phone call through a
headset, speaker, or handset. The new call on your IP phone (your “monitoring call”) appears in Agent
Desktop as an outbound call and also in the Supervisor Desktop tree control as an active call.

While you are monitoring a call, you cannot use the barge-in, intercept, conference, or transfer functions.
They become available when you stop monitoring.

Note: Unified CM-based monitoring is supported only on certain IP phone models. For a complete
list of IP phone models that support Unified CM-based monitoring, see the Cisco Unified Contact
Center Enterprise (Unified CCE) Software Compatibility Guide available on cisco.com.

Your monitoring call (on your IP phone) ends when one of the following events occurs:

n When the agent transfers or ends the monitored call

n When you stop monitoring or exit Supervisor Desktop

n When you or the agent exit Agent Desktop

To start monitoring a call using Unified CM-based monitoring:
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1. Select a call under an agent in the Agents tree.

2. Click Start Voice Monitor or choose Intervention > Start Voice Monitor. The call is sent to your IP
phone and answered automatically. The phone does not ring.

To stop monitoring a call using Unified CM-based monitoring:
n Click Stop Voice Monitor, choose Intervention > Stop Voice Monitor, or end the call on your IP phone.

Pushing aWeb Page to an Agent

You can coach an agent by pushing a web page to that agent’s Agent Desktop integrated browser.

To push a web page to an agent:
1. From the Agents tree, select an agent.

2. Choose Intervention > Coach by Pushing a Page. The Push URL to Agents dialog box appears.

3. Enter the URL of the web page you want the agent to see, and then click Push to send the web page
to the agent. The web page you pushed to the agent is displayed in the first tab of the agent’s
integrated browser. This tab is reserved for pushed web pages.

Note: There are no restrictions on what you can enter as a URL (for example, you are not
required to prefix the URL with “http://”) as long as the URL can be resolved by a browser.
Some sites require that “http” or “https” be part of the URL.

Note: If the integrated browser is not enabled for the selected agent, this operation will fail
and no error message will appear.
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Barging in on a Call

The Barge-In feature enables you to join an agent’s ACD (and if enabled by the administrator, non-ACD)
phone conversation. When you click the Barge-In button, you are automatically added to the phone call. It
is a forced conference.

Note: To barge in on a call, you must first be logged into Agent Desktop.

Note: You can barge in only once on a call per supervisor. For example, if you barge in on a call,
drop out of the conversation, and then attempt to barge in on the same call again, you will not be
able to do so.

If notification is enabled, the agent sees a message that you are attempting to join the call, then sees a
message that you have successfully joined it.

When you use the Barge-In feature, voice monitoring is disabled. You can, however, record calls.

You cannot barge in if any of the following conditions are true:

n The agent is on hold

n The agent is in a conference call

n You are already on another call

To barge in on a call:
1. Select an agent call in the team view pane.

2. Click Barge-In or choose Intervention > Barge-In. You are added to the call.

At any time during the conference call, you can click Intercept to disconnect the agent whose call is
selected from the conference call and continue talking with the remaining parties yourself.

To drop the barged-in call:
n In Agent Desktop, select the conference call in the contact appearance pane and then click Drop.

Intercepting a Call

The Intercept feature enables you to intercept an agent’s ACD (and if enabled by the administrator, non-
ACD) phone conversation while disconnecting the agent from that phone call. It is a forced transfer.

Note: To intercept a call, you must first be logged into Agent Desktop.

Note: You can intercept a call only once. For example, if you intercept a call, drop out of the
conversation, and then attempt to intercept the same call again, you will not be able to do so.
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If notification is enabled, the agent sees a message that you are attempting to intercept the phone call,
then sees a further message when the interception is successful.

When you use the Intercept feature, voice monitoring is disabled. You can, however, record calls.

You cannot intercept if any of the following conditions are true:

n The agent is on hold

n You are already on another call

To intercept a phone call:
1. Select an agent call in the team view pane.

2. Click Intercept or choose Intervention > Intercept. The call is transferred to you.

If you are intercepting a conference call you are on, the agent call you selected in the team view pane
is dropped from the conference call, and all other participants in the conference call remain
connected.

To drop the intercepted call:
n In Agent Desktop, select the intercepted call in the contact appearance pane and then click Drop.

Recording a Call

You can use Supervisor Desktop to record, save, and play back ACD calls handled by agents on your team.
If enabled by the administrator, you can also record an agent’s non-ACD phone call.

Note: Your ability to record depends on the features that are available in your system. If recording
is unavailable, the Start Record button on the toolbar is disabled.

Recordings are made on a per call basis, and multiple recordings can be in progress at the same time.
Recordings can be made on all lines for an agent, including non-ACD lines (if enabled by your
administrator). For instance, if an agent puts an active call on hold and starts another call, you can record
both calls, if the administrator configuration allows it.

You use the Supervisor Record Viewer to review recorded calls.

You can use the Barge-in, Intercept, and Voice Monitor features while recording.

When recording a call, keep in mind the following considerations:

n The recording feature is not intended to record every call. It is an on-demand solution only.

n When you select a call from the Team View pane to record, only the voice activity for that particular
call is recorded. The recording is limited to the call you selected. In order to record all voice activity
from an agent across all lines, each call must be individually selected for recording. For instance, if
the agent puts the selected call on hold and switches to another call, you must select the other call
and press Record in order to record both calls.

n Your administrator must enable recording of non-ACD calls.
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n The recording will end when the selected call terminates, or when you manually stop recording,
whichever comes first.

n Agents can be configured so that they can start and stop recording calls. However, an agent cannot
stop a recording started by a supervisor. If an agent attempts to do so, their Agent Desktop or IP Phone
Agent interface indicates the recording is stopped. However, the recording is not stopped, and Super-
visor Desktop displays an icon indicating that recording is proceeding.

n You can stop a recording initiated by an agent.

n If notification is off, agents have no way of knowing if you are recording their calls. If an agent
attempts to start recording a call that you are already recording, the agent will see a recording icon on
the call, although the agent is not in control of the recording.

n When you or an agent record a call, a recording license is used. The license is released when the
recording stops. If all recording licenses are in use when you attempt to start a recording, the
recording will not start.

To record a call:
1. Choose the call you want to record from the Agents tree.

2. Click the Start Record button, or choose Intervention > Call/Agent Start Recording.

3. When you are finished, click the Stop Record button, or choose Intervention > Call/Agent Stop
Recording. The call is archived to the Recording service database, where it is automatically saved for
seven days.

Note: If you want to save the recording for a longer period, you can do so for up to 30 days,
after which it is deleted. For more information on playing and saving recordings, see
Supervisor Record Viewer.

Changing an Agent’s ACD State

You can use Supervisor Desktop to change the ACD state of an agent on your team, including logging an
agent out.

Note: If you log a CAD agent out, that agent will continue to appear in the agents tree and will be
able to chat and receive teammessages. If you log out an IPPA agent, that agent disappears from
the agents tree.

To change an agent’s agent state:
1. From the Agents tree, select the agent whose state you want to change.

2. On the toolbar, click the appropriate agent state button.

Note: There is a delay of about 2 to 3 seconds before the command to change agent state takes
effect. To ensure you set the desired agent state, allow enough time between clicking Agent State
buttons for the command to take effect.
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Note: If an agent state change fails, you will not see any failure message. You will know that an agent
state change succeeds if the icon next to the agent’s name in the team view pane changes to the
current agent state icon.

Sending a TeamMessage

You can send a teammessage to all agents on a team, whether or not the agent is logged into the ACD. As
long as Agent Desktop is open, an agent can view a teammessage.

Note: You cannot send teammessages to IP Phone agents.

The TeamMessages dialog box stores the last 10 teammessages you broadcast. You can select any one
of these messages to broadcast again. If you send more than 10 teammessages, the oldest one drops off
the stored list. You cannot designate any particular teammessage for permanent storage.

Note: By default, the teammessage scrolls across Agent Desktop’s teammessage pane.
Individual agents can set their preference in Agent Desktop to view teammessages as stationary.
A stationary teammessage is more compatible with screen readers, which are often used by
vision-impaired agents.

The Current Message pane displays the message that is currently being sent to your team.

To send a teammessage to all agents on a team:
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1. From the team selection list, choose the team to which you want to send the message, and then click
View > TeamMessages or click the TeamMessages button.

2. Type your message in the text box. The teammessage can be up to 255 characters long. You must
type a message before choosing an expiration time.

3. In the Expires at field, choose a specific time for the message to expire. By default, the message runs
for 30 minutes.

If you set a time earlier than the current time, the message will run until that time the next day. For
example, if it is 10:15 AM and you set the expiration time to be 10:00 AM, the message will run until
10:00 AM tomorrow.

4. Click Start or press Enter.

The teammessage is sent to the team for the length of time you chose. The text of the message you
sent is logged in the current team performance message field.

To cancel a teammessage:
n In the TeamMessage dialog box, click Stop.
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Chat
Chat enables you to send instant messages to agents and supervisors on your teams. In addition, if your
configuration includes Cisco Unified Presence, you can send instant messages to non-agents (called
subject matter experts, or SMEs) who are using Cisco Unified Personal Communicator.

Some Chat features include:

n You can send the same chat message to multiple recipients. The sending chat window closes after
the message is sent, and recipient’s replies, if any, appear in separate chat windows, one for each per-
son.

n You can participate in multiple concurrent chat sessions.

n The title bar of the Chat window displays the name of the person with whom you are chatting.

n If you flag a chat message as high priority, the Chat window will pop up on the other person’s screen
so that the message is noticed immediately.

n If the priority of a chat message is normal (the default), the Chat window will remain in its current state
(open or minimized) and the corresponding icon will flash on your Windows task bar.

n A log of the chat messages sent between you and your chat partner (chat history) is available as long
as the Chat window is open. After you close the Chat window, the log is lost.

n Chat history is in chronological order, with the oldest messages at the top of the log pane.

n You can chat with agents who are logged out of the ACD as long as they still have Agent Desktop
open.

n You can chat with subject matter experts (SMEs) (non-agents).

n An agent’s ACD state is indicated by both an icon to the left of the agent name and by text to the right
of the agent name.

n If you are logged into Unified Presence, an SME’s Unified Presence status is indicated both by an icon
to the left of the SME name and by text to the right of the SME name.

Chat Contacts

Your contacts are organized in groupings called drawers in the Chat Selection window. Some drawers,
such as the Teammates, Supervisors, and Conference drawers, are default drawers. Any other drawers
that appear are customized by your administrator and appear only if you are logged into Unified Presence.

The example of a Contact Selection window below shows the default Teammates and Supervisors
drawers, as well as two customizable drawers, TAC and Engineering.
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n The Agents drawer lists all the agents on the team selected in Supervisor Desktop. The agents’ agent
state is indicated both by an icon to the left of the agent name and by text to the right of the agent
name. The agent state is updated whenever it changes. Agents do not have to be currently logged
into Agent Desktop to be listed here, but they must have Agent Desktop open and they must have
logged in at least once.

Note: You cannot chat with IP Phone agents.

n The Supervisors drawer lists all supervisors on your team. Their status is always listed as Available.
Supervisors must be logged in to be listed here.

n The Conference drawer appears when you are on a conference call with other agents. SMEs, if they
are on the conference call, are not listed here.

n The Personal Contacts drawer appears if you have this drawer set up in Unified Personal Com-
municator. The contacts in this drawer are administered in Unified Personal Communicator.

n Other drawers list the SMEs associated with the work flow groups to which your agents belong. The
SMEs’ Unified Presence status is indicated both by an icon to the left of the SME name and by text to
the right of the SME name. The Unified Presence status is updated whenever an SME status changes.

The Chat Selection window also provides menu access to the following call handling functions:

n Making a call

n Transferring a call

n Initiating a conference call
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Chat Shortcut Keys

The following table lists the shortcut keys in the Chat window.

Shortcut Key Description

Alt+L Starts a chat session with the person highlighted in the Chat Selection
window. If you are already chatting with the highlighted person, Alt+L
will bring that chat window to the foreground.

Alt+C Opens the dial pad so you can call the person highlighted in the Chat
Selection window. The Name: Number field is auto-populated with the
selected person's extension.

Ctrl+Shift+H Selects the chat log pane.

Sending a Chat Message

To send a chat message:
1. Click Chat on the toolbar to open the Chat Selection window.

2. To chat with one person, double-click that person’s name. To chat with several people, Ctrl+click to
select their names and press Enter or choose Actions > Chat. A Chat window opens and a session
begins with the people you selected.
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3. Type your message in the text entry pane and click Send or press Enter. Your message is sent to your
chat partner and logged in the chat history pane.

Replies from recipients of a group message appear in individual chat session windows. They cannot
reply to the group, they can reply only to you.

Note: If you want your message to be noticed immediately by popping on your chat partner’s
desktop, select the High priority check box.

Note: If you log out during a chat, your copy of the chat log is lost, the current Chat window
closes, and a new Chat window opens so you can continue communicating. The entire chat
log is still present in the other party’s Chat window.

To end a chat session:
n Choose File > Close or click Close in the upper right corner of the Chat window.

Predefined High Priority Chat Messages

Agents can have a task button in Agent Desktop configured to send a predefined high-priority chat
message to their supervisors. This predefined message (for example, “Please barge in on my call”) is set
up by the administrator. It behaves just like a regular chat message that is flagged as high priority—it pops
up on your screen on top of all other windows for your immediate attention.

You can reply to a predefined high-priority chat message from a CAD agent.
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Calling Someone in the Chat List

You can make a call, transfer a call, or conference a call to anyone listed in your Chat Selection window
using the call control actions.

n To call someone, you must be logged into Agent Desktop and be in an agent state that allows you to
make a call.

n You cannot call someone listed in your Personal Contacts drawer.

n You do not have to be chatting with an agent or SME in order to call them.

The call control menu items are typically disabled for SMEs. In order to make a call, transfer a call, or
conference a call to an SME in your chat list, the SME must be configured as an External Contact by your
administrator. If an SME name does not have a phone number associated with it, the call control menu
items are disabled.

To call someone in your chat list:

1. In the Chat Selection window, do one of the following:

n If you are chatting with the person you want to call, choose Actions > Call, Transfer, or Con-
ference.

n If you are not chatting with the person you want to call, select the person’s name and choose
Actions > Call, Transfer, or Conference. You can also right-click the person’s name and choose
the desired call action from the resulting popup menu.

The dial pad appears with the person’s phone number autofilled in the Name: Number field.

2. Click Dial.
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Agent Re-skilling
The Agent Re-skilling tool is a browser-based application that enables you to change the skill group
designations of agents on your team, and quickly view skill group members and details on individual
agents. Changes made to an agent's skill group membership take place immediately without need for the
agent to log out and log in again.

Dynamic Re-skilling must be enabled by your administrator on the ICMAdmin Workstation Distributor node
of the CADConfiguration Setup utility. See the Cisco CAD Installation Guide for more information.

Note: Changes to precision queues must be made in Cisco Unified CCE Web Administration.

The Agent Re-skilling tool can run in your integrated browser if the browser is enabled.

Re-skilling can be done on the agent level and on the skill group level. You can add and remove skill
groups from an agent, or you can add or remove agents from a skill group.

Note: The new skill group shows up in the agent’s reports immediately. It might take up to 19
minutes for changes in skill group data to show up in the local database. To display data
immediately, you can ask the system administrator to perform a manual Directory Services sync.
You must click the Refresh button after the sync has completed to display the changes in
Supervisor Desktop.

Re-skilling an Agent

To re-skill an agent:

1. From the menu, choose Tools > Agent Re-skilling > Site 1. The supervisor login window for the Agent
Re-skilling tool appears.

Note: Your menu might display Site 1 only, or Site 1 and Site 2 only. The number of sites
depends on the configuration of your system. These sites represent the servers on which the
Agent Re-skilling tool is located. If you receive an error when you try to access a site, try
another site until you find the site that is active.
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2. Enter your Supervisor Desktop login name and password, and then click Login. The Agents window
appears.

3. Use the search fields at the top of the window to locate the agent you want to re-skill.

4. Select the agent by clicking the agent’s login name. The Edit Agent window appears.
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5. In the Skill Groups pane you can:

n Assign a new skill group to the agent. Click Add, and in the resulting Select Skill Groups for Agent
window, check the skill group you want to add, and then click OK.

n Delete a skill group from the agent. Select the skill group you want to delete, and then click
Remove.

n Remove all skill groups from the agent. Click Remove All to delete all skill groups. Note that an
agent must be assigned to at least one skill group.

6. Click Save to save your changes. At the top of the window a message appears, stating that the agent
was saved successfully.

To add and remove agents from a skill group:
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1. From the menu, choose Tools > Agent Re-skilling > Site 1. The supervisor login window for the Agent
Re-skilling tool appears.

Note: Your menu might display Site 1 only, or more sites (Site 2, Site 3, etc.). This depends
on the configuration of your system. These sites represent the servers on which the Cisco
Unified CCE Agent Re-skilling Tool is located. If you receive an error when you try to access
a site, try another site until you find the site that is active.

2. Enter your Supervisor Desktop login name and passwor, then click Login. The Agents window
appears.

3. Click Skill Groups at the left side of the window to change the view to a list of skill groups.

4. Select the desired skill group from the list by clicking its name, or use the search fields at the top of
the window to locate the skill group. The Edit Skill Group window appears.

5. In the Agents in your team(s) pane you can:

n Assign a new agent to the skill group. Click Add, and in the resulting Select Agents for Skill Group
window, select the agents you want to add and then click OK.

n Delete an agent from the skill group. Select the agent you want to delete and then click Remove.

n Remove all agents from the skill group. Click Remove All to delete all agents. A skill group with no
agents assigned to it will not show up in Supervisor Desktop.

n View an agent’s properties. Select an agent, and then click Open to view that agent’s record. You
can only view this record, not edit it.

6. Click Save to save your changes. At the top of the window a message appears, stating that the skill
group was saved successfully.
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Service Autorecovery
The service autorecovery feature allows Supervisor Desktop to automatically recover its connection to the
Cisco services in the event of a service restart or a network outage.

When Supervisor Desktop detects that it is unable to communicate with a service (generally within three
minutes of the service failure), the status bar displays “Partial Service” or “No Service” to indicate some or
all of the services have failed.

When Supervisor Desktop detects that the service is again available (usually within one minute of service
recovery), the status bar displays “In Service” to indicate that the services have recovered.

Note: In some situations, you will not recover your connection to Cisco Unified Presence and you
must log back into Unified Presence manually.

To learn more about what is affected by the service failure, double-click the status message on the status
bar. Supervisor Desktop displays a popup window that lists features and indicates if that feature is
available or not due to the service outage.

Phone Network Failure

In the event that an agent’s phone loses its connection to the network, the agent is automatically moved to
the Not Ready agent state, and will see a popup window displaying a message that the phone is out of
service.

The supervisor will see the change of agent state in the Agent ACD State Log report, along with the
“Device out of service” reason code (code 32759).
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The agent must drop any call he or she is on in order for the phone to reconnect to the network. If the
agent continues on a call, CADwill not be able to show the call’s actual length because it shows as
“terminated” in the system.

When the phone comes back into service, the agent will see the popup window display a message that
the phone is in service. The agent can then change the agent state back to Ready and resume taking
calls.
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