Cisco Unified Attendant Console Standard - Installation and Configuration Guide

Version 12.0.5
February 14, 2019

Cisco Systems, Inc.
www.cisco.com

Cisco has more than 200 offices worldwide. Addresses, phone numbers, and fax numbers are listed on the Cisco website at www.cisco.com/go/offices.

Text Part Number: OL-25987-01
CONTENTS

About This Guide i
Who Should Read This Guide i
How This Guide is Organized i
Document Conventions ii
Obtaining Documentation and Submitting Service Requests iii

CHAPTER 1
Introduction to Cisco Unified Attendant Console Standard 1-1
Accessibility for Users with Disabilities 1
Cisco Unified Attendant Console Standard User Interface 1-2
Accessing the Application Help Menu 1-2

CHAPTER 2
Installing Cisco Unified Attendant Console Standard 2-1
PC Hardware and Software Requirements 2-1
  Operating System Support 2-1
  Virtual Desktop Support 2-2
  Network Requirements 2-2
    Round Trip Time 2-3
  Virus Scan Exclusions 2-3
  Windows Folder Permissions 2-3
    Directory Contact Jabber Presence 2-3
Cisco Unified Communications Manager Compatibility 2-4
  Shared Lines and Extension Mobility 2-4
  Console User Devices and Lines 2-4
  Directory Contact Devices and Lines 2-5
Configure Cisco Unified Communications Manager 2-5
  Create an Access Control Group 2-6
  Assign Roles to an Access Control Group 2-6
  Create an Application User 2-7
  Assign Devices to Application User 2-7
  End User Account Required For Jabber Presence 2-8
Application Dial Rules 2-8
Install or Upgrade Cisco Unified Attendant Console Standard 2-9
License Cisco Unified Attendant Console Standard 2-11
Obtain Registration Code 2-11
Activate Evaluation Software 2-12
Activate Purchased and Upgraded Software 2-12
License Expiry 2-14
Relicense Software 2-14
Apply License 2-15
Obtain My Activations 2-15

CHAPTER 3
Starting Cisco Unified Attendant Console Standard 3-1
Starting Cisco Unified Attendant Console Standard 3-1
Accessing Cisco Unified Attendant Console Standard When There Are No Valid Devices 3-3
Signing Out 3-3
Logging In to Hunt groups 3-4
Logging Out of Hunt groups 3-4
Exiting Cisco Unified Attendant Console Standard 3-4

CHAPTER 4
Configuring Cisco Unified Attendant Console Standard 4-1
Preventing Access To Options Tabs 4-2
Making Options Tabs Accessible 4-2
Setting Operator Details 4-3
Configuring Single Sign-on 4-4
Configuring Presence Server 4-5
  Modifying Presence Server Connection Details 4-5
  Configuring Multi-Domain Presence Server 4-6
  Configuring Single Domain Presence Server 4-6
Changing Cisco Unified Communications Manager directory source details 4-7
  Primary Call Manager Detail 4-7
  Backup Call Manager Detail 4-7
  Setting the Operator Voicemail Prefix 4-8
Configuring Alerts 4-9
Managing Sign In Devices 4-10
  Manually Adding Sign In Devices 4-10
  Importing Sign In Devices 4-11
  Deleting Sign In Devices 4-11

CHAPTER 5
Directories 5-1
Contact Matching 5-2
Directory Synchronization 5-3
## Contents

Synchronizing From a CSV Source File  5-4
Configuring Synchronization  5-4

Directory Filtering  5-5
Creating Directory Filters  5-5

Directory Field Mappings  5-6
Destination Fields  5-6
Source Fields  5-7
Setting Directory Field Mappings  5-7

BLF Rules  5-7
Adding BLF Rules  5-8
Editing BLF Rules  5-9
Test All Rules  5-9
Deleting BLF Rules  5-10
Reordering BLF Rules  5-10

Directory Groups  5-11
Creating Directory Groups  5-11
Deleting Directory Groups  5-12
Renaming Directory Groups  5-12
Importing Contacts Into Directory Groups  5-13
Manually Adding Contacts To Directory Groups  5-14
Deleting Contacts From Directory Groups  5-15
Editing Contacts In Directory Groups and the Corporate Directory  5-15
Exporting Contacts From Directory Groups  5-16

Viewing and Using Directories  5-17
Changing the Directory Tab Order  5-18
Changing the Directory View  5-19
Changing what data columns are displayed and column order  5-19
Changing contact order  5-19
Searching For Contacts  5-20
Search Preferences  5-20
Viewing Contact Information  5-21

Contact Notes  5-22
Adding Contact Notes  5-22
Editing Contact Notes  5-22
Deleting Contact Notes  5-22

**Chapter 6**

Keyboard Shortcuts  6-1
Defining and Editing Keyboard Shortcuts  6-2
Removing Keyboard Shortcuts  6-3
Resetting Shortcuts to their Default Values  6-3

CHAPTER 7  
Uninstalling Cisco Unified Attendant Console Standard  7-1

APPENDIX A  
Application Log Configuration and Collection  A-1  
  Access the Logging Menu  A-1  
  Configuring Logging  A-1  
  Log Collection  A-2

APPENDIX B  
Import/Export File Formats  B-1  
  XML File Format  B-1  
  CSV File Formats  B-2  
    CSV Files for Synchronization  B-2  
    CSV Files for Directory Import and Export  B-3  
    CSV Files for Importing Sign In Devices  B-4

APPENDIX C  
Phones Supported by Cisco Unified Attendant Console Standard  C-1

APPENDIX D  
Troubleshooting Guide  D-1  
  CUCM Upgrade Version Must Match Installed Version  D-1

APPENDIX E  
Using a Cisco Unified Communications Manager TFTP server for all non-TAPI functions  E-1  
  New Installation Instructions  E-1  
  Update Cisco TSP Primary CTI Manager Address, Application User and Password  E-2

INDEX
About This Guide

This guide describes how to install and configure Cisco Unified Attendant Console Standard.

Who Should Read This Guide

This guide is for deployment engineers, system administrators, and anyone else who installs or configures Cisco Unified Attendant Console Standard. You should have a knowledge of how to configure the Cisco Unified Communications Manager used by the application.

How This Guide is Organized

This guide contains the following sections.

<table>
<thead>
<tr>
<th>Section</th>
<th>Contains</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1, “Introduction to Cisco Unified Attendant Console Standard”</td>
<td>Introduction to Cisco Unified Attendant Console Standard</td>
</tr>
<tr>
<td>Chapter 2, “Installing Cisco Unified Attendant Console Standard”</td>
<td>Preparing Cisco Unified Communications Manager and installing Cisco Unified Attendant Console Standard</td>
</tr>
<tr>
<td>Chapter 3, “Starting Cisco Unified Attendant Console Standard”</td>
<td>Starting Cisco Unified Attendant Console Standard and configuring operator details</td>
</tr>
<tr>
<td>Chapter 4, “Configuring Cisco Unified Attendant Console Standard”</td>
<td>Configuring Cisco Unified Attendant Console Standard, including managing sign in devices</td>
</tr>
<tr>
<td>Chapter 5, “Directories”</td>
<td>Using and controlling directories</td>
</tr>
<tr>
<td>Chapter 6, “Keyboard Shortcuts”</td>
<td>Setting up keyboard shortcuts</td>
</tr>
<tr>
<td>Appendix A, “Application Log Configuration and Collection”</td>
<td>Configuring application logging</td>
</tr>
<tr>
<td>Appendix B, “Import/Export File Formats”</td>
<td>Formats of import and export files</td>
</tr>
<tr>
<td>Appendix C, “Phones Supported by Cisco Unified Attendant Console Standard”</td>
<td>List of supported Cisco phones</td>
</tr>
</tbody>
</table>
Document Conventions

The following textual and typographic conventions are used in this document:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>bold</strong> font</td>
<td>Commands, keywords and user-entered text appear in <strong>bold</strong> type.</td>
</tr>
<tr>
<td><em>italic</em> font</td>
<td>Document titles, new or emphasized terms, and arguments for which you supply values are in <em>italic</em> font.</td>
</tr>
<tr>
<td>[]</td>
<td>Elements in square brackets are optional.</td>
</tr>
<tr>
<td>{x</td>
<td>y</td>
</tr>
<tr>
<td>[x</td>
<td>y</td>
</tr>
<tr>
<td>string</td>
<td>A non-quoted set of characters. Do not use quotation marks around the string or the string will include the quotation marks.</td>
</tr>
<tr>
<td><strong>courier</strong> font</td>
<td>Terminal sessions and information the system displays appear in <strong>courier</strong> font.</td>
</tr>
</tbody>
</table>

- **Note**
  
  Means reader take note.

- **Tip**
  
  Means the following information will help you solve a problem.

- **Caution**
  
  Means reader be careful. In this situation, you might do something that could result in equipment damage or loss of data.

- **Timesaver**
  
  Means the described action saves time. You can save time by doing what is described in the paragraph.

- **Warning**
  
  Means reader be warned. In this situation, you might do something that could result in bodily injury.
Obtaining Documentation and Submitting Service Requests


Subscribe to the *What’s New in Cisco Product Documentation* as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS Version 2.0.
Introduction to Cisco Unified Attendant Console Standard

Cisco Unified Attendant Console Standard is a Microsoft Windows-based attendant console application for use with Cisco Unified Communications Manager (CUCM).

For an overview of the application features and a list of new and changed features, refer to the Release Notes.

Accessibility for Users with Disabilities

The Cisco Unified Attendant Console Standard user interface and controls are described in Cisco Unified Attendant Console Standard User Interface, page 1-2.

Cisco Unified Attendant Console Standard incorporates the following features to make it easier for blind and visually impaired people to use it:

• Most functions can be accessed using either the mouse or keyboard. You can define keyboard shortcuts for the most frequently used functions. For more information, see Chapter 6, “Keyboard Shortcuts”.

• Set the size of call and directory text in the interface.

• A tooltip is displayed for each graphical interface control when the cursor is hovered over.

For more information on the Cisco Accessibility Program visit http://www.cisco.com/web/about/responsibility/accessibility/contact.html.
Cisco Unified Attendant Console Standard User Interface

The Cisco Unified Attendant Console Standard interface does all the standard operator tasks, including making calls, putting calls on hold and conferencing calls. The interface has the following main components.

<table>
<thead>
<tr>
<th>Component</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main menu</td>
<td>Controls for using and configuring the application. Many of these controls are also available when you right-click specific parts of the interface. For example, controls relevant to the directories are displayed when you right-click in the directory pane.</td>
</tr>
<tr>
<td></td>
<td>The extension used to sign in to the application. You can click this to sign out of the application, or to log into and out of hunt groups.</td>
</tr>
<tr>
<td>Call Control pane</td>
<td>Displays the active call information on any line on the console phone, including the call status and duration, and controls for frequently used actions, such as transferring or ending the call.</td>
</tr>
<tr>
<td>Parked Calls pane</td>
<td>Displays active parked calls, by default in the order in which they were parked. Parked call information includes the park extension used, the identities of both the caller and the DN that parked the call, and how long the call has been parked.</td>
</tr>
<tr>
<td>Call History pane</td>
<td>Displays calls completed in the current session, by default listed in reverse chronological order. You can change the order in which completed calls are listed. This pane is not displayed by default; use View &gt; Show Call History to display it.</td>
</tr>
<tr>
<td>Directory pane</td>
<td>Displays the synchronized directory, directory groups and search results. Contact information includes line state, presence and any notes. Includes the following controls:</td>
</tr>
<tr>
<td></td>
<td>- Search box for finding contacts by last name, first name, department and number.</td>
</tr>
<tr>
<td></td>
<td>- Click to configure how searches are conducted.</td>
</tr>
<tr>
<td></td>
<td>- Click to create a new directory group.</td>
</tr>
<tr>
<td></td>
<td>For more information on the Directory pane, see Viewing and Using Directories, page 5-17.</td>
</tr>
</tbody>
</table>

You control the interface using both your mouse and keyboard. Many things that you can do with the mouse you can also do using your keyboard, provided that the application interface is selected.

Accessing the Application Help Menu

To display the Cisco Unified Attendant Console Standard Help Menu, do one of the following:

- Select Help > Cisco Unified Attendant Console Standard Help.
- Press F1.
The Help menu tools to search the help content:

- Text search tool
- Index
- Contents list.
Installing Cisco Unified Attendant Console Standard

To install Cisco Unified Attendant Console Standard, do the following:

1. Validate that the PC satisfies the minimum hardware and software requirements. For more information, see PC Hardware and Software Requirements, page 2-1.

2. Within Cisco Unified Communications Manager, create an Access Control Group, Application User, and associate any user devices and contact devices required.
   If you are working in a non-SSO environment and intend to use the Presence facility within Cisco Unified Attendant Console Standard, you must also set up an End User, as described in End User Account Required For Jabber Presence, page 2-8. For more information about SSO, see Starting Cisco Unified Attendant Console Standard, page 3-1.

3. Install the Cisco Unified Attendant Console Standard software. For instructions, see Install or Upgrade Cisco Unified Attendant Console Standard, page 2-9.

PC Hardware and Software Requirements

Minimum hardware requirements:

- 2.4 GHz Core 2 Duo
- 4 GB RAM
- 10 GB available hard drive space
- 100 Mbps network card, connected to the same network as Cisco Unified Communications Manager using TCP/IP
- Monitor with a minimum resolution of 1440x900
- Keyboard with 10-key number pad
- Headset (recommended)

Operating System Support

Cisco Unified Attendant Console Standard is supported under the following operating systems:

- Windows 7 with SP1
- Windows 8.1 Update 1, v. 6.3.9600 or later
Chapter 2  Installing Cisco Unified Attendant Console Standard

PC Hardware and Software Requirements

- Earlier builds will need the update (KB2919355) applied prior to installing Cisco Unified Attendant Console
- Windows 10 (Desktop Mode)

For a summary of the operating systems and Cisco Unified Communications Manager versions compatible with Cisco Unified Attendant Console Standard, see the compatibility matrix in the Release Notes.

The following third party applications are required. If they are not installed on the PC prior to executing the Cisco Unified Attendant Console Standard installer, they will be automatically installed.

- Microsoft Visual C++ 2010 Redistributable
- Microsoft Visual C++ 2015 Redistributable
- Microsoft .NET Framework 4.6.1

**Note** During the installation of Microsoft Visual C++ 2010 and C++ 2015 Redistributable, the system may require a reboot. After the reboot, the installation will continue automatically.

Virtual Desktop Support

Cisco Unified Attendant Console Standard is not supported in any virtualized desktop environment such as Citrix, Horizon or VMware Workstations.

Network Requirements

Cisco Unified Attendant Console Standard is a client application within the Cisco Unified Communications Manager (CUCM) infrastructure, and does not establish any listeners, being only a consumer of CUCM services.

The computer running Cisco Unified Attendant Console Standard must support TCP/IPv4 and permit access to the Cisco Unified Communications Manager and the Cisco Unified IM&P Server/Cisco WebEx Messenger Server. By default, these connections leverage the following:

- Two-way TCP ports:
  - Cisco Unified Communications Manager – Port 443
  - Cisco Unified IM&P Server – Port 5222
  - Cisco WebEx Messenger Server – Port 5222
  - TSP – Port 2748
- Two-way UDP ports:
  - TSP Media Driver – Port range 50000-51019

If you have a firewall on your computer, you must configure firewall exceptions for these ports or for any alternatives you may use in your installation.

**Note** Consider the default dynamic port range appropriate to your computer’s operating system when defining firewall exceptions, as described at [https://support.microsoft.com/en-us/kb/832017](https://support.microsoft.com/en-us/kb/832017).
Round Trip Time

The maximum Round Trip Time (RTT) for TAPI communication between Cisco Unified Attendant Console Standard and Cisco Unified Communications Manager is 80ms. For more information, see the Cisco Solution Reference Network Design.

Virus Scan Exclusions

To prevent key system files from being quarantined by anti-virus software, add the following folders to the virus scan exclusions:

- \Program Files\Cisco\Cisco Unified Attendant Console Standard (under 32-bit operating systems)
- \Program Files (x86)\Cisco\Cisco Unified Attendant Console Standard (under 64-bit operating systems)
- \Users\<windows_user_name>\AppData\Roaming\CUACSLayout
- \ProgramData\CUACS

Windows Folder Permissions

The following folders require the permissions outlined below:

- \Program Files (x86)\Cisco\Cisco Unified Attendant Console Standard
  - Modify
  - Read & execute
  - List folder contents
  - Read
  - Write
  - Special permissions
- \Users\<windows_user_name>\AppData\Roaming\CUACSLLayout
- \ProgramData\CUACS

Directory Contact Jabber Presence

Cisco Unified Attendant Console Standard can retrieve Jabber presence status for directory contacts. You can leverage a single user account for multiple installations. We recommend that no more than 100 Cisco Unified Attendant Console Standard installations share a single user account.
Supported authentication methods:

- Cisco IM and Presence Server: supports Cisco Unified Communications Manager End User and Single Sign On (SSO) authentication
- WebEx Messenger Server: supports Cisco Unified Communications Manager End User authentication (support for Single Sign On authentication is on the product roadmap, but is not committed to a specific release at this time).

Cisco Unified Communications Manager Compatibility

The operating system and Cisco Unified Communications Manager (CUCM) version compatibility matrix is available in the Release Notes.

Shared Lines and Extension Mobility

Console User Devices and Lines

A shared line is any line that is presented on two or more devices.

Shared Lines on a Cisco Unified Attendant Console user's login device are supported, but with several caveats.

- The Call Control panel will only display active calls belonging to the device used to sign in to the application. However, the presence indicator belonging to the shared line within the Call Control panel will show line status across all instances of the line.
- Calls in a ringing state on the shared line will be presented within the Call Control panel.
- Held calls on the shared line will be presented within the Call Control panel, regardless of which device was used to place the call on hold.

For example:

- Device A and Device B both display extension 1000.
- User signs in to Cisco Unified Attendant Console Standard with Device A and sees extension 1000 presented in the Call Control panel.
- A call comes in to extension 1000 displaying as a ringing call within the console user’s Call Control panel.
- Device B answers the call. The call is no longer visible on the console user’s screen, but the console user’s extension 1000 presence indicator will show an active call.
- Device B places the call on hold. The call appears in the Call Control panel as a held call, which the console user can now resume if desired.
**Extension Mobility** allows users to temporarily use another phone as their own, during which time that phone adopts the user’s configuration profile.

Cisco Extension Mobility users must sign in to their device prior to launching Cisco Unified Attendant Console Standard. Extension mobility devices must be associated with the application user, just as any other supported end point.

If the requirement is to have multiple operators using Cisco Unified Attendant Console Standard to answer calls ringing into a single destination (for example, an office’s main phone number), rather than relying on Shared Lines for call distribution, configure a hunt group (where each operator has a unique directory number associated with the Line Group) in Cisco Unified Communications Manager, using **Hunt Pilot > Hunt Group > Line Group**. This will prevent call control race conditions that could arise when multiple answer requests for a single call are simultaneously sent to Cisco Unified Communications Manager, and which could result in one request being fulfilled while the others return call control failures.

**Directory Contact Devices and Lines**

Directory contact extensions that are shared with multiple devices and/or extension mobility profiles are supported but carry the following caveats:

- For a device to be eligible for BLF status monitoring, it must be listed as a Controlled Device against the Cisco Unified Attendant Console Standard Application User account. See Assign Devices to Application User, page 2-7 for device association instructions.

- Shared line and/or extension mobility BLF status extends to a single partition. If shared lines exist in multiple partitions, and all devices are assigned to the Application User, BLF status will be inaccurately presented within the contact directory.

- **Busy Lamp Field (BLF) Status** - Cisco Unified Attendant Console Standard will monitor a shared extension on a single, registered, device. Any activity on a shared line, regardless of the device being monitored, will impact BLF status. Device selection criteria consists of the following descending items:
  - Line Priority - devices are ranked based on the shared line position, with the line 1 position ranking the highest. If there is a tie, the next criteria is evaluated.
  - Device Name - devices are ranked alphanumerically, in ascending order.

- **Registration Status** - Cisco Unified Attendant Console Standard will monitor device registration status. If at any point a monitored device remains unregistered for 30 or more seconds, the device selection process will restart.

- **Do Not Disturb** is a device function, as opposed to a line state. Therefore, Do Not Disturb will only be presented in the contact directory, if the monitored device sets Do Not Disturb. Any other device, with the shared line, that enables Do Not Disturb will not impact contact directory BLF for any given shared line.

**Configure Cisco Unified Communications Manager**

Prior to installing Cisco Unified Attendant Console Standard, perform the following steps:

Create an Access Control Group

Access Control Groups define the roles and permissions available to the designated Application Users. To create an Access Control Group, do the following:

Step 1 Access Cisco Unified CM Administration.
Step 2 Select User Management > User Settings > Access Control Group.
Step 3 Click Add New.
Step 4 Type a Name.
Step 5 Click Save.

Assign Roles to an Access Control Group

Add roles to the Cisco Unified Attendant Console Standard Access Control Group by doing the following:

Step 1 Access Cisco Unified CM Administration.
Step 2 Select User Management > User Settings > Access Control Group.
Step 3 Search for the Cisco Unified Attendant Console Standard User Group.
Step 4 Click the Roles icon to the right of the group name.
Step 5 Click Assign Role to Group, and then click Find.
Step 6 Select the following roles:

- Standard AXL API Access
- Standard CCM Admin Users
- Standard CTI Allow Calling Number Modification
- Standard CTI Allow Call Park Monitoring
- Standard CTI Allow Control of All Devices
- Standard CTI Allow Reception of SRTP Key Material
- Standard CTI Enabled
- Standard Serviceability
- Standard CTI Allow Control of Phones supporting Connected Xfer and conf
- Standard CTI Allow Control of Phones supporting Rollover Mode

Note Any divergence from the noted roles will break the solution.
Step 7 Click *Add Selected* to assign the roles.

Step 8 Click *Save*.

### Create an Application User

An Application User connects Cisco Unified Attendant Console Standard to Cisco Unified Communications Manager using Cisco TSP and AXL.

- Each install requires an Application User with all console user devices and directory contact devices assigned to it.
- Multiple installs, using the same login devices and monitoring the same directory contact BLF states, require a single Application User with all console user devices and directory contact devices assigned to it.
- Multiple installs, using different login devices and/or monitoring different directory contact BLF states, require multiple Application Users. Each Application User user would have its unique subset of controlled devices.
- You can associate up to 5000 lines (not phones) with the Application User.

To create an Application User and assign it to the Access Control Group, do the following:

**Step 1** Access Cisco Unified CM Administration.

**Step 2** Select *User Management > Application User*.

**Step 3** Click *Add New*.

**Step 4** Enter information in the following fields:

- User ID
- Password
- Confirm Password

**Step 5** Under *Permissions Information*, select *Add to Access Control Group*.

**Step 6** Search for and select the Cisco Unified Attendant Console Standard *Access Control Group*, and then click *Add Selected*.

**Step 7** Click *Save*.

### Assign Devices to Application User

To sign in to Cisco Unified Attendant Console Standard and monitor Busy Lamp Status of directory contacts, the following related devices must be assigned to the Application User:

- The operator device
- Contact devices - so that you can see their line states in the directory
Refer to **Scalability** in the *Release Notes* to determine the maximum number of devices that can be assigned to Cisco Unified Attendant Console Standard Application User(s).

To associate devices with an Application User, do the following:

**Step 1**  Access Cisco Unified CM Administration.

**Step 2**  Select **User Management > Application User**.

**Step 3**  Search for the Cisco Unified Attendant Console Standard **Application User**, and then click the **User ID**.

**Step 4**  Under **Device Information**, find **Available Devices** and click **Device Association**.

**Step 5**  Search for and then select all relevant devices.

**Step 6**  Click **Save Selected/Changes**.

---

### End User Account Required For Jabber Presence

Configuring the Cisco IM&P or WebEx Messenger Presence source for each install requires an End User account with presence enabled. This section pertains only to those installs that intend to present Jabber presence status within the Cisco Unified Attendant Console Standard contact directory.

If the Cisco Unified Attendant Console Standard users already have End User accounts configured against the presence sources, there is no requirement to create new accounts.

Supported authentication methods:

- Cisco IM and Presence Server: supports Cisco Unified Communications Manager End User and Single Sign On (SSO) authentication
- WebEx Messenger Server: supports Cisco Unified Communications Manager End User authentication (support for Single Sign On authentication is on the product roadmap, but is not committed to a specific release cycle at this time).

---

### Application Dial Rules

Cisco Unified Communications Manager uses Application Dial Rules to add or remove digits from dialed numbers. Cisco Unified Attendant Console Standard these synchronizes the rules from Cisco Unified Communications Manager at login. Application Dial Rules are applied to all outbound calls initiated by the user via the client.

If there are multiple rules, they are executed in order as defined in Cisco Unified Communications Manager. If the login synchronization fails, dial rules will not be applied.

During rule synchronization:

- New rules are added to the client repository.
- Existing rules in the client repository are updated as required.
- Rules deleted at a source level are removed from the client repository.
Install or Upgrade Cisco Unified Attendant Console Standard

These instructions apply to new installs and in-place upgrades. To execute an in-place upgrade, the upgrade version installer can be executed without uninstalling the existing version.

When upgrading from one major version to another (for example, from version 11.x to 12.x), licensing resets to a 10-day evaluation license. For further licensing instructions, see License Cisco Unified Attendant Console Standard, page 2-11.

Cisco Unified Attendant Console Standard requires .NET framework 4.0 to run. If .NET framework 4.0 has not been supplied or configured before installation, the installation wizard installs and configures it for you.

To install Cisco Unified Attendant Console Standard, do the following:

**Step 1** Confirm Cisco Unified Communications Manager compatibility. For more information, see Cisco Unified Communications Manager Compatibility in the Release Notes.

**Step 2** Confirm that the Application User roles and device assignments align with the requirements described in Configure Cisco Unified Communications Manager, page 2-5.

**Step 3** Log in to the Windows PC as a user with local administrator rights.

**Step 4** Launch CUACS_Setup.exe.

The installation wizard appears.

**Step 5** In the Welcome page, click Next.

**Step 6** In the Cisco Unified Communications Manager Connection Details page, type the following:

- **Cisco Unified Communications Manager Host Name**, Fully Qualified Domain Name (FQDN) or IP address
- **Cisco Unified Communications Manager Application User ID**
- **Password**

Click Next.

**Note** The following:

- Port 443 is used by default. The Cisco Unified Communications Manager configuration can be changed following the installation. For instructions, see Changing Cisco Unified Communications Manager directory source details, page 4-7.
Install or Upgrade Cisco Unified Attendant Console Standard

Chapter 2      Installing Cisco Unified Attendant Console Standard

Step 7 In the two Security Alert messages, click Yes.

Note During installation the Cisco Unified Communications Manager TSP appropriate to the Cisco Unified Communications Manager you intend to use is downloaded and installed.

Step 8 In the Language Information page, select the required language, and then click Next.

Step 9 In the Cisco Unified Presence Server Connection Information page, type the following:

- The Server Address of the Cisco IM&P or WebEx Messenger presence server.
- The Domain containing the server
- The Cisco Unified Presence User Name
- The Cisco Unified Presence Password

Click Next.

Note The following:

- If you are working in a Cisco Single Sign On (SSO) environment, the SSO End User provides the Presence information, and the User defined here is not used.
- Port 5222 is used by default. You can change the Presence configuration after you have installed Cisco Unified Attendant Console Standard. For instructions, see Configuring Presence Server, page 4-5.
- The Presence credentials are stored in the configuration file using AES-256 encryption.

Step 10 In the Choose Destination Location page, either accept the default folder (recommended) or Browse to the folder in which to install the application, and then click Next.

Step 12 In the Start Copying Files page, if the details are correct, click Next. If not, click Back and correct the information.

Cisco Unified Attendant Console Standard is installed.

Step 13 In the InstallShield Wizard Complete page, select Yes, I want to restart my computer now, and then click Finish.
License Cisco Unified Attendant Console Standard

This section describes how to license Cisco Unified Attendant Console Standard software.

This section contains the following topics:

- Obtain Registration Code
- Activate Evaluation Software
- Activate Purchased and Upgraded Software
- Relicense Software
- Apply License
- Obtain My Activations

Obtain Registration Code

As a local administrator, sign in to each instance of Cisco Unified Attendant Console Standard that you want to license and activate, and do the following:

**Step 1** Choose Help > About Cisco Unified Attendant Console Standard.
If the application is licensed, the Registration Code is shown in the About Cisco Unified Attendant Console Standard box.

**Step 2** Click Register.

**Step 3** Note the Registration Code.

Tip

Users are encouraged to keep record of the registration code(s) and identifying information of the PC(s) they belong to. These codes will be subsequently used to obtain permanent licensing and will be required for any subsequent major upgrades.
Activate Evaluation Software

The software installs with a 10-day evaluation period. You have the option to extend the evaluation period to 60 days. Once the evaluation period has elapsed, the console becomes inoperable until a permanent license is applied.

**Note**
Evaluation licenses cannot be extended or reset.

To obtain and apply the 60 day evaluation license, do the following:

**Step 1** Navigate to the *Cisco Unified Attendant Console Downloads and Licensing* website.

**Step 2** Enter your **User Name** and **Password**, and then click **Log In**.

**Step 3** In the navigation bar, click **ACTIVATE EVALUATION SOFTWARE**.

**Step 4** Select **Customer**, and then select the **Customer Site**.

**Note** If **Customer** or **Customer Site** do not exist, select the **Add** button, and then follow the on-screen prompts to add a new entry.

**Step 5** Select the applicable **Version** and the **Product**, and then click **Next**.

**Step 6** Enter the **Registration Code(s)** collected previously, and then click **Next**.

**Note** Click to create new fields for additional Registration Codes.

**Step 7** Enter any additional email addresses where you want to receive the registration file. Separate multiple addresses with a comma, for example: jane.doe@cisco.com,john.doe@cisco.com. Then click **Submit**.

A registration (RGF) file is e-mailed to you. The RGF file contains activation keys and serial numbers for the 60 day evaluation period. The RGF file needs to be attached to each of the Cisco Unified Attendant Console Standard workstations whose registration codes were provided in the previous step.

**Step 8** Open the email and save the RGF file to a location that can be browsed by Cisco Unified Attendant Console Standard. See **Apply License**, page 2-15 to learn how to apply the obtained license file.

Activate Purchased and Upgraded Software

Once Cisco processes your order, you are provided with a PDF file containing one (or more) 27-digit **License Activation Code (LAC)**.

**Note** Once you activate a permanent license, you cannot revert to a trial license.

Note the following details regarding major upgrades:

- Prior to executing the upgrade, ensure you have the existing registration and license activation codes available. Place the order and await fulfillment of the upgrade licenses, prior to executing the upgrade. Proceeding as advised will eliminate any risk of licensing conflicts.
Performing a major upgrade will require the following, based on your license type:

- Standard License type: Requires the existing license activation details (registration code and license activation code) and a new upgrade license activation code which is version-specific.
- Term Based License type: Reapply the existing license file following installation of the upgrade software. See Obtain My Activations, page 2-15 to learn how to obtain a copy of any previous activation files.

**Note**
If you have purchased "à la carte" upgrade licenses, or requested UCSS upgrade LAC, note the following: Before proceeding with the activation of the upgrade license(s), ensure that the previous version's 27 digit LAC(s) have been activated, and that you have access to the LAC(s) and the respective Registration Code(s) as this information may be required to successfully activate the upgrade licenses.

To activate your purchased or upgraded software, do the following:

**Step 1** Navigate to the Cisco Unified Attendant Console Downloads and Licensing website.

**Step 2** Enter your User Name and Password, and then click Log In.

**Step 3** In the navigation bar, click ACTIVATE PURCHASED SOFTWARE.

**Step 4** Select Customer, then click Choose Selected Customer.

**Step 5** Select Customer Site, then click Choose Selected Site.

**Note** If Customer or Customer Site do not exist, select the Add button, and then follow the on-screen prompts to add a new entry.

**Step 6** Select a License Type, then select Choose selected license type.

- **Standard License** refers to all upgrade licenses and perpetual licenses. Proceed to Step 7.
- **Term Based License** refers to Enterprise Agreement flexible term licenses. Proceed to Step 8.

**Step 7** This step only applies to Standard license types.
Select the Version and the Product (Cisco Unified Attendant Console Standard) that you have installed, and then click Next.

**Step 8** Enter a unique Registration Code (one of the machine codes collected on page 2-12) and License Activation Code pair for each instance, and then click Next.

**Note** Click to create new fields for any additional pairs of codes.

**Step 9** This step only applies to Upgrade Licenses.
Activating upgrade licenses requires the license activate code(s) or registration code(s) associated with the activation of the prior version. Input this data when prompted.

**Step 10** In the License Request Confirmation page, provide an additional e-mail address(es) (separate multiple addresses with a comma) and click Submit.
A registration (RGF) file is e-mailed to you and any provided additional address(es). License request confirmation information is displayed in the web page.
Step 11 Open the email and save the registration file to a location that can be browsed by Cisco Unified Attendant Console Standard. See Apply License, page 2-15 to learn how to apply the obtained license file.

License Expiry

Beginning 30 days prior to license expiration date, Cisco Unified Attendant Console Standard will display the following license status alerts and warnings:

- 30 days prior to and the day of expiration:
  - Application Title bar: *License expires in X days.*

- 30-day grace period, beginning the day after the expiration date:
  - At application launch: *License expired on MM/DD/YYYY. Request that your System Administrator applies a new license before MM/DD/YYYY to avoid service interruption.*
    
  - Application Title bar: *License expired.*
  
  - In the Help > About Cisco Unified Attendant Console Standard box: *X-year subscription expired. Apply new license within Y day(s) to avoid service interruption.*

For more information on applying a license, see Apply License, page 2-15.

Relicense Software

The following scenarios may remove the license from your install or change the Cisco Unified Attendant Console Standard registration code. In the event the registration code is changed, the existing license will need to be reset and subsequently activated against the new registration code.

Prior to executing any of the following actions, retrieve the existing registration code from the console client Help > About menu.

- Reinstall the operating system on the same hardware
- Install a different operating system on the same hardware
- Add or remove certain hardware (such as an NIC card)
- Change the machine name (join or leave a domain)

To reset the Cisco Unified Attendant Console Standard license, contact Cisco TAC and request a re-host. You will need to provide them with any combination of the original license activation codes, the SO number of your purchase, or the original Cisco Unified Attendant Console Standard registration code.

Once the license(s) have been reset by Cisco TAC, you can proceed with activating them against the new registration code(s), using the instruction provided under Activate Purchased and Upgraded Software, page 2-12.
Apply License

Step 1
In Cisco Unified Attendant Console Standard, do one of the following:
- In the main menu, choose Help > About Cisco Unified Attendant Console Standard.
- Use Open About Box keyboard shortcut (user-defined).

Step 2
In the message box, click Register.

Step 3
In the License dialog box, either:
  a. Select File Registration.
  b. Browse to the RGF file.
  c. Click Validate.

or – if you know details of the license for the specific instance you are licensing
  a. Select Key Registration.
  b. Type an activation key Serial Number, which is included with the license in the RGF file.
  c. Type the corresponding Registration Code.
  d. Click Register.

Obtain My Activations

Step 1
Navigate to the Cisco Unified Attendant Console Downloads and Licensing website at cisco.com/go/ac.

Step 2
Enter your User Name and Password that was used to originally activate the product licenses.

Step 3
From the left navigation pane, select My Activations or My 60 Day Activations.

Step 4
Locate and select the license file(s) you require.

Step 5
Provide any additional email addresses to send the files to, separating multiple addresses with a comma.

Step 6
Select Resend.
Starting Cisco Unified Attendant Console Standard

To start the Cisco Unified Attendant Console Standard client:

**Step 1**
Double-click the desktop icon.
A splash screen appears.

**Step 2**
If one of the following is true:
- You are working in a non-SSO environment
- You are working in an SSO environment but have not yet configured Cisco Unified Attendant Console Standard to use it (how to configure the application is described in Configuring Single Sign-on, page 4-4)
- You have configured Cisco Unified Attendant Console Standard to use the SSO environment and have already logged into it through another application, such as Jabber

the Cisco Unified Attendant Console Standard Sign In screen appears, containing either the number of the last attendant phone used to sign in, or the text *Extension*, showing that you need to enter an attendant phone number. Continue at **Step 3**.

Alternatively...
If you are working in an SSO environment, but have not yet logged into any Cisco Unified Communications application, do the following:

a. If security alerts are displayed, click **Yes** in each.

b. In the SSO credentials web page, enter your **User Name** and **Password**, and then click **Log In**.

**Note**
If the login details are invalid, a message appears and the application closes. Either try to log in again using correct SSO details, or contact your network administrator.

The Cisco Unified Attendant Console Standard Sign In screen appears, containing either the number of the last attendant phone used to sign in, or the text *Extension*, showing that you need to enter an attendant phone number.

**Step 3**
In the Cisco Unified Attendant Console Standard Sign In screen:
To use the number in the field, proceed to **Step 4**.
Starting Cisco Unified Attendant Console Standard

To use a new extension number:

a. Type the number into the field. As you type, the application lists those devices available for signing in that match the number (for more information on defining devices, see Managing Sign In Devices, page 4-10). The more you type, the shorter the list becomes. The list contains the name and extension number for each matching device.

Note
If the Device List under the File > Options > Device List tab is empty, all devices associated with the application user are available for signing in to Cisco Unified Attendant Console Standard. For more information, see Assign Devices to Application User, page 2-7.

If the Device List contains one or more devices, you can sign in using one of them. If all the devices in the Device List are invalid, you will be unable to sign in without the assistance of a system administrator, as described in Accessing Cisco Unified Attendant Console Standard When There Are No Valid Devices, page 3-3.

b. Select a number in the list by either double-clicking it, or by highlighting it and then pressing Enter. You can close the list and clear the selection by pressing Esc.

Step 4
If the sign in extension is part of one or more hunt groups, and you want the application to log you into them during sign in, select Log in to hunt groups at sign in.

Note
The following:

• If you are already logged into your hunt groups, you do not need to set Log in to hunt groups at sign in.
• You cannot log in to a hunt group using an extension that is already being used by another Cisco Unified Attendant Console Standard user.

Step 5
Click Sign In or press Enter.

The number you are trying to sign in with is checked against the list of valid extensions.

Step 6
Depending on the devices available, you may need to do one of the following

• If there are no valid devices a message is displayed requesting that you contact your system administrator, who will create a valid device following the procedure in Accessing Cisco Unified Attendant Console Standard When There Are No Valid Devices.
• If several valid devices have the same extension number, or if one or more valid devices has multiple lines, a list of the devices and lines is displayed. Select the device and line to use, and then click OK.

The main application user interface appears, ready for you to use.

If there was no device list and you entered the extension number of a valid Cisco device, that device and all its lines is added to the device list.

Note
If the partition of the line used to sign into the console is changed while the console is in use, the user must sign out and sign back in to the console.

While the application is running, you can change the attendant console operator directory number (DN), as described in Setting Operator Details, page 4-3.
Accessing Cisco Unified Attendant Console Standard When There Are No Valid Devices

If there are no valid devices in the Device List, the system administrator must create at least one or clear the Device List.

To access Cisco Unified Attendant Console Standard when no valid device is available in the Device List, the system administrator must do the following:

**Step 1**
In the Sign In screen invalid extension message, click **Administrative Override**.

**Note**
The **Administrative Override** link appears only when there is a Device List containing at least one device.

**Step 2**
Do one of the following:

- When an Options Password has *not* been set, the Options window appears, with the **Device List** tab displayed.
  
  Add one or more new devices, as described in *Manually Adding Sign In Devices*, page 4-10, or clear all devices from the list.

- When an Options Password *has* been set, the Options window appears, with the **Options Password** tab displayed.
  
  a. Make the Device List tab accessible as described in *Making Options Tabs Accessible*, page 4-2.
  
  b. Add one or more new devices, as described in *Manually Adding Sign In Devices*, page 4-10, or clear all devices from the list.

**Step 3**
Close the Options window.

**Signing Out**

To sign out an attendant console session, do either of the following:

- In the main menu, click the extension number at the top right of the interface, and then select **Sign out of application**.

- Use the **Ctrl+S** keyboard shortcut.

The sign in screen is displayed.

**Note**
- Active synchronizations of the directory at the time of sign out will continue in the background unless the application is closed.

- At sign out, active hunt group logins are logged out.
Logging In to Hunt groups

A hunt group is a group of extensions configured so that an unanswered call to any extension gets forwarded to one of the other lines in the group. Cisco Unified Communications Manager supports hunt groups, and Cisco Unified Attendant Console Standard enables you to sign in using a device that is part of one or more hunt groups, so that calls to the groups can be received through your operator phone.

If you are logged out from any hunt groups you will not receive any calls through the groups.

If you are not logged in to the hunt groups of which your extension is part, you can either log in to them when you sign in to the application (as described on page 3-2), or you can click the extension number at the top right of the interface, and then select Login to hunt groups.

While you are logging in to the hunt group (which may take a few seconds) you will not be able to receive any new calls, but current calls will continue unaffected, and you will be logged in at the end of the current call.

Logging Out of Hunt groups

If you are logged in to a hunt group, to log out do either of the following:

- Click the extension number at the top right of the interface, and then select Log out of hunt groups.
- Use the Ctrl+I keyboard shortcut.

When you sign out, you are automatically logged out of any hunt groups to which you belong.

While you are logging out you cannot take calls, but current calls will continue unaffected. You will be logged out at the end of the current call.

Exiting Cisco Unified Attendant Console Standard

To exit Cisco Unified Attendant Console Standard, do one of the following:

- In the main menu, choose File > Exit.
- Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard Shortcuts, page 6-2.
- Click the window close button.
Configuring Cisco Unified Attendant Console Standard

This chapter describes how to configure Cisco Unified Attendant Console Standard.

All the configuration functions are contained within tabbed pages of the **Options** window, which you access by choosing **File > Options**. You can password-protect the following Options tabs:

- Directory Filters
- Directory Mappings
- BLF Rules
- Device List
- Logging

Enabling password protection is described in **Preventing Access To Options Tabs**, page 4-2; disabling it is described in **Making Options Tabs Accessible**, page 4-2.

This chapter also describes the following configuration procedures:

- **Setting Operator Details**
- **Configuring Single Sign-on**
- **Configuring Presence Server**
- **Changing Cisco Unified Communications Manager directory source details**
  - Primary Call Manager Detail
  - Backup Call Manager Detail
- **Setting the Operator Voicemail Prefix**
- **Configuring Alerts**
- **Managing Sign In Devices**

For details of configuring synchronization with Cisco Unified Communications Manager, see **Configuring Synchronization**, page 5-4.

For details of moving, stretching and hiding parts of the interface, see the *Cisco Unified Attendant Console Standard Help*. 
Preventing Access To Options Tabs

In the application’s default state, all the Options tabs are accessible by any user. You can use the *Options Password* to prevent access to the password-protected Options tabs listed on page 4-1.

To prevent access to the password-protected Options tabs:

**Step 1** In the main menu, choose **File > Options**.

The *Options* window appears.

**Step 2** Click the *Options Password* tab.

**Step 3** Select *Password Protection*.

**Step 4** Type the *Application Password* (the Cisco Unified Communications Manager Application User password specified in the *CUCM Configuration* tab, as described in Changing Cisco Unified Communications Manager directory source details, page 4-7).

**Step 5** Click *Apply*.

**Step 6** Click *Cancel* to close the Options window.

The password-protected Options tabs are now inaccessible.

Making Options Tabs Accessible

You can regain access to the Options tabs listed on page 4-1 by entering the correct Options Password.

To regain access to the password-protected Options tabs:

**Step 1** In the main menu, choose **File > Options**.

The *Options* window appears.

**Step 2** Click the *Options Password* tab.

**Step 3** Type the *Application Password* (the Cisco Unified Communications Manager Application User password specified in the *CUCM Configuration* tab, as described in Changing Cisco Unified Communications Manager directory source details, page 4-7).

**Step 4** Click *Authenticate*.

If you have entered the password incorrectly, the *Application Password* field is highlighted, otherwise the *Password Protection* and *Application Password* controls appear.

You now have temporary access to the password-protected Options tabs, and you can make and apply changes to their settings. To keep the Options tabs password-protected after you finish modifying the settings, click *Cancel* to close the Options window, and then skip the rest of this procedure.

**Step 5** Clear *Password Protection*.

**Step 6** Type the *Application Password*. 
Chapter 4  Configuring Cisco Unified Attendant Console Standard

Setting Operator Details

You set your operator details either when you start Cisco Unified Attendant Console Standard or while it is running.

To set the operator details while Cisco Unified Attendant Console Standard is running, do the following:

**Step 1**  In the main menu, choose **File > Options**.

The **Options** window appears.

**Note**  You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2**  Click the **Operator Details** tab.

**Step 3**  Under **Operator Details**, type the **Extension** of the attendant console operator.

**Note**  If a **Device List** is defined (see Managing Sign In Devices, page 4-10), the same restrictions as on the sign in extension apply, but the list is not displayed when you start typing.

**Step 4**  Click **Apply**.

---

**Step 7**  Click **Apply**.

**Step 8**  Click **Cancel** to close the Options window.

Password protection is disabled and all the Options tabs are now accessible.

---

**Note**  If you forget the Options Password, you can either:

- Change the password of the existing Cisco Unified Communications Manager Application User
- Create a new Application User with a new password

and then validate the credentials under the CUCM Configuration tab, and enter the new password under the Options Password tab.
Configuring Single Sign-on

Cisco Single Sign On (SSO) is a facility designed to help users who run multiple Cisco Unified Communications applications in a work session. Once a user signs in to any one configured application, they do not need to subsequently sign in to other applications.

Cisco Unified Attendant Console Standard supports the following single sign-on Identity Providers:

- Microsoft Active Directory Federation Services (ADFS)
- OpenAM
- Ping

Leveraging Single Sign-On authentication introduces the following user experiences:

- SSO runs for a configurable length of time. If the session expires while Cisco Unified Attendant Console Standard is running, the user is prompted to re-authenticate.
- The application will not start until the user authenticates via SSO.
- If a user signs in using SSO for another Cisco Unified Communications application, prior to launching Cisco Unified Attendant Console Standard, the user will not be prompted to sign in again.
- If a user has not previously signed in to another Cisco Unified Communications application, prior to launching Cisco Unified Attendant Console Standard, the user will presented with a SSO login screen.

To configure Single Sign On, do the following:

**Step 1**
In the main menu, choose **File > Options**.

The **Options** window appears.

**Note**
You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2**
Click the **Operator Details** tab.

**Step 3**
Under **Presence Details**, select **Use Single Sign-On**.

**Note**
The following:

- If Cisco Unified Attendant Console Standard is running in a non-SSO environment, this control is disabled.
- If you have already entered valid SSO credentials, this control will already be selected.
- You do not need to click **Apply** to save and apply the **Use Single Sign-On** setting.

To stop using Cisco Unified Attendant Console Standard with SSO, repeat the above procedure but clear **Use Single Sign-On**. If you want to display Presence information outside of the SSO environment, you must define which Presence Server to use, as described in the next section.
Configuring Presence Server

Modifying Presence Server Connection Details

To add or modify Cisco Presence server connection details, do the following:

---

**Step 1**
In the main menu, choose **File > Options**.
The **Options** window appears.

**Note**
You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2**
Click the **Operator Details** tab.

**Step 3**
Under **Presence Details**, edit the following as required:

- **Select or clear Use Single Sign-On**.
  - This control is disabled if Cisco Unified Attendant Console Standard is not running in a SSO environment. Select this to use the End User accessed through the SSO login web page to provide Presence information.

**Note**
Single Sign-On is not supported for WebEx Messenger presence sources.

- **Presence Server Address** or URL required for hosted presence.
- **Presence Server Port** number. By default, this is 5222.
- **Domain** containing the Presence Server:
  - Configuring Multi-Domain Presence Server, page 4-6
  - Configuring Single Domain Presence Server, page 4-6
- **Presence Server User** name.
  - If you are using SSO, this will be the user name chosen for SSO validation, and you will be unable to edit it.
- Corresponding user **Password**.
  - If you are using SSO, this will be blank and you will not be able to edit it.

**Note**
The Presence credentials are stored in the configuration file using AES-256 encryption.

**Step 4**
Click **Apply**.
The application validates the connection. If this fails, it prompts you for the correct connection details.

**Step 5**
Perform a search to refresh the contact and display the correct presence state.
Configuring Multi-Domain Presence Server

If your Presence server supports multi-domains, do the following:

**Step 1**  
In the main menu, choose **File > Options**.  
The Options window appears.

**Step 2**  
Click the **Operator Details** tab.

**Step 3**  
Under **Presence Details**, edit the following:
- Delete the **Domain** value.
- Type the **User ID** (formatted as full URI).

**Note**  
Contact **User** IDs must be formatted as full URIs. Subscription request will pass the unmodified contact URI to the Presence Server.

Configuring Single Domain Presence Server

If your Presence server supports a single domain, do the following:

**Step 1**  
In the main menu, choose **File > Options**.  
The Options window appears.

**Step 2**  
Click the **Operator Details** tab.

**Step 3**  
Under **Presence Details**, edit the following:
- Type the **Domain** value.
- Type the **User ID** without affixing the domain.

**Note**  
Cisco Unified Attendant Console Standard will affix the specified domain to unmatched contacts. For example:

- Configured Domain = cisco.com
- Contact User ID in directory = john.doe@acme.com
  
  Subscription request will be made for john.doe@acme.com@cisco.com.

- Configured Domain = cisco.com
- Contact User ID in directory = john.doe@cisco.com
  
  Subscription request will be made for john.doe@cisco.com.
Changing Cisco Unified Communications Manager directory source details

**Note**
- Cisco Unified Communications Manager version must match the existing version.
- Certain menus may require a password to unlock. For more information, see Preventing Access To Options Tabs, page 4-2.

### Primary Call Manager Detail

To change the Cisco Unified Communications Manager directory source details, do the following:

**Step 1**
In the main menu, choose **File > Options**.

The **Options** window appears.

**Step 2**
Click the **CUCM Configuration** tab.

**Step 3**
Under **Primary Call Manager Detail**, edit the following as required:
- The Cisco Unified Communications Manager **Server Address**.
- The Cisco Unified Communications Manager **Port** number. By default, this is 443.
- The Cisco Unified Communications Manager **Application Username**. The Application User must have the roles described in Assign Roles to an Access Control Group, page 2-6.
- The **Application Password** that corresponds with the Username.

**Note**
The Cisco Unified Communications Manager credentials are stored in a database using AES-256 encryption.

**Step 4**
Click **Apply**.

If the new CUCM version does not match the currently configured CUCM version, a warning message appears.

**Step 5**
Exit and then restart Cisco Unified Attendant Console Standard for the changes to take effect.

### Backup Call Manager Detail

Setting up backup Call Manager details is optional. If you set up a backup CUCM, Cisco Unified Attendant Console Standard will still prioritize the primary CUCM, but will attempt to connect to the backup if the primary is unavailable.

If you do not want to use it, leave the **Server Address** field empty. Otherwise, do the following:

**Step 1**
In the main menu, choose **File > Options**.

The **Options** window appears.

**Step 2**
Click the **CUCM Configuration** tab.
Step 3  Under **Backup Call Manager Detail**, edit the following as required:
- The Cisco Unified Communications Manager **Server Address**.
- The Cisco Unified Communications Manager **Port** number. By default, this is 443.
- The Cisco Unified Communications Manager **Application Username**. The Application User must have the roles described in **Assign Roles to an Access Control Group, page 2-6**.
- The **Application Password** that corresponds with the Username.

**Note**  The Cisco Unified Communications Manager credentials are stored in a database using AES-256 encryption.

Step 4  Click **Apply**.

If the new CUCM version does not match the currently configured CUCM version, a warning message appears.

Step 5  Exit and then restart Cisco Unified Attendant Console Standard for the changes to take effect.

---

### Setting the Operator Voicemail Prefix

**Note**  Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see **Preventing Access To Options Tabs, page 4-2**.

If your operator uses a separate voicemail number, you define its prefix.

To set the operator voicemail prefix, do the following:

**Step 1**  In the main menu, choose **File > Options**.

The **Options** window appears.

**Note**  You can configure a keyboard shortcut to do this. For instructions, see **Chapter 6, “Keyboard Shortcuts”**.

**Step 2**  Click the **CUCM Configuration** tab.

**Step 3**  Under **Transfer to Voicemail Option**, type the attendant console operator **Voicemail Prefix**.

**Step 4**  Click **Apply**.
Configuring Alerts

Cisco Unified Attendant Console Standard alerts you when the following events occur (listed in order of precedence):

1. Call is ended (not by console)
2. Device is in service (the console device)
3. Call is ringing at primary device
4. Call is ringing at secondary device
5. Device is out of service (the console device)
6. A system error has occurred

If two or more alerts occur simultaneously, you are alerted about the one with the highest precedence.

Cisco Unified Attendant Console Standard can produce the following visual alerts:

- If the application is not the active window, it becomes the active window and is placed in front of any other open window, ready for you to interact with it.
- If the application is not the active window, then in the Windows taskbar the application icon flashes.

To configure alerts, do the following:

**Step 1** In the main menu, choose File > Options.

The Options window appears.

>Note
You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2** Click the Alerts tab.

**Step 3** Under Alerts Detail, for each event, do the following:

- Select the Taskbar check box if you want the application icon in the Windows taskbar to flash when that event occurs.
- Select the Pop to Front check box if you want the application window to be displayed in front of all others on the desktop when it is minimized to the taskbar or hidden at the time of the event.

**Step 4** Click Apply.
Managing Sign In Devices

Attendants can only sign in to Cisco Unified Attendant Console Standard using a valid Cisco device, with a device name, extension and line number. For attendants to be able to make calls, the device must also be associated with the Application User/End user configured in the Cisco TSP.

System administrators define which devices are available for attendants to use; these devices constitute the Device List, which is accessible using File > Options > Device List. At start-up and during execution, the application checks whether the devices in the Device List are associated with the Application User/End User configured in the Cisco TSP.

- If they are not, they are marked as invalid. These have a lighter color in the list, and attendants cannot make calls using them.
- If they were previously marked as invalid, but are now associated with the Application/End user, they are marked as valid, and attendants can make calls using them.

Administrators can either manually add devices to the list, or import them from CSV files.

While importing sign in devices from a CSV file, the application checks that each device is associated with the Application/End User configured in the Cisco TSP. If a device is not associated, it is shown as invalid in the Device List.

If additional lines are later associated with a sign in device (using Cisco Unified Communications Manager), they get added to the Device List. After these changes, attendants will still be able to sign in using the old extension.

Manually Adding Sign In Devices

Note

Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

To manually add devices:

Step 1
Choose File > Options > Device List.

The Device List appears.

Step 2
Under Device List, click Add Devices.

Step 3
In Search Devices, type a device name. All devices matching what you type are listed; and the more characters you type, the shorter the list becomes. Non-Cisco devices are not listed.

Step 4
For each device you want to add, select the Add checkbox.

Note
If there are multiple lines on the selected device, all the lines are selected and added to device list.

Step 5
Click Apply.

The devices are added to the Device List.
**Importing Sign In Devices**

**Note** Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

You can import sign in devices from a CSV file with the format described in CSV Files for Importing Sign In Devices, page B-4.

To import devices from a CSV file:

**Step 1** Choose File > Options > Device List.

**Step 2** Under Import From CSV, click Browse and select the file to import.

The file name and path are displayed under File Location.

**Note** If you click View Sample you can view the required format of the CSV file for importing login devices.

**Step 3** Click Import Devices.

The file format is validated, and if any devices in the file are non-Cisco, you are informed that they will no be imported, and then you are prompted to continue. To import the Cisco devices from the file, click Yes. To abort the process, click No.

The devices are imported and added to the Device List. As the devices are imported, they are checked against those already listed and any matching devices are ignored.

**Deleting Sign In Devices**

**Note** Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

To remove devices:

**Step 1** Choose File > Options > Device List.

In the Device List, click the corresponding X in the Delete column.

**Note** If a device has multiple lines, all are deleted from the list. The device remains in the database.

**Step 2** In the confirmation message, click Yes.
Directories

Cisco Unified Attendant Console Standard displays one or more directories of contacts. Always displayed is your corporate directory (shown in the interface as Directory), which is copied from one or more of the following sources:

- Cisco Unified Communications Manager
- A comma-separated-variable (CSV) file. CSV file names have the .csv extension.

Note: The CSV file can be on any shared network location to which Cisco Unified Attendant Console Standard has read and write access. However, if the file does not include a unique identifier (Primary Key) for each contact, it needs to be on the machine running Cisco Unified Attendant Console Standard.

Cisco Unified Communications Manager is the usual source of your corporate directory. Up to date contact information is copied from the source into Cisco Unified Attendant Console Standard by the synchronization process. For a description of this, see Directory Synchronization, page 5-3.

Directory Groups

You can also view and connect to contacts that are not in your synchronized directory but which you want to be able to select quickly. These directory groups can contain any combination of the following:

- Contacts imported (copied) from sources other than those listed above. These sources are either CSV files or Extensible Markup Language (XML) files. For more information, see Importing Contacts Into Directory Groups, page 5-13.
- Contacts you enter yourself. For more information, see Manually Adding Contacts To Directory Groups, page 5-14.

As well as importing contacts into directory groups, you can also export (copy) directory groups to CSV files, so that they can be used by other attendants or even in other applications.

Note: The format of CSV files imported/exported is different from that of CSV files used for synchronization.

You cannot amend contact records in the corporate directory. By contrast, directory groups are not updated by synchronization; and you can amend the contact details they contain.

For more information, see “Directory Groups” on page 5-11.
The relationships between directories and external information is summarized below.

**Legend**
2. Corporate directory.
3. Directory groups.
4. Cisco Unified Communications Manager.
5. CSV file for synchronization. For details of the format, see CSV File Formats, page B-2.
6. CSV file for importing and exporting. For details of the format, see CSV File Formats, page B-2.
7. XML file.
9. Import contacts.
10. Export contacts.
11. Manually entered contact.

**Contact Matching**

When displaying inbound or outbound calls Cisco Unified Attendant Console Standard displays the name of the matching contact, which is determined in the following way:

1. If the caller is a manually-created (speed dial) contact in the database, the name from there is displayed.
2. If the caller is not manually created, but their name is synchronized in the database, that is displayed.
3. If there is no caller name in the database, it is retrieved from Cisco Unified Communications Manager.
If **Unknown Caller** is displayed, the caller name has not been found. If **Private Caller** is displayed, the caller is blocked.

**Directory Synchronization**

The process of copying contacts from your source directories into Cisco Unified Attendant Console Standard is known as **synchronization**, because the information in the source and internal directories is identical at the instant of copying. When synchronization occurs, the contacts from both the Cisco Unified Communications Manager and the CSV file (if you specify one) are copied into Cisco Unified Attendant Console Standard. The actual data that is displayed in your corporate directory depends not only on what is in your sources but also on any directory field mappings, directory filters or BLF rules you have configured.

If synchronization detects that a contact it is copying is already in Cisco Unified Attendant Console Standard, it first validates the information (checks that it is correct) and then updates Cisco Unified Attendant Console Standard with any information that has changed since the last synchronization. If a synchronization fails mid-process – for example, because of a network failure – it starts again from the beginning.

The synchronization process needs to know what contact data to copy from the source to your corporate directory, and it gets this information from **directory field mappings**; for more information, including how to set the mappings, see Directory Field Mappings, page 5-6.

You can choose to copy only certain contacts to Cisco Unified Attendant Console Standard by applying a **directory filter**, this ensures that only those contacts that have the characteristics you specify in a series of **directory rules** are added to the corporate directory. For example, you can synchronize the contacts from only a specific department. For more information, see Directory Filtering, page 5-5.

During synchronization you can modify the first part of your contact telephone numbers, so that the numbers in your corporate directory differ from those in your source directory. For example, you might have telephone number stored in Cisco Unified Communications Manager as 01189728567, but in the corporate directory you want to see it as 8567. You achieve this number conversion by creating BLF Rules, which are applied during synchronization. For more information, see BLF Rules, page 5-7.

---

**Note**

- The converted numbers must match the DNs monitored in TAPI, otherwise the line state will not be displayed in the directories.
- These converted numbers are used by Cisco Unified Attendant Console Standard when it dials. If you set up BLF rules, you also need to set up translations in Cisco Unified Communications Manager to convert the numbers in Cisco Unified Attendant Console Standard back to the originals, so that you can call those numbers.

Directory synchronization takes place at regular intervals that you define, and you can also configure Cisco Unified Attendant Console Standard to synchronize with the source directory when you start the application (this is the default situation). Additionally, you can manually start synchronization. For more information, see Configuring Synchronization, page 5-4.
Chapter 5      Directories

Directory Synchronization

Synchronizing From a CSV Source File

When you synchronize from a CSV file, the file structure is first validated. The format of CSV files imported/exported is different from that of CSV files used for synchronization. For more information on valid CSV file formats, see CSV File Formats, page B-2. The first column of the CSV file must contain a unique identifier, known as a GUID, which identifies that contact as unique. If it does not, Cisco Unified Attendant Console Standard adds a first, GUID, column.

If your CSV file does not have a GUID column, and you intend storing it in a shared location that does not have write access, then before you put it there, you should place it locally and provide read-write access so that Cisco Unified Attendant Console Standard can add the GUID column.

Configuring Synchronization

Note Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

When you install Cisco Unified Attendant Console Standard, a set of default synchronization parameters are created, which should work for your installation. However, you can change these parameters to the values you require. Additionally, if you want to manually synchronize your system after changing its configuration, use this procedure.

To configure synchronization, do the following:

Step 1 In the main menu, choose File > Options.

The Options window appears.

Step 2 Click the General tab.

Step 3 Under Sync Detail, do the following:

- To synchronize when the application starts, select the Auto Synch Startup check box.
- To define the interval in hours between automatic synchronizations, in Sync Interval (In Hours), type a number. The default is zero, which means that synchronization is not scheduled to run again.
- To synchronize your directory now, click Sync Now. This control is disabled if there is already a synchronization in process.

Step 4 To synchronize to a CSV file source, under CSV Detail, Browse to the File Location of your CSV source, and either type its name or select it, and then click OK.

If you specify a CSV file source, the application synchronizes to both it and any specified Cisco Unified Communications Manager when you restart the application. For more information on specifying or changing CUCM details, see Changing Cisco Unified Communications Manager directory source details, page 4-7.

If you do not have a CSV source, click Clear to clear this field.

To view a sample CSV file, click View Sample.

Step 5 Click Apply.
Directory Filtering

A directory filter consists of a series of directory rules that are applied during synchronization to ensure that only certain contacts are copied to the corporate directory.

Each directory rule can compare one of the following contact details to a text string:

- Department
- Telephone
- Location

The rule makes the comparison according to one of the following conditions:

- Begins with
- Contains
- Is exactly
- Ends with
- Is not empty
- Does not contain

So, for example, you might only want to copy contacts whose Department Is exactly Sales. This would, however, exclude anyone whose department is Sales America, for example. Or maybe you want to synchronize those contacts whose Department Ends with ing, which would copy the contacts from both Marketing and Engineering (and any other department ending in those letters).

Directory filters can consist of any number of directory rules, combined using these logical operators:

- AND
- OR

So, for example, you might have a rule that synchronizes only those contacts whose Department Is exactly Sales AND their Location Ends with America, so that your corporate directory contains all the new world sales staff. When you use more than two rules, the AND operator has precedence over OR; so a rule with the structure X AND Y OR Z is equivalent to (X AND Y) OR Z.

Creating Directory Filters

**Note**
Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

To create a directory filter, do the following:

**Step 1**
In the main menu, choose **File > Options**.

The Options window appears.

**Note**
You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2**
Click the **Directory Filters** tab.
Step 3  Do the following, as many times as required until your filter is complete:
   
   a. If this is not the first rule in the filter, select the Link (Logical Operation) to apply between the
      previous rule and the one you are about to define.
   
   b. Select the contact Field to compare.
   
   c. Select the Condition to use in the comparison.
   
   d. In Value, type the text to compare with the Field.
   
   e. Click Add.

Step 4  Click Apply to save the changes.

Step 5  In the Options window, select the Configuration tab, and then, under Sync Detail, click Sync Now (this
control is disabled if there is already a synchronization in process). The filter is applied and only those
contacts satisfying the filter are copied to the corporate directory.

---

Directory Field Mappings

Before you synchronize contacts into Cisco Unified Attendant Console Standard the application needs to know which contact data fields (source fields) to import from Cisco Unified Communications Manager or a CSV file, and what destination fields within the application to populate with the data. This is called defining the directory field mappings. Contact data synchronized according to these mappings cannot be edited, but you can edit non-mapped fields.

You can specify separate directory field mappings for the data from your Cisco Unified Communications Manager and from a CSV file; so, for example, you could import your sales contacts from Cisco Unified Communications Manager, and your marketing contacts from a CSV file.

When you install Cisco Unified Attendant Console Standard default directory field mappings are defined for you. You can, however, change these mappings or define your own. How to do these is described in Setting Directory Field Mappings, page 5-7.

---

Destination Fields

Cisco Unified Attendant Console Standard supports the following contact destination fields:

- Department
- Directory URI
- Email
- First Name
- Home Phone
- Last Name
- Location
- Manager
- Middle Name
- Mobile
- Telephone (automatically mapped from source)
Source Fields

By default, Cisco Unified Attendant Console Standard has mappings set up for synchronizing contacts from Cisco Unified Communications Manager (CUCM) and CSV files. However, you may wish to change the default mappings, or define your own.

Setting Directory Field Mappings

**Note**
Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

To set the directory field mappings, do the following:

**Step 1**
In the main menu, choose **File > Options**.
The **Options** window appears.

**Note**
You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2**
Click the **Directory Mappings** tab.

**Step 3**
Select a **Directory Source**: CUCM or CSV.

**Step 4**
Do the following, as required:
To **add a mapping**, select the **Source Field**, **Destination Field**, and then click **Add**.
To **delete a mapping**, click the corresponding **Delete** symbol, and then in the confirmation message, click **Yes**.

**Step 5**
Click **Apply**.
The next time you synchronize with your source, the mappings are applied.

BLF Rules

BLF rules are applied during synchronization to convert directory numbers to a different format by searching for and replacing specific number prefixes. You can define sets of multiple rules to be applied one after the other during synchronization, and you can define different sets of rules for synchronizing from Cisco Unified Communications Manager and CSV files.

BLF rules are applied in the order they are listed in the BLF rules List. For example, if the first rule modifies the number from 01189597895 to 8957, the next rule is applied to the modified number. By moving rules up or down in the list, you change the order in which they are applied.
BLF Rules

Note
BLF rules will only be applied to contacts synchronized from CUCM, CSV or ALL, but not to imported or manually added contacts.

Adding BLF Rules

Note
Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

To add a BLF rule, do the following:

Step 1
In the main menu, choose File > Options. The Options window appears.

Note
You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

Step 2
Click the BLF rules tab. A list of all existing BLF rules is displayed. By default, no rules are defined.

Step 3
Click New Rule. The BLF Rule Detail page appears.

Step 4
Type a Rule Name.

Step 5
Define the Selection Criteria.
   a. Directory Source: select either CUCM, CSV or All.
   b. Length: optionally, enter that the rule applies to numbers that match a certain length - if no length is specified then the rule will apply to all numbers.
   c. Begins With: optionally, enter that the rule applies to numbers that begin with a specified value - if no value is specified then the rule will apply to all numbers.

Step 6
Define the Transformation Criteria.
   a. Ignore Characters: optionally, remove non-digit characters (such as +) from the number by typing them here (with no separators).
   b. Remove Non-Digit Characters: optionally, select if you want the rule to remove non-digit characters.
   c. Number of Characters to Remove from Beginning: optionally, enter that the rule removes a certain amount of characters from the beginning of the number.
   d. Add Prefix: optionally, enter that the rule adds a prefix to the start of the number.

Step 7
Before applying the criteria, you can Test BLF Rules.
   a. Pre-Transformation Number: type in any number, and then click Run Test.
   b. Check that the number displayed in Test Results matches your expectations. If not, revise the rule settings.
If you are satisfied with the rule, click **Apply**. If not, click **Cancel** to cancel any changes you have entered. This will take you back to the main application screen without making any changes.

After you apply a rule, the BLF Rules page appears, and you can continue adding, editing or deleting BLF rules.

---

**Editing BLF Rules**

- **Note**: Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

To edit an existing BLF rule, do the following:

1. In the main menu, choose **File > Options**. The **Options** window appears.

- **Note**: You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

2. Click the **BLF Rules** tab. A list of all existing BLF rules is displayed.

3. Select the rule to edit.

4. Click **Edit Rule** to display the **BLF Rule Detail** page.

5. Edit the fields, as required. These are described in Adding BLF Rules.

6. Test the rule, as required.

7. Click **Apply**.

---

**Test All Rules**

To test all the rules at the same time, do the following:

1. In the main menu, choose **File > Options**.

2. The **Options** window appears.

3. Click the **BLF Rules** tab.

4. Click **Test All Rules**.

5. In the pop-up window, enter the **Pre-Transformation Number** on which to test your rules.

6. Select the **Directory Source** (All, CUCM or CSV).

7. Click **Run Test** to see **Test Results**.
Once you are done, click Close to go back.

**Note** When multiple BLF rules are configured, the output of the first rule will become the input of the second rule. If you are not satisfied with the final result of your transformed number, you may need to review individual BLF rules or their order.

### Deleting BLF Rules

**Note** Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

To delete a BLF rule, do the following:

**Step 1** In the main menu, choose File > Options.

The Options window appears.

**Note** You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2** Click the BLF Rules tab.

A list of all existing BLF rules is displayed.

**Step 3** Select the rule to delete.

**Step 4** Click Delete Rule.

**Step 5** Click Apply.

### Reordering BLF Rules

**Note** Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

To change the order in which BLF rules are applied during synchronization, do the following:

**Step 1** In the main menu, choose File > Options.

The Options window appears.

**Note** You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2** Click the BLF Rules tab.
A list of all existing BLF rules is displayed.

**Step 3**  
On each rule to move, do the following, as required:

- a. Select the rule.
- b. To move the rule towards the top of the list, click **Move Up**.
- c. To move the rule towards the bottom of the list, click **Move Down**.

**Step 4**  
Click **Apply**.

---

### Directory Groups

Directory groups contain special contacts – including contacts not in your source directory – that you want to be able to select quickly. You must create your directory group before adding contacts to it. For details of how to do this, see **Creating Directory Groups**, page 5-11.

You add contacts to directory groups by either of the following methods:

- Importing contacts from CSV files or XML files, as described in **Importing Contacts Into Directory Groups**, page 5-13.
- Manually creating contacts, see **Manually Adding Contacts To Directory Groups**, page 5-14.

You can amend the name of a directory group, and the details of any contact in the group. You can also export the contacts from directory groups to CSV files.

### Creating Directory Groups

You need to create directory groups before you can import data to them.

To create a directory group, do the following:

**Step 1**  
Do one of the following:

- Click the **Add Directory Group** (+) control.
- In the main menu, choose **Edit > Add directory group**.
- Use the keyboard shortcut you have defined, as described in **Defining and Editing Keyboard Shortcuts**, page 6-2.

The **New Directory Group** dialog box appears.

**Step 2**  
Type a **Directory Group Name**, and then either click **Save** or press **Enter**.

The directory group is added as a new tab in the directory display.
Deleting Directory Groups

Note
You cannot delete directory groups while synchronization is in process.

To delete a directory group, do one of the following:

Step 1
Right-click the directory group tab.
Step 2
Select Delete Directory Group.
Step 3
In the confirmation message, click Yes.

or

Step 1
Select the directory group, and then do one of the following:
  • In the main menu, choose Edit > Delete directory group.
  • Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard Shortcuts, page 6-2.

Renaming Directory Groups

To rename a directory group, do the following:

Step 1
Right-click the directory group tab.
Step 2
Select Edit Directory Group.
Step 3
In the dialog box, type the new group name, and then click Save.

or

Step 1
Do one of the following:
  • In the main menu, choose Edit > Edit directory group.
  • Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard Shortcuts, page 6-2.
Step 2
In the dialog box, type the new group name, and then click Save.
Importing Contacts Into Directory Groups

You can import contacts from the following types of file into an existing directory group.

- XML – for example, one previously exported from Cisco Attendant Console (CAC)
- CSV

For details of the formats of these files, see Appendix B, “Import/Export File Formats”.

**Note**

The following points:

- You cannot import contacts into a directory group while the application is synchronizing to the corporate directory.
- The format of CSV files imported/exported is different from that of CSV files used for synchronization.

When importing contacts into the **main directory**, the information of a contact that already exists is amended. New contacts cannot be created in the main directory through import.

However, when importing into **speed dial directories**, duplication may occur in several scenarios:

- if the same contact was created by different users on different applications and CSV files are exchanged between these users, the contact is duplicated.
- if the unique ContactID is missing from the import file and cannot, therefore, be matched to the ContactID of existing contacts, the contacts are duplicated as many times as the user imports the file; the ContactID may be missing because you are using an old version import/export files, or if it has been manually edited out.

To avoid duplication, create contacts within a single Cisco Unified Attendant Console Standard installation, then export a CSV file and use it to import contacts on all other installations. This way, all contacts share the same ContactID.

At the start of the import process Cisco Unified Attendant Console Standard validates the file structure and format. If either is incorrect, you are alerted to the fact and the process is aborted.

You can only import contacts into an existing directory group – either one that already contains contacts, or a new one created especially for the purpose. See Creating Directory Groups, page 5-11.

To import contacts into a directory group, do one of the following:

**Step 1**

Do one of the following:

- In the main menu, choose **File > Import Contacts**.
  - or
- In the main menu, choose **File > Options**.
  - a. In the Options window, click the **Import/Export** tab.
    - or
  - Right-click in any directory group, and then select **Import Contacts**.
    - or
- Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard Shortcuts, page 6-2.
Step 2  Then do the following:
   a. In File Name, click Browse and select the file to import.

   ![Note](image)
   You cannot type a file name or edit the name of a selected file.
   
   b. Select the File Type.
   c. If the Directory Group to receive the contacts is not correct, select the correct one.
   d. Click Import Contacts.

The import progress is displayed.

Step 3  When the import is complete, close the dialog box.

### Manually Adding Contacts To Directory Groups

You can manually add contacts to directory groups.

![Note](image)
You cannot manually add contacts to your corporate directory.

To add a contact to the displayed directory group, do the following:

Step 1  Do one of the following:
   - Right-click the directory group contact listing, and then select Add Contact.
   - Select the directory group and do either of the following:
     - In the main menu, choose Edit > Contacts > Add Contact.
     - Use the keyboard shortcut you have defined, as described in Defining and Editing Keyboard Shortcuts, page 6-2.

The Contact dialog box appears.

Step 2  Type the contact information, which is described in Destination Fields, page 5-6. You can also enter a contact Note.

Step 3  Click Save.

Step 4  In the confirmation message, click OK.

Step 5  When you have finished adding contacts, close the Contact dialog box.

Alternatively, you can drag (copy) contacts from the corporate directory or another directory group, and then drop them into the target directory group.
**Note**

- This creates a duplicate contact in the directory group. Take care not to create multiple duplicates.
- When editing contact properties or adding/editing a note, the changes will only occur for the directory group contact against which you make the changes. That is, the changes will not copy from the duplicate to the original or the other way around.

---

To drag contacts into a directory group:

**Step 1** Display the directory containing the contact to copy.

**Step 2** Select the contact and then, holding the mouse button, drag the contact over the appropriate directory group tab to list its contents.

**Step 3** Drag the contact into the list, and then drop it.

---

**Deleting Contacts From Directory Groups**

You can delete contacts from directory groups.

**Note**

You cannot delete contacts from your corporate directory.

To delete a contact from the displayed directory group, do the following:

**Step 1** Select the contact to delete.

**Step 2** Do one of the following:

- Right-click and then select **Delete Contact**.
- In the main menu, choose **Edit > Contacts > Delete Contact**.
- Use the keyboard shortcut you have defined, as described in **Defining and Editing Keyboard Shortcuts, page 6-2**.

**Step 3** In the confirmation message, click **Yes**.

---

**Editing Contacts In Directory Groups and the Corporate Directory**

You can edit all the information belonging to a contact in a directory group and some of the information for a contact synchronized into the corporate directory.

**Note**

You can edit any fields in manually-added contacts, but you can only edit *unmapped* fields in contacts that have been synchronized into the corporate directory; the edited data is retained when the contact is synchronized. Should the field become mapped, the edited contact data in the corporate directory will be overwritten during synchronization with the data mapped from the Call Manager.
To edit a contact, do the following:

**Step 1**
Open the relevant directory and display the contact.

**Step 2**
Do one of the following:
- Right-click the contact, and then select **View/Edit Contact**.
- In the main menu, choose **Edit > Contacts > View/Edit Contact**.
- Use the keyboard shortcut you have defined, as described in **Defining and Editing Keyboard Shortcuts**, page 6-2.

The **Contact** dialog box appears.

**Step 3**
Edit the contact information, which is listed in **Destination Fields**, page 5-6.

**Note**
You can edit the data in the white fields, but not in the shaded fields.

**Step 4**
Click **Save**.

**Step 5**
In the confirmation message, click **OK**.

---

**Exporting Contacts From Directory Groups**

You can export a directory group into a preexisting CSV file. To export a directory group, do the following:

**Step 1**
Do one of the following:
- In the main menu, choose **File > Export Contacts**.
  or
  a. In the main menu, choose **File > Options**.
  b. In the **Options** window, click the **Import/Export** tab.
  or
  - Right-click in any directory group, and then select **Export Contacts**.
  or
  - Use the keyboard shortcut you have defined, as described in **Defining and Editing Keyboard Shortcuts**, page 6-2.

**Step 2**
Then do the following:
  a. In **File Name**, click **Browse** and navigate to the target folder.
  b. Either type a file name (to create a new CSV file) or select an existing file to export to. If you select an existing file you are prompted to overwrite it; click **Yes** to overwrite the file.

**Note**
The format of CSV files imported/exported is different from that of CSV files used for synchronization.

  c. Select the **Directory Group** to export.
d. Click **Export Contacts**.
   The export progress is displayed.

---

**Viewing and Using Directories**

The bottom part of the interface consists of the directories and their associated controls. For example:

![Directory Interface](image)

**Legend**

1. **Search** – type details of the contact to search for.
2. **Search Preferences** – define which contact information to search.
3. **Directory tabs** – select the directory to display. Includes both corporate directory and directory groups. Drag the tabs to change their order, as described in Changing the Directory Tab Order, page 5-18.
4. Create a new directory group.
5. **Column headings** – identify the data and enable you to change what columns are displayed, the column order, and the contact sort order. These are described below.
6. **Phone state** – the state of the contact’s phone, such as Ringing, On hook, and Do not disturb.

---

**Note**

If a contact DN includes spaces (for example, +44 123 456), the phone line state will not be shown. However, a call can be made to this contact successfully.

7. **Presence state** – this mimics a Jabber or CUPC client, where a symbol indicates the real-time status of the contact, such as Available, Do not disturb, and Away. All other contacts have their subscriptions opened only when displayed in the Directory pane.
The following information can be displayed for each contact (columns displayed by default are shown in **bold**):

- **Last Name** - always displayed
- **First Name**
- **Telephone** - always displayed
- **Department**
- **Notes**
- **Middle Name**
- **Email**
- **Directory URI**
- **Mobile**
- **Home Phone**
- **Manager**
- **User Field 1**
- **User Field 2**
- **Location**

How to change what columns of information are displayed is described Changing the Directory View, page 5-19.

If the contact was imported or manually entered into Cisco Unified Attendant Console Standard you can also edit the contact information.

### Changing the Directory Tab Order

Each directory is identified by a tab, which you click to display that directory. When you first start the application, the default directory tabs are displayed in a default order. You can change the order of the default directory tabs - and any new ones you create - by dragging them to the left or right and dropping them in the required position. If you drag a tab to the left and drop it on another tab, it replaces that tab, which then moves to the right one position. If you drag a tab to the right and drop it on another tab, it replaces that tab, which then moves to the left one position. For example, if you have tabs 1, 2, 3 and 4 in that order, and you drag tab 4 and then drop it on tab 1, the tabs become ordered 4, 1, 2, 3. If you then drag tab 1 and drop it on tab 3, the order changes to 4, 2, 3, 1.

**Note**

You cannot move the **Search Results** tab.

The positions of the tabs are stored when you log out or exit the application, and the tabs are displayed in the saved order when you next use it.
Changing the Directory View

You can change the following:

- What data columns are displayed
- The order of the columns, from left to right
- The contact order according to the data in any of the columns

Changing what data columns are displayed and column order

You can display any of the columns of information for each contact, so long as your selection includes Last Name and Telephone.

To select which columns to display and their order:

1. Right-click any column heading.
   A menu appears, listing the default columns, with a tick preceding each column displayed.
2. To hide a selected (ticked) default column or display an un-ticked column, click the item in the menu.
3. To control non-default columns or change the order in which all columns are displayed, click More.
   A dialog box appears listing the possible columns. Displayed columns have a tick in their check box.
4. Use this dialog box to add or remove columns from the display, and to change the order in which the columns are displayed in the following ways:
   - To show a column in the directory pane, click the corresponding check box to select it.
   - To remove a column from the directory pane, click the corresponding check box to clear it (you cannot remove Last Name or Telephone).
   - To move a column in the directory pane, select it (not the check box), and click Move Up (to move the displayed column to the left) and Move Down (to move the displayed column to the right).

Note: You can also change the order of the columns in the Directory pane by using your mouse to select a column heading; you can then drag it to another place in the table.

5. Click Save.
   The contact information in the Directory pane changes accordingly.

Changing contact order

When the data is first displayed it appears in its default order, as copied from the Call Manager. You can change the alphanumeric sort order of the directory table rows by clicking the following column headings – the entire table will be sorted according to the data in that column.

- Last Name
- First Name
- Telephone
- Department
The small arrowheads in the column heading row show the direction in which the column is sorted: an up-arrow for ascending (normal alphanumeric) order, a down-arrow for descending (reverse) order, and both arrows for default order. Repeatedly clicking the column heading toggles through these sort modes. The sort column and sort order are remembered by the application when you log off or exit, and are re-applied when you log in again.

### Searching For Contacts

You can search for contacts in any open directory (the corporate directory and any directory groups you are displaying). Details of matching contacts are shown under the **Search Results** directory tab.

You can search on any of the contact data fields, but no more than five at any time. The fewer fields you configure, the better will be the search speed. Configure the searchable fields as described in **Search Preferences**.

You do not need to specify which field you want to search: the string you type in the Search field is matched against all of them. So, for example, if you have a *Sales* department, and a staff member with the last name *Saunders*, searching for the characters *Sa*, will display all the matching last names (and first names) and list everyone in Sales.

If you type a string containing one or more spaces, all the individual “words” in the string and the entire string are searched for. For example, if you search for *Del Toro*, each directory field is searched for *Del* AND for *Toro* AND for *Del Toro*.

Searching begins as soon as you start typing; and the more characters you type, the fewer contacts will match. Matching occurs even with the accented equivalents of unaccented letters; for example: typing *ö* will match with *ö*, *ô* and any other accented equivalents in the contact data. When the contact you require is displayed, select it and then use the controls interface to communicate with that contact.

### Search Preferences

The Search Preferences enable you control which fields are searched and which contacts are displayed.

You can choose from one to five **Searchable Fields** from the following **Available Fields** (default searchable fields shown in **bold**):

- **First Name**
- **Last Name**
- **Telephone Number**
- **Department**
- **Email**
- **Middle Name**
- **Directory URI**
- **Mobile**
- **Note**
- **Home Phone**
- **Manager**
- **User Field 1**
- **User Field 2**
• Location

Use the Left-arrow and Right-arrow buttons to move the field selected in either list to the other.

You can also limit which contacts are displayed in the search results using these Filters:

• Has Telephone – Display only those contacts with a telephone number assigned. All other contacts are filtered out (excluded) from the search results.

• Has Emails – Display only those contacts with an email address assigned. All other contacts are filtered out (excluded) from the search results.

**Setting Search Preferences**

To set the search preferences, do the following:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Click Search Preferences. The Search Preferences dialog box appears.</td>
</tr>
<tr>
<td>2</td>
<td>Select Searchable Fields and Available Fields, as required, moving them between the lists by clicking Left-arrow and Right-arrow as required to define the searchable fields.</td>
</tr>
<tr>
<td>3</td>
<td>Select the required filters.</td>
</tr>
<tr>
<td>4</td>
<td>Click Save.</td>
</tr>
<tr>
<td>5</td>
<td>In the confirmation message, click OK.</td>
</tr>
</tbody>
</table>

**Viewing Contact Information**

The directory display contains basic information about each contact. You can view more information about a selected contact by viewing their contact details. How you view contact details depends on whether the contact is in the corporate directory or a directory group.

To view a contact’s details, do the following:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Display the directory containing the contact.</td>
</tr>
<tr>
<td>2</td>
<td>Right-click the contact.</td>
</tr>
<tr>
<td>3</td>
<td>Click View/Edit Contact. The Contact dialog box is displayed.</td>
</tr>
<tr>
<td></td>
<td>If you are viewing the details of a contact in a directory group, you can also edit the details, as described in Editing Contacts In Directory Groups and the Corporate Directory, page 5-15.</td>
</tr>
<tr>
<td>4</td>
<td>When you have finished viewing the information, click Cancel.</td>
</tr>
</tbody>
</table>
Contact Notes

You can add notes to any contact record in the main directory, the search results, or any directory group. The notes are text containing additional information about the contact. Notes are stored in the database and are available whenever you sign in. If you delete a contact - for example by applying BLF rules - any contact notes are also deleted. If you export a contact, their notes are also exported, and if you import a contact with notes, they are visible in the application.

Adding Contact Notes

To add contact notes:

Step 1  Select the contact to add notes to.
Step 2  Do one of the following:

- Right-click the contact, and then choose Add/Edit Note.
- Choose Edit > Contacts > Add/Edit Note.

Note  You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

The Edit Note dialog box appears.

Step 3  In the text box, type the notes and then either click Save or tab to the control and press Enter to add the notes to the contact.

Note  You must enter some text for you to be able to save it. When adding/editing a note, the changes will only occur for the directory group contact against which you make the changes. That is, the changes will not copy from the duplicate to the original or the other way around.

The notes appear in the contact’s Notes column.

Editing Contact Notes

You can edit existing contact notes. To do so, follow the Adding Contact Notes procedure, but edit the existing notes.

Deleting Contact Notes

To delete existing contact notes:

Step 1  Select a contact with notes to delete.
Step 2  Do one of the following:

- Right-click the contact, and then choose Delete Note.
Choose Edit > Contacts > Delete Note.

**Note**

The following:

- These menu options are disabled if there are no notes to delete.
- You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 3**
The notes are deleted from the contact Notes column.
Keyboard Shortcuts

Keyboard shortcuts enable you to quickly do things in the interface without needing to use the mouse or menus.

The application comes configured with the following keyboard shortcuts.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dial</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Answer</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>End Call</td>
<td>Ctrl+H</td>
</tr>
<tr>
<td>Hold Call</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Transfer Call (Blind transfer)</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Consult Transfer (speak to destination before transfer)</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Direct Transfer</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Join Call</td>
<td>Ctrl+J</td>
</tr>
<tr>
<td>Park Call</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Start Conference</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Transfer to Voicemail</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Sign out of application</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Login/ Logout of Hunt Groups</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Open Help</td>
<td>F1</td>
</tr>
<tr>
<td>Outbound Dialing Override</td>
<td>Ctrl+Enter</td>
</tr>
</tbody>
</table>

In addition, you can define shortcuts for the following actions:

- Dial (Mobile)
- Dial (Home)
- Transfer (Mobile)
- Transfer (Home)
- Consult Transfer (Mobile)
- Consult Transfer (Home)
- Conference (Mobile)
Defining and Editing Keyboard Shortcuts

To define or edit a keyboard shortcut, do the following:

**Step 1**  Do either of the following:
- In the main menu, choose **Edit > Keyboard Shortcuts**.

or

  a. In the main menu, choose **File > Options**.
  b. The **Options** window appears.
  c. Click the **Keyboard Shortcuts** tab.

**Step 2**  Select the Action to define. This can be an action that already has a shortcut.

**Step 3**  Click **Set Shortcut**.

Note: You cannot use the same keyboard shortcut for more than one action.
Step 4 Type the shortcut you require. For example, to set an action to Ctrl+Y or Ctrl+Shift+Y, simply type Ctrl+Y or Ctrl+Shift+Y (press and hold the Ctrl key or the Ctrl and Shift key, and then press the Y key).

Step 5 Click Apply.

Removing Keyboard Shortcuts

To remove a keyboard shortcut, do the following:

Step 1 Access the Keyboard Shortcuts page, as described in Defining and Editing Keyboard Shortcuts, page 6-2.

Step 2 Select the action from which to remove the keyboard shortcut.

Step 3 Click Clear Shortcut.

Step 4 Click Apply.

Resetting Shortcuts to their Default Values

To reset keyboard shortcuts to their default values, do the following:

Step 1 Access the Keyboard Shortcuts page, as described in Defining and Editing Keyboard Shortcuts, page 6-2.

Step 2 Do one of the following, as appropriate:

To reset all keyboard shortcuts to their default values, click Reset All Shortcuts to Default.

To reset a single keyboard shortcut to its default value:

a. Select the action to reset.

b. Click Reset Shortcut.

Step 3 Click Apply.
To uninstall Cisco Unified Attendant Console Standard, do the following:

**Step 1** Go to Start > Control Panel, and then double-click Add/Remove Programs.

**Step 2** From the list, select Cisco Unified Attendant Console Standard, and then click Remove. The Wizard prepares to (un)install the console application.

**Step 3** When you are prompted to confirm that you want to remove Cisco Unified Attendant Console Standard from your machine, click Yes.

**Step 4** You are asked Do you want to delete the application database? (Application database contains configuration and local directory contacts.)

- Selecting Yes allows you to delete all unneeded personal information for security and privacy reasons.
- Selecting No allows you to retain the application database. This is preferred if intending to reinstall Cisco Unified Attendant Console Standard.

**Step 5** When prompted that the uninstallation is complete, select Yes, I want to restart my computer now, and click Finish.

**Note** All Cisco Unified Attendant Console Standard application logs are deleted as part of the uninstallation process.
Application Log Configuration and Collection

**Note**
Access to the functions described in this section may be restricted by your system administrator, and you may need a password to access the necessary Options tab. For more information, see Preventing Access To Options Tabs, page 4-2.

Cisco Unified Attendant Console Standard can keep a log of all events that occur within the application. This information can be used to gauge the application’s configuration and performance, and to help troubleshoot any errors. You can control which application subsystems are monitored, which events are logged, and the size and number of the log files.

### Access the Logging Menu

**Step 1**
In the main menu, choose **File > Options**.

The Options window appears.

**Note**
You can configure a keyboard shortcut to do this. For instructions, see Chapter 6, “Keyboard Shortcuts”.

**Step 2**
Click the **Logging** tab to configure logging.

### Configuring Logging

From the Options > Logging tab, adjust the following values as required:

- **Number of Files**: Type the maximum number of log files to be retained. Once the threshold is met, the application will begin overwriting the log files starting with the oldest.
  - The default value is 10.

- **Max File Size (In MBs)**: Type the maximum file size, in MBs. Once the threshold is met, the log file will close, and a new log file is opened.
  - The default value is 20.

- **Logging Level**: Select the logging level that fits your logging needs.
  - Debug is the most verbose, with each subsequent level moving down in verbosity until Fatal, which is the least verbose.
• Logging Level - Custom, allows you to set a different logging level for the individual modules of the application. Each line in the application log files notes the module it belongs to (for example, a line marked ViewModel would be affected by the ViewModel module setting). A custom level of logging is not suitable for general use.
• The default and recommended value is Debug.

Log Collection

Step 1  From the Options > Logging tab, select Collect Logs.
Step 2  You are prompted to browse to a folder, where the application logs can be saved to. After making your selection, click OK.
• The Windows User account must have write-permissions to the specified folder.
Step 3  Once the log collection completes an alert indicating the success of the compressed log file creation and the file path will appear. Click OK to dismiss the alert.
• The output will be stored in a .zip file containing all of the log files and a log configuration file.
XML File Format

XML files that you import into Cisco Unified Attendant Console Standard must have the following format:

```xml
<SpeedDialUsers>
  <G n="Sample Group">
    <E>
      <N>Jim Kathirine</N>
      <T>25421</T>
      <M>Jim@cisco.com</M>
      <D>Jim@cisco.com</D>
      <O>This is a sample entry</O>
      <P>00443454332</P>
      <H>0044556634</H>
      <S>Reading</S>
      <A>IT</A>
      <R>Jason Rumsey</R>
      <U>Software Engineer</U>
      <V>Management</V>
    </E>
  </G>
</SpeedDialUsers>
```

**Tags**

- `<SpeedDialUsers>` = the file contains XML data for import into Cisco Unified Attendant Console Standard.
- `<G>` = Directory group name
- `<E>` = Individual contact
- `<N>` = Name
- `<T>` = Telephone number
- `<M>` = Email address
CSV File Formats

Cisco Unified Attendant Console Standard handles two types of comma-separated value (CSV) files:
- CSV Files for Synchronization
- CSV Files for Directory Import and Export

These files differ in the number of data fields they contain in each contact record.
All CSV files used by Cisco Unified Attendant Console Standard must have the following format:
- Each contact is on a single line.
- Empty comma-separated values are valid.
- Lines starting with # or ; are comments and are ignored. Empty and blank lines are also ignored.

CSV Files for Synchronization

In a CSV file for synchronization, the data for each contact must be in the following order:
Sync ID, Last Name, First Name, Telephone Number, Department, User Field 1, User Field 2, Site, Building, Directory URI.

For example:
```
# * Copyright (c) 2019 by Cisco Inc.
# * All rights reserved.
#
# Here is a sample corporate directory file. It should contain
# comma separated entries, one line per user in the directory
# The values should in the following format:
# # Sync ID, Last Name, First Name, Telephone number, Department, User Field 1, User Field 2, Site, Building, Directory URI
# # Empty values are legal (no department etc.)
# # Lines starting with '#' or ';' are treated as comments and ignored. Empty or blank lines are ignored as well
Kathirine,Jim,25421,Marketing,,,,,,,,Jim@cisco.com
Martha,Bryan,87952,Support,,,,,,,,martha@cisco.com
Luce,Richard,2548,Marketing,,,,,,,,luce@cisco.com
Meriall,Thomas,8763,Marketing,,,,,,,,meriall@cisco.com
```
CSV Files for Directory Import and Export

Both main directory and speed dial contacts can be exported and imported through CSV files. This feature has multiple benefits:

- Users can make backups of a contact's complete data - both modifiable and non-modifiable.
- Users moving from different products with extensive contact data not retained in the parent source database can use this option to migrate data.
- Modifiable fields, like custom notes, can be shared and synchronized between multiple users.
- Editing contacts in bulk is more efficient.

**Note**

Importing contacts using a CSV file should not duplicate but instead overwrite and add new information to contacts that may already exist in a directory prior to import. For more information about the possible scenarios in which duplication may occur, see [Importing Contacts Into Directory Groups](#).

In a CSV file for directory import or export, the data for each contact must be in the following order:

- Last Name
- First Name
- Telephone Number
- Note
- Group Name
- Email
- Directory URI
- Middle Name
- Mobile
- Home Phone
- Site
- Department
- Manager
- User Field 1
- User Field 2

For example:

```
#     * Copyright (c) 2019 by Cisco Inc.
#     * All rights reserved.
#
# Here is a sample import file. It should contain
# comma separated entries, one line per user in the directory
# The values should be in the following format:
# Last Name, First Name, Telephone Number, Note, Group Name, Email, Directory URI, Middle Name, Mobile, Home Phone, Site, Department, Manager, User Field 1, User Field 2
#
# Empty values are legal (no email etc.)
#
# If a Group Name is specified in the CSV file, it will take precedence over the Directory Group selected at the Import screen.
#
# Lines starting with '#', '!', ';' or '!' are treated as comments
# and ignored. Empty or blank lines are ignored as well

Kathirine, Jim, 25421, This is a sample entry, Sample Group 1, jim@cisco.com, jim@cisco.com, Maid, 00443454332, 0044556634, Reading, IT, Martin Taylor, Support Engineer, Senior
Martha, Bryan, 87952, This is a sample entry., Sample Group 1, martha@cisco.com, martha@cisco.com, Aryan, 00443454335, 0044556635, Reading, IT, Martin Taylor, Support Engineer, Junior
Luce, Richard, 2548, This is a sample entry, Sample Group 2, luce@cisco.com, luce@cisco.com, Tace, 00443454339, 0044556636, Reading, R&D, Jason Rumsey, Software Engineer, Management
Meriall, Thomas, 8763, This is a sample entry, Sample Group 2, meriall@cisco.com, meriall@cisco.com, Kate,
```
CSV Files for Importing Sign In Devices

You can import devices that operators use to log into Cisco Unified Attendant Console Standard, as described in Importing Sign In Devices, page 4-11.

These CSV files have the data for each device in the following format:

Device name, Extension, Line number

For example:

```
#     * Copyright (c) 2019 by Cisco Inc.
#     * All rights reserved.
#
# Here is a sample device list file. It should contain
# comma separated entries, one line per device in the device list.
# The values should in the following format:
#     *
#     * DeviceName,Extension,LineNumber
#     *
#     * Empty values are not allowed (no DeviceName etc.)
#     *
#     * Lines starting with '#' or ';' are treated as comments
#     * and ignored. Empty or blank lines are ignored as well

SEP2893FE130280,5868,1
SEP2893FEA2D22A,5873,1
SEP000C299DA714,5870,1
SEP88AE1DB0F66C,5869,1
SEP00141C48DDD9,5859,1
SEP00141C48DDD9,5870,2
```

**Note**

Any devices in the file that lack one or more of the fields Device name, Extension, or Line number are considered non-Cisco devices and will not be imported.
Cisco Unified Attendant Console Standard user and end-point device support. See *Shared Lines and Extension Mobility*, page 2-4 for details regarding shared lines and extension mobility.

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full</td>
<td>Console user device and BLF status for directory contacts</td>
</tr>
<tr>
<td>Console User</td>
<td>Console user device only</td>
</tr>
<tr>
<td>BLF Status</td>
<td>BLF status for directory contacts only</td>
</tr>
<tr>
<td>Not Supported</td>
<td>Tested, but not supported</td>
</tr>
<tr>
<td>Not Tested</td>
<td>Not tested, therefore no formal support</td>
</tr>
<tr>
<td>^x</td>
<td>Reference footnote</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Device Type/Phone Model</th>
<th>Supportability</th>
<th>Device Type/Phone Model</th>
<th>Supportability</th>
</tr>
</thead>
<tbody>
<tr>
<td>3905</td>
<td>Not Supported</td>
<td>7960</td>
<td>Full</td>
</tr>
<tr>
<td>6901</td>
<td>Not tested</td>
<td>7961</td>
<td>Full</td>
</tr>
<tr>
<td>6911</td>
<td>Full</td>
<td>7961G-GE</td>
<td>Full</td>
</tr>
<tr>
<td>6921</td>
<td>Full</td>
<td>7962</td>
<td>Full</td>
</tr>
<tr>
<td>6941</td>
<td>Full</td>
<td>7965</td>
<td>Full</td>
</tr>
<tr>
<td>6945</td>
<td>Full</td>
<td>7965G</td>
<td>Full</td>
</tr>
<tr>
<td>6961</td>
<td>Full</td>
<td>7970</td>
<td>Full</td>
</tr>
<tr>
<td>7811</td>
<td>Full</td>
<td>7971</td>
<td>Full</td>
</tr>
<tr>
<td>7821</td>
<td>Full</td>
<td>7975</td>
<td>Full¹</td>
</tr>
<tr>
<td>7841</td>
<td>Full</td>
<td>8811</td>
<td>Full</td>
</tr>
<tr>
<td>7861</td>
<td>Full</td>
<td>8841</td>
<td>Full</td>
</tr>
<tr>
<td>7902</td>
<td>Not tested</td>
<td>8845</td>
<td>Full</td>
</tr>
<tr>
<td>7905</td>
<td>Full</td>
<td>8851</td>
<td>Full</td>
</tr>
<tr>
<td>7906</td>
<td>Full</td>
<td>8851NR</td>
<td>Full</td>
</tr>
<tr>
<td>Device Type/Phone Model</td>
<td>Supportability</td>
<td>Device Type/Phone Model</td>
<td>Supportability</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------</td>
<td>------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>7910</td>
<td>Full</td>
<td>8861</td>
<td>Full</td>
</tr>
<tr>
<td>7911</td>
<td>Full</td>
<td>8865</td>
<td>Full</td>
</tr>
<tr>
<td>7912</td>
<td>Full</td>
<td>8865NR</td>
<td>Full</td>
</tr>
<tr>
<td>7915</td>
<td>Full</td>
<td>8941</td>
<td>Full</td>
</tr>
<tr>
<td>7916</td>
<td>Full</td>
<td>8945</td>
<td>Full</td>
</tr>
<tr>
<td>7920</td>
<td>Full</td>
<td>8961</td>
<td>Full</td>
</tr>
<tr>
<td>7921</td>
<td>Full</td>
<td>9951</td>
<td>Full</td>
</tr>
<tr>
<td>7925</td>
<td>Full</td>
<td>9971</td>
<td>Full</td>
</tr>
<tr>
<td>7925G</td>
<td>Full</td>
<td>Cisco CSF</td>
<td>Full</td>
</tr>
<tr>
<td>7925G-EX</td>
<td>Full</td>
<td>Cisco Jabber for Android</td>
<td>Not Supported</td>
</tr>
<tr>
<td>7926</td>
<td>Full</td>
<td>Cisco Jabber for iPad</td>
<td>Not Supported</td>
</tr>
<tr>
<td>7931</td>
<td>Full²</td>
<td>Cisco Jabber for iPhone</td>
<td>Not Supported</td>
</tr>
<tr>
<td>7940</td>
<td>Full</td>
<td>Cisco Jabber for Mac</td>
<td>Not Supported</td>
</tr>
<tr>
<td>7941</td>
<td>Full</td>
<td>Cisco Jabber for Windows</td>
<td>Full³</td>
</tr>
<tr>
<td>7941G-GE</td>
<td>Full</td>
<td>DX70</td>
<td>Full</td>
</tr>
<tr>
<td>7942</td>
<td>Full</td>
<td>DX80</td>
<td>Full</td>
</tr>
<tr>
<td>7942-G</td>
<td>Full</td>
<td>DX650</td>
<td>Full</td>
</tr>
<tr>
<td>7945</td>
<td>Full</td>
<td>IP Communicator</td>
<td>Full</td>
</tr>
<tr>
<td>7945G</td>
<td>Full</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. Using this device to sign in to the application requires the maximum calls setting in Cisco Unified Communications Manager to be set to a minimum of two.
2. If Log in to hunt groups at sign in is selected, the device will reset as part of the login process.
3. Both standard Jabber installations (locally installed on the operator computer) and VXME installations (installed in a VXME environment) are supported as console user devices and end points.
Troubleshooting Guide

This appendix describes notable problems with Cisco Unified Attendant Console Standard and their solutions. It describes the following:

CUCM Upgrade Version Must Match Installed Version.

CUCM Upgrade Version Must Match Installed Version

After entering the Call Manager Detail in the Options window, you see the error message:

*CUCM upgrade version must be matched with the installed version. Please check the connection details and try again.*

Reason

There has been a major Cisco Unified Communications Manager (CUCM) upgrade since Cisco Unified Attendant Console Standard was installed.

Solution

Uninstall and then reinstall Cisco Unified Attendant Console Standard.
Using a Cisco Unified Communications Manager TFTP server for all non-TAPI functions

Cisco Unified Attendant Console Standard can be configured to pass all AXL communications through a Unified Communications Manager TFTP server (not running the CCM service), while sending all TAPI communications to a node running the CCM service. This should only be a consideration for users that wish to disable Tomcat services on their CTI managers.

New Installation Instructions

Step 1
Follow the instructions in Chapter 2, “Install or Upgrade Cisco Unified Attendant Console Standard”, specifying the Cisco Unified Communications Manager TFTP Host Name, Fully Qualified Domain Name (FQDN) or IP address under Step 5.

Step 2
After the PC restarts, you will need to manually download and install the Cisco TAPI client from Cisco Unified Communications Manager.

1. Navigate to your Cisco Unified Communications Manager Administration webpage, and log in.
2. Navigate to Application > Plugins.
3. Search for and download the appropriate Cisco TAPI 32 or 64-bit Client
4. Execute the installer, following the on-screen prompts provide the following data:
   - Number of TSPs to install: 1
   - Provide the Application User specified for your Cisco Unified Attendant Console Standard installation.
   - Provide the CTI Manager 1 (and 2 if applicable) Host Name, Fully Qualified Domain Name (FQDN) or IP address, selecting IPv4 from the associated drop-down menu.
   - Specify a UDP Port Range, Start 50000, End 51019.
   - Select Never Auto-Upgrade.
   - Restart the PC when prompted.
Update Cisco TSP Primary CTI Manager Address, Application User and Password

**Note**
- For more information on how to modify the Cisco Unified Communications Manager directory source address or user credentials, see Changing Cisco Unified Communications Manager directory source details, page 4-7.
- The new Cisco Unified Communications Manager address version must match the existing version.

**Step 1** Launch Cisco TSPx64 Configuration.
**Step 2** Select CiscoTSP001.tsp.
**Step 3** Click Configure.
**Step 4** Make the required modifications:
  - **Primary CTI Manager**
    - Select CTI Manager tab.
    - Provide the new IP Address or Host Name.
  - **Application User Details**
    - Select User tab.
    - Provide User Name and/or Password.
**Step 5** Click OK, then click OK.
**Step 6** Restart the PC.
INDEX

A

Access Control Group
 creating  2-6
accessibility for users with disabilities  1-1
active call information  1-2
alerts, configuring  4-9
application dial rules  5-5
Application User
 assigning devices to, for directory BLF  2-7
 creating and assigning  2-7

B

BLF rules  5-3, 5-7 to 5-11
 adding  5-8
 deleting  5-10
 editing  5-9
 reordering  5-10

C

Call Control pane  1-2
Call History pane  1-2
Cisco Unified Attendant Console Standard
 features  1-1
 installing  2-9
 licensing  2-11 to 2-14
 upgrading  2-9
Cisco Unified Communications Manager
 compatibility  2-4
 configuring  2-5 to 2-8
 connecting to a different  4-7

computer requirements  2-1
contact information
 editing  5-15
 viewing  5-21
contact matching  5-2
contact notes  5-22
contact order  5-19
contacts
 adding  5-14
 searching  5-20
 corporate directory  5-1
 CSV file  5-1
 formats  B-2
 for synchronization  B-2

directory
 device list  4-10
directories  5-1 to 5-23
 editing contacts  5-15
 sorting  5-19
 viewing and using  5-17

directory field mappings  5-3, 5-6
 directory
 change view  5-19
 destination fields  5-6
 group  5-1
 search preferences  5-20
 source fields  5-7
 sources  5-1
 synchronization  5-3 to 5-4

directory filters  5-3, 5-5
creating 5-5
directory groups 5-11 to 5-17
  adding contacts manually 5-14
creating 5-11
deleting 5-12
deleting contacts 5-15
exporting contacts 5-16
importing contacts
renaming 5-12
Directory pane 1-2
directory tabs 5-17
reordering 5-18

E
End User account for Presence 2-8, 4-5
evaluation software, licensing 2-12
exiting Cisco Unified Attendant Console Standard 3-4
export contacts 5-1
exporting contacts 5-16

F
features of Cisco Unified Attendant Console Standard 1-1
file formats when importing data B-1
filtering directories 5-5
firewall exceptions 2-2

H
hardware requirements 2-1
Help, accessing 1-2
hunt group login 3-2, 3-4

I
import/export file formats B-1 to B-4
importing contacts 5-1, 5-13

installing Cisco Unified Attendant Console Standard 2-1 to 2-14
interface, description 1-2
introduction to Cisco Unified Attendant Console Standard 1-1 to 1-3

J
Jabber support 2-2

K
keyboard shortcuts 6-1 to 6-3, 7-1 to ??
  defining and editing 6-2
  removing 6-3
  resetting to default values 6-3

L
licensing 2-11
  evaluation software 2-12
  purchased and upgraded software 2-12

M
main menu 1-2

N
network requirements 2-2

O
operating system support 2-1
operator
  details, setting 4-3
  voicemail prefix, setting 4-8
Options Password 4-2
P

pane
  Call Control  1-2
  Call History  1-2
  Directory  1-2
  Parked Calls  1-2
Parked Calls pane  1-2
phones supported  C-1 to C-2
phone state, directory display  5-17
Presence Server
  configuring  4-5
    multi-domain, configuring  4-6
    single domain, configuring  4-6
presence state, directory display  5-17
purchased and upgraded software, licensing  2-12

R

requirements, hardware and software  2-1

S

searching for contacts  5-20
search preferences  5-20
shared lines  2-4
sign in devices  4-10
Single Sign On
  using  4-4
software
  relicensing  2-14
  requirements  2-1
starting Cisco Unified Attendant Console Standard  3-1 to 3-4, 4-1 to 4-11
synchronization  5-1, 5-3
  configuring  5-4
    from CSV Source File  5-4

T

troubleshooting  D-1
TSP installation  2-10

U

upgrading the software  2-9
User Group
  assigning roles to  2-6
user interface, description  1-2

V

virtualized desktop support  2-2

W

Windows folder permissions  2-3

X

XML file format  B-1