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About This Guide

About This Guide
Introduction
Interactive service offerings have exploded in the last few years, changing the way
subscribers view cable TV. The steady addition of cutting-edge offerings leaves
subscribers asking, “How can I get there NOW?”
With Services Portal 3.0, one click on the remote control provides immediate access
to a menu of interactive services and popular channels.

Purpose
This document provides step-by-step procedures for installing, upgrading, and
configuring your Services Portal version 3.0. It focuses primarily on procedures
rather than conceptual information. A companion guide, Designing the Look and Feel
for Your Services Portal, (part number 4002639) was written to help marketing
personnel make key customization decisions before you install the Services Portal.

Scope
This guide is written for Services Portal version 3.0, which consists of Services Portal
Client version 3.0.1.6 and Services Portal Server version 3.0.1.4.
Note: Screens shown in this guide are simulations and may not exactly reflect your
experience.

Read Me
Please read all instructions before beginning the upgrade process. If you are
uncomfortable with any of the procedures presented in these instructions, contact
Cisco Services for assistance.

Audience
This guide is written for system operators who will install, upgrade, configure,
customize, and maintain the Services Portal.

Related Publications
You may find the following publications useful as resources when you implement
the procedures in this document.
 Designing the Look and Feel of Your Services Portal (part number 4002639)
78-745238-01 Rev D

vii

About This Guide

 Enhancing Your Subscribers' Experience: SARA Configurable Options (part number
4002178)
 Guidelines for Adding URL Modifiers and Replacing URL Keywords (part number
4002527)

Document Version
This is the third release of this document. In addition to minor text and graphic
changes, the following table provides the technical changes to this document.
Description

See Topic

Installation and Upgrade Topics
Updated procedures for compatibility with SR Throughout document
2.7/3.7/4.2
Updated installation and upgrade instructions Throughout document
to include using the new installation tool
(required with Solaris 10 and later)
Added upgrade instructions

Upgrade the Services Portal (on page 53)

Information on preserving your
configurations when you upgrade

Preserving Your Previous Configuration
(on page 57)

Roll back instructions

Rolling Back to a Previous Version (on
page 141)

Information on preserving your
Restore the Configuration (on page 143)
configurations when you roll back the version
Configuration Topics

viii

Updated information regarding highresolution graphics

Throughout document

Added information about using custom fonts
in Services Portal

Define the Title Text Font (on page 118)

Added information about rounding both
edges of buttons

Define Button Edges (on page 96)
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1 Chapter 1
Before You Begin
Introduction
 Which button on the remote control should launch the Services
Portal?
 Do you want the Services Portal to display as a transparent toolbar
over the current channel or should it take up the full screen?
 Which services will you add to the portal?
 Do you have a custom background image for your portal?
This list of questions represents just a few of the many options for
customizing your Services Portal. Before you install and configure the
Services Portal, you need answers to these and other questions.
Each customization option requires careful consideration and
planning. For this reason, we created this chapter to let your
marketing department answer these questions before installation.
All of the information you need to set up the Services Portal is
included in the worksheets contained in this chapter.

In This Chapter
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Chapter 1 Before You Begin

Overview
What is the Services Portal? In short, it is an answer to the question, “How can I get
there NOW?”
Interactive service offerings have exploded in the last few years, changing the way
subscribers view cable TV. With anything-On-Demand (xOD), subscribers can watch
the year’s biggest action flick at their convenience. With walled garden applications
like the Fusion™ application, subscribers can read the news on the TV while
drinking their morning coffee. Subscribers with digital video recorders (DVRs) can
record programs and movies to view later—all from the set-top.
The on-screen program guide is an excellent tool for channel surfing. However, it
can add precious seconds when subscribers just want to watch episode 39 of The
Sopranos, just want to get to the latest traffic report, or just want to review the list of
movies they are recording…NOW! With the Services Portal, one click on the remote
provides immediate access to a menu of interactive services and popular channels.
Important: If you have already upgraded your DNCS System Release, you must
follow the directions in Installing the Services Portal Package Information (on page
58) before you can successfully upgrade Services Portal.

Introduction to Installing and Configuring the Services Portal 3.0
If you do not have a completed copy of these worksheets, contact your marketing
department to obtain answers to the questions presented in the worksheets. Your
marketing department may also provide a paper prototype for how the Services
Portal should look and electronic files of translations for service names and other
text elements.
Note: If you are upgrading Services Portal from a previous version, go to Upgrade
the Services Portal (on page 53).

2
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Services Portal Configuration Worksheets
Refer to these worksheets as you install and configure your Services Portal.

Access, Timers, and Launch Mode
Access Method (circle one):

A key

Guide key

Menu key

Launch the Services Portal each time a subscriber turns on the set-top? (Check
one)
 Yes
 No
Power On Time Out: _______ seconds (applies if Services Portal is a Power-On
service)
Time Out After Activation: ______ seconds
Launch Mode (check one):
 Toolbar
 Full Screen
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Service List
Number of Services to Display at Once: _________ (7 is maximum)
Enter the label and icon number for each service in the order in which you want
them to appear.
Label

Icon
Label
Number

1 (Reserved for IPG)

17

2

18

3

19

4

20

5

21

6

22

7

23

8

24

9

25

10

26

11

27

12

28

13

29

14

30

15

31

16

32

Icon
Number

Button Configuration
Button Color (if different from default): _________________________
Rounding (circle one):

Left Side Rounded

Both Sides Rounded

Change the default text font for buttons? (check one)
 Yes, enter the font to use: _________________________
 No
Notes:
 Custom fonts are only available on high-resolution set-top boxes. Low-resolution
set-top boxes ignore the font settings and use the default fonts. (If you do not
specify a font, the default Services Portal fonts will be used.)
 All fonts must be .bft files.
4
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Button Position and Widths for Toolbar Mode
Use the following form to record custom values for the position and widths of
buttons for the Toolbar mode. You can also refer to this form for default values for
button positions and widths.
Note: If you are using Services Portal with high-resolution graphics, enter these
values as if they are low-resolution graphics. Services Portal will display the
graphics correctly in the high-resolution versions.

Button 1

Button 2

Button 3

Button 4

Button 5

Button 6

Button 7

78-745238-01 Rev D

Default Values

Custom Values

Left = 29

Left =

Top = 42

Top =

Width = 84

Width =

Left = 24

Left =

Top = 64

Top =

Width = 89

Width =

Left = 20

Left =

Top = 86

Top =

Width = 93

Width =

Left = 18

Left =

Top = 108

Top =

Width = 95

Width =

Left = 18

Left =

Top = 130

Top =

Width = 95

Width =

Left = 20

Left =

Top = 152

Top =

Width = 93

Width =

Left = 24

Left =

Top = 174

Top =

Width = 89

Width =

5
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Button Position and Widths for Full Screen Mode
Use the following form to record custom values for the position and widths of
buttons for the Full Screen mode. You can also refer to this form for default values
for button position and width.
Note: If you are using Services Portal with high-resolution graphics, enter these
values as if they are low-resolution graphics. Services Portal will display the
graphics correctly in the high-resolution versions.

Button 1

Button 2

Button 3

Button 4

Button 5

Button 6

Button 7

6

Default Values

Custom Values

Left = 25

Left =

Top = 58

Top =

Width = 95

Width =

Left = 25

Left =

Top = 80

Top =

Width = 95

Width =

Left = 25

Left =

Top = 102

Top =

Width = 95

Width =

Left = 25

Left =

Top = 124

Top =

Width = 95

Width =

Left = 25

Left =

Top = 146

Top =

Width = 95

Width =

Left = 25

Left =

Top = 168

Top =

Width = 95

Width =

Left = 25

Left =

Top = 190

Top =

Width = 95

Width =
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Parental Control
Prevent subscribers from blocking certain services? (check one)
 Yes
 No
If yes, list the services you want to prevent subscribers from blocking.
____________________________________________________________________

Change the default text for any Parental Control messages? (check one)
 Yes
 No
If yes, enter the changes in this form. To minimize data-entry errors, we recommend
that you provide an electronic copy of the list to the installer.
PIN Entry Text
English
French (optional)
Spanish (optional)
PIN Entry Text to Clear Blocked Service
English
French (optional)
Spanish (optional)
Blocked Service Barker Text
English
French (optional)
Spanish (optional)
Blocked Service B Key Text
English
French (optional)
Spanish (optional)
PIN Entry Text to Clear All Blocked Services
English
French (optional)
Spanish (optional)

78-745238-01 Rev D
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Change the default text font for the Parental Control button (the "B" button)?
(check one)
 Yes
 No
If yes, enter the font to use: _________________________
Notes:
 Custom fonts are only available on high-resolution set-top boxes. Low-resolution
set-top boxes ignore the font settings and use the default fonts. (If you do not
specify a font, the default Services Portal fonts will be used.)
 All fonts must be .bft files.

Special Filtering Options
Show or hide blocked services (check one):
 Show
 Hide
Show or hide unauthorized services (check one):
 Show
 Hide

Services Portal Branding
Use a custom background image? (check one)
 Yes
 No
If you are using the same custom background for each SA Resident Application
(SARA) color scheme, list the name of the JPG file:
_________________________________________________
If you are using a different custom background for each SARA color scheme, list the
name of the JPG file for each color scheme:
SARA Color Scheme

Services Portal Custom Background Image

Town Square
Golf Course
Board Walk
Ball Park
Roller Rink
Aquarium
Campground
8
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Do you want to use customized fonts for the Title? (Check one)
 Yes
 No
If yes, list the the custom font here: _________________________
Notes:
 Custom fonts are only available on high-resolution set-top boxes. Low-resolution
set-top boxes ignore the font settings and use the default fonts. (If you do not
specify a font, the default Services Portal fonts will be used.)
 All fonts must be .bft files.
Show Logo Imported by SARA? (Check one)
 Yes
 No
Note: Check No if your logo is embedded in a custom background.
Add Title Through the Services Portal Configuration Tool? (Check one)
 Yes
 No
Note: Check No if your title is embedded in a custom background.
If yes, specify the title to add:
_________________________________________________

Navigational Aids
Page Up and Down (+/-) button images or Up and Down arrow images? check one:
 Page +/ Up and Down arrow images
Enter the location of the button images (x and y coordinates, or approximate
location):
X: ________

Approximate location: ____________________________

Y: ________
Note: If you are using Services Portal with high-resolution graphics, enter these
values as if they are low-resolution graphics. Services Portal will display the
graphics correctly in the high-resolution versions.
Show or hide the Where Am I banner? (applies to Full Screen mode only, check
one):
 Show
 Hide
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General placement of navigation buttons
Note: Specify general placement, such as “lower right corner.” You can also show
placement on your prototype.
Key

Placement

Title Text
A key
B key
Exit key (Toolbar Mode
only)
Select key
MSO logo

10
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2 Chapter 2
Install the Services Portal
Introduction
This chapter contains instructions for installing the Services Portal.
The procedures are listed in sequential order, and they are written
assuming that you can complete them without interruption.

In This Chapter
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Overview
Note: If you are upgrading Services Portal from a previous version, go to Upgrade
the Services Portal (on page 53).

Time To Complete
Installing Services Portal and configuring the application on the Digital Network
Control System (DNCS) takes approximately 1 to 2 hours to complete.

Software Needed
Before starting the installation, make sure that you have the following installation
CDs:




Services Portal Server Installation (version 3.0.1.4)
Services Portal Client Installation (version 3.0.1.6)

Client Software and System Release Compatibility
Services Portal 3.0, consisting of Services Portal Client version 3.0.1.6 and Services
Portal Server version 3.0.1.4, was tested and released against the following software.
Software

Versions

Client Software










System Release

SARA 1.59 and PowerTV OS 3.24
SARA 1.60 and PowerTV OS 3.13
SARA 1.89 and PowerTV OS 6.14
SARA 1.89 and PowerTV OS
SR 2.5/3.5 SP2
SR 2.7/3.7
SR 4.0 SP2
SR 4.2

Notes:
 This section provides compatibility of released software. If you have a question
about current testing status against Services Portal 3.0, contact the representative
who handles your account.
 For a complete configuration listing for the release of Services Portal 3.0, please
contact CiscoServices.

12
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Other Resident Applications
The Services Portal has only been qualified to work with our set-top boxes running
the SA Resident Application (SARA). If you use non-SA set-top boxes, you should be
able to run Services Portal if you also use SARA and the PowerTV operating system.
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Set Up the BFS
The Broadcast File System (BFS) is the primary means of communication between
the DNCS and set-tops (Digital Home Communication Terminals or DHCTs).
The BFS uses data carousels (also known as data pumps or sources) to send the files
that tell the set-top how to properly run specific applications. These carousels make
the information available to all set-tops in the system. However, only those set-tops
specifically authorized and looking for the information receive it.

Process Overview
To set up the BFS to process Services Portal data, you must complete the following
procedures, which are detailed in this section.

14

1

Add the new inband carousel to the PAT table.

2

Add Services Portal to the source list.

3

Define the inband source.

4

Create the inband and out-of-band carousels.

5

Authorize the BFS servers for the inband and out-of-band carousels.

6

Create the client BFS inband and out-of-band servers.

7

Tear down the BFS sessions.
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Add the Inband Carousel to the PAT Table
Determining the Session Number
1 On the DNCS Administrative Console, click the DNCS tab.
2

Click the Application Interface Modules tab.

3

Click Source. The Source List window opens.

4

Click the Source ID column header to sort the list of sources by source ID.

5

Write down two unused source numbers greater than 200 in the following
spaces.
Services Portal Inband Source _______________
Services Portal Out-of-band Source _______________

Notes:

6
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You will use the inband source number as the session number for the inband
carousel in this procedure.



You will use both the inband source and the out-of-band source numbers
later in this section.



Our numbering convention uses even numbers for inband sources and odd
numbers for out-of-band sources.



We recommend that the inband and out-of-band source IDs are sequential if
possible. For example, source ID 202 for inband and source ID 203 for out-ofband.



You must use numbers greater than 200. Source IDs 1 through 200 are
reserved for system-built sources.

Close the Source List window from the File menu.

15
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Adding the Inband Carousel to the BIG PAT Table
Note: If you use Direct ASI instead of a BIG, skip this procedure and go to Adding
the Inband Carousel to the ASI PAT Table (on page 18).
1

From the DNCS Administrative Console, click the Network Element
Provisioning tab.

2

Click BIG. The BIG List window opens.

3

On the BIG List window, double-click the BFS BIG. The Set Up BIG window
opens.

4

Click PAT Configuration. The BIG PAT window opens.

5

Verify that the session numbers and program numbers are in sequential order.

6

Does your BIG PAT table meet the requirements specified in the previous step?




16

If yes, go to the next step.
If no, stop this procedure and call Cisco Services.
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7

Click New Entry on the BIG PAT window. The BIG PAT Setup window opens.

8

For Session MAC Address, type twelve zeroes (00:00:00:00:00:00), and press
Tab.
Note: Do not type the colons.

9

For Session Number, type the source ID for the inband carousel, and click Save.
You recorded this number in Determining the Session Number (on page 15).
Note: The values for Program Number and PMT PID appear automatically.

10 Close the BIG PAT window.
11 In the Set Up BIG window, click Apply and then click Cancel. Changes to the
BIG PAT window are applied, and the Set Up BIG window closes.
12 Go to Adding the Services Portal to the Source List (on page 20).

78-745238-01 Rev D
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Adding the Inband Carousel to the ASI PAT Table
1 On the DNCS Administrative Console, click the Application Interface Modules
tab.

18

2

Click the BFS Admin tab. The Site BFS Administration window opens.

3

Click the Hosts tab.

4

Double-click dncsatm. The Set Up BFS Host window opens.

5

Click PAT Configuration. The Inband Data PAT window opens.

6

Verify that the session numbers and program numbers are in sequential order.
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7

Does your PAT table meet the requirements specified in the previous step?




If yes, go to the next step.
If no, stop this procedure and call Cisco Services.

8

Click New Entry on the BIG PAT window. The BIG PAT Setup window opens.

9

For Session MAC Address, type twelve zeroes (00:00:00:00:00:00), and press
Tab.
Note: Do not type the colons.

10 For Session Number, type the source ID for the inband carousel, and click Save.
You recorded this number in Determining the Session Number (on page 15).
Note: The values for Program Number and PMT PID appear automatically.
11 Close the BIG PAT window.
12 In the Inband Data Pat window, click Close.
13 In the Set Up BFS Host window, click Save then Cancel.
14 Close the Site DNCS BFS Administration window.
15 Go to Adding the Services Portal to the Source List (on page 20).
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Adding the Services Portal to the Source List
1

From the DNCS Administrative Console, click the DNCS tab.

2

Click the System Provisioning tab.

3

Click Source in the Service Provisioning group. The Source List window opens.

4

On the File menu, click New. The Set Up Source window opens.

5

For Source Name, type SP_ib_source.

6

For Source ID, type the source ID you recorded for the inband source in the
previous procedure.

7

Click Save. The system saves the source information in the DNCS database and
closes the Set Up Source window. The Source List window updates to include
the new source.

8

Leave the Source List window open, and go to Defining the Inband Source, next
in this document.

Defining the Inband Source
After you add the Services Portal sources to the DNCS database, you must define
parameters for the inband source so that the BFS knows how to process the service
content.
When you define a source, you also build a session. Sessions define and allocate the
resources that the network uses to deliver service content. It may help to think of a
session as a pipeline through the DBDS that delivers specific service content.
Complete these steps to define the inband BFS source.
Note: This process is also known as provisioning the source.

20

1

In the Source List window, select the SP_ib_source.

2

On the File menu, click Source Definitions. The Source Definition List window
opens for SP_ib_source.

3

On the File menu, click New Digital. The Set Up Digital Source Definition
window opens.
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4

In the Session ID box on the left, type 12 zeros.

5

In the Session ID box on the right, type the source ID you used for the inband
source.
Example:

6

Digital source sessions usually become effective as soon as they are saved. Do
you want to delay the effective date and time of this session?




If yes, go to the next step.
If no, go to step 12.

Note: Subscribers cannot view the Services Portal until either the session is saved
or the time that you specify arrives.
7

Click Specify effective date and time, and then click Next. The Set Start
Time/Date window opens.

8

In the Effective Date box, type the month, day, and year you want subscribers to
be able to view the Services Portal. Use the format MM/DD/YYYY.

78-745238-01 Rev D
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9

In the Effective Time box, type the hour, minute, and second you want
subscribers to be able to view the Services Portal.
Note: Enter the time in 12-hour time format. You must type two digits for each
value, the system adds the colons for you.

10 Click AM or PM.
11 Click Next. The Define Session window opens.
12 Click the BFS option.
13 Click Next. The Save Source Definition window opens.
14 Click Save. The system saves the source definition in the DNCS database, and
creates the session you built for it. The Source Definition List refreshes to show
the new source definition.
Example:

15 Close the Source Definition List window from the File menu.
16 Close the Source List window from the File menu.
17 Go to Creating the Inband BFS Carousel, next in this section.

Creating the Inband BFS Carousel
The BFS uses data carousels to send the files that tell the set-top how to run
applications, such as Services Portal. The inband carousel sends data files through
the BFS QAM modulator to the set-tops at a rate of about 27 megabits per second
(Mbps).
Complete these steps to create the inband BFS carousel for the Services Portal.
Notes:
 For Source Name in step 5, type SP_ib_source.
 For Source ID in step 6, type the ID for the inband source you recorded in Add
the Inband Carousel to the PAT Table (on page 15).
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1

From the DNCS Administrative Console, click the Application Interface
Modules tab.

2

Click BFS Admin. The BFS Administration window opens.
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3

Click the Sources tab.

4

On the File menu, click New. The Set Up BFS Source window opens.

5

For Source Name, type the source name for the inband source.

6

For Source ID, type the source ID for the inband source.

7

For Source Type, click BFS.

8

For Transport Type, click In-band.

9

For Data Rate, type 1.00.
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10 For Block Size, type 4000.
Note: We recommend a block size of 4000 bytes for optimum performance.
However, if the broadband integrated gateway (BIG) in your headend cannot
process the data at this rate, use the default block size of 1024 bytes.
11 Keep the default value for the Indication Interval.
12 For Source, click enable.
13 From Available Hosts, select dncsatm.
14 Click Add. The dncsatm host moves to Selected Hosts.
15 Click Save.
16 Go to Creating the Out-of-Band BFS Carousel, next in this section.

Creating the Out-of-Band BFS Carousel
The out-of-band carousel acts as a backup in case the inband path becomes
unavailable for some reason. The out-of-band carousel sends data files through the
QPSK modulator to the set-tops in your system at a rate of about 1.54 Mbps.
Complete these steps to create the out-of-band BFS carousel for the Services Portal.
Notes:
 For Source Name in step 3, type SP_oob_source.
 For Source ID in step 4, type the source ID for the out-of-band source you
recorded in Add the Inband Carousel to the PAT Table (on page 15).
1

In the BFS Administration window, click the Sources tab.

2

On the File menu, click New. The Set Up BFS Source window opens.

3

For Source Name, type the source name for the out-of-band source.

4

For Source ID, type the source ID for the out-of-band source.

5

For Source Type, click BFS.

6

For Transport Type, click Out-of-band.

7

For Data Rate, type .01.

8

For Block Size, type 1024.

9

Keep the default value for Indication Interval.

10 For Source, click enable.
11 From Available Hosts, select dncsatm.
12 Click Add. The selection moves to Selected Hosts.
13 Click Save.
14 Go to Authorizing the Services Portal Inband Server, next in this section.

24
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Authorizing the Services Portal Inband Server
1

On the BFS Administration window, click the Servers tab.

2

On the File menu, click New. The Authorize BFS Server window opens.

3

For Server Name, type:
SP_ib

4

From Available Sources, select SP_ib_source.

5

Click Add. The server appears in Selected Sources.

6

Click Save.

7

Go to Authorizing the Out-of-Band Server, next in this section.

Authorizing the Out-of-Band Server
1

Ensure the Servers tab is still selected in the BFS Administration window.

2

On the File menu, click New. The Authorize BFS Server window opens.

3

For Server Name, type:
SP_oob

4

From Available Sources, select SP_oob_source.

5

Click Add. The selection moves to Selected Sources.

6

Click Save.

7

Close the BFS Administration window from the File menu.

8

Go to Creating the Client BFS Inband Server, next in this section.
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Creating the Client BFS Inband Server

26

1

On the DNCS Administrative Console, click the Application Interface Modules
tab.

2

Click BFS Client. The Broadcast File Server List window opens.

3

On the File menu, click New Server. The Set Up Server window opens.

4

In the Server Name list, click SP_ib.

5

For mode, click 1-way.

6

From Available Sources, select SP_ib_source.

7

Click Add. The SP_ib_source is added to Selected Sources.

8

Click Save.

9

Go to Creating the Client BFS Out-of-Band Server, next in this section.
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Creating the Client BFS Out-of-Band Server
1

Return to the Broadcast File Server List window.

2

On the File menu, click New Server. The Set Up Server window opens.

3

In the Server Name list, click SP_oob.

4

For mode, click 1-way.

5

From Available Sources, select SP_oob_source.

6

Click Add. The SP_oob_source is added to Selected Sources.

7

Click Save.

8

Close the Broadcast File Server List window from the File menu.

9

Go to Tearing Down the BFS Sessions, next in this section.

78-745238-01 Rev D

27

Chapter 2 Install the Services Portal

Tearing Down the BFS Sessions
1

From the DNCS tab, click the Utilities tab, and then click Session List. The
Session Filter window opens.

2

Select the BFS QAM and click Display Sessions for Selected QAM. The session
data for the BFS QAM appears.

3

Click the Select box adjacent to the lowest numbered session. A checkmark
appears in the Select box to the left of that session.

4

Click Teardown Selected Sessions. BFS will tear down all sessions and will then
rebuild each session.
Note: It may take a few minutes for all of the sessions to rebuild.

28

5

When all sessions have been rebuilt (the session IDs are green in color), click Exit
all Session screens.

6

Go to Define a Services Portal Package (on page 29).

78-745238-01 Rev D

Define a Services Portal Package

Define a Services Portal Package
After you set up the BFS, you must define a Services Portal package.
A package consists of one or more services that are available only to subscribers
authorized for the package.
Use an existing authorization package, or create a new package for the Services
Portal.
 If you want to use an existing package, go to Determining the Services Portal
Package EID (on page 30).
 If you want to create a new package, continue to Setting Up a New Services
Portal Package, next in this section.

Setting Up a New Services Portal Package
Complete these steps to define a new Services Portal authorization package.
1

From the DNCS Administrative Console, click the DNCS tab.

2

Click the System Provisioning tab.

3

Click Package. The Package List window opens.
Note: If Subscription Only is selected, click Show and choose All Packages to
view a list of all packages.

4

On the File menu, click New. The Set Up Package window opens.

5

For Package Name, enter an appropriate name for the package, such as Services
Portal.
Important: The Unlimited option for Duration is selected by default. This option
lets the subscriber have unlimited access to the package. Do not change this
option without first consulting CiscoServices.

6

Click Save.

7

Go to Determining the Services Portal Package EID, next in this section.
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Determining the Services Portal Package EID
When you add a package, the DNCS automatically assigns an EID to the package.
When you install the Services Portal server, you need this EID number to register the
Services Portal package with the SAM.
However, the SAM can recognize only the decimal value of the package EID. For a
variety of system design reasons, the Set Up Package window displays the EID as a
hexadecimal value.
Complete these steps to locate the EID for the Services Portal package and convert
the EID from a hexadecimal value to a decimal value.

30

1

In the Package List window, select the package for the Services Portal.

2

On the File menu, click Open. The Set Up Package window opens.

3

Record the number shown for the EID here ____________________.

4

Click Cancel to close the Set Up Package window and return to the Package List
window.

5

Close the Package List window from the File menu.

6

Your next step is to convert the package EID from a hexadecimal value to a
decimal value. Go to Converting a Package EID to Decimal, next in this section.
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Converting a Package EID to Decimal
1

After you determine the Services Portal package EID, use the following table to
locate the EID in the HEX column.

2

Then, locate the corresponding decimal value in the DEC column.
For example, if the package EID is 1f, the decimal value is 31.

3
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Record the decimal value for the package EID here _________.
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Install the Services Portal Server
This section contains instructions for installing the Services Portal server onto the
Application Server.
Note: If you are upgrading Services Portal from a previous version, go to Upgrade
the Services Portal (on page 53).
The filenames and UNIX syntax in these procedures are case-sensitive. Type
filenames and paths exactly as they appear in the procedures.

Recording Configuration Information
During the server installation, verify the following configuration information:
 DNCS_HOST - the server name or the alias of the server where the DNCS is
running
 APPSERV_HOST - the server name or the alias of the server where the
Application Server is running
Before you begin the installation process, complete the following steps to record the
configuration information you need for the server installation.
1

From the Application Server, open an xterm window.

2

Log in as dncs user.
Type echo $DNCS_HOST and press Enter.

3

Record the value that appears in the space provided.
DNCS_HOST _________________________________

4

Type echo $APPSERV_HOST and press Enter.

5

Record the value that appears in the space provided.
APPSERV_HOST _______________________________

6

32

Leave the xterm window open, and go to one of the following:



If this is a new installation, go to Installing the Services Portal Server, next
in this document.



If this is an upgrade to a new version, go to Upgrading the Services Portal
Server (on page 61).
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Installing the Services Portal Server
1

Make sure you are logged in as root on the Application Server. If not, follow
these instructions.

a

Open an xterm window.

b

Log on as root (su).

c

Type the root password and press Enter.

d

Source in the environment variables again by typing the following command
and pressing Enter:
. /dvs/appserv/bin/appservSetup

2

Insert the Services Portal Server CD into the CD-ROM of the Application Server.
Wait for the Application Server to mount the CD.

3

In an xterm window on the Application Server where you are logged in as root
user, type df and press Enter to confirm that the Application Server mounted the
CD successfully. The last line of the df command output lists the number of free
disk blocks on the CD.
Note: The fact that the CD is listed in the df command output indicates that the
Application Server mounted the CD successfully.

4

Type cd /cdrom/cdrom0 and press Enter.

5

Type install_pkg and press Enter.
Results:




The Application Server lists the packages that will be installed.
A message appears asking you to confirm that you want to proceed with the
installation.

6

Type y and press Enter. A license agreement window appears.

7

Press Enter to start the installation. The system displays installation
configuration options. The following list describes the configuration options
available.
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DNCS_HOST — The server name or the alias of the server where the DNCS
is running. This server is usually aliased as dncs_host.



APPSERV_HOST — The server name or the alias of the server where the
appserv is running. This server is usually aliased as appserv_host.



BASDIR — The base directory where the Application Server was installed
(usually /dvs).







APPDIR — The directory where you want the Services Portal to be installed.
SVCNAME — What you want to call the Services Portal SAM Service.
LDESC — The long description of the Services Portal SAM Service.
APPURL — The application URL for Services Portal SAM Service.
INFORMIXDIR — The directory where Informix is located on the dncs
machine.
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8

DNCSDB — The name of the DNCS database.

Do the DNCS_HOST and APPSERV_HOST values match the values you
recorded in Recording Server Configuration Information (on page 56)?



9

INFORMIXSERVER — The alias of the computer where Informix is located.

If yes, go to the next step.
If no, change the appropriate values and then go to the next step.

Widen the xterm window to the entire width of your screen. This helps you see
the remaining steps clearly.

10 Type the number corresponding to APPURL.
11 Retype the entire SAM URL, making the appropriate changes as detailed in the
following steps.
a

Add the version number of the Services Portal client (3.0.1.x) immediately
after the ispguide.ptv; parameter. Use the format version=x.x.x.x
Example: If you are using Services Portal client version 3.0.1.5, type
version=3.0.1.5 (type the periods).

b

Add the EID number (package number) immediately following the version
number parameter. You recorded the EID earlier in this document. Use the
format EID=#.

c

We recommend that you download the Services Portal onto the set-tops as
part of the boot procedure. However, if you experience a significant increase
in boot time, you can set loadOnBoot to false (F).
Do you want to load the application on boot?
–

If yes, leave loadOnBoot=T.

–

If no, change the parameter to loadOnBoot=F.

Example:
bfs://SP_ib/ispguid.ptv;version=3.0.1.5; EID=2;obstructedRect=0,0,639,479;
loadOnBoot=T
Important: This information should appear continuously on one line. Do not
insert any spaces.
12 Type c and press Enter to continue the installation. The software begins loading
and the system displays an installation of SAIisp was successful message when
it has completed.
13 In the xterm window, type cd / and then press Enter. The root directory becomes
the working directory.
14 Type eject cd and then press Enter. The system ejects the CD.
15 Go to Save the Configuration (on page 35).
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Save the Configuration
This section provides instructions for saving the configuration defined during server
installation.

Saving the Configuration
1

From the DNCS Administrative Console, click the Server Applications tab.

2

Click Reload Applications. The Services Portal button appears on the Server
Applications tab.

3

Click the Services Portal button. The SP Service Guide opens.

4

On the File menu, click Save. The system creates the config.dat file. A message
similar to the following appears at the bottom of the Services Portal window:
Config file saved at: /dvs/appFiles/ServicesPortal/data/

5

On the File menu, click Exit. The SP Service Guide closes.

6

Go to Install the Services Portal Client (on page 36).
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Install the Services Portal Client
This section contains instructions for installing the Services Portal client onto the
Application Server.
The filenames and UNIX syntax in these procedures are case-sensitive. Type
filenames and paths exactly as they appear in the procedures.

Installing the Services Portal Client
1

Insert the Services Portal Client CD into the CD-ROM drive of the Application
Server. Wait for the Application Server to mount the CD.

2

In an xterm window on the Application Server where you are logged in as root
user, type df and press Enter to confirm that the Application Server mounted the
CD successfully. The last line of the df command output lists the number of free
disk blocks on the CD.
Note: The fact that the CD is listed in the df command output indicates that the
Application Server mounted the CD successfully.

3

Type cd /cdrom/cdrom0 and press Enter.

4

Type install_pkg and press Enter.
Results:




The Application Server lists the packages that will be installed.
A confirmation message appears asking you to confirm that you want to
proceed with the installation.

5

Type y and press Enter. A license agreement window appears.

6

Press Enter to start the installation. The system displays an installation
configuration menu.

7

Verify the inband source ID (the number corresponding to INBFSSRC). Is the
inband source ID correct?



8

If yes, click Next.
If no, type the inband source ID for Services Portal and Press Enter.

Verify the out-of-band source ID (the number corresponding to OBFSSRC). Is
the out-of-band source ID correct?




If yes, Type c and press Enter to continue the installation.
If no, type the out-of-band source ID for Services Portal and type c and press
Enter to continue the installation.

The software begins loading and the system displays an installation of SAIisp
was successful message when it has completed.
9
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In the xterm window, type cd / and then press Enter. The root directory becomes
the working directory.
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10 Type eject cd and then press Enter. The system ejects the CD.
11 Do you need to add support for Pace set-tops?
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If yes, go to Install Pace Set-Top Support (on page 40).
If no, go to Define How Subscribers Open the Services Portal (on page 46).
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Install Additional Set-Top Support for Services
Portal
Follow the instructions in this section to set up support for additional set-tops (Pace
and/or RNG/Linux set-tops), which requires the following steps:
1

Create new directories in the /dvs/appFiles/ServicesPortal directory.

2

Copy the SARA ptv file to the correct directory.

3

Acquire and copy the additional ptv files to the correct directories.




For Pace set-tops, see Install Pace Set-Top Support (on page 40)
For RNG/Linux set-tops, see Install RNG/Linux Set-Top Support (on page
42)

4

Set up the BFS client for the new ptv files.

5

Set up the SAM service for the new ptv files.

This section contains procedures for each of these steps.

Creating New Directories for the ptv Files
1

Open an xterm window on the Application Server.

2

Type the following command and press Enter to make the Services Portal
directory active.
cd /dvs/appFiles/ServicesPortal

3

Create the directory cpu1 by typing the following command and pressing Enter.
mkdir cpu1

4

Create the directory cpu2 by typing the following command and pressing Enter.
mkdir cpu2

5

Create the directory cpu3 by typing the following command and pressing Enter.
mkdir cpu3

6

38

Go to Copying the SARA ptv File to the Correct Directory (on page 39).
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Copying the SARA ptv File to the Correct Directory
1

In the Application Server xterm window, move the SARA ptv file to the cpu1
directory by typing the following command and pressing Enter.
mv ispguid.ptv /dvs/appFiles/ServicesPortal/cpu1

2

3

Do you need to add support for Pace set-tops?



If yes, go to Install Pace Set-Top Support (on page 40). After you have
finished there, go to step 3.



If no, go to step 3.

Do you need to add support for RNG/Linux set-tops?
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If yes, go to Install RNG/Linux Set-Top Support (on page 42).
If no, go to Setting Up the BFS Client for the Additional ptv Files (on page
43).
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Install Pace Set-Top Support
Follow the instructions in this section to set up support for the Pace set-tops, which
requires the following steps:
1

Acquire the ptv file from the FTP server.

2

Copy the ptv file to the correct directory.

3

Set up the BFS client for the Pace ptv file.

4

Set up the SAM service for the Pace ptv file.

This section contains procedures for each of these steps.
Acquiring and Copying the Pace ptv File to the Correct Directory
1 In the Application Server xterm window, type cd /export/home/dncs/download
and press Enter.
2

Log on to the FTP server.
Notes:



The address of the server is ftp.sciatl.com or 192.133.243.133.
Note: The address for the FTP server is subject to change. If you are unable to
reach the FTP server, please contact Cisco Services for the latest address.




The username is anonymous.
The password is the e-mail address of the person logging in.

3

Type cd /pub/scicare/RELEASED/ServicesPortal/Pace and press Enter.

4

Type bin and press Enter. The system sets the ftp transfer mode to binary.

5

Type hash and press Enter. The system configures itself to display hash marks
that show file-transfer progress.

6

Type prompt and press Enter. This command turns off the interactive mode of
the FTP utility.

7

Type get ispguid.ptv and press Enter.
Note: This command starts the transfer of the file from the FTP server to the
Application Server. A # symbol displays on the screen for each 8192 bytes
transferred from the FTP server to the Application Server or DNCS.

8

40

When the download is complete, type bye and press Enter to log out of the FTP
server.
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9

Go to the directory that contains the Pace ptv file by typing the following
command and pressing Enter.
cd /export/home/dncs/download

10 Move the Pace ptv file to the cpu2 directory by typing the following command
and pressing Enter.
mv ispguid.ptv /dvs/appFiles/ServicesPortal/cpu2
11 Do you need to add support for RNG/Linux set-tops?
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If yes, go to Install RNG/Linux Set-Top Support (on page 42).
If no, go to Setting Up the BFS Client for the Additional ptv Files (on page
43).

41

Chapter 2 Install the Services Portal

Install RNG/Linux Set-Top Support
Follow the instructions in this section to set up support for the RNG/Linux set-tops,
which requires the following steps:
1

Acquire the ptv file from the FTP server.

2

Copy the ptv file to the correct directory.

3

Set up the BFS client for the RNG/Linux ptv file.

4

Set up the SAM service for the RNG/Linux ptv file.

This section contains procedures for each of these steps.
Acquiring and Copying the RNG/Linux ptv File to the Correct Directory
1 In the Application Server xterm window, type cd /export/home/dncs/download
and press Enter.
2

Log on to the FTP server.
Notes:



The address of the server is ftp.sciatl.com or 192.133.243.133.
Note: The address for the FTP server is subject to change. If you are unable to
reach the FTP server, please contact Cisco Services for the latest address.




The username is anonymous.
The password is the e-mail address of the person logging in.

3

Type cd /pub/scicare/RELEASED/ServicesPortal/Linux_RNG and press Enter.

4

Type bin and press Enter. The system sets the ftp transfer mode to binary.

5

Type hash and press Enter. The system configures itself to display hash marks
that show file-transfer progress.

6

Type prompt and press Enter. This command turns off the interactive mode of
the FTP utility.

7

Type get ispguid.ptv and press Enter.
Note: This command starts the transfer of the file from the FTP server to the
Application Server. A # symbol displays on the screen for each 8192 bytes
transferred from the FTP server to the Application Server or DNCS.

8

When the download is complete, type bye and press Enter to log out of the FTP
server.

9

Go to the directory that contains the RNG/Linux ptv file by typing the following
command and pressing Enter.
cd /export/home/dncs/download

10 Move the RNG/Pace ptv file to the cpu3 directory by typing the following
command and pressing Enter.
mv ispguid.ptv /dvs/appFiles/ServicesPortal/cpu3
11 Go to Setting Up the BFS Client for the Additional ptv Files (on page 43).
42
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Setting Up the BFS Client for the Additional ptv Files
1

On the DNCS, click the Application Interface Modules tab and click BFS Client.
The Broadcast File Server List window opens.

2

Create the cpu1 directory using the following directions:

3




Highlight the SP_ib BFS in the Broadcast File Server List list.




Type cpu1 in the Directory Name field.
Click Save.

Create the cpu2 directory using the following directions:





4

Select File > New Directory. The Set Up Directory window opens.

Highlight the SP_ib BFS in the Broadcast File Server List list.
Select File > New Directory. The Set Up Directory window opens.
Type cpu2 in the Directory Name field.
Click Save.

Create the cpu3 directory using the following directions:






Highlight the SP_ib BFS in the Broadcast File Server List list.
Select File > New Directory. The Set Up Directory window opens.
Type cpu3 in the Directory Name field.
Click Save.

5

Double-click the SP_ib BFS to expand its contents.

6

Set up the link for the cpu1 directory using the following directions:
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Highlight the cpu1 directory. Select File > New Link. The Set Up Link
window opens.




Type cpu1 for the Link Name.
The Source Name should be SP_ib.
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7

8

9
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Type /dvs/appFiles/ServicesPortal/cpu1/ispguid.ptv for the Linked Path.
Click Save.

Set up the link for the cpu2 directory using the following directions:



Highlight the cpu2 directory. Select File > New Link. The Set Up Link
window opens.






Type cpu2 for the Link Name.
The Source Name should be SP_ib.
Type /dvs/appFiles/ServicesPortal/cpu2/ispguid.ptv for the Linked Path.
Click Save.

Set up the link for the cpu3 directory using the following directions:



Highlight the cpu3 directory. Select File > New Link. The Set Up Link
window opens.






Type cpu3 for the Link Name.
The Source Name should be SP_ib.
Type /dvs/appFiles/ServicesPortal/cpu3/ispguid.ptv for the Linked Path.
Click Save.

Close the Broadcast File Server List window.
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Setting Up the SAM Service for the Additional ptv Files
1

On the DNCS, click the Application Interface Modules tab and click SAM
Service. The SAM Service List window opens.

2

Double-click the _POWR SAM Service. The Set Up SAM Service window opens.

3

In the Application URL field, edit the link to insert /CPU between //SP_ib and
/ispguid.ptv.
Example: After editing, the link should look similar to the following link:
bfs://SP_ib/CPU/ispguid.ptv;EID=41;version=3.0.1.5;obstructedRect=0,0,639,47
9;loadOnBoot=T

4

Click Save.

5

In the SAM Service List window, double-click the _KEYA SAM Service. The Set
Up SAM Service window opens.

6

In the Application URL field, edit the link to insert /CPU between //SP_ib and
/ispguid.ptv.
Example: After editing, the link should look similar to the following link:
bfs://SP_ib/CPU/ispguid.ptv;EID=41;version=3.0.1.5;obstructedRect=0,0,639,47
9;loadOnBoot=T

7

Click Save.

8

Close the SAM Service List window.
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Define How Subscribers Open the Services Portal
Subscribers can open the Services Portal by pressing one of the following keys on the
remote control:
 A key
 Guide key
 Menu key
Choose the best access method for your subscribers. You can only assign one launch
key for all subscribers.
Complete one of the following procedures based on your selection.
Important: Do not use the Menu key to launch the Services Portal unless all of your
Services Portal customers are using a remote with a Menu key.

Defining the A Key or the Guide Key to Open the Services Portal
1

46

Complete the following steps to open the SP Service Guide.

a

From the DNCS Administrative Console, click the Server Applications tab.

b

Click Services Portal. The SP Service Guide opens with the Display Frame
tab selected.

2

Click the Display Information tab.

3

For Activation through, click either A Key or Guide Key. A confirmation
message appears.
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4

Click Yes to register the key.
Important: If you change your mind and register a different key later, keep in
mind that the SAM Service is automatically built based on the SAM URL you
specified during the server installation. Therefore, if you manually change the
SAM URL after you install the server, you need to add these changes to the SAM
URL after you register the new key.
For example, if you change the EID (package number), you need to make this
change again from the Set Up SAM Service window on the DNCS.

5

Go to Authorize a Test Set-Top (on page 49).
Important: Do not go to Defining the Menu Key to Open the Services Portal.
You can define only one launch key.

Defining the Menu Key to Open the Services Portal
Important: Do not use the Menu key to launch the Services Portal unless all of your
Services Portal customers use remote controls with Menu keys. Currently, the
following AllTouchTM remote control models have Menu keys: AT2000, AT2400,
AT8420, and the AT8400. Future models of remote controls may also support Menu
keys.
1

From the DNCS Administrative Console, click the Application Interface
Modules tab.

2

Click SAM Service. The SAM Service List window opens.

3

On the File menu, click New. The Set Up SAM Service window opens.

4

For Service Name, type Services Portal Menu.

5

For Short Description, type _MENU.

6

For Long Description, type Services Portal Menu.

7

In the Application URL box, type the URL for Services Portal. Make sure that
you type the EID # of the Services Portal package after the EID= parameter.
Example:
bfs://SP_ib/ispguid.ptv;version=3.0.1.5; EID=2;obstructedRect=0,0,639,479;
loadOnBoot=T

8
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For Logo, make sure the value is 0.
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9

For Parameter, make sure that Number is selected with a value of 0.

10 Click Save.
Important: If you use the Menu key, do not select either the A key or Guide key
option from Activation through in the Display Information tab for the SP
Service Guide.
11 Go to Authorize a Test Set-Top (on page 49).
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Authorize a Test Set-Top
If you created a new authorization package for the Services Portal, you need to
provision set-tops with this new package.
This section contains instructions for adding the Services Portal package to the list of
packages that are available to an individual set-top. Use these instructions to test an
individual set-top or a small sample of set-tops.
If you want to add the Services Portal Package to a large number of set-tops at once,
you must add this package through your billing system.

Authorizing a Test Set-Top with a Services Portal Package
Complete these steps to provision a set-top with the Services Portal package.
1

On the DNCS Administrative Console, click the DNCS tab.

2

Click the Element Provisioning tab.

3

Click DHCT. The DHCT Provisioning window opens.

4

In the DHCT Provisioning window, do the following:
a

Click Open.

b

Click By MAC Address.

c

Type the MAC Address of a DHCT in the By MAC Address box.

d

Click Continue. The Set Up DHCT window opens.

5

Click the Secure Services tab. The Secure Services tab of the Set Up DHCT
window opens, which displays available and selected packages.

6

In the Available box, select the Services Portal package.
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7

Click Add. The package appears in the Selected box.

8

Click Save.

9

Repeat steps 4 through 8 for each set-top you want to test.

10 In the DHCT Provisioning window, click Cancel.
11 Go to Add the Font Files to the BFS Server (on page 51).
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Add the Font Files to the BFS Server
Before you can use custom fonts on the Title, on buttons, or for Parental Control
messages, you must add links to the font files you want to use on the BFS server.
This section includes the procedures for adding the font file links to the BFS server.
Notes:
 Custom fonts are only available on high-resolution set-top boxes. Low-resolution
set-top boxes ignore the font settings and use the default fonts.
 If you do not specify a font, the default Services Portal fonts will be used.
 Fonts must be Binary File Transfer (.bft) files. Conversion utilities (such as Font
Gizmo from PowerTV®) exist to convert font files to .bft files. Contact Cisco
Services for more information.
 The fonts you use must be placed in the application server's
/dvs/appFiles/ServicesPortal/data directory.

Adding the Font Files to the BFS Server
1

On the DNCS Administrative Console, click the Application Interface Modules
tab.

2

Click BFS Client. The Broadcast File Server List window displays.
Note: If your DNCS hosts multiple sites, you must first select the site associated
with the Services Portal before the Broadcast File Server List window displays.

3

Click SP_ib.

4

From the File menu, select New Link. The Set Up Link window displays.

5

Type the name of the font in Link Name.
Example: If your font name is font1.bft, type font1.bft in Link Name.

6

Type the path to the font file in Linked Path.
Example: Type /dvs/appFiles/ServicesPortal/data/font1.bft in Link Name.

7

Click Save. The Set Up Link window closes.

8

Repeat steps 3 through 7 for each font you want to use with Services Portal.
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9

When you are finished linking the fonts, select File then Close on the Broadcast
File Server List window.

10 Do you want to launch the Services Portal each time a subscriber turns on the
set-top?

52



If yes, go to Launching the Services Portal When the Set-Top is Powered On
(on page 67)



If no, go to Defining Timeouts (on page 71)
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3 Chapter 3
Upgrade the Services Portal
Introduction
This chapter contains the procedures for upgrading the Services Portal
from a previous version. Use these procedures only if you have
previously installed an earlier version of Services Portal. If you are
installing Services Portal for the first time, or on a new server, follow
the procedures in Install the Services Portal (on page 11).

In This Chapter
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Before You Begin
There are a few considerations you should make before you upgrade your Services
Portal:
 If you have already upgraded your DNCS System Release, you must follow the
directions in Installing the Services Portal Package Information (on page 58)
before you can successfully upgrade Services Portal.
 If your marketing department wants to change the look and feel of the Services
Portal, make sure they give you a completed copy of the Services Portal
configuration worksheets. You can find the worksheets in Services Portal
Configuration Worksheets (on page 3) and in Designing the Look and Feel of Your
Services Portal.
 The upgrade process reads the configuration of the current installation and uses
those settings to configure the upgrade.
However, you should gather some configuration information of your DBDS. See
Recording Configuration Information (on page 32) for more information on
gathering this information.
 If you feel you might need to roll back to the previous version of Services Portal,
for any reason, make sure you follow these recommendations:
-

Keep your installation CDs of the previous version of Services Portal Client
and Server.

-

Make sure to follow the procedures in Preserving Your Previous
Configuration (on page 57) as a precaution.

Note: The upgrade process overwrites the existing config.dat file, but it preserves
the configuration from the previous version.
Important: The filenames and UNIX syntax in these procedures are case-sensitive.
Type filenames and paths exactly as they appear in the procedures.

54

78-745238-01 Rev D

Before You Begin

Information You Need Before You Upgrade
You will need to gather the following information before you begin the upgrade to
Services Portal 3.0. Record the information in the space provided.
Information needed

Found in...

Used in...

Version number of the
Services Portal client
(3.0.1.x)

On the SP Client
Installation CD

SAM URL (APPURL)

Services Portal package Go to Determining the
Services Portal
EID number
(hexadecimal)
Package EID (on page
30) for more
information

Record information
here

SAM URL (APPURL)

Services Portal client
inband source ID

Go to Defining the
Client configuration
Inband Source (on page (INBFSSRC)
20) for more
information

Services Portal client
out-of-band source ID

Go to Creating the
Client BFS Out-ofBand Server (on page
27) for more
information

Client configuration
(OBFSSRC)

Upgrade Process Overview
The upgrade process consists of the following tasks:
 Recording server configuration information
 Preserving your previous configuration
 Installing the Services Portal package information (only if you have upgraded
your DNCS System Release since the previous Services Portal installation)
 Uninstalling the previous version of Services Portal
 Upgrading the Services Portal Server
 Saving the Services Portal Server configuration
 Upgrading the Services Portal client
 Updating the Services Portal SAM Service
The following section details the procedures for each of these tasks.

78-745238-01 Rev D

55

Chapter 3 Upgrade the Services Portal

Recording Server Configuration Information
During the server installation, verify the following configuration information:
 DNCS_HOST - the server name or the alias of the server where the DNCS is
running
 APPSERV_HOST - the server name or the alias of the server where the
Application Server is running
Before you begin the installation process, complete the following steps to record the
configuration information you need for the server installation.
1

From the Application Server, open an xterm window.

2

Log in as dncs user.
Type echo $DNCS_HOST and press Enter.

3

Record the value that appears in the space provided.
DNCS_HOST _________________________________

4

Type echo $APPSERV_HOST and press Enter.

5

Record the value that appears in the space provided.
APPSERV_HOST _______________________________
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Preserving Your Previous Configuration
Important: If you are upgrading and you need to preserve the ability to roll back the
Services Portal to a previous version, you must copy and rename the config.dat file
to prevent the new installation from overwriting the earlier version's configuration
parameters. To do this, complete the following procedure before you begin the
upgrade to Services Portal 3.0.
1

Open an xterm window on the DNCS.

2

Type cd /dvs/appFiles/ServicesPortal/data and press Enter. The
/dvs/appFiles/ServicesPortal/data directory becomes the working directory.

3

Type cp -p config.dat config.vXX (where XX is your current version number of
the Services Portal, before upgrading) and press Enter. This copies, renames, and
date stamps the configuration file so that you keep a copy of the original
config.dat file.
Example: If you are upgrading from Services Portal 2.0, copy the configuration
file as config.v20. Type the following command and press Enter:
cp -p config.dat config.v20

4

Proceed with the upgrade.

If you need to roll the version back, rename the file back to its original name
(config.dat) after you roll back the version to preserve your configuration of the
earlier Services Portal version. Refer to Rolling Back to a Previous Version (on page
141) for more information.
Important: Keep the installation CD of the previous version of Services Portal. This
will help if you ever need to roll back the version.
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Installing the Services Portal Package Information
If you have already upgraded your DNCS System Release and did not preserve the
/var/sadm/pkg/SAIisp or /var/sadm/pkg/SAISPC directories, use the following
procedure to install the Services Portal package information files before you
uninstall the previous version of the Services Portal server.
Note: If you do not have Internet connectivity on your Application Server, follow
this procedure from your DNCS and transfer the file to your Application Server.
1

Open an xterm window on the Application Server (or on your DNCS if you do
not have Internet connectivity on your Application Server).

2

Type su – and press Enter to log on as root user. The password prompt appears.

3

Type the root password and press Enter.

4

Type cd /tmp and press Enter.

5

Log on to the FTP server.
Notes:



The address of the server is ftp.sciatl.com or 192.133.243.133.
Note: The address for the FTP server is subject to change. If you are unable to
reach the FTP server, please contact Cisco Services for the latest address.




The username is anonymous.
The password is the e-mail address of the person logging in.

6

Type cd /pub/scicare/RELEASED/ServicesPortal and press Enter.

7

Type bin and press Enter. The system sets the ftp transfer mode to binary.

8

Type hash and press Enter. The system configures itself to display hash marks
that show file-transfer progress.

9

Type prompt and press Enter. This command turns off the interactive mode of
the FTP utility.

10 Type get SP_pkginfo.tar and press Enter.
Note: This command starts the transfer of the files from the FTP server to the
Application Server. A # symbol displays on the screen for each 8192 bytes
transferred from the FTP server to the Application Server or DNCS.
11 When the download is complete, type bye and press Enter to log out of the FTP
server.
12 Move the SP_pkginfo.tar file into the /var/sadm/pkg directory on the Application
Server.
13 Did you download the file from the DNCS?

58



If yes, close the xterm window on the DNCS. Open an xterm window on the
Application Server and log onto the Application Server as root user.



If no, continue with step 14.
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14 Type cd /var/sadm/pkg to make the /var/sadm/pkg directory the active
directory.
15 Type tar xvpf SP_pkginfo.tar to untar the files.
You will see information similar to the following list in the xterm window.
The SAISPC and SAIisp package information is installed.
x ./SAISPC, 0 bytes, 0 tape blocks
x ./SAISPC/install, 0 bytes, 0 tape blocks
x ./SAISPC/install/checkinstall, 133 bytes, 1 tape blocks
x ./SAISPC/install/copyright, 183 bytes, 1 tape blocks
x ./SAISPC/install/depend, 55 bytes, 1 tape blocks
x ./SAISPC/install/request, 65 bytes, 1 tape blocks
x ./SAISPC/install/request.pl, 2754 bytes, 6 tape blocks
x ./SAISPC/save, 0 bytes, 0 tape blocks
x ./SAISPC/pkginfo, 668 bytes, 2 tape blocks
x ./SAIisp, 0 bytes, 0 tape blocks
x ./SAIisp/install, 0 bytes, 0 tape blocks
x ./SAIisp/install/checkinstall, 128 bytes, 1 tape blocks
x ./SAIisp/install/copyright, 183 bytes, 1 tape blocks
x ./SAIisp/install/depend, 55 bytes, 1 tape blocks
x ./SAIisp/install/postremove, 0 bytes, 0 tape blocks
x ./SAIisp/install/preremove, 872 bytes, 2 tape blocks
x ./SAIisp/install/request, 69 bytes, 1 tape blocks
x ./SAIisp/install/request.pl, 4188 bytes, 9 tape blocks
x ./SAIisp/save, 0 bytes, 0 tape blocks
x ./SAIisp/pkginfo, 949 bytes, 2 tape blocks

16 Type exit and press Enter to exit as root user.
17 Type exit and press Enter to close the xterm window on the Application Server.
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Uninstall the Services Portal
Uninstalling the Services Portal Server
Complete these steps to uninstall the Services Portal Server.
1

Open an xterm window on the Application Server.

2

Complete the following steps to log on to the xterm window as root user.

3

a

Type su - and press Enter. The password prompt appears.

b

Type the root password and press Enter.

Type the following command and press Enter:
pkgrm SAIisp
Note: The I in the command is an uppercase "i".
Result: A confirmation window appears.

4

When asked if you want to remove this package, type y and press Enter. The
following warning appears:
This package contains scripts which will be executed with super-user
permissions during the process of removing this package. Do you want to
continue with the removal of this package?

5

Type y and press Enter. This command deletes the Services Portal Server. The
deletion is complete when the following message appears:

6

Removal of <SAIisp> was successful

Uninstalling the Services Portal Client
1

In the Application Server xterm window where you are logged in as root user,
type the following command and press Enter:
pkgrm SAISPC
Note: The I in the command is an uppercase "i".
Result: A confirmation window appears.

2

Type y and press Enter. The deletion is complete when the following message
appears:
Removal of <SAIspc> was successful

60

3

Press Enter.

4

Go to Upgrading the Services Portal Server (on page 61).
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Upgrading the Services Portal Server
1

Insert the Services Portal Server CD into the CD-ROM of the Application Server.
Wait for the Application Server to mount the CD.

2

In an xterm window on the Application Server where you are logged in as root
user, type df and press Enter to confirm that the Application Server mounted the
CD successfully. The last line of the df command output lists the number of free
disk blocks on the CD.
Note: The fact that the CD is listed in the df command output indicates that the
Application Server mounted the CD successfully.

3

Type cd /cdrom/cdrom0 and press Enter.

4

Type install_pkg and press Enter.
Results:




The Application Server lists the packages that will be installed.
A message appears asking you to confirm that you want to proceed with the
installation.

5

Type y and press Enter. A license agreement window appears.

6

Press Enter to start the installation. The system displays installation
configuration options. The following list describes the configuration options
available.

7



DNCS_HOST — The server name or the alias of the server where the DNCS
is running. This server is usually aliased as dncs_host.



APPSERV_HOST — The server name or the alias of the server where the
appserv is running. This server is usually aliased as appserv_host.



BASDIR — The base directory where the Application Server was installed
(usually /dvs).







APPDIR — The directory where you want the Services Portal to be installed.




INFORMIXSERVER — The alias of the computer where Informix is located.

LDESC — The long description of the Services Portal SAM Service.
APPURL — The application URL for Services Portal SAM Service.
INFORMIXDIR — The directory where Informix is located on the dncs
machine.
DNCSDB — The name of the DNCS database.

Do the DNCS_HOST and APPSERV_HOST values match the values you
recorded in Recording Server Configuration Information (on page 56)?
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SVCNAME — What you want to call the Services Portal SAM Service.

If yes, go to the next step.
If no, change the appropriate values and then go to the next step.
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8

Widen the xterm window to the entire width of your screen. This helps you see
the remaining steps clearly.

9

Type the number corresponding to APPURL.

10 Retype the entire SAM URL, making the appropriate changes as detailed in the
following steps.
a

Add the version number of the Services Portal client (3.0.1.x) immediately
after the ispguide.ptv; parameter. Use the format version=x.x.x.x
Example: If you are using Services Portal client version 3.0.1.5, type
version=3.0.1.5 (type the periods).

b

Add the EID number (package number) immediately following the version
number parameter. You recorded the EID earlier in this document. Use the
format EID=#.

c

We recommend that you download the Services Portal onto the set-tops as
part of the boot procedure. However, if you experience a significant increase
in boot time, you can set loadOnBoot to false (F).
Do you want to load the application on boot?
–

If yes, leave loadOnBoot=T.

–

If no, change the parameter to loadOnBoot=F.

Example:
bfs://SP_ib/ispguid.ptv;version=3.0.1.5; EID=2;obstructedRect=0,0,639,479;
loadOnBoot=T
Important: This information should appear continuously on one line. Do not
insert any spaces.
11 Type c and press Enter to continue the installation. The software begins loading
and the system displays an installation of SAIisp was successful message when
it has completed.
12 In the xterm window, type cd / and then press Enter. The root directory becomes
the working directory.
13 Type eject cd and then press Enter. The system ejects the CD.
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Saving the Configuration
1

From the DNCS Administrative Console, click the Server Applications tab.

2

Click Reload Applications. The Services Portal button appears on the Server
Applications tab.

3

Click the Services Portal button. The SP Service Guide opens.

4

On the File menu, click Save. The system creates the config.dat file. A message
similar to the following appears at the bottom of the Services Portal window:
Config file saved at: /dvs/appFiles/ServicesPortal/data/

5
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On the File menu, click Exit. The SP Service Guide closes.
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Upgrading the Services Portal Client
1

Insert the Services Portal Client CD into the CD-ROM drive of the Application
Server. Wait for the Application Server to mount the CD.

2

In an xterm window on the Application Server where you are logged in as root
user, type df and press Enter to confirm that the Application Server mounted the
CD successfully. The last line of the df command output lists the number of free
disk blocks on the CD.
Note: The fact that the CD is listed in the df command output indicates that the
Application Server mounted the CD successfully.

3

Type cd /cdrom/cdrom0 and press Enter.

4

Type install_pkg and press Enter.
Results:




The Application Server lists the packages that will be installed.
A confirmation message appears asking you to confirm that you want to
proceed with the installation.

5

Type y and press Enter. A license agreement window appears.

6

Press Enter to start the installation. The system displays an installation
configuration menu.

7

Verify the inband source ID (the number corresponding to INBFSSRC). Is the
inband source ID correct?



8

If yes, click Next.
If no, type the inband source ID for Services Portal and Press Enter.

Verify the out-of-band source ID (the number corresponding to OBFSSRC). Is
the out-of-band source ID correct?




If yes, Type c and press Enter to continue the installation.
If no, type the out-of-band source ID for Services Portal and type c and press
Enter to continue the installation.

The software begins loading and the system displays an installation of SAIisp
was successful message when it has completed.
9

In the xterm window, type cd / and then press Enter. The root directory becomes
the working directory.

10 Type eject cd and then press Enter. The system ejects the CD.
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Updating the Services Portal SAM Service
1

From the DNCS Administrative Console, click the Application Interface
Modules tab.

2

Click SAM Service. The SAM Service List window opens.

3

Click the Short Description column header to sort the list of services by short
description. All services beginning with an underscore (such as _KEYA) display
at the top of the list. The Services Portal SAM service has one of the following
short descriptions: _KEYA, _GUID, or _MENU. Look for the service with
ispguide.ptv in the SAM URL.

4

Double-click the Services Portal SAM service. The Set Up SAM Service window
opens.

5

In the Application URL window, locate the version parameter.
Example: Locate the parameter that looks similar to the following:
version=2.1.0.5

6

Change the version number to the version number of the upgraded Services
Portal client (3.0.1.x).
Example: version=3.0.1.6

7
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Click Save.
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4 Chapter 4
Launching the Services Portal
When the Set-Top is Powered
On
Introduction
This chapter describes how to configure the Services Portal to launch
each time the set-top is powered on by the subscriber.

In This Chapter
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Overview
The service or channel that the set-top tunes to when a subscriber presses the Power
button on the set-top is known as the Power-On service.
You can configure Services Portal as the Power-On service so that Services Portal
launches each time the subscriber powers on the set-top.
Some cable service providers let subscribers choose a Power-On service from the
General Settings menu. For example, a subscriber may want to see the local sports
station every time they turn on the set-top.
Which Power-On service wins if you configure Services Portal to appear at power
on? The answer is both!
 In Full Screen mode, Services Portal displays the subscriber’s power-on channel
in the video window when the subscriber turns on the set-top.
 In Toolbar mode, Services Portal displays the subscriber’s power-on channel as
the background video underneath the translucent toolbar.
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Creating the Power-On SAM Service
Complete these steps to define a SAM Service that launches the Services Portal each
time the set-top is powered on.
1

From the DNCS Administrative Console, click the Application Interface
Modules tab.

2

Click SAM Service. The SAM Service List window opens.

3

Click the Short Description column header to sort the list of services by short
description.
Note: All services beginning with an underscore (such as _KEYA) display at the
top of the list. The Services Portal SAM service has one of the following short
descriptions: _KEYA, _GUID, or _MENU. Look for the service with ispguide.ptv
in the SAM URL.

4

Double-click the SAM service for Services Portal. The Services Portal SAM
Service opens.

5

Record the SAM URL for the service.
_______________________________________________________________________

6

Click Cancel. The SAM Service List window opens.

7

On the File menu, click New. The Set Up SAM Service window opens.

8

Type the following descriptions.




9

For Short Description, type _POWR.
For Long Description, type Power-On Services Portal.
For Service Name, type _POWR.

From Application URL, click Select. The Application URL Selection window
opens.

10 Select the SAM URL you recorded in step 5 of this procedure.
11 Click OK. The selected application URL appears in the Application URL box in
the Set Up SAM Service window.
12 For Logo, type 0 (zero).
13 For Parameter, click Number and type 0 (zero).
14 Click Save.
15 Close the SAM Service List window.
16 Go to Defining Timeouts (on page 71).
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Defining Timeouts
Introduction
This chapter describes how to configure two different timeout settings
(Normal Time Out at Power On and Time Out After Activation) that
define how long the Services Portal remains on the TV screen.

In This Chapter
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Overview
You can configure how long the Services Portal appears on the TV screen before
disappearing or timing out.
Timeouts provide a safety net for subscribers who either cannot find the remote
control to exit the portal or are not sure how to exit the portal using the remote
control. Timeouts are triggered by a lack of activity. As long as the subscriber is
performing tasks in Services Portal, Services Portal remains open.
The Services Portal has two different timeout settings:
 Normal Time Out at Power On
 Time Out After Activation
Normal Time Out at Power On
If the Services Portal launches each time the set-top is powered on, you need to
define the power-on timeout.
Consider this example: A subscriber turns on the set-top, the Services Portal
launches as the power-on service, and the subscriber cannot find the remote to exit
the portal. How much time should elapse before the Services Portal disappears?
The default for the power-on timeout is 30 seconds. Once this timeout expires, the
Services Portal suspends itself.
Time Out After Activation
The Time Out After Activation setting applies to all Services Portal configurations.
Unlike the power-on timeout, this timeout applies when a subscriber launches the
Services Portal from a key on the remote control.
For example, assume you set the Time Out After Activation to 20 seconds. If a
subscriber launches the Services Portal and does not press a key on the remote, the
Services Portal disappears from the screen after 20 seconds.
 In Full Screen mode, the channel the subscriber was tuned to appears in normal
view.
 In Toolbar mode, the translucent portal disappears from the screen.
The default for this timeout is 15 seconds.
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Configuring Timeouts
1

If the SP Service Guide is not open, complete the following steps to open it.

a

From the DNCS Administrative Console, click the Server Applications tab.

b

Click Services Portal. The SP Service Guide opens with the Display Frame
tab selected.

2

Click the Display Information tab.

3

Did you define a _POWR SAM Service to launch the Services Portal at power on?



If yes, complete the Normal Time out at power On field. Enter the number of
seconds that should elapse before the Services Portal disappears after the settop is powered on. Then, go to step 4.



If no, go to step 4.

4

For Time out After Activation, enter the number of seconds that should elapse
before the Services Portal disappears from the screen after the portal is launched
from the remote control.

5

On the File menu, click Save.
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6 Chapter 6
Choosing the Launch Mode for
the Services Portal
Introduction
This chapter describes the available launch modes and provides
instructions for defining the launch mode for your Services Portal.

In This Chapter




78-745238-01 Rev D

Overview ................................................................................................ 76
Available Launch Modes ..................................................................... 77
Define the Launch Mode ..................................................................... 79

75

Chapter 6 Choosing the Launch Mode for the Services Portal

Overview
The launch mode determines how the Services Portal displays when launched by
your subscribers. You can choose between a Toolbar Services Portal and a FullScreen Services Portal.
Important: The launch mode you choose affects certain configuration options
available to you. Therefore, choose the launch mode before you complete any other
configuration tasks in subsequent chapters of this document.
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Available Launch Modes
Toolbar Launch Mode
With Toolbar mode, you can still see the current program or service underneath the
Services Portal toolbar. The Services Portal is translucent over the current TV picture.
You can adjust the size and position of the toolbar.
In this example, the toolbar size and position allow optimal viewing of the current
program. The Toolbar launch mode is a good choice if you want to retain the full
video screen when subscribers launch the Services Portal.
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Full Screen Launch Mode
If you want to brand the Services Portal with additional graphics and feature a
scaled video window, choose the Full Screen Services Portal.
With Full Screen mode, you can also display a Where Am I banner to remind
subscribers of the current channel in the video window. The following picture is just
one example of a Full Screen Services Portal.
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Define the Launch Mode
This section describes how to define the launch mode for the Services Portal.

Defining the Launch Mode
1

On the Tools menu, click Screen Mode.

2

Click Toolbar or Fullscreen.

3

On the File menu, click Save. One of the following messages appears at the
bottom on the SP Service Guide, confirming your selection:
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Launch mode is Toolbar
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7 Chapter 7
Assign and Define Services
Introduction
This chapter explains how to assign and define services for your
Services Portal.

In This Chapter
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Chapter 7 Assign and Define Services

Overview
You can assign the services you want to provide in your portal from a list of all
available services. The list of available services includes all services in your SAM
service list.
You can add up to 32 services to your Services Portal.
After you have assigned the services you want to provide in your portal, you can
define characteristics for each service, such as the icon for a service.
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Assign Services
Assigning Services
1

From the SP Service Guide, click the Assign Service tab.

2

Select the first service you want to add to your portal from Available Services.

3

Under Portal Services, click the desired slot for the service you are adding.

4

Click Add. The system adds the service to the Services Portal.

5

Repeat steps 2 through 4 for all services you want to add to your portal. You can
add up to 32 services to your portal.

6

After you add the services for your portal, use the Move arrows to arrange your
list of services in the order you want them to display. For example, to move the
(the Move
service in Slot 3 to Slot 4, select the service in Slot 3 and click
down button).
Important: Slot 0 is reserved for the IPG. You cannot move a different service
into this slot.

7

On the File menu, click Save. You have successfully assigned services for your
portal.

8

Go to Define Details for Services (on page 85).
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Removing Services
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1

From the SP Service Guide, click the Assign Service tab.

2

Select the service you want to remove from the Portal Services column.

3

Click Remove.

4

On the File menu, click Save.
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Define Details for Services
Before You Begin
Before you complete the next procedure, it is important to understand the difference
between selected and unselected icons.
To provide a visual cue to subscribers as they select services, the Services Portal
toggles between two graphical versions of each service icon and button.
When a subscriber selects a service in the portal, the selected icon for that service
appears. These icons normally have a sharp color contrast between the oval-shaped
background of the icon and the fill color of the icon artwork.
Example:
The following example compares the selected movies icon to the unselected movies
icon.
Selected Icon

Unselected Icon

Icons for services are defined using icon numbers that map to specific icons in the
icons.sgo file, which is a "strip" of icons. The icon number refers to the position of
the unselected icon in the icon strip. The following example shows the icons.sgo file
that contains the default icon strip in Services Portal.

The following procedure requires you to enter the icon number for the unselected
version of each icon. Refer to your configuration worksheet for the icon number for
each service. Icon numbers for default icons are also provided in the following
procedure.
If you have customized icons for the Services Portal, refer to your configuration
worksheet.
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Defining Details for Services
1

From the Assign Service tab, click a service from Portal Services.

2

Click Details. The Service Properties window opens.

3

To keep subscribers from blocking this service, clear the Blockable check box (by
default, subscribers can block services).

4

Select the service's language from the Enter Label in list.

5

Type the label for the service.

6

Repeat steps 4 and 5 for all the languages this service supports.
Note: To speed up this task, you can select a default configuration language from
the Tools menu. Refer to Choosing a Default Configuration Language (on page
102) for more information.

7

If an icon number is specified in your configuration worksheet, choose the icon
that you want to use from the list below. Or, if you are using custom icons, refer
to your Services Portal Resource Layout file (icons.res.xls).
The following list provides icon numbers for the default icons provided with the
Services Portal.
Icon
(unselected)
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Icon
(selected)

Service

Icon Number for the Unselected
Version of the Icon

Movies

1

TV

2

Music

3

Software

4

Games

5
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8

For Icon Number, type the icon number associated with the unselected version
of the icon in the icon strip.

9

Click OK. The Service Properties window closes, and you can view your list of
Portal Services.

10 Repeat Steps 1 through 9 for each service in your Portal Services list.
11 On the File menu, click Save. The services you defined appear with the selected
labels and icons when the Service Portal is opened by subscribers.
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8 Chapter 8
Customize Buttons for
Services
Introduction
This chapter explains how to customize the buttons you use for your
Services Portal.

In This Chapter
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Chapter 8 Customize Buttons for Services

Overview
Rather than displaying a simple text list of services available from your portal, the
Services Portal uses buttons to represent services. The button is the background for
the icon and label you have selected for a service.
Example:

Buttons make the Services Portal an inviting interface for your subscribers.
Subscribers immediately recognize they can select services using the remote control.
We provide default settings for your Services Portal buttons. You can customize
these settings for existing buttons using the procedures provided in this chapter.
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Define the Number of Services to Show at One
Time
The Services Portal makes it easy for subscribers to scan the list of services. The
Services Portal limits the number of services a subscriber has to scan at one time.
While you may offer a total of 32 services in your portal, you can only show a
maximum of seven services at one time. The following methods allow your
subscribers to scroll up and down through the listed services:
 The Arrow Up and Arrow Down keys on the remote control let subscribers
scroll to one additional service at a time. As subscribers scroll through the list of
services, the icons and text for each service button change, but the service
buttons remain in place.
 The Page Up and Page Down keys on the remote control replace the current
visible services with the services on the previous page or the next page.
For example, assume you have a total of 10 services and you show seven services
at a time. If a subscriber presses Page Down from the first page, then the 3
services on the second page appear underneath the last 4 services from the first
page. Each page always shows the same number of services.

Defining the Number of Services to Show At One Time
1

From the SP Service Guide, click the Display Frame tab if it is not already
selected.

2

Select the Number of Buttons you want to show at one time.

3

On the File menu, click Save.
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Define Position and Width of Buttons
This section describes how to define the position and width of buttons for the
services in your Services Portal. You can use the appropriate form in this section to
record your custom values.
Use the following worksheets to complete your customization of the buttons:
 For toolbar mode: Button Position and Widths for Toolbar Mode (on page 5)
 For full screen mode: Button Position and Widths for Full Screen Mode (on page
6)

Defining Position and Width of Buttons
1

From the SP Service Guide, click the Display Frame tab, if it is not already
selected.

2

Enter the new Left and Top coordinates if you want to reposition buttons.

3

Enter new button Widths if you want to change the width of the buttons.

4

On the File menu, click Save.

5

View your Services Portal to see if any of your settings require adjustments.

6

Repeat this entire procedure until the positions and widths that you want are
achieved. If you want to start over, you can click Reset to Default to return to the
original button settings.
Important! Clicking Reset to Default resets all of the values in the Display
Frame tab. Therefore, before you click Reset to Default, record any customized
settings that you want to keep using the appropriate form on the following
pages. The form you use depends on the launch mode you have selected.
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Positioning Icons on Buttons
You can position icons horizontally on the button by adjusting the icon offset. The
icon offset is the distance of the icon from the left border of the button.

The default icon offset for buttons is 2 pixels (shown in the Less Offset example
above). You can change this setting using the following procedure.

Changing the Icon Offset for Buttons
1

From the SP Service Guide, click the Display Frame tab if it is not already
selected.

2

Enter the Icon Offset you want to use.

3

On the File menu, click Save.

4

View your Services Portal to see if you need to adjust the setting.

5

Repeat this procedure, if necessary.
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Defining the Button Text Font
You can define the text font that you use for the Button on-screen display. This
section contains the procedures for defining the Button display font.
Notes:
 Custom fonts are only available on high-resolution set-top boxes. Low-resolution
set-top boxes ignore the font settings and use the default fonts.
 If you do not specify a font, the default Services Portal fonts will be used.
 Fonts must be Binary File Transfer (.bft) files. Conversion utilities (such as Font
Gizmo from PowerTV®) exist to convert font files to .bft files. Contact Cisco
Services for more information.
 The fonts you use must be placed in the application server's
/dvs/appFiles/ServicesPortal/data directory.
 You must create a BFS link for each font file that you use for Services Portal.
Refer to Add the Font Files to the BFS Server (on page 51) for more information.

Defining the Button Text Font
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1

From the SP Service Guide, click the Text and Font tab.

2

In the Fonts section, enter the font you want to use in the Button field.

3

On the File menu, click Save.

78-745238-01 Rev D

Define Button Color

Define Button Color
You can define the color of the buttons in your Services Portal. If you do not want to
change the default button color, skip these procedures.

Defining Button Color
1

From the SP Service Guide, click the Display Frame tab.

2

Use the Button Color slider to define the color of the buttons displayed in
Services Portal. The color you choose displays in the box to the right of the slide.

3

From the File menu, select Save.

Button Color References
The following examples show the approximate slider positions for several popular
button colors.
Color

Approximate Slider Position

Red
Magenta
Violet
Blue
Cyan
Green
Yellow
Orange
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Define Button Edges
You can define the edges of the buttons in your Services Portal. You can choose one
of the following button edges:
 One side rounded (default) - Only the left button edge will be rounded
 Both sides rounded - Both the left and right button edges will be rounded
If you want to keep the button edges rounded on one side (the default setting), skip
these procedures.

Defining Button Edges
To set the buttons so that they display with both edges rounded, follow these
instructions.
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1

From the SP Service Guide, click the Display Frame tab.

2

Check the Both Ends Rounded box.

3

From the File menu, click Save.
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Change Service Labels for Buttons
When you add a service to your portal, you enter details for the service including the
label for services.
This service label appears on the button for the service. When you define button
widths, you may find that some service labels are too long for the button. If you like
the button width, consider changing the service label to something shorter. If you
decide to change the label for a service, you can quickly do so through the Assign
Service tab.

Changing Service Labels for Buttons
1

From the SP Service Guide, click the Assign Service tab.

2

From Portal Services, double-click the service you want to change. The Services
Properties window opens.

3

From Enter Label in, enter the new label for each of the supported languages.

4

Click OK in the Service Properties window.

5

Repeat steps 3 and 4 for all the labels you want to change.

6

On the File menu, click Save.
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9 Chapter 9
Customize Parental Control
Introduction
This chapter explains how to customize Parental Control options in
the Services Portal.

In This Chapter
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Enable or Disable Parental Control for a Service
If a subscriber blocks a channel-based service using the General Settings menu, this
service is automatically blocked in the Services Portal. If a subscriber blocks a
channel-based service using the Block: Service screen in the Services Portal, this
service is automatically blocked in the General Settings menu. This keeps the
Services Portal and SARA in sync on blocked channel-based services.
Example: The following pictures show the two different access points for blocking
channel-based services: General Settings (SARA) and Block: Service (Services Portal).

In addition to channel-based services, you may offer several overlay services in your
Services Portal. An overlay service “lays over” another channel, meaning the service
either displays on top of the current channel or shows the current channel in a
quarter screen or a video window. In fact, the Services Portal itself is an overlay
service.
Because overlay services are not assigned to a specific channel, time, or
rating, subscribers cannot block overlay services using the General Settings menu.
To provide subscribers the benefit of Parental Control for overlay services, the
Services Portal extends the blocking feature to overlay services.

100
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Preventing Subscribers from Blocking Services
Complete these steps to enable or disable parental control for a service.
1

From the SP Service Guide, click the Assign Service tab.

2

From Portal Services, double-click the service you want to edit. The Service
Properties window opens.

3

In the Blockable check box, do one of the following, depending on your
preference.




Select the check box to enable parental control for this service
Clear the check box to disable parental control for this service

4

Click OK.

5

On the File menu, click Save.
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Change Parental Control Messages
If you let subscribers block and unblock services in the Services Portal, you need to
provide instructional text related to blocked services.
Default text messages in English, Spanish, and French are provided for the following
message types:
 PIN Entry Text
 PIN Entry Text to Clear Blocked Service
 Blocked Service Barker Text
 Blocked Service B Key Text
 PIN Entry Text to clear All Blocked Services
These messages are specific to the blocked service feature of the Services Portal.
They do not apply to the blocked services feature of the Interactive Program Guide
(IPG).

Choosing a Default Configuration Language
Are you configuring the Services Portal to support multiple languages?
If you are, make sure that you change the text in each supported language.
Otherwise, the message text will not match between the different languages.
Note: To speed up this task, you can select a default configuration language from the
Tools menu. This sets the Enter Label in language to the default language for all
service labels.
For example, set the default language to French to enter all the French service labels.
Then, set the default language to Spanish to enter all the Spanish service labels.
The default language option in the SP Service Guide is for configuration purposes
only and is not related to the language the Services Portal shows to subscribers. The
language the Services Portal shows to subscribers is controlled by a setting in SARA.

102

78-745238-01 Rev D

Change Parental Control Messages

Changing Parental Control Messages
1

From the SP Service Guide, click the Text and Font tab.

2

Click the message you want to change.
Example: Click Enter Pin Entry Text to change the text that displays when the
subscriber needs to enter their Parental Control PIN.
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3

Type your message text in all supported languages using the Language list Enter
Text box at the bottom of the tab.
Important: To make this procedure easier, you can change the default
configuration language on the Tools menu. Refer to Choosing a Default
Configuration Language (on page 102) for more information.
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4

On the File menu, click Save.

5

Repeat this procedure for other messages if desired.
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Define the Parental Control Display Font
You can define the text font that you use for the Parental Control messages on-screen
display. This section contains the procedures for defining the Parental Control
messages display font.
Notes:
 Custom fonts are only available on high-resolution set-top boxes. Low-resolution
set-top boxes ignore the font settings and use the default fonts.
 If you do not specify a font, the default Services Portal fonts will be used.
 Fonts must be Binary File Transfer (.bft) files. Conversion utilities (such as Font
Gizmo from PowerTV®) exist to convert font files to .bft files. Contact Cisco
Services for more information.
 The fonts you use must be placed in the application server's
/dvs/appFiles/ServicesPortal/data directory.
 You must create a BFS link for each font file that you use for Services Portal.
Refer to Add the Font Files to the BFS Server (on page 51) for more information.

Defining the Parental Control Display Font
1

From the SP Service Guide, click the Text and Font tab.

2

In the Fonts section, enter the font you want to use in the Parental Control
messages field.

3

On the File menu, click Save.

78-745238-01 Rev D

105

Chapter 9 Customize Parental Control

Default Parental Control Messages
You can customize several of the messages in the Parental Control screens for the
Services Portal. If you change the message text for a screen, make sure that you
change the text in each supported language. Otherwise, the message text among the
different languages will not match.
The following tables provide the default message text for each message you can
change.

PIN Entry Text Message Defaults
Language

Default Message Text

English

Enter PIN to allow changing your Blocked Services.

French

Veuillez entrer votre NIP pour pouvoir apporter les
changements à vos services bloqués.

Spanish

Introduzca el número de identificación personal (PIN)
para poder cambiar los servicios bloqueados.

PIN Entry Text to Clear Blocked Service Message Defaults
Language

Default Message Text

English

Enter PIN to turn off Parental Control and allow
viewing of this service only.

French

Veuillez entrer votre NIP pour bloquer le contrôle
parental et permettre l'accès à ce service uniquement.

Spanish

Introduzca el PIN para desactivar el control paterno y
permitir que se vea únicamente este servicio.

Blocked Service Barker Text Message Defaults
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Language

Default Message Text

English

Parental Control prevents viewing this service.

French

Le contrôle parental interdit l'accès à ce service.

Spanish

El control paterno impide que se vea este servicio.
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Blocked Service B Key Text Message Defaults
Language

Default Message Text

English

Allow viewing of this service only.

French

Permet l'accès uniquement à ce service.

Spanish

Permitir que se vea únicamente este servicio.

PIN Entry Text to Clear All Blocked Services Message Defaults
Language

Default Message Text

English

Enter PIN to turn off Parental Control and
allow viewing of all services.

French

Veuillez entrer votre NIP pour bloquer le
contrôle parental et permettre l'accès à tous
les services.

Spanish

Introduzca el PIN para desactivar el control
paterno y permitir que se vean todos los
servicios.
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10
Introduction

This chapter describes special options for filtering the list of services
that display in the Services Portal.

In This Chapter
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Show or Hide Blocked Services
The Services Portal displays blocked services by default. With this configuration, any
service the subscriber blocks still appears in the Services Portal. If subscribers select a
blocked service from the Services Portal, they get a message which does the
following:
 States the service is blocked
 Provides the option to turn off Parental Control completely (after entering a PIN)
 Provides the option to unblock that specific service only (after entering a PIN)
When blocked services are always visible, subscribers can quickly find services they
may want to unblock.
In contrast, an advantage to hiding blocked services is that subscribers will only see
the services they can immediately access. While you may offer 32 services in your
Services Portal, a subscriber may only have interest in half of these services. If you
configure the Services Portal to hide blocked services, the list of services is
simplified.
Perhaps more importantly, if you hide blocked services, parents rest assured that
their children do not see programs such as Adult-On-Demand listed in the portal.
If blocked services are hidden in the Services Portal, subscribers can still view the list
of all services (including blocked services) by clicking the B key on their remote
control and entering a correct Parental Control PIN. Once the PIN is accepted,
subscribers can block or unblock services that are defined as blockable.
Example:

Showing or Hiding Blocked Services
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1

From the SP Service Guide, click the Display Information tab.

2

Select or clear the Display Blocked Service check box, depending on the
configuration you prefer.

3

On the File menu, click Save.
78-745238-01 Rev D

Show or Hide Blocked Services

Hiding Services When a DAVIC Connection Is Used
Digital Audio Visual Council (DAVIC) defines the end-to-end interoperability of
multimedia communication and broadcast and interactive digital audio-visual
information. This standard is administered by the Digital Audio Visual Council and
EuroCableLabs. Data Over Cable Service Interface Specification (DOCSIS®) defines
interface requirements for cable modems involved in high-speed data distribution
over cable television system networks. This standard was developed by CableLabs®
in North America and approved by the International Telecommunication Union
(ITU).
Do you have some applications that work fine with DOCSIS connections but require
too much out-of-band (OOB) bandwidth over DAVIC connections? The NODAVIC
parameter lets you hide services in the Services Portal list when DAVIC connections
are used.
Here’s an example of how it works:
1

The installer adds an application to the list of services in Services Portal.

2

The installer inserts the ;NODAVIC parameter in the SAM URL for the
application you want to hide when a DAVIC connection is used. The application
appears in the Services Portal for DOCSIS connections but not for DAVIC
connections. No rebooting is required.
Note: Refer to Guidelines for Adding URL Modifiers and Replacing URL Keywords
(part number 4002527) for more information.

Showing Services on HD Set-Tops Only
Do you have some services you want to display for HD set-tops only? The HDONLY
parameter lets you show services in the Services Portal list for HD set-tops only.
Here’s an example of how it works:
1

The installer adds an application to the list of services in Services Portal.

2

The installer inserts the ;HDONLY parameter in the SAM URL for the
application you want to show for HD set-tops only. The service appears in the
Services Portal for HD set-tops only. No rebooting is required.
Note: Refer to Guidelines for Adding URL Modifiers and Replacing URL Keywords
(part number 4002527) for more information.
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Show or Hide Unauthorized Services
The Services Portal displays all unauthorized services by default. You can, however,
change this option to hide all unauthorized services.
Hiding unauthorized services simplifies the list of services for your subscribers. In
addition, if you offer premium adult-oriented services in your portal, you probably
want to hide unauthorized services.
If the services in your portal are acceptable for all ages, consider displaying
unauthorized services to let subscribers know what they may be missing.

Showing or Hiding Unauthorized Services
Follow these steps to show or hide unauthorized services in the portal.
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1

From the SP Service Guide, click the Display Information tab.

2

Select or clear the Display Unauthorized Services check box, depending on the
configuration you prefer.

3

On the File menu, click Save.

78-745238-01 Rev D

11 Chapter
Brand Your Services Portal
11
Introduction

This chapter explains how to brand your Services Portal with a title
and your logo.

In This Chapter
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Overview
If you embed a title and logo in a customized background image, follow the
instructions to hide your logo and Services Portal title. Then, go to Customizing the
Background Image (on page 124).

114
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Prevent Cropping of Your Services Portal Title
Most TVs crop the video slightly to ensure the edges of the frame look sharp on the
TV screen. To make sure that important screen elements are not cropped, avoid
placing graphics or text against the edges of the screen.
The Society of Motion Picture and Television Engineers (SMPTE) developed clear
screen usage areas known as the Title Safe Area and the Action Safe Area. Observe
these areas when designing your Services Portal layout.

Low Resolution Safe Areas
Action Safe Area
The Action Safe Area is inside a rectangle that is placed 12 pixels vertically and 16
pixels horizontally and measures 287 x 215. Most televisions will display text and
graphics inside the Action Safe area.
Title Safe Area
The low-resolution Title Safe Area is inside a rectangle that is placed 24 pixels
vertically and 32 pixels horizontally and measures 255 x 191. All television sets will
display text and graphics inside the Title Safe Area.
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If you reposition the title or logo in your Services Portal or embed these elements in
a background graphic, make sure that they are within the Title Safe Area. Otherwise,
you risk having parts of the Services Portal background image, inset video, or
selection buttons placed in areas of the screen that are cropped on some TVs.

High Resolution Safe Areas
Action Safe Area
The Action Safe Area is inside a rectangle that is placed 24 pixels vertically and 33
pixels horizontally and measures 574 x 431. Most high-resolution televisions will
display text and graphics inside the Action Safe area.
Title Safe Area
The high-resolution Title Safe Area is inside a rectangle that is placed 24 pixels
vertically and 65 pixels horizontally and measures 450 x 384. All high-resolution
television sets will display text and graphics inside the Title Safe Area.
If you reposition the title or logo in your Services Portal or embed these elements in
a background graphic, make sure that they are within the Title Safe Area. Otherwise,
you risk having parts of the Services Portal background image, inset video, or
selection buttons placed in areas of the screen that are cropped on some TVs.
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Change or Remove the Title of Your Services
Portal
You can change the title of your Services Portal to reflect your corporate identity. If
you change the title, be sure to change the title in all of the supported languages. For
your reference, the default titles are as follows:
 English - Services Portal
 French - Portail de services
 Spanish - Portal de servicios
Important: The Services Portal title is embedded in a custom background image,
clear the title field so that a title does not display on top of your background image.
If you do not want to clear the title fields, you can hide the title instead. Refer to
Hiding the Services Portal Title (on page 121).

Changing the Title of Your Services Portal
1

From the SP Service Guide, click the Text and Font tab.

2

If it is not already selected, click Enter Title Text.

3

Type the title of your Services Portal for all supported languages using the
Language list and Enter Text box.

4

On the File menu, click Save. You have successfully changed the title of your
portal.

78-745238-01 Rev D

117

Chapter 11 Brand Your Services Portal

5

View the portal to see if you like the position of the title. If you want to
reposition your title, refer to Position or Hide the Services Portal Title (on page
120).

Define the Title Text Font
You can define the text font that you use for the Title on-screen display. This section
contains the procedures for defining the Title display font.
Notes:
 Custom fonts are only available on high-resolution set-top boxes. Low-resolution
set-top boxes ignore the font settings and use the default fonts.
 If you do not specify a font, the default Services Portal fonts will be used.
 Fonts must be Binary File Transfer (.bft) files. Conversion utilities (such as Font
Gizmo from PowerTV®) exist to convert font files to .bft files. Contact Cisco
Services for more information.
 The fonts you use must be placed in the application server's
/dvs/appFiles/ServicesPortal/data directory.
 You must create a BFS link for each font file that you use for Services Portal.
Refer to Add the Font Files to the BFS Server (on page 51) for more information.
Defining the Title Text Font
1 From the SP Service Guide, click the Text and Font tab.
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2

In the Fonts section, enter the font you want to use in the Title field.

3

On the File menu, click Save.
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Removing the Services Portal Title
Complete these steps if you do not want to show the Services Portal title or if the title
is embedded in a custom background image. If you do not want to clear the title
fields, you can hide the title instead. Refer to Hiding the Services Portal Title (on
page 121).
1

From the SP Service Guide, click the Text and Font tab.

2

If it is not already selected, click Enter Title Text.

3

Clear the title field for all supported languages.

4

On the File menu, click Save.
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Position or Hide the Services Portal Title
By default, your Services Portal title appears in the upper left corner of the portal
screen. The default coordinates of the title for the Full-Screen launch mode are:
 x = 30
 y = 15
The default coordinates of the title for the Toolbar launch mode are:
 x = 40
 y = 10
You can change these coordinates to reposition your title.

Positioning the Services Portal Title
1

From the SP Service Guide, click the Display Information tab.

2

Enter the desired x and y coordinates for the title text.

3

On the File menu, click Save to save your changes.

4

View the results in the Services Portal. If you need to adjust the position, enter
and save new x and y coordinates until the position is where you prefer.
Important: Clicking the Reset to Default button resets all of the fields in the
Display Information tab. Therefore, if you click Reset to Default to start over with
the default Title Text coordinates, ensure that you record any customized
settings you may have entered for other fields first.
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The default coordinates of the title for the Full-Screen launch mode are:




x = 30
y = 15

The default coordinates of the title for the Toolbar launch mode are:




x = 40
y = 10

Note: If you are using Services Portal with high-resolution graphics, enter these
values as if they are low-resolution graphics. Services Portal will display the
graphics correctly in the high-resolution versions.

Hiding the Services Portal Title
Complete these steps if you do not want to show the Services Portal title or if your
title is embedded in a custom background image.
1

From the SP Service Guide, click the Display Information tab.

2

For the title text coordinates, enter x=0 and y=0.

3

On the File menu, click Save.
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Position or Hide Your Logo
When you configure SARA, you have the option of adding your logo to the IPG
(Interactive Program Guide). If you added your logo in SARA, this logo
automatically appears in the upper left corner of the Services Portal. The default
coordinates for the logo for both launch modes are:
 x = 210
 y = 145
If you want to reposition your logo for the Services Portal, you can reposition your
logo in the Display Information tab. If the Services Portal logo is embedded in a
custom background image, position the logo at x=0, y=0 so that the logo does not
display on top of your background image.
Note: While you can reposition your existing logo in the Services Portal, you cannot
add your logo through the Services Portal.

Positioning Your Logo
1

From the SP Service Guide, click the Display Information tab.

2

Enter the desired x and y coordinates for your MSO Logo. These coordinates are
relative to a 320 x 240 screen resolution.
Note: If you are using Services Portal with high-resolution graphics, enter these
values as if they are low-resolution graphics. Services Portal will display the
graphics correctly in the high-resolution versions.

3

On the File menu, click Save to save your changes.

4

View the results in the Services Portal. If you need to adjust the position, enter
and save new x and y coordinates until the position is where you prefer.
Important: You can click the Reset to Default button to return to the default
settings. Clicking this button resets all of the fields in the Display Information
tab. Therefore, before you click Reset to Default, record any customized settings
that you want to keep.

Hiding Your Logo
Complete these steps if you do not want to show your MSO logo or if your logo is
embedded in a custom background image.
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1

From the SP Service Guide, click the Display Information tab.

2

For the MSO Logo coordinates, enter x=0 and y=0.

3

On the File menu, click Save.
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Customize the Background Image
You can further brand your Services Portal by creating a custom background. In
addition, you can use the custom background to incorporate a special title and logo.
By default, the Services Portal uses the logo defined in SARA. However, if you
position the MSO logo at x=0, y=0 in the Display Frame tab of the SP Service Guide,
the logo does not display on the Services Portal. This option lets you embed the MSO
logo into your custom background image. You can also position the Services Portal
title at x=0, y=0 in the Display Frame tab of the SP Service Guide to hide the default
title.
The following picture is an example of a custom background showing the skyline of
the local city.

If you let subscribers choose different color schemes, you may want to create a
background image for each color scheme.
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Customizing the Background Image
1

If you can preview the graphics, complete the following checks:





For full screen portals, make sure that each image is sized to 320x240.
For toolbar portals, make sure that each image is sized to 119x240.
Make sure that each image is saved as a JPEG file (.jpg extension).

2

On the DNCS, copy the JPEG file(s) to /dvs/appFiles/ServicesPortal/data. If you
have a PC on the same network as your DNCS, you can transfer the file or files
using FTP. Otherwise, copy the file from a floppy disk.

3

On the DNCS Administrative Console, click the Application Interface Modules
tab.

4

Click BFS Client. The Broadcast File Server List window opens.

5

Double-click the SP_ib server and select the data folder.

6

On the File menu, click New Link. The Set Up Link window opens.

7

For Linked Path, choose one of the following options:



Browse for the source path by clicking Select. On the Path Selection Dialog
window, you can browse to the directory, or you can type the directory in the
Filter box. Then, select your custom JPEG file from the file list, and click OK.



Type the following source path:
/dvs/appFiles/ServicesPortal/data/name of background image.jpg

8

Copy name of background image.jpg from the Linked Path and paste it into the
Link Name box.

9

In the Broadcast File Server List window, click View and then Refresh. The
newly created link icon for your custom background image should now display
a “linked” chain.
Note: If you do not see the link, double-click the server to display the newly
created link.

10 If you are creating different backgrounds for different color schemes, repeat
steps 6 through 9 for each background image.
11 Close the Broadcast File Server List window from the File menu.
12 Complete the following steps to open the SP Service Guide.
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a

From the DNCS Administrative Console, click the Server Applications tab.

b

Click Services Portal. The SP Service Guide opens with the Display Frame
tab selected.
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13 Click the Graphics tab.

14 Type the name of the custom background image that should be used for each
color scheme. If the same background image applies to all color schemes, type
that same filename for each color scheme.
15 On the File menu, click Save.
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12
Introduction

The Services Portal provides several navigation aids, such as the Select
key and Up and Down keys. In addition, if you launch the portal in
Full-Screen mode, your portal has a video window and can display the
Where Am I banner. These elements help your subscribers keep track
of where they are.
This chapter explains how to position and resize navigation aids.

In This Chapter
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Positioning and Sizing the Video Window for Full Screen
Launch Mode ....................................................................................... 128
Positioning and Sizing the Services Portal Window for
Toolbar Launch Mode ........................................................................ 129
Show, Position, and Size the Where Am I Banner ......................... 130
Position Navigation Keys .................................................................. 131
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Positioning and Sizing the Video Window for Full
Screen Launch Mode

128

1

From the SP Service Guide, click the Display Information tab.

2

If you want to reposition the video window, enter the desired x and y
coordinates for Video Window.

3

If you want to resize the video window, enter the desired Width and Height for
Video Window.

4

On the File menu, click Save.

5

View the result in your Services Portal.

6

If you need to adjust the position or size of the video window, return to the
Display Information tab and perform steps 2 through 5 until the position is
where you prefer.
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Positioning and Sizing the Services Portal Window
for Toolbar Launch Mode
1

From SP Service Guide, click the Display Information tab.

2

If you want to reposition the Services Portal window, enter the desired x and y
coordinates next to the Screen Dimensions label.

3

If you want to resize the Services Portal window, enter the desired Width and
Height next to the Screen Dimensions label.

4

On the File menu, click Save.

5

View the result in your Services Portal.

6

If you need to adjust the position or size of the Services Portal window, return to
the Display Information tab and perform steps 2 through 5 until the until the
position is where you prefer.
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Show, Position, and Size the Where Am I Banner
If you are launching the Services Portal in Full Screen mode, you have the option of
displaying a Where Am I banner.
This banner helps subscribers keep track of the current channel as they browse
through the portal. The Where Am I banner displays the current channel, date, and
time. While the position of the Where Am I banner is not restricted, we suggest that
you keep the banner close to the video window.

Showing, Positioning, and Sizing the Where Am I Banner
1

From the SP Service Guide, click the Display Information tab.

2

Select the Enable Where Am I check box if it is not already selected.

3

On the File menu, click Save.

4

View the result in your Services Portal. Do you like the default size and position?



If yes, you have completed this procedure.

5

If no, return to the Display Information tab and complete steps 5 through 8.
Repeat these steps until the until the size and position are where you prefer.

6

If you want to reposition the banner, enter the desired x and y coordinates next
to the Where Am I Banner label. The default coordinates are as follows:
x = 151, y = 126
Note: These coordinates are relative to a 320 x 240 screen resolution.

7

If you want to resize the banner, enter the desired width and height next to the
Where Am I Banner label. The default width and height are as follows:
Width = 169, Height = 16
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8

On the File menu, click Save.

9

View the result in your Services Portal.
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Position Navigation Keys
The Services Portal offers several navigational aids. Typically, these aids are
positioned in bottom corner of the screen.
If you move navigational aids, try to maintain a level of positional constancy.
Keeping similar elements in the same area of every screen helps subscribers find the
information they need more quickly.
The point of origin (or the 0, 0 point) in each navigational aid is the top, left-most
pixel in the graphic. For example, you are actually defining the position for the top,
left-most pixel in the B key graphic when you position the B key.

Important: Observe the Title Safe and Action Safe areas when positioning screen
elements. For a diagram depicting the safe areas, see Prevent Cropping of Your
Services Portal Title (on page 115).
If you are launching the Services Portal in Full-Screen mode, then a video window
appears in the Services Portal. By default, this window appears in the upper right
corner of the screen. You can customize the size and position of the video window.
Note: If you are using Services Portal with high-resolution graphics, enter these
values as if they are low-resolution graphics. Services Portal will display the
graphics correctly in the high-resolution versions.
The default coordinates and size of the Video Window are:
 x = 151
 y=0
 Width = 169
 Height = 126
For Full-Screen mode, the Services Portal is automatically sized to 320x240 with
default coordinates of x =0, y=0. You cannot change the size or coordinates of the
Full-Screen mode Services Portal window.
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If you are launching the Services Portal in Toolbar mode, you can change the
position and size of the Services Portal window. The default coordinates and size of
the Toolbar Services Portal window are:
 x=0
 y=0
 Width = 119
 Height =240
Complete one of the following procedures in this section, depending on your launch
mode.

Sizes of Navigational Aids
The size of each navigational aid is provided to help you place these elements within
the action safe area of the screen. In addition, this information helps you avoid
overlapping elements that have slightly different dimensions.
Navigational Aid Purpose

Size (width x height in pixels)
Low Resolution High Resolution

132

A key

Accepts Parental Control settings

18 x 18

36 x 36

B key

Opens the Parental Control screens once a 18 x 18
valid PIN is entered

36 x 36

Exit key (Toolbar Exits the Services Portal. Showing this key 18 x 18
Mode Only)
on the screen is optional

36 x 36

Select key

Select items on the screen. For example,
20 x 20
after a subscriber presses the B key for
Parental Control, subscribers can lock and
unlock services using the Select key.
Showing this key on the screen is optional

40 x 40

Up and Down
arrow keys

Scroll up or down to another service or
18 x 14
page of services. Generally, these arrows
should be placed under the list of services

36 x 28
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Positioning Navigation Keys
1

From the SP Service Guide, click the Display Information tab.

2

Enter the desired x and y coordinates for each navigation key.
Note: If you want to completely hide a navigation key, you can do so by placing
the key in the bottom right corner at x = 319, y = 239.

3

On the File menu, click Save.

4

View the results in the Services Portal. If you need to adjust positions, enter and
save new x and y coordinates until the position is where you prefer.
Important: You can click the Reset to Default button to return to the default
settings. Clicking this button resets all of the fields in the Display Information
tab. Therefore, before you click Reset to Default, record any customized settings
that you want to keep. You can record these values using the appropriate table
on the next page.
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Navigation Key Positions in Toolbar Mode
Use the following form to record custom values for the positions of navigation keys
for the Toolbar mode. You can also refer to this form for default values.
Note: If you are using Services Portal with high-resolution graphics, enter these values as if
they are low-resolution graphics. Services Portal will display the graphics correctly in the
high-resolution versions.
Key

Default Position

Custom Position

A Key or
Guide Key

x = 39

x=

y = 215

y=

B Key

x = 34

x=

y = 197

y=

x = 95

x=

y = 197

y=

x = 38

x=

y = 197

y=

x = 90

x=

y = 219

y=

Exit Key
Select Key
Up/Down
Key

Navigation Key Positions in Full Screen Mode
Use the following form to record custom values for the positions of navigation keys
for the Full Screen mode. You can also refer to this form for default values.
Note: If you are using Services Portal with high-resolution graphics, enter these values as if
they are low-resolution graphics. Services Portal will display the graphics correctly in the
high-resolution versions.
Key

Default Position

Custom Position

A Key or
Guide Key

x = 38

x=

y = 214

y=

B Key

x = 188

x=

y = 215

y=

x = 97

x=

y = 199

y=

x = 188

x=

y = 215

y=

x = 94

x=

y = 219

y=

Exit Key
Select Key
Up/Down
Key
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Configuration
Introduction
This chapter describes how to transfer your Services Portal
configuration to a different headend. This chapter assumes you have
already installed the Services Portal on the DNCS for this headend.

In This Chapter
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Copy Existing Configuration Files to a Floppy Disk
The first step in transferring an existing Services Portal configuration to a different
headend is to copy the existing configuration files to a floppy disk (disk).
Important: If you have customized any of the graphic files, it is possible the Services
Portal files will not fit on a disk. In this case, you must transfer the files by FTP. If
you FTP the files, you can still refer to the following procedure to see which files you
need to FTP.

Copying Existing Configuration Files to a Floppy Disk
Note: If your Application Server does not have a floppy disk, write the configuration
file to either a CD or FTP the file to your DNCS server.
1

Insert a disk into the floppy drive on the AppServer with your configured
Services Portal.

2

Open an xterm window on the AppServer.

3

Type the following and press Enter:
volcheck –v
A message stating the media was found appears. This message confirms that the
system can read from and copy to the disk.

4

Type the following and press Enter:
cd /floppy/floppy0
The working directory is now /floppy0.

5

Type the following and press Enter:
tar cvf /floppy/floppy0/spData.tar /dvs/appFiles/ServicesPortal/data/* \
Note: In the above command, a space precedes cvf, /floppy, /dvs, and \.
The cursor changes to >.

6

Type the following and press Enter:
/dvs/ServicesPortal/ISPSystemConfig.info \
Note: In the above command, a space precedes \.

136
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7

Type the following and press Enter:
/dvs/ServicesPortal/PortalServiceTable.tbl
The command combines all of the Services Portal data files, along with the
ISPSystemConfig.info file and the PortalServiceTable.tbl file into a single tape
archive (tar) file. An output similar to the following example shows which files
have been copied to the disk.

8

Type the following and press Enter:
floppy0 /; eject
A message stating the disk can be manually ejected appears.

9

Click OK in the message box, and eject the disk.

10 Go to Place Copied Configuration Files on a Different Headend (on page 138).
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Place Copied Configuration Files on a Different
Headend
After you copy your Services Portal configuration files, place the configuration files
on the AppServer for a different headend.

Placing Copied Files on a Different Headend
1

Insert a disk into the floppy drive on the AppServer for the headend to which
you are copying the configuration.

2

Open an xterm window on the AppServer.

3

Type the following and press Enter:
volcheck -v
A message stating the media was found appears. This message confirms that the
system can read from and copy to the floppy disk.

4

Type the following and press Enter:
tar xvf/floppy/floppy0/spData.tar
Important: In the command above, a space precedes xvf.
The files from the disk are copied to the AppServer. An output similar to the
following shows that the files were copied.

5

Type the following and press Enter:
floppy0/;eject
A message stating that the disk can be manually ejected appears.

6

138

Click OK and eject the floppy disk.
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14 Chapter
Customer Information
14
If You Have Questions
If you have technical questions, call Cisco Services for assistance.
Follow the menu options to speak with a service engineer.
Access your company's extranet site to view or order additional
technical publications. For accessing instructions, contact the
representative who handles your account. Check your extranet site
often as the information is updated frequently.
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Rolling Back to a Previous
Version
Appendix A

Introduction
This appendix contains procedures to roll back the installation to a
previous version of Services Portal.

In This Appendix
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Rolling Back to a Previous Version

Before You Begin
Before you begin the roll back process, you need the following:
 The upgrade process reads the configuration of the current installation and uses
those settings to configure the upgrade.
 However, you should gather some configuration information of your DBDS. See
Recording Configuration Information (on page 32) for more information on
gathering this information.
 You will need the original installation CDs of the Client and Server for the
version you are rolling back to. If you do not have the installation CD, contact
Cisco Services.
 You will need the name of the original configuration file (config.dat) that you
renamed before you upgraded to the current version. Refer to Restore the
Configuration (on page 143) and Preserving Your Previous Configuration (on
page 57) for more information.
Important: If your application server is running Solaris 10 or later, you cannot use
the swmtool installation tool to roll back your Services Portal. Contact Cisco Services
if you need to roll back the version on a Solaris 10 (or later) application server.

142
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Rolling Back the Services Portal
Important: The filenames and UNIX syntax in these procedures are case-sensitive.
Type filenames and paths exactly as they appear in the procedures.

Installing the Services Portal Server
To install the Services Portal server for a roll back installation:
1

Follow the procedures detailed in Upgrading the Services Portal Server (on page
61).

2

Go to Restore the Configuration, next in this document.

Restore the Configuration
Follow these instructions to restore your configuration.
Restoring the Configuration
1 Open an xterm window on the DNCS.
2

Type cd /dvs/appFiles/ServicesPortal/data and press Enter. The
/dvs/appFiles/ServicesPortal/data directory becomes the working directory.

3

Type mv config.vXX config.dat (where vXX is the version number you are
rolling back to) and press Enter. This renames the configuration file so that the
roll back process preserves your configuration.
Example: If you are rolling back to Services Portal 2.0, the configuration file is
listed as config.v20. Type the following command and press Enter:
mv config.v20 config.dat

4

Continue with the roll back procedures.

Installing the Services Portal Client
To install the Services Portal server for a roll back installation:
 Follow the procedures in Upgrading the Services Portal Client (on page 64)
using the previous software version.
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From Your System
Appendix B

Introduction
This appendix provides procedures for removing the Services Portal
Server and Client on the application server and removing Services
Portal from the DNCS.

In This Appendix
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Remove the Services Portal From Your System

Overview
Removing the Services Portal from your system is a process with the following steps:
1

Deleting the Services Portal SAM service.

2

Deleting the inband and out-of-band client BFS servers.

3

De-authorizing the inband and out-of-band servers.

4

Deleting the inband and out-of-band BFS carousels.

5

Removing the Services Portal from the source list.

6

Deleting the Services Portal package.

7

Deleting custom background images and configuration files.

8

Removing the inband carousel from the BIG PAT table.

9

Uninstalling the Services Portal.

10 Adding OSM back to the BIG PAT table.
Each of these steps is discussed in detail in this appendix.
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Deleting the Services Portal SAM Service
1

From the DNCS Administrative Console, click the Application Interface
Modules tab.

2

Click SAM Service. The SAM Service List window opens.

3

Click the Short Description column header to sort the list of services by short
description. All services beginning with an underscore (such as _KEYA) display
at the top of the list. The Services Portal SAM service has one of the following
short descriptions: _KEYA, _GUID, or _MENU. Look for the service with
ispguide.ptv in the SAM URL.

4

Highlight the Services Portal SAM service.

5

On the File menu, click Delete. A confirmation prompt asks if you are sure you
want to delete this item.

6

Click Yes.

7

Close the SAM Service List window from the File menu.

8

Go to Deleting the Inband and Out-of-Band Client BFS Servers (on page 148).
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Deleting the Inband and Out-of-Band Client BFS
Servers
1

On the DNCS Administrative Console, click the Application Interface Modules
tab.

2

Click BFS Client. The Broadcast File Server List window opens.

3

Select the inband server for Services Portal. If you used the suggested name from
the installation instructions, this server is named sp_ib.

4

On the File menu, click Delete. A confirmation prompts appears.

5

Click Yes to confirm the deletion.

6

Select the out-of-band server for Services Portal. If you used the suggested name
from the installation instructions, this server is named sp_oob.

7

On the File menu, click Delete. A confirmation prompt asks if you are sure you
want to delete this item.

8

Click Yes to confirm the deletion.

9

Close the BFS Client window from the File menu.

10 Go to De-authorizing the Inband and Out-of-Band Servers (on page 149).
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De-authorizing the Inband and Out-of-Band
Servers
1

From the DNCS Administrative Console, click the Application Interface
Modules tab.

2

Click BFS Admin. The BFS Administration window opens.

3

Click the Servers tab.

4

Select the inband server for Services Portal. If you used the suggested name from
the installation instructions, this server is named sp_ib.

5

On the File menu, click Delete. A confirmation prompt asks if you are sure you
want to delete this item.

6

Click Yes to confirm the deletion.

7

Select the out-of-band server for Services Portal. If you used the suggested name
from the installation instructions, this server is named sp_oob.

8

On the File menu, click Delete. A confirmation prompt asks if you are sure you
want to delete this item.

9

Click Yes to confirm the deletion.

10 Leave the BFS Administration window open and go to Deleting the Inband and
Out-of-Band BFS Carousels (on page 150).
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Deleting the Inband and Out-of-Band BFS
Carousels
1

From the BFS Administration window, click the Sources tab.

2

Select the inband carousel for Services Portal. If you used the suggested name
from the installation instructions, this server is named SP_ib_source.

3

Record the source ID for the inband source: ______________________
Note: You will need to know the inband source when you remove Services
Portal from the BIG PAT table.

4

On the File menu, click Delete. A confirmation prompt asks if you are sure you
want to delete this item.

5

Click Yes to confirm the deletion.

6

Select the out-of-band carousel for Services Portal. If you used the suggested
name from the installation instructions, this server is named SP_oob_source.

7

Record the source ID for the out-of-band source: ______________________
Note: You will need to know the out-of-band source when you remove Services
Portal from the BIG PAT table.

8

On the File menu, click Delete. A confirmation prompt asks if you are sure you
want to delete this item.

9

Click Yes to confirm the deletion.

10 Close the BFS Admin window from the File menu.
11 Go to Removing the Services Portal from the Source List (on page 151).

150

78-745238-01 Rev D

Removing the Services Portal from the Source List

Removing the Services Portal from the Source List
1

From the DNCS Administrative Console, click the DNCS tab, and then click the
System Provisioning tab.

2

Click Source in the Service Provisioning group. The Source List window opens.

3

Select the inband source for Services Portal. If you used the suggested name from
the installation instructions, this server is named SP_ib_source.

4

On the File menu, click Delete. A confirmation prompt asks if you are sure you
want to delete this item.

5

Click Yes to confirm the deletion. The following warning appears.

6

Click Yes.

7

Close the Source List window from the File menu.

8

Go to Deleting the Services Portal Package (on page 152).
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Deleting the Services Portal Package
Important: If you used an existing package when you installed the Services Portal,
do not delete this package if it is used for other active services. If you created a new
package dedicated to Services Portal, you can complete these steps to delete the
entire package.

152

1

From the DNCS Administrative Console, click the DNCS tab.

2

Click the System Provisioning tab.

3

Click Package in the Service Provisioning area. The Package List window opens.

4

In the Package List window, select the Services Portal package.

5

From the File menu, click Delete. The following message appears.

6

Click Yes.

7

Go to Deleting Custom Background Images and the Configuration File (on page
153).
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Deleting Custom Background Images and the
Configuration File
Note: Background images packaged with the Services Portal are automatically
deleted during the uninstall process.
1

Delete the background files (.jpg files) and the config.dat file from the following
directory on the DNCS:
/dvs/appFiles/ServicesPortal/data

2
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After deleting the config.dat file and custom background images, go to Remove
the Inband Carousel From the PAT Table (on page 154).
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Remove the Inband Carousel From the PAT Table
Process Overview
To remove the inband carousel from the BIG PAT table, you must complete the
following procedures.
1

Stop the OSM process on the DNCS.

2

Delete the Services Portal and OSM session from the PAT table.

3

Tear down the BFS sessions.

Stopping the OSM Process
1

If the DNCS Control window is not already open, click the Control button in the
DNCS area of the DNCS Administrative Console Status window.

Result: The DNCS Control window opens.
2

From the list of processes, click osm.

3

Click Process > Stop Process. A confirmation message appears.

4

Click Yes to stop the OSM process. This causes the indicator next to OSM to turn
red.

5

Are you using a BIG or ASI?



If you are using a BIG, go to Deleting Services Portal and OSM From the
BIG PAT Table.



If you are using ASI, go to Deleting Services Portal and OSM From the ASI
PAT Table (on page 159).

Deleting Services Portal and OSM From the BIG PAT Table
Important:
 Before you begin this procedure, make sure you know the source ID for the
inband Services Portal source. You recorded this ID in step 3 of Deleting the
Inband and Out-of-Band BFS Carousels (on page 150).
 If you use ASI in your system, follow the procedure in Deleting Services Portal
and OSM From the ASI PAT Table (on page 159).
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1

On the DNCS Administrative Console, click the DNCS tab if it is not already
active.

2

Click the Element Provisioning tab.
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3

Click BIG. The BIG List window opens.

4

Double-click the BFS BIG. The Set Up BIG window opens.
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5

Click PAT Configuration. The BIG PAT window opens.

6

Verify that the following requirements are met before you continue this
procedure:




The session numbers and program numbers are in sequential order.
The OSM session is the last entry in the table.

Notes:



During normal operation, the OSM session should always be the last session
in the BIG PAT table. Most sites use 199 as the session number for the OSM
session.



The MAC Address for the OSM session should be 77:77:77:77:77:77.

Does your BIG PAT table meet these requirements?
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If yes, go to step 7.
If no, stop this procedure and call Cisco Services.
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7

Record the session number of the OSM session. You will need this when you add
the OSM session back to the BIG PAT table later in this appendix.
OSM Session Number: _______________________________

8

Select the OSM entry and click Delete Entry. The following message appears.

9

Click Yes. The following message appears.

10 Click OK.
11 Scroll to the Services Portal session. The Session Number is the same as the
source ID for the Services Portal inband source.
12 Record the MAC Address and Session Numbers for all sessions listed
underneath the Services Portal session. Use a separate piece of paper if
necessary.
Important: List the sessions in the order they appear in the list. Later in this
procedure, you will add these sessions back to the BIG PAT table in the same
order.
a

Session Number: ________
MAC Address: __________

b

Session Number: ________
MAC Address: __________

c

Session Number: ________
MAC Address: __________

d

Session Number: ________
MAC Address: __________

13 Select the Services Portal session and click Delete Entry. A message appears,
asking if you want to delete the item.
14 Click Yes.
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15 Click New Entry on the BIG PAT window. The BIG PAT Setup window opens.

16 Enter the Session MAC Address and Session Number for the first session you
recorded in step 12.
17 Click Save.
18 Click OK.
19 Repeat steps 16 through 18 for each entry you recorded in step 12. Make sure
you add these entries in the order you recorded them.
20 In the BIG PAT window, click Close.
21 In the Set Up BIG window, click Apply and then click Cancel.
22 Go to Tearing Down the BFS Sessions (on page 162).
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Deleting Services Portal and OSM From the ASI PAT Table
Important:
 Before you begin this procedure, make sure you know the source ID for the
inband Services Portal source. You recorded this ID in step 3 of Deleting the
Inband and Out-of-Band BFS Carousels (on page 150).
 If you use a BFS BIG in your system, follow the procedure in Deleting Services
Portal and OSM From the BIG PAT Table (on page 154).
1

On the DNCS Administrative Console, click the Application Interface Modules
tab.

2

Click the BFS Admin tab. The Site BFS Administration window opens.

3

Click the Hosts tab.

4

Double-click dncsatm. The Set Up BFS Host window opens.

5

Click PAT Configuration. The Inband Data PAT window opens.
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6

Verify that the following requirements are met before you continue this
procedure:




The session numbers and program numbers are in sequential order.
The OSM session is the last entry in the table.

Notes:



During normal operation, the OSM session should always be the last session
in the PAT table. Most sites use 199 as the session number for the OSM
session.



The MAC Address for the OSM session should be 00:00:00:00:00:00.

Does your PAT table meet these requirements?



7

If yes, go to step 7.
If no, stop this procedure and call Cisco Services.

Record the session number of the OSM session. You will need this when you add
the OSM session back to the PAT table later in this appendix.
OSM Session Number: _______________________________

8

Select the OSM entry and click Delete Entry. The following message appears.

9

Click Yes. The following message appears.

10 Click OK.
11 Scroll to the Services Portal session. The Session Number is the same as the
source ID for the Services Portal inband source.
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12 Record the Session MAC Address and Session Numbers for all sessions listed
underneath the Services Portal session. Use a separate piece of paper if
necessary.
Important: List the sessions in the order they appear in the list. Later in this
procedure, you will add these sessions back to the BIG PAT table in the same
order.
a

Session MAC Address: ____________________________
Session Number: ____________________________

b

Session MAC Address: ____________________________
Session Number: ____________________________

c

Session MAC Address: ____________________________
Session Number: ____________________________

d

Session MAC Address: ____________________________
Session Number: ____________________________

13 Select the Services Portal session and click Delete Entry. A message appears,
asking if you want to delete the item.
14 Click Yes.
15 Click New Entry. The BIG PAT Setup window opens.

16 Enter the Session MAC Address and Session Number for the first session you
recorded in step 12.
17 Click Save.
18 Click OK.
19 Repeat steps 16 through 18 for each entry you recorded in step 12. Make sure
you add these entries in the order in which you recorded them.
20 Close the BIG PAT window.
21 Close the Inband Data PAT window.
22 In the Set Up BFS Host window, click Save and then click Cancel.
23 Go to Tearing Down the BFS Sessions, next in this section.
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Tearing Down the BFS Sessions
1

From the DNCS tab, click the Utilities tab, and then click Session List. The
Session Filter window opens.

2

Select the BFS QAM and click Display Sessions for Selected QAM. The session
data for the BFS QAM appears.

3

Click the Select box adjacent to the lowest numbered session. A checkmark
appears in the Select box to the left of that session.

4

Click Teardown Selected Sessions. BFS will tear down all sessions and will then
rebuild each session.
Note: It may take a few minutes for all of the sessions to rebuild.
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5

When all sessions have been rebuilt (the session IDs are green in color), click Exit
all Session screens.

6

Go to Uninstall the Services Portal, next in this document.
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Uninstall the Services Portal
Uninstalling the Services Portal Server
Complete these steps to uninstall the Services Portal Server.
1

Open an xterm window on the Application Server.

2

Complete the following steps to log on to the xterm window as root user.

3

a

Type su - and press Enter. The password prompt appears.

b

Type the root password and press Enter.

Type the following command and press Enter:
pkgrm SAIisp
Note: The I in the command is an uppercase "i".
Result: A confirmation window appears.

4

When asked if you want to remove this package, type y and press Enter. The
following warning appears:
This package contains scripts which will be executed with super-user
permissions during the process of removing this package. Do you want to
continue with the removal of this package?

5

Type y and press Enter. This command deletes the Services Portal Server. The
deletion is complete when the following message appears:

6

Removal of <SAIisp> was successful

Uninstalling the Services Portal Client
1

In the Application Server xterm window where you are logged in as root user,
type the following command and press Enter:
pkgrm SAISPC
Note: The I in the command is an uppercase "i".
Result: A confirmation window appears.

2

Type y and press Enter. The deletion is complete when the following message
appears:
Removal of <SAIspc> was successful

3

Press Enter.

4

Go to Upgrading the Services Portal Server (on page 61).
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Add OSM Back to the PAT Table
Earlier in this chapter, you removed OSM from the PAT table. This section describes
how to add OSM back to the BIG PAT table and restart the OSM process.

Adding OSM Back to the BIG PAT Table
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1

From the DNCS Administrative Console, click the Element Provisioning tab.

2

Click BIG. The BIG List window opens.
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3

On the BIG List window, double-click the BFS BIG. The Set Up BIG window
opens.

4

Click PAT Configuration. The BIG PAT window opens.
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5

Click New Entry on the BIG PAT window. The BIG PAT Setup window opens.

6

In the Session MAC Address box, type twelve zeros (00:00:00:00:00:00), and
press Tab.
Note: Do not type the colons in this box.

7

In the Session Number box, type the session number for the OSM session. You
recorded this number Deleting Services Portal and OSM From the BIG PAT
Table (on page 154), earlier in this appendix.
Note: Most sites use a session number of 199 for OSM.

8

Click Save.

9

Click Close in the BIG PAT window.

10 In the Set Up BIG window, click Apply and then click Cancel.
11 Go to Restarting the OSM Process, next in this section.
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Adding OSM Back to the ASI PAT Table
Note: For step 8, type the session number for the OSM session that you recorded in
the number in Add the Inband Carousel to the PAT Table (on page 15).
1

On the DNCS Administrative Console, click the Application Interface Modules
tab.

2

Click the BFS Admin tab. The Site BFS Administration window opens.

3

Click the Hosts tab.

4

Double-click dncsatm. The Set Up BFS Host window opens.

5

Click PAT Configuration. The Inband Data PAT window opens.
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6

Click New Entry. The BIG PAT Setup window opens.

7

For Session MAC Address, type twelve zeros (00:00:00:00:00:00), and press Tab.
Note: Do not type the colons.

8

For Session Number, type the session number for the OSM session.
Note: Most sites use a session number of 199 for OSM.

9

Click Save.

10 Close the BIG PAT window.
11 In the Inband Data PAT window, click Close.
12 In the Set Up BFS Host window, click Save then Cancel.
13 Close the Site BFS Administration window.
14 Go to Restarting the OSM Process, next in this document.

Restarting the OSM Process
1

If the DNCS Control window is not already open, click the Control button in the
DNCS area of the DNCS Administrative Console Status.

Result: The DNCS Control window opens.
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2

From the list of processes, click osm.

3

From the Process menu, click Start Process. The indicator next to osm turns
green when the osm has successfully restarted.
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Introduction
This appendix contains the release notes for Services Portal release 3.0.

In This Appendix







78-745238-01 Rev D

Introducing Services Portal 3.0 ......................................................... 170
Why Choose This Release? ................................................................ 171
What Are the Site Requirements? ..................................................... 172
What's Fixed?....................................................................................... 173
Known Issues ...................................................................................... 174
Upgrading the Software..................................................................... 175

169

Appendix C
Services Portal 3.0 Release Notes

Introducing Services Portal 3.0
This chapter lists the requirements for upgrading to Services Portal 3.0, while also
describing several performance improvements over previous releases of Services
Portal software. For additional details, see What's Fixed? (on page 173).
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Why Choose This Release?

Why Choose This Release?
Services Portal 3.0 was designed to install on the Application Server associated with
the DNCS. After the software is installed and active, it provides additional support
and flexibility for sites that use analog set-tops in their subscriber base.
This section includes the features supported in Services Portal software version 3.0.
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What Are the Site Requirements?
Services Portal 3.0 Compatibility
Services Portal 3.0 is compatible with System Releases 4.0 SP2 and later.

When to Perform the Upgrade
We recommend that you upgrade Services Portal during a maintenance window.
This ensures that the fewest number of subscribers are affected by the upgrade.
As you upgrade Services Portal, subscribers can still view the programs to which
they are currently tuned. However, they will not be able to change channels until the
upgrade is complete.
If you have already upgraded your DNCS System Release, you must follow the
directions in Installing the Services Portal Package Information (on page 58) before
you can successfully upgrade Services Portal.
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What's Fixed?
This section provides a description of the CRs implemented in Services Portal 3.0.

CR 16423: Parental Control One-Time Bypass Remained Unblocked
With Parental Control on, if a subscriber selected a blocked service from Services
Portal for one-time viewing, the services remained unblocked after the set-top was
powered off or rebooted. CR 16423 fixes this problem.

CR 17374: Services Portal Did Not Respond to Exit Key
With Services Portal launched, if a subscriber pressed the Exit key on the front panel
of the set-top, Services Portal did not exit. CR 17374 fixes this problem.

CR 17528: Changing Icon Offset for Fullscreen Mode Changed Toolbar Mode
With Services Portal in fullscreen mode, if the icon offset on the Display Frame tab
was changed, the service icons did not change. The icons change in toolbar mode,
even though the change was made to the fullscreen mode. CR 17528 fixes this
problem.

CR 42094: Space in SAM List Prevented Channel Display
If the Short Description in the SAM Service List contained spaces, Services Portal did
not display the channel. CR 42094 fixes this problem.

CR 47063: Services Portal Did Not Launch Using the DNCS GUI
Because of a Java incompatibility, you could not launch Services Portal using the
DNCS GUI. CR 47063 fixes this problem.

CR 54400: Set-Top Rebooted When A Key Pressed During CD Playback
On an Explorer® 8300 set-top, if a subscriber was playing an audio CD and pressed
the A key, sometimes the Services Portal would launch and the set-top would
reboot. CR 54400 fixes this problem so that pressing the A key has no impact on the
set-top.
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Known Issues
Upgrading the DNCS SR Removes the Services Portal Package Information
The DNCS System Release upgrade process removes the Services Portal package
information. This prevents you from being able to remove (uninstall) the previous
version of Services Portal during the Services Portal upgrade process. If you have
already upgraded your DNCS System Release, you must follow the directions in
Installing the Services Portal Package Information (on page 58) before you can
successfully upgrade Services Portal.
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Upgrading the Software
The upgrade process consists of the following tasks:
 Recording server configuration information
 Preserving your previous configuration
 Installing the Services Portal package information (only if you have already
upgraded your DNCS System Release)
 Uninstalling the previous version of Services Portal
 Upgrading the Services Portal Server
 Saving the Services Portal Server configuration
 Upgrading the Services Portal client
See Upgrade the Services Portal (on page 53) for complete instructions on
upgrading your Services Portal software.
If you feel you might need to roll back to the previous version of Services Portal for
any reason, make sure you follow these recommendations:
 Keep your installation CDs of the previous version of Services Portal Client and
Server.
 Make sure to follow the procedures in Preserving Your Previous Configuration
(on page 57) as a precaution.
Note: The upgrade process overwrites the existing config.dat file, but it preserves
the configuration from the previous version (except for button colors).
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A

action safe area
Defined by the Society of Motion Picture and Television Engineers (SMPTE) as an area inside
a rectangle that is placed 12 pixels vertically and 16 pixels horizontally and measures 287 x
215 (in low-resolution systems). Most televisions display text and graphics inside the Action
Safe area. See also Title Safe area.

Application Server
A computer workstation and server used to execute the application programs, which provide
an interface for downloading application data to the DHCTs. The AppServer works in
conjunction with the DNCS and the two computers share a common database.

AppServer
See Application Server.
B

BFS
Broadcast File System. The primary interface (means of communication) between the
AppServer and the DHCTs that are connected to the network.

BFS BIG
Broadcast File System Broadband Integrated Gateway. A device that processes the data it
receives and sends it to the data QAM modulator.

BIG
Broadband Integrated Gateway. A device that provides a data pipeline from the DNCS to the
DHCTs.
C

carousel
Transports data modules and application server processes from the BFS server to the DHCT.
For each new application server process that registers with the BFS, a new data carousel is
created and the ID information is updated in the BFS directory structure. Also known as Data
Carousel or Data Pump.

Channel Map
A set of channels that specific subscribers are authorized to receive through their DHCTs.
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data carousel
See carousel.

data pump
See carousel.

DBDS
Digital Broadband Delivery System. The entire network architecture of our digital system that
ultimately provides signal to and from a subscriber’s DHCT. The DBDS consists of five areas:
sources, headend, transport network, hub, and access network.

demodulator
Receives information such as billing and performance monitoring data in a reverse path from
the DHCT and returns it to the DNCS for processing.

DHCT
Digital Home Communications Terminal. Our digital set-top that is two-way capable for
interactive services. See also Explorer.

DNCS
Digital Network Control System. A computer server that monitors and controls the DBDS
network elements; located at the DBDS headend or at a remote site.

DTV
Digital Television. A telecommunication system for broadcasting and receiving video and
audio by means of digital signals.
E

Explorer®
Our registered trademark name for the Digital Home Communications Terminal (DHCT).
Also known as a set-top box.
F

FAT Channel
See BFS.

FDC
Forward Data Channel. Carries digital data (tuning, management, Internet, and at least two
days of IPG data) in ATM cells on RF signals from the ATM switch to a router, which then
forwards the data to the correct network. Also known as out-of-band data channel.
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FTP
File Transfer Protocol. A method used to exchange files between computers on a network or
the Internet using the TCP/IP protocol.
G

GQAM
gigabit quadrature amplitude modulation. A QAM that provides up to sixteen 6 MHz outputs
while occupying only one unit of rack space. See also QAM, MQAM.
H

HDTV
high-definition television. The high-resolution subset of the DTV system.

headend
The location of the network elements that processes the signal by receiving and preparing the
source signals and making them ready for the transport network. See also network elements.

hub
Physical locations designed to serve a specific number of subscribers, usually 50 to 15,000.
May be co-located with the headend or miles away from the headend. Hubs receive,
modulate, and boost the signal prior to sending it to the network of HFC nodes for
distribution to the subscriber. Hubs usually contain QPSK modulalators/demodulators that
establish the two-way communications with the DHCTs.
I

Internet Protocol
The standard protocol within TCP/IP that defines the basic unit of information passed across
an Internet connection by breaking down data messages into packets, routing and
transporting the packets over network connections, then reassembling the packets at their
destination.

IP
See Internet Protocol.

IP address
A 32-bit sequence of numbers used for routing IP data. Each IP address identifies a specific
component on a specific network. The address contains a network address identifier and a
host identifier.

IPG
Interactive Program Guide. Our name for the on-screen program guide provided by the
Explorer DHCT.
78-745238-01 Rev D

179

Glossary
M

MAC address
Media Access Control address. A unique physical address embedded into a network device.
Similar to a serial number.

modulator
A device that sends control and authorization information from the DNCS to the DHCT.

MPEG
Moving Picture Experts Group. An international video compression standards-setting group
working under the supervision of the International Standards Organization (ISO) and the
International Electrotechnical Commission (IEC). MPEG’s mission is to develop standards for
compressed full-motion video, still image, audio and other associated information.

MQAM
Multiple Quadrature Amplitude Modulation. A QAM that provides up to four 6 MHz
outputs while occupying only one unit of rack space. See also QAM, GQAM.
N

network elements
Devices typically located at the headend, which include satellite receivers (IRT, IRD), RealTime Encoder (RTE), BIG, QAM modulator, DNCS, and the application server. Also known as
system components.
O

OOB
Out-Of-Band. See FDC.
P

PAT
program association table. A second table in the transport stream which contains a list of all
MPEG programs on the transport stream along with their associated program numbers.

PID
packet/program identifier. A number assigned to MPEG transport packets to identify the
contents of the data and the information stream to which they belong. The 13-bit PID number
is assigned in the MPEG-2 transport packet headers. All packets from the same stream have
the same PID number.

PIN
personal identification number. A password used for identification.
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provision
The process of preparing a device or service so that the DNCS recognizes the device, which
allows the device to operate properly.
Q

QAM
quadrature amplitude modulation. A frequency modulation technique primarily used for
program audio and video. QAM supports data rates from 27 Mbps to 36 Mbps.

QAM modulator
A device that uses QAM techniques to modulate a digital signal onto an HFC network to
deliver voice, video, and data to a DHCT.

QPSK
Quadrature Phase-Shift Keying. Digital modulation scheme that send data by modulating the
phase of a reference signal (the carrier wave).

QPSK modulator/demodulator
The QPSK modulator works with the QPSK demodulator and the DHCT to provide forward
signaling and a reverse communications path for interactive video and data services. The
QPSK modulator and demodulator convert digital bit streams to RF format and RF signals to
digital bits, respectively.
S

SAM
Service Application Manager. Associates a specific service with an application that defines the
medium to be used for that service, such as the World Wide Web. The SAM maintains the
application in a specific directory to be used when needed by the DHCTs.

SARA
SA Resident Application. The set of operating programs that is “permanently” loaded into the
DHCT. These programs are immediately available to the subscriber upon activation of the
DHCT.

source
In the DBDS, a source is the actual program or data that is made available to the DHCT as a
service to the subscriber. Sources can include: MPEG-2 digital broadcast services that are nonsecure, non-encrypted, audio/video programs; Internet connections from an Internet service
provider (ISP); Digital PPVs that are secure, encrypted, digital MPEG-2 programs; Digital
music services; Analog programs that are modulated in the traditional format or converted
into MPEG-2 format.
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SR
System Release. Our software release package for components of the DBDS.
T

tar
Short for tape archive, a UNIX utility that combines a group of files into a single file with a .tar
extension.

TCP/IP
Transmission Control Protocol/Internet Protocol. An Internet working protocol that provides
reliable data transport using connection-oriented techniques.

title safe area
Defined by the Society of Motion Picture and Television Engineers (SMPTE) as an area inside
a rectangle that is placed 24 pixels vertically and 32 pixels horizontally and measures 255 x
191 (in low-resolution systems). All television sets display text and graphics inside the Title
Safe area.
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transport stream
A data communications signal that is formatted in accordance with the protocol defined in the
MPEG-2 specification ISO IEC 13818. An MPEG transport stream can carry voice, video, or
data information. The MPEG data transmission protocol transports real-time data.
U

UNIX
An operating system that is less computer/server-specific than other operating systems.
UNIX is widely used in the telecommunications industry and by the Internet.
V

VOD
video-on-demand. The ability of a subscriber to select a program event and watch it within
moments of selection. VOD allows pausing and rewinding of the event.
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Index
A
Action Safe area • 115
adding Services Portal to source list • 20
APPURL • 33

B
background image
customizing • 124
size requirements • 124
banner. • See Where Am I banner
before you begin • 2
BFS
adding in-band carousel to PAT table • 15
creating client BFS in-band server • 26
creating client BFS out-of-band server • 27
creating in-band BFS carousel • 22
creating out-of-band carousel • 24
defining in-band source • 20
set up • 14
tearing sessions down for installation • 28
BIG PAT table
adding inband carousel • 15
blocking services • See Parental Control
branding • 114
buttons
components of • 90
default positions (Full Screen) • 6
default positions (Toolbar) • 5
default widths (Full Screen) • 6
default widths (Toolbar) • 5
positioning • 92
sizing • 92

C
channel-based versus overlay services • 100
client
installing • 36
uninstalling • 60
client BFS
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creating inband server • 26
creating out-of-band server • 27
tearing down BFS sessions • 28
Client Software compatibility • 12
compatibility
Client Software • 12
resident applications • 13
System Release • 12
configuration
BFS • 14
define SP package • 29
font files • 51
launch mode • 76
navigational aids • 128
of buttons • 90
of timeouts • 72
parental control • 100
preserving previous during upgrade • 57
restore after uninstalling SP • 143
save the configuration during install • 35
worksheets • 3
coordinates • See positioning
copying
a configuration to a different headend • 136
the previous configuration when upgrading •
57
customizing
background image • 123
navigation aids • 128
navigation keys • 131
Services Portal window • 114
Where Am I banner • 130

D
default Parental Control messages • 106
define a Services Portal package • 29
DHCT • 49
authorize a test DHCT for Services Portal •
49
launching SP when set-top is powered on • 68
disabling Parental Control • 101
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Index

E

N

EID • 30
converting to decimal • 31
determining • 30
enabling Parental Control • 101
Entitlement ID • 30

names • See service labels
navigation
keys, default positions • 134
keys, purpose • 131
keys, size • 131
Services Portal • 131

F
filtering
blocked services • 110
unauthorized services • 112
Full Screen • 78

I
icon
icon number • 86
selected versus unselected • 85
inband carousel
adding to PAT table • 15
creating • 22
inband server, authorizing • 25
inband source
adding to Source List • 20
defining • 20
install Services Portal • 12
installing
requirements • 12
Services Portal client • 36
Services Portal on DNCS • 13
Services Portal server • 32

K
known issues • 174

L
labels • See service labels
launch mode
defining • 78
Toolbar • 77
layout • 3, 76, 85, 91, 114, 115, 131
logo
default position • 122
embedding in background image • 123
hiding • 122
positioning • 122

M

O
OOB carousel • See out-of-band carousel
OOB server • See out-of-band server
opening Services Portal
from remote control • 36
out-of-band carousel • 24, 150
out-of-band server • 25, 149
overlay service • 100

P
package
authorizing for testing • 49
converting a package EID to decimal • 31
defining • 29
determining SP package EID • 30
ID • See EID
page +/- • 9
page up and down • 9
Parental Control • 7
disable • 100
enable • 100, 101
message defaults • 106
messages, changing • 103
show or hide blocked services • 110
positioning • 115
Action Safe area • 115
buttons • 92
navigation keys • 131
Services Portal window • 129
Title Safe area • 115
Video window • 128
Where Am I banner • 130
Power-On service
timeout • 72

R
release notes • 170
remote control

moving • See positioning
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A key • 46
arrow up and down • 91
Guide key • 46
Menu key • 47
navigating Services Portal • 131
page up and down • 91
requirements, for installation • 12
resident application compatibility • 13
roll back to previous version • 142

S
SAM URL • 33
server
installing • 33
uninstalling • 60
service labels, changing • 97
services
adding to portal • 83
rearranging • 83
Services Portal window
branding • 114
positioning • 129
sizing • 129
set-top • See DHCT
site requirements • 172
sizing
buttons • 92
Services Portal window • 129
Video window • 128
Where Am I banner • 130
source list, adding Services Portal to • 20
System Release compatibility • 12

U
unauthorized services, show or hide • 112
uninstall Services Portal • 146
upgrading
before you begin • 54
keeping previous configuration • 57
saving the configuration • 63
Services Portal • 54
SP client • 64
SP server • 61
URL, for SAM service • 33

V
Video window
positioning • 128
sizing • 128

W
what's fixed? • 173
Where Am I banner • 130
default position • 130
showing or hiding • 130

T
timeout
after activating the Services Portal • 72
after turning on set-top • 72
configuring • 73
default values • 72
title
changing • 117
default position • 120
embedding in background image • 123
hiding • 121
positioning • 120
removing • 119
Title Safe area • 115
Toolbar Mode • 77
transfer the Services Portal configuration • 136
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