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About This Guide

About This Guide
Introduction
The LogoTool application, created by Cisco, is a Macintosh-capable application that
allows you to create MSO (Multiple System Operator) and service (channel) logos.
These logos are created using Adobe Photoshop (Photoshop) and then exported
from Photoshop into formats that are required for use with the Cisco Resident
Application (SARA), as well as the Digital Network Control System (DNCS).
The information within this guide describes the requirements for creating MSO and
service logos that are used on the DNCS. This guide also includes the procedures for
exporting the logos into the appropriate files needed for the DNCS.

Purpose
This guide provides an outline of the requirements and procedures required to
create custom logos and to export those logos from Photoshop using LogoTool plugin software. This guide also provides information about system requirements and
installation.

Scope
The contents of this user's guide apply to logos that will be used with Cisco
software. The contents of this user's guide do not include instructions for loading the
logos onto the DNCS. For instructions on loading logos onto the DNCS, refer to
Configuring Logos on the DNCS (part number 738163).

Audience
This guide is written for graphic designers who create logos for cable service
providers.

Document Version
This is the second release of this document.
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1 Chapter 1
Overview
LogoTool is a software application that allows you to create MSO and
service logo files that are SARA-compatible. When using LogoTool
with MSO logos, it creates a file during the Photoshop export process
that can be loaded onto the DNCS. When using LogoTool with service
logos, it inserts multiple exported service logos into a combined,
indexed file that can also be loaded onto the DNCS. Once these files
are on the DNCS, they can be transported to Digital Home
Communications Terminals (DHCTs) in the Digital Broadband
Delivery System (DBDS) network.
This chapter describes the LogoTool application, as well as the system
requirements and installation procedures. This chapter also describes
the requirements for creating MSO and service logos.

In This Chapter
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Chapter 1 Overview

System Requirements
The following list identifies the components that are required for your system to run
the LogoTool application:
 A Macintosh computer running Mac operating system X 10.3 or later
 Adobe Photoshop version 7.0 to CS2
Important: Adobe Photoshop version CS3 has not been tested; therefore, we
advise that you do not attempt to use this version with the LogoTool application.
 logotool.dmg
Note: This executable file is licensed to you by Cisco, Inc., and contains the
following Photoshop plug-in software (with Cisco license):

2

-

SARA Export

-

SARA Format

-

SARA Picker
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Software Installation

Software Installation
Installing Photoshop
Important: To see what versions of Photoshop are compatible with LogoTool, refer
to System Requirements (on page 2).
If the appropriate version Photoshop is not yet installed on your computer, install or
upgrade it now. To install Photoshop on your computer, refer to the instructions that
came with your Photoshop software.

Installing LogoTool
Complete the following steps to install the LogoTool application.
Important: Adobe Photoshop 7.0 or later should already be loaded on your
computer. If it is not, load or upgrade it now by using the instructions that were
provided with the Photoshop package.
1

Insert the LogoTool CD into your CD drive.

2

Create a directory called SA LogoTool.

3

Move the LogoTools.dmg file into the SA LogoTool directory and uncompress it.

4

Drag the following files into the Adobe Photoshop 7.0/Plug-Ins/Adobe
Photoshop Only/Import/Export/ folder:
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SARA Export
SARA Format
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Logo Requirements and Options
This section describes the requirements for MSO and service logos that will be used
with the LogoTool application. It also describes the transparency options that you
can apply to each of your logos.

Dimensions
When creating new logos or editing existing logos, you must size them within the
following dimensions:
Logo Type

Dimensions
(maximum size in pixels)

MSO logos

54 x 47

Service logos

25 x 25

Logo IDs
Although logo IDs are only required for service logos on the DNCS, an ID for both
MSO and service logos is required during the SARA export process. These IDs must
be within the following numeric ranges:
Logo Type

ID Range

MSO logos

256 – 32767

Service logos

> 256

Important:
 The ID for a service logo should match the ID assigned; make sure that the ID
matches the ID that you defined in the service logo index. Go to Create a Service
Logos Index (on page 21) for details.
 Logo IDs must be sequentially numbered.

4
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Logo Requirements and Options

Transparency Options
Overview
This section describes the various methods that may be used to apply transparency
to MSO and service logos. Applying a transparency layer to a logo image allows the
logo to seamlessly integrate into the design of any screen that is viewed by the
subscriber. There are several ways to create transparency effects in Photoshop. The
method you choose will depend on the logo you are exporting, as well as your
specific needs.
Types of Transparency Methods
If the original artwork does not use the Photoshop transparency feature, there are
several methods for achieving a transparency layer. Transparency methods are
explained within this section and include the following options:
Note: The transparency layer is defined during the "SARA Export" process. Review
these transparency options to see which method will best suit your needs.
 No transparency
 Photoshop transparency
 Color range transparency
No Transparency
If the logo does not need any transparency, you must set all minimum and
maximum values for the red, green, and blue (RGB) colors to zero. These color
values will be applied to the logo during the export process. Go to Export MSO
Logos (on page 13) or Export Service Logos (on page 24) for more details.
Note: Setting each RGB value to zero works well with rectangular or square-shaped
logos.
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Photoshop Transparency
The easiest method for applying transparency to a logo is to use Photoshop tools.
Creating the logo artwork on a transparent background in Photoshop allows the
edges of the logo to fade into transparency over any color background. This fading
effect provides a very smooth look on the screen.
Note: Do not select the parts of the logo that should be transparent.
Complete the following steps to apply a transparency layer to a logo.
1

Select the image by clicking the Select menu and clicking All.

2

From the File menu, click New. The New window opens.

3

From the Name field, enter a name that describes the logo.

4

Retain the image size as it will be exactly the same as the copied image.

5

Click OK. A new window opens.

6

From the Edit menu, click Paste. A copy of the image appears in the new
window.
Note: The image will be floating on a transparent background on a separate
layer.

6

7

Ensure that the area remains transparent by dragging the background layer to
the small trash can icon in the Layers palette (this deletes that layer).

8

Go to Export MSO Logos (on page 13) or Export Service Logos (on page 24).

4000820 Rev B

Logo Requirements and Options

Color Range Transparency
The color range transparency option allows you to specify a specific color range that
is applied to the logo during the export process. Go to Export MSO Logos (on page
13) or Export Service Logos (on page 24) for more details.
Tips:
 Pixels within the logo that have RGB values between the minimum and
maximum ranges become transparent in the exported file.
 To achieve a white transparency, set the RGB ranges between 220 (Min) and 255
(Max). Because the RGB values for white are all 255, white falls within the 220 to
255 range. The minimum value of 220 allows pixels that are almost white (for
example, R=245, G=250, B=240) to become transparent as well. This helps to
eliminate the halo from the non-transparent areas in the logo.
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2 Chapter 2
MSO Logos
This chapter describes the procedures necessary to prepare MSO logos
for use with LogoTool, as well as the procedures for exporting the
logos into a SARA-compatible format.

In This Chapter
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Chapter 2 MSO Logos

Introduction
A MSO logo is the logo that identifies the service provider. It is a single graphic file
(.rle file) that is stored and mapped on the DNCS. The MSO logo can appear in a
screen or banner as defined by the following list:
 IPG Logo: appears at either the top left or top right corner of the Interactive
Program Guide (IPG). This logo can also be used as a screen saver for services
that use the bfs://resapp/music URL
 Not IPG Logo: appears on other screens, such as the recorded list for the Digital
Video Recorder (DVR) service and the HDTV setup wizard
 Spin-Down Logo: appears when the DVR enters a power save mode (the hard
drive "spins down" and the DVR displays a moving logo as a screen saver)

10
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Prepare MSO Logos for Export

Prepare MSO Logos for Export
This section includes the procedures for placing an MSO logo into the appropriate
format to use with the LogoTool SARA export process. The dimensions of the MSO
logo must be 54 pixels x 37 pixels.
Note: If the MSO logo is not sized to the required dimensions, display problems may
be seen by subscribers.

Preparing MSO Logos
When preparing MSO logos for export to SARA, you can either create a new logo or
use an existing logo. Go to New MSO Logos (on page 11) or Existing MSO Logos (on
page 12), as needed.
New MSO Logos
1 From the File menu, click New. The New window opens.
2

From the New window, complete the following steps to create an MSO logo.
a

From the Name box, type a name that describes the MSO logo (for example,
victory).

b Enter the appropriate dimensions in the Width and Height text boxes.
Note: The dimensions of the MSO logo must be 54 x 37 pixels.
c

From the Mode file, select RGB Color.

d From the Contents field, select the appropriate background option.
e
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Click OK. The new file opens.

3

Create your logo, as needed.

4

Click Save and save the file in a Photoshop (PSD) format.

5

Repeat steps 1–4, as needed, to create other MSO logos.

6

Keep the MSO files open and go to Export MSO Logos (on page 13).

11
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Existing MSO Logos
1 From Photoshop, click the File menu and select Open.
2

Navigate to the appropriate directory and select the MSO logo that you want to
open.

3

Click Open. The logo image is displayed.

4

From the image menu, click Mode and select RGB. When selected, a check mark
will appear next to the RGB option.

5

Click Image and select Image Size. The Image Size window opens.

6

From the Pixel Dimensions area, enter the appropriate dimensions for the MSO
logo that you have opened.
Note: Refer to Prepare MSO Logos for Export (on page 11) for details about the
MSO logo size requirements.

7

Click OK.

8

Modify the file name to identify the MSO logo, as appropriate (for example,
name the file victory.psd).

9

Click Save As to save the logo as a new file.

10 If necessary, repeat steps 1–9 to create additional MSO files for export.
11 Keep the MSO files open and go to Export MSO Logos (on page 13).

12

4000820 Rev B

Export MSO Logos

Export MSO Logos
This section includes the procedures for exporting MSO logos into SARA-compatible
formats.

Exporting the MSO Logo
1

From the File menu, select Open.

2

Select an MSO logo from the appropriate directory and click Open.

3

From the File menu, click Export and select Sara Export.

4

From the Save As field, type a name that describes the MSO logo (for example,
msologo.rle).
Note: The .rle file is the name of the SARA graphics object (SGO) file that will be
exported for the MSO logo.

5

4000820 Rev B

Navigate to the appropriate folder where you want to export the logo and click
Save. The SARA export to file window closes and the following window opens.

13
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6

7

8

What type of transparency will the logo require?



If no transparency, enter 0 (zero) for each minimum and maximum RGB
value and then go to step 7.




If Photoshop transparency, go to step 7.

Verify the following values within this window:
Field

Value

Blend

128

Black Threshold

8

Dither Method

4x4

Are these values present?



9

If color range transparency, enter a value (0–255) for each minimum and
maximum RGB value, as desired. Then go to step 7.

If yes, go to step 9.
If no, modify the values to match those in step 7.

From the Logo file field, type the name for the MSO logo (for example,
msologo.rsrc).

10 From the Logo ID field, type a value that is greater or equal to 256.
11 Leave the Logo Name field blank.
12 Click OK. The system exports the following four file types to the directory you
defined in step 2.
Important: The RLE file is the file that you will send to the cable service
provider.






RLE: the final logo
RSRC: final Macintosh resource file
SGO: final exported SARA graphics file
SGP: final exported SARA graphics parameters file

13 Repeat steps 1–12 to export any other MSO logos, as needed.

14
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Export MSO Logos

Viewing Exported MSO Logos
1
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Open an exported MSO logo using one of the following methods:



Drag the SGO file onto the Photoshop icon in the Finder and press the
Option key as the file is opening. The SGO Read Options window opens. Go
to step 4.



From the Photoshop toolbar, click File and select Open. Then go to step 2.

2

Navigate to the appropriate directory and select the SGO file you want to view.

3

Press the Option key on your keyboard and, simultaneously, click Open. The
SGO Read Options window opens.

15
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4
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Modify any of the following options, as desired:



2x Enlarge: select this option to expand the logo to twice its size when
importing it into Photoshop. This is similar to what SARA does when
displaying logos on a TV screen.



Create Log File: select this option to build a text-based log file when opening
the SGO file. The log file will contain the settings used to build the SGO file.




Theme: choose from one of seven color themes available within SARA.



Show Out-of-Gamut Pixels: select this option to highlight pixels in the SGO
logo that will not display properly on a TV screen. The default highlight
color is bright green. To select another highlight color, click the color sample
that appears after you have selected this option.

Part: select a color to assign as the background color for an SGO file that you
are importing. The color swatches reflect the color theme selected in the
Theme menu. Transparent areas within the SGO file will be the color you
select here.

5

Click OK. The image in the SGO file opens in Photoshop.

6

View the image, as needed.

7

From the File menu, click Close to close the file.
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Send MSO Logos to Cable Service Providers
Logo files are delivered via email. When sending logos to cable service providers,
make sure you include the RLE file for each MSO file that was requested.
Important: Cisco recommends that you make copies of all logo files. This is
especially useful if you need to export the same logo in the future.

4000820 Rev B
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3 Chapter 3
Service Logos
This chapter describes the procedures necessary to prepare service
logos for use with LogoTool, as well as the procedures for exporting
the logos into a SARA-compatible format.

In This Chapter
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Chapter 3 Service Logos

Introduction
Service logos, such as the HBO logo, are used to enhance a service's identity and are
created for local or custom services. All custom service logos are placed into one
indexed resource file and stored on the DNCS.
Notes: Each channel can have its own service logo or a service logo can be shared
among several channels.
A service logo can appear in either of the following locations:
 IPG Logo: appears at either the top left or top right corner (opposite the MSO
logo) on the IPG
 Channel Banner: appears in the channel banner of the TV screen when a
subscriber tunes to a service or presses the Info button on the set-top or remote
control

20
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Create a Service Logos Index
Before you begin creating service logos, you must create an index of desired service
logos.
Important:
 Service logos require the following attributes:
-

Logo IDs greater than 256

-

Logos IDs must be sequentially numbered

 When updating the service logos, do not change the IDs for existing services.
This requires changes to the service-to-logo mapping on the DNCS. If this is not
done correctly, the wrong logo could be displayed.
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Prepare Service Logos for Export
This section includes the procedures for placing a service logo into the appropriate
format to use with the LogoTool SARA export process. The dimensions of the service
logos must be 25 pixels x 25 pixels.
Note: If the service logos are not sized to the required dimensions, display problems
may be seen by subscribers.

Preparing Service Logos
When preparing MSO logos for export to SARA, you can either create a new logo or
use an existing logo. Go to New Service Logos (on page 22) or Existing Service Logos
(on page 23), as necessary.
New Service Logos
1 From the File menu, click New. The New window opens.
2

From the New window, complete the following steps to create a service logo file
for export to SARA.
a

From the Name box, type a name that describes the service logo (for example,
hbo).

b Enter the appropriate dimensions in the Width and Height text boxes.
Note: The dimensions of the service logos must be 25 pixels x 25 pixels.
c

From the Mode file, select RGB Color.

d From the Contents field, select the appropriate background option.
e

22

Click OK. The new file opens.

3

Create your logo, as needed.

4

Click Save and save the file in a Photoshop (PSD) format.

5

If necessary, repeat steps 1–4 to create additional service logo files for export.

6

Keep the files open and go to Export Service Logos (on page 24).
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Existing Service Logos
1 From Photoshop, click the File menu and select Open.
2

Navigate to the appropriate directory and select the appropriate service logo file
that you want to open.

3

Click Open. The logo image is displayed.

4

From the Image menu, click Mode and select RGB. When selected, a check mark
appears next to the RGB option.

5

Click Image and select Image Size. The Image Size window opens.

6

From the Pixel Dimensions area, enter the appropriate dimensions for the service
logo file.
Note: The dimensions of the service logos must be 25 pixels x 25 pixels.

7

Click OK.

8

Modify the file name to identify the service logo, as appropriate (for example,
hbo.psd).

9

Click Save As to save the logo as a new file.

10 If necessary, repeat steps 1–9 to create additional service logo files for export.
11 Keep the files open and go to Export Service Logos (on page 24).
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Export Service Logos
This section includes the procedures for using LogoTool to export service logos into
SARA-compatible formats.

Exporting a Service Logo

24

1

From the File menu, select Open.

2

Select a service logo file from the appropriate directory and click Open.

3

From the File menu, click Export and select Sara Export.

4

From the Save As field, verify that the name is the same as the service logo you
opened and is in the SGO format (for example, starz.sgo).

5

Navigate to the folder where you want to export the logo.
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Export Service Logos

6

Click Save. The SARA export to file window closes and the following window
opens.

7

What type of transparency will the logo require?

8
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If no transparency, enter 0 (zero) for each minimum and maximum RGB
value and then go to step 8.




If Photoshop transparency, go to step 8.
If color range transparency, enter a value (0–255) for each minimum and
maximum RGB value, as desired. Then go to step 8.

Verify that the following values exist in the window:
Field

Value

Blend

128

Black Threshold

8

Dither Method

4x4

25
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9

Are these values present?




If yes, go to step 10.
If no, modify the values to match those in step 8. Then go to step 10.

10 From the Logo file field, verify that the file name is Logos.rsrc.
11 From the Logo ID field, type the logo ID number that you defined in your
service logo index.
Important: It is critical that the logo ID number that you enter agrees with the
service logo index you created. This will be a number greater than 256.
Note: This is also the ID number that the DNCS and DHCT will use to map the
logo to a service.
12 In the Logo Name field, type the name of the logo you are exporting (for
example, starz).
13 Click OK. The system exports the following four file types to the directory you
defined in step 5:






RSRC: final Macintosh resource file
RES: (Logos.res) SARA-compatible logo data file
SGO: final exported SARA graphics file
SGP: final exported SARA graphics parameters file

Notes:



If you are creating logos for several customers, it is a good idea to rename the
file to identify the customer with the logo file.
Example: CableCo_Logos.res




Each subsequent channel logo you export is added to this file.
The Logos.res file is the file that you will send to the cable service provider.

14 Repeat steps 1–13 for each service logo in the index.
15 Go to Viewing Exported Service Logos (on page 27).

26
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Export Service Logos

Viewing Exported Service Logos
1
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Open an exported service logo using one of the following methods:



Drag the SGO file onto the Photoshop icon in the Finder and press the
Option key as the file is opening. The SGO Read Options window opens. Go
to step 4.



From the Photoshop toolbar, click File and select Open. Then go to step 2.

2

Navigate to the appropriate directory and select the SGO file you want to view.

3

Press the Option key on your keyboard and, simultaneously, click Open. The
SGO Read Options window opens.

27
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4

Modify any of the following options, as desired:



2x Enlarge: select this option to expand the logo to twice its size when
importing it into Photoshop. This is similar to what SARA does when
displaying logos on a TV screen.



Create Log File: select this option to build a text-based log file when opening
the SGO file. The log file will contain the settings used to build the SGO file.




Theme: choose from one of seven color themes available within SARA.
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Part: select a color to assign as the background color for an SGO file that you
are importing. The color swatches reflect the color theme selected in the
Theme menu. Transparent areas within the SGO file will be the color you
select here.
Show Out-of-Gamut Pixels: select this option to highlight pixels in the SGO
logo that will not display properly on a TV screen. The default highlight
color is bright green. To select another highlight color, click the color sample
that appears after you have selected this option.

5

Click OK. The image in the SGO file opens in Photoshop.

6

View the image, as needed.

7

From the File menu, click Close to close the file.
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Send Service Logos to Cable Service Providers
Logo files are delivered via email.
Important: Cisco recommends that you make copies of all logo files. This is
especially useful if you need to export the same logo in the future.

4000820 Rev B

29

4 Chapter 4
Customer Information
If You Have Questions
If you have technical questions, call Cisco Services for assistance.
Follow the menu options to speak with a service engineer.
Access your company's extranet site to view or order additional
technical publications. For accessing instructions, contact the
representative who handles your account. Check your extranet site
often as the information is updated frequently.
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