Cisco TelePresence
MCU Conference Director
Online help (printable format)
Version 1.3(1.0)
February 2012

Contents

Contents
Introduction ......................................................................................................................... 6
Welcome .................................................................................................................................................. 6
A Windows™ application ......................................................................................................................... 6
Two views ......................................................................................................................................... 6
Getting started ......................................................................................................................................... 7
The MCU list ..................................................................................................................................... 7
The Address book ............................................................................................................................ 7
System tray icon ............................................................................................................................... 7
Troubleshooting ................................................................................................................................ 7
What you see in the Tree View ............................................................................................................... 8
Grouped by MCU view ..................................................................................................................... 8
Grouped by conference view............................................................................................................ 9
Icon reference list .................................................................................................................................. 10

Preferences.........................................................................................................................12
Setting preferences ............................................................................................................................... 12
Preferences dialog fields ....................................................................................................................... 12
General preferences ....................................................................................................................... 12
Conference preferences ................................................................................................................. 13

MCUs ...................................................................................................................................14
The MCU list .......................................................................................................................................... 14
Connecting to an MCU .......................................................................................................................... 15
Retrying a connection ..................................................................................................................... 15
Reasons for failure to connect........................................................................................................ 15
Access, user accounts and privilege levels ........................................................................................... 16
Disconnecting an MCU and removing it from the Tree View ................................................................ 16
Displaying MCU properties .................................................................................................................... 16
MCU properties fields ............................................................................................................................ 17
General page .................................................................................................................................. 17
Network status page ....................................................................................................................... 17
Ethernet status page ...................................................................................................................... 18
Health status page ......................................................................................................................... 18

Conferences .......................................................................................................................20
About conferences ................................................................................................................................. 20
Active vs scheduled conferences ................................................................................................... 20
What you see in the List View ........................................................................................................ 20
Cascaded conferences ................................................................................................................... 20
Layout views and video streams .................................................................................................... 21
Conference templates ........................................................................................................................... 21
Creating and selecting the conference template list ...................................................................... 21
Leaving the Conference template list open .................................................................................... 21
Creating/Selecting a Conference template list ............................................................................... 21
Creating and working with conference templates ................................................................................. 21
Leaving the Conference template list open .................................................................................... 22
Adding a Conference template ....................................................................................................... 22

Cisco TelePresence Conference Director online help (printable format)

Page 2 of 61

Contents

Editing a Conference template ....................................................................................................... 22
Duplicating a Conference template ................................................................................................ 22
Removing a conference template .................................................................................................. 23
Creating a conference template from a configured conference ..................................................... 23
Creating a conference ........................................................................................................................... 23
Creating a conference using menu options .................................................................................... 23
Creating a conference by dragging and dropping .......................................................................... 23
Creating a cascading conference .......................................................................................................... 24
Scheduling a cascaded conference ............................................................................................... 24
Possible issues ............................................................................................................................... 25
Editing a cascading conference ............................................................................................................ 25
Duplicating a conference ....................................................................................................................... 25
Dragging and dropping conferences ..................................................................................................... 26
Displaying and editing the conference configuration ............................................................................. 26
Conference configuration fields ............................................................................................................. 27
Repeat page ................................................................................................................................... 28
Permanent conferences ................................................................................................................. 29
Layout page .................................................................................................................................... 29
Participants page ............................................................................................................................ 29
Cascading page ............................................................................................................................. 29
Advanced page .............................................................................................................................. 30
Pane placement ..................................................................................................................................... 30
Streaming (of the main video channel) .................................................................................................. 31
Port reservation ..................................................................................................................................... 31
Media port types ............................................................................................................................. 32
Participant port usage .................................................................................................................... 32
Streaming ....................................................................................................................................... 32
Configuring the MCU ...................................................................................................................... 32
Unreserved mode ........................................................................................................................... 32
Reserved mode .............................................................................................................................. 32
Clashing reservations ..................................................................................................................... 33
Ad hoc conferencing ....................................................................................................................... 33
Auto attendant connections ............................................................................................................ 34
Changing MCU port reservation mode ........................................................................................... 34
Port usage with content channel support ....................................................................................... 34
The content (H.239) channel ................................................................................................................. 34
Content channel vs. main video ..................................................................................................... 35
H.323 endpoints' content channel support ..................................................................................... 35
Content channel sources................................................................................................................ 36
MCU content channel configuration ...................................................................................................... 36
Streaming of the content channel, markup and chat ............................................................................. 37
Markup............................................................................................................................................ 37
Text chat ......................................................................................................................................... 38
Sending a message during a conference .............................................................................................. 38
Ending and deleting a conference ......................................................................................................... 39

Participants.........................................................................................................................40
About participants .................................................................................................................................. 40
Connecting a participant ........................................................................................................................ 40
Understanding participant status ........................................................................................................... 40

Cisco TelePresence Conference Director online help (printable format)

Page 3 of 61

Contents

Adding a participant to a conference ..................................................................................................... 41
Displaying/Editing a participant's properties .......................................................................................... 42
Participant properties fields ................................................................................................................... 43
General page .................................................................................................................................. 43
Layout page .................................................................................................................................... 45
Focus page ..................................................................................................................................... 45
Camera page .................................................................................................................................. 46
Statistics page ................................................................................................................................ 46
Send message page ...................................................................................................................... 47
Making a participant important/have normal importance ...................................................................... 47
Muting/unmuting the audio or video for one or more participants ......................................................... 47
Participants in an active conference .............................................................................................. 48
Participants in a scheduled conference ......................................................................................... 48
Participants in the Address book .................................................................................................... 49
Lecture mode ................................................................................................................................. 49
Outgoing audio mute ...................................................................................................................... 49
Making a participant the lecturer ........................................................................................................... 49
Controlling a participant's endpoint camera .......................................................................................... 50
Dragging and dropping participants ...................................................................................................... 50
Dragging between conferences ..................................................................................................... 50
Keeping track of moved participants .............................................................................................. 50
Dragging to and from the Address book ........................................................................................ 50
Dragging from the auto attendant .................................................................................................. 51
Understanding layout views................................................................................................................... 51
Layout pages ......................................................................................................................................... 51
One layout or a family .................................................................................................................... 51
Equal sizes or different sized panes .............................................................................................. 51
Widescreen layouts and clipped panes .......................................................................................... 51
"Important" participants ......................................................................................................................... 52
"Important" Participants Combined with View Focus ..................................................................... 52
Participants viewing themselves ........................................................................................................... 52
Video stream vs. fixed images............................................................................................................... 52
Setting the layout ................................................................................................................................... 53
Active vs configured participants .................................................................................................... 53
Letting participants change their own layout .................................................................................. 53
Layouts in lecture mode ................................................................................................................. 54
Disconnecting or removing a participant from a conference ................................................................. 54

Address book .....................................................................................................................55
Creating and selecting the Address book .............................................................................................. 55
Leaving the Address book open ..................................................................................................... 55
Address book compared to pre-configured endpoints ................................................................... 55
Creating/Selecting an Address Book ............................................................................................. 55
Adding a participant to the Address book/Editing an entry ................................................................... 56
Adding a participant to a conference and to the Address book ..................................................... 56
Address book entry fields ...................................................................................................................... 56
General page .................................................................................................................................. 56
Layout page .................................................................................................................................... 57
Removing a participant from the Address book .................................................................................... 57
Obtaining Address book entries from an MCU ...................................................................................... 58

Cisco TelePresence Conference Director online help (printable format)

Page 4 of 61

Contents

Auto attendants ..................................................................................................................59
The auto attendant branch .................................................................................................................... 59

Troubleshooting .................................................................................................................60
Displaying the event log ........................................................................................................................ 60

Cisco TelePresence Conference Director online help (printable format)

Page 5 of 61

Introduction
Welcome
Cisco TelePresence MCU Conference Director is a tool for creating, scheduling and monitoring conferences
on Cisco TelePresence MCUs. These can be part of the MCU 4200 Series, MCU 4500 Series, or a MCU
MSE 8420 on an MSE 8000. The MCUs need to be running version 2.1(1) or later and have an MCU
Conference Director feature key enabled.
Conference Director is not a replacement or substitute for the MCU's web interface, but rather a
complementary tool for organizations that have one person monitoring several MCUs simultaneously or
several people who schedule and monitor conferences on the same MCUs simultaneously on a Windows™
platform and who need to be able to work together.
Conference Director is not a complete MCU administration tool in the current release. There are functions in
the web interface that are not available through the Conference Director and these are mentioned, where
appropriate, with pointers to the web interface pages that you need to use for those functions.
Conference Director can be used by several people at the same time working with the same MCUs.
Changes made by one user are seen by the other users the next time that the application refreshes. The
same is true of changes made via the web interface on an MCU that you are monitoring through
Conference Director.

A Windows application
Conference Director is a normal Windows application with two panes.
The left pane is a Tree View:
•

When you open Conference Director for the first time the only entry is System
click to begin using the application but also see Getting started below

•

Expand and close branches by clicking on the plus/minus signs

•

Right-click on an entry to see its context menu

. You can right-

For more specific information, see What you see in the Tree View.

The right pane is the List View and what is displayed in this view depends on what you select in the Tree
View. In the List View you can:
•

Order columns by dragging the titles

•

Sort entries by a column by clicking on the column title. Click again to reverse the order. The default
is to sort on the Name

•

To select an entry, click on the name. You can also right-click on an entry to display its context
menu

You can access functions in more than one way; for example right-clicking on an entry and selecting an
option from the context menu or by selecting an entry and using either the Toolbar icons or menu options.
The instructions in this help aim to provide the easiest method, and alternatives are sometimes added.

Two views
In Conference Director the Tree View can present information in two ways and you can swap between them
at any time by using the View menu: grouped by MCU (this is the default view that Conference Director
opens in the first time that you use it) and grouped by conference. Both views allow you to access all the
functionality - for more information see What you see in the Tree View.
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Getting started
To start using Conference Director you may want to do one or more of the following:
•

Connect to one MCU (MCU's have the
icon.). Either right-click on System
to MCU or use the Connect option from the MCU menu

•

Open an MCU list that someone else has set up to connect to a number of MCUs in one step. Go to
File > Open MCU list

•

Set your preferences. You can set up defaults for a number of functions such as conference properties.
This will save you time when you use these functions subsequently because these defaults are
displayed also see the next point. You can also set levels for displaying alarms. Go to Tools >
Preferences.

•

Create or select a conference template list if the conferences you will be creating can be grouped in
some way. Go to Tools > Conference templates > Select template list
•

•

and select Connect

Open the Conference template list and create a number of conference templates in the list. Go to
Tools > Conference templates > Open template list

Create or select an Address book. Go to Tools > Address book > Select address book and browse
for the file to open
•

Open the Address book and add entries. Go to Tools > Address book > Open address book

The MCU list
The MCU list is optional. It can be used to store the connection information for the MCUs that you connect
to frequently, so you can open the MCU list and connect to all these MCUs with one command each time
you use Conference Director.
You can keep a number of MCU lists, and they can be stored locally or on a server so that they can be
shared.
See the MCU list for details about how to create and use the MCU list.

The Address book
The Address book is also optional. You can create an Address book and add entries for the participants that
you call in to conferences frequently.
You can also keep a number of Address books and then select the one to use at any time. If you are one of
a team using Conference Director to monitor the same MCUs you can share (open) an Address book that
someone else has set up already. See Creating and selecting the Address book.
You can also import configured endpoints from an MCU in to your open Address book. See Obtaining
Address book entries from an MCU.

System tray icon
When Conference Director is running, an icon appears in the system tray. This can be used to display the
preferences dialog and to close the application. But more usefully, it is used by the application to display
pop-up warnings; for example, that a conference is about to end. See the Icon reference.

Troubleshooting
For more detailed information than is available in the Tree or List Views, display the Events log window.
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What you see in the Tree View
When you open Conference Director for the first time, the only entry is System

and you are in the

- or open an MCU list, if you have
"grouped by MCU" view. You can right-click to connect to an MCU
set one up, or you can use one that someone else has already set up. All these concepts are explained in
this topic.
Two views: grouped by MCU and grouped by conference
In Conference Director the Tree View can display information in two ways and you can swap between them
at any time with the View menu:
•

The grouped by MCU view is the one you see when you open Conference Director for the first time. In
this view entries in the Tree View are listed by MCU, with conferences as sub-categories. (When you
open Conference Director subsequently, the application opens in the view that was displayed when you
closed it)

•

The grouped by conference view lists entries by conference name

Both views are explained more fully below.

Grouped by MCU view
Top level in the Tree View
In this view the top level in the Tree View is the MCUs that you are managing through Conference Director.
•

For each MCU there are a number of branches: Active (live) conferences

, Scheduled conferences

and Auto attendants
•

The auto attendant branch is for information only: you cannot create auto attendants using Conference
Director. See the auto attendant branch

•

Expand and collapse branches by clicking on the plus/minus signs

With the Active conference branch selected
This branch opens to show all the active (live) conferences. The number in brackets besides each
conference name is the number of active participants. You can also expand the branch for each conference
and the active and disconnected participants are then listed for the selected conference.
When you click on the Active conferences branch, the List View displays each conference name with a
colored background and lists the participants under each name. The following information (columns) are
displayed for each participant: Name, Address, Type, Audio (incoming), Outgoing audio, Video (outgoing),
Important, Call state, Connect time, Disconnect time and Disconnect reason. (Remember that you can
reorder the columns if required by clicking on the column title.) This provides the connection history for ad
hoc participants: if an ad hoc participant connected, disconnected and reconnected there is more than one
entry for that participant in both views.



You can clear the entries for disconnected participants by right-clicking on the conference in the
Tree View and selecting Remove disconnected.

With the Scheduled conferences branch selected
This branch opens to show all the conferences scheduled on the MCU. The number in brackets besides
each conference name is the number of configured participants. The List View also shows these
conferences with a colored background. For each conference the Name, Status, Start and End time are
displayed.
When you select the name of a conference configuration in the Tree View, each configured participant is
displayed in the List View. There is only one entry per participant and the following information (columns)
are displayed: Name, Address, Type, Audio and Video.
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If you select an auto attendant in the Tree View, the List View clears.

Cascaded conferences
A cascaded conference is listed under each MCU that it occurs on. You see which MCU is the master MCU,
highlight any of the conference entries and change to the Grouped by conference view: the master MCU is
the first one listed for this conference,

Grouped by conference view
Top level in the Tree View
In this view the top level in the Tree View has three branches: Active (live) conferences
conferences
signs.

and Auto attendants

, Scheduled

. Expand and collapse branches by clicking on the plus/minus

With the Active conference branch selected
This branch opens to show all the active (live) conferences. Expand a conference to display the MCU it is
running on: the number in brackets is the number of active participants. You can also expand the branch
further and the active and disconnected participants are then listed.
When you click on the Active conferences branch the List View is empty. If you click on an conference the
List View displays the MCU name with a colored background and lists the participants underneath. The
following information (columns) are displayed for each participant: Name, Address (if known), Type, Audio
(incoming), Outgoing audio, Video (outgoing), Important, Call state, Connect time, Disconnect time and
Disconnect reason. (Remember that you can reorder the columns if required by clicking on the column title.)
This provides the connection history for ad hoc participants: if an ad hoc participant connected,
disconnected and reconnected there is more than one entry for that participant in both views.



You can clear the entries for disconnected participants by right-clicking on the conference in the
Tree View and selecting Remove disconnected.

With the Scheduled conferences branch selected
This branch opens to show all the scheduled conferences in alphanumerical order and the List View is
empty. Expand a conference to display the MCU it is scheduled to run on: the number in brackets is the
number of configured participants. Expand the branch further to see the participants in the Tree View.
When you select the name of a conference configuration in the Tree View, the MCU that it is scheduled to
run on is displayed in the List View with a colored background. Each configured participant is also displayed
in the List View. There is only one entry per participant and the following information (columns) are
displayed: Name, Address, Type, Audio and Video.
With the Auto attendant branch selected
Expand this branch to see the MCUs on which a participant is connected to an auto attendant.
Cascaded conferences
A cascaded conference is listed once: under the conference name. The master MCU is listed first, then the
slave MCUs with participants being listed under the MCU that they are connected to or will be connected to
when the conference starts.
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Icon reference list
Conference Director uses a number of icons in the Tree View, List view and toolbar. This topic lists them all.
Icon

Usage

Conference Director application
Icon on your desktop for opening the application and in the system tray.
System icon in Tree View.
MCU icons
MCU icon.
MCU warning icon. Expand the branch for this MCU to see what the issue is.
Cascaded MCU icon. If you are using the grouped by conference view, then
under the conference name you see all the MCUs involved in the conference.
The master MCU has the normal MCU icon, the slave MCUs have this icon.
This icon turns orange if there is a problem with a cascaded conference on this
MCU.
Conference icons
Active conference branch in Tree View. This icon turns orange if a problem is
cascaded up the branch. Expand it to see the issue.
Scheduled conference branch in Tree View. This icon turns orange if a
problem is cascaded up the branch. Expand it to see the issue.
Conference Tree View icon. This icon turns orange if there is a problem with
the conference - or with a particular participant in the conference.
Completed conference Tree View icon.
Create conference toolbar icon.
Remove conference toolbar icon.
Cascaded conference icon, shown when one conference is configured as a
slave in another conference.
Participant icons
Connected participant icon.
Connect participants toolbar icon.
Disconnect participants toolbar icon.
Add participants toolbar icon.
Remove participants toolbar icon.
The participant is configured in a scheduled conference.
Cascade link icon appears in the Tree View when a cascaded conference is
active showing that the conference is an active link to a master MCU.
The participant has been disconnected from an active conference. The reason
is shown in the Disconnect reason column in the List View.
The participant has been disconnected from an active conference because of
an error. The reason is shown in the Disconnect reason column in the List
View.
Waiting for the participant to connect.
There is a problem with this participant. There are a number of reasons why
you may see this icon; for example, this may be an alert that one of audio or
video warning and critical packet loss levels set in the preferences have been
reached.
Cisco TelePresence Conference Director online help (printable format)
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Icon

Usage
As a toolbar icon: Make this participant important.
As a status symbol: This participant has been made important and therefore
has been given priority in the layout views - see Making a participant
important/have normal importance.
Make this participant of normal importance toolbar icon
As a toolbar icon: Unmute audio
As a status symbol: Indicates the active speaker
As a status symbol: This participant's audio is unmuted see Muting/unmuting
the audio or video for one or more participants. Other participants can hear
what this participant is saying.
As a toolbar icon: mute participant's audio
As a status symbol: If the icon is blue the participant's audio has been muted
i.e. the participant does not contribute audio to the conference - see
Muting/unmuting the audio or video for one or more participants. If the icon is
orange, there is an error on the participant's audio.
As a toolbar icon: unmute outgoing audio
As a status symbol: The participant is receiving audio from the MCU.
As a toolbar icon: mute outgoing audio (i.e. the participant will not hear other
participants)
As a status symbol: The Outgoing audio mute check box has been selected in
General page of the participant's properties dialog.
As a toolbar icon: Unmute video from participant
As a status symbol: This participant's video is unmuted see Muting/unmuting
the audio or video for one or more participants. This icon turns orange if there
is a problem with the participant's video stream.
As a toolbar icon: mute video from participant
As a status symbol: If the icon is blue the participant's video has been muted see Muting/unmuting the audio or video for one or more participants. If the icon
is orange, there is an error on the participant's video.

Auto attendant icons
Auto attendant branch in the Tree View. This icon turns orange if a problem is
cascaded up the branch. Expand it to see the issue.
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Preferences
Setting preferences
You can set preferences for a number of functions such as alert levels and conference configuration default
settings — and this is useful for values that you use all the time. Any settings you define will display as
defaults in the appropriate dialogs - including the Create conference template dialog, which takes time
saving a step further by allowing you to have a set of preferences for conference configuration.
Defining the preferences
1.

Go to Tools > Preferences.
The Preferences dialog is displayed with the General page open.

2.

Select the options you require on the General and Conferences pages. (See Preference dialog fields.)

3.

Click OK.

Preferences are stored in the \Documents and Settings\<name>\Application Data\Codian\Codian Director
folder in a file called preferences.xml. This stores the location of the current Address book and current
Conference template list.

Preferences dialog fields
This topic describes the fields in the Preferences dialog.

General preferences
Field

Description

Minimize application to
system tray

Select this check box if you do not want a button for the Conference Director
when you minimize it in the main part of the task bar - only a notification
area (system tray) icon. Alerts will be displayed as normal.

Show confirmation
before participant
drag/drop

Select this check box if you want a confirmation dialog to be displayed when
you drag and drop a participant from one conference to another (see
Dragging and dropping participants). This may prevent you accidentally
moving a participant to the wrong conference.

Specify default
messaging parameters

Select this check box and then:
•
•

the default position of the message on participants' endpoints, top,
middle or bottom of their screen. See Sending a message during a
conference
the length of time a message is displayed on participants' endpoints.
If you do not select the check box, the default is 30 seconds. See
Sending a message during a conference

Alerts options
Packet loss alerts

When selected, if either audio or video packet loss is experienced between
an MCU and a participant, this is reported. There are two levels of alerts: a
warning and a critical alert. If a warning is received from the MCU the
participant for which packet loss has occurred is displayed with the warning
. If a critical alert is received, then in addition to the participant
icon
warning icon:
•
•

Alert when conferences

a message is displayed above the system tray icon
the critical warning is cascaded up the tree in the Tree View. In this
way, if you have collapsed the view for an MCU, you will still see the

and be able to expand the view again to see
critical warning
which conference and participant the critical warning applies to
To be alerted when conferences are approaching their end time, select the
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Preferences

Field

Description

are about to expire

check box and set the time beforehand that you want to be alerted. When
this time is reached, a dialog is displayed which you should acknowledge. In
addition, so that you are reminded even after the dialog is closed, the
conference, active conference and MCU icons change in the Tree View to
their alert equivalents until the conference completes.

Play audio indication on
alerts

If selected, an audio alert will sound when an alert occurs to prompt you to
investigate the issue. A default sound is provided but you can select a
different audio sound if you prefer.

Conference preferences
Field

Description

Set default conference
start time to next hour

If selected, each new conference will be configured to start on the next hour by
default. If do not tick this check box, the default configured will be to start
immediately.

Default conference
duration

You can specify the default length that new conferences will last for.

Automatically delete
expired conferences

If selected, the conference configuration will be deleted after the conference
has occurred for the last time. If this check box is not selected, the conference
configuration will remain on the MCU and will be displayed in the Tree View.
This may be useful; for example if the conference has a configuration that you
want to copy, or you may want to "resurrect" the conference by updating its
schedule.

Advanced conference options
Register with gatekeeper

If selected, the MCU will try to register new conferences with the gatekeeper
by default. The gatekeeper is set up on the MCU using the web interface.

Enable unicast streaming

If selected, unicast streaming will be allowed by default in new conferences.
Streaming needs to be enabled MCU-wide using the web interface. See
Streaming (of the main video channel).

Enable multicast
streaming

If selected, multicast streaming will be allowed by default in new conferences.
Streaming needs to be enabled MCU-wide using the web interface. See
Streaming (of the main video channel).

Enable H.239

If selected, new conference will have the content (H.239) channel enabled by
default.

Specify maximum
participants

If selected, the fields to enter the maximum number of video and the maximum
number of audio (voice) participants will be enabled in new conferences. What
the maximum number of participants means depends on whether the MCU has
port reservation enabled or not.
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MCUs
The MCU list
The MCU list is optional and can be used to store the information that you need to connect to the MCUs
that you work with frequently. By opening the MCU list, Conference Director attempts to connect to all the
MCUs in the list. This saves time and means that you do not need to remember the IP address, username
and password for each MCU unit or blade.
You can keep a number of MCU lists, and they can be stored locally, or on a server so that they can be
shared.



Each MCU that you connect to must be running software version 2.0(1) or later and needs to
have the Conference Director feature key installed. If you try to connect to one that does not
have the feature key, you will see an error message that the Conference Director is not
enabled on this MCU.

Opening the MCU List
Go to File > Open MCU list.

1.

If you are opening the MCU list for the first time a standard Windows File Open dialog is displayed. Go
on to step 3.
If you have connected to other MCUs or disconnected from one or more MCUs in this session, you see
the message "Save current MCU list?" If you want to add to, or remove MCUs from, the currently open
MCU list, click Yes. Otherwise click No.

2.

A standard Windows File Open dialog is displayed.
3.

Navigate to find the MCU list file to open. (It has a .cdn extension.)

4.

Click OK.



When you save the MCU list, it will include all the MCUs that you have connected to or tried to
connect to - even if a connection could not be established.
Equally when you open an MCU list:
•
•

Any MCU that you were connected to, but that is not on the MCU list that you open, is
disconnected
However, any active conferences on those disconnected MCUs continue

Saving the MCU List
At any time, you can save the list of MCUs displayed in the Tree View. Go to File > Save MCU list or File >
Save MCU list as.
The MCU list that is opened on startup
Because you can have more than one MCU list, each containing details for several MCUs, when it starts,
Conference Director automatically opens the MCU list that was in use when the application was closed.
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Connecting to an MCU
If the MCU you want to connect to is in the MCU list, then you can connect to it by opening the MCU list.
However, to connect to an MCU that is not in the list, or to connect and add it to the list, follow these
instructions.



Each MCU that you connect to must be running software version 2.0(1) or later and needs to
have the Conference Director feature key installed. If you try to connect to one that does not
have the feature key, you will see an error message that Conference Director is not enabled on
this MCU.

To connect to an MCU
1.

Either right-click on System
select the

2.

in the Tree View and select Connect MCU, go to MCU > Connect or

icon from the toolbar.

If you have connected to this MCU before, select its Hostname or IP address from the drop-down list;
otherwise type in the Hostname or IP address.
The drop-down list includes all the MCUs you have connected to in the past.

3.

Type in the username and password you use to connect to this MCU. (These are the same username
and password you use to connect via the web interface with admin level privileges. See Access, user
accounts and privilege levels for information about the MCU's default users and levels of access.)

4.

Click OK.

Retrying a connection
If the connection is successful, then the conferences and auto attendants configured on that MCU are
displayed.
If the connection could not be established, a message is displayed and you only see a top level entry for the
MCU when you are using the grouped by MCU view. Conference Director will retry the connection three
times and will display messages to keep you informed. (If you do not want this to happen, remove the MCU
entry from the Tree View.) Thereafter it will not retry the connection unless you manually try to
To retry the connection at any time
1.

If necessary go to View > Grouped by > MCU.

2.

Right-click on the MCU entry in the Tree View and click Connect.
The address, username and password are remembered and displayed.

3.

Click OK.

Reasons for failure to connect
There are a number of reasons why Conference Director may not be able to connect to an MCU. These
include:
Message

Reason

Software upgrade required on MCU

The MCU's software version is not compatible with the
Conference Director.

Conference Director not enabled on MCU

The Conference Director feature key is not enabled on
this MCU.

Conference Director upgrade required for
MCU

You need to upgrade the version of Conference Director
that you are running.

Authorization failed on MCU

Either the username or password that you entered in is
incorrect for this MCU.
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MCU is unreachable

Conference Director cannot establish a link with this
MCU.

MCU not available

Conference Director could not find this address.

MCU insufficient privileges

You are trying to log in with a username and password
that does not have admin privileges and this is not
allowed.

Access, user accounts and privilege levels
An MCU is pre-configured with two user accounts ("admin" and "guest"). Using the web interface the admin
user can display the list of all user accounts, modify these user accounts and add other users. (The web
interface online help includes a number of topics that cover managing users.) However, you cannot modify
any user accounts using the current version of Conference Director.
Every configured user has an associated privilege level. There are seven defined privilege levels which
determine the amount of control the user has over the MCU and its settings. However, to use Conference
Director you must log in to an MCU with a user account that has admin privilege level such as the admin
user.

Disconnecting an MCU and removing it from the Tree View
You can disconnect from an MCU at any time whether you connected to it using an MCU list or manually.
Disconnecting also removes the MCU entry from Tree View (with all its conferences, participants and auto
attendants).
If the MCU is in the current MCU list, disconnecting from it does not remove it from the list - unless you go
to File > Save MCU list after you disconnect.
You can reconnect to the MCU by going to MCU > Connect and then selecting the MCU from the dropdown list.
To disconnect an MCU and remove it from the Tree View
1.

Either right-click on the MCU entry and select Disconnect and remove MCU, or from the MCU menu
select Disconnect and remove.

2.

Click Yes.



You can also remove an MCU entry from the Tree View when the connection has failed to
establish or if a connection was made but in this case the context menu option is simply
Remove.

Displaying MCU properties
You can display the MCU properties either from the Tree View or from the MCU menu. (You cannot edit an
MCU's properties using Conference Director but you can edit the time zone adjustment that Conference
Director applies. See MCU properties fields.)
Displaying the properties of an MCU
1.

Right-click on the MCU and select Properties.
The Properties dialog is displayed with the General page open. See MCU properties fields.

2.

If required open the Network status, Ethernet status and Health status pages to display the information
you need to find.

3.

When you have finished, click OK.
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MCU properties fields
This topic describes the fields in each page of the MCU properties dialog.

General page
Field

Description

System status
Model

Specific MCU model from the MCU series e.g. MCU 4215.

Serial number

Unique serial number of the MCU.

Software version

Installed software version.

Build version

Build version of the installed software.

Up time

The hours, minutes and seconds since the MCU was last restarted.

CPU load

The load on the CPU as a percentage.

Media processing
load

An overview of the current media loading of the MCU. If the total load is
consistently high, you might need to add an additional MCU to better handle your
video conferencing needs. Also, the total load may increase during periods of
peak conference use. A low video load with high audio load implies that most of
the conference participants have connected with audio-only endpoints.

Port reservation

Whether port reservation mode is enabled or disabled. See Port reservation.

System time
Current time

The time now. This may be the time according to the MCU's clock or adjusted by
the Time zone offset value (see below).

Time zone offset

The time zone difference between where you are using the Conference Director
and the time zone that the MCU is in (see the note below). Select the offset from
the drop down list.
This version of Conference Director can "translate" times on the MCU in to local
times so that you always see conference start and end times etc in your local
time. This makes sense if a number of users are monitoring a number of MCUs in
different time zones. The Conference Director simply adds the offset that you
enter here to any times sent by the MCU before displaying them - and subtracts it
before sending time information to the MCU.
Note: You need to adjust the offset manually when the clocks go forward or
backwards for Daylight saving.



You can see the local time on the MCU in the bottom right hand corner of the Conference
Director window, when you select any part of the MCU branch in the Tree View.

Network status page
This page opens showing details for Port A: if you have Port B enabled you can select it from the drop down
list.
Field

Description

Port status

Whether the port is enabled or disabled. When enabled, the port will allow IP
traffic to flow; when disabled, IP traffic will not pass into or out of the MCU on
this port. Port A will never be disabled because it is the primary interface of the
MCU.

MAC address

The fixed hardware MAC (Media Access Control) address of this port.

Host name

The host name assigned to the MCU.
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Field

Description

IP address

The port's IP address in the dot-separated IPv4 address, for example
192.168.4.45.

Subnet mask

The subnet mask required for the IP address, for example 255.255.255.0.

Default gateway

The IP address of the default gateway on this subnet, for example 192.168.4.1.

Name server

Identifies the IP address of the name server.

Secondary name
server

Identifies an optional second name server.

Domain name

Specifies an optional suffix to add when performing DNS lookups.
This can allow you to use non-fully qualified host names when referring to a
device by host name instead of IP address. For example, if the domain name is
set to cisco.com, then a request to the name server to look up the IP address of
host endpoint will actually lookup endpoint.cisco.com.

Speed

Identifies the connection speed: 10, 100 or 1000 Mbit/s. The connection speed
must match that of the device to which this port is connected.

Full duplex

Identifies the connection duplex mode: Enabled (Full duplex: both devices can
send data to each other at the same time ) or Disabled (Half duplex: only one
device can send to the other at a time). The duplex setting must match that of
the device to which this port is connected.

Ethernet status page
This page opens showing details for Port A: if you have Port B enabled you can select it from the drop down
list.
Field

Description

Link status

Whether this Ethernet port is connected to or disconnected from the network.

Packets sent

The total number of packets sent from this port by the MCU. This includes all
TCP and UDP traffic. When troubleshooting connectivity issues, this information
can help you confirm that the blade is transmitting packets into the network.

Packets received

The total number of packets received by this port of the MCU. This includes all
TCP and UDP traffic. When troubleshooting connectivity issues, this information
can help you confirm that the blade is receiving packets from the network.

Multicast packets
sent

Use these fields for advanced network diagnostics, such as resolution of
problems with Ethernet link speed and duplex negotiation.

Multicast packets
received
Total bytes sent
Total bytes received
Receive queue drops
Collisions
Transmit errors
Receive errors

Health status page
Field

Description

System component
Fan status

One of: OK - component is functioning properly, Out of spec - Check with your
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Field

Description

Voltages status

support provider; component might require service, Critical - requires immediate
attention, or Unknown if the status cannot be ascertained.
If the Worst Seen column displays "Out of spec", but Current Status is "OK",
monitor the status regularly to verify that it was only a temporary condition.

RTC battery status
Temperature status

One of: OK - MCU's temperature is within the appropriate range , Out of spec Check the ambient temperature (should be less than 34 degrees Celsius) and
verify that the air vents are not blocked, or Critical - temperature of MCU is too
high. An error also appears in the event log indicating that the system will
shutdown in 60 seconds if the condition persists.
If the Worst Seen column displays "Out of spec", but Current Status is "OK",
monitor the status regularly to verify that it was only a temporary condition.

System log
Restart time &
reason

A log of all the system restarts and the reason why they occurred.
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Conferences
About conferences
The Tree View shows both active
and scheduled
conference branches and includes conferences
that were set up using an MCU's web interface or Conference Director whether they were based on a
conference template or not. Conferences in both branches have the
cascaded conferences while they are active.

icon and the

displays for

Active vs scheduled conferences
Active conferences are currently in progress. These may be scheduled or ad hoc conferences. (Ad hoc
conferences are those created using an auto attendant and therefore you cannot create an ad hoc
conference with Conference Director - but you can monitor them in the Active conferences branch.)
Scheduled conferences are those that are set up using the Conference Director or the web interface.
•

A scheduled conference does not necessarily occur more than once - the default setting is No repeat

•

A scheduled conference that is going on now will have two entries in the Tree View: one each under
the Active conferences and Scheduled conferences branches

•

A completed conference (one that will not repeat again) can still be a scheduled conference. Whether
the entry remains in the Tree View depends on the setting in the Automatically delete completed
conferences check box on the Conferences page of the Preferences dialog



When adding and removing participants from conferences, you need to be aware that there is a
difference between active conferences and scheduled but inactive conferences. See Adding a
participant to a conference and Removing a participant from a conference.

What you see in the List View
If you select a conference in the Tree View, its details are displayed in the List View. The information that is
displayed depends on whether it is a scheduled or an active conference:
•

Scheduled conferences: the Name, Status, Start time and End time (or Permanent) of the conference
and each participant is listed below the conference entry

•

Active conferences: each participant is listed and for each one the following details are provided:
Name, Address, Type, (incoming) Audio, Outgoing audio, (incoming) Video, Important, Call State,
Connect time, Disconnect time and Disconnect reason. See Understanding participant status for an
explanation of the icons

Cascaded conferences
A cascaded conference is a single conference occurring over more than one MCU. These MCUs may be
located at different locations. The cascade occurs between a single master MCU and one or more slave
MCUs. Endpoints can be connected to either the master or to one of the slave MCUs. Each slave
communicates with the master over a H.323 connection. These connections use up a port on each slave
MCU and one port per slave on the master MCU.



There is an automatic delay of one minute between the conference starting on the master MCU
and the slave MCUs calling to the master.

Cascaded conferences are listed in the Tree View in different ways depending on the grouping chosen:
•

If you are using grouped by MCU, then the conference is listed under each MCU that it occurs on. To
see the master MCU change to the Group by conference view
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•

If you are using grouped by conference, then under the conference name you see all the MCUs
involved in the conference. The master MCU has the normal MCU icon

, the slave MCUs have the

two crossing arrows

Layout views and video streams
During a cascaded conference the video from the active speaker on a slave MCU is sent to the master
MCU. On the master MCU, the video from all slave MCUs and the directly attached endpoints are mixed
according to the conference layout. This view is then sent back to each slave MCU, which then forwards
this to its endpoints. Each of these endpoints receives a separately encoded copy of the stream based on
their capabilities

Conference templates
Creating and selecting the conference template list
A Conference template takes the idea of conference preferences a step further. The conference
preferences determine the default settings that are displayed for a number of conference configuration
fields when you create a conference or a conference template. However, you may wish to have a number of
default sets, particularly if you can group conferences; for example those that happen weekly or those that
you always want to start with the same layout. Conference templates let you do this.
Conference templates are stored in a conference templates list. You must chose the folder that the
Conference template list is stored in. This can be locally or on a server. You can also share the Conference
template list with other users of Conference Director.
You can have more than one Conference template list and then select the one to use at any time. The
Conference template list that is selected when you close Conference Director will also be the one
automatically selected when the application reopens. Conference template lists have a filename extension
of .cconf.

Leaving the Conference template list open
The Conference template list can be left open (displayed) while you work with other dialogs. This can be
useful because dragging and dropping Conference templates is one way to create conferences, for
example. See Creating a conference.

Creating/Selecting a Conference template list
Creating a Conference template list also selects it as the current Conference template list but you can
change this at any time.
To select a Conference template list:
1.

Go to Tools > Conference templates > Select template list.

2.

Either type in a file name, or use Browse.
Select a folder for the Conference template list. If you want to use the same folder that has the
preferences file, this is \Documents and Settings\<name>\Application Data\Codian\Codian Director.

3.

Click OK.
If the file does not exist, Conference Director asks you if you want to create it, both creating a new
Conference template list and selecting it.

Creating and working with conference templates
You can create a number of templates for your conferences; then, when you create a conference, you can
choose whether to use one of the templates as the basis for the conferences configuration or to enter each
field manually. See Creating a conference.



The Conference template is added to the currently selected Conference template list. As there
can be more than one Conference template list, make sure it is the one you want to work with.
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Leaving the Conference template list open
The Conference template list can be left open (displayed) while you work with other dialogs. This can be
useful because dragging and dropping Conference templates is one way to create conferences, for
example. See Creating a conference.

Adding a Conference template
1.

Go to Tools > Conference templates > Open template list.
The Conference templates dialog opens with a list of the templates currently in the select Conference
template list.

2.

Click Add.
The Create conference template dialog opens with the General page open. The settings in individual
fields reflect what you set in the Preferences dialog.

3.

Type in the name for the new template.

4.

Complete the dialog pages as appropriate. See conference configuration fields.

5.

Click OK.

6.

Click Close.



You can also create a template from an existing conference: right-click on the conference name
in the Tree View and select Add to templates. Then enter the details as prompted. Note that
configured participants are added to the template but ad hoc participants are not.

Editing a Conference template
1.

Go to Tools > Conference templates > Open template list.
The Conference templates dialog opens with a list of the templates currently in the select Conference
template list.

2.

Select the template to edit and click Edit.
The Edit conference template dialog opens with the General page open.

3.

Modify the dialog pages as appropriate. See conference configuration fields.

4.

Click OK.

5.

Click Close.

Duplicating a Conference template
1.

Go to Tools > Conference templates > Open template list.
The Conference templates dialog opens with a list of the templates currently in the select Conference
template list.

2.

Select the template to copy and click Duplicate.
The Conference template dialog opens with the General page open and a default name of Copy of
<name>. The settings in individual fields are those from the template that you are copying.

3.

Name the new template.

4.

Open the different dialog pages modifying the settings as appropriate. See conference configuration
fields.

5.

Click OK.

6.

Click Close.
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Removing a conference template
1. Go to Tools > Conference templates > Open template list.
The Create templates dialog opens with a list of the templates currently in the select Conference
template list.
2. Select the template to remove and click Remove.
3. Click Yes to confirm.
4. Click Close.

Creating a conference template from a configured conference
You can create a conference template from either a scheduled or active conference by right-clicking on the
conference and selecting Add to templates.

Creating a conference
You can create a conference either by right-clicking on an MCU in the Tree View, from the Conference
when it is active. You can start "from scratch" or
menu or by using the Create conference toolbar icon
you can use a conference template. You can also drag a conference template anywhere within the MCU's
entries in the List View (either active or scheduled branch) and then edit the configuration to create a new
conference. Both options are described in this topic.



If you require more than one MCU for your conference, see Creating a cascaded conference.
.1.1

Creating a conference using menu options
1.

Click on the MCU that you want to create a conference on and go to Conference > Create or
Conference > Create from template. (You can also right-click on the Active conferences or
Scheduled conference headings and click Create conference or Create from template.)

2.

If you selected Create from template the Create from conference template dialog opens. Select the
template to use and click OK.
The Create conference dialog is displayed with the General page open and with fields reflecting either
the conference preferences or, if you used a template, the template you used.

3.

Type in a Name for the new conference.

4.

Complete the General, Repeat, Layout, Participants and Advanced pages as required. (See
Conference configuration fields.)

5.

•

To choose a custom layout that participants will see when they join a conference, go to the Layout
page

•

The Layout page also lets you use pane placement i.e. decide which participant will appear on in
which pane

Click OK.

Creating a conference by dragging and dropping
1.

Select an entry from the Conference templates list and drag it in to the List View - anywhere within the
entries for the MCU that you want to create the conference on.
The Create conference dialog is displayed with the General page open and with fields reflecting the
template you used.

2.

Type in a Name for the new conference.

3.

Complete the General, Repeat, Layout, Participants and Advanced pages as required. (See
Conference configuration fields.)
•

To choose a custom layout that participants will see when they join a conference, go to the Layout
page

•

The Layout page also lets you use pane placement i.e. decide which participant will appear on in
which pane
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4.

Click OK.



For both methods, it does not matter whether you click on the MCU, Active conferences or
Scheduled conferences headings, when you create a new conference — this is a scheduled
conference. If you select a start time of "now", then you also create an active conference.

Creating a cascading conference
You can create a cascaded conference (one that requires one MCU to call one or more additional MCUs in
to the conference) either by right-clicking on an MCU in the Tree View, from the Conference menu or by
when it is active. You can start "from scratch" or you can use
using the Create conference toolbar icon
a conference template. You can also drag a conference template anywhere within the MCU's entries in the
List View (either active or scheduled branch) and then edit the configuration to create a new cascaded
conference. Both options are described in this topic.
Finally you can drag one conference on to another to create a cascade. The conference that you dragged
and dropped is the slave conference; the one you dragged it on to is the master conference. The slave
conference is configured to dial the master conference. If the master conference is an active conference, a
confirmation dialog is displayed before the cascade is created.

Scheduling a cascaded conference
To create a cascaded conference using Conference Director, follow these instructions.
1.

Select which MCU will be the master MCU.

2.

If necessary go to View > Group by MCU.

3.

Do one of the following:
a.

To create the cascaded conference "from scratch", right-click on the master MCU in the Tree View
and select Create conference. (Alternatively, select the master MCU and then go to Conference
> Create conference or click the Create conference toolbar icon.)

b.

To create the cascaded conference from a template, drag the template from the Conference
templates window onto the master MCU in the Tree View
The Create conference dialog opens. Note that if the template had an MCU address completed,
then this MCU address is overwritten by that of the MCU that you dropped the template on to. If
this is also the address of one of the slave MCUs in the conference template, you will see an error
message when you click OK.

4.

In the Participants page enter/update the details of any endpoints that will be called by the master MCU
in the normal way. See Conference configuration fields.

5.

Enter/update the details of the conference: be sure to set a numeric ID for the conference on the
master MCU in the General page because this is required to allow the slave MCUs to connect to the
master MCU.





The start time for a cascading conference is set appropriately on all MCUs involved
in the conference so long as you have set the time zone offsets; it does not matter
if Conference Director, the master MCU and any slaves MCUs are in the same or
different time zones. The time you set is your local time and is the adjusted for the
time zone offset of the master MCU; the start time on each slave MCU is set to
take into account the difference in time zone between the master MCU and that
slave MCU.

6.

To select the view seen by the endpoints on the slave MCUs, open the Layout page, select Enable
conference custom layout and Make new participants see this view (see Layout page fields). Then
select click Set layout and select the view. Click OK.

7.

Open the Cascading page.

8.

To add a new slave MCU, click Add.
The Add cascaded conference dialog opens with the General page open. This dialog has the same
pages as the Create conference dialog with the exception of the Repeat page.
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9.

Enter the name of the conference as you want it to appear on the slave MCU and enter the MCU's IP
address.

10.

In the General page you can enter a Numeric ID if required, but we recommend that you do not use the
Numeric ID entered for the conference on the master MCU.

11.

In the Participants page add details of the participants that will be connected to this slave MCU.

12.

Add any other information required on the other pages.

13.

Click OK.
The name of the MCU is displayed in the Cascading page.

14.

Repeat from step 7 until all the slave MCUs have been configured.

15.

To amend any details of conferences on slave MCUs, repeat from step 7 but highlight an MCU and
click Edit in step 8.

16.

If a template is required based on this cascading conference, select Add to conference templates.

17.

Enter any remaining details for conference on master MCU not entered previously.

18.

Click OK.

19.

If you entered the IP address of an MCU that you are not already connected to The Connect to MCU
dialog is displayed. Enter the username and password of a user with admin rights on that MCU and
click OK.

icon on the slave MCUs shows that it is a cascaded
The conference is created. When it is active, the
conference. If you have problems, see Possible issues below.

Possible issues
When configuring a cascade you will see an error message or experience problems in a number of
circumstances, including:
•

If you drag a template on to an MCU that is set in the template as a slave MCU, you will see an
error message saying that the MCU is duplicated

•

If you use the same Numeric ID for the conference on the master and slave MCUs, you may see
an error message. The slave MCUs do not require a Numeric ID for the conference, although one
can be set

Editing a cascading conference
When a cascaded conference has been configured, you can display and edit the conference configuration
by right-clicking on the conference and selecting Configuration:
•

If you right-click on the master conference and display its configuration, you see the same dialog
as when you created the conference. For example, you can open the Cascade page and add
another slave MCU to the configuration. You can also display any of the cascaded conferences and
edit their properties also

•

If you display the properties of a conference on a slave MCU, you see only the dialog that applies
to the cascaded conference and you can edit the configuration of that conference. That is, there are
no Repeat or Cascading pages because these are part of the master conference configuration.
However, you can click the Master configuration button to open the master conference
configuration and then edit that configuration. Equally you can access the configuration any of the
cascaded conferences from there

For help when editing the conference configuration, see Conference properties fields.

Duplicating a conference
Use the Duplicate conference option to create new conferences quickly when the new conference
configuration will be similar to an existing one in one or more aspects - for example it has the same
schedule or a number of participants in common.
The dialog has the same pages and fields as the Create conference dialog but all the settings of the
conference that you are duplicating (except its name) are displayed for you to edit as appropriate.
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You can copy both active conferences and scheduled conferences. Choose which one to copy with care
because the properties of the active conference may not be identical to the scheduled conference of the
same name; for example all the configured participants currently in an active conference would be added to
the new conference - even if they are not configured in the scheduled conference of the same name.
New conferences can be set to start immediately if required but obviously, if you copy the participants they
cannot be called in to two conferences at the same time.
Duplicating a conference
1. Right-click on the conference that you want to copy and click Duplicate.
The Duplicate conference dialog is displayed.
2. Type in a name for the new conference.
3. Edit the other fields in the General, Repeat, Participants, Layout, Cascading and Advanced pages
as required. (See Conference configuration fields.)
4. Click OK.

Dragging and dropping conferences
You can now use drag and drop to move a conference from one MCU to another, but there are some
consequences:
•

Active conferences: this involves disconnecting all participants and redialing them from the new
MCU, and is therefore not seamless

•

Scheduled conferences: the conference is scheduled on second MCU and removed from the
original one




If you drag a scheduled conference that is currently active to another MCU, only the
scheduled participants are moved; ad hoc participants are disconnected.

You cannot create a cascaded conference by dragging and dropping.

Displaying and editing the conference configuration
You can display and edit the configuration of a conference. The dialog is the same as that opened when
you create a conference but the title shows the conference that you are working with.
Displaying a conference's properties
1. Right-click on the conference and select Configuration.
The Configuration dialog is displayed with the General page open.
2. Open the other pages to see different properties.
3. You can now:
• Edit many of the fields in the General, Repeat, Layout and Advanced pages
• Open the Participants page and:
o Add new participants. Click Add and see Participant properties fields
o Edit the properties of existing participants. Select the participant and then click
Edit. See Participant properties fields
o Remove a participant from the conference. Select the participant and then click
Remove. Click Yes to confirm
4. When you have finished, click OK.



Any participant added by opening the conference configuration is a scheduled participant who
is added to the conference configuration. This means that if the conference is scheduled to
repeat, the new participant will be called in to that conference (unless you set Use manual
connect for that participant).
To add a participant to an active conference for just the current conference session, see Adding
a participant to a conference.
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Conference configuration fields
The fields displayed in the Conference template, Create conference, Duplicate conference and Conference
configuration dialogs are the same. This topic describes those fields.
General page
Field

Description

Explanation

Name

The name of the conference.
Conference names must be
unique on each MCU.

(This is the name users will see on auto
attendants, in this interface and also on the
MCU's web interface.

Description

You can add the description
when creating or cloning a
conference.

Use the description to provide more detailed
information about the conference than the
name alone conveys.

MCU address

The MCU's IP address.

Numeric ID

The unique identifier used for
dialing the conference using
an auto attendant or through
a gatekeeper.

When connected to an auto attendant, users
can join a conference by typing its numeric
identifier. This field is required if you plan to
allow audio-only participants.
If gatekeeper registration is enabled for a
conference (see below), the MCU attempts to
register the conference with an E.164
telephone number, which is comprised of the
Registration Prefix and the ID.
The ID must be unique; conferences on the
same MCU cannot share this number.
Additionally, because the ID is used in
gatekeeper registration, conferences and
auto attendants cannot share a ID value.

PIN

The conference PIN, if
required. A PIN provides a
level of security to
conference access.

If a conference has a PIN, the PIN number
must be entered before a participant can
successfully call in and connect to the
conference.

Guest ID

There are two types of
conference participant on an
MCU: chairperson and
guest. Chairperson
participants use the Numeric
ID and optionally, the PIN
fields.

A conference will not begin until the first
chairperson joins. This means that guests will
see a black screen/hear silence with on
screen text 'Waiting for conference
chairperson' and an audio prompt after five
seconds and then every minute thereafter.
Streaming viewers will see a black
screen/hear silence although mark-up and
text chat will work.

Guest PIN

Note: Participants dragged and dropped into
a conference on the web interface will be
chairperson participants. Using the web
interface you can control the behavior when
the last chairperson leaves the conference.
Start time and duration
Start time

The start time for the
conference in the format
HH:MM.

If the conference preferences set the default
conference start time to the next hour, a time
is entered for you.
Conference Director can make adjustments
for time zones. If you have set the Time zone
offset in the MCU properties dialog, then the
Start time for a conference entered here is
your local time and is adjusted to local time
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Field

Description

Explanation
on the MCU that the conference is running
on. For example, if you are an hour ahead of
the MCU's local time and want a conference
to start at 2pm your time, enter 14:00. This
will be 13:00 on the MCU if the Time zone
offset was set correctly as -1:00.
If you are setting the start time for a
cascading conference Conference Director
will adjust the time on all MCUs involved in
the conference so long as you have set the
time zone offsets; it does not matter if
Conference Director, the master MCU and
any salves MCUs are in the same or different
time zones. The time you set here is your
local time and is the adjusted for the time
zone offset of the master MCU; the start time
on each slave MCU is set to take into account
the difference in time zone between the
master MCU and that slave MCU.

Start date

The start date for the
conference.

This is today by default.

Permanent

If selected, the conference
will not end. You can only set
a Start time and Start date.

If a conference is permanent, then you
should set Repeat page to a Frequency of No
repeat and a Termination of Never. If you try
to use any other settings, Conference
Director will reset them for you.

Scheduled

If selected, you can specify
the Start Date, Start time and
the Duration for the
conference.

The default settings depend on your
conference preferences. A conference can be
scheduled to be up to 24 hours long: the
Start, End and Duration fields are connected
so that changing one of the fields
automatically updates the others, as
appropriate.
Click Set to current time to set the Date and
Start time to now. This does not change the
Duration, which is one hour by default, unless
you changed the setting in the conference
preferences.
You can also set the Repeat fields if you want
the conference to repeat.

Duration

The duration of the
conference

This field is disabled for Permanent
conferences.

Repeat page
Field

Description

Interval

A conference can be scheduled to run once (No repeat), Daily, Every week
or Monthly on a particular day of a particular week.

Termination

The conference can be permanent (ending Never), or it can occur a
specified number of times, or finish by a fixed date.

Cisco TelePresence Conference Director online help (printable format)

Page 28 of 61

Permanent conferences
Permanent conferences should have a Frequency of No repeat and a Termination of Never.

Layout page
This page shows you the currently selected layout in the preview pane. Using this page you can select
custom layouts to use for conference participants instead of one of the default family views.
Field

Description

Set layout

Click Set layout to display the Set layout dialog in which you can select a
standard or widescreen layout. The current layout is shown with a blue
border.

Enable conference
custom layout

Selecting this check box means that this custom layout will be the default
when the conference starts.

Make new participants
see this view

Selecting this check box means that all participants will see the selected
view when they join the conference, even if it is already in progress. Note
that you can make all connected participants in an active see the conference
layout at any time by right-clicking on the conference in the active branch
and selecting Apply conference layout.

Enable pane placement

Selecting this check box allows you to decide which participant is displayed
in which pane and then to make selections in as many of the drop-down lists
as appropriate. For more details see Pane placement.

You can also set the layout for one or more active participants using the Layout page of the Participant
properties dialog.

Participants page
This page lists the scheduled participants for this conference. These participants will be called in to the
conference automatically when the conference starts.
• Click Address book to add new participants from the address book to the conference. The Add
from Address book dialog opens. Select the participants you want and click OK.
• Click Add to open the Add new participant dialog and be able to select additional participants for
this conference. See Adding a participant to a conference
• Select a participant and click Edit to edit the configuration of this participant. If the participant has
an entry in the Address book, this does not change their entry in the Address book— only their
settings for the conference
• Select a participant and click Remove. If the participant has an entry in the Address book, this does
not remove the participant from the Address book

Cascading page
This page is only available for scheduled conferences and is only used if you are setting up a cascaded
conference. It allows you to add slave MCUs in to the cascade. See Cascaded conferences and Creating a
cascading conference.
The list shows the name and IP address of any MCUs that will be cascaded in to the conference. Click:
• Add to define a slave MCU. This opens the Add cascaded conference dialog which contains
General, Layout, Participants and Advanced pages. These pages contain the same fields as those
in the equivalent pages for the master MCU. See the descriptions above and below in this topic
• Edit to change any settings for a slave MCU such as adding additional participants on this MCU
and changing the layout these participants will see when the conference starts
• Remove to remove an MCU from the cascade
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Advanced page
Field

Description

Explanation

Advanced conference options
Register with gatekeeper

If selected, the MCU will
attempt to register the ID
entered above (this
conference) with the
configured gatekeeper.

The gatekeeper is defined in the web
interface. Go to Settings > Gatekeeper.

Enable unicast
streaming

If selected unicast streaming
is allowed for this
conference. See Streaming
(of the main video channel).

The default depends on your conference
preferences.

Enable multicast
streaming

If selected multicast
streaming is allowed for this
conference. See Streaming
(of the main video channel).

The default depends on your conference
preferences.

Enable H.239

If selected a content (H.239)
channel can be transmitted
during this conference. See
the content (H.239) channel.

The default depends on your conference
preferences.

Specify maximum video
participants

If selected you can specify
the maximum number of
video participants that are
allowed during this
conference.

The default depends on your conference
preferences. The effect of selecting this field
and specifying the participant maximum
depends on whether the MCU has port
reservation enabled.

Specify maximum audio
participants

If selected you can specify
the maximum number of
voice (audio-only)
participants that are allowed
during this conference.

The default depends on your conference
preferences. The effect of selecting this field
and specifying the participant maximum
depends on whether the MCU has port
reservation enabled.

Pane placement
Normally the MCU decides which participant will appear in which pane of any layout that is in use and this
may change dynamically as a conference progresses (see Understanding layout views). To have more
control over which participant appears in which pane, you can use the Pane placement function in the
Layout page of a conference configuration. Pane placement works on a per conference basis.
Pane placement works on the selected custom layout in the Layout page which has the panes numbered.
The largest (and therefore most important) panes have the lowest numbers. Because the largest number of
panes in any custom layout is 20, there are twenty drop down lists, one per pane.
If you have not set pane placement for a conference all the panes are set to <default>. For each pane, you
can select an alternative setting:
•
•
•
•
•

<blank>: no participant appears in this pane
<default>: the MCU chooses the participant for each pane; for example, the participant that is set to
Important appears in pane 1
<loudest speaker>: the participant who is speaking the loudest at any time appears in this pane
<H.329 content>: this pane is reserved for the content channel (see the content (H.239) channel). If
the content channel is not used in this conference, this pane will be blank
<name>: for active conferences only: the name of each participant in this conference, whether
configured or ad hoc. If you select a specific participant (endpoint), that participant appears in this
pane at all times

To use pane placement:
1. Right-click on a conference and select Configuration.
2. Display the Layout page.
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3. Click Set layout and choose a layout to use. Click OK to return to the Layout page.
The Enable conference custom layout check box is selected automatically.
4. Select Enable pane placement.
5. For each pane that you want to control, select an entry from the drop down list.
6. For panes that you no longer want to control individually, select <default>.
7. Click OK.
When you use pane placement, bear in mind that:
•
•
•

•
•
•
•
•
•

•

Pane placement only applies to conference custom layouts. If they are disabled, so is pane
placement
You can mix panes set to <default> with panes that have other settings
Any panes that you configure keep their setting even if you change the custom layout view.
Therefore if you configure all the panes in the 20 pane layout and then move to one with only five
panes, panes 1 to 5 will have the same settings as before. Panes 6 to 20 will also keep their
settings, it is just that they are not used. Therefore if you subsequently move to a layout with say 10
panes, all ten panes have their settings pre-configured
This does mean that if you have participants who need to be seen at all times, you should configure
them in the lower numbered panes
You must set up pane placement for each conference that you want to use it with
You can set up pane placement before a conference starts and configure important and the loudest
participants and the data channel to particular panes. However, you can only configure participant
by name when they are active participants in an active conference
Pane placement persists over conference repetitions. If you set pane placement once, the same
placements are ready to be used when the conference next repeats
If you select a particular participant for a pane and they are disconnected for any reason, that pane
appears blank
After you set up pane placement, you can still change the layout for individual participants (see
Controlling a participant's endpoint camera) - and they can change their layout using the far end
camera controls unless you disable this for each participant individually (see Participant properties
fields).
The left and right controls on a participant's far end camera control do not work when pane
placement is enabled

Streaming (of the main video channel)
Using the web interface you can configure an MCU to support unicast or multicast streaming or both (but
see below):
•
•

Unicast streaming involves a direct connection between the MCU and the individual user
Multicast streaming involves transmitting a single copy of the video or audio stream to multiple
recipients. When choosing to support multicast streaming, ensure that your network has been
properly configured to avoid network flooding

Streaming sends conference audio and video to a remote computer, allowing the user to watch and listen to
a conference. The media flows in just one direction, so it is not possible to contribute to a conference via
streaming.
Streaming configuration is set up at two levels:
•
•

MCU-wide using the web interface. Go to Settings > Streaming.
Per-conference using Conference Director or the web interface. See Setting preferences and
Creating a conference. Conference configuration overrides the MCU-wide setting in that streaming
must be enabled unit-wide for the per-conference setting to have an effect. If you enable streaming
MCU-wide but disable it for the conference, that conference cannot be streamed

Streaming, whether unicast or multicast, only ever takes on one port: this is why all streaming participants
see the same layout. For information about how port reservation affects streaming see Port reservation.

Port reservation
MCUs can allocate available media ports in advance to specific conferences. This is called port reservation
and we say that the MCU is in "reserved mode" see Configuring the MCU below. This means that it is able
to guarantee that a certain number of participants will be able to join that conference, irrespective of how
many other people are using the MCU for other conferences at the same time.
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By default port reservation is disabled but you can enable it using the web interface. However, it is
important to know whether an MCU is in reserved mode or not when setting up conference preferences
(see Preference dialog fields) and when specifying the maximum number of participants for a conference
when you create or duplicate a conference. This can be found on the General page of the MCU properties
dialog.

Media port types
There are two types of media ports available on the MCU: video ports and audio-only ports and the number
of both on a particular MCU can be found on the General page of the MCU properties dialog.
A video port is a port that can be used by a video conferencing endpoint for a call. Therefore, a video port
includes both video and audio streams (bidirectionally) and the number of video ports available represents
the number of "normal" video calls that the MCU is able to maintain simultaneously.

Participant port usage
In general, each endpoint in a conference is able to use either a video port or an audio-only port, though
normally the MCU will assign video ports to video-capable devices and audio-only ports to audio-only
devices.
•

If a video-capable device joins a conference which just has audio-only ports available, the MCU will
assign it an audio-only port. That participant will be able to listen to other people and contribute
their own audio to the conference but the MCU will not transmit video to it — and will not use any
video received from it

•

If an audio-only device such as a simple telephone joins a conference which has just video ports
available, the MCU will assign it a video port, which includes audio capability. The video capability
of that allocation will not be used, but the audio device will be able to participate as normal in the
conference. The exception to this is a VNC endpoint: because this is a video-only protocol, the
MCU does not permit VNC connections to use audio-only ports

Streaming
Streaming a conference requires use of a video port. If a video port is unavailable (or not allocated in
advance when in reserved mode), it will not be possible to stream that conference. If a video port has been
allocated for the purpose of streaming a conference, any number of streaming viewers will be able to view
that conference via streaming using that same one video port, at any combination of available bit rates.

Configuring the MCU
To enable port reservation mode go to Settings > Conferences in the web interface. (You cannot change
port reservation mode using Conference Director.)

Unreserved mode
This is the default mode and the mode under which the device runs when the Media port reservation setting
is Disabled.
You can specify a maximum value for the number of video and audio-only ports for each conference. These
limits are optional, and by default there is no configured limit. These are strictly maximum values; in
particular, setting such a limit does not guarantee that there will be enough ports available at the time for
that many participants to join the conference. You can set these values such that the sum of the configured
limits across all active conferences exceeds the total number of ports available on the MCU.

Reserved mode
When the Media port reservation setting is Enabled, each conference is configured with a number of video
ports to reserve and a number of audio-only ports to reserve. If you are working with an MCU that is in
reserved mode you may want to set the conference preferences to specify the number of participants so
that you do not forget when you create new conferences.
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The numbers set in port reservation mode differ from the maximum port values set in the unreserved mode
in a number of ways:
•

Reservations are guaranteed
As well as being maximum values (i.e. enforcing limits on the number of conference participants),
port reservation values also guarantee that as many endpoints as are specified are able to
participate in the conference.

•

Port reservations are mandatory
In unreserved mode, it is not necessary to specify the number of video or audio-only ports for a
conference. In reserved mode, however, every conference must have configured reservations for
both video and audio-only ports.

•

Over-allocation is not permitted
Port reservations guarantee that a certain number of participants will be able to join a conference;
because of this, the MCU will not permit these reservations to be configured such that the total
number of reserved ports at any given time exceeds the total number of ports available. See
Clashing reservations for additional information.

Clashing reservations
In order to honor configured port reservations, the MCU must ensure that at any given time the number of
reserved ports does not exceed the total media capacity. This entails some level of clash detection when
conferences are scheduled or their configurations changed.
Two conferences are considered to clash if they can ever be active simultaneously. When validating a
conference scheduling operation, the MCU looks at the maximum number of ports reserved by other
conferences which can be active at the same time, and checks that the number of ports requested by the
conference being changed or added is guaranteed to be available. If, for instance, the MCU has 20 video
ports available in total, it will not be possible to set up two conferences which require 15 video ports each if
they are scheduled such that they overlap even for a minute.
In the simple case of conferences which start at specific times and end at specific times (or, indeed, are
permanent), it is easy to see whether they clash. The more complex cases involve repetition, and it is
important to bear in mind that port reservations are only permitted when the MCU can guarantee them for
every repetition of a conference. As an example, a conference scheduled to run from 08:00 to 10:00 on the
second Monday of each month will be deemed to clash with a conference configured to run from 09:00 to
09:30 every Monday, even though the former will only really clash with the latter every fourth or fifth week.
In general, to make best use of the available MCU media ports, conferences should not be scheduled for
longer than they are needed, and repetitions should be limited, either by end date or number, wherever
possible.
When scheduling conferences or changing port reservations for existing conferences, the MCU will
endeavor to tell you the maximum number of ports you are able to reserve, based on the start time,
duration, and repetition parameters of the conference in question.

Ad hoc conferencing
Ad hoc conferences are not permitted on MCUs in Reserved mode. This affects the operation of the MCU in
the following ways:
•

Auto attendant usage
When in reserved mode, the Create new conference option will not be shown on video auto
attendant menus, even for auto attendants configured to offer this facility.

•

Auto attendant configuration
When configuring new or existing auto attendants via the web interface, you cannot enable the
Create new conference option..

•

Calls to unknown E.164 number configuration
On the web interface, this field on the Settings > Conferences page also offers a Create new
conference option. When in reserved mode, this is not available, and becomes equivalent to the
Disconnect caller option.
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Auto attendant connections
If a participant calls in to the MCU and connects to an auto attendant, the MCU does not know which
conference they will join until they make a selection from the auto attendant menu.
In unreserved mode, the auto attendant connection just uses a video or audio-only port as appropriate from
those not currently in use. If all of the media ports are in use, the endpoint's connection will be dropped by
the MCU.
In reserved mode, the auto attendant connection effectively "borrows" a video or audio-only port from those
not currently in use. However, this borrowed media port has a lower priority than a media port used by a
conference participant, and if the auto attendant connection "borrows" the last remaining media port then
that connection will be dropped if another endpoint connects directly to a conference and requires a
reserved media port.

Changing MCU port reservation mode
In general, changing port reservation mode when there are active connections is not recommended.
Although you cannot change the port reservation mode using Conference Director it is important to
understand the consequences if this happening. They include, but are not necessarily limited to:
•

Destruction of ad hoc conferences
Ad hoc conferences are not permitted in port reservation mode. Changing an MCU from unreserved
mode to reserved mode, causes any ad hoc conferences in progress to be destroyed and their
participants dropped. (An ad hoc conference can be set up "on the fly" from an auto attendant if the
Create new conference option is available. Ad hoc conferences always start straight away.)

•

Participant disconnection
For each conference, the maximum port usage values (for unreserved mode) and the port
reservations (for reserved mode) are separate configuration items. When changing between modes,
if the new conference limit is less that the number of active participants in that conference, some
participants will be disconnected.

Port usage with content channel support
Port reservation mode
If the MCU is operating in reserved mode, enabling H.239 (a data channel) for a conference requires the
use of an additional video port. A single video port is needed for all content channel and H.239 operations,
irrespective of how many viewers there are; for example, a conference involving 5 video endpoints (one of
which is contributing a H.239 stream and the other 4 viewing it) will require 6 video ports.
In reserved mode, a conference with H.239 enabled will require a video port for H.239 operations even if no
current participants are actively making use of H.239.
Unreserved mode
If the MCU is operating in unreserved mode, enabling H.239 for a conference works in a similar way to
streaming in that it will require a video port to be allocated when content channel operations are first
attempted for that conference. For instance, this could be when a participant opens a H.239 channel or a
user starts viewing the content channel via their web browser. When the video port is no longer needed for
the conference's content channel (e.g. when the last remaining participant disconnects) the port will be
released for use by future participants or conferences.
Streaming of the content channel
The streaming of the content channel is performed using the video port allocated for H.239 rather than the
video port allocated for streaming. This means that it is possible to stream the content channel (for
example, to use the video markup feature) for conferences which do not have streaming enabled. Enabling
both streaming and H.329 for a conference will mean that 2 additional video ports will be required for that
conference, over and above the video and audio-only ports used by endpoints participating in that
conference.

The content (H.239) channel
For each conference, the MCU supports an additional video channel known as the content channel. This
feature encompasses:
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•
•

H.239 video streams sent from the MCU to viewing H.323 endpoints
Sourcing the content channel from a H.323 endpoint's H.239 video stream or from a VNC
connection. (Virtual Network Computing or VNC is an open standard commonly used for remotely
controlling one PC from another)
• Streaming the content channel to users' desktop machines (*)
• Allowing graphical and textual "markup" of the content channel (*)
• Text chat between conference participants (*)
* See Streaming of the content channel, markup and chat
Content channel configuration can be set at several levels (see MCU content channel configuration).
Whether a conference allows content channel support or not is determined when you create the
conference. However, you can set the default in the conference preferences. (The setting can also be
changed subsequently in the Advanced page of the conference configuration dialog.)
Content channel usage has some consequences when port reservation is enabled.

Content channel vs. main video
The H.239 protocol allows the MCU to support an additional video stream to or from each connected H.323
endpoint. Thus, there are potentially three media streams between each H.323 endpoint and the MCU:
audio, main video and H.239 video. (What is referred to here as main video is the normal multi-pane
conference view showing participants' video streams composed within the selected layout.)
The main differences between the H.239 (content channel) video and the main video are:
•

Single layout
Each participant in a conference can normally select their own individual main video layout (e.g. a 2 x
2 grid of other participants, 1 large focused pane plus 8 smaller panes) and they are free to change
this layout as many times as desired during the time they are connected to the conference. The
content channel video always shows just a single video stream, "full screen", and each viewing
endpoint will see the same stream. The stream which constitutes the content channel can change
any number of times during the conference, but there can be at most one such contributing stream at
any given moment.

•

One channel per conference
Each participant's main video stream is encoded independently; this means that each endpoint can
be receiving its main video stream at a different bit rate, codec, or resolution to that being sent to
other participants. However, there is a single H.239 video stream per-conference, which means that
the MCU sends the same bit rate and resolution to all endpoints receiving H.239. The bit rate and
resolution used are chosen to maximize the number of viewers: the resolution might be reduced if a
new endpoint joins the conference and its H.239 receive capabilities are more limited than those of
the other participants.

•

Differing characteristics
The range of bit rates, resolutions and frame rates available to the MCU for sending the content
channel via H.239 to H.323 video conferencing endpoints is potentially as wide as that for the main
video channel. However, in general, the main video channel is used for motion video (i.e. high frame
rate streams) and the content channel for less dynamic video such as an accompanying presentation
— typically high resolution, low frame rate. The MCU allows flexibility in terms of nominating which of
the available streams forms the content channel, as well as allowing control over which endpoints
are permitted to start contributing H.239 video.

•

Uni-directionality
In terms of its main video channel, a video conferencing endpoint would normally be both
contributing (sending) a video stream to the MCU and receiving a video stream from it. The content
channel works differently in that an endpoint can either be sending H.239 video or receiving H.239
video, but not both simultaneously. A given H.323 endpoint may switch between being the
contributor and a viewer during the course of its conference participation, but it will never be both.

H.323 endpoints' content channel support
Depending on the specific H.323 endpoint and how it is configured, the H.239 video stream may be
displayed on a separate screen, or the endpoint may show the main video and the H.239 video streams
side by side on the same screen.
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Irrespective of its H.239 receive capability, a H.323 endpoint may or may not be able to contribute the
content channel: typically, for this to be possible, it will either need a second camera or some other video
input such as a VCR or "video in" connection.
Some H.323 endpoints may have no support for the H.239 protocol - and no SIP endpoints support H.239.
However, it is still possible for such endpoints to view the content channel - the MCU is able to show the
content channel within a normal view pane in the same way as it displays other conference participants.
This ability is controlled by a unit-wide setting available in the web interface.

Content channel sources
There are several possible content channel sources:
•

H.239 video channel
This is the most conventional content channel behavior — a H.323 conference participant opens a
H.239 channel to the MCU and contributes a video stream such as that supplied by a second camera
or an attached PC. The H.323 endpoint needs to make a request to the MCU, and have that request
accepted, before actual content channel contribution can start. If the conference already has an
active content channel (for example, another endpoint is contributing H.239 video), the new request
will be rejected by the MCU: it is necessary to wait for the active contributor to cease sending H.239
video before the new endpoint is able to start.

•

VNC connection
A VNC connection is one where the MCU has made a connection to a remote device (normally a
desktop PC) and is receiving a video stream from that device. This is typically used to include a
slide-based presentation in a conference. By default, if a conference is configured with content
channel support and a VNC "participant" is added to that conference, the MCU will attempt to use the
VNC video as the content channel. This is normally the desired behavior; however, there are a
couple of caveats:
o If there is a H.323 video conferencing endpoint actively contributing H.239 video, then it will not
be possible to immediately switch over to using the VNC video instead: the switch over will
occur when the H.323 participant closes its H.239 channel
o With more than one active VNC connection in a conference, the first will be used as the content
channel source, and subsequent connections will be shown in main video layout panes, just as if
the conference had no content channel facility. If the currently active VNC connection is either
disconnected or its use as the content channel disabled, another VNC video stream will start to
be used as the content channel
o Participant main video
The MCU can use a H.323 endpoint's main video channel as the conference's content channel. This
has the same caveats as the use of a VNC connection for the content channel, as described above.
•

Video markup
Whichever of the content channel sources mentioned above is active for a conference, the MCU
allows users to add markup to the video channel. This is an additional video overlay onto which
graphics may be drawn and text added. Content channel viewers see the content channel source
video plus this overlay. The overlay can be later cleared leaving the source video unaltered.

MCU content channel configuration
H.239 or content channel configuration is set at different levels:
•

MCU-wide using the web interface
In the Settings > H.239 page, the MCU can be configured to disallow the use of conference content
channels completely. If the content channel facility is enabled, the MCU can be separately configured
not to allow textual or graphical markup of the content, and whether to make text chat visible to
connected H.323 endpoints.

•

Per-conference configuration using either Conference Director or the web interface
See Setting preferences, Creating a conference and Conference configuration fields (or the Add new
conference page in the web interface).

•

Per-participant configuration using the web interface
For a conference configured with content channel video enabled, each endpoint in that conference is
either permitted or prohibited from being able to contribute H.239 video. H.239 is the protocol used
by H.323 video conferencing endpoints to supply or receive content channel video: other content
channel source configurations, such as the use of a VNC connection, do not depend on any H.239
contribution parameters.
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Note that what is termed H.239 contribution is more precisely the ability to start contributing content
channel video via H.239. The nature of the H.239 protocol used between the MCU and H.323
endpoints is such that once an endpoint has successfully become the H.239 source for a conference,
the MCU is not then able to force that endpoint to stop contributing the content channel video.
While an endpoint is supplying the content channel via H.239, it is considered to be holding the
virtual H.239 token for the conference; this token must be relinquished before either another H.323
endpoint can start contributing video via H.239 or a content channel source such as VNC become
active. This token is normally released via a specific endpoint operation (e.g. a "stop H.239" option)
or by that endpoint leaving the conference.
By default, participants' ability to contribute H.239 video is determined by the per-conference H.239
contribution from endpoints setting. This setting can be overridden by the configuration of individual
H.323 endpoints and there are three options: <use conference default>, Enabled or Disabled. (If an
endpoint's ability to contribute H.239 video has been explicitly enabled or disabled via this
mechanism, this setting will take precedence over any current or future conference or participant
configuration, even if the endpoint later moves to a different conference.)



All of the content channel features are available for ad hoc conferences. However, content
channel support in ad hoc conferences can only be enabled or disabled on a unit-wide basis.
(An ad hoc conference can be set up "on the fly" from an auto attendant if the Create new
conference option is available. Ad hoc conferences always start straight away.)

Streaming of the content channel, markup and chat
H.239 is the mechanism by which a conference's content channel video is delivered to a H.323 endpoint.
There is a single H.239 video stream per conference, and, if the conference channel is active, the same
stream is sent to as many H.323 conference participants as are able to receive it.
As well as the H.239 stream (used for sending to H.323 endpoints), the MCU also generates a Cisco
proprietary format version of the content channel video that can be viewed in conjunction with PC-based
video streaming. This ensures that all participants and viewers for a conference are able to access all of its
associated media, if desired.
Content channel streaming also allows participants using H.323 video conferencing endpoints without
H.239 capability to view a high resolution version of the content channel. Content channel streaming also
provides some features not available via the H.239 protocol: markup and text chat.

Markup
"Markup" is the overlaying of graphics and text onto the content channel video; this could be used, for
instance, to draw attention to a specific element of a presentation slide. Markup can only be performed
through the content channel streaming interface, and is accomplished via the simple mechanism of clicking
and dragging with the mouse, with extra controls for changing the drawing color or clearing the markup
when its usefulness has passed.
Content channel markup also has the following characteristics:
•

All content streaming viewers have equal markup capabilities. This means that either all viewers
are able to perform markup on the content channel video (or clear it), or all are unable to do so - it
is not possible to restrict markup to just a subset of active viewers
• The video markup, although it can only be edited by streaming viewers, will be seen by both
content channel streaming viewers and participants connected via H.323 endpoints
• Video markup is normally used as an overlay to content channel video as supplied by a H.239 or
VNC connection. However, for a conference with content channel operations enabled, it is also
possible to form a content channel comprising just the markup applied to an otherwise blank video
stream. This can be accomplished simply by starting to stream the conference's content channel
and performing the usual markup operations on the (empty) content channel displayed. Adding
markup to such a blank channel "activates" it, and will cause a video channel to be opened to those
H.323 conference participants which have H.239 capabilities
The ability of content channel streaming viewers to perform markup is governed by the unit-wide Markup of
content channel video setting in Settings > H.239.
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Text chat
In parallel with, though in many senses independently of, content channel streaming, the MCU also
provides a mechanism for those streaming a conference's content channel to communicate with other
conference participants via text messages. Beneath the window showing the content channel video,
streaming viewers are able to type messages that will be sent to all other streaming viewers, as well as see
messages that other users type.
In order that users contributing text messages can be identified, each content streaming viewer has an
associated user ID, and this ID is pre-pended to each of the messages they type when it is sent out to other
viewers' displays. If the content channel streaming has been initiated via the streaming-only interface, each
user is required to supply a Sign-in name before streaming starts, and this sign-in is used as their text chat
identifier. If streaming has been initiated via the Watch control on the MCU conference list, the user's web
interface login ID will be used as their text chat identifier.
The text chat facility provided via web browser-based content streaming is two-way in that any content
channel streaming viewer is able to both contribute text and see all messages typed by other viewers.
Although there is no mechanism by which H.323 endpoints are able to contribute text chat messages, the
MCU is able to display the most recent text messages within H.323 endpoints' main video channels. This is
intended to be of use in the scenario whereby a presenter is connected to an MCU conference via a H.323
endpoint and wishes to field questions raised by (content channel) streaming viewers. In this situation, the
text typed by content channel streaming viewers is overlaid on the normal, multi-pane, conference layout,
though is restricted to approximately the lowest 1/3 of the screen.
The display of text chat in H.323 endpoints' views is governed by the unit-wide Overlay text chat in normal
video channel setting. The text chat facility itself, and display of typed text to all content channel streaming
viewers' windows, cannot be disabled.

Sending a message during a conference
You can send a short message to one, more or all participants in an active conference.
Messages must be fewer than 256 characters, but depending on the viewing screen, messages at the
higher-end of this limit might not display properly: therefore, consider limiting messages to approximately
180 characters. Also, messages longer than 256 characters will not be truncated; they will not display at all.
Sending a message:
1. To send a message to selected participants, right-click on one or more connected participants in
the same conference, or to send the message to all participants, right-click on the conference.
2. Select Send message.
3. Type in the message.
4. If required, change the default message position and duration.
5. Click OK.
The message is displayed on the participants' endpoints for the time specified in the General page of the
Preferences dialog (30 seconds by default). (If you select a combination of connected and disconnected
participants, the disconnected participants will not see the message — even when they reconnect).



The MCU needs to be set up to allow messages: go to Settings > Conferences in the web
interface.
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Ending and deleting a conference
You can end an active conference, and you delete one active conference or scheduled conference at a
time. This can be done in a number of ways.



Ending an active conference with the End now option ends the active conference and therefore
disconnects all participants but does not delete the scheduled conference of the same name, if
it exists. If the configuration is periodic, then the conference will happen again as scheduled.
Deleting an active conference with the Remove option also disconnects all participants and
therefore ends the conference, but in addition it deletes the scheduled conference of the same
name, if it exists. Therefore the conference will not recur even if it had been previously
scheduled to do so.
Deleting a scheduled conference with the Remove option both stops the active conference of
the same name if it exists, and stops the conference repeating even if it had been scheduled to
do so.
Whether you can still see a deleted conference in the Scheduled conferences depends on the
setting in the Conference page of the Preferences dialog.

Ending an active conference
1. Right-click on the active conference and select End now or select the conference and go to
Conference > End now.
2. Click Yes.
The active conference is deleted and removed from the Tree View but the scheduled conference of
the same name remains and the schedule still applies.
Deleting a conference
1. Right-click on the conference and select Remove, or select the conference and go to Conference
.
> Remove or click the Remove conference toolbar icon
2. Click Yes.
The conference is deleted and removed from the Tree View.
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About participants
As far as the MCU and Conference Director are concerned, a participant is any endpoint that can be called
or that can call in to an MCU and join a conference.
This means that the same participant can appear in the Conference Director several times:
• In one active conference
• In several scheduled conferences on the same or different MCUs in addition to the one active
conference
It is possible to have more than one participant with the same name in the same conference. To avoid
confusion, you can edit the name in the Participant properties dialog or in the Address book - but the two
are independent: changing the name in one place does not change it globally within the Conference
Director.

Connecting a participant
Participants can join a conference in a number of ways:
• By being added to a conference configuration. This can be a participant with an entry in the
Address book or you can add the details manually. In this case you choose whether the participant
will be dialed automatically by the MCU or whether you manually connect them when the
conference is active - see below
• By being added as an ad hoc participant in an active conference by right-clicking on the conference
and selecting Add participant
• By dialing in to the conference as an ad hoc participant, for example by using the auto attendant



Note that an ad hoc participant is not dialed when the conference recurs.

To connect a participant manually
If you selected the Use manual connect check box when you added a participant to a conference
configuration, the participant must be connected individually while the conference is active.
1. Right-click on the participant in either view and select Connect, or select the participant and either
go to Participant > Connect or click the Connect participant toolbar icon

A connected participant is shown as

.

.

Understanding participant status
During an active conference, you can display an entry for each participant in the List View.
Various icons might appear for these participants showing their status. Refer to the table below for
assistance interpreting these icons.
Icon

Description

Explanation

This participant has been made important
and therefore has been given priority in the
layout views - see Making a participant
important/have normal importance.

If the participant is not important. no icon
appears in this column.

This participant is the active speaker.
This participant's audio is unmuted - see
Muting/unmuting the audio or video for one
or more participants.
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Icon

Description

Explanation

There is an error on the participant's audio.
The participant is receiving audio from the
MCU - see Muting/unmuting the audio or
video for one or more participants.
The Outgoing audio mute check box has
been selected in General page of the
Participant's properties dialog.
This participant video is unmuted see
Muting/unmuting the audio or video for one
or more participants.
If the icon is blue the participant's video has
been muted - see Muting/unmuting the
audio or video for one or more participants.
If the icon is orange, there is an error on the
participant's video.

The status of a participant is also shown in the Tree View.
Icon

Description

Explanation

This participant is connected.
The participant has been disconnected from
an active conference.

The reason is shown in the Disconnect
reason column in the List View.

The participant has been disconnected from
an active conference because of an error.

The reason is shown in the Disconnect
reason column in the List View.

Waiting for the participant to connect.
There is a problem with this participant.
The participant is configured in a scheduled
conference.
There is a problem with this participant.

There are a number of reasons why you
may see this icon; for example, this may be
an alert that one of audio or video warning
and critical packet loss levels set in the
preferences have been reached.

Adding a participant to a conference
A participant can be added to a conference through Conference Director in a number of ways. In each case
see Participant properties fields for help about individual fields:
•

When you create or duplicate (copy) a conference
You can add the participant to the conference configuration when you create or duplicate the
conference. This can be a participant with an entry in the Address book or you can add the details
manually. You can choose whether the participant is called automatically by the MCU as soon as
the conference starts or whether you manually connect them subsequently

•

Adding to the conference configuration using the conference configuration dialog
You can add the participant to the conference configuration using the Conference configuration
dialog after the conference has been created or copied by right-clicking on the conference and
selecting Configuration). This can be a participant with an entry in the Address book or you can
add the details manually. In this case:
o The MCU dials the participant as soon as you click OK - or as soon as the conference
becomes active - unless you have selected Use manual connect. This is useful if you
regularly invite the same participants into a conference
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The participant is dialed every time the conference recurs unless you have Use manual
connect selected. To connect the participant after the conference starts, right-click and
select Connect
You can also add the participant to the Address book at the same time.
o

•

•

Adding to a conference configuration by dragging and dropping from the Address book
Drag and drop the entry from the Address book on to the conference entry in the scheduled
conferences branch of the Tree View.
As an ad hoc participant in an active conference using the Add new participant dialog
You can add the participant to an active conference dragging the participant from the by Address
book on to the conference entry in the List View or by right-clicking on the conference and selecting
Add participant and adding the details manually. In this case:
o The participant is an ad hoc participant: he or she will not be added to the scheduled
conference configuration and therefore he or she is not dialed when the conference recurs
You can also add the participant to the Address book at the same time.
(Note that right-clicking on a conference in the scheduled branch and selecting Add participant is
different from selecting this context menu option in the active conference branch: it adds the new
participant to the conference configuration in the same way that working through the Conference
configuration dialog does.

•

As an ad hoc participant in an active conference by dragging and dropping from another
conference
Drag and drop the participant's entry from another active conference on the same MCU. See
Dragging and dropping participants. These are then ad hoc participants in the new conference even
when they were configured participants in the original conference. You can also drag and drop from
one scheduled conference to another.

Note that a participant can also dial in and create or join a conference, for example through the auto
attendant. This participant is then an ad hoc participant in the conference.

Displaying/Editing a participant's properties
You can display a participant's properties in a number of ways. When the properties are displayed, you can
edit some of the fields. The information displayed and the fields that you can edit depend on whether the
participant is connected in a conference or not.
Displaying/editing a participant's properties
1. Either double-click on the participant in either view and or right-click and select Properties.
The Participant properties dialog is displayed:
•

If the participant is connected in an active conference the dialog opens with the General
page displayed and all pages are active
• For disconnected participants in an active conference all the pages are displayed but are
inactive: no statistics are displayed for example because there is no connection
• For a participant in a conference configuration that is not current active, only the General and
Layout pages are displayed,. you can edit the settings on these two pages
See Participant properties fields.
2. For active participants you can also:
• Open the other pages to see different properties. See Participant properties fields
• Modify some of the properties
• Control the participant's layout view using the Layout page. See Understanding layout
views.
• Control the participant's Far End Camera by opening the Camera preview page and
clicking the arrows. See Controlling a participant's endpoint camera
• Send a message to the participant using the Messaging page. See Sending a message
during a conference
3. When you have finished, click Close.
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Participant properties fields
This topic describes the fields in the Participant properties dialog. If the participant is in a scheduled
conference that is not active only the General and Layout pages of the dialog are relevant and displayed. If
the participant was in an active conference but is disconnected, all five pages are displayed so you can see
the details about their call but you cannot edit any fields.
When you have finished with this dialog, click OK.

General page
Some fields are editable for a connected participant only; others have a different effect when set for a
scheduled participant compared to settings for a connected participant and both uses are explained.
Field

Description

Explanation

Name

The name by which this participant will
be known in Conference Director.

The Name can be, but is not
necessarily, the same as the Internal
name of the participant's endpoint and
can be used to distinguish between
endpoints of the same Internal name.
Note that changing the Name in the
Address book after the participant has
been added to the conference does not
affect the name displayed for this
participant under the active or
scheduled conference branches in the
Tree View or in the List view. Equally,
editing the Name for a participant in
this dialog does not update the
Address book.

Address

The IP address, host name or an E.164
address (phone number) of the
participant's endpoint.

Gateway address

The gateway to use to connect to the
participant's endpoint.

You can select an existing gateway to
use but you cannot set up a H.323
gateway with Conference Director. To
do this through the web interface go to
Gateways and click Add new H.323
gateway.
This field is blank for disconnected
participants.

Conferencing parameters
Connected participant: Selecting this
check box makes the participant
important.
Scheduled participant: whether the
participant will be important when the
conference starts.

You can only make an active
participant important.

Layout control
enabled

When selected, this participant can
control their own layout during a
conference using their endpoint's
controls - and therefore override what
you set.

This field is blank for disconnected
participants.

Widescreen
(configured) and
Send widescreen

Only select this check box if you have a
legacy endpoint with a widescreen
display but the displayed video stream

Endpoints advertise the resolutions that
they are able to display. The MCU then
chooses from those advertised
resolutions, the resolution that it will

Important (active
only)

This field is blank for disconnected
participants.
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Field

Description

Explanation

(active)

is distorted.

use to transmit video. However, some
endpoints do not display widescreen
resolutions optimally. Therefore, you
might want to use this setting to restrict
the resolutions available to the MCU for
transmissions to this endpoint.
This field is blank for disconnected
participants.

Audio muted

Connected participant: whether their
audio is currently mute: other
participants do not hear this participant.
However, they see the video steam
unless that is muted separately
Scheduled participant: whether this
participant's audio will be muted when
the conference next starts.

This field is blank for disconnected
participants.
To change the properties for more than
one participant, select them in List
View and use the context menu.

Outgoing audio
muted

For active participants only, selecting
this check box prevents any audio
being sent from the MCU to this
participant.

Video muted

Active participant: whether their video
is currently muted.
Scheduled participant: whether this
participant's video will be muted when
the conference next starts i.e. other
participants will not see the video
stream from this participant's endpoint
however they will still hear the
participant unless the audio is muted
separately.

Use manual
connect
(configured only)

If selected, this participant will not be
connected automatically by the MCU
when the conference starts, but only
when you right-click on their icon and
select Connect.

This field is not displayed for
disconnected participants.

Audio gain

You can make the MCU adjust the
audio from this participant: louder
(positive numbers) or softer (negative
numbers). The default is no gain (zero).

Select a value from the drop-down list.

The settings for motion (frames per
second) and sharpness (frame size or
resolution) are negotiated between the
endpoint and the MCU.

This field is blank for disconnected
participants.

Motion/sharpness
tradeoff

Connected participant: controls
whether motion or sharpness takes
precedence during the current
conference.
Scheduled participant: controls whether
motion or sharpness will take
precedence when the conference
starts.

This field is blank for disconnected
participants.

Select a value from the drop-down list:
Default, Balanced, Prefer motion or
Prefer sharpness.
•

•
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Field

Description

Explanation
•

Bit rate to
MCU/Max bit rate
to MCU

Bit rate from
MCU/Max bit rate
from MCU

Connected participant: The bit rate (in
bits per second) that the MCU has
requested that the remote endpoint
sends during this conference.
Scheduled participant: The bit rate (in
bits per second) that the MCU will
request the remote endpoint to send
when the conference starts.
Connected participant: The bit rate that
the MCU is attempting to send at this
moment.
Scheduled participant: The bit rate that
the MCU will attempt to send when the
conference starts.

Prefer sharpness: the MCU will
use the highest resolution that
is appropriate for what is being
viewed
• Balanced: the MCU will select
settings that balance resolution
and frame rate (where the
frame rate will not be less than
12 frames per second)
This value cannot be changed for an
active participant.
This field is blank for disconnected
participants.

This value cannot be changed for an
active participant.
This field is blank for disconnected
participants.

Layout page
This page is only displayed for participants in an active conference and allows you to choose the layout that
this participant sees.
Select one of the following:
• the layout family to use
• the Conference layout radio button and click Edit to be able to select a new standard or widescreen
conference custom layout which will also be used for the participant straight away. The Conference
layout dialog opens with the current layout in a blue border. Then you click OK, you see the layout
you chose next to the radio button
• the Participant layout radio button and click Edit to be able to select a standard or widescreen
custom layout for this participant. The Participant layout dialog opens with the current layout in a
blue border. Then you click OK, you see the layout you chose next to the radio button
See Understanding layout views.

Focus page
This page is only relevant for connected participants and selecting one entry from the list determines the
participant who appears in the largest pane.
<loudest
speaker>

When selected, the loudest speaker will be the focused participant.

<H.239 content>

When selected, the content channel will be in the largest pane on endpoints on
which the content channel appears in the main video stream and not on a
separate monitor.

participant name

Each connected participant is listed. Select one participant to have that participant
be the focused participant.
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Camera page
This page is only relevant for connected participants. Use the buttons to control the view that the
participant's endpoint is sending to the MCU.
Movement

These buttons pan or tilt the endpoint's camera in the direction of arrows.

Zoom

The buttons zoom in and out.

Statistics page
This page is only displayed for participants in an active conference. For each of the following fields,
information is displayed both "From" and "To" the participant.
Field

Description

Explanation

Video statistics
Codec

The type of codec in use.

Resolution

The resolution currently in use.

Interlaced

Controls whether the MCU restricts
video resolutions in order to reduce the
effect of interlacing artifacts.

Frame rate

The most-recently measured actual
frame rate.

Channel bit
rate

The negotiated bit rate available for the
endpoint to send video in.

Selected bit
rate

The bit rate (in bits per second) that the
MCU has requested that the remote
endpoint sends.

Actual bit rate

The most-recently measured actual bit
rate.

Bit rate limit
reason

The reason why the actual bit rate
does not match the selected bit rate, if
appropriate.

Packets

A count of the number of packets that
have been sent from the MCU to the
participant's endpoint and vice versa.

Lost packets

The number of video packet-level
errors such as sequence
discontinuities, incorrect RTP details,
and so on.

You should only enable this option if
you are seeing video interlacing
artifacts or on the advice of Cisco
Technical Support. Note that all
resolution restrictions imposed by this
setting apply only to video being sent
from endpoints to the MCU.

This value represents the maximum
amount of video traffic that the remote
endpoint will send to the MCU. It may
send less data than this (if it does not
need to use the full channel bit rate or
the MCU has requested a lower rate),
but it should not send more.

This value does not include packets in
which the actual video data in the
packets is in error.
You should expect to see small values
for this setting. Consistently large
numbers typically imply potential
network problems.

Audio statistics
Codec

The type of codec in use.

Packets

The number of packets sent.

Lost packets

The number of audio packet-level

You should expect to see small values
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Field

Description

Explanation

errors including sequence errors and
packets of the wrong type.

for this setting. Consistently large
numbers typically imply potential
network problems.

Send message page
This page allows you to send a message to a connected participant. To send your message, click Send.
(The message displays on their endpoint for the duration you set in the Preferences dialog.
Field

Description

Explanation

Message

Type in your message.

Messages must be fewer than 256
characters, but depending on the
viewing screen, messages at the
higher-end of this limit might not
display properly: therefore, consider
limiting messages to approximately
180 characters. Also, messages
longer than 256 characters will not be
truncated; they will not display at all.

Status bar

Displays the status of the message.

Making a participant important/have normal importance
You can make one participant "important" in an active conference. Importance affects who appears in which
pane in a view. See Understanding layout views.
Only one participant can be important at any time - making one participant important removes the
importance from another participant. (However, you can also make an important participant have normal
importance so that no participant is important.)
The important participant is shown with the

icon in the List View.

Making a participant important or have normal importance
1. Right-click on a participant in an active conference.
2. Click on the Make important or Make normal context menu option.



You can only make a connected participant important.
Changing the settings of a participant in an active conference does not change their setting in
the conference configuration i.e. making a participant important now does not mean they will be
the important participant when the conference starts next time.
Equally, changing the setting in a scheduled conference configuration will make that participant
important when the conference next starts but does not change what is happening now if the
conference is also active.

Muting/unmuting the audio or video for one or more participants
You can set the audio and video streams that each participant sends to be on (unmuted) or off (muted). By
default, both incoming video and audio are on (unmuted), but you can adjust the setting in a number of
dialogs and using the toolbar. However, the effect will be different if the participant is in an active
conference compared to changing the setting in the Address book or for a participant in a scheduled
conference.
You can also mute the outgoing audio to an active participant i.e. that participant receives no audio from the
MCU.
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Participants in an active conference
You can "turn off" the audio or video signal for one or more participants in an active conference.
Participants who have had their incoming audio muted do not contribute audio to the conference but
continue to contribute to the video stream unless it is muted separately. Additionally, muted participants are
not considered when the MCU calculates the loudest speakers to display in the largest panes, even if the
participant had previously been in one of those positions. See Understanding layout views. Note that other
participants will not have an indication that a participant has been muted. They simply will no longer hear
that participant speaking.
Participants who have had their video muted do not contribute video to the conference. They will continue to
contribute audio as normal, unless it is separately muted.
Participants who have their outgoing audio muted do not hear any of the other participants.
Muting/unmuting the audio or video
1. Right-click on one or more participant(s) in the same conference and then click on the appropriate
context menu option. Alternatively select the participant(s) and use the toolbar icons:



•

unmute audio (i.e. what the participant says)

•

mute audio

•

unmute outgoing audio (i.e. audio to the participant)

•

mute outgoing audio

•

unmute video

•

mute video

Changing the settings of a participant in an active conference does not change the setting in the
scheduled conference i.e. the setting for this participant when the conference starts next time is
not affected.
If you mute (or unmute) connected participant(s) in an active conference, then the appropriate
setting is changed straight away. Changing the setting of participant(s) who are unconnected
determines what other participants see and hear when they connect during the same
conference session.

Participants in a scheduled conference
You can set the audio and video for a participant in a scheduled conference to be muted or unmuted when
the conference (or a recurrence of the conference) starts.
Muting/unmuting the audio or video
1. Right-click on one or more participant(s) in the same conference and then click on the appropriate
context menu option.
Alternatively select the participant(s) and use the toolbar icons:



•

unmute audio (i.e. what the participant says)

•

mute audio

•

unmute video

•

mute video

Changing the setting in a scheduled conference effects what it seen and heard when the
conference next starts but does not change what is happening now if the conference is also
active.
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Participants in the Address book
You can open a participant's entry in the Address book and edit their properties.



Changing the setting in the Address book only changes how this participant audio and video will
be set for conferences that you add the participant to after the change. It does not effect the
configuration of any conferences that this participant is already a part of.

Lecture mode
Using lecture mode does not affect the audio of other participants.

Outgoing audio mute
For an participant in an a active conference you can mute the audio they receive from the MCU by selecting
the Outgoing audio mute check box has been selected in General page of the Participant's properties
dialog.

Making a participant the lecturer
You can make one connected participant the lecturer and the conference is then said to be in lecture mode.
This is a simple and quick way to set the layout seen by participants:
• The lecturer is seen by all other participants full-screen irrespective of any of their current settings
• You can choose the layout view that the lecturer sees of the other participants
Making a participant the lecturer
1. Right-click on the participant who you want to be the lecturer and click Lecture mode.
The Set lecturer's layout dialog is displayed.
2. Select the appropriate layout or layout family that you want the lecturer to see.
• If you want to use the current custom Conference or Participant layout, click the
corresponding radio button
Note: Although you cannot change the custom Conference layout from this dialog you may
still want to use the one that is currently set because only the custom Conference layout
has pane placement. For any other views the lecturer sees the participants that the MCUs
would normally put in these views: see Understanding layout views.
•

You can select a different custom Participant layout. Click Edit. In the Participant layout
dialog select the layout you require and click OK to close the dialog.
3. Click OK.
The layout view for all participants changes:
•
•

the lecturer sees the view that you selected
all other current participants see the lecturer only. (However participants joining the conference
while lecture mode is in progress are not forced to view the lecturer full screen - unless this is the
default layout for the conference, or the MCU's default layout, if no default layout is set for the
conference)

Terminating lecture mode
Lecture mode can be turned off by right-clicking on the conference and selecting Apply conference layout.
The layout for all participants switches to the default conference layout or the MCU's default layout if none
is set for the conference.
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Controlling a participant's endpoint camera
While in an active conference, you might need to change the camera settings for one of the conference
participants, for example, if you want to zoom in on a particular speaker in a large group, or if you cannot
see the speaker. This is done using the participant's far end camera control.



Click on the preview window above the arrow keys to refresh the participant's camera view.

Using the Far End Camera controls
1. Right-click on a participant in an active conference and select Properties.
2. Open the Camera page.
3. To move the camera angle, click on the arrows as required.
4. To zoom in or out, click on the appropriate magnifying glass button.
5. When you have finished, click Close.

Dragging and dropping participants
You can now use drag and drop to make it easier to manage participants.

Dragging between conferences
You can drag and drop one or more participants from one conference to another conference:
•

Active conferences: From one active conference on an MCU to another active conference on the
same MCU. Dragged participants are ad hoc participants in the destination conference: they are not
dialed when the conference recurs. The participant's call remains connected continuously. If you
drag and drop between conferences, no messages are displayed to the participant (unless you
selected the preference to display a confirmation dialog) - the participant simply sees a different set
of participants and the layout is determined by the new conference . See Preferences dialog fields.

•

Scheduled conferences: From one scheduled conference on the same or a different MCU. The
participant is removed from the original conference.

Dragging and dropping can be done in either the Tree View or the List View.



You cannot drag a participant from an active conference to a scheduled conference and vice
versa.

Keeping track of moved participants
You can choose whether a dragged and dropped participant remains as a disconnected participant entry in
the conference that you moved the participant from by using the View > Show moved participants option.
The Disconnect reason is shown as "moved". If the option is not ticked, then no record remains that the
participant was once in the original conference.



Participants who were ad hoc participants in the original conference do not show as
disconnected participants after they have been dragged and dropped even if you have selected
the View > Show moved participants option.

Dragging to and from the Address book
You can drag and drop a participant in to the Address book and their details are stored for use
subsequently. If there is already an entry for a participant with the same name as the one you are adding,
you are prompted to enter a new name.
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You can drag and drop a participant from the Address book in to an active conference and that participant is
dialed straight away. You can also drag a participant from the Address book to a scheduled conference and
they are added to the conference configuration.

Dragging from the auto attendant
You can also drag a participant who is connected to an auto attendant to an active conference on the same
MCU to connect them to the conference: however, you cannot drag a participant to an auto attendant.

Understanding layout views
The MCU provides over 50 layout views and each participant can have a different view (except for
participants who are streaming the conference: all multicast streaming participants see the same view). The
views vary from the most simple of just displaying one participant to dividing the endpoint's screen in to a
large number of panes. The panes can be the same of different sizes. Which view is the most "sensible"
depends on a number of factors, including how many participants there are in the conference and whether
the endpoint supports widescreen views.
The default behavior of the MCU is to display the "loudest" participants in the most prominent layout panes.
If there are more contributors than there are panes available, then the "quietest" participants are not shown.
However, different styles of layout introduce slight subtleties to this behavior, and in addition there are a few
ways in which participants or conference administrators may change the system used for pane assignment.
These are described in this topic. (In addition, if you select a conference custom layout you can choose
which participant appears in each pane. See pane placement.)

Layout pages
One layout or a family
The Layout pages in the Conference configuration and participant dialogs allow you to choose a layout —
or a layout family — for the selected conference or participant(s). For example the difference between
selecting the third option (screen divided in to four panes) and the fourth option is that if you select the third
option then the screen is always divided in to four. There are blank panes if there are fewer than 4
participants and, equally, the endpoint only displays four other people even if there are 5 or more
participants in the conference. The fourth option is a layout family, so that when a fifth participant joins the
conference the layout changes from a 2 x 2 view to 3 x 3 so that up to 9 participants can be displayed
simultaneously. Equally, if a tenth participant joins the conference, the view will change again to 4 x 4.
The custom conference and participant options allow you to choose one layout from a large number of
layouts - and in the case of the custom conference layout, to use pane placement.

Equal sizes or different sized panes
Options two, three and four all have panes of equal sizes. Options 1 and 5 allow you to pick arrangements
with panes of different sizes and this may be useful if there is one main speaker, or a person who is more
important than the other participants.
When allocating participants to panes, the MCU always fills the largest pane or panes first. If there are more
participants than panes then there will never be empty big panes (though one or more small panes may be
empty). To reduce the number of view changes when different participants speak (for example, when
people change from being active speakers to inactive contributors), the MCU duplicates participant views
for layouts with more than four small panes. This reduces the impact of audio volume changes on the
composed layout while not needlessly wasting view space. However, it is possible to configure the MCU not
to duplicate participant views in this way if so desired (go to Settings > Conferences in the web interface).

Widescreen layouts and clipped panes
The custom conference and participant layouts include a page with a number of layouts more suitable for
endpoints with widescreens.
Clipped panes can occur when a view is scaled. Most panes, whether big or small, have the same aspect
ratio as the view itself: that is, the panes' widths and heights are in the same proportion as the width and
height of the encompassing view. However, some views have panes where the ratio is not preserved. In
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these cases, the MCU scales the participant video stream according to the larger dimension of the pane so
that that dimension fits. For example, in a pane which is one half of the view width and two thirds of the
view height, the MCU scales the participant video stream to two thirds of its size. Therefore a small amount
of the left and right of the original image will not appear in the final composed layout.

"Important" participants
For each conference, one active participant can be set as "important". The MCU then considers this
participant first when deciding which contributors to show in which layout panes, rather than their position in
the list being set by how loudly they are speaking. Note that importance is overridden if you are using pane
placement.
In a layout in which all panes are of equal size, the MCU cannot focus on a specific participant; however, if
a conference participant has been set to "important", that participant is always shown in the upper-left view
pane.

"Important" Participants Combined with View Focus
If the view focus has been changed (for instance with left and right Far End Camera Control operations),
then there is a potential conflict between the "important" participant and the focused participant.
In a layout with a single big pane and several small panes, the big pain shows the "important" participant by
default. However, if the focus is changed to a different participant, then the big pane shows the selected
participant and the "important" participant is shown in one of the small panes. If the view has been focused
on a participant and the same participant is also set as "important" then that participant is shown in the big
pane.
In a layout with two large panes and several smaller ones, if the view focus has been changed, then the
upper or left large pane shows the focused participant. If a participant has been set to "important" then that
video stream appears in the lower or right large pane. If the same participant is focused and "important",
that video stream appears in the upper or left pane.
In layouts with three large panes, even if the view is focused on a specific participant and another has been
set to "important", one large pane remains. This pane displays the "loudest" remaining participant.

Participants viewing themselves
When considering which participants to show in which panes, the MCU considers the participant's self view
with lowest priority. This has two main implications:
•

Participant pane selection
When choosing participants to display, the MCU considers the viewer last. This prevents the
participant who is the active speaker from potentially seeing only themselves. In this case, while
everyone else will see the active speaker, the active speaker will see the previous active speaker in
their biggest view pane.

•

View family layout selection
When the MCU is required to choose a layout from a view family, it does so based on the number of
video contributors to the conference. However, when calculating the number of video contributors for
a particular view, the MCU does not consider any video stream being received from the viewer.
Thus, with 5 participants in a conference and everyone seeing the standard equal-sized view family
(2x2, 3x3 or 4x4), each of the five contributing participants will always see the 2x2 view with
themselves excluded. However, streaming viewers will see the conference display using the 3x3
view with five panes in use.

You may configure the MCU so that participants never see their own video stream in small panes, even if
there are free slots (see Settings > Conferences in the web interface). They may still appear in large
panes, for example if the view focus is manually changed to show their video.

Video stream vs. fixed images
The image you see in a pane for a video conference participant is either the live video stream (if you are
viewing on a video endpoint) or a captured video image from the current video stream (if you are viewing on
the web interface).
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However, audio-only participants do not have any associated video to display. Instead, a fixed (bitmap or
gif) image can be assigned to a participant through the web interface. When the participant joins a
conference as an audio-only participant, this image appears in the layout pane. This can only be done
through the web interface after the user account has been added. Go to for video conference participants
and click on the link for an existing user.

Setting the layout
In Conference Director you can set the layout on a conference or per participant basis. you can:
• Control the layout for all the participants in a conference simultaneously using the Layout page of
the Conference configuration dialog. You can also set a custom conference layout and use pane
placement to select which participant appears in which pane
• Select more than one participant in the List View and set the layout; then, they all see the same
selected view.
• Change the conference layout at any time by right-clicking on a conference and selecting Set
conference layout; however you cannot set pane placement with this option, you must use the
Conference configuration dialog to do that
• Apply the conference layout at any time by right-clicking on a conference and selecting Apply
conference layout

Active vs configured participants
If you set the layout for active participants, then they see the selected view straight away.
However, if you set the layout for participants in a scheduled conference that is not currently active, the
selected layout will be seen when the conference next repeats.
Setting the layout for one or more participants in an active conference
1. In the List View right-click on one or more participants.
2. Select Set layout.
3. Select one of the layout options. See Understanding layout views for information about the different
choices.
4. Click OK.
The participant(s) see the selected view.
Setting all participants to the default conference layout in an active conference
1. In the List View right-click on the conference.
2. Select Apply conference layout.

Letting participants change their own layout
For each participant, you define whether that participant can override the layout you choose for them with
the Enable layout control check box. By default the setting is enabled so that participants can control what
they see. However, you can change the default setting when you add the participant to the Address book or
create an ad hoc participant for a conference, or subsequently by editing the participant's properties. See
Participant properties fields.
Setting the layout from the Address book or participant properties
1. Select a participant from the Address book and click Edit or right click on a participant in the Tree
or List View and click Properties.
2. Open the Layout page.
3. Select one of the layout options. See Understanding layout views for information about the different
choices.
4. Click OK.
If you updated the participant properties, the selected view is the one that the participant sees the next time
they connect to a conference. If you updated the participant's Address book entry the selected view is only
used when you subsequently add the participant to a conference from the Address book.
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Layouts in lecture mode
If you select a participant to be the lecturer, then the layout is changed. The lecturer is seen by all
participants full-screen but you can choose the layout view that the lecturer sees. See Making a participant
the lecturer.

Disconnecting or removing a participant from a conference
You can disconnect participants from a conference and they are no longer part of the conference. However
scheduled participants will be called in to the conference when it recurs. Simply right-click on the participant
and select Disconnect.
icon and the icon. (If you see the same icon but in orange
A disconnected participant is shown with the
the participant was disconnected due to an error.)
Removing a participant is different. There are a number of ways to remove a participant from a conference:
•
•
•

Open the Conference properties dialog and click on a name in right list box. Then click Remove.
No confirmation is required
Right-click on a participant in either the Tree View or the List View and select Remove. Click Yes
Select a participant from Tree View and select Remove from the Participant menu. Click Yes

•

Select a participant from Tree View and click the disconnect participant toolbar icon

Removing a scheduled participant from an active conference does also remove the participant from the
Conference configuration; therefore the participant will not be called if the conference is scheduled for any
repeats. A warning message is displayed.
Equally, removing a participant from a scheduled conference does not remove the participant from an active
conference; their call is not disconnected.
Finally removing a participant from either an active conference or a scheduled conference (or both) does
not remove the participant from the Address book - if he or she had an entry there.



Another way to remove a participant from an active conference is drag and drop them from this
conference to another active conference on the same MCU. See Dragging and dropping
participants.

Cisco TelePresence Conference Director online help (printable format)

Page 54 of 61

Address book
Creating and selecting the Address book
You can create an Address book and use it for the participants that you call in to conferences frequently.
You chose the folder to store the Address book in, locally or on a server. You can also share the Address
book with other users of Conference Director.



If you used the Address book in Conference Director's predecessor, the unofficial Management
Application, you will find that using the Address book is much faster in Conference Director.

You can have more than one Address book and then select the one to use at any time. For example you
may want to have one for your European participants and a different one for participant from the Americas.
The Address book that is selected when you close Conference Director will also be the one automatically
selected when the application reopens.
The Address book is used to store participant details such as their endpoint's IP address and whether to
use a gateway to call it. For each participant you can also store a number of connection settings such as
the maximum bandwidth, and preferences (for example, the initial layout displayed when the participant
joins a conference).
The current Address book is automatically opened each time Conference Director starts. Address books
have a filename extension of .caddr.

Leaving the Address book open
The Address book can be left open (displayed) while you work with other dialogs. This can be useful
because dragging and dropping Address book entries is one way to add participants to conferences, for
example. See Adding a participant to a conference.

Address book compared to pre-configured endpoints
The Address book is completely independent of the Endpoints function on the MCU; for example, it is not
stored on the MCU. However, they serve a similar purpose - to let you set up frequently-used participants'
endpoints once and call then in to conferences swiftly and easily. To save retyping information already
stored on the MCU, you can copy pre-configured endpoints from the MCU to an Address book: see
Obtaining Address book entries from an MCU.

Creating/Selecting an Address Book
When you create a new Address book it is automatically selected. If you are intending to import participants
from an MCU, you must select the Address book to import them in to before you use the Import from MCU
option in the Address book menu.
To select an Address book:
1. Go to Tools > Address book > Select address book.
2. Either type in a file name, or use Browse.
This can be local or on a server. If you want to store the Address book in the same folder as the
preferences file, this is \Documents and Settings\<name>\Application Data\Codian\Codian Director.
3. Click OK.
If the file does not exist, then Conference Director asks you if you want to create it, both creating a
new Address book and selecting it.
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Adding a participant to the Address book/Editing an entry
You can add an entry in the Address book and then add that participant to one or more conferences. You
can also add a participant to a conference and to the Address book in the same procedure.
Finally, you can add a participant from a scheduled or active conference as an Address book entry. This
can be achieved in two ways: dragging and dropping as described in the previous section or by rightclicking on the participant and selecting Add to address book.



The participant is added to the currently selected Address book. As there can be more than one
Address book, make sure it is the one you want to work with.

Adding an Address book entry
1. Go to Tools > Address book > Open address book.
2. Click Add.
The Add address book dialog opens with the General page open.
3. Type in the participant's name and their endpoint's IP address.
4. Complete the dialog as appropriate. See Address book entry fields.
5. Click OK to close the dialog.
6. Click Close.
Editing an Address book entry
1. Go to Tools > Address book > Open address book.
2. Click on the participant's entry and then click Edit.
The Edit address book dialog opens with the General page open and shows the current settings for
this participant.
3. Modify the dialog as appropriate. See Address book entry fields.
4. Click OK.
5. Click Close.

Adding a participant to a conference and to the Address book
There is a Add to Address book check box in the dialogs used to add participants to conferences. See
Adding a participant to a conference.



The one constraint about using this method to add a participant to the Address book is that the
participant's name must be unique within the Address book. Normally a participant's name only
has to be unique within a conference.

Address book entry fields
The same fields are displayed in the Add address book entry and the Update Address book entry dialogs.
This topic describes these fields.

General page
Field

Description

Name

The name of the participant as you want it to be displayed within the Conference
Director.

Address

The IP address, host name, or an E.164 address (phone number) of the participant's
endpoint.

Gateway

Identifies the gateway through which the endpoint connects.

Conferencing parameters
Use manual
connect

If selected, the MCU will not call out to this participant's endpoint when a conference
that this participant is configured in starts. You must connect to this participant
manually subsequently (right-click on the participant and select Connect).
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Field

Description

Auto connect on
dial in

If selected, this participant can connect to a conference without entering the
conference PIN (if one is set).

Layout control
enabled

If selected the participant is able to change their layout view using their endpoint's
controls.

Send widescreen

If selected, the MCU will send video to this endpoint in a format suitable for viewing
on a widescreen display.

Audio muted

If selected, other participants will not hear this participant.

Video muted

If selected, other participants will not see the video stream from this participant's
endpoint. However, they will still hear the participant unless the audio has been
muted separately.

Audio gain

Select a value from the drop-down list. You can make the audio louder (positive
numbers) or softer (negative numbers). The default is no gain (zero).

Motion/sharpness
tradeoff

The settings for motion (frames per second) and sharpness (frame size or
resolution) are negotiated between the endpoint and the MCU. This setting controls
how the MCU will negotiate the settings to be used with this endpoint.
Select a value from the drop-down list: Default, Balanced, Prefer motion or Prefer
sharpness.
•
•
•
•

Default: this is the MCU's unit-wide default value (i.e. the connection to the
endpoint will use the motion/sharpness tradeoff setting from the Settings >
Conferences page in the web interface
Prefer motion: the MCU will try and use a high frame rate. That is, the MCU
will strongly favor a resolution of at least 25 frames per second
Prefer sharpness: the MCU will use the highest resolution that is appropriate
for what is being viewed
Balanced: the MCU will select settings that balance resolution and frame
rate (where the frame rate will not be less than 12 frames per second)

Max bit rate to
MCU

Select a value from the drop-down list. Sets the bandwidth that the endpoint will
advertise to the MCU when it calls it.

Max bit rate from
MCU

Select a value from the drop-down list. Identifies the network capacity (measured in
bits per second) used by the media channels established by the MCU to a single
participant.

Layout page
This page shows a number of options for the layout that this participant sees when he or she connects to a
conference. Choose from:
• MCU default layout
• One of the families of views: the actual number of panes displayed depends on the number of
participants in the conference
• A custom layout for this participant that is the same as the Custom conference layout. Then click
OK.
• A custom layout for this participant: click Edit and select the view from the Participant layout dialog.
Then click OK.

Removing a participant from the Address book
You can remove one or more participants from the Address book. This has no effect on participants in a
conference:
• For participants that are connected in an active conference - the connection remains
• If the participants are in one or more Scheduled conferences, they remain there and the MCU will
called out to them each time those conferences start
If you want to disconnect participants from an active conference or delete them from a scheduled
conference, you need to do this separately.
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Removing a participant's entry from the Address book
1. Go to Tools > Address book > Open address book.
2. Select one or more participant(s) to delete and click Remove.
The message, Remove selected entries? is displayed.
3. Click Yes.
4. Click Close.

Obtaining Address book entries from an MCU
If a number of endpoints have been configured on an MCU using the web interface, you can add the
endpoints' details in to your open Address book using the configuration.xml file on the MCU instead of
retyping all the information.



The Address book you want to import entries in to must be open.
The import adds every entry it finds: therefore this can produce two entries for the same
participant — you must tidy up the Address book manually.

Obtaining Address book entries from an MCU
1. Using ftp, copy the configuration.xml file to the computer on which you are running Conference
Director.
2. With an Address book selected, go to Tools > Address book > Import from MCU and browse for
configuration.xml. Then click OK.
3. When the confirmation message displays, click OK.
This searches the configuration.xml file and extracts the details in to the Address book. New entries
are displayed in the normal way for example in the Address book dialog.
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The auto attendant branch
Auto attendants simplify the way participants can join conferences. By calling an auto attendant using their
video endpoint, a participant can choose among menu items to join, or start a new ad hoc conference if the
Create new conference option is available. No gateway or gatekeeper is required.



You can drag a participant who is connected to an auto attendant to an active conference on
the same MCU to connect them to the conference. See Dragging and dropping participants.

The auto attendant is configured on the MCU using the web interface (go to Conferences > Auto
attendants). The MCU has one default auto attendant but you can configure others and set up a menu
structure of auto attendants (otherwise known as Interactive Voice Responses or IVRs).
Although you cannot add or configure auto attendants with the Conference Director, you can see when they
are being used. When a participant is connected to an auto attendant on a MCU it is the same as being
connected to a conference in that the connection occupies a port. You see:
• The auto attendant in the Tree View Auto attendant branch
• How many participants are connected to the auto attendant as a number in brackets beside the
name



You can add a custom banner image to any auto attendant configured on the MCU using the
web interface. Go to Conferences > Auto attendants. Then if want to change the banner –
select the auto attendant from the list and click Banner.
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Troubleshooting
Displaying the event log
If you need to perform some troubleshooting for example to find you why an icon turned orange, or
you are asked by Cisco Technical support to provide an event log, you can display the Event log
dialog suing the View menu. The event log lists events from the current Conference Director session;
if you do not save the log, the data is lost when you close Conference Director.
Events are listed in chronological order, and for each event you can see the date and time that the
event occurs, the MCU that it occurred on, the event type and a description.
Examples of events include:
• connections and failed connections to MCUs
• conferences starting and stopping
• participants joining and leaving conferences
You can
• highlight and remove one or more entries from the log
• save the event log to a file in .xml format. You can choose the name and location of the file. If
you do not save the event log, the data is lost when you close the application
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