Cisco Email Reporting Plug-in 1.1
Administrator Guide

August 30, 2019

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
http://www.cisco.com
Tel: 408 526-4000
  800 553-NETS (6387)
Fax: 408 527-0883
THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of DUB’s public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED “AS IS” WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/ trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

Cisco Email Reporting Plug-in 1.1 Administrator Guide
© 2011—2019 Cisco Systems, Inc. and/or its affiliates. All rights reserved.
Deploying the Custom Configuration Files  3-40

Configuring and Using the Cisco Email Reporting Plug-in for Outlook  4-1
  Enabling the Cisco Email Reporting Plug-in  4-1
  Configuring the Sending of Usage Data  4-2
    General Information  4-2
    Account-Specific Information  4-3
  Cisco Email Reporting Plug-in For Outlook General Settings  4-3
    Enable or Disable  4-3
  Configuring Basic Settings for the Outlook Plug-in  4-4
  Configuring the Outlook Plug-in to Check for Updates  4-5
    Update Notifications  4-5
  Configuring Common Options Using the Config File  4-7
  Reporting Unwanted Emails-Spam, Marketing, Virus, and Phishing Attacks  4-8
    Reporting Options  4-8
    Using the Reporting Plug-in for Outlook  4-11
    Configuring the Encryption of Spam Reports  4-14
    Configuring the Tracking of Spam Reports  4-14
  Changing Additional Settings  4-14
    Logging Tab  4-15
    Sending Usage Data Tab  4-16
    Privacy Tab  4-17
  Errors and Troubleshooting  4-17
    Outlook Startup Errors  4-17
    Message Reporting Errors  4-18
    Repairing Cisco Email Reporting Plug-in for Outlook Files  4-19
  Troubleshooting Using the Diagnostic Tool  4-20
    Data Collected by the Cisco Email Reporting Diagnostic Tool  4-20
    Running the Cisco Email Reporting Diagnostic Tool  4-21
Uninstalling the Cisco Email Reporting Plug-in 4-23

Cisco End User License Agreement A-1
Getting Started with the Cisco Email Reporting Plug-in

This chapter contains the following sections:

- Supported Configurations, page 1-2
- Compliance With Security Configuration Guidelines, page 1-2
- How to Use This Guide, page 1-3
Supported Configurations

The following configurations are supported for the Cisco Email Reporting Plug-in 1.1:

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Vista 32 bit</td>
<td>compatible</td>
<td>compatible</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Vista 64 bit</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Win 7 32 bit</td>
<td>compatible</td>
<td>certified</td>
<td>—</td>
<td>—</td>
<td>compatible</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Win 7 64 bit</td>
<td>certified</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>certified</td>
</tr>
<tr>
<td>Win 8 32 bit</td>
<td>compatible</td>
<td>compatible</td>
<td>—</td>
<td>—</td>
<td>compatible</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Win 8 64 bit</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>compatible</td>
<td>—</td>
</tr>
<tr>
<td>Win 8.1 32 bit</td>
<td>compatible</td>
<td>compatible</td>
<td>—</td>
<td>—</td>
<td>certified</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Win 8.1 64 bit</td>
<td>compatible</td>
<td>certified</td>
<td>compatible</td>
<td>compatible</td>
<td>certified</td>
<td>compatible</td>
<td>compatible</td>
<td>—</td>
</tr>
<tr>
<td>Win 10 32 bit</td>
<td>compatible</td>
<td>compatible</td>
<td>—</td>
<td>—</td>
<td>compatible</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Win 10 64 bit</td>
<td>compatible</td>
<td>compatible</td>
<td>certified</td>
<td>certified</td>
<td>certified</td>
<td>certified</td>
<td>compatible</td>
<td>certified</td>
</tr>
</tbody>
</table>

Compliance With Security Configuration Guidelines

The Cisco Email Reporting Plug-in 1.1 has been tested to confirm that it can operate in the configurations and environments described in the following hardening guides:

- NSA Security Configuration Guides, located at: https://www.nsa.gov/ia/mitigation_guidance/security_configuration_guides/operating_systems.shtml#microsoft
How to Use This Guide

Use this guide as a resource to learn about the features in your Cisco Email Reporting Plug-in. Review the Table of Contents to determine which chapters are relevant to your particular configuration.

This guide is distributed electronically as a PDF. The electronic versions of the guide are available on the Cisco Customer Support Portal. You can also access an HTML online help tool in the appliance GUI as follows:

In Outlook 2010/2013/2016, click the **Plug-in Options** button on the ribbon or go to File > Options > Add-in Options > Cisco Email Reporting.

Where to Find More Information

Cisco offers the following resources to learn more about the Cisco Email Reporting Plug-in.

Security Training Services & Certification

Cisco Security Training Services deliver exceptional education and training for Cisco Security products and solutions. Through a targeted curriculum of technical training courses, the program provides up-to-date knowledge and skills transfer to different audiences.

Use any one of the following methods to contact Cisco Security Training Services:

**Training.** For question relating to registration, general training, certificates, and certification exams:

- stbu-trg@cisco.com

Cisco Support Community

Cisco Support Community is an online forum for Cisco customers, partners, and employees. It provides a place to discuss general email and web security issues, as well as technical information about specific Cisco products. You can post topics to the forum to ask questions and share information with other Cisco users.
You can access the Cisco Support Community from the following URL:
https://supportforums.cisco.com

**Cisco Customer Support**

_**Note**_
The level of support available to you depends upon your service level agreement. Cisco Customer Support service level agreement details are available on the Support Portal. Check this page for details about your level of support.

You can request support by phone, email, or online 24 hours a day, 7 days a week. You can contact Cisco Customer Support using any one of the following methods:

- Phone support: Contact Cisco Technical Assistance Center (TAC) within U.S./Canada at 800-553-2447 and at Worldwide Phone Numbers.
- Email: tac@cisco.com

If you purchased support through a reseller or another supplier, contact that supplier directly with your product support issues.
Deploying the Cisco Email Reporting Plug-in

This chapter contains the following sections:

- The Cisco Email Reporting Plug-in, page 2-2
- Installing the Cisco Email Reporting Plug-in, page 2-2
- Configuring Settings for the Cisco Email Reporting Plug-in, page 2-2
- System Processes Required for the Cisco Email Reporting Plug-in, page 2-3
- TCP Services Required for the Cisco Email Reporting Plug-in, page 2-3
The Cisco Email Reporting Plug-in

The Cisco Email Reporting Plug-in enables Outlook users to submit feedback to Cisco about unsolicited and unwanted email messages, such as spam, viruses, phishing, and marketing messages. Cisco uses this feedback to update its filters to stop unwanted messages from being delivered to your inbox.

You can also report false positives, which are legitimate email messages that are marked as spam, to Cisco by using the Not Spam button. Legitimate email messages are often referred to as “ham”. Cisco uses reports about false positives to adjust its spam filters to avoid misclassifying legitimate email in the future. Any valid email can be reported as Not Spam and will help to increase filter efficacy.

This plug-in provides a convenient interface that enables you to submit feedback by using toolbar buttons and right-click context menus. When you report a message, a dialog box appears indicating that the message was submitted. The message data that you submit is used by automated systems to improve the Cisco filters. By submitting message data, you help to reduce the volume of unsolicited email in your inbox.

Installing the Cisco Email Reporting Plug-in

To install the Cisco Email Reporting Plug-in for groups of users, you will likely want to perform a silent installation. A silent installation allows you to perform an installation without prompting the end user for input. For instructions on performing the silent installation, see Chapter 3, “Performing a Mass Installation.”

Configuring Settings for the Cisco Email Reporting Plug-in

After you install the Cisco Email Reporting Plug-in, you can make configuration changes from the Cisco Email Reporting tab in Outlook.

In Outlook 2010/2013/2016, click the Plug-in Options button on the ribbon or go to File > Options > Add-ins > Add-in Options > Cisco Email Reporting.

You can make changes to the Reporting plug-in installation. For example, you can enable or disable logging for the Cisco Email Reporting Plug-in.
To make configuration changes on an Outlook installation, see Chapter 4, “Configuring and Using the Cisco Email Reporting Plug-in for Outlook.”

**System Processes Required for the Cisco Email Reporting Plug-in**

The Cisco Email Reporting Plug-in requires only essential system processes, such as TCP/IP DNS, DHCP, and etc, which cannot be disabled. However, any nonessential system processes, such as database managers, HTTP servers, and hardware configuration daemons can be disabled without affecting the functionality of the Cisco Email Reporting Plug-in.

**TCP Services Required for the Cisco Email Reporting Plug-in**

The Cisco Email Reporting Plug-in requires the use of the following TCP/IP services and their associated ports. These ports must be left available for the TCP/IP services to use.

- **DNS (Domain Name System).**
  
  The DNS service translates Internet domain and host names to IP addresses. DNS automatically converts the names you type in the Web browser address bar to the IP addresses of Web servers hosting those sites.
  
  Port number:  53 (TCP/UDP)
  
  For more information, see:
  http://en.wikipedia.org/wiki/Domain_Name_System
  
  Impact: High
  
  Resolution: This service must be accessible to all end users.

- **SMTP (Simple Mail Transfer Protocol)**
  
  Simple Mail Transfer Protocol (SMTP) is an Internet standard for electronic mail (e-mail) transmission across Internet Protocol (IP) networks.
Port number: 25, 587, 465, 475, 2525 (TCP)
For more information, see:
Impact: High
Resolution: This service must be accessible to all end users.

- **DHCP (Dynamic Host Configuration Protocol)**
  DHCP is a network protocol used to configure devices that are connected to a network (known as hosts) so they can communicate on that network using the Internet Protocol (IP)
  Port number: 67, 68 (TCP/UDP)
  For more information, see:
  Impact: High
  Resolution: This service must be accessible to all end users which obtain IP addresses automatically from DHCP server.

- **Net BIOS over TCP/IP**
  NetBIOS over TCP/IP (NBT, or sometimes NetBT) is a networking protocol that allows legacy computer applications relying on the NetBIOS API to be used on modern TCP/IP networks.
  Port number: 137(UDP) (name services), 138(UDP) (datagram services), 139(TCP) (session services)
  For more information, see:
  Impact: High
  Resolution: This service must be accessible to all end users.

- **HTTP (Hypertext Transfer Protocol)**
  The Hypertext Transfer Protocol (HTTP) is an application protocol for distributed, collaborative, hypermedia information systems.
  Port number: 80, 8080 (TCP)
  For more information, see:
  Impact: High
Resolution: This service must be accessible to all end users.

- **HTTPS (Hypertext Transfer Protocol Secure)**
  
  HTTPS is a communications protocol for secure communication over a computer network, with especially wide deployment on the Internet.

  Port number: 443 (TCP)

  For more information, see:  
  http://en.wikipedia.org/wiki/HTTP_Secure

  Impact: High

  Resolution: This service must be accessible to all end users.

- **IMAP (Internet message access protocol)**
  
  Internet message access protocol allows an e-mail client to access e-mail on a remote mail server.

  Port number: 143, 993 (TCP)

  For more information, see:  

  Impact: High

  Resolution: This service must be accessible to all end users.

- **POP3 (Post Office Protocol)**
  
  Post Office Protocol is used by local e-mail clients to retrieve e-mail from a remote server over a TCP/IP connection.

  Port number: 110, 995 (TCP)

  For more information, see:  

  Impact: High

  Resolution: This service must be accessible to all end users.
Performing a Mass Installation

This chapter describes how to perform a mass installation on multiple desktops and contains the following sections:

- Installation Prerequisites, page 3-1
- Cisco Email Reporting Plug-in Mass Installation Tool, page 3-1
- Performing the Installation, page 3-12
- Using Custom Configuration Files, page 3-36

Installation Prerequisites

Before you can install the Cisco Email Reporting Plug-in application, ensure that you meet the following requirements:

- Microsoft .NET Framework 4.6.1 and later
- Microsoft Office Primary Interop Assemblies

In case you do not have these items installed, you will be prompted to install all software from the prerequisites list by the Plug-in installer.

Cisco Email Reporting Plug-in Mass Installation Tool

The Cisco Email Reporting Plug-in Mass Installation allows creating package for distribution of the Cisco Email Reporting Plug-in for users within your organization.
You can select the server where the distribution package needs to be stored, local or remote machine on the Server Connectivity step.

Also, you can modify the default configuration by editing common and account options. You might want to use different configuration files to change various aspects of the installation, for example, you can change some default options by customizing different parameter values. Also, you can redefine configurations only for selected users in a specific domain, localize user interface or even customize the button names.

You can upload the ready customized CommonComponentsConfig.xml and/or config_{n}.xml files.

On the final step, you will get a shared folder path with all files needed to perform the Mass Installation and the ready customized script that you must copy and reuse in the SCCM Administrator Tool.

**Options Modified by the Mass Installation**

The Cisco Email Reporting Plug-In Mass Installation modifies the following options used in the process of installation:

- Common options, such as Language, Logging, Sending usage data to Cisco, Check for updates, and so on.
- Account options (configurations predefined for users of the specified domain).

**Running the Mass Installation Tool**

Run the Cisco Email Reporting Mass Installation from either Start Menu or Program Files folder.

From the Start Menu:

- Click the Start Menu button and go to Cisco Email Reporting Plug-in > Cisco Email Reporting Plug-in Mass Installation.

OR

From the Program Files:
Go to the folder where Cisco Email Reporting Plug-in was installed (typically C:\Program Files (x86)\Cisco\Cisco Email Reporting Plug-in) and double-click the Cisco.EmailReporting.MassInstall.exe file.

Preparing the Mass Installation Package and Script

Follow this procedure:

**Step 1** Run the Mass Installation tool.

**Step 2** In the **Welcome** window that appears, click **Next**.

**Step 3** In the **Server Connectivity** window, choose preferable connectivity: use the local machine or use remote machine. If you choose the remote machine, complete the **Machine name or IP address**, **Username**, and **Password** fields, and click **Next**.
Step 4 In the **Package Options** window, specify the locations to create the installation package, and click **Next**.
**Step 5**  
In the **Common Options** window, specify the preferable plug-in common components configuration for all created accounts, and click **Next**.
Step 6  In the **Account Options** window, set up the plug-in options applicable for the specified domains, and click **Next**.
Step 7  In the Accounts Options window, click the Edit icon to set up the plug-in options. Click Save and then click Next.
Step 8  In the Mass Installation window, click Start to start the Mass Installation process.

Step 9  Wait till the processing of Mass Installation is complete and click Next.
Step 10  In the **Summary** window, you will receive the package location path and Mass Installation script.

The distribution package with the configuration files to be used during installation is now created in the shared folder. You can copy path to this folder or click 'Open' to view the contents.

The specified command can be used in the command line to install Cisco Email Reporting Plug-In with the predefined settings using SCCM Administration Tool on remote machines within your organization. To work with SCCM Administration Tool, see the [Cisco Email Reporting Plug-in Mass Installation Tool](#), page 3-1.

After you copy this script to reuse it in the SCCM tool, click **Finish**.
Performing the Installation

To perform the installation, complete the following steps to create a network shared folder, distribution package, New Package Wizard, and New Program Wizard.

To perform the installation:

---

**Step 1** Download the installation package and verify the checksum.

a. Use the Quick Hash GUI and the SHA512 hash algorithm at the following URL to generate the checksum for your installation package:


b. Verify that the generated checksum matches the following:

   E858C451B9E638DD475BEEC79E53BEEA24DEA2827E88E786921BD06A2D5404A3FA963EB72F9A8ECC4DBD7DBC4BF9C7B8E7448208E450808E1693E1658C758C8E

**Step 2** Create a network shared folder that contains the installation package and give users access to the shared folder.

---

**Note** You cannot perform an installation from a dropbox, a network drive, or a shared system folder.

**Step 3** Open the System Center Configuration Manager (SCCM) administrative tool.

**Step 4** Expand Application Management in the left pane, right-click Packages, and click Create Package.
The **Create Package** and **Program Wizard** window appears
**Step 5**  Type a name for the package in the **Name** box. for example, type **Cisco Email Reporting Plug-in**.

**Step 6**  Select **This package contains source files** and click **Browse**.

**Step 7**  Select **Network path (UNC name)** in the **Set Source Folder** pop up that appears
Step 8  Type the network source directory that you created in Step 2 in the **Source folder** box and click **OK**.
Step 9  Click Next.

Step 10  Select Do Not Create a Program and click Next.
Step 11  Click **Next** and then click **Close** when the **Create Package and Program Wizard** is completed successfully.
Step 12  Right-click the package that you created in the System Center Configuration Manage and click Distribute Content.
The **Distribute Content Wizard** window appears.
Step 13  Click Next.

Step 14  Click Add > Distribution Point in the Content destination screen
**Step 15**  Select the required items in the **Add Distribution Point** popup that appears and click **OK**.
Step 16  Click Next.

Step 17  Click Next and then click Close when the **Distribute Content Wizard** is completed successfully.
Step 18  Right-click the package that you created in the System Center Configuration and click Create Program.
The **Create Program Wizard** window appears.
Step 19  Choose **Standard Program** and click **Next**.
Step 20  Type “Cisco Email Reporting Plug-in.exe” /exenoui /qn in the Command line box.
Note

If you want to use customized configuration files, you need to add a special key during this step which enables the installation to use the customized files. You add the special key from the command line (specifying the location of the custom configuration files after the = sign) using the following syntax:

```
"Cisco Email Reporting Plug-in.exe" /exenoui /qn
UseCustomConfig="\sc2007\Shared\config"
```

For more information about customizing your configuration files, see Using Custom Configuration Files, page 3-36.

Step 21 Click Next.

Step 22 Click Next.
Step 23  Click **Next** and then click **Close** when the **Create Program Wizard** is completed successfully.

Step 24  Right-click the package that you created in the System Center Configuration Manager and click **Deploy**.
The Deploy Software Wizard window appears.
Step 25  Click **Browse** next to **Collection**.
Step 26  Select the required device collections that contains the group of clients where you want to install the plug-in in the **Start Collection** popup that appears and click **OK**.
Step 27  Click Next.
Step 28  Click Next.
Step 29  Click New in the Scheduling page to create a new Assignment Schedule.

Step 30  Select Assign immediately after this event, choose As soon as possible in the drop down list, and click OK.

Step 31  Click Next.
Step 32  Click **Next** and then click **Close** when the **Deploy Software Wizard** is completed successfully.
Step 33  See the Deployment Status to verify that the process is completed successfully.

Using Custom Configuration Files

The Cisco Email Reporting Plug-in allows you to modify the default configuration by editing a set of XML files included in your installation. You might want to use different configuration files to change aspects of the installation. For example, in the reporting component section of the config_1.xml configuration file, you might change some of the default options, such as the maximum mail size for reporting, or whether to maintain copies of the files after they have been reported. You may also want to customize the button names, or even localize the text used in the user interface.
Overview

To modify and deploy custom configuration files, complete the following steps:

---

**Step 1**

Make a copy of the `\%allusersprofile%\Cisco\Cisco Email Reporting Plug-In\Common` directory.

---

**Note**

You must maintain the directory structure of the original files to maintain validity. Make sure that you maintain the structure starting at the *Cisco Email Reporting Plug-in* directory and include all files with configuration files.

---

**Step 2**

Edit the XML configuration files. Rather than creating new files, Cisco recommends you to modify the XML files included in the installation file. For instructions on modifying these files, see *Editing the XML Configuration Files*, page 3-38.

---

**Step 3**

Navigate to the `\%allusersprofile%\Cisco\Cisco Email Reporting Plug-In\Common\CommonComponentsConfig.xml` file.

---

**Step 4**

Verify that the *CommonComponentsConfig.xml* file includes these tags:

```xml
<accountFileNames>
  <accountFileName filePath="config_1.xml" emailAddress="*" />
</accountFileNames>
```

**Tip**

Make sure that the `accountFileName` tag does not include the `profileName` attribute. If this attribute is present, remove it.

---

**Note**

To configure only selected users in a specific domain, you need to modify the *CommonComponentsConfig.xml* file by specifying the domain as an email address.

For example, to apply the config file to only Cisco users, change the:

```xml
<accountFileName filePath="config_1.xml" emailAddress="*" />
```

to:

```xml
<accountFileName filePath="config_1.xml" emailAddress="@cisco.com" />
```
If there is more than one `accountFileName` tag then the `filePath` will be `config_2.xml`, `config_3.xml`, and so on.

For example:

```xml
<accountFileName filePath="config_2.xml" emailAddress="@cisco.com" />
```

**Step 5**

Run the mass installation described in Installation Prerequisites, page 3-1, and deploy the customized XML files as described in Deploying the Custom Configuration Files, page 3-40.

---

**Note**

The `\%allusersprofile\%Cisco\Cisco Email Reporting Plug-In\Common` directory content must be copied to `\{SHARED_DIR}\{CONFIG_FOLDER}\Common`. The `UseCustomConfig` command parameter enables the installation to use the custom configuration file that you modified.

---

**Editing the XML Configuration Files**

When you install the Cisco Email Reporting Plug-in, configuration data is created and saved in XML files. You can edit the string values to customize the parameter values. However, Cisco does not recommend you remove values or modify the structure of the files.

By default, the plug-in installs configuration files in the `%AllUsersProfile%` directory in the following locations for Outlook:

```
%allusersprofile%\Cisco\Cisco Email Reporting Plug In
```

The XML files are located in the following default locations:

- `\%allusersprofile\%Cisco\Cisco Email Reporting Plug-In\{username\}config_1.xml, config_{N}.xml`. These numbers are dependent on the count of user accounts. It contains configuration data related to the Reporting plug-in, such as the maximum mail size that can be reported. Cisco does not recommend you to modify the Reporting settings.

- `\%allusersprofile\%Cisco\Cisco Email Reporting Plug-In\Common\CommonComponentsConfig.xml`. It contains basic configuration data that is common to the Reporting plug-in, such as the
location of the log files and the name of the localization file (en.xml is the default localization file). You can use your email program settings to change the log file location, and deploy it with your mass installation program. If you want to create a localization file in a language other than the available localization files, you need to reference the name of the new XML file here.

- \%allusersprofile%\Cisco\Cisco Email Reporting Plug-In\Common\Localization\en.xml. It contains data related to local languages. The default language is English. However, there are several localization files available, including de.xml, es.xml, fr.xml, it.xml, zh.xml, pt.xml, and ja.xml. If you want to use a language that is not within the scope of these xml files, you can create a custom xml file and reference it in the CommonConfig.xml file.

Caution
Do not change any string id settings that are inside the < or > symbols because it prevents your plug-in from functioning properly.

Example

The following example shows sample changes to the en.xml file.
To change the text in the Reporting toolbar, find the following section of the en.xml xml file and edit the text in bold:

```xml
<group name="Mso.Report.Button.Cations">
    <string id="blockSender">Block Sender</string>
    <string id="spam">Spam</string>
    <string id="ham">Not Spam</string>
    <string id="virus">Virus</string>
    <string id="phish">Phish</string>
</group>
```

For example, if you want to add more descriptive titles, you could change the text as follows:

```xml
<group name="Mso.Report.Button.Cations">
    <string id="blockSender">Block Sender using Outlook</string>
    <string id="spam">Report Spam</string>
    <string id="ham">Report Not Spam</string>
    <string id="virus">Report Virus</string>
    <string id="phish">Report Phishing Attacks</string>
</group>
```
Deploying the Custom Configuration Files

Once you have completed editing the configuration files, you need to add a special key during deployment to ensure that the installer uses the custom configuration files you modified. The **UseCustomConfig** command line parameter enables the installation to use custom configuration files and specifies the path to the folder containing configuration files which must be used during the installation.

You add the **UseCustomConfig** key from the command line during of the mass installation (see *Installation Prerequisites, page 3-1*) using the following syntax:

```
Cisco Email Reporting Plugin.exe /exenoui /qn
UseCustomConfig="\{SHARED_DIR}\{CONFIG_FOLDER}\"
```

where the path after the = specifies the path to the customized configuration files.
Enabling the Cisco Email Reporting Plug-in

The first time you start the Cisco Email Reporting Plug-in after installation, it might be disabled by Outlook. If this is the case, you see the following message:

![ADD-IN PROBLEM](image)

A problem was detected with an add-in and it has been disabled.

View Disabled Add-ins...
To enable the Cisco Email Reporting Plug-in, click the **View Disabled Add-ins** button on the notification bar to display the Disabled Add-ins dialog. To configure Outlook to always allow the add-in to run no matter how much time it requires during startup, click the **Always enable this add-in** button.

### Configuring the Sending of Usage Data

When the Cisco Email Reporting Plug-in is first started, you are asked whether you want to allow anonymous data to be sent to Cisco to help improve the product. When you select the **Send anonymous usage data to Cisco** check box, the following two types of information is collected and stored on the Cisco servers for analysis:

- General information about the machine the plug-in is running on
- Account-specific information

The details of this information are described below.

You can enable or disable the sending of usage data after the startup by selecting **Plug-in Options** > **Additional Options** > **Sending usage data** tab.

To enable or disable the sending of usage data to Cisco, set the following parameter in the CommonComponentsConfig.xml file:

- **callHomeAdminEnabled**—Set to true or false to enable or disable the sending of usage data when Outlook starts. The default value is true. If set to false, the user does not receive the notification about usage data collection and is not able to send anonymous usage data to Cisco.

### General Information

The following information is collected:

- **Identifier (UUID)** - A non-permanent identifier that is generated when the plug-in is first installed. It is mainly used to correlate the usage reports so that the usage data can be tracked over time. You can reset the identifier by selecting **Plug-in Options** > **Additional Options** > **Privacy** tab.
- **Version of the Operating System**
- **Version of Microsoft Outlook**
• Version of the Cisco Outlook Plug-in
• Language used for the Operating System
• Names of all the installed Outlook plug-ins

Account-Specific Information

The information whether non-standard reporting addresses are being used is collected.

Cisco Email Reporting Plug-in For Outlook General Settings

General settings for the Cisco Email Reporting Plug-in can be configured from the Options page.

Enable or Disable

By default, the Cisco Email Reporting Plug-in is enabled upon installation. The Cisco Email Reporting Plug-in can be disabled from the following place:

In Outlook 2010/2013/2016, go to File > Options and select Add-ins from the left navigation bar. Then, select COM Add-ins from the Manage drop-down menu at the bottom of the page, and click Go.
Configuring Basic Settings for the Outlook Plug-in

The end user can configure basic settings from the Cisco Email Reporting tab.

In Outlook 2010/2013/2016, click the **Plug-in Options** button on the ribbon or go to **File > Options > Add-ins > Add-in Options > Cisco Email Reporting**.

Cisco Email Reporting tab:

![Cisco Email Reporting Plug-in Options](image)

From this tab, the end user can enable reporting options by selecting the appropriate **Enable** check box. The end user can also enable additional options by selecting the **Additional Options** button. To further configure the settings, click the **Reporting Options** button. The end user can also use the Diagnostic tool to run a report on the Cisco Email Reporting Plug-in to send to Cisco Support when problem-solving. You can also configure the Plug-in to send anonymous usage information (general information about the Plug-in usage) to the server when Outlook is started.
Configuring the Outlook Plug-in to Check for Updates

To configure the plug-in to automatically check for updates, set the following parameters in the checkForUpdates section of the CommonComponentsConfig.xml file:

- **checkAutomatically**—Set to true or false to enable or disable the automatic checking of updates when Outlook starts. The default value is false.
- **serverURL**—Set to the URL that the plug-in uses to check whether a new version is available.
- **ignoredVersion**—Set to the version number that you want the plug-in to ignore when it looks for updates.

Update Notifications

If the Cisco Email Reporting Plug-in is configured to automatically check for updates and the current version of the Reporting plug-in is not the latest version, the following dialog box will be displayed when Outlook starts up:

Note

You need to have the appropriate rights to download the Cisco Email Reporting Plug-in application.
To check for updates after Outlook starts up, click the **About** button in the **Plug-in Options** window, and then click the **Check for updates** button in the following dialog box:

![Cisco Email Reporting Plug-In](image)

This product contains cryptographic features and is subject to United States and local country laws governing import, export, transfer and use. Delivery of Cisco cryptographic products does not imply third-party authority to import, export, distribute or use encryption. Importers, exporters, distributors and users are responsible for compliance with U.S. and local country laws. By using this product you agree to comply with applicable laws and regulations. If you are unable to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:


---

Warning: This computer program is protected by copyright law and international treaties. Unauthorized reproduction or distribution of this program, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to maximum extent possible under the law.

Copyright © 2011–2019 Cisco Systems, Inc. and/or its affiliates. All rights reserved.
Configuring Common Options Using the Config File

Options that are common to all Outlook accounts and the entire plug-in are contained in the CommonComponentsConfig.xml file. These options are:

- **diagnosticSupportAddress**—Specifies the email address of the recipient of the message that is sent when the Diagnostic Tool is run. The message contains the output of the Diagnostic Tool.

- **diagnosticReportSubject**—Specifies the subject of the message that is sent when the Diagnostic Tool is run.

- **showPluginOptions**—Set to true or false to enable or disable the Plug-in Options button that opens the Plug-in Options dialog box where you can use the reporting, diagnostic, and additional options. If set to false, the Plug-in Options button is hidden.

- **checkAutomatically**—Set to true or false to enable or disable the automatic checking of updates when Outlook starts. The default value is true. For more information, see the “Configuring the Outlook Plug-in to Check for Updates” section on page 4-5.

- **serverURL**—Set to the URL that the plug-in will use to check whether a new version is available.

- **callHomeAdminEnabled**—Set to true or false to enable or disable the sending of usage data when Outlook starts. The default value is true. If set to false, the user will not receive the notification about usage data collection and will not be able to send anonymous usage data to Cisco. For more information, see the “Configuring the Sending of Usage Data” section on page 4-2.

- **callHomeEnabled**—Set to true or false to enable or disable the sending of usage data when Outlook starts. The default value is true. If set to false, the user will not be able to send anonymous usage data to Cisco. For more information, see the “Configuring the Sending of Usage Data” section on page 4-2.

If these options are configured in the CommonComponentsConfig.xml file. To modify these options in a user environment, you must perform a mass installation with the UseCustomConfig option. For more information, see Using Custom Configuration Files, page 3-36
Reporting Unwanted Emails-Spam, Marketing, Virus, and Phishing Attacks

The reporting plug-in allows the end user to report to Cisco that an email received is spam, a marketing email, a phishing attack, or a virus. The end user can also report mail that is misclassified as spam, also sometimes called “ham.”

The end user can enable the Cisco Email Reporting Plug-in for Outlook via the Options page in Outlook. To enable Reporting:

In Outlook 2010/2013/2016, click the Plug-in Options button on the ribbon or go to File > Options > Add-ins > Add-in Options > Cisco Email Reporting. Select the Enable check box in the Reporting field of the Cisco Email Reporting tab.

Reporting Options

The Reporting settings are located on the Cisco Email Reporting page. To modify the Reporting settings:

In Outlook 2010/2013/2016, click the Plug-in Options button on the ribbon or go to File > Options > Add-ins > Add-in Options > Cisco Email Reporting and click the Reporting Options button.

There are also some reporting options that must be configured in the account config_{N} file. For more information, see Configuring the Encryption of Spam Reports, page 4-14

The following Reporting Accounts page displays all accounts configured in Outlook. To configure the reporting options for an account, select the appropriate account and the click the Options button. The reporting options for that account are then displayed.
The following account-specific Reporting Options page displays the reporting options for the selected account, and allows you to enable or disable their functionality. For more information, see the following table.
This table describes the reporting options the end user can configure.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Keep a copy of sent report</strong></td>
<td>By default, when the end user reports an email message to Cisco as spam, virus, misclassified spam, or virus, the reporting email the end user sent is deleted. Selecting this option prevents the email from being deleted.</td>
</tr>
<tr>
<td><strong>Display notification when a single email is successfully reported</strong></td>
<td>When the end user successfully reports an email as spam or virus, they can enable Outlook to display a success message in a dialog box. Clearing this option prevents this dialog box from displaying.</td>
</tr>
<tr>
<td><strong>Display notification when multiple emails are successfully reported</strong></td>
<td>When the end user successfully reports a group of emails as spam or virus, they can enable Outlook to display a success message in a dialog box. Clearing this option prevents this dialog box from displaying.</td>
</tr>
<tr>
<td><strong>Add message reporting options to the right-click menu</strong></td>
<td>By default, when the end user installs the Cisco Email Reporting Plug-in, the Reporting plug-in menu item is added to the Outlook right-click context menu. Clearing this option prevents this menu item from being added to the right-click context menu.</td>
</tr>
</tbody>
</table>
Using the Reporting Plug-in for Outlook

Overview

The Cisco Email Reporting Plug-in for Outlook allows the end user to submit feedback to Cisco about spam, virus, phishing, or marketing emails that are received in their inbox. The end user can let Cisco know if an email message is misclassified or if it should be treated as spam, for example. Cisco uses this feedback to update the email filters that prevent unwanted messages from being delivered to their inbox.

The Plug-in provides a convenient interface through Outlook menu bar and the right-click message menu to report spam, virus, phishing, marketing, and misclassified emails. After reporting an email, a message appears indicating that the report has been submitted. The messages the end user reports are used to improve Cisco email filters, helping to reduce the overall volume of unsolicited mail to their inbox.
Providing Feedback to Cisco

The Plug-in provides a toolbar in Outlook containing the following buttons: Spam, Not Spam, Virus, Phish, and Marketing.

These buttons are used to report spam, virus, phishing, and marketing emails (Phishing attacks are emails that link to “spoofed” and fraudulent websites designed to fool recipients into divulging personal financial data such as credit card numbers, account user names and passwords, social security numbers. For example, the end user might receive an email from infos@paypals.com that fraudulently requests their personal banking information). The end user can also use right-click context menu to report spam, misclassified mail, virus, phish, and marketing.

And, the end user can use the buttons in the message window to report spam, virus, phish, marketing, and misclassified mail (misclassified mail is mail that was erroneously marked as spam, virus, phish, or marketing).
Message Rotation for Reported Spam, Virus, Phish, or Marketing Emails

When messages are reported as spam, misclassified, virus, phish, or marketing, the messages are processed as follows.

Inbox messages:
- Inbox messages reported as spam, virus, phish, or marketing go into the Junk Email folder.
- Inbox messages reported as Not Spam stay in the Inbox folder.

Junk Messages:
- Junk messages reported as spam, virus, phish, or marketing stay in the Junk Email folder.
- Junk messages reported as Not Spam go in the Inbox folder.

If an email received is misclassified as spam (i.e. is filtered and sent to the Junk Email folder), the end user can report the email as misclassified by clicking the Not Spam button. This ensures that mail from the sender is not classified as spam in the future.

The end user can also mark misclassified email from the right-click context menu.
Configuring the Encryption of Spam Reports

To enable or disable the encryption of spam reports, configure the following two options in the “reporting” section of the account config_{N} file:

- **format** - Defines the format of the report. Supported values are:
  - `encrypted`—Specifies that the report is encrypted before sending.
  - `plain`—Specifies that the report is sent without encryption.
  The default value is encrypted.

- **subject** - Defines the subject of the report. You can include the report type (Spam, Ham, Virus, Phish, Marketing) in the subject by including the string “${reportType}.”

Configuring the Tracking of Spam Reports

To enable tracking, the reported messages marked as spam, virus, phish, or marketing, set the following parameter in the account config_{N} file:

`copyAddressInPlainFormat`—Specifies that a copy of the spam report is sent in plain (.raw) format to custom email address.

Changing Additional Settings

A log file writes and lists all actions that have occurred.

The Additional Options are located on the Cisco Email Reporting page. To modify the Additional Options:

In Outlook 2010/2013/2016, click the **Plug-in Options** button on the ribbon or go to **File > Options > Add-Ins > Add-in Options > Cisco Email Reporting > Additional Options.**
Cisco Email Reporting Add-in Options page:

Logging Tab

The end user can configure the following options from the Logging tab.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Logging</td>
<td>Select to enable logging for the Cisco Email Reporting plug-in.</td>
</tr>
</tbody>
</table>
Sending Usage Data Tab

The end user can configure the following option from the Sending Usage Data tab.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Send anonymous usage data to Cisco    | Enables the Cisco Email Reporting Plug-in to collect data that is used to improve the product. The following two types of information are collected and stored on Cisco servers for analysis:  
  • General information about the machine the plug-in is running on  
  • Account-specific information |
Privacy Tab

The end user can configure the following options from the Privacy tab.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resets Identifier</td>
<td>Resets the identifier used to correlate usage reports.</td>
</tr>
</tbody>
</table>

Errors and Troubleshooting

This section lists some of the common errors that can occur when using the Cisco Email Reporting Plug-in for Outlook, and it provides troubleshooting tips for fixing these errors.

Note

If the end user receives the same error message several times and the error disrupts the Cisco Email Reporting Plug-in for Outlook functionality, you can try to run the repair process. See Repairing Cisco Email Reporting Plug-in for Outlook Files, page 4-19. If the end user encounters the same error after running the repair process, follow the steps to provide Cisco feedback with the Diagnostic tool. See Running the Cisco Email Reporting Diagnostic Tool, page 4-21.

Outlook Startup Errors

Error occurred during configuration file initialization

The following messages may appear while Outlook is starting:

- An error occurred during <file_name> configuration file initialization. Some settings have been set to the default values.

- Config validation for account <account_address> has failed. Please set the correct configuration values or contact your administrator.

These error messages occur if some configuration values are invalid or some configuration files are corrupted in the %ALLUSERSPROFILE%\Cisco\Cisco Email Reporting Plug-In\<username> folder.
Solution

The Cisco Email Reporting Plug-in does not restore the default values of some reporting options in corrupted configuration files but turns off some reporting features instead. If the end user receives an error message repeatedly, run the repair process to fix the configuration files. See Repairing Cisco Email Reporting Plug-in for Outlook Files, page 4-19.

Configuration file not found

The following error message may display when Outlook is starting:

<file_name> configuration file was not found. Settings have been set to the default values.

Solution

The Cisco Email Reporting Plug-in does not restore the default values of some reporting options in corrupted configuration files but sets the corrupted values or tags to default values. If the end user receives an error message repeatedly, run the repair process to fix the configuration files. See Repairing Cisco Email Reporting Plug-in for Outlook Files, page 4-19.

Message Reporting Errors

Outlook does not recognize one or more names

The following message may appear when the end user clicks the Spam, Virus, Phish, Marketing, or Not Spam buttons in Outlook:

There was error during email reporting. Description: Outlook does not recognize one or more names.

This error occurs if the end user is using the Reporting plug-in and Outlook cannot recognize the format of the email message they are attempting to report. The end user will need to repair the Reporting plug-in file to ensure that they can report spam and phishing emails (as well as reporting legitimate mail as "Not Spam").
Solution

Run the repair process. See Repairing Cisco Email Reporting Plug-in for Outlook Files, page 4-19.

The connection to the server is unavailable

The following message may appear when the end user clicks Spam, Virus, Phish, Marketing, or Not Spam buttons plug-in buttons in Outlook and use IMAP protocol or "headers only" Outlook property:

Error: The connection to the server is unavailable. Outlook must be online or connected to complete this action.

This error occurs if the end user is trying to report message that downloaded partially (headers only) and the connection to the mail server is off. The Reporting plug-in cannot report a partially downloaded message, and it will attempt to connect to the mail server until it can download a full copy of the message to report.

Solution

Ensure that Outlook has a connection with the mail server before reporting emails with headers only.

Repairing Cisco Email Reporting Plug-in for Outlook Files

To repair Cisco Email Reporting Plug-in:

Step 1 Make sure Outlook is closed.
Step 2 Go to Control Panel > Add or Remove Programs.
Step 3 Find Cisco Email Reporting Plug In in the list of programs and click Uninstall/Change.
Step 4 Click Repair. The installer repair process runs.
Step 5 Perform the action that caused the error. If the same error occurs after running the repair process, follow the steps to provide Cisco feedback with the Diagnostic tool. See Running the Cisco Email Reporting Diagnostic Tool, page 4-21.

Troubleshooting Using the Diagnostic Tool

The Cisco Email Reporting Plug-in includes a diagnostic tool to help Cisco Support in troubleshooting problems. The Diagnostic tool collects important data from the Plug-in tool that can be sent to Cisco Support to aid them in problem-solving.

The end user may want to use the diagnostic tool if they are receiving errors or if they have issues with the Cisco Email Reporting Plug-in that the repair procedure does not resolve. You can also use the diagnostic tool to share critical information with Cisco engineers when reporting a bug.

See Repairing Cisco Email Reporting Plug-in for Outlook Files, page 4-19 or Running the Cisco Email Reporting Diagnostic Tool, page 4-21.

Note If you experience errors, review Errors and Troubleshooting, page 4-17 for troubleshooting tips.

Data Collected by the Cisco Email Reporting Diagnostic Tool

The Diagnostic tool collects the following information from your computer:

- Registration information about COM components
- Environment variables
- Cisco Email Reporting Plug-in output files
- Information about Windows and Outlook
- Your system user name and PC name
- Information about other Outlook plug-ins
- Outlook related Windows Event Log entries
Running the Cisco Email Reporting Diagnostic Tool

The Cisco Email Reporting Diagnostic tool can be run from any one of the following places:

- **From the Cisco Email Reporting options tab.** Typically, you run the diagnostic tool from the Cisco Email Reporting options tab.

- **From the “Program Files\ Cisco Email Reporting Plug-in” folder** (typically C:\Program Files\Cisco\Cisco Email Reporting Plug-in). This is the folder where your Cisco Email Reporting Plug-in is installed.

- **From the Start Menu> All Programs > Cisco Email Reporting Plug-in > Cisco Email Reporting Plug-in Diagnostic.**

Running the Diagnostic Tool from the Outlook Options Page

**Step 1**

Go to the following to run the Diagnostic tool:

In Outlook 2010/2013/2016, click the **Plug-in Options** button on the ribbon or go to **File > Options > Add-Ins > Add-in Options > Cisco Email Reporting > Run Diagnostic.**
Step 2  Wait a few seconds to allow the Diagnostic tool to collect data. When the Diagnostic tool finishes collecting data, it displays a message indicating that it successfully collected data.

The Diagnostic tool generates the CiscoReportingDiagnosticReport.zip file and saves it to the current user’s My Documents folder. The end user can then send the file to their system administrator or the administrator can send it to their Cisco Support representative. To view the report, double-click the CiscoReportingDiagnosticsReport.zip file.

Running the Diagnostic Tool from the Program Files

There are two ways to run the diagnostic tool from the Program files.

- Run the Diagnostic tool from Start > Programs > Cisco Email Reporting Plug-in > Cisco Email Reporting Plug-in Diagnostic.

-OR-
• Go to the folder where Cisco Email Reporting Plug-in was installed (typically C:\Program Files\Cisco\Cisco Email Reporting Plug-in) and double-click the Cisco.EmailReporting.Framework.Diagnostic.exe file.

Uninstalling the Cisco Email Reporting Plug-in

You can uninstall the Cisco Email Reporting Plug-in using the Control Panel > Add/Remove Program option or by running the setup.exe program.

During the uninstall, the following items are removed:

• All registry entries made by the plug-in.
• Entry for the plug-in from the Add/Remove programs listing.
• Some of the files related to the plug-in.

Note Not all files related to the plug-in are removed.

• The plug-in toolbar (removed from Outlook).

Note Uninstalling the plug-in does not affect Outlook performance. Outlook must be closed during the uninstall.

To uninstall the Cisco Email Reporting Plug-in for Outlook:

There are two ways to uninstall the Cisco Email Reporting Plug-in for Outlook:

Step 1 Click Start > Control Panel > Add/Remove Programs.

Step 2 Select Cisco Email Reporting Plug-In and click Uninstall/Change > Next > Remove.

The second option to uninstall is

Double-click the plug-in setup file (the file used to install the plug-in) and select the Remove option to uninstall the Cisco Email Reporting Plug-in.
Cisco End User License Agreement

For information about the Cisco End User License Agreement, see http://www.cisco.com/web/products/software/licensing_center.html.