Cisco Configuration Professional
Voice User’s Guide

1.1

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
http://www.cisco.com
Tel: 408 526-4000
800 553-NETS (6387)
Fax: 408 527-0883

Text Part Number: OL-16991-02
CONTENTS

Configuring Voice Mode  1-2
  Voice Mode Reference  1-3
  Voice Mode  1-3

Configuring Voice Gateway Mode  2-1
  Device Voice Gateway Mode Reference  2-1
  Voice Gateway Mode  2-2

Configuring SRST Settings  3-1
  SRST Settings Reference  3-1
  Configure SRST Settings  3-2

Configuring Trunks  4-1
  Trunks Reference  4-2
  Configure an Analog Trunk  4-3
  Edit an Analog Trunk  4-4
  Configure a Digital Trunk  4-9
  Edit a Digital Trunk  4-10

Configuring Incoming (Dial Plan)  5-2
  Incoming (Dial Plan) Reference  5-2
  Configure Incoming (Dial Plan)  5-2
  Edit or Create Incoming Dial Plans  5-3

Configuring Outgoing Calls  5-5
  Outgoing Call Reference  5-5
  Configuring Outgoing Calls  5-5
Contents

Configuring Intersite VoIP 5-8
  Intersite VoIP Reference 5-8
    Configure Intersite VoIP 5-8
    Edit or Create a Intersite VoIP Entry 5-9

Configuring Gateway VoIP 5-10
  Gateway VoIP Reference 5-10
    Configure Gateway VoIP 5-10
    Edit or Create a Gateway VoIP Entry 5-11

Configuring Telephony Settings 6-1
  Telephony Settings Reference 6-1
    Configure Telephony Settings 6-2

Configuring Extensions 7-2
  Extension Reference 7-2
    Configuring Extensions 7-2
    Edit or Create an Extension 7-3

Configuring Phones 7-5
  Phone Reference 7-5
    Configure a Phone 7-5
    Edit or Create a Phone Configuration 7-6

Configuring User Settings 7-7
  User Settings Reference 7-7
    Configure User Settings 7-7
    Edit or Create User Configurations 7-8

Configuring After-Hours Tollbar 8-2
  After-Hour Tollbar Reference 8-2
    Configure After-Hour Tollbar 8-3

Configuring Call Conference 8-7
Call Conference Reference 8-7
  Configure Call Conference 8-7

Configuring Call Park 8-9
  Call Park Reference 8-9
    Configure Call Park 8-9
    Edit or Create Call-Park Parameters: General Tab 8-11
    Edit or Create Call-Park Parameters: Advanced Tab 8-11

Configuring Call Pickup Groups 8-13
  Call Pickup Group Reference 8-14
    Configure Pickup Group 8-14
    Edit or Create a Pickup Group 8-14

Configuring Directory Services 8-16
  Directory Services Reference 8-16
    Configure Directory Services 8-16
    Edit or Add a Directory Entry 8-17

Configuring Hunt Groups 8-18
  Hunt Group Reference 8-18
    Configure Hunt Groups 8-18
    Set Extension Timeout 8-21

Configuring Intercom 8-24
  Intercom Reference 8-24
    Configure Intercom 8-24
    Edit or Create Intercom 8-25

Configuring Night Service Bell 8-26
  Night Service Bell Reference 8-27
    Configure Night Service Bell 8-27
    Configuring Night Service Weekly Schedule 8-27
    Configuring Night Service Annual Schedule 8-28
<table>
<thead>
<tr>
<th>Configuration</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring Night Service Daily Schedule</td>
<td>8-29</td>
</tr>
<tr>
<td>Configuring Night Service Code</td>
<td>8-30</td>
</tr>
<tr>
<td>Configuring Paging Numbers</td>
<td>8-31</td>
</tr>
<tr>
<td>Paging Number Reference</td>
<td>8-32</td>
</tr>
<tr>
<td>Configure Paging Numbers</td>
<td>8-32</td>
</tr>
<tr>
<td>Edit or Create a Paging Number</td>
<td>8-33</td>
</tr>
<tr>
<td>Set Phones Paging Type Preference</td>
<td>8-34</td>
</tr>
<tr>
<td>Configuring Paging Groups</td>
<td>8-35</td>
</tr>
<tr>
<td>Paging Groups Reference</td>
<td>8-35</td>
</tr>
<tr>
<td>Configure Paging Groups</td>
<td>8-36</td>
</tr>
<tr>
<td>Edit or Create a Paging Group</td>
<td>8-36</td>
</tr>
<tr>
<td>Configuring Phone Softkey Templates</td>
<td>8-38</td>
</tr>
<tr>
<td>Phone Softkey Template Reference</td>
<td>8-39</td>
</tr>
<tr>
<td>Configure Phone Softkey Templates</td>
<td>8-39</td>
</tr>
<tr>
<td>Edit or Create a Phone Softkey Template</td>
<td>8-40</td>
</tr>
<tr>
<td>Associate Phones</td>
<td>8-43</td>
</tr>
<tr>
<td>Configuring Voicemail</td>
<td>9-1</td>
</tr>
<tr>
<td>Voicemail Reference</td>
<td>9-1</td>
</tr>
<tr>
<td>Configure Voicemail</td>
<td>9-2</td>
</tr>
<tr>
<td>Configuring the Call-in Number</td>
<td>9-3</td>
</tr>
<tr>
<td>Call-in Number Reference</td>
<td>9-3</td>
</tr>
<tr>
<td>Configure the Call-in Numbers</td>
<td>9-4</td>
</tr>
<tr>
<td>Edit or Create Cisco Unity Express Call-in Numbers</td>
<td>9-4</td>
</tr>
<tr>
<td>Launching Cisco Unity Express</td>
<td>9-6</td>
</tr>
<tr>
<td>Cisco Unity Express Reference</td>
<td>9-6</td>
</tr>
<tr>
<td>Launch Cisco Unity Express</td>
<td>9-6</td>
</tr>
<tr>
<td>Configuring Cisco Unity Express IP Address</td>
<td>9-7</td>
</tr>
<tr>
<td>Cisco Unity Express IP Address Configuration Reference</td>
<td>9-8</td>
</tr>
</tbody>
</table>
Voice Mode

If Counterpoint discovers that the device is not configured for voice, you are prompted to configure the router in one of the voice modes before you can configure any of the other voice features.

You can set the device to be one of the following:

- A host for Cisco Unified Communications Manager Express (CCME). In this mode, the Integrated Services Router (ISR) acts as a call processing agent, and all the phones are registered with the ISR. You should configure all dial plans on this router to process the call. Cisco Configuration Professional provides three options: direct inward dial, outgoing calls, and intersite VoIP.

- A gateway to the router hosting CCME. Call control and media translation are separated into two devices, the voice gateway handles media translation and a call agent handles call control. A call-control device controls and tracks the state of each voice port on the gateway. Typically, public switched telephone network (PSTN) connections, such as FXO, FXS, and PRI lines, terminate in the gateway. The gateway translates calls made between the PSTN and the IP network. The gateway does not make any call routing decisions; it routes calls in response to instructions from the call agent, Cisco Unified CallManager.

- Cisco Unified Survivable Remote Site Telephony (SRST) fallback for the CCME device when the link or the application is down. During fallback, the router uses the H.323 default call-routing application when it looses contact with the Cisco Unified CallManager. When using fallback, you must configure at least one dial peer with a destination pattern that routes outbound calls if Cisco Unified CallManager is not available. That destination pattern is typically a wild card pattern that matches all outbound call, such as "9T." Typically calls are forwarded to PSTN using plain old telephone service (POTS) dial-peers. Occasionally the calls are forwarded to a different
Features Available in each Voice Mode

The voice features you can configure depend on the voice mode that you choose. When you choose the Cisco Unified CME mode, you can configure these features:

- Telephony Settings
- Users, Phones, and Extensions
- PSTN Trunks
- Dial Plans
- Telephony Features
- Voice Mail and Auto Attendant
- Firmware

Use router as Gateway to Cisco Unified CM provides these features:

- Gateway Mode
- PSTN Trunks
- Dial Plans

Use Cisco Unified SRST when link to Cisco Unified CM is down provides these features:

- Gateway Mode
- SRST Settings
- PSTN Trunks
- Dial Plans

gateway with VoIP dial-peers. Incoming dial-peers can also be configured to serve incoming calls during fallback. During normal operation of gateway, these dial peers are not used.

You can also erase the configuration.

This chapter contains the following sections:

- Features Available in each Voice Mode
- Voice Mode Reference
None provides only the Voice Mode feature.
To configure the device

**Voice Mode Reference**

The following topic describes the window used to configure voice mode:

- Configure Voice Mode

**Configure Voice Mode**

In the Voice Mode screen, you can select the router operating mode.

**How to get to this screen**
Click Configure > Voice > Voice Mode.

**How to Use this Screen**
When you first click the Voice folder, Voice Mode is the only branch visible. In order to display the voice features that you want to configure, do the following:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose the voice mode that you want the device to operate in. For example, choose Use router as Cisco Unified CME.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click <strong>Apply</strong> to save your choice.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the Voice folder again. The configuration options available for the mode that you chose are displayed.</td>
</tr>
</tbody>
</table>
## Field Reference

### Table 1-1  Voice Mode

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
</table>
| Use router as Cisco Unified CME             | Use this router as a Cisco Unified Communications Manager Express (CCME) configuration device. If you choose this option, click Apply, and then click on the Voice node again. The tree displays the following options:  
  - Telephony Settings  
  - Users, Phones, and Extensions  
  - PSTN Trunks  
  - Dial Plans  
  - Telephony Features  
  - Voice Mail and Auto Attendant  
  - Firmware |
| Use router as a gateway to Cisco Unified CM | Use this router as a gateway to CCME. If you choose this option, click Apply, and then click on the Voice node again. The tree displays the following options:  
  - Gateway Mode  
  - PSTN Trunks  
  - Dial Plans |
| Use Cisco SRST when link to Cisco Unified CM is down | Fall back to Survivable Remote Site Telephony (SRST) if the link to CCME goes down. If you choose this option, click Apply, and then click on the Voice node again. The tree displays the following options:  
  - Gateway Mode  
  - SRST Settings  
  - PSTN Trunks  
  - Dial Plans |
| None                                         | Select None to erase all configuration parameters and return the device to the default configuration.                                         |
Configuring Voice Gateway Mode

Cisco Configuration Professional supports a gateway mode with Media Gateway Control Protocol (MGCP), Session Initiation Protocol (SIP), or H.323 protocol for communication from the gateway. When you change the mode from Voice Mode to Gateway Mode, all the configuration that was done as part of Voice Mode, that is telephony service and the rest of all voice features, is erased on the device and from the database. The configuration on CUE is also erased. If SRST is configured, that is also erased.

This chapter contains the following sections:

- Configuring Voice Gateway Mode
- Voice Gateway Mode

Configuring Voice Gateway Mode

Configure voice gateway mode (the gateway to Cisco Communications Manager (CCM)) by selecting the gateway type and setting the related parameters.

Device Voice Gateway Mode Reference

The following topic describes the window used to configure voice gateway mode:

- Voice Gateway Mode
- Configuring Voice Gateway Mode
Voice Gateway Mode

In the Gateway Mode screen, you can select the gateway and operating parameters.

Incoming dial plans configured on PSTN trunks translate E.164 numbers into extensions. Gateway VoIP dial plans forward those calls to a Cisco CallManager. For redundancy, there can be more than one Cisco CallManager. If communication with the primary Cisco CallManager fails, the gateway queries the secondary Cisco CallManager to process the call, and so forth. In Cisco Configuration Professional, up to three Cisco CallManagers are supported.

How to get to this screen
Click Configure > Voice > Gateway Mode.

Related Link
- Configuring Voice Gateway Mode

Field Reference

<table>
<thead>
<tr>
<th>Table 2-1 Voice Gateway Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
</tbody>
</table>
| Gateway Type | Choose one of these protocols:  
• MGCP  
• H.323  
• SIP |
| Primary Call Manager IP Address/Host Name | After the last active call ends (when there is no voice call in setup mode on the gateway), control returns to this primary Cisco CallManager. |
| Secondary Call Manager IP Address/Host Name | After the last active call ends, control returns to the secondary Cisco CallManager if the primary Cisco CallManager is not available. |
| Tertiary Call Manager IP Address/Host Name | After the last active call ends, control returns to the tertiary Cisco CallManager if the primary and secondary Cisco CallManager is not available. |
| TFTP Server IP Address/Host Name | Location (audio file URL or directory in the TFTP server) where the audio files are stored. |
## Table 2-1  Voice Gateway Mode (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary Call Manager Preference</td>
<td>Preferred order of a dial peer within a rotary hunt group. The range is an integer from 0 to 10, where the lower the number, the higher the preference. Default is 0 (highest preference).&lt;br&gt;If you have configured a Secondary Call Manager IP, the preference is automatically calculated to be the preference of the Primary Call Manager plus 1.&lt;br&gt;If you have configured Tertiary Call Manager IP, the preference is automatically calculated to be the preference of the Primary Call Manager plus 2.</td>
</tr>
<tr>
<td>Codec Type</td>
<td>Voice coder rate of speech for a dial peer. If you select the H.323 or SIP protocol type and these dial peers are not active, you are configuring dummy dial peers (dial peers in shutdown state). To set dial peers to an active state, select H.323 or SIP and configure the parameters. Then go to Configuring Gateway VoIP and set the parameters.&lt;br&gt;If you select the MGCP protocol type, use the Cisco Unified Communications Manager application to configure active dial peers.</td>
</tr>
</tbody>
</table>
Configuring SRST Settings

Cisco Unified Survivable Remote Site Telephony (SRST) is embedded in the software running on Cisco routers. This chapter describes how to set parameters such as licenses, date format, and time format.

This chapter contains the following sections:

- Configuring SRST Settings
- Configure SRST Settings

Configuring SRST Settings

Configure SRST Settings by selecting the related parameters.

Related Link

- Configure SRST Settings

SRST Settings Reference

The following topic describes the window used to configure voice gateway mode:

- Configuring SRST Settings
- Configure SRST Settings
Configure SRST Settings

In the SRST Settings screen, you can select the license and format parameters.

**How to get to this screen**
Click **Configure > Voice > SRST Settings**.

**Field Reference**

**Table 3-1  SRST Settings**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Type</td>
<td>License based on the maximum number of phones.</td>
</tr>
<tr>
<td>Phone Registration Voice IP Address</td>
<td>SRST router IP address.</td>
</tr>
<tr>
<td>Message on Fallback Phones</td>
<td>Status message displayed on the phones when they are in fallback mode.</td>
</tr>
<tr>
<td>Date Format</td>
<td>Format that the date displays in on the phones.</td>
</tr>
<tr>
<td>Time Format</td>
<td>Format that the time, either 12-hour or 24-hour clock, displays in on the phones.</td>
</tr>
<tr>
<td>Maximum number of Extensions</td>
<td>Maximum number of extensions the device can support.</td>
</tr>
</tbody>
</table>

**Related Link**
- Configuring SRST Settings
Configuring PSTN Trunks

The PSTN trunk configuration screens allow you to view and edit trunk voice configurations for each port on the device.

This chapter contains the following sections:

- Configure an Analog Trunk
- Configure a Digital Trunk

Configuring Trunks

A trunk (tie-line) is a permanent point-to-point communication line between two voice ports. Trunk lines are the phone lines coming into the PBX from the telephone provider. This differentiates these incoming lines from extension lines that leave the PBX and usually lead to individual phone sets. Trunking saves cost, because there are usually fewer trunk lines than extension lines, since it is unusual in most offices to have all extension lines in use for external calls at once.

FXS and DID Modes

Foreign Exchange Station (FXS) is a two-wire telephone communication mode. An FXS interface connects directly to a standard telephone and supplies ring, voltage, and dial tone. Cisco's FXS interface is an RJ-11 connector that allows connections to basic telephone service equipment, keysets, and PBXs.

Direct Inward Dialing (DID) is a service offered by telephone companies that enables callers to dial directly an extension on a PBX or packet voice system without the assistance of an operator or automated call attendant. This service makes use of DID trunks, which forward only the last three to five digits of a
phone number to the PBX, router, or gateway. For example, a company has phone extensions 555-1000 to 555-1999. A caller dials 555-1234 and the local central office (CO) forwards 234 to the PBX or packet voice system. The PBX or packet voice system then rings extension 234. This entire process is transparent to the caller.

**FXO Modes**

FXO is a two-wire telephone communication mode. An FXO interface connects to the public switched telephone network (PSTN) central office and is the interface offered on a standard telephone. Cisco FXO interface is an RJ-11 connector that allows an analog connection at the PSTN central office or to a station interface on a PBX.

**Trunks Reference**

The following topics describe the windows used to configure trunk ports:

- Configure an Analog Trunk
- Edit an Analog Trunk
- Analog Trunks: General Settings Tab
- Analog Trunks: Advanced Signal Settings Tab
- Analog Trunks: Advanced Audio Settings Tab
- Analog Trunks: Advanced Timer Settings Tab
- Configure a Digital Trunk
- Edit a Digital Trunk
- Digital Trunks: T1/E1 Settings
- Digital Trunks: PRI or BRI General Settings Tab
- Digital Trunks: Advanced PRI or BRI Settings Tab
- Digital Trunks: Advanced PRI or BRI Audio Tab
Configure an Analog Trunk

You can view and edit an analog trunk voice configuration for each port on the device.

How to get to this screen
Click Configure > Voice > PSTN Trunks > Analog Trunks

Related Links
- Configuring Trunks
- Edit an Analog Trunk
- Analog Trunks: General Settings Tab
- Analog Trunks: Advanced Signal Settings Tab
- Analog Trunks: Advanced Audio Settings Tab
- Analog Trunks: Advanced Timer Settings Tab

Field Reference

<table>
<thead>
<tr>
<th>Table 4-1</th>
<th>Trunks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element</td>
<td>Description</td>
</tr>
<tr>
<td>Trunk Type</td>
<td>Connection type.</td>
</tr>
<tr>
<td>Hardware</td>
<td>Device providing the trunk connection.</td>
</tr>
<tr>
<td>Location</td>
<td>Location of the voice port.</td>
</tr>
<tr>
<td>Description</td>
<td>A string that identifies a trunk.</td>
</tr>
<tr>
<td>Destination Number</td>
<td>The Destination Number is populated for FXO cards. It is blank for FXS or DID cards.</td>
</tr>
</tbody>
</table>
Edit an Analog Trunk

The screen is subdivided by tabs. The active content in the tabs varies depending on which port you are configuring.

If an analog phone is configured to a FXS port, the FXS port cannot be configured as a trunk by using Cisco Configuration Professional and it is not listed in the Trunks window. To use Cisco Configuration Professional to configure an FXS port as a trunk, delete any analog phone configuration. The FXS port is released to be configured as a trunk.

You cannot reset an analog voice port to the factory default configuration by using Cisco Configuration Professional. You must reset the configuration to factory defaults manually.

Related Links

- Configure an Analog Trunk
- Configuring Trunks
- Configure an Analog Trunk
- Analog Trunks: General Settings Tab
- Analog Trunks: Advanced Signal Settings Tab
- Analog Trunks: Advanced Audio Settings Tab
- Analog Trunks: Advanced Timer Settings Tab

Analog Trunks: General Settings Tab

In the General Settings tab, enter settings for trunk shown in Table 4-2.

How to get to this screen
Click Configure > Voice > PSTN Trunks > Analog Trunks > (select a) Trunk Type > Edit > General Settings tab.
Field Reference

Table 4-2 General Settings Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Card Type</td>
<td>If you are editing a FXS-DID port, choose the <strong>FXS</strong> or <strong>DID</strong> radio button. If the trunk type is changed from DID to FXS, inputs for the Battery Reversal and Caller ID options are disabled until the change is applied to the device by clicking <strong>Apply</strong>.</td>
</tr>
<tr>
<td>Label</td>
<td>Enter the identifying information for the port.</td>
</tr>
<tr>
<td>Shutdown Voice Port?</td>
<td>To shut down the voice port, click the <strong>Yes</strong> radio button. To bring up the voice port, click the <strong>No</strong> radio button.</td>
</tr>
<tr>
<td>Station Number (FXS and FXO ports)</td>
<td>Enter the station number associated with the voice port. This information is sent when a user places a call.</td>
</tr>
<tr>
<td>Destination Number (FXO ports)</td>
<td>Enter a default destination number for incoming telephone calls.</td>
</tr>
<tr>
<td>Station ID (FXS ports)</td>
<td>Enter the calling station ID. This information is sent when a user places a call.</td>
</tr>
<tr>
<td>Send Caller ID (FXS ports)</td>
<td>To send caller ID information when a user places a call, click the <strong>Yes</strong> radio button. To prevent caller ID information from being sent, click the <strong>No</strong> radio button.</td>
</tr>
<tr>
<td>Receive Caller ID (FXO ports)</td>
<td>To receive caller ID information, click the <strong>On</strong> radio button. To block the caller ID information, click the <strong>Off</strong> radio button.</td>
</tr>
</tbody>
</table>

Analog Trunks: Advanced Signal Settings Tab

On the Advanced Signal Settings tab, enter settings for FXS or DID signals shown in Table 4-3.

How to get to this screen

Click **Configure > Voice > PSTN Trunks > Analog Trunks > (select a) Trunk Type > Edit > Advanced Signal Settings tab**.
Field Reference

Table 4-3  Advanced Signal Settings Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port Signaling</td>
<td>Select the port signaling. For PRI, select <strong>loopStart</strong> or <strong>groundStart</strong> from the list. For BRI, select <strong>wink-start</strong>, <strong>immediate</strong>, or <strong>delay-dial</strong>.</td>
</tr>
<tr>
<td>Supervisory Disconnect (FXO port)</td>
<td>Select the signal from the drop-down list. Signaling protocols such as loop-start do not provide means for quickly detecting when the call initiation is terminated prior to call connection. Supervisory disconnect quickly makes this determination and frees valuable resources for other calls.</td>
</tr>
<tr>
<td>Dual Tone Detection (FXO port)</td>
<td>Click the <strong>Disable</strong> radio button to configure the FXO voice port to detect voice, fax, and modem traffic when calls are answered. Click the <strong>Enable</strong> radio button to configure the FXO voice port so calls are not recorded as connected until answer supervision is triggered.</td>
</tr>
</tbody>
</table>
| Battery Reversal                     | To disable battery reversal, click the **Disable** radio button. To enable battery reversal, click the **Enable** radio button.  
FXS ports normally reverse battery upon call connection. If an FXS port is connected to an FXO port that does not support battery reversal detection, disable battery-reversal on the FXS port to prevent unexpected behavior. |

**Analog Trunks: Advanced Audio Settings Tab**

In the Advanced Audio Settings tab, enter settings for audio shown in Table 4-4.

**How to get to this screen**

Click **Configure > Voice > PSTN Trunks > Analog Trunks > (select a) Trunk Type > Edit > Advanced Audio Settings** tab.
### Field Reference

**Table 4-4**  
**Advanced Audio Settings Tab**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Echo Cancel</td>
<td>To enable the Cisco-proprietary G.165 echo canceller (EC), click the <strong>On</strong> radio button. To disable the Cisco-proprietary G.165 echo canceller (EC), click the <strong>Disable</strong> radio button. Disabling echo cancellation might cause the remote side of a connection to hear an echo. Because echo cancellation is an invasive process that can minimally degrade voice quality, this command should be disabled if it is not needed.</td>
</tr>
<tr>
<td>Echo Trail</td>
<td>Choose the echo trail wait time from the list. Echo cancellers are, by design, limited by the total amount of time they will wait for the reflected speech to be received. This amount of time is called an echo trail. The echo trail default is 64 milliseconds. VoIP also has configurable echo trails of 8, 16, 24, and 32 milliseconds.</td>
</tr>
<tr>
<td>Impedance</td>
<td>Choose the impedance from the list. 600 ohm impedance is normally used for FXS applications. Complex line impedance is normally used for FXO applications that connect to a PSTN. Usually, either position will provide acceptable performance.</td>
</tr>
<tr>
<td>Increase Receive Volume</td>
<td>To change the receive volume, select the volume from the drop-down list.</td>
</tr>
<tr>
<td>Decrease Volume Transmit</td>
<td>To change the transmit volume, select the volume from the drop-down list.</td>
</tr>
<tr>
<td>Nonlinear Processing</td>
<td>To disable nonlinear processing, click the <strong>Disable</strong> check box. When enabled, it shuts off any signal if no near-end speech is detected.</td>
</tr>
</tbody>
</table>
Analog Trunks: Advanced Timer Settings Tab

The Advanced Timer Settings Tab displays if you are configuring a FXO or FXS port. Enter settings for timers shown in Table 4-5.

How to get to this screen
Click Configure > Voice > PSTN Trunks > Analog Trunks > (select a) Trunk Type > Edit > Advanced Timer Settings tab.

Field Reference

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeouts Initial</td>
<td>Enter the number of seconds the system waits for the caller to input the first digit of the dialed digits.</td>
</tr>
<tr>
<td>Interdigit</td>
<td>Enter the length of time allotted for a user to dial a telephone number.</td>
</tr>
<tr>
<td>Ringing</td>
<td>Enter the length of time for which a caller can continue ringing a telephone when there is no answer.</td>
</tr>
<tr>
<td>Wait to release ports</td>
<td>Enter the time a voice port can be held in a failure state.</td>
</tr>
<tr>
<td>Call disconnect</td>
<td>Enter the delay time for releasing the calling voice port after a disconnect tone is received from the called voice port.</td>
</tr>
</tbody>
</table>
Configure a Digital Trunk

You can view and edit a digital trunk voice configuration for each port on the device.

Cisco routing devices support ISDN PRI and ISDN BRI. Both media types use bearer (B) channels and data (D) channels.

Basic Rate Interface (BRI) provides two 64 kbps B channels, and one 16 kbps D channel that carries signaling traffic. The D channel is used by the telephone network to carry instructions about how to handle each of the B channels. ISDN BRI (also referred to as 2B + D) provides a maximum transmission speed of 128 kbps.

Primary Rate Interface (PRI) consists of a single 64 kbps D channel plus 23 (T1) or 30 (E1) B channels.

Only ISDN-PRI Voice mode is supported; Data mode or Voice and Data mode are not supported:

- If the controller is configured as ISDN-PRI, the mode is set to ISDN-PRI and cannot be modified. If the controller is configured to support other voice modes, the modes are displayed in a summary table.
- If you have configured the controller timeslots as ds0-group, channel-group, or tdm-group, Cisco Configuration Professional displays the Mode as CAS and you cannot edit the configuration.
- If the controller is configured with pri-group with ds0-group, channel-group, or tdm-group, you cannot edit the configuration.

If the device is already configured, Cisco Configuration Professional reads and displays the configuration. If the controller has just the default configuration, Cisco Configuration Professional does not display the configuration. You must configure the pri-timegroup to configure the port by using Cisco Configuration Professional.

If T1/E1 card is configured as Media Gateway Control Protocol (MGCP) OOB (out-of-band), Cisco Configuration Professional does not allow you to edit configuration on that port.

How to get to this screen

Click Configure > Voice > PSTN Trunks > Digital Trunks
Related Links

- Edit a Digital Trunk
- Digital Trunks: T1/E1 Settings
- Digital Trunks: PRI or BRI General Settings Tab
- Digital Trunks: Advanced PRI or BRI Settings Tab
- Digital Trunks: Advanced PRI or BRI Audio Tab

Field Reference

Table 4-6 Trunks

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trunk Type</td>
<td>Connection type.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the voice port.</td>
</tr>
<tr>
<td>Location</td>
<td>Location of the interface.</td>
</tr>
<tr>
<td>Associated Timeslots</td>
<td>Time slot range. 1 through 31 for E1. 1 through 24 for T1.</td>
</tr>
<tr>
<td>Mode Type</td>
<td>Connection mode of the interface.</td>
</tr>
</tbody>
</table>

Edit a Digital Trunk

The screen is subdivided by tabs. The active content in the tabs varies depending on which port you are configuring.

The first time a BRI port is configured as a trunk by using the Digital Trunks > Edit dialog, the global and interface parameters are applied to the device. For T1/E1 ports, the switch type is configured only in global mode.

If network clock type is not supported for switch type selected on the BRI trunk edit dialog and the PRI trunk edit dialog, Cisco Configuration Professional automatically changes the value of the network clock. For example, if you selected NTT for the switch type, only user mode is supported. If you change the value to network mode, Cisco Configuration Professional automatically changes it back to user mode and displays the warning message, "Network mode is not supported."
Digital Trunks: T1/E1 Settings

The Digital T1/E1 Packet Voice Trunk Network Module provides the gateway to the PSTN allowing users to gain access to the public telephone network to and from traditional PBX, phone, fax, key communication systems, as well as IP telephony.

Enter settings for T1 or E1 trunk shown in Table 4-7.

How to get to this screen

Click Configure > Voice > PSTN Trunks > Digital Trunks > (select a) Trunk Type > Edit.

Field Reference

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Gateway type.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the gateway.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Telephone Mode Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mode</td>
</tr>
<tr>
<td>Signaling Type</td>
</tr>
<tr>
<td>Timeslots From</td>
</tr>
</tbody>
</table>

Enter a pair of numbers that indicate a range of timeslots. For T1, allowable values are from 1 to 24.
Digital Trunks: PRI or BRI General Settings Tab

In the General Settings tab, enter settings for trunk shown in Table 4-8.

**How to get to this screen**

- Click Configure > Voice > PSTN Trunks > Digital Trunks > (select a) Trunk Type > Edit > PRI General Settings tab.
- Click Configure > Voice > PSTN Trunks > Digital Trunks > (select a) Trunk Type > Edit > BRI General Settings tab.
Chapter 4  Configuring PSTN Trunks

Field Reference

Table 4-8  PRI or BRI General Settings Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Description of the interface.</td>
</tr>
<tr>
<td>Shutdown Voice Port</td>
<td>To shut down the voice port, click the Yes radio button. To bring up the voice port, click the No radio button.</td>
</tr>
</tbody>
</table>

Digital Trunks: Advanced PRI or BRI Settings Tab

On the Advanced PRI Settings tab or the Advanced BRI Settings tab, enter settings for PRI signals shown in Table 4-9.

How to get to this screen

- Click Configure > Voice > PSTN Trunks > Digital Trunks > (select a) Trunk Type > Edit > Advanced PRI Settings tab.
- Click Configure > Voice > PSTN Trunks > Digital Trunks > (select a) Trunk Type > Edit > Advanced BRI Settings tab.
## Field Reference

### Table 4-9  Advanced PRI or BRI Settings Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ISDN Switch Type</td>
<td>Select the PRI switch type:</td>
</tr>
<tr>
<td></td>
<td>- primary-4ess  Lucent 4ESS switch type for the U.S.</td>
</tr>
<tr>
<td></td>
<td>- primary-5ess  Lucent 5ESS switch type for the U.S.</td>
</tr>
<tr>
<td></td>
<td>- primary-dms100 Northern Telecom DMS-100 switch type for the U.S.</td>
</tr>
<tr>
<td></td>
<td>- primary-dpnss DPNSS switch type for Europe</td>
</tr>
<tr>
<td></td>
<td>- primary-net5  NET5 switch type for UK, Europe, Asia and Australia</td>
</tr>
<tr>
<td></td>
<td>- primary-ni   National ISDN Switch type for the U.S.</td>
</tr>
<tr>
<td></td>
<td>- primary-ntt  NTT switch type for Japan</td>
</tr>
<tr>
<td></td>
<td>- primary-qsig QSIG switch type</td>
</tr>
<tr>
<td></td>
<td>- primary-ts014  TS014 switch type for Australia (obsolete)</td>
</tr>
<tr>
<td>Select the BRI switch type:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- basic-1tr6  German 1TR6 ISDN switches</td>
</tr>
<tr>
<td></td>
<td>- basic-5ess  AT&amp;T basic rate switches</td>
</tr>
<tr>
<td></td>
<td>- basic-dms100 NT DMS-100 basic rate switches</td>
</tr>
<tr>
<td></td>
<td>- basic-net3  NET3 ISDN, Norway NET3, and New Zealand NET3 switches (covers the Euro-ISDN E-DSS1 signaling system and is ETSI-compliant)</td>
</tr>
<tr>
<td></td>
<td>- basic-ni   National ISDN switches</td>
</tr>
<tr>
<td></td>
<td>- basic-ts013 Australian TS013 switches</td>
</tr>
<tr>
<td></td>
<td>- ntt Japanese NTT ISDN switches</td>
</tr>
<tr>
<td></td>
<td>- vn3 French VN3 and VN4 ISDN BRI switches</td>
</tr>
<tr>
<td>Clock Type</td>
<td>Select the clock type. Use the clock slave for out-of-band clocking.</td>
</tr>
<tr>
<td>ISDN Overlap Receiving</td>
<td>When enabled, the router waits for all the digits to be received before the call is routed.</td>
</tr>
</tbody>
</table>
Digital Trunks: Advanced PRI or BRI Audio Tab

In the Advanced PRI Audio tab or the Advanced PRI Audio tab, enter settings for audio shown in Table 4-10.

How to get to this screen

- Click Configure > Voice > PSTN Trunks > Digital Trunks > (select a) Trunk Type > Edit > Advanced PRI Audio tab.
- Click Configure > Voice > PSTN Trunks > Digital Trunks > (select a) Trunk Type > Edit > Advanced BRI Audio tab.

Field Reference

Table 4-10 Advanced PRI or BRI Audio Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Echo Cancel</td>
<td>To enable the Cisco-proprietary G.165 echo canceller (EC), click the On radio button. To disable the Cisco-proprietary G.165 echo canceller (EC), click the Disable radio button. Disabling echo cancellation might cause the remote side of a connection to hear an echo. Because echo cancellation is an invasive process that can minimally degrade voice quality, this command should be disabled if it is not needed.</td>
</tr>
</tbody>
</table>
Choose the echo trail wait time from the list.

Echo cancellers are, by design, limited by the total amount of time they will wait for the reflected speech to be received. This amount of time is called an echo trail. The echo trail is normally 64 milliseconds. VoIP also has configurable echo trails of 8, 16, 24, and 32 milliseconds.

To change the receive volume, select the volume from the drop-down list.

To change the transmit volume, select the volume from the drop-down list.

To disable nonlinear processing, click the **Disable** check box. When enabled, it shuts off any signal if no near-end speech is detected.

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Echo Trail</td>
<td>Choose the echo trail wait time from the list.</td>
</tr>
<tr>
<td></td>
<td>Echo cancellers are, by design, limited by the total amount of time they will wait for the reflected speech to be received. This amount of time is called an echo trail. The echo trail is normally 64 milliseconds. VoIP also has configurable echo trails of 8, 16, 24, and 32 milliseconds.</td>
</tr>
<tr>
<td>Increase Receive Volume</td>
<td>To change the receive volume, select the volume from the drop-down list.</td>
</tr>
<tr>
<td>Decrease Volume Transmit</td>
<td>To change the transmit volume, select the volume from the drop-down list.</td>
</tr>
<tr>
<td>Nonlinear Processing</td>
<td>To disable nonlinear processing, click the <strong>Disable</strong> check box. When enabled, it shuts off any signal if no near-end speech is detected.</td>
</tr>
</tbody>
</table>
Configuring Dial Plans

The dial plan instructs a call processing agent, such as Cisco Unified Communication Manager Express (Cisco Unified CME), on how to route calls. Dial plan rules govern how a user reaches any destination. These rules include:

- Extension dialing — how many digits must be dialed to reach an extension on the system
- Extension addressing — how many digits are used to identify extensions
- Dialing privileges — allowing or not allowing certain types of calls
- Path selection — for example, using the IP network for on-net calls, or using one carrier for local PSTN calls and another for international calls
- Automated selection of alternate paths in case of network congestion — for example, using the local carrier for international calls if the preferred international carrier cannot handle the call
- Blocking calling privileges — Devices can be grouped and assigned to different classes of service, granting or denying access to certain destinations. For example, lobby phones might be allowed to reach only internal and local PSTN destinations, while executive phones could have unrestricted PSTN access.
- Transformation of the called number — for example, retaining only the last five digits of a call dialed as a ten-digit number. In some cases, it is necessary to manipulate the dialed string before routing the call. For example, rerouting a call over the PSTN, when the call was originally dialed using the on-net access code.
Call coverage — Special groups of devices can be created to handle incoming calls for a specific service according to different rules (top-down, circular hunt, longest idle, or broadcast).

A dial plan suitable for an IP telephony system is not fundamentally different from a dial plan designed for a traditional TDM telephony system; however, an IP-based system presents the dial plan architect with some new possibilities. For example, because of the flexibility of IP-based technology, telephony users in separate sites who used to be served by different, independent TDM systems can now be included in one, unified IP-based system.

This chapter describes:

- Configuring Incoming (Dial Plan)
- Configuring Outgoing Calls
- Configuring Intersite VoIP

## Configuring Incoming (Dial Plan)

The incoming calling (dial) plan analyzes, screens, and routes calls originated outside the network based on dialed digits. It defines valid dialing patterns and determines call routing. All records that share a common dial-plan-profile ID are considered a dial plan.

### Incoming (Dial Plan) Reference

The following topics describe the window used to configure an incoming dial or calling plan:

- Configure Incoming (Dial Plan)
- Edit or Create Incoming Dial Plans

### Configure Incoming (Dial Plan)

Display, enter, or modify an incoming dial or calling plan parameters.

**How to get to this screen**

Click **Configure > Voice > Dial Plans > Incoming**.
Related Link
- Edit or Create Incoming Dial Plans

Field Reference

**Table 5-1  Incoming Dial Plans**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Brief description identifying the dial plan.</td>
</tr>
<tr>
<td>Incoming Number to Translate</td>
<td>Called party complete PSTN numbers.</td>
</tr>
<tr>
<td>Internal Number Translation</td>
<td>Translated numbers.</td>
</tr>
<tr>
<td>Source Trunks</td>
<td>Incoming call sources.</td>
</tr>
</tbody>
</table>

**Edit or Create Incoming Dial Plans**

Enter settings for the incoming dial plan.

**How to get to this screen**
- Click Configure > Voice > Dial Plans > Incoming > Edit.
- Click Configure > Voice > Dial Plans > Incoming > Create.

Related Link
- Configure Incoming (Dial Plan)

Field Reference

**Table 5-2  Edit Incoming Dial Plan**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Describe the incoming dial plan.</td>
</tr>
<tr>
<td>Trunks</td>
<td>Choose the source trunks from the Available Trunks list and click Add to add the trunks to the Source Trunks of Incoming Numbers list. You can select multiple trunks by using the Ctrl key. To remove a trunk from the list, choose the source trunks from the Source Trunks of Incoming Numbers list and click Remove. Only one type of trunks can be associated to a dial plan.</td>
</tr>
</tbody>
</table>
### Configuring Incoming (Dial Plan)

#### Incoming Number to Translate
Choose the **Range** or **Number** radio button. Specifying a range of incoming numbers reduces the overall number of similar route patterns for called party numbers.

If you chose the Range radio button, enter the first number of the range in the **Numbers from** field and enter the last number of the range in the **to** field.

If you chose the Number radio button, enter the number in the **Number** field.

#### Internal Number Translation
Choose the **Range**, **Number**, or **No Translation** radio button. Specifying a range of incoming numbers reduces the overall number of similar route patterns for called party numbers.

To translate a range of contiguous incoming numbers, choose the Range radio button, enter the first number of the range in the **Numbers from** field and enter the last number of the range in the **to** field.

To translate a number, choose the Number radio button and enter the number in the **Number** field.

#### Enable Caller ID for Outgoing Calls
Click to enable caller ID translation for outgoing calls.

---

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Incoming Number to Translate</td>
<td>Choose the <strong>Range</strong> or <strong>Number</strong> radio button. Specifying a range of incoming numbers reduces the overall number of similar route patterns for called party numbers. If you chose the Range radio button, enter the first number of the range in the <strong>Numbers from</strong> field and enter the last number of the range in the <strong>to</strong> field. If you chose the Number radio button, enter the number in the <strong>Number</strong> field.</td>
</tr>
<tr>
<td>Internal Number Translation</td>
<td>Choose the <strong>Range</strong>, <strong>Number</strong>, or <strong>No Translation</strong> radio button. Specifying a range of incoming numbers reduces the overall number of similar route patterns for called party numbers. To translate a range of contiguous incoming numbers, choose the Range radio button, enter the first number of the range in the <strong>Numbers from</strong> field and enter the last number of the range in the <strong>to</strong> field. To translate a number, choose the Number radio button and enter the number in the <strong>Number</strong> field.</td>
</tr>
<tr>
<td>Enable Caller ID for Outgoing Calls</td>
<td>Click to enable caller ID translation for outgoing calls.</td>
</tr>
</tbody>
</table>
Configuring Outgoing Calls

An outgoing dial or calling plan analyzes, screens, and routes calls based on dialed digits.

All dialing destinations added to a device internal call routing table as patterns. These destinations include IP phone lines, voicemail ports, route patterns, translation patterns, and CTI route points.

When a number is dialed, the application uses closest-match logic to select which pattern to match from among all the patterns in its call routing table.

If multiple dial-plan patterns are defined, the system matches extension numbers against the patterns in sequential order, starting with the lowest numbered dial-plan pattern tag first. Once a pattern matches an extension number, the pattern is used to generate an expanded number. If additional patterns subsequently match the extension number, they are not used.

Outgoing Call Reference

An outgoing dial or calling plan analyzes, screens, and routes calls based on dialed digits. It allows you to prioritize the trunks when certain outgoing numbers are dialed. You can also deny or block certain call attempts based on the incoming and outgoing Class of Restrictions (COR) provisioned on the dial-peers.

This section contains the following parts:

- Configuring Outgoing Calls
- Outgoing Call Handling
- Outgoing Call Blocking

Configuring Outgoing Calls

In the Outgoing Calls screen, select a local from the Select Dial Plan Local menu, or select Other and enter settings for the outgoing dial plan.

How to get to this screen

Click Configure > Voice > Dial Plans > Outgoing.
Outgoing Call Handling defines parameters such as digits for placing long distance calls, international calls, and emergency numbers.

At least one trunk must be associated to each call type that is configured.

When associating a trunk to a call type dial plan, priority must be assigned. The trunk with the lowest number is given the highest priority when routing a particular type of outgoing call. Therefore, priority 0 is the highest priority.

### Field Reference

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Digits in Local Number</td>
<td>Length of local calling number.</td>
</tr>
<tr>
<td>Digits for Placing a Long Distance Call</td>
<td>Long distance calling digits.</td>
</tr>
<tr>
<td>Digits for Placing an International Call</td>
<td>International calling digits.</td>
</tr>
<tr>
<td>PSTN Access Digit</td>
<td>Dialed by phone users using regular ephone-dn lines. For example, the patterns are configured with a leading digit 9 to correspond to the conventional “dial 9 for outside line.”</td>
</tr>
<tr>
<td>Emergency Numbers</td>
<td>The emergency number patterns.</td>
</tr>
</tbody>
</table>

### Association of Outgoing Call Types to Trunks

<table>
<thead>
<tr>
<th>Trunks</th>
<th>All available outbound trunks.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local Calls</td>
<td>Trunks associated with local dial plans.</td>
</tr>
<tr>
<td>Long Distance Calls</td>
<td>Trunks associated with long distance call dial plans.</td>
</tr>
<tr>
<td>International Calls</td>
<td>Trunks associated with International call dial plans.</td>
</tr>
</tbody>
</table>
Outgoing Call Blocking

Outgoing Call Blocking prevents certain numbers from being dialed, for example, pay-per-minute calls. In gateway mode, call blocking of outgoing calls made by individual users is not supported.

Field Reference

Table 5-3   Outgoing Calls (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emergency Numbers</td>
<td>Trunks associated with emergency number dial plans. Association of a trunk to an emergency call type is only required if an emergency number is configured.</td>
</tr>
</tbody>
</table>

Table 5-4   Call Blocking

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blocked Prefixes</td>
<td>Prefixes to be rejected.</td>
</tr>
<tr>
<td>Enter Prefix to Block</td>
<td>Enter a prefix to add to the list of prefixes to be rejected.</td>
</tr>
</tbody>
</table>
Configuring Intersite VoIP

You can route calls between sites by using Intersite VoIP. Intersite callers use the PSTN area code and local prefix to route calls between systems. Different sites can be assigned different prefixes. To from one site to another, the phone user must dial the assigned prefix followed by the number.

Intersite VoIP is configured in Cisco Unified Communications Manager Express (CME) mode. Gateway VoIP is configured in gateway and gateway with SRST modes.

Intersite VoIP Reference

The following topics describe the window used to route calls between sites by using Intersite VoIP:

- Configure Intersite VoIP
- Edit or Create a Intersite VoIP Entry

Configure Intersite VoIP

For networks built on either H.323 or SIP, you are dealing with peer-to-peer communication between sites. Therefore, you also need some kind of telephone number directory system to be able to resolve the IP address of the appropriate destination VoIP peer device for intersite calls.

How to get to this screen
Click Configure > Voice > Dial Plans > Intersite VoIP.

Related Link
- Edit or Create a Intersite VoIP Entry

Field Reference

<table>
<thead>
<tr>
<th>Table 5-5</th>
<th>Configure Intersite VoIP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element</td>
<td>Description</td>
</tr>
<tr>
<td>Name</td>
<td>Name associated with the VoIP entry</td>
</tr>
</tbody>
</table>
Chapter 5  Configuring Dial Plans

Configuring Intersite VoIP

Table 5-5  Configure Intersite VoIP (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dial pattern</td>
<td>The destination number pattern. These are the numbers defined by the incoming dial plan.</td>
</tr>
<tr>
<td>Remote Site</td>
<td>IP address or host name of the remote site.</td>
</tr>
</tbody>
</table>

Edit or Create a Intersite VoIP Entry

You can create peer-to-peer communication between sites by using a telephone number directory system to resolve the IP address of the appropriate destination VoIP peer device.

How to get to this screen

- Click Configure > Voice > Dial Plans > Intersite VoIP > Create.
- Click Configure > Voice > Dial Plans > Intersite VoIP > Edit.

Related Link

- Configure Intersite VoIP

How To Use this Screen

To edit or create a Intersite VoIP entry, perform these steps:

Step 1  In the Configure tree, click Voice > Dial Plans > Intersite VoIP. Cisco Configuration Professional displays the Intersite VoIP screen.

Step 2  To edit an entry, choose an entry on the screen. Otherwise, skip this step.

Step 3  Click Edit to display the Intersite VoIP Edit screen or click Create to display the Intersite VoIP Create screen.

Step 4  In the Name field, enter the name associated with the VoIP Intersite entry; for example, Site Seven.

Step 5  In the Remote Site field, choose Cisco Unified Call Manager, IP address, or Host and enter the IP address or host name.

Step 6  In the Destination Numbers field, choose Prepopulated, Range, or Pattern, and and select the value.
Step 7  From the Codec Type list, select the codec. The Codec determines the type of compression and the maximum amount of bandwidth that is allocated for the calls. (Only codec g711ulaw is supported.)

Step 8  From the Priority list, select the priority that provides gateway resource management.

### Configuring Gateway VoIP

The gateway:

- Acts as the interface between the PSTN and the IP network
- Normalizes numbers from the PSTN before they enter the IP network
- Normalizes numbers from the IP network before they enter the PSTN
- Contains the dial peer configuration
- Registers to a gatekeeper

### Gateway VoIP Reference

The following topics describe the window used to route calls between sites by using Gateway VoIP:

- Configure Gateway VoIP
- Edit or Create a Gateway VoIP Entry

### Configure Gateway VoIP

For networks built on either H.323 or SIP, you are dealing with peer-to-peer communication between sites. Therefore, you also need some kind of telephone number directory system to be able to resolve the IP address of the appropriate destination VoIP peer device for intersite calls.

**How to get to this screen**
Click Configure > Voice > Dial Plans > Gateway VoIP.
Configuring Gateway VoIP

Related Link

- Edit or Create a Gateway VoIP Entry

Field Reference

<table>
<thead>
<tr>
<th>Table 5-6</th>
<th>Configure Gateway VoIP</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Name</td>
<td>Name associated with the VoIP entry</td>
</tr>
<tr>
<td>Destination Number</td>
<td>The destination numbers.</td>
</tr>
<tr>
<td>Remote Site</td>
<td>IP address or host name of the remote site.</td>
</tr>
</tbody>
</table>

Edit or Create a Gateway VoIP Entry

Gateway VoIP is configured in gateway and gateway with SRST modes.

**How to get to this screen**

- Click Configure > Voice > Dial Plans > Gateway VoIP > Create.
- Click Configure > Voice > Dial Plans > Gateway VoIP > Edit.

**Related Link**

- Configure Gateway VoIP

**How to Use this Screen**

To edit or create an Gateway VoIP entry, perform these steps:

**Step 1**

In the Configure tree, click Voice > Dial Plans > Gateway VoIP. Cisco Configuration Professional displays the Gateway VoIP screen.

**Step 2**

To edit an entry, choose an entry on the screen. Otherwise, skip this step.

**Step 3**

Click Edit to display the Gateway VoIP Edit screen or click Create to display the Gateway VoIP Create screen.

**Step 4**

In the Name field, enter the name associated with the VoIP Intersite entry; for example, Site Seven.

**Step 5**

In the Remote Site field, choose Cisco Unified Call Manager, IP address, or Host and enter the IP address or host name.
Step 6 In the Destination Numbers field, choose **Prepopulated**, **Range**, or **Pattern**.

Step 7 Select the value, enter the range, or enter the pattern.

Step 8 From the Codec Type list, select the codec. (The codec determines the type of compression and the maximum amount of bandwidth that is allocated for the calls.)

Step 9 From the Priority list, select the priority that provides gateway resource management. Lower numbers have higher priority.
Configuring Telephony Settings

Configure telephony by selecting the license type and softkey settings.

Telephony Settings Reference

The following topic describes the window used to configure telephony:

- Configure Telephony Settings
Configure Telephony Settings

In the Telephony Settings screen, you can modify the general telephony settings and softkey telephony options.

When you click Apply, the appropriate phone reset or restart prompt is displayed, based on what parameters you have edited.

How to get to this screen
Click Configure > Voice > Telephony Settings.

Field Reference

Table 6-1 Telephony Settings

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Telephony License Type</td>
<td>Choose the license that specifies the maximum number of users that can be configured on your device or select Other. If you selected Other, enter the custom maximum number of licenses you support. If you enter a number that matches a system license, that value is displayed after you apply the configuration. If it does not match, the license type remains Other and your custom entry is displayed.</td>
</tr>
<tr>
<td>Date Format</td>
<td>Choose the telephony date format.</td>
</tr>
<tr>
<td>Time Format</td>
<td>Check the telephony time format.</td>
</tr>
<tr>
<td>Phone Registration Source IP Address</td>
<td>Choose the phone registration source IP address.</td>
</tr>
<tr>
<td>Enable FXO Hook Flash</td>
<td>Check to enable Flash soft-key display. Certain public switched telephone network (PSTN) services, such as three-way calling and call waiting, require hook flash. A soft key labeled flash is available on phones that support a soft-key display and use foreign exchange office (FXO) lines attached to the Cisco Unified Communications Manager Express (CME) system.</td>
</tr>
</tbody>
</table>
### Table 6-1 Telephony Settings (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Hunt Group Logout (Hlog)</td>
<td>Check to enable <strong>Hlog</strong> soft-key. This enables separate handling of do-not-disturb (DND). When the Hunt Group Logout (Hlog) soft-key is pressed, the phone changes from the ready to not-ready status or from the not-ready to ready status. When the phone is in the not-ready status, it does not receive calls from the hunt group, but it is still able to receive calls that do not come through the hunt group (calls that are dialed directly to the extension number).</td>
</tr>
</tbody>
</table>
Configuring Users, Phones, and Extensions

Configure users by entering a user ID and associate phones, extensions, and mailboxes.

“User” is defined as a physical user with unique identity, password, phone, number (extension), and optionally a mailbox.

“Phone” or "Ethernet phone" is a single instance of the software configuration of the physical instrument with which a phone user makes and receives calls in a Cisco Unified Call Manager Express (CME) system. The physical phone is either a Cisco Unified IP phone or an analog phone equipped with an analog telephone adaptor (ATA). The maximum number of phones per system is platform-, version-, and license-dependent and listed in the Cisco Unified CME 7.0/4.3 Supported Firmware, Platforms, Memory, and Voice Products documents that can be found at http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/cme43spc.htm.

“Extension” or "Ethernet phone directory number" is a software construct that represents the line that connects a voice channel to a phone instrument on which a user can receive and make calls. An extension has one or more extension or telephone numbers associated with it to allow call connections to be made. An extension is equivalent to a phone line in most cases, but not always. There are several types of extensions that have different characteristics. For example: Single-Line Extension or Dual-Line Extension.
Configure phones by entering a MAC address, model number, and applying a phone template by using Phone Softkey Templates. This chapter contains the following sections:

- Configuring Extensions
- Configuring Phones
- Configuring User Settings

## Configuring Extensions

Configure the extension numbers by setting parameters such as the primary number. You can display, enter, or modify the Extension parameters.

### Extension Reference

The following topic describes the window used to configure extensions:

- Configuring Extensions
- Edit or Create an Extension

## Configuring Extensions

The Extensions screen associates an extension number with a feature set, such as Call Forwarding and Night Service.

### How to get to this screen

Click Configure > Users, Phones, and Extensions > Extensions.

### Related Link

- Edit or Create an Extension
Field Reference

Table 7-1  Extensions

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary Number</td>
<td>Primary number of the extension.</td>
</tr>
<tr>
<td>Type</td>
<td>Normal.</td>
</tr>
<tr>
<td>Label</td>
<td>Softkey label text.</td>
</tr>
<tr>
<td>User</td>
<td>The name associated with this extension number instance. This name is used for the local directory listings.</td>
</tr>
<tr>
<td>Line Mode</td>
<td>Indicates single-line mode or dual-line mode.</td>
</tr>
</tbody>
</table>

Edit or Create an Extension

In the Edit Extensions or the Create Extensions screen, enter settings for the extensions, such as the primary number.

How to get to this screen
- Click Configure > Users, Phones, and Extensions > Extensions > Edit.
- Click Configure > Users, Phones, and Extensions > Extensions > Create.

Related Link
- Configuring Extensions

Table 7-2  Extensions

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary Number</td>
<td>Enter the primary extension number. This enters creates a number, and optionally assigns it dual-line status.</td>
</tr>
<tr>
<td>Secondary Number</td>
<td>Enter a secondary number to create a valid extension number for this number instance.</td>
</tr>
<tr>
<td>Label</td>
<td>Enter a text string to identify the extensions.</td>
</tr>
</tbody>
</table>
Configuring Extensions

### Table 7-2  Extensions (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Mode</td>
<td>Select dual-line or single-line mode. Dual line (two voice channels are associated with the directory number)</td>
</tr>
<tr>
<td></td>
<td>In dual-line mode two voice channels are associated with the directory number. A user can make two call connections at the same time by using one phone line button. A dual-line extension is required if the user will be using dual-line functions, such as hold, transfer, conference, and so forth. Otherwise, single line mode can be used. In single-line mode a user makes one call connection at a time by using one phone line button.</td>
</tr>
<tr>
<td>Call Forward</td>
<td></td>
</tr>
<tr>
<td>Call Forward Busy Extension</td>
<td>Forward the call to this number if the number is busy.</td>
</tr>
<tr>
<td>Forward All Calls</td>
<td>Forward all calls to this number.</td>
</tr>
<tr>
<td>Call Forward No Answer Extension</td>
<td>Forward the call to this number if the user does not answer.</td>
</tr>
<tr>
<td>Call Forward No Answer Timeout</td>
<td>The number of seconds the call goes unanswered before it is forwarded.</td>
</tr>
<tr>
<td>Block Outgoing Caller ID</td>
<td>Choose Yes to block outgoing caller identification. Select No the display caller identification on the calling phone.</td>
</tr>
<tr>
<td>Night Service</td>
<td></td>
</tr>
<tr>
<td>Enable Night Service</td>
<td>Check to enable night service and identify if the call will be picked up or forwarded.</td>
</tr>
<tr>
<td>Call Forward Number</td>
<td>Destination number to forward night service calls.</td>
</tr>
</tbody>
</table>
Configuring Phones

The Phones configuration screens allow you to view, edit, and delete phone configurations.

Phone Reference

The following topics describe the window used to configure phones:

- Configure a Phone
- Edit or Create a Phone Configuration

Configure a Phone

Display, enter, or modify the phone parameters.

How to get to this screen

Click Configure > Voice > Users, Phones, and Extensions > Phones.

Related Link

- Edit or Create a Phone Configuration

Field Reference

<table>
<thead>
<tr>
<th>Table 7-3</th>
<th>Configure Phones</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element</td>
<td>Description</td>
</tr>
<tr>
<td>MAC Address</td>
<td>Media Access Control (MAC) address for the phone.</td>
</tr>
<tr>
<td>Type</td>
<td>Model number of the phone, for example, 7960, or 7970.</td>
</tr>
<tr>
<td>User</td>
<td>User ID associated with the phone.</td>
</tr>
<tr>
<td>Primary Extension</td>
<td>Primary extension for the phone.</td>
</tr>
</tbody>
</table>
Edit or Create a Phone Configuration

Enter the phone configuration parameters, such as MAC address or phone model.

**How to get to this screen**
- Click **Configure > Voice > Users, Phones, and Extensions > Phones > Edit**.
- Click **Configure > Voice > Users, Phones, and Extensions > Phones > Create**.

**Related Link**
- **Configure a Phone**

**Field Reference**

<table>
<thead>
<tr>
<th>Table 7-4</th>
<th>Create or Edit Phone</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone Type</td>
<td>Choose the model number of the phone that you are configuring or choose <strong>Analog</strong> if you are configuring an analog phone. If you are editing a configuration, this field is read only.</td>
</tr>
<tr>
<td>MAC Address</td>
<td>Enter the MAC address of the phone that you are configuring in dotted hexadecimal format (xxxx.xxxx.xxxx). If you are editing a configuration, this field is read only. (If Analog is chosen as the phone type, the MAC address field is disabled and the value is autopopulated when the FXS Port is selected.)</td>
</tr>
<tr>
<td>FXS Port</td>
<td>(Analog phones only.) From the list, select the FXS port to configure. Available ports not configured as a trunk are listed. You cannot modify the FXS Port or the type of analog phone. If you want to move an analog phone to another port, you can create a new analog phone using the new FXS port.</td>
</tr>
<tr>
<td>Night Service</td>
<td>To enable the night-service feature for the phone, check <strong>Night Service</strong>. The night-service feature allows you to provide coverage for unstaffed extensions during hours that you designate as “night-service” hours.</td>
</tr>
<tr>
<td>After-hour Tollbar Exempt</td>
<td>To exempt the phone from tollbar restrictions that may be configured, check <strong>After-hour Tollbar Exempt</strong>.</td>
</tr>
</tbody>
</table>
Configuring User Settings

Configure user settings by entering a user ID and associate phones, extensions, and mailboxes.

User Settings Reference

The following topics describe the User Settings window used to configure user parameters:

- Configure User Settings
- Edit or Create User Configurations

Configure User Settings

In the User Settings screen, you can view the voice system user accounts, and create and edit user accounts.

How to get to this screen
Click Configure > Voice > Users, Phones, and Extensions > User Settings.

Related Links
- Edit or Create User Configurations

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remote Worker Options</td>
<td></td>
</tr>
<tr>
<td>Configure Remote Worker</td>
<td>To configure options for a remote worker, check Configure Remote Worker. (This field is disabled if an analog phone is selected.)</td>
</tr>
<tr>
<td>Select Codec Type</td>
<td>Choose one of the following codecs to use for the remote connection:</td>
</tr>
<tr>
<td></td>
<td>• G.711(64 Kbps)</td>
</tr>
<tr>
<td></td>
<td>• G.729r8(8 Kbps)—requires Transcoding support</td>
</tr>
</tbody>
</table>
Field Reference

**Table 7-5 User Settings**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID</td>
<td>Alphanumeric ID of a user.</td>
</tr>
<tr>
<td>First Name</td>
<td>First name of a user.</td>
</tr>
<tr>
<td>Last Name</td>
<td>Last name of a user.</td>
</tr>
<tr>
<td>DisplayName</td>
<td>Display name for a user. The display name is the name that appears in voice monitoring screens.</td>
</tr>
<tr>
<td>Extensions</td>
<td>Extensions configured for a user.</td>
</tr>
<tr>
<td>Phone Type</td>
<td>Model of the phone assigned to the user.</td>
</tr>
<tr>
<td>MAC Address</td>
<td>MAC address (hardware address) of the phone assigned to the user.</td>
</tr>
<tr>
<td>Mailbox</td>
<td>Displays <strong>True</strong> if there is a mailbox associated with the user. Otherwise, displays <strong>False</strong>.</td>
</tr>
</tbody>
</table>

**Edit or Create User Configurations**

Edit or Create the user configuration.

**How to get to this screen**

- Click **Configure > Voice > Users, Phones, and Extensions > User Settings > Create**.
- Click **Configure > Voice > Users, Phones, and Extensions > User Settings > Edit**.

**Related Links**

- **Configure User Settings**
- **User Tab**
- **Extension Tab**
- **Phone Tab**
- **Mailbox Tab**
User Tab

In the User tab, create or edit general settings for a user, such as user name, display name, and passwords.

Field Reference

<table>
<thead>
<tr>
<th>Table 7-6 User Tab</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID</td>
<td>Enter the user ID. The user ID is a combination of letters and numbers. A user ID must start with an alphabetic (a-z / A-Z) character and end with an alphabetic (a-z / A-Z) character or a number (0-9). Allowed special characters: &quot;.&quot;(dot), &quot;-&quot;(hyphen) and &quot;-&quot;(underscore).</td>
</tr>
<tr>
<td>First Name</td>
<td>Enter the user’s first name.</td>
</tr>
<tr>
<td>Last Name</td>
<td>Enter the user’s last name.</td>
</tr>
<tr>
<td>Display Name</td>
<td>The display name for the user. This name appears in the phone display and in voice monitoring displays. This field is read-only.</td>
</tr>
<tr>
<td>Password Generation</td>
<td>Choose the following:</td>
</tr>
<tr>
<td>New Password</td>
<td>If you chose Use Custom Password Below in the Password Generation field, enter the password in this field. A password can consist of letters and numbers. It must be at least 1 character, and no more than 120 characters long.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Reenter the password. Cisco Configuration Professional compares the text you enter in this field with the text in the New Password field and displays a message if they are not the same.</td>
</tr>
<tr>
<td>PIN Generation</td>
<td>To configure a user Personal Identification Number (PIN) choose the following:</td>
</tr>
<tr>
<td></td>
<td>• Use Custom PIN below—To use a custom PIN that you enter, choose this option and enter the PIN in the New PIN and Confirm PIN fields.</td>
</tr>
</tbody>
</table>
Configuring User Settings

In the Extension tab, choose the extensions for the user. A user can have multiple extensions and class of restriction (COR) settings (Permission and Block Restricted Number) can be configured for each extension. The number of extensions assigned to each user must not exceed the number of phone lines available for the phone that you configured in the Phone Tab.

Table 7-6  User Tab (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New PIN</td>
<td>If you chose Use Custom PIN Below in the PIN Generation field, enter the PIN in this field. Enter only digits. Enter at least 4 digits, but no more than 8 digits.</td>
</tr>
<tr>
<td>Confirm PIN</td>
<td>Reenter the PIN. Cisco Configuration Professional compares the text you enter in this field with the text in the New PIN field and displays a message if they are not the same.</td>
</tr>
</tbody>
</table>

Extension Tab

In the Extension tab, choose the extensions for the user. A user can have multiple extensions and class of restriction (COR) settings (Permission and Block Restricted Number) can be configured for each extension. The number of extensions assigned to each user must not exceed the number of phone lines available for the phone that you configured in the Phone Tab.

Note  To edit or view associated Intercoms assigned to this extension, go to the Intercom feature.
### Chapter 7: Configuring Users, Phones, and Extensions

#### Configuring User Settings

### Field Reference

#### Table 7-7: Extensions Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available Extensions</td>
<td>This column lists the configured extensions available for use.</td>
</tr>
<tr>
<td></td>
<td>To select extensions that will be assigned to the user, do the following:</td>
</tr>
<tr>
<td></td>
<td>• To add an extension to the Extension Number list, select an extension in</td>
</tr>
<tr>
<td></td>
<td>the Available Extensions list and click the right arrow to move it.</td>
</tr>
<tr>
<td></td>
<td>• To delete an extension from the Extension Number list, select an extension</td>
</tr>
<tr>
<td></td>
<td>in the Selected Extensions list and click the left arrow to remove it.</td>
</tr>
<tr>
<td></td>
<td>• To add all the extensions to the Selected Extensions list, click the</td>
</tr>
<tr>
<td></td>
<td>right double-arrow.</td>
</tr>
<tr>
<td></td>
<td>• To delete all the extensions from the Selected Extensions list, click the</td>
</tr>
<tr>
<td></td>
<td>left double-arrow.</td>
</tr>
<tr>
<td>Extension Number</td>
<td>This column lists the extensions chosen for the user.</td>
</tr>
<tr>
<td>Permission</td>
<td>Class of restriction (COR) that determines which dial peers the phone user</td>
</tr>
<tr>
<td></td>
<td>on this extension or telephone number can access. Valid options are:</td>
</tr>
<tr>
<td></td>
<td><strong>Internal</strong>—Can place outgoing calls by dialing internal and emergency</td>
</tr>
<tr>
<td></td>
<td>numbers only. Restricted from placing all other calls.</td>
</tr>
<tr>
<td></td>
<td><strong>Local</strong>—Can place outgoing calls by dialing local, internal, and emergency</td>
</tr>
<tr>
<td></td>
<td>numbers only. Restricted from placing domestic long distance or international calls.</td>
</tr>
<tr>
<td></td>
<td><strong>Domestic</strong>—Can place outgoing calls to by dialing domestic long distance,</td>
</tr>
<tr>
<td></td>
<td>local, internal, and emergency numbers only. Restricted from placing</td>
</tr>
<tr>
<td></td>
<td>international calls.</td>
</tr>
<tr>
<td></td>
<td><strong>International</strong>—Can place outgoing calls by dialing internal, local,</td>
</tr>
<tr>
<td></td>
<td>domestic long distance, and international numbers.</td>
</tr>
<tr>
<td></td>
<td><strong>All</strong>—No access limits.</td>
</tr>
</tbody>
</table>
### Phone Tab

In the Phone tab, specify the phone, phone line, extension, and ring behavior for this user’s extensions.

#### Field Reference

<table>
<thead>
<tr>
<th>Table 7-8 Phone Tab</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>Select Phone</td>
</tr>
<tr>
<td><strong>Note</strong></td>
</tr>
<tr>
<td>Select Phone Line</td>
</tr>
<tr>
<td>Select Extension</td>
</tr>
</tbody>
</table>
Chapter 7 Configuring Users, Phones, and Extensions

Configuring User Settings

Table 7-8 Phone Tab (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ring Behavior</td>
<td>To specify ring behavior, choose one of the following options:</td>
</tr>
<tr>
<td></td>
<td><strong>Normal</strong>—the phone is to produce audible ringing, a flashing ((&lt;icon in the phone display, and a flashing red light on the handset for incoming calls, choose this option. A flashing yellow light also accompanies incoming calls on the Cisco Unified IP Phone Expansion Module 7914.</td>
</tr>
<tr>
<td></td>
<td><strong>Feature</strong>—a triple-pulse cadence that differentiates incoming calls on a line from incoming calls on other lines on this phone, choose this option.</td>
</tr>
<tr>
<td></td>
<td><strong>Silent</strong>—the user will not hear a call-waiting beep or call-waiting ring regardless of whether the number associated with the button is configured to generate a call-waiting beep or call-waiting ring.</td>
</tr>
<tr>
<td></td>
<td><strong>Call Waiting Beep (no ring)</strong>—suppress an audible ring for incoming calls, and allow call-waiting beeps, choose this option. Visible cues are the same as described for normal ring.</td>
</tr>
</tbody>
</table>

Mailbox Tab

In the Mailbox tab, configure the user’s mailbox. If mailbox size settings are not made in this screen, the default size setting for all phones is used.

To enable a mailbox for a user, check to **Add Voice Mailbox**.

Note

The Mailbox tab is disabled if Cisco Unity Express (CUE) is not available on the router.

The Mailbox tab has two tabs, Mailbox User Credentials and Mailbox Configuration.
# Configuring User Settings

## Mailbox User Credentials Tab

Configure the user credentials for the user mailbox in this tab.

### Field Reference

<table>
<thead>
<tr>
<th>Table 7-9</th>
<th>Mailbox User Credentials Tab</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
<td><strong>Description</strong></td>
</tr>
</tbody>
</table>
| Password Generation | Choose the following:  
  - Use Custom Password Below—To use a custom password that you enter, choose this option and enter the password in the New Password and Confirm Password fields.  
  - Use Blank Password—To use a blank password (no password set), choose this option. The New Password and Confirm Password fields are disabled. |
| New Password | If you chose Use Custom Password Below in the Password Generation field, enter the password in this field. A password can consist of letters and numbers. It can be from 3 to 32 characters long. |
| Confirm Password | Reenter the password. Cisco Configuration Professional compares the text you enter in this field with the text in the New Password field and displays a message if they are not the same. |
| PIN Generation | To configure a user Personal Identification Number (PIN) choose the following:  
  - Use Custom PIN below—To use a custom PIN that you enter, choose this option and enter the PIN in the New PIN and Confirm PIN fields.  
  - Use Blank PIN—To use a blank PIN, choose this option. The New PIN and Confirm PIN fields are disabled. |
| New PIN | If you chose Use Custom PIN Below in the PIN Generation field, enter the PIN in this field. Enter only digits. Enter at least 4 digits, but no more than 8 digits. |
| Confirm PIN | Reenter the PIN. Cisco Configuration Professional compares the text you enter in this field with the text in the New PIN field and displays a message if they are not the same. |
Mailbox Configuration Tab
Configure the user configuration parameters for the user mailbox in this tab.

Field Reference

Table 7-10 Mailbox User Credentials Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mailbox Description</td>
<td>Enter a description of the mailbox. If a user has multiple extensions and multiple mailboxes, entering a different description for each can be helpful.</td>
</tr>
<tr>
<td>Associated Extension</td>
<td>Enter the user extension that you want to associate with this mailbox. Only one extension can be associated with a mailbox.</td>
</tr>
<tr>
<td>Voice Mailbox Size</td>
<td>Enter the maximum number of seconds of stored messages allowed for the voice mailbox.</td>
</tr>
<tr>
<td>Maximum Caller Message Size</td>
<td>Enter the maximum size, in seconds, of a message that can be left by a caller in the voice-mail system.</td>
</tr>
<tr>
<td>Voice Mail Message Expiration</td>
<td>Enter the number of days to store messages. After a message has been stored for the specified number of days, the user can resave the message or delete it.</td>
</tr>
<tr>
<td>Zero Out Number</td>
<td>Enter the number to which callers are to be transferred when they press 0 at a voice-mail greeting. If you want callers to reach the operator when they press 0, enter the operator extension in this field.</td>
</tr>
<tr>
<td>Play Voice Mail Tutorial</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Yes—Play the system voicemail tutorial the first time that the user logs in to the mailbox. The tutorial provides instructions on setting up a greeting and creating a password.</td>
</tr>
<tr>
<td></td>
<td>• No—Do not play the system voicemail tutorial.</td>
</tr>
<tr>
<td>Voice Mailbox Enabled</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Yes—Enable this mailbox immediately.</td>
</tr>
<tr>
<td></td>
<td>• No—Disable this mailbox.</td>
</tr>
</tbody>
</table>
### Table 7-10  Mailbox User Credentials Tab (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Greeting Type</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Standard—Play the standard system greeting when callers reach</td>
</tr>
<tr>
<td></td>
<td>the voice mailbox.</td>
</tr>
<tr>
<td></td>
<td>• Alternate—Play the user’s alternate greeting when callers reach</td>
</tr>
<tr>
<td></td>
<td>the voice mailbox.</td>
</tr>
</tbody>
</table>
Configuring Telephony Features

This chapter explains how to configure telephony features. It contains the following sections:

- After-Hours Tollbar
- Call Conferencing
- Call Park
- Call Pickup Groups
- Directory Services
- Hunt Groups
- Intercom Lines
- Night Service Bell
- Paging Numbers
- Paging Groups
- Phone Softkey Templates
After-Hours Tollbar

The After-Hours Tollbar prevents the unauthorized use of phones by matching dialed numbers against a pattern of specified digits and matching the time against the time of day and day of week or date that has been specified for call blocking. Up to 32 patterns of digits can be specified. Call blocking is supported on IP phones only and not on analog foreign exchange station (FXS) phones.

When a user attempts to place a call to digits that match a pattern that has been specified for call blocking during a time period that has been defined for call blocking, a fast busy signal is played for approximately 10 seconds. The call is then terminated and the line is placed back in on-hook status.

Individual phone users can override the call blocking that has been defined for designated time periods. The system administrator must first assign a personal identification number (PIN) to any phone that will be allowed to override call blocking.

Logging in to a phone with a PIN only allows the user to override call blocking that is associated with particular time periods. Blocking patterns that are in effect 7 days a week, 24 hours a day cannot be overridden by using a PIN.

When PINs are configured for call-blocking override, they are cleared at a specific time of day or after phones have been idle for a specific amount of time. The time of day and amount of time can be set by the system administrator, or the defaults can be accepted.

Note: A phone can be exempted from the Tollbar by using the Users, Phones and Extensions > Phones window.

After-Hour Tollbar Reference

The following topics describe the window used to configure After-Hour Tollbar:

- Configuring Calling Restrictions
- Configuring a Weekly Schedule
- Configuring a Holiday Schedule
- Configuring an Override (Softkey Login)
Configure After-Hour Tollbar

Configure After-Hour Tollbar as described in these sections:

- Configuring Calling Restrictions
- Configuring a Weekly Schedule
- Configuring a Holiday Schedule
- Configuring an Override (Softkey Login)

Configuring Calling Restrictions

You can display, add, or modify phone number prefix patterns to be blocked. In gateway mode, call blocking of outgoing calls made by individual users is not supported.

After-Hours Tollbar call blocking restrictions:

- Up to 32 patterns of digits can be specified.
- Supported on IP phones only; not supported on analog (FXS) phones.
- Call blocking applies to all IP phones in the community by default.
- Individual IP phones can be exempted from all call blocking.

Note

Duplicate patterns are not allowed.

How to get to this screen

Click Configure > Voice > Telephony Features > After-Hour Tollbar > Calling Restrictions.

To add the list of blocked prefixes, complete the following tasks:

Step 1 In the Configure tree, click Voice > Advanced Voice Features > After-Hour Tollbar > Calling Restrictions. Cisco Configuration Professional displays the Calling Restrictions screen.

Step 2 In the Enter prefix to block field, enter the number pattern.

Step 3 Click Add.
Configuring a Weekly Schedule

The weekly schedule defines a recurring period based on day of the week during which outgoing calls that match defined block prefix patterns are blocked on IP phones.

How to get to this screen
Click Configure > Voice > Telephony Features > After-Hour Tollbar > Weekly Schedule.

Copying a Weekly Schedule
To copy a weekly schedule, perform these steps:

Step 1 In the Configure tree, click Voice > Advanced Voice Features > After-Hour Tollbar > Weekly Schedule. Cisco Configuration Professional displays the Weekly Schedule screen.
Step 2 Set the times. The Tollbar is applied before the time specified and after the time specified (the rest of that day is unblocked):
   - Select the hour or the minute under the desired day of the week and use the arrows to change the time.
   - To toggle between ante meridiem and post meridiem, select the am or pm field and use the arrows to change the setting.
Step 3 Check All Day to indicate the settings apply to the entire day.
Configuring a Holiday Schedule

When a Holiday setting is in effect, the system observes off hours blocking rules.

**How to get to this screen**
Click Configure > Voice > Telephony Features > After-Hour Tollbar > Holiday Schedule.

**Adding a Holiday**
To add a holiday, perform these steps:

**Step 1** In the Configure tree, click Voice > Advanced Voice Features > After-Hour Tollbar > Holiday Schedule. Cisco Configuration Professional displays the Holiday Schedule screen.

**Step 2** Choose a date from the calendar, and click Add. Cisco Configuration Professional displays the date in the Select date field.

**Step 3** To specify the start and stop times, uncheck All Day and use the arrow keys to set the hour and the minute. To toggle between ante meridiem and post meridiem, select am or pm and use the arrows to change the setting.

**Step 4** To put the date in the Call Restrictions list, click Add.
Configuring an Override (Softkey Login)

Individual phone users can be allowed to override call blocking associated with designated time periods by entering personal identification numbers (PINs) that have been assigned to their phones. Then, to override call blocking, the phone user presses the Login soft key on the phone and enters the PIN that is associated with the phone.

The override is cleared at a specific time of day or after phones have been idle for a specific amount of time.

**How to get to this screen**

Click Configure > Telephony Features > After-Hour Tollbar > Override (Softkey Login).

To enable a user to override the after-hours tollbar, perform these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>In the Configure tree, click Voice &gt; Advanced Voice Features &gt; After-Hour Tollbar &gt; Override (Softkey Login). Cisco Configuration Professional displays the Override (Softkey Login) screen.</td>
</tr>
<tr>
<td>Step 2</td>
<td>To allow callers make calls in spite of the after-hours configuration, click Enable.</td>
</tr>
<tr>
<td>Step 3</td>
<td>To set the idle time to clear the override, select the Clear override after field and use the arrows to change the number of minutes.</td>
</tr>
<tr>
<td>Step 4</td>
<td>To clear the override at a specific time, select the hour or the minute in the Clear override at field and use the arrows to change the time. To toggle between ante meridiem and post meridiem, select am or pm, and use the arrows to change the setting.</td>
</tr>
</tbody>
</table>

To **Reset to System Defaults** applies the default values of Clear override after 60 minutes and Clear override at 12 am (midnight).
Call Conferencing

Conferencing allows you to join three or more parties in a telephone conversation. Ad hoc conferences are created when one party calls another party, then either party adds one or more parties to the conference call.

Ad hoc conferences can be hardware-based or software-based, depending on the number of parties. Hardware-based ad hoc conferencing uses digital signal processors (DSPs) to allow more parties than software-based ad hoc conferencing, which allows three parties only.

Only one digital-signal-processor (DSP) farm-service (DSP farm) profile with a maximum of eight participants is read into Cisco Configuration Professional. Any DSP farm profile having with more than eight participants configured is ignored.

Hardware-based ad hoc conferencing uses the packet voice/data modules (PVDMs) that are listed in the show dialog output. It is supported only for Cisco Unified Communications Manager Express (CME) versions 4.1 and higher. If the device has PVDMs, but the CME version is less than 4.1, software-based ad hoc conferencing is supported.

Call Conference Reference

The following topics describe the window used to configure call conference:

- Configure Call Conference

Configure Call Conference

Display, enter, or modify the Call Conference parameters.

How to get to this screen
Click Configure > Voice > Telephony Features > Call Conference.

Related Links
- Call Conferencing
## Field Reference

### Table 8-1 Configure Call Conference

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Multiple Party Conferences</strong></td>
<td></td>
</tr>
<tr>
<td>Codec Type</td>
<td>If multi-party conferencing is supported by the device, to enable mixed mode (codec type G729 and G711), check the Mixed Mode check box. If it is not checked, the device is configured for single mode (G711 codec type only) conferencing.</td>
</tr>
<tr>
<td>Participants per Conference</td>
<td>Maximum number of participants allowed per conference. (This is always eight, and not editable.)</td>
</tr>
</tbody>
</table>
| Concurrent Ad Hoc Conferences        | Number of ad hoc conferences, or maximum number of sessions, which is limited by the number of DSPs on the device. Ad hoc conferences require a DSP farm profile. Cisco CP can only read one DSP-farm profile, and a profile can support a maximum of 8 participants. When reading this field, keep the following things in mind:  

  - If more than one properly-configured DSP-farm profile exists, Cisco CP reads the DSP-farm profile with the highest maximum sessions setting.  
  - If the DSP farm profile that Cisco CP reads is not enabled, Cisco CP ignores it, and this field is empty.  
  - If there are invalid DSP farm profiles, out-of-band messages are displayed. The message displays the DSP farm profile tag that identifies the DSP farm profile. |
| Total Conference Attendees           | Total number of conference attendees, based on the number of participants per conference times the number of Ad Hoc conferences.               |
| **3-way Conferences**                |                                                                                                                                              |
| Number of Conferences                | The maximum number of 3-way conferences allowed. (Limited by the device.)                                                                  |
Call Park

Call park allows a phone user to place a call on hold at a special number that is used as a temporary parking spot from which the call can be retrieved by anyone on the system. In contrast, a call that is placed on hold by using the Hold button or Hold soft key can be retrieved only from the extension that placed the call on hold.

The special number at which a call is parked is known as a call-park slot. A call-park slot is a floating extension, or number that is not bound to a physical phone, to which calls are sent to be held.

After at least one call-park slot has been defined and the Cisco Unified Communications Manager Express (CME) phones have been restarted, phone users are able to park calls using the Park soft key.

Call Park Reference

The following topics describe the window used to configure call park:

- Configure Call Park
- Edit or Create Call-Park Parameters: General Tab
Configure Call Park

Display, enter, or modify the Call Park parameters. The General tab configures basic call-park parameters, such as the name and number of slots. The Advanced tab advanced parameters, such as reminders and termination actions.

How to get to this screen
Click Configure > Voice > Telephony Features > Call Park.

Related Links
- Configure Call Park
- Edit or Create Call-Park Parameters: General Tab
- Edit or Create Call-Park Parameters: Advanced Tab

Field Reference

Table 8-2 Configure Call Park

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call Park type</td>
<td>Choose <strong>General Purpose</strong> or <strong>Directed</strong>. General purpose call park allows the user to place a call on hold, so it can be retrieved from another phone in the system (for example, a phone in another office or in a conference room). If the user is on an active call at that phone, they can park the call to a call park extension by pressing the Park softkey or the Call Park button. Someone on another phone in your system can then dial the call park extension to retrieve the call. Directed call park allows a user to route a call to another extension or to a voice-messaging mailbox. For example, user A calls user B, and user B parks the call. User B retrieves the call and then decides to send the call to voice-messaging mailbox. User A receives the voice-messaging mailbox greeting of user B. The user can park only one call at each directed call park number.</td>
</tr>
<tr>
<td>Name</td>
<td>Name displayed on a recall or transfer rather than an extension number.</td>
</tr>
<tr>
<td>Slots Start From</td>
<td>Starting call-park slot number.</td>
</tr>
<tr>
<td>Number of Slots</td>
<td>Number of call-park slots.</td>
</tr>
</tbody>
</table>
Chapter 8  Configuring Telephony Features

Table 8-2  Configure Call Park (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout</td>
<td>Interval length during which the call-park reminder ring is timed out or inactive. If the time-out is zero, no reminder ring is sent to the extension that parked the call.</td>
</tr>
<tr>
<td>Recall</td>
<td>Interval length which the parked call is returned to the extension that parked the call.</td>
</tr>
</tbody>
</table>

Edit or Create Call-Park Parameters: General Tab

In the General tab, enter the basic call-park parameters, such as the name and number of slots.

How to get to this screen

- Click Configure > Voice > Telephony Features > Call Park > Edit > General tab.
- Click Configure > Voice > Telephony Features > Call Park > Create > General tab.

Related Links

- Configure Call Park
- Edit or Create Call-Park Parameters: Advanced Tab

Field Reference

Table 8-3  General Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter the name to be displayed on a recall or transfer rather than an extension number.</td>
</tr>
<tr>
<td>Number of slots</td>
<td>Enter the number of call-park slots.</td>
</tr>
<tr>
<td>Starting number of slots</td>
<td>Enter the starting call-park slot number.</td>
</tr>
</tbody>
</table>
Call Park

Table 8-3  General Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout</td>
<td>Enter the time interval length the call-park reminder ring is timed out or inactive. At the end of the time-out interval, the first reminder ring is sent to the extension that parked the call. If the time-out is zero, no reminder ring is sent.</td>
</tr>
</tbody>
</table>

Edit or Create Call-Park Parameters: Advanced Tab

In the Advanced tab, enter the call-park advanced parameters, such as reminders and termination actions.

How to get to this screen

Click Configure > Voice > Telephony Features > Call Park > Edit > Advanced tab.

or

Click Configure > Voice > Telephony Features > Call Park > Create > Advanced tab.

Related Links

- Configure Call Park
- Edit or Create Call-Park Parameters: General Tab

Field Reference

Table 8-4  Advanced Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set reminder to extension</td>
<td>Select an extension from the list, other than the extension from where the call was parked, that will receive a reminder that the call has been parked.</td>
</tr>
<tr>
<td>Send reminder to originating phone</td>
<td>To send a reminder to the originating phone extension, click Yes. To silence the reminder, click No.</td>
</tr>
</tbody>
</table>
Table 8-4  Advanced Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remind user every</td>
<td>Enter the interval length in seconds between reminder rings.</td>
</tr>
<tr>
<td>Number of reminders to send</td>
<td>Enter the maximum number of reminder ring retries.</td>
</tr>
<tr>
<td>Total time in reminder phase</td>
<td>Enter the maximum time that a call will stay parked.</td>
</tr>
</tbody>
</table>

Table 8-5  Advanced Tab Termination Phase

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Target Phone</td>
<td>Choose to send the call back to the originating extension or to send the call to another extension after the reminder phase has expired. If you chose to send the call to another extension, from the Select Number list, select the number to send the call back to after the reminder phase has expired.</td>
</tr>
<tr>
<td>Select Action on Target Phone</td>
<td>Choose to send the call back to the target phone immediately after reminder phase.</td>
</tr>
<tr>
<td></td>
<td>Select If target phone is busy.... to set the interval length between retries, and complete the following steps:</td>
</tr>
<tr>
<td></td>
<td>1. Enter the number of seconds between retries in the retry every field.</td>
</tr>
<tr>
<td></td>
<td>2. Enter the number of retries in the repeating field.</td>
</tr>
<tr>
<td></td>
<td>Select the action If target phone busy after retry.... To send a parked call to a different extension when the target phone is busy interval expires, click Send call to extension and select the target extension from the Select Number list or click Disconnect.</td>
</tr>
</tbody>
</table>
Call Pickup Groups

Call pickup groups enable phone users to answer a call that is ringing on a directory number other than their own. The user can answer a ringing phone in any pickup group if the user knows the group number of the ringing phone. If there is only one pickup group defined, the phone user can pick up the call by pressing a soft key. The phone user does not need to belong to the pickup group.

Phone users can pick up the called number on another phone by pressing a soft key plus an asterisk (*) their own phone if both phones are in the same pickup group.

There is no limit to the number of numbers that can be assigned to a pickup group, and there is no limit to the number of pickup groups that can be defined in a system.

Pickup group numbers may be of varying length, but must have unique leading digits. For example, you cannot define pickup group 17 and pickup group 177 for the same system because a pickup in group 17 will always be triggered before the user can enter the final 7 for 177.

Call Pickup Group Reference

The following topics describe the window used to configure call pickup groups:

- Configure Pickup Group
- Edit or Create a Pickup Group

Configure Pickup Group

Display, enter, or modify the pickup group parameters.

How to get to this screen
Click Configure > Voice > Telephony Features > Pickup Groups.

Related Link
- Edit or Create a Pickup Group
Chapter 8 Configuring Telephony Features

Field Reference

Table 8-6 Pickup Group Summary

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pickup Group Number</td>
<td>Number assigned to the pickup group.</td>
</tr>
<tr>
<td>Extensions</td>
<td>Extension numbers assigned to the pickup group.</td>
</tr>
</tbody>
</table>

Edit or Create a Pickup Group

Enter or modify the settings for a pickup group.

How to get to this screen
- Click Configure > Voice > Telephony Features > Pickup Groups > Edit.
- Click Configure > Voice > Telephony Features > Pickup Groups > Create.

Related Links
- Configure Pickup Group

Field Reference

Table 8-7 Edit or Create Pickup Group

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pickup Group Number</td>
<td>Assign a number to the pickup group in the field. Once assigned, the number cannot be edited.</td>
</tr>
<tr>
<td>Available Extensions</td>
<td>Extensions eligible to be added to the pickup group.</td>
</tr>
</tbody>
</table>
Cisco Configuration Professional automatically creates a local phone directory containing the telephone numbers that are assigned in the directory entry number configuration of the phone.

You can make additional entries to the local directory in telephony services configuration mode. Additional entries can be nonlocal numbers such as telephone numbers on other Cisco systems used by your company.

Directory Services Reference

The following topic describes the window used to configure Directory Services:

- Configure Directory Services
- Edit or Add a Directory Entry
Configure Directory Services

You can make additional entries to the local directory. Additional entries can be nonlocal numbers such as telephone numbers on other Cisco systems used by your company.

How to get to this screen
Click Configure > Voice > Telephony Features > Directory Services

Related Link
• Edit or Add a Directory Entry

Field Reference

| Table 8-8 Configure Directory Services |
|------------------|-----------------|
| **Element**      | **Description** |
| Directory Entry Position | The system-level directory entry number. Directory entry numbers are one-digit or two-digit. A maximum 100 directory entry numbers are supported. |
| Name             | Name associated with the directory number. |
| Phone Number     | The extension associated with the dial position and name. |

Edit or Add a Directory Entry

Enter or modify the settings for directory services.

How to get to this screen
• Click Configure > Voice > Telephony Features > Directory Services > Edit.
• Click Configure > Voice > Telephony Features > Directory Services > Create.

Related Link
• Configure Directory Services
Hunt Groups

Field Reference

Table 8-9 Configure Directory Services

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Directory Entry Position</td>
<td>Choose a directory entry in the screen. Directory entry numbers are one-digit or two-digit. The default is 1. A maximum of 100 directory entry numbers are supported.</td>
</tr>
<tr>
<td>Name</td>
<td>Enter the name associated with the directory entry number.</td>
</tr>
<tr>
<td>Phone Number</td>
<td>Enter the extension associated with the directory entry position and name.</td>
</tr>
</tbody>
</table>

Hunt Groups

Hunt Groups direct incoming calls to a specific number (the pilot number) to a group of extensions (members). The first available member who is not busy in a hunt group receives the call. You do this by assigning the same number to several primary or secondary numbers or by using wildcards in the number associated with the directory numbers.

Pilot points and hunt groups must be configured before the Cisco Telephony Call Dispatcher (TCD) can route calls to Cisco WebAttendant. A Cisco WebAttendant pilot point is a virtual directory number that receives and redirects calls to the members of its associated hunt group.

The hunt group type and order in which the extensions (members) of the hunt group are listed determines the sequence the device uses to direct the call. The first available member who is not busy in a hunt group receives the call.

How to get to this screen
Click Configure > Voice > Telephony Features > Hunt Groups.
Hunt Group Reference

The following topics describe the User Interface (Hunt Group) window used to configure hunt groups:

- Configure Hunt Groups
- Edit or Create a Hunt Group: General Tab
- Edit or Create a Hunt Group: Advanced Tab
- Set Extension Timeout

Configure Hunt Groups

Configure the hunt group parameters defined in the User Interface window.

How to get to this screen
Click Configure > Voice > Telephony Features > Hunt Groups.

Field Reference

<table>
<thead>
<tr>
<th>Table 8-10 Configure Hunt Groups</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>Pilot Number</td>
</tr>
<tr>
<td>Type</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Description</td>
</tr>
<tr>
<td>Member Extensions</td>
</tr>
</tbody>
</table>
### Hunt Groups

**Related Links**
- Edit or Create a Hunt Group: General Tab
- Set Extension Timeout
- Edit or Create a Hunt Group: Advanced Tab

**Edit or Create a Hunt Group: General Tab**

In the General tab, enter the basic hunt group parameters.

**How to get to this screen**
- Click Configure > Voice > Telephony Features > Hunt Groups > Edit > General tab.
- Click Configure > Voice > Telephony Features > Hunt Groups > Create > General tab.

**Related Links**
- Configure Hunt Groups
- Set Extension Timeout
- Edit or Create a Hunt Group: Advanced Tab
Field Reference

Table 8-11  General Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pilot number</td>
<td>Enter a unique pilot number that callers dial to reach the hunt group. Once the pilot number is configured, it cannot be changed. This number should be unique throughout the system. E.164 number with a maximum length of 24 characters.</td>
</tr>
<tr>
<td>Type</td>
<td>Enter the hunt group type.</td>
</tr>
<tr>
<td></td>
<td><strong>Sequential</strong>—The extensions always ring left-to-right, in the order that they were listed when the hunt group was defined. The first number in the list is always the first number the system tries to call when the pilot number is called.</td>
</tr>
<tr>
<td></td>
<td><strong>Peer</strong>—The first extension to ring is the number to the right of the extension that was the extension that was rung when the pilot number was last called. Ringing proceeds in a circular manner, left to right, for the number of hops specified when the hunt group was defined.</td>
</tr>
<tr>
<td></td>
<td><strong>Longest Idle</strong>—Calls go to the extension that has been idle for the greatest number of hops. The longest-idle is counted from the last time that a phone registered, reregistered, or went on-hook.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description for the hunt group. The text appears in the configuration output and on IP phones that are members of a hunt group when they receive hunt-group calls.</td>
</tr>
<tr>
<td>Forward call to</td>
<td>Select the disposition of the call at the end of the call forwarding process as follows:</td>
</tr>
<tr>
<td></td>
<td>- Originating Number forwards the call to the directory number of the phone that transferred the call into the hunt group.</td>
</tr>
<tr>
<td></td>
<td>- Final Number forwards the call to the last number in the hunt group.</td>
</tr>
</tbody>
</table>
Chapter 8 Configuring Telephony Features

Hunt Groups

Table 8-11 General Tab (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Final number</td>
<td>Enter the final directory number in the hunt group or an extension number. It should be either the voice mail number or the number of some other application, such as Cisco IP Auto Attendant, that can accept multiple inbound calls simultaneously.</td>
</tr>
</tbody>
</table>

Hunt Group Extensions

- **Available extensions** are extensions eligible to be added to the hunt group. **Selected extensions** are the extensions that have been added to the hunt group.
  - To add an extension to the list, select an extension in the Available Extensions list and click the right arrow to move it.
  - To delete an extension from the list, select an extension in the Selected Extensions list and click the left arrow to remove it.
  - To add all the extensions to the Selected Extensions list, click the right double-arrow.
  - To delete all the extensions from the Selected Extensions list, click the left double-arrow.

**Note**

Set Extension Timeout sets the number of seconds call waits on the selected extension number before it moves to the next extension.

**Set Extension Timeout**

Display, enter, or modify the time outs for selected (or member) extensions.

**How to get to this screen**

- Click Configure > Voice > Telephony Features > Hunt Groups > Edit > General tab > Set Extension Timeout.
- Click Configure > Voice > Telephony Features > Hunt Groups > Create > General tab > Set Extension Timeout.
Field Reference

Table 8-12  Set Extension Timeout

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extension</td>
<td>Select an extension to configure from drop down menu.</td>
</tr>
<tr>
<td>Timeout</td>
<td>Enter the number of seconds. If the selected extension number has a timeout value configured, that value displays in Timeout field. The range is 3 to 60000 seconds. Default timeout value is 180 seconds.</td>
</tr>
</tbody>
</table>

Related Links
- Configure Hunt Groups
- Edit or Create a Hunt Group: General Tab
- Edit or Create a Hunt Group: Advanced Tab

Edit or Create a Hunt Group: Advanced Tab

In the Advanced tab, enter the advanced hunt group parameters, such as the primary and secondary pilot numbers.

How to get to this screen
- Click Configure > Voice > Telephony Features > Hunt Groups > Edit > Advanced tab.
- Click Configure > Voice > Telephony Features > Hunt Groups > Create > Advanced tab.

Related Links
- Configure Hunt Groups
- Edit or Create a Hunt Group: General Tab
- Set Extension Timeout
## Hunt Groups

### Field Reference

#### Table 8-13  Advanced Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary pilot number preference</td>
<td>Select the preference order for the pilot number.</td>
</tr>
<tr>
<td>Secondary pilot number</td>
<td>Enter the backup number that callers dial to enter the hunt group.</td>
</tr>
<tr>
<td>Secondary pilot number preference</td>
<td>Select the preference order for the backup number that callers dial to enter the hunt group.</td>
</tr>
<tr>
<td>Maximum timeout</td>
<td>Enter the maximum total timeout for all the no-answer periods for all extensions in the hunt group. The call proceeds to the final destination when this timeout period expires, regardless of whether or not it has completed the hunt cycle. The value can be from 3 to 60000 seconds.</td>
</tr>
<tr>
<td>Maximum hops</td>
<td>Enter the number of hops before the call proceeds to the final number. The value must be less than or equal to the number of extensions that are specified in the list. If the number is not set, the system defaults to the number of hunt group members. (Applies only to the Peer hunt group type or the Longest Idle hunt group type.)</td>
</tr>
<tr>
<td>Unanswered call message</td>
<td>Enter the message to be displayed on the unanswered phones when a phone goes unanswered.</td>
</tr>
<tr>
<td>Present call to</td>
<td>Choose to present hunt group calls only to member phones that are idle or onhook.</td>
</tr>
<tr>
<td></td>
<td>Idle Phone—a hunt group call is directed to this phone only if all lines on the phone are idle.</td>
</tr>
<tr>
<td></td>
<td>Onhook Phone—a hunt group call is directed to a phone only if the phone is in on-hook state.</td>
</tr>
<tr>
<td>Update on-hook timestamps when</td>
<td>Choose to update the on-hook time stamp when a call is answered or a call is answered and an extension rings. (Applies only to the Longest Idle hunt group type.)</td>
</tr>
</tbody>
</table>
Intercom Lines

An intercom line is a dedicated two-way audio path between two phones. When an intercom speed-dial button is pressed, a call is speed-dialed to the other half of the dedicated pair. When Auto Answer is enabled, the called phone automatically answers the call in speakerphone mode with mute activated, which provides a one-way voice path from the initiator to the recipient. A beep is sounded when the call is auto-answered to alert the recipient to the incoming call.

Intercom lines cannot be used in shared-line configurations. If a directory number is configured for intercom operation, it must be associated with one IP phone only. The intercom attribute causes an IP phone line to operate as an autodial line for outbound calls and as an autoanswer-with-mute line for inbound calls.

To prevent an unauthorized phone from dialing an intercom line (and creating a situation in which a phone automatically answers a call other than an intercom call), you can assign the intercom extension number that includes an alphabetic character. An alphabetic character cannot be dialed from a typical phone, but a Cisco phone can be configured to dial the number that contains the alphabetic character.

Intercom Reference

The following topics describe the window used to configure intercom:

- Configure Intercom
- Edit or Create Intercom

Configure Intercom

Display, enter, or modify the Intercom parameters.

How to get to this screen
Click Configure > Voice > Telephony Features > Intercom.

Related Link
- Edit or Create Intercom
Field Reference

Table 8-14  Configure Intercom

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User 1</td>
<td>The user ID associated with the first number of the intercom connection. This name is used for caller-ID displays and also shows up in the local directory associated with the intercom extension number.</td>
</tr>
<tr>
<td>User 1 Phone Type</td>
<td>The model of the phone assigned to the user.</td>
</tr>
<tr>
<td>User 1 Phone Button</td>
<td>Button number assigned to the intercom extension number.</td>
</tr>
<tr>
<td>User 2</td>
<td>The user ID associated with the second number of the intercom connection. This name is used for caller-ID displays and also shows up in the local directory associated with the number.</td>
</tr>
<tr>
<td>User 2 Phone Type</td>
<td>The model of the phone assigned to the user.</td>
</tr>
<tr>
<td>User 2 Phone Button</td>
<td>Button number assigned to the intercom extension number.</td>
</tr>
</tbody>
</table>

Edit or Create Intercom

Enter or modify the parameters to establish an intercom link between two users.

How to get to this screen

- Click Configure > Voice > Telephony Features > Intercom > Edit.
- Click Configure > Voice > Telephony Features > Intercom > Create.

Related Link

- Configure Intercom

Field Reference

Table 8-15  Edit Intercom or Create Intercom

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User1 or User2</td>
<td>Choose the user to be associated with this number.</td>
</tr>
<tr>
<td>Phone Model</td>
<td>Model of the phone. Displays automatically and cannot be modified.</td>
</tr>
</tbody>
</table>
Silent ringing is overridden when **night service** is active. It allows you to provide coverage for unstaffed extensions during hours that you designate as "night-service" hours. During the night-service hours, calls to the designated extensions (known as night-service directory numbers or night-service lines) send a special "burst" ring to phones that have been specified to receive this special ring (the phones are known as night-service phones). Phone users at the night-service phones can then use the call-pickup feature to answer the incoming calls from the night-service directory numbers.

You can configure silent ring on any type of phone. However, you typically set silent ring only on buttons of a phone with multiple lines, such as a Cisco Unified IP Phone 7940, Cisco Unified IP Phones 7960 and 7960G, or a Cisco Unified IP Phone 7914 Expansion Module. The only visible cue is a flashing (< icon in the phone display.

If you configure a button to have a silent ring, you will not hear a call-waiting beep or call-waiting ring regardless of whether the number associated with the button is configured to generate a call-waiting beep or call-waiting ring.

In Cisco IOS Release 12.4(4)XC and later releases, the silent ringing behavior is overridden during active night-service periods.

### Table 8-15 Edit Intercom or Create Intercom (continued)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone Button</td>
<td>Choose the number of the button for the number being configured from the list.</td>
</tr>
<tr>
<td>Auto Answer</td>
<td>Check Intercom Auto Answer feature on the directory number being configured to enable.</td>
</tr>
<tr>
<td>Mute</td>
<td>Check to answer the call in speakerphone mode with mute activated.</td>
</tr>
</tbody>
</table>
Night Service Bell Reference

The following topics describe the window used to manage silent ringing when night service is active:

- Configuring Night Service Weekly Schedule
- Configuring Night Service Annual Schedule
- Configuring Night Service Daily Schedule
- Configuring Night Service Code

Configure Night Service Bell

To manage silent ringing when night service is active, follow the instructions in these sections:

- Configuring Night Service Weekly Schedule
- Configuring Night Service Annual Schedule
- Configuring Night Service Daily Schedule
- Configuring Night Service Code

Configuring Night Service Weekly Schedule

A weekly schedule cycles every week.

**How to get to this screen**

Click Configure > Voice > Telephony Features > Night Service Bell > Weekly Schedule.

**Configure a Weekly Schedule**

To configure a weekly schedule, perform these steps:

**Step 1** Click Configure > Voice > Telephony Features > Night Service Bell > Weekly Schedule. Cisco Configuration Professional displays the Configure Night Service Weekly Schedule screen.

**Step 2** To set the start and stop times:
Chapter 8  Configuring Telephony Features

Night Service Bell

- Select the hour or the minute under the desired day of the week and use the arrows to change the time.
- To toggle between ante meridiem and post meridiem, select am or pm and use the arrows to change the setting.

To set the start and stop time for length of the entire day, check All Day.

Copying a Weekly Schedule

To copy a weekly schedule, perform these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Click Configure &gt; Voice &gt; Telephony Features &gt; Night Service Bell &gt; Weekly Schedule. Cisco Configuration Professional displays the Configure Night Service Weekly Schedule screen.</td>
</tr>
<tr>
<td>2</td>
<td>Choose a day from the Copy schedule from list.</td>
</tr>
<tr>
<td>3</td>
<td>Choose a day from the Copy schedule to list.</td>
</tr>
<tr>
<td>4</td>
<td>Click Copy.</td>
</tr>
</tbody>
</table>

Related Links
- Configuring Night Service Annual Schedule
- Configuring Night Service Daily Schedule
- Configuring Night Service Code

Configuring Night Service Annual Schedule

An annual schedule specifies the days to which the parameters are applied.

How to get to this screen
Click Configure > Voice > Telephony Features > Night Service Bell > Annual Schedule.
How to use this screen
To add a day for Night Service Bell to the annual schedule, perform these steps:

Step 1 In the Configure tree, click **Configure > Voice > Telephony Features > Night Service Bell > Annual Schedule**. Cisco Configuration Professional displays the Configure Night Service Annual Schedule screen.

Step 2 To choose the desired month, click the arrow keys on the calendar.

Step 3 To choose the desired day of the month, click the day of the month on the calendar.

Step 4 To set the start and stop times:
- Select the hour or the minute under the desired day of the week and use the arrows to change the time.
- To toggle between ante meridiem and post meridiem, select **am** or **pm** and use the arrows to change the setting.

Step 5 Click **Add**.
To set the start and stop time for length of the entire day, check **All Day**.

Related Links
- Configuring Night Service Weekly Schedule
- Configuring Night Service Daily Schedule
- Configuring Night Service Code

**Configuring Night Service Daily Schedule**

A night service bell can be scheduled for every day of the week.

How to get to this screen
Click **Configure > Voice > Telephony Features > Night Service Bell > Daily Schedule**.
How to use this screen

To configure a daily schedule, perform these steps:

---

**Step 1**  

**Step 2**  
Check Enable daily schedule override. To disable this night service, uncheck the checkbox.

**Step 3**  
To set the start and stop times:
  - Select the hour or the minute under the desired day of the week and use the arrows to change the time.
  - To toggle between ante meridiem and post meridiem, select am or pm and use the arrows to change the setting.

Related Links

- Configuring Night Service Weekly Schedule
- Configuring Night Service Annual Schedule
- Configuring Night Service Code

Configuring Night Service Code

The night service code is used by user to temporarily enable or disable night service. There is one code for all the phones. Dialing the same code toggles the service on or off.

How to get to this screen

Click Configure > Voice > Telephony Features > Night Service Bell > Code.
Paging Numbers

A paging number can be defined to relay audio pages to a group of designated phones. When a caller dials the paging number, each idle IP phone that has been configured with the paging number automatically answers using its speakerphone mode. Displays on the phones that answer the page show the caller ID that has been set under the paging number. When the caller finishes speaking the message and hangs up, the phones are returned to their idle states.

Audio paging provides a one-way voice path to the phones that have been designated to receive paging. It does not have a press-to-answer option like the intercom feature. The paging number can be dialed from anywhere, including on-net.
Paging Number Reference

The following topics describe the Paging Number window used to configure paging numbers:

- Configure Paging Numbers
- Edit or Create a Paging Number
- Set Phones Paging Type Preference

Configure Paging Numbers

Display, enter, or modify the paging number parameters.

How to get to this screen
Click Configure > Voice > Telephony Features > Paging Numbers.

Related Links
- Edit or Create a Paging Number
- Set Phones Paging Type Preference

Field Reference

<table>
<thead>
<tr>
<th>Table 8-16  Configure Paging Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>Paging Name</td>
</tr>
<tr>
<td>Paging Number</td>
</tr>
<tr>
<td>Multicast IP Address</td>
</tr>
<tr>
<td>UDP Port Number</td>
</tr>
<tr>
<td>Member Phones</td>
</tr>
</tbody>
</table>
Chapter 8  Configuring Telephony Features

Paging Numbers

Edit or Create a Paging Number

Enter or modify the paging number parameters.

**How to get to this screen**
- Click **Configure > Voice > Telephony Features > Paging Numbers > Edit**.
- Click **Configure > Voice > Telephony Features > Paging Numbers > Create**.

**Related Link**
- **Set Phones Paging Type Preference**

**Field Reference**

<table>
<thead>
<tr>
<th>Table 8-17</th>
<th>Edit or Create Paging Number</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Paging name</td>
<td>Assign a name to appear in caller-ID displays and directories to the paging number. Once the Paging name is configured, it cannot be changed.</td>
</tr>
<tr>
<td>Paging number</td>
<td>Enter a unique Paging Number that is called to initiate a page. Once the Paging Number is configured, it cannot be changed. This number must be unique throughout the system.</td>
</tr>
<tr>
<td>Multicast IP address</td>
<td>Specify a multicast IP address to use for the paging numbers. Each paging number must use a unique multicast IP address. Note that IP phones do not support multicast at 224.x.x.x addresses.</td>
</tr>
<tr>
<td>UDP port number</td>
<td>Specify the port to be used to broadcast paging messages to the idle IP phones. The UDP port number is used to broadcast audio paging messages to the idle IP phones that are associated with the paging number that is a member of the Paging Group.</td>
</tr>
<tr>
<td>Available Phones</td>
<td>All phones not associated with any paging number.</td>
</tr>
</tbody>
</table>
Set Phones Paging Type Preference

The paging mechanism supports audio distribution using IP multicast, replicated unicast, or both. (Multicast is used where possible and unicast is used for phones that cannot be reached through multicast.)

How to get to this screen
Click Configure > Voice > Telephony Features > Paging Numbers > (select a) paging number > Set Phones Paging Type Preference.

Related Link
• Edit or Create a Paging Number

Field Reference

Table 8-18 Edit or Create Paging Number

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phones</td>
<td>Select the phone to be modified. If the selected phone already has Paging Time configured, that value is selected in Paging Type radio button. The Paging Time can be changed anytime.</td>
</tr>
</tbody>
</table>
Chapter 8  Configuring Telephony Features

Paging Groups

A paging group is a group of paging numbers that relays incoming audio pages to a group of phones associated to member paging numbers. By combining paging numbers into paging groups, a user can page a paging group of up to ten member phones (such as, paging four phones in a store's jewelry department).

Paging numbers can be combine into paging groups For example, you can assign Paging Number 1000 to all phones located in one part of a human resources department. Assign Paging Number 2000 to all phones in a related part of the legal department. Then create Paging Group 3000 and assign as its members Paging Number 1000 and Paging Number 2000. Paging 1000 relays audio pages to phones in the human resources department. Paging 2000 relays audio pages to phones in the legal department. Paging 3000 relays audio pages to phones in both departments.

Note Configure Paging Numbers before configuring Paging Groups.

Paging Groups Reference

The following topics describe the Paging Group window used to configure paging groups:

- Configure Paging Groups
- Edit or Create a Paging Group

Table 8-18  Edit or Create Paging Number

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paging type</td>
<td>Specify that the phone will use unicast paging or multicast paging.</td>
</tr>
<tr>
<td></td>
<td>Multicast is used where possible and unicast is used for phones that</td>
</tr>
<tr>
<td></td>
<td>cannot be reached through multicast.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> The maximum number of phones supported by using unicast is</td>
</tr>
<tr>
<td></td>
<td>limited to ten phones.</td>
</tr>
</tbody>
</table>

Multicast is used where possible and unicast is used for phones that cannot be reached through multicast.

Note The maximum number of phones supported by using unicast is limited to ten phones.
Configure Paging Groups

Display, enter, or modify the paging group parameters.

How to get to this screen
Click Configure > Voice > Telephony Features > Paging Groups.

Related Link
- Edit or Create a Paging Group

Field Reference

Table 8-19  Configure Paging Groups

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paging Name</td>
<td>Name that appears in caller-ID displays and directories during the page.</td>
</tr>
<tr>
<td>Paging Number</td>
<td>Extension number associated with the paging group. This is the number that people call to initiate a page.</td>
</tr>
</tbody>
</table>
| Multicast IP Address   | Multicast IP address used to broadcast audio paging messages to the idle IP phones, associated with the paging number, that are part of a paging group. Each paging group must use a unique multicast IP address.  
                          | Note that IP phones do not support multicast at 224.x.x.x addresses.                                                                         |
| UDP Port Number        | UDP port that broadcasts audio paging messages to the idle IP phones that are associated with the paging number for that paging group.          |
| Group Members          | Displayed number of paging number members in a paging group.                                                                               |

Edit or Create a Paging Group

Enter or modify the paging group parameters.

How to get to this screen
- Click Configure > Voice > Telephony Features > Paging Groups > Edit.
- Click **Configure > Voice > Telephony Features > Paging Groups > Create.**

**Related Link**
- **Configure Paging Groups**

**Field Reference**

*Table 8-20  Edit or Create a Paging Group*

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paging name</td>
<td>Assign a name to appear in caller-ID displays and directories to the paging number group.</td>
</tr>
<tr>
<td>Paging number</td>
<td>Enter a unique Paging Number that is called to initiate a page. Once the Paging Number is configured, it cannot be changed. This number must be unique throughout the system.</td>
</tr>
</tbody>
</table>
| Multicast IP address  | Specify a multicast IP address to use for the paging numbers group. When multiple paging groups are configured, each paging group must use a unique multicast IP address.  
**Note**  IP phones do not support multicast at 224.x.x.x addresses. |
| UDP port number       | Specify the UDP port number to be used to broadcast paging messages to the idle IP phones. The default port number is 2000. |
| Available Paging Numbers | All configured Paging Numbers that are available to be part of a paging group. |
Phone Softkey Templates

You can customize the display and order of soft keys that appear during various call states on individual IP phones. Using softkey templates, you can delete soft keys that would normally appear or change the order in which the soft keys appear. For example, you might want to display the CFwdAll and Confrn soft keys on a manager's phone and remove these soft keys from a receptionist's phone.

**Note**  Ringing call state is not supported.
Phone Softkey Template Reference

The following topics describe the window used to configure Softkey Templates:

- Configure Phone Softkey Templates
- Edit or Create a Phone Softkey Template
- Associate Phones

Configure Phone Softkey Templates

In the Softkey Templates screen, review and manage softkey templates.

**Note**

Hlog softkey is available when huntgroup logout (Hlog) is enabled in the Telephony settings.

**Note**

Flash softkey is available if FXO hookflash is enabled in the Telephony settings.

**How to get to this screen**

Click Configure > Voice > Telephony Features > Phone Softkey Templates.

**Related Links**

- Edit or Create a Phone Softkey Template
- Associate Phones

**Field Reference**

**Table 8-21  SCCP Softkey Templates**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template ID</td>
<td>A number from 1 to 20 that identifies the template.</td>
</tr>
<tr>
<td>Softkey Call States</td>
<td>The call states that are configured for this template. A call state with no softkeys configured does not appear in this column.</td>
</tr>
<tr>
<td>Associated Phones</td>
<td>The phones associated with this template.</td>
</tr>
</tbody>
</table>
Edit or Create a Phone Softkey Template

Use the Create or Edit Softkey Template screen to change settings for call states and softkeys.

How to get to this screen

- Click Configure > Voice > Telephony Features > Phone Softkey Templates > Create.
- Click Configure > Voice > Telephony Features > Phone Softkey Templates > Edit.

This screen lets you select and order softkeys for multiple call states. To make settings for a call state, complete the following tasks:

To edit or create a softkey template, perform these steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the Configure tree, click Click Voice &gt; Telephony Features &gt; Phone Softkey Templates. Cisco Configuration Professional displays the Softkey Templates screen.</td>
</tr>
<tr>
<td>2</td>
<td>To edit an entry, choose an entry in the screen. To add a template, skip this step.</td>
</tr>
<tr>
<td>3</td>
<td>To display the Edit Softkey Template screen, click Edit or to display the Add Softkey Template screen, click Create.</td>
</tr>
<tr>
<td>4</td>
<td>If you are editing a template, skip this step; the Template ID field is read only. If you are adding a template, enter the identification number in the Template ID field. The identification number range is from 1 to 20. There is no default.</td>
</tr>
<tr>
<td>5</td>
<td>Select the group of softkeys you want to modify. Table 8-22 describes the groups.</td>
</tr>
</tbody>
</table>

<p>| Table 8-22 Softkey Template Call States |</p>
<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert Call State</td>
<td>A phone is in the alert call state when the remote point is being notified of an incoming call, and the status of the remote point is being relayed to the caller as either ringback or busy</td>
</tr>
<tr>
<td>Connected Call State</td>
<td>A phone is in the connected call state when the connection to a remote point is established.</td>
</tr>
<tr>
<td>Hold Call State</td>
<td>A phone is in the hold call state when a connected party is still connected but there is temporarily no voice connection.</td>
</tr>
</tbody>
</table>
Each softkey is described in Table 8-23. Not all softkeys are available for all call states.

**Step 6** To select an available softkey, click a softkey name in the Available Softkeys column and click the right arrow. The softkey moves to the Selected Softkeys column, and will be available on phones that use this template.

To move all available softkeys from the Available Softkeys column to the Selected Softkeys column, click the right double-arrow. To remove all available softkeys from the Selected Softkeys column, click the left double-arrow.

To remove a softkey from the Selected column, click the softkey name and then click the left arrow. The softkey moves to the Available column, and will not be available on phones that use this template.

**Step 7** The order of softkeys in the Selected column determines the order that the keys will be seen on phones. To move a softkey up the list of selected softkeys, select the softkey and click the up arrow.

To move a softkey down the list of selected softkeys, select the softkey and click the down arrow.

<table>
<thead>
<tr>
<th>Table 8-22 Softkey Template Call States</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>Idle Call State</td>
</tr>
<tr>
<td>Seized Call State</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 8-23 Available Softkeys</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Softkey</strong></td>
</tr>
<tr>
<td>Acct</td>
</tr>
<tr>
<td>Answer</td>
</tr>
<tr>
<td>Callback</td>
</tr>
<tr>
<td>Cfwall</td>
</tr>
<tr>
<td>Softkey</td>
</tr>
<tr>
<td>---------</td>
</tr>
<tr>
<td>Confrn</td>
</tr>
<tr>
<td>ConfList</td>
</tr>
<tr>
<td>DnD</td>
</tr>
<tr>
<td>EndCall</td>
</tr>
<tr>
<td>Flash</td>
</tr>
<tr>
<td>GPickUP</td>
</tr>
<tr>
<td>HLog</td>
</tr>
<tr>
<td>Hold</td>
</tr>
<tr>
<td>Join</td>
</tr>
<tr>
<td>Login</td>
</tr>
<tr>
<td>MeetMe</td>
</tr>
<tr>
<td>NewCall</td>
</tr>
<tr>
<td>Park</td>
</tr>
<tr>
<td>PickUp</td>
</tr>
<tr>
<td>Redial</td>
</tr>
<tr>
<td>Resume</td>
</tr>
<tr>
<td>RmLstC</td>
</tr>
<tr>
<td>Select</td>
</tr>
<tr>
<td>Transfer</td>
</tr>
</tbody>
</table>
Related Link

- Configure Phone Softkey Templates

**Associate Phones**

Associate a softkey template with phones.

**How to get to this screen**

- Click Configure > Voice > Telephony Features > Phone Softkey Templates > Associate Phones.

**How to use this screen**

To apply a softkey template to a phone, complete the following tasks:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the Configure tree, click Voice &gt; Telephony Features &gt; Phone Softkey Templates.</td>
</tr>
<tr>
<td>2</td>
<td>In the Softkey templates screen, choose the template to which you want to associate phones.</td>
</tr>
<tr>
<td>3</td>
<td>To associate one or more phones with the template, click Associate Phones. In the Associate Phones screen, select the phone that you want to associate with the template, and click the left arrow. The phone you selected moves to the Selected column. Note, Analog phones are not listed.</td>
</tr>
<tr>
<td>4</td>
<td>To remove a phone from the Selected column, choose the phone, and click the right arrow. The phone moves to the Available column.</td>
</tr>
<tr>
<td>5</td>
<td>When you have added all the phones that you want to associate with this template to the Selected column, click OK. You are prompted to restart the phone.</td>
</tr>
<tr>
<td>6</td>
<td>Click Yes to restart the phone, so the softkeys will be updated to the new configuration. Click No to associate the phone to the template without restarting the phone and updating the softkeys.</td>
</tr>
</tbody>
</table>

**Related Links**

- Configure Phone Softkey Templates
- Edit or Create a Phone Softkey Template
Chapter 9

Configuring Voicemail and Auto Attendant

This chapter explains how to configure Voicemail and Auto Attendant features. It contains the following sections:

- Configuring Voicemail
- Configuring the Call-in Number
- Launching Cisco Unity Express
- Configuring Cisco Unity Express IP Address

Configuring Voicemail

Voicemail initial setup configuration specifies the capacity of the voice system as a whole, and default mailbox settings. Default mailbox settings can be overridden when configuring mailbox settings for specific users.

Voicemail Reference

The following topics describe the window used to configure voicemail:

- Configure Voicemail


## Configure Voicemail

In the Mailbox Defaults screen, enter the system capacity settings and specify default values for individual voice mailboxes.

**How to get to this screen**

Click **Configure > Voice > Voicemail and Auto Attendant > Voice Mail**.

**Related Links**
- [Configuring Voicemail](#)

**Field Reference**

**Table 9-1 Mailbox Defaults**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>System Wide</strong></td>
<td></td>
</tr>
<tr>
<td>System Capacity</td>
<td>The total number of voicemail minutes to store on the system. For AIM-CUE, enter a value from 1 to 840 minutes. For NM-CUE, enter a value from 1 to 6000 minutes. For NM-CUE-EC, enter a value from 1 to 18000 minutes. (The upper limit might vary, based on the type of Cisco Unity Express installed (AIM-CUE, NM-CUE, NME-CUE).)</td>
</tr>
<tr>
<td>Maximum Greeting Recording Size</td>
<td>The total number of seconds of greetings to store on the system. Enter a value from 10 to 3,600 seconds.</td>
</tr>
</tbody>
</table>
| Play Caller ID of External Callers | Specify whether or not the system is to play the caller ID of an external caller by choosing one of the following:  
  • Disable—Do not play the caller ID of external callers.  
  • Enable—Play the caller ID of external callers when it is available. |
| **Mailbox**                   |                                                                                                                                              |
| The values that you enter in the following fields are default values that can be overridden when configuring user mailboxes. |
| Voice Mailbox Size            | The default maximum number of seconds of stored messages allowed for voice mailboxes.                                                         |
Configuring the Call-in Number

The call-in number is the number (trigger) that is called to invoke a particular application. This can be your main auto-attendant number, or a temporary one. Without a call-in number, you cannot test or launch a script.

**Note**

The Cisco Unity Express IP configuration window configures the Service Engine/Integrated Service Engine interface of Cisco unity express module. If Cisco Unity Express is not in a proper state, this feature is not available.

**How to get to this screen**

Click Configure > Voice > Voicemail and Auto Attendant > Unity Express IP Configuration.

Call-in Number Reference

The following topics describe the window used to Call-in Number parameters:

- Configure the Call-in Numbers
- Edit or Create Cisco Unity Express Call-in Numbers
Configure the Call-in Numbers

Enter the call-in number.

How to get to this screen
Click Configure > Voice > Voicemail and Auto Attendant > Call-in Numbers.

Related Links
- Edit or Create Cisco Unity Express Call-in Numbers

Field Reference

<table>
<thead>
<tr>
<th>Table 9-2</th>
<th>Unity Express Call-in Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element</td>
<td>Description</td>
</tr>
<tr>
<td>Call-in Number</td>
<td>The number that is called for which a particular application needs to be invoked (trigger).</td>
</tr>
<tr>
<td>Application Name</td>
<td>The application configured.</td>
</tr>
<tr>
<td>Max Call-in Sessions</td>
<td>The maximum number of callers who can concurrently access the application at any given time. This parameter is limited by the number of ports on the Cisco Unity Express module.</td>
</tr>
<tr>
<td>Locale</td>
<td>The locale being used by the application. (This is not configurable.)</td>
</tr>
<tr>
<td>Status</td>
<td>Displays Complete if there is a dial peer configured. Displays Incomplete if there is no dial peer configured.</td>
</tr>
</tbody>
</table>

Edit or Create Cisco Unity Express Call-in Numbers

Enter the call-in number parameters.

How to get to this screen
- Click Configure > Voice > Voicemail and Auto Attendant > Call-in Numbers > Add.
Field Reference

Table 9-3  Add CUE Application Trigger

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call-in number</td>
<td>Enter the call-in number. For Edit Call-in Number will be read-only. You can create more than one trigger for the same application. A duplicate call-in number is not allowed.</td>
</tr>
<tr>
<td>Application Name</td>
<td>Choose one of the applications. (ciscomwiapplication and msgnotification are not supported.)</td>
</tr>
<tr>
<td>Max Call-in Sessions</td>
<td>Enter the maximum number of call-in sessions for the application. The total number allowed is limited by the Usable System port of the module and by the application selected. If you selected the promptmgmt application the value for this field is 1.</td>
</tr>
<tr>
<td>Locale</td>
<td>This field is not editable. It displays the default value systemDefault.</td>
</tr>
</tbody>
</table>

Auto-complete

If an application is found that has a trigger but no dial-peer configured in Cisco Unified Call Manager Express, the status of the Call-in Number is Incomplete. You can use Auto-complete to create the dial peer for the application.

To create a dial-peer for this application, select the Call-in Number and click Auto-complete.

If the task is successful, the status changes from Incomplete to Complete.
Launching Cisco Unity Express

The Cisco Unity Express option opens the Cisco Unity Express Voice Mail and Auto Attendant (CUE) login window. You can open as many CUE windows as you want, but you must repeat the discovery process for the same router to synchronize the configuration with Cisco Configuration Professional.

**Note**
The Cisco Unity Express IP configuration window configures the Service Engine/Integrated Service Engine interface of Cisco unity express module. If Cisco Unity Express is not in a proper state, this feature is not available.

**Caution**
Do not make changes on the same router by using Cisco Configuration Professional and CUE simultaneously. The configurations might conflict.

Cisco Unity Express Reference

- Launch Cisco Unity Express

Launch Cisco Unity Express

You can launch the Cisco Unity Express application from within Cisco Configuration Professional.

**Caution**
After configuring the device with Cisco Unity Express GUI, you must re-discover the device by using Cisco Configuration Professional before using Cisco Configuration Professional to add or modify Voicemail configurations.

**How to get to this screen**
Click Configure > Voice > Voicemail and Auto Attendant > Cisco Unity Express.
Configuring Cisco Unity Express IP Address

Field Reference

Table 9-4 Launch Unity Express GUI

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco Unity Express IP</td>
<td>IP address of CUE service engine. This IP address must be routable to launch the CUE window. The field is auto-populated and it is not editable.</td>
</tr>
<tr>
<td>Launch Cisco Unity Express GUI</td>
<td>Launches the CUE window. It displays a user confirmation dialog.</td>
</tr>
</tbody>
</table>

Caution

Do not make changes on the same router by using Cisco Configuration Professional and Cisco Unity Express simultaneously.

Related Link

- Configure Cisco Unity Express IP Address

Configuring Cisco Unity Express IP Address

Use this window to configure the IP address of the Cisco Unity Express module.

Note

The Cisco Unity Express IP configuration window configures the Service Engine/Integrated Service Engine interface of Cisco unity express module. If Cisco Unity Express is not in a proper state, this feature is not available.
Cisco Unity Express IP Address Configuration Reference

- Configure Cisco Unity Express IP Address

Configure Cisco Unity Express IP Address

Configure the Cisco Unity Express IP address of the Cisco Unity Express module.

Error Messages

- **Unity Express module is not installed**: The Device being discovery is not installed with the Cisco Unity Express module. All Voicemail features are disabled.

- **Unity Express module is not steady state**: The Cisco Unity Express module on the device being discovered is not reachable, the module is being shutdown, or the module is shutdown. All Voicemail features are disabled.

- **Unity Express module is in Offline mode**: The Cisco Unity Express module on the device being discovered is in offline mode. All Voicemail features are disabled. You change the module to online mode and do a discovery to configure Voicemail features.

- **Unity Express module is in boot loader mode**: The Cisco Unity Express module on the device being discovered is in boot loader mode. All Voicemail features are disabled. you must bring the module to online mode and do a discovery to continue configure Voicemail features.

- **Unity Express interface is not up**: The IP unnumbered interface of Service Engine/Integrated Service engine is shutdown.

- **Unity Express is installed with CCM license**: Cisco Unity Express module is installed with a Cisco Configuration Manager (CCM) license that is not supported by Cisco Configuration Professional. You must upgrade the license to the latest version of Cisco Unified Communications Manager Express (CCME) and restart the discovery.

- **Unity Express version is not supported**: Supported versions of Cisco Unity Express module are 2.3, 3.0, and 3.1. Older releases are not supported.

- **Unity Express is reloading**: An attempt might have made to reload the Cisco Unity Express module. You must restart the discovery of the device after the Cisco Unity Express module reload is complete.
How to get to this screen
Click Configure > Voice > Voicemail and Auto Attendant > Cisco UE IP Configuration.

Related Link
- Launch Cisco Unity Express

Field Reference

<table>
<thead>
<tr>
<th>Table 9-5 Cisco Unity Express IP</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>CUE IP Address</td>
</tr>
<tr>
<td>Subnet Mask</td>
</tr>
<tr>
<td>Default Gateway</td>
</tr>
</tbody>
</table>
Phone Firmware

Phone firmware files, also known as a phone load, are stored locally in Flash memory and provide code to enable phone displays and operations. These files are specialized for each phone type and protocol, SIP or SCCP, and are periodically revised. You must be sure to have the appropriate phone firmware files for the types of phones, protocol being used, and Cisco Unified Communications Manager Express (CCME) version at your site. You can use Cisco CP to configure and upload firmware to the phones.

This chapter contains the following sections:

- Configuring Phone Firmware
- Phone Firmware Reference

Configuring Phone Firmware

The Phone Firmware feature uploads a phone firmware tar file to the device Flash. In addition, the upload process configures the load existing on the Flash and allows you to modify phone firmware association for a type of Cisco IP phone.

**Note**

If you upload a phone firmware file that is already present in Flash, Cisco CP overwrites the file in Flash.
If a phone load is already configured for a particular phone type and you try to upload another load file for same phone type, Cisco CP uploads the load files, but it does not overwrite the existing load configured on the phone. You must edit the phone load for that phone type and then update the phone load.

If you attempt to upload a phone load to a Cisco 2800 series router with IOS version 12.4(11)T, the results are unpredictable and this is not recommended. We recommend that you upgrade the router to a more recent image.

You can download phone firmware tar files from this location:
http://www.cisco.com/cgi-bin/tablebuild.pl/ip-iostsp

Phone Firmware Reference

The following topics describe the window used to configure phone firmware, upload a phone firmware tar file to Flash, reset the phones, and display registered phones:

- Phone Firmware
- Upload Phone Firmware
- Reset All Phones
- Show Registered Phones

Phone Firmware

Use this screen to:

- Upload the phone firmware tar files to Flash.
- Associate the phone firmware to a type of Cisco IP phone.
- Reset all phones.
- Display the number of registered phones.
Note

- If you upload a phone firmware file that is already present in Flash, Cisco CP overwrites the file in Flash.
- If a phone load is already configured for a particular phone type and you try to upload another load file for the same phone type, Cisco CP uploads the load files, but it does not overwrite the existing load configured on the phone. You must edit the phone load for that phone type and then reset the phone.
- If you attempt to upload a phone load to a Cisco 2800 series router with IOS version 12.4(11)T, the results are unpredictable and this is not recommended. We recommend that you upgrade the router to a more recent image.

How to get to this screen

- Click Configure > Voice > Firmware > Phone Firmware

Field Reference

Table 10-1  Phone Firmware

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upload Phone Firmware</td>
<td>In this area, browse for phone load files that you have downloaded to the PC, and upload them to the router. You can download phone firmware tar files to the PC from this location: <a href="http://www.cisco.com/cgi-bin/tablebuild.pl/ip-iostsp">http://www.cisco.com/cgi-bin/tablebuild.pl/ip-iostsp</a></td>
</tr>
<tr>
<td>Firmware File</td>
<td>Click Browse to locate the firmware file on the PC. After the tar file is displayed in the Firmware File field, click Upload to load the file. Read Upload Phone Firmware in this help topic for more information.</td>
</tr>
<tr>
<td>Associate Phone Type to Phone Firmware</td>
<td></td>
</tr>
<tr>
<td>Phone Type</td>
<td>Type of phone, for example 7905.</td>
</tr>
<tr>
<td>Phone Firmware</td>
<td>Phone load name, for example CP7905080001SCCP051117ASBIN.</td>
</tr>
</tbody>
</table>
Upload Phone Firmware

Upload the phone firmware to the device Flash. Once the phone load is in the device Flash, the application attempts to configure all the recognized phone loads in device Flash. You can associate the phone load with the phone type.

To upload the phone firmware to the device, do the following:

---

**Step 1**
From the following location, download the load file that you need to the PC:
http://www.cisco.com/cgi-bin/tablebuild.pl/ip-iostp

**Step 2**
Click **Browse** to locate the file on the PC hard drive. The filename is displayed in the Firmware File field.

**Step 3**
Click **Upload** to load the file. A confirmation message is displayed.

**Note**
If there is insufficient Flash memory on the device, Cisco CP displays an information message telling you the amount of available memory and the amount of memory required for the upload. If such a message is displayed, click **Application > Flash File Management**. In the File Management window, choose the files that you want to delete, and click **Delete** at the top of the window. Then, return to this screen.

**Step 4**
To reset all the phones after the phone load file has been uploaded, click **Yes**. To upload the phone load file and configure the phones without resetting them, click **No**.

The files are uploaded to Flash.

---

Reset All Phones

When you reset phones, you perform a complete reboot of all phones associated with a Cisco Unified Communications Manager Express (CCME) router. If a new phone load is associated with a phone type, the phone load is downloaded to the phones.

Click the Reset All Phones button to be prompted to reset the phones. To reset all the phones, click **Yes**. To exit the confirmation message window without resetting the phones, click **No**.
Edit Phone Firmware

In this screen, choose the firmware that you want a phone to use.

**How to get to this screen**

- Click *Configure > Voice > Firmware > Phone Firmware > Edit.*

**Related Links**

- Phone Firmware
- Show Registered Phones

**How to use this screen**

To update phone load association for a particular type of Cisco IP phone, do the following:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Select a phone type from the Associate Phone Type to Phone Firmware list in the Phone Firmware screen, and click <em>Edit.</em></td>
</tr>
<tr>
<td>2</td>
<td>Select the phone load from the Phone Firmware menu. The menu lists only those phone load files that are supported by the selected phone type and present in Flash.</td>
</tr>
<tr>
<td>3</td>
<td>Click <em>OK</em> and you are prompted to reset the phones.</td>
</tr>
<tr>
<td>4</td>
<td>To reset all the phones of a particular type, click <em>Yes.</em> To update the phone load association without resetting the phones, click <em>No.</em></td>
</tr>
</tbody>
</table>

Show Registered Phones

Use this screen to display the number of registered phones.

**Related Links**

- Upload Phone Firmware
- Reset All Phones
- Edit Phone Firmware
How to get to this screen

- Click Configure > Voice > Firmware > Phone Firmware > Show Registered Phones.

**Step 1**  Click **Show Registered Phones** to display a dialog indicating number of registered phones and the total number of phones.

**Step 2**  Click **Refresh** to update the data for the registered phones.
Configuring SRST Rerouting

Cisco Unified Survivable Remote Site Telephony (SRST) is embedded in the software running on Cisco routers. It takes advantage of a remote office's existing network to provide multi feature call-processing redundancy for centralized Cisco Unified Communications Manager and Cisco Unified Communications Manager Business Edition deployments if the office's WAN connection is lost.

This chapter contains the following sections:

- Configuring SRST Rerouting
- Configure SRST Rerouting

Note
SRST Rerouting is available only if the router is in Gateway with SRST mode.

Configuring SRST Rerouting

Cisco Unified SRST is used for the remote office routers that support from 24 to 720 users in a centralized CallManager processing environment, to back up IP phone calls and provide 911 emergency access by the public switched telephone network (PSTN).

Related Links

- Configure SRST Rerouting
- Edit or Create SRST Rerouting
SRST Rerouting Reference

The following topic describes the window used to configure voice gateway mode:

- Configuring SRST Rerouting
- Configure SRST Rerouting
- Edit or Create SRST Rerouting

Configure SRST Rerouting

In the SRST Rerouting screen, you can select the call manager fallback parameters.

Up to 50 sets of rerouting alias rules can be created for calls to telephone numbers that are unavailable during Cisco Unified CallManager fallback. An alias is activated when a telephone registers that has a phone number matching a configured alternate-number alias. Under that condition, an incoming call is rerouted to the alternate number. You can reroute multiple different numbers to the same target number.

The configured alternate-number must be a specific E.164 phone number or extension that belongs to an IP phone registered on the Cisco Unified SRST router. When an IP phone registers with a number that matches an alternate-number, an additional POTS dial peer is created. The destination pattern is set to the initial configured number-pattern, and the POTS dial peer voice port is set to match the voice port associated with the alternate-number.

How to get to this screen
Click Configure > Voice > Dial Plans > SRST Rerouting.

Field Reference

<table>
<thead>
<tr>
<th>Table 11-1</th>
<th>Telephony Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element</td>
<td>Description</td>
</tr>
<tr>
<td>Numbers to Reroute During SRST Fallback</td>
<td>Source numbers to be rerouted.</td>
</tr>
<tr>
<td>Extension to Reroute To</td>
<td>Target number.</td>
</tr>
</tbody>
</table>
Edit or Create SRST Rerouting

You can edit an existing fallback alias or create a new one.

How to get to this screen

- Click Configure > Voice > Dial Plans > SRST Rerouting > Edit.
- Click Configure > Voice > Dial Plans > SRST Rerouting > Create.

Field Reference

Table 11-2  SRST Rerouting

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>... Reroute Numbers that are unavailable During SRST Fallback</td>
<td>Numbers to be rerouted can be identified by selection from a pre-population list, entered as a range, or entered as an individual number.</td>
</tr>
<tr>
<td>Extension to Reroute To</td>
<td>Target extension number.</td>
</tr>
</tbody>
</table>

Related Links

- Configuring SRST Rerouting
- Configure SRST Rerouting
Numerics

911 emergency access (SRST) 11-1

A

ad hoc conferencing 8-7
After-Hours Tollbar
call blocking restrictions 8-3
calling restrictions 8-3
fast busy 8-2
holiday 8-5
override softkey login 8-6
reset to system defaults 8-6
unauthorized use of phones 8-2
weekly schedule 8-4
analog phone 7-6
analog telephone adaptor (ATA) 7-1
analog trunk 4-3
audio paging 8-31
autoanswer (intercom) 8-24
auto attendant 9-1
auto-complete (Cisco Unity Express Call-In Number) 9-5
autodial 8-24

B

back up IP phone calls 11-1
blocked call
override (softkey login) 8-6
prefixes 8-3
boot loader (Cisco Unity Express) 9-8

C

call blocking
extension 7-12
outgoing 5-7
override 8-2, 8-6
PIN 8-2
call control 1-1
caller-ID
intercom 8-25
paging name 8-32
calling plan
outgoing call blocking 5-7
outgoing call handling 5-6
calling restrictions (After-Hours Tollbar) 8-3

call-in number (Cisco Unity Express) 9-3

Call Manager IP 2-3
call park
  Advanced tab 8-9, 8-11
directed 8-10
general purpose 8-10
  General tab 8-9, 8-11
  name 8-11
  reminder 8-12
  reminder ring 8-11
  slot number 8-11
  slots 8-11
  termination 8-12
call pickup (night service bell) 8-26
call pickup groups
  description 8-13
  number 8-15
call-waiting 8-26

Cisco Communications Manager (CCM)
  gateway mode 2-1
  license 9-8

Cisco IP Auto Attendant 8-21
Cisco Unified Communications Manager Express (CME) 1-1
Cisco Unified Survivable Remote Site Telephony (SRST)
  See SRST
Cisco Unity Express
  Call-In Number 9-5

error messages 9-8
  IP address 9-7
  IP configuration 9-6
  launch 9-6
  mailbox 7-13
  reload error 9-8
  service engine 9-7
  supported versions 9-8
  voicemail 9-8

Cisco WebAttendant 8-18
class of restriction (COR) 7-10
Class of Restrictions (COR) 5-5, 7-11
codec
  gateway 5-12
  phone 7-7
  VoIP 5-10
codec type
  G711 8-8
  G729 8-8
conferencing
  call conferencing 8-7
  DSP farm 8-7

date format 6-2
default configuration 1-4
dial peers, dummy 2-3
dial plan
incoming dial or calling plan 5-2
outgoing call blocking 5-7
outgoing call handling 5-6
digital signal processor (DSP) 8-7
digital-signal-processor (DSP) 8-7
digital trunk 4-9
Direct Inward Dialing (DID) 4-1
directory number 8-17
directory numbers (night service bell) 8-26
directory services 8-16
do-not-disturb (DND) 6-3
DSP farm 8-7
dummy dial peers 2-3

fast busy (After-Hours Tollbar) 8-2
firmware, phone 10-1
Flash (phone firmware) 10-1
FXO 4-2, 6-2
FXS 4-1
FXS port 7-6

g711ulaw 5-10
gateway
    Cisco Communications Manager
        (CCM) 2-1
        type 2-2
        VoIP 5-10
greeting 7-16

H.323 1-1, 2-1, 2-3
hi_v_dp_in 5-2
hook flash 6-2
hosting CME 1-1
hunt groups
    Advanced tab 8-22
    extension timeout 8-21
    General tab 8-19
    limit ephone-hunt group calls 8-23
    logout 6-3
    number of hops 8-23

emergency access (SRST) 11-1
emergency numbers 5-6
erase all configuration parameters 1-4
error messages (Cisco Unity Express) 9-8
extensions
    configure 7-2
    user management 7-10
    user settings 7-12

fallback
    SRST 1-1
Index

on-hook time stamp 8-23
pilot number 8-18, 8-19
preference order for the backup number 8-23
primary and secondary pilot numbers 8-23
unsanswered call message 8-23

I

incoming dial or calling plan 5-2
Integrated Services Router (ISR) 1-1
intercom 8-24
mute 8-26
international calls 5-6
intersite VoIP
    codec 5-10, 5-12
    remote site 5-9, 5-11
    routing calls 5-8
IP address
    Cisco Unity Express 9-7
IP phones, configure 7-5
ISDN BRI 4-9
ISDN PRI
    configure trunk 4-9
    Voice mode support 4-9
L

license

Cisco Communications Manager (CCM) 9-8
telephony 6-1
long distance calls 5-6

M

mailbox 7-13
    defaults 9-2
    tab 7-13
    user settings 7-13
media access control (MAC) address (IP phone) 7-5
Media Gateway Control Protocol (MGCP) 2-1, 4-9
media translation 1-1
MGCP protocol type 2-3
mixed mode 8-8
model number
    IP phone 7-5
multi-party conferencing 8-8

N

name, call park 8-11
night service, enable 7-6
night service bell
    annual schedule 8-28
    call pickup 8-26
    code 8-30
daily schedule 8-29
directory numbers 8-26
silent ring 8-26
weekly schedule 8-28

display the registered phones 10-5
download link 10-2, 10-3
reset phone 10-4
phones
configure 7-5
editing 7-6
ring behavior 7-13
softkeys 8-41
user settings 7-12
pilot number 8-18, 8-20
place a call on hold 8-10
plain old telephone service (POTS) 1-1
primary extension
  IP phone 7-5
protocol types
  H.323 2-3
  MGCP 2-3
  SIP 2-3
PSTN trunk 4-1
public switched telephone network (PSTN) 1-1

pay-per-minute calls 5-7
peer-to-peer communication 5-8, 5-10
personal identification number (After-Hours Tollbar) 8-2

pay-per-minute calls 5-7
peer-to-peer communication 5-8, 5-10
personal identification number (After-Hours Tollbar) 8-2

remote worker 7-7
Index

ring behavior  7-12
route calls by using intersite VoIP  5-8
router operating mode  1-2

S

Service Engine/Integrated Service Engine  9-8
Session Initiation Protocol (SIP)  2-1
silent ring
  call-waiting  8-26
  night service bell  8-26
SIP protocol type  2-3
softkey
  login override  8-6
  telephony  6-1, 6-2
  templates
    associating phones  8-43
    configuring  8-38
softkey template  8-40
speed-dial
  intercom  8-24
  maximum number  8-17
SRST
  configuring  3-1
  fallback  1-1
  formats  3-1
  licenses  3-1
  rerouting  11-1
Survivable Remote Site Telephony (SRST)

See SRST

telephony
  configuring  6-1
  date format  6-2
  features  8-1
  hook flash  6-2
  hunt groups logout  6-3
  license  6-1
  phone registration source IP address  6-2
  softkey  6-1, 6-2
  time format  6-2
  termination, call park  8-12
  time-division multiplexing (TDM)  4-12
  time format  6-2
  toolbar
    exempt phone  7-6
    configuring  8-2
    See also After-hours Tollbar
trunk
  analog  4-3
  associated with dial plans  5-6
  digital  4-9
  emergency call type  5-7
  PSTN  4-1
U

unauthorized use of phones (After-Hours Tollbar) 8-2
user configuration 7-7, 7-8
user ID 7-5
users
    configuring 7-7
    display name 7-9
    Extension tab 7-10
    password generation 7-9, 7-14
    Phone tab 7-12
    PIN generation 7-9, 7-14

V

voice
    mailbox 7-13
voice gateway mode 2-1
voicemail
    Cisco Unity Express 9-6
    default mailbox settings 9-1
    features 9-1
    greeting 7-16
    mailbox defaults 9-2
voice mode 1-2