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Preface 
Documentation for Cisco Validated Designs 

The following types of documentation for Cisco Validated Designs (CVDs) provide the foundation for 
systems design based on common use cases or current engineering system priorities. They incorporate a 
broad set of technologies, features, and applications to 
address customer needs and ensure faster, more reliable, 
and fully predictable deployment: 

Cisco Preferred Architecture (PA) Design Overview guides 
help customers and sales teams select the appropriate 
architecture based on an organization's business 
requirements, understand the products that are used within 
the architecture, and obtain general design best practices. 
These guides support sales processes. 

Cisco Validated Design (CVD) guides provide detailed steps 
for deploying the Cisco Preferred Architectures. These guides 
support planning, design, and implementation of the Preferred 
Architectures. 

Cisco Collaboration Solution Reference Network Design 
(SRND) guides provide detailed design options for Cisco 
Collaboration. The SRND should be referenced when design 
requirements are outside the scope of Cisco Preferred 
Architectures.  

 

Scope 
Organizations want to reap the budgetary and productivity gains that a remote workforce allows, without 
compromising the benefits of face-to-face interaction. They need a solution that is fast to deploy and easy 
to manage from a central location, without replicating costly components at their remote sites.  

This document details Video Collaboration with Desktop and Multipurpose Room Systems. It covers the 
following areas of technology and products: 

• Video call agent 

• Desktop video endpoints 

• Multipurpose room systems 

• Video Conference Bridge 

• Video Conference Management Systems 

• Video Conference Scheduling Systems 

To view the related CVD guides,  
click the titles or visit the following site: 

http://www.cisco.com/go/cvd/collaboration 

Related CVD Guides 
Unified Communications  
Using Cisco Business Edition 
6000 CVD 

Related PA Guides 
Cisco Preferred Architecture for 
Midmarket Collaboration,  
Design Overview 
Cisco Preferred Architecture for Video,  
Design Overview 

http://www.cisco.com/c/en/us/solutions/enterprise/validated-designs-collaboration/index.html
http://www.cisco.com/c/en/us/solutions/enterprise/validated-designs-collaboration/index.html
http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/uc_system/design/guides/UCgoList.html#48016
http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/uc_system/design/guides/UCgoList.html#48016
http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
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• Video Recording and Streaming 

• Session Initiation Protocol (SIP) signaling 

For more information, see the Design Overview section in this guide. 

Proficiency 
This guide is for people with technical proficiencies—or equivalent experience in CCNA Collaboration—1 to 
3 years in designing, installing, and troubleshooting voice and unified communications applications, 
devices, and networks.  

Comments and Questions 
If you would like to comment on a guide or ask questions, please email  
collab-mm-cvd@external.cisco.com. 

Disclaimer 
The IP address scheme used in this document is for representational purposes only. 

Whats new in this version 
• Cisco Meeting Server as the Conferencing Bridge 

• Cisco Meeting Server as the Recording Platform 

• Cisco TelePresence Server and Cisco Conductor has been removed 

• Cisco TelePresence Content Server has been removed 

 

 

 

 

 

 

mailto:collab-mm-cvd@external.cisco.com
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Introduction 
Businesses around the world are struggling with escalating travel costs. Growing corporate expense 
accounts reflect the high price of travel, but travel also takes a toll on the health and well being of 
employees and their families. Often, the only way to solve a difficult problem is to fly an expert to the 
location to see the issue and discuss it with the people at the site. When an expert cannot see what is 
being described, the resolution of a complex problem often takes much longer. 

Workers at remote sites often feel isolated from their departments because they do not spend enough 
face time with their peers and they feel disconnected from the decision-making process. This isolation can 
lead to lower job performance and less job satisfaction from employees who do not work at the 
organization’s main location. 

Hiring process can be very lengthy and costly, especially when candidates are located in other cities or 
when multiple people are involved in the interview process. Organizations with video conferencing systems 
in their offices can reduce expenses and time by bringing candidates into the nearest facility and allowing 
interviews to be conducted both in person and over video.  

Technology Use Case 
The face-to-face interaction during video collaboration meetings helps to boost information retention, 
promotes increased attention span, and reduces participant confusion. The nonverbal cues experienced in 
a visual meeting are sometimes more important than what is actually spoken. 

Use Case: Video Collaboration with Desktop and Multipurpose Room 
Systems 
Organizations want to reap the budgetary and productivity gains that a remote workforce allows—without 
compromising the benefits of face-to-face interaction. They want to allow the flexibility for an employee to 
work across remote sites while still maintaining the familiar in-person contact of their peers and managers. 
They also want to enrich the collaboration experience in their meeting rooms, boardrooms, auditoriums 
and other shared environments. A solution is needed that is fast to deploy and easy to manage from a 
central location without replicating costly components at their remote sites. 

This design guide enables the following capabilities: 

• Single cluster centralized design to simplify deployment and management while saving on 
infrastructure components. 

• URI and numeric dialing to allow video-enabled IP phones to call room systems. 

• Provisioning the videoconference bridge for the site. 

• Conference resource optimization, management and scheduling. 

• Instant, Personal and Scheduled Conferences on Cisco Meeting Server Spaces. 

• Recording and Streaming of Conferences.  



452BIntroduction 

 

 

 
 PAGE 6  

Technology Use Case Design Overview  Deployment Details  Product List Contents  

• Captures video and presentations for live streaming and video-on-demand (VoD) viewing. 

Design Overview 
An end-to-end video-collaboration solution incorporates a full suite of endpoints, infrastructure 
components, and centralized management tools. 

Cisco Preferred Architecture 
Cisco Preferred Architectures provide recommended deployment models for specific market segments 
based on common use cases. They incorporate a subset of products from the Cisco Collaboration portfolio 
that is best suited for the targeted market segment and defined use cases. These deployment models are 
prescriptive, out-of-the-box, and built to scale with an organization as its business needs change.This 
prescriptive approach simplifies the integration of multiple system-level components and enables an 
organization to select the deployment model that best addresses its business needs. 

The Cisco Preferred Architecture (PA) delivers capabilities that enable organizations to realize immediate 
gains in productivity and add value to their current voice deployments. 

Figure 1.   High-Leve l B lock D iagram 

 



452BIntroduction 

 

 

 
 PAGE 7  

Technology Use Case Design Overview  Deployment Details  Product List Contents  

Network Considerations 
If you already have an IP network in place for voice, your natural next step is to deploy video over IP. Many 
organizations run video systems in a mixed environment as they move from older systems to newer ones, 
based on IP. As older systems migrate off of ISDN, significant quality improvements and cost savings will 
be seen. 

Unified communications running over IP offers lower costs, easier management, remote monitoring, and 
control from across the network. It also provides higher bandwidth for calls, enabling superior audio and 
video quality while providing tighter integration into the corporate IT mainstream. 

With an IP network, the ongoing costs of running video calls are minimal because you only have to pay for 
maintenance and technical support. When return on investment (ROI) for the initial deployment is met, any 
additional costs are essentially free. Because there is no incremental cost involved, employees and 
managers are more likely to use the technology. As usage goes up, payback times go down, further 
boosting the ROI. 

Solution Details 
The Video Conferencing CVD includes the following components: 

• Cisco Unified Communications Manager (Unified CM), for call control and SIP endpoint registrations 

• Desktop (Cisco 8800 series IP phones, Cisco Jabber and Cisco Desktop Collaboration Experience DX 
series) and multipurpose (Cisco TelePresence SX 10 and 20 Quick Set) systems for placing and 
receiving calls 

• Cisco Meeting Server for reservation-less, instant conference (formerly ad-hoc conference), 
personal conference (formerly rendezvous/static conference) 

• Cisco TelePresence Management Suite (TMS) for scheduled conference 

• Cisco Meeting Server for conference recording 

• Network Time Protocol (NTP) server for logging consistency 
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Figure 2.   High-Leve l Ne twork D iagram 
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Cisco Unified Communications Manager 
Unified CM serves as the software-based, call-processing component of Cisco Unified Communications. 
Additional data, voice, and video services, such as unified messaging, rich media conferencing, 
collaborative contact centers, and interactive multimedia response systems, interact through Cisco Unified 
Communications Manager open-telephony application program interface (API). 

Unified CM is the primary call agent in this CVD. Unified CM supports session initiation protocol (SIP), and 
the configurations in this document use SIP as the signaling protocol for endpoints. 

Cisco Video and TelePresence Endpoints 
Cisco video endpoints provide IP video telephony features and functions similar to IP voice telephony, 
enabling users to make point to point and multipoint video calls. Cisco video endpoints are classified into 
families based on the features they support, hardware screen size, and environments where the endpoints 
are deployed. 

There are two types of endpoints mentioned in this document: 

• Desktop & Mobile Video endpoints—Cisco Jabber software-based clients, such as Cisco Jabber for 
Windows/Mac/Android/IOS and the Cisco 8800 series IP phones are capable of transmitting video by 
means of the built-in front-facing camera. The Cisco TelePresence System DX70 and 80 endpoints 
take the personal desktop solution to the next level of experience with support for content sharing, 
mobile and remote access. 

• Multipurpose Endpoints—The Cisco TelePresence SX10 and SX20 Quick Sets are flexible integrators 
that can turn any display into a powerful Cisco TelePresence system. SX20 Quick Sets are designed 

for HD video and multiparty conferencing, with the flexibility to accommodate various room sizes. 

Cisco Meeting Server 
The Cisco Meeting Server is an innovative software solution enabling high-quality standards-based 
conferencing for mobile, webRTC based clients, desktop and immersive endpoints. It can have instant, 
personal and scheduled conferences hosted on Spaces. It also enables Recording and streaming of the 
conferences. It is available in both applicance based offering and can also be installed on a specs based 
vmware hardware.  

Spaces are always-on virtual spaces that have a fixed video address. Users can call in to that address at 
any time to start a meeting.  

Cisco TelePresence Management Suite 
Cisco TelePresence Management Suite (Cisco TMS) enables a variety of scheduling features and 
management functionality within Cisco Unified Communications for the Scheduled Conferences. 
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Dial Plan 
These design uses, single-cluster, centralized call processing. The endpoints use a seven-digit phone 
number for dialing, which preserves the capability to receive calls from devices that only support only 
numeric dialing. The numbers are in the following pattern: 

• 800xxxx 

For URI dialing the endpoints are assigned the URI in the following pattern: 

• 800xxxx@mmcvd.ciscolabs.com 

The domain used in this document is mmcvd.ciscolabs.com. 

As your solution grows, you may need to acquire a security certificate from a public certification authority. 
Choose a domain name in this step with a valid Internet domain suffix (.com, .edu etc) to ensure that your 
system is ready for this requirement. 

For instant conferences, Cisco Meeting Server is added as a media resource on the Unified CM. 

For personal Spaces, Cisco Meeting Server is SIP trunked to Unified CM. Personal Spaces can have both 
numbers and URIs. In this document, every user has a dedicated number and URI configured on the Cisco 
Meeting Server imported via Active Directory. The Space numbers and URIs used in the following pattern: 

• 851xxxx 

• <user>.space@mmcvd.ciscolabs.com    e.g. abdey.space@mmcvd.ciscolabs.com 

For scheduled conferences, Cisco Meeting Server is SIP trunked to Unified CM. In this document, the 
same SIP trunk referenced above is used. Whenever a user schedules a conference; a number, from a 
configured range in TMS, is assigned to the scheduled conference for the users to dial in. The scheduled 
conference numbers are used in the following pattern: 

• 821xxxx 

For recording, Cisco Meeting Server is SIP-trunked to Unifed CM. User can press a number to start and 
stop a recording. In this document, the same SIP trunk referenced above is used. For self-video recording 
the user has to be the only participant in the space and record the space.  
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Deployment Details 
This guide is divided into multiple sections: server installations and deploying Spaces. Each section has 
procedures and steps needed to configure the system from the ground up. 

For customers who want to deploy both conferencing and recording in their environments, please follow all 
the procedures in all the process boxes. 

For customers who want to deploy only conferencing without the recording capability, please skip the 
precedures labelled as (recording only). 

For customers who want to deploy only recording without the conferencing capability, please follow the 
procedures labelled as (recording only). 

For the installation of Cisco Unified Communications Manager (Unified CM), refer the to the Installing the 
Cisco Unified CM process in the Installation Guide for Cisco Business Edition 6000. 

 Easy Access Configuration Sheet 
General Networking Parameters 

Element CVD Configuration Site-Specific Configuration 
Domain name  mmcvd.ciscolabs.com  
DNS server 10.106.170.130  
NTP server 10.106.170.130  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.cisco.com/c/en/us/support/unified-communications/business-edition-6000/products-installation-guides-list.html
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Installing Cisco Meeting Server 
Easy Access Configuration Sheet 

Cisco Meeting Server Installation Requirements 
Element CVD Configuration Site-Specific Configuration 
Cisco Meeting Server Name  cms1  
Cisco Meeting Server IP 
Address for Conferencing 

10.106.170.214  

Cisco Meeting Server IP 
Address for Recording and 
Streaming 

10.106.170.215  

Cisco Meeting Server 
Subnet Masks 

255.255.255.128  

Cisco Meeting Server 
Default Gateway 

10.106.170.129  

 

Cisco Meeting Server Configuration Requirements 
Element CVD Configuration Site-Specific Configuration 
User for API access apiadmin  
 

We would need two instances of Cisco Meeting Servers installed. One for Conferencing and the second 
for Recording and Streaming. 

PR
O

C
ES

S
 

 1. Configure  Cisco  B usiness Ed ition 6000 Connectivity to  LAN 

2. Deploy OVA to  Host fo r Confe rencing 

3. Deploy OVA to  Host fo r Record ing and Streaming 

4. Configure  the  VM Guest fo r Confe rencing 

5. Configure  the  VM Guest fo r Record ing 

6. Apply Licenses on Cisco  Meeting Server 
 

 

 This process guides you through installing the Cisco Meeting Server.  

 

Procedure 1   Configure  Cisco  B usiness Ed ition 6000 Connectivity to  LAN 

 

The Cisco Business Edition 6000 is connected to a switch in the data center. 

Step 1.   Using the user account that has the ability to make configuration changes, log in to the data 
center switch. 
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Step 2.   If there is a previous configuration on the switch port where BE6000 is connected, bring the 
port back to its default state by issuing a no in front of each command. 

Step 3.   Configure the port as an access port.  

interface GigabitEthernet1/14  

description BE6000 

switchport access vlan 20 

switchport host 

  

Procedure 2   Deploy OVA to  Host fo r Confe rencing 

 

This procedure represents a typical installation. The Deploy OVF Template wizard dynamically changes to 
reflect host configuration, so your steps may vary. 

Step 1.   Log in to vSphere in order to access the ESXi Host. 

Step 2.   Select File > Deploy OVF Template. 
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Step 3.   Click Browse, find the location of the ova file, click Open, and then click Next. 

 

Step 4.   On the OVF Template Details page, click Next. 

Step 5.   If an End User License Agreement page appears, read it, click Accept, then Next. 

Step 6.   On the Name and Location page, enter cms1 and the Inventory Location where the virtual 
machine will reside. 

Step 7.   If the Host Cluster page appears, select the host or cluster you want to run the deployed 
virtual machine, and then click Next. 

Step 8.   If the Resource Pool page appears, select the resource pool with which you want to run the 
deployed virtual machine, and then click Next. 

Step 9.   If the Storage page appears, select the datastore onto which the Cisco Meeting Server 
Virtual Machine Guest will be deployed, and then click Next. 
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Step 10.   On the Disk Format page, ensure that the default disk format of Thick Provision Lazy 
Zeroed is selected and then click Next. 

 

 
 

i Tech Tip 

Because VM performance may degrade during the resizing of a partition, Thin Provision is not 
recommended. 

 

Step 11.   If Network Mapping is listed, configure it and select the network mapping that applies to 
your infrastructure (the default is VM Network), and then click Next. 

Step 12.   On the Ready to Complete page, confirm your deployment Setting, do not select Power on 
after deployment, and click Finish. 
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Step 13.   Right-click the cms1 virtual machine and click Edit Settings. 

Step 14.   Set the CPU to 8, Memory to 8 GB and click OK. 
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Cisco Meeting Server OVA for Conferencing is now deployed as a guest on the VM Host.  

 

Procedure 3   Deploy OVA to  Host fo r Record ing and Streaming 

 

Step 1.   Follow steps 1 - 5 from Procedure 2 above. 

Step 2.   On the Name and Location page, enter cms2 and the Inventory Location where the virtual 
machine will reside. 

Step 3.   Follow steps 7 -12 from Procedure 2 above. 

Step 4.   Right-click the cms1 virtual machine and select Edit Settings. 

Step 5.   Set the CPU to 4, Memory to 4 GB and click ok. 
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Cisco Meeting Server OVA for Recording and Streaming is now deployed as a guest on the VM Host. 

  

Procedure 4   Configure  the  VM Guest fo r Confe rencing 

 

Step 1.   Right-click the VM guest and click Power -> Power On. 

Step 2.   Right-click the VM guest and click Open Console. The VM guest will take some time to 
boot. This is the Mainboard Management Processor (MMP) interface. 

Step 3.   When the Acano login prompt appears, log in with the following:  

• Username: admin 

• Password: admin.  

Step 1.   When the default password expires, create a new password and,  
The Cisco Meeting Server is now ready for initial configuration. 

Step 4.   At the acano: prompt, Enter the following to configure a static IP address. 

ipv4 a add 10.106.170.214/25 10.106.170.129 
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Cisco Meeting Server for Conferencing is now accessible using the configured IP address. 

 

Procedure 5   Configure  the  VM Guest fo r Record ing 

 

Step 1.   Follow steps 1 - 3 from Procedure 4 above. 

Step 2.   At the acano: prompt, Enter the following to configure a static IP address. 

ipv4 a add 10.106.170.215/25 10.106.170.129 

Cisco Meeting Server for Recording can now be accessed using the configured IP address. 
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Procedure 6   Apply Licenses on the  Cisco  Meeting Server 

 

For the scenarios covered in this CVD, the following types of licenses can be installed on the Cisco 
Meeting Server: 

• Virtual Machine Activation key for both the servers 

• CallBridge key 

• Recording and Streaming key 

• Personal Multiparty Plus License 

i Tech Tip 

For additional licensing details, refer to the Cisco Preferred Architecture for Midmarket Collaboration, 
Design Overview. 

 

The licenses are included in a single .lic file that must be uploaded to the CMS server.  

Two cms.lic files are required. One is for Conferencing server and the other for the Recording and 
streaming server. 

The server for Conferencing will have the activation key and CallBridge key. 

The server for Recording and streaming will have activation key and Recording and Streaming key. 

Configuration of the Personal Multiparty Plus Licenses is covered in the Configuring Cisco Meeting Server 
section of this document. 

Step 1.   If the name of the license file is not cms.lic, you must rename it to cms.lic. 

Step 2.   Transfer the license file to the default folder of Cisco Meeting Server using SFTP. 

Step 3.   After the file is uploaded, restart the servers.  

The required licenses are applied.   

http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
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Installing TelePresence Management Suite  
Easy Access Configuration Sheet  

Cisco TMS Installation Requirements 
Element CVD Configuration Site-Specific Configuration 
TMS Name  TMS on Win Std 2012  
TMS IP Address 10.106.170.203  
TMS Subnet Mask 255.255.255.128  
TMS Default Gateway 10.106.170.129  
Release Key   
IP/ISDN zone name HQ  
IP/ISDN zone country/region India  
 

Cisco TMS Configuration Requirements 
Element CVD Configuration Site-Specific Configuration 
DN range for scheduled 
conferences 

8211000-8211010  

 

PR
O

C
ES

S
  1. Install Windows Server 

2. Install TMS on the  Windows Server 

 

This CVD installs the TMS applications on Windows Server 2012 Standard 64-bit Edition with Microsoft 
SQL Server 2012 64-bit installed. TMS stores all its customer data in its SQL database. 

 

i Tech Tip 

The SQL Server can also be installed off-box for resiliency. 

 

Procedure 1   Install Windows Server 

 

Step 1.   Log in to vSphere to access the ESXi Host. 

Step 2.   Select File > New > Virtual Machine. 
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Step 3.   On the Configuration page select Custom, and click Next. 

  

Step 4.   On the Name and Location page, enter Name as TMS on Win Std 2012, select Inventory 
Location and click Next. 

  

Step 5.   On the Storage page select the datastore and click Next. 
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Step 6.   On the Virtual Machine Version page, select Virtual Machine Version: 8 and click Next. 

  
  

Step 7.   On the Guest Operating System page, select Windows under Guest Operating System, 
select Microsoft Windows Server 2012 (64-bit) and click Next. 

  

Step 8.   On the CPUs page, select the following and click Next:  

• Number of Virtual sockets:  1 

• Number of cores per virtual: 1 
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Step 9.   On the Memory page, select Memory Size as 8 GB and click Next. 

  

Step 10.   On the Network page, select the How many NICs do you want to connect as 1 and click 
Next. 

Step 11.   On the SCSI Controller page, select the appropriate settings and click Next. 

Step 12.   On the Select a disk page, select Create a new virtual disk, click Next. 
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Step 13.   On the Create a Disk page, select Disk Size as 60 GB, Disk Provisioning as Thick Provision 
Lazy Zeroed and click Next. 

  
  

i Tech Tip 

Because VM performance may degrade during the resizing of a partition, Thin provision is not 
recommended. 

 

Step 14.   On the Advanced Options page, select appropriate options and click Next. 

Step 15.   On the Ready to Complete page, confirm your deployment settings and click Finish. 

Step 16.   Once the VM is created, right-click the newly created VM, select Power and click Power 
On.  

Step 17.   Install Windows Server 2012 Standard on this newly created VM. 

Step 18.   To configure the IP information, enter the following in the relevant fields. (Configure other 
entries as required): 

o IP address: 10.106.170.203 

o Subnet mask: 255.255.255.128 

o Default gateway: 10.106.170.129 

o DNS server: 10.106.170.130 

Step 19.   Complete all critical Windows updates, close all open applications and disable virus-
scanning and other software that may prevent an installation from completing. 
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i Tech Tip 

Depending on windows components needing to be added, you may me prompted to reboot the server 
more than once during the installation. The installer automatically resumes after the server boots. 

The Windows server is now installed. 

Step 20.   Install SQL Server 2012 on the Windows Server. 

  

Procedure 2   Install TMS on the  Windows Server 

 

For the scenarios covered in this CVD, following are the type of licenses installed on the TMS: 

• Cisco TelePresence Management Suite Base License 

• Cisco TMS – additional 100 systems 

  

i Tech Tip 

For additional licensing details, refer the Cisco Preferred Architecture for Midmarket Collaboration, 
Design Overview. 

 

Step 1.   Download the Cisco TMS.zip file from Cisco.com. 

Step 2.   Extract the .zip file. 

Step 3.   Run the Cisco TMS executable as administrator. 

The installer checks the hardware and software configuration of the server. A warning or 
error message may be displayed, depending on your server’s configuration. Follow the 
prompts and install any missing Windows server components. 

Step 4.   Click Yes to continue. 

  

http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
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Step 5.   On the welcome screen, click Next. 
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Step 6.   On the License Agreement page, click Yes. 

  
  

Step 7.   On the Database Settings page, select Use local SQL Server, enter the username, 
password to allow the installer to create a new database, and click Next. 
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i Tech Tip 

The SQL Server can also be installed off-box for resiliency. 

 

Step 8.   On the Release and Option Keys page, enter the release key and click Next. 
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Step 9.   On the Network and Settings page, enter the following: 

• TMS Server IPv4 Address: 10.106.170.203 

• IP Broadcast/Multicast Addresses for System Discovery: 10.106.170.255 

 
  

Step 10.   Click Next. 

Step 11.   On the IP/ISDN Zone page, enter the following: 

• Name: HQ 

• Country/Region: India 

Step 12.   Click Next. 

Step 13.   On the Folder Settings page, specify the TMS installation path and click Next. 

  



453BDeployment Details 

 

 

 
 PAGE 31  

Technology Use Case Design Overview  Deployment Details  Product List Contents  

Step 14.   On the Encryption Key page, click Generate to generate the new encryption key and click 
Copy. 

  

Step 15.   Click Next. 

Step 16.   On the Start Copying Files page, verify all the settings. 

Step 17.   Click Next. 

Step 18.   On the HTTPS for the TMS Website page, click Create to generate a self-signed 
certificate and click OK. 
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Step 19.   Click Finish. 

  
 

  The setup wizard is complete and TMS is now installed. 
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Configuring Cisco Meeting Server 
Easy Access Configuration Sheet  

Cisco Meeting Server Configuration Requirements 
Element CVD Configuration Site-Specific Configuration 
API username / password api / Password  
WebAdmin Listening Port 445  
Recorder Listening Port 8443  
NFS Server IP 10.106.170.84  
XMPP Listening Port 8443  
LDAP Server 10.106.170.130  
LDAP Server Listening Port 389  
 

 

PR
O

C
ES

S
 

 1. Creating a new user fo r configuring though APIs 

2. Enab ling WebAdmin, CallB ridge, Recorder, XMPP and WebBridge modules 

3. Setting up CMS to  be  an ad-hoc resource  in CUCM 

4. Setting up CMS fo r Personal Spaces 

5. Setting up Personal Multiparty Plus Licenses 

6. Setting up CMS fo r WebRTC 

7. Setting up CMS fo r Record ing 
 

 

Procedure 1  Creating a new user fo r configuring though APIs 

 

A new user account has to be created for configuration throughout the API. This has to be done using the 
Mainboard Management Processor (MMP) interface in CMS which can be reached by doing SSH into the 
CMS server. 

Step 1.   SSH into the CMS server using the admin credentials. 

Step 2.   Enter the following command to create an API user named api: 

user add api api 

Step 3.   Enter password as api twice when prompted to enter the password. 

Step 4.   Enter the command user list to confirm the creation of the user. 
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A new user has been created. This CVD uses the Postman tool which is available as an extension for the 
Google Chrome browser. 

The APIs Actions used to configure CMS are: 

• GET – Retrieves existing information  

• POST – Creates new instance 

• PUT – Modifies existing instance 

• DELETE – Deletes existing instance 

API commands are entered as an URL in the following format: 

 

Following steps would verify the newly created API user works on CMS. 

Step 5.   Open Google Chrome, and go to: https://chrome.google.com/webstore/category/apps. 

Step 6.   In the search bar, search for Postman. 

https://chrome.google.com/webstore/category/apps
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Step 7.   Install the Postman app and restart Chrome. 

Step 8.   Enter chrome://apps/ and Enter. 

Step 9.   Click the Postman app installed above to open the application. 

Step 10.   Enter the following values to check if GET messages are working for CMS: 

• Select GET from the dropdown list 

• Enter https://10.106.170.214:443/api/v1/system/status in the parameter section,  

• Select Authorization tab, select Type as Basic Auth and enter the username api and the 
password 
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Step 11.   Click Send. 

Step 12.   If you get the following error, then log in via the Chrome browser to the CMS Webadmin 
interface and accept the certificates. 

 

Step 13.   After you can successfully log in to CMS server, sending the above GET message should 
give a similar output. 
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The created API user works fine. 

 

Procedure 2  Enab ling WebAdmin, CallB ridge, Recorder, XMPP and WebBridge modules 

 

WebAdmin is the module that enables https access to the CMS server for GUI configurations. WebAdmin 
is accessible only through https. Security certificates have to be created and installed on the CMS server 
for logging in.  

Step 1.   Log in to the MMP of CMS for conferencing using the admin account and enter the 
following command to create webadmin1.key and webadmin.csr files: 

pki csr webadmin1 

Step 2.   Download the CSR file using a SFTP from the CMS server. 

Step 3.   Get the CSR file signed by a Certificate Authority(CA), get a signed certificate and upload 
the signed certificate file to the CMS server using SFTP. 

Step 4.   Enter the following commands to enable the WebAdmin module on CMS: 

webadmin certs webadmin1.key webadmin1.crt 

webadmin listen a 445 

webadmin restart 

webadmin enable 
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Now CMS can be accessed using https://10.106.170.214:445/. 

CallBridge is the module that enables audio and video conferencing in CMS. Following steps enable the 
CallBridge module on CMS. 

Step 5.   Log in to the MMP of CMS for conferencing using the admin account and enter the 
following command to create callbridge.key and callbridge.csr files: 

pki csr callbridge 

Step 6.   Download the CSR file using a SFTP from the CMS server. 

Step 7.   Get the CSR file signed by a Certificate Authority (CA), get a signed certificate and upload 
the signed certificate file to the CMS server using SFTP. 

Step 8.   Enter the following commands to enable the CallBridge module on CMS: 

callbridge certs callbridge.key callbridge.crt 

callbridge listen a 

callbridge restart 

 

CallBridge is now enabled. 

Recorder is the module that enables the recording of conference spaces on the CMS server. Following 
steps enable recorder. 

Step 9.   Log in to the MMP of CMS for recording using the admin account and enter the following 
command to create cms2recorder.key and cms2recorder.csr files: 

pki csr cms2recorder 

Step 10.   Download the CSR file using a SFTP from the CMS server. 

https://10.106.170.214:445/
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Step 11.   Get the CSR file signed by a Certificate Authority(CA), get a signed certificate and upload 
the signed certificate file to the CMS server using SFTP. 

Step 12.   Upload the callbridge signed certificate file to the CMS server using SFTP. 

Step 13.   Enter the following commands to enable the recorder module on CMS: 

recorder certs cms2recorder.key cms2recorder.crt 

recorder trust callbridge.crt 

recorder listen a:8443 

recorder nfs 10.106.170.84:/ 

recorder enable 

 

Step 14.   Issue the following API command on CMS for conferencing: 

• Method – POST 

• URL - https://10.106.170.214:445/api /v1/recorders 

 

Step 15.   Check the created recorders instance on CMS for conferencing by issuing the following 
command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/recorders 

 

https://10.106.170.214:445/api/v1/recorders
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Step 16.   Add the recording URL on the CMS for conferencing by issuing the following API command: 

• Method: PUT 

• URL: https://10.106.170.214:445/api/v1/recorders/f3dbe066-fa97-4f8c-8771-
a3612895cf06 

• Key: url, Value: https://10.106.170.215:8443 

 

Step 17.   Verify the configuration by using the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/recorders/f3dbe066-fa97-4f8c-8771-
a3612895cf06 

 

Step 18.   Create a new callProfile to enable recording using the following command: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/callProfiles/ 

 

https://10.106.170.214:445/api/v1/recorders/f3dbe066-fa97-4f8c-8771-a3612895cf06
https://10.106.170.214:445/api/v1/recorders/f3dbe066-fa97-4f8c-8771-a3612895cf06
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Step 19.   Verify the configuration using the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/callProfiles/ 

 

Step 20.   Enable recording in the above created callProfile using the following command: 

• Method: PUT 

• URL: https://10.106.170.214:445/api/v1/callProfiles/602eb7e1-4152-4737-8aec-
81a4008d7985 

• Key: recordingMode, value: manual 

 

Step 21.   Create a callLegProfile to enable recording control for every user by using the following 
commands: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/callLegProfiles/ 

 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/callLegProfiles/ 

https://10.106.170.214:445/api/v1/callLegProfiles/
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• Method: PUT 

• URL: https://10.106.170.214:445/api/v1/callLegProfiles/6735d228-7cde-4298-ad6a-
452068b8337e 

• Key: recordingControlAllowed, Value: true 

 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/callLegProfiles/6735d228-7cde-4298-ad6a-
452068b8337e 

 

Step 22.   Create the dtmfProfile to map the DTMF tones to start and stop the recording by using the 
following commands: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/dt mfProfiles 

 



453BDeployment Details 

 

 

 
 PAGE 43  

Technology Use Case Design Overview  Deployment Details  Product List Contents  

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/dt mfProfiles 

 

• Method: PUT 

• URL: https://10.106.170.214:445/api/v1/dt mfProfiles/0e613fff-3f31-4996-aff5-
aef12449da08 

• Key: startRecording, Value: *7 

• Key: stopRecording, Value: *8 

 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/dt mfProfiles/0e613fff-3f31-4996-aff5-
aef12449da08 

https://10.106.170.214:445/api/v1/dtmfProfiles
https://10.106.170.214:445/api/v1/dtmfProfiles/0e613fff-3f31-4996-aff5-aef12449da08
https://10.106.170.214:445/api/v1/dtmfProfiles/0e613fff-3f31-4996-aff5-aef12449da08
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Step 23.   Apply the above created callProfile, callLegProfile and dtmfProfile to the system default 
profile by following the commands: 

• Method: PUT 

• URL: https://10.106.170.214:445/api/v1/system/profiles 

• Key: callLegProfile, Value - 6735d228-7cde-4298-ad6a-452068b8337e 

• Key: callProfile, Value - 602eb7e1-4152-4737-8aec-81a4008d7985 

• Key: dtmfProfile, Value - 0e613fff-3f31-4996-aff5-aef12449da08 

 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/system/profiles 

https://10.106.170.214:445/api/v1/system/profiles
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The Recorder is configured but would need the XMPP module to be enabled too. 

XMPP server is needed for recording and for participants joining spaces through CMA or webRTC based 
browsers. Following steps enables XMPP server on CMS for conferencing. 

Step 24.   Create DNS A record for cms1.mmcvd.ciscolabs.com as this server will be used to host the 
XMPP Server and set it to the IP address 10.106.170.214 which is the interface that the 
XMPP server is listening on. 

Step 25.   Create DNS SRV record for _xmpp-server for tcp port 5269 resolving to the DNS A record 
cms1.mmcvd.ciscolabs.com. 

Step 26.   Create DNS SRV record for _xmpp-client for tcp port 5222 resolving to the DNS A record 
cms1.mmcvd.ciscolabs.com. 

Step 27.   SSH into the CMS for conferencing and enter the following commands to enable the XMPP 
module: 

xmpp listen a:8443 

xmpp certs callbridge.key callbridge.crt 

xmpp domain mmcvd.ciscolabs.com 

xmpp enable 

 

 

XMPP server is enabled.  
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WebBridge is being used by the WebRTC app. The users or guests who want to join a conference can use 
a WebRTC-supported web browser to join the conference. The following steps enable WebRTC on the 
CMS for conferencing.  

Step 28.   SSH into the CMS for conferencing, create a key and csr file using the following command: 

 pki csr webbridge1 

Step 29.   Get the csr signed by a CA server, then upload the crt file back on the server: 

Step 30.   SSH in to the CMS for conferencing server, and enter the following commands: 

webbridge listen a:443 

webbridge certs webbridge1.key webbridge1.crt 

webbridge trust callbridge.crt 

webbridge enable 

 

Step 31.   Create a DNS A record for the WebBridge and set it to resolve to the IP address: 
10.106.170.214.   

The WebBridge is now enabled. 

 

Procedure 3  Setting up CMS to  be  an ad-hoc resource  in CUCM 

 

Step 1.   Log in to the GUI of CMS for conferencing, navigate to Configuration > Incoming Calls, 
under Call Matching section enter the following and hit Add New: 

• Domain name: 10.106.170.214 

• Priority: 1 

• Targets Spaces: Yes 

• Targets users: Yes 

• Targets IVRs: Yes 

• Targets Lync: No 
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• Targets Lync Siplejoin: No 

 

Step 2.    Log in to the GUI of CMS for conferencing, navigate to Configuration > Incoming Calls, 
under Call Matching section enter the following and hit Add New: 

• Domain name: mmcvd.ciscolabs.com 

• Priority: 1 

• Targets Spaces: Yes 

• Targets users: Yes 

• Targets IVRs: Yes 

• Targets Lync : No 

• Targets Lync Siplejoin: No 

 
 

 

Procedure 4  Setting up CMS fo r Personal Spaces 

 

For Personal Spaces for users in the Active Directory will be automatically created when we import the 
users in Cisco Meeting Server. This section configures the LDAP related settings and imports users from 
the AD. 

In this CVD a separate Organizational Unit called cmaUsers have been created with users who can log in to 
the CMA application or via webRTC supported browsers. 

Step 1.    Create a ldapServer by issuing the following API command on CMS for conferencing 
through Postman: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/ldapServ ers 

• Key: address, Value – 10.106.170.130 

• Key: PortNumber, Value: 389 

• Key: username, Value: cn=Administrator,cn=Users,dc=mmcv d,dc=ciscolabs,dc=com 

• Key: password, Value: Password 

• Key: secure, Value: false  

https://10.106.170.214:445/api/v1/ldapServers
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Step 2.   Check the created instance of ldapServer by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/ldapServers 

 

Step 3.   Create a ldapMappings by issuing the following API command on CMS for conferencing 
through Postman: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/ldapMappings 

• Key: jidMapping, Value: $mail$@mmcvd.ciscolabs.com 

• Key: nameMapping, Value: $cn$ 

• Key: coSpaceNameMapping, Value: $cn$’s Space 

• Key: coSpaceUriMapping, Value: $mail$.space 

• Key: coSpaceSecondaryUriMapping, Value: $telephoneNumber$ 

• Key: coSpaceCallIdMapping, Value: $telephoneNumber$ 

https://10.106.170.214:445/api/v1/ldapServers
https://10.106.170.214:445/api/v1/ldapMappings
mailto:$mail$@mmcvd.ciscolabs.com
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Step 4.   Check the created instance of ldapMapping by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/ldapMappings 

 

• Method: GET 

• URL:  https://10.106.170.214:445/api/v1/ldapMappings/4d91054d-11d7-493e-
bcd0-a9fb2fdf0e30 

 

Step 5.   Create a ldapSource by issuing the following API command on CMS for conferencing 
through Postman: 

• Method: POST 

https://10.106.170.214:445/api/v1/ldapMappings
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• URL: https://10.106.170.214:445/api/v1/ldapSources 

• Key: server, Value: dc639ccb-c9bd-4183-848a-7fc893e0d8e4 

• Key: mapping, Value: 4d91054d-11d7-493e-bcd0-a9fb2fdf0e30 

• Key: baseDn, Value: ou=cmaUsers,dc=mmcvd,dc=ciscolabs,dc=com 

• Key: filter, Value: (&(objectClass=user)(sAMAccountName=*)) 

 
Step 6.   Check the created instance of ldapSource by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/ldapSources 

 

Step 7.   Start a ldapSync with the above created ldapSource by issuing the following API command 
on CMS for conferencing through Postman: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/ldapSyncs 

• Key: removeWhenFinished, Value: false 

• Key: ldapSource, Value: 0271689d-6148-4c3a-9b6a-142c9286cc30 

 

Step 8.   Check the status of ldapSync by issuing the following command: 

• Method: GET 

https://10.106.170.214:445/api/v1/ldapSources
https://10.106.170.214:445/api/v1/ldapSyncs
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• URL: https://10.106.170.214:445/api/v1/ldapSyncs 

 

Step 9.   Check the users imported by log in to the GUI of CMS for conferencing and navigating to 
Status > Users. 

 

Step 10.   Check the Spaces created by navigating to Configuration > Spaces. 

 

Personal Spaces are created. 

 

Procedure 5  Setting up Personal Multiparty Plus Licenses 

 

To enable a set of users to be PMP+ users, a user profile has to be configured with hasLicense parameter 
as true. This represents the users with this userProfile will use Personal Multiparty Plus License.  

Before that CMS has to be configured with ldapServer, ldapMapping and ldapSource configuration, which 
is similar to the configuration in Configuration > Active Directory on CMS for conferencing. 

Step 11.   Create a userProfile by issuing the following API command on CMS for conferencing 
through Postman: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/userProfiles 

https://10.106.170.214:445/api/v1/ldapSyncs
https://10.106.170.214:445/api/v1/userProfiles
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Step 12.   Check the created instance of userProfile by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/userProfiles 

 

Step 13.   Enable the personal multiparty parameter by issuing the following command: 

• Method: PUT 

• URL:  https://10.106.170.214:445/api/v1/userProfiles/ed9af2dd-6f34-49ff-ba87-
b5ce8e5baf20 

• Key: hasLicense, Value: true 

 

Step 14.   Update the existing ldapSource, created in the previous procedure, by issuing the following 
API command on CMS for conferencing through Postman: 

• Method: PUT 

• URL: https://10.106.170.214:445/api/v1/ldapSources/0271689d-6148-4c3a-9b6a-
142c9286cc30 

• Key: userProfile, Value: ed9af2dd-6f34-49ff-ba87-b5ce8e5baf20  

 

Step 15.   Check the created instance of ldapSource by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/ldapSources 

https://10.106.170.214:445/api/v1/userProfiles
https://10.106.170.214:445/api/v1/userProfiles/ed9af2dd-6f34-49ff-ba87-b5ce8e5baf20
https://10.106.170.214:445/api/v1/userProfiles/ed9af2dd-6f34-49ff-ba87-b5ce8e5baf20
https://10.106.170.214:445/api/v1/ldapSources
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Step 16.   Start a ldapSync with the above created ldapSource by issuing the following API command 
on CMS for conferencing through Postman: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/ldapSyncs 

• Key: ldapSource, Value: 0271689d-6148-4c3a-9b6a-142c9286cc30 

 

Step 17.   Verify the ldapSync by issuing the following API command on CMS for conferencing 
through Postman: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/ldapSyncs 
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Step 18.   Check the users if the userProfile has been associated or not by issuing the following 
commands: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/users/ 

 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/users/d30c90a0-ff06-490c-8125-
97d315db728c 

 

Personal Multiparty Plus Licenses are applied to the imported users on CMS for conferencing. 

 

Procedure 6  Setting up CMS fo r WebRTC 

 

WebRTC capability enables the users to join into spaces without any Video endpoint. A user can log in to 
CMA though a webRTC supported browser. 

XMPP and WebBridge modules must be enabled for the WebRTC to be working. It has been enabled in 
the Enabling WebAdmin, CallBridge, Recorder, XMPP and WebBridge modules. 

Following are the further steps to do the rest of the configurations. 

Step 1.   Go to Configuration > General and configure the following in the WebBridge settings: 
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• Guest account client URI: https://10.106.170.214 

• Guest account JID domain: mmcvd.ciscolabs.com 

• Guest access via ID and passcode: secure: require passcode to be supplied with ID 

• Guest access via hyperlinks: allowed 

• User sign in: allowed 

 

• WebRTC capability is enabled on CMS for conferencing, users can browse the URL 
https://10.106.170.214 and use this feature. 

https://10.106.170.214/
https://10.106.170.214/
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Procedure 7  Setting up CMS fo r Record ing 

 

Recording module must be enabled and has been enabled in the Enabling WebAdmin, CallBridge, 
Recorder, XMPP and WebBridge modules.  

Step 1.   Create a recorder instance on the CMS for conferencing and give the IP address of the 
CMS for recording server by issuing the following API command: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/recorders 

• Key: url, Value: https://10.106.170.215:8443 
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Step 2.   Verify the created instance of recorder by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/recorders 

 

Step 3.   Create a callProfile instance on the CMS for conferencing and set the recording mode as 
manual which means user has to enter a set of DTMF keys to start or stop recording, by 
issuing the following command: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/callProfiles 

• Key: recordingMode, Value: manual 

 

Step 4.   Verify the created instance of callProfile by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/callProfiles 

 



453BDeployment Details 

 

 

 
 PAGE 58  

Technology Use Case Design Overview  Deployment Details  Product List Contents  

Step 5.   Create a callLegProfile instance on the CMS for conferencing and set which users have 
the permission to start and stop recording by issuing the following command: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/callLegProfiles 

• Key: recordingControlAllowed, Value: true 

 

Step 6.   Verify the created instance of callLegProfile by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/callLegProfiles 

 

Step 7.   Create a dtmfProfile instance on the CMS for conferencing to setup the keys used to start 
and stop the recording by issuing the following command: 

• Method: POST 

• URL: https://10.106.170.214:445/api/v1/dtmfProfiles 

• Key: startRecording, Value: *7 

• Key: stopRecording, Value: *8 

 

Step 8.   Verify the created instance of dtmfProfile by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/dt mfProfiles 
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Step 9.   Apply the above created callLegProfile, callProfile and dtmfProfile to the system profile by 
issuing the following command: 

• Method: PUT 

• URL: https://10.106.170.214:445/api/v1/system/Profiles 

• Key: callLegProfile, Value: 6735d228-7cde-4298-ad6a-452068b8337e 

• Key: callProfile, Value: 602eb7e1-4152-4737-8aec-81a4008d7985 

• Key: dtmfProfile, Value: 0e613fff-3f31-4996-aff5-aef12449da08 

 

Step 10.   Verify the system Profile by issuing the following command: 

• Method: GET 

• URL: https://10.106.170.214:445/api/v1/system/Profiles 
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Configuring Cisco TelePresence Management Suite 
Easy Access Configuration Sheet  

Cisco TMS Configuration Requirements 
Element CVD Configuration Site-Specific Configuration 
WebAdmin IP:Port 10.106.170.214:445  
WebAdmin 
Username/password 

api / Password  

Domain Mmcvd.ciscolabs.com  
Numeric Base ID for 
Scheduled conferences 

8211001  

WebBridge URI https://10.106.170.214/  
 

PR
O

C
ES

S
  1.  Add Cisco  Meeting Server on TMS 

2. Configuring CMS in TMS fo r Scheduled Confe rences  

3. Configure  Confe rence  Se ttings on TMS 
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Procedure 1   Add Cisco  Meeting Server on TMS 

 

Step 1.   Log in to the TMS and navigate to Systems > Navigator. 

 

Step 2.   Click Add Systems. 

Step 3.   Under the Add by Address tab, enter the following: 

• IP Address: 10.106.170.214:445 

• Username: api 

• Password: Password 

 

Step 4.   Click Next and then click Finish Adding Systems. 
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Procedure 2   Configuring CMS in TMS fo r Scheduled Confe rences 

 
Step 1.   Click the newly added CMS system from the Navigator section, and then select the 

Settings tab. 

Step 2.   Configure the following and click Save: 

• Name: cms1 

• Allow Incomming H.323 Dialing: Unchecked 

• Allow Outgoing H.323 Dialing: Unchecked 
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Step 3.   Click the Extended Settings sub-tab, enter the following and click Save: 

• Domain: mmcvd.ciscolabs.com 

• Numeric ID Base: 8211001 

• Numeric ID Quantity: 10 
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Now 10 Spaces with the above shown ID will be created on CMS for the conferencing server. These 
spaces will be used as scheduled spaces when a user schedules a conference. These spaces will be 
enabled only during the time of a scheduled conference and are disabled other times.  

Step 4.   Verify the creation of spaces by logging in to the GUI of CMS for conferencing and 
navigating to Configuration > Spaces. 

 

SIP Trunks must be configured for scheduled calls to work. (Covered in the Configuring CUCM section). 

The following steps, enable users to join a conference instantly with a single click. This requires the 
WebBridge module to be enabled (already configured in the previous sections).  

Step 5.   Log in to TMS and navigate to Systems > Navigator. 

Step 6.   Select cms1, click the Settings tab and select Edit Settings.  

Step 7.   Configure the following and click Save: 

• Web Bridge URI: https://10.106.170.214/ 

https://10.106.170.214/
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Procedure 3   Configure  Confe rence  Se ttings on TMS 

 

Step 8.   Navigate to Administrative Tools > Configuration > Conference Settings.  

Step 9.   Enter Preferred MCU Type in Routing as Cisco Meeting Server. And click Save. 

 

The conference settings are configured.   
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Configuring Cisco Unified Communications Manager 
Easy Access Configuration Sheet  

Cisco Unified CM Configuration Requirements 
Element CVD Configuration Site-Specific Configuration 
Video bandwidth for video 
region 

32256  

Route pattern for personal 
conferences 

821XXXX  

Route pattern for scheduled 
conferences 

851XXXX  

URI pattern for personal 
CMR conferences 

user.space@mmcvd.cisco labs.com  

 

PR
O

C
ES

S
 

 1. Configure  Region fo r Video  

2. Configure  Device  Pool fo r Video  and Add the  Video Region 

3. Configure  SIP Trunk to  Cisco  Meeting Server fo r Confe rences 

4. Configure  D irecto ry Number Route Patte rn fo r Personal and Scheduled Conferences  

5. Configure  Unified CM SIP Route  Pattern fo r Personal CMR Confe rences  

6. Configure  Cisco  Meeting Server as Conference B ridge fo r Ad-Hoc Confe rences 

7. Add this MRGL to  the  Device  Pro file  fo r Video  
 

 

Procedure 1   Configure  Region fo r Video  

Step 1.   Navigate to System > Region Information > Region, and click Add New in order to create 
a new Region. 

Step 2.   In Name, enter Video_Reg, and then click Save. 

  

Step 3.   Under Regions, select Default. 

Step 4.   Under Maximum Session Bit Rate for Video Calls, enter 32256 kbps and click Save. 
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This CVD is using 32256 as the configured video bandwidth for this region. 

The region is configured.  

Procedure 2   Configure  Device  Pool fo r Video  and Add the  Video Region 

 

Step 1.   Navigate to System > Device Pool, and then click Add New in order to add a new device 
pool. 

Step 2.   Enter the following into the relevant fields, leaving the other fields at their default values and 
click Save. 

• Device Pool Name:Video_DP 

• Cisco Unified Communications Manager Group: Sub1_Pub1 

• Date/Time Group: CMLocal 

• Region: Video_Reg 

  

The device pool is configured.   
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Procedure 3   Configure  SIP Trunk to  Cisco  Meeting Server fo r Confe rences 

 

A trunk is a communications channel on Unified CM that enables it to connect to other servers. Using one 
or more trunks, Unified CM can receive or place voice, video, and encrypted calls, exchange real-time 
event information, and communicate in other ways with call control servers and other external servers. 

Step 1.   Navigate to Device > Trunk, and then click Add New in order to create a new SIP trunk. 

Step 2.   Enter the following into the relevant fields: 

• Trunk Type: SIP Trunk 

• Device Protocol: SIP 

• Trunk Service Type: None(Default) 

  

Step 3.   Click Next. 

Step 4.   Enter the following into the relevant fields, leaving other fields at their default values: 

• Device Name: TR-2-CMS1 

• Device Pool: Video_DP 

• Destination Address: 10.106.170.214 

• Destination Port: 5060 

• SIP Trunk Security Profile: Non Secure SIP Trunk Profile 

• SIP Profile: Standard SIP Profile for TelePresence Conferencing 

• Normalization Script: cisco-telepresence-conductor-interop 
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Step 5.   Click Save, and then click Reset.  

Step 6.   Now click Reset again in the pop-up window that appears and click Close.  

The Unified CM trunk is now configured to the Cisco Meeting Server for conferences. 

  

 

Procedure 4   
Configure  D irecto ry Number Route Patte rn fo r Personal and Scheduled 
Confe rences 

 

In this CVD, 851XXXX is the range of Directory Numbers for Personal Conferences and 821XXXX is the 
range of Directory Numbers for Scheduled Conferences.  

Step 1.   Navigate to Call Routing > Route/Hunt > Route Pattern, and then click Add New to create 
a new route pattern. 

Step 2.   To route calls to the personal conferences, enter the following in the relevant fields, leave 
other fields at their default values and click Save. 

• Route Pattern: 851XXXX 

• Gateway/Route List: TR-2-CMS1 
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Step 3.   Navigate to Call Routing > Route/Hunt > Route Pattern, and then click Add New to create 
a new route pattern. 

Step 4.   To route calls to scheduled conferences, enter the following in the relevant fields, leave 
other fields at their default values and click Save. 

• Route Pattern: 821XXXX 

• Gateway/Route List: TR-2-CMS1 

 

The route patterns are now configured.  

  



453BDeployment Details 

 

 

 
 PAGE 71  

Technology Use Case Design Overview  Deployment Details  Product List Contents  

 

Procedure 5   Configure  Unified CM SIP Route  Pattern fo r Personal CMR Confe rences 

 

The regular Unified CM SIP route pattern routing cannot be used for routing calls to the personal CMR 
conferences created in this document because Unified CM can only route URIs based on domains (e.g. 
mmcvd.ciscolabs.com) and not the URIs created for the personal conferences (e.g. 
space@mmcvd.ciscolabs.com). 

To route the calls to the personal CMR conference URIs, you must use the Intercluster Lookup Service 
(ILS) in the Unified CM and manually import the personal CMR conference URIs into Unified CM. 

The following steps configure the Unified CM to enable ILS and import the personal CMR conference 
URLs. 

 

Step 1.   Click the Navigation tab on the top right corner of the Unified CM Administration page, 
select Cisco Unified Serviceability from the dropdown list and click Go. 

  

Step 2.   Navigate to Tools > Service Activation. 

 

Step 3.   Select CUCM-Pub--CUCM Voice/Video from the drop-down list under the Server field, 
and click Go. 

Step 4.   Select the Cisco Bulk Provisioning Service under the Database and Admin Services pane, 
and click Save. 
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Step 5.   Go back to the Cisco Unified CM Administration page by clicking on the Navigation tab at 
the top-right corner of the Cisco Unified Serviceability page.  

Step 6.   Select the Cisco Unified CM Administration, and then click Go. 

  

ILS must be enabled and working for the following steps to work. ILS can work either in 
“Hub Cluster” or “Spoke Cluster” mode. In this CVD we follow a single cluster deployment, 
so we will configure this publisher in “Hub Cluster” mode. 

Step 7.   Navigate to Advanced Features > ILS Configuration, select Hub Cluster as the Role under 
the Intercluster Lookup Service Configuration tab, and then click Save. 

 

 
 

Step 8.   Navigate to Call Routing > Global Dial Plan Replication > Imported Global Dial Plan 
Catalogue, and click Add New. 

Step 9.   Enter the following into the relevant fields: 

• Name: CMS_Personal_Space_Catalog 

• Route String: space.mmcvd.ciscolabs.com 

 

i Tech Tip 

The Route String is just a name, it does not represent that the user will have to dial 
*cmr.mmcvd.ciscolabs.com. 

 

Step 10.   Click Save. 

 
 



453BDeployment Details 

 

 

 
 PAGE 73  

Technology Use Case Design Overview  Deployment Details  Product List Contents  

Step 11.   Create a cvd_space.csv file in the following format for all the personal CMR conference 
URIs that must be imported into the ILS of the Unified CM. 

 

Step 12.   Navigate to Bulk Administration > Upload/Download Files and click Add New. 

Step 13.   Enter the following into the relevant fields: 

• File: cvd_space.csv 

• Select The Target: Imported Directory URIs and Patterns 

• Select Transaction Type: Insert Imported Directory URIs and Patterns 

• Overwrite File if it exists: Selected 

 

  

Step 14.   Click Save. 

Step 15.   Navigate to Bulk Administration > Directory URIs and Patterns > Insert Imported Directory 
URI and Pattern Configuration. 

Step 16.   Enter the following into the relevant fields: 

• File Name: cvd_space.csv 

• Imported Global Dial Plan Catalog: CMS_Personal_Space_Catalog 

• Run Immediately: Selected 
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Step 17.   Click Submit. 

Step 18.   Navigate to Call Routing > SIP Route Pattern.  

Step 19.   Click Add New. 

Step 20.   Enter the following into the relevant fields, leave other fields at their default values, and click 
Save.  

• IPv4 Pattern: space.mmcvd.ciscolabs.com 

• SIP Trunk/Route List: TR-2-CMS1 

 

The SIP route pattern is now configured.  

 

Procedure 6   Configure  Cisco  Meeting Server as Conference B ridge fo r Ad-Hoc Confe rences 

 

This procedure describes configuring Cisco Meeting Server as a conference bridge in Unified CM for Ad-
Hoc conferences. 

Ad-Hoc conferences on Cisco Meeting Server require the Cisco Unified CM to communicate with the API 
of the Cisco Meeting Server. The API requires HTTPS communication, so certificates must be created and 
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uploaded to both the Cisco Meeting Server and Cisco Unified Communications Manager. For escalated ad 
hoc calls to work, each must trust the other's certificate, . 

Certificates on Cisco Meeting Server are already uploaded in the previous procedures. 

This process covers certificates on Unified CM. 

Step 1.   Log in to the CUCM OS Administration page and Navigate to Security > Certificate 
Management. 

Step 2.   Click the Generate CSR button and generate a Certificate Signing Request (CSR) for Cisco 
Unified Communications Manager. 

Step 3.   Get the CSR signed by a Certificate Authority and upload the signed certificate and private 
key to Unified CM. 

Step 4.   Select Upload Certificate / Certificate Chain. 

Step 5.   Click Browse to find your certificate. (This can be the root certificate or the call bridge’s 
certificate and certificate bundle) and click Upload. 

Step 6.   Navigate to Media Resources > Conference Bridge, and then click Add New in order to 
create a new conference bridge. 

Step 7.   Enter the following into the relevant fields, and leave other fields at their default values: 

• Conference Bridge Type: Cisco TelePresence Conductor 

• Conference Bridge Name: cms1 

• SIP Trunk: TR-2-CMS1 

• Allow Conference Bridge Control of the Call Security Icon: UnSelected 

• Override SIP Trunk Destination as HTTP Address: Selected 

• Hostname/IP Address: cms1.mmcvd.ciscolabs.com 

• Username: api 

• Password: password 

• Use HTTPS:  Selected 

• HTTP Port: 445 
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Step 8.   Click Save. 

Step 9.   Make sure that the Conference Bridge shows as registered to the Unified CM. 
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Step 10.   Navigate to Media Resources > Media Resource Group, and then click Add New.  

Step 11.   In Name, enter MRG-CMS1 

Step 12.   In Available Media Resources, select cms1 (CFB), click the down arrow to move it down to 
the Selected Media Resources and click Save. 

 

 

Step 13.   Navigate to Media Resources > Media Resource Group List, and then click Add New.  

Step 14.   In Name, enter MRGL-CMS1 
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Step 15.   In Available Media Resources Groups, select MRG-CMS1 and click the down arrow to 
move it down to the Selected Media Resources Groups and click Save. 

 

The Cisco Meeting Server is now configured as a media resource.  

Procedure 7   Add this MRGL to  the  Device  Pro file  fo r Video  

 

Step 1.   Navigate to System > Device Pool, and then click Find in order to list all configured Device 
Pools. 

Step 2.   Select Video_DP. 

Step 3.   In Media Resource Group List, select MRGL-1-cond-1 and click Save. 

 

The MRGL is added.  
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Configuring Endpoints 
 

PR
O

C
ES

S
  1. Configure  Unified CM fo r Endpoints 

2. Configure  SX20 

 

Procedure 1  Configure  Unified CM fo r Endpoints 

 

Step 1.   Navigate to Device > Phone, and then click Add New. 

Step 2.   In Phone Type, select Cisco TelePresence EX60. 

  

Step 3.   Click Next. 

Step 4.   Enter the following into the relevant field, and leave the other fields at their default values: 

• MAC Address: 00506005246F 

• Device Pool: Video_DP 

• Phone Button Template: Standard Cisco TelePresence EX60 

• Common Phone Profile: Standard Common Phone Profile 

• Device Security Profile: Cisco TelePresence EX60—Standard 

• SIP Profile: Standard SIP Profile for TelePresence Endpoint 

 

Step 5.   Click Save. 
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Step 6.   Click Line [1] - Add a new DN. 

  

Step 7.   In Directory Number, enter 8001001, and then click Save. 

  

Step 8.   Under Directory URIs, enter 8001001@mmcvd.ciscolabs.com as the URI and click Add 
Row. 

 

The endpoint is now added.  
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Procedure 2  Configure  SX20 

 

Step 1.   Navigate to Home > Settings > Administrator Settings > Advanced Configuration > 
Provisioning > External Manager > Address. 

Step 2.   In External Manager, enter 10.106.170.135, and then click Save. 

The endpoint is added.  

 

Initiating Conferences 
 

PR
O

C
ES

S
  1. Initiate  Ad-Hoc Confe rence  

2. Initiate  Personal Conference  

3. Create  Scheduled CMR Confe rence  

 

Procedure 1  Initiate  Ad-Hoc Confe rence  

 

Step 1.   Call 8001002 from 8001001. 

Step 2.   After the call is connected, press on the Add+ button. 

Step 3.   Call 8001003 from 8001001. 

Step 4.   Press the Merge button. 

The Ad-Hoc conference should now be started. 
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Procedure 2  Initiate  Personal Conference  

 

Step 1.   Call abhijitdey.space@mmcvd.ciscolabs.com from 8001001. 

Step 2.   Call abhijitdey.space@mmcvd.ciscolabs.com from 8001003. 

Step 3.   Call abhijitdey.space@mmcvd.ciscolabs.com from 8001003.  

The personal conference should now be connected.  

Step 4.   Call 8511001 from endpoints that cannot dial a SIP URI to join the same conference. 

Step 5.   A guest or other users can join the same Personal Conference from a WebRTC based 
browser by entering https://10.106.170.214/. 

 

Step 6.   Click Join call, then enter 8511001 and click Continue. 

https://10.106.170.214/
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Step 7.   Enter Guest1 and click Join call. 
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Guest1 can join the above conference. 
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Procedure 3  Create  Scheduled Conference  

 

Step 1.   Log in to TMS as a user by typing http://10.106.170.203/tms/ in the browser. 

Step 2.   Click Booking > New Conference. 

 

Step 3.   Configure the settings based on the requirement and click Add Participants to add systems 
to the conference. 

http://10.106.170.203/tms/


453BDeployment Details 

 

 

 
 PAGE 86  

Technology Use Case Design Overview  Deployment Details  Product List Contents  

 

Step 4.   After you add participants, click Save. 

 

The Meeting is created and users can dial 8211003@mmcvd.ciscolabs.com to join this conference. 

mailto:8211003@mmcvd.ciscolabs.com
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Recording Conferences 
 

PR
O

C
ES

S
  1.  Record Confe rences 

 

Procedure 1   Record Confe rences 

 

Step 1.   While in the conference, press *7 to start a recording. 

Step 2.   Press *8 to stop the recording.  
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Appendix A: Product List 
Component Product Description Part Number Software 

Call Control Cisco Unified CM Business Edition 6000 
with up to 1000 users 

BE6H-M4-K9= 
BE6H-M4-XU= 

11.5(1) 

Video 
Phones 

Unified IP Phones 8800 series CP-88xx-K9= 11.5 

Video 
Endpoints 

Cisco TelePresence DX70 CP-DX70-W-K9= CE 8.3.1 

Cisco TelePresence DX80 CP-DX80-K9= CE 8.3.1 

Cisco TelePresence SX10 CTS-SX10N-K9 CE 8.2 

Cisco TelePresence SX20 CTS-SX20N-PHD2.5X-K9 CE 8.2 

Video 
Conference 
Bridge 

Cisco Meeting Server 
R-VTS-K9 

2.2 

Video 
Conference 
Scheduling 

Cisco TelePresence Management Suite CTI-TMS-SW-K9 15.5 

Soft Client Cisco Jabber for Windows JAB9-DSK-K9 11.8 
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	Preface
	Documentation for Cisco Validated Designs
	The following types of documentation for Cisco Validated Designs (CVDs) provide the foundation for systems design based on common use cases or current engineering system priorities. They incorporate a broad set of technologies, features, and applications to address customer needs and ensure faster, more reliable, and fully predictable deployment:
	Cisco Preferred Architecture (PA) Design Overview guides help customers and sales teams select the appropriate architecture based on an organization's business requirements, understand the products that are used within the architecture, and obtain general design best practices. These guides support sales processes.
	Cisco Validated Design (CVD) guides provide detailed steps for deploying the Cisco Preferred Architectures. These guides support planning, design, and implementation of the Preferred Architectures.
	Cisco Collaboration Solution Reference Network Design (SRND) guides provide detailed design options for Cisco Collaboration. The SRND should be referenced when design requirements are outside the scope of Cisco Preferred Architectures. 
	Scope
	Organizations want to reap the budgetary and productivity gains that a remote workforce allows, without compromising the benefits of face-to-face interaction. They need a solution that is fast to deploy and easy to manage from a central location, without replicating costly components at their remote sites. 
	This document details Video Collaboration with Desktop and Multipurpose Room Systems. It covers the following areas of technology and products:
	 Video call agent
	 Desktop video endpoints
	 Multipurpose room systems
	 Video Conference Bridge
	 Video Conference Management Systems
	 Video Conference Scheduling Systems
	 Video Recording and Streaming
	 Session Initiation Protocol (SIP) signaling
	For more information, see the Design Overview section in this guide.
	Proficiency
	This guide is for people with technical proficiencies—or equivalent experience in CCNA Collaboration—1 to 3 years in designing, installing, and troubleshooting voice and unified communications applications, devices, and networks. 
	Comments and Questions
	If you would like to comment on a guide or ask questions, please email collab-mm-cvd@external.cisco.com.
	Disclaimer
	The IP address scheme used in this document is for representational purposes only.
	Whats new in this version
	 Cisco Meeting Server as the Conferencing Bridge
	 Cisco Meeting Server as the Recording Platform
	 Cisco TelePresence Server and Cisco Conductor has been removed
	 Cisco TelePresence Content Server has been removed
	Introduction
	Businesses around the world are struggling with escalating travel costs. Growing corporate expense accounts reflect the high price of travel, but travel also takes a toll on the health and well being of employees and their families. Often, the only way to solve a difficult problem is to fly an expert to the location to see the issue and discuss it with the people at the site. When an expert cannot see what is being described, the resolution of a complex problem often takes much longer.
	Workers at remote sites often feel isolated from their departments because they do not spend enough face time with their peers and they feel disconnected from the decision-making process. This isolation can lead to lower job performance and less job satisfaction from employees who do not work at the organization’s main location.
	Hiring process can be very lengthy and costly, especially when candidates are located in other cities or when multiple people are involved in the interview process. Organizations with video conferencing systems in their offices can reduce expenses and time by bringing candidates into the nearest facility and allowing interviews to be conducted both in person and over video. 
	Technology Use Case
	The face-to-face interaction during video collaboration meetings helps to boost information retention, promotes increased attention span, and reduces participant confusion. The nonverbal cues experienced in a visual meeting are sometimes more important than what is actually spoken.
	Use Case: Video Collaboration with Desktop and Multipurpose Room Systems
	Organizations want to reap the budgetary and productivity gains that a remote workforce allows—without compromising the benefits of face-to-face interaction. They want to allow the flexibility for an employee to work across remote sites while still maintaining the familiar in-person contact of their peers and managers. They also want to enrich the collaboration experience in their meeting rooms, boardrooms, auditoriums and other shared environments. A solution is needed that is fast to deploy and easy to manage from a central location without replicating costly components at their remote sites.
	This design guide enables the following capabilities:
	 Single cluster centralized design to simplify deployment and management while saving on infrastructure components.
	 URI and numeric dialing to allow video-enabled IP phones to call room systems.
	 Provisioning the videoconference bridge for the site.
	 Conference resource optimization, management and scheduling.
	 Instant, Personal and Scheduled Conferences on Cisco Meeting Server Spaces.
	 Recording and Streaming of Conferences. 
	 Captures video and presentations for live streaming and video-on-demand (VoD) viewing.
	Design Overview
	An end-to-end video-collaboration solution incorporates a full suite of endpoints, infrastructure components, and centralized management tools.
	Cisco Preferred Architecture
	Cisco Preferred Architectures provide recommended deployment models for specific market segments based on common use cases. They incorporate a subset of products from the Cisco Collaboration portfolio that is best suited for the targeted market segment and defined use cases. These deployment models are prescriptive, out-of-the-box, and built to scale with an organization as its business needs change.This prescriptive approach simplifies the integration of multiple system-level components and enables an organization to select the deployment model that best addresses its business needs.
	The Cisco Preferred Architecture (PA) delivers capabilities that enable organizations to realize immediate gains in productivity and add value to their current voice deployments.
	Figure 1.   High-Level Block Diagram
	/
	Network Considerations
	If you already have an IP network in place for voice, your natural next step is to deploy video over IP. Many organizations run video systems in a mixed environment as they move from older systems to newer ones, based on IP. As older systems migrate off of ISDN, significant quality improvements and cost savings will be seen.
	Unified communications running over IP offers lower costs, easier management, remote monitoring, and control from across the network. It also provides higher bandwidth for calls, enabling superior audio and video quality while providing tighter integration into the corporate IT mainstream.
	With an IP network, the ongoing costs of running video calls are minimal because you only have to pay for maintenance and technical support. When return on investment (ROI) for the initial deployment is met, any additional costs are essentially free. Because there is no incremental cost involved, employees and managers are more likely to use the technology. As usage goes up, payback times go down, further boosting the ROI.
	Solution Details
	The Video Conferencing CVD includes the following components:
	 Cisco Unified Communications Manager (Unified CM), for call control and SIP endpoint registrations
	 Desktop (Cisco 8800 series IP phones, Cisco Jabber and Cisco Desktop Collaboration Experience DX series) and multipurpose (Cisco TelePresence SX 10 and 20 Quick Set) systems for placing and receiving calls
	 Cisco Meeting Server for reservation-less, instant conference (formerly ad-hoc conference), personal conference (formerly rendezvous/static conference)
	 Cisco TelePresence Management Suite (TMS) for scheduled conference
	 Cisco Meeting Server for conference recording
	 Network Time Protocol (NTP) server for logging consistency
	Figure 2.   High-Level Network Diagram
	/
	Cisco Unified Communications Manager
	Unified CM serves as the software-based, call-processing component of Cisco Unified Communications. Additional data, voice, and video services, such as unified messaging, rich media conferencing, collaborative contact centers, and interactive multimedia response systems, interact through Cisco Unified Communications Manager open-telephony application program interface (API).
	Unified CM is the primary call agent in this CVD. Unified CM supports session initiation protocol (SIP), and the configurations in this document use SIP as the signaling protocol for endpoints.
	Cisco Video and TelePresence Endpoints
	Cisco video endpoints provide IP video telephony features and functions similar to IP voice telephony, enabling users to make point to point and multipoint video calls. Cisco video endpoints are classified into families based on the features they support, hardware screen size, and environments where the endpoints are deployed.
	There are two types of endpoints mentioned in this document:
	 Desktop & Mobile Video endpoints—Cisco Jabber software-based clients, such as Cisco Jabber for Windows/Mac/Android/IOS and the Cisco 8800 series IP phones are capable of transmitting video by means of the built-in front-facing camera. The Cisco TelePresence System DX70 and 80 endpoints take the personal desktop solution to the next level of experience with support for content sharing, mobile and remote access.
	 Multipurpose Endpoints—The Cisco TelePresence SX10 and SX20 Quick Sets are flexible integrators that can turn any display into a powerful Cisco TelePresence system. SX20 Quick Sets are designed for HD video and multiparty conferencing, with the flexibility to accommodate various room sizes.
	Cisco Meeting Server
	The Cisco Meeting Server is an innovative software solution enabling high-quality standards-based conferencing for mobile, webRTC based clients, desktop and immersive endpoints. It can have instant, personal and scheduled conferences hosted on Spaces. It also enables Recording and streaming of the conferences. It is available in both applicance based offering and can also be installed on a specs based vmware hardware. 
	Spaces are always-on virtual spaces that have a fixed video address. Users can call in to that address at any time to start a meeting. 
	Cisco TelePresence Management Suite
	Cisco TelePresence Management Suite (Cisco TMS) enables a variety of scheduling features and management functionality within Cisco Unified Communications for the Scheduled Conferences.
	Dial Plan
	These design uses, single-cluster, centralized call processing. The endpoints use a seven-digit phone number for dialing, which preserves the capability to receive calls from devices that only support only numeric dialing. The numbers are in the following pattern:
	For URI dialing the endpoints are assigned the URI in the following pattern:
	The domain used in this document is mmcvd.ciscolabs.com.
	As your solution grows, you may need to acquire a security certificate from a public certification authority. Choose a domain name in this step with a valid Internet domain suffix (.com, .edu etc) to ensure that your system is ready for this requirement.
	For instant conferences, Cisco Meeting Server is added as a media resource on the Unified CM.
	For personal Spaces, Cisco Meeting Server is SIP trunked to Unified CM. Personal Spaces can have both numbers and URIs. In this document, every user has a dedicated number and URI configured on the Cisco Meeting Server imported via Active Directory. The Space numbers and URIs used in the following pattern:
	For scheduled conferences, Cisco Meeting Server is SIP trunked to Unified CM. In this document, the same SIP trunk referenced above is used. Whenever a user schedules a conference; a number, from a configured range in TMS, is assigned to the scheduled conference for the users to dial in. The scheduled conference numbers are used in the following pattern:
	For recording, Cisco Meeting Server is SIP-trunked to Unifed CM. User can press a number to start and stop a recording. In this document, the same SIP trunk referenced above is used. For self-video recording the user has to be the only participant in the space and record the space. 
	Deployment Details
	This guide is divided into multiple sections: server installations and deploying Spaces. Each section has procedures and steps needed to configure the system from the ground up.
	For customers who want to deploy both conferencing and recording in their environments, please follow all the procedures in all the process boxes.
	For customers who want to deploy only conferencing without the recording capability, please skip the precedures labelled as (recording only).
	For customers who want to deploy only recording without the conferencing capability, please follow the procedures labelled as (recording only).
	For the installation of Cisco Unified Communications Manager (Unified CM), refer the to the Installing the Cisco Unified CM process in the Installation Guide for Cisco Business Edition 6000.
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	We would need two instances of Cisco Meeting Servers installed. One for Conferencing and the second for Recording and Streaming.
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	2. Deploy OVA to Host for Conferencing
	3. Deploy OVA to Host for Recording and Streaming
	4. Configure the VM Guest for Conferencing
	5. Configure the VM Guest for Recording
	6. Apply Licenses on Cisco Meeting Server
	 This process guides you through installing the Cisco Meeting Server. 
	Configure Cisco Business Edition 6000 Connectivity to LAN
	The Cisco Business Edition 6000 is connected to a switch in the data center.
	Step 1.   Using the user account that has the ability to make configuration changes, log in to the data center switch.
	Step 2.   If there is a previous configuration on the switch port where BE6000 is connected, bring the port back to its default state by issuing a no in front of each command.
	Step 3.   Configure the port as an access port. 
	interface GigabitEthernet1/14 
	description BE6000
	switchport access vlan 20
	switchport host
	Deploy OVA to Host for Conferencing
	This procedure represents a typical installation. The Deploy OVF Template wizard dynamically changes to reflect host configuration, so your steps may vary.
	Step 1.   Log in to vSphere in order to access the ESXi Host.
	Step 2.   Select File > Deploy OVF Template.
	 /
	Step 3.   Click Browse, find the location of the ova file, click Open, and then click Next.
	/
	Step 4.   On the OVF Template Details page, click Next.
	Step 5.   If an End User License Agreement page appears, read it, click Accept, then Next.
	Step 6.   On the Name and Location page, enter cms1 and the Inventory Location where the virtual machine will reside.
	Step 7.   If the Host Cluster page appears, select the host or cluster you want to run the deployed virtual machine, and then click Next.
	Step 8.   If the Resource Pool page appears, select the resource pool with which you want to run the deployed virtual machine, and then click Next.
	Step 9.   If the Storage page appears, select the datastore onto which the Cisco Meeting Server Virtual Machine Guest will be deployed, and then click Next.
	Step 10.   On the Disk Format page, ensure that the default disk format of Thick Provision Lazy Zeroed is selected and then click Next.
	 /
	i
	Tech Tip
	Because VM performance may degrade during the resizing of a partition, Thin Provision is not recommended.
	Step 11.   If Network Mapping is listed, configure it and select the network mapping that applies to your infrastructure (the default is VM Network), and then click Next.
	Step 12.   On the Ready to Complete page, confirm your deployment Setting, do not select Power on after deployment, and click Finish.
	/
	Step 13.   Right-click the cms1 virtual machine and click Edit Settings.
	Step 14.   Set the CPU to 8, Memory to 8 GB and click OK.
	/
	Cisco Meeting Server OVA for Conferencing is now deployed as a guest on the VM Host. 
	Deploy OVA to Host for Recording and Streaming
	Step 1.   Follow steps 1 - 5 from Procedure 2 above.
	Step 2.   On the Name and Location page, enter cms2 and the Inventory Location where the virtual machine will reside.
	Step 3.   Follow steps 7 -12 from Procedure 2 above.
	Step 4.   Right-click the cms1 virtual machine and select Edit Settings.
	Step 5.   Set the CPU to 4, Memory to 4 GB and click ok.
	Cisco Meeting Server OVA for Recording and Streaming is now deployed as a guest on the VM Host.
	Configure the VM Guest for Conferencing
	Step 1.   Right-click the VM guest and click Power -> Power On.
	Step 2.   Right-click the VM guest and click Open Console. The VM guest will take some time to boot. This is the Mainboard Management Processor (MMP) interface.
	Step 3.   When the Acano login prompt appears, log in with the following: 
	 Username: admin
	 Password: admin. 
	Step 1.   When the default password expires, create a new password and, The Cisco Meeting Server is now ready for initial configuration.
	Step 4.   At the acano: prompt, Enter the following to configure a static IP address.
	ipv4 a add 10.106.170.214/25 10.106.170.129
	/
	Cisco Meeting Server for Conferencing is now accessible using the configured IP address.
	Configure the VM Guest for Recording
	Step 1.   Follow steps 1 - 3 from Procedure 4 above.
	Step 2.   At the acano: prompt, Enter the following to configure a static IP address.
	ipv4 a add 10.106.170.215/25 10.106.170.129
	Cisco Meeting Server for Recording can now be accessed using the configured IP address.
	Apply Licenses on the Cisco Meeting Server
	For the scenarios covered in this CVD, the following types of licenses can be installed on the Cisco Meeting Server:
	 Virtual Machine Activation key for both the servers
	 CallBridge key
	 Recording and Streaming key
	 Personal Multiparty Plus License
	i
	Tech Tip
	For additional licensing details, refer to the Cisco Preferred Architecture for Midmarket Collaboration, Design Overview.
	The licenses are included in a single .lic file that must be uploaded to the CMS server. 
	Two cms.lic files are required. One is for Conferencing server and the other for the Recording and streaming server.
	The server for Conferencing will have the activation key and CallBridge key.
	The server for Recording and streaming will have activation key and Recording and Streaming key.
	Configuration of the Personal Multiparty Plus Licenses is covered in the Configuring Cisco Meeting Server section of this document.
	Step 1.   If the name of the license file is not cms.lic, you must rename it to cms.lic.
	Step 2.   Transfer the license file to the default folder of Cisco Meeting Server using SFTP.
	Step 3.   After the file is uploaded, restart the servers. 
	The required licenses are applied. 
	Installing TelePresence Management Suite 
	Easy Access Configuration Sheet 
	Cisco TMS Installation Requirements
	Element
	CVD Configuration
	Site-Specific Configuration
	TMS Name
	 TMS on Win Std 2012
	TMS IP Address
	10.106.170.203
	TMS Subnet Mask
	255.255.255.128
	TMS Default Gateway
	10.106.170.129
	Release Key
	IP/ISDN zone name
	HQ
	IP/ISDN zone country/region
	India
	Cisco TMS Configuration Requirements
	Element
	CVD Configuration
	Site-Specific Configuration
	DN range for scheduled conferences
	8211000-8211010
	PROCESS
	1. Install Windows Server
	2. Install TMS on the Windows Server
	This CVD installs the TMS applications on Windows Server 2012 Standard 64-bit Edition with Microsoft SQL Server 2012 64-bit installed. TMS stores all its customer data in its SQL database.
	i
	Tech Tip
	The SQL Server can also be installed off-box for resiliency.
	Install Windows Server
	Step 1.   Log in to vSphere to access the ESXi Host.
	Step 2.   Select File > New > Virtual Machine.
	 /
	Step 3.   On the Configuration page select Custom, and click Next.
	 /
	Step 4.   On the Name and Location page, enter Name as TMS on Win Std 2012, select Inventory Location and click Next.
	 /
	Step 5.   On the Storage page select the datastore and click Next.
	Step 6.   On the Virtual Machine Version page, select Virtual Machine Version: 8 and click Next.
	 /
	Step 7.   On the Guest Operating System page, select Windows under Guest Operating System, select Microsoft Windows Server 2012 (64-bit) and click Next.
	 /
	Step 8.   On the CPUs page, select the following and click Next: 
	 Number of Virtual sockets:  1
	 Number of cores per virtual: 1
	 /
	Step 9.   On the Memory page, select Memory Size as 8 GB and click Next.
	 /
	Step 10.   On the Network page, select the How many NICs do you want to connect as 1 and click Next.
	Step 11.   On the SCSI Controller page, select the appropriate settings and click Next.
	Step 12.   On the Select a disk page, select Create a new virtual disk, click Next.
	 /
	Step 13.   On the Create a Disk page, select Disk Size as 60 GB, Disk Provisioning as Thick Provision Lazy Zeroed and click Next.
	 /
	i
	Tech Tip
	Because VM performance may degrade during the resizing of a partition, Thin provision is not recommended.
	Step 14.   On the Advanced Options page, select appropriate options and click Next.
	Step 15.   On the Ready to Complete page, confirm your deployment settings and click Finish.
	Step 16.   Once the VM is created, right-click the newly created VM, select Power and click Power On. 
	Step 17.   Install Windows Server 2012 Standard on this newly created VM.
	Step 18.   To configure the IP information, enter the following in the relevant fields. (Configure other entries as required):
	o IP address: 10.106.170.203
	o Subnet mask: 255.255.255.128
	o Default gateway: 10.106.170.129
	o DNS server: 10.106.170.130
	Step 19.   Complete all critical Windows updates, close all open applications and disable virus-scanning and other software that may prevent an installation from completing.
	i
	Tech Tip
	Depending on windows components needing to be added, you may me prompted to reboot the server more than once during the installation. The installer automatically resumes after the server boots.
	The Windows server is now installed.
	Step 20.   Install SQL Server 2012 on the Windows Server.
	Install TMS on the Windows Server
	For the scenarios covered in this CVD, following are the type of licenses installed on the TMS:
	 Cisco TelePresence Management Suite Base License
	 Cisco TMS – additional 100 systems
	i
	Tech Tip
	For additional licensing details, refer the Cisco Preferred Architecture for Midmarket Collaboration, Design Overview.
	Step 1.   Download the Cisco TMS.zip file from Cisco.com.
	Step 2.   Extract the .zip file.
	Step 3.   Run the Cisco TMS executable as administrator.
	The installer checks the hardware and software configuration of the server. A warning or error message may be displayed, depending on your server’s configuration. Follow the prompts and install any missing Windows server components.
	Step 4.   Click Yes to continue.
	Step 5.   On the welcome screen, click Next.
	/
	Step 6.   On the License Agreement page, click Yes.
	 /
	Step 7.   On the Database Settings page, select Use local SQL Server, enter the username, password to allow the installer to create a new database, and click Next.
	/
	/
	i
	Tech Tip
	The SQL Server can also be installed off-box for resiliency.
	Step 8.   On the Release and Option Keys page, enter the release key and click Next.
	/
	Step 9.   On the Network and Settings page, enter the following:
	 TMS Server IPv4 Address: 10.106.170.203
	 IP Broadcast/Multicast Addresses for System Discovery: 10.106.170.255
	/
	Step 10.   Click Next.
	Step 11.   On the IP/ISDN Zone page, enter the following:
	 Name: HQ
	 Country/Region: India
	Step 12.   Click Next.
	Step 13.   On the Folder Settings page, specify the TMS installation path and click Next.
	Step 14.   On the Encryption Key page, click Generate to generate the new encryption key and click Copy.
	 /
	Step 15.   Click Next.
	Step 16.   On the Start Copying Files page, verify all the settings.
	Step 17.   Click Next.
	Step 18.   On the HTTPS for the TMS Website page, click Create to generate a self-signed certificate and click OK.
	Step 19.   Click Finish.
	 /
	  The setup wizard is complete and TMS is now installed.
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	API username / password
	api / Password
	WebAdmin Listening Port
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	8443
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	8443
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	Creating a new user for configuring though APIs
	A new user account has to be created for configuration throughout the API. This has to be done using the Mainboard Management Processor (MMP) interface in CMS which can be reached by doing SSH into the CMS server.
	Step 1.   SSH into the CMS server using the admin credentials.
	Step 2.   Enter the following command to create an API user named api:
	Step 3.   Enter password as api twice when prompted to enter the password.
	Step 4.   Enter the command user list to confirm the creation of the user.
	/
	A new user has been created. This CVD uses the Postman tool which is available as an extension for the Google Chrome browser.
	The APIs Actions used to configure CMS are:
	 GET – Retrieves existing information 
	 POST – Creates new instance
	 PUT – Modifies existing instance
	 DELETE – Deletes existing instance
	API commands are entered as an URL in the following format:
	/
	Following steps would verify the newly created API user works on CMS.
	Step 5.   Open Google Chrome, and go to: https://chrome.google.com/webstore/category/apps.
	Step 6.   In the search bar, search for Postman.
	/
	Step 7.   Install the Postman app and restart Chrome.
	Step 8.   Enter chrome://apps/ and Enter.
	Step 9.   Click the Postman app installed above to open the application.
	Step 10.   Enter the following values to check if GET messages are working for CMS:
	 Select GET from the dropdown list
	 Enter https://10.106.170.214:443/api/v1/system/status in the parameter section, 
	 Select Authorization tab, select Type as Basic Auth and enter the username api and the password
	/
	Step 11.   Click Send.
	Step 12.   If you get the following error, then log in via the Chrome browser to the CMS Webadmin interface and accept the certificates.
	/
	Step 13.   After you can successfully log in to CMS server, sending the above GET message should give a similar output.
	/
	The created API user works fine.
	Enabling WebAdmin, CallBridge, Recorder, XMPP and WebBridge modules
	WebAdmin is the module that enables https access to the CMS server for GUI configurations. WebAdmin is accessible only through https. Security certificates have to be created and installed on the CMS server for logging in. 
	Step 1.   Log in to the MMP of CMS for conferencing using the admin account and enter the following command to create webadmin1.key and webadmin.csr files:
	pki csr webadmin1
	Step 2.   Download the CSR file using a SFTP from the CMS server.
	Step 3.   Get the CSR file signed by a Certificate Authority(CA), get a signed certificate and upload the signed certificate file to the CMS server using SFTP.
	Step 4.   Enter the following commands to enable the WebAdmin module on CMS:
	webadmin certs webadmin1.key webadmin1.crt
	webadmin listen a 445
	webadmin restart
	webadmin enable
	/
	Now CMS can be accessed using https://10.106.170.214:445/.
	CallBridge is the module that enables audio and video conferencing in CMS. Following steps enable the CallBridge module on CMS.
	Step 5.   Log in to the MMP of CMS for conferencing using the admin account and enter the following command to create callbridge.key and callbridge.csr files:
	pki csr callbridge
	Step 6.   Download the CSR file using a SFTP from the CMS server.
	Step 7.   Get the CSR file signed by a Certificate Authority (CA), get a signed certificate and upload the signed certificate file to the CMS server using SFTP.
	Step 8.   Enter the following commands to enable the CallBridge module on CMS:
	callbridge certs callbridge.key callbridge.crt
	callbridge listen a
	callbridge restart
	/
	CallBridge is now enabled.
	Recorder is the module that enables the recording of conference spaces on the CMS server. Following steps enable recorder.
	Step 9.   Log in to the MMP of CMS for recording using the admin account and enter the following command to create cms2recorder.key and cms2recorder.csr files:
	Step 10.   Download the CSR file using a SFTP from the CMS server.
	Step 11.   Get the CSR file signed by a Certificate Authority(CA), get a signed certificate and upload the signed certificate file to the CMS server using SFTP.
	Step 12.   Upload the callbridge signed certificate file to the CMS server using SFTP.
	Step 13.   Enter the following commands to enable the recorder module on CMS:
	/
	Step 14.   Issue the following API command on CMS for conferencing:
	 Method – POST
	 URL - https://10.106.170.214:445/api/v1/recorders
	/
	Step 15.   Check the created recorders instance on CMS for conferencing by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/recorders
	/
	/
	Step 16.   Add the recording URL on the CMS for conferencing by issuing the following API command:
	 Method: PUT
	 URL: https://10.106.170.214:445/api/v1/recorders/f3dbe066-fa97-4f8c-8771-a3612895cf06
	 Key: url, Value: https://10.106.170.215:8443
	/
	Step 17.   Verify the configuration by using the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/recorders/f3dbe066-fa97-4f8c-8771-a3612895cf06
	/
	Step 18.   Create a new callProfile to enable recording using the following command:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/callProfiles/
	/
	Step 19.   Verify the configuration using the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/callProfiles/
	/
	Step 20.   Enable recording in the above created callProfile using the following command:
	 Method: PUT
	 URL: https://10.106.170.214:445/api/v1/callProfiles/602eb7e1-4152-4737-8aec-81a4008d7985
	 Key: recordingMode, value: manual
	/
	Step 21.   Create a callLegProfile to enable recording control for every user by using the following commands:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/callLegProfiles/
	/
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/callLegProfiles/
	/
	 Method: PUT
	 URL: https://10.106.170.214:445/api/v1/callLegProfiles/6735d228-7cde-4298-ad6a-452068b8337e
	 Key: recordingControlAllowed, Value: true
	/
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/callLegProfiles/6735d228-7cde-4298-ad6a-452068b8337e
	/
	Step 22.   Create the dtmfProfile to map the DTMF tones to start and stop the recording by using the following commands:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/dtmfProfiles
	/
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/dtmfProfiles
	/
	 Method: PUT
	 URL: https://10.106.170.214:445/api/v1/dtmfProfiles/0e613fff-3f31-4996-aff5-aef12449da08
	 Key: startRecording, Value: *7
	 Key: stopRecording, Value: *8
	/
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/dtmfProfiles/0e613fff-3f31-4996-aff5-aef12449da08
	/
	Step 23.   Apply the above created callProfile, callLegProfile and dtmfProfile to the system default profile by following the commands:
	 Method: PUT
	 URL: https://10.106.170.214:445/api/v1/system/profiles
	 Key: callLegProfile, Value - 6735d228-7cde-4298-ad6a-452068b8337e
	 Key: callProfile, Value - 602eb7e1-4152-4737-8aec-81a4008d7985
	 Key: dtmfProfile, Value - 0e613fff-3f31-4996-aff5-aef12449da08
	/
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/system/profiles
	/
	The Recorder is configured but would need the XMPP module to be enabled too.
	XMPP server is needed for recording and for participants joining spaces through CMA or webRTC based browsers. Following steps enables XMPP server on CMS for conferencing.
	Step 24.   Create DNS A record for cms1.mmcvd.ciscolabs.com as this server will be used to host the XMPP Server and set it to the IP address 10.106.170.214 which is the interface that the XMPP server is listening on.
	Step 25.   Create DNS SRV record for _xmpp-server for tcp port 5269 resolving to the DNS A record cms1.mmcvd.ciscolabs.com.
	Step 26.   Create DNS SRV record for _xmpp-client for tcp port 5222 resolving to the DNS A record cms1.mmcvd.ciscolabs.com.
	Step 27.   SSH into the CMS for conferencing and enter the following commands to enable the XMPP module:
	/
	XMPP server is enabled. 
	WebBridge is being used by the WebRTC app. The users or guests who want to join a conference can use a WebRTC-supported web browser to join the conference. The following steps enable WebRTC on the CMS for conferencing. 
	Step 28.   SSH into the CMS for conferencing, create a key and csr file using the following command:
	Step 29.   Get the csr signed by a CA server, then upload the crt file back on the server:
	Step 30.   SSH in to the CMS for conferencing server, and enter the following commands:
	Step 31.   Create a DNS A record for the WebBridge and set it to resolve to the IP address: 10.106.170.214.  
	The WebBridge is now enabled.
	Setting up CMS to be an ad-hoc resource in CUCM
	Step 1.   Log in to the GUI of CMS for conferencing, navigate to Configuration > Incoming Calls, under Call Matching section enter the following and hit Add New:
	 Domain name: 10.106.170.214
	 Priority: 1
	 Targets Spaces: Yes
	 Targets users: Yes
	 Targets IVRs: Yes
	 Targets Lync: No
	 Targets Lync Siplejoin: No
	/
	Step 2.    Log in to the GUI of CMS for conferencing, navigate to Configuration > Incoming Calls, under Call Matching section enter the following and hit Add New:
	 Domain name: mmcvd.ciscolabs.com
	 Priority: 1
	 Targets Spaces: Yes
	 Targets users: Yes
	 Targets IVRs: Yes
	 Targets Lync : No
	 Targets Lync Siplejoin: No
	/
	Setting up CMS for Personal Spaces
	For Personal Spaces for users in the Active Directory will be automatically created when we import the users in Cisco Meeting Server. This section configures the LDAP related settings and imports users from the AD.
	In this CVD a separate Organizational Unit called cmaUsers have been created with users who can log in to the CMA application or via webRTC supported browsers.
	Step 1.    Create a ldapServer by issuing the following API command on CMS for conferencing through Postman:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/ldapServers
	 Key: address, Value – 10.106.170.130
	 Key: PortNumber, Value: 389
	 Key: username, Value: cn=Administrator,cn=Users,dc=mmcvd,dc=ciscolabs,dc=com
	 Key: password, Value: Password
	 Key: secure, Value: false 
	/
	Step 2.   Check the created instance of ldapServer by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/ldapServers
	/
	Step 3.   Create a ldapMappings by issuing the following API command on CMS for conferencing through Postman:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/ldapMappings
	 Key: jidMapping, Value: $mail$@mmcvd.ciscolabs.com
	 Key: nameMapping, Value: $cn$
	 Key: coSpaceNameMapping, Value: $cn$’s Space
	 Key: coSpaceUriMapping, Value: $mail$.space
	 Key: coSpaceSecondaryUriMapping, Value: $telephoneNumber$
	 Key: coSpaceCallIdMapping, Value: $telephoneNumber$
	/
	Step 4.   Check the created instance of ldapMapping by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/ldapMappings
	/
	 Method: GET
	 URL:  https://10.106.170.214:445/api/v1/ldapMappings/4d91054d-11d7-493e-bcd0-a9fb2fdf0e30
	/
	Step 5.   Create a ldapSource by issuing the following API command on CMS for conferencing through Postman:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/ldapSources
	 Key: server, Value: dc639ccb-c9bd-4183-848a-7fc893e0d8e4
	 Key: mapping, Value: 4d91054d-11d7-493e-bcd0-a9fb2fdf0e30
	 Key: baseDn, Value: ou=cmaUsers,dc=mmcvd,dc=ciscolabs,dc=com
	 Key: filter, Value: (&(objectClass=user)(sAMAccountName=*))
	/
	Step 6.   Check the created instance of ldapSource by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/ldapSources
	/
	Step 7.   Start a ldapSync with the above created ldapSource by issuing the following API command on CMS for conferencing through Postman:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/ldapSyncs
	 Key: removeWhenFinished, Value: false
	 Key: ldapSource, Value: 0271689d-6148-4c3a-9b6a-142c9286cc30
	/
	Step 8.   Check the status of ldapSync by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/ldapSyncs
	/
	Step 9.   Check the users imported by log in to the GUI of CMS for conferencing and navigating to Status > Users.
	/
	Step 10.   Check the Spaces created by navigating to Configuration > Spaces.
	/
	Personal Spaces are created.
	Setting up Personal Multiparty Plus Licenses
	To enable a set of users to be PMP+ users, a user profile has to be configured with hasLicense parameter as true. This represents the users with this userProfile will use Personal Multiparty Plus License. 
	Before that CMS has to be configured with ldapServer, ldapMapping and ldapSource configuration, which is similar to the configuration in Configuration > Active Directory on CMS for conferencing.
	Step 11.   Create a userProfile by issuing the following API command on CMS for conferencing through Postman:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/userProfiles
	Step 12.   Check the created instance of userProfile by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/userProfiles
	/
	Step 13.   Enable the personal multiparty parameter by issuing the following command:
	 Method: PUT
	 URL:  https://10.106.170.214:445/api/v1/userProfiles/ed9af2dd-6f34-49ff-ba87-b5ce8e5baf20
	 Key: hasLicense, Value: true
	/
	Step 14.   Update the existing ldapSource, created in the previous procedure, by issuing the following API command on CMS for conferencing through Postman:
	 Method: PUT
	 URL: https://10.106.170.214:445/api/v1/ldapSources/0271689d-6148-4c3a-9b6a-142c9286cc30
	 Key: userProfile, Value: ed9af2dd-6f34-49ff-ba87-b5ce8e5baf20 
	/
	Step 15.   Check the created instance of ldapSource by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/ldapSources
	/
	Step 16.   Start a ldapSync with the above created ldapSource by issuing the following API command on CMS for conferencing through Postman:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/ldapSyncs
	 Key: ldapSource, Value: 0271689d-6148-4c3a-9b6a-142c9286cc30
	/
	Step 17.   Verify the ldapSync by issuing the following API command on CMS for conferencing through Postman:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/ldapSyncs
	/
	Step 18.   Check the users if the userProfile has been associated or not by issuing the following commands:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/users/
	/
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/users/d30c90a0-ff06-490c-8125-97d315db728c
	/
	Personal Multiparty Plus Licenses are applied to the imported users on CMS for conferencing.
	Setting up CMS for WebRTC
	WebRTC capability enables the users to join into spaces without any Video endpoint. A user can log in to CMA though a webRTC supported browser.
	XMPP and WebBridge modules must be enabled for the WebRTC to be working. It has been enabled in the Enabling WebAdmin, CallBridge, Recorder, XMPP and WebBridge modules.
	Following are the further steps to do the rest of the configurations.
	Step 1.   Go to Configuration > General and configure the following in the WebBridge settings:
	 Guest account client URI: https://10.106.170.214
	 Guest account JID domain: mmcvd.ciscolabs.com
	 Guest access via ID and passcode: secure: require passcode to be supplied with ID
	 Guest access via hyperlinks: allowed
	 User sign in: allowed
	/
	 WebRTC capability is enabled on CMS for conferencing, users can browse the URL https://10.106.170.214 and use this feature.
	/
	Setting up CMS for Recording
	Recording module must be enabled and has been enabled in the Enabling WebAdmin, CallBridge, Recorder, XMPP and WebBridge modules. 
	Step 1.   Create a recorder instance on the CMS for conferencing and give the IP address of the CMS for recording server by issuing the following API command:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/recorders
	 Key: url, Value: https://10.106.170.215:8443
	/
	Step 2.   Verify the created instance of recorder by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/recorders
	/
	Step 3.   Create a callProfile instance on the CMS for conferencing and set the recording mode as manual which means user has to enter a set of DTMF keys to start or stop recording, by issuing the following command:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/callProfiles
	 Key: recordingMode, Value: manual
	/
	Step 4.   Verify the created instance of callProfile by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/callProfiles
	/
	Step 5.   Create a callLegProfile instance on the CMS for conferencing and set which users have the permission to start and stop recording by issuing the following command:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/callLegProfiles
	 Key: recordingControlAllowed, Value: true
	/
	Step 6.   Verify the created instance of callLegProfile by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/callLegProfiles
	/
	Step 7.   Create a dtmfProfile instance on the CMS for conferencing to setup the keys used to start and stop the recording by issuing the following command:
	 Method: POST
	 URL: https://10.106.170.214:445/api/v1/dtmfProfiles
	 Key: startRecording, Value: *7
	 Key: stopRecording, Value: *8
	/
	Step 8.   Verify the created instance of dtmfProfile by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/dtmfProfiles
	/
	Step 9.   Apply the above created callLegProfile, callProfile and dtmfProfile to the system profile by issuing the following command:
	 Method: PUT
	 URL: https://10.106.170.214:445/api/v1/system/Profiles
	 Key: callLegProfile, Value: 6735d228-7cde-4298-ad6a-452068b8337e
	 Key: callProfile, Value: 602eb7e1-4152-4737-8aec-81a4008d7985
	 Key: dtmfProfile, Value: 0e613fff-3f31-4996-aff5-aef12449da08
	/
	Step 10.   Verify the system Profile by issuing the following command:
	 Method: GET
	 URL: https://10.106.170.214:445/api/v1/system/Profiles
	/
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	PROCESS
	1. Add Cisco Meeting Server on TMS
	2. Configuring CMS in TMS for Scheduled Conferences 
	3. Configure Conference Settings on TMS
	Add Cisco Meeting Server on TMS
	Step 1.   Log in to the TMS and navigate to Systems > Navigator.
	/
	Step 2.   Click Add Systems.
	Step 3.   Under the Add by Address tab, enter the following:
	 IP Address: 10.106.170.214:445
	 Username: api
	 Password: Password
	/
	Step 4.   Click Next and then click Finish Adding Systems.
	/
	Configuring CMS in TMS for Scheduled Conferences
	Step 1.   Click the newly added CMS system from the Navigator section, and then select the Settings tab.
	Step 2.   Configure the following and click Save:
	 Name: cms1
	 Allow Incomming H.323 Dialing: Unchecked
	 Allow Outgoing H.323 Dialing: Unchecked
	/
	Step 3.   Click the Extended Settings sub-tab, enter the following and click Save:
	 Domain: mmcvd.ciscolabs.com
	 Numeric ID Base: 8211001
	 Numeric ID Quantity: 10
	/
	Now 10 Spaces with the above shown ID will be created on CMS for the conferencing server. These spaces will be used as scheduled spaces when a user schedules a conference. These spaces will be enabled only during the time of a scheduled conference and are disabled other times. 
	Step 4.   Verify the creation of spaces by logging in to the GUI of CMS for conferencing and navigating to Configuration > Spaces.
	/
	SIP Trunks must be configured for scheduled calls to work. (Covered in the Configuring CUCM section).
	The following steps, enable users to join a conference instantly with a single click. This requires the WebBridge module to be enabled (already configured in the previous sections). 
	Step 5.   Log in to TMS and navigate to Systems > Navigator.
	Step 6.   Select cms1, click the Settings tab and select Edit Settings. 
	Step 7.   Configure the following and click Save:
	 Web Bridge URI: https://10.106.170.214/
	/
	Configure Conference Settings on TMS
	Step 8.   Navigate to Administrative Tools > Configuration > Conference Settings. 
	Step 9.   Enter Preferred MCU Type in Routing as Cisco Meeting Server. And click Save.
	/
	The conference settings are configured. 
	Configuring Cisco Unified Communications Manager
	Easy Access Configuration Sheet 
	Cisco Unified CM Configuration Requirements
	Element
	CVD Configuration
	Site-Specific Configuration
	Video bandwidth for video region
	32256
	Route pattern for personal conferences
	821XXXX
	Route pattern for scheduled conferences
	851XXXX
	URI pattern for personal CMR conferences
	user.space@mmcvd.ciscolabs.com
	PROCESS
	1. Configure Region for Video
	2. Configure Device Pool for Video and Add the Video Region
	3. Configure SIP Trunk to Cisco Meeting Server for Conferences
	4. Configure Directory Number Route Pattern for Personal and Scheduled Conferences 
	5. Configure Unified CM SIP Route Pattern for Personal CMR Conferences 
	6. Configure Cisco Meeting Server as Conference Bridge for Ad-Hoc Conferences
	7. Add this MRGL to the Device Profile for Video
	Configure Region for Video
	Step 1.   Navigate to System > Region Information > Region, and click Add New in order to create a new Region.
	Step 2.   In Name, enter Video_Reg, and then click Save.
	 /
	Step 3.   Under Regions, select Default.
	Step 4.   Under Maximum Session Bit Rate for Video Calls, enter 32256 kbps and click Save.
	 /
	This CVD is using 32256 as the configured video bandwidth for this region.
	The region is configured. 
	Configure Device Pool for Video and Add the Video Region
	Step 1.   Navigate to System > Device Pool, and then click Add New in order to add a new device pool.
	Step 2.   Enter the following into the relevant fields, leaving the other fields at their default values and click Save.
	 Device Pool Name:Video_DP
	 Cisco Unified Communications Manager Group: Sub1_Pub1
	 Date/Time Group: CMLocal
	 Region: Video_Reg
	 /
	The device pool is configured.  
	Configure SIP Trunk to Cisco Meeting Server for Conferences
	A trunk is a communications channel on Unified CM that enables it to connect to other servers. Using one or more trunks, Unified CM can receive or place voice, video, and encrypted calls, exchange real-time event information, and communicate in other ways with call control servers and other external servers.
	Step 1.   Navigate to Device > Trunk, and then click Add New in order to create a new SIP trunk.
	Step 2.   Enter the following into the relevant fields:
	 Trunk Type: SIP Trunk
	 Device Protocol: SIP
	 Trunk Service Type: None(Default)
	 /
	Step 3.   Click Next.
	Step 4.   Enter the following into the relevant fields, leaving other fields at their default values:
	 Device Name: TR-2-CMS1
	 Device Pool: Video_DP
	 Destination Address: 10.106.170.214
	 Destination Port: 5060
	 SIP Trunk Security Profile: Non Secure SIP Trunk Profile
	 SIP Profile: Standard SIP Profile for TelePresence Conferencing
	 Normalization Script: cisco-telepresence-conductor-interop
	/
	/
	Step 5.   Click Save, and then click Reset. 
	Step 6.   Now click Reset again in the pop-up window that appears and click Close. 
	The Unified CM trunk is now configured to the Cisco Meeting Server for conferences.
	Configure Directory Number Route Pattern for Personal and Scheduled Conferences
	In this CVD, 851XXXX is the range of Directory Numbers for Personal Conferences and 821XXXX is the range of Directory Numbers for Scheduled Conferences. 
	Step 1.   Navigate to Call Routing > Route/Hunt > Route Pattern, and then click Add New to create a new route pattern.
	Step 2.   To route calls to the personal conferences, enter the following in the relevant fields, leave other fields at their default values and click Save.
	 Route Pattern: 851XXXX
	 Gateway/Route List: TR-2-CMS1
	/
	Step 3.   Navigate to Call Routing > Route/Hunt > Route Pattern, and then click Add New to create a new route pattern.
	Step 4.   To route calls to scheduled conferences, enter the following in the relevant fields, leave other fields at their default values and click Save.
	 Route Pattern: 821XXXX
	 Gateway/Route List: TR-2-CMS1
	/
	The route patterns are now configured. 
	Configure Unified CM SIP Route Pattern for Personal CMR Conferences
	The regular Unified CM SIP route pattern routing cannot be used for routing calls to the personal CMR conferences created in this document because Unified CM can only route URIs based on domains (e.g. mmcvd.ciscolabs.com) and not the URIs created for the personal conferences (e.g. space@mmcvd.ciscolabs.com).
	To route the calls to the personal CMR conference URIs, you must use the Intercluster Lookup Service (ILS) in the Unified CM and manually import the personal CMR conference URIs into Unified CM.
	The following steps configure the Unified CM to enable ILS and import the personal CMR conference URLs.
	Step 1.   Click the Navigation tab on the top right corner of the Unified CM Administration page, select Cisco Unified Serviceability from the dropdown list and click Go.
	 /
	Step 2.   Navigate to Tools > Service Activation.
	/
	Step 3.   Select CUCM-Pub--CUCM Voice/Video from the drop-down list under the Server field, and click Go.
	Step 4.   Select the Cisco Bulk Provisioning Service under the Database and Admin Services pane, and click Save.
	/
	Step 5.   Go back to the Cisco Unified CM Administration page by clicking on the Navigation tab at the top-right corner of the Cisco Unified Serviceability page. 
	Step 6.   Select the Cisco Unified CM Administration, and then click Go.
	 /
	ILS must be enabled and working for the following steps to work. ILS can work either in “Hub Cluster” or “Spoke Cluster” mode. In this CVD we follow a single cluster deployment, so we will configure this publisher in “Hub Cluster” mode.
	Step 7.   Navigate to Advanced Features > ILS Configuration, select Hub Cluster as the Role under the Intercluster Lookup Service Configuration tab, and then click Save.
	/
	Step 8.   Navigate to Call Routing > Global Dial Plan Replication > Imported Global Dial Plan Catalogue, and click Add New.
	Step 9.   Enter the following into the relevant fields:
	 Name: CMS_Personal_Space_Catalog
	 Route String: space.mmcvd.ciscolabs.com
	i
	Tech Tip
	The Route String is just a name, it does not represent that the user will have to dial *cmr.mmcvd.ciscolabs.com.
	Step 10.   Click Save.
	Step 11.   Create a cvd_space.csv file in the following format for all the personal CMR conference URIs that must be imported into the ILS of the Unified CM.
	/
	Step 12.   Navigate to Bulk Administration > Upload/Download Files and click Add New.
	Step 13.   Enter the following into the relevant fields:
	 File: cvd_space.csv
	 Select The Target: Imported Directory URIs and Patterns
	 Select Transaction Type: Insert Imported Directory URIs and Patterns
	 Overwrite File if it exists: Selected
	/
	Step 14.   Click Save.
	Step 15.   Navigate to Bulk Administration > Directory URIs and Patterns > Insert Imported Directory URI and Pattern Configuration.
	Step 16.   Enter the following into the relevant fields:
	 File Name: cvd_space.csv
	 Imported Global Dial Plan Catalog: CMS_Personal_Space_Catalog
	 Run Immediately: Selected
	/
	Step 17.   Click Submit.
	Step 18.   Navigate to Call Routing > SIP Route Pattern. 
	Step 19.   Click Add New.
	Step 20.   Enter the following into the relevant fields, leave other fields at their default values, and click Save. 
	 IPv4 Pattern: space.mmcvd.ciscolabs.com
	 SIP Trunk/Route List: TR-2-CMS1
	/
	The SIP route pattern is now configured. 
	Configure Cisco Meeting Server as Conference Bridge for Ad-Hoc Conferences
	This procedure describes configuring Cisco Meeting Server as a conference bridge in Unified CM for Ad-Hoc conferences.
	Ad-Hoc conferences on Cisco Meeting Server require the Cisco Unified CM to communicate with the API of the Cisco Meeting Server. The API requires HTTPS communication, so certificates must be created and uploaded to both the Cisco Meeting Server and Cisco Unified Communications Manager. For escalated ad hoc calls to work, each must trust the other's certificate, .
	Certificates on Cisco Meeting Server are already uploaded in the previous procedures.
	This process covers certificates on Unified CM.
	Step 1.   Log in to the CUCM OS Administration page and Navigate to Security > Certificate Management.
	Step 2.   Click the Generate CSR button and generate a Certificate Signing Request (CSR) for Cisco Unified Communications Manager.
	Step 3.   Get the CSR signed by a Certificate Authority and upload the signed certificate and private key to Unified CM.
	Step 4.   Select Upload Certificate / Certificate Chain.
	Step 5.   Click Browse to find your certificate. (This can be the root certificate or the call bridge’s certificate and certificate bundle) and click Upload.
	Step 6.   Navigate to Media Resources > Conference Bridge, and then click Add New in order to create a new conference bridge.
	Step 7.   Enter the following into the relevant fields, and leave other fields at their default values:
	 Conference Bridge Type: Cisco TelePresence Conductor
	 Conference Bridge Name: cms1
	 SIP Trunk: TR-2-CMS1
	 Allow Conference Bridge Control of the Call Security Icon: UnSelected
	 Override SIP Trunk Destination as HTTP Address: Selected
	 Hostname/IP Address: cms1.mmcvd.ciscolabs.com
	 Username: api
	 Password: password
	 HTTP Port: 445
	/
	Step 8.   Click Save.
	Step 9.   Make sure that the Conference Bridge shows as registered to the Unified CM.
	/
	Step 10.   Navigate to Media Resources > Media Resource Group, and then click Add New. 
	Step 11.   In Name, enter MRG-CMS1
	Step 12.   In Available Media Resources, select cms1 (CFB), click the down arrow to move it down to the Selected Media Resources and click Save.
	/
	Step 13.   Navigate to Media Resources > Media Resource Group List, and then click Add New. 
	Step 14.   In Name, enter MRGL-CMS1
	Step 15.   In Available Media Resources Groups, select MRG-CMS1 and click the down arrow to move it down to the Selected Media Resources Groups and click Save.
	/
	The Cisco Meeting Server is now configured as a media resource. 
	Add this MRGL to the Device Profile for Video
	Step 1.   Navigate to System > Device Pool, and then click Find in order to list all configured Device Pools.
	Step 2.   Select Video_DP.
	Step 3.   In Media Resource Group List, select MRGL-1-cond-1 and click Save.
	/
	The MRGL is added. 
	Configuring Endpoints
	PROCESS
	1. Configure Unified CM for Endpoints
	2. Configure SX20
	Configure Unified CM for Endpoints
	Step 1.   Navigate to Device > Phone, and then click Add New.
	Step 2.   In Phone Type, select Cisco TelePresence EX60.
	 /
	Step 3.   Click Next.
	Step 4.   Enter the following into the relevant field, and leave the other fields at their default values:
	 MAC Address: 00506005246F
	 Device Pool: Video_DP
	 Phone Button Template: Standard Cisco TelePresence EX60
	 Common Phone Profile: Standard Common Phone Profile
	 Device Security Profile: Cisco TelePresence EX60—Standard
	 SIP Profile: Standard SIP Profile for TelePresence Endpoint
	/
	Step 5.   Click Save.
	Step 6.   Click Line [1] - Add a new DN.
	 /
	Step 7.   In Directory Number, enter 8001001, and then click Save.
	 /
	Step 8.   Under Directory URIs, enter 8001001@mmcvd.ciscolabs.com as the URI and click Add Row.
	/
	The endpoint is now added. 
	Configure SX20
	Step 1.   Navigate to Home > Settings > Administrator Settings > Advanced Configuration > Provisioning > External Manager > Address.
	Step 2.   In External Manager, enter 10.106.170.135, and then click Save.
	The endpoint is added. 
	Initiating Conferences
	PROCESS
	1. Initiate Ad-Hoc Conference
	2. Initiate Personal Conference
	3. Create Scheduled CMR Conference
	Initiate Ad-Hoc Conference
	Step 1.   Call 8001002 from 8001001.
	Step 2.   After the call is connected, press on the Add+ button.
	Step 3.   Call 8001003 from 8001001.
	Step 4.   Press the Merge button.
	The Ad-Hoc conference should now be started.
	Initiate Personal Conference
	Step 1.   Call abhijitdey.space@mmcvd.ciscolabs.com from 8001001.
	Step 2.   Call abhijitdey.space@mmcvd.ciscolabs.com from 8001003.
	Step 3.   Call abhijitdey.space@mmcvd.ciscolabs.com from 8001003. 
	The personal conference should now be connected. 
	Step 4.   Call 8511001 from endpoints that cannot dial a SIP URI to join the same conference.
	Step 5.   A guest or other users can join the same Personal Conference from a WebRTC based browser by entering https://10.106.170.214/.
	/
	Step 6.   Click Join call, then enter 8511001 and click Continue.
	/
	Step 7.   Enter Guest1 and click Join call.
	/
	Guest1 can join the above conference.
	/
	Create Scheduled Conference
	Step 1.   Log in to TMS as a user by typing http://10.106.170.203/tms/ in the browser.
	Step 2.   Click Booking > New Conference.
	/
	Step 3.   Configure the settings based on the requirement and click Add Participants to add systems to the conference.
	/
	Step 4.   After you add participants, click Save.
	/
	The Meeting is created and users can dial 8211003@mmcvd.ciscolabs.com to join this conference.
	/
	Recording Conferences
	PROCESS
	1. Record Conferences
	Record Conferences
	Step 1.   While in the conference, press *7 to start a recording.
	Step 2.   Press *8 to stop the recording. 
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