المقدمة
يوضح هذا المستند كيفية حل أخطاء تسجيل الدخول إلى Kerberos أو LDAP للمستخدم OpenDNS_Connector عند عدم العثور على تقرير أحداث تسجيل الدخول DN.
المشكلة
تنطبق هذه المقالة على أخطاء الموصل حيث تفشل مصادقة Kerberos و LDAP، ولكن لا يزال يتم العثور على أحداث تسجيل الدخول. تشير أحداث تسجيل الدخول إلى "لم يتم العثور على DN".
الحل
يجب التحقق من خاصية UserPrincipalName وتحديثها لمستخدم OpenNs_connector:
1. افتح خصائص المستخدم لحساب open_connector.
2. تأكد من تحديد "UserPrincipalName" باستخدام عنوان البريد الإلكتروني الخاص بالحساب.
3. قارن قيمة UserPrincipalName بحساب آخر لتأكيد التنسيق والتعريف المتوقع.
4. قم بتحديث القيمة إذا لزم الأمر.
بمجرد ملء حقل UserPrincipalName، يمكن للموصل إستئناف العملية الصحيحة.
السبب
يحدث فشل في تسجيل الدخول بسبب اسم مستخدم غير معروف أو كلمة مرور غير صحيحة. تعرض السجلات المشكلة حيث أنه لا يزال يتم العثور على الأحداث، ولكن النظام يبلغ عن "DN لم يتم العثور عليه."
على سبيل المثال:
Logon failure: unknown user name or bad password.
7/22/2019 3:16:01 PM: Using NTLM for LDAP://10.0.0.31:389/DC=Nephrology,DC=com communication to fetch the DN
7/16/2019 4:33:18 PM: DN not found!