<dJ9su AnyConnect Remote Access VPN gJs
FTD

lJpzossle

| Jp, 9506

IJpobJole Il wsé
lJoobJule

lJodoule | OEdp0
o8 9ol |l sé
lJodJosy

1. IJpclbdole Ul wl_wsé

D) lwosil Giolyé SSL

>) 1oy, jule o2 0 oy |

2) logwle pJod w2 oS0 XML
0) wzesd o9y AnyConnect

I ool
lJ. 959>
leooble loosé

) opdsy URPF
o) wedsy gsh lJwelz Llo old sysopt VPN

psJ9ple do o Jé
NFX YY)

SuweWd o3l IJpwews odysy J AnyConnect Remote Access VPN gJs FTD.

lJecbdolo IUlgwlgusé
IJeobJule
9008 Cisco Ly oday Jbsd pe,uds ldpsluose IJoldss:
c peyd6 luwluwss Llduvwds IJglos IUblo,sé (VPN) g TLS g IKEV2

e 01586 slJes9s o sl ezl s (AAA) IJiul wss 908,96 RADIUS
. Szyub g pyd; 31,6 FirePOWER

lJedsule IJpuwegspd
ouwowd Idpedypele 1Jglyo WO o3l ldpuwews 1Js luesble Ido)lez 9ldedsule 1Jebss Ideldss:

. Cisco FTD 7.2.0
. CiscoFMC 7.2.1



- AnyConnect 4.10

Up |uu.u|c Urog_dgplu Ugl_,.)o u_95 o.>| |Jrouuuu.) ,Du Ulz_o_)o I._Jpgag.w x_9§ usso pE_deo z_luoo

peJ9plS |l uso
S9dp 03l IJpywowd puU| Jdodssu IUglue wldluesl) 7.2.0 ey "ld>Ale gu woss> FirePOWER
(FTD)" slJl_oshyle 1izac: sldses Sumpz Juivods VPN Jds,osd £0 wes dlovcisle lelo bods

IJodd (TLS) sldluosh 2 pu wobd pcle IJlow,ow (IKEV2). Jgpsd: spdu luvwesle Cisco
AnyConnect. 909 3890 £Js lubpd |uwluss pogsdé.

lJodosy

1. lJpobdoule IUlguluss

Jdloedld e pelde 1Jswosd e we> Ss pud; by Firepower:
- logule guobé ouwagse Jpuolb 96 1UEbe.
- Bp wodssy gl RADIUS ig LDAP Jo ol3$6 lJpuucése.

e vlugble wgeg pu ldevlsse Jeuwegrps VPN.
- wgpesd w9y AnyConnect Jlub po | wlwss pgoduds.

) luwos,l> Siolyé SSL

IJgboble yo)9,86 gus wdssu AnyConnect. szo o OTUIS I.Jua:uobé eds pdeld "lJluwe
lJoosd Jdeaunse” pe luwe DNS 9/ly euglo IP Jezue IUizble Os puwogsuole 1Usse.

pdlgbé: spJdy :Jrouuo'a)ro@ Cisco ldpwedsu Wb 1Us o9 1Us Ui>_9|o lJ>lgJsé
9ped9ple IJEbl.

ould 99> gds lJouwesd 1Usr9s Jduwolsé:
- s FTD ceolz IUs yuvol>s CA Bod lugule CSR.

- Bl op logile CSR ghzsl Wlu 1Ubys @96 1Us2956 o iud: Bszw luwwgsle bys@o pgoduds
(PKCS12).

ould 1Ugsrss pu IUb, 8 JJeuesd eds uvolds gds zoly FTD. 9JIu IJgsh 1Ulew sldwod 09
logsle bdw ©98se Uolss (CSR). 9usdseo wluwole IJpsze 1Upuoo8 (CA) e luwos)ls
IJuivol>e Iduolbye Jdpvclz IUgle: sldos Jluw bs CSR. 9ldsy bys@e IUdsle w3JY:

- IJluw@ld |Js Objects > Object Management > PKI > Cert Enroliment ¢ 10,9 <999 lolw96 o wesd
lJe@6.



Add Cert Enroliment (7]

Name*
vpntestbbed.cisco.com
Description
|
CA Information Certificate Parameters Key Revocation

Enrollment Type: | Manual v
[ ] CA Only
Check this option if you do not require an identity certificate fo be created
from this CA
CA Certificate: Ep':“_ Iangreno .. ST2xar
YfPCilB7g

BMAV7Gzdc4VspS6ljirAhbiiaw
dBiQIQmsBeFz9JkF4..b3I8Bo
GN+gMa56Y
lt8unaZgY4l20//on88r5IWJIm

Validation Usage: IPsec Client SSL Client [ | SSL Server
| | Skip Check for CA flag in basic constraints of the CA Certificate

|| Allow Overrides

Cancel Save

- &g>S> Enrollment Type 9J 29 Uwolsé IJp,yze lJpues9 (CA) (Iduwolss lJpuwegsrpd Jogdse
CSR).
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Add Cert Enrolilment

Name*
vpntesthbed.cisco.com
Description
CA Information Certificate Parameters Key Revocation

Include FQDN:

Include Device's IP Address:
Common Mame (CN):
Organization Unit (OU):
Organization (O):

Locality (L):

State (ST):

Country Code (C):

Email (E)

Use Device Hostname as FODN

10.88.243.123

vpntestbed.cisco.com

TAC

Mexico

MX

CDMX

MX

: I tac@cisco.com

Include Device's Serial Number | |

|| Allow Overrides

Cancel Save

R edlpd lJowsso IJolJeé o> Key Type: i'ao_) lJluwpe 9ldzze- wlduuwed s RSA wes
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Add New Certificate (7]

Add a new certificate to the device using cert enrollment object which is used to
generate CA and identify certificate.

Device*:
| FTD v|

Cert Enrollment®:

l vpntestbed.cisco.com| v ‘ +

Cert Enrollment Details:

MName: vpntestbed.cisco.com

- OSpl wediguggl) luwpe TrustPoint. |69, W99 + IUIS 9906 &p Yes: 9 weEdSU luuw "Csr
Juoz 9 1909€9. seu lu wewss Iduuwolé gds uwple ppleds Juwpele glbe HTTPS IJglsé.
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- IJlueld |Js Objects > Object Management > RADIUS Server Group > Add RADIUS Server Group.
Nedl 1Uluwpe 9luowd 09lu IP pg gy puvesdi @) save:



Edit RADIUS Server

IP Address/Hostname:*

192.168.20.7
Configure DNS at Threat Defense Platform Settings to resolve hostname
Authentication Port:* (1-65535)

1812
Key:*

Confirm Key:*

—
—a
I
an
(9 |
(]
Cad
(9 |

Accounting Port:
1813

Timeout: (1-300) Seconds

10

Connect using:
(® Routing () Specific Interface @

Default: Management/Diagnostic i

Redirect ACL:

- 908> 08 wodlds IUuws,ys) eds [JSlsps:
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- IJlueld |Js Objects > Object Management > Address Pools > Add IPv4 Pools.

« 9028 IUluwe sldubl @ sldBule es) plodyw:
Mame*

I vpn_pool ‘

IPv4 Address Range*
\ 10.72.1.1-10.72.1.150 \

Mask
‘ Specify a netmask in X.X.X.X format ‘

Description

Allow Overrides

. Configure device overrides in the address pool object to
avoid IP address conflicts in case of object is shared across
multiple devices

»  Override (0)

3) loble pdWd oguosue XML

* 8p wouisd pru pddle lJogssd pu psde Cisco gldezo.
- IJlooyld |Js server List > Add...

+ 9528 luwe IJg,u2 9 FQDN. spdod punloss IUlglJle WOs $lises 1Ugslse:

[ AnyConnect Profile Editor - VPN

File Help
VPN | Server List
@ Preferences (Part 1) . J
Profile: C:AUsers\calo\Documents\Anyconnect_profile.xml

----- -+ Preferences (Part 2)

----- Backup Servers

----- % Certificate Pinning
=0 Certificate Matching
----- Certificate Enrollment

Hostname Host Address User Group
-- Inherited --
- Inherited --

VPM(S5L) vpntestbed.dsco....
vpntestbed.cisco....

Backup Server List  SCEP

Maobile Settings

Certificate Pins

{23y Mobile Policy VPN(IPSEC)

----- il Server List

Mote: it is highly recommended that at least one server be defined in a profile.

- lu9) OK9 File > Save as...

Add...

Delete

Details




o) wepsd w29y AnyConnect
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- IJlueWld |Js Objects > Object Management > VPN > AnyConnect File > Add AnyConnect File.

cldoo |J|L}u,o 92> le_Q PKG PV |.JL§_)UD‘ |Qk§_) Save:

Edit AnyConnect File (7]

Mame:*

I Mnyconnectmac4.10 |

File Name:*

| anyconnect-macos-4.10.06079-webdef | | Browse..
File Type:*

| AnyConnect Client Image v |
Description:

| Cancel |

B 1Upsss po 1dese wole eds pobdoled 1Jgluos.

2. pelde IJouesd o we>

- IJlue¥ld |Js Devices > VPN > Remote Access > Add a new configuration.
- 8p wouwpss pJV IJog s 9ueass gol; FTD:



Targeted Devices and Protocols

This wizard will guide you through the required minimal steps to configure the Remote
Access VPN policy with a new user-defined connection profile.

Mame:*

| Anyconnect_RA |

Description:

VPN Protocols:

SSL
IPsec-IKEv2

Targeted Devices:

Available Devices Selected Devices

| Q_ Search | FTD

FTD

- VOS ¢b9s pJud we)ysW IJle ol [Je . Connection Profile Name: 25> Authentication Server 9 Address
Pools IJos Ypw vluublsel gwlogl:



Connection Profile:

Connection Profiles specify the tunnel group policies for a VPN connection. These policies pertain to creating the
tunnel itself, how AAA is accomplished and how addresses are assigned. They also include user attributes, which
are defined in group policies.

Connection Profile Name:* | Anyconnect_RA

I @ This name is configured as a connection alias, it can be used to connect to the VPN gateway

Authentication, Authorization & Accounting (AAA):

Specify the method of authentication (AAA, certificates or both), and the AAA servers that will be used for VPN
connections.

Authentication Method: [ AAA Only v l

RadiusServer v l -+
(LOCAL or Realm or RADIUS)
[ Fallback to LOCAL Authentication

Authentication Server:*

Authorization Server: | Use same authentication server | +
(Realm or RADIUS)

Accounting Server: | v | -
(RADIUS)

Client Address Assignment:

Client IP address can be assigned from AAA server, DHCP server and IP address pools. When multiple options are
selected, IP address assignment is tried in the order of AAA server, DHCP server and IP address pool.

] Use AAA Server (Realm or RADIUS only) @
[ ] Use DHCP Servers
Use IP Address Pools

IPvd Address Pools: | vpn_pool

N

IPv6 Address Pools: I

Group Policy:

A group policy is a collection of user-oriented session attributes which are assigned to client when a VPN
connection is established. Select or create a Group Policy object.

Group Policy:* DfitGrpPolicy v | +

Edit Group Policy

- lu@) W99 Edit Group Policy 9eJs £Jlpo IJew9se AnyConnect. 2> Client Profile. &p 10,9, Save:



Edit Group Policy (7]

Name:*
DfitGrpPolicy

Description:

General AnyConnect Advanced

Profile

AnyConnect profiles contains settings for the VPN client functionality and
Management Profile = optional features. Firewall Threat Defense deploys the profiles during
AnyConnect client connection.

Client Modules

SSL Settings Client Profile:

Connection Settings Anyconnect_profile v | +

Custom Attributes Standalone profile editor can be used to create a new or modify existing

AnyConnect profile. You can download the profile editor from Cisco Software
Download Center.

- s lJuowes IJeldsé: 23> o9, AnyConnect 9l ) Next.
AnyConnect Client Image

The VPN gateway can automatically download the latest AnyConnect package to the client device when the VPN
connection is initiated. Minimize connection setup time by choosing the appropriate OS for the selected package.

Download AnyConnect Client packages from Cisco Software Download Center.

Show Re-order buttons 4

AnyConnect File Object Name AnyConnect Client Package Name Operating System

Anyconnectmac4.10 anyconnect-macos-4.10.06079-webdeploy... Mac OS v ‘

- O Iyl IJoldso: 23> Network Interface and Device Certificates:



Network Interface for Incoming VPN Access

Select or create an Interface Group or a Security Zone that contains the network interfaces users
will access for VPN connections.

Interface group/Security Zone:* | Outsied v | +

Enable DTLS on member interfaces

A All the devices must have interfaces as part of the Interface Group/Security Zone selected.

Device Certificates

Device certificate (also called Identity certificate) identifies the VPN gateway to the remote access
clients. Select a certificate which is used to authenticate the VPN gateway.

Certificate Enrollment:* vpntestbed.cisco.com v | +

Access Control for VPN Traffic

All decrypted traffic in the VPN tunnel is subjected to the Access Control Policy by default. Select
this option to bypass decrypted traffic from the Access Control Policy.

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
This option bypasses the Access Control Policy inspection, but VPN filter ACL and
authorization ACL downloaded from AAA server are still applied to VPN traffic.

s ew odasu JJ yise wuvdd Loeser spdud 1Juy, Finish 90 & Deploy:
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Remote AnyConnect
User Client Device
%0
AAM

Remete Access VN Policy Configurstion Additional Configuration Requirements

Firepower Management Center will configure an RA VPN Policy with the following settings After the wizard completes, the following
configuration needs to be completed for VPN to

work on all device targets.

Name: Anyconnect_RA

Device Targets: FTD

Connection Profile:
Connection Alias:
AAA:
Authentication Method:
Authentication Server:
Authorization Server:
Accounting Server;
Address Assignment:
Address from AAA:
DHCP Servers:
Address Pools (IPvd):
Address Pools (IPv6):
Group Policy:
AnyConnect Images:
Interface Objects:

Device Certificates:

Anyconnect_RA

Anyconnect_RA

AAA Only
RadiusServer (RADIUS)
RadiusServer (RADIUS)

vpn_pool
DMGrpPolicy
Anyconnectmac4.10
Qutsied

vpntestbed.cisco.com

Device Identity Certificate Enrollment

Certificate enrollment object 'vpntestbed.cisco.com’ is not installed on one or more
targeted devices. Certificate installation will be initiated on the targeted devices on
finishing the wizard. Go to the Certificates page to check the status of the installation.

© Access Control Policy Update

An Access Control rule must be defined to allow
VPN traffic on all targeted devices.

© NAT Exemption

If MAT is enabled on the targeted devices, you
must define a NAT Policy to exempt VPN traffic.

@ DNS Configuration

To resolve hostname specified in AAA Servers
or CA Servers, configure DNS using FlexConfig
Policy on the targeted devices.

@ Port Configuration

SSL will be enabled on port 443.

IPsec-IKEv2 uses port 500 and Client Services
will be enabled on port 443 for Anyconnect
image download.NAT-Traversal will be enabled
by default and will use port 4500.

Please ensure that these ports are not used in
NAT Policy or other services before deploying
the configuration.

A Network Interface Configuration

Make sure to add interface from targeted
devices to SecurityZone object 'Outsied’
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Add Static Route Configuration 7

Type: @ IPvd () IPvB
Interface*
\ Nullo v \

(Interface starting with this icon [ signifies it is available for route leak)

Available Network . Selected Network

Q, Search ‘ Add ‘ objvpnusers ™
any-ipvd
FMC
GW

IPvd-Benchmark-Tests
IPvd-Link-Local

IPvd-Multicast

Gateway*

Metric:
1

(1 -254)

Tunneled: [ | (Used only for default Route)

Route Tracking:

- 08 3JY Yp wopdsu URPF gds 1Jglzes Idos wouwoes Bsol louoldle VPN. Jdeey) eds
o3l luew9J |Js Devices > Device Management > Edit > Interfaces > Edit > Advanced > Security Configuration >

Enable Anti Spoofing.



Edit Physical Interface

General IPwd IPv6 Path Monitoring Hardware Configuration Manager Access Advanced
I

Information ARP Security Configuration

Enable Anti Spoofing:
Allow Full Fragment Reassembly:

Override Default Fragment Setting:

‘ Cancel |m

s louold puwedsp sup wouse IJpuwl) 32 vo J3JI Idpuwegse Bs z29d [Jugesoe. leuwe
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FirePOWER.

v.,.-) o,od.,,sc, Sysopt connection permit-vpn 'a.,,sl )

B3Il dssd IUluosl; 6.2.3 19 |uosl, Tzae: Would ¢sh JJdsle w3dd wluwogsle 1deelde 1o

| .9J Devices > VPN > Remote Access > VPN Profile > Access Interfaces.

Access Control for VPN Traffic

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)

Decrypted traffic is subjected to Access Control Policy by default. This option

bypasses the inspection, but VPN Filter ACL and authorization ACL downloaded from

AAA server are still applied to VPN traffic.

- JJluosble od 6.2.3: e d |Js Objects > Object Management > FlexConfig > Text Object > Add Text Object.

Nouble pogs) Jliso vuo eds uwesd IJpald: vpnSysVar pxgd o9, w9Se6 sysopt.
- IJlue@ld |Js Objects> Object Management > FlexConfig > FlexConfig Object > Add FlexConfig Object.
- lowle FlexConfig Jlisy w9lgod ywlo, IJIgle, connection permit-vpn.

- lz pogs) Jlisu lduue WO FlexConfig Jlisy O 9lgos yulo, |Ji_9|,o_) ©& $vpnSysVar connection

permit-vpn. |9 Save:
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/content/en/us/td/docs/security/firepower/622/configuration/guide/fpmc-config-guide-v622/interfaces_for_firepower_threat_defense.html?bookSearch=true#task_34BB9AC8E91946AB847C65FB79D67A5F

Insert Text Object Variable

Varible Name: | vpnSysvar
Description: [

Available Objects & Selected Object

[ 4, Search [T vpnSysvar

S ———

[T tepMssBytes
[T tepMssMinimum
[T threat_cetection_statistics

[T vadan_wve_only

[T vdtan_Port_and_Nve
[T vtan_wini

[T weepPassword

- wlbus 9 FlexConfigdlisy, J Append 9wess> wuby |Js Everytime:

Edit FlexConfig Object ? %
Name: | connection_permit-vpn
Description:

Qunsert/> | | E | Deployment: Type:
SvpnSysVar connection permit-vpn
Variables E]
vpnSysvar SINGLE sysopt FREEFORM:vpn.. false

[ Save J[ Cancel J

- IJlgowld |JsDevices > FlexConfig 9og)s) [Juwog 1JzlJs i_9 louble wog 238> wluwwesle New
Policy .
- luols Wb 1U3s wp luublgo FlexConfig 109 999 Save.
- uuw IJodssy JJwj9sssysopt connection permit-vpnlJiro_) eds IJgols.
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lJeuveédesu. I sild spdud luwegsle glpd wuoss Juvwds VPN Ig §lises IJozde Vs
IJsue9d (ACL) IJsleds JJeussd Jouodss erds ey, ldpumweése.
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