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Preface

This preface contains the following sections:

 • Conventions

 • Related Documentation

 • Obtaining Documentation and Submitting a Service Request

Conventions
This guide uses the following conventions:

Note Means reader take note

Table 1 Conventions

Convention Indication

bold font Commands and keywords and user-entered text appear in bold font.

italic font Document titles, new or emphasized terms, and arguments for which you supply 
values are in italic font.

[ ] Elements in square brackets are optional.

{x | y | z} Required alternative keywords are grouped in braced and separated by vertical 
bars.

[x | y | z} Optional alternative keywords are grouped in braced and separated by vertical 
bars.

string A nonquoted set of characters. Do not use quotation marks around the string or 
the string will include the quotation marks.

courier font Terminal sessions and information the system displays appear in courier font

<> Nonprinting characters such as passwords are in angle brackets.

[ ] Default responses to system prompts are in square brackets.

!, # An exclamation point (!) or a pound sign (#) at the beginning of a line of code 
indicates a comment line.
vii
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Chapter 
Tip Means the following information will help you solve a problem.

Caution Means reader be careful. In this situation, you might do something that can result in equipment damage 
or loss of data.

Warning This warning symbol means danger. You are in a situation that could cause bodily injury. Before you 
work on any equipment, be aware of the hazards involved with electrical circuitry and be familiar with 
standard practices for preventing accidents. (To see translations of the warnings that appear in this 
publication, refer to the appendix "Translated Safety Warnings.")

Related Documentation
See the Cisco 3310 Mobility Services Engine Getting Started Guide or Cisco 3350 Mobility Services 
Engine Getting Started Guide for mobility services engine installation and setup information.

These documents are available on Cisco.com at the following URL:

http://www.cisco.com/en/US/products/ps9742/tsd_products_support_install_and_upgrade.html

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional 
information, see the monthly What’s New in Cisco Product Documentation, that also lists all new and 
revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as an RSS feed and set content to be 
delivered directly to your desktop using a reader application. The RSS feeds are a free service. Cisco currently 
supports RSS Version 2.0.
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Overview

This chapter describes the role of Location Analytics service that is supported on the Cisco mobility 
services engine (MSE).

This chapter contains the following sections:

 • About the Location Analytics Service, page 1-1

 • Location Analytics Service Within a Cisco Unified Wireless Network, page 1-2

 • Getting Information on Your Network, page 1-3

About the Location Analytics Service
The Advanced Location services includes the recently acquired ThinkSmart Technology Software, 
which has been integrated into the mobility services engine. The location analytics is a system that 
provides a set of data analytic tools packaged for analyzing Wi-Fi device location data that comes from 
the MSE.

The Location Analytics analyzes wireless device location information in a particular network and 
provides analytic information for historical trends and patterns. The Location Analytics service uses the 
data provided by MSE to calculate the location of wireless devices in the WLAN. This enables greater 
visibility into customer movements and behavior across the building throughout the day. The location 
analytics determine device parameters such as dwell time, crowding, path choice, and aggregate these 
for common understanding.

Business can better understand how their customers interact with different parts of their building or 
environment. The benefits to the venue owners are as follows:

 • Analyze business performance through measuring in-venue actions and improve marketing.

 • Helps document customers movement throughout the building

 • Increase customer satisfaction through sufficient staffing during peak times.

This allows for better facility planning, measurement of changes to the building, and business interaction 
with customers.
1-1
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  Location Analytics Service Within a Cisco Unified Wireless Network
Location Analytics Service Within a Cisco Unified Wireless 
Network

Cisco Unified Wireless Network Solution ensures that your business achieves the highest level of 
network security and versatility. Cisco UWN solution empowers your network with the ability to offer 
secure wireless networking, either within your office for increased mobility or bridging between your 
office buildings. The following are the components of CUWN:

 • Access Points—The Access point is the end point on the network side that provides the wireless 
access.

 • Wireless LAN Controllers—The controller actively manages these APs w.r.t what channel it 
operates, how does the client gets attach to it, what security types are supported and so on.

 • Prime Infrastructure—Prime Infrastructure is a web based application used to configure and manage 
controllers and associated APs. Prime Infrastructure provides a centralized management.

 • Mobility Services Engine—MSE is an open platform that [provides a new approach for delivery of 
the mobility services and applications. The MSE is managed by the Prime Infrastructure and 
supports various services.

The following figure shows the overall architecture within which the Location Analytics system fits. The 
Location Analytics service contains the following components:

 • Analysis

 • Reporting

 • Administration
1-2
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Figure 1-1 Location Analytics Architecture

Getting Information on Your Network
The process of downloading and creating a database of devices or path information is automatic. If the 
installation is new, then the collection of data starts immediately and continues to download increments 
of data every 15 minutes. If you are upgrading to an existing MSE that has been collecting data, then the 
system downloads the previous 3 days data before continuing every 15 minutes. The analytics is 
available immediately when the data is in the database.
1-3
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Getting Started

This chapter provides information on prerequisites, system requirements, and enabling the Cisco 
Location Analytics service.

This chapter contains the following sections:

 • Prerequisites for Enabling Location Analytics Service, page 2-1

 • WebGL Requirements, page 2-26

 • Logging into Location Analytics User Interface, page 2-25

Prerequisites for Enabling Location Analytics Service
 • The location analytics system takes input from the MSE. The location analytics is installed as part 

of the MSE installation but you must select Location Analytics service explicitly from the list of 
available services within the Prime Infrastructure UI. For details on enabling location analytics 
service, see the “Enabling Location Analytics Service on the Mobility Services Engine” section on 
page 2-17.

 • If you want to use data from specific parts of your network, then you must edit the 
mse.properties 

(.opt/mse/analytics/intellify/tools/MSEclient/mse.properties) file in order to 
select either network, building, or floor that you want to analyze. Keep these guidelines in mind 
when editing the mse.properties file. 

 – Network, building, or floors—By default, the analytics takes all the data that is available in the 
MSE. These three settings allow you to download only a subset. For example, if you have three 
building B1, B2, and B3 in network N and you want to run analytics only on building B1 and 
building B2, then you need to specify as buildings=N>B1,N>B2.

 – max-history—By default, when the analytics becomes active for the first time, it searches for 
the previous three days data in the MSE history file and tries to fetch data if there is any. In case 
there is more data available and you want to retrieve, you need to set this to a different value. 
You can set it to nnnD, and it retrieves nnn days, or nnnW to retrieve nnn weeks.

Note In order for the Location Analytics to access data from the MSE, you must set the history 
parameters on the MSE. For more information, see the Configuring MSE Tracking and History 
Parameters, page 2-9.

 – All settings (including the above said) are documented in the properties file.
2-1
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 • Location analytics requires both floor plans and coverage areas defined in the Prime Infrastructure 
UI in order for the location analytics visualization and reporting to function. You need to provide 
floor numbers for each floor plan. Floors on the same level should have the same number and floors 
above should have a higher number. The choice of coverage areas correspond to the zones which 
you want to report on. If you want to know the details of location A, then an area defining that 
location should be made available in the Prime Infrastructure. See the “Adding Floor Areas” section 
on page 2-18 and “Defining Coverage Area” section on page 2-23 for more information.

 • You must define at least three GPS markers in the Prime Infrastructure UI. This is necessary to 
provide the latitude/longitude values that is necessary for the 2D view in Open Street Maps.

 • You need three APs to get any location information on the device.

This section contains the following topics:

 • Prime Infrastructure Delivery Modes, page 2-2

 • Reinstalling Prime Infrastructure on a Physical Appliance, page 2-4

 • Deploying Prime Infrastructure Virtual Appliance, page 2-5

 • Setting Up Prime Infrastructure, page 2-6

 • Starting Prime Infrastructure Server, page 2-6

 • Logging into Prime Infrastructure User Interface, page 2-6

 • Applying Prime Infrastructure Software License, page 2-6

 • Adding a Mobility Services Engine to the Prime Infrastructure, page 2-7

 • Adding Floor Areas, page 2-18

 • Defining Coverage Area, page 2-23

 • Monitoring Geo-Location, page 2-23

 • Enabling Location Analytics Service on the Mobility Services Engine, page 2-17.

Prime Infrastructure Delivery Modes
Prime Infrastructure comes preinstalled on a physical appliance with various performance 
characteristics. Prime Infrastructure software runs on either a dedicated Prime Infrastructure appliance 
or on a VMware server. Prime Infrastructure software image does not support the installation of any 
other packages or applications on this dedicated platform. The inherent scalability of Prime 
Infrastructure allows you to add appliances to a deployment and increase performance and resiliency.

Prime Infrastructure is delivered in two modes, the physical appliance and the virtual appliance. This 
section contains the following topics:

 • Physical Appliance, page 2-2

 • Virtual Appliance, page 2-3

Physical Appliance
The physical appliance is a dual Intel 2.40 GHz Xeon E5620 quad core processor, with 16 GB RAM, 
and four hard drives running in a RAID level 5 configuration. The physical appliance runs the latest 
64-bit Red Hat Linux Operating System.
2-2
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The physical appliance supports up to 15000 Cisco Aironet lightweight access points, 5000 standalone 
access points, 5000 switches and 1200 Cisco wireless LAN controllers.

Note To receive the expected results with the Prime Infrastructure, you need a high performance 
physical appliance with built-in redundancy for hard disks, power supplies and internal cooling 
fans.

For more information on the physical appliance, see the Cisco Prime Infrastructure Getting Started 
Guide, Release 1.0.

Virtual Appliance
Prime Infrastructure is also offered as a virtual appliance to help support lower level deployments. Prime 
Infrastructure can be run on a workstation or a server and access points can be distributed unevenly 
across controllers.

Prime Infrastructure virtual appliance software is distributed as an Open Virtualization Archive (OVA) 
file. There are three recommended levels of Prime Infrastructure distribution with different resources 
and numbers of devices supported. 

This section contains the following topics:

 • Virtual Appliance for Large Deployment, page 2-3

 • Virtual Appliance for Medium Deployment, page 2-4

 • Virtual Appliance for Small Deployment, page 2-4

Note You can deploy the OVA file directly from the vSphere Client; you do not need to extract the 
archive before performing the deployment. 

You can install the Prime Infrastructure virtual appliance using any of the methods for deploying an OVF 
supported by the VMware environment. Before starting, make sure that Prime Infrastructure virtual 
appliance distribution archive is in a location that is accessible to the computer on which you are running 
the vSphere Client. 

Note For more information about setting up your VMware environment, see the VMware vSphere 4.0 
documentation.

Virtual Appliance for Large Deployment

 • Supports up to 15000 Cisco Aironet lightweight access points, 5000 standalone access points, 5000 
switches, and 1200 Cisco wireless LAN controllers.

 • 16 Processors at 2.93 GHz or better.

 • 16-GB RAM.

 • 300 GB minimum free disk space is required on your hard drive.
2-3
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Note The free disk space listed is a minimum requirement but might be different for your system 
depending on the number of backups performed.

Virtual Appliance for Medium Deployment

 • Supports up to 7500 Cisco Aironet lightweight access points, 2500 standalone access points, 2500 
switches, and 600 Cisco wireless LAN controllers.

 • 8 Processors at 2.93 GHz or better.

 • 12-GB RAM.

 • 300 GB minimum free disk space is required on your hard drive.

Virtual Appliance for Small Deployment

 • Supports up to 3000 Cisco Aironet lightweight access points, 1000 standalone access points, 1000 
switches, and 240 Cisco wireless LAN controllers.

 • 4 Processors at 2.93 GHz or better.

 • 8-GB RAM.

 • 200 GB minimum free disk space is required on your hard drive.

Note For all server levels, AMD processors equivalent to the listed Intel processors are also supported.

Note The free disk space listed is a minimum requirement, but several variables (such as backups) 
impact the disk space.

For information about the system and client requirements, and prerequisites, see the “Pre-installation 
tasks” section in the Cisco Prime Infrastructure 2.0 Quick Start Guide.

Reinstalling Prime Infrastructure on a Physical Appliance
You must have root privileges to install Prime Infrastructure on a physical appliance.

To reinstall Prime Infrastructure on a physical appliance, follow these steps:

Step 1 Insert the provided Prime Infrastructure software Image DVD. The system boots up and the following 
console appears:

ISOLINUX 3.11 2005-09-02  Copyright (C) 1994-2005 H. Peter Anvin

           Welcome to Cisco Prime Infrastructure

To boot from hard disk, press <Enter>.

Available boot options:

  [1] Prime Infrastructure Installation (Keyboard/Monitor)
  [2] Prime Infrastructure Installation (Serial Console)
2-4
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  [3] Recover administrator password. (Keyboard/Monitor)
  [4] Recover administrator password. (Serial Console)
  <Enter> Boot existing OS from Hard Disk.

Enter boot option and press <return>.

boot:

Step 2 Select option 1 to reinstall Prime Infrastructure software image. The system reboots and the configure 
appliance screen appears.

Step 3 Enter the initial setup parameters and the system reboots again. Remove the DVD and follow the steps 
to start the Prime Infrastructure server.

Deploying Prime Infrastructure Virtual Appliance
This section describes how to deploy the Prime Infrastructure virtual appliance from the VMware 
vSphere Client using the Deploy OVF Wizard or from the command line. (VMware vSphere Client is a 
Windows application for managing and configuring the vCenter Server.) This section contains the 
following topics:

 • Deploying Prime Infrastructure Virtual Appliance from the VMware vSphere Client, page 2-5

 • Deploying Prime Infrastructure Virtual Appliance using the Command Line Client, page 2-5 

Deploying Prime Infrastructure Virtual Appliance from the VMware vSphere 
Client

Prime Infrastructure Virtual Image is packaged as an OVF file. An OVF is a collection of items in a 
single archive. In the vSphere Client, you can use the Deploy OVF Wizard to create a virtual machine, 
running the Prime Infrastructure virtual appliance application.

For detailed instructions on how to deploy the Prime Infrastructure virtual appliance using the Deploy 
OVF Wizard, see the “Deploying the OVA” section in the Cisco Prime Infrastructure 2.0 Quick Start 
Guide.

Deploying Prime Infrastructure Virtual Appliance using the Command Line 
Client

This section describes how to deploy Prime Infrastructure virtual appliance from the command line. As 
an alternative to using the vSphere Client to deploy Prime Infrastructure OVA distribution, you can use 
the VMware OVF Tool, which is a command-line client.

To deploy an OVA with the VMware OVF Tool, use the ovftool command, which takes the name of the 
OVA file to be deployed and the target location as arguments, as in the following example:

ovftool Prime Infrastructure-VA-X.X.X-large.ova vi://my.vmware-host.example.com/ 

In this case, the OVA file to be deployed is Prime Infrastructure-VA-X.X.X-large.ova and the target ESX 
host is my.vmware-host.example.com. For complete documentation on the VMware OVF Tool, see the 
VMware vSphere 4.0 documentation.
2-5
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Setting Up Prime Infrastructure
This section describes how to configure the initial settings of Prime Infrastructure virtual appliance. 

Note These steps need to be performed only once, upon first installation of Prime Infrastructure 
virtual appliance.

For detailed instructions on how to configure the basic network and login settings for Prime 
Infrastructure virtual appliance system, see the “Installing the Server” section in the Cisco Prime 
Infrastructure 2.0 Quick Start Guide. When the steps are completed, Prime Infrastructure virtual 
appliance is accessible over the network. 

Starting Prime Infrastructure Server
This section provides instructions for starting Prime Infrastructure on either a physical or virtual 
appliance.

To start Prime Infrastructure when it is installed on a physical or virtual appliance, follow these steps:

Step 1 Log into the system as administrator.

Step 2 Using the command-line interface, enter the following command:

ncs start

Logging into Prime Infrastructure User Interface
To log into Prime Infrastructure user interface through a web browser, see the detailed instructions 
provided in the “Logging into the Prime Infrastructure User Interface” section of the Cisco Prime 
Infrastructure 2.0 Quick Start Guide.

Applying Prime Infrastructure Software License
This section describes how to apply a license to Prime Infrastructure. Before starting, make sure that you 
have already acquired the license from the Cisco License Center and put it in a location that is accessible 
by the network from Prime Infrastructure. To add a new Prime Infrastructure license file, follow these 
steps:

Step 1 In the Administrator menu, choose License Center > Files > Prime Infrastructure Files page, and 
click Add.

Step 2 In the Add a License File dialog box, enter or browse to the applicable license file.

Step 3 Once displayed in the License File text box, click Upload.
2-6
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To add a new license, see the “Managing Licenses” section in the Cisco Prime Infrastructure 2.0 
Administrator Guide.

For more information about the licensing requirements, see the “About Cisco Prime Infrastructure 
Licensing” section in the Cisco Prime Infrastructure 2.0 Quick Start Guide.

Adding a Mobility Services Engine to the Prime Infrastructure
You can add MSE using the Add Mobility Services Engine dialog box in the Mobility Service page. In 
this dialog box, you can add licensing files, tracking parameters, and assign maps to MSE. If you launch 
the wizard with an existing MSE for configuration, then the Add MSE option appears as Edit MSE 
Details.

Tip To learn more about Cisco Adaptive wIPS features and functionality, go to Cisco.com to watch a 
multimedia presentation. Here you can find the learning modules for a variety of Prime Infrastructure 
topics. Over future releases, there will be more overview and technical presentations to enhance your 
learning.

Note The Prime Infrastructure Release 1.0 recognizes and supports MSE 3355 appropriately.

To add a mobility services engine to the Prime Infrastructure, log into the Prime Infrastructure and 
follow these steps:

Step 1 Verify that you can ping the mobility services engine.

Step 2 Choose Services > Mobility Services to display the Mobility Services page.

Step 3 From the Select a command drop-down list, choose Add Mobility Services Engine. Click Go.

Step 4 In the Device Name text box, enter a name for the mobility services engine.

Step 5 In the IP Address text box, enter the IP address of the mobility services engine.

Step 6 (Optional) In the Contact Name text box, enter the name of the mobility services engine administrator.

Step 7 In the User Name and Password text boxes, enter the username and password for the mobility services 
engine.

This refers to the Prime Infrastructure communication username and password created during the setup 
process.

If you have not specified the username and password during the setup process, use the defaults.

The default username and password are both admin.

Note If you changed the username and password during the automatic installation script, enter those 
values here. If you did not change the default passwords, we recommend that you rerun the 
automatic installation script and change the username and password.

Step 8 Select the HTTP check box to allow communication between the mobility services engine and 
third-party applications. By default, the Prime Infrastructure uses HTTPs to communicate with MSE.
2-7
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Step 9 Select the Delete synchronized service assignments check box if you want to permanently remove all 
service assignments from the mobility services engine. 

This option is applicable for network designs, wired switches, controllers and event definitions. The 
existing location history data is retained, however, you must use manual service assignments to perform 
any future location calculations. 

Step 10 Click Next. The Prime Infrastructure automatically synchronizes the selected elements with the MSE.

After the synchronization, the MSE License Summary page appears. You can use the MSE License 
Summary page to install a license, add a license, remove a license, install an activation license, and 
install service license.The Select Mobility Service page appears.

Note After adding a new mobility services engine, you can synchronize network designs (campus, 
building, and outdoor maps), controllers, switches (Catalyst Series 3000 only), and event groups 
on the local mobility services engine using the Prime Infrastructure. You can perform this 
synchronization immediately after adding a new mobility services engine or at a later time. To 
synchronize the local and the Prime Infrastructure databases, see the Information About 
Synchronizing the Prime Infrastructure and Mobility Services Engines, page 2-10.

Enabling Services on the Mobility Services Engine

To enable services on the mobility services engine, follow these steps:

Step 1 After adding the license file, the Select Mobility Service page appears.

Step 2 To enable a service on the mobility services engine, select the check box next to the service. The different 
type of services are as follows:

 • Context Aware Service—If you select the Context Aware Service check box, then you must select a 
location engine to perform location calculation. You can choose CAS to track clients, rogues, 
interferers, and tags. You can choose either of the following engines to track tags:

 – Cisco Context-Aware Engine for Clients and Tags

 – Partner Tag Engine

Note By default, the Context Aware Service check box and Cisco Context-Aware Engine for 
Clients and Tags radio button are enabled.

 • Wireless Intrusion Prevention System—If you select the Wireless Intrusion Prevention System 
check box, it detects wireless and performance threats.

 • MSAP Service—If you select the MSAP Service check box, it provides service advertisements that 
describe the available services for the mobile devices.

Note With MSE 6.0 and later, you can enable multiple services (CAS and wIPS) simultaneously. 
Before Version 6.0, mobility services engines only supported one active service at a time.

Step 3 Click Next to configure the tracking and history parameters.
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Configuring MSE Tracking and History Parameters

Step 1 After you enable services on the mobility services engine, the Select Tracking & History Parameters 
page appears.

Note If you skip configuring the tracking parameters, the default values are selected.

Step 2 You can select the clients that you want to keep track of by selecting the corresponding Tracking check 
box(es). The various tracking parameters are as follows:

 • Wired Clients

 • Wireless Clients

 • Rogue Access Points

 – Exclude Adhoc Rogue APs

 • Rogue Clients

 • Interferers

 • Active RFID Tags

Step 3 You can enable the history tracking of devices by selecting the corresponding devices check box(es). The 
different history parameters are as follows:

 • Wired Stations

 • Client Stations

 • Rogue Access Points

 • Rogue Clients

 • Interferers

 • Asset Tags

Step 4 Click Next to Assign Maps to the MSE.

Assigning Maps to the MSE

Note The Assigning Maps page is available only if you select CAS as one of the services to be enabled on the 
MSE.

Step 1 Once you configure MSE tracking and history parameters, the Assigning Maps page appears.

The Assign Maps page shows the following information:

 • Map Name

 • Type (building, floor, campus)

 • Status

Step 2 You can see the required map type by selecting All, Campus, Building, Floor Area, or Outdoor Area from 
the Filter option available on the page.

Step 3 To synchronize a map, select the Name check box and click Synchronize.
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Upon synchronization of the network designs, the appropriate controllers that have APs assigned on a 
particular network design are synchronized with the MSE automatically. Click Done to save the MSE 
settings.

Information About Synchronizing the Prime Infrastructure and 
Mobility Services Engines

This section describes how to synchronize the Prime Infrastructure and mobility services engines 
manually and automatically.

Note The Services > Synchronize Services page is available only in the virtual domain in Release 7.3.101.0.

After adding a mobility services engine to the Prime Infrastructure, you can synchronize network 
designs (campus, building, floor, and outdoor maps), controllers (name and IP address), specific Catalyst 
3000 series and 4000 series switches, and event groups with the mobility services engine.

 • Network Design—A logical mapping of the physical placement of access points throughout 
facilities. A hierarchy of a single campus, the buildings that comprise that campus, and the floors of 
each building constitute a single network design. 

 • Controller—A selected controller that is associated and regularly exchanges location information 
with a mobility services engine. Regular synchronization ensures location accuracy.

 • Wired Switches—Wired Catalyst switches that provide an interface to wired clients on the network. 
Regular synchronization ensures that location tracking of wired clients in the network is accurate.

 – The mobility services engine can be synchronized with Catalyst stackable switches (3750, 
3750-E, 3560, 2960, IE-3000 switches), switch blades (3110, 3120, 3130, 3040, 3030, 3020), 
and switch ports. 

 – The mobility services engine can also be synchronized with the following Catalyst 4000 series 
switches: WS-C4948, WS-C4948-10GE, ME-4924-10GE, WS-4928-10GE, WS-C4900M, 
WS-X4515, WS-X4516, WS-X4013+, WS-X4013+TS, WS-X4516-10GE, WS-X4013+10GE, 
WS-X45-SUP6-E, and WS-X45-SUP6-LE.

 • Event Groups—A group of predefined events that define triggers that generate an event. Regular 
synchronization ensures that the latest defined events are tracked. Event groups can also be created 
by third-party applications. For more information on third-party application created event groups, 
see the “Configuring Automatic Database Synchronization and Out-of-Sync Alerts” section on 
page 2-14.

 • Third Party Elements—When you synchronize elements with MSE, there might be event groups on 
the MSE that have been created by third-party applications. You can either delete the unused 
elements or mark them as third-party elements.

 • Service Advertisements—MSAP provides service advertisements on mobile devices. This shows the 
service advertisement that is synchronized with the MSE.
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Prerequisites for Synchronizing the Mobility Services Engine
 • Be sure to verify software compatibility between the controller, Prime Infrastructure, and the 

mobility services engine before synchronizing. See the latest mobility services engine release notes 
at the following URL: 
http://www.cisco.com/en/US/products/ps9742/tsd_products_support_series_home.html

 • Communication between the mobility services engine, Prime Infrastructure, and the controller is in 
Coordinated Universal Time (UTC). Configuring NTP on each system provides devices with UTC 
time. The mobility services engine and its associated controllers must be mapped to the same NTP 
server and the same Prime Infrastructure server. An NTP server is required to automatically 
synchronize time between the controller, Prime Infrastructure, and the mobility services engine. 
However, the timezone for MSE should still be set to UTC. This is because wIPS alarms require that 
the MSE time be set to UTC.

Working with Third-Party Elements
When you synchronize elements with MSE, there might be event groups on the MSE that have been 
created by third-party applications. You can either delete the unused elements or mark them as 
third-party elements.

Deleting Elements or Marking Them as Third-Party Elements
To delete elements or mark them as third-party elements, follow these steps:

Step 1 Choose Services > Synchronize Services.

The Network Designs page appears.

Step 2 In the Network Designs page, choose Third Party Elements from the left sidebar menu.

The Third Party Elements page appears.

Step 3 Select one or more elements.

Step 4 Click one of the following buttons:

 • Delete Event Groups—Deletes the selected event groups.

 • Mark as 3rd Party Event Group(s)—Marks the selected event groups as third-party event groups.

Synchronizing Controllers with a Mobility Services Engine
This section describes how to synchronize a controller, assign an MSE to any wireless controller and 
also to unassign a network design, controller, wired switch, or event group from a mobility services 
engine.
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Synchronizing a Controller, Catalyst Switch, or Event Group
To synchronize network designs, a controller, a Catalyst switch, or event group with the mobility 
services engine, follow these steps:

Step 1 Choose Services > Synchronize Services.

The left sidebar menu contains the following options: Network Designs, Controllers, Event Groups, 
Wired Switches, Third Party Elements, and Service Advertisements. 

Step 2 From the left sidebar menu, choose the appropriate menu options.

Step 3 To assign a network design to a mobility services engine, in the Synchronize Services page, choose 
Network Designs from the left sidebar menu. 

The Network Designs page appears.

Step 4 Select all the maps to be synchronized with the mobility services engine by selecting the corresponding 
Name check box.

Note Through Release 6.0, you can assign only up to a campus level to a mobility services engine. 
Starting with Release 7.0 this option is granular to a floor level. For example, you can choose to 
assign floor1 to MSE 1, floor2 to MSE 2, and floor3 to MSE 3.

Step 5 Click Change MSE Assignment.

Step 6 Select the mobility services engine to which the maps are to be synchronized.

Step 7 Click either of the following in the MSE Assignment dialog box:

 • Save—Saves the mobility services engine assignment. The following message appears in the 
Messages column of the Network Designs page with a yellow arrow icon:

“To be assigned - Please synchronize.”

 • Cancel—Discards the changes to the mobility services engine assignment and returns to the 
Network Designs page.

You can also click Reset to undo the mobility services engine assignments.

Note A network design may include a floor in a campus or a large campus with several buildings, 
each monitored by a different mobility services engine. Because of this, you may need to 
assign a single network design to multiple mobility services engines.

Note Network design assignments also automatically picks up the corresponding controller for 
synchronization.

Step 8 Click Synchronize to update the mobility services engine(s) database(s).

When items are synchronized, a green two-arrow icon appears in the Sync. Status column for each 
synchronized entry.
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You can use the same procedure to assign wired switches or event groups to a mobility services engine. 
To assign a controller to a mobility services engine, see “Synchronizing Controllers with a Mobility 
Services Engine” section on page 2-11 for more information.

Assigning an MSE to the Controller
To assign a mobility services engine with any wireless controller on a per-service basis (CAS or wIPS), 
follow these steps:

Step 1 Choose Services > Synchronize Services.

Step 2 In the Network Designs page, choose Controller from the left sidebar menu.

Step 3 Select the controllers to be assigned to the mobility services engine by selecting the corresponding Name 
check box.

Step 4 Click Change MSE Assignment.

Step 5 Choose the mobility services engine to which the controllers must be synchronized.

Step 6 Click either of the following in the Choose MSEs dialog box:

 • Save—Saves the mobility services engine assignment. The following message appears in the 
Messages column of the Controllers page with a yellow arrow icon:

“To be assigned - Please synchronize.”

 • Cancel—Discards the changes to mobility services engine assignment and returns to the Controllers 
page.

You can also click Reset to undo the mobility services engine assignments. 

Step 7 Click Synchronize to complete the synchronization process.

Step 8 Verify that the mobility services engine is communicating with each of the controllers for only the 
chosen service. This can be done by clicking the NMSP status link in the status page.

Note After Synchronizing a controller, verify that the timezone is set on the associated controller.

Note Controller names must be unique for synchronizing with a mobility services engine. If you have two 
controllers with the same name, only one is synchronized.

You can use the same procedure to assign Catalyst switches or event groups to a mobility services 
engine. 

Note A switch can only be synchronized with one mobility services engine. However, a mobility services 
engine can have many switches attached to it.
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Unassigning a Network Design, Controller, Wired Switch, or Event Group from 
the MSE

To unassign a network design, controller, wired switch, or event group from a mobility services engine, 
follow these steps:

Step 1 Choose Services > Synchronize Services.

Step 2 From the left sidebar menu, choose the appropriate menu options.

Step 3 Select one or more elements by selecting the Name check box, and click Change MSE Assignment. 
The Choose MSEs dialog box appears. 

Step 4 Unselect the mobility services engine if you do not want the elements to be associated with that mobility 
services engine by selecting either the CAS or wIPS check box.

Step 5 Click Save to save the assignment changes.

Step 6 Click Synchronize.

The Sync Status column appears blank.

Configuring Automatic Database Synchronization and  
Out-of-Sync Alerts

Manual synchronization of the Prime Infrastructure and mobility services engine databases is 
immediate. However, future deployment changes (such as changes to maps and access point positions) 
can yield incorrect location calculations and asset tracking until resynchronization.

To prevent out-of-sync conditions, use the Prime Infrastructure to carry out synchronization. This policy 
ensures that synchronization between the Prime Infrastructure and mobility services engine databases is 
triggered periodically and any related alarms are cleared.

Any change to one or more of any synchronized component is automatically synchronized with the 
mobility services engine. For example, if a floor with access points is synchronized with a particular 
mobility services engine and then one access point is moved to a new location on the same floor or 
another floor that is also synchronized with the mobility services engine, then the changed location of 
the access point is automatically communicated. 

To further ensure that the Prime Infrastructure and MSE are in sync, smart synchronization happens in 
the background. 

This section contains the following topics:

 • Configuring Automatic Database Synchronization, page 2-14

 • Smart Controller Assignment and Selection Scenarios, page 2-15

 • Out-of-Sync Alarms, page 2-16

Configuring Automatic Database Synchronization
To configure smart synchronization, follow these steps:
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Step 1 Choose Administration > Background Tasks.

Step 2 Select the Mobility Service Synchronization check box.

The Mobility Services Synchronization page appears.

Step 3 To set the mobility services engine to send out-of-sync alerts, select the Out of Sync Alerts Enabled 
check box.

Step 4 To enable smart synchronization, select the Smart Synchronization Enabled check box.

Note Smart synchronization does not apply to elements (network designs, controllers, or event 
groups) that have not yet been assigned to a mobility services engine. However, out-of-sync 
alarms are still generated for these unassigned elements. For smart synchronization to apply to 
these elements, you must manually assign them to a mobility services engine.

Note When a mobility services engine is added to an Prime Infrastructure, the data in the Prime 
Infrastructure is always treated as the primary copy that is synchronized with the mobility 
services engine. All synchronized network designs, controllers, event groups and wired switches 
that are present in the mobility services engine and not in the Prime Infrastructure are removed 
automatically from mobility services engine.

Step 5 Enter the time interval, in minutes, that the smart synchronization is to be performed.

By default, the smart-sync is enabled.

Step 6 Click Submit.

For Smart controller assignment and selection scenarios, see the “Smart Controller Assignment and 
Selection Scenarios” section on page 2-15.

Smart Controller Assignment and Selection Scenarios
Scenario 1

If a floor having at least one access point from a controller is chosen to be synchronized with the mobility 
services engine in the Network Designs menu of the Synchronize Services page, then the controller to 
which that access point is connected is automatically selected to be assigned to the mobility services 
engine for CAS service. 

Scenario 2

When at least one access point from a controller is placed on a floor that is synchronized with the 
mobility services engine, the controller to which the access point is connected is automatically assigned 
to the same mobility services engine for the CAS service.

Scenario 3

An access point is added to a floor and assigned to a mobility services engine. If that access point is 
moved from controller A to controller B, then controller B is automatically synchronized to the mobility 
services engine.

Scenario 4
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If all access points placed on a floor that is synchronized to the MSE are deleted, then that controller is 
automatically removed from the mobility services engine assignment or unsynchronized.

Out-of-Sync Alarms
Out-of-sync alarms are of the minor severity (yellow), and are raised in response to the following 
conditions:

 • Elements are modified in the Prime Infrastructure (the auto-sync policy pushes these elements)

 • Elements other than controllers exist in the mobility services engine database but not in the Prime 
Infrastructure

 • Elements are not assigned to any mobility services engine (the auto-sync policy does not apply)

Out-of-sync alarms are cleared when the following occurs:

 • The mobility services engine is deleted

Note When you delete a mobility services engine, the out-of-sync alarms for that system are also 
deleted. In addition, if you delete the last available mobility services engine, the alarm for 
the following event: “elements not assigned to any server” is deleted.

 • Elements are synchronized manually or automatically

 • User manually clears the alarms (although the alarms may reappear in the future when the scheduled 
task is next executed)

Viewing Mobility Services Engine Synchronization Status
You can use the Synchronize Services feature in the Prime Infrastructure to view the status of network 
design, controller, switch, and event group synchronization with a mobility services engine.

This section contains the following topics:

 • Viewing Mobility Services Engine Synchronization Status, page 2-16

 • Viewing Synchronization History, page 2-17

Viewing Mobility Services Engine Synchronization Status
To view the synchronization status, follow these steps:

Step 1 Choose Services > Synchronize Services.

Step 2 From the left sidebar menu, choose Network Designs, Controllers, Event Groups, Wired Switches, 
Third Party Elements, or Service Advertisements.

For each of the elements, the Sync. Status column shows the synchronization status. A green two-arrow 
icon indicates that its corresponding element is synchronized with the specified server such as a mobility 
services engine. A gray two-arrow icon with a red circle indicates that its corresponding item is not 
synchronized with a provided server.

The Message column shows the reason for failure if the elements are out of sync.
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You can also view the synchronization status at Monitor > Site Maps > System Campus > Building > 
Floor.

where Building is the building within the campus and Floor is a specific floor in that campus building.

The MSE Assignment option on the left sidebar menu shows which mobility services engine the floor is 
currently assigned to. You can also change the mobility services engine assignment in this page.

Viewing Synchronization History
You can view the synchronization history for the last 30 days for a mobility services engine. This is 
especially useful when automatic synchronization is enabled as alarms are automatically cleared. 
Synchronization history provides a summary of those cleared alarms.

To view synchronization history choose Services > Synchronization History. The Synchronization 
History page appears.

Table 2-1 describes the table column headings that appear in the Synchronization History page.

Click the column headings to sort the entries.

Enabling Location Analytics Service on the Mobility Services 
Engine

To enable Location Analytics service on the mobility services engine within the Prime Infrastructure UI, 
follow these steps:

Step 1 Choose Services > Mobility Services Engine.

Table 2-1 Synchronization History Page

Text Boxes Description

Timestamp The date and time at which the synchronization has happened.

Server The mobility services engine server.

Element Name The name of element that was synchronized.

Type The type of the element that was synchronized.

Sync Operation The sync operation that was performed. 

It can be an Update, Add, or Delete.

Generated By The method of synchronization.

It can be Manual or Automatic.

Status The status of the synchronization. It can be either Success or Failed.

Message Any additional message about the synchronization.
2-17
Cisco Location Analytics Service Configuration Guide

OL-28567-01



Chapter 2      Getting Started
  Adding Floor Areas
The Mobility Services Engines page appears.

Step 2 In the Mobility Services page, click the Device Name to configure its properties.

Step 3 To enable Location Analytics service on the mobility services engine, select the check box next to the 
Location Analytics Service.

Step 4 Click Save.

Step 5 Click Done to save the settings.

Adding Floor Areas
This section describes how to add floor plans to either a campus building or a standalone building in the 
Prime Infrastructure database.

This section contains the following topics:

 • “Adding Floor Areas to a Campus Building” section on page 2-18

 • “Adding Floor Plans to a Standalone Building” section on page 2-21

Adding Floor Areas to a Campus Building
After you add a building to a campus map, you can add individual floor plan and basement maps to the 
building.

Note Use the zoom controls at the top of the campus image to enlarge or decrease the size of the map 
view and to hide or show the map grid (which shows the map size in feet or meters).

To add a floor area to a campus building, follow these steps:

Step 1 Save your floor plan maps in .PNG, .JPG, ,JPEG, or .GIF format.

Note The maps can be of any size because Prime Infrastructure automatically resizes the maps to fit 
the workspace.

Note If there are problems converting the auto-cad file, an error message is displayed. The Prime 
Infrastructure uses a native image conversion library to convert auto-cad files into raster formats 
like .png. If the native library cannot be loaded, the Prime Infrastructure shows an “unable to 
convert the auto-cad file” message. If you receive this error, make sure all the required 
dependencies are met for the native library. To find any dependency problems, use ldd on Linux 
platforms. The following DLLs must be present under the /webnms/rfdlls Prime Infrastructure 
installation directory: LIBGFL254.DLL, MFC71.DLL, MSVCR71.DLL, and MSVCP71.DLL. 
If dependency problems occurs, you have to install the required libraries and restart Prime 
Infrastructure.
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Note The floor map image is enhanced for zooming and panning. The floor image is not visible 
completely until this operation is complete. You can zoom in and out to view the complete map 
image. For example, if you have a high resolution image (near 181 megapixels) whose size is 
approximately 60 megabytes, it may take two minutes to appear on the map.

Step 2 Choose Monitor > Site Maps.

Step 3 From the Maps Tree View or the Monitor > Site Maps list, choose the applicable campus building to 
open the Building View page.

Step 4 Hover your mouse cursor over the name within an existing building rectangle to highlight it.

Note You can also access the building from the Campus View page. In the Campus View page, click 
the building name to open the Building View page.

Step 5 From the Select a command drop-down list, choose New Floor Area.

Step 6 Click Go. The New Floor Area page appears.

Step 7 In the New Floor Area page, follow these steps to add floors to a building in which to organize related 
floor plan maps:

a. Enter the floor area and contact names.

b. Choose the floor or basement number from the Floor drop-down list.

c. Choose the floor or basement type (RF Model).

d. Enter the floor-to-floor height in feet.

Note To change the unit of measurement (feet or meters), choose Monitor > Site Maps, and choose 
Properties from the Select a command drop-down list.

e. Select the Image or CAD File check box. 

f. Browse to and choose the desired floor or basement image or CAD filename, and click Open.

Note If you are importing a CAD file, use the Convert CAD File drop-down list to determine the 
image file for conversion.

Tip It is not recommended to use a .JPEG (.JPG) format for an auto-cad conversion. Unless a JPEG 
is specifically required, use .PNG or .GIF format for higher quality images.

g. Click Next. At this point, if a CAD file was specified, a default image preview is generated and 
loaded. 
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Note The Prime Infrastructure uses a native image conversion library to convert auto-cad files into 
raster formats like .PNG. When there are issues loading the native library, Prime 
Infrastructure shows the following error: "Unable to convert the auto-cad file. Reason: Error 
while loading the auto-cad image conversion library.” For more information see Prime 
Infrastructure online help or Prime Infrastructure documentation.

The names of the CAD file layers are listed with check boxes to the right side of the image indicating 
which are enabled.

Note When you choose the floor or basement image filename, the Prime Infrastructure shows the 
image in the building-sized grid.

Note The maps can be of any size because the Prime Infrastructure automatically resizes the maps 
to fit the workspace. 

Note The map must be saved in .PNG, .JPG, .JPEG, or .GIF format.

h. If you have CAD file layers, you can select or deselect as many as you want and click Preview to 
view an updated image. Click Next when you are ready to proceed with the selected layers. 

Enter the remaining parameters for the floor area.

i. Either leave the Maintain Aspect Ratio check box selected to preserve the original image aspect 
ratio or unselect the check box to change the image aspect ratio.

j. Enter an approximate floor or basement horizontal and vertical span (width and depth on the map) 
in feet.

Note The horizontal and vertical spans should be smaller than or the same size as the building 
horizontal and vertical spans in the Prime Infrastructure database.

k. If applicable, enter the horizontal position (distance from the corner of the outdoor area rectangle to 
the left edge of the campus map) and vertical position (distance from the corner of the outdoor area 
rectangle to the top edge of the campus map) in feet or meters.

Tip Use Ctrl-click to resize the image within the building-sized grid.

l. If desired, select the Launch Map Editor after floor creation check box to rescale the floor and 
draw walls.

m. Click OK to save this floor plan to the database. The floor is added to the Maps Tree View and the 
Design > Site Maps list.

Note Use different floor names in each building. If you are adding more than one building to the 
campus map, do not use a floor name that exists in another building. This overlap causes 
incorrect mapping information between a floor and a building.
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Step 8 Click any of the floor or basement images to view the floor plan or basement map. 

Note You can zoom in or out to view the map at different sizes and you can add access points.

Adding Floor Plans to a Standalone Building
After you have added a standalone building to the Prime Infrastructure database, you can add individual 
floor plan maps to the building. 

To add floor plans to a standalone building, follow these steps:

Step 1 Save your floor plan maps in .PNG, .JPG, or .GIF format.

Note The maps can be of any size because the Prime Infrastructure automatically resizes the maps to 
fit the workspace.

Step 2 Browse to and import the floor plan maps from anywhere in your file system. You can import CAD files 
in DXF or DWG formats or any of the formats you created in Step 1.

Note If there are problems converting the auto-cad file, an error message is displayed. the Prime 
Infrastructure uses a native image conversion library to convert auto-cad files into raster formats 
like .PNG. If the native library cannot be loaded, the Prime Infrastructure shows an “unable to 
convert the auto-cad file” message. If you receive this error, make sure all the required 
dependencies are met for the native library. To find any dependency problems, use ldd on Linux 
platforms. The following DLLs must be present under the /webnms/rfdlls the Prime 
Infrastructure installation directory: LIBGFL254.DLL, MFC71.DLL, MSVCR71.DLL, and 
MSVCP71.DLL. If dependency problems occurs, you must install the required libraries and 
restart the Prime Infrastructure.

Step 3 Choose Monitor > Site Maps. 

Step 4 From the Maps Tree View or the Design > Site Maps left sidebar menu, choose the desired building to 
display the Building View page. 

Step 5 From the Select a command drop-down list, choose New Floor Area.

Step 6 Click Go. 

Step 7 In the New Floor Area page, add the following information:

 • Enter the floor area and contact names.

 • Choose the floor or basement number from the Floor drop-down list.

 • Choose the floor or basement type (RF Model).

 • Enter the floor-to-floor height in feet.

 • Select the Image or CAD File check box. 

 • Browse to and choose the desired floor or basement Image or CAD file, and click Open.
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Note If you are importing a CAD file, use the Convert CAD File drop-down list to determine the image 
file for conversion.

Tip A .JPEG (.JPG) format is not recommended for an auto-cad conversion. Unless a .JPEG is 
specifically required, use a .PNG or .GIF format for higher quality images.

Step 8 Click Next. At this point, if a CAD file was specified, a default image preview is generated and loaded.

Note The Prime Infrastructure uses a native image conversion library to convert auto-cad files into 
raster formats like .PNG. When there are issues loading the native library, the Prime 
Infrastructure shows the following error: “Unable to convert the auto-cad file. Reason: Error 
while loading the auto-cad image conversion library. For more information, see the Prime 
Infrastructure online help or the Prime Infrastructure documentation”.

The names of the CAD file layers are listed with check boxes to the right side of the image indicating 
which are enabled.

Note When you choose the floor or basement image filename, the Prime Infrastructure shows the 
image in the building-sized grid.

Note The maps can be any size because the Prime Infrastructure automatically resizes the maps 
to fit the workspace.

Note The map must be saved in .PNG, .JPG, .JPEG, or .GIF format.

If you have CAD file layers, you can select or deselect as many as you want and click Preview to 
view an updated image. Click Next when you are ready to proceed with the selected layers. 

Step 9 Enter the remaining parameters for the floor area.

 • Either leave the Maintain Aspect Ratio check box selected to preserve the original image aspect 
ratio or unselect the check box to change the image aspect ratio.

 • Enter an approximate floor or basement horizontal and vertical span (width and depth on the map) 
in feet.

Note The horizontal and vertical spans should be smaller than or the same size as the building 
horizontal and vertical spans in the Prime Infrastructure Prime Infrastructure database.

 • If applicable, enter the horizontal position (distance from the corner of the outdoor area rectangle to 
the left edge of the campus map) and vertical position (distance from the corner of the outdoor area 
rectangle to the top edge of the campus map) in feet or meters.

Tip Use Ctrl-click to resize the image within the building-sized grid.
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 • Adjust the floor characteristics with the Prime Infrastructure map editor by selecting the check box 
next to Launch Map Editor. 

Step 10 Click OK to save this floor plan to the database. The floor is added to the Maps Tree View and the Design 
> Site Maps list.

Step 11 Click any of the floor or basement images to view the floor plan or basement map. 

You can zoom in or out to view the map at different sizes and you can add access points.

Defining Coverage Area
To draw a coverage area using the Prime Infrastructure UI, follow these steps:

Note You must add floor plan before drawing a coverage area.

Step 1 Add the floor plan if it is not already represented in the Prime Infrastructure.

Step 2 Choose Monitor > Site Maps.

Step 3 Click the Map Name that corresponds to the outdoor area, campus, building, or floor you want to edit.

Step 4 From the Select a command drop-down list, choose Map Editor, and click Go.

Step 5 It the Map Editor page, click the Draw Coverage Area icon on the toolbar.

A pop-up appears.

Step 6 Enter the name of the area that you are defining. Click OK.

A drawing tool appears.

Step 7 Move the drawing tool to the area you want to outline.

 • Click the left mouse button to begin and end drawing a line.

 • When you have completely outlined the area, double-click the left mouse button and the area is 
highlighted in the page.

The outlined area must be a closed object to appear highlighted on the map.

Step 8 Click the disk icon on the toolbar to save the newly drawn area.

Monitoring Geo-Location
The MSE provides physical location of wired clients, wired endpoints, switches, controllers, and access 
points present in a wireless network deployment. Currently, MSE provides location information in 
geo-location format to the external entities through northbound and southbound entities. 

To improve the accuracy of the geo-location information provided by MSE, this feature aims to 
transform the geometric location co-ordinates of a device to geo-location coordinates (latitude and 
longitude) and provides it to the external entities through northbound and southbound interfaces.
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Note At least three GPS markers are required for geo-location calculation. The maximum number of GPS 
markers that you can add is 20.

This section contains the following topics:

 • Adding a GPS Marker to a Floor Map, page 2-24

 • Editing a GPS Marker, page 2-24

 • Deleting a GPS Marker Present on a Floor, page 2-25

Adding a GPS Marker to a Floor Map
To add a GPS marker to a floor map, follow these steps:

Step 1 Choose Monitor > Site Maps to display the Maps page.

Step 2 Choose Campus Name > Building Name > Floor Name.

Step 3 Choose the Add/Edit GPS Markers Information menu option on the top left menu to open the 
Add/Edit GPS page.

A GPS Marker icon appears on the top left corner of the map (X=0 Y=0).

Step 4 You can drag the GPS Marker icon and place it in the desired location on the map or enter the X and Y 
position values in the GPS Marker Details table on the left sidebar menu to move the marker to the 
desired position.

Note If the markers added are too close, then the accuracy of geo-location information is less.

Step 5 Enter the Latitude and Longitude degrees for the selected GPS Marker icon in the left sidebar menu.

Step 6 Click Save.

The GPS Marker information is saved to the database.

Step 7 Click Apply to other Floors of Building to copy GPS markers on one floor of a building to all the 
remaining floors of that building.

Editing a GPS Marker
To edit a GPS marker present on the floor, follow these steps:

Step 1 Choose Monitor > Site Maps to display the Maps page.

Step 2 Choose the Campus Name > Building Name > Floor Name.

Step 3 Choose the Add/Edit GPS Markers Information menu option on the top left menu to open the 
Add/Edit GPS page.

Step 4 Select an existing GPS marker present on the floor.
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Step 5 From the left sidebar menu, you can change the Latitude, Longitude, X Position, and Y Position which 
is associated with the GPS marker.

Step 6 Click Save.

The modified GPS marker information is now saved to the database.

Deleting a GPS Marker Present on a Floor
To delete a GPS marker present on a floor, follow these steps:

Step 1 Choose Monitor > Site Maps to display the Maps page.

Step 2 Choose Campus Name > Building Name > Floor Name.

Step 3 Choose the Add/Edit GPS Markers Information menu option to open the Add/Edit GPS page.

Step 4 Select an existing GPS Marker which is present on the floor from the left sidebar menu.

Note You can delete multiple GPS markers present on a floor by selecting the Multiple GPS Markers 
check box.

Step 5 Click Delete GPS Marker.

Step 6 The selected GPS marker is deleted from the database.

Logging into Location Analytics User Interface
To log into Location Analytics user interface through a web browser, follow these steps:

Step 1 In the address line of browser, enter https://location-analytics-ip-address:8080/ui, where 
location-analytics-ip-address is the IP address of the Location Analytics server. Location Analytics user 
interface displays the User Login page.

Step 2 Enter your username.

Step 3 Enter your password.

Step 4 Click Login to log into Location Analytics. 

The Location Analytics home page appears.
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WebGL Requirements
The Location Analytics in Release 7.4 provides ability to view the analytic results in both 2D (Open 
Street Maps) and 3D (WebGL) environments. This provides improved understanding of results on 
multiple floor paths or when dwell times are calculated throughout a multi-storey building. The 3D 
environment presents the same information as the 2D environment. 

WebGL is an advanced feature that provides graphic capabilities. All browsers do not support WebGL 
on a particular hardware. Ensure to verify your browser compatibility at the following URL: 
http://get.webgl.org/. If your browser supports WebGL, then you must see a spinning cube. 

If your browser does not support WebGL, you must do the following:

 • Update your latest drivers for video card.

 • For Google Chrome, follow the instructions at the following URL: 
http://support.google.com/chrome/bin/answer.py?hl=en&answer=1220892

 • For Firefox, go to Help > Troubleshooting Information and scroll down to Graphics and WebGL 
Renderer. This indicates if your system supports WebGL and if not, it provides information on what 
is recommended.

Note If your system does not support 3D, then the analytic results are displayed only in 2D Open Street Maps 
view.

Internet Explorer 10 does not have the built-in support for WebGL and Microsoft has not announced any 
plans for implementing it in the future. WebGL support can be manually added to Internet Explorer using 
third-party plugins. For more information, see the http://www.iewebgl.com/
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Licensing Requirement for Location Analytics 
Service

Advanced Location service is introduced in Release 7.4 and it includes Location Analytics service and 
Mobile Concierge service. From Release 7.4, licensing is going to be AP based and not end point based. 
To accommodate this, new L-LS-licenses are introduced in this release. 

Cisco MSE 3355 supports up to 500 access points for Cisco MSE Location Services or Advanced 
Location Services. The Cisco MSE virtual appliance supports up to 1,000 access points, depending on 
the server resources.

There is no change to endpoint support and MSE 3355 supports 25,000 and high end virtual alliance 
supports 50000. All licenses are additive.
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Location Analytics Home Page Components

The Location Analytics user interface allows you to analyze the wireless devices location information 
using different analysis techniques.

Log into the Location Analytics user interface with your username and password. The following figure 
shows the Location Analytics User Login page.

Figure 4-1 Location Analytics User Login Page

After loggin in, the Location Analytics home page appears.
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Figure 4-2 Location Analytics Home Page

The Location Analytics home page contains the following:

 • Left Pane

 – 3D Analytics Tab, page 4-4

 – 2D Analytics, page 4-5

 – Reporting tab, page 4-5

 – Rules Group Box, page 4-2

 – Analysis Group Box, page 4-4

The blue color inverted triangle next to the top bar allows the Analysis control panel to be moved off 
screen, thus providing greater space for visualization.

 • Right Pane

 – Visualization Pane, page 4-5

 – Auxiliary Information Dashlet, page 4-6

Rules Group Box
The Rules group box allows you to identify the specific set of devices to which the analytics have to be 
applied. In order to describe the subset of this data, parameterized rule types have been created for the 
user to describe these devices. 

The Rules group box displays the following:

 • Date/Time—The date/time rule allows you to select a specific date (or range of dates) and/or a time 
period for which you want the analytics to be applied. Click on the black inverted triangle to 
configure Date/Time.

 • Zones

 • Filters

 • Path

 • Advanced Filters
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 • Date/Time—The Date/Time rule allows you to select a specific date or range of dates and time or 
range of time period for which you want the analytics to be applied. Click the black inverted triangle 
to configure Date/Time.

Note The date selector allows you to select only dates for which there exist data.

Select the Date checkbox to enable the Date and click the Date text box to open the Calendar and to 
perform the following:

 – Specific Date—Select this option if you want the analytics to be applied based on the specific 
date. 

 – All Dates Before—If you select this option, all dates before the selected date are considered for 
analysis.

 – All Dates After—If you select this option, all dates after the selected date are considered for 
analysis.

 – Date Range—If you select this option, the analytics will be applied between the selected Start 
Date and End Date.

 • Zones—Click the black inverted triangle to open the Restrict to Zones.

 – Restrict to Zones—Select the Restrict to Zones check box and choose one or multiple zones 
from the drop-down list to restrict your analysis to selected zones. If you are interested in 
analyzing only certain part of the building, then information about the selected part is displayed.

Note Zones are defined as coverage areas in the Prime Infrastructure.

 • Filters—Click the black inverted triangle to configure the following constraints on the points with 
different dwell time. This option allows you to select the data for analysis based on quantitative 
constraints on paths. 

You can select the following different quantitative constraints that you can use on paths from the 
Path Filters are:

 – Length—Length restricts the analysis to those paths within the sum of the straight line distances 
between the points.

 – Duration—Duration restricts the analysis to the total duration between the first and the last time 
points on the path.

 – Hops—Hops is the measure of the number of location observations made on that path.

 • Path—Click the black inverted triangle to open the Path window that allows you to select those 
devices that have followed a particular path through the predefined zones for analysis. The options 
are:

 – Starts In—Select the zone where the wireless device was first detected from the Starts In 
drop-down list.

 – Visits—Select the intermediate zone through which the device passes through from the Visits 
drop-down list.

 – Ends In—Select the zone where the device was last detected from the Ends In drop-down list.

 • Load a rule set—This option allows you to load the predefined rules. You can create a number of 
different rules and load them. A number of rules together constitute a ruleset. 

 • Save this rule set—After creating rules, you can save them and load the rule when you require them.
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 • These can also be saved as Rule Sets.

Analysis Group Box
The Analysis group box allows you to perform different analysis on devices that are passing through a 
building or environment. The Analysis group box displays the following:

 • Type—Select the type of analyses you can perform from the Type drop-down list.

 – Typical Locations—For more information on Typical Locations, see Typical Location Analysis, 
page 5-1

 – Typical Paths—For more information on Typical Paths, see Typical Path Analysis, page 5-3

 • Advanced—Click the black inverted triangle icon to configure the following:number of locations 
that you want to include in the analysis.

Note The Advanced option depends on the initial type of analysis that you have chosen. There is a 
different one for Typical paths.

A large number of locations will result in breakdown of the building into many areas.

 – Number of Locations—Enter the number of locations or paths that you want to include in the 
analysis. A large number of locations for Typical location analysis results in a dense 
concentration of markers across an area.

 – Building—Select the location from the Building drop-down list.

3D Analytics Tab
Location analytics provides the ability to view the analytic results in 3D environment. This provides an 
improved understanding of results, especially on multiple floor paths or when dwell times are calculated 
throughtour the multi-storey building. 

This section contains the 

 • Prerequisites for viewing Location Analytics in 3D, page 4-4

 • Viewing Analytics in the 3D Environment, page 4-4

Prerequisites for viewing Location Analytics in 3D

 • Location Analytics system must be installed and configured

 • Ensure that sufficient points or devices are present in the device or path database.

 • Floor plans are present in the MSE dabatabse through Prime Infrastructure.

 • Ensure that zones have been defined and overlays are suppiled.

Viewing Analytics in the 3D Environment

To view the analytics results in the 3D environment, follow these steps:
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Step 1 From the Rules Group box, you can set rule types to specify which devices have to be considered for 
analysis based on different rules parameters. For information on Rules parameters, see Rules Group Box, 
page 4-2.

Step 2 From the Analysis group box, you can perform different analysis on devices that are passing through a 
building or environment. To perform different analysis, see Typical Location Analysis, page 5-1 and 
Typical Path Analysis, page 5-3.

Step 3 Click Run.

Step 4 Click 3D Analytics to view the results in the 3D environment.

The results are displayed in the right pane.

Step 5 Click the Navigation buttons available in the Auxiliary Information window to see different overlays of 
the building and also different views of the floors. The 3D environment provides the ability to switch 
on/off floors.

2D Analytics
To view the analytics results in the 2D environment, follow these steps:

Step 1 From the Rules Group box, you can set rule types to specify which devices have to be considered for 
analysis based on different rules parameters. In order to set rules parameters, see Rules Group Box, 
page 4-2.

Step 2 From the Analysis group box, you can perform different analysis on devices that are passing through a 
building or environment. In order to perform different analysis, see Typical Location Analysis, page 5-1 
and Typical Path Analysis, page 5-3.

Step 3 Click Run.

Step 4 Click 2D Analytics to view the results in the 2D environment.

The result is displayed in the right pane.

Reporting tab
The location analytics reporting is necessary to monitor common behavioural patterns over time. A 
number of reports can be generated and provides more regular and task oriented set of information. The 
location analytics reports give deep analytic insight and provides a degree of flexibility in the types of 
reports that are generated. See the Reports, page 6-1 section for more information.

Visualization Pane
You can view the following in the visualization pane:

 • Analytics results of 2D or 3D environment.

 • Report results in the visulization pane.
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Auxiliary Information Dashlet
You can access the Auxiliary Information dashlet at the top right corner of the right page. The auxiliary 
information menu provides access to the 3D navigation and visible overlays on the building or area when 
you are in the 3D environment. Click icon in the right pane and choose the additional information on the 
building or area for analysis. You can include additional information like switching floors on/off, layout 
of access points, any point of interest, or the actual cluster area.
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Information About Analysis

This chapter describes the different types of analysis that you can perform on devices in a building or 
environment. You can perform the following two types of analysis:

 • “Typical Location Analysis” on page 1

 • “Typical Path Analysis” on page 3

Typical Location Analysis
The typical location analysis creates and analyzes different areas of the building and measures the 
movement of people within building. The location analysis is a way of segmenting all the points detected 
into representative areas on which parameters are calculated. 

The process starts by clustering mathematically all the devices into areas determined by the geographical 
layout of the observations. Each point is allocated to an area and each area is represented by a center 
point. Once the set of areas have been established, parameters associated with each area can be 
calculated which reflects the movement of people through that part of the building.

The results of carrying out a location analysis is a set of areas represented by center points indicating the 
spread of device parameters over the Wi-Fi detected area.

Areas and Zones

The concept of areas and zones are different but they work together. You need to consider the following:

 • A zone is a user defined space with a name and can be used for reporting or for path rule purposes.

 • Zones can be overlapping and need not cover all the building. 

 • Areas are defined by mathematical clustering on the observable Wi-Fi points. 

 • Cluster areas can be used when there are no known zones established or to ensure all parts of the 
location space are accounted for. 

 • Each area is associated with a set of behavior parameters that are represented by icons. 

There following are the different behavior measurements:

 • Dwell Time— Dwell time or wait time is an estimate of the time, a person is spending in an area as 
they move through the building. Dwell times are color coded as follows:

 – Yellow—Displays areas of low dwell time where people movement is fast.

 – Red—Displays areas of high dwell time where people movement is slow.
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 • Crowding— Crowding is measured by the density of people within a particular area over a time 
period. Crowding is a relative measure of crowding across all areas. It is derived from the number 
of observed devices in that area and a measure of the size of the area.

 • Number of devices passing—This indicates the number of unique MAC addresses identified in that 
area and is defined by your filtered conditions. The number of visits is also calculated. In case a 
device re-appear in the same area after an elapsed time, then it is counted as a second visit.

The following figure shows the number of device parameters in the same locations. 

Figure 5-1 Distribution of Number of Devices Across One Floor

The following figure shows the distribution of median dwell times in the 2D map.
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Figure 5-2 Distribution of Median Dwell Times

Typical Path Analysis
Typical paths analyses the behavior of devices or people as they move through the building. The typical 
path presents you with a set of paths taken and the parameters associated with them.This analysis is 
carried out through clustering, which aggregates the paths into sets which are equivalent. Each resulting 
set is represented by an actual path and shown graphically by a set of observed points linked by edges. 
The clustering allows you to identify the common routes that people usually take.

This section contains Analyzing areas of building using Typical Path analysis

Analyzing Areas of the Building Using the Typical Path Analysis
To analyze different areas if the building using the typical patha analysis, follow these steps:

Step 1 Do the following in the Analysis group box:

 • From the Type drop-down list, choose Typical Path.

 • Click the black inverted triangle icon to configure the number of locations or path that you want to 
include in the analysis.

 – In the Number of Locations text box, enter the number of locations or path.

 • From the Building drop-down list, select the building that you want to analyze.

Step 2 You can apply the parameterised rules to your analysis from the Rules group box. See Rules Group Box, 
page 4-2 for more information.

Step 3 Click Run.

Step 4 Click 3D Analytics to view the results in 3D environment or 2D to view the results in 2D environment.

The typical path presents you with a set of paths taken and the parameters associated with them in the 
right pane. The following figure shows the typical path across a shopping mall on a particular day and 
time in 3D. The observed points on the path are shown and lined with a straight line. 

The following figure shows the typical path across a shopping mall on a particular day and time in 2D.
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Figure 5-3 Typical Path Across One Floor in 2D Environment

The following figure shows typical path between floors

Figure 5-4 Typical Path Between Floors

Step 5 To obtain information associated with the parameter, click the node or use the location selector from the 
Auxiliary Information dashlet. The following figure shows the path parameters at Start Node.
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Figure 5-5 Path Parameters at Start Node

The below figure shows the path parameters at the intermediate node.

Figure 5-6 Path Parameters at Intermediate Node

The below figure shows the path parameters at the edge node.
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Figure 5-7 Path Parameters at Edge Node

The following information is displayed when you click on the node:

 • Number of paths in the cluster

 • Overall distance travelled

 • Number of point observations recorded along the path

 • Time took to complete the particular path

 • Average speed along the path (km/hr)

 • Date and time of the first and the last recorded point on the path

The following are the parameters for a particular point:

 • Arrival date and time

 • Zones located within

 • Any tags associated with this point

The following are the parameters displayed for a particular edge:

 • Crow- files distance between the two points it joins

 • Difference in time between two points

 • Estimated speed between the two points.
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Reports

The Location analytics reporting provides a more regular, manager-oriented set of information through 
the provision of parameterized templates to measure various common trends and patterns taking place 
over time in the building.This section describes the report templates provided and the parameters they 
take in order to tailor them to your and buildings requirements. The reports provided are:

 • Frequent Devices

 • Movement Between Zones

 • Daily Device Snapshot

 • Daily Devices and Dwell

Frequent Devices
The Frequent Devices report allows you to identify the top 10..100, etc devices in terms of number of 
times seen over a time period. The result shows frequently seen devices in the building. The result also 
provides the frequency distribution of those devices. 

See Configuring a frequent devices report for more information.

Configuring a Frequent Devices

To configure a frequent devices report, follow these steps:

Step 1 Click the Reporting tab from the left pane.

Step 2 From the Select Report Type drop-down list, choose Frequent Devices.

The following parameters are displayed:

 • In the Top Devices text box, enter the number of top devices that were frequently seen during a 
particular time and date in the building. For example, if you want to see top 10 devices during a 
particular time period, then enter 10 in the Top Devices text box.

 • From the Time drop-down list, choose the time period for which you want to generate the report. 
The results show the top N frequently seen devices in the building during the selected time. The 
possible options are: All day, Morning, Afternoon, Evening, Night, and explicit three hourly time 
periods.

 • From the Date from drop-down list, choose a start date. The report will show the frequently seen top 
N devices from the selected date onwards.
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 • From the Date to drop-down list, choose the end date. The report will show the frequently seen 
devices until the selected date.

Step 3 Click Run Report. 

The following example pdf report is displayed in the right pane.

The report displays the following:

 • A table showing how frequently a particular device was seen in the building.

 • Graph displaying the number of visits on the x-axis and no of devices on the y-axis.

Movement Between Zones
The movement between zones report allows you to identify a zone of interest. The report provides you 
with information on the number of devices seen moving to and away from that zone to/from other 
zones.This report is specified within a time period across a continuos set of days.

As a devices passes to/from the zone of interest, it may pass through multiple zones. Each zone it passes 
through is counted towards that zone movement total. Therefore, it is likely that devices are counted 
multiple times.

See configuring movement and flow between zones for more information.

Configuring Movement Between Zones

To configure a movement between zones report, follow these steps:
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Step 1 Click the Reporting tab from the left pane.

Step 2 From the Select Report Type drop-down list, choose Movement Between Zones.

The following parameters are displayed:

 • From the Time drop-down list, choose the time period for which you want to generate the report. 
The result shows movement between zones within the building during the selected time. The 
possible options are: All day, Morning, Afternoon, Evening, Night, and explicit three hourly time 
periods.

 • From the Date from drop-down list, choose a start date. The report shows the movement between 
zones to a focus zone within the building from the selected date onwards.

 • From the Date to drop-down list, choose the end date. The report shows the movement between 
zones to a focus zone within the building until the selected date.

 • From the Focus zone drop-down list, choose the zone you want to reference as a zone of interest.

Step 3 Click Run Report.

The movement report is displayed in the right pane. The following example pdf report shows the total 
detected devices flowing from each of the zones to the zone of interest.

This report contains the following movement report:

 • One pie chart displaying total and percentage of devices that were seen in other zones before going 
to the reference zone.

 • Another pie chart displaying the number of devices that were seen going to other zones from the 
referenced zone.
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Daily Device Snapshot
This report breaks the selected day into pre-defined time periods. Each period shows the number of 
devices that have been observed in a particular zone of the building. In this report, each device is 
separated according to its dwell time. This report shows people passing through and those staying for a 
significant time within the zone. See Configuring a Snapshot Report section for more information.

Configuring a Snapshot Report

To configure a snapshot report, follow these steps:

Step 1 Click the Reporting tab from the left pane.

Step 2 From the Select Report Type drop-down list, choose Snapshot.

 • From the Date drop-down list, choose the date for which you want the report to be generated.

Step 3 Click Run Report to view a graph of devices that are passing through or staying within the zone. The 
distinction of passing through or staying is determined by the amount of dwell time the device spends in 
that zone. 

Daily Devices and Dwell
This report allows you to compare the same time period across consecutive days for a particular zone. 
This report shows the number of devices broken down by dwell time. The dwell time ranges provided in 
this report template are:

 • Less than 5 minutes (passing through)

 • 5-45 minutes (short term customers)

 • 45 minutes - 2 hours (long term customers)

 • Greater than 2 hours (staff)

 • All devices detected

See configuring Daily Devices and Dwell for more information.

Configuring Daily Devices and Dwell

To configure Daily Devices and Dwell report, follow these steps:

Step 1 Click the Reporting tab from the left pane.

Step 2 From the Select Report Type drop-down list, choose Daily Devices and Dwell.

 • From the Time drop-down list, choose the time period for which you want to generate the report. 
The result shows the comparison of the same time period across consecutive days for a particular 
zone. The possible options are: All day, Morning, Afternoon, Evening, Night, and explicit three 
hourly time periods.

 • From the Date from drop-down list, choose a start date. The report shows the number of devices 
broken down by dwell time from the selected date onwards.
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 • From the Date to drop-down list, choose the end date. The report shows the number of devices 
broken down by dwell time until the selected date.

 • From the Focus zone drop-down list, choose the zone you want to reference as a zone of interest

Step 3 Click Run Report.

The movement report is displayed in the right pane. The following example pdf report shows the 
comparison of the me period across consecutive days for a particular zone.
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	Step 7 In the User Name and Password text boxes, enter the username and password for the mobility services engine.
	Step 8 Select the HTTP check box to allow communication between the mobility services engine and third-party applications. By default, the Prime Infrastructure uses HTTPs to communicate with MSE.
	Step 9 Select the Delete synchronized service assignments check box if you want to permanently remove all service assignments from the mobility services engine.
	Step 10 Click Next. The Prime Infrastructure automatically synchronizes the selected elements with the MSE.
	Enabling Services on the Mobility Services Engine
	Step 1 After adding the license file, the Select Mobility Service page appears.
	Step 2 To enable a service on the mobility services engine, select the check box next to the service. The different type of services are as follows:
	Step 3 Click Next to configure the tracking and history parameters.

	Configuring MSE Tracking and History Parameters
	Step 1 After you enable services on the mobility services engine, the Select Tracking & History Parameters page appears.
	Step 2 You can select the clients that you want to keep track of by selecting the corresponding Tracking check box(es). The various tracking parameters are as follows:
	Step 3 You can enable the history tracking of devices by selecting the corresponding devices check box(es). The different history parameters are as follows:
	Step 4 Click Next to Assign Maps to the MSE.

	Assigning Maps to the MSE
	Step 1 Once you configure MSE tracking and history parameters, the Assigning Maps page appears.
	Step 2 You can see the required map type by selecting All, Campus, Building, Floor Area, or Outdoor Area from the Filter option available on the page.
	Step 3 To synchronize a map, select the Name check box and click Synchronize.


	Information About Synchronizing the Prime Infrastructure and Mobility Services Engines
	Prerequisites for Synchronizing the Mobility Services Engine
	Working with Third-Party Elements
	Deleting Elements or Marking Them as Third-Party Elements
	Step 1 Choose Services > Synchronize Services.
	Step 2 In the Network Designs page, choose Third Party Elements from the left sidebar menu.
	Step 3 Select one or more elements.
	Step 4 Click one of the following buttons:


	Synchronizing Controllers with a Mobility Services Engine
	Synchronizing a Controller, Catalyst Switch, or Event Group
	Step 1 Choose Services > Synchronize Services.
	Step 2 From the left sidebar menu, choose the appropriate menu options.
	Step 3 To assign a network design to a mobility services engine, in the Synchronize Services page, choose Network Designs from the left sidebar menu.
	Step 4 Select all the maps to be synchronized with the mobility services engine by selecting the corresponding Name check box.
	Step 5 Click Change MSE Assignment.
	Step 6 Select the mobility services engine to which the maps are to be synchronized.
	Step 7 Click either of the following in the MSE Assignment dialog box:
	Step 8 Click Synchronize to update the mobility services engine(s) database(s).

	Assigning an MSE to the Controller
	Step 1 Choose Services > Synchronize Services.
	Step 2 In the Network Designs page, choose Controller from the left sidebar menu.
	Step 3 Select the controllers to be assigned to the mobility services engine by selecting the corresponding Name check box.
	Step 4 Click Change MSE Assignment.
	Step 5 Choose the mobility services engine to which the controllers must be synchronized.
	Step 6 Click either of the following in the Choose MSEs dialog box:
	Step 7 Click Synchronize to complete the synchronization process.
	Step 8 Verify that the mobility services engine is communicating with each of the controllers for only the chosen service. This can be done by clicking the NMSP status link in the status page.

	Unassigning a Network Design, Controller, Wired Switch, or Event Group from the MSE
	Step 1 Choose Services > Synchronize Services.
	Step 2 From the left sidebar menu, choose the appropriate menu options.
	Step 3 Select one or more elements by selecting the Name check box, and click Change MSE Assignment. The Choose MSEs dialog box appears.
	Step 4 Unselect the mobility services engine if you do not want the elements to be associated with that mobility services engine by selecting either the CAS or wIPS check box.
	Step 5 Click Save to save the assignment changes.
	Step 6 Click Synchronize.


	Configuring Automatic Database Synchronization and Out-of-Sync Alerts
	Configuring Automatic Database Synchronization
	Step 1 Choose Administration > Background Tasks.
	Step 2 Select the Mobility Service Synchronization check box.
	Step 3 To set the mobility services engine to send out-of-sync alerts, select the Out of Sync Alerts Enabled check box.
	Step 4 To enable smart synchronization, select the Smart Synchronization Enabled check box.
	Step 5 Enter the time interval, in minutes, that the smart synchronization is to be performed.
	Step 6 Click Submit.

	Smart Controller Assignment and Selection Scenarios
	Out-of-Sync Alarms

	Viewing Mobility Services Engine Synchronization Status
	Viewing Mobility Services Engine Synchronization Status
	Step 1 Choose Services > Synchronize Services.
	Step 2 From the left sidebar menu, choose Network Designs, Controllers, Event Groups, Wired Switches, Third Party Elements, or Service Advertisements.

	Viewing Synchronization History
	Table 2-1 Synchronization History Page


	Enabling Location Analytics Service on the Mobility Services Engine
	Step 1 Choose Services > Mobility Services Engine.
	Step 2 In the Mobility Services page, click the Device Name to configure its properties.
	Step 3 To enable Location Analytics service on the mobility services engine, select the check box next to the Location Analytics Service.
	Step 4 Click Save.
	Step 5 Click Done to save the settings.

	Adding Floor Areas
	Adding Floor Areas to a Campus Building
	Step 1 Save your floor plan maps in .PNG, .JPG, ,JPEG, or .GIF format.
	Step 2 Choose Monitor > Site Maps.
	Step 3 From the Maps Tree View or the Monitor > Site Maps list, choose the applicable campus building to open the Building View page.
	Step 4 Hover your mouse cursor over the name within an existing building rectangle to highlight it.
	Step 5 From the Select a command drop-down list, choose New Floor Area.
	Step 6 Click Go. The New Floor Area page appears.
	Step 7 In the New Floor Area page, follow these steps to add floors to a building in which to organize related floor plan maps:
	Step 8 Click any of the floor or basement images to view the floor plan or basement map.

	Adding Floor Plans to a Standalone Building
	Step 1 Save your floor plan maps in .PNG, .JPG, or .GIF format.
	Step 2 Browse to and import the floor plan maps from anywhere in your file system. You can import CAD files in DXF or DWG formats or any of the formats you created in Step 1.
	Step 3 Choose Monitor > Site Maps.
	Step 4 From the Maps Tree View or the Design > Site Maps left sidebar menu, choose the desired building to display the Building View page.
	Step 5 From the Select a command drop-down list, choose New Floor Area.
	Step 6 Click Go.
	Step 7 In the New Floor Area page, add the following information:
	Step 8 Click Next. At this point, if a CAD file was specified, a default image preview is generated and loaded.
	Step 9 Enter the remaining parameters for the floor area.
	Step 10 Click OK to save this floor plan to the database. The floor is added to the Maps Tree View and the Design > Site Maps list.
	Step 11 Click any of the floor or basement images to view the floor plan or basement map.


	Defining Coverage Area
	Step 1 Add the floor plan if it is not already represented in the Prime Infrastructure.
	Step 2 Choose Monitor > Site Maps.
	Step 3 Click the Map Name that corresponds to the outdoor area, campus, building, or floor you want to edit.
	Step 4 From the Select a command drop-down list, choose Map Editor, and click Go.
	Step 5 It the Map Editor page, click the Draw Coverage Area icon on the toolbar.
	Step 6 Enter the name of the area that you are defining. Click OK.
	Step 7 Move the drawing tool to the area you want to outline.
	Step 8 Click the disk icon on the toolbar to save the newly drawn area.

	Monitoring Geo-Location
	Adding a GPS Marker to a Floor Map
	Step 1 Choose Monitor > Site Maps to display the Maps page.
	Step 2 Choose Campus Name > Building Name > Floor Name.
	Step 3 Choose the Add/Edit GPS Markers Information menu option on the top left menu to open the Add/Edit GPS page.
	Step 4 You can drag the GPS Marker icon and place it in the desired location on the map or enter the X and Y position values in the GPS Marker Details table on the left sidebar menu to move the marker to the desired position.
	Step 5 Enter the Latitude and Longitude degrees for the selected GPS Marker icon in the left sidebar menu.
	Step 6 Click Save.
	Step 7 Click Apply to other Floors of Building to copy GPS markers on one floor of a building to all the remaining floors of that building.

	Editing a GPS Marker
	Step 1 Choose Monitor > Site Maps to display the Maps page.
	Step 2 Choose the Campus Name > Building Name > Floor Name.
	Step 3 Choose the Add/Edit GPS Markers Information menu option on the top left menu to open the Add/Edit GPS page.
	Step 4 Select an existing GPS marker present on the floor.
	Step 5 From the left sidebar menu, you can change the Latitude, Longitude, X Position, and Y Position which is associated with the GPS marker.
	Step 6 Click Save.

	Deleting a GPS Marker Present on a Floor
	Step 1 Choose Monitor > Site Maps to display the Maps page.
	Step 2 Choose Campus Name > Building Name > Floor Name.
	Step 3 Choose the Add/Edit GPS Markers Information menu option to open the Add/Edit GPS page.
	Step 4 Select an existing GPS Marker which is present on the floor from the left sidebar menu.
	Step 5 Click Delete GPS Marker.
	Step 6 The selected GPS marker is deleted from the database.


	Logging into Location Analytics User Interface
	Step 1 In the address line of browser, enter https://location-analytics-ip-address:8080/ui, where location-analytics-ip-address is the IP address of the Location Analytics server. Location Analytics user interface displays the User Login page.
	Step 2 Enter your username.
	Step 3 Enter your password.
	Step 4 Click Login to log into Location Analytics.

	WebGL Requirements
	3
	Licensing Requirement for Location Analytics Service
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	Location Analytics Home Page Components

	Figure 4-1 Location Analytics User Login Page
	Figure 4-2 Location Analytics Home Page

	Rules Group Box
	Analysis Group Box
	3D Analytics Tab
	Prerequisites for viewing Location Analytics in 3D
	Viewing Analytics in the 3D Environment
	Step 1 From the Rules Group box, you can set rule types to specify which devices have to be considered for analysis based on different rules parameters. For information on Rules parameters, see Rules Group Box, page 4-2.
	Step 2 From the Analysis group box, you can perform different analysis on devices that are passing through a building or environment. To perform different analysis, see Typical Location Analysis, page 5-1 and Typical Path Analysis, page 5-3.
	Step 3 Click Run.
	Step 4 Click 3D Analytics to view the results in the 3D environment.
	Step 5 Click the Navigation buttons available in the Auxiliary Information window to see different overlays of the building and also different views of the floors. The 3D environment provides the ability to switch on/off floors.


	2D Analytics
	Step 1 From the Rules Group box, you can set rule types to specify which devices have to be considered for analysis based on different rules parameters. In order to set rules parameters, see Rules Group Box, page 4-2.
	Step 2 From the Analysis group box, you can perform different analysis on devices that are passing through a building or environment. In order to perform different analysis, see Typical Location Analysis, page 5-1 and Typical Path Analysis, page 5-3.
	Step 3 Click Run.
	Step 4 Click 2D Analytics to view the results in the 2D environment.

	Reporting tab
	Visualization Pane
	Auxiliary Information Dashlet
	5
	Information About Analysis



	Typical Location Analysis
	Areas and Zones
	Figure 5-1 Distribution of Number of Devices Across One Floor
	Figure 5-2 Distribution of Median Dwell Times


	Typical Path Analysis
	Analyzing Areas of the Building Using the Typical Path Analysis
	Step 1 Do the following in the Analysis group box:
	Step 2 You can apply the parameterised rules to your analysis from the Rules group box. See Rules Group Box, page 4-2 for more information.
	Step 3 Click Run.
	Step 4 Click 3D Analytics to view the results in 3D environment or 2D to view the results in 2D environment.
	Figure 5-3 Typical Path Across One Floor in 2D Environment
	Figure 5-4 Typical Path Between Floors

	Step 5 To obtain information associated with the parameter, click the node or use the location selector from the Auxiliary Information dashlet. The following figure shows the path parameters at Start Node.
	Figure 5-5 Path Parameters at Start Node
	Figure 5-6 Path Parameters at Intermediate Node
	Figure 5-7 Path Parameters at Edge Node
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	Reports




	Frequent Devices
	Configuring a Frequent Devices
	Step 1 Click the Reporting tab from the left pane.
	Step 2 From the Select Report Type drop-down list, choose Frequent Devices.
	Step 3 Click Run Report.


	Movement Between Zones
	Configuring Movement Between Zones
	Step 1 Click the Reporting tab from the left pane.
	Step 2 From the Select Report Type drop-down list, choose Movement Between Zones.
	Step 3 Click Run Report.


	Daily Device Snapshot
	Configuring a Snapshot Report
	Step 1 Click the Reporting tab from the left pane.
	Step 2 From the Select Report Type drop-down list, choose Snapshot.
	Step 3 Click Run Report to view a graph of devices that are passing through or staying within the zone. The distinction of passing through or staying is determined by the amount of dwell time the device spends in that zone.


	Daily Devices and Dwell
	Configuring Daily Devices and Dwell
	Step 1 Click the Reporting tab from the left pane.
	Step 2 From the Select Report Type drop-down list, choose Daily Devices and Dwell.
	Step 3 Click Run Report.





