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Welcome

Thank you for downloading the Cisco FindIT Network Discovery Utility. This simple utility helps you 
to monitor and manage your local network from a convenient toolbar in your web browser. Cisco FindIT 
automatically discovers all supported Cisco Small Business devices in the same local network segment 
as your PC. You can get a snapshot view of each device or launch the product configuration utility to 
view and configure the settings. You will also be notified of any firmware updates available for each 
device and can easily download them with just a few clicks.

Before You Begin
Your PC must meet the following requirements to run Cisco FindIT.

 • Operating system:

 – Microsoft Windows XP SP3, 7 or 8

 – Apple OS X 10.6, 10.8 or 10.9

 • Web browser: 

 – Microsoft Internet Explorer 8, 9, or 10

 – Mozilla Firefox 24 or 25

Note When running on Windows XP, Cisco FindIT only supports Internet Explorer.

Your network devices must meet the following requirements to be monitored and accessed through Cisco 
FindIT.

 • Must be on the same subnet as the PC that is running Cisco FindIT.

 • Must be a Cisco Small Business device with the Bonjour service supported and enabled (see the 
Administration Guide or online Help for the device)

Installing and Uninstalling Cisco FindIT
If needed, you can reinstall or uninstall Cisco FindIT.

 • Installing Cisco FindIT on a Windows PC, page 1-4
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 • Installing Cisco FindIT on an Apple Macintosh, page 1-8

 • Uninstalling Cisco FindIT from a Windows PC, page 1-9

 • Uninstalling Cisco FindIT from an Apple Macintosh, page 1-10

Installing Cisco FindIT on a Windows PC

Step 1 Download the installation file from www.cisco.com/go/findit. 
In the list of available firmware, look for the most recent version for your operating system. For Windows 
32-bit, look for x86 in the filename. For Windows 64-bit, look for x64. Mouse-over the installer file to 
get all information about the .exe file.

Step 2 Close any web browser windows that are open. If the browser is open during this process, the toolbar 
will not be updated to display Cisco FindIT.

Step 3 Click Download. You may be prompted to read and accept the End User Agreement. 

Step 4 On Accepting the License Agreement, you will get an option to either Run or Save the .exe file. Click 
Run. 

Step 5 You will now receive a Security warning to confirm if you want to Run the file. Click Run.

If you previously installed another version of Cisco FindIT, the Program Maintenance window appears, 
which has two options - Repair and Remove. You can choose to continue with this installation by 
selecting Repair. To delete the existing version of FindIT from your system, select Remove. Follow the 
onscreen instructions to complete the process.

Note This message does not indicate an issue with the installation.

Step 6 On the next screen select the language for installation. Click Next.
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Note Screen shots are provided for reference only; the text and options on the screen may vary.

Wait until the Welcome window appears. 

Step 7 On the Welcome window, click Next.

Step 8 Read and accept the license agreement, and then click Next.

Step 9 Select the destination folder for the installation. By default, it will select C:\Program Files (x86)\Cisco 
Small Business\FindIT\. It is recommended to allow installation in this location. You, however, have the 
option to change it to a desired location.
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Follow the instructions on each Wizard page to continue with the installation. 

Step 10 When the InstallShield Wizard Completed message appears, click Finish.

Step 11 Start your web browser.

Tip Internet Explorer running on Windows Vista or later includes a feature known as Protected 
Mode.  FindIT is not compatible with Protected Mode and will not operate correctly when 
Protected Mode is enabled.   
If you are using Internet Explorer on Windows Vista or later, launch Internet Explorer as an 
administrator. The Administrator mode enables browser functions that are blocked for 
non-administrator use.  
To launch Internet Explorer as an administrator, right-click the IE icon on your Desktop, and 
then click Run as administrator. 

Step 12 If the Cisco FindIT toolbar does not appear automatically, open the View menu, and then choose 
Toolbars> Cisco FindIT Toolbar.
1-6
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Cisco FindIT appears in the toolbar area. The side bar appears in the window. You are now ready to start 
using Cisco FindIT. 

Note In Internet Explorer 9, it is necessary to enable the toolbar. Then perfom the above step.

You must restart the browser, and then the sidebar will appear.

Step 13 After Internet Explorer has restarted, and if this is the first time FindIT has been installed on this PC, the 
Product Improvement settings dialog will open, and the Product Registration page will appear in the 
content area.

Note Registering FindIT and providing Product Improvement data to Cisco are both optional, but will help to 
ensure that future FindIT updates and other Small Business products are of the highest possible quality.
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Installing Cisco FindIT on an Apple Macintosh

Note The process described below may also be used to install Cisco FindIT for Firefox running on Windows, 
but the Windows Bonjour driver required for FindIT to operate will not be installed.  We recommend you 
use the process described above to install FindIT for Firefox on Windows and ensure that the Bonjour 
driver is also installed.

Step 1 Download the installation file from www.cisco.com/go/findit. In the list of available firmware, look for 
the most recent.  If you are downloading the file using Firefox on the Macintosh where you wish to install 
the software, skip to Step 3.

Step 2 On the Macintosh where you wish to install FindIT, open the Firefox web browser and choose File > 
Open, selecting the FindIT install file you have just downloaded.

Step 3 When you are presented with the warning dialog, click Install Now.

Step 4 Click to restart Firefox.

 

Step 5 After Firefox has restarted, and if this is the first time FindIT has been installed on this PC, the Product 
Improvement settings dialog will open, and the Product Registration page will appear in the content area.
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Note Registering FindIT and providing Product Improvement data to Cisco are both optional, but will help to 
ensure that future FindIT updates and other Small Business products are of the highest possible quality.

Uninstalling Cisco FindIT from a Windows PC
You can uninstall Cisco FindIT by using the Windows Control Panel (preferred) or the InstallShield 
Wizard.

Uninstalling from the Control Panel (preferred method):

Step 1 Click the Windows Start button.

Step 2 Choose Control Panel > Add or Remove Programs (Windows XP) or Control Panel > Programs > 
Programs and Features > Uninstall a Program (Windows 7).

Step 3 Find Cisco FindIT in the list of programs.

Step 4 Click Change/Remove (Windows XP) or Uninstall/Change (Windows 7).

Step 5 When the Confirm Uninstall message appears, click OK to continue, or click Cancel to close the message 
without removing the program.

Uninstalling from the InstallShield Wizard:

Step 1 Locate the Cisco FindIT installation file on your PC.

Step 2 Double-click the file to run the program.

Step 3 When the Welcome page appears, click Next.
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Step 4 When the Program Maintenance page appears, click Remove, and then click Next.

Step 5 When the Remove the Program page appears, click Remove to confirm, or click Cancel to quit this 
process.

Uninstalling Cisco FindIT from an Apple Macintosh

Step 1 In Firefox, select Tools > Addons.

Step 2 Locate Cisco FindIT in the list of installed addons and click Remove.

 

Step 3 Click Restart Now to restart Firefox.

 

Step 4 Optionally delete the Settings and other files associated with FindIT by deleting the Cisco FindIT 
directory in the user’s Firefox Profile folder.

Suggested Next Steps
You are now ready to start using Cisco FindIT. Refer to the following information to become familiar 
with the features.

Note If your computer is running Windows Vista or Windows 7, you should launch Internet Explorer as an 
administrator. Administrator mode enables browser functions that are blocked for non-administrator use. 
To launch Internet Explorer, right-click the Internet Explorer icon on your Desktop, and then click Run 
as administrator.

Cisco FindIT Buttons
Cisco FindIT includes the following buttons:

 • Cisco: Click this button to connect to the Cisco Small Business home page on Cisco.com.

 • FindIT: Click this button to show or hide the Device Discovery sidebar. To refresh the display, click 
the arrow icon on the FindIT button, and then choose Refresh from the menu. 

 • Applications (only on a Windows PC): Click this button to see a menu of the supported Cisco 
Small Business applications. Click the link to launch the application. If the application was not 
found on your computer, an error message appears. Supported applications include Cisco Video 
Monitoring System and Cisco Continuous Data Protection.  
Settings: Click this button to open the Settings menu. 
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 • Support: Click this button to open the Support menu, which includes links for the Help system, 
support sites, online chat support, and version information (About Cisco FindIT). Depending on 
the products being used, the links in the Support menu provide details on the types of support 
available for different types of products.

Note When you launch the Help system, Internet Explorer may display a message about scripts or 
ActiveX controls. To enable all functions of the Help system, click the yellow message box, 
and then click Allow Blocked Content. 

Device Discovery Sidebar
Cisco FindIT automatically discovers all supported Cisco Small Business devices in your network and 
lists them in the Device Discovery sidebar. You can use the sidebar to view basic device information or 
to launch the device managers to review and modify the device configurations.

Devices are organized by device type (router, switch, and so on.).

 • To collapse a device type section, click the minus sign (-) next to the device type. To expand a 
section, click the plus sign (+).

 • To view device information, position your mouse pointer over the device name.

 • To launch a device manager, double-click the device name.

 • If a firmware update is available for a device, the download icon  will appear. Click on this icon 
to download the update to the PC. An example is shown below.

Note If you are running Internet Explorer on Windows Vista or Windows 7, you may have 
difficulties with programs like Cisco FindIT that use pop-up windows. 
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Questions and Answers

This section provides more information about Cisco FindIT features and web browser issues that may 
occur. The topics are organized into the following categories:

 • Basic Operations, page A-13

 • Devices and Device Discovery Sidebar, page A-15

 • Applications, page A-17

Basic Operations
Q. How do I tell which version of Cisco FindIT is installed?

A. Click the Support button, and then click About Cisco FindIT. The version number appears in the 
pop-up window. Click the X button in the top right corner of the pop-up window to close it.

Q. How do I upgrade Cisco FindIT?

A. Whenever a newer version of FindIT is available for download, the system brings up a pop-up 
message indicating the same. A message ”A more recent version of the FindIT application is 
available. Would you like to download it now?” You can either choose Download Now or Maybe 
Later to proceed accordinly with the upgrade. if you select Download Now, the installer will be 
downloaded and executed. To complete the installation, follow the steps in Installing and 
Uninstalling Cisco FindIT, page 1-3

OR

Click on the drop-down next to FindIT in the toolbar. You should see an option Update FindIT. 
Select this and follow on screen instructions to upgrade to the newer version.

OR

To manually upgrade the Cisco FindIT utility follow the steps given below:

Step 1 Download the installation file from http://www.cisco.com/go/findit.

Step 2 Close any web browser windows that are open.
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Note Sometimes it is may not be required to close the browser. Double-click on the installer to 
continue with teh upgrade.

Step 3 Follow the instructions from Installing and Uninstalling Cisco FindIT, page 1-3 to complete the 
installation.

Step 4 Restart the browser to use the new version of Cisco FindIT.

Note After you upgrade Cisco FindIT, it is not recommended to downgrade to an earlier version.

Q. How do I uninstall Cisco FindIT?

A.  See Installing and Uninstalling Cisco FindIT, page 1-3.

Q. How do I move Cisco FindIT in Internet Explorer?

A. In Internet Explorer, you can move Cisco FindIT as you would move any other toolbar. 

Note This feature is not available in Firefox.

To move FindIT in Internet Explorer:

Step 1 From the Internet Explorer View menu, choose Toolbars. If there is a check mark next to the Lock the 
Toolbars option, click to remove the check mark.

Step 2 Position your mouse pointer near the left corner of the Cisco button in Cisco FindIT. The mouse pointer 
becomes a crosshair.

Step 3 Drag Cisco FindIT to the new position, and then release the mouse button.

Q. Why did Cisco FindIT revert to the default settings when I disabled Protected Mode?

A. Recent versions of Internet Explorer have a security feature, Protected Mode, that greatly restricts 
the privileges for IE processes. If you choose to turn off Protected Mode and disable these security 
features, the browser no longer has access to the toolbar settings that you saved with Protected Mode 
turned on. You can either enable Protected Mode to access the saved settings, or configure the 
settings again. Settings that are saved when Protected Mode is turned off will be available as long 
as you continue to run the browser with Protected Mode turned off.

To enable or disabled Protected Mode:

Step 1 From Tools menu, choose Internet Options.

Step 2 Click the Security tab.

Step 3 Check (enable) or uncheck (disable) the Enable Protected mode box.

Step 4 Click OK.

Step 5 Close IE to end the session, and then restart IE.

Q. How do I temporarily run Internet Explorer without Protected Mode?
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A. Recent versions of Internet Explorer have a security feature, Protected Mode, that greatly restricts 
the privileges for IE processes. To temporarily disabled Protected Mode for the current session, you 
can run IE as an administrator. Be aware that you will not have access to any browser or toolbar 
settings that you customized with Protected Mode turned on. If you want to use IE for web browsing, 
you can restart the browser with the normal user privileges to enable Protected Mode.

To temporarily disabled Protected Mode:

Step 1 Close Internet Explorer.

Step 2 Right-click the Internet Explorer icon on your Desktop.

Step 3 Choose Run as administrator. Your customized Cisco FindIT settings will be available whenever you run 
IE as an administrator.

Q. Does FindIT allow me to configure settings for automatic updates?

A. Yes. To configure these settings, on the toolbar, click on the drop-down next to Settings and select 
Software Update Options. 

On the next screen you will find options to configure the settings for Device Firmware Updates 
and FindIT Application Updates. Select the options according to your preference and click OK.

Q. Why do I see a yellow message box in Internet Explorer when the Help system opens?

A. Internet Explorer displays this message when a web page runs scripts or ActiveX controls. The Help 
system uses scripts for certain features. To enable all functions of the Help system, click the yellow 
message box, and then click Allow Blocked Content.

Devices and Device Discovery Sidebar
Q. I can’t open the device manager in a new window. What should I do?

A. In Internet Explorer, a pop-up blocker may be preventing the device manager from launching. Even 
if you have set up Internet Explorer to allow pop-ups, it is possible that pop-ups may be blocked by 
other toolbar applications that you have installed.

You can adjust the Internet Explorer pop-up settings, adjust the pop-up settings for other toolbars, or use 
the shortcut menu to launch the device manager within the same window.

 • Pop-up Settings for Internet Explorer: To determine if the Internet Explorer pop-up settings are 
preventing the window from opening, choose the Tools menu, and then click Pop-up Blocker.

 – If the Turn On Pop-up Blocker menu option appears, then the Internet Explorer Pop-up Blocker 
is disabled, and Internet Explorer is not blocking any pop-ups.

 – If the Turn Off Pop-up Blocker menu option appears, then the Internet Explorer Pop-up Blocker 
is enabled. You can disable the Pop-up Blocker by clicking this menu option. Alternatively, you 
can allow pop-ups only from specified web sites. Choose Tools > Pop-up Blocker > Pop-up 
Blocker Settings. Enter the URL for the device that you want to access with Cisco FindIT, and 
then click Add. Repeat for each device that you want to add, and then click Close.

 • Pop-up Settings for Other Toolbars: Review the pop-up settings for each product toolbar that you 
have installed, such as the toolbar for Google, Yahoo, or another software or hardware provider. 
Adjust the toolbar options to allow web pop-ups.
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 • Launching a device manager in the same window: To avoid the pop-up issue, you can launch a device 
manager into the current window. From the device discovery sidebar, double-click the name of the 
device, or right-click and then choose Open.

 • Launching a device manager in a new window: Right-click the device, and then click Open in a New 
Window.

Note With Windows 7 and IE 9, the default is to open a new tab rather than a new window. If you want 
to adjust the settings for tabbed browsing, go to Tools > Internet Options. Choose Tabbed 
Browsing Settings. Select Always open pop-ups in a new window.

Q. When I try to launch a device manager, Internet Explorer displays the following message: Internet 
Explorer cannot display the webpage. What should I do?

A. There are two possible solutions:

 • Verify that the device has power and is connected to the network.

 • Verify that the browser mode of operation (32-bit or 64-bit) matches the mode of operation of the 
Bonjour daemon.

Q. In Internet Explorer, I cannot log in to a device manager from the device discovery sidebar.

A. In Internet Explorer, if the Security, Privacy, or Content option is set too high, IE may prevent you 
from logging in to a device manager from the Cisco FindIT device discovery sidebar. If you 
encounter this issue, use the IE menu bar to choose Tools > Internet Options. Then make the changes 
listed below:

 • Security tab: For best results, select Medium-high (the default setting).

 • Privacy tab: For best results, select Medium (the default setting).

 • Content tab: For best results, ensure that the Content Advisor is disabled.

(If you previously enabled the Content Advisor, you will be prompted for your password when you 
disable it. Enter the password that you created for the Content Advisor.)

Q. When I launch a device manager and attempt to log in, an error message states that cookies are not 
enabled.

A. If you are using Internet Explorer 9 and have the Privacy settings at High, logins will be blocked. 
As a work around, go to Tools > Internet Options. Click the Privacy tab, and then click the Advanced 
button. Check the Overwrite automatic cookie handling box.

Q. I disconnected a device, but it still appears in the device discovery sidebar. What do I need to do to 
update the sidebar?

A. Differences in device timing may prevent Cisco FindIT from promptly updating the device status. 
If the sidebar is not updated automatically within a few minutes after you connect or disconnect a 
device, click the arrow icon on the FindIT button, and then choose Refresh from the menu.

Q. A device was moved to a different subnet, but it still appears in the sidebar with the former IP 
address, and I cannot launch the device manager.

A. If a device’s IP address is changed, it may continue to appear in the device discovery sidebar with 
the former IP address. Reboot the device. Then click the arrow on the FindIT button, and choose 
Refresh.

Q. Why can’t I connect to the device manager of a device that is displayed in the discovery sidebar?
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A. The device has a static IP address on a different subnet, and the router cannot find a path to that IP 
address. To determine if there is an IP addressing issue, position your mouse pointer over the device 
in the discovery sidebar and check the IP address shown in the popup. Compare it to the address of 
your PC.As a work-around, configure the PC with an IP address on the same subnet as the device, 
configure the device with a static IP address on the subnet, or configure the device to dynamically 
receive an IP address from the router.

Q. Why can I not see my device in the sidebar

A. There are several possibilities:

 • Bonjour service is disabled on the device. Refer to the device documentation for instructions about 
launching the configuration utility and enabling Bonjour service.

 • Multicast traffic is blocked. Review the router’s firewall settings to ensure that multicast traffic is 
allowed.

Q. Why are some of my network devices not discovered by Cisco FindIT?

A. The device discovery mechanism used by Cisco FindIT does not operate across VLANs or LANs 
connected by a router. To discover devices in a different VLAN, you should connect your PC to that 
VLAN.

Q. Why is the popup information is displayed differently for different types of devices in the Device 
Discovery sidebar?

A. Cisco FindIT gets this information directly from a device during discovery. Different devices and 
different versions of firmware may advertise more or less information. In general, older devices and 
firmware will advertise less information than newer devices and firmware. For best results, update 
your device firmware to the latest available release.

Applications
Q. Cisco FindIT is not finding all of my installed applications. Why?

A. Cisco FindIT automatically includes the supported applications on your PC. Cisco FindIT cannot 
find unsupported applications or applications that are installed on other devices on your network.

Q. The Cisco Video Monitoring System launched in full screen mode. How do I return to the normal 
view?

A. From the Cisco Video Monitoring System toolbar, choose Setup > Settings, and then uncheck Full 
Screen.

Q. Cameras that appear in the device discovery sidebar are not showing up in the Cisco Video 
Monitoring System. What can I do to view these cameras?

A. To view the cameras, follow these steps:

Step 1 Launch the camera’s device manager from the device discovery sidebar, and log in.

Step 2 Enable the UPnP discovery option for the camera. For more information about this setting, refer to the 
documentation for your camera.
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Q. When I try to launch the Cisco Video Monitoring System from the Applications button in Cisco 
FindIT, I see the following error message: “Main console is already running. Unable to create 
another instance.” What should I do?

A. This message indicates that the Cisco Video Monitoring System is open in another window. In the 
Windows task bar at the bottom of the screen, find the icon for the Cisco Video Monitoring System. 
Click the button, and then log in again.

Q. When running Internet Explorer on Windows Vista or Windows 7, I can not launch applications from 
the Applications button. What can I do?

A. Security settings may prevent the applications from launching. Perform the following steps:

Step 1 Close the browser.

Step 2 Right-click the browser icon on your Desktop.

Step 3 Choose Run as administrator.
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Resources
Cisco provides a wide range of resources to help you and your customer obtain the full benefits of the 
Cisco FindIT.

Support

Cisco Small Business Support Community www.cisco.com/go/smallbizsupport

Cisco Small Business Support and Resources www.cisco.com/go/smallbizhelp

Phone Support Contacts www.cisco.com/go/sbsc

Cisco Small Business Firmware Downloads www.cisco.com/go/software

Product Documentation

Cisco FindIT www.cisco.com/go/findit

Cisco Small Business 

Cisco Partner Central for Small Business (Partner Login 
Required)

www.cisco.com/web/partners/sell/smb

Cisco Small Business Home www.cisco.com/smb
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