Identifying the Effectiveness of Security Mitigations Using Cisco IOS Software


Contents

Introduction
Cisco IOS Routers and Switches
       Identifying the Effectiveness of Infrastructure Access Control Lists
       Transit Access Control Lists
          Identifying the Effectiveness of Transit Access Control Lists
       Identifying the Effectiveness of Access List Logging
       Spoofing Protections
          Unicast Reverse Path Forwarding
          IP Source Guard
          Identifying the Effectiveness of Spoofing Protection Using Unicast Reverse Path Forwarding
       IPv4 and IPv6 Identification
Cisco IOS NetFlow and Cisco IOS Flexible NetFlow
       Identifying the Effectiveness of IPv4 Traffic Flow Identification Using Cisco IOS NetFlow
       Identifying the Effectiveness of IPv6 Traffic Flow Identification Using Cisco IOS NetFlow
       Identifying the Effectiveness of IPv4 Traffic Flow Identification Using Cisco IOS Flexible NetFlow
       Identifying the Effectiveness of IPv6 Traffic Flow Identification Using Cisco IOS Flexible NetFlow
Cisco IOS Software Zone-Based Firewall
       Identifying the Effectiveness of Cisco IOS Software Zone-Based Firewall on Cisco IOS Routers
Conclusion
Additional Information
       Risk Management
       Resources




Introduction

Cisco IOS Software can provide effective means of exploit prevention using the following methods:

  • Infrastructure access control lists (iACLs)
  • Transit access control lists (tACLs)
  • Unicast Reverse Path Forwarding (uRPF)
  • IP source guard (IPSG)

This document provides identification techniques that administrators can deploy on Cisco network devices to identify whether the prevention methods are having the desired effect. Readers of this document will understand that the specific commands used in this document will differ from production devices depending on the traffic being blocked.

Caution: The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Device-Specific Identification Methods

Specific information about identification is available for these Cisco IOS devices:

  • Cisco IOS Routers and Switches
  • Cisco IOS NetFlow and Cisco IOS Flexible NetFlow

Cisco IOS Routers and Switches

Identifying the Effectiveness of Infrastructure Access Control Lists

After the administrator applies an iACL to an interface, the show ip access-lists and show ipv6 access-list commands will identify the number of IP version 4 (IPv4) and IP version 6 (IPv6) packets that have been filtered on interfaces on which the iACL is applied. Administrators should investigate filtered packets to determine whether they are attempts to exploit security vulnerabilities. Example output for show ip access-lists Infrastructure-ACL-Policy and show ipv6 access-list IPv6-Infrastructure-ACL-Policy follows:

router#show ip access-lists Infrastructure-ACL-Policy
Extended IP access list Infrastructure-ACL-Policy
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 (60 matches)
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 (41 matches)
    30 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 (188 matches)
    40 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 (51 matches)
    50 deny tcp any 192.168.60.0 0.0.0.255 eq 5060 (9 matches)
    60 deny tcp any 192.168.60.0 0.0.0.255 eq 5061 (18 matches)
    70 deny udp any 192.168.60.0 0.0.0.255 eq 5060 (34 matches)
    80 deny udp any 192.168.60.0 0.0.0.255 eq 5061 (72 matches)
    90 deny ip any 192.168.60.0 0.0.0.255 (17 matches)
router#

In the preceding example, access list Infrastructure-ACL-Policy has dropped the following packets received from an untrusted host or network:

  • 9 SIP packets on TCP port 5060 for ACE line 5
  • 18 SIP packets on TCP port 5061 for ACE line 6
  • 34 SIP packets on UDP port 5060 for ACE line 7
  • 72 SIP packets on UDP port 5061 for ACE line 8

 

router#show ipv6 access-list IPv6-Infrastructure-ACL-Policy 
IPv6 access list IPv6-Infrastructure-ACL-Policy
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5060 (71 matches) sequence 10
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5061 (85 matches) sequence 20
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5060 (512 matches) sequence 30
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5061 (171 matches) sequence 40
    deny tcp any 2001:DB8:1:60::/64 eq 5060 (58 matches) sequence 50
    deny tcp any 2001:DB8:1:60::/64 eq 5061 (81 matches) sequence 60
    deny udp any 2001:DB8:1:60::/64 eq 5060 (216 matches) sequence 70
    deny udp any 2001:DB8:1:60::/64 eq 5061 (114 matches) sequence 80
    permit icmp any any nd-ns (80 matches) sequence 90
    permit icmp any any nd-na (80 matches) sequence 100
    deny ipv6 any 2001:DB8:1:60::/64 (5 matches) sequence 110

In the preceding example, access list IPv6-Infrastructure-ACL-Policy has dropped the following packets received from an untrusted host or network:

  • 58 SIP packets on TCP port 5060 for ACE line 5
  • 81 SIP packets on TCP port 5061 for ACE line 6
  • 216 SIP packets on UDP port 5060 for ACE line 7
  • 114 SIP packets on UDP port 5061 for ACE line 8

For additional information about investigating incidents using ACE counters and syslog events, see the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security Intelligence Operations white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Cisco Security Intelligence Operations white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy transit access control lists (tACLs) to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against security vulnerabilities when the attack originates from a trusted source address.

Identifying the Effectiveness of Transit Access Control Lists

After the administrator applies the tACL to an interface, show ip access-lists and show ipv6 access-list commands will identify the number of IPv4 and IPv6 packets that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit security vulnerabilities. Example output for show ip access-lists 150 andshow ipv6 access-list IPv6-Transit-ACL-Policy follows:

router#show ip access-lists 150
Extended IP access list 150
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 139
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 445
    30 deny tcp any 192.168.60.0 0.0.0.255 eq 139 (12 matches)
    40 deny tcp any 192.168.60.0 0.0.0.255 eq 445 (26 matches)
    50 deny ip any any
router#

In the preceding example, access list 150 has dropped the following packets received from an untrusted host or network:

  • 12 NetBIOS packets on TCP port 139 for ACE line 3
  • 26 HTTPS packets on TCP port 445 for ACE line 4

 

router#show ipv6 access-list IPv6-Transit-ACL-Policy 
IPv6 access list IPv6-Transit-ACL-Policy
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5060 (55 matches) sequence 10
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5061 (38 matches) sequence 20
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5060 (210 matches) sequence 30
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5061 (59 matches) sequence 40
    deny tcp any 2001:DB8:1:60::/64 eq 5060 (30 matches) sequence 50
    deny tcp any 2001:DB8:1:60::/64 eq 5061 (41 matches) sequence 60
    deny udp any 2001:DB8:1:60::/64 eq 5060 (310 matches) sequence 70
    deny udp any 2001:DB8:1:60::/64 eq 5061 (131 matches) sequence 80
    permit icmp any any nd-ns (41 matches) sequence 90
    permit icmp any any nd-na (41 matches) sequence 100
    deny ipv6 any any (21 matches) sequence 110

In the preceding example, access list IPv6-Transit-ACL-Policy has dropped the following packets received from an untrusted host or network:

  • 30 SIP packets on TCP port 5060 for ACE line 50
  • 41 SIP packets on TCP port 5061 for ACE line 60
  • 310 SIP packets on TCP port 5060 for ACE line 70
  • 131 SIP packets on TCP port 5061 for ACE line 80

For additional information about investigating incidents using ACE counters and syslog events, see the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security Intelligence Operations white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Cisco Security Intelligence Operations white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identifying the Effectiveness of Access List Logging

The log and log-input access control list (ACL) option will cause packets that match specific ACEs to be logged. The log-input option enables logging of the ingress interface in addition to the packet source and destination IP addresses and ports.

Caution: Access control list logging can be very CPU intensive and must be used with extreme caution. Factors that drive the CPU impact of ACL logging are log generation, log transmission, and process switching to forward packets that match log-enabled ACEs.

For Cisco IOS Software, the ip access-list logging interval interval-in-ms command can limit the effects of process switching induced by IPv4 ACL logging. The logging rate-limit rate-per-second [except loglevel] command limits the impact of log generation and transmission.

The CPU impact from ACL logging can be addressed in hardware on the Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers with Supervisor Engine 720 or Supervisor Engine 32 using optimized ACL logging.

For additional information about the configuration and use of ACL logging, see the Understanding Access Control List Logging Cisco Security Intelligence Operations white paper.

Spoofing Protections

Unicast Reverse Path Forwarding

Security vulnerabilities can be exploited by spoofed IP packets. Administrators can deploy and configure Unicast Reverse Path Forwarding (uRPF) as a protection mechanism against spoofing.

uRPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on uRPF to provide complete spoofing protection because spoofed packets may enter the network through a uRPF-enabled interface if an appropriate return route to the source IP address exists. Administrators are advised to take care to ensure that the appropriate uRPF mode (loose or strict) is configured during the deployment of this feature because it can drop legitimate traffic that is transiting the network. In an enterprise environment, uRPF may be enabled at the Internet edge and the internal access layer on the user-supporting Layer 3 interfaces.

For additional information about the configuration and use of uRPF, see the Understanding Unicast Reverse Path Forwarding Cisco Security Intelligence Operations white paper.

IP Source Guard

IP source guard (IPSG) is a security feature that restricts IP traffic on nonrouted, Layer 2 interfaces by filtering packets based on the DHCP snooping binding database and manually configured IP source bindings. Administrators can use IPSG to prevent attacks from an attacker who attempts to spoof packets by forging the source IP address and/or the MAC address. When properly deployed and configured, IPSG coupled with strict mode uRPF provides the most effective means of spoofing protection for security vulnerabilities.

Additional information about the deployment and configuration of IPSG is in Configuring DHCP Features and IP Source Guard.

Identifying the Effectiveness of Spoofing Protection Using Unicast Reverse Path Forwarding

With uRPF properly deployed and configured throughout the network infrastructure, administrators can use the show cef interface type slot/port internalshow ip interfaceshow cef dropshow ip cef switching statistics feature, and show ip traffic commands to identify the number of packets that uRPF has dropped.

Note: Beginning with Cisco IOS Software Release 12.4(20)T, the command show ip cef switching has been replaced by show ip cef switching statistics feature.

Note: The show command | begin regex and show command | include regex command modifiers are used in the following examples to minimize the amount of output that administrators will need to parse to view the desired information. Additional information about command modifiers is in the show command sections of the Cisco IOS Configuration Fundamentals Command Reference.

router#show cef interface GigabitEthernet 0/0 internal | include drop 
  ip verify: via=rx (allow default), acl=0, drop=18, sdrop=0
  IPv6 unicast RPF: via=rx acl=None, drop=10, sdrop=0 (if IPv6 applies)
router#

Note: show cef interface type slot/port internal is a hidden command that must be fully entered at the command-line interface. Command completion is not available for it.

router#show cef drop
CEF Drop Statistics
Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj  ChkSum_Err
RP            27           0           0          18           0           0
router#
router#show ip interface GigabitEthernet 0/0 | begin verify
  IP verify source reachable-via RX, allow default, allow self-ping
  18 verification drops
  0 suppressed verification drops
router#
router#show ipv6 interface GigabitEthernet 0/0 | section IPv6 verify
  IPv6 verify source reachable-via rx 
  0 verification drop(s) (process), 10 (CEF)
  0 suppressed verification drop(s) (process), 0 (CEF)
 --      CLI Output Truncated      -- 
router#
router#show ip cef switching statistics feature
IPv4 CEF input features:
Path Feature Drop Consume Punt Punt2Host Gave route
RP PAS uRPF 18 0 0 0 0 Total 18 0 0 0 0 -- CLI Output Truncated -- router# router#show ipv6 cef switching statistics feature IPv6 CEF input features: Feature Drop Consume Punt Punt2Host Gave route RP LES Verify Unicast R 10 0 0 0 0 Total 10 0 0 0 0 -- CLI Output Truncated -- router# router#show ip traffic | include RPF 18 no route, 18 unicast RPF, 0 forced drop router# router#show ipv6 traffic | include RPF 10 RPF drops, 0 RPF suppressed, 0 forced drop router#

IPv4 and IPv6 Identification

In the preceding show cef interface GigabitEthernet 0/0 internalshow cef dropshow ip interface GigabitEthernet 0/0 and show ipv6 interface GigabitEthernet 0/0 show ip cef switching statistics feature and show ipv6 cef switching statistics feature, and show ip traffic and show ipv6 traffic examples, uRPF has dropped the following packets received globally on all interfaces that have uRPF configured. The packets were dropped because of the inability to verify the source address of the IP packets within the forwarding information base of Cisco Express Forwarding.

  • 18 IPv4 packets
  • 10 IPv6 packets

Cisco IOS NetFlow and Cisco IOS Flexible NetFlow

Identifying the Effectiveness of IPv4 Traffic Flow Identification Using Cisco IOS NetFlow

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv4 traffic flows that may be attempts to exploit security vulnerabilities. Administrators are advised to investigate flows to determine whether they are attempts to exploit the vulnerabilities or whether they are legitimate traffic flows.

router#show ip cache flow
IP packet size distribution (90784136 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .698 .011 .001 .004 .005 .000 .004 .000 .000 .003 .000 .000 .000 .000
    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .001 .256 .000 .010 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 4456704 bytes
  1885 active, 63651 inactive, 59960004 added
  129803821 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 402056 bytes
  0 active, 16384 inactive, 0 added, 0 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet    11393421      2.8         1    48      3.1       0.0       1.4
TCP-FTP            236      0.0        12    66      0.0       1.8       4.8
TCP-FTPD            21      0.0     13726  1294      0.0      18.4       4.1
TCP-WWW          22282      0.0        21  1020      0.1       4.1       7.3
TCP-X              719      0.0         1    40      0.0       0.0       1.3
TCP-BGP              1      0.0         1    40      0.0       0.0      15.0
TCP-Frag         70399      0.0         1   688      0.0       0.0      22.7
TCP-other     47861004     11.8         1   211     18.9       0.0       1.3
UDP-DNS            582      0.0         4    73      0.0       3.4      15.4
UDP-NTP         287252      0.0         1    76      0.0       0.0      15.5
UDP-other       310347      0.0         2   230      0.1       0.6      15.9
ICMP             11674      0.0         3    61      0.0      19.8      15.5
IPv6INIP            15      0.0         1  1132      0.0       0.0      15.4
GRE                  4      0.0         1    48      0.0       0.0      15.3 
Total:        59957957     14.8         1   196     22.5       0.0       1.5
SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  11 0984 00A1     1 
Gi0/0         192.168.11.54   Gi0/1         192.168.60.158  11 0911 00A1     3
Gi0/1         192.168.150.60  Gi0/0         10.89.16.226    06 0016 12CA     1
Gi0/0         192.168.13.97   Gi0/1         192.168.60.28   11 0B3E 00A1     5
Gi0/0         192.168.10.17   Gi0/1         192.168.60.97   11 0B89 00A1     1
Gi0/0         10.88.226.1     Gi0/1         192.168.202.22  11 007B 007B     1
Gi0/0         192.168.12.185  Gi0/1         192.168.60.239  11 0BD7 00A1     1
Gi0/0         10.89.16.226    Gi0/1         192.168.150.60  06 12CA 0016     1
router#

In the preceding example, there are multiple flows for SNMP on UDP port 161 (hex value 00A1).

If this traffic is sourced from and sent to addresses within the 192.168.60.0/24 address block, which is used by affected devices, the packets in these flows may be spoofed and may indicate an attempt to exploit security vulnerabilities. Administrators are advised to compare these flows to baseline utilization for SNMP on UDP port 161 and also investigate the flows to determine whether they are sourced from untrusted hosts or networks.

If administrators are interested only in a specific type of TCP flow, the following example shows only the SSH packets on TCP port 22 (hex value 0016). Use the show ip cache flow | include SrcIf|_06_.*0016 command to display the related Cisco NetFlow records:

TCP Flows

router#show ip cache flow | include SrcIf|_06_.*0016
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.12.110   Gi0/1         192.168.60.163  06 092A 0016     6
Gi0/0         192.168.11.230   Gi0/1         192.168.60.20   06 0C09 0016     1
Gi0/0         192.168.11.131   Gi0/1         192.168.60.245  06 0B66 0016    18
Gi0/0         192.168.13.7     Gi0/1         192.168.60.162  06 0914 0016     1
Gi0/0         192.168.41.86    Gi0/1         192.168.60.27   06 0B7B 0016     2
router#

As shown in the following example, to view only the SNMP packets on UDP port 161 (hex value 00A1), use show ip cache flow | include SrcIf|_11_.*00A1

Note: For multiple destination ports, use the following format: show ip cache flow | include SrcIf|_PrHex_.*(DstP1Hex|DstP2Hex|DstP3Hex)_ command to display the related Cisco NetFlow records.

UDP Flows

router#show ip cache flow | include SrcIf|_11_.*00A1
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.12.110   Gi0/1         192.168.60.163  11 092A 00A1     6
Gi0/0         192.168.11.230   Gi0/1         192.168.60.20   11 0C09 00A1     1
Gi0/0         192.168.11.131   Gi0/1         192.168.60.245  11 0B66 00A1    18
Gi0/0         192.168.13.7     Gi0/1         192.168.60.162  11 0914 00A1     1
Gi0/0         192.168.41.86    Gi0/1         192.168.60.27   11 0B7B 00A1     2
router#

Identifying the Effectiveness of IPv6 Traffic Flow Identification Using Cisco IOS NetFlow

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv6 traffic flows that may be attempts to exploit security vulnerabilities. Administrators are advised to investigate flows to determine whether they are attempts to exploit vulnerabilities or whether they are legitimate traffic flows.

The following output is from a Cisco IOS device running the Cisco IOS Software 12.4 mainline train. The command syntax will vary for different Cisco IOS Software trains.

router#show ipv6 flow cache
IP packet size distribution (50078919 total packets):
   1-32  64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .990 .001 .008 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 475168 bytes
  8 active, 4088 inactive, 6160 added
  1092984 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33928 bytes
  16 active, 1008 inactive, 12320 added, 6160 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x11 0x16C4 0x13C4 1464
2001:DB...6A:5BA6 Gi0/0    2001:DB...28::21 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...134::3 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::4 Gi0/1    0x3A 0x0000 0x8000 1192 
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x13C4 1597
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x11 0x1610 0x13C5 1001 
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x11 0x1634 0x13C4 1292  
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::3 Gi0/1    0x3A 0x0000 0x8000 1155
2001:DB...6A:5BA6 Gi0/0    2001:DB...146::3 Gi0/1    0x3A 0x0000 0x8000 1092
2001:DB...6A:5BA6 Gi0/0    2001:DB...144::4 Gi0/1    0x3A 0x0000 0x8000 1193 

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

In the preceding example, there are multiple IPv6 flows for SIP on TCP port 5060 (hex value 13C4) and UDP ports 5060 (hex value 13C4) and 5061 (hex value 13C5).

If the packets on the UDP ports are sourced from and sent to addresses within the 2001:DB8:1:60::/64 address block that is used by affected devices, the packets in the UDP flows may be spoofed and could indicate an attempt to exploit security vulnerabilities. Administrators are advised to compare these flows to baseline utilization (such as SIP in the above example) and also investigate the flows to determine whether they are sourced from untrusted hosts or networks.

As shown in the following example, to view only the SIP packets on TCP port 5060 (hex value 13C4), use show ipv6 flow cache | include SrcIf|_06_.*13C4

Note: For multiple destination ports, use the following format: show ipv6 flow cache | include SrcIf|_PrHex_.*(DstP1Hex|DstP2Hex|DstP3Hex)_ command to display the related Cisco NetFlow records:

TCP Flows

router#show ipv6 flow cache | include SrcIf|_06_.*(13C4)_
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x13C4 1597
router#

As shown in the following example, to view only the SIP packets on UDP port 5060 (hex value 13C4) and UDP port 5061 (hex value 13C5), use show ipv6 flow cache | include SrcIf|_PrHex_.*(DstP1Hex|DstP2Hex)_

UDP Flows

router#show ipv6 flow cache | include SrcIf|_11_.*(13C4|13C5)_
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x11 0x16C4 0x13C4 1464 
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x11 0x1610 0x13C5 1001
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x11 0x1634 0x13C4 1292 
router#

Identifying the Effectiveness of IPv4 Traffic Flow Identification Using Cisco IOS Flexible NetFlow

Introduced in Cisco IOS Software Releases 12.2(31)SB2 and 12.4(9)T, Cisco IOS Flexible NetFlow improves original Cisco NetFlow by adding the capability to customize the traffic analysis parameters for the administrator's specific requirements. Original Cisco NetFlow uses a fixed seven tuples of IP information to identify a flow, whereas Cisco IOS Flexible NetFlow allows the flow to be user defined. It facilitates the creation of more complex configurations for traffic analysis and data export by using reusable configuration components.

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv4 flows based on source IPv4 address, as defined by the match ipv4 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv4 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.

! 
!-- Configure key and nonkey fields 
!-- in the user-defined flow record 
!
flow record FLOW-RECORD-ipv4
 match ipv4 source address
 collect ipv4 protocol
 collect ipv4 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
! 
!-- Configure the flow monitor to 
!-- reference the user-defined flow 
!-- record 
!
flow monitor FLOW-MONITOR-ipv4
 record FLOW-RECORD-ipv4
! 
!-- Apply the flow monitor to the interface 
!-- in the ingress direction 
!
interface GigabitEthernet0/0
 ip flow monitor FLOW-MONITOR-ipv4 input

The Cisco IOS Flexible NetFlow flow output is as follows:

router#show flow monitor FLOW-MONITOR-ipv4 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                1
  Flows added:                                   9181
  Flows aged:                                    9175
    - Active timeout      (  1800 secs)          9000
    - Inactive timeout    (    15 secs)           175
    - Event aged                                    0
    - Watermark aged                                0
    - Emergency aged                                0
IPV4 SRC ADDR   ipv4 dst addr   trns src port trns dst port intf input intf output pkts   ip prot
=============== =============== ============= ============= ========== =========== ====== =======
 192.168.10.201  192.168.60.102          1456            80      Gi0/0       Gi0/1   1128      6
 192.168.11.54   192.168.60.158           123           123      Gi0/0       Gi0/1   2212     17
 192.168.150.60    10.89.16.226          2567           443      Gi0/0       Gi0/1     13      6
 192.168.13.97    192.168.60.28          3451            80      Gi0/0       Gi0/1      1      6
 192.168.10.17    192.168.60.97          4231          5060      Gi0/0       Gi0/1    146     17
   10.88.226.1   192.168.202.22          2678           443      Gi0/0       Gi0/1  10567      6
  10.89.16.226   192.168.150.60          3562            80      Gi0/0       Gi0/1  30012      6

To view only the packets on TCP port 80, use the show flow monitor FLOW-MONITOR-ipv4 cache format table | include IPV4 DST ADDR |_(80)_.*_6_ command to display the related NetFlow records.

For more information about Cisco IOS Flexible NetFlow, see Flexible Netflow Configuration Guide, Cisco IOS Release 15M&T.

Identifying the Effectiveness of IPv6 Traffic Flow Identification Using Cisco IOS Flexible NetFlow

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv6 flows based on the source IPv6 address, as defined by the match ipv6 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv6 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.

! 
!-- Configure key and nonkey fields 
!-- in the user-defined flow record 
!
flow record FLOW-RECORD-ipv6
 match ipv6 source address
 collect ipv6 protocol
 collect ipv6 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
! 
!-- Configure the flow monitor to 
!-- reference the user-defined flow 
!-- record 
!
flow monitor FLOW-MONITOR-ipv6
 record FLOW-RECORD-ipv6
! 
!-- Apply the flow monitor to the interface 
!-- in the ingress direction 
!
interface GigabitEthernet0/0
  ipv6 flow monitor FLOW-MONITOR-ipv6 input

The Cisco IOS Flexible NetFlow flow output is as follows:

router#show flow monitor FLOW-MONITOR-ipv6 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                2
  Flows added:                                   539
  Flows aged:                                    532
    - Active timeout      (  1800 secs)          350
    - Inactive timeout    (    15 secs)          182
    - Event aged                                   0
    - Watermark aged                               0
    - Emergency aged                               0
IPV6 SRC ADDR     ipv6 dst addr     trns src port trns dst port intf input intf output pkts ip prot
================= ================= ============= ============= ========== =========== ==== =======
2001:DB...06::201  2001:DB...28::20           123           123      Gi0/0       Gi0/0   17      17
2001:DB...06::201  2001:DB...28::20          1265            80      Gi0/0       Gi0/0 1237       6
2001:DB...06::201  2001:DB...28::20          1441           443      Gi0/0       Gi0/0 2346       6
2001:DB...06::201  2001:DB...28::20          1890            80      Gi0/0       Gi0/0 5009       6
2001:DB...06::201  2001:DB...28::20          2856          5060      Gi0/0       Gi0/0  486      17
2001:DB...06::201  2001:DB...28::20          3012            53      Gi0/0       Gi0/0 1016      17
2001:DB...06::201  2001:DB...28::20          2477            53      Gi0/0       Gi0/0 1563      17

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

To view only the packets on TCP port 443, use the show flow monitor FLOW-MONITOR-ipv6 cache format table | include IPV6 DST ADDR|_(443)_.*_6_ command to display the related Cisco IOS Flexible NetFlow records.

Cisco IOS Software Zone-Based Firewall

Identifying the Effectiveness of Cisco IOS Software Zone-Based Firewall on Cisco IOS Routers

The Cisco IOS Software Zone-Based Firewall is an advanced stateful firewall method for Cisco IOS routers. It changes the older Context-Based Access Control (CBAC ) to a more flexible zone-based model that employs inter-zone policies for more flexibility and granularity.

The following example shows a configuration for the Zone-Based Firewall. Traffic may be initiated only from the private to public zone for SIP, and all other traffic will be dropped for either direction, inbound or outbound. The example shows 4 dropped packets for the default drop action.

router#show policy-map type inspect zone-pair
Zone-pair: priv-pub
  Service-policy inspect : priv-pub-pmap
     Class-map: private-sip (match-all)
       Match: protocol sip
       Inspect
         Packet inspection statistics [process switch:fast switch]
         udp packets: [8800:70]
         Session creations since subsystem startup or last reset 731
         Current session counts (estab/half-open/terminating) [0:0:0]
         Maxever session counts (estab/half-open/terminating) [0:3:0]
         Last session created 00:00:25
         Last statistic reset never
         Last session creation rate 0
         Maxever session creation rate 4
         Last half-open session total 0
     Class-map: class-default (match-any)
       Match: any 
       Drop (default action)
         4 packets, 112 bytes

Conclusion

In summary, network administrators and security engineers can use the vulnerability exploit attempt identification techniques presented in this document to identify vulnerability exploit attempts. These techniques can be leveraged by using the attack vector characteristics of the vulnerability investigated in place of the example attack vectors used in the document. Administrators can then ensure that the exploit attempts do not have any impact on the network.

Additional Information

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of vulnerabilities. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Resources

 


This document is part of the Cisco Security portal. Cisco provides the official information contained on the Cisco Security portal in English only.

This document is provided on an “as is” basis and does not imply any kind of guarantee or warranty, including the warranties of merchantability or fitness for a particular use. Your use of the information in the document or materials linked from the document is at your own risk. Cisco reserves the right to change or update this document without notice at any time.


Back to Top