[an error occurred while processing this directive]
日本語マニュアル一覧
スイッチ
Catalyst 3750 Metro シリーズ
Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)EY
はじめに
このマニュアルについて
図一覧
表一覧
概要
CLIの使用方法
スイッチのIPアドレスおよびデフォルト ゲートウェイの割り当て
スイッチのクラスタ設定
IE2100 CNSエージェントの設定
スイッチの管理
SDMテンプレートの設定
スイッチベースの認証の設定
802.1xポートベースの認証の設定
インターフェイス特性の設定
SmartPortマクロの設定
VLANの設定
VTPの設定
プライベートVLANの設定
音声VLANの設定
IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定
STPの設定
MSTPの設定
オプションのスパニングツリー機能の設定
Flex Linkの設定
DHCP機能およびIPソース ガードの設定
ダイナミックARP検査の設定
IGMPスヌーピングおよびMVRの設定
ポートベースのトラフィック制御の設定
CDPの設定
UDLDの設定
SPANおよびRSPANの設定
RMONの設定
システム メッセージ ロギングの設定
SNMPの設定
ACLによるネットワーク セキュリティの設定
QoSの設定
EtherChannelの設定
IPユニキャスト ルーティングの設定
HSRPの設定
MPLSおよびEoMPLSの設定
IPマルチキャスト ルーティングの設定
MSDPの設定
代替ブリッジングの設定
トラブルシューティング
サポートされているMIB
Cisco IOSファイル システム、コンフィギュレーション ファイル、およびソフトウェア イメージの操作
Cisco IOS Release12.2(25)EYでサポートされていないコマンド

スイッチ
Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)EY

この章では、Catalyst 3750 MetroスイッチにMultiprotocol Label Switching(MPLS;マルチプロトコル ラベル スイッチング)およびEthernet over MPLS(EoMPLS)を設定する方法について説明します。MPLSは、リンク レイヤ(レイヤ2)スイッチングとネットワーク レイヤ(レイヤ3)ルーティングを統合するパケットスイッチング テクノロジーです。MPLSがイネーブルの場合、データは任意のレイヤ3プロトコルを使用し、複数のレイヤ2テクノロジーを任意に組み合わせて転送されるため、スケーラビリティが高まります。MPLSは、ルータベース インターネット バックボーンを介して送信元と宛先を接続する複数のルートをサポートします。

EoMPLSは、MPLSネットワークを介してレイヤ2イーサネット フレームをトランスポートするトンネリング メカニズムです。ブリッジ、ルータ、またはスイッチを配置しなくても、離れた位置にある2つのレイヤ2ネットワークを接続することができます。MPLSバックボーンをイネーブルにして、レイヤ2トラフィックを受信できるようにするには、MPLSバックボーンの両端にあるLabel Edge Router(LER;ラベル エッジ ルータ)を設定します。

MPLS機能がサポートされるのはEnhanced-Services(ES)ポート上のみです。EoMPLSは標準ポートおよびESポート上でサポートされます。

MPLSの詳細については、『 Cisco IOS Switching Services Configuration Guide 』Release 12.2の
「Multiprotocol Label Switching」を参照してください。この章で使用するMPLSコマンドの構文および使用方法の詳細については、『 Cisco IOS Switching Services Command Reference 』Release 12.2を参照してください。EoMPLSコマンドの詳細については、このリリースのコマンド リファレンスを参照してください。

この章で説明する内容は、次のとおりです。

MPLSサービスの概要
MPLS VPNの概要
MPLS VPNの設定
EoMPLSの概要
EoMPLSのイネーブル化
MPLSおよびEoMPLS QoSの設定
MPLSおよびEoMPLSのモニタおよびメンテナンス

MPLSサービスの概要

従来のレイヤ3転送では、パケットがネットワークを通過するときに、各ルータでレイヤ3ヘッダーからパケット転送情報を抽出します。この情報をインデックスに使用して、ルーティング テーブル検索を実行し、パケットのネクスト ホップを判別します。通常はヘッダー内の宛先アドレス フィールドのみが関連しますが、他のヘッダー フィールドが関連することもあります。このため、パケットが通過する各ルータではパケット ヘッダーを分析する必要があります。

MPLSを使用すると、レイヤ3ヘッダーは1回のみ分析され、構造化されていない固定長の値( ラベル )にマッピングされます。複数の異なるヘッダーで同じネクスト ホップが選択される場合は、これらのヘッダーを同じラベルにマッピングすることができます。実際は、ラベルは 転送同等クラス を表します。つまり、外見が異なるにもかかわらず、転送機能に関して区別できない一連のパケットを表します。

最初のラベル選択は、レイヤ3ヘッダーの内容のみを基準として行うことができます。また、ポリシーを基準とすることにより、後続ホップでの転送判断をポリシーベースで行うこともできます。ラベルが選択されると、レイヤ3パケットの前に短いラベル ヘッダーが付加され、パケットの一部としてネットワーク内で伝達されます。ネットワーク内の各MPLSルータを経由する後続ホップでは、ラベルが交換されます。ルータはラベルに関するMPLS転送テーブル検索を実行して、転送判断を行います。パケット ヘッダーを再び分析する必要はありません。ラベルは構造化されていない固定長の値であるため、MPLS転送テーブル検索プロセスは簡単かつ高速です。

ネットワーク内の各Label Switching Router(LSR;ラベル スイッチング ルータ)は、転送同等クラスを表すために使用されるラベル値に関して、独立したローカルな判断を行います。この対応関係は、 ラベル バインディング といいます。各LSRは、自身が行ったラベル バインディングをネイバに通知します。ラベルの付いたパケットがLSR Aから近接するLSR Bに送信されると、パケットで伝達されるラベル値は、パケットの転送同等クラスを表すためにBが割り当てたラベル値になります。このため、IPパケットがネットワークを通過するにつれて、ラベル値は変更されます。

Catalyst 3750 Metroスイッチはサービスプロバイダー コア ルータとしてでなく、サービスプロバイダー エッジのcustomer-located equipment(PE-CLE)として使用されるため、LSRとして正常に動作しません。スイッチがラベル スイッチングを実行するのは、ESポートを介して2つの異なるプロバイダー コア ルータに接続されて、冗長パスを実現している場合のみです。この場合、スイッチはQuality of Service(QoS;サービス品質)ポリシーを使用して出力側でMPLSパケットを分類し、ラベル スイッチングを行います。

ラベルは転送同等クラスを表しますが、ネットワーク内の特定のパスは表しません。一般に、ネットワーク内のパスは Open Shortest Path First(OSPF)、Enhanced Interior Gateway Protocol(EIGRP)、
Intermediate-System-to-Intermediate-System(IS-IS)、Border Gateway Protocol(BGP)など、既存のレイヤ3ルーティング プロトコルによって常に選択されます。各ホップでラベルを検索する場合、ネクスト ホップはダイナミック ルーティング アルゴリズムによって決定されます。

MPLS VPNの概要

MPLS Virtual Private Network(VPN;仮想私設網)を使用すると、ビジネス カスタマー向けにスケーラブルなレイヤ3 VPNバックボーン サービスを導入したり、管理することができます。VPNは、1つまたは複数の物理ネットワーク上でリソースを共有するセキュアなIPベース ネットワークです。VPNに含まれる地理的に離れたサイトでは、共有バックボーンを介して安全に通信することができます。

VPNルートはMultiprotocol BGP(MP-BGP)を使用して、MPLSネットワークを介して配信されます。MP-BGPは各VPNルートに対応付けられたラベルも配信します。MPLS VPNはVPN
Routing/Forwarding(VRF)サポートを使用して、ルーティング ドメインを相互に隔離します。MPLS VPNを介してルートが取得された場合、スイッチは新しいルートを標準VRFルートとして学習します。ただし、ネクスト ホップの宛先MAC(メディア アクセス制御)アドレスは実際のアドレスでなく、ルートに割り当てられたIDを含む特殊な形式のアドレスです。MPLS-VPNパケットがポートに着信すると、スイッチはルーティング テーブル内でラベルを検索し、パケットの処理内容を決定します。

各VPNは1つまたは複数のVPN VRFインスタンスに対応付けられます。VRFにはルーティング テーブル、転送テーブル、およびCustomer Edge(CE;カスタマー エッジ)デバイスに接続されたカスタマー デバイスのVPNメンバーシップを定義する規則が格納されています。カスタマー サイトは複数のVPNに属することができますが、1つのサイトに対応付けることができるVRFは1つのみです。VRFには次の要素があります。

IPルーティング テーブル
Cisco Express Forwarding(CEF)テーブル
CEF転送テーブルを使用するインターフェイスのセット
ルーティング テーブル内の情報を制御する規則およびルーティング プロトコル パラメータのセット

カスタマーサイトVRFには、そのサイトで使用可能な、そのサイトが属するVPNのすべてのルートが格納されます。VPNルーティング情報は、各VRFのIPルーティング テーブルおよびCEFテーブルに格納されます。各テーブル セットはVRFごとに維持されます。これにより、情報がVPN外部に転送されたり、VPN外部のパケットがVPN内のルータに転送されることがなくなります。パケットはVRF IPルーティング テーブルおよびVRF CEFテーブルに格納されたルーティング情報に基づいて、宛先に転送されます。

PEルータはCEデバイスから取得された各カスタマー プレフィクスにラベルをバインドし、他のPEルータにアドバタイズされるプレフィクスのネットワーク到達可能性情報にラベルを追加します。プロバイダー ネットワークを介してCEデバイスから着信したパケットがPEルータによって転送されると、そのパケットには宛先PEルータから取得されたラベルが付加されます。宛先PEルータは、ラベルの付いたパケットを受信すると、ラベルを調べて、正しいCEデバイスにパケットを転送するために使用します。バックボーンを通過するカスタマー データパケットが伝達するラベルには、2つのレベルがあります。

上位ラベルは正しいPEルータにパケットを転送します。
2番めのラベルは、PEルータがCEデバイスにパケットを転送する方法を定義します。

VPNの利点

MPLS VPNを使用すると、サービス プロバイダーはスケーラブルなVPNを導入したり、次のような付加価値のあるサービスを提供するための基礎を構築することができます。

コネクションレス サービス ― MPLS VPNはコネクションレスです。つまり、ホスト間の通信を確立する場合に、事前の処理が不要です。コネクションレスVPNでは、トンネルおよび暗号化を使用してネットワークのプライバシーを確保する必要がありません。
中央集中型サービス ― MPLS VPNはプライベート イントラネットとして使用されます。プライベート イントラネットでは、VPNで表されるユーザ グループに目的のIPサービスを提供することができます。
スケーラビリティ ― MPLSベースVPNではピア モデルおよびレイヤ3コネクションレス アーキテクチャを使用して、スケーラビリティの高いソリューションを利用することができます。ピア モデルでは、カスタマー サイトは1つのPEルータに対するピアとして機能する必要があります。これは、VPNに属する他のすべてのカスタマーPEデバイスまたはCEデバイスと異なります。PEルータには、メンバーであるVPNのVPNルートが保持されます。コア ネットワーク内のルータには、VPNルートは保持されません。
セキュリティ ― MPLS VPNはコネクション型VPNと同じレベルのセキュリティを提供します。特定のVPNからのパケットが、誤って別のVPNに送信されることはありません。プロバイダー ネットワークのエッジに実装されたセキュリティにより、カスタマーから着信したパケットは正しいVPNに送信されます。バックボーンに実装されたセキュリティにより、VPNトラフィックは互いに分離されます。
作成が容易 ― MPLS VPNはコネクションレスであるため、特定のポイントツーポイント接続マップやトポロジーは不要です。サイトをイントラネットおよびエクストラネットに追加して、閉じたユーザ グループを形成することができます。
柔軟なアドレス指定 ― Network Address Translation(NAT;ネットワーク アドレス変換)を使用しなくても、カスタマーは引き続き現在のアドレス スペースを使用することができます。MPLS VPNによって、パブリック アドレスとプライベート アドレスが対応付けられるためです。NATが必要となるのは、アドレス スペースが重複する2つのVPNが通信する場合のみです。
移行が容易 ― 複数のネットワーク アーキテクチャ上にMPLS VPNを構築することができます。MPLSをサポートするためにCEルータを配置したり、カスタマーのイントラネットを変更する必要がないため、エンド カスタマーは簡単に移行することができます。
MPLS VPNを導入すると、BGPの機能も拡張されます。

図36-1 に、サービスプロバイダー バックボーン ネットワーク、PE-CLEルータ、およびCEデバイスを含むVPNの例を示します。

図36-1 VPNおよびサービス プロバイダー バックボーン

各VPNには、CEデバイスに接続されたカスタマー デバイスが含まれています。カスタマー デバイスはVPNを使用してデバイス間で情報を交換します。プロバイダー ルータ(P)はVPNを認識しません。

図36-2 に、3つのVPN内で通信を行う5つのカスタマー サイトを示します。VPNは次のサイトと通信することができます。

VPN1:サイト2および4

VPN2:サイト1、3、および4

VPN3:サイト1、3、および5

図36-2 カスタマー サイトおよびVPN

VPNルーティング情報の配信

VPNルーティング情報の配信を制御するには、BGP拡張コミュニティによって実装されるVPNルート ターゲット コミュニティを使用します。VPNルーティング情報は、次の方法で配信されます。

CEデバイスから取得されたVPNルートがBGPプロセスに追加されると、VPNルート ターゲット拡張コミュニティ アトリビュートのリストがVPNルートに対応付けられます。アトリビュート値は、ルート取得元のVRFに対応付けられたルート ターゲットのエクスポート リストから取得されます。
各VRFには、ルート ターゲット拡張コミュニティのインポート リストも対応付けられます。インポート リストは、ルートをVRFにインポートする場合にルータに格納されていなければならないルート ターゲット拡張コミュニティ アトリビュートを定義します。たとえば、特定のVRFのインポート リストにルート ターゲット コミュニティA、B、およびCが含まれている場合、これらのルート ターゲット拡張コミュニティ(A、B、またはC)のいずれかを伝達するすべてのVPNルートが、このVRFにインポートされます。

PEルータはスタティックな設定を使用してCEデバイスからIPプレフィクスを取得することができます。そのためには、CEデバイスとのBGPセッション、またはCEルータとのRouting Information Protocol(RIP)交換を使用します。IPプレフィクスはIPv4アドレス ファミリーのメンバーです。IPプレフィクスを取得すると、PEルータはIPプレフィクスと8バイトのRoute Distinguisher(RD)を組み合わせて、IPプレフィクスをVPN-IPv4プレフィクスに変換します。生成されたプレフィクスはVPN-IPv4アドレス ファミリーのメンバーです。カスタマー サイトがグローバルに一意でない(未登録のプライベート)IPアドレスを使用している場合でも、カスタマー アドレスを一意に識別します。

BGPは、VPNごとにVPN-IPv4プレフィクスの到達可能性情報を配信します。BGP通信は、IPドメイン内(別名Autonomous System[AS;自律システム])(Internal BGP[IBGP])およびAS間(External BGP[EBGP])の2つのレベルで実行されます。PE/PEセッションはIBGPセッションです。PE/CEセッションはEBGPセッションです。

BGPは、IPv4以外のアドレス ファミリーのサポートを定義するBGPマルチプロトコル拡張機能を使用して、PEルータ間でVPN-IPv4プレフィクスの到達可能性情報を伝播します。この方法では、指定されたVPNのルートは、このVPNの他のメンバーによってのみ学習されるため、VPNのメンバー間で相互に通信できます。

MPLS VPNの設定

ここでは、PEルータとして使用されるCatalyst 3750 MetroスイッチにMPLS VPNを設定する方法について説明します。

MPLSのデフォルト設定
MPLS VPN設定時の注意事項

ここでは、必要な作業について説明します。

MPLSのイネーブル化
VPNの定義
BGPルーティング セッションの設定
PE/PEルーティング セッションの設定

PE/CEルーティング セッションも設定する必要があります。ここでは、設定例を示します。

BGP PE/CEルーティング セッションの設定
RIP PE/CEルーティング セッションの設定
スタティック ルートPE/CEルーティング セッションの設定

MPLS VPN内のパケット フローの例については、 MPLS VPN内のパケットフロー を参照してください。

MPLSのデフォルト設定

通常のルーテッド パスでのIPv4パケットのラベル スイッチングは、デフォルトでグローバルにイネーブル化されています。インターフェイスでのIPv4パケットのMPLS転送は、デフォルトでディセーブルです。

mpls label protocol グローバル コンフィギュレーション コマンドで配信プロトコルが明示的に設定されていない場合は、Tag Distribution Protocol(TDP)がスイッチのデフォルトのラベル配信プロトコルになります。MPLSを使用する場合は、Label Distribution Protocol(LDP)を設定することを推奨します。

インターフェイスにプロトコルが明示的に設定されていない場合は、スイッチのデフォルトのラベル配信プロトコルが使用されます。デフォルトでは、すべての宛先のラベルがすべてのLDPネイバにアドバタイズされます。

VRFは未定義です。インターフェイスのデフォルト ルーティング テーブルは、グローバル ルーティング テーブルです。

MPLS VPN設定時の注意事項

MPLSを使用するには、スイッチ上でCEFをイネーブルにする必要があります。CEFはデフォルトでイネーブルに設定されています。CEFの詳細については、 「CEF の設定」 を参照してください。

スイッチはESポートを介してMPLSネットワークと接続する必要があります。MPLS設定がサポートされるのは、ESポートのみです。

MPLSが設定されているインターフェイスには、VLAN(仮想LAN)マッピングを設定しないでください。

スイッチは合計26個のVRFおよびVPNをサポートします。

VRFはPBRテンプレートと互換性がありません。 sdm prefer routing-pbr コマンドを入力してPBRテンプレートを設定した場合は、コンフィギュレーションから設定済みVRFがすべて削除されます。PBRおよびVRFを同じスイッチ上で機能させることはできません。

MPLSのイネーブル化

図36-1 のようなネットワーク内でMPLSを使用する場合は、MPLSをグローバルにイネーブル化し、PE-CLEルータ上で明示的に設定する必要があります。

すべての宛先プレフィクスへのパケットに対してラベルスイッチングを行う場合に、ネットワークを介してMPLSを追加導入するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip cef

デバイス上でCEFがディセーブルの場合は、イネーブルにします。

ステップ 3

mpls ip

通常のルーテッド パスでIPv4パケットのMPLS転送がディセーブルの場合は、イネーブルにします。

ステップ 4

mpls label protocol ldp

スイッチのラベル プロトコルをLDPに設定します。デフォルト プロトコルはTDPです。

ステップ 5

mpls ldp advertise-labels [ for prefix-access-list [ to peer-access-list ]]

スイッチ上でMPLSラベル アドバタイズをイネーブルにします。キーワードを指定しない場合は、アドバタイズされるラベルに制限は課せられません。

(任意) for prefix-access-list ― ラベルをアドバタイズする必要がある宛先を指定します。
(任意) to peer-access-list ― ラベル アドバタイズを受信する必要があるLDPネイバを指定します。LSRは、6バイトのLDP IDの最初の4バイトからなるルータIDによって識別されます。

ステップ 6

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、MPLSネットワークに接続されているレイヤ3 ESインターフェイスを指定します。

ステップ 7

mpls ip

インターフェイスの通常のルーテッド パスでIPv4パケットのMPLS転送をイネーブルにします。

ステップ 8

end

イネーブルEXECモードに戻ります。

ステップ 9

show mpls forwarding table

show mpls interfaces

設定を確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ネットワーク内のすべてのPE-CLEルータおよび該当するインターフェイスに対して上記ステップを繰り返し、すべてのルータおよび接続先インターフェイスをMPLSに対してイネーブルに設定します。

スイッチ上でMPLSをディセーブルにするには、 no mpls ip グローバル コンフィギュレーション コマンドを使用します。デフォルトTDPに戻すには、 no mpls label protocol ldp グローバル コンフィギュレーション コマンドを使用します。

VPNの定義

PE-CLEルータ上でVPNルーティング インスタンスを定義するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip routing

IPルーティングをイネーブルにします(IPルーティングがディセーブルになっている場合にのみ必須)。

ステップ 3

ip vrf vrf-name

VRFコンフィギュレーション モードを開始し、VRF名を割り当ててVPNルーティング インスタンスを定義します。

ステップ 4

rd route-distinguisher

RDを指定して、VRFテーブルを作成します。AS番号と任意の番号(xxx:y)、またはIPアドレスと任意の番号(A.B.C.D:y)を入力します。

ステップ 5

route-target { export | import | both } route-target-ext-community

指定されたVRFのインポート、エクスポート、またはインポート/エクスポート ルート ターゲット コミュニティのリストを作成します。AS番号と任意の番号(xxx:y)、またはIPアドレスと任意の番号(A.B.C.D:y)を入力します。 route-target-ext-community に、ステップ4で入力した route-distinguisher と同じ値を設定する必要があります。

ステップ 6

import map route-map

(任意)VRFに、指定されたインポート ルート マップを関連付けます。

ステップ 7

export map route-map

(任意)VRFに、指定されたエクスポート ルート マップを関連付けます。

ステップ 8

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、VRFに関連付けるレイヤ3 ESまたはVLANインターフェイスを指定します。

ステップ 10

ip vrf forwarding vrf-name

VRFにレイヤ3インターフェイスを関連付けます。

ステップ 11

end

イネーブルEXECモードに戻ります。

ステップ 12

show ip vrf

定義されたVRFおよびインターフェイスを表示します。

ステップ 13

show ip route vrf

show ip cef vrf vrf-name

VRFのIPルーティング テーブルを表示します。

VRFに関連付けられたCEF転送テーブルを表示します。

ステップ 14

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VRFを削除し、VRFからすべてのインターフェイスを削除するには、 no ip vrf vrf-name グローバル コンフィギュレーション コマンドを使用します。VRFから特定のインターフェイスを削除するには、 no ip vrf forwarding インターフェイス コンフィギュレーション コマンドを使用します。

BGPルーティング セッションの設定

プロバイダー ネットワークにBGP ルーティング セッションを設定するには、PE-CLEルータ上でイネーブルEXECモードを開始し、次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip routing

IPルーティングをイネーブルにします(IPルーティングがディセーブルになっている場合にのみ必須)。

ステップ 3

router bgp autonomous-system-number

BGPルーティング プロセスをイネーブルにし、他のBGPルータに渡されたAS番号を割り当てて、ルータ コンフィギュレーション モードを開始します。指定できるAS番号は1〜65535です。64512〜65535は、プライベートAS番号専用です。

ステップ 4

neighbor { ip-address | peer-group-name } remote-as as-number

ローカルASに対して識別されるネイバIPアドレスまたはBGPピア グループを指定します。指定できるAS番号の範囲は1〜65535です。

ステップ 5

neighbor ip-address activate

IPv4アドレス ファミリーのアドバタイズをアクティブにします。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show ip bgp neighbor

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

BGPルーティング セッションを削除するには、 no router bgp autonomous-system グローバル コンフィギュレーション コマンドを使用します。

PE/PEルーティング セッションの設定

IBGPを使用するプロバイダー ネットワークにPE/PEルーティング セッションを設定するには、PE-CLEルータ上でイネーブルEXECモードを開始し、次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

ルータ コンフィギュレーション モードを開始します。

ステップ 3

address-family vpnv4 [ unicast ]

アドレス ファミリー コンフィギュレーション モードを開始して、標準VPNv4アドレス プレフィクスを使用するルーティング セッションを設定します。

(任意) unicast ― VPNv4ユニキャスト アドレス プレフィクスを指定します。

ステップ 4

neighbor ip-address remote-as as-number

PEルータ間のIBGPセッションを定義します。

ステップ 5

neighbor ip-address activate

IPv4アドレス ファミリーのアドバタイズをアクティブにします。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show ip bgp [ ipv4 ] [ neighbors ] [ vpnv4 ]

BGPの設定を確認します。すべてのBGP IPv4プレフィクスの情報を表示します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

BGPルーティング セッションを削除するには、 no router bgp autonomous-system グローバル コンフィギュレーション コマンドを使用します。

BGP PE/CEルーティング セッションの設定

BGP PE/CEルーティング セッションを設定するには、PE-CLEルータ上でイネーブルEXECモードを開始し、次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

BGPルーティング プロセスに、他のBGPルータに渡されたAS番号を設定して、ルータ コンフィギュレーション モードを開始します。

ステップ 3

address-family ipv4 [ unicast ] vrf vrf-name

PE/CEルーティング セッション用のEBGPパラメータを定義して、VRFアドレスファミリー コンフィギュレーション モードを開始します。

(注) VRFアドレスファミリー コンフィギュレーション モードでの自動サマリーおよび同期については、デフォルトは off です。

ステップ 4

neighbor address remote-as as-number

PEおよびCEルータ間のEBGPセッションを定義します。

ステップ 5

neighbor address activate

IPv4アドレス ファミリーのアドバタイズをアクティブにします。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show ip bgp [ ipv4 ] [ neighbors ]

BGPの設定を確認します。すべてのBGP IPv4プレフィクスの情報を表示します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

BGPルーティング セッションを削除するには、 no router bgp as-number グローバル コンフィギュレーション コマンドを使用します。

RIP PE/CEルーティング セッションの設定

PE/CEルーティング セッションには、OSPFルーティング プロトコルも使用できます。

RIP PE/CEルーティングを設定するには、PE-CLEルータ上でイネーブルEXECモードを開始し、次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router rip

RIPルーティングをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

ステップ 3

address-family ipv4 [ unicast ] vrf -name

PE/CEルーティング セッション用のRIPパラメータを定義して、VRFアドレスファミリー コンフィギュレーション モードを開始します。

(注) VRFアドレスファミリー コンフィギュレーション モードでの自動サマリーおよび同期については、デフォルトは off です。

ステップ 4

network prefix

PE/CEリンク上でRIPをイネーブルに設定します。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show ip rip database [ network-prefix ]

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

RIPルーティングをディセーブルにするには、 no router rip グローバル コンフィギュレーション コマンドを使用します。

スタティック ルートPE/CEルーティング セッションの設定

スタティック ルーティングを設定するには、PE-CLEルータ上でイネーブルEXECモードを開始し、次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip route vrf vrf-name prefix mask

PE/CEセッションに使用するVRFスタティック ルーティング テーブルを定義します。

ステップ 3

router bgp autonomous-system-number

BGPルーティング プロセスAS番号を入力し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv4 [ unicast ] vrf vrf-name

PE/CEルーティング セッションごとにスタティック ルート パラメータを定義して、VRFアドレスファミリー コンフィギュレーション モードを開始します。

(注) VRFアドレスファミリー コンフィギュレーション モードでの自動サマリーおよび同期については、デフォルトは off です。

ステップ 5

redistribute static

VRFスタティック ルートをVRF BGPテーブルに再配信します。

ステップ 6

redistribute connected

直接接続されたネットワークをVRF BGPテーブルに再配信します。

ステップ 7

end

イネーブルEXECモードに戻ります。

ステップ 8

show ip bgp [ ipv4 ]

設定を確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

MPLS VPN内のパケットフロー

図36-3 に、MPLS VPNネットワークの2つのカスタマー サイト間のパケット フローの例を示します。

図36-3 MPLS VPNパケット フローの例

スイッチPE1のカスタマー(ファスト イーサネット)ポートは、VPNでのルーテッド動作用に設定されています。このポートではスタティック ルーティングまたはルーティング プロトコル(RIP、OSPF、EIGRP、またはBGP)を使用して、パケットを転送します。カスタマーのVPNに関連付けられたRDを持つPE1スイッチのESポートには、MP-BGPが設定されています。MP-BGPは、このRDを使用しているESポートを介して、ルートおよび関連付けられたVPNラベルを再配信するように設定されています。

パケット フローに関する手順は、次のとおりです。

ステップ 1 PEスイッチPE1(Catalyst 3750 Metroスイッチなど)は、サイト1のカスタマー スイッチからパケットを受信します。スイッチは検索テーブルから、VRFがMPLSを実行しているVLANであることを判別し、MPLS検索テーブルを使用して、パケットの処理内容を判別します。MPLS検索テーブルには、宛先MACアドレスとしてピアLSR、および送信元MACアドレスとしてローカル インターフェイスが格納されています。

ステップ 2 PE1は適切なネクスト ホップおよびラベルが設定されたBGPルートを検出し、パケットに適切なラベルを追加して、ESポートからネクスト ホップ ルータ(P3)にパケットを転送します。

ステップ 3 P3ルータはこのパケットを受信し、パケットの上位ラベル(Interior Gateway Protocol [IGP;内部ゲートウェイ プロトコル])に基づいてMPLS-VPNネットワークを介してパケットを転送してから、上位ラベルを削除します。

ステップ 4 PE3はパケットを受信し、MPLSカプセル化を解除して、パケットを転送します。転送する場合は、宛先としてCEスイッチCE2が設定されたパケット内のVPNラベルに関連付けられたVRFインターフェイスを使用します。

EoMPLSの概要

Any Transport over MPLS(AToM)はMPLSネットワーク上でレイヤ2パケットをトランスポートするためのソリューションです。サービス プロバイダーはMPLSネットワークを使用して、既存のレイヤ2ネットワークが設定されたカスタマー サイト間を接続することができます。サービス プロバイダーは、ネットワーク管理環境によってネットワークを分離しなくても、MPLSネットワークを使用して、各カスタマーにすべてのタイプのトラフィックをトランスポートすることができます。Catalyst 3750 MetroスイッチはEoMPLSをサポートします。EoMPLSは、トンネリング メカニズムを使用してレイヤ2イーサネット トラフィックを伝送するAToMのサブセットです。EoMPLSはイーサネット フレームをMPLSパケットにカプセル化して、MPLSネットワーク内で転送します。各フレームは単一のパケットとしてトランスポートされます。バックボーンに接続されたPEルータは、必要に応じてパケット カプセル化用ラベルを追加したり、削除したりします。

入力PEルータはイーサネット フレームを受信し、プリアンブル、Start of Frame Delimiter(SFD)、およびFrame Check Sequence(FCS)を削除して、パケットをカプセル化します。それ以外のパケット ヘッダーは変更されません。
入力PEルータはポイントツーポイントVirtual Connection(VC)ラベルおよびLabel Switched Path(LSP;ラベル スイッチド パス)トンネル ラベルを追加して、MPLSバックボーンを介して通常のMPLSルーティングを行います。
ネットワーク コア ルータはLSPトンネル ラベルを使用して、MPLSバックボーンを介してパケットを送信します。MPLSバックボーンでは、イーサネット トラフィックと他のタイプのパケットを区別しません。
MPLSバックボーンの反対側では、出力PEルータがパケットを受信し、LSPトンネル ラベルが付加されている場合はこれを削除して、パケットのカプセル化を解除します。PEルータは、パケットからVCラベルも削除します。
PEルータは必要に応じてヘッダーを更新し、該当するインターフェイスから宛先スイッチにパケットを送信します。

MPLSバックボーンはトンネル ラベルを使用して、PEルータ間でパケットをトランスポートします。出力PEルータはVCラベルを使用して、イーサネット パケットの発信インターフェイスを選択します。EoMPLSトンネルは単一方向です。双方向のEoMPLSを実現するには、各方向にトンネルを1つずつ設定する必要があります。

ポイントツーポイントVCを使用するには、2つのPEルータにVCエンドポイントを設定する必要があります。レイヤ2トラフィックのトランスポート専用VCに関する情報を取得するのは、MPLSバックボーンの入口および出口にあるPEルータのみです。その他のルータには、これらのVCのテーブル エントリは格納されません。

ここでは、次の内容について説明します。

他の機能との相互作用
EoMPLSの制限

他の機能との相互作用

ここでは、EoMPLSと他の機能との相互作用について説明します。具体的な内容は次のとおりです。

EoMPLSおよび802.1Qトンネリング
EoMPLSおよびレイヤ2トンネリング
EoMPLSおよびQoS

EoMPLSおよび802.1Qトンネリング

IEEE 802.1Qトンネリングを使用すると、サービス プロバイダーは単一のVLANを使用して、複数のVLANを持つカスタマーをサポートすることができます。この際に、カスタマーのVLAN IDは保護され、複数のVLANのトラフィックが集約されます。802.1Qトンネリングの詳細については、 第16 章「IEEE 802.1Q およびレイヤ2 プロトコルトンネリングの設定」 を参照してください。

図36-4 に、MPLSネットワーク上でEoMPLSを使用して、802.1Qトンネリング トラフィックを転送する設定の例を示します。PE-CLEとして機能するスイッチを介してレイヤ2デバイスがMPLSネットワークに接続されているトポロジー内で、802.1Qトンネリングをサポートするには、802.1Qトンネリング カプセル化トラフィック(PE1)を受信するPE-CLEの入力LANポートを、VLAN 100トラフィックを受信するトンネル ポートとして設定します。PE1のインターフェイスはポートベースEoMPLS転送用に、PE2のインターフェイスは宛先IPアドレスとして設定されます。CE1から着信したVLAN 10〜50のパケットは、VLAN 100でカプセル化されて、MPLSネットワークに接続されたPE1出力ポートに送信されます。出力ポートでは、MPLSタグがフレーム ヘッダーに追加されたあと、VCにマッピングされ、次のMPLS PE-CLE(PE2)に転送されます。

図36-4 EoMPLSの例

VLANベースEoMPLSの場合はVLANに、ポートベースEoMPLSの場合はイーサネット ポートに mpls l2transport route または xconnect インターフェイス コンフィギュレーション コマンドを入力すると、カスタマーVLANまたはイーサネット ポートに基づいてトラフィックを転送するように、EoMPLSトンネルを設定することができます。

MPLSコアを介して、MPLSネットワークの反対側の特定の受信側に、802.1Qトンネルによってカプセル化されたトラフィックを転送するには、ポートベースEoMPLSを設定します。
802.1Qトンネルによってカプセル化されたトラフィックをアクセス デバイスからPEルータに転送するには、VLANベースEoMPLSを設定します。

EoMPLSおよびレイヤ2トンネリング

EoMPLSリンクを介してレイヤ2プロトコル トンネリングを行うと、CDP、STP、およびVTP Protocol Data Unit(PDU;プロトコル データ ユニット)をMPLSネットワークを介してトンネリングすることができます。レイヤ2デバイスがPEとして機能するスイッチを介してMPLSネットワークに接続されている場合に、レイヤ2プロトコル トンネリングをサポートするには、レイヤ2プロトコル トラフィックを受信するPEの入力ポートをトンネル ポートとして設定します。レイヤ2プロトコル トラフィックがカプセル化されてから、MPLSネットワークを介して転送されます。レイヤ2プロトコル トンネリングの詳細については、 「MPLS およびEoMPLS QoS の設定」 を参照してください。

EoMPLSおよびQoS

EoMPLSはラベル内の3つのEXP(試験)ビットを使用してパケットのプライオリティを判別することにより、QoSをサポートします。LER間でQoSをサポートするには、VCとトンネル ラベルの両方にEXPビットを設定します。EoMPLS QoS分類は入力側で実行されます。照合できるのはレイヤ3パラメータ(IPやDSCPなど)のみであり、レイヤ2パラメータ(CoS[サービス クラス])は照合されません。EoMPLSおよびQoSの詳細については、 MPLSおよびEoMPLS QoSの設定 を参照してください。

EoMPLSの制限

EoMPLSに適用される制限事項は、次とのとおりです。

EoMPLSを使用するには、MPLS用として少なくとも1つのESポートを設定する必要があります。したがって、ESポートでEoMPLSを稼働させる場合に、EoMPLSを設定できるのは、MPLSが設定されていないESポート上のみです。
MTU(最大伝送ユニット) ― EoMPLSはパケットの分割および再組み立てをサポートしていません。したがって、受信された最大のレイヤ2 VLANを伝達できるように、エンドポイント間のすべての中間リンクのMTUを設定する必要があります。入力および出力PEルータには、同じMTU値を設定する必要があります。
アドレス形式 ― MPLS転送を適切に動作させるには、PEルータのすべてのループバック アドレスに32ビット マスクを設定する必要があります。OSPFでは、ループバック アドレスを使用する必要があります。
パケット形式 ― EoMPLSは、IEEE 802.1Q標準に準拠するVLANパケットをサポートします。PEおよびCEルータ間では、ISL(スイッチ間リンク)カプセル化はサポートされません。
スイッチ上でEoMPLSを使用するVLANの最大数は1005です。
レイヤ2接続に関する制限:
− EoMPLSを使用する場合は、PEルータ間を直接レイヤ2で接続することはできません。
− MPLSバックボーンを介してイーサネットVLANをトランスポートするようにルータが設定されている場合は、これらのルータ間に複数のレイヤ2接続を設定することはできません。別のレイヤ2接続を追加すると、ピア ルータ上でスパニングツリーがディセーブルの場合、スパニングツリー ステートが頻繁に切り替わります。
EoMPLSおよびトランキングに関する制限:
− EoMPLSバックボーンでイーサネット スパニングツリーBridge Protocol Data Unit(BPDU;ブリッジ プロトコル データ ユニット)をサポートするには、EoMPLS VLANのスパニングツリーをディセーブルにする必要があります。このようにすると、EoMPLS VLANの伝達経路がカスタマー スイッチへのトランクに限定されます。
− トランクのネイティブVLANをEoMPLS VLANにすることはできません。
802.1Qインターフェイス上でEoMPLSをイネーブルにするには、 mpls l2transport route または xconnect インターフェイス コンフィギュレーション コマンドを使用します。
EoMPLSが設定されているインターフェイスには、VLANマッピングを設定しないでください。
プライベートVLANインターフェイスでEoMPLSを設定しないでください。

EoMPLSのイネーブル化

ここでは、PEルータとして使用されるスイッチにEoMPLSを設定する方法について説明します。

EoMPLSのデフォルト設定
EoMPLS設定時の注意事項
EoMPLSの設定
EoMPLSネットワークのパケット フロー

EoMPLSのデフォルト設定

デフォルトで、EoMPLSは設定されていません。

mpls ldp router-id コマンドはディセーブルです。VCは設定されていません。

EoMPLS設定時の注意事項

EoMPLSを設定する場合は、次の注意事項を考慮してください。

EoMPLSを使用するには、MPLS用として少なくとも1つのESポートを設定する必要があります。したがって、ESポートでEoMPLSを稼働させる場合に、EoMPLSを設定できるのは、MPLSが設定されていないESポート上のみです。
EoMPLSをイネーブルにする前に、インポジションLERとディスポジションLERの間のすべてのパスに対して mpls ip インターフェイス コンフィギュレーション コマンドを使用して、ダイナミックMPLSラベリングをイネーブルにする必要があります。デフォルトで、MPLSはグローバルにイネーブルに設定されています。
VLANベースEoMPLSの場合は、スイッチにVLANを設定する必要があります。
2つのPEルータ間でEoMPLSを稼働させるには、ルータ間のLDPセッションが必要です。各ルータでLDPルータIDとして使用されるIPアドレスは、他のルータからIP到達可能でなければなりません。IPアドレスを使用する必要があるインターフェイスを指定して、LDPルータIDの選択を制御するには、任意の mpls ldp router-id グローバル コンフィギュレーション コマンドを使用します。
− 指定されたインターフェイスが起動していて、IPアドレスが設定されている場合は、このコマンドを使用するときに任意の force キーワードを省略できます。ルータIDを選択する場合は、このIPアドレスがルータIDとして選択されます。
− 指定されたインターフェイスが起動していないか、またはIPアドレスが設定されていない場合に、指定されたインターフェイスのIPアドレスがインターフェイスの起動時に使用されるように設定するには、 force キーワードを指定してこのコマンドを使用します。
両方のPEルータに、ルータ間のVCを作成する場合に使用できるループバック アドレスを設定する必要があります。OSPFをIGPとして使用する場合に、PEルータ間でMPLS転送を適切に稼働させるには、PEルータのすべてのループバック アドレスに32ビット マスクを設定する必要があります。
VLANマッピングが設定されているインターフェイスには、EoMPLSを設定しないでください。

EoMPLSの設定

VLANインターフェイスには、VLANベースEoMPLSを設定します。VLANベースEoMPLSがイネーブルの場合、スイッチはVLAN IDに基づいてトンネルとVCラベルを関連付けます。ESインターフェイス上でポートベースEoMPLSをイネーブルにする場合は、同じコマンドを使用します。

2つのエンドポイント間でレイヤ2パケットをトランスポートするようにEoMPLSを設定するには、PE-CLEルータ上でイネーブルEXECモードを開始し、次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mpls label protocol ldp

すべてのインターフェイスでLDPをイネーブルにします。デフォルトで、TDPはイネーブルに設定されます。このコマンドを使用すると、すべてのインターフェイスがLDPを使用するように設定されます。

ステップ 3

interface loopback0

ループバック インターフェイスに対して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address subnet mask

ループバック インターフェイスにIPアドレスを割り当てます。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

mpls ldp router-id loopback0 force

(任意)ループバック インターフェイス0のIPアドレスをルータIDとして使用するように強制的に設定します。

ステップ 7

interface interface-id

レイヤ3 VLAN(VLANベースEoMPLSの場合)またはESポートのインターフェイスID(ポートベースEoMPLSの場合)を入力して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

mpls l2transport route destination vc-id

または

xconnect destination vc-id encapsulation mpls

MPLSを介してレイヤ2 VLANパケットをトランスポートするようにインターフェイスを設定します。

destination ― VCの反対側にあるPEルータのIPアドレス。
vc-id ― VCに定義された一意の値。vc-idはVCのエンドポイントに関連付けられます。この値は、VCの両端で同じでなければなりません。指定できる範囲は1〜4294967295です。

ステップ 9

end

イネーブルEXECモードに戻ります。

ステップ 10

show mpls l2transport vc

設定を確認します。

ステップ 11

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

EoMPLSトンネルを削除するには、 no mpls l2transport route destination vc-id または no xconnect destination vc-id encapsulation mpls インターフェイス コマンドを使用します。

次に、スイッチPE1のVLAN 3インターフェイスとPE2のVLAN 4インターフェイス間にEoMPLSトンネルを設定する例を示します。

PE1のIPアドレスは10.0.0.1/32、PE2のIPアドレスは20.0.0.1/32です。両方のPEルータに、MPLSコアとのMPLS接続が設定されています。VC IDは123です。

PE1スイッチに、次のコマンドを入力します。

S witch(config)# interface loopback0

S witch(config-if)# ip address 10.10.10.10 255.255.255.255

S witch(config-if)# exit

S witch(config)# interface vlan 3

S witch(config-if)# mpls l2transport route 20.0.0.1 123

PE2スイッチに、次のコマンドを入力します。

S witch(config)# interface loopback0

S witch(config-if)# ip address 20.20.20.20 255.255.255.255

S witch(config-if)# exit

S witch(config)# interface vlan 4

S witch(config-if)# mpls l2transport route 10.0.0.1 123

EoMPLSネットワークのパケット フロー

図36-5 に、EoMPLSネットワークのパケット フローの例を示します。PE1のカスタマー ポートは、PE2のリモート カスタマー ポートへのポート単位EoMPLSトンネル用に設定されています。この設定により、これらのポートに接続された、物理的に離れている2つのカスタマー スイッチ(AおよびB)は、同じ物理LAN上で直接接続されているかのように認識されます。

EoMPLSトンネルにはスイッチBのIPアドレス、およびリモート カスタマー ポートに関連付けられたVC IDが設定されています。PE1は、ルータA(PE1のESポートに接続)からLDPによってアドバタイズするラベルを使用して、PE2とのトンネルLSPを確立します。次に、PE1はPE2とのターゲットLDPセッションを確立して、VC IDに関連付けられたVCラベルをアドバタイズします。PE2にEoMPLSトンネルが設定されている場合、PE2もターゲットLDPセッションを確立して、VC IDに関連付けられたVCラベルをアドバタイズします。これにより、スイッチPE1とスイッチPE2の2つのESポート間に、EoMPLSトンネルが確立されます。

図36-5 EoMPLSパケット フローの例

ホストAがVLAN 3上のカスタマー スイッチに接続されていて、このVLAN 3のトランク ポートが802.1Qタギング用に設定されたPE1に接続されているとします。ホストAは、MACアドレス、ラベル、およびVLANの特定の値を使用して(図を参照)、パケットをホストBに送信します。カスタマー スイッチはホスト パケットにタグを付加し、トランク ポートを介してPE1に転送します。

タグ付きパケットは、ポート単位EoMPLSトンネリング用に設定されたCEポートに着信します。PE1スイッチはパケット ヘッダーを調べて、スイッチに格納されたテーブルを検索し、パケットの処理内容を判別します。ポートにはポート単位EoMPLSトンネリングが設定されているため、スイッチはパケット内のVLANタグを削除しないで、内部VLANにパケットを割り当てます。カスタマー ポートおよびESポートにのみ、内部VLANが設定されています。したがって、PE1 ESポートがパケットの唯一の宛先となります。

ESポートはトンネル ラベルおよびVCラベルを含めてパケット ヘッダーをカプセル化し、パケットをネクスト ホップ(この場合はルータA)に転送し、そこからMPLSネットワークにパケットを送信します。

ルータはパケットを受信し、MPLSネットワークを介してリモートPE2スイッチに転送します。PE2はMPLSカプセル化を解除し、VCラベルに関連付けられたポートからパケットを送信します。カスタマー スイッチBは最終的なVLANタグを削除し、パケットをリモート ホストBに転送します。

VLANベースEoMPLSパケット フローは、基本的にポートベースEoMPLSと同じです。ただし、内部VLANでなく、カスタマーVLANが使用されます。PE1スイッチはカスタマーVLAN IDを検索して、パケットをESポートに転送するかを判別します。ここで、パケットは再び調べられ、該当するVLANのEoMPLSに基づいて、トンネル ラベルおよびVCラベルとともにカプセル化されます。

MPLSおよびEoMPLS QoSの設定

MPLSおよびEoMPLSでQoSを使用すると、ネットワーク管理者はMPLSネットワーク上で異なるType of Service(ToS;サービス タイプ)を提供することができます。各パケットは、パケットQoSによって指定された特定の種類のサービスを受信できます。QoS IP precedenceビットを保護するには、QoSをグローバルにディセーブルにする必要があります。

QoSをイネーブルにしたあとで、Differentiated Services Code Point(DSCP)またはIP precedenceビットを保護するには、インターフェイス レベルの信頼設定を使用します。詳細については、 「ポートの信頼状態による入力分類の設定」 を参照してください。ただし、保護されていないビットは、保護されたビットの値によって自動的に上書きされます。たとえば、DSCPビットが保護されている場合、IP precedenceおよびCoSビットはDSCPビットの値によって上書きされます。また、MPLSラベル内の3つのEXPビットを使用してパケットのプライオリティを判別することにより、MPLSおよびEoMPLS QoSプライオリティを設定することもできます。

スイッチでサポートされるのは、MPLSおよびEoMPLSのDSCPおよびIP precedence分類のみです。

ここでは、次の情報について説明します。

MPLS QoSの概要
MPLSおよびEoMPLS QoSのイネーブル化

MPLS QoSの概要

MPLSネットワークでは、サービスを複数の方法で指定することができます。たとえば、IPパケット内のIP precedenceビット設定を使用します。サイト間でIPパケットを送信する場合は、IP precedenceフィールド(IPパケットのヘッダー内のDSCPフィールドの最初の3ビット)によってQoSが指定されます。IP precedenceのマーキングに基づいて、遅延や帯域幅などの目的の処理がパケットに設定されます。ネットワークがMPLSネットワークの場合、IP precedenceビットはネットワーク エッジのMPLS EXPフィールドにコピーされます。

サービス プロバイダーはMPLSパケットのQoS値を別の値に設定することもできます。サービス プロバイダーはカスタマーに属するIP precedenceフィールドの値を上書きしないで、MPLS EXPフィールドを設定することができます。カスタマーは引き続きIPヘッダーを使用することができます。パケットがMPLSネットワークを通過するときに、IPパケットのQoSは変化しません。

MPLS EXPフィールドに別の値を選択することにより、レートやタイプなどの特性に基づいてパケットにマーキングすることができます。これにより、輻輳期間中に必要となるプライオリティをパケットに設定することができます。

図36-6 に、カスタマーに属するIPネットワークの2つのサイトを接続するMPLSネットワークを示します。

図36-6 2つのカスタマー サイトを接続するMPLSネットワーク

PE1およびPE2はMPLSネットワークとIPネットワークの境界に配置されたcustomer-locatedルータであり、入力および出力PEデバイスです。CE1およびCE2はCEデバイスです。P1およびP2は、サービスプロバイダー ネットワークの中心にあるサービス プロバイダー ルータです。

パケットはPE1(入力PE-CLEルータ)にIPパケットとして着信します。PE1は着信したパケットをMPLSパケットとしてMPLSネットワークに送信します。サービスプロバイダー ネットワーク内では、パケットはMPLSパケットであるため、キューイング メカニズムが検索するIP precedenceフィールドは存在しません。パケットはPE2(出力PE-CLEルータ)に着信するまで、MPLSパケットのままです。PE2は各パケットからラベルを削除し、パケットをIPパケットとして転送します。

サービス プロバイダーはMPLS QoSを使用することにより、タイプ、入力インターフェイス、およびその他の要素に従ってパケットを分類できます。その場合には、IP precedenceまたはDSCPフィールドを変更しないで、MPLS EXPフィールド内に各パケットを設定(マーキング)します。IP precedenceまたはDSCPビットを使用すると、IPパケットに対してQoSを指定できます。MPLS EXPビットを使用すると、MPLSパケットに対してQoSを指定できます。MPLSネットワーク内のMPLSパケットにQoS値を設定するには、PE1(入力ルータ)でMPLS EXPフィールド値を設定します

パケットに正しいプライオリティを割り当てることが重要です。パケットのプライオリティは、輻輳期間中のパケットの処理方法に影響します。たとえば、サービス プロバイダーとカスタマーとの間に、サービス プロバイダーが提供するトラフィック量を指定するサービスレベル契約が交わされているとします。契約に準拠するには、カスタマーは合意したレートを超えるレートで送信しないようにする必要があります。パケットはレートに適合するか、または適合しないかのどちらかです。ネットワークに輻輳が発生した場合は、レートに適合しないパケットをより積極的に廃棄することができます。

MPLSおよびEoMPLS QoSのイネーブル化

ここでは、入力PEルータにMPLS QoSを設定する方法について説明します。具体的な内容は次のとおりです。

MPLSおよびEoMPLS QoSのデフォルト設定
EXPビットによるパケットのプライオリティの設定

QoSの詳細については、 第32 章「QoS の設定」 を参照してください。

MPLSおよびEoMPLS QoSのデフォルト設定

QoSはディセーブルに設定されています。パケットは変更されません。また、パケット内のCoS、DSCP、およびIP precedence値も変更されません。トラフィックはパススルー モードでスイッチングされます(パケットは書き換えられずにスイッチングされ、ポリシングを伴わないベストエフォート型として分類されます)。

VLANベースEoMPLSパケットのデフォルトの動作では、802.1pビットがVCおよびトンネル ラベルのEXPビットにリレーされます。ポートベースEoMPLSパケットのデフォルトの動作では、VCおよびトンネル ラベルのEXPビットに値0が使用されます。階層型QoSポリシーをESポートに適用すれば、VLANベースまたはポートベースのEoMPLSのデフォルト動作を変更できます。

mls qos グローバル コンフィギュレーション コマンドを使用してQoSをイネーブルにし、その他のすべてのQoS設定がデフォルトである場合、トラフィックはポリシングを伴わないベストエフォート型として分類されます(DSCPは0に設定されます)。ポリシー マップは設定されていません。

MPLSおよびEoMPLS QoSの場合、照合できるのはレイヤ3パラメータ(IPまたはDSCP値)のみです。レイヤ2パラメータ(CoS値)は照合されません。

EXPビットによるパケットのプライオリティの設定

MPLSおよびEoMPLSを使用すると、ラベル内の3つのEXPビットを使用してパケットのプライオリティを判別し、入力ルータでQoSを実行することができます。LER間でQoSをサポートするには、VCとトンネル ラベルの両方にEXPビットを設定します。EXPビットに値を割り当てない場合、802.1Qヘッダー タグ制御情報フィールドのプライオリティ ビットがEXPビット フィールドに書き込まれます。

このプロセスでは、入力ルータで次の作業を行います。

DSCPまたはIP precedence分類に従ってIPパケットを分類するように、クラス マップを設定します。

スイッチでサポートされるのは、MPLSおよびEoMPLSのDSCPおよびIP precedence分類のみです。

MPLSパケットをマーキングするように(分類情報をMPLS EXPフィールドに書き込むように)、ポリシー マップを設定します。
サービス ポリシーを付加するように、入力インターフェイスを設定します。

EoMPLSまたはMPLS QoS用にEXPビットを設定するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mls qos

QoSをグローバルにイネーブルにします。

デフォルト設定におけるQoSの動作については、 第32 章「QoS の設定」 を参照してください。

ステップ 3

class-map class-map-name

トラフィック クラスの名前を指定し、クラスマップ コンフィギュレーション モードを開始します。

ステップ 4

match { ip dscp dscp-list | ip precedence ip-precedence-list }

802.1Qパケットの一致条件を指定します。

ip dscp dscp-list ― 着信パケットと比較する最大8個のIP DSCP値。指定できる範囲は0〜63です。
ip precedence ip-precedence-list 着信パケットと比較する最大8個のIP precedence値。各値はスペースで区切ります。指定できる範囲は0〜7です。

(注) MPLSおよびEoMPLSに対して、 cos および vlan キーワードはサポートされません。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

policy-map policy-map-name

設定するトラフィック ポリシーの名前を指定し、ポリシーマップ コンフィギュレーション モードを開始します。

ステップ 7

class class-name

class-map コマンドを使用して事前に設定されたトラフィック クラスの名前を指定し、ポリシーマップ クラス コンフィギュレーション モードを開始します。

ステップ 8

set mpls experimental exp-number

指定されたポリシー マップとパケットが一致する場合に、MPLSビットに設定する値を指定します。指定できる範囲は0〜7です。

ステップ 9

exit

ポリシーマップ コンフィギュレーション モードに戻ります。

ステップ 10

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

interface interface-id

インターフェイスIDを入力し、インターフェイス コンフィギュレーション モードを開始します。インターフェイスは入力ルータのES出力ポートでなければなりません。

ステップ 12

service-policy output policy-map-name

指定されたポリシー マップを出力インターフェイスに付加します。

ステップ 13

end

イネーブルEXECモードに戻ります。

ステップ 14

show policy-map [ policy-map-name [ class class-map-name ]]

show policy-map interface interface-id

設定を確認します。

ステップ 15

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

既存のポリシー マップを削除するには、 no policy-map policy-map-name グローバル コンフィギュレーション コマンドを使用します。既存のクラスを削除するには、 no class class-name ポリシーマップ コンフィギュレーション コマンドを使用します。

次に、クラスおよびポリシー マップを使用して、MPLS QoSのDSCPおよびIP precedence用に異なる各EXPビットを設定する例を示します。

Switch(config)# class-map match-all gold-class

Switch(config-cmap)# match ip dscp 1

Switch(config-cmap)# exit

Switch(config)# class-map match-all silver-class

Switch(config-cmap)# match ip precedence 2

Switch(config-cmap)# exit

Switch(config)# policy-map out-policy

Switch(config-pmap)# class gold-class

Switch(config-pmap-c)# set mpls experimental 5

Switch(config-pmap-c)# exit

Switch(config-pmap)# class silver-class

Switch(config-pmap-c)# set mpls experimental 4

Switch(config-pmap-c)# exit

Switch(config)# interface gigabitethernet1/1/1

Switch(config-if)# service-policy output out-policy

Switch(config-if)# end

MPLSおよびEoMPLSのモニタおよびメンテナンス

MPLSカウンタを消去したり、MPLSおよびEoMPLS情報を表示するには、 表36-1 に記載されたイネーブルEXECコマンドを使用します。

表36-1 MPLSおよびEoMPLS情報表示用のコマンド

コマンド

説明

clear mpls counters

MPLS転送カウンタをクリアします。

show mpls forwarding-table

MPLS Label Forwarding Information Base(LFIB)の内容を表示します。

show mpls interfaces

ラベル スイッチング用に設定されたインターフェイスの情報を表示します。

show mpls ip binding

LDPによって取得されたラベル バインディングに関する指定された情報を表示します。

show mpls l2transport vc [ detail ] [ summary ]

PEデバイスでレイヤ2パケットをルーティングするためにイネーブル化されたEoMPLS VCに関する詳細情報、またはサマリー情報を表示します。

show mpls l2transport vc [ vc-id ] [ vc-id-min - vc-id-max ]

指定されたVCまたはVC範囲に関する情報を表示します。指定できる範囲は1〜4294967295です。

show mpls label range

パケット インターフェイスで使用可能なローカル ラベルの範囲を表示します。

show mpls ldp bindings

Label Information Base(LIB)の内容を表示します。

show mpls ldp discovery

LDP検出プロセスのステータスを表示します。

show mpls ldp neighbor

LDPセッションのステータスを表示します。

show mpls ldp parameters

現在のLDPパラメータを表示します。

show mpls prefix-map

標準IPアクセス リストを照合するネットワーク プレフィクスにQoSマップを割り当てるためのプレフィクス マップを表示します。

show mpls ldp backoff

設定済みのセッション設定バックオフ パラメータ、およびセッション設定をスロットリングするときに使用される任意のLDPピアに関する情報を表示します。


[an error occurred while processing this directive]