[an error occurred while processing this directive]
日本語マニュアル一覧
スイッチ
Catalyst 3750 Metro シリーズ
Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)EY
はじめに
このマニュアルについて
図一覧
表一覧
概要
CLIの使用方法
スイッチのIPアドレスおよびデフォルト ゲートウェイの割り当て
スイッチのクラスタ設定
IE2100 CNSエージェントの設定
スイッチの管理
SDMテンプレートの設定
スイッチベースの認証の設定
802.1xポートベースの認証の設定
インターフェイス特性の設定
SmartPortマクロの設定
VLANの設定
VTPの設定
プライベートVLANの設定
音声VLANの設定
IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定
STPの設定
MSTPの設定
オプションのスパニングツリー機能の設定
Flex Linkの設定
DHCP機能およびIPソース ガードの設定
ダイナミックARP検査の設定
IGMPスヌーピングおよびMVRの設定
ポートベースのトラフィック制御の設定
CDPの設定
UDLDの設定
SPANおよびRSPANの設定
RMONの設定
システム メッセージ ロギングの設定
SNMPの設定
ACLによるネットワーク セキュリティの設定
QoSの設定
EtherChannelの設定
IPユニキャスト ルーティングの設定
HSRPの設定
MPLSおよびEoMPLSの設定
IPマルチキャスト ルーティングの設定
MSDPの設定
代替ブリッジングの設定
トラブルシューティング
サポートされているMIB
Cisco IOSファイル システム、コンフィギュレーション ファイル、およびソフトウェア イメージの操作
Cisco IOS Release12.2(25)EYでサポートされていないコマンド

スイッチ
Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)EY

この章では、Catalyst 3750 Metroスイッチに、標準範囲のVLAN(仮想LAN)(VLAN IDが1〜1005)および拡張範囲のVLAN(VLAN IDが1006〜4094)を設定する方法について説明します。VLANメンバーシップ モード、VLANコンフィギュレーション モード、VLANトランク、VLAN Membership Policy Server(VMPS;VLANメンバーシップ ポリシー サーバ)からのダイナミックVLAN割り当てについても説明します。

ここで使用されるコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。

この章の内容は次のとおりです。

VLANの概要
標準範囲VLANの設定
拡張範囲VLANの設定
VLANの表示
VLANトランクの設定
VMPSの設定

VLANの概要

VLANは、ユーザの物理的な位置に関係なく、機能、プロジェクト チーム、またはアプリケーションによって論理的に分割されたスイッチド ネットワークです。VLANは物理VLANと同じ属性を備えていますが、エンド ステーションが物理的に同一のLANセグメントにない場合でもグループ化できます。どのスイッチ ポートもVLANに割り当てることができます。ユニキャスト、ブロードキャスト、およびマルチキャスト パケットは、VLAN内のエンド ステーションにだけフォワーディングおよびフラッディングが行われます。各VLANは1つの論理ネットワークとみなされ、VLANに属さないステーション宛のパケットは、ルータまたは代替ブリッジングをサポートするスイッチを経由して伝送しなければなりません( 図12-1 を参照)。VLANはそれぞれが独立した論理ネットワークとみなされるので、VLANごとに独自のブリッジMIB(管理情報ベース)情報があり、それぞれが独自にスパニングツリーの実装をサポートします。 第17章 「STPの設定」 を参照してください。

VLANを作成するには、まずVLAN Trunk Protocol(VTP;VLANトランク プロトコル)を使用してネットワークのグローバルVLAN設定をメンテナンスするかどうかを決定する必要があります。VTPの詳細については、 第13章 「VTPの設定」 を参照してください。

図12-1 に、論理的に定義されたネットワークに分割したVLANの例を示します。

図12-1 論理的に定義されたネットワークとしてのVLAN

VLANは、多くの場合、IPサブネットワークと対応付けられます。たとえば、特定のIPサブネットのすべてのエンド ステーションを同一のVLANに属させることがあります。スイッチ上のインターフェイスVLANメンバーシップは、インターフェイスごとに手動で割り当てます。この方法でVLANにスイッチ インターフェイスを割り当てることを、インターフェイスベースまたはスタティックVLANメンバーシップと呼びます。

VLAN間のトラフィックはルーティングするか代替ブリッジングする必要があります。スイッチは、Switch Virtual Interface(SVI)を使用して、VLAN間でトラフィックをルーティングできます。VLAN間でトラフィックをルーティングするには、SVIを明示的に設定してIPアドレスを割り当てる必要があります。詳細については、 「SVI」 および 「レイヤ3 インターフェイスの設定」 を参照してください。

スイッチに多数のVLANを設定し、ルーティングをイネーブル化しない予定の場合は、sdm prefer
vlan グローバル コンフィギュレーション コマンドを使用してSwitch Database Management(SDM)機能をVLANテンプレートに設定できます。このテンプレートは、最大数のユニキャストMAC(メディア アクセス制御)アドレスをサポートするようにシステム リソースを設定します。SDMテンプレートの詳細については、 第7 章「SDM テンプレートの設定」 、またはこのリリースのコマンド リファレンスの sdm prefer コマンドを参照してください。

サポートされるVLAN

スイッチは、VTPクライアント、サーバ、およびトランスペアレント モードの1〜1005のVLANをサポートします。VLANは、1〜4094の番号で識別されます。VLAN IDの1002〜1005は、トークン リングおよびFDDI VLAN用です。VTPは、VLAN IDが1〜1005の標準範囲VLANだけを学習します。1005を超えるVLAN IDは拡張範囲VLANであり、VLANデータベースには保管されません。1006〜4094のVLAN IDを作成するときには、スイッチはVTPトランスペアレント モードである必要があります。

スイッチは合計1005(標準範囲および拡張範囲)のVLANをサポートしますが、ルーテッド ポート、SVI、その他の設定済み機能の個数によって、スイッチのハードウェアの使用は左右されます。

このスイッチは、Per-VLAN Spanning-Tree plus(PVST+)と最大128のスパニングツリー インスタンスをサポートします。VLANごとに1つのスパニングツリー インスタンスがサポートされます。スパニングツリー インスタンスの数とVLAN番号の詳細については、 標準範囲VLANの設定時の注意事項 を参照してください。スイッチは、イーサネットポート経由のVLANトラフィックの送信方式として、ISL(スイッチ間リンク)およびIEEE 802.1Qトランキングの両方をサポートしています。

VLANポート メンバーシップ モード

VLANに属するポートは、メンバーシップ モードを指定して設定します。メンバーシップ モードにより、各ポートが搬送できるトラフィックの種類、および属することができるVLANの数が決まります。 表12-1 に、各種メンバーシップ モード、メンバーシップ、VTP特性を示します。

表12-1 ポート メンバーシップ モード(続き)

メンバーシップ
モード

VLANメンバーシップの特性

VTP特性

スタティック
アクセス

スタティック アクセス ポートは、1つのVLANだけに属し、手動でそのVLANに割り当てられます。詳細については、 VLANへのスタティック アクセス ポートの割り当て を参照してください。

VTPは必須ではありません。VTPにグローバルに情報を伝播させないようにする場合は、VTPモードをトランスペアレントに設定してVTPをディセーブルにします。VTPに加入するには、あるスイッチのトランク ポートに接続した別のスイッチ上に最低1つのトランク ポートがなければなりません。

トランク(ISLまたはIEEE 802.1Q)

トランク ポートは、拡張範囲VLANも含めて、デフォルトで全VLANのメンバーですが、許可VLANリストを設定することにより、メンバーシップを制限できます。プルーニング適格リストを変更して、リストに含まれるトランク ポート上でVLANに対するフラッディング トラフィックをブロックすることもできます。トランク ポートの設定の詳細については、 トランク ポートとしてのイーサネット インターフェイスの設定 を参照してください。

VTPは、推奨はしますが、必須ではありません。VTPは、ネットワーク全体にわたってVLANの追加、削除、名前変更を管理することにより、VLAN設定の整合性を維持します。VTPはトランク リンクを通じて他のスイッチとVLANコンフィギュレーション メッセージを交換します。

ダイナミック
アクセス

ダイナミック アクセス ポートは、1つのVLAN(VLAN IDが1〜4094)だけに属し、VMPSによってダイナミックに割り当てられます。たとえば、Catalyst 5000または
Catalyst 6500シリーズ スイッチはVMPSとして使用できますが、Catalyst 3750 MetroスイッチはVMPSとして使用することはできません。Catalyst 3750 Metroスイッチは、VMPSクライアントです。

同じスイッチ上にダイナミック アクセス ポートとトランク ポートを設定できますが、ダイナミック アクセス ポートはエンド ステーションまたはハブに接続する必要があります。別のスイッチに接続してはなりません。

設定の詳細については、 VMPSクライアントのダイナミック アクセス ポートの設定 を参照してください。

VTPは必須です。

VMPSとクライアントは、同じVTPドメイン名で設定してください。

VTPに加入するには、あるスイッチのトランク ポートに接続した別のスイッチ上に最低1つのトランク ポートがなければなりません。

プライベート
VLAN

プライベートVLANは、プライベートVLANのプライマリまたはセカンダリVLANに属する、ホストまたは混合ポートです。この機能を使用するには、Enhanced Multilayer Image(EMI;拡張マルチレイヤ ソフトウェア イメージ)がスイッチ上で稼働している必要があります。

プライベートVLANの詳細については、 第14章 「プライベートVLANの設定」 を参照してください。

プライベートVLANを設定する場合、スイッチはVTPトランスペアレント モードでなければなりません。プライベートVLANがスイッチで設定されている場合、VTPモードをトランスペアレントからクライアントまたはサーバ モードに変更しないでください。

音声VLAN

音声VLANポートは、Cisco IP Phoneに接続されたアクセス ポートです。Cisco IP Phoneは、音声トラフィック用に1つのVLANを使用し、電話に接続されたデバイスからのデータ トラフィック用には別のVLANを使用するように設定されています。音声VLANポートの詳細については、 第15章 「音声VLANの設定」 を参照してください。

VTPは必須ではなく、音声VLANには影響しません。

トンネル
dot1q-tunnel

トンネル ポートは、サービス プロバイダー ネットワーク上でカスタマーVLANの完全性を保つための802.1Qトンネリングに使用されます。トンネル ポートは、サービス プロバイダー ネットワークのエッジ スイッチ上に設定し、カスタマー インターフェイスの802.1Qトランク ポートに接続して、非対称リンクを作成します。トンネル ポートは、トンネリング専用の1つのVLANにのみ所属します。

トンネル ポートの詳細については、 第16章 「IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定」 を参照してください。

VTPは必須ではありません。トンネル ポートを手動でVLANに割り当てるには、 switchport access vlan インターフェイス コンフィギュレーション コマンドを使用します。

モードおよびその機能の詳細については、 表12-4 を参照してください。

VLANにポートを割り当てると、スイッチはVLAN単位で、ポートに対応するアドレスを学習して管理します。詳細については、 「MAC アドレステーブルの管理」 を参照してください。

標準範囲VLANの設定

標準範囲VLAN とは、 VLAN IDが1〜1005のVLANのことです。スイッチがVTPサーバまたはトランスペアレント モードにある場合は、VLANデータベース内のVLAN 2〜1001について設定を追加、変更、または削除できます(VLAN IDの1と1002〜1005は、自動作成され、削除できません)。

スイッチがVTPトランスペアレント モードにある場合は、拡張範囲VLAN(IDが1006〜4094のVLAN)を作成することもできますが、このVLANはVLANデータベースには保存されません。 拡張範囲VLANの設定 を参照してください。

VLAN IDが1〜1005の設定はファイル vlan.dat (VLANデータベース)に保存され、 show vlan イネーブルEXECコマンドを入力すると表示できます。 vlan.dat ファイルは、NVRAM(不揮発性RAM)に保存されます。

vlan.dat ファイルを手動で削除しようとすると、VLANデータベースに不整合が生じる可能性があります。VLAN設定を変更する場合は、ここに記載されているコマンド、およびこのリリースのコマンド リファレンス を使用してください。 VTP設定を変更する場合は、 第13章 「VTPの設定」 を参照してください。

さらに、インターフェイス コンフィギュレーション モードを使用して、ポートのメンバーシップ モードの定義、VLANに対するポートの追加および削除を行います。このモードのコマンド実行結果は実行コンフィギュレーション ファイルに書き込まれ、 show running-config イネーブルEXECコマンドを入力することによって表示できます。

VLANデータベースに新しい標準範囲VLANを作成する場合、またはVLANデータベース内の既存のVLANを変更する場合、次のパラメータを設定できます。

VLAN ID
VLAN名
VLANタイプ(イーサネット、Fiber Distributed Data Interface [FDDI]、FDDI Network Entity Title [NET]、TrBRF[トークンリング ブリッジ リレー機能]またはTrCRF[トークンリング コンセントレータ リレー機能]、トークン リング、トークン リングネット)
VLANステート(アクティブまたはサスペンド)
VLANのMaximum Transmission Unit(MTU;最大伝送ユニット)
Security Association Identifier(SAID)
TrBRF VLANのブリッジ識別番号
FDDIおよびTrCRF VLANのリング番号
TrCRF VLANの親VLAN番号
TrCRF VLANのSpanning-Tree Protocol(STP;スパニングツリープロトコル)タイプ
あるVLANタイプから別のVLANタイプに変換するときに使用するVLAN番号

ここでは、これらのパラメータのほとんどについて設定の詳細は説明しません。VLAN設定を制御するコマンドおよびパラメータの詳細については、このリリースのコマンド リファレンスを参照してください。

ここでは標準範囲VLANについて説明します。内容は次のとおりです。

トークン リングVLAN
標準範囲VLANの設定時の注意事項
VLAN設定モードのオプション
VLAN設定の保存
イーサネットVLANのデフォルト設定
イーサネットVLANの作成または変更
VLANの削除
VLANへのスタティック アクセス ポートの割り当て

トークン リングVLAN

スイッチはトークンリング接続をサポートしていませんが、トークンリング接続を行っているCatalyst 5000シリーズ スイッチなどのリモート デバイスを、サポート対象スイッチのうちの1台から管理できます。VTPバージョン2が稼働するスイッチは、次のトークン リングVLANに関する情報をアドバタイズします。

トークン リングTrBRF VLAN
トークン リングTrCRF VLAN

トークン リングVLANの設定の詳細については、『 Catalyst 5000 Series Software Configuration Guide 』を参照してください。

標準範囲VLANの設定時の注意事項

ネットワーク内で 標準範囲VLANを作成または変更する場合には、次の注意事項に従ってください。

スイッチは、VTPクライアント、サーバ、およびトランスペアレント モードの1〜1005のVLANをサポートします。
標準範囲VLANは、1〜1001の番号で識別されます。VLAN番号の1002〜1005は、トークン リングおよびFDDI VLAN用です。
1〜1005のVLAN設定は、常にVLANデータベースに保存されます。VTPモードがトランスペアレントの場合、VTPとVLANの設定もスイッチの実行コンフィギュレーション ファイルに保存されます。
スイッチは、VTPトランスペアレント モード(VTPがディセーブル)のVLAN ID 1006〜4094もサポートします。これらは拡張範囲VLANで、設定オプションに制限があります。拡張範囲VLANは、VLANデータベースに追加されません。 拡張範囲VLANの設定 を参照してください。
VLANを作成する前に、スイッチをVTPサーバ モードまたはVTPトランスペアレント モードにしておく必要があります。スイッチがVTPサーバの場合は、VTPドメインを定義する必要があります。そうしないとVTPが機能しません。
スイッチは、トークンリングまたはFDDIメディアをサポートしません。このスイッチはFDDI、FDDI-Net、TrCRF、またはTrBRFトラフィックを伝送しませんが、VTPを介してVLAN設定を伝播させます。
128のスパニングツリー インスタンスが、このスイッチによってサポートされます。サポートされるスパニングツリー インスタンスを超える数のアクティブVLANがスイッチに設定されている場合は、128 のVLANでスパニングツリーをイネーブルに設定できますが、残りのVLANではディセーブルに設定します。スイッチ上で使用できるすべてのスパニングツリー インスタンスを使用している場合、VTPドメインにVLANをさらに1つ追加すると、そのスイッチにスパニングツリーを実行しないVLANが作成されます。(すべてのVLANを許可するための)スイッチのトランク ポートにデフォルトの許可リストが設定されていると、すべてのトランク ポートに新しいVLANが割り当てられます。ネットワークのトポロジーに応じて、新しいVLAN内に阻止されないループが作成されることがあります。特に、複数の隣接スイッチでスパニングツリー インスタンスをすべて使用してしまっている場合は、注意してください。このような事態を防ぐには、スパニングツリー インスタンスの割り当てを使い切っているスイッチのトランク ポートに、許可リストを設定します。

スイッチ上のVLAN数がサポートされるスパニング ツリー インスタンス数を超える場合は、
IEEE 802.1s Multiple STP(MSTP)をスイッチに設定して、複数のVLANを単一のSTPインスタンスにマッピングすることを推奨します。MSTPの詳細については、 第18章 「MSTPの設定」 を参照してください。

VLAN設定モードのオプション

標準範囲VLAN(VLAN IDが1〜1005)は、次の2つの設定モードを使用して設定できます。

config-vlanモードでのVLAN設定

config-vlanモードは、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力するとアクセスできます。

VLANデータベース コンフィギュレーション モードでのVLAN設定

VLANデータベース コンフィギュレーション モードは、 vlan database イネーブルEXECコマンドを入力するとアクセスできます。

config-vlanモードでのVLAN設定

config-vlanモードにアクセスするには、VLAN IDを指定して vlan グローバル コンフィギュレーション コマンドを入力します。VLANを新規に作成するには、新しいVLAN IDを入力します。既存のVLANを変更するには、そのVLAN IDを入力します。デフォルトのVLAN設定( 表12-2 を参照)を使用するか、複数のコマンドを入力してVLANを設定します。このモードで使用できるコマンドの詳細については、このリリースのコマンド リファレンスに記載されている vlan グローバル コンフィギュレーション コマンドを参照してください。設定が終了したら、設定が有効になるようにconfig-vlanモードを終了する必要があります。VLAN設定を表示するには、 show vlan イネーブルEXECコマンドを入力します。

拡張範囲VLAN(1005を超えるVLAN ID)の作成時は、このconfig-vlanモードを使用する必要があります。 拡張範囲VLANの設定 を参照してください。

VLANデータベース コンフィギュレーション モードでのVLAN設定

VLANデータベース コンフィギュレーション モードにアクセスするには、 vlan database イネーブルEXECコマンドを入力します。VLANを新規に作成するには、新しいVLAN IDを指定して vlan コマンドを入力します。既存のVLANを変更するには、そのVLAN IDを入力します。デフォルトのVLAN設定( 表12-2 を参照)を使用するか、複数のコマンドを入力してVLANを設定します。このモードで使用できるキーワードの詳細については、このリリースのコマンド リファレンスに記載されている vlan VLANデータベース コンフィギュレーション コマンドを参照してください。設定が終了したら、設定が有効になるように apply または exit を入力する必要があります。 exit コマンドを入力すると、すべてのコマンドが適用され、VLANデータベースが更新されます。VTPドメイン内の他のスイッチにVTPメッセージが送信され、イネーブルEXECモード プロンプトが表示されます。

VLAN設定の保存

IDが1〜1005のVLANの設定は、常にVLANデータベース(vlan.datファイル)に保存されます。VTPモードがトランスペアレントな場合は、スイッチの実行コンフィギュレーション ファイルへの保存も行われるので、 copy running-config startup-config イネーブルEXECコマンドを入力して設定をスタートアップ コンフィギュレーション ファイルに保存できます。 show running-config イネーブルEXECコマンドを使用して、スイッチの実行コンフィギュレーションを表示できます。VLAN設定を表示するには、 show vlan イネーブルEXECコマンドを入力します。

スタートアップ コンフィギュレーション ファイルにVLANおよびVTP情報(拡張範囲VLAN設定も含む)を保存してスイッチを再起動すると、スイッチの設定が次のように決定されます。

スタートアップ コンフィギュレーションで、VTPモードがトランスペアレントであり、VLANデータベースとVLANデータベースからのVTPドメイン名がスタートアップ コンフィギュレーション ファイルのものと一致する場合は、VLANデータベースは無視(消去)され、スタートアップ コンフィギュレーション ファイルのVTPおよびVLAN設定が使用されます。VLANデータベースでは、VLANデータベースのリビジョン番号は元のままです。
スタートアップ コンフィギュレーションのVTPモードまたはドメイン名がVLANデータベースと一致しない場合は、ドメイン名、VTPモード、最初の1005のVLANの設定は、VLANデータベースの情報を使用します。
VTPモードがサーバである場合は、ドメイン名と最初の1005のVLANの設定は、VLANデータベースの情報を使用します。

スタートアップ時にVLANデータベースの設定が使用され、スタートアップ コンフィギュレーション ファイルに拡張範囲VLAN設定が含まれている場合は、システムの起動時にこの情報は失われます。

イーサネットVLANのデフォルト設定

表12-2 に、イーサネットVLANのデフォルト設定を示します。

スイッチは、イーサネット インターフェイスのみをサポートします。FDDIおよびトークン リングVLANは、ローカルではサポートされないので、FDDIおよびトークン リングのメディア固有の特性は、他のスイッチに対するVTPグローバル アドバタイズにのみ設定します。

表12-2 イーサネットVLANのデフォルト値および範囲(続き)

パラメータ

デフォルト値

範囲

VLAN ID

1

1〜4094

(注) 拡張範囲VLAN(VLAN IDが1006〜4094)はVLANデータベースに保存されません。

VLAN名

VLANxxxx 、ここで xxxx
VLAN IDである4桁の数字(先頭の0を含む)

範囲なし

802.10 SAID

100001(100000 + VLAN ID)

1〜4294967294

MTUサイズ

1500

1500〜18190

トランスレーショナル
ブリッジ1

0

0〜1005

トランスレーショナル
ブリッジ2

0

0〜1005

VLANステート

active

アクティブ、サスペンド

Remote SPAN(RSPAN)

ディセーブル

イネーブル、ディセーブル

プライベートVLAN

設定なし

2〜1001、1006〜4094

イーサネットVLANの作成または変更

VLANデータベースの各イーサネットVLANは一意の4桁(1〜1001)のIDを持ちます。VLAN IDの1002〜1005はトークン リングおよびFDDI VLAN用です。VLANデータベースにVLAN標準範囲VLANを追加するには、VLANに番号と名前を割り当てます。

スイッチがVTPトランスペアレント モードにある場合は、1006を超えるVLAN IDを割り当てることができますが、VLANデータベースには追加されません。 拡張範囲VLANの設定 を参照してください。

VLANの追加時に指定されるデフォルト パラメータの一覧は、 標準範囲VLANの設定 を参照してください。

config-vlanモードを使用してイーサネットVLANを作成または変更するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id

VLAN IDを入力し、config-vlanモードを開始します。VLANを新規に作成するには新しいVLAN IDを、既存のVLANを変更するには、そのVLAN IDを入力します。

(注) このコマンドに指定可能なVLAN ID範囲は、1〜4094です。1005を超えるVLAN ID(拡張範囲VLAN)の詳細については、 拡張範囲VLANの設定 を参照してください。

ステップ 3

name vlan-name

(任意)VLANの名前を入力します。VLAN名を指定しない場合には、デフォルトとして、VLANという文字列の後ろに先頭の0付きで vlan-id が付加されます。たとえば、VLAN 4のデフォルトのVLAN名はVLAN0004です。

ステップ 4

mtu mtu-size

(任意)MTUサイズ(またはその他のVLAN特性)を変更します。

ステップ 5

remote-span

(任意)VLANをリモートSPANセッションのRSPAN VLANとして設定します。リモートSPANの詳細については、 第27章 「SPANおよびRSPANの設定」 を参照してください。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 8

copy running-config startup config

(任意)スイッチがVTPトランスペアレント モードにある場合は、VLAN設定は、VLANデータベースだけでなく実行コンフィギュレーション ファイルにも保存されます。これは、スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。

VLAN名をデフォルト設定に戻すには、 no name no mtu 、または no remote-span config-vlanコマンドを使用します。

次に、config-vlanモードを使用してイーサネットVLAN 20を作成し、 test20 と名前を付け、VLANデータベースに追加する例を示します。

Switch# configure terminal

Switch(config)# vlan 20

Switch(config-vlan)# name test20

Switch(config-vlan)# end

VLANデータベース コンフィギュレーション モードを使用すると、イーサネットVLANを作成または変更することもできます。

VLANデータベース コンフィギュレーション モードは、RSPAN VLAN設定または拡張範囲VLANをサポートしていません。

VLANデータベース コンフィギュレーション モードを使用してイーサネットVLANを作成または変更するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

vlan database

VLANデータベース コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id name vlan-name

番号を割り当てることによって、イーサネットVLANを追加します。指定可能な範囲は、1〜1001です。 vlan first-vlan-id end last-vlan-id を指定すると、連続するVLANの範囲を作成または変更できます。

(注) VLANデータベース コンフィギュレーション モードでVLAN IDを入力する場合は、先頭の0は入力しないでください。

VLAN名を指定しない場合には、デフォルトとして、VLANという文字列の後ろに先頭の0付きで vlan-id が付加されます。たとえば、VLAN 4のデフォルトのVLAN名はVLAN0004です。

ステップ 3

vlan vlan-id mtu mtu-size

(任意)VLANを変更するには、VLANを特定してMTUサイズなどの特性を変更します。

ステップ 4

exit

VLANデータベースをアップデートし、アップデート情報を管理ドメイン全体に伝播させて、イネーブルEXECモードに戻ります。

ステップ 5

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 6

copy running-config startup config

(任意)スイッチがVTPトランスペアレント モードにある場合は、VLAN設定は、VLANデータベースだけでなく実行コンフィギュレーション ファイルにも保存されます。これは、スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。

VLAN名をデフォルト設定に戻すには、 no vlan vlan-id name または no vlan vlan-id mtu VLANデータベース コンフィギュレーション コマンドを使用します。

次の例は、VLAN設定モードを使用してイーサネットVLAN 20を作成し、 test20 と名前を付け、VLANデータベースに追加する方法を示しています。

Switch# vlan database

Switch(vlan)# vlan 20 name test20

Switch(vlan)# exit

APPLY completed.

Exiting....

VLANの削除

VTPサーバ モードのスイッチからVLANを削除すると、VTPドメイン内にあるすべてのスイッチのVLANデータベースからそのVLANが削除されます。VTPトランスペアレント モードのスイッチからVLANを削除した場合、そのスイッチ上に限りVLANが削除されます。

メディア タイプが異なるデフォルトのVLANを削除することはできません。たとえば、イーサネットVLAN 1、およびFDDIまたはトークン リングVLANの1002〜1005を削除することはできません。

VLANを削除すると、そのVLANに割り当てられていたすべてのポートが非アクティブになります。これらのポートは、新しいVLANに割り当てられるまで、元のVLANに(非アクティブな状態で)対応付けられたままとなります。

スイッチ上でVLANを削除するには、イネーブルEXECモードでグローバル コンフィギュレーション モードを使用して次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no vlan vlan-id

VLAN IDを入力してVLANを削除します。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vlan brief

VLANが削除されたことを確認します。

ステップ 5

copy running-config startup config

(任意)スイッチがVTPトランスペアレント モードにある場合は、VLAN設定は、VLANデータベースだけでなく実行コンフィギュレーション ファイルにも保存されます。これは、スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。

VLANデータベース コンフィギュレーション モードを使用してVLANを削除するには、VLANデータベース コンフィギュレーション モードを開始する vlan database イネーブルEXECコマンドと、 no vlan vlan-id VLANデータベース コンフィギュレーション コマンドを使用します。

VLANへのスタティック アクセス ポートの割り当て

VTPをディセーブルにして(VTPトランスペアレント モード)、VTPによってVLAN設定情報をグローバルに伝播させずに、スタティック アクセス ポートをVLANに割り当てることができます。

VLANにクラスタ メンバー スイッチのポートを割り当てる場合は、最初に rcommand イネーブルEXECコマンドを使用して、クラスタ メンバー スイッチにログインします。

存在しないVLANにインターフェイスを割り当てると、新しくVLANが作成されます( イーサネットVLANの作成または変更 を参照)。

VLANデータベース内のVLANにポートを割り当てるには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

VLANに追加されるインターフェイスを入力します。

ステップ 3

switchport mode access

ポート(レイヤ2アクセス ポート)のVLANメンバーシップ モードを定義します。

ステップ 4

switchport access vlan vlan-id

VLANにポートを割り当てます。有効なVLAN IDは、1〜4094です。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show running-config interface interface-id

インターフェイスのVLANメンバーシップ モードを確認します。

ステップ 7

show interfaces interface-id switchport

表示された Administrative Mode および Access Mode VLAN フィールドの設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスの設定をデフォルトに戻すには、 default interfac e interface-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、ポートをVLAN 2のアクセス ポートとして設定する例を示します。

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)# interface gigabitethernet1/0/1

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 2

Switch(config-if)# end

拡張範囲VLANの設定

スイッチがVTPトランスペアレント モード(VTPがディセーブル)にある場合は、拡張範囲VLAN(1006〜4094の範囲)を作成できます。拡張範囲VLANにより、サービス プロバイダーはインフラストラクチャをさらに多数のカスタマーに拡張できます。拡張範囲VLAN IDは、VLAN IDを許可するどのスイッチポート コマンドでも許可されます。拡張範囲VLANは、常にconfig-vlanモード( vlan vlan-id グローバル コンフィギュレーション コマンドを入力してアクセス)を使用して設定します。拡張範囲は、VLANデータベース コンフィギュレーション モード( vlan database イネーブルEXECコマンドを入力してアクセス)ではサポートされていません。

拡張範囲VLANの設定は、VLANデータベースには保存されませんが、VTPモードがトランスペアレントなので、スイッチの実行コンフィギュレーション ファイルに保存されます。また、 copy
running-config startup-config
イネーブルEXECコマンドを使用するとスタートアップ コンフィギュレーション ファイルに設定を保存できます。

スイッチは4094のVLAN IDをサポートしますが、サポートされるVLANの実数については サポートされるVLAN を参照してください。

ここでは拡張範囲VLANについて説明します。内容は次のとおりです。

VLANのデフォルト設定
拡張範囲VLANの設定時の注意事項
拡張範囲VLANの作成
内部VLAN IDを指定した拡張範囲VLANの作成

VLANのデフォルト設定

イーサネットVLANのデフォルト設定については、 表12-2 を参照してください。拡張範囲VLANについてはMTUサイズとRSPAN設定ステートしか変更できません。残りの特性はデフォルト状態のままでなければなりません。

拡張範囲VLANの設定時の注意事項

拡張範囲VLAN作成時は、次の注意事項に従ってください。

拡張範囲VLANを追加するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを使用してconfig-vlanモードにアクセスする必要があります。拡張範囲VLANは、VLANデータベース コンフィギュレーション モード( vlan database イネーブルEXECコマンドを入力してアクセス)では追加できません。
拡張範囲のVLAN IDはVLANデータベースに保存されず、VTPによって認識されません。
プルーニング適格範囲に拡張範囲VLANを入れることはできません。
拡張範囲VLANの作成時は、スイッチはVTPトランスペアレント モードでなければなりません。VTPモードがサーバまたはクライアントの場合は、エラー メッセージが生成され、拡張範囲VLANは拒否されます。
グローバル コンフィギュレーション モードまたはVLANデータベース コンフィギュレーション モードで、VTPモードをトランスペアレントに設定できます。 VTPのディセーブル化(VTPトランスペアレント モード) を参照してください。この設定をスタートアップ コンフィギュレーションに保存して、スイッチがVTPトランスペアレント モードで起動するようにする必要があります。そうしないとスイッチをリセットした場合に、拡張範囲VLANの設定が失われます。
拡張範囲VLANでは、STPはデフォルトでイネーブルに設定されていますが、no spanning-tree vlan vlan-id グローバル コンフィギュレーション コマンドを使用するとディセーブルにできます。スイッチ上にスパニングツリー インスタンスの最大数(128) がある場合、新たに作成されたどのVLANでもスパニングツリーはディセーブルになっています。スイッチ上のVLAN数がサポートされるスパニング ツリー インスタンスの最大数を超える場合は、IEEE 802.1s MSTPをスイッチに設定して、複数のVLANを単一のSTPインスタンスにマッピングすることを推奨します。MSTPの詳細については、 第18章 「MSTPの設定」 を参照してください。
スイッチ上の各ルーテッド ポートは、内部VLANを作成して使用します。この内部VLANは拡張範囲VLAN番号を使用し、その内部VLAN IDは拡張範囲VLANには使用できません。内部VLANとして割り当て済みのVLAN IDを指定して拡張範囲VLANを作成すると、エラー メッセージが生成され、コマンドは拒否されます。
− 内部VLAN IDは拡張範囲の下部の方なので、拡張範囲VLANを作成するには最大の番号(4094)から始めて最小値(1006)へと動いて、内部VLAN IDを使用する可能性を減らすことを推奨します。
− 拡張範囲VLANを設定する前に、 show vlan internal usage イネーブルEXECコマンドを入力して、どのVLANが内部VLANとして割り当てられているかを確認します。
− 必要に応じて内部VLANに割り当てられたルーテッド ポートをシャットダウンできます。これにより、内部VLANが解放され、拡張範囲VLANを作成してポートを再度イネーブルにし、別のVLANを内部VLANとして使用します。 内部VLAN IDを指定した拡張範囲VLANの作成 を参照してください。
スイッチは合計1005(標準範囲および拡張範囲)のVLANをサポートしますが、ルーテッド ポート、SVI、その他の設定済み機能の個数によって、スイッチのハードウェアの使用は左右されます。拡張範囲のVLANを作成しようとしたときに、使用可能なハードウェア リソースが不十分な場合は、エラー メッセージが生成され、拡張範囲のVLANは拒否されます。

拡張範囲VLANの作成

拡張範囲VLANは、グローバル コンフィギュレーション モードで、1006〜4094のVLAN IDを指定して vlan グローバル コンフィギュレーション コマンドを入力して作成します。このコマンドでconfig-vlanモードにアクセスします。拡張範囲VLANはイーサネットVLANのデフォルトの特性を備えており( 表12-2 を参照)、MTUサイズとRSPAN設定だけが変更できるパラメータです。全パラメータのデフォルト設定については、コマンド リファレンスに記載されている vlan グローバル コンフィギュレーション コマンドを参照してください。スイッチがVTPトランスペアレント モードにない場合に拡張範囲VLAN IDを入力すると、config-vlanモードの終了時にエラー メッセージが生成され、拡張範囲VLANは作成されません。

拡張範囲VLANはVLANデータベースに保存されません。スイッチの実行コンフィギュレーション ファイルに保存されます。 copy running-config startup-config イネーブルEXECコマンドを使用すると、スイッチのスタートアップ コンフィギュレーション ファイルに拡張範囲VLANの設定を保存できます。

拡張範囲VLANを作成する前に、 show vlan internal usage イネーブルEXECコマンドを入力して、VLAN IDが内部的に使用されていないことを確認します。VLAN IDが内部的に使用されている場合に、それを解放するには、 内部VLAN IDを指定した拡張範囲VLANの作成 を参照してから拡張範囲VLANを作成してください。

拡張範囲VLANを作成するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp mode transparent

スイッチをVTPトランスペアレント モードに設定し、VTPをディセーブルにします。

ステップ 3

vlan vlan-id

拡張範囲VLAN IDを入力し、config-vlanモードを開始します。指定できる範囲は1006〜4094です。

ステップ 4

mtu mtu-size

(任意)MTUサイズを変更してVLANを変更します。

(注) config-vlanモードではCLI(コマンドライン インターフェイス)ヘルプにすべてのVLANコマンドが表示されますが、拡張範囲VLANにサポートされているのは、 mtu mtu-size コマンドと remote-span コマンドだけです。

ステップ 5

remote-span

(任意)VLANをRSPAN VLANとして設定します。 RSPAN VLANとしてのVLANの設定 を参照してください。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show vlan id vlan-id

VLANが作成されていることを確認します。

ステップ 8

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲VLAN設定を保存するには、スイッチのスタートアップ コンフィギュレーション ファイルにVTPトランスペアレント モード設定と拡張範囲VLAN設定を保存する必要があります。そうしないとスイッチをリセットした場合に、デフォルトでVTPサーバ モードになり、拡張範囲VLAN IDは保存されません。

拡張範囲VLANを削除するには、 no vlan vlan-id グローバル コンフィギュレーション コマンドを使用します。

拡張範囲VLANにスタティック アクセス ポートを割り当てる手順は、標準範囲VLANに対するものと同じです。 VLANへのスタティック アクセス ポートの割り当て を参照してください。

次に、すべてのデフォルト特性を備えた新しい拡張範囲VLANを作成し、config-vlanモードを開始し、スイッチのスタートアップ コンフィギュレーション ファイルに新しいVLANを保存する例を示します。

Switch(config)# vtp mode transparent

Switch(config)# vlan 2000

Switch(config-vlan)# end

Switch# copy running-config startup config

内部VLAN IDを指定した拡張範囲VLANの作成

内部VLANに割り当て済みの拡張範囲VLAN IDを入力すると、エラー メッセージが生成され、拡張範囲VLANは拒否されます。内部VLAN IDを手動で解放するには、内部VLAN IDを使用しているルーテッド ポートを一時的にシャットダウンする必要があります。

内部VLANに割り当てられたVLAN IDを解放してそのIDで拡張範囲VLANを作成するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

show vlan internal usage

スイッチが内部的に使用しているVLAN IDを表示します。使用したいVLAN IDが内部VLANである場合は、そのVLAN IDを使用しているルーテッド ポートが表示されます。そのポート番号をステップ3で入力してください。

ステップ 2

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface interface-id

そのVLAN IDを使用しているルーテッド ポートのインターフェイスIDを入力します。

ステップ 4

shutdown

ポートをシャットダウンして内部VLAN IDを解放します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

vtp mode transparent

VTPモードをトランスペアレントに設定して拡張範囲VLANを作成します。

ステップ 7

vlan vlan-id

新しい拡張範囲VLAN IDを入力し、config-vlanモードを開始します。

ステップ 8

exit

config-vlanモードを終了してグローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface interface-id

ステップ4でシャットダウンしたルーテッド ポートのインターフェイスIDを入力します。

ステップ 10

no shutdown

ルーテッド ポートを再度イネーブルにします。新しい内部VLAN IDが割り当てられます。

ステップ 11

end

イネーブルEXECモードに戻ります。

ステップ 12

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲VLAN設定を保存するには、スイッチのスタートアップ コンフィギュレーション ファイルにVTPトランスペアレント モード設定と拡張範囲VLAN設定を保存する必要があります。そうしないとスイッチをリセットした場合に、デフォルトでVTPサーバ モードになり、拡張範囲VLAN IDは保存されません。

VLANの表示

拡張範囲VLANを含めてスイッチ上のすべてのVLANのリストを表示するには、 show vlan イネーブルEXECコマンドを使用します。表示には、VLANのステータス、ポート、およびコンフィギュレーション情報が含まれます。VLANデータベースの標準範囲VLAN(1〜1005)を表示するには、 show VLANデータベース コンフィギュレーション コマンド( vlan database イネーブルEXECコマンドを入力してアクセス)を使用します。スイッチ上のVLAN IDのリストを表示するには、 show vlan イネーブルEXECコマンドを使用します。

表12-3 に、VLANモニタ用のコマンドを示します。

表12-3 VLANモニタ コマンド

コマンド

コマンド モード

説明

show

VLANデータベース コンフィギュレーション

VLANデータベース内のVLANのステータスを表示します。

show current [ vlan-id ]

VLANデータベース コンフィギュレーション

VLANデータベース内のすべての、または指定されたVLANのステータスを表示します。

show interfaces [ vlan vlan-id ]

イネーブルEXEC

スイッチに設定されたすべてのインターフェイス、または指定されたインターフェイスの特性を表示します。

show vlan [ id vlan-id ]

イネーブルEXEC

スイッチのすべての、または指定されたVLANのパラメータを表示します。

showコマンドのオプションと出力フィールドの詳細については、このリリースのコマンド リファレンスを参照してください。

VLANトランクの設定

ここでは、スイッチ上のVLANトランクの機能について説明します。

トランキングの概要
カプセル化タイプ
レイヤ2イーサネット インターフェイスVLANのデフォルト設定
トランク ポートとしてのイーサネット インターフェイスの設定
トランク ポートのロード シェアリングの設定

トランキングの概要

トランクは、1つまたは複数のイーサネット スイッチ インターフェイスと、ルータやスイッチといった他のネットワーキング デバイス間のポイントツーポイント リンクです。イーサネット トランクは1つのリンクを介して複数のVLANトラフィックを搬送するので、VLANをネットワーク全体に拡張できます。

トランキング カプセル化方式は、802.1Qイーサネット インターフェイスで使用できます。802.1Qは、業界標準のトランキング カプセル化方式です。

トランクを設定できるのは、1つのイーサネット インターフェイスまたは1つのEtherChannelバンドルに対してです。EtherChannelの詳細については、 第33章 「EtherChannelの設定」 を参照してください。

イーサネット トランク インターフェイスは、数種類のトランキング モードをサポートしています( 表12-4 を参照)。インターフェイスをトランキングまたは非トランキングとして設定することも、あるいは近接インターフェイスとトランキングをネゴシエーションするように設定することもできます。トランキングの自動ネゴシエーションを設定するには、インターフェイスが同じVTPドメイン内にある必要があります。

トランク ネゴシエーションは、PPP(ポイントツーポイント プロトコル)であるDynamic Trunking Protocol(DTP)によって管理されます。ただし、一部のインターネットワーキング デバイスは、不正にDTPフレームを伝送することがあり、これによって誤った設定になることがあります。

これを避けるには、DTPをサポートしないデバイスに接続しているインターフェイスがDTPフレームを転送しないように設定する(DTPをオフにする)必要があります。

これらのリンクをトランキングしない場合は、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用してトランキングをディセーブルにします。
DTPをサポートしないデバイスに対するトランキングをイネーブルにするには、 switchport
mode
trunk および switchport nonegotiate インターフェイス コンフィギュレーション コマンドを使用します。これにより、インターフェイスがトランクになりますがDTPフレームは生成されません。 switchport trunk encapsulation dot1q インターフェイス コンフィギュレーション コマンドを使用して、トランク ポートのカプセル化タイプを選択できます。

また、DTPインターフェイスでは、トランクでのISLまたは802.1Qカプセル化の使用、あるいはカプセル化タイプの自動ネゴシエーションを指定することもできます。DTPは、802.1Qトランクの自動ネゴシエーションをサポートします。

DTPはプライベートVLANポートまたはトンネル ポートではサポートされていません。

トンネル ポートはDTPをサポートしません。トンネル ポートの詳細については、 IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定 を参照してください。

表12-4 レイヤ2インターフェイス モード

モード

説明

switchport mode access

インターフェイス(アクセス ポート)は永続的な非トランキング モードになり、リンクを非トランク リンクに変換するようにネゴシエーションします。インターフェイスは、近接インターフェイスがトランク インターフェイスであるかどうかに関係なく、非トランク インターフェイスになります。

switchport mode dynamic auto

インターフェイスがリンクをトランク リンクに変換できるようにします。近接インターフェイスが trunk または desirable モードに設定されていれば、インターフェイスはトランク インターフェイスになります。すべてのイーサネット インターフェイスのデフォルトのスイッチポート モードは、 dynamic auto です。

switchport mode dynamic desirable

インターフェイスがリンクのトランク リンクへの変換をアクティブに試行するようにします。近接インターフェイスが trunk desirable 、または auto モードに設定されていれば、インターフェイスはトランク インターフェイスになります。

switchport mode trunk

インターフェイスは永続的なトランキング モードになり、近接リンクをトランク リンクに変換するようにネゴシエーションします。近接インターフェイスがトランク インターフェイスでなくても、インターフェイスはトランク インターフェイスになります。

switchport nonegotiate

インターフェイスがDTPフレームを生成しないようにします。このコマンドを使用できるのは、インターフェイスのスイッチポート モードが access または trunk の場合だけです。近接インターフェイスを手動でトランク インターフェイスとして設定して、トランク リンクを確立する必要があります。

switchport mode dot1q-tunnel

802.1Qトランク ポートと非対称リンクで接続するトンネル(非トランキング)ポートとして、インターフェイスを設定します。802.1Qトンネリングは、サービス プロバイダー ネットワーク上でカスタマーVLANの完全性を保つために使用します。トンネル ポートの詳細については、 IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定 を参照してください。

カプセル化タイプ

表12-5 に、イーサネット トランクのカプセル化タイプおよびキーワードを示します。

表12-5 イーサネット トランクのカプセル化タイプ

カプセル化

説明

switchport trunk encapsulation dot1q

トランク リンクに802.1Qカプセル化を指定します。

switchport trunk encapsulation negotiate

インターフェイスが近接インターフェイスとネゴシエーションを行い、近接インターフェイスの設定および機能に応じて、ISLトランク(優先)または802.1Qトランクになるように指定します。これは、スイッチのデフォルトです。

switchport trunk dot1q ethertype value

802.1Qカプセル化のethertype値を設定します。802.1Qタグ付きフレームを識別する、標準外(非デフォルト)の2バイトのethertypeを選択する場合に使用します。デフォルトのethertype値は0x8100です。

このオプションは、Enhanced-Services(ES)ポート上でのみサポートされます。

スイッチはレイヤ3トランクをサポートしません。したがって、サブインターフェイスを設定したり、レイヤ3インターフェイスで encapsulation キーワードを使用したりすることはできません。ただし、スイッチは、同等の機能を備えたレイヤ2トランクおよびレイヤ3 VLANインターフェイスをサポートします。

802.1Qの設定に関する注意事項

802.1Qトランクでは、ネットワークのトランキング方式に次の制約があります。

802.1Qトランクを使用して接続したシスコのスイッチのネットワークでは、スイッチはトランク上で許可されたVLANごとに1つのスパニングツリー インスタンスを維持します。他社製のデバイスは、すべてのVLANに対して1つのスパニングツリー インスタンスをサポートする場合があります。

802.1Qトランクを使用して他社製のデバイスにシスコのスイッチを接続する場合、シスコのスイッチは、トランクのVLANのスパニングツリー インスタンスを他社製802.1Qスイッチのスパニングツリー インスタンスと結合します。ただし、各VLANのスパニングツリー情報は、他社製の802.1Qスイッチからなるクラウドにより分離されたシスコのスイッチによって維持されます。シスコのスイッチを分離する他社製の802.1Qスイッチ クラウドは、スイッチ間の1つのトランク リンクとして取り扱われます。

802.1Qトランクに対応するネイティブVLANが、トランク リンクの両端で一致していなければなりません。トランクの一方のネイティブVLANともう一方のネイティブVLANが異なっていると、スパニングツリー ループが発生する可能性があります。
ネットワーク内のすべてのVLANでスパニングツリーをディセーブルにしないまま、802.1QトランクのネイティブVLANでスパニングツリーをディセーブルにすると、スパニングツリー ループが発生する可能性があります。802.1QトランクのネイティブVLANでスパニングツリーをイネーブルのままにしておくか、または、ネットワーク内のすべてのVLANでスパニングツリーをディセーブルにしてください。また、ネットワークにループがないことを確認してから、スパニングツリーをディセーブルにしてください。
ESポート上では、 switchport trunk dot1q ethertype value インターフェイス コンフィギュレーション コマンドを使用して、インターフェイス用のカスタムなethertype値を設定できます。この機能を使用すると、スイッチは802.1Qタグ付きフレームを識別するために標準の0x8100 ethertypeを使用しないサードパーティ ベンダー製スイッチと相互運用できるようになります。たとえば、トランク ポートでカスタムな802.1Q ethertypeとして0x1234を設定すると、このethertypeを含む着信フレームは、標準802.1Qトランクの場合と同じように、ethertypeの後ろのタグに含まれるVLANに割り当てられます。標準ethertype(0x8100)またはカスタムethertype値を設定したトランク ポートに着信するフレームは、有効な802.1Qトラフィックとして取り扱われます。それ以外のethertypeを含むフレームは、そのトランクのネイティブVLANに割り当てられます。ethertype値0x8100を持った出力トラフィックは、カスタマーethertypeにマッピングされます。

レイヤ2イーサネット インターフェイスVLANのデフォルト設定

表12-6 に、レイヤ2イーサネット インターフェイスVLANのデフォルト設定を示します。

表12-6 レイヤ2イーサネット インターフェイスVLANのデフォルト設定

機能

デフォルト設定

インターフェイス モード

switchport mode dynamic auto

トランク カプセル化

switchport trunk encapsulation negotiate

802.1Qカプセル化のethertype値

0x8100

許可VLAN範囲

VLAN 1〜4094

プルーニング適格のVLAN範囲

VLAN 2〜1001

デフォルトVLAN(アクセス ポート用)

VLAN 1

ネイティブVLAN(802.1Qトランク用)

VLAN 1

トランク ポートとしてのイーサネット インターフェイスの設定

トランク ポートはVTPアドバタイズを送受信するので、VTPを使用するためには、スイッチに少なくとも1つのトランクポートが設定されており、そのトランク ポートが別のスイッチのトランク ポートに接続されていることを確認する必要があります。そうでない場合、スイッチはVTPアドバタイズを受信できません。

ここでは、スイッチ上でイーサネット インターフェイスをトランク ポートとして設定する手順について説明します。

他の機能との相互作用
トランク上での許可VLANの定義
プルーニング適格リストの変更
タグなしトラフィック用ネイティブVLANの設定

デフォルトでは、インターフェイスはレイヤ2モードです。レイヤ2インターフェイスのデフォルト モードは、 switchport mode dynamic auto です。近接インターフェイスがトランキングをサポートし、トランキングを許可するように設定されている場合、リンクはレイヤ2トランクです。また、インターフェイスがレイヤ3モードの場合は、 switchport インターフェイス コンフィギュレーション コマンドを入力するとレイヤ2トランクになります。デフォルトでは、トランクはカプセル化をネゴシエーションします。近接インターフェイスがISLおよび802.1Qカプセル化の両方をサポートし、両方のインターフェイスがカプセル化タイプをネゴシエーションするように設定されている場合は、トランクはISLカプセル化を使用します。

他の機能との相互作用

トランキングは、次のように他の機能と相互作用します。

トランク ポートはセキュア ポートにできません。
トランク ポートはトンネル ポートにできません。
トランク ポートはEtherChannelポート グループにまとめることができますが、グループ内のすべてのトランクは同じ設定にしておく必要があります。グループを初めて作成したときは、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次に示すパラメータのいずれかの設定を変更すると、スイッチは、入力された設定をグループ内のすべてのポートに伝播します。
− 許可VLANリスト
− 各VLANのSTPポート プライオリティ
− STP PortFastの設定値
− トランク ステータス:ポート グループ内の1つのポートがトランクでなくなった場合、すべてのポートがトランクでなくなります。
設定するトランク ポートは、PVSTモードでは24個まで、MSTモードでは40個までにすることを推奨します。
トランク ポートで802.1xをイネーブルにしようとすると、エラー メッセージが表示され、802.1xはイネーブルになりません。802.1x対応ポートのモードをトランクに変更しようとしても、ポート モードは変更されません。
ダイナミック モードのポートは、近接ポートとネゴシエーションしてトランク ポートになることができます。ダイナミック ポートで802.1xをイネーブルにしようとすると、エラー メッセージが表示され、802.1xはイネーブルになりません。802.1x対応ポートのモードをダイナミックに変更しようとしても、ポート モードは変更されません。

トランク ポートの設定

ポートをISLトランク ポートまたは802.1Qトランク ポートとして設定するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トランキング用に設定するポートを入力します。

ステップ 3

switchport trunk encapsulation { isl | dot1q | negotiate }

ISLまたは802.1Qカプセル化をサポートするように、またはカプセル化タイプについて近接インターフェイスとネゴシエーションする(デフォルト)ようにポートを設定します。

リンクの各終端に同じカプセル化タイプを設定する必要があります。

ステップ 4

switchport mode { dynamic { auto | desirable } | trunk }

インターフェイスをレイヤ2トランクとして設定します(インターフェイスがレイヤ2アクセス ポートまたはトンネル ポートである場合、またはトランキング モードを設定する場合に限り必要となります)。

dynamic auto ― 近接インターフェイスがtrunkまたはdesirableモードに設定されている場合に、トランク リンクとしてインターフェイスを設定します。これはデフォルト設定です。
dynamic desirable ― 近接インターフェイスがtrunk、desirable、またはautoモードに設定されている場合に、トランク リンクとしてインターフェイスを設定します。
trunk ― 近接インターフェイスがトランク インターフェイスではない場合でも、インターフェイスを永続的なトランキング モードに設定し、リンクをトランク リンクに変換するようネゴシエーションします。

ステップ 5

switchport access vlan vlan-id

(任意)デフォルトVLANを指定します。これは、インターフェイスがトランキングを停止した場合に使用されます。

ステップ 6

switchport trunk native vlan vlan-id

802.1Qトランク用にネイティブVLANを指定します。

ステップ 7

end

イネーブルEXECモードに戻ります。

ステップ 8

show interfaces interface-id switchport

表示された Administrative Mode および Administrative Trunking
Encapsulation
フィールドにインターフェイスのスイッチポート設定を表示します。

ステップ 9

show interfaces interface-id trunk

インターフェイスのトランク設定を表示します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスの設定をデフォルトに戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを 使用します。トランキング インターフェイスのすべてのトランキング特性をデフォルトにリセットするには、 no switchport trunk インターフェイス コンフィギュレーション コマンドを使用します。トランキングをディセーブルにするには、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用してポートをスタティック アクセス ポートとして設定します。

次に、ポートを802.1Qトランクとして設定する例を示します。ここでは、近接インターフェイスが802.1Qトランキングをサポートするよう設定されていると仮定しています。

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)# interface gigabitethernet1/0/2

Switch(config-if)# switchport mode dynamic desirable

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# end

トランク上での許可VLANの定義

デフォルトでは、トランク ポートはすべてのVLANに対してトラフィックの送受信を行います。各トランクで、すべてのVLAN ID(1〜4094)が許可されます。ただし、許可リストからVLANを削除することにより、それらのVLANからのトラフィックがトランク上を流れないようにできます。トランクが伝送するトラフィックを制限するには、 switchport trunk allowed vlan remove vlan-list インターフェイス コンフィギュレーション コマンドを使用して、許可リストから特定のVLANを削除します。

VLAN 1は、すべてのシスコのスイッチ内のすべてのトランクポートのデフォルト VLANです。以前は、すべてのトランク リンクでVLAN 1を常にイネーブルにしておく必要がありました。VLAN 1上でユーザ トラフィック(スパニング ツリー アドバタイズを含む)が送受信されないように、VLAN 1最小化機能を使用して、任意の個々のVLANトランク リンクでVLAN 1をディセーブルにできます。

スパニングツリー ループまたはストームのリスクを削減するために、許可リストからVLAN 1を削除して、いずれかの個々のVLANトランク ポートのVLAN 1をディセーブルにできます。トランク ポートからVLAN 1を削除しても、インターフェイスは、たとえば、Cisco Discovery Protocol
(CDP)、Port Aggregation Protocol(PAgP)、Link Aggregation Control Protocol(LACP)、DTP、VLAN 1内のVTPなどの管理トラフィックを送受信し続けます。

VLAN 1がディセーブルなトランク ポートが非トランク ポートに変換された場合は、アクセスVLANに追加されます。アクセスVLANが1に設定されている場合、 switchport trunk allowed 設定に関係なく、ポートはVLAN 1に追加されます。ポート上でディセーブルなすべてのVLANについて、同じことが当てはまります。

トランクポートは、VLANがイネーブルになっており、VTPがVLANを認識し、かつポートの許可リストにそのVLANが登録されている場合に、VLANのメンバーになることができます。VTPが新しくイネーブルにされたVLANを認識し、そのVLANがトランク ポートの許可リストに登録されている場合、トランク ポートは自動的にそのイネーブルにされたVLANのメンバーになります。VTPが新しいVLANを認識し、そのVLANがトランク ポートの許可リストに登録されていない場合には、トランク ポートはその新しいVLANのメンバーにはなりません。

ISLトランクまたは802.1Qトランクの許可リストを変更するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode trunk

インターフェイスをVLANトランク ポートとして設定します。

ステップ 4

switchport trunk allowed vlan { add | all | except | remove } vlan-list

(任意)トランク上で許可されるVLANのリストを設定します。

add all except remove キーワードの使用法については、このリリースのコマンド リファレンスを参照してください。

vlan-list パラメータは、1〜4094のうちいずれか1つのVLAN番号か、値の小さい方を先にしてハイフンで区切られた2つのVLAN番号で指定する一定範囲のVLANです。カンマで区切られたVLANパラメータやハイフンで指定された範囲の間には、スペースは入れないでください。

デフォルトではすべてのVLANが許可されています。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Trunking VLANs Enabled フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべてのVLANの許可VLANリストをデフォルトに戻すには、 no switchport trunk allowed vlan インターフェイス コンフィギュレーション コマンドを使用します。

次に、ポートの許可VLANリストからVLAN 2を削除する例を示します。

Switch(config)# interface gigabitethernet1/0/1

Switch(config-if)# switchport trunk allowed vlan remove 2

Switch(config-if)# end

プルーニング適格リストの変更

プルーニング適格リストは、トランク ポートだけに適用されます。各トランク ポートには、それぞれ独自の適格リストがあります。次の手順を有効にするためには、VTPプルーニングがイネーブルに設定されている必要があります。VTPプルーニングをイネーブルにする手順については、 VTPプルーニングのイネーブル化 を参照してください。

トランク ポートのプルーニング適格リストからVLANを削除するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、VLANプルーニングを適用するトランク ポートを選択します。

ステップ 3

switchport trunk pruning vlan { add | except | none | remove } vlan-list [ ,vlan [ ,vlan [ ,,, ]]

トランクからのプルーニングが許可されているVLANのリストを設定します( VTPプルーニング を参照)。

add except none 、および remove キーワードの使用法については、このリリースのコマンド リファレンスを参照してください。

連続しないVLAN IDは、スペースを入れずにカンマで区切ります。IDの範囲を表すには、ハイフンを使用します。有効なIDは、2〜1001です。 拡張範囲VLAN(VLAN IDが1006〜4094)はプルーニングできません。

プルーニング不適格とされたVLANは、フラッディング トラフィックを受信します。

デフォルトでは、プルーニングが許可されるVLANのリストには、VLAN 2〜1001が含まれています。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show interfaces interface-id switchport

表示された Pruning VLANs Enabled フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべてのVLANのプルーニング適格リストをデフォルトに戻すには、 no switchport trunk pruning vlan インターフェイス コンフィギュレーション コマンドを使用します。

タグなしトラフィック用ネイティブVLANの設定

802.1Qタギングが設定されたトランク ポートは、タグ付きトラフィックおよびタグなしトラフィックの両方を受信できます。デフォルトでは、スイッチはタグなしトラフィックをポートに設定されたネイティブVLANに伝送します。ネイティブVLANは、デフォルトではVLAN 1です。

ネイティブVLANには任意のVLAN IDを割り当てることができます。

802.1Q設定の詳細については、 802.1Qの設定に関する注意事項 を参照してください。

802.1QトランクでネイティブVLANを設定するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、
802.1Qトランクとして設定するインターフェイスを定義します。

ステップ 3

switchport trunk native vlan vlan-id

トランク ポート上でタグなしトラフィックを送受信しているVLANを設定します。

vlan-id に指定できる範囲は、1〜4094です。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show interfaces interface-id switchport

表示された Trunking Native Mode VLAN フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ネイティブVLANをデフォルトのVLAN 1に戻すには、 no switchport trunk native vlan インターフェイス コンフィギュレーション コマンドを使用します。

パケットのVLAN IDが発信ポートのネイティブVLAN IDと同じであれば、そのパケットはタグなしで伝送されます。同じでない場合、スイッチはそのパケットをタグ付きで伝送します。

トランク ポートのロード シェアリングの設定

ロード シェアリングにより、スイッチに接続しているパラレル トランクの提供する帯域幅が分割されます。STPは通常、ループを防止するために、スイッチ間で1つのパラレル リンク以外のすべてのリンクをブロックします。ロード シェアリングを行うと、トラフィックが属するVLANに基づいて、リンク間でトラフィックが分割されます。

トランクポートでロード シェアリングを設定するには、STPポート プライオリティまたはSTPパス コストを使用します。STPポート プライオリティを使用してロード シェアリングを設定する場合には、両方のロード シェアリング リンクを同じスイッチに接続する必要があります。STPパスコストを使用してロード シェアリングを設定する場合には、それぞれのロード シェアリング リンクを同じスイッチに、または2台の異なるスイッチに接続できます。STPの詳細については、 第17章 「STPの設定」 を参照してください。

STPポート プライオリティによるロード シェアリング

同一スイッチ上の2つのポートがループを形成すると、STPポート プライオリティの設定により、イネーブルになるポートとブロッキング ステートになるポートが決まります。パラレル トランク ポートにプライオリティを設定すると、そのポートは、特定のVLANのすべてのトラフィックを搬送させることができます。VLANに対するプライオリティがより高い(より小さい値)トランク ポートがそのVLANのトラフィックを伝送します。同じVLANに対してプライオリティのより低い(より大きい値)トランク ポートは、そのVLANに対してブロッキング ステートのままです。1つのトランク ポートが特定のVLANに関するすべてのトラフィックを送受信することになります。

図12-2 に、サポート対象スイッチを接続する2つのトランクを示します。この例では、スイッチは次のように設定されています。

VLAN 8〜10は、トランク1でポート プライオリティ16が与えられています。
VLAN 3〜6は、トランク1でデフォルトのポート プライオリティ128のままです。
VLAN 3〜6は、トランク2でポート プライオリティ16が与えられています。
VLAN 8〜10は、トランク2でデフォルトのポート プライオリティ128のままです。

このように設定すると、トランク1がVLAN 8〜10のトラフィックを搬送し、トランク2がVLAN 3〜6のトラフィックを搬送します。アクティブ トランクで障害が起きた場合には、プライオリティのより低いトランクが引き継ぎ、すべてのVLANのトラフィックを搬送します。どのトランク ポート上でも、トラフィックの重複は発生しません。

図12-2 STPポート プライオリティによるロード シェアリング

図12-2 に示すネットワークを設定するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

スイッチAで、グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp domain domain-name

VTP管理ドメインを設定します。

1〜32文字のドメイン名を使用できます。

ステップ 3

vtp mode server

スイッチAをVTPサーバとして設定します。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show vtp status

スイッチAおよびBの両方で、VTP設定を確認します。

表示された VTP Operating Mode および VTP Domain Name フィールドをチェックします。

ステップ 6

show vlan

スイッチAのデータベースにVLANが存在していることを確認します。

ステップ 7

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 8

interface gigabitethernet1/ 0/1

インターフェイス コンフィギュレーション モードを開始し、トランクに設定するインターフェイスとしてギガビット イーサネット ポート1を定義します。

ステップ 9

switchport trunk encapsulation { isl | dot1q | negotiate }

ISLカプセル化または802.1Qカプセル化をサポートするように、または近接インターフェイスとネゴシエーションするようにポートを設定します。リンクの各終端に同じカプセル化タイプを設定する必要があります。

ステップ 10

switchport mode trunk

ポートをトランク ポートとして設定します。

ステップ 11

end

イネーブルEXECモードに戻ります。

ステップ 12

show interfaces gigabitethernet1/ 0/1 switchport

VLAN設定を確認します。

ステップ 13

スイッチの2番めのインターフェイスに対して、スイッチA上でステップ7〜11を実行します。

ステップ 14

スイッチAに設定されたトランク ポートに接続するトランク ポートを設定するため、スイッチBでステップ7〜11を実行します。

ステップ 15

show vlan

トランク リンクがアクティブになると、VTPがスイッチBにVTPおよびVLAN情報を流します。スイッチBがVLAN設定を学習したことを確認します。

ステップ 16

configure terminal

スイッチAで、グローバル コンフィギュレーション モードを開始します。

ステップ 17

interface gigabitethernet1/ 0/1

インターフェイス コンフィギュレーション モードを開始し、STPポート プライオリティを設定するインターフェイスを定義します。

ステップ 18

spanning-tree vlan 8-10 port-priority 16

VLAN 8〜10にポート プライオリティ16を割り当てます。

ステップ 19

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 20

interface gigabitethernet1/ 0/2

インターフェイス コンフィギュレーション モードを開始し、STPポート プライオリティを設定するインターフェイスを定義します。

ステップ 21

spanning-tree vlan 3-6 port-priority 16

VLAN 3〜6にポート プライオリティ16を割り当てます。

ステップ 22

end

イネーブルEXECモードに戻ります。

ステップ 23

show running-config

設定を確認します。

ステップ 24

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

STPパス コストによるロード シェアリング

トランクに異なるパス コストを設定し、各パス コストを異なるVLANセットに対応付け、VLANごとに異なるポートをブロッキングすることにより、VLANトラフィックを分担するようにパラレル トランクを設定できます。VLANは、トラフィックを個別に保持し、リンクが失われても冗長性を維持します。

図12-3 で、トランク ポート1および2は100BASE-Tポートとして設定されています。次のVLANパス コストが割り当てられています。

VLAN 2〜4には、トランク ポート1でパス コスト30が割り当てられています。
VLAN 8〜10は、トランク ポート1で100BASE-Tのデフォルトのパス コスト19のままになっています。
VLAN 8〜10には、トランク ポート2でパス コスト30が割り当てられています。
VLAN 2〜4は、トランク ポート2で100BASE-Tのデフォルトのパス コスト19のままになっています。
図12-3 パス コストによってトラフィックが分散されるロード シェアリング トランク

図12-3 に示すネットワークを設定するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

スイッチAで、グローバル コンフィギュレーション モードを開始します。

ステップ 2

interfa c e gigabitethernet1/0/1

インターフェイス コンフィギュレーション モードを開始し、トランクに設定するインターフェイスとしてギガビット イーサネット ポート1を定義します。

ステップ 3

switchport trunk encapsulation
{ isl | dot1q | negotiate }

ISLカプセル化または802.1Qカプセル化をサポートするようにポートを設定します。リンクの各終端に同じカプセル化タイプを設定する必要があります。

ステップ 4

switchport mode trunk

ポートをトランク ポートとして設定します。

トランクは、デフォルトでISLトランキングが設定されます。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

スイッチAの2番めのインターフェイスについて、ステップ2〜4を繰り返します。

ステップ 7

end

イネーブルEXECモードに戻ります。

ステップ 8

show running-config

設定を確認します。ステップ2〜6で設定したインターフェイスがトランク ポートになっていることを出力で確認します。

ステップ 9

show vlan

トランク リンクがアクティブになると、スイッチAが他のスイッチからVTP情報を受信します。スイッチAがVLAN設定を学習したことを確認します。

ステップ 10

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 11

interface gigabitethernet1/ 0/1

インターフェイス コンフィギュレーション モードを開始し、STPコストを設定するインターフェイスとしてギガビット イーサネット ポート1を定義します。

ステップ 12

spanning-tree vlan 2-4 cost 30

VLAN 2〜4に対し、スパニングツリー パス コストを30に設定します。

ステップ 13

end

グローバル コンフィギュレーション モードに戻ります。

ステップ 14

スイッチAに設定済みのその他のトランク インターフェイスに対してステップ9〜11を繰り返し、VLAN 8、9、10に対して、スパニングツリー パス コストを30に設定します。

ステップ 15

exit

イネーブルEXECモードに戻ります。

ステップ 16

show running-config

設定を確認します。両方のトランク インターフェイスにパス コストが正しく設定されていることを出力で確認します。

ステップ 17

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VMPSの設定

VLAN Query Protocol(VQP)は、ダイナミック アクセス ポートをサポートするために使用します。ダイナミック アクセス ポートは、永続的にVLANに割り当てられるのではなく、ポート上で認識されたMAC送信元アドレスに基づいてVLANに割り当てられます。スイッチは、不明のMACアドレスを認識するたびに、VQPクエリをリモートVMPSへ送信します。クエリには、新たに認識されたMACアドレスと認識元のポートが含まれます。VMPSは、ポートのVLAN割り当てと一緒に応答を返します。このスイッチはVMPSサーバとしては使用できませんが、VMPSのクライアントとして動作し、VQPを介してVMPSと通信します。

ここではVMPSの設定について説明します。

VMPSの概要
VMPSクライアントのデフォルト設定
VMPS設定時の注意事項
VMPSクライアントの設定
VMPSのモニタ
ダイナミック アクセス ポートVLANメンバーシップのトラブルシューティング
VMPSの構成例

VMPSの概要

クライアント スイッチは、新たなホストのMACアドレスを受け取るたびに、VQPクエリをVMPSに送信します。VMPSは、このクエリを受信すると、自身のデータベースでMACアドレス/VLAN間のマッピングを検索します。サーバはこのマッピングと、サーバがオープン モードかセキュア モードであるかに基づいて応答を返します。セキュア モードでは、サーバは、違法なホストを検出すると、そのポートをシャットダウンします。オープン モードでは、サーバは単にポートへのホストのアクセスを拒否するだけです。

ポートが現在 未割り当て(unassigned) の場合(つまり、まだVLANに割り当てられていない)、
VMPSは次の応答のいずれかを返します。

ホストがポート上で許可されている場合、VMPSは、割り当てられたVLAN名を含み、ホストへのアクセスを許可する VLAN割り当て (vlan-assignment) の応答をクライアントへ送信します。
ホストがポート上で許可されておらず、かつ、VMPSがオープン モードである場合、VMPSは アクセス拒否(access-denied) の応答を送信します。
VLANがポート上で許可されておらず、かつ、VMPSがセキュア モードの場合、VMPSは ポート シャットダウン(port-shutdown) の応答を送信します。

ポートがすでにVLAN割り当てを持つ場合は、VMPSは次の応答のいずれかを返します。

データベース内のVLANがポート上の現在のVLANと一致する場合、VMPSは 成功(success) の応答を返し、ホストへのアクセスを許可します。
データベースのVLANとポート上の現在のVLANが一致せず、かつ、ポート上にアクティブなホストがある場合、VMPSのセキュア モードに応じて、VMPSは アクセス拒否 または ポート シャットダウン の応答を送信します。

VMPSから アクセス拒否 の応答を受信したスイッチは、引き続き、そのホストMACアドレスとやり取りされるトラフィックをブロックします。また、スイッチは引き続きそのポート宛てのパケットをモニタし、新しいホスト アドレスを検出するたびに、VMPSにクエリを送ります。VMPSから ポート シャットダウン の応答を受け取ったスイッチは、ポートをディセーブルにします。このポートは、CLIまたはSNMP(簡易ネットワーク管理プロトコル)を使用して、手動で再びイネーブルにする必要があります。

ダイナミック アクセス ポートVLANメンバーシップ

ダイナミック アクセス ポートはIDが1〜4094の1つのVLANにしか属せません。リンクがアクティブになっても、VMPSによってVLAN割り当てが行われるまで、スイッチとこのポート間ではトラフィックの伝送は行われません。VMPSはダイナミック アクセス ポートに接続された新しいホストの最初のパケットから送信元MACアドレスを受信し、VMPSデータベースに登録されているVLANとそのMACアドレスを照合します。

MACアドレスとVMPSデータベース内のVLANが一致した場合には、VMPSがそのポートのVLAN番号を送信します。クライアント スイッチがまだ設定されていない場合には、クライアント スイッチは、トランク ポートでVMPSから受信した最初のVTPパケットに指定されているドメイン名を使用します。クライアント スイッチがすでに設定されている場合には、VMPSへのクエリ パケットに自身のドメイン名を指定して、VLAN番号を取得します。VMPSはパケットに指定されたドメイン名が自身のドメイン名と一致することを確認してから、要求を受け入れ、そのクライアント用に割り当てたVLAN番号を使用してクライアントに応答します。一致しなかった場合、VMPSは(VMPSのセキュア モードの設定に応じて)要求を拒否するか、またはポートをシャットダウンします。

ダイナミック アクセス ポート上で複数のホスト(MACアドレス)がアクティブになるのは、それらのホストがすべて同じVLANに属する場合に限られます。ただし、同一ポート上でアクティブのホストが20を超えると、VMPSはそのポートをシャットダウンします。

ダイナミック アクセス ポート上でリンクがダウンすると、そのポートは切り離された状態に戻り、VLANから離脱します。このポートを介してオンラインになるホストは、VQPにより再びVMPSのチェックを受けた後に、ポートがVLANに割り当てられます。

ダイナミック アクセス ポートは、直接ホストに接続できます。また、ネットワークへ接続することもできます。スイッチ上のポートあたり最大20のMACアドレスが許可されます。ダイナミック アクセス ポートは1度に1つのVLANにしか属せません。ただし、VLANは認識されたMACアドレスに応じて時間の経過とともに変更されることがあります。

VMPSクライアントのデフォルト設定

表12-7 に、クライアント スイッチ上のVMPSおよびダイナミック アクセス ポートのデフォルト設定を示します。

表12-7 VMPSクライアントおよびダイナミック アクセス ポートのデフォルト設定

機能

デフォルト設定

VMPSドメイン サーバ

なし

VMPS再確認インターバル

60分

VMPSサーバへの再試行回数

3

ダイナミック アクセス ポート

設定なし

VMPS設定時の注意事項

ダイナミック アクセス ポートVLANメンバーシップには、次の注意事項および制限事項があります。

VMPSを先に設定してから、ダイナミック アクセス ポートとしてポートを設定する必要があります。
ポートをダイナミック アクセス ポートとして設定すると、そのポートに対してスパニングツリーのPortFast機能が自動的にイネーブルになります。PortFastモードにより、ポートがフォワーディング ステートになるプロセスが短縮されます。
802.1xポートは、ダイナミック アクセス ポートとして設定できません。ダイナミック アクセス(VQP)ポートで802.1xをイネーブルにしようとすると、エラー メッセージが表示され、802.1xはイネーブルになりません。802.1x対応ポートをダイナミックVLAN割り当てに変更しようとすると、エラー メッセージが表示され、VLAN設定は変更されません。
トランク ポートをダイナミック アクセス ポートにすることはできません。ただし、トランク ポートに対して switchport access vlan dynamic インターフェイス コンフィギュレーション コマンドを入力できます。 この場合、スイッチは設定値を保持し、後にポートがアクセス ポートとして設定された場合にはその設定値が適用されます。

ダイナミック アクセスの設定を有効にするには、ポートのトランキングをオフにする必要があります。

ダイナミック アクセス ポートをモニタ ポートにすることはできません。
セキュア ポートをダイナミック アクセス ポートにすることはできません。ダイナミックになる前にポートでのポート セキュリティをディセーブルにする必要があります。
プライベートVLANポートはダイナミック アクセス ポートにすることはできません。
ダイナミック アクセス ポートは、EtherChannelグループのメンバーになることはできません。
ポート チャネルは、ダイナミック アクセス ポートとして設定できません。
ダイナミック アクセス ポートは、代替ブリッジングに加入できます。
VMPSクライアントとVMPSサーバのVTP管理ドメインは同じである必要があります。
VMPSサーバ上に設定されたVLANは、音声VLANにしないでください。

VMPSクライアントの設定

ダイナミックVLANはVMPS(サーバ)を使用して設定します。スイッチはVMPSクライアントにすることはできますが、VMPSサーバにはできません。

VMPSのIPアドレスの入力

スイッチをクライアントとして設定するには、最初にサーバのIPアドレスを入力する必要があります。

スイッチ クラスタにVMPSを定義する場合は、コマンド スイッチ上でアドレスを入力します。

VMPSのIPアドレスを入力するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps server ipaddress primary

プライマリVMPSサーバとして動作するスイッチのIPアドレスを入力します。

ステップ 3

vmps server ipaddress

(任意)セカンダリVMPSサーバとして動作するスイッチのIPアドレスを入力します。

最大3つのセカンダリ サーバ アドレスを入力できます。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show vmps

表示された VMPS Domain Server フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ダイナミック アクセス ポートを動作させるには、VMPSへのIP接続を確立する必要があります。
VMPSのIPアドレスへpingし、応答の受信を確認することで、IP接続をテストできます。

VMPSクライアントのダイナミック アクセス ポートの設定

クラスタ メンバー スイッチのポートをダイナミック アクセス ポートとして設定する場合は、最初に rcommand イネーブルEXECコマンドを使用してクラスタ メンバー スイッチにログインします。

ダイナミック アクセス ポートVLANメンバーシップは、エンド ステーション用、またはエンド ステーションに接続しているハブ用です。ダイナミック アクセス ポートを他のスイッチに接続すると、接続が切断される可能性があります。

VMPSクライアント スイッチにダイナミック アクセス ポートを設定するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

エンド ステーションに接続しているスイッチ ポートのインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode access

ポートをアクセス モードに設定します。

ステップ 4

switchport access vlan dynamic

ダイナミックVLANメンバーシップ適格としてポートを設定します。

ダイナミック アクセス ポートはエンド ステーションに接続されている必要があります。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Operational Mode フィールドを確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスの設定をデフォルトに戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。インターフェイスのスイッチポート モードの設定をデフォルト(dynamic auto)に戻すには、 no switchport mode インターフェイス コンフィギュレーション コマンドを使用します。アクセス モードをスイッチのデフォルトVLANにリセットするには、 no switchport access vlan インターフェイス コンフィギュレーション コマンドを使用します。

VLANメンバーシップの確認

スイッチがVMPSから受信したダイナミック アクセス ポートVLANメンバーシップの割り当てを確認するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

vmps reconfirm

ダイナミック アクセス ポートVLANメンバーシップを再確認します。

ステップ 2

show vmps

ダイナミックVLANの再確認ステータスを調べます。

再確認インターバルの変更

VMPSクライアントは、VMPSから受信したVLANメンバーシップ情報を定期的に再確認します。この再確認を行う間隔を分単位で設定できます。

クラスタ内のメンバー スイッチを設定する場合、このパラメータをコマンド スイッチ上の再確認設定値以上にする必要があります。この場合もまた、 rcommand イネーブルEXECコマンドを使用してメンバー スイッチにログインする必要があります。

再確認インターバルを変更するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps reconfirm minutes

ダイナミックVLANメンバーシップを再確認する間隔を分単位で指定します。指定できる範囲は1〜120です。デフォルト値は60分です。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vmps

表示されている Reconfirm Interval フィールドのダイナミックVLANの再確認ステータスを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチをデフォルト設定に戻すには、 no vmps reconfirm グローバル コンフィギュレーション コマンドを使用します。

再試行回数の変更

スイッチが次のサーバにクエリ送信するまでに、VMPSとの接続を試みる試行回数を変更するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps retry count

再試行回数を変更します。再試行回数は1〜10回の範囲で指定できます。デフォルトは3回です。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vmps

表示された Server Retry Count フィールドを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチをデフォルト設定に戻すには、 no vmps retry グローバル コンフィギュレーション コマンドを使用します。

VMPSのモニタ

VMPS情報を表示するには、 show vmps イネーブルEXECコマンドを使用します。VMPSについて、次の情報が表示されます。

VMPS VQPバージョン ― VMPSとの通信に使用されるVQPのバージョン。スイッチはVQPバージョン1を使用するVMPSにクエリ送信をします。
再確認インターバル ― VLANとMACアドレスとの割り当てを再確認するまでにスイッチが待機する時間(分単位)。
サーバ再試行回数 ― VQPからVMPSにクエリを再送信する回数。この回数だけ試行しても応答がない場合、スイッチはセカンダリVMPSに対してクエリ送信を開始します。
VMPSドメイン サーバ ― 設定されているVMPSのIPアドレス。スイッチは、currentの指定があるサーバにクエリを送信しています。primaryと表示されたサーバがプライマリ サーバです。
VMPSアクション ― 最新の再確認試行の結果。再確認は、再確認インターバルとして設定された時間が経過すると自動的に行われます。また、 vmps reconfirm イネーブルEXECコマンドを入力するか、CMSまたはSNMPの同等のコマンドを使用することによって、強制的に再確認できます。

次に、 show vmps イネーブルEXECコマンドの出力例を示します。

Switch# show vmps

VQP Client Status:

--------------------

VMPS VQP Version: 1

Reconfirm Interval: 60 min

Server Retry Count: 3

VMPS domain server: 172.20.128.86 (primary, current)

172.20.128.87

Reconfirmation status

---------------------

VMPS Action: other

ダイナミック アクセス ポートVLANメンバーシップのトラブルシューティング

VMPSは次の条件が発生したときに、ダイナミック アクセス ポートをシャットダウンします。

VMPSがセキュア モードで、かつ、ホストにポートへの接続を許可しない場合。VMPSは、ホストがネットワークに接続しないように、ポートをシャットダウンします。
1つのダイナミック アクセス ポート上に20を超えるアクティブ ホストが存在する場合。

ディセーブルのダイナミック アクセス ポートを再度イネーブルにするには、 shutdown インターフェイス コンフィギュレーション コマンドに続けて、 no shutdown インターフェイス コンフィギュレーション コマンドを入力します。

VMPSの構成例

図12-4 に、VMPSサーバ スイッチと、ダイナミック アクセス ポートの設定されたVMPSクライアント スイッチで構成されるネットワークを示します。この例の前提条件は次のとおりです。

VMPSサーバとVMPSクライアントは、それぞれ別個のスイッチです。
Catalyst 6500シリーズ スイッチAがプライマリのVMPSサーバです。
Catalyst 6500シリーズ スイッチCおよびスイッチJが、セカンダリのVMPSサーバです。
エンド ステーションは、クライアント、スイッチB、およびスイッチIに接続されます。
データベース コンフィギュレーション ファイルは、IPアドレス172.20.22.7のTFTP(簡易ファイル転送プロトコル)サーバに保管されます。
図12-4 ダイナミック ポートVLANメンバーシップの構成


[an error occurred while processing this directive]