[an error occurred while processing this directive]
日本語マニュアル一覧
スイッチ
Catalyst 3750 Metro シリーズ
Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)EY
はじめに
このマニュアルについて
図一覧
表一覧
概要
CLIの使用方法
スイッチのIPアドレスおよびデフォルト ゲートウェイの割り当て
スイッチのクラスタ設定
IE2100 CNSエージェントの設定
スイッチの管理
SDMテンプレートの設定
スイッチベースの認証の設定
802.1xポートベースの認証の設定
インターフェイス特性の設定
SmartPortマクロの設定
VLANの設定
VTPの設定
プライベートVLANの設定
音声VLANの設定
IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定
STPの設定
MSTPの設定
オプションのスパニングツリー機能の設定
Flex Linkの設定
DHCP機能およびIPソース ガードの設定
ダイナミックARP検査の設定
IGMPスヌーピングおよびMVRの設定
ポートベースのトラフィック制御の設定
CDPの設定
UDLDの設定
SPANおよびRSPANの設定
RMONの設定
システム メッセージ ロギングの設定
SNMPの設定
ACLによるネットワーク セキュリティの設定
QoSの設定
EtherChannelの設定
IPユニキャスト ルーティングの設定
HSRPの設定
MPLSおよびEoMPLSの設定
IPマルチキャスト ルーティングの設定
MSDPの設定
代替ブリッジングの設定
トラブルシューティング
サポートされているMIB
Cisco IOSファイル システム、コンフィギュレーション ファイル、およびソフトウェア イメージの操作
Cisco IOS Release12.2(25)EYでサポートされていないコマンド

スイッチ
Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)EY

この章では、Catalyst 3750 MetroスイッチにSmartPortマクロを設定して適用する方法について説明します。

ここで使用されるコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。

この章で説明する内容は、次のとおりです。

SmartPortマクロの概要
SmartPortマクロの設定
SmartPortマクロの表示

SmartPortマクロの概要

SmartPortマクロは、共通の設定を保存および共有するのに便利な方法です。SmartPortマクロを使用すると、ネットワークのスイッチの位置に基づく機能および設定をイネーブルにしたり、ネットワーク上で大規模な設定配置を行うことができます。

各SmartPortマクロは、定義するCLI(コマンドライン インターフェイス)コマンドのセットです。SmartPortマクロは、新しいCLIコマンドを含みません。既存のCLIコマンドの集合です。

インターフェイスでSmartPortマクロを適用すると、マクロ内のCLIコマンドがこのインターフェイス上で設定されます。マクロがインターフェイスに適用されても、既存のインターフェイスの設定は失われません。新しいコマンドはインターフェイスに追加され、実行コンフィギュレーション ファイルに保存されます。

スイッチ ソフトウェアにはシスコのデフォルトSmartPortマクロが組み込まれています( 表11-1 を参照)。 show parser macro ユーザEXECコマンドを使用して、これらのマクロとマクロに含まれるコマンドを表示できます。

表11-1 シスコのデフォルトSmartPortマクロ

マクロ名 1

説明

cisco-global

Rapid PVST+、ループ ガード、リンク ステート障害のダイナミック ポート エラー回復をイネーブルにするには、このグローバル コンフィギュレーション マクロを使用します。

cisco-desktop

PCなどのデスクトップ デバイスをスイッチ ポートに接続する場合、ネットワーク セキュリティおよび信頼性を強化するには、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-phone

Cisco IP Phoneを装備したPCなどのデスクトップ デバイスをスイッチ ポートに接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。このマクロは cisco-desktop マクロの拡張版で、同様のセキュリティと復元力を提供します。ただし、遅延に影響されやすい音声トラフィックを適切に処理するために、専用音声VLAN(仮想LAN)が追加されています。

cisco-switch

GigaStackモジュールまたはGBICを使用してアクセス スイッチとディストリビューション スイッチ、またはアクセス スイッチ同士を接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-router

スイッチとWANルータを接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-wireless

スイッチと無線アクセス ポイントを接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。

またシスコでは、Catalystスイッチ用に、事前にテストされているシスコ推奨のベースライン コンフィギュレーション テンプレート集を提供しています。オンライン リファレンス ガイド テンプレートには、ポートの使用状況に基づいたSmartPortマクロを作成するのに使用できるCLIコマンドがあります。コンフィギュレーション テンプレートを使用してSmartPortマクロを作成することで、シスコ推奨ネットワーク設計およびコンフィギュレーションを構築し展開できます。シスコ推奨のコンフィギュレーション テンプレートの詳細については、SmartportのWebサイトを参照してください。

http://www.cisco.com/go/smartports

SmartPortマクロの設定

新たにSmartPortマクロを作成したり、ご使用のアプリケーションに特有の新しいマクロを作成する場合に、既存のマクロをテンプレートとして使用できます。マクロを作成すると、スイッチ、スイッチ インターフェイス、またはインターフェイス範囲にグローバルに適用できます。

ここでは、次の内容について説明します。

SmartPortマクロのデフォルト設定
SmartPortマクロ設定時の注意事項
SmartPortマクロの作成
SmartPortマクロの適用
シスコのデフォルトSmartPortマクロの適用

SmartPortマクロのデフォルト設定

いずれのSmartPortマクロもイネーブルではありません。

SmartPortマクロ設定時の注意事項

スイッチでマクロを設定するには、次の注意事項に従ってください。

マクロを作成するときは、 exit または end コマンドを使用したり interface interface-id を使用して、コマンド モードを変更したりしないでください。 exit end 、または interface interface-id コマンドに続くコマンドが異なるコマンド モードで実行される可能性があります。
マクロを作成するには、すべてのCLIコマンドが同じコンフィギュレーション モードである必要があります。
一意な値の割り当てが必要なマクロを作成する場合、 parameter value キーワードを使用してインターフェイス固有の値を指定します。キーワードの一致では、大文字と小文字が区別されます。キーワードが一致する場合はすべて対応する値に置き換えられます。キーワードが完全一致すると、それが長いストリングの一部であっても一致しているとみなされ、対応する値に置き換えられます。
マクロ名は大文字と小文字で区別されます。たとえば、 macro name Sample-Macro コマンドおよび macro name sample-macro コマンドは、別々の2つのマクロになります。
一部のマクロには、パラメータ値を必要とするキーワードが含まれている場合があります。マクロで必要な値の一覧を表示するには、 macro global apply macro-name ? グローバル コンフィギュレーション コマンド、または macro apply macro-name ? インターフェイス コンフィギュレーション コマンドを使用できます。キーワード値を入力しないでマクロを適用すると、コマンドは無効になり適用されません。
マクロがグローバルにスイッチまたはスイッチ インターフェイスに適用されると、インターフェイス上の既存の設定はすべて保持されます。これは、差分設定を適用する場合に役立ちます。
コマンドを追加または削除してマクロ定義を変更する場合、この変更は元のマクロが適用されていたインターフェイスに反映されません。新しいコマンドまたは変更したコマンドを適用するには、インターフェイスに更新されたマクロを再適用する必要があります。
マクロを適用およびデバッグして、構文エラーまたは設定エラーを検出するには、 macro global trace macro-name グローバル コンフィギュレーション コマンド、または macro trace macro-name インターフェイス コンフィギュレーション コマンドを使用できます。構文エラーまたはコンフィギュレーション エラーによりコマンドに障害が生じた場合でも、マクロは引き続き残りのコマンドを適用します。
CLIコマンドには、あるインターフェイス タイプに特有のものもあります。マクロが設定を受け入れないインターフェイスに適用されると、マクロが構文または設定の確認に失敗するため、スイッチからエラー メッセージが返されます。
インターフェイス範囲にマクロを適用することは、単一のインターフェイスにマクロを適用するのと同じです。インターフェイス範囲を使用すると、マクロはその範囲内の各インターフェイスに順番に適用されます。1つのインターフェイスでマクロ コマンドに障害が生じても、このコマンドは残りのインターフェイスでは適用されます。
スイッチまたはスイッチ インターフェイスにマクロを適用すると、マクロ名が自動的にスイッチまたはインターフェイスに追加されます。 show running-config ユーザEXECコマンドを使用して、適用されたコマンドとマクロ名を表示できます。

スイッチ ソフトウェアにはシスコのデフォルトSmartPortマクロが組み込まれています( 表11-1 を参照)。 show parser macro ユーザEXECコマンドを使用して、これらのマクロとマクロに含まれるコマンドを表示できます。

シスコのデフォルトのSmartPortマクロをインターフェイスに適用するには、次の注意事項に従ってください。

show parser macro ユーザEXECコマンドを使用して、スイッチのすべてのマクロを表示します。 show parser macro macro-name ユーザEXECコマンドを使用して、特定のマクロの内容を表示します。
$ で始まるキーワードは、一意なパラメータ値が必要であることを示しています。 parameter value キーワードを使用して、シスコのデフォルトのマクロを必要な値とともに追加します。

シスコのデフォルト マクロでは、必要なキーワードを識別するのに $ 文字を使用します。マクロを作成する場合、キーワードの定義で、 $ 文字の使用に制限はありません。

SmartPortマクロの作成

Smartportマクロを作成するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

macro name macro-name

マクロ定義を作成して、マクロ名を入力します。マクロ定義には、最大3000文字まで含めることができます。

1行につき1つのコマンドで、マクロ コマンドを入力します。マクロを終了するには、 @ 文字を使用します。マクロ内でコメント テキストを入力するには、行の始めに # 文字を使用します。

(任意)キーワードを指定するのにヘルプ ストリングを使用することで、マクロ内にキーワードを定義できます。マクロで使用する
キーワードを定義するには、 # macro keywords word を入力します。スペースで区切って、マクロにヘルプ ストリング キーワードを3つまで入力できます。

マクロ名は大文字と小文字で区別されます。たとえば、 macro name
Sample-Macro
コマンドおよび macro name sample-macro コマンドは、別々の2つのマクロになります。

exit または end コマンドを使用しないこと、またはマクロで interface interface-id を使用してコマンド モードを変更しないことを推奨します。 exit end 、または interface interface-id コマンドに続くコマンドが異なるコマンド モードで実行される可能性があります。最良の結果を出すには、マクロ内のすべてのコマンドが同じコンフィギュレーション モードである必要があります。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show parser macro name macro-name

マクロが作成されたことを確認します。

macro name グローバル コンフィギュレーション コマンドの no 形式によって、マクロの定義のみが削除されます。マクロがすでに適用されているインターフェイスの設定には影響しません。

次に、スイッチポート アクセスVLANおよびセキュアMACアドレス数を定義するマクロを作成し、また # macro keywords を使用してヘルプ ストリング キーワードを2つ含める例を示します。

Switch(config)# macro name test

switchport access vlan $VLANID

switchport port-security maximum $MAX

#macro keywords $VLANID $MAX

@

SmartPortマクロの適用

Smartportマクロを適用するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

macro global { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

マクロで定義された各コマンドをスイッチに適用するには、
macro global apply macro-name を入力します。マクロを適用およびデバッグして、構文エラーまたは設定エラーを検出するには、
macro global trace macro-name を指定します。

(任意)スイッチ固有の一意なパラメータ値を指定します。最大3つのキーワードと値のペアを入力できます。パラメータ キーワードの一致では、大文字と小文字が区別されます。キーワードが一致する場合はすべて対応する値に置き換えられます。

一部のマクロには、パラメータ値を必要とするキーワードが含まれている場合があります。マクロで必要な値の一覧を表示するには、 macro global apply macro-name ? コマンドを使用できます。キーワード値を入力しないでマクロを適用すると、コマンドは無効になり適用されません。

ステップ 3

macro global description text

(任意)スイッチに適用されるマクロについての説明を入力します。

ステップ 4

interface interface-id

(任意)インターフェイス コンフィギュレーション モードで、マクロを適用するインターフェイスを指定します。

ステップ 5

default interface interface-id

(任意)指定したインターフェイスからすべてのコンフィギュレーションをクリアします。

ステップ 6

macro { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

マクロで定義された各コマンドをインターフェイスに適用するには、 macro apply macro-name を入力します。マクロを適用およびデバッグして、構文エラーまたは設定エラーを検出するには、 macro trace macro-name を指定します。

(任意)インターフェイス固有の一意なパラメータ値を指定します。最大3つのキーワードと値のペアを入力できます。パラメータ キーワードの一致では、大文字と小文字が区別されます。キーワードが一致する場合はすべて対応する値に置き換えられます。

一部のマクロには、パラメータ値を必要とするキーワードが含まれている場合があります。マクロで必要な値の一覧を表示するには、 macro apply macro-name ? コマンドを使用できます。キーワード値を入力しないでマクロを適用すると、コマンドは無効になり適用されません。

ステップ 7

macro description text

(任意)インターフェイスに適用されるマクロについての説明を入力します。

ステップ 8

end

イネーブルEXECモードに戻ります。

ステップ 9

show parser macro description [ interface interface-id ]

マクロがインターフェイスに適用されたことを確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

マクロ内にある各コマンドの no バージョンを入力するだけで、スイッチ上のグローバル マクロで適用された設定を削除できます。 default interface interface-id インターフェイス コンフィギュレーション コマンドを入力して、マクロで適用されたインターフェイス上の設定を削除できます。

次に、 snmpという ユーザ作成マクロを適用してホスト名アドレスを test-server に設定し、IP
precedence値を 7 に設定する例を示します。

Switch(config)# macro global apply snmp ADDRESS test-server VALUE 7

次に、スイッチに適用されたときのマクロ内の構文エラーまたは設定エラーを検出するため、 macro global trace グローバル コンフィギュレーション コマンドを使用して、 snmp というユーザ作成マクロをデバッグする例を示します。

Switch(config)# macro global trace snmp VALUE 7

Applying command...`snmp-server enable traps port-security'

Applying command...`snmp-server enable traps linkup'

Applying command...`snmp-server enable traps linkdown'

Applying command...`snmp-server host'

%Error Unknown error.

Applying command...`snmp-server ip precedence 7'

次に、 desktop-config というユーザ作成マクロを適用し、設定を確認する例を示します。

Switch(config)# interface fastethernet1/0/2

Switch(config-if)# macro apply desktop-config

Switch(config-if)# end

Switch# show parser macro description

Interface Macro Description

--------------------------------------------------------------

Fa1/0/2      desktop-config

--------------------------------------------------------------

次に、 desktop-config というユーザ作成マクロを適用して、VLAN 1が存在すればそれをすべてVLAN 25に置き換える例を示します。

Switch(config-if)# macro apply desktop-config vlan 25

シスコのデフォルトSmartPortマクロの適用

Smartportマクロを適用するには、イネーブルEXECモードで次の手順を実行します。

コマンド

説明

ステップ 1

show parser macro

スイッチ ソフトウェアに組み込まれたシスコのデフォルト
SmartPortマクロを表示します。

ステップ 2

show parser macro macro-name

適用したい特定のマクロを表示します。

ステップ 3

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

macro global { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

parameter value キーワードを使用して、シスコのデフォルトのマクロを必要な値とともに追加し、マクロをスイッチに適用します。 $ で始まるキーワードは、一意なパラメータ値が必要であることを示しています。

マクロで必要な値の一覧を表示するには、 macro global apply
macro-name ? コマンドを使用できます。キーワード値を入力しないでマクロを適用すると、コマンドは無効になり適用されません。

ステップ 5

interface interface-id

(任意)インターフェイス コンフィギュレーション モードを開始し、マクロを適用するインターフェイスを指定します。

ステップ 6

default interface interface-id

(任意)指定したインターフェイスからすべてのコンフィギュレーションをクリアします。

ステップ 7

macro { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

parameter value キーワードを使用して、シスコのデフォルトのマクロを必要な値とともに追加し、マクロをインターフェイスに適用します。 $ で始まるキーワードは、一意なパラメータ値が必要であることを示しています。

マクロで必要な値の一覧を表示するには、 macro apply
macro-name ? コマンドを使用できます。キーワード値を入力しないでマクロを適用すると、コマンドは無効になり適用されません。

ステップ 8

end

イネーブルEXECモードに戻ります。

ステップ 9

show running-config interface interface-id

マクロがインターフェイスに適用されたことを確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

マクロ内にある各コマンドの no バージョンを入力するだけで、スイッチ上のグローバル マクロで適用された設定を削除できます。 default interface interface-id インターフェイス コンフィギュレーション コマンドを入力して、マクロで適用されたインターフェイス上の設定を削除できます。

次に、 cisco-desktop マクロを表示して、マクロを適用し、インターフェイス上のアクセスVLAN IDを25に設定する例を示します。

Switch# show parser macro cisco-desktop

--------------------------------------------------------------

Macro name : cisco-desktop

Macro type : default

# Basic interface - Enable data VLAN only

# Recommended value for access vlan (AVID) should not be 1

switchport access vlan $AVID

switchport mode access

# Enable port security limiting port to a single

# MAC address -- that of desktop

switchport port-security

switchport port-security maximum 1

# Ensure port-security age is greater than one minute

# and use inactivity timer

switchport port-security violation restrict

switchport port-security aging time 2

switchport port-security aging type inactivity

# Configure port as an edge network port

spanning-tree portfast

spanning-tree bpduguard enable

--------------------------------------------------------------

Switch#

Switch# configure terminal

Switch(config)# fastethernet1/0/4

Switch(config-if)# macro apply cisco-desktop $AVID 25

SmartPortマクロの表示

SmartPortマクロを表示するには、 表11-2 に示すイネーブルEXECコマンドを1つまたは複数使用します。

表11-2 SmartPortマクロを表示するコマンド

コマンド

説明

show parser macro

設定されたすべてのマクロを表示します。

show parser macro name macro-name

特定のマクロを表示します。

show parser macro brief

設定されたマクロ名を表示します。

show parser macro description [ interface interface-id ]

すべてのインターフェイスまたは特定のインターフェイスに関するマクロの説明を表示します。


1.

シスコのデフォルトSmartPortマクロは、スイッチで稼働するソフトウェアのバージョンによって異なります。


[an error occurred while processing this directive]