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Related Information
Introduction

This document provides instructions on troubleshooting subscriber addition and import problems in Cisco
Unity versions 2.4.x, 3., and 4.x using Microsoft Exchange and Domino (in Cisco Unity 4.x only). In
addition, an overview that details the mechanics of the subscriber addition and import process, and a list of
common problems and solutions are presented that pertain to:

» Adding new subscribers through the Cisco Unity System Administrator (SA).

« Importing existing Exchange users into Cisco Unity through the Cisco Unity SA.

« Importing existing Exchange users into Cisco Unity using the Cisco Unity Import tool.
« Importing subscribers from a CSV file using the Cisco Unity Import tool.

Create a Cisco Unity Subscriber

In Cisco Unity version 2.4.x and earlier, Exchange 5.5 was used as the message store for the voice messag
and also as the database store to store all the settings for the voice mail subscribers. Custom attributes 11
through 15 and the raw properties starting with "Voice—" were used to configure the Cisco Unity subscriber.
But, all these raw properties were not sufficient to create a voice mail subscriber. Therefore, the creation of
another object to store the rest of the settings was necessary in order to create a voice mail subscriber. This
why, when a subscriber is created in Cisco Unity, a few settings are entered under the subscriber's schema
then a call handler associated to that subscriber is created. This process was limited in creating more settin
as Cisco Unity was including more features in newer versions. This is the reason for the database store beir
moved to SQL, so that the Cisco Unity database could be expanded with all the attributes to the extent
necessary.

Create and Import a User from the SA

This is a behind the scenes process involved with creating and importing a user from the SA.

1. A copy is made of the mail user template specified as well as its corresponding call handler, taking
with it the default information supplied in the template (contact rules, call transfer, and so forth). The
result is a mail user object and a corresponding call handler.

2. The new mail user and call handler are populated with the unique information specified during the

initial creation process (extension, alias, first name, last name, and so forth).

.A check is run in order to make sure all the unigue information does not already exist in the directory

. SA communicates with the DOH (Database Object Hierarchy layer of Cisco Unity).

. The DOH negotiates with the directory. Once the user is created in the directory, a unique identifier i
passed back to the DOH, which is written to SQL in Cisco Unity versions 3.x and 4.x. In the
Exchange 5.5 schema in Cisco Unity version 2.4.x, when a subscriber is imported, the DOH
negotiates with the directory. However, instead of waiting for a unique identifier to be passed back,
the DOH binds to the existing user that you import.

g~ w

Note: Information about Mail User Templates for Cisco Unity 4.x can be found in the documentation
for Subscriber Template Settings. This information is very similar to Cisco Unity 3.x and 2.4.x. Refer
to the correct Cisco Unity version document if not applicable.

The Behind the Scenes Process Used to Create or Import an
Existing Exchange User Using the Cisco Unity Import Tool



This procedure explains the behind the scenes process used to create or import an existing Exchange user
using the Cisco Unity Import tool.

1. A copy is made of the mail user template specified as well as its corresponding call handler, taking
with it the default information supplied in the template (contact rules, call transfer, and so forth). The
result is a mail user object and a corresponding call handler.

2. The new mail user and call handler are populated with the unique information specified during the
initial creation process (extension, alias, first name, last name, and so forth).

3. A check is run to make sure all the unique information does not already exist in the directory.

4. The Cisco Unity Import Tool writes all the information directly to SQL in Cisco Unity versions 3.x
and 4.x, or in the Exchange 5.5 schema in Cisco Unity version 2.4.X.

5. The Cisco Unity Import Tool calls the Sqglsyncsvr to sync the new changes in SQL with the directory.

Note: Information about Mail User Templates for Cisco Unity 4.x can be found in the Subscriber

Template Settings documentation. This information is very similar to Cisco Unity 3.x and 2.4.x. Refel
to the correct Cisco Unity version documentation if not applicable.

Import User Data from a CSV File

The procedure used to import user data from a CSV file can be found in the Creating Subscriber Accounts
documentation.

CSV headers vary from Cisco Unity version to Cisco Unity version. For example, in Cisco Unity 4.x there is
field to import Visual Messaging Interface (VMI) email addresses using the VMI_TEXT_SMTP_ADDRESS

column header in the Bulk Import tool. However, this value was not available in the 3.x version of that tool.
These are the links for the CSV headers for each version of Cisco Unity.

 For Cisco Unity 4.x:
¢ Table 15-1: Required CSV Headers for Regular Subscribers.
¢ Table 15-2: Optional CSV File Column Headers.

 For Cisco Unity 3.x:

¢ Preparing for a CSV Import.
 For Cisco Unity 2.4x:

¢ Refer to the Cisco Unity Administration Guide and perform a search for CSV.
The Relationship Between Mail User Templates and Their
Associated Call Handlers

This series of screen shots shows the standard Default Subscriber Template in the SA and its location in the
DOH.

Default Subscriber Template in the SA
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2. Doh Property Tester d : ..J_.l- o 5’
Collections [~ Global Collection Qbgects; 20 Obiect Properties Dynamic_|
Apolications i ch_defaultadmintemplate & AVP_ADMINISTRATOR_OBJECT_ID -

St 2t i iarrinte AVP_AFTER_MESSAGE_ACTION =
CosObgects i AVP_AFTER_MESSAGE_CONVERSATION
DistributionLists ed ch_EAdministratos AVP_AFTER_MESSAGE_OBJECT_ID
Fad tuargH anders et ch_ES ubscriber AVP_ALIAS
FaxMaiH anders PR | etaller AVP_ALTERNATE_DTMF_IDS
InterviewHardlers — bk AVP_APPLICATION_OBJECT_ID
Locations e ch_jfisusted AVP_CONTACT_RULES
Mall)sers ke ch_jiohnn AVP_CREATION_TIME e
MalUserTemplates A ch_jemith AVP_CUSTOM_BSTR1
NameLookupHanders Ay AVE CUSTOM_BSTA2
PrenaryD omanAccounts e ch_sty AVE DISTINGUISHED_NAME
PrenaryD omanGroups e ch_sint AVP_DTMF_ACCESS_ID
PwPolicies 8 b suser AVP_EDIT_MSG
RestichonT ables . PR < 1avPIS_PRIMARY
TrustedD omaine C Ll-' AVP_LANGUAGE

S\VP I NCATINN NRIFCT 1IN :I

Buk Adder I Create I Remove | (et User's Mattios l Get User's Caler ja'l
Table Quesy I Filter I Ewiting | (et User's Notces I et User's FreeBus ;I
SysCorlig | Loged et | FindByid | ADMortoe | ExS5Montor |

GC Morgtor

- Propedy Yaue

Multiple Values:

[ s |  Delete | sg | || Rerove | o |

Default Mail User Template Location in the DOH



% Doh Property Tester . o e _-Jgjﬂ

Colectors [~ Global Colection Qbects: 2 Obgect Propesties Dynaniic |
Apolications Eww“dmr‘cmmlc ALP_MSG_ALTOREAD -
CalHanders ALP_MSG_PRESENTATION

CosObjects defaultempiate AVP_ADD_TO_DLS

DigtributionLists AVP_ADDRESS_MODE

Farl ibrayHandlers AVP_ALIAS

FarMailHandlers AVP_AUDIO_SPEED

InterviewH anders AVP_ALUDIO_VOLUME

Locatons AVP_BILLING 1D

Mail)zens AVP CALLHANDLER OBJECT ID

M adl Jsea T emplates AVP_CONVERSATION_NAME

N amel cokupHandlers AVP_COS_OBJECT_ID

PrimasyDomaindccounts AVP_CREATION_TIME

PrimasyDomainGroups AVP_DEFAULT_PW_DTMF

PuwiPolices AVP_DEFAULT_PW_DTMF_CHANGED

AestnctionT ables . S(P_DEFAULT_PW_NT

TrustedDomans

XI¥P DEFAULT_PW_NT_CHANGED o
P NISTINGIHISHFN NaMF _I

Buk Adder | Type: [CallHandier e Users Matboe | (Gt firida]

Table Query | Alias: [ch_defaubtempiate etUsefs fiotces | | GetUsers FresB

SysConfig | Fod | = ADMortor | ExS5Monitor |
|

GC Mondox
Property Value
IUJ: {DBIFCAOF-9CFB-441B-A584-FER2D3CTFODC}
Multple Values:
)61 FCAOF-SCF8- 441 B ASBS-FEB2D3C7FODC)
Set Delete | I I About

Note: In the picture of the Default Mail User Template, the AVP_CALLHANDLER_OBEJCT_ID
corresponds to the Default Subscriber Call Handler object in the DOH. All mail users and mail user template
have a corresponding call handler associated with them.

The Result When You Create or Import a User Into a Cisco
Unity Subscriber

When a voice mail subscriber is created in Cisco Unity, an email account in Exchange 5.5 or an Active
Directory account with email enabled in Exchange 2000 (in the case of importing) is used or created to ente
series of voice mail properties in the schema of that email account. Also, a call handler object (created as at
Exchange 5.5 object under the Cisco Unity folder in Cisco Unity version 2.4 or created as a record in a
different SQL table in Cisco Unity 3.x and 4.x) is created for that subscriber. This call handler is associated t
this subscriber and contains the rest of the voice mail properties such as audio volume, and so forth.

General Troubleshooting Tips for Creating/Importing
Subscribers Problems
There are a lot of elements that take place in creating and importing a user into Cisco Unity. When there is ¢

problem with creating and importing subscribers, it is a good idea to focus on what can be failing or wrong
with the process of creating and importing a user into Cisco Unity.



The Tool You Use to Create/Import a Subscriber
 Try different tools.

¢ System Administration (SA). Local or at a remote computer.
¢ Cisco Unity Bulk Import Utility (CUBI)

« Search in the application event log for error messages if one or both of the tools that you use in orde
to create/import a subscriber fails.

« In order to narrow down problems when you import subscribers, it is a good idea to test importing
users into Cisco Unity through the Unity SA and also with the use of the Cisco Unity Import tool.
This way, you can verify if the problem is with the SA, with the Import tool, or a system-wide
problem not related to the specific tool that you are using to import subscribers. For more informatior
about creating subscribers, refer to Creating Subscriber Accounts.

« Also refer to About the Accounts That Can Be Used to Administer Cisco Unity from the Accessing
the Cisco Unity Administrator documentation.

Access to the Directory

« Permissions of the Directory Service account for Cisco Unity — It is a good idea to run the
Permissions Wizard for the specific Cisco Unity version and Message Store that you have
implemented in your system. The Directory Service account is the account that AVDSAD and
AvDsGlobalCatalog run as. If you have Exchange 2000, you should have the correct rights and
permissions under the common OU that contains all the subscribers that you want to import. This is
described under the section of the Exchange 2000 scope in the directory.

» The permissions or settings for the accounts that can be used to administer Cisco Unity — Check the
About the Accounts That Can Be Used to Administer Cisco Unity document in the System
Administration guide for Cisco Unity 4.0. The same document can be applied for the rest of the Ciscc
Unity/Message Store combinations.

« In Domino, you need these rights:

¢ For the domain directory database, you need Editor with Delete document rights for the
name.nsf file. In order to check these rights, go to the Domino server, open the Administrator
program for Domino with an Id that has manager access and click on Files. Select name.nsf,
right—click on it, and select Manage ACL. A screen similar to this appears.
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¢ For the Administration Process, you need Editor rights on Admin4.nsf. In order to check
these rights, from the Domino server open the Administrator program for Domino with an Id
that has manager access and click on Files. Select Admin4.nsf, right—click on it, and select
Manage ACL. A screen similar to this appears.
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* Replication changes in Active Directory can take up to 15 minutes even after replication is forced.
When you have problems with replication, verify that the Cisco Unity registries that point to the
Domain Controller are correct.



¢ If the Cisco Unity system is E2K connected, verify that the
HKEY_LOCAL_MACHINE\SOFTWARE\ActiveVoice\DirectoryConnectors\DirSynchAD\1.00\I
domainf\DefaultDomainController key is set correctly and points toward a valid DC.

¢ For Cisco Unity 3.x and later with Exchange 5.5, look in the
HKLM\Software\ActiveVoice\Directory Connectors\AvDirMonExchange55\1.0 key and
subkeys for the configuration.

¢ Cisco Unity 2.4.x does not have a directory connector. The Cisco Unity database and possibl
subscribers to be imported are stored in the cache from Exchange 5.5. (If this is the case, the
troubleshooting has to be focused on Exchange 5.5 and authentication). Troubleshoot the
HKEY_LOCAL_MACHINE\SOFTWARE\ActiveVoice\Dalex\1.00\ registry and make
sure that the values for this registry are correct. The complete Domain information is under
the \Server\Root should have the value of the DefaultDomainController registry folder.

¢ Check Scenario 4: An unrecognized Error has Occurred.

Necessary Elements in order to Create/Import a User into Cisco Unity

If there is a problem importing or creating Cisco Unity subscribers, check these items in order to make sure
that the subscriber is importable.

* Check the user template.

« In order to import, the user has to have an email account in Exchange 5.5 with the raw property
"Allow rich text" set to 1. Or, the user can have an Active Directory that has email enabled in
Exchange 2000. In the case of Domino, you can only import users from Domino into Cisco Unity.
Therefore the user has to have an email account in the Domino server. In order to be able to import:
subscriber, this subscriber cannot belong to any other Cisco Unity. If the subscriber already has Cisc
Unity properties in his/her schema, then your Cisco Unity will not be able to manage this subscriber.
Refer to Clean a Subscriber from Cisco Unity Properties if this is your case. Check if the subscriber
that you are trying to import has Cisco Unity properties every time that you try to import it. Importing
a subscriber does not work if those properties are there.

« If importing/creating a Cisco Unity subscriber fails in the middle of this process, Cisco Unity has
already created two records for that subscriber in the Cisco Unity SQL database. These two records
need to be deleted manually in order to be able to import the subscriber again.

« If you are unable to import some users, you might need to delete the subscribers' properties. Comple
these steps:

1. Go to C:\CommServer\Utilities\RemoveSubscriberProperties.

2. Open the RemoveSubscribersProperties tool.

3. Search for the user that has the problem.

4. Right—click on the user and choose Remove Subscriber Properties. This option greys out if
the subscribers do not have properities.

Note: Ensure the Cisco Unity and Active Directory are synchornized. If not, use DOHProp
test in order to resynchronize.
Once the properties are deleted, you should be able to import the subscribers using Exchange.

Directory Scope Used to Import or Create Accounts

» Scope for Importing Cisco Unity Users from Exchange 5.5.

« Scope for Importing Cisco Unity Users from Exchange 2000.

« Scope for Importing Cisco Unity Users from a Mixed Environment with Exchange 2000 and
Exchange 5.5.

« Scope for Importing Cisco Unity Users from Domino.



Scope for Importing Cisco Unity Users from Exchange 5.5

When you try to import users from existing Exchange 5.5 servers, only the users that reside in the site that
Cisco Unity is installed in are offered the Cisco Unity Import Utility.

Explanation

It is prohibited to import users from an Exchange server that are not a member of the site that Cisco Unity is
installed in. Exchange servers connected through a site connector are not accessible because of the Unity
architecture. This is expected behavior. By design, all the Exchange servers in a site communicate with
remote—procedure call (RPC), which is a faster communication method than Simple Mail Transfer Protocol
(SMTP) which is what Exchanges from different sites use to communicate with each other. When Cisco Uni
tries to access a voice mail through the phone, you need to create an RPC connection through a Messaging
Application Programmer Interface (MAPI) in order to access the voice message and play it to the user over
the phone.

You can change the scope inside of the Exchange 5.5 site by using the Advance Setting tool, which you car
download from the Cisco Unity Tools site.

From Advanced Tools, set the directory scope to the site instead of recipients container as shown in this
output:

HKLM\Software\Active Voice\DALex\1.0\MailUsers\

STRING: Root

By default, this key looks something like ch=recipients;ou=<Site Name> ;0=<Organization

Name>. If you remove cn=recipients; from the beginning, it starts to search for subscribers from the

top level down for users in the system instead of starting with the recipients container. This can be done for
sites that choose to have their various recipients containers to be "peers" to the recipients container insteac
under it. This gets around that problem. There is a slight performance hit with this.

Scope for Importing Cisco Unity Users from Exchange 2000

When you try to import users from existing Exchange 2000 servers, you need to consider having the proper
rights and permissions on the common OU that is going to nest the rest of the OUs where your subscribers
going to reside (you can go all the way up to the domain.).

Explanation

The Permissions Wizard that you can find at the Cisco Unity Tools site ensures the directory facing account
has the rights necessary to import users from the selected root container all the way down. However, you st
need to set the start of the lookup scope. This can be done in DOHPropTest by changing the setting under /
Monitor > Mail_User_Search_Root to point to the domain or the common OU that is going to nest the rest
of the OUs. It can also be done through the registry by changing the registry key named ROOT to empty if
you want to point to the domain on= <a different OU> .
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Scope for Importing Cisco Unity Users in a Mixed
Environment with Exchange 2000 and Exchange 5.5

In a mixed environment with different versions of Exchange, Cisco Unity points to one of the Exchange 200(
servers, and the importing or creating subscriber is handled by the Exchange 2000 server that it points to. T
scope is handled as an Exchange 2000 environment.

Scope for Importing Cisco Unity Users in Domino
Environment

In a Domino environment Cisco Unity points to the Domino server and there is only one directory to import
from.

Clean a Subscriber from Cisco Unity Properties

In order to import a subscriber, you have to make sure that those properties tagging a Cisco Unity subscribe
as a Cisco Unity subscriber are not there by mistake. For example, if a Cisco Unity server is removed from t
network without properly uninstalling it, this user is still "tagged” as a Unity subscriber and a subsequent
installation of Cisco Unity is unable to import that user as subscriber again. In order to uninstall Cisco Unity
from your site, you need to use the Uninstall procedure described in the Cisco Unity Tools site. Another
example is if you have problems trying to import a subscriber and the subscriber is only created half-way.
This is when a problem can occur. These properties are deleted by default when you click Delete at the
Administration page in Cisco Unity (SA).

Note: For information on how to run the Cisco Unity Uninstall utility, refer to the Uninstall utility Read Me

file associated with your Unity software. If you go ahead and reformat and reinstall Cisco Unity, it will not be
uninstalled from your site and will leave behind properties in the schema such as the voice mail users
properties. In such cases, it is necessary to clean the user of these properties before you can import them a
into a new or current Cisco Unity installation.



When reinstalling Cisco Unity software, it is common to forget to run the Uninstall utility. The Uninstall

utility deletes, among other things, the custom properties that Cisco Unity populates in the Exchange
Subscriber in order to create a Unity subscriber. If this utility is not run before Unity is reinstalled (to replace
existing Unity software and its subscribers) the most recently installed Cisco Unity software is unable to
administer or reimport existing subscribers because these subscribers contain custom properties that point 1
the Unity software that has been replaced. This statement is true for all the versions of Cisco Unity working
with any version of Exchange or Domino in Cisco Unity 4.x.

One of the easiest ways to identify this problem, after noticing the above symptom, is to check the custom
properties for the failing subscribers:

 For Cisco Unity 3.0 and later:

¢ Use either adsiedit.msc (Exchange 2000) or Exchange Admin in raw mode (Exchange 5.5) tc
verify that the users have values for the location object ID.
¢ 1. For Domino, go to the Domino Server.
2. Go to the Administrator tool for Domino by selecting Start > Programs > Lotus
Application > Lotus Administrator.
3. Select the People and Groups tab and click People.
4. Select Subscriber.
5. Click on the File menu and select Document Properties.
From the Fields tab you will see the Cisco Unity properties starting with AVP__ as shown in
the following screen.

$FILE a | Field Name: AVP_ALIAS
$Revisions Data Type: Text
$UpdatedBy Data Length: B bytes
AlFullN ame SeqNum: 4
AltFullNamel anguage Dup Item ID: O

AltFullN ameSort Field Flags: SUMMARY
Assistant

AvailableForDirSync ‘"Alex"

AVP_DTMF_ACCESS_~|

« For Cisco Unity version 2.4.6 and earlier:

¢ Use the Exchange Admin in Raw mode (Exchange 5.5) to verify that the users have values
for custom properties 11 through 15 and also for all of the Raw properties starting with Voice.

Solution

The solution is to delete all remaining Cisco Unity properties from the previous Cisco Unity installation from

the subscribers, while leaving the Exchange subscriber alone. The messages will be kept in each Exchange
subscriber's in—-box. These subscribers are re—created in Cisco Unity. All of their settings and greetings are

also re—created, and not retained.

n Caution: Instructions for deleting the properties for the affected subscribers are described below.

Incorrectly following these steps could result in lost data or messages. Try this procedure on a test system
until you are comfortable with this process.



Cisco Unity Version 3.x and Above Connected to Exchange 2000 and
Active Directory

There are two ways to remove the Cisco Unity attributes from the Exchange 2000 account. You should alwe
first try the utility "Remove Subscriber Properties” if possible. You can use the ADSIEdit utility only if you
have problems using the first utility.

Removing Subscriber Properties

Use the following procedure to remove subscriber properties.

1.
2.

B~ W

(o]

Logon to the Cisco Unity server with a user account that has domain administrative privileges.
Launch the Remove Subscriber Properties utility from the Tools Depot on the Cisco Unity server
desktop. You can also use the folder
<drive>:\CommServer\Utilities\RemoveSubscriberProperties\RemoveSubscriberProperties.exe
(assuming you have installed Cisco Unity on your C drive).

. Highlight the container where the users are located (for example, C).
. From the right pane, select the user that you have trouble importing (you should see a Locationid

associated with this user).

. Right—click and choose Remove Subscriber Properties.
. Confirm the removal by clicking Yes.

There should now be no Locationld associated to this subscriber and this subscriber is now available
to be imported into a Cisco Unity subscriber. If the Locationld still exists, then the user logged on to
the Cisco Unity server does not have enough privileges. Try with a different user, preferably the
Domain Administrator.
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ADSIEdit Utility

Follow the procedure below.

1.

Ensure that the ADSIEdit utility is installed on the Cisco Unity system.

For Cisco Unity 3.0x (ADSIEdit utility included in the Windows 2000 server CD):



a.To install the ADSIEdit utility on your system, install the support tools from the Windows
2000 CD located at <CD drive>\SUPPORT\TOOLS\setup.exe.
b. Copy adsiedit.exe and adsiedit.dll into a folder on the Cisco Unity system. The folder should
be named c:\adsiedit\.
c. Register adsiedit.dll by running regsvr32.exe c:\adsi\adsiedit.dll after the c:\winnt\system32
command prompt.
For Cisco Unity version 3.1 and above, the ADSIEdit utility is included in the Cisco Unity system
under the folder c:\CommServer\TechTools (assuming you have installed Cisco Unity on your C:
drive).

Install the ADSIEdit.dll by typing the following command at the command prompt:

C:\winnt\system32\regsvr32 c:\commserver\techtools\adsiedit.dll

You will receive a response window reading:

DlIRegiserServer in c:\commserver\techtools\adsiedit.dll succeeded
2.0nce ADSIEdit is installed, double—click adsiedit.msc to open it and press OK for a valid username
and password.
3. Expand the folders to find the location of the users.

The users are most likely located in the Domain NC [...] >...> CN=Users.
4. Select the subscriber that you want to delete from the previous Cisco Unity database.

The subscriber will show up as CN=1st Name Last Name.
5. Right—click on the selected subscriber and choose Properties.
6. Select which properties should be set to Optional.

a.From the Select which Property to View list, select ciscoEcsbuUMLocationObijectld.
b. Click the Clear button.

Values will be dimmed with a value of not set.
7. Click Apply and close this subscriber's Properties window.
8. Navigate backward to the Domain NC [...] folder.
9. Right—click the folder and select Update Schema Now.
10.Right—click again on the Domain NC [&] folder and select Refresh.

You should now be able to import this Exchange subscriber into the new Cisco Unity software.

Cisco Unity Version 3.x and Later Connected to Exchange 5.5
Follow the procedure below.

1. Open the Exchange Administrator in raw mode by selecting Start > Run and click the Browse
button.

2. Browse to the drive where Exchange is installed, browse to the bin directory, and select admin.exe.

3. Click Open to open the complete path to \bin\admin.exe.

4. Add space rto the end of the text line.

&\bin\admin.exe r
5. Go to the Recipients container for the site in Exchange and select the affected subscriber.
6. Select File > Raw Properties.

After loading the schema, the Raw Properties window appears.



7. Under List Attributes, select Existing.
8. Select Custom Attribute 12 and then click Remove until the field is empty.

Note: An edit value and attribute value is dimmed. Click Remove until the attribute value is empty.
9. Repeat step 8 for Custom Attribute 14 and Voice—Mail-UserID.
10.Make sure the attribute "Allow rich text" is set to 1.
11. After replication, this subscriber is available to be imported into a Cisco Unity subscriber.

Note: Technically, you only need to delete Attribute 12, but Attribute 14 is a workaround for Cisco
bug ID CSCdu80561 (registered customers only) .

Cisco Unity 2.x
Follow the procedure below.

1. Open the Exchange Administrator in raw mode by selecting Start > Run and clicking the Browse
button.

2. Browse to the drive where Exchange is installed, browse to the bin directory, and select admin.exe.

3. Click Open to open the complete path to \bin\admin.exe.

4. Add space rto the end of the text line.

For example, &\bin\admin.exe r
5. Go to the Recipients container for the site in Exchange and select the affected subscriber.
6. Select File > Raw Properties.

After loading the schema, the Raw Properties window appears.
7. Under List Attributes, select Existing.
8. Select Custom Attribute 12, then click Remove until the field is empty.

Note: An edit value and attribute value is dimmed. Click Remove until the attribute value is empty.
9. Repeat step 8 for the following attributes:

Custom Attribute 13
Custom Attribute 14
Custom Attribute 15
Extension—Name-Inherited
Voice—Mail-Flags
Voice—Mail-Greetings
Voice—Mail-Password
Voice—Mail-RecordingLength
Voice—Mail-Speed
Voice—Mail-SystemGUID
Voice—Mail-UserID

+ Voice—Mail-Volume
10. Ensure that the "Allow rich text" attribute is set to 1.
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After replication, this subscriber is available to be imported into a Cicso Unity subscriber.

Clean Cisco Unity Properties from a Cisco Unity 4.x
Subscriber with Domino

There will be cases where it is necessary to clean the user notes of these properties before you can import
them again into a new Cisco Unity installation. To do this you need to install an agent that allows this action.



The Misc Unity Design Elements.NTF template contains an agent named "Mark Subscriber Not Imported in
Unity" that performs this task for you. To install this agent make sure the Lotus designer is installed on the
Domino server.

Use the following procedure to clean Cisco Unity properties from a Cisco Unity 4.x subscriber with Domino.

1. Start the Lotus Designer Application on the Domino Server that Cisco Unity connects to and open
the public names.nsf file from the Domino server by selecting File > Database > Open.

2. Download it from
http://www.ciscounitytools.com/Applications/RemoveUnityPropertiesFromNotes.exe.
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3. Once the address book is open, open the template file Misc Unity Design Elements.NTF.
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4. Copy the Agent from the template file by right—clicking on the file and selecting Copy.
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5. Paste it to the names.nsf agent section.
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["; Paste the Clipboard contents
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You should now have a new agent listed.
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6. Once the agent is copied, a new menu item in the Actions drop—down menu called "Mark Subscribel
Not Imported in Unity" appears in the Domino Administration tool as shown in the following screen.
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You can now select any user in the address book and clean their Cisco Unity properties. However,
exercise caution, because if you delete Cisco Unity properties off of a valid subscriber on a Unity
server, they will need to be reimported and rebuilt from scratch.



Delete the Subscriber Records in the Cisco Unity Database
for Cisco Unity 3.x and Later with any Store Message

When Cisco Unity starts creating the subscriber, two records are entered in the SQL database. If Cisco Unit
fails to complete the creation or importing of the subscriber, these two records are left behind and cause
problems like not being able to access the voice mail box. Deleting also fails. In addition, when you try to
create or import a subscriber with the same extension, you will receive an error saying that the extension
already exists in the Cisco Unity database. Unfortunately, Directory Walker from the Cisco Unity Tools page
does fix or delete these records. It must be done manually.

Note: There is no way to find who deleted a user from the Unity System Administrator page.
Use the following procedure to delete the subscriber records from SQL.

1. From the Unity server, select Start > Programs > Microsoft SQL Server > Enterprise Manager.
(If you have MSDE and Enterprise Manager is not installed, please install Enterprise Manager by
following the instructions in the Cisco Unity 3.1.5 Installation Guide.

2. Expand the Database until you find the Subscribers and Callhandlers tables.

3. Right—click on the Callhandlers table, and select Open Table > Query as in the following screen.
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4. Configure your query (as seen in the following image) to search the subscriber that you are trying to

delete from the Cisco Unity SQL database.
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In the following example, the search is for a subscriber with the DTMF 99999.
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5. Select the entire record and press the Delete key on your keyboard.
6. Repeat steps 3 through 5 for the Subscribers table.

Scenarios and Solutions

This section discusses examples and solutions of the most commonly found issues with adding/importing ne
subscribers in Cisco Unity. If none of the scenarios listed below applies to your situation, please gather as
much information as possible by following the generic troubleshooting steps and try to relate that informatior
with the error messages in the event log.

Receiving the Error: An Unrecognized Error has Occurred when Trying
to Add or Import a New Cisco Unity Subscriber

The most common error encountered when adding a new subscriber is "An Unrecognized Error has occurre

Microsoft Internet Explorer e x|

/"‘-\ An unrecognized error has occurred.
.

The new subscriber was not successfully added.

In Cisco Unity 4.x, you may see a variation of this error that includes a hexadecimal error code (the
hexadecimal error you receive may vary and does not have to match the screen shot below, this is only an



example.).

Microsoft Internet Explorer E3

,/ (] Unrecognized error 0x80005000 has occurred.

(e The new subscriber was not successfully added.

Improvements are being made to report a more accurate error statement, but for now, this error is by far the
most common. The next several sections are scenarios and solutions for a variety of causes for this error.

An Unrecognized Error has occurred Scenario 1

Problem

When trying to add or import a new subscriber via the SA, you receive the "An Unrecognized Error has
occurred" error. This is commonly followed by the "The new subscriber was not successfully added" error.

Solution (for Cisco Unity 3.x and 4.x)
A default object the SA is expecting to access no longer exist in the database.
1. Check the DOH to make sure the following objects exist.

The following constitute the most common missing objects. Please note that there can be other
scenarios.

¢ The MailUser Template that you are attempting to import with (for example, Default

Subscriber).
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¢ In the Mail User template, verify the avp_callhandler_object_id contains a valid call

handler.

Y. Doh Property Tester -|ﬂ|_’_‘J
Cofections |~ Ghbal Colaction Objectz: 2 Object Piopettias Oynasic |
oot e AP HaCPAESENTATION =

aHarder: E
CosDdiects 8 cetanenciate AFADDCTO_DLS
DistributionLists AVP_ADDRESS MODE
FaxlbrayHanders AVP_ALIAS
FaxMadiandas AVP_AUDIO_SPEED
Indervertiandle: ANP, _AUD)D “WOLUME
Lecaions AVP BILLIN(: |0
Mail)zeig A\ L HANDLER OBJEC
A‘JP CUN‘\'ERSATIUN NAME
Namel.cokupHanders AVP_COS_0BJECT_ID™
PrmanyDomainiccounts AVP_CREATION_TIME
PrmanDaomainGroups AVP DEF&ULT FV/ DTMF
Prfchows A\’P DEFAULT F'W DTMF _CHAMNGED
RestichonT ables - PP DEFALULT_PW N
TiutedDomans Object Information 3 XIfFDEFAUT PV NT_CHANGED &
Iréoemat TISTINGITSKEN H4ME
Bulk Adder | Type: [Cobander G Upea b | < Sincal|
Tabls Quary I Alisr "h.*"‘m e l:’:';'_Jr'i'"j et U ser's FreeBus ,I
Sycei ot | s ADMondce | ExSSMorker |
GCMonde |
- Propesty Yabos
| IU? (DB1FCAQF-SCFE-ATB-A58A-FEEZDICTFODC)
| Muitigle Vahaes:
| |0 DE1FCANF-ICF3-241 B-ASSS-FEE2D 327F00C
|
I Set l Delete l Sidd Remcor: | About I

¢ The CallHandler object specified in the avp_administrator_object_id exists in CallHandlers.
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2.If any of these propertles is mlssmg, see the Repair Default Objects section of this document.

An Unrecognized Error has Occurred Scenario 2



Problem

When trying to add a new subscriber, or import a new subscriber via the SA, you receive the "An
Unrecognized Error has occurred.” error. This is commonly followed by the "The new subscriber was not
successfully added.” error.

Solution (for Cisco Unity 2.x, 3.x and 4.x)

Use the following procedure.

In Windows 2000, from the Local Security Settings tree, click Account Policies > Password Policy to
disable the setting Passwords must meet complexity requirements.
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This is necessary because when Cisco Unity creates a new subscriber, it also creates a new user account f
that user. By default, it sets the new account password to 12345678. If the complexity requirements are
checked in Windows 2000, then the operating system does not allow Cisco Unity to complete the addition o
that user using the simple password of 12345678 and the process fails.

Note: You may need to make this change on the Domain Controller depending on the Cisco Unity
configuration.

Domain Name Field or Exchange Server List in the SA is Empty When
Importing an Exchange Subscriber Scenario 3

Problem

This section of this document explains how to fix the problem that occurs when trying to import an Exchange
subscriber into Cisco Unity from the System Attendant and the Domain Name field to select the subscriber t
import is empty. The Default Global Catalog setting in the Cisco Unity registry is not dynamic. This means
that if the customer changes the role of the Global Catalog server in their network (demoting the Global
Catalog Server to any other domain controller role) or the Global Catalog server is not available (the Global



Catalog is replaced with another server or the name of the Global Catalog server is changed), the ability to
import an Exchange subscriber into Cisco Unity from the System Attendant is affected. Cisco Unity will be
up and running and taking calls as normal, but you will not be able to import subscribers because the Doma
Name field will be empty or the list of Exchange servers to import subscribers from will be empty.

For more information, refer to Cisco bug ID CSCdw14838 (registered customers only) — GC Monitor fails to
monitor changes if the Global Catalog server moves.

Solution

This solution applies to Cisco Unity 3.x and 4.x in a Windows 2000 Box with Exchange 2000 (On and Off
Box) in a Windows 2000 domain.

The information presented in this document was created from devices in a specific lab environment. All of th
devices used in this document started with a cleared (default) configuration. If you are working in a live
network, ensure that you understand the potential impact of any command before using it.

To make the change manually, you need to go to the registry. Expand the key HKLM/ Software/Active
Voice/DirectoryConnectors/DirSynchGlobalCatalog/1.00/Directory. You will see a key called
DefaultGlobalCatalogServer. Change it to point to the new Global Catalog server and make sure you enter ¢
fully qualified domain name, such as "mycomputer.mydomain.com."

To change this setting, perform the following steps:
1. Start Regedit.

n Caution: Changing the wrong registry key or entering an incorrect value can cause the server

to malfunction. Before you edit the registry, confirm that you know how to restore it if a problem
occurs. (Refer to the "Restoring” topics in Registry Editor Help.)

Note: A typical backup of the Cisco Unity server does not back up the registry. Also note that for
Cisco Unity failover, registry changes on one Cisco Unity server must be made manually on the othe
Cisco Unity server, because registry changes are not replicated. If you have any questions about
changing registry key settings, contact Cisco Technical Support.

2.1f you do not have a current backup of the registry, select Registry > Export Registry File and save
the registry settings to a file.

3. Expand the key HKLM\Software\Active
Voice\DirectoryConnectors\DirSynchGlobalCatalog\1.00\Directory.

4. Change the DefaultGlobalCatalogServer key to point to the new Global Catalog server by entering a
fully qualified domain name such as "mycomputer.mydomain.com."

Note: You do not need to restart the Cisco Unity system.

To verify that the server the above registry is pointing to is a Global Catalog server, use the following
procedure.

1. On one of the domains, start the Active Directory Sites and Services snap—in by selecting Start >
Programs > Administrative Tools and clicking Active Directory Sites and Services.

2.In the console tree, double—click Sites and then double—click Sitename.

3. Double—click Servers and then click the domain controller that corresponds to the Default Global
Catalog value in the Cisco Unity server registry.

4. Right—click NTDS Settings and select Properties.

5. From the General tab, determine if you want to check the Global Catalog check box to assign the rol



of the Global Catalog to this server or not.

Note: By default, Windows 2000 only places a Global Catalog on the first Domain Controller in each
Active Directory (AD) forest. Allow sufficient time for the account and the schema information to
replicate to the new Global Catalog server before you remove the Global Catalog from the original
domain controller.

Note: Event 1119 may be logged in the Directory Services log in Event Viewer with a description
that states the computer is now advertising itself as a Global Catalog server. In a Windows 2000
domain with only one domain controller, you typically assign the roles of the Global Catalog and the
Operations Master (also known as Flexible Single—-master Operations (FSMO)) to the same domain
controller. However, in domains with multiple domain controllers, particularly in forests with

multiple domains, it is important to consider the placement of these roles before you assign them.

An Unrecognized Error has Occurred Scenario 4

Problem

When trying to add a new subscriber, or import a new subscriber via the SA, you receive the An
Unrecognized Error has occurred 0x8007200F. error message. This is commonly followed

by the "The new subscriber was not successfully added." error.

Solution (for Cisco Unity 3.x and 4.x)

The registry setting on Cisco Unity is pointing to the wrong Domain Controller. Verify the following key is
set correctly and points toward a valid DC.

« HKEY_LOCAL_ MACHINE\SOFTWARE\ActiveVoice\DirectoryConnectors
\DirSynchAD\1.00\Domains\{your domainj\DefaultDomainController

Solution (for Cisco Unity 2.4x)

The registry setting on Cisco Unity is pointing to the wrong Domain Controller. Verify the following key is
set correctly and points toward a valid DC and that DC is not being upgraded or moved while Cisco Unity is
being installed and trying to connect to it.

* HKEY_LOCAL_MACHINE\SOFTWARE\ActiveVoice\Dalex\1.00\

All of the Domain information is under the registry folder \Server\Root and should have the value of the
DefaultDomainController.

For more information, check the General Troubleshooting section related to Access to the Directory under tt
General Troubleshooting Steps for Creating/Importing Subscribers Problems section of this document.

An Unrecognized Error has Occurred Scenario 5
Problem
When trying to add a new subscriber, or import a new subscriber via the SA, you receive the "An

Unrecognized Error has occurred.” error. This is commonly followed by the "The new subscriber was not
successfully added.” error.



Solution (for Cisco Unity 3.x and 4.x)

Run the Permissions Wizard tool on the USERS container in Active Directory or the container that you want
to import from depending on your scope for importing subscribers. There are various reasons that permissic
are incorrectly configured within the Active Directory. Typically, the Permissions Wizard should be run on
the USERS container, or if the customer stores users in a container other than the USERS container, point
Permissions Wizard to that container when running the utility. An overview of the Permissions Wizard can b
found at the Cisco Unity Tools page. There is also a help file located on the Cisco Unity server in Drive
Letter:\Commserver\Utilities\PermissionsWizard. Also, restart the AvDSAD and AvDSGlobal Catalog

services.

An Unrecognized Error has Occurred Scenario 6

Problem

When trying to add a new subscriber, or import a new subscriber via the SA, you receive the "An
Unrecognized Error has occurred.” error. This is commonly followed by the "The new subscriber was not

successfully added.” error.

Solution (for Cisco Unity 3.x and 4.x)

The account associated with the AvDSAD and AvGlobalCatalog services does not have sufficient
permissions. Use the following procedure to fix this.

1. Verify which account is associated with these services.

? =181
k=) 2 /rm0m
Name | Descrption | Status | Startwp Type [ LogOnas | -
%Nevtev Notifies cel...  Started Atomatic LocalSystem
S Appication Manage... Providess... Manual LocalSystem
%Av(st;:ltway Started Automatc LocalSystom
%A\'Cqu- Sarted Manusl LocaSystem
avDeChangewiner Rarted  Avtomatic | LecalSystem
BAVDSAD ) Startod  Automatc  SALINGER)Admnstrator |
@ AvDSGlobalC atabog Started  Automatic SALINGER | Administrator
%Avﬁoen.’m Manusl LocalSyster
o AvMsgStoraMonior. .. Rarted  Manual LecalSystem —
RoAvRecOu S Sve Started  Manual LocalSystem
Sy AvTesSwr Stated  Manual LocalSystem
R AVLIR SyneSvr Started  Manud LocaSystem
B ClipBock Supports C... Manus LocalSystem
RCOM+ Event System  Providesa... Sarted  Manual LecalSystem
B Computor Erowsar Maktans ... Started Automatc LocalSystom
S CsBridonConnector Manual LecalSystem
%DH’.O Clort Marages ... Started Automatic LecalSystem
%L\L':bu.ed File Syst... Manzges ... Sarted Automatic LocaSystem
Roicrbutedlink Tra,,, Sendsnonf.., Started  Automatic LocaiSystem
%Cnst'bued Urk Tra,,. Stores ibfo... Started Automatic LocalSystem
Ryistrbuted Transac,.. Coordinate,,, Started  Automatic LecalSystem
%DNS Clemt Resoives & Sarted Automatic LocalSystem
%Ev«l Log Logs event.., Started Automatic LocaSystem
BFax Sarvice Helps you Manual LocatSystom
SaFic Repication Serv... Martansf.., Started  Automadic LocalSystem
115 Admin Service Alows adm,,,  Started Automatc LocalSystem
%lncming Service Indexes co... Manual LocaSystem
R Internet Cennecto,..  Providesn.., Manusl LecalSystem -
- Pa— ‘. - - e

2. Run the Permissions Wizard and choose the account verified in step 1.

An overview of the Permissions Wizard can be found at the Cisco Unity Tools page. There is also a

help file located on the Cisco Unity server in Drive
Letter:\Commserver\Utilities\PermissionsWizard.



3. If steps 1 and 2 are unsuccessful, run the Directory Access Diagnostic tool (DAD).

DAD can be run on Cisco Unity version 3.0.1 and higher running Exchange 2000. In Cisco Unity 4.x
systems, this tool is located in the x:\commserver\utilities directory. In Cisco Unity 3.x systems, go
to the DAD tool located in the Cisco Unity Tools page. The DAD tool is very straightforward and
contains suggested solutions for problems it encounters. There is also a training video on DAD as
well as an additional help file.

Templates CallHandler not found Error Received Scenario 7
Problem

When trying to add a new subscriber, or import a new subscriber via the SA, you receive the "Templates
CallHandler not found." error.

Solution (for Cisco Unity 2.x)

In Cisco Unity 2.4.x, you will have to run the confmgr.exe utility that is found in your Unity server under the
directory \commserver\ confmgr.exe. Before you run this utility, you have to understand that the following
procedure re—creates the Cisco Unity default database (Eadministrator, Esubscriber, the default templates,
opening greeting callhandler, and goodbye and operator CallHandlers). The opening greeting says "Welcon
to the Unity system&" as it did when you first installed Cisco Unity, instead of your Company's opening
greeting. The same is true with caller input, schedules, and so forth, that you may have reconfigured. Please
back-up the greetings that need to restore and make screen shots of the configuration for the default datab:
that you need to reconfigure.

Use the following procedure to run the utility.
1. Go to the commserver\confmgr.exe directory.
2. Run the DOH script.
3. Click Run.
Solution (for Cisco Unity 3.x and 4.x)
For repairing default objects, a default object fix script is now included in Cisco Unity 3.1(4).
Only Cisco Unity versions 3.0(4), 3.1(1), 3.1(2c), and 3.1(3) were tested for backwards compatibility.
This script restores the default subscribers, class of services, templates, and location mentioned for Cisco
Unity 2.4.x. Please back up the greetings that you need to restore back to and make screen shots of the
configuration for the default database that you need to reconfigure.
Please note that if the Mail User Template exists, but the corresponding call handler for that template does r

(for example, if ch_defaultemplate is missing), you must manually remove the Mail User Template from the
DOH before proceeding with the following steps.



Use the following procedure to restore the default objects for Cisco Unity 3.1(4) and higher.

1. Run the C:\commserver\localize\defaultconfiguration\enu\FixDefaultObjects.sql from the
command line using the syntagql —E -i fixdefaultobjects.sq|l.

Note: The script will make a SQL backup of the Cisco Unity database before modifying it and you
must CD to the above location to run the script. Run C:\commserver\configmgr.exe.
2. Select and run Configure Database Schema.

f [Warning: Do not run the Run Database Schema Script or the database will be wiped clean!

3. Select and run the Run Rules Configuration Script.

4. Select and run Configure Default Location.

5. Run C:\commserver\configurationsetup\setup.exe /sync.

6. Reboot the server.

7. Run C:\commserver\utilities\dbwalken\dbwalker.exe when Cisco Unity comes up.

Use the following procedure to restore the default objects for Cisco Unity 3.1(3) and earlier.

1. Obtain the fixdefaultobjects.sql script from a Cisco Unity 3.1(4) or later version.
2. Run the C:\commservenlocalize\defaultconfiguration\enu\FixDefaultObjects.sql from the
command line using the syntax osql —E —i fixdefaultobjects.sq|l.

Note: The script will make an SQL backup of the Cisco Unity database before modifying it and you
must CD to the above location to run the script.

3. Run C:\commserver\configmgr.exe.

4. Select and run the Run Rules Configuration Script and select the DefaultRules.sql script file.

5. Select and run Configure Default Location and select the DefaultDatabase.sql script file.

6. Run C:\commserver\configurationsetup\setup.exe /sync.

7.Reboot the server.

8. Run C:\commserver\utilities\dbwalker\dbwalker.exe when Cisco Unity comes up.

9. Fix any errors and orphaned call handlers. You can use Directory Walker, which can be found at the
Cisco Unity Tools page.

For more information on the above solutions for repairing default objects, see Cisco bug ID
CSCdx20173 (registered customers only) .

Import Existing Exchange 2000 and Cisco Unity Subscribers to a new
Unity Server Scenario 8

When you have a Cisco Unity 3.x server with an Exchange 2000 inbox and in production, and you need to
transfer all mailboxes and Cisco Unity subscriber information to a new Cisco Unity 4.x server and Exchange
2000 server, several things must be taken in consideration. In Exchange 2000 you can move mailboxes to &
new server. To avoid problems, you need to make sure that these subscribers are completely logged out of
their inboxes. They may have no access to their voicemail through the phone and Outlook must also be turr
off during the moving process. For the Unity Information, if the mail aliases between the two systems are the
same, you can use the DIiRT utility to move Cisco Unity subscriber information and inbox messages
(optionally) as well. You can find the latest DIRT utilities on the Cisco Unity Tools page (be sure to use the
latest ones).

If the mail aliases don't match, it will create new mailboxes for those users on the fly. You can then use the
Migrate Subscriber Data tool to move the Cisco Unity information (and, optionally, the inbox content as well)
to the correct corporate email account. You can get this tool (and training video and help file) from the Cisco



Unity Tools page.
Unrecognized Error 0x80042024 has Occurred Scenario 9

Problem

When trying to import a new subscriber via the SA, you receive the "An Unrecognized Error 0x80042024 ha
occurred.” error. This is commonly followed by the "The new subscriber was not successfully added." error.
This problem only appears in Cisco Unity 4.x.

Solution

The account that is being imported does not have the right permissions or enough permissions. Use the
following procedure to fix this.

1. Run the Permissions Wizard on the OU that you will import users from. The Permissions Wizard is
in the Tools Depot.

There is a Tools Depot icon on the desktop of the Cisco Unity server.
2. The user account in Active Directory has to have inherited permissions from the OU.

a.Go to Active Directory Users and Computers.

b. Select View > Advanced Features in order to see the Security tab in the account properties.

c. Go to the OU and double—click on the user account to bring up the Properties page.

d. Click the Security tab.

e.Make sure that the Allow inheritable permissions from parent to propagate to this object
checkbox is checked.



Scenario Nine Properties ﬂ m

Environment I Sessions I Remote control I Terminal Services Profile I
Exchange General I E-mail Addresses
Exchange Features I Exchange Advanced I
General ] Address | Account I Profile I Telephones I Organization |
Published Certificates | MemberOf | Dialin | Object ~ Security

Name = | & Add... |
m Account Operators [U3XF2\Account Operators)
m Authenticated Users _ﬂi.'&_l
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Permissions: Allow Deny
Full Control O ﬂ
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Wite O
Create All Child Objects (M|
Delete All Child Objects O
Change Password O =]

Advanced... |

v Allow inhentable permissions from parent to propagate to this

iobject
| 0K I Cancel I Apply | Heln |

......

Error Message: The alias specified matches an alias already existing in
the active directory

Problem

When you try to add a new subscriber to the Cisco Unity server, you receive the The alias specified
matches an alias already existing in active directory error message. But, if you do
a search for the same alias by extension or name, the alias is not found.

Solution

This issue can be due to a user in the Active Directory (AD) who has the same alias that you want to use.
Verify if the user that you are attempting to create already exists in AD or if there is another user in AD that
has the same alias. When you delete a subscriber in Cisco Unity, it is only deleted from the Unity database,
but the user remains in AD and Exchange. If you do not remove it from AD and Exchange manually, you
have problems when you add the user again or add another subscriber that matches the alias.

Verify if the user that is already in AD is valid and active. If this is the case, you need to assign a different
alias to the new Cisco Unity subscriber. If the user is not active and valid, you can manually delete the user
from AD and Exchange and add the new subscriber in order to overcome this issue. Complete these steps:

1. Choose Start > Programs > Microsoft Exchange > Active Directory Users and Computers.
2. Expand the tree and open the User folder.
3. Search for the user that has the same alias. Right—click on the user and choose Delete.



This deletes the account from AD only. You also need to delete the mailbox from Exchange.

Note: If you have voicemail only, then the user in AD that matches the alias is probably an old user
that is no longer a Cisco Unity subscriber. In this case, it should be safe to delete the user. But, if yol
are not sure, then you might need to select another alias for the new subscriber. If you have Unified
Messaging, since AD serves email users and voicemail users, it can happen that an email user has 1
same alias. In this case the only option is to create a new alias for the new subscriber.

4. Choose Start > Programs > Microsoft Exchange > System Manager.

5. Expand the tree and choose Servers > First Storage group > Mailbox Store > Mailboxes.

6. Right—click on Mailboxes and choose Run Clean—up Agent in order to disable all of the mailboxes
that are not currently associated to an AD user.

7. Click on Mailboxes in order to see all of the mailboxes listed on the right window.

8. Search for the mailbox of the user that you just deleted in AD. Due to the clean—up it should show a
solid red circle with an X in it.

9. Right—click on it and choose Purge in order to delete the mailbox and the messages in it.

10.You are now able to add your new subscriber in Cisco Unity. At the moment you create the new

subscriber, a user account appears in Active Directory Users and Computers and in Exchange Syste
Manager. The mailbox is also created.

Error Message: Page Cannot be displayed

Problem

When a user imports an existing Exchange user to Cisco Unity using Cisco Unity Administrator, this error
message displays:

Page Cannot be displayed

Solution

Use any one of these workarounds in order to resolve this issue:

1. Try to force a reconnection by using the Domain Controller/Global Catalog (DC/GC) Reconnect tool
available at Unity Tools Depot > Administrative Tools.

Note: This is not service impacting so it is safe to run at anytime. When you force a reconnection, yo
can monitor it on the Application Log on the Event Viewer. There you see a message when the
process starts and once when it finishes.

2. If forcing the connection with the DC/GC Reconnect tool does not work, try to import Unity
subscribers using the Bulk Import Utility (instead of SAWeb) as documented by Cisco bug ID
CSCeg18768 (registered customers only) .

Error: Extension xxxx is already in use by Mail User:xxxxx. Please enter
a unique extension

The Extension xxxx is already in use by Mail User:xxxxx. Please enter a
unique extension error message appears. This error message is received:

* When you attempt to import a subscriber

* When the Extension field of some users shows a blank value and when you try to put the correct
extension in the field

* When you attempt to create new user in Cisco Unity



Solution
This issue usually happens when the DB field is corrupted. Complete these steps in order to resolve the issl

1. Enter a new extension in the extension field for the affected subscribers, and save the profile.
2. Change the extension back to the original value, and save again

Error: LDAP_SERVER_DOWN

This error message appears when users are imported from Microsoft Exchange:

(Error)
Sync failed: annettem. Error: LDAP_SERVER_DOWN

Solution

If you receive the LDAP error when you import users from Microsoft Exchange/Active Directory, it indicates
that the Domain controller is not set properly. It is recommended to check if the correct Domain Controller is
added in the Domain Controller/Global Catalog (DC/GC) Reconnect tool available at Unity Tools Depot

> Administrative Tools. You need to enter the active and running domain controller in this tool and click
Force Reconnect.

Error: Multiple-step OLE DB operation generated errors

When you try to add a subscriber in Cisco Unity, this error message is received:

Cisco Unity encountered a SQL error.

Description: Multiple—step OLE DB operation generated errors. Check each OLE DB status
value, if available. No work was done.

Source: Microsoft OLE DB Provider for SQL Server

SQL Error Code: 0x0

ADO Error Code: 0x80040e21

Cisco Unity encountered a SQL error.

Description: Maximum stored procedure, function, trigger, or view nesting level exceeded
(limit 32).

Source: Microsoft OLE DB Provider for SQL Server

SQL Error Code: 0xd9

ADO Error Code: 0x80004005

Solution
Complete these steps in order to resolve this issue:

1. On the Cisco Unity server, choose Start > Programs > Microsoft SQL Server > Enterprise
Manager.

2. Choose Microsoft SQL Servers > SQL Server Group > <UnityserverName> > Databases,
right—click on UnityDb and choose Properties.

3. Choose the Options tab and make sure that these values are unchecked:

¢ Recursive triggers
¢ Auto close
¢ Auto shrink



Unable to run COBRAS backup from Cisco Unity 4.1 to 4.2

When you try to run COBRAS import on the Cisco Unity 4.2, you get conflicts for every subscriber that say
they were homed on another Cisco Unity machine on the network.

The reason behind the COBRAS backup failure is because the subscribers exist in the Global subscriber DI

Solution

The solution for this issue is to delete the global subscriber. These are the commands to be performed on tf
command prompt in order to delete the global subscriber

Osql -E

Use UnityDB

Go

Delete From GlobalSubscriber Where Alias like '%'

Go
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