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Viewing Your WLAN Radio 
Environment with Location Manager

The Location Manager gives you a graphical view of the access points (APs) on 
each floor of your building(s). Use Location Manager to:

• Enter information about building and floor environments (see Adding 
Building Information, page 10-6)

• Specify the location of APs on each floor (see Adding Devices to the Floor, 
page 10-12)

• Display graphically the APs and their configuration values on each floor of 
your building (see Modifying Information Displayed with Device Icons, 
page 10-13)

• View the relative location of unknown or rogue APs (see Changing Display 
Options for Unknown Radios, page 10-21)

• Use the Assisted Site Survey to determine optimal radio transmit power, 
channel selection, and beacon interval (see Using the Assisted Site Survey 
Wizard, page 10-22)

• Display the predicted coverage of APs (see Using the Assisted Site Survey 
Wizard, page 10-22)

The Location Manager supports up to 1,500 buildings per location with a 
maximum of 100 floors per building and a maximum of 100 APs per floor.
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Prerequisites for Using Location Manager
Before using Location Manager, you must have 

• Installed Java Runtime version 1.4.1 or higher. When you click on Location 
Manager, a message appears displaying what version of Java plug in you have 
installed and gives you a link to install the correct version if necessary.

• Discovered, inventoried, and managed all devices. See Managing Devices, 
page 3-1. 

• Authenticated the devices with WDS. IOS access points must be configured 
for Wireless Domain Service (WDS) and for LEAP authentication. For 
information on the minimum requirements for device setup, see the “Setting 
Up Devices” chapter in the Installation and Configuration Guide for the 
CiscoWorks Wireless LAN Solution Engine, Release 2.7. This guide is shipped 
with each WLSE, or you can view it online on Cisco.com.

• Obtained an image (.gif, .jpg, .jpeg, or .png) of the layout of your building, 
which you import in to Location Manager (see Importing an Image of the 
Building or Floor, page 10-8). It is recommended that your image be less 
than300KB and less than 1,000x1,000 pixels. While it is not required that you 
import an image, you must at least specify the floor dimensions.

Launching Location Manager
You can launch Location Manager in two ways:

• By clicking the Location Manager tab, then clicking Location Manager > 
Launch.

• By selecting Faults > Display Faults and clicking the link in the Address, 
Description, or Timestamp fields in the Fault Summary Table for an unknown 
access point. A new window displays the Rogue Access Point Details report. 
From the Rogue Access Point Details report, click on Location Manager to 
launch Location Manager. 

Related Topics

• Understanding the Location Manager Window, page 10-3

• Getting Started with Location Manager, page 10-3
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Getting Started with Location Manager
After you launch Location Manager, there are several steps you need to perform 
before using the Location Manager features:

1. Add information about your building (see Adding Building Information, 
page 10-6)

2. Import a image of your building (see Importing an Image of the Building or 
Floor, page 10-8). This step is optional but highly recommended. 

3. Add information about the floor(s) in your building (see Adding Floor 
Information, page 10-11)

4. Place devices in their approximate location on the floor map (see Adding 
Devices to the Floor, page 10-12)

Understanding the Location Manager Window
Figure 10-1 shows the information contained in the Location Manager window.
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Figure 10-1 Location Manager Window

Table 10-1 describes the Location Manager fields that are numbered above

Table 10-1 Location Manager Window Descriptions

Number Description

1 Under All Locations, the buildings and floors that have been added to Location Manager 
are listed. 

• If you click on All Locations, the All Locations Summary appears in field 3. (See All 
Locations Summary, page 10-5.)

• Click on a building to see the Building Summary in field 3. Double-click on a building 
name or click the expand button to see the floors of each building.

• Click on a floor to see the floor map in field 3.Double-click on a floor name or click 
the expand button to see the devices on the floor.

• Double-click on a device to center the device in the floor map in field 3.

2 Zoom options for the floor map (See Zooming In and Out, page 10-36.)
10-4
User Guide for the CiscoWorks Wireless LAN Solution Engine

78-16193-01



 

Chapter 10      Viewing Your WLAN Radio Environment with Location Manager
Understanding the Location Manager Window
Related Topics

• All Locations Summary, page 10-5

• Prerequisites for Using Location Manager, page 10-2

• Getting Started with Location Manager, page 10-3

• Understanding Location Manager Device Icons, page 10-12

All Locations Summary
When you first launch Location Manager, the default view is All Locations. The 
window on the right displays the All Locations Summary which contains the 
following information:

• Managed Access Points—Number of managed APs

• Active Alarms—Sum of major and minor alarms currently in your network

• Major Alarms—P1 and P2 alarms (see Viewing Fault Information, page 2-2)

• Minor Alarms—P3, P4, and P5 alarms (see Viewing Fault Information, 
page 2-2)

When you expand the All Locations folder, you see a list of the buildings and 
corresponding floors that have been entered in to Location Manager. When you 
click on a building or floor, the building or floor image map appears in place of 
the All Locations Summary. 

3 If you imported an image map, the map for the floor you clicked on appears here (See 
Importing an Image of the Building or Floor, page 10-8 for information about importing 
floor maps.) 

4 Tools you can use for measuring and displaying color keys (See Using Location Manager 
Tools, page 10-34.)

5 Lists discovered, inventoried, and managed devices not assigned to a building or floor. 
(See Managing Devices, page 3-1.)

Table 10-1 Location Manager Window Descriptions (continued)

Number Description
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The Building Summary, which appears when you click on a building name, 
displays the same information as the All Locations Summary but about the 
specific building.

Related Topics

• Understanding the Location Manager Window, page 10-3

• Getting Started with Location Manager, page 10-3

Adding Building Information
When you start Location Manager, the first thing you need to do is add 
information about your building(s) and its floor(s).

Procedure

Step 1 Select the Location Manager tab, then click Location Manager. A page appears 
telling you about the necessary Java plug-in version required to use Location 
Manager, and it displays the Java version you are currently running.

Step 2 When you are sure you are running the correct version of the Java plug-in, click 
Launch to start Location Manager. The Location Manager window opens. 

The first time you launch Location Manager, a dialog box appears saying that no 
building or floor information was found. It asks if you want to add a new building. 
Click Yes.

If you have previously launched Location Manager and want to add a building, 
select Edit > Add Building or right-click on All Locations and select Add 
Building. 

Step 3 The Building Tool opens displaying the Create Building Information form. Enter 
information about the building. 

The following table shows the character limits for each field on the Create 
Building Information form:

Field Maximum Character Length

Building Name 64 characters
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Step 4 To import an image of the building, click Upload/Select. This step is optional but 
useful if each floor plan and floor dimensions in the building are the same. If you 
want to specify different images for each floor, you can skip this step. 

The larger an image resolution is, the longer it takes to upload to the server and 
the more memory it uses. Therefore, we recommended that your image be less 
than 300KB and less than 1,000x1,000 pixels. For more information about 
importing an image, see Importing an Image of the Building or Floor, page 10-8. 
This step is optional, but highly recommended. If you do not import an image, the 
floor appears as a white box.

Note If you import an image at the building level, that image is the default for 
all floors in the building. 

Step 5 Enter dimensions for the floor in the Floor Dimension fields and select whether 
the measurement is in feet or meters. See Specifying Dimensions for and Scaling 
Imported Images, page 10-9 for more information. 

Step 6 Click Save or click Add Floor to add information about the floor of the building 
(see Adding Floor Information, page 10-11). If you click Add Floor, you are 
prompted to save the building information first. 

The Create Floor Information window appears. See Adding Floor Information, 
page 10-11.

Related Topics

• Importing an Image of the Building or Floor, page 10-8

• Adding Floor Information, page 10-11

• Specifying Dimensions for and Scaling Imported Images, page 10-9

Contact 64 characters

Address 256 characters

Field Maximum Character Length
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Importing an Image of the Building or Floor
To use Location Manager, you need an image (.gif, .jpg, .jpeg, or .png) of the 
layout of your building or floor. The larger an image resolution is, the longer it 
takes to upload to the server and the more memory it uses. Therefore, we 
recommended that your image be less than 300KB and less than 1,000x1,000 
pixels. You can import this image into Location Manager by following these steps.

Note If you import an image at the building level (not a floor), that image is the default 
for all floors in the building. 

Note If your image filename has any spaces in, the spaces are replaced with underscores 
(_). For example, if your image filename is my floor image.jpg, it will become 
my_floor_image.jpg in Location Manager.

Procedure

Step 1 In the Location Manager window, right click on a building (or floor name) and 
select Edit Building (or Edit Floor if you right-clicked on a floor). The Edit 
Building (or Floor) Information form appears.

Step 2 Click Upload/Select. The Select Image File window appears. If your image file 
appears in the Select Image File window, skip to Step 5 .

Step 3 Click Add to List. to browse to the location of your image file.

Step 4 Click on your image file, then click Select. Your file is uploaded and added to the 
Select Image file window.

Step 5 Click on the image file, the click Select. The image is selected. The image file 
appears in the Default Floor Map Image field on the Building Tool window, and 
your image file appears in the Map Image Preview field. 

Step 6 Enter the correct the values in the Floor Dimension field, then click Update 
Preview.

Step 7 On the Map Image preview, drag the red rectangle to cover just the edges of your 
building or floor, or if desired, drag the rectangle over just a portion of the image. 
This is particularly important if your image has white space around the building 
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or floor because it helps Location Manager more accurately determine the 
location of any interferers. See Specifying Dimensions for and Scaling Imported 
Images, page 10-9.

Related Topics

• Adding Floor Information, page 10-11

• Adding Devices to the Floor, page 10-12

• Specifying Dimensions for and Scaling Imported Images, page 10-9

Specifying Dimensions for and Scaling Imported Images

In order for Location Manager and many Radio Manager functions to give the 
most accurate information, it’s important that you enter the correct floor 
dimensions and, if you imported an image, that your floor image be as accurate as 
possible. There are two important steps you need to perform to ensure your 
building and floor information are accurate:

• Specify exact floor dimensions in the Floor Dimension fields on the Location 
Manager Building Tool.

• If you imported an image, use the scaling tool (the red rectangle) in the 
Building Tool window to encompass the area on the image for which you 
specified dimensions (see Scaling the Building or Floor Image, page 10-10).
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Figure 10-2 Scaling the Building or Floor Image

Number Description

1 Enter exact dimensions in the Floor Dimension fields and select 
whether the measurement is in feet or meters.

2 Move the red rectangles in each corner to cover only the area of 
floor for which you specified dimensions in the Floor 
Dimension fields. 
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Adding Floor Information
After importing an image file of your building, you need to specify the dimensions 
of the floor(s) so that Location Manager knows the scale of the image you 
imported and can more accurately report the location of any interferers. When you 
first import an image file into Location Manager, the floor dimensions are the 
pixel size of the imported image. 

Procedure

Step 1 In the Location Manager window, right click on the building name and select Add 
Floor. The Building Tool opens with the Create Floor Information form.

Step 2 Enter the name of the floor and import an image map.

Note If you previously imported an image to your building, that image is the 
default for all floors in the building. To upload a new image for the floor, 
import a new image. For more information on importing an image, see 
Importing an Image of the Building or Floor, page 10-8. 

Step 3 Select whether the measurement is in feet or meters using the pull-down menu, 
and then enter the dimensions of your floor in the Floor Dimensions field.

Step 4 On the Map Image preview, drag the red rectangles, which appear in the corners 
of your image, to cover just the edges of your floor, or if desired, drag the 
rectangle over just a portion of the image. This is particularly important if your 
image has white space around the building or conference room because it helps 
Location Manager more accurately determine the location of any interferers.

Related Topics

• Adding Devices to the Floor, page 10-12

• Importing an Image of the Building or Floor, page 10-8

• Adding Building Information, page 10-6
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Adding Devices to the Floor
After you add a new building and new floor and import an image map, you can 
place the devices on the floor map for each floor. 

Note You must discover, inventory, and manage all devices before adding them to 
Location Manager. See Managing Devices, page 3-1. 

To add devices to the floor map, from the list of devices in the Unspecified 
Location list, click and hold on a device name and drag it to its approximate 
location on the image of the floor map.

You do not need to place the devices in the exact location on the image map, but 
the closer the device on the map matches its location on the floor, the more 
accurate coverage displays will be and the more accurate Location Manager is 
when giving information about unknown radios and interferers. 

Related Topics

• Understanding Location Manager Device Icons, page 10-12

• Understanding the Location Manager Window, page 10-3

Understanding Location Manager Device Icons
After you have placed the devices on the floor map, the devices are represented 
by icons as shown in Table 10-2. The color of the icons correspond to the devices’ 
fault status:

• Red indicates the device has major (P1 or P2) faults.

• Yellow indicates the device has minor (P3, P4, or P5) faults.

• Green indicates the device has no faults.

The color of the buildings and icons in the location tree also correspond to their 
fault status.

For more information about faults, see Viewing Fault Information, page 2-2.
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Based on the different options you select in the View menu, the information that 
is displayed with the device icons might be different (see Modifying Information 
Displayed with Device Icons, page 10-13).

You can right-click on any AP and select Device Details. A new browser opens 
displaying the AP Summary Report for the AP you selected. 

Related Topics

• Modifying Information Displayed with Device Icons, page 10-13

• Displaying Information About Rogue Access Points, page 10-17

Modifying Information Displayed with Device Icons
From the View menu, you can select what information to display with the device 
icons on the Location Manager floor map. Table 10-3 explains what information 
is displayed with each View option.

Table 10-2 Device Icons Used in Location Manager

Icon Meaning

AP with no faults

Interference reporting AP with minor 
faults

Scanning-only AP with major faults
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Table 10-3 Location Manager View Menu Options 

Location Manager 
Menu Sequence Option Selected

Information Displayed 
on the Floor Map Example

View > AP Label Name Device name

IP Address Device IP address

Ethernet MAC Address Device Ethernet MAC 
address

View > Radio Band1 
See Understanding 
Radio Band Display 
Options, page 10-16.

Show All View options for both 
2.4GHz and 5.0 GHz 
radio interfaces

Depending on which option 
you select, displays the 
view options for all radios, 
2.4 GHz radios, or 5.0 GHz 
radios.

Show 2.4 GHz View options for 
devices with 2.4 GHz 
radio interfaces

Show 5.0 GHz View options for 
devices with 5.0 GHz 
radio interfaces
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View > Radio 
Channel

n/a Radio channel of each 
radio interface 
(channel 9 in the 
example). The color 
corresponds to the 
channel color (see 
Using Location 
Manager Channel 
Color Key, 
page 10-35). 

Note Scanning-only APs 
have an “S” in place 
of the radio 
channel.

View > Transmit 
Power

n/a Transmit power (in 
mW) of each radio 
interface (100 mW in 
the example)

Note Scanning-only APs 
display “N/A.”

View > Data Rate n/a Data rate (in Mbps) of 
each radio interface 
(11 Mbps in the 
example). See Using 
the Location Manager 
Coverage By Data 
Rate Color Key, 
page 10-36.

Note Scanning-only APs 
display “N/A.”

1. This menu option is available only when you click on a floor. These options are also available from the Radio Band pulldown 
menu. 

Table 10-3 Location Manager View Menu Options  (continued)

Location Manager 
Menu Sequence Option Selected

Information Displayed 
on the Floor Map Example
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Understanding Radio Band Display Options

When you click on an option from the View > Radio Band menu or from the 
Radio Band pulldown menu, you are specifying which radio band’s view options 
you want to display in the Location Manager window:

• Show All—Displays view options for all devices, including AP labels for 
both 2.4 GHz and 5.0 GHz radios

• Show 2.4 GHz—Displays view options and AP labels for devices with 2.4 
GHz radio interfaces

• Show 5.0 GHz—Displays view options and AP labels for devices with 5.0 
GHz radio interfaces

Note Because APs can have a 2.4 GHz and a 5.0 GHz radio interface, the same View 
information might appear if you select to display 2.4 GHz radios and later select 
to display 5.0 GHz radios. If you place your mouse over an AP, information about 
each interface (called Radio 1 and Radio 2) is displayed. 

If you have not selected to view Radio Channel, Transmit Power, or Data Rate, 
the display does not change when you select different Radio Bands from the View 
> Radio Band menu or from the Radio Band pulldown menu. 
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Depending on what radio band you select from the View > Radio Band menu or 
from the Radio Band pulldown menu, the AP label that is displayed on the 
Coverage Display pulldown, or on the Coverage Display On menu when you 
right-click on an AP, changes as shown in Table 10-4.

Displaying Information About Rogue Access Points
When Radio Monitoring detects a rogue AP, a new fault is generated. (See 
Understanding Rogue AP Detection, page 9-10 for more information.) When you 
select the link in the Address, Description, or Timestamp fields in the Fault 
Summary Table for an unknown access point, the Rogue Access Point Details 
window displays information about the rogue AP such as details about the 
unknown access point, beacon and location information, switch port tracing, 
reporting access points, and fault history. You access the faults window from 
WLSE, not from within Location Manager. 

You can also view this information, except for switch port tracing, from the 
Location Manager Unknown Radio List (see Displaying the Location of Unknown 
or Rogue Radios, page 10-18).

Table 10-4 Radio Band Selection

Radio Band 
Selected1

1. From either the View > Radio Band menu or from the Radio Band pulldown menu. 

AP Labels Displayed2

2. For information about modifying what AP label information is displayed, see Modifying 
Information Displayed with Device Icons, page 10-13. 

Available Options in 
Coverage Display Menu3

3. You can see the Coverage Display options by selecting Coverage > Coverage Display, by 
clicking on the Coverage Display pulldown menu, or by right-clicking on an AP and viewing 
the Coverage Display On menu. For more information, see Modifying AP Coverage Display 
Options, page 10-28. 

All Both 2.4 GHz and 5 GHz None, 2.4 GHz, and 5 GHz

2.4 GHz 2.4 GHz None, 2.4 GHz

5 GHz 5 GHz None, 5 GHz
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Procedure

Step 1 From WLSE, select Faults > Display Faults. The Fault window appears.

Step 2 Click the link in the Description or Timestamp fields in the Fault Summary Table 
for an unknown access point.

A new window displays the Rogue Access Point Details report. For information 
about this report, see Unknown AP Details, page 2-15

For more information about faults, see Viewing Fault Information, page 2-2. 

Related Topics

• Unknown AP Details, page 2-15

• Understanding Rogue AP Detection, page 9-10

• Displaying the Location of Unknown or Rogue Radios, page 10-18

• Changing Display Options for Unknown Radios, page 10-21

Displaying the Location of Unknown or Rogue 
Radios

Location Manager helps you see the approximate location of unknown or rogue 
radios in your network by using the received signal strength from all detecting 
APs to locate the unknown radio relative to the detecting APs. 

Location Manager can also estimate the distance between the detecting AP and 
the unknown radio. 

Procedure

Step 1 In the Location Manager window, click on the Unknown Radio List icon or select 
Rogue > Unknown Radio List. The Unknown Radio List window opens 
displaying a list of all unknown radios interfaces. 
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Note If you click on a floor, the Unknown Radios pulldown menu lists the 
unknown radios on the floor that you are currently viewing. You can click 
on a unknown radio from this pulldown menu.

Step 2 At the top of the Unknown Radio List window, select which devices you want to 
view:

• Rogue— APs that have not been identified as Friendly. By default, all 
unknown radios are classified as Rogue until you change them to Friendly.

• Friendly—APs that you know exists, for example, a neighboring network’s 
AP, but that you are not going to modify in any way.

The window refreshes to display the devices of the unknown radio type you 
selected. 

Step 3 Click on a device name. The Unknown Radio List window refreshes with data 
specific to that device.

The Reported By field shows the device(s) that detected the unknown radio:

• If the APs checkbox is selected, the Reported By field displays the APs that 
detected the selected unknown radio.

• If the Clients checkbox is selected, the Reported By list contains the AP the 
detecting client is associated to.

If the device you selected does not have a building name listed in the Building 
field, the Location Estimation field indicates the estimated location as unknown. 

Step 4 Click Change to Friendly (if you selected Rogue from the Unknown Radio Type 
pulldown) to change the status of the selected unknown radio from Rogue to 
Friendly.

If you selected Friendly from the Unknown Radio Type pulldown, you can click 
Change to Rogue to change the status of the selected unknown radio from 
Friendly to Rogue.
10-19
User Guide for the CiscoWorks Wireless LAN Solution Engine

78-16193-01



 

Chapter 10      Viewing Your WLAN Radio Environment with Location Manager
Displaying the Location of Unknown or Rogue Radios
Step 5 Click Display Location to view the approximate location of the unknown radio 
on the floor map.The possible location of the unknown radio shaded is in color 
where the darkest shade indicates the most probable location.

Note If the Estimated Location indicates “Unknown,” the Display Location 
button is greyed out. The location might be unknown because you didn’t 
specify the location of the reporting APs on the floor map before the APs 
detected the unknown radio. In this case, after specifying the location of 
the reporting APs on the Location Manager floor map, run Radio 
Monitoring again to get the estimated location (see Using Radio 
Monitoring to Collect RM Data, page 9-52). 

Because Location Manager does not know the transmit power of the unknown 
radio, you might need to change the display options as explained in Changing 
Display Options for Unknown Radios, page 10-21. 

Tip If the Unknown Radio List dialog box is covering the Location Manager 
window, you might need to close the dialog box to see the unknown radio 
displayed on the building map in Location Manager.

Step 6 To delete a rogue AP when you have determined that it no longer exists, you can 
remove it by clicking Delete. 

Related Topics

• Assigning Rogue AP Detection Network Settings, page 2-82

• Modifying AP Coverage Display Options, page 10-28

• Displaying Information About Rogue Access Points, page 10-17
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Changing Display Options for Unknown Radios
You can select different display options for the unknown radios to change the 
information that is displayed on the floor map. Changing display options can help 
you find the unknown radio by increasing the area in which you’re likely to find 
the unknown radio.

Procedure

Step 1 Click on a floor, and then select the unknown radio type who’s display options you 
want to modify. The pulldown menu contains MAC addresses of the unknown 
radio interfaces on the specific floor you are viewing.

Step 2 Click Options. The Unknown Radio Display options form appears. The default 
transmit power is 50mW and 100mW.

Step 3 Click on different transmit power options to see a different area on the floor map 
in which the unknown radio might be located. If you select all transmit powers, 
the floor map displays all possible areas that the selected unknown radio might be 
located. 

Step 4 Select whether to use the Exclusion Algorithm. By default, the Exclusion 
Algorithm is selected so that, in its calculations, Location Manager includes the 
APs in the general area that did not detect the unknown radio. If you deselect the 
Exclusion Algorithm option, only the APs that detected the unknown radio are 
used in the location calculation. 

Step 5 Click OK to save the display options and to view the unknown radio on the floor 
map. 

Note You might need to zoom out if you cannot see the possible location of the 
unknown radio in the Location Manager window. See Zooming In and 
Out, page 10-36.

Related Topics

• Changing Display Options for Unknown Radios, page 10-21
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Using the Assisted Site Survey Wizard
The Assisted Site Survey walks you through the process of determining the 
optimal radio transmit power and channel selection. It helps you select APs, run 
an AP radio scan job, perform a client walkabout, and generate radio parameters 
for the selected APs.

The Assisted Site Survey takes you through the following steps:

1. AP Selection—See Selecting the APs, page 10-22.

2. AP Radio Scan—See Performing AP Radio Scan, page 10-23.

3. Client Walkabout—See Performing a Client Walkabout, page 10-25.

4. Radio Parameter Generation—See Generating Radio Parameters, 
page 10-26.

Note Because the more devices included in an Assisted Site Survey Wizard session 
increases the time required for completion, it is recommended that you run a 
separate Assisted Site Survey Wizard session for each building or for each floor. 

Selecting the APs

Procedure

Step 1 From the Location Manager window, select Wizard > Assisted Site Survey. The 
Assisted Site Survey Wizard appears. 

Step 2 Select the APs you want to participate in the site survey:

• To select all APs in a building, click on the building name, then click Add.

• To select all APs on a floor, click on the floor name, then click Add.

• To select individual APs, click on the AP name, then click Add.

Step 3 To remove an AP that you previously selected, click on the AP name, then click 
Remove.

Step 4 Click Next to go to the next step, Filter By PHY.
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Step 5 Select the type of 802.11 radio, either 2.4 GHz or 5 GHz, that will participate in 
the assisted site survey. 

Note Only radios of the selected types take part in the assisted site survey. If a 
selected AP has no interfaces of the desired radio types, this is noted in 
the job run log. 

Step 6 Click Next to go to the next step (see Performing AP Radio Scan).

Performing AP Radio Scan
After you selected the APs to participate in the assisted site survey, the wizard 
checks to see if there is any existing radio scan data for the APs you selected. If 
there is no previous scan data, the wizard asks you to run a new radio scan setup. 
In addition, the following information is displayed in the table:

Field Description

Name Name of the AP

IP Address IP address of the AP

Radio Type The type of radio

Radio MAC The MAC address of the radio

Last Scan Time Time the most recent radio scan job 
started. If this field indicates None, you 
need to run a new radio scan.
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Procedure

Step 1 Select one of the following options:

• Start new radio scan setup—The wizard starts a new radio scan job. Select 
this option if there is no previous radio scan date for the selected APs. 

• Use previous radio scan data—The wizard uses the data collected from the 
most recent radio scan job. Use this option if all APs have a time stamp in the 
“Last Scan Time” field.

Note A running scan job temporarily degrades wireless LAN service, which 
might affect client associations. To minimize any disruption, run scan 
jobs during off-hours.

Step 2 If you select to start a new radio scan setup, you need to specify the AP’s 
maximum transmit power setting for the radio scan procedure. The default is 
100mW. See Understanding AP Radio Scans, page 9-7.

Step 3 To start the new radio scan, click Start. You’ll see informational messages appear 
in the text box and when the scan is complete, the form will display the following 
information:

Step 4 Click Next to go to the next step (see Performing a Client Walkabout).

Field Description

Name Name of the AP

IP Address IP address of the AP

Radio Type The type of radio

Radio MAC The MAC address of the radio

Last Scan Time Time the most recent radio scan job 
started
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Performing a Client Walkabout
Performing a client walkabout is an optional procedure in the Assisted Site Survey 
Wizard. If the APs you selected have data from a previous Client Walkabout 
session, this information is displayed in the wizard. For more information, see 
Understanding Client Walkabouts, page 9-9.

Procedure

Step 1 Select one of the following options:

• Start Client Walkabout Setup—The wizard walks you through the steps of 
setting up a client walkabout. See Guidelines for Running a Client 
Walkabout, page 9-49.

• Skip Client Walkabout—If the location data is accurate, you can skip the 
client walkabout and go directly to Generating Radio Parameters, page 10-26.

Step 2 If you select to start client walkabout Setup, you need to enter at least one client 
MAC address, and up to five addresses, that will move around during the 
walkabout.

Step 3 Select the AP power setting. You might choose to enter a lower power setting 
when, for example, the default power level might affect a neighboring network.

Step 4 Click Start to start the client walkabout. When the client walkabout is complete, 
click Stop and the following information is displayed:

Field Description

Name Name of the AP

IP Address IP address of the AP

Radio Type The type of radio

Radio MAC The MAC address of the radio

Total WA Data Accumulated data from previous 
walkabouts. 

New WA Data Data from the current walkabout 
session. 
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While you are running a client walkabout session, the data in the Total WA Data 
and New WA Data fields should increase. If these fields remain at zero, make sure 
you have set up the walkabout session correctly (see Guidelines for Running a 
Client Walkabout, page 9-49).

Step 5 Click Next to go to the next step (see Generating Radio Parameters).

Generating Radio Parameters
You need to set channel constraints and transmit power constraints for the APs 
you selected. The wizard can help you configure your APs by internally utilizing 
measurement data collected from a client walkabout and AP radio scanning. The 
wizard recommends optimal radio transmit power, channel selection, and beacon 
interval (optional), and then applies these configuration settings to the APs, if 
desired. For more information, see Creating a New Assisted Configuration Task, 
page 9-59.

Tip To get optimal channel settings, run the radio parameter generation on a per 
building basis. That is, include all APs in one building in a single radio parameter 
generation job.

Procedure

Step 1 Click on one of the Constraints options:

• All APs—Applies the constraints to all APs you selected to participate in the 
site survey

• Individual AP—Allows you to specify constraints for individual APs.

Step 2 Select the Channel Sets. Use ctrl-click to select more than one channel set. The 
radio parameter generation feature will give you a suggested channel within the 
channels you select. Click Presets to chose from a pre-selected set of channels.

Step 3 If you click Presets, the Select Channel Sets window appears. Click on a channel 
set, then click Select. The channels you selected appear in the Channel Sets field.
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Step 4 Enter a value in the Minimum and Maximum Transmit Power fields. You might 
choose to enter a lower power setting when, for example, the default power level 
might affect a neighboring network. You must enter a numerical value greater than 
zero and less than 100.

Step 5 Under Goal, enter a numerical value for the expected maximum number of clients 
per AP, and a numerical value for the expected average number of clients per AP. 
You must enter a numerical value greater than zero and less than 500.

Step 6 Select whether to enable black hole mitigation. If you select this option, Radio 
Manager recommends a beacon interval, which is slightly altered from what the 
AP is configured to, for the APs. If you do not select the Black Hole Mitigation 
option, Radio Manager will not recommend a beacon interval.

Step 7 Click Start to start the configuration parameter calculation. A status bar appears 
indicating the progress of the parameter generation. When the radio parameter 
generation is complete, a message appears at the bottom of the screen.

Step 8 Click Next to view the calculation results and apply the configuration to the APs.

Step 9 After reviewing the calculation results, click Preview to preview the changes in 
the Location Manager window or click Apply Configuration to apply the 
configuration changes to the APs. 

Note The configuration on your devices will not change unless you click Apply 
Configuration.

The Apply Status column in the table indicates if the configuration was 
successfully applied. 

Related Topics

• Understanding AP Radio Scans, page 9-7

• Understanding Client Walkabouts, page 9-9
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Modifying AP Coverage Display Options
You can modify which APs’ coverage to display and how to display the coverage 
in the floor map. The colors used to represent an AP’s coverage area let you see 
what areas are covered by which data rate and where you might have holes in your 
coverage. In areas of overlapping coverage, the highest data rate is displayed. 

Tip If you do not perform a client walkabout, you must provide the dimensions of the 
floor (see Adding Building Information, page 10-6). It is also recommended that 
you import a floor image that includes the distances between APs (see Importing 
an Image of the Building or Floor, page 10-8).

Note You cannot display the coverage area of a scanning-only AP. For more 
information about Scanning APs, see Understanding Scanning-Only AP Mode, 
page 9-16.

Procedure

Step 1 Select which radio’s coverage you want to display:

• To display the coverage of 2.4 GHz APs, select Coverage > Coverage 
Display > Show 2.4 GHz coverage or select 2.4 GHz from the Coverage 
Display pulldown menu. 

• To display the coverage of 5.0 GHz APs, select Coverage > Coverage 
Display > Show GHz coverage or select 5 GHz from the Coverage Display 
pulldown menu.

• If you don’t want to display any coverage areas, select Coverage > Coverage 
Display > None or select None from the Coverage Display pulldown menu.

Note If the radio band you want is greyed out, see Radio Bands Available in 
Coverage Menus, page 10-31 for more information. 

Step 2 Next to the Coverage Display pulldown, click Options or select Coverage > 
Coverage Display Options. The Coverage Display Options form appears. 
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Step 3 Chose one of the display options (see Table 10-5 for information about how the 
coverage display options compare):

• Display Selected Data Rates 

Select a data rate to see that coverage area displayed on the floor map. If you 
have a hole in your coverage, a white spot appears on the map. You can also 
click one of the buttons under Quick Selection Choices to view the data rates 
for a particular radio band.

• Display Received Signal Strength

Select Display Received Signal Strength to view how strong a signal is for a 
particular area. The darker the color, the stronger the signal strength.

Select whether you want to display overlaps. If you select to not display 
overlaps, the color of the strongest signal is displayed. If you have a hole in 
your coverage, a white spot appears on the map. 

When you display overlaps, you get an additional pulldown menu that lets 
you control the display of the each AP’s signal strength. For example, if you 
select 80% (-55dBm), the floor map displays the area in which the AP signal 
strength is at least 80% (-55dBm).

Step 4 To see the received signal strength in any area on the floor, select Coverage > 
Show RSS from Selected AP and click on an AP. A grid appears on the floor map, 
and the selected AP’s received signal strength appears in each square of the grid.

Step 5 Change the Calculation Grid Size by clicking on a value in the pulldown menu. 
Changing the size to a larger value, for example 8 ft., gives you a more general 
coverage that is not as granular as if you had picked a smaller value, for example 
2 ft. The smaller the value you choose, the more time it will take for the floor map 
to refresh because it will display a more specific coverage area.

Step 6 Click Apply to see the changes on the floor map while keeping the Coverage 
Display Options form open.

Step 7 Click OK to close the form. The floor map refreshes to show the display options 
you selected.

Step 8 To turn Coverage display off for a specific AP, right click on the AP and select 
Coverage Display Off. To turn the coverage display back on, right click on the 
AP and select Coverage Display On. The Coverage Display pulldown menu now 
says Selective.
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Table 10-5 shows you the relationship between the coverage display options and 
the features available with each option.

Related Topics

• Radio Bands Available in Coverage Menus, page 10-31

Table 10-5 Coverage Display Options

Coverage 
Display Option

Can I 
selectively turn 
display on/off 
per AP?1

Can I control the 
display of the 
signal strength 
based on a 
percentage of 
signal strength?2 

Given a location, 
can I see which 
AP gives the 
strongest signal 
and what its 
signal strength 
is?3

What color 
key is used 
with this 
option

Is gradient 
color used or 
one color?

Data Rate Yes No No Data Rate 
Color Key4 

One color

Signal Strength 
with Overlap

Yes Yes No Channel 
Color Key5

Gradient 
color. The 
darker the 
color, the 
stronger the 
signal 
strength.

Signal Strength 
without 
Overlap

No No Yes Channel 
Color Key6

Gradient 
color. The 
darker the 
color, the 
stronger the 
signal 
strength.

1. See Step 8 in Modifying AP Coverage Display Options, page 10-28. 

2. See Step 3 in Modifying AP Coverage Display Options, page 10-28. 

3. See Step 3 in Modifying AP Coverage Display Options, page 10-28. 

4. See Using the Location Manager Coverage By Data Rate Color Key, page 10-36

5. See Using Location Manager Channel Color Key, page 10-35

6. See Using Location Manager Channel Color Key, page 10-35
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Radio Bands Available in Coverage Menus
There is a direct relationship between the radio band you select in the View > 
Radio Band menu or the Radio Band pulldown menu and what radio band options 
you see in the Coverage Display menu. For example, if you select View > Radio 
Band > Show 2.4 GHz or if you select 2.4 GHz in the Radio Band pulldown 
menu, you get the following options in the Coverage Display menu:

• None

• 2.4 GHz

5 GHz is greyed out because you have 2.4 GHz selected in the Radio Band 
pulldown menu. 

If you select View > Radio Band > Show All or if you select All in the Radio 
Band pulldown menu, you get the following options in the Coverage Display 
menu:

• None

• 2.4 GHz

• 5 GHz

See Table 10-4 for more information about the relationship between these 
options. 
10-31
User Guide for the CiscoWorks Wireless LAN Solution Engine

78-16193-01



 

Chapter 10      Viewing Your WLAN Radio Environment with Location Manager
Moving Devices on Location Manager Image Map
Moving Devices on Location Manager Image Map
If you already placed a device on your Location Manager image map and need to 
change its location, you can move it to a new location by following these steps:

Procedure

Step 1 Click on the Enable Edit Location Mode icon or select Edit > Enable Edit 
Location.

Step 2 Click on the device you want to move. 

Step 3 You can either drag the device to a new location on the map, or you can select Edit 
> Cut from the menu or by right-clicking on the device. 

Step 4 If you select Edit > Cut, click on the new location for the device (or to move it to 
a different floor but at the same location, click on different floor), then select Edit 
> Paste from the menu or by right-clicking on the device. 

The device appears in the new location on the image map.

Related Topics

• Adding Devices to the Floor, page 10-12

Locating Devices in Location Manager
You can search for devices in the Location Manager window. 

Procedure

Step 1 From the Location Manager window, select Tools > Find AP. The Find AP 
window appears.

Step 2 From the pulldown menu, select whether to search by device name, IP Address, 
or MAC Address.

Step 3 Select either Containing or Exactly Matching.

Step 4 Enter the text string to search for in the text field.
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Step 5 Click Search. The Find AP form displays the device or devices that match your 
search criteria. 

Step 6 Click on the name of the device you want to locate, then click Locate AP at the 
bottom of the form. 

The AP you selected appears in the center of the floor map.

You can right-click on any AP and select Device Details. A new browser opens 
displaying the AP Summary Report for the AP you selected. 

Related Topics

• Adding Devices to the Floor, page 10-12

• Understanding Location Manager Device Icons, page 10-12

Obtaining Server Information
From Location Manager, you can:

• Verify Server Status 

To verify the status of your server, select Server > Status. The Server Status 
window appears displaying the IP address of the server and the time the server 
was started. The Server status form also displays the following information:

– UserID—Username of the person who launched Location Manager

– Client Address—Address of the client machine that launched Location 
Manager

– Login Time—Time that the user launched Location Manager

• View Server Messages 

To view server messages after you configure your floor plan with APs, select 
Server > Message. The Message Server Message Log window appears 
displaying messages about your server. This information might be helpful 
when troubleshooting issues, for example, if the AP display coverage isn’t 
correct. 
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Using Location Manager Tools
Location Manager includes several tools that you can use:

• Measuring Tool (See Using Location Manager Measuring Tool, page 10-34.)

• Modify Contrast Tool (See Using Location Manager Contrast Sliding Tool, 
page 10-35.)

• Channel Color Key (See Using Location Manager Channel Color Key, 
page 10-35.) 

• Unknown Radio Location Color Key (See Using Location Manager Radio 
Location Color Key, page 10-35.) 

• Coverage by Data Rate Color Key (See Using the Location Manager 
Coverage By Data Rate Color Key, page 10-36.)

Using Location Manager Measuring Tool
The Location Manager Distance Measure Tools allow you to measure the distance 
(in either feet or meters) between APs and perform other measure functions.

Note The Distance Measure Tool icons appear only when you have added floor 
information to your building(s). (See Adding Floor Information, page 10-11.)

Procedure

Step 1 In the Location Manager window, click on either Distance Measure Tool icon. The 
icon with ft indicates feet, and the icon with m indicates meters. 

The icon you selected is shaded grey, and the bottom of the Location Manager 
displays the following message:

Distance Measure Tool: On

Step 2 Click and drag your mouse anywhere on the building map to start your 
measurement from. 
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Step 3 Drag your mouse to the desired location. You’ll see the measurement display as 
you’re dragging the mouse.

Step 4 To end the measurement, lift your finger from the mouse.

Note If the Distance Measure Tool is enabled, the Edit Location tool is disabled 
automatically. 

Using Location Manager Contrast Sliding Tool
You can modify the background contrast in the image of your floor map by using 
the Location Manager Contrast sliding tool. 

• To make the background image lighter, move the sliding bar to the left.

• To make the background image darker, move the sliding bar to the right.

Using Location Manager Channel Color Key
When you select View > Radio Channel or when you view coverage by received 
signal strength, the color of the channel label and the coverage display indicate 
the channel the AP is transmitting on. To verify which color corresponds with 
which channel, click on the Channel Color Key icon or select Help > Channel 
Color Key. The Channel Color Key legend appears showing you which color 
represents which channel.

Using Location Manager Radio Location Color Key
The Location Manager Unknown Radio Location Color Key displays what the 
Unknown Radio Location color values mean. The color gradations correspond to 
the percentage of probability that the unknown radio exists in the specified region. 
Click on the Unknown Radio Location Color Key icon or select Help > Unknown 
Radio Location Color Key to view this information.
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Using the Location Manager Coverage By Data Rate Color Key
The Location Manager Coverage By Data Rate Color Key shows you what colors 
correspond to which data rates. A check mark next to a color indicates that you 
specified to include this data rate in the Coverage Display. For example, if you 
selected 11 Mbps and 5.5 Mbps in the Options menu, which is next to the 
Coverage Display pulldown menu, these data rates are shown with a check mark 
(in the Data Rate Color Key window) and are displayed in Coverage Display by 
Data Rate. Click on the Coverage By Data Rate Color Key icon or select Help > 
Coverage By Data Rate Color Key to view this information. 

Zooming In and Out
When using Location Manager, you might need to zoom in and out to see APs 
displayed on the floor map. You can zoom in and out by selecting a radio button 
to the left of your floor image. There are 7 radio buttons that correspond to the 
following zoom levels:

• 32 pixels per foot

• 16 pixels per foot

• 8 pixels per foot

• 4 pixels per foot

• 3 pixels per foot

• 2 pixels per foot

• 1 pixel per foot

To return to the normal view, select the fourth radio button (4 pixels per foot) in 
the list.
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