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Replacing or Converting a Cisco Unity 5.x Server, 
or Upgrading to Windows 2003

This chapter contains the following sections:

• Replacing a Cisco Unity 5.x Server Without Failover, or Upgrading to Windows 2003, page 10-1

• Replacing Only the Primary 5.x Server, or Upgrading to Windows 2003, page 10-6

• Replacing Only the Secondary 5.x Server, or Upgrading to Windows 2003, page 10-14

• Replacing Both 5.x Failover Servers, or Upgrading to Windows 2003, page 10-20

• About Uninstalling Failover on Cisco Unity 5.x Servers, page 10-28

• Converting a Secondary Server to a 60-Day Cisco Unity 5.x Server Without a Primary Server, 
page 10-29

• Converting a Secondary Server to a Permanent Regular Cisco Unity 5.x Server Without Failover, 
page 10-30

• Converting a Primary Server to a Permanent Regular Cisco Unity 5.x Server Without Failover, 
page 10-35

Replacing a Cisco Unity 5.x Server Without Failover, or 
Upgrading to Windows 2003

The procedure in this section requires that you use the Cisco Unity Disaster Recovery tools (DiRT).

Caution Upgrading from Windows 2000 Server to Windows Server 2003 on an existing Cisco Unity server is 
supported only when you follow the procedures in this section. If you use Microsoft processes for 
upgrading Windows without reinstalling all software, default Windows Server 2003 configuration 
settings are different than settings for a fresh Windows Server 2003 installation, and Cisco Unity will 
not function properly. 

Caution You must install the exact version of Cisco Unity on the replacement server as the version that you back 
up on the existing server. The Disaster Recovery Restore tool can restore data only to the exact version 
of Cisco Unity that was backed up.
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Caution Do the procedure only if the Cisco Unity server is the only server in the domain or if it is a member 
server. If the Cisco Unity server is the domain controller and it is not the only server in the domain, refer 
to Microsoft documentation for information on installing Active Directory on another server in the 
domain, transferring roles from the Cisco Unity server to the new domain controller, and other 
applicable tasks before you replace the Cisco Unity server.

To Replace a Cisco Unity Server Without Failover, or Upgrade to Windows 2003

Step 1 Confirm that you have all of the disks necessary to reinstall the version of Cisco Unity currently installed 
on the Cisco Unity server. When you use DiRT to back up and restore Cisco Unity data, you must restore 
to the same version of Cisco Unity that you backed up. 

Step 2 If you are replacing the server, get updated license files that reference the MAC address of the NIC in 
the new server. (Cisco Unity 5.x licenses are associated with the MAC address on the network interface 
card (NIC).) 

For information on getting updated license files, refer to the white paper Licensing for Cisco Unity (All 
Versions) at http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_white_papers_list.html.

Step 3 Download the latest versions of the following applications:

• The Cisco Unity Directory Walker (DbWalker) utility at 
http://ciscounitytools.com/App_DirectoryWalker4.htm. 

• The Cisco Unity Disaster Recovery Backup tool and Disaster Recovery Restore tool, available at 
http://ciscounitytools.com/App_DisasterRecoveryTools.htm.

Step 4 On the Cisco Unity server, install the versions of DbWalker and the Disaster Recovery Backup tool that 
you downloaded in Step 3.

Step 5 Run DbWalker, and correct all errors that the utility finds. Refer to DbWalker Help for detailed 
instructions on running the utility and on correcting errors in the database. (The Help file, 
DbWalker.htm, is in the same directory as DbWalker.exe.)

Step 6 Back up Cisco Unity data by using the Disaster Recovery Backup tool. Refer to DiRT Help for detailed 
instructions. (The Help file, UnityDisasterRecovery.htm, is in the same directory as 
UnityDisasterRecoveryBackup.exe.)

Caution Follow Help carefully. DiRT includes a variety of options that you must understand to use the 
tools successfully. In addition, the account you are logged on as when you back up 
Cisco Unity data must have sufficient permissions or the backup will fail.

Step 7 If you are replacing the server, if the existing Cisco Unity server is integrated with a circuit-switched 
phone system through voice cards, and if you want to move the voice cards to the replacement server, 
shut down the existing server.

If the replacement server will be integrated with Cisco Unified CM or with a circuit-switched phone 
system through PIMG/TIMG units, or if you are installing new voice cards, the existing Cisco Unity 
server can continue taking calls until Step 10.

Step 8 If you are replacing the server, remove voice cards from the existing server, if applicable.

Step 9 If you are replacing the server, install hardware, if applicable, and software on the replacement server 
by following the instructions in the applicable Cisco Unity installation guide for your configuration at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides_list.html.
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If you are upgrading Windows, reinstall all software on the server by following the instructions in the 
applicable Cisco Unity installation guide for your configuration at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides_list.html.

Caution You must install the same version of Cisco Unity that was installed when you backed up 
Cisco Unity data earlier in this procedure. Otherwise, the Disaster Recovery Restore tool 
cannot restore the data that you backed up.

Note the following: 

• When you configure Windows, if there is more than one Cisco Unity server in the Active Directory 
forest, give each Cisco Unity server a name that is unique in the first 14 characters, or Cisco Unity 
will have problems communicating with the Active Directory accounts created by Cisco Unity. For 
example, the following names would cause communication problems: CiscoUnitySrvr1 and 
CiscoUnitySrvr2.

• If you are not replacing the phone system, you can skip the task on setting up or programming the 
phone system. 

Step 10 If you are replacing the server, disconnect the old Cisco Unity server from the network, and connect the 
replacement server to the network.

Step 11 Install the version of the Disaster Recovery Restore tool that you downloaded in Step 3.

Step 12 Restore Cisco Unity data by using the Disaster Recovery Restore tool and the backup that you made 
earlier. Refer to DiRT Help for detailed instructions. (The Help file, UnityDisasterRecovery.htm, is in 
the same directory as UnityDisasterRecoveryRestore.exe.)

Caution Follow Help carefully. DiRT includes a variety of options that you must understand to use the 
tools successfully.

Step 13 Reapply any non-Cisco Unity custom registry settings. (DiRT backs up and restores Cisco Unity registry 
settings.)

Enabling Subscribers to Use the Phone for Recording and Playback
IBM Lotus Notes with IBM Lotus Domino Unified Communications (DUC) for Cisco offers a 
VCR-style recorder/player in the message form. Subscribers can customize it to use a phone or a 
computer microphone and speakers as the recording and playback device. However, if you rename a 
Cisco Unity server while you are reinstalling Windows, a phone does not work as a recording or 
playback device unless you manually update the Cisco Unity server name specified in each subscriber 
mail file. 

To correct the problem, you can either run an agent on a Domino server to change each subscriber mail 
file and push the changed mail files out to subscriber workstations, or you can provide subscribers with 
an agent that the subscriber runs on the workstation to change the server name in the mail file. 

Note You do not need to change anything for subscribers who use a computer microphone and speakers as 
their recording and playback devices. 
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The agents are located on the Cisco Unity server. 

• The CommServer\Utilities\Domino\Agents\ClientUpdateUCProfileforTrap directory contains the 
following files: 

– ClUpUn.nsf—The agent that subscribers run on their workstations to change the Cisco Unity 
server name in their mail file. Note that the agent must be modified with the Cisco Unity server 
name before it is run. 

– Client Update Unity Profile Agent.txt—A text file that contains the LotusScript in ClUpUn.nsf. 
Note that the script must be modified with the Cisco Unity server name before it is run. 

– Readme.txt—A text file with instructions on using the agent. 

• The CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory contains the 
following files: 

– UpdateUn.nsf—The agent that is run on a Domino server to change the Cisco Unity server name 
in each subscriber mail file. Note that the agent must be modified with the Cisco Unity server 
name and Domino server name before it is run. 

– Update Unity Profile Agent.txt—A text file that contains the LotusScript in UpdateUn.nsf. Note 
that the script must be modified with the Cisco Unity server name and Domino server name 
before it is run. 

– AgentLog.nsf—A Notes database that stores output from the agent that is run on the Domino 
server. 

– Readme.txt—A text file with instructions on using the agent. 

See the following procedures for details on modifying and running the agents: 

• To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server, 
page 10-4

• To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber 
Workstation, page 10-5

• To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation, page 10-6

The following procedure is specific to Domino R6.5 and assumes that you have Full Access 
Administration rights or have been added to the access control list (ACL) of each subscriber mail file 
with sufficient rights. Change the steps as necessary if you are running another version of Domino. 

The procedure describes using Update Unity Profile Agent.txt, but if you are familiar with agents, you 
can modify UpdateUn.nsf in Domino Designer by using the steps as a guideline. 

To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server 

Step 1 Copy the Update Unity Profile Agent.txt located in the 
CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory on the Cisco Unity server to 
the Domino server where you will run Domino Designer. 

Step 2 Copy AgentLog.nsf to your Domino data directory. 

Step 3 Open Domino Designer, click Open an Existing Database, and open Names.nsf. 

Step 4 In the Design pane for names.nsf (the pane on the left, underneath Recent Databases), click Shared 
Code > Agents. 

Step 5 In the right pane, click the New Agent button. The Agent Properties box appears. 

Step 6 On the Basics tab, enter a name for the agent in the Name field. 

Step 7 In the Runtime section, for the Target, click None. 
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Step 8 Close the Agent Properties box. 

Step 9 In the Programmer’s pane on the right, click LotusScript from the Run menu. 

Step 10 On the Objects tab, click Declarations. 

Step 11 Open the file Update Unity Profile Agent.txt in Notepad, and copy the text from the beginning of the file 
to the line right above the line that contains “Sub Initialize.” (Do not copy the “Sub Initialize” line.) 

Step 12 Paste the text in the Script area of the Programmer’s pane in Domino Designer. 

Step 13 Modify the agent text in the Script area of the Programmer’s pane as follows: 

• Replace the const values AGENTLOG_SERVER and DUC_SERVER with your Domino server 
name. 

• Replace the const value NEW_UNITY_SERVER_NAME with the new Cisco Unity server name. 

Be sure that the server names are encapsulated in double quotes. 

Step 14 In the Objects tab, click Initialize. The lines “Sub Initialize” and “End Sub” with a blank line between 
them are displayed in the Script area of the Programmer’s pane. 

Step 15 In the file Update Unity Profile Agent.txt in Notepad, copy the text between (but not including) the lines 
“Sub Initialize” and “End Sub.” 

Step 16 Paste the text in the Script area of the Programmer’s pane on the blank line between the lines 
“Sub Initialize” and “End Sub.” 

Step 17 Exit Notepad. 

Step 18 Close and save the agent, and exit Domino Designer. 

Step 19 Open the Domino Administrator, click File > Database > Open, and open names.nsf. 

Step 20 Click Actions > <Your Agent Name> to run the agent. 

Step 21 Repeat Step 1 through Step 20 on every Domino server containing subscriber mail files that you want to 
change. 

Note Subscribers will need to exit and reopen Notes on their workstations for the change to take effect. 

The procedure below is specific to Notes R6.5. Modify the steps as needed for other Notes versions. If 
you will be providing these instructions to subscribers, you will also need to provide them with the name 
of the Cisco Unity server. Consider customizing the instructions below with the name of your 
Cisco Unity server. 

Note that the file Client Update Unity Profile Agent.txt contains only one line of script, and it is given 
in the procedure. 

To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber Workstation 

Step 1 On a subscriber workstation, start Notes and open the subscriber mail file. 

Step 2 Click Create > Agent. The Agent Properties box appears. 

Step 3 On the Basics tab, enter a name for the agent in the Name field. 

Step 4 In the Runtime section, for the Target, click None. 

Step 5 Close the Agent Properties box. 
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Step 6 In the Programmer’s pane on the right, click Formula from the Run menu. 

Step 7 Copy and paste the following text to the Script area of the Programmer’s pane: 

@SetProfileField("ucprofile";"VoiceServerList";"<NewUnityServerName>"); 

Step 8 Replace <NewUnityServerName> with your Cisco Unity server name. 

Step 9 Verify that the server name is enclosed in double quotes, that each argument is separated with a 
semicolon, and that the entire formula ends with a semicolon. 

Step 10 Close and save the Agent. 

To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation 

Step 1 On a subscriber workstation, start Notes and open the subscriber mail file. 

Step 2 Click Action > <Agent Name>, where <Agent Name> is the name of the applicable agent.

Step 3 Exit and then re-open Notes. 

Replacing Only the Primary 5.x Server, or Upgrading to 
Windows 2003

Revised November 14, 2008
This section describes how to replace the primary Cisco Unity server or upgrade from Windows 2000 to 
Windows 2003 on that server. The replacement or upgraded primary server keeps the same IP address 
and server name as the original server.

Caution Upgrading from Windows 2000 Server to Windows Server 2003 on an existing Cisco Unity primary 
server is supported only when you follow the procedures in this section. If you use Microsoft processes 
for upgrading Windows without reinstalling all software, default Windows Server 2003 configuration 
settings are different than settings for a fresh Windows Server 2003 installation, and Cisco Unity will 
not function properly. 

Caution Changes made to the Cisco Unity system (for example, recording new greetings or making subscriber 
changes) while the secondary server is active and the primary server is off line are not replicated to the 
primary server.

Caution An interruption of the voice messaging service occurs in the final procedure. During this time, callers 
and subscribers will not be able to record or listen to voice messages.

The following items are required to replace the primary server:

• The latest versions of the following applications:
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– The Cisco Unity Directory Walker (DbWalker) utility, available at 
http://ciscounitytools.com/App_DirectoryWalker4.htm.

– The Cisco Unity Disaster Recovery tools (DiRT), available at 
http://ciscounitytools.com/App_DisasterRecoveryTools.htm.

• Software for reinstalling the primary server (must be the same versions installed on the secondary 
server).

• The applicable Cisco Unity installation guide for your configuration, available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides_list.html.

• If you are replacing the server, updated license files that reference the MAC address of the network 
interface card (NIC) in the replacement server. Licenses are associated with the MAC address on the 
NIC. For information on getting updated license files, refer to the white paper Licensing for Cisco 
Unity (All Versions) at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_white_papers_list.html.

Do the following 10 procedures in the order listed. Do the applicable procedure for your version.

To Manually Initiate Failover to the Secondary Server and Disable Automatic Failback

Step 1 If the primary server is not active, skip to Step 4.

If the primary server is active, on the primary server, on the Windows Start menu, click Programs > 
Cisco Unity > Failover Monitor.

Step 2 Click Failover.

Step 3 Click OK to confirm that you want to fail over to the secondary server. The primary server becomes 
inactive, and the secondary server becomes active.

Step 4 On the secondary server, on the Windows Start menu, click Programs > Cisco Unity > Failover 
Monitor.

Step 5 Click Configure.

Step 6 In the Failback Type field of the Failover Configuration dialog box, click Manual.

Step 7 Click OK to close the Failover Configuration dialog box.

To Stop File Replication on the Secondary and Primary Servers

Step 1 On the secondary server, on the Windows Start menu, click Programs > Administrative Tools > 
Services.

Step 2 In the right pane, double-click AvCsNodeMgr.

Step 3 On the General tab, click Stop.

Step 4 In the Startup Type list, click Disabled.

Step 5 Click OK.

Step 6 Close the Services window.
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Caution Because the Node Manager service is disabled, file replication stops. Replication is re-enabled 
when normal failover operation resumes.

Step 7 On the primary server, on the Windows Start menu, click Programs > Administrative Tools > Services.

Step 8 In the right pane, double-click AvCsNodeMgr.

Step 9 On the General tab, click Stop.

Step 10 In the Startup Type list, click Disabled.

Step 11 Click OK.

Step 12 Close the Services window.

To Stop SQL Replication on the Primary Server

Step 1 On the primary server, on the Windows Start menu, click Programs > Microsoft SQL Server > 
Enterprise Manager.

Step 2 In the left pane of the Console Root window, browse to the Replication node for the primary server. 
Typically, the node is three levels under the Microsoft SQL Servers node.

Step 3 Right-click the Replication node, and click Disable Publishing. The Disable Publishing and 
Distribution wizard appears.

Step 4 On the Welcome page, click Next.

Step 5 On the Disable Publishing page, click Yes, then click Next.

Step 6 On the Confirm Dropping of Publications page, click Next.

Step 7 On the Completing page, click Finish.

Step 8 When the process is completed, click OK.

Step 9 Close the Console Root window.

Step 10 Exit Enterprise Manager.

To Check the Consistency of the Cisco Unity Database on the Secondary Server

Step 1 On the secondary server, install the latest version of DbWalker, if it is not already installed.

Step 2 Run DbWalker, and correct all errors that the utility finds. Refer to DbWalker Help for detailed 
instructions on running the utility and on correcting errors in the database. (The Help file, 
DbWalker.htm, is in the same directory as DbWalker.exe.)

To Back Up Cisco Unity Data on the Secondary Server to a Network Storage Location

Step 1 On the secondary server, install the latest versions of DiRT, if the tools are not already installed.
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Step 2 Back up Cisco Unity data by using the Disaster Recovery Backup tool. Refer to DiRT Help for detailed 
instructions. (The Help file, UnityDisasterRecovery.htm, is in the same directory as 
UnityDisasterRecoveryBackup.exe.)

Caution Follow Help carefully. DiRT includes a variety of options that you must understand to use the 
tools successfully. In addition, the account you are logged on as when you back up 
Cisco Unity data must have sufficient permissions or the backup will fail.

Caution Do not back up the primary server unless the secondary server is unavailable. If you restore 
from a backup of the primary server, you must also perform an additional procedure for 
Cisco Unity failover to function correctly. For more information, see “Working With Systems 
Configured For Failover” in DiRT Help.

Step 3 Save the data to a network storage location.

To Remove the Primary Server from the Environment

Step 1 On the primary server, log on to Windows as a Cisco Unity administrator.

Step 2 Right-click the Cisco Unity icon in the status area of the taskbar.

(If the Cisco Unity icon is not in the taskbar, browse to the CommServer directory and double-click 
AvCsTrayStatus.exe.)

Step 3 Click Stop Cisco Unity. 

Step 4 Click OK to confirm that you want to stop the Cisco Unity software. Cisco Unity stops running when 
all calls are finished, and an “X” appears in the Cisco Unity icon.

Step 5 Right-click the SQL Server icon in the status area of the taskbar.

Step 6 Click MSSQLServer - Stop.

Step 7 Using the System control panel, make the server a workgroup server.

Step 8 Disconnect the network cable from the server. 

To Install the Replacement Primary Server, or Upgrade to Windows 2003

Step 1 If you are replacing the server, follow the instructions in the applicable Cisco Unity installation guide 
for your configuration to install the replacement primary server. If you are upgrading from Windows 
2000 to Windows 2003, reinstall all software on the server. Refer to Part 1 in the “Overview of 
Mandatory Tasks for Installing Cisco Unity” chapter. Note that the same version of Cisco Unity must be 
installed on both servers.
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To Restore Cisco Unity Data on the Replacement or Upgraded Primary Server from the Network Storage Location

Step 1 On the replacement or upgraded primary server, install the latest versions of DiRT, if the tools are not 
already installed.

Step 2 Restore Cisco Unity data by using the Disaster Recovery Restore tool and the backup that you made 
earlier. Refer to DiRT Help for detailed instructions. (The Help file, UnityDisasterRecovery.htm, is in 
the same directory as UnityDisasterRecoveryRestore.exe.)

Caution Follow Help carefully. DiRT includes a variety of options that you must understand to use the 
tools successfully.

Step 3 In the HKEY_LOCAL_MACHINE\SOFTWARE hive of the registry, confirm that the following registry 
settings match the settings on the secondary server:

• Active Voice\Conversations\1.0\Exclude All Receipts

• Active Voice\Conversations\1.0\Exclude Return Receipts

• Active Voice\SystemParameters\1.0\EnabledAlternateGreetingNotice

• Active Voice\MALEx\1.0\MinSearchFolderLifeHours

• Active Voice\MALEx\1.0\DisableSearchFolderUse

Step 4 Reapply any non-Cisco Unity custom registry settings. (DiRT backs up and restores Cisco Unity registry 
settings.)

To Configure Failover on the Primary Server

Step 1 In Windows Explorer, browse to the CommServer directory.

Step 2 Double-click FailoverConfig.exe to start the Configure Cisco Unity Failover wizard.

Step 3 When the prompt that lists the requirements for the wizard appears, confirm that the requirements have 
been met and click OK.

Step 4 On the Welcome page, click Next.

Step 5 On the Specify Server Role page, click Primary Server, and click Next.

Step 6 On the Enter the Name of Your Server page, click Browse, select the name of the secondary server, and 
click OK. The IP address for the secondary server is filled in automatically.

Step 7 Click Next.

Step 8 On the Enter Failover Account Information page, click Browse, and double-click the name of the 
directory and message store services account. This is the account that the failover service will log on as.

The account you select must have the right to act as part of the operating system and to log on as a 
service, and must be a member of the Local Administrators group.

Caution You must specify the same account on both the primary and secondary servers.

Step 9 In the Password field, enter the password for the account that the failover service will log on as, and click 
Next.
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Step 10 On the Begin Configuring Your Server page, click Configure. The wizard verifies settings and 
configures failover on the primary server.

If the wizard does not finish the configuration successfully, an error message explains why the wizard 
failed. Exit the wizard, correct the problem, and click Configure again.

Step 11 On the Completing page, click Finish.

To Configure Failover on the Secondary Server

Step 1 On the Windows taskbar, double-click the system clock. The Date/Time Properties dialog box appears.

Step 2 Set the time to the same hour and minute as shown on the primary server, and click OK.

Step 3 In Windows Explorer, browse to the CommServer directory.

Step 4 Double-click FailoverConfig.exe to start the Configure Cisco Unity Failover wizard.

Step 5 When the prompt that lists the requirements for the wizard appears, confirm that the requirements have 
been met and click OK.

Step 6 On the Welcome page, click Next.

Step 7 On the Specify Server Role page, click Secondary Server, and click Next.

Step 8 On the Enter the Name of Your Server page, click Browse, select the name of the primary server, and 
click OK. The IP address for the primary server is filled in automatically.

Step 9 Click Next.

Step 10 On the Enter Failover Account Information page, click Browse, and double-click the name of the 
directory and message store services account. This is the account that the failover service will log on as.

The account you select must have the right to act as part of the operating system and to log on as a 
service, and must be a member of the Local Administrators group.

Caution You must specify the same account on both the primary and secondary servers.

Step 11 In the Password field, enter the password for the account that the failover service will log on as, and click 
Next.

Step 12 On the Begin Configuring Your Server page, click Configure. The wizard verifies settings and 
configures failover on the secondary server.

If the wizard does not finish the configuration successfully, an error message explains why the wizard 
failed. Exit the wizard, correct the problem, and click Configure again.

Step 13 On the Completing page, click Finish.

Enabling Subscribers to Use the Phone for Recording and Playback
IBM Lotus Notes with IBM Lotus Domino Unified Communications (DUC) for Cisco offers a 
VCR-style recorder/player in the message form. Subscribers can customize it to use a phone or a 
computer microphone and speakers as the recording and playback device. However, if you rename a 
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Cisco Unity server while you are reinstalling Windows, a phone does not work as a recording or 
playback device unless you manually update the Cisco Unity server name specified in each subscriber 
mail file. 

To correct the problem, you can either run an agent on a Domino server to change each subscriber mail 
file and push the changed mail files out to subscriber workstations, or you can provide subscribers with 
an agent that the subscriber runs on the workstation to change the server name in the mail file. 

Note You do not need to change anything for subscribers who use a computer microphone and speakers as 
their recording and playback devices. 

The agents are located on the Cisco Unity server. 

• The CommServer\Utilities\Domino\Agents\ClientUpdateUCProfileforTrap directory contains the 
following files: 

– ClUpUn.nsf—The agent that subscribers run on their workstations to change the Cisco Unity 
server name in their mail file. Note that the agent must be modified with the Cisco Unity server 
name before it is run. 

– Client Update Unity Profile Agent.txt—A text file that contains the LotusScript in ClUpUn.nsf. 
Note that the script must be modified with the Cisco Unity server name before it is run. 

– Readme.txt—A text file with instructions on using the agent. 

• The CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory contains the 
following files: 

– UpdateUn.nsf—The agent that is run on a Domino server to change the Cisco Unity server name 
in each subscriber mail file. Note that the agent must be modified with the Cisco Unity server 
name and Domino server name before it is run. 

– Update Unity Profile Agent.txt—A text file that contains the LotusScript in UpdateUn.nsf. Note 
that the script must be modified with the Cisco Unity server name and Domino server name 
before it is run. 

– AgentLog.nsf—A Notes database that stores output from the agent that is run on the Domino 
server. 

– Readme.txt—A text file with instructions on using the agent. 

See the following procedures for details on modifying and running the agents: 

• To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server, 
page 10-13

• To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber 
Workstation, page 10-14

• To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation, page 10-14

The following procedure is specific to Domino R6.5 and assumes that you have Full Access 
Administration rights or have been added to the access control list (ACL) of each subscriber mail file 
with sufficient rights. Change the steps as necessary if you are running another version of Domino. 

The procedure describes using Update Unity Profile Agent.txt, but if you are familiar with agents, you 
can modify UpdateUn.nsf in Domino Designer by using the steps as a guideline. 
10-12
Reconfiguration and Upgrade Guide for Cisco Unity Release 5.x (With IBM Lotus Domino)

OL-13604-01



Chapter 10 Replacing or Converting a Cisco Unity 5.x Server, or Upgrading to Windows 2003
Replacing Only the Primary 5.x Server, or Upgrading to Windows 2003
To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server

Step 1 Copy the Update Unity Profile Agent.txt located in the 
CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory on the Cisco Unity server to 
the Domino server where you will run Domino Designer. 

Step 2 Copy AgentLog.nsf to your Domino data directory. 

Step 3 Open Domino Designer, click Open an Existing Database, and open Names.nsf. 

Step 4 In the Design pane for names.nsf (the pane on the left, underneath Recent Databases), click Shared 
Code > Agents. 

Step 5 In the right pane, click the New Agent button. The Agent Properties box appears. 

Step 6 On the Basics tab, enter a name for the agent in the Name field. 

Step 7 In the Runtime section, for the Target, click None. 

Step 8 Close the Agent Properties box. 

Step 9 In the Programmer’s pane on the right, click LotusScript from the Run menu. 

Step 10 On the Objects tab, click Declarations. 

Step 11 Open the file Update Unity Profile Agent.txt in Notepad, and copy the text from the beginning of the file 
to the line right above the line that contains “Sub Initialize.” (Do not copy the “Sub Initialize” line.) 

Step 12 Paste the text in the Script area of the Programmer’s pane in Domino Designer. 

Step 13 Modify the agent text in the Script area of the Programmer’s pane as follows: 

• Replace the const values AGENTLOG_SERVER and DUC_SERVER with your Domino server 
name. 

• Replace the const value NEW_UNITY_SERVER_NAME with the new Cisco Unity server name. 

Be sure that the server names are encapsulated in double quotes. 

Step 14 In the Objects tab, click Initialize. The lines “Sub Initialize” and “End Sub” with a blank line between 
them are displayed in the Script area of the Programmer’s pane. 

Step 15 In the file Update Unity Profile Agent.txt in Notepad, copy the text between (but not including) the lines 
“Sub Initialize” and “End Sub.” 

Step 16 Paste the text in the Script area of the Programmer’s pane on the blank line between the lines 
“Sub Initialize” and “End Sub.” 

Step 17 Exit Notepad. 

Step 18 Close and save the agent, and exit Domino Designer. 

Step 19 Open the Domino Administrator, click File > Database > Open, and open names.nsf. 

Step 20 Click Actions > <Your Agent Name> to run the agent. 

Step 21 Repeat Step 1 through Step 20 on every Domino server containing subscriber mail files that you want to 
change. 

Note Subscribers will need to exit and reopen Notes on their workstations for the change to take effect. 
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The procedure below is specific to Notes R6.5. Modify the steps as needed for other Notes versions. If 
you will be providing these instructions to subscribers, you will also need to provide them with the name 
of the Cisco Unity server. Consider customizing the instructions below with the name of your 
Cisco Unity server. 

Note that the file Client Update Unity Profile Agent.txt contains only one line of script, and it is given 
in the procedure. 

To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber Workstation 

Step 1 On a subscriber workstation, start Notes and open the subscriber mail file. 

Step 2 Click Create > Agent. The Agent Properties box appears. 

Step 3 On the Basics tab, enter a name for the agent in the Name field. 

Step 4 In the Runtime section, for the Target, click None. 

Step 5 Close the Agent Properties box. 

Step 6 In the Programmer’s pane on the right, click Formula from the Run menu. 

Step 7 Copy and paste the following text to the Script area of the Programmer’s pane: 

@SetProfileField("ucprofile";"VoiceServerList";"<NewUnityServerName>"); 

Step 8 Replace <NewUnityServerName> with your Cisco Unity server name. 

Step 9 Verify that the server name is enclosed in double quotes, that each argument is separated with a 
semicolon, and that the entire formula ends with a semicolon. 

Step 10 Close and save the Agent. 

To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation 

Step 1 On a subscriber workstation, start Notes and open the subscriber mail file. 

Step 2 Click Action > <Agent Name>, where <Agent Name> is the name of the applicable agent.

Step 3 Exit and then re-open Notes. 

Replacing Only the Secondary 5.x Server, or Upgrading to 
Windows 2003

Revised November 14, 2008
This section describes how to replace the secondary Cisco Unity server or upgrade from Windows 2000 
to Windows 2003 on that server. The replacement or upgraded secondary server keeps the same IP 
address and server name as the original server.
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Caution Upgrading from Windows 2000 Server to Windows Server 2003 on an existing Cisco Unity secondary 
server is supported only when you follow the procedures in this section. If you use Microsoft processes 
for upgrading Windows without reinstalling all software, default Windows Server 2003 configuration 
settings are different than settings for a fresh Windows Server 2003 installation, and Cisco Unity will 
not function properly. 

The following items are required to replace the secondary server:

• The latest version of the Cisco Unity Directory Walker (DbWalker) utility, available at 
http://ciscounitytools.com/App_DirectoryWalker4.htm.

• Software for reinstalling the secondary server (must be the same versions installed on the primary 
server).

• The applicable Cisco Unity installation guide for your configuration, available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides_list.html.

Do the following five procedures in the order listed.

To Remove Any SQL Errors and Stop SQL Replication on the Primary Server

Step 1 On the primary server, on the Windows Start menu, click Programs > Microsoft SQL Server > 
Enterprise Manager.

Step 2 In the left pane of the Console Root window, right-click the Replication node, and click Disable 
Publishing. The Disable Publishing and Distribution wizard appears.

Step 3 On the Welcome page, click Next.

Step 4 On the Disable Publishing page, click Yes, then click Next.

Step 5 On the Confirm Dropping of Publications page, click Next.

Step 6 On the Completing page, click Finish.

Step 7 When the process is completed, click OK.

Step 8 Close the Console Root window.

Step 9 Exit Enterprise Manager.

To Check the Consistency of the Cisco Unity Database on the Primary Server

Step 1 On the primary server, install the latest version of DbWalker, if it is not already installed.

Step 2 Run DbWalker, and correct all errors that the utility finds. Refer to DbWalker Help for detailed 
instructions on running the utility and on correcting errors in the database. (The Help file, 
DbWalker.htm, is in the same directory as DbWalker.exe.)

To Remove the Secondary Server from the Environment

Step 1 On the secondary server, log on to Windows as a Cisco Unity administrator.

Step 2 Right-click the Cisco Unity icon in the status area of the taskbar.
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(If the Cisco Unity icon is not in the taskbar, browse to the CommServer directory and double-click 
AvCsTrayStatus.exe.)

Step 3 Click Stop Cisco Unity. 

Step 4 Click OK to confirm that you want to stop the Cisco Unity software. Cisco Unity stops running when 
all calls are finished, and an “X” appears in the Cisco Unity icon.

Step 5 Right-click the SQL Server icon in the status area of the taskbar.

Step 6 Click MSSQLServer - Stop.

Step 7 Using the System control panel, make the server a workgroup server.

Step 8 Disconnect the network cable from the server. 

To Install the Replacement Secondary Server

Step 1 If you are replacing the server, follow the instructions in the applicable Cisco Unity installation guide 
for your configuration to install the replacement secondary server. If you are upgrading from Windows 
2000 to Windows 2003, reinstall all software on the server. Refer to Part 2 in the “Overview of 
Mandatory Tasks for Installing Cisco Unity” chapter.

Step 2 In the HKEY_LOCAL_MACHINE\SOFTWARE hive of the registry, confirm that the following registry 
settings match the settings on the primary server:

• Active Voice\Conversations\1.0\Exclude All Receipts

• Active Voice\Conversations\1.0\Exclude Return Receipts

• Active Voice\SystemParameters\1.0\EnabledAlternateGreetingNotice

• Active Voice\MALEx\1.0\MinSearchFolderLifeHours

• Active Voice\MALEx\1.0\DisableSearchFolderUse

Step 3 Reapply any non-Cisco Unity custom registry settings. 

To Configure Failover on the Secondary Server

Step 1 On the Windows taskbar, double-click the system clock. The Date/Time Properties dialog box appears.

Step 2 Set the time to the same hour and minute as shown on the primary server, and click OK.

Step 3 In Windows Explorer, browse to the CommServer directory.

Step 4 Double-click FailoverConfig.exe to start the Configure Cisco Unity Failover wizard.

Step 5 When the prompt that lists the requirements for the wizard appears, confirm that the requirements have 
been met and click OK.

Step 6 On the Welcome page, click Next.

Step 7 On the Specify Server Role page, click Secondary Server, and click Next.

Step 8 On the Enter the Name of Your Server page, click Browse, select the name of the primary server, and 
click OK. The IP address for the primary server is filled in automatically.

Step 9 Click Next.
10-16
Reconfiguration and Upgrade Guide for Cisco Unity Release 5.x (With IBM Lotus Domino)

OL-13604-01



Chapter 10 Replacing or Converting a Cisco Unity 5.x Server, or Upgrading to Windows 2003
Replacing Only the Secondary 5.x Server, or Upgrading to Windows 2003
Step 10 On the Enter Failover Account Information page, click Browse, and double-click the name of the 
directory and message store services account. This is the account that the failover service will log on as.

The account you select must have the right to act as part of the operating system and to log on as a 
service, and must be a member of the Local Administrators group.

Caution You must specify the same account on both the primary and secondary servers.

Step 11 In the Password field, enter the password for the account that the failover service will log on as, and click 
Next.

Step 12 On the Begin Configuring Your Server page, click Configure. The wizard verifies settings and 
configures failover on the secondary server.

If the wizard does not finish the configuration successfully, an error message explains why the wizard 
failed. Exit the wizard, correct the problem, and click Configure again.

Step 13 On the Completing page, click Finish.

Enabling Subscribers to Use the Phone for Recording and Playback
IBM Lotus Notes with IBM Lotus Domino Unified Communications (DUC) for Cisco offers a 
VCR-style recorder/player in the message form. Subscribers can customize it to use a phone or a 
computer microphone and speakers as the recording and playback device. However, if you rename a 
Cisco Unity server while you are reinstalling Windows, a phone does not work as a recording or 
playback device unless you manually update the Cisco Unity server name specified in each subscriber 
mail file. 

To correct the problem, you can either run an agent on a Domino server to change each subscriber mail 
file and push the changed mail files out to subscriber workstations, or you can provide subscribers with 
an agent that the subscriber runs on the workstation to change the server name in the mail file. 

Note You do not need to change anything for subscribers who use a computer microphone and speakers as 
their recording and playback devices. 

The agents are located on the Cisco Unity server. 

• The CommServer\Utilities\Domino\Agents\ClientUpdateUCProfileforTrap directory contains the 
following files: 

– ClUpUn.nsf—The agent that subscribers run on their workstations to change the Cisco Unity 
server name in their mail file. Note that the agent must be modified with the Cisco Unity server 
name before it is run. 

– Client Update Unity Profile Agent.txt—A text file that contains the LotusScript in ClUpUn.nsf. 
Note that the script must be modified with the Cisco Unity server name before it is run. 

– Readme.txt—A text file with instructions on using the agent. 

• The CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory contains the 
following files: 
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– UpdateUn.nsf—The agent that is run on a Domino server to change the Cisco Unity server name 
in each subscriber mail file. Note that the agent must be modified with the Cisco Unity server 
name and Domino server name before it is run. 

– Update Unity Profile Agent.txt—A text file that contains the LotusScript in UpdateUn.nsf. Note 
that the script must be modified with the Cisco Unity server name and Domino server name 
before it is run. 

– AgentLog.nsf—A Notes database that stores output from the agent that is run on the Domino 
server. 

– Readme.txt—A text file with instructions on using the agent. 

See the following procedures for details on modifying and running the agents: 

• To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server, 
page 10-18

• To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber 
Workstation, page 10-19

• To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation, page 10-20

The following procedure is specific to Domino R6.5 and assumes that you have Full Access 
Administration rights or have been added to the access control list (ACL) of each subscriber mail file 
with sufficient rights. Change the steps as necessary if you are running another version of Domino. 

The procedure describes using Update Unity Profile Agent.txt, but if you are familiar with agents, you 
can modify UpdateUn.nsf in Domino Designer by using the steps as a guideline. 

To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server

Step 1 Copy the Update Unity Profile Agent.txt located in the 
CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory on the Cisco Unity server to 
the Domino server where you will run Domino Designer. 

Step 2 Copy AgentLog.nsf to your Domino data directory. 

Step 3 Open Domino Designer, click Open an Existing Database, and open Names.nsf. 

Step 4 In the Design pane for names.nsf (the pane on the left, underneath Recent Databases), click Shared 
Code > Agents. 

Step 5 In the right pane, click the New Agent button. The Agent Properties box appears. 

Step 6 On the Basics tab, enter a name for the agent in the Name field. 

Step 7 In the Runtime section, for the Target, click None. 

Step 8 Close the Agent Properties box. 

Step 9 In the Programmer’s pane on the right, click LotusScript from the Run menu. 

Step 10 On the Objects tab, click Declarations. 

Step 11 Open the file Update Unity Profile Agent.txt in Notepad, and copy the text from the beginning of the file 
to the line right above the line that contains “Sub Initialize.” (Do not copy the “Sub Initialize” line.) 

Step 12 Paste the text in the Script area of the Programmer’s pane in Domino Designer. 

Step 13 Modify the agent text in the Script area of the Programmer’s pane as follows: 

• Replace the const values AGENTLOG_SERVER and DUC_SERVER with your Domino server 
name. 

• Replace the const value NEW_UNITY_SERVER_NAME with the new Cisco Unity server name. 
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Be sure that the server names are encapsulated in double quotes. 

Step 14 In the Objects tab, click Initialize. The lines “Sub Initialize” and “End Sub” with a blank line between 
them are displayed in the Script area of the Programmer’s pane. 

Step 15 In the file Update Unity Profile Agent.txt in Notepad, copy the text between (but not including) the lines 
“Sub Initialize” and “End Sub.” 

Step 16 Paste the text in the Script area of the Programmer’s pane on the blank line between the lines 
“Sub Initialize” and “End Sub.” 

Step 17 Exit Notepad. 

Step 18 Close and save the agent, and exit Domino Designer. 

Step 19 Open the Domino Administrator, click File > Database > Open, and open names.nsf. 

Step 20 Click Actions > <Your Agent Name> to run the agent. 

Step 21 Repeat Step 1 through Step 20 on every Domino server containing subscriber mail files that you want to 
change. 

Note Subscribers will need to exit and reopen Notes on their workstations for the change to take effect. 

The procedure below is specific to Notes R6.5. Modify the steps as needed for other Notes versions. If 
you will be providing these instructions to subscribers, you will also need to provide them with the name 
of the Cisco Unity server. Consider customizing the instructions below with the name of your 
Cisco Unity server. 

Note that the file Client Update Unity Profile Agent.txt contains only one line of script, and it is given 
in the procedure. 

To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber Workstation 

Step 1 On a subscriber workstation, start Notes and open the subscriber mail file. 

Step 2 Click Create > Agent. The Agent Properties box appears. 

Step 3 On the Basics tab, enter a name for the agent in the Name field. 

Step 4 In the Runtime section, for the Target, click None. 

Step 5 Close the Agent Properties box. 

Step 6 In the Programmer’s pane on the right, click Formula from the Run menu. 

Step 7 Copy and paste the following text to the Script area of the Programmer’s pane: 

@SetProfileField("ucprofile";"VoiceServerList";"<NewUnityServerName>"); 

Step 8 Replace <NewUnityServerName> with your Cisco Unity server name. 

Step 9 Verify that the server name is enclosed in double quotes, that each argument is separated with a 
semicolon, and that the entire formula ends with a semicolon. 

Step 10 Close and save the Agent. 
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To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation 

Step 1 On a subscriber workstation, start Notes and open the subscriber mail file. 

Step 2 Click Action > <Agent Name>, where <Agent Name> is the name of the applicable agent.

Step 3 Exit and then re-open Notes. 

Replacing Both 5.x Failover Servers, or Upgrading to Windows 
2003

Revised November 14, 2008
This section describes how to replace the primary and secondary failover servers at the same time or 
upgrade from Windows 2000 to Windows 2003 on both servers. Both replacement or upgraded servers 
keep the IP addresses and server names that the original servers had.

Caution Upgrading from Windows 2000 Server to Windows Server 2003 on existing Cisco Unity failover servers 
is supported only when you follow the procedures in this section. If you use Microsoft processes for 
upgrading Windows without reinstalling all software, default Windows Server 2003 configuration 
settings are different than settings for a fresh Windows Server 2003 installation, and Cisco Unity will 
not function properly. 

The procedures in this section require that you have a recent backup of or can back up Cisco Unity data 
from the secondary server by using the Cisco Unity Disaster Recovery Backup tool. If a backup is not 
available or backing up the Cisco Unity data is not possible, you must repopulate the Cisco Unity system 
with subscriber and call management data as described in the Cisco Unity installation guide instead.

The following items are required to replace the primary and secondary servers at the same time:

• The latest versions of the following applications:

– The Cisco Unity Directory Walker (DbWalker) utility, available at 
http://ciscounitytools.com/App_DirectoryWalker4.htm.

– The Cisco Unity Disaster Recovery tools (DiRT), available at 
http://ciscounitytools.com/App_DisasterRecoveryTools.htm.

• Software for reinstalling the primary and secondary servers (must be the same versions installed on 
both servers).

• The applicable Cisco Unity installation guide for your configuration, available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides_list.html.

• Updated license files that reference the MAC address of the network interface card (NIC) in the 
replacement server. Licenses are associated with the MAC address on the NIC. For information on 
getting updated license files, refer to White Paper: Licensing for Cisco Unity (All Versions) at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_white_papers_list.html.
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Note The voice messaging service does not function while the primary and secondary servers are being 
replaced or upgraded. During this time, callers and subscribers will not be able to record or listen to voice 
messages. We recommend that you replace the servers when phone traffic is light (for example, after 
business hours).

Do the following 10 procedures in the order listed. Do the first two procedures only if it is possible to 
back up Cisco Unity data on the secondary server.

To Manually Initiate Failover to the Secondary Server and Disable Automatic Failback

Step 1 If the primary server is not active, skip to Step 4.

If the primary server is active, on the primary server, on the Windows Start menu, click Programs > 
Cisco Unity > Failover Monitor.

Step 2 Click Failover.

Step 3 Click OK to confirm that you want to fail over to the secondary server. The primary server becomes 
inactive, and the secondary server becomes active.

Step 4 On the secondary server, on the Windows Start menu, click Programs > Cisco Unity > Failover 
Monitor.

Step 5 Click Configure.

Step 6 In the Failback Type field of the Failover Configuration dialog box, click Manual.

Step 7 Click OK to close the Failover Configuration dialog box.

To Stop File Replication on the Secondary and Primary Servers

Step 1 On the secondary server, on the Windows Start menu, click Programs > Administrative Tools > 
Services.

Step 2 In the right pane, double-click AvCsNodeMgr.

Step 3 On the General tab, click Stop.

Step 4 In the Startup Type list, click Disabled.

Step 5 Click OK.

Step 6 Close the Services window.

Caution Because the Node Manager service is disabled, file replication stops. Replication is re-enabled 
when normal failover operation resumes.

Step 7 On the primary server, on the Windows Start menu, click Programs > Administrative Tools > Services.

Step 8 In the right pane, double-click AvCsNodeMgr.

Step 9 On the General tab, click Stop.

Step 10 In the Startup Type list, click Disabled.

Step 11 Click OK.
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Step 12 Close the Services window.

To Stop SQL Replication on the Primary Server

Step 1 On the primary server, on the Windows Start menu, click Programs > Microsoft SQL Server > 
Enterprise Manager.

Step 2 In the left pane of the Console Root window, browse to the Replication node for the primary server. 
Typically, the node is three levels under the Microsoft SQL Servers node.

Step 3 Right-click the Replication node, and click Disable Publishing. The Disable Publishing and 
Distribution wizard appears.

Step 4 On the Welcome page, click Next.

Step 5 On the Disable Publishing page, click Yes, then click Next.

Step 6 On the Confirm Dropping of Publications page, click Next.

Step 7 On the Completing page, click Finish.

Step 8 When the process is completed, click OK.

Step 9 Close the Console Root window.

Step 10 Exit Enterprise Manager.

To Check the Consistency of the Cisco Unity Database on the Secondary Server

Step 1 On the secondary server, install the latest version of DbWalker, if it is not already installed.

Step 2 Run DbWalker, and correct all errors that the utility finds. Refer to DbWalker Help for detailed 
instructions on running the utility and on correcting errors in the database. (The Help file, 
DbWalker.htm, is in the same directory as DbWalker.exe.)

To Back Up Cisco Unity Data on the Secondary Server to a Network Storage Location

Step 1 On the secondary server, install the latest versions of DiRT, if the tools are not already installed.

Step 2 Back up Cisco Unity data by using the Disaster Recovery Backup tool. Refer to DiRT Help for detailed 
instructions. (The Help file, UnityDisasterRecovery.htm, is in the same directory as 
UnityDisasterRecoveryBackup.exe.)

Caution Follow Help carefully. DiRT includes a variety of options that you must understand to use the 
tools successfully. In addition, the account you are logged on as when you back up 
Cisco Unity data must have sufficient permissions or the backup will fail.
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Caution Do not back up the primary server unless the secondary server is unavailable. If you restore 
from a backup of the primary server, you must also perform an additional procedure for 
Cisco Unity failover to function correctly. For more information, see “Working With Systems 
Configured For Failover” in DiRT Help.

Step 3 Save the Cisco Unity data to a network storage location.

To Remove the Primary and Secondary Servers from the Environment

Step 1 On the primary server, log on to Windows as a Cisco Unity administrator.

Step 2 Right-click the Cisco Unity icon in the status area of the taskbar.

(If the Cisco Unity icon is not in the taskbar, browse to the CommServer directory and double-click 
AvCsTrayStatus.exe.)

Step 3 Click Stop Cisco Unity. 

Step 4 Click OK to confirm that you want to stop the Cisco Unity software. Cisco Unity stops running when 
all calls are finished, and an “X” appears in the Cisco Unity icon.

Step 5 Right-click the SQL Server icon in the status area of the taskbar.

Step 6 Click MSSQLServer - Stop.

Step 7 Using the System control panel, make the server a workgroup server.

Step 8 Disconnect the network cable from the server. 

Step 9 Repeat the procedure on the secondary server. 

To Install the Replacement Primary and Secondary Servers

Step 1 Follow the instructions in the applicable Cisco Unity installation guide for your configuration to install 
the replacement primary and secondary servers. Refer to Part 1 and Part 2 in the “Overview of Mandatory 
Tasks for Installing Cisco Unity” chapter. Note that you must install the updated license files on the 
replacement primary server.

Note that the same version of Cisco Unity must be installed on both servers.

To Restore Cisco Unity Data on the Replacement Primary Server from the Network Storage Location

Step 1 On the replacement primary server, install the latest versions of DiRT, if the tools are not already 
installed.

Step 2 Restore Cisco Unity data by using the Disaster Recovery Restore tool and the backup that you made 
earlier. Refer to DiRT Help for detailed instructions. (The Help file, UnityDisasterRecovery.htm, is in 
the same directory as UnityDisasterRecoveryRestore.exe.)
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Caution Follow Help carefully. DiRT includes a variety of options that you must understand to use the 
tools successfully.

Step 3 In the HKEY_LOCAL_MACHINE\SOFTWARE hive of the registry, confirm that the following registry 
settings match the settings on the secondary server:

• Active Voice\Conversations\1.0\Exclude All Receipts

• Active Voice\Conversations\1.0\Exclude Return Receipts

• Active Voice\SystemParameters\1.0\EnabledAlternateGreetingNotice

• Active Voice\MALEx\1.0\MinSearchFolderLifeHours

• Active Voice\MALEx\1.0\DisableSearchFolderUse

Step 4 Reapply any non-Cisco Unity custom registry settings. (DiRT backs up and restores Cisco Unity registry 
settings.)

To Configure Failover on the Primary Server

Step 1 In Windows Explorer, browse to the CommServer directory.

Step 2 Double-click FailoverConfig.exe to start the Configure Cisco Unity Failover wizard.

Step 3 When the prompt that lists the requirements for the wizard appears, confirm that the requirements have 
been met and click OK.

Step 4 On the Welcome page, click Next.

Step 5 On the Specify Server Role page, click Primary Server, and click Next.

Step 6 On the Enter the Name of Your Server page, click Browse, select the name of the secondary server, and 
click OK. The IP address for the secondary server is filled in automatically.

Step 7 Click Next.

Step 8 On the Enter Failover Account Information page, click Browse, and double-click the name of the 
directory and message store services account. This is the account that the failover service will log on as.

The account you select must have the right to act as part of the operating system and to log on as a 
service, and must be a member of the Local Administrators group.

Caution You must specify the same account on both the primary and secondary servers.

Step 9 In the Password field, enter the password for the account that the failover service will log on as, and click 
Next.

Step 10 On the Begin Configuring Your Server page, click Configure. The wizard verifies settings and 
configures failover on the primary server.

If the wizard does not finish the configuration successfully, an error message explains why the wizard 
failed. Exit the wizard, correct the problem, and click Configure again.

Step 11 On the Completing page, click Finish.
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To Configure Failover on the Secondary Server

Step 1 On the Windows taskbar, double-click the system clock. The Date/Time Properties dialog box appears.

Step 2 Set the time to the same hour and minute as shown on the primary server, and click OK.

Step 3 In Windows Explorer, browse to the CommServer directory.

Step 4 Double-click FailoverConfig.exe to start the Configure Cisco Unity Failover wizard.

Step 5 When the prompt that lists the requirements for the wizard appears, confirm that the requirements have 
been met and click OK.

Step 6 On the Welcome page, click Next.

Step 7 On the Specify Server Role page, click Secondary Server, and click Next.

Step 8 On the Enter the Name of Your Server page, click Browse, select the name of the primary server, and 
click OK. The IP address for the primary server is filled in automatically.

Step 9 Click Next.

Step 10 On the Enter Failover Account Information page, click Browse, and double-click the name of the 
directory and message store services account. This is the account that the failover service will log on as.

The account you select must have the right to act as part of the operating system and to log on as a 
service, and must be a member of the Local Administrators group.

Caution You must specify the same account on both the primary and secondary servers.

Step 11 In the Password field, enter the password for the account that the failover service will log on as, and click 
Next.

Step 12 On the Begin Configuring Your Server page, click Configure. The wizard verifies settings and 
configures failover on the secondary server.

If the wizard does not finish the configuration successfully, an error message explains why the wizard 
failed. Exit the wizard, correct the problem, and click Configure again.

Step 13 On the Completing page, click Finish.

Enabling Subscribers to Use the Phone for Recording and Playback
IBM Lotus Notes with IBM Lotus Domino Unified Communications (DUC) for Cisco offers a 
VCR-style recorder/player in the message form. Subscribers can customize it to use a phone or a 
computer microphone and speakers as the recording and playback device. However, if you rename a 
Cisco Unity server while you are reinstalling Windows, a phone does not work as a recording or 
playback device unless you manually update the Cisco Unity server name specified in each subscriber 
mail file. 

To correct the problem, you can either run an agent on a Domino server to change each subscriber mail 
file and push the changed mail files out to subscriber workstations, or you can provide subscribers with 
an agent that the subscriber runs on the workstation to change the server name in the mail file. 
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Note You do not need to change anything for subscribers who use a computer microphone and speakers as 
their recording and playback devices. 

The agents are located on the Cisco Unity server. 

• The CommServer\Utilities\Domino\Agents\ClientUpdateUCProfileforTrap directory contains the 
following files: 

– ClUpUn.nsf—The agent that subscribers run on their workstations to change the Cisco Unity 
server name in their mail file. Note that the agent must be modified with the Cisco Unity server 
name before it is run. 

– Client Update Unity Profile Agent.txt—A text file that contains the LotusScript in ClUpUn.nsf. 
Note that the script must be modified with the Cisco Unity server name before it is run. 

– Readme.txt—A text file with instructions on using the agent. 

• The CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory contains the 
following files: 

– UpdateUn.nsf—The agent that is run on a Domino server to change the Cisco Unity server name 
in each subscriber mail file. Note that the agent must be modified with the Cisco Unity server 
name and Domino server name before it is run. 

– Update Unity Profile Agent.txt—A text file that contains the LotusScript in UpdateUn.nsf. Note 
that the script must be modified with the Cisco Unity server name and Domino server name 
before it is run. 

– AgentLog.nsf—A Notes database that stores output from the agent that is run on the Domino 
server. 

– Readme.txt—A text file with instructions on using the agent. 

See the following procedures for details on modifying and running the agents: 

• To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server, 
page 10-26

• To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber 
Workstation, page 10-28

• To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation, page 10-28

The following procedure is specific to Domino R6.5 and assumes that you have Full Access 
Administration rights or have been added to the access control list (ACL) of each subscriber mail file 
with sufficient rights. Change the steps as necessary if you are running another version of Domino. 

The procedure describes using Update Unity Profile Agent.txt, but if you are familiar with agents, you 
can modify UpdateUn.nsf in Domino Designer by using the steps as a guideline. 

To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server

Step 1 Copy the Update Unity Profile Agent.txt located in the 
CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory on the Cisco Unity server to 
the Domino server where you will run Domino Designer. 

Step 2 Copy AgentLog.nsf to your Domino data directory. 

Step 3 Open Domino Designer, click Open an Existing Database, and open Names.nsf. 
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Step 4 In the Design pane for names.nsf (the pane on the left, underneath Recent Databases), click Shared 
Code > Agents. 

Step 5 In the right pane, click the New Agent button. The Agent Properties box appears. 

Step 6 On the Basics tab, enter a name for the agent in the Name field. 

Step 7 In the Runtime section, for the Target, click None. 

Step 8 Close the Agent Properties box. 

Step 9 In the Programmer’s pane on the right, click LotusScript from the Run menu. 

Step 10 On the Objects tab, click Declarations. 

Step 11 Open the file Update Unity Profile Agent.txt in Notepad, and copy the text from the beginning of the file 
to the line right above the line that contains “Sub Initialize.” (Do not copy the “Sub Initialize” line.) 

Step 12 Paste the text in the Script area of the Programmer’s pane in Domino Designer. 

Step 13 Modify the agent text in the Script area of the Programmer’s pane as follows: 

• Replace the const values AGENTLOG_SERVER and DUC_SERVER with your Domino server 
name. 

• Replace the const value NEW_UNITY_SERVER_NAME with the new Cisco Unity server name. 

Be sure that the server names are encapsulated in double quotes. 

Step 14 In the Objects tab, click Initialize. The lines “Sub Initialize” and “End Sub” with a blank line between 
them are displayed in the Script area of the Programmer’s pane. 

Step 15 In the file Update Unity Profile Agent.txt in Notepad, copy the text between (but not including) the lines 
“Sub Initialize” and “End Sub.” 

Step 16 Paste the text in the Script area of the Programmer’s pane on the blank line between the lines 
“Sub Initialize” and “End Sub.” 

Step 17 Exit Notepad. 

Step 18 Close and save the agent, and exit Domino Designer. 

Step 19 Open the Domino Administrator, click File > Database > Open, and open names.nsf. 

Step 20 Click Actions > <Your Agent Name> to run the agent. 

Step 21 Repeat Step 1 through Step 20 on every Domino server containing subscriber mail files that you want to 
change. 

Note Subscribers will need to exit and reopen Notes on their workstations for the change to take effect. 

The procedure below is specific to Notes R6.5. Modify the steps as needed for other Notes versions. If 
you will be providing these instructions to subscribers, you will also need to provide them with the name 
of the Cisco Unity server. Consider customizing the instructions below with the name of your 
Cisco Unity server. 

Note that the file Client Update Unity Profile Agent.txt contains only one line of script, and it is given 
in the procedure. 
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To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber Workstation 

Step 1 On a subscriber workstation, start Notes and open the subscriber mail file. 

Step 2 Click Create > Agent. The Agent Properties box appears. 

Step 3 On the Basics tab, enter a name for the agent in the Name field. 

Step 4 In the Runtime section, for the Target, click None. 

Step 5 Close the Agent Properties box. 

Step 6 In the Programmer’s pane on the right, click Formula from the Run menu. 

Step 7 Copy and paste the following text to the Script area of the Programmer’s pane: 

@SetProfileField("ucprofile";"VoiceServerList";"<NewUnityServerName>"); 

Step 8 Replace <NewUnityServerName> with your Cisco Unity server name. 

Step 9 Verify that the server name is enclosed in double quotes, that each argument is separated with a 
semicolon, and that the entire formula ends with a semicolon. 

Step 10 Close and save the Agent. 

To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation 

Step 1 On a subscriber workstation, start Notes and open the subscriber mail file. 

Step 2 Click Action > <Agent Name>, where <Agent Name> is the name of the applicable agent.

Step 3 Exit and then re-open Notes. 

About Uninstalling Failover on Cisco Unity 5.x Servers
When converting a Cisco Unity failover server to another purpose for which Cisco Unity failover is not 
needed, it is necessary to change a number of settings for the Cisco Unity system.

To convert a primary or secondary Cisco Unity server to a Cisco Unity server without failover, see the 
applicable section in this chapter:

• Converting a Secondary Server to a 60-Day Cisco Unity 5.x Server Without a Primary Server, 
page 10-29

• Converting a Secondary Server to a Permanent Regular Cisco Unity 5.x Server Without Failover, 
page 10-30

• Converting a Primary Server to a Permanent Regular Cisco Unity 5.x Server Without Failover, 
page 10-35

To convert a primary or secondary Cisco Unity server to a server for another application, follow the 
installation instructions for the application.
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Converting a Secondary Server to a 60-Day Cisco Unity 5.x 
Server Without a Primary Server

When operating without the primary server, the secondary server answers calls for 60 days after the last 
time that it was able to contact the primary server, provided the secondary server has contacted the 
primary server at least once.

Do the following three procedures in the order listed.

To Disable Sharing in the Directories Used by Failover on Both Servers

Step 1 On the primary server, browse to the CommServer\Stream Files directory.

Step 2 Right-click the Stream Files directory, and click Sharing.

Step 3 In the Links Properties dialog box, on the Sharing tab, click Do Not Share This Folder, then click OK.

Step 4 Repeat Step 1 through Step 3 for the following five directories:

• CommServer\Snapshot

• CommServer\Support

• CommServer\UnityMTA

• CommServer\Localize\DefaultConfiguration

• CommServer\Localize\Prompts

Step 5 On the secondary server, browse to the CommServer\Stream Files directory.

Step 6 Right-click the Stream Files directory, and click Sharing.

Step 7 In the Links Properties dialog box, on the Sharing tab, click Do Not Share This Folder, then click OK.

Step 8 Repeat Step 5 through Step 7 for the following five directories on the secondary server:

• CommServer\Snapshot

• CommServer\Support

• CommServer\UnityMTA

• CommServer\Localize\DefaultConfiguration

• CommServer\Localize\Prompts

To Remove the Primary Server from the Environment

Step 1 Shut down the primary server. For details, see the “Shutting Down or Restarting the Cisco Unity Server” 
section on page A-3.

The secondary server becomes active and handles calls.

Step 2 Disconnect the network cable from the primary server.
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To Convert the Secondary Server into a 60-Day Cisco Unity Server Without a Primary Server

Step 1 On the secondary server, on the Windows Start menu, click Programs > Cisco Unity > Failover 
Monitor.

Step 2 Click Configure.

Step 3 In the Failback Type field, click Manual.

Step 4 Click OK to close the Failover Configuration dialog box.

Step 5 Click Advanced.

Step 6 Uncheck the Disable Automatic Failover and Failback check box.

Step 7 Click OK.

Step 8 On the Windows Start menu, click Programs > Administrative Tools > Services.

Step 9 In the right pane, double-click AvCsNodeMgr.

Step 10 On the General tab, click Stop.

Step 11 In the Startup Type list, click Disabled.

Step 12 Click OK.

Converting a Secondary Server to a Permanent Regular 
Cisco Unity 5.x Server Without Failover

Revised May 1, 2008
To convert the secondary server to a regular Cisco Unity server that operates without failover, you must 
purchase a new license because the failover license will disable the former secondary server after 60 
days.

The following items are required to convert the secondary server to a permanent regular Cisco Unity 
server without failover:

• A Cisco Unity license for the server.

• The latest versions of the following applications:

– The Cisco Unity Directory Walker (DbWalker) utility, available at 
http://ciscounitytools.com/App_DirectoryWalker4.htm. 

– The Cisco Unity Disaster Recovery tools (DiRT), available at 
http://ciscounitytools.com/App_DisasterRecoveryTools.htm.

– The Uninstall Cisco Unity utility, available at 
http://ciscounitytools.com/App_UninstallUnity30.htm.

• Software for reinstalling the Cisco Unity server.

• The applicable Cisco Unity installation guide for your configuration, available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides_list.html.

Do the following 11 procedures in the order listed.
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To Disable Automatic Failover

Step 1 If the primary server is active, skip to Step 5.

If the primary server is not active, on the Windows Start menu on the secondary server, click Programs > 
Cisco Unity >Failover Monitor.

Step 2 Click Failback.

Step 3 Click OK to confirm that you want to fail back to the primary server.

Step 4 Close the Failover Monitor.

Step 5 On the primary server, on the Windows Start menu, click Programs > Cisco Unity > Failover Monitor.

Step 6 Click Advanced.

Step 7 Check the Disable Automatic Failover and Failback check box.

Step 8 (If the applicable ES is installed on the Cisco Unity servers) Confirm that the Enable File Replication 
check box is unchecked.

Note The Enable File Replication check box does not appear if the applicable ES is not installed.

Step 9 Click OK, and close the Failover Monitor.

To Stop File Replication on the Primary Server

Step 1 On the primary server, on the Windows Start menu, click Programs > Administrative Tools > Services.

Step 2 In the right pane, double-click AvCsNodeMgr.

Step 3 On the General tab, click Stop.

Step 4 In the Startup Type list, click Disabled.

Step 5 Click OK.

Step 6 Close the Services window.

To Stop SQL Replication on the Primary Server

Step 1 On the primary server, on the Windows Start menu, click Programs > Microsoft SQL Server > 
Enterprise Manager.

Step 2 In the left pane of the Console Root window, browse to the Replication node for the primary server. 
Typically, the node is three levels under the Microsoft SQL Servers node.

Step 3 Right-click the Replication node, and click Disable Publishing. The Disable Publishing and 
Distribution wizard appears.

Step 4 On the Welcome page, click Next.

Step 5 On the Disable Publishing page, click Yes, then click Next.

Step 6 On the Confirm Dropping of Publications page, click Next.

Step 7 On the Completing page, click Finish.
10-31
Reconfiguration and Upgrade Guide for Cisco Unity Release 5.x (With IBM Lotus Domino)

OL-13604-01



Chapter 10 Replacing or Converting a Cisco Unity 5.x Server, or Upgrading to Windows 2003
Converting a Secondary Server to a Permanent Regular Cisco Unity 5.x Server Without Failover
Step 8 When the process is completed, click OK.

Step 9 Close the Console Root window.

Step 10 Exit Enterprise Manager.

To Delete References to the Node Manager Service on the Secondary Server

Step 1 On the secondary server, exit the Cisco Unity software. For details, see the “Exiting the Cisco Unity 
Software” section on page A-1.

Step 2 On the Windows Start menu, click Programs > Administrative Tools > Services.

Step 3 In the right pane, double-click NodeMgr.

Step 4 On the General tab, click Stop.

Step 5 In the Startup Type list, click Disabled.

Step 6 Click OK.

Step 7 Close the Services window.

Step 8 On the Windows Start menu, click Run.

Step 9 Enter Cmd, and press Enter.

Step 10 In the Command window, enter <Drive on which Cisco Unity is 
installed>:\CommServer\AvCsNodeMgr /unregserver, and press Enter.

Step 11 Enter Regedit, and press Enter.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) If you have any questions 
about changing registry key settings, contact Cisco TAC. 

Step 12 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 13 Delete the key
HKEY_LOCAL_MACHINE\SOFTWARE\Active Voice\AvCsNodeMgr.

Step 14 Expand the key
HKEY_LOCAL_MACHINE\Software\Active Voice\AvCsGateway\1.0\Services.

Step 15 Under Services, search for the Service key in which the Name value is “AvCsNodeMgr.”

Step 16 In the Service key, double-click Start.

Step 17 In the Edit DWORD Value dialog box, in the Value Data field, enter 0, and click OK.

Step 18 Close the Registry Editor.

Step 19 In the Command window, enter Exit, and press Enter.

Step 20 On the Windows Start menu, click Programs > Cisco Unity.

Step 21 Right-click NodeMgr Monitor, and click Delete.

Step 22 Click Yes to confirm.
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To Disable Sharing in the Directories Used by Failover on the Secondary Server

Step 1 On the secondary server, browse to the CommServer\Stream Files directory.

Step 2 Right-click the Stream Files directory, and click Sharing.

Step 3 In the Links Properties dialog box, on the Sharing tab, click Do Not Share This Folder, then click OK.

Step 4 Repeat Step 1 through Step 3 for the following five directories:

• CommServer\Snapshot

• CommServer\Support

• CommServer\UnityMTA

• CommServer\Localize\DefaultConfiguration

• CommServer\Localize\Prompts

Caution Changes made to the primary server (for example, recording new greetings or making subscriber 
changes) after the next procedure is finished will not be replicated to the secondary server and will be 
lost.

To Check the Consistency of the Cisco Unity Database on the Secondary Server

Step 1 On the secondary server, install the latest version of DbWalker, if it is not already installed.

Step 2 Run DbWalker, and correct all errors that the utility finds. Refer to DbWalker Help for detailed 
instructions on running the utility and on correcting errors in the database. (The Help file, 
DbWalker.htm, is in the same directory as DbWalker.exe.)

To Back Up Cisco Unity Data on the Secondary Server to a Network Storage Location

Step 1 On the secondary server, install the latest version of DiRT, if the tools have not already been installed.

Step 2 Back up Cisco Unity data by using the Disaster Recovery Backup tool. Refer to DiRT Help for detailed 
instructions. (The Help file, UnityDisasterRecovery.htm, is in the same directory as 
UnityDisasterRecoveryBackup.exe.)

Caution Follow Help carefully. DiRT includes a variety of options that you must understand to use the 
tools successfully. In addition, the account you are logged on as when you back up 
Cisco Unity data must have sufficient permissions or the backup will fail.

Caution Do not back up the primary server unless the secondary server is unavailable. If you restore 
from a backup of the primary server, you must also perform an additional procedure for 
Cisco Unity failover to function correctly. For more information, see “Working With Systems 
Configured For Failover” in DiRT Help.
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Step 3 Save the Cisco Unity data to a network storage location.

To Uninstall Cisco Unity on the Secondary Server

Step 1 On the secondary server, install the latest version of the Uninstall Cisco Unity utility, if it is not already 
installed.

Step 2 Log on to the secondary server by using the Cisco Unity installation account.

Step 3 Exit the Cisco Unity software. For details, see the “Exiting the Cisco Unity Software” section on 
page A-1.

Step 4 On the Windows Start menu, click Programs > Accessories > Command Prompt.

Step 5 In the Command Prompt window, enter
cd commserver\utilties\uninstallunity3xand4x
and press Enter.

Step 6 Enter
unityuninstall3xand4x.exe /skipdoh
and press Enter.

Caution The Cisco Unity Uninstall utility cannot be stopped after it starts, and the uninstall cannot be 
reversed.

Step 7 Uncheck the Remove Subscriber Information from Mail Users in Directory check box.

Step 8 Click Uninstall.

Step 9 Follow the on-screen prompts.

Step 10 When the utility has finished, you may need to manually delete the CommServer directory.

If you cannot delete the CommServer directory:

a. In the CommServer directory, delete all files with the .exe extension.

b. On the Windows Start menu, click Programs > Startup, right-click AvCsTrayStatus, and click 
Delete.

c. Restart the Cisco Unity server, and delete the CommServer directory.

To Install the Former Secondary Server as a Regular Cisco Unity Server Without Failover

Step 1 Disable virus-scanning services. Refer to the software manufacturer documentation to determine the 
correct services.

Step 2 Follow the instructions in the “Installing and Configuring Cisco Unity Software” chapter of the 
applicable Cisco Unity installation guide for your configuration.

To Restore Cisco Unity Data on the Cisco Unity Server from the Network Storage Location

Step 1 On the Cisco Unity server, install the latest versions of DiRT, if the tools are not already installed.
10-34
Reconfiguration and Upgrade Guide for Cisco Unity Release 5.x (With IBM Lotus Domino)

OL-13604-01



Chapter 10 Replacing or Converting a Cisco Unity 5.x Server, or Upgrading to Windows 2003
Converting a Primary Server to a Permanent Regular Cisco Unity 5.x Server Without Failover
Step 2 Restore Cisco Unity data by using the Disaster Recovery Restore tool and the backup that you made 
earlier. Refer to DiRT Help for detailed instructions. (The Help file, UnityDisasterRecovery.htm, is in 
the same directory as UnityDisasterRecoveryRestore.exe.)

Caution Follow Help carefully. DiRT includes a variety of options that you must understand to use the 
tools successfully.

Step 3 Reapply any non-Cisco Unity custom registry settings. (DiRT backs up and restores Cisco Unity registry 
settings.)

To Remove the Primary Server from the Environment

Step 1 Disconnect the network cable from the primary server.

Caution To prevent unexpected behavior from the former secondary server, do not reconnect the 
primary server to the network while the former secondary server is connected and running.

Step 2 Reinstall the operating system on the primary server to remove Cisco Unity failover from the hard disk.

Converting a Primary Server to a Permanent Regular Cisco Unity 
5.x Server Without Failover

Do the following six procedures in the order listed.

To Disable Automatic Failover

Step 1 On the primary server, on the Windows Start menu, click Programs > Cisco Unity > Failover Monitor.

Step 2 Click Advanced.

Step 3 Check the Disable Automatic Failover and Failback check box.

Step 4 (If the applicable ES is installed on the Cisco Unity servers) Confirm that the Enable File Replication 
check box is unchecked.

Note The Enable File Replication check box does not appear if the applicable ES is not installed.

Step 5 Click OK.

To Stop File Replication on the Primary and Secondary Servers

Step 1 On the primary server, on the Windows Start menu, click Programs > Administrative Tools > Services.
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Step 2 In the right pane, double-click AvCsNodeMgr.

Step 3 On the General tab, click Stop.

Step 4 In the Startup Type list, click Disabled.

Step 5 Click OK.

Step 6 Close the Services window.

Step 7 On the secondary server, on the Windows Start menu, click Programs > Administrative Tools > 
Services.

Step 8 In the right pane, double-click AvCsNodeMgr.

Step 9 On the General tab, click Stop.

Step 10 In the Startup Type list, click Disabled.

Step 11 Click OK.

Step 12 Close the Services window.

To Delete References to the Node Manager Service on the Primary Server

Step 1 On the primary server, exit the Cisco Unity software. For details, see the “Exiting the Cisco Unity 
Software” section on page A-1.

Step 2 On the Windows Start menu, click Programs > Administrative Tools > Services.

Step 3 In the right pane, double-click NodeMgr.

Step 4 On the General tab, click Stop.

Step 5 In the Startup Type list, click Disabled.

Step 6 Click OK.

Step 7 Close the Services window.

Step 8 On the Windows Start menu, click Run.

Step 9 Enter Cmd, and press Enter.

Step 10 In the Command window, enter <Drive on which Cisco Unity is 
installed>:\CommServer\AvCsNodeMgr /unregserver, and press Enter.

Step 11 Enter Regedit, and press Enter.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) If you have any questions 
about changing registry key settings, contact Cisco TAC. 

Step 12 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 13 Delete the key
HKEY_LOCAL_MACHINE\SOFTWARE\Active Voice\AvCsNodeMgr.

Step 14 Expand the key
HKEY_LOCAL_MACHINE\Software\Active Voice\AvCsGateway\1.0\Services.
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Step 15 Under Services, search for the Service key in which the Name value is “AvCsNodeMgr.”

Step 16 In the Service key, double-click Start.

Step 17 In the Edit DWORD Value dialog box, in the Value Data field, enter 0, and click OK.

Step 18 Close the Registry Editor.

Step 19 In the Command window, enter Exit, and press Enter.

Step 20 On the Windows Start menu, click Programs > Cisco Unity.

Step 21 Right-click NodeMgr Monitor, and click Delete.

Step 22 Click Yes to confirm.

To Disable Sharing in the Directories Used by Failover on the Primary Server

Step 1 On the primary server, browse to the CommServer\Stream Files directory.

Step 2 Right-click the Stream Files directory, and click Sharing.

Step 3 In the Links Properties dialog box, on the Sharing tab, click Do Not Share This Folder, then click OK.

Step 4 Repeat Step 1 through Step 3 for the following five directories:

• CommServer\Snapshot

• CommServer\Support

• CommServer\UnityMTA

• CommServer\Localize\DefaultConfiguration

• CommServer\Localize\Prompts

To Stop SQL Replication on the Primary Server

Step 1 On the primary server, on the Windows Start menu, click Programs > Microsoft SQL Server > 
Enterprise Manager.

Step 2 In the left pane of the Console Root window, browse to the Replication node for the primary server. 
Typically, the node is three levels under the Microsoft SQL Servers node.

Step 3 Right-click the Replication node, and click Disable Publishing. The Disable Publishing and 
Distribution wizard appears.

Step 4 On the Welcome page, click Next.

Step 5 On the Disable Publishing page, click Yes, then click Next.

Step 6 On the Confirm Dropping of Publications page, click Next.

Step 7 On the Completing page, click Finish.

Step 8 When the process is completed, click OK.

Step 9 Close the Console Root window.

Step 10 Exit Enterprise Manager.
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To Remove the Secondary Server from the Environment 

Step 1 Disconnect the network cable from the secondary server.

Caution To prevent unexpected behavior from the former primary server, do not reconnect the 
secondary server to the network while the former primary server is connected and running.

Step 2 Reinstall the operating system on the secondary server to remove Cisco Unity failover from the hard 
disk.
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