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This document provides instructions for integrating the phone system with Cisco Unity.

Integration Tasks
Before doing the following tasks to integrate Cisco Unity with the SIP phone system, confirm that the 
Cisco Unity server is ready for the integration by completing the applicable tasks in the applicable 
Cisco Unity installation guide.

The following task list describes the process for creating the integration.

Task List to Create the Integration
Use the following task list to set up a new integration with the SIP phone system. If you are installing a 
new Cisco Unity server by using the applicable Cisco Unity installation guide, you may have already 
completed some of the following tasks.

1. Review the system and equipment requirements to confirm that all phone system and Cisco Unity 
server requirements have been met. See the “Requirements” section on page 2.

2. Plan how the voice messaging ports will be used by Cisco Unity. See the “Planning How the Voice 
Messaging Ports Will Be Used by Cisco Unity” section on page 4.

3. Program the SIP proxy server and other call processing components. See the “Programming the SIP 
Phone System” section on page 5.

4. Set up the SIP gateway that services Cisco Unity. See the “Configure the SIP Gateway Servicing 
Cisco Unity for the SIP Integration” section on page 6.

5. Create the integration. See the “Creating a New Integration with the SIP Phone System” section on 
page 7.

6. Test the integration. See the “Testing the Integration” section on page 12.
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Requirements
7. If you have a secondary server for Cisco Unity failover, integrate the secondary server. See the 
“Integrating a Secondary Server for Cisco Unity Failover” section on page 16.

Requirements
The SIP integration supports configurations of the following components:

Phone System

• SIP proxy server (Cisco SIP Proxy Server).

• SIP-enabled phones (for example, SIP-enabled Cisco IP Phone 7960 or Pingtel xpressa).

The SIP phones must use the REFER method for call transfers.

• SIP-enabled gateways (for example, Cisco AS5300 Access Server, Cisco 2600 series router, or 
Cisco 3600 series router) for access to the PSTN.

For details on compatibility of the phone system components with the integration, see the “Appendix: 
Compatibility of Phone System Components” section on page 18.

Cisco Unity Server

• Cisco Unity installed and ready for the integration, as described in the applicable Cisco Unity 
installation guide at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides_list.html.

• A license that enables the applicable number of voice messaging ports.

Network Configuration

• Cisco Unity server, SIP proxy server, SIP-enabled phones, and SIP-enabled gateways installed on 
the same subnet (ensures adequate bandwidth and avoids latency issues affecting integration 
behavior).

Integration Description
The SIP integration uses the SIP proxy server to set up communications between the voice messaging 
ports on the Cisco Unity server and the applicable end point (for example, a SIP-enabled phone). The 
communications occur through:

• An IP network (LAN, WAN, or Internet) to all SIP-enabled devices connected to it.

• A SIP-enabled gateway to the PSTN and all phones connected to it.

Figure 1 shows the connections.
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Integration Description
Figure 1 Connections Between the SIP Phone System and Cisco Unity

Call Information
The proxy server sends the following information in the SIP message with the calls forwarded:

• In the Diversion header, the extension of the called party

• In the Diversion header, the reason for the forward (the extension is busy, does not answer, or is set 
to forward all calls)

• In the From header, the extension of the calling party (for internal calls) or the SIP URL of the 
calling party (if it is an external call and the system uses caller ID)

Cisco Unity uses this information to answer the call appropriately. For example, a call forwarded to 
Cisco Unity is answered with the personal greeting of the subscriber. If the phone system routes the call 
to Cisco Unity without this information, Cisco Unity answers with the opening greeting.

Integration Functionality
The SIP integration with Cisco Unity provides the following integration features:

• Call forward to personal greeting

• Call forward to busy greeting

• Caller ID

• Easy message access (a subscriber can retrieve messages without entering an ID because 
Cisco Unity identifies the subscriber based on the extension from which the call originated; a 
password may be required)

• Identified subscriber messaging (Cisco Unity identifies the subscriber who leaves a message during 
a forwarded internal call, based on the extension from which the call originated)

• Message waiting indication (MWI)

Integrations with Multiple Phone Systems
Cisco Unity can be integrated with multiple phone systems at one time. For information on the maximum 
supported combinations and instructions for integrating Cisco Unity with multiple phone systems, refer 
to the applicable Multiple Phone System Integration Guide at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_installation_and_configuration_g
uides_list.html.
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Planning How the Voice Messaging Ports Will Be Used by 
Cisco Unity

Before programming the phone system, you need to plan how the voice messaging ports will be used by 
Cisco Unity.

Unlike other integrations, the hunt group mechanism for SIP integrations is implemented on the 
Cisco Unity server. Within an integration cluster, each incoming call hunts for an available voice 
messaging port among all the ports in a round-robin (or circular) fashion. If a voice messaging port in 
the cluster is set not to answer calls or is not enabled, a call reaching that port may receive a busy signal.

The following table describes the voice messaging port settings in Cisco Unity that can be set in UTIM, 
and that are displayed as read-only text on the System > Ports page of the Cisco Unity Administrator.

The Number of Voice Messaging Ports to Install

The number of voice messaging ports to install depends on numerous factors, including:

• The number of calls Cisco Unity will answer when call traffic is at its peak.

• The expected length of each message that callers will record and that subscribers will listen to.

• The number of subscribers.

• The number of calls made for message notification.

• The number of MWIs that will be activated when call traffic is at its peak.

• The number of AMIS delivery calls.

Table 1 Settings for the Voice Messaging Ports

Field Considerations

Enabled Check this check box.

Answer Calls Check this check box.

Caution All voice messaging ports connecting to the SIP proxy server must have the 
Answer Calls box checked. Otherwise, calls to Cisco Unity may not be answered.

Message Notification Check this check box to designate the port for notifying subscribers of messages. 

AMIS Delivery

(available with the AMIS 
licensed feature only)

Check this check box to designate the port for making outbound AMIS calls to deliver voice 
messages from Cisco Unity subscribers to users on another voice messaging system. 
Cisco Unity supports the Audio Messaging Interchange Specification (AMIS) protocol, 
which provides an analog mechanism for transferring voice messages between different 
voice messaging systems.

This setting affects outbound AMIS calls only. All ports are used for incoming AMIS calls.

Because the transmission of outgoing AMIS messages may tie up voice ports for long 
periods of time, you may want to adjust the schedule on the Network > AMIS > Schedule 
page so that outgoing AMIS calls are placed during closed hours or at times when 
Cisco Unity is not processing many calls.

TRAP Connection Check this check box so that subscribers can use the phone as a recording and playback 
device in Cisco Unity web applications and e-mail clients. 
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• The number of TRAP connections needed when call traffic is at its peak. (TRAP connections are 
used by Cisco Unity web applications to play back and record over the phone.)

• The number of calls that will use the automated attendant and call handlers when call traffic is at its 
peak.

It is best to install only the number of voice messaging ports that are needed so that system resources are 
not allocated to unused ports.

The Number of Voice Messaging Ports That Will Answer Calls

The calls that the voice messaging ports answer can be incoming calls from unidentified callers or from 
subscribers. Assign all of the voice messaging ports to answer calls.

You can set voice messaging ports to both answer calls and to dial out (for example, to set MWIs).

The Number of Voice Messaging Ports That Will Dial Out

Ports that will dial out can do one or more of the following:

• Notify subscribers by phone, pager, or e-mail of messages that have arrived.

• Turn MWIs on and off for subscriber extensions.

• Make outbound AMIS calls to deliver voice messages from Cisco Unity subscribers to users on 
another voice messaging system. (This action is available only with the AMIS licensed feature.)

• Make a TRAP connection so that subscribers can use the phone as a recording and playback device 
in Cisco Unity web applications.

Preparing for Programming the Phone System

Record your decisions about the voice messaging ports to guide you in programming the phone system.

Programming the SIP Phone System
If you use programming options other than those supplied in the following procedure, the performance 
of the integration may be affected.

Do the following procedure.

To Program the SIP Phone System

Step 1 Install and set up the SIP proxy server as described in the server documentation.

Step 2 Program each phone to forward calls to <the contact line name>@<SIP proxy server>, the voice 
messaging line name that subscribers will use to contact Cisco Unity.

Step 3 If Cisco Unity will authenticate with the SIP proxy server, enter a subscriber record for the contact line 
name that Cisco Unity will use.
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Configure the SIP Gateway Servicing Cisco Unity for the SIP 
Integration

To configure the SIP gateway for the SIP integration with Cisco Unity, do the following three 
procedures.

To Configure Application Session on the Sip Gateway

Step 1 On the VoIP dial-peer servicing Cisco Unity, use the following command:

application session

Step 2 Create a destination pattern that matches the voice messaging port numbers. For example, if the system 
has voice messaging ports 1001 through 1016, enter the dial-peer destination pattern 10xx.

Step 3 Repeat Step 1 and Step 2 for all remaining VoIP dial-peers servicing Cisco Unity.

To Disable the SIP Media Inactivity Timer

Step 1 On the gateway, go into the gateway configuration mode by entering the following command:

Router(config)# gateway

Step 2 Disable the RTCP timer by entering the following command:

Router(config-gateway)# no timer receive-rtcp

Step 3 Exit the gateway configuration mode by entering the following command:

Router(config-gateway)# exit

To Enable DTMF Relay for SIP Calls by Using Named Telephony Events

Step 1 On the gateway, go into dial-peer configuration mode and define the VoIP dial peer by entering the 
following command:

Router(config)# dial-peer voice <dial peer number> voip

Step 2 Configure the SIP protocol on the gateway by entering the following command:

Router(config-dial-peer)# session protocol sipv2

Step 3 Enable DTMF relay using NTE RTP packets by entering the following command:

Router(config-dial-peer)# dtmf-relay rtp-nte

Step 4 Configure the type of payload in the NTE packet by entering the following command:

Router(config-dial-peer)# rtp payload-type nte <NTE packet payload type>
6
Session Initiation Protocol (SIP) Integration Guide for Cisco Unity 5.0

OL-12119-02



 

Session Initiation Protocol (SIP) Integration Guide for Cisco Unity 5.0
Creating a New Integration with the SIP Phone System
Creating a New Integration with the SIP Phone System
After ensuring that the SIP phone system and the Cisco Unity server are ready for the integration, do the 
following procedures to set up the integration and to enter the port settings.

To Create an Integration

Step 1 If UTIM is not already open, on the Windows Start menu of the Cisco Unity server, click Programs > 
Cisco Unity > Manage Integrations. UTIM appears.

Step 2 In the left pane of the UTIM window, click Cisco Unity Server.

Step 3 On the Integration menu of the UTIM window, click New. The Telephony Integration Setup Wizard 
appears.

Step 4 On the Welcome page, click SIP (including CUCM/CCM) and click Next.

Step 5 On the Name This SIP Integration and Cluster page, enter the following settings, then click Next.

Step 6 On the Enter Primary and Secondary SIP Server page, enter the following settings, then click Next.

You can click Ping Servers to confirm that the IP address is correct.

Step 7 On the Set Number of Voice Messaging Ports page, enter the number of voice messaging ports on 
Cisco Unity that you want to connect to the SIP server, then click Next.

This number must not be more than the number of ports set up on the SIP server.

Step 8 On the Configure Cisco Unity SIP Settings page, enter the following settings, then click Next.

Table 2 Settings for the Name This SIP Integration and Cluster Page

Field Setting

Integration Name <the name you will use to identify this SIP integration; accept the default name 
or enter another name>

Cluster Name <the name you will use to identify this SIP server cluster; accept the default 
name or enter another name>

Table 3 Settings for the Enter Primary and Secondary SIP Server Page

Field Setting

Primary:
IP Address/Name

<the IP address of the primary SIP server that you are connecting to 
Cisco Unity>

Primary:
Port

<the IP port of the primary SIP server that you are connecting to Cisco Unity>

Secondary:
IP Address/Name

<optional; the IP address of the secondary SIP server that you are connecting 
to Cisco Unity>

Secondary:
Port

<optional; the IP port of the secondary SIP server that you are connecting to 
Cisco Unity>
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Step 9 On the Enter SIP Server Authentication page, enter the following settings, then click Next.

Step 10 If other integrations already exist, the Enter Trunk Access Code page appears. Enter the extra digits that 
Cisco Unity must use to transfer calls through the gateway to extensions on the other phone systems with 
which it is integrated. Then click Next.

Step 11 On the Reassign Subscribers page, any subscribers whose phone system integration has been deleted and 
who are not currently assigned to a phone system integration will appear in the list.

If no subscribers appear in the list, click Next and continue to Step 12.

Otherwise, select the subscribers that you want to assign to this phone system integration and click Next. 
You can use the following selection controls for selecting subscribers.

Step 12 On the Reassign Call Handlers page, any call handlers whose phone system integration has been deleted 
and that are not currently assigned to a phone system integration will appear in the list.

If no call handlers appear in the list, click Next and continue to Step 13.

Table 4 Settings for the Configure Cisco Unity SIP Settings Page

Field Setting

Contact Line Name <the voice messaging line name that subscribers will use to contact 
Cisco Unity and that Cisco Unity uses to register with the SIP server>

Cisco Unity SIP Port <the IP port on Cisco Unity that callers and the SIP server use to connect to 
voice mail; we recommend using the default setting>

Preferred Codec <the codec Cisco Unity will first attempt to use on outgoing calls>

Preferred Transport 
Protocol

Click UDP.

Table 5 Settings for the Enter SIP Server Authentication Page

Field Setting

Authenticate with the 
SIP Server

<your indication whether Cisco Unity will authenticate with the SIP server>

Name <the name the SIP server will use for authentication>

Password <the password the SIP server will use for authentication>

Table 6 Selection Controls for the Reassign Subscribers Page

Selection Control Effect

Check All Checks the check boxes for all subscribers in the list.

Uncheck All Unchecks the check boxes for all subscribers in the list.

Toggle Selected For the subscribers highlighted in the list, toggles between checking and 
unchecking the check boxes.

If some highlighted subscriber check boxes are checked and others are 
unchecked, clicking this button will check all the check boxes. Clicking again 
will uncheck all the check boxes.
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Otherwise, select the call handlers that you want to assign to this phone system integration and click 
Next. You can use the following selection controls for selecting call handlers.

Step 13 On the Completing page, verify the settings you entered, then click Finish.

Step 14 At the prompt to restart the Cisco Unity services, click Yes. The Cisco Unity services restart.

Alternatively, you can restart the Cisco Unity services in UTIM on the Tools menu by clicking Restart 
Cisco Unity.

Unlike other integrations, the hunt group mechanism for SIP integrations is implemented on the 
Cisco Unity server. Within an integration cluster, each incoming call hunts for an available voice 
messaging port among all the ports in a round-robin fashion. If a voice messaging port in the cluster is 
set not to answer calls or is not enabled, a call reaching that port may receive a busy signal.

To Enter the Voice Messaging Port Settings for the Integration

Step 1 After the Cisco Unity services restart, on the View menu, click Refresh.

Step 2 In the left pane of the UTIM window, expand the phone system integration that you are creating.

Step 3 In the left pane, click the name of the phone system.

Step 4 In the right pane, click the Ports tab.

Step 5 Enter the settings shown in Table 8 for the voice messaging ports.

Table 7 Selection Controls for the Reassign Call Handlers Page

Selection Control Effect

Check All Checks the check boxes for all call handlers in the list.

Uncheck All Unchecks the check boxes for all call handlers in the list.

Toggle Selected For the call handlers highlighted in the list, toggles between checking and 
unchecking the check boxes.

If some highlighted call handler check boxes are checked and others are 
unchecked, clicking this button will check all the check boxes. Clicking again 
will uncheck all the check boxes.

Table 8 Settings for the Voice Messaging Ports

Field Considerations

Enabled Check this check box.

Answer Calls Check this check box.

Caution All voice messaging ports connecting to the SIP proxy server must have the 
Answer Calls box checked. Otherwise, calls to Cisco Unity may not be answered.

Message Notification Check this check box to designate the port for notifying subscribers of messages. 
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Step 6 Click Save.

Step 7 Exit UTIM.

Step 8 When integrated with a SIP phone system, Cisco Unity can use a non-20 ms packet size. See the 
following table to determine whether you must enable a non-20 ms packet size for your system.

To Enable a Non-20 ms Packet Size on Cisco Unity

Step 1 On the Windows Start menu, click Run.

Step 2 Enter regedit and click OK. The Registry Editor window appears.

AMIS Delivery

(available with the AMIS 
licensed feature only)

Check this check box to designate the port for making outbound AMIS calls to deliver voice 
messages from Cisco Unity subscribers to users on another voice messaging system. 
Cisco Unity supports the Audio Messaging Interchange Specification (AMIS) protocol, 
which provides an analog mechanism for transferring voice messages between different 
voice messaging systems.

This setting affects outbound AMIS calls only. All ports are used for incoming AMIS calls.

Because the transmission of outgoing AMIS messages may tie up voice ports for long 
periods of time, you may want to adjust the schedule on the Network > AMIS > Schedule 
page so that outgoing AMIS calls are placed during closed hours or at times when 
Cisco Unity is not processing many calls.

TRAP Connection Check this check box so that subscribers can use the phone as a recording and playback 
device in Cisco Unity web applications and e-mail clients. 

Cisco Unity uses only the 20 ms 
packet size

Non-20 ms packet sizes are not needed. Skip to the “Testing the 
Integration” section on page 12.

Cisco Unity uses a non-20 ms 
packet size

If your system meets one of the following conditions, you must enable 
a non-20 ms packet size on Cisco Unity:

• The SIP endpoints do not support ptime, and the SIP phone system 
uses a non-20 ms packet size.

• You want Cisco Unity to initiate calls with a non-20ms packet size.

Continue to the procedure “To Enable a Non-20 ms Packet Size on 
Cisco Unity” procedure on page 10.

Note Cisco Unity does not support different packet-size intervals for 
sending and receiving.

Table 8 Settings for the Voice Messaging Ports (continued)

Field Considerations
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Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that for Cisco Unity 
failover, registry changes on one Cisco Unity server must be made manually on the other 
Cisco Unity server, because registry changes are not replicated. If you have any questions 
about changing registry key settings, contact Cisco TAC.

Step 3 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 4 Select the key 
HKEY_LOCAL_MACHINE\Software\ActiveVoice\MIU\1.0\Initialization\Integrations\Integration<n> 
where <n> is the number of the SIP integration.

Step 5 On the Edit menu, click New > DWORD Value.

Step 6 In the right pane, for the name of the new value, enter G711 Packetization and press Enter.

Step 7 On the Edit menu, click New > DWORD Value.

Step 8 In the right pane, for the name of the new value, enter G729 Packetization and press Enter.

Step 9 Double-click the G711 Packetization value.

Step 10 In the Edit DWORD Value dialog box, Under Base, click Decimal.

Step 11 In the Value Data field, enter one of the following values that you want to use for the packet size (in ms) 
for the G.711 codec:

• 10

• 20

• 30

Caution If you enter a setting other than one that appears in the list above, Cisco Unity will use the 
20 ms default packet size.

Step 12 Click OK.

Step 13 Double-click the G729 Packetization value.

Step 14 In the Edit DWORD Value dialog box, Under Base, click Decimal.

Step 15 In the Value Data field, enter one of the following values that you want to use for packet size (in ms) for 
the G.729 codec:

• 10

• 20

• 30

• 40

• 50

• 60

Caution If you enter a setting other than one that appears in the list above, Cisco Unity will use the 
20 ms default packet size.
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Step 16 Click OK.

Step 17 Close the Registry Editor window.

Step 18 Restart the Cisco Unity server for these changes to take effect.

Step 19 If Cisco Unity is configured for failover, repeat this procedure on the secondary server.

When a non-20 ms packet size is enabled and depending on the situation, Cisco Unity will use the 
following packet sizes:

• When the initial SDP offer does not contain a ptime attribute, Cisco Unity will use the enabled 
packet size.

• When the initial SDP offer contains a ptime attribute, Cisco Unity will use the requested packet size.

• When Cisco Unity initiates the initial SDP offer, Cisco Unity will use the enabled packet size.

Testing the Integration
To test whether Cisco Unity and the phone system are integrated correctly, do the following procedures 
in the order listed.

If any of the steps indicate a failure, refer to the following documentation as applicable:

• The installation guide for the phone system.

• Cisco Unity Troubleshooting Guide, available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_troubleshooting_guides_list.html.

• The setup information earlier in this guide.

To Set Up the Test Configuration

Step 1 Set up two test extensions (Phone 1 and Phone 2) on the same phone system that Cisco Unity is 
connected to.

Step 2 Set Phone 1 to forward calls to the Cisco Unity pilot number when calls are not answered.

Caution The phone system must forward calls to the Cisco Unity pilot number in no fewer than four 
rings. Otherwise, the test may fail.

Step 3 In the Cisco Unity Administrator, create a test subscriber to use for testing by doing the applicable 
substeps below.

If your message store is Microsoft Exchange, do the following:

a. In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Profile page.

b. Click the Add icon.

c. In the New subscriber field, click Exchange.

d. On the Add Subscriber page, enter the applicable information.

e. Click Add.
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If your message store is IBM Lotus Domino, do the following:

a. In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Profile page.

b. Click the Add icon.

c. In the New Subscriber field, click Notes.

d. In the Address Book list, confirm that the address book listed is the one that contains the user data 
that you want to import.

If the address book that you want to use is not listed, go to the System > Configuration > 
Subscriber Address Books page and add a different address book.

e. In the Find Domino Person By list, indicate whether to search by short name, first name, or last 
name.

f. Enter the applicable short name or name. You also can enter * to display a list of all users, or enter 
one or more characters followed by * to narrow your search.

g. Click Find.

h. On the list of matches, click the name of the user to import.

i. On the Add Subscriber page, enter the applicable information.

j. Click Add.

Step 4 In the Extension field, enter the extension of Phone 1.

Step 5 In the Active Schedule field, click All Hours - All Days.

Step 6 Click the Save icon.

Step 7 In the navigation bar, click Call Transfer to go to the Subscribers > Subscribers > Call Transfer page 
for the test subscriber.

For more information on transfer settings, refer to the “Subscriber Template Call Transfer Settings” 
section in the Cisco Unity Administrator Help.

Step 8 In the Transfer Rule Applies To field, click Standard.

Step 9 Under Transfer Incoming Calls, click Yes, Ring Subscriber’s Extension, and confirm that the extension 
number is for Phone 1.

Step 10 Under Transfer Type, click Release to Switch.

Step 11 Click the Save icon.

Step 12 In the navigation bar, click Messages to go to the Subscribers > Subscribers > Messages page for the test 
subscriber.

Step 13 Under Message Waiting Indicators (MWIs), check Use MWI for Message Notification.

Step 14 In the Extension field, enter x.

Step 15 Click the Save icon.

Step 16 Open the Status Monitor by doing one of the following:

• In Internet Explorer, go to http://<Cisco Unity server name>/web/sm.

• Double-click the desktop shortcut to the Status Monitor.

• In the status bar next to the clock, right-click the Cisco Unity tray icon and click Status Monitor.
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To Test an External Call with Release Transfer

Step 1 From Phone 2, enter the access code necessary to get an outside line, then enter the number outside 
callers use to dial directly to Cisco Unity.

Step 2 On the Status Monitor, note which port handles this call.

Step 3 When you hear the opening greeting, enter the extension for Phone 1. Hearing the opening greeting 
means that the port is configured correctly.

Step 4 Confirm that Phone 1 rings and that you hear a ringback tone on Phone 2. Hearing a ringback tone means 
that Cisco Unity correctly released the call and transferred it to Phone 1.

Step 5 Leaving Phone 1 unanswered, confirm that the state of the port handling the call changes to “Idle.” This 
state means that release transfer is successful.

Step 6 Confirm that, after the number of rings that the phone system is set to wait, the call is forwarded to 
Cisco Unity and that you hear the greeting for the test subscriber. Hearing the greeting means that the 
phone system forwarded the unanswered call and the call-forward information to Cisco Unity, which 
correctly interpreted the information.

Step 7 On the Status Monitor, note which port handles this call.

Step 8 Leave a message for the test subscriber and hang up Phone 2.

Step 9 On the Status Monitor, confirm that the state of the port handling the call changes to “Idle.” This state 
means that the port was successfully released when the call ended.

Step 10 Confirm that the MWI on Phone 1 is activated. The activated MWI means that the phone system and 
Cisco Unity are successfully integrated for turning on MWIs.

To Test Listening to Messages

Step 1 From Phone 1, enter the internal pilot number for Cisco Unity.

Step 2 When asked for your password, enter the default password. Hearing the request for your password means 
that the phone system sent the necessary call information to Cisco Unity, which correctly interpreted the 
information.

Step 3 Confirm that you hear the recorded voice name for the test subscriber (if you did not record a voice name 
for the test subscriber, you will hear the extension number for Phone 1). Hearing the voice name means 
that Cisco Unity correctly identified the subscriber by the extension.

Step 4 When asked whether you want to listen to your message, press 1.

Step 5 After listening to the message, press 3 to delete the message.

Step 6 Confirm that the MWI on Phone 1 is deactivated. The deactivated MWI means that the phone system and 
Cisco Unity are successfully integrated for turning off MWIs.

Step 7 Hang up Phone 1.

Step 8 On the Status Monitor, confirm that the state of the port handling the call changes to “Idle.” This state 
means that the port was successfully released when the call ended.
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To Set Up Supervised Transfer on Cisco Unity

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Call Transfer page.

If the name of the test subscriber is not displayed, click the Find icon (the magnifying glass) in the title 
bar, then click Find, and select the name of the test subscriber in the list that appears.

For more information on transfer settings, refer to the “Subscriber Template Call Transfer Settings” 
section in the Cisco Unity Administrator Help.

Step 2 Under Transfer Type, click Supervise Transfer.

Step 3 Set the Rings to Wait For field to 3.

Step 4 Click the Save icon.

To Test Supervised Transfer

Step 1 From Phone 2, enter the access code necessary to get an outside line, then enter the number outside 
callers use to dial directly to Cisco Unity.

Step 2 On the Status Monitor, note which port handles this call.

Step 3 When you hear the opening greeting, enter the extension for Phone 1. Hearing the opening greeting 
means that the port is configured correctly.

Step 4 Confirm that Phone 1 rings and that you do not hear a ringback tone on Phone 2. Instead, you should 
hear the indication your phone system uses to mean that the call is on hold (for example, music or beeps).

Step 5 Leaving Phone 1 unanswered, confirm that the state of the port handling the call remains “Busy.” This 
state and hearing an indication that you are on hold mean that Cisco Unity is supervising the transfer.

Step 6 Confirm that, after three rings, you hear the greeting for the test subscriber. Hearing the greeting means 
that Cisco Unity successfully recalled the supervised-transfer call.

Step 7 During the greeting, hang up Phone 2.

Step 8 On the Status Monitor, confirm that the state of the port handling the call changes to “Idle.” This state 
means that the port was successfully released when the call ended.

To Delete the Test Subscriber

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Profile page.

If the name of the test subscriber is not displayed, click the Find icon (the magnifying glass) in the title 
bar, then click Find, and select the name of the test subscriber in the list that appears.

Step 2 In the title bar, click the Delete Subscriber icon (the X).

Step 3 Click Delete.

Step 4 When prompted to confirm deleting the subscriber, click OK.
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Integrating a Secondary Server for Cisco Unity Failover
The Cisco Unity failover feature enables a secondary server to provide voice messaging services when 
the primary server becomes inactive. For information on installing a secondary server for failover, refer 
to the applicable Cisco Unity installation guide, available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides_list.html.

For information on failover, refer to the applicable Cisco Unity Failover Guide at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_feature_guides_list.html.

Requirements
The following components are required to integrate a secondary server:

• One secondary server for each primary server installed and ready for the integration, as described in 
the applicable Cisco Unity installation guide and earlier in this integration guide.

• A license that enables failover.

Integration Description
The phone system communicates with both the primary and secondary servers through the LAN or 
WAN. Figure 2 shows the required connections.

Figure 2 Connections Between the SIP Proxy Server and the Cisco Unity Servers

The primary and secondary servers act in the following manner:

• When the primary server is operating normally, the secondary server is inactive.

• When the primary server becomes inactive, the secondary server becomes active.

• When the primary server becomes active again, the secondary server becomes inactive.

Primary
Cisco Unity server

Secondary
Cisco Unity server

LAN

76
28

3

IP

SIP proxy
server
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Setting Up the Secondary Server for Failover
Do the following procedure to integrate the secondary server.

To Set Up the Secondary Server for Failover

Step 1 Install a secondary server with the same configuration as the primary server. For installation instructions, 
refer to the applicable Cisco Unity installation guide.

Step 2 On the Windows Start menu of the secondary server, click Programs > Cisco Unity > Manage 
Integrations. The UTIM window appears.

Step 3 On the Integration menu of the UTIM window, click New. The Telephony Integration Setup Wizard 
appears.

Step 4 Enter the settings to match the integration settings on the primary server.

The Contact Line Name must be the same for both the primary and secondary servers.

Note We recommend not reassigning any unassigned subscribers and call handlers to the new 
integration, if you are asked by the wizard. Failover replication will automatically assign the 
correct integration.

Step 5 At the prompt to restart the Cisco Unity services, click Yes.

Note When restarting the Cisco Unity services, use the UTIM prompt instead of the Cisco Unity icon 
in the Windows taskbar. The taskbar icon does not restart all of the Cisco Unity services.

Step 6 After Cisco Unity restarts, on the Windows Start menu of the Cisco Unity server, click Programs > 
Cisco Unity > Manage Integrations. UTIM appears.

Step 7 In the left pane of the UTIM window, click the phone system integration that you created in Step 3.

Step 8 In the right pane, click Properties.

Step 9 On the Integration tab, compare the setting of the Integration ID field for the secondary server to the 
setting of the Integration ID field for the primary server.

Step 10 If the integration IDs of the phone system on the primary and secondary server are the same, continue 
to Step 16.

If the integration IDs of the phone system on the primary and secondary servers are different, on the 
secondary server, click Modify Integration ID.

Step 11 When cautioned that subscribers associated with the current Integration ID setting will not be 
automatically associated with the new Integration ID setting, click OK.

Step 12 In the Modify Integration ID dialog box, in the Enter New Integration ID field, enter the Integration ID 
setting for the phone system on the primary server and click OK.

Step 13 Click Save.

Step 14 At the prompt to restart the Cisco Unity services, click Yes.

Step 15 In the left pane, click the phone system integration that you created in Step 3.

Step 16 In the right pane of the UTIM window, click the Ports tab.

Step 17 Enter the port settings to match the port settings on the primary server.
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Appendix: Compatibility of Phone System Components
Integrating a Secondary Server for Cisco Unity Failover
Caution In programming the SIP proxy server, do not send calls to voice messaging ports in 
Cisco Unity that cannot answer calls (voice messaging ports that are not set to Answer Calls). 
For example, if a voice messaging port is set only to Dialout MWI, do not send calls to it.

Step 18 Click Save.

Step 19 Exit UTIM.

Appendix: Compatibility of Phone System 
Components

Testing has shown compatibility of the following phone system components with Cisco Unity in a SIP 
integration.

Table 9 Cisco SIP Proxy Server Compatibility with the Integration

Version Comments

1.3 If Cisco Unity authenticates with the SIP proxy server, the authentication 
name entered in Cisco Unity must be the same as the contact line name in 
the SIP proxy server.

2.0 If Cisco Unity authenticates with the SIP proxy server, the authentication 
name entered in Cisco Unity must be the same as the contact line name in 
the SIP proxy server.

Table 10 Cisco 7960 IP Phone Compatibility with the Integration

Version Comments

7960 P0S3-03-1-00

7960 P0S3-03-2-00

7960 P0S3-04-0-00 When the phone initiates a call, release transfer of the call is not available 
to Cisco Unity.

7960 P0S3-04-1-00 When the phone initiates a call, release transfer of the call is not available 
to Cisco Unity.

7960 P0S3-04-2-00
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Integrating a Secondary Server for Cisco Unity Failover
Other compatibility issues are:

• The Pingtel xpressa cannot connect to a backup SIP proxy server.

• To enable call forwarding when Cisco Unity is configured for failover, set the forwarding 
destinations in MySQL to be <contact line name>@proxy instead of <contact line name>@Unity.

• Caveat: CSCdx74350.

• Caveat: CSCdx66707.

• Caveat: CSCdx71968.

Table 11 Pingtel xpressa Compatibility with the Integration

Version Comments

1.2.6 To get the call forwarding to busy greeting integration feature, forwarding 
must be programmed on the SIP proxy server rather than configured on the 
Pingtel xpressa phones.

2.0.1
2.0.2

Not compatible. Silence is inserted into the audio stream every few 
seconds.

To get the call forwarding to busy greeting integration feature, forwarding 
must be programmed on the SIP proxy server rather than configured on the 
Pingtel xpressa phones.

Table 12 Gateway IOS Compatibility with the Integration

Version Comments

12.2(2)XB4

12.2(2)XB6
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Conventions
Appendix: Documentation and Technical 
Assistance

Conventions
The Session Initiation Protocol (SIP) Integration Guide for Cisco Unity 5.0 uses the following 
conventions.

The Session Initiation Protocol (SIP) Integration Guide for Cisco Unity 5.0 also uses the following 
conventions:

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
document.

Table 13 Session Initiation Protocol (SIP) Integration Guide for Cisco Unity 5.0 Conventions

Convention Description

boldfaced text Boldfaced text is used for:

• Key and button names. (Example: Click OK.)

• Information that you enter. (Example: Enter Administrator in the User 
Name box.)

< > 

(angle brackets)

Angle brackets are used around parameters for which you supply a value. 
(Example: In the Command Prompt window, enter ping <IP address>.)

- 

(hyphen)

Hyphens separate keys that must be pressed simultaneously. (Example: Press 
Ctrl-Alt-Delete.)

> 

(right angle 
bracket)

A right angle bracket is used to separate selections that you make:

• On menus. (Example: On the Windows Start menu, click Settings > Control 
Panel > Phone and Modem Options.)

• In the navigation bar of the Cisco Unity Administrator. (Example: Go to the 
System > Configuration > Settings page.)

[x]

(square brackets)

Square brackets enclose an optional element (keyword or argument). (Example: 
[reg-e164])

[x | y]

(vertical line)

Square brackets enclosing keywords or arguments separated by a vertical line 
indicate an optional choice. (Example: [transport tcp | transport udp])

{x | y}

(braces)

Braces enclosing keywords or arguments separated by a vertical line indicate a 
required choice. (Example: {tcp | udp})
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Appendix: Documentation and Technical Assistance
Obtaining Documentation, Obtaining Support, and Security Guidelines
Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data.

For descriptions and URLs of Cisco Unity documentation on Cisco.com, see the About Cisco Unity 
Documentation. The document is shipped with Cisco Unity and is available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_documentation_roadmaps_list.ht
ml.

Obtaining Documentation, Obtaining Support, and Security 
Guidelines

For information on obtaining documentation, obtaining support, providing documentation feedback, 
security guidelines, and also recommended aliases and general Cisco documents, see the monthly 
What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical 
documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and 
figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and 
coincidental.

© 2007 Cisco Systems, Inc. All rights reserved.
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