CHAPTER 6

Renaming a Cisco Unity Server or Moving a
Cisco Unity Server to Another Domain

This chapter contains the following sections:

» Renaming a Cisco Unity Server or Moving a Cisco Unity Server to Another Domain (Without
Failover), page 6-1

- Renaming Both Cisco Unity Servers or Moving the Servers to Another Domain (With Failover
Configured), page 6-6

Renaming a server and moving a server to another domain are not related, but the procedures are nearly
identical.

Renaming a Cisco Unity Server or Moving a Cisco Unity
Server to Another Domain (Without Failover)

A

Do the procedure in this section to change the Windows name of a Cisco Unity server or to move a
Cisco Unity server that is a member server in one domain to a different domain (for example, to move
the server from a Windows NT domain to a Windows Server 2003 domain).

The procedure in this section requires that you use the Cisco Unity Disaster Recovery tools (DiRT),
which are supported for Domino with Cisco Unity 4.0(3) and later only. To rename a Cisco Unity server
or move the server to another domain when it is running version 4.0(2) or earlier, first upgrade the
existing server to the shipping version, then rename the server by doing the procedure in this section.

Caution

A

When you reinstall software, you must install the exact version of Cisco Unity that was installed when
you backed up the server. The Disaster Recovery Restore tool can restore data only to the exact version
of Cisco Unity that was backed up.

Caution

Do the procedure only if the Cisco Unity server isthe only server in the domain or if it is a member
server. If the Cisco Unity server isthe domain controller and it is not the only server in the domain, refer
to Microsoft documentation for information on installing Active Directory on another server in the
domain, transferring roles from the Cisco Unity server to the new domain controller, and other
applicable tasks before you rename the Cisco Unity server or move it to another domain.
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Step 1

Step 2

Step 3

Step 4

Step 5

Step 6

To Rename a Cisco Unity Server or Move a Cisco Unity to Another Domain (Without Failover)

Confirmthat you have all of the disks necessary to reinstall the version of Cisco Unity currently installed
on the Cisco Unity server. When you use DiRT to back up and restore Cisco Unity data, you must restore
to the same version of Cisco Unity that you backed up.

Download the latest versions of the following applications to a network drive:

« The Cisco Unity Directory Walker (DbWalker) utility. The version for Cisco Unity 4.x is available
at http://ciscounitytools.com/App_DirectoryWalker4.htm. The version for Cisco Unity 3.1(x) is
available at http://ciscounitytools.com/App_DirectoryWalker3.htm.

» The Cisco Unity Disaster Recovery Backup tool and Disaster Recovery Restore tool, available at
http://ciscounitytools.com/App_DisasterRecoveryTools.htm.

On the Cisco Unity server, install the versions of DbWalker and the Disaster Recovery Backup tool that
you downloaded in Step 2.

~

Note Do notinstall the Disaster Recovery Restore tool now. When you reinstall the operating system,
you delete all partitions, which deletes all data and applications.

Run DbWalker, and correct al errors that the utility finds. Refer to DbWalker Help for detailed
instructions on running the utility and on correcting errors in the database. (The Help file,
DbWalker.htm, isin the same directory as DbWalker.exe.)

Back up Cisco Unity data by using the Disaster Recovery Backup tool. Refer to DiRT Help for detailed
instructions. (The Help file, UnityDisasterRecovery.htm, isin the same directory as
UnityDisasterRecoveryBackup.exe.)

A

Caution  Follow Help carefully. DiRT includes avariety of options that you must understand to use the
tools successfully. In addition, the account you are logged on as when you back up
Cisco Unity data must have sufficient permissions or the backup will fail.

Reinstall all software on the Cisco Unity server, including the operating system, by following the
instructions in the applicable Cisco Unity installation guide for your configuration at
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides list.html.

A

Caution  You must install the same version of Cisco Unity that was previously installed. Otherwise, the
Disaster Recovery Restore tool cannot restore the data that you backed up earlier in this
procedure.

Note the following:

« If you use aretail Windows disk to install Windows, delete and recreate all partitions to ensure that
old applications and data are deleted.

« When you configure Windows, if there is more than one Cisco Unity server in the Active Directory
forest, give each Cisco Unity server aname that is unique in the first 14 characters, or Cisco Unity
will have problems communicating with the Lotus Domino accounts created by Cisco Unity. For
example, the following names would cause communication problems: CiscoUnitySrvrl and
CiscoUnitySrvr2.
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« If you are not replacing the phone system, you can skip the task on setting up or programming the
phone system.

» Install the same version of Cisco Unity that was running when you backed up Cisco Unity data.
DiRT Restore can only restore data to the same version of Cisco Unity that you backed up.

- If you areinstalling Cisco Unity 4.2(1) or later, and if you are making the Cisco Unity server a
member server in an existing domain, add the server to a Windows 2000 Server domain or Windows
Server 2003 domain. Beginning with Cisco Unity 4.2(1), adding the Cisco Unity server to a
Windows NT domain is not supported.

On the Cisco Unity server, install the version of the Disaster Recovery Restore tool that you downloaded
in Step 2.

Restore Cisco Unity data by using the Disaster Recovery Restore tool and the backup that you made
earlier. Refer to DIRT Help for detailed instructions. (The Help file, UnityDisasterRecovery.htm, isin
the same directory as UnityDisasterRecoveryRestore.exe.)

A

Caution  Follow Help carefully. DiRT includes avariety of options that you must understand to use the
tools successfully.

Reapply any non-Cisco Unity custom registry settings. (DiRT backs up and restores Cisco Unity registry
settings.)

Enabling Subscribers to Use the Phone for Recording and Playback

Note

IBM Lotus Notes with IBM Lotus Domino Unified Communications (DUC) for Cisco offersa

V CR-style recorder/player in the message form. Subscribers can customize it to use a phone or a
computer microphone and speakers as the recording and playback device. However, when you rename a
Cisco Unity server, aphone does not work as arecording or playback device unless you manually update
the Cisco Unity server name specified in each subscriber mail file.

To correct the problem, you can either run an agent on a Domino server to change each subscriber mail
file and push the changed mail files out to subscriber workstations, or you can provide subscribers with
an agent that the subscriber runs on the workstation to change the server name in the mail file.

You do not need to change anything for subscribers who use a computer microphone and speakers as
their recording and playback devices.

The agents are located on the Cisco Unity server.

» The CommServer\Utilities\Domino\Agents\ClientUpdateUCProfileforTrap directory contains the
following files:

— ClUpUn.nsf—The agent that subscribers run on their workstations to change the Cisco Unity
server name in their mail file. Note that the agent must be modified with the Cisco Unity server
name before it is run.

— Client Update Unity Profile Agent.txt—A text file that contains the L otusScript in ClUpUn.nsf.
Note that the script must be modified with the Cisco Unity server name before it is run.

— Readme.txt—A text file with instructions on using the agent.
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» The CommServer\Utilities\Domino\Agents\UpdateU CProfileforTrap directory contains the
following files:

— UpdateUn.nsf—The agent that isrun on aDomino server to change the Cisco Unity server name
in each subscriber mail file. Note that the agent must be modified with the Cisco Unity server
name and Domino server name before it is run.

— Update Unity Profile Agent.txt—A text file that containsthe L otusScript in UpdateUn.nsf. Note
that the script must be modified with the Cisco Unity server name and Domino server name
beforeitis run.

— AgentLog.nsf—A Notes database that stores output from the agent that is run on the Domino
server.

— Readme.txt—A text file with instructions on using the agent.
See the following procedures for details on modifying and running the agents:

» To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server, page
6-4

- To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber
Workstation, page 6-5

» To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation, page 6-6

The following procedure is specific to Domino R6.5 and assumes that you have Full Access
Administration rights or have been added to the access control list (ACL) of each subscriber mail file
with sufficient rights. Change the steps as necessary if you are running another version of Domino.

The procedure describes using Update Unity Profile Agent.txt, but if you are familiar with agents, you
can modify UpdateUn.nsf in Domino Designer by using the steps as a guideline.

To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server

Stepl  Copy the Update Unity Profile Agent.txt located in the
CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory on the Cisco Unity server to
the Domino server where you will run Domino Designer.

Step2  Copy AgentL og.nsf to your Domino data directory.
Step3  Open Domino Designer, click Open an Existing Database, and open Names.nsf.

Step4  Inthe Design pane for names.nsf (the pane on the left, underneath Recent Databases), click Shared
Code > Agents.

Step5  Intheright pane, click the New Agent button. The Agent Properties box appears.
Step6  On the Basicstab, enter a name for the agent in the Name field.

Step7  Inthe Runtime section, for the Target, click None.

Step8  Close the Agent Properties box.

Step9  Inthe Programmer’s pane on theright, click L otusScript from the Run menu.
Step 10  On the Objects tab, click Declarations.

Step 11  Openthefile Update Unity Profile Agent.txt in Notepad, and copy the text from the beginning of thefile
to the line right above the line that contains “ Sub Initialize.” (Do not copy the “ Sub Initialize” line.)

Step 12 Paste the text in the Script area of the Programmer’s pane in Domino Designer.
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Modify the agent text in the Script area of the Programmer’s pane as follows:

» Replace the const values AGENTLOG_SERVER and DUC_SERVER with your Domino server
name.

» Replace the const value NEW_UNITY_SERVER_NAME with the new Cisco Unity server name.
Be sure that the server names are encapsulated in double quotes.

In the Objects tab, click Initialize. The lines “ Sub Initialize” and “End Sub” with ablank line between
them are displayed in the Script area of the Programmer’s pane.

Inthefile Update Unity Profile Agent.txt in Notepad, copy the text between (but not including) thelines
“Sub Initialize” and “End Sub.”

Paste the text in the Script area of the Programmer’s pane on the blank line between the lines “ Sub
Initialize” and “End Sub.”

Exit Notepad.

Close and save the agent, and exit Domino Designer.

Open the Domino Administrator, click File > Database > Open, and open names.nsf.
Click Actions > <Your Agent Name> to run the agent.

Repeat Step 1 through Step 20 on every Domino server containing subscriber mail files that you want to
change.

Subscribers will need to exit and reopen Notes on their workstations for the change to take effect.

The procedure below is specific to Notes R6.5. Modify the steps as needed for other Notes versions. If
you will be providing these instructions to subscribers, you will also need to provide them with the name
of the Cisco Unity server. Consider customizing the instructions below with the name of your

Cisco Unity server.

Note that the file Client Update Unity Profile Agent.txt contains only one line of script, and it is given
in the procedure.

To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber Workstation

On a subscriber workstation, start Notes and open the subscriber mail file.
Click Create > Agent. The Agent Properties box appears.

On the Basics tab, enter a name for the agent in the Name field.

In the Runtime section, for the Target, click None.

Close the Agent Properties box.

In the Programmer’s pane on the right, click For mula from the Run menu.
Copy and paste the following text to the Script area of the Programmer’s pane:
@SetProfileField("ucprofile";"VoiceServerList";"<NewUnityServerName>");
Replace <NewUnityServerName> with your Cisco Unity server name.

Verify that the server name is enclosed in double quotes, that each argument is separated with a
semicolon, and that the entire formula ends with a semicolon.
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Step 10  Close and save the Agent.

To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation

Stepl  On asubscriber workstation, start Notes and open the subscriber mail file.
Step2  Click Action > <Agent Name>, where <Agent Name> is the name of the applicable agent.
Step3  Exit and then re-open Notes.

Renaming Both Cisco Unity Servers or Moving the Serversto
Another Domain (With Failover Configured)

This section describes how to rename both the primary server and the secondary server, or how to move
both servers to another domain Active Directory domain. (Both servers must be in the same domain.)

The following items are required:
« Thelatest versions of the following applications:

— The Cisco Unity Directory Walker (DbWalker) utility, available at
http://ciscounitytools.com/App_DirectoryWalker4.htm.

— The Disaster Recovery Backup tool and the Disaster Recovery Restore tool, available at
http://ciscounitytools.com/App_DisasterRecoveryTools.htm.

- Software for reinstalling the primary and secondary servers (must be the same versionsinstalled on
both servers).

« The applicable Cisco Unity installation guide for your configuration, available at
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_installation_guides list.html.

Note  The voice messaging service does not function while the servers are being renamed or moved to another
domain. During thistime, callers and subscribers will not be able to record or listen to voice messages.
We recommend that you replace the servers when phone traffic is light (for example, after business
hours).

Do the following procedures in the order listed.

To Manually Initiate Failover to the Secondary Server and Disable Automatic Failback

Stepl  If the primary server is not active, skip to Step 4.

If the primary server is active, on the primary server, on the Windows Start menu, click Programs >
Cisco Unity > Failover Monitor.

Step2  Click Failover.

Step3  Click OK to confirm that you want to fail over to the secondary server. The primary server becomes
inactive, and the secondary server becomes active.
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On the secondary server, on the Windows Start menu, click Programs > Cisco Unity > Failover
Monitor.

Click Configure.
In the Failback Type field of the Failover Configuration dialog box, click Manual.
Click OK to close the Failover Configuration dialog box.

To Stop File Replication on the Secondary and Primary Servers

On the secondary server, on the Windows Start menu, click Programs > Administrative Tools >
Services.

In the right pane, double-click AvCsNodeM gr.
On the General tab, click Stop.

In the Startup Type list, click Disabled.

Click OK.

Close the Services window.

A

Caution  Becausethe Node Manager serviceisdisabled, filereplication stops. Replicationisre-enabled
when normal failover operation resumes.

On the primary server, on the Windows Start menu, click Programs> Administrative Tools > Services.
In the right pane, double-click AvCsNodeMgr.

On the General tab, click Stop.

In the Startup Type list, click Disabled.

Click OK.

Close the Services window.

To Stop SQL Replication on the Primary Server

On the primary server, on the Windows Start menu, click Programs > Microsoft SQL Server >
Enterprise Manager.

In the left pane of the Console Root window, browse to the Replication node for the primary server.
Typically, the node is three level s under the Microsoft SQL Servers node.

Right-click the Replication node, and click Disable Publishing. The Disable Publishing and
Distribution wizard appears.

On the Welcome page, click Next.
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On the Disable Publishing page, click Yes, then click Next.
On the Confirm Dropping of Publications page, click Next.
On the Completing page, click Finish.

When the process is completed, click OK.

Close the Console Root window.

Exit Enterprise Manager.

To Check the Consistency of the Cisco Unity Database on the Secondary Server

On the secondary server, install the latest version of DbWalker, if it is not already installed.

Run DbWalker, and correct all errors that the utility finds. Refer to DbWalker Help for detailed
instructions on running the utility and on correcting errors in the database. (The Help file,
DbWalker.htm, isin the same directory as DbWalker.exe.)

To Back Up Cisco Unity Data on the Secondary Server to a Network Storage Location

On the secondary server, install the latest version of the Disaster Recovery Backup tool, if the tool is not
aready installed.

Back up Cisco Unity data by using the Disaster Recovery Backup tool. Refer to DiRT Help for detailed
instructions. (The Help file, UnityDisasterRecovery.htm, is in the same directory as
UnityDisasterRecoveryBackup.exe.)

A

Caution  Follow Help carefully. DiRT includes avariety of optionsthat you must understand to use the
tools successfully. In addition, the account you are logged on as when you back up
Cisco Unity data must have sufficient permissions or the backup will fail.

Save the Cisco Unity datato a network storage location.

To Remove the Primary and Secondary Servers from the Environment

On the primary server, log on to Windows as a Cisco Unity administrator.
Right-click the Cisco Unity icon in the status area of the taskbar.

(If the Cisco Unity icon is not in the taskbar, browse to the CommServer directory and double-click
AvCsTrayStatus.exe.)

Click Stop Cisco Unity. Cisco Unity stops running when all calls are finished, and an “X” appearsin
the Cisco Unity icon.

Right-click the SQL Server icon in the status area of the taskbar.
Click M SSQL Server - Stop.
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Step6  Disconnect the network cable from the primary server.
Step7  On the secondary server, repeat Step 1 through Step 6.

Step8  Remove the computer accounts from the domain, depending on the operating system:

Windows 2000 Remove the primary and secondary servers from Active Directory Users and
Computers.

Windows NT Remove the primary and secondary servers from the primary domain controller.

To Reinstall All Software on the Primary and Secondary Servers

Stepl  Follow theinstructionsin the applicable Cisco Unity installation guide for your configuration to install
the replacement primary and secondary servers. Refer to “Part 1: Installing and Configuring the
Cisco Unity Server” and “Part 2: Installing the Secondary Server for Cisco Unity Failover” in the
“Overview of Mandatory Tasks for Installing Cisco Unity” chapter. Note that you must install the
updated license files on the replacement primary server.

Note the following:

« If you use aretail Windows disk to install Windows, delete and recreate all partitions to ensure that
old applications and data are del eted.

« When you configure Windows, if there is more than one Cisco Unity server in the Active Directory
forest, give each Cisco Unity server aname that is unique in the first 14 characters, or Cisco Unity
will have problems communicating with the Lotus Domino accounts created by Cisco Unity. For
example, the following names would cause communication problems: CiscoUnitySrvrl and
CiscoUnitySrvr2.

» If you are not replacing the phone system, you can skip the task on setting up or programming the
phone system.

» Install the same version of Cisco Unity that was running when you backed up Cisco Unity data.
DiRT Restore can only restore data to the same version of Cisco Unity that you backed up.

« If you areinstalling Cisco Unity 4.2(1) or later, and if you are making the Cisco Unity server a
member server in an existing domain, add the server to a Windows 2000 Server domain or Windows
Server 2003 domain. Beginning with Cisco Unity 4.2(1), adding the Cisco Unity server to a
Windows NT domain is not supported.

To Restore Cisco Unity Data on the Primary Server from the Network Storage Location

Step1  Onthe primary server, install the latest version of the Disaster Recovery Restoretool, if it isnot already
installed.
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Restore Cisco Unity data by using the Disaster Recovery Restore tool and the backup that you made
earlier. Refer to DiRT Help for detailed instructions. (The Help file, UnityDisasterRecovery.htm, isin
the same directory as UnityDisasterRecoveryRestore.exe.)

A

Caution  Follow Help carefully. DiRT includes avariety of options that you must understand to use the
tools successfully.

Reapply any non-Cisco Unity custom registry settings. (DiRT backs up and restores Cisco Unity registry
settings.)

To Configure Failover on the Primary Server

In Windows Explorer, browse to the CommServer directory.

Double-click Failover Config.exe to start the Configure Cisco Unity Failover wizard.
On the Welcome page, click Next.

On the Specify Server Role page, click Primary Server, and click Next.

On the Enter the Name of Your Server page, click Browse, select the name of the secondary server, and
click OK. The IP address for the secondary server isfilled in automatically.

Click Next.

On the Enter Failover Account Information page, click Browse, and double-click the name of the
directory and message store services account. Thisis the account that the failover service will log on as.

The account you select must have the right to act as part of the operating system and to log on as a
service, and must be a member of the Local Administrators group.

A

Caution  You must specify the same account on both the primary and secondary servers.

In the Password field, enter the password for the account that the failover servicewill log on as, and click
Next.

On the Begin Configuring Your Server page, click Configure. The wizard verifies settings and
configures failover on the primary server.

If the wizard does not finish the configuration successfully, an error message explains why the wizard
failed. Exit the wizard, correct the problem, and click Configure again.

On the Completing page, click Finish.

To Configure Failover on the Secondary Server

On the Windows taskbar, double-click the system clock. The Date/Time Properties dialog box appears.
Set the time to the same hour and minute as shown on the primary server, and click OK.

In Windows Explorer, browse to the CommServer directory.

Double-click Failover Config.exe to start the Configure Cisco Unity Failover wizard.
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On the Welcome page, click Next.
On the Specify Server Role page, click Secondary Server, and click Next.

On the Enter the Name of Your Server page, click Browse, select the name of the primary server, and
click OK. The IP address for the primary server isfilled in automatically.

Click Next.

On the Enter Failover Account Information page, click Browse, and double-click the name of the
directory and message store services account. Thisisthe account that the failover service will log on as.

The account you select must have the right to act as part of the operating system and to log on as a
service, and must be a member of the Local Administrators group.

A

Caution  You must specify the same account on both the primary and secondary servers.

Inthe Password field, enter the password for the account that the failover servicewill log on as, and click
Next.

On the Begin Configuring Your Server page, click Configure. The wizard verifies settings and
configures failover on the secondary server.

If the wizard does not finish the configuration successfully, an error message explains why the wizard
failed. Exit the wizard, correct the problem, and click Configure again.

On the Completing page, click Finish.

Enabling Subscribers to Use the Phone for Recording and Playback

Note

IBM Lotus Notes with IBM Lotus Domino Unified Communications (DUC) for Cisco offersa

V CR-style recorder/player in the message form. Subscribers can customize it to use a phone or a
computer microphone and speakers as the recording and playback device. However, when you rename a
Cisco Unity server, aphone does not work as arecording or playback device unless you manually update
the Cisco Unity server name specified in each subscriber mail file.

To correct the problem, you can either run an agent on a Domino server to change each subscriber mail
file and push the changed mail files out to subscriber workstations, or you can provide subscribers with
an agent that the subscriber runs on the workstation to change the server name in the mail file.

You do not need to change anything for subscribers who use a computer microphone and speakers as
their recording and playback devices.

The agents are located on the Cisco Unity server.

» The CommServer\Utilities\Domino\Agents\ClientUpdateUCProfileforTrap directory contains the
following files:

— ClUpUn.nsf—The agent that subscribers run on their workstations to change the Cisco Unity
server name in their mail file. Note that the agent must be modified with the Cisco Unity server
name before it is run.
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— Client Update Unity Profile Agent.txt—A text file that contains the L otusScript in ClUpUn.nsf.
Note that the script must be modified with the Cisco Unity server name before it is run.

— Readme.txt—A text file with instructions on using the agent.

» The CommServer\Utilities\Domino\Agents\UpdateUCProfileforTrap directory contains the
following files:

— UpdateUn.nsf—The agent that is run on aDomino server to change the Cisco Unity server name
in each subscriber mail file. Note that the agent must be modified with the Cisco Unity server
name and Domino server name before it is run.

— Update Unity Profile Agent.txt—A text file that containsthe L otusScript in UpdateUn.nsf. Note
that the script must be modified with the Cisco Unity server name and Domino server name
beforeit is run.

— AgentLog.nsf—A Notes database that stores output from the agent that is run on the Domino
server.

— Readme.txt—A text file with instructions on using the agent.
See the following procedures for details on modifying and running the agents:

» To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server, page
6-4

« To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber
Workstation, page 6-5

» To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation, page 6-6

The following procedure is specific to Domino R6.5 and assumes that you have Full Access
Administration rights or have been added to the access control list (ACL) of each subscriber mail file
with sufficient rights. Change the steps as necessary if you are running another version of Domino.

The procedure describes using Update Unity Profile Agent.txt, but if you are familiar with agents, you
can modify UpdateUn.nsf in Domino Designer by using the steps as a guideline.

To Change the Cisco Unity Server Name for Every Subscriber Mail File on a Domino Server

Copy the Update Unity Profile Agent.txt located in the
CommServer\Utilities\Domino\Agents\U pdateUCProfileforTrap directory on the Cisco Unity server to
the Domino server where you will run Domino Designer.

Copy AgentL og.nsf to your Domino data directory.
Open Domino Designer, click Open an Existing Database, and open Names.nsf.

In the Design pane for names.nsf (the pane on the left, underneath Recent Databases), click Shared
Code > Agents.

In the right pane, click the New Agent button. The Agent Properties box appears.
On the Basics tab, enter a name for the agent in the Name field.

In the Runtime section, for the Target, click None.

Close the Agent Properties box.

In the Programmer’s pane on the right, click L otusScript from the Run menu.
On the Objects tab, click Declarations.

Open thefile Update Unity Profile Agent.txt in Notepad, and copy the text from the beginning of thefile
to the line right above the line that contains “ Sub Initialize.” (Do not copy the “Sub Initialize” line.)
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Paste the text in the Script area of the Programmer’s pane in Domino Designer.
Modify the agent text in the Script area of the Programmer’s pane as follows:

» Replace the const values AGENTLOG_SERVER and DUC_SERVER with your Domino server
name.

» Replace the const value NEW_UNITY_SERVER_NAME with the new Cisco Unity server name.
Be sure that the server names are encapsulated in double quotes.

In the Objects tab, click Initialize. The lines “ Sub Initialize” and “End Sub” with a blank line between
them are displayed in the Script area of the Programmer’s pane.

In thefile Update Unity Profile Agent.txt in Notepad, copy the text between (but not including) thelines
“Sub Initialize” and “End Sub.”

Paste the text in the Script area of the Programmer’s pane on the blank line between the lines “ Sub
Initialize” and “End Sub.”

Exit Notepad.

Close and save the agent, and exit Domino Designer.

Open the Domino Administrator, click File > Database > Open, and open names.nsf.
Click Actions > <Your Agent Name> to run the agent.

Repeat Step 1 through Step 20 on every Domino server containing subscriber mail files that you want to
change.

Subscribers will need to exit and reopen Notes on their workstations for the change to take effect.

The procedure below is specific to Notes R6.5. Modify the steps as needed for other Notes versions. If
you will be providing these instructionsto subscribers, you will also need to provide them with the name
of the Cisco Unity server. Consider customizing the instructions below with the name of your

Cisco Unity server.

If Cisco Unity isconfigured for failover, you will need to provide subscribers with the names of both the
primary and secondary Cisco Unity servers. Subscribers will actually create two agents: one that saves
the secondary Cisco Unity server name to the mail file (for when Cisco Unity has failed over to the
secondary), and one that saves the primary Cisco Unity server name to the mail file (for when

Cisco Unity has failed back to the primary).

Note that the file Client Update Unity Profile Agent.txt contains only one line of script, and it is given
in the procedure.

To Create an Agent that Changes the Cisco Unity Server Name in a Mail File on a Subscriber Workstation

On a subscriber workstation, start Notes and open the subscriber mail file.
Click Create > Agent. The Agent Properties box appears.

On the Basics tab, enter a name for the agent in the Name field.

In the Runtime section, for the Target, click None.

Close the Agent Properties box.

In the Programmer’s pane on the right, click For mula from the Run menu.
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Step7  Copy and paste the following text to the Script area of the Programmer’s pane:
@SetProfileField("ucprofile";"VoiceServerList";"<NewUnityServerName>");

Step8  Replace <NewUnityServerName> with your Cisco Unity server name. If Cisco Unity failover is
configured, enter the primary or secondary server name, as applicable.

Step9  Confirm that the server name is enclosed in double quotes, that each argument is separated with a
semicolon, and that the entire formula ends with a semicolon.

Step 10  Close and save the Agent.
Step 11 If Cisco Unity failover is configured, repeat Step 1 through Step 10.

To Change the Cisco Unity Server Name in a Mail File on a Subscriber Workstation

Stepl  On asubscriber workstation, start Notes and open the subscriber mail file.

Step2  Click Action > <Agent Name>, where <Agent Name> is the name of the applicable agent. (If
Cisco Unity failover is configured, there are two agents.)

Step3  Exit and then reopen Notes.
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