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Preface

This preface describes the audience, organization, and conventions of the Cisco Unity Troubleshooting 
Guide, and provides information on how to obtain related documentation.

Audience
The Cisco Unity Troubleshooting Guide is written for technicians and information systems professionals 
who configure and manage Cisco Unity™. This guide requires knowledge of and access to the phone 
system, the network, and the voice messaging system.

Organization
The Cisco Unity Troubleshooting Guide is divided into sections relating to general problem areas.

Each section addresses a specific problem, which is listed in the section title. The section contains 
possible causes, and procedures with which you can determine if a possible cause applies to your 
situation, and with which you can resolve the problem.

When the expected result is achieved during a procedure, continue with the next step when applicable, 
or continue with the next possible cause within the section.

See the “Tools Depot” section on page 11-1 for information on how to use utilities for researching and 
resolving problems. Refer to the “Exiting and Starting the Cisco Unity Software and Server” section in 
the “Introduction” of the Cisco Unity System Administration Guide for procedures for stopping and 
starting Cisco Unity. The Cisco Unity System Administration Guide is available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_list.
html.

If you encounter a problem that is not described in this guide, contact the Cisco Technical Assistance 
Center (TAC).
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Preface
Document Conventions
Document Conventions

The Cisco Unity Troubleshooting Guide also uses the following conventions:

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
document.

Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data.

Cisco Unity Documentation
For descriptions and the URLs of Cisco Unity documentation on Cisco.com, refer to the Cisco Unity 
Documentation Guide. The document is shipped with Cisco Unity and is available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_pre_installation_guides_list.html.

Obtaining Documentation from Cisco Systems
The following sections provide sources for obtaining documentation from Cisco Systems.

Table 1 Cisco Unity Troubleshooting Guide conventions

Convention Description

boldfaced text Boldfaced text is used for:

• Key and button names. (Example: Click OK.)

• Information that you enter. (Example: Enter Administrator in the User 
Name box.)

< > 

(angle brackets)

Angle brackets are used around parameters for which you supply a value. 
(Example: In the Command Prompt window, enter ping <IP address>.)

- 

(hyphen)

Hyphens separate keys that must be pressed simultaneously. (Example: Press 
Ctrl-Alt-Delete.)

> 

(right angle 
bracket)

A right angle bracket is used to separate selections that you make:

• On menus. (Example: On the Windows Start menu, click 
Settings > Control Panel > Phone and Modem Options.)

• In the navigation bar of the Cisco Unity Administrator. (Example: Go to the 
System > Configuration > Settings page.)
vi
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Preface
Obtaining Technical Assistance
World Wide Web
You can access the most current Cisco documentation on the World Wide Web at the following sites:

• http://www.cisco.com

Documentation CD-ROM
Cisco documentation and additional literature are available in a CD-ROM package, which ships with 
your product. The Documentation CD-ROM is updated monthly and may be more current than printed 
documentation. The CD-ROM package is available as a single unit or as an annual subscription.

Ordering Documentation
Cisco documentation is available in the following ways:

• Registered Cisco Direct Customers can order Cisco Product documentation from the Networking 
Products MarketPlace:

http://www.cisco.com/cgi-bin/order/order_root.pl

• Registered Cisco.com users can order the Documentation CD-ROM through the online Subscription 
Store:

http://www.cisco.com/go/subscription

• Nonregistered Cisco.com users can order documentation through a local account representative by 
calling Cisco corporate headquarters (California, USA) at 408 526-7208 or, in North America, by 
calling 800 553-NETS(6387).

Documentation Feedback
If you are reading Cisco product documentation on the World Wide Web, you can submit technical 
comments electronically. Click Feedback in the toolbar and select Documentation. After you complete 
the form, click Submit to send it to Cisco.

You can e-mail your comments to bug-doc@cisco.com.

To submit your comments by mail, write to the following address:

Attn Document Resource Connection
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
Cisco provides Cisco.com as a starting point for all technical assistance. Customers and partners can 
obtain documentation, troubleshooting tips, and sample configurations from online tools. For Cisco.com 
registered users, additional troubleshooting tools are available from the Cisco TAC website.
vii
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Preface
Obtaining Technical Assistance
Cisco.com
Cisco.com is the foundation of a suite of interactive, networked services that provides immediate, open 
access to Cisco information and resources at anytime, from anywhere in the world. This highly 
integrated Internet application is a powerful, easy-to-use tool for doing business with Cisco.

Cisco.com provides a broad range of features and services to help customers and partners streamline 
business processes and improve productivity. Through Cisco.com, you can find information about Cisco 
and our networking solutions, services, and programs. In addition, you can resolve technical issues with 
online technical support, download and test software packages, and order Cisco learning materials and 
merchandise. Valuable online skill assessment, training, and certification programs are also available.

Customers and partners can self-register on Cisco.com to obtain additional personalized information and 
services. Registered users can order products, check on the status of an order, access technical support, 
and view benefits specific to their relationships with Cisco.

To access Cisco.com, go to the following website:

http://www.cisco.com

Technical Assistance Center
The Cisco TAC website is available to all customers who need technical assistance with a Cisco product 
or technology that is under warranty or covered by a maintenance contract.

When you report a problem to Cisco TAC, you will be asked to provide information about your system 
and about the problem. The “Reporting Problems to Cisco TAC” section on page 1-3 provides 
procedures for gathering the data and system information that may be requested. The more data that can 
be gathered and communicated about a problem, the more likely it is that the problem will be diagnosed 
and fixed quickly.

Contacting Cisco TAC by Using the Cisco TAC Website

If you have a priority level 3 (P3) or priority level 4 (P4) problem, contact Cisco TAC by going to the 
TAC website:

http://www.cisco.com/tac

P3 and P4 level problems are defined as follows:

• P3—Your network performance is degraded. Network functionality is noticeably impaired, but most 
business operations continue.

• P4—You need information or assistance on Cisco product capabilities, product installation, or basic 
product configuration.

In each of the above cases, use the Cisco TAC website to quickly find answers to your questions. 

To register for Cisco.com, go to the following website:

http://www.cisco.com/register/

If you cannot resolve your technical issue by using the TAC online resources, Cisco.com registered users 
can open a case online by using the TAC Case Open tool at the following website:

http://www.cisco.com/tac/caseopen
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Preface
Obtaining Technical Assistance
Contacting Cisco TAC by Phone

If you have a priority level 1(P1) or priority level 2 (P2) problem, contact Cisco TAC by phone and 
immediately open a case. To obtain a directory of toll-free numbers for your country, go to the following 
website:

http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

P1 and P2 level problems are defined as follows:

• P1—Your production network is down, causing a critical impact to business operations if service is 
not restored quickly. No workaround is available.

• P2—Your production network is severely degraded, affecting significant aspects of your business 
operations. No workaround is available.
ix
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Introduction

In this chapter you will find basic information that will help you prepare for troubleshooting 
Cisco Unity. See the following sections:

• Preparations for Troubleshooting the Phone System, page 1-1—This section includes instructions 
for setting up for a diagnostic test.

• Reporting Problems to Cisco TAC, page 1-3—This section explains what information you will need 
to interact with the Cisco Technical Assistance Center (TAC), including instructions for obtaining 
logs and traces and enabling Miu diagnostics.

Preparations for Troubleshooting the Phone System
Problems with external and internal calls, message notification calls, and message waiting indicators can 
be caused by the phone system, by Cisco Unity, or by both, and are therefore difficult to diagnose. 
Several of the procedures for resolving problems use the single-line test, in which the phone lines 
connected to Cisco Unity are tested one at a time.

Most phone systems provide documentation on the codes that perform transfers, recalls, and other call 
progress functions. Have the phone system documentation available while performing the procedures in 
this section.

Depending on your phone system, do one of the following to set up for troubleshooting:

• Setting Up For a Diagnostic Test (Cisco CallManager or SIP Integrations Only), page 1-1

• Setting Up for a Single-Line Test (Circuit-Switched Phone System Integrations Only), page 1-2

Setting Up For a Diagnostic Test (Cisco CallManager or SIP Integrations Only)
To perform diagnostic tests you need three test extensions. Phone 1 is assigned to the Unity Example 
Subscriber. Phones 2 and 3 are set up only in Cisco CallManager and do not need to have a Cisco Unity 
subscriber assigned. All three extensions must be in the same calling search space as Cisco Unity.

To set up the test configuration

Step 1 Set up two test extensions (Phone 1 and Phone 2) on the same phone system that Cisco Unity is 
connected to.

Step 2 Set Phone 1 to forward calls to the Cisco Unity pilot number when calls are not answered or when the 
called extension is busy.
1-1
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Chapter 1 Introduction
Preparations for Troubleshooting the Phone System
Step 3 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Profile page for the Example 
Subscriber.

Step 4 In the Extension field, enter the extension of Phone 1.

Step 5 Click the Save icon.

Step 6 In the navigation bar, click Call Transfer to go to the Subscribers > Subscribers > Call Transfer page 
for Example Subscriber.

Step 7 Under Transfer Incoming Calls, click Yes, Ring Subscriber’s Extension, and confirm that the extension 
number is for Phone 1.

Step 8 Under Transfer Type, click Release to Switch.

Step 9 Click the Save icon.

Step 10 Click Messages for Example Subscriber.

Step 11 Under Message Waiting Indicators (MWIs), check Use MWI for Message Notification.

Step 12 In the Extension field, enter x.

Step 13 Click the Save icon.

Setting Up for a Single-Line Test (Circuit-Switched Phone System Integrations 
Only)

To perform diagnostic tests, you need a lineman test set or an analog phone with a ringer. Additional 
equipment and the method you use to set up for a single-line test depend on the type of voice cards in 
the Cisco Unity server.

Because single lines cannot be split out from T1 digital cables, it is not possible to set up single-line 
testing for integrations that use T1 cables.

To set up a Dialogic D/120 card for single-line testing

This voice card supports two lines per jack, so you need a line splitter to test individual lines.

Step 1 Determine which line you are having trouble with, and unplug it from the voice card.

. 

Step 2 Plug that line into a line splitter.

Phone system

Analog
phone

Line
splitter

61
09

9

........................................................ ..
..

.
.

Unity server
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Chapter 1 Introduction
Reporting Problems to Cisco TAC
Step 3 Plug the test phone into the jack on the line splitter corresponding to the port you are having trouble with. 
The middle pair of wires (numbers 3 and 4) correspond to the first port, and the next pair of wires 
(numbers 2 and 5) correspond to the second port. The outer pair of wires (numbers 1 and 6) are unused.

To set up a Dialogic D/41 card for single-line testing

This voice card supports only one line per jack.

Step 1 Determine which line you are having trouble with, and unplug it from the voice card.

 

Step 2 Plug that line into the test phone.

Reporting Problems to Cisco TAC
When you report a problem to the Cisco Technical Assistance Center (TAC), you will be asked to provide 
information about your system and about the problem. This section provides procedures for gathering 
the system information and problem description that may be requested.

System Information
Have the following system information ready when you call:

Phone system
ports 1 and 2

RJ-14

Port 2 connections

Unused connections 76
52

4

RJ-14

Line splitter

Port 1 connections
Analog
phone

Connection to
port 1 or port 2

Phone system

Analog phone

Unity server

61
09

7

........................................................ ..
..

.
.
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Chapter 1 Introduction
Reporting Problems to Cisco TAC
• Cisco Unity version currently in use. See one of the following procedures: To determine the 
Cisco Unity version in use by using the Cisco Unity Administrator, page 1-4, or To determine the 
Cisco Unity version in use by using the AvCsMgr.exe file, page 1-4.

• Cisco Unity-CM TSP version currently in use. See the procedure, To determine the Cisco Unity-CM 
TSP version in use, page 1-5.

Note In versions earlier than 3.1(1), the Cisco Unity-CM TSP was known as the AV-Cisco TSP.

• RealSpeak TTS version currently in use. See the procedure, To determine the RealSpeak ENU 
language engine in use, page 1-5.

• Build number(s) of any software releases or upgrades installed.

• Number, type, and speed of processors.

• Memory and pagefile size.

• Hard disk size and free space.

• Number and type of voice ports installed.

• Phone system integration, including the manufacturer, model, and version (if applicable).

• Cisco Unity switch.ini file version currently in use. See the procedure, To determine the Switch.ini 
file version in use, page 1-5.

• Other telephony software or hardware installed, such as fax or UniModem.

• Microsoft Windows 2000 service packs installed.

• Exchange service packs installed.

• Number of subscribers in the Cisco Unity database.

• Number of subscribers in the Exchange database.

• Size of the Exchange database file.

• Approximate normal Cisco Unity server CPU utilization. (For example, does the Windows task 
manager often show 100 percent CPU utilization, or is it usually less than 80 percent?)

To determine the Cisco Unity version in use by using the Cisco Unity Administrator

Step 1 In the Cisco Unity Administrator, go to the System > Configuration > Software Versions page. The 
version is displayed in the Cisco Unity Version field.

To determine the Cisco Unity version in use by using the AvCsMgr.exe file

Step 1 Browse to the CommServer directory.

Step 2 Right-click AvCsMgr.exe, and click Properties.

Step 3 In the Properties window, click the Version tab.

Step 4 In the Item Name list, click Product Version. The Cisco Unity version is displayed in the Value window.
1-4
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Chapter 1 Introduction
Reporting Problems to Cisco TAC
To determine the Cisco Unity-CM TSP version in use

Step 1 Browse to the WinNT\System32 directory.

Step 2 Right-click the Avskinny.tsp file, and select Properties. 

Step 3 In the Properties window, click the Version tab.

Step 4 The File Version value is the Cisco Unity-CM TSP version currently in use.

To determine the Switch.ini file version in use

Step 1 Browse to the CommServer directory.

Step 2 Double-click Editswitch.exe.

Step 3 Click Edit this Switch Configuration.

Step 4 The Switch.ini file version is displayed in the title bar of the window.

To determine the RealSpeak ENU language engine in use

Step 1 Browse to the CommServer\RealSpeak\Engine directory.

Step 2 Right-click the file Enu_g2p.dll, and click Properties.

Step 3 Click the Version tab.

Step 4 The File Version value is the DLL version. It corresponds to the following RealSpeak versions: 

– 2.1.0.0 = RealSpeak ENU language engine version 2.0(1)

– 2.11.0.0 = RealSpeak ENU language engine version 2.1(1)

– 3.6.0.0 = RealSpeak ENU language engine version 3.0(1)

To determine the RealSpeak base engine version in use

Step 1 Browse to the CommServer\RealSpeak\Api\Lib directory.

Step 2 Right-click the file Lhstts.dll, and click Properties.

Step 3 Click the Version tab.

Step 4 The File Version is the DLL version. It corresponds to the following RealSpeak versions:

– 2.1.0.0 = RealSpeak base engine version 2.0(1)

– 2.11.0.0 = RealSpeak base engine version 2.1(1)

– 2.12.0.0 = RealSpeak base engine version 3.0(0)

– 2.13.0.0 = RealSpeak base engine version 3.0(1)
1-5
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Chapter 1 Introduction
Reporting Problems to Cisco TAC
Problem Description
Be prepared to give a complete description of the problem, including:

• Symptoms such as lost ports, Event log errors, or Dr. Watson errors.

• Problem frequency under normal load conditions (for example, every call, once per hour, or once 
only).

• Problem frequency when specific attempts are made to reproduce it.

• Detailed sequence of steps to reproduce the problem.

• Date and time of last known occurrence of the problem.

• Which digits were entered by the caller (for example, menu selections or subscriber extensions, or 
the extension of the caller and/or called port), if known.

• Which port(s) were affected by the problem, if known.

• Applicable logs and traces (see Chapter 2, “Logs and Traces” for more information on how to obtain 
log and trace files).
1-6
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Logs and Traces

In this chapter you will find information to help you gather logs and traces when troubleshooting 
Cisco Unity. See the following sections:

• Dr. Watson Logs, page 2-2—This section includes instructions for obtaining a Dr. Watson trace.

• Event Log Traces, page 2-2—This section includes instructions for obtaining an Event log trace.

• MIU Diagnostics, page 2-3—This section includes information on setting up and collecting MIU 
diagnostic traces.

• TSP Traces, page 2-4—This section includes instructions for obtaining Dialogic and 
Cisco Unity-CM TSP traces.

• Exchange 5.5 Directory Monitor Diagnostic Traces, page 2-5—This section includes information on 
setting up and collecting Exchange 5.5 Directory Monitor traces.

• Active Directory Monitor Diagnostic Traces, page 2-6—This section includes information on 
setting up and collecting Active Directory Monitor traces.

• AMIS Diagnostic Traces, page 2-8—This section includes information on setting up collecting 
AMIS traces.

• Cisco Unity Voice Connector Logs, page 2-10—This section provides information about the Voice 
Connector logs and includes instructions for changing the log settings.

Cisco Unity and Third-Party Logs and Traces
For problems in the MIU or TSP, Cisco TAC may ask for logs and traces before the problem can be 
diagnosed and fixed. MIU diagnostic logs, along with the Event log and/or Dr. Watson logs, if available, 
are usually sufficient for the initial phase of diagnosing a problem.

Caution Diagnostic traces that are set before a Cisco Unity software upgrade are not preserved and must be reset 
after the upgrade.

See the following sections for details about third-party logs and traces:

• Dr. Watson Logs, page 2-2

• Event Log Traces, page 2-2

Most Cisco Unity components such as the MIU, Arbiter, Notifier, Conversations, and Cisco Unity 
Administrator (also known as the “SA” or “System Administrator”) can write diagnostic information to 
a log file. Diagnostic output of the problem occurring is critical to determining what caused the problem. 
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If the problem seldom occurs, such as only once a day, it can be difficult to find the actual occurrence of 
the problem in the diagnostic log. See the following sections for details about Cisco Unity diagnostic 
traces:

• MIU Diagnostics, page 2-3

• TSP Traces, page 2-4

Dr. Watson Logs
Dr. Watson is a program invoked by Windows 2000 when a serious problem occurs that is not handled 
by Cisco Unity. When Dr. Watson is invoked, a dialog box appears containing an error message, for 
example, “Dr. Watson encountering an error in the AvCsMgr.exe process.” Dr. Watson errors may occur 
in other processes such as Tapisrv.exe, or Dlgc_srv.exe.

To obtain a Dr. Watson log

Step 1 When a Dr. Watson error occurs, make a copy of the file Winnt\Drwtsn32.log.

Step 2 Before you attempt to reproduce the problem, from a command prompt, enter drwtsn32 and press Enter.

Step 3 In the Number of Instructions field, enter 50.

Step 4 In the Number of Errors to Save field, enter the number of errors you want to record. The default is 10.

Step 5 Under Options, confirm that the Dump All Thread Contexts, Append to Existing Log File, Visual 
Notification, and Create Crash Dump File check boxes are checked.

Step 6 Click OK to close the dialog box.

Step 7 Reproduce the problem.

Step 8 Make a copy of the file Winnt\Drwtsn32.log.

Event Log Traces
The Event log is used by Windows applications to report errors and warnings. The MIU reports serious 
failures to the Event log, for example, “Component MIU: thread <XXX> had a failure on port <YYY> 
in AvWav.”

To obtain an Event log trace

Step 1 On the Windows Start menu, click Programs > Administrative Tools > Event Viewer.

Step 2 In the Tree pane, click Application Log.

Step 3 Look for failure messages in the Application log. These can include errors from the MIU or AvWav, as 
well as errors from other Cisco Unity components or Exchange errors.

Step 4 If failure messages are present in the Application log, in the Tree pane, click Application Log, then on 
the Action menu click Save Log File As.

Step 5 In the Save as Type field, click CSV, then click Save. Do not save the raw Event log data in a *.evt file.
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MIU Diagnostics
Enable the MIU diagnostics when you are obtaining traces for an MIU problem. For example, if there 
are AvWav errors in the Event log, enable the AvWav diagnostics. However, keep in mind that running 
additional diagnostics can affect system performance and hard drive space.

You can use micro traces to set individual levels for selected MUI traces, or you can use macro traces to 
select preset combinations of traces.

To obtain micro trace MIU diagnostics

Step 1 On the Windows Start menu, click Programs > Unity > Unity Diagnostic Tool.

Step 2 On the Cisco Unity Diagnostic Viewer screen, click the Configure Micro Traces icon. The Configure 
Micro Traces wizard appears.

Step 3 On the Welcome page, click Next.

Step 4 On the Configure Micro Traces page, check the boxes for selected traces in components beginning with 
Miu.

Step 5 Click Next.

Step 6 On the Completing page, click Finish.

Step 7 On the Cisco Unity Diagnostic Viewer screen, click the Start New Log Files icon.

Step 8 Reproduce the problem.

Step 9 To view the log files, in the Tree pane, click Processes > AvCsMgr, and then click the Current log file.

Step 10 The selected log file is appears in the right pane.

Step 11 To export or save a copy of the log file, on the Action menu, click Export List.

Step 12 Name the file and save it to a location of your choice in .txt or .csv format, then click Save.

Step 13 To turn off the traces set in Step 4, on the Cisco Unity Diagnostic Viewer screen, click the Disable All 
Traces icon.

Step 14 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

To obtain macro trace MIU diagnostics

Step 1 On the Windows Start menu, click Programs > Unity > Unity Diagnostic Tool.

Step 2 On the Cisco Unity Diagnostic Viewer screen, click the Configure Macro Traces icon. The Configure 
Macro Traces wizard appears.

Step 3 On the Welcome page, click Next.

Step 4 On the Configure Macro Traces page, check the boxes for selected traces.

Step 5 Click Next.

Step 6 On the Completing page, click Finish.

Step 7 On the Cisco Unity Diagnostic Viewer screen, click the Start New Log Files icon.

Step 8 Reproduce the problem.

Step 9 To view the log files, in the Tree pane, click Processes > AvCsMgr, and then click the Current log file.
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Step 10 The selected log file is appears in the right pane.

Step 11 To export or save a copy of the log file, on the Action menu, click Export List.

Step 12 Name the file and save it to a location of your choice in .txt or .csv format, then click Save.

Step 13 To turn off the traces set in Step 4, on the Cisco Unity Diagnostic Viewer screen, click the Disable All 
Traces icon.

Step 14 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

TSP Traces
If Cisco TAC determines that TSP traces are needed, they will ask you to provide them.
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To obtain Cisco Unity-CM TSP traces

Step 1 Confirm that the clocks on Cisco Unity and Cisco CallManager are synchronized.

Step 2 Enable tracing on the Cisco CallManager system.

Step 3 On the Windows Start menu, click Programs > Unity > Unity Diagnostic Tool.

Step 4 On the Cisco Unity Diagnostic Viewer screen, click the Configure Macro Traces icon. The Configure 
Macro Traces wizard appears.

Step 5 On the Welcome page, click Next.

Step 6 On the Configure Macro Traces page, check the Skinny TSP check box.

Step 7 Click Next.

Step 8 On the Completing page, click Finish.

Step 9 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 10 Reproduce the problem.

Step 11 To view the log files, in the Tree pane, click Processes > Svchost, and then click the Current log 
file. 

Step 12 The selected log file is appears in the right pane.

Step 13 To export or save a copy of the log file, on the Action menu, click Export List.

Step 14 Name the file and save it to a location of your choice in .txt or .csv format, then click Save.

Step 15 To turn off the traces set in Step 6, on the Cisco Unity Diagnostic Viewer screen, click the Disable All 
Traces icon.

Step 16 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

Exchange 5.5 Directory Monitor Diagnostic Traces
You use the Unity Diagnostic Tool to set micro traces for the Exchange 5.5 directory monitor. The micro 
traces to enable are in the DSEx55 group.

Flags To Enable

• If the creation, modification, or deletion of subscriber accounts, distribution lists, or location objects 
in the Cisco Unity Administrator fails, then enable flags 00 and 10. If the diagnostics show an error 
when accessing the directory with LDAP, then also enable flag 13 to get more details.

• If changes made in the Exchange 5.5 directory are not reflected in Cisco Unity, enable flags 10, 11, 
and 12. If the error is related to inconsistency in distribution list membership, then also enable flag 
17.

• If the directory monitor service logs an error to the Windows event log saying that it has thrown an 
exception, then enable flags 00, 01, and 10.

The table below provides descriptions of the diagnostic flags.
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Active Directory Monitor Diagnostic Traces
You use the Unity Diagnostic Tool to set micro traces for the Active Directory monitors. The diagnostics 
for the DC monitor are in the DSAD group. The diagnostics for the GC monitor are in the 
DSGlobalCatalog group. The flags that can be enabled are the same for both monitors.

Table 2-1 Diagnostics Flags for the Exchange 5.5 Directory Monitor

Diagnostic Flag Description

00—High level, method entry and exit, 
and parameter values

Traces Cisco Unity Administrator calls to create, modify, delete, and find 
subscribers, distribution lists, and locations. Also traces calls to get and set system 
configuration parameters.

01—Low level, method entry and exit, 
and parameter values

Traces calls to internal methods. Note that enabling this flag will produce very large 
diagnostic files.

02—Memory Traces memory allocation and deallocation. There is seldom a need to enable this 
flag.

10—General Traces main events and all errors associated with them. This flag should always be 
enabled when a diagnostic file is needed.

11—Synchronization start and end Records the time when a synchronization cycle starts and ends.

12—Objects queued for change app Traces the change or deletion of every object that has been detected and sent to 
Cisco Unity.

13—LDAP The Exchange 5.5 monitor uses LDAP to access the Exchange 5.5 directory. When 
this flag is enabled, all LDAP operations are traced. Note that this produces a very 
large amount of data.

14—Initialization Traces all the initialization activity for the directory monitor service.

15—Shutdown Traces all the shutdown activity for the directory monitor service.

16—Configuration Traces all configuration activity: reading and writing from the registry, default 
settings at initialization time, and access to internal configuration at run time.

17—Database access For performance reasons, the directory monitor keeps some information in a SQL 
database: the names of all distribution lists and their members, and a list of all 
Cisco Unity objects and the domain that they are in. Enable this flag when 
investigating errors in these areas.

18—Import directory connector The import directory connector (IDC), is used by the Cisco Unity Administrator and 
the Cisco Unity Import utility to get lists of directory user objects that have not been 
imported into Cisco Unity. For example, when you choose to import a subscriber 
from the Cisco Unity Administrator, the list of directory objects it generates comes 
from the IDC.

The IDC returns properties on the non-imported users, which is how the Cisco Unity 
Administrator and the Cisco Unity Import utility fill in things like first name, last 
name, phone number, and so on. If you enable flag 18, you get traces that show the 
names and values of the retrieved attributes.

Enable this flag for troubleshooting import problems. For example, if the 
Cisco Unity Administrator is not displaying the first name of a person in the import 
list, then enable this flag to see if the import directory component is returning the 
value to the calling application correctly.
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Flags To Enable

• If the creation, modification, or deletion of subscriber accounts, distribution lists, or location objects 
in the Cisco Unity Administrator fails, then enable flags 00 and 10. If the diagnostics show an error 
when accessing Active Directory, then also enable flag 12 to get more details.

• If changes made in Active Directory are not reflected in Cisco Unity, then enable flags 10, 11, and 
17. If the error is related to inconsistency in distribution list membership, then also enable flag 16.

• If the directory monitor service logs an error to the Windows event log saying that it has thrown an 
exception, then enable flags 00, 01, and 10.

The table below provides descriptions of the diagnostic flags.

Table 2-2 Diagnostic Flags for the Active Directory Monitors

Diagnostic Flag Description

00—High level, method entry and exit, 
and parameter values

Traces Cisco Unity Administrator calls to create, modify, delete, and find 
subscribers, distribution lists, and locations. Also traces calls to get and set system 
configuration parameters.

01—Low level, method entry and exit, 
and parameter values

Traces internal methods calls. Note that enabling this flag will produce very large 
diagnostic files.

02—Memory Traces memory allocation and deallocation. There is seldom a need to enable this 
flag.

10—General Traces main events and all errors associated with them. This flag should always be 
enabled when a diagnostic file is needed.

11—Changes queued Traces the change or deletion of every object that has been detected and sent to 
Cisco Unity.

12—ADSI operations The monitor uses ADSI (Active Directory Services Interface) to access Active 
Directory. When this flag is enabled, all ADSI operations are traced. Note that this 
produces a very large amount of data.

13—Initialization Traces all the initialization activity for the directory monitor service.

14—Shutdown Traces all the shutdown activity for the directory monitor service.

15—Configuration Traces all configuration activity: reading and writing from the registry, default 
settings at initialization time, and access to internal configuration at run time.

16—Database access For performance reasons, the monitor keeps some information in a SQL database: the 
names of all distribution lists and their members, and a list of all Cisco Unity objects 
and the domain that they are in. Enable this flag when investigating errors in these 
areas.

17—Synchronization start and end Records the time when a synchronization cycle starts and ends, and also the start and 
end time for the synchronization of each single domain (if enabled in the DSAD 
group).
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AMIS Diagnostic Traces
The Unity Diagnostic Tool provides macro and micro traces to help you troubleshoot AMIS message 
delivery problems. See the “To set and retrieve traces for AMIS messages” section on page 5-13 for 
information on using the Unity Diagnostic tool. See the following sections for more information about 
the appropriate AMIS macro traces to set for your situation:

• Basic Incoming and Outgoing AMIS Message Trace, page 2-9—These traces help you verify that 
Cisco Unity can send and receive AMIS messages. You can send test messages with these traces 
enabled to verify that the AMIS configuration is set up properly.

• General Incoming AMIS Message Traces, page 2-9—These traces help you narrow down the 
problem to a specific Cisco Unity component. When troubleshooting incoming message problems, 
set these traces first.

• Extensive Incoming AMIS Message Traces, page 2-9—These traces include more Cisco Unity 
components than the general traces and enable extensive logging. If you cannot determine the 
problem from the set of general traces, then enable the traces specified in this section.

• General Outgoing AMIS Message Traces, page 2-9—These traces help you narrow down the 
problem to a specific Cisco Unity component. When troubleshooting outgoing message problems, 
set these traces first.

• Extensive Outgoing AMIS Message Traces, page 2-10—These traces include additional 
Cisco Unity components and enable extensive logging. If you cannot determine the problem from 
the set of general traces, then enable the traces specified in this section.

18—Import directory connector

(DSGlobalCatalog only)

The import directory connector (IDC), is used by the Cisco Unity Administrator and 
the Cisco Unity Import utility to get lists of directory user objects that have not been 
imported into Cisco Unity. For example, when you choose to import a subscriber 
from the Cisco Unity Administrator, the list of directory objects it generates comes 
from the IDC. 

The IDC returns properties on the non-imported users, which is how the Cisco Unity 
Administrator and the Cisco Unity Import utility fill in things like first name, last 
name, phone number, and so on. If you enable flag 18, you get traces that show the 
names and values of the retrieved attributes.

Enable this flag for troubleshooting import problems. For example, if the 
Cisco Unity Administrator is not displaying the first name of a person in the import 
list, then enable this flag to see if the import directory component is returning the 
value to the calling application correctly.

18—Input property lists

(DSAD only)

Low-level diagnostic trace. Do not enable unless requested by Cisco TAC.

19—Output property lists

(DSAD only)

Low-level diagnostic trace. Do not enable unless requested by Cisco TAC.

Table 2-2 Diagnostic Flags for the Active Directory Monitors (continued)

Diagnostic Flag Description
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Basic Incoming and Outgoing AMIS Message Trace

The macro trace “Basic Incoming and Outgoing AMIS Message Trace” sets the following micro traces, 
which help you verify that Cisco Unity can send and receive AMIS messages.

• Conv AMIS—28

• Notifier—28

General Incoming AMIS Message Traces

The macro trace “General Incoming AMIS Message Trace” sets the following micro traces, which help 
you narrow down the problem to a specific Cisco Unity component.

• CDE—10, 14, 18

• AlCommon—10

• DalDb—10

• DalEx—10

• Doh—10

• MALEx—10

• MALLn—10

• Conv AMIS—28

Extensive Incoming AMIS Message Traces

The macro trace called “Extensive Incoming AMIS Message Trace” sets the following micro traces, 
which include additional Cisco Unity components, and enable extensive logging.

• CDE—10, 11, 12, 13, 14, 18, 19

• AlCommon—10

• DalDb—10

• DalEx—10

• Doh—10

• MALEx—10

• MALLn—10

• FailureConv—11

• PhraseServer—12

• Conv AMIS—13, 14, 15, 17, 20, 23, 25, 26, 27, 28

General Outgoing AMIS Message Traces

The macro trace called “General Outgoing AMIS Message Trace” sets the following micro traces, which 
help you narrow down the problem to a specific Cisco Unity component.

• CDE—10, 14, 18

• AlCommon—10

• DalDb—10
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• DalEx—10

• Doh—10

• MALEx—10

• MALLn—10

• Conv AMIS—28

• Notifier—13, 19, 24, 26, 28

• ExchangeMonitor—13 (Note that if no information is logged from the Exchange Monitor 13 trace, 
this indicates a problem.)

Extensive Outgoing AMIS Message Traces

The macro trace called “Extensive Outgoing AMIS Message Trace” sets the following micro traces, 
which include additional Cisco Unity components, and enable extensive logging.

• CDE—10, 11, 12, 13, 14, 18, 19

• AlCommon—10

• DalDb—10

• DalEx—10

• Doh—10

• MALEx—10

• MALLn—10

• Conv AMIS—13, 14, 15, 17, 20, 23, 25, 26, 27, 28

• FailureConv—11

• PhraseServer—12

• Notifier—13, 19, 20, 21, 24, 26, 28

• ExchangeMonitor—13 (Note that if no information is logged from the Exchange Monitor 13 trace, 
this indicates a problem.)

Cisco Unity Voice Connector Logs
With the Voice Connector version 10.0(1) and later, logging is enabled at the Warning level by default. 
By default, the log files are kept for 14 days before being deleted. The default location for the log files 
is on the Exchange server on which the Voice Connector is installed, in the following folder:

• Exchange 2000: <Exchange Server Path>\VoiceGateway\logFiles

• Exchange 5.5: <Exchange Server Path>\IvcData\logFiles

The Voice Connector provides several logging levels that allow you to control the level of detail logged 
to the files. The logging levels are:

• Function (level 5)

• Information (level 4)

• Warning (level 3)

• Error (level 2)
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• Core (level 1)

• No Logging (level 0)

The higher levels provide more detail and include all the lower levels. For example, the Information level 
includes Warning, Error and Core. When logging is enabled at any level, performance data is logged to 
a separate file. Changing the logging level does not change the data written to the performance log.

The Voice Connector allows you to set the logging level, the number of days to keep log files, and the 
location of the log files. The logging properties for the Voice Connector for Exchange 2000 can be 
modified in the Exchange System manager. See the procedure, To change the Voice Connector for 
Exchange 2000 logging settings, page 2-12 for details.

The logging properties for the Voice Connector for Exchange 5.5 must be modified in the registry. You 
use the logging level numbers listed above when changing the logging level in the registry. See the 
procedure, To change the Voice Connector for Exchange 5.5 logging settings, page 2-12 for details.

Note that the Voice Connector service must be restarted for logging changes to take effect.

Two log files per day are created:

• Voice Connector log files are named GwIvc_YyMmDd.log, where Yy is the year, Mm is the month 
and Dd is the day.

• Voice Connector performance log files are named GwIvc_perf_ YyMmDd.log, where Yy is the year, 
Mm is the month and Dd is the day.

Performance Logging

By examining the performance log (or writing a tool to extract the data), the following information can 
be obtained:

• The total number of inbound messages accepted.

• The total number of outbound messages sent.

• The rate at which inbound messages are being received (messages/second).

• The rate at which outbound messages are being sent (messages/second).

• The total number of bytes sent.

• The total number of bytes received.

• The rate that bytes are being received (bytes/second).

• The rate that bytes are being sent (bytes/second).

• The number of NDRs generated.

• The time that it takes for message to be sent by the Voice Connector.

The format for the performance log is:

Date Time ThreadId Address Type=<Type> Message Status=<Status> Size=<size KB> Time In 
Queue=(time sec)

Field Description

Type Indicates the address type of the message, and can be either AMIS, VOICE, VPIM, or 
Bridge.
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Changing the Voice Connector Logging Properties

Use the appropriate procedure to change the Voice Connector logging:

• To change the Voice Connector for Exchange 2000 logging settings, page 2-12

• To change the Voice Connector for Exchange 5.5 logging settings, page 2-12

To change the Voice Connector for Exchange 2000 logging settings

Step 1 Log on to the Exchange server on which the Voice Connector is installed.

Step 2 From the Windows Start menu, click Programs > Microsoft Exchange > Exchange System Manager.

Step 3 Expand the Connectors container in the left-hand pane.

Step 4 Right-click Exchange 2000 Voice Connector (<server name>), and select Properties.

Step 5 Click the Advanced tab.

Step 6 Adjust the logging level and the other settings as needed. If you change the directory where the log files 
are created, be sure to end the path with a backslash (“\”).

Note that if you increase the logging level (the default is Warning), the log file size increases. This could 
become an issue if hard-disk space is a concern.

Step 7 Click OK and close Exchange System Manager.

Step 8 Open the Windows Services Applet.

Step 9 Right-click Exchange 2000 Voice Connector and select Restart.

Step 10 Close the Windows Services Applet.

To change the Voice Connector for Exchange 5.5 logging settings

Step 1 Log on to the Exchange server on which the Voice Connector is installed, and start Regedit.

Status Indicates the kind of message, and can be one of the following: Incoming, Outgoing, 
NDR for Incoming, NDR for Outgoing.

Time in 
Queue

Measured in seconds, the Time in Queue has a different meaning depending on the 
message status.

• Outgoing message—The difference between the current time and the time the 
message was submitted by the telephone user interface, ViewMail, or Cisco Unity 
Inbox. This includes the time taken by the Exchange MTA to process the message 
and deliver it to the Voice Connector queue.

• Incoming message—The difference between the current time and the time the 
message was received by Exchange.

• NDR messages—The difference between the current time and the time the 
original message was processed (and NDR is generated). Typically, this will be 0 
or close to 0.

Field Description
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Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for Cisco Unity failover, 
registry changes on one Cisco Unity server must be made manually on the other Cisco Unity 
server, because registry changes are not replicated.

Step 2 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 3 To change the number of days to keep the log files before they are deleted:

a. Expand the following key: 

HKEY_LOCAL_MACHINE\Software\ActiveVoice\AvIVC

b. Double-click LogCycleDays to display the Edit DWORD Value dialog box.

c. Select Hexidecimal or Decimal to indicate the base of the value that you will enter.

d. Enter the number and then click OK.

Step 4 To change the logging level:

a. Expand the following key:

HKEY_LOCAL_MACHINE\Software\ActiveVoice\AvIVC\

b. Double-click LogLevel to display the Edit DWORD Value dialog box.

c. Enter a number from 0 to 5, where 0 indicates no logging and 5 indicates the highest logging level, 
and then click OK.

Step 5 To change the location of the log files:

a. Expand the following key:

HKEY_LOCAL_MACHINE\Software\ActiveVoice\AvIVC

b. Double-click LoggingPath to display the Edit String dialog box.

c. Enter the full directory path where the log files are to be created. Be sure to end the path with a 
backslash ( “\”).

Step 6 Click OK, and close Regedit. 

Step 7 Open the Windows Services Applet.

Step 8 Right-click Exchange 2000 Voice Connector and select Restart.

Step 9 Close the Windows Services Applet.

Retaining Outbound VPIM, Bridge, and SMTP Messages Temporarily

If needed for troubleshooting message delivery problems, you can change a registry setting so that 
outbound VPIM, Bridge, and SMTP messages processed by the Voice Connector are copied as text files 
to a specified directory. This setting does not apply to outbound AMIS messages.
2-13
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01



Chapter 2 Logs and Traces
Cisco Unity and Third-Party Logs and Traces
To retain outbound VPIM, Bridge, and SMTP messages processed by the Voice Connector

Step 1 Log on to the Exchange server on which the Voice Connector is installed, and start Regedit.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for Cisco Unity failover, 
registry changes on one Cisco Unity server must be made manually on the other Cisco Unity 
server, because registry changes are not replicated.

Step 2 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 3 Expand the following key:

HKEY_LOCAL_MACHINE\Software\ActiveVoice\AvIVC key

Step 4 Click Edit > New > String Value. Enter StoreFiles as the name.

Step 5 Double-click StoreFiles to display the Edit String dialog box.

Step 6 Enter the full directory path where the log files are to be created. Be sure to end the path with a backslash 
( “\”).

Step 7 Click OK and close Regedit.

Step 8 Open the Windows Services Applet.

Step 9 Right-click Exchange 2000 Voice Connector and select Restart.

Step 10 Close the Windows Services Applet.

When finished troubleshooting, be sure to delete the StoreFiles key that you created in the registry, and 
restart the Voice Connector service.
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Internal and External Calls

About Problems with Internal and External Calls
Call problems fall into two categories:

If you encounter a call problem that is not described in this chapter, contact the Cisco Technical 
Assistance Center (TAC).

Cisco Unity Is Not Answering Any Internal and/or External Calls
There are several possible reasons that Cisco Unity may not answer any internal and/or external calls. 
Use the Task List for Troubleshooting No Answers on Incoming Calls to troubleshoot the possible 
causes.

Task List for Troubleshooting No Answers on Incoming Calls

1. Confirm that the phone system settings are correct. See the “Confirming the Phone System Settings” 
section on page 3-2.

2. Confirm that Cisco Unity was restarted after an Exchange shutdown. See the “Confirming that 
Cisco Unity Was Restarted After an Exchange Shutdown and Restart” section on page 3-2.

3. (Serial integrations only) Confirm that a COM port is available. See the “Confirming that a COM 
Port Is Available to Cisco Unity (Serial or SMDI Integrations Only)” section on page 3-2.

4. If callers hear reorder tone or dead air shortly after Cisco Unity startup, enable the 
ForceGlobalAcmThreadSafety Registry Setting. See the “Enabling the 
ForceGlobalAcmThreadSafety Registry Setting When Corruption in Windows ACM Causes Callers 
to Hear Reorder Tone or Dead Air Shortly After Cisco Unity Startup” section on page 3-3.

No internal or external 
calls are answered

Problems that prevent internal calls from being answered are a subset of 
problems that prevent external calls from being answered. See the 
“Cisco Unity Is Not Answering Any Internal and/or External Calls” section 
on page 3-1.

Some internal or external 
calls are answered

If you determine that the problem occurs only with some internal or external 
calls, see the “Cisco Unity Is Not Answering Some Internal or External 
Calls” section on page 3-5.
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5. (Circuit-switched systems only) Confirm that the phone system generates a ring signal. See the 
“Confirming that the Phone System Generates a Ring Signal (Circuit-Switched Systems Only)” 
section on page 3-5.

Confirming the Phone System Settings

When the phone system settings in the Cisco Unity Telephony Integration Manager (UTIM) do not 
match the type of phone system that Cisco Unity is connected to, Cisco Unity may not answer calls.

To confirm the phone system settings in UTIM

Step 1 On the Cisco Unity server, browse to the CommServer\Utilities\Utim directory and double-click 
Utim.exe. UTIM appears.

Step 2 Confirm that the settings match those indicated in the integration guide for your phone system.

Step 3 Correct any incorrect values for the phone system.

Step 4 If you changed values in Step 3, click Save.

Step 5 If prompted, restart the Cisco Unity server.

Confirming that Cisco Unity Was Restarted After an Exchange Shutdown and Restart

When you shut down and restart Microsoft Exchange on the Cisco Unity server, Cisco Unity may need 
to be restarted manually.

Confirming that a COM Port Is Available to Cisco Unity (Serial or SMDI Integrations Only)

Serial or SMDI traffic during a Windows startup may result in Windows assigning the COM port to a 
serial mouse, thus making the COM port unavailable to Cisco Unity. When Windows starts, it searches 
for the pointing device (usually a mouse). If a serial mouse is detected, Windows disables the port so 
that a device driver for the mouse can load instead. If no device is detected, Windows disables the port. 
A disabled COM port does not display any information in Control Panel > Ports.

If the serial integration was working correctly before shutting down and restarting the Cisco Unity 
server, but not after, do the following procedure to determine whether the COM port is available.

To view COM port assignments

Step 1 On the Windows Start menu, click Control Panel > Ports.

Step 2 Confirm that the COM port connected to the serial cable, usually COM1, is listed in the Ports box.

If the COM port for the serial integration is listed, skip to the “Confirming that the Phone System 
Generates a Ring Signal (Circuit-Switched Systems Only)” section on page 3-5.

If the COM port for the serial integration is not listed, continue with Step 3.

Step 3 On the Windows Start menu, click Run. Enter Regedit and click OK.

Step 4 Click HKEY_LOCAL_MACHINE > Hardware > Description > System > MultifunctionAdapter.

Step 5 Click folder 4, 5, or 6 and locate the SerialController folder.
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Step 6 The SerialController folder contains folders with a single-digit numeric designation (0, 1, and so on). 
Click the folder that corresponds to the serial integration COM port number.

Step 7 Double-click the Identifier key in the folder you chose in Step 6. If the Identifier key Value Data refers 
to a mouse—for example Microsoft Ballpoint Serial Mouse—instead of a COM port (COM1, COM2, 
and so on), continue with the next procedure, To disable the detection of devices on COM ports in 
Windows.

To disable the detection of devices on COM ports in Windows

Step 1 Make a backup copy of the Boot.ini file.

Step 2 Remove the Hidden, System, and Read-only attributes from the Boot.ini file.

Step 3 Using a text editor (such as Notepad) open the Boot.ini file.

Step 4 Add the /NoSerialMice option to the end of each entry in the [operating systems] section of Boot.ini. 
The /NoSerialMice option is not case sensitive. See the following list for syntax options.

Sample Windows Boot.ini file with /NoSerialMice option added:

[boot loader]
   timeout=3
   default=multi(0)disk(0)rdisk(0)partition(1)\WINNT35
[operating systems]
   multi(0)disk(0)rdisk(0)partition(1)\WINNT35="Windows NT Workstation
      Version 3.51" /NoSerialMice
multi(0)disk(0)rdisk(0)partition(1)\WINNT35="Windows NT Workstation
      Version 3.51 [VGA mode]" /basevideo /sos /NoSerialMice

Step 5 Save the Boot.ini file, and exit the text editor.

Step 6 Restore the Hidden, System, and Read-only attributes to the Boot.ini file.

Step 7 Shut down and restart Windows.

Enabling the ForceGlobalAcmThreadSafety Registry Setting When Corruption in Windows ACM 
Causes Callers to Hear Reorder Tone or Dead Air Shortly After Cisco Unity Startup

A few sites have experienced a problem when using both G.711 and G.729a codecs with Cisco Unity. 
The problem occurs shortly after Cisco Unity starts. Calls received immediately after startup are 
answered, but within a few minutes, Cisco Unity stops answering calls.

This problem occurs only when all of the following conditions are present:

• When transcoding between G.729a and G.711 codecs is required in a Cisco Unity system. This 
includes any instances of G.729a prompts, messages, or greetings, even if Cisco Unity is in a G.711 
region. The possibility that this problem can exist on a G.711 system has not been completely ruled 
out.

/NoSerialMice Disables the detection of serial mice on all COM ports.

/NoSerialMice:COM<x> Disables the detection of serial mice on the COM<x> port.

/NoSerialMice:COM<x,y,z> Disables the detection of serial mice on COM<x, y and z> ports. 
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• When there are identical sequences of MIU wave errors in the Event log from more than one port at 
the same time, beginning with:

Component Miu: Thread 0x<NUM> had a Failure on Port X in AvWav

There will usually be four to six of these errors from one port intermingled with an identical 
sequence of four to six errors from another port. Errors from other ports may also be present.

• When the problem occurs within a few minutes of system startup, and when it can be consistently 
reproduced. When this happens, restarting the Cisco Unity server eliminates the problem 
temporarily, but it reoccurs. If a problem with similar symptoms occurs days after startup, or is 
sporadic, it is likely a different problem.

When Cisco Unity transcodes wave formats, it uses Microsoft Windows ACM (Audio Compression 
Manager) to call into the third-party G.729a codec. When multiple threads call into the Windows ACM 
function AcmStreamConvert() at the same time, they can conflict with one another and generate errors, 
causing callers to hear dead air or the reorder tone. Restarting the Cisco Unity server clears the 
corruption in Windows ACM temporarily, but it does not prevent the problem from reoccurring.

An application-level workaround, an optional registry setting, makes Windows ACM globally 
thread-safe. To enable the registry setting, do the procedure, To enable the 
ForceGlobalAcmThreadSafety registry setting, page 3-4.

The procedure is not required on all systems that use transcoding. Because it can have a performance 
impact, it should be done only if all of the conditions listed above are present.

To enable the ForceGlobalAcmThreadSafety registry setting

Step 1 Start Regedit.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for a Cisco Unity 
failover system, registry changes on one Cisco Unity server must be made manually on the 
other Cisco Unity server, because registry changes are not replicated. If you have any 
questions about changing registry key settings, contact Cisco TAC. 

Step 2 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 3 Expand HKEY_LOCAL_MACHINE\Software\ActiveVoice.

Step 4 On the Edit menu, click New Key.

Step 5 Name the new key UnityAvWav.

Step 6 Click the new UnityAvWav key, then on the Edit menu, click New Key.

Step 7 Name the new key 1.0.

Step 8 Click the new 1.0 key, then on the Edit menu, click New Dword.

Step 9 Name the new Dword ForceGlobalAcmThreadSafety, and set the Value to 1.

Step 10 Close the Registry Editor.

Step 11 Restart the Cisco Unity server for the settings to take effect.
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Step 12 Confirm that the problem does not reoccur within the first few minutes after Cisco Unity restarts. If the 
problem does reoccur, set the ForceGlobalAcmThreadSafety DWORD Value back to 0, to avoid a system 
performance impact. Contact Cisco TAC for further assistance.

Confirming that the Phone System Generates a Ring Signal (Circuit-Switched Systems Only)

In order for Cisco Unity to answer calls, all ports and trunks must be configured correctly.

To test whether the phone system is generating a ring signal

Step 1 Set up a test phone (Phone 1) for single-line testing. For more information, see the “Preparations for 
Troubleshooting the Phone System” section on page 1-1.

Step 2 On an extension that is connected to the phone system but that is not connected to Cisco Unity (Phone 2), 
call Phone 1.

If Phone 1 rings, the phone system recognizes the port and is generating a ring signal.

If Phone 1 does not ring, skip to Step 6.

Step 3 Repeat Step 2 for each extension that is normally connected to Cisco Unity.

Step 4 On Phone 2, dial the access code necessary to get an external line, then call Phone 1.

If Phone 1 rings, the trunk is configured correctly to be answered by Cisco Unity ports. Continue with 
Step 5.

If Phone 1 does not ring, skip to Step 6.

Step 5 Repeat Step 4 for each extension that is normally connected to Cisco Unity.

Step 6 Verify the phone system programming, and change values as necessary.

Step 7 Confirm that the wiring and the jacks are securely connected.

Step 8 Repeat Step 1 through Step 5.

If Phone 1 rings for each extension tested, the phone system is generating a ring signal and the ports and 
trunks are programmed correctly.

If Phone 1 still does not ring for each extension tested, contact the phone system vendor.

Cisco Unity Is Not Answering Some Internal or External Calls
There are several possible reasons that Cisco Unity may not answer some internal and/or external calls. 
Use the Task List for Troubleshooting Sporadic Answers on Incoming Calls to troubleshoot the possible 
causes.

Task List for Troubleshooting Sporadic Answers on Incoming Calls

1. Confirm that the hunt group programming is correct. See the “Confirming Hunt Groups” section on 
page 3-6.
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2. Confirm that the routing rules are working correctly. See the “Confirming Routing Rules” section 
on page 3-9.

3. Verify the number of licensed voice messaging ports is correct. See the “Confirming Voice 
Messaging Port Licensing” section on page 3-9.

4. Confirm that calls are sent to the correct voice messaging ports and that the ports are enabled. See 
the “Confirming Voice Messaging Port Settings” section on page 3-10.

5. Confirm that the phone lines and voice cards are working correctly. See the “Confirming Phone 
Lines and Voice Cards” section on page 3-11.

Confirming Hunt Groups

Depending on your phone system and whether Cisco Unity failover is installed, do one of the following 
procedures, as applicable, to verify the hunt group programming for voice messaging ports on the phone 
system.

To verify hunt group programming for voice messaging ports (Cisco CallManager integration without Cisco Unity 
failover)

Step 1 In Cisco CallManager Administration, click Service > Service Parameters.

Step 2 On the Service Parameters Configuration page, click the server that Cisco CallManager is installed on.

Step 3 In the Configured Services list, click Cisco CallManager.

Step 4 In the Configured Service Parameters list, click VoiceMailMaximumHopCount.

Step 5 Confirm that VoiceMailMaximumHopCount is set to a value of two more than the number of Cisco 
CallManager ports connected to Cisco Unity. For example, on a 48-port system, the 
VoiceMailMaximumHopCount should be set to 50.

Step 6 Confirm that the voice messaging ports are set to forward both when busy and when not answered.

Step 7 Set up two test phones. For more information, see the “Setting Up For a Diagnostic Test (Cisco 
CallManager or SIP Integrations Only)” section on page 1-1.

Step 8 From a phone (not the test phones), dial the extension of the first voice messaging port, and leave the 
voice messaging port in a busy state.

Step 9 Access an external line from test Phone 2, and call test Phone 1. The first available port should take the 
call.

Step 10 Release the busy voice messaging port.

Step 11 In the Cisco Unity Administrator, go to the System > Ports page, and disable the port you just tested by 
unchecking the Enabled check box for that port.

Step 12 From a phone (not the test phones), dial the extension of the next voice messaging port, and leave the 
voice messaging port in a busy state.

Step 13 Repeat Step 9 through Step 12 until all the voice messaging ports have been tested in a busy state. When 
all voice messaging ports are disabled, and the last port is busy, Cisco CallManager should do whatever 
you programmed it to do when all lines are busy, such as forward the call to the attendant number. If this 
does not happen, change the Cisco CallManager programming and repeat the test.
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To verify hunt group programming for voice messaging ports (Cisco CallManager integration with Cisco Unity 
failover)

Step 1 In Cisco CallManager Administration, click Service > Service Parameters.

Step 2 On the Service Parameters Configuration page, click the server that Cisco CallManager is installed on.

Step 3 In the Configured Services list, click Cisco CallManager.

Step 4 In the Configured Service Parameters list, click VoiceMailMaximumHopCount.

Step 5 Confirm that VoiceMailMaximumHopCount is set to a value of twice the number of Cisco 
CallManager ports connected to Cisco Unity. For example, on a 48-port system, the 
VoiceMailMaximumHopCount should be set to 96.

Step 6 For the ports connected to the Cisco Unity primary server, confirm that the voice messaging ports that 
answer calls are set to forward both when busy and when not answered as described in the applicable 
Cisco CallManager integration guide.

For the ports connected to the Cisco Unity secondary server, confirm that the voice messaging ports that 
answer calls are set to forward both when busy and when not answered as described in the applicable 
Cisco CallManager integration guide.

Step 7 Set up two test phones. For more information, see the “Setting Up For a Diagnostic Test (Cisco 
CallManager or SIP Integrations Only)” section on page 1-1.

Step 8 On the Cisco Unity primary server, on the Windows Start menu, click Programs > Cisco Unity > 
Failover Monitor.

Step 9 In the Services section, confirm that the primary server is active and the secondary server is inactive.

Step 10 Click Advanced.

Step 11 Check the Disable Automatic Failover and Failback check box.

Step 12 Click OK to close the Failover Monitor.

Step 13 From a phone (not the test phones), dial the extension of the first voice messaging port on the primary 
server, and leave the voice messaging port in a busy state.

Step 14 Access an external line from test Phone 2, and call test Phone 1. The first available port for the primary 
server should take the call.

Step 15 Release the busy voice messaging port on the primary server.

Step 16 In the Cisco Unity Administrator on the primary server, go to the System > Ports page, and disable the 
port you just tested by unchecking the Enabled check box for that port.

Step 17 From a phone (not the test phones), dial the extension of the next voice messaging port on the primary 
server, and leave the voice messaging port in a busy state.

Step 18 Repeat Step 14 through Step 17 until all the voice messaging ports on the primary server have been tested 
in a busy state. When all voice messaging ports are disabled, and the last port is busy, Cisco CallManager 
should do whatever you programmed it to do when all lines are busy, such as forward the call to the 
attendant number. If this does not happen, change the Cisco CallManager programming and repeat the 
test.

Step 19 On the primary server, on the Windows Start menu, click Programs > Cisco Unity > Failover Monitor.

Step 20 Click Force Inactive.

Step 21 Click OK to confirm. The primary server become inactive.

Step 22 On the secondary server, on the Windows Start menu, click Programs > Cisco Unity > Failover 
Monitor.
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Step 23 Click Force Active.

Step 24 Click OK to confirm. The secondary server become inactive.

Step 25 Repeat Step 13 through Step 17 on the secondary server to verify hunt group programming.

Step 26 In the Cisco Unity Administrator on the secondary server, go to the System > Ports page, and enable the 
ports you tested by checking the Enabled check box for those ports. Then enable the ports you tested on 
the primary server.

Step 27 On the secondary server, on the Windows Start menu, click Programs > Cisco Unity > Failover 
Monitor.

Step 28 Click Force Inactive.

Step 29 Click OK to confirm. The secondary server become inactive.

Step 30 On the primary server, on the Windows Start menu, click Programs > Cisco Unity > Failover Monitor.

Step 31 Click Force Active.

Step 32 Click OK to confirm. The primary server become inactive.

Step 33 In the Failover Monitor on the primary server, click Advanced.

Step 34 Uncheck the Disable Automatic Failover and Failback check box.

Step 35 Click OK.

To verify hunt group programming (circuit-switched phone systems only)

Step 1 Set up a test phone (Phone 1) for single-line testing. For more information, see the “Preparations for 
Troubleshooting the Phone System” section on page 1-1.

Step 2 Connect Phone 1 to the last line in the first hunt group.

Step 3 Busy every extension in the first hunt group except the last one by using the phone system programming.

Step 4 From an extension that is connected to the phone system but that is not connected to Cisco Unity 
(Phone 2), dial the first hunt group pilot number.

If Phone 1 rings, continue with Step 5.

If you hear the busy tone or if Phone 1 does not ring, verify the phone system programming for the first 
hunt group and change values as necessary, then repeat this step. If Phone 1 still does not ring, contact 
the phone system vendor.

Step 5 Busy the last extension, so that every extension in the first hunt group is busied.

Step 6 On Phone 2, dial the first hunt group pilot number again.

If you hear the busy tone, the first hunt group is programmed correctly.

If you do not hear the busy tone, verify the phone system programming for the first hunt group and 
change values as necessary, then repeat this step. If you still do not hear the busy tone, contact the phone 
system vendor.

For details on programming hunt groups, see the documentation for your phone system.

Step 7 Repeat Step 1 through Step 6 for each hunt group.
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Confirming Routing Rules

By default, Cisco Unity does not reject any calls. If routing rules have been changed, Cisco Unity may 
have been unintentionally programmed to reject some internal or external calls.

To confirm that Cisco Unity routing rules are working correctly

Step 1 On the Cisco Unity desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane of the Tools Depot window, under Diagnostic Tools, double-click Unity Diagnostic Tool.

Step 3 On the Cisco Unity Diagnostic Viewer screen, click the Configure Micro Traces icon.

Step 4 In the Groups list, click Arbiter.

Step 5 In the Flags list, click Diagnostics 14, 15, and 16.

Step 6 In the Groups list, click Ruler Domain.

Step 7 In the Flags list, click Diagnostic 11.

Step 8 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 9 Reproduce the problem.

Step 10 To view the log files, in the left pane of the Cisco Unity Diagnostic Viewer screen, click 
Process > AvCsMgr, and then click the Current log file.

Step 11 The selected log file is formatted and displayed in the right pane.

Step 12 To export or save a copy of the log file, click Action > Export list.

Step 13 Name the file and save it to a location of your choice in .txt or .csv format. 

Step 14 To turn off the traces set in Step 4 through Step 7, on the Cisco Unity Diagnostic Viewer screen, click 
Disable All Traces.

Step 15 Go to the \CommServer\TechTools directory.

Step 16 Open the AvRulerEditor.

Step 17 Click Routing to view the actual conditions of routing rules. Compare the conditions of the routing rules 
with the information gathered from the diagnostic file to see why a rule is applied to a call.

Step 18 If you need to make a change to a routing rule, in the Cisco Unity Administrator, go to the Call 
Management > Call Routing page.

Note Do not use AvRulerEditor to change routing rules.

If you are unable to determine if routing rules are the source of the problem, or if you need assistance 
interpreting the information in the diagnostic logs or AvRulerEditor, contact Cisco TAC.

Confirming Voice Messaging Port Licensing

When more voice messaging ports are installed on the Cisco Unity server than are licensed, Cisco Unity 
does not answer calls on the extra ports. (For example, if the voice cards in the Cisco Unity server have 
48 ports but only 24 ports are licensed, Cisco Unity will answer calls only on the first 24 ports.)
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To confirm the number of ports

Step 1 On the Cisco Unity server, on the Windows Start menu, click Programs > Cisco Unity > Licensing.

Step 2 Confirm that the Voice Ports value matches the number of ports on the voice cards.

If the values match, continue with the following “Confirming Voice Messaging Port Settings” section. 
If the value is smaller than the number of ports on voice cards in the Cisco Unity server, contact your 
sales representative.

Confirming Voice Messaging Port Settings

If the phone system is programmed to send calls to a voice messaging port on Cisco Unity that is not 
configured to answer calls, Cisco Unity will not answer the call.

To confirm that calls are being sent to the correct voice messaging ports on Cisco Unity

Step 1 In the Cisco Unity Administrator, go to the System > Ports page.

Step 2 Note which ports are designated to answer calls.

Step 3 In the phone system programming, confirm that calls are being sent only to those ports designated to 
answer calls. Change the phone system programming if necessary.

Step 4 If you made a change to the phone system programming in Step 3, shut down and restart the Cisco Unity 
server to clear any hung ports.

If a voice messaging port is disabled or set incorrectly, it will not answer calls.

To confirm that voice messaging ports are set correctly

Step 1 In the Cisco Unity Administrator, go to the System > Ports page.

Step 2 Verify the settings for each voice messaging port.

If a port is not enabled, check the Enabled check box to enable it.

If all of the ports are enabled and set correctly, continue with the “Confirming Phone Lines and Voice 
Cards” section on page 3-11.

If all of the ports cannot be enabled by using the Cisco Unity Administrator, do the procedure, To enable 
voice messaging ports in the registry, page 3-10.

To enable voice messaging ports in the registry

Caution Changing the wrong registry key or entering an incorrect value can cause the server to malfunction. 
Before you edit the registry, confirm that you know how to restore it if a problem occurs. (Refer to the 
“Restoring” topics in Registry Editor Help.) Note that a typical backup of the Cisco Unity server does 
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not back up the registry. Also note that for Cisco Unity failover, registry changes on one Cisco Unity 
server must be made manually on the other Cisco Unity server, because registry changes are not 
replicated. If you have any questions about changing registry key settings, contact Cisco TAC. 

Step 1 On the Windows Start menu, click Run.

Step 2 Enter Regedit and click OK.

Step 3 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 4 Click HKEY_LOCAL_MACHINE > Software > ActiveVoice > Arbiter > 1.0 > 
PortConfiguration > Dev<n>, where <n> is the number of the disabled port.

Step 5 Double-click Capabilities.

Step 6 In the Edit Dword Value window, change the Capabilities to 0xfffffff.

Step 7 While still in the HKEY_LOCAL_MACHINE > Software > ActiveVoice directory, click 
Miu > 1.0 > Initialization > Port<n>, where <n> is the number of the disabled port.

Step 8 Change the OfflineStatus to 0x0.

Step 9 Restart the Cisco Unity server.

Step 10 In the Cisco Unity Administrator, go to the System > Ports page.

Confirm that all ports are enabled. If a port is still not enabled, contact Cisco TAC.

Confirming Phone Lines and Voice Cards

To isolate a problem with a phone line or voice card

Step 1 Swap the phone lines from one jack to another on a voice card.

If the problem follows a phone line, the problem is in the phone line.

Step 2 Swap the phone lines from a jack on one voice card to a jack on another voice card.

If the problem follows a jack, the problem is in the jack.

Step 3 Swap the locations of voice cards.

If the problem follows a voice card, the problem is in the card.

For information on testing Dialogic voice cards, see the “Universal Dialogic Diagnostics Utility” section 
on page 11-14.

Related section

• The “Voice Messaging Port Settings” section in the “System Settings” chapter of the Cisco Unity 
System Administration Guide. The Cisco Unity System Administration Guide is available on 
Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_
list.html.
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Call Transfers

About Call Transfer Problems
Call transfer problems fall into two categories:

If you encounter a call transfer problem that is not described in this chapter, contact the Cisco Technical 
Assistance Center (TAC).

Calls Are Not Transferred to the Correct Greeting
The following sections describe possible reasons that calls may not be transferred to the correct greeting. 
Use the Task List for Troubleshooting Call Transfers to the Wrong Greeting to troubleshoot the possible 
causes.

Task List for Troubleshooting Call Transfers to the Wrong Greeting

1. Confirm that the forward timer in the phone system is synchronized with the Rings To Wait For 
setting in Cisco Unity. See the “Confirming that the Forward Timer in the Phone System Is in Synch 
with the Rings To Wait For Setting in Cisco Unity” section on page 4-2.

2. Confirm that the phone system programming enables callers to hear the subscriber personal 
greeting. See the “Confirming that the Phone System Programming Enables Callers To Hear the 
Subscriber Personal Greeting” section on page 4-3.

Problems on a newly 
installed or upgraded 
system 

For call transfer problems that occur on newly installed systems or on systems 
that have just been upgraded, refer to the Cisco Unity integration guide for your 
system.

Problems on an 
existing system 

See the “Calls Are Not Transferred to the Correct Greeting” section on page 4-1, 
or the “Subscriber Hears a Reorder Tone When Answering a Call from 
Cisco Unity” section on page 4-3.
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Confirming that the Forward Timer in the Phone System Is in Synch with the Rings To Wait For 
Setting in Cisco Unity

For supervised transfers, the number of rings that Cisco Unity waits before routing a call to a subscriber 
personal greeting (or to another extension) can be reconfigured. If the phone system is programmed to 
forward calls, confirm that the phone system waits longer to forward a call than Cisco Unity waits before 
taking a message.

If the phone system is forwarding the call to another extension before Cisco Unity can take a message, 
the following may occur:

• The caller does not hear the beginning of the subscriber personal greeting. (For example, the 
subscriber greeting is “Hi, this is Maria Ramirez. Please leave a message after the tone.” But the 
caller hears only “...message after the tone.”)

• The call is forwarded to another phone (for example, the operator) rather than to the subscriber 
personal greeting.

• The call is forwarded to the opening greeting.

• The caller hears only ringing.

To synchronize the forward timer and the Rings To Wait For setting

Step 1 In the phone system programming, find the value of the forward timer.

Step 2 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Call Transfer page.

Step 3 Click Find, and find the subscriber whose calls are not being routed to the correct greeting.

Step 4 In the Transfer Incoming Calls to Subscriber’s Phone section, confirm that the Yes, Ring Subscriber’s 
Extension check box is checked.

Step 5 In the Transfer Type section, confirm that the Supervise Transfer check box is checked.

Step 6 In the Rings To Wait For box, the value should be two rings less than the value of the forward timer of 
the phone system, which you found in Step 1; this value is typically not greater than four, and is never 
greater than eight. This value specifies the number of rings that Cisco Unity waits before routing the call 
to the subscriber personal greeting.

If the values do not meet the parameters, either reprogram the phone system so it waits longer before 
forwarding unanswered calls, or change the value in the Rings To Wait For box so that Cisco Unity 
routes the call before the phone system forwards it.

Step 7 To change the default Rings To Wait For value for all subscribers, go to the Subscribers > Subscriber 
Template > Call Transfer page.

If you change the value in the subscriber template, note that the value for existing subscriber accounts 
is not changed. Changing the template affects only the value for subscriber accounts that are created after 
the template is changed.

Step 8 Determine whether the phone system changes the ringback cadence after a certain number of rings. If 
so, in the Cisco Unity Administrator, set the Rings To Wait For value to a number less than the number 
of rings at the initial cadence.

Step 9 If you have determined that the phone system is waiting longer to forward a call than Cisco Unity is 
waiting to take a message, but Cisco Unity still is not routing calls to the correct greeting, run the Learn 
Tones utility. For more information, see the “Learn Tones” section on page 11-5.
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If you have run the Learn Tones utility, and Cisco Unity still is not routing calls to the correct greeting, 
contact Cisco TAC.

Confirming that the Phone System Programming Enables Callers To Hear the Subscriber Personal 
Greeting

When callers hear the opening greeting instead of a subscriber personal greeting, confirm that the 
integration is enabled and that the phone system settings are correct. If the settings are incorrect, call 
forward to personal greeting and easy message access will not be enabled. Do one of the following 
procedures, depending on your phone system integration.

To verify the phone system settings for the integration (all integrations)

Step 1 On the Cisco Unity server, browse to the CommServer\Utilities\Utim directory and double-click 
Utim.exe. The Cisco Unity Telephony Integration Manager (UTIM) appears.

Step 2 Confirm that the settings match those indicated in the integration guide for your phone system.

Step 3 Correct any incorrect values for the phone system, and click Save.

Step 4 If prompted, restart the Cisco Unity server.

Step 5 If you have confirmed that the phone system settings are correct, and callers still hear the opening 
greeting after dialing the subscriber extension, contact Cisco TAC.

To verify the phone system programming (Ericsson MD-110 integration only)

Step 1 On the phone system, confirm that the Prefix digits for forwarded calls and for easy message access are 
programmed correctly.

Step 2 Confirm that the called extension has Coverage On No Answer set to forward to the voice messaging 
system.

Subscriber Hears a Reorder Tone When Answering a Call from 
Cisco Unity

A possible cause for this problem is that the Rings to Wait For settings are incorrect.

Cisco Unity requires a minimum setting of three rings to wait to properly transfer a call or to make a 
message notification call. If the number of rings to wait is set to less than three, a subscriber may hear 
the reorder tone instead of the Cisco Unity conversation.

To correct the Rings to Wait For settings

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page 
for the subscriber.
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Step 2 In the Notification Options section for each device used, set the Wait For How Many Rings Before 
Hanging Up box to three or more rings.

Step 3 Go to the Subscribers > Subscriber Template > Message Notification page.

Step 4 In the Notification Options section for each device used, confirm that the Wait For How Many Rings 
Before Hanging Up box is set to three or more rings. This ensures that future subscriber accounts get the 
correct default value.

If the default setting in the subscriber template is incorrect, you will need to change the value in all 
subscriber accounts that are based on that template.

Step 5 Go to the Call Management > Call Handlers > Call Transfer page.

Step 6 View the Standard, Alternate, and Closed rules. In the Transfer Type section, if Supervise Transfer is 
selected for any of the rules, confirm that the Rings To Wait For box is set to three or more rings.

If Rings To Wait For is set correctly, and the subscriber still hears a reorder tone when answering a call 
from Cisco Unity, contact Cisco TAC.
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Messages

About Problems with Messages
Message problems fall into four categories:

.

Begin your troubleshooting by gathering information about the message problem. By discussing the 
problem with the subscriber, sometimes you can determine whether a problem is due to a 
misunderstanding of how Cisco Unity works. If you encounter a message problem that is not described 
in this section, contact the Cisco Technical Assistance Center (TAC).

Messages Appear to Be Delayed
The following sections describe possible reasons that messages may appear to be delayed. Use the Task 
List for Troubleshooting Delay in Appearance of Messages to troubleshoot the possible causes.

Messages appear to be 
delayed

Some subscriber errors or misconceptions can lead to the impression that 
Cisco Unity is delaying messages. See the “Messages Appear to Be Delayed” 
section on page 5-1.

Messages seem to 
disappear

Some Exchange and Cisco Unity situations can affect message delivery. See 
the “Some Messages Seem to Disappear” section on page 5-3. 

Outbound AMIS 
messages are not 
delivered

See the “Troubleshooting Problems with Outbound AMIS Messages” section 
on page 5-5

Inbound AMIS 
messages are not 
delivered

See the “Troubleshooting Problems with Inbound AMIS Messages” section on 
page 5-9.

Messages are 
incomplete

A setup problem may cause callers to be cut off when they try to leave a 
message. See the “Cisco Unity Stops Recording Before a Caller Has Finished 
Leaving a Message” section on page 5-17.

Messages include dial 
tone or reorder tone

See the “Dial Tone or Reorder Tone Is Present at the End of a Message” section 
on page 5-18.
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Task List for Troubleshooting Delay in Appearance of Messages

1. Check to see if the Exchange server is down or disconnected. See the “Cisco Unity Primary 
Exchange Server Is Down or Is Disconnected” section on page 5-2.

2. Investigate whether the subscriber misunderstands how Cisco Unity delivers messages. See the 
“Subscriber Misunderstandings” section on page 5-2.

3. If the messages in question are AMIS messages, see the “AMIS Messages Are Unable to Be 
Delivered Promptly” section on page 5-2.

Note To confirm the arrival times of messages, generate a subscriber message activity report for the 
subscriber. For more information, refer to the “Subscriber Message Activity Report” section in the 
“Reports” chapter of the Cisco Unity System Administration Guide, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_list.
html.

Cisco Unity Primary Exchange Server Is Down or Is Disconnected

Messages recorded while the primary Exchange server is down or disconnected are stored in the Unity 
Messaging Repository (UMR) until the server is brought back up. Because calls for message notification 
and MWIs are not made until a message is actually delivered to a subscriber, the delay experienced 
between the time a message is recorded and its delivery is dependent on the amount of time that the 
primary Exchange server was down or disconnected.

Subscriber Misunderstandings

• A subscriber misunderstands the use of the # key—When a subscriber presses the # key while 
listening to a message, Cisco Unity saves the message as a new message and skips to the next 
message. Later, the subscriber checks messages again, hears the same message, and believes the 
message arrived after a delay.

Explain to the subscriber that pressing the # key while a message plays saves it as a new message.

• System clock time is incorrect—When the system clock is slow or when a desk clock is fast, the 
subscriber may believe messages were delayed.

Confirm that the system clock on the Cisco Unity server is reporting the correct time.

• Exchange settings were updated—When settings are changed for a subscriber in Exchange, the 
new values may not be reflected immediately in Cisco Unity.

Explain to the subscriber that the settings may take a few minutes to synchronize, causing a delay 
in receipt of messages.

AMIS Messages Are Unable to Be Delivered Promptly

There are a number of reasons why AMIS messages may not be delivered promptly (or why they may 
be perceived as not being delivered promptly):

• Outbound AMIS messages can be restricted to use only certain voice messaging ports. If the ports 
designated to handle AMIS messages are busy with other calls, outbound AMIS messages can be 
delayed. The AMIS Out Traffic report shows AMIS outbound traffic and total transmission time 
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used. If the total transmission time approaches the limit of the ports dedicated to AMIS deliveries, 
review the AMIS schedule and port assignments to determine if additional resources (time and/or 
ports) should be dedicated to AMIS message traffic.

• AMIS delivery of non-urgent messages can be restricted to occur only at scheduled delivery times. 
This may cause the recipient to believe message delivery was delayed.

• Some AMIS messages may be undeliverable. An undeliverable message is returned to the sender 
with a non-delivery receipt (NDR) status; the sender or the administrator can make corrections and 
resend the message. This may also appear to the recipient as a delayed delivery.

For more information, see the “Troubleshooting Problems with Outbound AMIS Messages” section on 
page 5-5.

Some Messages Seem to Disappear
The following sections describe possible reasons that messages may not be delivered to the intended 
recipients. Use the Task List for Troubleshooting the Disappearance of Some Messages to troubleshoot 
the possible causes.

Task List for Troubleshooting the Disappearance of Some Messages

1. Check to see if the Exchange server or network are down. See the “Network or Home Exchange 
Server Is Down” section on page 5-3.

2. Verify that the subscriber mailbox is not full. See the “A Mailbox Is Full” section on page 5-4.

3. Verify that subscribers who are assigned to the Unaddressed Messages distribution list have been 
forwarding messages to the intended recipients. See the “Undeliverable Messages Have Not Been 
Forwarded to Recipients” section on page 5-4.

4. Confirm that you or another administrator did not inadvertently delete a subscriber who was 
assigned to review the messages for Cisco Unity entities. See the “Subscribers Assigned to 
Cisco Unity Entities Were Deleted and No Replacements Were Assigned” section on page 5-5.

5. Certain messages may get stuck in the UAmis, UOmni, or Unity Messaging System mailboxes. See 
the “Unity Messaging System, UAmis, or UOmni Mailboxes Have Been Moved Incorrectly in 
Exchange” section on page 5-5.

Network or Home Exchange Server Is Down

This applies only if there are multiple Exchange servers. Increasing the Max Open Retries value and 
decreasing the Open Interval value will increase the number of tries and decrease the wait time Exchange 
uses when it tries to deliver a message after the network or server comes back up.

Change these message transfer agent (MTA) site configuration values, if needed, in the Exchange 
Administrator.
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A Mailbox Is Full

By default, Cisco Unity does not check if a subscriber mailbox has exceeded the Prohibit Send and 
Receive limit before allowing a caller to leave a message, although Cisco Unity does check before 
sending the message to the subscriber mailbox. If the subscriber mailbox is no longer allowed to receive 
messages, then Cisco Unity handles the message accordingly:

• If the message was left by an unidentified caller—an outside caller or a caller from inside the 
organization calling from a phone that is not associated with a subscriber account (such as a 
conference room), Cisco Unity sends the message to the Unaddressed Messages distribution list, 
which should be monitored by the Cisco Unity system administrator or another subscriber. 

• If the message was left by another subscriber, Cisco Unity sends a non-delivery receipt (NDR) 
message to the subscriber who left the message.

Encourage the subscriber to dispose of messages promptly so that the Exchange mailbox does not fill 
up, and explain to subscribers on the Unaddressed Messages distribution list the importance of regularly 
checking for and forwarding undeliverable messages. (Note that if the mailbox(es) of the subscriber(s) 
who are assigned to check the Unaddressed Messages list exceed the Prohibit Send and Receive storage 
limit that is specified in Exchange, the messages sent to the Unaddressed Messages distribution list are 
lost. To avoid this problem, specify a generous value for the Prohibit Send and Receive storage limit for 
the mailbox of at least one subscriber who is a member of the Unaddressed Messages list.)

Cisco Unity can be set to check if a subscriber mailbox is full when an outside caller tries to leave a 
message for the subscriber. To do so, refer to the “Message Handling” section in the “Default Accounts 
and Message Handling” chapter of the Cisco Unity System Administration Guide.

For more information on Exchange 5.5 and Exchange 2000 storage limits, see the “Setting a Maximum 
Size for Exchange Mailboxes” section in the “Maintaining Cisco Unity” chapter of the Cisco Unity 
System Administration Guide, or refer to the Microsoft Exchange documentation. The Cisco Unity 
System Administration Guide is available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_list.
html.

You can also review the “White Paper: Understanding How Exchange 2000 Storage Limits Work with 
Cisco Unity,” available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_technical_reference_list.html.

Undeliverable Messages Have Not Been Forwarded to Recipients

Messages returned to the Unity Messaging System mailbox are forwarded automatically to subscribers 
whose names appear on the Unaddressed Messages public distribution list. The messages then must be 
forwarded to the intended recipients. Explain to subscribers on the Unaddressed Messages public 
distribution list the importance of regularly checking for and forwarding undeliverable messages.

Note that if the mailbox(es) of the subscriber(s) who are assigned to check the Unaddressed Messages 
list exceed the Prohibit Send and Receive storage limit that is specified in Exchange, the messages sent 
to the Unaddressed Messages distribution list are lost. To avoid this problem, specify a generous value 
for the Prohibit Send and Receive storage limit for the mailbox of at least one subscriber who is a 
member of the Unaddressed Messages list and encourage the subscriber to dispose of messages promptly 
so that the Exchange mailbox does not fill up.
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Subscribers Assigned to Cisco Unity Entities Were Deleted and No Replacements Were Assigned

When you delete a subscriber who was assigned to review the messages sent to any of the following 
Cisco Unity entities, make sure that you assign another subscriber or a public distribution list to replace 
the deleted subscriber; otherwise, messages may be “lost.”

• Unaddressed Messages distribution list

• System Event Messages distribution list (because the Example Administrator is the only member of 
this distribution list by default)

• Operator call handler (because the Example Administrator is the only member of this distribution 
list by default)

• Opening Greeting call handler

• Good-Bye call handler

• Example Interview call handler

To identify call handlers that are associated with improperly deleted accounts, run the Unresolved 
References report. See the “Unresolved References Report” section on page 26-26 for more information.

Unity Messaging System, UAmis, or UOmni Mailboxes Have Been Moved Incorrectly in Exchange

The Unity Messaging System, UAmis, and UOmni mailboxes are special Exchange mailboxes with 
specific functions. Each requires special care if you move them in Exchange. If you recently moved a 
group of subscriber mailboxes, you may have inadvertently moved the Unity Messaging System, UAmis, 
or UOmni mailboxes at the same time if:

• Messages from unidentified callers—outside callers or callers from inside the organization calling 
from a phone that is not associated with a subscriber account, such as a conference room—are stuck 
in the Unity Messaging Repository (UMR).

• Messages are stuck in the UAmis mailbox.

• Messages are stuck in the UOmni mailbox.

Refer to the “Moving the Unity Messaging System, UAmis, and UOmni Exchange Mailboxes” section 
in the “Maintaining Cisco Unity” chapter of the Cisco Unity System Administration Guide, available on 
Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_list.
html.

Troubleshooting Problems with Outbound AMIS Messages
Figure 5-1 shows at a high level the flow of outbound AMIS messages through Cisco Unity to the remote 
voice messaging system, and the logs and other tools that you can use to troubleshoot problems along 
the path (after checking the Windows Event log).
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Figure 5-1 Outbound AMIS Message Flow and Troubleshooting Tools

Use the following list to troubleshoot problems with outbound AMIS messages:

• Confirm that the other voice messaging system is supported by Cisco Unity for AMIS messaging. 
Refer to the “AMIS Support” section of the Cisco Unity 3.1 System Requirements, and Supported 
Hardware and Software, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_pre_installation_guides_list.html.

• Check the Windows Application Event log. If there are AMIS-related errors in the Event log, check 
http://www.CiscoUnitySupport.com to see if troubleshooting information about the error is 
available.

• Determine if the Voice Connector delivered the messages to the UAmis mailbox, by using one of the 
following methods:

– See the procedure, To confirm that messages are being delivered to the UAmis mailbox, page 
5-11.

– Use Exchange Message Tracking. Refer to your Microsoft Exchange documentation for more 
information.

If you determine that the messages are not being delivered to the UAmis mailbox, see the “Messages 
Are Not Delivered to the UAmis Mailbox” section on page 5-7 for information on how to 
troubleshoot this problem.

• If messages are being delivered to the UAmis mailbox, but are not being sent on from there, see the 
“Messages Are Stuck in the UAmis Mailbox” section on page 5-7 for information on how to 
troubleshoot this problem.
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• If messages are leaving the UAmis mailbox, but are not delivered to users on the other voice 
messaging system, see the “Messages Leave the UAmis Mailbox But Are Not Delivered” section on 
page 5-8 for information on how to troubleshoot this problem.

Detailed procedures for troubleshooting the above AMIS problems, and information about AMIS 
diagnostic traces, can be found in the following sections:

• AMIS Troubleshooting Procedures, page 5-11

• AMIS Diagnostic Traces, page 2-8

Messages Are Not Delivered to the UAmis Mailbox
When subscribers address messages to an AMIS recipient, the Voice Connector is responsible for 
delivering the messages to the UAmis mailbox. If messages are not showing up in the UAmis mailbox, 
then more than likely there is a problem with the Voice Connector. When there is a problem with the 
Voice Connector, no AMIS-related errors are logged to the Windows Application Event log.

If you are not sure whether messages are being delivered to the UAmis mailbox, do the procedure, To 
confirm that messages are being delivered to the UAmis mailbox, page 5-11.

To troubleshoot problems with the Voice Connector

• Confirm that the Exchange server on which the Voice Connector is installed has not gone down.

• Confirm that the Voice Connector service is running. If the service is not running, then start it. The 
messages will be delivered from the Voice Connector MTS-OUT queue to the UAmis mailbox.

For detailed instructions, see the following procedures: To confirm that the Voice Connector service 
is running, page 5-12; To view the Voice Connector MTS-OUT queue in Exchange 2000, page 5-12; 
and, To view the Voice Connector MTS out queue in Exchange 5.5, page 5-13.

• View the Voice Connector log files in the <ExchangeServerPath>\VoiceGateway\logFiles folder on 
the Exchange server on which the Voice Connector is installed. For more information about the 
Voice Connector log files, see the “Cisco Unity Voice Connector Logs” section on page 2-10.

• Use the Unity Diagnostic Tool to set the macro trace called “General Outgoing AMIS Message 
Trace.” For information on using the Unity Diagnostic tool, see “To set and retrieve traces for AMIS 
messages” section on page 5-13.

Messages Are Stuck in the UAmis Mailbox
After the Voice Connector has delivered a message to the UAmis mailbox, the AMIS schedule and the 
AMIS restriction table will determine when the message will be sent. When an AMIS delivery number 
is allowed by the restriction table, messages to this number are sent immediately from the UAmis 
mailbox—the schedule settings do not matter. When the delivery number is disallowed by the restriction 
table, messages to this number are queued in the UAmis mailbox until the active hours of the AMIS 
schedule.

An error is logged in the Windows Application Event log when messages remain in the UAmis mailbox 
for more than 24 hours. Only one error is logged in the Event log, no matter how many messages remain 
in the UAmis mailbox. An additional error is logged daily until the messages are either sent or deleted 
from the UAmis mailbox.

If necessary, you can delete messages that are stuck in the UAmis mailbox by using Outlook or 
DohPropTest. See the procedure, To view or remove messages in the UAmis mailbox by using 
DohPropTest, page 5-13, for detailed steps.
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To determine why messages are stuck in the UAmis mailbox

• In the Cisco Unity Administrator, review the settings for the AMIS restriction table. If any delivery 
numbers are disallowed, messages addressed to these numbers will be queued in the UAmis 
mailbox. This may not be what you intended. To send the messages immediately, change the AMIS 
schedule so that it is active during the time that you are troubleshooting. After the messages are sent 
from the UAmis mailbox, reset the AMIS schedule and adjust the AMIS restriction table as needed.

• Review the AMIS schedule. Confirm that the schedule has sufficient Active hours set for sending 
all the messages.

• Go to the System > Ports page, and confirm that there is at least one port configured for outbound 
AMIS messages.

• Go to the Reports > System > AMIS Out Traffic page, and run the report.

If the total transmission time (listed at the bottom of the transmission duration column, and reported 
in seconds) is approaching the limit of the ports dedicated to AMIS deliveries, all of the port 
resources available are being used. Review the AMIS schedule and port assignments again to 
determine if additional resources (time and/or ports) should be dedicated to AMIS message traffic.

• Confirm that the delivery phone numbers on all AMIS delivery locations are valid. To confirm that 
the delivery phone numbers are valid, do one of the following:

– If there are few AMIS delivery locations, in the Cisco Unity Administrator, go to the Network > 
Delivery Locations > Profile page of each AMIS delivery location to confirm the delivery phone 
number.

– Alternatively, you can run DohPropTest to view the delivery phone number and other attributes 
about the messages that are stuck in the UAmis mailbox. See the procedure, To view or remove 
messages in the UAmis mailbox by using DohPropTest, page 5-13 for more information.

• In Outlook, confirm that the messages are marked as Unread. Messages that have been manually 
marked as Read will not be sent from the UAmis mailbox. For example, if someone has been 
monitoring the UAmis mailbox and has opened a message, that message will not be sent.

• Use the Unity Diagnostic Tool to set the macro trace called “General Outgoing AMIS Message 
Trace.” For information on using the Unity Diagnostic tool, see the procedure, To set and retrieve 
traces for AMIS messages, page 5-13.

Messages Leave the UAmis Mailbox But Are Not Delivered
Use the following steps to troubleshoot problems with messages that leave the UAmis mailbox but are 
not delivered to users of the remote voice messaging system.

To troubleshoot undelivered messages

• Check the Event log.

If there are AMIS-related errors in the Event log, check http://www.CiscoUnitySupport.com to see 
if troubleshooting information about the error is available.

• Double-check the AMIS configuration in Cisco Unity, as follows:

– In the Cisco Unity Administrator, go to the Network > AMIS Options > Delivery Options page. 
Review the settings for If The Remote System Does Not Answer and If The Remote System Is 
Busy. These settings should be set to at least the default values (Hang Up After 4 Rings; Try 
Calling 4 Times; Retry Every 5 Minutes). Otherwise, the remote voice messaging system may 
not be given enough time to answer.
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– Go to the Network > Delivery Options > Profile page of each of the AMIS delivery locations. 
If the Disable Outbound Messages To This AMIS Location check box is checked, change the 
Delivery Phone Number as needed, and then uncheck the check box.

– Go to the Network > Primary Location > Profile page. Confirm that the Node ID is accepted by 
the remote voice messaging system.

– Confirm that the extension addresses listed in Exchange for AMIS subscribers are correct. If the 
Dial ID for an AMIS delivery location has changed, or if the remote mailbox number for an 
AMIS subscriber has changed, you need to run the Extension Address utility to update the 
extension addresses. See the procedures, To view AMIS subscriber extension addresses, page 
5-14, and To run the Extension Address utility, page 5-14 for more information.

• Determine whether the calls to an AMIS location are actually being made or whether there is 
something unexpected happening during the AMIS transmission. You can use the StatusMonitor 
utility (located in \CommServer\TechTools) to observe call progress. See the procedure, To use the 
StatusMonitor utility to watch details of an AMIS transmission, page 5-14.

• If the outgoing AMIS calls are to a long distance number, check the phone system to see if there are 
restrictions for placing long distance calls.

• Use the Unity Diagnostic Tool to set the macro trace called “Extensive Outgoing AMIS Message 
Trace.” For information on using the Unity Diagnostic tool, see the procedure, To set and retrieve 
traces for AMIS messages, page 5-13.

• See the ““C” and “D” DTMF Hang-Up Tones Cause AMIS Calls To Fail” section on page 5-15 to 
determine if this could be the source of the problem.

Troubleshooting Problems with Inbound AMIS Messages
Figure 5-2 shows at a high level the flow of inbound AMIS messages from the remote voice messaging 
system to Cisco Unity, and the logs and other tools that you can use to troubleshoot problems along the 
path (after checking the Windows Event log).
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Figure 5-2 Inbound AMIS Message Flow and Troubleshooting Tools

Use the following list to troubleshoot problems with inbound AMIS messages:

• Confirm that the other voice messaging system is supported by Cisco Unity for AMIS messaging. 
Refer to the “AMIS Support” section of the Cisco Unity 3.1 System Requirements, and Supported 
Hardware and Software, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_pre_installation_guides_list.html.

• Check the Windows Application Event log. If there are AMIS-related errors in the Event log, check 
http://www.CiscoUnitySupport.com to see if troubleshooting information about the error is 
available.

• Go to the Network > Delivery Options > Profile page of each of the AMIS delivery locations. 
Confirm that the Node ID entered on the page exactly matches the node ID that the remote voice 
messaging system transmits.

• If you have not determined why the messages are not being delivered, use the Cisco Unity 
Diagnostic Tool to set diagnostic traces and send a test message. See the “AMIS Diagnostic Traces” 
section on page 2-8 for information on the appropriate traces to set.

• See the ““C” and “D” DTMF Hang-Up Tones Cause AMIS Calls To Fail” section on page 5-15 to 
determine if this could be the source of the problem.

Detailed procedures for troubleshooting the above AMIS problems, and information about AMIS 
diagnostic traces, can be found in the following sections:

• AMIS Troubleshooting Procedures, page 5-11

• AMIS Diagnostic Traces, page 2-8
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AMIS Troubleshooting Procedures
Use the following procedures as needed to troubleshoot problems with AMIS message delivery. For 
discussion of when to use the following procedures, and the correct order in which to do the procedures, 
see the preceding topics:

• Troubleshooting Problems with Outbound AMIS Messages, page 5-5

• Troubleshooting Problems with Inbound AMIS Messages, page 5-9

To confirm that messages are being delivered to the UAmis mailbox

Step 1 In the Cisco Unity Administrator, change the AMIS restriction table to disallow all numbers. This causes 
all AMIS messages to be queued in the UAmis mailbox until the AMIS schedule becomes active.

For detailed instructions on changing the restriction table, see the procedure, To change the AMIS 
restriction table to disallow all delivery numbers, page 5-11.

Step 2 Change the AMIS schedule so that it is inactive during the time that you are troubleshooting. This way, 
the messages (if they arrive) stay in the UAmis mailbox long enough for you to see them.

For detailed instructions on changing the schedule, see the procedure, To change the AMIS schedule so 
that it is inactive while troubleshooting, page 5-12.

Step 3 Open the UAmis mailbox by using one of the following methods:

• If you have access to Outlook, set up a user profile for the UAmis mailbox just like you would for 
any Exchange mail user, and then use Outlook to determine if messages are in the UAmis mailbox. 
Refer to your Outlook documentation for information about setting up user profiles.

Note When a message is addressed to an AMIS recipient by using the phone, a copy of the message 
is not saved in the Outlook Sent Items folder after the message leaves the UAmis mailbox. 
However, when a message is addressed to an AMIS recipient by using Outlook, a copy of the 
message is saved in the Sent Items folder of the UAmis mailbox.

• Use DohPropTest to open the UAmis mailbox. See the procedure, To view or remove messages in 
the UAmis mailbox by using DohPropTest, page 5-13.

• Use MbxMonitor.exe to monitor the UAmis mailbox.

Step 4 Send a test message to see if it is delivered to the UAmis Inbox. If using blind addressing, be sure to 
verify that you are using a valid Dial ID number from a Delivery Location.

Step 5 After testing, be sure to reset the AMIS restriction table and schedule.

To change the AMIS restriction table to disallow all delivery numbers

Step 1 In the Cisco Unity Administrator, go to the Network > AMIS Options > Delivery Options page.

Step 2 Click the View button next to Local Dial Restriction Table to display the AMIS restriction table.

Step 3 On the AMIS restriction table page, click Add Dial String.

Step 4 In the Call Pattern box, enter *.

Step 5 In the Allow This String box, click No.
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Step 6 Click the Save icon.

To change the AMIS schedule so that it is inactive while troubleshooting

Step 1 In the Cisco Unity Administrator, go to the Network > AMIS Options > Schedule page.

Step 2 Click the appropriate blocks so that the schedule is inactive while you are troubleshooting.

Step 3 Click the Save icon.

To confirm that the Voice Connector service is running

Step 1 Log on to the Exchange server on which the Voice Connector is installed.

Step 2 Open Windows Services (on the Windows Start menu, click Programs > Administrative Tools > 
Services).

Step 3 Locate the Voice Connector service in the Name column. In Exchange 2000, the display name for the 
service is “Exchange 2000 Voice Connector,” and in Exchange 5.5, the display name is “Internet Voice 
Connector.”

Step 4 If the Status column indicates that the Voice Connector service is not running, right-click the service and 
click Start.

To set access permissions on the Exchange 2000 mailbox store

Do this procedure if you need to gain access to the MTS-IN and MTS-OUT queues on the Exchange 
server on which the Voice Connector is installed.

Step 1 On the Exchange server on which the Voice Connector is installed, start the Exchange System Manager 
(on the Windows Start menu, click Programs > Microsoft Exchange > System Manager).

Step 2 Expand Servers.

Step 3 Expand the node for your Exchange 2000 Server.

Step 4 Expand the First Storage Group node.

Step 5 Right-click the Mailbox Store.

Step 6 Select Properties to bring up the Mailbox Store Properties sheet.

Step 7 Click the Security tab.

Step 8 Click Add, and add the current administrator to the list.

Step 9 Click OK twice and close the Exchange System Manager.

To view the Voice Connector MTS-OUT queue in Exchange 2000

Step 1 Log on to the Exchange server on which the Voice Connector is installed.
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Step 2 Start the Exchange System Manager (on the Windows Start menu, click Programs > Microsoft 
Exchange > System Manager).

Step 3 Browse to Connectors\ Exchange 2000 Voice Connector\Queues.

Step 4 Click MTS-OUT.

To view the Voice Connector MTS out queue in Exchange 5.5

Step 1 Log on to the Exchange server on which the Voice Connector is installed.

Step 2 Start the Exchange Administrator (on the Windows Start menu, click Programs > Microsoft Exchange 
> Exchange Administrator).

Step 3 Browse to Connectors\ Internet Voice Connector.

Step 4 Double-click Internet Voice Connector to display the properties.

Step 5 Click the Queues tab.

Step 6 Select MTS-OUT from the Queue Name list.

To view or remove messages in the UAmis mailbox by using DohPropTest

Step 1 On the Cisco Unity server, browse to the location where Cisco Unity is installed (the default is 
C:\CommServer), and then browse to the TechTools folder.

Step 2 Run DohPropTest.exe.

Although DohPropTest is password protected, it can be run in read-only mode. However, in read-only 
mode, you cannot remove messages from the UAmis mailbox.

Step 3 In the DohPropTest Logon dialog box, leave the Password box empty, and click OK.

Step 4 On the warning dialog box, click Ignore to start the read-only mode of DohPropTest.

Step 5 In the list on the left side of the window, click MailUsers.

Step 6 In the middle list, click the UAmis_<server name> mailbox.

Step 7 Click Get User's Mailbox, which displays a dialog box.

Step 8 Click OK. A dialog box with all the messages appears.

Step 9 Click a message. The message plays, and the message properties are displayed. Select a property to 
check the values. The following properties should be checked:

• AVP_AMIS_Destination_NODE—The AMIS delivery location Dial ID.

• AVP_AMIS_Recipient—The remote mailbox number of the recipient.

• AVP_AMIS_SENDER_ADDRESS—The message sender.

• AVP_SUBMIT_TIME—The time the message was submitted. Note that the timestamp is in GMT.

To set and retrieve traces for AMIS messages

See the“AMIS Diagnostic Traces” section on page 2-8 for information about the diagnostic traces to set 
for troubleshooting AMIS message delivery problems.
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Step 1 On the Windows Start menu, click Programs > Unity > Unity Diagnostic Tool.

Step 2 On the Cisco Unity Diagnostic Tasks screen, click Configure Macro Traces. The Configure Macro 
Traces Wizard displays.

Step 3 Click Next to select the traces to enable.

Step 4 After selecting the appropriate traces, click Finish.

Step 5 On the Cisco Unity Diagnostic Tasks screen, click Start New Log Files.

Step 6 After the problem reoccurs, or sufficient time has passed to gather AMIS message data, in the tree in the 
left pane of the Unity Diagnostic Tool, click Processes > AvCsMgr, and then click the Current log file 
to view it.

The selected log file is formatted and displayed in the right pane.

Step 7 To export or save a copy of the log file, click Action > Export List.

Step 8 Name the file and save it to a location of your choice in .txt or .csv format.

Step 9 Disable all diagnostic traces that were activated in Step 3.

Step 10 If you need assistance in interpreting the diagnostic logs, or are unable to resolve an AMIS message 
problem, contact Cisco TAC.

To view AMIS subscriber extension addresses

Step 1 Open Active Directory Users and Computers (on the Windows Start menu, click Programs > 
Administrative Tools > Active Directory Users and Computers).

Step 2 Open the properties page for an AMIS subscriber.

Step 3 Click the E-mail Addresses tab. You should see an address with the type “amis” and an address in the 
form <Location Dial ID>_<Remote Mailbox Number>.

Step 4 Confirm that this is the correct address.

To run the Extension Address utility

Step 1 On the Cisco Unity server, on the Windows Start menu, click Programs > Unity > Extension Address 
Utility.

Step 2 Click Update.

Step 3 When the utility has finished updating extension addresses, click Close.

To use the StatusMonitor utility to watch details of an AMIS transmission

Step 1 In the Cisco Unity Administrator, go to the System > Ports page, and change the settings as needed so 
that only one port is enabled for outbound AMIS calls, and that all other functions (such as Message 
Notification and Dialout MWIs) on the port are disabled. This makes it easier to observe the call progress 
information in the StatusMonitor.
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For any outgoing call troubleshooting—be it AMIS, MWI, message notification, or TRAP—it is best to 
use one of the last ports because the higher-numbered ports are most likely being used for outgoing tasks 
anyway. Cisco Unity searches for available ports for outgoing tasks starting with the last port.

Step 2 On the Cisco Unity server, browse to the location in which Cisco Unity is installed (the default is 
C:\CommServer), and then browse to the TechTools folder.

Step 3 Run StatusMonitor.exe.

Step 4 Click Display and Conversation in the Monitor Settings When Started section.

Step 5 In the Ports list, confirm that the port selected on the System > Ports page for outbound AMIS calls (the 
port you selected in Step 1) is selected for monitoring.

Step 6 Click Start Monitor.

Step 7 Use the phone to dial into Cisco Unity on a port other than the one configured for outbound AMIS calls, 
and send a test message to someone on the remote voice messaging system.

Step 8 Observe the information in the StatusMonitor.

In the Display State pane in the StatusMonitor window, you should see the dialout information. In the 
Conversation State pane, you should see the states that the AMIS call goes through. An AMIS call goes 
through a finite number of states during an AMIS transmission. As the AMIS call progresses, you should 
see the descriptive name of each state in the Conversation State pane. For detailed information about the 
AMIS transmission states, refer to White Paper: AMIS Analog Networking Definitions, available on 
Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_technical_reference_list.html.

“C” and “D” DTMF Hang-Up Tones Cause AMIS Calls To Fail
“C” and “D” DTMF tones, also known as fourth-column tones, are just like the twelve other DTMF tones 
(“0”–”9,” “*,” and “#”) found on a regular analog phone. They are commonly used for in-band analog 
integrations and other “non-human” tasks.

The first action of an AMIS call is the handshake between the originating and receiving voice messaging 
systems. The originating system dials the number of the destination system. When the originating system 
detects that the destination system has answered the call, the originating system transmits a “C” tone to 
the destination. If the destination system answers the call and detects the “C” tone, it should respond 
with a “D” tone within 10 seconds. After transmitting the “D” tone, the destination system expects a Start 
Session frame.

(For more information on the details of an AMIS call, refer to White Paper: AMIS Analog Networking 
Definitions, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_technical_reference_list.html.)

Many Toshiba phone systems use the “D” tone to indicate to voice messaging systems that a disconnect 
has occurred. Other phone systems may also use the “C” or “D” tones to indicate that a disconnect has 
occurred. When this is the case, a parameter of “HangUpTone=C” or “HangUpTone=D” will be defined 
in the active switch configuration file on the Cisco Unity server.

If “HangUpTone=C” is defined, the AMIS feature cannot be used on that system. When a remote voice 
messaging system dials Cisco Unity and sends the “C” tone to initiate the AMIS handshake, Cisco Unity 
interprets it as a disconnect signal from the phone system and hangs up on the call.
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Similarly, if “HangUpTone=D” is defined, the AMIS feature cannot be used on that system. When Cisco 
Unity dials the remote voice messaging system and sends the “C” tone to initiate the AMIS handshake, 
and the remote system responds with the “D” tone, Cisco Unity interprets it as a disconnect signal from 
the phone system and hangs up on the call.

To fix this problem, configure the phone system to use another type of disconnect indication (such as the 
reorder tone, dial tone, or loop current reversal), then remove the HangUpTone parameter from the active 
switch file. This is the best option.

If this is not possible, configure the phone system to use “A” or “B” as a hang-up tone, then modify the 
HangUpTone parameter in the active switch file to match this new value.

The default values for the hang-up packets expected by Cisco Unity (defined in avanaglog.avd) have 
been chosen to work with AMIS. Changing these values may cause AMIS calls to fail.

To obtain the name(s) of the active switch file(s)

Step 1 On the Cisco Unity server, start Regedit.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for Cisco Unity failover, 
registry changes on one Cisco Unity server must be made manually on the other Cisco Unity 
server, because registry changes are not replicated.

Step 2 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 3 Expand the following key: 

HKEY_LOCAL_MACHINE\Software\Active Voice\Miu\1.0\Initialization
\Switch 0

For dual-switch integrations, also expand the key:

HKEY_LOCAL_MACHINE\Software\Active Voice\Miu\1.0\Initialization
\Switch 1

Step 4 View the Switch Configuration File value under the …\Switch 0 key to obtain the name of the active 
switch file, and then click Cancel. For dual-switch integrations, also view the Switch Configuration 
File value under the …\Switch 1 key to obtain the name of the second active switch file, and then click 
Cancel.

Step 5 Close Regedit.

To edit the active switch file(s)

Step 1 On the Cisco Unity server, browse to the \CommServer\IntLib folder. (C:\CommServer is the default 
folder in which Cisco Unity is installed. If Cisco Unity is installed in another folder, use that path 
instead.)

Step 2 Open the active switch file with a text editor.
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Step 3 In the [Configuration] section, if “HangUpTone=” does not exist, or if it is set to any value other than 
“C” or “D,” then do not change anything in the file, because the parameter does not conflict with AMIS. 
Close the file, and skip to Step 5.

Step 4 If “HangUpTone=” is set to either the “C” or “D” DTMF tone, then the action you take depends on the 
new disconnect indication that you configured on the phone system, as follows:

• If the phone system uses some other type of disconnect indication, such as the reorder tone, dial 
tone, or loop current reversal, then remove the HangUpTone parameter from the active switch file. 
Save and close the file.

• If the phone system uses either the “A” or “B” DTMF tone as a hang-up tone, then modify the 
“HangUpTone=” to match this new value. Save and close the file.

Step 5 For dual-switch integrations, repeat Step 1 through Step 4 to edit the second active switch file.

Step 6 Stop and restart Cisco Unity to activate the changes to the active switch file.

Cisco Unity Stops Recording Before a Caller Has Finished 
Leaving a Message

The following sections describe possible reasons that Cisco Unity may stop recording before a caller has 
finished leaving a message. Use the Task List for Troubleshooting Recordings Being Cut Off to 
troubleshoot the possible causes.

Task List for Troubleshooting Recordings Being Cut Off

1. Check to see if the quiet parameter is set to recognize low voice volume. See the “Dialogic Quiet 
Parameter Is Incorrect” section on page 5-17.

2. Calls may be cut off by Cisco Unity, the phone system, or the central office. See the “Cisco Unity, 
the Phone System, or the Central Office Disconnected the Call” section on page 5-18.

Dialogic Quiet Parameter Is Incorrect

A caller may report hearing a prompt and being prevented from completing a message, or a subscriber 
may report this problem after noticing that a recording ends before the caller finished leaving a message. 
This can happen when the quiet parameter is not set to recognize low voice volume. It also can happen 
when a changed quiet parameter is not retained after a Cisco Unity upgrade.

To change the Dialogic quiet parameter (systems equipped with Dialogic voice cards only)

Step 1 Shut down the Cisco Unity software.

Step 2 On the Windows Start menu, click Programs > Dialogic System Software > Dialogic Configuration 
Manager–DCM.

Step 3 On the Service menu, click Stop Service. A second Dialogic Configuration Manager window appears.

Step 4 When the message “Success: Dialogic service stopped” appears, click Close.

Step 5 In the Service window, select a Dialogic voice card.
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Step 6 In the DCM–Properties dialog box for the card, click Misc.

Step 7 Click ParameterFile.

Step 8 Under Edit in the Value field, enter quiet50.prm, and click OK.

Note If spandti.prm or any other values exist in the Value field, enter a space at the end of the existing 
value, and enter quiet50.prm. The space ensures that both .prm entries exist in the field.

Step 9 Repeat Step 5 through Step 8 for each additional Dialogic voice card.

Step 10 On the Service menu, click Start Service. A second Dialogic Configuration Manager window appears.

Step 11 When the message “Success: Dialogic service started” appears, click Close.

Step 12 Restart the Cisco Unity server.

Cisco Unity, the Phone System, or the Central Office Disconnected the Call

If a caller reports being cut off while leaving a message and if the caller did not hear a prompt prior to 
the disconnect, Cisco Unity, the phone system, or the central office may have disconnected the call.

To determine why the call was disconnected

Step 1 On the Windows Start menu, click Programs > Administrative Tools > Event Viewer.

Step 2 On the Log menu, click System.

Step 3 In the System Event log, look for an error that occurred at the time of the reported disconnected call.

If an error appears, double-click the error and skip to Step 6.

If no error appears for the date and time of the disconnected call, continue with Step 4.

Step 4 On the Log menu, click Application.

Step 5 In the Application Event log, look for an error that occurred at the time of the reported disconnected call. 
Double-click the error.

Step 6 In the Event Detail dialog box, review the contents of the Description box.

If you need assistance interpreting or resolving the error, or if no error appears in the Application Event 
log that matches the date and time of the reported disconnected call, contact Cisco TAC.

Dial Tone or Reorder Tone Is Present at the End of a Message
A possible cause may be that the switch disconnect tone and/or the PSTN disconnect tone are incorrect 
in the Switch.ini file (for circuit-switched phone systems only).

To run the Learn Tones utility

Step 1 Run the Learn Tones utility. See the “Learn Tones” section on page 11-5 for detailed instructions.
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Step 2 If running the Learn Tones utility does not resolve the problem, contact Cisco TAC.
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Audio Quality

About Audio Quality Problems
Audio quality problems can manifest themselves in a variety of ways, and can be difficult to diagnose 
and correct. For example, subscribers may report volume differences between messages and system 
prompts, or report that messages are distorted. Audio quality symptoms may not be present for every 
subscriber, or consistently appear on every message or every system prompt.

The entire device topology can affect audio quality, both within and outside of the control of 
Cisco Unity. Cisco Unity-controlled features include automatic gain control (AGC), the 
Cisco Unity-CM TSP wave gain, and the audio codec chosen for message storage. Cisco CallManager 
controls the region setting for the audio codec. Finally, the Cisco gateway gain and attenuation settings 
can also affect audio quality.

Audio Quality Problems in Cisco Unity Version 3.1(x) and later
The most common symptom of audio quality problems in Cisco Unity version 3.1(x) is when the volume 
of greetings and voice names is higher or lower than the volume of Cisco Unity prompts.

See Table 6-1 for basic corrective action to level all WAV files on the Cisco Unity server to the same 
value, and then to adjust the playback level if needed.
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Set Volume Level Utility
The Set Volume Level utility allows you to level all WAV files on the Cisco Unity server to the same 
value, and to adjust the playback level, if needed.

Because automatic gain control is enabled by default in Cisco Unity version 3.1(2c) and later, systems 
upgraded to 3.1(2c) and later may experience a problem where the existing greeting and name recordings 
sound louder than new greetings and names recorded after the upgrade.

In Cisco Unity version 3.1(4), a new registry setting, AGCminimumThreshold, was added to control the 
minimum dB level of an incoming recording that Cisco Unity attempts to adjust. The setting prevents 
silence in a message and background hiss from being adjusted. The AGCminimumThreshold has a 
default setting of –45 dB and an allowable range of –35 dB to –55 dB.

To maximize success in resolving or avoiding volume problems, we recommend that you first upgrade 
to Cisco Unity version 3.1(4) or later, then use the Set Volume utility to match the existing greeting and 
name recordings to the gain levels of Cisco Unity after the upgrade.

Confirm that you have the latest version of the Set Volume utility by doing the procedure, To download 
and install the latest version of the Set Volume utility, page 6-2.

The procedure, To adjust greeting and name recordings by using the Set Volume utility, page 6-3, levels 
all WAV files on the Cisco Unity server to the same value, and provides instructions for adjusting the 
playback level, if necessary.

Note A typical backup of the Cisco Unity server does not back up the registry. Also note that for Cisco Unity 
failover, registry changes on one Cisco Unity server must be made manually on the other Cisco Unity 
server, because registry changes are not replicated.

To download and install the latest version of the Set Volume utility

Step 1 Go to the Software Center website at http://www.cisco.com/kobayashi/sw-center/sw-voice.shtml.

Table 6-1 Basic Audio Quality Troubleshooting for Cisco Unity Version 3.1(x) Systems

Symptom General Circumstances Corrective Action

The volume of greetings 
and voice names is 
higher or lower than the 
volume of Cisco Unity 
prompts.

Only certain greetings and voice 
names may be affected on a 
version 3.1(1) or later system, 
and/or an upgrade to version 
3.1(3) or later was recently 
performed.

3. Confirm that the Cisco Unity-CM TSP wave gain playback 
and record settings are both set to 0.

4. Run the Set Volume Level utility to bring pre-upgrade 
greetings and voice names to the correct dB levels.

5. Check and adjust the Cisco Unity AGC settings, if necessary 
(set to –26 dB default value).

6. Check and adjust the Cisco Unity-CM wave gain playback 
setting, if necessary.

For detailed instructions, see the “Set Volume Level Utility” 
section on page 6-2.

For upgrades from 3.1(2) to 3.1(3) or to 3.1(4), see also 
http://www.cisco.com/warp/public/788/AVVID/white_noise.ht
ml.
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Step 2 Under “Cisco Unity Software,” click Cisco Unity Utilities.

Step 3 Compare the version of the file SetVolume.zip in the table to the Set Volume utility version on the 
Cisco Unity system.

Step 4 If the version in the table is later than the version currently installed on the system, download the file 
SetVolume.zip.

Step 5 Specify a directory to which the files will be downloaded.

Step 6 In Winzip, double-click Setup.exe.

Step 7 Click OK.

Step 8 Click Change Directory, and browse to the directory CommServer\Utilities\VolumeAdjust.

Step 9 Follow the on-screen prompts to complete the installation.

To adjust greeting and name recordings by using the Set Volume utility

Step 1 Exit the Cisco Unity Administrator.

Step 2 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 3 If you do not have a Cisco CallManager integration, skip to step Step 5.

If you have a Cisco CallManager integration, and the Cisco CallManager region is set to use the G.711 
codec, in the left pane, under Administrative Tools, double-click Wave Gain.

Step 4 Confirm that both Record Gain and Playback Gain are set to 0.

Step 5 In the left pane of the Tools Depot window, go to Audio Management Tools, and double-click Set 
Volume.

Step 6 In the Set Greetings and Voice Names window, click Select All.

Step 7 Confirm that the Save Original Files check box is checked, then enter the location to which the backup 
copy of the original recorded names and greetings files will be saved.

Step 8 In the Options section, verify the following values. Note that only Cisco Unity versions 3.1(4) and later 
have the Min. dB Threshold registry setting referred to in the following table.

Step 9 Confirm that the Save Above Volume Options check box is checked. Note that setting New Target dB 
to a value other than zero turns on automatic gain control.

Step 10 Click Set Volume Level.

Step 11 When “Done” appears in the Set Volume window, all existing greeting and name recordings have been 
adjusted to the New Target dB level. Click OK, and then click Exit.

Step 12 If you do not have a Cisco CallManager integration, you have completed all necessary steps in this 
procedure.

New Target dB –26

Sample Size 8000

Max dB Adjustment 5

Min. dB Threshold –45
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If you have a Cisco CallManager integration, and the Cisco CallManager region is set to use the G.711 
codec, start the Cisco Unity Administrator.

Step 13 Go to any page in the Cisco Unity Administrator that contains a Media Master control bar, and verify 
that the phone is selected as the playback device. 

Note In order to use the phone as a recording and playback device, Cisco Unity must have at least one 
port designated TRAP Connection per session on the System > Ports page. Refer to the “Voice 
Messaging Port Settings” section in the Cisco Unity System Administration Guide for more 
information. This guide is available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_boo
ks_list.html.

Step 14 Click Play on the Media Master control bar to listen to a recording (for example, a subscriber greeting) 
over the phone.

If the volume of the recording is acceptable, you have completed all necessary steps in this procedure.

If the volume of the recording is too quiet, continue with Step 15.

Step 15 In the left pane of the Tools Depot window, under Audio Management Tools, double-click Wave Gain.

Step 16 Increase the Playback Gain value by one or two dB. Listen to the volume of a recording.

If the volume of the recording is acceptable, note the Playback Gain value and continue with Step 17.

If the volume of the recording is still too quiet, repeat this step.

Step 17 In the left pane of the Tools Depot window, under Administrative Tools, double-click Advanced 
Settings Tool.

Step 18 In the Unity Settings pane, click Set Wave Gain dB Adjustment for Playback.

Step 19 Enter the new value determined in Step 16, and click Set.

Step 20 When prompted, click OK. You do not need to restart the Cisco Unity server to enable the registry 
change.

Step 21 Click Exit.

Step 22 If you are using failover, repeat this procedure to apply the registry setting to secondary server. 

Advanced Audio Quality Troubleshooting in Cisco Unity Version 
3.(x) and Later

See Table 6-2 for advanced corrective actions and links to other troubleshooting procedures and 
information for these symptoms:

• Messages and/or Cisco Unity prompts sound distorted.

• A hissing sound is heard when there is no audio from Cisco Unity.

• Message playback volume is higher or lower than the volume of Cisco Unity prompts, in special 
cases.

For more information, refer to White Paper: Audio Codecs and Cisco Unity, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_technical_reference_list.html.
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Note than unless otherwise specified, all procedures apply to Cisco Unity version 3.1(4) and later.

Table 6-2 Advanced Audio Quality Troubleshooting

Symptom General Circumstances Corrective Action

Messages and/or 
Cisco Unity prompts 
sound distorted.

You are using the G729a codec 
for message storage and 
retrieval.

1. Confirm that Cisco Unity is capable of receiving G.729a 
streams. See the “Cisco Unity Is G.729a Capable” section on 
page 6-6.

2. Confirm that the G.729a codec is being used for message 
recording on Cisco Unity. See the “Set Record Format” 
section on page 6-6.

3. Confirm that the Cisco CallManager region is set to G.729a. 
Refer to the appropriate Cisco CallManager Administration 
Guide, available on Cisco.com at 
http://www.cisco.com/univercd/cc/td/doc/product/voice/c_c
allmg/index.htm.

4. Confirm that the Cisco Unity G.729a prompts are installed. 
Refer to the CiscoUnity3.1.G729aPrompts.Readme, 
available on the Software Center download website at 
http://www.cisco.com/kobayashi/sw-center/sw-voice.shtml.

You are using the G.711 codec 
for message storage and 
retrieval.

Confirm that the Cisco CallManager region is set to G.711. Refer 
to the appropriate Cisco CallManager Administration Guide, 
available on Cisco.com at 
http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callm
g/index.htm.

Hissing noise is heard 
when there is no audio 
from Cisco Unity, such 
as between system 
prompts or during 
transfers.

You are using IP phones. Check the Cisco Unity comfort noise registry setting. See the 
procedure, To view and adjust the Cisco Unity comfort noise 
registry setting, page 6-13.

For upgrades from 3.1(2) to 3.1(3) or to 3.1(4), see also 
http://www.cisco.com/warp/public/788/AVVID/white_noise.htm
l.

Message playback 
volume is higher or 
lower than the volume 
of Cisco Unity prompts, 
in special cases.

Only outside caller messages 
are affected on a Cisco Unity 
system version 3.1(2b) and 
earlier.

1. Check the Cisco gateway gain and attenuation levels. Refer 
to the guide for your gateway, available on Cisco.com at 
http://www.cisco.com/univercd/cc/td/doc/product/voice/c_a
ccess/index.htm.

2. Check the Cisco Unity-CM TSP wave gain playback and 
record settings. See the “Cisco Unity-CM TSP Wave Gain 
Utility” section on page 6-8.

Both subscriber and outside 
caller messages are affected 
system-wide on a Cisco Unity 
system version 3.1(2b) and 
earlier.

Check the Cisco Unity-CM TSP wave gain playback and record 
settings. See the “Cisco Unity-CM TSP Wave Gain Utility” 
section on page 6-8.
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Cisco Unity Is G.729a Capable
When the registry setting HKEY_LOCAL_MACHINE\Software\Active Voice\AVSkinny\G729 Enabled 
is set to 1, it means that Cisco Unity is capable of receiving both G.729a streams and G.711 streams. It 
does not indicate that G.729a is in use for message storage. This is the default setting for Cisco Unity 
version 3.1(x) systems. Because the G.729a codec is installed automatically with version 4.0(1) and 
later, this registry setting is no longer needed.

To confirm that Cisco Unity is capable of receiving G.729a streams (version 3.(x) only)

Step 1 Start Regedit.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for a Cisco Unity 
failover system, registry changes on one Cisco Unity server must be made manually on the 
other Cisco Unity server, because registry changes are not replicated. If you have any 
questions about changing registry key settings, contact Cisco TAC.

Step 2 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file, then close Regedit.

Step 3 Go to the registry key in HKEY_LOCAL_MACHINE\Software\Active Voice\AVSkinny\G729 Enabled.

Step 4 Confirm that the Value is set to 1.

Step 5 If you changed the value in Step 4, click OK. You do not need to restart the Cisco Unity server to 
enable the registry change.

Set Record Format
The Set Record Format utility changes the codec used for all recordings on Cisco Unity. It is not possible 
to select user or port-specific recording formats. Changes to the record format apply only to recordings 
made after the change takes place. The utility does not convert any existing messages or greetings to the 
new codec.

If a Cisco Unity system has been running for a while and the codec is then changed, Cisco Unity may 
have greetings, voice names, prompts and messages stored in more than one format. Cisco Unity can 
transcode between formats; however, mixed message formats on very busy version 3.(x) systems have 
been known to cause the problem described in caveat CSCae08069. For more information, and for a 
workaround for the problem, refer to 
http://www.cisco.com/warp/public/788/AVVID/reorder_tone_after_startup.htm. Contact Cisco TAC 
before installing the workaround.

To view codec information for greetings, voice names, and prompts, do the procedure, To view codec 
information for greetings, voice names, and system prompts, page 6-7.

To change the codec used for all Cisco Unity recordings (messages, greetings, and voice names) do the 
procedure, To change the Cisco Unity recording codec, page 6-7.
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For information on choosing and implementing codecs, refer to White Paper: Audio Codecs and 
Cisco Unity, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_technical_reference_list.html.

To view codec information for greetings, voice names, and system prompts

Step 1 On the Cisco Unity desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane of the Tools Depot window, under Audio Management Tools, double-click Codec 
Checker.

Step 3 To export the data to a CSV file, click File, then choose to export either greeting and voice name data or 
prompt data.

Step 4 Click Exit.

Note A typical backup of the Cisco Unity server does not back up the registry. Also note that for Cisco Unity 
failover, registry changes on one Cisco Unity server must be made manually on the other Cisco Unity 
server, because registry changes are not replicated.

To change the Cisco Unity recording codec

Step 1 Exit the Cisco Unity software (right-click the Cisco Unity icon in the system tray, then click Stop 
Cisco Unity).

Step 2 To use the G.711 Mu-law or A-Law, G729a, or GSM 6.10 codec, skip to Step 3.

To use one of the optional Dialogic OKI ADPCM codecs:

a. Go to the Software Center website at http://www.cisco.com/kobayashi/sw-center/sw-voice.shtml
Click Other Components under Cisco Unity.

b. Click CiscoUnityDialogicCodec.exe, and download the file to the directory of your choice on the 
Cisco Unity server.

c. Unzip the CiscoUnityDialogicCodec.exe file to the directory of your choice.

d. Double-click Avvox_setup.exe, and follow the on-screen prompts.

To use the optional G.726 32 Kbps codec on a Cisco Unity version 4.0(1) or later system using VPIM 
with Microsoft Exchange:

a. Purchase license(s) from a vendor of your choice:

b. Follow the vendor installation instructions, then continue with Step 3.

Step 3 On the Cisco Unity desktop, double-click the Cisco Unity Tools Depot icon.

Step 4 In the left pane, under Audio Management Tools, double-click Set Record Format.

Step 5 In the Format list, select a supported codec, and click OK.

Step 6 Restart the Cisco Unity server.
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To change the recording format for existing greetings and voice names

Step 1 On the Cisco Unity desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane, under Audio Management Tools, double-click Set Wav Format.

Step 3 Select the greetings and voice names to adjust.

Step 4 Under Backup Original Voice Names and Greetings, check the check box, and type the location to save 
the original files.

Step 5 From the drop-down menu, select the new Wav format.

Step 6 Click Set Wav Format.

Step 7 Click OK, then click Exit.

Step 8 Restart the Cisco Unity server.

Cisco Unity-CM TSP Wave Gain Utility
The registry keys shown in Table 6-3 determine how the Cisco Unity-CM TSP adjusts record and 
playback volume for all recordings (messages, prompts, voice names, and greetings) for IP devices in a 
Cisco CallManager region that contains Cisco Unity and is set to use the G.711 codec. 

These registry settings are only applicable with a Cisco CallManager integration. If you have a PBX 
integration that uses Dialogic voice cards, see the “Dialogic Voice Card Automatic Gain Control and 
Registry Settings” section on page 6-11.

Use the Wave Gain utility to adjust and test the WaveDBGainPlayback and WaveDBGainRecord levels. 
The record and playback settings determined by using the Wave Gain utility must be manually entered 
into the registry by using either the Advanced Settings Tool or Regedit.

For Cisco Unity versions 3.1(2c) and later, set both the Cisco Unity-CM TSP Wave Gain record and 
playback levels to 0 to begin the volume adjustment process. If you have not already done so, do the 
procedure, To adjust greeting and name recordings by using the Set Volume utility, page 6-3.

If Cisco Unity automatic gain control is not present (version 3.1(2b) and earlier systems only), then the 
Cisco Unity-CM TSP Wave Gain playback level setting alone can be adjusted as needed for best sound 
quality, one or two dB at a time, by doing the following procedure.

Table 6-3 Wave Gain Utility Registry Keys

Key Name Purpose Recommended Setting

WaveDBGainPlayback Controls the wave driver boost or 
the reduction of system-wide 
playback levels for all recordings.

0—When Cisco Unity automatic gain control (AGC) is 
enabled. This value may be changed if necessary after 
adjustments are made to the AGC setting.

0xfffffff6 (the default)—version 3.0(x) and earlier systems 
where Cisco Unity AGC is not present.

WaveDBGainRecord Controls the wave driver boost or 
the reduction of recordings 
system-wide.

0—When AGC is enabled.

5 (the default)— version 3.1(2b) and earlier systems where 
AGC is not present.
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To determine the optimum Cisco Unity-CM TSP wave gain settings (Cisco Unity version 3.1(2b) and earlier only)

Step 1 Start Regedit.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for a Cisco Unity 
failover system, registry changes on one Cisco Unity server must be made manually on the 
other Cisco Unity server, because registry changes are not replicated. If you have any 
questions about changing registry key settings, contact Cisco TAC.

Step 2 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file, then close Regedit.

Step 3 Browse to the CommServer\Utilities directory.

Step 4 Double-click Wave Gain.

Step 5 To increase the playback volume, enter a positive number in the Playback Gain field. To decrease the 
playback volume, enter a negative number in the field. Do not adjust the value by more than one or two 
dB.

Step 6 Confirm that Record Gain is set to 0. Do not change this setting to a value other than 0.

Step 7 Leave a message for a test subscriber.

Step 8 Log on to Cisco Unity and listen to the test subscriber message.

Step 9 If you are not satisfied with the volume of the test subscriber message, repeat Step 5 as necessary.

When you are satisfied with the volume of the test subscriber message, write down the recording and 
playback volume settings, which you will enter into the registry in the procedure, To update wave gain 
settings in the registry for Cisco Unity version 3.1(2b) and earlier, page 6-9.

To update wave gain settings in the registry for Cisco Unity version 3.1(2b) and earlier

Note A typical backup of the Cisco Unity server does not back up the registry. Also note that for Cisco Unity 
failover, registry changes on one Cisco Unity server must be made manually on the other Cisco Unity 
server, because registry changes are not replicated.

Step 1 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane, under Administrative Tools, double-click Advanced Settings Tool.

Step 3 In the Unity Settings pane, click the wave gain adjustment registry key to be edited.

Step 4 Enter a new value, as recorded in Step 9 of the procedure, To determine the optimum Cisco Unity-CM 
TSP wave gain settings (Cisco Unity version 3.1(2b) and earlier only), page 6-9, and then click Set.

Step 5 When prompted, click OK.

Step 6 Click Exit.
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Step 7 Restart the Cisco Unity server for the registry change to take effect.

Automatic Gain Control

Cisco Unity Automatic Gain Control and Registry Settings

Cisco Unity automatic gain control (AGC) gives subscribers consistent message playback levels through 
the normalization of recordings. AGC affects recordings only. It is on by default, is controlled by registry 
settings, and is applied to voice samples after they have passed through all external hardware.

AGC does not improve the quality of recordings; it only addresses volume issues. For example, it cannot 
improve garbled incoming messages.

Because automatic gain control is enabled by default in Cisco Unity version 3.1(2c) and later, systems 
upgraded to 3.1(2c) and later may experience a problem where the existing greeting and name recordings 
sound louder than new greetings and names recorded after the upgrade. To prevent or resolve this 
problem after an upgrade, use the Set Volume utility to match the existing greeting and name recordings 
to the gain levels of Cisco Unity after the upgrade.The default values for the registry settings should be 
used for all Cisco Unity version 3.1(2c) and later upgrades. If you have not already done so, do the 
procedures in the “Set Volume Level Utility” section on page 6-2.

If you are using Dialogic voice cards, Cisco Unity AGC should be turned on, and the recommended 
settings for AGC in Table 6-4 are applicable.

The following registry keys determine how Cisco Unity AGC normalizes recordings.

Table 6-4 Automatic Gain Control Registry Keys

Key Name Purpose Recommended Setting

AGCtargetDB Target root mean square (RMS) power to which all 
recordings are normalized.

The setting is system-wide.

–26 dB.

The accepted range is –18dB to –30dB.

A setting of 0 (zero) disables AGC.

AGCsampleSize Buffer sample size used to calculate the average 
RMS power level.

8000.

AGCuseCompression Determines if a sample is clipped when a gain 
adjustment is applied. A value of 1 will not clip the 
sample; 0 clips the sample to the 
minimum/maximum values.

1.

(0 = clipped sample; disables compression).

AGCgainThreshold Maximum dB gain (+/–) applied to a sample to 
bring it to the target dB level.

5 dB.

AGCminimumThreshold Controls the minimum dB level of an incoming 
recording that Cisco Unity attempts to adjust. The 
setting prevents silence in a message and 
background hiss from being adjusted.

–45 dB.

The accepted range is –35 dB to –55 dB.
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To disable Cisco Unity AGC

Step 1 Exit the Cisco Unity Administrator.

Step 2 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 3 In the left pane of the Tools Depot window, go to Audio Management Tools, and double-click Set 
Volume.

Step 4 In the Set Greetings and Voice Names window, click Select All.

Step 5 Confirm that the Save Original Files check box is checked, then enter the location to which the backup 
copy of the original recorded names and greetings files will be saved.

Step 6 In the Options section, set New Target dB to 0 (zero).

Step 7 Confirm that the Save Above Volume Options check box is checked. Note that setting New Target dB 
to a value other than zero turns on automatic gain control.

Step 8 Click Set Volume Level.

Step 9 When “Done” appears in the Set Volume window, all existing greeting and name recordings have been 
adjusted to the New Target dB level with AGC disabled. 

Step 10 Click OK, and then click Exit.

Step 11 If you are using failover, repeat this procedure to apply the setting to secondary server.

Dialogic Voice Card Automatic Gain Control and Registry Settings

Dialogic voice cards adjust the volume of recorded messages by using their own on-board AGC. 
Adjusting the playback volume for all recordings on systems equipped with Dialogic voice cards is done 
by changing the Median Volume registry setting. This setting is also used in the case of a dual 
integration, when you want to change the output volume level on the PBX side without affecting the 
Cisco CallManager side.

Cisco Unity AGC should also be enabled on systems with Dialogic voice cards.

To adjust the playback volume of recordings for Cisco Unity systems equipped with Dialogic voice cards

Step 1 Start Regedit.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for a Cisco Unity 
failover system, registry changes on one Cisco Unity server must be made manually on the 
other Cisco Unity server, because registry changes are not replicated. If you have any 
questions about changing registry key settings, contact Cisco TAC.

Step 2 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.
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Step 3 Using Regedit, go to the registry key in HKEY_LOCAL_MACHINE\Software\Active 
Voice\Miu\1.0.\Initialization\ServiceProvider<n>\MedianVolume, where <n> is either 0 for a single 
switch, or 1 for a dual switch configuration. Expand the setting appropriate to your configuration to 
select the PBX switch. Do not select the Cisco CallManager switch.

Step 4 In the Base window, click Decimal.

The default setting for analog voice cards is 50, and the accepted range is between 0 and 100. Note that 
this setting is not in decibels, and that the numerical values are not linear. For example, a setting of 100 
is louder, but not twice as loud as 50. Make a small adjustment to this setting of no more than 10 units 
louder or quieter.

Step 5 To adjust the playback volume for Text-to-Speech recordings (TTS), go to the Median TTS Volume key.

Step 6 In the Base window, click Decimal.

The default setting for analog voice cards is 50, and the accepted range is between 0 and 100. Like the 
Median Volume key, this setting is not in decibels, and the adjustments are not linear. Make a small 
adjustment to this setting of no more than 10 units louder or quieter.

Step 7 Restart the Cisco Unity server.

Step 8 Test the playback levels of several recordings. If the volume levels are acceptable, you have completed 
all steps necessary in this procedure. If the volume levels are too high or too low, repeat Step 3 through 
Step 7, and retest until you are satisfied with the results.

Step 9 If you are using failover, repeat this procedure to apply the registry settings to secondary server.

Comfort Noise
Comfort noise is low-level background noise generated on a IP device. Its purpose is to simulate the hiss 
produced in a circuit-switched connection, and it can be generated when there is no audio from 
Cisco Unity, for example, during a transfer or between system prompts.

Comfort noise is not sent over the network, and is audible only on the IP device that receives a comfort 
noise generation packet. Comfort noise generation packets are sent by Cisco Unity when it is integrated 
with Cisco CallManager, and when the 
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\
Avaudio\Parameters\ComfortNoise registry setting is enabled.

The Cisco Unity ComfortNoise registry setting controls the ability of Cisco Unity to send comfort noise 
generation packets to an IP phone, or to a gateway that is enabled to receive and respond to comfort noise 
generation packets. This registry setting does not affect comfort noise generation on a call between two 
IP phones. Cisco Unity also does not respond to comfort noise generation packets sent by other devices. 
These packets are treated as silence at the wave driver level.

If subscribers hear an audible hissing noise when there is no audio from Cisco Unity, and if it is judged 
to be too loud a noise, confirm that the Cisco Unity comfort noise registry setting is enabled (set to a 
value other than zero), and then adjust the setting to a lower value as needed. The default value set during 
the Cisco Unity-CM TSP install is –50dB. 

Note The registry setting for Cisco Unity comfort noise does not reflect the minus sign, so a registry setting 
of 50 is actually –50dB.
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There will always be some amount of hissing noise between prompts. The Cisco Unity ComfortNoise 
registry setting only tells the IP phone or gateway how loud that hiss should be. A value of zero causes 
the IP phone or gateway to use its default hiss level.

To view and adjust the Cisco Unity comfort noise registry setting

Step 1 Start Regedit.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for a Cisco Unity 
failover system, registry changes on one Cisco Unity server must be made manually on the 
other Cisco Unity server, because registry changes are not replicated. If you have any 
questions about changing registry key settings, contact Cisco TAC.

Step 2 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 3 Go to the registry key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\
Avaudio\Parameters\ComfortNoise

Step 4 In the Edit Dword Value window, click Decimal.

Step 5 Modify the Cisco Unity comfort noise setting as needed:

• To decrease the volume of background noise between prompts and other audio, increase the setting 
(for example, to 60 dB). Make small adjustments to this setting of no more than 10 units.

• To increase the volume of background noise, reduce the setting (for example, to 40 dB). Make small 
adjustments to this setting of no more than 10 units.

• To disable Cisco Unity comfort noise, set the value to 0.

Step 6 Click OK.

Step 7 Restart the Cisco Unity server.

Step 8 If you are using failover, repeat this procedure to apply the registry setting to secondary server.
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Message Waiting Indicators (MWIs)

This chapter describes message waiting indicators (MWIs), how they function in Cisco Unity, and 
methods for troubleshooting them.

This chapter contains the following sections:

• How MWIs Function, page 7-1

• Troubleshooting MWIs When They Do Not Turn On or Off, page 7-4

• Troubleshooting MWIs When They Are Delayed Turning On and Off, page 7-11

• Troubleshooting MWIs When They Sometimes Do Not Turn Off, page 7-15

• Additional References, page 7-15

How MWIs Function
An MWI is a lamp, flashing LCD panel, or special dial tone on subscriber phones that lets subscribers 
know a voice message is waiting. The type of indicator depends on the phone system and the phones that 
subscribers use.

MWIs are not the same as message notification, which is the feature that notifies a subscriber of new 
voice messages by calling a phone or pager, or by sending an e-mail message.

When MWIs Turn On and Off

There are two principal events that cause Cisco Unity to activate and deactivate MWIs:

• When a caller leaves a message for a subscriber, Cisco Unity notifies the phone system to activate 
the MWI on the phone for that subscriber.

• When the subscriber listens to the message, Cisco Unity notifies the phone system to deactivate the 
MWI on the phone.

There are three additional events that cause Cisco Unity to activate and deactivate MWIs: 

• When the subscriber saves a listened-to message as a new message, Cisco Unity notifies the phone 
system to activate the MWI on the phone for that subscriber.

• When a subscriber deletes a new message without listening to it or moves it to another folder, 
Cisco Unity notifies the phone system to deactivate the MWI on the phone.

• When MWIs are manually resynchronized—for example, by clicking the Resynchronize Now 
button on the Properties tab in the Cisco Unity Telephony Integration Manager 
(UTIM)—Cisco Unity queries the Data Object Hierarchy (DOH) to determine the status of MWIs 
on all phones and resets all MWIs.
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However, an MWI remains activated under the following conditions when a subscriber listens to a new 
message:

• More messages are waiting to be heard. When all new messages are listened to, the MWI will be 
turned off.

• A new message arrives while the subscriber is listening to the original message. When all new 
messages are listened to, the MWI will be turned off.

• The subscriber listens on the phone to only part of the message and time stamp, then either hangs 
up or skips to the next message before hearing the entire message and time stamp.

• The server with the message store is offline and the message is stored in the Unity Messaging 
Repository (UMR).

• (Unified messaging only) In the Inbox, the subscriber marks a listened-to message as unread.

• (Unified messaging only) The subscriber uses the Inbox in offline mode to listen to messages.

In certain situations, MWIs are not activated:

• (Unified messaging only) E-mail messages arrive. Cisco Unity monitors only voice messages.

• Fax messages arrive. Cisco Unity monitors only voice messages.

• (Unified messaging only) Return receipts arrive. Cisco Unity monitors only voice messages.

• (Unified messaging only) An Inbox rule automatically moves voice messages to another folder. 
Cisco Unity monitors only the Inbox.

• The server with the message store is offline and the message is stored in the Unity Messaging 
Repository (UMR).

What Causes MWIs To Turn On and Off

The phone system is set up with one code or extension to turn MWIs on and a second code or extension 
to turn MWIs off. Cisco Unity sends the code or dials the extension to turn the MWI on and off for a 
subscriber.

You enter these codes or extensions in Cisco Unity in the Cisco Unity Telephony Integration Manager 
(UTIM)—click Programs > Unity > Unity Telephony Integration Manager.

Four Cisco Unity components (Exchange Monitor, Notifier queue, Notifier, and Media Interface Unit or 
MIU) work together to turn MWIs on and off. Figure 7-1 shows how these components interact.

Figure 7-1 Components That Turn MWIs On and Off

When a new message arrives in a subscriber Inbox, these components work together in the following 
sequence to activate the MWI on the phone of the subscriber:

1. The Exchange Monitor receives MAPI notification from the Exchange server each time a change 
occurs in the Inbox of each subscriber (when new voice messages arrive). When this happens, the 
Exchange Monitor sends an MWI activation message to the Notifier queue.

2. The Notifier queue adds the MWI activation message as an MWI activation request (with the 
activation code or extension) to send to the phone system.

Exchange Monitor Notifier queue Notifier
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3. The Notifier queries the Data Object Hierarchy (DOH) to determine the status of the MWI on the 
phone of the subscriber.

If the DOH responds that the MWI is turned off, the Notifier sends the MWI activation request in 
the Notifier queue to the phone system.

If the DOH responds that the MWI is turned on, the Notifier discards the MWI activation request.

4. The MIU—which includes the integration—enables Cisco Unity to communicate successfully with 
the phone system. The phone system receives the request and activates the MWI on the phone of the 
subscriber.

5. The phone system sends the new status of the MWI (activated) to the Notifier, which then sends the 
status to the DOH where Cisco Unity records the MWI status.

When there are no more new messages in the subscriber Inbox (all new messages have been listened to, 
deleted, or marked as read), the same four Cisco Unity components work together in the following 
sequence to deactivate the MWI on the phone of the subscriber:

1. The Exchange Monitor receives MAPI notification from the Exchange server each time a change 
occurs in the Inbox of each subscriber (all voice messages are listened to, deleted, or marked as 
read). When this happens, the Exchange Monitor sends an MWI deactivation message to the Notifier 
queue.

2. The Notifier queue adds the MWI deactivation message as an MWI deactivation request (with the 
deactivation code or extension) to send to the phone system.

3. The Notifier queries the DOH to determine the status of the MWI on the phone of the subscriber.

If the DOH responds that the MWI is turned on, the Notifier sends the MWI deactivation request in 
the Notifier queue to the phone system.

If the DOH responds that the MWI is turned off, the Notifier discards the MWI deactivation request.

4. The MIU—which includes the integration—enables Cisco Unity to communicate successfully with 
the phone system. The phone system receives the request and deactivates the MWI on the phone of 
the subscriber.

5. The phone system sends the new status of the MWI (deactivated) to the Notifier, which then sends 
the status to the DOH where Cisco Unity records the MWI status.

What Causes MWIs to Behave Differently Than Expected

The following conditions cause MWIs to behave differently than expected:

• (Unified messaging only) An Inbox rule automatically moves voice messages to another folder. 
Cisco Unity monitors only the Inbox, so the MWI is not activated.

• The DOH, which records the status of the MWI for each subscriber, received indication that an 
activation or deactivation request had not succeeded when in fact it had. Consequently, the Notifier 
may discard subsequent MWI requests.

• There are an inadequate number of voice messaging ports on the Cisco Unity server so the ports are 
not immediately available to dial out for activating and deactivating MWIs.

• An inadequate number of voice messaging ports on the Cisco Unity server are set to Dialout MWI, 
so the ports are too busy to dial out immediately to activate and deactivate MWIs.

• No voice messaging ports on the Cisco Unity server are enabled to dial out.

• (Multiple Cisco CallManager clusters) There are no voice messaging ports on the Cisco Unity server 
dedicated to activating and deactivating MWIs, one port for each cluster.

• (Cisco CallManager) In the UTIM, the MWI On Extension and MWI Off Extension fields on the 
MWI tab do not have the extensions that the phone system requires.
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• (Circuit-switched phone systems) In UTIM, the MWI On Code and MWI Off Code fields on the 
MWI tab do not have the code that the phone system requires.

• The codes or extensions are switched (for example, the code that activates MWIs is entered in the 
MWI Off Code field).

• (Cisco CallManager) The extensions that activate and deactivate MWIs are in a different partition 
or calling search space used for the phones and voice mail ports.

• The subscriber may not have the correct phone system assignment on the Subscribers > 
Subscribers > Profile page.

• MWIs are not enabled for the subscriber on the Subscribers > Subscribers > Messages page.

• The wrong extension for the subscriber is entered in the Extension field on the Subscribers > 
Subscribers > Messages page.

• The primary Exchange server is shut down or is off line.

• The phone system is programmed to send calls to a voice messaging port on the Cisco Unity server 
that sets MWIs but does not answer calls.

• (Cisco CallManager) A route plan (or dial plan) overlaps with an MWI extension number, so while 
the phone system waits for additional digits, Cisco Unity abandons the MWI request and the DOH 
records that the request failed. The phone system then successfully completes the MWI request.

• (Serial integrations) A faulty RS-232 serial cable passes data from the phone system to Cisco Unity 
but not from Cisco Unity to the phone system. So Cisco Unity sends MWI requests to the phone 
system, which does not receive them.

Troubleshooting MWIs When They Do Not Turn On or Off
To troubleshoot MWIs when they do not turn on or off, do the procedures for the following components 
in the order given:

• MIU Component, page 7-4

– Resolving Cisco CallManager Integration Problems, page 7-6

– Subscriber Phone System Assignment Is Incorrect, page 7-8

• Notifier and Notifier Queue Components, page 7-8

• Exchange Monitor Component, page 7-10

MIU Component

This section describes troubleshooting the MIU component, which includes the integration. Many MWI 
problems can be resolved by troubleshooting this component. In addition, if MWI requests reach the 
MIU, the preceding components probably are processing MWIs correctly. Figure 7-2 shows the focus.
7-4
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01



Chapter 7 Message Waiting Indicators (MWIs)
Troubleshooting MWIs When They Do Not Turn On or Off
Figure 7-2 MIU Component in the Troubleshooting Process

Do the following procedures in the order given.

To verify phone system and port settings in UTIM

Step 1 On the Windows Start menu of the Cisco Unity server, click Programs > Cisco Unity > Unity 
Telephony Integration Manager. UTIM appears.

Step 2 In the left pane, click the appropriate integration.

Step 3 In the right pane, click the MWI tab.

Step 4 Confirm that the codes or extensions to activate and deactivate MWIs are correct:

• (Circuit-switched phone systems) In UTIM, the values for the MWI On Code and MWI Off Code 
fields match the codes the phone system uses.

• (Cisco CallManager) In UTIM, the values in the MWI On Extension and MWI Off Extension 
fields match the extensions the phone system uses.

Step 5 If you changed any settings, click Save.

Step 6 Click the Ports tab.

Step 7 Confirm that the correct port ranges have been assigned to the appropriate phone system.

Step 8 If you changed any settings, click Save.

Step 9 Confirm the settings on any remaining tabs.

Step 10 If prompted, restart the Cisco Unity server.

To confirm that MWIs are enabled for the subscriber

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Messages page for the 
subscriber.

Step 2 Confirm that the Use MWI for Message Notification check box is checked.

Step 3 Confirm that the MWI Extension field is set to X (indicating the primary extension assigned to a 
subscriber) or to the extension number on which MWIs will be set for the subscriber.

To confirm that the MIU lets Cisco Unity and the phone system communicate

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page 
for the subscriber.

Step 2 Set up message notification for urgent messages for the subscriber.
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Step 3 Send an urgent message to the subscriber. If message notification of the urgent message arrives, the 
problem with MWIs is probably caused by the integration. Continue with the next procedure, To 
troubleshoot MIU problems.

To troubleshoot MIU problems

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscriber > Messages page.

Step 2 Confirm that the Use MWI for Message Notification check box is checked and that the Extension field 
is either X (which causes Cisco Unity to the use the MWI on subscriber extension) or the actual 
subscriber extension.

Step 3 Browse to the \Commserver\TechTools\ directory and double-click StatusMonitor.exe.

Step 4 In the Status Monitor window, confirm that the Display check box is checked and click Start All 
Monitors.

Step 5 Go to the Subscribers > Subscriber > Messages page, and click Resynchronize MWIs. In the Status 
Monitor window, the following message should appear:

"Dialing" (MWI) 'X'

Step 6 If the message appear, the MWIs are resynchronized and function correctly. Skip the rest of this 
procedure.

If the message does not appear, on the Windows Start menu, click Programs > Unity > Unity 
Diagnostic Tool.

Step 7 On the Cisco Unity Diagnostic Viewer screen, click the Configure Micro Traces icon.

Step 8 Set the following diagnostic traces:

• MiuGeneral—0–4, 12, 16

• MiuIO—11, 14

• MiuMethods—10, 12, 14, 18

• (Circuit-switched phone systems) MiuMethods—20, 22

• MiuIntegration—12

Step 9 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 10 Leave a message for a subscriber.

Step 11 Review the diagnostic logs to determine the cause of the problems. The command SetMWI is the one 
that is used by the MIU to set the MWI on a phone.

Step 12 On the Cisco Unity Diagnostic Viewer screen, click the Disable All Traces icon.

Step 13 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

Resolving Cisco CallManager Integration Problems

Consider the following issues if Cisco CallManager is integrated with Cisco Unity:

• The unique extensions for turning MWIs on and off may not have been entered in the 
Cisco CallManager server, or the Cisco CallManager server has not been restarted to enable these 
values. For instructions on setting these extensions, refer to the applicable Cisco CallManager 
integration guide at 
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http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_configuration_guides_list.html, 
and at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_
list.html.

• A Cisco CallManager route plan may include the unique extensions for turning MWIs on and off. 
For example, a route plan could send all numbers starting with 9 to a gateway, while the extension 
that turns MWIs on is 99991. Revise the route plan so it does not include the MWI extensions or 
alter the extensions. For instructions on setting up route plans, refer to the applicable 
Cisco CallManager Administration Guide at 
http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/index.htm.

• The unique extensions for turning MWIs on and off may not have been entered in the MWI On 
Extension and MWI Off Extension fields in the Cisco Unity Telephony Integration Manager 
(UTIM), or Cisco Unity may not have been restarted to enable these values. Enter the appropriate 
values in UTIM. For instructions on setting these values in UTIM, refer to the applicable Cisco 
CallManager integration guide at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_configuration_guides_list.html, 
and at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_
list.html.

• The IP phone may not be in the same calling search space and partition as the Cisco Unity voice 
messaging ports. From a phone, dial the extension that turns on MWIs. If you hear the reorder tone, 
the extensions for turning MWIs on is not assigned the correct calling search space and partition in 
Cisco CallManager. If you do not hear the reorder tone but the MWI is not activated or deactivated, 
a route plan may be causing the problem.

• The unique extensions for turning MWIs on and off in Cisco CallManager may not be identical to 
the values entered in the MWI On Extension and MWI Off Extension fields in UTIM. Confirm the 
values and restart the Cisco CallManager servers and Cisco Unity server. For instructions on setting 
these values, refer to the applicable Cisco CallManager integration guide at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_configuration_guides_list.html, 
and at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_
list.html.

• If the site has a publisher (primary) and subscriber (secondary) Cisco CallManager server, the 
unique extensions for turning MWIs on and off may not have been set on the subscriber Cisco 
CallManager server, or the subscriber CallManager server may not have been restarted to enable 
these values. On the subscriber Cisco CallManager server, set the extensions for turning MWIs on 
and off, and restart the Cisco Unity server. For instructions on setting these extensions, refer to the 
applicable Cisco CallManager integration guide at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_configuration_guides_list.html, 
and at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_
list.html.

• If Cisco Unity integrates with multiple Cisco CallManager clusters, you need to dedicate at least one 
voice messaging port to set MWIs for each cluster. For example, in a two-cluster environment, there 
must be at least two ports dedicated to setting MWIs, one sending MWI requests for the first cluster 
and another sending MWI requests to the second cluster. Confirm that at least one voice messaging 
port is dedicated to each cluster and that the port is set to Dialout MWI. For instructions on 
configuring ports, refer to the applicable Cisco CallManager integration guide at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_configuration_guides_list.html, 
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and at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_
list.html.

Subscriber Phone System Assignment Is Incorrect

If the subscriber is assigned to the wrong phone system, do the following procedure.

To confirm that the subscriber has the correct phone system assignment (dual phone system or former dual phone 
system integration)

Step 1 In the Cisco Unity Administrator, click Subscribers > Subscribers > Profile.

Step 2 In the Subscriber Information section, confirm that the correct phone system has been selected for the 
subscriber. Correct if necessary.

Step 3 If you made a change, click Save, then shut down and restart Cisco Unity.

Notifier and Notifier Queue Components

If the MIU component does not receive MWI requests, the problem lies earlier in the MWI process. This 
section describes troubleshooting the Notifier and Notifier queue components.

If MWI requests reach the Notifier queue and the Notifier components, the Exchange Monitor 
component is probably processing MWIs correctly. Figure 7-3 shows the focus.

Figure 7-3 Notifier and Notifier Queue Components in the Troubleshooting Process

Do the following procedures in the order given.

To confirm that the Notifier makes MWI requests

Step 1 On the Cisco Unity Diagnostic Viewer screen, click the Disable All Traces icon.

Step 2 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

Step 3 On the Cisco Unity Diagnostic Viewer screen, click the Configure Micro Traces icon.

Step 4 Check the check boxes for Notifier—12 and 20.

Step 5 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 6 Leave a message for a subscriber.

Step 7 To view the log files, click Processes > AvCsMgr, and then click the Current log file.

Step 8 The selected log file is formatted and appears in the right pane.

Step 9 Check the log for the following:

Exchange Monitor Notifier queue Notifier

DOHExchange

MIU

76
28

0

7-8
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_list.html
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_list.html


Chapter 7 Message Waiting Indicators (MWIs)
Troubleshooting MWIs When They Do Not Turn On or Off
• A Notifier—12 entry with the correct subscriber and extension listed to confirm that the MWI 
request is made with the correct information.

• The entry contains the text “Queued MWI task for mailuser.”

Step 10 If the Notifier thinks the MWI is already activated, the Notifier does not make the MWI request. In the 
Cisco Unity Administrator, go to the Subscribers > Subscribers > Messages page for the subscriber. 
Then click Resynchronize MWIs.

To confirm that MWI requests are successful

Step 1 In the log from the preceding procedure, locate a Notifier—12 entry.

Step 2 If the entry has the text “Completed MWI task for mailuser,” the MWI request was successful. If not, 
depending on the content of the entry, do one of the following:

• If the entry has the text “Received: Task” or “Continues Task,” the MWI request was not successful. 
Check the diagnostic log for any problem with the voice messaging ports. See the procedure, To 
troubleshoot port problems, page 7-9.

• If the diagnostic log indicates the MWI request was successful, but the MWI is not activated, set 
diagnostic traces for Notifier—12, MiuIntegration—12, and MiuMethods—20, 21, and review the 
logs.

Step 3 On the Cisco Unity Diagnostic Viewer screen, click the Disable All Traces icon.

Step 4 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

Do the following procedure as needed.

To troubleshoot port problems

Step 1 In the Cisco Unity Administrator, go to the System >Ports page, and confirm that some ports are set to 
Dialout MWI.

For dual phone system integrations, make sure that each phone system has some of its ports set to 
Dialout MWI.

Step 2 On the Cisco Unity Diagnostic Viewer screen, click the Disable All Traces icon.

Step 3 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

Step 4 On the Cisco Unity Diagnostic Viewer screen, click the Configure Micro Traces icon.

Step 5 Set the following diagnostic traces:

• Notifier—20

• Arbiter—13

• ResourceManager—12

Step 6 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 7 Leave a message for a subscriber.

Step 8 Review the diagnostic logs to determine the cause of the problems.

Step 9 On the Cisco Unity Diagnostic Viewer screen, click the Disable All Traces icon.
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Step 10 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

Exchange Monitor Component

If the Notifier queue and the Notifier do not receive MWI requests, the problem lies earlier with the 
Exchange Monitor. This section describes troubleshooting the Exchange Monitor component. Figure 7-4 
shows the focus.

Figure 7-4 Exchange Monitor Component in the Troubleshooting Process

Do the following procedures.

To confirm that the Exchange Monitor detects new messages

Step 1 On the Cisco Unity Diagnostic Viewer screen, click the Configure Micro Traces icon.

Step 2 Check the check boxes for the following traces:

• ExchangeMonitor—13

• Notifier—21

Step 3 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 4 Leave a message for a subscriber.

Step 5 To view the log files, click Processes > AvCsMgr, and then click the Current log file.

Step 6 The selected log file is formatted and appears in the right pane.

Step 7 Check the log for the following:

• An ExchangeMonitor—13 entry with TABLE_ROW_ADDED or TABLE_ROW_MODIFIED to 
confirm that the Exchange Monitor detected the new message.

• A Notifier—21 entry (soon after the ExchangeMonitor entry) with “NotifyQ popped,” “Action=2,” 
and the subscriber name. This entry confirms the MWI message was added to the Notifier queue.

Step 8 If these entries appear, but the MWI is not activated, skip to Step 9.

If these entries don’t appear, then on the Cisco Unity Diagnostic Viewer screen, click the Disable All 
Traces icon.

Step 9 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

To Troubleshoot Advanced Exchange Monitor Problems

Step 1 On the Windows Start menu, click Programs > Unity > Unity Diagnostic Tool.
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Step 2 On the Cisco Unity Diagnostic Viewer screen, click the Configure Micro Traces icon.

Step 3 Check the check boxes for the following traces:

• Notifier—12, 20, 21, 22, 24

• AlCommon—10

• DalEx—10

• DOH—10

• SalNT—10

Step 4 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 5 Leave a message for a subscriber.

Step 6 To view the log files, click Processes > AvCsMgr, and then click the Current log file.

Step 7 The selected log file is formatted and appears in the right pane.

Step 8 Review the diagnostic logs to determine the cause of the problem.

To Troubleshoot MWIs That Work for Some Subscribers but Not Others

Step 1 Check the Exchange properties to determine whether the site created its own Cisco Unity profile. If so, 
check the RPC limit set in the profile. To find the settings, locate the following registry key:

• For Exchange 2000:
HKU\.Default\Software\Microsoft\Windows NT\Current Version\Windows 
Messaging\Profiles\Unity System Profile\12dbb0c8aa05101a9bb000aa002fc45a

• For Exchange 5.5:
HKCU\Software\Microsoft\Windows NT\Current Version\Windows Messaging\Profiles\Unity 
System Profile\13dbb0c8aa05101a9bb000aa002fc45a

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for a Cisco Unity 
failover system, registry changes on one Cisco Unity server must be made manually on the 
other Cisco Unity server, because registry changes are not replicated. If you have any 
questions about changing registry key settings, contact Cisco TAC. 

Step 2 Confirm that the value 00036604 is set to 06 00 00 00. The fourth bit of the first byte must be set to 05 
through 07 or 0C through 0F.

Otherwise, the site has an RPC limit, which prevents an MWI from being updated.

Troubleshooting MWIs When They Are Delayed Turning On and 
Off

There are several possible reasons that MWIs may be delayed turning on and off. These reasons include:
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• Restarting the Cisco Unity Server Causes MWI Delay, page 7-12

• The Cisco Unity Primary Exchange Server Is Down or Is Disconnected, page 7-12

• Ports Are Too Busy to Turn MWIs On and Off Promptly, page 7-12

• Not Enough Ports Are Set for MWIs, page 7-13

• Calls Are Sent to Cisco Unity Ports That Set MWIs but Do Not Answer Calls, page 7-13

• MWI Turns On and Off Slowly After Adding Subscribers (Exchange 5.5), page 7-13

• MWI Turns On and Off Slowly After the AppleTalk Protocol Is Uninstalled on the Exchange Server, 
page 7-14

Restarting the Cisco Unity Server Causes MWI Delay

Restarting the Cisco Unity server may result in delayed MWIs until MAPI logon to all subscriber 
mailboxes has been completed. (MAPI logon is necessary for monitoring each subscriber mailbox for 
voice messages.) Depending on the size of the subscriber database, it could take several hours to 
complete the MAPI logon.

The Cisco Unity Primary Exchange Server Is Down or Is Disconnected

Messages recorded while the primary Exchange server is down or disconnected are stored in the Unity 
Messaging Repository (UMR) until the server is brought back up. Since MWIs are not lit until a message 
is actually delivered to a subscriber, the delay experienced between the time a message is recorded and 
its delivery is entirely dependant on the amount of time that the primary Exchange server was down or 
disconnected.

Ports Are Too Busy to Turn MWIs On and Off Promptly

When the ports that turn MWIs on and off are also set to perform other operations, they may be too busy 
to turn MWIs on and off promptly. You can improve MWI performance by taking the following actions:

• Dedicate a number of ports exclusively to turning MWIs on and off.

• Make sure that the entry point of the Cisco Unity hunt group for ports is not a port that also handles 
MWIs.

• Use the last ports assigned to a phone system to turn MWIs on and off. 

• For systems that handle a large volume of calls, install additional ports.

To review port configuration for message waiting indication (non-serial integrations only)

Step 1 In the Cisco Unity Administrator, click System > Ports.

Step 2 Review the existing port configuration and determine if one or more ports can be set only to Dialout 
MWI.
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Not Enough Ports Are Set for MWIs

When Cisco Unity takes a lot of messages, the ports assigned to turn MWIs on and off may not always 
be able to dial out promptly. A single port set to dial out only for Message Waiting Indication with an IP 
phone system integration can change approximately 240 to 360 MWIs per hour, depending on the phone 
system. An analog integration can take up to seven seconds per MWI change.

To determine whether the number of message waiting indication ports is adequate

Step 1 In the Cisco Unity Administrator, click Reports > System > Port Usage.

Step 2 Generate a port usage report for the ports set only to dial out for MWIs.

If the value of Percentage Of Ports Used exceeds 40 percent usage during peak periods, click 
System > Ports in the Cisco Unity Administrator, then continue with Step 3.

If the value of Percentage Of Ports Used does not exceed 40 percent usage during peak periods, then the 
number of message waiting indication ports is adequate.

Step 3 Review the existing port configuration and determine if one or more additional ports can be set only to 
Dialout MWI.

Calls Are Sent to Cisco Unity Ports That Set MWIs but Do Not Answer Calls

If the phone system is programmed to send calls to a port on Cisco Unity that is configured to set MWIs 
and not to answer calls, MWIs may be delayed.

To confirm that calls are being sent to the correct Cisco Unity ports

Step 1 In the Cisco Unity Administrator, click System > Ports.

Step 2 Note which ports are designated to answer calls.

Step 3 In the phone system programming, confirm that calls are only being sent to ports designated to answer 
calls.

Step 4 If you make a change to the phone system programming, shut down and restart the Cisco Unity server 
to clear any hung ports.

MWI Turns On and Off Slowly After Adding Subscribers (Exchange 5.5)

If MWIs are slow to turn on and the system connects to an Exchange 5.5 server, the cause is often the 
creation or moving of approximately 100 subscribers. When the new subscribers are created or imported, 
Cisco Unity creates a primary call handler on the Cisco Unity server. However, Exchange 5.5 needs to 
allocate additional threads to service MWIs for the new subscribers. The solution is to run Exchange 5.5 
Optimizer, which allocates additional threads in Exchange.

If there are other Exchange servers in the site, you do not need to run the Exchange Optimizer on the 
other Exchange servers.
7-13
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01



Chapter 7 Message Waiting Indicators (MWIs)
Troubleshooting MWIs When They Are Delayed Turning On and Off
To run Exchange 5.5 Optimizer 

Step 1 Shut down the Cisco Unity server, if it is running.

Step 2 On the Windows Start menu, click Programs > Microsoft Exchange > Microsoft Exchange 
Optimizer.

Step 3 Follow the on-screen instructions. If the Exchange Optimizer recommends that you move files, you can 
safely choose not to do so.

Step 4 If the Exchange 5.5 Optimizer displays an error message saying that a service could not be shut down, 
do the following:

• Exit the Exchange Optimizer.

• Right-click the Cisco Unity icon in the status area of the taskbar, and click Exit.

• Start the Exchange Optimizer, and follow the on-screen instructions.

Step 5 When the Exchange Optimizer is finished, restart the Cisco Unity server.

MWI Turns On and Off Slowly After the AppleTalk Protocol Is Uninstalled on the Exchange Server

When you install and then uninstall the AppleTalk protocol on the Exchange server on which 
Cisco Unity subscribers are homed, a value remains in the Winsock file that prevents Exchange from 
registering for push notifications. Consequently, all MAPI clients use a polling mechanism that is less 
reliable than a push notification.

This problem occurs in all versions of Cisco Unity that connect to Exchange version 5.5 SP4 or 
Exchange 2000.

Do the following procedure.

To change the registry to enable Exchange to push notifications

Step 1 On the Cisco Unity server, click Start > Run.

Step 2 In the Open field, enter Regedit and press Enter. The Registry Editor appears.

Caution Changing the wrong registry key or entering an incorrect value can cause the server to 
malfunction. Before you edit the registry, confirm that you know how to restore it if a problem 
occurs. (Refer to the “Restoring” topics in Registry Editor Help.) Note that a typical backup 
of the Cisco Unity server does not back up the registry. Also note that for a Cisco Unity 
failover system, registry changes on one Cisco Unity server must be made manually on the 
other Cisco Unity server, because registry changes are not replicated. If you have any 
questions about changing registry key settings, contact Cisco TAC. 

Step 3 If you do not have a current backup of the registry, click Registry > Export Registry File, and save the 
registry settings to a file.

Step 4 Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock\Parameters and 
delete AppleTalk.

Step 5 Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Exchange 
Provider\Rpc_Svr_Binding_Order and delete ncacn_at if it is present.
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Step 6 Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\ClientProtocols and delete 
ncacn_at_dsp.

Step 7 Close the Registry Editor.

Step 8 For the settings to take effect, exit and restart the Cisco Unity software.

Troubleshooting MWIs When They Sometimes Do Not Turn Off
There is one possible reason for MWIs not turning off as expected.

MWIs Have Lost Synchronization

MWIs may lose synchronization if, for example, the phone system is off-line when an MWI status 
changes.

Do the following procedure.

To resynchronize MWIs

Step 1 On the Cisco Unity server, browse to the CommServer\Utilities\Utim directory and double-click 
Utim.exe. UTIM appears.

Step 2 For the integration node, click the Properties tab.

Step 3 In the MWI Synchronization section, click Resynchronize Now.

Step 4 If appropriate, check the Resynchronize At check box, and choose the time that you want the system to 
resynchronize the MWIs. We recommend choosing a time outside of regular business hours because of 
the Cisco Unity resources needed for resynchronization.

Additional References
More information about setting up MWIs can be found in the following documents:

• Cisco Unity integration guides for various phone systems available at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_configuration_guides_list.html, 
and at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_
list.html.

• Cisco Unity System Administration Guide at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_
list.html.

• Cisco Unity Release Notes at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_release_notes_list.html.
7-15
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_configuration_guides_list.html
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_list.html
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_list.html
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_release_notes_list.html
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_list.html
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_configuration_guides_books_list.html


Chapter 7 Message Waiting Indicators (MWIs)
Additional References
7-16
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01



Cisco Unity Troublesho
OL-3102-01
C H A P T E R 8

Message Notification Calls

About Problems with Message Notification Calls
Problems with message notification calls that Cisco Unity makes to a subscriber pager, or a work, home, 
or spare phone fall into two categories:

Message Notification Is Slow for Multiple Subscribers
There are several possible reasons that message notification may appear to be slow for multiple 
subscribers. Use the Task List for Troubleshooting Slow Message Notifications for Multiple Subscribers 
to troubleshoot the possible causes.

Task List for Troubleshooting Slow Message Notifications for Multiple Subscribers

1. Confirm that ports are not too busy to handle message notification. See the “Ports Are Too Busy To 
Make Notification Calls Promptly” section on page 8-2.

2. Confirm that there are enough ports assigned to message notification. See the “Not Enough Ports 
Are Set for Message Notification Only” section on page 8-2.

3. Confirm that the phone system sends calls to ports that are set to answer calls. See the “Confirming 
that the Phone System Sends Calls to the Ports Set To Answer Calls” section on page 8-2.

4. Confirm that the Exchange server is not down or disconnected. See the “Cisco Unity Primary 
Exchange Server Is Down or Is Disconnected” section on page 8-3.

Message notification 
is slow 

When multiple subscribers report that message notification is slow, a port setup 
problem is the likely cause. See the “Message Notification Is Slow for Multiple 
Subscribers” section on page 8-1. Isolated complaints about slow message 
notification likely are related to a subscriber message notification settings. See 
the “Message Notification Is Slow for a Subscriber” section on page 8-3.

Message notification 
does not work at all

Some system problems can prevent Cisco Unity from making any notification 
calls. See the “MAPI Logon Delay After Restarting the Cisco Unity Server” 
section on page 8-5 and “Message Notification Calls Are Not Made to Any 
External Numbers” section on page 8-5. When a subscriber sets up message 
notification incorrectly, it can prevent Cisco Unity from making any notification 
calls to that subscriber. See the “Message Notification Is Not Working at All for 
a Subscriber” section on page 8-5.
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Ports Are Too Busy To Make Notification Calls Promptly

When the ports that make notification calls are also set to perform other operations, they may be too busy 
to make notification calls promptly. You can improve notification performance by dedicating a smaller 
number of ports to making notification calls exclusively.

Systems that handle a large volume of calls may require additional ports to improve notification 
performance.

To review port configuration for message notification

Step 1 In the Cisco Unity Administrator, go to the System > Ports page.

Step 2 Review the existing port configuration and determine if one or more ports can be set to dial out for 
message notification only.

Not Enough Ports Are Set for Message Notification Only

When a small number of ports are set to make notification calls and Cisco Unity takes a lot of messages, 
the notification ports may not always be able to dial out promptly.

To determine if the number of notification ports is adequate

Step 1 In the Cisco Unity Administrator, go to the Reports > System > Port Usage page.

Step 2 Generate a port usage report.

If the value of Percentage Of Ports Used exceeds 70 percent usage during peak periods for the ports set 
to dial out for message notification, go to the System > Ports page in the Cisco Unity Administrator, 
then continue with Step 3.

If the value of Percentage Of Ports Used does not exceed 70 percent usage during peak periods for the 
ports set to dial out for message notification, the number of notification ports is adequate. Contact the 
Cisco Technical Assistance Center (TAC) to resolve the problem.

Step 3 Review the existing port configuration and determine if more ports can be set to dial out for message 
notification only.

Confirming that the Phone System Sends Calls to the Ports Set To Answer Calls

If the phone system is programmed to send calls to a port on Cisco Unity that is not configured to answer 
calls, Cisco Unity will not answer the call.

To confirm that calls are being sent to the correct Cisco Unity ports

Step 1 In the Cisco Unity Administrator, go to the System > Ports page.

Step 2 Note which ports are set to answer calls.

Step 3 In the phone system programming, confirm that calls are only being sent to ports set to answer calls. 
Change the phone system programming if necessary.
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Step 4 If you make a change to the phone system programming, restart the Cisco Unity server to clear any hung 
ports.

Cisco Unity Primary Exchange Server Is Down or Is Disconnected

Messages recorded while the primary Exchange server is down or disconnected are stored in the Unity 
Messaging Repository (UMR) until the server is brought back up. Because calls for message notification 
are not made until a message is actually delivered to a subscriber, the delay experienced between the 
time a message is recorded and its delivery is dependant on the amount of time that the primary Exchange 
server was down or disconnected.

Message Notification Is Slow for a Subscriber
There are several possible reasons that message notification may appear to be slow for a subscriber. Use 
the Task List for Troubleshooting Slow Message Notification for a Single Subscriber to troubleshoot the 
possible causes.

Task List for Troubleshooting Slow Message Notification for a Single Subscriber

1. The subscriber settings may not be adequate for the needs of the subscriber. See the “Message 
Notification Setup Is Inadequate” section on page 8-3.

2. The subscriber settings may need adjustment to more correctly map to the work schedule of the 
subscriber. See the “Notification Attempts Are Missed” section on page 8-4.

3. The subscriber may not clearly understand how repeat notifications are handled by Cisco Unity. See 
the “Repeat Notification Option Is Misunderstood” section on page 8-4.

Message Notification Setup Is Inadequate

When a subscriber complains that notification calls are not being received when expected, the problem 
may be with the notification settings.

To determine if notification setup is adequate

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page 
for the subscriber.

Step 2 In the Device list, click the correct notification device.

Step 3 Confirm with the subscriber that the notification device is appropriate for the needs of the subscriber. If 
the subscriber has selected a very busy phone for Cisco Unity to call, ask if there is an alternate phone 
or pager to use for message notification.

Step 4 Confirm with the subscriber that the notification schedule is consistent with the days and times that the 
subscriber is available to receive notification calls.
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Notification Attempts Are Missed

A subscriber who is frequently away from or busy using a notification device may repeatedly miss 
notification attempts. To the subscriber, it appears that Cisco Unity has delayed message notification.

To resolve missed notification attempts

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page 
for the subscriber.

Step 2 In the Device list, click the correct notification device.

Step 3 In the Notification Options section, check the Restart Notification Each Time a New Message Arrives 
check box.

Step 4 In the Try Again How Many Times boxes, increase the numbers so that Cisco Unity makes more 
notification calls when the device does not answer or is busy.

Step 5 In the How Many Minutes To Wait Between Tries boxes, decrease the numbers so that Cisco Unity 
makes notification calls more often when the device does not answer or is busy.

Step 6 In the If Notification Fails box, select Pager as a backup device if the subscriber has a pager available 
for use. Also enter settings and a schedule for the pager.

Step 7 Suggest that the subscriber set up an answering machine for the notification phone, so that notification 
calls are received even when the subscriber is unavailable.

When Cisco Unity is set to call a phone that has an answering machine, confirm with the subscriber that 
the answering machine greeting is short enough so that the machine starts recording before the 
notification message is repeated.

Repeat Notification Option Is Misunderstood

Setting Cisco Unity to repeat notification at a particular interval when there are still new messages can 
be useful for subscribers who receive a lot of messages but who do not want immediate notification. 
However, when a subscriber chooses not to have Cisco Unity restart notification each time a new 
message arrives, setting a long interval between repeat notification calls may lead the subscriber to 
believe that Cisco Unity is delaying notification.

To resolve a repeat notification problem

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page 
for the subscriber.

Step 2 In the Device list, click the correct notification device.

Step 3 In the Notification Options section, in the box next to the Repeat Notification If There Are Still New 
Messages After This Many Minutes check box, set a shorter interval, such as 15 minutes.
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MAPI Logon Delay After Restarting the Cisco Unity Server
Restarting the Cisco Unity server may result in delayed message notification until MAPI logon to all 
subscriber mailboxes has been completed. Depending on the size of the subscriber database, it could take 
several hours to complete the MAPI logon.

Message Notification Calls Are Not Made to Any External 
Numbers

A possible cause for this problem is that Cisco Unity cannot access an external line.

To verify external line access (circuit-switched phone systems only)

Step 1 Set up a test phone (Phone 1) for single-line testing. Use a line connected to a port that is set to dial out 
for Message Notification. For more information, see the “Preparations for Troubleshooting the Phone 
System” section on page 1-1.

Step 2 On Phone 1, dial the access code necessary to get an external line.

Step 3 Dial an external phone number.

If you do not reach the external number, continue with Step 4.

If you reach the number, Cisco Unity can access external lines for message notification. Message 
notification settings in the subscriber template may be preventing Cisco Unity from making notification 
calls. Verify the message types and access code in the template, and change the values if necessary. If 
you make changes to the template message types or access code, you must make the same changes to all 
existing subscriber accounts based on the subscriber template.

Step 4 Review the phone system programming for restrictions on external line access. Change the phone system 
programming values as necessary, and repeat the test.

If the test fails again, contact Cisco TAC.

Message Notification Is Not Working at All for a Subscriber
There are several possible reasons that message notification may not work at all for a subscriber. Use the 
Task List for Troubleshooting Non-Functional Message Notifications for a Subscriber to troubleshoot 
the possible causes.

Task List for Troubleshooting Non-Functional Message Notifications for a Subscriber

1. Confirm that message notification is enabled for the correct types of messages. See the “Only 
Certain Types of Messages Are Set To Trigger Notification” section on page 8-6.

2. Confirm that the message notification phone number includes the access code for an external line if 
notification is to an external phone. See the “Access Code for an External Line Is Missing” section 
on page 8-6.
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3. Confirm that the notification device is enabled. See the “Notification Number Is Incorrect or the 
Device Is Disabled or Not Working” section on page 8-6.

4. (Dual phone system integrations only) Confirm that the notification device is assigned to the correct 
phone system. See the “Notification Device Phone System Assignment Is Incorrect (Dual Phone 
System Integrations Only)” section on page 8-7.

Only Certain Types of Messages Are Set To Trigger Notification

Cisco Unity can be set so that a subscriber is notified only of certain types of messages. For example, if 
subscriber notification is set up only for fax and urgent voice messages, then e-mail and regular voice 
messages will not cause Cisco Unity to make a notification call.

To change the message types that trigger notification calls

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page 
for the subscriber.

Step 2 In the Device list, click the correct notification device.

Step 3 In the Notify Subscriber Of section, verify the selected message types with the subscriber.

Access Code for an External Line Is Missing

To place an external call, a subscriber usually must dial an access code to get an external line (for 
example, 9). When the phone system requires an access code, an external message notification phone 
number set in Cisco Unity must include the access code.

In addition, some phone systems may require a brief pause between dialing the access code and being 
connected to an external line.

To verify an access code

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page 
for the subscriber.

Step 2 In the Device list, click the correct notification device.

Step 3 In the Phone Number box, confirm that the correct access code is included before the phone number. If 
the phone system requires a pause, enter two commas between the access code and the phone number 
(for example, 9,,5551234).

Notification Number Is Incorrect or the Device Is Disabled or Not Working

The subscriber may have entered a wrong phone number for Cisco Unity to call. Also, when a subscriber 
disables notification to a phone or pager, Cisco Unity will not attempt a notification call to the device 
regardless of the other notification settings.
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To verify a device phone number and status

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page 
for the subscriber.

Step 2 In the Device list, click the correct notification device.

Step 3 In the Phone Number box, confirm that the correct access code and phone number are entered for the 
device.

Step 4 In the Status section, confirm that the device is set to Enabled.

To test a notification device

Step 1 If the notification device is a cellular phone or pager, ask the subscriber to have it available for the test.

If the notification device is a home phone or another phone away from the office, ask the subscriber to 
have someone available to answer the phone during the test.

Step 2 Confirm that the notification device is on.

Step 3 Set up a test phone (Phone 1) for single-line testing. Use a line connected to a port that is set to dial out 
for message notification. For more information, see the “Preparations for Troubleshooting the Phone 
System” section on page 1-1.

Step 4 On Phone 1, dial the notification number set in Cisco Unity for the device.

If the pager is activated or the phone rings, you have confirmed that Cisco Unity can call the device.

If the pager is not activated or the phone does not ring, there may be a problem with the device. Consult 
the documentation from the device manufacturer, or ask the subscriber to obtain a different notification 
device and repeat the test.

Notification Device Phone System Assignment Is Incorrect (Dual Phone System Integrations Only)

To verify notification device phone system assignment

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Message Notification page.

Step 2 In the Notification Options section, note the phone system assigned to the device in the Switch field at 
the bottom of the page.

Step 3 Go to the System > Ports page for the phone system assigned to the device.

Step 4 Verify that the phone system assigned to the notification device has at least one port designated for 
message notification. Correct the port settings if necessary.

Step 5 Click the Save icon.
8-7
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01



Chapter 8 Message Notification Calls
Message Notification Is Not Working at All for a Subscriber
8-8
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01



Cisco Unity Troublesho
OL-3102-01
C H A P T E R 9

Error Messages

About Error Messages
Error message problems fall into these categories:

For information about the error messages that Cisco Unity writes to the Windows Application Event log, 
see http://www.CiscoUnitySupport.com.

Startup Error Messages
Use the information in this section to troubleshoot errors that occur when starting either the Cisco Unity 
software or server.

Cisco Unity Fails To Start

Error Message At least one service or driver failed during system startup.

Explanation This message is displayed when one or more of the Cisco Unity services or the services 
required by Cisco Unity do not start.

Recommended Action To troubleshoot this problem:

• Check the startup settings for the services as described in the procedure, To check the service 
startup settings, page 9-2.

Startup error messages These are error messages that may appear when Cisco Unity or the 
Cisco Unity server is started. See the “Startup Error Messages” section 
on page 9-1.

Browser and Windows error 
messages

Browser error messages may appear during a logon attempt to the 
Cisco Unity Administrator, the Cisco Unity Assistant, or the Cisco Unity 
Inbox. Windows error messages may appear when accessing 
Administrative Tools. See the “Browser and Windows Error Messages” 
section on page 9-3.

E-mail and voice error 
messages

Cisco Unity may send e-mail and voice mail error messages. See the 
“E-mail and Voice Error Messages” section on page 9-6.
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• Check for errors listed in the Application and System Event logs as described in the procedure, 
To look for errors in the Application and System Event logs, page 9-2.

To check the service startup settings

Do the steps below for each of the following services:

• These Cisco Unity services: AvCsGateway, AvCsMgr, and AvGaenSvr

• Dialogic

• IIS Admin Service

• Each Microsoft Exchange service

• World Wide Web Publishing Service

Step 1 In the Control Panel Services dialog box, click the service, then click Startup.

Step 2 Verify that Manual is selected for AvCsMgr, AvUMRSyncSvr, and AvRepDirSvrSvc.

Step 3 Verify that Automatic is selected for the other services.

Step 4 Verify that the domain name, user name, and password in the account assigned to the service are correct 
and that the account has the correct rights and permissions. 

To look for errors in the Application and System Event logs

Because startup events occur in rapid succession, when you look in the Application or System Event log 
for information about these events, you will be looking for the first event in a series of events that 
probably occurred just seconds apart. Locate the first error in the startup attempt. Subsequent errors may 
have been caused by the first error. If you can determine the cause and fix the first error, then shut down 
and restart the Cisco Unity server. All subsequent errors may be resolved by fixing the first.

Step 1 On the Windows Start menu, click Programs > Administrative Tools > Event Viewer.

Step 2 In the Application Event log, look at the Date and Time columns to find the first event in the current 
startup attempt.

Step 3 Once you find the first event in the startup attempt, look for the first error that occurred after it. If no 
errors appear in the startup attempt, skip to Step 5.

Step 4 Look at the value in the Source column for the first error and then for any subsequent errors in the startup 
attempt.

If the name in the source begins with “CiscoUnity” or with the letters “Av,” then double-click the error 
to display a dialog box containing additional information that may help you solve the problem.

If the source is Doh, then Exchange probably is not running. Start Exchange, then try again to start 
Cisco Unity.

If the Source column for an error contains any other value, or if you cannot determine the cause of the 
problem, contact the Cisco Technical Assistance Center (TAC).

Step 5 In the System Event log, look at the Date and Time columns to find the first event in the current startup 
attempt.

Step 6 Once you find the first event in this startup attempt, look for the first error that occurred after it.

If no errors appear in the System Event log, contact Cisco TAC.
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Step 7 Look at the value in the Source column for the first error and for any subsequent errors in the startup 
attempt.

If the value is Dlgc_log or DlgcDcm, then the problem is with the installation or configuration of the 
Dialogic voice or fax cards. Double-click the event error to display additional information that may help 
you solve the problem. When a Dialogic service fails to start, you may need to check the IRQ settings, 
switches, jumpers, and rotary dials on each card, as appropriate. When the Cisco Unity server contains 
more than one Dialogic voice card, you may also need to check the cable that connects the cards. See 
the “Installing Voice Cards” section in the “Installing the Cisco Unity System” chapter of the 
Cisco Unity Installation Guide for additional information. The Cisco Unity Installation Guide is 
available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_installation_guides_books_list.ht
ml.

If the Source column for an error has any other value, contact Cisco TAC.

To change LPT1 port settings

Step 1 On the Windows Start menu, click Programs > Administrative Tools > Computer Management.

Step 2 Double-click Device Manager.

Step 3 Expand Ports and double-click LPT1.

Step 4 Click Port Settings.

Step 5 Click Try Not To Use an Interrupt.

Step 6 Click OK.

Browser and Windows Error Messages
Cisco Unity administrators or subscribers may see the following error messages:

Error Message Access denied. Your class of service prohibits you from accessing the 
System Administration Web pages.

Explanation When this message appears during a logon attempt to the Cisco Unity Administrator, one 
of the following has occurred:

• The class of service for the logon account has been changed. Log on using a different account. 

• The Cisco Unity class of service has been changed to subscriber for everyone who previously 
had administrator privileges. There is no longer a Cisco Unity account for the administrator 
class of service.

Recommended Action Do the procedure, To temporarily associate an Exchange account with the 
Administrator class of service, page 9-4.
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To temporarily associate an Exchange account with the Administrator class of service

Step 1 In the Exchange Administrator, go to the recipients for your site, and locate the Example Administrator 
recipient.

Step 2 Double-click the Example Administrator recipient.

Step 3 Associate the Example Administrator recipient with the Windows account that you are logged on with.

Step 4 Log off and then log back on again to Cisco Unity.

Step 5 Assign accounts as needed to the administrator class of service.

Step 6 Log off of Cisco Unity.

Step 7 In the Exchange Administrator, remove your account association with the Example Administrator 
account.

Under normal circumstances, the Example Administrator should not be associated with a Windows 
account.

Error Message Access denied. You cannot access the System Administration Web pages. 
Cisco Unity is not running.

Explanation When this message appears, Cisco Unity is not running. Cisco Unity must be running 
before anyone can log on to the Cisco Unity Administrator.

Recommended Action Start Cisco Unity.

Error Message Access denied. You cannot access the System Administration web pages. 
There are too many active sessions.

Explanation When this message appears, the maximum limit of concurrent system administration 
sessions has been reached.

Recommended Action Wait for an active session to be closed and then try again later.

Error Message Access denied. Your Windows Domain Account [Domain\login] is not 
associated with a Cisco Unity subscriber.

Explanation When this message appears during a logon attempt to the Cisco Unity Administrator, an 
invalid user name or password is being used.

Recommended Action Confirm the user name and password.
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Error Message Additional users cannot be assigned to the class of service associated 
with the selected subscriber template. You have reached the license limit for one 
or more of the features enabled by the class of service.

Explanation Class of service can be used to restrict which licensed features are available to 
subscribers. If all available licenses for a feature are in use by a class of service, no new subscribers 
can be added to that class of service.

Recommended Action Go to the Subscribers > Class of Service > Features page for the class of service 
associated with the subscriber template. Determine if any of the licensed features used by that class 
of service are out of licenses, and if so, obtain sufficient additional licenses to meet subscriber needs. 
As a temporary measure until additional licenses are available, you can change the class of service 
associated with the selected subscriber template.

Error Message Failed to perform fetch against AvXml.dll. Check AvXml virtual 
directory settings in IIS for proper permissions and execute access. See the 
Troubleshooting Guide for details.

Explanation This error may appear when accessing the Status Monitor page.

Recommended Action Do the procedure, To set up access to the Status Monitor after an upgrade, page 
9-5.

Error Message This page cannot be displayed. HTTP 403.1 Forbidden execute access 
forbidden.

Explanation This error may appear when Status Monitor access is attempted for the first time after an 
upgrade.

Recommended Action Do the procedure, To set up access to the Status Monitor after an upgrade, page 
9-5.

To set up access to the Status Monitor after an upgrade

Step 1 On the Windows Start menu, click Programs > Administrative Tools > Internet Services Manager.

Step 2 Click the Default Web Site folder, then locate the Status folder.

Step 3 Right-click the Status folder and go to Properties.

Step 4 Click the Virtual Directory tab.

Step 5 Set Execute Permissions to Scripts Only.

Step 6 Click OK.
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E-mail and Voice Error Messages
By default, Cisco Unity sends e-mail to the System Event Messages public distribution list when certain 
critical errors occur. Cisco Unity administrators can use the Event Notification utility to send e-mail 
and/or voice mail to other subscribers or distribution lists when an error occurs. Cisco Unity 
administrators or subscribers may see the following error messages:

Error Message A conversation error has occurred.

Explanation A conversation error has occurred, sending a caller to the fail safe conversation.

Recommended Action Refer to the Windows Application Event log for more information about the 
error. If you are unable to determine the source of the problem from the information in the 
Application Event log, contact Cisco TAC.

Error Message Account locked—logon attempt limit reached.

Explanation An account is locked because the limit of unsuccessful phone logon attempts was 
reached.

Recommended Action Go to the Subscribers > Subscribers > Account page for the subscriber, and 
uncheck the Cisco Unity Account Status box to unlock the account. You can also refer to the 
Windows Application Event log for more information about the error.

Error Message All Ports Busy notification.

Explanation The voice server detected that all ports that are set to answer calls are busy. In this 
circumstance, incoming calls receive a busy signal and subscribers are unable to access the 
Cisco Unity conversation.

Recommended Action Generate a port usage report for the ports set to answer calls. 

If the percentage of ports used exceeds 70 percent usage during peak periods, determine if additional 
answer ports are required, or if other adjustments to the port settings are needed. For more 
information, see the “Voice Messaging Port Settings” section in the “System Settings” chapter of 
the Cisco Unity System Administration Guide. The Cisco Unity System Administration Guide is 
available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_
list.html.

Error Message One or more Exchange servers in the site are unavailable.

Explanation The Cisco Unity server detected that one or more Exchange servers are unavailable.

Recommended Action Restart the Exchange server(s), and refer to the Windows Application Event log 
for more information about the error.
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Error Message Possible phone system integration failure.

Explanation The Cisco Unity server received an inbound call with no phone system integration 
information.

Recommended Action Refer to the Windows Application Event log for more information. If you are 
unable to determine the source of the problem from the information in the Application Event log, 
contact Cisco TAC.

Error Message System event notification.

Explanation Notification of a system event was attempted, but the notification text or voice message 
is missing or corrupt.

Recommended Action Refer to the Windows Application Event log for more information, and review 
the notification message settings for the Event Notification utility. If you are unable to determine the 
source of the problem from the information in the Application Event log, contact Cisco TAC.

Error Message That e-mail cannot be played at this time.

Explanation All of the licensed text-to-speech resources are in use.

Recommended Action Subscribers can try again later, or you may need to add more licenses.

Error Message Voice server hard disk almost full.

Explanation The Cisco Unity server hard disk is almost full. System logging and report data 
generation are terminated to conserve space.

Recommended Action Reclaim space on the hard disk to avoid potential loss of new messages and to 
resume logging and report generation. The Example Administrator account, which Cisco Unity 
creates during installation, serves as a default message recipient for the Unaddressed Messages and 
System Event Messages distribution lists. If you have not assigned another subscriber to these 
distribution lists, be sure to monitor the Example Administrator account and forward or delete the 
messages sent to this account as appropriate. For subscribers on the Unaddressed Messages public 
distribution list, create a separate Inbox folder for returned messages. Then create a rule that 
automatically moves messages sent by the Cisco Unity Messaging System account from the Inbox to 
the returned messages folder.

Caution Do not delete the Example Administrator unless you have assigned another subscriber to the 
Unaddressed Messages and System Event Messages distribution lists. Following Cisco Unity 
installation, the only member of these distribution lists by default is the Example Administrator. If these 
distribution lists contain no members, messages sent to them will be lost.
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Error Message Voice server restart.

Explanation The Cisco Unity server stopped responding and was restarted.

Recommended Action Refer to the Windows Application Event log for more information about the 
error. If you are unable to determine the source of the problem from the information in the 
Application Event log, contact Cisco TAC.
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Third-Party Fax Integration

About Problems With a Third-Party Fax Integration
Problems and troubleshooting procedures specific to a fax integration are described in this section.

A Subscriber Cannot Send or Receive Faxes

To verify the subscriber fax settings

Step 1 In the Cisco Unity Administrator, go to the Subscribers > Subscribers > Profile page for the 
subscriber.

Step 2 Click View.

Step 3 Confirm that the features for the class of service include FaxMail.

Step 4 Confirm that the subscriber is listed as a fax user in the fax server database.

If the subscriber is in a class of service with access to FaxMail and is listed as a fax user in the fax server 
database, and still is unable to send or receive faxes, contact the Cisco Technical Assistance Center 
(TAC).

A Subscriber Cannot Send an E-Mail Attachment as a Fax

Cisco Unity sends only those attached files that have .txt, .tif, or .dcx file name extensions.

A Subscriber Fax Did Not Arrive at the Destination

To research an outbound fax problem

Step 1 Verify the fax phone number. Ask the subscriber to resend the fax to confirm that the problem was not 
with the receiving station or with an incorrect fax phone number.

Step 2 In the fax server administration program, look for the fax in the outbound queue.

If the fax is there, continue with Step 3.

If the fax is not there, verify the configuration of the Exchange gateway, make changes as necessary, and 
resend the fax. If the fax still is not in the queue, contact Cisco TAC.
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Step 3 Confirm that the fax server is configured correctly for the fax card(s) that are installed.

If the server is not configured correctly, make changes as necessary and resend the fax.

If the server is configured correctly, then the problem is most likely with the fax card(s). Contact 
Cisco TAC.

Related section

• The “Overview: Fax Server Integration” section in the “Integrating a Fax Server with Cisco Unity” 
chapter of the Cisco Unity System Administration Guide. The Cisco Unity System Administration 
Guide is available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_
list.html.
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Utilities

Tools Depot
Tools Depot allows access to most Cisco Unity tools from a single location. The Cisco Unity Tools 
Depot icon is available on the Cisco Unity server desktop.

The left pane of the Tools Depot window lists all available tools by category. To display online Help for 
a tool, click the name in the left pane. To run the tool, double-click the name.

Some tools work only with selected versions of Cisco Unity. If a tool does not appear in the Tools Depot, 
it does not work with the version of Cisco Unity currently running.

For more information on the following tools, see the related sections.

Integration Monitor
The Integration Monitor shows the information being sent between the phone system and Cisco Unity. 
Each packet of data contains information on one call that the phone system forwards to Cisco Unity. In 
some cases, seeing this data can help you diagnose integration problems.

With a serial integration, you can view the packets of data that are sent over the serial link. The 
Integration Monitor also displays the packets that Cisco Unity sends to the phone system, each of which 
contains one MWI on or off code.

The Integration Monitor Shows the information being sent between the phone system and Cisco Unity. 
See the “Integration Monitor” section on page 11-1.

Learn Tones Learns the frequency and cadence of the phone system tones and updates the 
phone system template file. See the “Learn Tones” section on page 11-5.

The Call Viewer Displays information about each call that the phone system integration sends 
to Cisco Unity. See the “Call Viewer” section on page 11-10.

The Cisco Unity 
Diagnostic Tool

Contains a database of possible Cisco Unity problems and controls the 
gathering of diagnostic traces used to troubleshoot these problems. See the 
“Cisco Unity Diagnostic Tool” section on page 11-10.

Advanced Settings Tool Allows updating of hidden registry settings and addition of new registry keys. 
See the “Advanced Settings Tool” section on page 11-12.

The Universal Dialogic 
Diagnostics utility 

Performs a wide range of tests on the Dialogic voice cards. See the “Universal 
Dialogic Diagnostics Utility” section on page 11-14.
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With an DTMF (analog) integration, you can view the packets sent over the analog phone lines that 
connect the phone system and Cisco Unity.

When troubleshooting IP integrations (such as Cisco CallManager or SIP), use the Call Viewer. The 
Cisco Unity Integration Monitor is not compatible with IP integrations. See the “Call Viewer” section 
on page 11-10 for more information.

To run the Integration Monitor

Step 1 Cisco Unity must be running for the Integration Monitor to display the packets being passed to and from 
the Cisco Unity server. If Cisco Unity is not running, start it.

Step 2 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 3 In the left pane of the Tools Depot window, in the Switch Integration Tools directory, double-click 
Integration Monitor.

Step 4 Use the View menu to select display options. For more information, see the “Integration Monitor Display 
Options” section on page 11-3.

Values Displayed in the Integration Monitor
For information on the values and menu options that appear in the Integration Monitor, see Table 11-1.

 
Table 11-1 Integration Monitor Fields and Columns

Field/Column Meaning

Analog Integration or 
Serial Integration

Immediately below the menu bar, the Integration Monitor displays the name of the current integration 
and the integration type.

First Digit Delay (ms)

(DTMF or analog 
integrations only)

The amount of time that Cisco Unity waits (in milliseconds) for the first digit of a packet to arrive 
after Cisco Unity answers a call. For example, to specify that the Integration Monitor wait three 
seconds for the first digit to arrive, enter 3000.

If you change this value, you are changing the value in the Cisco Unity phone system template file 
for the current integration. Changing this value may cause Cisco Unity to work incorrectly.

Next Digit Delay (ms)

(DTMF or analog 
integrations only)

The amount of time that Cisco Unity waits between digits for the next digit of a packet to arrive. If 
the next digit does not arrive within that amount of time, Cisco Unity considers the next digit user 
input, and the Integration Monitor displays the digit on a new line (only when the Include digits 
option and Hang-up packet are defined). For example, to specify that the Integration Monitor wait 
two-tenths of a second for the next digit to arrive, enter 200.

If you change this value, you are changing the value in the Cisco Unity phone system template file 
for the current integration. Changing this value may cause Cisco Unity to work incorrectly.

Time The time at which Cisco Unity received the call from the phone system or the time at which 
Cisco Unity sent an MWI on or off code to the phone system. New packets appear at the top of the 
Integration Events list.

Packet The unformatted information that the phone system sent to Cisco Unity or that Cisco Unity sent to 
the phone system. The Integration Monitor uses the phone system template file to parse the contents 
of the packet into the values in the remaining columns.

Port The voice card port on the Cisco Unity server on which a call arrives from the phone system.
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Integration Monitor Display Options
The menus in the Integration Monitor allow you to save data to a file and change the display in a variety 
of ways, as described in Table 11-2.

Table 11-2 Integration Monitor Options

Menu Option Description

File Log to file To specify a file for saving Integration Monitor data.

Edit Allow delay edits

(DTMF or analog 
integrations only)

To change the values in the First Digit Delay (ms) and Next Digit Delay (ms) fields. 
If this option is not selected, the values are display only. For more information, see 
First Digit Delay (ms) and Next Digit Delay (ms) in Table 11-1.

View Always on top To display the Integration Monitor window in front of all other windows regardless of 
which window is currently active.

To cancel the option, click it again.

View Include digits

(DTMF or analog 
integrations only)

To display individual digits that are not recognized as part of a packet. For more 
information, see Next Digit Delay (ms) in Table 11-1.

View Freeze display To prevent new data packets from being displayed in the Integration Monitor window. 
If Cisco Unity is busy, this option can be useful for analyzing an individual packet. 
Freezing the display prevents the packet from scrolling out of the window before you 
can look at it.

To unfreeze the display, click the option again.

View Raw serial data

(serial integrations only)

To display data from the phone system or from Cisco Unity regardless of whether the 
Integration Monitor recognizes the data as a valid packet. If no data is displayed in 
the Integration Monitor but you think it should be, try this option. There may be no 
display because the Integration Monitor is unable to determine what the pieces of the 
packets are.

To return to displaying formatted packets, click the option again.

View Outgoing data

(serial integrations only)

To display only the packets that Cisco Unity is sending to the phone system to turn 
MWIs on and off.

To return to displaying all packets, click the option again.

View Incoming data only

(serial integrations only)

To display only the packets that the phone system is sending to Cisco Unity, 
including:

• Calls forwarded to Cisco Unity because the extension is busy.

• Calls forwarded to Cisco Unity because the extension is not answered.

• Calls forwarded to Cisco Unity because the extension is in do not disturb mode.

• Calls from subscribers who want to check or leave voice messages.

• Calls from external callers who called Cisco Unity.

To return to displaying all packets, click the option again.
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Frequently Asked Questions About the Integration Monitor

Integration Monitor Troubleshooting

To resolve a situation where no integration information is displayed for a serial or DTMF integration

Step 1 In the View menu, confirm that Freeze Display is not selected. If it is selected, deselect it.

Step 2 On the Cisco Unity server, browse to the CommServer\Utilities\Utim directory and double-click 
Utim.exe. The Cisco Unity Telephony Integration Manager (UTIM) appears.

Step 3 Confirm that the settings match those indicated in the integration guide for your phone system.

Step 4 Correct any incorrect values.

Step 5 If you changed values in Step 4, click Save, and continue with Step 6. If you did not change any values, 
skip to Step 7.

Step 6 If prompted, restart the Cisco Unity server.

Step 7 If you have a serial integration, confirm that the serial cable is plugged securely into the correct 
Cisco Unity COM port and into the phone system serial port.

If none of the steps in this procedure correct the problem, contact the Cisco Technical Assistance Center 
(TAC).

To resolve a situation where only partial packets appear (DTMF or analog integrations only)

Step 1 On the Integration Monitor Edit menu, click Allow Delay Edits.

Step 2 Increase the values in the First Digit Delay (ms) and Next Digit Delay (ms) fields. For example, if the 
First Digit Delay (ms) field is set to 2000, change it to 3000. And if the Next Digit Delay (ms) field is 
set to 250, change it to 500.

Step 3 On the Integration Monitor Edit menu, click Allow Delay Edits again to save the changes.

Question Answer

Can I freeze the display? Yes. From the View menu, click Freeze Display.

Can I view raw serial data? Yes. From the View menu, click Raw Serial Data.

Can I view DTMF digits 
(analog only) separately from 
the packets?

Yes. From the View menu, click Include Digits, and confirm that the 
Hang-up packet is defined. This view lets you see all packets and all 
other DTMF digits detected by Cisco Unity and can be helpful in 
troubleshooting DTMF integration packet problems.

Can I log the integration 
packets in the Integration 
Monitor to a file?

Yes. From the File menu, click Log to File. Specify name and location 
of the file to receive the integration packet information.

Can the Integration Monitor 
be used with all integrations?

No. The Integration Monitor can be used only for serial and DTMF 
(analog) integrations. For IP integrations (such as Cisco CallManager 
and SIP), use the Call Viewer. See the “Call Viewer” section on 
page 11-10 for more information.
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Step 4 If partial packets still appear, contact Cisco TAC for assistance in changing the OffHook delay 
parameter.

Learn Tones
Cisco Unity comes with template files for a variety of phone systems. These template files usually work 
without modification. However, problems with transfers, message waiting indicators (MWIs), and 
message notification can arise if Cisco Unity does not understand the phone system tones. If any of these 
problems occur, and basic troubleshooting procedures do not correct the problem, run the Learn Tones 
utility to modify the phone system template file.

The Learn Tones utility is designed to run on systems equipped with Dialogic analog voice cards only. 
The Learn Tones utility also requires exclusive access to the ports. Do not run Learn Tones unless 
Cisco Unity is shut down.

The Learn Tones utility learns the frequency and cadence of the phone system tones, such as busy and 
ringback, and teaches them to Cisco Unity. Once you start the utility, the process is automatic. One voice 
messaging port calls other ports to generate the tones. The utility displays the tone settings already 
present in the phone system template file on start-up, and sets any missing items to the default values. 
Upon completion, it adds the learned tones of your choice to the phone system template file.

Tones Defined in the Switch Configuration File
There are five different tones that can be defined in the Cisco Unity switch configuration file. These can 
be split into two categories. The first category is tones that are used during call progress. Cisco Unity 
listens for these tones when performing a transfer or making an outgoing call, but does not listen for 
these tones during the voice mail conversation or during recording. These tones are:

• Switch Dial Tone

• Switch Ringback Tone

• Switch Busy Tone

The other two tones are disconnect tones. Cisco Unity always listens for these tones during voice 
messaging conversation and during recording. If one of these tones is detected, it tells Cisco Unity that 
the caller has hung up, and Cisco Unity goes on hook. These tones are:

• Switch Disconnect Tone

• CO Disconnect Tone

There are usually no tone definitions in the switch configuration file when the Cisco Unity system is 
installed. Depending on the phone system and integration being used, it is often unnecessary to define 
any tones in the switch configuration file. Cisco Unity uses a default set of definitions for tones that are 
not defined in the switch configuration file, and this default set usually works. When it is determined 
that a particular tone (or tones) must be defined in the switch configuration file, it is best to define only 
that tone. Defining tones that are not necessary for Cisco Unity to perform properly with a particular 
phone system can limit the ability of the voice messaging system to handle unexpected tones, such as 
unexpected disconnect tones sent from a PSTN.

Learning tones may resolve the problem when callers report being disconnected (hung up on) while they 
are recording a voice message. The default disconnect tone definitions in Cisco Unity have very large 
frequency and cadence deviations defined. While this allows the system to detect disconnect tones from 
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a wide range of central offices, phone systems, countries, and so on, it also increases the chance that the 
voice of a caller will mistakenly be detected as disconnect tone, causing the voice messaging system to 
hang up on the call. Learning the disconnect tones specific to the phone system in use can remedy this 
problem. Once the tone definition is in the switch configuration file, the deviations can be manually 
edited if fine tuning is desired.

Switch Configuration File Location
The switch configuration.ini files are located in the \CommServer\Intlib folder on the Cisco Unity server. 
The active switch configuration file is based on the selections made in the UTIM during Cisco Unity 
installation, or by any subsequent changes made in the Edit Switch utility.

Running the Learn Tones Utility
Do the following procedure to run the Learn Tones utility.

To run the Learn Tones utility (on systems equipped with Dialogic analog cards only)

Step 1 Shut down the Cisco Unity software.

Step 2 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 3 In the left pane of the Tools Depot window, in the Switch Integration Tools directory, double-click Learn 
Tones.

Step 4 Confirm that all ports and extensions are correct. Do not use a hunt group for the helper extension.

Step 5 Choose Manual mode or allow Learn Tones to run in Automatic (default) mode.

Both modes use port 1 as the primary learning port, and Automatic mode uses ports 2 and 3 as helper 
ports. Or, you can designate other helper ports by entering their port numbers and extensions. Extension 
numbers for ports 1, 2, and 3 are imported automatically from the Cisco Unity Administrator Ports page.

Use Manual mode when you want the primary port to call a specific extension rather than a helper port, 
or when some aspect of the phone system programming, such as forwarding when a line is busy, conflicts 
with the tone-learning process. The phone specified for Manual mode should be close to the Cisco Unity 
server, so that you can see the on-screen prompts and operate the phone at the same time. To run in 
Manual mode, check the Manual Mode check box under Settings, and enter the extension of the phone 
you want to use in the Manual Ext field.

Step 6 Confirm that the Delay Between Calls field is set to the default value of 4000 ms. Delay between calls 
is the number of milliseconds that Learn Tones delays before making a subsequent call to learn or verify 
a tone.

Step 7 Confirm that the Deviation Threshold field is set to the default value of 15 percent. The Deviation 
Threshold field sets the deviation that is considered acceptable when learning individual tones. Tones 
outside the Deviation Threshold field setting for any single field (frequency 1, frequency 2, on, off, and 
so on) are discarded.

Step 8 Confirm that the Calls field is set to the default value of 1.

Step 9 Confirm that the Frames field is set to the default value of 5.

Step 10 Confirm that the Delay(ms) field is set to the default value of 1500ms. The Delay field sets the amount 
of time between the completion of the action to cause a tone, and the beginning of learning the tone. The 
delay value avoids detection of stray events on the line during line state transitions.
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Step 11 To learn dial tone, in the Dialtone section, click Learn. In Automatic mode, Learn Tones uses the 
following process to learn dial tone:

a. Goes off-hook on port 1.

b. Waits the number of milliseconds defined in the Delay field for dial tone.

c. Listens to and learns the tone on port 1.

d. Goes on-hook on port 1.

e. Waits the number of milliseconds defined in the Delay Between Calls field.

f. Listens to and verifies the tone on port 1.

g. Goes on-hook on port 1.

If a “Success” message appears at the conclusion of this process, continue with Step 12.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 12 To learn busy tones, in the Busy section, click Learn. In Automatic mode, Learn Tones follows this 
process to learn busy tone:

a. Goes off-hook on port 2.

b. Dials port 3 extension.

c. Goes off-hook on port 3 to answer the call from port 2.

d. Goes off-hook on port 1.

e. Dials port 2 extension.

f. Waits the number of milliseconds defined in the Delay field for busy tone.

g. Listens to and learns the tone on port 1.

h. Goes on-hook on ports 1, 2, and 3.

i. Waits the number of milliseconds defined in the Delay Between Calls field.

j. Goes off-hook on port 2.

k. Dials port 3 extension.

l. Goes off-hook on port 3 to answer the call from port 2.

m. Goes off-hook on port 1.

n. Dials the extension of port 2.

o. Listens to and verifies the tone on port 1.

p. Goes on-hook on ports 1,2 and 3.

If a “Success” message appears, continue with Step 13.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 13 To learn the phone system disconnect tone, in the Disconnect section, click Learn. In Automatic mode, 
Learn Tones follows this process to learn disconnect tone:

a. Waits the amount of milliseconds defined in the Delay Between Calls field.

b. Goes off-hook on port 1.

c. Dials port 2 extension.

d. Goes off-hook on port 2 to answer the call from port 1.

e. Delays for 2000ms (2 seconds).
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f. Goes on-hook on port 2.

g. Waits the amount of milliseconds defined in the Delay field for disconnect tone.

h. Listens to and learns the tone on port 1.

i. Goes on-hook on port 1.

j. Waits the amount of milliseconds defined in the Delay Between Calls field.

k. Goes off-hook on port 1.

l. Dials port 2 extension.

m. Goes off-hook on port 2 to answer the call from port 1.

n. Delays for 2000ms (2 seconds).

o. Goes on-hook on port 2.

p. Listens to and verifies the tone on port 1.

q. Goes on-hook on port 1.

If a “Success” message appears, continue with Step 14.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 14 To learn CO Disconnect tone, in the CO Disconnect section, click Learn. In Automatic mode, Learn 
Tones uses the following steps to learn CO disconnect tone:

a. Goes off hook on port 1.

b. Dials 9.

c. Waits the amount of milliseconds defined in the Delay field for CO Disconnect tone.

d. Listens to and learns the tone on port 1.

e. Goes on-hook on port 1.

f. Waits the amount of milliseconds defined in the Delay Between Calls field.

g. Goes off-hook on port 1.

h. Dials 9.

i. Listens to and verifies the tone on port 1.

j. Goes on hook on port 1.

If a “Success” message appears, continue with Step 15.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 15 To learn ringback tone, in the Ringback section, click Learn. In Automatic mode, Learn Tones uses the 
following steps to learn ringback tone:

a. Goes off-hook on port 1.

b. Dials the extension of port 2.

c. Waits the amount of milliseconds defined in the Delay field for ringback tone.

d. Listens to and learns the tone on port 1.

e. Goes on hook on port 1.

f. Waits the amount of milliseconds defined in the Delay Between Calls field.

g. Goes off-hook on port 1.

h. Dials the extension of port 2.
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i. Listens to and verifies the tone on port 1.

j. Goes on hook on port 1.

If a “Success” message appears, continue with Step 16.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 16 The Learn Tones utility automatically verifies tones after it learns them, so there is no need to click the 
Verify All button before saving the learned tones.

Step 17 Click Save.

Step 18 In the dialog box that appears, check only the boxes of the tones you want to update in the switch 
configuration file, then click OK.

Step 19 To save the new tones directly to the active switch configuration file, accept the default file name. If you 
want to save the tones to a temporary file for comparison and then manually copy them to the switch 
configuration file at a later time, enter a file name of your choice. Click Open.

Step 20 Click Done to exit the Learn Tones utility.

Step 21 Restart the Cisco Unity software.

Troubleshooting the Learn Tones Utility
If the learn tones process fails, do one or more of the following actions:

• Adjust the setting in the Delay field for the tone that you are having trouble with. 1500 to 2000 
milliseconds is usually sufficient. Be careful not to make this delay too long as Learn Tones may fail 
to learn a tone, learn the wrong tone, or miss the tone altogether.

• If Automatic mode is not working, try Manual mode, or vice versa.

• Unplug the line cord from port 1 of Cisco Unity and plug it into an analog phone. Use the same steps 
that the Learn Tones utility uses to manually recreate the condition that Learn Tones is listening to.

• If one or more tones are learned with the following cadence.

the learned tone is continuous. When a tone with continuous cadence is saved to the switch 
configuration file, the cadence appears as:

TimeOn1=4000
TimeOnDeviation1=0
TimeOff1=0
TimeOffDeviation1=0
Cycles=0

This is intentional. To support voice card manufacturers other than Dialogic, the latter method must 
be used when defining a continuous tone in the switch configuration file. When Cisco Unity is 
restarted, the Miu translates the cadence back to the original settings if Dialogic cards are installed.

• If you need assistance resolving these or other Learn Tones problems, contact Cisco TAC.

On(ms) Dev Off(ms) Dev

2000 –2000 0 0
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Call Viewer
For each call that the phone system integration sends to Cisco Unity, the Call Viewer displays one line 
of information. This information can be helpful when troubleshooting problems with the phone system 
integration, as well as testing call routing rules.

The Call Viewer displays integration information for inbound calls only. To see call information for 
outbound calls, use the StatusMonitor, located in the Tech Tools directory.

Note that if you are troubleshooting a Cisco CallManager integration, you must use the Call Viewer; the 
Cisco Unity Integration Monitor is not compatible with a Cisco CallManager integration.

To run the Call Viewer

Step 1 If Cisco Unity is not running, start it.

Step 2 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 3 In the left pane of the Tools Depot window, in the Switch Integration Tools directory, double-click Call 
Viewer.

Step 4 Use the Call Viewer window to see call information that the phone system integration provides to 
Cisco Unity for inbound calls.

Cisco Unity Diagnostic Tool
The Cisco Unity Diagnostic Tool allows creating and viewing of diagnostic log files to troubleshoot 
problems. It replaces the diagnostic log functionality in Maestro Tools, and allows the system 
administrator or TAC staff to selectively run diagnostic traces at two levels:

• Macro Traces—These are collections of component traces that help diagnose problems such as 
message waiting indicator and system problems.

• Micro Traces—These are the component traces. Each component has up to 32 trace levels that can 
be individually selected.

The Cisco Unity Diagnostic Tool also allows the system administrator or TAC staff to perform the 
following tasks:

• Create new log files on demand. This makes troubleshooting problems easier. When a problem can 
be reproduced reliably, the system administrator can close all existing log files and create new log 
files prior to reproducing the problem. This eliminates many unnecessary and unrelated items from 
the logs.

• Configure log settings. The system administrator can adjust the maximum disk space allowed for all 
diagnostic log files. (The default setting is 400 MB.) The Logging Properties screen also allows the 
system administrator to disable all diagnostic output by clearing the Diagnostic Output check box.

• Gather standard logs. This option provides the ability to quickly gather all or selected Microsoft 
Windows and Cisco Unity logs.

• Disable all traces. This is a quick way to return diagnostic logs to their default settings after 
troubleshooting efforts are complete.

• View the Event log. The Event log files for either the local computer or another computer can be 
viewed and exported.
11-10
Cisco Unity Troubleshooting Guide (With Microsoft Exchange)

OL-3102-01



Chapter 11 Utilities
Cisco Unity Diagnostic Tool
• Change the display language for Windows Event log messages that are generated by Cisco Unity. 
This is a temporary change and is only in effect while the Cisco Unity Diagnostic Tool is running.

To view and export diagnostic files by using the Cisco Unity Diagnostic Tool

Step 1 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane of the Tools Depot window, in the Diagnostic Tools directory, double-click Unity 
Diagnostic Tool.

Step 3 On the left pane of the Cisco Unity Diagnostic Viewer screen, click Processes. The node expands to list 
each process that uses log manager.

Step 4 Click a process node and then click a log file. The selected log file is formatted and displayed in the right 
pane.

Step 5 To export or save a copy of the log file, click Action > Export List.

Step 6 Name the file and save it to a location of your choice in .txt or .csv format.

To create macro or micro diagnostic traces for troubleshooting

Step 1 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane of the Tools Depot window, in the Diagnostic Tools directory, double-click Unity 
Diagnostic Tool.

Step 3 On the Cisco Unity Diagnostic Viewer screen, click either the Configure Macro Traces icon, or the 
Configure Micro Traces icon, as applicable.

Step 4 Follow the wizard on-screen instructions.

Step 5 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 6 Reproduce the problem.

Step 7 View and export the results by doing the procedure, To view and export diagnostic files by using the 
Cisco Unity Diagnostic Tool, page 11-11.

Step 8 On the Cisco Unity Diagnostic Viewer screen, click the Disable All Traces icon to turn off the traces set 
in Step 3.

Step 9 In the Disable All Traces Wizard screen, check the Disable All Traces check box, and click Finish.

To access the Event Viewer on another computer

Step 1 In the left pane of the Cisco Unity Diagnostic Tool window, right-click Event Viewer (Local).

Step 2 Click Connect to Another Computer.

Step 3 Browse to select a computer from the list.

Step 4 Click OK.

Step 5 Select and view the log file.

Step 6 To export or save a copy of the log file, click Action > Export List. 
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Step 7 Name the file and save it to a location of your choice in .txt or .csv format.

To change the Windows Event log display language for Cisco Unity-generated messages

Step 1 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane of the Tools Depot window, in the Diagnostic Tools directory, double-click Unity 
Diagnostic Tool.

Step 3 In the left pane of the Cisco Unity Diagnostic Tool, click Cisco Unity Diagnostic Tool > Processes. The 
node expands to list each process that uses log manager.

Step 4 Right-click Processes or the individual process node of your choice.

Step 5 Click Change Cisco Unity Event Log Language.

Step 6 Click a new language from the list of available languages.

Step 7 Click Apply, then click OK.

Step 8 In the left pane of the Cisco Unity Diagnostic Tool, click Event Viewer (Local), and then click the log 
file category you wish to view.

When the Cisco Unity Diagnostic Tool is closed, Cisco Unity Event log messages revert to the original 
language.

Advanced Settings Tool
The Advanced Settings Tool allows system administrators to safely edit many of the Cisco Unity hidden 
registry settings. It gives a brief overview of each setting, limits edits to specific value ranges, and 
ensures that edits are consistent with the installed Cisco Unity version.

Note A typical backup of the Cisco Unity server does not back up the registry. Also note that for Cisco Unity 
failover, registry changes on one Cisco Unity server must be made manually on the other Cisco Unity 
server, because registry changes are not replicated.

To edit an existing registry key

Step 1 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane, under Administrative Tools, double-click Advanced Settings Tool.

Step 3 In the Unity Settings pane, click the key name.

Step 4 In the New Value box or list, click or enter the appropriate value, then click Set.

Step 5 When prompted, click OK.

Step 6 Click Exit.

Step 7 If applicable, restart the Cisco Unity server for the registry change to take effect.
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To add a new registry key

Adding a new registry key to the database should be done only when indicated in the Cisco Unity 
documentation, or on the advice of Cisco TAC. Note that the add function can also be used to display 
information about existing registry settings.

Step 1 Open a command prompt window, and browse to the CommServer\Utilities\Advanced Settings Tool 
directory.

Step 2 Enter start unityadvancedsettingstool /addkey and press Enter. The Unity Advanced Settings page 
appears.

Step 3 On the Unity Advanced Settings page, click Add New Key.

Step 4 On the Add New Registry Key page, click Add New. Enter information in the following fields as 
applicable.

 

Field Name Description

Index Display only. A read-only field that displays a unique number for each record 
in the database.

Short Description Enter a description of the registry key change (maximum of 250 characters).

Long Description Enter a description of the behavior change that the registry key invokes.

Key Path Enter the path to the directory where the key is stored. All values are assumed 
to be under HKEY_LOCAL_MACHINE.

If you need to set values outside of this registry branch, do not use this tool. Use 
Regedit instead.

Key Name Enter the name of the registry at the key path. In the rare case of a registry 
setting that is only the key path and not a key value, you can leave this field 
blank.

Key Type Select a value from the drop down list, as follows:

• REG_SZ—string values.

• REG_DWORD—number values.

• REG_BINARY—binary values (not used).

• NONE—for cases where the presence of the key path is all that is needed, 
rather than a key with a value. This value should be used rarely, if at all.

Minimum Value Enter the minimum allowable value, if the key type is a number. String values 
do not use this field.

Maximum Value Enter the maximum allowable value, if the key type is a number. String values 
do not use this field.

Step By Enter the step for each value added to the drop down list, if the key type is a 
number. For example, if the minimum value is 0, and the maximum value is 
100, a step by value of 20 will populate the drop down list with 0, 20, 40, 60, 
80, 100.

Minimum Unity 
Version

A list of all Cisco Unity versions 2.3 and later. Indicate if the registry key is not 
valid for versions earlier than a specified version.

Maximum Unity 
Version

A list of all Cisco Unity versions 2.3 and later. Indicate if the registry key is not 
valid for versions later than a specified version.
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Step 5 Click Save, and then click OK.

Step 6 Click Exit.

Universal Dialogic Diagnostics Utility
The Universal Dialogic Diagnostics (UDD) utility performs a wide range of tests on the Dialogic voice 
cards. It is used to determine if something is wrong with one or more of the Dialogic voice cards in the 
Cisco Unity server.

To run the UDD utility

Step 1 On the Windows Start menu, click Programs > Dialogic System Software > Universal Dialogic 
Diagnostics Utility.

Step 2 On the Service menu, click Stop Service.

Step 3 The UDD utility may display several warning or error messages. For each, choose the option that 
continues the process of starting the utility.

Step 4 Select the options required to perform all tests on all voice cards. The tests take approximately five 
minutes per voice card.

Step 5 When the tests are finished, the Done button becomes available. Click Done to display additional 
information on failed tests, if any.

Step 6 If you see errors that you do not know how to resolve, contact Cisco TAC.

Step 7 When you are finished reviewing test results, click Exit UDD.

Step 8 Shut down and restart the Cisco Unity server.

Status Monitor
Cisco Unity has two Status Monitors: the web-based Status Monitor that is described in the Cisco Unity 
System Administration Guide, and StatusMonitor.exe located in the Switch Integration Tools directory 
of Tools Depot. 

Both are useful as troubleshooting tools; however, the web-based Status Monitor is not intended to be 
run for long periods of time due to the significant amount of system resources it utilizes. The web-based 
Status Monitor automatically times out after 20 minutes of use while the StatusMonitor.exe does not 
adversely impact system performance and can be run for as long as necessary to monitor call activity 
and troubleshoot a problem.

StatusMonitor.exe is useful for testing and troubleshooting integration issues with a Cisco CallManager 
integration, including call handlers, conversations, message waiting indicators, and notification calls. It 
displays information for both inbound and outbound calls, and can work remotely with Windows 
Terminal Services. 
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To use StatusMonitor.exe

Step 1 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane of the Tools Depot window, in the Switch Integration Tools directory, double-click 
Status Monitor.

Step 3 On the Status Monitor page, choose from the following options according to your testing and 
troubleshooting needs. When a monitor is started, the state shown is controlled by the Monitor Settings 
When Started selection: Application, Display, or Conversation.

Step 4 Use the Print Screen function on the workstation or server to copy or save the displayed data for later 
reference, if needed.

Step 5 Click Cancel to close the Status Monitor window.

Window Element Function

Start Monitor Starts the monitor for the port selected in the left pane.

Start All Monitors Starts the monitor for all ports.

Stop Monitor Stops the monitor.

Stop All Monitors Stops the monitor for all ports.

Tile Monitors Sets the display format.

Cascade Monitors Sets the display format.

Monitor Settings When 
Started: Application

Shows the state of the Cisco Unity application during the monitoring session. 
States include Idle, Attempt Sign-in, Transfer, Greeting, etc.

Monitor Settings When 
Started: Display

Shows a high-level overview of activity during the monitoring session 
including Dial, MWI (with extension), Notification (with extension), etc.

Monitor Settings When 
Started: Conversation

Shows detailed events that occur during the monitoring session. Events 
include Call Handlers in use, Action by Subscribers, Greetings, DTMF, etc.

Show Port Availability Shows the registry setting (in hex.) 

Tip: use the Ports page in the Cisco Unity Administrator for this function.

Place Call Do not use. Place the test call from a nearby phone.

Show New Calls Displays the call origin and other information useful for testing routing rules. 
You can also use the Call Viewer to obtain this information.

Set MWI Do not use. To test an MWI, leave a message from a nearby phone.

Reset Port Disconnects any active calls on the selected port.

Busy Port Disables the selected port, placing it in an RNA (ring no answer) state.

Disable Port Do not use. This function is not currently available.
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Subscriber and Administrator Access

About Access Problems
Subscriber access problems are usually related to a problem with the phone system integration. 
Subscriber access problems may include:

Administrator access problems can include a missing tray icon, or missing or defaced web pages. See 
the “Cisco Unity Tray Icon Is Missing from the Status Bar” section on page 12-7, and the “Cisco Unity 
Administrator or Status Monitor Pages Cannot Be Opened or Have Been Defaced” section on page 12-7.

If you encounter a subscriber or administrator access problem that is not described in these two chapters, 
contact the Cisco Technical Assistance Center (TAC).

Problems that prevent subscribers 
from using Cisco Unity

See the following sections:

The “Subscribers Logging On to Cisco Unity Hear the Opening 
Greeting Instead of the Subscriber Conversation” section on 
page 12-2.

The “Cisco Unity Does Not Respond to Touchtones” section on 
page 12-2.

Problems that prevent subscribers 
from fully utilizing the features of 
Cisco Unity and the phone system

See the following sections:

The “Subscribers Cannot Use ViewMail for Microsoft Outlook” 
section on page 12-4.

The “Subscribers Cannot Access Cisco Personal Communications 
Assistant Pages” section on page 12-5.

The “Subscribers Cannot Access Cisco Unity Assistant or 
Cisco Unity Inbox From the Cisco PCA” section on page 12-6

The “No Sounds Play on the Multimedia System After Installing the 
Cisco CallManager Software” section on page 12-6.

The “Subscribers Can Not Be Located in a New or Updated Directory 
Handler” section on page 12-6.
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Subscribers Logging On to Cisco Unity Hear the Opening 
Greeting Instead of the Subscriber Conversation

Confirm that the integration is enabled and that the phone system settings are correct.

To verify the phone system settings in the Cisco Unity Administrator

Step 1 On the Cisco Unity server, browse to the CommServer\Utilities\Utim directory and double-click 
Utim.exe. The Cisco Unity Telephony Integration Manager (UTIM) appears.

Step 2 Confirm that the settings match those indicated in the integration guide for your phone system.

Step 3 Correct any incorrect values for the phone system.

Step 4 If you changed values in Step 3, click Save.

Step 5 If prompted, restart the Cisco Unity server.

Step 6 If you have confirmed that the integration is enabled and that the phone system settings are correct, and 
subscribers still hear the opening greeting instead of the subscriber conversation, contact Cisco TAC.

Cisco Unity Does Not Respond to Touchtones
There are several possible reasons that Cisco Unity may not respond to touchtones. Use the Task List for 
Troubleshooting Problems with Touchtones to troubleshoot the possible causes.

Task List for Troubleshooting Problems with Touchtones

1. (Cisco CallManager only) Confirm that DTMF relay is enabled through VoIP dial-peer gateways. 
See the “DTMF Signal Is Not Being Sent (Cisco CallManager Only)” section on page 12-2.

2. (Circuit-switched phone systems only) Confirm that the DTMF signal is being sent. See the “DTMF 
Signal Is Not Being Sent (Circuit-Switched Phone Systems Only)” section on page 12-3.

3. (Circuit-switched phone systems only) Confirm that the DTMF values are consistent with 
Cisco Unity and the phone system. See the “DTMF Values in Cisco Unity Are Inconsistent with the 
Values in the Phone System (Circuit-Switched Phone Systems Only)” section on page 12-4.

DTMF Signal Is Not Being Sent (Cisco CallManager Only)

In certain situations, DTMF digits are not recognized when processed through VoIP dial-peer gateways. 
To avoid this problem, certain gateways must be configured to enable DTMF relay. The DTMF relay 
feature is available in Cisco IOS software version 12.0(5) and later.

Cisco IOS software-based gateways that use H.245 out-of-band signaling must be configured to enable 
DTMF relay.

The Catalyst 6000 T1/PRI and FXS gateways enable DTMF relay by default and do not need additional 
configuration to enable this feature.
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To enable DTMF relay

Step 1 On a VoIP dial-peer servicing Cisco Unity, use the following command:

dtmf-relay h245-alphanumeric

Step 2 Create a destination pattern that matches the Cisco CallManager voice mail port numbers. For example, 
if the system has voice mail ports 1001 through 1016, enter the dial-peer destination pattern 10xx.

Step 3 Repeat Step 1 and Step 2 for all remaining VoIP dial-peers servicing Cisco Unity.

DTMF Signal Is Not Being Sent (Circuit-Switched Phone Systems Only)

The first procedure in this section is used only for feature-set phones, because feature-set phones rely on 
the phone system to generate touchtones, while analog phones generate their own touchtones. For 
feature-set phones, you may need to enable touchtones on the phone system.

If you are having trouble only with the operator console, skip to the procedure, To test manual DTMF 
signaling on the operator console, page 12-3.

If you are using only analog phones to access Cisco Unity and are having trouble with response to 
touchtones, contact Cisco TAC.

To test manual DTMF signaling on feature-set phones

Do this procedure for each type of feature-set phone that you use to access Cisco Unity.

Step 1 Set up a test phone (Phone 1) for single-line testing. For more information, see the “Preparations for 
Troubleshooting the Phone System” section on page 1-1.

Step 2 On a feature-set phone that is connected to the phone system but that is not connected to Cisco Unity 
(Phone 2), call Phone 1. For Phone 2, use a phone that is the same type that subscribers use to access 
Cisco Unity.

Step 3 Answer Phone 1.

Step 4 On Phone 2, press touchtone keys.

If you hear touchtones on Phone 1, then the type of phone you are using for Phone 2 is sending DTMF 
signals to Cisco Unity. Continue with Step 5.

If you do not hear touchtones, reprogram the phone system to provide station-to-station DTMF signaling 
on that line, and repeat the test. If you still do not hear touchtones, contact the phone system vendor.

Step 5 Connect a line-monitoring device (for example, a ZiadLinemaster) to Phone 1, and test the duration and 
volume of the touchtones Phone 2 is generating. Write down the values, and contact Cisco TAC to 
determine whether touchtone durations in the phone system template file need to be changed. For 
information on setting up the line-monitoring device, see the documentation from the manufacturer.

To test manual DTMF signaling on the operator console

Step 1 Do the procedure, To test manual DTMF signaling on feature-set phones, page 12-3, but use the operator 
console for Phone 2.
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Step 2 If you hear touchtones on Phone 1, then the operator console is sending DTMF signals to Cisco Unity. 
The reason Cisco Unity is not responding to touchtones is most likely related to the Cisco Unity setup. 
Contact Cisco TAC.

If you cannot hear touchtones on Phone 1, the operator console is not generating touchtones. Add a tone 
dialer that generates DTMF tones, and repeat the test.

If you still cannot hear touchtones, contact Cisco TAC.

DTMF Values in Cisco Unity Are Inconsistent with the Values in the Phone System (Circuit-Switched 
Phone Systems Only)

To compare phone system and Cisco Unity values for DTMF duration and delay between digits

Step 1 In the phone system documentation or programming, locate the duration of DTMF tones and the delay 
between digits that the phone system expects from Cisco Unity.

Step 2 On the Cisco Unity server, on the Windows Start menu, click Programs > Cisco Unity > Edit Switch 
Utility. The Switch Configuration Editor window appears.

Caution Do not use the Edit Switch utility to change values without contacting Cisco TAC for 
assistance.

Step 3 Confirm that the phone system Cisco Unity is integrated with appears in the fields, then click Edit This 
Switch Configuration.

Step 4 In the Switch Configuration dialog box, click the Outdial tab.

Step 5 Compare values in the Dialed DTMF Duration and Delay Between Dialed DTMF Digits fields with the 
the phone system values. If the values do not match, contact Cisco TAC.

Subscribers Cannot Use ViewMail for Microsoft Outlook
Use the following procedure to repair or restore ViewMail if a problem occurs.

To repair or restore ViewMail

Step 1 From the Windows Start menu, click Settings > Control Panel > Add/Remove Programs.

Step 2 Click ViewMail from the list.

Step 3 If you are using Windows 2000 or Windows XP, click Change.

If you are using Windows 98, ME, or NT, click Add/Remove.

Step 4 Follow the onscreen instructions to complete the repair or restore process.
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Subscribers Cannot Access Cisco Personal Communications 
Assistant Pages

Subscribers use the Cisco PCA website to access the Cisco Unity Assistant and the Cisco Unity Inbox. 
(Note that in version 3.1 and earlier, the Cisco Unity Assistant was known as the ActiveAssistant, or AA; 
the Cisco Unity Inbox was known as the Visual Messaging Interface, or VMI.)

When a subscriber cannot access the Cisco Personal Communications Assistant (PCA) pages, consider 
the following possible causes:

URL is case-sensitive

Subscribers can access the Cisco PCA at the following URL: http://<Cisco Unity server>/ciscopca. 
Note, however, that the URL is case-sensitive.

Browser configuration is not correct

When a subscriber cannot access any of the Cisco PCA pages, it may be that the subscriber browser is 
not configured properly. Make sure that the subscriber browser is configured to:

• Enable Active scripting.

• Download and run ActiveX controls.

• Enable Java scripting.

• Accept all cookies.

For a list of supported versions of Cisco Unity combined with the supported versions the software on 
client workstations, see the Compatibility Matrix: Cisco Unity and the Software on Subscriber 
Workstations, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_pre_installation_guides_list.html.

Cisco Unity uses SSL but the certificate has not been distributed to the trusted root store

When Cisco Unity is set up to use SSL, the browser displays a message to alert the subscriber that the 
authenticity of the Cisco PCA site cannot be verified and therefore, its content cannot be trusted. 
Subscribers will see this message, even if they add the Cisco PCA website to their list of trusted sites for 
the browser.

To prevent the browser from displaying the security alert, you can:

• Distribute the certificate to the trusted root store for all users in the domain by adding it to the Group 
Policy. See the “Distributing the Root Certificate to the Trusted Root Store for All Users in the 
Domain (Optional)” section on page 3-6 in the “Setting Up Cisco Unity To Use SSL” chapter.

• Tell subscribers how to add the certificate to the trusted root store on their own computers. See the 
“Configuring Subscriber Browsers To Use the Cisco PCA” section on page 5-11 in the “Setting Up 
Client Applications” chapter.

Discuss the two options with your the network administrator for your organization to determine which 
is best for your site.
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Subscribers Cannot Access Cisco Unity Assistant or Cisco Unity 
Inbox From the Cisco PCA

When subscribers can access the Cisco PCA, but cannot access the Cisco Unity Assistant or the 
Cisco Unity Inbox consider the following possible causes:

• In order to access the Cisco Unity Assistant, subscribers must be given the proper class of service 
rights on the Subscribers > Class of Service > Features Page in the Cisco Unity Administrator. 

• The Cisco Unity Inbox is a licensed feature, and can be accessed only if it is purchased. In addition, 
subscribers must be given the proper class of service rights on the Subscribers > Class of Service > 
Features Page in the Cisco Unity Administrator.

Finally, note that the Media Master control bar, which appears on the Cisco Unity Assistant and 
Cisco Unity Inbox pages, is not available across a firewall.

No Sounds Play on the Multimedia System After Installing the 
Cisco CallManager Software

When a multimedia system is installed on the Cisco Unity server, registry entries for the multimedia 
system wave driver may be overwritten when you install the Cisco wave driver. If this happens, the 
multimedia system no longer plays sounds. Contact Cisco TAC.

Subscribers Can Not Be Located in a New or Updated Directory 
Handler

Subscribers or outside callers may report that they are unable to locate one or more subscribers in a 
recently created or updated directory handler. When a directory handler is scoped by a distribution list, 
the membership is synchronized from the Active Directory or Exchange 5.5 Directory into the 
Cisco Unity SQL database. Changing the distribution list by which the directory handler is scoped 
requires a synchronization. This synchronization takes place when the Cisco Unity directory services 
(AvDSAD and AvDSGlobalCatalog) poll the directory for any changes to be applied to the SQL 
database, which usually occurs within 15 to 20 minutes after the directory handler scope change is made 
in the Cisco Unity Administrator.

To initiate an immediate synchronization, do the following procedure. 

To manually synchronize the Cisco Unity database

Step 1 In the Cisco Unity Administrator, go to the System > Configuration > Settings page.

Step 2 In the Replicate Cisco Unity directory objects section, click Changed Objects.

The Settings page is refreshed and the database changes will be synchronized in the background.

Step 3 Wait a few minutes, then call in to Cisco Unity and confirm that the subscriber(s) can be located in the 
directory handler.
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Step 4 If the subscriber(s) still can not be located, confirm that they have recorded names. Subscribers must 
have recorded names to be accessed by using directory handlers.

Another way to update directory handlers is to change the membership of a distribution list by which 
one or more directory handlers are scoped. Changes made to distribution list membership by using the 
Cisco Unity Administrator are updated in the Cisco Unity database within a few minutes. However, in 
complex networked sites, the replication process may take much longer. This is a function of network 
complexity and varies from site to site. The network replication process time is not a function of 
Cisco Unity directory synchronization services, and it is not possible to reduce this time by using the 
previous procedure.

Cisco Unity Tray Icon Is Missing from the Status Bar
To manually start the Cisco Unity tray icon

Step 1 Browse to the CommServer directory.

Step 2 Run AvCsTrayStatus.exe. The tray icon will be restored.

Cisco Unity Administrator or Status Monitor Pages Cannot Be 
Opened or Have Been Defaced

Virus incidents and attacks from hackers can cause the Cisco Unity Administrator or Status Monitor 
pages to be defaced or to become unusable. You can restore these pages by doing one of the following:

• Run the Cisco Unity install again. Refer to the Cisco Unity Installation Guide for instructions (this 
guide is available on Cisco.com, at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_installation_guides_books_lis
t.html).

• Manually restore the applicable files from the Cisco Unity discs by using the following procedure.

For information on restoring defaced or unusable Cisco Personal Communications Assistant (PCA) 
pages, see the “Subscribers Cannot Access Cisco Personal Communications Assistant Pages” section on 
page 12-5.

To manually restore the Cisco Unity Administrator or Status Monitor pages

Step 1 From Cisco Unity Disc 1, copy the Web directory to the CommServer directory on the Cisco Unity 
server. In the Confirm Folder Replace window, click Yes To All.

Step 2 For US English, from Cisco Unity Disc 1, copy the Localize\Web directory to the CommServer 
directory on the Cisco Unity server. In the Confirm Folder Replace window, click Yes To All.

Step 3 For each additional language, locate the Cisco Unity disc on which the language files are stored. Repeat 
Step 2. In the Confirm Folder Replace window, click Yes To All.
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Reports

About Problems With Reports
Problems and troubleshooting procedures specific to reports are described in this chapter.

A Requested Report Was Not Generated

To research a report

Step 1 In Internet Explorer, go to http://<Cisco Unity server name>/status or double-click the desktop 
shortcut to the Status Monitor.

Step 2 In the Status Monitor page, click the Report Status icon.

Step 3 Locate the report you are waiting for in the list of submitted reports. The wait time for a queued report 
will vary depending on the size of the Exchange database and on how busy Cisco Unity and Exchange 
are.

Step 4 If wait time for the report seems excessive, do one or more of the following:

• Cancel the queued report and request it again at a time when Cisco Unity and Exchange are not as 
busy.

• Cancel the queued report, refine the selection criteria, and then submit the report again.

• On the Windows Start menu, click Programs > Administrative Tools > Services. Locate 
AVRepDirSvrSvc. If reports are not working properly or are locked, restarting this service will 
remove the locked state and the reports process will be restarted. Note that some queued reports may 
be lost due to the restart.

Step 5 If a requested report is missing from the Report Status page, this may be due to stopping and restarting 
Cisco Unity or the AvRepDirSvrSvc. Request the report again.

Step 6 If requested reports are still not being produced, on the Windows Start menu, click 
Programs > Unity > Unity Diagnostic Tool.

Step 7 On the Cisco Unity Diagnostic Viewer screen, click the Configure Micro Traces icon.

Step 8 Check the check boxes for all traces beginning with the word Report.

Step 9 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 10 Request the reports again at a time when Cisco Unity and Exchange are not busy. Wait for a time equal 
to the wait time previously experienced. If the reports print successfully, skip to Step 15. If the reports 
do not print, continue with Step 11.
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Step 11 To view the log files, click Process > AvCsMgr, and then click the Current log file. The selected log 
file is formatted and displayed in the right pane.

Step 12 To export or save a copy of the log file, click Action > Export List.

Step 13 Name the file and save it to a location of your choice in .txt or .csv format.

Step 14 If the requested reports still are not produced, and you are unable to determine the cause of the problem 
from the diagnostic logs, contact the Cisco Technical Assistance Center (TAC).

Step 15 To turn off the traces set in Step 8, on the Cisco Unity Diagnostic Viewer screen, click Disable All 
Traces.

Related section

• Refer to the “Overview: Reports” section in the “Reports” chapter of the Cisco Unity System 
Administration Guide. The Cisco Unity System Administration Guide is available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_administration_guide_books_
list.html.

Report Notification Not Generated

The Installer account has no mailbox. Therefore, if reports are requested by using the Installer account, 
no notification will be received when a report is complete. If you are using the Installer account (or 
another account that has no mailbox) to request reports, you can view the completed reports in the 
\CommServer\Reports directory.
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Cisco Unity Services

Cisco Unity Services are the top level components for the diagnostic traces that are used in 
troubleshooting. When a diagnostic trace is viewed by using the Cisco Unity Diagnostic Tool, the file 
always contains the Service in the file name immediately following the “diag_”. For example, the 
diagnostic log for the Reports Group will be diag_AvRepDirSvrSvc_YYYYMMDD_HHMMSS_.txt.

Table A-1 Cisco Unity Services

Service Function

AvCsGateway The Gateway service provides a secure interface to the Manager service. It allows external 
processes to query the state of the Manager, start or stop the Manager, or request internal 
interfaces to Manager components (if allowed).

AvCsMgr The Manager service is the core voice messaging system. It runs the CommServer platform 
components, provides status on the components, and exposes component interfaces to other 
internal and external components.

AvCsNodeMgr The Node Manager service provides the core services for failover. It runs on both the primary and 
secondary servers, and is responsible for monitoring the status of the server.

AvDirChangeWriter The Directory Change Writer service gets messages from the change queue (posted by the 
AvDSEx55, AvDSAD, and AvDSGlobalCatalog services) and writes them to the Cisco Unity 
SQL database.

AvDSAD

(Exchange 2000 systems 
only)

The Active Directory Datastore service monitors the AD for changes in Cisco Unity objects 
(users, locations, distribution lists, contacts) on domain controllers, and sends notification of the 
changes to the Change Writer service. This keeps Cisco Unity synchronized with directory 
changes made in the Cisco Unity Administrator.

AvDSEx55

(Exchange 5.5 systems 
only)

The Exchange 5.5 Datastore service monitors the database for changes in Cisco Unity objects 
(users, locations, distribution lists, contacts) and sends notification of the changes to the Change 
Writer service. This keeps Cisco Unity synchronized with directory changes made in the 
Cisco Unity Administrator.

AvDSGlobalCatalog

(Exchange 2000 systems 
only)

The Global Catalog Datastore service monitors the AD global catalog for changes in Cisco Unity 
objects (users, locations, distribution lists, contacts) and sends notification of the changes to the 
Change Writer service. This keeps Cisco Unity synchronized with directory changes made in the 
Cisco Unity Administrator.

AvGaenSvr The Event Notification utility service polls the Event log and sends e-mail and/or voice mail 
notifications according to the Event Properties set in the Event Notification Utility Administrator.

AvLic The Licensing service provides secure licensing information to Cisco Unity and authenticated 
clients. In addition, it monitors the database and provides dynamic utilization information of 
per-seat licensing features.
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Behavior of Cisco Unity Services in a Configuration with 
Exchange 5.5

Services that log on with the account that owns the Cisco Unity directory and message store services are 
listed as logging on as UnitySvc, the suggested Active Directory user logon name.

AvMMProxySvr The Media Master Proxy server provides client authentication and anonymous access to media 
and resource interfaces. Available to anyone, this service provides application-level 
authentication of clients running on any platform. After authenticating, it then exposes interfaces 
for streaming WAV files over the phone or to a client platform.

AvMsgStoreMonitorSvr The Message Store Monitor service watches subscriber mailboxes on the Cisco Unity server for 
new or deleted messages. This service then adds an MWI request to the Notifier Queue to turn 
the subscriber message waiting indicator (MWI) on or off.

AvRepDirSvrSvc The Reports service accepts report requests from the Cisco Unity Administrator, extracts data 
from log files, and obtains dynamic information from Cisco Unity components such as the DOH 
and MIU. The Reports service also handles report queuing and canceling.

AvSqlChangeWriter The SQL Change Writer service monitors the SQL Server database and requests the applicable 
directory service to update the directory as needed.

AvTtsSvr The Text-to-speech service provides a text-to-audio rendering service that is used by the Call 
Control/Media (MIU) component.

AvUMRSyncSvr The Unity Messaging Repository (UMR) service places the initial voice messages left by 
unidentified callers—an outside caller or a caller from inside the organization calling from a 
phone that is not associated with a subscriber account (such as a conference room)— in the 
UnityMTA directory.

CsBridgeConnector The Connector service monitors the UOmni mailbox and synchronizes directory information in 
both directions between Cisco Unity and an Octel Node (the Bridge).

Table A-1 Cisco Unity Services (continued)

Service Function

Table A-2 Behavior of Cisco Unity Services in a Configuration with Exchange 5.5

Service Dependencies Startup Mode Logs on as Comments

AvCsGateway MSSQLSERVER Automatic UnitySvc Critical; must be restarted if 
stopped.

Starts and stops AvCsMgr.

AvCsMgr Dialogic System Service, 
MSSQLSERVER, 
Telephony

Manual UnitySvc Critical; must be stopped if 
AvCsGateway stops; must use 
AvCsGateway to start 
AvCsMgr.

Can be started only by 
AvCsGateway; should be 
stopped by AvCsGateway
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AvCsNodeMgr

(installed only when 
failover is installed)

Remote Procedure Call 
(RPC)

Automatic Account that owns 
failover service; 
account must be the 
same on both servers

Critical; must be restarted if 
stopped or failover does not 
work.

If stopped, there is no impact 
on AvCsMgr.

AvDirChangeWriter Message Queuing, 
MSSQLSERVER

Automatic Local system 
account (account that 
owns failover 
service; needs access 
to SQL)

Critical, must be restarted if 
stopped.

If stopped, there is no impact 
on AvCsMgr, but it cannot take 
changes from AD and place 
them into SQL.

AvDSEx55 Message Queuing, 
Microsoft Exchange 
Directory, 
MSSQLSERVER

Automatic UnitySvc Critical, must be restarted if 
stopped.

If stopped, there is no impact 
on AvCsMgr, but it cannot take 
changes from AD and place 
them into SQL.

AvGaenSvr None Automatic UnitySvc Not critical.

If stopped, there is no impact 
on AvCsMgr.

AvLic MSSQLSERVER Automatic Local system 
account

AvMMProxySvr Remote Procedure Call 
(RPC)

Automatic Local system 
account

Critical; used by web 
applications and e-mail clients.

AvMsgStoreMonitorSvr AvCsGateway Manual UnitySvc Critical; used for message 
notification and MWIs.

AvRepDirSvrSvc MSSQLSERVER Manual Local system 
account

Not critical; can be disabled if 
reports are not used; AvCsMgr 
starts Reports during startup if 
Reports is not already running.

If stopped, there is no impact 
on AvCsMgr, but it can be 
disabled if reports are not used.

AvSqlChangeWriter MSSQLSERVER Automatic Local system 
account

AvTtsSvr None Manual Local system 
account

Not critical

Table A-2 Behavior of Cisco Unity Services in a Configuration with Exchange 5.5 (continued)

Service Dependencies Startup Mode Logs on as Comments
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Behavior of Cisco Unity Services in a Configuration with 
Exchange 2000

Services that log on with the account that owns the Cisco Unity directory services are listed as logging 
on as UnityDirSvc. Services that log on with the account the owns Cisco Unity message store services 
are listed as logging on as UnityMsgStoreSvc. Both are suggested Active Directory user logon names.

AvUMRSyncSvr MSSQLSERVER Manual UnitySvc Critical; must be restarted if 
stopped; AvCsMgr starts UMR 
during startup if UMR is not 
already running.

If stopped, there is no impact 
on AvCsMgr, but cannot store 
messages if the Exchange 
server is down; must be 
restarted if stopped.

CsBridgeConnector

(always installed, but 
started only if the Bridge 
is licensed)

MSSQLSERVER Manual UnitySvc Not critical; can be disabled if 
the Bridge is not used; does not 
start if no Bridge ports are 
licensed.

If stopped, there is no impact 
on AvCsMgr, but the Bridge 
does not function.

Table A-2 Behavior of Cisco Unity Services in a Configuration with Exchange 5.5 (continued)

Service Dependencies Startup Mode Logs on as Comments

Table A-3 Behavior of Cisco Unity Services in a Configuration with Exchange 2000

Service Dependencies Startup Mode Logs on as Comments

AvCsGateway MSSQLSERVER Automatic UnityMsgStoreSvc Critical; must be restarted if 
stopped.

Starts and stops AvCsMgr.

AvCsMgr Dialogic System Service, 
MSSQLSERVER, 
Telephony

Manual UnityMsgStoreSvc Critical; must be stopped if 
AvCsGateway stops; must use 
AvCsGateway to start 
AvCsMgr.

Can be started only by 
AvCsGateway; should be 
stopped by AvCsGateway.

AvCsNodeMgr

(installed only when 
failover is installed)

Remote Procedure Call 
(RPC)

Automatic Account that owns 
failover service; 
account must be the 
same on both servers

Critical; must be restarted if 
stopped or failover does not 
work.

If stopped, there is no impact 
on AvCsMgr.
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AvDirChangeWriter Message Queuing, 
MSSQLSERVER

Automatic Local system 
account

Critical, must be restarted if 
stopped.

If stopped, there is no impact 
on AvCsMgr, but it cannot take 
changes from AD and place 
them into SQL.

AvDSAD Message Queuing, 
MSSQLSERVER

Automatic UnityDirSvc Critical; must be restarted if 
stopped.

If stopped, there is no impact 
on AvCsMgr, but cannot write 
to or read from AD.

AvDSGlobalCatalog Message Queuing, 
MSSQLSERVER

Automatic UnityDirSvc Critical; must be restarted if 
stopped.

If stopped, there is no impact 
on AvCsMgr, but cannot read 
from global catalog.

AvGaenSvr None Disabled UnityMsgStoreSvc Not critical.

If stopped, there is no impact 
on AvCsMgr.

AvLic MSSQLSERVER Automatic Local system 
account

AvMMProxySvr Remote Procedure Call 
(RPC)

Automatic Local system 
account

Critical; used by web 
applications and e-mail clients.

AvMsgStoreMonitorSvr AvCsGateway Manual UnityMsgStoreSvc Critical; used for message 
notification and MWIs.

AvRepDirSvrSvc MSSQLSERVER Manual Local system 
account

Not critical; can be disabled if 
reports are not used; AvCsMgr 
starts Reports during startup if 
Reports is not already running.

If stopped, there is no impact 
on AvCsMgr, but it can be 
disabled if reports are not used.

AvSqlChangeWriter MSSQLSERVER Automatic Local system 
account

Runs during the MSCW bulk 
synchronization of all SQL and 
AD data. It may also run at 
other times.

AvTtsSvr None Manual Local system 
account

Not critical

Table A-3 Behavior of Cisco Unity Services in a Configuration with Exchange 2000 (continued)

Service Dependencies Startup Mode Logs on as Comments
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AvUMRSyncSvr MSSQLSERVER Manual UnityMsgStoreSvc Critical; must be restarted if 
stopped; AvCsMgr starts UMR 
during startup if UMR is not 
already running.

If stopped, there is no impact 
on AvCsMgr, but cannot store 
messages if the Exchange 
server is down; must be 
restarted if stopped.

CsBridgeConnector

(always installed, but 
started only if the Bridge 
is licensed)

MSSQLSERVER Manual UnityMsgStoreSvc Not critical; can be disabled if 
the Bridge is not used; does not 
start if no Bridge ports are 
licensed.

If stopped, there is no impact 
on AvCsMgr, but the Bridge 
does not function.

Table A-3 Behavior of Cisco Unity Services in a Configuration with Exchange 2000 (continued)

Service Dependencies Startup Mode Logs on as Comments
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access code, missing for external line 8-6

account, locked 9-6

ActiveAssistant. See Cisco Unity Assistant

AGC 6-10

AMIS

and Toshiba phone systems 5-15

diagnostic traces 2-8

fourth-column tones, problems with 5-15

messages, delivery delays 5-2

messages are not delivered to UAmis mailbox 5-7

messages leave UAmis mailbox but are not 
delivered 5-8

messages stuck in UAmis mailbox 5-7

transmission, viewing 5-14

troubleshooting problems with inbound messages 5-10

troubleshooting problems with outbound messages 5-6

Application logs, finding errors 9-2

audio quality 6-1

automatic gain control 6-10

B

browser error messages 9-3

busy ports notification 9-6

C

callers hear reorder tone or dead air space 3-3

calls

disconnected 5-18

internal, not answered 3-5

none answered 3-1
some answered 3-5

call transfers, transferred to incorrect greeting 4-1

Call Viewer utility, about 11-10

changing 6-6

Cisco CallManager integration

diagnostic test setup 1-1

multimedia sound system problems 12-6

subscriber transfer problems 4-3

Cisco CallManager phone system, DTMF signal 
problems 12-2

Cisco Personal Communications Assistant, access 
problems 12-5

Cisco TAC, reporting problems to 1-3

Cisco Unity

services definition table A-1

tray icon missing 12-7

Cisco Unity Administrator

access problems 12-7

unusable or missing pages 12-7

Cisco Unity Assistant

access denied 12-6

access problems 12-6

Cisco Unity Inbox

access denied 12-6

access problems 12-6

class of service

Exchange account, associating with Administrator 
COS 9-4

license limit reached 9-5

logon access denied 9-3

codecs 6-6

comfort noise 6-12

COM ports

disabling device detection 3-3
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viewing assignments 3-2

confirming

phone system settings 3-2

ports, number of 3-10

conversation errors 9-6

D

data packets, viewing 11-1

dead air space, callers hear 3-3

delayed messages, causes of 5-1

diagnostics test setup 1-1

Diagnostic Tool 11-10

diagnostic traces, AMIS 2-8

Dialogic

quiet parameter, changing 5-17

single-line test setup 1-2

 

Dialogic automatic gain control 6-11

Dialogic voice card, quiet parameter 5-17

dial tone present at end of message 5-18

directory handler missing subscribers 12-6

disabling

COM ports 3-2

detection of devices on COM ports 3-3

diagnostic logs 11-10

disconnected calls 5-18

distribution list missing subscribers 12-6

DohPropTest, using to view or remove messages from the 
UAmis mailbox 5-13

Dr. Watson logs, obtaining 2-2

DTMF

duration and delay settings, comparing 12-4

phone signal problems (circuit-switched phone 
systems) 12-3

phone signal problems (Cisco CallManager) 12-2

testing on feature-set phones 12-3

testing on operator console 12-3
IN-2
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E

e-mail

attachments, fax problems 10-1

text-to-speech problems 9-7

error messages

browser 9-3

e-mail and voice 9-6

startup 9-1

Windows 9-3

errors, finding in Application and System Event logs 9-2

Event log traces, obtaining 2-2

Example Subscriber, using as test subscriber 1-1

Exchange

changing MTA settings 5-3

mailbox full 5-4

server down or disconnected 5-2, 8-3

external lines

access code missing 8-6

use in message notification 8-5

F

fax

delivery problems 10-1

e-mail attachment, problems 10-1

verifying subscriber settings 10-1

feature set phones, DTMF signal problems 12-3

forward timer, out of synch 4-2

G

G.729 enabled registry setting 6-6

gain control 6-10

greetings

call transfer problems 4-1

wrong greeting plays 4-3

greeting volume 6-1
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H

hacker attack, recovery from 12-7

hunt groups

confirming programming with Cisco Unity failover 3-7

confirming programming without Cisco Unity 
failover 3-6

programming errors 3-6

I

Integration Monitor

correcting display problems 11-4

display options table 11-3

field value table 11-2

frequently asked questions 11-4

utility, about 11-1

integrations

call transfer problems 4-1

internal calls, not answered 3-5

test setup, single-line 1-2

verifying settings (Cisco CallManager) 4-3

L

Learn Tones

process failure, troubleshooting 11-9

switch configuration file location 11-6

tone definitions 11-5

utility, about 11-5

utility, running 5-18

 

log files, creating 11-10

logs, Voice Connector 2-10

logs and traces 2-1

LPT1 port settings, changing 9-3
Ci
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macro traces 11-10

mailbox storage limits 5-4

median volume setting 6-11

message notifications

access code errors 8-6

device problems 8-6

dual integration settings, correcting 8-7

external numbers, no calls made 8-5

port setup 8-2

setup, testing 8-3

slow for multiple subscribers 8-1

slow for single subscriber 8-3

subscriber errors 8-4

testing devices 8-7

message playback volume 6-1

messages

AMIS delivery problems 5-2

AMIS inbound delivery problems 5-10

AMIS outbound delivery problems 5-6

delayed 5-1

delayed delivery 5-2

disappearing 5-3

leave UAmis mailbox but not delivered 5-8

not delivered to UAmis mailbox 5-7

notifications, types that trigger 8-6

playback volume problems 6-1

recording cuts off 5-17

server outage, recording during 5-2

stuck in UAmis mailbox 5-7

messaging waiting indicators (MWIs)

about 7-1 to 7-4

troubleshooting 7-4 to 7-15

micro traces, diagnostic tool 11-10

MIU, diagnostics 2-3

multimedia sound system problems 12-6

MWIs, delayed activation 5-2, 8-3
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O

opening greeting

caller hears in error (Cisco CallManager 
integration) 4-3

caller hears instead of personal options 12-2

P

packets, viewing values 11-1

PCA. See Cisco Personal Communications 
Assistant

phone system

line not working 3-11

packets, viewing 11-1

programming, confirming (Ericsson 
MD-110) 4-3

settings, confirming 3-2

port configuration

confirming 3-10

disabled or set incorrectly 3-10

message notification problems 8-2

system key, does not match 3-9

ports

all ports busy notification 9-6

assigned incorrectly 3-2

calls misdirected 3-10

calls sent to port that is not set to answer 8-2

confirming number 3-10

disabled 3-10
IN-4
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enabled in Registry 3-10

hanging due to misconfiguration 8-2

message notification setup 8-2

Q

quiet parameter, Dialogic voice card 5-17

R

Registry, using to enable ports 3-10

reorder tone

hearing, at end of message 5-18

hearing, when answering call 4-3

repeat notifications 8-4

reports

generation problems 13-1

notification problems 13-2

restarting Exchange, need to restart Cisco 
Unity 3-2

restart notifications 8-4

ring signal, testing 3-5

rings to wait, setting 4-3

routing rules, testing 3-9

running the Learn Tones utility 5-18

S

services, Cisco Unity A-1

service startup settings, checking 9-2
xchange)
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Set Record Format utility 6-6

Set Volume utility 6-2

single-line tests, setup 1-2

Skinny TSP traces, obtaining 2-5

startup problems

browser error messages 9-3

error messages 9-1

Status Monitor

accessing after upgrade 9-5

access problems 12-7

missing or unusable pages 12-7

subscribers

conversation problems 12-2

Exchange mailbox, full 5-4

missing from directory handler 12-6

missing from distribution list 12-6

supervised transfers, confirming settings 4-2

Switch.ini version, locating 1-5

System Event logs, finding errors 9-2

system event notifications 9-7

system key problems 3-9

T

Technical Assistance Center (TAC), Cisco 1-3

test extensions, setting up 1-1

testing

DTMF signals on feature-set phones 12-3

DTMF signals on operator console 12-3

hunt group programming (non-IP phone systems) 3-8

routing rules 3-9

touchtones, no response to 12-2

traces

AMIS 2-8

TSP 2-4

TSP version number, locating 1-5
Ci
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UAmis mailbox

determining why messages are stuck 5-8

viewing or removing messages from 5-13

Unity Diagnostic Tool

AMIS diagnostic traces 2-8

setting and retrieving AMIS traces. 5-13

Universal Dialogic Diagnostics utility 11-14

utilities

Advanced Settings Tool 11-12

Call Viewer 11-10

Cisco Unity Diagnostic Tool 11-10

Integration Monitor 11-1

Learn Tones 11-5

Set Record Format 6-6

Set Volume 6-2

Universal Dialogic Diagnostics 11-14

Wave Gain 6-8

V

verifying

fax settings, subscriber 10-1

integration settings, Cisco CallManager 4-3
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