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Maintaining Cisco Unity

Overview: Maintaining Cisco Unity
All of the software and hardware associated with the Cisco Unity server requires maintenance to ensure 
availability. Degradation in any piece of the installed software can affect server performance. If you 
perform regular maintenance, you can reduce the likelihood of unplanned downtime.

See the following sections in this chapter for more information:

• Scheduling Maintenance Tasks, page 7-1—This section provides an overview of system 
maintenance tasks and suggested frequency.

• Configuring Cisco Unity for Maintenance Tasks, page 7-3—This section describes application level 
maintenance tasks on the Cisco Unity server.

• Configuring Exchange for Maintenance Tasks, page 7-7—This section describes maintenance tasks 
for Microsoft Exchange (whether on- or off-box configuration) that are related to maintenance of 
Cisco Unity.

• Moving Subscriber Mailboxes, page 7-19—It is possible to move subscribers from one Exchange 
server to another without having to shut down Cisco Unity.

• Moving the Unity Messaging System, UAmis, and UOmni Exchange Mailboxes, page 7-22—Like 
subscriber mailboxes, it is possible to move the Unity Messaging System, UAmis, and UOmni 
mailboxes from one Exchange server to another—but with a few extra steps to prevent problems that 
can occur after these special mailboxes are moved.

• Cisco Unity Failover Feature, page 7-23—This feature provides a redundant Cisco Unity server in 
the event the primary Cisco Unity server fails, or for use during routine maintenance.

• Backing Up and Restoring a Cisco Unity System, page 7-24—Backups are essential for restoring 
Cisco Unity quickly if data is corrupted or lost.

Scheduling Maintenance Tasks
The frequency of scheduled maintenance depends on your particular environment, taking into account 
such issues as system size, configuration, and traffic levels. At a minimum, we recommend that you do 
scheduled maintenance as indicated in Table 7-1. If you already do the following tasks more frequently 
than we recommend, use your schedule rather than our recommendations.
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Table 7-1 Maintenance Tasks and How Often to Perform Them

Task Daily Monthly Other

Forward unaddressed messages to the appropriate 
recipients. For more information, see the “Forwarding 
Unaddressed Messages to the Appropriate Recipients” 
section on page 7-11.

Continually

Scan for viruses. See the “Scanning for Viruses” section 
on page 7-10.

X

Back up the Cisco Unity server. See the “Backing Up 
and Restoring a Cisco Unity System” section on 
page 7-24.

X

Upgrade virus-scanning definitions. See the “Updating 
Virus-Scanning Definitions” section on page 7-11.

Whenever new definitions become available

Exchange: Check for Exchange mailboxes that are over 
their limit. See the “Checking for Mailboxes that Are 
Over Their Size Limit” section on page 7-13.

X

Install the latest Cisco Unity-qualified service packs 
and security hot fixes. See the “Installing Service Packs 
and Updates” section on page 7-13.

X

Exchange 5.5 and Exchange 2000: Free unused space in 
the Exchange database by using the Eseutil utility. 
Refer to Article ID 192185, “How to Defragment with 
the Eseutil Utility” on the Microsoft website.

Offline defragmentation every six months

Exchange 5.5: Run the Exchange Optimizer. Refer to 
Article ID 266051, “The ‘Understanding the Microsoft 
Exchange Server Performance Optimizer’ White Paper 
Is Available” on the Microsoft website.

Whenever you add 100 or more Exchange 
mailboxes or Cisco Unity subscribers

Run the Dbwalker Utility, available from Tools Depot. 
Fix any errors encountered by following the on-screen 
instructions. 

X Use to check database integrity.

Install new hardware and drivers. See the “Installing 
New Hardware and Drivers” section on page 7-13.

As required

Update the system clock. See the “Updating the System 
Clock” section on page 7-14.

X

Restart the Cisco Unity server. See the “Restarting the 
Cisco Unity Server” section on page 7-14. 

According to your current schedule for 
restarting servers or as needed

Upgrade third-party software. X

Verify that messages in the Unity Messaging Repository 
(UMR) are being delivered.

Set an event notice to determine if failover has occurred.

Run and review Cisco Unity reports. As required.

Check whether Cisco Unity Administrator sessions are 
not in use but are not being freed by Cisco Unity.
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Configuring Cisco Unity for Maintenance Tasks
See the following sections:

• Status Monitor, page 7-3

• Event Notification Utility, page 7-5

Status Monitor
The Status Monitor is a Web-based application on the Cisco Unity server that runs separately from the 
Cisco Unity Administrator. It contains pages providing information about system status, ports, reports, 
and disk drives. Each page of the Status Monitor displays key status information from the other Status 
Monitor pages in the taskbar at the bottom of the screen. (See Table 7-2 for information about each page 
in the Status Monitor.)

To access the Status Monitor, use one of the following two procedures. The way that you log on to the 
Status Monitor depends on which authentication method it uses. Note that the authentication method that 
you choose to use for the Cisco Unity Administrator automatically applies to the Status Monitor. (To 
learn more about the authentication methods that you can use with the Cisco Unity Administrator and 
the Status Monitor, see the “About Cisco Unity Administrator Authentication” section on page 2-5.)

To log on to the Status Monitor when it uses Integrated Windows authentication

Step 1 Log on to Windows on the Cisco Unity server (or a remote computer) by using the administration 
account or an appropriate Windows domain account.

Step 2 If you logged on to the Status Monitor on the Cisco Unity server, double-click the desktop shortcut to 
the Status Monitor.

If you logged on to the Status Monitor on a computer other than the Cisco Unity server, start Internet 
Explorer, and go to http://<Cisco Unity server name>/status.

Step 3 If Internet Explorer prompts you for a user name and password, enter the user name, password, and 
domain for the administration account or an appropriate Windows domain account.

To log on to the Status Monitor when it uses Anonymous authentication

Step 1 Log on to Windows on the Cisco Unity server (or a remote computer) by using any domain account that 
has the right to log on locally.

Verify that the system back-up is completing before the 
beginning of the next business day.

X

Verify that the back-up medium has enough room to 
back up the entire contents of the Cisco Unity server.

X

Monitor system resources. According to your current schedule or as 
required.

Table 7-1 Maintenance Tasks and How Often to Perform Them (continued)

Task Daily Monthly Other
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Step 2 If you logged on to the Status Monitor on the Cisco Unity server, double-click the desktop shortcut to 
the Status Monitor.

If you logged on to the Status Monitor on a computer other than the Cisco Unity server, start Internet 
Explorer, and go to http://<Cisco Unity server name>/status.

Step 3 On the Cisco Unity Log On page, enter the user name, password, and domain for the administration 
account or an appropriate Windows domain account, and click Log On.

Table 7-2 describes each page in the Status Monitor.

Access to the Status Monitor is controlled by class of service. Internet Explorer is also required to view 
the Status Monitor pages.

To set up or modify access to the Status Monitor

Step 1 In the Cisco Unity Administrator, go to any Subscribers > Class of Service page.

Step 2 Click the Find icon.

Step 3 Double-click the class of service that you want to modify.

Step 4 Go to the System Access page.

Step 5 Check the Unity Administrator Application Access check box.

Step 6 Under Troubleshooting and Administration, check the Status Monitor Access check box. Note that by 
checking only this one check box, the class of service has no other Unity Administrator Application 
Access rights.

Table 7-2 Status Monitor Pages

Button Page Name Description

System Status Shows whether Cisco Unity is operating, and allows you to start and exit from Cisco Unity. You 
can choose to exit after all calls are finished or to interrupt calls in progress with a message and 
then disconnect all calls and exit.

Port Status Shows the status of each port. This page is useful for testing and troubleshooting. For example, 
you can monitor an incoming call to see which call handlers the call is routed to.

Report Status Shows the status of reports that have been generated.

Disk Drive 
Status

Shows the total size and the available space of each drive and partition on the Cisco Unity 
server.

Help Displays the online Status Monitor Help.
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Step 7 Click the Save icon.

Event Notification Utility
The Event Notification utility sends e-mail, voice mail, or both to subscribers or public distribution lists 
in response to an error condition or potential problem on the Cisco Unity server. The utility monitors the 
Windows application log and sends notification when a specified event occurs, such as “Disk almost 
full.” In addition, the utility can also automatically restart the Cisco Unity server when a specified event 
occurs.

The Event Notification utility has several default event notifications predefined, though some event 
notifications, such as those which require the Cisco Unity server to automatically restart, are disabled. 
The notification settings for the default event notifications specify that an e-mail is sent to the System 
Event Messages distribution list. Because the Example Administrator is the only member of this 
distribution list by default, assign the appropriate subscriber(s) or public distribution list to the list to 
ensure that someone receives event notifications. Note that if you later delete the assigned subscribers 
or distribution lists, Cisco Unity does not prompt you to assign a replacement. 

You can disable or enable existing event notifications, as well as modify the event which is monitored, 
how you are notified when the event occurs, and who receives notification. You can also add new event 
notifications. There are two types of event notifications that you can create:

Note that Cisco Unity writes events only to the Windows application log; it does not write events to the 
system or security logs. For information on how to generate an Event Log report for all application 
events on the Cisco Unity server, or for the events that apply only to Cisco Unity, see the “Event Log 
Report” section on page 24-9. You can also view application events by using the Windows Event Viewer 
(on the Windows Start menu, click Programs > Administrative Tools > Event Viewer). You can identify 
the Cisco Unity events as those events that begin with CiscoUnity (for example, 
“CiscoUnity_LogMgr”). For more information on Windows events, refer to the Windows Event Viewer 
online Help.

To modify or add an event notification

Step 1 On the Cisco Unity server desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane, under Reporting Tools, double-click Event Notification Utility. The Notification Utility 
Administration window appears, listing the events monitored by the utility and the type of notification(s) 
set up for each.

Step 3 Do one of the following actions:

• To modify an existing event notification, double-click the event that you want to modify. Note that 
the event notification type is specified in the title bar of the Properties dialog box which appears.

• To add a new event notification, click File > New Event. Then choose the appropriate action:

Table 7-3 Event Notification Types

Type Action

NT Event Log The utility notifies you when an application event that you specify occurs.

Reboot Cisco Unity The utility notifies you and automatically restarts Cisco Unity when an 
application event that you specify occurs.
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– If you want the Event Notification utility to notify you when the event that you specify occurs, 
click NT Event Log.

– If you want the utility to notify you and automatically restart the Cisco Unity server when the 
event that you specify occurs, click Reboot Cisco Unity.

Step 4 From the Event tab, do the following actions as appropriate:

• In the Display Name field, enter the event notification name that you want listed in the Notification 
Utility Administration window.

• To enable or disable the event notification, check or uncheck the Active box as appropriate.

• Select or enter the source, and then enter the event ID of the event that you want the utility to monitor 
as each is referenced in the Windows application log.

Step 5 From the Voice Mail Message tab, do one of the following actions:

• To enable or disable voice mail notification, check or uncheck the Send Message box as appropriate.

• To set up or modify voice mail notification, see the procedure, To set up or modify voice mail 
notification, page 7-6, and then continue with Step 6 in this procedure.

Step 6 From the E-Mail Message tab, do the following actions as appropriate:

• To enable or disable e-mail notification for the event, check or uncheck the Send Message box as 
appropriate.

• Complete or modify the remaining fields.

Step 7 From the SMTP Message tab, do one of the following actions:

• To enable or disable SMTP notification for the event, check or uncheck the Send Message box as 
appropriate.

• To set up or modify SMTP notification, see the procedure, To set up or modify SMTP message 
notification, page 7-7, and then continue with Step 8 in this procedure.

Step 8 Click OK.

Step 9 If necessary, repeat Step 3 through Step 8 to add or modify another event notification.

Step 10 Click Tools > Reset Server to update the utility with your changes. Note that this action resets the Event 
Notification utility—not the Cisco Unity server. It is not necessary to restart the Cisco Unity server to 
save your event notification changes.

To set up or modify voice mail notification

Step 1 Record the message that you want to use as the voice mail message for an event notification by using the 
Media Master control bar. Use the Media Master Copy to File option to save the recording as a WAV 
file. (For details, see the “Recording Greetings and Names” section on page 2-18.)

Step 2 If the Event Notification utility is not already running, on the Cisco Unity server, on the Windows Start 
menu, click Programs > Cisco Unity > Event Notification Utility.

Step 3 Go to the Voice Mail Message tab in the Properties dialog box for the appropriate event notification.

Step 4 Confirm that the Send Message check box is checked, and complete the To and Subject fields.

Step 5 Enter the directory path where you stored the WAV file that you recorded in Step 1, or click Browse to 
select it.
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Step 6 Complete the remaining fields as appropriate, and then click OK.

To set up or modify SMTP message notification

You can set up the Event Notification utility to send an e-mail message through an SMTP gateway in 
response to an error condition or potential problem on the Cisco Unity server. This capability is useful 
when Exchange has gone down, or if you want to send notification through the Internet to an e-mail 
address at another location.

Step 1 If the Event Notification utility is not already running, on the Cisco Unity server, on the Windows Start 
menu, click Programs > Cisco Unity > Event Notification Utility.

Step 2 Go to the SMTP Message tab in the Properties dialog box for the appropriate event notification.

Step 3 Confirm that the Send Message check box is checked.

Step 4 In the SMTP Server field, enter either the IP address or the fully-qualified domain name of an SMTP 
server that is not on your Exchange network.

Step 5 In the Port field, confirm that the port number for the SMTP server is correct for your site. Consult your 
network administrator for more information.

Step 6 Complete the From field as appropriate. You can enter a name or an e-mail address.

Step 7 In the To field, enter the e-mail address of the message recipient.

Step 8 Complete the remaining fields as appropriate, and then click OK.

Monitoring Cisco Unity Performance

Refer to the White Paper: Monitoring Cisco Unity Performance, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_technical_reference_list.html.

Configuring Exchange for Maintenance Tasks
On any Exchange server that is the home server for Cisco Unity subscribers, do the tasks in the following 
sections:

• Setting a Maximum Size for Exchange Mailboxes, page 7-7

• Circular Logging in Exchange, page 7-9

• Monitoring the Message Transfer Agent, page 7-10

Existing Microsoft best practices can be researched and utilized based on system scaling and traffic 
patterns. Refer to the Microsoft website for best practices on maintaining Microsoft products.

Setting a Maximum Size for Exchange Mailboxes
Voice messages can consume significant amounts of disk space. For example voice messages recorded 
by using the G.711 codec consume 480 KB/minute. If you allow all Cisco Unity subscribers to save 
every voice message they ever receive, the hard disk where messages are stored can quickly run out of 
space. To prevent this from happening, you can set limits on the size of subscriber Exchange mailboxes.
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For more information on Exchange 5.5 and Exchange 2000 storage limits, refer to the Microsoft 
Exchange documentation. 

To learn more about how Cisco Unity handles subscribers with full mailboxes, see the “How Cisco Unity 
Handles Subscribers Whose Mailboxes Are Full” section on page 4-2.

Exchange 2000

To set limits for all users in Exchange 2000

Step 1 On the Windows Start menu, click Programs > Microsoft Exchange > System Manager.

Step 2 In the left pane, expand Servers, expand the appropriate server, and expand the storage group.

Step 3 Right-click Mailbox Store, and click Properties.

Step 4 Click the Limits tab.

Step 5 In the Storage Limits section, specify values as appropriate. For more information, refer to the Exchange 
System Manager online Help.

If you want to set different limits for individual users (for example, set no limit for the company 
president), do the following procedure.

To set limits for individual users in Exchange 2000

Step 1 On the Windows Start menu, click Programs > Microsoft Exchange > Active Directory Users and 
Computers.

Step 2 In the left pane, expand the server.

Step 3 In the left pane, click the folder in which the user appears (by default, the folder is named Users).

Step 4 In the right pane, right-click the user name, and click Properties.

Step 5 Click the Exchange General tab.

Step 6 Click Storage Limits. 

Step 7 In the Storage Limits dialog box, uncheck the Use Mailbox Store Defaults check box.

Step 8 Specify values as appropriate. For more information, refer to the Active Directory Users and Computers 
online Help.

Exchange 5.5

To set limits for all users in Exchange 5.5

Step 1 On the Windows Start menu, click Programs > Microsoft Exchange > Microsoft Exchange 
Administrator.

Step 2 In the left pane, expand the site, expand Configuration, expand Servers, and expand the appropriate 
server name.

Step 3 In the left pane, click Private Information Store.
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Step 4 On the Exchange Administrator menu, click File > Properties.

Step 5 On the General tab, specify values in the Storage Limits section as appropriate. Refer to the Exchange 
Administrator online Help for more information.

If you want to set different limits for individual users (for example, set no limit for the company 
president), do the following procedure.

To set limits for individual users in Exchange 5.5

Step 1 On the Windows Start menu, click Programs > Microsoft Exchange > Microsoft Exchange 
Administrator.

Step 2 In the left pane, expand the site and click Recipients.

Step 3 In the right pane, double-click the mailbox whose limit you want to change.

Step 4 Click the Limits tab.

Step 5 In the Use Information Store Defaults section, uncheck the Use Information Store Defaults check box.

Step 6 Specify values as appropriate. Refer to the Exchange Administrator online Help for more information.

Circular Logging in Exchange
You can configure logging in one of two ways: either the existing logs are overwritten when hard disk 
space runs low, or the existing logs are never overwritten. Overwriting the existing logs when hard disk 
space runs low is known as circular logging.

Exchange 5.5 and Exchange 2000 store data in Jet databases. The most current transactions are stored 
in the Edb.log file. When the Edb.lg file reaches 5 MB in size, Exchange checks to see if the oldest 
transactions in the file have been committed to the database. If they have, then the old transactions are 
overwritten with new transactions, preventing the total size of the log files from growing beyond 25 to 
30 MB in size. Exchange will not, however, overwrite any transactions that have not been committed to 
the database. This process is circular logging. When circular logging is enabled, full backups of 
Exchange are required.

When circular logging is disabled, and the Edb.lg file reaches 5 MB in size, Exchange creates a new log 
file of the same name, and renames the inactive file. The number of log files increases as more 
transactions are logged, and the system continues to create new log files until a backup is completed. If 
you disable circular logging, Exchange backups must be done, or the transaction logs can fill up all of 
the available disk space. We recommend that you set a backup schedule to do periodic full backups and 
incremental backups all other times.

After you back up the message store by using Exchange-aware backup software, the backup software 
clears the transaction logs. At this point, the backup reflects the current state of the message store, so the 
transaction logs are no longer required to restore the message store.

Caution If circular logging is on and hard disk space runs low, the newest transaction log entries (which contain 
the newest messages) overwrite the oldest log entries (the oldest messages). When log entries are 
overwritten, you cannot use the transaction logs to restore messages that were received after the last 
backup. If disk space is very low and if the system is very busy, this can happen in less than a day.
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Do not disable circular logging if you are not going to back up Exchange. If you decide to disable 
circular logging, confirm that backups continue to run and that they do not fail or stop working for some 
reason. If backups are not done, the transaction logs can cause the hard disk to fill up, which in turn 
causes Exchange to stop working and subsequently can cause Cisco Unity to stop working.

We strongly recommend that you do the following:

• Use Exchange-aware backup software to back up the message store.

• Carefully watch the amount of available space on the hard disk or in the partition where logs are 
stored, and free up disk space when the amount of available space gets too low.

To turn circular logging off for Exchange 5.5

Step 1 In the left pane of Microsoft Exchange Administrator, select the server.

Step 2 On the Exchange Administrator File menu, click Properties.

Step 3 Click the Advanced tab.

Step 4 In the Database Circular Logging section, uncheck the Information Store check box.

If you also want to turn circular logging off for the directory, you can also uncheck the Directory check 
box.

Monitoring the Message Transfer Agent 
Monitor the MTA (UnityMTA and UnityMTA\failed folders) to confirm that messages are going to home 
servers. The MTA queue can contain messages that did not go their home servers if there has been a loss 
of network connectivity, if the Exchange server has gone off-line, or if there is a DNS issue (if the name 
of the sending or home server cannot be resolved, the messages cannot be sent to the home server.)

For Exchange 5.5 systems, refer to Microsoft Knowledge Base article 247133, available on the Microsoft 
support website.

Monitoring System Resources
Monitor for low free disk space on all hard disks and partitions on the Cisco Unity server. (Cisco Unity 
already checks available disk space on the partition on which Cisco Unity is installed.) What qualifies 
as low disk space can vary from partition to partition. For the operating system partition, 10 percent may 
suffice. For the data store, 25 percent or less should generate a notification to the system administrator.

Scanning for Viruses

Selecting Virus-Scanning Software
For a list of the virus-scanning software that has been qualified for use with Cisco Unity, refer to the 
System Requirements document for your version of Cisco Unity, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_pre_installation_guides_list.html.
7-10
Cisco Unity System Administration Guide (With Microsoft Exchange)

OL-3098-01

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_pre_installation_guides_list.html


Chapter 7 Maintaining Cisco Unity
Managing the Location of Log Files and Database Files
Scheduling Virus Scanning
Schedule virus scanning to occur daily. Ideally, virus scanning should occur when the server is least busy 
so that it does not interfere with Cisco Unity voice messaging functions.

Updating Virus-Scanning Definitions
Your virus-scanning software should be configured to alert you every week or two to check the 
manufacturer website for new virus-scanning definitions. If you already have a policy for updating these 
definitions on the other computers on your network, follow the same policy for the Cisco Unity server. 
If you do not already have a policy, download and install the new definitions on the Cisco Unity server 
whenever the software prompts you.

Managing the Location of Log Files and Database Files
The way in which logical drives on the Cisco Unity server are partitioned and what content is located on 
the drives depends on the size of the Cisco Unity system, the RAID volume configuration used, whether 
the system will be installed as Voice Messaging Only (VM) or as Unified Messaging (UM), and whether 
Exchange is used on-box or off-box.

The partition and drive content recommendations from the Cisco Unity Installation Guide should 
continue to be followed when maintaining your system.

For more information on storage issues, refer to White Paper: Physical Storage Best Practices for 
Cisco Unity with Microsoft Exchange, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_technical_reference_list.html. 

Performing Scheduled Maintenance on the Cisco Unity Server
See the following sections for detailed information on scheduled maintenance tasks:

• Forwarding Unaddressed Messages to the Appropriate Recipients, page 7-11

• Checking for Mailboxes that Are Over Their Size Limit, page 7-13

• Installing Service Packs and Updates, page 7-13

• Installing New Hardware and Drivers, page 7-13

• Updating the System Clock, page 7-14

• Restarting the Cisco Unity Server, page 7-14

Forwarding Unaddressed Messages to the Appropriate Recipients
In some situations, messages left in Cisco Unity are not associated with a specific recipient, and so they 
must be screened and routed to the appropriate subscriber or call handler. A subscriber should be 
assigned the responsibility of reviewing these messages frequently.
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Such messages are left as indicated in the following sections.

Unaddressed Messages Distribution List

Messages that cannot be delivered because the network, or a server assigned to a subscriber, has gone 
off-line or is otherwise unavailable to the Cisco Unity server, or because the subscriber mailbox has 
exceeded the Prohibit Send and Receive limit specified for the mailbox in Exchange, are forwarded to 
the Unaddressed Messages distribution list. By default, this distribution list contains the Example 
Administrator as its only member.

To route these messages properly, ensure that the Unaddressed Messages distribution list has at least one 
member (such as the operator) who will monitor the mailbox and handle messages that cannot be 
delivered. (When Cisco Unity is installed, the Example Administrator account is set as the only member 
of the Unaddressed Messages distribution list.) See the procedure, To add subscribers to the Unaddressed 
Messages distribution list, page 7-12. (For information about public distribution lists, see the “Overview: 
Public Distribution Lists” section on page 16-1.)

Note that if the mailbox(es) of the subscriber(s) who are assigned to check the Unaddressed Messages 
list exceed the Prohibit Send and Receive storage limit that is specified in Exchange, the messages sent 
to the Unaddressed Messages distribution list are lost. To avoid this problem, specify a generous value 
for the Prohibit Send and Receive storage limit for the mailbox of at least one subscriber who is a 
member of the Unaddressed Messages list and encourage the subscriber to dispose of messages promptly 
so that the Exchange mailbox does not fill up. (To learn more about how Cisco Unity handles subscribers 
with full mailboxes, see the “How Cisco Unity Handles Subscribers Whose Mailboxes Are Full” section 
on page 4-2.)

To add subscribers to the Unaddressed Messages distribution list

Step 1 In the Cisco Unity Administrator, go to any Subscribers > Public Distribution Lists page.

Step 2 Click the Find icon.

Step 3 Double-click the Unaddressed Messages distribution list.

Step 4 Change settings as appropriate, and then click the Save icon.

System Event Messages Distribution List

Messages sent from the Event Notification Utility are forwarded to the System Event Messages 
distribution list. By default, this distribution list contains the Example Administrator as its only member. 
To route these messages properly, add a subscriber (such as the operator) to the System Event Messages 
distribution list. For information on adding subscribers to a distribution list, see the “Overview: Public 
Distribution Lists” section on page 16-1.

Operator, Opening Greeting, and Goodbye Call Handlers

When a caller to Cisco Unity dials the operator and no operator is available, the caller can leave a 
message, depending on the call transfer settings for the Operator call handler. Call transfer settings in 
the Opening Greeting and Goodbye Call Handlers also can allow callers to leave a message. By default, 
messages left in the Operator, Opening Greeting, and Goodbye call handlers are sent to the Unaddressed 
Messages distribution list. For more information on call handler message recipient settings, see the “Call 
Handler Messages Settings” section on page 19-13.
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Example Interview

When callers are routed to the Example Interview, which gathers basic information about who they are 
and who they are trying to reach, the answers to the questions are routed by default to the Example 
Administrator. If you want these messages to be routed to another recipient, choose a subscriber (such 
as the operator) or a distribution list as the recipient. For information on choosing an interview response 
recipient, see the “Overview: Interview Handler Settings” section on page 21-1.

Checking for Mailboxes that Are Over Their Size Limit
If you set limits on the maximum size of subscriber mailboxes as recommended in the “Setting a 
Maximum Size for Exchange Mailboxes” section on page 7-7, you should regularly run the Cisco Unity 
Storage Usage report to determine which users have exceeded mailbox limits. See the “Reports” chapter 
for details.

To learn more about how Cisco Unity handles subscribers with full mailboxes, see the “How Cisco Unity 
Handles Subscribers Whose Mailboxes Are Full” section on page 4-2.

Installing Service Packs and Updates
Microsoft frequently provides updates for Windows 2000, Exchange, SQL Server 2000/MSDE 2000, 
Internet Explorer, and Microsoft Internet Information Server (IIS).

Microsoft updates (referred to by a variety of names, including security updates, critical updates, 
patches, and hot fixes) are limited to changes that fix specific problems. They do not include general 
defect fixes or new functionality. Cisco TAC provides support for a Cisco Unity system on which these 
updates have been installed.

Microsoft also occasionally releases service packs, which contain fixes generated since the general 
product release, including most fixes that were released as updates.

Because the service pack scope is broad, each service pack must be thoroughly tested to ensure that 
changes do not adversely affect Cisco Unity. Cisco TAC does not support new service packs until they 
have been qualified for use with Cisco Unity. Do not install a service pack or maintenance release that 
has not been qualified, or Cisco TAC will not help you resolve problems until you uninstall it.

For information on which Microsoft service packs have been qualified for use with Cisco Unity, refer to 
Cisco Unity System Requirements, and Supported Hardware and Software, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_pre_installation_guides_list.html.

Installing New Hardware and Drivers
Cisco Unity servers that you purchase from Cisco Systems are configured for a specific hardware setup. 
Do not add or change any hardware on the server, except to add voice cards, processor(s), memory, a 
tape drive, an external modem, or a rail kit.
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Updating the System Clock
If the Cisco Unity server is connected to the network, we recommend that you configure an authoritative 
time server to ensure that all computers in the organization use a common time. Refer to Article ID 
216734, “How to Configure an Authoritative Time Server in Windows 2000,” on the Microsoft support 
website.

When the system clock on the Cisco Unity server is slow by a significant amount, subscribers may 
believe that Cisco Unity is delaying message delivery.

If the Cisco Unity server is not connected to the network, check the system clock monthly to ensure that 
the time is accurate to within a minute. To change the time, use the Date/Time Control Panel (Settings > 
Control Panel > Date/Time on the Windows Start menu).

Caution Do not change the time on the system clock while you are changing values by using the Cisco Unity 
Administrator, or you may encounter inconsistencies in the data. 

Restarting the Cisco Unity Server
Depending on how your network is configured, Cisco Unity services may rely on the availability of a 
number of other servers on the network, as follows:

• The server that homes the Unity System mailbox

• The server(s) that home Cisco Unity subscriber mailboxes

• Exchange bridgehead servers

• The domain controller for the domain in which the Cisco Unity server belongs

• The Active Directory global catalog server

• The Cisco CallManager server (if Cisco Unity is integrated with Cisco CallManager)

• The Cisco Unity secondary server, for Cisco Unity failover systems

• The Exchange 2000 Voice Connector server

The availability of each of these servers, the network connection to these servers, and the corresponding 
components on the Cisco Unity server may each affect Cisco Unity services.

If you restart servers or network devices on a regular schedule, include Cisco Unity servers in this 
schedule.

The Unity Schedule Restart tool, available in Tools Depot, allows you schedule an automatic restart of 
the Cisco Unity server (recommended), or just the Cisco Unity services. You can also use the tool to 
view Application Event log entries related to restarting Cisco Unity.

To schedule Cisco Unity restarts

Step 1 On the Cisco Unity desktop, double-click the Cisco Unity Tools Depot icon.

Step 2 In the left pane, under Administrative Tools, double-click Schedule Unity Restart.

Step 3 In the Configure Scheduled Restart Options window, choose to restart the Cisco Unity server 
(recommended), or to restart Cisco Unity services only.

Step 4 Click Schedule Restart, and complete the fields as needed for your site. To change an existing schedule, 
delete the task and schedule a new task.
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Step 5 Click Save and Exit.

Accessing Cisco Unity Remotely
There are several methods that allow remote access to the Cisco Unity server so that you can perform 
tasks—such as loading updates or patches and transferring files—that otherwise would have to be 
performed locally. Depending on your site, you can set up remote access to the Cisco Unity server by 
using:

• Windows Terminal Services (WTS)—For more information, see the “Using Windows Terminal 
Services” section on page 7-15. WTS is also supported for the Cisco Unity Bridge server.

• Symantec pcAnywhere—For more information, see the “Using pcAnywhere” section on page 7-17.

• A Virtual Private Network (VPN)—For more information, see the “Using a Virtual Private Network” 
section on page 7-18.

Using Windows Terminal Services
Windows Terminal Services comes with Windows 2000, and should already be set up on the Cisco Unity 
server. In order to set up and use Windows Terminal Services on your remote computer, do the following 
procedures. (For details on setting up Windows Terminal Services on the Cisco Unity server, refer to the 
Cisco Unity Installation Guide.)

To find additional information about Windows Terminal Services, refer to the online Help available from 
either the Terminal Services server program on the Cisco Unity server, or from the Terminal Services 
Client program that you install on the remote computer. You can also refer to the Microsoft website.

To create the Windows Terminal Client install disks

To use Windows Terminal Services on a remote computer, you must first create a set of install disks by 
using the Windows Terminal Services host program on the Cisco Unity server. You will need two blank 
disks—labeled “Disk 1” and “Disk 2”—to do this procedure.

Step 1 On the Cisco Unity server, click Start > Programs > Administrative Tools > Terminal Services 
Client Creator.

Step 2 In the Create Installation Disk(s) dialog box, do the following:

• Click Terminal Services for 32-bit x86 Windows.

• Check the Format Disk(s) check box to erase any existing data on the disks, and then click OK.

Step 3 Follow the on-screen instructions to create the two install disks.

Step 4 Close the Create Installation Disk(s) dialog box.

To set up Windows Terminal Services Client on a remote computer

Step 1 On the remote computer, insert Disk 1 in the A drive, and run setup.exe.

Step 2 Follow the on-screen instructions to complete the installation.
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Step 3 On the Start menu, click Programs > Terminal Services Client > Client Connection Manager.

Step 4 In the Client Connection Manager window, click File > New Connection.

Step 5 Follow the on-screen instructions to complete the Connection Wizard.

To start a remote session with Windows Terminal Services

When you connect to the Cisco Unity server from a remote computer by using Windows Terminal 
Services, your computer controls the server. The Cisco Unity server screen appears within a window on 
your remote computer and, in general, you can access any of the server files and applications. It is 
recommended that the Cisco Unity server host only one Windows Terminal Services connection at a 
time. 

Step 1 On the remote computer, do one of the following:

• In the Client Connection Manager window, double-click the new connection icon that was created 
in the previous procedure.

• On the Start menu, click Programs > Terminal Services Client > {new connection icon}. If you 
changed the default location for the new connection icon, go to the location that you specified in the 
previous procedure.

Step 2 If required, enter the password for the new connection icon.

Step 3 Log on to the Cisco Unity Administrator with the appropriate name and password.

To perform file transfers

Step 1 On the remote computer, run \\{IP address for Cisco Unity server}\c$.

Step 2 Log on to the Cisco Unity Administrator with the appropriate name and password.

Step 3 Transfer files by using either copy-and-paste or drag-and-drop Windows commands.

To end a remote session with Windows Terminal Services

Step 1 On the remote computer, log off and exit the Cisco Unity Administrator.

Step 2 Close the Terminal Services Client {New Connection} window.

Step 3 When prompted, click OK to end the remote connection session.
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Windows Terminal Services Limitations

Using pcAnywhere
You can install pcAnywhere on the Cisco Unity server and on remote computer(s) that will be used to 
access the Cisco Unity server in your organization. Contact your reseller for the appropriate number of 
licenses.

Use the following procedures to set up and use pcAnywhere on a remote computer. For more detailed 
procedures or information about the other pcAnywhere capabilities that may be useful to you, refer to 
the pcAnywhere documentation.

To set up pcAnywhere on a remote computer

Step 1 Insert the pcAnywhere compact disc in the remote computer.

Step 2 Follow the on-screen instructions to complete the installation.

Step 3 On the Windows Start menu, click Programs > Symantec pcAnywhere, or double-click the desktop 
shortcut provided.

Step 4 In the pcAnywhere Manager window, double-click the Add Remote icon.

Step 5 From the Connection Info tab, do the appropriate action:

• If you are using a modem connection, check the appropriate box in the Device List to indicate the 
modem that is used by your remote computer. Then, click the Settings tab, and enter the phone 
number of the Cisco Unity server in the Use Dialing Properties and Phone Number fields.

• If you are using a LAN connection, confirm that TCP/IP is selected. Then, click the Settings tab, 
and enter the IP address for the Cisco Unity server in the Network Host PC to Control or IP Address 
field.

Step 6 If desired, enter or change other properties as needed on the remaining tabs.

Step 7 Click OK.

Step 8 Enter a name for the new Remote icon that you just created, and then press Enter.

Table 7-4 Windows Terminal Services Limitations with Cisco Unity

Remote Functionality Cisco Unity 4.0(1) and later

Add or delete a subscriber by using the 
Cisco Unity Administrator

Supported

Use the Cisco Unity Diagnostic Tool Supported

Use the Status Monitor in Tools Depot Supported

Set the dB level of recorded names and greetings 
by using the Set Volume utility

Not supported

Convert recorded names and greetings to a 
different codec by using the Set Wav Format utility

Not supported

Test the Cisco Unity-CM TSP Supported
7-17
Cisco Unity System Administration Guide (With Microsoft Exchange)

OL-3098-01



Chapter 7 Maintaining Cisco Unity
Accessing Cisco Unity Remotely
To start a remote session with pcAnywhere

When you connect to the Cisco Unity server from a remote computer by using pcAnywhere, your 
computer controls the server. The Cisco Unity server screen appears within a window on your remote 
computer and, in general, you can access any of the server files and applications. Before you start a 
remote session, confirm that pcAnywhere is running in host mode on the Cisco Unity server. If you plan 
to use a modem connection, confirm that there is no checkmark in the Launch With Windows check box 
on the Settings tab of the Host Properties dialog box.

Note that a Cisco Unity server can host only one pcAnywhere connection at a time.

Step 1 On the remote computer, double-click the desktop shortcut provided to start pcAnywhere.

Step 2 Double-click the new Remote icon that was created in the procedure, To set up pcAnywhere on a remote 
computer, page 7-17.

Step 3 If required, enter the password for the Remote icon.

Step 4 When it becomes available, click the listing for the Cisco Unity server that you want to access, and then 
click OK.

When a connection with the Cisco Unity server is established, the desktop of the Cisco Unity server 
appears, and the pcAnywhere online toolbar is displayed across the top of the screen.

Step 5 If desired, do the following actions to improve your connection speed:

• From the pcAnywhere online toolbar, click View/Modify Online Options.

• In the Online Options dialog box, click 16 Colors from the Color Scale menu, and then click OK.

Step 6 Log on to the Cisco Unity Administrator with the appropriate name and password.

To end a remote session with pcAnywhere

Step 1 On the remote computer, log off and exit the Cisco Unity Administrator.

Step 2 From the pcAnywhere online toolbar, click End Remote Control Session, and then click Yes.

Using a Virtual Private Network
A Virtual Private Network (VPN) is a private network that uses public phone lines (or in some cases a 
cable modem). Privacy is maintained through encryption and the use of secure protocols. When you use 
a VPN to access Cisco Unity through a firewall, you will be able to use Cisco Unity as if you were inside 
the network.

VPN is required to be able to:

• Access the Cisco Unity Administrator website (http://<Cisco Unity server name>/web/sa) from a 
remote computer outside your network firewall.

• Utilize the Media Master control bar to record voice names and greetings by using Distributed 
Component Object Model (DCOM) to connect your remote computer to the Cisco Unity server 
through a firewall. (If you are not using VPN for remote access, refer to the Microsoft website for 
information on configuring DCOM through a firewall.)

Discuss setting up a VPN with your LAN administrator.
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Moving Subscriber Mailboxes
From time to time you may need to move subscriber mailboxes to another server that is faster or has more 
disk space available, or you may want to move the mailboxes when you add new servers to your network. 
It is possible to move subscribers between servers without having to shut down Cisco Unity.

Caution If you are moving a group of subscriber mailboxes at once, confirm that you do not inadvertently select 
the Unity Messaging System, UAmis, or UOmni mailboxes. To move these special mailboxes, see 
“Moving the Unity Messaging System, UAmis, and UOmni Exchange Mailboxes” section on page 7-22.

If your Cisco Unity server is connected to Exchange 2000, you can follow the procedure offered in the 
Microsoft Exchange documentation to move mailboxes from one server to another. However, if your 
Cisco Unity server is connected to Exchange 5.5, you need to use the Bulk Logout utility to direct the 
Cisco Unity server(s) to log out of the mailboxes that you plan to move before you move them in 
Exchange. With the Bulk Logout utility, you can select the subscriber mailboxes that you want to log out 
of Exchange 5.5 on each Cisco Unity server in your site. You can select one or more of the following:

• All subscriber mailboxes.

• A group of subscriber mailboxes based on an extension range, membership in a public distribution 
list, an association with a class of service (COS), or an assigned phone system (in dual phone system 
environments).

• You can also use a comma-separated value (CSV) file to select subscribers based on their Exchange 
aliases. CSV is a common text file format for moving data from one data store to another. You can 
edit CSV files in a text editor or in a spreadsheet application. If you choose to select subscribers 
from a CSV file, format your file by using the following guidelines to ensure that it parses correctly:

– Separate values by commas. Do not use a tab, spaces, or a semicolon to separate values in the 
file.

– Include a column header titled “alias” in the first line. Column headers are not case sensitive, 
and can be formatted with spaces on the left, right, or on both sides.

For example:

first name, last name, home server, alias, domain
Alex, Abade, EXServer1, aabade, ENG_MAIN
Kelly, Bader, EXServer1, kbader, ENG_MAIN

To move multiple subscriber mailboxes between Exchange 5.5 servers while Cisco Unity is running, do 
the appropriate procedures, in the order listed. Note that if your Cisco Unity server is connected to 
Exchange 2000, you do not need to do these procedures. Instead, you can move Exchange 2000 
mailboxes by using the procedure specified in the Microsoft Exchange documentation.

To force Cisco Unity to log out of multiple Exchange 5.5 mailboxes

Step 1 Confirm that subscribers have exited Outlook and have logged off of Cisco Unity.

Caution The mailboxes that you plan to move must not be accessed until after they have been moved 
and the Exchange directory has replicated. Subscribers must understand not to start Outlook 
or to access Cisco Unity over the phone until notified by you that it is okay to do so. If 
mailboxes are accessed during this process, subscribers will be disconnected, and the 
Cisco Unity server may need to be restarted.
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Step 2 Start the Bulk Logout utility, available in Tools Depot, and then run it on the drive on which Cisco Unity 
is installed.

Step 3 In the Bulk Subscriber Logout window, select the subscribers that you want to log out of Exchange by 
doing one of the following:

• Click All Subscribers.

• Click Subscribers With Extension Numbers, and then enter the range in the From and To fields.

• Click All Subscribers in This Public Distribution List, and then click the distribution list from the 
list in the adjacent field.

• Click All Subscribers Associated With This Class of Service, and then click the COS from the list 
in the adjacent field.

• Click All Subscribers With Aliases in This CSV File, and then click Browse to locate the CSV 
file.

Step 4 Click Add Subscribers to Grid. The subscribers that you selected in Step 3 are displayed in the grid. 
(If you selected subscribers from a CSV file, note that only those subscribers with mailboxes associated 
with the local Cisco Unity server are displayed.)

Step 5 Repeat Step 3 and Step 4, if appropriate, to add additional subscribers to the grid.

Step 6 If necessary, check or uncheck the boxes next to each subscriber listed in the grid to add or remove 
subscribers from the group that you selected for log out.

Step 7 Click Log Out Subscribers, and follow the on-screen instructions. For the selected subscribers, 
Cisco Unity logs out of all Exchange mailboxes that are associated with the local Cisco Unity server.

Step 8 If subscribers are associated with more than Cisco Unity server, or if you are not sure which Exchange 
mailboxes are associated with which Cisco Unity servers in your site, repeat Step 2 through Step 7 for 
each Cisco Unity server in your site as necessary.

Step 9 Leave the Bulk Subscriber Logout window open, and continue with the procedure, To move 
Exchange 5.5 mailboxes, page 7-20.

To move Exchange 5.5 mailboxes

Step 1 On the Windows Start menu, click Programs > Microsoft Exchange > Microsoft Exchange 
Administrator.

Step 2 In the tree in the left pane, click Recipients, then click the name(s) of the subscriber(s) in the right pane.

Caution If you are moving a group of subscriber mailboxes at once, confirm that you do not 
inadvertently select the Unity Messaging System, UAmis, or UOmni mailboxes. To move 
these special mailboxes, see “Moving the Unity Messaging System, UAmis, and UOmni 
Exchange Mailboxes” section on page 7-22.

Step 3 Click Tools > Move Mailbox.

Step 4 In the Move Mailbox To list, click the server to which the mailbox(es) will be moved.

Step 5 Click OK to move the mailbox(es).

Step 6 Once the mailbox(es) have been moved, subscribers may not be able to access messages until the 
directory is updated. You can either force directory replication, or you can wait for the directory 
replication to occur automatically, depending upon your Exchange settings. 
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Before you force directory replication, it is a good idea to discuss this with the Exchange administrator 
for your site. If you decide to force directory replication, do so for the Cisco Unity server where the 
mailbox(es) used to reside and for the server to which the mailbox(es) were moved. Refer to the 
Microsoft Exchange 5.5 documentation for detailed procedures.

Step 7 Continue with the procedure, To synchronize the servers, page 7-21.

To synchronize the servers

Repeat the following procedure for each Cisco Unity server with subscribers that had their mailboxes 
moved in the previous procedure.

Step 1 In the Bulk Subscriber Logout window, click the Resynch Subscribers button, and follow the on-screen 
instructions. This step synchronizes the Cisco Unity cache with the Exchange 5.5 directory, logging 
Cisco Unity back into the subscriber mailboxes.

Step 2 Click Exit.

Step 3 Notify subscribers that they can log on to both Outlook and Cisco Unity.

To run the Exchange 5.5 Optimizer

If you have moved more than 100 subscribers in Exchange 5.5, run the Exchange Optimizer on the 
Cisco Unity server. Otherwise, you may encounter problems with Cisco Unity not accepting dialed 
extensions for subscribers and call handlers, and with conversation-related errors in the event log. If 
there are other Exchange servers in the site, you do not need to run the Exchange Optimizer on the other 
Exchange servers.

Step 1 Shut down the Cisco Unity server, if it is running.

Step 2 On the Windows Start menu, click Programs > Microsoft Exchange > Microsoft Exchange 
Optimizer.

Step 3 Follow the on-screen instructions. If the Exchange Optimizer recommends that you move files, you can 
safely choose not to do so.

Step 4 If the Exchange 5.5 Optimizer displays an error message saying that a service could not be shut down, 
do the following:

• Exit the Exchange Optimizer.

• Right-click the Cisco Unity icon in the status area of the taskbar, and click Exit.

• Start the Exchange Optimizer, and follow the on-screen instructions.

Step 5 When the Exchange Optimizer is finished, restart the Cisco Unity server.
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Moving the Unity Messaging System, UAmis, and UOmni 
Exchange Mailboxes

The Unity Messaging System, UAmis, and UOmni mailboxes are special Exchange mailboxes with 
specific functions. From time to time, you may need to move mailboxes to a server that is faster or has 
more disk space available, or you may want to move mailboxes when you add new servers to your 
network.

You use the same procedures to move the Unity Messaging System, UAmis, and UOmni mailboxes that 
you use to move ordinary subscriber mailboxes in Exchange—but with a few extra steps to prevent 
problems that can occur after these special mailboxes are moved.

To avoid inadvertently moving the Unity Messaging System, UAmis, or UOmni mailboxes when you 
move a group of subscriber mailboxes, consider changing their Exchange display names so the 
mailboxes are clearly identified as requiring “special” treatment.

The following sections describe the mailboxes and how to move them correctly.

Unity Messaging System Mailbox
When an unidentified caller—an outside caller or a caller from inside the organization calling from a 
phone that is not associated with a subscriber account (such as a conference room)—leaves a message 
for a subscriber, Cisco Unity gives the message to Exchange, which routes the message to the subscriber 
home server (if not the Cisco Unity server) and stores it in the subscriber mailbox. Such messages are 
identified as coming from the Unity Messaging System mailbox, which is homed on the server that 
Cisco Unity gives the message to, and has the display name Unity Messaging System.

For more information on the Unity Messaging System mailbox and its associated account, see the 
“Default Accounts” section on page 4-1.

To move the Unity Messaging System mailbox

Step 1 Use the same procedures that you use for moving ordinary subscriber mailboxes in either Exchange 5.5 
or Exchange 2000 as indicated in the “Moving Subscriber Mailboxes” section on page 7-19.

Step 2 To prevent messages from an unidentified caller—an outside caller or a caller from inside the 
organization calling from a phone that is not associated with a subscriber account (such as a conference 
room)—from getting stuck in the UMR after the move, do the following steps:

a. On the Windows Start menu, click Programs > Administrative Tools > Services.

b. From the Services window, stop and restart AvUMRSyncSvr, which is the Cisco Unity Messaging 
Repository (UMR) service.

Once the UMR service has restarted (it may take a few minutes), Cisco Unity exhibits the following 
behavior:

• Messages from unidentified callers that are addressed to subscribers who do not have full mailboxes 
are delivered.

• As expected, messages from unidentified callers that are addressed to subscribers who have full 
mailboxes are not delivered. However, when Cisco Unity attempts to send a nondelivery receipt 
(NDR), the NDR gets stuck in the Unity Messaging System mailbox, and is never forwarded to the 
Unidentified Messages distribution list.
7-22
Cisco Unity System Administration Guide (With Microsoft Exchange)

OL-3098-01



Chapter 7 Maintaining Cisco Unity
Cisco Unity Failover Feature
Step 3 To release any stuck NDRs from the Unity Messaging System mailbox, stop and restart Cisco Unity by 
using the system tray icon.

UAmis Mailbox
Outgoing AMIS messages are placed in the special Exchange mailbox that has the display name 
UAmis_<Servername>. For more information on the UAmis mailbox, refer to the “The UAmis Mailbox” 
section in the “AMIS Networking” chapter of the Networking in Cisco Unity Guide, available on 
Cisco.com, at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_installation_and_configuration_g
uide_books_list.html.

To move the UAmis mailbox

Step 1 Use the same procedures that you use for moving ordinary subscriber mailboxes in either Exchange 5.5 
or Exchange 2000 as indicated in the “Moving Subscriber Mailboxes” section on page 7-19.

Step 2 To prevent messages from getting stuck in the UAmis mailbox after the move, stop and restart 
Cisco Unity by using the system tray icon.

UOmni Mailbox
Administrative messages from the Cisco Unity Bridge to create, modify, or delete Bridge subscribers are 
placed in the special Exchange mailbox that has the display name UOmni_<Servername>.

To move the UOmni mailbox

Step 1 Use the same procedures that you use for moving ordinary subscriber mailboxes in Exchange 2000 as 
indicated in the “Moving Subscriber Mailboxes” section on page 7-19.

Step 2 On the Windows Start menu, click Programs > Administrative Tools > Services.

Step 3 From the Services window, stop and restart CsBridgeConnector, which is the Bridge Connector service.

The Bridge Connector monitors the UOmni mailbox. Restarting it immediately after the mailbox move 
ensures that the Active Directory contacts that are associated with Bridge subscribers are created 
correctly and messages do not get stuck in the UOmni mailbox. Once you have restarted the Connector, 
Bridge subscribers can be added, modified, and deleted without any problems.

Cisco Unity Failover Feature
Failover is a feature that provides a simple redundancy, allowing voice messaging functions to continue 
if the Cisco Unity server fails or when you need to perform maintenance. To set up failover, you install 
and configure Cisco Unity on two servers, a primary server and a secondary server.
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Under normal circumstances, the primary server is active—Cisco Unity answers phone calls and takes 
messages, sends message notifications, and turns message waiting indicators (MWIs) on and off. The 
secondary server is inactive—Cisco Unity is running, but it does not perform any voice messaging 
functions.

If the primary server fails or if the Cisco Unity service on the primary server stops, the secondary 
Cisco Unity server automatically becomes active and starts performing standard Cisco Unity operations. 
This shift from primary to secondary Cisco Unity servers is called failover. If you want to stop the 
primary Cisco Unity server for maintenance, you can also initiate failover manually.

For details, see the Cisco Unity Failover Configuration and Administration Guide, which is available on 
Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_installation_and_configuration_g
uide_books_list.html.

Backing Up and Restoring a Cisco Unity System
The software installed on a Cisco Unity server includes Windows 2000 Server, SQL Server 2000 or 
MSDE 2000, and, for some configurations, Exchange 2000. There are a number of suitable backup 
software products that are tailored to back up this software and the accompanying data. In addition, 
Cisco Unity includes a Disaster Recovery Tool that you can use to back up and restore Cisco Unity data.

For detailed information on backing up and restoring a Cisco Unity system, refer to the White Paper: 
Backing Up and Restoring a Cisco Unity System, available on Cisco.com at 
http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_technical_reference_list.html.

Cisco Unity Data and Message Storage
Information about subscriber accounts and other Cisco Unity data is stored in a SQL database on the 
Cisco Unity server. Additionally, a small subset of the Cisco Unity information is also stored in the 
directory. Cisco Unity keeps the information in the directory and in the SQL database synchronized.

The directory that Cisco Unity uses for data storage depends on what was selected when Cisco Unity 
was installed. During installation, you specify a “bridgehead” Exchange server for Cisco Unity to 
communicate with. This bridgehead server can be either an Exchange 5.5 or Exchange 2000 server and 
can be either on the same computer as Cisco Unity or on another computer. When the bridgehead server 
is an Exchange 5.5 server, the directory in which Cisco Unity stores data is the Exchange 5.5 directory. 
When Exchange 2000 is the bridgehead server, Cisco Unity stores data in Active Directory.

By storing its data in a SQL database, Cisco Unity derives many performance, reliability, and scalability 
benefits. Cisco Unity supports a Global Address List (GAL) of 250,000 users while maintaining current 
performance levels of the telephone user interface (TUI) in a networked configuration. This allows 
installations where the GAL is very large and Cisco Unity subscribers are a subset of the GAL.

Because very little information is stored in the directory, and because that information is not likely to 
change often, directory replication caused by changes to Cisco Unity data is minimal after the initial 
creation of subscriber accounts.

Cisco Unity functions when the network is down

In addition to the SQL database that contains subscriber names and extensions, the Unity Messaging 
Repository (UMR) is also on the Cisco Unity server. When an Exchange server or even the entire 
Exchange network is down, Cisco Unity can answer calls, allow unidentified callers to look up 
subscriber extensions, and take voice messages. While the e-mail system or network is off line, new 
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voice messages are stored in the messaging repository on the Cisco Unity server. During this time, 
subscribers checking their voice messages hear the UMR conversation, which explains that their 
Exchange server is not available but lets them access voice messages left since it went down. When the 
Exchange server or network is back on line, the voice messages stored in the messaging repository are 
routed to the subscriber mailboxes.
7-25
Cisco Unity System Administration Guide (With Microsoft Exchange)

OL-3098-01



Chapter 7 Maintaining Cisco Unity
Cisco Unity Data and Message Storage
7-26
Cisco Unity System Administration Guide (With Microsoft Exchange)

OL-3098-01


	Maintaining Cisco Unity
	Overview: Maintaining Cisco Unity
	Scheduling Maintenance Tasks
	Configuring Cisco Unity for Maintenance Tasks
	Status Monitor
	Event Notification Utility
	Monitoring Cisco Unity Performance


	Configuring Exchange for Maintenance Tasks
	Setting a Maximum Size for Exchange Mailboxes
	Exchange 2000
	Exchange 5.5

	Circular Logging in Exchange
	Monitoring the Message Transfer Agent

	Monitoring System Resources
	Scanning for Viruses
	Selecting Virus-Scanning Software
	Scheduling Virus Scanning
	Updating Virus-Scanning Definitions

	Managing the Location of Log Files and Database Files
	Performing Scheduled Maintenance on the Cisco Unity Server
	Forwarding Unaddressed Messages to the Appropriate Recipients
	Unaddressed Messages Distribution List
	System Event Messages Distribution List
	Operator, Opening Greeting, and Goodbye Call Handlers
	Example Interview

	Checking for Mailboxes that Are Over Their Size Limit
	Installing Service Packs and Updates
	Installing New Hardware and Drivers
	Updating the System Clock
	Restarting the Cisco Unity Server

	Accessing Cisco Unity Remotely
	Using Windows Terminal Services
	Windows Terminal Services Limitations
	Using pcAnywhere
	Using a Virtual Private Network

	Moving Subscriber Mailboxes
	Moving the Unity Messaging System, UAmis, and UOmni Exchange Mailboxes
	Unity Messaging System Mailbox
	UAmis Mailbox
	UOmni Mailbox

	Cisco Unity Failover Feature
	Backing Up and Restoring a Cisco Unity System
	Cisco Unity Data and Message Storage



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000500044004600206587686353ef901a8fc7684c976262535370673a548c002000700072006f006f00660065007200208fdb884c9ad88d2891cf62535370300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef653ef5728684c9762537088686a5f548c002000700072006f006f00660065007200204e0a73725f979ad854c18cea7684521753706548679c300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA <>
    /JPN <>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020b370c2a4d06cd0d10020d504b9b0d1300020bc0f0020ad50c815ae30c5d0c11c0020ace0d488c9c8b85c0020c778c1c4d560002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken voor kwaliteitsafdrukken op desktopprinters en proofers. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents for quality printing on desktop printers and proofers.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /NoConversion
      /DestinationProfileName ()
      /DestinationProfileSelector /NA
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /MediumResolution
      >>
      /FormElements false
      /GenerateStructure true
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles true
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /NA
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /LeaveUntagged
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


