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Utilities

About Cisco Unity Utilities
Cisco Unity provides utilities that you can use to troubleshoot problems. These 
utilities include:

The Integration Monitor Shows the information being sent between the phone 
system and Cisco Unity. See the “Integration Monitor” 
section on page 9-2.

Learn Tones Learns the frequency and cadence of the phone system 
tones and updates the phone system template file. See 
the “Learn Tones” section on page 9-7.

The Call Viewer Displays information about each call that the phone 
system integration sends to Cisco Unity. See the “Call 
Viewer” section on page 9-14.

The Cisco Unity 
Diagnostic Tool

Contains a database of possible Cisco Unity problems 
and controls the gathering of diagnostic traces used to 
troubleshoot these problems. See the “The Cisco Unity 
Diagnostic Tool” section on page 9-15.
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Integration Monitor
The Integration Monitor shows the information being sent between the phone 
system and Cisco Unity. Each packet of data contains information on one call that 
the phone system forwards to Cisco Unity. In some cases, seeing this data can 
help you diagnose integration problems.

With a serial integration, you can view the packets of data that are sent over the 
serial link. The Integration Monitor also displays the packets that Cisco Unity 
sends to the phone system, each of which contains one MWI on or off code.

With an analog integration, you can view the packets sent over the phone lines that 
connect the phone system and Cisco Unity.

When troubleshooting the Cisco CallManager integration, use the Call Viewer. 
The Cisco Unity Integration Monitor is not compatible with the CallManager 
integration. See the “Call Viewer” section on page 9-14 for more information.

To run the Integration Monitor

Step 1 Cisco Unity must be running for the Integration Monitor to display the packets 
being passed to and from the Cisco Unity server. If Cisco Unity is not running, 
start it.

Step 2 On the Windows Start menu, click Programs > Unity > Integration Monitor.

Step 3 Use the View menu to select display options. For more information, see the 
“Integration Monitor Display Options” section on page 9-4.

Advanced Settings Tool Allows updating of hidden registry settings and 
addition of new registry keys. See the “Advanced 
Settings Tool” section on page 9-17.

The Universal Dialogic 
Diagnostics utility 

Performs a wide range of tests on the Dialogic voice 
cards. See the “Universal Dialogic Diagnostics Utility” 
section on page 9-19.
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Values Displayed in the Integration Monitor
For information on the values and menu options that appear in the Integration 
Monitor, see Table 9-1.

 
Table 9-1 Integration Monitor Fields and Columns

Field/Column Meaning

Analog Integration or 
Serial Integration

Immediately below the menu bar, the Integration Monitor displays the name 
of the current integration and the integration type.

First Digit Delay (ms)

(analog integrations 
only)

The amount of time that Cisco Unity waits (in milliseconds) for the first digit 
of a packet to arrive after Cisco Unity answers a call. For example, to specify 
that the Integration Monitor wait three seconds for the first digit to arrive, 
enter 3000.

If you change this value, you are changing the value in the Cisco Unity phone 
system template file for the current integration. Changing this value may cause 
Cisco Unity to work incorrectly.

Next Digit Delay (ms)

(analog integrations 
only)

The amount of time that Cisco Unity waits between digits for the next digit of 
a packet to arrive. If the next digit does not arrive within that amount of time, 
Cisco Unity considers the next digit user input, and the Integration Monitor 
displays the digit on a new line (only when the Include digits option and 
Hang-up packet are defined). For example, to specify that the Integration 
Monitor wait two-tenths of a second for the next digit to arrive, enter 200.

If you change this value, you are changing the value in the Cisco Unity phone 
system template file for the current integration. Changing this value may cause 
Cisco Unity to work incorrectly.

Time The time at which Cisco Unity received the call from the phone system or the 
time at which Cisco Unity sent an MWI on or off code to the phone system. 
New packets appear at the top of the Integration Events list.

Packet The unformatted information that the phone system sent to Cisco Unity or that 
Cisco Unity sent to the phone system. The Integration Monitor uses the phone 
system template file to parse the contents of the packet into the values in the 
remaining columns.

Port The voice card port on the Cisco Unity server on which a call arrives from the 
phone system.
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Integration Monitor Display Options
The menus in the Integration Monitor let you save data to a file and change the 
display in a variety of ways, as described in Table 9-2.

Table 9-2 Integration Monitor Options

Menu Option Description

File Log to file To specify a file for saving Integration Monitor data.

Edit Allow delay 
edits

(analog 
integrations 
only)

To change the values in the First Digit Delay (ms) and Next Digit Delay (ms) 
boxes. If this option is not selected, the values are display only. For more 
information, see First Digit Delay (ms) and Next Digit Delay (ms) in 
Table 9-1.

View Always on 
top

To display the Integration Monitor window in front of all other windows 
regardless of which window is currently active.

To cancel the option, click it again.

View Include digits

(analog 
integrations 
only)

To display individual digits that are not recognized as part of a packet. For 
more information, see Next Digit Delay (ms) in Table 9-1.

View Freeze 
display

To prevent new data packets from being displayed in the Integration Monitor 
window. If Cisco Unity is busy, this option can be useful for analyzing an 
individual packet. Freezing the display prevents the packet from scrolling 
out of the window before you can look at it.

To unfreeze the display, click the option again.

View Raw serial 
data

(serial 
integrations 
only)

To display data from the phone system or from Cisco Unity regardless of 
whether the Integration Monitor recognizes the data as a valid packet. If no 
data is displayed in the Integration Monitor but you think it should be, try 
this option. There may be no display because the Integration Monitor is 
unable to determine what the pieces of the packets are.

To return to displaying formatted packets, click the option again.
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Integration Monitor Frequently Asked Questions

View Outgoing data

(serial 
integrations 
only)

To display only the packets that Cisco Unity is sending to the phone system 
to turn MWIs on and off.

To return to displaying all packets, click the option again.

View Incoming 
data only

(serial 
integrations 
only)

To display only the packets that the phone system is sending to Cisco Unity, 
including:

• Calls forwarded to Cisco Unity because the extension is busy.

• Calls forwarded to Cisco Unity because the extension is not answered.

• Calls forwarded to Cisco Unity because the extension is in do not disturb 
mode.

• Calls from subscribers who want to check or leave voice messages.

• Calls from external callers who called Cisco Unity.

To return to displaying all packets, click the option again.

Question Answer

Can I freeze the display? Yes. From the View menu, select Freeze Display.

Can I view raw serial data? Yes. From the View menu, select Raw Serial 
Data.

Can I view DTMF digits 
(analog only) separately from 
the packets?

Yes. From the View menu, select Include Digits, 
and confirm that the Hang-up packet is defined. 
This allows you to view all packets and all other 
DTMF digits detected by Cisco Unity, which 
can be helpful in troubleshooting DTMF 
integration packet problems.

Table 9-2 Integration Monitor Options (continued)

Menu Option Description
9-5
Cisco Unity Troubleshooting Guide

OL-1842-01



Chapter 9 Utilities
Integration Monitor
Integration Monitor Troubleshooting

To resolve a situation where no integration information is displayed for a serial or analog 
integration

Step 1 In the View menu, confirm that Freeze Display is not selected. If it is, deselect it. 
If it is not selected, continue with Step 2.

Step 2 In the Cisco Unity Administrator, click System > Switch.

Step 3 In the Set Active Switch Type section, verify that all values are correct for your 
phone system.

Step 4 Correct any incorrect values.

Step 5 If you changed values in Step 4, click Save, and continue with Step 6. If you did 
not change any values, skip to Step 7.

Step 6 Shut down and restart Cisco Unity.

Step 7 If you have a serial integration, confirm that the serial cable is plugged securely 
into the correct Cisco Unity COM port and into the phone system.

If you have an analog integration, in the Cisco Unity Administrator, click 
System >  Licensing > Licensed Features. Confirm that the analog integration is 
enabled on the system key.

If none of the steps in this procedure correct the problem, contact the Cisco 
Technical Assistance Center (TAC).

To resolve a situation where only partial packets are displayed (analog integrations only)

Step 1 From the Integration Monitor Edit menu, select Allow Delay Edits.

Can I log the integration 
packets in the Integration 
Monitor to a file?

Yes. From the File menu, select Log to File. 
Specify name and location of the file to receive 
the integration packet information.

Can the Integration Monitor 
be used with all Integrations?

No. The Integration Monitor can only be used 
for serial and analog integrations.
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Step 2 Increase the values in the First Digit Delay (ms) and Next Digit Delay (ms) boxes. 
For example, if the First Digit Delay (ms) is set to 2000, change it to 3000. And 
if the Next Digit Delay (ms) is set to 250, change it to 500.

Step 3 From the Integration Monitor Edit menu, select Allow Delay Edits again to save 
the changes.

Step 4 If partial packets still display, contact Cisco TAC for assistance in changing the 
OffHook delay parameter.

Learn Tones
Cisco Unity comes with template files for a variety of phone systems. These 
template files should work with most phone systems without modification. 
However, problems with transfers, message waiting indication, and message 
notification can arise if Cisco Unity does not understand the phone system tones. 
If any of these problems occur, and basic troubleshooting procedures do not 
correct the problem, run the Learn Tones utility to modify the phone system 
template file.

The Learn Tones utility is designed to run on systems equipped with Dialogic 
analog voice cards only. The Learn Tones utility also requires exclusive access to 
the ports. Do not run Learn Tones unless Cisco Unity is shut down.

The Learn Tones utility learns the frequency and cadence of the phone system 
tones, such as busy and ringback, and teaches them to Cisco Unity. Once you start 
the utility, the process is automatic. One voice messaging port calls other ports to 
generate the tones. The utility displays the tone settings already present in the 
phone system template file on start-up, and sets any missing items to the default 
values. Upon completion, it adds the learned tones of your choice to the phone 
system template file.
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Tones Defined in the Switch Configuration File
There are five different tones that can be defined in the Cisco Unity switch 
configuration file. These can be split into two categories. The first category is 
tones that are used during call progress. Cisco Unity listens for these tones when 
performing a transfer or making an outgoing call, but does not listen for these 
tones during the voice mail conversation or during recording. These tones are:

• Switch Dial Tone

• Switch Ringback Tone

• Switch Busy Tone

The other two tones are disconnect tones. Cisco Unity always listens for these 
tones during voice messaging conversation and during recording. If one of these 
tones is detected, it tells Cisco Unity that the caller has hung up, and Cisco Unity 
goes on hook. These tones are:

• Switch Disconnect Tone

• CO Disconnect Tone

There are usually no tone definitions in the switch configuration file when the 
Cisco Unity system is installed. Depending on the switch and integration being 
used, it is often unnecessary to define any tones in the switch configuration file. 
Cisco Unity uses a default set of definitions for tones that are not defined in the 
switch configuration file, and this default set works fine in most cases. When it is 
determined that a particular tone (or tones) must be defined in the switch 
configuration file, it is best to define only that tone. Defining tones that are not 
necessary for Cisco Unity to perform properly with a particular phone system can 
limit the ability of the voice messaging system to handle unexpected tones, such 
as unexpected disconnect tones sent from a central office.

Learning tones may resolve the problem when callers report being disconnected 
(hung up on) while they are recording a voice message. The default disconnect 
tone definitions in Cisco Unity have very large frequency and cadence deviations 
defined. While this allows the system to detect disconnect tones from a wide range 
of central offices, phone systems, countries, and so on, it also increases the chance 
that the voice of a caller will mistakenly be detected as disconnect tone, causing 
the voice messaging system to hang up on the call. Learning the disconnect 
tone(s) specific to the phone system in use can remedy this problem. Once the 
tone definition is in the switch configuration file, the deviations can be manually 
edited if fine tuning is desired.
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Switch Configuration File Location
The switch configuration.ini files are located in the \CommServer\Intlib folder on 
the Cisco Unity server. The active switch configuration file is based on the 
selections made in the Switch Selection page during Cisco Unity installation, or 
by any subsequent changes on the Switch page or made in the Edit Switch utility.

The file that Cisco Unity uses as the active switch configuration file is the “Switch 
Configuration File” located in the registry at HKLM > SOFTWARE > Active 
Voice > MIU > 1.0 > Initialization > Switch 0.

Running the Learn Tones Utility
Perform the following procedure to run the Learn Tones utility.

To run the Learn Tones utility (systems equipped with Dialogic analog cards only)

Step 1 In the Cisco Unity Administrator, click System > Switch.

Step 2 In the Set Active Switch Type section, verify all values. Correct any incorrect 
values for the phone system.

Step 3 If you changed values in Step 2, click the Save icon.

Step 4 Shut down Cisco Unity.

Step 5 On the Windows Start menu, click Programs > Unity > Learn Tones.

Step 6 Confirm that all ports and extensions are correct. Do not use a hunt group for the 
helper extension.

Step 7 Choose Manual mode or allow Learn Tones to run in Automatic (default) mode.

Both modes use port 1 as the primary learning port, and Automatic mode uses 
ports 2 and 3 as helper ports. Or, you can designate other helper ports by entering 
their port numbers and extensions. Extension numbers for ports 1, 2, and 3 are 
imported automatically from the Cisco Unity Administrator Ports page.

Use Manual mode when you want the primary port to call a specific extension 
rather than a helper port, or when some aspect of the phone system programming, 
such as forwarding when a line is busy, conflicts with the tone-learning process. 
The phone specified for Manual mode should be close to the Cisco Unity server, 
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so that you can see the on-screen prompts and operate the phone at the same time. 
To run in Manual mode, check the Manual Mode check box under Settings, and 
enter the extension of the phone you want to use in the Manual Ext field.

Step 8 Confirm that Delay Between Calls is set to the default value of 4000 ms. Delay 
between calls is the number of milliseconds that Learn Tones delays before 
making a subsequent call to learn or verify a tone.

Step 9 Confirm that Deviation Threshold is set to the default value of 15 percent. 
Deviation Threshold sets the deviation that is considered acceptable when 
learning individual tones. Tones outside the Deviation Threshold for any single 
field (frequency 1, frequency 2, on, off, and so on) are discarded.

Step 10 Confirm that Calls is set to the default value of 1.

Step 11 Confirm that Frames is set to the default value of 5.

Step 12 Confirm that Delay(ms) is set to the default value of 1500ms. Delay sets the 
amount of time between the completion of the action to cause a tone, and the 
beginning of learning the tone. The delay value avoids detection of stray events 
on the line during line state transitions.

Step 13 To learn dial tone, in the Dialtone section, click Learn. In Automatic mode, Learn 
Tones uses the following process to learn dial tone:

a. Goes off-hook on port 1.

b. Waits the number of milliseconds defined in Delay for dial tone.

c. Listens to and learns the tone on port 1.

d. Goes on-hook on port 1.

e. Waits the number of milliseconds defined in Delay Between Calls.

f. Listens to and verifies the tone on port 1.

g. Goes on-hook on port 1.

If a “Success” message appears at the conclusion of this process, continue with 
Step 14.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 14 To learn busy tones, in the Busy section, click Learn. In Automatic mode, Learn 
Tones follows this process to learn busy tone:

a. Goes off-hook on port 2.

b. Dials port 3 extension.
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c. Goes off-hook on port 3 to answer the call from port 2.

d. Goes off-hook on port 1.

e. Dials port 2 extension.

f. Waits the number of milliseconds defined in Delay for busy tone.

g. Listens to and learns the tone on port 1.

h. Goes on-hook on ports 1, 2, and 3.

i. Waits the number of milliseconds defined in Delay Between Calls.

j. Goes off-hook on port 2.

k. Dials port 3 extension.

l. Goes off-hook on port 3 to answer the call from port 2.

m. Goes off-hook on port 1.

n. Dials the extension of port 2.

o. Listens to and verifies the tone on port 1.

p. Goes on-hook on ports 1,2 and 3.

If a “Success” message appears, continue with Step 15.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 15 To learn switch disconnect tone, in the Disconnect section, click Learn. In 
Automatic mode, Learn Tones follows this process to learn disconnect tone:

a. Waits the amount of milliseconds defined as Delay between calls(ms).

b. Goes off-hook on port 1.

c. Dials port 2 extension.

d. Goes off-hook on port 2 to answer the call from port 1.

e. Delays for 2000ms (2 seconds).

f. Goes on-hook on port 2.

g. Waits the amount of milliseconds defined as Delay(ms) for disconnect tone.

h. Listens to and learns the tone on port 1.

i. Goes on-hook on port 1.

j. Waits the amount of milliseconds defined as Delay between calls.

k. Goes off-hook on port 1.
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l. Dials port 2 extension.

m. Goes off-hook on port 2 to answer the call from port 1.

n. Delays for 2000ms (2 seconds).

o. Goes on-hook on port 2.

p. Listens to and verifies the tone on port 1.

q. Goes on-hook on port 1.

If a “Success” message appears, continue with Step 16.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 16 To learn CO Disconnect tone, in the CO Disconnect section, click Learn. In 
Automatic mode, Learn Tones uses the following steps to learn CO disconnect 
tone:

a. Goes off hook on port 1.

b. Dials 9.

c. Waits the amount of milliseconds defined as Delay(ms) for CO Disconnect 
tone.

d. Listens to and learns the tone on port 1.

e. Goes on-hook on port 1.

f. Waits the amount of milliseconds defined as Delay between calls.

g. Goes off-hook on port 1.

h. Dials 9.

i. Listens to and verifies the tone on port 1.

j. Goes on hook on port 1.

If a “Success” message appears, continue with Step 17.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 17 To learn ringback tone, in the Ringback section, click Learn. In Automatic mode, 
Learn Tones uses the following steps to learn ringback tone:

a. Goes off-hook on port 1.

b. Dials the extension of port 2.

c. Waits the amount of milliseconds defined as Delay for ringback tone.

d. Listens to and learns the tone on port 1.
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e. Goes on hook on port 1.

f. Waits the amount of milliseconds defined as Delay between calls.

g. Goes off-hook on port 1.

h. Dials the extension of port 2.

i. Listens to and verifies the tone on port 1.

j. Goes on hook on port 1.

If a “Success” message appears, continue with Step 18.

If a “Failure” message appears, resolve the problem and repeat this step.

Step 18 The Learn Tones utility automatically verifies tones after it learns them, so there 
is no need to click the Verify All button before saving the learned tones.

Step 19 Click Save.

Step 20 In the dialog box that appears, check only the boxes of the tones you want to 
update in the switch configuration file, then click OK.

Step 21 To save the new tones directly to the active switch configuration file, accept the 
default file name. If you want to save the tones to a temporary file for comparison 
and then manually copy them to the switch configuration file at a later time, enter 
a file name of your choice. Click Open.

Step 22 Click Done to exit the Learn Tones utility.

Step 23 Restart Cisco Unity.

Troubleshooting the Learn Tones Utility
If the learn tones process fails, perform the following procedure.

To troubleshoot the Learn Tones utility

Step 1 Adjust the Delay(ms) setting for the tone that you are having trouble with. 1500 
to 2000 milliseconds is usually sufficient. Be careful not to make this delay too 
long as Learn Tones may fail to learn a tone, learn the wrong tone, or miss the tone 
altogether.

Step 2 If Automatic mode is not working, try Manual mode, or vice versa.
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Step 3 Unplug the line cord from port 1 of Cisco Unity and plug it into an analog phone. 
Use the same steps that the Learn Tones utility uses to manually recreate the 
condition that Learn Tones is listening to.

Step 4 If one or more tones are learned with the following cadence:

this indicates that the learned tone is continuous. When a tone with continuous 
cadence is saved to the switch configuration file, the cadence appears as:

TimeOn1=4000

TimeOnDeviation1=0

TimeOff1=0

TimeOffDeviation1=0

Cycles=0

This is intentional. To support voice card manufacturers other than Dialogic, the 
latter method must be used when defining a continuous tone in the switch 
configuration file. When Cisco Unity is restarted, the Miu translates the cadence 
back to the original settings if Dialogic cards are installed.

If you need assistance resolving these or other Learn Tones problems, contact 
Cisco TAC.

Call Viewer
For each call that the phone system integration sends to Cisco Unity, the Call 
Viewer displays one line of information. This information can be helpful when 
troubleshooting problems with the phone system integration.

When troubleshooting the Cisco CallManager integration, use the Call Viewer. 
The Cisco Unity Integration Monitor is not compatible with the CallManager 
integration.

On(ms) Dev Off(ms) Dev

2000 -2000 0 0
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To run the Call Viewer

Step 1 If Cisco Unity is not running, start it.

Step 2 On the Windows Start menu, click Programs > Unity > Call Viewer.

Step 3 Use the Call Viewer window to see call information that the phone system 
integration provides to Cisco Unity.

The Cisco Unity Diagnostic Tool
The Cisco Unity Diagnostic Tool allows creating and viewing of diagnostic log 
files to troubleshoot problems. It replaces the diagnostic log functionality in 
Maestro Tools, and allows the system administrator or TAC staff to selectively run 
diagnostic traces at two levels.

• Macro Traces. These are collections of component traces that help diagnose 
problems such as message waiting indicator and system problems.

• Micro Traces. These are the component traces. Each component has up to 32 
trace levels that can be individually selected.

The Cisco Unity Diagnostic Tool also allows the system administrator or TAC 
staff to perform the following tasks.

• Create new log files on demand. This makes troubleshooting problems easier. 
When a problem can be reproduced reliably, the system administrator can 
close all existing log files and create new log files prior to reproducing the 
problem. This eliminates many unnecessary and unrelated items from the 
logs.

• Configure log settings. The system administrator can adjust the maximum 
disk space allowed for all diagnostic log files. The default setting is 400 MB. 
The Logging Properties screen also allows the system administrator to 
disable all diagnostic output by clearing the Diagnostic Output check box.

• Gather standard logs. This option provides the ability to quickly gather all or 
selected Microsoft Windows and Cisco Unity logs.

• Disable all traces. This is a quick way to return diagnostic logs to their default 
settings after troubleshooting efforts are complete.
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• View the Event Log. The Event Log files for either the local computer or 
another computer can be viewed and exported.

To view and export diagnostic files using the Cisco Unity Diagnostic Tool 

Step 1 On the Windows Start menu, click Programs > Unity > Unity Diagnostic Tool.

Step 2 On the left pane of the Cisco Unity Diagnostic Viewer screen, click Processes. 
The node expands to list each process that uses log manager.

Step 3 Click a process node and then click a log file. The selected log file is formatted 
and displayed in the right pane.

Step 4 To export or save a copy of the log file, click Action > Export list. 

Step 5 Name the file and save it to a location of your choice in .txt or .csv format. 

To create Macro or Micro diagnostic traces for troubleshooting 

Step 1 On the Windows Start menu, click Programs > Unity > Unity Diagnostic Tool.

Step 2 On the Cisco Unity Diagnostic Viewer screen, click either the Configure Macro 
Traces icon, or the Configure Micro Traces icon, as appropriate for the traces 
you want to run.

Step 3 Follow the wizard on-screen instructions.

Step 4 On the Cisco Unity Diagnostic Viewer screen, click Start New Log Files.

Step 5 Reproduce the problem.

Step 6 View and export the results by using the following the steps in the previous 
procedure, To view and export diagnostic files using the Cisco Unity Diagnostic 
Tool.

Step 7 To turn off the traces set in Step 2, on the Cisco Unity Diagnostic Viewer screen, 
click the Disable All Traces icon.

Step 8 In the Disable All Traces Wizard screen, check the Disable All Traces check box, 
and click Finish.
9-16
Cisco Unity Troubleshooting Guide

OL-1842-01



Chapter 9 Utilities
Advanced Settings Tool
To access the Event Viewer on another computer

Step 1 Right-click the Event Viewer (local).

Step 2 Click Connect to Another Computer.

Step 3 Browse to select a computer from the list.

Step 4 Click OK.

Step 5 Select and view the log file.

Step 6 To export or save a copy of the log file, click Action > Export List. 

Step 7 Name the file and save it to a location of your choice in .txt or .csv format.

Advanced Settings Tool
The Advanced Settings Tool allows system administrators to safely edit many of 
the Cisco Unity hidden registry settings. It gives a brief overview of each setting, 
limits edits to specific value ranges, and ensures that edits are consistent with the 
installed Cisco Unity version.

To edit an existing hidden registry key

Step 1 Browse to the \CommServer\Utilities directory (the default location is drive C).

Step 2 Double-click UnityAdvancedSettingsTool.exe.

Step 3 In the Unity Settings pane, click the registry key to be edited.

Step 4 Enter a new value as appropriate.

To add a new registry key

Adding a new registry key to the database should be done only when indicated in 
the Cisco Unity documentation, or on the advice of Cisco TAC. Note that the add 
function can also be used to display information about existing registry settings.
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Step 1 Open a command prompt window, and navigate to the \CommServer\Utilities 
directory (the default location is drive C).

Step 2 Enter start unityadvancedsettingstool /addkey and press Enter. The Unity 
Advanced Settings page appears.

Step 3 On the Unity Advanced Settings page, click Add New Key.

Step 4 On the Add New Registry Key page, click Add New. Enter information in the 
following fields as appropriate.

 

Field Name Description

Index Display only. A read-only field that displays a unique 
number for each record in the database.

Short Description Enter a description of the registry key change (maximum 
of 250 characters).

Long Description Enter a description of the behavior change that the 
registry key invokes.

Key Path Enter the path to the directory where the key is stored. 
All values are assumed to be under 
HKEY_LOCAL_MACHINE.

If you need to set values outside of this registry branch, 
do not use this tool. Use Regedit instead.

Key Name Enter the name of the registry at the key path. In the rare 
case of a registry setting that is only the key path and not 
a key value, you can leave this field blank.

Key Type Select a value from the drop down list, as follows:

• REG_SZ—string values.

• REG_DWORD—number values.

• REG_BINARY—binary values (not used).

• NONE—for cases where the presence of the key 
path is all that is needed, rather than a key with a 
value. This value should be used rarely, if at all.

Minimum Value Enter the minimum allowable value, if the key type is a 
number. String values do not use this field.
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Step 5 Click Save, and then click OK.

Universal Dialogic Diagnostics Utility
The Universal Dialogic Diagnostics (UDD) utility performs a wide range of tests 
on the Dialogic voice cards. It is used to determine if something is wrong with one 
or more of the Dialogic voice cards in the Cisco Unity server.

To run the UDD utility

Step 1 On the Windows Start menu, click Programs > Dialogic System Software > 
Universal Dialogic Diagnostics Utility.

Step 2 Shut down the Dialogic Service.

Step 3 The UDD utility may display several warning or error messages. For each, choose 
the option that continues the process of starting the utility.

Step 4 Select the options required to perform all tests on all cards. The tests take 
approximately five minutes per card.

Maximum Value Enter the maximum allowable value, if the key type is a 
number. String values do not use this field.

Step By Enter the step for each value added to the drop down list, 
if the key type is a number. For example, if the minimum 
value is 0, and the maximum value is 100, a step by value 
of 20 will populate the drop down list with 0, 20, 40, 60, 
80, 100.

Minimum Unity 
Version

A list of all Cisco Unity versions 2.3 and later. Indicate 
if the registry key is not valid for versions earlier than a 
specified version.

Maximum Unity 
Version

A list of all Cisco Unity versions 2.3 and later. Indicate 
if the registry key is not valid for versions later than a 
specified version.

Field Name Description
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Chapter 9 Utilities
Universal Dialogic Diagnostics Utility
Step 5 When the tests are finished, the Done button becomes available. Click Done to 
display additional information on failed tests, if any.

Step 6 If you see errors that you do not know how to resolve, contact Cisco TAC.

Step 7 When you are finished reviewing test results, click Exit UDD.

Step 8 Shut down and restart the Cisco Unity server.
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