APPENDIX

Cisco MeetingPlace for Lotus Notes Template
Integration

Revised: February 2006, 0L-7246-02
This chapter includes the following sections:

e About Cisco MeetingPlace for Lotus Notes Template Integration, page B-1

e How to Modify the Lotus Notes Mail Template, page B-1

About Cisco MeetingPlace for Lotus Notes Template Integration

Release 5.3 adds Cisco MeetingPlace features to the Lotus Notes interface by modifying the default
Lotus Notes mail template, for example, mail6.ntf. During installation, a modified version of this
template (mail6x_xMP.ntf) is placed on your integration server in “Files to be put in your Domino server
data directory.”

After installation, you have two options for integrating the two template files:
¢ Copy the mail6x_xMP.ntf template file to your Domino server's data directory.

— After copying the template file, deploy the template to your Lotus Notes clients to make the
Cisco MeetingPlace interface available to your users.

e Use the mail6x_xMP.ntf template file to manually modify the mail6.ntf file.

— The mail6x_xMP.ntf file contains the extra LotusScript code that you will need to add to the
base mail template.

— After modifying your mail template with the new code, copy it to your Domino server and roll
out the template to your users.

How to Modify the Lotus Notes Mail Template

If you decide to modify the Lotus Notes mail template yourself, follow these guidelines:

e To reduce the risk of typographic errors, copy and paste the required LotusScript code sections from
MPmail6.ntf directly into your mail template.

¢ Do not modify existing LotusScript code. Only add the Cisco MeetingPlace code sections to existing
code in the template.
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B How to Modify the Lotus Notes Mail Template

Read the following sections for detailed instructions about the changes you need to make to the
Lotus Notes mail template:

e Modifying the wPreferences Form, page B-2

e Adding the webDlgJoinVoiceConf Form, page B-2

¢ Adding the MPNewPassword Subform, page B-3

e Adding the MPCalendarEntry and MPNotice Subforms, page B-3

e Copying the MeetingPlace Section Into the Calendar Entry Form, page B-4
e Copying the Cisco MeetingPlace Fields, page B-4

e Copying the Cisco MeetingPlace LotusScript Code, page B-5

e Modifying the Calendar Profile Form, page B-6

¢ Adding New MeetingPlace Script Libraries, page B-7

e Modifying the Notice Form, page B-7

¢ Modifying Existing Script Libraries, page B-8

e Adding the MeetingPlace Agents, page B-9

¢ Adding Cisco MeetingPlace for Lotus Notes Online Help, page B-9

Modifying the wPreferences Form

Step 1 In Designer, open the mail6.ntf template and choose the wPreferences form.

Step 2 On the left of the form, locate the Calendar section. It contains three hotspots: FreeTime, Entries, and
AutoProcess.

Step3  Move the cursor to the bottom of the list and enter MeetingPlace as a new hotspot.
Step4  Double-click the new MeetingPlace hotspot to choose it.
Step5 Choose Create > HotSpot > Action Hotspot.
Step6  In the Hotspot: Click the pane at lower right and enter the following formula for the click action:
REM "DNT";
@If($PreferencesPage = '""MeetingPlace'; @Return(""); '"");
FIELD $PreferencesPage := ""MeetingPlace'';
@Command([RefreshHideFormulas])

Step7  Save your changes to the mail6.ntf template.

Adding the webDIlgJoinVoiceConf Form

Restrictions

This procedure is only for Release 5.3 FCS
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Step 1
Step 2
Step 3

Step 4

How to Modify the Lotus Notes Mail Template

In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.
In the mail6x_xMP.ntf template, display the forms list.

Select and copy (Edit > Copy) the webDIgJoinVoiceConf form; then, switch to mail6.ntf and paste (Edit
> Paste) the form in to the mail6.ntf template forms list.

Save your changes to the mail6.ntf template.

Adding the MPNewPassword Subform

Restrictions

Step 1
Step 2

Step 3

Step 4

This procedure is only for Release 5.3 FCS.

In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.

In the mail6x_xMP.ntf template, choose Shared Code > SubForms to display the current list of
subforms.

Select and copy (Edit > Copy) the MPNewPassword subform; then, switch to mail6.ntf and paste (Edit
> Paste) the subform in to the corresponding subform list for mail6.ntf.

Save your changes to the mail6.ntf template.

Adding the MPCalendarEntry and MPNotice Subforms

Restrictions

Step 1
Step 2

Step 3

Tip

Step 4

This procedure is only for Release 5.3(0.120).

In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.

In the mail6x_xMP.ntf template, choose Shared Code > SubForms to display the current list of
subforms.

By choosing Edit > Copy, select and copy the MPCalendarEntry and MPNotice subforms; then,
switch to mail6.ntf and by choosing Edit > Paste, paste the subform in to the corresponding subform list
for mail6.ntf.

You can select multiple subforms simultaneously by depressing the Ctrl key.

Save your changes to the mail6.ntf template.
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B How to Modify the Lotus Notes Mail Template

Copying the MeetingPlace Section Into the Calendar Entry Form

Step 1
Step 2
Step 3

Step 4

Step 5

You must modify this form so that users who are scheduling meetings can see the Cisco MeetingPlace
fields.

In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.
In mail6.ntf, choose the Calendar Entry form.

Scroll down to the Scheduler section of the Calendar Entry form; then, click in the space above that
section to create an insertion point.

For Release 5.3 FCS, complete the following steps:

a. Switch to mail6x_xMP.ntf and locate the MeetingPlace section, above the Scheduler section. Copy
the MeetingPlace section (Edit > Copy).

b. Switch to mail6.ntf and paste the section (Edit > Paste) in to the template at the insertion point.
or

For Release 5.3(0.120), complete the following steps:

a. From the menu, choose Create > Resources > Insert Subform.

b. Choose MPCalendarEntry.

c. Click OK.

Save your changes to the mail6.ntf template.

Copying the Cisco MeetingPlace Fields

Restrictions

Step 1

Step 2

Step 3

Step 4

This procedure is only for Release 5.3 FCS.

In the mail6x_xMP.ntf Calendar Entry form, locate the Cisco MeetingPlace fields at the top of the form.
They are located in a block below the fields tmpRepeatConflictDates and DispDuration. The block of
Cisco MeetingPlace fields include the following:

Field MP_BeenProcessed, Field MP_ServerNames, Field MP_ServerAddress,
MP_ServerAddress_External, MP_AttachAddr, MP_NotesAuth, MP_DisableURL, MP_Prefix,
MP_Postfix, MP_CallLabel, MPIDLabel, MP_DaysAdvance, MP_UniqueMeetingID,
MP_UniqueMeetingIDs, MP_Telephone, MP_Database, MP_DOCID, MP_IsOnline, MP_Server,
MP_Server_Selected, MP_WebOnlyMeeting, MP_NOSHOW, MP_VideolP, MP_VideoISDN

Select the entire block of fields; then, choose Edit > Copy (or right-click the selected block and choose
Copy).
Switch to mail6.ntf, and locate the fields at the top of the Calendar Entry form. Place the cursor after the

last field; then, press Enter to create a new line. This is the insertion point for the new
Cisco MeetingPlace fields.

Paste the Cisco MeetingPlace fields in to the form (choose Edit > Paste, or right-click, Paste).
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Step 5

Step 6
Step 7

Step 8

How to Modify the Lotus Notes Mail Template

In the mail6x_xMP.ntf Calendar Entry form, locate the text line URL shortcut to Meeting, and the
MP_CTA field below it.

Select the text and field and copy them (Edit > Copy).

Switch to mail6.ntf and paste (Edit > Paste) the copied text and field in to the Calendar Entry form,
above the Body field, as follows:

LIRL ghortout to bMeeting:

Save your changes to the mail6.ntf template.

Copying the Cisco MeetingPlace LotusScript Code

Restrictions
This procedure is only for Release 5.3 FCS.
Step 1 In mail6x_xMP.ntf, in the Objects Tab, scroll to the top of the object list to display the Appointment
(Form). Expand this node if necessary to view all the objects under this form.
Step2  Choose the JS Header object in the Appointment (Form) sublist.
JEII:uiects ]Heference ] Appointment (Form) : U5 Header |
= B Appointment [Form] | |Bun IWEb j IJavaScript
# Window Title
< HTML Head Content if MeetingPlace Begin {3FEEEA45-5C02-11d3-BSDF-00 EI
£+ HTML Body Attributes
& \WeblQuenOpen . _ ]
& WebluenS ave war whdPdoin null;
& Target Frame war whPD ata = rull;
3 J5 Header ifear whiFP_CLICK_IMCLLIDE = ™ou have not checked the
# onHel IIIE in
$ ook ] (K. :
Step3  In the Programmer’s Pane to the right of the Objects tab, select all the LotusScript code located between
the “// MeetingPlace begin” and “// MeetingPlace end” comment lines; then, copy (Edit > Copy) the
selected code.
Step4  Switch to the mail6.ntf template’s Calendar Entry form, and locate the corresponding JS Header object
in the Appointment (Form) sublist.
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B How to Modify the Lotus Notes Mail Template

Step 5

Step 6

Step 7

Paste (Edit > Paste) the LotusScript code you copied from mail6x_xMP.ntf in to the Programmer’s Pane
for the mail6.ntf JS Header object.

Repeat Steps 2-5 for the following Appointment (Form) subobjects, copying Cisco MeetingPlace code
from the mail6x_xMP.ntf template and pasting it in to the mail6.ntf template:

e Queryopen
e Postopen

¢ Querysave
¢ Queryclose

Save your changes to the mail6.ntf template.

Modifying the Calendar Profile Form

Step 1
Step 2
Step 3

Step 4
Step 5

Step 6

Step 7
Step 8
Step 9

Step 10

Step 11

In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.
In the mail6x_xMP.ntf template, select the Calendar Profile form.

In the fields area at the top of the mail6x_xMP.ntf template, locate the two Cisco MeetingPlace fields
MP_ServerNames and MP_ServerAddress, in the last row of fields.

Select the two fields, and choose Edit > Copy.

Switch to the mail6.ntf template. In the field area at the top of the Calendar Profile form, add a new line
after the last row of fields.

Choose Edit > Paste to paste the two Cisco MeetingPlace fields in to the Lotus Notes mail template
Calendar Profile form.

Click the Calendar & To Do tab; then, click the MeetingPlace tab.

Select all text and fields on this tab; then, choose Edit > Copy.

Switch to the mail6.ntf template and insert a row by completing the following steps:
a. Click the Calendar & To Do tab.

b. Click the To Do tab and click inside this tab.

c. Choose Table > Insert Row.

Create a new tab by completing the following steps:

a. Click inside the newly created row.

b. Right-click and choose Table Properties.

c. Click the Table Rows tab.

d. In the Tab label and Caption field, enter MeetingPlace.

e. Close the Properties window.

Configure the properties of the newly created MeetingPlace tab by completing the following steps:
a. Click inside the MeetingPlace tab.

b. Choose Edit > Paste.

c. Click Yes.
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How to Modify the Lotus Notes Mail Template

Step12 Save your changes to the mail6.ntf template.

Adding New MeetingPlace Script Libraries

Step1  In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.

Step2  In the mail6x_xMP.ntf template’s Shared Code folder, click Script Libraries to display the list of Script
Libraries in the right pane of the window.

Step3  Locate the following Cisco MeetingPlace script libraries in the list:
e MeetingPlace
¢ MeetingPlaceBackGround
¢ MeetingPlaceBackGroundWeb
¢ MeetingPlaceGlobal
e MeetingPlaceWeb
Step4d  To select all the libraries, press Shift+Click; then, right-click the selection and choose Copy.
Step5  Switch to the mail6.ntf template, and open the Script Libraries list.
Step6  Right-click in the library list and choose Paste.

Step7  Save your changes to the mail6.ntf template.

Modifying the Notice Form

To display Cisco MeetingPlace information in an invitation, add the MeetingPlace section to the Notice
form as indicated in the following procedure:

Step1  In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.

Step2  For Release 5.3(0.120), copy the MeetingPlace section from the mail6x_xMP.ntf template and paste it
in to the mail6.ntf template as follows:

a. In mail6.ntf, choose the Notice form.

b. Scroll down to the Description section of the form. Click in the area above the Description line to
place the cursor. This is where you will insert the MeetingPlace section in to the form.

¢. From the menu, choose Create > Resources > Insert Subform.
d. Choose MPNotice.

e. Click OK.

or

For Release 5.3 FCS, copy the MeetingPlace section from the mail6x_xMP.ntf template and paste it in
to the mail6.ntf template as follows:

a. In mail6.ntf, choose the Notice form.
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B How to Modify the Lotus Notes Mail Template

Step 3

Step 4
Step 5

Step 6

Step 7

b. Scroll down to the Description section of the form. Click in the area above the Description line to
place the cursor. This is where you will insert the MeetingPlace section in to the form.

c. Switch to the mail6x_xMP.ntf template and scroll down to locate the MeetingPlace section of the
form. Choose the MeetingPlace section and copy it (Edit> Copy).

d. Switch to the mail6.ntf file and paste the MeetingPlace section in to the target location (Edit >
Paste).

In the Action Pane, choose Respond > Delegate.
e If the Action Pane is not visible to the right of the form, choose View > Action Pane.
Right-click the menu choice and choose Action Properties; then, click the Action when Hide tab.

Click Formula Window. In the Edit Formula window, scroll to the end of the current formula text, add
a space; then, add the following code to the script:

| MP_Include="1"

Modify the formulas for the following actions in the same way, adding the same script as in Step 5:
e Respond > Propose New Time
¢ Respond with Comments > Delegate

Save your changes to the mail6.ntf template.

Modifying Existing Script Libraries

B-8

Step 1
Step 2
Step 3

Step 4

Step 5

Step 6

You need to add Cisco MeetingPlace-specific code to the following functions in the following
Lotus Notes mail template script libraries:

Script Library Functions That Need Added Cisco MeetingPlace Code

Common Options, CSDocSave, CopyProfileValues, CSDocScanForUpdates
CSCalendarEntry Options, Declaration

CSEventClass Declarations, Options, RemoveFromMiniView

CSEventNotes Options, Declarations

CSEventWeb Options, Declarations

CSUIViewClass Options, ProcessViewCommand, ViewDragPasteHandler

In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.
In the mail6x_xMP.ntf template, choose Shared Code > Script Libraries.

For each library and function listed above, locate the Cisco MeetingPlace-specific code, between the
“MeetingPlace Begin” and “MeetingPlace End” comment lines.

By choosing Edit > Copy, select and copy the code (including comment lines, for later identification);
then, switch to mail6.ntf and by choosing Edit > Paste, paste the code in to the corresponding script
library functions in mail6.ntf.

In the mail6x_xMP.ntf template, choose Other > Database Resources; then, double-click the Database
Script library to open it.

Choose the Querydocumentdelete subquery.
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Step 7
Step 8

Step 9

How to Modify the Lotus Notes Mail Template

Locate the code between the “MeetingPlace Begin” and “MeetingPlace End” comment lines.

By choosing Edit > Copy, select the code (including comment lines, for later identification); then,
switch to mail6.ntf and by choosing Edit > Paste, paste the code in to the corresponding subquery in the
Database Script library in mail6.ntf.

Save your changes to the mail6.ntf template.

Adding the MeetingPlace Agents

Step 1
Step 2
Step 3

Step 4

In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.

In the mail6x_xMP.ntf template, choose Form > Shared Code > Agents.

For Release 5.3 FCS using any template other than 6.0.4, complete the following steps:
a. By choosing Edit > Copy, select the MPSendInvitations agent.

b. Switch to mail6.ntf and by choosing Edit > Paste, paste the agents in to the Forms > Shared Code
> Agents section of the mail6.ntf template:

or

Select and copy (Edit > Copy) the following agents; then, switch to mail6.ntf and paste (Edit > Paste)
the agents in to the Forms > Shared Code > Agents section of the mail6.ntf template:

e MPSendInvitations
e WebJoinMPVoiceConference
¢ WebMPOutDialVoiceConf

Save your changes to the mail6.ntf template.

Adding Cisco MeetingPlace for Lotus Notes Online Help

Step 1
Step 2
Step 3

Step 4

Step 5

The mail6x_xMP.ntf template contains an online help link in its About Database document that provides
access to HTML help pages for Cisco MeetingPlace for Lotus Notes. Copying and pasting the help link
in to your Lotus Notes mail template will allow you to access these help pages, which are installed with
Cisco MeetingPlace for Lotus Notes.

In Designer, open the mail6.ntf and mail6x_xMP.ntf templates.
In the mail6x_xMP.ntf template, choose Other > Database Resources.

Double-click the About DataBase document to open it; then, select and copy (Edit > Copy) the online
help link.

Switch to mail6.ntf and paste (Edit > Paste) the link in to the corresponding About Database document
in the mail6.ntf template.

Save your changes to the mail6.ntf template.
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B How to Modify the Lotus Notes Mail Template
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