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Overview

Introduction

The Workforce Management (WFM) InstallShield Wizard guides you through the
WFM installation. The installation includes the components listed in Table 1.

Table 1. Workforce Management Installation Components
Installation Components
Capture Services ¢ WFM Capture service

* WFM OOC Service

Compile Services e WFM Compile service
Process Services ¢ WFM Request service
Transaction Services * WFM Adherence RTE service

¢ WFM Adherence Conformity Calculator service
* WFM Sync service

* Apache Tomcat webserver

* WFM web application

* BIRT (Business Intelligence Reporting Tools)

¢ Omnis

These components are installed on a single server. See "Server Configurations" on
page 20 for more information.

After you have successfully installed WFM into a properly-configured Cisco Unified
Workforce Optimization (WFO) environment, the basic functionality of WFM is
ready to be configured for your use. Users access WFM through a web browser.

For information about configuring WFM, see the Workforce Management
Administrator User Guide.
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What's New in This Version

WFM 8.5(1) includes the following new feature.

Support for Cisco Unified Contact Center Express 8.0 and 8.5

WFM Documentation

The following documents contain additional information about WFM.

Workforce Management Administrator User Guide
Workforce Management Agent User Guide
Workforce Management Troubleshooting Guide
Workforce Management Reports Reference

Workforce Management Release Notes

Obtaining Documentation and Submitting a Service

Request

For information on obtaining documentation, submitting a service request, and
gathering additional information, see the monthly What's New in Cisco Product
Documentation, which also lists all new and revised Cisco technical documentation,

at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html|

(Click Obtaining Additional Information.)

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple
Syndication (RSS) feed and set content to be delivered directly to your desktop using a
reader application. The RSS feeds are a free service and Cisco currently supports RSS
version 2.0.

Documentation Feedback

You can provide comments about this document by sending email to the following
address:

ccbu_docfeedback@cisco.com

We appreciate your comments.
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Workforce Management Feature Levels

Workforce Management Feature Levels

This version of Workforce Management has only the Basic feature level.

June 2011 9



Workforce Management Installation Guide

Workforce Management Services

Workforce Management Adherence Conformity
Calculator Service

The Workforce Management Adherence Conformity Calculator (ACC) service
processes data from the daily schedule and agent status table and computes the
adherence and conformity percentages used in historical productivity reports.

Workforce Management Capture Service

The Workforce Management Capture service (Capture service) listens for historical
call data reports created by the Workforce Management Odysoft ODBC Collector (OOC)
service. When the Capture service detects a new report, it sends a compilation
request to the Compile service.

Workforce Management Compile Service

The Workforce Management Compile service (Compile service) listens for compilation
requests from the Capture service. The Compile service can compile historical data for
agents, services, or teams by day, week, month, or year for use in forecasting and
scheduling.

Workforce Management OOC Service

Every 30 minutes, the Workforce Management Odysoft ODBC Collector (OOC) service
(OO0C service) collects all of the call data for the preceding 30 minutes from the ACD
database using the Open Database Connectivity (ODBC) interface. The OOC service
then writes the call data into historical reports.

High availability (HA) configurations can use multiple data sources. The OOC service
always connects to the primary ACD node, however, and fails over to the secondary
node only if the first connection fails.

Workforce Management Request Service

The Workforce Management Request service (Request service) listens for user
requests to generate forecasts and schedules.
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Workforce Management Adherence RTE Service

m The Workforce Management RTE (Real Time Engine) service (RTE service)
allows WFM to display agent state information in the Supervisor Adherence
dashboard. To get real-time information on agent states, the RTE service uses
Advanced Contact Management Interface (ACMI) protocol for Unified CCX

Workforce Management Sync Service

The Workforce Management Sync service (Sync service) connects to the Unified CCX
node using the ACMI-based synchronization process. The Sync service retrieves and

processes configuration data, such as contact service queue (CSQ) configurations,
team configurations, and agent configurations.

Tomcat Service

The Tomcat Service enables desktop clients to access WFM.
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Port Usage

A WFM environment consists of one WFM server and two or more remote devices,
including the Unified CCX server and one or more client PCs.

Table 2 lists the software running on each of these devices in a Unified CCX

environment.

Table 2.

Configuration in a Unified CCX environment

Server

Hosted Software

WFM servers

e WFM services

* WFM application

¢ WFM instance of SQL Server

* Apache Tomcat

Unified CCX server

* Unified CCX

¢ Unified CCX instance of SQL Server

e CTl server (part of the RmCm subsystem)

Client PC

¢ Microsoft Internet Explorer 6, 7, or 8

Table 3 lists the TCP and UDP ports used by WFM and its components on the WFM

server.

NOTE: For more information about Apache Tomcat port usage, go to
http://tomcat.apache.org/tomcat-5.5-doc/index.html.

Table 3.

WFM Port Usage on WFM Server

Server application protocol

Destination port (listening)

Client application protocol

WFM instance TCP 1433 WFM Capture Service
of SQL Server TCP 1434 WFM Compile Service
WFM RTE Service
WFM Request Service
WFM Sync Service
Apache Tomcat
WFM RTE Service TCP 30001 (configurable) | ACMI Service (GED-188)
WFM Sync Service TCP 59011 unused
Apache Tomcat TCP 8087 HTTP
TCP 8017 AJP 1.3
TCP 8007 Shutdown port
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Table 4 lists the TCP and UDP ports used by WFM and its components on remote
devices in the WFM environment, including the Unified CCX server and one or more

client PCs.

Table 4.

WFM Port Usage on Remote Devices

Server application protocol

Destination port (listening)

Client application protocol

CTl server” TCP 42027 (configurable) | ACMI Service
Unified CCX instance TCP 1433 WFM Sync Service
of SQL Server TCP 1434

WFM RTE Service

TCP 42027 (configurable)

Unified CCX instance of
SQL Server

Apache Tomcat

TCP 8087
TCP 8017
TCP 8007

HTTP
AJP 1.3
Shutdown port

*You can set this port number in the System Parameters window of the Unified CCX
Administration web page. The parameter name for the port number is RmCm TCP Port.
For more information, see Managing System Parameters, Cisco Customer Response
Solutions Administration Guide.
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Overview
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This chapter describes the following requirements for WFM:

System Requirements (page 16)
Server Configurations (page 20)
Configuration Data (page 22)
System Capacity (page 24)
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System Requirements

The following tables list the minimum system requirements for the WFM server
and clients.

Cisco Unified Workforce Optimization Environment

Workforce Management is compatible with Quality Management (QM) and Monitoring
and Recording (MR) as outlined in Table 5.

Table 5. WFM/QM version compatibility
QM Version MR Version

WFM Version 24 25 2.6 2.7 8.0
8.0 No Yes No No No

8.1 No Yes No No No

8.2 No Yes No No No
8.3(1) No Yes No No No
8.3(2) No Yes No No No
8.3(3) Yes Yes Yes Yes No
8.3(4) Yes Yes Yes Yes Yes
8.5(1) Yes Yes Yes Yes Yes

System Environment

WFM 8.5 has been verified in the Cisco Unified Contact Center Express 8.0 and 8.5
environment.

Operating Environment

Server Requirements

Table 6 on page 17 displays the minimum operating system and hardware
requirements for WFM servers.
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NOTE: Running WFM on a platform other than a Cisco MCS or exact
equivalent server is not supported

Table 6. WFM server minimum requirements

Operating System Hardware

Windows Server 2003 | 3.4 GHz Dual Pentium 4

R2 2 GB RAM

150 GB hard disk space

Cisco Media Convergence Server (MCS) or equivalent*

VMware ESX ServerT 3.4 GHz Dual Pentium 4

3 GB RAM

200 GB hard disk space

Cisco Media Convergence Server (MCS) or equivalent

* For the latest information on supported MCS equivalent platforms (including IBM and HP), go to
http://www.cisco.com/en/US/products/hw/voiceapp/ps378/prod_brochure_list.html.

T WFM systems hosted on VMware have been tested for functionality only, not for scalability. Due to
the many possible virtual server configurations, and the possible impact of additional hosted virtual
servers on WFM, the actual server performance in the user’'s VMware environment is the
responsibility of the customer. Cisco support for performance and scalability issues is limited to
server-based deployments.If a problem occurs in a VMware deployment, the customer might be
required to shut down other sessions or reproduce the problem in a non-VMware configuration to
assist in isolating the issue.

Desktop Requirements

WFM is operating system-independent. The only requirement is that the OS can run
the supported web browsers (see "Third Party Software Requirements").

Third Party Software Requirements

Table 7 on page 18 displays the minimum third party software requirements for WFM
servers and where they are installed.

NOTE: WFM requires the Cisco Media Convergence Server (MCS)
platform to be a dedicated standalone server. Running other
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applications on the WFM server can adversely affect

performance.
Table 7. Minimum third party software requirements for the WFM server
Application Where Installed/Description
Microsoft SQL Cisco MCS platform
Server 2005

System configuration data is maintained using Microsoft SQL
Server 2005. The customer must purchase and install SQL
Server 2005. SQL Server 2005 is not installed as part of the
product and must be installed prior to deploying WFM.

See "Server Configurations" on page 20 for more
information.

Internet Explorer 6, | Cisco MCS platform: Internet Explorer is required to access
7 the WFM web application.

Internet Explorer 8
(32- or 64-bit)

Java 2 Runtime Cisco MCS platform: Java 2 Runtime Environment is required
Environment (JRE) | to run the Java Server Pages (JSP) used by the WFM
Standard Edition application. The version of JRE shipped with WFM meets the

Version 5.0 minimum requirements and is installed automatically on the
(v1.5.0_12) Cisco MCS platform.
BIRT v2.2.1 Cisco MCS platform: BIRT is an open source Eclipse-based

reporting system. The version of BIRT shipped with WFM
meets the minimum requirements and is installed
automatically. For more information about BIRT, see
http://www.eclipse.org/birt/phoenix.

JFreeChart v1.0.1 Cisco MCS platform: JFreeChart is an open source Java chart
library. The version of JFreeChart shipped with WFM meets
the minimum requirements and is installed automatically.
For more information about JFreeChart, see
http://www.jfree.org/jfreechart/.

Omnisv7.1 Cisco MCS platform: Omnis is a rapid application
development (RAD) tool. The version of Omnis shipped with
WFM meets the minimum requirements and is installed
automatically. For more information about Omnis, see
http://www.omnis.net.
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System Requirements

Table 7. Minimum third party software requirements for the WFM server (cont’d)
Application Where Installed/Description
Apache Tomcat Cisco MCS platform: Apache Tomcat is a web container, or
v5.5.9 application server that provides an environment for Java

code to run in cooperation with a web server. The version of
Apache Tomcat shipped with WFM meets the minimum
requirements and is installed automatically. For more
information about Apache Tomcat, see
http://tomcat.apache.org.

Desktop Requirements

Table 8 displays the minimum desktop software requirements for WFM and where
they are installed.

Table 8. WFM desktop minimum third party software requirements

Application Where Installed/Description

Internet Explorer 6, | WFM client desktops: Internet Explorer is required to access
7,0r8 the WFM web application.
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Server Configurations

The number of agents and associated voice traffic WFM can support is scalable. WFM
supports a single server configuration.

Single Server Configuration

A single server configuration has one automatic call distributor (ACD) cluster with all
Workforce Management services located on a single server (Figure 1 on page 21). The
single server configuration supports 150 concurrent users and 450 configured users.
The following components must be installed on the single server:

m  WFM Transaction Services (including Apache Tomcat, ACC service, BIRT,
Omnis, RTE service, and sync service)

m  WFM Process Services (including the Request Service)
m  WFM Capture Services (including the OOC Service and Capture Service)

m  WFM Compile Services (including the Compile Service)

NOTE: The Microsoft SQL Server 2005 must be installed on the
single server before you install the components.
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Figure 1. Single server configuration
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Configuration Data

The following data needs to be stored persistently and must be backed up on a regular
basis:

m  WFM database (hamed CWFM)

m  Customer-specific configuration files, such as the files in
C:\Program Files\Cisco\WFO_WFM\config

WFM database backups are independent of Unified CCX backup and restore or BARS
tools. Use standard SQL Server 2005 tools to manually back up and restore the WFM
database.

NOTE: If you are running Cisco Security Agent (CSA) on your WFM
server, shut CSA down before you back up the WFM database. If CSA
is running while you run SQL Server utilities to backup the WFM
database, the backup may fail.
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System Capacity

The system capacity for the WFM server can be defined by specific hardware and
software configurations. It is also defined by the number of users. User capacity is

defined as follows.

m Configured users—Any scheduled or recorded agent plus all other users with
active login rights to Workforce Optimization (WFO) applications (for example,
supervisors, managers, quality evaluators, or schedulers). The maximum
capacity for configured users is the total number of users that can be

configured in WFM.

m  Concurrent users—The users who are logged into WFM at any given time. The
maximum capacity for concurrent users is the total number of users that can

be logged into WFM at any given time.

Table 9 shows Workforce Management server capacities.

Table 9. Workforce Management server capacities

Server Configuration

Processor Intel 5140 2.33 GHz dual core 2 Intel 5140 2.33 GHz dual
core

Memory (RAM) 2 GB DDR 2/DDR 3 4 GB DDR 2/DDR 3

System Storage 40 GB HDD 40 GB HDD

Cisco MCS or Equivalent 7835 7845

Max Number Configured 450 900

Users

Max No. Concurrent Users 150 300

24
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Before You Install WFM

Overview

This chapter describes how to configure the WFM server before you install WFM.
This process consists of the following tasks.

m Installing Microsoft SQL Server 2005 (page 26)
m Creating a SQL Server Login for WFM (page 28)
m  Configuring Firewall Port Exceptions (page 29)
m  Configuring Regional Settings (page 31)

m Verifying Prerequisites (page 33)
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Installing Microsoft SQL Server 2005

26

You must install Microsoft SQL Server 2005 on the WFM server.

An abbreviated installation procedure is provided below. For detailed information
about how to install Microsoft SQL Server 2005, see the Microsoft SQL Server 2005

installation documentation.

Complete the Microsoft SQL Server 2005 Setup utility windows as shown in Table 10:

Table 10. Microsoft SQL Server 2005 Setup utility entries

Window

Complete as follows:

Registration
Information

Enter your name, company, and product key.

Components to Install

Select check boxes for:
e SQL Server Database Services
* Workstation Components

* Any other desired components

Instance Name

Select one of the following options:

» Default Instance. If you are upgrading from
WFM 8.0, you must select the Default instance.
WFM 8.0 required a default instance, and you
cannot upgrade from WFM 8.0 to a SQL environment
using a named instance.

¢ Named Instance. If you select this option, specify the
named instance.

Service Account

Select Use the Built-In System Account, then select Local
System from the drop-down list.

Under Start Services at the End of Setup, highlight
SQL Server, SQL Server Agent, and SQL Browser.

Authentication Mode

Select Mixed Mode.

Enter a password for the SQL Server System
Administrator (sa) logon.
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June 2011

Table 10. Microsoft SQL Server 2005 Setup utility entries (cont’d)

Window

Complete as follows:

Collation Settings

Under Collation Designator and Sort Order, select
Latin1_General from the drop-down list.

Select the Accent-sensitive check box. Do not select any
of the other check boxes.

NOTE: The SQL collation name is SQL_Latin1_General_
CP1_CI_AS. See
http://msdn2.microsoft.com/en-us/library/ms180175.
aspx for more information about SQL Server collation
settings.
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Creating a SQL Server Login for WFM

NOTE: If you are using an historical database (HDS) and an
administrative workstation (AW) database instead of a single
database, make sure the SQL Server login has access to both
databases.

NOTE: Store the WFM SQL Server login name and password in a safe
place. You will need this information for the WFM Configuration Setup
utility, which runs automatically after you install WFM.

To create a SQL Server login for WFM:

1.

On the SQL Server computer, start Microsoft SQL Server Management Studio
and log in.

In the Object Explorer pane, expand the SQL Server instance. Choose
Security > Logins.

3. Right-click Logins and choose New Login.

The Login—-New window appears.

5. On the General page, enter the login you want WFM services to use to

28

connect to SQL Server. Select SQL Server Authentication, enter a password,
and clear the Enforce password policy check box so that the WFM user
account does not expire.

On the Server Roles page, select dbcreator and sysadmin from the list of
server roles.

NOTE: The WFM SQL Server login must be able to create databases
and run the WFM administrative scripts.

Click OK. The new login is added to the list of logins in the right pane.

IMPORTANT: If this database user is modified (for example, name or
password are changed) after WFM is installed and configured to use
it, WFM must be reinstalled.
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Configuring Firewall Port Exceptions

June 2011

If Microsoft Windows Firewall is enabled when WFM is installed, the installation
process opens the firewall ports listed in Table 11.

If another firewall is used, or if you turn on the Windows Firewall after WFM is
installed, these ports must be opened manually. See your firewall documentation for

instructions.

Table 11.

Microsoft Windows Firewall port exceptions

Server Application
Protocol

Listening Port

Client Application
Protocol

WFM RTE Service”

TCP 30001 (configurable)

ACMI Service (GED-188)

TCP 42027 (configurable)

Unified CCX instance of
SQL Server

TCP 42027 (configurable)

Unified CCE instance of
SQL Server

RTA port configured when
the BCSI WFM REAL TIME
IMPLEMENTATION
package was installed

Avaya CMS

TCP 5000, 3000, or
10000

Default = 5000

Nortel Contact Center

Apache Tomcat

TCP 8087
TCP 8017
TCP 8007

HTTP
AJP 1.3
Shutdown port

* QOpen the ports listed here on the server where the WFM RTE service is installed.

NOTE: For a complete list of ports used in a WFM environment, see
Port Usage (page 12).

To add a port to the Microsoft Windows Firewall exceptions list:

1. On the WFM server where the applicable WFM service is installed, choose
Start > Settings > Control Panel > Windows Firewall.
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2. On the Exceptions tab, click Add Port. The Add a Port window appears
(Figure 2).
Figure 2. Add a Port window

add a Port |

IJze theze zettings to open a port through *windows Firewall. To find the port
nurnber and protocol, consult the docurmentation for the program or gervice yoL
want to uze.

M arme: I

Fart rumber: I

Change scope... | [ Canicel

3. Enter a name that describes the port, and then enter the port number. Select
the appropriate connection type (TCP or UDP), and then click OK.

4. Repeat steps 2 and 3 to add another port to the exceptions list.

5. When you are finished adding ports, click OK to close Microsoft Windows
Firewall.
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Configuring Regional Settings
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The OOC Service must use US English regional settings. If you are installing the
Capture Service on a server running a Windows operating system where US English
not the default setting, you must change the default regional settings to US English
the Windows registry.

To change the regional settings in the Windows registry:
1. Open the Windows registry on the Capture service server.
2. Navigate to the following registry key:
HKEY_USERS\.DEFAULT\Control Panel\International\
3. Ensure that the registry settings under the International key are as listed in
Table 12.

Table 12. Regional settings

Value Type Data
iCalendarType string | 1
iCountry string | 1
iCurrDigits string | 2
iCurrency string | O
iDate string | O
iDigits string | 2
iFirstDayOfWeek string | 6
iFirstWeekOfYear string | O
iLZero string | 1
iMeasure string | 1
iNegCurr string | O
iNegNumber string | 1
iTime string | O
iTimePrefix string | O
iTLZero string | O
Locale string | 00000409
NumShape string | 1

is
in
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Table 12. Regional settings (cont’d)

Value Type Data

s1159 string | AM

s$2359 string | PM

sCountry string | United States
sCurrency string | $

sDate string | /

sDecimal string

sGrouping string | 3;0
sLanguage string | ENU

sList string |,

sLongDate string | dddd, MMMM dd, yyyy

sMonDecimalSep string

sMonGrouping string | 3;0

sMonThousandSep | string |,

sNativeDigits string | 0123456789
sNegativeSign string | -
sPositiveSign string

sShortDate string | mm-dd-yyyy
sThousand string |,

sTime string | ;
sTimeFormat string | h:mm:ss tt
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Verifying Prerequisites

Active Directory Prerequisites
If you are using Active Directory, the WFM server must be part of the Active Directory
domain.
You also need the following information:

m Active Directory distinguished names and ports (if you are not using the
default port)

m Active Directory paths to the users

m  Common names (CN) from the Active Directory account and password

Unified CCX Prerequisites

If you plan to use Unified CCX, you must install and configure the following systems
before you install WFM.

m Cisco Unified Contact Center Express (Unified CCX)

m Cisco Unified Communications Manager (Unified CM) or Unified
Communications Manager Express (Unified CME)

m Cisco Unity server (if you use Cisco Unity)
m Unified CM IP address and port number
m CTl server IP address and port number (see "Port Usage" on page 12)
m  Quality Management (QM) server IP address (if you use QM)
m Unified CCX server IP address:
— Single node environment: use the primary server IP address

— High Availability (two node) environment: use the secondary server
IP address

m High Availability (two node) environment: use the secondary server IP address

WFM Prerequisites

To install WFM, you need the following information.
m  WFM server IP address

m  WFM SQL Server database username and password you used in "Creating a
SQL Server Login for WFM" on page 28
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m  SQL Server instance name you used in "Installing Microsoft SQL Server 2005"
on page 26 (if you did not use the default instance)
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Installing and Configuring WFM

Overview

This chapter describes how to install and configure WFM. This process consists of
the following tasks.

m Upgrading WFM (page 36)

m Installing WFM (page 38)

m Configuring WFM (page 43)

m  Configuring NT Authentication for Unified CCX (page 51)
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Upgrading WFM

36

You can upgrade WFM 8.0(n) and 8.2(n) to WFM 8.5(1).

To upgrade from WFM 8.0(n) and 8.2(n) to WFM 8.5(1):

1.

Schedule a maintenance period for installation.

NOTE: Because upgrading WFM requires temporarily stopping all
WFM services and processes on your WFM server, WFM is not
available to users and agents during an upgrade. Therefore, to limit
impact to a live WFM system, schedule upgrades after business
hours or during a maintenance period when your WFM system is out
of production.

Log into the WFM server as the local machine administrator.

NOTE: You can log into the WFM server remotely using Virtual
Network Computing (VNC) software. See the documentation that
came with your VNC software for instructions on establishing a
remote connection to another machine.

Run the old WFM version of WFM Configuration Setup and note the settings
you used when you installed WFM. Not all WFM settings are maintained
during the upgrade process. You must enter them again after you install the
upgrade.

Back up the old SQL Server WFM database using SQL Server backup tools.

NOTE: Do not remove the old SQL Server WFM database. The old SQL
Server WFM database is required during the upgrade process.
Backing up your database is recommended in case a problem occurs
during the upgrade.

Uninstall any service releases (SRs) applied to the old version of WFM. For
instructions, see "Removing a WFM Service Release" on page 64. Removing
an SR takes approximately 10 minutes, followed by a server reboot.

Uninstall the old version of WFM. For instructions, see "Removing WFM
Services" on page 65.Removing a WFM base release takes approximately
10 minutes. The system does not reboot.

NOTE: When you uninstall WFM, the WFM SQL Server database
instance remains.
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7.

Install WFM 8.5(1). For instructions, see "Installing WFM" on page 38.

NOTE: Installing the release, including the configuration setup, takes
approximately 30-40 minutes.

Configure WFM 8.5(1). For instructions, see "Configuring WFM" on page 43.

9. After installation and configuration, log into WFM as an administrator and test

10.

11.

your WFM system to ensure that it is working properly.

From the WFM interface, choose Agents > Agents. If the right pane displays a
list of agents, the synchronization was successful.

Log into the WFM server as the local machine administrator and navigate to
C:\Program Files\Cisco\WFO_WFM\log. Open the OOC Service log file
(<yyyymmdd>-ooCollector.log, where <yyyymmdd> is the date). Verify that the
log file does not contain any error messages.
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Install the WFM services according to the supported system configuration as
described in "Server Configurations" on page 20.
WFM Configuration Setup runs automatically after you install WFM.

IMPORTANT! Any time WFM Configuration Setup starts after an installation, it
must be run to completion in order for the system to function.

To install WFM:

1. Onthe WFM server, log in as the local machine administrator.

NOTE: You can log into the WFM server remotely using Virtual
Network Computing (VNC) software. See the documentation that
came with your VNC software for instructions on establishing a
remote connection to another machine.

2. If Cisco Security Agent (CSA) is running on your WFM server, shut CSA down
before you begin the installation process.

NOTE: If CSA is running while you install WFM, the installation might
fail.

3. Load the installation CD in the server computer, and then navigate to the CD
in My Computer or Windows Explorer.
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4. Double-click setup_WFM_<Version>.exe, where <Version> is the version
number associated with this release (for example, setup_WFM_833.exe), to
start the installation wizard. The Cisco Unified WFO Workforce Management
Services—InstallShield Wizard Welcome window appears (Figure 3).

Figure 3. InstallShield Wizard Welcome window

{5 Cisco Unified WFO Workforce Management Services - Installshield Wizard E3

Welcome to the InstallShield Wizard for Cisco
Unified WFO Workforce Management Services

The Installshield(R) Wizard will install Cisco Unified WEO
Workforce Management Services on your computer, To
continue, click Mext,

WARNIMNG: This program is protected by copyright law and
international treaties.

< Bark

Cancel |
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5. Click Next to continue. The Custom Setup window appears (Figure 4).

Figure 4. Custom Setup window

ji& Cisco Unified WFD Workforce Management Services - InstallShield Wizard

Custom Setup

Select the program Features wou want installed.,

Click on an icon in the list below to change how a Feature is installed.

[~ Feature Description
Installs the WEM web

) applications and the 'WFM

Capture Services Services; RTE and Svnc.

Compile Services

Process Services

This Feature requires 236ME on
wour hard drive.

Install bo:

CiProgram Files\Ciscol change... |
ImstallShield
Help Space < Back I Mext = I Cancel |

6. The default installation folder is C:\Program Files\Cisco. If you want to change
the default folder, click Change and follow the prompts.

NOTE: If you are upgrading from WFM 8.0, use the folder path
specified when WFM 8.0 was installed. WFM needs this folder path
when upgrading the SQL Server WFM 8.0 database.
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7. Click Next to continue. The Ready to Install the Program window appears
(Figure 5).

Figure 5. Ready to Install the Program window

ji& Cisco Unified WFD Workforce Management Services - InstallShield Wizard

Ready to Install the Program ol

The wizard is ready to begin installation,

Click Install to begin the installation.

I wou want to review or change any of wour installation settings, click Back. Click Cancel to
exit the wizard.

Imstallshield

< Back Cancel
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8. Click Install to continue. When the installation completes, the InstallShield
Wizard Completed window appears (Figure 6).

Figure 6. InstallShield Wizard Complete window

{5 Cisco Unified WFO Workforce Management Services - Installshield Wizard E3

InstallShield Wizard Completed

The Installshield Wizard has successfully installed Cisco Unified
WD WWorkforce Management Services, Click Finish to exit the
wizard,

< Bark

Camee| |

9. Click Finish to close the InstallShield window. WFM Configuration Setup is
launched automatically. See "Configuring WFM" on page 43 for more
information on WFM Configuration Setup.

NOTE: If a dialog appears asking you to restart your server, Click No
to dismiss the dialog box. Complete the WFM Configuration Setup
utility and then restart the server.

10. If present on the server, restart Cisco Security Agent.
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After you have installed the WFM server, WFM Configuration Setup is used to
configure the WFM environment. WFM Configuration Setup has two modes:

Initial mode—WFM Configuration Setup is launched automatically in initial

mode after the WFM installation finishes. After you configure all of the

required parameters and exit WFM Configuration Setup, the WFM services

are started automatically and the system is ready for use.

Update mode—WFM Configuration Setup can be launched manually when you

want to change configuration settings in an existing system. See Launching
WFM Configuration Setup Manually on page 51 for instructions. In update

mode you cannot modify the WFM database hostname/IP address or

instance name or enable/disable Active Directory. To change those settings,

you must reinstall WFM.

The following is a list of all possible steps that can appear when you run WFM
Configuration Setup in either initial or update mode.

NOTE: Some steps trigger actions and do not display windows that
contain fields to be completed.

WFM Database Step (page 49)

Create WFM DB—action only. This step creates the WFM database.
WFM Server Step (page 50)

ACD Connection Step (page 44)

QM Connection Step (page 48)

Administrator Password Step (page 47)

Active Directory Step (page 46)

Start Services—action only. This step starts all the WFM service.

Finish Configuration—action only. This step configures the WFM Windows
registry settings
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ACD Connection Step
The ACD Connection step (Figure 7) configures which ACD is used with your WFM

44

system.

Figure 7. ACD Connection step

WFM Database
Create \WFM DB

QM Connection
Active Direckory
Start Services

Select:

Instance name ICRSSQL
Primary IP Address IID. 192,252.24
Secondary IP Address IID. 192,252.24

Database Mame Idb_cra

CTI Servers

=10l x|

ACD Platform

User name [334LICCH7

Passward Ia—a—wa—a—a—a—wa—

Client Lacale [en_UUS.CP1252

Server Locale Ien_US.S?S?Z

1P Address I Part I
10.192.252.24 42027 |

Add | Bemaove |

PREVICUS | HEXT |

Complete the following fields listed in Table 13:

Table 13. ACD Connection step (Nortel ACD) fields

Field

Description

Select ACD

Select the version of Unified CCX used at your site.
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Table 13. ACD Connection step (Nortel ACD) fields (cont’d)

Field

Description

Instance Name

Enter the instance name of the Unified CCX database.
When typing the database instance name, use the
following guidelines:

¢ Convert all uppercase characters to lowercase
characters

* Replace all hyphens with underscores

If the host name starts with a number, add the prefix
i

* Append _uccx to complete the instance name

For example, if your host name is 80-ABC, your instance
name will be i80_abc_uccx.

Primary IP Address

Enter the IP address of the primary ACD.

Secondary IP Address

Enter the IP address of the secondary ACD, if this is a
redundant system.

Database Name

Enter the name of the Unified CCX database.

User Name The database authorized user name. Type uccxhruser in
this field.

Password The password for the authorized database user.

Client Locale The client locale that is configured in Unified CCX. The

locale for US English appears by default in this field. If
the client locale is changed in Unified CCX, then it must
also be manually changed in Configuration Setup.

Server Locale

The server locale that is configured in Unified CCX. The
locale for US English appears by default in this field. If
the server locale is changed in Unified CCX, then it must
also be manually changed in Configuration Setup.

CTI Server

The CTl server(s) and port(s) associated with your
system. to add a CTl server to the list, click Add and
enter the CTl server IP address and port, then click OK.
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Active Directory Step
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The Active Directory step (Figure 8) configures access to your Windows Active
Directory.

Figure 8. Active Directory step

£ workforce Management - Configuration Setup

WM Database r
ACD Connection Active Directory

QM Connection
Adrinistrator Password

& ity Domain Information

Start Services
Finish Configuration

Base DM |

1P Address I

Part [52

User Mame (With Read Access) I

User Password I

User Search Base I

Alternate Domain

1P Address I

Part [250

PREVICUS | MEXT |

Complete the following fields listed in Table 14:

Table 14. Active Directory step fields

Field Description

Use Active Directory Select the check box to use Active Directory.

Note: If you are upgrading from a previous version of
WFM, you cannot change using or not using Active
Directory. You must configure the upgrade to the same
settings as defined in the previous version of WFM.

Domain Information

Base DN The location in the directory server tree under which all
active directory users are located.

IP Address The IP address of the Active Directory server.

Port The port number of the Active Directory server.

User Name (with Read The display name as configured in Active Directory of a

Access) user with read access to the Active Directory database.
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Table 14. Active Directory step fields (cont’d)

Field

Description

User Password

The user’s password.

User Search Base

The path to organizational units (OU) for user records.
The path must be specified from the most specific to the
least specific (from left to right in the path statement).
For example:

ou=Users,ou=Minneapolis,ou=Minnesota,ou=US

Alternate Domain

IP Address The redundant Active Directory server’s IP address, if
there is one.
Port The redundant Active Directory server’s port.

Administrator Password Step

June 2011

The Administrator Password step (Figure 9)creates the password used by the WFM
administrator to access the application. This step appears only in Initial Mode.

Figure 9. Administrator Password step

WFM Database
ACD Connection
QM Conneckion

Edrinisteaitor
Ackive Direckory
Start Services
Finish Configuration

£ workforce Management - Configuration Setup =] B3 I

Administrator Password

Mew Administrator Password ||

Confirm Administrator Password I

PREVICUS | HEXT |

Enter the WFM administrator password in the New Administrator Password and
Confirm New Administrator Password fields.
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NOTE: Store this password in a safe place. You will need it to log into
WFM as an administrator. The password can be changed using WFM

Administrator.

QM Connection Step
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The QM Connection step (Figure 10) is used if you are using the Cisco Quality
Management part of the Cisco Workforce Optimization suite.

Figure 10.

WFM Database
ACD Connection

Active Direckory
Start Services

£ workforce Management - Configuration Setup ;IEI.E'

Host Mame ar IP I

DE Instance Mame (blank = default) I

QM Connection step

QM Connection

" Host Mame (% IP Address

Database Mame l

User Mame I

Passward I

PREVICLIS | HEXT |

Select the Quality Management is Installed check box if you are using QM, and then
complete the fields as follows.

Table 15.

QM Connection fields

Field

Description

Host Name/IP Address

Select if you are entering a host name or IP address

Host Name or IP

The host name or IP address of the QM Base server

DB Instance Name
(blank = default)

The name of the QM database instance (leave blank if
you are using the default name)

Database Name

The name of the QM database
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Table 15. QM Connection fields

Field Description

User Name The name of a user with access to the QM database.
This user can have read or read/write access to the
database.

Password The user’s password

WFM Database Step
The WFM Database step (Figure 11) configures access to the WFM database.

June 2011

Figure 11. WFM Database step

wiEH Database

Create \WFM DB

“WFM Server

ACD Connection

QM Conneckion
Administrator Password
Ackive Direckory

Start Services

Finish Configuration

i workforce Management - Configuration Setup

WFM Database

" Host Mame (* IP Address

Host Mame or IP ||

DE Instance Mame |<default instance =

User Mame I

Passward I

PREVICUS | HEXT |

Complete the following fields listed in Table 16:.

Table 16. WFM Database step fields

Field

Description

Host Name or IP
Address

Select if you are entering a host name or IP address of
the machine that hosts the WFM database.

Host Name or IP

The host name or IP address of the machine that hosts
the WFM database.
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Table 16. WFM Database step fields (cont’d)

Field

Description

DB Instance Name

The WFM database instance name.

If this is a new installation of WFM, this field is
prepopulated with the text “<default instance>". Use the
default value, the named instance, or leave the field
blank. Leaving the field blank is the same as using the
default instance.

NOTE: If you are upgrading from a previous version of
WEFM, do not enter a named instance in this field. Use
the prepopulated text “<default instance>.”

User Name User name with access to SQL Server. The user is the
one created when installing Microsoft SQL Server 2005.
See "Creating a SQL Server Login for WFM" on page 28.
Password User’s password.
WFM Server Step
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The WFM Server step (Figure 12) configures the IP address of the server where WFM
is installed. It appears only if Configuration Setup detects that there is more than one
network interface card (NIC) on the server. Select the appropriate IP address from the

drop-down list.

Figure 12.

< Workforce Management - Configuration Setup

WEFM Server step

CEX

WFM Server

IP Address of Local Machine [ 11.22.333.44 v|

11.22,333.44
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Launching WFM Configuration Setup Manually

To launch WFM Configuration Setup manually:

1. Navigate to C:\Program Files\Cisco\WFO_WFM\bin. This is the default
location. Your system might use a different location.

2. Run the executable file, postinstall.exe.

Configuring NT Authentication for Unified CCX

You must complete the following steps after you install WFM and before you start
using WFM to administer users.

m Step 1. Creating WFM Users for the Unified CCX Database (page 51)
m  Step 2. Configuring the OOC Service to Run as the New User (page 53)
m Step 3. Granting the New User Access to the Unified CCX Database (page 54)

m  Step 4. Verifying the Database Connection to the Unified CCX Database (page
54)

Step 1. Creating WFM Users for the Unified CCX
Database

On both the WFM server and the Unified CCX server, create Windows logins that WFM
can use to connect to the Unified CCX database.

NOTE: The WFM user must also have write access to the folder
C:\Program Files\Calabrio\WFO_WFM\log on the WFM server so the
WFM services can write to log files in the directory.

To create WFM users for the Unified CCX database:
1. Onthe WFM server, create a new user by completing the following steps.

a. From the Start Menu, choose Programs > Administrative Tools >
Computer Management.

b. Expand Local Users and Groups. Right-click Users and choose New User.
c. Enter a user name and password.

d. Clear the User Must Change Password at Next Logon check box and
select the Password Never Expires check box.

e. Click Create, then Close. The new user is added to the list of users.
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2. Onthe WFM server, add the new user to the Administrator group by

completing the following steps.

a.

Right-click the name of the user you just created and choose Properties.
The user properties dialog box appears.

Go to the Member Of tab and click Add. The Select Groups dialog box
appears.

Click Advanced. Another Select Groups dialog box appears.
Click Find Now. A list of groups appears.

Highlight the Administrators group and click OK twice to close both Select
Groups dialog boxes.

Click OK again to close the user properties dialog box, then click the close
window icon to close the Computer Management window.

3. On the WFM server, grant the new user permission to log on as a service by

completing the following steps.

a.

h.

Choose Start > Programs > Administrative Tools > Local Security Policy.
The Local Security Settings window appears.

In the left pane, choose Local Policies > User Rights Assignment.

In the right pane, double-click Log on as a service. The Log on as a service
Properties dialog box appears.

Click Add User or Group. The Select Users, Computers, or Groups dialog
box appears.

Click Advanced. The Select Users or Groups dialog box appears.
Click Find Now. A list of users and groups appears.

Select the name of the new user from the list, click OK twice to close the
Select Users or Groups dialog boxes, then click OK to close the Log on as
a service Properties dialog box.

Choose File > Exit to close the Local Security Settings window.

4. On the Unified CCX server, create a new user by completing the following
steps.

a.

From the Start Menu, choose Programs > Administrative Tools >
Computer Management.

Expand Local Users and Groups. Right-click Users and choose New User.

Enter a user name and password.

NOTE: Use the same name and password for the new user that you
used on the WFM server in step 1.
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d. Clear the User Must Change Password at Next Logon check box and
select the Password Never Expires check box.

e. Click Create, then Close. The new user is added to the list of users.

5. On the Unified CCX server, add the new user to the Administrators group and

the Users group by completing the following steps.

a. Right-click the name of the user you just created and choose Properties.
The user properties dialog box appears.

b. Go to the Member Of tab and click Add. The Select Groups dialog box
appears.

c. Click Advanced. Another Select Groups dialog box appears.
d. Click Find Now. A list of groups appears.

e. Highlight the Administrators group and the Users group and click OK twice
to close both Select Groups dialog boxes.

f. Click OK again to close the user properties dialog box, then click the close
window icon to close the Computer Management window.

Step 2. Configuring the OOC Service to Run as the

New User

Use this procedure to configure the OOC service to run as a new user.

To configure the OOC service to run as the new user:

1.

On the WFM server on which the OOC service is installed, choose Start >
Programs > Administrative Tools > Services.

Right-click the name of the OOC Service and choose Properties. The
properties dialog box appears.

3. Click Stop and wait for the service to stop.

4. On the Log On tab and select This Account. Enter the name and password of

June 2011

the Windows user you created in Step 1, and then click OK.

On the General tab, click Start to restart the service. The service must be
restarted for your changes to take effect.

After the service starts, click OK to dismiss the properties dialog box for the
service.

Choose File > Exit to close the Services Management Console.
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Step 3. Granting the New User Access to the
Unified CCX Database

To grant the new user access to the Unified CCX database:
1. On the Unified CCX server, start Microsoft SQL Server Enterprise Manager.

2. Under the Unified CCX instance, choose Security > Logins. A list of Windows
and SQL Server users who have permission to access the databases in this
instance appears.

3. Right-click Logins and choose New Login. The SQL Server Login Properties -
New Login dialog box appears.

4. Click the button to the right of the name field to browse for the new user you
created in Step 1 (page 51). A second SQL Server Login Properties - New
Login dialog box appears.

5. Select the machine name from the List Names From list. A list of users and
groups defined on the machine appears.

6. Select the new user, then click Add. The user name appears in the Add
Name field.

7. Click OK to dismiss the second SQL Server Login Properties - New Login
dialog box.

8. On the Database Access tab, select the Permit check box for the side A
database, then select the Permit in Database Role check box for db_
datareader.

9. Ifthere is a side B database, select the Permit check box for the side B
database, then select the Permit in Database Role check box for db_
datareader.

10. Click OK to dismiss the SQL Server Login Properties - New Login dialog box.

11. Choose Console > Exit to close SQL Server Enterprise Manager.

Step 4. Verifying the Database Connection to the
Unified CCX Database

To verify the database connection from WFM to the Unified CCX database:

1. Enter the following URL in your web browser, where <wfm> is either the name
or the IP address of the server where WFM is installed.

http://<wfm>:8087/c3/
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NOTE: The website address is case sensitive.

The Workforce Management login window appears.

. Enter administrator in the username field and the password that you

specified in WFM Configuration Setup (see "Administrator Password Step" on
page 47), then click GO or press the Enter key. The Workforce Management
window appears.

. Choose Agents > Agents. If the right pane displays a list of agents, the

synchronization was successful.

. Navigate to C:\Program Files\Cisco\WFO_WFM\log. Open the O0C Service

log file, which is named <yyyymmdd>-ooCollector.log, where <yyyymmdd> is
the date. Verify that the log file does not contain any error messages. If there
are error messages, correct the errors before proceeding.
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The WFM forecasting feature uses your contact center’s historical contact data to
estimate future call volume and scheduling requirements. The OOC Service
retrieves data automatically every 30 minutes, starting from the time you installed
WEM.

If you want to use historical contact data from the time before you installed WFM,
you must complete the procedures in this chapter to capture the data manually.

For more information about the forecasting feature, see Workforce Management
Administrator User Guide for Cisco Unified Workforce Optimization.

NOTE: You must complete the procedures described in this
chapter immediately after you install WFM.
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Capturing Skill Group Historical Call Data for

Unified CCX

To capture skill group historical call data for Unified CCX:
1. From the WFM server, choose Start > Programs > Cisco> WFO > WFM > OOC.

The Odysoft ODBC Collector window appears (Figure 13).

Figure 13.

£ 0dysoft ODBC Collector

Collector 7

Odysoft ODBC Collector

2. Choose Collector > Capture. The Capture Agent window appears (Figure 14).

Figure 14.

F'g Capture Agent E

Capture Agent - Historical CSQ data

Interval

— Cratizhi

|PCCE vpress_Service_Historical From:;  |2007-07-30
IPCCE xpress_Agent_State
p AgenteS ervice Historical 080731

|PCCE wpress

To 2007-07-31

08:07:31
[~ Use 30 minutes interval

Directory
’7 C:\Program Files\CiscotwFO_wWFid\reports Browse.. ‘
~-C ion Yalues
DSN: | Mene] =
ip: I
Test cannection |
Pazaword I

G | it |
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In the From fields in the Interval pane on the right, enter the beginning date
and time for the historical call reference period. The date must be in the
YYYY-MM-DD format, and the time in the 24-hour HH:MM:SS format.

In the To fields, enter the ending date and time for the historical call reference
period.

Highlight the last two statistics queries in the Statistics pane as shown in
Figure 14.

Clear the Use 30 minutes interval check box.
Enter the following directory path in the Directory field:
C:\Program Files\Cisco\WFO_WFM\reports

8. Select the desired database instance name from the DSN field.

9. In the UID and Password fields, enter the user ID and password of a user with

10.
11.

12.
13.

read/write access to the selected database.
Click Test connection to verify the connection is working.

Click Go to capture the historical call data. The reports are created and saved
to the folder C:\Program Files\Cisco\WFO_WFM\reports.

When the hourglass disappears, click Quit to exit the Capture Agent window.

Choose Collector > Quit to exit Odysoft ODBC Collector.
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Capturing Agent Historical Call Data for
Unified CCX

To capture agent historical call data:

1. From the Odysoft ODBC Collector window, choose Collector > Capture. The
Capture Agent window appears (Figure 15).

Figure 15. Capture Agent - Historical Agent data

o= apture Agent ﬂ
Statist Interval
CCExpre istorica From:  |2007-07-30
08:07:31
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08:07:31
[~ Use 30 minutes inkerval
Directory
’7 [ \F'mgram Files\CiscotwFO_'wFM\reports Browse... | ‘
C. ion Yalues
DSH | Nane) |
uID: |
Test connection |
Password: I
G | it |

2. Inthe From fields in the Interval pane on the right, enter the beginning date
and time for the historical call reference period.

3. In the To fields, enter the ending date and time for the historical call
reference period.

4. Highlight the first three statistics queries in the Statistics pane as shown in
Figure 15.

5. Select the Use 30 Minutes Interval check box.

6. Enter the following directory path in the Directory field:
C:\Program Files\Cisco\WFO_WFM\reports

7. Select the Unified CCX DSN from the DSN field.

8. Enter the Unified CCX user ID and password.

9. Click Test Connection to verify the connection is working.

10. Click Go to capture the historical call data. The reports are created and saved
to the folder C:\Program Files\Cisco\WFO_WFM\reports.

11. When the hourglass disappears, click Quit to exit the Capture Agent dialog.
12. Choose Collector > Quit to exit Odysoft ODBC Collector.
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Verifying Historical Call Data Capture
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When you finish capturing the historical call data for Unified CCX, the capture module
processes the reports in the folder C:\Program Files\Cisco\WFO_WFM\reports and
moves them to the folder C:\Program Files\Cisco\WFO_WFM\archives.

The historical contact data capture is complete when there are no more reports in the
folder C:\Program Files\Cisco\WFO_WFM\reports.
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Removing WFM

Overview

To remove WFM, you must proceed in the following order:

1. Remove all service releases (see "Removing a WFM Service Release" on
page 64).

2. Remove WFM (see "Removing WFM Services" on page 65)
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Removing a WFM Service Release

Follow these steps to remove a Cisco Unified Workforce Management service release
from a WFM server.

NOTE: If you cancel the removal process while it is running, the
service release might continue to be listed in the Add or Remove
Programs window, and you will not be able to remove or repair the
service release, or reinstall it. Contact Cisco TAC for assistance. See
the monthly What’s New in Cisco Product Documentation for contact
information:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

To remove a Cisco Unified WFO Workforce Management service release:

1. Log into the WFM server as the local machine administrator.

NOTE: You can log into the WFM server remotely using Virtual
Network Computing (VNC) software. See the documentation that
came with your VNC software for instructions on establishing a
remote connection to another machine.

2. Choose Start > Settings > Control Panel > Add or Remove Programs.

3. Select Cisco Unified WFO Workforce Management Service Release, click
Remove, and follow the prompts.

During the removal process, a DOS window named srRollbackRepair.exe
appears. Do not close this window. The srRollbackRepair.exe DOS window
closes automatically.

4. Your computer automatically reboots. After the computer restarts, the system
will be back to its base level software state.
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Removing WFM Services

Removing WFM Services

June 2011

NOTE: When you remove WFO Workforce Management Services, the

WFM database is not removed.

NOTE: If there is a service release installed on the Workforce
Management server and you want to install WFM, you must remove
the service release before you can remove WFM.See "Removing a
WFM Service Release" on page 64 for more information.

To remove Cisco Unified WFO Workforce Management Services:

1. Log into the WFM server as the local machine administrator.

NOTE: You can log into the WFM server remotely using Virtual
Network Computing (VNC) software. See the documentation that
came with your VNC software for instructions on establishing a
remote connection to another machine.

2. From the Start menu, choose Settings > Control Panel.

3. Double-click Add or Remove Programs.

4. Select Cisco Unified WFO Workforce Management Services, click Remove,

and follow the prompts.

Table 17 lists the programs you will find on the server.

Table 17. Applications on the server

Server

Applications to Remove

Cisco Unified WFO Workforce
Management Server

Cisco Unified WFO Workforce
Management Services”

* JRE and Tomcat are automatically removed when you remove Cisco Unified WFO Workforce

Management Services.
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