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C H A P T E R  1
Cisco Packaged Contact Center Enterprise

Cisco Packaged Contact Center Enterprise (Packaged CCE) is a solution deployment for delivering Cisco
Unified Contact Center Enterprise in a virtualized environment. The initial model of Packaged CCE (CCE
PAC M1) supports up to 1000 agents. Packaged CCE requires strict adherence to capacity limits that are
detailed in the Cisco Packaged Contact Center Enterprise Product Specification, 9.0(1). It is mandatory to
follow all rules and requirements stated in that document.

Partners and service providers have two options.

• Golden Template: Create re-usable master copies (golden templates) of the Cisco contact center
applications for subsequent cloning and installation on virtual machines (VMs) for any number of
customers. See Create Golden Templates, on page 11.

• Direct Install: Deploy the Cisco contact center applications directly on customer servers, as VMs. See
Create Virtual Machines Directly, on page 27

This release of Packaged CCE (CCE PAC M1) supports the creation of golden templates or VMs for:

• Unified Contact Center Enterprise (golden templates or VMs)

• Unified Customer Voice Portal Call/VXML server (golden templates or VMs)

• Unified Customer Voice Portal OAMP server (golden templates or VMs)

• Unified Customer Voice Portal Reporting server (supported as an optional VM only- there is no golden
template for the CVP reporting server)

• Unified Communications Manager Publisher and Subscribers (golden templates or VMs)

• Cisco Unified Intelligence Center Publisher and Subscriber (golden templates or VMs)

• Cisco Finesse Primary and Secondary nodes (golden templates or VMs)

This document assumes that partners and service providers who will be implementing Packaged CCE are
familiar with the Cisco applications and are experienced regarding the deployment andmanagement of virtual
machines using VMware vCenter technology.

• CCE PAC M1 Solution Components, page 2

• Change Log, page 3
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CCE PAC M1 Solution Components
Whether deployed from golden templates or installed directly, the virtual machines (VMs) are located at the
customer site on two core servers, called destination server Side A and destination server Side B. There are
nine virtual machines on Side A. There are eight virtual machines on redundant destination Side B.

SIDE B (8 VMs)SIDE A (9 VMs)

(1) Unified CCE Call Server(1) Unified CCE Call Server

(2) Unified CCE Data Server(2) Unified CCE Data Server

(3) Unified CVP Call/VXML Server 1B(3) Unified CVP Call/VXML Server 1A

(4) Unified CVP Call/VXML Server 2B(4) Unified CVP Call/VXML Server 2A

N/A (There is no CVP OAMP Server on Side B.)(5) Unified CVP OAMP Server

(5) Unified CVP Reporting Server (optional)N/A (There is no Unified CVP Reporting Server on
Side A.)

N/A (There is no Unified Communications Manager
Publisher on Side B.)

(6) Unified Communications Manager Publisher

(6) Unified Communications Manager Subscriber 2(7) Unified Communications Manager Subscriber 1

(7) Unified Intelligence Center Subscriber(8) Unified Intelligence Center Publisher

(8) Cisco Finesse Secondary(9) Cisco Finesse Primary
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Change Log
This section notes the changes made to Installing and Configuring Cisco Packaged Contact Center Enterprise
since Release 9.0(1).
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NotesSeeChange to

Step 6, Administration & Data
Servers Connectivity

Clarified that you must not
configure a secondary
Administration Server for Side A
or Side B.

Configure the Administration
Server & Real-time Data Server
Components , on page 64

Configure Adminstration Server

Added step to Edit Registry
Settings and Restart VM.

Configure Cisco Unified CVP, on
page 77

Configure Cisco Unified CVP

Changed version from 64-bit to
32-bit.

Install JTAPI, on page 76Install JTAPI

Added information about block
size.

Datastore Components and RAID
Configuration, on page 129

Datastore Components and RAID
Configuration
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C H A P T E R  2
Prerequisites

This section explains prerequisites for deploying Packaged CCE model CCE PAC M1.

All prerequisites except Automation Software apply to both golden template and direct install options.
Automation software is required for golden template deployments only.

Note

• Required Hardware, page 5

• Cisco Contact Center Software, page 6

• Automation Software, page 6

• Third-Party Software, page 7

• Configuration Software, page 9

• Software Licenses, page 9

• Open Virtualization Format Files, page 10

Required Hardware

Hardware requirements are for both golden templates and direct installs.Note

This section lists the specifications for the UCS C-260-series server. If you deploy using golden templates,
the source system at the partner or service provider uses one core server for the golden template environment.
For either golden template or direct-install, the customer destination systemmust run in a duplexed environment
using a pair of core Unified Computing System (UCS) C-260-Series servers—known as Side A and Side B.

Firmware: Ensure that your UCS C-260-series server is running the current firmware. To check this. go to
http://www.cisco.com/cisco/software/type.html?mdfid=283862072&catid=282558030.
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Cisco UCS C-260 Technology Refresh Configuration
(TRC) Series

Server Model

Intel(R) Xeon(R) CPU E7-2870 @ 2.40GHzCPU Type

Two 10-core CPUsCPU Cores

128 GBMemory

Sixteen 300 GB hard drives (HDD)Disks

The core server has an integrated dual port:

• One port is used for Management.

• One port is used for the Public Network.

A Quad Port 10/100/1GB NIC is part of the CCE
PAC M1 customized C series.

• One port used for the Private Network.

• The other three ports remain available.

Virtual Interface

Cisco Contact Center Software
Contact center software requirements are for both golden templates and direct installs.

Order DVDs from Cisco Systems. Create ISOs from each DVD, and install the software from the ISOs.

Major Release VersionComponent

9.0(1) and laterUnified CCE

9.0(1) and laterUnified CM

9.0(1) and laterUnified CVP

8.5(4) and laterUnified Intelligence Center

9.0(1) and laterCisco Finesse

Automation Software
Automation software is required for golden templates only.
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NotesDownloadVersionSoftware

Download and extract the
GoldenTemplateTool_901 zip zip
file to run the automation tool.
See Run Golden Template
Automation, on page 19.

Go to http://cisco.com/en/US/
products/ps12586/tsd_
products_support_series_
home.html.

Click Download Software.

Then select Packaged Contact
Center Enterprise
Deployment Scripts.

9.0(1)GoldenTemplateTool_901
zip file

Use PowerCLI to run the
automation script.

Download and then install this
VMWare tool on the client
computer from which the
automation scripts will be run.

http://
downloads.vmware.com/d/
details/pcli50/
dHRAYnQlKmpiZHAlJQ==

Version 5.0,
32-bit

PowerCLI

Used in the configuration of the:

• Cisco Unified
Communications Manager
publisher and subscribers

• Cisco Unified Intelligence
Center publisher and
subscriber

• Cisco Finesse primary and
secondary nodes

WinImage creates a floppy image
(.flp file) from the
platformConfig.xml file. This file
contains the parameters for the
customization of the
publishers/primary and
subscribers/secondary nodes.

Download and then install
WinImage 8.5 on the client
computer from which the
automation scripts will be run.

http://winimage.com/
download.htm.

WinImage 8.5WinImage

Third-Party Software
This section lists third-party software required to deliver virtualized Contact Center modules.

Third-party software requirements are for both golden templates and direct installs.Note
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NotesVersionSoftware

Used for:

• Unified CCE Call Server

• Unified CCE Data Server

• Unified CVP Call/VXML Server

• Unified CVP OAMP Server

• Unified CVP Reporting Server

Service Pack 1Microsoft Windows Server
2008 R2 Standard Edition

Used for Unified CCE Data ServerService Pack 1Microsoft SQL Server 2008
R2 x64 Standard Edition

Required for deploying virtual
machines. http://
downloads.vmware.com/

5.0vCenter Server

Required for deploying virtual
machines. www.vmware.com/go/
get-free-esxi

5.0ESXi Server

http://downloads.vmware.com/

vSphere client is a free software
provided by VMWare. It is required for
managing a virtualized infrastructure.

Datastore and network configuration of
the ESXi host must be done manually.

5.0vSphere Client

Required for all applications that run on
the Windows platform.

For more information, see Install
Anti-Virus Software, on page 38.

One of:

• Symantec Endpoint Protection
11.0/12.1

• Trend Micro Server Protect
version 5.7/5.8

• McAfee VirusScan Enterprise
8.7i/8.8i

Anti-Virus

Microsoft Excel Release 2003 or later
is used to provide the input data for the
datasheet used for the automation.

Release 2003 or laterMicrosoft Excel
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Configuration Software
Configuration software is required for both golden templates and direct installs.

NotesDownloadSoftware

This software updates Unified CCE
Configuration Manager for
Packaged CCE deployments.

Go to http://cisco.com/en/US/
products/ps12586/tsd_products_
support_series_home.html.

Click Download Software.

Then select Packaged Contact
Center Enterprise Configuration
Scripts.

CCEPACM1BaseConfig901.zip

Run this software to modify the
domain name in System
Information.

http://cisco.com/en/US/products/
ps12586/tsd_products_support_
series_home.html

Domain_Update_Tool.zip

Software Licenses
Software licenses are required for both golden templates and direct installs.

Number of LicensesSoftware License

One PAK for each required Unified CVP server -
total of 4 PAKs.

Additional PAK for optional Unified CVP Reporting
server.

Unified CVP

One PAK for Unified Intelligence Center PublisherUnified Intelligence Center

4Microsoft Windows Server 2008 R2 SP1

2Microsoft SQL Server 2008 SP1

2 - one for each Call StudioCall Studio

1VMare vCenter (for golden template deployments)

4 - two for each C-260 serverVMware sSphere Standard or Enterprise

Refer to the http://www.cisco.com/en/US/products/sw/custcosw/ps1844/prod_technical_reference_list.html
for licensing details.
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Open Virtualization Format Files
Open Virtualization Format files (OVAs) are required for both golden templates and direct installs.

Packaged CCE (CCE PAC M1) uses six OVAs, which define the basic structure of the corresponding VMs
that are created—including the CPU, RAM, disk space, reservation for CPU and reservation for memory.

OVA files are contained in the CCE-PAC-M1-OVA-v9.0.1.zip file at Cisco.com.

Go to http://cisco.com/en/US/products/ps12586/tsd_products_support_series_home.html. Click Download
Software. Then select Packaged Contact Center Enterprise Virtual Machine Templates.

Download and extract the file and save the OVAs to your local drive. You will browse to them from the
vCenter.

OVASoftware

CCE-PAC-M1-UCCE-vmv8-v9.0.1 ovaCisco Unified Contact Center Enterprise CCE
Call Server and Data server

CCE-PAC-M1-CVP-vmv8-v9.0.1 ovaCustomer Voice Portal (CVP) Call/VXML, and
OAMP servers

CCE-PAC-M1-CVP-Reporting-Server-vmv8-v9.0.1.ovaCustomer Voice Portal (CVP) reporting server

cucm_9.0_vmv8_v1.5.ovaCicsoUnifiedCommunicationsManager (CUCM)
publisher and subscriber

CCE-PAC-M1-IntelligenceCenter-vmv8-v8.5.4.ovaCisco Unified Intelligence Center (CUIC)
publisher and subscriber

CCE-PAC-M1-Finesse-vmv8-v9.0.1.ovaCisco Finesse primary and secondary
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C H A P T E R  3
Create Golden Templates

If you chose to create virtual machines directly on the destination servers, skip this chapter and go to
Create Virtual Machines Directly, on page 27.

Note

This chapter explains how to build golden templates for contact center applications. Golden templates are
master copies of contact center applications that can be reused—that is, installed onmultiple virtual machines.
They are built on a source system, which is a single (source) core server controlled by a partner or service
provider.

Once the golden templates are built, an automation process clones and deploys the golden templates as
virtual machines (VMs) for the pair of destination core servers deployed for the customer.

You then administer configuration tasks on the contact center VM applications on the destination system
Side A and Side B.

The sequence is:

1 Create golden templates (this chapter)

2 Run the automation process to deploy VMs from the golden templates on the customer destination servers.
See Run Golden Template Automation, on page 19.

3 Configure the VMs on the customer destination servers. See Configure Customer Instance, on page 57.

This chapter contains directions to:

• Create Golden Template for Cisco Unified Contact Center Enterprise Call Server, page 12

• Create Golden Template for Cisco Unified Contact Center Enterprise Data Server, page 13

• Create Golden Template for Cisco Unified Customer Voice Portal Call/VXML Server, page 14

• Create Golden Template for Cisco Unified Customer Voice Portal OAMP Server, page 15

• Create Golden Template for Cisco Finesse, page 16

• Create Golden Template for Cisco Unified Intelligence Center, page 16

• Create Golden Template for Cisco Unified Communications Manager, page 17
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Create Golden Template for Cisco Unified Contact Center
Enterprise Call Server

Follow this sequence of tasks to create the golden template for the CCE Call Server.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open
Virtualization Format
Files, on page 10

Download the
CCE-PAC-M1-CCE-vmv8-v9.0.1.ova.

1

Follow the procedure
that is documented in
Create Virtual
Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2

Follow the procedure
in the section Install
Microsoft Windows
Server 2008 Standard
Service Pack 1, on
page 43.

Install Microsoft Windows Server 2008
R2 Service Pack 1.

3

Follow the procedure
Install VMware Tools,
on page 39

Install VMware Tools.4

Follow the procedure
in the section Install
Anti-Virus Software,
on page 38

Install Anti-Virus software.5

Follow the procedure
documented in the
section Install Cisco
Unified Contact Center
Enterprise, on page
46.

Run the CCEInst901 Installer.6

Follow the procedure
Convert Virtual
Machine to Golden
Template, on page 39

Convert the virtual machine to a Golden
Template.

7
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When you have created all golden templates, you will run the automation process (Run Golden Template
Automation, on page 19). After you run the automation process, you can configure the CCE Call Server on
the destination system. See Configure the Unified CCE Call Server, on page 65

Create Golden Template for Cisco Unified Contact Center
Enterprise Data Server

Follow this sequence of tasks to create the golden template for the CCE Data Server. The golden template
process for the CCE Data Server is nearly identical to that for the CCE Call Server—the Data Server requires
the installation of Microsoft SQL Server 2008 SP1, x64.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download the
CCE-PAC-M1-CCE-vmv8-v9.0.1.ova.

1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2

Follow the procedure Install
Microsoft Windows Server
2008 Standard Service Pack
1, on page 43.

InstallMicrosoftWindows Server 2008R2 Service
Pack 1.

3

Follow the procedure Install
VMware Tools, on page
39

Install VMware Tools, on
page 39.

Install VMware Tools.4

Follow the procedure in the
section Install Anti-Virus
Software, on page 38.

Install Anti-Virus software.5

See Install Microsoft SQL
Server 2008 SP1 Standard
Edition x64, on page 44.

Install Microsoft SQL Server 2008 SP1, x64.6

Follow the procedure
documented in the section
Install Cisco Unified
Contact Center Enterprise,
on page 46.

Run the CCEInst901 Installer.7
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NotesTasksDone?Sequence

Follow the procedure
Convert Virtual Machine to
Golden Template, on page
39.

Convert the virtual machine to a Golden Template.8

When you have created all golden templates, you will run the automation process (Run Golden Template
Automation, on page 19). After you run the automation process, you can configure the CCE Data Server
VM on the destination system. See Configure the Unified CCE Data Server, on page 57

Create Golden Template for Cisco Unified Customer Voice Portal
Call/VXML Server

Follow this sequence of tasks to create the golden template for the CVP Call/VXML Server.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10

Download the
CCE-PAC-M1-CVP-vmv8-v9.0.1.ova

1

Follow the procedure that is
documented in Create
Virtual Machines from
OVAs, on page 37

Create the virtual machine from the OVA.2

Follow the procedure in the
section Install Microsoft
Windows Server 2008
Standard Service Pack 1,
on page 43.

Install Microsoft Windows Server 2008 and
Service Pack 1.

3

Follow the procedure in the
section Install Anti-Virus
Software, on page 38

Install Anti-Virus software.4

Follow the procedure Install
Unified CVP Server, on
page 47 .

Install Cisco Unified CVP.5

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.6
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NotesTasksDone?Sequence

Follow the procedure in the
section Convert Virtual
Machine to Golden
Template, on page 39 .

Convert the virtual machine to a Golden
Template.

7

When you have created all golden templates, you will run the automation process (Run Golden Template
Automation, on page 19). After you run the automation process, you can configure the CVP VMs on the
destination system. See Configure Cisco Unified CVP, on page 77

Create Golden Template for Cisco Unified Customer Voice Portal
OAMP Server

Follow this sequence of tasks to create the golden template for the CVP OAMP Server. This process is similar
to creating the golden template for the CVP Call/VXML server—the differences are selection you make from
the OVA dropdown and in the Select Packages options during the installation.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10

Download the
CCE-PAC-M1-CVP-vmv8-v9.0.1.ova

1

Follow the procedure Create
Virtual Machines from
OVAs, on page 37

Create the virtual machine from the OVA2

Follow the procedure in the
section Install Microsoft
Windows Server 2008
Standard Service Pack 1,
on page 43.

Install Microsoft Windows Server 2008 R2
and Service Pack 1

3

Follow the procedure in the
section Install Anti-Virus
Software, on page 38

Install Anti-Virus software4

See Install Cisco Unified
CVP OAMP server, on
page 47

Install Cisco Unified CVP5

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools6
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NotesTasksDone?Sequence

Follow the procedure in the
section Convert Virtual
Machine to Golden
Template, on page 39.

Convert the virtual machine to a Golden
Template

7

When you have created all golden templates, you will run the automation process (Run Golden Template
Automation, on page 19). After you run the automation process, you can configure the CVP VMs on the
destination system. See Configure Cisco Unified CVP, on page 77

Create Golden Template for Cisco Finesse
Follow this sequence of tasks to create the golden template for Cisco Finesse.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10

Download the
CCE-PAC-M1-Finesse-vmv8-v9.0.1 ova.

1

Follow the procedure that is
documented in Create
Virtual Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2

Follow the procedure for
installing VOS applications
Install Golden Template for
Unified Communications
Manager, Unified
Intelligence Center, and
Cisco Finesse, on page 50.

Install Cisco Finesse.3

Follow the procedure
Convert Virtual Machine to
Golden Template, on page
39.

Convert the virtual machine to a Golden
Template.

4

After you create all golden templates, you can run the automation process. After you run the automation
process, you can configure Cisco Finesse on the destination system. Refer Configure Cisco Finesse, on page
108.

Create Golden Template for Cisco Unified Intelligence Center
Follow this sequence of tasks to create the golden template for Cisco Unified Intelligence Center.

After each task, return to this page to mark the task "done" and continue the sequence.
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NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10

Download the
CCE-PAC-M1-IntelligenceCenter-vmv8-v8.5.4.ova.

1

See Create Virtual
Machines from OVAs, on
page 37.

Create the virtual machine from the OVA.2

See Install Golden Template
for Unified
Communications Manager,
Unified Intelligence Center,
and Cisco Finesse, on page
50 .

Install Cisco Unified Intelligence Center.3

See Convert Virtual
Machine to Golden
Template, on page 39.

Convert the virtual machine to a Golden
Template.

4

After you create all golden templates, you can run the automation process. After you run the automation
process, you can configure the Cisco Unified Intelligence Center VMs on the destination system. Refer
Configure Unified Intelligence Center, on page 102.

Create Golden Template for Cisco Unified Communications
Manager

Follow this sequence of tasks to create the golden template for Cisco Unified Communications Manager.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

Open Virtualization Format
Files, on page 10.

Download the cucm_9.0_vmv8_v1.5.ova.1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2

Follow the procedure for
installing VOS applications
Install Golden Template for
Unified Communications
Manager, Unified
Intelligence Center, and
Cisco Finesse, on page 50.

Install Cisco Unified Communications
Manager.

3
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NotesTasksDone?Sequence

Follow the procedure
Convert VirtualMachine to
Golden Template, on page
39

Convert the virtual machine to a Golden
Template.

4

After you create all golden templates, you can run the automation process. After you run the automation
process, you can configure the Unified Communications Manager publisher and subscriber VM on the
destination system. Refer Configure Unified Communications Manager, on page 88.
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C H A P T E R  4
Run Golden Template Automation

If you chose to create virtual machines directly on the destination servers, skip this chapter and go to
Create Virtual Machines Directly, on page 27.

Note

CCE PAC M1 automation is the process of deploying virtual machines on the destination system using the
golden templates on the source system.

Before you run the automation, download and install vSphere PowerCLI on the computer from which the
automation is to be run. See Automation Software, on page 6. VSphere PowerCLI is a command-line tool
built on Windows PowerShell. It provides cmdlets (commands) for managing and automating vSphere.

• Download Automation Tool, page 19

• Complete Automation Spreadsheet, page 20

• Run Automation Script, page 24

Download Automation Tool
The automation tool is contained in the GoldenTemplateTool_901.zip file, downloadable from Cisco.com at
http://cisco.com/en/US/products/ps12586/tsd_products_support_series_home.html.

Extract the file and copy the CCEPACM1_VMAutomation folder to the root of your C: drive.

This folder contains five subfolders and the CCEPAKM1_VMDataSheet_901 file.
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• The Archive subfolder will hold any prior versions of the automation spreadsheet, saved with a date and
time stamp.

• The Log subfolder holds all log files saved with a date and time stamp.

• The PlatformConfigRepository subfolder has three subfolders. All folders are empty until you run the
automation script

◦ The CUCM folder has three XML files—one for the publisher and one for each subscriber.

◦ The CUIC folder has two XML files—one for the publisher and one for the subscriber.

◦ The FINESSE folder has two XML files—one for the primary node and one for the secondary
node.

• The Report subfolder holds all automation reports, saved with a date and time stamp. (This subfolder is
empty until you run the automation script.)

• The scripts subfolder holds four scripts. The file named deployVM.PS1 is the primary script and calls
the other scripts during the automation.

• CCEPAKM1_VMDataSheet_901 is the spreadsheet to complete for the automation process.

Complete Automation Spreadsheet
The CCEPAKM1_VMDataSheet_901 automation spreadsheet contains a row for each virtual machine that
will be created from the source system.

The automation script reads this spreadsheet row-by-row. For each golden template, the script clones, creates
the customization file for the operating system, and deploys all virtual machines to the destination Sides A
and B.

Automation Spreadsheet Values
This table explains the value required in each cell of the CCEPACM1_VMDatasheet_901 spreadsheet. Enter
values for the Source server. Obtain and enter values for the Destination servers.
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The Description column below identifies any guidelines that apply to the data. For example,
GOLDEN_TEMPLATE_NAME cannot contain spaces. Both the automation spreadsheet and VMWare
accept names that do not comply with these guidelines. However, the automation script will fail if the
template names are not in conformance with them.

Note

ExampleDescriptionColumn

UCCE_CallServer_SideAThe type of the VM, based on the
Contact Center software installed.
Default contents are not editable.

VM_TYPE

Windows2008The type of Operating System
installed on the VM. Default
contents are not editable.

OS_TYPE

YESRequired. Retain the default YES
to create a VM using automation.

CREATEVM

Change to NO to skip VM creation
during automation.

xx.xx.xxx.xxxRequired. The IP address of the
ESXi host for this Golden
Template.

SOURCE_HOST_IP

datastore1(3)Required The name of the
Datastore where this Golden
Template resides.

SOURCE_DATASTORE_NAME

My_CallServerRequired. The name of the Golden
Template fromwhich the newVM

GOLDEN_TEMPLATE_NAME

it to be deployed. Cannot contain
spaces.

CallServerSideARequired. The name for the new
VM. Cannot contain spaces or

NEW_VM_NAME

special characters. Maximum of
32 characters.

xx.xx.xxx.xxxRequired. The IP address of the
ESXi Host for the new VM.

DEST_HOST_IP

datastore2(1)Required. The name of the
Datastore for the new VM.

DEST_DATASTORE_NAME

9.0.xCurrently this field is applicable
only for Cisco Unified
Communications Manager.

PRODUCT_VERSION
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Demo-CallSrvARequired. The NET BIOS name
for the new computer. 15-character

COMPUTER_NAME

maximum. Do not use special
characters /, \, ?,:,*,",<,>,.,.

NODropdown:

YES adds the VM to aWorkGroup
and enables
WORK_GROUP_NAME.

WORK_GROUP

NO adds the VM to a domain and
enables DOMAIN_NAME,
DOMAIN_USER, and
DOMAIN_PASSWORD.

NARequired. Enter the Workgroup
name. Used only if
WORK_GROUP is set to YES.

WORK_GROUP_NAME

mydomain.comRequired. Enter the Domain name.
Used only if WORK_GROUP is
set to NO.

DOMAIN_NAME

AmericaRequired. Drop-down selection of
the timezone area to be set Unified

TIME_ZONE_LINUX_AREA

CM. For the United States of
America, select America.

EasternRequired. Drop-down selection of
the timezone location to be set for
Unified CM, CUIC, or Finesse.

TIME_ZONE_LINUX_LOCATION

(GMT-05:00) Eastern TIme (US &
Canada)

Required. Drop-down selection of
the timezone to be set for the
Unified CVP and Unified CCE
VMs.

TIME_ZONE_WINDOWS

HarryUserRequired. The user name for a
domain user with privileges to add

DOMAIN_USER

the new computer to the domain.
Enabled only if WORK_GROUP
is set to NO.

package123Required. The password for the
domain user. Enabled only if
WORK_GROUP is set to NO.

DOMAIN_PASSWORD

ZZZM2-Y330L-HH123-99Y1B-GJ20BRequired. The valid Windows OS
product key in the format
xxxxx-xxxxx-xxxxx-xxxxx-xxxxx.

PRODUCT_KEY
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LabAdminRequired. The full name of the
owner.

OWNER_NAME

Administrator and Guest are not
allowable names.

This is a mandatory field for
OS_TYPE Windows 2008.

MyOrganizationRequired. The Organization Name
to be set for Unified CM, CUIC,
or Finesse.

ORGANIZATION_NAME

MyUnitRequired. The Organization Unit
to be set for Unified CM, CUIC,
or Finesse.

ORGANIZATION_UNIT

MyCityRequired. The Organization
Location to be set for Unified CM,
CUIC, or Finesse.

ORGANIZATION_LOCATION

MyStateRequired. The Organization State
to be set for Unified CM, CUIC,
or Finesse.

ORGANIZATION_STATE

United States of AmericaRequired. Drop-down selection of
the Organization Country to be set
for Unified CM, CUIC, or Finesse.

ORGANIZATION_COUNTRY

xx.xx.xxx.xxxRequired. The IP Address of the
NTP server.

NTP_SERVER

2Values in the field are
pre-populated based on

NIC_NUM

VM_TYPE field and are protected.
Values are “1” or “2”.

This value indicates the number of
NICs to be configured for the
VMs.

xx.xx.xxx.xxxRequired. A valid IPv4 address for
NIC1.

IP_ADDRESS_NIC1

xx.xx.xxx.xxxRequired. A valid subnet mask
(IPv4 address) for NIC 1.

SUB_NET_MASK_NIC1

xx.xx.xxx.xxxRequired. A valid Default gateway
(IPv4 address) for NIC1.

DEFAULT_GATEWAY_NIC1

xx.xx.xxx.xxxRequired. A valid IPv4 address for
the primary DNS for NIC1.

DNS_IP_NIC1
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xx.xx.xxx.xxxRequired. A valid IPv4 address for
NIC 2.

IP_ADDRESS_NIC2

Valid only if the value in the
NIC_NUM fields is 2.

255.255.255.255Required. A valid subnet mask
(IPv4 address) for NIC 2. For
Unified CCE VMs only.

SUB_NET_MASK_NIC2

xx.xx.xxx.xxxRequired. A valid IPv4 address for
the primary DNS for NIC2. For
Unified CCE VMs only.

DNS_IP_NIC2

xx.xx.xxx.xxxOptional. A valid IPv4 address for
the alternate DNS for NIC2. For

DNS_ALTERNATE_NIC2

Unified CCE VMs only. Must
differ from the address of the
primary DNS for NIC2.

Refer to the Appendix for an Automation Spreadsheet Entry Form for entry of information for your automation.

Run Automation Script
Launch VMware vSphere PowerCLI (32-Bit) to run the automation script.
The first time you run PowerCLI, you must enter the command get-executionpolicy to determine whether the
Restricted Execution policy is in effect or is restricted

If the policy is restricted, enter set-executionpolicy. At the Supply Values prompt, enter "Unrestricted." Then
enter 'Y". This changes the execution policy so that you can run unsigned scripts that you write on your local
computer and signed scripts from other users.

What to Do Next

Enter a command using the following syntax: <Path to the script> <Path of the spread sheet> <vCenter IP
/ Hostname> <vCenter User> <Password to connect to vCenter>
C:\GoldenTemplateTool_901\scripts\DeployVM.PS1
C:\GoldenTemplate_901\CCEPACM1_VMDataSheet_901.xls testvCenter testuser testpassword

This starts a script that parses the data, validates the data, creates a VM and a customization file for the VM.

Ongoing status messages, updated every 30 seconds, display as the script executes.
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If you monitor the progress in the vSphere client, note that the vSphere Target is the golden template source.

If the script runs successfully, it will typically complete in several hours.

If the script encounters errors, it stops and displays those errors on the screen and also stores them in the log
file. Refer to Troubleshooting, on page 147 for tips on resolving errors.

Completion of the script generates a status report in the Report folder. The status report has a link to the Log
file. Consult this file to debug error conditions and to consult with Cisco Support.
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C H A P T E R  5
Create Virtual Machines Directly

This chapter explains the sequence of tasks for creating virtual machines directly on the customer destination
servers.

The sequence is:

1 Create VMs (this chapter)

2 Configure the VMs on the customer destination servers. See Configure Customer Instance, on page 57

Skip this chapter if you are deploying with golden templates.Note

• Create VM for Cisco Unified Contact Center Enterprise Call Server, page 27

• Create VM for Cisco Unified Contact Center Enterprise Data Server, page 28

• Create VM for CVP Call/VXML Server, page 29

• Create VM for CVP OAMP Server, page 30

• Create VM for Cisco Unified Communications Manager Publisher, page 31

• Create VM for Cisco Unified Communications Manager Subscriber, page 32

• Create VM for Unified Intelligence Center Publisher, page 33

• Create VM for Cisco Unified Intelligence Center Subscriber, page 33

• Create VM for Cisco Finesse Primary, page 34

• Create VM for Cisco Finesse Secondary, page 35

• Create VM for CVP Reporting Server (optional), page 35

Create VM for Cisco Unified Contact Center Enterprise Call
Server

Follow this sequence of tasks to create a VM directly for the CCE Call Servers on Side A and Side B.
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After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open
Virtualization Format
Files, on page 10.

Download the
CCE-PAC-M1-CCE-vmv8-v9.0.1.ova.

1

Follow the procedure
that is documented in
Create Virtual
Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2

Follow the procedure
in the section Install
Microsoft Windows
Server 2008 Standard
Service Pack 1, on
page 43.

Install Microsoft Windows Server 2008 R2
Service Pack 1.

3

Follow the procedure
Install VMware Tools,
on page 39.

Install VMware Tools.4

Follow the procedure
in the section Install
Anti-Virus Software,
on page 38.

Install Anti-Virus software.5

Follow the procedure
documented in the
section Install Cisco
Unified Contact Center
Enterprise, on page
46.

Run the CCEInst901Installer.6

When you have created the VM, you can configure the CCE Call Server on the destination system. See
Configure the Unified CCE Call Server, on page 65

Create VM for Cisco Unified Contact Center Enterprise Data
Server

Follow this sequence of tasks to create a virtual machine directly for the CCE Data Servers on Side A and
Side B. The process is nearly identical to creating a VM for the CCE Call Server, with the additional step to
install Microsoft SQL Server 2008 SP1, x64.
After each task, return to this page to mark the task "done" and continue the sequence.
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NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download theCCE-PAC-M1-CCE-vmv8-v9.0.1.ova.1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Select CCE Data Server
from the OVA drop-down.

Create the virtual machine from the OVA.2

Follow the procedure Install
Microsoft Windows Server
2008 Standard Service Pack
1, on page 43.

Install Microsoft Windows Server R2 2008 Service
Pack 1.

3

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

See Configure Database
Drives, on page 62.

Configure a drive.5

Follow the procedure in the
section Install Anti-Virus
Software, on page 38.

Install Anti-Virus software.6

Follow the procedure in the
section Install Microsoft
SQL Server 2008 SP1
Standard Edition x64, on
page 44.

Install Microsoft SQL Server 2008 SP1, x64.7

Follow the procedure
documented in the section
Install Cisco Unified
Contact Center Enterprise,
on page 46.

Run the CCEInst901Installer.8

When you have created the VM, you can configure the CCE Data Server VM on the destination system. See
Configure the Unified CCE Data Server, on page 57.

Create VM for CVP Call/VXML Server
Follow this sequence of tasks to directly create a virtual machine for the CVP Call/VXML Server.
After each task, return to this page to mark the task "done" and continue the sequence.
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NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download the CCE-PAC-M1-CVP-vmv8-v9.0.1.ova.1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Select CVP Call Server
from the OVA drop-down.

Create the virtual machine from the OVA.2

Follow the procedure in the
section Install Microsoft
Windows Server 2008
Standard Service Pack 1,
on page 43.

Install Microsoft Windows Server 2008 and Service
Pack 1.

3

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

Follow the procedure in the
section Install Anti-Virus
Software, on page 38.

Install Anti-Virus software.5

Follow the procedure Install
Unified CVP Server, on
page 47.

Install Cisco Unified CVP.6

When you have created the VM, you can configure the CVP VMs on the destination system. See Configure
Cisco Unified CVP, on page 77.

Create VM for CVP OAMP Server
Follow this sequence of tasks to directly create a virtual machine for the CVP OAMP Server on Side A.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download the CCE-PAC-M1-CVP-vmv8-v9.0.1.ova.1

Follow the procedure
Create Virtual Machines
from OVAs, on page 37.

Create the virtual machine from the OVA.2
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NotesTasksDone?Sequence

Follow the procedure in the
section Install Microsoft
Windows Server 2008
Standard Service Pack 1,
on page 43.

Install Microsoft Windows Server 2008 and Service
Pack 1.

3

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

Follow the procedure in the
section Install Anti-Virus
Software, on page 38.

Install Anti-Virus software.5

Follow the procedure Install
Unified CVP Server, on
page 47.

Install Cisco Unified CVP.6

When you have created them, you can configure the CVP VMs on the destination system. See Configure
Cisco Unified CVP, on page 77

Create VM for Cisco Unified Communications Manager
Publisher

Follow this sequence of tasks to directly create the virtual machine for the Cisco Unified Communications
Manager publisher.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download the cucm_9.0_vmv8_v1.5.ova.1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.

Select the 7500 configuration.

2

Follow the procedure for
installing in this section
Direct Install Unified
Communications Manager,
Unified Intelligence Center,
and Finesse
Publishers/Primary Nodes,
on page 51.

Install Cisco Unified Communications Manager.3
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NotesTasksDone?Sequence

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

When you have the VMs for the CommunicationsManager publisher and subscriber, you can configure them.
See Configure Unified Communications Manager, on page 88.

Create VM for Cisco Unified Communications Manager
Subscriber

Follow this sequence of tasks to directly create a virtual machine for both Cisco Communications Manager
Subscribers.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download the cucm_9.0_vmv8_v1.5.ova.1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2

Follow the procedure for
installing in this section:
Direct Install of Unified
Communications Manager,
Unified Intelligence Center,
and Finesse
Subscribers/Secondary
node, on page 53.

Install Cisco Communications Manager subscriber3

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

When you have created the CommunicationsManager publisher and subscribers, you can configure the Cisco
Unified Communications Manager on the destination system. See Configure Unified Communications
Manager, on page 88.
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Create VM for Unified Intelligence Center Publisher
Follow this sequence of tasks to directly create the virtual machine for the Cisco Unified Intelligence Center
Publisher.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download the
CCE-PAC-M1-IntelligenceCenter-vmv8-v8.5.4.ova.

1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2

Follow the procedure for
installing in this section
Direct Install Unified
Communications Manager,
Unified Intelligence Center,
and Finesse
Publishers/Primary Nodes,
on page 51.

Install Cisco Unified Intelligence Center.3

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

When you have the VMs for the Cisco Unified Intelligence Center publisher and subscriber, you can configure
them. See Configure Unified Intelligence Center, on page 102.

Create VM for Cisco Unified Intelligence Center Subscriber
Follow this sequence of tasks to directly create a virtual machine for the Cisco Unified Intelligence Center
Subscriber on Side B.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download the
CCE-PAC-M1-IntelligenceCenter-vmv8-v8.5.4.ova.

1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2
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NotesTasksDone?Sequence

Follow the procedure for
installing in this section:
Direct Install of Unified
Communications Manager,
Unified Intelligence Center,
and Finesse
Subscribers/Secondary
node, on page 53.

Install Cisco Unified Intelligence Center subscriber.3

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

When you have created the CUIC publisher and subscriber nodes, you can configure the CUIC on the destination
system. See Configure Unified Intelligence Center, on page 102.

Create VM for Cisco Finesse Primary
Follow this sequence of tasks to directly create the virtual machine for the Cisco Finesse Primary node.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download the
CCE-PAC-M1-Finesse-vmv8-v9.0.1.ova.

1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37.

Create the virtual machine from the OVA.2

Follow the procedure for
installing in this section
Direct Install Unified
Communications Manager,
Unified Intelligence Center,
and Finesse
Publishers/Primary Nodes,
on page 51.

Install Cisco Finesse primary node.3

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

When you have the VMs for the Cisco Finesse primary and secondary nodes, you can configure them. See
Configure Cisco Finesse, on page 108.
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Create VM for Cisco Finesse Secondary
Follow this sequence of tasks to directly create a virtual machine for the Cisco Finesse Secondary node.
After each task, return to this page to mark the task "done" and continue the sequence.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10

Download the
CCE-PAC-M1-Finesse-vmv8-v9.0.1.ova.

1

Follow the procedure that
is documented in Create
Virtual Machines from
OVAs, on page 37

Create the virtual machine from the OVA.2

Follow the procedure for
installing in this section:
Direct Install of Unified
Communications Manager,
Unified Intelligence Center,
and Finesse
Subscribers/Secondary
node, on page 53

Install Cisco Finesse.3

Follow the procedure Install
VMware Tools, on page
39

Install VMware Tools.4

When you have created the Cisco Finesse primary and secondary nodes, you can configure the Cisco Finesse
on the destination system. See Configure Cisco Finesse, on page 108.

Create VM for CVP Reporting Server (optional)
Follow this sequence of tasks to directly create a virtual machine for the CVP Reporting Server on Side B.
Creating this VM is optional. Install it if the customer will use Courtesy Call Back and CVP callback reports.
After each task, return to this page to mark the task "done" and continue the sequence.

The CVP Reporting component cannot be installed on a machine with a hostname that contains a hyphen; the
hostname can be no longer than 12 characters.

NotesTasksDone?Sequence

See Open Virtualization
Format Files, on page 10.

Download
CCE-PAC-M1-CVP-Reporting-Server-vmv8-v9.0.1.ova.

1

Follow the procedure
Create Virtual Machines
from OVAs, on page 37.

Create the virtual machine from the OVA.2
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NotesTasksDone?Sequence

Follow the procedure in the
section Install Microsoft
Windows Server 2008
Standard Service Pack 1,
on page 43.

Install Microsoft Windows Server 2008 and Service
Pack 1.

3

Follow the procedure Install
VMware Tools, on page
39.

Install VMware Tools.4

See Configure Database
Drives, on page 62.

Configure a drive.5

Follow the procedure in the
section Install Anti-Virus
Software, on page 38.

Install Anti-Virus software.6

Follow the procedure Install
the Unified CVP Reporting
Server, on page 48.

Install Cisco Unified CVP.7

When you have created them, you can configure the CVP VMs on the destination system. See Configure
Cisco Unified CVP, on page 77.
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C H A P T E R  6
Tasks common to golden templates and direct
installs

These tasks are common to many golden template and direct-install procedures. The applicability (golden
template or direct-install, or both) is noted at the start of each task.

• Create Virtual Machines from OVAs, page 37

• Install Anti-Virus Software, page 38

• Install VMware Tools, page 39

• Convert Virtual Machine to Golden Template, page 39

• Mount ISO File, page 40

• Configure DNS Server, page 40

• Set up NTP and Time Configuration at the Customer Site, page 41

• Configure the Destination Servers, page 42

Create Virtual Machines from OVAs
Complete the following procedure to create virtual machines from the OVAs.

Complete this procedure for both golden-template and for direct-install options.

Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)    
37



Procedure

Step 1 Select the Host in the vSphere client.
Step 2 Choose File > Deploy OVF Template.
Step 3 Browse to the location on your local drive where you stored the OVA. Click Open to select the file. Click

Next.
Step 4 Click Next at the OVF Template Details page.
Step 5 Enter the virtual machine name. It cannot contain spaces or special characters. Enter a maximum of 32

characters. Click Next.
Step 6 On the Name and Location page, enter a name of your choice in the Name field.
Step 7 On the Deployment Configuration page, use the drop-down to select the appropriate configuration. Then click

Next:
a) For the CCE Call Server, select CCE Call Server.
b) For the CCE Data Server, select CCE Data Server.
c) For the CVP Call Server, select CVP Call Server.
d) For the CVP OAMP Server, select CVP OAMP Server.
e) For CUCM, select 7500 user node.

Step 8 Choose a datastore on which to deploy the new virtual machine. For more information, see Datastore
Components and RAID Configuration. Click Next.

Step 9 On the Disk Format page, keep the default virtual disk format: Thick provisioned Lazy Zeroed format.
Click Next.

Step 10 Confirm that the Network Mapping page is correct:
a) Public to Visible Network
b) Private to Private Network

Step 11 Click Finish.
After the VM is created, you cannot rename
it.

Important

Step 12 At the Successfully Completed message, click Close.

Install Anti-Virus Software
Perform this procedure for both golden-template and for direct-install options.

This procedure is required for the applications that use the Windows 2008 Operating System. These are the
Unified CCE Call Server, the Unified CCE Data Server, the Unified CVP server, the Unified CVP OAMP
server, and the Unified Reporting server.

Install one of the following anti-virus software products:

• McAfee VirusScan Enterprise 8.7i / 8.8i

• Symantec Endpoint Protection 11.0 / 12.1

• Trend Micro Server Protect Version 5.7 / 5.8
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Update virus software manually. Do not enable automatic updates.Important

To allow required access to installation program files or folders, perform file-blocking exclusions in the
anti-virus product file-and-folder protection rules. To do this in McAfee VirusScan:

Procedure

Step 1 Launch the VirusScan console.
Step 2 Right-click Access Protection and select Properties.
Step 3 In the Anti-virus Standard Protection category, make sure that the rule Prevent IRC communication is unchecked

in the Block column.

Install VMware Tools
VMware Tools is a suite of utilities that enhance the performance of the virtual machine's guest operating
system and improve management of the virtual machine.

Perform this procedure for both golden-template and for direct-install options.

Procedure

Step 1 Right-click the VM menu. Select Guest > Install / Upgrade VMware tools.
Step 2 Wait for the pop-up (this may take time) and accept the default Automatic Tools Upgrade.
Step 3 Click OK.
Step 4 Restart when prompted.

Convert Virtual Machine to Golden Template
Perform this procedure for the golden-template install option. This procedure is not necessary for the
direct-install option.

VMware uses the term Template. Packaged CCE uses the term Golden Template for templates consisting
of application and operating systems that are used for CCE PAC M1.

Note
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Procedure

Step 1 If the VM is not already powered off, from the VM menu, select Power > Shut down the guest.
Step 2 From the VMware vCenter Inventorymenu, right-click the virtual machine and chooseTemplate >Convert

to Template.

Mount ISO File
Do this for both golden template and direct installs.

Upload ISO image to datastore:

1 Select the host and click Configuration. Then click Storage in the left panel.

2 Select the datastore that will hold the ISO file.

3 Click Browse this datastore. Then click the Upload icon.

4 Click the Upload icon and select Upload file....

5 Browse to the location on your local drive where you saved the ISO file and upload the ISO to the datastore.

Mount the ISO image:

1 Right-click the VM and select Edit virtual machine settings.

2 Click Hardware and select CD|DVD Drive 1.

3 Check Connect at Power On under Device status panel (upper right).

4 Click on the Datastore ISO File radio button and then click Browse.

5 Navigate to the datastore where you uploaded the file.

6 Select the ISO.

Unmount the ISO image:

1 Right-click the VM and select Edit virtual machine settings.

2 Click Hardware and select CD|DVD Drive 1.

3 Uncheck the Connect at power on check box (Device status panel, upper right).

Configure DNS Server
DNS Configuration is mandatory for Cisco Unified Communications Manager, Cisco Unified Intelligence
Center, and Cisco Finesse.
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Procedure

Step 1 Login in to the DNS Server.
Step 2 Click Start > Administrative Tools > DNS. This opens the DNS Manager.
Step 3 In the Forward lookup zone, navigate to the domain name you have provided in the automation excel sheet.
Step 4 Right-click on the domain name and select New Host (A or AAAA).
Step 5 In the New Host dialog box, enter the computer name and IP address of the VOS products (Unified

Communications Manager, Unified Intelligence Center, and Finesse). Click Add Host.
Step 6 The DNS manager automatically creates a New Host record in the Reverse Lookup Zones.
Step 7 Check whether the Added Host exists in the Forward and Reverse Lookup Zones.

Set up NTP and Time Configuration at the Customer Site
Any domain controllers at the customer site must be configured to use NTP servers. The two ESXi core servers
must point to the sameNTP servers as the domain controllers. Additionally, youmust review time configuration
settings on the ESXi core servers. Doing this prevents a race condition and an incorrect time setting when the
server starts or reboots.

Procedure

Step 1 To add an NTP server to the domain controller:
a) Locate the Microsoft instructions on how to configure an authoritative time server in Windows Server.

Public NTP servers are available on the Internet if you do not have one.

b) Note down the IP address or domain name of the NTP server that you add.

Step 2 To point the ESXi core servers to the domain controller NTP servers:
a) For each core server, click the Configuration tab.
b) Choose Time Configuration > Properties... > Options.

This opens a panel with two sections: General and NTP Settings.

c) Click NTP Settings. Then click Add.
d) Enter the IP address or fully qualified domain name of the NTP Servers associated with the domain

controller. Click OK. Click Restart.

Step 3 To set the startup policy for the NTP server(s):
a) Navigate to Time Configuration > Properties... > Options.
b) Click General.
c) Select Start and stop with host. Click OK.

Step 4 To review the time settings for the core servers:
a) Click the Configuration tab.
b) In the Software panel, select Time Configuration, which shows the Date & Time and the NTP Servers.

Step 5 To adjust the Date & Time if they are incorrect:
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a) Click Properties...
This opens the Time Configuration dialog box.

b) Change the Time and Date fields. Then click OK.

Configure the Destination Servers
• Complete the RAID configuration. See Datastore Components and RAID Configuration.

• Add the Customer ESXi host to the vCenter.
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C H A P T E R  7
Install Software for Golden Templates and Direct
Installs

This chapter explains the installation of all contact center application software and operating system software
used by Packaged CCE.

It is noted when the installation differs for a golden template deployment and a direct VM deployment.

• Install Microsoft Windows Server 2008 Standard Service Pack 1, page 43

• Install Microsoft SQL Server 2008 SP1 Standard Edition x64, page 44

• Install Cisco Unified Contact Center Enterprise, page 46

• Install Unified CVP Server, page 47

• Install Cisco Unified CVP OAMP server, page 47

• Install the Unified CVP Reporting Server, page 48

• Install Unified Intelligence Center COP file, page 49

• Install Golden Template for Unified Communications Manager, Unified Intelligence Center, and Cisco
Finesse, page 50

• Direct Install Unified Communications Manager, Unified Intelligence Center, and Finesse
Publishers/Primary Nodes, page 51

• Direct Install of Unified Communications Manager, Unified Intelligence Center, and Finesse
Subscribers/Secondary node, page 53

Install Microsoft Windows Server 2008 Standard Service Pack
1

Complete the following procedure to install Microsoft Windows Server 2008 R1 Service Pack 1.

Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)    
43



This task is required for both direct installs and golden templates for the CCE Call Server, the CCE Data
Server, the CVP Servers.

Note

Procedure

Step 1 Mount theMicrosoftWindows Server 2008 R1 ISO image to the CD/DVD drive of the newly deployed virtual
machine that you created in the procedures. For more information, see Mount ISO File, on page 40.

Step 2 Enter the Language, Time and Currency Format, and Keyboard settings. Click Next.
Step 3 Click Install Now.
Step 4 Select Full install for the Windows Server 2008 R1 standard. Then click Next.
Step 5 Accept the license terms.
Step 6 Select Custom (Advanced). The install begins.
Step 7 At the conclusion of the installation, click OK at the prompt to enter and confirm the user password.
Step 8 At the Customize This Server section of the initial configuration tasks, select Enable Remote Desktops.

Select the middle option: Allow connections from computers running any version of Remote Desktop.
Step 9 Open the Network and Sharing Center and select Local Area Connections.
Step 10 In the Network Settings dialog box, configure the network settings and the Domain Name System (DNS)

data:
a) Select Properties. Then select Internet Protocol Version 4.
b) Select Properties again. Then select Use the following IP Address.
c) Enter the IP address, Subnet mask, and Default gateway.

Step 11 Run Service Pack 1 for Windows Server 2008 R1.
Step 12 Run MS Windows Update.

Once the MS update is done, click Do not enable automatic updates.

What to Do Next

Microsoft Windows Server 2008 R1 installs Internet Explorer 8. You must upgrade to Internet Explorer 9.

Install Microsoft SQL Server 2008 SP1 Standard Edition x64
This task is required for golden templates for the Unified CCE Data Server.

Install Microsoft SQL Server 2008 x64 and store the SQL Server log and temporary files on the same physical
disk as the operating system (typically the C drive). Use the secondary drive to store the Logger database
(typically the E drive).
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Procedure

Step 1 Mount the Microsoft SQL Server 2008 ISO image to the virtual machine. See Mount ISO File, on page 40.
Step 2 Run setup.exe.
Step 3 Select Installation on the left pane and then click New installation or add features to an existing installation.

Click OK.
Step 4 On the Product Key page, enter the product key and click Next.
Step 5 Accept the Licence Terms and click Next. Click Install on the Setup Support Rules page.
Step 6 On the Setup Support Rules page, click Next.
Step 7 On the Setup Role page, select SQL Server Feature Installation. Then click Next.
Step 8 On the Feature Selection page, click Select All and then click Next.
Step 9 On the Installation Rules page, click Next.
Step 10 On the Instance Configuration page, select Default Instance . Click Next.
Step 11 On the Disk Space Requirements page, click Next.
Step 12 On Server Configuration page, select the Services Account tab.

a) For Service SQL Server Agent, select Account Name NT AUTHORITY\SYSTEM and Startup Type
Automatic.

b) For Service SQL Server Database Engine. select Account Name NT AUTHORITY\SYSTEM.
c) For Service SQL Server Analysis Services, select Account Name NT AUTHORITY\SYSTEM.
d) For Service SQL Server Reporting Services, select Account Name NT AUTHORITY\SYSTEM.

Step 13 Remain on the Server Configuration page and select the Collation tab.
a) Click Customize for Database Engine.
b) Check the radio buttonWindows Collation designator and sort order.
c) Select the collation that is appropriate for the customer. In most cases, this is Latin1_General and BIN.
d) Click OK.Click Next. on the Server Configuration page.
e) Click Next.

Step 14 On the Database Engine Configuration page:
a) CheckMixed Mode.
b) Enter your password and confirm it by reentering it.
c) Click Add Current User.
d) ClickNext.

Step 15 On the Analysis Services configuration page, click Add current user. Then click Next.
Step 16 On the Reporting Server configuration, check the radio button for Install but do not configure the report

server. Click Next.
Step 17 Click Next on the Error reporting page.
Step 18 Click Next on the Installation Configuration Rules page.
Step 19 Click Install on the Ready to Install page.
Step 20 Click Close at the Complete page.
Step 21 Install SQL Server 2008R2 Service Pack 1 x64. Follow the Wizard and accept all defaults.
Step 22 Enable Named Pipes and set the sort order as follows:

a) Open the SQL Server Configuration Manager.
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b) In the left pane, navigate to SQL Native Client 10.0 Configuration (32bit) > Client Protocols.
c) In the right pane, right-click Named Pipes and select Order.
d) In the Client Protocols Properties window, select Named Pipes and Click Move Up or Move down to

change the order of the protocols as follows: Shared Memory, Named Pipes, TCP/IP, then click OK
e) In the left pane, navigate to SQL Server Network Configuration > Protocols for MSSQLSERVER.
f) In the right pane, right-click Named Pipes and select Enable

Step 23 Enable autogrow as follows:
a) Select Start > All Programs > Microsoft SQL Server 2008R2 > SQL Server Management Studio..
b) Click Connect > Databases. Then expand System Databases.
c) Right-click tempdb and select Properties.
d) Check Enable Autogrowth. Set In Percent to 10. Click OK.

Step 24 Restart the SQL Server service.

Related Topics

Microsoft SQL Server Collation Settings for Languages

Install Cisco Unified Contact Center Enterprise
This task is required for installs and for creating the golden templates for both the Unified CCE Call Server
and the Unified CCE Data Server.

Procedure

Step 1 Add the virtual machine into the domain.
Step 2 Mount the correct version of Cisco Unified CCE ISO image to the virtual machine. See Mount ISO File, on

page 40.
Step 3 Navigate to the ISO file on the CD/DVD drive D. Run setup.exe from the D:\ICM-CCE-CCH Installer

directory.
Step 4 Follow the InstallShield procedures to install Cisco Unified CCE.
Step 5 When the installation completes, restart the computer when prompted. At restart, if there is an MR, the

Maintenance Release installer will begin.
Step 6 When prompted to restart the computer, click Yes. Click Finish.
Step 7 Remove the machine from a domain and add it to a work group.

Ignore this step for a direct install. Do this step only for a golden
template.

Note

Step 8 Unmount the ISO image.
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Install Unified CVP Server
This task is required for direct installs and for creating the golden template for the CVP Call/VXML data
server, also known as the CVP server.

Procedure

Step 1 Mount the Unified CVP ISO image to the virtual machine. For more information, see Mount ISO File, on
page 40

Step 2 Copy the current Engineering Specials to the local drive.
Ignore this step if there are no Engineering
Specials.

Note

Step 3 Navigate to the ISO file on the CD/DVD drive D.
Step 4 Run setup.exe from the D:\ CVP\Installer_Windows directory.
Step 5 Follow the InstallShield wizard to Run setup.exe from the D:\CVP\Installer_Windows directory:

a) In the Select Packages screen, check CVP Server.
b) In the Choose Destination Folder screen, select the folder locations for the CVP installation folder and

the Media Files Installation folder.
c) In the X.509 certificate screen, enter the information that you want to include in the certificate.
d) In the Ready to Install screen, click Install.
e) Restart the server after installation.

Step 6 If Unified CVP Engineering Specials are available, follow the InstallShield wizard to install them. Ignore this
step if there are no Engineering Specials.

Step 7 After the Engineering Special installation completes, launch the Services Microsoft Management Console
(MMC) and disable the Unified CVP OPSConsoleServer service.

Step 8 Copy the license file cvp.license to %CVP_HOME%\conf\license.
Step 9 Add any custom media files to the appropriate location.
Step 10 Unmount the ISO image.

Install Cisco Unified CVP OAMP server

This task is required for the direct install on Side A and for creating the golden template for the CVP
OAMP server, also known as the Operations Console.

Note

Procedure

Step 1 Mount the Cisco Unified CVP ISO image to the virtual machine. See Mount ISO File, on page 40.
Step 2 Copy the current Engineering Specials to the local drive.
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Ignore this step if there are no Engineering
Specials.

Note

Step 3 Navigate to the ISO file on the CD/DVD drive D.
Step 4 Run setup.exe from the D:\ CVP\Installer_Windows directory.
Step 5 Follow the InstallShield wizard to run setup.exe from the D:\CVP\Installer_Windows directory.
Step 6 In the Select Packages screen, check Operations Console

a) In the Choose Destination Folder screen, select the folder location for CVP installation.
b) Complete the Certificate screen.
c) In the Ready to Install screen, click Install.
d) Enter the password.
e) Restart the server.

Step 7 If Cisco Unified CVP Engineering Specials are available, follow the InstallShield wizard to install them.
Ignore this step if there are no Engineering Specials.

Step 8 After the Engineering Special installation completes, launch the Services Microsoft Management Console
(MMC) and disable Cisco CVP OPSConsoleServer service.

Step 9 Copy the license file cvp.license to %CVP_HOME%\conf\license.
Step 10 Unmount the ISO image.

Install the Unified CVP Reporting Server
This task is required for direct install of the optional CVP Reporting server.

Complete the following procedure to install the Unified CVP Reporting Server

Procedure

Step 1 Mount the Unified CVP ISO image to the virtual machine. For more information, see Mount ISO File, on
page 40.

Step 2 Copy the current Engineering Specials to the local drive.
Ignore this step if there are no Engineering
Specials.

Note

Step 3 Navigate to the ISO file on the CD/DVD drive.
Step 4 Run setup.exe from the DVD drive located at CVP\Installer_Windows directory.
Step 5 Follow the InstallShield wizard to Run setup.exe from the D:\CVP\Installer_Windows directory:

a) In the Select Packages screen, check Reporting Server.
b) In the Choose Destination Folder screen, select the folder locations for the CVP installation folder and

the Media Files Installation folder.
c) In the X.509 certificate screen, enter the information that you want to include in the certificate.
d) In the Choose the database data and backup drive screen, enter the drive letter (typically, E).
e) In the Database size selection screen, select Standard (250GB) or Premium (375GB).
f) In the Ready to Install screen, click Install.
g) Enter the Reporting Server password when prompted.

It can take some time for the database to install.
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h) Restart the server after installation.

Step 6 If Unified CVP Engineering Specials are available, follow the InstallShield wizard to install them. Ignore this
step if there are no Engineering Specials.

Step 7 After the Engineering Special installation completes, launch the Services Microsoft Management Console
(MMC) and disable Unified CVP OPSConsoleServer service.

Step 8 Copy the license file cvp.license to %CVP_HOME%\conf\license.
Step 9 Add any custom media files to the appropriate location.
Step 10 Unmount the ISO image.

Install Unified Intelligence Center COP file

The Cisco Unified Intelligence Center COP file applies the High Availability (HA) Logger support
introduced in Cisco Unified Intelligence Center Release 8.5(4). You must install in this sequence:

Note

• Install the COP file on the subscriber.

• Restart the subscriber.

• Install the COP file on the publisher

Procedure

Step 1 Download ciscocuic.cuic_854_ha_logger.cop from the Software Download Area to an SFTP server that can
be accessed from the CUIC 8.5(4) system.

Step 2 Use this CLI command to stop the CUIC service on the node on which you are installing the COP: utils service
stop Intelligence Center Reporting Service.

Step 3 Enter the commandutils system upgrade initiate to initiate the COP installation.
Step 4 Select remote file system as the source and set the remote path to the directory on the SFTP server where you

have downloaded the COP file.
If the COP file is located on a Linux or UNIX server, enter a forward slash at the beginning of the directory
path. For example, if the COP file is in the patches directory, enter /patches. If the COP file is located on a
Windows server, check with your system administrator for the correct directory path.
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Step 5 Enter the SFTP server name or IP address and credentials.
Step 6 Select the transfer protocol as SFTP. The system displays the list of COP files available in the SFTP location.
Step 7 Select the number corresponding to the COP file that you want to install. Then press Enter.
Step 8 Select Yes when prompted to start the installation. If this is the publisher, your installation ends here
Step 9 If this installation was done on the subscriber, restart the box and wait for about ten min. Then proceed with

installation on the publisher.
Step 10 Once installation is completed on the publisher, wait for about 20 min for the subscriber setup and dereplication

reset to complete. This can be verified by running the command utils dbreplication runtimestate. After this,
restart the system.

Install Golden Template for Unified Communications Manager,
Unified Intelligence Center, and Cisco Finesse

Complete this procedure to create golden templates for the VOS-based contact center applications:

• Cisco Unified Communications Manager

• Cisco Unified Intelligence Center

• Cisco Finesse

.

Procedure

Step 1 Mount the ISO file to the CD/DVD drive of the virtual machine. For more information, see Mount ISO File,
on page 40.

Step 2 Right-click the VM and select Edit Settings.
Step 3 Click Hardware and select CD|DVD Drive 1.
Step 4 Make sure that the Connected and Connect at power are both checked (Device status panel, upper right).
Step 5 Select the virtual machine and power it on. Then open the console. Text displays on the monitor while the

setup is prepared.
Step 6 Follow the Install wizard:

a) In the DVD Found screen, click Yes.
b) At the Media Check Result screen, click OK.
c) Text briefly displays on the screen.
d) In the Product Deployment Selection screen, select OK.
e) For Unified Communications Manager only, select Cisco Unified Communications Manager and click

OK. You obtain the License when you configure the Unified Communications Manager.
f) In the Proceed with Install screen, select Yes.
g) In the Platform Installation screen, select Skip.
h) About ten minutes into the installation, after the Component Installation completes, there is a reboot.
i) Press Ctrl Alt to free your cursor. Immediately, click the red Shut Down icon at the top left of the screen.
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j) Unmount the ISO image.

Direct Install Unified Communications Manager, Unified
Intelligence Center, and Finesse Publishers/Primary Nodes

This task is required for the publisher/primary nodes of the three VOS-based contact center applications:
Cisco Finesse, Cisco Communications Manager, and Cisco Unified Intelligence Center. Do not use this
procedure to create golden templates.

The installation uses a command-line interface. Use the Tab key to move to an option and the Enter key to
select it.

Before You Begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, and Cisco Finesse. To configure DNS, add the VMs to the forward and reverse lookups
of the DNS. See Configure DNS Server, on page 40

Procedure

Step 1 Right-click the VM and select Edit Settings.
Step 2 Click Hardware and select CD|DVD Drive 1.
Step 3 Make sure that the Connected and Connect at power are both checked (Device status panel, upper right).
Step 4 Select the virtual machine and power it on.
Step 5 Follow the Install wizard, making selections as follows:

a) In the DVD Found screen, click Yes to begin the verification of the media integrity.
b) In the Media Check Results screen, select OK.
c) In the Product Deployment Selection screen, select OK.
d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local timezone that most closely

matches where your server is located. select OK.
i) In the Auto Negotiation Configuration screen, select Yes.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission Units

(1500).
k) In the DHCP Configuration screen, select No. (Finesse does not have this step.)
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, select Yes.
n) Enter your DNS Client Configuration. Select OK.
o) In the Administrator Login Configuration screen, enter the ID for the system administrator. Enter and

confirm the password for the administrator. select OK.
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p) In the Certificate Information screen, enter data to create your Certificate Signing Request: Organization,
Unit Location, State, and Country. Select OK.

q) In the First Node Configuration screen, select Yes. Then select OK.
r) In the Network Time Protocol Client Configuration screen, enter a valid NTP server IP address and select

OK
s) In the Security Configuration screen, enter the security password and select OK.
t) In the SMTP Host Configuration screen, select No. (Finesse does not have this step.)
u) In the Application User Configuration screen, enter the application username, Enter and confirm the

application user password. Select OK.
v) In the Platform Configuration Confirmation screen, select OK. The installation begins and can run

unattended.
w) • There is a reboot in the middle of the installation.

• If you see a Product Licensing screen that shows the URL for obtaining the license
(https://tools.cisco.com/SWIFT/Licensing/PrivateRegistrationServlet and theMedia Access Control
(MAC) address. Write down this address; you will need it for the license application.

• The installation ends at a login prompt.

What to Do Next

After installing the publisher/primary node, you must configure the cluster to make the publisher/primary
nodes aware of the subscriber/secondary nodes.

Related Topics

Configure the Cluster for Cisco Unified Communications Manager, on page 52
Configure the Cluster for Cisco Unified Intelligence Center, on page 53
Configure the Cluster for Cisco Finesse, on page 53

Configure the Cluster for Cisco Unified Communications Manager

Procedure

Step 1 Launch Unified Communications Manager Publisher in a browser (http://<IP Addr of CUCM Publisher>).
Step 2 Select System > Server > Add New.
Step 3 On the Server Configuration tab, enter the IP Address of the subscriber.
Step 4 Click Save.
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Configure the Cluster for Cisco Unified Intelligence Center

Procedure

Step 1 Direct a browser to the URL http://<HOST ADDRESS>/oamp where HOST ADDRESS is the IP Address or
Hostname of your Cisco Unified Intelligence Center publisher.

Step 2 Sign in using the system application user ID and password that you defined during installation.
Step 3 From the panel in the left, select Device Management > Device Configuration.
Step 4 Click Add Member.
Step 5 On the Device Configuration fields for the Subscriber, enter a name, the hostname or IP address, and a

description for the device.

Configure the Cluster for Cisco Finesse

Procedure

Step 1 Launch the Cisco Finesse primary node in a browser (http://Primary Node IP Address/cfadmin), where the
Primary Node or IP Address is that of your host.

Step 2 Go toHome >Cluster Settings. (This is based on the default configuration and assumes you have not changed
the page for the Cluster Settings gadget.)

Step 3 Add the IP address for the Cisco Finesse secondary node..
Step 4 Click Submit.

Direct Install of Unified Communications Manager, Unified
Intelligence Center, and Finesse Subscribers/Secondary node

This task is required for installation of the subscriber/secondary nodes of the three VOS-based contact
center applications: Cisco Finesse, Cisco CommunicationsManager, and Cisco Unified Intelligence Center.
Do not use this procedure to create golden templates.

Before you install the subscriber/secondary nodes, you must install the publisher/primary nodes and
configure the clusters. Direct Install Unified Communications Manager, Unified Intelligence Center, and
Finesse Publishers/Primary Nodes, on page 51

Note
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Before You Begin

DNS Configuration is mandatory for Cisco Unified Communications Manager, Cisco Unified Intelligence
Center, and Cisco Finesse. To configure DNS, add the VMs to the forward and reverse lookups of the DNS.
See Configure DNS Server, on page 40

Procedure

Step 1 Right-click the VM and select Edit Settings.
Step 2 Click Hardware and select CD|DVD Drive 1.
Step 3 Make sure that the Connected and Connect at power are both checked (Device status panel,, upper right).
Step 4 Select the virtual machine and power it on.
Step 5 Follow the Install wizard, making selections as follows:

a) In the DVD Found screen, click Yes to begin the verification of the media integrity.
b) In the Media Check Results screen, select OK.
c) In the Product Deployment Selection screen, select OK.
d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local timezone that most closely

matches where your server is located. select OK.
i) In the Auto Negotiation Configuration screen, select Yes.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission Units

(1500).
k) In the DHCP Configuration screen, select No.
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, select Yes.
n) Enter your DNS Client Configuration. Select OK.
o) In the Administrator Login Configuration screen, enter the ID for the system administrator. Enter and

confirm the password for the administrator. select OK.
p) In the Certificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit Location, State, and Country. Select OK.
q) In the First Node Configuration screen, select No. Then select OK.

You see a warning screen and you must verify network connectivity to the first node.

r) In the Platform Configuration Confirmation screen, select OK. The installation begins and can run
unattended.

s) • There is a reboot in the middle of the installation.

• If you see a Product Licensing screen that shows the URL for obtaining the license
(https://tools.cisco.com/SWIFT/Licensing/PrivateRegistrationServlet and theMedia Access Control
(MAC) address, write down this address; you will need it for the license application.

• The installation ends at a login prompt.
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What to Do Next

After installing the Cisco Unified Intelligence Center subscriber, you must run the CUIC COP file. See Install
Unified Intelligence Center COP file, on page 49
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C H A P T E R  8
Configure Customer Instance

After you create VMs on the destination system—by golden template or direct-install—you must configure
those VMs for customer uer. This chapter contains the procedures you must perform.

Unless otherwise noted, the procedures in this section apply to both golden-template and direct-install
options.

Note

• Configure the Unified CCE Data Server, page 57

• Configure the Unified CCE Call Server, page 65

• Configure Cisco Unified CVP, page 77

• Configure Unified Communications Manager, page 88

• Configure Unified Intelligence Center, page 102

• Configure Cisco Finesse, page 108

• Configure Unified CVP Reporting Server, page 113

Configure the Unified CCE Data Server
This section explains the configuration procedures you must perform for the Unified CCE Data Servers.

Done?TaskSequence

Validate Network Adapter Settings and Power On, on
page 58

1

Configure Network Cards, on page 592

Edit Registry Settings and Restart VM, on page 603

Configure Unified CCE Encryption Utility, on page 614

Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)    
57



Done?TaskSequence

Configure SQL Server, on page 615

Configure Database Drives, on page 626

Configure the Unified CCE Logger, on page 627

Configure the Administration Server & Real-time Data
Server Components , on page 64

8

Verify Cisco Diagnostic Framework Portico , on page
65

9

Set up Cisco SNMP10

Validate Network Adapter Settings and Power On
For all VMs that use the Windows Operating System, validate the VM Settings as follows.

Procedure

Step 1 Access the VM and select Basic Tasks > Edit Virtual Machine Settings.
Step 2 On theHardware tab, select each Network adapter. Make sure that Connect at power on in the Device Status

group is checked:
a) Select the appropriate Network Connection in the Network label drop-down list. Unified CCE systems

have two network adapters. Network adapter 1 must be set to Public. Network adapter 2 must be set to
Private. All other VMs have only Network adapter 1, which must be set to Public.

b) Close the Edit Settings.

Step 3 Power on the virtual machine.
Step 4 DO NOT press Ctrl-Alt-Delete.
Step 5 Wait for the VM to restart itself and to apply customization. This can take five to ten minutes.

What to Do Next

If you press Ctrl-Alt-Delete after powering on, the customization does not take effect. You must complete
it manually. For more information, see Recover from Pressing Ctrl-Alt-Del During Power-On .

Warning

For the Unified CVP only, make sure all services are running.Important
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Configure Network Cards
For all the Unified CCE Call Servers and Data Servers, configure and validate the Network Cards as follows.

Procedure

Step 1 Select Start and right-click Network.
Step 2 Select Properties > Change Adapter Settings.
Step 3 Rename the Local Area Connection to visible. This is the Public network card.
Step 4 Rename the Local Area Connection 2 to private.
Step 5 On the Network Connections page, press Alt F to display the Advanced menu.
Step 6 From the Advanced menu choose Advanced Settings.
Step 7 Click Adapters and Bindings and move the connections so that visible is on top. Click OK.

Configure Private Ethernet Card
Complete the following procedure to configure the Private Ethernet card.

Procedure

Step 1 Right-click private and select Properties.
Step 2 Uncheck Client for Microsoft Networks.
Step 3 Uncheck File and Printer Sharing for Microsoft Networks.
Step 4 Uncheck Internet Protocol Version 6 (TCP/IPV6).
Step 5 Check Internet Protocol Version 4 and select Properties:

a) Remove the IP Address for the Default Gateway.
b) Remove the IP Address for the Preferred DNS server.
c) Remove the IP Address for the Alternate DNS server.

Step 6 Click the Advance button. Open the DNS tab. Uncheck Register this connection's addresses in DNS.
Step 7 Click OK twice. Then click Close.
Step 8 Add an entry for the private IP address. Append a suffix such as p to the hostname for this IP, to identify it

as a private.

Validate Visible Ethernet Card
Complete the following procedure to validate the Visible Ethernet card.
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Procedure

Step 1 Right-click visible and select Properties.
Step 2 Uncheck Internet Protocol Version 6 (TCP/IPV6).
Step 3 Check Internet Protocol Version 4 and select Properties.
Step 4 Confirm the data for Visible IP addresses, Subnet mask, Default gateway and Preferred and alternate DNS

servers for the template.
Step 5 Click OK. Then click Close.

Edit Registry Settings and Restart VM
Perform this task for golden templates for all the WIN2K8 machines that are cloned using the Automation
Tool.

Do not perform this step for direct installs.

Procedure

Step 1 Reset the Local Admin password on the machine:
a) Go to Start > Administrative Tools > Computer Management.
b) Expand Computer Management (Local) > System Tools > Local Users and Groups > Users on the

left panel.
c) On the right panel, right-click the Administrator and choose Set Password.
d) Click Proceed at the warning message, and then enter the new password.
e) Click OK to save.

Step 2 Access the Registry Editor (Start > Run > regedit).
Step 3 For both CCE Call Servers and CCE Data Servers, Sides A and B, navigate toHKEY_LOCAL_MACHINE

> SOFTWARE >Microsoft:
a) Continue to navigate toWindows NT > CurrentVersion >Winlogon.
b) Set AutoAdminLogon to 0.
c) Add or set DefaultDomainName to the customer domain name.
d) Add or set DefaultUserName to the customer user name.

Step 4 From the VM client, restart the machine and log in to the domain.

What to Do Next

To synchronize time with the domain controller, open a command prompt and type the commandNETTIME
/DOMAIN:<domain>.
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Configure Unified CCE Encryption Utility

Complete this procedure for the Unified CCE Call Servers and Data Servers on Side A and Side B.

Perform this procedure for golden templates only. Do not perform this procedure for direct installs.

Note

Procedure

Step 1 Start All Programs > Cisco Unified CCE Tools.
Step 2 Select SSL Encryption Utility.
Step 3 Click the Certificate Administration tab.
Step 4 Click Uninstall. Select Yes at the message.
Step 5 When the Uninstall completes, click Install.

You see a stream of messages, ending with SSL Certificate successfully installed.

Step 6 Click Close.

Configure SQL Server
Check for the BUILTIN\Administrators group on Side A and Side B of the MS SQL Server for the Unified
CCE database servers.

Procedure

Step 1 Go to Start > All Programs >Microsoft SQL Server 2008R2 > SQL Server Management Studio.
Step 2 Expand Security and then Logins.
Step 3 Use the default settings to log in.

a) Double-click BUILTIN\Administrators.
b) Expand Server Roles.
c) Make sure that public and sysadmin are both checked.

Step 4 If Logins does not contain BUILTIN\Administrators:
a) Right-click Logins and select New Login.
b) Select Search and then Locations to locate BUILTINS in the domain tree.
c) Type Administrators and click Check Name and then OK.
d) Double-click BUILTIN\Administrators.
e) Expand Server Roles.
f) Make sure that public and sysadmin are both checked.

Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)    
61

Configure Customer Instance
Configure Unified CCE Encryption Utility



Configure Database Drives
Complete the following procedure to configure the database drives for the Unified CCE database servers on
Side A, Side B and the CVP Reporting Server. These servers need an additional drive to archive data.

You must perform this procedure if you deploy the optional CVP Reporting Server.

Procedure

Step 1 Choose Start > All Programs > Administrative Tools > Computer Management.
Step 2 Under Storage, click Disk Management.
Step 3 At the popup, Select Disks: Disk 1 the optionUse the following partition style for the selected disks:MBR

(Master Boot Record).
Step 4 Create a new disk partition as follows: right-click the disk you just initialized, choose New Simple Volume,

and follow the wizard. Keep the default drive size of 767997 MB.

Configure the Unified CCE Logger
Complete the following procedure to configure the Unified CCE logger on the Unified CCE Data Server for
Side A and Side B.

Ensure that your browser is enabled.Note

Procedure

Step 1 Launch the Unified CCEWeb Setup.
Step 2 Sign in using as domain user having local Administrator rights.
Step 3 Click Instance Management, and then click Add.
Step 4 On the Add Instance page, configure as follows and then click Save:

a) Choose the customer facility and instance.
b) In the Instance Number field, enter 0.

Step 5 Configure the logger database as follows:
a) Choose Start > All Programs > Cisco Unified CCE Tools > ICMdba. Click Yes at the warnings.
b) Navigate to Server > Instance (logger being installed).
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c) Right-click the instance name and choose Create to create the logger database.

Step 6 In the Select Component dialog box, choose the logger you are working on ( Logger A or Logger B). Click
OK.

Step 7 At the prompt, "SQL Server is not configured properly. Do you want to configure it now?" Click Yes.
Step 8 On the Configure page, in the SQL Server Configurations pane check Memory (MB) and Recovery Interval.

Click OK.
Step 9 On the Stop Server page, click Yes to stop the services.
Step 10 In the Select Logger Type dialog box, choose Enterprise. Click OK.
Step 11 In the Create Database dialog box, configure as follows to create the Log:

a) In the DB Type field, choose the Side (A or B).
b) In the region field, choose your region.
c) In the Storage pane, click Add.

Step 12 In the Create Database dialog box, click Add. The Add Device dialog box appears. In the Add Device, do
the following:
a) Click Data
b) Choose the E drive.
c) Enter 665600 MB in the Size field.
d) Click OK to return to the Create Database dialog box.

Step 13 In the Add Device dialog box, configure as follows:
a) Click Log.
b) Choose the E drive.
c) Enter 3072MB in the Size field.
d) Click OK to return to the Create Database dialog box.

Step 14 In the Create Database dialog box, click Create. Then click Start.
When you see the successful creation message, click OK and then Close.

Step 15 Configure the logger component as follows:
a) Return to Unified CCEWeb Setup. You ,,might need to log in again.
b) Choose Component Management > Loggers. Click Add. Choose the Instance.
c) On the Deployment page, select the Logger (A or B). Click Duplexed. Click Next.
d) On the Central Controller Connectivity page, enter the host names for Sides A and B for the Router Private

Interface and Logger Private Interface.

Step 16 On the Additional Options page, click Display Database Purge Configuration Steps:
a) If an external AW-HDS-DDS exists in the deployment, checkEnable Historical/Detail Data Replication.

If no external AW-HDS-DDS exists in the deployment, leaveEnable Historical/Detail Data Replication
unchecked.

b) Check Display Database Purge Configuration Step.
c) Click Next.

Step 17 On the Data Retention page, modify the Database Retention Configuration table:
a) For the seven following tables, set the retention period to 40 days: Application_Event, Event,

Network_Event, Route_Call_Detail, Route_Call_Variable, Termination_Call_Detail, and
Termination_Call_Variable.

b) Set the retention period for all other tables to 400 days.
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c) Click Next,

Step 18 On the Data Purge page, configure purge for a time when there is low demand on the system. Click Next.
Step 19 Review the Summary page, and then click Finish.

Database and Log File Size
Steps to increase tempdb and log file size.

Procedure

Step 1 Go to Start > All Programs >Microsoft SQL Server 2008R2.
Step 2 Open SQL Server Management studio, using the default credentials to sign in. Expand the Databases tree.

Then expand System databases.
Step 3 Right click tempdb and go to Properties.
Step 4 Click on Files on the left pane.
Step 5 On the right pane change the tempdev size to 1400 MB and the templog file size to 512 MB.
Step 6 Click OK.

Configure the Administration Server & Real-time Data Server Components
Complete the following procedure to configure the Administration Server &Real-timeData Server components
for the Unified CCE Data Servers on Side A and Side B.

Procedure

Step 1 Return to the Unified CCEWeb Setup.
Step 2 Choose Component Management > Administration & Data Servers. Click Add.
Step 3 On the Deployment page, choose the current instance.
Step 4 On the Add Administration & Data Servers page, configure as follows:

a) Click Enterprise.
b) Click Small to Medium Deployment Size.
c) Click Next.

Step 5 On the Server Role in a Small to Medium Deployment page, choose the option Administration Server and
Real-time Data Server (AW). Click Next.

Step 6 On the Administration & Data Servers Connectivity page:
a) For Side A and Side B, click Primary Administration Server .
b) Do not configure a Secondary Administration Server for either Side A or Side B.
c) In the Primary Name field, enter the data server hostnames for Side A and Side B.
d) Click Next.
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For example, if the data server on Side A is named CCE-DS-A and the data server on Side B is named
CCE-DS-B, the Side A AW should be configured as a Primary AW with site CCE-DS-A. The Side B AW
should be configured as a Primary AW with site CCE-DS-B.

Step 7 On the Database and Options page, configure as follows:
a) In the Create Database(s) on Drive field, choose C.
b) Click Agent Re-skilling web tool. Click OK at the warning message.
c) Click Internet script editor.
d) Click Next.

Step 8 On the Central Controller Connectivity page, configure as follows:
a) For Router Side A, enter the Call Server Side A Public Interface.
b) For Router Side B, enter the Call Server Side B Public Interface.
c) For Logger Side A, enter the Data Server Side A Public Interface.
d) For Logger Side B, enter the Data Server Side B Public Interface.
e) Enter the Central Controller Domain Name.
f) Click Central Controller Side A Preferred.
g) Click Next.

Step 9 Review the Summary page, and then click Finish.

Verify Cisco Diagnostic Framework Portico
Do this for the Unified CCE Call Server and Unified CCE Data Server, Sides A and B. This procedure applies
only to golden templates.

Procedure

Step 1 Open the command prompt and enter cd C:\.
Step 2 Enter cd icm\serviceability\diagnostics\bin and press Enter.
Step 3 Enter DiagFwCertMgr /task:CreateAndBindCert /port:7890 and press Enter.
Step 4 Go to Start -> Run and enter services.msc to open the Services tool. Make sure the Cisco Diagnostic

Framework service is running. If it is not, start it.
Step 5 OpenDiagnostic Framework Portico: Start > Programs >CiscoUnifiedCCETools >Diagnostic Framework

Portico. Then make sure you can log in to the Diagnostic Framework Portico using domain user credentials.

Configure the Unified CCE Call Server
This section explains the configuration procedures you must perform for the Unified Call Server Sides A and
B.
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Done?TaskSequence

Validate Network Adapter Settings and Power On, on page 581

Configure Network Cards, on page 592

Edit Registry Settings and Restart VM, on page 603

Configure Domain Manager, on page 664

Configure Unified CCE Encryption Utility, on page 615

Configure Unified CCE Router, on page 676

Configure Generic Peripheral Gateway, on page 687

Configure CTI Server, on page 728

Configure Media Routing Peripheral Gateway, on page 729

Configure CTI OS Server, on page 7510

Provision Unified CCE, on page 7611

Install JTAPI, on page 7612

Verify Cisco Diagnostic Framework Portico , on page 6513

Configure Domain Manager
You do this once, on the first Unified CCE Server that you configure. Configuring Domain Manager for the
Side A Unified CCE Server also configures the domain manager for the Side B Unified CCE Server and both
Side A and Side B Data Servers.
Skip this procedure if have already done it when you configured the Data Server.

Procedure

Step 1 Choose Start > All Programs > Cisco Unified CCE Tools > Domain Manager.
Step 2 Log in to an administrator's account in the domain.
Step 3 Choose the domain that you want to add.
Step 4 If this is the first instance, add the Cisco Root as Cisco_ICM:

a) Click Cisco Root Add. Then click Add.
b) Select the OU under which you want to create the Cisco Root OU, then click OK.
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When you return to the Domain Manager dialog box, the Cisco Root OU appears either at the domain
root, or under the OU you selected. You can now add the facility.

Step 5 Add the facility organizational unit (OU):
a) Select the Cisco Root OU under which you want to create the Facility OU.
b) In the right pane, under Facility, click Add.
c) Enter the name for the Facility. Then click OK.

Step 6 Add the Instance OU:
a) Navigate to and select the Facility OU under which you want to create the Instance OU.
b) In the right pane, under Instance, click Add.
c) Enter the Instance name and click OK.

Step 7 Click Close.

Configure Unified CCE Router
Complete the following procedure to configure the router for the Unified CCE Call Servers on Side A and
Side B.

Procedure

Step 1 Launch the Unified CCE Web Setup.
Step 2 Sign in as the domain user with local Administrator permission.
Step 3 Click Instance Management, and then click Add.
Step 4 In the Add Instance dialog box, select the customer facility and instance.
Step 5 In the Instance Number field, enter 0. Click Save.
Step 6 Choose Component Management > Routers.
Step 7 Click Add to set up the Call Router.
Step 8 In the Deployment dialog box, click the appropriate Side.
Step 9 Click Duplexed. Click Next.
Step 10 In the Router Connectivity dialog box configure the Private Interface and Public (Visible) Interfaces. Click

Next.
Step 11 In the Enable Peripheral Gateways dialog box enter 1-2 in the Enable Peripheral Gateways field. Click

Next.
Step 12 In the Router Options dialog box, check Enable Quality of Service (QoS) check box, and then click Next.

This step applies to Side A only.

Step 13 In Router Quality of Service, click Next.
Step 14 In the Summary dialog box, make sure that the Router summary is correct, then click Finish.
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Configure Generic Peripheral Gateway
Complete the following tasks to configure the Unified CCE peripheral gateways for the Call Server on Side
A. Then repeat all tasks for Side B.

Related Topics

Prepare to Add PIMs, on page 68
Add PIM1 (CUCM PIM), on page 68
Add PIM2 (first VRU PIM), on page 69
Add PIM3 (second VRU PIM), on page 69
Add PIM4 (third VRU PIM), on page 70
Add PIM5 (fourth VRU PIM), on page 70
After Creating PIMs, on page 71

Prepare to Add PIMs
Complete the following procedure to prepare to add PIMs (Peripheral Interface Manager):

Procedure

Step 1 Choose Start > All Programs > Cisco Unified Tools > Peripheral Gateway Setup.
Step 2 Click Add in the Instance Components pane, and from the Component Selection dialog box choose

Peripheral Gateway.
Step 3 In the Peripheral Gateway Properties dialog box:

a) Check Production mode.
b) Check Auto start system startup.
c) Check Duplexed Peripheral Gateway.
d) Choose PG1 in the PG node Properties ID field.
e) Click the appropriate Side (Side A or Side B).
f) Add CUCM to the selected types.
g) Add VRU to the selected types.
h) Click Next.

Add PIM1 (CUCM PIM)
In the Peripheral Interface Manager pane of the Peripheral Gateway Component Properties dialog box,
click Add and configure PIM1 with the Client Type of CUCM as follows
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Procedure

Step 1 Check Enabled.
Step 2 In the Peripheral name field, enter CM.
Step 3 In the Peripheral ID field, enter 5000.
Step 4 In the Agent extension length field, enter extension length for this deployment.
Step 5 In the CallManager Parameters pane, configure as follows:

a) In the Service field, enter the hostname of Communications Manager Subscriber.
b) In the User ID field, enter pguser.
c) In the User password field, enter your password.
d) In theMobile Agent Codec field, choose G.711 or G.729.

Step 6 Click OK.

Add PIM2 (first VRU PIM)
In the Peripheral Interface Manager pane of the Peripheral Gateway Component Properties dialog box,
click Add and configure PIM2 with the Client Type of VRU as follows.

Procedure

Step 1 Check Enabled.
Step 2 In the Peripheral name field, enter CVP1.
Step 3 In the Peripheral ID field, enter 5001.
Step 4 In the VRU Connect port field, enter 5000.
Step 5 In the Reconnect interval (sec) field, enter 10.
Step 6 In the Heartbeat interval (sec) field, enter 5.
Step 7 n the DSCP field, choose CSC3(24).
Step 8 Click OK.

Add PIM3 (second VRU PIM)
In the Peripheral Interface Manager pane of the Peripheral Gateway Component Properties dialog box,
click Add and configure PIM3 with the Client Type of VRU as follows.
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Procedure

Step 1 Check Enabled.
Step 2 In the Peripheral name field, enter CVP2.
Step 3 In the Peripheral ID field, enter 5002.
Step 4 In the VRU Connect port field, enter 5000.
Step 5 In the Reconnect interval (sec) field, enter 10.
Step 6 In the Heartbeat interval (sec) field, enter 5.
Step 7 n the DSCP field, choose CSC3(24).
Step 8 Click OK.

Add PIM4 (third VRU PIM)
In the Peripheral Interface Manager pane of the Peripheral Gateway Component Properties dialog box,
click Add and configure PIM4 with the Client Type of VRU as follows.

Procedure

Step 1 Check Enabled.
Step 2 In the Peripheral name field, enter CVP3.
Step 3 In the Peripheral ID field, enter 5003.
Step 4 In the VRU Connect port field, enter 5000.
Step 5 In the Reconnect interval (sec) field, enter 10.
Step 6 In the Heartbeat interval (sec) field, enter 5.
Step 7 n the DSCP field, choose CSC3(24).
Step 8 Click OK.

Add PIM5 (fourth VRU PIM)
In the Peripheral Interface Manager pane of the Peripheral Gateway Component Properties dialog box,
click Add and configure PIM5 with the Client Type of VRU as follows.
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Procedure

Step 1 Check Enabled.
Step 2 In the Peripheral name field, enter CVP4.
Step 3 In the Peripheral ID field, enter 5004.
Step 4 In the VRU Connect port field, enter 5000.
Step 5 In the Reconnect interval (sec) field, enter 10.
Step 6 In the Heartbeat interval (sec) field, enter 5.
Step 7 n the DSCP field, choose CSC3(24).
Step 8 Click OK.

After Creating PIMs

Procedure

Step 1 Enter 5000 in the Logical Controller ID field.
Step 2 Enter 0 in the CTI Call Wrapup Data delay field.
Step 3 In the VRU Reporting pane, click Service Control and check Queue Reporting. Click Next.
Step 4 In the Device Management Protocol Properties dialog box, click Side A Preferred.
Step 5 If you are configuring Side A:

• Side A Properties panel = Call Router is local.

• Side B Properties panel = Call Router is remote (WAN).

Step 6 If you are configuring Side B:

• Side A Properties panel = Call Router is remote (WAN).

• Side B Properties panel = Call Router is local.

Step 7 Enter 30000 in the Usable Bandwidth (kbps) field.
Step 8 Enter 4 in the Heartbeat Interval (100ms) field. Click Next.
Step 9 In the Peripheral Gateway Network Interfaces dialog box, enter the PG Private Interfaces and the PG

Public (Visible) Interfaces.
Step 10 Click the QoS button in the private interfaces section for Side A. In the PG Private Link Qos Settings, check

the check box Enable QoS and click OK.
Step 11 Click the QoS button in the public interfaces section. In the PG Visible Link Qos Settings, check Enable QoS

and click OK.
This step applies only to Side A.
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Step 12 In the Peripheral Gateway Network Interfaces dialog box, click Next.
Step 13 In the Check Setup Information dialog box, click Next.
Step 14 In the Setup Complete dialog box, click Finish.

Configure CTI Server
Follow this procedure to configure the CTI Server for the CUCM PIM.

Procedure

Step 1 In the Instance Components pane of the Components Setup dialog box click Add.
Step 2 In the Component Selection dialog box, click CTI Server.

a) Check Production mode.
b) Check Auto start at system startup.
c) Check Duplexed CTI Server.
d) Choose CG1 in the CG node properties pane ID field.
e) Enter 1 in the CG node properties ICM system ID field.
f) Click the appropriate side (Side A or Side B).
g) Click Next.

Step 3 In the Server Component Properties dialog box, configure as follows:
a) For Side A, enter 42027 in the Client Connection Port Number field.
b) For Side B, enter 43027 in the Client Connection Port Number field.

Step 4 Click Next.
Step 5 In the Network Interface Properties dialog box, enter the private interfaces.
Step 6 Enter the public (visible) interfaces. Click Next.
Step 7 Check that all settings are correct, and Click Next.
Step 8 In the Setup is Complete dialog box, click Finish.
Step 9 Click Exit Setup.

Configure Media Routing Peripheral Gateway
Complete the following procedures to configure the Unified CCE Media Routing Peripheral Gateway for the
call servers on Side A and then repeat for Side B. The Media Routing Peripheral Gateway has two PIMs-the
MultiChannel PIM and the Outbound PIM.

You must configure this PG, even if Multichannel and Outbound are not used. In that case, this PG remains
idle.

Related Topics

Configure Multichannel PIM, on page 73
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Configure Outbound PIM, on page 74

Configure Multichannel PIM
Complete the following procedure to configure multichannel PIM:

Procedure

Step 1 Choose Start > Programs > Cisco Unified Tools > Peripheral Gateway Setup.
Step 2 Click Add in the Instance Components pane, and from the Component Selection dialog box choose

Peripheral Gateway.
Step 3 In the Peripheral Gateway Properties dialog box:

a) Check Production Mode.
b) Check Auto start system startup.
c) Check Duplexed Peripheral Gateway.
d) Choose PG2 in the PG node Properties ID field.
e) Click the appropriate Side (Side A or Side B).
f) AddMedia Routing to the selected types.
g) Click Next.

Step 4 In the Peripheral Interface Manager pane of the Peripheral Gateway Component Properties dialog box,
click Add and configure PIM1 with the Client Type of Media Routing as follows:
a) Check Enabled.
b) In the Peripheral name field, enter MR.
c) In the Peripheral ID field, enter 5005.
d) In theApplicationHostname (1), field, enter the host name or the IP address of themultichannel application

server machine .
e) In the Application connection port (1), field, enter the port number on the application server machine

that the PIM will use to communicate with the application. The default port is 38001.
f) In theApplicationHostname (2), field, enter the host name or the IP address of themultichannel application

server machine.
g) In the Application connection port (2), field, enter the port number on the application server machine

that the PIM will use to communicate with the application.
h) In the Heartbeat interval (sec) field, enter 5.
i) Click OK.

Step 5 Enter 5001 in the Logical Controller ID field.
Step 6 Enter 0 in the CTI Call Wrapup Data delay field. Click Next.
Step 7 In the Device Management Protocol Properties dialog box, click Prefer Side A.
Step 8 For both Side A and Slide B properties, click Call Router is local.

a) In a Wide Area Network (WAN):
b) • Click Call Router is local for Side A and

• Click Call Router is remote for Side B.
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Step 9 Enter 30000 in the Usable Bandwidth (kbps) field.
Step 10 Enter 4 in the Heartbeat Interval (100ms) field. Click Next.
Step 11 In the Peripheral Gateway Network Interfaces dialog box, enter the PG Private Interfaces and the PG Public

(Visible) Interfaces.
a) Click the QoS button in the private interfaces section. In the PG Private Link Qos Settings, check the

check box Enable QoS and click OK.
b) Click theQoS button in the public interfaces section. In the PGVisible Link Qos Settings, check the check

box Enable QoS and click OK.

Step 12 In the Check Setup Information dialog box, click Next.
Step 13 In the Setup Complete dialog box, click Finish.
Step 14 Exit Setup.

Configure Outbound PIM

Procedure

Step 1 Open the Call Server and select Start > All programs > Cisco Unified Tools >Peripheral Gateway Setup.
Step 2 Select PG2<Side> on the right pane and click Edit.
Step 3 Click Next and go to Peripheral Interface Manager pane of the Peripheral Gateway component properties

dialog box.
Step 4 Click Add and configure PIM2 with the client type of Media Routing as follows:

a) Check Enabled.
b) In the peripheral name field, enterMR2 or a name of your choice.
c) In the Peripheral ID field, enter 5006.
d) In the Application Hostname(1) field, enter UCCE call server sideA IP.
e) The Application Connection port (1), retain the default value.
f) In the Application Hostname (2), field, enter UCCE Call server side B IP.
g) The Application Connection port (2), retain the default value.
h) In the Heartbeat interval (sec) field, enter 5 and click OK.

Step 5 Enter 5001 in the Logical Controller ID field. Leave all other fields with default values and click Next.
Step 6 In the Device Management Protocol properties dialog box, click Prefer side A. Then clickNext, leaving other

fields with default values.
Step 7 In the Peripheral Gateway Network Interface dialog box, enter the PG private interface and PG Public (visible)

interfaces. Click Next.
Step 8 Click Next on the Check Setup Information dialog box.
Step 9 In the Setup Complete dialog box, click Finish.
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Configure CTI OS Server
Complete the following procedure to configure the CTI OS server for Side A and Side B.

Procedure

Step 1 Mount the CTIOS 9.0(1) ISO image or copy the CTIOS 9.0(1) installer to the local drive of UCCECall Server.
Step 2 If a maintenance release for CTIOS 9.0(1) is available, copy the maintanance release to the local drive of

UCCE Call Server.
Step 3 Navigate to CTIOS Server and run setup.exe. Click Yes to the warning that the service will be stopped and

then restarted after the installation completes.
Step 4 Accept the Software License Agreement.
Step 5 Browse to the location for the latest Maintenance Release, if any.
Step 6 In the CTIOS Instances dialog box, click Add in the CTI OS Instance List pane. Enter the instance name for

this deployment and click OK.
Step 7 In the CTI OS Server List pane, click Add. Click OK.
Step 8 In the Enter Desktop dialog box, choose drive C. Click OK.
Step 9 In the CTI Server Information screen, enter the IP address of the Call Server and the ports for Side A (42027)

and Side B (43027). Then click Next.
Step 10 In the Peripheral Identifier dialog box, accept all defaults. In the Login By pane, click Agent ID and then click

Next.
Step 11 In the Connect Information dialog box, accept all defaults and then click Next.
Step 12 In the Statistics Information dialog box check Polling for Agent Statistics at End Call, and then click Next.
Step 13 In the IPCC Silent Monitor Type dialog box, set Silent Monitor Type to Disabled and click Next.
Step 14 In the Peer CTIOS Server dialog box, configure as follows:

a) Check Duplex CTIOS Install.
b) If you are configuring Side A, set the hostname of the CCE Call Server Side B. If you are configuring

Side B, set the hostname of the CCE Call Server Side A.
c) In the Port field, enter 42028.

Step 15 Click Finish.
Step 16 In the Cisco CTIOS Server Security dialog box, uncheck Enable Security. Click OK.
Step 17 In the CTI OS Security Setup Complete dialog box click Finish.
Step 18 If prompted to restart the computer, click Yes. If there is a Maintenance Release, its installation begins

automatically.
Step 19 Follow all prompts to install the Maintenance Release, if there is one.
Step 20 When the MR install completes, click Finish and follow the prompts to restart.

What to Do Next

1 Access Registry Editor (Start > Run > regedit).

2 Navigate toHKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems,Inc.\Ctios\CTIOS_<instance
name>\CTIOS1\Server\Agent.
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3 Set forceLogoutOnSessionClose Dword to 1.

Provision Unified CCE
After you run the base configuration using ICMDBA, you must perform the tasks listed here in Cisco Unified
CCE Configuration Manager.
If you are using an Administration Server and Real-time Data Server system or an Administration Client
system, double-click the Unified CCE Tools icon on the desktop, and then choose Administration Tools.

• Install the JTAPI Client on the PG. Configure network trunk groups (one for each VRU PIM).

• Configure trunk groups. These trunk ID's match the IDs configured in CVP and the gateway.

• Enable ECC variables.

• Create Agent Targeting Rule

• Configure call types.

• Configure dialed numbers.

• Configure routing in Script Editor and schedule for the Call Type.

• Configure routing and administrative scripts.

Install JTAPI

This task is a required post-cloning task for the Unified CCE Call Server. To download JTAPI, you must
launch the CUCM Admin page on the Unified CCE Call Server. You will return to this step after you
Configure Unified Communications Manager.

Note

Complete the following procedure to install JTAPI on the Cisco Unified CCE Call Servers for Side A and
Side B.

Procedure

Step 1 From the Unified CCE Call Server, launch the Unified Communications Manager in a browser
(https://{callmanager-hostname}) and sign in.

Step 2 Navigate to Application > Plugins. Click Find.
Step 3 Download the Cisco JTAPI 32-bit Client for Windows.
Step 4 Install the downloaded file, accepting all of the default settings.
Step 5 At the prompt, enter the IP address for the Communications Manager TFTP Server.
Step 6 Click Done.
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Configure Cisco Unified CVP
This section explains the procedure to configure Cisco Unified CVP.

Done?TaskSequence

Validate Network Adapter Settings and Power On, on page
58

1

Enable Unified CVP Operations Console, on page 782

Edit Registry Settings and Restart VM, on page 603

Configure Unified CVP Call Server, on page 784

Configure Cisco Unified CVP VXML Server, on page 795

Configure Gateways, on page 806

Configure Unified CVP Media Server, on page 807

Transfer Scripts and Media Files, on page 818

Configure SNMP, on page 819

Configure SIP Server Group, on page 8210

Configure Dialed Number Pattern, on page 8311

Configure Cisco IOS Enterprise Voice Gateway, on page 8412

Configure and Validate Network Card for Unified CVP
For all Unified CVP servers, configure and validate the Network Cards as follows.

Configure
Complete the following procedure to configure the Ethernet card.

Procedure

Step 1 Choose Start and right-click Network.
Step 2 Select Properties. Then select Change Adapter Settings.
Step 3 Press Alt F from the Network Connections page to display the Advanced menu.
Step 4 From the Advanced menu choose Advanced Settings.
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Validate
Complete the following procedure to validate the Ethernet card.

Procedure

Step 1 Right-click Local Area Connection and select Properties.
Step 2 Uncheck Internet Protocol Version 6 (TCP/IPV6).
Step 3 Check Internet Protocol Version 4 and select Properties.
Step 4 Confirm the data for Visible IP addresses, Subnet mask, Default gateway and Preferred and alternate DNS

servers for the template.
Step 5 Click OK.

Enable Unified CVP Operations Console
Complete the following procedure on the Unified CVP OAMP server to enable Unified CVP Operations
Console.

Procedure

Step 1 Go to Start-> Run and type services.msc.
Step 2 Check that Unified CVP OPSConsoleServer service is running.

If it is not, right-click that service and click Start.

Step 3 Go to Start -> All Programs -> Cisco Unified Customer Voice Portal -> Operation Console to open the
Unified CVP OPSConsole page. With IE, you will need to accept the self-signed certificate.

Configure Unified CVP Call Server
Complete the following procedure to configure the Call Server component on the Unified CVP Call/VXML
Servers. There are two CVP Call/VXML Servers on Side A and two on side B.
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Procedure

Step 1 In the Unified CVP Operations console, navigate to Device Management > Unified CVP Call Server.
Step 2 Click Add New.
Step 3 On the General tab, enter the IP address and the hostname of the Cisco Unified CVP Call/VXML Server.

Check ICM, IVR, and SIP. Click Next.
Step 4 Click the ICM tab. For each of the Cisco Unified CVP Call Servers, retain the default port of 5000 for the

VRU connection port.
Step 5 Click the SIP tab:

a) In the Enable outbound proxy field, click No.
b) In the Use DNS SRV type query field, click Yes.
c) Check Resolve SRV records locally.

Step 6 Click the Device Pool tab. Make sure the default device pool is selected.
Step 7 (This step is optional.) Click the Infrastructure tab. In the Configuration Syslog Settings pane, configure

these fields as follows:
a) Enter the IP address or the hostname of the syslog server.
b) Enter 514 for the port number of the syslog server.
c) Enter the name of the backup server to which the reporting server writes log messages.
d) In the Backup server port number field, enter the port number of the backup syslog server.

Step 8 Click Save & Deploy.
Step 9 Repeat Steps 1 through 8 for the next three Unified CVP Call Servers.

Configure Cisco Unified CVP VXML Server
Complete the following procedure to configure the VXML Server component on the Cisco Unified CVP
Call/VXML Servers. There are two Unified CVP Call/VXML Servers on Side A and two on side B.

Procedure

Step 1 In the CVP Operations console, navigate to Device Management > Unified CVP VXML Server.
Step 2 Click Add New.
Step 3 On the General tab, enter the IP address and the hostname of the Cisco Unified CVP Call/VXML Server.
Step 4 Configure the primary and backup CVP Call Servers as follow:

a) For CVP-1A, the primary call server is CVP-1A and the backup call server is CVP-1B.
b) For CVP-2A, the primary call server is CVP-2A and the backup call server is CVP-2B.
c) For CVP-1B, the primary call server is CVP-1B and the backup call server is CVP-1A.
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d) For CVP-2B, the primary call server is CVP-2B and the backup call server is CVP-2A.

Step 5 Click the Device Pool tab. Make sure the default device pool is selected.
Step 6 Click Save & Deploy.
Step 7 Repeat Steps 1 through 6 for all CVP Call Servers.

Configure Gateways
Complete the following procedure to configure every gateway.

Procedure

Step 1 In theCVPOperations Console, navigate to theGatewayDevice. ChooseDeviceManagement >Gateway.
Step 2 Click Add New.
Step 3 On the General tab, configure as follows:

a) Enter the IP address of the gateway.
b) Enter the hostname.
c) Choose the device type.
d) In the Username and Passwords pane, enter the gateway username and a password.

Step 4 Click Save.
Step 5 Do this for every gateway.

Configure Unified CVP Media Server

Procedure

Step 1 Sign in to the CVP Operations Console.
Step 2 Navigate to theMedia Server Device. Choose Device Management >Media Server.
Step 3 Click Add New.
Step 4 On the General tab, enter the IP address and the hostname of the CVP server.
Step 5 Click Save.
Step 6 Repeat Steps 1 through 5 for all four Media Servers.
Step 7 Change Default Media Server from None to any one of the CVP servers. Then click Set.
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Transfer Scripts and Media Files
Create the notification destination and deploy to all of the Unified CVP devices.

Procedure

Step 1 Sign in to the CVP Operations Console.
Step 2 Navigate to Scripts & Media. Choose Bulk Administration > File Transfer > Scripts & Media.
Step 3 In the Select device type field, choose Gateway.
Step 4 Move all Gateways to Selected.
Step 5 Click Default Gateway files.
Step 6 Click Transfer and select OK at the popup window.
Step 7 Click File Transfer Status to monitor transfer progress.

Configure SNMP

This step is optional. For more information, see Simple Network Management Protocol, on page 143Note

Complete the following procedure to configure SNMP. You must complete this procedure for servers on Side
A and Side B.

Procedure

Step 1 Sign in to the CVP Operations Console.
Step 2 Select SNMP > V1/V2c.
Step 3 Select Community String > Add New.

a) Name the community string and verify that the default values for other fields are correct.
b) Select the Devices tab and assign the SNMP community string to a device.
c) Click Save and Deploy.

Step 4 Create the notification destination and deploy to all of the Unified CVP devices.
a) Select Notification Destination > Add New.
b) Complete the fields.
c) Select the Devices tab and assign the SNMP notification destination to a device.
d) Click Save and Deploy.
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Configure SIP Server Group
Complete the following procedure to configure the SIP Server Group.

Before You Begin

The following devices require the SIP Server Group:

• Unified Communications Manager

• Gateway

Procedure

Step 1 Launch the CVP Operations console.

Example:

Step 2 Navigate to System > SIP Server Group.
Step 3 Create a server group for the Unified Communications Manager devices:

a) On the General tab, click Add New.
b) In the SRV Domain Name FQDN field, enter the service record (SRV) fully qualified domain name

(FQDN).
The FQDN should match the FQDN configured in the Enterprise Cluster FQDN setting on the Cisco
Unified CommunicationsManager. For more information, see Validate ClusterwideDomain Configuration,
on page 94. For example, cucm.cisco.com. Adding the cluster subscriber nodes will load balance across
all sub nodes.

c) In the IP Address/Hostname field, enter an IP address or hostname for the Unified Communications
Manager node.

d) Click Add.
e) Repeat Steps c and d for each Unified Communications Manager node. Click Save.

Do not put the Publisher node in the server group—it is not used for call processing.Note

Step 4 Create a server group for the gateway devices:
a) On the General tab, click Add New.
b) In the SRV Domain Name FQDN field, enter the SRV Domain Name FQDN. For example

vxmlgw.cisco.com.
c) In the IP Address/Hostname field, enter an IP address or hostname for each gateway.
d) Click Add.
e) Repeat Steps c and d for each gateway.

Add all VXML gateways as appropriate for deployment and branches. Adding all VXML gateways to the
server group will load balance calls across all the member server group gateways.

Step 5 Associate these server groups to all Unified CVP Call Servers:
a) On the Call Server Deployment tab, move all Unified CVP Call Servers from the Available list to the

Selected list.
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b) Click Save and Deploy.

Step 6 Click Deployment Status to make sure that you applied the configuration.

Configure Dialed Number Pattern
Complete the following procedure to configure a dialed number pattern for CCE PAC M1.

Before You Begin

The following labels require a dialed number pattern:

• Agent Device

• Network VRU

• Ringtone

• Error

Procedure

Step 1 Navigate to System > Dialed Number Pattern.
Step 2 For each dialed number pattern in the following table:

a) Click Add New.
b) In the Dialed Number Pattern field, enter the dialed number pattern.
c) In the Description field, enter a description for the dialed number pattern.
d) In the Dialed Number Pattern Types pane, check the specified dialed number pattern type.
e) Click Save.

Step 3 After you configure all dialed number patterns, click Deploy.
Step 4 Click Deployment Status to make sure that you applied the configuration.

Dialed Number Pattern TypesDescriptionDialed Number Pattern

Check Local Static Route.

Route to SIP Server Group and IP
Address/Hostname Server Group
Name are both VXML Gateway
(for example vxmlgw.cisco.com).

Check Send Calls to Originator.

Ringtone Label91*

Check Local Static Route.

Route to SIP Server Group and IP
Address/Hostname Server Group
Name are both VXML Gateway
(for example vxmlgw.cisco.com).

Check Send Calls to Originator.

Error Label92*
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Dialed Number Pattern TypesDescriptionDialed Number Pattern

Check Local Static Route.

Route to SIP Server Group and IP
Address/Hostname Server Group
Name are both the Unified
Communications Manager
gateway.

Check RNA Timeout for
Outbound Calls. The timeout is
15 seconds.

Agent Device LabelThis must be the agent extension
pattern. For example, enter 500*
where the range of agent extensions
is 5001 to 500999.

Check Local Static Route.

Route to SIP Server Group and IP
Address/Hostname Server Group
Name are both VXML Gateway
(for example vxmlgw.cisco.com).

Check Send Calls to Originator.

Network VRU Label777*

This must match the incoming
called-number configured in
Configure Cisco IOS Enterprise
Voice Gateway and the customer's
Prevalidation Changes in
Configuration Manager.

Configure Cisco IOS Enterprise Voice Gateway
Complete the following procedure to configure the Cisco IOS Voice Gateway.

Complete all configuration steps in enable > configuration terminal mode.Note

Procedure

Step 1 Configure the network interfaces:
interface GigabitEthernet0/0
ip route-cache same-interface
duplex auto
speed auto
no keepalive
no cdp enable

Step 2 Configure global settings:
voice service voip
no ip address trusted authenticate
signaling forward unconditional
sip
rel1xx disable
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header-passing
options-ping 60

Step 3 Configure voice codec preference:
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8

Step 4 Configure Unified CVP services and settings:
# Default CVP Services
application
service new-call flash:bootstrap.vxml
service survivability flash:survivability.tcl
service CVPSelfService flash:CVPSelfServiceBootstrap.vxml
service ringtone flash:ringtone.tcl
service cvperror flash:cvperror.tcl
service bootstrap flash:bootstrap.tcl
service handoff flash:handoff.tcl

# Default CVP http, ivr, rtsp, mrcp and vxml settings
http client cache memory pool 15000
http client cache memory file 1000
http client cache refresh 864000
no http client connection persistent
http client connection timeout 60
http client connection idle timeout 10
http client response timeout 30
ivr prompt memory 15000
ivr asr-server rtsp://asr-en-us/recognizer
ivr tts-server rtsp://tts-en-us/synthesizer
rtsp client timeout connect 10
rtsp client timeout message 10
mrcp client timeout connect 10
mrcp client timeout message 10
mrcp client rtpsetup enable
vxml tree memory 500
vxml audioerror
vxml version 2.0

Step 5 Configure gateway and sip-ua timers:
gateway
media-inactivity-criteria all
timer receive-rtp 1200

sip-ua
retry invite 2
retry bye 1
timers expires 60000
timers connect 1000
reason-header override

Step 6 Configure the dial-peers:
# Configure CVP survivability
dial-peer voice 1 pots
description CVP TDM dial-peer
service cvp-survivability
incoming called-number .T
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direct-inward-dial

# Configure CVP Ringtone
dial-peer voice 919191 voip
description CVP SIP ringtone dial-peer
service ringtone
incoming called-number 9191T
voice-class sip rel1xx disable
dtmf-relay rtp-nte dtmf-relay rtp-nte
voice-class codec 1
no vad

# Configure CVP Error
dial-peer voice 929292 voip
description CVP SIP error dial-peer
service cvperror
incoming called-number 9292T
voice-class sip rel1xx disable
dtmf-relay rtp-nte dtmf-relay rtp-nte
voice-class codec 1
no vad

#Configure VXML leg where the incoming called-number matches the Network VRU Label
dial-peer voice 9999 voip
description Used for VRU leg
service bootstrap
incoming called-number 777T
dtmf-relay rtp-nte dtmf-relay rtp-nte
voice-class codec 1
no vad

#Configure the Switch leg where
# preference is used to distinguish between sides.
# max-conn is used prevent overloading of CVP
# options-keepalive is used to handle failover
# Note: the example below is for gateways located on the A-side of a geographically
distributed deployment

dial-peer voice 70021 voip
description Used for Switch leg SIP Direct
preference 1
max-conn 225
destination-pattern xxxx...... # Customer specific destination pattern
session protocol sipv2
session target ipv4:###.###.###.### # IP Address for CVP1, SideA
session transport tcp
voice-class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte dtmf-relay rtp-nte
no vad

dial-peer voice 70022 voip
description Used for Switch leg SIP Direct
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preference 1
max-conn 225
destination-pattern xxxx...... # Customer specific destination pattern
session protocol sipv2
session target ipv4:###.###.###.### # IP Address for CVP2, SideA
session transport tcp
voice-class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte dtmf-relay rtp-nte
no vad

dial-peer voice 70023 voip
description Used for Switch leg SIP Direct
preference 2
max-conn 225
destination-pattern xxxx...... # Customer specific destination pattern
session protocol sipv2
session target ipv4:###.###.###.### # IP Address for CVP1, SideB
session transport tcp
voice-class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte dtmf-relay rtp-nte
n o vad

dial-peer voice 70024 voip
description Used for Switch leg SIP Direct
preference 2
max-conn 225
destination-pattern xxxx...... # Customer specific destination pattern
session protocol sipv2
session target ipv4:###.###.###.### # IP Address for CVP2, SideB
session transport tcp
voice-class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte dtmf-relay rtp-nte

Step 7 Configure the hardware resources (transcoder, conference bridge and MTP):
# Configure the voice-cards share the DSP resources located in Slot0
voice-card 0
dspfarm
dsp services dspfarm
voice-card 1
dspfarm
voice-card 2
dspfarm
voice-card 3
dspfarm
voice-card 4
dspfarm
# Point to the contact center call manager
sccp local GigabitEthernet0/0
sccp ccm ###.###.###.### identifier 1 priority 1 version 7.0 (CVP1)
sccp ccm ###.###.###.### identifier 1 priority 1 version 7.0 (CVP2)
# Add a SCCP group for each of the hardware resource types
sccp ccm group 1
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associate ccm 1 priority 1
associate profile 2 register gw70mtp
associate profile 1 register gw70conf
associate profile 3 register gw70xcode
# Configure DSPFarms for Conference, MTP and Transcoder
dspfarm profile 1 conference
codec g711ulaw
codec g711alaw
codec g729r8
maximum sessions 24
associate application SCCP
dspfarm profile 2 mtp
codec g711ulaw
codec g711alaw
codec g729r8
maximum sessions software 500
associate application SCCP
dspfarm profile 3 transcode
codec g711ulaw
codec g711alaw
codec g729r8
maximum sessions 52
associate application SCCP

Step 8 Configure the SIP Trunking (optional):
# Configure the resources to be monitored
voice class resource-group 1
resource cpu 1-min-avg threshold high 80 low 60
resource ds0
resource dsp
resource mem total-mem
periodic-report interval 30
# Configure one rai target for each CVP Call/VXML Server
sip-ua
rai target ipv4:###.###.###.### resource-group (CVP1A)
rai target ipv4:###.###.###.### resource-group (CVP2A)
rai target ipv4:###.###.###.### resource-group (CVP1B)
rai target ipv4:###.###.###.### resource-group (CVP2B)

Configure Unified Communications Manager
Follow this sequence of tasks to configure Unified Communications Manager:

Done?TaskSequence

Configure the Publisher for Unified CommunicationsManager,
on page 89

1

Configure Unified Communications Manager Subscriber, on
page 91

2
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Unified Communications Manager License, on page 923

Validate Clusterwide Domain Configuration, on page 944

Install JTAPI, on page 765

Activate service, on page 956

Configure Cisco Unified Communications Manager groups,
on page 95

7

Configure CTI Route Point, on page 968

Configure trunk, on page 979

Configure SIP options, on page 9610

Configure application user, on page 9711

Configure route pattern, on page 9812

Configure conference bridge, on page 9813

Configure media termination point, on page 9914

Configure transcoder, on page 9915

Configure media resource group, on page 10016

Configure and associate media resource group list, on page
100

17

Add Phones, on page 10118

Configure the Publisher for Unified Communications Manager
This procedure is for golden templates only.

You must customize the Unified Communications Manager publisher before you customize the subscribers

Before You Begin

DNS Configuration is mandatory for Unified Communications Manager, Cisco Unified Intelligence Center,
and Cisco Finesse. To configure DNS, add the VMs to the forward and reverse lookups of the DNS. For more
information, see Configure DNS Server, on page 40
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Procedure

Step 1 In the client computer where the automation tool was run, navigate to
C:\GoldenTemplateTool_901\PlatformConfigRepository\CUCM.

Step 2 Copy the file named CUCM_PUB_SideA_platformConfig.xml .
Step 3 Paste it to another location and rename it to platformConfig.xml
Step 4 Launch WinImage and select File > New > 1.44 MB.
Step 5 Drag and drop platformConfig.xml into WinImage.
Step 6 When prompted to inject the file, click Yes.
Step 7 Select File > Save as.
Step 8 From the Save as list, chooseVirtual floppy image. Provide the file name as platformConfig.flp and

click Save.
Step 9 Open vSphere infrastructure client and connect to the vCenter. Go to the customer ESXi host where the VMs

are deployed.
Step 10 Navigate to the Configuration tab. In the storage section, browse to a datastore and create a folder named

CUCM_PUB.
Step 11 Upload the platformConfig.flp file to the folder CUCM_PUB.
Step 12 Edit the Virtual Machine Settings for the Unified Intelligence Center Publisher VM.
Step 13 On theHardware tab, click on the floppy drive andmount theplatformConfig.flp from theCUCM_PUB

folder on the datastore.
Step 14 Ensure that Connect at Power On is checked for the network adapters and the floppy drive.
Step 15 Power on the Publisher. This begins the installation based on the information in the .flp file.

The installation begins automatically and runs with no interaction from you. After an hour or more, a message
appears indicating a successful installation.

Step 16 Click theConsole tab for the VM. Log in to the publisher machine, using the credentials for the Administration
User. The machine opens to the CLI interface.

Step 17 Edit settings and uncheck the Connect at Power on option for the floppy drive.

During the customization of the publisher/primary, the username and the password are modified as follows.
The customer should change the password.

Note

• Default Password for OS Administrator: pcce@123

• Application UserName: Administrator

• Default Password for Application User: pcce@123

• Sftp password: pcce@123

• IPSec password: pcce@123

After rebooting, the VM installation is complete with all the parameters provided in the spreadsheet for the
VM.
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Continue to: Configure Unified Communications Manager Subscriber, on page 91

Configure Unified Communications Manager Subscriber

Before You Begin

DNS Configuration is mandatory for Unified Communications Manager. To configure DNS, add the VMs to
the forward and reverse lookups of the DNS. See Configure DNS Server, on page 40

Related Topics

Launch the Publisher to Add the Subscriber, on page 91
Configure the Subscriber, on page 91

Launch the Publisher to Add the Subscriber
To add the subscriber, you must launch the publisher node.

Do this for golden templates only. For direct installs, this procedure was part of the installation of the publisher.

Procedure

Step 1 Launch th eUnified CommunicationsManager Publisher in a browser (http://<IP Addr of CUCMPublisher>).
Step 2 Select System > Server > Add New.
Step 3 On the Server Configuration tab, enter the IP Address of the subscriber.
Step 4 Click Save.

Configure the Subscriber

Procedure

Step 1 Launch WinImage and select File > New > 1.44 MB.
Step 2 In the client computer where the automation tool was run, navigate to

C:\GoldenTemplateTool_901\PlatformConfigRepository\CUCM.
Step 3 Copy the file named CUCM_SUB_SideA_platformConfig.xml.
Step 4 Paste it to another location and rename it to platformConfig.xml.
Step 5 Drag and drop platformConfig.xml into WinImag.

a) Click Yes at the message asking if you want to inject the file.
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b) Select File > Save as and save the file as a Virtual Floppy Image with the filename platformConfig.flp.

Step 6 Open vSphere infrastructure client and connect to the vCenter. Go to the customer ESXi host where the VMs
are deployed.

Step 7 Create the folder CUCM_SUB and upload platformConfig.flp to it.
Step 8 Edit the Virtual Machine settings for the Unified Communications Manager Subscriber VM.
Step 9 On the Hardware tab, click on the floppy drive and mount the platformConfig.flp from the CUCM_SUB

folder on the datastore.
Step 10 Power on the VM. Ensure that Connect at Power On is checked for the network adapters and the floppy

drive.
This begins the installation and customizes the installation based on the information in the .flp file.

Step 11 If there is a value in the optional DNS_IP_NIC1 cell of the automation spreadsheet, configure the DNS server
by adding the machine in forward and reverse lookup.

During the customization of the subscriber node, the username and the password are modified as
follows. The customer should change the password.

Note

• Default Password for OS Administrator: pcce@123

• Application UserName: Administrator

• Default Password for Application User: pcce@123

• Sftp password: pcce@123

• IPSec password: pcce@123

Step 12 After you complete the installation uncheck the Connect at Power on option for the floppy drive.
Step 13 Repeat this procedure for the second subscriber on Side B.

Unified Communications Manager License
To configure the Unified Communications Manager license, first add a product instance, then generate and
register the license, and then install the license.

Related Topics

Add Product Instance, on page 92
Generate and Register License, on page 93
Install License, on page 93

Add Product Instance
Complete the following procedure to add a product instance.
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Procedure

Step 1 Launch Communications Manager publisher in a browser (http://<IP Addr of CUCM Publisher>).
Step 2 Click Cisco Enterprise License Manager.
Step 3 Sign in with the credentials of CCM.
Step 4 Go to Inventory > Product Instances.
Step 5 Click Add to open a popup window.
Step 6 Enter details:

a) Name and Description
b) Product Type: Unified CM.
c) Hostname/IP Address of the CCM
d) Credentials of the publisher

Step 7 Click Test Connection. Then click OK at the success message.
Step 8 Click OK to add the product instance.
Step 9 Click Home > Inventory > Product Instance.

You can see the newly added product instance.

Step 10 Click synchronize now to synchronize with the Communications Manager.
Step 11 Go toMonitoring > License usage. You can see the number licenses used and required number of licenses.

You must apply the license for the information to
appear.

Note

Generate and Register License

Procedure

Step 1 Go to License Management > Licenses. Then click Generate License Request.
Step 2 When the License Request and Next Steps window opens, copy the test as directed (PAK ID) and save it to

a text editor.
Step 3 Click the Cisco License Registration site and proceed with steps in the site. Keep the PAK handy, which will

be asked for.
Step 4 Enter the PAK when prompted.

You will receive the license file in an email.

Install License
Complete the following procedure to install a license.
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Procedure

Step 1 Unzip the license file from the email.
Step 2 Navigate to License Management -> Licenses.
Step 3 Click Install License File and select the unzipped file.
Step 4 Go to the License Usage page to verify a successful installation.

Validate Clusterwide Domain Configuration
This validation is required for running calls.

Procedure

Step 1 In the Unified CM Administration, navigate to System > Enterprise Parameters.
Step 2 Scroll down to Clusterwide Domain Configuration.

Cluster Fully Qualified Domain Name should match the Server Group name in Unfied CVP SIP Server Groups
Configure SIP Server Group, on page 82

Install JTAPI on Unified CCE Call Servers
Now that you configured the Unified Communications Manager, you can Install JTAPI.

Provision Cisco Unified Communications Manager
This section contains the procedures you must perform to provision Cisco Unified CommunicationsManager.
This section assumes you have added phones (Add Phones, on page 101.

• Activate service, on page 95

• Configure Cisco Unified Communications Manager groups, on page 95

• Configure CTI Route Point, on page 96

• Configure trunk, on page 97

• Configure SIP options, on page 96

• Configure application user, on page 97

• Configure route pattern, on page 98

• Configure conference bridge, on page 98

• Configure media termination point, on page 99

   Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)
94

Configure Customer Instance
Validate Clusterwide Domain Configuration



• Configure transcoder, on page 99

• Configure media resource group, on page 100

• Configure and associate media resource group list, on page 100

Activate service
Complete the following procedure to activate service.

Procedure

Step 1 Select Cisco Unified Serviceability from the Navigation menu and click Go.
Step 2 Select Tools > Service Activation to open the Service Activation window.
Step 3 From the Server drop-down list, choose the server on which you want to activate the service, and then click

Go. For the server that you chose, the window displays the service names and activation status of the services.
Step 4 Check the following services to activate and click Save:

a) For the Publisher:
b) Cisco CallManager•

• Cisco IP Voice Media Streaming Application

• Cisco CTIManager

• Cisco Tftp

• Cisco Bulk Provisioning Service

• Cisco AXL Web Service

• Cisco Serviceability Reporter

• Cisco CTL Provider

• Cisco Certificate Authority Proxy Function

a) For the Subscribers:
b) • Cisco Unified CM

• Cisco IP Voice Media Streaming Application

• Cisco CTIManager

• Cisco AXL Web Service

• Cisco CTL Provider

Configure Cisco Unified Communications Manager groups
Complete the following procedure to add a Cisco Unified Communications Manager to the Unified
Communications Manager Group. Make sure that you configured both the publisher and the subscribers.
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Before you configure a Cisco Unified Communications manager group, you must configure the Cisco
Unified Communications Managers that you want to assign as members to that group.

Note

Procedure

Step 1 Select Cisco Unified CM Administrator from the Navigation menu and click Go.
Step 2 Select System > Cisco Unified CM Group.
Step 3 Click Find. Then click Default.
Step 4 Move the publisher and the two subscribers from the Available panel to the Selected panel.
Step 5 Click Save.

Configure CTI Route Point
Complete the following procedure to add a computer telephony integration (CTI) route point for agents to
use for transfers and conferences.

Procedure

Step 1 In Cisco CM Administration, select Device > CTI Route Point.
Step 2 Click Add New.
Step 3 In the Device Name field, add the number configured in UCCE for internal dialing for the DN that is used

for transfers and conferences. Use the wildcard string XXXXX to represent the digits of the dialed number
configured on Unified CCE.

Step 4 For Device Pool, select Default.
Step 5 Click Save.
Step 6 Add the CTI route point to pguser in the Application User interface. Configure application user, on page

97

Configure SIP options
Complete the following procedure to configure SIP options.
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Procedure

Step 1 Choose Device > Device Settings > SIP Profile.
Step 2 Click Add New.
Step 3 Name the option Standard SIP Profile - Early Offer.
Step 4 Scroll to Trunk Specific Configuration, check Early Offer support for voice and video calls (insert MTP if

needed).
Step 5 Scroll to the SIP Options Ping panel. Check Enable OPTIONS Ping to monitor destination status for Trunks

with Service Type None Default.
Step 6 Click Save.
Step 7 Click Reset.

Configure trunk
Complete the following procedure to configure a trunk for the CVP call servers on side-A, and a trunk for the
CVP call servers on side-B. In all, you will be adding 4 SIP trunks—one for each CVP server.

Procedure

Step 1 In Cisco CM Administration, select Device > Trunk.
Step 2 Click Add New.
Step 3 From the Trunk Type drop-down list, choose SIP Trunk, and then click Next.
Step 4 In the Device Name field, enter a name for the SIP trunk, for example, sipTrunkCVP1A.
Step 5 Retain all defaults in the Trunk Information panel.
Step 6 Click Next.
Step 7 In the Trunk Configuration window, enter the appropriate settings.

a) Do not check theMedia Termination Point Required check box.
b) From the DTMF Signaling Method drop-down list, choose RFC 2833.
c) From the SIP Profile drop-down list, choose Standard SIP Profile.

Step 8 Click Save.
Step 9 Repeat for the sip trunks on CVP1B, CVP2A, and CVP2B.

Configure application user
Complete the following procedure to configure each application user.

This step assumes you have added users and phones.Note
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Procedure

Step 1 In Cisco CM Administration, select User Management > Application User.
Step 2 Click Add New.
Step 3 Enter the User ID that you entered in Configure the Cisco Unified CCE Peripheral Gateway and CTI Server

(Side A). Unified CCE defines the user ID as pguser.
Step 4 Enter cisco in the Password and Confirm Password fields. Note that if you change this user ID or password

in Unified CCE, you must also change the Unified Communication Manager application user configuration.
Step 5 Click Add to Access Control Group and select Standard CTI Allow Call Monitoring, Standard CTI Allow

Control of All Devices, and Standard CTI Enabled.
Step 6 Click Add Selected.
Step 7 Click Save.

Configure route pattern
Complete the following procedure to configure a route pattern.

Procedure

Step 1 In Unified CM Administration, select Call Routing > Route Hunt > Route Group.
Step 2 Configure and save a Route Group with the four CVP sip trunks.
Step 3 Select Call Routing > Route Hunt > Route List.
Step 4 Configure and save a Route List for the Route Group.
Step 5 Add the Route Group to a Route List
Step 6 Select Call Routing > Route Hunt > Route Pattern.
Step 7 Click Add New.
Step 8 Create one Route Pattern Definition for Route Pattern 888!. Keep all defaults in the Pattern Definition panel.
Step 9 Click Save.

To load-balance sending calls across all 4 CVP servers, add all 4 CVP servers to the route group/route list.

Configure conference bridge
Complete the following procedure to configure a conference bridge.
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Procedure

Step 1 ChooseMedia Resources > Conference bridge.
Step 2 Add a conference bridge for each ingress/VXML combination gateway in the deployment. Use type Cisco

IOS Conference Bridge.
Step 3 In theConference Bridge name field, enter a unique identifier for the conference bridge name that coincides

with the configuration on the gateway. See Step 7 in Configure Cisco IOS Enterprise Voice Gateway.
Step 4 Click Save.
Step 5 Click Apply Config.

Configure media termination point
Complete the following procedure to configure a media termination point.

Procedure

Step 1 ChooseMedia Resources >Media Termination Point.
Step 2 Add a media termination point for each ingress/VXML combo gateway in the deployment.
Step 3 In the Media Termination Point Name field, enter a media termination point name for each ingress/VXML

combo gateway in the deployment. See Step 7 in Configure Cisco IOS Enterprise Voice Gateway.
Step 4 Click Save.
Step 5 Click Apply Config.

Configure transcoder
Complete the following procedure to configure a transcoder.

Procedure

Step 1 ChooseMedia Resources > Transcoder.
Step 2 From the drop-down, select Cisco IOS enhanced media termination point.
Step 3 Add a transcoder for each ingress/VXML combo gateway in the deployment.
Step 4 In the Device Name field, enter a unique identifier for the transcoder that coincides with the configuration

on the gateway. See Step 7 in Configure Cisco IOS Enterprise Voice Gateway.
Step 5 In the Device Pool field, select Default.
Step 6 Click Save.
Step 7 Click Apply Config.
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Configure media resource group
Complete the following procedure to configure amedia resource group for conference bridge, media termination
point, and transcoder.

Procedure

Step 1 ChooseMedia Resources >Media Resource Group.
Step 2 Add a Media Resource Group for Conference Bridges.
Step 3 Select all the hardware conference bridge resources configured for each ingress/VXML combination gateway

in the deployment and add them to the group.
Step 4 Click Save.
Step 5 ChooseMedia Resources >Media Resource Group.
Step 6 Add a Media Resource Group for Media Termination Point.
Step 7 Select all the hardware media termination points configured for each ingress/VXML combination gateway in

the deployment and add them to the group.
Step 8 Click Save.
Step 9 ChooseMedia Resources >Media Resource Group.
Step 10 Add a Media Resource Group for Transcoder.
Step 11 Select all the transcoders configured for each ingress/VXML combination gateway in the deployment and

add them to the group.
Step 12 Click Save.

Configure and associate media resource group list
Complete the following procedure to configure and associate a media resource group list. Add the media
resource group list to the following devices and device pool.
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Procedure

Step 1 ChooseMedia Resources >Media Resource Group List.
Step 2 Add a Media Resource Group list and associate all of the media resource groups. Click Save.
Step 3 Choose System > Device Pool. Click Default.
Step 4 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2.
Step 5 Click Save. Click Reset.
Step 6 Choose Device > CTI Route Point.
Step 7 Click the configured CTI Route Point. See Configure a CTI Route Point.
Step 8 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2.
Step 9 Click Save. Click Reset.
Step 10 Choose Device > SIP Trunk.
Step 11 Click the configured SIP Trunk for side-A. See Configure a Trunk.
Step 12 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2.
Step 13 Click Save. Click Reset.
Step 14 Click the configured SIP Trunk for side-B. See Configure trunk.
Step 15 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2.
Step 16 Click Save. Click Reset.

Add Phones
It is beyond the scope of this document to explain how to add phones and associate them with the Application
User. You will, however, need two phones for the agents who will sign in to Finesse to test calls. This is
necessary to complete the final step to make a call.

This topic points to the Cisco Unified Communications Manager tools that you access to add phones

Procedure

Step 1 Sign in to the Cisco Unified Intelligence Center Administration Console (http://{hostname}/oamp).
Step 2 Select Device > Phone.
Step 3 Click Find and then Add New.
Step 4 Select the phone type you will use for the agent. Then click Next.
Step 5 Complete all required fields in the Device Information screen and Save.
Step 6 Repeat steps 2 - 4 for the second phone.
Step 7 Select User Management > Application User.
Step 8 Click Find. Then select pguser.
Step 9 Make sure the CTI Route Point (Configure CTI Route Point) and both phones are moved from Available

Devices to Controlled Devices.

Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)    
101

Configure Customer Instance
Provision Cisco Unified Communications Manager



Configure Unified Intelligence Center
Follow these tasks to configure Unified Intelligence Center.

Done?TaskSequence

Configure Unified Intelligence Center Publisher, on page 1021

Configure Unified Intelligence Center Subscriber, on page 1042

Configure Unified Intelligence Center SQL User Account, on
page 105

3

Configure Unified Intelligence Center Data Sources, on page
106

4

Configure Unified Intelligence Center Administration, on page
106

5

Unified Intelligence Center License and Sign In, on page 1076

Configure Unified Intelligence Center Publisher
This procedure is for golden templates only.

You must customize the Cisco Unified Intelligence Center publisher before you customize the subscriber.

Before You Begin

DNS Configuration is mandatory for Unified Intelligence Center. To configure DNS, add the VMs to the
forward and reverse lookups of the DNS. See Configure DNS Server, on page 40
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Procedure

Step 1 In the client computer where the automation tool was run, navigate to
C:\GoldenTemplateTool_901\PlatformConfigRepository\CUIC.

Step 2 Copy the file named CUICPUB_SideA_platformConfig.xml.
Step 3 Paste it to another location and rename it to platformConfig.xml
Step 4 Launch WinImage and select File > New > 1.44 MB.
Step 5 Drag and drop platformConfig.xml into WinImage.
Step 6 When prompted to inject the file, click Yes.
Step 7 Select File > Save as.
Step 8 From the Save as type list, selectVirtual floppy image. Provide the file name as platformConfig.flp

and click Save. Make sure you have selected the correct network adapter.
Step 9 Open vSphere infrastructure client and connect to the vCenter. Go to the customer ESXi host where the VMs

are deployed.
Step 10 Navigate to the Configuration tab. In the storage section, browse to a datastore and create a folder named

CUIC_PUB.
Step 11 Upload the platformConfig.flp file to the folder CUCM_PUB.
Step 12 Edit the Virtual Machine Settings for the Unified Intelligence Center Publisher VM .
Step 13 On theHardware tab, click on the floppy drive andmount theplatformConfig.flp from theCUIC_PUB

folder on the datastore.
Step 14 Ensure that Connect at Power On is checked for the network adapters and the floppy drive.
Step 15 Power on the Publisher. This begins the installation based on the information in the .flp file.

The installation begins automatically and runs with no interaction from you. After an hour or more, you will
see a message indicating a successful installation.

Step 16 Click the Console tab for the VM. Log in to the publisher, using the credentials for the Administration User.
The machine opens to the CLI interface.

Step 17 Edit settings and uncheck the Connect at Power on option for the floppy drive.

During the customization of the publisher/primary, the username and the password are modified as follows.
The customer should change the password.

Note

• Default Password for OS Administrator: pcce@123

• Application UserName: Administrator

• Default Password for Application User: pcce@123

• Sftp password: pcce@123

• IPSec password: pcce@123

After rebooting, the VM installation is complete with all the parameters provided in the spreadsheet for the
VM.
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Continue to: Configure Unified Intelligence Center Subscriber, on page 104.

Configure Unified Intelligence Center Subscriber
Before adding a subscriber, youmust upload the license file in the Publisher. DNSConfiguration is mandatory
for Unified Intelligence Center. To configure DNS, add the VMs to the forward and reverse lookups of the
DNS. For more information, see Configure DNS Server, on page 40.

Related Topics

Launch the Publisher to Add the Subscriber, on page 104
Configure Subscriber , on page 104

Launch the Publisher to Add the Subscriber
To add the subscriber, you must launch the publisher node and define the subscriber in the Administration
Console.

Do this for golden templates only. For direct installs, this procedure was part of the installation of the publisher.

Procedure

Step 1 Direct a browser to the URL http://<HOST ADDRESS>/oamp where HOST ADDRESS is the IP Address or
Hostname of your Cisco Unified Intelligence Center publisher.

Step 2 Sign in using the system application user ID and password that you defined during installation.
Step 3 From the panel in the left, select Device Management > Device Configuration.
Step 4 Click Add Member.
Step 5 On the Device Configuration fields for the Subscriber, enter a name, the hostname or IP address, and a

description for the device.
Step 6 Click Save.

Configure Subscriber
Complete the following procedure to configure a subscriber.

Procedure

Step 1 Launch WinImage and select File > New > 1.44 MB.
Step 2 In the client computer where the automation tool was run, navigate to

C:\GoldenTemplateTool_901\PlatformConfigRepository\CUIC.
Step 3 Copy the file named CUIC_SUB_SideA_platformConfig.xml.
Step 4 Paste it to another location and rename it to platformConfig.xml.
Step 5 Drag and drop platformConfig.xml into WinImage:

a) Click Yes at the message asking if you want to inject the file.
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b) Select File > Save as and save the file as a Virtual Floppy Image with the filename
platformConfig.flp.

Step 6 Open vSphere infrastructure client and connect to the vCenter. Go to the customer ESXi host where the VMs
are deployed.

Step 7 Create the folder CUIC_SUB and upload platformConfig.flp to it.
Step 8 Edit the Virtual Machine settings for the CUIC Subscriber VM.
Step 9 On theHardware tab, click on the floppy drive andmount the platformConfig.flp from the CUIC_SUB folder

on the datastore.
Step 10 Power on the VM. Ensure that Connect at Power On is checked for the network adapters and the floppy

drive.
This begins the installation and customizes the installation based on the information in the .flp file.

Step 11 If there is a value in the optional DNS_IP_NIC1 cell of the automation spreadsheet, configure the DNS server
by adding the machine in forward and reverse lookup:

During the customization of the subscriber node, the username and the password are modified as
follows. The customer should change the password.

Note

• Default Password for OS Administrator: pcce@123

• Application UserName: Administrator

• Default Password for Application User: pcce@123

• Sftp password: pcce@123

• IPSec password: pcce@123

Step 12 After you complete the installation uncheck the Connect at Power on for the floppy drive.

Configure Unified Intelligence Center Reporting
Complete the following procedures to configure Unified Intelligence Center Reporting. There are two
components to configure:

• Configure Unified Intelligence Center SQL User Account, on page 105

• Configure Unified Intelligence Center Data Sources, on page 106

Configure Unified Intelligence Center SQL User Account

Procedure

Step 1 Launch Microsoft SQL Server Management Studio on the Unified CCE Logger A.
Step 2 Connect to Unified CCE Logger A using the default credentials.
Step 3 Navigate to Security Login and create a New Login.
Step 4 On the General Screen:
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a) Enter the Login Name.
b) Click SQL Server Authentication.
c) Enter and confirm the Password.
d) Uncheck Enforce password policy.

Step 5 On the User Mapping Screen:
a) Check the databases associated with Side A and awdb.
b) Choose each database and associate it with the db_datareader and public roles.

Configure Unified Intelligence Center Data Sources
Complete the following procedure to configure Unified Intelligence Center data sources.

Procedure

Step 1 Sign in to Unified Intelligence Center (http://{hostname}).
Step 2 Click Data Sources drawer in the left panel to open the Data Sources page.
Step 3 Choose the UCCE Historical Data Source. Click Edit to open the Data Source Create/Edit page:

a) In the Database Host field, enter the IP Address of the Unified CCE Database Server.
b) In the Database Name field, enter {instance}_sideA.
c) In the Database User ID field, enter the ID for the user authorized to access the database.
d) Enter and confirm the Cisco Unified Intelligence Center User password.
e) Click Test Connection to confirm the Online status.
f) Click Save.

Step 4 Choose the UCCE Realtime Data Source. Click Edit:
a) In the Database Host field, enter the IP Address of the Unified CCE Database Server.
b) In the Database Name field, enter {instance}_awdb.
c) In the Database User ID field, enter the Cisco Unified Intelligence Center user created in Step 3.
d) Enter and confirm the Cisco Unified Intelligence Center User password.
e) Click Test Connection to confirm the Online status.
f) Click Save.

Configure Unified Intelligence Center Administration
Complete the following procedure to configure Unified Intelligence Center Administration.

Procedure

Step 1 Sign in to theCiscoUnified IntelligenceCenter AdministrationConsole (http://{hostname}/oamp).
Step 2 Configure syslog for all devices.

   Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)
106

Configure Customer Instance
Configure Unified Intelligence Center Administration



a) Choose Device Management > Log and Trace Settings.
b) For each host address:
c) • Select the associated servers.

• In the Edit Serviceability Settings screen Syslog Settings pane, configure the Primary and Backup
Host. Click Save.

Step 3 Configure SNMP for all devices.
a) Select Network Management > SNMP.
b) For each server:

• Add the V1/V2c Community Strings.

• Add the Notification Destination.

Unified Intelligence Center License and Sign In

Acquire license online
After you install the publisher and before you install the subscriber, you must contact Cisco to request a
Unified Intelligence Center license.

Procedure

Step 1 To acquire the license file, go to the Cisco Product License Registration website at this URL: https://
tools.cisco.com/SWIFT/Licensing/PrivateRegistrationServlet.

Step 2 If you do not have a Product Authorization Key (PAK), click the available licenses link.
Step 3 Scroll to Unified communications and click Cisco Unified Intelligence Center.
Step 4 Enter your MAC Address, accept the agreement, and enter your Registrant Information.

TheMACAddress appears online at the end of the installation. If you do not have time to write it down before
it disappears, you can find it through the CLI, after the install is complete, as follows:

1 Sign in to the server node, using the credentials of the System Administration user.

2 Enter this CLI command: show status.

Step 5 Follow prompts to complete the registration windows.
You will receive an email from Cisco that contains your license file as an attachment. The file format is *.lic.

Step 6 Save the license file in a location where the System Application User can access it.
As a best practice, save a backup copy of this file. You can open a *.lic. file to look at it, but do
not make any changes to it. Changing the file invalidates the license.

Warning
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Sign in to Administration Console
Who can sign in to the administration console: The System Application User who is the default Superuser.
For information on user roles, see Other Cisco Unified Intelligence Center user roles.

To upload the license, you must sign in to the Unified Intelligence Center Administration Console. This is
the OAMP interface for Unified Intelligence Center. The first person who signs in to the Administration
application must do so using the User ID and password that were defined for the System Application User
during the installation. This user is the initial Superuser for Unified Intelligence Center Administration.

Procedure

Step 1 Enter this URL: http://<HOST ADDRESS>/oamp, where HOST ADDRESS is the IP address or Hostname of
your Controller node.

Step 2 Enter the System Application User ID and password that you defined during installation.

Upload License
Who can upload the license: The System Application User who is the default Superuser.

As soon as the System Application User signs in, they must upload the license file. The file is uploaded to
the publisher node and, within a minute, is automatically replicated to all nodes in the cluster.

Procedure

Step 1 In the Administration application, choose Cluster Configuration > License Management.
This opens the License File Management page.

Step 2 Click Upload license file (Browse).
Step 3 Navigate to the location where the *.lic file was saved.
Step 4 Click Apply License to load the license.

A message appears indicating that the license file was uploaded successfully and will be distributed to other
nodes (if any) in the cluster in approximately one minute.

The databases are polled once a minute for changes. The license replication is not immediate but
occurs within a minute.

Note

Configure Cisco Finesse
Follow this sequence of tasks to configure Cisco Finesse.

Done?TaskSequence

Configure Cisco Finesse Primary, on page 1091
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Configure Unified CCE CTI Server Settings in Cisco Finesse
Primary Node, on page 110

2

Configure Cisco Finesse secondary node, on page 1113

Configure Cisco Finesse Primary
This procedure is for golden templates only.

You must configure the Finesse primary node before you customize the secondary node.

Before You Begin

DNS Configuration is mandatory for Cisco Finesse. To configure DNS, add the VMs to the forward and
reverse lookups of the DNS. See Configure DNS Server, on page 40

Procedure

Step 1 In the client computer where the automation tool was run, navigate to
C:GoldenTemplateTool_901\PlatformConfigRepository\Finesse .

Step 2 Copy the file named FINESSE_PRIMARY_platformConfig.xml.
Step 3 Paste it to another location and rename it to platformConfig.xml.
Step 4 Launch WinImage and select File > New > 1.44 MB.
Step 5 Drag and drop platformConfig.xml into WinImage.
Step 6 When prompted to inject the file, click Yes.
Step 7 Select File > Save as.
Step 8 Choose the Save as type as Virtual floppy image. Provide the file name as platformConfig.flp and click Save.
Step 9 Open vSphere infrastructure client and connect to the vCenter. Go to the customer ESXi host where the VMs

are deployed.
Step 10 Navigate to the Configuration tab. In the storage section, browse to a datastore and create a folder named

FINESSE_PRIMARY.
Step 11 Upload the platformConfig.flp file to the folder FINESSE_PRIMARY.
Step 12 Edit the Virtual Machine Settings for the Finesse Primary VM .
Step 13 On the Hardware tab, click on the floppy drive and mount the platformConfig.flp from the

FINESSE_PRIMARY folder on the datastore.
Step 14 Ensure that Connect at Power On is checked for the network adapters and the floppy drive.
Step 15 Power on the Primary. This begins the installation based on the information in the .flp file.

The installation begins automatically and runs with no interaction from you. After an hour or more, you will
see a message indicating a successful installation.

Step 16 Click theConsole tab for the VM. Log in to the primary machine, using the credentials for the Administration
User. The machine opens to the CLI interface.

Step 17 Edit settings and uncheck the Connect at Power on option for the floppy drive.
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During the customization of the primary, the username and the password are modified as follows. The customer
should change the password.

• Default Password for OS Administrator: pcce@123

• Application UserName: Administrator

• Default Password for Application User: pcce@123

• Sftp password: pcce@123

• IPSec password: pcce@123

After rebooting, the VM installation is complete with all the parameters provided in the spreadsheet for the
VM.

Continue to: Configure Unified CCE CTI Server Settings in Cisco Finesse Primary Node, on page 110.

Configure Unified CCE CTI Server Settings in Cisco Finesse Primary Node
This procedure is required for the Finesse primary node for golden templates and for direct-install deployments.

Related Topics

Configure CTI Server Settings in Cisco Finesse Primary Node, on page 110
Configure Contact Center Enterprise Administration and Data Server, on page 111
Restart Tomcat, on page 111

Configure CTI Server Settings in Cisco Finesse Primary Node

Procedure

Step 1 Launch the URL http://hostname or IP address/cfadmin, where hostname or IP address is the hostname or
IP address of your primary Finesse server.

Step 2 Go to Home > Contact Center Enterprise CTI Server Settings.
Step 3 Update the following:

a) A Side Host/IP Address (of Side A Call Server)
b) A Side Port (CTI Server Port on Side A)—42027
c) Peripheral ID (of CallManager PIM)—5000
d) B Side Host/IP Address (of Side B Call Server)
e) B Side Port (CTI Server Port on Side B)—43027

Step 4 Click Submit.
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Configure Contact Center Enterprise Administration and Data Server

Procedure

Step 1 Go to Home > Contact Center Enterprise Administration & Data Server Settings. (This menu structure
assumes the default configuration).

Step 2 Update the following:
a) Primary Host/IP Address (of Side A Data Server)
b) Database Port: 1433
c) Backup Host/Ip Address (of Side B Data Server)
d) Domain (required field): The name of the UCCE to which Finesse connects.
e) AW Database Name: <ucceinstance_awdb>
f) UserName: The domain user name required to sign into the database. Cannot be SQL user.
g) Password: The password required to sign into the database

Step 3 Click Submit.

Restart Tomcat
After changing and saving any value on the Contact Center Enterprise Administration Server Settings gadget,
you must restart the Cisco Tomcat Service on the primary Finesse server.

Procedure

Step 1 To stop the Cisco Tomcat service, enter this CLI command: utils service stop Cisco Tomcat .
Step 2 To start the Cisco Tomcat service, enter this CLI command: utils service start Cisco Tomcat .

Next step is to Configure Cisco Finesse secondary node, on page 111

Configure Cisco Finesse secondary node
DNS Configuration is mandatory for Cisco Finesse. To configure DNS, add the VMs to the forward and
reverse lookups of the DNS. See Configure DNS Server, on page 40

Related Topics

Launch the Primary and Add the Secondary, on page 111
Configure the Subscriber, on page 112

Launch the Primary and Add the Secondary
To add the secondary, you must launch the primary node and add the secondary to the cluster.
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Do this for golden templates only. For direct installs, this procedure was part of the installation of the primary.

Procedure

Step 1 Launch the Cisco Finesse primary node in a browser (http://Primary Node IP Address/cfadmin), where the
Primary Node or IP Address is that of your host.

Step 2 Go toHome >Cluster Settings. (This is based on the default configuration and assumes you have not changed
the page for the Cluster Settings gadget.)

Step 3 Add the IP address for the Cisco Finesse secondary node.
Step 4 Click Submit.

Configure the Subscriber

Procedure

Step 1 Launch WinImage and select File > New > 1.44 MB.
Step 2 In the client computer where the automation tool was run, navigate to

C:\CCEPAC1_VMAutomation\PlatformConfigRepository\Finesse .
Step 3 Copy the file named FINESSE_SECONDARY_platformConfig.xml .
Step 4 Paste it to another location and rename it to platformConfig.xml.
Step 5 Drag and drop platformConfig.xml into WinImage:

a) When prompted to inject the file, click Yes.
b) Select File > Save as and save the file as a Virtual Floppy Image (.flp).

Step 6 Open vSphere infrastructure client and connect to the vCenter. Go to the customer ESXi host where the VMs
are deployed.

Step 7 Ensure there is a FINESSE_SECONDARY in the datastore and upload the platformConfig.flp file to that folder
FINESSE_SECONDARY.

Step 8 Edit settings for the VM. On the Hardware tab, click on the floppy drive and mount the
platformConfig.flp from the FINESSE_SECONDARY folder on the datastore.

Step 9 Ensure that Connect at Power On is checked for the network adapters and the floppy drive.
Step 10 Power on the VM. This begins the installation and customizes the installation based on the information in the

.flp file.
During the customization of the secondary node, the username and the password are modified as follows. The
customer may change the password:

• Default Password for OS Administrator: pcce@123

• Application UserName: Administrator

• Default Password for Application User: pcce@123

• Sftp password: pcce@123

• IPSec password: pcce@123
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Step 11 After you complete the installation uncheck the Connect at Power on for the floppy drive.

Configure Unified CVP Reporting Server
The optional Unified CVP Reporting VM is required for customers who use Courtesy Callback and who want
to run Unified CVP IVR callback application reports. Unified CVP customers must sign in to Cisco Unified
Intelligence Center as users.

Follow this sequence of tasks to configure Unified CVP Reporting:

Done?TaskSequence

Configure CVP Reporting Server in CVP OAMP, on page
113

1

Create Reporting Users, on page 1132

Import Unified CVP Report Templates and Set Data source,
on page 115

3

Configure CVP Reporting Server in CVP OAMP
Perform this procedure only if the customer will use the optional CVP Reporting Server.

Procedure

Step 1 In the CVP Operations Console, navigate to Device Management > Unified CVP Reporting Server..
Step 2 Click Add New.
Step 3 Enter the IP Address and Host Name of the Reporting Server.
Step 4 Move all Unified CVP Call Servers from Available to Selected.
Step 5 Click Save and Deploy.

Unified CVP Reporting Users

Create Reporting Users
Who can create a user:

• Initially, the System Application User who is the default Superuser.

• Eventually, any Superuser.
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For information about user roles, see Other Cisco Unified Intelligence Center user roles.

Unified CVP reporting users can sign in to Unified Intelligence Center only if they exist in the Administration
console as Superusers or if Active Directory (AD) is configured in the Unified Intelligence Center
Administration console for their domain:

• Superusers who are added are considered to be IP Multimedia Subsystem (IMS) users. For more
information, see Create Superusers.

• Users authenticated through Active Directory are considered to be Lightweight Directory Access Protocol
(LDAP) users. For more information, see Set up Active Directory Server for LDAP Users.

Both IMS users and LDAP users can log in to Unified Intelligence Center reporting and are restricted to the
limited Login User role until the Unified Intelligence Center reporting security administrator gives them
additional roles and flags them as active users.

Although you can create a user on the Unified Intelligence Center User List page, an entry on the User List
is not sufficient for that user to sign in to the Unified Intelligence Center. One reason to create users on the
User List page is to expedite the permissions for users before their Active Directory domain is configured.

Create Superusers
Sign in to Cisco Unified Intelligence Center Administration (http://server/oamp).

To create Superusers, navigate to Admin User Management drawer > Admin User Management to open
the Users page. Click Add New to add and configure a new user or click an existing user name to edit the
configuration for that user.
This page has three tabs: General, Credentials, and Policy.

For information about completing these tabs, see Administration Console User Guide for Cisco Unified
Intelligence Center or to the Administration console online help.

Set up Active Directory Server for LDAP Users
Configure the Active Directory tab in the Administration console so that Unified CVP reporting users can
log in to the Unified Intelligence Center reporting application with the user name and password that is defined
in their domain.

Who can do set up an active directory for LDAP users:

• Initially, the System Application User who is the default Superuser.

• Eventually, any Superuser.

For information about user roles, see Other Cisco Unified Intelligence Center user roles.
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Procedure

Step 1 In the Administration application, navigate toCluster Configuration >Reporting Configuration and select
the Active Directory tab.

Step 2 Complete all fields on this page, referring to the online help for guidance.
Step 3 Click Test Connection.
Step 4 When the connection is confirmed, click Save.

Sign in to Cisco Unified Intelligence Center Reporting Interface
Who can sign in to the Unified Intelligence Center reporting interface:

• Initially, the System Application User who is the default Superuser. For more information, see Other
Cisco Unified Intelligence Center user roles.

• Eventually, any Unified CVP user created in the Administration Console as an IMS superuser or an
LDAP user. For more information, see Unified CVP reporting user role additions.

Perform the following procedure to sign in to the Unified Intelligence Center reporting interface.

Procedure

Step 1 From the home page of the Administration interface, click the Control Center drawer.
Step 2 Locate and double-click the name of the Member node you want to access. This opens the Cisco Unified

Intelligence Center login page for that member.
Step 3 Enter your user ID and password. The Overview page appears.

What to Do Next

Next step: Add User Roles for Unified CVP Reporting Users.

Import Unified CVP Report Templates and Set Data source
Who can do this:

• Initially, the SystemApplication User who has full permissions in Unified Intelligence Center Reporting.

• Eventually, any Report Designer has full permissions.

For information about user roles, see Cisco Unified Intelligence Center reporting user roles.

Before reporting users can run the Unified CVP report templates in the Unified IC reporting application, a
Unified IC reporting user with permission to do so must import them into Unified IC and associate them with
the Unified CVP Data Source.

Packaged CCE supports the Callback reports only. Do not import other reports.
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Procedure

Step 1 Launch the Unified ICweb application using the URL http://<HOST ADDRESS>/cuic, where HOSTADDRESS
is the IP Address or Hostname of your Member node.
This opens the login window.

Step 2 Enter your User Name and Password.
This opens the Overview page.

Step 3 Click the Reports drawer to open the Available Reports page.
Step 4 Right-click the top Reports folder and select Create New Sub-Category.
Step 5 Name the new sub-category as a container for Unified CVP reports. Click OK.
Step 6 Click Import Reports.
Step 7 Browse to the location where you copied the Unified CVP XML template report templates files.
Step 8 Select a report.

This populates the File Name with the full path for the report.

Step 9 From the Data Source To Use drop-down list, choose the Data Source you created to access the Unified CVP
reporting database.

Step 10 From the Data Source To Use drop-down list, choose the Unified CVP sub-category folder you created in
Step 5.

Step 11 Click Import.
Step 12 Repeat Steps 6 to 11 for each Unified CVP report template.

Create Data Source for Cisco Unified CVP Report Data
Who can create data source for Cisco Unified Customer Voice Portal report data:

• Initially, the SystemApplication User who has full permissions in Unified Intelligence Center reporting.

• Eventually, any System Configuration Administrator.

For more information on user roles, see Cisco Unified Intelligence Center reporting user roles.

Similar to creating an Open Database Connectivity (ODBC) connection, this task is necessary to access the
Unified CVP reporting data.

In Unified Intelligence Center, the user must perform this task with the System Configuration Administrator
User Role.

Perform the following procedure to create a data source.
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Procedure

Step 1 Select the Data Sources drawer to open the Data Sources page.

Figure 1: Data Sources page

This page shows three data sources that are installed by Unified Intelligence Center. They are the CUIC data
source, the UCCE Historical data source, and the UCCE Realtime data source.

• The CUIC data source represents the Unified Intelligence Center database on the node that stores records
for reports, dashboards, and users maintained on that node. This data is replicated across all nodes in
the cluster.

• The two UCCE data sources represent the databases that populate the stock Cisco Unified CCE reports.

Step 2 explains how to add a data source for Unified CVP.

Step 2 Click Create to open an Add Data Source window.
Step 3 Complete fields on this page as follows:

ValueField

Enter the name of this data source.

Report Designers and Report Definition Designers do not
have access to the Data Sources page but can see the list of
Data Sources when they create custom reports.

Best Practice: to benefit those users, give a new Data Source
a meaningful name.

Name

Enter a description for this data source.Description

Options are Informix and SQL server.

Choose Informix.

Type is disabled in Edit
mode.

Note

Type

Enter the IP address or Domain Name System (DNS) name
for the server and append the port for the Informix database.

Database Host

Enter the port number. Typically, the port is 1526.

You may have to open this port in the CVP Reporting Server
firewall (Window Firewall > Inbound rules > new rule).

Port

Enter the name of the reporting database on the Unified CVP
reporting server.

Use the database name callback for stock callback reports.

Database name

Specify the instance name of the desired database. By default,
this is cvp.

Instance
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ValueField

Choose the correct time zone for the data stored in the
database. In locations that change from Standard Time to
Daylight Savings Time, this time zone is updated
automatically.

Timezone

Enter the user ID of the Reporting User who is configured in
the Operations Console to access the Unified CVP reporting
database.

Database User ID

Enter and confirm the password for the database user.Password and Confirm Password

Choose UTF-8 for the Unified CVP Informix database.

If this field is not set correctly, the Unified
Intelligence Center cannot connect.

Note

Charset

View or edit the permissions for this datasource forMyGroup
and for the All Users group.

Default Permissions

Step 4 Click Test Connection.
If the status is not Online, review the error message to determine the cause and edit the data source accordingly.
Repeat Step 3 until the page indicates that the data source is Online.

Step 5 Click Save to close the Add Data Source window.
The new data source appears on the Data Sources list.

Import Cisco Unified Customer Voice Protocol Report Templates
The Unified CVP reporting template XML files are installed with Unified CVP. Locate them and copy them
to a Unified Intelligence Center client workstation.

For Packaged CCE, import the Callback reports only.

To obtain import Unified CVP report templates complete the following:

Procedure

Step 1 In the Unified CVP server, locate the Unified CVP template files. These are XML files that reside on the
reporting server in %CVP_HOME%\CVP_Reporting_Templates. You can also find them on the Installation
DVD in \Downloads and Samples\ Reporting Templates.

Step 2 Choose the files and copy them to the client computer from which you will launch the Unified IC Reporting
web application.
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C H A P T E R  9
Final Tasks

• Run base configuration using the ICMDBA tool, page 119

• Prevalidation Changes in Configuration Manager, page 120

• Set Deployment Type and Run System Validation, page 122

• Make a Call, page 124

Run base configuration using the ICMDBA tool
This task is required for CCE Data server on Side A.

Procedure

Step 1 Download the CCEPACM1BaseConfig901.zip file from Cisco.com, at http://cisco.com/en/US/products/
ps12586/tsd_products_support_series_home.html. Save it locally and unzip it.

Step 2 Download the Domain_Update_Tool.zip file from Cisco.com, at http://cisco.com/en/US/products/ps12586/
tsd_products_support_series_home.html and save it locally and unzip it.

Step 3 Unzip and copy the configuration folder to the local drive of CCE DataServer on Side A.
Step 4 Open the ICMDBA Tool on the CCE DataServer on Side A.
Step 5 Select the CCE Data Server and expand the tree to <instance name>_sideA.
Step 6 Select Data on the menu bar and click Import.
Step 7 Browse to locate the configuration folder and click Open.
Step 8 Click OK and then click Import.
Step 9 Click Start and then click OK on all messages.
Step 10 Navigate to the folderDomain_Update_Tool and right-clickUpdateDomain.PS1. and Run with PowerShell.

Respond as follows:
a) For Server name, enter the computer name of the CCE Data Server Side A.
b) For Database name, enter <instance_sideA (Logger database)>.
c) For Domain Name, enter the customer's domain name.

Step 11 Return to the ICMDBA tool. Open Data on the menu bar and click Synchronize.
a) Enter the hostname for the CCE Data Server on Side A.
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b) Enter the database name as <instance name>_sideA for the source side.
c) Enter the hostname for the CCE Data Server on Side B.
d) Enter the database name as <instance name>_sideB for the target side.
e) Click Synchronize

Step 12 Click Start and then click OK on all messages.

Running this procedure performs the following functions on the system:

Creates core system objects to support call routing and dial plan for Packaged CCE.

Creates two Peripheral Gateways:

• One Generic PG with 1 CUCM PIM and 4 CVP PIMs

• One MR PG with 2 PIMs - one for Outbound and one for Multichannel

Configures the system Correlation ID to be 1001-9999

Sets intelligent application defaults for the Packaged CCE deployment model:

• Default Agent Desk Settings record

• Enables ECC Variables

Create configuration objects to support CVP:

• A type 10 Network VRU for CVP along with Network VRU Labels to send calls to CVP

• CVP ECC Variables

• VXML_Server Network VRU Script - GS,V microapp

Creates configuration objects to support Multichannel Configuration:

• A Network VRU for the MR PG

• Application Instance for Multichannel

• Media Classes for Multichannel

What to Do Next

After running Day 1 congfiguration and before changing deployment type to Packaged CCE, youmust perform
prevalidation configuration.

Prevalidation Changes in Configuration Manager
Once you change the system deployment type to Packaged CCE-PAC-M1, you lose access to most UCCE
Configuration Manager tools. For this reason, you must access Configuration before you change deployment
type and make the following configurations.
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Procedure

Modify Network VRU Labels
The base configuration adds five Network VRU labels. They are:

Routing Client NameNetwork VRU Label

CVP_PG_1A7771111000

CVP_PG_1B7772222000

CVP_PG_2A7773333000

CVP_PG_2B7774444000

CUCM_PG_18881111000

These labels may not be what the customer wants.

Important

If the customer requires Network VRU Labels for the CVP routing clients that begin with numbers other than
777, then you must match the first three digits of their CVP_PG Network VRU Labels to the value in the
Configure Dialed Number Pattern for the Network VRU Label and to the incoming called-number for the
VRU leg, as set in the Configure Cisco IOS Enterprise Voice Gateway.

Procedure

Step 1 Access Network VRU labels in UCCE Configuration Manager.
Step 2 Modify the labels according to the customer's routing patterns.

Define Network Trunk Groups

Procedure

Step 1 Access Network Trunk Groups in UCCE Configuration Manager.
Step 2 Define trunk groups for the trunk reporting in Unified CVP.

Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)    
121

Final Tasks
Modify Network VRU Labels



Set Deployment Type and Run System Validation
Sign in and select deployment type

After you have completed installation and configuration, sign in to Packaged CCE to select the Packaged
CCE deployment type.

To sign in and select the deployment type:

1 Point to https://<IP Address>/cceadmin/Container.jsp, where <IP Address> is the address of either CCE
data server (the one on Side A or the one on Side B).

2 At the sign in page, enter the Active Directory username and password.

This opens the Configure Deployment page, showing the default deployment type of Not Specified.

3 Select Packaged CCE: CCE-PAC-M1 from the drop-down.

This launches the VMValidation process to ensure that the deployment is in conformance with the required
virtual machine specifications, capacity limits, and system validation rules.

4 Enter fields for the Host (or IP address), Username, and Password for the two core servers (Side A and
Side B).

5 Click Save.

Validation results

After a successful validation, you see a Congratulations message.

If the Host (or IP address), Username, or Password entries were invalid, you see a Could Not Connect message.

If either the server or any of the VMs do not meet requirements, you see a message indicating connection
problems. This message has a link to a log file. Open this file to see whether the servers are valid and whether
all VMs match the deployment profiles.

Sample log file showing summary of invalid results
VM Validation Results: Wed Jun 20 08:05:36 EDT 2012
Overall: false
Valid Systems: 0 of 1
Summary:
ESX Server: sideB
ESX Server Properties Valid: true
VM Layout Valid: false.
The information at the top of the log is a summary of the results. This log shows that the server is valid but
the VM layout is not.

Sample log showing invalid server

This shows that the server does not have the required number of CPU Cores.
Server Result:
Required Version: 5.0.0
Required Min CPU Cores: 20
Required Min Memory (MB): 95000
Required HD(s) (GB): [1392, 1949, 273]
Required Bios <Major version>: C260
Required Vendor: Cisco Systems Inc
Found Version: 5.0.0
Found CPU Cores: 10
Found Memory (MB): 98185
Found HD(s) (GB): [1392, 273, 1949]
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Found Bios: C260.1.4.2b.0.102620111637
Found Vendor: Cisco Systems Inc
Sample log showing valid VM
Virtual Machines Matching Defined Profiles:
VM: BB-CCE-DataSvr-A
Profile: Unified CCE Data Server
OS: Microsoft Windows Server 2008 R2 (64-bit)
CPU Cores: 4
Reservation: 5100
RAM (MB): 8192
HD(s) (GB): [80, 750]
VMWare Tools Version: 8384
Invalid VMs

There are three log entries for invalid VMs:

• Required Profiles without Matching Virtual Machines

This means system does not have VMs present that match our requirements.

• Optional Profiles without Matching Virtual Machines

This means that the CVP Reporting profile, which is defined as optional, does not exist on the system.
This does not block validation.

• Virtual Machines without Matching Profiles

This means the system has VMs that do not match requirements. They might be extra VMs or
incorrectly-configured VMs.

Capacity and validation rules pages in the user interface

Two screens in the user interface, both accessed by tabs on the Homemenu, show additional system information,
with indicator for what you must address:

Capacity Info shows the maximum capacity that Packaged CCE supports, whether your system is within
those limits, and what percentage of the maximum is currently used. For example, if the maximum capacity
is 100 reason codes and your system has 300, the capacity indicator will be red.

SystemValidation shows the software specifications for which Packaged CCE has been qualified and whether
your system conforms to those rules. For example, if exactly 9 ECC Variables are required for CVP and your
system has 8 or 10, the Is Valid indicator will be red.

Validation for other system types

For Packaged CCE: CCE-PAC-M1 Lab Only, the same Capacity Info and System Validation checks apply.
There is no VM Validation for these lab systems.

For all other deployment types, no VM validation, Capacity Info, or System Validation takes place.

Deployment Types

TheDeployment Type drop-downmenu on the Packaged CCEConfigure Deployment screen offers 13 options.
The two options appropriate for Packaged CCE are Packaged CCE: CCE-PAC-M1 and Packaged CCE:
CCE-PAC-M1 Lab Only.
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NotesValidationDeployment Type

Requires C260 servers.

The production option enables full
call capacity (8 cps / 1000 agents)
and checks hardware and all VMs
footprint (CCE, CVP, CUIC,
UCM, Finesse).

Capacity check for full call
capacity (8 cps / 1000 agents)

System validation

Validation of all VMs (CCE, CVP,
CUIC, UCM, Finesse)

The production option enables full
call capacity (8 cps / 1000 agents)
and checks hardware and all VMs
footprint (CCE, CVP, CUIC,
UCM, Finesse).

Packaged CCE: CCE-PAC-M1

Allows non-C260 servers.

Select this option if you want a lab
that runs at production-level call
capacity.

The lab only option reduces the call
capacity of the system to 1 CPS /
50 agents.

Capacity check for full call
capacity (8 cps / 1000 agents)

System validation

No VM Validation

PackagedCCE:CCE-PAC-M1Lab
Only

-No validationAll other types

Make a Call
This section explains to make a call:

1 Start up all Unified CCE services if they are not set to Auto Start.

2 Create agents, a skill group, a call type, a dialed number, and a Network VRU script in Unified CCE
Administration. Create agents, skill group, call type, dialed number, and Network VRU script, on page
125

3 Use Script Editor to create a script. Create script, on page 126

4 Add an Agent Targeting Rule. Add Agent Targeting Rule, on page 126

5 Log in to Call from Finesse, on page 127

For calls to run successfully:

See Add Phones, on page 101.You must create two phones for the two agents you
will use in Cisco Finesse.

See Configure application user, on page 97.You must edit the Application User to add those two
phones.

   Installing and Configuring Cisco Packaged Contact Center Enterprise 9.0(x)
124

Final Tasks
Make a Call



• The Network VRU Labels that you changed
during Prevalidation Changes in Configuration
Manager.

• The value for the Network VRU Label
configured for CVP in the Configure Dialed
Number Pattern.

• The incoming called-number for the VRU leg,
as set in the Configure Cisco IOS Enterprise
Voice Gateway.
#Configure VXML leg where the incoming
called-number matches the Network
VRU Label
dial-peer voice 9999 voip
description Used for VRU leg
service bootstrap
incoming called-number 777T
dtmf-relay rtp-nte dtmf-relay rtp-nte
voice-class codec 1
no vad

These values must match:

See Validate Clusterwide Domain Configuration, on
page 94 and Configure SIP Server Group, on page
82

The value configured in Unified CM Administration
Clusterwide Domain Configuration must match the
Server Group name in Unified CVP Server Groups

See Configure CTI Route Point, on page 96The CTI route point must be added to pguser.

Create agents, skill group, call type, dialed number, and Network VRU script
To run a call, you must set up at least two agents, one skill group, a call type, and a dialed number in Unified
CCE Administration.

Procedure

Step 1 Point a browser to the URL https://<IP Address>/cceadmin/Container.jsp, where <IP Address> is the address
of either CCE data server (the one on Side A or the one on Side B).

Step 2 Sign in using your Active Directory username and password.
Step 3 From the menu, selectManage > Agent > Agents. Then create two agents. Refer to the online help for the

procedure.
Step 4 From the menu, selectManage > Agent > Skill Groups. Then create a Skill Group. Refer to the online help

for the procedure.
Step 5 From the menu, selectManage > Call > Dialed Numbers. Then create a Dialed Number String of the routing

type Internal Voice. Refer to the online help for the procedure.
Step 6 From the menu, selectManage > Call > Network VRU Scripts. Then create a Network VRU Script. Refer

to the online help for the procedure.
a) Enter a Name of your choice.
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b) For VRU Script Name, enter the script using the VRU script name parameters; for example:
PM,CCAM_PM.wav,A,CVP, which represents PlayMedia, wav file name, Application, CVP.

c) Keep the defaults in the other fields.

Create script
To run a call, you must create a script.

Procedure

Step 1 Open either CCE Data Server.
Step 2 Navigate to Unified CCE Administration Tools > Script Editor.
Step 3 From the Start node > Run Ext. Script > Queue to Skill Group.
Step 4 Schedule the script.

Add Agent Targeting Rule
To run a call, you must create an Agent Targeting Rule.
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Procedure

Step 1 From either CCEData Server, navigate toUnifiedCCEAdministrationManager >ConfigurationManager.
Step 2 Select Tools > List Tools > Agent Targeting Rule.
Step 3 Click Retrieve. Then click Add.
Step 4 In the Attributes dialog box:

a) Name the rule
b) For Rule type, select Agent Extension.
c) In the Routing client panel, select all four CVP clients.
d) In the Extension Ranges panel, enter the phone extension range of the agents.

Call from Finesse

Procedure

Step 1 Point your browser to Cisco Finesse.
Step 2 Log in as Agent 1, using the ID, password, and phone extension of one of the agents you added.
Step 3 Set the state for Agent 1 to Ready.
Step 4 Log in as Agent 2: using the ID, password, and phone extension of the other agent you added.
Step 5 Set the state for Agent 2 to Ready.
Step 6 As Agent 2, make a call, using the dialed number you configured.

Agent 1 should receive the call.

Related Topics

Create agents, skill group, call type, dialed number, and Network VRU script, on page 125
Add Phones, on page 101
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C H A P T E R  10
Appendix

• Datastore Components and RAID Configuration, page 129

• Automation Spreadsheet Entry Form, page 130

• UCS Network Configuration and QoS, page 142

• Simple Network Management Protocol, page 143

• Virtualization for Packaged CCE, page 144

• Virtualization RF 2, page 145

Datastore Components and RAID Configuration
A datastore is a logical container that holds virtual machine files and other files necessary for virtual machine
operations. CCE PACM1 deploys two datastores for Side A and two for Side B. For each datastore, the table
below describes the RAID configuration, the ESXi Server, and the virtual machines. Note that Datastores A-2
and B-2 service the UCCE Data Server and have individual drives (C and E) for the operating system and
database.

The default block size is 64k.

Virtual MachinesDisk
Drive

ESXi
Host

VM DatastoreRAID Group

Unified CCE Call Server, Side AC:ADatastore-A1

8 x 300GB disks configured
as A1-RAID 5

A1-RAID5

Unified CVP Server number 1A

Unified CVP Server number 2A

Unified Intelligence Center Server (Publisher)

Unified CVP OAMP Server

Unified CMPublisher Unified CMSubscriber
1

Cisco Finesse primary
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Used for the VMware ESXi 5 OS2 x 300GB disks configured
as A3 RAID 1

A3-RAID1

Unified CCE Data Server, Side-A Operating
System

C:ADatastore-A2

6 x 300GB disks configured
as A2-RAID 5

A2-RAID5

Unified CCE Data Server, Side-A DatabaseE:

Unified CCE Call Server, Side-BC:BDatastore-B1

8 x 300GB disks configured
as B1-RAID 5

B1-RAID5

Unified CVP Server number 1A

Unified CVP Server number 2A

Unified Intelligence Center Server
(Subscriber)

Unified CM Subscriber 2

Unified CVP Reporting server (optional)

Cisco Finesse secondary

Unified CCE Data Server, Side-B Operating
System

C:BDatastore-B2

6 x 300GB disks configured
as B2-RAID 5

B2-RAID5

Unified CCE Data Server, Side-B DatabaseE:

Used for the VMware ESXi 5 OS2 x 300GB disks configured
as B3 RAID 1

B3-RAID1

Automation Spreadsheet Entry Form
Use this checklist to enter values for each automation.

ValueRowColumn

_______________________UCCE_CallServer_SideAVM_TYPE

______________________UCCE_CallData_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA
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_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideAOS_TYPE

______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideACREATEVM

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB
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_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideASOURCE_HOST_IP

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideASOURCE_DATASTORE_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB
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_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideAGOLDEN_TEMPLATE_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideANEW_VM_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideADEST_HOST_IP

_______________________UCCE_DataServer_SideA
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_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideADEST_DATASTORE_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________CUCM_Pub_SideAPRODUCT_VERSION

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB
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_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideACOMPUTER_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideAWORK_GROUP

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________UCCE_CallServer_SideAWORK_GROUP_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA
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_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________

_______________________

_______________________

_______________________UCCE_CallServer_SideADOMAIN_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________CUCM_Pub_SideATIME_ZONE_LINUX_AREA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________CUCM_Pub_SideATIME_ZONE_LINUX_LOCATION

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB
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_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideATIME_ZONE_WINDOWS

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________UCCE_CallServer_SideADOMAIN_USER

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________UCCE_CallServer_SideADOMAIN_PASSWORD

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________UCCE_CallServer_SideAPRODUCT_KEY

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA
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_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________UCCE_CallServer_SideAOWNER_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________UCCE_CallServer_SideAORGANIZATION_NAME

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________CUCM_Pub_SideAORGANIZATION_UNIT

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB
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_______________________FINESSE_SUB

_______________________CUCM_Pub_SideAORGANIZATION_LOCATION

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________CUCM_Pub_SideAORGANIZATION_STATE

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________CUCM_Pub_SideAORGANIZATION_COUNTRY

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________CUCM_Pub_SideANTP_SERVER

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideANIC_NUM

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA
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_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideAIP_ADDRESS_NIC1

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideASUB_NET_MASK_NIC1

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA
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_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideADEFAULT_GATEWAY_NIC1

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA

_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideADNS_IP_NIC1

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_Call/VXML_1_SideA

_______________________CVP_Call/VXML_2_SideA

_______________________CVP_OAMP_SideA

_______________________CUCM_Pub_SideA

_______________________CUCM_Sub_SideA
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_______________________CUCM_Sub_SideB

_______________________CUIC_PUB_SideA

_______________________CUIC_SUB_SideB

_______________________FINESSE_PUB

_______________________FINESSE_SUB

_______________________UCCE_CallServer_SideADNS_ALTERNATE_NIC1

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________UCCE_CallServer_SideAIP_ADDRESS_NIC2

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________UCCE_CallServer_SideASUB_NET_MASK_NIC2

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________UCCE_CallServer_SideADEFAULT_GATEWAY_NIC2

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________UCCE_CallServer_SideADNS_IP_NIC2

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

_______________________UCCE_CallServer_SideADNS_ALTERNATE_NIC1

_______________________UCCE_DataServer_SideA

_______________________UCCE_CallServer_SideB

_______________________UCCE_DataServer_SideB

UCS Network Configuration and QoS
In a UCS network configuration, you must enable QoS for both the private network connections (between
Side A and B) and the public network connections (between the Router and the PG).
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You enable QoS on the Call Server in the:

• Cisco Unified CCE router (Configure Unified CCE Router, on page 67)

• Peripheral Gateway Network Interfaces dialog box when you configure the generic peripheral gateway
and CTI server

• Peripheral Gateway Network Interfaces dialog box when you configure the media routing peripheral
gateway Configure Generic Peripheral Gateway, on page 68

To enable QoS on the network, your network must support it. For details, refer to the Bandwidth Provisioning
and QoS considerations section in the SRND: http://www.cisco.com/en/US/partner/products/sw/custcosw/
ps1844/products_implementation_design_guides_list.html.

Simple Network Management Protocol
Simple Network Management Protocol (SNMP) facilitates the exchange of management information among
network devices so that administrators can manage network performance and solve network problems. SNMP
community strings, users, and network destinations are configured in Cisco Unified Serviceability. SNMP is
covered in detail in the Serviceability Administration online help.

Unified Serviceability is one of the tools that open from the Navigation drop-down in Cisco Unified
Communications Solutions tools. You can also access Unified Serviceability by entering
http://x.x.x.x/ccmservice/ where x.x.x.x is the IP address of the publisher.

Community Strings

The SNMP agent uses community strings to provide security. You must configure community strings to access
any management information base (MIB). Add new community strings in the Cisco Serviceability
Administration interface.

A community string is configured with:

• a server

• a name of up to 32 characters

• a setting to accept SNMP packets from any host or from specified hosts

• access privileges (readonly, readwrite, readwritenotify, notifyonly, readnotifyonly, and none)

• a setting to apply the community string to all nodes in the cluster

Notification Destinations

Add notification destinations for delivery of SNMP notification events when events occur. Add and maintain
notification destinations in the Cisco Serviceability Administration interface.

A notification destination is configured with:

• a server

• the host IP addresses of the trap destination

• a port number

• the SNMP version (V1 or V2c)
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• the community string name to be used in the notification messages that the host generates

• the notification type

• a setting to apply to the notification destination configuration to all nodes in the cluster

Virtualization for Packaged CCE
Packaged CCE 9.0(x) has been qualified for ESXi 5.0, installed on UCS C-260-series servers.

VMware Feature Support

waiting for Dhiren

ESXi Counters

The ESXi server and virtual machines must operated within the limits of these key ESXi performance counters:

Performance Indication
and Threshold

DescriptionUnitsMeasurementObjectCategory

This counter should be
zero. A non-zero value
indicates storage
performance issue.

Number of disk
commands aborted
on this disk in the
period. Disk
command aborts
when the disk
array is taking too
long to respond to
the command.
(Command
timeout)

NumberDisk Command
Aborts• ESXi

Server
vmhba
ID

• VM
vmhba
ID

Disk

15ms latencies or greater
indicates a possible
over-utilized,
misbehaving, or
mis-configured disk
array.

The average
amount of time
taken for a
command from the
perspective of a
Gust OS. Disk
CommandLatency
= Kernel
CommandLatency
+ Physical Device
Command
Latency.

mSecDisk Command
Latency• ESXi

Server
vmhba
ID

• VM
vmhba
ID

Disk
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Kernel Command
Latency should be very
small in comparison to
the Physical Device
Command Latency, and
it should be close to zero.
Kernel Command
Latency can be high, or
even higher than the
Physical Device
Command Latency if
there is a lot of queuing
in the ESXi kernel.

The average time
spent in ESXi
Server VMKernel
per command

mSecKernel Disk
Command
Latency

• ESXi
Server
vmhba
ID

• VM
vmhba
ID

Disk

Related Topics

Datastore Components and RAID Configuration, on page 129

Virtualization RF 2

Virtualization Task 3

Procedure

Virtualization Task 3

Procedure

Virtualization Task 3

Procedure
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Virtualization Task 1

Procedure
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C H A P T E R  11
Troubleshooting

This section lists error messages and tips for resolving them.

• Automation Errors, page 147

• Recover from Pressing Ctrl-Alt-Del During Power-On, page 151

• Rerun Automation, page 151

Automation Errors
Table 1: Automation errors

ResolutionIssueError

• Manually add the computer to the required
domain by providing the valid domain
name and credentials.

• Ensure that the user has sufficient
privileges to add the computer to the
domain.

• If the computer cannot reach the domain,
manually configure the network.

• Domain user does not have
sufficient privilege to add the
computer to the specified
domain.

• Computer cannot reach the
specified domain.

• DomainName provided does not
exist.

• Domain user name provided is
incorrect.

• Domain password provided is
incorrect.

Computer did not
get added to the
domain
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ResolutionIssueError

• Manually add the computer to the required
work group by providing the valid
Workgroup name.

• Ensure that the user has sufficient
privileges to add the computer to the
workgroup.

• If the computer network is not configured,
manually configure it.

Workgroup Name provided does not
exist.

Computer did not
get added to the
work group

Computer name should have a minimum of one
and a maximum of 15 characters.

It should not contain special characters other
than hyphen (-).

Invalid criteriaComputer Name

Check that the domain name in the spreadsheet
is not empty and that the format is correct.

Invalid criteriaDomain Name

Check that when the product key specified in
the input file meets the specified format. Product
key should have five blocks, each block
containing five alpha-numeric characters.

Invalid criteriaProduct Key

Check for the computer name. If it is not
provided, enter the correct computer name.

Invalid value or no valueComputer Name
field

Provide the default gateway in the required
format XXX.XXX.XXX.XXX.

Invalid value or no valueDefault Gateway
field.

The name of the Destination Host Data store in
which the new virtual machine is to be created.

Invalid value or no valueDestination Data
Store Name

The IP address of the Destination Host in which
the new virtual machine is to be created.

Invalid value or no valueDestination Host
IP

Enter this value if it is not provided.Invalid value or no valueDomain User
Name field

Enter this value if it is not provided.Invalid value or no valueDomain password
field

Provide the DNS Server in the required format
XXX.XXX.XXX.XXX.

Invalid value or no valueDNS Server field

Provide the IP address in the required format
XXX.XXX.XXX.XXX.

Invalid valueAlternate DNS
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ResolutionIssueError

Provide the IP address in the required format
XXX.XXX.XXX.XXX.

Invalid value or no valueIP Address field

The name of the golden template from which
the customer machine is to be cloned.

Invalid value or no valueGolden Template
Name

Enter this value if it is not provided.Invalid value or no valueOrganization
Name field

Provide the number of NICs required based on
the host golden template.

Invalid value or no valueNum NICs

Configure the correct number of network
adapters.

This error occurs when the wrong
number of network adapters are
configured in the VM before you
convert it to a golden template. VM
deployment will not be successful if
the number of NICs in the template
and its corresponding customization
file do not match.

NIC Mapping
mismatch

Enter this value if it is not provided.Invalid value or no value.

Administrator and Guest are invalid
values.

OwnerName field
(Applicable for
Windows only)

Enter this value if it is not provided.Invalid value or no valueOrganization
Name field

Enter this value if it is not provided.Invalid value or no valueOrganization
Location field

Enter this value if it is not provided.Invalid value or no valueOrganization State
field

Enter this value if it is not provided.Invalid value or no valueOrganization
Country field

Enter this value if it is not provided.Invalid value or no valueProduct key field
(Applicable only
for Windows).

The name of the Source DataStore which
contains the golden template to be used.

Invalid value or no valueSource Data Store
Name field

The IP address of the Source Host that contains
the golden template to be used.

Invalid value or no valueSource Host IP
field
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ResolutionIssueError

Provide the subnet mask in the required format
XXX.XXX.XXX.XXX.

Invalid value or no valueSubnet mask field

Provide and check the Time Zone area for Linux
systems.

Invalid value or no valueTime Zone Linux
Area field
(Applicable for
Linux only)

Provide and check the Time Zone location for
Linux systems

Invalid value or no valueTime Zone Linux
Location"field
(Applicable for
Linux only)

Provide and check the Time Zone area for
Windows system

Invalid value or no valueTime Zone
Windows
(Applicable for
Windows only)

1 Open the command prompt and run the
command slmgr /ipk <product key>.

2 Open the command prompt and run the
command slmgr - dlv and check if product
key is successfully installed.

3 Run the command slmgr - ato to activate the
product key.

The product key provided is not valid.Windows is not
activated

1 Manually configure the network to connect
the computer to internet.

2 Open the command prompt and run the
command slmgr - dlv and check if product
key is successfully installed.

3 Run the command slmgr - ato to activate the
product key

The computer cannot connect to the
Internet for activating.

Windows is not
activated

1 Add the proxy in the LAN settings to connect
to Microsoft key activation server.

2 Open the command prompt and run the
command slmgr - dlv and check if product
key is successfully installed.

3 Run the command slmgr - ato to activate the
product key.

Computer is not able to connect to
Microsoft product key activation
server due to firewall issues.

Windows is not
activated
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Recover from Pressing Ctrl-Alt-Del During Power-On
Validate Network Adapter Settings and Power On initializes the customization process. Although you are
prompted to press Ctrl-Alt-Delete after powering on, doing do will prevent the customization from taking
effect.
DO NOT press Ctrl-Alt-Del.

If you inadvertently press Ctrl-Alt-Del, you have the following option to restore the customization:

Procedure

Step 1 Open the archived spreadsheet for the automation.
Step 2 Go to the CCEPAC1_VMAutomation folder and select the Archive subfolder.
Step 3 Locate the row for the VM whose customization did not process.
Step 4 Enter that data manually for the VM.

Rerun Automation
If you need to delete the VM and rerun the automation script, note the following.

Procedure

Step 1 While rerunning the script, ensure that NO is selected in the spreadsheet CREATEVM column for all the
VMs that deployed successfully.

Step 2 Delete the VM by logging in to vCenter using VSphere Client. Select the VM and delete it from the disk.
Step 3 Ensure that the network configuration provided in the input file is valid before re-running the script.
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