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Preface
Introduction

Cisco Desktop Administrator consists of two parts:

■ Desktop-based Cisco Desktop Work Flow Administrator

■ Web-based Cisco Desktop Administrator

Cisco Desktop Work Flow Administrator enables you to configure the following:

■ Dial strings

■ Phone books

■ Reason codes

■ Wrap-up data

■ Record/monitor notification

■ Work flow groups

Cisco Desktop Administrator enables you to configure the following:

■ Enterprise Data

■ Personnel

■ Agent E-Mail Settings

NOTE:  Desktop Work Flow Administrator is not supported if installed 
on a virtual private network (VPN) desktop.
9
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What’s New In This Release

■ Web-based Cisco Desktop Administrator

■ Agent E-Mail integration

■ Support for Cisco Agent Desktop—Browser Edition

■ Support for multiple browser tabs in Cisco Supervisor Desktop and Cisco 
Agent Desktop

Cisco Desktop Administrator Feature Levels

There are three versions of Cisco Desktop Administrator: Standard, Enhanced, and 
Premium. The following chart outlines the features available in each version. All 
features not listed here are present in all three versions.

Related Documentation

The following documents contain additional information about CAD 6.6:

■ Cisco CAD Installation Guide

■ Cisco Agent Desktop User Guide

■ Cisco Agent Desktop—Browser Edition User Guide

■ Cisco Supervisor Desktop User Guide

■ Cisco IP Phone Agent User Guide

■ Cisco CAD Troubleshooting Guide

■ Cisco CAD Error Code Dictionary

■ Integrating CAD with Citrix Presentation Server or Microsoft Terminal Services

■ Configuring and Troubleshooting VoIP Monitoring

Feature Standard Enhanced Premium

Configure CAD interface × ×

Configure work flows × ×

Configure server and desktop monitoring × ×

Wrap-up data × ×

Agent E-Mail ×
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Getting Started with Cisco Desktop 
Work Flow Administrator
Introduction

Cisco Desktop Work Flow Administrator comes with one license, so only one person 
can view and/or edit data in it at any one time. More than one instance of Desktop 
Work Flow Administrator can be open concurrently.

If someone is using Desktop Work Flow Administrator when you try to access it, an 
error message appears that identifies the IP address of the other user’s computer.

For this reason, it is important that you close Desktop Work Flow Administrator 
completely when you are done using it. As long as the application is running, a license 
is being used and others are blocked from accessing it.
11
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Starting Desktop Work Flow Administrator

To start Desktop Work Flow Administrator:

1. Click Start > Programs > Cisco > Desktop > Admin. Desktop Work Flow 
Administrator starts.

2. Click the Call Center 1 node to expand the navigation tree. By default, 
Desktop Work Flow Administrator is not password-protected and the tree will 
expand. If a password has been configured, you are asked to enter it now. 

For more information about passwords, see "Passwords" on page 17.
12 September 2009
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Automated Updates

Every time you start Desktop Work Flow Administrator, the application checks to see if 
there is an updated version available, or if there was a system configuration change 
that requires a Windows registry change. If either condition exists, the application 
automatically runs the update process.

NOTE:  For automated updates to function correctly, Internet Explorer 
must be configured so that it checks for newer versions of stored 
pages. In Internet Explorer, choose Tools > Internet Options and 
select the General tab. In the Temporary Internet Files section, click 
Settings and ensure that any option other than Never is selected.

NOTE:  If your system is configured with two Unified CCX servers, and 
one server is upgraded while your instance of Desktop Work Flow 
Administrator is connected to the older Unified CCX, and your system 
administrator performs a failover to switch all agents to the upgraded 
server, your instance of Desktop Work Flow Administrator will not 
automatically upgrade when you log into the new server. You must 
shut down Desktop Work Flow Administrator and start it again for the 
automatic upgrade to take place.

When an update is available, you will see a dialog box notifying you that your copy of 
Desktop Work Flow Administrator will be updated. Click OK to proceed with the 
update.

A progress bar is displayed to show you the status of the download.

When the update is finished, you will see a final dialog box that tells you the update is 
complete, and which applications were updated. If you have other CAD applications 
(Cisco Agent Desktop and Cisco Supervisor Desktop) on your PC, they will all have 
been updated.

NOTE:  Because Agent Desktop is automatically installed when 
Supervisor Desktop is installed, only Supervisor Desktop will be listed 
as having been updated in the final dialog box. Agent Desktop will be 
listed only if Supervisor Desktop is not present on your PC.

When you click OK to close the dialog box, any CAD application that had been running 
on your desktop restarts automatically.
September 2009 13
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The Desktop Work Flow Administrator 
Interface

The Desktop Work Flow Administrator interface has two panes. The left pane is a 
navigation tree similar to that found in Windows Explorer. The right pane displays the 
application that you choose in the left pane. 

Toolbar

When you select a node on the navigation tree, the Desktop Work Flow Administrator 
menu bar and toolbar change to reflect the design of that node’s application. 

The toolbar buttons you see are among those listed in Table 1. 

Figure 1. Desktop Work Flow Administrator interface

Table 1. Desktop Work Flow Administrator toolbar buttons 

Button Name Description

About Displays copyright and version information

Delete Removes the selected work flow group

Help Accesses Help files
14 September 2009
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Navigation Tree Pane

Use these mouse or keyboard actions in the left pane to navigate the tree.

Mouse

■ Double-click an icon/application name to expand or collapse the tree.

■ Click the plus sign ( + ) to expand the tree.

■ Click the minus sign ( – ) to collapse the tree.

■ Right-click to rename or delete a node (not available for all nodes).

Keyboard

With a node selected,

■ Press the up and down arrow keys to move from one node to the next.

■ Press the left arrow key to collapse the tree.

■ Press the right arrow key to expand the tree.

Display Pane Navigation

The applications displayed in the right pane are designed to use shortcut keys and the 
tab key as alternatives to using the mouse to navigate around a window. The shortcut 
keys that apply to a specific node are discussed in the section devoted to that node’s 
functions.

New Adds a new work flow group 

Web Opens your web browser and accesses 
Cisco’s website

Table 1. Desktop Work Flow Administrator toolbar buttons — Continued

Button Name Description
September 2009 15
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User Privileges in Windows XP and Vista

Because Desktop Work Flow Administrator users must be able to update registry 
settings, they must have Administrator or Power User privileges on Windows XP and 
Vista platforms. 

Only a person with Administrator privileges can change user privileges on the 
Administrator PC if it is necessary to upgrade them.
16 September 2009
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Passwords

You can use a password to protect both Desktop Work Flow Administrator and Desktop 
Administrator. If you set a password in either application, that password applies to 
both applications.

If you do not want Desktop Work Flow Administrator to be password-protected, you 
must not configure a password in Desktop Administrator. 

For information on configuring passwords in Desktop Administrator, see "Configuring a 
Password in Desktop Administrator" on page 122.

Configuring a Password in Desktop Work Flow 
Administrator

A password is optional for Desktop Work Flow Administrator. If a password is 
configured, when you select the logical contact center node you will be prompted to 
provide the password before you can access any of the subnodes. 

NOTE:  Any password you set in Desktop Work Flow Administrator is 
also the password for Desktop Administrator.

Setting Up a Password

To set up a password:

1. In the navigation pane, select the Call Center 1 node.

2. From the menu bar, choose Setup > Change Password.

The Administrator Password dialog box appears (Figure 2). 

Figure 2. Administrator Password dialog box
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3. Leave the Old Password field blank, and enter a new password, type it again 
to confirm it, and then click OK.

Passwords are case sensitive and can consist of up to a maximum of 32 
alphanumeric characters.

Desktop Work Flow Administrator is now password protected. You must 
restart the application for the change to go into effect.

Changing a Password

To change your password:

1. In the left pane, select the Call Center 1 node

2. From the menu bar, choose Setup > Change Password. The Change Password 
dialog box appears.

3. Enter your old password, a new password, and your new password again to 
confirm it, and then click OK. 

The password is now changed. You must restart Desktop Work Flow 
Administrator for the change to go into effect.

Deleting a Password

To remove password protection:

When you remove the password from Desktop Work Flow Administrator, you 
automatically reset the password in Desktop Administrator to the default value, which 
is blank.

1. In the left pane, select the Call Center 1 node

2. From the menu bar, choose Setup > Change Password. The Change Password 
dialog box appears.

3. Enter your old password, leave the New password and Confirm password 
fields blank, and then click OK.

4. You are asked to confirm that you want to leave Desktop Work Flow 
Administrator unprotected. Click Yes. The password is removed. You must 
restart the application for the change to go into effect.

Restoring the Default Password

The Reset Administrator Password option can be used In the event you forget a 
password you set up. This option resets the password back to its default value (blank) 
without requiring that you know the previous password. 

This menu option is available only in CAD Configuration Setup located on the Unified 
CCX server.
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To restore the default password:

1. On the Unified CCX server, navigate to the C:\Program 
Files\Cisco\Desktop\bin folder.

2. Double-click postinstall.exe to launch CAD Configuration Setup.

3. Choose File > Reset Administrator Password. The utility runs and resets the 
password to blank.

Client Applications

User IDs and passwords are administered inUnified CCX for the following applications:

■ Cisco Agent Desktop

■ Cisco Agent Desktop—Browser Edition

■ Cisco Supervisor Desktop

■ Cisco IP Phone Agent

The user’s password is verified on the CTI server when a user starts the application.
September 2009 19
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CAD Configuration Setup Utility

You can use the CAD Configuration Setup utility to:

■ Configure the CAD services

■ Reset the Administrator password

■ Reset the client install files

Overview

CAD Configuration Setup runs initially as part of the CAD installation process when the 
Unified CCX system is installed. After initial installation, you can change your 
configuration settings by launching it from Desktop Administrator or running 
PostInstall.exe (located in the …\Program Files\Cisco\Desktop\bin folder on each 
CAD computer). 

CAD Configuration Setup displays different step windows, depending on which host 
computer it runs on. Table 2 shows which step windows appear when CAD 
Configuration Setup is run on a specific host computer. Refer to this table to 
determine where you should run Configuration Setup to change the desired 
configuration setting.

NOTE:  If you run CAD Configuration Setup on a computer that hosts 
only Desktop Work Flow Administrator, and no other CAD application 
or service, you will receive a message that there is nothing to 
configure on that computer. Run CAD Configuration Setup on another 
computer that hosts CAD services or applications.  

Table 2. CAD Configuration Setup windows displayed per host computer

Step Name Base*

* Header key: Base—Base services; VoIP—VoIP Monitor service: Rec—Recording service: CAD CSD—
Cisco Agent Desktop, Cisco Supervisor Desktop—CWA: Cisco Work Flow Administrator

VoIP Rec
CAD
CSD CWA

CAD-BE Servers Step (page 23) ×

VoIP Monitor Service Step (page 24) × ×

Services Configuration Step (page 25) × × ×

Terminal Services Step (page 26) ×

SNMP Configuration Step (page 27) × × ×
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Modifying Configuration Data

To modify configuration data:

1. Start CAD Configuration Setup.

■ In Desktop Work Flow Administrator, select the Call Center 1 node in the 
left pane and then choose Setup > Configure Systems from the menu bar.

■ On another CAD host computer, navigate to the C:\Program 
Files\Cisco\Desktop\bin folder and double-click PostInstall.exe.

Configuration Setup starts and displays the CAD Directory Services dialog box. 

2. Ensure that the correct primary (and optional secondary) Directory Services IP 
addresses are entered, and then click OK.

The Cisco Agent Desktop Configuration Setup utility is displayed, with the 
Unified CM node selected.

NOTE:  You can press F6 to switch between the left and right pane, 
and the up and down arrows to move up and down the navigation tree 
in the left pane.

3. Select the step window you want to modify from the left pane, enter the new 
data in the right pane, and then click Apply.

■ You can display the step windows in any order you wish.

■ If you modify something in a step window, you must click Apply to save 
your changes before you move on to another window.

4. When you are done making your changes, choose File > Exit from the menu or 
click Close.

Figure 3. CAD Directory Services dialog box
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CAD Configuration Setup closes.

5. Stop and restart the modified service and all desktops for the change to go 
into effect.

Resetting the Administrator Password

Use the Reset Administrator Password option on the File menu to set the Desktop 
Work Flow Administrator/Desktop Administrator password back to the default. See 
"Restoring the Default Password" on page 18 for more details.

Resetting Client Installation Files

Use the Reset Client Install option on the File menu to recreate the client application 
installation files that are downloaded from the Unified CCX server. This process might 
become necessary if, for example, the IP address of the VoIP service is changed.

This option is available only in CAD Configuration Setup located on the Unified CCX 
server.

To reset the client installation files:

1. On the Unified CCX server, navigate to the C:\Program 
Files\Cisco\Desktop\bin folder.

2. Double-click postinstall.exe to launch CAD Configuration Setup.

3. Choose File > Reset Client Installs. The following MSI files are recreated:

■ Cisco Desktop Administrator.msi

■ Cisco Supervisor Desktop.msi

■ Cisco Agent Desktop.msi
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ConfigurationSetup Step Windows

CAD-BE Servers Step 

The CAD-BE Servers step window appears only in update mode.

Enter the host name or IP address of the CAD Base Services server in the Primary 
Location field. Apache Tomcat, which is required to run CAD-BE, is installed on this 
server. 

If some of your agents are outside the firewall, use the external hostname/IP address 
that maps to the server. If all your agents are inside the firewall, use the internal 
hostname/IP address.

If your configuration includes a second server that hosts the CAD Base Services and 
you have configured replication between the primary and secondary servers, enter the 
location of the second server in the Secondary Location field. 

Figure 4. CAD-BE Servers step window
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NOTE:  If you establish replication in initial mode, the Secondary 
Location field is filled automatically.

The Secondary Location field is not enabled until you configure the second CAD Base 
Services server and establish replication.

VoIP Monitor Service Step 

Select the IP address of the network adaptor to which voice packets are sent to be 
sniffed by the VoIP Monitor service (if this is a server box) or the desktop monitor (if 
this is a client desktop).

■ On a VoIP Monitor Service server, it is the IP address of the NIC that is 
connected to the port configured for SPAN.

■ On a client desktop computer, it is the IP address of the NIC on which the 
computer is daisy-chained to the phone.

NOTE:  If you change these settings after initial setup, you must 
restart the VoIP Monitor service or the client application (depending 

Figure 5. VoIP Monitor Service step window
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on where you run CAD Configuration Setup) to ensure that the change 
is registered with them properly.

Services Configuration Step 

If the computer has more than one IP address, select the IP address of the NIC used 
to connect to the LAN—it must be accessible by the client desktops.

In order to connect to the Unified CM, the Browser and IP Phone Agent (BIPPA) service 
must have a user ID and password. This user ID and password are also set up in 
Unified CME (see “Configuring IP Phones for Use With a Localized BIPPA Service” in 
the Cisco CAD Installation Guide). You can complete these fields before actually 
setting up the user in Unified CME, but the user ID and password must be identical in 
both places. If they are changed in this window or in Unified CMCME, they must be 
changed in both.

NOTE:  If Directory Services is not running when you view this step, 
the IPPA login information cannot be changed.

Figure 6. Services Configuration step window
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NOTE:  If you change these settings, you must restart all CAD services 
to ensure that the change is registered with them properly.

Terminal Services Step 

If this installation of Cisco Agent Desktop is installed in a Microsoft Terminal Services 
or Citrix environment, click Yes. If not, click No.

Figure 7. Terminal Services step window
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SNMP Configuration Step  

The SNMP Configuration step window appears only during update mode if the 
Microsoft Simple Network Management Protocol (SNMP) service is installed on the 
CAD Base services server.

If you select the Enable SNMP Trap Generation check box, INFO and higher error 
messages are sent from the CAD services server to the IP addresses configured in the 
Destination pane. Use the Add, Edit, and Remove buttons to manage the list of 
destination IP addresses.

The SNMP service can be installed using the Add/Remove Windows Components 
button in the Add or Remove Programs utility in Control Panel. Select Management 
and Monitoring Tools from the list of available components, and then choose Simple 
Network Management Protocol.

SNMP allows you to monitor and manage a network from a single workstation or 
several workstations, called SNMP managers. SNMP is actually a family of 
specifications that provide a means for collecting network management data from the 

Figure 8. SNMP Configuration step window
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devices residing in a network. It also provides a method for those devices to report 
any problems they are experiencing to the management station.

For more information on using this tool, see Microsoft SNMP documentation.
28 September 2009
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Synchronizing Directory Services

The Directory Services database should be synchronized with the master Unified CCX 
agent database. The databases are synced automatically whenever the master 
Unified CCX database changes. However, you can manually sync them with the 
Synchronize Directory Services command.

NOTE:  You can synchronize Directory Services manually from the 
Desktop Administrator web application also. See "Synchronizing 
Directory Services" on page 139 for more information.

To synchronize the databases manually:

1. In the left pane, select the Call Center 1 node.

2. From the menu, choose Setup > Synchronize Directory Services.

When the synchronization is complete, the system displays a confirmation 
message that Directory Services was successfully synchronized.
September 2009 29



Cisco Desktop Administrator User Guide
30 September 2009



September 2009
Work Flow Configuration
Introduction

Work Flow Configuration enables you to configure and maintain the appearance and 
behavior of Agent Desktop, Agent Desktop—Browser Edition, and IP Phone Agent. 
Work Flow Configuration has the following functions:

■ Reason Codes (page 33)

■ Monitor/Record Notification (page 43)

■ Work Flow Groups (page 44)

To use any Work Flow Configuration application, select its node in the left navigation 
pane of the Desktop Work Flow Administration window (Figure 9). The right display 
pane shows the selected node.
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The CAD client applications must be restarted for any configuration changes you 
make to go into effect.   

NOTE:  When configuring the name or ID of objects (examples are 
work groups, work flows, agent login names, server names, and 
macro names), do not use the “=”character. This can cause problems 
when backing up and restoring data.

  

Figure 9. Work Flow Configuration window, Reason Codes node selected
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Reason Codes

Reason codes describe why an agent has changed to the Not Ready agent state or 
has logged out. 

A maximum of 999 reason codes can be set up for CAD and CAD-BE. IP Phone Agent 
has a limit of 100 reason codes.

Global reason codes, which are available to all agents, are assigned using the Reason 
Codes node under the Work Flow Configuration node. Work flow group reason codes, 
which are available only to agents in that specific work flow group, are assigned using 
the Reason Codes node under the specific work flow group’s node (Figure 10).  

Reserved reason codes (identified by [RESERVED] after the description) are 
predefined in Directory Services and cannot be created or deleted.

There are also Unified CCX-generated reason codes that are entered when an agent is 
automatically put in the Not Ready or Logout state. For instance, when an agent 
receives a non-ACD call, the agent is put into the Not Ready state by Unified CCX and 
the reason code “32761–Non-ACD Call” is entered.

Figure 10. Global and work flow Reason Codes nodes

Global reason code node

Work flow reason code node
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The reserved reason codes are listed in Table 3.  

Table 3. Reserved reason codes 

Code State Description

22 Logout Supervisor logout.

33 Not Ready Supervisor Not Ready.

1000 ACD voice.

32755 Not Ready Call ended. The system issues this reason code when 
an agent is moved to the Not Ready state after handling 
a Unified CCX call.

32756 Not Ready Device in service (phone up). The system issues this 
reason code when the agent’s phone comes up after it 
has been through a Phone Down state.

32757 Not Ready CallManager failover. The system issues this reason 
code when the Unified CM fails over and the agent is 
moved to the Not Ready state.

32758 Not Ready Work timer expired. The system issues this reason code 
when an agent’s state is changed from Work to Not 
Ready. This change occurs if the Work state for that 
agent’s CSQ is associated with an expired wrap-up time.

32759 Not Ready Device out of service (phone down). The system issues 
this reason code if the agent’s phone crashes and that 
agent is placed in the unavailable state.

32760 Not Ready Logon. The system issues this reason code when an 
agent logs in and is automatically placed in the Not 
Ready state.

32761 Not Ready Non-ACD call. The system issues this reason code when 
the agent is logged on to Agent Desktop or IP Phone 
Agent and then receives a call that is not queued on the 
Unified CCX platform.

32762 Not Ready Off hook. The system issues this reason code when the 
agent goes off the hook to place a call. If the agent 
remembered to do this task the corresponding 
agent-triggered reason code is displayed. If the agent 
did not remember to do this task, the system issues this 
reason code.

32763 Not Ready Ring no answer. The system issues this reason code 
when the agent fails to answer a Unified CCX call within 
the specified timeout period.
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Not Ready and Logout reason codes are enabled or disabled on the work flow group 
level.

When creating reason codes, follow these guidelines:

■ Descriptions can consist of up to 40 alphanumeric characters. No 
punctuation or other characters are allowed.

■ No agent state can contain duplicate numbers and descriptions among its 
reason codes.

■ Reason code numbers can be any number from 0 to 999.

NOTE:  While 0 is an allowed reason code number, it is strongly 
recommended that you do not use it. Using 0 as a reason code can 
result in control failures or missing agent state events in Unified CCX. 

■ Reason codes are either all enabled or all disabled for both the Not Ready and 
Logout agent states. You cannot enable reason codes for one state and 
disable them for another.

■ You cannot enable reason codes unless at least one user-defined reason 
code exists for Logout and one exists for Not Ready. 

NOTE:  Agents must restart Agent Desktop, Agent Desktop–Browser 
Edition, and IP Phone Agent to see any changes you make to reason 
codes.

32764 Logout CRS failover. The system issues this reason code when 
the active server becomes the standby server and the 
agent loses connection to the Unified CCX platform.

32765 Logout Connection down. The system issues this reason code 
when IP Phone Agent or Agent Desktop crashes due to 
any reason or if the connection is disrupted.

32766 Logout Force logout (close Agent Desktop). The system issues 
this reason code when an agent closes Agent Desktop 
without logging off.

32767 Logout Force login (agent relogin). The system issues this 
reason code when an agent is already logg3ed in to one 
device (computer or phone) and then tries to relog in to 
a second device.

Table 3. Reserved reason codes — Continued

Code State Description
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NOTE:  For Chinese, Japanese, and Korean localized sites, reason 
codes might not appear correctly in IP PHone Agent due to the phone 
limitations on multi-byte characters. 

Assigning Reason Codes

To assign global reason codes:

1. Select the global Reason Codes node in the navigation tree to display the 
Reason Codes window (Figure 11, left). 

2. Select the appropriate tab for the type of reason codes you want to assign: 
Logout or Not Ready.

3. From the Available Reason Codes List, select the reason codes you want 
available to all agents, and then click the right arrow button to move them to 
the Global Reason Codes List.

4. Click Apply.

To assign work flow reason codes:

1. Select the Reason Codes node under the desired work flow group in the 
navigation pane to display the Reason codes window (Figure 11, right).

2. Select the appropriate tab for the type of reason codes you want to assign: 
Logout or Not Ready.

3. From the Available Reason Codes List, select the reason codes you want 
available to agents in that work flow group, and then click the right arrow 
button to move them to the Work Flow Group List.

Figure 11. Reason Code window

Global level Work flow group level
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4. Select the Enable Logout Reason Codes or Enable Not Ready Reason Codes 
check box to enable that type of reason code for the agents in that work flow 
group. This includes any global reason codes set up.

5. Click Apply.

Enabling or Disabling Reason Codes

Reason codes can be enabled or disabled only on the work flow group level, and must 
be done individually for every work flow group.

To enable or disable reason codes:

1. Select the Reason Codes node under the work flow group whose reason 
codes you want to enable or disable.

2. Select the appropriate tab and then select or clear the Enable Logout Reason 
Codes or Enable Not Ready Reason Codes check box.

3. Click Apply.
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Wrap-up Data

Wrap-up data descriptions are used by contact centers for purposes such as tracking 
the frequency of different activities and identifying the account to which to charge a 
call, among others. Wrap-up data is set up and maintained, and automated state 
changes are enabled, using the Wrap-up Data window. Wrap-up data descriptions are 
used for both calls and e-mails.

There is no limit on how many wrap-up data descriptions can be set up for CAD and 
CAD-BE. IP Phone Agent has a limit of 100 wrap-up data descriptions.

NOTE:  CAD and CAD-BE agents must log out, exit, and restart the 
application for changes to take effect.

Global wrap-up data descriptions, which are available to all agents, are created and 
assigned using the Wrap-up Data under the Work Flow Configuration node. Work flow 
group wrap-up data descriptions, which are available to agents only in that specific 
work flow group, are created and assigned using the Wrap-up Data node under the 
specific work flow group’s node (Figure 12).  

In Agent Desktop, CAD-BE, and IP Phone Agent, the agent selects the appropriate 
wrap-up data description at the beginning of the wrap-up work time for a call or sent 
e-mail.

Figure 12. Global and work flow wrap-up data nodes

Global wrap-up data node

Work flow wrap-up data node
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When creating wrap-up data descriptions, follow these guidelines:

■ Descriptions can consist of up to 39 alphanumeric characters. No 
punctuation or other characters are allowed.

NOTE:  For Chinese, Japanese, and Korean localized sites, 
descriptions might not appear correctly in IP Phone Agent due to the 
phone limitations on multi-byte characters. 

■ Duplicate descriptions are not allowed.

Creating Wrap-up Data Descriptions

You can create and modify wrap-up data descriptions on both the global and work flow 
group level. 

To create a wrap-up data description:

1. Select the global or work flow group Wrap-up Codes node in the navigation 
tree to display the Wrap-up Codes window (Figure 13).  

Figure 13. Wrap-up Data window

Global level Work flow group level
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2. Click Modify List to display the Wrap-up Data Editor dialog box (Figure 14). 

3. Type the new wrap-up data description in the Description field, and then click 
Add. The wrap-up data description is added to the Wrap-up Data list.

4. Click OK close the dialog box, and then click Apply to save your changes.

To edit a wrap-up data description:

1. Select the global or work flow group Wrap-up Data node in the navigation tree 
to display the Wrap-up Data window (Figure 13).

2. Click Modify List to display the Wrap-up Data Editor dialog box (Figure 14).

3. Double-click the wrap-up data description you want to edit.

4. In the pop-up dialog box, edit the description as desired and then click OK.

5. Click OK to close the Wrap-up Data Editor dialog box, and then click Apply to 
save your changes.

Figure 14. Wrap-up Data Editor dialog box
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To delete a wrap-up data description:

1. Select the global or work flow group Wrap-up Data node in the navigation tree 
to display the Wrap-up Data window (Figure 13).

2. Click Modify List to display the Wrap-up Data Editor dialog box (Figure 14).

3. Select the wrap-up data description you want to delete, and then click Delete.

4. Click OK to close the dialog box, and then click Apply to save your changes.

Assigning Wrap-up Data Descriptions

Wrap-up data descriptions can be assigned at the global and at the work flow group 
level. Global wrap-up data descriptions are available to all agents. Work flow group 
level wrap-up data descriptions are available only to the agents in that specific work 
flow group.

To assign global wrap-up data descriptions:

1. Select the global Wrap-up Data node in the navigation tree to display the 
Wrap-up Data window (Figure 13, left).

2. From the Available Wrap-up Descriptions list, select the descriptions you want 
available to all agents, and then click the right arrow button to move them to 
the Global Wrap-up Descriptions list. 

3. Click Apply.

To assign work flow wrap-up data descriptions:

1. Select the Wrap-up Data node under the desired work flow group in the 
navigation pane to display the Wrap-up Data window (Figure 13, right).

2. From the Available Wrap-up Data list, select the descriptions you want 
available to agents in that work flow group, and then click the right arrow 
button to move them to the Work Flow Wrap-up Data list. 

3. Select the Enable Wrap-up Data check box to enable wrap-up data for the 
agents in that work flow group. This includes any global wrap-up data 
descriptions set up.

4. Click Apply.

Enabling or Disabling Wrap-up Data

Wrap-up data can be enabled or disabled only on the work flow group level.

To enable or disable wrap-up data:

1. Select the Wrap-up Data node under the work flow group whose wrap-up data 
descriptions you want to enable or disable.
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2. Select or clear the Enable Wrap-up Data check box. 

3. Click Apply.

Automatic State Changes

By default, automatic state changes are not enabled. After agents enter wrap-up data, 
they remain in the Work state for the length of time set for the wrap-up timer or until 
they change states manually, whichever happens first. (The wrap-up timer value is 
configured in Unified CCX Administration.)

If automatic state changes are enabled, agents are automatically changed from the 
Work state to the Ready state (or to the Not Ready state, if they select that state while 
still on a call) after they enter wrap-up data.

Automatic state changes can be enabled or disabled only on the work flow group level.

To enable or disable automatic state changes:

1. Select the Wrap-up Data node under the work flow group whose automatic 
state changes you want to enable or disable.

2. Select or clear the Enable Automatic State Change check box. 

3. Click Apply.
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Monitor/Record Notification

The Monitor/Record Notification window (Figure 15) is used at the global level to 
enable or disable messages to agents that they are being recorded or monitored, or 
both. 

To enable or disable agent notification:

1. Select the Record/Monitor Notification node in the navigation tree.

2. In the Record/Monitor Notification window, select or clear the Notify 
Monitoring and/or Notify Recording check boxes, and then click Apply.

You can also enable/disable monitoring and recording from the menu bar.

To enable or disable agent notification from the menu bar:

■ From the menu bar, choose Monitoring > Notify Monitoring and/or 
Monitoring > Notify Recording. A check mark appears next to the option when 
it is enabled.

Figure 15. Monitor/Record Notification window
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Work Flow Groups

Use the Work Flow Groups function to create and configure agent work flow groups.

Under the Work Flow Groups node are individual work flow groups. Initially there is a 
default work flow group, which can be edited, renamed, or deleted. You can also 
create additional work flow groups.

When you click on a work flow group, the elements that make up and apply only to that 
work flow group appear as subnodes:

■ Enterprise Data—Configure enterprise data on the agent desktop.

■ Reason Codes—Assign reason codes.

■ Wrap-up Data—Create and edit wrap-up data.

Figure 16. Accessing the Work Flow Group functions in the navigation pane
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■ CAD Agent—Configure the user interface and voice contact work flow, and 
agent management work flows for agents using Cisco Agent Desktop.

■ CAD-BE Agent—Configure the user interface and voice contact work flows for 
agents using Cisco Agent Desktop—Browser Edition.

■ IP Phone Agent—Enable agent-initiated recording for agents using the Cisco IP 
Phone Agent service.

Maintaining Work Flow Groups

You can add, delete, or edit work flow groups under the Work Flow Groups node. 

NOTE:  If you choose to delete the default work flow group, make sure 
that all agents are assigned to a custom work flow group you have set 
up. If an agent is not assigned to a work flow group, and there is no 
default work flow group, that agent will not be able to start Agent 
Desktop.

To add a new work flow group:

1. In the Navigation pane, choose the Agents node or work flow group subnode 
(for example, under Agents, choose the Default work flow group).

2. From the menu bar, choose File > New. The Work Flow Group Name Editor 
dialog box appears (Figure 17). 

3. Enter a new work flow group name. The name can be a maximum of 64 
characters long.

Figure 17. Work Flow Group Name Editor dialog box
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If you want to copy an existing work flow group, select the “Copy the following 
work flow group” check box and choose a work flow group from the drop-down 
list.

4. Click OK. The new work flow group appears in the Navigation pane. The new 
work flow group has the same setup as the default work flow group. 

To delete an existing work flow group:

1. In the Navigation pane, choose the work flow group you want to delete.

2. From the menu bar, choose File > Delete.

You are warned that all agents belonging to the work flow group you want to 
delete must be reassigned to other work flow groups. Click Yes to confirm the 
deletion, or No to cancel it. If you do not reassign the agents, you will not be 
able to delete the work flow group.

3. Click OK to close the dialog box.

To rename a work flow group:

1. Add a new work flow group. 

Name the new work flow group with the name you want the existing work flow 
group to be renamed.

Select the “Copy the following work flow group” check box and select the 
existing work flow group from the drop-down list.

2. Delete the old work flow group.
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Enterprise Data

The Enterprise Data window enables you to: 

■ Configure Agent Desktop so that agents in the selected work flow group can 
edit enterprise data

■ Set thresholds for call duration at a particular type of device while a call is in 
the contact center

Data

The Data tab (Figure 18) controls whether or not an agent in the work flow group is 
allowed to edit the enterprise data displayed in Agent Desktop. 

To enable enterprise data editing:

■ Select the Allow agent to edit Enterprise Data check box, and then click Apply.

Figure 18. Data tab
September 2009 47



Cisco Desktop Administrator User Guide
Call Activity

The Call Activity tab (Figure 19) enables you to set the thresholds for the selected work 
flow group for call duration at a particular type of device (CSQ and Agent) while a call 
is in the contact center.

If a call remains at a device longer than the defined Caution or Warning threshold, a 
Caution or Warning icon is displayed next to the device name in the Agent Desktop call 
activity pane. 

To set up call activity thresholds:

1. On the Call Activity tab, enter the threshold times as desired.

Enter values in the Warning fields before entering values in the Caution fields. 
If you enter values in the Caution fields first, Desktop Work Flow Administrator 
automatically enters values one second greater in the Warning fields.

The Warning threshold value must be greater than the Caution threshold 
value. If you enter a greater value in the Caution field, Desktop Work Flow 
Administrator automatically changes it so that it is one second less than the 
Warning value.

Figure 19. Call Activity tab
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Maximum Warning value: 59 minutes, 59 seconds 
Maximum Caution value: 59 minutes, 58 seconds

2. Click Apply to save your changes.
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CAD, CAD-BE, and IP Phone Agent

The CAD Agent, CAD-BE Agent, and IP Phone Agent nodes enable you to configure 
various functions for each type of agent within the selected work flow group.

CAD Agent

You can configure the following for agents using Agent Desktop:

■ User Interface (page 51)

■ Voice Contact Work Flows (page 65)

■ Agent Management Work Flows (page 73) 

CAD-BE Agent

You can configure the following for agents using CAD-BE:

■ User Interface (page 51)

■ Voice Contact Work Flows (page 65)

IP Phone Agent

The Recording node under the IP Phone Agent node enables agent-initiated recording 
for agents who use the IP Phone Agent service.

NOTE:  If your CAD system is configured to use Unified CM-based 
monitoring, the IP Phone Agent node is not available.

When enabled, the IP Phone Agent service has soft key options for starting and 
stopping recording. The IPPA agent can then record his or her own phone 
conversations, and these recordings can be reviewed by the supervisor using 
Supervisor Record Viewer.

See the Cisco IP Phone Agent User Guide and the Cisco Supervisor Desktop User 
Guide for more information.

To enable IPPA agent-initiated recording:

1. Select the Enable IPPA Recording check box.

2. Click Apply to save your changes.
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User Interface

The User Interface window enables you to configure the appearance and behavior of 
Agent Desktop (when accessed under the CAD Agent node) and CAD-BE (when 
accessed under the CAD-BE Agent node).

NOTE:  The User Interface windows for CAD Agent and CAD-BE Agent 
are slightly different to allow for the differences in the two 
applications. The following section will discuss the CAD Agent version 
and note where it is different for CAD-BE Agent.

Toolbar

The Toolbar tab (Figure 20) enables you to:

■ Adding and Removing Toolbar Buttons (page 51)

■ Associating Actions with Task Buttons (page 52)

■ Changing a Task Button’s Hint (page 53)

■ Customizing Button Icons (page 53)

■ Show Data Fields (page 55)  

Adding and Removing Toolbar Buttons

The pane on the left of the Toolbar tab displays the buttons that are available to be 
used on the Agent Desktop toolbar. Buttons that are assigned show an icon next to 
them; unassigned buttons do not show an icon. 

Figure 20. Toolbar tab

CAD Agent version CAD-BE Agent version
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You cannot change the hint or the shortcut key combination on any of the standard 
buttons, or assign an additional action to them. You can, however, customize the icon 
displayed on the button (see “Customizing Button Icons” on page 53).

To add a button to the toolbar:

1. In the list of buttons, select the available button you want to add.

2. Select the Visible check box, and then click Apply.

Removing a button from the toolbar:

1. In the list of buttons, select the button you want to remove.

2. Clear the Visible check box, and then click Apply.

Associating Actions with Task Buttons

You can associate as many actions with a task button as you wish. The actions are 
executed sequentially in the order they are listed in the Actions window. 

NOTE:  Bear in mind the amount of time it takes to execute actions. 
Generally, a maximum of two or three actions per task button is 
recommended.

The default task buttons display icons of the numbers 1 through 10. You can 
customize these icons if you wish.

To associate an action with a task button:

1. Select a task button from the list of available buttons. 

2. Select the Visible check box. The Actions pane and its associated buttons 
become enabled.

3. Under the Actions pane, click Add. The Select Action window appears. 

4. Select the action you want to associate with the button.

You can select an existing action or set up a new action. (See “Actions” on 
page 78 for more information on setting up new actions.)

5. Click OK. The Toolbar tab is displayed.

6. Type a short description of the action in the Hint field. You can replace only 
the hint; you cannot change the shortcut key combination.

7. Repeat Steps 3–6 if you want to add other actions to the same task button. 

8. Click Apply to save your changes.
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Changing a Task Button’s Hint

You can change the hint (the text an agent sees when the mouse hovers over a button) 
associated with a task button. 

You cannot change the hint associated with a standard button, or change the shortcut 
key combination of any button.

To change a task button’s hint:

1. Select the button whose hint you want to change.

2. In the Hint field, type the hint you want displayed to the agent.

3. Click Apply to save your changes.

Customizing Button Icons

Buttons can be customized by applying different icons to them. A library of available 
icons is supplied with Desktop Work Flow Administrator, or you can use icons of your 
own.

If you use your own icons, when applied to a button the icon file is written to Directory 
Services so it is available to all instances of Agent Desktop. 

Custom icons must meet the following specifications.

■ ICO format

■ 50 Kb file size limit

■ 16 × 16 or 32 × 32 pixels

■ up to 256 colors

To customize an icon:

1. Choose the button whose icon you want to customize.
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2. Click Customize Icon. The Choose Icon dialog box appears (Figure 21).  

3. Choose an icon. The icon is displayed in the Preview area.

You can also click Browse to navigate to another location if you wish to use 
your own icon. 

4. Click OK. The button is displayed with the new icon on it in the button list.

To reset a button icon:

1. Select the button that has the icon that you previously customized. The Reset 
button becomes enabled.

2. Click Reset. The original icon is displayed in the button list.

3. When you are finished, click Apply to save your changes.

Figure 21. Choose Icon dialog box
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Show Data Fields

The Show Data Fields tab (Figure 22) configures the data fields that appear in the 
contact appearance pane in Agent Desktop and CAD-BE, and enables you to rename 
data fields. It also allows you to enable/disable incrementing duration fields in 
CAD-BE.  

NOTE:  Agent Desktop and CAD-BE agents must log out, exit, and log 
in again for changes to take effect.

Configuring and Renaming Data Fields

The left pane displays the fields that appear in Agent Desktop and CAD-BE. The right 
pane displays the available fields. 

NOTE:  The left pane must contain at least one field.

To configure data fields:

1. Use the left and right arrows to move the available fields between the left and 
right panes, and the up and down arrows to set the left-to-right order in which 
the fields will appear.

2. Click Apply to save your changes. 

Figure 22. Show Data Fields tab

CAD Agent version CAD-BE Agent version
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To rename a data field:

1. Double-click the field you want to rename. The Rename dialog box appears 
(Figure 23).  

2. Enter a new name and then click OK.

Show Duration

For CAD-BE agents, select the Show Duration check box to enable the Duration field in 
CAD-BE to increment during a call. By default this option is enabled. However, a 
continually changing field can cause difficulties for screen readers, so this field might 
be disabled for agents who are visually impaired. 

For CAD agents, this feature is enabled/disabled in the Agent Desktop Preferences.

Figure 23. Rename dialog box
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Miscellaneous

Use the Miscellaneous tab (Figure 24) to configure other user interface options. 
Select or check your desired settings, and then click Apply to save your changes. 

Figure 24. Miscellaneous tab

Table 4. Miscellaneous Tab options

Option Description

Window Behavior Specify how you want the Agent Desktop window to 
behave. The default setting is Agent’s Choice.

• Normal. The window appears when calls are present 
and minimizes when idle.

• Keep Open. The window is always visible, but can be 
hidden by other open applications.

• Always on Top. The window is always visible and on 
top of other open applications.

• Stealth. The window appears as an icon in the 
system tray.

• Agent’s Choice. Behavior is set locally by the agent. 
The local setting persists until reset or until you 
choose something other than Agent’s Choice. On the 
agent’s desktop, the default setting is Normal.

CAD Agent version CAD-BE Agent version
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Browser Setup

Use the Browser Setup tab (Figure 25) to configure the Integrated Browser portion of 
Agent Desktop and CAD-BE. On this tab you can:

■ Enable/disable the integrated browser window

■ Set the default web page displayed by the browser

■ Enable up to 10 browser tabs

■ Enable/disable agents’ access to other websites 

■ Add work sites (or “favorites”) so agents can quickly access frequently-used 
websites

Macro Hot Key Specify the key you want to use to pause macro 
recording and display the Suspend Macro Recording 
dialog. The default is F2.

Rules and Actions only 
apply to the first call 
appearance

Select to invoke rules processing only for the oldest (top) 
call appearance. If the check box is not selected, rules 
processing is invoked for all inbound calls.

Table 4. Miscellaneous Tab options

Option Description

Figure 25. Browser Setup tab

CAD Agent version CAD-BE Agent version
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Enabling the Integrated Browser

You can enable/disable the integrated browser in Agent Desktop/CAD-BE by selecting 
or clearing the Enable Integrated Browser check box at the bottom of the Browser 
Setup tab.

Enabling Access to Other Websites

You can enable/disable an agent’s access to other websites by selecting or clearing 
the Allow Address Editing check box. When selected, the Address field appears in the 
integrated browser window, and agents can enter the URL of a website they wish to 
view. When disabled, the Address field does not appear in the integrated browser 
window.

Configuring the Number of Browser Tabs

Choose 0 to 10 in the Number of Work Flow Browsers field to set how many browser 
tabs appear in Agent Desktop (this feature is not available in CAD-BE). If you choose 0, 
only the supervisor push page tab appears—it is always enabled. If you choose 1 to 
10, that many tabs in addition to the supervisor push page tab appear. 

Work flow HTTP actions can be set up to display web pages in a specific browser tab. 
See “HTTP Action” on page 89 for more information.

Setting Up the Home Page

A home page is the website that appears in the integrated browser when Agent 
Desktop or CAD-BE is started. The default website is www.cisco.com. If no home page 
is configured (the default is deleted), the integrated browser tab is blank.

To configure a home page:

1. From the Browser Tab drop-down list, select the tab where you want the home 
page to appear.

2. In the Home Page field, type the web address (URL) of the website you want to 
appear by default in the integrated browser.

3. Click Update.

4. Repeat steps 1 through 3 for each tab as desired.

5. Click Apply to save your changes. The home page is set. 

Setting Up Work Sites

A work site is a website that is frequently accessed by agents to assist them in their 
jobs. They are similar to the “favorites” you can set up in a web browser. 

Work sites you set up appear in a drop-down list in the agent’s integrated browser. 
When the agent selects a work site from the list, it is displayed in the integrated 
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browser window. This allows the agent quick access to the site without having to type 
its address in the (optional) Address field.

To add a work site:

1. In the Site Name field, type the name of the website you wish to add as a work 
site.

2. In the URL field, enter the web address of the website.

3. Click Add. The work site is added to the list in the Work Sites pane.

4. Click Apply to save your changes.

To update a work site:

1. In the Work Sites field, select the work site you wish to update. The 
information for the website appears in the Site Name and URL fields.

2. Edit the information as needed, and then click Update. The updated 
information appears in the Work Sites pane.

3. Click Apply to save your changes.

To delete a work site:

1. In the Work Sites pane, select the work site you wish to delete. The 
information for the website appears in the Site Name and URL fields.

2. Click Delete. The work site is deleted from the Work Sites pane.

3. Click Apply to save your changes.

Remote Access

The Remote Access tab (Figure 26) is used to enable the IPC Receive Event feature 
and configure the port used by the feature. The IPC Receive Event feature is available 
in the Enhanced and Premium bundles only.
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NOTE:  The Remote Access feature is not available for CAD-BE.  

An IPC Receive Event occurs when a third party application sends a message to Agent 
Desktop over a UDP socket. These messages must adhere to a predefined XML 
schema (see examples below) and cannot exceed 4000 bytes. 

Unlike work flow actions, IPC Receive Event actions do not require configuration or 
setup in Desktop Administrator. All attributes that IPC Receive Event actions require in 
order to execute are a part of the IPC Receive Event message content. All incoming IPC 
Receive Event messages must adhere to a strict predefined XML schema. The 
required schemas are defined below.

When Agent Desktop receives an IPC Receive Event message, it does not send a reply 
back. IPC Receive Events are queued so no messages are lost.

Figure 26. Remote Access tab
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By default, IPC Receive Events are disabled. The default port number is Port 58000. 

NOTE:  The Remote Access action provides for receiving an 
asynchronous event. Even if the event is solicited by an IPC Action 
request being sent out, the request may never be delivered, and there 
is no assurance that a response will arrive because of the nature of 
UDP.

Five actions are supported by the IPC Receive Event:

■ IPC Make Call Action (page 62)

■ IPC High Priority Chat Action (page 62) 

■ IPC Record Action (page 63)

■ IPC Agent Notification Action (page 63)

■ IPC Set Variable Action (page 64)

IPC Make Call Action

For the IPC Make Call action to be successful:

■ The agent must be in the Not Ready state

■ There can be no call appearance present in Agent Desktop

■ The Make Call dialog box must be closed (if it is open, the action will close it)

The message sent to Agent Desktop must conform to this XML format. Bold text 
indicates a variable that must be replaced with your own values.

<?xml version="1.0"?>
<!-- IPC Receive Event Message -->
<IPCActions>

<IPCMakeCallAction>
<ActionName>IPC Make Call Action</ActionName>
<PhoneNumber>2961</PhoneNumber>
<DisplayError>true</DisplayError>

</IPCMakeCallAction>
</IPCActions>

IPC High Priority Chat Action

For the IPC High Priority Chat action to be successful, the agent must be logged in.

The message sent to Agent Desktop must conform to this XML format. Bold text 
indicates a variable that must be replaced with your own values.

<?xml version="1.0"?>
<!-- IPC Receive Event Message -->
<IPCActions>
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<IPCHighPriorityChatAction>
<ActionName>IPC High Priority Chat 

Action</ActionName>
<MessageText>Need help from 

supervisor</MessageText>
</IPCHighPriorityChatAction>

</IPCActions>

IPC Record Action

For the IPC Record action to be successful:

■ A call appearance must be present in Agent Desktop

■ The call must be connected, on hold, or conferenced

■ The call must be the first call appearance listed in Agent Desktop

The message sent to Agent Desktop must conform to this XML format. The action 
supports two commands: start and stop. 

<?xml version="1.0"?>
<!-- IPC Receive Event Message -->
<IPCActions>

<IPCRecordAction>
<ActionName>IPC Record Action</ActionName>
<Command>start</Command>
<DisplayError>true</DisplayError>

</IPCRecordAction>
</IPCActions>

IPC Agent Notification Action

For the IPC Agent Notification action to be successful, the agent must be logged in.

The message sent to Agent Desktop must conform to this XML format. Bold text 
indicates a variable that must be replaced with your own values.

<?xml version="1.0"?>
<!-- IPC Receive Event Message -->
<IPCActions>

<IPCAgentNotificationAction>
<ActionName>IPC Agent Notification 

Action</ActionName>
<MessageText>Go to Not Ready state!</MessageText>

</IPCAgentNotificationAction>
</IPCActions>
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IPC Set Variable Action

For the IPC Set Variable action to be successful, the agent must be logged in. 

The IPC Set Variable action receives data values (for example, Cisco Outbound Dialer 
variables prefixed with “BA”) from a third party application in UDP format. The action 
sends these data values to the CTI server.

All variables (ECC variables, call variables, and Outbound Dialer variables) can be set 
with this action.

The message sent to Agent Desktop must conform to this XML format. Bold text 
indicates a variable that must be replaced with your own values.

<?xml version="1.0"?>
<!-- IPC Receive Event Message -->
<IPCActions>

<IPCSetVariableAction>
<ActionName>IPC Set Variable Action</ActionName>
<Variable>BAResponse</Variable>
<DataValue>03/05/2009 05:45</DataValue>

</IPCSetVariableAction>
</IPCActions>
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Voice Contact Work Flows

Voice contact work flows manage agent activity based on voice call events. Once a call 
is classified it is further filtered according to events, rules, and actions. Voice contact 
work flows are available to Agent Desktop and CAD-BE agents.

For example, a voice contact work flow could be set up as follows:

1. A call comes into the contact center and is routed to an agent in the Ready 
state.

Figure 27. Voice Contact Work Flows flow chart
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2. The Voice Contact Classification filter determines which work flow to select. It 
examines the inbound call’s enterprise data (original dialed number) and 
determines that it is a call for Product A technical support and thus meets the 
data conditions of Work Flow 1. The call is now subject to the second layer of 
filtering set up in Work Flow 1.

3. Work Flow 1 says that any ringing event on the Product A support line triggers 
an HTTP action. This action takes the customer-entered account information 
from the IVR (part of the call’s enterprise data) and pops a web page in Agent 
Desktop’s or CAD-BE’s integrated browser that displays the customer’s 
account information to the agent. 

4. The agent answers the phone call and is ready to assist the customer.

Creating a Voice Contact Work Flow

The general procedure for creating a voice contact work flow is as follows:

1. Set up a new voice contact classification filter:

a. Select the type of call the work flow applies to—inbound, outbound, or all 
calls.

b. If required, further classify the call by specifying it must meet various data 
field conditions.

2. Set up the second level of filtering: 

a. Select the call or agent state event—Ringing, Answered, Work, or Dropped.

b. If required, set up one or more rules with data field conditions that the 
call must meet.

c. Set up one or more actions that will take place if the call or agent event 
meets the rules’ data field conditions.

3. Set up as many second level filters as needed for calls selected by the first 
level filter. You can set up rules and actions for each of the filtered call’s call 
or agent events.

NOTE:  It is possible to set rules and conditions that are contradictory 
so that a work flow cannot function. Desktop Work Flow Administrator 
does not check a work flow’s logic and validity. If a work flow fails to 
operate as expected, make sure that the rules and conditions you set 
up are logically valid.

Setting Up a New Voice Contact Classification

When you select the Voice Contact Work Flow node in the navigation tree, the Voice 
Contact Work Flow List window is displayed. This window shows all the existing voice 
contact work flows, and enables you to edit them or to set up new ones.
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The Voice Contact Classification is the first level of filtering in a voice contact work 
flow.

To set up a new voice contact classification:

1. In the Voice Contact Work Flow List window, click Add. The New Work Flow 
Name dialog box is displayed.

2. Enter a name for your new voice contact work flow, and then click OK. The Edit 
Voice Contact Classification dialog box appears (Figure 28). Note that the 
work flow name you just created is shown in the dialog box.  

3. Set up the criteria for the first level filter in this dialog box. 

a. Select the type of call you want the filter to apply to from the drop-down 
list: inbound calls, outbound calls, or all calls.

Note that there is also the option to disable the work flow. You can select 
this option later on if and when you want to disable the work flow, but 
want to keep the work flow on file for use at a later date.

b. Apply up to three data field conditions. Click Edit to display the Data Field 
Condition dialog box. For information on setting up a data field condition, 
see “Data Field Conditions” on page 69.

c. Select if you want the filter to apply when ALL conditions are true, or if 
ANY conditions are true. 

4. Click OK to complete setting up the first level filter in the new voice contact 
work flow.

Figure 28. Edit Voice Contact Classification dialog box
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Setting Up a New Work Flow

After a new voice contact classification is created, Desktop Work Flow Administrator 
takes you to the Voice Contact Work Flow window (Figure 27). In this window you set 
up the second level of filtering, consisting of events and rules, and the resulting 
actions for your new voice contact work flow. 

When an event occurs, the rules associated with the event are evaluated in the order 
they are listed in the Rules pane. When a rule is met, the actions associated with that 
rule are executed in the order they are listed in the Actions pane. Subsequent rules 
are not evaluated.

If no rules are met, the default rule governs, and all actions associated with the 
default rule are executed. Default rules cannot be changed or deleted.

The default action might be <no action>. 

Figure 29. Voice Contact Work Flow window
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To set up a new work flow:

1. Select the event that triggers the work flow from the Event pane. The available 
events are:

— Ringing. The agent’s phone rings.

— Answered. The agent answers the phone.

— Dropped. The call is terminated.

— Work. The agent transitions to the Work agent state.

2. Under the Rules pane, click New to set up a new rule. The New Rule Name 
dialog box appears. 

3. Enter the name of the new rule, and then click OK. The fields in the Current 
Rule Conditions section of the window are enabled.

4. Add up to 3 data field conditions (see “Data Field Conditions” on page 69 for 
more information) and specify when the actions should be executed—when 
any one of the data field conditions is met, or when all of the data field 
conditions are met.

When a data field condition is established, the Enable Rule check box is 
automatically selected.

NOTE:  You cannot use a route point phone number when configuring 
a rule for inbound ACD calls. 

5. Under the Actions pane, click Add to choose one or more actions to run when 
the event occurs and the rules are met. 

You can select an existing action, or create a new action. If the action you 
select cannot be associated with the event, you will receive an error message. 
See “Actions” on page 78 for more information. 

6. Repeat steps 1 through 5 for as many events as desired. 

7. When you are finished associating events with rules and actions, click Apply 
to save the new voice contact work flow.

Data Field Conditions

Data field conditions are criteria that a call’s selected enterprise data fields must 
meet in order for a voice contact classification or a work flow rule to be enforced. 

You can configure up to 3 data field conditions for a voice contact classification filter 
and for a work flow rule. You specify if all the data field conditions must be met (an 
AND statement) or if any of the data field conditions must be met (an OR statement). 
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To do this you use the Data Field Condition dialog box (for a voice contact 
classification) (Figure 30) or the Current Rule Conditions section of the Voice Contact 
Work Flow window (for a work flow rule).  

To set up data field conditions:

1. In the Voice Contact Classification dialog box, click Edit. In the Voice Contact 
Work Flow window, add a new rule and then click Edit in the Current Rule 
Conditions section of the window. 

2. Select a data field from the Data Field drop-down list.

The Data Field lists all the enterprise data fields used in your system. 

Not all data fields are available for all events, for instance, Calling# and 
Called# are not available for the Ringing event.

3. Specify one of the data field filters:

— Is Empty. There is no data in the data field.

— Is Not Empty. There is data in the data field.

Figure 30. Data Field Condition dialog box
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— Is In the List. The data field is compared to the list you set up in the List 
pane to determine if it is in that list. Click Add to add an item to the list of 
strings. Strings are not case sensitive. You can use wild cards (* and ?) to 
simplify your list. See “Wild Card Searches” on page 71. 

— Is Not in the List. The data field is compared to the list you set up in the 
List pane to determine if it is not in that list. Click Add to add an item to 
the list of strings. Strings are not case sensitive. You can use wild cards (* 
and ?) to simplify your list. See “Wild Card Searches” on page 71.

— Length of Data. The length of the data field is between a minimum and 
maximum number of characters that you set. 

4. Ensure that the Enable Condition check box is selected, and then click OK.

Wild Card Searches

You can use wild cards when entering strings in the data field conditions list pane. 
This enables you to avoid having to enter many strings if the strings you want to list 
have common elements. 

Wild card characters used are the asterisk (*) and the question mark (?). 

An asterisk in a string replaces any quantity of characters, as long as the other 
characters in the string match. For instance, ABC* matches strings that begin with 
ABC but end in any quantity of any characters.

A question mark in a string replaces any character, but the length of the string must 
be exactly as represented. For instance, ABC?? matches strings that begin with ABC 
and end in 2 other characters.

Double quotes around a string searches for the exact characters within the double 
quotes, including the wild card characters (*) and (?). For instance, “123*ABC” 
matches only the string 123*ABC, and does not allow the asterisk to act as a wild 
card.

Modifying a Voice Contact Work Flow

You can modify the default work flow and any custom work flows you create.

NOTE:  The classification filter for the Default work flow is Inbound 
Calls. This cannot be changed. 

To modify a voice contact work flow:

1. From the Voice Contact Work Flow List, select the work flow you want to 
modify, and then click Edit.

■ If you selected a custom work flow, the Edit Voice Contact Classification 
dialog box appears. 
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■ If you select the default work flow, the Voice Contact Work Flow window 
appears. The default work flow does not classify voice contacts, and so 
bypasses the Edit Voice contact Classification dialog box.

2. Modify the voice contact classification if desired, and then click OK to proceed 
to the Voice Contact Work Flow window.

3. Modify the work flow as desired, and then click Apply to save your changes.

Deleting a Voice Contact Work Flow

You can delete any custom work flow you create. You cannot delete the default work 
flow.

To delete a voice contact work flow:

1. From the Voice Contact Work Flow List, select the work flow you want to 
delete, and then click Delete. A popup window appears asking you to confirm 
you want to delete the work flow.

2. Click OK to confirm the deletion.
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Agent Management Work Flows

Agent management work flows manage agent activity based on Agent Desktop and 
CAD-BE activity, agent ACD states, and time of day. The work flows follow the event—
rule—action behavior used by voice contact work flows. There is a major difference—
there is no initial filtering similar to the voice contact classification applied to voice 
contacts.

For example, agent management work flows could be set up as follows:

■ Every work day at 4:30, agents receive a popup message reminding them to 
complete their time cards.

■ Whenever Agent Desktop starts up, Notepad is launched on the agent’s 
desktop.

■ Whenever an agent enters the Ready state, the customer database is 
launched.

Figure 31. Agent Management Work Flows flow chart
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Creating an Agent Management Work Flow

The general procedure for creating an agent management work flow is as follows:

1. Select the event that triggers the work flow.

2. If the event is time of day, set up a rule with one or more data conditions that 
the event must meet.

NOTE:  It is possible to set rules and conditions that are contradictory 
so that a work flow cannot function. Desktop Administrator does not 
check a work flow’s logic and validity. If a work flow fails to operate as 
expected, make sure that the rules and conditions you set up are 
logically valid.

3. Set up one or more actions that will take place whenever the event occurs, or, 
if a time of day event, whenever the rule is met. 

When you select the Agent Management Work Flow node, the Work Flow window 
appears (Figure 32).  

Figure 32. Work Flow window
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Unlike rules in voice contact work flows, rules in agent management work flows can be 
applied only to a time of day event, not to all events.

Not all actions are available for agent management work flows. See “Action 
Availability” on page 79 for more information.

To set up a CAD activity or agent state work flow:

1. Select the event that triggers the work flow from the Event pane. The available 
events are:

— Startup. Agent Desktop/CAD-BE starts.

— Shutdown. Agent Desktop/CAD-BE closes.

— Ready. The agent transitions to the Ready state.

— Not Ready. The agent transitions to the Not Ready state.

2. Under the Actions pane, click Add to choose one or more actions to run when 
the selected event occurs. You can select an existing action, or create a new 
action. See “Actions” on page 78 for more information.

3. Repeat steps 1 and 2 for as many events as desired. 

4. When you are finished associating events with actions, click Apply to save the 
agent management work flow.

To set up a time of day work flow:

1. Select the Time of day event from the Event pane. 

2. Under the Rules pane, click New to set up a new rule. The New Rule Name 
dialog box appears. 
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3. Enter the name of the new rule, and then click OK. The fields in the Current 
Rule Conditions section of the window are enabled, and the Time of Day 
Condition dialog box appears (Figure 33). 

4. Set up the day or date conditions for the rule, and then click OK. 

a. To specify that an action takes place every week on certain days or at a 
certain time, select Day(s) of the week and then select the desired days. 
You must specify a time of day as well.

b. To specify that an action takes place on a specific date, select Date, and 
then select the desired date from the calendar. Today’s date is circled in 
red. You must specify a time of day as well.

The condition you set up is automatically entered in the first Data Field 
Conditions line in the Current Rule Conditions section of the Work Flow 
window, and the Enable Rule check box is automatically selected.

Figure 33. Time of Day Conditions dialog box
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5. Click Edit next to the 2 remaining Data Field Conditions fields to display the 
State Condition dialog box (Figure 34), and further define the rule, if desired: 

■ Specify if the agent is on hook or off hook

■ Specify if the agent state is or is not equal to Ready or Not Ready  

6. Under the Actions pane, click Add to choose one or more actions to run when 
the event occurs and the rules are met. 

You can select an existing action, or create a new action. See “Actions” on 
page 78 for more information.

7. Click Apply to save the new time of day work flow.

Figure 34. State Condition dialog box
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Actions

Actions are stored independently of events and rules. You can use an action in more 
than one event, and you can assign actions to more than one task button in Agent 
Desktop and CAD-BE.

While actions are processed, events are queued. It is generally a good idea to avoid 
long actions. 

Table 5. Action types and descriptions 

Action Type Description

Importing and Exporting 
Actions (page 81)

Displays a popup message on the agent’s desktop

Agent Notification Action 
(page 85)

Displays a custom message popup window on the 
agent’s desktop when a certain event occurs

Agent State Action (page 87) Sets an agent state

Delay Action (page 89) Inserts delay time in series of actions

HTTP Action (page 89) Enables the Agent Desktop and CAD-BE integrated 
browser to interact with a web application

IPC Action (page 97) Passes enterprise data or user-defined data from 
the agent desktop to a custom third-party 
application

Launch External Application 
Action (page 99)

Starts a third-party application

Run Macro Action (page 101) Plays back a recorded sequence of keystrokes.

Set Enterprise Data Action 
(page 112)

Automatically changes an enterprise data field in 
Agent Desktop to a selected desktop variable or 
static text

Timer Action (page 114) Triggers actions after a specified time has elapsed

Utility Action (page 115) Run a utility, such as start and stop recording or 
sending a predefined, high-priority chat message 
to a supervisor
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Action Availability

Not all actions are available for all events or for all types of agents. Table 6 shows 
which actions are available for the three types of work flows and for each type of agent 
(CAD agents and CAD-BE agents). 

Table 6. Action availability per work flow type and agent type* 

* “×” indicates the action is available: “—” indicates the action is not available.

Action Type

Voice Contact Agent Mgmt Time of Day

CAD CBE CAD CBE CAD CBE

Agent Notification × — × — × —

Agent State × — — — × —

Delay × — × — — —

HTTP × × × — × —

IPC × — × — — —

Launch External Application × — × — — —

Run Macro × — × — — —

Set Enterprise Data × — — — — —

Timer × — — — — —

Utility × × — — — —
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Adding a New Action

To add a new action:

1. Access the Voice Contact Work Flow or Agent Management Work Flow window.

2. Select the event to be associated with the new action.

3. Under the Actions pane, click Add. The Select Action dialog box appears 
(Figure 35).  

4. Choose the tab for the type of action you want to associate with the event. 

5. If the action already exists, select it, and then click Add Action.

If the action does not yet exist, click New and follow the instructions for setting 
up that type of action as outlined below.

6. Click Add Action. The Select Action dialog box closes and you return to the 
Work Flow window. The new action is listed in the Actions pane.

Figure 35. Select Action dialog box
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Editing an Action

To edit an action:

1. In the Work Flow window, select the appropriate event, and then select the 
action you want to edit from the Actions pane. 

2. Click Edit. The edit dialog box for that action appears.

3. Make your changes, and then click OK. The action is now changed.

Deleting an Action

To permanently delete an action, you must first delete it from any event it is 
associated with, and then delete the action itself. 

To permanently delete an action:

1. In the Work Flow window, select each event. If the action you want to delete is 
associated with that event, select the action in the Action pane and then click 
Delete to remove it from that event. The action is now removed from all 
events.

2. Under the Actions pane, click Add. The Select Actions dialog box appears.

3. Choose the appropriate tab, and then select the action you want to delete.

4. Click Delete. The action is deleted.

5. Click Close. The Select Action dialog box closes and you return to the Work 
Flow window.

Importing and Exporting Actions

You can export actions associated with a specific work flow group and import them to 
other work flow groups. The actions are exported to any location you choose, locally or 
on a network drive. 

NOTE:  If you export actions to the default location (C:\Program 
Files\Cisco\Desktop\config\Action) they will be lost in the event that 
a client desktop is reinstalled. To avoid this, choose a location other 
than the CAD installation directory.

The actions you export can also be imported by other instances of Desktop Work Flow 
Administrator, belonging to your system or any other system, as long as those 
instances are the same version of Desktop Work Flow Administrator and can access 
the file storage folder.
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Types of actions that can be exported and imported are:

■ Run Macro action

■ HTTP action

■ IPC action

■ Launch External Application action

The rules and events associated with the actions are not part of this function and 
cannot be exported or imported. 

You can export only one action at a time. For example, if there are five actions you 
want to export from a work flow group, you must export each action individually. 

You can add a description (limited to 255 characters) to the exported action for easier 
identification when importing to another work flow group. 

If an imported action has the same name as an action already present in the work 
flow group, you will be prompted to rename the imported action.

To export a work flow action:

1. Select the work flow group whose action you want to export.

The Import Export Work Flow Actions window appears (Figure 36). 
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If there are actions available for import and/or export, the Import and/or 
Export button is enabled. If there are no actions available for the specific 
action, that button is disabled. 

Figure 36. Import Export Work Flow Actions window
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2. Click Export. The Export Action dialog box appears (Figure 37).  

3. Select the action you want to export from the Action List, and then complete 
the fields in the dialog box:

■ Folder Path: Select the default path shown or browse to any other local or 
network folder location.

■ Description (optional): Enter a description of the action. Maximum length 
of the description is 255 characters.

4. Click OK.

To import a work flow action:

1. Select the work flow group to which you want to import an action.

The Import Export Work Flow Actions window appears (Figure 36).

Figure 37. Export Actions dialog box
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2. Click Import. The Import Select dialog box appears (Figure 38). 

3. Navigate to the folder where actions are stored. The field is autofilled with the 
default path.

4. From the Action Names list, select the action you want to import to the work 
flow group. You can import only one action at a time. 

5. Click OK.

Agent Notification Action

An Agent Notification action displays a custom message popup window on the agent’s 
desktop when a certain event occurs. For instance, when an agent logs out, a popup 
window reminding the agent to complete his time card could pop up on his desktop. 

To set up an Agent Notification action:

1. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears.

Figure 38. Import Select dialog box
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2. Select the Agent Notification tab, and then click New. The Agent Notification 
Action Setup dialog box appears (Figure 39). 

3. Enter an action name, select the icon you want to appear in the popup 
window, and then type your message.

4. Click Preview to see what the popup window will look like (Figure 40). 

NOTE:  The title bar on the actual popup window might contain 
truncated text, because Windows automatically adds “Cisco Agent 
Desktop” to the beginning of the title bar text, and the popup window 
does not resize. 

5. Click OK.

Figure 39. Agent Notification Action Setup dialog box

Figure 40. Preview of an Agent Notification popup window
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Agent State Action

An Agent State action enables you to select an agent state to associate with an event. 

Agent State actions can be associated only with Answered and Dropped events. The 
only valid agent states are Login, Logout, Ready, Not Ready, and Work.

To set up an Agent State action:

1. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears. 

2. Select the Agent State tab, and then click New. The Agent State Action Setup 
box appears (Figure 41).  

3. Enter a name for the action, select the agent state control from the drop-down 
list, and then click OK.

Automated Reason Codes for Agent State Changes

You can enable automated reason codes when you set up an agent state action for 
transitioning to Logout or Not Ready. 

If you enable automated reason codes, the agent does not have to choose the 
appropriate reason code when an agent state action to transition to Logout or Not 
Ready is triggered.

To enable automated reason codes

1. Set up a new Agent State action (see “Agent State Action” on page 87) or edit 
an existing Agent State action (see “Editing an Action” on page 81). 

Figure 41. Agent State Action Setup dialog box
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2. In the Agent State Action Setup dialog box, enter a name for the action, select 
either AgentNotReady or AgentLogout from the Agent State Control drop-down 
list. The Automate Reason button appears in the dialog box (Figure 42).  

3. Click Automate Reason. The Select Reason dialog box appears (Figure 43). 
This dialog box contains the reason codes already set up in the system. 

4. Select the reason code you want to be entered automatically when the action 
is triggered, and then click OK.

The default is “Agent will choose.” If you select this, the agent will have to 
manually enter the reason code. 

The dialog box closes and the Agent State Action Setup dialog box is 
displayed, with the number of your chosen reason code entered in the gray 
box next to the Automate Reason button. 

5. Click OK. 

Figure 42. Agent State Action dialog box with Automate Reason button

Figure 43. Select Reason dialog box
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Delay Action

Delay actions are used to add delay time between actions in a series of actions. For 
example, the delay action can be added to a work flow that includes a series of 
macros that need delay time between execution of those macros. 

To set up a Delay action:

1. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears.

2. Select the Delay Action tab, and then click New. The Delay Action Setup dialog 
box appears (Figure 44).  

3. Enter the following information:

■ A name for the delay action

■ The length of delay time, in milliseconds

■ Select the Process Events During Delay check box if you want events to be 
processed in the background during the delay period

4. Click OK.

HTTP Action

This action is available to Agent Desktop agents at the Premium level (Post and Get), 
and to CAD-BE agents at the Enhanced and Premium levels (Get only). 

HTTP actions enable an agent to use call-based data to interact with a website or a 
web application in the Integrated Browser window.

For example, an HTTP action can be set up so the enterprise data of an incoming call 
is used to retrieve a customer record and display it in the Integrated Browser. 

Figure 44. Delay Action Setup dialog box
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NOTE:  For more information on HTTP requests and the HTTP protocol 
in general, see the website of the World Wide Web Consortium, 
www.w3.org.

NOTE:  Keep in mind that a URL, including arguments, is limited by 
the HTTP service to a maximum of 2075 characters. If you create an 
HTTP action that results in a URL longer than that, it will not work 
correctly. 

To set up an HTTP action:

1. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears.

2. Select the HTTP Action tab, and then click New. The HTTP Actions Setup dialog 
box appears (Figure 45.).

3. Complete the HTTP Actions Setup dialog box as follows:

Field Description

Action Name Enter a name for the new action.

Protocol Select the protocol to be used by the browser: http 
(default) or https.

Method Select the http method to be used by the browser: GET 
(default, CAD and CAD-BE agents) or POST (CAD agents 
only).

Host Enter the host name or IP address of the website. Do not 
include the http or https prefix.

Port Enter the port (0–65535) that the host is listening on (for 
http the default is 80; for https, the default is 443). 

Path Enter the path portion of the URL (optional). Default is 
blank. Do not include a leading slash.

Browser Tab Select the browser tab in which you want the action 
results to be displayed. (For CAD-BE agents there is only 
1 tab available so this field is not present.)

If the tab you select is removed later, the action will be 
displayed in the first tab (ordinarily reserved for 
supervisor page push).
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Figure 45. HTTP Actions Setup dialog box
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4. Click Add to display the HTTP Request Data dialog box (Figure 46). The fields 
added with this dialog box make up the query or post data portion of the 
request. The fields are optional and are blank by default. 

5. Complete the HTTP Request Data dialog box as follows:

Figure 46. HTTP Request Data dialog box

Field Description

Value Name Enter the name of the field in the web application.

Value Type Select one of the following:

• DataField to use an enterprise data variable as the 
source of the data. This is inserted in the URL 
following the <name>=<value> format.

• UserDefined to use a specific string entered in the 
Value field. This is inserted in the URL following the 
<name>=<value> format.

• DataFieldOnly to insert any value selected from the 
Valuedrop-down list without following the 
<name>=<value> format.

Value If you selected a value type of DataField or 
DataFieldOnly, select the enterprise data variable from 
the drop-down list. If you selected UserDefined, enter the 
value to be used.

Test Data Enter a string of test data to simulate DataField or 
DataFieldOnly data. This field is enabled only if you 
select a Value Type of DataField or DataFieldOnly.
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6. Continue to build your request using the Add, Edit, and Delete buttons as 
needed.

7. When you have completed building the request, click Preview to view the 
request. Note that Desktop Work Flow Administrator has added the special 
characters needed for a valid HTTP request. 

■ If a path is specified and there is request data, there will be a “/” after the 
port and a “?” after the path.

Example: http://www.site.com:80/index.jsp?name=value

■ If a path is not specified, there is request data, and the first request data 
is not DataFieldOnly, there will be a “?” after the port and no “/”.

Example: http://site.com:80?name=value

■ If a path is not specified, there is request data, and the first request data 
is DataFieldOnly, there will be a “/” after the port and no “?”.

Example: http://www.site.com:80/value

■ If a path is not specified, there is more than one request data, and the 
first request data is DataFieldOnly, there will be a “/” after the port and no 
“?”.

Example: http://www.site.com:80/value&value&value…

8. When you are satisfied your request is correctly formatted, click Test to test it 
using the test data you entered when adding the request data.

Reserved Characters

There are characters that must not be used in an HTTP request. These characters are 
listed in Table 7.

Table 7. HTTP request reserved characters 

Symbol Description

& Ampersand

@ At sign

\ Back slash

^ Carat

: Colon

, Comma

$ Dollar sign

“ Double quote

= Equal sign
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Example of an HTTP Request

To illustrate how to create a basic HTTP request, we will write a request that uses the 
Google search engine to search the web for “Cisco Systems.” 

To learn what value names and values go into the Google search:

1. Open your web browser and navigate to www.google.com. 

! Exclamation point

< Left angle bracket

[ Left square bracket

% Percent

+ Plus

# Pound sign

? Question mark

> Right angle bracket

] Right square bracket

; Semicolon

‘ Single quote

/ Slash

Table 7. HTTP request reserved characters — Continued

Symbol Description
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2. Type Cisco Systems in the search field and then click Google Search. The 
address bar shows the HTTP request we will create in Desktop Work Flow 
Administrator(Figure 47). 

3. The Address bar shows this string:

www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=gd&q=Cisco+ 
Systems&wxob=0

The portion of the string before the question mark is the host and the path. 
After that, all the request data is listed, separated by ampersands (&). 

Figure 47. Google search results page

Name Value

Host www.google.com

Path search

Request Data ie=UTF-8

oe=UTF-8

sourceid=gd

q=Cisco+Systems

wxob=0
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To create the HTTP request:

1. Complete the HTTP Actions Setup dialog box with the information you 
gathered from the manual Google search (Figure 48).  

The values are all user-defined. The value name is on the left side of the equal 
sign, and the value is on the right side of the equal sign.

Note that Google inserted a plus sign (+) between the words Cisco and 
Systems in the request string. You do not need to include that character in the 
HTTP Request Data dialog box. Desktop Work Flow Administrator will add an 
acceptable string to indicate the space between the words.

2. After you have entered the request data, click Preview to view the resulting 
request string. 

It should be identical to the string displayed in the Google search results 
address bar. If you used a plus sign between the words Cisco and Systems, 
you will see “%2B” instead of the plus sign; if you used a space, you will see 
“%20”. These strings indicate a space and are an acceptable substitute for 
the plus sign.

Figure 48. Google search information entered in the HTTP Action Setup dialog box
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3. Click Test to test your HTTP request. 

The request should open your browser, navigate to the Google Search page, 
and run a search for Cisco Systems.

IPC Action

This action is available to Agent Desktop agents at the Premium level.

IPC actions pass information in the form of UDP (user datagram protocol) messages 
from the agent desktop to a third-party application using IPC (interprocess 
communication) methods. The third-party application can be located on the agent’s 
PC or anywhere on the network.

NOTE:  You must have a custom application written that listens for 
data sent to a specific IP address and port.

An IPC action is one-way—that is, when CAD sends data using an IPC action, it does 
not receive a response or any acknowledgement that the message was received by 
the recipient third-party application.

The data sent is enterprise data or user-defined data. It is sent in the format:

valuename=value&name=value&name=value…

To set up an IPC action:

1. Set up a new action. See “Adding a New Action” on page 80.

The Select Action window appears.

2. Select the IPC Action tab, and then click New.
September 2009 97



Cisco Desktop Administrator User Guide
The IPC Action Setup dialog box appears (Figure 49).  

3. Complete the IPC Action Setup dialog box as follows:

4. Click Add to display the IPC Request Data dialog box (Figure 50).

Figure 49. IPC Action Setup dialog box

Field Description

Action Name Enter a name for the new action.

Protocol The default (and only) protocol is UDP.

IP Address Enter the IP address of the third-party application that 
will receive the data.

Port Enter the port number the third-party application is 
listening on for data.
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The fields added with this dialog box make up the query portion of the 
request.  

5. Complete the IPC Request Data dialog box as follows:

6. Continue to build your request using the Add, Edit, and Delete buttons as 
needed.

7. When you have completed building the request, click OK.

Launch External Application Action

Launch External Application actions start a third-party application in a new window.

To ensure applications are running before macros attempt to use them, start them 
with launch actions assigned to the Startup event.

Figure 50. IPC Request Data dialog box

Field Description

Value Name Enter the name of the field.

Value Type Select DataField to use an enterprise data variable as 
the source of the data. Select UserDefined to use a 
specific string entered in the Value field.

Value If you selected a value type of DataField, select the 
enterprise data variable from the drop-down list. If you 
selected UserDefined, enter the value to be used.
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NOTE:  An application started by a launch action must use the same 
path on the agent’s PC as it does on the administrator’s PC or it must 
be on a network drive, or the launch action will not be successful.

When using launch actions, Agent Desktop can pass parameters such as command 
line arguments in two ways. 

The first method is to add parameters after the application path name. For example, 
the command to start Microsoft Excel and open a spreadsheet named mrmtest.xls is:

“c:\program files\excel.exe” “c:\my documents\mrmtest.xls”

NOTE:  Program names and command line arguments that contain 
spaces must be in quotes so that they appear as one argument rather 
than as multiple arguments.

The second method involves passing data fields as arguments. You can pass any valid 
data field while launching an application. Note that if a launch action takes place on 
the Startup event, call data may not be present. Empty or blank data fields will contain 
the string <NULL>.

To set up a Launch External Application action:

1. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears.
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2. Select the Launch External Application Action tab, and then click New. The 
Launching External Application Action Setup dialog box appears (Figure 51). 

3. Enter a name for the action and enter the path to the desired application’s 
location. Make sure the application is located so that it is available to Agent 
Desktop at runtime.

4. Add any arguments you wish to pass to the application. Choose the desired 
argument in the Available Arguments list, and use the left arrow to add it to 
the Argument list. Use the up and down arrows to reorder the Argument list.

5. When you have finished entering information, click OK. 

Run Macro Action

A macro is a shortcut for a sequence of keystrokes. For example, you might record a 
macro that performs the following tasks with each incoming call:

1. Copy the ANI (Automatic Number Identification) from Agent Desktop to 
Microsoft Outlook

2. Open a contact list

3. Find the ANI in a database or spreadsheet

4. Display a screen containing the caller’s account information

NOTE:  Do not use a Run Macro action to perform tasks that can be 
accomplished by one of the other types of actions available. For 

Figure 51. Launching External Application Action Setup dialog box
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example, use a Call Control action to transfer a call, and an Agent 
State action to change agent states.

NOTE:  Run Macro actions do not work correctly when Chinese and 
Korean characters (and potentially any multi-byte characters) are 
used. 

Macro Recording Tips

If your macro accesses a third-party application, make sure that the application is 
open. If the macro enters text into the third-party application, make sure that 
application has Windows focus. 

Keystroke macros play back to the top level window they were recorded in. If you are 
running a keystroke macro to a Terminal Services window, you must make sure that 
the appropriate application in that Terminal Services window always has focus, 
otherwise the keystrokes will be sent to the wrong application.

Before you begin to record the macro, make a test run with the third-party application, 
writing down all of the keystrokes required for the tasks you wish to perform.

Avoid using:

■ Tab or arrow keys in your macro because the cursor may not always be in the 
same position each time a window opens.

■ Mouse clicks and movements, because the macro recorder does not record 
them.

Use keyboard shortcut keys instead to perform actions in the application.

NOTE:  When a macro is executed, it can be impacted by the current 
keyboard settings of the client PC. Care should be taken to ensure 
that keyboard settings, such as Caps Lock, are not inadvertently left 
on. Agents should also be cautioned not to enter keystrokes while a 
macro is running, since that can also affect the macro.

Shortcut keys are indicated by an underlined letter in the button name, field name, or 
description. You press Alt, Ctrl, or Shift plus the underlined letter to perform the 
action. For instance:

In this case, pressing Alt+E clicks the Edit button.
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The exact keystrokes for a keyboard shortcut are listed in the application’s menu. For 
instance, in Microsoft Word, to find out what the shortcut is to save a document, 
choose File from the menu bar. On the drop-down menu the Save option is followed by 
its shortcut, Ctrl+S.

Common Windows shortcut keys are:

A macro can include keystrokes for multiple applications. For example, one macro 
might include keystrokes for word processing, spreadsheet, and database 
applications. 

To switch between applications when recording a macro, use the mouse to select the 
application. Do not press Alt-Tab. If you do, these keystrokes are recorded and might 
not select the correct application when you play back the macro.

NOTE:  Do not press Ctrl+Esc to click the Microsoft Windows Start 
button, or the Macro Recorder stops recording without providing a 
message showing that recording has stopped. All keystrokes recorded 
up to this point are deleted. To click Start without causing an error or 
stopping recording, use your mouse.

Shortcut Key Description

Esc Cancels an action.

Enter Clicks OK or the default button in a dialog box. (Default buttons 
have a heavier border surrounding them.)

Ctrl+A Selects all text.

Ctrl+C Copies selected text to the clipboard.

Ctrl+P Prints the document.

Ctrl+S Saves the document.

Ctrl+V Pastes text into the window at the cursor position.

Ctrl+X Cuts selected text to the clipboard.
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Allowed Macro Keystrokes

Table 8. Allowed Macro Keystrokes—Keys

Key Type Key Macro Notation

Character 0 1 2 3 4 5 6 7 8 9

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

* + ; = , - . / ` [ \ ] '

Non-Character Tab [TAB]

Backspace [BACKSPACE]

Enter/Return [ENTER]

Shift [SHIFT]

Control/Ctrl [CONTROL]

Alt [ALT]

Pause/Break [PAUSE]

Caps Lock [CAPSLOCK]

Esc [ESC]

Space/Space Bar [SPACE]

Page Up/PgUp [PAGE-UP]

Page Down/PgDn [PAGE-DOWN]

End [END]

Home [HOME]

Left Arrow [LEFT-ARROW]

Up Arrow [UP-ARROW]

Right Arrow [RIGHT-ARROW]

Down Arrow [DOWN-ARROW]

Print Scrn [PRINTSCREEN]

Insert [INSERT]

Delete [DELETE]

F1 through F24 [F1] … [F24]
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Recording Macros

Follow these steps to record a macro.

To record a macro:

1. Start any third-party applications you want to include in the new macro, and 
then minimize them.

2. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears.

3. Select the Run Macro tab, and then click New. The New Macro dialog box 
appears.

Table 9. Allowed Macro Special Commands

Special Command Description

[ENTERPRISE FIELD:] Inserts an Enterprise Data field.

[DATA FIELD:] Inserts data from Agent Desktop.

[SYSTEM FIELD:] Inserts data from Agent Desktop system fields.

[APPLICATION:=] Changes focus to an application window. The equal 
sign ( = ) is used as a separator between the 
application and the window title. If either the 
application name or window title is missing, Agent 
Desktop attempts to find the correct application and 
window to play the macro to, based on the 
parameters present.

[DELAY] Time, in milliseconds, to wait before performing the 
next macro command.

Example: [DELAY] 1000 delays the next macro key 
or command by 1 second.
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4. Enter a new macro action name, and then click OK. The Macro Editor window 
appears (Figure 52).  

5. Click Record. The Macro Editor window minimizes and the macro recorder 
starts. Anything you type from now on is entered in the new macro.

6. Maximize the third-party application and begin typing. The macro recorder 
records your keystrokes.

Figure 52. Macro Editor window with a macro script displayed
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7. If you want to insert an Agent Desktop or CAD-BE data field into the macro, 
press the Pause Macro hot key (the default is F2). The Macro Recorder 
Suspended dialog box appears (Figure 53). 

NOTE:  Do not change the window focus away from the third-party 
application to the macro recorder before pressing the Pause Macro 
hot key and inserting a data field. If you do this, you will receive an 
error message and your macro recording will be interrupted.

Figure 53. Macro Recorder Suspended dialog box
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8. Click Insert Data. The Select a Data Field dialog box appears (Figure 54). See 
“Data Fields” on page 109 for more information. 

9. Choose the desired data field from the list, enter test data if desired, and then 
click OK. The test data you enter is displayed in the application only when the 
macro is tested using the Playback function.

The Macro Recording Suspended dialog box appears.

10. Click Resume Recording to continue recording the macro.

11. Once you have finished recording the macro, press the macro hot key. The 
Macro Recording Suspended dialog box appears.

12. Click End Recording. You are returned to the Macro Editor window. 

13. You can take any of the following actions:

■ Click OK to save the macro as recorded.

If there are no errors, the macro is saved and you are returned to the 
Select Action dialog box. 

If there are errors, the macro editor displays the line and highlights the 
text in question. Correct it and click OK again. 

■ Click Playback to test the macro.

If there are errors, the macro editor displays the line and highlights the 
text in question. Correct it and click Playback again.

Figure 54. Select a Data Field dialog box
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If there are no errors, the macro is played back. If it works as you want it 
to, click OK to save it and return to the Select Action dialog box.

To change test data, choose Data > Change Test Data in the macro editor 
and enter new test data.

■ Click Cancel to cancel the macro.

The macro is canceled and the Select Action dialog box appears.

Data Fields

The Select a Data Field dialog box (Figure 54) enables you to select and insert a Agent 
Desktop data field into a macro. Access this dialog box either through the Suspend 
Macro Recording dialog box or from the Data menu in the Macro Editor window.

There are three types of data fields:

■ Standard. Data from the switch.

■ System. System data, for example the date and time. These fields are 
enclosed in square brackets [ ].

■ Enterprise. Data from the Enterprise service. These fields are marked with an 
asterisk ( * ).

NOTE:  When selecting data fields to be used in actions or rules, keep 
in mind that not every data field is available for every event. For 
example, the calling number is not available during the Startup event. 
If an unavailable field is used, <N/A> is displayed in the application 
the macro pops.

These fields can be included in the Run Macro and Launch External Application work 
flow actions. 

The available data fields are:

Table 10. Enterprise Data Fields 

Data Field Description

*Account Number The customer’s account number.

*Alerting Number The number of the ringing device.

*ANI The number of the phone that made a call.

*Application Data The ISDN user-to-user information element.

*BAAccountNumber Outbound Dialer: The customer’s account number.

*BABuddyName Outbound Dialer: The customer's first and last name 
separated by a comma.
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*BACampaign Outbound Dialer: The name of the campaign to which 
the call belongs.

*BADialedListID Outbound Dialer: Unique key identifying a specific 
customer record within the Dialing_List table located in 
the BA private database.

*BAResponse Outbound Dialer: Multi-purpose placeholder that sends 
data from Agent Desktop to the BA Dialer. This variable 
responds to the reservation call, schedule and cancel 
callbacks, and changes to the callback phone number.

*BAStatus Outbound Dialer: Two characters indicating the mode 
and direction of the BA Dialer-initiated call. The first 
character identifies the call mode:

• P: Reservation call, Preview mode

• C: Customer call

• A: Reservation call, callback

• Z: Agent-to-agent transfer or conference customer 
call

During a reservation call, the first character is P or A. 
When a customer call is transferred to an agent, the 
first character is C.

The second character of BAStatus indicates the call 
direction:

• O: Outbound

• I: Inbound

• B: Blended

Table 10. Enterprise Data Fields — Continued

Data Field Description
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*BATimeZone Outbound Dialer: Indicates the GMT offset, in minutes, 
for the customer’s time zone and obtains the 
customer’s local time. The format of this ECC variable 
is +/–#####.

This field’s first character is either a positive or 
negative sign, followed by 5 digits. For example:

• This example indicates that the customer is one 
hour behind GMT:

BATimeZone = -00060

• This example indicates that the customer is two 
hours ahead of GMT:

BATimeZone = +00120

*Call Duration The difference between the call’s end time and start 
time. The time is read from the Enterprise server’s 
clock.

*cisco.com.Category Reserved for future use.

*cisco.com.MessageKey Reserved for future use.

*cisco.com.Priority Reserved for future use.

*Collected Digits Digits entered by the caller in response to IVR 
prompting.

*DNIS The number of the phone that received a call.

*ICM Call Variable 1… 
*ICM Call Variable 10

Call-related variable data. There are 10 available 
variables.

*Last Called Number The last number dialed.

*Last Calling Number The last device that made a call.

*Last Connected 
Number

The last monitored device that joined the call.

*Last Queued Time The amount of time spent in queue the last time the 
call was queued. The time is read from the Enterprise 
server’s clock.

*Last Redirection 
Number

The last number the call was redirected from.

*Layout The name of the enterprise data layout.

Table 10. Enterprise Data Fields — Continued

Data Field Description
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Set Enterprise Data Action

This action enables you to set one enterprise data field variable that appears in the 
Agent Desktop or CAD-BE enterprise data pane to a desktop variable or static text of 
your choosing. 

The action is available only for the Ringing and Answered events. 

NOTE:  Do not include a Set Enterprise Data action in the same work 
flow as the following Call Control actions: supervised transfer, blind 
transfer, conference, or blind conference. This can cause a critical 
race condition that results in the enterprise data not being available.

*Trunk ID Device ID of the trunk.

*UCID Not applicable.

[AGENT_ID] The agent’s identification.

[CALL_DURATION] The difference between the call’s end time and start 
time. The time is read from the agent’s PC’s clock.

[CALL_END_TIME] The end time of the current call. If the call has not yet 
ended, it is the current time. The time is read from the 
agent’s PC’s clock.

[CALL_START_TIME] The start time of the current call. If there is no call, this 
data is empty. The time is read from the agent’s PC’s 
clock.

[COMPUTER_NAME] The name of the computer the agent is currently logged 
onto.

{LOCAL_PHONE_EXT] The agent’s extension.

Alerting# The number of the ringing phone.

Called# The number of the phone that received a call.

Calling# The number of the phone that made a call.

Original Called# The original number that received a call.

Original Calling# The original number that made a call.

Table 10. Enterprise Data Fields — Continued

Data Field Description
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To set up a Set Enterprise Data action:

1. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears.

2. Select the Set Enterprise Data tab, and then click New. The Set Enterprise 
Data Action Setup Editor dialog box appears (Figure 55).  

3. Complete the dialog box as follows:

4. Click OK.

Figure 55. Set Enterprise Data Action Editor dialog box

Field Description

Action Name Enter a name for the new action.

Enterprise Data 
Field to Set

Select the enterprise data field you whose content 
you want to set. You can choose from among ECC, 
call, and BA (Cisco Outbound Dialer) variables.

Select one of the following data sources:

Desktop Variable From the drop-down list, select the desktop variable 
you want to be entered automatically in the 
enterprise data field. Your choices are Agent ID, 
System Name, System Time, or Skill Group.

Static Text Enter the static text you want to be entered 
automatically in the enterprise data field. Maximum 
length of text for ECC fields is 210 characters, and for 
call variables, 39 characters. 
September 2009 113



Cisco Desktop Administrator User Guide
Timer Action

This action is available to Agent Desktop and CAD-BE agents at the Enhanced and 
Premium levels. 

The timer action enables you to trigger Agent State, HTTP, Agent Notification or Set 
Enterprise Data actions after a certain amount of time has elapsed under specified 
circumstances. 

For instance, you can configure the Timer action to change the agent’s state to Ready 
if the agent has been in the Work state for 3 minutes. 

To set up a Timer action:

1. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears.

2. Select the Timer Action tab, and then click New. The Timer Action Setup dialog 
box appears (Figure 56). 

3. Complete the Timer Action Setup dialog box as follows:

Figure 56. Timer Action Setup dialog box

Field Description

Action Name Enter a name for the new action.
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4. Click Add to select or set up the actions you want to execute when the timer 
has expired. You can choose among the following types of actions:

■ Agent Notification Action (page 85)

■ Agent State Action (page 87)

■ HTTP Action (page 89)

■ Set Enterprise Data Action (page 112)

5. When you have configured the Timer Expiration Work Flow, click OK.

Utility Action

There are three utility actions:

■ Start recording

■ Stop recording

■ Send a predefined, high-priority chat message to the agent’s supervisor

High Priority Chat Messages

A high priority chat message is a predefined message that appears in a supervisor’s 
Chat window. The message behaves just like a regular chat message that is tagged as 
high priority—it pops up on the supervisor’s screen on top of all other windows to 
attract the supervisor’s attention. 

You can configure a task button on the Agent Desktop or CAD-BE toolbar to send such 
a message from an agent to the agent’s supervisor(s). 

NOTE:  For CAD-BE agents, a high priority chat message can be sent 
but it cannot be replied to by the supervisor, because CAD-BE agents 
do not have chat capability.

To set up a utility action:

1. Set up a new action. See “Adding a New Action” on page 80. The Select Action 
window appears.

Timer Duration Set the amount of time the agent must spend in the 
selected agent state before the action executes.

Timer 
Expiration 
Work Flow 
Setup section

In this section, specify the actions that will execute when 
the time duration has expired. You can specify that the 
agent state must also be equal or not equal to either 
Ready or Not Ready.

Field Description
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2. Select the Utility Action tab, and then click New. The Utility Action Setup dialog 
box appears (Figure 57). 

3. Enter a name for the new action, select an action type from the drop-down list, 
and then click OK.

■ If you select Record as the action type, select Start or Stop from the 
Action field. 

■ If you select HighPriorityChat, type the message you want to send as the 
predefined, high-priority chat message in the Message field.

NOTE:  When the dialog box initially opens, only the Action Name and 
Action Type fields are visible. When you choose the Record action 
type, the Action field appears. When you choose the High Priority 
Message action type, the Message field appears.

NOTE:  If a Record action is part of a voice contact work flow, the 
agent being recorded will see a recording icon in the contact 
appearance pane even if notification is turned off. 

Figure 57. Utility Action Setup dialog box
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September 2009
Getting Started with Desktop 
Administrator
Introduction

Desktop Administrator enables you to configure the following CAD elements:

■ Services Configuration—enterprise data and silent monitoring and recording

■ Personnel—agents

■ Cisco Unified Presence Settings

■ Agent E-Mail Settings
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Accessing Desktop Administrator

You can access Desktop Administrator by either of two methods:

■ From the Desktop Work Flow Administrator menu bar, choose Desktop 
Administrator > Side A. If your system includes redundancy, you can also 
choose Side B.

■ In your web browser, enter Desktop Administrator’s URL:

http://<CCX-server>:6293/teamadmin/main.cda

where CCX-server is the hostname or IP address of the server that hosts Cisco 
Unified Contact Center Express.

By default, only a default username is required to log in unless a password has been 
configured. Password usage by Desktop Work Flow Administrator and Desktop 
Administrator is linked. See "Passwords" on page 17 for more information.

Only one person at a time can make changes in Desktop Administrator. Until a user 
logs out or until that user’s login times out after 15 minutes of inactivity, other users 
can only view information.

To log in to Desktop Administrator:

1. Access Desktop Administrator. The Login window appears.

2. By default, the username admin is autofilled in the Username field. 

■ If a custom password has not been configured in either Desktop 
Administrator or in Desktop Work Flow Administrator, leave the Password 
field blank.

■ If a custom password has been configured in either Desktop 
Administrator or in Desktop Work Flow Administrator, enter that custom 
password in the Password field.

3. Click Login.
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Using the Search Function

Follow these steps to search for one or more records on any Desktop Administrator 
page that contains the Search function. 

NOTE:  Searches are not case sensitive. For example, if you type a 
lowercase letter “s” in a search field, the results will include all items 
that begin with the lowercase letter “s” and the uppercase letter “S.”

To search for one or more records:

1. Enter your search criteria:

■ If you are searching for a text string, select the field name from the first 
drop-down list box, a search pattern from the second drop-down list box, 
and enter a text string in the third box.

■ If you are searching for a checked or cleared check box, select the check 
box name in the first drop-down list box, and True (checked) or False 
(cleared) in the second list box.

2. If necessary, complete any of the following actions.

■ If you want to add another criterion to the search query, click +. A new row 
appears. Repeat step 1 for the new row.

■ If you want to remove the last criterion from the search query, click —. The 
bottom row is deleted. If you click — and the search query only contains 
one criterion, no change occurs.

■ If you want to remove all of the criteria from the search query, click 
Clear Filter. All of the rows except the first row are deleted, and the first 
row is reset to the default value.

3. When you are done creating your search query, click Find. A list of results that 
match all of the criteria appears.
September 2009 121



Cisco Desktop Administrator User Guide
Configuring a Password in Desktop 
Administrator

A password is not required to access Desktop Administrator. By default it is not 
password-protected. However, you can configure a password to protect access to 
Desktop Administrator.

NOTE:  Any password you configure in Desktop Administrator is also 
the password for Desktop Work Flow Administrator. 

To change the default password:

1. In Cisco Desktop Administrator, click Change Password. The Change 
Password window appears (Figure 58). 

2. In the Old Password field, enter the default password, admin. In the New 
Password and Confirm Password fields, enter your new password, and then 
click Save.

Figure 58. Change Password window
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Services Configuration
Introduction

You can perform the following tasks in the Services Configuration node:

■ Configuring Enterprise Data (page 126)

■ Configuring Desktop and Server Monitoring and Recording (page 134)

■ Synchronizing Directory Services (page 139)
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Configuring Enterprise Data

The Enterprise Data node has two pages, the Fields page and the Layout List page.

You can perform the following tasks on the Fields page:

■ Creating a Custom Field (page 127)

■ Editing a Field (page 129)

■ Deleting a Field (page 129)

You can perform the following tasks on the Layout List page:

■ Creating a Custom Layout (page 131)

■ Copying a Layout (page 132)

■ Editing a Layout (page 133)

■ Deleting a Layout (page 133)

Enterprise data is information associated with an incoming call. It is displayed in the 
Contact Management pane of Agent Desktop and CAD-BE, and on the Caller Data 
screen in IP Phone Agent.
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Fields

Enterprise data fields and layouts are configured under the Enterprise Data node.

NOTE:  The agent applications must be restarted for any enterprise 
data variable or layout changes you make to go into effect.

The Field List displays both the predefined fields available for your switch type and the 
custom fields you create.

■ Predefined fields have index numbers of 159–255. Only the display name of 
these fields is editable, with the exception of field 252, whose display name 
and field name can be edited. Note that when you click the Select All button, 
these fields are not selected.

■ Custom fields have index numbers of 0–158, and are editable.

Creating a Custom Field

To create a custom field:

1. Choose Services Configuration > Enterprise Data > Fields. The Field List page 
page appears (Figure 59).

Figure 59. Field List page
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2. Click Add New. The Add New page appears(Figure 60).

3. Complete the fields as described below.

Figure 60. Add New page

Field Description

Field Name The variable’s field name. The field name and value can be 
up to 29 characters long and can contain any character 
except:

- ` ~ ! @ # $ % ^ & * ( ) - + = [ ] } { < > , / ? | \ \ : ; ' " and 
space

If you use disallowed characters in the field name or value, 
the enterprise data field might not display in the IP Phone 
Agent service.

Display 
Name

The name that appears in desktop applications. The 
display name can be up to 29 characters long and can 
contain any character except:

- ` ~ ! @ # $ % ^ & * ( ) - + = [ ] } { < > , / ? | \ \ : ; ' "

Expanded 
Call Context 
(ECC)

If the field is an ECC variable, select the appropriate check 
box:

• Scalar: A scalar ECC variable is one that stores a single 
piece of data.

• Array: An array ECC variable is one that stores multiple 
pieces of data.

If you selected array, choose the number of elements in 
the array from the number field drop-down list.
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4. Click Save to save your changes. The field is added.

5. When you are finished adding fields, click Return to Field list.

Editing a Field

To edit a field:

1. Choose Services Configuration > Enterprise Data > Fields. The Field List page 
appears (Figure 59).

2. If necessary, search for the field you want to edit. For instructions, see "Using 
the Search Function" on page 121.

3. Select the field by clicking its name. The Field Information page for that field 
appears.

4. Edit the field information as desired.

■ For predefined fields, you can edit only the display name.

■ For custom fields, you can edit all field information.

Note that if you are editing an array field, the field index numbers assigned to 
the array elements are listed, separated by commas.

5. When you are finished making changes, click Save, then click Return to Field 
list.

Deleting a Field

You cannot delete a predefined field. You can delete only custom fields.

If the field selected for deletion is the only field associated with a custom layout, you 
cannot delete it until another field is added to the custom layout, or the layout itself 
will be deleted. Either delete the custom layout, or add another field to it and then 
delete the field you originally intended to delete.

If the field selected for deletion is the only field associated with a default layout, you 
cannot delete it until another field is added to the default layout. Default layouts 
cannot be deleted, and must always contain at least one field.

Field Index Choose a field index number from the drop-down list. The 
field automatically shows the next available number.

If you selected Array in the ECC field, the Field Index field is 
automatically disabled. The system will assign indexes to 
each element in the array.

Field Description
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To delete a custom field:

1. Choose Services Configuration > Enterprise Data > Fields. The Field List page 
appears (Figure 59).

2. If necessary, search for the field you want to delete. For instructions, see 
"Using the Search Function" on page 121.

3. Select the check box corresponding to one or more custom fields, then click 
Delete Selected. The selected fields are no longer displayed in the Field list. 
However, the actual deletion is not performed until you click Save.
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Layouts

The Layout List displays the field layouts available for use in the agent applications. 
Each layout can contain up to 16 fields chosen from the Field List.

There is one default layout, named “default.” This is the basic layout for normal 
operations. 

Unified CCX automatically uses the default layout for normal call activity. If you want to 
use a custom layout, a custom script to pop that layout must be created.

You cannot delete the default layout, but it can be edited to add or remove enterprise 
data variables.

You can create up to 14 custom layouts in addition to the default layouts. Once the 
limit of custom layouts is reached, the Add New and Copy buttons are disabled. 

Creating a Custom Layout

To create a custom layout:

1. Choose Services Configuration > Enterprise Data > Layouts. The Layout List 
page appears (Figure 61).

Figure 61. Layout List page
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2. Click Add New. The Add New page appears (Figure 60).

3. Complete the fields as described below.

4. Use the arrow buttons to move selected fields between the Available and 
Selected panes. Use the double arrow buttons to move all fields from one 
pane to the other. Use the Up and Down buttons to change the order of the 
fields in the Selected pane.

5. Click Save to save the custom layout. The layout is added to the Layouts list 
page. 

6. When you are finished adding custom layouts, click Return to Layout list.

Copying a Layout

1. Choose Services Configuration > Enterprise Data > Layouts. The Layout List 
page appears (Figure 61).

Figure 62. Add New page

Field Description

Layout Name The layout name must be unique and be no longer than 16 
characters.

Available The fields available to be used in the layout. The list shows 
the field’s index number and display name.

Selected The fields that have been selected to be in the layout. The 
list shows the field’s index number and display name.
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2. Select the layout you want to copy. The selected layout list page appears.

3. Click Copy.

4. Enter a name for the new layout and edit the fields as needed.

5. Click Save to save the copied layout. The layout is added to the Layouts list 
page. 

6. If desired, repeat steps 4 and 5 to create more new layouts. 

7. When you are finished, click Return to Layout list.

Editing a Layout

1. Choose Services Configuration > Enterprise Data > Layouts. The Layout List 
page appears (Figure 61).

2. Select the layout you want to edit. The selected layout list page appears.

3. Edit the layout as needed.

4. Click Save to save the edited layout.

5. When you are finished, click Return to Layout list.

Deleting a Layout

You cannot delete a default layout. You can delete only custom layouts.

To delete a custom layout:

1. Choose Services Configuration > Enterprise Data > Layouts. The Layout List 
page appears (Figure 61).

2. Select the check box corresponding to one or more custom layouts, then click 
Delete Selected. The selected layouts are no longer displayed in the Layout 
list. However, the actual deletion is not performed until you click Save.
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Configuring Desktop and Server Monitoring 
and Recording

You can perform the following tasks on the VoIP Monitoring Device page of the Silent 
Monitoring & Recording node:

■ Enabling Desktop Monitoring (page 134)

■ Configuring a Default Monitor Service (page 135)

■ Assigning Phone Devices to a Specific VoIP Monitor Service (page 136)

■ Removing a VoIP Monitor or Recording & Playback Service from Directory 
Services (page 136)

The VoIP Monitoring Device page displays all phone devices configured in Unified CM. 

If a phone is configured for extension mobility and a static extension is set up, the 
Extension field displays the static extension assigned to the device’s MAC address. If 
no static extension is set up, the Extension field is blank.

NOTE:  Assign a static extension to an extension mobility device to 
make administration easier.

Enabling Desktop Monitoring

When desktop monitoring is enabled, software on the agent desktop handles 
recording and monitoring requests for that agent. This is possible only on desktops 
that are physically connected to the network through a hard IP phone or through a soft 
phone. 

By default, desktop monitoring is enabled for all phone devices.

NOTE:  Desktop monitoring does not function with some NIC cards 
that are unable to detect both voice packets and data packets in a 
multiple VLAN environment. For more information on this issue, and 
suggested work-arounds, see the Cisco CAD Installation Guide.

A phone is monitored either through desktop monitoring or a VoIP Monitor service—it 
cannot be monitored by both. However, a VoIP Monitor service can be a backup if the 
agent’s desktop monitoring module fails to register with Directory Services when 
Agent Desktop is started.
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To enable desktop monitoring:

1. Choose Services Configuration > Silent Monitoring & Recording > VoIP 
Monitoring Device. The VoIP Monitoring Device page appears (Figure 63). 

2. If necessary, search for the phone device for which you want to enable 
desktop monitoring. For instructions, see "Using the Search Function" on 
page 121.

3. Select the Enable Desktop Monitoring check box for the phone device and 
click Save. Desktop monitoring is enabled for that device.

Configuring a Default Monitor Service

Select a default monitor service to avoid the possibility of having devices unassigned 
to any monitor service. This situation can arise when there is more than one VoIP 
Monitor service in the system.

NOTE:  If your system has only one VoIP Monitor service, it is not 
necessary to set a default monitor service or to manually assign each 
device to that single monitor service. The VoIP Monitor service 
assumes that each device is assigned to it as the only available 
monitor service.

Modifications you make on the VoIP Monitoring Device page go into effect 
immediately after you save your changes.

Figure 63. VoIP Monitoring Device page
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To configure a default VoIP Monitor service:

1. Choose Services Configuration > Silent Monitoring & Recording > VoIP 
Monitoring Device. The VoIP Monitoring Device page appears (Figure 63).

2. From the Default VoIP Monitor Service drop-down list, select the VoIP Monitor 
service you want to be the default service.

3. Click Save.

Assigning Phone Devices to a Specific VoIP Monitor 
Service

To assign a phone device to a specific VoIP Monitor service:

1. Choose Services Configuration > Silent Monitoring & Recording > VoIP 
Monitoring Device. The VoIP Monitoring Device page appears (Figure 63).

2. If necessary, search for the phone device you want to assign to a VoIP Monitor 
server. For instructions, see "Using the Search Function" on page 121.

3. Select the Selected check box for the device, then select the desired VoIP 
Monitor service from the Monitor Service drop-down list. 

■ To assign multiple devices, select the Selected check boxes for each 
device, then select the desired VoIP Monitor service from the drop-down 
list field above the list of devices, and then click Modify. 

4. Click Save. The device or devices are now assigned to the specific VoIP 
Monitor service.

Removing a VoIP Monitor or Recording & Playback 
Service from Directory Services

The Remove VoIP/Recording/Playback Services page enables you to remove a VoIP 
Monitor service or Recording & Playback service from Directory Services and 
unregister it from the LRM service.

Remove these services only if you intend to uninstall (or already have uninstalled) the 
VoIP Monitor service or Recording & Playback service permanently. The Remove 
option enables you to clean up Directory Services.
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To remove a VoIP Monitor or Recording & Playback service from Directory Services:

1. Choose Services Configuration > Silent Monitoring & Recording > Remove 
VoIP/Recording & Playback Services. The Remove VoIP/Recording & 
Playback Services page appears (Figure 64).  

2. From the appropriate drop-down list, select the service to be removed, and 
then click Remove. The service is removed from Directory Services.

When you remove a VoIP Monitor service from Directory Services, it also removes that 
service from the list of available VoIP Monitor services on the VoIP Monitoring Device 
page as well (Figure 63). This can result in devices becoming unmonitored. 

If the selected VoIP Monitor service has been set as the default service, you are 
notified that this situation exists when you click Remove. When you click OK to 
confirm that you want to remove the default VoIP Monitor service, any device that was 
monitored by the default service will now be unmonitored. It is recommended that you 
select another VoIP Monitor service to be the default. See "Configuring a Default 
Monitor Service" on page 135 for more information.

If the VoIP Monitor service was selected to monitor specific devices, when you click 
OK the following can occur:

■ The devices will be monitored by the default VoIP Monitor service (if one is 
configured)

■ The devices will be monitored by desktop monitoring, if the Enable Desktop 
Monitoring checkbox is selected for each device

■ The devices will be unmonitored

Figure 64. Remove VoIP/Recording & Playback Services page
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If devices become unmonitored, search for them on the VoIP Monitor Devices page 
and reassign them to the default monitor, a specific monitor, or enable desktop 
monitoring.

To restore a removed service to Directory Services:

1. Start the removed service.

■ If you uninstalled the service, reinstall it. See the Cisco CAD Installation 
Guide for information on installing CAD services.

■ If you have not uninstalled the service, stop the service and then restart 
it, using the Windows Services utility in Control Panel.

2. In Desktop Administrator, click the VoIP Monitoring Device node again. The 
refreshed page shows that the service is restored to the list of available 
services.
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Synchronizing Directory Services

The Directory Services database should be synchronized with the master Unified CCX 
agent database. The databases are synced automatically whenever the master 
Unified CCX database changes. However, you can manually sync them with the 
Synchronize Directory Services command.

NOTE:  You can also synchronize Directory Services manually from 
Work Flow Administrator. See "Synchronizing Directory Services" on 
page 29 for more information.

To synchronize the databases manually:

1. Choose Services Configuration > Synchronize Directory Services. The 
Synchronize Directory Services page appears (Figure 65).

2. Click Synchronize. The databases are synchronized, and you will see the 
message, “Transaction successful”when the process is complete.

Figure 65. Synchronize Directory Services page
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Personnel Configuration
Introduction

Personnel displays a list of agents configured in Unified CCX. This node enables you to 
view information about agents and assign agent to work flow groups.
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Configuring Agents

You can perform the following tasks from the Agents page of the Personnel node:

■ Changing an Agent’s Work Flow Group (page 142)

Changing an Agent’s Work Flow Group

1. Choose Personnel > Agents. The Agents List page appears (Figure 66). 

2. If necessary, search for the agent you want to assign to a work flow group. For 
instructions, see "Using the Search Function" on page 121.

3. Select the Selected check box for the agent, then select the desired work flow 
group from the Work Flow Group drop-down list field. 

■ To assign multiple agents to a work flow group, select the Selected check 
boxes for each agent, then select the desired work flow group from the 
drop-down list field above the list of agents, and then click Modify. 

4. Click Save. The agent or agents are now assigned to the specific work flow 
group.

NOTE:  If a recently-added work flow group does not appear in the 
drop-down list, or a recently-deleted work flow group does appear in 
the drop-down list, refresh the page by clicking the 
Personnel > Agents link again.

Figure 66. Agents List page
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Configuring Agent E-Mail
Introduction

Agent E-Mail can be configured only if you have the Premium package. The Agent 
E-Mail Settings node is not displayed if you have the Standard or Enhanced package.

Prerequisites

Before the Agent E-Mail feature can function, there are settings that must be 
configured in Microsoft Exchange and Cisco Unified CCX Application Administration. 

■ Microsoft Exchange: Set up the Agent E-Mail user account, distribution lists, 
and mailboxes

■ Unified CCX Application Administration: Set up CSQs and skills

See “Configuring Agent E-Mail” in the Cisco CAD Installation Guide for information on 
setting up these prerequisites, and for information on how the Agent E-Mail feature 
manages customer e-mails and agent replies to those e-mails.

Overview

Configuring Agent E-Mail in Desktop Administrator consists of the following tasks.

■ Configuring Global Settings (page 145)

■ Configuring Contact Service Queue Settings (page 148)

■ Configuring Templates (page 150)

Customers can send e-mail to e-mail addresses assigned to specific customer service 
queues. The CSQs funnel the customer e-mails to agents who service those CSQs. 

Agents put themselves in the E-Mail Ready state to receive customer e-mail. Going 
into the E-Mail Ready state signals Agent Desktop to deliver the configured number of 
customer e-mails to the agent’s desktop. Depending on how it is configured, an agent 
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can work on up to 5 customer e-mails at a time. The agent can also take the following 
actions:

■ Re-queue the e-mail if the agent wants it to be handled by another agent in 
the same CSQ.

■ Transfer the e-mail to a different, more appropriate CSQ.

■ Save the e-mail as a draft so it can be worked on at a later time.

■ Delete the e-mail, which actually transfers the e-mail to a specific e-mail 
address where supervisors can evaluate it for true deletion or for re-queueing 
if it needs to be handled.

■ Send their response to the customer. Their response can include boilerplate 
text inserted from templates and attached files of any format.

The system can be configured to send an automated response to every customer 
e-mail, retention periods for keeping e-mail in the e-mail store, and other settings.
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Configuring Global Settings

You can configure the following settings on the Global Settings page of the Agent 
E-Mail Settings node:

■ IMAP server information

■ SMTP server information

■ Other global settings

To configure global e-mail settings:

1. Choose Agent E-Mail Settings > Global Settings. The Global Settings page 
appears (Figure 67).  

2. Complete the fields as described below.

Figure 67. Global Settings page

Field Description

IMAP Server

Host/IP 
Address

The hostname or IP address of the Internet Message 
Access Protocol (IMAP) server.
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Port The port used to access the IMAP server.

User Name User name required to gain access to the IMAP server. 

NOTE: If the account you are using to log in to IMAP is an 
NT domain account, the login must be specified as 
NTDOMAIN/NTACCOUNT/ALIAS. For example, if your e-mail 
address is Jane.Doe@mydomain.com and your Windows 
NT login name is jdoe, then your NT domain name is 
mydomain and your Microsoft Exchange mailbox name is 
Jane.Doe. You would use the username 
mydomain/jdoe/Jane.Doe when logging in to the IMAP 
server.

Password Password required to gain access to the IMAP server.

NOTE: Supported authentication mechanisms are Basic 
Authentication (plainTextLogin) and Secure Password 
Authentication (SecureLogin) with SSL encryption.

SMTP Server

Host/IP 
Address

The hostname or IP address of the Simple Mail Transfer 
Protocol (SMTP) server.

Port The port used to access the SMTP server.

User Name User name required to gain access to the SMTP server.

Password Password required to gain access to the SMTP server.

NOTE: Supported authentication mechanisms are Open 
Relay and Basic Authentication over non-encrypted 
connections. SSL/TLS (Secure Socket Layer/Transport 
Layer Security) is not supported.

Other Settings

Maximum 
Number of 
E-Mails on 
Agent 
Desktop

The maximum number of e-mails an agent can have on the 
desktop at any one time. Minimum is 1, maximum is 5. The 
e-mails can be in draft or in process.

Retention 
Period for 
E-Mails Sent 
and Handled 
(Days)

The number of days that sent and handled e-mails are 
retained in the mail store. After the time period is up, the 
sent and handled e-mails are permanently deleted from 
the mail store.

Field Description
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3. Click Save to save your changes.

Retention 
Period for 
E-Mails 
Pending 
Delete and 
System 
Status (Days)

The number of days that pending delete and system status 
e-mails are retained in the mail store. After the time period 
is up, the e-mails are permanently deleted from the mail 
store. 

Enable 
Outbound 
Attachments

Select this check box to allow agents to attach files to 
outgoing e-mails. The files can be of any format allowed by 
the mail server.

Enable 
Requeue of 
E-Mails on 
Agent Logout

Select this check box to requeue all e-mails assigned to an 
agent to the same CSQ when the agent logs out or closes 
Agent Desktop so that other agents in the Ready state can 
work on them. The agent will lose any drafts in progress at 
the time of the logout.

NOTE: In the event of a failover, even though the agent is 
automatically logged out of Agent Desktop, the agent’s 
e-mails will not be requeued if this option is enabled. The 
agent will be able to continue working on the e-mails after 
failover.

Maximum 
Outbound 
Attachment 
Size (MB)

The maximum size of a file, in MB, that agents can attach 
to an outgoing e-mail. The default value is 10 MB, and the 
maximum allowed size is 50 MB. 

NOTE: This value must not exceed the maximum outbound 
attachment size limit set in the Microsoft Exchange Server, 
if that is less than 50 MB.

Forwarding 
Address for 
delete 
E-Mails

Optional. An external e-mail address to which all 
agent-deleted e-mails are sent. An administrator or 
supervisor can then review the deleted e-mails using a 
third-part e-mail client and determine if they should be 
re-queued or permanently deleted. 

Field Description
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Configuring Contact Service Queue Settings

Use the Contact Service Queue Settings page to configure how e-mail that is sent to 
specific CSQs is handled.

Finding a CSQ

To find a specific CSQ:

1. Choose Agent E-Mail Settings > Contact Service Queue Settings. The Contact 
Service Queue List page appears (Figure 68). This page contains a list of all 
the E-Mail CSQs configure in Unified CCX.  

2. If necessary, search for the contact service queue you want to edit. For 
instructions, see "Using the Search Function" on page 121.

Configuring a CSQ

1. When you have found the contact service queue you want to configure, click 
its name. The settings page for the selected contact service queue appears.  

Figure 68. Contact Service Queue List page

Figure 69. Contact Service Queue Settings page
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2. Complete the fields as described below.

3. Click Save to save your changes. 

Field Description

Settings

Send 
Automatic 
Response

Select this check box if you want to send an automated 
response to all who send an e-mail to this CSQ. 

Note that when sending a single e-mail to multiple 
addresses that are mapped to multiple e-mail CSQs, only 
one of the CSQs will get the e-mail, and therefore only the 
single auto-response will be sent if configured for that CSQ.

Response 
Template 
URI

The Uniform Resource Indicator (URI) of the automated 
response. This field is enabled only if you select Send 
Automatic Response. URIs should follow either of these 
formats:

• http://www.myserver.com/mytemplate.txt

• file:///x:/mytemplate.txt

File URIs must be accessible from the CAD server(s) and is 
limited to a maximum of 64 characters.

Send 
responses 
using E-Mail 
address

The e-mail address from which both agent and automated 
responses are sent.

BCC all 
responses to 
E-Mail 
address

The blind carbon copy (BCC) e-mail address to which all 
agent responses to customer e-mail is sent.

NOTE: CAD will not route e-mail based on an address in the 
BCC field. The CSQ e-mail address must be in the TO field 
in order for e-mail to be routed correctly.

E-Mail addresses that map to this CSQ

The one or more e-mail addresses that map to the contact 
service queue. E-mail addresses are case sensitive. Any 
e-mail sent to these addresses is routed to agents 
assigned to the CSQ. These e-mail addresses are the 
addresses of distribution groups set up in Active Directory, 
each of which contains only one member, the e-mail 
address set up as the Agent E-Mail user in Active Directory. 
See the Cisco CAD Installation Guide for information on 
setting up the user and distribution groups.
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Configuring Templates

Templates are text files that agents can insert into their responses to customer 
e-mails. They enable agents to answer common e-mail questions and problems with 
consistent and accurate answers. You can add up to 50 templates for agents to use.

Use the Templates page on the Agent E-Mail Settings node to complete the following 
tasks.

■ Adding a Template (page 150)

■

■ Choose Agent E-Mail Settings > Templates. The Template List page appears 
(Figure 70). (page 152)

NOTE:  You must have access to the Unified CCX server in order to 
create a template URI. 

Adding a Template

To add a template:

1. Choose Agent E-Mail Settings > Templates. The Template List page appears 
(Figure 70).  

Figure 70. Template List page
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2. Click Add New. The Add New page appears (Figure 71).  

3. Complete the fields as described below.

4. Click Save to save your changes. The template is added to the Template List.

Figure 71. Add New page

Field Description

Template 
Name

The name that identifies the template. Maximum length = 
64 characters.

Description A description of the template. Maximum length = 64 
characters.

URI The Uniform Resource Indicator of the template. Maximum 
length = 64 characters. The URI must be accessible from 
all agent desktops that use the Agent E-Mail feature. The 
URI can follow these formats:

• http://www.myserver.com/mytemplate.txt 
This protocol is used for webserver files.

• file:///x:/templates/mytemplates.txt 
This protocol is used only when the network share is 
mapped to the same drive letter on all agent desktops.

• file:////fileServer/share/templates/mytemplate.txt 
This protocol is used when the network share is not 
mapped to the same drive letter on all agent desktops.

Note: URIs using the file:/// or file://// protocols are not 
validated. You must ensure that the correct path is 
entered. URI validation for the http:// protocol is 
performed. 
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Copying a Template

You can copy the information of an existing template and then customize that 
information for a new template. You might want to do this if the name, description, 
and/or URI of a new template is very similar to the name, description, and/or URI of 
an existing template.

To copy a template:

1. Choose Agent E-Mail Settings > Templates. The Template List page appears 
(Figure 70). 

2. If necessary, search for the template you want to copy. For instructions, see 
"Using the Search Function" on page 121.

3. Select the template you want to copy. The Template Information page 
appears. 

4. Click Copy. The Template Information page now shows the template name as 
“Copy of <original template name>” and the description as “Copy of <original 
template description>”. The original template’s URI is also displayed.

5. Customize the template information fields to be appropriate for the new 
template, and then click Save. The new template is now listed in the Template 
List page.

Deleting a Template

To delete a template:

1. Choose Agent E-Mail Settings > Templates. The Template List page appears. 
(Figure 70)

2. If necessary, search for the template you want to delete. For instructions, see 
"Using the Search Function" on page 121.

3. Select the check box corresponding to one or more templates, then click 
Delete Selected. The selected templates are no longer displayed in the 
Template list. However, the actual deletion is not performed until you click 
Save.
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