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Cisco Supervisor Desktop User Guide
Introduction

Cisco Supervisor Desktop for Cisco Unified Contact Center Express is a robust 
computer telephony integration solution for IP-based contact centers that is easy to 
deploy, configure, and manage. It provides supervisors with powerful tools to increase 
productivity and improve customer satisfaction. 

Supervisor Desktop’s features allow you to view real-time statistics, monitor and 
coach agents, barge-in, intercept and record active agent calls when necessary, 
enabling effective management of agent resources. 

What’s New in This Version

■ Ability to choose 16 × 16 (small) or 32 × 32 (large) icons for the toolbar.
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About This Document

Intended Audience

This document is written for contact center supervisors who use Cisco Supervisor 
Desktop on their computers.

Conventions Used

This document uses the following conventions:

Convention Use

Bold Highlights keys, buttons, and menu items you can 
select in the interface.

Code Highlights file paths and code.

Italic Highlights book titles, variables, and terms that are 
defined.

> The angle bracket indicates a menu choice. For 
example, “choose File > Open” means “click the File 
menu, and then click Open.”
2 January 2007



Supervisor Desktop Feature Levels
Supervisor Desktop Feature Levels

There are three feature levels of Cisco Supervisor Desktop: Standard, Enhanced, and 
Premium. The following chart outlines the features available at each feature level. All 
features not listed here are present in all three versions.

Feature Standard Enhanced Premium

Silent monitoring × ×

Barge-in × ×

Intercept × ×

Recording (up to 32 simultaneous 
recordings/playbacks) ×

Recording (up to 80 simultaneous 
recordings/playbacks) ×

Team performance messages (TPMs) × × ×

Skill statistics × × ×

Reports × × ×
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Cisco Supervisor Desktop User Guide 6.3
Starting Supervisor Desktop

NOTE:  In order to be able to use Supervisor Desktop’s barge-in and 
intercept functionality, you must first start and log into Agent 
Desktop.

To start Supervisor Desktop:

1. Choose Start > Programs > Cisco > Desktop > Supervisor.

The login dialog box appears (see Figure 1).

Figure 1. Supervisor Login dialog box.

2. Enter your Supervisor Desktop ID and password in the appropriate fields, 
and then click OK or press Enter.

NOTE:  You might see an error message, “A licensing error has 
occurred. Please see your administrator.” This generally appears 
when all Supervisor Desktop software licenses are in use. For this 
reason, it is important that you close Supervisor Desktop completely 
when you are done using it, rather than simply logging off. As long as 
the application is running, one license is being used.

Changing Your Password

Your password should remain confidential. If it becomes known, follow these steps to 
change it. 

To change your password:

1. From the menu bar, choose File > Change Password.

The Change Password dialog box appears (see Figure 2).
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Starting Supervisor Desktop
Figure 2. Change Supervisor Password dialog box.

2. Type your old password, a new password, and then the new password again. 

Your password can have a maximum of 32 alphanumeric characters.

3. Click OK.

Your password is changed.

Access Through a Virtual Private Network

Supervisor Desktop is able to connect to the Cisco servers through a virtual private 
network (VPN). This enables you to work remotely and still have the benefit of 
Supervisor Desktop’s full functionality. 

NOTE:  It is recommended that you use a VPN in order to provide a 
more secure connection when using Supervisor Desktop outside the 
contact center.

NOTE:  It is intended that you use IP Communicator when running 
Agent Desktop behind a VPN, not a hard IP phone.

The VPN connection must be established before starting Supervisor Desktop. If the 
VPN connection is lost during a session, you must restart Supervisor Desktop after 
the connection is reestablished.

It has been verified that Cisco VPN 3000 Concentrator and Cisco VPN Client work 
properly with Supervisor Desktop and are supported for access. VPN solutions from 
other vendors might work correctly, but since they have not been formally verified, 
they are not supported. If you want an alternative solution to be verified, please 
contact your Cisco distributor.
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Automated Updates

CAD 6.3 allows your system administrator to update all instances of Supervisor 
Desktop automatically to a newer version of CAD 6.3. 

Every time you start Supervisor Desktop, it checks to see if there is an updated 
version available, or if there was a system configuration change that requires a 
Windows registry change. If there is, it automatically runs the update process. 

NOTE:  For automated updates to function correctly, Internet Explorer 
must be configured so that it checks for newer versions of stored 
pages. In Internet Explorer, choose Tools > Internet Options and 
select the General tab. In the Temporary Internet Files section, click 
Settings and ensure that any option other than Never is selected.

NOTE:  If your system is configured with two CRS servers, and one 
server is upgraded while your instance of Supervisor Desktop is 
connected to the older CRS, and your system administrator performs 
a failover to switch all agents to the upgraded server, your instance of 
Supervisor Desktop will not automatically upgrade when you log into 
the new server. You must shut down Supervisor Desktop and start it 
again for the automatic upgrade to take place.

When an updated version of Supervisor Desktop is detected, you will see a dialog 
box notifying you that your copy of Supervisor Desktop will be updated (see Figure 3, 
left).

Click OK and then follow the instructions in the series of dialog boxes that follows. 
When the update is finished, you will see a final dialog box telling you that your update 
is complete (see Figure 3, right). When you click OK, Supervisor Desktop starts and 
you are able to log in as usual.

Figure 3. Update notification dialog box.
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Supervisor Desktop Window
Supervisor Desktop Window

The Supervisor Desktop window (see Figure 4) is divided into three areas:

■ The Team View pane, which displays the supervisor’s team of agents

■ The Data View pane, which displays agent and call information

■ The Team Performance Message pane, which enables you to broadcast team 
performance messages 

Figure 4. Supervisor Desktop window.

Accessibility

Supervisor Desktop has a number of features that aid accessibility by vision-impaired 
users. They are:

■ Follows Windows settings for screen resolution and color/contrast settings

■ Screen reader-compatible tool tips for all controls

■ Screen reader-compatible shortcut keys for navigating the application and 
toolbar (see "Interface Shortcut Keys" on page 8 and "Toolbar" on page 8)

■ Screen reader-compatible non-scrolling team performance messages (TPMs) 
(see "Sending a Team Performance Message" on page 21)

Team selection list Data View pane

Team View pane Team Performance Message pane

Toolbar

Status bar

Menu bar
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Interface Shortcut Keys

Shortcut keys are available to navigate the Supervisor Desktop interface:

Toolbar

The Supervisor Desktop toolbar consists of the following buttons. Move your mouse 
pointer over a button to view a tooltip that shows its function.

Table 1. Accessibility shortcut keys

Shortcut Description

Ctrl-H Selects and drops down the Team Selection List.

Ctrl-T Selects the Team View pane.

Ctrl-G Selects the upper left cell in the Data View pane.

Alt-M Positions the cursor in the message field in the Team 
Performance Message pane.

Alt-T Clicks the Start button in the Team Performance Message pane.

Alt-O Clicks the Stop button in the Team Performance Message pane.

Alt-R Selects the Reports menu from the menu bar.

Alt-E In the Team Reports window, selects and drops down the 
Reports selection list.

Alt-S In the Team Reports window, selects the upper left cell in the 
report display pane.

Ctrl-D In the Supervisor Record Viewer, selects the first day in the Day 
Select section.

Ctrl-F In the Supervisor Record Viewer, selects the first recording for 
the selected day. 

Table 2.  Supervisor Desktop toolbar buttons

Button Name Shortcut Description

Refresh Ctrl-F Refreshes the information in the Data 
View pane.

Logout Ctrl-L Logs the selected agent out of the ACD.

Ready Crtl-E Puts the selected agent in the Ready 
agent state.
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Supervisor Desktop Window
Changing the Toolbar Icons Size

You can change the size of the buttons on the toolbar from the default 16 × 16 pixels 
to 32 × 32 pixels. To illustrate the size difference:

Not Ready Ctrl-N Puts the selected agent in the Not Ready 
agent state.

Barge-In Ctrl-B Enables you to join an agent’s phone 
conversation (forced conference). This 
button is enabled only when a call is 
selected.

Intercept Ctrl-I Enables you to intercept a phone call 
while disconnecting the agent from the 
phone call (forced transfer). This button is 
enabled only when a call is selected.

Chat Ctrl-J Opens the Chat window.

Reports Ctrl-Q Opens the Reports window.

Start Record Ctrl-R Starts recording the selected phone call. 
This button is enabled only when a call is 
selected.

Stop Record Ctrl-S Stops recording the selected phone call. 
This button is enabled only when a call is 
selected.

Start Voice 
Monitor

Ctrl-A Starts monitoring the selected agent. This 
button is enabled only when an agent is 
selected.

Stop Voice 
Monitor

Ctrl-P Stops monitoring the selected agent. This 
button is enabled only when an agent is 
selected.

Voice 
Monitor 
Volume

none Controls the volume when monitoring a 
call.

Table 2.  Supervisor Desktop toolbar buttons — Continued

Button Name Shortcut Description

16 × 16 Intercept icon

32 × 32 Intercept icon
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To change the toolbar icon size:

1. On the menu bar, choose Prefererences.

The Prerefences window opens.

2. At the bottom of the window, select the Enable Large Toolbar Icons check 
box to enable large icons, or deselect the check box to return to the default 
small icons. 

3. Click OK.

Team Selection List

The Team Selection list displays every team you are associated with as a supervisor. 
You must select a team from the list to view any data in Supervisor Desktop.

Team View Pane

The Team View pane displays the supervisors, agents, and phone calls belonging to 
your team, which you select from the Team Selection List. Only agents who are 
currently logged in are visible.

NOTE:  If you or the agents you are monitoring disconnect from a 
VPN and then reconnect to it, Agent Desktop or Supervisor Desktop 
must be restarted in order for the agents to appear in the Team View 
pane. 

Supervisor Desktop monitors two types of agent groups: desktop agents, who use 
Agent Desktop to manage their calls, and IP phone agents, who use the IP Phone 
Agent service on their IP phone for call management. 

When you select an agent or phone call, information about your selection is displayed 
in the Data View pane. No information is available when you select the team, 
supervisors, desktop agents, or IP phone agents nodes (see Data View Pane on page 
12).

The Team View pane displays icons next to agent names and phone calls to indicate 
their agent state and call status. 

Table 3. Team View pane icons

Agent State Icons Ready

Not Ready

Work
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Supervisor Desktop Window
Talking

Reserved

Logging Out (visible only when the agent 
is in the process of logging out)

Call Status Icons Conference Call

Talking

On Hold

Audio Icons Monitoring

Recording

Table 3. Team View pane icons — Continued
January 2007 11
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Data View Pane

The Data View pane displays different information depending on what you select in 
the Team View pane:

■ If you select a particular agent, that agent’s statistics are displayed.

■ If you select a call, call information is displayed. 

NOTE:  If you select a supervisor, no information is displayed. You 
cannot monitor another supervisor.

NOTE:  If a CAD agent and an IPPA agent are on the same call with 
an unknown party, and CAD and IPPA have been localized to a 
non-English language, you may see extra parties on the call. This is 
because IPPA does not send the localized version of <Unavailable> 
for an unknown party on a call, and CAD does. IPPA will always send 
<Unavailable> in English.

Call information is real-time and always reflects the current status. Other information 
that can be displayed in the Data View pane (Agent Detail, Agent ACD State, and 
Agent Call Log) is automatically refreshed at regular intervals (see Table 5 on page 22 
for more information on refresh rates).

You can sort the columns in the Data View pane in ascending/descending order by 
clicking on the column header. A triangle at the right of the column name denotes in 
which order the data is sorted.

Agent Statistics

When you select an agent’s name from the Team View pane, the Agent Statistics 
report is displayed in the Data View pane by default. You can change the information 
displayed by selecting another report from the Reports menu. The available reports 
are:

■ Agent Statistics (default)

■ Agent ACD State Log

■ Agent Call Log

For more information on the agent statistics displayed, see "Agent Reports" on page 
28.

Call Information

When you select a call from the Team View pane, the Data View pane displays the 
following information for each call participant.
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Supervisor Desktop Window
NOTE:  Supervisor Desktop displays <N/A> if any of this information 
is not available to the system.

Team Performance Message Pane

The team performance pane allows you to send team performance messages (TPMs) 
to all agents on your team. These messages are displayed prominently in the Agent 
Desktop interface and can be scrolling or stationary. 

TPMs can be displayed for a specified length of time, or stopped on demand.

For more information on using TPMs, see "Sending a Team Performance Message" 
on page 21.

Status Bar

The status bar displays current information about Supervisor Desktop.

Figure 5. Status Bar

In the event of a service failure, the Current Status section changes from “In Service” 
to “Partial Service” or “No Service.” To learn what features are affected by the service 
outage, double-click the Current Status section of the status bar to view a popup 
window that displays which features are active or inactive.

Table 4. Call information statistics

Statistic Description

Name The call participant’s name.

Number The call participant’s phone number.

Call Status The status of the call participant.

Duration The length of time the participant has been in the call.

Skill The skill group to which the call is routed.

Current system time in 24-hour format

Current status of Supervisor Desktop features

User ID, as entered in the Login dialog box at startup

User name, from the Directory Services database
January 2007 13
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For more information on the Current Status popup window and service autorecovery, 
see "Service Autorecovery" on page 36.
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Supervisor Desktop Functions

Monitoring an Agent

The voice monitor button allows you to silently listen in on an agent’s phone 
conversations.

Voice monitoring is available whenever an agent is logged in, whether or not the 
agent is on the phone. It is not available when:

■ You are a participant in a phone call.

■ You use the Barge-In or Intercept option.

The volume slider allows you to control the volume when monitoring an agent’s phone 
conversation. The system remembers your last volume setting and uses it the next 
time you log in.

Notification

The system administrator can configure CAD so that agents are notified that a 
supervisor is monitoring their calls. If notification is on, the agent receives a popup 
message when monitoring starts and one when it stops. If notification is off, the agent 
will not know if he or she is being monitored.

To start monitoring an agent:

1. Choose an agent in the Team View pane.

2. Click the Start Voice Monitor button, or choose Intervention > Start Voice 
Monitor.

To stop monitoring an agent:

1. Click the Stop Voice Monitor button, or choose Intervention > Stop Voice 
Monitor.

Barging In on a Call

The Barge-In feature enables you to join an agent’s phone conversation. When you 
click the Barge-In button, you are automatically added to the phone call. It is a forced 
conference.

The agent sees a message that you are attempting to join the call, then sees a 
message that you have successfully joined it.

When you use the Barge-In feature, voice monitoring is disabled.
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You can’t barge in if:

■ The agent is on hold

■ The agent is on two calls

■ The agent is in a conference call

■ You are already on another call

To barge in:

1. Select an agent call in the Team View pane.

2. Click the Barge-In button or choose Intervention > Barge-In.

You are added to the call.

At any time during the conference call, you can click Intercept to disconnect 
the agent whose call is selected from the conference call and continue 
talking with the remaining parties yourself.

Intercepting a Call

The Intercept feature enables you to intercept a phone call while disconnecting the 
agent from that phone call. It is a forced transfer.

The agent sees a message that you are attempting to intercept the phone call, then 
sees a further message when the interception is successful.

When you use the Intercept feature, voice monitoring is disabled.

You can’t intercept if: 

■ The agent is on hold

■ The agent is on two calls

■ You are already on another call

To intercept a phone call:

1. Select an agent call in the Team View pane.

2. Click Intercept or choose Intervention > Intercept.

The call is transferred to you.

If you are intercepting a conference call you are on, the agent call you 
selected in the Team View pane is dropped from the conference call, and all 
other participants in the conference call remain connected.
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Recording a Call

You can use Supervisor Desktop to record, save, and play back calls handled by 
agents on your team. Multiple recordings can be in progress at the same time, 
although only one recording can be made per agent at any one time. You use the 
Supervisor Record Viewer to review recorded calls.

NOTE:  A recording license is used whenever you or an agent 
triggers the recording function, and is released when the recording is 
stopped. If all licenses are in use when you trigger a recording, the 
recording will not start.

You can use the Barge-In, Intercept, and Voice Monitor features while recording. 

NOTE:  Recordings that are in progress when either the Recording & 
Statistics service or Recording & Playback service fails will be lost.

When recording a call, keep in mind the following:

■ Although you select a specific call from the Team View pane when recording, 
you are actually recording all voice activity to and from that particular agent. It 
is not limited to the call you selected. For instance, if the agent puts the 
selected call on hold and switches to another call, the recording will record 
both calls.

■ The recording will end when the selected call terminates, or when you 
manually stop recording, whichever comes first.

■ If notification is off, agents have no way of knowing if you are recording their 
calls.

■ Agents might have Agent Desktop task buttons that allow them to start and 
stop recording calls. However, an agent cannot stop a recording that you, as 
a supervisor, started. If an agent attempts to do so, the Agent Desktop icon 
indicates the recording is stopped. However, the recording is not stopped, 
and Supervisor Desktop continues to display an icon indicating that 
recording is proceeding.

■ You can stop a recording initiated by an agent.

■ If an agent attempts to start recording a call that you are already recording, 
the agent will see a recording icon on the call, although the agent is not in 
control of the recording. 

Notification

The system administrator can configure CAD so that agents are notified that a 
supervisor is recording their calls. If notification is on, the agent receives a popup 
message when recording starts and one when it stops. If notification is off, the agent 
will not know if he or she is being recorded.
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To record a call:

1. Choose the agent call you wish to record from the Team View pane.

2. Click the Start Record button, or choose Intervention > Call/Agent Start 
Recording.

3. When you are finished, click the Stop Record button, or choose Intervention 
> Call/Agent Stop Recording.

The call is archived to the Recording service database, where it is 
automatically saved for 7 days. If you want to archive it for a longer period, 
you can do so for up to 30 days, after which it is deleted. 

You can also save recordings as.wav files for permanent archiving with the 
Play and Save feature. 

See "Supervisor Record Viewer" on page 32 for more information on playing 
and saving recordings). 

Changing Agent States

You can use Supervisor Desktop to change the agent state of an agent on your team, 
including logging the agent out.

To change an agent’s agent state:

1. From the Team View pane, select the agent whose state you want to change.

2. On the toolbar, click the appropriate agent state button.

NOTE:  If an agent state change fails, you will not see any failure 
message. You will know that an agent state change is successful if 
the icon next to the agent’s name in the Team View pane changes to 
the agent state you selected.

Using Chat

Chat allows you to send instant messages to the desktop agents on your team and to 
other supervisors. You initiate a chat session by clicking the Chat button on the 
toolbar.

NOTE:  You cannot send chat messages to IP Phone Agent (IPPA) 
agents.

Chat Features

■ You can participate in multiple concurrent chat sessions.
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■ You can send the same chat message to multiple recipients (their replies, if 
any, appear in separate chat windows, one for each person).

■ The Chat Session window’s title bar displays the name of the person with 
whom you are chatting.

■ High priority chat messages pop on your desktop so they are immediately 
noticed, while normal priority chat messages are minimized and flash on your 
Windows task bar.

■ Chat logs are available as long as the Chat Session window is open. Once 
you close the window, the log is lost.

■ Chat logs are in chronological order, with the oldest messages at the top of 
the log pane.

To initiate a chat session:

1. On the toolbar, click the Chat button.

The Chat Selection window is displayed (see Figure 6).

Figure 6. Chat Selection window

The window lists the people with whom you can chat (logged-in members of 
your team and other supervisors).

2. Check the check box next to the name of the person(s) with whom you wish 
to chat. 

A Chat Session window is displayed and a chat session is initiated with the 
selected people (see Figure 7).

If you check the Desktop Agents or Supervisors check box, the check boxes 
next to all agents or supervisors listed underneath are automatically checked. 
You can then send a message to multiple recipients.
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Figure 7. Chat Session window

3. Type your message in the text entry field. 

4. If you want your message to be noticed immediately by popping on the 
recipient’s desktop, check the High priority check box.

5. Click Send or press Enter.

Your message is sent to your chat partner and logged in the chat log pane.

Replies from recipients of a group message appear in individual chat session 
windows. They cannot reply to the group, they can reply only to you.

To terminate a chat session:

■ Click Close in the upper right-hand corner of the Chat Session window.

Predefined High-Priority Chat Messages

Agents might have a task button on their Agent Desktop toolbar that is configured to 
send a predefined high-priority chat message to their supervisor(s). This predefined 
message (for instance, “Please barge in on my call”) is set up by the system 
administrator. It behaves just like a high-priority chat message—it pops up on your 
desktop on top of all other windows for your immediate attention.

Chat log pane

Text entry field
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Sending a Team Performance Message

You can send a team performance message (TPM) to all agents on a team. 

By default, the TPM scrolls across Agent Desktop’s TPM pane. If you want to send a 
stationary TPM, you must uncheck the Scroll Team Messages check box.

A stationary TPM is more compatible with the screen readers often used by 
vision-impaired agents. If some of the recipients of your TPM are vision-impaired, you 
might want to send a stationary TPM. 

To send a TPM to all agents on a team:

1. From the team selection list, choose the team to which you want to send the 
message.

2. In the Expires at field, choose a specific time for the message to expire. 

By default, the message runs for 30 minutes.

3. Type your message in the text box. The TPM can be up to 200 characters 
long.

4. Click Start or press Enter.

The TPM is sent to the team for the length of time you chose. The text of the 
message you sent is logged in the current team performance message field. 

To cancel a TPM:

■ Click Stop.
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Reports

Supervisor Desktop allows you to view reports on both teams and on individual 
agents. 

NOTE:  If Supervisor Desktop makes a successful request for report 
data and there is no data available, the report will display <N/A> (not 
available) in that field. If Supervisor Desktop makes a request for 
report data and that request fails for some reason (a service is down, 
for example), the report field(s) will be blank.

Report Refresh Rates

Reports are either automatically refreshed at regular intervals or manually refreshed 
by the user (by clicking the Refresh button), as shown in Table 5.

The Refresh button is disabled on reports that are automatically refreshed.

Setting Report Preferences

You can configure what data is displayed in team and agent reports using the 
Preferences dialog box (see Figure 8).

The Preferences dialog box lists each report available in Supervisor Desktop as well 
as the Agent Active Call (the information displayed when an agent is on a call). Using 
this dialog box you can choose what information to display on each report and on an 
active call.

Table 5. Report Refresh Rates

Report Refresh Rate

Team Agent Statistics Report manual

Team Agent State Report 1 second

Team Skill Statistics Report 10 seconds

Agent Call Log Report manual

Agent ACD State Log Report manual

Agent Statistics Report 30 seconds
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Figure 8. Preferences dialog box

To configure report information:

1. From the menu bar, choose Preferences.

The Preferences dialog box appears.

2. Click the plus ( + ) next to the report you want to configure.

The view expands to display a list of the report’s available fields.

3. Check the fields you want to be displayed in the report, and then click OK.
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Team Reports

Team reports are accessed through the Reports button on the toolbar, or by 
choosing Reports > Team Reports on the menu bar. Either method displays the 
Team Reports window.

The reports display information that can be sorted in ascending/descending order by 
clicking on any column header. 

The available reports are:

■ Team Agent Statistics Report

■ Team Agent State Report

■ Team Skill Statistics Report

Team Agent Statistics Report

This report (see Figure 9) displays agent statistics for agents who are currently 
logged in as of midnight of the current day, sorted by agent user name. The 
information is current as of the moment the report is displayed, and can be refreshed 
as needed.

Figure 9. Team Agent Statistics Report

Table 6. Team Agent Statistics Report fields

Field Description

Agent Name The agent’s name.

Agent ID The agent’s ID.
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Team Agent State Report

This report (see Figure 10) displays the real-time ACD state of each agent on the 
supervisor’s team who is currently logged in for the current day starting at midnight, 
sorted by agent user name.

Calls Presented Number of inbound calls (ACD or non-ACD) that are 
delivered to the agent’s extension (causes the agent’s 
phone to ring). This can be verified by counting the 
number of entries whose call direction displays 
“Inbound” in the Agent Call Log for the current day.

Calls Completed Number of inbound or outbound calls (ACD or 
non-ACD) that are answered at the agent’s extension. 
This can be verified by counting the number of entries 
whose call answered column displays “Yes” in the 
Agent Call Log for the current day.

Average Talking The total time spent on calls (talk time + hold time) 
divided by the number of calls.

Maximum Talking Longest time spent on a call (talk time + hold time).

Average Ready The total time spent in the Ready state divided by the 
number of times spent in the Ready state,

Maximum Ready Longest time spent in the Ready state.

Average Not Ready The total time spent in the Not Ready state divided by 
the number of times spent in the Not Ready state.

Maximum Not Ready Longest time spent in the Not Ready state.

Average Work The total time spent in the Work state divided by the 
number of times spent in the Work state.

Maximum Work Longest time spent in the Work state.

Table 6. Team Agent Statistics Report fields — Continued

Field Description
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Figure 10. Team Agent State Report

Team Skill Statistics Report

This report (see Figure 11) displays information on the contact service queues in the 
contact center for the current day starting at midnight, sorted by contact service 
queue. The information is automatically refreshed every 10 seconds.

NOTE:  This report displays information on all agents assigned to a 
specific skill group, not just agents in the team selected in the Team 
Selection field. 

Table 7. Team Agent State Report fields

Field Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Current State The agent’s current ACD agent state.

State Duration Length of time spent in the current ACD agent state 
(increments in real time every second).

Reason Code A number followed by a string description in 
parentheses identifying why the agent has transitioned 
to the Not Ready or Logout state. Blank if there is no 
reason code.
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Figure 11. Team Skill Statistics Report

Table 8. Team Skill Statistics Report fields

Field Description

Contact Service Queue Name of the contact service queue.

Agents Logged In Number of agents currently logged into the system.

Agents in Talking Number of agents currently in the Talking state.

Agents Ready Number of agents currently in the Ready state.

Agents Not Ready Number of agents currently in the Not Ready state.

Agents in Work Number of agents currently in the Work state.

Agents Reserved Number of agents currently in the Reserved state.

Oldest in Queue Elapsed wait time of the oldest call in the queue.

Total Calls Total number of calls that have arrived, including calls 
waiting, calls connected to agents, and calls that have 
disconnected.

Handled Today Number of calls handled by the contact service queue 
for the current reporting period. A call is considered to 
be handled when an agent picks up the call.

Calls Abandoned Number of calls that were routed to the contact service 
queue but were not answered by an agent because the 
caller hung up or was disconnected.
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Agent Reports

Agent reports are viewed in the Data View pane. You access them by selecting the 
agent’s name on the tree control and then choosing a report to view from the Reports 
menu. The default report displayed when you select the agent’s name is the Agent 
Statistics report.

The reports display information that can be sorted in ascending/descending order by 
clicking on any column header. 

Available reports are:

Calls Dequeued Number of calls that were dequeued. A call is 
considered to be dequeued from a particular contact 
service queue if the call is handled by an agent in 
another contact service queue. This situation can occur 
when a call is queued for more than one contact service 
queue.

Start Time Starting date and time of the current reporting period.

End Time Ending date and time of the current reporting period.

Average Talking Average talk time for all calls handled by agents. Talk 
time is the elapsed time between the time that an agent 
connects to a call and when the call is disconnected or 
transferred, not including hold time.

Average Waiting Average wait time for calls routed to the contact service 
queue. Wait time is the elapsed time between the time a 
call entered the queue and the time the call was 
answered by an agent or was disconnected.

Longest Talking Longest talk time of any one call that agents have 
handled. Talk time is the elapsed time between the time 
that an agent connects to a call and when the call is 
disconnected or transferred, not including hold time.

Longest Waiting Longest wait time for any one call routed to the contact 
service queue. Wait time is the time that elapsed 
between the time a call entered the queue and the time 
the call was answered by an agent or was 
disconnected.

Calls Priority 1…
Calls Priority 10

Total number of Priority N calls that were routed to each 
contact service queue.

Table 8. Team Skill Statistics Report fields — Continued

Field Description
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■ Agent Call Log

■ Agent ACD State Log

■ Agent Statistics Report

Agent Call Log

The Agent Call Log displays information about the agent’s call activity for the current 
day, starting at midnight. 

Agent ACD State Log

This log displays information about the agent states the agent was in during the 
current day, starting at midnight.

NOTE:  If the Cisco Unified CC Express engine fails over, then the 
IPPA service on that server will also fail over. When this happens, the 
IPPA service does not have the time required to write a logout record 
to the Recording & Statistics database. This results in a missing 
logout record for the agent in the Agent ACD State log. In this case, 
you may see a login record that is not preceded by a logout record.

Table 9. Agent Call Log fields

Field Description

Call Start Time Time the call started. Start time is based on the time the 
Recording & Statistics service received the state data 
from the CAD agent, so that the start time reflects the 
time from the server hosting the Recording & Statistics 
service, not the time shown on the CAD PC.

Call Direction Inbound or outbound call.

Call Answered (Yes/No) Was the call answered?

Calling Party The number of the phone that made the call.

Called Party The number of the phone that received the call.

Call Duration The length of the call. For inbound calls, call duration = 
ring time + talk time + hold time. For outbound calls, call 
duration = dialtone + ringback + talk time + hold time.
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Agent Statistics Report

This report is the default view displayed the first time you select an agent from the 
tree control. It reports details of the agent’s call activity during the current day, 
starting at midnight.

Table 10. Agent ACD State Log fields

Field Description

Agent State ACD agent state. The last ACD state written to the log 
is actually the previous ACD state that the agent was in. 
In order to calculate State Duration, the current state 
cannot be written to the log until the agent transitions to 
the next ACD agent state.

Start Time The time the ACD agent state was initiated. Start time is 
based on the time the Recording & Statistics service 
received the ACD agent state data from the CAD agent, 
so that the start time reflects the time from the server 
hosting the Recording & Statistics service, not the time 
shown on the CAD PC.

State Duration Length of time the agent was in the ACD agent state.

Reason Code A number followed by a string description in 
parentheses identifying why the agent has transitioned 
to the Not Ready or Logout state. Blank if there is no 
reason code.

Table 11. Agent Statistics Report fields

Field Description

Calls Presented Number of inbound calls (ACD and non-ACD) that are 
delivered to the agent’s extension (causes the agent’s 
phone to ring). This can be verified by counting the 
number of entries whose call direction displays 
“Inbound” in the Agent Call Log for the current day.

Calls Completed Number of inbound or outbound calls (ACD or 
non-ACD) that are answered at the agent’s extension. 
This can be verified by counting the number of entries 
whose Call Answered column displays “Yes” in the 
Agent Call Log for the current day.

Average Talking The total time on call (all talk time + all hold time) divided 
by the number of calls.

Maximum Talking Length of the longest call (talk time + hold time).
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Average Ready The total time spent in the Ready state divided by the 
number of times spent in the Ready state.

Maximum Ready Longest time spent in the Ready state.

Average Not Ready The total time spent in the Not Ready state divided by 
the number of times spent in the Not Ready state.

Maximum Not Ready Longest time spent in the Not Ready state.

Average Work The total time spent in the Work state divided by the 
number of times spent in the Work state.

Maximum Work Longest time spent in the Work state.

Table 11. Agent Statistics Report fields — Continued

Field Description
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Supervisor Record Viewer

The Supervisor Record Viewer (see Figure 12) is accessed by choosing View > 
Recorded Files from the Supervisor Desktop menu bar. It displays all recordings 
made by your team over the last 7 days as well as those you tag for 30-day extended 
archiving.

NOTE:  A recording license is used whenever you open the 
Supervisor Record Viewer, and is released when you close it. If no 
licenses are available, Supervisor Record Viewer will start but no 
recordings will be listed and the error message “Licensing error” will 
be displayed. You must wait until a license is released and available 
for you to use. For this reason, it is important to close Supervisor 
Record Viewer after you are finished using it.

When you first open Supervisor Record Viewer, the current day is selected and the 
recordings for that day are displayed. However, if there are no recordings for the 
current day, the application opens with no day selected, and you must select a day to 
view.

Figure 12. Supervisor Record Viewer

The recordings are archived as raw voice data packets; they can only be reviewed 
using the Supervisor Record Viewer. However, if you wish to permanently save 
selected recordings as *.wav files, you can use the Play and Save button and save 
the recording to a selected folder.
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Unless recordings are tagged for extended archiving (“extended lifetime”), they are 
automatically deleted after 7 days. 

If a recording is tagged for the 30-day extended lifetime, it will not be deleted until 
that 30-day period expires. If you delete it manually before the 30-day period expires, 
it is deleted in the next folder cleanup—cleanups run daily at midnight.

The Supervisor Record Viewer displays the following information:

Toolbar

The Supervisor Record Viewer toolbar enables you to play and save recordings.

Table 12. Supervisor Record Viewer fields

Field Description

Agent The agent whose call is recorded.

Team The team to which the agent belongs.

Time The time the recording was made.

Duration The length of the recording in hh:mm:ss format.

Lifetime The length of time the recording is archived: Normal is 7 
days, Extended is 30 days.

Date Recorded (Appears only when “Extended Lifetime” is selected in 
Day Select) The date the recording was made.

Table 13. Supervisor Record Viewer Toolbar Buttons

Button Name Description

Play Starts playing a selected recording.

Play and 
Save

Starts playing a selected recording and 
simultaneously saves it as a *.wav file.

Pause Pauses a selected recording.

Stop Stops playing a selected recording.

Set 
Extended 
Lifetime

Tags a selected recording so that it is archived for 
30 days instead of the normal 7 days.
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Working with Recordings

To listen to a recording:

1. From the Day Select section of Supervisor Record Viewer, click the radio 
button for the date of the recording you want to review.

You can also click the Extended Lifetime radio button to view a list of all 
recordings that have been tagged for extended 30-day archiving. 

2. Select the recording you want to review.

3. Click the Play button, or choose Recording > Play from the menu bar.

Use the Pause or Stop buttons to control the recording playback, and the 
volume slider to control the playback volume.

There is a progress bar at the bottom of the window that shows where you 
are within the recording. You can click the progress bar and drag it 
backwards or forwards to rewind or fast-forward the recording. You must 
click Play again after you reposition the progress bar to restart the playback.

To tag a recording for extended archiving:

1. Select the recording you want to archive for 30 days.

2. Click the Set Extended Lifetime button, or choose File > Set Extended 
Lifetime from the menu bar.

The recording is tagged to be archived for 30 days from the date of 
recording.

To save a recording for permanent archiving:

1. Select the recording you want to save.

2. Click the Play and Save button, or choose Recording > Play and Save from 
the menu bar.

The Save As dialog box appears.

3. Select a folder to save the recording to, enter a file name for the recording, 
and then click Save.

Set Normal 
Lifetime

Tags a selected recording so that it is archived for 
the normal 7 days instead of the extended 30 days.

Delete Deletes the selected recording.

Table 13. Supervisor Record Viewer Toolbar Buttons — Continued

Button Name Description
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The recording plays and simultaneously is saved as a *.wav file to the location 
you selected.
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Service Autorecovery

The service autorecovery feature allows Supervisor Desktop to automatically recover 
its connection to the Cisco services in the event of a service restart or a network 
outage.

When Supervisor Desktop detects that it is unable to communicate with a service 
(generally within three minutes of the service failure), the status bar displays “Partial 
Service” or “No Service” to indicate that some or all of the services have failed.

When Supervisor Desktop detects that the service is again available (usually within 
one minute of service recovery), the status bar displays “In Service” to indicate that 
the services have recovered.

To learn more about what is affected by the service failure, double-click the status 
message on the status bar. Supervisor Desktop displays a popup box that lists 
features and indicates if that feature is available or not due to the service outage. The 
server that hosts the failed service is listed in the Host column. This field can display 
either the host’s IP address, host name, or both.

Figure 13. Server Status popup window

Phone Network Failure

In the event that an agent’s phone loses its connection to the network, the agent is 
automatically moved to the Not Ready agent state, and will see a popup window 
displaying a message that the phone is out of service.

The supervisor will see the change of agent state in the Agent ACD State Log report, 
along with the “Device out of service” reason code (code 32759).
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The agent must drop any call he or she is on in order for the phone to reconnect to 
the network. If the agent continues on a call, CAD will not be able to show the call’s 
actual length because it shows as “terminated” in the system.

When the phone comes back into service, the agent will see the popup window 
display a message that the phone is in service. The agent can then change the agent 
state back to Ready and resume taking calls. 
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