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Cisco Supervisor Desktop User Guide
Introduction

Cisco Supervisor Desktop for Cisco Unified Contact Center Enterprise (Unified CCE) is 
a robust computer telephony integration solution for single-site and multi-site IP-based 
contact centers that is easy to deploy, configure, and manage. It provides supervisors 
with powerful tools to increase productivity and improve customer satisfaction. 

Supervisor Desktop’s features allow you to view real time statistics, monitor and 
coach agents, barge-in, intercept, and record active agent calls when necessary, 
enabling effective management of agent resources. 

What’s New in This Version

■ Configurable support for Cisco Unified Communications Manager-based call 
silent monitoring via an IP phone instead of CAD-based (desktop or server) 
monitoring.

■ The interface has been updated to the Windows Office 2003 theme, with 
improvements to grid controls and column alignment
June 2007 7
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About This Document

Intended Audience

This document is written for contact center supervisors who use Cisco Supervisor 
Desktop on their computers.

Conventions Used

This document uses the following conventions:

Convention Use

Bold Highlights keys, buttons, and menu items you can 
select in the interface.

Code Highlights file paths and code.

Italic Highlights book titles, variables, and terms that are 
defined.

> The angle bracket indicates a menu choice. For 
example, “choose File > Open” means “click the File 
menu, and then click Open.”
8 June 2007



Supervisor Desktop Feature Levels
Supervisor Desktop Feature Levels

There are three feature levels of Cisco Supervisor Desktop: Standard, Enhanced, and 
Premium. The following chart outlines the features available at each feature level. All 
features not listed here are present in all three feature levels.

Table 1. Cisco Supervisor Desktop bundle features.

Feature Standard Enhanced Premium

Silent monitoring × × ×

Barge-in × × ×

Intercept × × ×

Recording × ×

Team messages (TMs) × × ×

Supervisor work flows—threshold 
alerts only

× ×

Supervisor work flows—all actions ×

Skill statistics × × ×

Real time displays (text) × × ×

Real time displays (charts) ×

Web page push to agents ×

Support for Cisco Mobile Agent × × ×

Integrated Browser × × ×
June 2007 9
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Starting Supervisor Desktop

NOTE:  In order to be able to use all of Supervisor Desktop’s 
functionality, you must first log into Cisco Agent Desktop.

To start Supervisor Desktop:

1. Choose Start > Programs > Cisco > Desktop > Supervisor.

The Supervisor Login dialog box appears (see Figure 1).

Figure 1. Supervisor Login dialog box

2. Enter your Supervisor Desktop login ID (maximum 12 characters) and 
password in the appropriate fields, and then click OK or press Enter.

Supervisor Desktop starts. The application will show no data and the status 
bar will display “No Service” until you select a team from the Team drop-down 
list.

NOTE:  Supervisor Desktop can be configured by the administrator so 
that you log in using your login name, not your login ID. The field name 
(Login ID or Login Name) will tell you which login method you should 
use.

NOTE:  The first time you log into Supervisor Desktop, the password is 
empty by default—all you need to enter is your Login ID. Create your 
own password by using the Change Password function. 

NOTE:  Supervisor Desktop remembers your login ID/login name the 
first time you log in. It is automatically entered the next time you log 
in. If you share a computer with another supervisor, check the Login 
ID/Login Name field to make sure it contains your information and 
not someone else’s.

NOTE:  It may take some time for Supervisor Desktop to start because 
default report data must be generated.
10 June 2007



Starting Supervisor Desktop
Changing Your Password

Your password should remain confidential. If it becomes known, follow these steps to 
change it. 

To change your password:

1. From the menu bar, choose Tools > Change Password.

The Change Password dialog box appears (see Figure 2).

Figure 2. Change Supervisor Password dialog box

2. Type your old password, a new password, and then the new password again. 

If the old password was empty (blank), leave the Old Password field empty.

Your password may have a maximum of 32 alphanumeric characters.

3. Click OK.

Your password is changed.

Access Through a Virtual Private Network

Supervisor Desktop is able to connect to the CAD servers through a virtual private 
network (VPN). This allows a supervisor to work remotely and still have the benefit of 
Supervisor Desktop’s full functionality. 

NOTE:  It is recommended that you use a VPN in order to provide a 
more secure connection when using Supervisor Desktop outside the 
contact center.

NOTE:  It is intended that you use IP Communicator when running 
Agent Desktop behind a VPN, not a hard IP phone.

The VPN connection must be established before starting Supervisor Desktop. If the 
VPN connection is lost during a sessions, you must restart Supervisor Desktop after 
the connection is reestablished.
June 2007 11
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If Supervisor Desktop can log into all services except the Chat service, it must be 
restarted after the Chat service comes back online.

It has been verified that Cisco VPN 3000 Concentrator and Cisco VPN Client work 
properly with CAD, and are supported for access. VPN solutions from other vendors 
may work correctly, but since they have not been formally verified, they are not 
supported. If you want an alternative solution to be verified, please contact your Cisco 
distributor.
12 June 2007



Automated Updates
Automated Updates

CAD enables your system administrator to update all instances of Supervisor Desktop 
automatically to a newer build of the same version of CAD. 

Every time you start Supervisor Desktop, it checks to see if there is an updated build 
available, or if there was a system configuration change that requires a Windows 
registry change. If there is, it automatically runs the update process. 

NOTE:  For automated updates to function correctly, Internet Explorer 
must be configured so that it checks for newer versions of stored 
pages. In Internet Explorer, choose Tools > Internet Options and 
select the General tab. In the Temporary Internet Files section, click 
Settings and ensure that the “Every visit to the page” option is 
selected.

NOTE:  Automated updates are disabled for Windows Vista.

When this happens, you will see a dialog box notifying you that your copy of Supervisor 
Desktop will be updated. (See Figure 3, left.)

Click OK and then follow the instructions in the series of dialog boxes that follows.

When the update is finished, you will see a final dialog box telling you that your update 
is complete. (See Figure 3, right.) After you click OK, restart Supervisor Desktop and 
log in as usual.

Figure 3. Update notification and completion dialog boxes
June 2007 13



Cisco Supervisor Desktop User Guide
The Supervisor Desktop Window

The Supervisor Desktop window is divided into 5 areas:

■ The skill group tree, showing all skill groups associated with the team you 
choose from the team selection list

■ The agent tree, showing all the agents and supervisors on the team

■ Tabular/graphical real time displays of skill group information

■ Tabular/graphical real time displays of agent and team information

■ Integrated browser, if enabled

The Supervisor Desktop interface can be extremely flexible in its configuration. Using 
the Preferences dialog box, you can add or remove real time displays in the right-hand 
portion of the window, enable all panes in the interface to act as dockable windows 
(that is, they can be resized and moved anywhere on your desktop) and enable the 
integrated browser. By default, the panes are not dockable and the browser is not 
enabled. You can also change the size of the toolbar icons from the default 16 × 16 
pixels to 32 × 32 pixels.

Which panes are displayed depends on which nodes are selected in the skill group 
and agent trees. Figure 4 shows the Supervisor Desktop window in its default 
configuration and the integrated browser enabled. 

Figure 4. Supervisor Desktop interface, with a skill group and the Agents nodes selected

Skill group 
tree

Agent tree

Tabular and 
graphical 
real time 
displays—the 
data 
displayed 
depends on 
which nodes 
in skill group 
and agent 
trees are 
selected

Team 
selection

Status bar

Integrated browser
14 June 2007



The Supervisor Desktop Window
Real time display panes are identified as containing information related to skill groups 
or agents by the text in their title bars (see Figure 5).

Figure 5. Identifying real time displays 

When Supervisor Desktop is in default layout (movable windows are disabled), Skill 
Groups real time displays occupy approximately the top half of the right pane, and the 
Agents real time displays occupy approximately the lower half of the right pane. These 
displays can be resized by dragging the horizontal splitters up and down. 

Each type of display will dock to another display of its own type. For example, you 
cannot separate one Agents display from another, although they can be resized in 
relationship to each another (see Figure 6). In contrast, a Skill Groups display will not 
dock to an Agents display.

Figure 6. Examples of docked and resized displays

Displays containing Skill 
Groups information and 
Agents information

These displays are in 
“movable windows” mode: 
able to be resized and moved 
anywhere on the desktop

Default layout. The Skill 
Groups and Agents displays 
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there is no blank space 
between the types of displays.

Customized layout. The Skill 
Groups and Agents displays 
have been resized by dragging 
the horizontal splitters up and 
down. Note the blank space 
between the types of displays 
because Agents displays will 
not dock to Skill Groups 
displays. 
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Skill Groups
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You can also drag the vertical splitter between the trees panes and the display panes 
left or right, and the horizontal splitter between the two trees panes up and down. 

If you choose to enable movable windows (see "Setting Preferences"), Skill Groups 
displays dock to Skill Groups displays and Agents displays dock to Agents displays, but 
they are all free to be resized and moved anywhere on your desktop. 

If you choose to enable the integrated browser, the real time displays and the browser 
appear on tabs in the right pane. 

Setting Preferences

The Preferences dialog box controls what information is displayed in the real time 
display panes and how those panes behave. Table 2 summarizes what you can 
configure using Preferences. 

To set your interface preferences:

1. Choose View > Preferences.

The Preferences dialog box is displayed (see Figure 7).

Table 2. Configurable Elements of the Supervisor Desktop Interface

Tree Control 
Node

Available Real Time 
Displays

Configure 
Columns?

Configure 
Graphs?

Configure 
Refresh? 

Skill Groups Team Skill Statistics Yes Yes Yes

Skill Skill Summary Statistics Yes No Yes

Skill Agent Statistics Yes Yes No

Team Team Agent Statistics Yes Yes Yes

Team Agent State Yes Yes No

Agent Agent vs. Team Statistics Yes Yes Yes

Logs Agent Call Log Yes No No

Agent ACD State Log Yes No No

Calls Agent Active Call Yes No No

Enterprise Data Yes No No

Call History Yes No No
16 June 2007



The Supervisor Desktop Window
Figure 7. Preferences dialog box.

2. From the left pane, select the node whose real time displays you want to 
configure.

The displays for that node are listed in the right pane. 

3. Configure the display as follows. If the element of the display is disabled, it 
cannot be configured.

a. Columns—select Columns, and then click the ellipsis (…) to display the 
Configure Columns dialog box. Select the columns you wish to appear in 
the display, and use the up and down arrows to set the order in which they 
appear. If a column name is disabled (appears grayed out), you cannot 
move it. Click OK when you are done.

b. Graphical Displays—select Graphical displays, and then click the ellipsis 
(…) to display the Select Charts dialog box. Select the chart you wish to 
appear, and then click OK. You can select one chart only for each real 
time display. 

c. Refresh rate—select Refresh rate in seconds and adjust the rate.

4. If you want to be able to move and rearrange the panes that make up the 
Supervisor Desktop window, select the Enable movable windows check box.

5. If you want the toolbar icons to be 32 × 32 pixels instead of the default 
16 × 16 pixels, select the Enable large toolbar icons check box.

6. If you want to enable the integrated browser, select the Enable Integrated 
Browser check box. 
June 2007 17
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If you want to configure a browser home page, select the Browser node in the 
left pane and enter the URL of the web page you want to appear by default in 
the browser in the URL field in the right pane.

7. Click Apply to save your configuration. 

Agent Tree

The Agent tree displays all agents and supervisors on the selected team who are 
currently logged in. The icon next to the agent’s name indicates which agent state the 
agent is in. 

NOTE:  CAD-BE agents may close CAD-BE without logging out. If this is 
the case, they will continue to appear in the Agent tree for 
approximately 20 minutes. After 20 minutes they are logged out 
automatically by the system if they were in a non-Talking agent state 
when they closed CAD-BE. If they were in the Talking state, they will 
not be logged out but will continue to appear in the Agent tree.

Formatting Agent Names in the Agent Tree

The Preferences dialog box also enables you to control how agent names are 
displayed in the Agent tree. 

An agent can be identified by one or all of the following:

■ Name

■ Extension

■ Application used by the agent (CAD, CAD-BE, or IPPA)

■ Type of agent (mobile)

At least one of these must be selected to identify an agent in the Agent tree. 

If all options are selected, the information in the Agent tree appears as follows:

Jane Smith x1500 CAD-BE 
John Doe x1000 CAD 6125551234 (Mobile)

In this example: 

■ Jane Smith is a CAD-BE agent. The number displayed is her extension. 

■ John Doe is a mobile agent. The number displayed as the extension is the CTI 
port the agent is connected to when logging in, and the 10-digit phone 
number is the number of the phone device the agent is using to handle calls. 
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The Supervisor Desktop Window
To format agent names in the Agent tree:

1. Choose View > Preferences, and then select the Agents node.

2. In the Format node text grid, check the elements you want to use to identify 
an agent. You must select at least one element. A sample of what the name 
will look like appears on the Sample line.

3. Click OK.

Restoring the Interface Default Layout

You can restore your Supervisor Desktop layout to its default configuration by 
accessing the Preferences dialog box (View > Preferences) and clicking the Restore 
default layout button. 

This button does the following:

■ Resets the arrangement of real time display panes to the default 
arrangement

■ Disables the integrated browser

■ Deselects any graphical real time displays you had selected

It does not reset the columns displayed in each pane to the original selection. You 
must use the Preferences dialog box (see "Setting Preferences" on page 16) to 
manually reset these elements to their original configuration.

Accessibility

Supervisor Desktop has a number of features which aid accessibility by 
vision-impaired users. They are:

■ Follows Windows settings for screen resolution, color/contrast settings, and 
font sizes

■ Choice of small (16 × 16 pixels) or large (32 × 32 pixels) toolbar icons (see 
"Setting Preferences" on page 16)

■ Screen reader-compatible shortcut keys and tooltips
June 2007 19
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Interface Shortcut Keys

Shortcut keys are available to navigate the Supervisor Desktop interface. The shortcut 
keys are:

Once you have set focus to the skill group tree, the agent tree, or the team node in the 
agent tree, you can use the tab key to navigate to the real time display panes. Once 
your focus is in a real time display pane, you can use the arrow keys to navigate 
around the display grid.

NOTE:  The tab key will move you among the real time display panes, 
but the order in which you access them will not necessarily be in sync 
with the physical arrangement of the display panes on your desktop.

Toolbar

The Supervisor Desktop toolbar consists of the following buttons. Move your mouse 
pointer over a button on the toolbar to view a tooltip that shows its function.

Table 3. Accessibility shortcut keys

Shortcut Keys Description

Ctrl-Shift-S Selects the Skill Groups node in the Skill Groups tree.

Ctrl-Shift-A Selects the Agents node in the Agents tree.

Ctrl-Shift-T Selects the Team node in the Agents tree.

Ctrl-H Selects and drops down the Team Selection List.

Table 4.  Supervisor Desktop toolbar buttons 

Button Name Shortcut Key Description

Refresh Ctrl-F Refreshes the information in the 
active data view pane.

Logout Ctrl-L Logs the selected agent out of the 
ACD.

Ready Crtl-E Puts the selected agent in the Ready 
agent state.

Not Ready Ctrl-N Puts the selected agent in the Not 
Ready agent state.

Work Ready Ctrl-D Puts the selected agent in the Work 
Ready agent state.
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Status Bar

The status bar displays current information about Supervisor Desktop.

Figure 8. Status Bar
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Intercept Ctrl-I Enables you to intercept the selected 
agent’s phone call while 
disconnecting the agent from the 
phone call.

Chat Ctrl-J Opens the Chat window.

Team 
Message

Ctrl-X Opens the Team Message dialog box.

Start Record Ctrl-R Starts recording the selected phone 
call.

Stop Record Ctrl-S Stops recording the selected phone 
call.

Start Voice 
Monitor

Ctrl-A Starts monitoring the selected agent.

Stop Voice 
Monitor

Ctrl-P Stops monitoring the selected agent.

Voice Monitor 
Volume

none Controls the volume when monitoring 
a call.

Table 4.  Supervisor Desktop toolbar buttons — Continued

Button Name Shortcut Key Description

Current system time in 24-hour format

Current status of Supervisor Desktop features

User ID or name, as entered in the Login dialog box

User name
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In the event of a service failure, the Current Status section changes from “In Service” 
to “Partial Service” or “No Service.” To learn what features are affected by the service 
outage, double-click the Current Status section of the status bar to view a popup 
window that displays which features are active or inactive.

For more information on the Current Status popup window and service auto-recovery, 
see "Service Auto-recovery" on page 68.
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Real Time Displays

The real time displays contain the information you need to manage your teams and 
agents. 

There are two types of displays: tabular and graphical.

■ Tabular displays present skill group, team, and agent information in a grid. 

■ Graphical displays present that same information as bar charts, except for the 
Agent vs. Team Statistics, which is presented as two pie charts.

NOTE:  Graphical displays are available at the Premium feature level 
only.

Tabular information can be sorted in ascending/descending order by clicking any 
column header in the grid. You can sort by one column only.

Team Skill Statistics

The Team Skill Statistics real time display is available when you select the Skill Groups 
node in the Skill Groups tree (see Figure 9). 

Figure 9. Team Skill Statistics real time display.

This display presents the details of each individual skill group, regardless of whether 
or not an agent with that skill is logged in. By default, the data displayed is sorted in 
ascending order by skill name. 

The data is obtained from the CTI server unless otherwise noted, and is for the current 
day starting at midnight. The data refresh rate is configurable. By default it is every 
15 seconds. The minimum rate is 5 seconds, and the maximum rate is 60 seconds.
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Graphical displays of this information consist of bar charts with the skill name on the Y 
axis and any of the available statistics listed in the table below on the X axis, 
expressed in either an integer (0, 1, 2…) or time duration (hh:mm:ss).

Skill Summary Statistics

The Skill Summary Statistics real time display is available when you select a specific 
skill from the Skill Groups tree (see Figure 10). 

Figure 10. Skill Summary Statistics real time display.

This display presents a summary of a specific skill group’s statistics. These statistics 
are from the entire contact center, not just from members of the selected team.

Table 5. Team Skill Statistics real time display data 

Column Name Description

Skill Name The skill group identifier, as set up in Cisco Unified CCE. 
This column is required and cannot be disabled.

Agents The number of agents logged in.

Calls Waiting The number of calls currently in queue waiting for an 
agent.

Current Oldest The time of the oldest call in queue.

ASA Average speed of answer. The average amount of time a 
caller waits in queue for an agent, calculated by dividing 
the skill group wait time by the number of calls 
answered by the skill group. The data for this statistic 
comes from the AW HDS database, not from the CTI 
server. 

Calls Handled The number of calls presented, answered, and 
completed by agents.

Talk Average The average amount of time agents in the skill group 
spend in the Talking state.
24 June 2007



Real Time Displays
The data is obtained from the CTI server unless otherwise noted, and are for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 
60 seconds.

There is no graphical display available for these statistics.

Skill Agent Statistics

The Skill Agent Statistics real time display is available when you select a specific skill 
from the Skill Groups tree (see Figure 11). 

Figure 11. Skill Agent Statistics real time display.

Table 6. Skill Summary Statistics real time display data 

Column Name Description

Skill Name The skill group identifier, as set up in Cisco Unified CCE. 
This column is required and cannot be disabled.

Agents The number of agents assigned to the skill group who 
are logged in.

Calls Waiting The number of calls currently in queue waiting for an 
agent.

Current Oldest The time of the oldest call in queue.

ASA Average speed of answer. The average amount of time a 
caller waits in queue for an agent, calculated by dividing 
the skill group wait time by the number of calls 
answered by the skill group. The data for this statistic 
comes from the AW HDS database, not from the CTI 
server. 

Calls Handled The number of calls presented, answered, and 
completed by agents.

Talk Average The average amount of time agents in the skill group 
spend in the Talking state.
June 2007 25



Cisco Supervisor Desktop User Guide
This display presents information about each agent logged into the ACD and assigned 
to the selected skill group. By default, the data displayed is sorted in ascending order 
by agent name.

The data is obtained from the CAD Chat service, and are for the current day starting at 
midnight. The data refresh rate is 1 second, and is not configurable.

The graphical display of this information consists of a bar chart with the ACD states on 
the Y axis and the number of agents on the X axis. 

Team Agent Statistics

The Team Agent Statistics real time display is available when you select the Team 
node or Agents node in the Agents tree (see Figure 12).

Figure 12. Team Agent Statistics real time display.

This display presents the real time state of the agents on the selected team who are 
currently logged into the ACD. By default, the data displayed is sorted in ascending 
order by agent name.

Table 7. Skill Agent Statistics real time display data 

Column Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Current State The agent’s current ACD state.

Skill Group The skill group ID of the ACD call the agent is currently 
servicing (in Talking state). If there is no call, or if the call 
is a non-ACD call, this field is blank.

State Duration The amount of time, in seconds, that the agent has been 
in the current ACD state.

Reason Code The reason why the agent is in the current ACD state. 
Reason codes are available for the Not Ready and 
Logout states only. 
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The data is obtained from the CAD Recording & Statistics service, and is for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 
30 seconds.

Graphical displays of the information consist of bar charts with agent names on the 
Y axis and the average amount of time (hh:mm:ss) the agent spent in a selected ACD 
state.

Table 8. Team Agent Statistics real time display data 

Column Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Logon Time The total amount of time the agent has been logged into 
the ACD today.

Calls Presented The number of inbound calls (ACD and non-ACD) 
presented to the agent today.

Calls Handled The number of inbound calls (ACD and non-ACD) 
presented to and answered by the agent today.

Max Talking The longest talk time of all calls handled today.

Avg Talking The average talk time and hold time of all calls handled 
today.

Total Talking The total talk time and hold time of all calls handled 
today.

Max Ready The longest time the agent spent in the Ready state 
today.

Avg Ready The average time the agent spent in the Ready state 
today.

Total Ready The total time the agent spent in the Ready state today.

Max Not Ready The longest time the agent spent in the Not Ready state 
today.

Avg Not Ready The average time the agent spent in the Not Ready state 
today.

Total Not Ready The total time the agent spent in the Not Ready state 
today.

Max After Call Work The longest time the agent spent in the Work Ready or 
Work Not Ready state today.
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Team Agent State

The Team Agent State real time display is available when you select the Team node or 
Agents node in the Agents tree (see Figure 13). 

Figure 13. Team Agent State real time display.

This display presents the performance details for each agent on the team. By default, 
the data displayed is sorted in ascending order by agent name.

The data is obtained from the CAD Chat service, and is for the current day starting at 
midnight. The data refresh rate is 1 second, and is not configurable.

The graphical display of the information consists of a bar chart with ACD states on the 
Y axis and the number of agents currently in each ACD state. 

Avg After Call Work The average time the agent spent in the Work Ready and 
Work Not Ready state today.

Total After Call Work The total time the agent spent in the Work Ready and 
Work Not Ready state today.

Other Time The total time the agent spent in states other than 
Talking, Ready, Not Ready, Work Ready, or Work Not 
Ready today.

Table 8. Team Agent Statistics real time display data — Continued

Column Name Description

Table 9. Team Agent State real time display data 

Column Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Current State The agent’s current ACD state.

Skill Group The skill group ID of the call the agent is currently 
servicing (in Talking state). If there is no call, or if the call 
is a non-ACD call, this field is blank.
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Agent vs. Team Statistics

The Agent vs. Team Statistics real time display is available when you select a specific 
agent in the Agents tree (see Figure 14). 

Figure 14. Agent vs. Team Statistics real time display.

This display presents the performance details for the agent and compares them to the 
performance details of the team. 

The data is obtained from the CAD Recording & Statistics service, and is for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 
30 seconds.

The graphical display (entitled the “Agent vs. Team Percent Time in State display”) is 
presented as two pie charts. These pie charts show the percentage of time a specific 
agent spends in various ACD states in comparison to the percentages spent by the 
team as a whole. The ACD states compared are:

■ Ready

■ Not Ready

■ Talking

■ After Call Work (Work Ready and Work Not Ready)

■ Other (all other ACD states not listed here)

Skill Name The skill group identifier, as set up in Cisco Unified CCE. 

State Duration The amount of time, in seconds, that the agent has been 
in the current ACD state.

Reason Code The reason why the agent is in the current ACD state. 
Reason codes are available for the Not Ready and 
Logout states only. 

Table 9. Team Agent State real time display data — Continued

Column Name Description
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Table 10. Agent vs. Team Statistics real time display data 

Column Name Description

ID Identifies the statistics as for the selected agent or the 
team.

Logon Time The amount of time the agent and team have been 
logged into Agent Desktop.

Calls Presented Agent: The number of inbound calls (ACD and non-ACD) 
presented to the agent today.

Team: The total number of inbound calls (ACD and 
non-ACD) presented to all members of the team today.

Calls Handled Agent: The number of inbound calls (ACD and non-ACD) 
presented to and answered by the agent today.

Team: The number of inbound calls (ACD and non-ACD) 
presented to and answered by all members of the team 
today.

Max Talking Agent: The longest talk time of all calls handled today.

Team: The longest talk time of all calls handled by any 
member of the team today.

Avg Talking Agent: The average talk time and hold time of all calls 
handled today.

Team: The average talk time and hold time of all calls 
handled by all members of the team today.

Total Talking Agent: The total talk time and hold time of all calls 
handled today.

Team: The total talk time and hold time of all calls 
handled by all members of the team today.

Max Ready Agent: The longest time the agent spent in the Ready 
state today.

Team: The longest time any member of the team spent 
in the Ready state today.

Avg Ready Agent: The average time the agent spent in the Ready 
state today.

Team: The average time all members of the team spent 
in the Ready state today.
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Total Ready Agent: The total time the agent spent in the Ready state 
today.

Team: The total time all members of the team spent in 
the Ready state today.

Max Not Ready Agent: The longest time the agent spent in the Not 
Ready state today.

Team: The longest time any member of the team spent 
in the Not Ready state today

Avg Not Ready Agent: The average time the agent spent in the Not 
Ready state today.

Team: The average time all members of the team spent 
in the Not Ready state today.

Total Not Ready Agent: The total time the agent spent in the Not Ready 
state today.

Team: The total time all members of the team spent in 
the Not Ready state today.

Max After Call Work Agent: The longest time the agent spent in the Work 
Ready or Work Not Ready state today.

Team: The longest time any member of the team spent 
in the Work Ready or Work Not Ready state today.

Avg After Call Work Agent: The average time the agent spent in the Work 
Ready and Work Not Ready states today.

Team: The average time all members of the team spent 
in the Work Ready and Work Not Ready states today.

Total After Call Work Agent: The total time the agent spent in the Work Ready 
and Work Not Ready states today.

Team: The total time all members of the team spent in 
the Work Ready and Work Not Ready states today.

Other Time Agent: The total time the agent spent in states other 
than Talking, Ready, Not Ready, Work Ready, and Work 
Not Ready today.

Team: The total time all members of the team spent in 
states other than Talking, Ready, Not Ready, Work 
Ready, and Work Not Ready today.

Table 10. Agent vs. Team Statistics real time display data — Continued

Column Name Description
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Agent Call Log

The Agent Call Log real time display is available when you select the Logs node 
underneath a specific agent’s name in the Agents tree (see Figure 15). 

Figure 15. Agent Call Log real time display.

This display presents a history of the calls made and received by the agent during the 
current session. By default, the data displayed is sorted in ascending order by time of 
day. The data in the report must be refreshed manually by clicking the Refresh button 
on the toolbar.

Agent ACD State Log

The Agent ACD State Log real time display is available when you select the Logs node 
underneath a specific agent’s name in the Agents tree (see Figure 16). 

Figure 16. Agent ACD State Log real time display.

Table 11. Agent Call Log real time display data 

Column Name Description

Start Time The time the call was answered.

Direction Inbound or outbound call.

Answered (Yes/No) Answered or unanswered call.

Calling Party The originating phone number.

Called Party The recipient phone number.

Call Duration The length of the call.
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This display presents a history of the ACD states the agent transitioned through during 
the current session. By default, the data displayed is sorted in ascending order by time 
of day. The data in the report must be refreshed manually by clicking the Refresh 
button on the toolbar.

Agent Active Call

The Agent Active Call real time display is available when you select an active call under 
a specific agent’s name in the Agents tree (see Figure 17). 

Figure 17. Agent Active Call real time display.

This display presents information about each party in the current active call. 

Table 12. Agent ACD State Log real time display data 

Column Name Description

State Start Time The time the agent state was initiated.

Agent State The ACD agent state.

Wrap-up Data Any wrap-up data the agent entered, if the agent state 
transitioned to is After Call Work (Work Ready or Work 
Not Ready).

Reason Code Any reason code the agent entered, if the agent state 
transitioned to is Not Ready or Logout (if required).

State Duration The length of time the agent was in the agent state.

Table 13. Agent Active Call real time display data 

Column Name Description

Name Name of the parties in the call, if known. If this data is 
not known, <unavailable> is displayed.

Number The party’s phone number.

Call Status Hook state of the party (Active or Held).

Duration The length of time the party has been in the call.
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Enterprise Data

The Enterprise Data real time display is available when you select an active call under 
a specific agent’s name in the Agents tree (see Figure 18). The data displayed is 
configured by your administrator.

Figure 18. Enterprise Data real time display.

Call History

The Call History real time display is available when you select an active call under a 
specific agent’s name in the Agent’s tree (see Figure 19). 

This display presents a history of the call’s presence in the contact center.

Figure 19. Call History real time display.

Skill Group The skill group ID the called was queued to, if applicable.

Table 13. Agent Active Call real time display data — Continued

Column Name Description
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Table 14. Call History real time display data

Column Name Description

Threshold The acceptable amount of time a call can remain at a 
particular device or contact center. The administrator 
may assign caution and warning threshold values to 
each device type, as well as a total threshold value for a 
call. 

If a call remains at a device longer than the defined 
caution and warning thresholds, a caution or warning 
icon is displayed in this field.

Device A device that the call has passed through.

Type The type of device the call has passed through.

Description Description of the device.

Duration The amount of time the call spends at a device.

Total The sum of all the durations listed.
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Monitoring Agents

If your system configuration uses Cisco CallManager 4.x or Cisco Unified 
Communications Manager 5.x (Unified CM), CAD supports one kind of monitoring: 
CAD-based (agent-based) monitoring. 

If your system configuration uses Unified CM 6.0, CAD supports two kinds of 
monitoring: CAD-based monitoring and Unified CM-based (call-based) monitoring. 

The type of monitoring that is used is determined when the Cisco components of your 
system are installed. CAD uses either Unified CM-based or CAD-based monitoring, not 
both. Supervisor Desktop automatically determines which kind of monitoring is used 
when it is launched.

CAD-Based Monitoring

CAD-based monitoring is available whenever an agent is logged in to Agent Desktop. It 
is not available when:

■ You are a participant in a phone call (you cannot monitor yourself)

■ You use the Barge-In or Intercept function

NOTE:  Only one supervisor at a time can monitor a mobile agent.

When you use CAD-based monitoring, the monitored call is audible through your PC 
speakers. The volume slide on the Supervisor Desktop toolbar enables you to control 
the volume when monitoring an agent’s phone conversation. The system remembers 
your last volume setting and uses it the next time you log in.

In CAD-based monitoring, you can record while monitoring an agent.

To start monitoring an agent using CAD-based monitoring:

1. Choose an agent in the Agents tree.

2. Click the Start Voice Monitor button, or choose Intervention > Start Voice 
Monitor.

To stop monitoring an agent using CAD-based monitoring:

1. Click the Stop Voice Monitor button, or choose Intervention > Stop Voice 
Monitor.
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Unified CM-Based Monitoring

Unified CM-based monitoring is available when an agent is logged into Agent Desktop 
and is on an active call. You must also be logged into Agent Desktop, and in the Not 
Ready agent state. It is not available when:

■ You are a participant in a phone call.

■ The agent you want to monitor is not on a call or has a call on hold.

■ The agent being monitored is logged in as a mobile agent.

In Unified CM-based monitoring, when you start monitoring an agent’s call, a new call 
is directed to your IP phone and answered automatically. The phone does not ring. You 
can listen to the phone call through a headset, speaker, or handset. The new call on 
your IP phone, or your “monitoring call”, appears in Agent Desktop as an outbound call 
and also in the Supervisor Desktop tree control as an active call.

While you are monitoring a call, you cannot use the Barge-In, Intercept, Conference, or 
Transfer functions. You must stop monitoring to use one of these functions.

NOTE:  You cannot monitor an agent who is using Cisco IP 
Communicator.

NOTE:  Recording is not supported in Unified CM-based monitoring.

NOTE:  Unified CM-based monitoring is supported only on certain 
models of IP phones. For a complete list of IP phone models that 
support Unified CM-based monitoring, see the Cisco CAD Installation 
Guide.

Your monitoring call (on your IP phone) ends when one of the following events occurs:

■ When the agent transfers or ends the monitored call

■ When you stop monitoring or exit Supervisor Desktop

■ When you or the agent exit Agent Desktop

Your monitoring call does not end if the agent conferences in another party or if the 
agent closes Agent Desktop—Browser Edition.

To start monitoring a call using Unified CM-based monitoring:

1. Choose a call under an agent in the Agents tree.

2. Click the Start Voice Monitor button, or choose Intervention > Start Voice 
Monitor.

The call is directed to your IP phone and answered automatically. The phone 
does not ring.
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To stop monitoring a call using Unified CM-based monitoring:

■ Click the Stop Voice Monitor button, or choose Intervention > Stop Voice 
Monitor.

■ End the call on your IP phone.
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Pushing a Web Page to an Agent

You can coach an agent by pushing a web page to that agent’s Agent Desktop 
integrated browser. 

To push a web page to an agent:

1. Select the agent in the Agent tree, and then choose Intervention > Coach by 
pushing a page.

The Push URL to Agents dialog box appears (see Figure 20).

Figure 20. Push URL to Agents dialog box.

2. Enter the URL of the web page you want the agent to see, and then click Push 
to send the web page to the agent.

There are no restrictions on what you can enter as a URL (for example, you are 
not required to prefix the URL with “http://”) as long as the URL can be 
resolved by a browser. Some sites require http or https be part of the URL. 

The web page you pushed to the agent is displayed in the first tab of the 
agent’s integrated browser. This tab is reserved for pushed web pages.
June 2007 39



Cisco Supervisor Desktop User Guide
Barging In on Calls

The Barge-In feature enables you to join an agent’s phone conversation. When you 
click the Barge-In button, you are automatically added to the phone call. It is a forced 
conference.

If notification is enabled, the agent sees a message that you are attempting to join the 
call, then sees a message that you have successfully joined it.

When you use the Barge-In feature, voice monitoring is disabled. You can, however, 
record calls.

You can’t barge in if:

■ The agent is on hold

■ The agent is on two calls

■ The agent is in a conference call

■ You are already on another call

To barge in:

1. Select an agent call in the team view pane.

2. Click the Barge-In button or choose Intervention > Barge-In.

You are added to the call.

At any time during the conference call, you may click Intercept to disconnect 
the agent whose call is selected from the conference call and continue talking 
with the remaining parties yourself.

To drop the barged-in call:

■ In Cisco Agent Desktop, select the conference call from the dashboard and 
then click Drop.
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Intercepting Calls

The Intercept feature enables you to intercept a phone call while disconnecting the 
agent from that phone call. It is a forced transfer.

NOTE:  You can intercept a call only once per supervisor.

If notification is enabled, the agent sees a message that you are attempting to 
intercept the phone call, then sees a further message when the interception is 
successful.

When you use the Intercept feature, voice monitoring is disabled. You can, however, 
record calls.

You can’t intercept if: 

■ The agent is on hold

■ The agent is on two calls

■ You are already on another call

To intercept a phone call:

1. Select an agent call in the team view pane.

2. Click the Intercept button or choose Intervention > Intercept.

The call is transferred to you.

If you are intercepting a conference call you are on, the agent call you 
selected in the team view pane is dropped from the conference call, and all 
other participants in the conference call remain connected.

To drop the intercepted call:

■ In Cisco Agent Desktop, select the intercepted call from the dashboard and 
then click Drop.
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Recording Calls

You can use Supervisor Desktop to record, save, and play back calls handled by 
agents on your team. Multiple recordings can be in progress at the same time, 
although only one recording may be made per agent at any one time. You use the 
Supervisor Record Viewer to review recorded calls.

You can use the Barge-In, Intercept, and Voice Monitor features while recording. 

When recording a call, keep in mind the following:

■ The recording feature is not intended to record every call. It is an on-demand 
solution only.

■ Although you select a specific call from the Team View pane when recording, 
you are actually recording all voice activity to and from that particular agent. It 
is not limited to the call you selected. For instance, if the agent puts the 
selected call on hold and switches to another call, the recording will record 
both calls.

■ The recording will end when the selected call terminates, or when you 
manually stop recording, whichever comes first.

■ Agents may be configured so that they are allowed to start and stop recording 
calls. However, an agent cannot stop a recording that you, as a supervisor, 
started. If an agent attempts to do so, their Agent Desktop or IP Phone Agent 
interface indicates the recording is stopped. However, the recording is not 
stopped, and Supervisor Desktop displays an icon indicating that recording is 
proceeding.

■ You can stop a recording initiated by an agent.

■ If notification is off, agents have no way of knowing if you are recording their 
calls. If an agent attempts to start recording a call that you are already 
recording, the agent will see a recording icon on the call, although the agent is 
not in control of the recording. 

■ When you or an agent record a call, a recording license is used. The license is 
released when the recording stops. If all recording licenses are in use when 
you attempt to start a recording, the recording will not start.

To record a call:

1. Choose the call you wish to record from the Agents tree.

2. Click the Start Record button, or choose Intervention > Call/Agent Start 
Recording.

3. When you are finished, click the Stop Record button, or choose Intervention > 
Call/Agent Stop Recording.
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The call is archived to the Recording service database, where it is 
automatically saved for seven days. If you want to save it for a longer period, 
you may do so for up to 30 days, after which it is deleted (see "Using 
Supervisor Record Viewer" on page 65 for more information on playing and 
saving recordings). 
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Changing Agents’ ACD States

You can use Supervisor Desktop to change the ACD state of an agent on your team, 
including logging an agent out. 

NOTE:  If you log a CAD agent out, that agent will continue to appear in 
the agent tree and will be able to chat and receive team messages. If 
you log out a CAD-BE or IP Phone agent, that agent disappears from 
the agent tree.

To change an agent’s agent state:

1. From the Agents tree, select the agent whose state you want to change.

2. On the toolbar, click the appropriate agent state button.

NOTE:  If an agent state change fails, you will not see any failure 
message. You will know that an agent state change succeeds if the 
icon next to the agent’s name in the team view pane changes to the 
current agent state icon.
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Using Chat

Chat allows you to send instant messages to agents on your team and to other 
supervisors. You initiate a chat session by clicking the Chat button on the toolbar.

NOTE:  You cannot chat with CAD-BE or IP Phone agents.

Chat Features

■ You can chat with agents who are logged out of the ACD as long as their Agent 
Desktop interface is open.

■ You can participate in multiple concurrent chat sessions.

■ You can send the same chat message to multiple recipients (their replies, if 
any, appear in separate chat windows, one for each person).

■ The Chat Session window’s title bar displays the name of the person with 
whom you are chatting.

■ High priority chat messages pop on your screen so they are immediately 
noticed, while normal priority chat messages are minimized and flash on your 
Windows task bar.

■ Chat logs are available as long as the Chat Session window is open. Once you 
close the window, the log is lost.

■ Chat logs are in chronological order, with the oldest messages at the top of 
the log pane.

To initiate a chat session:

1. On the toolbar, click the Chat button.

The Chat Selection window is displayed (see Figure 21).

Figure 21. Chat Selection window
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The window lists the people with whom you can chat (logged-in members of 
your team and other supervisors).

2. Select the check box next to the name of the person(s) with whom you wish to 
chat. 

If you select the check box next to Desktop Agents or Supervisors, the check 
boxes next to all agents or supervisors listed underneath are automatically 
selected. You can then send a message to multiple recipients.

A Chat Session window is displayed and a chat session is initiated with the 
selected people (see Figure 22).

Figure 22. Chat Session window

3. Type your message in the text entry field. 

4. If you want your message to be noticed immediately by popping on the 
recipient’s screen, select the High priority check box.

5. Click Send or press Enter.

Your message is sent to your chat partner and logged in the chat log pane.

Replies from recipients of a group message appear in individual chat session 
windows. They cannot reply to the group, they can reply only to you.

To terminate a chat session:

■ Click Close in the upper right-hand corner of the Chat Session window.

Chat log pane

Text entry field
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Predefined High-Priority Chat Messages

Agents may have a task button in Agent Desktop and CAD-BE configured to send a 
predefined high-priority chat message to their supervisor(s). This predefined message 
(for instance, “Please barge in on my call”) is set up by the system administrator. It 
behaves just like a regular chat message that is tagged as high priority—it pops up on 
your screen on top of all other windows for your immediate attention.

NOTE:  Although a CAD-BE agent can send you a high-priority chat 
message, you cannot send a chat message back to that agent. 
CAD-BE agents do not have regular chat capability.
June 2007 47



Cisco Supervisor Desktop User Guide
Using the Integrated Browser

The integrated browser allows you to view intranet and internet web pages from within 
Supervisor Desktop. When enabled, the browser appears as a tab in the real time 
display pane, with up to 20 characters of the name of the current webpage displayed 
on the tab. The real time displays appear on another tab in that pane.

NOTE:  You must have Internet Explorer 6 or 7 installed on your PC for 
the integrated browser to function.

NOTE:  Running Cisco Agent Desktop—Browser Edition (CAD-BE) in the 
integrated browser is not supported.

By default, the browser is not enabled. See "Setting Preferences" on page 16 for 
instructions on enabling the browser and configuring a home page.

The Address field’s drop-down list contains the URLs of the last 10 websites visited for 
quick access to frequently-visited websites.

Browser Toolbar

The browser toolbar is the basic Internet Explorer toolbar. It allows you to navigate 
among web pages you view, refresh a current page, and return to your home page.

Table 15. Browser toolbar buttons 

Button Name Shortcut Key Description

Back Alt–left arrow Returns you to the last page you viewed.

Forward Alt–right 
arrow

Takes you to the page you viewed before you 
clicked the Back button.

Stop Esc Stops the browser from displaying a web page 
(for example, if the download is taking too long).

Refresh F5 Refreshes the web page displayed to ensure 
you see the latest content.

Home Alt–Home Returns you to your predefined home page.
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Sending Team Messages

You can send a team message (TM) to all agents on a team, whether or not the agent 
is logged into the ACD. As long as Agent Desktop is open, an agent can view a TM.

NOTE:  You cannot send TMs to CAD-BE and IP Phone agents.

The Team Messages dialog box (see Figure 23) stores the last 10 TMs you broadcast. 
You can select any one of these messages to broadcast again. If you send more than 
10 TMs, the oldest one drops off the stored list. You cannot designate any particular 
TM for permanent storage.

Figure 23. Team Message dialog box.

NOTE:  By default, the TM scrolls across Agent Desktop’s TM pane. 
Individual agents can set their preference in Agent Desktop to view 
TMs as stationary. A stationary TM is more compatible with screen 
readers, which are often used by vision-impaired agents. 

The Current Message pane displays the message that is currently being sent to your 
team.

To send a TM to all agents on a team:

1. From the team selection list, choose the team to which you want to send the 
message, and then click View > Team Messages or click the Team Messages 
button.

2. In the Expires at field, choose a specific time for the message to expire. 

By default, the message runs for 30 minutes. 
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If you set a time earlier than the current time, the message will run until that 
time the next day. For example, if it is 10:15 AM and you set the expiration 
time to be 10:00 AM, the message will run until 10:00 AM tomorrow.

3. Type your message in the text box. The TM can be up to 255 characters long.

4. Click Start or press Enter.

The TM is sent to the team for the length of time you chose. The text of the 
message you sent is logged in the current team performance message field. 

To cancel a TM:

■ In the Team Message dialog box, click Stop.
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Creating Supervisor Work Flows

Using the Supervisor Work Flow Administrator feature, you can configure your desktop 
to perform certain actions based on queue statistics for calls waiting and calls in 
queue for specified skill groups. 

These work flows apply only to you, not to any other supervisors, and are available to 
you no matter where you log into Supervisor Desktop. They are tied to your login 
information.

In general, work flows consist of events, rules, and actions. 

■ The event that triggers an action is a skill groups queue statistics update. 
Queue statistics are updated once every 5 seconds.

■ The rule the event must meet is one or both of the following:

— The number of calls waiting is below, within, or above specified limits

— The oldest call in queue is below, within, or above specified time 
durations

■ The actions triggered by meeting the rules can be:

— Change the color of the skill group name in the tree control and/or add a 
message next to it

— Highlight data in the tabular real time display

— Display a popup message on your desktop

— Play a *.wav file on your desktop

— Send an email to selected recipients

For example, you can set up a work flow so that when there are more than 10 calls 
waiting in the queue for Skill Group 6500, the skill group name in the Skill Groups tree 
turns red and an audible warning sounds every 15 seconds. 

To set up a supervisor work flow:

1. Choose Tools > Supervisor Work Flow Administrator.

The Supervisor Work Flow List dialog box appears.

2. Click Add.

The Add New Work Flow dialog box appears.

3. Enter a name for your new work flow, and then click OK.

The Skill Group Selection dialog box appears.

4. Select the skill groups you want your work flow to apply to from the Available 
Skill Groups pane and use the arrows to move them to the Selected Skill 
Groups pane. Click OK when finished. 
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NOTE:  A skill group may be a part of only one work flow per 
supervisor.

The Supervisor Work Flow Setup dialog box appears (see Figure 24).

Figure 24. Supervisor Work Flow Setup dialog box.

5. Set up the parameters for the work flow:

a. Specify the upper and lower limits for the Call Waiting and/or Current 
Oldest threshold. 

NOTE:  When you select both Calls Waiting and Current Oldest, 
the highest threshold crossed takes precedence.

b. Select Above from the Thresholds pane. 

c. Click Add, and from the resulting Action Type Selection dialog box, select 
the action you want to be triggered when the Calls Waiting and/or Current 
Oldest statistic is above the upper limit you set, and then click OK. See 
"Work Flow Actions" on page 55 for information on the types of actions 
available.

d. Repeat for the Within and Below thresholds.

6. When you have finished, click OK to enable the work flow.
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Example: Setting Up a Supervisor Work Flow

The following is a step-by-step illustration of setting up a supervisor work flow. This 
work flow:

■ Changes the skill group name color to green and displays “Below” next to it in 
the Skill Groups tree control when there are less than 2 calls waiting, or if the 
current oldest call is less than 1 minute old

■ Changes the skill group name color to blue and displays “Caution” when there 
are 2 to 5 calls waiting, or if the current oldest call is between 1 and 5 
minutes old

■ Changes the skill group name color to red and displays “Warning” when there 
are more than 5 calls waiting, or if the current oldest call is more than 5 
minutes old 

To set up the example supervisor work flow:

1. Choose Tools > Supervisor Work Flow Administrator.

The Supervisor Work Flow List dialog box appears.

2. Click Add.

The Add New Work Flow dialog box appears.

3. Enter the name Customer Management, and then click OK.

The Skill Group Selection dialog box appears.

4. Select the skill groups you want your work flow to apply to from the Available 
Skill Groups pane and use the arrows to move them to the Selected Skill 
Groups pane. Click OK when finished.

The Supervisor Work Flow Setup dialog box appears.

5. Select the Calls Waiting check box and set the lower limit to 2 and the upper 
limit to 5. 

6. Select the Current Oldest check box and set the lower limit to 1 minute and 
the upper limit to 5 minutes.
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7. Select Below in the Thresholds pane and then click Add under the Actions 
pane.

The Action Type Selection dialog box appears.

8. Select Tree Control Node Action and then click OK.

The Tree Control Action dialog box appears.

9. Check Display Text and enter Below in the field. 

10. Check Change Text Color, click Set Color, choose green from the color palette 
displayed, and then click OK.
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11. Repeat steps 7 through 10 for the Above and Within thresholds. For Above, 
select “Warning” as the display text and set the color to red. For Within, select 
“Caution” as the display text and set the color to blue.

12. When you are finished, click OK to enable the work flow. The skill group 
names will now be color-coded with text displayed.

Work Flow Actions

There are 5 possible work flow actions that can be triggered by threshold rules. These 
actions are:

■ Audible Alert Action (page 56)

■ Message Box Action (page 56)

■ Report Action (page 57)

■ Report Action (page 57)

■ Tree Control Action (page 57)

■ Email Alert Action (page 58)
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Audible Alert Action

The Audible Alert action plays a *.wav file on your desktop whenever the threshold 
rules are met. By default, the file plays once, but you can also configure it so that it 
plays repeatedly at specified intervals. 

NOTE:  You can turn off audible alerts that are configured to repeat at 
intervals by choosing Actions > Supervisor Work Flow — Audio Off 
from the menu.

Your computer most likely has system *.wav files available that are used to signal 
standard Windows events. These files are a good source of sounds. 

NOTE:  Any *.wav file you select must be 300K or smaller. 

To set up an audible alert, in the Audible Alert Action dialog box (see Figure 25) click 
Add New and then browse to the location of your selected *.wav file. If desired, set up 
a repeat interval, and then click OK.

Figure 25. Audible Alert Action dialog box.

Message Box Action

The Message Box action pops a message box containing a customized message on 
your desktop whenever the threshold rules are met. The message box is cleared by 
clicking OK. 

To set up a message box, in the Message Box Action dialog box (see Figure 26) type 
your message in the Message Text field, select the appropriate message icon, and 
then click OK.
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Figure 26. Message Box Action dialog box

Report Action

The Report action highlights in color the Calls Waiting and Current Oldest cells in the 
tabular Team Skill Statistics real time display when the data in the cell exceeds the 
threshold rules. 

To set up a Report action, In the Report Action dialog box (see Figure 27) click Set 
Color to select the color to use for highlighting the display cells, and then click OK. 

If you select the Show Team Skill Statistics Report check box, then whenever a 
statistic changes that triggers a Report action Supervisor Desktop automatically 
changes its focus to display the Team Skill Statistics report so that you will see the 
current report with the cells highlighted. 

Figure 27. Report Action dialog box

Tree Control Action

The Tree Control action enables you to select a color to apply to a skill group name 
and/or a message to display beside the skill group name in the Skill Groups tree 
control whenever the threshold rules are met.

To set up a Tree Control action, in the Tree Control Action dialog box (see Figure 28) 
check the effect(s) you want applied to the skill group name. Click Set Color to select a 
text color, enter your own message or select from the drop-down list a predefined 
message (Caution or Warning) to appear next to the skill group name, and then click 
OK.
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Figure 28. Tree Control Action dialog box

Email Alert Action

The Email Alert action enables you to send an email to specified people whenever the 
threshold rules are not met. 

The email messages have predefined subject lines, depending on what threshold rule 
is met. They are:

■ Skill: <skill group name>, Number of Calls Waiting is above upper limit

■ Skill: <skill group name>, Number of Calls Waiting is below lower limit

■ Skill: <skill group name>, Number of Calls Waiting is within upper and lower 
limits

■ Skill: <skill group name>, Oldest Call in Queue is above upper limit

■ Skill: <skill group name>, Oldest Call in Queue is below lower limit

■ Skill: <skill group name>, Oldest Call in Queue is within upper and lower limits

The email messages sent can consist only of the Subject line; a message in the body 
of the email is optional. 
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Figure 29. Email Alert Action Setup dialog box

To set up an email alert action, complete the Email Alert Action Setup dialog box (see 
Figure 29) as follows:

Table 16. Email Alert Action Setup dialog box fields 

Field Description

From: Required. Enter your email address. The first time this 
dialog box is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.

To: Required. Enter the email addresses of the recipients, 
separated by a semicolon. The first time this dialog is 
displayed the field is blank; thereafter it is automatically 
filled with what you previously entered.

Mail Server: Required. The SMTP IP address or host name of the 
email server used to send the email. The first time this 
dialog is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.

BCC: Optional. Enter the email addresses of the recipients you 
want copied in on the email message. The first time this 
dialog is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.

Subject: The subject line is automatically generated by the 
action.
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Use the Test button to check if the email alert action is configured correctly. When you 
click Test, a test email is sent to the email addresses in the To and BCC fields.

If the test email is successful, “Mail Sent Successfully” appears in the field next to the 
test button. If it is unsuccessful, “Mail Send Failed” appears. In that event, check your 
entries in the To, BCC, and Mail Server fields for accuracy and test it again.

High Priority Select the check box if you want the email to be 
delivered with high priority. Leave it unselected for 
normal email delivery.

Message Pane (not 
labeled)

Optional. Enter a message to appear in the body of the 
email. 

Table 16. Email Alert Action Setup dialog box fields — Continued

Field Description
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Re-skilling Agents

The Agent Re-skilling tool is a browser-based application that enables you to change 
the skill group designations of agents on your team, and quickly view skill group 
members and details on individual agents. Changes made to an agent's skill group 
membership take place immediately without need for the agent to log out and log in 
again.

The Agent Re-skilling tool can run in your integrated browser if the browser is enabled.

Re-skilling can be done on the agent level and on the skill group level. You can add 
and remove skill groups from an agent, or you can add or remove agents from a skill 
group. 

NOTE:  The new skill group shows up in the agent’s reports 
immediately. If it is a new skill group, it may take up to 19 minutes for 
skill group data to show up in Supervisor Desktop. To display data 
immediately, you can ask the system administrator to perform a 
manual Directory Services sync, or you can select another team in 
Supervisor Desktop and then return to the team to which you added 
the new skill group.

To add or remove skill groups from an agent:

1. From the menu, choose Tools > Agent Re-skilling > Site 1.

NOTE:  Your menu might display just Site 1, or Site 1 and Site 2. This 
depends on the configuration of your system. These sites represent 
the servers on which the Agent Re-skilling tool is located. If you 
receive an error when you try to access a site, try another site until 
you find the site that is active.

The supervisor login window for the Agent Re-skilling tool appears (see Figure 
30).
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Figure 30. Supervisor Login screen.

2. Enter your Supervisor Desktop login name and password, and then click 
Login.

The Agents window appears (see Figure 31).

Figure 31. Agents window.

3. Use the search fields at the top of the window to locate the agent you want to 
re-skill. 

4. Select the agent by clicking the agent’s login name.

The Edit Agent window appears.
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Figure 32. Edit Agent window.

5. In the Skill Groups pane you can:

■ Assign a new skill group to the agent. Click Add, and in the resulting 
Select Skill Groups for Agent window, check the skill group you wish to 
add, and then click OK.

■ Delete a skill group from the agent. Select the skill group you want to 
delete, and then click Remove.

■ Remove all skill groups from the agent. Click Remove All to delete all skill 
groups. Note that an agent must be assigned to at least one skill group.

6. Click Save to save your changes.

At the top of the window you will see the message, Agent saved successfully.

To add and remove agents from a skill group:

1. From the menu, choose Tools > Agent Re-skilling > Site 1.

NOTE:  Your menu might display just Site 1, or more sites (Site 2, Site 
3, etc.). This depends on the configuration of your system. These sites 
represent the servers on which the Cisco Unified CCE Agent 
Re-skilling Tool is located. If you receive an error when you try to 
access a site, try another site until you find the site that is active.

The supervisor login window for the Agent Re-skilling tool appears (see Figure 
30).
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2. Enter your Supervisor Desktop login name and password, and then click 
Login.

The Agents window appears (see Figure 31).

3. Click Skill Groups at the left side of the window to change the view to a list of 
skill groups.

4. Select the desired skill group from the list by clicking on its name, or use the 
search fields at the top of the window to locate the skill group. 

The Edit Skill Group window appears.

5. In the Agents in your team(s) pane you can:

■ Assign a new agent to the skill group. Click Add, and in the resulting 
Select Agents for Skill Group window, check the agents you wish to add, 
and then click OK.

■ Delete an agent from the skill group. Select the agent you want to delete, 
and then click Remove.

■ Remove all agents from the skill group. Click Remove All to delete all skill 
groups. A skill group with no agents assigned to it will not show up in 
Supervisor Desktop.

■ View an agent’s properties. Select an agent, and then click Open to view 
that agent’s record. You can only view this record, not edit it.

6. Click Save to save your changes.

At the top of the window you will see the message, Skill group saved 
successfully.
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Using Supervisor Record Viewer

The Supervisor Record Viewer (see Figure 33) displays all recordings made by your 
team over the last seven days as well as those you tag for 30-day extended lifetime. 

NOTE:  A license is used whenever you open the Supervisor Record 
Viewer, and is released when you close it. If no licenses are available, 
Supervisor Record Viewer will start but no recordings will be listed 
and the error message, “Licensing error” will be displayed. You must 
wait until a license is released and available for you to use in order to 
review any recordings. For this reason, it is important to close 
Supervisor Record Viewer after you are finished using it.

The recordings are archived as raw voice data packets; they can only be played back 
using the Supervisor Record Viewer. However, if you wish to save selected recordings 
as *.wav files, you can use the “Play and Save” button and save the recording to a 
folder in *.wav format.

Unless recordings are tagged for an extended lifetime, they are automatically deleted 
after seven days. 

If a recording is tagged for the 30-day extended lifetime, it will not be deleted until that 
30-day period expires. If you delete it manually before the 30-day period expires, it is 
deleted during the next folder cleanup—cleanups run daily at midnight.

Figure 33. Supervisor Record Viewer
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Figure 34. Supervisor Record Viewer toolbar.

The Supervisor Record Viewer displays the following information:

To start Supervisor Record Viewer:

1. From the Supervisor Desktop menu bar, choose Tools > Recorded Files.

Supervisor Record Viewer starts with no day selected.

2. From the Day Select section, click one of the radio buttons to view the 
recordings made by your team on that date.

To listen to a recording:

1. From the Day Select section of Supervisor Record Viewer, click the radio 
button for the date of the recording you want to review.

You can also click the Extended Lifetime radio button to view a list of all 
recordings that have been tagged for extended 30-day archiving. 

Table 17. Supervisor Record Viewer fields 

Column Name Description

Agent The agent whose call is recorded.

Team The team to which the agent belongs.

Time The time the recording was made.

Duration The length of the recording in hh:mm:ss format.

Lifetime The length of time the recording is archived: Normal is 7 
days, Extended is 30 days.

Date Recorded (Appears only when “Extended Lifetime” is selected in 
Day Select) The date the recording was made.

Play
Play & Save

Stop
Set Extended Lifetime

Set Normal Lifetime
Delete

Volume Control

Pause
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2. Select the recording you want to review.

3. Click the Play button, or choose Recording > Play from the menu bar.

Use the Pause or Stop buttons to control the recording playback, and the 
volume slider to control the playback volume.

There is a progress bar at the bottom of the screen that shows where you are 
within the recording. You can click the progress bar and drag it backwards or 
forwards to rewind or fast forward the recording. You must click Play again 
after you reposition the progress bar to restart the playback.

NOTE:  Playing back a recording while you are monitoring a call is not 
supported.

To save a recording:

1. Select the recording you want to save.

2. Click the Play and Save button, or choose Recording > Play and Save from the 
menu bar.

The Save As dialog box appears.

3. Select a folder to save the recording to, enter a file name for the recording, 
and then click Save.

The recording plays and simultaneously is saved as a wav file to the location 
you selected.

To tag a recording for extended archiving:

1. Select the recording you want to archive for 30 days.

2. Click the Set Extended Lifetime button, or choose File > Set Extended Lifetime 
from the menu bar.

The recording is tagged to be archived for 30 days from the date of recording.
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Service Auto-recovery

The service auto-recovery feature allows Supervisor Desktop to automatically recover 
its connection to the Cisco services in the event of a service restart or a network 
outage.

When Supervisor Desktop detects that it is unable to communicate with a service 
(generally within three minutes of the service failure), the status bar displays “Partial 
Service” or “No Service” to indicate some or all of the services have failed.

When Supervisor Desktop detects that the service is again available (usually within 
one minute of service recovery), the status bar displays “In Service” to indicate that 
the services have recovered.

To learn more about what is affected by the service failure, double-click the status 
message on the status bar. Supervisor Desktop displays a popup box (see Figure 35) 
that lists features and indicates if that feature is available or not due to the service 
outage. 

Figure 35. Service Status popup window
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