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Bulk Trace Analysis

The Cisco Bulk Trace Analysis tool, a plug-in software application provided in 
Serviceability, takes the input from one or multiple large (over 2MB) XML trace 
files and creates a report that you can use to analyze trace data.

This chapter contains the following topics:

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

Before You Begin

Bulk Trace Analysis uses an XML trace file as the input file. Use the Trace tools 
to generate the XML trace file. For information on XML trace files, see the 
following chapters:

• Chapter 5, “Trace Configuration”

• Chapter 6, “Trace Collection Configuration”

• Chapter 7, “Trace Analysis Configuration”

Downloading Bulk Trace Analysis
You download the Bulk Trace Analysis tool from Serviceability and install it on 
a client PC.

This section describes how to download the Bulk Trace Analysis tool.
21-1
er Serviceability Administration Guide



 

Chapter 21      Bulk Trace Analysis
Installing the Bulk Trace Analysis Program
Procedure

Step 1 From the Serviceability window, choose Application > Install Plugins.

The Serviceability Install Plugins window displays.

Step 2 Click the Bulk Trace Analysis icon.

Step 3 In the window, choose Save the program to disk.

Step 4 Enter the filename and location where you want the Bulk Trace Analysis program 
saved.

Step 5 Click the OK button.

Related Topics

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

Installing the Bulk Trace Analysis Program
Install the Bulk Trace Analysis program on a PC after the plugin has been 
downloaded from the Serviceability program.

This section describes how to install the Bulk Trace Analysis program on a client 
PC.

Procedure

Step 1 From the PC, double-click the Bulk Trace Analysis icon or the 
TraceAnalysis_installation.exe filename.

The installation wizard window displays.

Step 2 Click the Next > buttons in the windows as they display.

Step 3 Click the Finish button.

The now installed program is ready to be used.
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Using Bulk Trace Analysis
Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Using Bulk Trace Analysis, page 21-3

Using Bulk Trace Analysis
Bulk Trace Analysis takes one or multiple SDI or SDL XML trace files and 
creates reports that you can use to analyze the trace data. Bulk Trace Analysis 
supports the following report functionality:

• Create a new report

• Open a report

• Print a report

• Save a report

• Search for data in a report

• Create multiple views in a report

Before You Begin

You must install the Bulk Trace Analysis program on a PC other than the 
Cisco CallManager publisher or subscriber system. See Downloading Bulk Trace 
Analysis, page 21-1 and Installing the Bulk Trace Analysis Program, page 21-2.

Make sure the program is started and running on the PC. See Starting and Exiting 
the Program, page 21-4.
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Starting and Exiting the Program
This section describes how to start and exit the Bulk Trace Analysis program.

Step 1 Choose Start > Programs > Cisco Bulk Trace Analysis Tool.

The Bulk Trace Analysis Tool window displays. See Figure 21-1.

Step 2 Use the procedures described in this section to create a report, open a report, and 
print a report.

Step 3 To end the program, choose File > Exit.
21-4
Cisco CallManager Serviceability Administration Guide

OL-3388-01



 

Chapter 21      Bulk Trace Analysis
Using Bulk Trace Analysis
Figure 21-1 Bulk Trace Analysis Window

Related Topics

• Creating a Report, page 21-6

• Opening a Report, page 21-8

• Printing a Report, page 21-9

• Saving the Master Report, page 21-10

• Searching for Data in a Report, page 21-10

• Creating a Report with Multiple Views, page 21-12

1 Workplace

2 Report Table

3 Task Control and Status
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• Displaying View Information, page 21-15

• Customizing the Report Table Headings, page 21-16

Creating a Report
Bulk Trace Analysis creates reports using SDI or SDL XML trace files. You create 
a report using the following input trace files:

• Select multiple XML files in the Bulk Trace Analysis program File Open 
dialog window using the Control key while selecting filenames.

• Select a file from a remote Cisco CallManager node by entering the IP 
address of the node in the Bulk Trace Analysis program File Open dialog 
window. You must use a user ID and password.

• From Cisco CallManager Serviceability, choose a zip file that was collected 
using the Trace Collection tool.

Caution The Bulk Trace Analysis program only accepts original XML trace files or trace 
files that the Trace Collection tool zipped. Using a trace file zipped by any other 
application (such as WinZip) could cause the Cisco CallManager system to stop 
working.

Procedure

This section describes how to create a report from a trace file.

Step 1 From the Bulk Trace Analysis window, choose File > New Report.

The New File dialog window displays.

Step 2 To choose an SDI trace file, click the SDI button; to choose an SDL trace file, 
click the SDL button.

Step 3 To choose the trace source file, click the Browse button.

The Open window displays.

Step 4 Choose the source trace file from the list of files.

Step 5 Click the Open button.
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The New File dialog window displays, and the file that you chose is entered in the 
Source File field. To choose multiple files, press the Control key while clicking 
on the file name.

Step 6 To save the report using the default file name displayed in the Save Report As 
field, click the OK button. Continue with Step 10; otherwise, continue with Step 
7.

Step 7 To save the report using another file name, click the Browse button.

Step 8 In the Save As window, enter a file name in the file name field or use the default.

Step 9 Click the Save button.

The New File dialog window displays, and the file name that you chose is entered 
in the Save Report As field.

Step 10 Click the OK button.

The data from the source file displays in the Report Table pane, the report name 
appears in the Workplace Views pane, and the status of the report displays in the 
Task Control and Status pane. See Figure 21-1.

Step 11 To save the report, choose File > Save.

Step 12 Click the Save button.

Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

• Starting and Exiting the Program, page 21-4

• Opening a Report, page 21-8

• Printing a Report, page 21-9

• Saving the Master Report, page 21-10

• Searching for Data in a Report, page 21-10

• Creating a Report with Multiple Views, page 21-12

• Displaying View Information, page 21-15

• Customizing the Report Table Headings, page 21-16
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Opening a Report
This section describes how to open a report that is already created. See Creating 
a Report, page 21-6.

Procedure

Step 1 From the Bulk Trace Analysis window, choose File > Open Report.

The Open dialog window displays.

Step 2 Choose the report file from the list of files.

Step 3 Click the Open button.

The data from the source file displays in the Report Table pane, the report name 
appears in the Workplace Views pane, and the status of the report displays in the 
Task Control and Status pane.

Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

• Starting and Exiting the Program, page 21-4

• Creating a Report, page 21-6

• Printing a Report, page 21-9

• Saving the Master Report, page 21-10

• Searching for Data in a Report, page 21-10

• Creating a Report with Multiple Views, page 21-12

• Displaying View Information, page 21-15

• Customizing the Report Table Headings, page 21-16
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Printing a Report
This section describes how to print a report.

Procedure

Step 1 If you have more than one report open, choose the report that you want to print.

Tip Before printing a report, choose File > Print Preview.

Step 2 From the Bulk Trace Analysis window, choose File > Print.

The Print dialog window displays.

Tip Choose Landscape as the paper layout.

Step 3 Click the OK button.

Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

• Starting and Exiting the Program, page 21-4

• Creating a Report, page 21-6

• Opening a Report, page 21-8

• Saving the Master Report, page 21-10

• Searching for Data in a Report, page 21-10

• Creating a Report with Multiple Views, page 21-12

• Displaying View Information, page 21-15

• Customizing the Report Table Headings, page 21-16
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Saving the Master Report
This section describes how to save the master report. The master report designates 
the report without any filtering criteria.

Procedure

Step 1 In the Workplace Views pane, choose the report that you want to save.

Step 2 Choose File > Save.

Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

• Starting and Exiting the Program, page 21-4

• Creating a Report, page 21-6

• Opening a Report, page 21-8

• Printing a Report, page 21-9

• Searching for Data in a Report, page 21-10

• Creating a Report with Multiple Views, page 21-12

• Displaying View Information, page 21-15

• Customizing the Report Table Headings, page 21-16

Searching for Data in a Report
This section describes how to search for data (information) in a report.

Procedure

Step 1 In the Workplace Views pane, choose the report that you want to search.
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Step 2 Choose Edit > Find or click the binoculars icon.

The Find window displays.

Step 3 Enter the search criteria; for example, Alarm.

Step 4 Choose additional search options as described in Table 21-1.

Step 5 Click the Find Next button.

The highlighted match displays.

Step 6 To search again, click the Find Next button.

Step 7 Click the Cancel button when you finish searching.

Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

• Starting and Exiting the Program, page 21-4

• Creating a Report, page 21-6

• Opening a Report, page 21-8

• Printing a Report, page 21-9

Table 21-1 Search Options

Option Description

Match case Searches the file for the search criteria 
matching the case (upper and lower) 
exactly.

Up Direction Searches the file for the search criteria 
beginning at the current cursor position 
and searching upwards.

Down Direction Searches the file for the search criteria 
beginning at the current cursor position 
and searching downwards.
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• Saving the Master Report, page 21-10

• Creating a Report with Multiple Views, page 21-12

• Displaying View Information, page 21-15

• Customizing the Report Table Headings, page 21-16

Creating a Report with Multiple Views
A view designates a report that contains specific information used for 
troubleshooting. A report can contain multiple views that allow you to examine 
the trace information from different perspectives.

Configuration of Bulk Trace Analysis filtering criteria is similar to configuration 
of filtering criteria in the Trace Analysis tool (see Chapter 7, “Trace Analysis 
Configuration”). You can choose the type of information (such as host name, IP 
address, or correlation tag) to include in a trace analysis.

The results you receive from choosing correlation tag filtering provides more 
information than when you do not choose correlation tag filtering. Correlation tag 
filtering shows the relation between one trace to another trace. See the following 
examples.

Example Using Correlation Tag

In a trace file, a user checks the Use Correlation Tag check box and chooses a filter 
of IP Address=172.21.10.555 and Trace type=Alarm. Bulk Trace Analysis looks 
for all trace records with this IP address and trace type and collects all trace 
records that have a correlation tag associated with the trace records. The 
correlation tag gets applied to all the trace records found and gets filtered again. 
The trace filter finds the following records:

• Record 1: IP Address=172.21.10.555, Trace type=Alarm, Ctag=3,65,100,1.1

• Record 2: IP Address=172.21.10.555, Trace type=Error, Ctag=3,65,100,1.1

• Record 3: IP Address=172.21.10.556, Trace type=Alarm, Ctag=3,65,100,1.1

• Record 4: IP Address=172.21.10.557, Trace type=Trace, Ctag=3,65,100,1.3

Because Use Correlation Tag is checked the view displays record 1, record 2, and 
record 3.
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Example Without Correlation Tag

In a trace file, a user does not check the Use Correlation Tag check box. The user 
chooses a filter of IP Address=172.21.10.555 and Trace type=Alarm. Bulk Trace 
Analysis looks for all trace records with this IP address and trace type and collects 
all trace records that have a correlation tag associated with the trace records. The 
correlation tag gets applied to all the trace records found and gets filtered again. 
The trace filter finds the following records:

• Record 1: IP Address=172.21.10.555, Trace type=Alarm, Ctag=3,65,100,1.1

• Record 2: IP Address=172.21.10.555, Trace type=Error, Ctag=3,65,100,1.1

• Record 3: IP Address=172.21.10.556, Trace type=Alarm, Ctag=3,65,100,1.1

• Record 4: IP Address=172.21.10.557, Trace type=Trace, Ctag=3,65,100,1.3

Because Use Correlation Tag is not checked the view only displays record 1.

This section describes how to make the report contain specific information by 
choosing filtering criteria and saving it as another view. 

Procedure

Step 1 In the Workplace Views pane, choose the report for which you want to create 
another view.

Step 2 Choose View > New View, right-click the report name or click the new view icon.

The Filter window displays.

Step 3 Check the Use Correlation Tag check box if you want to use the CTag field of the 
trace record. See Example Using Correlation Tag, page 21-12.
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Step 4 In the Selection Criteria area, choose the information that you want included in 
the new view. See Table 21-2.

Step 5 In the Time area, choose a specific time and date range.

Step 6 Click the OK button.

The view with the specified criteria displays in the Report Table pane with a new 
view name (for example, View 2) displayed under the Task name in the Workspace 
Views pane.

Tip If you do not want the view in the report, close the view using the Windows close 
box.

Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

Table 21-2 Selection Criteria

Option Description

Use Correlation Tag Check this check box if you want the 
view to contain all trace records 
associated with the selection criteria 
you chose.

CallManager Host (CCM) Choose a specific host from which the 
trace originated or choose all hosts.

Source Device (SrcDev) Choose a specific device from which a 
trace was created or choose all devices.

Source IP Address (SrcIP) Choose a specific IP address for a 
device from which a trace was created 
or choose all IP addresses.

Trace Type Choose trace types such as alarms or 
errors, only alarms, or only traces from 
which the trace originated.
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• Using Bulk Trace Analysis, page 21-3

• Starting and Exiting the Program, page 21-4

• Creating a Report, page 21-6

• Opening a Report, page 21-8

• Printing a Report, page 21-9

• Saving the Master Report, page 21-10

• Searching for Data in a Report, page 21-10

• Displaying View Information, page 21-15

• Customizing the Report Table Headings, page 21-16

Displaying View Information
If you need to find out the filter information for a particular view, you can display 
the information. This section describes how to display the filter information for a 
view.

Procedure

Step 1 In the Workplace Views pane, choose the view for which you want filter 
information displayed.

The filter information window displays.

Step 2 Right-click the view name.

Step 3 Choose View Information from the pop up menu.

Step 4 Click the OK button to close.

Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

• Starting and Exiting the Program, page 21-4
21-15
Cisco CallManager Serviceability Administration Guide

OL-3388-01



 

Chapter 21      Bulk Trace Analysis
Using Bulk Trace Analysis
• Creating a Report, page 21-6

• Opening a Report, page 21-8

• Printing a Report, page 21-9

• Searching for Data in a Report, page 21-10

• Creating a Report with Multiple Views, page 21-12

• Customizing the Report Table Headings, page 21-16

Customizing the Report Table Headings
To view specific columns of information in the report, you can remove the 
columns of information that you do not want to see.

This section describes how to customize the Report Table headings.

Procedure

Step 1 In the Workplace Views pane, choose the report or view for which you want to 
customize the Report Table headings.

Step 2 Choose Edit > Customize Header or click the Customize header icon.

The Customize columns window displays.

Step 3 To remove columns, choose a column from the Columns to be shown and order 
area.

Step 4 Click the <- Remove button.

Step 5 To rearrange the order of the columns, choose the column from the Columns to be 
shown and order area.

Step 6 Click the Move Up or Move Down button.

Step 7 To add columns, choose a column from the Columns not shown area.

Step 8 Click the Add -> button.

Step 9 Click the OK button.

The report with the new heading arrangement displays in the Report Table pane.
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Related Topics

• Downloading Bulk Trace Analysis, page 21-1

• Installing the Bulk Trace Analysis Program, page 21-2

• Using Bulk Trace Analysis, page 21-3

• Starting and Exiting the Program, page 21-4

• Creating a Report, page 21-6

• Opening a Report, page 21-8

• Printing a Report, page 21-9

• Saving the Master Report, page 21-10

• Searching for Data in a Report, page 21-10

• Creating a Report with Multiple Views, page 21-12

• Displaying View Information, page 21-15
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