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CiscoCallManagerAutoAttendant

Cisco CallManager AutoAttendant, a simple automated attendant, allows callers 
to locate people in your organization without talking to a receptionist. You can 
customize the prompts that are played for the caller, but you cannot customize 
how the software interacts with the customer.

Cisco CallManager AutoAttendant comes bundled with Cisco CallManager on 
the Cisco CallManager Extended Services CD. This version of 
Cisco CallManager AutoAttendant provides a four-CTI port limit. If you need a 
fully configurable automated attendant, you will need to purchase Cisco IP 
Interactive Voice Response (IP IVR), one of the 
Cisco Customer Response Applications (CRA).

This chapter describes Cisco CallManager AutoAttendant that is running on 
Cisco CallManager 4.1 with Cisco CRA 3.5. 

Note For information about supported versions of Cisco CRA with Cisco CallManager, 
see the Cisco CallManager Compatibility Matrix at the following URL: 
http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/ccmcomp.htm
#CompatibleApplications

Use the following topics to understand, install, configure, and manage 
Cisco CallManager AutoAttendant:

• Understanding Cisco CallManager AutoAttendant, page 7-2

• Installing and Upgrading Cisco CallManager AutoAttendant, page 7-5

• Configuring Cisco CallManager AutoAttendant, page 7-7

• Managing Cisco CallManager AutoAttendant, page 7-29
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Understanding Cisco CallManager AutoAttendant
Cisco CallManager AutoAttendant (see Figure 7-1) works with 
Cisco CallManager to receive calls on specific telephone extensions. The 
software interacts with the caller and allows the caller to search for and select the 
extension of the party (in your organization) that the caller is trying to reach. 

This section provides an introduction to Cisco CallManager AutoAttendant:

• Cisco CallManager AutoAttendant Overview, page 7-3

• Components of Cisco CallManager AutoAttendant, page 7-4

Figure 7-1 Using Cisco CallManager AutoAttendant
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Cisco CallManager AutoAttendant Overview
Cisco CallManager AutoAttendant provides the following script:

• Answers a call

• Plays a user-configurable welcome prompt

• Plays a main menu prompt that asks the caller to perform one of three actions:

– Press 0 for the operator.

– Press 1 to enter an extension number.

– Press 2 to spell by name.

• If the caller chooses to spell by name (option 2), the system compares the 
letters that are entered with the names that are configured to the available 
extensions.

– If a match exists, the system announces a transfer to the matched user and 
waits for up to 2 seconds for the caller to press any DTMF key to stop the 
transfer. If the caller does not stop the transfer, the system performs an 
explicit confirmation: it prompts the user for confirmation of the name 
and transfers the call to that user’s primary extension.

– If more than one match occurs, the system prompts the caller to choose 
the correct extension. 

– If too many matches occur, the system prompts the caller to enter more 
characters.

• When the caller has specified the destination, the system transfers the call.

– If the line is busy or not in service, the system informs the caller 
accordingly and replays the main menu prompt.

Related Topic:

Components of Cisco CallManager AutoAttendant, page 7-4
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Components of Cisco CallManager AutoAttendant
The Cisco Customer Response Platform provides the components that are 
required to run Cisco CallManager AutoAttendant. The platform provides a 
multimedia (voice/data/web) IP-enabled customer care application environment.

Note Cisco Customer Response Applications (CRA), which was renamed 
Cisco Customer Response Solutions (CRS) with its 3.0 release, gets marketed 
under the names IPCC Express and IP IVR. The Cisco website and packaging 
materials reflect the new name but the user interface and, therefore, the 
documentation do not.

Cisco CallManager AutoAttendant uses four main components of the 
Cisco Customer Response Platform:

• Gateway—Connects the enterprise IP telephony network to the Public 
Switched Telephone Network (PSTN) and to other private telephone systems 
such as Public Branch Exchange (PBX). You must purchase gateways 
separately.

• Cisco CallManager Server—Provides the features that are required to 
implement IP phones, manage gateways, provides failover and redundancy 
service for the telephony system, and directs voice over IP traffic to the 
Cisco Customer Response Application (Cisco CRA) system. You must 
purchase Cisco CallManager separately.

• Cisco IP Telephony Directory—Provides the repository for configuration 
information and Cisco CRA application scripts. The repository acts as the 
subdirectory that stores scripts. Cisco CallManager AutoAttendant comes 
with a predefined script that you cannot alter. The Cisco CallManager 
AutoAttendant package includes the Cisco IP Telephony Directory.

• Cisco CRA Server—Contains the Cisco CRA Engine that runs 
Cisco CallManager AutoAttendant. The Cisco CallManager AutoAttendant 
package includes the Cisco CRA Server and Engine.

You must install Cisco CallManager AutoAttendant co-resident on the same 
server as Cisco CallManager.

For more information about the Cisco Customer Response Platform, refer to the 
following URL.

http://www.cisco.com/en/US/products/ps5883/index.html
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Related Topic

Installing and Upgrading Cisco CallManager AutoAttendant, page 7-5

Installing and Upgrading Cisco CallManager 

AutoAttendant
Use these topics to install or upgrade Cisco CallManager AutoAttendant:

• Hardware and Software Requirements, page 7-5.

• Installing or Upgrading Cisco CallManager AutoAttendant, page 7-5.

Hardware and Software Requirements
Before you install this version of Cisco CallManager AutoAttendant, you must 
have a functioning voice over IP system. You must have installed and configured 
Cisco CallManager 4.1. This software manages the telephony system.

Cisco CallManager AutoAttendant runs on the Cisco Media Convergence Server 
(Cisco MCS) platform or on a Cisco-certified server such as the Compaq DL320 
and DL380 and the IBM-330 and IBM-340. Ensure that the server is running 
Microsoft Windows 2000.

You must install Cisco CallManager AutoAttendant co-resident on the same 
server as Cisco CallManager. 

Installing or Upgrading Cisco CallManager AutoAttendant
Install Cisco CallManager and Windows 2000 before you install 
Cisco CallManager AutoAttendant. For information, refer to the following 
documents:

• Cisco CallManager installation documentation at:

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/4_0/instal
l/instcall/index.htm

• Cisco IP Telephony Operating System at:

http://www.cisco.com/univercd/cc/td/doc/product/voice/iptel_os/index.htm
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You must configure proxy settings for Internet Explorer and verify that you can 
browse to internal and external web sites. For details on configuring your proxy 
settings, contact your network administrator.

Before You Begin

Ensure that you have met all preinstallation requirements that are described in 
Hardware and Software Requirements, page 7-5

These topics describe how to install Cisco CallManager AutoAttendant:

• Installing Cisco CallManager AutoAttendant, page 7-6

• Upgrading or Reinstalling Cisco CallManager AutoAttendant, page 7-7.

Installing Cisco CallManager AutoAttendant

Use this section to install Cisco CallManager AutoAttendant for the first time.

Procedure

Step 1 Insert the Cisco CallManager Extended Services CD.

Step 2 Click the .exe file to start the installation program and follow the on-screen 
instructions.

Related Topics

• Hardware and Software Requirements, page 7-5

• Upgrading or Reinstalling Cisco CallManager AutoAttendant, page 7-7

• Configuring Cisco CallManager AutoAttendant, page 7-7
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Upgrading or Reinstalling Cisco CallManager AutoAttendant

This procedure describes how to upgrade to Cisco CallManager AutoAttendant 
from an earlier version of Cisco CallManager AutoAttendant or 
Cisco CallManager Extended Services or how to reinstall the current version of 
Cisco CallManager AutoAttendant.

Procedure

Step 1 On the Cisco CallManager server, choose 
Start> Programs>Cisco CRA Administrator>Application Administrator.

Step 2 Enter your user name and password and click OK.

Step 3 Follow the on-screen instructions.

You do not need to reboot after this procedure.

Related Topics

• Hardware and Software Requirements, page 7-5

• Configuring Cisco CallManager AutoAttendant, page 7-7

Configuring Cisco CallManager AutoAttendant
These topics describe how to configure Cisco CallManager and the 
Cisco Customer Response Application (CRA) Engine in preparation for 
deploying Cisco CallManager AutoAttendant.
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Configuration Checklist for Cisco CallManager
Table 7-1 describes the procedures you perform to configure Cisco CallManager 
AutoAttendant.

Table 7-1 Configuration Checklist for Cisco CallManager AutoAttendant

Configuration Steps Related Procedures and Topics

Step 1 Configure Cisco CallManager to create the 
telephone number and other telephony 
entities that Cisco CallManager 
AutoAttendant requires. 

See the “Configuring Cisco CallManager” 
section on page 7-9.

Step 2 Configure the Cisco Customer Response 
Applications (CRA) Engine. You must 
install and configure Cisco CRA before you 
can use Cisco CallManager AutoAttendant. 
The Cisco CRA Engine controls the 
software and its connection to the telephony 
system

See “Configuring the Cisco Customer Response 
Application Engine” section on page 7-13.

Step 3 Customize Cisco CallManager 
AutoAttendant, so its prompts are 
meaningful to how you are using the 
automated attendant. 

See the “Customizing 
Cisco CallManager AutoAttendant” section on 
page 7-24.
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Configuring Cisco CallManager
Before you can use Cisco CallManager AutoAttendant, you must configure 
Cisco CallManager as shown in Table 7-2:

These topics assume that you know how to use Cisco CallManager. For more 
information about Cisco CallManager, refer to the Cisco CallManager 
Administration Guide and the Cisco CallManager System Guide.

Adding CTI Route Points in Cisco CallManager

Create a CTI route point in Cisco CallManager for Cisco CallManager 
AutoAttendant use. This route point specifies the telephone number that callers 
will call to use the automated attendant.

Table 7-2 Configuration Checklist for Cisco CallManager

Configuration Steps Related Procedures and Topics

Step 1 Create a CTI route point. This action 
specifies the telephone number that people 
will call to use Cisco CallManager 
AutoAttendant.

See the “Adding CTI Route Points in 
Cisco CallManager” section on page 7-9.

Step 2 Create CTI ports for use by the CTI route 
point. The number of ports that you create 
determines the number of simultaneous 
callers that can use Cisco CallManager 
AutoAttendant. The version of 
Cisco CallManager AutoAttendant, that 
comes bundled with Cisco CallManager has 
a four-port limit. 

See “Adding CTI Ports in Cisco CallManager” 
section on page 7-11.

Step 3 Create a Cisco CallManager user for 
Cisco CallManager AutoAttendant and 
associate the CTI route points and CTI ports 
that you created to this user.

See “Creating a Cisco CallManager User for 
Cisco CallManager AutoAttendant” section on 
page 7-12.
7-9
Cisco CallManager Features and Services Guide

OL-6505-01



 

Chapter 7      Cisco CallManager AutoAttendant
Configuring Cisco CallManager AutoAttendant
Procedure

Step 1 In Cisco CallManager, choose Device>CTI Route Point.

The Find and List CTI Route Points window displays.

Step 2 Click Add a new CTI Route Point.

The CTI Route Point Configuration window displays.

Step 3 Fill in the CTI route point properties:

• Enter a unique name, such as AutoAttendant, in the Device Name field to 
identify this as the Cisco CallManager AutoAttendant number.

• From the Device Pool menu, choose the appropriate device pool.

Step 4 To add the new CTI route point, click Insert.

Cisco CallManager adds the route point and asks whether you want to add a 
directory number for line 1. To add line 1, click OK.

Cisco CallManager opens the Directory Number configuration window.

Step 5 In the Directory Number field, enter the directory number for this CTI route point. 
This number specifies the number that callers will dial to reach this CTI route 
point (for example, 4000). You can also fill in other fields as appropriate for your 
telephony network.

Step 6 Click Insert.

Cisco CallManager assigns the directory number to the current device and asks 
you if you want to return to the current device configuration window. Click OK 
to return to the current device configuration window. 

Create only one line for the device. 

Related Topics

• Configuring Cisco CallManager, page 7-9

• Adding CTI Ports in Cisco CallManager, page 7-11
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Adding CTI Ports in Cisco CallManager

Create CTI ports for use with the Cisco CallManager AutoAttendant CTI route 
point. The number of ports that you create determines the number of simultaneous 
callers that can use your automated attendant. If all ports are in use when a caller 
calls, the caller receives a busy signal.

Procedure

Step 1 In Cisco CallManager, choose Device>Phone.

Cisco CallManager opens the Find and List Phones window.

Step 2 Click Add a New Phone.

Cisco CallManager opens the Add a New Phone window.

Step 3 Choose CTI Port for Phone Type and click Next.

Cisco CallManager opens the Phone Configuration window.

Step 4 Configure the CTI Port and enter at minimum this information:

• Device Name—Enter something meaningful to you, for example, CTI4001.

• Device Pool—Choose an appropriate device pool.

Step 5 Click Insert.

Cisco CallManager creates the CTI port and asks whether you want to add a 
directory number for line 1. Click OK. Cisco CallManager opens the Directory 
Number Configuration window.

Step 6 In the Directory Number field, enter an unused extension number for the port, 
such as 4001. 

Step 7 Click Insert.

Cisco CallManager assigns the directory number to the current device. Click OK 
to return to the device configuration window. 

Repeat the procedure to create each CTI port that you require. Create only one line 
for each CTI port.
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Related Topics

• Adding CTI Route Points in Cisco CallManager, page 7-9

• Creating a Cisco CallManager User for Cisco CallManager AutoAttendant, 
page 7-12

Creating a Cisco CallManager User for Cisco CallManager AutoAttendant

In Cisco CallManager, create a user for Cisco CallManager AutoAttendant. 
Cisco CallManager AutoAttendant uses this account to gain access to 
Cisco CallManager and control the CTI route points and CTI ports that you 
defined for its use.

Procedure

Step 1 In Cisco CallManager, choose User> Add a New User.

Cisco CallManager opens the User Configuration window.

Step 2 Complete the following required fields:

• First Name—Use a descriptive name such as “Automated.”

• Last Name—Use a descriptive name such as “Attendant.”

• UserID—Use a descriptive name such as “AutoAttendant.”

• User Password and Confirm Password—Enter a password and enter it again 
for confirmation.

• PIN and Confirm PIN—Enter a PIN and enter it again for confirmation.

• Enable CTI Application Use—Check this checkbox.

Step 3 To create the user, click Insert.

Cisco CallManager adds the user.

Step 4 In the left column, click Device Association.

Cisco CallManager opens the Device Association subwindow of the User 
Information window.

Step 5 Enter search criteria to list the desired route points and CTI ports or enter nothing 
to list all devices and click Select Devices to list the devices.
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Step 6 In the list that Cisco CallManager produces, choose these devices:

• The CTI route point that was created for the automated attendant. See Adding 
CTI Route Points in Cisco CallManager, page 7-9, for more information.

• All CTI ports that were created for Cisco CallManager AutoAttendant use. 
See Adding CTI Ports in Cisco CallManager, page 7-11, for more 
information.

Make sure you click the No Primary Extension radio button.

Step 7 To save your changes, click Update Selected.

Related Topics

• Adding CTI Ports in Cisco CallManager, page 7-11

• Configuring the Cisco Customer Response Application Engine, page 7-13

Configuring the Cisco Customer Response Application Engine
After you have configured Cisco CallManager for Cisco CallManager 
AutoAttendant, configure the Cisco Customer Response Application (CRA) 
Engine to communicate with Cisco CallManager and the 
Cisco IP Telephony Directory. Perform the configuration steps shown in 
Table 7-3:

Table 7-3 Configuration Checklist for Cisco CRA Engine

Configuration Steps Related Procedures and Topics

Step 1 Configure the IP Telephony Directory so 
Cisco CRA can use it. You may have 
already completed this configuration when 
you installed Cisco CRA. 

See the “Logging In and Configuring Directory 
Information” section on page 7-14, for more 
information.

Step 2 Configure the Cisco CRA Engine JTAPI 
subsystem to use the Cisco CallManager 
user that you created for 
Cisco CallManager AutoAttendant. 

See “Configuring the JTAPI Subsystem on the 
Cisco Customer Response Application Engine” 
section on page 7-18, for more information
7-13
Cisco CallManager Features and Services Guide

OL-6505-01



 

Chapter 7      Cisco CallManager AutoAttendant
Configuring Cisco CallManager AutoAttendant
These topics only cover the basics of using and configuring Cisco CRA. See the 
Cisco CRA online help for more detailed information.

Related Topic:

Logging In and Configuring Directory Information, page 7-14

Logging In and Configuring Directory Information

The Cisco IP Telephony Directory server stores two types of information that the 
Cisco Customer Response Application (Cisco CRA) Engine uses. First, it stores 
directory information, which includes CTI port and routing configurations. 
Second, it contains the repository subdirectory, which stores the applications that 
are used with the Cisco CRA Engine.

Cisco recommends that you use one Cisco CRA server for the IP Telephony 
Directory with Cisco CallManager AutoAttendant rather than split the directory 
information and repository subdirectories onto separate servers.

Tip To start Cisco CRA Administration, open http://servername/AppAdmin in your 
web browser, where servername is the DNS name or IP address of the application 
server. Click Help for detailed information about using the interface.

Step 3 Add a CTI port group in the Cisco CRA 
Engine JTAPI subsystem that contains the 
CTI ports that you created for 
Cisco CallManager AutoAttendant use. 

See the “Adding a CTI Port Group” section on 
page 7-19, for more information.

Step 4 Add the Cisco CallManager AutoAttendant 
application to the Cisco CRA Engine. 

See the “Adding a New 
Cisco CallManager AutoAttendant” section on 
page 7-22, for more information.

Table 7-3 Configuration Checklist for Cisco CRA Engine

Configuration Steps Related Procedures and Topics
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To establish the directory server settings on a new Cisco CRA server, perform the 
following steps:

Procedure

Step 1 The first time that you log in to the Cisco CRA server, enter the username 
Administrator and the password ciscocisco. Click Log On.

Note Because the login name and password are case-sensitive, enter them exactly 
as shown.

Note Enter the specified username and password for first-time setup process 
only.

The Cisco CRA Administrator Setup window displays. 

Step 2 Click Setup.

The Directory Setup window displays.

Step 3 Enter the directory configuration information as described in Table 7-4.

Table 7-4 Directory Configuration Defaults

Field Description Default for DC Directory

Directory hostname Hostname or IP address of the Cisco IP 
Telephony Directory server where the profile 
resides or will reside with the CRA engine 
profile.

Directory port number Port number of the Cisco IP Telephony 
Directory. 

8404

Directory user (DN) The user name (also called the distinguished 
name) that is configured on the directory server 
for the user that has permission to modify the 
Cisco IP Telephony tree and object entries. 

cn=Directory Manager, 
o=cisco.com.

Directory password Password for the Directory user. ciscocisco
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Step 4 Click Next.

The second Directory Setup window displays.

Step 5 To configure the Directory setup for Netscape, Active Directory and Other, 
perform the following step:

From the Server Type drop-down arrow, choose the appropriate directory (for 
example, Netscape).

The following fields adjust to the new information:

• Directory User

• Base Context

• User Base

Step 6 Click Edit and enter a new profile or use the Profile Name drop-down arrow to 
choose a profile.

Step 7 To enter the new profile, click OK.

Step 8 Click Next.

The third Directory Setup window displays.

Base Context Branch of the Cisco IP Telephony Directory tree 
that contains the Cisco configuration 
information. 

o=cisco.com

User Base Branch of the Cisco IP Telephony Directory tree 
that contains user information. 

ou=Users, o=cisco.com

Server Type Type of LDAP directory, such as MS Active 
Directory, Netscape Directory Server 4.0, or DC 
Directory.

DC Directory

Configuration Profile 
Name

Profile name that identifies this CRA server 
configuration or repository.

Table 7-4 Directory Configuration Defaults (continued)

Field Description Default for DC Directory
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Step 9 Accept the default setting: Use the default Repository profile to create the 
repository profile on the same server and with the same name.

-Or

If you want to maintain separate profiles for your configuration and repository, 
click the Use a different Repository profile radio button. When this option is 
chosen, the system prompts the user for directory information for the repository 
profile, which provides the windows to capture the directory information for the 
repository.

The Repository Configuration window appears. Complete these fields with the 
configuration information that is appropriate for your repository directory.

Step 10 Click OK.

The User Maintenance window displays. Use this window to assign access levels 
to an Administrator.

Step 11 In the User Maintenance window, choose the Group drop-down arrow and then 
choose Administrator.

Step 12 From the CMUsers list box, choose an available CM User and click < to move a 
user to the CRA Administrator/Supervisor list box.

If the steps are correctly followed, a (Administrator) label displays after the user 
name.

Caution To update the system, you must choose at least one Administrator.

Step 13 To complete the process and initialize configuration and repository profiles, click 
Finish.

The Setup window displays your configuration choices.

Step 14 Log in to the system again by using the administrator username and password that 
you created.

Note The login name, Administrator, and the Password, ciscocisco, no longer 
work. Log in by using the configured administrator password.

The Cisco CRA Administration window displays.
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Related Topics

• Configuring the Cisco Customer Response Application Engine, page 7-13

• Configuring the JTAPI Subsystem on the Cisco Customer 
Response Application Engine, page 7-18

Configuring the JTAPI Subsystem on the Cisco Customer 
Response Application Engine

After you complete the directory configuration, you must configure the JTAPI 
subsystem on the Cisco Customer Response Application Engine 
(Cisco CRA Engine). The Cisco CRA Engine uses the JTAPI subsystem to send 
and receive calls from Cisco CallManager.

Tip To start Cisco CRA Administration, open http://servername/AppAdmin in your 
web browser, where servername is the DNS name or IP address of the application 
server. Click Help for detailed information on using the interface.

Procedure

Step 1 From the Cisco CRA Administration main menu, choose Subsystems > JTAPI. 

The JTAPI Configuration window displays.

Step 2 In the JTAPI Provider(s) field, enter the IP address or DNS name of the Cisco 
Media Convergence Server (Cisco MCS) that is running Cisco CallManager CTI 
Manager. You can enter up to two CTI Managers, separated by a space. If the first 
CTI Manager becomes unavailable, the second one connects and maintains calls.

Step 3 In the UserID field, enter the Cisco CallManager UserID that you created in the 
“Creating a Cisco CallManager User for Cisco CallManager AutoAttendant” 
section on page 7-12 (for example, “AutoAttendant”).

Step 4 In the Password field, enter the password that you defined for this UserID.
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Step 5 To apply changes, click Update.

The following message appears:

“JTAPI Subsystem configured successfully!!”

Step 6 To close the dialog box, click OK.

Related Topics

• Logging In and Configuring Directory Information, page 7-14

• Adding a CTI Port Group, page 7-19

Adding a CTI Port Group

Identify the CTI ports that you created for Cisco CallManager AutoAttendant use 
on JTAPI Configuration in the Cisco CRA Administration configuration. These 
ports comprise a CTI port group.

Tip To start Cisco CRA Administration, open http://servername/AppAdmin in your 
web browser, where servername is the DNS name or IP address of the application 
server. Click Help for detailed information on using the interface.

Procedure

Step 1 From the CRA Administration main window, choose Subsystems > JTAPI.

The JTAPI Configuration window displays.

Note To access the CTI Ports window, you must ensure that the CRA Engine is 
running.

Step 2 To apply changes and restart the engine, click Update.

Step 3 In the left column, click the CTI Port Groups hyperlink.

The JTAPI Call Control Group window displays.
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Step 4 Click the Add a New JTAPI Call Control Groups hyperlink.

The second JTAPI Call Control Group Configuration window displays.

Step 5 Accept the automatic group ID or enter a group ID in the Group ID field. The 
Group ID corresponds to the trunk group number that is reported to the ICM when 
the CRA server is part of the Cisco IPCC solution.

Step 6 To automatically populate the Description field, press the Tab key.

Step 7 Click Associate CTI Ports.

The Please assign CTI Ports for this Group window displays.

Step 8 In the Directory Number column, click the checkboxes that contain the directory 
numbers that you established in Adding CTI Ports in Cisco CallManager, 
page 7-11.

Note You must complete configuration of ports in the Cisco Call Manager first, 
before assigning a user port to a group.

Step 9 To add the port to the list of available CTI ports and close the window, click 
Update.

Step 10 Click Add.

The Call Control Group appears in the Group ID column.

Related Topics:

• Configuring the JTAPI Subsystem on the Cisco Customer 
Response Application Engine, page 7-18

• Adding a New Cisco CallManager AutoAttendant, page 7-22

Provisioning Cisco Media Termination Subsystem

You can choose different types of media, from a simple type of media that is 
capable of supporting prompts and DTMF (Cisco Media Termination) to a more 
complex and rich type of media that is capable of supporting speech recognition 
in addition to prompts and DTMFs. You can even provision calls without media. 
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Because of these capabilities, you must provision media manually. Each call 
requires both a CTI port and a media channel for the system to be backward 
compatible or to support media interactions.

Furthermore, media resources are licensed and sold as IVR ports so you can 
provision more channels than you are licensed for and, at run-time, licensing will 
be enforced to prevent the system accepting calls, as this would violate your 
licensing agreements.

You can provision Call Control groups, multiple CMT Dialog groups, and Nuance 
ASR Dialog groups to allow for the sharing of resources between different 
applications. In addition, you can provision special applications to primarily use 
specific sets of resources. You can do this, for example, when you configure a 
JTAPI Trigger. For more information, see the Cisco Customer Response 
Applications Administrator Guide.

Provisioning CMT Dialog Groups

The Cisco CRA server uses the Real-Time Transport Protocol (RTP) to send and 
receive media packets over the IP network. To ensure that the CRA Engine can 
communicate with your Cisco IP Telephony system, you need to configure the 
RTP ports that the CRA Engine will use to send and receive RTP data. 

To configure a CMT Dialog, perform the following steps:

Procedure

Step 1 Connect to Cisco CRA Administration.

Step 2 From the CRA Administration main menu, choose Subsystems > Cisco Media.

The Cisco Media Termination Dialog Group Configuration window displays.

Step 3 Click the Add a New CMT Dialog Group hyperlink.

The second Cisco Media Termination Dialog Group Configuration window 
displays.

Step 4 Accept the automatic group ID or enter a group ID in the Group ID field.

Note Ensure this Group ID is unique within all media group identifiers, 
including ASR.

Step 5 To automatically populate the Description field, press the Tab key.
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Step 6 Enter a maximum number of channels available for the group in the Maximum 
Number Of Channels field.

Step 7 Click Add.

The Cisco Media Termination Dialog Group Configuration window displays.

Adding a New Cisco CallManager AutoAttendant

After you have configured the JTAPI subsystem on the Cisco CRA Engine, you 
can use one of the sample scripts to create an application and start the 
Cisco CRA Engine. To add a new Cisco CallManager AutoAttendant, use this 
procedure.

Tip To start Cisco CRA Administration, open http://servername/AppAdmin in your 
web browser, where servername is the DNS name or IP address of the application 
server. Click Help for detailed information on using the interface.

Procedure

Step 1 From the CRA Administration main menu, choose Applications > Configure 
Applications.

Cisco CRA Administration opens Application Configuration window.

Step 2 Click the Add New Application link on the Application Configuration window.

The Add a New Application window displays.

Step 3 Click Next.

The Cisco Script Application window displays.

Step 4 In the Name field, enter the name of the application.

Step 5 To automatically populate the Description field, press the Tab key.
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Step 6 In the ID field, enter a unique ID. The ID gets reported in Historical Reporting to 
identify this application.

Note The system automatically generates an ID; therefore, you can use the ID 
that the field contains or erase the value and enter a new one.

Step 7 In the Maximum Number of Sessions field, enter the maximum number of  
sessions that can be running this application simultaneously.

Note Depending on the Script and Default Script selection, the window may 
refresh and provide additional fields and drop-down menu options.

Step 8 From the Script drop-down arrow, choose the script that will be running the 
application. The script for Cisco CallManager AutoAttendant specifies aa.aef.

Step 9 From the Default Script drop-down menu, accept System Default. The default 
script executes when an error occurs with the configured application script.

Step 10 Click Add.

The following message displays:

“The operation has been executed successfully”

Step 11 To close the dialog box, click OK.

Related Topics

• Adding a New Cisco CallManager AutoAttendant, page 7-22

• Customizing Cisco CallManager AutoAttendant, page 7-24
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Customizing Cisco CallManager AutoAttendant
Cisco CallManager AutoAttendant comes with a prerecorded welcome prompt. 
By default, it spells out user names; it does not attempt to pronounce names. You 
can customize your automated attendant by adding your own welcome prompt and 
recordings of your user spoken names. These topics describe how to customize 
Cisco CallManager AutoAttendant:

• Modifying an Instance of Cisco CallManager AutoAttendant, page 7-24

• Configuring Prompts, page 7-25

Modifying an Instance of Cisco CallManager AutoAttendant

This section describes how to modify Cisco CallManager AutoAttendant settings.

Tip To start Cisco CRA Administration, open http://servername/AppAdmin in your 
web browser, where servername is the DNS name or IP address of the application 
server. Click Help for detailed information on using the interface.

Procedure

Step 1 From the Cisco CRA Administration main window, choose Applications > 
Configure Applications.

Step 2 Click the instance of Cisco CallManager AutoAttendant that you want to 
configure.

Step 3 You can change these settings:

• Description—The description of the application.

• ID—The application ID. The system reports the ID in Historical Reporting to 
identify this application.

• Maximum Number of Sessions—The maximum number of simultaneous 
callers that can use this automated attendant. This number should not exceed 
the number of CTI Ports that were created for its use.

• Enabled—Indications that the automated attendant is running.

• Script—The script that will be running the application.
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• welcomePrompt—The prompt that initially plays when the automated 
attendant answers the phone. See Configuring the Welcome Prompt, 
page 7-27, for information about how to upload prompts.

• MaxRetry—The number of times that a caller is returned to the 
Cisco CallManager AutoAttendant script main menu if caller encounters an 
error. The default specifies 3.

• operExtn—The extension of the phone that the operator will use.

• Default Script—The script that executes when an error occurs with the 
configured application script.

Step 4 To save your changes, click Update.

Related Topics

• Adding a CTI Port Group, page 7-19

• Configuring Prompts, page 7-25

Configuring Prompts

Through Cisco CRA Administration Media Configuration, you can modify the 
prompts that Cisco CallManager AutoAttendant uses. You can also upload spoken 
names for each person in the organization, so callers receive spoken names rather 
than spelled-out names when the automated attendant is asking the caller to 
confirm which party they want.

These topics describe how to customize these features:

• Recording the Welcome Prompt, page 7-25

• Configuring the Welcome Prompt, page 7-27

• Uploading a Spoken Name, page 7-28

Recording the Welcome Prompt

Cisco CallManager AutoAttendant comes with a prerecorded, generic welcome 
prompt. You should record your own welcome prompt to customize your 
automated attendant for the specific role that it is to fulfill for your organization.
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You can use any sound recording software to record the welcome prompt if the 
software can save the prompt in the required file format. You can record a 
different welcome prompt for each instance of Cisco CallManager AutoAttendant 
that you create.

This section describes how to record the welcome prompt by using Microsoft 
Sound Recorder. Save the prompt as a .wav file in CCITT (mu-law) 8-kHz, 8-bit, 
mono format. You must have a microphone and speakers on your system to use 
the software.

Procedure

Step 1 Start the Sound Recorder software; for example, by choosing 
Start> Programs>Accessories> Entertainment>Sound Recorder.

Step 2 Click the Record button and say your greeting into the microphone.

Step 3 When you finish the greeting, click the Stop button.

Step 4 To check your greeting

a. Click the Rewind button (also called “Seek to Start”) or drag the slider back 
to the beginning of the recording.

b. To play the recording, click the Play button. Rerecord your greeting until you 
are satisfied.

Step 5 When you are satisfied with your greeting, save the recording:

a. Choose File> Save As.

b. To set the recording options, click Change. (You can also do this by choosing 
Properties from the Sound Recorder File menu). Choose these options:

• Name—Choose [untitled].

• Format—Choose CCITT u-law.

• Attributes—Choose 8.000 kHz, 8 Bit, Mono 7 kb/sec.

You can save these settings to reuse later by clicking Save As and entering a 
name for the format.

c. To close the Sound Selection window, click OK.

d. Browse to the directory where you want to save the file, enter a file name, and 
click Save. Use the .wav file extension.
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Related Topics

• Configuring Prompts, page 7-25

• Configuring the Welcome Prompt, page 7-27

Configuring the Welcome Prompt

Cisco CallManager AutoAttendant can only use welcome prompts that are stored 
on the Cisco CRA Engine. To configure your automated attendant to use a 
customized welcome prompt, you must upload it to the server and configure the 
appropriate Cisco CallManager AutoAttendant instance.

Tip To start Cisco CRA Administration, open http://servername/AppAdmin in your 
web browser, where servername is the DNS name or IP address of the application 
server. Click Help for detailed information on using the interface.

Procedure

Step 1 From the Cisco CRA Administration main menu, choose Tools > Prompt 
Management.

The Prompt Management window displays.

Note Before adding a new user prompt, you need to Create a .wav file source 
folder. Use the Create Folder function to create a source folder.

Step 2 From the Language Directory drop-down menu, choose the specific language and 
directory where the prompt should be uploaded.

Step 3 To add a new prompt

a. Click the Add a new prompt hyperlink.

The the Prompt File Name dialog box displays.

b. To open the Choose file dialog box, click Browse.

c. Navigate to the source .wav file folder and double-click the .wav file that you 
want to upload to the Cisco CRA Engine.

d. Confirm your choice in the Destination File Name field by clicking in the 
field.
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e. To upload the .wav file, click Upload.

The system displays a message that the upload was successful.

f. Click the Return to Prompt Management hyperlink.

The window refreshes, and the file displays in the Prompt Management 
window.

Step 4 To replace an existing prompt with a new .wav file 

a. Click the arrow in the Upload column for the prompt that you want to modify.

The Choose file dialog box opens.

b. Enter the name of the .wav file that you want to use to replace the existing 
prompt.

c. When you have provided the .wav file and prompt name information, click 
Upload.

Related Topics

• Recording the Welcome Prompt, page 7-25

• Uploading a Spoken Name, page 7-28

Uploading a Spoken Name

By default, Cisco CallManager AutoAttendant spells out the names of parties 
when it asks a caller to choose between more than one matching name or to 
confirm that the user wants to connect to the party. You can upload spoken names 
to the system, so your automated attendant plays spoken names rather than 
spelling them out.

To upload Cisco CallManager Spoken Names in your users voices, upload the 
corresponding .wav files into the directory by performing the following steps:

Procedure

Step 1 Ask users to record their names in the manner that is described in the “Recording 
the Welcome Prompt” section on page 7-25, and to save their files as userId.wav, 
where userId is their user name.

Step 2 Connect to Cisco CRA Administration.
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Step 3 From the Cisco CRA Administration main menu, choose Tools > Spoken Name 
Upload.

The Spoken Name Prompt Upload window displays.

Step 4 In the User Id* field, enter a User ID.

Step 5 Enter the path that contains the Spoken Name .wav file in the Spoken Name 
(.wav)* field or click Browse and navigate to the directory that contains the 
Spoken Name .wav file.

Step 6 To upload the file, click Upload.

Related Topic

Configuring the Welcome Prompt, page 7-27

Managing Cisco CallManager AutoAttendant
Use Cisco CRA Administration to manage Cisco CallManager AutoAttendant. 
Use the online help to learn how to use the interface and perform these tasks. 
Table 7-5 describes the management tasks.

Table 7-5 Managing Cisco CallManager AutoAttendant

Task Purpose
Commands (from the Cisco CRA 
Administration main window)

Start and stop the 
Cisco CRA Engine

Make sure that the engine is 
running for your automated 
attendant to work. You can stop 
and restart the engine to help 
resolve or troubleshoot 
problems.

Choose System > Engine.

Change the Cisco CRA 
Engine configuration

Modify the engine configuration 
to resolve problems.

Choose System > Engine; then, click 
Engine Configuration. See the 
online help for detailed information.

Set up trace files Set up trace files to collect 
troubleshooting information.

Choose System > Engine; then, click 
Trace Configuration. See the online 
help for detailed information.
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Related Topics

• Configuring Cisco CallManager AutoAttendant, page 7-7

• Troubleshooting Cisco CallManager AutoAttendant, page A-29

View trace files View trace files to see the results 
of your tracing.

Choose System > Engine; then, click 
Trace Files. Choose the trace file 
that you created.

Monitor performance in real 
time

You can monitor the 
performance of the system while 
it is running if you install the 
real-time reporting monitor.

Choose Tools > Real Time 
Reporting. See the online help for 
information on installing and using 
Real Time Reporting.

Table 7-5 Managing Cisco CallManager AutoAttendant (continued)

Task Purpose
Commands (from the Cisco CRA 
Administration main window)
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