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CHAPTER 5

Cisco CallManager AutoAttendant

Cisco CallManager AutoAttendant, a simple automated attendant, allows callers
to locate people in your organization without talking to a receptionist. You can
customi ze the prompts that are played for the caller, but you cannot customize
how the software interacts with the customer. Cisco CallManager AutoAttendant
comes bundled with the CallManager CDs on the extended services CD. This
version of Cisco CallManager AutoAttendant has a4-CT]I port limit. If you need
afully configurable automated attendant, you will need to purchase Cisco |P
Interactive Voice Response (IP IVR), one of the Cisco Customer Response
Applications.

This chapter describes Cisco CallManager AutoAttendant that is running on
Cisco CallManager 3.3(3) and Cisco Customer Response Applications 3.0.

For documentation on earlier versions of Cisco CallManager AutoAttendant, go
to the following web site:
http://www.cisco.com/univercd/cc/td/doc/product/voice/sw_ap_to/ip_auto/
index.htm

Use the following topics to understand, install, configure, and manage
Cisco CallManager AutoAttendant:

« Understanding Cisco CallManager AutoAttendant, page 5-2

« Installing and Upgrading Cisco CallManager AutoAttendant, page 5-5
» Configuring Cisco CallManager AutoAttendant, page 5-8

» Managing Cisco CallManager AutoAttendant, page 5-29
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Understanding Cisco CallManager AutoAttendant

Cisco CallManager AutoAttendant, illustrated in Figure 5-1, works with

Cisco CallManager to receive calls on specific telephone extensions. The
software interacts with the caller and allows the caller to search for and select the
extension of the party (in your organization) that the caller istrying to reach.

Figure 5-1 Using Cisco CallManager AutoAttendant
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This section provides an introduction to Cisco CallManager AutoAttendant:
» Cisco CallManager AutoAttendant Overview, page 5-3
» Components of Cisco CallManager AutoAttendant, page 5-4
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Understanding Cisco CallManager AutoAttendant [l

Cisco CallManager AutoAttendant Overview

Cisco CallManager AutoAttendant provides the following script:
- Answersacall
» Plays a user-configurable welcome prompt
» Playsamain menu prompt that asksthe caller to perform one of three actions:
— Press 0O for the operator.
— Press 1 to enter an extension number.
— Press 2 to spell by name.

« |If the caller chooses to spell by name (option 2), the system compares the
letters that are entered with the names that are configured to the available
extensions.

— If amatch exists, the system announces atransfer to the matched user and
waitsfor up to 2 seconds for the caller to pressany DTMF key to stop the
transfer. If the caller does not stop the transfer, the system performs an
explicit confirmation: it prompts the user for confirmation of the name
and transfers the call to that user’s primary extension.

— If more than one match occurs, the system prompts the caller to choose
the correct extension.

— If too many matches occur, the system prompts the caller to enter more
characters.

« When the caller has specified the destination, the system transfers the call.

— If thelineisbusy or not in service, the system informs the caller
accordingly and replays the main menu prompt.

Related Topic:
Components of Cisco CallManager AutoAttendant, page 5-4

Cisco CallManager Features and Services Guide
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Components of Cisco CallManager AutoAttendant

The Cisco Customer Response Platform provides the components that are
required to run Cisco CallManager AutoAttendant. The platform provides a
multimedia (voice/data/Web) | P-enabled customer care application environment.

Cisco CallManager AutoAttendant uses four main components of the
Cisco Customer Response Platform:

- Gateway—Connects the enterprise | P telephony network to the Public
Switched Telephone Network (PSTN) and to other private tel ephone systems
such as Public Branch Exchange (PBX). You must purchase gateways
separately.

» Cisco CallManager Server—Provides the features that are required to
implement | P phones, manage gateways, provides failover and redundancy
service for the telephony system, and directs voice over IP traffic to the
Cisco Customer Response Application (Cisco CRA) system. You must
purchase Cisco CallManager separately.

» Cisco IP Telephony Directory—Provides the repository for configuration
information and Cisco CRA application scripts. The repository acts as the
subdirectory that stores scripts. Cisco CallManager AutoAttendant comes
with a predefined script that you cannot alter. The Cisco CallManager
AutoAttendant package includes the Cisco I P Telephony Directory.

» Cisco CRA Server—Contains the Cisco CRA Engine that runs
Cisco CallManager AutoAttendant. The Cisco CallManager AutoAttendant
package includes the Cisco CRA Server and Engine.

You must install Cisco CallManager AutoAttendant co-resident on the same
server as Cisco CallManager.

For more information about the Cisco Customer Response Platform, refer to the
Cisco Customer Response Applications Administrator Guide.

Related Topic
Installing and Upgrading Cisco CallManager AutoAttendant, page 5-5

Cisco CallManager Features and Services Guide
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Installing and Upgrading Cisco CallManager
AutoAttendant

Use these topics to install or upgrade Cisco CallManager AutoAttendant:
» Hardware and Software Requirements, page 5-5.
- Installing or Upgrading Cisco CallManager AutoAttendant, page 5-6.

Hardware and Software Requirements

Before you install this version of Cisco CallManager AutoAttendant, you must
have a functioning voice over | P system. You must have installed and configured
Cisco CallManager 3.3 or later. This software manages the telephony system.

Cisco CallManager AutoAttendant runs on the Cisco Media Convergence Server
(Cisco MCS) platform or on a Cisco-certified server such as the Compag DL 320
and DL 380 and the IBM-330 and IBM-340. The server must be running
Microsoft Windows 2000.

You must install Cisco CallManager AutoAttendant co-resident on the same
server as Cisco CallManager.

Cisco CallManager AutoAttendant has the following requirements:
» Theinstallation of Cisco CallManager AutoAttendant requires 275MB.

» Running Cisco CallManager AutoAttendant requires 512MB for the
Cisco MCS 7820 series (7820, 7822, and 7825) and 1GB for the Cisco MCS
7830 series (7830 and 7835).

Cisco CallManager Features and Services Guide
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Installing or Upgrading Cisco CallManager AutoAttendant

Install Cisco CallManager and Windows 2000 before you install

Cisco CallManager AutoAttendant. For more information, refer to Installing
Cisco CallManager and Operating System Installation Procedures for the Cisco
Media Convergence Server (MCS).

You must configure proxy settings for Internet Explorer and verify that you can
browse to internal and external web sites. For details on configuring your proxy
settings, contact your network administrator.

Before You Begin

Ensure that you have met all pre-installation requirements that are described in
Hardware and Software Requirements, page 5-5

These topics describe how to install Cisco CallManager AutoAttendant:
« Installing Cisco CallManager AutoAttendant, page 5-6
» Upgrading or Reinstalling Cisco CallManager AutoAttendant, page 5-7.

Installing Cisco CallManager AutoAttendant

Step 1
Step 2

Use this section to install Cisco CallManager AutoAttendant for the first time.

Procedure

Start the installation program and follow the on-screen instructions.

Configure Cisco CallManager for Cisco CallManager AutoAttendant, as
explained in Configuring Cisco CallManager, page 5-9.

Related Topics
» Hardware and Software Requirements, page 5-5

» Upgrading or Reinstalling Cisco CallManager AutoAttendant, page 5-7
» Configuring Cisco CallManager AutoAttendant, page 5-8

Cisco CallManager Features and Services Guide
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Upgrading or Reinstalling Cisco CallManager AutoAttendant

This procedure describes how to upgrade to Cisco CallManager AutoAttendant
from an earlier version of Cisco CallManager AutoAttendant or

Cisco CallManager Extended Services or how to reinstall the current version of
Cisco CallManager AutoAttendant.

Procedure

Stepl  On the Cisco CallManager server, choose Start>Programs> Cisco
CRA Administrator >Application Administrator.

Enter your user name and password and click OK.
Step2  Follow the on-screen instructions.
You do not need to reboot after this procedure.

Related Topics
- Hardware and Software Requirements, page 5-5

» Configuring Cisco CallManager AutoAttendant, page 5-8

Cisco CallManager Features and Services Guide
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Configuring Cisco CallManager AutoAttendant

These topics describe how to configure Cisco CallManager and the
Cisco Customer Response Application Engine (Cisco CRA Engine) in
preparation for deploying Cisco CallManager AutoAttendant.

Perform the following procedures to configure Cisco CallManager
AutoAttendant:

1. Configure Cisco CallManager to create the telephone number and other
telephony entities that Cisco CallManager AutoAttendant requires. See
Configuring Cisco CallManager, page 5-9.

2. Configure the Cisco Customer Response Applications (Cisco CRA) Engine.
You must install and configure Cisco CRA before you can use
Cisco CallManager AutoAttendant. The Cisco CRA Engine controls the
software and its connection to the telephony system. See Configuring the
Cisco CRA Engine, page 5-13

3. Customize Cisco CallManager AutoAttendant, so its prompts are meaningful
to how you are using the automated attendant. See Customizing
Cisco CallManager AutoAttendant, page 5-23

Cisco CallManager Features and Services Guide
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Configuring Cisco CallManager

Before you can use Cisco CallManager AutoAttendant, you must configure
Cisco CallManager:

1.

Create a CTI route point. This action specifies the telephone number that
people will call to use Cisco CallManager AutoAttendant. See Adding CTI
Route Points in Cisco CallManager, page 5-9.

Create CTI portsfor use by the CTI route point. The number of portsthat you
create determines the number of simultaneous callers that can use

Cisco CallManager AutoAttendant. The version of

Cisco CallManager AutoAttendant, that comes bundled with

Cisco CallManager has a 4-port limit. See Adding CTI Portsin

Cisco CallManager, page 5-11.

Create a Cisco CallManager user for Cisco CallManager AutoAttendant and
associate the CTI route pointsand CTI ports that you created to this user. See
Creating a Cisco CallManager User for Cisco CallManager AutoAttendant,
page 5-12.

These topics assume that you know how to use Cisco CallManager. For more
information about Cisco CallManager, refer to the Cisco CallManager
Administration Guide and the Cisco CallManager System Guide.

Adding CTI Route Points in Cisco CallManager

Create a CTI route point in Cisco CallManager for Cisco CallManager
AutoAttendant use. This route point specifies the telephone number that callers
will call to use the automated attendant.

Procedure

Stepl  In Cisco CallManager, choose Device>CTI Route Point.

The Find and List CTI Route Points page displays.
Step2  Click Add anew CTI Route Point.
The CTI Route Point Configuration page displays.

[ 78-15311-01
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Step 3

Step 4

Step 5

Step 6

Fill in the CTI route point properties:

« Enter a unique name, such as AutoAttendant, in the Device Name field to
identify this as the Cisco CallManager AutoAttendant number.

« From the Device Pool menu, choose the appropriate device pool.
To add the new CTI route point, click Insert .

Cisco CallManager adds the route point and asks whether you want to add a
directory number for line 1. To add line 1, click OK.

Cisco CallManager opens the Directory Number configuration page.

Inthe Directory Number field, enter the directory number for this CTI route point.
This number specifies the number that callers will dial to reach this CTI route
point (for example, 4000). You can also fill in other fields as appropriate for your
telephony network.

Click Insert.

Cisco CallManager assigns the directory number to the current device and asks
you if you want to return to the current device configuration page. Click OK to
return to the current device configuration page.

Create only one line for the device.

Related Topics
» Configuring Cisco CallManager, page 5-9
» Adding CTI Portsin Cisco CallManager, page 5-11

Cisco CallManager Features and Services Guide
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Configuring Cisco CallManager AutoAttendant

Adding CTI Ports in Cisco CallManager

Step 1

Step 2

Step 3

Step 4

Step 5

Step 6

Step 7

Create CTI ports for use with the Cisco CallManager AutoAttendant CTI route
point. The number of portsthat you create determines the number of simultaneous
callersthat can use your automated attendant. If all ports arein use when acaller
calls, the caller receives a busy signal.

Procedure

In Cisco CallManager, choose Device>Phone.

Cisco CallManager opens the Find and List Phones page.

Click Add a New Phone.

Cisco CallManager opens the Add a New Phone page.

Choose CTI Port for Phone Type and click Next.

Cisco CallManager opens the Phone Configuration page.

Configure the CTI Port and enter at minimum this information:
« Device Name—Enter something meaningful to you, for example, CT14001.
» Device Pool—Choose an appropriate device pool.

Click Insert.

Cisco CallManager creates the CTI port and asks whether you want to add a
directory number for line 1. Click OK. Cisco CallManager opens the Directory
Number Configuration page.

In the Directory Number field, enter an unused extension number for the port,
such as 4001.

Click Insert.

Cisco CallManager assigns the directory number to the current device. Click OK
to return to the device configuration page.

Repeat the procedureto create each CTI port that you require. Create only oneline
for each CTI port.
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Related Topics
» Adding CTI Route Pointsin Cisco CallManager, page 5-9

» Creating a Cisco CallManager User for Cisco CallManager AutoAttendant,
page 5-12

Creating a Cisco CallManager User for Cisco CallManager AutoAttendant

Step 1

Step 2

Step 3

Step 4

Step 5

Create a user for Cisco CallManager AutoAttendant in Cisco CallManager.
Cisco CallManager AutoAttendant uses this account to gain access to
Cisco CallManager and control the CTI route points and CTI ports that you
defined for its use.

Procedure

In Cisco CallManager, choose User >Add a New User.
Cisco CallManager opens the User Configuration window.
Complete the following required fields:
» First Name—Use a descriptive name such as “Automated.”
» Last Name—Use a descriptive name such as “Attendant.”
» UserID—Use a descriptive name such as “AutoAttendant.”

» User Password and Confirm Password—Enter a password and enter it again
for confirmation.

« PIN and Confirm PIN—Enter a PIN and enter it again for confirmation.
- Enable CTI Application Use—Check this check-box.

To create the user, click I nsert.

Cisco CallManager adds the user.

In the left column, click Device Association.

Cisco CallManager opens the Device Association subpage of the User
Information page.

Enter search criteriato list the desired route points and CTI ports or enter nothing
to list all devices and click Select Devices to list the devices.

Cisco CallManager Features and Services Guide
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Configuring Cisco CallManager AutoAttendant

Step6  Inthelist that Cisco CallManager produces, choose these devices:

- TheCTI route point that was created for the automated attendant. See Adding
CTI Route Points in Cisco CallManager, page 5-9, for more information.

« All CTI portsthat were created for Cisco CallManager AutoAttendant’s use.
See Adding CTI Portsin Cisco CallManager, page 5-11, for more
information.

Make sure you click the No Primary Extension radio button.
Step7  To save your changes, click Update Selected.

Related Topics
» Adding CTI Portsin Cisco CallManager, page 5-11

« Configuring the Cisco CRA Engine, page 5-13

Configuring the Cisco CRAENgine

After you have configured Cisco CallManager for Cisco CallManager
AutoAttendant, configure the Cisco Customer Response Application
(Cisco CRA) Engine to communicate with Cisco CallManager and the
Cisco | P Telephony Directory. To do this, you must

1. Configure the IP Telephony Directory, so Cisco CRA can use it. You may
have already completed this configuration when you installed Cisco CRA.
See Logging In and Configuring Directory Information, page 5-14, for more
information.

2. Configure the Cisco CRA Engine JTAPI subsystem to use the
Cisco CallManager user that you created for Cisco CallManager
AutoAttendant. See Configuring the JTAPI Subsystem on the
Cisco Customer Response Application Engine, page 5-18, for more
information.

3. Add aCTI port group in the Cisco CRA Engine's JTAPI subsystem that
containsthe CTI portsthat you created for Cisco CallManager AutoAttendant
use. See Adding a CTI Port Group, page 5-19, for more information.

Cisco CallManager Features and Services Guide
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4, Add the Cisco CallManager AutoAttendant application to the Cisco CRA
Engine. See Adding a New Cisco CallManager AutoAttendant, page 5-22,
for more information.

These topics only cover the basics of using and configuring Cisco CRA. See the
online help for more detailed information.

Related Topic:
Logging In and Configuring Directory Information, page 5-14

Logging In and Configuring Directory Information

The Cisco |P Telephony Directory server stores two types of information that are
used by the Cisco Customer Response Application (Cisco CRA) Engine. First, it
stores directory information, which includes CTI port and routing configurations.
Second, it contains the repository subdirectory, which stores the applications that
are used with the Cisco CRA Engine.

Cisco recommends that you use one | P Telephony Directory with
Cisco CallManager AutoAttendant rather than split the directory information and
repository subdirectories onto separate servers.

Tip To start CiscoCRA Application Administration, open
http://servername/AppAdmin in your web browser, where servernameisthe DNS
name or | P address of the application server. Click Help for detailed information
on using the interface.

To establish the directory server settings on anew CRA server, perform the following
steps:

Procedure

Stepl  Thefirst timethat you log in to the CRA server, enter the username
Administrator and the password ciscocisco. Click Log On.

S

Note  Thelogin name and password are case-sensitive. Enter them exactly as
shown.

Cisco CallManager Features and Services Guide
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~

Note

Configuring Cisco CallManager AutoAttendant

Enter the specified username and password for first time setup process

only.

The Cisco CRA Administrator Setup page displays.

Step2  Click Setup.
The Directory Setup window displays.
Step3  Enter the directory configuration information as described in Table 5-1.
Table 5-1  Directory Configuration Defaults
Field Description Default for DC Directory

Directory hostname

Hostname or | P address of the Cisco IP
Telephony Directory server where the profile
resides or will reside with the CRA engine
profile.

Directory port number

Port number of the Cisco IP Telephony
Directory.

8404

Directory user (DN)

The user name (also called the distinguished

cn=Directory Manager,

name) that is configured on the directory server |o=cisco.com.
for the user that has permission to modify the
Cisco | P Telephony tree and object entries.
Directory password Password for the Directory user. ciscocisco
Base Context Branch of the Cisco | P Telephony Directory tree |o=cisco.com
that contains the Cisco configuration
information.
User Base The branch of the Cisco I P Telephony Directory |ou=Users, o=cisco.com
tree that contains user information.
Server Type Type of LDAP directory, such as MS Active DC Directory

Directory, Netscape Directory Server 4.0, or DC
Directory.

Configuration Profile
Name

Profile name that identifies this CRA server
configuration or repository.

[ 78-15311-01
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Step 4

Step 5

Step 6

Step 7
Step 8

Step 9

Step 10

Step 11

Step 12

Click Next.
The second Directory Setup window displays.

To configure the Directory setup for Netscape, Active Directory and Other,
perform the following step:

From the Server Type drop-down arrow, choose the appropriate directory (for
example, Netscape).

The following fields adjust to the new information:
- Directory User
« Base Context
« User Base

Click Edit and enter a new profile or use the Profile Name drop-down arrow to
choose a profile.

To enter the new profile, click OK.
Click Next.
The third Directory Setup window displays.

Accept the default setting: Use the default Repository profile to create the
repository profile on the same server and with the same name.

-Or

If you want to maintain separate profiles for your configuration and repository,
click the Use a different Repository profile radio button. When this option is
chosen, the system prompts the user for directory information for the repository
profile, which provides the windows to capture the directory information for the
repository.

The Repository Configuration window appears. Complete these fields with the
configuration information that is appropriate for your repository directory.

Click OK.

The User Maintenance window displays. Use this window to assign access levels
to an Administrator.

In the User Maintenance window, choose the Group drop-down arrow and then
choose Administrator.

l_ Cisco CallManager Features and Services Guide
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Step 13

A

Configuring Cisco CallManager AutoAttendant

From the CMUsers list box, choose an available CM User and click < to move a
user to the CRA Administrator/Supervisor list box.

If the steps are correctly followed, a (Administrator) label displays after the user
name.

Caution

Step 14

Step 15

To update the system, you must choose at |east one Administrator.

Click Finish to complete the process and initialize configuration and repository
profiles.

The Setup window displays your configuration choices.

Log in to the system again using the administrator username and password that
you created.

~

Note The login name, Administrator, and the Password, ciscocisco, no longer
work. Log in using the configured administrator password.

The Cisco Customer Response Applications Administration window displays.

Related Topics
» Configuring the Cisco CRA Engine, page 5-13

« Configuring the JTAPI Subsystem on the Cisco Customer
Response Application Engine, page 5-18
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Configuring the JTAPI Subsystem on the Cisco Customer
Response Application Engine

Tip

Step 1

Step 2

Step 3
Step 4
Step 5

Step 6

After you complete the directory configuration, you must configure the JTAPI
subsystem on the Cisco Customer Response Application Engine

(Cisco CRA Engine). The Cisco CRA Engine uses the JTAPI subsystem to send
and receive calls from Cisco CallManager.

To start CiscoCRA Application Administration, open
http://servername/AppAdmin in your web browser, where servernameisthe DNS
name or |P address of the application server. Click Help for detailed information
on using the interface.

Procedure

From the CRA Administration main menu, choose Subsystems > JTAPI.
The JTAPI Configuration window displays.

In the JTAPI Provider(s) field, enter the IP address or DNS name of the Cisco
Media Convergence Server (Cisco MCS) that isrunning Cisco CallManager CTI
Manager. You can enter up to two CTI Managers, separated by a space. If thefirst
CTI Manager becomes unavailable, the second one connects and maintains calls.

In the UserID field, enter the Cisco CallManager UserID (for example, “JTAPI").
In the Password field, enter the password that you defined for this UserID.

To apply changes, click Update.

The following message appears:

“JTAPI Subsystem configured successfully!!”

To close the dialog box, click OK.

Related Topics
- Logging In and Configuring Directory Information, page 5-14

» Adding aCTI Port Group, page 5-19

Cisco CallManager Features and Services Guide
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Adding a CTl Port Group

Tip

Step 1

Step 2
Step 3

Step 4

Step 5

Step 6
Step 7

Identify the CTI portsthat you created for Cisco CallManager AutoAttendant use
on the JTAPI Configuration page in the Cisco CRA Application Administration
configuration. These ports comprise a CTl port group.

To start CiscoCRA Application Administration, open
http://servername/AppAdminin your web browser, where servernameisthe DNS
name or |P address of the application server. Click Help for detailed information
on using the interface.

Procedure

From the CRA Administration main window, choose Subsystems > JTAPI.
The JTAPI Configuration window displays.

S

Note  Toaccessthe CTI Portswi ndow, you must ensure that the CRA Engineis
running.

To apply changes and restart the engine, click Update.

In the left column, click the CTI Port Groups hyperlink.

The JTAPI Call Control Group window displays.

Click the Add a New JTAPI Call Control Groups hyperlink.

The second JTAPI Call Control Group Configuration window displays.

Accept the automatic group ID or enter agroup ID in the Group ID field. The
Group ID correspondsto the trunk group number that is reported to the |ICM when
the CRA server is part of the Cisco IPCC solution.

To automatically populate the Description field, press the Tab key.
Click Associate CTI Ports.
The Please assign CTI Ports for this Group window displays.

[ 78-15311-01
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Step8  Inthe Directory Number column, click the check boxesthat containsthe directory
numbers that you established in Adding CTI Portsin Cisco CallManager,
page 5-11.

~

Note  You must complete configuration of portsinthe Cisco Call Manager first,
before assigning a user port to a group.

Step9  To add the port to the list of available CTI ports and close the window, click
Update.

Step10 Click Add.
The Call Control Group appears in the Group ID column.

Related Topics:

» Configuring the JTAPI Subsystem on the Cisco Customer
Response Application Engine, page 5-18

» Adding a New Cisco CallManager AutoAttendant, page 5-22

Provisioning Cisco Media Termination Subsystem

You can choose different types of media, from a simple type of media capable of
supporting promptsand DTMF (Cisco M edia Termination) to amore complex and
rich type of media capable of supporting speech recognition in addition to
promptsand DTMFs. It iseven possibleto provision callswithout media. Because
of these capabilities, you must provision media manually. Each call requires both
a CTI port and a media channel for the system to be backward compatible or to
support mediainteractions.

Furthermore, media resources are licensed and sold as I VR ports. You can
provision more channelsthan you are licensed for; however, at run-time, licensing
will be enforced to prevent calls from being accepted by the system, as thiswould
violate your licensing agreements.

Call Control Groups, multiple CMT Dialog Groups, and Nuance ASR Dialog
groups can be provisioned to allow for the sharing of resources between different
applications. In addition, specific sets of resources can be primarily used by
special applications.

Cisco CallManager Features and Services Guide
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Step 1
Step 2

Step 3

Step 4

Step 5
Step 6

Step 7

Configuring Cisco CallManager AutoAttendant

This can be done when configuring a JTAPI Trigger. For more information, see
the Cisco Customer Response Applications Administrator Guide.

Provisioning CMT Dialog Groups

The Cisco CRA server uses the Real-Time Transport Protocol (RTP) to send and
receive media packets over the IP network. To ensure that the CRA Engine can
communicate with your Cisco | P Telephony system, you need to configure the
RTP ports that the CRA Engine will use to send and receive RTP data.

To configure a CMT Dialog, perform the following steps:

Procedure

Connect to the Cisco CRA Administration pages.

From the CRA Administration main menu, choose Subsystems > Cisco M edia.
The Cisco Media Termination Dialog Group Configuration window appears.
Click the Add a New CMT Dialog Group hyperlink.

The second Cisco Media Termination Dialog Group Configuration window
appears.

Accept the automatic group ID or enter agroup ID in the Group ID field.

>

Note  This Group ID must be unique within all media group identifiers,
including ASR.

Press the Tab key to automatically populate the Description field.

Enter a maximum amount of channels available for the group in the Maximum
Number Of Channelsfield.

Click Add.
The Cisco Media Termination Dialog Group Configuration window appears.

[ 78-15311-01
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Adding a New Cisco CallManager AutoAttendant

Tip

Step 1

Step 2

Step 3

Step 4

Step 5
Step 6

After you have configured the JTAPI subsystem on the Cisco CRA Engine, you
can use one of the sample scripts to create an application and start the

Cisco CRA Engine. To add a new Cisco CallManager AutoAttendant, use this
procedure.

To start CiscoCRA Application Administration, open
http://servername/AppAdminin your web browser, where servernameisthe DNS
name or |P address of the application server. Click Help for detailed information
on using the interface.

Procedure

From the CRA Administration main menu, choose Applications > Configure
Applications.

Cisco CRA Application Administration opens the Application Configuration
page.
Click the Add New Application link on the Application Configuration page.

The Add a New Application window displays.

Click Next.

The Cisco Script Application window displays.

Enter the name of the application in the Name field.

To automatically populate the Description field, press the Tab key.

Enter aunique ID inthe ID field. The ID getsreported in Historical Reporting to
identify this application.

~

Note  The system automatically generates an ID; therefore, you can use the ID
that is contained within the field or erase the value and enter a new one.

Cisco CallManager Features and Services Guide
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Step 7

Step 8

Step 9

Step 10

Step 11

Configuring Cisco CallManager AutoAttendant

In the Maximum Number of Sessions field, enter the maximum number of
sessions that can be running this application simultaneously.

~

Note  Depending on the Script and Default Script selection, the window may
refresh and provide additional fields and drop-down menu options.

From the Script drop-down arrow, choose the script that will be running the
application. The script for Cisco CallManager AutoAttendant is aa.aef.

From the Default Script drop-down menu, accept System Default. The default
script executes when an error occurs with the configured application script.

Click Add.

The following message displays:

“The operation has been executed successfully”
To close the dialog box, click OK.

Related Topics
« Adding a New Cisco CallManager AutoAttendant, page 5-22

« Customizing Cisco CallManager AutoAttendant, page 5-23

Customizing Cisco CallManager AutoAttendant

Cisco CallManager AutoAttendant comes with a prerecorded welcome prompt.
By default, it spells out user names; it does not attempt to pronounce names. You
can customize your automated attendant by adding your own welcome prompt and
recordings of your user spoken names. These topics describe how to customize
Cisco CallManager AutoAttendant:

- Modifying an Instance of Cisco CallManager AutoAttendant, page 5-24
» Configuring Prompts, page 5-25

[ 78-15311-01
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Modifying an Instance of Cisco CallManager AutoAttendant

This section describes how to modify Cisco CallManager AutoAttendant settings.

Je

Tip To start CiscoCRA Application Administration, open
http://servername/AppAdminin your web browser, where servernameisthe DNS
name or |P address of the application server. Click Help for detailed information
on using the interface.

Procedure

Stepl  From the CRA Administration main window, choose Applications > Configure
Applications.

Step2  Click on the instance of Cisco CallManager AutoAttendant that you want to
configure.

Step3  You can change these settings:

Description—The description of the application.

ID—The application ID. The ID gets reported in Historical Reporting to
identify this application.

Maximum Number of Sessions—The maximum number of simultaneous
callers that can use this automated attendant. This number should not exceed
the number of CTI Ports that were created for its use.

Enabled—Whether the automated attendant is running.
Script—The script that will be running the application.

welcomePrompt—The prompt that initially plays when the automated
attendant answers the phone. See Configuring the Welcome Prompt,
page 5-27, for information about how to upload prompts.

MaxRetry—The number of times that a caller is returned to the AA script's
main menu if they encounter an error. The default is 3.

operExtn—The extension of the phone that the operator will use.

Default Script—The script that executes when an error occurs with the
configured application script.

Cisco CallManager Features and Services Guide
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Step4  To save your changes, click Update.

Related Topics
e Adding aCTlI Port Group, page 5-19

- Configuring Prompts, page 5-25

Configuring Prompts

Through the Cisco CRA Application Administration’s Media Configuration page,
you can modify the promptsthat Cisco CallManager AutoAttendant uses. You can
also upload spoken names for each person in the organization, so callers receive
spoken names rather than spelled-out names when the automated attendant is
asking the caller to confirm which party they want.

These topics describe how to customize these features:
» Recording the Welcome Prompt, page 5-25
» Configuring the Welcome Prompt, page 5-27
» Uploading a Spoken Name, page 5-28

Recording the Welcome Prompt

Cisco CallManager AutoAttendant comes with a prerecorded, generic welcome
prompt. You should record your own welcome prompt to customize your
automated attendant for the specific role that it isto fulfill for your organization.
You can use any sound recording software to record the welcome prompt if the
software can save the prompt in the required file format. You can record a
different welcome prompt for each instance of Cisco CallManager AutoAttendant
that you create.

Thistopic describes how to record the wel come prompt by using Microsoft Sound
Recorder. Save the prompt asa.wav filein CCITT (mu -law) 8-kHz, 8-bit, mono
format. You must have a microphone and speakers on your system to use the
software.

Cisco CallManager Features and Services Guide
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Step 1

Step 2
Step 3
Step 4

Step 5

Procedure

Start the Sound Recorder software; for example, by choosing
Start>Programs>Accessories>Entertainment > Sound Recorder.

Click the Record button and say your greeting into the microphone.
Click the Stop button when you finish the greeting.
To check your greeting

a. Click the Rewind button (also called “ Seek to Start”) or drag the slider back
to the beginning of the recording.

b. Click the Play button to play the recording. Rerecord your greeting until you
are satisfied.

When you are satisfied with your greeting, save the recording:
a. Choose File>Save As.

b. To settherecording options, click Change. (You can also do this by choosing
Properties from the Sound Recorder File menu). Choose these options:

» Name—Choose [untitled].
« Format—Choose CCITT u-law.
» Attributes—Choose 8.000 kHz, 8 Bit, Mono 7 kb/sec.

You can save these settings to reuse later by clicking Save As and entering a
name for the format.

c. To close the Sound Selection window, click OK.

d. Browsetothedirectory whereyou want to save thefile, enter afile name, and
click Save. Use the .wav file extension.

Related Topics
» Configuring Prompts, page 5-25

- Configuring the Welcome Prompt, page 5-27
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Tip

Step 1

Step 2

Step 3

Configuring Cisco CallManager AutoAttendant

Configuring the Welcome Prompt

Cisco CallManager AutoAttendant can only use welcome prompts that are stored
on the Cisco CRA Engine. To configure your automated attendant to use a
customized welcome prompt, you must upload it to the server and configure the
appropriate Cisco CallManager AutoAttendant instance.

To start CiscoCRA Application Administration, open
http://servername/AppAdmin in your web browser, where servernameisthe DNS
name or | P address of the application server. Click Help for detailed information
on using the interface.

Procedure

From the CRA Administration main menu, choose Tools > Prompt
M anagement.

The Prompt Management window displays.

~

Note  Before addi ng a new user prompt, you need to Create a .wav file source
folder. Use the Create Folder to create a source folder.

From the Language Directory drop-down menu, choose the specific language and
directory where the prompt should be uploaded.

To add a new prompt
a. Click the Add a new prompt hyperlink.
The the Prompt File Name dialog box displays.
b. To open the Choose file dialog box, Click Browse...

c. Navigateto the source .wav file folder and double-click the .wav file that you
want to upload to the Cisco CRA Engine.

d. Confirm your choice in the Destination File Name field by clicking in the
field.

e. To upload the .wav file, click Upload.
The system displays a message that the upload was successful.

[ 78-15311-01
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Step 4

Step 1

Step 2
Step 3

f. Click the Return to Prompt Management hyperlink.

The window refreshes, and the file displays in the Prompt Management
window.

To replace an existing prompt with a new .wav file
a. Click thearrow inthe Upload column for the prompt that you want to modify.
The Choose file dialog box opens.

b. Enter the name of the .wav file that you want to use to replace the existing
prompt.

¢. When you have provided the .wav file and prompt name information, click
Upload.

Related Topics
» Recording the Welcome Prompt, page 5-25

» Uploading a Spoken Name, page 5-28

Uploading a Spoken Name

By default, Cisco CallManager AutoAttendant spells out the names of parties
when it asks a caller to choose between more than one matching name or to
confirm that the user wants to connect to the party. You can upload spoken names
to the system, so your automated attendant plays spoken names rather than
spelling them out.

To upload Cisco CallManager Spoken Names in your users voices, upload the
corresponding .wav filesinto the directory by performing the following steps:

Procedure

Ask users to record their names in the manner described in Recording the
Welcome Prompt, page 5-25, and to save their files as userld.wav, where userldis
their user name.

Connect to the Cisco CRA Administration pages.

From the CRA Administration main menu, choose Tools > Spoken Name
Upload.

The Spoken Name Prompt Upload window displays.

l_ Cisco CallManager Features and Services Guide
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Step 4
Step 5

In the User 1d* field, enter aUser ID.

Managing Cisco CallManager AutoAttendant

Enter the path that contains the Spoken Name .wav file in the Spoken Name

(.wav)* field or click Browse and navigate to the directory that contains the
Spoken Name .wav file.

Step 6

To upload thefile, click Upload.

Related Topic
Configuring the Welcome Prompt, page 5-27

Managing Cisco CallManager AutoAttendant

Use Cisco CRA Application Administration to manage

Cisco CallManager AutoAttendant. Use the online help to learn how to use the

interface and perform these tasks. Table 5-2 describes the management tasks.

Table 5-2  Managing Cisco CallManager AutoAttendant

Commands (from the Cisco CRA
Task Purpose Administration main page)
Start and stop the Make sure that the engineis Choose System > Engine.

Cisco CRA Engine

running for your automated
attendant to work. You can stop
and restart the engine to help
resolve or troubleshoot
problems.

Change the Cisco CRA
Engine configuration

Modify the engine configuration
to resolve problems.

Engine Configuration. See the

Choose System > Engine; then, click

online help for detailed information.

Set up trace files

Set up trace files to collect
troubleshooting information.

help for detailed information.

Choose System > Engine; then, click
Trace Configuration. Seetheonline
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Table 5-2  Managing Cisco CallManager AutoAttendant (continued)

Commands (from the Cisco CRA

Task Purpose Administration main page)

View trace files View trace filesto seetheresults |Choose System > Engine; then, click
of your tracing. Trace Files. Choose the trace file

that you created.

Monitor performanceinreal |You can monitor the Choose Tools > Real Time

time performance of the system while |Reporting. See the online help for
itisrunning if you install the information on installing and using
real-time reporting monitor. Real Time Reporting.

Related Topics
» Configuring Cisco CallManager AutoAttendant, page 5-8
» Troubleshooting Cisco CallManager AutoAttendant, page A-29
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