
 

Quick Start Guide
INSTALLING AND USING CISCO PHONE CONTROL AND 
PRESENCE 7.1(1) WITH IBM LOTUS SAMETIME

1 Installing the Cisco Phone Control and Presence Plug-in

2 How to Configure the Plug-in

3 How To Use the Plug-in

4 Uninstalling the Plug-In

5 Where to Find More Documentation



 

Revised: June 5, 2009

1  Installing the Cisco Phone Control and Presence Plug-in
If the plug-in does not install automatically, use this procedure to install the plug-in directly. The Cisco Phone Control and 
Presence plug-in can be installed on either:

• IBM Lotus Sametime Connect 7.5.1 with Cumulative Fix 1 (CF1) or later

• IBM Lotus Notes 8.0.1 or later

Before You Begin
• Verify that your operating system is Windows Vista or Windows XP SP2 or later.

• Verify that you have at least 20 MB of free disk space.

• We recommend setting up the auto-push feature for IBM Lotus Sametime Connect, so updates are automatically installed. 
Please see your administrator for details. IBM Lotus Notes does not support auto-push.

• Obtain the URL for the update site hosting the plug-in from your administrator.

Procedure

Step 1 Sign in.

Step 2 Select Tools > Plug-Ins > Install Plug-Ins on the Sametime Connect window.

or

Select File > Application > Install on the IBM Lotus Notes window.

Before you can install a plug-in into a new installation of Lotus Notes, you must perform the following steps: 

a. Locate this file: <notesdir>/framework/rcp/plugin_customization.ini

b. Open the file in an editor and add the following line to the bottom:

com.ibm.notes.branding/enable.update.ui=true

c. Restart IBM Lotus Notes.

The File->Application->Application Management and Install menus will display. 

Step 3 Select Search for new features to install.

Step 4 Select Next.

Note For the next step, we recommend selecting only one update site.

Step 5 If you do not already have the update site configured, perform the applicable step to add an update site:

– For Sametime Connect 8.0.x, select Add Remote Location.

– For Sametime Connect 7.5.1, select New Remote Site.

Step 6 Perform the following steps on the New Update Site window:

– Enter an identifying name for this update site. For example, use Cisco Phone Control.

– In the URL field, enter the complete URL address for the update site hosting the plug-in. If you do not have this 
information, ask your administrator.

Step 7 Select OK.

Step 8 Select Finish on the Install window.

Step 9 Expand the update site tree until you see the Cisco Phone Control and Presence plug-ins in the Updates window.

Step 10 Check the version of Sametime Connect that you are running. For example, if you are running Sametime Connect 8.0.x, 
check Cisco Phone Control and Presence with Lotus Sametime 8.0.x Feature 7.1.1.952.

Step 11 Check Next.
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Step 12 Accept the license agreement.

Step 13 Check Finish to complete the installation.

Step 14 If a feature verification warning appears, select Install All.

Step 15 When the installation is complete, select Yes to restart Sametime Connect.

Troubleshooting Tips
If you select the plug-in for multiple versions of Sametime Connect, an error message is displayed with details, and you cannot 
continue with the installation. To fix the problem, uncheck the feature that is not compatible with your version of 
Sametime Connect. 

2  How to Configure the Plug-in
Your configuration tasks may vary depending on how your administrator enabled the plug-in installation package.

• Configuring the Plug-in to Control Your Desk Phone, page 3

• Configuring the Plug-in to Dial Using Cisco IP Communicator, page 4

• Configuring the Plug-in to Display Phone Availability, page 5

Configuring the Plug-in to Control Your Desk Phone
The Control Desk Phone option, allows you to make, answer, and manage calls in Sametime Connect. Sametime Connect uses 
the phone that you specify to control the call. Once you configure both phone modes, you can toggle between your desk phone 
and Cisco IP Communicator by selecting the Choose Phone Mode button on the toolbar. This allows you to easily switch 
between phone modes.

Before You Begin
• Check with your administrator whether your system supports this feature.

• You cannot configure the plug-in to use the Control Desk Phone and the Dial Using Cisco IP Communicator options at the 
same time.

Procedure

Step 1 Sign in to Sametime Connect.

Step 2 Select File > Preferences on the Sametime Connect window.

Step 3 Expand Cisco in the left pane.

Step 4 Select Phone.

Step 5 Select the Phone Control tab.

Step 6 Select Control Desk Phone.

Step 7 If the Username and Password fields are blank, enter your Cisco Unified Communications Manager user name and 
password.

Step 8 If the Servers field is blank, enter the name or IP address of your Cisco Unified Communications Manager server. If you 
do not have this information, ask your administrator. You can add another server name or IP address using a comma 
to separate the entries. This provides fail-over redundancy, so if one server fails, you are automatically connected to 
second entry listed. Typically, administrators set the Servers field when they prepare the plug-in for installation.

Step 9 If the Voicemail Pilot Number field is blank, enter your voicemail pilot number. If you do not have this information, 
ask your administrator. Typically, administrators set the Voicemail Pilot Number field when they prepare the plug-in 
for installation.

Step 10 Select Search for Phones.
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Step 11 Highlight a device in the Select Phone to Control list. If you have Cisco IP Communicator, you can select it instead of 
a desk phone.

Step 12 Optionally, click Edit Phone Name, and provide a unique user-friendly display name for the device.

Step 13 Select Control this Phone.

Step 14 Select Apply or OK.

Troubleshooting Tips
• If the Phone Control tab is missing, your administrator may have disabled this feature.

• If your phones do not display in the list of available devices, ensure that:

– your user name and password, and Cisco Unified Communications Manager server are correct

– Control Desk Phone is selected

• For the Control Desk Phone option to work, the plug-in must be connected to Cisco Unified Communications Manager. To 
check the connection, select the Cisco > Phone > Troubleshooting tab in Preferences, and verify the status of the Desk Phone 
Control Server.

• Directory services help the plug-in to display the correct information about contacts. For directory services to work, the 
plug-in must be connected to the directory server. To check the connection, select the Cisco > Phone > Troubleshooting tab 
in Preferences, and verify the status of the LDAP Server.

Configuring the Plug-in to Dial Using Cisco IP Communicator
The Dial Using Cisco IP Communicator option allows you to make calls from Sametime Connect. When you place a call, 
Sametime Connect sends the number to Cisco IP Communicator, where you manage the call. You cannot answer calls or make 
conference calls from Sametime Connect. Once you configure both phone modes, you can toggle between your desk phone and 
Cisco IP Communicator by selecting the phone mode switch button on the toolbar. 

Before You Begin
• Check with your administrator whether your system supports this feature.

• You cannot configure the plug-in to use both the Dial Using Cisco IP Communicator and the Control Desk Phone options 
at the same time.

Procedure

Step 1 Sign in to Sametime Connect.

Step 2 Select File > Preferences on the Sametime Connect window.

Step 3 Expand Cisco in the left pane.

Step 4 Select Phone.

Step 5 Select the Phone Control tab.

Step 6 Select Dial Using Cisco IP Communicator.

Step 7 Select Apply or OK.

Troubleshooting Tips
• If the Phone Control tab is missing, your administrator may have configured the installation program to enable this feature 

automatically.

• The Dial Using Cisco IP Communicator option requires Cisco IP Communicator version 2.1(3) or later. To verify the Cisco 
IP Communicator version and status, select Cisco> Phone> Troubleshooting tab in Preferences.
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Configuring the Plug-in to Display Phone Availability
You can configure the plug-in to show the phone availability of your contacts. With this feature, an off-hook icon is displayed 
beside a contact name when that phone is in use.

If the installation program does not enable this feature automatically, complete the following procedure.

Before You Begin
Check with your administrator to see if your system supports this feature.

Procedure

Step 1 Sign in to Sametime Connect.

Step 2 Select File > Preferences on the Sametime Connect window.

Step 3 Expand Cisco in the left pane.

Step 4 Select Phone.

Step 5 Select the Phone Status tab.

Step 6 If the Username and Password fields are blank, enter your user name and password for Cisco Unified Presence.

Step 7 If the Servers field is blank, enter the name or IP address of the Cisco Unified Presence server. If you do not have this 
information, ask your administrator. You can add an additional server name or IP address using a comma to separate 
the entries. This provides fail-over redundancy, so if one server fails, you are automatically connected to second entry 
listed.

Typically, administrators set the Servers field when they prepare the plug-in for installation.

Step 8 Optionally, uncheck Display off-hook status only to show your on-hook status also. This is selected by default.

Step 9 Select Apply or OK.

Troubleshooting Tips
• If the Phone Status tab is missing, your system may not have Cisco Unified Presence or your administrator may have 

disabled this feature.

• To see phone availability of contacts, the plug-in must be connected to the Cisco Unified Presence servers. To check the 
connections, select the Cisco > Phone > Troubleshooting tab in Preferences, and verify the status of the servers. The server 
names are:

– Cisco Unified Presence Server (Login)

– Cisco Unified Presence Server (Presence)

3  How To Use the Plug-in
• Plug-in and Lotus Notes, page 6

• Making Calls from Sametime Connect, page 6

• Working with Incoming Calls from Sametime Connect, page 6

• Working with Calls Already in Progress, page 7

• Making Conference Calls from Sametime Connect, page 7
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Plug-in and Lotus Notes
Cisco Phone Control and Presence with IBM Lotus Sametime can be integrated with IBM Lotus Notes to achieve the following: 

• Sametime is displayed in a pane within the Notes client. 

• Native capabilities of Sametime—as well as those exposed through plug-ins—are either partially or completely accessible 
from other applications within the Notes client for example, right-click to call from “live names” in IBM Lotus Notes email 
or contacts.

Ask your system administrator if you have access to this functionality. Refer to Installing the Cisco Phone Control and Presence 
Plug-in, page 2 for details on activating IBM Lotus Notes menus.

Making Calls from Sametime Connect

Working with Incoming Calls from Sametime Connect

Note If you configured the plug-in to use the Dial Using Cisco IP Communicator option, this section does not apply. 

If you configured the plug-in to use the Control Desk Phone option, a tone and a pop-up window will alert you to an incoming 
call. The window displays the identity of the caller, including a business card, if available.

Troubleshooting Tips
For the voice mail option to work, you must configure your voicemail pilot number correctly. This is set on the Phone Control 
tab in your Cisco preferences.

To Do This

Call someone from the Sametime Connect Contacts list or from 
a chat window.

Right-click a contact, and select Phone Call > [Phone 
number]. Alternatively, select the phone icon on the tool bar, 
and choose [Phone number].

If the phone number is not displayed in the list, choose 
Add/Edit Phone Number, to enter it manually.

If you have phone status configured, off-hook phone icons 
appear for contacts whose phones are currently in use.

Return a call from the voicemail pane. Right-click a message, and select Phone Call > [Phone 
number].

Call any number. Enter the number in the search field of the 
Sametime Connect window, and select Dial: [Phone 
number].

To Do This

Answer the call. Select Answer at the bottom of the call alert window.

Send the call directly to voice mail. Select Send to Voicemail at the bottom of the call alert 
window.

Start a Sametime Connect chat with the caller. Double-click the business card on the call alert window.
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Working with Calls Already in Progress

Note If you configured the plug-in to use the Dial Using Cisco IP Communicator option, this section does not apply. 

If you configured the plug-in to use the Control Desk Phone option, you manage calls that you make or answer in 
Sametime Connect by using a conversation window.

Troubleshooting Tips
You cannot merge calls that include the same party. For example, if you are in two conference calls that both include party A, 
merging the conference calls will fail.

Making Conference Calls from Sametime Connect

Note If you configured the plug-in to use the Dial Using Cisco IP Communicator option, this section does not apply. Please 
note conferencing is possible with Cisco IP Communicator by initiating each call sequentially from IBM Lotus Sametime 
and using the conferencing interface in Cisco IP Communicator to merge calls. Refer to Cisco IP Communicator User 
Guide for details.

If you configured the plug-in to use the Control Desk Phone option, you make conference calls from Sametime Connect by 
selecting multiple contacts before dialing or by merging calls that are already in progress.

To Do This

Place the call on hold. Select the Hold/Resume this Call icon.

Resume the call. Select the Hold/Resume this Call icon.

End the call. Select the End this Call icon, or close the conversation 
window.

Start a Sametime chat session with the other party. If there is a business card in the conversation window, 
double-click it. Otherwise, you must start the chat session in 
the usual way from the main window.

Merge calls already in progress into a conference call. Select the Merge the Call with Another icon. If you have 
more than two calls in progress, a menu appears, allowing 
you to select which of the calls to include. The menu 
identifies each call by conversation window title.

See a list of participants if you are on a conference call. Select the Show/Hide the Roster icon.

Enter dual tone multi-frequency (DTMF) digits (including “*” 
and “#”) when connected to Interactive Voice Response (IVR) 
system. For example, enter a pin to access your voicemail box.

Select the Show/Hide the Keypad icon, and click the keypad 
buttons.
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When you select contacts before dialing, the plug-in dials each contact one at a time and shows the sequence of connections in 
a separate window. When the status of a participant is connected, you select Add to Conference to include the participant. If a 
call transfers to voicemail, select Disconnect this Person to continue dialing the next participant.

4  Uninstalling the Plug-In
You can uninstall the plug-in from Sametime Connect.

Procedure

Step 1 From the Sametime Connect window, select Tools > Plug-Ins > Manage Plug-ins.

Step 2 Select the Cisco Phone Control and Presence feature in the left pane of the Product Configuration window.

Step 3 Right-click the feature, and select Uninstall.

Step 4 Select OK to confirm the uninstall.

Step 5 Select Yes when prompted to restart.

5  Where to Find More Documentation
For information about how to use Cisco IP Communicator, see the applicable user guide at 
http://cisco.com/en/US/products/sw/voicesw/ps5475/products_user_guide_list.html.

For information about how to use the Cisco Unity Plug-in for Sametime Connect, see the applicable user guide at 
http://www.cisco.com/en/US/products/ps9830/products_user_guide_list.html.
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To Do This

Start a conference call from the Sametime Connect Contacts list 
or from a chat window

Select multiple contacts, right-click to open the context 
menu, and select Phone Call > Conference. Alternatively, 
select the contacts, and select the phone button on the tool 
bar.

If you have phone status configured, off-hook phone icons 
appear for contacts whose phones are currently in use.

Merge calls already in progress into a conference call Select the Merge the Call with Another icon in the 
Conversation window, and select the calls to merge.
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