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This section includes the following topics:

• Submitting a Job in Five Steps, page 8-1

• Step 1: Choose Your Source, page 8-2

• Step 2: Select Preprocessor Settings, page 8-6

• Step 3: Select Encoders, page 8-12

• Step 4: Select Distribution Settings, page 8-12

• Step 5: Submit the Job, page 8-13

Submitting a Job in Five Steps

Note Most Cisco MXE 3000 customers use Folder Attendant to automatically submit jobs. From your 
desktop, click the Folder Attendant icon. See the Folder Attendant chapters in this guide for more 
information.

You can manually submit a job or jobs in either of the following ways:

• Use a Job Profile to submit a job. See also: Using a Job Profile to Submit a Job.

or

• Complete the following five steps:

– Step 1: Choose Your Source

– Step 2: Select Preprocessor Settings

– Step 3: Select Encoders

– Step 4: Select Distribution Settings 

– Step 5: Submit the Job.

Note A job must contain a minimum of a File Job tab and a Preprocessor tab to be submitted to the Job Log. 
You must create a new Job Profile or associate the job with a profile before submitting to the Job Status 
window.
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Step 1: Choose Your Source
When you open the Cisco MXE 3000 CLUI, a File Job tab displays in the main window. From here you 
will select your source files and complete File Job Settings. 

This section includes the following topics:

• Introduction to the File Job Tab, page 8-2

• Understanding File Job Settings, page 8-3

Introduction to the File Job Tab
A File Job, shown in Figure 8-1, allows you to ingest video and/or audio files for encoding. The source 
files may exist on your PC, on network drives, or on a SAN. However, if the file resides in a location not 
directly accessible to the Cisco MXE 3000, the file must first be copied to the appropriate server.
8-2
User Guide for Cisco Media Experience Engine 3000 Release 2.0

OL-16995-01



 

Chapter 8      Submitting a Job (CLUI)
  Step 1: Choose Your Source
Figure 8-1 File Job Tab

You can import video only, audio only, audio and video files. See also: Input Formats (File-Based Inputs) 
for a list of supported file formats.

Understanding File Job Settings
Adjust File Job settings on the following subtabs: 

• Job Data

• Advanced
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Job Data

The Job Data subtab contains two sections:

• File Job

• Metadata

File Job

The File Job section, shown in Figure 8-2, is used to select the file or files to be encoded and to set other 
job parameters, including whether the file needs to be copied to the server before preprocessing and 
encoding begins, the output name, thumbnail time, and start timecode. 

Note To avoid possible job failures, always check the Copy file to server box.

Figure 8-2 File Job Section

Table 8-1 describes the settings.

Table 8-1 File Job Settings and Descriptions

Setting Description

Select File Set Click the Select File Set button to select the files that will be processed in the 
current job. Clicking the button opens a Locate movie files browse window 
where you can search for and select files. 

The selected files will appear in the box below the button.

• To add more files: Select the button again. 

• To remove a file: Select the file, and press the Delete button on your 
keyboard

Copy File to Server Check this box to copy a file from the source directory to a media directory on 
the encoder server before the job begins.   We recommend that you always 
check this box.
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Metadata

Metadata entered in this section, shown in Figure 8-3, is optional and will be attached to the clip being 
processed. Depending on the data type and the media player, some types of metadata are viewable on the 
output clip. 

Figure 8-3 Metadata Section

Table 8-2 describes the settings.

Remove file from 
server when finished

Check this box to delete the new copy of the file from the Cisco MXE 3000 
when the job is finished, which is recommended due to the typical size of 
media files. 

Note The Remove file from server when finished checkbox only works if 
Copy file to server is also checked.

Output name Enter an output name that the Cisco MXE 3000 will use to build the encoded 
output file name. If no output name is specified, the input file name will be 
used as the output name.

Thumbnail Time Enter a time (00:00:00.00) at which the Cisco MXE 3000 will capture a single 
thumbnail image. 

Start Timecode Enter the timecode that will appear on the first encoded frame. You can match 
the source file timecode or start the timecode at 00:00. 

Note This timecode entry does not affect the start or stop time of the 
encoding, nor does it trim the input source in any way. To trim the 
source file, go to View > Preview Window.

Table 8-1 File Job Settings and Descriptions (continued)

Table 8-2 Metadata Settings and Descriptions

Setting Description

Title Enter a title for the clip being encoded. If you do not specify a title, the source file 
name will be used.

Description Enter a description of the clip. 

Keywords Enter descriptive search words relating to the clip content. Keywords are stored in the 
database and can be used to create custom reports.

Author Enter the name of the clip's author. 
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Note Data entered in the Tools > Preferences > Submission Preferences (Defaults) tab will auto-populate the 
File Job Metadata fields. Overwrite or delete automatic data as needed.

Advanced

The V-Chip controls, shown in Figure 8-4, are used to manually submit a V-Chip rating. Use the 
Preprocessor > V-Chip Gfx subtab to set the rating image and to map the rating to a V-Chip watermark, 
which is then applied by the preprocessor. See also: Creating a V-Chip Rating Watermark for details on 
V-Chips and how they work. 

Figure 8-4 V-Chip

Step 2: Select Preprocessor Settings
To understand the Preprocessor tab and its settings, see the following topics: 

• Introduction to the Preprocessor Tab

• Understanding Preprocessor Settings

See also: Working With Jobs in the Preview Window.

Working With Jobs in the Preview Window
The Preview window allows you to see frame-by-frame results of cropping, color and noise reduction, 
and watermark options selected on the Preprocessor tab. The image displayed in the Preview window 
shows a Before/After Split where the left side is the unprocessed image and the right side is the same 
image with the currently selected preprocessor options applied.

Copyright Enter the clip's copyright information. 

Rating Select a rating to be embedded in the output file. The rating indicates the appropriate 
audience for the media that will be viewed. The following ratings are available:

• none

• General - All Ages

• Parental Guidance Recommended

• Adult Supervision Required

• Adults Only

Table 8-2 Metadata Settings and Descriptions (continued)
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The Preview Window allows you to preview the following types of input media:

• File-based media: Allows you to preview the source file and view video before and after 
preprocessor settings have been applied.

• File-based media from the job log: Same as original file-based media, but also allows you to set 
in and out points.

This section also includes the following topics:

• Understanding the Preview Window, page 8-7

• Opening the Preview Window, page 8-9

• Setting File Job In and Out Points, page 8-11

• Choosing Where to Set In and Out Points, page 8-11

Understanding the Preview Window

The Preview window is used to view and fine-tune preprocessor settings. 

Note Graphic overlays are not visible in the Preview window, but will display in the encoded clip and in the 
preprocessed .avi intermediate file. 

From top to bottom, Preview window features are shown in Figure 8-5. 
8-7
User Guide for Cisco Media Experience Engine 3000 Release 2.0

OL-16995-01



 

Chapter 8      Submitting a Job (CLUI)
  Step 2: Select Preprocessor Settings
Figure 8-5 Preview Window

Table 8-3 describes the settings.

Table 8-3 Preview Window Features and Settings

Feature or Setting Description

Before/After Split 
Slider

Slide the indicator to the left or right to adjust the amount of the image 
displayed unprocessed and the amount displayed with preprocessing options 
applied.

Preview Pane Displays a frame-by-frame view of the input video.
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Opening the Preview Window

Procedure

Step 1 Highlight a job in the Job Log list

Step 2 Do one of the following:

• In the Job Log window, right-click the selected job, and click Preview Job.

Timeline The full bar (base color white) represents the entire clip. To use the timeline:

• Slide the green and red brackets left or right to define the in and out points 
of the clip. The In Point and Out Point counters reflect the bracket 
positions. The blue section is the portion of the clip that will be encoded.

• Drag the white tab (below the timeline) to the right or left to view the clip. 

• Slide the gray zoom bar to the right to zoom in on a specific frame. The 
zoom status bar to the right displays the position of the zoom control 
relative to the entire clip.

Input Displays the dimensions of the input media. 

Note In point and out point markers that are changed in the Preview window 
override these values shown on the Preprocessor tab of a Job Profile.

Output Displays the dimensions of the output video. 

Note In point and out point markers that are changed in the Preview window 
override these values shown on the Preprocessor tab of a Job Profile.

Size Enter new dimensions, if needed, and click Set. The clip will display in the new 
size. Click PP Size to preview the image at the settings on the Preprocessor tab, 
or click Thumb Size to preview the image at the default width and height 
defined in Thumbnail Preferences. 

Save Thumbnail Click this button to save a thumbnail of the currently displayed frame using the 
default path, name, and image properties as defined in the Thumbnail 
Preferences. The size of the image is determined by the current image size in 
the Preview window, and the thumbnail image will be captured after the 
preprocessing is applied.

Apply edit Click this button to save the new in point and out point. 

Table 8-3 Preview Window Features and Settings (continued)
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Figure 8-6 Right-click to Preview Job

• Or, from the main window, click Tools > Preview.

Figure 8-7 Click Tools > Preview to Preview Job

• Or, from the Job Log window, click Edit > Preview Job. 

The Preview window displays.
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Tip If the Preview window is hidden behind another window, click View > Preview Window to 
bring it to the foreground. 

Setting File Job In and Out Points

See also: Choosing Where to Set In and Out Points.

Procedure

Step 1 Open the job in the Preview window. See also: Opening the Preview Window.

Step 2 Set the In Point frame: 

• Use the Forward and/or Back buttons to navigate to the frame, and press your I key to set the in point.

or

• Slide the green bracket left or right to define the in point. 

Step 3 Repeat one of the above methods to set the out point, and press your O key or drag the red bracket.  

Step 4 Click apply edit. The in point and out point information displays in the Job Log. 

Note When the job is run, only the in point and out point applied in the Preview window will override the Job 
Profile in point and out point settings.

Choosing Where to Set In and Out Points

Both the Preview window and the Preprocessor tab of a Job Profile allow you to define the In Points and 
Out Points of clips. The overlap is designed to allow users flexibility in determining whether these 
settings should be included as part of the Job Profile or whether they should be applied on a job-by-job 
basis. 

Assign In Points and Out Points in a Job Profile when clips encoded with the profile have consistent 
information at the beginning or end that always needs to be trimmed. For example:

• If clips from a particular source always begin or end with color bars.

• If clips from a particular source are a uniform length and are preceded by or followed by superfluous 
footage.

• If the desired goal of the encoding is a uniform sample of how a profile will work with a variety of 
source material. For example, if a profile needs to be tested, encoding twenty seconds in the same 
section of multiple types of source material can give excellent results demonstrating what to expect 
when the profile is in production.

Assign the In Points and Out Points in the Preview window whenever the In Point and Out Point are 
unique to the clip. For example:
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• If the footage is unfamiliar, In Point and Out Point will need to be set by someone visually reviewing 
the clip. The Preview window allows the interaction required when the In Point and Out Point are 
unknown or not uniform across a set of clips. 

• If clips are preceded or followed by unwanted material, but the amount that each clip needs to be 
trimmed is not uniform, setting the In Point and Out Point in the Job Profile will provide a uniform 
trim. Additional fine tuning of the material to be encoded can be achieved by adjusting the In Point 
and Out Point in the Preview window.

The type of trim required by the media being encoded will determine the best option for setting In Points 
and Out Points. 

Step 3: Select Encoders
The Cisco MXE 3000 uses Encoder tabs to set parameters that govern how uncompressed preprocessor 
output will be compressed for distribution. 

See also: Encoders for more information on each encoder.

Procedure

Step 1 To add an encoder to your job, from the main menu, click Encoder. A list of all encoders displays.  

Step 2 Select an encoder. The encoder tab is added to the job. 

Step 3 Check boxes and complete fields as needed. See also: Encoders. Select the appropriate encoder to 
understand its settings. 

Step 4: Select Distribution Settings
Distribution settings tell the Cisco MXE 3000 what to do with output files once encoding is complete. 
Setting distributions for a job is optional.

You may choose to add the following to the job:

• Add Delivery

• Add Notification

• Add Output

See also: Adding Distribution Settings to a Job Profile (CLUI).

Add Delivery
See also: 

• Introduction to the Delivery Tab

• Understanding Delivery Settings
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Procedure

Step 1 From the main menu, click Distribution > Add Delivery. A Delivery tab is added to the job. 

Step 2 Select Formats to Deliver, Delivery Methods, and Rename on Delivery settings. 

Add Notification
See also: 

• Introduction to the Notification Tab

• Understanding Notification Settings

Procedure

Step 1 From the main menu, click Distribution > Add Notification. A Notification tab is added to the job. 

Step 2 Check boxes and complete fields as needed. 

Add Output
See also:

• Introduction to the Output Tab

• Understanding Output Settings

Procedure

Step 1 From the main menu, click Distribution > Add Output. An Output tab is added to the job. 

Step 2 Check the appropriate Save Local Output File boxes, and complete the Output section, if needed. 

Step 5: Submit the Job
See also:

• Job Log Window: Managing Jobs Before Submission

• Job Status Window: Managing Submitted Jobs

Procedure

Step 1 When all File Job, Preprocessor, Encoder, and Distribution tabs have been added and settings applied to 
each tab, from the main menu, (if you are not using a pre-existing Job Profile), select Save Job Profile.
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Step 2 At the base of the File Job tab, click Add job to log, as shown in Figure 8-8. The job appears in the Job 
Log window.

Figure 8-8 Add Job to Log 

Step 3 Adjust Job Properties, if needed, and click Submit, as shown in Figure 8-9. The job displays in the Job 
Status window. See also: Job Status Window: Managing Submitted Jobs.

Figure 8-9 Job Listed in Job Log Window

Note If you have not saved the current job as a Job Profile or associated a Job Profile to the job, an 
error pop-up displays:

Step 4 Click OK, right-click the job in the Job Log window, select Set Profile, and choose a profile, as shown 
in Figure 8-10.
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Figure 8-10 Selecting a Job Profile

Step 5 Click Submit. In the Job Log window, the job now displays a Status of submitted, as shown in 
Figure 8-11.
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Figure 8-11 Job Log: Status Submitted 

The job also displays in the Job Status window, as shown in Figure 8-12.
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Figure 8-12 Job Listed in Job Status Window
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