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This section includes the following topics:

• Job Log Window: Managing Jobs Before Submission, page 9-1

• Job Status Window: Managing Submitted Jobs, page 9-12

Job Log Window: Managing Jobs Before Submission
This section includes the following topics:

• Introduction to the Job Log Window, page 9-1

• Understanding the Job Log Window, page 9-2

• Job Log Menus, page 9-3

• Adding Jobs to the Job Log, page 9-6

• Submitting Jobs from the Job Log Window, page 9-7

• Creating a New Job Log, page 9-7

• Saving the Job Log, page 9-8

• Opening a Saved Job Log, page 9-8

• Editing Jobs in the Job Log, page 9-8

• Assigning Job Profiles in the Job Log Window, page 9-9

• Changing the Priority of Jobs in the Job Log Window, page 9-9

• Resetting a Job, page 9-9

• Updating Jobs in the Job Log, page 9-9

• Understanding Job Properties, page 9-10

• Viewing and Setting Job Properties, page 9-11

• Deleting Jobs from the Job Log, page 9-12

Introduction to the Job Log Window
The Job Log window is one of four user interface windows available with the Cisco MXE 3000.
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The Job Log window can be opened from any Cisco MXE 3000 window by selecting View > Job Log.

The Job Log lists jobs in chronological order (most recently logged jobs last).

The Job Log window is used to display information about jobs that have been created in the main 
window. From the Job Log window, among other tasks, you can complete the following:

• Assigning Job Profiles in the Job Log Window

• Submitting Jobs from the Job Log Window

• Changing the Priority of Jobs in the Job Log Window

• Deleting Jobs from the Job Log 

The entire set of information displayed in the Job Log window can be saved for later use, and previously 
saved log files can be reopened. Log files are saved in a standardized Avid Log Exchange (ALE) format.

See also: Saving the Job Log and Opening a Saved Job Log.

Understanding the Job Log Window
The Job Log window, shown in Figure 9-1, lets you manage each logged job in a central repository prior 
to submitting it for encoding. Jobs are created in the main window and are submitted by you to the Job 
Log. 

Jobs are not automatically removed from the Job Log. You may want to resubmit jobs or make changes 
to jobs even after they have been submitted. See also: Resetting a Job.

Figure 9-1 Job Log Window
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Job Log information is displayed in six columns, as described in Table 9-1. 

Job Log Menus
This section describes the following Job Log menus:

• File Menu

• Edit Menu

• View Menu

• Help Menu

File Menu

The Job Log File menu options are described in Figure 9-2. 

Table 9-1 Job Log Window Displays and Descriptions

Display Description

Id Displays the order of jobs submitted to the Job Log. 

Note Id is a temporary number assigned to the job to track its order in the Job Log. This 
number is different than the Job ID, which is assigned when jobs are submitted 
for encoding.

Priority Displays the priority assigned to the job. By default, the Priority is set to 2. Jobs that are 
more urgent can be set to Priority 1, while jobs that are less time-critical can be set to the 
lowest priority, Priority 3. 

In the Job Log window, change Job Priority by highlighting the job and selecting Edit > 
Set Priority or by right-clicking the job and selecting Set Priority.

Profile Lists the name of the Job Profile assigned to the job. A blank field indicates that no profile 
has been assigned. A job can be added to the Job Log without a Job Profile, but the job 
cannot be submitted without a Job Profile. 

Assign a Job Profile or change the currently assigned Job Profile from the Job Log 
window, by highlighting the job and selecting Edit > Set Profile or by right-clicking the 
job and selecting Set Profile.

Input Displays information about the input media to be encoded. The name of the source file 
will display. 

Output Displays the Output Name assigned when the job was created. Output Name can be a text 
string defined by you or can be a unique name generated based on variables used by the 
Cisco MXE 3000.

Status Displays the current status of the logged job.

• Queued: Indicates that the job either has not yet been submitted for encoding or has 
been reset and is ready to be submitted again. Only jobs with a status of queued can 
be submitted.

• Submitted: Indicates that the job has been submitted for encoding. A job can only be 
successfully submitted if a Job Profile has been assigned and the Cisco MXE 3000 is 
able to establish communication with the server. Jobs that show a status of submitted 
cannot be resubmitted without being reset.
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Figure 9-2 Job Log File Menu
.

Table 9-1 describes the menu options.

Edit Menu

The Job Log File menu options are shown in Figure 9-3.

Table 9-2 Job Log Window Menu Options and Descriptions

Option Description

New Job Log Clears the information currently displayed, and creates a new Job Log.

Open Job Log Allows you to browse for and open existing Job Logs that have been saved as 
.ale files. 

Save Job Log Allows information in the Job Log window to be saved as a log file in .ale 
format. 

Save Job Log As Allows information in the Job Log window to be saved. This option is normally 
used to save a copy of a previously saved log file under a new name or to a new 
location.

Close Window Closes the Job Log window. 

Exit Exits the Cisco MXE 3000 CLUI. 
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Figure 9-3 Job Log Edit Menu
.

Table 9-1 describes the menu options.

View Menu

The View menu, shown in Figure 9-4, is consistent across all Cisco MXE 3000 windows and can be 
accessed from the top menu bar in each window. Select a window to bring it to the foreground.

Table 9-3 Edit Menu Options and Descriptions

Option Description

Set Profile Displays a list of Job Profiles. Select a profile to associate to the job, and the profile 
name displays in the Job Log window. 

Set Priority Allows you to set or change the highlighted job's priority: 1, 2, or 3 (1 is highest)

Open Job Opens the job and its associated Job Profile in the main window.

Queue Job Changes the status of the job from submitted to queued to allow the job to be 
resubmitted.

Dequeue Job Sets the status of the job to dequeued meaning that the job will not be submitted 
when you click Submit. 

Preview Job Opens the Preview window allowing a frame-by-frame preview and a modification 
of the in point and out point.

Delete Job Deletes the job from the Job Log.

Properties Opens a Properties window to display job properties including assigned metadata.
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Figure 9-4 Job Log View Menu
.

Help Menu

The Job Log Help menu, shown in Figure 9-5, displays release and build information for the 
Cisco MXE 3000. To view the Help guide for the Cisco MXE 3000, click Help on the main window.

Figure 9-5 Job Log Help Menu
.

Adding Jobs to the Job Log

Note See also: Step 5: Submit the Job for complete instructions on submitting jobs.

Procedure

Step 1 From the File Job tab, in the File Job box, highlight one or more jobs. 

Step 2 Click the Add file job to log button. The job appears in the job log, as shown in Figure 9-6.
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Figure 9-6 Job Log Window.

Submitting Jobs from the Job Log Window

Note Only jobs that have a Job Profile attached and are queued can be submitted.

Procedure

Step 1 From the Job Log window, highlight one or more jobs. 

Step 2 Click Submit.

Creating a New Job Log

Caution You may want to save the current job log before performing this procedure. Creating a New Job Log 
before saving the current job log will discard all jobs in the current Job Log window. Jobs that are 
currently in a queued status will be discarded without being submitted, and all data about those jobs will 
be lost.  See also: Saving the Job Log.
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Procedure

Step 1 In the Job Log window, click File on the menu bar.  

Step 2 Select New Job Log. The Open Queue warning pop-up displays. 

Step 3 Click Yes to confirm that the current job log can be discarded. A new, empty job log displays.

Saving the Job Log

Procedure

Step 1 Add jobs to the Job Log. See also: Adding Jobs to the Job Log.

Step 2 Click File on the menu bar, and select Save Job Log. 

Step 3 Browse to the directory where the log will be saved. 

Step 4 Enter a file name, and click Save.

Opening a Saved Job Log

Caution If you don't save the current Job Log before opening another log file, the information will be discarded 
and the jobs will have to be recreated in order to be submitted.

Step 1 In the Job Log window, save the Job Log.  See also: Saving the Job Log.

Step 2 Click File > Open Job Log. The Open Queue warning pop-up displays. 

Step 3 Click Yes. 

Step 4 Browse to the location of the log file you want to open. 

Step 5 Select the file, and click Open. 

Editing Jobs in the Job Log
• To modify jobs listed in the Job Log window, right-click the job to open the Edit menu.

or

• From the Job Log menu, click Edit.

See also: Edit Menu for editing options.
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Assigning Job Profiles in the Job Log Window

Procedure

Step 1 In the Job Log window, highlight the desired job. 

Step 2 Right-click the job, or click Edit from the top menu bar. 

Step 3 Select Set Profile. 

Step 4 Select the desired Job Profile. The Job Profile name displays to the left of the job in the Job Log window.

Changing the Priority of Jobs in the Job Log Window

Procedure

Step 1 In the Job Log window, highlight the desired job. 

Step 2 Right-click the job, or click Edit from the top menu bar. 

Step 3 Select Set Priority. 

Step 4 Click 1, 2, or 3 (1 highest, 2 default, 3 lowest) to set the job's priority. 

Resetting a Job
You can resubmit a job with the identical settings or edit the settings and then resubmit.

Procedure

Step 1 In the Job Log window, highlight a submitted job to be reset.    

Step 2 Right-click the job, or click Edit from the top menu bar. 

Step 3 Select Queue Job. The Status now displays queued. 

Step 4 (Optional) You may now edit the job if needed.  See also: Edit Menu.

Updating Jobs in the Job Log
Once jobs have been added to the Job Log, they can be opened and updated in the main window. 

There are three ways to update job information from the Job Log window:

• To open the job's corresponding main window File Job tab, double-click the job in the Job Log 
window. This allows you to update job metadata, output name, and other settings.

• To open the job and all of its associated Job Profile information, from the Job Log window, click 
Edit > Open Job. From here you can adjust any job or Job Profile settings. 
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• To open the Preview window and all job information including the associated Job Profile, from the 
Job Log window, click Edit > Preview Job. From here you can interactively modify job settings 
including the in point and out point.

Once all necessary adjustments have been made, update the job by completing the following procedure:

Procedure

Step 1 To update and resave a job queued in the Job Log, select one of the three methods to open the job in the 
main window. 

Step 2 Add/remove/change data, change any of the file job settings, or make changes to the clip from the 
Preview window. 

Step 3 Click Update file job to save the new information. 

Understanding Job Properties
The Properties window, shown in Figure 9-7, displays basic information about the selected job. 

To access the Properties window from the Job Log:

• Highlight a job, right-click it, and select Properties.

or

• Highlight a job, click the Job Log Edit menu > Properties.

Figure 9-7 Job Log Properties Window 
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Table 9-4 describes the settings.

Viewing and Setting Job Properties

Procedure

Step 1 In the Job Log Window, highlight a job. 

Step 2 Right-click the job, or click Edit from the top menu bar. 

Step 3 Click Properties. The Properties window displays. 

Step 4 To adjust settings, do one of the following:

• JobData or Forensic Watermarking settings. See also: Updating Jobs in the Job Log.

• User Defined Meta-Data: Double-click a field in the Value column to override that setting.

Table 9-4 Properties Settings and Descriptions

Setting Description

Filename Displays the name or names of the media files to be submitted. 

Output Displays the name of the output file as entered on the File Job tab. 

Priority Displays the job priority (1: highest, 3: lowest). 

Title Displays the title of the clip being encoded as entered in the Metadata 
section of the File Job tab. 

Description Displays the description of the clip as entered in the Metadata section of 
the File Job tab. 

Keywords Displays keywords as entered in the Metadata section of the File Job tab. 

Author Displays the author as entered in the Metadata section of the File Job tab.

Copyright Displays copyright information for the clip: either the default copyright 
defined in metadata preferences or the copyright entered in the Metadata 
section of the File Job tab. See also: Submission Defaults.

Rating Displays the rating as entered in the Metadata section of the File Job tab.

In/Out Points Displays the in point(s) and out point(s) for the clip. This can be defined 
on the Job Profile's Preprocessor tab or can be individually set for each 
clip using the Preview window. 

Profile Displays the Job Profile selected for this job.

Copy to Server Indicates whether the Copy File to Server box was checked on the File 
Job tab.

Delete Copied Media Indicates whether the Remove File From Server When Finished box was 
checked on the File Job tab. 

User Defined Metadata Double-click a field in the Value column to override various settings on 
a job-by-job basis. See also: Applying Graphic Overlays to a Job with 
User-Defined Metadata. 
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Deleting Jobs from the Job Log

Caution There is no way to restore a job that has been deleted from the Job Log. To resubmit the job, recreate it. 

Step 1 In the Job Log window, highlight the unwanted job.

Step 2 Right-click the job, or click Edit from the top menu bar.

Step 3 Select Delete Job. The job is removed from the Job Log. 

Job Status Window: Managing Submitted Jobs
This section includes the following topics:

• Introduction to the Job Status Window, page 9-12

• Understanding the Job Status Window, page 9-13

• Job Status Menus, page 9-13

• Expiration of Jobs from Job Status, page 9-15

• Working with Jobs in the Job Status Window, page 9-16

• Viewing Task Detail in the Job Status Window, page 9-18

• Changing the Priority of Jobs in the Job Status Window, page 9-19

• Rescheduling Jobs in the Job Status Window, page 9-19

• Stopping Pending or Running Jobs in the Job Status Window, page 9-19

• Viewing Encoded Output from the Job Status Window, page 9-20

• Viewing the Output Folder From the Job Status Window, page 9-20

• Deleting Jobs From the Job Status Window, page 9-20

• Displaying Errors on Failed Jobs, page 9-20

• Understanding the Worker Error Status Window, page 9-21

Introduction to the Job Status Window
Once jobs are submitted for encoding, they can be monitored in the Job Status window, shown in 
Figure 9-8. Job Status shows a real-time summary of each job's status. It indicates when a job is 
submitted, running, completed, or has failed. It can also be used to display the percent of completion for 
each task defined in the assigned Job Profile.

See also: Understanding the Job Status Window for an explanation of each color.
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Figure 9-8 Job Status Window 

Understanding the Job Status Window
Jobs that have been submitted for encoding can be viewed in the Job Status window, shown in Figure 9-8. 

Summary information about each job is displayed along with the status. 

The status of each job is also indicated by color, as described Table 9-5.

Job Status Menus
This section describes the following Job Status menus:

Table 9-5 Job Status Color and Description

Color Description

Yellow Pending: The job has been submitted but has not begun.

Green Running: The job has begun. Jobs stay in a Running state until all tasks in the Job Profile 
have been executed or until the job fails.

Blue Completed: All tasks in the Job Profile have completed successfully. 

Red Failed: A job fails if any task in the Job Profile did not complete successfully. For example, 
if communication with an FTP server cannot be established, the job will fail because the 
distribution task cannot be completed successfully. Likewise, if a user stops a job, the job 
will show as failed with a “user stop request” message.
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• File Menu

• Tools Menu

• View Menu

• Help Menu

File Menu

The Job Status File menu is shown in Figure 9-9. 

Figure 9-9 Job Status File Menu

Table 9-6 describes the options.

Tools Menu

The Job Status Tools Menu is shown in Figure 9-10. 

Figure 9-10 Job Status Tools Menu

Change Server: Displays a list of servers available to the Cisco MXE 3000 and permits selection of a 
current server. This servers list is set defined in General Preferences.

View Menu

The View menu, shown in Figure 9-11, is consistent across all Cisco MXE 3000 windows and can be 
accessed from the top menu bar in each window. Select a window to bring it to the foreground.

Table 9-6 File Menu Options and Descriptions

Option Description

Close 
Window

Closes the Job Status window only. The main window and the Job Log window remain 
open.

Exit Closes the entire Cisco MXE 3000 Client User Interface.
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Figure 9-11 Job Status View Menu

Help Menu

The Job Status Help menu, shown in Figure 9-12, displays release and build information for the 
Cisco MXE 3000 version you are using. If you need to contact Technical Support, they will need this 
information. 

Figure 9-12 Job Status Help Menu

Expiration of Jobs from Job Status 
As new jobs are submitted, the Job Status list lengthens. Jobs that are not individually deleted from the 
Job Status window can be removed using an Auto Reap interval that is established at the time of your 
system deployment. For more information on setting the Auto Reap interval, see the Depoyment and 
Administration Guide for Cisco Media Experience Engine 3000 Cisco.com.

Descriptions of the Job Status fields are labeled in Figure 9-13.
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Figure 9-13 Job Status Display Features 

Working with Jobs in the Job Status Window
The Job Status window offers two menus for working with jobs, as described in Table 9-7.

Job Menu

In the Job Status window, right-click anywhere on the job row. The menu, shown in Figure 9-14, 
displays. 

Table 9-7 Job Status Menus and Descriptions

Menu Description

Job Menu Allows you to make changes that affect the entire job. Open the job menu by 
highlighting the job and right-clicking.

Task Menu Allows you to view the encoded output or any errors associated with a specific 
encoding task. (A job is comprised of one or more tasks.) Open the task menu by 
expanding (click the + on the left) a Job ID, highlighting a task, and right-clicking that 
task. 

Note To see the difference between a Job ID and a Task ID, see Job Status Display 
Features.
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Figure 9-14 Job Menu

Table 9-8 describes the menu options.

Task Menu

In the Job Status window, expand a JobID to view its tasks. Highlight a task and right-click it to open, 
as shown in Figure 9-15. 

Figure 9-15 Task Menu

Table 9-8 Job Menu Options and Descriptions

Option Description

Change Priority Changes the priority of the job. (1: highest; 2: default; 3:lowest)

Stop Stops a running or pending job if, for example, you realize after the job has been 
submitted that it was submitted incorrectly. 

Note Stopped jobs display a failed status in the collapsed Job Status view. 
Expanding the detailed status shows that the job failed because of a user stop 
request. 

Delete Allows you to manually delete completed jobs from the Job Status window. Select 
one job or Ctrl+click or Shift+click to select multiple jobs.

Deleting pending jobs removes the job. If the job is later resubmitted, it will be 
assigned a new ID number.

Jobs can also be deleted by highlighting the unwanted job and pressing the Delete 
key on the keyboard.

Reschedule Rescheduling a stopped or failed job resubmits the job from within the Job Status 
window. The job maintains its unique ID and is processed in the order that it was 
originally submitted.

Show XML In a separate window, displays the job XML.

Show Errors To view errors on a failed job, right-click the job and select Show Errors. A Worker 
Status Error window will open to display any errors as seen below. See also: 
Understanding the Worker Error Status Window. 
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Table 9-9 describes the menu options.

Viewing Task Detail in the Job Status Window
As jobs are processed, a status for each task (profile component) is recorded. Display the statuses by 
expanding a JobID (click the + to the left). 

As seen in Figure 9-16, the detailed statuses show exactly which profile components have been 
processed and which are still outstanding. The status for each preprocessing or encoding task is updated 
as the work progresses.

Note You may also use the task status displays when troubleshooting to determine where a submitted failed.

Figure 9-16 Task Detail Display

Table 9-9 Task Menu Options and Descriptions

Option Description

Show Job 
Errors

Click this option to display the Worker Status Error window. See also: Understanding 
the Worker Error Status Window.

View Clip The appropriate media player opens and plays the clip.

Note The correct media player for the type of clip being viewed must be installed 
for the clip to play properly.

View Folder The output folder opens in Windows Explorer. 
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Changing the Priority of Jobs in the Job Status Window

Note The priority of Pending (yellow), Running (green), or Failed (red) jobs can be changed. The priority of 
Completed (blue) jobs cannot be changed.

Procedure

Step 1 To change a job priority in the Job Status window, highlight a job. 

Step 2 Right-click the job to open the Job menu.

Step 3 Click Change Priority, and select 1(highest) to 3 (lowest). 

Rescheduling Jobs in the Job Status Window

Procedure

Step 1 In the Job Status window:, highlight a job. 

Step 2 Right-click the job to open the Job Status menu, and click Reschedule. 

Note The job will be rescheduled. The Job ID and Priority will not be changed from the original, so the job 
will be processed according to the order it was originally submitted. If changes are made to the Job 
Profile after the job has been submitted, the changes will not affect the rescheduled job. 

Stopping Pending or Running Jobs in the Job Status Window

Procedure

Step 1 In the Job Status window, highlight the pending (yellow) or running (green) job to be stopped. 

Step 2 Right-click to open the Job Status menu, and click Stop. 

Note Stopped jobs display in red indicating that the job has failed. In the task detail or Worker Error window 
the reason for failure displays: User Stop Request. See also: Viewing Task Detail in the Job Status 
Window and Understanding the Worker Error Status Window.
9-19
User Guide for Cisco Media Experience Engine 3000 Release 2.0

OL-16995-01



 

Chapter 9      Managing Jobs (CLUI)
  Job Status Window: Managing Submitted Jobs
Viewing Encoded Output from the Job Status Window

Procedure

Step 1 In the Job Status window, click the plus sign (+) to expand a completed (blue) job. 

Step 2 Highlight a task, right-click it, and select View Clip. The media player opens and the clip plays. 

Note The correct media player for the type of clip being viewed must be installed for the clip to play 
properly.

Viewing the Output Folder From the Job Status Window

Procedure

Step 1 In the Job Status window, click the plus sign (+) to expand a completed (blue) job. 

Step 2 Highlight a task, right-click it, and select View Folder. The folder with all output jobs displays.

Deleting Jobs From the Job Status Window

Procedure

Step 1 In the Job Status window, highlight the job to be deleted. 

Step 2 Right-click the job, and click Delete. (Or, highlight the job, and press your Delete key.) 

Step 3 Click OK to confirm deletion. 

Displaying Errors on Failed Jobs
See also: Understanding the Worker Error Status Window.

• In the Job Status window: 

1. Highlight the failed (red) job. 

2. Right-click the job, and click Show Errors. 

or 

• From the expanded tasks list:

1. Highlight any task listed within the failed job. 

2. Right-click the task, and select Show Job Errors. 
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Understanding the Worker Error Status Window
Open the Worker Error Status window from the right-click pop-up menu in the Job Status window. The 
pop-up, shown in Figure 9-17, displays the reason for job failure. 

Figure 9-17 Worker Error Status Window

Table 9-10 describes the fields.

Table 9-10 Worker Error Status Fields and Descriptions

Field Description

Job Id Displays the unique numeric identification number assigned to the entire job. 

Task-Id Displays the unique numeric identification number assigned to the task within the job 
that generated the error. 

Time Displays the time that the error occurred. Time is displayed in a 24-hour format as 
hh:mm:ss.

Worker Displays the name of the worker responsible for the task that generated the error. 

Error 
Message

Displays the text of the error message generated. 

Note Drag the window edge to the right to view the entire message. 
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