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Distribution tabs tell the Cisco MXE 3000 what to do with output files once encoding is complete. 

This section includes the following topics:

• When to Add a Distribution Tab to a Job Profile, page 7-1

• Delivery, page 7-1

• Notification, page 7-9

• Output, page 7-13

• Variables Used for File and Directory Naming, page 7-16

Note From the main menu, select Distribution to display distribution options.

When to Add a Distribution Tab to a Job Profile
Distribution tabs allow users and administrators to save encoded output according to their specific 
business needs in addition to or instead of the default location.

Distribution tabs are not a required component of Job Profiles. By default, output files will be saved to 
the system default locations. When any type of distribution tab is added to a job or Job Profile, the system 
default will be overridden. When any type of distribution tab is added to a job or Job Profile, the output 
file is sent to the location specified on the distribution tab in addition to the default distribution location.

Likewise, distribution tabs are used to automate portions of the encoding workflow. For example, if 
encoded clips must be reviewed before they are moved to a streaming server, you can add a Delivery tab 
to automatically send the media to the reviewer's server using FTP, eliminating the need to manually FTP 
files. Or, if encoding files for an external customer, you can use the Notification tab to automatically post 
job statuses (via HTTP Post or e-mail) to a site for client reference.

Delivery
This section includes the following topics:

• Introduction to the Delivery Tab, page 7-2
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• Understanding Delivery Settings, page 7-4

• Adding a Delivery Tab to a Job Profile, page 7-9

Introduction to the Delivery Tab
Delivery tabs are added to a job or a Job Profile from the main menu, by selecting Distribution > Add 
Delivery. Adding a Delivery tab is optional. 

The Delivery tab controls the distribution of encoded media files. Encoded media can be copied to a 
network drive or can be delivered to another site via File Transfer Protocol (FTP). You can add one or 
multiple Delivery tabs to a job or a Job Profile. Each Delivery tab specifies how a subset of all the 
encoded outputs will be delivered. Multiple deliveries and multiple delivery methods may be specified 
with multiple Delivery tabs. For instance, within one job, you can have Real and QuickTime outputs 
delivered to a network drive. Then you can add another tab that sets delivery of Windows Media output 
to another site via FTP.

If a Delivery tab is not added to a job or a Job Profile, files will be saved to the system default location 
or to the client default location defined on the General Preferences tab. 

See also: Understanding Delivery Settings for a description of each of the settings in Figure 7-1.
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Figure 7-1 Delivery Tab
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Understanding Delivery Settings
Each Delivery tab is made up of the following sections:

• Formats to Deliver

• Select Profiles

• Delivery Method

• Rename on Delivery

Note You may choose to deliver one or more formats or one or more particular profiles.

Formats to Deliver

Select file types to be delivered to the location defined in the Delivery Method section.

Checking a particular format type will specify that all the encodes for that encoder will be delivered. 
Unchecked formats are not delivered.

Figure 7-2 Delivery Tab: Formats to Deliver

Select Profiles

In addition to checking one or more format boxes, check the Select Profiles box, shown in Figure 7-3, 
to specify a distribution method limited to certain profiles within the encoder types. 

Checking this box allows profiles to be picked from the adjacent list.
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Figure 7-3 Delivery Tab: Select Profiles Checkbox

The Select Profiles box lists the profiles used in the current job. Select only the profiles for which you 
want to set delivery.

Click on a profile name to select it (or select multiple profiles using the Shift or Ctrl keys). The encoded 
files generated from the selected profiles are then subject to the delivery method specified on this tab. 

If the Select Profiles box is not checked, individual profiles cannot be selected and are grayed out.

Note To deliver to individual profiles, you must check at least one Format to Deliver, you must check the 
Select Profiles box, and you must highlight the chosen profile(s).

Delivery Method

Use this section, shown in Figure 7-4, to specify delivery method, choosing to copy the output to a file 
location and/or to FTP the output to a host. 

Figure 7-4 Delivery Tab: Delivery Methods
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Table 7-1 describes the settings.

Table 7-1 Delivery Method Settings and Descriptions

Setting Description

Copy Check this box to allow encoded files to be copied to a network folder.

Location Specify the network folder to which the encoded files will be copied, by 
entering the UNC path of a network folder (Example: 
\\Machine\EncodedMedia).

Note: The path must be to a network folder to which you have access from 
the node that executes the Distribution worker. If your MXE-3000 is 
configured to work with a SAN, you can use the drive letter mapping of the 
SAN that is common to all hosts. Also, variables can be used in this field to 
define custom directories and filenames for copying files. See also: 
Notification.

FTP Check this box to send encoded files to another server via FTP, and specify 
the following settings, if applicable:

Hostname The hostname (or address) of the FTP server that will receive the output files

Directory The name of the directory path where the file will be stored. Variables can 
be used in this field to define custom directories.

Username The username used to establish the FTP session, if required

Password The password used to validate the user establishing the FTP session, if 
required

Port The port the destination server uses for FTP traffic. The port number is 
supplied by the administrator of the destination server.

Retry attempts The maximum number of times (0-16) an attempt will be made after the first 
FTP transfer fails.

Minutes between retry 
attempts

The number of minutes the Cisco MXE 3000 will wait after a failed FTP 
connection attempt before trying again. 

Secure FTP Check the box to use the secure FTP protocol.

Passive Check this box to request Passive mode from the host. In Passive mode, the 
FTP host server opens a random port and tells the Cisco MXE 3000 the 
address and port on which it is listening.

Use Temp File Check this box to use a temporary remote filename and rename after the 
transfer completes. This option helps prevent an external system from 
ingesting the remote file that failed to completely transfer. For example, if 
the FTP connection was dropped during the transfer, a partial file could be 
left at the destination. Only after a completed transfer will the delivered file 
be renamed to its desired name. See also: Understanding FTP .tmp File 
Extension for more information on the .tmp file extension.
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Rename on Delivery

Figure 7-5 shows the Rename on Delivery section.

Figure 7-5 Rename on Delivery

Table 7-2 describes the settings.

Understanding FTP .tmp File Extension
This section includes the following topics:

• Overview of File Transfer, page 7-7

• Addition of .tmp Extension, page 7-7

• Enabling the .tmp File Extension, page 7-8

Overview of File Transfer

After the encoding process, the newly generated file is transferred through file transfer protocol (FTP) 
from the Cisco MXE 3000 file system to the target server. The transfer takes place one chunk at a time, 
until the file is completely copied.    

A problem can occur if there is an interruption in the transfer (i.e., lost connection or remote FTP server 
down) and the file is not completely copied over. FTP does not provide guaranteed delivery of the 
complete files, and valid but incomplete files could result. A validation mechanism is needed to ensure 
that content is fully uploaded before the watch folder agent begins to ingest the file.

Addition of .tmp Extension

The Cisco MXE 3000 File Manager (FM) adds a .tmp extension to the target file name during transfer. 
After the upload is complete, FM removes the .tmp extension from the target file name. If the transfer is 
incomplete, the .tmp extension remains. Therefore, the watch folder agent can be configured to ignore 
files with a .tmp file extension to ensure complete transfers.

Example: Target file thefile.bmp is uploaded as thefile.bmp.tmp then renamed to thefile.bmp.

Table 7-2 Rename on Delivery Settings and Descriptions

Setting Description

Rename Output Check this box to enable file renaming, as determined by the Output Filename box. 
If this box is not checked, the files retain the same names they have in the normal 
output folders.

Output Filename The text and/or pattern of variables used to build the names of output files. 
Variables can be used to replace the default file name structure with one that 
reflects the unique Job Profile requirements. See also: Notification.
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Note The recommended Minutes between retry attempts value is 3 or greater. This gives the remote FTP server 
enough time to recycle the previously failed session. 

Enabling the .tmp File Extension

• From the main menu: On the Distribution > Add Delivery tab, under Delivery Method, check the 
FTP box and the Use Temp File box, as shown in Figure 7-6.

Figure 7-6 FTP and Use Temp File Checkboxes

• From File Manager: The Boolean field use-temp-file resides in the File Manager’s Task XML 
parameter section. (See example XML in Figure 7-7.) This field is optional and defaults to false. 
The preferred field values are: yes or no. An empty field <use-temp-file/> is treated as a true value. 

Figure 7-7 Example XML
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Adding a Delivery Tab to a Job Profile

Procedure

Step 1 From the main menu, click File and New Job Profile or Open Job Profile.  

Step 2 From the main menu, click Distribution > Add Delivery. A Delivery tab is added to the job. 

Step 3 Set Formats to Deliver, Delivery Methods, and Rename on Delivery settings. See also: Understanding 
Delivery Settings. 

Step 4 Click File > Save Job Profile to save changes. 

Notification
This section includes the following topics:

• Introduction to the Notification Tab, page 7-9

• When to Use the Notification Feature, page 7-9

• Understanding Notification Settings, page 7-10

• Adding a Notification Tab to a Job Profile, page 7-13

Introduction to the Notification Tab
Notification tabs are added to a job or a Job Profile from the main menu, by selecting Distribution > 
Add Notification. Adding a Notification tab is optional. 

Notification settings enable the Cisco MXE 3000 to send messages regarding job success or failure. The 
four forms of notification available are: 

• E-mail

• HTTP Post

• TCP Post

• UDP Post 

Any of the above notification types can be used separately or together. It is also possible to use multiple 
Notification tabs to implement complex notification scenarios.

When to Use the Notification Feature
Add a Notification tab if you want to be notified of a job’s completion, or if you need metadata from the 
job to be sent to another location. For example, you may elect to receive an e-mail alert whenever a job 
fails, or a list of output file names for every successful encode. In another example, watermarking 
associates metadata items with an embedded watermark payload, and these metadata are included in the 
notification, which can be forwarded to a central database via HTTP post. 

See also: Understanding Notification Settings for a description of each of the settings in Figure 7-8.
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Figure 7-8 Notification Tab

Understanding Notification Settings
Each Notification tab is made up of five sections used to define when and how notification will take 
place.

• Send Notification

• Email

• HTTP Post

• TCP Post

• UDP Post
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Send Notification

Select the status at which a notification is sent. 

• Always

• On Success

• On Failure

Note Failed jobs are jobs that fail at any point in the process and include jobs stopped by a user..

Email

Check this box, shown in Figure 7-9, to enable e-mail notification. Notifications are forwarded to the 
server name previously configured at the time of your system deployment. The server must be running 
the Simple Mail Transport Protocol (SMTP) service to process the e-mail transmission.

Figure 7-9 Notification Tab: Email

From and To Options

• Address: uses an e-mail address supplied in the From Address field 

• System Administrator: uses the System Administrator e-mail address stored in the Cisco MXE 
3000 database. 

Note The To Address can be any type of account capable of receiving text messages from an SMTP server, 
regular e-mail addresses, pagers, and text-enabled cellular phones.

HTTP Post

Check this box, shown in Figure 7-10, to define parameters used to post notification messages to web 
servers using HTTP Post.
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Figure 7-10 Notification Tab: HTTP Post

HTTP Post Fields

• Server Name: Enter the host name of the web server to which HTTP notification messages will be 
posted. This is a required field.

• Port: Enter the TCP port used for HTTP communication with the web server specified. If no value 
is specified the default port, port 80, will be used.

• CGI Path: Enter the path of the Common Gateway Interface (CGI) script used for HTTP 
notification. The path does not include the server name, which is supplied in the HTTP Server name 
field above, but does include the file name of the script being called.

TCP Post

Check this box, shown in Figure 7-11, to enable Transmission Control Protocol (TCP) post notifications.

Figure 7-11 Notification Tab: TCP Post

TCP Post Fields

• Server Name: Enter the name of a destination server for the notification. This is a required field.

• Port: Enter the destination server's TCP port number. If no value is specified the default port, port 
80, will be used.

UDP Post

Check this box, shown in Figure 7-12, to enable User Datagram Protocol (UDP) post notifications.

Figure 7-12 Notification Tab: UDP Post
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UDP Post Fields

• Server Name: Enter the name of a destination server for the notification. This is a required field.

• Port: Enter the destination server's TCP port number. If no value is specified the default port, port 
80, will be used.

Adding a Notification Tab to a Job Profile

Procedure

Step 1 From the main menu, click File and New Job Profile or Open Job Profile.  

Step 2 From the main menu, click Distribution > Add Notification. A Notification tab is added to the job. 

Step 3 Check boxes and complete fields as needed. See also: Understanding Notification Settings. 

Step 4 Click File > Save Job Profile to save changes.

Output
This section includes the following topics:

• Introduction to the Output Tab, page 7-13

• Understanding Output Settings, page 7-14

• Adding an Output Tab to a Job Profile, page 7-16

Introduction to the Output Tab
Output tabs are added to a job or a Job Profile from the main menu, by selecting Distribution > Add 
Output. Adding an Output tab is optional. 

Use this tab to identify encoder types for which the output files should be saved locally. 

The output file locations are defined during system setup. The name assigned to each output file is 
determined either by the client default defined in the General Preferences tab or by the Output File Name 
defined on the Output tab. 

Output files that are not saved are automatically removed from the local machine as the last step of a job. 
When a delivery method is used (see Delivery Tab) there may be no reason to keep the local files. The 
automatic file removal keeps the local machine clean for high-volume users.

See also: Understanding Output Settings for a description of each of the settings in Figure 7-13. 
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Figure 7-13 Output Tab

Understanding Output Settings
Each Output tab is made up of two sections:

• Save Local Output File

• Output

Save Local Output File

Check the boxes, shown in Figure 7-14, to specify output for certain encoded formats. 

Checking a particular format type will specify that all the encodes for that encoder will be saved in the 
output folder. Unchecked formats are not saved. 
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Note The Preprocessor checkbox allows the Cisco MXE 3000 intermediate preprocessed files to be retained 
in the temporary directory. 

Figure 7-14 Save Local Output File

Output

Figure 7-15 shows the Output section.

Figure 7-15 Output

• Output Name Enabled: Check this box to allow output files to be renamed according to the Output 
File Name box below. If unchecked, the files are named according to the default format defined in 
General Preferences.

• Output File Name: This field defines the new name for encoded output files.

You may use Cisco MXE 3000 substitution macros, which allow this single entry to specify the names 
of multiple encoded outputs. By default, the box holds: 
$(basename).$(profile).$(subprofile).$(extension), which ensures that each encoded file will receive a 
distinct name.
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Adding an Output Tab to a Job Profile

Procedure

Step 1 Click File and New Job Profile or Open Job Profile. 

Step 2 From the main menu, click Distribution > Add Output. An Output tab is added to the job. 

Step 3 Check the appropriate Save Local Output File boxes, and complete the Output section, if needed. See 
also: Understanding Output Settings. 

Step 4 Click File > Save Job Profile to save changes.

Variables Used for File and Directory Naming
Table 7-3 describes the variables for file and directory naming.

Table 7-3 File and Directory Naming Variables and Descriptions

Variable Description

$(date) Inserts the current date in a yyyymmdd format.

$(time) Inserts the current time in 24-hour format, hhmmss.

$(day) Inserts the current day of the month as a two digit number.

$(month) Inserts the current month as a two digit number.

$(year) Inserts the current year as a four digit number.

$(author) Inserts the author metadata provided on the File Job tab.

$(title) Inserts the title metadata provided on the File Job tab.

$(profile) Inserts the name of the Job Profile used to encode the output file.

$(basename) Inserts the Output Name provided in the File Job tab. 

$(format) Inserts a description of the file type created during encoding.

$(extension) Inserts the appropriate file extension for the type of file created.

$(filename) Inserts the name of the source file.

$(uid) Creates a unique filename based on text or other values included, which are 
appended by a number. For example, File1, File2, File3, and so on.

$(user-data) Inserts text entered on the encoder tab using the Change Encoded Data command 
from the Edit menu. This variable can only be used in Output Profiles. 
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