Tip

CHAPTER

Using DMM-DSM for Digital Signage

Revised October 22, 2007

Features in DMM-DSM are available to you if you purchased and installed the required license. For
information about licensing, see Chapter 2, “Using DMM-Admin to View and Install Licenses.”

DMM-DSM is a flexible environment from which to create, manage, and run a digital signage network.
Its simple but powerful design and publishing features help you to deliver compelling presentations for
digital signage, while its centralized management features help you to manage a global network of
on-premise DMP displays for any purpose. The possible use cases for DMM-DSM include:

Marketing— Describe products and services directly to your in-store customers.

Customer experience— Deliver entertainment and information to reduce perceived wait times.
Messaging— Broadcast executive and internal communications in real time.

Training— Deliver cost-effective, flexible training.

Information— Deliver real-time schedules, news, and way-faring information where people need it.
Advertising—Sell advertising time and space to third parties.

Branding— Communicate about your brand consistently.

This chapter describes DMM-DSM features and options in these sections:

Logging in to DMM-DSM for the First Time, page 3-2

Configuring DMPs to Support Centralized Management, page 3-2
Enabling the CVBS (Component Video) Interface on DMPs, page 3-3
Managing and Grouping DMPs, page 3-3

Creating Categories and Organizing Assets for Digital Signage, page 3-8
Developing Presentations, Templates, and Playlists for Signage, page 3-12
Using Advanced Tasks, page 3-34

Deploying Saved Commands and Presentations to Your DMPs, page 3-42
Using Administrative Options, page 3-49

Common Scenarios for Using DMM-DSM, page 3-58

Understanding and Using Digital Signage Status Report Charts, page 3-59
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Bl Logging in to DMM-DSM for the First Time

Logging in to DMM-DSM for the First Time

The first time that you log in to DMM-DSM, the username is admin and the password is default. We
strongly recommend that you change at least the password immediately. To learn how to change the
username as well as the password, see Configuring DMM-DSM User Accounts, page 3-49.

Configuring DMPs to Support Centralized Management

You must configure your DMPs to recognize the authority of your DMM appliance, so that you can
manage them centrally in DMM-DSM. This process occurs automatically when you autodiscover DMPs,
but if autodiscovery is somehow not suitable, you can also perform the required steps manually.

e To understand autoregistration, see Managing and Grouping DMPs, page 3-3.

e To learn how to use autoregistration, see the “{ Add New | Edit} DMP Group” row in Table 3-1 on
page 3-5.

DMM-DSM and your DMPs communicate over TCP port 7777 when centralized management
is enabled.

A

Caution  To stop untrusted DMM appliances from being able to seize control of your DMPs, you must configure
your network firewall to restrict which devices you will permit to send inbound traffic to your DMP over
TCP port 7777. If you do not know how to work with access control lists, see the manufacturer
documentation for your firewall.

Do the following for each DMP that you will manage centrally.

Step1  To log in to the embedded device management software, point your browser to the DMP IP address.
Step2 At the login prompt, enter the username and the password that you configured for the DMP.
Step3  In the Settings area, click Centralized Management, then enter the required values:

e DMM Appliance IP Address— The IP address of your DMM appliance.

e DMM-DSM Server Timeout (in seconds) —The maximum number of seconds that your DMP
should wait for a response from your DMM appliance.

Step4  To confirm your entries and to implement them until you change them or until you restart the DMP,
click Apply.

Step5 In the Administration area, to make your configuration changes permanent even after you restart your
DMP, click Save Configuration, then (after you see the Save Configuration page) click Save.

Step6  Click Restart DMP, then (after you see the Restart DMP page) click Restart.
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Enabling the CVBS (Component Video) Interface on DMPs

Step 1
Step 2

Step 3
Step 4

Step 5
Step 6

To take advantage of the latest features, options, and modern technologies, most digital signage
environments use digital displays. However, some networks might include legacy devices and
technologies, including analog displays. If you use analog displays or have any other reason to use
Component Video cables when you connect your DMPs to their displays, you must first enable the
CVBS interface on your DMPs.

Select Digital Signage Module from the untitled list at the top far-right of any page.

Select Digital Media Players > Advanced Tasks, then click the System Tasks row in the Application
Types list.

Click _| Add New Application.

After the page is refreshed, select the required options and enter the required values for this task:
a. In the Name field, enter DMP_Enable_ CVBS_(Component_Video).

b. In the Description field, enter Enable DMP support for Component Video output.

c¢. From the Request Type list, select Set.

d. In the Request field, enter sigma.conn=6&sigma.tvst=91&sigma.cspc=1&mib.save=1.

To save your selections, click Submit.

To deploy to any of your DMPs the “DMP_Enable_ CVBS_(Component_Video)” task that you defined
and saved, see Deploying Saved Commands and Presentations to Your DMPs, page 3-42.

Managing and Grouping DMPs

You can organize your DMPs in groups and manage them collectively instead of managing only one
DMP at a time. We recommend that you create DMP groups to organize your DMPs according to
characteristics that they have in common, such as where or how you will use them, but you can group
your DMPs according to whatever logic works best for you. For example, the logical basis for your DMP
groups might be geographic (by state, province, or metropolitan area) or corporate (by product team,
sales region, time zone, primary spoken language, or type of facility), as in this illustration:

= oALL DMPs
lll:undl:un

#s5an jose
lfinance
#marketing

DMM-DSM includes a feature to autoregister your DMPs so that you do not have to register each DMP
manually. Autoregistration finds every DMP in the subnets that you specify, configures those DMPs to
know and trust the IP address for your DMM appliance, restarts the DMPs, and registers them in
DMM-DSM for centralized management. To learn how to use autoregistration, see the “{ Add New |
Edit} DMP Group” row in Table 3-1 on page 3-5.

Autoregistration requires that all of the DMPs in your digital signage network share identical user
credentials for their DMP Web Account and identical user credentials for their DMP Service Account.
For more information, see Quick Start Guide for Cisco Digital Media Player 4305G on Cisco.com.
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W  Managing and Grouping DMPs

TCP ports 6666 and 7777 are open on DMPs and you cannot close them. DMM-DSM uses TCP
port 7777 to communicate with DMPs and Cisco staff use TCP port 6666 to troubleshoot DMPs.

Step 1 Select Digital Signage Module from the untitled list at the top far-right of any page.
Step2  Select Digital Media Players > DMP Manager.
Step3  Select the options and enter the values that meet your requirements.

If you do not understand your options, see Table 3-1 on page 3-5. When you make selections anywhere
on the DMP Manager page, it is updated automatically to show the options and features that are relevant
to your selection.

Note  Important considerations apply to your digital signage network if any of your DMPs uses an HTTP proxy
server. It is unusual and not scalable to manage many DMPs that share one HTTP proxy server. We
recommend that you do not use proxies.

e We recommend that you use Web Cache Communication Protocol (WCCP) to reroute HTTP
requests transparently, instead of using a proxy server. To learn how to use WCCP if you do not
already know how, see Cisco.com.

e To configure one DMP to use one proxy server, use DMPDM, not DMM-DSM. See the “Adjusting
Basic Network Settings” topic in User Guide for Cisco Digital Media Player Device Manager 1.1
on Cisco.com.

¢ To configure many DMPs to share one proxy server, even though we recommend that you do not,
Select Digital Media Players > Advanced Tasks, click System Tasks in the list of defined tasks,
then click _| Add New Application. Enter a name and description, then select Set from the Request
Type list and use this syntax in the Request field:
init.BROWSER_PROXY=<on|off>s&init.BROWSER_PROXY_IP=
<proxy_server_IP_address>sinit.BROWSER_PROXY_PORT=<proxy_server_logical_port>.

For example, if the proxy server uses 192.168.12.12 as its IP address and delivers proxy services
through port 5678, the Request string would look like this: init.BROWSER_PROXY=on&init.
BROWSER_PROXY_TIP=192.168.12.12&init.BROWSER_PROXY_PORT=5678&mib.save=1&mng.reboot=1.

To remove that example proxy, you would select Set from the Request type list, then enter this
Request string: init.BROWSER_PROXY_IP=&init.BROWSER_PROXY_PORT=&init.BROWSER_PROXY=off

&mib.save=1&mng.reboot=1.
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Table 3-1 Elements for Managing DMPs
Element Icon and Description
DMP Groups A hierarchical tree (an object selector) of DMP groups, subgroups, and DMPs. From the object

selector, you can add or remove group assignments for registered DMPs, create new groups, edit
existing groups, and make selections for which DMPs the DMP List pane should describe.

One group can contain another and the choices that you make for centralized management propagate
from parent (DMP group), to child (DMP subgroup or DMP), to grandchild (DMP). There is no
maximum number of levels that you can add to the hierarchy, but a simpler organization is more
scalable than an unreasonably complex one would be. We recommend that you do not assign any
DMP to the root level in the hierarchy, due to the complexity of management, but you can do this if
you choose to.

| |Add New DMP Group— Shows the Add New DMP Group pane, where you:

¢ Enter a name and description for the group.

e (Optional) Define one or more ranges of IP addresses that DMM-DSM should use to
autoregister DMPs.

/| |Edit DMP Group—Shows the Edit DMP Group pane, described elsewhere in this topic.
%] |Delete DMP Group— Deletes the group that you highlighted.

# |Opened Group— Shows the list of group members until you click to hide them.

@ |Closed Group—Hides the list of group members until you click to show them.

# |DMP—A DMP that you assigned to the relevant parent group.

User Guide for Cisco Digital Media Manager 4.1
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W  Managing and Grouping DMPs

Table 3-1 Elements for Managing DMPs (continued)
Element Icon and Description
DMP List A list of all DMPs contained in (or under) the level that you clicked in the DMP Groups object selector.

To see a list of every registered DMP, click the group that represents the root level of your digital signage
network. The interval between polling cycles is 2 minutes, so any newly added DMP might report
temporarily that it is unavailable; if this happens to you, wait a few minutes, then check again.

Actions—List from which to select a presentation that you designed and saved in DMD, a task
that you configured and saved on the Advanced Tasks page, or a task that DMM-DSM includes
by default. DMM-DSM can perform the corresponding action on one or more DMPs that you
select from the DMP List table. After you select the DMPs and the action, click Go. The specified
action starts immediately.

Add New DMP— Shows the Add New DMP pane, where you enter a name, [P address, MAC
address, and description for the DMP.

Edit DMP — Shows the Edit DMP pane. A registered DMP might become unavailable if it
receives a new dynamic IP address from the DHCP server at its deployment site. In this case, you
should restart the DMP or edit the IP address record that DMM-DSM maintains for the DMP.

Delete DMP— Deletes the DMP that you highlighted.

)| [,

LCD Control—Opens the LCD Control popup window, where you can configure parameters
(for some display types manufactured by NEC and DMTECH.!) for a DMP display.

Assign DMP to Group—Creates an association between at least one DMP and at least one
group. Do the following:

1. Click "

2. In the DMP List pane, click one or more DMPs to select them.

3. In the object selector, click one or more DMP groups that the selected DMPs should join.
4. Click &" again.

Remove DMP from Group— Deletes the association between at least one DMP and at least one
group. Do the following:

1. Click ¥.
2. In the DMP List pane, click one or more DMPs to select them.

3. In the object selector, click one or more DMP groups from which to disassociate the
selected DMPs.

4. Click &¥ again.

Filter— Select a filter type? from the list, then click Go to see only the DMPs that match your filter.

Display Number —The maximum number of rows that the table should show per page if it
straddles multiple pages.

Status— Says whether a DMP is reachable. A green icon () tells you that the DMP is connected
to a power source, uses a known IP address, and is reachable. A red icon (X) tells you that the
DMP is unreachable.

Name— A unique and human-readable name that you entered or that DMM-DSM chose; If
DMM-DSM chose the name, it is either the DMP IP address or MAC address.

IP—The public IP address at which the DMP receives instructions and data from DMM-DSM.

Version—The release number for the installed firmware version on the DMP.

Description— The description that you entered.
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Table 3-1 Elements for Managing DMPs (continued)

Element Icon and Description

{Add New | Edit} You can create or edit a DMP group. You must specify the group name and description. In addition, you
DMP Group can populate the group automatically with all of the DMPs in any CIDR address range that you specify.

The address range can span one subnet or multiple subnets. You can schedule multiple DMP discovery
operations to run simultaneously if they all search the same one subnet. If the DMP discovery operations
that you configure do not all search the same one subnet, you should not schedule them to run
simultaneously. If you do, only the first such operation will run and DMM-DSM will not show any error
message to explain why the other discovery operations failed to find any DMPs. If you must run DMP
discovery tasks that search different subnets, schedule a 35-minute interval between the start time for one
discovery and the start time for the next discovery. In a very large network that contains thousands of
DMPs, the required interval might be longer than 35 minutes. When you autodiscover a DMP, it restarts
immediately even if it is already centrally managed by a different DMM appliance than the one that you
are using, and even if it is showing a presentation on its DMP display. Therefore, we recommend that you
be careful to autodiscover only those DMPs that you are not already managing from any of your DMM
appliances. Otherwise, you might temporarily disrupt the deployment of presentations and their assets in
your digital signage network. Autodiscovery operations follow this sequence:

1. DMM-DSM scans every device in the specified CIDR address range, looking for devices where
TCP ports 6666 and 7777 are both open. This phase fails if you have disabled the “Enable TAC
Troubleshooting Access” option in DMPDM (which is enabled by default) and unless your
firewall allows ICMP traffic to pass from your DMM appliance to your DMPs.

2. After finding a device with ports 6666 and 7777 open, DMM-DSM learns the IP address for the device
and compares that address to the registered DMPs. A registered DMP might receive a new dynamic
IP address from the DHCP server at its deployment site and the new IP address might be within the
CIDR range that you specified for autodiscovery. In this case, DMM-DSM will not centrally manage
the DMP until you edit the IP address record that DMM-DSM maintains for the DMP.

3. When one of these IP addresses does not match any DMP that DMM-DSM has registered (even if it
is registered with a different dynamic IP address or centrally managed by a different DMM appliance
than the one that you are using), DMM-DSM assumes that the associated device is an unregistered
DMP and transmits DMP-specific instructions to the device, including an instruction to restart.

4, If the device is a DMP, it restarts.

5. If the DMP is not centrally managed already by a different DMM appliance, it transmits
information to DMM-DSM to enable centralized management of the DMP as an endpoint in your
digital signage network.

— |Name— A unique and human-readable name for the group.

— |Description— A brief description of the group and its purpose.

_| |Add New Range—IP address subnet ranges in which to find and autoregister DMPs. The netmask
typically is /24. To find every DMP in a subnet, use O (zero) as the only digit in the fourth quad, such
as 192.0.2.0/24. To find one DMP whose address is already known to you, enter its [P address and the
netmask but use a comma instead of the fourth dot, like 192.0.2,50/24.

%] |Delete a Range— Deletes the range that you highlighted.

— |Automatic Grouping Ranges— Shows a list of all the defined CIDR address ranges. Click a
range to edit it.

— |Range (CIDR)—The field where you edit one CIDR address range at a time. For DMP autodiscovery
to succeed, the routers, switches, and firewalls that pass packets between your DMM appliance and

the specified CIDR address range must allow TCP ports 6666 and 7777 to send and receive packets.
and must allow ICMP traffic to pass from your DMM appliance to your DMPs.

User Guide for Cisco Digital Media Manager 4.1
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W Creating Categories and Organizing Assets for Digital Signage

Table 3-1 Elements for Managing DMPs (continued)

Element Icon and Description

{Add New | Edit} Note We recommend that you never use manual registration for any medium- or large-scale
DMP deployment. To understand autoregistration, see the “{Add New | Edit} DMP Group” row,

elsewhere in this table.

Make selections and enter required values to add one DMP manually.

— |DMP Name— A unique and human-readable name for the DMP.

— |DMP IP—The public IP address that receives instructions and data from DMM-DSM.
— |DMP MAC—The MAC address that the DMP NIC uses.

— |DMP Description—Optional, brief description of the DMP, its deployment site, or anything that
is relevant or meaningful to you.

1. The DMP display properties that you can select and configure in the LCD Control popup window are as follows:
TV Type—Select the manufacturer and the model type {DMTECH | NEC_3210 | NEC_4010 | NEC_4610 | NEC_5710}.
Contrast—Select or enter a contrast value from 0 to 100.
Brightness—Select or enter a brightness value from 0 to 100.
Sharpness— Select or enter a sharpness value from 0 to 100.
Color—Select or enter a color value from 0 to 100.
Tint—Select or enter a tint value from 0 to 100.
TV Channel— Select or enter the analog television signal frequency for a channel from 0 to 99.
Audio Volume—Select or enter a volume level from 0 to 100.
Mute—Select whether to mute the display {on | off}.
Input—Select the input type {TV | RGB | RGB1 (DVI-D) | RGB2 (D-SUB) | RGB3 (BNC) | DVD/HD | Video (Composite) |
Video 11 Video 2 | Video 3 | S-Video | None (DVD) | Component) | PC | HDMI | None (DVBT)}. Options vary according to the manufacturer
and device model.
® Power—Select whether the television should be turned on {on | off}.
To save your work in the LCD Control popup window, click Submit. Otherwise, to discard your work, click Cancel.

2. The filter types are as follows:

Status— Select Up or Down to limit matches by DMP availability.

Name—Enter the text string to limit matches by DMP name.

IP—Enter any part of the “dotted quad” to limit matches by DMP IP address.

MAC —Enter the text string to limit matches by DMP MAC address.

Description—Enter the text string to limit matches by DMP descriptions.
Version—Enter the text string to limit matches by DMP firmware release version number.

Creating Categories and Organizing Assets for Digital Signage

You can organize your assets in categories for simplified management. We recommend that you create
categories for sets of characteristics that your assets have in common—such as their filetype, intended
audience, or genre.

Note  This release does not support audio in Shockwave Flash media. If your media library contains any
Shockwave Flash files that use audio, their playback will be silent on your DMP displays.

Step1  Select Digital Signage Module from the untitled list at the top far-right of any page.
Step2  Select Media > Media Library.

Step3  Enter the values and select the options that meet your requirements. To understand the options, see
Table 3-2 on page 3-9.
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Table 3-2 Elements for Managing Media Files

Element

Icon and Description

Media Categories

An unsorted, nonhierarchical list (an object selector) of all the categories in your media library. From
the object selector, you can create new categories, edit existing categories, delete categories, or click
the one category that the Media Files pane should describe. You can add almost any number of

categories to your media library, but you cannot make any category subordinate to any other category.

Note  You can add assets at the root level of your media library, but we recommend that you do not.
If you do, you must manage them one at a time, instead of managing them as a group.

A category contains assets.

w |Add New Media Category — Shows the Add New Media Category pane, where you enter a name
and description for the category.

e |Edit Media Category— Shows the Edit Media Category pane.

me | Delete Media Category — Deletes the category that you highlighted.

# |Opened Media Library— Shows all the categories in your media library.

Closed Media Library— Hides the list of categories until you click to show them.

s
# Media Category— A category that you created.
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W Creating Categories and Organizing Assets for Digital Signage

Table 3-2 Elements for Managing Media Files (continued)

Element

Icon and Description

Media Files

A list of all assets contained in the category that you clicked in the Media Categories object selector.

Note To assign an asset to more than one category, you must upload a new copy of the asset for

each category that should use it. You cannot move any asset directly from one category to
another. To move assets between two categories, you must delete each relevant asset entry in
the first category, then create an equivalent entry in the second category.

Few

Add New Media— Shows the Add New Media pane, described elsewhere in this topic.

Note Depending on the filesize and on network performance, a large file might take several
minutes to import. If you navigate to any other page in your browser while DMM-DSM
is importing a file, import fails.

Edit

Edit Media— Shows the Edit Media pane, described elsewhere in this topic.

Delete

Delete Media— Deletes the asset that you highlighted.

Batch Media Download — Shows the Batch Media Download pane, described elsewhere in
this topic.

We do not support any use of spaces in filenames or URLs.

The untitled table sorts information into these columns:
e Name—A unique and human-readable name that you entered.
* Source—Says whether the asset is a file (F) or an HTTP URL (U).
¢ Data Type—Identifies the format of the asset that the corresponding row describes.
¢ Size—The filesize in bytes.
e Path—The full pathname that points to the asset file on the DMP.
e Description— The description that you entered.

¢ Upload Started — Time stamp (in the format vyyyy-MM-DD hh:mm:ss:ms) that says when you
started to upload the file.

¢ Upload Finished —Time stamp (in the format yyyy-MM-DD hh:mm: ss :ms) that says when the
file was completely uploaded.

e Status— Says whether the upload succeeded or failed for the asset that the corresponding
row describes. A green icon (v) tells you that the upload succeeded. A red icon (X) tells you
that the upload failed.

{Add New | Edit}
Media Category

Make selections and enter required values to add or edit categories.

Name— A unique and human-readable name for a category.

Description— A brief description of the category and its purpose.
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Table 3-2 Elements for Managing Media Files (continued)

Element

Icon and Description

{Add New | Edit}
Media

Make selections and enter required values to add one asset, then click Submit.

Before you add any asset, confirm that its filesize is not more than 1.9 GB, which is the maximum
stream size for any file that you include in the layout for a DMD presentation.

For purposes of stage-one failover, the combined size of all files cannot exceed 900 MB. To
understand failover, see the “Understanding Content Substitution (Failover)” topic in User Guide for
Cisco Digital Media Player Device Manager 1.1 on Cisco.com.

Note This release does not support audio in Shockwave Flash media. If your media library contains
any Shockwave Flash files that use audio, their playback will be silent on your DMP displays.

Tip After you start to import an asset, do not click any browser button or navigate away from this
page until the import is finished. If you do, the import will not finish successfully.

— |Source of Content—The full local pathname or remote HTTP URL of the asset. We do not
support any use of spaces in filenames or URLs.

Do one of the following:
¢ Click File, then click Browse or enter the full local pathname.

e Click URL, enter the URL, then select or deselect the Download URL check box to choose
whether to download a local copy of the asset or use the version of it that is stored remotely.

Tip We recommend that you do not use your DMM appliance as if it is a storage server. It has
limited capacity to store files and DMM might not function as designed if space runs low.

— |Select Content File Type—Select the type that best applies to the asset:

¢ Firmware—A firmware image for the DMP. The filename extension must be FWIMG
or BIN. See Table 3-10 on page 3-35.

e Flash— An Adobe (Macromedia) Shockwave Flash 6 or 7 file. The filename extension must
be SWF.

e HTML —A web page. The filename extension must be HTM or HTML.

¢ Video— A video file in MPEG-1, MPEG-2, or MPEG-4 format. The filename extension
must be MPG, MPEG, or MP4. (Our support for MPEG-4 requires that you use the MPEG-4
Part 2 codec and that you multiplex audio and video in an MPEG-2 transport stream.)

e Image—A standard image file, such as a nonprogressive JPEG image. The filename
extension must be JPG, JPEG, GIF, or PNG.

— |Name— A unique and human-readable name for the asset.

— |Description— Optional, brief description of the DMP, its deployment site, or anything that is

relevant or meaningful to you.

— |Content Creator Name— Your name or the name of the person who added the asset.
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Table 3-2

Elements for Managing Media Files (continued)

Element

Icon and Description

Batch Content
Download

Make selections and enter required values to add multiple assets, then click Submit. The amount of
time that the batch download operation requires depends on the speed of your connection, the number
of directory levels that you search for downloadable files, and the total combined filesize of all files
that you transfer.

Before you add any asset, confirm that its filesize is not more than 1.9 GB, which is the maximum
stream size for any file that you include in the layout for a DMD presentation.

Note This release does not support audio in Shockwave Flash media. If your media library contains
any Shockwave Flash files that use audio, their playback will be silent on your DMP displays.

— |Base URL—An HTTP URL that points to a directory on a server. The directory that you point
to serves as the root-level URL for the batch download operation; every file that you download
is retrieved from this directory or from one of its children at a lower level. We do not support any
use of spaces in URLs.

— |Pattern— The filename pattern that identifies which files to download. For example, to
download every file that uses the three-letter MPG filename extension, the pattern is *.MPG. We
do not support any use of spaces in filenames.

Note Do not enter the filename pattern to use any unsupported filetype.

— |Content Type— Select the type that best applies to files in the batch download:

¢ Firmware—Firmware image files for the DMP. The filename extension must be FWIMG
or BIN. See Table 3-10 on page 3-35.

e Flash— Adobe (Macromedia) Shockwave Flash 6 or 7 files. The filename extension must
be SWF.

e HTML—Web pages. The filename extension must be HTM or HTML.

¢ Video— Video files in MPEG-1, MPEG-2, or MPEG-4 format. The filename extension must
be MPG, MPEG, or MP4.

¢ Image— Standard image files, such as nonprogressive JPEG images. The filename extension
must be JPG, JPEG, GIF, or PNG.

— |Levels—The number of levels below the specified base URL to search for (and download) files
with filenames that match the specified pattern.

Developing Presentations, Templates, and Playlists for Signage

Digital Media Designer (DMD) is a powerful, drag-and-drop design tool that helps you to create
customized presentations for digital signage. It includes predesigned templates that you can use as a
jumping-off point for your designs or you can create designs that are entirely your own. DMD supports
horizontal and vertical screen orientations. With DMD, you:

¢ Subdivide the screen space on a DMP display into rectangular areas called screen zones.

e Select the media objects, called assets, to play back in those screen zones—including media from
digital video files, JPEG files, SWF files, RSS feeds, ordinary web pages, and other popular
media types.

e Add assets to, and configure the timeline for, any screen zone that represents a playlist.
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Although you use your browser to start DMD, it runs outside your browser, in Java Web Start. You can
open and work with only one template or one presentation at a time. Presentations for digital signage
most commonly divide screen space into two, three, or four screen zones, but you can create more zones
for a presentation in DMD if you need more.

After you create, edit, and save a presentation, you can deploy it to your DMPs from the DMM-DSM
scheduler. Each affected DMP then restarts automatically before it starts to show the presentation. To
learn how to deploy a presentation to your DMPs, see Deploying Saved Commands and Presentations to
Your DMPs, page 3-42.

This section contains these topics:
e Before You Start to Use Digital Media Designer, page 3-13
e Getting Started with DMD, page 3-14
e DMD User Interface Reference, page 3-16
e Creating and Organizing Playlists for Your Presentations, page 3-27

e Supported Fonts, page 3-31

Before You Start to Use Digital Media Designer

Use the following checklist to track your compliance with the requirements and recommended best
practices for using DMD successfully.

v/ |Requirements and Recommendations

Prerequisites

D 1. Ensure that Java Runtime Engine (JRE) 1.6.0 or later is installed on your PC. Also confirm that it is
configured to use English as its language, and that it is working correctly. The JRE 1.6.0 release is part of Java
Version 6.

¢ To learn exactly which JRE release you are using and to confirm that it is working correctly, go to
http://java.com/en/download/help/testvm.xml.

e To understand the Java release naming conventions, which have changed over time, see
http://java.sun.com/javase/namechange.html.

e To obtain the required JRE, go to http://javasoft.com, click Java SE, then download the latest JRE version.

e Apple maintains and distributes its own implementations of Java software for Mac OS users. To learn if Apple
has made available any JRE that is based on JRE 1.6.0, see http://www.apple.com/java. Alternatively, registered
Apple Developer Connection (http://connect.apple.com/) members might find that Apple has released a preview
version of a compatible JRE. We make no claims about the suitability of such software for any purpose and
recommend that you test all software thoroughly before you rely on it.

D 2. If you use Windows, select Start > Settings > Control Panel > Internet Options, then click the Advanced tab.
Scroll to the Browsing area, deselect the Enable third party browser extensions (requires restart) check box,
then click OK.

0 3. Ensure that your DMPs use firmware version 2.43. You cannot use DMD if your DMPs use any earlier firmware
version. To check the firmware version on a DMP, log in to its local instance of DMPDM, then click About. If you
learn that you must obtain new firmware, go to http://www.cisco.com/cgi-bin/tablebuild.pl/dms.

0 4. You must enable popup windows in your web browser. See the manufacturer documentation for your browser
and for any installed third-party browser extensions, such as toolbars that provide popup-blocking features.
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v/ |Requirements and Recommendations

5. You must already have created and saved the media files that your presentation will show. See Creating
Categories and Organizing Assets for Digital Signage, page 3-8.

(.

D 6. Confirm that none of the individual assets that you will show has a file size any larger than 1.9 GB. If any file
has a larger file size, the presentation that should show the file shows nothing and your DMP device logs will
describe many errors. This size is constrained by the limits of streaming.

D 1. Make note of the collective file size for the assets in your presentation. If you will use the advanced task called
“File Transfer to DMP or Server” to deploy your presentation to the SD memory card inside a DMP, confirm that
the combined file size for all assets that you will show in the presentation is not collectively any larger than:

¢ For playback on a DMP 4300G—900 MB.
¢ For playback on a DMP 4305G—1.9 GB

This size is constrained by the storage capacity of the SD memory card in a DMP. If you deploy a presentation to
the SD memory card, the assets from that presentation will serve as the basis for stage-one failover on that DMP.
If the combined file size for a presentation is too large, only stage-two failover is available. See the “Understanding
Content Substitution (Failover)” topic in User Guide for Cisco Digital Media Player Device Manager 1.1 on
Cisco.com.

Recommended Best Practices

0 8. Understand the factors that can interfere with smooth playback in streaming media. Playback of media in a
presentation might be slow or jerky or might fail if:

¢ You neglect to carefully consider the network bandwidth requirements and DMP memory and CPU
requirements for the sum total of all assets that you will play simultaneously in a presentation.

e Your presentation uses too many processor-intensive assets. Remember that some file types (SWF, for
example) are more likely than others to require extra processing to play back.

D 9. Understand the effects on your presentations of the “safe area” on your DMP displays. If you use analog

DMP displays that are old or inexpensive, be sure that your layouts for signage do not extend past the dotted line
in DMD that designates the safe area all around the edge of a screen object. The safe area helps you to compensate
for such displays, which use only approximately 90 percent of their screens.

Getting Started with DMD

You can create the layout for a new presentation or edit a presentation that you created previously.

Step1  Select Digital Signage Module from the untitled list at the top far-right of any page.

Step2  To start Digital Media Designer so that you can define a set of screen zones, select the Designs tab, then
click Start Digital Media Designer.

Step3  When prompted, select the option to use Java Web Start.
DMD opens.

In DMD, select the options and enter the values that meet your requirements. To understand the options,
see DMD User Interface Reference, page 3-16.

Stepd  To save your work in DMD when you are done, select File > Save.
Step5  To close DMD when you are done, select File > Exit.

Step6  (Optional) Deploy the presentation to a DMP group. See Deploying Saved Commands and Presentations
to Your DMPs, page 3-42.
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Note e To show a presentation during stage-one failovers on a DMP, you must first create and deploy a “File
Transfer to DMP or Server” task that saves copies of the presentation and its assets to the SD memory
card inside the DMP. When you do this, DMM-DSM automatically creates a “Go to URL” task. The
name by default for this generated task is “failover - <name_of_presentation>.” If a DMP should show
its locally stored presentation at any time other than during stage-one failover, you must deploy the
corresponding Go to URL task to the DMP. See Deploying Saved Commands and Presentations to
Your DMPs, page 3-42.

e After you delete a presentation for which DMM-DSM automatically generated a corresponding Go
to URL task, you must also delete that Go to URL task.
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DMD User Interface Reference

Figure 3-1 on page 3-16 shows the Digital Media Designer user interface as it looks when you first open
it in Java Web Start.

Figure 3-1 Digital Media Designer
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In Digital Media Designer, the workspace is the largest part of the user interface. After you enter values
for it so that it has the same height and width in pixels as the screen on your DMP display, the workspace
is where you design your presentations and presentation templates for digital signage.

In addition to its workspace, the user interface in Digital Media Designer consists of four menus, a
toolbar, and four dockable panels.

e Understanding the Menus and Their Options, page 3-17
e Understanding the Toolbar and Its Options, page 3-20
e Understanding the Panels and Their Options, page 3-21
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Understanding the Menus and Their Options

Table 3-3

Table 3-3 on page 3-17 describes the menus in Digital Media Designer.

Digital Media Designer Menus

Menu Option

Description

File Menu

New

Shows the New Design/Template dialog box, which lists all of the templates that you have saved as well
as all of the presentation templates that Cisco provides with DMD, minus any presentation templates that
you have deleted. Select the template that meets your requirements or select a blank canvas. When you are
done, click OK to start work on your design, or click Cancel to discard your selections and return to

the canvas.

e {Landscape | Portrait} —Click a tab so that you can select or configure preliminary options for a
design that will use the corresponding orientation.

e untitled table—Most rows describe one presentation template apiece that you can use as the basis for
a new presentation or as the basis for a new presentation template. Alternatively, you can select the
blank canvas that one row describes. (The blank canvas is described, by default, in the first row.) To
re-sort the table by the attributes that the Thumbnail, Screen Resolution, Name, or Description columns
show, click the corresponding column heading. Click a row to select the presentation template or the
blank canvas that the row describes.

¢ Filter—Enter any part of a presentation template name to filter out from the table all presentation
templates whose descriptions do not match your text string. The filtering occurs in real time as you
enter text.

¢ Resolution— Enter the resolution width and height in pixels that your presentation design will use.
This feature is available only when you have selected to use a blank canvas. To learn the native
resolution for a display, see its manufacturer documentation.

Open

Shows the Open dialog box, which lists all of the presentations and presentation templates that you have
saved, in addition to the presentation templates that Cisco provides with DMD, minus any presentations or
presentation templates that you have deleted. To open a design so that you can review or change it, select
it, then click OK. Alternatively, to return to the canvas without opening a design, click Cancel.

e {Presentations | Presentation Templates} —Click a tab to restrict the type of designs that the table
should describe.

e untitled table—Each row describes one design. To re-sort the table by the attributes that the
Thumbnail, Screen Resolution, Name, or Description columns show, click the corresponding column
heading. Click a row to select the presentation or the presentation template that the row describes.

¢ Filter—Enter any part of a design name to filter out from the table all of the saved designs whose
descriptions do not match your text string. The filtering occurs in real time as you enter text.

[ oL-13984-01
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Table 3-3

Digital Media Designer Menus (continued)

Menu Option

Description

Save

One of these:

e If you are designing a layout that you have not yet saved and named, opens the “Add New Presentation
or Presentation Template” dialog box. Select the options and enter the values that meet your
requirements. When you are done, click OK to save your work or click Cancel to discard your work.

— Name—A unique and human-readable name for the layout. The name is unique in the sense that
you have not used it previously as the name for any presentation or presentation template, or for
anything that you created under the Digital Media Players tab in DMM-DSM.

— Description— A brief description of the layout and its purpose.

— Resolution— Shows in pixels the width and height that your design will require as a supported
resolution on your DMP display. Uses this syntax: NNNNxNNN. For example, 1366x768 would
specify a display that can show as many as 1,366 pixels horizontally and as many as 768 pixels
vertically. Confirm that the values you see are not any greater than what your DMP display can
actually show.

- Presentation—Identifies the layout as a one-time design. A presentation is a design that uses a
freeform layout or uses a layout derived from a presentation template.

— Presentation Template—Identifies the layout as a foundational design. A presentation template
is the basis, potentially, for multiple presentations that you expect to create in the future, which all
will share a common look and feel.

e If you are working on a layout that you saved previously, saves your work since then.

Save As

Opens the “Save As Presentation or Presentation Template” dialog box, so that you can save multiple
variants of a presentation or a template, or so you can overwrite a saved presentation or saved presentation
template that you no longer need. Select the options and enter the values that meet your requirements. When
you are done, click Save to save your work or click Close to discard your work.

e {Presentations | Presentation Templates} tab— Determines whether the table under the tab shows
information about your saved presentations or about your saved presentation templates. Each row in
the table shows a thumbnail picture of the corresponding design and describes its attributes.

e Name—A unique and human-readable name for the design. The name is unique in the sense that you
have not used it previously as the name for any presentation or presentation template, or for anything
that you created under the Digital Media Players tab in DMM-DSM.

¢ Description— A brief description of the design and its purpose.

¢ {Resolution | Screen Resolution } — Shows in pixels the width and height that your design will require
as a supported resolution on your DMP display. Uses this syntax: NNNNxNNN. For example,
1366x768 would specify a display that can show as many as 1,366 pixels horizontally and as many as
768 pixels vertically. Confirm that the values you see are not any greater than what your DMP display
can actually show.

e Presentation—Select this radio button to identify the layout as a one-time design that uses a freeform
layout or a layout that you will derive from a presentation template.

e Presentation Template— Select this radio button to identify the layout as a foundational design. A
presentation template is the basis, potentially, for multiple presentations that you expect to create in
the future, which all will share a common look and feel.
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Table 3-3 Digital Media Designer Menus (continued)

Menu Option Description

Delete Shows the Delete Presentation(s) and/or Presentation Template(s) dialog box, which lists all of the
Presentation/ presentations and presentation templates that you have saved, in addition to the presentation templates that
Template Cisco provides with DMD, minus any presentations or presentation templates that you have already

deleted. To delete a design, select it, then click Delete Selected Presentation. To return to the canvas
whether or not you have deleted any designs, click Close.

e {Presentations | Presentation Templates} —Click a tab to restrict the type of designs that the table
should describe.

e untitled table—Each row describes one design. To re-sort the table by the attributes that the
Thumbnail, Screen Resolution, Name, or Description columns show, click the corresponding column
heading. Click a row to select the presentation or the presentation template that the row describes.

¢ Filter—Enter any part of a design name to filter out from the table all of the saved designs whose
descriptions do not match your text string. The filtering occurs in real time as you enter text.

Exit Closes DMD.
Edit Menu

Whole Screen  |Expands the selected object so that its height and width become the same as the total height and width of
your layout. To reduce its dimensions again if you prefer to use smaller dimensions, edit the height and
width values that the Properties panel shows for the selected object. This feature is not available for you to
use unless at least one object is selected on the workspace or in the Layouts panel.

Safe Area Expands the selected object so that its height and width become the same as the height and width of the
safe area in your layout. To change its dimensions again, edit the height and width values that the Properties
panel shows for the selected object. This feature is not available for you to use unless at least one object is
selected on the workspace or in the Layouts panel.

Delete Deletes the selected object or action from the workspace. This feature is not available for you to use unless
at least one object or action is selected on the workspace or in the Layouts panel.

Up Moves the selected object up by one layer, in the sense that your layout might position overlapping screen
zones as if they are stacked or piled on top of each other. When you use this option, you make the selected
screen zone more prominent than it was before you moved it. This feature is not available for you to use
unless at least one object is selected on the workspace or in the Layouts panel.

Down Moves the selected object down by one layer. When you use this option, you make the selected screen zone
less prominent than it was before you moved it. This feature is not available for you to use unless at least
one object is selected on the workspace or in the Layouts panel.

Top Moves the selected object to the top layer. When you use this option, the effect is that you make the selected
screen zone more prominent than every other screen zone. This feature is not available for you to use unless
at least one object is selected on the workspace or in the Layouts panel.

Bottom Moves the selected object to the bottom layer. When you use this option, the effect is that you make the
selected screen zone least prominent of all your screen zones. This feature is not available for you to use
unless at least one object is selected on the workspace. or in the Layouts panel

View Menu

{Objects/ Expands or collapses the the Objects/Actions panel, the Navigator panel, the Layers panel, or the Properties
Actions | Layers |panel, respectively. To understand the panels, see Understanding the Panels and Their Options, page 3-21.
| Navigator |

Properties}
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Table 3-3 Digital Media Designer Menus (continued)
Menu Option Description
Tools Menu

Add Action > As described in the “Understanding the Objects/Actions Panel and Its Options” section of Table 3-5 on
page 3-22:

e {Static | RSS} Text Ticker

e Synchronize Playlists

Add Object > As described in the “Understanding the Objects/Actions Panel and Its Options” section of Table 3-5 on
page 3-22:

e Screen

e Box

e Video Playlist

e Nonvideo Playlist

Understanding the Toolbar and Its Options

The toolbar in DMD contains buttons that you click and controls for the degree of workspace
magnification. To understand the toolbar, see Table 3-4.

Table 3-4 Digital Media Designer Toolbar

Icon |Tool Name |Description

H Save Saves your work.
Changes
Delete Deletes from your design the one object or action that is selected on the workspace.
Selected
Object
(4 |Zoom In Increases the degree of magnification by 10 percentage points per click.

4

Incremental |Increases or decreases the degree of magnification by 1 percentage point per click, depending
Zoom respectively on whether you click the arrow head that points up or the arrow head that points down.
Alternatively, you can do either or both of the following:

e Use the scroll wheel on your mouse to increase or decrease the degree of magnification.

e Enter any percentage value in the unlabeled field, then press Enter.

(i |Zoom Out  Decreases the degree of magnification by 10 percentage points per click.

3 |Fitto View Increases or decreases the degree of magnification by whatever percentage amount is necessary to fit
the entire screen object inside the visible workspace.
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Understanding the Panels and Their Options

Panels are dockable controls in the Digital Media Designer user interface that you can move, resize,
expand, or collapse, which contain features to help you design layouts for digital signage. All panels are
opened by default. To understand how to use the features of a particular panel, see:

e Understanding the Objects/Actions Panel and Its Options, page 3-22
e Understanding the Layers Panel and Its Options, page 3-25

¢ Understanding the Navigator Panel and Its Options, page 3-25

e Understanding the Properties Panel and Its Options, page 3-26

Moving Panels To move a panel so that its location is more convenient to you, drag it by its title bar to the location that
you prefer. The only constraint when you move a panel is that one side of it will always be pinned to
the workspace. DMD rearranges and resizes the other panels automatically to create an open space for
the panel that you are moving.

Resizing Panels To change the width or height of a panel, click and drag the vertical or the horizontal border between
it and the workspace. The width or height of nearby panels changes automatically in response.

Collaps_ing and e To collapse a panel, click the square button at the right end of its title bar. In its collapsed form,
Expanding Panels the entirety of a panel is reduced to button form, where the button shows nothing except the panel
name in very small type and is pinned to one edge of the DMD window.

e Toreopen a panel temporarily after you collapse it, click where you see its name pinned to the edge
of the DMD window. After you move your mouse away from the panel, it closes again
automatically.

¢ To reopen a panel that you collapsed, click where you see its name pinned to the edge of the DMD
window, then click the square button at the right end of its title bar.
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Understanding the Objects/Actions Panel and Its Options

Digital Media Designer — The Objects/Actions Panel

Icon

Tool Name

Description

T

)

Box

Creates a new screen zone and a new layer where you can show:

¢ One bitmapped image in JPEG, GIF, or PNG format. (Other filetypes are not supported.) If you
place a bitmapped image in a box object, be sure that the box object uses the same height and width
in pixels that the bitmapped file uses. If the box object is too small, the displayed image will be
cropped. It will not be resized or scaled automatically.

¢ One text string. The string can be completely motionless and presented without any visual effects
when you show it on a DMP display or you can show it in the form of a ticker.)

¢ One background color.

To start using a box object, drag it to the workspace from the Objects/Actions panel or select Tools >
Add Object > Box. To populate and configure a box object, click it on the workspace, then make
selections and enter values in the Properties panel. To understand the Properties panel, see
Understanding the Properties Panel and Its Options, page 3-26.

When you choose which layer to use for a box object in your layout, ensure that you choose a layer that
is lower than any layer that your playlist objects use in the same layout. Otherwise, your DMP displays
will not show the screen zone that the box object represents. To understand the use of layers in DMD,
see Understanding the Layers Panel and Its Options, page 3-25.

If you right-click a box object after it is part of your layout, a shortcut menu appears. To understand its
options, see the “Edit Menu” section in Table 3-3 on page 3-17.

Note  The Properties panel values that you see might be misleading for a box object after you select it
on the workspace, if you have associated it with a ticker action. Furthermore, box object
attributes that you see in the Properties panel can differ according to the type of ticker action
that you use.

If you use a static ticker, there are two possible scenarios. In the first scenario, you enter
Properties panel text for the box object but not for the ticker action, so the ticker shows the text
that you entered for the box object because it has no alternative. In the second scenario, you enter
Properties panel text separately for both the box object and the ticker action, and the ticker
ignores the text that you entered for the box object because instead, it shows the text that you
entered for the ticker action. In that case, even though you can see in the Properties panel that
you entered text for your box object, DMD ignores that text.

There is only one relevant scenario if you use an RSS ticker, assuming that the server for your
RSS feed is reachable and configured correctly. The RSS ticker always shows what it receives
from the RSS server, without regard for any text that you might have entered in the Properties
panel after you selected your box object on the workspace or in the Layouts panel. Even though
you can see in the Properties panel that you entered text for your box object, DMD ignores
that text.
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Digital Media Designer — The Objects/Actions Panel (continued)

Icon

Tool Name

Description

2

Nonvideo
Playlist

Creates a new screen zone and a new layer where you can arrange and play back in any combination an
ordered sequence of JPEG, GIF, and PNG files, SWF files, and pages on web servers. If you place a
bitmapped image in a playlist object, be sure that the playlist object uses the same height and width in
pixels that the bitmapped file uses. If the playlist object is too small, the displayed image will be
cropped. It will not be resized or scaled automatically.

To start using a nonvideo playlist object, drag it to the workspace from the Objects/Actions panel or
select Tools > Add Object > Nonvideo Playlist. A layout can contain any number of nonvideo playlist
objects at a time.

To populate and configure the object, click it on the workspace or in the Layouts panel, then make
selections in the Properties panel. For example, the Properties panel is where you define the playback
sequence for a playlist and define the playback duration for each entry that it contains. To understand
the Properties panel, see Understanding the Properties Panel and Its Options, page 3-26.

You can place this object on any layer in your layout. To understand layers in Digital Media Designer,
see Understanding the Layers Panel and Its Options, page 3-25.

If you right-click a playlist object after it is part of your layout, a shortcut menu appears. To understand
its options, see the “Edit Menu” section in Table 3-3 on page 3-17.

Note The Properties panel values that you see for a selected playlist object might be misleading if you
have used a synchronize playlists action to override the natural timing of transitions between
assets in the playlist. See the “Synchronize Playlists” row elsewhere in this table.

Video
Playlist

Creates a new screen zone and a new layer where you can arrange and play back in any combination
an ordered sequence of video files (MPEG-1 and MPEG-2), SWF files, JPEG, GIF, and PNG files,
multicast video streams, and pages on web servers. If you place a bitmapped image in a playlist object,
be sure that the playlist object uses the same height and width in pixels that the bitmapped file uses.
If the playlist object is too small, the displayed image will be cropped. It will not be resized or

scaled automatically.

To start using a video playlist object, drag it to the workspace from the Objects/Actions panel or select
Tools > Add Object > Video Playlist. A layout cannot contain any more than one video playlist object
at a time.

To populate and configure the object, click it on the workspace, then make selections in the Properties
panel. For example, the Properties panel is where you define the playback sequence for a playlist and
define the playback duration for each entry that it contains. To understand the Properties panel, see
Understanding the Properties Panel and Its Options, page 3-26.

You can place this object on any layer in your layout. To understand layers in Digital Media Designer,
see Understanding the Layers Panel and Its Options, page 3-25.

If you right-click a playlist object on the workspace, a shortcut menu appears. To understand its options,
see the “Edit Menu” section in Table 3-3 on page 3-17.

Note  The Properties panel values that you see might be misleading for a playlist object after you select
it on the workspace, if you have used a synchronize playlists action to override the natural timing
of transitions between assets in the playlist. See the “Synchronize Playlists” row elsewhere in
this table.
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Table 3-5 Digital Media Designer — The Objects/Actions Panel (continued)
Icon |Tool Name Description
= New Screen |Restarts your design process by closing the open layout—discarding any design work in it that you have
not saved—and showing to you a completely new representation of a blank DMP display as
your workspace. Because each presentation and each presentation template can contain only one screen,
the new workspace does not have any objects, actions, or playlists associated with it—even if the closed
layout used them.
To start using a new screen, drag it to the workspace from the Objects/Actions panel or select Tools >
Add Object > Screen. DMD asks you if you really want to proceed. By proceeding, you will discard
any unsaved work in the layout that you close.
S Static Text |Places a static ticker action on your workspace. Its size and placement on the workspace do not matter
Ticker because actions do not, by themselves, occupy any space on a screen.
A ticker action will not produce a visible ticker on your DMP displays until you finish configuring the
association between the action and the object, save your work, and deliver your presentation to a DMP
as part of a scheduled deployment. You can use only one ticker per box object.
The workflow for this action is as follows:
1. To add the potential for a static text ticker to your layout, drag its action type to the workspace from
the Objects/Actions panel or select its type from the Tools menu.
2. Select the action on your workspace.
3. In the Properties panel:
a. Enter text for your ticker in the Text field.
b. From the Assign to Object list, select the box object that should contain the ticker.
(3 RSS Text Places an RSS ticker action on your workspace. Its size and placement on the workspace do not matter
Ticker because actions do not, by themselves, occupy any space on a screen.
A ticker action will not produce a visible ticker on your DMP displays until you finish configuring the
association between the action and the object, save your work, and deliver your presentation to DMPs
as part of a scheduled deployment. Your DMPs will check the RSS feed and update the ticker every
15 minutes. You can use only one ticker per box object.
The workflow for this action is as follows:
1. To add the potential for an RSS ticker to your layout, drag its action type to the workspace from the
Objects/Actions panel or select its type from the Tools menu.
2. Select the action on your workspace.
3. In the Properties panel:
a. Enter the RSS feed source URL for your ticker in the RSS URL field.
The feed that you specify should be one that does not include any file enclosures. We
recommend as a best practice that you use only RSS feeds over which you have direct editorial
control.
b. From the Assign to Object list, select the box object that should contain the ticker.
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Table 3-5 Digital Media Designer — The Objects/Actions Panel (continued)

Icon |Tool Name

Description

B Synchronize
Playlists

Places a synchronization action on your workspace. Its size and placement on the workspace do not matter
because actions do not, by themselves, occupy any space on a screen.

You use a synchronization action to bind two playlist objects together in a layout, imposing the playback
timing from the primary playlist on, and overriding, the playback timing for the secondary playlist. In this
way, you can synchronize transitions in two playlists, no matter how asynchronous those transitions would
be ordinarily. The workflow is as follows:

1. To add the potential for synchronization to your layout, drag a Synchronize Playlists action to
the workspace from the Objects/Actions panel or select Tools > Add Action >
Synchronize Playlists.

2. In the Properties panel:
a. From the Primary Playlist list, select the primary playlist object.
b. From the Secondary Playlist list, select the secondary playlist object.

Note If you plan ahead, you can keep in mind the eventual synchronization of two playlists when you
populate them and configure the playback duration for each asset. If you do not plan ahead,
synchronization might truncate the playback for one or more assets in the secondary playlist.

Understanding the Layers Panel and Its Options

The Layers panel lists all of the objects that you have dragged to your workspace, sorted by their
placement on different layers. Each layer holds one object only, and each object represents one
screen zone.

e The object at the bottom of the list is also the screen zone that is behind or under all of your other
screen zones in this layout.

e The object at the top of the list is also the screen zone that is in front of or on top of all of your other
screen zones in this layout.

e If you select an object in the list, you can use buttons in the Properties panel to manipulate the
selected object.

Table 3-6 Digital Media Designer — The Layers Panel

Icon |Tool Name

Description

Remove

Deletes the selected object.

Bring to Front

Moves the selected object to the absolute top layer.

Move Up

Moves the selected object up by one layer per click.

Move Down

Moves the selected object down by one layer per click.

Send to Back

Moves the selected object to the absolute bottom layer.

Understanding the Navigator Panel and Its Options

The Navigator panel shows a wireframe thumbnail view of, and scrolling controller for, your workspace in
DMD. The Navigator panel is especially useful when you design presentations for high-definition
DMP displays, because you might not be able to see the entire design all at one time in the workspace area.

To scroll the workspace vertically and horizontally, click and move the small gray rectangle from place
to place inside the Navigator panel.
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Understanding the Properties Panel and Its Options

Shows the editable and uneditable properties of the selected object or action. The type of properties that
you see depend on the type of object or action that you select on the workspace or in the Layouts panel.

Table 3-7 Digital Media Designer — The Properties Panel

Element Icon and Description

Border Make selections to define the border attributes, if your box object should be enclosed in a border.
{Style | Width |

Color}

Assign to Object

Select the box object that represents the screen zone where the selected ticker action should show
its ticker.

Duration Shows the playback duration for each asset in the selected playlist. If you use the Synchronize Playlists
action to make the selected playlist secondary, the duration values shown here might not have any bearing
on how long an asset plays back before the playlist transitions to the next asset. There is no factory default
duration value for nonvideo assets, so you must enter all such duration values manually.

Type Signifies the type of playlist. This value is not editable.

Name An editable field or an uneditable column in a table:

e Enter a unique and meaningful name in the Name field to identify the selected object or action.

¢ Click the Name column heading to sort the table by the values in that column.

Playlist Items

To understand the elements in the Playlist Items area, see Understanding the Playlist Items Area and
Its Options, page 3-28.

To learn about the workflow to create a playlist, see Creating and Organizing Playlists for Your
Presentations, page 3-27.

Primary Playlist

Select the playlist object whose transition timing between assets during playback should override the
equivalent transition timing of a secondary playlist.

RSS URL

Enter the source URL for the RSS feed.

Secondary Playlist

Select the playlist object whose transition timing between assets during playback should be overridden
by the equivalent transition timing from the primary playlist.

Text {Size | Color |
Horizontal
Alignment | Vertical
Alignment | Text}

Increases or decreases the text size (in pixels), depending respectively on whether you click the arrow
head that points up or the arrow head that points down. Changes the text size (in pixels) to the numeric
value that you enter. Changes the text color to match a color that you select after you click ... or to
match a hexidecimal color value that you enter.! Changes the horizontal or vertical alignment of text
to match the alignment types that you select. Shows exactly the text that you enter in the Text field.

URL

An uneditable column in a table, where each row shows the URLfor one remote playlist asset.

{Width | Height}

Enter in pixels the respective width and height of the selected screen zone object.

(X1Y}

X and Y coordinates that represent the placement of the first pixel (when reading from left to right and

top to bottom) of the selected object.

1. The text color that you use should be one that results in clear and legible text against the background color that you specified; if there is not enough
difference between the two colors, your audience might not see information clearly when you use this layout to show text on a DMP display.
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Creating and Organizing Playlists for Your Presentations

Tip

Step 1

Step 2

Step 3

Step 4

Step 5

Step 6

Step 7

The presentations that you design in DMD can contain playlists that you configure. A playlist contains
assets from one or more media library categories or remote servers and shows these assets in the order
that you specify. The only way to save a playlist and deploy it to your DMPs is inside a presentation.

Before You Begin

¢ You must add assets to your media library before you can organize them in a playlist. See the “{ Add
New | Edit} Media” row in Table 3-2 on page 3-9.

¢ You must add a DMP to DMM-DSM before you can deploy any presentations to it, and you must
organize your DMPs into groups before you can deploy any presentation to a group. The DMP
Groups list does not show any DMPs until you add at least one. See Managing and Grouping DMPs,
page 3-3.

¢ You must add an external deployment server to DMM-DSM before you can deploy any presentations
to it. The DMP Groups list does not show any external servers until you add at least one. You cannot
use the Schedules > Immediate Deployment feature with external deployment servers. All
deployments to your external deployment servers require that you use the Schedules > Future
Deployment feature. See Configuring DMM-DSM to Deploy to External Servers, page 3-56.

We recommend that you use the advanced task called DMP Startup URL and enter a value for either the
Video URL or the Browser URL. If both values are blank, you might find that your DMP sometimes
loses its ability to play even the Shockwave Flash files that it has played successfully in the past. To learn
how to use advanced tasks, see Using Advanced Tasks, page 3-34. To understand this advanced task, see
the “DMP Startup URL” row in Table 3-10 on page 3-35.

If you have not done so already, start DMD. To learn how to start it, see Getting Started with DMD,
page 3-14.

In DMD, do any of the following:
e Drag a playlist object (video or nonvideo) to the workspace from the Objects/Actions panel.
e Select a playlist object that you already placed on your workspace.
e Select a playlist object in the Layers panel.

The Properties panel now contains an area called “Playlist [tems,” where you can make selections that
add, remove, or rearrange assets in a playlist.

In the Playlist Items area, enter values and select options that meet your requirements. To understand the
Playlist Items area, see Table 3-8 on page 3-28.

To open the Content Chooser dialog box, where you configure a playlist, click [ # ] To understand the
Content Chooser dialog box, see Table 3-9 on page 3-30.

To save a playlist after you have populated and organized it and set the playback duration for each of its
assets, click Submit in the Content Chooser dialog box.

To save a presentation or a template after you have finished designing it, select File > Save in DMD. To
understand the dialog box for saving your designs, see the “File Menu” section of Table 3-3 on
page 3-17.

Deploy the presentation to the DMP displays that should show it. See Deploying Saved Commands and
Presentations to Your DMPs, page 3-42.
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Understanding the Playlist Items Area and Its Options
The Playlist Items area loads inside the Properties panel when the selected object on your workspace is
either a video playlist object or a nonvideo playlist object.
e To understand the two playlist object types, see Table 3-5 on page 3-22.
¢ To understand other elements inside the Properties panel, see Understanding the Properties Panel

and Its Options, page 3-26.

Table 3-8 Elements for Managing Playlists

Element Icon and Description

unlabeled check box |Click to select (or to deselect) one or more assets so that you can change the playback sequence of,
or remove assets from, the playlist that you are editing.

asset location Shows a miniature icon to indicate whether you selected the asset from your media library or from a
remote server.

- media library

L] remote server

Internet Media Type |Shows a miniature file icon to represent the asset that the corresponding row describes. DMD
identifies assets according to their IANA-registered Internet media types. To learn about media types
and understand the requirements to register them, see http://www.iana.org/assignments/media-types/.

& Video asset of any supported type, whether a file or a multicast stream.

@ Shockwave Flash 6 or Shockwave Flash 7 asset.

] JPEG, GIF, or PNG asset.

Bl |Web page.
Name A unique and human-readable name that you entered.
Duration, sec The playback duration in seconds for the asset that the corresponding row describes. Click a value to

see and use its duration control (%), which is hidden until you click the value. To increase the
playback duration by 1 second, click the top of a control. Alternatively, to reduce the playback
duration by 1 second, click the bottom of a control. To increment or decrement the duration value
quickly, hold down the mouse button after you click the top or the bottom of a control.

URL Shows the storage URL for the asset that the corresponding row describes.

Add

g

Opens the Content Chooser dialog box, where—to populate a playlist—you make selections
from your media library or enter the URLs for remotely stored assets. To understand the
Content Chooser dialog box, see Table 3-9 on page 3-30.

Remove Removes all of the selected assets from the relevant playlist. Nonetheless, the assets remain in
your media library or on the remote server from which you selected them.
Move Up Reorders the playlist so that the selected asset moves up one row, exchanging places with the

asset that was above it.

J Ll

Move Down Reorders the playlist so that the selected asset moves down one row, exchanging places with

the asset that was below it.
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Understanding the Content Chooser and Its Options

The Content Chooser dialog box is part of DMD. You use the Content Chooser to populate a playlist. To
save your work and use a playlist that you have populated, click Submit. Alternatively, to discard your
work, click Cancel.

Tip We recommend that you use the advanced task called DMP Startup URL and enter a value for either the
Video URL or the Browser URL. If both values are blank, you might find that your DMP sometimes
loses its ability to play even the Shockwave Flash files that it has played successfully in the past. To learn
how to use advanced tasks, see Using Advanced Tasks, page 3-34. To understand this advanced task, see
the “DMP Startup URL” row in Table 3-10 on page 3-35.
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Table 3-9 describes elements in the Content Chooser dialog box.

Table 3-9 Elements to Manage Assets in Playlists

Element Icon and Description

{Content Manager |  |Tabs that you can select, which determine whether the Available Content table will show selectable
URL} assets in your media library or help you to select an asset that is stored remotely.

Content Groups An object selector that lists all of the categories in your media library and that is visible only when

the Content Manager tab is selected. From the object selector, click the one category that the
Available Content table should describe. See Creating Categories and Organizing Assets for Digital
Signage, page 3-8.

Available Content A table, which describes every available asset in the category that you clicked. Click any other
category to see descriptions of its assets in the Available Content table.

% |Add to Playlist— Adds to the Selected Items table whichever assets you have checked in the
Available Content table, so that they might be included in a playlist. To add more assets to the
Selected Items table, repeat this step as many times as necessary.

— |Name—The name that you entered for the asset.

— | Type—Says whether the asset is stored locally or should be retrieved from an HTTP URL.
— |Path—Shows the HTTP URL for the described asset.

External URL Area where you select an asset that is stored remotely, so that you can add the asset to the Selected
Items table.

— Name—Enter a name to describe the asset.
— URL —Enter the HTTP URL for the remote asset.

& Add URL — Add the remote asset to the Selected Items table, so you can might include it in
a playlist.
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Table 3-9 Elements to Manage Assets in Playlists (continued)
Element Icon and Description
Selected Items A table, which describes every asset that you have selected so far for the playlist that you are

configuring. Sorts the assets according to their order of playback. Also, includes features to change
the playback order, change the duration of playback for each asset, and remove assets from
the playlist.

$ Move Down—Changes the order of playback for assets in your playlist. Reorders the list so
that the one asset whose name you have highlighted moves down by one row, exchanging places
with the asset that was below it.

4 Move Up— Changes the order of playback for assets in your playlist. Reorders the list so that
the one asset whose name you have highlighted moves up by one row, exchanging places with
the asset that was above it.

X Remove Assets from Playlist—Removes any number of assets from the playlist that you are
configuring. You must first select one or more check boxes, corresponding to the assets that
you want to remove. Even though you remove these assets from the playlist, they remain
available in your media library or on the remote server that you specified.

— |Name—The name that you entered for the asset.

—  |Duration, sec—The number of seconds that the asset will be visible when you show it on a
DMP display. Click a value to see and use its duration control ('¢), which is hidden until you
click the value. To increase the playback duration by 1 second, click the top of a control.
Alternatively, to reduce the playback duration by 1 second, click the bottom of a control. To
increment or decrement the duration value quickly, hold down the mouse button after you click
the top or the bottom of a control.

e If you do not specify a duration for playback of video and SWF assets, the file plays
to completion one time.

e If you do not specify a duration for playback of images or web pages, their duration
is continuous.

— URL —Shows the HTTP URL for the described asset.

Supported Fonts

The browser that is preinstalled on DMPs supports some bitmap fonts and some TrueType fonts. The
browser will substitute an installed font for any unsupported font.

S

Note  Other typographic representations that you might show on a DMP display, such as the opening titles for
a theatrical film, do not require that any font be installed. Similarly, when a font is embedded within a
Shockwave Flash file that you show, the file will load correctly even if the corresponding font is not
installed on your DMP.

This section contains these topics:
e Supported X11 Bitmap Fonts, page 3-32
e Supported TrueType Fonts, page 3-33
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Supported X11 Bitmap Fonts

These X11 bitmap fonts are preinstalled as part of this release:

> >
® s |8 o
> - s = e |E |2 @ - = - E
= - S o -2 e Ao |— - = = S S 23 % 5
s ES §5 § 2% 25 EgS: 3 % £ 22 :g g2
2 L= == » oz <= |Enaon e | | |42 S S &
adobe- helvetica- bold- r- |normal- |- 0- 0- 75- |75- |p- |O- 1s08859- 1
adobe- helvetica- bold- r- |normal- |- 12- |120- |75- |75- |p- |70- 1s08859- 1
adobe- helvetica- bold- r- |normal- |- 14- |140- |75- |75- |p- |82- i508859- 1
adobe- helvetica- bold- r- |normal- |- 18- |180- |75- |75- |p- |103- |iso8859- 1
adobe- helvetica- bold- r- |normal- |- 24- |240- |75- |75- |p- |138- |is08859- 1
b&h- lucida- bold- I- |normal- |sans- |0- 0- 75- |75- |p- |O- 1s08859- 1
bé&h- lucida- bold- I- |normal- |sans- |[12- [120- |75- |75- |p- |79- 1s08859- 1
b&h- lucida- bold- l- |[normal- |sans- |14- [140- |75- |75- |p- |[92- 1508859- 1
b&h- lucida- bold- I- |normal- |sans- [18- |[180- |75- |75- |p- |120- |is08859- 1
b&h- lucida- bold- I- |normal- |sans- |24- |240- |75- |75- |p- [152- |is08859- 1
misc- fixed- medium- |r- |normal- |- 7- 50- 100- [100- |c- |50- 1s08859- 1
misc- fixed- medium- |r- |normal- |- 7- 70- 75- |75- |c- |50- 1508859- 1
misc- fixed- medium- |r- |normal- |- 8- 60- 100- |100- |c- |50- 1s08859- 1
misc- fixed- medium- |r- |normal- |- 8- 80- 75-  |75- |c- |50- 150646.1991- |irv
misc- fixed- medium- |r- |normal- |- 8- 80- 75-  |75- |c- |50- is08859- 1
e 5x7
e 5x8
e 6x13
* cursor
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User Guide for Cisco Digital Media Manager 4.1
m. 0L-13984-01 |



| Chapter3 Using DMM-DSM for Digital Signage

Developing Presentations, Templates, and Playlists for Signage ||

Supported TrueType Fonts

These TrueType fonts are preinstalled as part of this release:

Name

Filename

Typographic Sample

Vera Sans

Vera.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefgh
ijklmnopqrstuvwxyz1234567890!@#%$% "~ &

Vera Sans
Bold

VeraBd.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabc
defghijkimnopqrstuvwxyz1234567890

Vera Sans
Bold
Oblique

VeraBI.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabc
defghijkimnopqrstuvwxyz1234567890

Vera Sans
Oblique

Veralt.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefgh
ijkimnopqrstuvwxyz1234567890!@#%$% ™~ &

Vera Sans
Mono

VeraMono.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghi]
kKilmnopqrstuvwxyz1234567890 ! @#%$%"&* ()

Vera Sans
Mono
Bold

VeraMoBd.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghij
klmnopgqrstuvwxyz1234567890!@#$%"&* ()

Vera Sans
Mono
Bold
Oblique

VeraMoBI.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghij
kimnopqrstuvwxyz1234567890!@#$%"&*()

Vera Sans
Mono
Oblique

VeraMolt.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghij
klmnopqrstuvwxyz1234567890!@#%$%"&* ()

Vera Serif

VeraSe.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZabcd
efghijklmnopqrstuvwxyz1234567890!@#$

VeraSerif
Bold

VeraSeBd.ttf

ABCDEFGHIJKLMNOPQRSTUVWXYZab

cdefghijklmnopqrstuvwxyz1234567890
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Using Advanced Tasks

Many advanced tasks and options are available to you in DMM-DSM. Your expectations and goals for
your digital signage network determine which tasks and options are relevant to you at any particular time
or for any particular purpose.

Step1  Select Digital Signage Module from the untitled list at the top far-right of any page.

Step2  Select Digital Media Players > Advanced Tasks, then click an application name in the Application
Types list, as follows:

Application Type Purpose

(Go to) URL Load media from a web server into the embedded browser on a DMP. See the “Go to URL”
section on page 3-35.

DMP Audio/Video Settings | Adjust the audio and video signals that DMPs send to their attached DMP displays. See the
“DMP Audio/Video Settings” section on page 3-35.

DMP Discovery Discover the DMPs in a network range that you specify and add those DMPs to DMM-DSM
for centralized management. See the “DMP Discovery” section on page 3-36.

DMP Display Controls Bind together a group of RS232 instructions that you can use to remotely configure display
settings on some DMTECH and NEC display models when displays of these types are
attached to your DMPs. See the “DMP Display Controls” section on page 3-37.

DMP Failover Retry Set the DMP Recovery URL value and the Recovery Timeout value. See the “DMP Failover
Retry” section on page 3-37.

DMP Firmware Upgrade Select firmware upgrades and patches to send to one or more DMPs. See the “DMP Firmware
Upgrade” section on page 3-38.

DMP Startup URL Configure DMPs to load a particular HTTP URL when you start or restart them. See the “DMP
Startup URL” section on page 3-39.

File Transfer to DMP Transfer to particular DMPs or to external (FTP) deployment servers the:

or Server

e Assets from presentations that you prepared in Digital Media Designer.

e Commands and settings from advanced tasks that you selected or configured under the
Digital Media Players tab.

See the “File Transfer to DMP or Server” section on page 3-40.

System Tasks Select an administrative command to send to one or more DMPs. See the “System Tasks”
section on page 3-41.

Step3  (Optional) If you previously defined or configured options for the relevant application and you saved
your selections, click any row in the Applications table to select one of the operations that you defined;
the row that you click should be one that you want to edit, deploy to DMPs, or delete.

Step4 Do one of the following:
e To define or configure options for a new operation, click _| Add New Application.

¢ To edit the options that you previously defined or configured for the operation that you selected in
Step 3, click /| Edit Application.

¢ To delete the operation that you selected in Step 3, click x| Delete Application.

Step5  If you clicked | Add New Application or /| Edit Application, the page is refreshed and you can
select options or enter values that define or redefine the behavior for this operation.
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Step 6 To save your selections, click Submit. Otherwise, click Cancel to discard your selections.

Step7  To deploy to your DMPs the commands that you saved in Step 6, see Deploying Saved Commands and
Presentations to Your DMPs, page 3-42.

Table 3-10 Understanding and Using Advanced Tasks
Application Name Description, Icons, and Options
Go to URL Load media from a web server into the embedded DMP browser.

— |Name— A unique and human-readable name for the website that you will select to show in this
task. You must enter a name. The name is unique in the sense that you have not used it previously
as the name for any presentation or presentation template, or for any task that you created under
the Digital Media Players tab in DMM-DSM.

— |Description— A brief description. The description is optional.

— |URL—The full and correct HTTP URL that points to a page or file on a webserver. The URL
that you enter should point to a page that is dynamic and does not require any human interaction
(such as clicking or scrolling) to be useful or interesting. You must enter a URL.

DMP Audio/Video Adjust the audio and video signals that DMPs send to their attached DMP displays.
Settings

— |Name— A unique and human-readable name for the settings that you configure in this task. For
example, you might adjust the brightness setting to accommodate a locale where the lighting is
dim, then enter a name that identifies that kind of locale. You must enter a name. The name is
unique in the sense that you have not used it previously as the name for any presentation or
presentation template, or for any task that you created under the Digital Media Players tab in
DMM-DSM.

— |Description— A brief description. The description is optional.

— |Brightness—The setting that compensates for any deficiencies in the on-screen brightness of
your DMP displays. Brightness compensation values can range from —128 to 127.

— |Contrast—The setting that compensates for any deficiencies in the on-screen contrast of your
DMP displays. Contrast compensation values can range from O to 255. The default is 128.

— |Saturation— The setting that compensates for any deficiencies in the on-screen color saturation
of your DMP displays. Saturation compensation values can range from 0 to 255. The default
is 128.

— |Left Audio Channel Volume—The setting to control how loudly or softly your DMP display
speakers play sound in the left audio channel. Volume can range from 0 to 100, where O is silent.
The default is 50.

— |Right Audio Channel Volume— The setting to control how loudly or softly your DMP display
speakers play sound in the left audio channel. Volume can range from 0 to 100, where 0 is silent.
The default is 50.
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Table 3-10 Understanding and Using Advanced Tasks (continued)
Application Name Description, Icons, and Options
DMP Discovery Discover the DMPs in a network range that you specify and add those DMPs to DMM-DSM for

centralized management. For autodiscovery and centralized management to succeed:

¢ Your firewall must allow DMM-DSM and your DMPs to communicate over TCP ports 6666
and 7777 and must also allow ICMP (ping) traffic between them.

e In DMPDM, you must enable the Enable Cisco TAC Troubleshooting Access option.

To learn about other autodiscovery options for the DMPs in your digital signage network, see the
“{Add New | Edit} DMP” row in Table 3-1 on page 3-5.

Note  You can schedule multiple DMP Discovery operations to run simultaneously if they all
search the same one subnet. If the DMP Discovery operations that you configure do not all
search the same one subnet, you should not schedule them to run simultaneously. If you do,
only the first such operation will run and DMM-DSM will not show any error message to
explain why the other discovery operations failed to find any DMPs. If you must run DMP
Discovery tasks that search different subnets, schedule a 35-minute interval between the start
time for one discovery and the start time for the next discovery.

— |Name— A unique and human-readable name for this autodiscovery IP address range task. You
must enter a name. The name is unique in the sense that you have not used it previously as the
name for any presentation or presentation template, or for any task that you created under the
Digital Media Players tab in DMM-DSM.

— |Description— A brief description. The description is optional.

— |Discovery IP Range— The CIDR syntax to describe one or multiple ranges of IP addresses.
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Table 3-10 Understanding and Using Advanced Tasks (continued)

Application Name

Description, Icons, and Options

DMP Display Controls

Note

Before you can use this feature, you must enable RS-232 support for your displays. Select
Digital Media Players > Advanced Tasks > System Tasks, then name, save, and deploy
one of these as the correct option for your display type:

e Turn On DMTech RS-232 Control.

e Turn On NEC RS-232 Control.

Bind together a group of RS-232 instructions that you can use to remotely configure display settings.

TV Type—Select the manufacturer and the model type:
e {DMTECH | NEC_3210 | NEC_4010 | NEC_4610 | NEC_5710}

Contrast — Select or enter a contrast value from O to 100.

Brightness — Select or enter a brightness value from 0 to 100.

Sharpness — Select or enter a sharpness value from 0 to 100.

Color — Select or enter a color value from 0 to 100.

Tint — Select or enter a tint value from 0 to 100.

TV Channel — Select or enter the analog television signal frequency for a channel from 0 to 99.

Audio Volume — Select or enter a volume level from 0 to 100.

Mute — Select whether to mute the display.
e {on | off}

Input — Select the input type. Options differ, according to your selection from the TV Type list.

e {TVIRGB I RGBI1 (DVI-D) | RGB2 (D-SUB) | RGB3 (BNC) | DVD/HD |
Video (Composite) | Video 1 | Video 2 | Video 3 | S-Video | None (DVD) |
Component | PC | HDMI | None (DVBT)}

Power — Select whether the television should be turned on.

e {on/| off}

DMP Failover Retry

Configure the recovery URL to use in case of failover and the interval between attempts to reload

that

URL if the connection to it is disrupted.

Name— A unique and human-readable name for the DMP failover retry task that you are
configuring. You must enter a name. The name is unique in the sense that you have not used it
previously as the name for any presentation or presentation template, or for any task that you
created under the Digital Media Players tab in DMM-DSM.

Description— A brief description. The description is optional.

Recovery URL —The URL to show immediately on a DMP display after its attached DMP
restarts for any reason, unless other content is scheduled to be shown. If this value is blank, your
DMP will reuse the most recent URL that failed to load.

Recovery Timeout (in seconds)—The maximum number of seconds that your DMP will wait
for a response from the server that you identify in the Recovery URL field before it tries again
to reach that server. There is no maximum number of retry attempts.
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Table 3-10 Understanding and Using Advanced Tasks (continued)
Application Name Description, Icons, and Options

DMP Firmware A

Upgrade

Caution  Before you install an upgrade, you must run the “Stop All Applications” system task on
all the affected DMPs. To do so, click the Schedules tab, select the DMP group that you
will upgrade, select Stop All Applications from the Actions list, then click Go.

Note Before you transfer a firmware upgrade file to the SD memory card in a DMP, you must
configure, save, and deploy a system task that causes your DMP to accept the transfer. Select
Digital Media Players > Advanced Tasks, click System Tasks in the list of defined tasks,
then click _| Add New Application. Enter a name and description, then select Set from the
Request Type list and use this syntax in the Request field:
init.startService_shell=yes&mib.save=1&mng.exit=1.

To restore DMP security after the file transfer is finished, repeat the procedure but use this
syntax instead: init.startService_shell=no&mib.save=1l&mng.exit=1.

Send a DMP firmware image from your media library to a DMP and send commands to install the
new firmware image.

— |Name— A unique and human-readable name for the upgrade task that you are configuring. You
must enter a name. The name is unique in the sense that you have not used it previously as the
name for any presentation or presentation template, or for any task that you created under the
Digital Media Players tab in DMM-DSM.

— |Description— A brief description. The description is optional.

— |Content Categories— An object selector that lists all the categories in your media library. From the
object selector, click the one category that the Available Content table should describe. To learn more
about categories, see Creating Categories and Organizing Assets for Digital Signage, page 3-8.

¢ % Opened Media Library— Shows all the categories in your media library until you click
to hide them.

¢ 4 Closed Media Library—Hides the list of media library categories until you click to
show them.

e # Content Category— A media library category that you created.

— |Available Content— A table in which you can click any row to select one asset in the specified
category. The table sorts information into these columns:

e Name— A unique and human-readable name that you entered.

e Type—Says whether the asset is a file (F) or an HTTP URL (U).
e Size—The filesize in bytes.

e Path—The full pathname that points to the file on the DMP.

¢ Description— A brief description. The description is optional.

¢ Upload Started—Time stamp (in the format yyyy-MM-DD hh:mm:ss:ms) that says when
you started to upload the file.

e Upload Finished —Time stamp (in the format yvyyy-MM-DD hh:mm:ss:ms) that says when
the file was completely uploaded.

e Status—Says whether a DMP is reachable. A green icon () tells you that the DMP is
connected to a power source, uses a known IP address, and is reachable. A red icon (X) tells
you that the DMP is unreachable.
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Table 3-10 Understanding and Using Advanced Tasks (continued)

Application Name

Description, Icons, and Options

DMP Startup URL

Causes DMPs to load and show media that you specify, immediately after every restart.

Tip We recommend that you enter a value for either the Video URL or the Browser URL. If both
values are blank, you might find that your DMP sometimes loses its ability to play even the
Shockwave Flash files that it has played successfully in the past.

— |Name— A unique and human-readable name for the startup URL task that you are configuring.
You must enter a name. The name is unique in the sense that you have not used it previously as
the name for any presentation or presentation template, or for any task that you created under
the Digital Media Players tab in DMM-DSM.

— |Description— A brief description. The description is optional.

— |Video URL—The HTTP URL (or local path on the DMP) that points to an encoded digital
video file that a DMP should load automatically and show immediately after every restart. We
do not support any use of spaces in filenames or URLs. The supported transport protocols and
URL types are:

o http://<ip_address>/<path_and_filename>

e udp://<ip_address_of_multicast_server>/<port_number>

— |Browser URL—The HTTP URL of any document that the embedded browser on a DMP should
load automatically and show immediately after each restart. We do not support any use of spaces
in URLs. We recommend that you do not point to any document or site that requires human
interaction to be useful, interesting, or entertaining, because there is no keyboard or mouse that
you can use to interact with what you show on a DMP display.

— |Reboot— Select the check box if a DMP should restart immediately when it receives this
instruction. Deselect the check box if no immediate restart is required.
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Table 3-10 Understanding and Using Advanced Tasks (continued)
Application Name Description, Icons, and Options

File Transfer to DMP A

or Server

Caution  Before you use a file transfer application to deploy the assets from a new or updated
presentation to any of your DMPs, you must first run the “Stop All Applications” system
task on each affected DMP. To do so, click the Schedules tab, select the DMP group that
will use the presentation, select Stop All Applications from the Actions list, then
click Go.

Transfer to particular DMPs or to external (FTP) deployment servers the:
e Assets from presentations that you prepared in Digital Media Designer.

¢ Commands and settings from advanced tasks that you selected or configured under the Digital
Media Players tab.

See Deploying Saved Commands and Presentations to Your DMPs, page 3-42.

Tip Although it is technically possible, it is not useful to transfer a system task, a go to URL task,
or a startup URL task.

— |Name— A unique and human-readable name for the file transfer task that you are configuring.
You must enter a name. The name is unique in the sense that you have not used it previously as
the name for any presentation or presentation template, or for any task that you created under
the Digital Media Players tab in DMM-DSM.

— |Description— A brief description. The description is optional.

— |Application Types— The list of categories for advanced tasks. Click a category to see its tasks.

— |Available Applications— Advanced tasks in the category that you clicked. Click anywhere in a
row to select the corresponding task.

e %] Select Applications—Moves from the Available Applications table to the Selected
Applications table the tasks that you selected.

e Name—The unique and human-readable name that identifies a particular task.

¢ Description— A brief description. The description is optional.

— |Selected Applications— Advanced tasks that you selected from the Available Applications
table, so that you could include them in the file transfer operation that you are configuring. Click
a file transfer task to select its assets for deployment.

+ 4 Move Selected Item Up—Reorders the list so that the highlighted item moves up one
row, exchanging places with the item that was above it.

< Move Selected Item Down — Reorders the list so that the highlighted item moves down
one row, exchanging places with the item that was below it.

e x| Delete Selected Item —Moves from the Selected Applications table to the Available
Applications table the applications that you selected.

e @& Zoom In—Shows only the Selected Applications table, hiding the Available
Applications table.

e @ Zoom Out— Shows the Selected Applications table and the Available Applications table
simultaneously.
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Table 3-10 Understanding and Using Advanced Tasks (continued)

Application Name

Description, Icons, and Options

System Tasks

A

Caution  If you restore factory-default settings on a DMP, you must set it up again, exactly as you

would set up a brand-new DMP. (To learn how to set up a DMP, see Quick Start Guide for
Cisco Digital Media Player 4305G on Cisco.com.) If you restart a DMP, you will disrupt
whatever it is doing at that time. If you save any configuration settings mistakenly, you
must reenter the correct settings manually.

Predefined system commands that you can send to a DMP. If you will use this feature to pass RS-232
commands through your DMPs and to your DMP displays, first confirm that an RS-232 cable connects
each DMP to its associated DMP display; otherwise, your displays will not receive the commands that
you define for them.

When you create or edit a system task, these are the elements:

Name— A unique and human-readable name for the system task that you are configuring. You
must enter a name. The name is unique in the sense that you have not used it previously as the
name for any presentation or presentation template, or for any task that you created under the
Digital Media Players tab in DMM-DSM.

Description— A brief description. The description is optional.

Request Type—A list in which the options are Ger and Set, in the sense that you can set new
values on a DMP or instruct DMM-DSM to get information from a DMP and show that
information in a popup window.

Request—The command string.

Default— Restore factory default settings.

FTP {Off | On} —Enable or disable the FTP service.

HDMI Autodetection {Off | On}—Enable or disable DMP display type autodetection.

Reboot—Restart.

Save Settings— Save the active settings.

Save Settings and Reboot— Save the active settings, then restart.

Screen Resolution Autodetection {Off | On} —Enable or disable autodetection of the
resolutions that your DMP displays support.

Show {Browser | Video}—Show one content plane but hide the other.

Status— See the DMP status message in real time.

Stop All Applications— Stop every application that DMPs are running.

Transparency 50 % — Set the browser plane to be partially transparent and show the video plane
through it.

Turn On DMTech RS-232 LCD Control— Cause DMPs to send RS-232 management
instructions to an LCD display manufactured by DMTech.

Turn On NEC RS-232 LCD Control—Cause DMPs to send RS-232 management instructions
to an LCD display manufactured by NEC.

Upgrade Status—See the DMP upgrade status message in real time.

Version— See the installed firmware version number.
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Deploying Saved Commands and Presentations to Your DMPs

Je

Tip

Note

Network congestion or other performance problems at a DMP deployment site might cause the assets
that you deploy to pause, stop, or play at unacceptably low speeds. To work around this problem,
troubleshoot network performance at the deployment site and consider upgrading its network or applying
policies to shape and prioritize its traffic.

Topics in this section tell you how to deploy (deliver to your DMPs or to external deployment servers)
the presentations and commands that you saved elsewhere in DMM-DSM.

e Deploying Commands and Presentations Immediately, page 3-42
e Scheduling Future Deployments of Commands and Presentations, page 3-43
e Preempting a Recurring Deployment for a One-time Event, page 3-48

e Using Deployment Reports, page 3-48

To learn how to configure DMM-DSM support for ACNS, see Configuring DMM-DSM to Use ACNS,
page 3-55.

Deploying Commands and Presentations Immediately

~

Note

Step 1
Step 2
Step 3

Step 4
Step 5

You can deploy commands or presentations immediately to one DMP or to multiple DMPs that all use
the same one DMP group as their parent.

¢ In this release, we do not support immediate deployments to external (FTP) servers.

¢  We recommend that you avoid using immediate deployments with ACNS, due to the amount of time
required to distribute assets throughout your network and to its edge. If you do so despite this
recommendation, DMM-DSM always uses the default ACNS channel. You cannot select any
other channel.

Before You Begin

¢ You must already have created and saved the commands or the presentations that you will deploy.
See Creating Categories and Organizing Assets for Digital Signage, page 3-8.

¢ You must already have created the DMP group whose member DMPs should receive the
deployment. See Managing and Grouping DMPs, page 3-3.

Select Digital Signage Module from the untitled list at the top far-right of any page.
Select Schedules > Immediate Deployment.

In the DMP Groups object selector, click the name of a DMP group to see its member DMPs in the DMP
List table.

In the DMP List table, select the check box for each DMP that should receive the deployment.

Select from the Actions list the name of the advanced task or presentation that you want to deploy.
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Options in the Actions list are sorted into categories, based on their purpose. The Actions list contains
a particular category only if you have created what the category should describe; for example, if you have
not defined any presentations, the Actions list does not show the Digital Media Designer category.

Step6  Click Go.

Scheduling Future Deployments of Commands and Presentations

You can schedule future one-time or repeated deployment of commands or presentations to:
¢ One registered DMP.
e Multiple registered DMPs that all use the same one DMP group as their parent.

e All of your registered external (FTP) deployment servers; DMM-DSM treats all of your registered
external servers identically.

In addition, you can view two types of summary for any scheduled deployment. See:
e Understanding Tooltips in the Scheduler Timeline, page 3-45
¢ Understanding Popup Windows in the Scheduler Timeline, page 3-46

You can deploy only one presentation at a time if the assets that it contains should be stored directly on
your DMPs. If you want a particular presentation to play during stage-one failover on a DMP, the
combined filesize of all its assets must not be any more than 900 MB (on a DMP 4300G) or 1.9 GB (on
a DMP 4305G).

A

Caution Do not delete the scheduled deployment job for a presentation to stop it from playing on your DMPs. If
you delete the deployment job, your DMPs will continue to use the presentation as if you did nothing.
This happens because each deployment job includes an instruction to stop, but you delete that instruction
when you delete the deployment job that contains it. To stop your DMPs from using a presentation in
this case, create and deploy an advanced task to stop all applications. See the “System Tasks” row in
Table 3-10 on page 3-35.

Note It is important that you understand all of the possible limitations and effects of deploying to an FTP
server, as well as the exact circumstances that lead to these effects. Files are sometimes unplayable or
deleted automatically, subdirectories are sometimes created automatically, and values that you enter in
DMM-DSM are sometimes changed automatically.

¢ Video files do not play at all if you deploy a presentation to an FTP server when the presentation
uses MPEG files that are:

— Served from Microsoft Internet Information Server (IIS). On Windows, we support only Apache.
- Requested through Microsoft Proxy Server.
- Requested through Microsoft Internet Security and Acceleration Server.

¢ When your media library in DMM-DSM is the source for a file that you deploy as part of a
presentation, and when you select an FTP server as the target to receive that file, DMM-DSM
transfers copies of the relevant file to all of the FTP servers that you have registered. After the
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Step 1
Step 2

Step 3
Step 4
Step 5

Step 6

Step 7

transfer is completed, DMM-DSM deletes the original file from its media library, then changes the
relevant presentation so that it uses a URL instead of a local path. The URL that DMM-DSM enters
automatically is specific to whichever FTP server you registered first.

e When an HTTP URL is the source for a deployed file, and when the pathname on the source server
contains subdirectories that do not exist on the target FTP server, DMM-DSM automatically creates
the required subdirectories on the FTP server.

You can schedule a deployment to occur at any time and recur any number of times, and you can schedule
any number of deployments. DMM-DSM can make multiple deployments simultaneously
and—assuming that a DMP has a fast network connection and you send deployments to it that are not
mutually exclusive—a DMP can receive multiple deployments simultaneously.

Before You Begin

¢ You must already have created and saved the commands or the presentations that you will deploy.
See Creating Categories and Organizing Assets for Digital Signage, page 3-8.

¢ You must already have created the DMP group that should receive a deployment. See Managing and
Grouping DMPs, page 3-3.

Select Digital Signage Module from the untitled list at the top far-right of any page.

Select Schedules > Future Deployment.

L

Tip If the user interface for the scheduler does not load correctly in your browser, see the “Client
System Requirements to Use DMM 4.1 Modules or Video Portal 4.1” section in Release Notes
for Cisco Digital Media System 4.1 on Cisco.com.

Click E (the large “Select Target Date” button near the left edge of the user interface).
In the Select Target Date dialog box, click the calendar date for the first deployment, then click OK.
Do one of the following:

e Ifyou are scheduling a new deployment, select from the DMP Groups list the DMPs or the external
(FTP) deployment servers that should receive the deployment.

e Ifyou are editing a scheduled deployment, find that task in the timeline row that names the recipient
DMP group. You might have to scroll horizontally through the timeline to see earlier or later times.
When you find the task, click it to select it.

Set or edit the timing for deployment:

a. From the How Often list, select the interval between deployments.

b. In the From area, click D, then select the hour and minute to start the deployment.

c. In the To area, click [, then select the calendar date, hour, and minute to stop the deployment.

The times that you configure for deployments are relative to the time zone where you deployed your
DMM appliance, not to the time zone where you deployed any DMP. You set the time zone value when
you used AAI to set up your DMM appliance and you can change the time zone value if it is wrong. To
learn how to set or reset the time zone, see the “Administering a DMM Appliance” chapter in Appliance
Administration Guide for Cisco Digital Media System 4.1 on Cisco.com.

From the Applications list, select the option that names what you want to deploy.
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Options in the Applications list are sorted into categories, based on their purpose. For example, the
Digital Media Designer category contains every presentation that you have saved. The Applications list
contains a particular category only if you have created what the category should describe.

Do one of the following:

e If you are scheduling a new deployment, click Add Task.

e If you are editing a scheduled deployment, click Update Task.

e If you are deleting a scheduled deployment, click Remove Task.
To save your selections, click Save.

If you do not save your selections for a deployment that you add or update, DMM-DSM discards your
selections immediately after you refresh your browser or load any other page in it.

(Optional) To make copies of a deployment, so that it recurs as many times as you want and at any
interval that you specify, click Multiply Task.

a. At the first prompt, enter the hours and minutes between copied instances of the deployment. Use
the format for military time (24 hours that increment from 0100 to 2400) and the format HH:MM.

b. At the second prompt, enter the number of copies to make.

(Optional) To transmit the deployment according to the schedule that you defined—and synchronize it
if you use ACNS —click Publish.

Understanding Tooltips in the Scheduler Timeline

Whenever your pointer hovers over a scheduled deployment in the timeline, DMM-DSM displays a
tooltip. Information in the tooltip describes the current status of the corresponding deployment and
summarizes its most important attributes. Information in the tooltip is organized as follows:

Category Description
Status One of the following:

e New— You made selections to define a new deployment. However, because you have not yet
clicked Save, DMM-DSM will discard your selections if you refresh your browser or load any
other page in it.

e Saved— You made selections to define a new deployment and you clicked Save. DMM-DSM
created a permanent record for the deployment, but has not scheduled it yet to run.

e Published — You made selections to define a deployment, you saved your selections, and
DMM-DSM has scheduled the deployment to run at the times that you specified.

¢ Scheduled—The deployment is occurring now.

e Finished—The deployment occurred at the scheduled time and is now stopped.

App The selection that you made from the Applications list.
Group The selection that you made from the DMP Groups list.
From The date and time when the deployment is (or was) scheduled to start.
To The date and time when the deployment is (or was) scheduled to stop.
How Often The number of times that the deployment is scheduled to recur.
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Category

Description

Start Cmd Result
(Total/OK/Failed)

N/N/N, where:

e The first Nis a color-coded (black) numeral that counts the total number of times that DMM-DSM
tried to deploy the command to start the designated task.

e The second N is a color-coded (green) numeral that counts the number of times that DMM-DSM
succeeded in deploying the command to start the designated task.

e The third N is a color-coded (red) numeral that counts the number of times that DMM-DSM failed
to deploy the command to start the designated task.

Stop Cmd Result
(Total/OK/Failed)

N/N/N, where:

e The first Nis a color-coded (black) numeral that counts the total number of times that DMM-DSM
tried to deploy the command to stop the designated task.

e The second N is a color-coded (green) numeral that counts the number of times that DMM-DSM
succeeded in deploying the command to stop the designated task.

e The third N is a color-coded (red) numeral that counts the number of times that DMM-DSM failed
to deploy the command to stop the designated task.

Understanding Popup Windows in the Scheduler Timeline

Whenever you double-click a scheduled deployment in the timeline, DMM-DSM opens a popup window.
Information in the popup describes the current status of the corresponding deployment and summarizes
its most important attributes. Information in the popup is organized as follows:

Category

Description

Application Name

The selection that you made from the Applications list.

Application Type

Either Digital Media Designer (see Developing Presentations, Templates, and Playlists for Signage,
page 3-12) or one of the following (see Using Advanced Tasks, page 3-34):

e (Goto) URL

e DMP Audio/Video Settings

e DMP Discovery

e DMP Display Controls

e DMP Failover Retry

e DMP Firmware Upgrade

e DMP Startup URL

¢ File Transfer to DMP or Server

e System Tasks

From The date and time when the deployment is (or was) scheduled to start.
To The date and time when the deployment is (or was) scheduled to stop.
How Often The number of times that the deployment is scheduled to recur.
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Category

Description

Status

One of the following:

New— You made selections to define a new deployment. However, because you have not yet
clicked Save, DMM-DSM will discard your selections if you refresh your browser or load any
other page in it.

Saved — You made selections to define a new deployment and you clicked Save. DMM-DSM
created a permanent record for the deployment, but has not scheduled it yet to run.

Published — You made selections to define a deployment, you saved your selections, and
DMM-DSM has scheduled the deployment to run at the times that you specified.

Scheduled — The deployment is occurring now.

Finished —The deployment occurred at the scheduled time and is now stopped.

Group

The selection that you made from the DMP Groups list.

Start Command
Summary
(Total/OK/Failed)

N/N/N, where:

The first N is a color-coded (white) numeral that counts the total number of times that DMM-DSM
tried to deploy the command to start the designated task.

The second N is a color-coded (green) numeral that counts the number of times that DMM-DSM
succeeded in deploying the command to start the designated task.

The third N is a color-coded (red) numeral that counts the number of times that DMM-DSM failed
to deploy the command to start the designated task.

Stop Command
Summary
(Total/OK/Failed)

N/N/N, where:

The first N is a color-coded (white) numeral that counts the total number of times that DMM-DSM
tried to deploy the command to stop the designated task.

The second N is a color-coded (green) numeral that counts the number of times that DMM-DSM
succeeded in deploying the command to stop the designated task.

The third N is a color-coded (red) numeral that counts the number of times that DMM-DSM failed
to deploy the command to stop the designated task.

In addition, a status bar at the bottom of the popup window counts the number of errors associated with
the described deployment.
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Preempting a Recurring Deployment for a One-time Event

In some cases, you might want to show a presentation one time, or for a limited time, that overlaps with
a recurring deployment.

For example, you might schedule a presentation to run from 9:00 a.m. to 6:00 p.m. every weekday in the
month of March, but want to show a different presentation on the second Tuesday in March. The problem
in this scenario is that your DMP cannot prioritize contradictory events that are scheduled to start
simultaneously. However, there are three possible methods that you might use to schedule a preemption.
In this scenario, you can do any of the following:

Method 1 1. Schedule and deploy a recurring event for the first uninterrupted span of dates.
2. Schedule and deploy the one-time event.

3. Schedule and deploy a copy of the first recurring event for the second uninterrupted span of dates.

Method 2 Create two DMP groups. In this scenario, we will call them Group_A and Group_B.
e For Group_A, schedule an event that recurs throughout the entire span of dates.
e For Group_B, schedule the one-time event.
Then complete these steps:
1. When the one-time event should begin, move your DMPs from Group_A to Group_B.

2. When the one-time event should end, move your DMPs back to Group_A, then select Schedules >
Immediate Deployment.

3. Inthe DMP Groups object selector, click the Group_A name to see its member DMPs in the DMP
List table.

4. In the DMP List table, select the check box for each DMP that should start again to show the
recurring presentation.

5. Select from the Actions list the name of the recurring presentation. It will be under the Digital

Media Designer heading.
6. Click Go.
Method 3 1. Schedule the recurring event to run every weekday, as you would expect, from 9:00 a.m. to
6:00 p.m.

2. Schedule the one-time event to start at 9:05 a.m, so that it interrupts the recurring event instead of
conflicting with its start time, and schedule it to stop at 6:00 p.m.

The recurring task will begin again, as expected, the next day.

Using Deployment Reports

You can view, configure, and export “proof-of-play” reports for the presentations and tasks that you have
deployed in your digital signage network.

Step1  Select Digital Signage Module from the untitled list at the top far-right of any page.
Step2  Select Schedules > Reports.
Step3  Enter date range values in the From field and the To field.
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Stepd  From the Report Type list, select the report type.
Step5  Select the relevant DMP groups in the untitled table, then click Go.

Using Administrative Options

This section contains these topics:
e Configuring DMM-DSM User Accounts, page 3-49
e Limiting User Permissions, page 3-51
e Configuring DMM-DSM Server Settings, page 3-54
e Configuring DMM-DSM to Send Notification Settings, page 3-54
e Configuring DMM-DSM to Use ACNS, page 3-55
e Configuring DMM-DSM to Deploy to External Servers, page 3-56
e Viewing the DMM-DSM ‘About Box’, page 3-57

e Testing for the Presence of, and Obtaining, the Required Java Version, page 3-57

Configuring DMM-DSM User Accounts

You can create, configure, and delete user accounts for DMM-DSM.

Before You Begin
To see and use the Settings tab, you must be logged in an administrator.

Step1  Select Digital Signage Module from the untitled list at the top far-right of any page.

Step2  Select Settings > User Accounts, then select the options that meet your requirements. If you do not
understand your options, see Table 3-11 on page 3-49.

Step3  Click Submit.

Table 3-11 Elements for Configuring DMM-DSM User Accounts
Element Icon and Description
Users List Add a new user account or select a preexisting account to edit or delete.

When you click a username to highlight it, DMM-DSM automatically shows the Change User pane for the
corresponding user account.

| |Add New User— Shows the Add New User pane, where you can define the settings for a new user
account.

%] |Delete User—Deletes the user account that you highlighted.
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Table 3-11 Elements for Configuring DMM-DSM User Accounts (continued)

Element Icon and Description

{Add New | |A worksheet where you define the attributes of the user account that you are adding or editing.
Change}
User

Name— A unique username. The name is unique in the sense that you have not used it as the name for
any other user account that you created in DMM-DSM. You must enter the username.

— | Description— Optional, brief description of the user account and its purpose.

— |Password | Repeat— The password for the user account. You must enter a password, then reenter it.

— |Administrator —The check box to select if this account belongs to an administrator. Otherwise, deselect
the check box. When a user account belongs to an administrator, the corresponding user is granted full
permissions to create, read, write, and delete every object type without limitation. If you deselect the
check box, you must manually change the permissions for each user role and each object type that pertain
to this user account. Because we recommend that you follow a best practice in which you create only a
few users, the check box is selected by default each time that you add a user account.

— |Role—The list of user role types. Each type of role is associated with some of the features in
DMM-DSM. Select a role to see or change the corresponding permissions for the user whose account
you are adding or editing. After you select a role, you can set the permissions to create, read, write,
and delete objects that are relevant to whichever role you selected. Depending on the user role that you
select, an object might be a registered DMP, a registered FTP server, a category in your digital media
library, an application that you configured, or the target device (DMP or FTP server) to receive a
scheduled deployment.

e DMP Manager— A user with permissions to manage every DMP in your digital signage network,
only the DMPs within particular DMP groups that you specify, or no DMPs whatsoever.

¢ Content Manager— A user with permissions to manage every category in your media library, only
the particular categories that you specify, or none of the categories.

e Application Manager — A user with permissions to work with every application type, only the
particular application types that you specify, or no applications of any kind.

¢ Publisher Manager — A user with permissions to schedule media deployments to all of your
registered DMPs and external (FTP) deployment servers, only the particular DMPs and FTP servers
that you specify, or none of the registered DMPs or FTP servers.

— |The untitled table sorts user account permissions information into these rows:

¢ Objects—Contains the Create, Read, Write, and Delete buttons. To see or edit any one of these types
of permissions as it applies to the specified user, you must first click the corresponding button. If you
deselect both the All check box and the Selected check box in the column under a button,
DMM-DSM automatically shows the words “No permissions” in red, to signify that the user does
not have any permissions of that type in relation to the objects that are relevant to the role that you
selected from the Role list.

¢ All—Contains the check box that you select to assign global permissions to the user, so that he or
she can always {create | see | edit | delete} objects that pertain to whichever user role you selected
from the Role list. Click the relevant button, then select the corresponding check box in the All row.

e Selected—Contains the check box that you select to assign limited permissions to the user, so that
he or she can {create | see | edit | delete} only a subset of the objects that pertain to the user role that
you selected from the Role list. Click the relevant button, select the corresponding check box in the
Selected row, then select the subset where the user permissions should apply. (Depending on the
object type, you might choose the subset by clicking its name in an object selector or clicking its
name in a table; DMM-DSM automatically displays either an object selector or a table from which
to select the subset.)
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Limiting User Permissions

Step 1
Step 2
Step 3

Step 4

You can restrict the permissions that you grant to particular user accounts in DMM-DSM. For example,
you might grant a user the permission to use only the advanced tasks that you choose or to deploy
presentations to only the DMPs that you choose.

Before You Begin

To see and use the Settings tab, you must be logged in an administrator.

Select Digital Signage Module from the untitled list at the top far-right of any page.
Select Settings > User Accounts.

In the Users list, click a username to highlight it. DMM-DSM automatically shows the Change User pane
for the corresponding user account, where you can edit the permissions that apply to the user.

Make selections to limit any or all of the permissions that you will grant to the user. If you do not
understand your options, see Table 3-11 on page 3-49.

By limiting permissions in specific ways, you can assign highly specialized combinations of access to
any DMM-DSM user. This table describes some of the types of limited permissions that you might want
to assign and tells you how to assign them:

Scenario

What You Must Do

Allow a user to
work with media
files but not to
deploy them.

a. From the Role list, select DMP Manager, select the All check box in the Read column, then
deselect every check box in the Create, Write, and Delete columns.

b. From the Role list, select Content Manager, then select the All check box in the Create, Read,
Write, and Delete columns.

c. From the Role list, select Application Manager, then select the Selected check box in the Create,
Read, Write, and Delete columns. Next, do all of the following:

- Click Create, then—in the table that associates permissions with applications—select only
these check boxes: Digital Media Designer and Go to URL.

— Click Read, then—in the table that associates permissions with applications—select only
these check boxes: Digital Media Designer and Go to URL.

— Click Write, then—in the table that associates permissions with applications—select only
these check boxes: Digital Media Designer and Go to URL.

— Click Delete, then—in the table that associates permissions with applications—select only
these check boxes: Digital Media Designer and Go to URL.

d. From the Role list, select Publisher Manager, select the All check box in the Read column, then
deselect every check box in the Create, Read, Write, and Delete columns.
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Scenario

What You Must Do

Allow a user to
administer one
DMP (or all of the
DMPs in one DMP
group), but have no
media-related
permissions.

a. From the Role list, select DMP Manager, then select the Selected check box in the Create, Read,
Write, and Delete columns. Next, do all of the following:

— Click Create. Then, in the object selector, click a DMP or a DMP group to highlight it.

— Click Read. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for Create permissions.

— Click Write. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for Create permissions.

— Click Delete. Then, in the object selector, click and highlight the same DMP or DMP group
that you highlighted for Create permissions.

b. From the Role list, select Content Manager, then deselect every check box in the Create, Read,
Write, and Delete columns.

c. From the Role list, select Application Manager, then—in the table that associates permissions
with applications—select only these check boxes: DMP Discovery, DMP Video/Audio Settings,
System Tasks, DMP Firmware Upgrade.

d. From the Role list, select Publisher Manager, then select the Selected check box in the Create,
Read, Write, and Delete columns. Next, do all of the following:

— Click Create. Then, in the object selector, click and highlight the same DMP or DMP group
that you highlighted for the DMP Manager role.

— Click Read. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for the DMP Manager role.

— Click Write. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for the DMP Manager role.

— Click Delete. Then, in the object selector, click and highlight the same DMP or DMP group
that you highlighted for the DMP Manager role.
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Scenario What You Must Do
Allow a user to a. From the Role list, select DMP Manager, then select the Selected check box in the Create, Read,
administer one Write, and Delete columns. Next, do all of the following:
DMP ((')r all of the — Click Create. Then, in the object selector, click a DMP or a DMP group to highlight it.
DMPs in one DMP
group), manage — Click Read. Then, in the object selector, click and highlight the same DMP or DMP group that
media for it, and you highlighted for Create permissions.
deploy assets to it. - Click Write. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for Create permissions.
— Click Delete. Then, in the object selector, click and highlight the same DMP or DMP group
that you highlighted for Create permissions.
b. From the Role list, select Content Manager, then select the All check box in the Create, Read,
Write, and Delete columns.
c. From the Role list, select Application Manager, then—in the table that associates permissions
with applications—select every check box.
d. From the Role list, select Publisher Manager, then select the Selected check box in the Create,
Read, Write, and Delete columns. Next, do all of the following:
— Click Create. Then, in the object selector, click and highlight the same DMP or DMP group
that you highlighted for the DMP Manager role.
— Click Read. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for the DMP Manager role.
— Click Write. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for the DMP Manager role.
— Click Delete. Then, in the object selector, click and highlight the same DMP or DMP group
that you highlighted for the DMP Manager role.
Allow a user to a. From the Role list, select DMP Manager, select the All check box in the Read column, then
deploy assets to one deselect every check box in the Create, Write, and Delete columns.
DMP (or all of the . .
: b. From the Role list, select Content Manager, then deselect every check box in the Create, Read,
DMPs in one DMP .
) Write, and Delete columns.
group), without any
other permissions. | €. From the Role list, select Application Manager, select the All check box in the Read column, then
deselect every check box in the Create, Write, and Delete columns.
d. From the Role list, select Publisher Manager, then select the Selected check box in the Create,
Read, Write, and Delete columns. Next, do all of the following:
— Click Create. Then, in the object selector, click a DMP or a DMP group to highlight it.
— Click Read. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for Create permissions.
— Click Write. Then, in the object selector, click and highlight the same DMP or DMP group that
you highlighted for Create permissions.
— Click Delete. Then, in the object selector, click and highlight the same DMP or DMP group
that you highlighted for Create permissions.
Step5  Click Submit.
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Configuring DMM-DSM Server Settings

Step 1
Step 2
Step 3
Step 4

Step 5

Step 6

You must configure DMM-DSM to use the correct Java servlet server and to use one, consistent
username and password for administrative access to all of the DMPs that you will manage centrally.

Before You Begin

To see and use the Settings tab, you must be logged in an administrator.

Select Digital Signage Module from the untitled list at the top far-right of any page.
Select Settings > Server Settings.

In the Servlet Server Address field, enter the routable IP address or resolvable DNS hostname for your
DMM appliance. It will not be updated automatically if you use AAI to change the IP address of your
DMM appliance.

In the DMP User Name field, enter the one administrative username that you have configured all of your
DMPs to share.

In the DMP User Password field, enter the one administrative password that you have configured all of
your DMPs to share.

Click Save.

Configuring DMM-DSM to Send Notification Settings

You can configure DMM-DSM to notify you or other interested parties automatically whenever
important events affect your digital signage network.

Before You Begin

To see and use the Settings tab, you must be logged in an administrator.

Step 1 Select Digital Signage Module from the untitled list at the top far-right of any page.
Step2  Select Settings > Email Notifications, then select the options that meet your requirements. If you do
not understand your options, see Table 3-12 on page 3-54.
Table 3-12 Elements for Configuring Notification Settings
Element Description
SMTP Mail Server Enter the required values for DMM-DSM to use an SMTP server. You must enter these values or you
Configuration cannot send notification messages.
e Host—Enter the routable IP address or resolvable DNS hostname for the SMTP server.
¢ User—Enter the username for an email account on the SMTP server.
e Password—Enter the password for the email user account on the SMTP server.
Administrator Email Address— Enter the administrator email address.
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Table 3-12 Elements for Configuring Notification Settings (continued)
Element Description
Notification Events Make selections and enter required values to configure notification settings, then click Save.

¢ Notification Events— Select the event type.

— DMP Registered —Select before you will enter the sender and recipient addresses for
messages that list all newly registered DMPs.

- DMP Up—Select before you will enter the sender and recipient addresses for messages that
list all registered DMPs that restarted recently.

— DMP Down—Select before you will enter the sender and recipient addresses for messages
that list all registered but inaccessible DMPs.

- DMP IP taken— Select before you will enter the sender and recipient addresses for
messages that list all registered DMPs with IP address conflicts. An address conflict occurs
when a DHCP server assigns to one registered DMP the exact dynamic IP address that some
other registered DMP used previously. If the DMP that previously used the address is no
longer in active use, you should delete the record of it in DMM-DSM; see Managing and
Grouping DMPs, page 3-3. If the DMP that previously used the address is one that should
still be active, confirm that it is still running and still connected to the network, then restart
it and confirm that its DHCP server does not assign IP addresses with expiration dates.

¢ From—Enter the email address from which to send notification messages. You can enter a
unique sender address for each of the notification event types.

e To—Enter the email address that should receive notification messages. You can enter a unique
recipient address for each of the notification event types.

¢ Subject—The human-readable subject category name that notification messages should
associate with the From address that you entered. You can enter a distinct name for each of the
different notification categories to assist you in filtering or recognizing important messages
when you receive them.

e Text before List of the DMPs—Enter the text that notification messages should place before
the list of DMPs.

e Text after List of the DMPs—Enter the text that notification messages should place after the
list of DMPs.

Configuring DMM-DSM to Use ACNS
You can configure DMM-DSM to use ACNS.

Before You Begin
To see and use the Settings tab, you must be logged in an administrator.

Step1  Select Digital Signage Module from the untitled list at the top far-right of any page.

Step2  Select Settings > ACNS, then select the options that meet your requirements. If you do not understand
your options, see Table 3-13 on page 3-56.

Step3  Click Save.

User Guide for Cisco Digital Media Manager 4.1
| oL-13984-01 .m



Chapter3  Using DMM-DSM for Digital Signage |

M Using Administrative Options

Table 3-13 Elements for Using ACNS

Element Description

CDM Address The routable IP address or resolvable DNS hostname of the appliance or services module (“blade”)
that runs ACNS and Content Distribution Manager software.

Port The TCP port for login access to CDM. The port number by default is 8443.

User The username for login access to CDM.

Password The password that corresponds to the CDM username that you entered.

Configuring DMM-DSM to Deploy to External Servers

You can configure DMM-DSM to deploy to external servers, but only within these operating parameters:
e The only supported server type is FTP in this release.
¢ You cannot use the Schedules > Immediate Deployment feature with external deployment servers.
e All deployments to your external deployment servers require that you use the Schedules > Future

Deployment feature.

Before You Begin

To see and use the Settings tab, you must be logged in an administrator.

Step1  Select Digital Signage Module from the untitled list at the top far-right of any page.

Step2  Select Settings > External Deployment Locations, then select the options that meet your requirements.
If you do not understand your options, see Table 3-14 on page 3-56.

Step3  Click Save.

Table 3-14 Elements to Configure Deployments to External Servers

Element Icon and Description

External Publishing Add, select, edit, or delete external deployment (FTP) servers.
Server List

— |Click a server to highlight it, so that you can edit or delete it. DMM-DSM automatically shows
the Change External Publishing Server pane for the corresponding server, where you can edit
its settings.

_| |Add New External Publishing Server— Shows the Add New External Publishing Server pane,
where you can define the settings to use a new server.

%] |Delete External Publishing Server —Deletes the server that you highlighted.
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Table 3-14 Elements to Configure Deployments to External Servers (continued)

Element

Icon and Description

{Add New | Change}
External Publishing
Server

Add or edit attributes of the external servers that you use for deployments.

Each of your external publishing servers most run the neccessary services to function both as an http
server and as an ftp server. In addition, the root-level directory for ftp must be equal to or under the
root-level directory for http. For example, you might use /wwwroot for http and /wwwroot/ftproot
for ftp.

Host—The routable IP address or resolvable DNS hostname of the external deployment (FTP)
server. You must enter this value.

Port— The port number to use. You can use any port number, but the default is 21.

Server Type—FTP.

Remote Directory — Corresponding to the same server directory structure that you reference
when you enter an HTTP Mapping value (see the row below this one), enter the root-level
deployment directory to use on your external publishing server when your communications
protocol is ftp. For example, you might enter only a forward slash (/).

HTTP Mapping— Corresponding to the same server directory structure that you reference
when you enter a Remote Directory value (see the row above this one), enter the root-level
deployment directory to use on your external publishing server when your communications
protocol is http. For example, you might enter /ftproot.

HTTP Port—Enter the port number to use on the external deployment server. You can use any
port number. If you do not enter a port number, the default is to use port 80.

User Name —Enter the FTP username. It is acceptable to use the name anonymous.

Password | Confirm Password— You must enter the FTP password, then reenter it.

Viewing the DMM-DSM ‘About Box’

To view version information about DMM-DSM, select Digital Signage Module from the untitled list at
the top far-right of any page, then select Help > About.

Testing for the Presence of, and Obtaining, the Required Java Version

pe

Tip

Step 1
Step 2

You can test for the presence on your PC of the Java Runtime Engine version that DMM-DSM requires.
If the required version is not installed, DMM-DSM tells you where you can download it.

To understand all of the prerequisites to use DMS and its components, including DMM-DSM, see
Release Notes for Cisco Digital Media System 4.1 on Cisco.com.

Select Digital Signage Module from the untitled list at the top far-right of any page.
Select Help > Downloads, then click Check Java Plugin.

A popup window opens. If the correct Java version is installed, a message tells you so. Otherwise,
DMM-DSM directs you to download the required version.
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Common Scenarios for Using DMM-DSM

Note

Step 1
Step 2

Step 3

Step 4

This section describes common scenarios for using DMM-DSM.

Uploading Files to a DMP for Local Storage and Inmediate Deployment

You can create a presentation that shows video files from a playlist, then transfer the presentation and
its assets to the local Secure Digital (SD) flash memory card in a DMP for playback on its attached
DMP display.

e The total amount of available file space for local storage is 0.9 GB on a DMP 4300G, or 1.9 GB on
a DMP 4305G.

e A presentation cannot play any file with a filesize greater than 1.9 GB on a DMP 4300G or on a
DMP 4305G. This size is constrained by the limits of streaming.

e For purposes of stage-one failover, the combined size of all files cannot exceed 900 MB on a
DMP 4300G or 1.9 GB on a DMP 4305G. This size is constrained by the storage capacity of the SD
memory card inside a DMP. To understand failover, see the “Understanding Content Substitution

(Failover)” topic in User Guide for Cisco Digital Media Player Device Manager 1.1 on Cisco.com.

Select Digital Signage Module from the untitled list at the top far-right of any page.

To learn how to create a playlist in Digital Media Designer, so that you can show the playlist as part of
a presentation, see Creating and Organizing Playlists for Your Presentations, page 3-27.

To create an advanced task that will transfer the assets for your playlist anywhere in your digital signage
network, select Digital Media Players > Advanced Tasks > File Transfer to DMP or Server, then do
the following:

a. Click | Add New Application, then enter a name for the new file transfer task in the Name field;
for example, you might enter the name LocalPublishing.

You must enter a name. The name is unique in the sense that you have not used it previously as the
name for any presentation or presentation template, or for anything that you created under the
Digital Media Players tab in DMM-DSM.

b. In the Applications list, click Digital Media Designer.

c. In the Available Content table, click a row to highlight the presentation, then click ¢ | Select
Applications. Doing this moves the highlighted presentation to the Selected Content table, so that
its assets become available for deployment.

d. To save your work, click Submit.

To deploy the file transfer task to a DMP or DMP group, select Schedules > Immediate Deployment,
then do the following:

a. From the DMP Groups object selector, select the DMP or DMP group that should receive
the deployment.

b. From the Actions list, select the name of the advanced task that you configured and saved for this
file transfer operation, then click Go.

DMM-DSM deploys the assets and commands immediately to the DMPs that you selected, and the
targeted DMPs restart automatically.
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After they restart, your DMPs will not show the newly received presentation automatically on their
attached DMP displays. The presentation will not play unless stage-one failover occurs or until you
deploy the Go to URL task that DMM-DSM generated automatically when you deployed assets to
the SD memory card.

After you create and deploy any “File Transfer to DMP or Server” task to save the assets from a
DMD presentation to the SD memory card inside a DMP, DMM-DSM automatically creates a Go to
URL task. The name by default for the Go to URL task is “failover - <name_of_presentation>. If
any of your DMPs should show the presentation at any time other than during stage-one failover,
you must deploy the corresponding Go to URL task to those DMPs. See Deploying Saved
Commands and Presentations to Your DMPs, page 3-42.

After you delete a presentation for which DMM-DSM automatically generated a corresponding Go
to URL task, you must also delete that Go to URL task.

Understanding and Using Digital Signage Status Report Charts

This section contains these topics:

Viewing the DMP Access Status Summary, page 3-59
Viewing Available and Used Disk Space, page 3-60

Viewing the DMP Access Status Summary

Step 1
Step 2

Tip

You can view a color-coded chart that illustrates in real time how many of the DMPs you registered in
DMM-DSM are reachable for centralized management.

The color green represents registered DMPs that are reachable.

The color red represents registered DMPs that are unreachable.

Select Digital Signage Module from the untitled list at the top far-right of any page.
Select Digital Media Players > Network Status.

The interval between polling cycles is 2 minutes, so any newly added DMP might report temporarily that
it is unavailable; if this happens to you, wait a few minutes, then check again.

If you notice that any of your DMPs are unreachable, see FAQs and Troubleshooting Guide for Cisco
Digital Media System 4.1 on Cisco.com.
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Viewing Available and Used Disk Space

Step 1
Step 2

You can view a color-coded chart that illustrates the percentages of free disk space and used disk space
on the /dm2 partition that your DMM appliance uses to store local copies of digital signage assets after
you upload them.

e The color green represents available space in gigabytes.

e The color blue represents used space in gigabytes.

Select Digital Signage Module from the untitled list at the top far-right of any page.
Select Media > Disk Space.

L

Tip To check the free space on the SD memory card in a DMP, log in to its local instance of DMPDM,
then click Internal Storage.
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