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1  Overview
The Cisco Unified Videoconferencing Manager IBM Lotus Notes Plug-in is a separately deployed plug-in that can work in a 
Cisco Unified Videoconferencing Manager deployment or in a standalone Desktop Server deployment without Cisco Unified 
Videoconferencing Manager.

In a Cisco Unified Videoconferencing Manager deployment, the IBM Lotus Notes Plug-in allows users to schedule, modify, 
cancel and manage Resource Manager meetings using the IBM Lotus Notes interface.

In a standalone Desktop Server deployment, the Cisco IBM Lotus Notes Plug-in allows users to send out meeting invitations 
using the IBM Lotus Notes interface.

2  Lotus Domino User Interface
This document uses the Lotus Domino 8 interface to illustrate procedures. There are several minor differences between the user 
interfaces for each of the supported Lotus Domino versions, including the following:

• Versions 7 and 7.5 include a File > Database option. This is replaced in version 8 by File > Application.

• Versions 7 and 7.5 include a Server list in the Open Database dialog box. This is replaced in version 8 by the Look in option.

3  Prerequisites

System Requirements
Lotus Domino Server

• Supported versions: 7.0, 8.0 and 8.5

• Running DIIOP HTTP services

• Configured as a Web Single Sign-on (SSO) server with LTPA token

• Lotus Domino Administrator and Designer interfaces must be available

Each user should have a dedicated email account for receiving meeting messages including meeting accept and decline messages.

For Cisco Unified Videoconferencing Manager deployments

• A dedicated Cisco Unified Videoconferencing Manager server which the IBM Lotus Notes Plug-in can connect to.

• This Cisco Unified Videoconferencing Manager server should be configured to work with IBM Domino server LDAP 
Directory service.

• Assign at least one virtual room to each user.

For Desktop Server deployments

• A dedicated Desktop Server server which the IBM Lotus Notes Plug-in can connect to.

Installation Files
The following files are provided with the product:

• Setup0.nsf (where 0 represents the version number of your Lotus Domino Server) containing the agents used to install or 
upgrade Cisco Unified Videoconferencing Manager IBM Lotus Notes Plug-in.

• 9 .dxl files containing the code used to install Cisco Unified Videoconferencing Manager IBM Lotus Notes Plug-in

– IVAgentLib.dxl

– IVClientConfig.dxl

– IVConfig.dxl

– IVForm.dxl

– IVShareLib.dxl
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– IVSubForm.dxl

– LotusAddonAppletJar.dxl

– MeetingAgent.dxl

– SDAccessAgent.dxl

Copy them all to a location of your choice on your computer.

4  How to Verify that the DIIOP and HTTP Services are Running
Procedure

Step 1 Use a text editing application to open the notes.ini file located at C:\Program Files\IBM\Lotus\Domino\ on your 
computer. 

Step 2 Locate the line 

ServerTasks=Update,Replica,Router,AMgr,AdminP,CalConn,Sched,LDAP,RnRMgr,DIIOP,HTTP

Step 3 Verify that DIIOP and HTTP are present. Add them if they are not.

Step 4 Restart your Domino server.

Step 5 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 6 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 7 Select the Domain tab displaying the name of your Lotus Domino server.

Step 8 Select the Server tab.

Step 9 Select the Status tab.

Step 10 Select Server Tasks from the list below the Status tab.

Step 11 Verify that the DIIOP Server and HTTP Server tasks appear. 
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5  How to Install the Cisco Unified Videoconferencing IBM Lotus Notes 
Plug-in

• Creating NSF Objects in the Domino Designer Interface, page 4

• Configuring a Template in the Domino Administrator Interface, page 5

• Configuring Forms and Script Libraries in the Domino Designer Interface, page 7

Creating NSF Objects in the Domino Designer Interface
This procedure uses the following terms where 0 represents the version number of your Lotus Domino Server:

• mail0.ntf

• mail0_IV.ntf

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Designer to connect to the target Domino server.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select File > Application > Open in the Lotus Domino Designer interface.

Step 4 Browse to the setup.nsf file and select Open.

Step 5 Select the setup icon in the left panel to expand it.

Step 6 Select Shared Code > Agents.
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Step 7 Sign the agents as follows:

a. Select the Create IVConfig.nsf agent in the panel on the right, and then select the Sign button.

Create IVConfig.nsf contains the Cisco IBM Lotus Notes Plug-in configuration screen.

b. Select the Create mail0_IV.ntf agent in the panel on the right, and then select the Sign button.

Create mail0_IV.ntf contains a new template file for scheduling meetings using the Cisco IBM Lotus Notes Plug-in, 
based on mail0.ntf.

Step 8 Create the IVConfig.nsf file on the Domino server as follows:

a. Right-click the Create IVConfig.nsf agent and select Run.

b. Select File > Application > Open and browse to the IVConfig.dxl file.

c. Select Open.

Step 9 Create the mail0_IV.ntf file on the remote server as follows:

• Right-click the Create mail0_IV.ntf agent and select Run.

• Select File > Application > Open and browse to the IVAgentLib.dxl file.

• Select Open.

Step 10 Close the Domino Designer interface.

Configuring a Template in the Domino Administrator Interface
This procedure uses the following terms where 0 represents the version number of your Lotus Domino Server:

• mail0_IV.ntf

• Stdmail0_IV
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Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Files tab.

Step 5 Select All file types in the Show me field.

Step 6 Locate the mail0_IV.ntf file in the filename list.

Step 7 Right-click mail0_IV.ntf and select Properties to display the Database dialog box.

Step 8 Select the Design tab (the fourth tab from the left).

Step 9 Select Database file is master template.

Step 10 Enter StdMail0_IV in the Template Name field.
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Step 11 Close the Database dialog box.

Step 12 Save your changes.

Step 13 Close the Domino Administrator interface.

Configuring Forms and Script Libraries in the Domino Designer Interface
This procedure uses the following terms where 0 represents the version number of your Lotus Domino Server:

• Mail (R0) IV

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Designer to connect to the target Domino server.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select File > Application > Open in the Lotus Domino Designer interface.

Step 4 Select the Look in drop-down list.

Step 5 Select the remote Domino server that has the Cisco IBM Lotus Notes Plug-in installed from the list.

Step 6 Select Mail (R0) IV Addon from the database list, and then select Open.
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Step 7 Double-click _Calender Entry in the list of forms that displays.

Step 8 Scroll to the end of the code that appears above the list of forms and locate the Body field.

Step 9 Place your cursor next to the Body field and then select Create > Resource > Insert Subform from the menu at the top 
of the screen.

Step 10 Select IVSubForm from the Insert Subform window.

Step 11 Select OK and verify that the subform is inserted near the Body field.

Step 12 Select the X in the _Calendar Entry Form tab to save and close the _Calendar Entry form.
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Step 13 Select View > Go to > Views from the menu at the top of the screen to display all views in the Mail (R0) IV Addon 
database.

Step 14 Double-click ($Calendar).

Step 15 Select View again from the menu at the top of the screen and verify that Action Pane is selected.

Step 16 Locate the Action pane at the right of the screen.

Step 17 Right-click Unfilter and select Create Action.

Step 18 Enter Cisco Settings in the Name field in the first tab of the Actions dialog box.

Step 19 Select Hide action if formula is true in the second tab of the Action dialog box, and select Formula Window.

Step 20 Paste the following code in the Edit Formula window:

@If(@TextToNumber(@Version) < 174;@True;@False) | @Environment("OEMClient") = "1" | 
@IsNotMember("Notes_Video_conf_sched_group"; @UserNamesList)

Step 21 Select Done to close the Action window.

Step 22 Paste the following code in the (Action): Click window:

@If(@ClientType = "Notes";@Command([Compose];"IVClientConfig") : @Return(0);"")

Step 23 Select the Mail (R0) IV Addon tab.

Step 24 Select View > Go to > Forms from the menu at the top of the screen.

Step 25 Double-click _Calender Entry in the list of forms that displays.

Step 26 Select View again from the menu at the top of the screen and verify that Programmer’s Pane is selected.

Step 27 Select (Globals)Appointment > (Options) in the Objects tab and add the following line at the end of the code:

Use "IVShareLib"

Step 28 Select Appointment (Form) > Queryopen in the Objects tab.

Step 29 Locate CSCalendarEntry in the code and replace with IVCSWrapper.
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Step 30 Save and close the form.

Step 31 Enter code into the CSUIViewClass Script Library as follows:

a. Select the Mail (R0) IV Addon tab.

b. Select View > Go to > Script Libraries from the menu at the top of the screen to display all script libraries for the Mail 
(R0) IV Addon database.

c. Double-click CSUIViewClass.

d. Select CSUIViewClass > (Options) in the Objects tab and add the following line at the end of the code:

Use "IVShareLib"

e. Select CSUIViewClass > InitEventObject in the Objects tab. 

f. Locate CSEventNotes in the code and replace with IVCalendarWrapper.

g. Save and close the script library.

6  How to Configure the Cisco Unified Videoconferencing IBM Lotus Notes 
Plug-in

• Using a New Template, page 10

• Configuring Domino Web Single Sign-on, page 11

• Assigning an Execution Control List, page 12

Using a New Template
This procedure uses the following terms where 0 represents the version number of your Lotus Domino Server:

• mail0_IV.ntf
10



Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the People & Groups tab, and then select Add Group.

Step 5 Create a user group called Notes_Video_conf_sched_group.

Any user that you assign to this group can see the user interface of the Cisco IBM Lotus Notes Plug-in.

Step 6 Access the Domino server console as follows:

a. Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

b. Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

c. Select the Domain tab displaying the name of your Lotus Domino server.

d. Select the Server tab.

e. Select the Status tab.

f. Select Server Console from the list below the Status tab.

Step 7 Use the Domino server console command to change the mail file template for all affected users.

For example, assume user John’s mail file is John.nsf. Enter the following command in the Domino Command field to 
convert the John.nsf template to mail0_IV.ntf:

For Windows:

>> load convert mail\ John.nsf * mail0_IV.ntf

For Linux

>> load convert mail/ John.nsf * mail0_IV.ntf 

Step 8 To change all mail files in the mail directory, send the following command:

For Windows:

>> load convert mail\*.nsf * mail0_IV.ntf

For Linux: 

>> load convert mail/ *.nsf * mail0_IV.ntf

Configuring Domino Web Single Sign-on 
The Web Single Sign-on (SSO) configuration described here is R5 compatible.

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Configuration tab.

Step 5 Select Server > Current Server Document. 

Step 6 Select Create Web and then SSO Configuration.
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Step 7 Enter the Cisco Unified Videoconferencing Manager server DNS domain in the DNS Domain field.

For example, “mycompany.com”.

Step 8 Select the arrow next to the Domino Server Names field to display the Select Name dialog box.

Step 9 Select the name of the Domino server with the Cisco IBM Lotus Notes Plug-in installed from the list in the left panel, 
and move it to the Names list in the right panel.

Step 10 Select OK to close the Select Name dialog box.

Step 11 Verify that the name of the Domino server with the Cisco IBM Lotus Notes Plug-in installed appears in the Domino 
Server Names field.

Step 12 Select Keys > Create Domino SSO Key to generate a new key.

Step 13 Select Save & Close to save your changes and close the Web SSO Configuration window.

Step 14 Select the Configuration tab.

Step 15 Select Server > Current Server Document. 

Step 16 Select Internet Protocols > Domino Web Engine.

Step 17 Select Edit Server.

Step 18 Select Multiple Servers (SSO) in the Session authorization option.

Step 19 Select LtpaToken in the Set Web SSO Configuration option.

Step 20 Select Basics and verify that the Load Internet configurations from Server\Internet Sites documents field is set to 
Disabled.

Step 21 Select Save & Close to save your changes.

Assigning an Execution Control List
Assign an Execution Control List (ECL) to users so that they can execute the Cisco IBM Lotus Notes Plug-in client-side module.

Create a new policy which allows users to run the Cisco IBM Lotus Notes Plug-in, and then assign this policy to user group 
Notes_Video_conf_sched_group.

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.
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Step 4 Select the Configuration tab.

Step 5 Select Policies > Create in the right panel to create a new policy. 

Step 6 Select the Policy option in the Create New Policy dialog box and select OK.

Step 7 Select Basics and enter a name for the policy in the Policy name field such as “IV_POLICY”.

Step 8 Select New next to the Security field to create new security settings.

Step 9 Enter a name for the new security setting in the Basics tab such as “IV_SECURITY”.

Step 10 Select Execution Control List.

Step 11 Select Refresh in the Set Update Mode field.

Step 12 Select Manage next to Admin ECL and enter a name for the ECL in the Create New Admin ECL field such as “IV_ECL”.

Step 13 Select OK and then Edit.

Step 14 Select Allow user to modify and Workstation security in the Workstation Security: Execution Control List dialog box.

Step 15 Select Add and then select the icon in the Add User dialog box to specify the users that have permission to modify 
workstation security.   

Step 16 Select Java applet security in the Workstation Security: Execution Control List dialog box and repeat Step 15.

Step 17 Select the following access options:

• Access to file system

• Access to Notes Java classes

• Access to network addresses

• Printing

• Access to system properties

• Dialog and clipboard access

• Process-level access

Step 18 Select OK to save your changes and close the Execution Control List window.

Step 19 Verify that IV_POLICY appears in the Configuration tab. 

Step 20 Select the People & Groups tab and select Groups.

Step 21 Right-click Notes_Video_conf_sched_group and select Assign Policy. 

Step 22 Select IV_POLICY for this user group.

Step 23 Select OK to save your changes.
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7  Configuring the Domino Server
This section describes how to perform the server-side configuration for the Cisco Unified Videoconferencing Manager IBM 
Lotus Notes Plug-in. 

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Files tab.

Step 5 Select Databases only in the Show me field.

Step 6 Double-click ivconfig.nsf in the database list.

The CUVC-M Administrator Settings window displays. Use this window to configure the Cisco Unified 
Videoconferencing Manager or Desktop Servers that users can connect to for meeting scheduling. 

Step 7 In the Add Server section

• Set the type of server URL that you want to add in the Server Type field.

• Enter a name for the server that you want to add in the Server Name field.

• Enter the server URL in the Server URL field. 

For Cisco Unified Videoconferencing Manager use the format http://SERVER_URL:PORT_NUMBER

For Cisco Unified Videoconferencing Desktop use the format http://SERVER_URL:PORT_NUMBER/cuvm

Step 8 Select Add to list.

Step 9 (Optional) Select Remove from list to remove any defined server from the Select List section.

Step 10 (Optional) Select Check Server Status to verify that the server is reachable.

The server status is displayed in the Status field. 

A server must be reachable for the Cisco Unified Videoconferencing Manager IBM Lotus Notes Plug-in to function 
properly.

Step 11 (Optional) Select Generate LTPA token in the Advanced section to verify that a secure communication mechanism has 
been properly configured between the Lotus Domino server and the Cisco Unified Videoconferencing Manager server 
working in Single Sign-on (SSO) mode.

If a new LTPA token is displayed in the Status field, secure communication has been properly configured.

8  How to Uninstall the Cisco Unified Videoconferencing IBM Lotus Notes 
Plug-in

• Reverting to the Default Mail Template, page 14

• Removing the ivconfig Database, page 15

• Removing the mail0_iv Template, page 15

Reverting to the Default Mail Template
This procedure uses the following terms where 0 represents the version number of your Lotus Domino Server:

• mail0.ntf
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Procedure

Step 1 Access the Domino server console as follows:

a. Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

b. Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

c. Select the Domain tab displaying the name of your Lotus Domino server.

d. Select the Server tab.

e. Select the Status tab.

f. Select Server Console from the list below the Status tab.

Step 2 Use Domino server console command to change the mail file template for all affected users.

For example, assume user John’s mail file is John.nsf. Enter the following command in the Domino Command field to 
convert the John.nsf template to mail0.ntf:

For Windows:

>> load convert mail\ John.nsf * mail0.ntf

For Linux

>> load convert mail/ John.nsf * mail0.ntf

Step 3 To change all mail files in the mail directory, send the following command:

For Windows:

>> load convert mail\*.nsf * mail0.ntf

For Linux: 

>> load convert mail/ *.nsf * mail0.ntf

Removing the ivconfig Database

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Files tab.

Step 5 Select Databases only in the Show me field.

Step 6 Right-click ivconfig.nsf and select Delete Database.

Step 7 Select Also delete replicas of this database on all other servers.

Step 8 Select OK to delete this database.

Removing the mail0_iv Template 
This procedure uses the following terms where 0 represents the version number of your Lotus Domino Server:

• mail0_IV.ntf

• Mail (R0) IV
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Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Files tab.

Step 5 Select All file types in the Show me field.

Step 6 Right-click Mail (R0) IV Addon and select Delete Database.

Step 7 Select Also delete replicas of this database on all other servers.

Step 8 Select OK to delete this template.


	Installing and Configuring the Lotus Notes Plug-in for Cisco Unified Videoconferencing Manager Release 7.1
	1 Overview
	2 Lotus Domino User Interface
	3 Prerequisites
	System Requirements
	Installation Files

	4 How to Verify that the DIIOP and HTTP Services are Running
	5 How to Install the Cisco Unified Videoconferencing IBM Lotus Notes Plug-in
	Creating NSF Objects in the Domino Designer Interface
	Configuring a Template in the Domino Administrator Interface
	Configuring Forms and Script Libraries in the Domino Designer Interface

	6 How to Configure the Cisco Unified Videoconferencing IBM Lotus Notes Plug-in
	Using a New Template
	Configuring Domino Web Single Sign-on
	Assigning an Execution Control List

	7 Configuring the Domino Server
	8 How to Uninstall the Cisco Unified Videoconferencing IBM Lotus Notes Plug-in
	Reverting to the Default Mail Template
	Removing the ivconfig Database
	Removing the mail0_iv Template



