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1  Preparing for Installation
This document provides installation information for administrators and users of Cisco Unified Videoconferencing Connector.

Prior to installing Cisco Unified Videoconferencing Connector, verify that these conditions are fulfilled:

 • IBM Lotus Sametime is configured with Working Sametime installation.

 • Cisco Unified Videoconferencing Desktop Server is installed and configured.

 • Desktop product CD-ROM is available.

2  Installing and Configuring the Cisco Unified Videoconferencing Desktop 
Connector Plug-In Release 7.1 with IBM Lotus Sametime Connect
This section describes how administrators can automatically deploy the Cisco Unified Videoconferencing Connector plug-in 
throughout a network, and how end users can manually install the plug-in on a Sametime Connect client.

 • Update Sites, page 2

 • Installing the Cisco Unified Videoconferencing Connector Update Site from the CD-ROM, page 2

 • How to Install the Cisco Unified Videoconferencing Connector from an Update Site, page 3

 • Distribution Methods for the Cisco Unified Videoconferencing Connector, page 6

Update Sites
An update site is a specific directory layout with an XML file that specifies all the available plug-ins. The method of how the 
update site is presented to the client can vary (for example, as a web site or through the local file system).

If Desktop is detected when installing Cisco Unified Videoconferencing Connector, an Eclipse update site is created for you in 
the Desktop installation directory at   <installdir>/Tomcat/webapps/ROOT/sametime. You can use the update site at this 
location, or you can copy the files from the update site to a location of your choice.

An update site is a specific directory layout with an XML file that specifies all the available plug-ins. You can variously present 
the update site to the client; for example, as a web site or using the local file system.

If Desktop is detected when installing Cisco Unified Videoconferencing Connector, an Eclipse update site is created for you in 
the Desktop installation directory at <installdir>/Tomcat/webapps/ROOT/sametime.

We recommend using the installer to create the update site. The update site is usually set up on the same server as Desktop.

If you already have plug-ins that you automatically push using an update site, you need to merge the Cisco Unified 
Videoconferencing Connector site.xml file with the existing site.xml file, and copy the contents of the Cisco Unified 
Videoconferencing Connector features and plug-ins folders into the existing corresponding folders.

Installing the Cisco Unified Videoconferencing Connector Update Site from the 
CD-ROM
Install the Cisco Unified Videoconferencing Connector update site from the Desktop CD-ROM.

Procedure

Step 1 Insert the CD-ROM.

Step 2 Wait for the autorun menu screen to display.

Step 3 Select Cisco Unified Videoconferencing Connector for IBM Lotus Sametime.

Step 4 Select Install Update Site.
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Step 5 Select the setup.exe file and follow the on-screen instructions.

The Choose Installation Location screen detects if Desktop is installed.

If Desktop is detected, the installer attempts to create an update site at

<installdir>/Tomcat/webapps/ROOT/sametime

The default update site URL is http://<server>/sametime.

Where <server> stands for either the IP address or FQDN of the server on which you install the Cisco Unified 
Videoconferencing Connector.

Alternatively, you can configure the installer to create an update site at a different location.

Step 6 If Desktop is not detected, define the location at which you want the installer to place the files needed for an update site. 

Step 7 By default, the installer places the files at

\Program Files\Cisco\ Connector for IBM Lotus Sametime

You must either place the files needed for an update site under a Sametime update site, or distribute them manually.

How to Install the Cisco Unified Videoconferencing Connector from an Update Site
You can install Cisco Unified Videoconferencing Connector either automatically or manually.

 • How to Automatically Deploy the Cisco Unified Videoconferencing Connector, page 3

 • Manually Installing the Cisco Unified Videoconferencing Connector from an Update Site, page 5

How to Automatically Deploy the Cisco Unified Videoconferencing Connector

 • Installing the Cisco Unified Videoconferencing Connector using the Community Client Document, page 3

 • Installing the Plug-in Using the preferences.ini File, page 4

Installing the Cisco Unified Videoconferencing Connector using the Community Client Document

This section describes how you can automatically deploy the Cisco Unified Videoconferencing Connector plug-in using the 
Sametime server Community Client Document.

Procedure

Step 1 Access the Sametime Server.

Step 2 Double-click the Domino Admin icon on the desktop.

Step 3 Sign in using administrator credentials.

Step 4 Select the Domain tab.

Step 5 Select the Files tab.

Step 6 Double-click the Sametime Configuration (stconfig.nsf) document.

Step 7 Select By Form. 

Step 8 Right-click and select Edit CommunityClient document.

Step 9 Locate the UIM Provisioning field.

Step 10 Edit the URL in the field by adding the full path to your update site (including http://). For example, http://<server name 
or IP>/sametime.

Step 11 Copy this URL to the Sametime update site URL field in the Policy which applies to the users:

a. Using the web-based server administrator (http://<sametime server>/stcenter.nsf) sign in as the administrator.

b. Where <server> stands for either the IP address or FQDN of the Sametime Server.

c. Select the Administer the server link.
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d. Select the Policies link.

e. Select the Sametime Default Policy link.

f. Scroll down to the Instant Messaging section.

g. Modify the Sametime update site URL with local update site on the Sametime server.

h. Check the Override all policies check box to immediately push the new configuration to clients.

i. Select OK to save your changes.

j. Use another web page and run the Domino Server Administrator (http://<server>/webadmin.nsf).

k. Sign in and select the Server tab at the top of the page.

l. Select Tools > Server > Restart to restart your Sametime server.

The next time a user signs in to the Sametime Connect client, the plug-in is downloaded and the user is prompted to 
restart the Sametime client.

Step 12 Save and close the stconfig.nsf file.

Installing the Plug-in Using the preferences.ini File 

This section describes how you can automatically deploy the Cisco Unified Videoconferencing Connector plug-in using the 
Sametime Connect preferences.ini configuration file.

The preferences.ini file is located by default at the following locations on the Sametime Connect client:

 • Sametime 7.5.x

C:\Program Files\ibm\Sametime Connect\plugins\

com.ibm.collaboration.realtime.update_1.0.0

 • Sametime 8.0

C:\Program Files\IBM\Lotus\Sametime Connect\shared\

eclipse\plugins\com.ibm.collaboration.realtime.update_8.0.0.20071119-1552

Procedure

Step 1 Access the Cisco Unified Videoconferencing Desktop Server.

Step 2 Verify that an update site is created. See How to Install the Cisco Unified Videoconferencing Connector from an Update 
Site, page 3 for an explanation of update sites.

Step 3 Open the preferences.ini file. 

Step 4 Enter your update site URL as the value for the adminUpdatePolicyURL parameter. Use the format

adminUpdatePolicyURL=http://server.domain.com/sametime/site.xml

Step 5 Save and close the preferences.ini file.

The next time the user signs in to the Sametime Connect client, the client searches for the update site URL in the URL 
for UIM Provisioning parameter of the stconfig.nsf file on the Sametime server.

If the client fails to find the URL, the client searches for the value of the adminUpdatePolicyURL parameter of the 
preferences.ini file.

When the client finds this value, the plug-in is downloaded and the user is prompted to restart the Sametime client.
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Manually Installing the Cisco Unified Videoconferencing Connector from an Update Site

This section describes how Sametime users can manually install the Cisco Unified Videoconferencing Connector plug-in on a 
Sametime Connect client.

The Cisco Unified Videoconferencing Connector plug-in is available for download from an update site. For more information, 
see How to Install the Cisco Unified Videoconferencing Connector from an Update Site, page 3.

Note Sametime Administrators may prevent users from performing manual downloads. For more information, see Preventing 
Manual Downloading, page 6. 

Procedure

Step 1 In the Sametime Connect client user interface, choose 

 • (for Sametime 7.5 CF1) File > Manage Updates > Download Plugins 

 • (for Sametime 7.5.1 and 8.0) Tools > Plug-ins > Install plug-ins.

Step 2 If you have a previous version of the plug-in already installed, the installer prompts you to search for updates to the 
currently installed features. In the Feature Updates window, choose Search for updates of the currently installed 
features, and then go to Step 9.

Step 3 If you do not have a previous version of the plug-in installed, in the Feature Updates window choose Search for new 
features to install, and select Next.

Step 4 In the Update sites to visit window, select Add Remote Location (or New Remote Site for Sametime 7.5.1 CF1).

Step 5 Enter an update site name and URL.

For example, name “Cisco Unified Videoconferencing Connector” and URL http://<server>/sametime.

Where <server> stands for either the IP address or FQDN of the server hosting the update site.

Step 6 Select OK to save the location.

Step 7 Check the checkbox for the new location.

Step 8 Select Finish.

Step 9 In the Search Results window, expand the tree labeled with the name that you entered at Step 5 to view all available
Cisco Unified Videoconferencing Connector plug-ins.

Step 10 Choose the latest version of the Cisco Unified Videoconferencing Connector plug-in and click Next.

Step 11 In the Feature License window, accept the terms of the license agreement and select Next.

Step 12 In the Installation window, select Finish.

If the installation is successful, you are prompted to restart the Sametime client to access to the new plug-ins.

Installation is now complete and the Cisco Unified Videoconferencing Connector plug-in Preferences window is now 
available.
5



Preventing Manual Downloading

This section describes how Sametime you can prevent users from performing manual downloads to a Sametime Connect client.

Procedure

Step 1 On the Sametime server host machine, open the sametime.ini configuration file located at \Lotus\Domino. 

Step 2 Under the [config] section, add the following line: DisableConnectPluginUpdates=1. 

Step 3 Restart the server and reconnect with the client. 

The user options are grayed out.

In the Sametime Connect client user interface, the options under Tools > Plug-ins are disabled.

Installing the Cisco Unified Videoconferencing Connector without an HTTP Server

This section describes how to install the Cisco Unified Videoconferencing Connector plug-in in Sametime Connect client from 
a local file without using an HTTP server. To do this, you locate the update site in a shared network directory. Users can then 
access this directory from the Sametime Client interface.

Procedure

Step 1 Save the sametime directory to a shared network location.

Step 2 In the Sametime Connect client user interface, choose Tools > Plug-ins > Install plug-ins.

Step 3 In the Feature Updates window choose Search for new features to install, and select Next.

Step 4 In the Update sites to visit window, select Add Folder Location (for Sametime 8.0) or New Local Site (for Sametime 
7.5.1), navigate to the saved sametime directory and select OK.

Step 5 Select Finish. The Sametime Connect client now searches for updates from the defined site.

Step 6 In the Search Results window, select sametime. 

Step 7 Enter a new name for the directory and select OK, or leave the directory name unchanged.

Step 8 Select Next.

Step 9 In the Feature License window, accept the terms of the license agreement and select Next.

Step 10 In the Installation window, select Finish.

Step 11 Select Install or Install All.

If the installation is successful, you are prompted to restart the Sametime client to access to the new plug-ins.

Installation is now complete and the Cisco Unified Videoconferencing Connector plug-in Preferences window is now 
available.

Distribution Methods for the Cisco Unified Videoconferencing Connector
You can distribute the Cisco Unified Videoconferencing Connector plug-in by using these methods: 

 • “Pushing” the plug-in to all Lotus Sametime Connect users in a specified community.

The plug-in is automatically downloaded to the client when the user launches Lotus Sametime Connect. The user is notified 
of the update and can choose to automatically restart the client to load the new plug-in.

For more information, see How to Automatically Deploy the Cisco Unified Videoconferencing Connector, page 3.

 • Sending the update site URL to users:

Users must retrieve and install the plug-in manually using the Lotus Sametime Connect Manage Updates user interface.
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For more information, see Manually Installing the Cisco Unified Videoconferencing Connector from an Update Site, page 5.

You can optionally prevent users from performing this procedure. For more information, see Preventing Manual 
Downloading, page 6.

3  Integrating Cisco Unified Videoconferencing Connector for Lotus 
Sametime Web Conferencing into the Sametime Deployment
 • About Deploying IBM Lotus Sametime Web Conferencing with Cisco Unified Videoconferencing Connector Deployment, 

page 7

 • Installing the Sametime Connector on the Cisco Unified Videoconferencing Desktop Server, page 10

 • How to Prepare the Sametime Servers, page 10

 • Configuring the Sametime Settings on the Cisco Unified Videoconferencing Desktop Server, page 11

About Deploying IBM Lotus Sametime Web Conferencing with Cisco Unified 
Videoconferencing Connector Deployment
When you integrate IBM Lotus Sametime with Desktop, your users can add real-time multipoint video and audio to Sametime 
Web meetings. To accomplish this, you must associate a Cisco Unified Videoconferencing Desktop Server with an IBM Lotus 
Sametime Community deployment.

You use two modules for the integration:

 • Sametime Connector, a Sametime Community Server application that runs as part of the Desktop middleware

 • Sametime Meeting Room Client Javascript extension that is used to realize the user interface inside the Sametime Meeting 
Room Client

Sametime Connector detects the start of a Sametime meeting and attaches meeting attributes along with an ID of a Desktop 
ad-hoc meeting which is generated at that time. The Javascript extension is loaded with the Meeting Room Client when a user 
joins a Sametime meeting and pulls the video meeting information from the meeting so that all attendees transparently join the 
same video meeting.

Read these sections to correctly plan your deployment:

 • Simple Sametime Deployments, page 8

 • Multiple Sametime Community Hubs Deployments, page 8
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Simple Sametime Deployments
Use this diagram when planning your Sametime Deployment.

Figure 1 Simple Sametime Deployment

Multiple Sametime Community Hubs Deployments

In deployments described in this section, there may be multiple community hubs. Users schedule meetings through their home 
Sametime Server and may invite users from the same home server as well as users from other Community Server clusters. The 
meetings may be hosted on the home Sametime Server of the meeting creator as shown on Figure 2 on page 9. In this case, 
meeting attributes do not need to be propagated to the other server. 
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Figure 2 Multiple Sametime Community Hub Deployment for non-propagated meetings

Alternatively, meetings may be hosted on different Sametime Servers. In this case, the meeting information and attributes are 
propagated from the home Sametime Server to the other server as shown on Figure 3.

Figure 3 Multiple Sametime Community Hub Deployment for propagated meetings
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Installing the Sametime Connector on the Cisco Unified Videoconferencing Desktop 
Server

Procedure

Step 1 On the Cisco Unified Videoconferencing Desktop Server, navigate to this location: >InstallDir>Desktop\SametimeWeb.

Step 2 Double-click the enable_sametime.vbs file.

Step 3 Select OK in the confirmation message.

When the installation is completed, a message is displayed explaining that the Sametime Connector is installed and the 
log file is created.

How to Prepare the Sametime Servers
 • Enabling Community Services Connectivity, page 10

 • Installing the Meeting Room Client Javascript Extension, page 10

Enabling Community Services Connectivity

To prepare the Sametime server for the Cisco Unified Videoconferencing Connector for IBM Lotus Sametime Web Conferencing, 
you must edit the Sametime configuration: open the IBM Domino Administrator Application and change the IP address 
configuration of the Cisco Unified Videoconferencing Desktop Server to allow connection to Community Services. Perform this 
procedure on every Sametime server that has a Cisco Unified Videoconferencing Desktop Server associated with it.

Procedure

Step 1 Open the IBM Domino Administrator application.

Step 2 Select the Domain tab.

Step 3 Select the Files tab.

Step 4 Navigate to this location: \Program Files\IBM\Lotus\Domino\Data.

Step 5 Double-click the Sametime Configuration file.

Step 6 Select By Form in the left pane.

Step 7 Right-click the CommunityConnectivity, and then select Edit.

The form opens.

Step 8 Enter the IP address of the Cisco Unified Videoconferencing Desktop Server in the Community Trusted IPS field.

Step 9 Select File > Save.

Installing the Meeting Room Client Javascript Extension

To enable the video integration, you need to copy a file to the Sametime server. This file was placed on the Cisco Unified 
Videoconferencing Desktop Server during the Cisco Unified Videoconferencing Connector installation.

Procedure

Step 1 On the Cisco Unified Videoconferencing Desktop Server, navigate to this location:

Program Files\Cisco\Desktop\SametimeWeb\

Step 2 Copy the SDMrcExtension.js file.
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Step 3 On the Sametime server, create this location:

\Program Files\IBM\Lotus\Domino\data\domino\html\sametime\jsext

Step 4 Paste the copied file into this location.

Configuring the Sametime Settings on the Cisco Unified Videoconferencing Desktop 
Server
You need to configure the Cisco Unified Videoconferencing Desktop Server to work with the Sametime Server.

By default, the Cisco Unified Videoconferencing Desktop Server generates meeting IDs for IBM Lotus Sametime Web 
Conferencing meetings dynamically. The Cisco Unified Videoconferencing Desktop Server uses a service number configured in 
MCU as a meeting prefix, adding a randomly generated four-digit number to it to create a meeting ID. In deployments using 
Cisco Unified Videoconferencing Manager, you can configure the Cisco Unified Videoconferencing Desktop Server to use a 
predefined virtual room.

Before You Begin
 • Access the Desktop Administration web user interface.

 • Verify the Sametime Server address.

 • Verify which port on the Sametime Server you need to assign to the Cisco Unified Videoconferencing Desktop Server.

Procedure

Step 1 Select Sametime in the sidebar.

Step 2 Enter the Sametime Server address.

Step 3 Enter the port on the Sametime Server.

The default port is 1516.

Step 4 For deployments using MCU, select Generate meeting IDs dynamically, using the specified meeting prefix, and then 
enter the meeting prefix. The meeting ID generated by Cisco Unified Videoconferencing Desktop Server will be based 
on the meeting prefix you define.

-or-

Step 5 For deployments using Cisco Unified Videoconferencing Manager, select Use the meeting creator’s virtual room. The 
virtual room configured for this user on Cisco Unified Videoconferencing Manager will be used.

Step 6 Enter the meeting prefix for the Cisco Unified Videoconferencing Desktop Server to use for the Sametime meetings.

Step 7 If necessary, set the number of video panes displayed in the Conference Client pane when it is opened in the Sametime 
Meeting Room window:

a. Select Set the initial view that users will see when they join a Sametime meeting.

b. Select one of these options:

 – 1 Video

 – 2 Videos

Step 8 If necessary, select Enable Audio in Desktop for Sametime meetings.

Step 9 If necessary, select Allow only the Sametime Meeting Chair to add video to a meeting. This allows a Sametime Meeting 
chair to control when the video pane is displayed in the user's meeting room client.

Note This feature in not available if the Cisco Unified Videoconferencing Connector is configured to work with the 
Sametime Server version 7.5.1.

Step 10 If necessary, select Allow only the Sametime Meeting Chair to moderate a meeting. This determines whether audio and 
video moderation functions are enabled only a Sametime Meeting chair or for all participants in a Desktop meeting.
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Step 11 Select OK or Apply.

Step 12 Verify that the connection to the Sametime Server is successful:

a. Select Status in the sidebar.

b. Select the link showing the IP address of the Sametime Server to display the settings.

The indicator next to the link shows whether or not the connection to the Sametime server is successful. When the 
indicator is red, a tooltip containing error details is available. Select the red indicator to view further error 
information.

4  Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional information, see the 
monthly What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be 
delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS version 
2.0. 
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