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Chapter 4      Using the DCNM Client
Working with Statistics and Charts
Information about Statistics and Charts
You can use a Statistics tab to start and stop statistical monitoring for an object and to work with charts 
of statistical data about the selected object. For each chart, the client also provides overview charts, 
which allow you to see historical trends and to control the time scale of the standard chart.

When you start monitoring for a new chart, DCNM creates a new statistical collection process that 
appears in the Statistical Data Collection feature. For more information, see the “Administering 
Statistical Data Collection” section on page 9-37.

Licensing Requirements for Statistics and Charts
The following table shows the licensing requirements for this feature:

Accessing a Chart
You can access any chart. The charts that are available for a particular Statistics tab depend upon the 
feature and object selected.

DETAILED STEPS

To access a chart, follow these steps:

Step 1 From the Feature Selector pane, choose the feature for which you want to use a statistical chart.

For example, choose Interfaces > Physical > Ethernet.

Step 2 From the Summary pane, select an object.

The Statistics tab appears in the Details pane. In the Statistics tab, one or more charts may appear.

Note If no Statistics tab appears, then DCNM does not provide a statistical chart for the object that 
you selected.

Step 3 If the chart for the data that you want to monitor does not appear, from the toolbar, choose New Chart 
and then choose the chart that you want.

Step 4 Click the title bar of the chart that you want to work with.

Product License Requirement

DCNM Real-time monitoring requires no license.

DCNM requires a LAN Enterprise license for the following features:

 • Maintaining a history of statistical data

 • Using overview charts

For a complete explanation of the DCNM licensing scheme and how to obtain and apply licenses, see the 
Cisco DCNM Licensing Guide.
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Chapter 4      Using the DCNM Client
Working with Statistics and Charts
Step 2 From the Monitor toolbar choose the  icon.

Note If the chart you want to stop does not appear, use the Statistical Data Collection feature to stop 
the collection process. For more information, see the “Starting Statistical Monitoring for a 
Chart” section on page 4-11.

Using a Chart
The client provides the following options for using a chart:

 • Changing parameters

 • Setting the charting frequency

 • Controlling the magnification of the chart data

 • Showing, moving, and hiding threshold lines

 • Tearing the chart away from the client window

This procedure provides basic instructions for using each of these options.

Note For information about using an overview chart, see the “Using an Overview Chart” section on page 4-13.

DETAILED STEPS

To use a chart, follow these steps:

Step 1 Access the chart that you want to use. For more information, see the “Accessing a Chart” section on 
page 4-10.

Step 2 If the chart is not active, you must start statistical monitoring for the chart before you can use it. For 
more information, see the “Starting Statistical Monitoring for a Chart” section on page 4-11.

Step 3 (Optional) To change parameters, click Select Parameters, check the statistics parameters that you want 
to collect, and click Select Parameters again.

Step 4 (Optional) To set the frequency with which DCNM retrieves statistical data for the selected object, from 
the Select Frequency drop-down list on the Monitor tool bar, choose the new frequency.

Step 5 Optional) To control the magnification, or zoom, of the chart, do one of the following:

 • To zoom in on a portion of the chart, position the mouse pointer at one end of the portion, click and 
hold the left mouse button, drag the mouse pointer to the other end of the portion, and release the 
mouse button.

 • To zoom in on a portion of the chart, position the mouse pointer at one end of the portion and then 
click and drag the mouse pointer to the other end of the portion.

 • To change to the previous zoom, click the  icon.

 • To change to the next zoom, click the  icon.

 • To reset the zoom to the default magnification, click the  icon.

Step 6 (Optional) To show, move, or hide threshold lines, do one of the following:
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Working with Statistics and Charts
 • To show or hide threshold lines, on the Monitor tool bar, click the  icon.

 • To move the lower threshold line, click and drag the  icon.

 • To move the lower threshold line, click and drag the  icon.

Step 7 (Optional) To tear the chart away from the DCNM client window, click on the red line that appears below 
the chart title.

Using an Overview Chart
You can use an overview chart to view the historical trend of the statistical data of the current chart and 
to set the time scale of the standard chart.

BEFORE YOU BEGIN

Overview charts are a licensed feature. For more information, see the “Licensing Requirements for 
Statistics and Charts” section on page 4-10.

DETAILED STEPS

To use an overview chart, follow these steps:

Step 1 Access the chart that contains the overview chart that you want to use. For more information, see the 
“Accessing a Chart” section on page 4-10.

Step 2 If the chart is not active, you must start statistical monitoring for the chart before you can use its 
overview chart. For more information, see the “Starting Statistical Monitoring for a Chart” section on 
page 4-11.

Step 3 Click Show Overview Chart.

In a new window, the overview chart displays the historical trends of the charted data.

Step 4 To set the time scale of the chart, at the bottom of the overview chart window, click the desired time scale 
button. The time scale buttons are as follows:

 • RT—Real time

 • 1d—One day

 • 2d—Two days

 • 5d—Five days

 • 15d—Fifteen days

 • 1m—One month

 • 3m—Three months

Step 5 To close the overview chart, click Show Overview Chart again.
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Exporting a Chart
You can export a chart as an JPG image or as a comma-separated value (CSV) file.

When you export a chart as a JPG image, the image is of the chart as it appears when you export the 
image.

When you export a chart as a CSV file, the file contains all data from the statistical collection for the 
chart.

DETAILED STEPS

To export an image of a chart, follow these steps:

Step 1 Access the chart that you want to use. For more information, see the “Accessing a Chart” section on 
page 4-10.

Step 2 If the chart is not active, you must start statistical monitoring for the chart before you can export an 
image of it. For more information, see the “Starting Statistical Monitoring for a Chart” section on 
page 4-11.

Step 3 If you want to export an image, configure the chart to show the data that you want to appear in the image. 
For more information, see the “Using a Chart” section on page 4-12.

Step 4 Right-click on the chart.

Step 5 Choose one of the following:

 • Export as CSV

 • Export as JPG

Step 6 Specify the location and filename, and then click Save.

The client exports the chart in the file format that you specified.

Configuring Global Preferences
Using the Global Preferences dialog box, you can configure several preferences for how the DCNM 
client displays data and fields. The four sections on the Global Preferences are as follows:

 • Monitoring—Controls the default frequency of statistical data retrieval from managed devices. For 
more information, see the “Configuring the Default Frequency of Statistical Data Retrieval” section 
on page 4-15.

 • Events—Controls the maximum age of events that the DCNM client fetches from the DCNM server 
when you start the client. For more information, see the “Configuring the Maximum Age of Events 
Fetched from the Server” section on page 4-15.

 • Administration—Controls how frequently the DCNM server fetches accounting and system logs 
from managed devices. To configure this setting, see the “Configuring the Polling Frequency for 
Accounting and System Logs” section on page 4-16.

 • Pre Provision—Controls whether the DCNM client displays some settings only when other settings 
are made or whether the client always displays all settings. For more information, see the 
“Configuring Preprovisioning” section on page 4-16.
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Configuring the Default Frequency of Statistical Data Retrieval
You can configure the default frequency for statistical data retrieval from monitored devices. The default 
frequency for statistical data retrieval is 30 seconds. This frequency determines the initial data retrieval 
frequency for a new chart. Users can override the default frequency by configuring the chart-specific 
setting.

BEFORE YOU BEGIN

Determine how often you want DCNM to retrieve statistical data by default. Consider how important it 
is to your organization that charts update frequently. If very current charting data is important to your 
organization, consider using a short data retrieval frequency.

DETAILED STEPS

To configure the default frequency of statistical data retrieval, follow these steps:

Step 1 From the menu bar, choose Tools > Preferences.

The Global Preferences dialog box appears. Under Monitoring, the Default Monitoring Frequency 
drop-down list displays the current frequency for statistical data retrieval.

The default polling frequency is 30 seconds.

Step 2 From the Default Monitoring Frequency drop-down list, choose the new data retrieval frequency.

Step 3 Click Ok.

Configuring the Maximum Age of Events Fetched from the Server
You can configure the maximum age of events that the DCNM client fetches from the DCNM server 
when you start the client. This setting affects how old the events are that the client displays in the Event 
Browser and on feature-specific Events tabs. By default, the client fetches events that occurred up to 1 
hour prior to the client startup. You can configure the client to fetch events that are up to 24 hours old.

DETAILED STEPS

To configure the maximum age of events that the client fetches from the server, follow these steps:

Step 1 From the menu bar, choose Tools > Preferences.

The Global Preferences dialog box appears. Under Events, the Fetch events before drop-down list 
displays the current maximum age of events.

Step 2 From the Fetch events before drop-down list, choose the new maximum age of events.

Note To prevent the client from fetching any old events, choose zero (0) hours as the maximum age 
of events. When you choose zero hours, the client shows only the events that the DCNM server 
receives after you start the client.
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Step 3 Click Ok.

Configuring the Polling Frequency for Accounting and System Logs
You can configure how frequently the DCNM server fetches accounting and system logs from managed 
devices. This setting affects how frequently the Topology feature in the DCNM client is updated with 
changes to the topology.

DETAILED STEPS

To configure the polling frequency for accounting and system logs, follow these steps:

Step 1 From the menu bar, choose Tools > Preferences.

The Global Preferences dialog box appears. Under Administration, the Polling Frequency for 
Accounting and System Log drop-down list displays the current polling frequency.

The default polling frequency is 1 minute.

Step 2 From the Polling Frequency for Accounting and System Log drop-down list, choose the new polling 
frequency.

Step 3 Click Ok.

Configuring Preprovisioning
Preprovisioning refers to configuring a managed device with settings for modes or protocols that are not 
enabled. The preprovisioning preference affects the following sections of the DCNM client interface:

 • Interfaces > Physical > Ethernet > Device > Slot > Interface, Port Details tab, Port Mode Settings 
section

When you enable preprovisioning, the client displays all port mode fields regardless of the setting 
in the Mode drop-down list. When you disable preprovisioning, the client displays only the port 
mode settings that are relevant to the currently selected port mode. For example, if preprovisioning 
is disabled and you choose Trunk from the Mode drop-down list, the client displays only the Trunk 
settings and hides the Access, PVLAN Host, and PVLAN Promiscuous fields.

Additionally, the dialog boxes for configuring the Access VLAN field and the Native VLAN field 
include the Create in the Device check box. When you enable preprovisioning, you can uncheck this 
check box if you want DCNM to configure the device to refer to a VLAN that is not currently 
configured. When you disable preprovisioning, this check box is always checked and DCNM creates 
the VLAN specified, if it does not already exist.

 • Switching > Spanning Tree > Device, Configuration tab, Global Settings section

When you enable preprovisioning, the client displays MST settings regardless of the settings in the 
Protocol drop-down list. When you disable preprovisioning, the client displays the MST Setting 
fields unless you choose MST from the Protocol drop-down list.
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DETAILED STEPS

To configure preprovisioning, follow these steps:

Step 1 From the menu bar, choose Tools > Preferences.

The Global Preferences dialog box appears. Under Pre Provision, the Pre Provision check box appears.

Step 2 Do one of the following:

 • If you want to enable preprovisioning, ensure that the Pre Provision check box is checked.

 • If you want to disable preprovisioning, ensure that the Pre Provision check box is unchecked.

Step 3 Click Ok.

Using Online Help
To access the welcome page in online help, from the menu bar, choose Help > Help Contents.

DCNM online help includes context-sensitive help. To access context-sensitive help for a feature, follow 
these steps:

1. Select a specific feature from the Feature Selector pane in the DCNM client. For example, choose 
Security > Access Control > IPv4 ACL.

2. Do one of the following:

 – Press F1.

 – From the toolbar, click the question mark icon.

Online help for the selected feature appears in a browser window. DCNM uses the default browser 
application on the computer that runs the DCNM client.

Online help has the following features:

 • Contents—The organization of DCNM online help is shown in the Contents tab of the online help 
window. When a topic has subtopics, the book icon appears to the left of the topic in the contents.

You can expand and collapse individual topics in the contents. You can also collapse or expand all 
topics.

 • Index—DCNM online help includes an index, which allows you to look up subjects alphabetically 
and open related topics directly from the index.

 • Favorites—DCNM online help allows you to add specific topics to the Favorites tab. Favorites are 
stored locally on the computer that you use to access online help.
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Working with Inventory

The Inventory feature displays information about the chassis, modules, fan trays, and power supplies for 
managed devices. DCNM can display summary and detailed information for these device components. 

The following sections describe how to display inventory information:

 • Displaying the Chassis Information, page 5-1

 • Displaying the Module Information, page 5-5

 • Displaying the Power Supply Information, page 5-7

 • Displaying the Fan Tray Information, page 5-9

Displaying the Chassis Information
DCNM displays summary, detail, environmental, and event information for the chassis.

RELATED TOPICS

 • Displaying the Chassis Summary Information, page 5-1

 • Displaying the Chassis Detail information, page 5-2

 • Displaying the Chassis Environmental Status, page 5-2

 • Displaying the Chassis CPU Utilization, page 5-2

 • Displaying the Chassis Memory Utilization, page 5-3

 • Displaying the Chassis Events, page 5-4

Displaying the Chassis Summary Information
DCNM displays the chassis summary information for each device it manages when you choose Inventory 
in the Feature Selector pane. The summary information includes the chassis description, product ID, 
serial number, hardware version, software version, status, temperature, and events.

DETAILED STEPS

To display the summary information for a chassis, from the Feature Selector pane, choose Inventory. 
The summary pane displays summary information for each managed device.
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Displaying the Chassis Detail information
DCNM displays the chassis detail information for the device that you choose in the Summary pane. This 
detail information includes hardware and software information. The hardware information includes the 
switch name, product ID, IP address, serial number, chassis description.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Inventory. 

Summary chassis information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Tabs appear in the Details pane. The Details tab shows the hardware and software information.

Displaying the Chassis Environmental Status
DCNM displays the chassis environmental status information for the device that you choose in the 
Summary pane. The environmental information includes power usage information and information about 
supervisor and power supply redundancy.

DETAILED STEPS

To display the environmental status for a chassis, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Tabs appear in the Details pane.

Step 3 From the Details pane, click the Environmental Status tab.

Power usage and redundancy information appears in the Details pane.

Displaying the Chassis CPU Utilization
DCNM displays the percentage of CPU utilization over time for the device that you choose in the 
Summary pane. You can customize the reporting of this utilization for types of utilization (user, kernel, 
or idle), specific thresholds, and time intervals. 
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DETAILED STEPS

To display the CPU utilization, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary information for each managed device appears in the Summary pane.

Step 2 From the summary pane, click the device.

Tabs appear in the Details pane.

Step 3 From the Details pane, click the CPU Utilization tab.

The CPU utilization table appears.

Step 4 (Optional) To display the percentage of utilization devoted to user or kernel functions, follow these steps:

a. Click Select Parameters.

A list of utilization types (user, kernel, and idle) appears.

b. Choose the utilization types that you need to see reported.

Step 5 (Optional) To display utilization within specific thresholds, follow these steps:

a. Click the Turn Thresholds On/Off tool.

The Adjust Threshold Limits slider tool appears on the toolbar next to the Turn Thresholds On/Off 
tool.

b. To set a minimum CPU utilization threshold, move the left slider to the desired utilization.

c. To set a maximum CPU utilization threshold, move the right slider to the desired utilization.

Step 6 (Optional) To change the monitoring frequency, follow these steps:

a. Click in the Select Frequency tool drop-down list.

Time intervals appear for you to choose.

b. Choose the appropriate time interval.

Step 7 Click the Start Monitoring tool to begin monitoring CPU utilization.

Step 8 (Optional) To stop monitoring the CPU utilization, click the Stop Monitoring tool.

Step 9 (Optional) To display how the CPU utilization compares over days or months, follow these steps:

a. Click Show Overview Chart.

b. (Optional) To see the latest or real-time utilization data, click RT.

c. (Optional) To compare utilization data over days or months, click the appropriate button for the 
amount of time desired (1d shows one day, 2d shows two days, and so on).

Displaying the Chassis Memory Utilization
DCNM displays the percentage of memory utilization over time for the device that you choose in the 
Summary pane. You can customize the reporting of this utilization for specific thresholds and time 
intervals. 
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DETAILED STEPS

To display the memory utilization, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Tabs appear in the Details pane.

Step 3 From the Details pane, click the Memory Utilization tab.

The Memory Utilization table appears.

Step 4 (Optional) To display utilization within specific thresholds, follow these steps:

a. Click the Turn Thresholds On/Off tool.

The Adjust Threshold Limits slider tool appears on the toolbar next to the Turn Thresholds On/Off 
tool.

b. To set a minimum utilization threshold, move the left slider to the desired utilization.

c. To set a maximum utilization threshold, move the right slider to the desired utilization.

Step 5 (Optional) To change the monitoring frequency, follow these steps:

a. Click in the Select Frequency tool drop-down list.

Time intervals appear for you to choose.

b. Choose the appropriate time interval.

Step 6 Click the Start Monitoring tool to begin monitoring utilization.

Step 7 (Optional) To stop monitoring the utilization, click the Stop Monitoring tool.

Step 8 (Optional) To display how the utilization compares over days or months, follow these steps:

a. Click Show Overview Chart.

b. (Optional) To see the latest or real-time utilization data, click RT.

c. (Optional To compare utilization data over days or months, click the appropriate button for the 
amount of time desired (1d shows one day, 2d shows two days, and so on).

Displaying the Chassis Events
DCNM displays the chassis events, which includes the source, time, severity, message, and status of the 
event. You can display additional details for an event.

DETAILED STEPS

To display the chassis events, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary information for each managed device appears in the Summary pane.
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Step 2 From the Summary pane, click the device.

Tabs appear in the Details pane.

Step 3 From the Details pane, click the Memory Utilization tab.

The Memory Utilization table appears.

Step 4 (Optional) To see details for the event, select the event in the Details pane and click the up arrow at the 
bottom of the details pane.

Displaying the Module Information
DCNM displays summary, detail, environmental, and event information for the supervisor modules, I/O 
modules, and fabric modules.

RELATED TOPICS

 • Displaying the Module Summary Information, page 5-5

 • Displaying the Module Detail Information, page 5-5

 • Displaying the Module Environmental Status, page 5-6

 • Displaying the Module Events, page 5-7

Displaying the Module Summary Information
DCNM displays the module summary information for each device it manages when you expand the 
device listing in the Summary pane. The summary information includes the module description, product 
ID, serial number, hardware version, software version, status, temperature, and events.

DETAILED STEPS

To display the summary information for a module, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Chassis summary information for the device appears in the Summary pane.

Step 2 From the Summary pane, expand the device with the modules that you are interested in viewing.

A list of modules, power supplies, and fan trays appears under the device in the Summary pane. Each 
line includes summary information for the component.

Displaying the Module Detail Information
DCNM displays the module detail information for the device that you choose in the Summary pane. This 
detail information includes general identification information and special information that applies the 
the module type.
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DETAILED STEPS

To display module detail information, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary chassis information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Step 3 Expand the device.

The device listing expands to include a summary of each module, power supply, and fan tray in the 
chassis.

Step 4 Click the module.

Tabs appear in the Details pane. General details appear in the Details tab.

Displaying the Module Environmental Status
DCNM displays the module environmental status information for the supervisor module, I/O module, or 
fabric module that you choose in the Summary pane. The environmental information includes power 
usage and temperature information.

DETAILED STEPS

To display the environmental status for a module, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary chassis information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Step 3 Expand the device.

The device listing expands to include a summary of each module, power supply, and fan tray in the 
chassis.

Step 4 Click the module.

Step 5 From the Details pane, click the Environmental Status tab.

Power supply and temperature sections appear in the Details pane. The Power Supply section is 
expanded and the two temperature sections are not expanded

Step 6 (Optional) To see textual temperature information, expand the Temperature Status Table section.

Step 7 (Optional) To see graphical temperature information, expand the Temperature Status Thermometer 
section.
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Displaying the Module Events
DCNM displays the module event information for the supervisor module, I/O module, or fabric module 
that you choose in the Summary pane. The events information includes source, time, severity, message, 
and status information for the event. You can display details for each event.

DETAILED STEPS

To display the events for a module, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary chassis information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Step 3 Expand the device.

The device listing expands to include a summary listing of each module, power supply, and fan tray in 
the chassis.

Step 4 Click the module.

Step 5 From the Details pane, click the Events tab.

An events listing appears in the Details pane.

Step 6 (Optional) To see details for an event, click on the event and click the up arrow button at the bottom of 
the pane.

Displaying the Power Supply Information
DCNM displays summary information, general details, and events for power supplies.

RELATED TOPICS

 • Displaying the Power Supply Summary Information, page 5-7

 • Displaying the Power Supply Detail Information, page 5-8

 • Displaying the Power Supply Events, page 5-8

Displaying the Power Supply Summary Information
DCNM displays the power supply summary information for each device it manages when you expand 
the device listing in the Summary pane. The summary information includes the module description, 
product ID, serial number, hardware version, software version, status, temperature, and events.
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DETAILED STEPS

To display the summary information for a power supply, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Chassis summary information for the device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Step 3 Expand the device with the modules that you are interested in viewing.

A list of modules, power supplies, and fan trays appears under the device in the Summary pane. Each 
line includes summary information for the component.

Displaying the Power Supply Detail Information
DCNM displays the power supply detail information for the device that you choose in the Summary 
pane. This detail information includes general identification information, power (watts), and current 
(Amps).

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Inventory. 

Summary chassis information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Step 3 Expand the device.

The device listing expands to include a summary of each module, power supply, and fan tray in the 
chassis.

Step 4 Click the power supply.

Tabs appear in the Details pane. General details appear in the Details tab.

Displaying the Power Supply Events
DCNM displays the event information for the power supply that you choose in the Summary pane. The 
events information includes source, time, severity, message, and status information for the events. You 
can display details for each event.

DETAILED STEPS

To display the events for a power supply, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary chassis information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.
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Step 3 Expand the device.

The device listing expands to include a summary listing of each module, power supply, and fan tray in 
the chassis.

Step 4 Click the power supply.

Step 5 From the Details pane, click the Events tab.

An events listing appears in the Details pane.

Step 6 (Optional) To see details for an event, click on the event and click the up arrow button at the bottom of 
the pane.

A field opens to display detailed event information.

Displaying the Fan Tray Information
DCNM displays summary information, general details, and events for fan trays.

RELATED TOPICS

 • Displaying the Fan Tray Summary Information, page 5-9

 • Displaying the Fan Tray Detail Information, page 5-10

 • Displaying the Fan Tray Events, page 5-10

Displaying the Fan Tray Summary Information
DCNM displays the fan tray summary information for each device it manages when you expand the 
device listing in the Summary pane. The summary information includes the fan identification and status 
information.

DETAILED STEPS

To display the summary information for a fan tray, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Chassis summary information for the device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Step 3 Expand the device with the fan tray that you are interested in viewing.

A list of modules, power supplies, and fan trays appears under the device in the Summary pane. Each 
line includes summary information for the component.
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Displaying the Fan Tray Detail Information
DCNM displays the fan tray detail information for the device that you choose in the Summary pane. This 
detail information includes descriptive information and status for the fan tray.

DETAILED STEPS

Step 1 From the Feature Selector pane, choose Inventory. 

Summary chassis information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Step 3 Expand the device.

The device listing expands to include a summary of each module, power supply, and fan tray in the 
chassis.

Step 4 Click the fan tray.

Tabs appear in the Details pane. General details appear in the Details tab.

Displaying the Fan Tray Events
DCNM displays the event information for the fan tray that you choose in the Summary pane. The events 
information includes source, time, severity, message, and status information for the event. You can 
display details for each event.

DETAILED STEPS

To display the events for a fan tray, follow these steps:

Step 1 From the Feature Selector pane, choose Inventory. 

Summary chassis information for each managed device appears in the Summary pane.

Step 2 From the Summary pane, click the device.

Step 3 Expand the device.

The device listing expands to include a summary listing of each module, power supply, and fan tray in 
the chassis.

Step 4 Click the fan tray.

Step 5 From the Details pane, click the Events tab.

An events listing appears in the Details pane.

Step 6 (Optional) To see details for an event, click on the event and click the up arrow button at the bottom of 
the pane.
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Working with Topology

This chapter describes how to use the Topology feature in Cisco Data Center Network Manager 
(DCNM).

This chapter includes the following topics:

 • Information About Topology, page 6-1

 • Licensing Requirements for Topology, page 6-2

 • Prerequisites for Topology, page 6-2

 • Guidelines and Limitations, page 6-2

 • Using the Topology Feature, page 6-3

 • Field Descriptions for Topology, page 6-9

 • Related Documents, page 6-9

Information About Topology
The Topology feature provides you with a topology map of the Cisco Nexus 7000 series devices and 
switches that run Cisco IOS software, such as the Catalyst 6500 series switches, that are linked by the 
Cisco Discovery Protocol (CDP). For Nexus devices, the map shows details about Virtual Device 
Contexts (VDCs).

When Cisco Data Center Network Manager (DCNM) receives new information, the DCNM client 
updates the map dynamically. By default, updates occur once a minute. You can see changes occur to the 
status of links and devices, such as links going down or VDC creation, deletion, or modification. 

Because the map is always current, you can use it to troubleshoot ongoing network management issues.

You can modify and save the layout of device icons. The map also provides you quick access to 
configuring features for a managed device.
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Licensing Requirements for Topology
The following table shows the licensing requirements for this feature:

Prerequisites for Topology
Topology has the following prerequisites:

 • You should be familiar with the following:

 – Cisco NX-OS

 – Virtual Device Contexts (VDCs)

 – Cisco Nexus 7000 Series

 – Cisco Discovery Protocol (CDP)

 • On devices shown in the topology map, CDP should be enabled both globally and specifically on 
interfaces used for device discovery.

Guidelines and Limitations
Topology has the following configuration guidelines and limitations:

 • While the Topology feature is an unlicensed feature, you must have a LAN Enterprise license to 
manage non-default VDCs that appears in the topology.

 • The Topology feature displays changes to the topology periodically as determined by the polling 
frequency for accounting and system logs. By default, the polling frequency is one minute.

Product License Requirement

DCNM Topology requires no license. Any feature not included in a license package is bundled with the Cisco 
DCNM and is provided at no charge to you. For a complete explanation of the DCNM licensing scheme, see 
the Cisco DCNM Licensing Guide.
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Using the Topology Feature
Figure 6-1 shows the Topology Contents pane.

Figure 6-1 Topology Contents pane

This section includes the following topics:

 • Viewing the Topology Map, page 6-3

 • Showing and Hiding Other Views, page 6-4

 • Accessing Other DCNM Features from the Topology Map, page 6-5

 • Moving Devices in the Topology Map, page 6-6

 • Reloading the Previous Layout, page 6-7

 • Exporting the Topology as a JPG Image, page 6-7

 • Configuring the Polling Frequency for Accounting and System Logs, page 6-8

Viewing the Topology Map
You can view the topology map. The DCNM client also provides you with tools to zoom and pan the 
map.

The map shows Nexus 7000 series devices, switches that run Cisco IOS software, and CDP links 
between devices. The link colors have the following meanings:

 • Dark gray—The physical link between the two devices is active.

 • Light gray—One of the devices is not reachable.
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 • Red—All physical links between the two devices are down.

The map also indicates whether a link is a single port link or a multiple port link, as follows:

 • Single port link—When one link connects two devices, the map connects the two devices with a thin 
line. The port icon at either end of the line shows a single port.

 • Multiple port link—When more than one link connect two devices, the map connects the two devices 
with a thick line. The port icon at either end of the line shows two ports.

DETAILED STEPS

To view the topology, follow these steps:

Step 1 From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the 
topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly 
for the name of the icon to appear.

Step 2 If you want to move, or pan, the map, from the topology toolbar, click the  icon, and then click 
anywhere on the topology map, hold down the mouse button, drag the map in any direction, and release 
the mouse button.

Step 3 If you want to control the magnification, or zoom, of the view, do one of the following:

 • To zoom to a specific portion of the map, from the topology toolbar, click the  icon, then click 
on the map and drag a rectangle over the area that you want to see, and release the mouse button.

 • To zoom in, from the topology toolbar, click the  icon.

 • To zoom out, from the topology toolbar, click the  icon.

 • To fit the entire topology map in the Contents pane, click the  icon.

 • To reset the zoom to the default magnification, click the  icon.

Step 4 If you want to show or hide VDCs in all Nexus devices, right-click on a blank part of the map and choose 
Show All VDCs or Hide All VDC, as desired.

Step 5 If you want to show or hide the VDCs in a single Nexus device, right-click on a Nexus device icon and 
choose Show VDC or Hide VDC, as desired.

Showing and Hiding Other Views
You can show or hide the following three additional views of the topology:

 • Topology tree

 • Device properties

 • Device overview

You can toggle between showing and hiding each of these views by clicking to select or clicking to clear 
the topology toolbar icon for the view.
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DETAILED STEPS

To show or hide other views, follow these steps:

Step 1 From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the 
topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly 
for the name of the icon to appear.

Step 2 If you want to show or hide the topology tree, click the  icon.

The Topology Tree pane appears between the topology toolbar and map.

Step 3 If you want to show or hide device properties, click the  icon.

The Device Properties pane appears between the topology toolbar and map.

Step 4 If you want to show or hide the device overview, click the  icon.

The Device Overview pane appears between the topology toolbar and map.

Accessing Other DCNM Features from the Topology Map
You can use the topology map to access DCNM features for managed devices. The feature or feature 
groups that you can access are as follows:

 • Inventory

 • VDCs

 • Interfaces

 • Switching

 • Security

You can also use the topology map to access the Device Discovery feature.

DETAILED STEPS

To access a feature from the topology map, follow these steps:

Step 1 From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the 
topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly 
for the name of the icon to appear.
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Step 2 To access a DCNM feature for a specific managed device, do the following:

a. Find the device in the topology map. For more assistance, see the “Viewing the Topology Map” 
section on page 6-3.

b. Right-click the device and choose the feature that you want to configure.

The feature that you selected appears in the Contents pane. The device that you selected on the 
topology map is selected in the Summary table for the feature.

c. (Optional) If you want to view context-sensitive help with the selected feature, press F1.

Step 3 (Optional) To access the Device Discovery feature, right-click a blank area on the map and choose 
Discover Device.

The Device Discovery feature appears in the Contents pane.

Moving Devices in the Topology Map
You can move device icons that are shown in the topology map.

You can also save the layout, which you can reload later if you make additional changes and want to 
revert to your last save. For more information, see the “Reloading the Previous Layout” section on 
page 6-7.

The saved layout becomes the default layout that you see in the topology map when you start the DCNM 
client.

Note The DCNM client saves topology layouts as local user data on the computer that runs the client. When 
you are using the DCNM client, you do not have access to topology layouts that you saved on other 
computers or that you saved while logged in to the computer under a different username.

DETAILED STEPS

To move devices in the topology map, follow these steps:

Step 1 From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the 
topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly 
for the name of the icon to appear.

Step 2 From the topology toolbar, choose the  icon.

Step 3 Find and move device icons as needed. To move an icon, click on the device icon, hold down the mouse 
button, drag the icon to the new location, and release the mouse button.
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You can zoom and pan as needed to find icons. For more information, see the “Viewing the Topology 
Map” section on page 6-3.

Step 4 (Optional) If you want to save the changes to the device icon layout, click the  icon.

Reloading the Previous Layout
You can load the most recent saved layout. This feature allows you to undo changes to device 
arrangement that you have made since you last saved the layout.

Note The DCNM client saves topology layouts as local user data on the computer that runs the client. When 
you are using the DCNM client, you do not have access to topology layouts that you saved on other 
computers or that you saved while logged in to the computer under a different username.

DETAILED STEPS

To save the topology layout, follow these steps:

Step 1 From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the 
topology map.

Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly 
for the name of the icon to appear.

Step 2 From the topology toolbar, choose the  icon.

The topology map changes to the most recent layout that you saved.

Exporting the Topology as a JPG Image
You can export, or save, a JPG image of the topology map. The JPG image created shows only the portion 
of the topology that appears in the DCNM client at the moment that you save the JPG file.

DETAILED STEPS

To export the visible portion of the topology map as a JPG image, follow these steps:

Step 1 From the Feature Selector pane, choose Topology > Topology View.

The topology map appears in the Contents pane. The topology toolbar appears on the left side of the 
topology map.
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Note To see the names of topology toolbar icons, move the mouse pointer to the icon and wait briefly 
for the name of the icon to appear.

Step 2 View the portion of the topology map that you want to save. For more information, see the “Viewing the 
Topology Map” section on page 6-3.

Step 3 Arrange the device icons as desired. For more information, see the “Moving Devices in the Topology 
Map” section on page 6-6.

Step 4 From the topology toolbar, click the  icon.

A dialog box appears.

Step 5 Specify the location and filename of the JPG image and click Save.

The JPG image of the visible portion of the topology map is saved.

Configuring the Polling Frequency for Accounting and System Logs
You can configure how frequently the DCNM server fetches accounting and system logs from managed 
devices. This setting affects how frequently the Topology feature in the DCNM client is updated with 
changes to the topology.

DETAILED STEPS

To configure the polling frequency for accounting and system logs, follow these steps:

Step 1 From the menu bar, choose Tools > Preferences.

The Global Preferences dialog box appears. Under Administration, the Polling Frequency for 
Accounting and System Log drop-down list displays the current polling frequency.

The default polling frequency is one minute.

Step 2 From the Polling Frequency for Accounting and System Log drop-down list, choose the new polling 
frequency.

Step 3 Click Ok.
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Field Descriptions for Topology
This section includes the following field descriptions for Topology:

 • Topology Toolbar, page 6-9

Topology Toolbar

Related Documents
For additional information related to implementing Topology, see the following sections:

Table 6-1 Topology Toolbar 

Field Description

Pan Allows you to click and drag the topology map.

Select Allows you to select network devices.

Zoom in Rect Magnifies the topology map to the area that you identify by clicking and 
dragging the mouse pointer on the topology map.

Zoom In Magnifies the topology map.

Zoom Out Reduces the topology map.

Fit to View Magnifies or reduces the entire topology map so that it fits in the Contents 
pane.

Reset Zoom Changes the magnification of the topology map to the default level.

Hide/Show Overview Hides or shows the overview pane.

Reload Previous Layout Reloads the most recent saved topology layout.

Save Layout Saves the layout of the network devices in the topology map.

Hide/Show Topology 
Tree

Hides or shows the topology tree pane.

Hide/Show Properties Hides or shows the properties pane.

Export as JPG Exports the visible portion of the topology map as a JPG image file.

Related Topic Document Title

VDCs Cisco DCNM Virtual Device Context Configuration Guide

Cisco Nexus 7000 series devices Cisco Nexus 7000 Series Hardware Installation and Reference 
Guide

Device discovery Administering Device Discovery, page 9-1
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Managing Events

This chapter describes how to use the Event Browser and feature-specific Events tabs in Cisco Data 
Center Network Manager (DCNM).

This chapter includes the following topics:

 • Information About Events, page 7-1

 • Licensing Requirements for the Events Browser, page 7-2

 • Prerequisites for Events, page 7-2

 • Guidelines and Limitations, page 7-2

 • Using the Event Browser and Events Tabs, page 7-3

 • Field Descriptions for Events, page 7-8

 • Related Documents, page 7-10

Information About Events
DCNM allows you to view and manage recent status events. An event can be either of the following:

 • A status-related system message that DCNM retrieves from managed devices. For more information, 
see the “Logfile Requirements” section on page 1-7.

 • A message generated by the DCNM server.

The DCNM client includes the Event Browser and feature-specific Events tabs that appears in the Details 
pane for features that can have events. The Events Browser shows all recent status events while a 
feature-specific Events tab shows recent status events that pertain to the feature. The client updates the 
Event Browser and Events tabs dynamically when it receives new events from the server.

In the Events Browser and on Events tabs, you can change the status of an event, add notes to an event, 
or delete an event.

In addition, the Event Browser provides a pie chart and a bar chart of events separated by the event 
severity. You can also delete old events from the events database.

To control the minimum severity of event messages, you configure the logging level for NX-OS features 
and for DCNM server features. For more information, see the “NX-OS System-Message Logging 
Requirements” section on page 1-6.
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Note DCNM has minimum logging level requirements for managed NX-OS devices. Logging levels on a 
managed device should never be lower than the minimum requirements.

For more information about DCNM server logging levels, see the “Administering DCNM Server Log 
Settings” section on page 9-43.

Note Configuring DCNM server log settings does not affect logging levels on managed NX-OS devices.

Licensing Requirements for the Events Browser
The following table shows the licensing requirements for this feature:

Prerequisites for Events
The Event Browser has the following prerequisites:

 • You should be familiar with NX-OS system messages.

 • Managed NX-OS devices must be configured to send system messages to the DCNM server.

Guidelines and Limitations
The Event Browser has the following configuration guidelines and limitations:

 • The Event Browser and feature-specific Events tabs display only status events, which are events 
generated when the status of a feature or object changes. For example, configuration events do not 
appear in the Events Browser or on an Events tab.

 • The Event Browser can display event messages that are no older than 24 hours when you start the 
DCNM client. By default, the client fetches from the server messages that are no older than 1 hour.

 • The Events Browser can display up to 5000 events. The events database is limited by the amount of 
space available to the database.

 • You cannot use DCNM to control the logging levels of managed NX-OS devices. For more 
information, see the “NX-OS System-Message Logging Requirements” section on page 1-6.

 • We recommend that you delete events that you no longer need or that you have resolved. For 
information about deleting old events from the events database, see the “Deleting Data from the 
Events Database” section on page 9-35.

Product License Requirement

DCNM The Event Browser requires no license. Any feature not included in a license package is bundled with the 
Cisco DCNM and is provided at no charge to you. For a complete explanation of the DCNM licensing 
scheme, see the Cisco DCNM Licensing Guide.
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Using the Event Browser and Events Tabs
Figure 7-1 shows the Event Browser content pane.

Figure 7-1 Event Browser Content Pane

This section includes the following topics:

 • Viewing Events in the Events Browser, page 7-3

 • Applying and Removing an Event Filter, page 7-4

 • Viewing Events on an Events Tab, page 7-5

 • Changing the Status of an Event, page 7-6

 • Adding a Note to One or More Events, page 7-7

 • Deleting an Event, page 7-7

Viewing Events in the Events Browser
You can use the Event Browser to view recent events. By default, the Event Browser shows events that 
occurred up to 1 hour prior to starting the DCNM client. For more information, see the “Configuring the 
Maximum Age of Events Fetched from the Server” section on page 4-15.

DETAILED STEPS

To view events in the Event Browser, follow these steps:

Step 1 From the Feature Selector pane, choose Event Browser.
7-3
Cisco DCNM Fundamentals Configuration Guide, Release 4.0

OL-15316-03



Send  document  comments  to  nexus7k -doc feedback@c i sco .com

Chapter 7      Managing Events
Using the Event Browser and Events Tabs
The event table appears in the Contents pane. The summary charts appear above the Feature Selector 
pane.

Step 2 (Optional) If you want to sort events, click the column heading that you want to sort by. For example, if 
you want to see events grouped by the status of the event, click the Status column heading.

Step 3 (Optional) If you want to use an event filter, see the “Applying and Removing an Event Filter” section 
on page 7-4.

Step 4 (Optional) If you want to filter events by column headings, from the menu bar, choose View > Filter and 
then use the column headings to filter the events.

Step 5 (Optional) If you want to use quick filtering, in the Event Browser toolbar, enter the text that you want 
to use to filter the events.

The client shows only the events that contain the text that you enter.

Note To configure quick filtering options, use the drop-down list of the Event Browser toolbar.

Step 6 (Optional) If you want to view details about a specific event, follow these steps:

a. Find the event in the event list.

b. Click the event.

c. Expand the Details pane, if necessary.

Details about the selected event appear in the Details pane.

d. (Optional) To read notes and messages about status changes to the event, read the information in the 
Action Log field.

Applying and Removing an Event Filter
You can filter events in the Events Browser by the following criteria:

 • Event date and time—By default, the client displays all events received after you started the client 
and for a configurable number of hours prior to starting the client (for more information, see the 
“Configuring the Maximum Age of Events Fetched from the Server” section on page 4-15).

 • Event severity—By default, the client displays events of all severities.

BEFORE YOU BEGIN

If the message “Filter Applied” appears at the top of the Contents pane, the client is applying an event 
filter to the Event Browser.

DETAILED STEPS

To apply or remove an event filter in the Event Browser, follow these steps:

Step 1 View events in the Events Browser (see the “Viewing Events in the Events Browser” section on 
page 7-3).

Step 2 If you want to apply an event filter, follow these steps:

a. From the menu bar, choose View > Event Filter.
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b. Check Apply Filter.

c. As applicable, configure the filter criteria.

d. Click OK.

The Event Browser displays events filtered by the criteria that you specified. The message “Filter 
Applied” appears at the top of the Contents pane.

Step 3 If you want to remove an event filter, follow these steps:

a. From the menu bar, choose View > Event Filter.

b. Uncheck Apply Filter.

c. Click OK.

The Event Browser lists events without filtering them. No message appears at the top of the Contents 
pane.

Viewing Events on an Events Tab
You can view feature-specific events on the Events tab that appears in the Details pane for a feature. By 
default, an Events tab shows events received up to 1 hour prior to starting the DCNM client. For more 
information, see the “Configuring the Maximum Age of Events Fetched from the Server” section on 
page 4-15.

BEFORE YOU BEGIN

Typically, the Events tab appears when, in the Summary pane, you select an object that can have events 
associated with it. For example, if you select Interfaces > Physical > Ethernet from the Feature Selector 
pane, the Summary pane displays devices. Devices contain slots, and slots contain Ethernet ports. When 
you select a device, slot, or port, the Details pane displays an Events tab. 

What you select in the Summary pane affects which events are shown in the tab. Continuing the Ethernet 
interface example, the scope of the events in the Events tab depends on what you select, as follows:

 • Device—Events that pertain to the selected device, any slot within the device, and any Ethernet 
interface within the slot.

 • Slot—Events that pertain to the selected slot and to any Ethernet interface within the slot.

 • Port—Events that pertain to the selected Ethernet interface.

DETAILED STEPS

To view an event on an Events tab, follow these steps:

Step 1 From the Feature Selector pane, choose the feature for which you want to view events.

For example, choose Interfaces > Physical > Ethernet.

Step 2 From the Summary pane, select an object.

The Events tab appears in the Details pane. In the Events tab, the events table appears.

Note If no Events tab appears, then DCNM cannot display events for the object you selected.
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Step 3 (Optional) If you want to sort events, click the column heading that you want to sort by. For example, if 
you want to see events grouped by the status of the event, click the Status column heading.

Step 4 (Optional) If you want to filter events by column headings, from the menu bar, choose View > Filter and 
then use the column headings to filter the events.

Step 5 (Optional) If you want to view details about a specific event, follow these steps:

a. Find the event in the event list.

b. Click the event.

c. Expand the Details pane, if necessary.

Details about the selected event appear in the Details pane.

d. (Optional) To read notes and messages about status changes to the event, read the information in the 
Action Log field.

Changing the Status of an Event
You can change the status of an event to one of the following statuses:

 • Acknowledged—Shown as a green check mark.

 • Critical—Shown as a red circle.

 • Error—Shown as an orange triangle that points down.

 • Warning—shown as a yellow triangle that points up.

By default, the status of new event is Unacknowledged, which is indicated in the Status column by a 
green check mark with a red slash across it.

BEFORE YOU BEGIN

Select an event in the Events Browser or on an Events tab for a specific feature. For more information, 
see the “Viewing Events in the Events Browser” section on page 7-3 or the “Viewing Events on an Events 
Tab” section on page 7-5.

DETAILED STEPS

Step 1 In the event table, right-click the selected event.

Step 2 Choose the desired status.

The new status appears in the Status column for the selected event.

In the Details pane, the message about the status change appears in the Action Log field.
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Adding a Note to One or More Events
As of DCNM 4.0.2, you can add a note to one or more events. Notes can contain 1 to 1000 characters.

Note In Cisco DCNM 4.0.1, you can add a note to one event at a time. To add the same note to more than one 
event, you must add the note to each event separately, using the Notes field and Add Notes button.

BEFORE YOU BEGIN

Find the events to which you want to add a note. For more information, see the “Viewing Events in the 
Events Browser” section on page 7-3 or the “Viewing Events on an Events Tab” section on page 7-5.

DETAILED STEPS

To add a note to one or more events, follow these steps:

Step 1 Select one or more events. Do one of the following:

 • To select one event, click the one event that you want to select.

 • To select two or more adjacent events, click and drag across the events.

 • To select two more events, press and hold Ctrl and click each event.

Step 2 On one of the selected events, right-click and then choose Add Notes.

The Notes dialog box appears.

Step 3 Enter the note. You can enter up to 1000 case-sensitive, alphanumeric characters.

Step 4 Click OK.

The note appears in the Action Log field for each selected event.

Deleting an Event
You can delete one or more events from the Events Browser or a feature-specific Events tab. A deleted 
event no longer appears in the Event Browser or on a feature-specific Events tab; however, the event 
remains in the events database.

For information about deleting old events from the events database, see the “Deleting Data from the 
Events Database” section on page 9-35.

BEFORE YOU BEGIN

Select an event in the Events Browser or on an Events tab for a specific feature. For more information, 
see the “Viewing Events in the Events Browser” section on page 7-3 or the “Viewing Events on an Events 
Tab” section on page 7-5.

DETAILED STEPS

Step 1 In the event table, select one or more events that you want to delete.
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Note To select more than one event, you can click and drag across the events or you can press and hold 
Ctrl and click each event.

Step 2 Right-click a selected event.

Step 3 Choose Remove Event.

The selected events disappear from the Event Browser.

Field Descriptions for Events
This section includes the following field descriptions for Events:

 • Events Table, page 7-8

 • Event Details, page 7-9

Events Table
The events table appears in the Event Browser and on feature-specific Events tabs.

Table 7-1 Events Table 

Field Description

Device Display only. Name and IP address of the device that the event is related to.

Source Display only. Where the event message originated. Sources are either a 
feature on a managed NX-OS device or the DCNM server.

Feature Display only. Name of the NX-OS or DCNM server feature that the event 
pertains to.

Time Display only. Date and time that the event occurred.

Severity Display only. Severity of the event. Possible severities are as follows:

 • Emergency

 • Alert

 • Critical

 • Error

 • Warning

 • Notification

 • Informational

 • Debug

Message Display only. Text of the event.
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Event Details
Event details appear below the events table in the Event Browser and on feature-specific Events tabs.

Status Status that you assign to the event. Possible statuses are as follows:

 • Acknowledge

 • Critical

 • Error

 • Warning

Table 7-1 Events Table (continued)

Field Description

Table 7-2 Event Details 

Field Description

Event Type Display only. Type of the event. Event types are categories that describe the 
general nature of the event. Possible event types are as follows:

 • Communication

 • Environmental

 • Equipment

 • Processing Error

 • Quality of Service

 • Security

 • Unknown

Action Log Shows all actions taken on the event and all notes added to the event.

Life Cycle Type Display only. Type of life cycle of the event. Possible life cycle types are as 
follows:

 • State Change

 • Attribute Value Change

 • Instance Creation

 • Instance Deletion

 • Informational

Notes Allows you to enter text about the event. Maximum length is 1000 
alphanumeric characters. After you save the note, it appears in the Action 
Log field.
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Related Documents
Related Topic Document Title

Minimum required NX-OS logging levels

DCNM server log settings Administering DCNM Server Log Settings, page 9-43

Deleting events from the events database Deleting Data from the Events Database, page 9-35

NX-OS system messages Cisco NX-OS System Messages Reference
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Configuring SPAN

This chapter describes how to configure an Ethernet switched port analyzer (SPAN) on the device.

This chapter includes the following sections:

 • Information About SPAN, page 8-1

 • Licensing Requirements for SPAN, page 8-4

 • Prerequisites for SPAN, page 8-4

 • Guidelines and Limitations, page 8-4

 • Configuring SPAN, page 8-5

 • Field Descriptions for SPAN, page 8-9

 • Additional References, page 8-10

Information About SPAN
You can configure an Ethernet SPAN to monitor traffic in and out of your device. These features allow 
you to copy packets from sources to destinations.

You create SPAN sessions to define the sources and destinations to use for the network traffic. Sources 
designate the traffic to monitor and whether to copy ingress, egress, or both directions of traffic. 
Destination ports receive the copied traffic from all sources.

SPAN sessions apply to the local device.

This section includes the following topics:

 • SPAN Sessions, page 8-1

 • Virtual SPAN Sessions, page 8-2

 • Shutting Down a SPAN Session, page 8-3

 • High Availability, page 8-3

 • Virtualization Support, page 8-3

SPAN Sessions
You can create up to 18 SPAN sessions to define sources and destinations on the local device, although 
only two sessions can be running simultaneously.
8-1
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Figure 8-1 shows a SPAN configuration. Packets on three Ethernet ports are copied to destination port 
Ethernet 2/5. Only traffic in the direction specified is copied.

Figure 8-1 SPAN Configuration
.

Sources for a SPAN session include Ethernet ports, VLANs, and remote SPAN (RSPAN) VLANs. 

Note NX-OS does not support terminating an RSPAN session.

Destinations for a SPAN session include ports in either access or trunk mode.

Note Only two SPAN sessions can be running simultaneously.

For information about configuring a SPAN session, see the “Configuring a SPAN Session” section on 
page 8-5.

Virtual SPAN Sessions
You can create a virtual SPAN session to monitor multiple VLAN sources and choose only VLANs of 
interest to transmit on multiple destination ports. For example, you can configure SPAN on a trunk port 
and monitor traffic from different VLANs on different destination ports.

Figure 8-2 shows a virtual SPAN configuration. The virtual SPAN session copies traffic from the three 
VLANs to the three specified destination ports. You can choose which VLANs to allow on each 
destination port to limit the traffic that the device transmits on it. In Figure 8-2, the device transmits 
packets from one VLAN at each destination port.

Note Virtual SPAN sessions cause all source packets to be copied to all destinations, whether the packets are 
required at the destination or not. VLAN traffic filtering occurs at the egress destination port level.
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Figure 8-2 Virtual SPAN Configuration
.

For information about configuring a virtual SPAN session, see the “Configuring a Virtual SPAN Session” 
section on page 8-6.

Shutting Down a SPAN Session
You can shut down SPAN sessions to discontinue the copying of packets from sources to destinations. 
Although you can define up to 18 SPAN sessions, only two SPAN sessions can be running 
simultaneously.

For information about shutting down SPAN sessions, see the “Shutting Down or Resuming a SPAN 
Session” section on page 8-8.

High Availability
The SPAN feature supports stateless and stateful restarts. After a reboot or supervisor switchover, Cisco 
NX-OS applies the running configuration.

Virtualization Support
A virtual device context (VDC) is a logical representation of a set of system resources. SPAN applies 
only to the VDC where the commands are entered.

For information about configuring VDCs, see the Cisco DCNM Virtual Device Context Configuration 
Guide, Release 4.0 at the following URL:

http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/dcnm/virtual_device_context/ 
configuration/guide/vdc_dcnm_book.html
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Licensing Requirements for SPAN
The following table shows the licensing requirements for this feature:

Prerequisites for SPAN
SPAN has the following prerequisites:

 • You configure the ports on each device to support the desired SPAN configuration. For more 
information, see the Cisco DCNM Interfaces Configuration Guide, Release 4.0 at the following 
URL: 
http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/dcnm/interfaces/configuration/ 
guide/if_dcnm_book.html

Guidelines and Limitations
SPAN has the following configuration guidelines and limitations:

 • A maximum of 18 SPAN sessions can be configured on a device.

 • A maximum of two SPAN sessions can be running simultaneously on a device.

 • You can configure a particular destination port in only one SPAN session.

 • You cannot configure a port as both a source and destination port.

 • Destination ports do not participate in any spanning tree instance. SPAN output includes Bridge 
Protocol Data Unit (BPDU) Spanning-Tree Protocol hello packets.

 • When a SPAN session contains multiple egress source ports, packets that these ports receive may be 
replicated even though they are not transmitted on the ports. Some examples of this behavior on 
source ports are as follows:

 – Traffic that results from flooding

 – Broadcast and multicast traffic

 • For VLAN SPAN sessions with both ingress and egress configured, two packets (one from ingress 
and one from egress) are forwarded from the destination port if the packets get switched on the same 
VLAN.

 • VLAN SPAN monitors only the traffic that leaves or enters Layer 2 ports in the VLAN.

 • You can configure an RSPAN VLAN for use only as a SPAN session source.

Product License Requirement

DCNM SPAN requires no license. Any feature not included in a license package is bundled with the Cisco DCNM 
and is provided at no charge to you. For a complete explanation of the DCNM licensing scheme, see the 
Cisco DCNM Licensing Guide, Release 4.0.

NX-OS SPAN requires no license. Any feature not included in a license package is bundled with the Cisco NX-OS 
system images and is provided at no extra charge to you. For a complete explanation of the NX-OS licensing 
scheme, see the Cisco NX-OS Licensing Guide, Release 4.0 at the following URL:

http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/nx-os/licensing/configuration/guide/ 
nx-os_licensing.html
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• If you configure a SPAN session to monitor a routed interface, only the received traffic is captured, 
even if the session is configured for both directions. This limitation is only for traffic that enters a 
Layer 2 interface (with SVI as a Layer 3 interface) and then exits a routed (physical Layer 3) 
interface, which is the source of the monitor session. If traffic enters a routed (physical Layer 3) 
interface and exits another routed (physical Layer 3) interface, which is the source of the monitor 
session, then the destination port of the monitor session captures traffic in both directions. A SPAN 
session captures traffic in both directions if traffic entering the routed port is destined to an IP 
address (SVI) on the switch.

Configuring SPAN
You can configure a SPAN session to copy packets from sources to destinations on the local device only.

You can configure a virtual SPAN session by choosing multiple VLAN sources and then choosing which 
VLANs to allow on each destination port to limit the traffic that the device transmits on it.

This section includes the following topics:

• Configuring a SPAN Session, page 8-5

• Configuring a Virtual SPAN Session, page 8-7

• Configuring an RSPAN VLAN, page 8-8

• Shutting Down or Resuming a SPAN Session, page 8-9

Configuring a SPAN Session
You can configure a SPAN session to copy packets from sources to destinations on the local device only. 
By default, SPAN sessions are created in the shut state.

For sources, you can specify Ethernet ports, port channels, VLANs, and RSPAN VLANs. You can 
specify private VLANs (primary, isolated, and community) in SPAN sources.

For destination ports, you can specify Ethernet ports in either access or trunk mode. You must enable 
monitor mode on all destination ports.

BEFORE YOU BEGIN

• Configure the destination ports in access or trunk mode. For more information, see the Cisco DCNM 
Interfaces Configuration Guide, Release 4.0 at the following URL:
http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/dcnm/interfaces/configuration/
guide/if_dcnm_book.html

DETAILED STEPS

To configure a SPAN session, follow these steps:

Step 1 From the Feature Selector pane, choose Interfaces > Traffic Monitoring > SPAN. The available devices 
appear in the Summary pane.

Step 2 From the Summary pane, double-click the device that you want to configure with a SPAN session to 
display the configured SPAN sessions.
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Step 3 (Optional) To delete a SPAN session that you are no longer using, right-click the SPAN session and 
choose Delete.

Step 4 (Optional) To configure a new SPAN session, from the menu bar choose File > New > Local SPAN 
Session. By default, SPAN sessions are created in the shut state.

a. (Only the first time you create a SPAN session) From the Summary pane, double-click the device 
that you want to configure with a SPAN session to display the configured SPAN sessions.

b. (Optional) To modify the session number, from the Summary pane, double-click the Session Id field 
and enter a session number from 1 to 18.

Note You can only modify the session number immediately after you create the session.

Step 5 From the Summary pane, choose the SPAN session to configure.

Step 6 From the Details pane, click the Configuration tab and expand the Session Settings section, if 
necessary. 

Step 7 (Optional) To add a description of the SPAN session, specify it in the Description field.

Step 8 (Optional) To add VLANs to filter (include) in the SPAN session, in the Filtered VLANs field, down 
array to displays the configured VLANs that you can choose.

Step 9 Add source Ethernet ports to the SPAN session as follows:

a. From the Ports association panel, double-click the device and then double-click the desired slot to 
display ports.

b. Choose the port, right-click on the port row, and choose Add to SPAN Source to add this port to the 
SPAN session sources.

Step 10 Add source VLANs or RSPAN VLANs to the SPAN session as follows:

a. From the VLANs association panel, double-click the device to display the configured VLANs.

b. Choose the VLAN, right-click on the VLAN row, and choose Add to SPAN Source to add this 
VLAN to the SPAN session sources.

Step 11 Add destination Ethernet ports to the SPAN session as follows:

a. From the Ports association panel, double-click the device and then double-click the desired slot to 
display ports.

b. Choose an access or trunk port. 

c. In the Monitor column check the check box to enable monitoring on this port.

d. Right-click on the port row and choose Add to SPAN Destination to add this port to the SPAN 
session destinations.

Step 12 (Optional) To modify SPAN session source settings, follow these steps:

a. From the Details pane, click the Configuration tab and expand the Source and Destination 
section, if necessary.

b. To modify the ingress or egress choice for a source, check or uncheck the Ingress or Egress check 
box to activate the desired direction to monitor. By default, both ingress and egress are monitored.

c. To delete a SPAN source or destination, choose the source or destination entry, right-click on it, and 
choose Delete.

Step 13 From the menu bar, choose File > Deploy to apply your changes to the device.
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Configuring a Virtual SPAN Session
You can configure a virtual SPAN session to copy packets from source ports, VLANs, and RSPAN 
VLANs to destination ports on the local device. By default, SPAN sessions are created in the shut state.

For sources, you can specify ports, VLANs, or RSPAN VLANs.

For destination ports, you can specify Ethernet ports. You can choose which VLANs to allow on each 
destination port to limit the traffic that the device transmits on it.

BEFORE YOU BEGIN

• Configure the destination ports in trunk mode. For more information, see the Cisco DCNM 
Interfaces Configuration Guide, Release 4.0 at the following URL:
http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/dcnm/interfaces/configuration/
guide/if_dcnm_book.html

DETAILED STEPS

To configure a virtual SPAN session, follow these steps:

Step 1 From the Feature Selector pane, choose Interfaces > Traffic Monitoring > SPAN. The available devices 
appear in the Summary pane.

Step 2 From the Summary pane, double-click the device that you want to configure with a SPAN session to 
display the configured SPAN sessions.

Step 3 (Optional) To delete a SPAN session that you are no longer using, right-click the SPAN session and 
choose Delete.

Step 4 (Optional) To configure a new SPAN session, from the menu bar choose File > New > Local SPAN 
Session. By default, SPAN sessions are created in the shut state.

a. (Only the first time you create a SPAN session) From the Summary pane, double-click the device 
that you want to configure with a SPAN session to display the configured SPAN sessions.

b. (Optional) To modify the session number, from the Summary pane, double-click the Session Id field 
and enter a session number from 1 to 18.

Note You can only modify the session number immediately after you create the session.

Step 5 From the Summary pane, choose the SPAN session to configure.

Step 6 From the Details pane, click the Configuration tab and expand the Session Settings section, if 
necessary. 

Step 7 (Optional) To add a description of the SPAN session, specify it in the Description field.

Step 8 (Optional) To add VLANs to filter (include) in the SPAN session, in the Filtered VLANs field, down 
array to displays the configured VLANs that you can choose.

Step 9 Add source Ethernet ports to the SPAN session as follows:

a. From the Ports association panel, double-click the device and then double-click the desired slot to 
display ports.

b. Choose the port, right-click on the port row, and choose Add to SPAN Source to add this port to the 
SPAN session sources.
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Step 10 Add source VLANs or RSPAN VLANs to the SPAN session as follows:

a. From the VLANs association panel, double-click the device to display the configured VLANs.

b. Choose the VLAN, right-click on the VLAN row, and choose Add to SPAN Source to add this 
VLAN to the SPAN session sources.

Step 11 Add destination Ethernet ports to the SPAN session as follows:

a. From the Ports association panel, double-click the device and then double-click the desired slot to 
display ports.

b. Choose an access or trunk port. 

c. In the Monitor column check the check box to enable monitoring on this port.

d. Right-click on the port row and choose Add to SPAN Destination to add this port to the SPAN 
session destinations.

Step 12 Limit the VLANs allowed on a trunk port by following these steps:

a. From the Feature Selector pane, choose Interfaces > Physical > Ethernet. The available devices 
appear in the Summary pane.

b. From the Summary pane, double-click the device and then double-click the slot that you want to 
configure.

c. Choose the trunk port to configure.

d. From the Details pane, click the Port Details tab and expand the Port Mode Settings section, if 
necessary.

e. Limit the VLANs on the trunk by clicking the Allowed VLANs field. The field displays configured 
VLANs that you can choose.

Step 13 From the menu bar, choose File > Deploy to apply your changes to the device.

Configuring an RSPAN VLAN
You can specify a remote SPAN (RSPAN) VLAN as a SPAN session source. 

DETAILED STEPS

To configure an RSPAN VLAN, follow these steps:

Step 1 From the Feature Selector pane, choose Switching > VLAN. The available devices appear in the 
Summary pane.

Step 2 From the Summary pane, double-click the device that you want to configure.

Step 3 Choose the VLAN to configure.

Step 4 From the Details pane, click the VLAN Details tab and expand the Advanced Settings section, if 
necessary.

Step 5 Check the RSPAN VLAN check box.

Step 6 From the menu bar, choose File > Deploy to apply your changes to the device.
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Shutting Down or Resuming a SPAN Session
You can shut down SPAN sessions to discontinue the copying of packets from sources to destinations. 
Because only two SPAN sessions can be running simultaneously, you can shut down one session in order 
to free hardware resources to enable another session. By default, SPAN sessions are created in the shut 
state.

You can resume (enable) SPAN sessions to resume the copying of packets from sources to destinations. 
In order to enable a SPAN session that is already enabled but operationally down, you must first shut it 
down and then enable it.

DETAILED STEPS

To shut down or resume (enable) a SPAN session, follow these steps:

Step 1 From the Feature Selector pane, choose Interfaces > Traffic Monitoring > SPAN.

The available devices appear in the Summary pane.

Step 2 From the Summary pane, double-click the device that you want to configure with a SPAN session to 
display the configured SPAN sessions.

Step 3 From the Summary pane, choose the SPAN session to configure.

Step 4 From the Details pane, click the Configuration tab and expand the Session Settings section, if 
necessary. 

Step 5 Resume (enable) the SPAN session by choosing Up in the Admin Status field.

Step 6 Shut down the SPAN session by choosing Down in the Admin Status field.

Note If a monitor session is enabled but its operational status is down, then to enable the session you 
must first shut down the session followed by resuming the session.

Field Descriptions for SPAN
This section includes the following field descriptions for SPAN:

• Local SPAN Session: Configuration: Session Settings Section, page 8-9

• Local SPAN Session: Configuration: Source and Destination Section, page 8-10

Local SPAN Session: Configuration: Session Settings Section

Table 8-1 Local SPAN Session: Configuration: Session Settings Section

Element Description

Session Id Local SPAN session number. Can only be specified when the session is first 
created. The value ranges from 1 to 18.

Description Description for this session.
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Local SPAN Session: Configuration: Source and Destination Section

Additional References
For additional information related to implementing SPAN, see the following sections:

• Related Documents, page 8-11

• Standards, page 8-11

Filtered VLANs When clicked, list of configured VLANs.

Admin Status Administrative status of the session.

Operational Status Display only. Whether the session is shut (down) or enabled (up).

Status Description Display only. Status description.

Table 8-2 Local SPAN Session: Configuration: Source and Destination Section

Element Description

Source

Interface/VLAN Display only. Port or VLAN number.

Description Display only. Port or VLAN description.

Ingress Status of whether to monitor ingress packets.

Egress Status of whether to monitor egress packets.

Destination

Interface Display only. Port number.

Description Display only. Port description.

Table 8-1 Local SPAN Session: Configuration: Session Settings Section (continued)

Element Description
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Related Documents

Standards

Related Topic Document Title

VDCs Cisco DCNM Virtual Device Context Configuration Guide, Release 
4.0 at the following URL:

http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/
dcnm/virtual_device_context/configuration/guide/
vdc_dcnm_book.html

Standards Title

No new or modified standards are supported by this 
feature, and support for existing standards has not been 
modified by this feature.

—
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Administering the DCNM Server

This chapter describes how to administer the DCNM server.

This chapter includes the following topics:

 • Administering Device Discovery, page 9-1

 • Administering Devices and Credentials, page 9-8

 • Administering DCNM Licensed Devices, page 9-19

 • Administering DCNM Server Users, page 9-24

 • Administering Auto-Synchronization with Devices, page 9-31

 • Administering Statistical Data Collection, page 9-37

 • Administering DCNM Server Log Settings, page 9-43

Administering Device Discovery
This section includes the following topics:

 • Information About Device Discovery, page 9-1

 • Licensing Requirements for Device Discovery, page 9-3

 • Prerequisites for Device Discovery, page 9-3

 • Guidelines and Limitations for Device Discovery, page 9-3

 • Performing Device Discovery, page 9-4

 • Viewing the Status of Device Discovery Tasks, page 9-7

 • Where to Go Next, page 9-7

 • Field Descriptions for Device Discovery, page 9-7

 • Additional References for Device Discovery, page 9-8

Information About Device Discovery
This section includes the following topics:

 • Device Discovery, page 9-2

 • Cisco Discovery Protocol, page 9-2
9-1
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 • Credentials and Discovery, page 9-2

 • NX-OS Device Preparation, page 9-2

 • Virtualization Support, page 9-3

Device Discovery

Device discovery feature creates devices in DCNM by connecting to an NX-OS device and retrieving the 
running configuration of each virtual device context (VDC) on the NX-OS device. DCNM displays each 
VDC as a device, including the default VDC. If the NX-OS device has only the default VDC, then device 
discovery creates only one device in DCNM.

When DCNM connects to a device to retrieve its configuration, it uses the XML management interface, 
which uses the XML-based Network Configuration Protocol (NETCONF) over secure shell (SSH). For 
more information, see the Cisco NX-OS XML Management Interface User Guide.

Cisco Discovery Protocol

Device discovery uses Cisco Discovery Protocol (CDP) to find devices that are connected to the initial 
device in the discovery process. CDP exchanges information between adjacent devices over the data link 
layer. The exchanged information is helpful in determining network topology and physical configuration 
outside of the logical or IP layer.

CDP allows DCNM to discover devices that are one or more hops beyond the first device (seed device) 
in the discovery process. When you start the discovery process using the Device Discovery feature, you 
can limit the number of hops that the discovery process can make.

After DCNM discovers an NX-OS device using CDP, it connects to the device and retrieves information, 
such as the running configuration of the device. The information collected allows DCNM to manage the 
device.

DCNM supports CDP hops on some Cisco switches that run Cisco IOS software. Although DCNM 
cannot manage these devices, the Topology feature shows them and the CDP links between them and 
other discovered devices.

Credentials and Discovery

Device discovery requires that you provide a username and password for a user account on the seed 
device. To successfully complete discovery of an NX-OS device, the user account that you specify must 
be assigned to either the network-admin or the vdc-admin role.

If you want to discover devices that are one or more hops from the seed device, all devices in the chain 
of hops must be configured with a user account of the same username and password. All NX-OS devices 
in the chain of hops must assign the user account to the network-admin or the vdc-admin role.

NX-OS Device Preparation

Before you perform device discovery, you should ensure that the NX-OS device configuration can 
support a successful discovery. For more information, see the “NX-OS Device Configuration 
Requirements” section on page 1-5.
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Chapter 9      Administering the DCNM Server
Administering Device Discovery
Virtualization Support

When DCNM discovers an NX-OS device, it determines how many virtual device contexts (VDC) are 
on the NX-OS device. In DCNM, each VDC is treated as a separate device. The status of each VDC is 
tracked separately and you can configure each VDC independently of other VDCs on an NX-OS device.

Licensing Requirements for Device Discovery
The following table shows the licensing requirements for this feature:

Prerequisites for Device Discovery
Prior to performing device discovery, you should be familiar with the following:

 • VDCs

 • CDP

Device discovery has the following prerequisites:

 • The DCNM server must be able to connect to devices it discovers.

 • NX-OS devices must be running a supported version of NX-OS.

 • CDP must be enabled both globally and specifically on interfaces used for device discovery.

 • The NX-OS device must have the minimal configuration that is required to enable device discovery 
to succeed. For more information, see the “NX-OS Device Preparation” section on page 9-2.

Guidelines and Limitations for Device Discovery
Device discovery has the following configuration guidelines and limitations:

 • Ensure that NX-OS devices that you want to discover have been prepared for discovery. For more 
information, see the “NX-OS Device Configuration Requirements” section on page 1-5.

 • DCNM can manage only devices that run NX-OS 4.0.

 • CDP-based discovery of devices requires that all devices in the chain of CDP hops use the same 
username and password specified for the seed device. If your security practices do not allow the 
same username and password to be used on each device, you can perform device discovery for each 
device individually.

 • Devices that are CDP hops but which are not running Cisco IOS software appear in the Topology 
feature but cannot be managed by DCNM.

Product License Requirement

DCNM Device discovery requires no license. Any feature not included in a license package is bundled with the 
Cisco DCNM and is provided at no charge to you. For a complete explanation of the DCNM licensing 
scheme, see the Cisco DCNM Licensing Guide.
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