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Activities User Interface Reference

An activity is a temporary container within which you define and assign policies. 
You must create an activity or open an existing activity before you can define 
policies and assign them to devices. 

To create and open activities, and perform other management functions, ensure 
that Workflow mode is enabled and then select Tools > Activity Manager. The 
Activity Manager window appears. To help you understand the information 
available and functions you can perform in the Activity Manager window, see 
Activity Manager Window, page E-1.

If you do not create or open an activity before trying to define policies, a dialog 
box prompts you to do so. The following topics explain these dialog boxes:

• Activity Required (Create Activity) Dialog Box, page E-17

• Activity Required (Create or Open Activity) Dialog Box, page E-18

• Openable Activities Dialog Box, page E-19

Activity Manager Window
The Activity Manager window contains three parts: the Activity Table, Activity 
Details tab, and Activity History tab. These parts allow you to create and manage 
activities.

Note The Activity Manager option from the Tools menu is only visible when Workflow 
mode is enabled.
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This section also describes the following features of the Activity Manager 
window:

• Activity States

• Details Tab

• History Tab

• Create Activity Dialog Box

• Submit Activity Dialog Box

• Approve Activity Dialog Box

• Reject Activity Dialog Box

• Discard Activity Dialog Box

• Validation Dialog Box

• View Changes (Activity Change Report)

Navigation Path

Click the Activity Manager button on the Main toolbar.

Related Topics

• Working with Activities, page 7-9

• Understanding Activity States, page 7-5

Field Reference

Table E-1 Activities Manager Window

Element Description

Activity Contains the unique name of each activity. 

State The state of each activity. For a list of valid states, see Table E-2.

Last Modified The timestamp for the most recent action.

User The username of the person who changed the state of the activity. 

Last Action The most recent action performed on the activity.

Create button Adds a new activity so that you can create or change policies or assign policies to 
devices. For more information, see Create Activity Dialog Box, page E-7.
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Open button Opens the activity so that changes, such as defining and assigning policies, are 
captured within the activity. You can open an activity when it is in the Edit or the 
Submitted state. 

Close button Closes and save all changes made while the activity was open. You can close an 
activity when it is in the Edit Open or the Submit Open state.

Validate button Validates changes that you have made to the activity from the time you created the 
activity to the current time, then generates and displays a report. Validating an 
activity checks policy integrity and deployability. For more information, see 
Validation Dialog Box, page E-12.

Submit button Submits the activity. When using Workflow mode without activity approval, 
submitting the activity approves and saves it to the database in one step. When using 
Workflow mode with activity approval, submitting the activity sends notification that 
the activity is ready for review to the specified approver. For more information, see 
Submit Activity Dialog Box, page E-8.

You can submit an activity when it is in the Edit or the Edit Open state.

Approve button Saves the proposed changes to the database. Devices associated with the activity are 
unlocked, meaning they can be included in policy definitions and changes in other 
activities. You must have appropriate user permissions to approve the activity. You 
can approve an activity only when it is in the Submitted state. For more information, 
see Approve Activity Dialog Box, page E-9.

Note The Approve button is available only in Workflow mode with an activity 
approver.

Table E-1 Activities Manager Window (continued)

Element Description
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Activity States
The State column in the Activity Table lists the status of each activity.

Reject button Rejects the changes proposed in the activity. You must have appropriate user 
permissions to reject an activity. If the activity is rejected, the submitter can continue 
to make changes to the activity. Devices associated with the activity are not unlocked, 
meaning that they cannot be included in policy definitions or changes in another 
activity. For more information, see Reject Activity Dialog Box, page E-10.

You can reject an activity only when it is in the Submitted or the Submitted Open 
state.

Note The Reject button is available only in Workflow mode with an activity 
approver.

Discard button Discards the activity. The activity is then purged from the system when you perform 
the purge action manually or automatically, as set under Tools > Security Manager 
Administration > Workflow. The activity state is shown as discarded until the activity 
is purged from the system. For more information, see Discard Activity Dialog Box, 
page E-11 and Deployment Page, page A-5.

View Changes Generates a report in pdf for any individual activity. If activity is in the Closed state, 
this button is grayed out. For more information, see View Changes (Activity Change 
Report), page E-15.

Refresh button Refreshes the information presented on the Activity page.

Activity 
Details tab

Information about the selected activity, such as the name and description of the 
activity and the date and time it was created and modified. For more information, see 
Details Tab, page E-5.

Activity 
History tab

Transactions that occurred to the selected activity since it was created. For more 
information, see History Tab, page E-6.

Close button Closes the window.

Help button Opens help for this window.

Table E-1 Activities Manager Window (continued)

Element Description
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Related Topics

• Understanding Activity States, page 7-5

• Working with Activities, page 7-9

Field Reference

Details Tab
The Details tab provides information about the selected activity.

Table E-2 Activity States

State Description

Edit The activity was created, but the activity is not currently being edited. The activity can 
be opened or discarded while it is in the Edit state.

Edit Open The activity is open for editing. Changes, such as defining and assigning policies, are 
made in the activity. Devices or groups being configured are locked from other 
activities. The activity can be closed, discarded, submitted, or approved while it is in 
the Edit Open state.

Submitted The activity was submitted for review. It can be viewed but not edited while it is in the 
Submitted state. It must be opened (in the Submitted Open state) to be edited. Devices 
and groups in the activity are locked from other activities. The activity can be opened, 
discarded, or rejected while it is in the Submitted state.

Submitted 
Open

The activity is open for viewing. Devices in the activity are locked to other activities. 
The activity can be approved or rejected while it is in the Submitted Open state.

Approved The activity was approved, and the corresponding configuration elements are now 
committed policy configurations. Devices associated with the activity are unlocked and 
can now be used by another activity. The activity can be deployed or discarded while it 
is in the Approved state.

Approve 
Failed

The activity is placed in the Approve Failed state if errors occur during approval (for 
example, due to a power failure). If this happens, try to approve the activity again or 
reboot the server.

Discarded Changes made to the activity since the activity was created were discarded and further 
changes to the activity are not allowed. Devices associated with the activity are 
unlocked and can now be used in a new activity. The activity remains in the Activity 
table showing a Discarded state until it is purged from the system.
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Navigation Path

Click the Activity Manager button on the Main toolbar, select an activity, then 
click the Details tab.

Related Topics

• Activity Manager Window, page E-1

• History Tab, page E-6

Field Reference

History Tab
The History tab displays the transactions that occurred to the selected activity 
since the activity was created. The History tab provides information about the 
selected activity.

Navigation Path

Click the Activity Manager button on the Main toolbar, select an activity, then 
click the History tab.

Related Topics

• Activity Manager Window, page E-1

Table E-3 Details Tab

Element Description

Activity ID Identification number assigned by Security Manager when you create the activity.

Activity Name Name of the activity. The default activity name contains the username, date, and time 
the activity was created. However, whoever creates the activity can create a different 
name for the activity.

Created Date and time the activity was created.

Last Modified Date and time the activity was last modified.

Description Comments entered when the activity state is changed.

Close button Closes the window.

Help button Opens help for this window.
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• History Tab, page E-6

Field Reference

Create Activity Dialog Box
Activities must be created before you can make policy changes.

Navigation Path

Click the Create Activity button on the Main toolbar.

Related Topics

• Opening an Activity, page 7-12

• Activity States, page E-4

Field Reference

Table E-4 History Tab

Element Description

State State of the activity. For a list of valid states, see Table E-2.

User Username of the person who performed the action on the activity.

Date/Time Date and time the action was performed on the activity.

Comment Comments entered when the activity state is changed.

Table E-5 Create Activity Dialog Box

Element Description

Activity Name Name of the activity. The default activity name contains the username, date, and time 
the activity was created. If you enter a different name, you should assign a logical 
name that reflects the contents of the activity. The activity name must be unique.

Comment Brief description of the changes to the activity or other pertinent information.

OK button Saves your changes and closes the dialog box. 

Cancel button Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.
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Submit Activity Dialog Box
When in Workflow mode with an activity approver, you must submit activities for 
approval before policy changes can be committed to the Security Manager 
database and deployed to devices.

Navigation Path

Do one of the following:

• To submit an open activity, click the Submit Activity button on the Main 
toolbar.

• To submit a closed activity, click the Activity Management button on the 
Main toolbar, select the desired activity, then click Submit.

Related Topics

• Opening an Activity, page 7-12

• Submitting an Activity for Approval, page 7-14

• Activity States, page E-4

Field Reference

Table E-6 Submit Activity Dialog Box

Element Description

Approver Default email address of the person assigned approval permissions. This person receives 
notification of your submission. You can leave the default address or enter a new email 
address. The default email address is set in Tools > Security Manager Administration > 
Workflow.

Note If the email does not reach the recipient, Security Manager displays a message 
indicating that the email server is unreachable, and you must contact the 
approver directly.

Comment Brief description of the changes included in the activity or other pertinent information.

OK button Saves your changes and closes the dialog box. 
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Approve Activity Dialog Box
When in Workflow mode with an activity approver, you must submit activities for 
review. 

Approving an activity commits policy changes to the Security Manager database 
so that they can then be deployed to devices.

Navigation Path

Do one of the following:

• To approve an open activity, click the Approve Activity button on the Main 
toolbar.

• To approve a closed activity, click the Activity Management button on the 
Main toolbar, select the desired activity, then click Approve.

Related Topics

• Approving or Rejecting an Activity, page 7-16

• Activity States, page E-4

Field Reference

Cancel 
button

Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.

Table E-6 Submit Activity Dialog Box (continued)

Element Description

Table E-7 Approve Activity Dialog Box

Element Description

Comment Brief explanation of why you are approving the activity.

OK button Saves your changes and closes the dialog box. 
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Reject Activity Dialog Box
In Workflow mode with an activity approver, you must submit activities to an 
activity approver who has permissions to approve or reject the activity. 

Rejecting an activity does not commit policy changes to the Security Manager 
database. The activity is retuned to the Edit state so that changes can be made. As 
the activity approver, you can specify any desired changes in the comments field.

Navigation Path

Do one of the following:

• To reject an open activity, click the Reject Activity button on the Main 
toolbar.

• To reject a closed activity, click the Activity Management button on the Main 
toolbar, select the desired activity, then click Reject.

Related Topics

• Approving or Rejecting an Activity, page 7-16

• Activity States, page E-4

Field Reference

Cancel 
button

Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.

Table E-7 Approve Activity Dialog Box (continued)

Element Description

Table E-8 Reject Activity Dialog Box

Element Description

Comment Brief description of why you are rejecting the activity and any suggested revisions.

OK button Saves your changes and closes the dialog box. 
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Discard Activity Dialog Box
You can discard an activity if you want to cancel the changes that you have made. 
For tracking purposes, you can enter a comment explaining why you are 
discarding the activity.

Navigation Path

Do one of the following:

• To discard an open activity, click the Discard Activity button on the Main 
toolbar.

• To discard a closed activity (must be in the Edit or Edit Open state), click the 
Activity Management button on the Main toolbar, select the desired activity, 
then click Discard.

Related Topics

• Discarding an Activity, page 7-19

• Activity States, page E-4

Field Reference

Cancel 
button

Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.

Table E-8 Reject Activity Dialog Box (continued)

Element Description

Table E-9 Discard Activity Dialog Box

Element Description

Comment Brief explanation of why you are discarding the activity.

OK button Saves your changes and closes the dialog box. 

Cancel 
button

Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.
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Validation Dialog Box
The validation process checks the integrity and deployability of policy changes 
you have made. The process works slightly differently depending on whether 
Workflow mode is turned disabled or enabled.

• Workflow mode disabled—The validation process checks policy changes 
that took place within a login session and displays the results. The validation 
process reports on policy changes that were made up until the changes are 
saved or deployed. After changes are saved or deployed, the validation report 
remains static; it does not contain any policy changes to the activity after it 
was saved or deployed.

• Workflow mode enabled—The validation process checks policy changes 
within an open activity and displays a report with the results. The validation 
process reports on policy changes that were made to the activity until it was 
submitted. After an activity is submitted, the validation report remains static.

The Validation dialog box contains detailed error information organized in two 
tabs. Click the desired tab to display its contents. 

The following topics contain information about these tabs:

• Errors Tab, page E-12

• Devices Tab, page E-14

Errors Tab

The Error tab contains the Validation Results table and Details pane.

The Validation Results table provides details about each error found during 
validation. The details consist of a description of the error, the severity of the 
error, and the number of devices affected.

Click an error to display the Details pane. The pane shows a description of and 
solution to the error and the specific devices affected.

Navigation Path

Do one of the following:

• To display validation errors for an open activity, click the Validate Activity 
button on the Main toolbar. When the Validation Result dialog box appears, 
click Details, then click the Errors tab.
E-12
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• To display validation errors for a closed activity, click the Activity 
Management button on the Main toolbar, select the desired activity, then click 
Validate. When the Validation Result dialog box appears, click Details, then 
click the Errors tab.

Related Topics

• Validating an Activity, page 7-13

• Validation Dialog Box, page E-12

• Devices Tab, page E-14

Field Reference

Table E-10 Errors Tab

Element Description

Validation Results table—List of validation errors.

Error Error message headline.

Severity Icon representing the severity of the error:

• Information icon shows that there are no errors to prevent approval.

• Warning icon shows that there are errors; however they are not severe 
enough to prevent approval.

Note A validation warning will not prevent activity approval or deployment.

• Error icon shows that errors prevent approval.

# devices effected Number of devices affected by the validation error listed in the Error column.

Details pane—Information about the errors and affected devices.

Devices Name of the device.

Types Icon representing the type of device, for example firewall, router, and so on.

Error Error message headline.

Description Error message details, such as device types affected and current device status.

Solution Probable cause and suggested resolution when relevant and available.

OK button Saves your changes and closes the dialog box. 
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Devices Tab

The Devices tab contains the Validation Results table and Details pane.

The Validation Results table provides details about each device and the errors and 
warnings found during validation. The details consist of the type of device, the 
status of the validation, and the number of errors and warnings encountered. 

Click a device to display the Details pane. The pane shows a description of and 
solution to each error and warning.

Navigation Path

Do one of the following:

• To display errors grouped by device for an open activity, click the Validate 
Activity button on the Main toolbar. When the Validation Result dialog box 
appears, click Details, then click the Devices tab.

• To display errors grouped by device for a closed activity, click the Activity 
Management button on the Main toolbar, select the desired activity, then click 
Validate. When the Validation Result dialog box appears, click Details, then 
click the Devices tab.

Related Topics

• Validating an Activity, page 7-13

• Validation Dialog Box, page E-12

• Errors Tab, page E-12

Field Reference

Cancel button Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.

Table E-10 Errors Tab (continued)

Element Description

Table E-11 Devices Tab

Validation Results table—List of devices.

Type Icon representing the type of device effected.
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View Changes (Activity Change Report) 
From the Tools > Change Reports menu (non-Workflow mode), or Activity 
Manager (Workflow mode) you can view reports about actions that users have 
taken within an activity. You can see which actions were taken and what devices 
and groups were acted upon within an activity or configuration session 
(non-Workflow mode). The Activity Change report, generated in PDF format, 

Device Name of the device.

Status Icon indicating the results of the validation test:

• Information icon shows there are no errors to prevent approval.

• Warning icon shows that there are errors; however, they are not severe 
enough to prevent approval.

• Error icon shows that errors prevent approval.

Summary Number of errors, warnings, or no text if neither is present.

Details pane—Information about the errors and warnings for the device selected in the Validation 
Results table.

Error Error message headline.

Severity Icon representing the severity of the error:

• Information icon indicates there are no errors to prevent approval.

• Warning icon indicates there are errors; however they are not severe 
enough to prevent approval.

• Error icon indicates errors prevent approval.

Summary Brief description of the error.

Description Details about the error.

Solution Probable cause and suggested resolution when relevant and available.

OK button Saves your changes and closes the dialog box. 

Cancel button Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.

Table E-11 Devices Tab (continued)

Validation Results table—List of devices.
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also identifies the policy changes made as part of that activity. You must disable 
any popup-blocker applications in your browser for the Activity Change report to 
launch.

Note If you discover a device or rediscover policies on a device, subsequent policy 
changes in the same activity performed on that device are not listed in the activity 
change report. This is also true on a device that you clone from another device.

For more information, see Understanding Activity Change Reports, page 7-17.

Navigation Path

If you are in non-Workflow Mode do the following:

• In Device view, highlight a device and select Select Tools > Change Reports. 
Select an entry from the Change Report window and click the View Changes 
button.

If you are in Workflow Mode do any one of the following:

• In Device View, highlight a device and select Activities > View Changes.

• In Device View, highlight a device and click the View Changes icon from the 
Activity toolbar.

• Highlight an activity in the Activity Manager window and click the View 
Changes button.

Use File > View Changes to obtain an Activity Change Report that only reports 
changes on the current activity (or configuration session in non-Workflow mode).

Related Topics

• Understanding Activity Change Reports, page 7-17

• Understanding Activities, page 7-2

• Working with Activities, page 7-9
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Field Reference

Activity Required (Create Activity) Dialog Box 
When in Workflow mode, creating or modifying policies requires that an activity 
be open.

Navigation Path

If you attempt to create or modify policies without first creating an activity, the 
Activity Required (Create Activity) Dialog Box appears.

Related Topics

• Creating an Activity, page 7-11

• Activity States, page E-4

Table E-12 Activity Report PDF

Element Description

Bookmarks tab Use the PDF bookmarks structure to navigate the report.

Activity name Name of the activity (or the user and session start date and time if unnamed).

Created by User and start date and time of activity.

Current state Current state of activity.

Report created 
on

Date and time Activity Report generated.

Devices Devices names acted upon (added, modified, deleted) within this activity. Changes to 
local policies only will be listed here.

Shared Policies Changes to all shared policies displayed here.

Policy Objects Changes to all policy objects displayed here.
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Field Reference

Activity Required (Create or Open Activity) Dialog 
Box

In Workflow mode, creating or modifying policies requires that an activity be 
open. 

Navigation Path

If you attempt to create or modify policies without first creating or opening an 
activity, the Activity Required (Create or Open Activity) Dialog Box appears.

Related Topics

• Creating an Activity, page 7-11

• Opening an Activity, page 7-12

• Activity States, page E-4

Table E-13 Activity Required (Create Activity) Dialog Box

Element Description

Activity Name Name of the activity. The default activity name contains the username, date, and time 
the activity was created.

Comment Brief description of the changes included in the activity or other pertinent 
information.

OK button Saves your changes and closes the dialog box. 

Cancel button Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.
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Field Reference

Openable Activities Dialog Box
In Workflow mode, creating or modifying policies requires that an activity be 
open.

Navigation Path

Click the Open Activity button on the Main toolbar.

Related Topics

• Opening an Activity, page 7-12

Table E-14 Activity Required (Create or Open Activity) Dialog Box

Element Description

Create a new 
activity

Creates a new activity with the following information:

• Name—Name of the activity. The default activity name contains the username, 
date, and time the activity was created.

• Description—Brief description of the changes in the activity or other pertinent 
information.

Open an 
existing 
activity

Opens the activity selected from the Activity list (if there are activities available in 
the Edit state).

OK button Saves your changes and closes the dialog box. 

Cancel button Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.
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Field Reference

Table E-15 Openable Activities Dialog Box

Element Description

Activity Name Name of the activity. The default activity name includes the username, date, and time 
the activity is created.

State State of the activity. For a list of valid states, see Table E-2.

Creator Username of the person who created the activity.

OK button Saves your changes and closes the dialog box. 

Cancel button Closes the dialog box without saving your changes.

Help button Opens help for this dialog box.
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